About ImageDraw

Neodynamic ImageDraw SDK for .NET
What is Neodynamic ImageDraw SDK for .NET?
Neodynamic ImageDraw SDK for .NET is the definitive solution for professional imaging tasks, exclusively designed for .NET developers. ImageDraw is a lightweight royalty-free .NET component (.NET DLL Class Library a.k.a. assembly) which lets you to easily add advanced Imaging Effects and Dynamic Image Composition to any .NET Framework-based applications. ImageDraw allows you to dynamically create composite images (Supporting image files, Texts like captions and watermarks, WordArt as well as AutoShapes (lines and arrows, rectangles, ovals, polygons, stars, etc)) with lots of useful built-in Imaging Effects like drop shadows, reflections, perspective views, Polaroid, filmstrip, scaling, resizing, skewing, and so on.

Features
  • Dynamic image composition supporting Images/Photos/Pictures, Texts, Rich Text, WordArt and Autoshapes like lines, arrows, rectangles, rounded rectangles, polygons, stars, ovals, and so on.
  • Accepts as image sources the following formats: GIF, JPG/JPEG, BMP, TIFF, ICO, WMF, EMF and PNG.
  • Generated composite images on-fly in formats such as GIF, JPG/JPEG, BMP, Wireless Bitmap (WBMP), and PNG.
  • Can render GDI+ bitmap objects to the specified image format.
  • High Quality Resolution for output composite images supporting DPI setting.
  • Support for handling Multipage TIFF files.
  • Renders images served by WebServices.
  • Lots of useful Imaging Effects out of the box, including: Adjust Brightness, Contrast, Gamma, Hue, Saturation, Opacity, HSL; Convert To Grayscale, Negative, Sepia, Black & White; Crop, Drop REAL Shadow, Flip, Make Transparent, Perspective Shadow, Resize, Scale, Rotate, Round Corners, Silhouette, Stretch, Decorative Border, Glass Table, Mail Stamp, Polaroid, Filmstrip, Skew, Perspective View, Camera view, Gaussian Blur, Distort Corners, Remove Transparency, Perspective Reflection, Red-Eye Removal, Feather, Glow, Fade, BitmapMask, Remove Pixel, Color Substitution, Tint, Emboss, Solarize, Pixelate, Sharpen, Focal Grayscale, Focal Pixelate, Focal Soften, Focal Tint, and Museum Matte Frame.
  • Image Metadata Utility (EXIF support).
  • Visual Studio 2005/2008/2010, Visual Studio Express 2005/2008/2010 Editions and Visual Web Developer Express 2005/2008/2010 support.
  • Intellisense support.
  • No complex configurations.
  • Lightweight royalty-free .NET assemblies for .NET Framework.
  • 64-bit .NET Framework support.
Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Licensing

Neodynamic ImageDraw SDK for .NET
License Registration
When you buy a commercial version of Neodynamic ImageDraw SDK for .NET you are provided with license information to register your licensed copy of Neodynamic ImageDraw SDK for .NET.

The registration process is very simple and can be accomplished in two ways:

  • Codeless License Setting
    Codeless License Setting involves adding the license info in the Application's Configuration file (*.config). The license info must be specified in the ImageDrawSDK30LicenseOwner and ImageDrawSDK30LicenseKey entries in the appSettings section of *.config file. Example:
    <configuration>
  <appSettings>
    <add key="ImageDrawSDK30LicenseOwner" value="LICENSE-OWNER"/>
    <add key="ImageDrawSDK30LicenseKey" value="LICENSE-KEY"/>
  </appSettings>
  ...
</configuration>
  • Using License Properties in code
    In the class you're using ImageDraw, set the LicenseOwner and LicenseKey static (shared in VB) properties with the license info you've received.
    IMPORTANT
    Please, keep in mind that the license info is case-sensitive!

    VB.NET
    ' ASP.NET SAMPLE

Imports Neodynamic.SDK

Partial Class Default
    Inherits System.Web.UI.Page

    Protected Sub Page_Init(ByVal sender As Object, ByVal e As System.EventArgs) Handles Me.Init

         ImageDraw.LicenseOwner = "LICENSE-OWNER"
         ImageDraw.LicenseKey = "LICENSE-KEY"

    End Sub
End Class

    ' WINDOWS FORMS SAMPLE

Imports Neodynamic.SDK

Public Class Form1

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        ImageDraw.LicenseOwner = "LICENSE-OWNER"
        ImageDraw.LicenseKey = "LICENSE-KEY"

    End Sub

End Class

    C#
    // ASP.NET SAMPLE

using Neodynamic.SDK;

public partial class _Default : System.Web.UI.Page
{

       protected void Page_Init(object sender, EventArgs e)
       {
              ImageDraw.LicenseOwner = "LICENSE-OWNER";
              ImageDraw.LicenseKey = "LICENSE-KEY";
       }

}

    // WINDOWS FORMS SAMPLE

using Neodynamic.SDK;

public partial class Form1 : Form
{
    private void Form1_Load(object sender, EventArgs e)
    {
        ImageDraw.LicenseOwner = "LICENSE-OWNER";
        ImageDraw.LicenseKey = "LICENSE-KEY";
    }
}

After you set these properties the red TRIAL legend should disappear from the generated image.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Trial Version

Neodynamic ImageDraw SDK for .NET
Trial Version
The Trial Version of Neodynamic ImageDraw SDK for .NET is fully functional and has no expiry date. The only limitation it has is that a TRIAL legend will appear on the generated image.

When you buy a licensed version of Neodynamic ImageDraw SDK for .NET you will receive license information to register your copy of ImageDraw for ASP.NET. For more information about the registration process view License Registration topic.

Distribution restrictions

If you are using a Trial Version, you should not distribute any of the files provided with it.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageDraw Getting Started

Neodynamic ImageDraw SDK for .NET
ImageDraw Getting Started
In This Section:
  • ImageDraw System Requirements
  • Installation
  • Microsoft Visual Studio 2005/2008/2010 and Visual Studio Express Editions 2005/2008/2010 Configuration

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


System Requirements

Neodynamic ImageDraw SDK for .NET
System Requirements
For developing applications with Neodynamic ImageDraw SDK for .NET, you must have the following system and software specifications:

Microsoft .NET Framework

• Microsoft .NET Framework 2.0 or greater with its latest service pack.
• ImageDraw requires FullTrust permission.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Installation and Configuration

Neodynamic ImageDraw SDK for .NET
Installation and Configuration
Installing Neodynamic ImageDraw SDK for .NET is very simple.
  • Download the latest version from Neodynamic's website.
  • Unzip the downloaded file onto your hard drive and launch the installation program double-clicking on it.
  • Follow the on-screen instructions.
Development Tools Configuration
Learn about how to configure ImageDraw with most popular .NET Development Tools.
  • How to configure ImageDraw in Microsoft Visual Studio or Visual Studio Express Editions...

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Visual Studio and Visual Studio Express Editions Configuration

Neodynamic ImageDraw SDK for .NET
Microsoft Visual Studio and Visual Studio Express Editions Configuration
  • Launch Visual Studio or Visual Studio Express Edition.
  • Create a new .NET project. For example, a Windows Forms Application or an ASP.NET Web Application project.
  • Add a reference to Neodynamic.SDK.ImageDraw.dll assembly (Project > Add Reference... OR Website > Add Reference...).
  • Select .NET tab. You should find the Neodynamic.SDK.ImageDraw assembly listed.
    If you cannot find it...

    • Select Browse tab, and navigate to the folder you installed it to.
    • Browse to the Redistributable folder, and select the folder that matches the version of .NET Framework you are using.
    • Select Neodynamic.SDK.ImageDraw.dll from that dialog.
    • Click on OK button.
    Click on ImageDraw assembly to select it, then click on OK.
  • The ImageDraw assembly should now appear referenced to your project. You can now use ImageDraw classes in your code.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageDraw Basics

Neodynamic ImageDraw SDK for .NET
ImageDraw Basics
To get starting with ImageDraw, it would be helpful for you to understand general concepts such as how images are composed for ImageDraw objects and what each built-in Imaging Effect does.

This chapter contains the following topics:
  • ImageDraw Basic Object Model
  • What is Canvas?
  • What are Image and Text Elements?

    • Image Elements
    • Text Elements
    • Rich Text Elements
    • WordArt Elements
    • Shape Elements (AutoShapes)
  • What are Actions (Imaging Effects)?
  • Image Formats Overview
  • Saving and Getting the Output Composite Image
  • Misc Notes

    • Transparent Fills
  • Deploying ImageDraw Assembly

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageDraw controls – Basic Object Model & ASP.NET HTML Syntax

Neodynamic ImageDraw for ASP.NET
ImageDraw controls - Basic Object Model
ImageDraw object features the Object Model which is shown in the following diagram:

ImageDraw Controls – Basic Object Model

You should find the object model fairly self-explanatory and full documentation of all of the methods and properties of each control and its objects are provided in the Class Reference section of this help. However, here is a short explanation of the objects on the previous diagram:
  • ImageDraw
    It's an ImageDraw object for image composition – ImageDraw.

  • Canvas
    It is a rectangular area intended for drawing Graphical Elements (Image, Text, and Shape Elements). Canvas plays a key role in the ImageDraw architecture because it governs and determines the final size for the output image to be generated. Learn more about Canvas...

  • Elements
    They are simple graphical objects which are assembled together to create a composite image. All elements are drawn on the Canvas in the order that each of them has in the stack of elements. There are three main kinds of elements: ImageElement, TextElement, RichTextElement, WordArtElement and ShapeElement (Lines, Rectangles, Ovals, Polygons, Stars, etc.). Learn more about Elements...

  • Actions
    Actions are imaging effects that are applied on Element objects. ImageDraw comes with 50 built-in ready to use Actions. Actions can also be applied onto the output image generated by the elements on the canvas as the last step in the output image generation process. Learn more about Actions...

Visit Neodynamic's website.
Neodynamic ImageDraw for ASP.NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Canvas

Neodynamic ImageDraw SDK for .NET
Canvas
Canvas is a rectangular area intended for drawing Graphical Elements (Image, Text, WordArt and Shape Elements). Canvas plays a key role in the ImageDraw architecture because it governs and determines the final size for the output image to be generated. Canvas is represented by Neodynamic.SDK.Canvas class.
The main features and properties of Canvas are the following:
  • Width and Height
    Set these properties to adjust the final size of the output image. The values are expressed in pixel.
  • AutoSize
    When this feature is enabled (it has been set to True), canvas will expand or contract to the size of the contents represented by all Elements, if any. Notice that enabling this feature will lock the Width and Height properties.

    Example: In the following hypothetical case, canvas is transparent and has an ImageElement and a TextElement.

    AutoSize feature is not enabled.

    AutoSize feature is enabled.
  • Center Elements
    When this feature is enabled (it has been set to True), all Elements on the canvas, if any, will be centered.

    Example: In the following hypothetical case, canvas is transparent and has an ImageElement and a TextElement.

    Center Elements and AutoSize are disabled.

    Both features Center Elements and AutoSize are enabled.
  • Fill
    It determines how the filling in the canvas is rendered. There are four Fill Styles available – Solid, Texture, Gradient, and Pattern. Fill is represented by Neodynamic.SDK.Fill class.
Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Elements

Neodynamic ImageDraw SDK for .NET
ImageDraw Elements
Elements are simple graphical objects which are assembled together to create a composite image. All elements are drawn on the Canvas in the order that each of them has in the stack of elements. An element with greater stack order is always drawn in front of another element with lower stack order. In addition, each element can have associated to it zero or more imaging effects a.k.a. Actions that affect its appearance.
Element objects are managed by the Elements property of ImageDraw class.

There are three main kinds of elements:
  • ImageElement
  • TextElement
  • RichTextElement
  • WordArtElement
  • ShapeElement

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageElement

'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.File
'Set an Absolute URL

imgElem.SourceFile = "http://www.domain.com/imageSample.jpg"

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.File;
//Set an Absolute URL
imgElem.SourceFile = "http://www.domain.com/imageSample.jpg";

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:ImageElement Source="File" SourceFile="http://www.domain.com/imageSample.jpg"></neoimg:ImageElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.File
'Set a Relative URL

imgElem.SourceFile = "~/images/imageSample.jpg"

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.File;
//Set a Relative URL
imgElem.SourceFile = "~/images/imageSample.jpg";

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:ImageElement Source="File" SourceFile="~/images/imageSample.jpg"></neoimg:ImageElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.File
'Set a path file

imgElem.SourceFile = "C:\Projects\Images\imageSample.jpg"

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.File;
//Set a path file
imgElem.SourceFile = @"C:\Projects\Images\imageSample.jpg";

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:ImageElement Source="File" SourceFile="C:\Projects\Images\imageSample.jpg"></neoimg:ImageElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.Base64String
'Set the Base64 string representing the binary content of the image

imgElem.SourceBase64 = "THE BASE64 STRING HERE..."

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.Base64String;
//Set the Base64 string representing the binary content of the image
imgElem.SourceBase64 = "THE BASE64 STRING HERE...";

'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.Binary
'Set the binary content of the image

imgElem.SourceBinary = ...Byte Array

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.Binary;
//Set the binary content of the image
imgElem.SourceBinary = ...Byte Array;

'Create an instance of ImageElement class

Dim imgElem As New Neodynamic.SDK.ImageElement
'Set the source property

imgElem.Source = Neodynamic.SDK.ImageSource.Image
'Set the source image object

imgElem.SourceImage = New System.Drawing.Bitmap(100, 50)

//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = new Neodynamic.SDK.ImageElement();
//Set the source property
imgElem.Source = Neodynamic.SDK.ImageSource.Image;
//Set the source image object
imgElem.SourceImage = new System.Drawing.Bitmap(100, 50);

'Create an instance of ImageElement class using Shared method

Dim imgElem As Neodynamic.SDK.ImageElement = Neodynamic.SDK.ImageElement.FromUrl("http://www.domain.com/imageSample.jpg")

//Create an instance of ImageElement class using static method
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("http://www.domain.com/imageSample.jpg");

'Create an instance of ImageElement class using Shared method

Dim imgElem As Neodynamic.SDK.ImageElement = Neodynamic.SDK.ImageElement.FromFile("C:\Projects\Images\imageSample.jpg")

//Create an instance of ImageElement class using static method
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromFile("C:\Projects\Images\imageSample.jpg");
'Create an instance of ImageElement class using Shared method

Dim imgElem As Neodynamic.SDK.ImageElement = Neodynamic.SDK.ImageElement.FromBase64("THE BASE64 STRING HERE...")

//Create an instance of ImageElement class using static method
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromBase64("THE BASE64 STRING HERE...");

'Create an instance of ImageElement class using Shared method

Dim imgElem As Neodynamic.SDK.ImageElement = Neodynamic.SDK.ImageElement.FromImage(Byte Array)

//Create an instance of ImageElement class using static method
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromBinary(Byte Array);

'Create an instance of ImageElement class using Shared method

Dim imgElem As Neodynamic.SDK.ImageElement = Neodynamic.SDK.ImageElement.FromImage(New System.Drawing.Bitmap(100, 50))

//Create an instance of ImageElement class using static method
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromImage(new System.Drawing.Bitmap(100, 50));
Neodynamic ImageDraw SDK for .NET
ImageElement
An ImageElement – represented by Neodynamic.SDK.ImageElement class – simply wraps an image or picture that must be drawn on the Canvas.
    In This Section

  • Image Formats that can be wrapped by ImageElement objects
  • ImageElement sources
    • From URL or file path
    • From Base64 string
    • From Byte Array
    • From GDI+ Image Object
  • Static (Shared) methods of ImageElement class
  • Applying Actions (Imaging Effects) on ImageElement objects

Image Formats that can be wrapped by ImageElement objects
The ImageElement object can wrap and manage the following image formats:
  • PNG, or Portable Network Graphic, is a versatile web graphic format that can support up to 32-bit color, contain transparency or an alpha channel.
  • GIF, or Graphics Interchange Format, is a popular web graphic format for cartoons, logos, and graphics with transparent areas. GIFs contain a maximum of 256 colors.
  • JPG/JPEG was developed by the Joint Photographic Experts Group specifically for photographic or high-color images. The JPEG format is best for digital or scanned photographs, images using textures, images with gradient color transitions, and any images that require more than 256 colors.
  • BMP or Bit Mapped format is used internally in the Microsoft Windows operating system to handle graphics images. These files are typically not compressed resulting in large files.
  • TIFF or Tagged Image File Format, is a flexible image format that normally uses a filename extension of TIFF or TIF
  • WMF or Windows Metafile, is a graphics file format on Microsoft Windows systems. WMF file stores a list of function calls that have to be issued to the Windows graphics layer GDI in order to restore the image.
  • EMF or Enhanced Metafile, is a newer 32-bit version of WMF with additional commands.
  • ICO file format is an image file format used for icons in Microsoft Windows.

ImageElement sources
The image or picture -wrapped by ImageElement objects- can be acquired from several sources such as a URL or path file, Base64 string, byte array, or System.Drawing.Image object. The following points describe in details each source and their settings.
  • URL or path file
    An ImageElement will be created by acquiring the image or picture from the specified URL (Absolute or Relative) or path file. Please, see the sidebar "How to specify Relative URL Image paths"...
    Note
    This image source is the only supported by ImageDraw Visual Editor.

    Syntax samples:

    Absolute URL

    Relative URL

    Path file

  • Base64 string
    An ImageElement will be created by acquiring the image or picture from the specified Base64 string. This kind of sources can be found when dealing with XML documents or WebServices - because binary data is Base64 encoded in those scenarios.

    Syntax samples:

  • Byte Array – Binary content
    An ImageElement will be created by acquiring the image or picture from the specified byte array. The most common scenario for this kind of sources is found when dealing with images stored in a BLOB (Binary Large Object) field of SQL Server database tables.

    Syntax samples:

  • GDI+ Image Object
    An ImageElement will be created by acquiring the image or picture from the specified System.Drawing.Image object.

    Syntax samples:

Static (Shared) methods of ImageElement class
The Neodynamic.SDK.ImageElement class features five useful static (shared) methods for creating ImageElement objects depending of the source type.
  • For Absolute or Relative URL

  • For path file

  • For Base64 string

  • For Byte Array – Binary content

  • For GDI+ Image Object

Applying Actions (Imaging Effects) on ImageElement objects
Most time, ImageElement objects will require some "retouching" such as resizing, scaling, FX effects and so on. An ImageElement can be "affected" by more than one Action because ImageElement objects feature an Actions property of type Neodynamic.SDK.ActionCollection.

Learn more about Actions...

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


TextElement

'Create an instance of TextElement class

Dim txtElem As New Neodynamic.SDK.TextElement
'Set Font properties

txtElem.Font.Name = "Arial"
txtElem.Font.Size = 36
'Set color for text

txtElem.ForeColor = System.Drawing.Color.Crimson
'Set stroke

txtElem.StrokeWidth = 4
txtElem.StrokeColor = System.Drawing.Color.Gold
'Set the text to show

txtElem.Text = "Watermark"

//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
//Set Font properties
txtElem.Font.Name = "Arial";
txtElem.Font.Size = 36.0f;
//Set color for text
txtElem.ForeColor = System.Drawing.Color.Crimson;
//Set stroke
txtElem.StrokeWidth = 4;
txtElem.StrokeColor = System.Drawing.Color.Gold;
//Set the text to show
txtElem.Text = "Watermark";

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:TextElement Font-Size="36" ForeColor="Crimson" StrokeColor="Gold" StrokeWidth="4" Text="Watermark"
            TextAlignment="MiddleCenter">
        </neoimg:TextElement>
    </Elements>
</neoimg:ImageDraw>
Neodynamic ImageDraw SDK for .NET
TextElement
A TextElement – represented by Neodynamic.SDK.TextElement class – simply wraps a text string that must be drawn on the Canvas. TextElement objects are created by specifying some basic properties such as Text, Font, ForeColor, StrokeColor, etc.
    In This Section

  • Text Features
  • Font Features
  • Applying Actions (Imaging Effects) on ImageElement objects

Text Features
The main features and properties of TextElement objects are the following:
  • AutoSize
    When this feature is enabled (it has been set to True), then the TextElement object is automatically resized to display its entire contents.
  • Multi-line Text
    When this feature is enabled (Multiline property has been set to True), then the text can span more than one line.
  • Outlined Text
    TextElement objects support outlined text by setting up the width of the border along the outline of the text through out StrokeWidth property. In addition, you can specify the color of the border by setting up the StrokeColor property.
  • Text Color
    The ForeColor property of TextElement objects is used for specifying the foreground color of the text and StrokeColor property is used for specifying the color of the border along the outline of the text if StrokeWidth property is greater than zero.
  • Text Alignment
    If AutoSize property is disabled, then the text can be aligned inside the TextElement's bound which is determined by its X, Y, Width and Height properties. The text can be left-aligned, center-aligned, or right-aligned in both vertical and horizontal directions.

Syntax sample:

TextElement Output Sample:

TextElement Output Sample

Font Features
TextElement objects support rich font formatting allowing you to use server's installed fonts as well as custom font files (*.ttf) that are stored in your website folders. In addition, you can configure the text font so it's bold, italic, underline, etc; as well as the size and unit of measure (Point, Inch, Millimeter, or Pixel). Learn more about Font settings.
Applying Actions (Imaging Effects) on TextElement objects

TextElement are useful for drawing custom captions and watermarks; and as just for ImageElement objects, TextElement objects can be "affected" by more than one Action due to they feature an Actions property of type Neodynamic.SDK.ActionCollection.

Learn more about Actions.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


RichTextElement

'Create an instance of RichTextElement class
Dim rtxtElem As New Neodynamic.SDK.ImageDraw.RichTextElement
'Create TextSpan objects...
Dim ts1 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts1.FontName = "Arial"
ts1.FontSize = 14
ts1.Text = "Rich Text combines "

Dim ts2 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts2.FontName = "Tahoma"
ts2.FontSize = 14
ts2.Text = "font "

Dim ts3 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts3.FontName = "Broadway"
ts3.FontSize = 14
ts3.Text = "types and "

Dim ts4 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts4.FontName = "Arial"
ts4.FontSize = 20
ts4.Text = "sizes, new lines<br/>"

Dim ts5 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts5.FontName = "Arial"
ts5.FontSize = 14
ts5.Text = "styles like "

Dim ts6 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts6.FontName = "Arial"
ts6.FontSize = 14
ts6.FontBold = true
ts6.Text = " BOLD and "

Dim ts7 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts7.FontName = "Arial"
ts7.FontSize = 14
ts7.FontItalic = true
ts7.Text = "italic, "

Dim ts8 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts8.FontName = "Arial"
ts8.FontSize = 14
ts8.BackColor = System.Drawing.Color.Yellow
ts8.Text = "background"

Dim ts9 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts9.FontName = "Arial"
ts9.FontSize = 14
ts9.ForeColor = System.Drawing.Color.Blue
ts9.Text = " and foreground colors<br/>"

Dim ts10 As New Neodynamic.SDK.ImageDraw.TextSpan()
ts10.FontName = "Arial"
ts10.FontSize = 14
ts10.Kerning = 5
ts10.Text = "and letter spacing (kerning)"

'Set RicText property
rtxtElem.RichText = ts1.ToString() + ts2.ToString() + ts3.ToString() + _
                    ts4.ToString() + ts5.ToString() + ts6.ToString() + _
                    ts7.ToString() + ts8.ToString() + ts9.ToString() + _
                    ts10.ToString()

//Create an instance of RichTextElement class
Neodynamic.SDK.ImageDraw.RichTextElement rtxtElem = new Neodynamic.SDK.ImageDraw.RichTextElement();

//Create TextSpan objects...
Neodynamic.SDK.ImageDraw.TextSpan ts1 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts1.FontName = "Arial";
ts1.FontSize = 14;
ts1.Text = "Rich Text combines ";

Neodynamic.SDK.ImageDraw.TextSpan ts2 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts2.FontName = "Tahoma";
ts2.FontSize = 14;
ts2.Text = "font ";

Neodynamic.SDK.ImageDraw.TextSpan ts3 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts3.FontName = "Broadway";
ts3.FontSize = 14;
ts3.Text = "types and ";

Neodynamic.SDK.ImageDraw.TextSpan ts4 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts4.FontName = "Arial";
ts4.FontSize = 20;
ts4.Text = "sizes, new lines<br/>";

Neodynamic.SDK.ImageDraw.TextSpan ts5 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts5.FontName = "Arial";
ts5.FontSize = 14;
ts5.Text = "styles like ";

Neodynamic.SDK.ImageDraw.TextSpan ts6 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts6.FontName = "Arial";
ts6.FontSize = 14;
ts6.FontBold = true;
ts6.Text = " BOLD and ";

Neodynamic.SDK.ImageDraw.TextSpan ts7 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts7.FontName = "Arial";
ts7.FontSize = 14;
ts7.FontItalic = true;
ts7.Text = "italic, ";

Neodynamic.SDK.ImageDraw.TextSpan ts8 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts8.FontName = "Arial";
ts8.FontSize = 14;
ts8.BackColor = System.Drawing.Color.Yellow;
ts8.Text = "background";

Neodynamic.SDK.ImageDraw.TextSpan ts9 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts9.FontName = "Arial";
ts9.FontSize = 14;
ts9.ForeColor = System.Drawing.Color.Blue;
ts9.Text = " and foreground colors<br/>";

Neodynamic.SDK.ImageDraw.TextSpan ts10 = new Neodynamic.SDK.ImageDraw.TextSpan();
ts10.FontName = "Arial";
ts10.FontSize = 14;
ts10.Kerning = 5;
ts10.Text = "and letter spacing (kerning)";

//Set RichText property
rtxtElem.RichText = ts1.ToString() + ts2.ToString() + ts3.ToString() +
                    ts4.ToString() + ts5.ToString() + ts6.ToString() +
                    ts7.ToString() + ts8.ToString() + ts9.ToString() +
                    ts10.ToString();
Neodynamic ImageDraw SDK for .NET
RichTextElement
A RichTextElement – represented by Neodynamic.SDK.ImageDraw.RichTextElement class – lets you to render rich text by mixing words in different fonts, sizes, capitalizations, foreground colors, etc.
    In This Section

  • RichText Features
  • Applying Actions (Imaging Effects) on ImageElement objects

Rich Text Features
The RichTextElement class features a property named RichText which must be set up with a string containing the ImageDraw rich text markup. ImageDraw rich text markup is composed of TextSpan objects. A TextSpan object is used to indicate a text inline container within the whole rich text content.

The TextSpan object features the following markup:

<TextSpan FontName=""
 FontUnit=""
 FontSize=""
 FontBold=""
 FontItalic=""
 FontUnderline=""
 FontStrikeout=""
 CustomFontFile=""
 CustomFontFileFamilyIndex=""
 ForeColor=""
 BackColor=""
 BaselineOffset=""
 Kerning=""
 Text="" />

Description of each attributes/properties of the TextSpan object:
  • FontName
    It specifies the font face name. It must be one of the fonts' name registered in Windows OS. Default value is Arial.
  • FontUnit
    It specifies the unit of measure for the font. It must be a value of System.Drawing.GraphicsUnit enumeration. Default value is Point.
  • FontSize
    It specifies the size of the font. Default value is 8
  • FontBold
    It specifies whether the font is bold. Default value is False.
  • FontItalic
    It specifies whether the font is italic. Default value is False.
  • FontUnderline
    It specifies whether the font is underlined. Default value is False.
  • FontStrikeout
    It specifies whether the font draws a horizontal line through the text. Default value is False.
  • CustomFontFile
    It specifies the custom font file (*.TTF). It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file. Default value is an empty string meaning that no custom font will be used.
  • CustomFontFileFamilyIndex
    It specifies the Font Family index of the typefaces defined by the specified Custom Font File. Default value is 0 (zero)
  • ForeColor
    It specified the foreground color. Default value is Black.
  • BackColor
    It specifies the background color. Default value is Transparent.
  • BaselineOffset
    It specifies a vertical offset value for the baseline of the TextSpan. Default value is 0 (zero)
  • Kerning
    It specifies the spacing between the letters contained in the TextSpan. Default value is 0 (zero)
  • Text
    It specifies the text to be rendered by the TextSpan. Default value is an empty string. NOTE: for new line breaks you must use <BR/> inside the content of this property.

Syntax sample:

TextElement Output Sample:

RichTextElement Output Sample

Applying Actions (Imaging Effects) on RichTextElement objects

RichTextElement can be "affected" by more than one Action due to it features an Actions property of type Neodynamic.SDK.ImageDraw.ActionCollection.

Learn more about Actions.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2010 Neodynamic - All rights reserved.


ShapeElement (Lines, Rectangles, Ovals, Polygons, Stars)

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:RectangleShapeElement Fill-GradientAngle="90" Fill-GradientColor2="GreenYellow"
            Fill-Type="Gradient" Height="100" StrokeFill-BackgroundColor="Black" StrokeWidth="3" Width="200">
        </neoimg:RectangleShapeElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of RectangleShapeElement class
Dim rectElem As New Neodynamic.SDK.RectangleShapeElement()
'Set rectangle size
rectElem.Width = 200
rectElem.Height = 100
'Set Fill to linear gradient
rectElem.Fill.Type = Neodynamic.SDK.FillType.Gradient
rectElem.Fill.GradientAngle = 90
rectElem.Fill.GradientColor1 = System.Drawing.Color.White
rectElem.Fill.GradientColor2 = System.Drawing.Color.GreenYellow
'Set Stroke
rectElem.StrokeWidth = 3
//Create an instance of RectangleShapeElement class
Neodynamic.SDK.RectangleShapeElement rectElem = new Neodynamic.SDK.RectangleShapeElement();
//Set rectangle size
rectElem.Width = 200;
rectElem.Height = 100;
//Set Fill to linear gradient
rectElem.Fill.Type = Neodynamic.SDK.FillType.Gradient;
rectElem.Fill.GradientAngle = 90;
rectElem.Fill.GradientColor1 = System.Drawing.Color.White;
rectElem.Fill.GradientColor2 = System.Drawing.Color.GreenYellow;
//Set Stroke
rectElem.StrokeWidth = 3;
<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:OvalShapeElement Fill-GradientAngle="90" Fill-GradientColor2="GreenYellow"
            Fill-Type="Gradient" Height="100" StrokeFill-BackgroundColor="Black" StrokeWidth="3" Width="200">
        </neoimg:OvalShapeElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of OvalShapeElement class
Dim ovalElem As New Neodynamic.SDK.OvalShapeElement()
'Set oval size
ovalElem.Width = 200
ovalElem.Height = 100
'Set Fill to linear gradient
ovalElem.Fill.Type = Neodynamic.SDK.FillType.Gradient
ovalElem.Fill.GradientAngle = 90
ovalElem.Fill.GradientColor1 = System.Drawing.Color.White
ovalElem.Fill.GradientColor2 = System.Drawing.Color.GreenYellow
'Set Stroke
ovalElem.StrokeWidth = 3
//Create an instance of OvalShapeElement class
Neodynamic.SDK.OvalShapeElement ovalElem = new Neodynamic.SDK.OvalShapeElement();
//Set oval size
ovalElem.Width = 200;
ovalElem.Height = 100;
//Set Fill to linear gradient
ovalElem.Fill.Type = Neodynamic.SDK.FillType.Gradient;
ovalElem.Fill.GradientAngle = 90;
ovalElem.Fill.GradientColor1 = System.Drawing.Color.White;
ovalElem.Fill.GradientColor2 = System.Drawing.Color.GreenYellow;
//Set Stroke
ovalElem.StrokeWidth = 3;
<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:LineShapeElement EndLineCap="Circle" EndLineCapWidth="8" Height="100"
              StartLineCap="Arrow" StartLineCapWidth="8" StrokeFill-BackgroundColor="Black" StrokeWidth="3" Width="150">
         </neoimg:LineShapeElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of LineShapeElement class
Dim lineElem As New Neodynamic.SDK.LineShapeElement()
'Set line size
lineElem.Width = 150
lineElem.Height = 100
'Set Stroke
lineElem.StrokeWidth = 3
'Set Cap Styles
lineElem.StartLineCap = Neodynamic.SDK.LineCapStyle.Arrow
lineElem.StartLineCapWidth = 8
lineElem.EndLineCap = Neodynamic.SDK.LineCapStyle.Circle
lineElem.EndLineCapWidth = 8
//Create an instance of LineShapeElement class
Neodynamic.SDK.LineShapeElement lineElem = new Neodynamic.SDK.LineShapeElement();
//Set line size
lineElem.Width = 150;
lineElem.Height = 100;
//Set Stroke
lineElem.StrokeWidth = 3;
//Set Cap Styles
lineElem.StartLineCap = Neodynamic.SDK.LineCapStyle.Arrow;
lineElem.StartLineCapWidth = 8;
lineElem.EndLineCap = Neodynamic.SDK.LineCapStyle.Circle;
lineElem.EndLineCapWidth = 8;
<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:PolygonShapeElement Fill-BackgroundColor="198, 217, 240" Sides="5"
                StrokeFill-BackgroundColor="36, 64, 97" StrokeWidth="3" Width="150" Height="130">
        </neoimg:PolygonShapeElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of PolygonShapeElement class
Dim polyElem As New Neodynamic.SDK.PolygonShapeElement()
'Create a pentagon
polyElem.Sides = 5
'Set polygon size
polyElem.Width = 150
polyElem.Height = 130
'Set Fill
polyElem.Fill.Type = Neodynamic.SDK.FillType.Solid
polyElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(198, 217, 240)
'Set Stroke
polyElem.StrokeWidth = 3
polyElem.Fill.Type = Neodynamic.SDK.FillType.Solid
polyElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(36, 64, 97)
//Create an instance of PolygonShapeElement class
Neodynamic.SDK.PolygonShapeElement polyElem = new Neodynamic.SDK.PolygonShapeElement();
//Create a pentagon
polyElem.Sides = 5;
//Set polygon size
polyElem.Width = 150;
polyElem.Height = 130;
//Set Fill
polyElem.Fill.Type = Neodynamic.SDK.FillType.Solid;
polyElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(198, 217, 240);
//Set Stroke
polyElem.StrokeWidth = 3;
polyElem.Fill.Type = Neodynamic.SDK.FillType.Solid;
polyElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(36, 64, 97);
<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:StarShapeElement Fill-BackgroundColor="204, 193, 217" Points="10"
                   StrokeFill-BackgroundColor="112, 48, 160" StrokeWidth="3" Width="150" Height="150">
        </neoimg:StarShapeElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of StarShapeElement class
Dim starElem As New Neodynamic.SDK.StarShapeElement()
'Create a 10-Points Star
starElem.Points = 10
'Set star size
starElem.Width = 150
starElem.Height = 150
'Set Fill
starElem.Fill.Type = Neodynamic.SDK.FillType.Solid
starElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(204, 193, 217)
'Set Stroke
starElem.StrokeWidth = 3
starElem.Fill.Type = Neodynamic.SDK.FillType.Solid
starElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(112, 48, 160)
//Create an instance of StarShapeElement class
Neodynamic.SDK.StarShapeElement starElem = new Neodynamic.SDK.StarShapeElement();
//Create a 10-Points Star
starElem.Points = 10;
//Set star size
starElem.Width = 150;
starElem.Height = 150;
//Set Fill
starElem.Fill.Type = Neodynamic.SDK.FillType.Solid;
starElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(204, 193, 217);
//Set Stroke
starElem.StrokeWidth = 3;
starElem.Fill.Type = Neodynamic.SDK.FillType.Solid;
starElem.Fill.BackgroundColor = System.Drawing.Color.FromArgb(112, 48, 160);
Neodynamic ImageDraw SDK for .NET
ShapeElement (Lines, Rectangles, Ovals, Polygons, Stars)
ImageDraw supports AutoShapes which are preset shapes like rectangles, ovals, lines, arrows, stars, and polygons that can be drawn on the Canvas. In addition, AutoShapes supports imaging effects (a.k.a. Actions), text inside them by allowing padding text feature, border roundness and dashed patterns.
    In This Section

  • AutoShapes common features
  • Supported AutoShapes
    • Rectangles
    • Ovals
    • Lines & Arrows
    • Polygons
    • Stars
  • Applying Actions (Imaging Effects) on AutoShapes objects

AutoShapes common features
All AutoShapes support the following features:
  • Rich Text Support
    AutoShapes can display text inside them and they support the same rich text features available when working with TextElement objects i.e. multi-line text, outlined text, and text alignment.
  • Rich Fill Support
    AutoShapes can be filled out with solid colors, texture images, linear gradients, and built-in patterns. The same is applied for shape's border.
  • Roundness
    AutoShapes support roundness that allows you to make them rounded shapes. For example, by setting up the Roundness property of a Rectangle shape, then you will get a rounded rectangle. By setting up the Roundness property of a Star shape, then you can get a burst (those rounded star shaped ovals often seen in advertising).
  • Border Style Support
    AutoShapes support setting up the line style of the border shape to a dashed pattern.

Supported AutoShapes
  • Rectangles
  • Ovals
  • Lines & Arrows
  • Polygons
  • Stars

Rectangles
A Rectangle Element – represented by Neodynamic.SDK.RectangleShapeElement class – lets you draw rectangle shapes on the Canvas. RectangleShapeElement objects are created by specifying some basic properties such as Width, Height, Fill, StrokeFill, etc.

Syntax sample:

RectangleShapeElement Output Sample:

RectangleShapeElement Output Sample

  • By setting up Roundness property to 25, you will get a rounded rectangle:

  • By setting up StrokeDashStyle property to Dash, you will get the following output:

  • By setting up Text property to "My Rectangle", you will get the following output:

Ovals
An Oval Element – represented by Neodynamic.SDK.OvalShapeElement class – lets you draw oval shapes (ellipses and circles included) on the Canvas. OvalShapeElement objects are created by specifying some basic properties such as Width, Height, Fill, StrokeFill, etc.

Syntax sample:

OvalShapeElement Output Sample:

OvalShapeElement Output Sample

  • By setting up StrokeDashStyle property to DashDot, you will get the following output:

  • By setting up Text property to "My Oval", you will get the following output:

Lines & Arrows
A Line Element – represented by Neodynamic.SDK.LineShapeElement class – lets you draw line shapes on the Canvas. LineShapeElement objects are created by specifying some basic properties such as Width, Height, StrokeFill, etc. Line shapes support cap styles for staring and ending line points. By setting up cap styles, you can convert lines into arrows.

Note
Line shapes are drawn within the area defined by Width and Height properties of LineShapeElement class i.e. there's no start and end line points for setting up. LineShapeElement class also feature Orientation property which lets you specify the line orientation to Horizontal (Default), Vertical, DiagonalUp, and DiagonalDown.

Syntax sample:

LineShapeElement Output Sample:

LineShapeElement Output Sample

  • By setting up Orientation property to Vertical, DiagonalUp, and DiagonalDown, you will get the following outputs respectively:

  • By setting up StrokeDashStyle property to Dash, you will get the following output:

  • By setting up Text property to "My Line" and TexPadding-Bottom property to 20, you will get the following output:

Polygons
A Polygon Element – represented by Neodynamic.SDK.PolygonShapeElement class – lets you draw irregular polygon shapes on the Canvas. PolygonShapeElement objects are created by specifying some basic properties such as Sides, Width, Height, Fill, StrokeFill, etc.

Syntax sample:

PolygonShapeElement Output Sample:

PolygonShapeElement Output Sample

  • By setting up Roundness property to 25, you will get a rounded pentagon:

  • By setting up StrokeDashStyle property to Dash, you will get the following output:

  • By setting up Text property to "My Rectangle', you will get the following output:

Stars
A Star Element – represented by Neodynamic.SDK.StarShapeElement class – lets you draw istar shapes and bursts (those rounded star shaped ovals often seen in advertising) on the Canvas. StarShapeElement objects are created by specifying some basic properties such as Points, InnerRadiusPercentage, Width, Height, Fill, StrokeFill, etc.

Syntax sample:

StarShapeElement Output Sample:

StarShapeElement Output Sample

  • By setting up Roundness property to 50, you will get a rounded 10-points star:

  • By setting up StrokeDashStyle property to Dot, you will get the following output:

  • By setting up Text property to "50% Off", you will get the following output:

Applying Actions (Imaging Effects) on AutoShapes objects

As for ImageElement and TextElement objects, all ShapeElement derived-classes - RectangleShapeElement, OvalShapeElement, LineShapeElement, PolygonShapeElement, and StarShapeElement objects - can be "affected" by more than one Action due to they feature an Actions property of type Neodynamic.SDK.ActionCollection.

Learn more about Actions.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


WordArtElement

'Create an instance of WordArtElement class

Dim wordArtElem As New Neodynamic.SDK.WordArtElement
wordArtElem.AutoSize = False
wordArtElem.Font.Name = "Arial Black"
wordArtElem.Font.Size = 20
wordArtElem.ForeFill.GradientColor1 = Color.FromArgb(255, 215, 0)
wordArtElem.ForeFill.GradientColor2 = Color.FromArgb(255, 41, 0)
wordArtElem.ForeFill.Type = Neodynamic.SDK.FillType.Gradient
wordArtElem.Height = 225
wordArtElem.Multiline = True
wordArtElem.StrokeFill.BackgroundColor = Color.FromArgb(0, 0, 0)
wordArtElem.StrokeWidth = 3
wordArtElem.Width = 242
wordArtElem.WordArtShape.Shape = Neodynamic.SDK.WarpShape.CirclePath
wordArtElem.Text = "Word Art Text"

//Create an instance of WordArtElement class
Neodynamic.SDK.WordArtElement wordArtElem = new Neodynamic.SDK.WordArtElement();
wordArtElem.AutoSize = false;
wordArtElem.Font.Name = "Arial Black";
wordArtElem.Font.Size = 20;
wordArtElem.ForeFill.GradientColor1 = Color.FromArgb(255, 215, 0);
wordArtElem.ForeFill.GradientColor2 = Color.FromArgb(255, 41, 0);
wordArtElem.ForeFill.Type = Neodynamic.SDK.FillType.Gradient;
wordArtElem.Height = 225;
wordArtElem.Multiline = true;
wordArtElem.StrokeFill.BackgroundColor = Color.FromArgb(0, 0, 0);
wordArtElem.StrokeWidth = 3;
wordArtElem.Width = 242;
wordArtElem.WordArtShape.Shape = Neodynamic.SDK.WarpShape.CirclePath;
wordArtElem.Text = "Word Art Text";

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:WordArtElement AutoSize="False" Font-Name="Arial Black" Font-Size="20" ForeFill-BackgroundColor="0, 0, 0"
            ForeFill-ForegroundColor="0, 0, 0" ForeFill-GradientColor1="255, 215, 0" ForeFill-GradientColor2="255, 41, 0"
            ForeFill-Type="Gradient" Height="225" Multiline="True" Name="myWordArt" StrokeFill-BackgroundColor="0, 0, 0"
            StrokeFill-ForegroundColor="0, 0, 0" StrokeFill-GradientColor1="255, 255, 255"
            StrokeFill-GradientColor2="0, 0, 0" StrokeWidth="3" Text="Word Art Text" TextAlignment="MiddleCenter"
            Width="242" WordArtShape-Shape="CirclePath">
        </neoimg:WordArtElement>
    </Elements>
</neoimg:ImageDraw>
Neodynamic ImageDraw SDK for .NET
WordArtElement
A WordArtElement – represented by Neodynamic.SDK.WordArtElement class – creates stylized text with special effects differing from ordinary text with the added features of gradient color fills and shaping. WordArtElement objects are created by specifying some basic properties such as Text, Font, ForeFill, StrokeFill, WordArtShape, etc.
    In This Section

  • Text Features
  • Font Features
  • Applying Actions (Imaging Effects) on ImageElement objects

Text Features
The main features and properties of WordArtElement objects are the following:
  • AutoSize
    When this feature is enabled (it has been set to True), then the WordArtElement object is automatically resized to display its entire contents. NOTE: If any WordArtShape is used, then AutoSize property is not enabled.
  • Multi-line Text
    When this feature is enabled (Multiline property has been set to True), then the text can span more than one line.
  • Outlined Text
    WordArtElement objects support outlined text by setting up the width of the border along the outline of the text through out StrokeWidth property. In addition, you can specify the fill of the border by setting up the StrokeFill property.
  • Text Fill
    The ForeFill property of WordArtElement objects is used for specifying the foreground fill of the text and StrokeFill property is used for specifying the fill of the border along the outline of the text if StrokeWidth property is greater than zero. You can create gradient or texture fill for WordArtElement objects
  • Text Alignment
    If AutoSize property is disabled, then the text can be aligned inside the WordArtElement's bound which is determined by its X, Y, Width and Height properties. The text can be left-aligned, center-aligned, or right-aligned in both vertical and horizontal directions.
  • WordArt Shape
    WordArtElement objects can be set up to conform/fit a given shape like Circles, Rectangles, Quadrilaterals with effects like Fade, Cascade, Slant; etc.

Syntax sample:

WordArtElement Output Sample:

WordArtElement Output Sample

Font Features
WordArtElement objects support rich font formatting allowing you to use server's installed fonts as well as custom font files (*.ttf) that are stored in your website folders. In addition, you can configure the text font so it's bold, italic, underline, etc; as well as the size and unit of measure (Point, Inch, Millimeter, or Pixel). Learn more about Font settings.
Applying Actions (Imaging Effects) on WordArtElement objects

WordArtElement are useful for drawing custom captions, signs, watermarks, etc; and as just for ImageElement objects, WordArtElement objects can be "affected" by more than one Action due to they feature an Actions property of type Neodynamic.SDK.ActionCollection.

Learn more about Actions.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Actions (Imaging Effects)

Neodynamic ImageDraw SDK for .NET
Actions (Imaging Effects)
Actions are imaging effects that are applied on an Element object. ImageDraw comes with 50 built-in ready to use Actions. Each Action - with representative illustrations of what it does – is overviewed in the next lines.

Built-in ImageDraw Actions:

  • AdjustBrightness

  • AdjustContrast

  • AdjustGamma

  • AdjustHue

  • AdjustHSL

  • AdjustOpacity

  • AdjustSaturation

  • BitmapMask

  • CameraView

  • ConvertToBlackWhite

  • ConvertToGrayscale

  • ConvertToNegative

  • ConvertToSepia

  • Crop

  • DecorativeBorder

  • DistortCorners

  • DropShadow

  • Emboss

  • Fade

  • Feather

  • Filmstrip

  • Flip

  • FocalGrayscale

  • FocalPixelate

  • FocalSoften

  • FocalTint

  • GaussianBlur

  • GlassTable

  • Glow

  • MailStamp

  • MakeTransparent

  • MuseumMatteFrame

  • PerspectiveReflection

  • PerspectiveShadow

  • PerspectiveView

  • Pixelate

  • Polaroid

  • RedEyeRemoval

  • RemovePixel

  • RemoveTransparency

  • Resize

  • Rotate

  • RoundCorners

  • Scale

  • Sharpen

  • Silhouette

  • Skew

  • Solarize

  • Stretch

  • Tint
Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


AdjustBrightness

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustBrightness class

Dim adjBrightness As New Neodynamic.SDK.AdjustBrightness()
'Set the brightness level

adjBrightness.Level = 60

'Apply the action on the ImageElement

imgElem.Actions.Add(adjBrightness)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustBrightness class
Neodynamic.SDK.AdjustBrightness adjBrightness = new Neodynamic.SDK.AdjustBrightness();
//Set the brightness level
adjBrightness.Level = 60;

//Apply the action on the ImageElement
imgElem.Actions.Add(adjBrightness);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:AdjustBrightness Level="60" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustBrightness
Represented by Neodynamic.SDK.AdjustBrightness class.

This action adjusts the brightness of an Element. Brightness is adjusted by specifying a level value which ranges from -100 (dark) to 100 (light). This action is typically used when correcting images that are too dark or too light.

In the following example we have an ImageElement and a TextElement on the Canvas and an AdjustBrightness action is applied on the ImageElement only.

ImageElement with Brightness Level equal to -60.
ImageElement before the action is applied.
ImageElement with Brightness Level equal to 60.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustContrast

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustContrast class

Dim adjContrast As New Neodynamic.SDK.AdjustContrast()
'Set the contrast level

adjContrast.Level = 60

'Apply the action on the ImageElement

imgElem.Actions.Add(adjContrast)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustContrast class
Neodynamic.SDK.AdjustContrast adjContrast = new Neodynamic.SDK.AdjustContrast();
//Set the contrast level
adjContrast.Level = 60;

//Apply the action on the ImageElement
imgElem.Actions.Add(adjContrast);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
             <neoimg:AdjustContrast Level="60" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustContrast
Represented by Neodynamic.SDK.AdjustContrast class.

This action adjusts the contrast of an Element. Contrast is adjusted by specifying a level value which ranges from -100 (dark) to 100 (light). This action is typically used when correcting images that are too dark or too light.

In the following example we have an ImageElement and a TextElement on the Canvas and an AdjustContrast action is applied on the ImageElement only.

ImageElement with Contrast Level equal to -60.
ImageElement before the action is applied.
ImageElement with Contrast Level equal to 60.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustGamma

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustGamma class

Dim adjGamma As New Neodynamic.SDK.AdjustGamma()
'Set the gamma correction value

adjGamma.Gamma = 70

'Apply the action on the ImageElement

imgElem.Actions.Add(adjGamma)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustGamma class
Neodynamic.SDK.AdjustGamma adjGamma = new Neodynamic.SDK.AdjustGamma();
//Set the gamma correction value
adjGamma.Gamma = 70;

//Apply the action on the ImageElement
imgElem.Actions.Add(adjContrast);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:AdjustGamma Gamma="70" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustGamma
Represented by Neodynamic.SDK.AdjustGamma class.

This action adjusts the Gamma correction value of an Element. Gamma correction is adjusted by specifying a value which ranges from -100 to 100.

In the following example we have an ImageElement and a TextElement on the Canvas and an AdjustGamma action is applied on the ImageElement only.

ImageElement with Gamma Correction equal to -70.
ImageElement before the action is applied.
ImageElement with Gamma Correction equal to 70.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustHue

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustHue class

Dim adjHue As New Neodynamic.SDK.AdjustHue()
'Set the Hue angle

adjHue.Angle = 130

'Apply the action on the ImageElement

imgElem.Actions.Add(adjHue)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustHue class
Neodynamic.SDK.AdjustHue adjHue = new Neodynamic.SDK.AdjustHue();
//Set the Hue angle
adjHue.Angle = 130;

//Apply the action on the ImageElement
imgElem.Actions.Add(adjHue);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:AdjustHue Angle="130" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustHue
Represented by Neodynamic.SDK.AdjustHue class.

This action adjusts the Hue Channel of an Element. Hue Channel is adjusted by specifying an angle value which ranges from -180 to 180 degrees.

In the following example we have an ImageElement and a TextElement on the Canvas and an AdjustHue action is applied on the ImageElement only.

ImageElement with Hue angle equal to -130.
ImageElement before the action is applied.
ImageElement with Hue angle equal to 130.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustHSL

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustHSL class

Dim hsl As New Neodynamic.SDK.AdjustHSL()
hsl.Hue = -50
hsl.Saturation = 20
hsl.Lightness = 50

'Apply the action on the ImageElement

imgElem.Actions.Add(hsl)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustHSL class
Neodynamic.SDK.AdjustHSL hsl = new Neodynamic.SDK.AdjustHSL();
hsl.Hue = -50;
hsl.Saturation = 20;
hsl.Lightness = 50;

//Apply the action on the ImageElement
imgElem.Actions.Add(hsl);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:AdjustHSL Hue="-50" Saturation="20" Lightness="50" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustHSL
Represented by Neodynamic.SDK.AdjustHSL class.

This action adjusts the shade of a color, its hue; the intensity of a color, its saturation; or the lightness of a color of an Element.

In the following example we have an ImageElement on the Canvas and a AdjustHSL action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with AdjustHSL action applied on it. Hue = -50, Saturation = 20, and Lightness = 50.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustOpacity

'...
'Create an instance of ImageElement class

Dim imgElem1 As Neodynamic.SDK.ImageElement
imgElem1 = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

Dim imgElem2 As Neodynamic.SDK.ImageElement
imgElem2 = Neodynamic.SDK.ImageElement.FromUrl("~/images/plane.gif")

'Create an instance of AdjustOpacity class

Dim adjOpacity As New Neodynamic.SDK.AdjustOpacity()
'Set the opacity value

adjOpacity.Opacity = 40

'Apply the action on the second ImageElement

imgElem2.Actions.Add(adjOpacity)

'Add the ImageElement objects to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem1)
Me.ImageDraw1.Elements.Add(imgElem2)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem1 = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

Neodynamic.SDK.ImageElement imgElem2 = Neodynamic.SDK.ImageElement.FromUrl("~/images/plane.gif");

//Create an instance of AdjustOpacity class
Neodynamic.SDK.AdjustOpacity adjOpacity = new Neodynamic.SDK.AdjustOpacity();
//Set the opacity value
adjOpacity.Opacity = 40;

//Apply the action on the second ImageElement
imgElem2.Actions.Add(adjOpacity);

//Add the ImageElement objects to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem1);
this.ImageDraw1.Elements.Add(imgElem2);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
      </neoimg:ImageElement>
      <neoimg:ImageElement Source="File" SourceFile="~/images/plane.gif" X="20" Y="124">
          <Actions>
              <neoimg:AdjustOpacity Opacity="40" />
          </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of TextElement class

Dim txtElem As New Neodynamic.SDK.TextElement
txtElem.Font.Name = "Segoe UI"
txtElem.Font.Size = 20.25F
txtElem.Font.Bold = True
txtElem.ForeColor = System.Drawing.Color.White
txtElem.StrokeColor = System.Drawing.Color.MidnightBlue
txtElem.StrokeWidth = 3
txtElem.Text = "Wonderful Night"
txtElem.X = 5
txtElem.Y = 155

'Create an instance of AdjustOpacity class

Dim adjOpacity As New Neodynamic.SDK.AdjustOpacity()
'Set the opacity value

adjOpacity.Opacity = 50

'Apply the action on the TextElement

txtElem.Actions.Add(adjOpacity)

'Add the Element objects to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
Me.ImageDraw1.Elements.Add(txtElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
txtElem.Font.Name = "Segoe UI";
txtElem.Font.Size = 20.25f;
txtElem.Font.Bold = true;
txtElem.ForeColor = System.Drawing.Color.White;
txtElem.StrokeColor = System.Drawing.Color.MidnightBlue;
txtElem.StrokeWidth = 3;
txtElem.Text = "Wonderful Night";
txtElem.X = 5;
txtElem.Y = 155;

//Create an instance of AdjustOpacity class
Neodynamic.SDK.AdjustOpacity adjOpacity = new Neodynamic.SDK.AdjustOpacity();
//Set the opacity value
adjOpacity.Opacity = 50;

//Apply the action on the TextElement
txtElem.Actions.Add(adjOpacity);

//Add the Element objects to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
this.ImageDraw1.Elements.Add(txtElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
      </neoimg:ImageElement>
      <neoimg:TextElement Font-Bold="True" Font-Name="Segoe UI" Font-Size="20.25" ForeColor="White" StrokeColor="MidnightBlue" StrokeWidth="3" Text="Wonderful Night" X="5" Y="155">
          <Actions>
             <neoimg:AdjustOpacity Opacity="50" />
          </Actions>
      </neoimg:TextElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustOpacity
Represented by Neodynamic.SDK.AdjustOpacity class.

This action adjusts the opacity of an Element. Opacity is adjusted by specifying an opacity level value which ranges from 0 (totally transparent) to 100 (totally opaque). This action is typically used when creating watermarks through either an ImageElement or a TextElement.

Examples

1. In the first example we have two ImageElement objects on the Canvas and an AdjustOpacity action is applied on the last one making it a watermark image effect.

Two ImageElement objects before the action is applied.
The second ImageElement with opacity equal to 40.

Syntax sample

2. In this second example we have an ImageElement and a TextElement on the Canvas and an AdjustOpacity action is applied on the last one making it a text watermark effect.

An ImageElement and a TextElement before the action is applied.
The TextElement with opacity equal to 50.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


AdjustSaturation

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of AdjustSaturation class

Dim adjSaturation As New Neodynamic.SDK.AdjustSaturation()
'Set the saturation level

adjSaturation.Level = 75

'Apply the action on the ImageElement

imgElem.Actions.Add(adjSaturation)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of AdjustSaturation class
Neodynamic.SDK.AdjustSaturation adjSaturation = new Neodynamic.SDK.AdjustSaturation();
//Set the saturation level
adjSaturation.Level = 75;

//Apply the action on the ImageElement
imgElem.Actions.Add(adjSaturation);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:AdjustSaturation Level="75" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
AdjustSaturation
Represented by Neodynamic.SDK.AdjustSaturation class.

This action adjusts the saturation level of an Element. Saturation is adjusted by specifying a level value which ranges from -100 (dark) to 100 (light).

In the following example we have an ImageElement and a TextElement on the Canvas and an AdjustSaturation action is applied on the ImageElement only.

ImageElement with Saturation Level equal to -75.
ImageElement before the action is applied.
ImageElement with Saturation Level equal to 75.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


BitmapMask

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of BitmapMask class

Dim fxBitmapMask As New Neodynamic.SDK.BitmapMask()
fxBitmapMask.MaskFile = "~/images/mask.png"

'Apply the action on the ImageElement

imgElem.Actions.Add(fxBitmapMask)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of BitmapMask class
Neodynamic.SDK.BitmapMask fxBitmapMask = new Neodynamic.SDK.BitmapMask();
fxBitmapMask.MaskFile = "~/images/mask.png";

//Apply the action on the ImageElement
imgElem.Actions.Add(fxBitmapMask);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:BitmapMask MaskFile="~/images/mask.png" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
BitmapMask
Represented by Neodynamic.SDK.BitmapMask class.

This action performs alpha channel bitmap masking on an Element. Bitmap Masking means that the pixels of a mask object affect the visibility of the underlying object i.e. of the target element.

In the following example we have an ImageElement on the Canvas and a BitmapMask action is applied on the ImageElement.

ImageElement before the action is applied.
The image used for masking and specified in the BitmapMask action.
ImageElement with BitmapMask action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


CameraView

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of CameraView class

Dim view As New Neodynamic.SDK.CameraView()
view.Elevation = 30
view.Azimuth = 25

'Apply the action on the ImageElement

imgElem.Actions.Add(view)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of CameraView class
Neodynamic.SDK.CameraView view = new Neodynamic.SDK.CameraView();
view.Elevation = 30;
view.Azimuth = 25;

//Apply the action on the ImageElement
imgElem.Actions.Add(view);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:CameraView Elevation="30" Azimuth="25" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
CameraView
Represented by Neodynamic.SDK.CameraView class.

This action simulates a camera view of an Element. In CameraView action, the camera point of view is defined by specifying two angles called Elevation & Azimuth which refer to the vertical and horizontal rotation angle of a camera's sight line relative to the center point of an element respectively; as is shown in the following figure.

In the following example we have an ImageElement on the Canvas and a CameraView action is applied on the ImageElement. In this example, the Elevation angle is set to 30 degrees and the Azimuth angle is set to 25 degrees.

ImageElement before the action is applied.
ImageElement with CameraView action applied on it. Elevation = 30 degrees and Azimuth = 25 degrees.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


ConvertToBlackWhite

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of ConvertToBlackWhite class

Dim fxBW As New Neodynamic.SDK.ConvertToBlackWhite()
fxBW.DitherMethod = Neodynamic.SDK.DitherMethod.Threshold
fxBW.Threshold = 53

'Apply the action on the ImageElement

imgElem.Actions.Add(fxBW)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of ConvertToBlackWhite class
Neodynamic.SDK.ConvertToBlackWhite fxBW = new Neodynamic.SDK.ConvertToBlackWhite();
fxBW.DitherMethod = Neodynamic.SDK.DitherMethod.Threshold;
fxBW.Threshold = 53;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxBW);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:ConvertToBlackWhite DitherMethod="Threshold"  Threshold="53" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
ConvertToBlackWhite
Represented by Neodynamic.SDK.ConvertToBlackWhite class.

This action converts an Element to black/white or monochrome. ImageDraw provides three different Dithering methods for black & white conversion including Simple Threshold, Pattern Diffusion and Floyd-Steinberg algorithm.

In the following example we have an ImageElement on the Canvas and a ConvertToBlackWhite action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with ConvertToBlackWhite action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ConvertToGrayscale

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of ConvertToGrayscale class

Dim grayscale As New Neodynamic.SDK.ConvertToGrayscale()

'Apply the action on the ImageElement

imgElem.Actions.Add(grayscale)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of ConvertToGrayscale class
Neodynamic.SDK.ConvertToGrayscale grayscale = new Neodynamic.SDK.ConvertToGrayscale();

//Apply the action on the ImageElement
imgElem.Actions.Add(grayscale);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:ConvertToGrayscale />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
ConvertToGrayscale
Represented by Neodynamic.SDK.ConvertToGrayscale class.

This action converts an Element to grayscale. Grayscale conversion is made in one step and it does not require any setting.

In the following example we have an ImageElement on the Canvas and a ConvertToGrayscale action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with ConvertToGrayscale action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


ConvertToNegative

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of ConvertToNegative class

Dim negative As New Neodynamic.SDK.ConvertToNegative()

'Apply the action on the ImageElement

imgElem.Actions.Add(negative)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of ConvertToNegative class
Neodynamic.SDK.ConvertToNegative negative = new Neodynamic.SDK.ConvertToNegative();

//Apply the action on the ImageElement
imgElem.Actions.Add(negative);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
       <Actions>
           <neoimg:ConvertToNegative />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
ConvertToNegative
Represented by Neodynamic.SDK.ConvertToNegative class.

This action converts an Element to negative. Negative conversion is made in one step and it does not require any setting.

In the following example we have an ImageElement on the Canvas and a ConvertToNegative action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with ConvertToNegative action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


ConvertToSepia

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of ConvertToSepia class

Dim sepia As New Neodynamic.SDK.ConvertToSepia()

'Apply the action on the ImageElement

imgElem.Actions.Add(sepia)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of ConvertToSepia class
Neodynamic.SDK.ConvertToSepia sepia = new Neodynamic.SDK.ConvertToSepia();

//Apply the action on the ImageElement
imgElem.Actions.Add(sepia);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:ConvertToSepia />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
ConvertToSepia
Represented by Neodynamic.SDK.ConvertToSepia class.

This action converts an Element to sepia. Sepia conversion is made in one step and it does not require any setting.

In the following example we have an ImageElement on the Canvas and a ConvertToSepia action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with ConvertToSepia action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


ColorSubstitution

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg")

'Create an instance of ColorSubstitution class

Dim fxColorSubstitution As New Neodynamic.SDK.ColorSubstitution()
fxColorSubstitution.OldColor = Color.FromArgb(202, 185, 167)
fxColorSubstitution.ColorTolerance = 10
fxColorSubstitution.NewColor = Color.Gray

'Apply the action on the ImageElement

imgElem.Actions.Add(fxColorSubstitution)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg");

//Create an instance of ColorSubstitution class
Neodynamic.SDK.ColorSubstitution fxColorSubstitution = new Neodynamic.SDK.ColorSubstitution();
fxColorSubstitution.OldColor = Color.FromArgb(202, 185, 167);
fxColorSubstitution.ColorTolerance = 10;
fxColorSubstitution.NewColor = Color.Gray;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxColorSubstitution);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/photo.jpg">
        <Actions>
            <neoimg:ColorSubstitution OldColor="202, 185, 167" ColorTolerance="10" NewColor="Gray" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
ColorSubstitution
Represented by Neodynamic.SDK.ColorSubstitution class.

This action replaces one color (old color) with another (new color) on an Element.

In the following example we have an ImageElement on the Canvas and a ColorSubstitution action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with ColorSubstitution action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Crop

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Crop class

Dim crop As New Neodynamic.SDK.Crop()
crop.X = 0
crop.Y = 10
crop.Width = 200
crop.Height = 60

'Apply the action on the ImageElement

imgElem.Actions.Add(crop)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Crop class
Neodynamic.SDK.Crop crop = new Neodynamic.SDK.Crop();
crop.X = 0;
crop.Y = 10;
crop.Width = 200;
crop.Height = 60;

//Apply the action on the ImageElement
imgElem.Actions.Add(crop);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Crop Height="60" Width="200" Y="10" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Crop
Represented by Neodynamic.SDK.Crop class.

This action crops a rectangular section from an Element. The rectangular section to crop is specified by an x/y location and a given size.

In the following example we have an ImageElement on the Canvas and a Crop action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Crop action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


DecorativeBorder

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of DecorativeBorder class

Dim decoBorder As New Neodynamic.SDK.DecorativeBorder()
decoBorder.Width = 15
decoBorder.Fill.Type = Neodynamic.SDK.FillType.Pattern
decoBorder.Fill.Pattern = System.Drawing.Drawing2D.HatchStyle.HorizontalBrick
decoBorder.Fill.ForegroundColor = System.Drawing.Color.Crimson
decoBorder.Fill.BackgroundColor = System.Drawing.Color.SeaShell

'Apply the action on the ImageElement

imgElem.Actions.Add(decoBorder)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of DecorativeBorder class
Neodynamic.SDK.DecorativeBorder decoBorder = new Neodynamic.SDK.DecorativeBorder();
decoBorder.Width = 15;
decoBorder.Fill.Type = Neodynamic.SDK.FillType.Pattern;
decoBorder.Fill.Pattern = System.Drawing.Drawing2D.HatchStyle.HorizontalBrick;
decoBorder.Fill.ForegroundColor = System.Drawing.Color.Crimson;
decoBorder.Fill.BackgroundColor = System.Drawing.Color.SeaShell;

//Apply the action on the ImageElement
imgElem.Actions.Add(decoBorder);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:DecorativeBorder Fill-BackgroundColor="SeaShell" Fill-ForegroundColor="Crimson"
          Fill-Pattern="HorizontalBrick" Fill-Type="Pattern" Width="15" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
DecorativeBorder
Represented by Neodynamic.SDK.DecorativeBorder class.

This action adds decorative border to an Element. The decorative border is specified by setting a border width, a dash style and a Fill – which can be set by a Visual Fill Editor at design-time.

In the following example we have an ImageElement on the Canvas and a DecorativeBorder action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with DecorativeBorder action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


DistortCorners

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of DistortCorners class

Dim distCorners As New Neodynamic.SDK.DistortCorners()
distCorners.X1 = -20
distCorners.Y1 = -20
distCorners.X2 = 200
distCorners.Y2 = 0
distCorners.X3 = 250
distCorners.Y3 = 180
distCorners.X4 = -30
distCorners.Y4 = 200

'Apply the action on the ImageElement

imgElem.Actions.Add(view)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of DistortCorners class
Neodynamic.SDK.DistortCorners distCorners = new Neodynamic.SDK.DistortCorners();
distCorners.X1 = -20;
distCorners.Y1 = -20;
distCorners.X2 = 200;
distCorners.Y2 = 0;
distCorners.X3 = 250;
distCorners.Y3 = 180;
distCorners.X4 = -30;
distCorners.Y4 = 200;

//Apply the action on the ImageElement
imgElem.Actions.Add(view);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:DistortCorners X1="-20" Y1="-20" X2="200" Y2="0" X3="250" Y3="180" X4="-30" Y4="200" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
DistortCorners
Represented by Neodynamic.SDK.DistortCorners class.

This action distorts an Element by changing the coordinates of the four corners (see figure) defined by the element's boundaries.

In the following example we have an ImageElement on the Canvas and a DistortCorners action is applied on the ImageElement. In this example, the new four corners are defined as (x1 = -20, y1 = -20), (x2 = 200, y2 = 0), (x3 = 250, y3 = 180), and (x4 = -30, y4 = 200).

ImageElement before the action is applied.
ImageElement with DistortCorners action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


DropShadow

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of DropShadow class

Dim dropShadow As New Neodynamic.SDK.DropShadow()

'Apply the action on the ImageElement

imgElem.Actions.Add(dropShadow)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of DropShadow class
Neodynamic.SDK.DropShadow dropShadow = new Neodynamic.SDK.DropShadow();

//Apply the action on the ImageElement
imgElem.Actions.Add(dropShadow);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:DropShadow />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of TextElement class

Dim txtElem As New Neodynamic.SDK.TextElement
txtElem.Font.Name = "Segoe UI"
txtElem.Font.Size = 20.25F
txtElem.Font.Bold = True
txtElem.ForeColor = System.Drawing.Color.White
txtElem.StrokeColor = System.Drawing.Color.Black
txtElem.StrokeWidth = 3
txtElem.Text = "Wonderful Night"
txtElem.X = 5
txtElem.Y = 120

'Create an instance of DropShadow class

Dim dropShadow As New Neodynamic.SDK.DropShadow()
dropShadow.Angle = 270
dropShadow.Color = System.Drawing.Color.Lime
dropShadow.Softness = 10

'Apply the action on the TextElement

txtElem.Actions.Add(dropShadow)

'Add the Element objects to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
Me.ImageDraw1.Elements.Add(txtElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
txtElem.Font.Name = "Segoe UI";
txtElem.Font.Size = 20.25f;
txtElem.Font.Bold = true;
txtElem.ForeColor = System.Drawing.Color.White;
txtElem.StrokeColor = System.Drawing.Color.Black;
txtElem.StrokeWidth = 3;
txtElem.Text = "Wonderful Night";
txtElem.X = 5;
txtElem.Y = 120;

//Create an instance of DropShadow class
Neodynamic.SDK.DropShadow dropShadow = new Neodynamic.SDK.DropShadow();
dropShadow.Angle = 270;
dropShadow.Color = System.Drawing.Color.Lime;
dropShadow.Softness = 10;

//Apply the action on the TextElement
txtElem.Actions.Add(dropShadow);

//Add the Element objects to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
this.ImageDraw1.Elements.Add(txtElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg ">
      </neoimg:ImageElement>
      <neoimg:TextElement Font-Bold="True" Font-Name="Segoe UI" Font-Size="20.25" ForeColor="White" StrokeWidth="3" Text="Wonderful Night" X="5" Y="120">
         <Actions>
             <neoimg:DropShadow Angle="270" Color="Lime" Softness="10" />
         </Actions>
      </neoimg:TextElement>
   </Elements>
</neoimg:imagedraw>
...

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/film.png")

'Create an instance of DropShadow class

Dim dropShadow As New Neodynamic.SDK.DropShadow()
dropShadow.Opacity = 50
dropShadow.Color = System.Drawing.Color.DarkOrange

'Apply the action on the ImageElement

imgElem.Actions.Add(dropShadow)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/film.png");

//Create an instance of DropShadow class
Neodynamic.SDK.DropShadow dropShadow = new Neodynamic.SDK.DropShadow();
dropShadow.Opacity = 50;
dropShadow.Color = System.Drawing.Color.DarkOrange;

//Apply the action on the ImageElement
imgElem.Actions.Add(dropShadow);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/film.png">
        <Actions>
           <neoimg:DropShadow Color="DarkOrange" Opacity="50" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
DropShadow
Represented by Neodynamic.SDK.DropShadow class.

This action adds drop shadows to an Element. ImageDraw makes it easy to apply drop shadows to any Element allowing you to specify the following shadow settings:
  • Angle: to set the direction of the shadow and to simulate the angle of the light shining on the object. It is measured counterclockwise from the x-axis.
  • Color: to set the color of the shadow.
  • Distance: to set the distance of the shadow from the Element.
  • Opacity: to set the percentage of transparency in the shadow.
  • Softness: to set the sharpness of the shadow.
Examples

1. In the first example we have two ImageElement objects on the Canvas anda simple DropShadow action is applied on it.

ImageElement before the action is applied.
ImageElement with DropShadow action applied on it.

Syntax sample

2. In the following example we have an ImageElement and a TextElement on the Canvas and a DropShadow action is applied on the TextElement only.

TextElement before the action is applied.
TextElement with DropShadow action applied on it.

Syntax sample

3. In the following example we have an ImageElement wrapping an "irregular" image on the Canvas and a DropShadow action is applied on the ImageElement. Notice how the image boundaries are maintained on the shadow.

ImageElement before the action is applied.
ImageElement with DropShadow action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Emboss

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Emboss class

Dim fxEmboss As New Neodynamic.SDK.Emboss()
fxEmboss.BumpHeight = 50
fxEmboss.LightAngle = 90
fxEmboss.LightElevation = 60

'Apply the action on the ImageElement

imgElem.Actions.Add(fxEmboss)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Emboss class
Neodynamic.SDK.Emboss fxEmboss = new Neodynamic.SDK.Emboss();
fxEmboss.BumpHeight = 50;
fxEmboss.LightAngle = 90;
fxEmboss.LightElevation = 60;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxEmboss);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Emboss BumpHeight="50" LightAngle="90" LightElevation="60" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Emboss
Represented by Neodynamic.SDK.Emboss class.

This action embosses an Element. ImageDraw provides a flexible Emboss effect allowing you to control the bump height and the light angle and elevation. You can also generate a colored relief instead of emboss effect.

In the following example we have an ImageElement on the Canvas and a Emboss action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Emboss action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Fade

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Fade class

Dim fxFade As New Neodynamic.SDK.Fade()
fxFade.Shape = Neodynamic.SDK.FadeShape.Oval
fxFade.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient
fxFade.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFade)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Fade class
Neodynamic.SDK.Fade fxFade = new Neodynamic.SDK.Fade();
fxFade.Shape = Neodynamic.SDK.FadeShape.Oval;
fxFade.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient;
fxFade.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFade);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:Fade Shape="Oval" ShapeFill-BackgroundColor="255, 255, 255" ShapeFill-ForegroundColor="0, 0, 0"
                    ShapeFill-GradientColor1="0, 255, 255, 255" ShapeFill-GradientColor2="0, 0, 0"
                    ShapeFill-GradientShape="Path" ShapeFill-Type="Gradient" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Fade
Represented by Neodynamic.SDK.Fade class.

This action performs fading effect on an Element. Fading action/effect gradually fades a given area/region of the target Element into the background. ImageDraw implements a very flexible and powerful Fading effect allowing you to define an area/region represented by a shape on which the fade effect takes place. Given that, you can get fading effects like rectangles, ovals, stars of any number of points, polygons of any number of sides and much more. You can specify whether the area/region for fading should fit the target element's size or be of a fixed size. You can control the area/region location as well if needed.
The fading effect is determined based on how the shape's fill is set up. For example, if you set up the shape's fill to be a solid color, then no fading effect will be produced. However, if you set up the shape's fill to be a gradient colors and one of those colors is transparent or contains some transparency (through out Alpha color channel), then a fading effect will take place.

In the following example we have an ImageElement on the Canvas and a Fade action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Rectangle fading.
ImageElement with Oval (with path gradient fill) fading.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Feather

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Feather class

Dim fxFeather As New Neodynamic.SDK.Feather()
'Set the radius
fxFeather.FeatherRadius = 5
'Set the shape
fxFeather.Shape = Neodynamic.SDK.FeatherShape.Oval

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFeather)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Feather class
Neodynamic.SDK.Feather fxFeather = new Neodynamic.SDK.Feather();
//Set the radius
fxFeather.Angle = 5;
//Set the shape
fxFeather.Shape = Neodynamic.SDK.FeatherShape.Oval;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFeather);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:Feather FeatherRadius="5"  Shape="Oval"/>
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Feather
Represented by Neodynamic.SDK.Feather class.

This action performs feathering effect on an Element. Feathering blurs the edges of a given area/region on the target Element, blending it into the background. ImageDraw implements a very flexible and powerful Feathering effect allowing you to define an area/region represented by a shape on which the feather effect takes place. Given that, you can get feathering effects like rectangles, ovals, vertical and horizontal sides, stars of any number of points, polygons of any number of sides and much more. You can specify the feathering radius and area/region for feathering should fit the target element's size or be of a fixed size.

In the following example we have an ImageElement on the Canvas and a Feather action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Rectangle feathering.
ImageElement with Oval feathering.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Filmstrip

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/starwars.jpg")

'Create an instance of Filmstrip class

Dim filmstrip As New Neodynamic.SDK.Filmstrip()
filmstrip.Width = 150
filmstrip.Height = 180
filmstrip.Roundness = 0

'Apply the action on the ImageElement

imgElem.Actions.Add(filmstrip)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/starwars.jpg");

//Create an instance of Filmstrip class
Neodynamic.SDK.Filmstrip filmstrip = new Neodynamic.SDK.Filmstrip();
filmstrip.Width = 150;
filmstrip.Height = 180;
filmstrip.Roundness = 0;

//Apply the action on the ImageElement
imgElem.Actions.Add(filmstrip);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/starwars.jpg">
        <Actions>
           <neoimg:Filmstrip Height="180" Roundness="0" Width="150" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Filmstrip
Represented by Neodynamic.SDK.Filmstrip class.

This action creates a Filmstrip representation of an Element. This action is typically used when showing VHS or DVD Covers at Entertainment Stores Websites or when showing photo albums at Photography-related or Personal Websites.
Filmstrips are very flexible allowing you to change the appearance of each component of it such as background, orientation, size, and so on.

In the following example we have an ImageElement on the Canvas and a Filmstrip action is applied on the ImageElement in both filmstrip orientations, vertical and horizontal.

ImageElement before the action is applied.
ImageElement with Filmstrip action applied on it. Vertical orientation.
ImageElement with Filmstrip action applied on it. Horizontal orientation.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Flip

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Flip class

Dim flip As New Neodynamic.SDK.Flip()
flip.Type = Neodynamic.SDK.FlipType.Horizontal

'Apply the action on the ImageElement

imgElem.Actions.Add(flip)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Flip class
Neodynamic.SDK.Flip flip = new Neodynamic.SDK.Flip();
flip.Type = Neodynamic.SDK.FlipType.Horizontal;

//Apply the action on the ImageElement
imgElem.Actions.Add(flip);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Flip Type="Horizontal" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Flip
Represented by Neodynamic.SDK.Flip class.

This action flips an Element across its vertical or horizontal axis.

In the following example we have an ImageElement on the Canvas and a Flip action is applied on the ImageElement in both directions, horizontal and vertical.

ImageElement before the action is applied.
ImageElement with Flip action applied on it. Horizontal flipping.
ImageElement with Flip action applied on it. Vertical flipping.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


FocalGrayscale

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of FocalGrayscale class

Dim fxFocalGray As New Neodynamic.SDK.FocalGrayscale()
fxFocalGray.Shape = Neodynamic.SDK.FocalShape.Oval
fxFocalGray.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient
fxFocalGray.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path
fxFocalGray.ShapeFill.GradientColor1 = Color.FromArgb(0, 255, 255, 255)
fxFocalGray.ShapeFill.GradientColor2 = Color.FromArgb(0, 0, 0)

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFocalGray)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'Add the TextElement to the Elements collection of the ImageDraw control
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of FocalGrayscale class
Neodynamic.SDK.FocalGrayscale fxFocalGray = new Neodynamic.SDK.FocalGrayscale();
fxFocalGray.Shape = Neodynamic.SDK.FocalShape.Oval;
fxFocalGray.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient;
fxFocalGray.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path;
fxFocalGray.ShapeFill.GradientColor1 = Color.FromArgb(0, 255, 255, 255);
fxFocalGray.ShapeFill.GradientColor2 = Color.FromArgb(0, 0, 0);

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFocalGray);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//Add the TextElement to the Elements collection of the ImageDraw control
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:FocalGrayscale ShapeFill-BackgroundColor="255, 255, 255" ShapeFill-ForegroundColor="0, 0, 0"
                    ShapeFill-GradientColor1="0, 255, 255, 255" ShapeFill-GradientColor2="0, 0, 0"
                    ShapeFill-GradientShape="Path" ShapeFill-Type="Gradient" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
FocalGrayscale
Represented by Neodynamic.SDK.FocalGrayscale class.

This action creates grayscale element with a colored focal point represented by a shape. ImageDraw implements a very flexible and powerful Focal Grayscale effect allowing you to define an area/region represented by a shape on which the FocalGrayscale effect takes place. Given that, you can get focal grayscale effects like rectangles, ovals, stars of any number of points, polygons of any number of sides and much more. You can specify whether the area/region for focus should fit the target element's size or be of a fixed size. You can control the area/region location as well. In addition, reversing the effect is also supported.
The smoothing effect is determined based on how the shape's fill is set up. For example, if you set up the shape's fill to be a solid color, then no smoothing effect will be produced. However, if you set up the shape's fill to be a gradient colors and one of those colors is transparent or contains some transparency (through out Alpha color channel), then a smoothing effect will take place.

In the following example we have an ImageElement on the Canvas and a FocalGrayscale action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Oval focal point.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


FocalPixelate

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg")

'Create an instance of FocalPixelate class

Dim fxFocalPixel As New Neodynamic.SDK.FocalPixelate()
fxFocalPixel.Shape = Neodynamic.SDK.FocalShape.Oval
fxFocalPixel.ShapeFill.Type = Neodynamic.SDK.FillType.Solid
fxFocalPixel.ShapeFill.BackgroundColor = Color.FromArgb(0, 0, 0)
fxFocalPixel.PixelSize = 5
fxFocalPixel.ReverseEffect = True
fxFocalPixel.Location = Neodynamic.SDK.FocalLocation.Custom
fxFocalPixel.X = 30
fxFocalPixel.Y = 0
fxFocalPixel.Sizing = Neodynamic.SDK.FocalSizing.Custom
fxFocalPixel.Width = 100
fxFocalPixel.Height = 100

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFocalPixel)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)

'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg");

//Create an instance of FocalPixelate class
Neodynamic.SDK.FocalPixelate fxFocalPixel = new Neodynamic.SDK.FocalPixelate();
fxFocalPixel.Shape = Neodynamic.SDK.FocalShape.Oval;
fxFocalPixel.ShapeFill.Type = Neodynamic.SDK.FillType.Solid;
fxFocalPixel.ShapeFill.BackgroundColor = Color.FromArgb(0, 0, 0);
fxFocalPixel.PixelSize = 5;
fxFocalPixel.ReverseEffect = true;
fxFocalPixel.Location = Neodynamic.SDK.FocalLocation.Custom;
fxFocalPixel.X = 30;
fxFocalPixel.Y = 0;
fxFocalPixel.Sizing = Neodynamic.SDK.FocalSizing.Custom;
fxFocalPixel.Width = 100;
fxFocalPixel.Height = 100;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFocalPixel);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);

//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/photo.jpg">
         <Actions>
            <neoimg:FocalPixelate Location="Custom" PixelSize="5" ReverseEffect="True" ShapeFill-BackgroundColor="255, 255, 255"
                    ShapeFill-ForegroundColor="0, 0, 0" ShapeFill-GradientColor1="0, 255, 255, 255"
                    ShapeFill-GradientColor2="0, 0, 0" ShapeFill-GradientShape="Path" Sizing="Custom"
                    X="30" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
FocalPixelate
Represented by Neodynamic.SDK.FocalPixelate class.

This action creates pixelated element with a non-pixelated focal point represented by a shape. ImageDraw implements a very flexible and powerful Focal Pixelate effect allowing you to define an area/region represented by a shape on which the FocalPixelate effect takes place. Given that, you can get focal pixelate effects like rectangles, ovals, stars of any number of points, polygons of any number of sides and much more. You can specify whether the area/region for focus should fit the target element's size or be of a fixed size. You can control the area/region location as well. In addition, reversing the effect is also supported.
The smoothing pixelate effect is determined based on how the shape's fill is set up. For example, if you set up the shape's fill to be a solid color, then no smoothing pixelate effect will be produced. However, if you set up the shape's fill to be a gradient colors and one of those colors is transparent or contains some transparency (through out Alpha color channel), then a smoothing pixelate effect will take place.

In the following example we have an ImageElement on the Canvas and a FocalPixelate action in reverse mode is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Oval focal pixelate point in reverse mode.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


FocalSoften

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of FocalSoften class

Dim fxFocalSoften As New Neodynamic.SDK.FocalSoften()
fxFocalSoften.Shape = Neodynamic.SDK.FocalShape.Oval
fxFocalSoften.ShapeFill.Type = Neodynamic.SDK.FillType.Solid
fxFocalSoften.ShapeFill.BackgroundColor = Color.FromArgb(0, 0, 0)
fxFocalSoften.Softness = 10
fxFocalSoften.Location = Neodynamic.SDK.FocalLocation.Custom
fxFocalSoften.X = 0
fxFocalSoften.Y = 0
fxFocalSoften.Sizing = Neodynamic.SDK.FocalSizing.Custom
fxFocalSoften.Width = 200
fxFocalSoften.Height = 75

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFocalSoften)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)

'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of FocalSoften class
Neodynamic.SDK.FocalSoften fxFocalSoften = new Neodynamic.SDK.FocalSoften();
fxFocalSoften.Shape = Neodynamic.SDK.FocalShape.Oval;
fxFocalSoften.ShapeFill.Type = Neodynamic.SDK.FillType.Solid;
fxFocalSoften.ShapeFill.BackgroundColor = Color.FromArgb(0, 0, 0);
fxFocalSoften.Softness = 10;
fxFocalSoften.Location = Neodynamic.SDK.FocalLocation.Custom;
fxFocalSoften.X = 0;
fxFocalSoften.Y = 0;
fxFocalSoften.Sizing = Neodynamic.SDK.FocalSizing.Custom;
fxFocalSoften.Width = 200;
fxFocalSoften.Height = 75;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFocalSoften);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);

//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
            <neoimg:FocalSoften Height="75" Location="Custom" ShapeFill-BackgroundColor="255, 255, 255"
                    ShapeFill-ForegroundColor="0, 0, 0" ShapeFill-GradientColor1="255, 255, 255"
                    ShapeFill-GradientColor2="0, 0, 0" Sizing="Custom" Softness="10" Width="200" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
FocalSoften
Represented by Neodynamic.SDK.FocalSoften class.

This action creates soften element with a focal point represented by a shape. ImageDraw implements a very flexible and powerful Focal Soften effect allowing you to define an area/region represented by a shape on which the FocalSoften effect takes place. Given that, you can get focal soften effects like rectangles, ovals, stars of any number of points, polygons of any number of sides and much more. You can specify whether the area/region for focus should fit the target element's size or be of a fixed size. You can control the area/region location as well. In addition, reversing the effect is also supported.
The smoothing soften effect is determined based on how the shape's fill is set up. For example, if you set up the shape's fill to be a solid color, then no smoothing soften effect will be produced. However, if you set up the shape's fill to be a gradient colors and one of those colors is transparent or contains some transparency (through out Alpha color channel), then a smoothing soften effect will take place.

In the following example we have an ImageElement on the Canvas and a FocalSoften action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Oval focal point.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


FocalTint

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of FocalTint class

Dim fxFocalTint As New Neodynamic.SDK.FocalTint()
fxFocalTint.Shape = Neodynamic.SDK.FocalShape.Oval
fxFocalTint.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient
fxFocalTint.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path
fxFocalTint.ShapeFill.GradientColor1 = Color.FromArgb(0, 255, 255, 255)
fxFocalTint.ShapeFill.GradientColor2 = Color.FromArgb(0, 0, 0)
fxFocalTint.Color = Color.Crimson
fxFocalTint.Location = Neodynamic.SDK.FocalLocation.Custom
fxFocalTint.X = 0
fxFocalTint.Y = 10
fxFocalTint.Sizing = Neodynamic.SDK.FocalSizing.Custom
fxFocalTint.Width = 200
fxFocalTint.Height = 75

'Apply the action on the ImageElement

imgElem.Actions.Add(fxFocalTint)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)

'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of FocalTint class
Neodynamic.SDK.FocalTint fxFocalTint = new Neodynamic.SDK.FocalTint();
fxFocalTint.Shape = Neodynamic.SDK.FocalShape.Oval;
fxFocalTint.ShapeFill.Type = Neodynamic.SDK.FillType.Gradient;
fxFocalTint.ShapeFill.GradientShape = Neodynamic.SDK.GradientShape.Path;
fxFocalTint.ShapeFill.GradientColor1 = Color.FromArgb(0, 255, 255, 255);
fxFocalTint.ShapeFill.GradientColor2 = Color.FromArgb(0, 0, 0);
fxFocalTint.Color = Color.Crimson;
fxFocalTint.Location = Neodynamic.SDK.FocalLocation.Custom;
fxFocalTint.X = 0;
fxFocalTint.Y = 10;
fxFocalTint.Sizing = Neodynamic.SDK.FocalSizing.Custom;
fxFocalTint.Width = 200;
fxFocalTint.Height = 75;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxFocalTint);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);

//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
         <Actions>
           <neoimg:FocalTint Color="Crimson" Height="75" Location="Custom" ShapeFill-GradientColor1="0, 255, 255, 255"
                    ShapeFill-GradientColor2="0, 0, 0" ShapeFill-GradientShape="Path" ShapeFill-Type="Gradient"
                    Sizing="Custom" Width="200" Y="10" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
FocalTint
Represented by Neodynamic.SDK.FocalTint class.

This action creates tinted look of an element with a focal point represented by a shape. ImageDraw implements a very flexible and powerful Focal Tint effect allowing you to define an area/region represented by a shape on which the FocalTint effect takes place. Given that, you can get focal soften effects like rectangles, ovals, stars of any number of points, polygons of any number of sides and much more. You can specify whether the area/region for focus should fit the target element's size or be of a fixed size. You can control the area/region location as well. In addition, reversing the effect is also supported.
The smoothing tint effect is determined based on how the shape's fill is set up. For example, if you set up the shape's fill to be a solid color, then no smoothing tint effect will be produced. However, if you set up the shape's fill to be a gradient colors and one of those colors is transparent or contains some transparency (through out Alpha color channel), then a smoothing tint effect will take place.

In the following example we have an ImageElement on the Canvas and a FocalTint action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with a gradient Oval focal point.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


GaussianBlur

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of GaussianBlur class

Dim gBlur As New Neodynamic.SDK.GaussianBlur()
gBlur.Radius = 5

'Apply the action on the ImageElement

imgElem.Actions.Add(view)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of GaussianBlur class
Neodynamic.SDK.GaussianBlur gBlur = new Neodynamic.SDK.GaussianBlur();
gBlur.Radius = 5;

//Apply the action on the ImageElement
imgElem.Actions.Add(view);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:GaussianBlur Radius="5" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
GaussianBlur
Represented by Neodynamic.SDK.GaussianBlur class.

This action softens the look of an Element. Gaussian Blur applies a weighted average of blur to each pixel producing a hazy effect. The only property for setting up when working with Gaussian Blur is called Radius which is the strength of the blur effect.

In the following example we have an ImageElement on the Canvas and a GaussianBlur action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with GaussianBlur action applied on it. Radius = 5.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


GlassTable

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of GlassTable class

Dim glassTable As New Neodynamic.SDK.GlassTable()
glassTable.ReflectionOpacity = 50
glassTable.ReflectionPercentage = 25

'Apply the action on the ImageElement

imgElem.Actions.Add(glassTable)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of GlassTable class
Neodynamic.SDK.GlassTable glassTable = new Neodynamic.SDK.GlassTable();
glassTable.ReflectionOpacity = 50;
glassTable.ReflectionPercentage = 25;

//Apply the action on the ImageElement
imgElem.Actions.Add(glassTable);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:GlassTable ReflectionOpacity="50" ReflectionPercentage="25" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of TextElement class

Dim txtElem As New Neodynamic.SDK.TextElement
txtElem.Font.Name = "Segoe UI"
txtElem.Font.Size = 20.25F
txtElem.Font.Bold = True
txtElem.ForeColor = System.Drawing.Color.White
txtElem.StrokeColor = System.Drawing.Color.Black
txtElem.StrokeWidth = 3
txtElem.Text = "Wonderful Night"
txtElem.X = 5
txtElem.Y = 120

'Create an instance of GlassTable class

Dim glassTable As New Neodynamic.SDK.GlassTable()
glassTable.ReflectionLocation = Neodynamic.SDK.ReflectionLocation.Custom
glassTable.ReflectionLocationY = 15

'Apply the action on the TextElement

txtElem.Actions.Add(glassTable)

'Add the Element objects to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
Me.ImageDraw1.Elements.Add(txtElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
txtElem.Font.Name = "Segoe UI";
txtElem.Font.Size = 20.25f;
txtElem.Font.Bold = true;
txtElem.ForeColor = System.Drawing.Color.White;
txtElem.StrokeColor = System.Drawing.Color.Black;
txtElem.StrokeWidth = 3;
txtElem.Text = "Wonderful Night";
txtElem.X = 5;
txtElem.Y = 120;

//Create an instance of GlassTable class
Neodynamic.SDK.GlassTable glassTable = new Neodynamic.SDK.GlassTable();
glassTable.ReflectionLocation = Neodynamic.SDK.ReflectionLocation.Custom;
glassTable.ReflectionLocationY = 15;

//Apply the action on the TextElement
txtElem.Actions.Add(glassTable);

//Add the Element objects to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
this.ImageDraw1.Elements.Add(txtElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
        <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg ">
        </neoimg:ImageElement>
        <neoimg:TextElement Font-Bold="True" Font-Name="Segoe UI" Font-Size="20.25" ForeColor="White" StrokeWidth="3" Text="Wonderful Night" X="5" Y="120">
            <Actions>
               <neoimg:GlassTable ReflectionLocation="Custom" ReflectionLocationY="15" />
            </Actions>
        </neoimg:TextElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
GlassTable
Represented by Neodynamic.SDK.GlassTable class.

This action creates a glass table effect (a.k.a. Reflection effect) on an Element. ImageDraw makes it easy to apply reflection effect on any Element showing it as it was standing on a glass table. You have full control over the action allowing you to specify the following settings:

  • Location: to set how the reflection of the Element will be positioned. If it is Auto, then the reflection will be positioned just below of the Element based on its dimensions; otherwise, the reflection position must be specified by Location X and Location Y.
    • Location X: to set the x-coordinate of the left side of the reflection object.
    • Location Y: to set the y-coordinate of the top side of the reflection object.
  • Opacity: to set the percentage of transparency in the reflection.
  • Reflection Percentage: to set the percentage of the Element height that will be reflected.
Examples

1. In the following example we have an ImageElement on the Canvas and a GlassTable action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with GlassTable action applied on it.

Syntax sample

2. In the following example we have an ImageElement and a TextElement on the Canvas and a GlassTable action is applied on the TextElement only. Notice that in this case the Reflection had to be "manually positioned" because "g" letter.

TextElement before the action is applied.
TextElement with GlassTable action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Glow

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Glow class

Dim fxGlow As New Neodynamic.SDK.Glow()
fxGlow.Color = Color.Purple
fxGlow.Softness = 10

'Apply the action on the ImageElement

imgElem.Actions.Add(fxGlow)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Glow class
Neodynamic.SDK.Glow fxGlow = new Neodynamic.SDK.Glow();
fxGlow.Color = Color.Purple;
fxGlow.Softness = 10;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxGlow);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Glow Color="Purple" Softness="10" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Glow
Represented by Neodynamic.SDK.Glow class.

This action adds glow effect to an Element. Glow settings include a color, an opacity value and the softness.

In the following example we have an ImageElement on the Canvas and a Glow action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Glow action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


MailStamp

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/nature.jpg")

'Create an instance of TextElement class

Dim txtElem As New Neodynamic.SDK.TextElement
txtElem.Font.Name = "Arial"
txtElem.Font.Size = 20.25F
txtElem.Font.Bold = True
txtElem.ForeColor = System.Drawing.Color.MidnightBlue
txtElem.StrokeColor = System.Drawing.Color.White
txtElem.StrokeWidth = 3
txtElem.Text = "63"
txtElem.X = 15
txtElem.Y = 110

'Create an instance of MailStamp class

Dim mailStamp As New Neodynamic.SDK.MailStamp()
mailStamp.Width = 150
mailStamp.ImageBorderColor = System.Drawing.Color.Transparent
mailStamp.ImagePadding.Left = 10
mailStamp.ImagePadding.Top = 10
mailStamp.ImagePadding.Right = 10
mailStamp.ImagePadding.Bottom = 10

'Apply the action on the ImageElement

imgElem.Actions.Add(mailStamp)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
Me.ImageDraw1.Elements.Add(txtElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/nature.jpg");

//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
txtElem.Font.Name = "Arial";
txtElem.Font.Size = 20.25f;
txtElem.Font.Bold = true;
txtElem.ForeColor = System.Drawing.Color.MidnightBlue;
txtElem.StrokeColor = System.Drawing.Color.White;
txtElem.StrokeWidth = 3;
txtElem.Text = "63";
txtElem.X = 15;
txtElem.Y = 110;

//Create an instance of MailStamp class
Neodynamic.SDK.MailStamp mailStamp = new Neodynamic.SDK.MailStamp();
mailStamp.Width = 150;
mailStamp.ImageBorderColor = System.Drawing.Color.Transparent;
mailStamp.ImagePadding.Left = 10;
mailStamp.ImagePadding.Top = 10;
mailStamp.ImagePadding.Right = 10;
mailStamp.ImagePadding.Bottom = 10;

//Apply the action on the ImageElement
imgElem.Actions.Add(mailStamp);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
this.ImageDraw1.Elements.Add(txtElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/nature.jpg">
         <Actions>
             <neoimg:MailStamp ImageBorderColor="Transparent" ImagePadding-Bottom="10" ImagePadding-Left="10" ImagePadding-Right="10" ImagePadding-Top="10" Width="150" />
         </Actions>
      </neoimg:ImageElement>
      <neoimg:TextElement Font-Bold="True" Font-Size="20.25" ForeColor="MidnightBlue" StrokeColor="White" StrokeWidth="3" Text="63" X="110" Y="15">
      </neoimg:TextElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
MailStamp
Represented by Neodynamic.SDK.MailStamp class.

This action creates a mail stamp representation of an Element. This action might typically used when showing photos or stamps in Personal Websites for example.
You can manage each component of the mail stamp through simple properties or attributes.

In the following example we have an ImageElement and a TextElement on the Canvas and a MailStamp action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with MailStamp action applied on it.
ImageElement with MailStamp action applied on it. No padding is set in this case.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


MakeTransparent

'...
'Create instances of ImageElement class

Dim imgElem1 As Neodynamic.SDK.ImageElement
imgElem1 = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")
Dim imgElem2 As Neodynamic.SDK.ImageElement
imgElem2 = Neodynamic.SDK.ImageElement.FromUrl("~/images/tcylogo.gif")

'Create an instance of MakeTransparent class

Dim makeTransparent As New Neodynamic.SDK.MakeTransparent()
makeTransparent.UseFirstPixel = True

'Apply the action on the ImageElement

imgElem2.Actions.Add(makeTransparent)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem1)
Me.ImageDraw1.Elements.Add(imgElem2)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem1 = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");
Neodynamic.SDK.ImageElement imgElem2 = Neodynamic.SDK.ImageElement.FromUrl("~/images/tcylogo.gif");

//Create an instance of MakeTransparent class
Neodynamic.SDK.MakeTransparent makeTransparent = new Neodynamic.SDK.MakeTransparent();
makeTransparent.UseFirstPixel = true;

//Apply the action on the ImageElement
imgElem2.Actions.Add(makeTransparent);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem1);
this.ImageDraw1.Elements.Add(imgElem2);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
      </neoimg:ImageElement>
      <neoimg:ImageElement Source="File" SourceFile="~/images/tcylogo.gif" X="5" Y="120">
         <Actions>
             <neoimg:MakeTransparent Alpha="255" UseFirstPixel="True" />
         </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
MakeTransparent
Represented by Neodynamic.SDK.MakeTransparent class.

This action makes color transparent for an Element. This action is typically used to convert a given color pixel to transparent. The conversion process takes a solid color -with a specified alpha channel value if any- and then converts all pixel matches on the Element to transparent. MakeTransparent can take the color of the upper top left pixel as the one to be transparent when the action is applied on the Element as well.
MakeTransparent action also supports color tolerance for transparency. Color Tolerance represents the tonal range of colors that will be converted to transparent taking the specified color as starting point. For example, if you ColorTolerance property is set to 0 (zero), then only adjacent pixels of exactly the same tone as the specified color will be converted to transparent; otherwise, a wider range of tones will be converted.
Note
MakeTransparent action works on Index Transparency only. In other words, a pixel becomes totally transparent when it matches a given value which is specified through the properties of Neodynamic.SDK.MakeTransparent class. The problem with Index transparency is that pixels do not have an in-between opacity value; they are either solid or transparent and thus, images with feathered edges or other effects might look not so good after all.

In the following example there are two ImageElement objects on the Canvas and a MakeTransparent action is applied on the last ImageElement using the upper top left pixel as the one to be transparent.

ImageElement before the action is applied.
ImageElement with Filmstrip action applied on it. Vertical orientation.
Travelocity and the Stars Design are trademarks of Travelocity.com LP.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


MuseumMatteFrame

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of MuseumMatteFrame class

Dim fxMuseumMatte As New Neodynamic.SDK.MuseumMatteFrame()
fxMuseumMatte.InnerBorderFill.BackgroundColor = Color.FromArgb(240, 234, 228)
fxMuseumMatte.OuterBorderFill.BackgroundColor = Color.FromArgb(26, 14, 3)

'Apply the action on the ImageElement

imgElem.Actions.Add(fxMuseumMatte)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of MuseumMatteFrame class
Neodynamic.SDK.MuseumMatteFrame fxMuseumMatte = new Neodynamic.SDK.MuseumMatteFrame();
fxMuseumMatte.InnerBorderFill.BackgroundColor = Color.FromArgb(240, 234, 228);
fxMuseumMatte.OuterBorderFill.BackgroundColor = Color.FromArgb(26, 14, 3);

//Apply the action on the ImageElement
imgElem.Actions.Add(fxMuseumMatte);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:MuseumMatteFrame InnerBorderFill-BackgroundColor="240, 234, 228" InnerBorderFill-ForegroundColor="0, 0, 0"
                    InnerBorderFill-GradientColor1="255, 255, 255" InnerBorderFill-GradientColor2="0, 0, 0"
                    OuterBorderFill-BackgroundColor="26, 14, 3" OuterBorderFill-ForegroundColor="0, 0, 0"
                    OuterBorderFill-GradientColor1="255, 255, 255" OuterBorderFill-GradientColor2="0, 0, 0" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
MuseumMatteFrame
Represented by Neodynamic.SDK.MuseumMatteFrame class.

This action adds shadowed matte frame to an Element. ImageDraw provides a flexible Museum Matte Frame effect allowing you to control the outside and inside border thikness and fill as well as shadow colors.

In the following example we have an ImageElement on the Canvas and a MuseumMatteFrame action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with MuseumMatteFrame action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


PerspectiveReflection

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of PerspectiveReflection class

Dim reflection As New Neodynamic.SDK.PerspectiveReflection()
reflection.Angle = 270;
reflection.Opacity = 50;
reflection.Length = 50;
reflection.WidthPercentage = 150;

'Apply the action on the ImageElement

imgElem.Actions.Add(reflection)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of PerspectiveReflection class
Neodynamic.SDK.PerspectiveReflection reflection = new Neodynamic.SDK.PerspectiveReflection();
reflection.Angle = 270;
reflection.Opacity = 50;
reflection.Length = 50;
reflection.WidthPercentage = 150;

//Apply the action on the ImageElement
imgElem.Actions.Add(reflection);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:PerspectiveReflection Angle="270" Length="50" Opacity="50" WidthPercentage="150" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
PerspectiveReflection
Represented by Neodynamic.SDK.PerspectiveReflection class.

This action adds perspective reflection to an Element. ImageDraw makes it easy to apply perspective reflection to any Element allowing you to specify similar settings as PrespectiveShadow action.

In the following example we have an ImageElement on the Canvas and a simple PerspectiveReflection action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with PerspectiveReflection action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


PerspectiveShadow

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of PerspectiveShadow class

Dim perspectiveShadow As New Neodynamic.SDK.PerspectiveShadow()
perspectiveShadow.Color = System.Drawing.Color.Gray
perspectiveShadow.Length = 30
perspectiveShadow.Softness = 1

'Apply the action on the ImageElement

imgElem.Actions.Add(perspectiveShadow)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of PerspectiveShadow class
Neodynamic.SDK.PerspectiveShadow perspectiveShadow = new Neodynamic.SDK.PerspectiveShadow();
perspectiveShadow.Color = System.Drawing.Color.Gray;
perspectiveShadow.Length = 30;
perspectiveShadow.Softness = 1;

//Apply the action on the ImageElement
imgElem.Actions.Add(perspectiveShadow);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:PerspectiveShadow Color="Gray" Length="30" Softness="1" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of PerspectiveShadow class

Dim perspectiveShadow As New Neodynamic.SDK.PerspectiveShadow()
perspectiveShadow.Color = System.Drawing.Color.DodgerBlue
perspectiveShadow.Length = 40
perspectiveShadow.Softness = 1
perspectiveShadow.Angle = 90
perspectiveShadow.WidthPercentage = 200

'Apply the action on the ImageElement

imgElem.Actions.Add(perspectiveShadow)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of PerspectiveShadow class
Neodynamic.SDK.PerspectiveShadow perspectiveShadow = new Neodynamic.SDK.PerspectiveShadow();
perspectiveShadow.Color = System.Drawing.Color.DodgerBlue;
perspectiveShadow.Length = 40;
perspectiveShadow.Softness = 1;
perspectiveShadow.Angle = 90;
perspectiveShadow.WidthPercentage = 200;

//Apply the action on the ImageElement
imgElem.Actions.Add(perspectiveShadow);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:PerspectiveShadow Angle="90" Color="DodgerBlue" Length="40" WidthPercentage="200" Softness="1" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
PerspectiveShadow
Represented by Neodynamic.SDK.PerspectiveShadow class.

This action adds perspective shadows to an Element. ImageDraw makes it easy to apply perspective shadows to any Element allowing you to specify the following shadow settings:

  • Angle: to set the direction of the perspective shadow and to simulate the angle of the light shining on the object. It is measured counterclockwise from the x-axis.
  • Color: to set the color of the shadow.
  • Length: to set the length of the perspective shadow.
  • Width Percentage: to set the width percentage of the perspective shadow based on the Element's width.
  • Softness: to set the sharpness of the perspective shadow.

Examples

1. In the following example we have an ImageElement on the Canvas and a simple PerspectiveShadow action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with PerspectiveShadow action applied on it.

Syntax sample

2. In the following example the same ImageElement of the previous sample but with other perspective shadow settings.

ImageElement before the action is applied.
ImageElement with PerspectiveShadow action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


PerspectiveView

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of PerspectiveView class

Dim view As New Neodynamic.SDK.PerspectiveView()
view.Angle = 25
view.Orientation = Neodynamic.SDK.PerspectiveOrientation.LeftToRight

'Apply the action on the ImageElement

imgElem.Actions.Add(view)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of PerspectiveView class
Neodynamic.SDK.PerspectiveView view = new Neodynamic.SDK.PerspectiveView();
view.Angle = 25;
view.Orientation = Neodynamic.SDK.PerspectiveOrientation.LeftToRight;

//Apply the action on the ImageElement
imgElem.Actions.Add(view);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:PerspectiveView Angle="25" Orientation="LeftToRight" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
PerspectiveView
Represented by Neodynamic.SDK.PerspectiveView class.

This action simulates a perspective view of an Element.

In the following example we have an ImageElement on the Canvas and a PerspectiveView action is applied on the ImageElement. You can specify an orientation for the perspective view which values can be "Left Ro Right", "Right to Left", "Top to Bottom", and "Bottom to Top"

ImageElement before the action is applied.
ImageElement with PerspectiveView action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Pixelate

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Pixelate class

Dim fxPixelate As New Neodynamic.SDK.Pixelate()
fxPixelate.PixelSize = 5

'Apply the action on the ImageElement

imgElem.Actions.Add(fxPixelate)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Pixelate class
Neodynamic.SDK.Pixelate fxPixelate = new Neodynamic.SDK.Pixelate();
fxPixelate.PixelSize = 5;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxPixelate);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Pixelate PixelSize="5" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Pixelate
Represented by Neodynamic.SDK.Pixelate class.

This action pixelates an Element.

In the following example we have an ImageElement on the Canvas and a Pixelate action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Pixelate action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Polaroid

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Polaroid class

Dim polaroid As New Neodynamic.SDK.Polaroid()
polaroid.Background.BackgroundColor = System.Drawing.Color.OldLace
polaroid.BorderColor = System.Drawing.Color.SandyBrown
polaroid.Font.Bold = True
polaroid.Font.Name = "Courier New"
polaroid.Font.Size = 8.25F
polaroid.ForeColor = System.Drawing.Color.Purple
polaroid.Text = "Wonderful Night"
polaroid.ImagePadding.Left = 10
polaroid.ImagePadding.Top = 10
polaroid.ImagePadding.Right = 10
polaroid.ImagePadding.Bottom = 35

'Apply the action on the ImageElement

imgElem.Actions.Add(polaroid)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Polaroid class
Neodynamic.SDK.Polaroid polaroid = new Neodynamic.SDK.Polaroid();
polaroid.Background.BackgroundColor = System.Drawing.Color.OldLace;
polaroid.BorderColor = System.Drawing.Color.SandyBrown;
polaroid.Font.Bold = true;
polaroid.Font.Name = "Courier New";
polaroid.Font.Size = 8.25f;
polaroid.ForeColor = System.Drawing.Color.Purple;
polaroid.Text = "Wonderful Night";
polaroid.ImagePadding.Left = 10;
polaroid.ImagePadding.Top = 10;
polaroid.ImagePadding.Right = 10;
polaroid.ImagePadding.Bottom = 35;

//Apply the action on the ImageElement
imgElem.Actions.Add(polaroid);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Polaroid Background-BackgroundColor="OldLace" BorderColor="SandyBrown" Font-Bold="True"
              Font-Name="Courier New" Font-Size="8.25" ForeColor="Purple" ImagePadding-Bottom="35" ImagePadding-Left="10"
              ImagePadding-Right="10" ImagePadding-Top="10" Text="Wonderful Night" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Polaroid
Represented by Neodynamic.SDK.Polaroid class.

This action creates a Polaroid representation of an Element. This action is typically used when showing photo albums in Photography-related or Personal Websites.
Polaroid is very flexible allowing you to change the appearance of each component of it such as background, size, caption and so on.

In the following example we have an ImageElement on the Canvas and a Polaroid action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Polaroid action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


RedEyeRemoval

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg")

'Create an instance of RedEyeRemoval class

Dim redEyeRemoval As New Neodynamic.SDK.RedEyeRemoval()
redEyeRemoval.Threshold = 70
redEyeRemoval.RedEyeAreas = New Neodynamic.SDK.RedEyeArea() { New Neodynamic.SDK.RedEyeArea(307, 239, 11, 11, 0), New Neodynamic.SDK.RedEyeArea(386, 233, 11, 11, 0) }

'Apply the action on the ImageElement

imgElem.Actions.Add(redEyeRemoval)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg");

//Create an instance of RedEyeRemoval class
Neodynamic.SDK.RedEyeRemoval redEyeRemoval = new Neodynamic.SDK.RedEyeRemoval();
redEyeRemoval.Threshold = 70;
redEyeRemoval.RedEyeAreas = new Neodynamic.SDK.RedEyeArea[] { new Neodynamic.SDK.RedEyeArea(307, 239, 11, 11, 0), new Neodynamic.SDK.RedEyeArea(386, 233, 11, 11, 0) };

//Apply the action on the ImageElement
imgElem.Actions.Add(redEyeRemoval);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/photo.jpg">
        <Actions>
            <neoimg:RedEyeRemoval RedEyeAreas="307,239,11,11,0|386,233,11,11,0" Threshold="70" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
RedEyeRemoval
Represented by Neodynamic.SDK.RedEyeRemoval class.

This action performs red-eye removal effect from an Element. RedEyeRemoval lets you define as many red-eye areas as you want on which the red-eye removal algorithm will be applied. Each red-eye area can be set with a Threshold value or you can set up a single Threshold for all specified red-eye areas. The Threshold value is used for detecting red pixels.

In the following example we have an ImageElement on the Canvas and a RedEyeRemoval action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with RedEyeRemoval action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


RemovePixel

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg")

'Create an instance of RemovePixel class

Dim fxRemovePixel As New Neodynamic.SDK.RemovePixel()
fxRemovePixel.Color = Color.FromArgb(202, 185, 167)
fxRemovePixel.ColorTolerance = 10

'Apply the action on the ImageElement

imgElem.Actions.Add(fxRemovePixel)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/photo.jpg");

//Create an instance of RemovePixel class
Neodynamic.SDK.RemovePixel fxRemovePixel = new Neodynamic.SDK.RemovePixel();
fxRemovePixel.Color = Color.FromArgb(202, 185, 167);
fxRemovePixel.ColorTolerance = 10;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxRemovePixel);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/photo.jpg">
        <Actions>
            <neoimg:RemovePixel Color="202, 185, 167" ColorTolerance="10" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
RemovePixel
Represented by Neodynamic.SDK.RemovePixel class.

This action removes pixels from an Element and automatically resizes it.

In the following example we have an ImageElement on the Canvas and a RemovePixel action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with RemovePixel action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


RemoveTransparency

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of RemoveTransparency class

Dim removeTrans As New Neodynamic.SDK.RemoveTransparency()

'Apply the action on the ImageElement

imgElem.Actions.Add(removeTrans)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of RemoveTransparency class
Neodynamic.SDK.RemoveTransparency removeTrans = new Neodynamic.SDK.RemoveTransparency();

//Apply the action on the ImageElement
imgElem.Actions.Add(removeTrans);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:RemoveTransparency />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
RemoveTransparency
Represented by Neodynamic.SDK.RemoveTransparency class.

This action removes transparent pixels from an Element and automatically resizes it.

In the following example we have an ImageElement on the Canvas and a RemoveTransparency action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with RemoveTransparency action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Resize

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Resize class

Dim resize As New Neodynamic.SDK.Resize()
resize.Width = 100
resize.LockAspectRatio = Neodynamic.SDK.LockAspectRatio.WidthBased

'Apply the action on the ImageElement

imgElem.Actions.Add(resize)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Resize class
Neodynamic.SDK.Resize resize = new Neodynamic.SDK.Resize();
resize.Width = 100;
resize.LockAspectRatio = Neodynamic.SDK.LockAspectRatio.WidthBased;

//Apply the action on the ImageElement
imgElem.Actions.Add(resize);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Resize Width="100" LockAspectRatio="WidthBased" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Resize
Represented by Neodynamic.SDK.Resize class.

This action changes the size of an Element. This action is typically used when you need to reduce or enlarge the current Element size to a new one. One interested feature is LockAspectRatio which determine how Element's proportions are maintained. For example, if LockAspectRatio is set to WidthBased, then the Element's proportions will be maintained based on the new specified width value i.e. the new Height of the Element will be automatically calculated based on the new Width value.

In the following example we have an ImageElement on the Canvas and a Resize action is applied on the ImageElement with none, width based, and height based lock aspect ratio respectively.

ImageElement before the action is applied.
ImageElement with Resize action applied on it. New width and height are 100 pixels. None LockAspectRatio was applied.
ImageElement with Resize action applied on it. New width is 100 pixels. LockAspectRatio is WidthBased and thus the new height is automatically calculated maintaining the aspect ratio.
ImageElement with Resize action applied on it. New height is 100 pixels. LockAspectRatio is HeightBased and thus the new width is automatically calculated maintaining the aspect ratio.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Rotate

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Rotate class

Dim rotate As New Neodynamic.SDK.Rotate()
rotate.Angle = 45

'Apply the action on the ImageElement

imgElem.Actions.Add(rotate)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Rotate class
Neodynamic.SDK.Rotate rotate = new Neodynamic.SDK.Rotate();
rotate.Angle = 45;

//Apply the action on the ImageElement
imgElem.Actions.Add(rotate);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Rotate Angle="45" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Rotate
Represented by Neodynamic.SDK.Rotate class.

This action rotates an Element pivoting on its center point. Rotate action requires a rotation angle which is measured counterclockwise from the x-axis.

In the following example we have an ImageElement on the Canvas and a Rotate action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Rotate action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


RoundCorners

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of RoundCorners class

Dim roundCorners As New Neodynamic.SDK.RoundCorners()
roundCorners.Roundness = 20

'Apply the action on the ImageElement

imgElem.Actions.Add(roundCorners)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of RoundCorners class
Neodynamic.SDK.RoundCorners roundCorners = new Neodynamic.SDK.RoundCorners();
roundCorners.Roundness = 20;

//Apply the action on the ImageElement
imgElem.Actions.Add(roundCorners);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:RoundCorners Roundness="20" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
RoundCorners
Represented by Neodynamic.SDK.RoundCorners class.

This action rounds Element corners. RoundCorners settings include the corner roundness and a color and width for the border if necessary.

In the following example we have an ImageElement on the Canvas and a RoundCorners action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement before the action is applied.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Scale

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Scale class

Dim scale As New Neodynamic.SDK.Scale()
scale.WidthPercentage = 50
scale.HeightPercentage = 50

'Apply the action on the ImageElement

imgElem.Actions.Add(scale)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Scale class
Neodynamic.SDK.Scale scale = new Neodynamic.SDK.Scale();
scale.WidthPercentage = 50;
scale.HeightPercentage = 50;

//Apply the action on the ImageElement
imgElem.Actions.Add(scale);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Scale HeightPercentage="50" WidthPercentage="50" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Scale
Represented by Neodynamic.SDK.Scale class.

This action enlarges or reduces the size of an Element based on percentage values.
Tip
For the Element's proportions to be maintained when scaling, both WidthPercentage and HeightPercentage properties must be equals.
In the following example we have an ImageElement on the Canvas and a Scale action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Scale action applied on it. Scaled at 50% width and height.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Sharpen

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Sharpen class and apply the action on the ImageElement

imgElem.Actions.Add(New Neodynamic.SDK.Sharpen())

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Sharpen class and apply the action on the ImageElement
imgElem.Actions.Add(new Neodynamic.SDK.Sharpen());

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Sharpen />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Sharpen
Represented by Neodynamic.SDK.Sharpen class.

This action sharpen an Element trying to enhance the overall visual impression.

In the following example we have an ImageElement on the Canvas and a Sharpen action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Sharpen action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Silhouette

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/bird.png")

'Create an instance of Silhouette class

Dim silhouette As New Neodynamic.SDK.Silhouette()
silhouette.Color = System.Drawing.Color.Silver

'Apply the action on the ImageElement

imgElem.Actions.Add(silhouette)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/bird.png");

//Create an instance of Silhouette class
Neodynamic.SDK.Silhouette silhouette = new Neodynamic.SDK.Silhouette();
silhouette.Color = System.Drawing.Color.Silver;

//Apply the action on the ImageElement
imgElem.Actions.Add(silhouette);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/bird.png">
        <Actions>
           <neoimg:Silhouette Color="Silver" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Silhouette
Represented by Neodynamic.SDK.Silhouette class.

This action creates a Silhouette of an Element. A silhouette is a view of an object consisting of the outline and a featureless interior. Silhouette action is effective only for irregular images with transparent background.

In the following example we have a transparent PNG image (DO NOT use the image below because it was converted to JPEG) wrapped by an ImageElement on the Canvas and a Silhouette action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Silhouette action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Skew

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Skew class

Dim skew As New Neodynamic.SDK.Skew()
skew.Angle = -10
skews.Type = Neodynamic.SDK.SkewType.Parallelogram
skew.Orientation = Neodynamic.SDK.SkewOrientation.Horizontal

'Apply the action on the ImageElement

imgElem.Actions.Add(skew)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Skew class
Neodynamic.SDK.Skew skew = new Neodynamic.SDK.Skew();
skew.Angle = -10;
skews.Type = Neodynamic.SDK.SkewType.Parallelogram;
skew.Orientation = Neodynamic.SDK.SkewOrientation.Horizontal;

//Apply the action on the ImageElement
imgElem.Actions.Add(skew);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Skew Skew="-10" Type="Parallelogram" Orientation="Horizontal" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Skew
Represented by Neodynamic.SDK.Skew class.

This action transforms an Element by slanting it along the horizontal or vertical axis. When skewed, an element pivots on its origin point.
Skew action is defined by specifying a skewing type (Parallelogram or Trapezoid), an orientation (Horizontal or Vertical) and a positive or negative angle.

The following table describes how skewing settings are related to each other.

Skew Type | Skew Orientation
 | Horizontal |  | Vertical
Parallelogram | Angle = -25 degrees | Angle = 25 degrees | Angle = -25 degrees | Angle = 25 degrees
Trapezoid | Angle = -8 degrees | Angle = 8 degrees | Angle = -8 degrees | Angle = 8 degrees

In the following example we have an ImageElement on the Canvas and a Skew action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Skew action applied on it. Skew Settings: Parallelogram, Horizontal orientation, Angle = -10 degress.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Solarize

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Solarize class and apply the action on the ImageElement

imgElem.Actions.Add(New Neodynamic.SDK.Solarize())

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Solarize class and apply the action on the ImageElement
imgElem.Actions.Add(new Neodynamic.SDK.Solarize());

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Solarize />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Solarize
Represented by Neodynamic.SDK.Solarize class.

This action solarizes an Element.

In the following example we have an ImageElement on the Canvas and a Solarize action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Solarize action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Stretch

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Stretch class

Dim stretch As New Neodynamic.SDK.Stretch()
stretch.Width = 90
stretch.Height = 150

'Apply the action on the ImageElement

imgElem.Actions.Add(stretch)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Stretch class
Neodynamic.SDK.Stretch stretch = new Neodynamic.SDK.Stretch();
stretch.Width = 90;
stretch.Height = 150;

//Apply the action on the ImageElement
imgElem.Actions.Add(stretch);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
           <neoimg:Stretch Height="150" Width="90" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Stretch
Represented by Neodynamic.SDK.Stretch class.

This action stretches an Element to fit a given size.

In the following example we have an ImageElement on the Canvas and a Stretch action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Stretch action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2007 Neodynamic - All rights reserved.


Tint

'...
'Create an instance of ImageElement class

Dim imgElem As Neodynamic.SDK.ImageElement
imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg")

'Create an instance of Tint class

Dim fxTint As New Neodynamic.SDK.Tint()
fxTint.Color = Color.Orange

'Apply the action on the ImageElement

imgElem.Actions.Add(fxTint)

'Add the ImageElement to the Elements collection of the ImageDraw control

Me.ImageDraw1.Elements.Add(imgElem)
'...

//...
//Create an instance of ImageElement class
Neodynamic.SDK.ImageElement imgElem = Neodynamic.SDK.ImageElement.FromUrl("~/images/night.jpg");

//Create an instance of Tint class
Neodynamic.SDK.Tint fxTint = new Neodynamic.SDK.Tint();
fxTint.Color = Color.Orange;

//Apply the action on the ImageElement
imgElem.Actions.Add(fxTint);

//Add the ImageElement to the Elements collection of the ImageDraw control
this.ImageDraw1.Elements.Add(imgElem);
//...

...
<neoimg:imagedraw id="ImageDraw1" runat="server">
   <Canvas AutoSize="True" />
   <Elements>
      <neoimg:ImageElement Source="File" SourceFile="~/images/night.jpg">
        <Actions>
            <neoimg:Tint Color="Orange" />
        </Actions>
      </neoimg:ImageElement>
   </Elements>
</neoimg:imagedraw>
...
Neodynamic ImageDraw SDK for .NET
Tint
Represented by Neodynamic.SDK.Tint class.

This action creates a tinted look of an Element.

In the following example we have an ImageElement on the Canvas and a Tint action is applied on the ImageElement.

ImageElement before the action is applied.
ImageElement with Tint action applied on it.

Syntax sample

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Image Formats Supported

Neodynamic ImageDraw SDK for .NET
Image Formats Supported
ImageDraw supports the following image formats.
  • Input Image Formats
    ImageDraw manages input images by wrapping them through ImageElement objects and the supported formats are PNG, GIF, JPG/JPEG, BMP, TIFF, WMF, EMF, and ICO.

  • Output Image Formats
    Each ImageDraw features the ImageFormat property which indicates what image format must be rendered. The following formats are supported for the output image: PNG, GIF, JPG/JPEG, BMP, and Wireless Bitmap (WBMP). Read the sidebar "Transparent Fills" related to this topic.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Saving and getting the output composite image

Neodynamic ImageDraw SDK for .NET
Saving and getting the output composite image
ImageDraw features a set of class methods intended to save the output composite image on different storage mediums such as Disk, Memory Streams, and GDI+ Image Objects. The aforementioned class methods are:

  • GetDraftImage

    This method lets you to get a System.Drawing.Bitmap object of the draft of the composite image. The term Draft means that there is no image format applied on the Bitmap object.

  • GetOutputImage

    This method is similar to GetDraftImage method with the difference that the System.Drawing.Bitmap object returned by GetOutputImage is applied with the image format specified by the ImageFormat property.

  • GetOutputImageBinary

    This method lets you to get a Byte Array (a buffer) of the output composite image in the image format specified the ImageFormat property. This method is especially useful when dealing with WebServices scenarios.

  • Save

    This method -with 4 overload versions- lets you to save the output composite image to the specified file on disk or to the specified memory stream, depending on the invoked overload version of the method.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Misc Notes

Neodynamic ImageDraw SDK for .NET
Misc Notes
In This Section:
  • Transparent Fills

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Transparent Fills

Neodynamic ImageDraw SDK for .NET
Transparent Fills
When using transparent fills, you have to know that there's a close relationship between Transparency values and output image formats.

Keep in mind the following rules regarding this topic:
  • Totally Transparent fill (Alpha channel is 0)
    Both -and only- PNG and GIF image formats support it.

  • Semi-Transparent fill (Alpha channel is between 1 and 254)
    Only PNG image format support it. Keep in mind that transparency is supported by PNG format only if the ColorDepth property is set to Format32bppAlpha; otherwise a black background will be rendered.

  • For JPG/JPEG and BMP formats, transparency is not allowed and if a transparency value is set, a black background will be rendered.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Deployment

Neodynamic ImageDraw SDK for .NET
Neodynamic ImageDraw SDK for .NET Deployment
Deploying an application that uses Neodynamic ImageDraw SDK for .NET is not different than any other application that uses .NET custom libraries or assemblies. All functionality of ImageDraw is contained in a unique assembly (Neodynamic.SDK.ImageDraw.dll). For example, when deploying your web application using ImageDraw SDK, you must ensure that Neodynamic.SDK.ImageDraw.dll assembly is located in the BIN folder of your application.

Where is the Neodynamic.SDK.ImageDraw.dll assembly for deployment?
We provide ImageDraw assemblies ready for deploying and targeting different platform versions of .NET Framework such as 32bit and 64bit (x64 and IA64 Itanium).

The Neodynamic.SDK.ImageDraw.dll assembly for deploying is located in the ImageDraw installation folder under Redistributable folder. You should deploy Neodynamic.SDK.ImageDraw.dll assembly based on the .NET Framework version which your .NET Application is running on.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Merging Actions to get impressive imaging effects

Neodynamic ImageDraw SDK for .NET
Merging Actions to get impressive imaging effects
In the following points you can find how to merge Actions in order to get some impressive imaging effects without efforts.
Note
We will publish all other new effects at our Website (www.neodynamic.com) and if you cannot figure out how to get a given effect working, please contact our Tech Support emailing support@neodynamic.com
Merging Actions
  • ConvertToSepia + Filmstrip + PerspectiveShadow
  • Filmstrip + GlassTable (Reflection)
  • ConvertToNegative + Filmstrip
  • ConvertToGrayscale + Polaroid + DropShadow
  • Polaroid + PerspectiveShadow
  • GlassTable (Reflection) on Image and Text elements
  • MailStamp + Rotate + DropShadow
  • Scale + Silhouette + GlassTable (Reflection) on Image and Text elements
  • Halo effect through DropShadow
ConvertToSepia + Filmstrip + PerspectiveShadow

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • ConvertToSepia
    • Filmstrip
    • PerspectiveShadow
Filmstrip + GlassTable (Reflection)

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • Filmstrip
    • GlassTable (Opacity: 30, Reflection Percentage: 30)
ConvertToNegative + Filmstrip

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • ConvertToNegative
    • Filmstrip (Orientation: Horizontal, Perforation Width: 5, Roundness: 0)
ConvertToGrayscale + Polaroid + DropShadow

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • ConvertToGrayscale
    • Polaroid (Background: Solid-WhiteSmoke, ImageBorderColor: DimGray, Roundness: 5)
    • DropShadow (Angle: 270, Opacity: 75)
Polaroid + PerspectiveShadow

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • Polaroid (Background: Solid-WhiteSmoke, ImageBorderColor: DimGray, Roundness: 0)
    • PerspectiveShadow (Angle: 90)
GlassTable (Reflection) on Image and Text elements

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement (X: 40)
  • Apply the following actions on it in the specified order

    • GlassTable (Opacity: 50, Reflection Percentage: 20)
  • Add an TextElement (Font-Size: 24, Font Bold, ForeColor: White, StrokeColor: Maroon, StrokeWidth: 3, Text: DVD Store, Y: 145)
  • Apply the following actions on it in the specified order

    • GlassTable (Opacity: 30)
MailStamp + Rotate + DropShadow

This is the original image

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • MailStamp (ImageBorderColor: WhiteSmoke, ImagePadding: 8; PerforationBorderColor: OliveDrab, Width: 150)
    • Rotate (Angle: 15)
    • DropShadow (Angle: 240, Color: DimGray)
Scale + Silhouette + GlassTable (Reflection) on Image and Text elements

This is the original image (PNG with Transparency background).

The original image after ImageDraw processes it. 		Steps to reproduce this effect
  • Add an TextElement (Font-Name: Trebuchet MS, Font-Size: 28, ForeColor: White, StrokeColor: DarkOrange, StrokeWidth: 3, Text: Bird Accessories, X: 40, Y: 23)
  • Apply the following actions on it in the specified order

    • GlassTable (Location: Custom, LocationY: 24, Opacity: 50)
  • Add an ImageElement
  • Apply the following actions on it in the specified order

    • Scale (WidthPercentage: 35, HeightPercentage: 35)
    • Silhouette (Color: LightSlateGray)
    • GlassTable (Opacity: 50, Reflection Percentage: 50)
Halo effect through DropShadow
Steps to reproduce this effect
  • Set the background canvas to Solid-Black
  • Add an TextElement (Font-Size: 72, StrokeColor: SteelBlue, StrokeWidth: 1, Text: Halo)
  • Apply the following actions on it in the specified order

    • DropShadow (Angle: 0, Distance: 3, Softness: 20, Color: Aqua)

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageDraw Fonts

<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:TextElement AutoSize="True" Font-CustomFontFile="~/MyFonts/Simpsonfont.ttf" Font-Size="28" Multiline="False"
            Text="Hello World" >
        </neoimg:TextElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of TextElement class
Dim txtElem As New Neodynamic.SDK.TextElement()
'Set custom font file URL
txtElem.Font.CustomFontFile = "~/MyFonts/Simpsonfont.ttf"
'Set font size to 28 points
txtElem.Font.Size = 28F
'Set text and other properties
txtElem.AutoSize = True
txtElem.Multiline = False
txtElem.Text = "Hello World"
//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
//Set custom font file URL
txtElem.Font.CustomFontFile = "~/MyFonts/Simpsonfont.ttf";
//Set font size to 28 points
txtElem.Font.Size = 28f;
//Set text and other properties
txtElem.AutoSize = true;
txtElem.Multiline = false;
txtElem.Text = "Hello World";
<configuration>
  <appSettings>
    <add key="MyCustomFont" value="~/MyFonts/Simpsonfont.ttf"/>
  </appSettings>
  ...
</configuration>
<neoimg:ImageDraw runat="server" id="ImageDrawControl">
    <Elements>
        <neoimg:TextElement AutoSize="True" Font-CustomFontFile="MyCustomFont" Font-Size="28" Multiline="False"
            Text="Hello World" >
        </neoimg:TextElement>
    </Elements>
</neoimg:ImageDraw>
'Create an instance of TextElement class
Dim txtElem As New Neodynamic.SDK.TextElement()
'Set custom font file KEY from Web.config
txtElem.Font.CustomFontFile = "MyCustomFont"
'Set font size to 28 points
txtElem.Font.Size = 28F
'Set text and other properties
txtElem.AutoSize = True
txtElem.Multiline = False
txtElem.Text = "Hello World"
//Create an instance of TextElement class
Neodynamic.SDK.TextElement txtElem = new Neodynamic.SDK.TextElement();
//Set custom font file KEY from Web.config
txtElem.Font.CustomFontFile = "MyCustomFont";
//Set font size to 28 points
txtElem.Font.Size = 28f;
//Set text and other properties
txtElem.AutoSize = true;
txtElem.Multiline = false;
txtElem.Text = "Hello World";
Neodynamic ImageDraw SDK for .NET
ImageDraw Fonts
ImageDraw Font objects – represented by Neodynamic.SDK.Font class – are used for displaying text on TextElement and ShapeElement objects. ImageDraw Font objects not only let you to use Windows System installed fonts (%windir%\Fonts folder) but also let you to use custom font files (*.ttf) stored in local disk.
    In This Section

  • Using Windows installed fonts
  • Using Custom Font Files (*.ttf)
  • Font Size and Style

Using Windows installed fonts
You can create ImageDraw Font objects by choosing one of the Windows installed fonts which are available in %windir%\Fonts folder. To do that, just set up the Name property of Font class to a string representation of the face name of the installed font. For example, one of the most commonly used Windows installed font is called "Arial". That font is stored in ARIAL.TTF file under %windir%\Fonts folder. The typeface name for such font is just "Arial". So, if you want to use that installed font to create an ImageDraw Font object, then you must set up the Name property to "Arial" string.

Note
If you select an installed font from your development machine, then you must be sure the same font is installed in the Windows System where your .NET Application will be hosted and run. If the font is missing and you cannot install it on the target system, then you might consider trying "Using Custom Font Files (*.ttf)" approach which is described below.

Using Custom Font Files (*.ttf)
In some situations, it's possible you want or need to use fonts that are not installed in the Windows System where your .NET Application is running on. For such cases, ImageDraw Font objects let you to render text by using font files (*.ttf) that are not installed in the Windows System but are located in any local folders of target machine.

To create ImageDraw Font objects from custom font files, just set up the CustomFontFile property of Font class. You can specify the CustomFonFile property as a relative URL or full path string pointing out to the custom font file on the Windows System disk or; as an identifier stored in the appSettings section of the Configuration file (*.config) of your .NET application.

Example of Custom Font Files in ASP.NET Web Applications:

  • Adding Custom Font File to website structure:
    Suppose we have a folder named MyFonts under our website root folder and a custom font file named Simpsonsfont.TTF inside it as is shown in the following figure:

    MyFonts folder under website root folder holding custom font file

    Note
    The Simpsonsfont.ttf file and author info is available at http://www.sharkshock.com/fonts/fontscar.html

  • Creating an ImageDraw Font from Custom Font File:
    Suppose we want to create a simple TextElement displaying the text "Hello World" by using the "Simpsonsfont.ttf" file. As mentioned before, in order to create an ImageDraw Font object from a custom font file, you must set up the CustomFonFile property of Font class. You can set up CustomFonFile property in two ways:

    • Directly specifying the custom font file's relative URL to CustomFonFile property. Example:

    • Configure custom font file's relative URL in the Web.config file and then set the configuration key to CustomFonFile property. Example:

    Either of the aforementioned settings will produce the following TextElement output i.e. featuring text that is dispalyed by using a custom font file:

    A TextElement object featuring custom font files

Font Size and Style
ImageDraw Font objects support the following additional features regarding Style and Size.
  • Font Styles
    ImageDraw Font objects can be set so they look bold, italic, underline, and strikeout.
  • Font Size and Unit
    The font size value will depend on the font unit which can be set to Point, Inch, Millimeter, or Pixel.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


ImageDraw XML Templates

'Create an instance of XmlDocument
Dim xmlDoc As New System.Xml.XmlDocument()
'Load XML Template getting it by invoking GetXmlTemplate
'NOTE: ImageDrawObj is an instance of an ImageDraw class
xmlDoc.LoadXml(Me.ImageDrawObj.GetXmlTemplate())
'Save XML Template on disk
xmlDoc.Save("c:\temp\imageDrawXmlTemplateSample.xml")
//Create an instance of XmlDocument
System.Xml.XmlDocument xmlDoc = new System.Xml.XmlDocument();
//Load XML Template getting it by invoking GetXmlTemplate
//NOTE: ImageDrawObj is an instance of an ImageDraw class
xmlDoc.LoadXml(this.ImageDrawObj.GetXmlTemplate());
//Save XML Template on disk
xmlDoc.Save(@"c:\temp\imageDrawXmlTemplateSample.xml");

'Create an instance of XmlDocument
Dim xmlDoc As New System.Xml.XmlDocument()
'Load XML Template File
xmlDoc.Load("c:\temp\imageDrawXmlTemplateSample.xml")
'Import XML template
'NOTE: ImageDrawObj is an instance of an ImageDraw class
Me.ImageDrawObj.LoadXmlTemplate(xmlDoc.OuterXml)
//Create an instance of XmlDocument
System.Xml.XmlDocument xmlDoc = new System.Xml.XmlDocument();
//Load XML Template File
xmlDoc.Load(@"c:\temp\imageDrawXmlTemplateSample.xml");
//Import XML template
//NOTE: ImageDrawObj is an instance of an ImageDraw class
this.ImageDrawObj.LoadXmlTemplate(xmlDoc.OuterXml);
Neodynamic ImageDraw SDK for .NET
ImageDraw XML Templates
ImageDraw features XML Template i.e. you can instruct an ImageDraw object for exporting/importing the composite image in XML text formatting. The following is an ImageDraw XML Template produced by an ImageDraw object:

<ImageDrawTemplate>
  <OutputImageSettings ColorDepth="Format32bppAlpha" ImageFormat="Jpeg" JpegCompressionLevel="80" />
  <Canvas AutoSize="False" CenterElements="False" Height="400" Width="400" Fill="Solid,-1,-16777216,BackwardDiagonal,-1,-16777216,0,,Tile" />
  <Elements>
    <ImageElement Name="imgNight" X="24" Y="19" Width="243" Height="182" Source="File" Offset="0" SourceData="~/images/night.jpg" NullImageUrl="">
      <Actions>
        <GlassTable ReflectionLocation="Auto" ReflectionLocationX="0" ReflectionLocationY="0" ReflectionOpacity="50" ReflectionPercentage="30" />
      </Actions>
    </ImageElement>
    <TextElement Name="txtTitle" X="26" Y="189" Width="233" Height="76" AutoSize="False" Multiline="True" Font="Arial,20,Point,,0" ForeColor="-16777216" StrokeColor="-16777216" StrokeWidth="0" Text="Wonderful Night" TextAlignment="MiddleCenter" TextQuality="AntiAlias" />
    <PolygonShapeElement Name="shpDiamond" X="240" Y="107" Width="119" Height="111" Font="Arial,20,True,False,False,False,Point,,0" StrokeDashStyle="Solid" StrokeFill="Solid,-7155632,-16777216,BackwardDiagonal,-1,-16777216,0,,Tile" StrokeLineJoinStyle="Miter" StrokeWidth="7" Text="" TextAlignment="MiddleCenter" TextForeColor="-16777216" TextPadding="0" TextQuality="AntiAlias" TextStrokeColor="-16777216" TextStrokeWidth="0" Roundness="0" Fill="Solid,-1,-16777216,BackwardDiagonal,-1,-16777216,0,,Tile" Sides="4" />
    <LineShapeElement Name="shpLine" X="122" Y="259" Width="203" Height="45" Font="Arial,20,True,False,False,False,Point,,0" StrokeDashStyle="Solid" StrokeFill="Solid,-65536,-16777216,BackwardDiagonal,-1,-16777216,0,,Tile" StrokeLineJoinStyle="Miter" StrokeWidth="7" Text="" TextAlignment="MiddleCenter" TextForeColor="-16777216" TextPadding="0" TextQuality="AntiAlias" TextStrokeColor="-16777216" TextStrokeWidth="0" Roundness="0" Orientation="Horizontal" StartLineCap="Circle" StartLineCapWidth="5" EndLineCap="Arrow" EndLineCapWidth="5" />
  </Elements>
</ImageDrawTemplate>

Exporting and Importing ImageDraw XML Templates
  • Exporting ImageDraw XML Templates
    For exporting an ImageDraw XML Template, you must invoke the GetXmlTemplate() method that ImageDraw controls feature. The GetXmlTemplate() method returns a string representation of the XML Template allowing you to save it in any kind of data source be it SQL Server Database, file on disk, etc. For example, you can easily save the XML Template in a disk file by leveraging System.Xml.XmlDocument class of .NET Framework:

  • Importing ImageDraw XML Templates
    For importing an ImageDraw XML Template, you must invoke the LoadXmlTemplate() method that ImageDraw controls feature. You must pass to the LoadXmlTemplate() method a string representation of the XML Template. For example, based on the exporting sample above, you can import a XML Template from a file as follows:

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Online Samples

Neodynamic ImageDraw SDK for .NET
Neodynamic ImageDraw SDK for .NET Online Samples
We've developed many samples using ImageDraw SDK for .NET in order to help you getting started.

Below is the list of online up to date Step-By-Step Guides. If for any reason you can't see them, please enter at http://www.neodynamic.com/Products/Demos/Demos.aspx?tabid=95&prodid=8

Visit Neodynamic's website.

Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.


Neodynamic.SDK.ImageDraw Namespace

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Neodynamic.SDK.ImageDraw Namespace
Send Feedback

Classes

Class | Description
Action | An abstract base class that provides basic functionality for any descended action class.
ActionCollection | Provides a collection of Action objects that will be applied on an Element object. This class cannot be inherited.
AdjustBrightness | Defines an action that adjusts the brightness level of an image. This class cannot be inherited.
AdjustContrast | Defines an action that adjusts the contrast level of an image. This class cannot be inherited.
AdjustGamma | Defines an action that adjusts the gamma correction value of an image. This class cannot be inherited.
AdjustHSL | Defines an action that adjusts the Hue channel, saturation, and lightness levels of an image. This class cannot be inherited.
AdjustHue | Defines an action that adjusts the Hue channel of an image. This class cannot be inherited.
AdjustOpacity | Defines an action that adjusts the opacity level of an image. This class cannot be inherited.
AdjustSaturation | Defines an action that adjusts the saturation level of an image. This class cannot be inherited.
BitmapMask | It defines an action that allows performing alpha channel bitmap masking on an Element. Bitmap Masking means that the pixels of a mask object affect the visibility of the underlying object. This class cannot be inherited.
BlendPercentagesConverter | Converts integer objects from one data type to another. Access the BlendPercentagesConverter class through the TypeDescriptor object.
CalloutShapeElement | Represents a callout (a.k.a. speech bubble) shape element.
CameraView | Defines an action that simulates the camera view on an element. This class cannot be inherited.
Canvas | Represents the surface on which Element objects are drawn.
CanvasConverter | Converts Canvas objects from one data type to another. Access the CanvasConverter class through the TypeDescriptor object.
ClosedShapeElement | An abstract base class that provides basic functionality for any descended closed shape element class.
ColorSubstitution | Defines an action that replaces one color (old color) with another (new color) on an element. This class cannot be inherited.
ConvertToBlackWhite | Defines an action that converts an element to black/white or monochrome. This class cannot be inherited.
ConvertToGrayscale | Defines an action that converts an image to grayscale. This class cannot be inherited.
ConvertToNegative | Defines an action that converts an image to negative. This class cannot be inherited.
ConvertToSepia | Defines an action that converts an image to sepia. This class cannot be inherited.
Crop | Defines an action that crops a rectangular section from an image. This class cannot be inherited.
DecorativeBorder | Defines an action that adds decorative border to an image. This class cannot be inherited.
DistortCorners | Defines an action that distorts an element by changing the coordinates of the four corners defined by the element's boundaries. This class cannot be inherited.
DropShadow | Defines an action that adds drop shadows to an image. This class cannot be inherited.
Element | An abstract base class that provides basic functionality for any descended element class.
ElementCollection | Provides a collection of Element objects.
Emboss | Defines an action that embosses an element. This class cannot be inherited.
Fade | It defines an action that performs fading. Fading action/effect gradually fades a given area/region of the target Element into the background. This class cannot be inherited.
Feather | It defines an action that performs feathering. Feathering blurs the edges of a given area/region on the target Element, blending it into the background. This class cannot be inherited.
Fill | Defines a Fill object used to paint the interior of the given graphical element.
FillConverter | Converts Fill objects from one data type to another. Access the FillConverter class through the TypeDescriptor object.
Filmstrip | Defines an action that creates a Filmstrip representation of an image. This class cannot be inherited.
Flip | Defines an action that flips an image across its vertical or horizontal axis. This class cannot be inherited.
FocalGrayscale | It defines an action that creates grayscale element with a colored focal point represented by a shape. This class cannot be inherited.
FocalPixelate | It defines an action that creates pixelated element with a non-pixelated focal point represented by a shape. This class cannot be inherited.
FocalSoften | It defines an action that creates soften element with a focal point represented by a shape. This class cannot be inherited.
FocalTint | It defines an action that creates tinted look of an element with a focal point represented by a shape. This class cannot be inherited.
Font | Encapsulates the font properties of text.
FontConverter | Converts Font objects from one data type to another. Access the FontConverter class through the TypeDescriptor object.
GaussianBlur | Defines an action that softens the look of an element. Gaussian Blur applies a weighted average of blur to each pixel producing a hazy effect. This class cannot be inherited.
GlassTable | It defines an action that creates a glass table effect on an image. The glass table effect adds a reflection of an image just below it. This class cannot be inherited.
Glow | Defines an action that adds glow effect to an image. This class cannot be inherited.
GradientColorsConverter | Converts Color objects from one data type to another. Access the GradientColorsConverter class through the TypeDescriptor object.
ImageDraw | ImageDraw generates dynamic composite images to your .NET applications.
ImageElement | Represents an image element.
ImageMetaDataReader | Extract image metadata like EXIF
LineShapeElement | Represents a line shape element.
MailStamp | Defines an action that creates a mail stamp representation of an image. This class cannot be inherited.
MakeTransparent | Defines an action that makes transparent color for an image. This class cannot be inherited.
MonochromeSettings | Defines monochrome settings used for Black/White and WBMP conversion.
MuseumMatteFrame | Defines an action that adds shadowed matte frame to an element. This class cannot be inherited.
OvalShapeElement | Represents an oval shape element.
Padding | Represents padding information
PaddingConverter | Converts Padding objects from one data type to another. Access the PaddingConverter class through the TypeDescriptor object.
PathShapeElement | Represents a path shape element.
PerspectiveReflection | Defines an action that adds perspective reflection to an element. This class cannot be inherited.
PerspectiveShadow | Defines an action that adds perspective shadows to an element. This class cannot be inherited.
PerspectiveView | Defines an action that simulates a perspective view of an element. This class cannot be inherited.
Pixelate | Defines an action that pixelates an element. This class cannot be inherited.
Polaroid | Defines an action that creates a polaroid representation of an image. This class cannot be inherited.
PolygonShapeElement | Represents a polygon shape element.
QuadrilateralPoints | Represents the four points of a quadrilateral shape.
RectangleShapeElement | Represents a rectangle shape element.
RedEyeAreasConverter | Converts RedEyeArea objects from one data type to another. Access the RedEyeAreasConverter class through the TypeDescriptor object.
RedEyeRemoval | Defines an action that performs Red-Eye removal from an image. This class cannot be inherited.
RemovePixel | Defines an action that removes pixels from an element and automatically resizes it. This class cannot be inherited.
RemoveTransparency | Defines an action that removes transparent pixels from an element and automatically resizes it. This class cannot be inherited.
Resize | Defines an action that changes the size of an image. This class cannot be inherited.
RichTextElement | Represents a rich text element.
Rotate | Defines an action that rotates an image. When rotated, an image pivots on its center point. This class cannot be inherited.
RoundCorners | Defines an action that rounds image corners. This class cannot be inherited.
Scale | Defines an action that enlarges or reduces the size of an image. This class cannot be inherited.
ShapeElement | An abstract base class that provides basic functionality for any descended shape element class.
Sharpen | Defines an action that sharpen an element trying to enhance the overall visual impression. This class cannot be inherited.
Silhouette | Defines an action that creates a Silhouette of an image. This class cannot be inherited.
Skew | Defines an action that skews an element. Skewing an element transforms it by slanting it along the horizontal or vertical axis. When skewed, an element pivots on its origin point. This class cannot be inherited.
Solarize | Defines an action that solarizes an element. This class cannot be inherited.
StarShapeElement | Represents a star shape element.
Stretch | Defines an action that stretches an image to fit a given size. This class cannot be inherited.
TextElement | Represents a text element.
TextSpan | A TextSpan is used to indicate a text inline container.
Tint | Defines an action that creates a tinted look of an element. This class cannot be inherited.
WordArtElement | Represents a WordArt element.
WordArtShape | Defines a WordArtShape object used to warp an element.
WordArtShapeConverter | Converts WordArtShape objects from one data type to another. Access the WordArtShapeConverter class through the TypeDescriptor object.

Structures

Structure | Description
RedEyeArea | Stores information of a rectangular area for applying red-eye removal. Information includes the location and size of the red-eye rectangular area as well as a threshold.

Enumerations

Enumeration | Description
BitmapMaskLocation | Specifies how the bitmap mask object will be positioned on the target element.
CalloutType | Specifies the shape type used for callouts.
CircleTextLayout | Specifies how the text is layout when using Circle-based paths for warping.
ColorDepth | Specifies the format of the color data for each pixel in the output image.
Corners | Specifies what corners will be rounded.
DitherMethod | Specifies the dithering method to be used for Black/White conversion.
ExifTags | Specifies the Exif (Exchangeable Image File Format) tags based on Exif v2.2 (JEITA CP-3451)
FadeLocation | Specifies how the area/region's shape used for fading will be positioned.
FadeShape | Specifies the area/region's shape used for fading.
FadeSizing | Specifies the area/region's size type used for fading.
FeatherShape | Specifies the area/region's shape used for feathering.
FeatherSizing | Specifies the area/region's size type used for feathering.
FillType | Specifies the Fill type to use.
FilmstripOrientation | Specifies the orientation of a Filmstrip
FlipType | Specifies the direction used to flip an image
FocalLocation | Specifies how the area/region's shape used for creating the focal point will be positioned.
FocalShape | Specifies the area/region's shape used for creating the focal point.
FocalSizing | Specifies the area/region's size type used for creating the focal point.
FontUnit | Specifies the unit of measure for Font objects.
GradientShade | Specifies the shading style used for creating gradient fills.
GradientShape | Specifies the shape used for creating gradient fills.
HorizontalAlignment | Specifies how an object or text is horizontally aligned.
ImageDrawFormat | Specifies the format of the output image.
ImageSource | Specifies the source for an ImageElement object
LineCapStyle | Specifies the available cap styles used to start and end a line element.
LineOrientation | Specifies the orientation for line shape elements.
LockAspectRatio | Specifies how element's proportions are maintained.
PerspectiveOrientation | Specifies the prespective view orientation.
ReflectionLocation | Specifies how the reflection of the image will be positioned.
ScanDirection | Specifies the direction of the pixel scanning process.
SkewOrientation | Specifies the direction used to skew an element.
SkewType | Specifies the shape used to skew an element.
TextSizing | Specifies the text sizing.
WarpShape | Specifies the shape used for warping.
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Action Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Action Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended action class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract class Action : IStateManager
Visual Basic (Declaration)
Public MustInherit Class Action _
    Implements IStateManager
Visual C++
public ref class Action abstract : IStateManager

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustBrightness
Neodynamic.SDK.ImageDraw..::.AdjustContrast
Neodynamic.SDK.ImageDraw..::.AdjustGamma
Neodynamic.SDK.ImageDraw..::.AdjustHSL
Neodynamic.SDK.ImageDraw..::.AdjustHue
Neodynamic.SDK.ImageDraw..::.AdjustOpacity
Neodynamic.SDK.ImageDraw..::.AdjustSaturation
Neodynamic.SDK.ImageDraw..::.BitmapMask
Neodynamic.SDK.ImageDraw..::.CameraView
Neodynamic.SDK.ImageDraw..::.ColorSubstitution
Neodynamic.SDK.ImageDraw..::.ConvertToBlackWhite
Neodynamic.SDK.ImageDraw..::.ConvertToGrayscale
Neodynamic.SDK.ImageDraw..::.ConvertToNegative
Neodynamic.SDK.ImageDraw..::.ConvertToSepia
Neodynamic.SDK.ImageDraw..::.Crop
Neodynamic.SDK.ImageDraw..::.DecorativeBorder
Neodynamic.SDK.ImageDraw..::.DistortCorners
Neodynamic.SDK.ImageDraw..::.DropShadow
Neodynamic.SDK.ImageDraw..::.Emboss
Neodynamic.SDK.ImageDraw..::.Fade
Neodynamic.SDK.ImageDraw..::.Feather
Neodynamic.SDK.ImageDraw..::.Filmstrip
Neodynamic.SDK.ImageDraw..::.Flip
Neodynamic.SDK.ImageDraw..::.FocalGrayscale
Neodynamic.SDK.ImageDraw..::.FocalPixelate
Neodynamic.SDK.ImageDraw..::.FocalSoften
Neodynamic.SDK.ImageDraw..::.FocalTint
Neodynamic.SDK.ImageDraw..::.GaussianBlur
Neodynamic.SDK.ImageDraw..::.GlassTable
Neodynamic.SDK.ImageDraw..::.Glow
Neodynamic.SDK.ImageDraw..::.MailStamp
Neodynamic.SDK.ImageDraw..::.MakeTransparent
Neodynamic.SDK.ImageDraw..::.MuseumMatteFrame
Neodynamic.SDK.ImageDraw..::.PerspectiveReflection
Neodynamic.SDK.ImageDraw..::.PerspectiveShadow
Neodynamic.SDK.ImageDraw..::.PerspectiveView
Neodynamic.SDK.ImageDraw..::.Pixelate
Neodynamic.SDK.ImageDraw..::.Polaroid
Neodynamic.SDK.ImageDraw..::.RedEyeRemoval
Neodynamic.SDK.ImageDraw..::.RemovePixel
Neodynamic.SDK.ImageDraw..::.RemoveTransparency
Neodynamic.SDK.ImageDraw..::.Resize
Neodynamic.SDK.ImageDraw..::.Rotate
Neodynamic.SDK.ImageDraw..::.RoundCorners
Neodynamic.SDK.ImageDraw..::.Scale
Neodynamic.SDK.ImageDraw..::.Sharpen
Neodynamic.SDK.ImageDraw..::.Silhouette
Neodynamic.SDK.ImageDraw..::.Skew
Neodynamic.SDK.ImageDraw..::.Solarize
Neodynamic.SDK.ImageDraw..::.Stretch
Neodynamic.SDK.ImageDraw..::.Tint

See Also

Action Members
Neodynamic.SDK.ImageDraw Namespace


Action Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Action Members
Action Class Methods See Also Send Feedback

The Action type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Action object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Action Class


Action Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Action Methods
Action Class See Also Send Feedback

The Action type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Action object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Action Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Action..::.Clone Method
Action Class See Also Send Feedback
When overridden in a derived class, creates an exact copy of this Action object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract Action Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As Action
Visual C++
public:
virtual Action^ Clone() abstract

Return Value

The new Action object that this method creates.

See Also

Action Class


ActionCollection Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection Class
Members See Also Send Feedback
Provides a collection of Action objects that will be applied on an Element object. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class ActionCollection : IList,
    ICollection, IEnumerable
Visual Basic (Declaration)
Public NotInheritable Class ActionCollection _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ActionCollection sealed : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.ActionCollection

See Also

ActionCollection Members


ActionCollection Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection Members
ActionCollection Class Constructors Methods Properties See Also Send Feedback

The ActionCollection type exposes the following members.

Constructors

Name | Description
ActionCollection | Initializes a new instance of the ActionCollection class.

Methods

Name | Description
Add | Appends the specified Action to the end of the collection.
Clear | Removes all Action objects from the collection.
Contains | Determines whether the collection contains the specified Action.
CopyTo | Copies the items from the ActionCollection to the specified Array, starting with the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns a IEnumerator implemented object that contains all Action objects in the ActionCollection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index value that represents the position of the specified Action in the collection.
Insert | Inserts the specified Action in the collection at the specified index location.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified Action from the collection.
RemoveAt | Removes the Action at the specified index from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of Action objects in the collection.
IsSynchronized | Gets a value indicating whether access to the ActionCollection is synchronized (thread-safe).
Item | Gets an Action at the specified index in the collection.
SyncRoot | Gets the object that can be used to synchronize access to the ActionCollection.

See Also

ActionCollection Class


ActionCollection Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection Constructor
ActionCollection Class See Also Send Feedback
Initializes a new instance of the ActionCollection class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ActionCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ActionCollection()

See Also

ActionCollection Class


ActionCollection Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection Methods
ActionCollection Class See Also Send Feedback

The ActionCollection type exposes the following members.

Methods

Name | Description
Add | Appends the specified Action to the end of the collection.
Clear | Removes all Action objects from the collection.
Contains | Determines whether the collection contains the specified Action.
CopyTo | Copies the items from the ActionCollection to the specified Array, starting with the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns a IEnumerator implemented object that contains all Action objects in the ActionCollection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index value that represents the position of the specified Action in the collection.
Insert | Inserts the specified Action in the collection at the specified index location.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified Action from the collection.
RemoveAt | Removes the Action at the specified index from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActionCollection Class


Add Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Add Method
ActionCollection Class See Also Send Feedback
Appends the specified Action to the end of the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Add(
    Action action
)
Visual Basic (Declaration)
Public Function Add ( _
    action As Action _
) As Integer
Visual C++
public:
int Add(
    Action^ action
)

Parameters

action
Type: Neodynamic.SDK.ImageDraw..::.Action
The Action to append to the collection.

Return Value

The index position of the appended Action.

See Also

ActionCollection Class


Clear Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Clear Method
ActionCollection Class See Also Send Feedback
Removes all Action objects from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ActionCollection Class


Contains Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Contains Method
ActionCollection Class See Also Send Feedback
Determines whether the collection contains the specified Action.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Contains(
    Action action
)
Visual Basic (Declaration)
Public Function Contains ( _
    action As Action _
) As Boolean
Visual C++
public:
bool Contains(
    Action^ action
)

Parameters

action
Type: Neodynamic.SDK.ImageDraw..::.Action
An Action to search for in the collection.

Return Value

true if the collection contains the specified Action; otherwise, false.

See Also

ActionCollection Class


CopyTo Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.CopyTo Method
ActionCollection Class See Also Send Feedback
Copies the items from the ActionCollection to the specified Array, starting with the specified index.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
A zero-based Array that receives the copied items from the ActionCollection.
index
Type: System..::.Int32
The first index in the specified Array to receive the items.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

ActionCollection Class


GetEnumerator Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.GetEnumerator Method
ActionCollection Class See Also Send Feedback
Returns a IEnumerator implemented object that contains all Action objects in the ActionCollection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

A IEnumerator implemented object that contains all Action objects in the ActionCollection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ActionCollection Class


IndexOf Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.IndexOf Method
ActionCollection Class See Also Send Feedback
Determines the index value that represents the position of the specified Action in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int IndexOf(
    Action action
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    action As Action _
) As Integer
Visual C++
public:
int IndexOf(
    Action^ action
)

Parameters

action
Type: Neodynamic.SDK.ImageDraw..::.Action
An Action to search for in the collection.

Return Value

The index position of the specified Action in the collection.

See Also

ActionCollection Class


Insert Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Insert Method
ActionCollection Class See Also Send Feedback
Inserts the specified Action in the collection at the specified index location.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Insert(
    int index,
    Action action
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    action As Action _
)
Visual C++
public:
void Insert(
    int index,
    Action^ action
)

Parameters

index
Type: System..::.Int32
The location in the collection to insert the Action.
action
Type: Neodynamic.SDK.ImageDraw..::.Action
The Action to add to the collection.

See Also

ActionCollection Class


Remove Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Remove Method
ActionCollection Class See Also Send Feedback
Removes the specified Action from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Remove(
    Action action
)
Visual Basic (Declaration)
Public Sub Remove ( _
    action As Action _
)
Visual C++
public:
void Remove(
    Action^ action
)

Parameters

action
Type: Neodynamic.SDK.ImageDraw..::.Action
The Action to remove from the collection.

See Also

ActionCollection Class


RemoveAt Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.RemoveAt Method
ActionCollection Class See Also Send Feedback
Removes the Action at the specified index from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the Action to remove.

See Also

ActionCollection Class


ActionCollection Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection Properties
ActionCollection Class See Also Send Feedback

The ActionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of Action objects in the collection.
IsSynchronized | Gets a value indicating whether access to the ActionCollection is synchronized (thread-safe).
Item | Gets an Action at the specified index in the collection.
SyncRoot | Gets the object that can be used to synchronize access to the ActionCollection.

See Also

ActionCollection Class


Count Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Count Property
ActionCollection Class See Also Send Feedback
Gets the number of Action objects in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

ActionCollection Class


IsSynchronized Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.IsSynchronized Property
ActionCollection Class See Also Send Feedback
Gets a value indicating whether access to the ActionCollection is synchronized (thread-safe).

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

ActionCollection Class


Item Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.Item Property
ActionCollection Class See Also Send Feedback
Gets an Action at the specified index in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Action this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Action
Visual C++
public:
property Action^ default[int index] {
    Action^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ActionCollection Class


SyncRoot Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ActionCollection..::.SyncRoot Property
ActionCollection Class See Also Send Feedback
Gets the object that can be used to synchronize access to the ActionCollection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

ActionCollection Class


AdjustBrightness Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Class
Members See Also Send Feedback
Defines an action that adjusts the brightness level of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustBrightness : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustBrightness _
    Inherits Action
Visual C++
public ref class AdjustBrightness sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustBrightness

See Also

AdjustBrightness Members


AdjustBrightness Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Members
AdjustBrightness Class Constructors Methods Properties See Also Send Feedback

The AdjustBrightness type exposes the following members.

Constructors

Name | Description
AdjustBrightness | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustBrightness. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Level | Gets or sets the Brightness Level. Values range from -100 to 100.

See Also

AdjustBrightness Class


AdjustBrightness Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Constructor
AdjustBrightness Class See Also Send Feedback

Overload List

Name | Description
AdjustBrightness()()() | Initializes a new instance of the AdjustBrightness class.
AdjustBrightness(Int32) | Initializes a new instance of the AdjustBrightness class with a Brightness Level.

See Also

AdjustBrightness Class
AdjustBrightness Members


AdjustBrightness Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Constructor
AdjustBrightness Class See Also Send Feedback
Initializes a new instance of the AdjustBrightness class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustBrightness()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustBrightness()

See Also

AdjustBrightness Class
AdjustBrightness Overload


AdjustBrightness Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Constructor (Int32)
AdjustBrightness Class See Also Send Feedback
Initializes a new instance of the AdjustBrightness class with a Brightness Level.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustBrightness(
    int level
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Integer _
)
Visual C++
public:
AdjustBrightness(
    int level
)

Parameters

level
Type: System..::.Int32
The Brightness Level. Values range from -100 to 100.

See Also

AdjustBrightness Class
AdjustBrightness Overload


AdjustBrightness Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Methods
AdjustBrightness Class See Also Send Feedback

The AdjustBrightness type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustBrightness. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustBrightness Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness..::.Clone Method
AdjustBrightness Class See Also Send Feedback
Creates a copy of the current AdjustBrightness.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustBrightness.

See Also

AdjustBrightness Class


AdjustBrightness Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness Properties
AdjustBrightness Class See Also Send Feedback

The AdjustBrightness type exposes the following members.

Properties

Name | Description
Level | Gets or sets the Brightness Level. Values range from -100 to 100.

See Also

AdjustBrightness Class


Level Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustBrightness..::.Level Property
AdjustBrightness Class See Also Send Feedback
Gets or sets the Brightness Level. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustBrightness Class


AdjustContrast Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Class
Members See Also Send Feedback
Defines an action that adjusts the contrast level of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustContrast : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustContrast _
    Inherits Action
Visual C++
public ref class AdjustContrast sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustContrast

See Also

AdjustContrast Members


AdjustContrast Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Members
AdjustContrast Class Constructors Methods Properties See Also Send Feedback

The AdjustContrast type exposes the following members.

Constructors

Name | Description
AdjustContrast | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustContrast. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Level | Gets or sets the Contrast Level. Values range from -100 to 100.

See Also

AdjustContrast Class


AdjustContrast Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Constructor
AdjustContrast Class See Also Send Feedback

Overload List

Name | Description
AdjustContrast()()() | Initializes a new instance of the AdjustContrast class.
AdjustContrast(Int32) | Initializes a new instance of the AdjustContrast class with a Contrast Level.

See Also

AdjustContrast Class
AdjustContrast Members


AdjustContrast Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Constructor
AdjustContrast Class See Also Send Feedback
Initializes a new instance of the AdjustContrast class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustContrast()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustContrast()

See Also

AdjustContrast Class
AdjustContrast Overload


AdjustContrast Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Constructor (Int32)
AdjustContrast Class See Also Send Feedback
Initializes a new instance of the AdjustContrast class with a Contrast Level.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustContrast(
    int level
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Integer _
)
Visual C++
public:
AdjustContrast(
    int level
)

Parameters

level
Type: System..::.Int32
The Contrast Level. Values range from -100 to 100.

See Also

AdjustContrast Class
AdjustContrast Overload


AdjustContrast Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Methods
AdjustContrast Class See Also Send Feedback

The AdjustContrast type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustContrast. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustContrast Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast..::.Clone Method
AdjustContrast Class See Also Send Feedback
Creates a copy of the current AdjustContrast.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustContrast.

See Also

AdjustContrast Class


AdjustContrast Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast Properties
AdjustContrast Class See Also Send Feedback

The AdjustContrast type exposes the following members.

Properties

Name | Description
Level | Gets or sets the Contrast Level. Values range from -100 to 100.

See Also

AdjustContrast Class


Level Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustContrast..::.Level Property
AdjustContrast Class See Also Send Feedback
Gets or sets the Contrast Level. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustContrast Class


AdjustGamma Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Class
Members See Also Send Feedback
Defines an action that adjusts the gamma correction value of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustGamma : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustGamma _
    Inherits Action
Visual C++
public ref class AdjustGamma sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustGamma

See Also

AdjustGamma Members


AdjustGamma Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Members
AdjustGamma Class Constructors Methods Properties See Also Send Feedback

The AdjustGamma type exposes the following members.

Constructors

Name | Description
AdjustGamma | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustGamma. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Gamma | Gets or sets the Gamma correction value. Values range from -100 to 100.

See Also

AdjustGamma Class


AdjustGamma Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Constructor
AdjustGamma Class See Also Send Feedback

Overload List

Name | Description
AdjustGamma()()() | Initializes a new instance of the AdjustGamma class.
AdjustGamma(Int32) | Initializes a new instance of the AdjustGamma class with a Gamma correction value.

See Also

AdjustGamma Class
AdjustGamma Members


AdjustGamma Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Constructor
AdjustGamma Class See Also Send Feedback
Initializes a new instance of the AdjustGamma class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustGamma()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustGamma()

See Also

AdjustGamma Class
AdjustGamma Overload


AdjustGamma Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Constructor (Int32)
AdjustGamma Class See Also Send Feedback
Initializes a new instance of the AdjustGamma class with a Gamma correction value.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustGamma(
    int gamma
)
Visual Basic (Declaration)
Public Sub New ( _
    gamma As Integer _
)
Visual C++
public:
AdjustGamma(
    int gamma
)

Parameters

gamma
Type: System..::.Int32
The Gamma correction. Values range from -100 to 100.

See Also

AdjustGamma Class
AdjustGamma Overload


AdjustGamma Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Methods
AdjustGamma Class See Also Send Feedback

The AdjustGamma type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustGamma. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustGamma Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma..::.Clone Method
AdjustGamma Class See Also Send Feedback
Creates a copy of the current AdjustGamma.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustGamma.

See Also

AdjustGamma Class


AdjustGamma Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma Properties
AdjustGamma Class See Also Send Feedback

The AdjustGamma type exposes the following members.

Properties

Name | Description
Gamma | Gets or sets the Gamma correction value. Values range from -100 to 100.

See Also

AdjustGamma Class


Gamma Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustGamma..::.Gamma Property
AdjustGamma Class See Also Send Feedback
Gets or sets the Gamma correction value. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Gamma { get; set; }
Visual Basic (Declaration)
Public Property Gamma As Integer
Visual C++
public:
property int Gamma {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustGamma Class


AdjustHSL Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Class
Members See Also Send Feedback
Defines an action that adjusts the Hue channel, saturation, and lightness levels of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustHSL : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustHSL _
    Inherits Action
Visual C++
public ref class AdjustHSL sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustHSL

See Also

AdjustHSL Members


AdjustHSL Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Members
AdjustHSL Class Constructors Methods Properties See Also Send Feedback

The AdjustHSL type exposes the following members.

Constructors

Name | Description
AdjustHSL | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustHSL. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Hue | Gets or sets the Hue angle. Values range from -180 to 180.
Lightness | Gets or sets the Lightness Level. Values range from -100 to 100.
Saturation | Gets or sets the Saturation Level. Values range from -100 to 100.

See Also

AdjustHSL Class


AdjustHSL Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Constructor
AdjustHSL Class See Also Send Feedback

Overload List

Name | Description
AdjustHSL()()() | Initializes a new instance of the AdjustHSL class.
AdjustHSL(Int32, Int32, Int32) | Initializes a new instance of the AdjustHSL class with a hue angle.

See Also

AdjustHSL Class
AdjustHSL Members


AdjustHSL Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Constructor
AdjustHSL Class See Also Send Feedback
Initializes a new instance of the AdjustHSL class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustHSL()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustHSL()

See Also

AdjustHSL Class
AdjustHSL Overload


AdjustHSL Constructor (Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Constructor (Int32, Int32, Int32)
AdjustHSL Class See Also Send Feedback
Initializes a new instance of the AdjustHSL class with a hue angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustHSL(
    int hue,
    int saturation,
    int lightness
)
Visual Basic (Declaration)
Public Sub New ( _
    hue As Integer, _
    saturation As Integer, _
    lightness As Integer _
)
Visual C++
public:
AdjustHSL(
    int hue,
    int saturation,
    int lightness
)

Parameters

hue
Type: System..::.Int32
The Hue angle. Values range from -180 to 180.
saturation
Type: System..::.Int32
The Saturation Level. Values range from -100 to 100.
lightness
Type: System..::.Int32
The Lightness Level. Values range from -100 to 100.

See Also

AdjustHSL Class
AdjustHSL Overload


AdjustHSL Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Methods
AdjustHSL Class See Also Send Feedback

The AdjustHSL type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustHSL. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustHSL Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL..::.Clone Method
AdjustHSL Class See Also Send Feedback
Creates a copy of the current AdjustHSL.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustHSL.

See Also

AdjustHSL Class


AdjustHSL Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL Properties
AdjustHSL Class See Also Send Feedback

The AdjustHSL type exposes the following members.

Properties

Name | Description
Hue | Gets or sets the Hue angle. Values range from -180 to 180.
Lightness | Gets or sets the Lightness Level. Values range from -100 to 100.
Saturation | Gets or sets the Saturation Level. Values range from -100 to 100.

See Also

AdjustHSL Class


Hue Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL..::.Hue Property
AdjustHSL Class See Also Send Feedback
Gets or sets the Hue angle. Values range from -180 to 180.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Hue { get; set; }
Visual Basic (Declaration)
Public Property Hue As Integer
Visual C++
public:
property int Hue {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -180 to 180.

See Also

AdjustHSL Class


Lightness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL..::.Lightness Property
AdjustHSL Class See Also Send Feedback
Gets or sets the Lightness Level. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Lightness { get; set; }
Visual Basic (Declaration)
Public Property Lightness As Integer
Visual C++
public:
property int Lightness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustHSL Class


Saturation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHSL..::.Saturation Property
AdjustHSL Class See Also Send Feedback
Gets or sets the Saturation Level. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Saturation { get; set; }
Visual Basic (Declaration)
Public Property Saturation As Integer
Visual C++
public:
property int Saturation {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustHSL Class


AdjustHue Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Class
Members See Also Send Feedback
Defines an action that adjusts the Hue channel of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustHue : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustHue _
    Inherits Action
Visual C++
public ref class AdjustHue sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustHue

See Also

AdjustHue Members


AdjustHue Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Members
AdjustHue Class Constructors Methods Properties See Also Send Feedback

The AdjustHue type exposes the following members.

Constructors

Name | Description
AdjustHue | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustHue. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the Hue angle. Values range from -180 to 180.

See Also

AdjustHue Class


AdjustHue Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Constructor
AdjustHue Class See Also Send Feedback

Overload List

Name | Description
AdjustHue()()() | Initializes a new instance of the AdjustHue class.
AdjustHue(Int32) | Initializes a new instance of the AdjustHue class with a hue angle.

See Also

AdjustHue Class
AdjustHue Members


AdjustHue Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Constructor
AdjustHue Class See Also Send Feedback
Initializes a new instance of the AdjustHue class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustHue()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustHue()

See Also

AdjustHue Class
AdjustHue Overload


AdjustHue Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Constructor (Int32)
AdjustHue Class See Also Send Feedback
Initializes a new instance of the AdjustHue class with a hue angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustHue(
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    angle As Integer _
)
Visual C++
public:
AdjustHue(
    int angle
)

Parameters

angle
Type: System..::.Int32
The Hue angle. Values range from -180 to 180.

See Also

AdjustHue Class
AdjustHue Overload


AdjustHue Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Methods
AdjustHue Class See Also Send Feedback

The AdjustHue type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustHue. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustHue Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue..::.Clone Method
AdjustHue Class See Also Send Feedback
Creates a copy of the current AdjustHue.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustHue.

See Also

AdjustHue Class


AdjustHue Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue Properties
AdjustHue Class See Also Send Feedback

The AdjustHue type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the Hue angle. Values range from -180 to 180.

See Also

AdjustHue Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustHue..::.Angle Property
AdjustHue Class See Also Send Feedback
Gets or sets the Hue angle. Values range from -180 to 180.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -180 to 180.

See Also

AdjustHue Class


AdjustOpacity Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Class
Members See Also Send Feedback
Defines an action that adjusts the opacity level of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustOpacity : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustOpacity _
    Inherits Action
Visual C++
public ref class AdjustOpacity sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustOpacity

See Also

AdjustOpacity Members


AdjustOpacity Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Members
AdjustOpacity Class Constructors Methods Properties See Also Send Feedback

The AdjustOpacity type exposes the following members.

Constructors

Name | Description
AdjustOpacity | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustOpacity. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Opacity | Gets or sets the Opacity Level. Values range from 0 to 100.

See Also

AdjustOpacity Class


AdjustOpacity Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Constructor
AdjustOpacity Class See Also Send Feedback

Overload List

Name | Description
AdjustOpacity()()() | Initializes a new instance of the AdjustOpacity class.
AdjustOpacity(Int32) | Initializes a new instance of the AdjustOpacity class with a Opacity Level.

See Also

AdjustOpacity Class
AdjustOpacity Members


AdjustOpacity Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Constructor
AdjustOpacity Class See Also Send Feedback
Initializes a new instance of the AdjustOpacity class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustOpacity()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustOpacity()

See Also

AdjustOpacity Class
AdjustOpacity Overload


AdjustOpacity Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Constructor (Int32)
AdjustOpacity Class See Also Send Feedback
Initializes a new instance of the AdjustOpacity class with a Opacity Level.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustOpacity(
    int opacity
)
Visual Basic (Declaration)
Public Sub New ( _
    opacity As Integer _
)
Visual C++
public:
AdjustOpacity(
    int opacity
)

Parameters

opacity
Type: System..::.Int32
The Opacity Level. Values range from 0 to 100.

See Also

AdjustOpacity Class
AdjustOpacity Overload


AdjustOpacity Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Methods
AdjustOpacity Class See Also Send Feedback

The AdjustOpacity type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustOpacity. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustOpacity Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity..::.Clone Method
AdjustOpacity Class See Also Send Feedback
Creates a copy of the current AdjustOpacity.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustOpacity.

See Also

AdjustOpacity Class


AdjustOpacity Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity Properties
AdjustOpacity Class See Also Send Feedback

The AdjustOpacity type exposes the following members.

Properties

Name | Description
Opacity | Gets or sets the Opacity Level. Values range from 0 to 100.

See Also

AdjustOpacity Class


Opacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustOpacity..::.Opacity Property
AdjustOpacity Class See Also Send Feedback
Gets or sets the Opacity Level. Values range from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Integer
Visual C++
public:
property int Opacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

AdjustOpacity Class


AdjustSaturation Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Class
Members See Also Send Feedback
Defines an action that adjusts the saturation level of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class AdjustSaturation : Action
Visual Basic (Declaration)
Public NotInheritable Class AdjustSaturation _
    Inherits Action
Visual C++
public ref class AdjustSaturation sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.AdjustSaturation

See Also

AdjustSaturation Members


AdjustSaturation Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Members
AdjustSaturation Class Constructors Methods Properties See Also Send Feedback

The AdjustSaturation type exposes the following members.

Constructors

Name | Description
AdjustSaturation | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current AdjustSaturation. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Level | Gets or sets the Saturation Level. Values range from -100 to 100.

See Also

AdjustSaturation Class


AdjustSaturation Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Constructor
AdjustSaturation Class See Also Send Feedback

Overload List

Name | Description
AdjustSaturation()()() | Initializes a new instance of the AdjustSaturation class.
AdjustSaturation(Int32) | Initializes a new instance of the AdjustSaturation class with a Saturation Level.

See Also

AdjustSaturation Class
AdjustSaturation Members


AdjustSaturation Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Constructor
AdjustSaturation Class See Also Send Feedback
Initializes a new instance of the AdjustSaturation class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustSaturation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AdjustSaturation()

See Also

AdjustSaturation Class
AdjustSaturation Overload


AdjustSaturation Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Constructor (Int32)
AdjustSaturation Class See Also Send Feedback
Initializes a new instance of the AdjustSaturation class with a Saturation Level.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public AdjustSaturation(
    int level
)
Visual Basic (Declaration)
Public Sub New ( _
    level As Integer _
)
Visual C++
public:
AdjustSaturation(
    int level
)

Parameters

level
Type: System..::.Int32
The Saturation Level. Values range from -100 to 100.

See Also

AdjustSaturation Class
AdjustSaturation Overload


AdjustSaturation Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Methods
AdjustSaturation Class See Also Send Feedback

The AdjustSaturation type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current AdjustSaturation. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AdjustSaturation Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation..::.Clone Method
AdjustSaturation Class See Also Send Feedback
Creates a copy of the current AdjustSaturation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current AdjustSaturation.

See Also

AdjustSaturation Class


AdjustSaturation Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation Properties
AdjustSaturation Class See Also Send Feedback

The AdjustSaturation type exposes the following members.

Properties

Name | Description
Level | Gets or sets the Saturation Level. Values range from -100 to 100.

See Also

AdjustSaturation Class


Level Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
AdjustSaturation..::.Level Property
AdjustSaturation Class See Also Send Feedback
Gets or sets the Saturation Level. Values range from -100 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Level { get; set; }
Visual Basic (Declaration)
Public Property Level As Integer
Visual C++
public:
property int Level {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -100 to 100.

See Also

AdjustSaturation Class


BitmapMask Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask Class
Members See Also Send Feedback
It defines an action that allows performing alpha channel bitmap masking on an Element. Bitmap Masking means that the pixels of a mask object affect the visibility of the underlying object. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class BitmapMask : Action
Visual Basic (Declaration)
Public NotInheritable Class BitmapMask _
    Inherits Action
Visual C++
public ref class BitmapMask sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.BitmapMask

See Also

BitmapMask Members


BitmapMask Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask Members
BitmapMask Class Constructors Methods Properties See Also Send Feedback

The BitmapMask type exposes the following members.

Constructors

Name | Description
BitmapMask | Initializes a new instance of the BitmapMask class.

Methods

Name | Description
Clone | Creates a copy of the current BitmapMask. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
MaskBase64 | Gets or sets the Base64 string of the bitmap mask content.
MaskBinary | Gets or sets the binary content of the bitmap mask.
MaskBinaryOffset | Gets or sets the number of bytes that must be skipped on the source image when generating the bitmap mask based on the MaskBinary property
MaskFile | Gets or sets the bitmap mask file path or URL.
MaskImage | Gets or sets the content of the bitmap mask.
MaskLocation | Gets or sets how the bitmap mask object will be positioned on the target element. If it is Center, then the bitmap mask object will be centered on the target element; otherwise, the bitmap mask position must be specified by MaskLocationX and MaskLocationY properties.
MaskLocationX | Gets or sets the x-coordinate of the left side of the bitmap mask object.
MaskLocationY | Gets or sets the y-coordinate of the top side of the bitmap mask object.

See Also

BitmapMask Class


BitmapMask Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask Constructor
BitmapMask Class See Also Send Feedback
Initializes a new instance of the BitmapMask class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public BitmapMask()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BitmapMask()

See Also

BitmapMask Class


BitmapMask Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask Methods
BitmapMask Class See Also Send Feedback

The BitmapMask type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current BitmapMask. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BitmapMask Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.Clone Method
BitmapMask Class See Also Send Feedback
Creates a copy of the current BitmapMask.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current BitmapMask.

See Also

BitmapMask Class


BitmapMask Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask Properties
BitmapMask Class See Also Send Feedback

The BitmapMask type exposes the following members.

Properties

Name | Description
MaskBase64 | Gets or sets the Base64 string of the bitmap mask content.
MaskBinary | Gets or sets the binary content of the bitmap mask.
MaskBinaryOffset | Gets or sets the number of bytes that must be skipped on the source image when generating the bitmap mask based on the MaskBinary property
MaskFile | Gets or sets the bitmap mask file path or URL.
MaskImage | Gets or sets the content of the bitmap mask.
MaskLocation | Gets or sets how the bitmap mask object will be positioned on the target element. If it is Center, then the bitmap mask object will be centered on the target element; otherwise, the bitmap mask position must be specified by MaskLocationX and MaskLocationY properties.
MaskLocationX | Gets or sets the x-coordinate of the left side of the bitmap mask object.
MaskLocationY | Gets or sets the y-coordinate of the top side of the bitmap mask object.

See Also

BitmapMask Class


MaskBase64 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskBase64 Property
BitmapMask Class See Also Send Feedback
Gets or sets the Base64 string of the bitmap mask content.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string MaskBase64 { get; set; }
Visual Basic (Declaration)
Public Property MaskBase64 As String
Visual C++
public:
property String^ MaskBase64 {
    String^ get ();
    void set (String^ value);
}

See Also

BitmapMask Class


MaskBinary Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskBinary Property
BitmapMask Class See Also Send Feedback
Gets or sets the binary content of the bitmap mask.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] MaskBinary { get; set; }
Visual Basic (Declaration)
Public Property MaskBinary As Byte()
Visual C++
public:
property array<unsigned char>^ MaskBinary {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

BitmapMask Class


MaskBinaryOffset Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskBinaryOffset Property
BitmapMask Class See Also Send Feedback
Gets or sets the number of bytes that must be skipped on the source image when generating the bitmap mask based on the MaskBinary property

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int MaskBinaryOffset { get; set; }
Visual Basic (Declaration)
Public Property MaskBinaryOffset As Integer
Visual C++
public:
property int MaskBinaryOffset {
    int get ();
    void set (int value);
}

See Also

BitmapMask Class


MaskFile Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskFile Property
BitmapMask Class See Also Send Feedback
Gets or sets the bitmap mask file path or URL.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string MaskFile { get; set; }
Visual Basic (Declaration)
Public Property MaskFile As String
Visual C++
public:
property String^ MaskFile {
    String^ get ();
    void set (String^ value);
}

See Also

BitmapMask Class


MaskImage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskImage Property
BitmapMask Class See Also Send Feedback
Gets or sets the content of the bitmap mask.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Image MaskImage { get; set; }
Visual Basic (Declaration)
Public Property MaskImage As Image
Visual C++
public:
property Image^ MaskImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

BitmapMask Class


MaskLocation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskLocation Property
BitmapMask Class See Also Send Feedback
Gets or sets how the bitmap mask object will be positioned on the target element. If it is Center, then the bitmap mask object will be centered on the target element; otherwise, the bitmap mask position must be specified by MaskLocationX and MaskLocationY properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public BitmapMaskLocation MaskLocation { get; set; }
Visual Basic (Declaration)
Public Property MaskLocation As BitmapMaskLocation
Visual C++
public:
property BitmapMaskLocation MaskLocation {
    BitmapMaskLocation get ();
    void set (BitmapMaskLocation value);
}

See Also

BitmapMask Class


MaskLocationX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskLocationX Property
BitmapMask Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the bitmap mask object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int MaskLocationX { get; set; }
Visual Basic (Declaration)
Public Property MaskLocationX As Integer
Visual C++
public:
property int MaskLocationX {
    int get ();
    void set (int value);
}

See Also

BitmapMask Class


MaskLocationY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMask..::.MaskLocationY Property
BitmapMask Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the bitmap mask object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int MaskLocationY { get; set; }
Visual Basic (Declaration)
Public Property MaskLocationY As Integer
Visual C++
public:
property int MaskLocationY {
    int get ();
    void set (int value);
}

See Also

BitmapMask Class


BitmapMaskLocation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BitmapMaskLocation Enumeration
See Also Send Feedback
Specifies how the bitmap mask object will be positioned on the target element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum BitmapMaskLocation
Visual Basic (Declaration)
Public Enumeration BitmapMaskLocation
Visual C++
public enum class BitmapMaskLocation

Members

Member name | Description
Center | The bitmap mask object will be centered on the target element.
Custom | The bitmap mask object position must be specified by MaskLocationX and MaskLocationY properties.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


BlendPercentagesConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter Class
Members See Also Send Feedback
Converts integer objects from one data type to another. Access the BlendPercentagesConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class BlendPercentagesConverter : TypeConverter
Visual Basic (Declaration)
Public Class BlendPercentagesConverter _
    Inherits TypeConverter
Visual C++
public ref class BlendPercentagesConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Neodynamic.SDK.ImageDraw..::.BlendPercentagesConverter

See Also

BlendPercentagesConverter Members


BlendPercentagesConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter Members
BlendPercentagesConverter Class Constructors Methods See Also Send Feedback

The BlendPercentagesConverter type exposes the following members.

Constructors

Name | Description
BlendPercentagesConverter | Initializes a new instance of the BlendPercentagesConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlendPercentagesConverter Class


BlendPercentagesConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter Constructor
BlendPercentagesConverter Class See Also Send Feedback
Initializes a new instance of the BlendPercentagesConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public BlendPercentagesConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
BlendPercentagesConverter()

See Also

BlendPercentagesConverter Class


BlendPercentagesConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter Methods
BlendPercentagesConverter Class See Also Send Feedback

The BlendPercentagesConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BlendPercentagesConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.CanConvertFrom Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
BlendPercentagesConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

BlendPercentagesConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.CanConvertTo Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
BlendPercentagesConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

BlendPercentagesConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertFrom Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
BlendPercentagesConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

BlendPercentagesConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertFromInvariantString Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertFromString Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertTo Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
BlendPercentagesConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

BlendPercentagesConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertToInvariantString Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.ConvertToString Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.CreateInstance Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetCreateInstanceSupported Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetProperties Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetPropertiesSupported Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetStandardValues Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetStandardValuesExclusive Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.GetStandardValuesSupported Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
BlendPercentagesConverter..::.IsValid Method
BlendPercentagesConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

BlendPercentagesConverter Class
BlendPercentagesConverter Members


CalloutShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Class
Members See Also Send Feedback
Represents a callout (a.k.a. speech bubble) shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class CalloutShapeElement : ClosedShapeElement
Visual Basic (Declaration)
Public Class CalloutShapeElement _
    Inherits ClosedShapeElement
Visual C++
public ref class CalloutShapeElement : public ClosedShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.CalloutShapeElement

See Also

CalloutShapeElement Members


CalloutShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Members
CalloutShapeElement Class Constructors Methods Properties See Also Send Feedback

The CalloutShapeElement type exposes the following members.

Constructors

Name | Description
CalloutShapeElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current CalloutShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
CalloutArrowX | Gets or sets the x-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.
CalloutArrowY | Gets or sets the y-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.
CalloutType | Gets or sets the callout shape.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | (Overrides ShapeElement..::.StrokeLineJoinStyle.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

CalloutShapeElement Class


CalloutShapeElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Constructor
CalloutShapeElement Class See Also Send Feedback

Overload List

Name | Description
CalloutShapeElement()()() | Initializes a new instance of the CalloutShapeElement class.
CalloutShapeElement(Int32, Int32, Int32, Int32) | Initializes a new instance of the CalloutShapeElement class with the specified size.

See Also

CalloutShapeElement Class
CalloutShapeElement Members


CalloutShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Constructor
CalloutShapeElement Class See Also Send Feedback
Initializes a new instance of the CalloutShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CalloutShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CalloutShapeElement()

See Also

CalloutShapeElement Class
CalloutShapeElement Overload


CalloutShapeElement Constructor (Int32, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Constructor (Int32, Int32, Int32, Int32)
CalloutShapeElement Class See Also Send Feedback
Initializes a new instance of the CalloutShapeElement class with the specified size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CalloutShapeElement(
    int width,
    int height,
    int calloutPointX,
    int calloutPointY
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    calloutPointX As Integer, _
    calloutPointY As Integer _
)
Visual C++
public:
CalloutShapeElement(
    int width,
    int height,
    int calloutPointX,
    int calloutPointY
)

Parameters

width
Type: System..::.Int32
The width of the callout shape.
height
Type: System..::.Int32
The height of the callout shape.
calloutPointX
Type: System..::.Int32
calloutPointY
Type: System..::.Int32

See Also

CalloutShapeElement Class
CalloutShapeElement Overload


CalloutShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Methods
CalloutShapeElement Class See Also Send Feedback

The CalloutShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current CalloutShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

CalloutShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.Clone Method
CalloutShapeElement Class See Also Send Feedback
Creates a copy of the current CalloutShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current CalloutShapeElement.

See Also

CalloutShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.GetOutputImage Method
CalloutShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

CalloutShapeElement Class
CalloutShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.GetOutputImageBinary Method
CalloutShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

CalloutShapeElement Class
CalloutShapeElement Members


CalloutShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement Properties
CalloutShapeElement Class See Also Send Feedback

The CalloutShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
CalloutArrowX | Gets or sets the x-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.
CalloutArrowY | Gets or sets the y-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.
CalloutType | Gets or sets the callout shape.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | (Overrides ShapeElement..::.StrokeLineJoinStyle.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

CalloutShapeElement Class


CalloutArrowX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.CalloutArrowX Property
CalloutShapeElement Class See Also Send Feedback
Gets or sets the x-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CalloutArrowX { get; set; }
Visual Basic (Declaration)
Public Property CalloutArrowX As Integer
Visual C++
public:
property int CalloutArrowX {
    int get ();
    void set (int value);
}

See Also

CalloutShapeElement Class


CalloutArrowY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.CalloutArrowY Property
CalloutShapeElement Class See Also Send Feedback
Gets or sets the y-coordinate of the arrow tip. NOTE: The coordinate is relative to the callout boundary being x = 0, y = 0 the upper-left corner and x = Width, y = Height the bottom-lower corner.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CalloutArrowY { get; set; }
Visual Basic (Declaration)
Public Property CalloutArrowY As Integer
Visual C++
public:
property int CalloutArrowY {
    int get ();
    void set (int value);
}

See Also

CalloutShapeElement Class


CalloutType Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.CalloutType Property
CalloutShapeElement Class See Also Send Feedback
Gets or sets the callout shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CalloutType CalloutType { get; set; }
Visual Basic (Declaration)
Public Property CalloutType As CalloutType
Visual C++
public:
property CalloutType CalloutType {
    CalloutType get ();
    void set (CalloutType value);
}

See Also

CalloutShapeElement Class


StrokeLineJoinStyle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutShapeElement..::.StrokeLineJoinStyle Property
CalloutShapeElement Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override LineJoin StrokeLineJoinStyle { get; set; }
Visual Basic (Declaration)
Public Overrides Property StrokeLineJoinStyle As LineJoin
Visual C++
public:
virtual property LineJoin StrokeLineJoinStyle {
    LineJoin get () override;
    void set (LineJoin value) override;
}

See Also

CalloutShapeElement Class


CalloutType Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CalloutType Enumeration
See Also Send Feedback
Specifies the shape type used for callouts.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum CalloutType
Visual Basic (Declaration)
Public Enumeration CalloutType
Visual C++
public enum class CalloutType

Members

Member name | Description
Rectangle |
Oval |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


CameraView Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Class
Members See Also Send Feedback
Defines an action that simulates the camera view on an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class CameraView : Action
Visual Basic (Declaration)
Public Class CameraView _
    Inherits Action
Visual C++
public ref class CameraView : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.CameraView

See Also

CameraView Members


CameraView Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Members
CameraView Class Constructors Methods Properties See Also Send Feedback

The CameraView type exposes the following members.

Constructors

Name | Description
CameraView | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current CameraView. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Azimuth | Gets or sets the horizontal rotation angle of a camera's sight line relative to the center point of an element.
Elevation | Gets or sets the vertical rotation angle of a camera's sight line relative to the center point of an element.

See Also

CameraView Class


CameraView Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Constructor
CameraView Class See Also Send Feedback

Overload List

Name | Description
CameraView()()() | Initializes a new instance of the CameraView class.
CameraView(Int32, Int32) | Initializes a new instance of the CameraView class with the specified elevation and azimuth angles.

See Also

CameraView Class
CameraView Members


CameraView Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Constructor
CameraView Class See Also Send Feedback
Initializes a new instance of the CameraView class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CameraView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CameraView()

See Also

CameraView Class
CameraView Overload


CameraView Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Constructor (Int32, Int32)
CameraView Class See Also Send Feedback
Initializes a new instance of the CameraView class with the specified elevation and azimuth angles.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CameraView(
    int elevation,
    int azimuth
)
Visual Basic (Declaration)
Public Sub New ( _
    elevation As Integer, _
    azimuth As Integer _
)
Visual C++
public:
CameraView(
    int elevation,
    int azimuth
)

Parameters

elevation
Type: System..::.Int32
The vertical rotation angle of a camera's sight line relative to the center point of an element.
azimuth
Type: System..::.Int32
The horizontal rotation angle of a camera's sight line relative to the center point of an element.

See Also

CameraView Class
CameraView Overload


CameraView Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Methods
CameraView Class See Also Send Feedback

The CameraView type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current CameraView. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CameraView Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView..::.Clone Method
CameraView Class See Also Send Feedback
Creates a copy of the current CameraView.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current CameraView.

See Also

CameraView Class


CameraView Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView Properties
CameraView Class See Also Send Feedback

The CameraView type exposes the following members.

Properties

Name | Description
Azimuth | Gets or sets the horizontal rotation angle of a camera's sight line relative to the center point of an element.
Elevation | Gets or sets the vertical rotation angle of a camera's sight line relative to the center point of an element.

See Also

CameraView Class


Azimuth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView..::.Azimuth Property
CameraView Class See Also Send Feedback
Gets or sets the horizontal rotation angle of a camera's sight line relative to the center point of an element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Azimuth { get; set; }
Visual Basic (Declaration)
Public Property Azimuth As Integer
Visual C++
public:
property int Azimuth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -180 to 180.

See Also

CameraView Class


Elevation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CameraView..::.Elevation Property
CameraView Class See Also Send Feedback
Gets or sets the vertical rotation angle of a camera's sight line relative to the center point of an element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Elevation { get; set; }
Visual Basic (Declaration)
Public Property Elevation As Integer
Visual C++
public:
property int Elevation {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -180 to 180.

See Also

CameraView Class


Canvas Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Class
Members See Also Send Feedback
Represents the surface on which Element objects are drawn.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Canvas : IStateManager
Visual Basic (Declaration)
Public Class Canvas _
    Implements IStateManager
Visual C++
public ref class Canvas : IStateManager

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Canvas

See Also

Canvas Members


Canvas Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Members
Canvas Class Constructors Methods Properties See Also Send Feedback

The Canvas type exposes the following members.

Constructors

Name | Description
Canvas | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
AutoSize | Gets or sets whether canvas expands or contracts to the size of the contents represented by Element objects
CenterElements | Gets or sets whether all elements onto canvas will be centered or not.
Fill | Gets canvas' fill.
Height | Gets or sets canvas' height.
ViewState |
Width | Gets or sets canvas' width.

See Also

Canvas Class


Canvas Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Constructor
Canvas Class See Also Send Feedback

Overload List

Name | Description
Canvas()()() | Initializes a new instance of the Canvas class.
Canvas(Int32, Int32) | Initializes a new instance of the Canvas class with the specified size.
Canvas(Int32, Int32, Fill, Boolean, Boolean) | Initializes a new instance of the Canvas class with the specified canvas' settings.

See Also

Canvas Class
Canvas Members


Canvas Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Constructor
Canvas Class See Also Send Feedback
Initializes a new instance of the Canvas class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Canvas()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Canvas()

See Also

Canvas Class
Canvas Overload


Canvas Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Constructor (Int32, Int32)
Canvas Class See Also Send Feedback
Initializes a new instance of the Canvas class with the specified size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Canvas(
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
Canvas(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32
The width of the canvas
height
Type: System..::.Int32
The height of the canvas

See Also

Canvas Class
Canvas Overload


Canvas Constructor (Int32, Int32, Fill, Boolean, Boolean)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Constructor (Int32, Int32, Fill, Boolean, Boolean)
Canvas Class See Also Send Feedback
Initializes a new instance of the Canvas class with the specified canvas' settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Canvas(
    int width,
    int height,
    Fill fill,
    bool autoSize,
    bool centerElements
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    fill As Fill, _
    autoSize As Boolean, _
    centerElements As Boolean _
)
Visual C++
public:
Canvas(
    int width,
    int height,
    Fill^ fill,
    bool autoSize,
    bool centerElements
)

Parameters

width
Type: System..::.Int32
The width of the canvas
height
Type: System..::.Int32
The height of the canvas
fill
Type: Neodynamic.SDK.ImageDraw..::.Fill
Canvas' fill represented by a Fill
autoSize
Type: System..::.Boolean
Set to true in order canvas can expand or contract to the size of the contents represented by Element objects; otherwise, false.
centerElements
Type: System..::.Boolean
Set to true in order all elements on canvas are centered; otherwise, false.

See Also

Canvas Class
Canvas Overload


Canvas Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Methods
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

See Also

Canvas Class


ToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.ToString Method
Canvas Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the Canvas object to a string representation, using the current CultureInfo. (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Converts the Canvas object to a string representation, using the specified CultureInfo.

See Also

Canvas Class
Canvas Members


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.ToString Method
Canvas Class See Also Send Feedback
Converts the Canvas object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the Canvas object in the current culture.

See Also

Canvas Class
ToString Overload


ToString Method (CultureInfo)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.ToString Method (CultureInfo)
Canvas Class See Also Send Feedback
Converts the Canvas object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public virtual string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Overridable Function ToString ( _
    culture As CultureInfo _
) As String
Visual C++
public:
virtual String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that contains the culture to represent the Canvas.

Return Value

The string representation of the Canvas object in the specified culture.

See Also

Canvas Class
ToString Overload


Canvas Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas Properties
Canvas Class See Also Send Feedback

The Canvas type exposes the following members.

Properties

Name | Description
AutoSize | Gets or sets whether canvas expands or contracts to the size of the contents represented by Element objects
CenterElements | Gets or sets whether all elements onto canvas will be centered or not.
Fill | Gets canvas' fill.
Height | Gets or sets canvas' height.
ViewState |
Width | Gets or sets canvas' width.

See Also

Canvas Class


AutoSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.AutoSize Property
Canvas Class See Also Send Feedback
Gets or sets whether canvas expands or contracts to the size of the contents represented by Element objects

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

Canvas Class


CenterElements Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.CenterElements Property
Canvas Class See Also Send Feedback
Gets or sets whether all elements onto canvas will be centered or not.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool CenterElements { get; set; }
Visual Basic (Declaration)
Public Property CenterElements As Boolean
Visual C++
public:
property bool CenterElements {
    bool get ();
    void set (bool value);
}

See Also

Canvas Class


Fill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.Fill Property
Canvas Class See Also Send Feedback
Gets canvas' fill.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
}

See Also

Canvas Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.Height Property
Canvas Class See Also Send Feedback
Gets or sets canvas' height.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 1.

See Also

Canvas Class


ViewState Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.ViewState Property
Canvas Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
protected StateBag ViewState { get; }
Visual Basic (Declaration)
Protected ReadOnly Property ViewState As StateBag
Visual C++
protected:
property StateBag^ ViewState {
    StateBag^ get ();
}

See Also

Canvas Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Canvas..::.Width Property
Canvas Class See Also Send Feedback
Gets or sets canvas' width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 1.

See Also

Canvas Class


CanvasConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter Class
Members See Also Send Feedback
Converts Canvas objects from one data type to another. Access the CanvasConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class CanvasConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class CanvasConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class CanvasConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
Neodynamic.SDK.ImageDraw..::.CanvasConverter

See Also

CanvasConverter Members


CanvasConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter Members
CanvasConverter Class Constructors Methods See Also Send Feedback

The CanvasConverter type exposes the following members.

Constructors

Name | Description
CanvasConverter | Initializes a new instance of the CanvasConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanvasConverter Class


CanvasConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter Constructor
CanvasConverter Class See Also Send Feedback
Initializes a new instance of the CanvasConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CanvasConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CanvasConverter()

See Also

CanvasConverter Class


CanvasConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter Methods
CanvasConverter Class See Also Send Feedback

The CanvasConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CanvasConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.CanConvertFrom Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

CanvasConverter Class
CanvasConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
CanvasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

CanvasConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.CanConvertTo Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

CanvasConverter Class
CanvasConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
CanvasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

CanvasConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertFrom Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

CanvasConverter Class
CanvasConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
CanvasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

CanvasConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertFromInvariantString Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertFromString Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertTo Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

CanvasConverter Class
CanvasConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
CanvasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

CanvasConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertToInvariantString Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.ConvertToString Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.CreateInstance Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetCreateInstanceSupported Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetProperties Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetPropertiesSupported Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetStandardValues Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetStandardValuesExclusive Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.GetStandardValuesSupported Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
CanvasConverter..::.IsValid Method
CanvasConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

CanvasConverter Class
CanvasConverter Members


CircleTextLayout Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
CircleTextLayout Enumeration
See Also Send Feedback
Specifies how the text is layout when using Circle-based paths for warping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum CircleTextLayout
Visual Basic (Declaration)
Public Enumeration CircleTextLayout
Visual C++
public enum class CircleTextLayout

Members

Member name | Description
Rotate |
Vertical |
Perpendicular |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


ClosedShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended closed shape element class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract class ClosedShapeElement : ShapeElement
Visual Basic (Declaration)
Public MustInherit Class ClosedShapeElement _
    Inherits ShapeElement
Visual C++
public ref class ClosedShapeElement abstract : public ShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.CalloutShapeElement
Neodynamic.SDK.ImageDraw..::.PathShapeElement
Neodynamic.SDK.ImageDraw..::.PolygonShapeElement
Neodynamic.SDK.ImageDraw..::.RectangleShapeElement
Neodynamic.SDK.ImageDraw..::.StarShapeElement

See Also

ClosedShapeElement Members


ClosedShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement Members
ClosedShapeElement Class Constructors Methods Properties See Also Send Feedback

The ClosedShapeElement type exposes the following members.

Constructors

Name | Description
ClosedShapeElement | Initializes a new instance of the ClosedShapeElement class

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object. (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style.
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ClosedShapeElement Class


ClosedShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement Constructor
ClosedShapeElement Class See Also Send Feedback
Initializes a new instance of the ClosedShapeElement class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
protected ClosedShapeElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ClosedShapeElement()

See Also

ClosedShapeElement Class


ClosedShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement Methods
ClosedShapeElement Class See Also Send Feedback

The ClosedShapeElement type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object. (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

ClosedShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement..::.GetOutputImage Method
ClosedShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

ClosedShapeElement Class
ClosedShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement..::.GetOutputImageBinary Method
ClosedShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

ClosedShapeElement Class
ClosedShapeElement Members


ClosedShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement Properties
ClosedShapeElement Class See Also Send Feedback

The ClosedShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style.
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ClosedShapeElement Class


Fill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ClosedShapeElement..::.Fill Property
ClosedShapeElement Class See Also Send Feedback
Gets the shape's fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
}

See Also

ClosedShapeElement Class


ColorDepth Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorDepth Enumeration
See Also Send Feedback
Specifies the format of the color data for each pixel in the output image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ColorDepth
Visual Basic (Declaration)
Public Enumeration ColorDepth
Visual C++
public enum class ColorDepth

Members

Member name | Description
Format16bpp | Specifies that the format is 16 bits per pixel.
Format24bpp | Specifies that the format is 24 bits per pixel.
Format32bpp | Specifies that the format is 32 bits per pixel.
Format32bppAlpha | Specifies that the format is 32 bits per pixel with alpha channel support.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


ColorSubstitution Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Class
Members See Also Send Feedback
Defines an action that replaces one color (old color) with another (new color) on an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class ColorSubstitution : Action
Visual Basic (Declaration)
Public NotInheritable Class ColorSubstitution _
    Inherits Action
Visual C++
public ref class ColorSubstitution sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.ColorSubstitution

See Also

ColorSubstitution Members


ColorSubstitution Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Members
ColorSubstitution Class Constructors Methods Properties See Also Send Feedback

The ColorSubstitution type exposes the following members.

Constructors

Name | Description
ColorSubstitution | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current ColorSubstitution. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorTolerance | Gets or sets the color tolerance for replacing pixels. Color Tolerance represents the tonal range of colors that will be replaced by taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be replaced; otherwise, a wider range of tones will be replaced.
NewColor | Gets or sets the new color to replace the old color on the target element.
OldColor | Gets or sets the old color to be replaced on the target element.

See Also

ColorSubstitution Class


ColorSubstitution Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Constructor
ColorSubstitution Class See Also Send Feedback

Overload List

Name | Description
ColorSubstitution()()() | Initializes a new instance of the ColorSubstitution class.
ColorSubstitution(Color, Color) | Initializes a new instance of the ColorSubstitution class replacing the specified colors.

See Also

ColorSubstitution Class
ColorSubstitution Members


ColorSubstitution Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Constructor
ColorSubstitution Class See Also Send Feedback
Initializes a new instance of the ColorSubstitution class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ColorSubstitution()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ColorSubstitution()

See Also

ColorSubstitution Class
ColorSubstitution Overload


ColorSubstitution Constructor (Color, Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Constructor (Color, Color)
ColorSubstitution Class See Also Send Feedback
Initializes a new instance of the ColorSubstitution class replacing the specified colors.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ColorSubstitution(
    Color oldColor,
    Color newColor
)
Visual Basic (Declaration)
Public Sub New ( _
    oldColor As Color, _
    newColor As Color _
)
Visual C++
public:
ColorSubstitution(
    Color oldColor,
    Color newColor
)

Parameters

oldColor
Type: System.Drawing..::.Color
The old color to be replaced on the target element.
newColor
Type: System.Drawing..::.Color
The new color to replace the old color on the target element.

See Also

ColorSubstitution Class
ColorSubstitution Overload


ColorSubstitution Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Methods
ColorSubstitution Class See Also Send Feedback

The ColorSubstitution type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current ColorSubstitution. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorSubstitution Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution..::.Clone Method
ColorSubstitution Class See Also Send Feedback
Creates a copy of the current ColorSubstitution.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current ColorSubstitution.

See Also

ColorSubstitution Class


ColorSubstitution Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution Properties
ColorSubstitution Class See Also Send Feedback

The ColorSubstitution type exposes the following members.

Properties

Name | Description
ColorTolerance | Gets or sets the color tolerance for replacing pixels. Color Tolerance represents the tonal range of colors that will be replaced by taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be replaced; otherwise, a wider range of tones will be replaced.
NewColor | Gets or sets the new color to replace the old color on the target element.
OldColor | Gets or sets the old color to be replaced on the target element.

See Also

ColorSubstitution Class


ColorTolerance Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution..::.ColorTolerance Property
ColorSubstitution Class See Also Send Feedback
Gets or sets the color tolerance for replacing pixels. Color Tolerance represents the tonal range of colors that will be replaced by taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be replaced; otherwise, a wider range of tones will be replaced.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte ColorTolerance { get; set; }
Visual Basic (Declaration)
Public Property ColorTolerance As Byte
Visual C++
public:
property unsigned char ColorTolerance {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

ColorSubstitution Class


NewColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution..::.NewColor Property
ColorSubstitution Class See Also Send Feedback
Gets or sets the new color to replace the old color on the target element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color NewColor { get; set; }
Visual Basic (Declaration)
Public Property NewColor As Color
Visual C++
public:
property Color NewColor {
    Color get ();
    void set (Color value);
}

See Also

ColorSubstitution Class


OldColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ColorSubstitution..::.OldColor Property
ColorSubstitution Class See Also Send Feedback
Gets or sets the old color to be replaced on the target element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color OldColor { get; set; }
Visual Basic (Declaration)
Public Property OldColor As Color
Visual C++
public:
property Color OldColor {
    Color get ();
    void set (Color value);
}

See Also

ColorSubstitution Class


ConvertToBlackWhite Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite Class
Members See Also Send Feedback
Defines an action that converts an element to black/white or monochrome. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class ConvertToBlackWhite : Action
Visual Basic (Declaration)
Public Class ConvertToBlackWhite _
    Inherits Action
Visual C++
public ref class ConvertToBlackWhite : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.ConvertToBlackWhite

See Also

ConvertToBlackWhite Members


ConvertToBlackWhite Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite Members
ConvertToBlackWhite Class Constructors Methods Properties See Also Send Feedback

The ConvertToBlackWhite type exposes the following members.

Constructors

Name | Description
ConvertToBlackWhite | Initializes a new instance of the ConvertToBlackWhite class.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToBlackWhite. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DitherMethod | Gets or sets the dithering method to be used for Black/White conversion.
ReverseEffect | Gets or sets whether black/white effect should be reversed.
Threshold | Gets or sets the threshold percentage. Values range from 0 to 100.

See Also

ConvertToBlackWhite Class


ConvertToBlackWhite Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite Constructor
ConvertToBlackWhite Class See Also Send Feedback
Initializes a new instance of the ConvertToBlackWhite class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ConvertToBlackWhite()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConvertToBlackWhite()

See Also

ConvertToBlackWhite Class


ConvertToBlackWhite Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite Methods
ConvertToBlackWhite Class See Also Send Feedback

The ConvertToBlackWhite type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToBlackWhite. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToBlackWhite Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite..::.Clone Method
ConvertToBlackWhite Class See Also Send Feedback
Creates a copy of the current ConvertToBlackWhite.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current ConvertToBlackWhite.

See Also

ConvertToBlackWhite Class


ConvertToBlackWhite Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite Properties
ConvertToBlackWhite Class See Also Send Feedback

The ConvertToBlackWhite type exposes the following members.

Properties

Name | Description
DitherMethod | Gets or sets the dithering method to be used for Black/White conversion.
ReverseEffect | Gets or sets whether black/white effect should be reversed.
Threshold | Gets or sets the threshold percentage. Values range from 0 to 100.

See Also

ConvertToBlackWhite Class


DitherMethod Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite..::.DitherMethod Property
ConvertToBlackWhite Class See Also Send Feedback
Gets or sets the dithering method to be used for Black/White conversion.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DitherMethod DitherMethod { get; set; }
Visual Basic (Declaration)
Public Property DitherMethod As DitherMethod
Visual C++
public:
property DitherMethod DitherMethod {
    DitherMethod get ();
    void set (DitherMethod value);
}

See Also

ConvertToBlackWhite Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite..::.ReverseEffect Property
ConvertToBlackWhite Class See Also Send Feedback
Gets or sets whether black/white effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

ConvertToBlackWhite Class


Threshold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToBlackWhite..::.Threshold Property
ConvertToBlackWhite Class See Also Send Feedback
Gets or sets the threshold percentage. Values range from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Threshold { get; set; }
Visual Basic (Declaration)
Public Property Threshold As Integer
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

See Also

ConvertToBlackWhite Class


ConvertToGrayscale Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToGrayscale Class
Members See Also Send Feedback
Defines an action that converts an image to grayscale. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class ConvertToGrayscale : Action
Visual Basic (Declaration)
Public NotInheritable Class ConvertToGrayscale _
    Inherits Action
Visual C++
public ref class ConvertToGrayscale sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.ConvertToGrayscale

See Also

ConvertToGrayscale Members


ConvertToGrayscale Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToGrayscale Members
ConvertToGrayscale Class Constructors Methods See Also Send Feedback

The ConvertToGrayscale type exposes the following members.

Constructors

Name | Description
ConvertToGrayscale | Initializes a new instance of the [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale] class.

Methods

Name | Description
Clone | Creates a copy of the current [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale]. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToGrayscale Class


ConvertToGrayscale Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToGrayscale Constructor
ConvertToGrayscale Class See Also Send Feedback
Initializes a new instance of the [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale] class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ConvertToGrayscale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConvertToGrayscale()

See Also

ConvertToGrayscale Class


ConvertToGrayscale Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToGrayscale Methods
ConvertToGrayscale Class See Also Send Feedback

The ConvertToGrayscale type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale]. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToGrayscale Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToGrayscale..::.Clone Method
ConvertToGrayscale Class See Also Send Feedback
Creates a copy of the current [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale].

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current [!:Neodynamic.SDK.ImageDraw.ConvertToGrayScale].

See Also

ConvertToGrayscale Class


ConvertToNegative Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToNegative Class
Members See Also Send Feedback
Defines an action that converts an image to negative. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class ConvertToNegative : Action
Visual Basic (Declaration)
Public NotInheritable Class ConvertToNegative _
    Inherits Action
Visual C++
public ref class ConvertToNegative sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.ConvertToNegative

See Also

ConvertToNegative Members


ConvertToNegative Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToNegative Members
ConvertToNegative Class Constructors Methods See Also Send Feedback

The ConvertToNegative type exposes the following members.

Constructors

Name | Description
ConvertToNegative | Initializes a new instance of the ConvertToNegative class.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToNegative. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToNegative Class


ConvertToNegative Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToNegative Constructor
ConvertToNegative Class See Also Send Feedback
Initializes a new instance of the ConvertToNegative class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ConvertToNegative()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConvertToNegative()

See Also

ConvertToNegative Class


ConvertToNegative Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToNegative Methods
ConvertToNegative Class See Also Send Feedback

The ConvertToNegative type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToNegative. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToNegative Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToNegative..::.Clone Method
ConvertToNegative Class See Also Send Feedback
Creates a copy of the current ConvertToNegative.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current ConvertToNegative.

See Also

ConvertToNegative Class


ConvertToSepia Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToSepia Class
Members See Also Send Feedback
Defines an action that converts an image to sepia. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class ConvertToSepia : Action
Visual Basic (Declaration)
Public NotInheritable Class ConvertToSepia _
    Inherits Action
Visual C++
public ref class ConvertToSepia sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.ConvertToSepia

See Also

ConvertToSepia Members


ConvertToSepia Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToSepia Members
ConvertToSepia Class Constructors Methods See Also Send Feedback

The ConvertToSepia type exposes the following members.

Constructors

Name | Description
ConvertToSepia | Initializes a new instance of the ConvertToSepia class.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToSepia. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToSepia Class


ConvertToSepia Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToSepia Constructor
ConvertToSepia Class See Also Send Feedback
Initializes a new instance of the ConvertToSepia class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ConvertToSepia()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ConvertToSepia()

See Also

ConvertToSepia Class


ConvertToSepia Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToSepia Methods
ConvertToSepia Class See Also Send Feedback

The ConvertToSepia type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current ConvertToSepia. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConvertToSepia Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ConvertToSepia..::.Clone Method
ConvertToSepia Class See Also Send Feedback
Creates a copy of the current ConvertToSepia.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current ConvertToSepia.

See Also

ConvertToSepia Class


Corners Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Corners Enumeration
See Also Send Feedback
Specifies what corners will be rounded.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
[FlagsAttribute]
public enum Corners
Visual Basic (Declaration)
<FlagsAttribute> _
Public Enumeration Corners
Visual C++
[FlagsAttribute]
public enum class Corners

Members

Member name | Description
All | All four corners will be rounded.
TopLeft | The top left corner will be rounded.
TopRight | The top right corner will be rounded.
BottomLeft | The bottom left corner will be rounded.
BottomRight | The bottom right corner will be rounded.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Crop Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Class
Members See Also Send Feedback
Defines an action that crops a rectangular section from an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Crop : Action
Visual Basic (Declaration)
Public NotInheritable Class Crop _
    Inherits Action
Visual C++
public ref class Crop sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Crop

See Also

Crop Members


Crop Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Members
Crop Class Constructors Methods Properties See Also Send Feedback

The Crop type exposes the following members.

Constructors

Name | Description
Crop | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Crop. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AntiAlias | Gets or sets whether path cropping is antialiased.
Center | Gets or sets whether to perform centered cropping.
Height | Gets or sets the height of the cropping rectangle.
PathPoints | Gets or sets a string containing pairs of point describing the path for cropping. Use it for performing Path cropping.
Roundness | Gets or sets the path roundness used for cropping. Use it for performing Path cropping.
Width | Gets or sets the width of the cropping rectangle.
X | Gets or sets the x-coordinate of the cropping rectangle.
Y | Gets or sets the y-coordinate of the cropping rectangle.

See Also

Crop Class


Crop Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Constructor
Crop Class See Also Send Feedback

Overload List

Name | Description
Crop()()() | Initializes a new instance of the Crop class.
Crop(Int32, Int32) | Initializes a new instance of the Crop class with the specified size. Cropping will be centered.
Crop(Int32, Int32, Int32, Int32) | Initializes a new instance of the Crop class with the specified rectangular section.

See Also

Crop Class
Crop Members


Crop Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Constructor
Crop Class See Also Send Feedback
Initializes a new instance of the Crop class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Crop()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Crop()

See Also

Crop Class
Crop Overload


Crop Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Constructor (Int32, Int32)
Crop Class See Also Send Feedback
Initializes a new instance of the Crop class with the specified size. Cropping will be centered.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Crop(
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
Crop(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32
The width of the cropping section.
height
Type: System..::.Int32
The height of the cropping section.

See Also

Crop Class
Crop Overload


Crop Constructor (Int32, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Constructor (Int32, Int32, Int32, Int32)
Crop Class See Also Send Feedback
Initializes a new instance of the Crop class with the specified rectangular section.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Crop(
    int x,
    int y,
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
Crop(
    int x,
    int y,
    int width,
    int height
)

Parameters

x
Type: System..::.Int32
The x-coordinate of the cropping section.
y
Type: System..::.Int32
The y-coordinate of the cropping section.
width
Type: System..::.Int32
The width of the cropping section.
height
Type: System..::.Int32
The height of the cropping section.

See Also

Crop Class
Crop Overload


Crop Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Methods
Crop Class See Also Send Feedback

The Crop type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Crop. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Crop Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Clone Method
Crop Class See Also Send Feedback
Creates a copy of the current Crop.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Crop.

See Also

Crop Class


Crop Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop Properties
Crop Class See Also Send Feedback

The Crop type exposes the following members.

Properties

Name | Description
AntiAlias | Gets or sets whether path cropping is antialiased.
Center | Gets or sets whether to perform centered cropping.
Height | Gets or sets the height of the cropping rectangle.
PathPoints | Gets or sets a string containing pairs of point describing the path for cropping. Use it for performing Path cropping.
Roundness | Gets or sets the path roundness used for cropping. Use it for performing Path cropping.
Width | Gets or sets the width of the cropping rectangle.
X | Gets or sets the x-coordinate of the cropping rectangle.
Y | Gets or sets the y-coordinate of the cropping rectangle.

See Also

Crop Class


AntiAlias Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.AntiAlias Property
Crop Class See Also Send Feedback
Gets or sets whether path cropping is antialiased.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool AntiAlias { get; set; }
Visual Basic (Declaration)
Public Property AntiAlias As Boolean
Visual C++
public:
property bool AntiAlias {
    bool get ();
    void set (bool value);
}

See Also

Crop Class


Center Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Center Property
Crop Class See Also Send Feedback
Gets or sets whether to perform centered cropping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Boolean
Visual C++
public:
property bool Center {
    bool get ();
    void set (bool value);
}

See Also

Crop Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Height Property
Crop Class See Also Send Feedback
Gets or sets the height of the cropping rectangle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Crop Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.PathPoints Property
Crop Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for cropping. Use it for performing Path cropping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

Crop Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Roundness Property
Crop Class See Also Send Feedback
Gets or sets the path roundness used for cropping. Use it for performing Path cropping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Crop Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Width Property
Crop Class See Also Send Feedback
Gets or sets the width of the cropping rectangle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Crop Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.X Property
Crop Class See Also Send Feedback
Gets or sets the x-coordinate of the cropping rectangle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Crop Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Crop..::.Y Property
Crop Class See Also Send Feedback
Gets or sets the y-coordinate of the cropping rectangle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Crop Class


DecorativeBorder Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Class
Members See Also Send Feedback
Defines an action that adds decorative border to an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class DecorativeBorder : Action
Visual Basic (Declaration)
Public NotInheritable Class DecorativeBorder _
    Inherits Action
Visual C++
public ref class DecorativeBorder sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.DecorativeBorder

See Also

DecorativeBorder Members


DecorativeBorder Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Members
DecorativeBorder Class Constructors Methods Properties See Also Send Feedback

The DecorativeBorder type exposes the following members.

Constructors

Name | Description
DecorativeBorder | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current DecorativeBorder. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DashStyle | Gets or sets the border dash style.
Fill | Gets the border's fill style.
Width | Gets or sets the border width.

See Also

DecorativeBorder Class


DecorativeBorder Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Constructor
DecorativeBorder Class See Also Send Feedback

Overload List

Name | Description
DecorativeBorder()()() | Initializes a new instance of the DecorativeBorder class.
DecorativeBorder(Int32) | Initializes a new instance of the DecorativeBorder class with the specified width.
DecorativeBorder(Int32, DashStyle, Fill) | Initializes a new instance of the DecorativeBorder class with the specified settings.

See Also

DecorativeBorder Class
DecorativeBorder Members


DecorativeBorder Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Constructor
DecorativeBorder Class See Also Send Feedback
Initializes a new instance of the DecorativeBorder class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DecorativeBorder()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DecorativeBorder()

See Also

DecorativeBorder Class
DecorativeBorder Overload


DecorativeBorder Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Constructor (Int32)
DecorativeBorder Class See Also Send Feedback
Initializes a new instance of the DecorativeBorder class with the specified width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DecorativeBorder(
    int width
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer _
)
Visual C++
public:
DecorativeBorder(
    int width
)

Parameters

width
Type: System..::.Int32
The border width.

See Also

DecorativeBorder Class
DecorativeBorder Overload


DecorativeBorder Constructor (Int32, DashStyle, Fill)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Constructor (Int32, DashStyle, Fill)
DecorativeBorder Class See Also Send Feedback
Initializes a new instance of the DecorativeBorder class with the specified settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DecorativeBorder(
    int width,
    DashStyle dashStyle,
    Fill fill
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    dashStyle As DashStyle, _
    fill As Fill _
)
Visual C++
public:
DecorativeBorder(
    int width,
    DashStyle dashStyle,
    Fill^ fill
)

Parameters

width
Type: System..::.Int32
The border width.
dashStyle
Type: System.Drawing.Drawing2D..::.DashStyle
The border dash style.
fill
Type: Neodynamic.SDK.ImageDraw..::.Fill
The border fill.

See Also

DecorativeBorder Class
DecorativeBorder Overload


DecorativeBorder Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Methods
DecorativeBorder Class See Also Send Feedback

The DecorativeBorder type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current DecorativeBorder. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DecorativeBorder Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder..::.Clone Method
DecorativeBorder Class See Also Send Feedback
Creates a copy of the current DecorativeBorder.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current DecorativeBorder.

See Also

DecorativeBorder Class


DecorativeBorder Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder Properties
DecorativeBorder Class See Also Send Feedback

The DecorativeBorder type exposes the following members.

Properties

Name | Description
DashStyle | Gets or sets the border dash style.
Fill | Gets the border's fill style.
Width | Gets or sets the border width.

See Also

DecorativeBorder Class


DashStyle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder..::.DashStyle Property
DecorativeBorder Class See Also Send Feedback
Gets or sets the border dash style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DashStyle DashStyle { get; set; }
Visual Basic (Declaration)
Public Property DashStyle As DashStyle
Visual C++
public:
property DashStyle DashStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

DecorativeBorder Class


Fill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder..::.Fill Property
DecorativeBorder Class See Also Send Feedback
Gets the border's fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Fill { get; }
Visual Basic (Declaration)
Public ReadOnly Property Fill As Fill
Visual C++
public:
property Fill^ Fill {
    Fill^ get ();
}

See Also

DecorativeBorder Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DecorativeBorder..::.Width Property
DecorativeBorder Class See Also Send Feedback
Gets or sets the border width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 0.

See Also

DecorativeBorder Class


DistortCorners Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Class
Members See Also Send Feedback
Defines an action that distorts an element by changing the coordinates of the four corners defined by the element's boundaries. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class DistortCorners : Action
Visual Basic (Declaration)
Public Class DistortCorners _
    Inherits Action
Visual C++
public ref class DistortCorners : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.DistortCorners

See Also

DistortCorners Members


DistortCorners Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Members
DistortCorners Class Constructors Methods Properties See Also Send Feedback

The DistortCorners type exposes the following members.

Constructors

Name | Description
DistortCorners | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current DistortCorners. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
X1 | Gets or sets the new upper-left corner x-coordinate.
X2 | Gets or sets the new upper-right corner x-coordinate.
X3 | Gets or sets the new bottom-right corner x-coordinate.
X4 | Gets or sets the new bottom-left corner x-coordinate.
Y1 | Gets or sets the new upper-left corner y-coordinate.
Y2 | Gets or sets the new upper-right corner y-coordinate.
Y3 | Gets or sets the new bottom-right corner y-coordinate.
Y4 | Gets or sets the new bottom-left corner y-coordinate.

See Also

DistortCorners Class


DistortCorners Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Constructor
DistortCorners Class See Also Send Feedback

Overload List

Name | Description
DistortCorners()()() | Initializes a new instance of the DistortCorners class.
DistortCorners(Point, Point, Point, Point) | Initializes a new instance of the DistortCorners class with the specified coordinates.
DistortCorners(Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32) | Initializes a new instance of the DistortCorners class with the specified coordinates.

See Also

DistortCorners Class
DistortCorners Members


DistortCorners Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Constructor
DistortCorners Class See Also Send Feedback
Initializes a new instance of the DistortCorners class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DistortCorners()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DistortCorners()

See Also

DistortCorners Class
DistortCorners Overload


DistortCorners Constructor (Point, Point, Point, Point)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Constructor (Point, Point, Point, Point)
DistortCorners Class See Also Send Feedback
Initializes a new instance of the DistortCorners class with the specified coordinates.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DistortCorners(
    Point pt1,
    Point pt2,
    Point pt3,
    Point pt4
)
Visual Basic (Declaration)
Public Sub New ( _
    pt1 As Point, _
    pt2 As Point, _
    pt3 As Point, _
    pt4 As Point _
)
Visual C++
public:
DistortCorners(
    Point pt1,
    Point pt2,
    Point pt3,
    Point pt4
)

Parameters

pt1
Type: System.Drawing..::.Point
The new upper-left corner point.
pt2
Type: System.Drawing..::.Point
The new upper-right corner point.
pt3
Type: System.Drawing..::.Point
The new bottom-right corner point.
pt4
Type: System.Drawing..::.Point
The new bottom-left corner point.

See Also

DistortCorners Class
DistortCorners Overload


DistortCorners Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Constructor (Int32, Int32, Int32, Int32, Int32, Int32, Int32, Int32)
DistortCorners Class See Also Send Feedback
Initializes a new instance of the DistortCorners class with the specified coordinates.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DistortCorners(
    int x1,
    int y1,
    int x2,
    int y2,
    int x3,
    int y3,
    int x4,
    int y4
)
Visual Basic (Declaration)
Public Sub New ( _
    x1 As Integer, _
    y1 As Integer, _
    x2 As Integer, _
    y2 As Integer, _
    x3 As Integer, _
    y3 As Integer, _
    x4 As Integer, _
    y4 As Integer _
)
Visual C++
public:
DistortCorners(
    int x1,
    int y1,
    int x2,
    int y2,
    int x3,
    int y3,
    int x4,
    int y4
)

Parameters

x1
Type: System..::.Int32
The new upper-left corner x-coordinate.
y1
Type: System..::.Int32
The new upper-left corner y-coordinate.
x2
Type: System..::.Int32
The new upper-right corner x-coordinate.
y2
Type: System..::.Int32
The new upper-right corner y-coordinate.
x3
Type: System..::.Int32
The new bottom-right corner x-coordinate.
y3
Type: System..::.Int32
The new bottom-right corner y-coordinate.
x4
Type: System..::.Int32
The new bottom-left corner x-coordinate.
y4
Type: System..::.Int32
The new bottom-left corner y-coordinate.

See Also

DistortCorners Class
DistortCorners Overload


DistortCorners Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Methods
DistortCorners Class See Also Send Feedback

The DistortCorners type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current DistortCorners. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DistortCorners Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.Clone Method
DistortCorners Class See Also Send Feedback
Creates a copy of the current DistortCorners.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current DistortCorners.

See Also

DistortCorners Class


DistortCorners Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners Properties
DistortCorners Class See Also Send Feedback

The DistortCorners type exposes the following members.

Properties

Name | Description
X1 | Gets or sets the new upper-left corner x-coordinate.
X2 | Gets or sets the new upper-right corner x-coordinate.
X3 | Gets or sets the new bottom-right corner x-coordinate.
X4 | Gets or sets the new bottom-left corner x-coordinate.
Y1 | Gets or sets the new upper-left corner y-coordinate.
Y2 | Gets or sets the new upper-right corner y-coordinate.
Y3 | Gets or sets the new bottom-right corner y-coordinate.
Y4 | Gets or sets the new bottom-left corner y-coordinate.

See Also

DistortCorners Class


X1 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.X1 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new upper-left corner x-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X1 { get; set; }
Visual Basic (Declaration)
Public Property X1 As Integer
Visual C++
public:
property int X1 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


X2 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.X2 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new upper-right corner x-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X2 { get; set; }
Visual Basic (Declaration)
Public Property X2 As Integer
Visual C++
public:
property int X2 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


X3 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.X3 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new bottom-right corner x-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X3 { get; set; }
Visual Basic (Declaration)
Public Property X3 As Integer
Visual C++
public:
property int X3 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


X4 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.X4 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new bottom-left corner x-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X4 { get; set; }
Visual Basic (Declaration)
Public Property X4 As Integer
Visual C++
public:
property int X4 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


Y1 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.Y1 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new upper-left corner y-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y1 { get; set; }
Visual Basic (Declaration)
Public Property Y1 As Integer
Visual C++
public:
property int Y1 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


Y2 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.Y2 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new upper-right corner y-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y2 { get; set; }
Visual Basic (Declaration)
Public Property Y2 As Integer
Visual C++
public:
property int Y2 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


Y3 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.Y3 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new bottom-right corner y-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y3 { get; set; }
Visual Basic (Declaration)
Public Property Y3 As Integer
Visual C++
public:
property int Y3 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


Y4 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DistortCorners..::.Y4 Property
DistortCorners Class See Also Send Feedback
Gets or sets the new bottom-left corner y-coordinate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y4 { get; set; }
Visual Basic (Declaration)
Public Property Y4 As Integer
Visual C++
public:
property int Y4 {
    int get ();
    void set (int value);
}

See Also

DistortCorners Class


DitherMethod Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DitherMethod Enumeration
See Also Send Feedback
Specifies the dithering method to be used for Black/White conversion.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum DitherMethod
Visual Basic (Declaration)
Public Enumeration DitherMethod
Visual C++
public enum class DitherMethod

Members

Member name | Description
Threshold | Any pixel below the threshold becomes black; otherwise it becomes white. Use it for logos or simple images.
PatternDiffusion | It uses a 4x4 dithering matrix to create a grouping of pixels that approximates the pixel group brightness. Use it for photos and other complicated images.
FloydSteinberg | It uses Floyd-Steinberg algorithm to keep a track of the error in brightness caused by the threshold, and diffusing it across an area. Use it for photos and other complicated images.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


DropShadow Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Class
Members See Also Send Feedback
Defines an action that adds drop shadows to an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class DropShadow : Action
Visual Basic (Declaration)
Public NotInheritable Class DropShadow _
    Inherits Action
Visual C++
public ref class DropShadow sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.DropShadow

See Also

DropShadow Members


DropShadow Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Members
DropShadow Class Constructors Methods Properties See Also Send Feedback

The DropShadow type exposes the following members.

Constructors

Name | Description
DropShadow | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current DropShadow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the direction of the shadow. It is measured counterclockwise from the x-axis.
Color | Gets or sets the color of the shadow
Distance | Gets or sets the distance of the shadow from the object
Opacity | Gets or sets the percentage of transparency in the shadow
Softness | Gets or sets the sharpness of the shadow

See Also

DropShadow Class


DropShadow Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Constructor
DropShadow Class See Also Send Feedback

Overload List

Name | Description
DropShadow()()() | Initializes a new instance of the DropShadow class.
DropShadow(Int32, Color, Int32, Int32, Int32) | Initializes a new instance of the DropShadow class with the specified settings.

See Also

DropShadow Class
DropShadow Members


DropShadow Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Constructor
DropShadow Class See Also Send Feedback
Initializes a new instance of the DropShadow class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DropShadow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DropShadow()

See Also

DropShadow Class
DropShadow Overload


DropShadow Constructor (Int32, Color, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Constructor (Int32, Color, Int32, Int32, Int32)
DropShadow Class See Also Send Feedback
Initializes a new instance of the DropShadow class with the specified settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DropShadow(
    int distance,
    Color color,
    int opacity,
    int softness,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    distance As Integer, _
    color As Color, _
    opacity As Integer, _
    softness As Integer, _
    angle As Integer _
)
Visual C++
public:
DropShadow(
    int distance,
    Color color,
    int opacity,
    int softness,
    int angle
)

Parameters

distance
Type: System..::.Int32
The distance of the shadow from the object
color
Type: System.Drawing..::.Color
The color of the shadow
opacity
Type: System..::.Int32
The percentage of transparency in the shadow
softness
Type: System..::.Int32
The sharpness of the shadow
angle
Type: System..::.Int32
The direction of the shadow

See Also

DropShadow Class
DropShadow Overload


DropShadow Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Methods
DropShadow Class See Also Send Feedback

The DropShadow type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current DropShadow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DropShadow Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Clone Method
DropShadow Class See Also Send Feedback
Creates a copy of the current DropShadow.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current DropShadow.

See Also

DropShadow Class


DropShadow Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow Properties
DropShadow Class See Also Send Feedback

The DropShadow type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the direction of the shadow. It is measured counterclockwise from the x-axis.
Color | Gets or sets the color of the shadow
Distance | Gets or sets the distance of the shadow from the object
Opacity | Gets or sets the percentage of transparency in the shadow
Softness | Gets or sets the sharpness of the shadow

See Also

DropShadow Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Angle Property
DropShadow Class See Also Send Feedback
Gets or sets the direction of the shadow. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

See Also

DropShadow Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Color Property
DropShadow Class See Also Send Feedback
Gets or sets the color of the shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

DropShadow Class


Distance Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Distance Property
DropShadow Class See Also Send Feedback
Gets or sets the distance of the shadow from the object

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Distance { get; set; }
Visual Basic (Declaration)
Public Property Distance As Integer
Visual C++
public:
property int Distance {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

DropShadow Class


Opacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Opacity Property
DropShadow Class See Also Send Feedback
Gets or sets the percentage of transparency in the shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Integer
Visual C++
public:
property int Opacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

DropShadow Class


Softness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
DropShadow..::.Softness Property
DropShadow Class See Also Send Feedback
Gets or sets the sharpness of the shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Softness { get; set; }
Visual Basic (Declaration)
Public Property Softness As Integer
Visual C++
public:
property int Softness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

DropShadow Class


Element Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended element class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract class Element
Visual Basic (Declaration)
Public MustInherit Class Element
Visual C++
public ref class Element abstract

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ImageElement
Neodynamic.SDK.ImageDraw..::.RichTextElement
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.TextElement
Neodynamic.SDK.ImageDraw..::.WordArtElement

See Also

Element Members


Element Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element Members
Element Class Methods Properties See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it.
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96.
Height | Gets or sets the height of the element.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image.
Visible | Gets or sets whether this element is visible or hidden.
Width | Gets or sets the width of the element.
X | Gets or sets the x-coordinate of the left side of the element
Y | Gets or sets the y-coordinate of the top side of the element

See Also

Element Class


Element Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element Methods
Element Class See Also Send Feedback

The Element type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it.
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Overrides Object..::.ToString()()().)

See Also

Element Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Clone Method
Element Class See Also Send Feedback
When overridden in a derived class, creates an exact copy of this Element object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract Element Clone()
Visual Basic (Declaration)
Public MustOverride Function Clone As Element
Visual C++
public:
virtual Element^ Clone() abstract

Return Value

The new Element object that this method creates.

See Also

Element Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImage Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element.
GetOutputImage(Fill) | Returns a Bitmap object of the element.

See Also

Element Class
Element Members


GetOutputImage Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImage Method
Element Class See Also Send Feedback
Returns a Bitmap object of the element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Bitmap GetOutputImage()
Visual Basic (Declaration)
Public Function GetOutputImage As Bitmap
Visual C++
public:
Bitmap^ GetOutputImage()

Return Value

A Bitmap object representing the output image generated by this Element object.

See Also

Element Class
GetOutputImage Overload


GetOutputImage Method (Fill)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImage Method (Fill)
Element Class See Also Send Feedback
Returns a Bitmap object of the element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Bitmap GetOutputImage(
    Fill background
)
Visual Basic (Declaration)
Public Function GetOutputImage ( _
    background As Fill _
) As Bitmap
Visual C++
public:
Bitmap^ GetOutputImage(
    Fill^ background
)

Parameters

background
Type: Neodynamic.SDK.ImageDraw..::.Fill
The background fill for the output image.

Return Value

A Bitmap object representing the output image generated by this Element object.

See Also

Element Class
GetOutputImage Overload


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImageBinary Method
Element Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element.
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element.

See Also

Element Class
Element Members


GetOutputImageBinary Method (ImageDrawFormat)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImageBinary Method (ImageDrawFormat)
Element Class See Also Send Feedback
Returns a byte array of the output image generated byt this element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] GetOutputImageBinary(
    ImageDrawFormat format
)
Visual Basic (Declaration)
Public Function GetOutputImageBinary ( _
    format As ImageDrawFormat _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetOutputImageBinary(
    ImageDrawFormat format
)

Parameters

format
Type: Neodynamic.SDK.ImageDraw..::.ImageDrawFormat

Return Value

A byte array representing the output image generated by this Element object.

See Also

Element Class
GetOutputImageBinary Overload


GetOutputImageBinary Method (Fill, ImageDrawFormat)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetOutputImageBinary Method (Fill, ImageDrawFormat)
Element Class See Also Send Feedback
Returns a byte array of the output image generated byt this element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] GetOutputImageBinary(
    Fill background,
    ImageDrawFormat format
)
Visual Basic (Declaration)
Public Function GetOutputImageBinary ( _
    background As Fill, _
    format As ImageDrawFormat _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetOutputImageBinary(
    Fill^ background,
    ImageDrawFormat format
)

Parameters

background
Type: Neodynamic.SDK.ImageDraw..::.Fill
The background fill for the output image.
format
Type: Neodynamic.SDK.ImageDraw..::.ImageDrawFormat
The output image format.

Return Value

A byte array representing the output image generated by this Element object.

See Also

Element Class
GetOutputImageBinary Overload


GetSize Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetSize Method
Element Class See Also Send Feedback
Calculates the size of the element without applying any actions onto it.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Size GetSize()
Visual Basic (Declaration)
Public Function GetSize As Size
Visual C++
public:
Size GetSize()

Return Value

The size of the element without applying any actions onto it.

See Also

Element Class


GetSizeAfterActions Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.GetSizeAfterActions Method
Element Class See Also Send Feedback
Calculates the new size of the element after applying the actions onto it.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Size GetSizeAfterActions()
Visual Basic (Declaration)
Public Function GetSizeAfterActions As Size
Visual C++
public:
Size GetSizeAfterActions()

Return Value

The new size of the element after applying the actions onto it.

See Also

Element Class


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.ToString Method
Element Class See Also Send Feedback
Returns the String representation of this instance of a Element object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

A string that represents this Element object.

See Also

Element Class


Element Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element Properties
Element Class See Also Send Feedback

The Element type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96.
Height | Gets or sets the height of the element.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image.
Visible | Gets or sets whether this element is visible or hidden.
Width | Gets or sets the width of the element.
X | Gets or sets the x-coordinate of the left side of the element
Y | Gets or sets the y-coordinate of the top side of the element

See Also

Element Class


Actions Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Actions Property
Element Class See Also Send Feedback
Gets the Action objects that will applied on this Element object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Actions As ActionCollection
Visual C++
public:
property ActionCollection^ Actions {
    ActionCollection^ get ();
}

See Also

Element Class


Dpi Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Dpi Property
Element Class See Also Send Feedback
Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Dpi { get; set; }
Visual Basic (Declaration)
Public Property Dpi As Integer
Visual C++
public:
property int Dpi {
    int get ();
    void set (int value);
}

See Also

Element Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Height Property
Element Class See Also Send Feedback
Gets or sets the height of the element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public virtual int Height { get; set; }
Visual Basic (Declaration)
Public Overridable Property Height As Integer
Visual C++
public:
virtual property int Height {
    int get ();
    void set (int value);
}

See Also

Element Class


Name Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Name Property
Element Class See Also Send Feedback
Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Element Class


Visible Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Visible Property
Element Class See Also Send Feedback
Gets or sets whether this element is visible or hidden.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean
Visual C++
public:
property bool Visible {
    bool get ();
    void set (bool value);
}

See Also

Element Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Width Property
Element Class See Also Send Feedback
Gets or sets the width of the element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public virtual int Width { get; set; }
Visual Basic (Declaration)
Public Overridable Property Width As Integer
Visual C++
public:
virtual property int Width {
    int get ();
    void set (int value);
}

See Also

Element Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.X Property
Element Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the element

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

Element Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Element..::.Y Property
Element Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the element

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

Element Class


ElementCollection Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection Class
Members See Also Send Feedback
Provides a collection of Element objects.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class ElementCollection : IList,
    ICollection, IEnumerable
Visual Basic (Declaration)
Public Class ElementCollection _
    Implements IList, ICollection, IEnumerable
Visual C++
public ref class ElementCollection : IList,
    ICollection, IEnumerable

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.ElementCollection

See Also

ElementCollection Members


ElementCollection Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection Members
ElementCollection Class Constructors Methods Properties See Also Send Feedback

The ElementCollection type exposes the following members.

Constructors

Name | Description
ElementCollection | Initializes a new instance of the ElementCollection class.

Methods

Name | Description
Add | Appends the specified Element to the end of the collection.
Clear | Removes all Element objects from the collection.
Contains | Determines whether the collection contains the specified Element.
CopyTo | Copies the items from the ElementCollection to the specified Array, starting with the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns a IEnumerator implemented object that contains all Element objects in the ElementCollection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index value that represents the position of the specified Element in the collection.
Insert | Inserts the specified Element in the collection at the specified index location.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified Element from the collection.
RemoveAt | Removes the Element at the specified index from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of Element objects in the collection.
IsSynchronized | Gets a value indicating whether access to the ElementCollection is synchronized (thread-safe).
Item | Overloaded.
SyncRoot | Gets the object that can be used to synchronize access to the ElementCollection.

See Also

ElementCollection Class


ElementCollection Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection Constructor
ElementCollection Class See Also Send Feedback
Initializes a new instance of the ElementCollection class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ElementCollection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ElementCollection()

See Also

ElementCollection Class


ElementCollection Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection Methods
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Methods

Name | Description
Add | Appends the specified Element to the end of the collection.
Clear | Removes all Element objects from the collection.
Contains | Determines whether the collection contains the specified Element.
CopyTo | Copies the items from the ElementCollection to the specified Array, starting with the specified index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns a IEnumerator implemented object that contains all Element objects in the ElementCollection.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Determines the index value that represents the position of the specified Element in the collection.
Insert | Inserts the specified Element in the collection at the specified index location.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the specified Element from the collection.
RemoveAt | Removes the Element at the specified index from the collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ElementCollection Class


Add Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Add Method
ElementCollection Class See Also Send Feedback
Appends the specified Element to the end of the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Add(
    Element element
)
Visual Basic (Declaration)
Public Function Add ( _
    element As Element _
) As Integer
Visual C++
public:
int Add(
    Element^ element
)

Parameters

element
Type: Neodynamic.SDK.ImageDraw..::.Element
The Element to append to the collection.

Return Value

The index position of the appended Element.

See Also

ElementCollection Class


Clear Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Clear Method
ElementCollection Class See Also Send Feedback
Removes all Element objects from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

ElementCollection Class


Contains Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Contains Method
ElementCollection Class See Also Send Feedback
Determines whether the collection contains the specified Element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Contains(
    Element element
)
Visual Basic (Declaration)
Public Function Contains ( _
    element As Element _
) As Boolean
Visual C++
public:
bool Contains(
    Element^ element
)

Parameters

element
Type: Neodynamic.SDK.ImageDraw..::.Element
An Element to search for in the collection.

Return Value

true if the collection contains the specified Element; otherwise, false.

See Also

ElementCollection Class


CopyTo Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.CopyTo Method
ElementCollection Class See Also Send Feedback
Copies the items from the ElementCollection to the specified Array, starting with the specified index.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)
Visual C++
public:
virtual void CopyTo(
    Array^ array,
    int index
) sealed

Parameters

array
Type: System..::.Array
A zero-based Array that receives the copied items from the ElementCollection.
index
Type: System..::.Int32
The first index in the specified Array to receive the items.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

ElementCollection Class


GetEnumerator Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.GetEnumerator Method
ElementCollection Class See Also Send Feedback
Returns a IEnumerator implemented object that contains all Element objects in the ElementCollection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator
Visual C++
public:
virtual IEnumerator^ GetEnumerator() sealed

Return Value

A IEnumerator implemented object that contains all Element objects in the ElementCollection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ElementCollection Class


IndexOf Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.IndexOf Method
ElementCollection Class See Also Send Feedback
Determines the index value that represents the position of the specified Element in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int IndexOf(
    Element element
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    element As Element _
) As Integer
Visual C++
public:
int IndexOf(
    Element^ element
)

Parameters

element
Type: Neodynamic.SDK.ImageDraw..::.Element
An Element to search for in the collection.

Return Value

The index position of the specified Element in the collection.

See Also

ElementCollection Class


Insert Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Insert Method
ElementCollection Class See Also Send Feedback
Inserts the specified Element in the collection at the specified index location.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Insert(
    int index,
    Element element
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    element As Element _
)
Visual C++
public:
void Insert(
    int index,
    Element^ element
)

Parameters

index
Type: System..::.Int32
The location in the collection to insert the Element.
element
Type: Neodynamic.SDK.ImageDraw..::.Element
The Element to add to the collection.

See Also

ElementCollection Class


Remove Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Remove Method
ElementCollection Class See Also Send Feedback
Removes the specified Element from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Remove(
    Element element
)
Visual Basic (Declaration)
Public Sub Remove ( _
    element As Element _
)
Visual C++
public:
void Remove(
    Element^ element
)

Parameters

element
Type: Neodynamic.SDK.ImageDraw..::.Element
The Element to remove from the collection.

See Also

ElementCollection Class


RemoveAt Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.RemoveAt Method
ElementCollection Class See Also Send Feedback
Removes the Element at the specified index from the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32
The index of the Element to remove.

See Also

ElementCollection Class


ElementCollection Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection Properties
ElementCollection Class See Also Send Feedback

The ElementCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of Element objects in the collection.
IsSynchronized | Gets a value indicating whether access to the ElementCollection is synchronized (thread-safe).
Item | Overloaded.
SyncRoot | Gets the object that can be used to synchronize access to the ElementCollection.

See Also

ElementCollection Class


Count Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Count Property
ElementCollection Class See Also Send Feedback
Gets the number of Element objects in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
virtual property int Count {
    int get () sealed;
}

Implements

ICollection..::.Count

See Also

ElementCollection Class


IsSynchronized Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.IsSynchronized Property
ElementCollection Class See Also Send Feedback
Gets a value indicating whether access to the ElementCollection is synchronized (thread-safe).

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean
Visual C++
public:
virtual property bool IsSynchronized {
    bool get () sealed;
}

Implements

ICollection..::.IsSynchronized

See Also

ElementCollection Class


Item Property

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Item Property
ElementCollection Class See Also Send Feedback

Overload List

Name | Description
Item[([(Int32])]) | Gets an Element at the specified index in the collection.
Item[([(String])]) | Gets the first Element in the collection which name is equal to the specified.

See Also

ElementCollection Class
ElementCollection Members


Item Property (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Item Property (Int32)
ElementCollection Class See Also Send Feedback
Gets an Element at the specified index in the collection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Element this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Element
Visual C++
public:
property Element^ default[int index] {
    Element^ get (int index);
}

Parameters

index
Type: System..::.Int32

See Also

ElementCollection Class
Item Overload


Item Property (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.Item Property (String)
ElementCollection Class See Also Send Feedback
Gets the first Element in the collection which name is equal to the specified.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Element this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Element
Visual C++
public:
property Element^ default[String^ name] {
    Element^ get (String^ name);
}

Parameters

name
Type: System..::.String

See Also

ElementCollection Class
Item Overload


SyncRoot Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ElementCollection..::.SyncRoot Property
ElementCollection Class See Also Send Feedback
Gets the object that can be used to synchronize access to the ElementCollection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object
Visual C++
public:
virtual property Object^ SyncRoot {
    Object^ get () sealed;
}

Implements

ICollection..::.SyncRoot

See Also

ElementCollection Class


Emboss Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss Class
Members See Also Send Feedback
Defines an action that embosses an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Emboss : Action
Visual Basic (Declaration)
Public NotInheritable Class Emboss _
    Inherits Action
Visual C++
public ref class Emboss sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Emboss

See Also

Emboss Members


Emboss Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss Members
Emboss Class Constructors Methods Properties See Also Send Feedback

The Emboss type exposes the following members.

Constructors

Name | Description
Emboss | Initializes a new instance of the Emboss class.

Methods

Name | Description
Clone | Creates a copy of the current Emboss. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BumpHeight | Gets or sets the bump height for embossing.
LightAngle | Gets or sets the light angle. It is measured counterclockwise from the x-axis.
LightElevation | Gets or sets the light elevation.
ReliefTexture | Gets or sets whether a colored relief of the target element should be displayed.

See Also

Emboss Class


Emboss Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss Constructor
Emboss Class See Also Send Feedback
Initializes a new instance of the Emboss class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Emboss()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Emboss()

See Also

Emboss Class


Emboss Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss Methods
Emboss Class See Also Send Feedback

The Emboss type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Emboss. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Emboss Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss..::.Clone Method
Emboss Class See Also Send Feedback
Creates a copy of the current Emboss.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Emboss.

See Also

Emboss Class


Emboss Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss Properties
Emboss Class See Also Send Feedback

The Emboss type exposes the following members.

Properties

Name | Description
BumpHeight | Gets or sets the bump height for embossing.
LightAngle | Gets or sets the light angle. It is measured counterclockwise from the x-axis.
LightElevation | Gets or sets the light elevation.
ReliefTexture | Gets or sets whether a colored relief of the target element should be displayed.

See Also

Emboss Class


BumpHeight Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss..::.BumpHeight Property
Emboss Class See Also Send Feedback
Gets or sets the bump height for embossing.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int BumpHeight { get; set; }
Visual Basic (Declaration)
Public Property BumpHeight As Integer
Visual C++
public:
property int BumpHeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 2 to 100.

See Also

Emboss Class


LightAngle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss..::.LightAngle Property
Emboss Class See Also Send Feedback
Gets or sets the light angle. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LightAngle { get; set; }
Visual Basic (Declaration)
Public Property LightAngle As Integer
Visual C++
public:
property int LightAngle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

Emboss Class


LightElevation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss..::.LightElevation Property
Emboss Class See Also Send Feedback
Gets or sets the light elevation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LightElevation { get; set; }
Visual Basic (Declaration)
Public Property LightElevation As Integer
Visual C++
public:
property int LightElevation {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 90.

See Also

Emboss Class


ReliefTexture Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Emboss..::.ReliefTexture Property
Emboss Class See Also Send Feedback
Gets or sets whether a colored relief of the target element should be displayed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReliefTexture { get; set; }
Visual Basic (Declaration)
Public Property ReliefTexture As Boolean
Visual C++
public:
property bool ReliefTexture {
    bool get ();
    void set (bool value);
}

See Also

Emboss Class


ExifTags Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ExifTags Enumeration
See Also Send Feedback
Specifies the Exif (Exchangeable Image File Format) tags based on Exif v2.2 (JEITA CP-3451)

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ExifTags
Visual Basic (Declaration)
Public Enumeration ExifTags
Visual C++
public enum class ExifTags

Members

Member name | Description
ImageWidth | The number of columns of image data, equal to the number of pixels per row. In JPEG compressed data a JPEG marker is used instead of this tag.
ImageLength | The number of rows of image data. In JPEG compressed data a JPEG marker is used instead of this tag.
BitsPerSample | The number of bits per image component. In this standard each component of the image is 8 bits, so the value for this tag is 8. See also SamplesPerPixel. In JPEG compressed data a JPEG marker is used instead of this tag.
Compression | The compression scheme used for the image data. When a primary image is JPEG compressed, this designation is not necessary and is omitted. When thumbnails use JPEG compression, this tag value is set to 6.
PhotometricInterpretation | The pixel composition. In JPEG compressed data a JPEG marker is used instead of this tag.
ImageDescription | A character string giving the title of the image.
Make | The manufacturer of the recording equipment. This is the manufacturer of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank, it is treated as unknown.
Model | The model name or model number of the equipment. This is the model name of number of the DSC, scanner, video digitizer or other equipment that generated the image. When the field is left blank, it is treated as unknown.
StripOffsets | For each strip, the byte offset of that strip. It is recommended that this be selected so the number of strip bytes does not exceed 64 Kbytes. With JPEG compressed data this designation is not needed and is omitted. See also RowsPerStrip and StripByteCounts.
Orientation | The image orientation viewed in terms of rows and columns.
SamplesPerPixel | The number of components per pixel. Since this standard applies to RGB and YCbCr images, the value set for this tag is 3. In JPEG compressed data a JPEG marker is used instead of this tag.
RowsPerStrip | The number of rows per strip. This is the number of rows in the image of one strip when an image is divided into strips. With JPEG compressed data this designation is not needed and is omitted. See also RowsPerStrip and StripByteCounts.
StripByteCounts | The total number of bytes in each strip. With JPEG compressed data this designation is not needed and is omitted.
XResolution | The number of pixels per ResolutionUnit in the ImageWidth direction. When the image resolution is unknown, 72 dpi is designated.
YResolution | The number of pixels per ResolutionUnit in the ImageLength direction. The same value as XResolution is designated.
PlanarConfiguration | Indicates whether pixel components are recorded in chunky or planar format. In JPEG compressed files a JPEG marker is used instead of this tag. If this field does not exist, the TIFF default of 1 (chunky) is assumed.
ResolutionUnit | The unit for measuring XResolution and YResolution. The same unit is used for both XResolution and YResolution. If the image resolution in unknown, 2 (inches) is designated.
TransferFunction | A transfer function for the image, described in tabular style. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
Software | This tag records the name and version of the software or firmware of the camera or image input device used to generate the image.
DateTime | The date and time of image creation. In this standard it is the date and time the file was changed.
Artist | This tag records the name of the camera owner, photographer or image creator.
WhitePoint | The chromaticity of the white point of the image. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
PrimaryChromaticities | The chromaticity of the three primary colors of the image. Normally this tag is not necessary, since color space is specified in the color space information tag (ColorSpace).
JPEGInterchangeFormat | The offset to the start byte (SOI) of JPEG compressed thumbnail data. This is not used for primary image JPEG data.
JPEGInterchangeFormatLength | The number of bytes of JPEG compressed thumbnail data. This is not used for primary image JPEG data.
YCbCrCoefficients | The matrix coefficients for transformation from RGB to YCbCr image data.
YCbCrSubSampling | The sampling ratio of chrominance components in relation to the luminance component. In JPEG compressed data a JPEG marker is used instead of this tag.
YCbCrPositioning | The position of chrominance components in relation to the luminance component.
ReferenceBlackWhite | The reference black point value and reference white point value.
Copyright | Copyright information. In this standard the tag is used to indicate both the photographer and editor copyrights. It is the copyright notice of the person or organization claiming rights to the image.
ExposureTime | Exposure time, given in seconds (sec).
FNumber | The F number.
ExposureProgram | The class of the program used by the camera to set exposure when the picture is taken.
SpectralSensitivity | Indicates the spectral sensitivity of each channel of the camera used. The tag value is an ASCII string compatible with the standard developed by the ASTM Technical committee.
ISOSpeedRatings | Indicates the ISO Speed and ISO Latitude of the camera or input device as specified in ISO 12232.
OECF | Indicates the Opto-Electric Conversion Function (OECF) specified in ISO 14524. OECF is the relationship between the camera optical input and the image values.
ExifVersion | The version of this standard supported.
DateTimeOriginal | The date and time when the original image data was generated. For a DSC the date and time the picture was taken are recorded.
DateTimeDigitized | The date and time when the image was stored as digital data. If, for example, an image was captured by DSC and at the same time the file was recorded, then the DateTimeOriginal and DateTimeDigitized will have the same contents.
ComponentsConfiguration | Information specific to compressed data. The channels of each component are arranged in order from the 1st component to the 4th. For uncompressed data the data arrangement is given in the PhotometricInterpretation tag.
CompressedBitsPerPixel | Information specific to compressed data. The compression mode used for a compressed image is indicated in unit bits per pixel.
ShutterSpeedValue | Shutter speed. The unit is the APEX (Additive System of Photographic Exposure) setting.
ApertureValue | The lens aperture. The unit is the APEX (Additive System of Photographic Exposure) value.
BrightnessValue | The value of brightness. The unit is the APEX (Additive System of Photographic Exposure) value. Ordinarily it is given in the range of -99.99 to 99.99.
ExposureBiasValue | The exposure bias. The unit is the APEX (Additive System of Photographic Exposure) value. Ordinarily it is given in the range of –99.99 to 99.99.
MaxApertureValue | The smallest F number of the lens. The unit is the APEX (Additive System of Photographic Exposure) value. Ordinarily it is given in the range of 00.00 to 99.99, but it is not limited to this range.
SubjectDistance | The distance to the subject, given in meters.
MeteringMode | The metering mode.
LightSource | The kind of light source.
Flash | This tag indicates the status of flash when the image was shot.
FocalLength | The actual focal length of the lens, in mm.
SubjectArea | This tag indicates the location and area of the main subject in the overall scene.
MakerNote | A tag for manufacturers of Exif writers to record any desired information.
UserComment | A tag for Exif users to write keywords or comments on the image besides those in ImageDescription, and without the character code limitations of the ImageDescription tag.
SubsecTime | A tag used to record fractions of seconds for the DateTime tag.
SubsecTimeOriginal | A tag used to record fractions of seconds for the DateTimeOriginal tag.
SubsecTimeDigitized | A tag used to record fractions of seconds for the DateTimeDigitized tag.
FlashpixVersion | The Flashpix format version supported by a FPXR file.
ColorSpace | The color space information tag (ColorSpace) is always recorded as the color space specifier.
PixelXDimension | Information specific to compressed data. When a compressed file is recorded, the valid width of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker. This tag should not exist in an uncompressed file.
PixelYDimension | Information specific to compressed data. When a compressed file is recorded, the valid height of the meaningful image shall be recorded in this tag, whether or not there is padding data or a restart marker. This tag should not exist in an uncompressed file.
RelatedSoundFile | This tag is used to record the name of an audio file related to the image data.
FlashEnergy | Indicates the strobe energy at the time the image is captured, as measured in Beam Candle Power Seconds (BCPS).
SpatialFrequencyResponse | This tag records the camera or input device spatial frequency table and SFR values in the direction of image width, image height, and diagonal direction, as specified in ISO 12233.
FocalPlaneXResolution | Indicates the number of pixels in the image width (X) direction per FocalPlaneResolutionUnit on the camera focal plane.
FocalPlaneYResolution | Indicates the number of pixels in the image height (Y) direction per FocalPlaneResolutionUnit on the camera focal plane.
FocalPlaneResolutionUnit | Indicates the unit for measuring FocalPlaneXResolution and FocalPlaneYResolution. This value is the same as the ResolutionUnit.
SubjectLocation | Indicates the location of the main subject in the scene.
ExposureIndex | Indicates the exposure index selected on the camera or input device at the time the image is captured.
SensingMethod | Indicates the image sensor type on the camera or input device.
FileSource | Indicates the image source. If a DSC recorded the image, this tag value of this tag always be set to 3, indicating that the image was recorded on a DSC.
SceneType | Indicates the type of scene. If a DSC recorded the image, this tag value shall always be set to 1, indicating that the image was directly photographed.
CFAPattern | Indicates the color filter array (CFA) geometric pattern of the image sensor when a one-chip color area sensor is used. It does not apply to all sensing methods.
CustomRendered | This tag indicates the use of special processing on image data, such as rendering geared to output. When special processing is performed, the reader is expected to disable or minimize any further processing.
ExposureMode | This tag indicates the exposure mode set when the image was shot. In auto-bracketing mode, the camera shoots a series of frames of the same scene at different exposure settings.
WhiteBalance | This tag indicates the white balance mode set when the image was shot.
DigitalZoomRatio | This tag indicates the digital zoom ratio when the image was shot. If the numerator of the recorded value is 0, this indicates that digital zoom was not used.
FocalLengthIn35mmFilm | This tag indicates the equivalent focal length assuming a 35mm film camera, in mm. A value of 0 means the focal length is unknown. Note that this tag differs from the FocalLength tag.
SceneCaptureType | This tag indicates the type of scene that was shot. It can also be used to record the mode in which the image was shot. Note that this differs from the scene type (SceneType) tag.
GainControl | This tag indicates the degree of overall image gain adjustment.
Contrast | This tag indicates the direction of contrast processing applied by the camera when the image was shot.
Saturation | This tag indicates the direction of saturation processing applied by the camera when the image was shot.
Sharpness | This tag indicates the direction of sharpness processing applied by the camera when the image was shot.
DeviceSettingDescription | This tag indicates information on the picture-taking conditions of a particular camera model.
SubjectDistanceRange | This tag indicates the distance to the subject.
ImageUniqueID | This tag indicates an identifier assigned uniquely to each image.
GPSVersionID | Indicates the version of GPSInfoIFD. The version is given as 2.2.0.0. This tag is mandatory when GPSInfo tag is present.
GPSLatitudeRef | Indicates whether the latitude is north (N) or south (S) latitude.
GPSLatitude | Indicates the latitude. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.
GPSLongitudeRef | Indicates whether the longitude is east (E) or west (W) longitude.
GPSLongitude | Indicates the longitude. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.
GPSAltitudeRef | Indicates the altitude used as the reference altitude. If the reference is sea level and the altitude is above sea level, 0 is given. If the altitude is below sea level, a value of 1 is given and the altitude is indicated as an absolute value in the GPSAltitude tag. The reference unit is meters.
GPSAltitude | Indicates the altitude based on the reference in GPSAltitudeRef. The reference unit is meters.
GPSTimeStamp | Indicates the time as UTC (Coordinated Universal Time).
GPSSatellites | Indicates the GPS satellites used for measurements. This tag can be used to describe the number of satellites, their ID number, angle of elevation, azimuth, SNR and other information.
GPSStatus | Indicates the status of the GPS receiver when the image is recorded. 'A' means measurement is in progress, and 'V' means the measurement is Interoperability.
GPSMeasureMode | Indicates the GPS measurement mode. '2' means two-dimensional measurement and '3' means three-dimensional measurement is in progress.
GPSDOP | Indicates the GPS DOP (data degree of precision). An HDOP value is written during two-dimensional measurement, and PDOP during three-dimensional measurement.
GPSSpeedRef | Indicates the unit used to express the GPS receiver speed of movement. 'K' 'M' and 'N' represents kilometers per hour, miles per hour, and knots.
GPSSpeed | Indicates the speed of GPS receiver movement.
GPSTrackRef | Indicates the reference for giving the direction of GPS receiver movement. 'T' denotes true direction and 'M' is magnetic direction.
GPSTrack | Indicates the direction of GPS receiver movement. The range of values is from 0.00 to 359.99.
GPSImgDirectionRef | Indicates the reference for giving the direction of the image when it is captured. 'T' denotes true direction and 'M' is magnetic direction.
GPSImgDirection | Indicates the direction of the image when it was captured. The range of values is from 0.00 to 359.99.
GPSMapDatum | Indicates the geodetic survey data used by the GPS receiver.
GPSDestLatitudeRef | Indicates whether the latitude of the destination point is north (N) or south (S) latitude.
GPSDestLatitude | Indicates the latitude of the destination point. The latitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If latitude is expressed as degrees, minutes and seconds, a typical format would be dd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be dd/1,mmmm/100,0/1.
GPSDestLongitudeRef | Indicates whether the longitude of the destination point is east (E) or west (W) longitude.
GPSDestLongitude | Indicates the longitude of the destination point. The longitude is expressed as three RATIONAL values giving the degrees, minutes, and seconds, respectively. If longitude is expressed as degrees, minutes and seconds, a typical format would be ddd/1,mm/1,ss/1. When degrees and minutes are used and, for example, fractions of minutes are given up to two decimal places, the format would be ddd/1,mmmm/100,0/1.
GPSDestBearingRef | Indicates the reference used for giving the bearing to the destination point. 'T' denotes true direction and 'M' is magnetic direction.
GPSDestBearing | Indicates the bearing to the destination point. The range of values is from 0.00 to 359.99.
GPSDestDistanceRef | Indicates the unit used to express the distance to the destination point. 'K', 'M' and 'N' represent kilometers, miles and knots.
GPSDestDistance | Indicates the distance to the destination point.
GPSProcessingMethod | A character string recording the name of the method used for location finding.
GPSAreaInformation | A character string recording the name of the GPS area.
GPSDateStamp | A character string recording date and time information relative to UTC (Coordinated Universal Time).
GPSDifferential | Indicates whether differential correction is applied to the GPS receiver.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Fade Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Class
Members See Also Send Feedback
It defines an action that performs fading. Fading action/effect gradually fades a given area/region of the target Element into the background. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Fade : Action
Visual Basic (Declaration)
Public NotInheritable Class Fade _
    Inherits Action
Visual C++
public ref class Fade sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Fade

See Also

Fade Members


Fade Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Members
Fade Class Constructors Methods Properties See Also Send Feedback

The Fade type exposes the following members.

Constructors

Name | Description
Fade | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Fade. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the height of the fading shape area/region.
Location | Gets or sets how the area/region's shape used for fading will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for fading. Use it for performing Path or RoundedPath fading.
PolygonSides | Gets or sets the number of sides of the polygon shape used for fading.
Roundness | Gets or sets the shape roundness used for fading.
Shape | Gets or sets the area/region's shape used for fading.
ShapeFill | Gets the shape's fill used for fading.
Sizing | Gets or sets the area/region's size type used for fading. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for fading.
StarPoints | Gets or sets the number of points of the star shape used for fading.
Width | Gets or sets the width of the fading shape area/region.
X | Gets or sets the x-coordinate of the left side of the fading shape area/region.
Y | Gets or sets the y-coordinate of the top side of the fading shape area/region.

See Also

Fade Class


Fade Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Constructor
Fade Class See Also Send Feedback

Overload List

Name | Description
Fade()()() | Initializes a new instance of the Fade class.
Fade(FadeShape) | Initializes a new instance of the Fade class with the specified fading settings.

See Also

Fade Class
Fade Members


Fade Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Constructor
Fade Class See Also Send Feedback
Initializes a new instance of the Fade class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fade()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Fade()

See Also

Fade Class
Fade Overload


Fade Constructor (FadeShape)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Constructor (FadeShape)
Fade Class See Also Send Feedback
Initializes a new instance of the Fade class with the specified fading settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fade(
    FadeShape shape
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FadeShape _
)
Visual C++
public:
Fade(
    FadeShape shape
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FadeShape
The area/region's shape used for fading.

See Also

Fade Class
Fade Overload


Fade Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Methods
Fade Class See Also Send Feedback

The Fade type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Fade. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Fade Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Clone Method
Fade Class See Also Send Feedback
Creates a copy of the current Fade.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Fade.

See Also

Fade Class


Fade Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade Properties
Fade Class See Also Send Feedback

The Fade type exposes the following members.

Properties

Name | Description
Height | Gets or sets the height of the fading shape area/region.
Location | Gets or sets how the area/region's shape used for fading will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for fading. Use it for performing Path or RoundedPath fading.
PolygonSides | Gets or sets the number of sides of the polygon shape used for fading.
Roundness | Gets or sets the shape roundness used for fading.
Shape | Gets or sets the area/region's shape used for fading.
ShapeFill | Gets the shape's fill used for fading.
Sizing | Gets or sets the area/region's size type used for fading. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for fading.
StarPoints | Gets or sets the number of points of the star shape used for fading.
Width | Gets or sets the width of the fading shape area/region.
X | Gets or sets the x-coordinate of the left side of the fading shape area/region.
Y | Gets or sets the y-coordinate of the top side of the fading shape area/region.

See Also

Fade Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Height Property
Fade Class See Also Send Feedback
Gets or sets the height of the fading shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Fade Class


Location Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Location Property
Fade Class See Also Send Feedback
Gets or sets how the area/region's shape used for fading will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FadeLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As FadeLocation
Visual C++
public:
property FadeLocation Location {
    FadeLocation get ();
    void set (FadeLocation value);
}

See Also

Fade Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.PathPoints Property
Fade Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for fading. Use it for performing Path or RoundedPath fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

Fade Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.PolygonSides Property
Fade Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

Fade Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Roundness Property
Fade Class See Also Send Feedback
Gets or sets the shape roundness used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Fade Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Shape Property
Fade Class See Also Send Feedback
Gets or sets the area/region's shape used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FadeShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FadeShape
Visual C++
public:
property FadeShape Shape {
    FadeShape get ();
    void set (FadeShape value);
}

See Also

Fade Class


ShapeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.ShapeFill Property
Fade Class See Also Send Feedback
Gets the shape's fill used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ShapeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeFill As Fill
Visual C++
public:
property Fill^ ShapeFill {
    Fill^ get ();
}

See Also

Fade Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Sizing Property
Fade Class See Also Send Feedback
Gets or sets the area/region's size type used for fading. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FadeSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FadeSizing
Visual C++
public:
property FadeSizing Sizing {
    FadeSizing get ();
    void set (FadeSizing value);
}

See Also

Fade Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.StarInnerRadiusPercentage Property
Fade Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

Fade Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.StarPoints Property
Fade Class See Also Send Feedback
Gets or sets the number of points of the star shape used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

Fade Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Width Property
Fade Class See Also Send Feedback
Gets or sets the width of the fading shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Fade Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.X Property
Fade Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the fading shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

Fade Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fade..::.Y Property
Fade Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the fading shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

Fade Class


FadeLocation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FadeLocation Enumeration
See Also Send Feedback
Specifies how the area/region's shape used for fading will be positioned.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FadeLocation
Visual Basic (Declaration)
Public Enumeration FadeLocation
Visual C++
public enum class FadeLocation

Members

Member name | Description
Center | The area/region's shape used for fading is centered on target element.
Custom | The position of the area/region's shape used for fading must be specified by X and Y properties.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FadeShape Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FadeShape Enumeration
See Also Send Feedback
Specifies the area/region's shape used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FadeShape
Visual Basic (Declaration)
Public Enumeration FadeShape
Visual C++
public enum class FadeShape

Members

Member name | Description
Rectangle |
Oval |
Polygon |
Star |
Path |
RoundedRectangle |
RoundedPolygon |
RoundedStar |
RoundedPath |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FadeSizing Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FadeSizing Enumeration
See Also Send Feedback
Specifies the area/region's size type used for fading.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FadeSizing
Visual Basic (Declaration)
Public Enumeration FadeSizing
Visual C++
public enum class FadeSizing

Members

Member name | Description
Custom | The area/region's size must be specified by Width and Height properties.
Fit | The area/region's size will automatically fit to the target Element's size

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Feather Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Class
Members See Also Send Feedback
It defines an action that performs feathering. Feathering blurs the edges of a given area/region on the target Element, blending it into the background. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Feather : Action
Visual Basic (Declaration)
Public NotInheritable Class Feather _
    Inherits Action
Visual C++
public ref class Feather sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Feather

See Also

Feather Members


Feather Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Members
Feather Class Constructors Methods Properties See Also Send Feedback

The Feather type exposes the following members.

Constructors

Name | Description
Feather | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Feather. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
FeatherRadius | Gets or sets the amount of feathering.
Height | Gets or sets the height of the feathering shape area/region.
PathPoints | Gets or sets a string containing pairs of point describing the path for feathering. Use it for performing Path or RoundedPath feathering.
PolygonSides | Gets or sets the number of sides of the polygon shape used for feathering.
Roundness | Gets or sets the shape roundness used for feathering.
Shape | Gets or sets the area/region's shape used for feathering.
Sizing | Gets or sets the area/region's size type used for feathering. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for feathering.
StarPoints | Gets or sets the number of points of the star shape used for feathering.
Width | Gets or sets the width of the feathering shape area/region.

See Also

Feather Class


Feather Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Constructor
Feather Class See Also Send Feedback

Overload List

Name | Description
Feather()()() | Initializes a new instance of the Feather class.
Feather(FeatherShape, Int32) | Initializes a new instance of the Feather class with the specified feather settings.

See Also

Feather Class
Feather Members


Feather Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Constructor
Feather Class See Also Send Feedback
Initializes a new instance of the Feather class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Feather()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Feather()

See Also

Feather Class
Feather Overload


Feather Constructor (FeatherShape, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Constructor (FeatherShape, Int32)
Feather Class See Also Send Feedback
Initializes a new instance of the Feather class with the specified feather settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Feather(
    FeatherShape shape,
    int radius
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FeatherShape, _
    radius As Integer _
)
Visual C++
public:
Feather(
    FeatherShape shape,
    int radius
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FeatherShape
The area/region's shape used for feathering.
radius
Type: System..::.Int32
The amount of feathering.

See Also

Feather Class
Feather Overload


Feather Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Methods
Feather Class See Also Send Feedback

The Feather type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Feather. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Feather Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Clone Method
Feather Class See Also Send Feedback
Creates a copy of the current Feather.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Feather.

See Also

Feather Class


Feather Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather Properties
Feather Class See Also Send Feedback

The Feather type exposes the following members.

Properties

Name | Description
FeatherRadius | Gets or sets the amount of feathering.
Height | Gets or sets the height of the feathering shape area/region.
PathPoints | Gets or sets a string containing pairs of point describing the path for feathering. Use it for performing Path or RoundedPath feathering.
PolygonSides | Gets or sets the number of sides of the polygon shape used for feathering.
Roundness | Gets or sets the shape roundness used for feathering.
Shape | Gets or sets the area/region's shape used for feathering.
Sizing | Gets or sets the area/region's size type used for feathering. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for feathering.
StarPoints | Gets or sets the number of points of the star shape used for feathering.
Width | Gets or sets the width of the feathering shape area/region.

See Also

Feather Class


FeatherRadius Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.FeatherRadius Property
Feather Class See Also Send Feedback
Gets or sets the amount of feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int FeatherRadius { get; set; }
Visual Basic (Declaration)
Public Property FeatherRadius As Integer
Visual C++
public:
property int FeatherRadius {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Feather Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Height Property
Feather Class See Also Send Feedback
Gets or sets the height of the feathering shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Feather Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.PathPoints Property
Feather Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for feathering. Use it for performing Path or RoundedPath feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

Feather Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.PolygonSides Property
Feather Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

Feather Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Roundness Property
Feather Class See Also Send Feedback
Gets or sets the shape roundness used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Feather Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Shape Property
Feather Class See Also Send Feedback
Gets or sets the area/region's shape used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FeatherShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FeatherShape
Visual C++
public:
property FeatherShape Shape {
    FeatherShape get ();
    void set (FeatherShape value);
}

See Also

Feather Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Sizing Property
Feather Class See Also Send Feedback
Gets or sets the area/region's size type used for feathering. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FeatherSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FeatherSizing
Visual C++
public:
property FeatherSizing Sizing {
    FeatherSizing get ();
    void set (FeatherSizing value);
}

See Also

Feather Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.StarInnerRadiusPercentage Property
Feather Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

Feather Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.StarPoints Property
Feather Class See Also Send Feedback
Gets or sets the number of points of the star shape used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

Feather Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Feather..::.Width Property
Feather Class See Also Send Feedback
Gets or sets the width of the feathering shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Feather Class


FeatherShape Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FeatherShape Enumeration
See Also Send Feedback
Specifies the area/region's shape used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FeatherShape
Visual Basic (Declaration)
Public Enumeration FeatherShape
Visual C++
public enum class FeatherShape

Members

Member name | Description
Rectangle |
Oval |
Polygon |
Star |
Path |
VerticalSides |
HorizontalSides |
RoundedRectangle |
RoundedPolygon |
RoundedStar |
RoundedPath |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FeatherSizing Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FeatherSizing Enumeration
See Also Send Feedback
Specifies the area/region's size type used for feathering.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FeatherSizing
Visual Basic (Declaration)
Public Enumeration FeatherSizing
Visual C++
public enum class FeatherSizing

Members

Member name | Description
Custom | The area/region's size must be specified by Width and Height properties.
Fit | The area/region's size will automatically fit to the target Element's size

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Fill Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Class
Members See Also Send Feedback
Defines a Fill object used to paint the interior of the given graphical element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Fill : ICloneable
Visual Basic (Declaration)
Public Class Fill _
    Implements ICloneable
Visual C++
public ref class Fill : ICloneable

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Fill

See Also

Fill Members


Fill Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Members
Fill Class Constructors Methods Properties See Also Send Feedback

The Fill type exposes the following members.

Constructors

Name | Description
Fill | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
BackgroundColor | Gets or sets the background color used by Solid and Pattern fill types.
BackgroundTextureUrl | Gets or sets the image URL to fill the interior of a surface used by Texture fill type.
ForegroundColor | Gets or sets the foreground color used by Pattern fill type.
GradientAngle | Gets or sets the orientation angle used by Gradient fill type. It is measured counterclockwise from the x-axis.
GradientBlendColors | Gets or sets the blend colors for gradient fills.
GradientBlendFactors | Gets or sets the blend factors for gradient fills. Factor values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientBlendPositions | Gets or sets the blend positions for gradient fills. Position values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientCentered | Gets or sets whether path gradient must be centered.
GradientCenterPointX | Gets or sets the center point x-coordinate of the gradient fill.
GradientCenterPointY | Gets or sets the center point y-coordinate of the gradient fill.
GradientColor1 | Gets or sets the starting color used by Gradient fill type.
GradientColor2 | Gets or sets the ending color used by Gradient fill type.
GradientFocusScaleX | Gets or sets the focus point x-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientFocusScaleY | Gets or sets the focus point y-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientShade | Gets or sets the shading style used for creating gradient fills.
GradientShadeFocus | Gets or sets the position of the gradient's starting color. The position is a percentage of the distance between the boundary lines and must be in the range from 0 through 100.
GradientShadeScale | Gets or sets the percentage of the gradient's starting color that gets blended, at the focus position, with the gradient's ending color. The scale parameter must be in the range from 0 through 100. The default value is 100, which specifies that the ending color is at full intensity.
GradientShape | Gets or sets the shape used for creating gradient fills.
Pattern | Gets or sets the pattern or hatch style used by Pattern fill type.
Type | Gets or sets the fill type.
WrapMode | Gets or sets a WrapMode enumeration that indicates the wrap mode for Texture fill type.

See Also

Fill Class


Fill Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor
Fill Class See Also Send Feedback

Overload List

Name | Description
Fill()()() | Initializes a new instance of the Fill class.
Fill(Color) | Initializes a new instance of the Fill class which fill type is Solid.
Fill(String, WrapMode) | Initializes a new instance of the Fill class which fill type is Texture.
Fill(Color, Color, Int32) | Initializes a new instance of the Fill class which fill type is Gradient.
Fill(HatchStyle, Color, Color) | Initializes a new instance of the Fill class which fill type is Pattern.

See Also

Fill Class
Fill Members


Fill Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Fill()

See Also

Fill Class
Fill Overload


Fill Constructor (Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor (Color)
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class which fill type is Solid.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill(
    Color backgroundColor
)
Visual Basic (Declaration)
Public Sub New ( _
    backgroundColor As Color _
)
Visual C++
public:
Fill(
    Color backgroundColor
)

Parameters

backgroundColor
Type: System.Drawing..::.Color
The background color.

See Also

Fill Class
Fill Overload


Fill Constructor (String, WrapMode)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor (String, WrapMode)
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class which fill type is Texture.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill(
    string backgroundTextureUrl,
    WrapMode wrapMode
)
Visual Basic (Declaration)
Public Sub New ( _
    backgroundTextureUrl As String, _
    wrapMode As WrapMode _
)
Visual C++
public:
Fill(
    String^ backgroundTextureUrl,
    WrapMode wrapMode
)

Parameters

backgroundTextureUrl
Type: System..::.String
The image URL with which this Fill object paints interiors.
wrapMode
Type: System.Drawing.Drawing2D..::.WrapMode
A WrapMode enumeration that specifies how this Fill object is tiled.

See Also

Fill Class
Fill Overload


Fill Constructor (Color, Color, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor (Color, Color, Int32)
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class which fill type is Gradient.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill(
    Color gradientColor1,
    Color gradientColor2,
    int gradientAngle
)
Visual Basic (Declaration)
Public Sub New ( _
    gradientColor1 As Color, _
    gradientColor2 As Color, _
    gradientAngle As Integer _
)
Visual C++
public:
Fill(
    Color gradientColor1,
    Color gradientColor2,
    int gradientAngle
)

Parameters

gradientColor1
Type: System.Drawing..::.Color
The starting color of the gradient.
gradientColor2
Type: System.Drawing..::.Color
The ending color of the gradient.
gradientAngle
Type: System..::.Int32
The orientation angle of the gradient. It is measured counterclockwise from the x-axis.

See Also

Fill Class
Fill Overload


Fill Constructor (HatchStyle, Color, Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Constructor (HatchStyle, Color, Color)
Fill Class See Also Send Feedback
Initializes a new instance of the Fill class which fill type is Pattern.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill(
    HatchStyle pattern,
    Color backgroundColor,
    Color foregroundColor
)
Visual Basic (Declaration)
Public Sub New ( _
    pattern As HatchStyle, _
    backgroundColor As Color, _
    foregroundColor As Color _
)
Visual C++
public:
Fill(
    HatchStyle pattern,
    Color backgroundColor,
    Color foregroundColor
)

Parameters

pattern
Type: System.Drawing.Drawing2D..::.HatchStyle
The pattern or hatch style.
backgroundColor
Type: System.Drawing..::.Color
The background color.
foregroundColor
Type: System.Drawing..::.Color
The foreground color.

See Also

Fill Class
Fill Overload


Fill Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Methods
Fill Class See Also Send Feedback

The Fill type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Fill.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

See Also

Fill Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.Clone Method
Fill Class See Also Send Feedback
Creates a copy of the current Fill.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Return Value

A copy of the current Fill.

Implements

ICloneable..::.Clone()()()

See Also

Fill Class


ToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.ToString Method
Fill Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the Fill object to a string representation, using the current CultureInfo. (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Converts the Fill object to a string representation, using the specified CultureInfo.

See Also

Fill Class
Fill Members


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.ToString Method
Fill Class See Also Send Feedback
Converts the Fill object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the Fill object in the current culture.

See Also

Fill Class
ToString Overload


ToString Method (CultureInfo)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.ToString Method (CultureInfo)
Fill Class See Also Send Feedback
Converts the Fill object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that contains the culture to represent the Fill.

Return Value

The string representation of the Fill object in the specified culture.

See Also

Fill Class
ToString Overload


Fill Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill Properties
Fill Class See Also Send Feedback

The Fill type exposes the following members.

Properties

Name | Description
BackgroundColor | Gets or sets the background color used by Solid and Pattern fill types.
BackgroundTextureUrl | Gets or sets the image URL to fill the interior of a surface used by Texture fill type.
ForegroundColor | Gets or sets the foreground color used by Pattern fill type.
GradientAngle | Gets or sets the orientation angle used by Gradient fill type. It is measured counterclockwise from the x-axis.
GradientBlendColors | Gets or sets the blend colors for gradient fills.
GradientBlendFactors | Gets or sets the blend factors for gradient fills. Factor values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientBlendPositions | Gets or sets the blend positions for gradient fills. Position values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientCentered | Gets or sets whether path gradient must be centered.
GradientCenterPointX | Gets or sets the center point x-coordinate of the gradient fill.
GradientCenterPointY | Gets or sets the center point y-coordinate of the gradient fill.
GradientColor1 | Gets or sets the starting color used by Gradient fill type.
GradientColor2 | Gets or sets the ending color used by Gradient fill type.
GradientFocusScaleX | Gets or sets the focus point x-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientFocusScaleY | Gets or sets the focus point y-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.
GradientShade | Gets or sets the shading style used for creating gradient fills.
GradientShadeFocus | Gets or sets the position of the gradient's starting color. The position is a percentage of the distance between the boundary lines and must be in the range from 0 through 100.
GradientShadeScale | Gets or sets the percentage of the gradient's starting color that gets blended, at the focus position, with the gradient's ending color. The scale parameter must be in the range from 0 through 100. The default value is 100, which specifies that the ending color is at full intensity.
GradientShape | Gets or sets the shape used for creating gradient fills.
Pattern | Gets or sets the pattern or hatch style used by Pattern fill type.
Type | Gets or sets the fill type.
WrapMode | Gets or sets a WrapMode enumeration that indicates the wrap mode for Texture fill type.

See Also

Fill Class


BackgroundColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.BackgroundColor Property
Fill Class See Also Send Feedback
Gets or sets the background color used by Solid and Pattern fill types.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color BackgroundColor { get; set; }
Visual Basic (Declaration)
Public Property BackgroundColor As Color
Visual C++
public:
property Color BackgroundColor {
    Color get ();
    void set (Color value);
}

See Also

Fill Class


BackgroundTextureUrl Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.BackgroundTextureUrl Property
Fill Class See Also Send Feedback
Gets or sets the image URL to fill the interior of a surface used by Texture fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string BackgroundTextureUrl { get; set; }
Visual Basic (Declaration)
Public Property BackgroundTextureUrl As String
Visual C++
public:
property String^ BackgroundTextureUrl {
    String^ get ();
    void set (String^ value);
}

See Also

Fill Class


ForegroundColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.ForegroundColor Property
Fill Class See Also Send Feedback
Gets or sets the foreground color used by Pattern fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ForegroundColor { get; set; }
Visual Basic (Declaration)
Public Property ForegroundColor As Color
Visual C++
public:
property Color ForegroundColor {
    Color get ();
    void set (Color value);
}

See Also

Fill Class


GradientAngle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientAngle Property
Fill Class See Also Send Feedback
Gets or sets the orientation angle used by Gradient fill type. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int GradientAngle { get; set; }
Visual Basic (Declaration)
Public Property GradientAngle As Integer
Visual C++
public:
property int GradientAngle {
    int get ();
    void set (int value);
}

See Also

Fill Class


GradientBlendColors Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientBlendColors Property
Fill Class See Also Send Feedback
Gets or sets the blend colors for gradient fills.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color[] GradientBlendColors { get; set; }
Visual Basic (Declaration)
Public Property GradientBlendColors As Color()
Visual C++
public:
property array<Color>^ GradientBlendColors {
    array<Color>^ get ();
    void set (array<Color>^ value);
}

See Also

Fill Class


GradientBlendFactors Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientBlendFactors Property
Fill Class See Also Send Feedback
Gets or sets the blend factors for gradient fills. Factor values must be expressed in terms of percentages i.e. ranging from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int[] GradientBlendFactors { get; set; }
Visual Basic (Declaration)
Public Property GradientBlendFactors As Integer()
Visual C++
public:
property array<int>^ GradientBlendFactors {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Fill Class


GradientBlendPositions Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientBlendPositions Property
Fill Class See Also Send Feedback
Gets or sets the blend positions for gradient fills. Position values must be expressed in terms of percentages i.e. ranging from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int[] GradientBlendPositions { get; set; }
Visual Basic (Declaration)
Public Property GradientBlendPositions As Integer()
Visual C++
public:
property array<int>^ GradientBlendPositions {
    array<int>^ get ();
    void set (array<int>^ value);
}

See Also

Fill Class


GradientCentered Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientCentered Property
Fill Class See Also Send Feedback
Gets or sets whether path gradient must be centered.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool GradientCentered { get; set; }
Visual Basic (Declaration)
Public Property GradientCentered As Boolean
Visual C++
public:
property bool GradientCentered {
    bool get ();
    void set (bool value);
}

See Also

Fill Class


GradientCenterPointX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientCenterPointX Property
Fill Class See Also Send Feedback
Gets or sets the center point x-coordinate of the gradient fill.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float GradientCenterPointX { get; set; }
Visual Basic (Declaration)
Public Property GradientCenterPointX As Single
Visual C++
public:
property float GradientCenterPointX {
    float get ();
    void set (float value);
}

See Also

Fill Class


GradientCenterPointY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientCenterPointY Property
Fill Class See Also Send Feedback
Gets or sets the center point y-coordinate of the gradient fill.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float GradientCenterPointY { get; set; }
Visual Basic (Declaration)
Public Property GradientCenterPointY As Single
Visual C++
public:
property float GradientCenterPointY {
    float get ();
    void set (float value);
}

See Also

Fill Class


GradientColor1 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientColor1 Property
Fill Class See Also Send Feedback
Gets or sets the starting color used by Gradient fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color GradientColor1 { get; set; }
Visual Basic (Declaration)
Public Property GradientColor1 As Color
Visual C++
public:
property Color GradientColor1 {
    Color get ();
    void set (Color value);
}

See Also

Fill Class


GradientColor2 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientColor2 Property
Fill Class See Also Send Feedback
Gets or sets the ending color used by Gradient fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color GradientColor2 { get; set; }
Visual Basic (Declaration)
Public Property GradientColor2 As Color
Visual C++
public:
property Color GradientColor2 {
    Color get ();
    void set (Color value);
}

See Also

Fill Class


GradientFocusScaleX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientFocusScaleX Property
Fill Class See Also Send Feedback
Gets or sets the focus point x-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int GradientFocusScaleX { get; set; }
Visual Basic (Declaration)
Public Property GradientFocusScaleX As Integer
Visual C++
public:
property int GradientFocusScaleX {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Fill Class


GradientFocusScaleY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientFocusScaleY Property
Fill Class See Also Send Feedback
Gets or sets the focus point y-coordinate for the gradient falloff. Focus Point values must be expressed in terms of percentages i.e. ranging from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int GradientFocusScaleY { get; set; }
Visual Basic (Declaration)
Public Property GradientFocusScaleY As Integer
Visual C++
public:
property int GradientFocusScaleY {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Fill Class


GradientShade Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientShade Property
Fill Class See Also Send Feedback
Gets or sets the shading style used for creating gradient fills.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GradientShade GradientShade { get; set; }
Visual Basic (Declaration)
Public Property GradientShade As GradientShade
Visual C++
public:
property GradientShade GradientShade {
    GradientShade get ();
    void set (GradientShade value);
}

See Also

Fill Class


GradientShadeFocus Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientShadeFocus Property
Fill Class See Also Send Feedback
Gets or sets the position of the gradient's starting color. The position is a percentage of the distance between the boundary lines and must be in the range from 0 through 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int GradientShadeFocus { get; set; }
Visual Basic (Declaration)
Public Property GradientShadeFocus As Integer
Visual C++
public:
property int GradientShadeFocus {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Fill Class


GradientShadeScale Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientShadeScale Property
Fill Class See Also Send Feedback
Gets or sets the percentage of the gradient's starting color that gets blended, at the focus position, with the gradient's ending color. The scale parameter must be in the range from 0 through 100. The default value is 100, which specifies that the ending color is at full intensity.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int GradientShadeScale { get; set; }
Visual Basic (Declaration)
Public Property GradientShadeScale As Integer
Visual C++
public:
property int GradientShadeScale {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Fill Class


GradientShape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.GradientShape Property
Fill Class See Also Send Feedback
Gets or sets the shape used for creating gradient fills.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GradientShape GradientShape { get; set; }
Visual Basic (Declaration)
Public Property GradientShape As GradientShape
Visual C++
public:
property GradientShape GradientShape {
    GradientShape get ();
    void set (GradientShape value);
}

See Also

Fill Class


Pattern Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.Pattern Property
Fill Class See Also Send Feedback
Gets or sets the pattern or hatch style used by Pattern fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public HatchStyle Pattern { get; set; }
Visual Basic (Declaration)
Public Property Pattern As HatchStyle
Visual C++
public:
property HatchStyle Pattern {
    HatchStyle get ();
    void set (HatchStyle value);
}

See Also

Fill Class


Type Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.Type Property
Fill Class See Also Send Feedback
Gets or sets the fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FillType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As FillType
Visual C++
public:
property FillType Type {
    FillType get ();
    void set (FillType value);
}

See Also

Fill Class


WrapMode Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Fill..::.WrapMode Property
Fill Class See Also Send Feedback
Gets or sets a WrapMode enumeration that indicates the wrap mode for Texture fill type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WrapMode WrapMode { get; set; }
Visual Basic (Declaration)
Public Property WrapMode As WrapMode
Visual C++
public:
property WrapMode WrapMode {
    WrapMode get ();
    void set (WrapMode value);
}

See Also

Fill Class


FillConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter Class
Members See Also Send Feedback
Converts Fill objects from one data type to another. Access the FillConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class FillConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class FillConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class FillConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
Neodynamic.SDK.ImageDraw..::.FillConverter

See Also

FillConverter Members


FillConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter Members
FillConverter Class Constructors Methods See Also Send Feedback

The FillConverter type exposes the following members.

Constructors

Name | Description
FillConverter | Initializes a new instance of the FillConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillConverter Class


FillConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter Constructor
FillConverter Class See Also Send Feedback
Initializes a new instance of the FillConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FillConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FillConverter()

See Also

FillConverter Class


FillConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter Methods
FillConverter Class See Also Send Feedback

The FillConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FillConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.CanConvertFrom Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

FillConverter Class
FillConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
FillConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

FillConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.CanConvertTo Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

FillConverter Class
FillConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
FillConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

FillConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertFrom Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

FillConverter Class
FillConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
FillConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

FillConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertFromInvariantString Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertFromString Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertTo Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FillConverter Class
FillConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
FillConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

FillConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertToInvariantString Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.ConvertToString Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.CreateInstance Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetCreateInstanceSupported Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetProperties Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

FillConverter Class
FillConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetPropertiesSupported Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

FillConverter Class
FillConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetStandardValues Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetStandardValuesExclusive Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.GetStandardValuesSupported Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillConverter..::.IsValid Method
FillConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FillConverter Class
FillConverter Members


FillType Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FillType Enumeration
See Also Send Feedback
Specifies the Fill type to use.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FillType
Visual Basic (Declaration)
Public Enumeration FillType
Visual C++
public enum class FillType

Members

Member name | Description
Solid | Specifies a Solid Fill type.
Gradient | Specifies a Gradient Fill type.
Texture | Specifies a Texture Fill type.
Pattern | Specifies a Pattern Fill type.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Filmstrip Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Class
Members See Also Send Feedback
Defines an action that creates a Filmstrip representation of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Filmstrip : Action
Visual Basic (Declaration)
Public NotInheritable Class Filmstrip _
    Inherits Action
Visual C++
public ref class Filmstrip sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Filmstrip

See Also

Filmstrip Members


Filmstrip Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Members
Filmstrip Class Constructors Methods Properties See Also Send Feedback

The Filmstrip type exposes the following members.

Constructors

Name | Description
Filmstrip | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Filmstrip. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets the background of the filmstrip
Height | Gets or sets the height of the filmstrip
Orientation | Gets or sets the orientation of the filmstrip
PerforationColor | Gets or sets the perforations color of the filmstrip
PerforationWidth | Gets or sets the perforations width of the filmstrip
Roundness | Gets or sets the corner roundness of the filmstrip content
Width | Gets or sets the width of the filmstrip

See Also

Filmstrip Class


Filmstrip Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Constructor
Filmstrip Class See Also Send Feedback

Overload List

Name | Description
Filmstrip()()() | Initializes a new instance of the Filmstrip class.
Filmstrip(Int32, Int32, Fill, Int32, Color, Int32, FilmstripOrientation) | Initializes a new instance of the Filmstrip class with Filmstrip settings.

See Also

Filmstrip Class
Filmstrip Members


Filmstrip Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Constructor
Filmstrip Class See Also Send Feedback
Initializes a new instance of the Filmstrip class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Filmstrip()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Filmstrip()

See Also

Filmstrip Class
Filmstrip Overload


Filmstrip Constructor (Int32, Int32, Fill, Int32, Color, Int32, FilmstripOrientation)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Constructor (Int32, Int32, Fill, Int32, Color, Int32, FilmstripOrientation)
Filmstrip Class See Also Send Feedback
Initializes a new instance of the Filmstrip class with Filmstrip settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Filmstrip(
    int width,
    int height,
    Fill background,
    int perforationWidth,
    Color perforationColor,
    int roundness,
    FilmstripOrientation orientation
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    background As Fill, _
    perforationWidth As Integer, _
    perforationColor As Color, _
    roundness As Integer, _
    orientation As FilmstripOrientation _
)
Visual C++
public:
Filmstrip(
    int width,
    int height,
    Fill^ background,
    int perforationWidth,
    Color perforationColor,
    int roundness,
    FilmstripOrientation orientation
)

Parameters

width
Type: System..::.Int32
The width of the filmstrip
height
Type: System..::.Int32
The height of the filmstrip
background
Type: Neodynamic.SDK.ImageDraw..::.Fill
The background of the filmstrip
perforationWidth
Type: System..::.Int32
The perforations width of the filmstrip
perforationColor
Type: System.Drawing..::.Color
The perforations color of the filmstrip
roundness
Type: System..::.Int32
The corner roundness of the filmstrip content
orientation
Type: Neodynamic.SDK.ImageDraw..::.FilmstripOrientation
The orientation of the filmstrip

See Also

Filmstrip Class
Filmstrip Overload


Filmstrip Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Methods
Filmstrip Class See Also Send Feedback

The Filmstrip type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Filmstrip. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Filmstrip Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Clone Method
Filmstrip Class See Also Send Feedback
Creates a copy of the current Filmstrip.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Filmstrip.

See Also

Filmstrip Class


Filmstrip Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip Properties
Filmstrip Class See Also Send Feedback

The Filmstrip type exposes the following members.

Properties

Name | Description
Background | Gets the background of the filmstrip
Height | Gets or sets the height of the filmstrip
Orientation | Gets or sets the orientation of the filmstrip
PerforationColor | Gets or sets the perforations color of the filmstrip
PerforationWidth | Gets or sets the perforations width of the filmstrip
Roundness | Gets or sets the corner roundness of the filmstrip content
Width | Gets or sets the width of the filmstrip

See Also

Filmstrip Class


Background Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Background Property
Filmstrip Class See Also Send Feedback
Gets the background of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Fill
Visual C++
public:
property Fill^ Background {
    Fill^ get ();
}

See Also

Filmstrip Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Height Property
Filmstrip Class See Also Send Feedback
Gets or sets the height of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Filmstrip Class


Orientation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Orientation Property
Filmstrip Class See Also Send Feedback
Gets or sets the orientation of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FilmstripOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As FilmstripOrientation
Visual C++
public:
property FilmstripOrientation Orientation {
    FilmstripOrientation get ();
    void set (FilmstripOrientation value);
}

See Also

Filmstrip Class


PerforationColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.PerforationColor Property
Filmstrip Class See Also Send Feedback
Gets or sets the perforations color of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color PerforationColor { get; set; }
Visual Basic (Declaration)
Public Property PerforationColor As Color
Visual C++
public:
property Color PerforationColor {
    Color get ();
    void set (Color value);
}

See Also

Filmstrip Class


PerforationWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.PerforationWidth Property
Filmstrip Class See Also Send Feedback
Gets or sets the perforations width of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PerforationWidth { get; set; }
Visual Basic (Declaration)
Public Property PerforationWidth As Integer
Visual C++
public:
property int PerforationWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Filmstrip Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Roundness Property
Filmstrip Class See Also Send Feedback
Gets or sets the corner roundness of the filmstrip content

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Filmstrip Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Filmstrip..::.Width Property
Filmstrip Class See Also Send Feedback
Gets or sets the width of the filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Filmstrip Class


FilmstripOrientation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FilmstripOrientation Enumeration
See Also Send Feedback
Specifies the orientation of a Filmstrip

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FilmstripOrientation
Visual Basic (Declaration)
Public Enumeration FilmstripOrientation
Visual C++
public enum class FilmstripOrientation

Members

Member name | Description
Horizontal | Specifies the a horizontal orientation for a Filmstrip
Vertical | Specifies the a vertical orientation for a Filmstrip

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Flip Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Class
Members See Also Send Feedback
Defines an action that flips an image across its vertical or horizontal axis. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Flip : Action
Visual Basic (Declaration)
Public NotInheritable Class Flip _
    Inherits Action
Visual C++
public ref class Flip sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Flip

See Also

Flip Members


Flip Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Members
Flip Class Constructors Methods Properties See Also Send Feedback

The Flip type exposes the following members.

Constructors

Name | Description
Flip | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Flip. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Type | Gets or sets direction used to flip an image

See Also

Flip Class


Flip Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Constructor
Flip Class See Also Send Feedback

Overload List

Name | Description
Flip()()() | Initializes a new instance of the Flip class.
Flip(FlipType) | Initializes a new instance of the Flip class with the specified direction.

See Also

Flip Class
Flip Members


Flip Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Constructor
Flip Class See Also Send Feedback
Initializes a new instance of the Flip class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Flip()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Flip()

See Also

Flip Class
Flip Overload


Flip Constructor (FlipType)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Constructor (FlipType)
Flip Class See Also Send Feedback
Initializes a new instance of the Flip class with the specified direction.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Flip(
    FlipType type
)
Visual Basic (Declaration)
Public Sub New ( _
    type As FlipType _
)
Visual C++
public:
Flip(
    FlipType type
)

Parameters

type
Type: Neodynamic.SDK.ImageDraw..::.FlipType
The flip orientation.

See Also

Flip Class
Flip Overload


Flip Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Methods
Flip Class See Also Send Feedback

The Flip type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Flip. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Flip Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip..::.Clone Method
Flip Class See Also Send Feedback
Creates a copy of the current Flip.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Flip.

See Also

Flip Class


Flip Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip Properties
Flip Class See Also Send Feedback

The Flip type exposes the following members.

Properties

Name | Description
Type | Gets or sets direction used to flip an image

See Also

Flip Class


Type Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Flip..::.Type Property
Flip Class See Also Send Feedback
Gets or sets direction used to flip an image

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FlipType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As FlipType
Visual C++
public:
property FlipType Type {
    FlipType get ();
    void set (FlipType value);
}

See Also

Flip Class


FlipType Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FlipType Enumeration
See Also Send Feedback
Specifies the direction used to flip an image

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FlipType
Visual Basic (Declaration)
Public Enumeration FlipType
Visual C++
public enum class FlipType

Members

Member name | Description
Horizontal | Specifies a horizontal flip
Vertical | Specifies a vertical flip

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FocalGrayscale Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Class
Members See Also Send Feedback
It defines an action that creates grayscale element with a colored focal point represented by a shape. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class FocalGrayscale : Action
Visual Basic (Declaration)
Public NotInheritable Class FocalGrayscale _
    Inherits Action
Visual C++
public ref class FocalGrayscale sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.FocalGrayscale

See Also

FocalGrayscale Members


FocalGrayscale Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Members
FocalGrayscale Class Constructors Methods Properties See Also Send Feedback

The FocalGrayscale type exposes the following members.

Constructors

Name | Description
FocalGrayscale | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current FocalGrayscale. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the colored focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the colored focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the colored focal point.
ReverseEffect | Gets or sets whether focal grayscale effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the colored focal point.
Shape | Gets or sets the area/region's shape used for creating the colored focal point.
ShapeFill | Gets the shape's fill used for creating the colored focal point.
Sizing | Gets or sets the area/region's size type used for creating the colored focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the colored focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the colored focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalGrayscale Class


FocalGrayscale Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Constructor
FocalGrayscale Class See Also Send Feedback

Overload List

Name | Description
FocalGrayscale()()() | Initializes a new instance of the FocalGrayscale class.
FocalGrayscale(FocalShape) | Initializes a new instance of the FocalGrayscale class with the specified focal settings.

See Also

FocalGrayscale Class
FocalGrayscale Members


FocalGrayscale Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Constructor
FocalGrayscale Class See Also Send Feedback
Initializes a new instance of the FocalGrayscale class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalGrayscale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FocalGrayscale()

See Also

FocalGrayscale Class
FocalGrayscale Overload


FocalGrayscale Constructor (FocalShape)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Constructor (FocalShape)
FocalGrayscale Class See Also Send Feedback
Initializes a new instance of the FocalGrayscale class with the specified focal settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalGrayscale(
    FocalShape shape
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FocalShape _
)
Visual C++
public:
FocalGrayscale(
    FocalShape shape
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FocalShape
The area/region's shape used for creating the colored focal point.

See Also

FocalGrayscale Class
FocalGrayscale Overload


FocalGrayscale Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Methods
FocalGrayscale Class See Also Send Feedback

The FocalGrayscale type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current FocalGrayscale. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FocalGrayscale Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Clone Method
FocalGrayscale Class See Also Send Feedback
Creates a copy of the current FocalGrayscale.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current FocalGrayscale.

See Also

FocalGrayscale Class


FocalGrayscale Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale Properties
FocalGrayscale Class See Also Send Feedback

The FocalGrayscale type exposes the following members.

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the colored focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the colored focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the colored focal point.
ReverseEffect | Gets or sets whether focal grayscale effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the colored focal point.
Shape | Gets or sets the area/region's shape used for creating the colored focal point.
ShapeFill | Gets the shape's fill used for creating the colored focal point.
Sizing | Gets or sets the area/region's size type used for creating the colored focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the colored focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the colored focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalGrayscale Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Height Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the height of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalGrayscale Class


Location Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Location Property
FocalGrayscale Class See Also Send Feedback
Gets or sets how the area/region's shape used for creating the colored focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As FocalLocation
Visual C++
public:
property FocalLocation Location {
    FocalLocation get ();
    void set (FocalLocation value);
}

See Also

FocalGrayscale Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.PathPoints Property
FocalGrayscale Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for creating the colored focal point. Use it for performing Path or RoundedPath focal shapes.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

FocalGrayscale Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.PolygonSides Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalGrayscale Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.ReverseEffect Property
FocalGrayscale Class See Also Send Feedback
Gets or sets whether focal grayscale effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

FocalGrayscale Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Roundness Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the shape roundness used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

FocalGrayscale Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Shape Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the area/region's shape used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FocalShape
Visual C++
public:
property FocalShape Shape {
    FocalShape get ();
    void set (FocalShape value);
}

See Also

FocalGrayscale Class


ShapeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.ShapeFill Property
FocalGrayscale Class See Also Send Feedback
Gets the shape's fill used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ShapeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeFill As Fill
Visual C++
public:
property Fill^ ShapeFill {
    Fill^ get ();
}

See Also

FocalGrayscale Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Sizing Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the area/region's size type used for creating the colored focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FocalSizing
Visual C++
public:
property FocalSizing Sizing {
    FocalSizing get ();
    void set (FocalSizing value);
}

See Also

FocalGrayscale Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.StarInnerRadiusPercentage Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

FocalGrayscale Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.StarPoints Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the number of points of the star shape used for creating the colored focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalGrayscale Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Width Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the width of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalGrayscale Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.X Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

FocalGrayscale Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalGrayscale..::.Y Property
FocalGrayscale Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

FocalGrayscale Class


FocalLocation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalLocation Enumeration
See Also Send Feedback
Specifies how the area/region's shape used for creating the focal point will be positioned.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FocalLocation
Visual Basic (Declaration)
Public Enumeration FocalLocation
Visual C++
public enum class FocalLocation

Members

Member name | Description
Center | The area/region's shape used for creating the focal point is centered on target element.
Custom | The position of the area/region's shape used for creating the focal point must be specified by X and Y properties.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FocalPixelate Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Class
Members See Also Send Feedback
It defines an action that creates pixelated element with a non-pixelated focal point represented by a shape. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class FocalPixelate : Action
Visual Basic (Declaration)
Public NotInheritable Class FocalPixelate _
    Inherits Action
Visual C++
public ref class FocalPixelate sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.FocalPixelate

See Also

FocalPixelate Members


FocalPixelate Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Members
FocalPixelate Class Constructors Methods Properties See Also Send Feedback

The FocalPixelate type exposes the following members.

Constructors

Name | Description
FocalPixelate | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current FocalPixelate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the non-pixelated focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the non-pixelated focal point. Use it for performing Path or RoundedPath focal shapes.
PixelSize | Gets or sets the pixel size.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the non-pixelated focal point.
ReverseEffect | Gets or sets whether focal pixelate effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the non-pixelated focal point.
Shape | Gets or sets the area/region's shape used for creating the non-pixelated focal point.
ShapeFill | Gets the shape's fill used for creating the non-pixelated focal point.
Sizing | Gets or sets the area/region's size type used for creating the non-pixelated focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the non-pixelated focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the non-pixelated focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalPixelate Class


FocalPixelate Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Constructor
FocalPixelate Class See Also Send Feedback

Overload List

Name | Description
FocalPixelate()()() | Initializes a new instance of the FocalPixelate class.
FocalPixelate(FocalShape) | Initializes a new instance of the FocalPixelate class with the specified focal settings.

See Also

FocalPixelate Class
FocalPixelate Members


FocalPixelate Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Constructor
FocalPixelate Class See Also Send Feedback
Initializes a new instance of the FocalPixelate class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalPixelate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FocalPixelate()

See Also

FocalPixelate Class
FocalPixelate Overload


FocalPixelate Constructor (FocalShape)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Constructor (FocalShape)
FocalPixelate Class See Also Send Feedback
Initializes a new instance of the FocalPixelate class with the specified focal settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalPixelate(
    FocalShape shape
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FocalShape _
)
Visual C++
public:
FocalPixelate(
    FocalShape shape
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FocalShape
The area/region's shape used for creating the non-pixelated focal point.

See Also

FocalPixelate Class
FocalPixelate Overload


FocalPixelate Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Methods
FocalPixelate Class See Also Send Feedback

The FocalPixelate type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current FocalPixelate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FocalPixelate Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Clone Method
FocalPixelate Class See Also Send Feedback
Creates a copy of the current FocalPixelate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current FocalPixelate.

See Also

FocalPixelate Class


FocalPixelate Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate Properties
FocalPixelate Class See Also Send Feedback

The FocalPixelate type exposes the following members.

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the non-pixelated focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the non-pixelated focal point. Use it for performing Path or RoundedPath focal shapes.
PixelSize | Gets or sets the pixel size.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the non-pixelated focal point.
ReverseEffect | Gets or sets whether focal pixelate effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the non-pixelated focal point.
Shape | Gets or sets the area/region's shape used for creating the non-pixelated focal point.
ShapeFill | Gets the shape's fill used for creating the non-pixelated focal point.
Sizing | Gets or sets the area/region's size type used for creating the non-pixelated focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the non-pixelated focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the non-pixelated focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalPixelate Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Height Property
FocalPixelate Class See Also Send Feedback
Gets or sets the height of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalPixelate Class


Location Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Location Property
FocalPixelate Class See Also Send Feedback
Gets or sets how the area/region's shape used for creating the non-pixelated focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As FocalLocation
Visual C++
public:
property FocalLocation Location {
    FocalLocation get ();
    void set (FocalLocation value);
}

See Also

FocalPixelate Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.PathPoints Property
FocalPixelate Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for creating the non-pixelated focal point. Use it for performing Path or RoundedPath focal shapes.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

FocalPixelate Class


PixelSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.PixelSize Property
FocalPixelate Class See Also Send Feedback
Gets or sets the pixel size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PixelSize { get; set; }
Visual Basic (Declaration)
Public Property PixelSize As Integer
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is less than 1.

See Also

FocalPixelate Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.PolygonSides Property
FocalPixelate Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalPixelate Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.ReverseEffect Property
FocalPixelate Class See Also Send Feedback
Gets or sets whether focal pixelate effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

FocalPixelate Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Roundness Property
FocalPixelate Class See Also Send Feedback
Gets or sets the shape roundness used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

FocalPixelate Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Shape Property
FocalPixelate Class See Also Send Feedback
Gets or sets the area/region's shape used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FocalShape
Visual C++
public:
property FocalShape Shape {
    FocalShape get ();
    void set (FocalShape value);
}

See Also

FocalPixelate Class


ShapeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.ShapeFill Property
FocalPixelate Class See Also Send Feedback
Gets the shape's fill used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ShapeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeFill As Fill
Visual C++
public:
property Fill^ ShapeFill {
    Fill^ get ();
}

See Also

FocalPixelate Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Sizing Property
FocalPixelate Class See Also Send Feedback
Gets or sets the area/region's size type used for creating the non-pixelated focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FocalSizing
Visual C++
public:
property FocalSizing Sizing {
    FocalSizing get ();
    void set (FocalSizing value);
}

See Also

FocalPixelate Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.StarInnerRadiusPercentage Property
FocalPixelate Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

FocalPixelate Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.StarPoints Property
FocalPixelate Class See Also Send Feedback
Gets or sets the number of points of the star shape used for creating the non-pixelated focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalPixelate Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Width Property
FocalPixelate Class See Also Send Feedback
Gets or sets the width of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalPixelate Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.X Property
FocalPixelate Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

FocalPixelate Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalPixelate..::.Y Property
FocalPixelate Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

FocalPixelate Class


FocalShape Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalShape Enumeration
See Also Send Feedback
Specifies the area/region's shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FocalShape
Visual Basic (Declaration)
Public Enumeration FocalShape
Visual C++
public enum class FocalShape

Members

Member name | Description
Rectangle |
Oval |
Polygon |
Star |
Path |
RoundedRectangle |
RoundedPolygon |
RoundedStar |
RoundedPath |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FocalSizing Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSizing Enumeration
See Also Send Feedback
Specifies the area/region's size type used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FocalSizing
Visual Basic (Declaration)
Public Enumeration FocalSizing
Visual C++
public enum class FocalSizing

Members

Member name | Description
Custom | The area/region's size must be specified by Width and Height properties.
Fit | The area/region's size will automatically fit to the target Element's size

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


FocalSoften Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Class
Members See Also Send Feedback
It defines an action that creates soften element with a focal point represented by a shape. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class FocalSoften : Action
Visual Basic (Declaration)
Public NotInheritable Class FocalSoften _
    Inherits Action
Visual C++
public ref class FocalSoften sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.FocalSoften

See Also

FocalSoften Members


FocalSoften Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Members
FocalSoften Class Constructors Methods Properties See Also Send Feedback

The FocalSoften type exposes the following members.

Constructors

Name | Description
FocalSoften | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current FocalSoften. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the focal point.
ReverseEffect | Gets or sets whether focal soften effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the focal point.
Shape | Gets or sets the area/region's shape used for creating the focal point.
ShapeFill | Gets the shape's fill used for creating the focal point.
Sizing | Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
Softness | Gets or sets the softness.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalSoften Class


FocalSoften Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Constructor
FocalSoften Class See Also Send Feedback

Overload List

Name | Description
FocalSoften()()() | Initializes a new instance of the FocalSoften class.
FocalSoften(FocalShape) | Initializes a new instance of the FocalSoften class with the specified focal settings.

See Also

FocalSoften Class
FocalSoften Members


FocalSoften Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Constructor
FocalSoften Class See Also Send Feedback
Initializes a new instance of the FocalSoften class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSoften()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FocalSoften()

See Also

FocalSoften Class
FocalSoften Overload


FocalSoften Constructor (FocalShape)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Constructor (FocalShape)
FocalSoften Class See Also Send Feedback
Initializes a new instance of the FocalSoften class with the specified focal settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSoften(
    FocalShape shape
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FocalShape _
)
Visual C++
public:
FocalSoften(
    FocalShape shape
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FocalShape
The area/region's shape used for creating the focal point.

See Also

FocalSoften Class
FocalSoften Overload


FocalSoften Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Methods
FocalSoften Class See Also Send Feedback

The FocalSoften type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current FocalSoften. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FocalSoften Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Clone Method
FocalSoften Class See Also Send Feedback
Creates a copy of the current FocalSoften.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current FocalSoften.

See Also

FocalSoften Class


FocalSoften Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften Properties
FocalSoften Class See Also Send Feedback

The FocalSoften type exposes the following members.

Properties

Name | Description
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the focal point.
ReverseEffect | Gets or sets whether focal soften effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the focal point.
Shape | Gets or sets the area/region's shape used for creating the focal point.
ShapeFill | Gets the shape's fill used for creating the focal point.
Sizing | Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
Softness | Gets or sets the softness.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalSoften Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Height Property
FocalSoften Class See Also Send Feedback
Gets or sets the height of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalSoften Class


Location Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Location Property
FocalSoften Class See Also Send Feedback
Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As FocalLocation
Visual C++
public:
property FocalLocation Location {
    FocalLocation get ();
    void set (FocalLocation value);
}

See Also

FocalSoften Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.PathPoints Property
FocalSoften Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

FocalSoften Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.PolygonSides Property
FocalSoften Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalSoften Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.ReverseEffect Property
FocalSoften Class See Also Send Feedback
Gets or sets whether focal soften effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

FocalSoften Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Roundness Property
FocalSoften Class See Also Send Feedback
Gets or sets the shape roundness used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

FocalSoften Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Shape Property
FocalSoften Class See Also Send Feedback
Gets or sets the area/region's shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FocalShape
Visual C++
public:
property FocalShape Shape {
    FocalShape get ();
    void set (FocalShape value);
}

See Also

FocalSoften Class


ShapeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.ShapeFill Property
FocalSoften Class See Also Send Feedback
Gets the shape's fill used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ShapeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeFill As Fill
Visual C++
public:
property Fill^ ShapeFill {
    Fill^ get ();
}

See Also

FocalSoften Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Sizing Property
FocalSoften Class See Also Send Feedback
Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FocalSizing
Visual C++
public:
property FocalSizing Sizing {
    FocalSizing get ();
    void set (FocalSizing value);
}

See Also

FocalSoften Class


Softness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Softness Property
FocalSoften Class See Also Send Feedback
Gets or sets the softness.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Softness { get; set; }
Visual Basic (Declaration)
Public Property Softness As Integer
Visual C++
public:
property int Softness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 50.

See Also

FocalSoften Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.StarInnerRadiusPercentage Property
FocalSoften Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

FocalSoften Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.StarPoints Property
FocalSoften Class See Also Send Feedback
Gets or sets the number of points of the star shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalSoften Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Width Property
FocalSoften Class See Also Send Feedback
Gets or sets the width of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalSoften Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.X Property
FocalSoften Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

FocalSoften Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalSoften..::.Y Property
FocalSoften Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

FocalSoften Class


FocalTint Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Class
Members See Also Send Feedback
It defines an action that creates tinted look of an element with a focal point represented by a shape. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class FocalTint : Action
Visual Basic (Declaration)
Public NotInheritable Class FocalTint _
    Inherits Action
Visual C++
public ref class FocalTint sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.FocalTint

See Also

FocalTint Members


FocalTint Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Members
FocalTint Class Constructors Methods Properties See Also Send Feedback

The FocalTint type exposes the following members.

Constructors

Name | Description
FocalTint | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current FocalTint. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the color used for tinting.
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the focal point.
ReverseEffect | Gets or sets whether focal tint effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the focal point.
Shape | Gets or sets the area/region's shape used for creating the focal point.
ShapeFill | Gets the shape's fill used for creating the focal point.
Sizing | Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalTint Class


FocalTint Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Constructor
FocalTint Class See Also Send Feedback

Overload List

Name | Description
FocalTint()()() | Initializes a new instance of the FocalTint class.
FocalTint(FocalShape) | Initializes a new instance of the FocalTint class with the specified focal settings.

See Also

FocalTint Class
FocalTint Members


FocalTint Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Constructor
FocalTint Class See Also Send Feedback
Initializes a new instance of the FocalTint class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalTint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FocalTint()

See Also

FocalTint Class
FocalTint Overload


FocalTint Constructor (FocalShape)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Constructor (FocalShape)
FocalTint Class See Also Send Feedback
Initializes a new instance of the FocalTint class with the specified focal settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalTint(
    FocalShape shape
)
Visual Basic (Declaration)
Public Sub New ( _
    shape As FocalShape _
)
Visual C++
public:
FocalTint(
    FocalShape shape
)

Parameters

shape
Type: Neodynamic.SDK.ImageDraw..::.FocalShape
The area/region's shape used for creating the focal point.

See Also

FocalTint Class
FocalTint Overload


FocalTint Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Methods
FocalTint Class See Also Send Feedback

The FocalTint type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current FocalTint. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FocalTint Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Clone Method
FocalTint Class See Also Send Feedback
Creates a copy of the current FocalTint.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current FocalTint.

See Also

FocalTint Class


FocalTint Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint Properties
FocalTint Class See Also Send Feedback

The FocalTint type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color used for tinting.
Height | Gets or sets the height of the focal shape area/region.
Location | Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.
PathPoints | Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.
PolygonSides | Gets or sets the number of sides of the polygon shape used for creating the focal point.
ReverseEffect | Gets or sets whether focal tint effect should be reversed.
Roundness | Gets or sets the shape roundness used for creating the focal point.
Shape | Gets or sets the area/region's shape used for creating the focal point.
ShapeFill | Gets the shape's fill used for creating the focal point.
Sizing | Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.
StarInnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape used for creating the focal point.
StarPoints | Gets or sets the number of points of the star shape used for creating the focal point.
Width | Gets or sets the width of the focal shape area/region.
X | Gets or sets the x-coordinate of the left side of the focal shape area/region.
Y | Gets or sets the y-coordinate of the top side of the focal shape area/region.

See Also

FocalTint Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Color Property
FocalTint Class See Also Send Feedback
Gets or sets the color used for tinting.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

FocalTint Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Height Property
FocalTint Class See Also Send Feedback
Gets or sets the height of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalTint Class


Location Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Location Property
FocalTint Class See Also Send Feedback
Gets or sets how the area/region's shape used for creating the focal point will be positioned. If it is Center, then the area/region will be centered on the target Element; otherwise, the area/region's location must be specified by X and Y properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalLocation Location { get; set; }
Visual Basic (Declaration)
Public Property Location As FocalLocation
Visual C++
public:
property FocalLocation Location {
    FocalLocation get ();
    void set (FocalLocation value);
}

See Also

FocalTint Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.PathPoints Property
FocalTint Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path for creating the focal point. Use it for performing Path or RoundedPath focal shapes.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

FocalTint Class


PolygonSides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.PolygonSides Property
FocalTint Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PolygonSides { get; set; }
Visual Basic (Declaration)
Public Property PolygonSides As Integer
Visual C++
public:
property int PolygonSides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalTint Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.ReverseEffect Property
FocalTint Class See Also Send Feedback
Gets or sets whether focal tint effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

FocalTint Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Roundness Property
FocalTint Class See Also Send Feedback
Gets or sets the shape roundness used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

FocalTint Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Shape Property
FocalTint Class See Also Send Feedback
Gets or sets the area/region's shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As FocalShape
Visual C++
public:
property FocalShape Shape {
    FocalShape get ();
    void set (FocalShape value);
}

See Also

FocalTint Class


ShapeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.ShapeFill Property
FocalTint Class See Also Send Feedback
Gets the shape's fill used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ShapeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ShapeFill As Fill
Visual C++
public:
property Fill^ ShapeFill {
    Fill^ get ();
}

See Also

FocalTint Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Sizing Property
FocalTint Class See Also Send Feedback
Gets or sets the area/region's size type used for creating the focal point. If it is Fit, then the area/region's size will automatically fit to the target Element's size; otherwise, the area/region's size must be specified by Width and Height properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FocalSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As FocalSizing
Visual C++
public:
property FocalSizing Sizing {
    FocalSizing get ();
    void set (FocalSizing value);
}

See Also

FocalTint Class


StarInnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.StarInnerRadiusPercentage Property
FocalTint Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarInnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property StarInnerRadiusPercentage As Integer
Visual C++
public:
property int StarInnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

FocalTint Class


StarPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.StarPoints Property
FocalTint Class See Also Send Feedback
Gets or sets the number of points of the star shape used for creating the focal point.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StarPoints { get; set; }
Visual Basic (Declaration)
Public Property StarPoints As Integer
Visual C++
public:
property int StarPoints {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

FocalTint Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Width Property
FocalTint Class See Also Send Feedback
Gets or sets the width of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

FocalTint Class


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.X Property
FocalTint Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

FocalTint Class


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FocalTint..::.Y Property
FocalTint Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the focal shape area/region.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

FocalTint Class


Font Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Class
Members See Also Send Feedback
Encapsulates the font properties of text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Font
Visual Basic (Declaration)
Public Class Font
Visual C++
public ref class Font

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Font

See Also

Font Members


Font Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Members
Font Class Constructors Methods Properties See Also Send Feedback

The Font type exposes the following members.

Constructors

Name | Description
Font | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
Bold | Gets or sets a value that indicates whether this Font object is bold.
CustomFontFile | Gets or sets the custom font file to use for this Font object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
CustomFontFileFamilyIndex | Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.
Italic | Gets or sets a value that indicates whether this Font object is italic.
Name | Gets or sets the face name of this Font object.
Size | Gets or sets the size of this Font object.
Strikeout | Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font.
Underline | Gets or sets a value that indicates whether this Font object is underlined.
Unit | Gets or sets the unit of measure for this Font object.

See Also

Font Class


Font Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor
Font Class See Also Send Feedback

Overload List

Name | Description
Font()()() | Initializes a new instance of the Font class.
Font(String, Single) | Initializes a new instance of the Font class with the specified font name and size.
Font(String, Int32, Single) | Initializes a new instance of the Font class with the specified custom font file and size.
Font(String, Single, FontUnit) | Initializes a new instance of the Font class with the specified font name, size and unit of measure.
Font(String, Int32, Single, FontUnit) | Initializes a new instance of the Font class with the specified custom font file, size and unit of measure.

See Also

Font Class
Font Members


Font Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor
Font Class See Also Send Feedback
Initializes a new instance of the Font class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Font()

See Also

Font Class
Font Overload


Font Constructor (String, Single)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor (String, Single)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified font name and size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font(
    string name,
    float size
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    size As Single _
)
Visual C++
public:
Font(
    String^ name,
    float size
)

Parameters

name
Type: System..::.String
The name of the font.
size
Type: System..::.Single
The size of the font measured in Points.

See Also

Font Class
Font Overload


Font Constructor (String, Int32, Single)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor (String, Int32, Single)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified custom font file and size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font(
    string customFontFile,
    int customFontFileFamilyIndex,
    float size
)
Visual Basic (Declaration)
Public Sub New ( _
    customFontFile As String, _
    customFontFileFamilyIndex As Integer, _
    size As Single _
)
Visual C++
public:
Font(
    String^ customFontFile,
    int customFontFileFamilyIndex,
    float size
)

Parameters

customFontFile
Type: System..::.String
The custom font file to use. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
customFontFileFamilyIndex
Type: System..::.Int32
The Font Family index of the type faces defined by the specified Custom Font File.
size
Type: System..::.Single
The size of the font measured in Points.

See Also

Font Class
Font Overload


Font Constructor (String, Single, FontUnit)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor (String, Single, FontUnit)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified font name, size and unit of measure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font(
    string name,
    float size,
    FontUnit unit
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    size As Single, _
    unit As FontUnit _
)
Visual C++
public:
Font(
    String^ name,
    float size,
    FontUnit unit
)

Parameters

name
Type: System..::.String
The name of the font.
size
Type: System..::.Single
The size of the font.
unit
Type: Neodynamic.SDK.ImageDraw..::.FontUnit
The unit of measure for the font.

See Also

Font Class
Font Overload


Font Constructor (String, Int32, Single, FontUnit)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Constructor (String, Int32, Single, FontUnit)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified custom font file, size and unit of measure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font(
    string customFontFile,
    int customFontFileFamilyIndex,
    float size,
    FontUnit unit
)
Visual Basic (Declaration)
Public Sub New ( _
    customFontFile As String, _
    customFontFileFamilyIndex As Integer, _
    size As Single, _
    unit As FontUnit _
)
Visual C++
public:
Font(
    String^ customFontFile,
    int customFontFileFamilyIndex,
    float size,
    FontUnit unit
)

Parameters

customFontFile
Type: System..::.String
The custom font file to use. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
customFontFileFamilyIndex
Type: System..::.Int32
The Font Family index of the type faces defined by the specified Custom Font File.
size
Type: System..::.Single
The size of the font measured in Points.
unit
Type: Neodynamic.SDK.ImageDraw..::.FontUnit
The unit of measure for the font.

See Also

Font Class
Font Overload


Font Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Methods
Font Class See Also Send Feedback

The Font type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

See Also

Font Class


ToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.ToString Method
Font Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the Font object to a string representation, using the current CultureInfo. (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Converts the Font object to a string representation, using the specified CultureInfo.

See Also

Font Class
Font Members


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.ToString Method
Font Class See Also Send Feedback
Converts the Font object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the Font object in the current culture.

See Also

Font Class
ToString Overload


ToString Method (CultureInfo)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.ToString Method (CultureInfo)
Font Class See Also Send Feedback
Converts the Font object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that contains the culture to represent the Font.

Return Value

The string representation of the Font object in the specified culture.

See Also

Font Class
ToString Overload


Font Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font Properties
Font Class See Also Send Feedback

The Font type exposes the following members.

Properties

Name | Description
Bold | Gets or sets a value that indicates whether this Font object is bold.
CustomFontFile | Gets or sets the custom font file to use for this Font object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
CustomFontFileFamilyIndex | Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.
Italic | Gets or sets a value that indicates whether this Font object is italic.
Name | Gets or sets the face name of this Font object.
Size | Gets or sets the size of this Font object.
Strikeout | Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font.
Underline | Gets or sets a value that indicates whether this Font object is underlined.
Unit | Gets or sets the unit of measure for this Font object.

See Also

Font Class


Bold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Bold Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is bold.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Bold { get; set; }
Visual Basic (Declaration)
Public Property Bold As Boolean
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}

See Also

Font Class


CustomFontFile Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.CustomFontFile Property
Font Class See Also Send Feedback
Gets or sets the custom font file to use for this Font object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string CustomFontFile { get; set; }
Visual Basic (Declaration)
Public Property CustomFontFile As String
Visual C++
public:
property String^ CustomFontFile {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class


CustomFontFileFamilyIndex Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.CustomFontFileFamilyIndex Property
Font Class See Also Send Feedback
Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CustomFontFileFamilyIndex { get; set; }
Visual Basic (Declaration)
Public Property CustomFontFileFamilyIndex As Integer
Visual C++
public:
property int CustomFontFileFamilyIndex {
    int get ();
    void set (int value);
}

See Also

Font Class


Italic Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Italic Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is italic.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Italic { get; set; }
Visual Basic (Declaration)
Public Property Italic As Boolean
Visual C++
public:
property bool Italic {
    bool get ();
    void set (bool value);
}

See Also

Font Class


Name Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Name Property
Font Class See Also Send Feedback
Gets or sets the face name of this Font object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Font Class


Size Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Size Property
Font Class See Also Send Feedback
Gets or sets the size of this Font object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Single
Visual C++
public:
property float Size {
    float get ();
    void set (float value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than zero.

See Also

Font Class


Strikeout Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Strikeout Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Strikeout { get; set; }
Visual Basic (Declaration)
Public Property Strikeout As Boolean
Visual C++
public:
property bool Strikeout {
    bool get ();
    void set (bool value);
}

See Also

Font Class


Underline Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Underline Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is underlined.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Underline { get; set; }
Visual Basic (Declaration)
Public Property Underline As Boolean
Visual C++
public:
property bool Underline {
    bool get ();
    void set (bool value);
}

See Also

Font Class


Unit Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Font..::.Unit Property
Font Class See Also Send Feedback
Gets or sets the unit of measure for this Font object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FontUnit Unit { get; set; }
Visual Basic (Declaration)
Public Property Unit As FontUnit
Visual C++
public:
property FontUnit Unit {
    FontUnit get ();
    void set (FontUnit value);
}

See Also

Font Class


FontConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter Class
Members See Also Send Feedback
Converts Font objects from one data type to another. Access the FontConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class FontConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class FontConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class FontConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
Neodynamic.SDK.ImageDraw..::.FontConverter

See Also

FontConverter Members


FontConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter Members
FontConverter Class Constructors Methods See Also Send Feedback

The FontConverter type exposes the following members.

Constructors

Name | Description
FontConverter | Initializes a new instance of the FontConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontConverter Class


FontConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter Constructor
FontConverter Class See Also Send Feedback
Initializes a new instance of the FontConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public FontConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FontConverter()

See Also

FontConverter Class


FontConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter Methods
FontConverter Class See Also Send Feedback

The FontConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FontConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.CanConvertFrom Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

FontConverter Class
FontConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

FontConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.CanConvertTo Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

FontConverter Class
FontConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

FontConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertFrom Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

FontConverter Class
FontConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

FontConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertFromInvariantString Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertFromString Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertTo Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FontConverter Class
FontConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

FontConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertToInvariantString Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.ConvertToString Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.CreateInstance Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetCreateInstanceSupported Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetProperties Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

FontConverter Class
FontConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetPropertiesSupported Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

FontConverter Class
FontConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetStandardValues Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetStandardValuesExclusive Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.GetStandardValuesSupported Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontConverter..::.IsValid Method
FontConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

FontConverter Class
FontConverter Members


FontUnit Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
FontUnit Enumeration
See Also Send Feedback
Specifies the unit of measure for Font objects.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum FontUnit
Visual Basic (Declaration)
Public Enumeration FontUnit
Visual C++
public enum class FontUnit

Members

Member name | Description
Inch | Specifies the inch as the unit of measure.
Millimeter | Specifies the millimeter as the unit of measure.
Pixel | Specifies the pixel as the unit of measure.
Point | Specifies the point (1/72 inch) as the unit of measure.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


GaussianBlur Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Class
Members See Also Send Feedback
Defines an action that softens the look of an element. Gaussian Blur applies a weighted average of blur to each pixel producing a hazy effect. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class GaussianBlur : Action
Visual Basic (Declaration)
Public Class GaussianBlur _
    Inherits Action
Visual C++
public ref class GaussianBlur : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.GaussianBlur

See Also

GaussianBlur Members


GaussianBlur Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Members
GaussianBlur Class Constructors Methods Properties See Also Send Feedback

The GaussianBlur type exposes the following members.

Constructors

Name | Description
GaussianBlur | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current GaussianBlur. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Radius | Gets or sets the strength of the blur effect.

See Also

GaussianBlur Class


GaussianBlur Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Constructor
GaussianBlur Class See Also Send Feedback

Overload List

Name | Description
GaussianBlur()()() | Initializes a new instance of the GaussianBlur class.
GaussianBlur(Int32) | Initializes a new instance of the GaussianBlur class with the specified radius.

See Also

GaussianBlur Class
GaussianBlur Members


GaussianBlur Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Constructor
GaussianBlur Class See Also Send Feedback
Initializes a new instance of the GaussianBlur class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GaussianBlur()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GaussianBlur()

See Also

GaussianBlur Class
GaussianBlur Overload


GaussianBlur Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Constructor (Int32)
GaussianBlur Class See Also Send Feedback
Initializes a new instance of the GaussianBlur class with the specified radius.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GaussianBlur(
    int radius
)
Visual Basic (Declaration)
Public Sub New ( _
    radius As Integer _
)
Visual C++
public:
GaussianBlur(
    int radius
)

Parameters

radius
Type: System..::.Int32
The strength of the blur effect.

See Also

GaussianBlur Class
GaussianBlur Overload


GaussianBlur Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Methods
GaussianBlur Class See Also Send Feedback

The GaussianBlur type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current GaussianBlur. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GaussianBlur Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur..::.Clone Method
GaussianBlur Class See Also Send Feedback
Creates a copy of the current GaussianBlur.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current GaussianBlur.

See Also

GaussianBlur Class


GaussianBlur Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur Properties
GaussianBlur Class See Also Send Feedback

The GaussianBlur type exposes the following members.

Properties

Name | Description
Radius | Gets or sets the strength of the blur effect.

See Also

GaussianBlur Class


Radius Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GaussianBlur..::.Radius Property
GaussianBlur Class See Also Send Feedback
Gets or sets the strength of the blur effect.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Integer
Visual C++
public:
property int Radius {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 50.

See Also

GaussianBlur Class


GlassTable Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Class
Members See Also Send Feedback
It defines an action that creates a glass table effect on an image. The glass table effect adds a reflection of an image just below it. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class GlassTable : Action
Visual Basic (Declaration)
Public NotInheritable Class GlassTable _
    Inherits Action
Visual C++
public ref class GlassTable sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.GlassTable

See Also

GlassTable Members


GlassTable Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Members
GlassTable Class Constructors Methods Properties See Also Send Feedback

The GlassTable type exposes the following members.

Constructors

Name | Description
GlassTable | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current GlassTable. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ReflectionLocation | Gets or sets how the reflection of the image will be positioned. If it is Auto, then the reflection will be positioned just below of the image based on its dimensions; otherwise, the reflection position must be specified by ReflectionLocationX and ReflectionLocationY properties.
ReflectionLocationX | Gets or sets the x-coordinate of the left side of the reflection image.
ReflectionLocationY | Gets or sets the y-coordinate of the top side of the reflection image.
ReflectionOpacity | Gets or sets the percentage of transparency in the reflection
ReflectionPercentage | Gets or sets the percentage of the image height that will be reflected.

See Also

GlassTable Class


GlassTable Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Constructor
GlassTable Class See Also Send Feedback

Overload List

Name | Description
GlassTable()()() | Initializes a new instance of the GlassTable class.
GlassTable(Int32, Int32) | Initializes a new instance of the GlassTable class with the specified reflection settings.
GlassTable(Int32, Int32, Int32, Int32) | Initializes a new instance of the GlassTable class with the specified reflection settings.

See Also

GlassTable Class
GlassTable Members


GlassTable Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Constructor
GlassTable Class See Also Send Feedback
Initializes a new instance of the GlassTable class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GlassTable()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GlassTable()

See Also

GlassTable Class
GlassTable Overload


GlassTable Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Constructor (Int32, Int32)
GlassTable Class See Also Send Feedback
Initializes a new instance of the GlassTable class with the specified reflection settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GlassTable(
    int reflectionOpacity,
    int reflectionPercentage
)
Visual Basic (Declaration)
Public Sub New ( _
    reflectionOpacity As Integer, _
    reflectionPercentage As Integer _
)
Visual C++
public:
GlassTable(
    int reflectionOpacity,
    int reflectionPercentage
)

Parameters

reflectionOpacity
Type: System..::.Int32
The percentage of transparency in the reflection.
reflectionPercentage
Type: System..::.Int32
The percentage of the image height that will be reflected.

See Also

GlassTable Class
GlassTable Overload


GlassTable Constructor (Int32, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Constructor (Int32, Int32, Int32, Int32)
GlassTable Class See Also Send Feedback
Initializes a new instance of the GlassTable class with the specified reflection settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GlassTable(
    int reflectionLocationX,
    int reflectionLocationY,
    int reflectionOpacity,
    int reflectionPercentage
)
Visual Basic (Declaration)
Public Sub New ( _
    reflectionLocationX As Integer, _
    reflectionLocationY As Integer, _
    reflectionOpacity As Integer, _
    reflectionPercentage As Integer _
)
Visual C++
public:
GlassTable(
    int reflectionLocationX,
    int reflectionLocationY,
    int reflectionOpacity,
    int reflectionPercentage
)

Parameters

reflectionLocationX
Type: System..::.Int32
The x-coordinate of the left side of the reflection image.
reflectionLocationY
Type: System..::.Int32
The y-coordinate of the top side of the reflection image.
reflectionOpacity
Type: System..::.Int32
The percentage of transparency in the reflection.
reflectionPercentage
Type: System..::.Int32
The percentage of the image height that will be reflected.

See Also

GlassTable Class
GlassTable Overload


GlassTable Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Methods
GlassTable Class See Also Send Feedback

The GlassTable type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current GlassTable. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GlassTable Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.Clone Method
GlassTable Class See Also Send Feedback
Creates a copy of the current GlassTable.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current GlassTable.

See Also

GlassTable Class


GlassTable Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable Properties
GlassTable Class See Also Send Feedback

The GlassTable type exposes the following members.

Properties

Name | Description
ReflectionLocation | Gets or sets how the reflection of the image will be positioned. If it is Auto, then the reflection will be positioned just below of the image based on its dimensions; otherwise, the reflection position must be specified by ReflectionLocationX and ReflectionLocationY properties.
ReflectionLocationX | Gets or sets the x-coordinate of the left side of the reflection image.
ReflectionLocationY | Gets or sets the y-coordinate of the top side of the reflection image.
ReflectionOpacity | Gets or sets the percentage of transparency in the reflection
ReflectionPercentage | Gets or sets the percentage of the image height that will be reflected.

See Also

GlassTable Class


ReflectionLocation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.ReflectionLocation Property
GlassTable Class See Also Send Feedback
Gets or sets how the reflection of the image will be positioned. If it is Auto, then the reflection will be positioned just below of the image based on its dimensions; otherwise, the reflection position must be specified by ReflectionLocationX and ReflectionLocationY properties.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ReflectionLocation ReflectionLocation { get; set; }
Visual Basic (Declaration)
Public Property ReflectionLocation As ReflectionLocation
Visual C++
public:
property ReflectionLocation ReflectionLocation {
    ReflectionLocation get ();
    void set (ReflectionLocation value);
}

See Also

GlassTable Class


ReflectionLocationX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.ReflectionLocationX Property
GlassTable Class See Also Send Feedback
Gets or sets the x-coordinate of the left side of the reflection image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ReflectionLocationX { get; set; }
Visual Basic (Declaration)
Public Property ReflectionLocationX As Integer
Visual C++
public:
property int ReflectionLocationX {
    int get ();
    void set (int value);
}

See Also

GlassTable Class


ReflectionLocationY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.ReflectionLocationY Property
GlassTable Class See Also Send Feedback
Gets or sets the y-coordinate of the top side of the reflection image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ReflectionLocationY { get; set; }
Visual Basic (Declaration)
Public Property ReflectionLocationY As Integer
Visual C++
public:
property int ReflectionLocationY {
    int get ();
    void set (int value);
}

See Also

GlassTable Class


ReflectionOpacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.ReflectionOpacity Property
GlassTable Class See Also Send Feedback
Gets or sets the percentage of transparency in the reflection

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ReflectionOpacity { get; set; }
Visual Basic (Declaration)
Public Property ReflectionOpacity As Integer
Visual C++
public:
property int ReflectionOpacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

GlassTable Class


ReflectionPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GlassTable..::.ReflectionPercentage Property
GlassTable Class See Also Send Feedback
Gets or sets the percentage of the image height that will be reflected.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ReflectionPercentage { get; set; }
Visual Basic (Declaration)
Public Property ReflectionPercentage As Integer
Visual C++
public:
property int ReflectionPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

GlassTable Class


Glow Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Class
Members See Also Send Feedback
Defines an action that adds glow effect to an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Glow : Action
Visual Basic (Declaration)
Public NotInheritable Class Glow _
    Inherits Action
Visual C++
public ref class Glow sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Glow

See Also

Glow Members


Glow Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Members
Glow Class Constructors Methods Properties See Also Send Feedback

The Glow type exposes the following members.

Constructors

Name | Description
Glow | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Glow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the color of the glow
Opacity | Gets or sets the percentage of transparency in the glow
Softness | Gets or sets the sharpness of the glow

See Also

Glow Class


Glow Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Constructor
Glow Class See Also Send Feedback

Overload List

Name | Description
Glow()()() | Initializes a new instance of the Glow class.
Glow(Color, Int32, Int32) | Initializes a new instance of the Glow class with the specified settings.

See Also

Glow Class
Glow Members


Glow Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Constructor
Glow Class See Also Send Feedback
Initializes a new instance of the Glow class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Glow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Glow()

See Also

Glow Class
Glow Overload


Glow Constructor (Color, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Constructor (Color, Int32, Int32)
Glow Class See Also Send Feedback
Initializes a new instance of the Glow class with the specified settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Glow(
    Color color,
    int opacity,
    int softness
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    opacity As Integer, _
    softness As Integer _
)
Visual C++
public:
Glow(
    Color color,
    int opacity,
    int softness
)

Parameters

color
Type: System.Drawing..::.Color
The color of the glow
opacity
Type: System..::.Int32
The percentage of transparency in the glow
softness
Type: System..::.Int32
The sharpness of the glow

See Also

Glow Class
Glow Overload


Glow Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Methods
Glow Class See Also Send Feedback

The Glow type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Glow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Glow Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow..::.Clone Method
Glow Class See Also Send Feedback
Creates a copy of the current Glow.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Glow.

See Also

Glow Class


Glow Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow Properties
Glow Class See Also Send Feedback

The Glow type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color of the glow
Opacity | Gets or sets the percentage of transparency in the glow
Softness | Gets or sets the sharpness of the glow

See Also

Glow Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow..::.Color Property
Glow Class See Also Send Feedback
Gets or sets the color of the glow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

Glow Class


Opacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow..::.Opacity Property
Glow Class See Also Send Feedback
Gets or sets the percentage of transparency in the glow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Integer
Visual C++
public:
property int Opacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Glow Class


Softness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Glow..::.Softness Property
Glow Class See Also Send Feedback
Gets or sets the sharpness of the glow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Softness { get; set; }
Visual Basic (Declaration)
Public Property Softness As Integer
Visual C++
public:
property int Softness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Glow Class


GradientColorsConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter Class
Members See Also Send Feedback
Converts Color objects from one data type to another. Access the GradientColorsConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class GradientColorsConverter : TypeConverter
Visual Basic (Declaration)
Public Class GradientColorsConverter _
    Inherits TypeConverter
Visual C++
public ref class GradientColorsConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Neodynamic.SDK.ImageDraw..::.GradientColorsConverter

See Also

GradientColorsConverter Members


GradientColorsConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter Members
GradientColorsConverter Class Constructors Methods See Also Send Feedback

The GradientColorsConverter type exposes the following members.

Constructors

Name | Description
GradientColorsConverter | Initializes a new instance of the GradientColorsConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientColorsConverter Class


GradientColorsConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter Constructor
GradientColorsConverter Class See Also Send Feedback
Initializes a new instance of the GradientColorsConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GradientColorsConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GradientColorsConverter()

See Also

GradientColorsConverter Class


GradientColorsConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter Methods
GradientColorsConverter Class See Also Send Feedback

The GradientColorsConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GradientColorsConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.CanConvertFrom Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
GradientColorsConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

GradientColorsConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.CanConvertTo Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
GradientColorsConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

GradientColorsConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertFrom Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
GradientColorsConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

GradientColorsConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertFromInvariantString Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertFromString Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertTo Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
GradientColorsConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

GradientColorsConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertToInvariantString Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.ConvertToString Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.CreateInstance Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetCreateInstanceSupported Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetProperties Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetPropertiesSupported Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetStandardValues Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetStandardValuesExclusive Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.GetStandardValuesSupported Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientColorsConverter..::.IsValid Method
GradientColorsConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

GradientColorsConverter Class
GradientColorsConverter Members


GradientShade Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientShade Enumeration
See Also Send Feedback
Specifies the shading style used for creating gradient fills.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum GradientShade
Visual Basic (Declaration)
Public Enumeration GradientShade
Visual C++
public enum class GradientShade

Members

Member name | Description
None | Creates a gradient shade without using any special shape.
Triangle | Creates a gradient shade based on a triangular shape.
BellShapedCurve | Creates a gradient shade based on a bell-shaped curve.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


GradientShape Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
GradientShape Enumeration
See Also Send Feedback
Specifies the shape used for creating gradient fills.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum GradientShape
Visual Basic (Declaration)
Public Enumeration GradientShape
Visual C++
public enum class GradientShape

Members

Member name | Description
Line |
Path |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


HorizontalAlignment Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
HorizontalAlignment Enumeration
See Also Send Feedback
Specifies how an object or text is horizontally aligned.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum HorizontalAlignment
Visual Basic (Declaration)
Public Enumeration HorizontalAlignment
Visual C++
public enum class HorizontalAlignment

Members

Member name | Description
Left | The object or text is aligned on the left.
Right | The object or text is aligned on the right.
Center | The object or text is aligned in the center.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


ImageDraw Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw Class
Members See Also Send Feedback
ImageDraw generates dynamic composite images to your .NET applications.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class ImageDraw
Visual Basic (Declaration)
Public Class ImageDraw
Visual C++
public ref class ImageDraw

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.ImageDraw

See Also

ImageDraw Members


ImageDraw Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw Members
ImageDraw Class Constructors Methods Properties See Also Send Feedback

The ImageDraw type exposes the following members.

Constructors

Name | Description
ImageDraw | Initializes a new instance of the ImageDraw class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDraftImage | Returns a Bitmap object of the draft image.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Returns a Bitmap object of the output image. The image format will be the specified by ImageFormat property.
GetOutputImageBinary | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlTemplate | Gets an XML Template for the composite image.
LoadXmlTemplate | Restores the composite image based on data in the specified XML Template.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
SaveWbmpImage | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Neodynamic.SDK.ImageDraw object.
Background | Gets the background fill only when applying Actions on the whole output image.
Canvas | Gets the image canvas. Represents the surface on which Element objects are drawn.
ColorDepth | Gets or sets the pixel format (a.k.a. color depth) that defines the number of bits within each pixel (a.k.a. bpp). If the output image format is GIF, then the Color Depth value will be ignored because GIF images are always saved using an 8 bits-per-pixel.
Dpi | Gets or sets the resolution of the output image; in dots per inch (DPI). Default value is 96.
Elements | Gets a collection of Element objects representing the individual elements within the control.
ImageFormat | Gets or sets the image format to render. MIME possible values: Gif, Jpeg, Bmp, and Png.
JpegCompressionLevel | Gets or sets the JPEG Compression Level that must be applied when the output image format is JPEG. Possible values: integer number between 0 and 100. A quality level of 0 corresponds to the greatest compression, and a quality level of 100 corresponds to the least compression.
LicenseKey | Gets or sets the License Key you receive when purchasing a licensed version of ImageDraw.
LicenseOwner | Gets or sets the License Owner you receive when purchasing a licensed version of ImageDraw.
Monochrome | Gets or sets a value indicating whether the output image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.
MonochromeSettings | Gets the monochrome settings used for Black/White and WBMP conversion.
OutputImageSize | Gets the size of the output image, in pixel unit.

See Also

ImageDraw Class


ImageDraw Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw Constructor
ImageDraw Class See Also Send Feedback
Initializes a new instance of the ImageDraw class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ImageDraw()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageDraw()

See Also

ImageDraw Class


ImageDraw Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw Methods
ImageDraw Class See Also Send Feedback

The ImageDraw type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDraftImage | Returns a Bitmap object of the draft image.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Returns a Bitmap object of the output image. The image format will be the specified by ImageFormat property.
GetOutputImageBinary | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetXmlTemplate | Gets an XML Template for the composite image.
LoadXmlTemplate | Restores the composite image based on data in the specified XML Template.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | Overloaded.
SaveWbmpImage | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageDraw Class


GetDraftImage Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetDraftImage Method
ImageDraw Class See Also Send Feedback
Returns a Bitmap object of the draft image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Bitmap GetDraftImage()
Visual Basic (Declaration)
Public Function GetDraftImage As Bitmap
Visual C++
public:
Bitmap^ GetDraftImage()

Return Value

A Bitmap object representing the draft image generated by this ImageDraw object.

See Also

ImageDraw Class


GetOutputImage Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetOutputImage Method
ImageDraw Class See Also Send Feedback
Returns a Bitmap object of the output image. The image format will be the specified by ImageFormat property.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Bitmap GetOutputImage()
Visual Basic (Declaration)
Public Function GetOutputImage As Bitmap
Visual C++
public:
Bitmap^ GetOutputImage()

Return Value

A Bitmap object representing the output image generated by this ImageDraw object.

See Also

ImageDraw Class


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetOutputImageBinary Method
ImageDraw Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary()()() | Returns a byte array of the output image. The image format will be the specified by ImageFormat property.
GetOutputImageBinary(String) | Gets a byte array that represents the output image based on the specified MIME image format.

See Also

ImageDraw Class
ImageDraw Members


GetOutputImageBinary Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetOutputImageBinary Method
ImageDraw Class See Also Send Feedback
Returns a byte array of the output image. The image format will be the specified by ImageFormat property.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] GetOutputImageBinary()
Visual Basic (Declaration)
Public Function GetOutputImageBinary As Byte()
Visual C++
public:
array<unsigned char>^ GetOutputImageBinary()

Return Value

A byte array representing the output image generated by this ImageDraw object.

See Also

ImageDraw Class
GetOutputImageBinary Overload


GetOutputImageBinary Method (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetOutputImageBinary Method (String)
ImageDraw Class See Also Send Feedback
Gets a byte array that represents the output image based on the specified MIME image format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] GetOutputImageBinary(
    string MIME
)
Visual Basic (Declaration)
Public Function GetOutputImageBinary ( _
    MIME As String _
) As Byte()
Visual C++
public:
array<unsigned char>^ GetOutputImageBinary(
    String^ MIME
)

Parameters

MIME
Type: System..::.String
The MIME image format for the output image.

Return Value

A byte array representation of the output image.

See Also

ImageDraw Class
GetOutputImageBinary Overload


GetXmlTemplate Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.GetXmlTemplate Method
ImageDraw Class See Also Send Feedback
Gets an XML Template for the composite image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string GetXmlTemplate()
Visual Basic (Declaration)
Public Function GetXmlTemplate As String
Visual C++
public:
String^ GetXmlTemplate()

Return Value

An XML Template for the composite image.

See Also

ImageDraw Class


LoadXmlTemplate Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.LoadXmlTemplate Method
ImageDraw Class See Also Send Feedback
Restores the composite image based on data in the specified XML Template.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void LoadXmlTemplate(
    string xmlTemplate
)
Visual Basic (Declaration)
Public Sub LoadXmlTemplate ( _
    xmlTemplate As String _
)
Visual C++
public:
void LoadXmlTemplate(
    String^ xmlTemplate
)

Parameters

xmlTemplate
Type: System..::.String
An XML Template for restoring the composite image.

See Also

ImageDraw Class


Save Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Save Method
ImageDraw Class See Also Send Feedback

Overload List

Name | Description
Save(Stream) | Saves the output image to the specified stream. The image format will be the specified by ImageFormat property.
Save(String) | Saves the output image to the specified file. The image format will be the specified by ImageFormat property.
Save(Stream, ImageFormat) | Saves the output image to the specified stream in the specified format.
Save(String, ImageFormat) | Saves the output image to the specified file in the specified format.

See Also

ImageDraw Class
ImageDraw Members


Save Method (Stream)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Save Method (Stream)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified stream. The image format will be the specified by ImageFormat property.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream _
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The Stream where the image will be saved.

See Also

ImageDraw Class
Save Overload


Save Method (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Save Method (String)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified file. The image format will be the specified by ImageFormat property.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String _
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
A string that contains the name of the file to which to save the output image.

See Also

ImageDraw Class
Save Overload


Save Method (Stream, ImageFormat)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Save Method (Stream, ImageFormat)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified stream in the specified format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Save(
    Stream stream,
    ImageFormat format
)
Visual Basic (Declaration)
Public Sub Save ( _
    stream As Stream, _
    format As ImageFormat _
)
Visual C++
public:
void Save(
    Stream^ stream,
    ImageFormat^ format
)

Parameters

stream
Type: System.IO..::.Stream
The Stream where the image will be saved.
format
Type: System.Drawing.Imaging..::.ImageFormat
The ImageFormat object for the output image.

See Also

ImageDraw Class
Save Overload


Save Method (String, ImageFormat)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Save Method (String, ImageFormat)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified file in the specified format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void Save(
    string fileName,
    ImageFormat format
)
Visual Basic (Declaration)
Public Sub Save ( _
    fileName As String, _
    format As ImageFormat _
)
Visual C++
public:
void Save(
    String^ fileName,
    ImageFormat^ format
)

Parameters

fileName
Type: System..::.String
A string that contains the name of the file to which to save the output image.
format
Type: System.Drawing.Imaging..::.ImageFormat
The ImageFormat object for the output image.

See Also

ImageDraw Class
Save Overload


SaveWbmpImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.SaveWbmpImage Method
ImageDraw Class See Also Send Feedback

Overload List

Name | Description
SaveWbmpImage(Stream) | Saves the output image to the specified Stream object in Wireless Bitmap (WBMP) image format.
SaveWbmpImage(String) | Saves the output image to the specified file in Wireless Bitmap (WBMP) image format.

See Also

ImageDraw Class
ImageDraw Members


SaveWbmpImage Method (Stream)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.SaveWbmpImage Method (Stream)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified Stream object in Wireless Bitmap (WBMP) image format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void SaveWbmpImage(
    Stream stream
)
Visual Basic (Declaration)
Public Sub SaveWbmpImage ( _
    stream As Stream _
)
Visual C++
public:
void SaveWbmpImage(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::.Stream
The Stream object to which to save the output image.

See Also

ImageDraw Class
SaveWbmpImage Overload


SaveWbmpImage Method (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.SaveWbmpImage Method (String)
ImageDraw Class See Also Send Feedback
Saves the output image to the specified file in Wireless Bitmap (WBMP) image format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void SaveWbmpImage(
    string filename
)
Visual Basic (Declaration)
Public Sub SaveWbmpImage ( _
    filename As String _
)
Visual C++
public:
void SaveWbmpImage(
    String^ filename
)

Parameters

filename
Type: System..::.String
A string that contains the name of the file to which to save the output image.

See Also

ImageDraw Class
SaveWbmpImage Overload


ImageDraw Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw Properties
ImageDraw Class See Also Send Feedback

The ImageDraw type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Neodynamic.SDK.ImageDraw object.
Background | Gets the background fill only when applying Actions on the whole output image.
Canvas | Gets the image canvas. Represents the surface on which Element objects are drawn.
ColorDepth | Gets or sets the pixel format (a.k.a. color depth) that defines the number of bits within each pixel (a.k.a. bpp). If the output image format is GIF, then the Color Depth value will be ignored because GIF images are always saved using an 8 bits-per-pixel.
Dpi | Gets or sets the resolution of the output image; in dots per inch (DPI). Default value is 96.
Elements | Gets a collection of Element objects representing the individual elements within the control.
ImageFormat | Gets or sets the image format to render. MIME possible values: Gif, Jpeg, Bmp, and Png.
JpegCompressionLevel | Gets or sets the JPEG Compression Level that must be applied when the output image format is JPEG. Possible values: integer number between 0 and 100. A quality level of 0 corresponds to the greatest compression, and a quality level of 100 corresponds to the least compression.
LicenseKey | Gets or sets the License Key you receive when purchasing a licensed version of ImageDraw.
LicenseOwner | Gets or sets the License Owner you receive when purchasing a licensed version of ImageDraw.
Monochrome | Gets or sets a value indicating whether the output image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.
MonochromeSettings | Gets the monochrome settings used for Black/White and WBMP conversion.
OutputImageSize | Gets the size of the output image, in pixel unit.

See Also

ImageDraw Class


Actions Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Actions Property
ImageDraw Class See Also Send Feedback
Gets the Action objects that will applied on this Neodynamic.SDK.ImageDraw object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Actions As ActionCollection
Visual C++
public:
property ActionCollection^ Actions {
    ActionCollection^ get ();
}

See Also

ImageDraw Class


Background Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Background Property
ImageDraw Class See Also Send Feedback
Gets the background fill only when applying Actions on the whole output image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Fill
Visual C++
public:
property Fill^ Background {
    Fill^ get ();
}

See Also

ImageDraw Class


Canvas Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Canvas Property
ImageDraw Class See Also Send Feedback
Gets the image canvas. Represents the surface on which Element objects are drawn.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Canvas Canvas { get; }
Visual Basic (Declaration)
Public ReadOnly Property Canvas As Canvas
Visual C++
public:
property Canvas^ Canvas {
    Canvas^ get ();
}

See Also

ImageDraw Class


ColorDepth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.ColorDepth Property
ImageDraw Class See Also Send Feedback
Gets or sets the pixel format (a.k.a. color depth) that defines the number of bits within each pixel (a.k.a. bpp). If the output image format is GIF, then the Color Depth value will be ignored because GIF images are always saved using an 8 bits-per-pixel.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ColorDepth ColorDepth { get; set; }
Visual Basic (Declaration)
Public Property ColorDepth As ColorDepth
Visual C++
public:
property ColorDepth ColorDepth {
    ColorDepth get ();
    void set (ColorDepth value);
}

See Also

ImageDraw Class


Dpi Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Dpi Property
ImageDraw Class See Also Send Feedback
Gets or sets the resolution of the output image; in dots per inch (DPI). Default value is 96.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Dpi { get; set; }
Visual Basic (Declaration)
Public Property Dpi As Integer
Visual C++
public:
property int Dpi {
    int get ();
    void set (int value);
}

See Also

ImageDraw Class


Elements Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Elements Property
ImageDraw Class See Also Send Feedback
Gets a collection of Element objects representing the individual elements within the control.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ElementCollection Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As ElementCollection
Visual C++
public:
property ElementCollection^ Elements {
    ElementCollection^ get ();
}

See Also

ImageDraw Class


ImageFormat Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.ImageFormat Property
ImageDraw Class See Also Send Feedback
Gets or sets the image format to render. MIME possible values: Gif, Jpeg, Bmp, and Png.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ImageDrawFormat ImageFormat { get; set; }
Visual Basic (Declaration)
Public Property ImageFormat As ImageDrawFormat
Visual C++
public:
property ImageDrawFormat ImageFormat {
    ImageDrawFormat get ();
    void set (ImageDrawFormat value);
}

See Also

ImageDraw Class


JpegCompressionLevel Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.JpegCompressionLevel Property
ImageDraw Class See Also Send Feedback
Gets or sets the JPEG Compression Level that must be applied when the output image format is JPEG. Possible values: integer number between 0 and 100. A quality level of 0 corresponds to the greatest compression, and a quality level of 100 corresponds to the least compression.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int JpegCompressionLevel { get; set; }
Visual Basic (Declaration)
Public Property JpegCompressionLevel As Integer
Visual C++
public:
property int JpegCompressionLevel {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

ImageDraw Class


LicenseKey Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.LicenseKey Property
ImageDraw Class See Also Send Feedback
Gets or sets the License Key you receive when purchasing a licensed version of ImageDraw.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static string LicenseKey { get; set; }
Visual Basic (Declaration)
Public Shared Property LicenseKey As String
Visual C++
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

See Also

ImageDraw Class


LicenseOwner Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.LicenseOwner Property
ImageDraw Class See Also Send Feedback
Gets or sets the License Owner you receive when purchasing a licensed version of ImageDraw.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static string LicenseOwner { get; set; }
Visual Basic (Declaration)
Public Shared Property LicenseOwner As String
Visual C++
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

See Also

ImageDraw Class


Monochrome Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.Monochrome Property
ImageDraw Class See Also Send Feedback
Gets or sets a value indicating whether the output image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Monochrome { get; set; }
Visual Basic (Declaration)
Public Property Monochrome As Boolean
Visual C++
public:
property bool Monochrome {
    bool get ();
    void set (bool value);
}

See Also

ImageDraw Class


MonochromeSettings Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.MonochromeSettings Property
ImageDraw Class See Also Send Feedback
Gets the monochrome settings used for Black/White and WBMP conversion.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MonochromeSettings MonochromeSettings { get; }
Visual Basic (Declaration)
Public ReadOnly Property MonochromeSettings As MonochromeSettings
Visual C++
public:
property MonochromeSettings^ MonochromeSettings {
    MonochromeSettings^ get ();
}

See Also

ImageDraw Class


OutputImageSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDraw..::.OutputImageSize Property
ImageDraw Class See Also Send Feedback
Gets the size of the output image, in pixel unit.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Size OutputImageSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property OutputImageSize As Size
Visual C++
public:
property Size OutputImageSize {
    Size get ();
}

See Also

ImageDraw Class


ImageDrawFormat Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageDrawFormat Enumeration
See Also Send Feedback
Specifies the format of the output image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ImageDrawFormat
Visual Basic (Declaration)
Public Enumeration ImageDrawFormat
Visual C++
public enum class ImageDrawFormat

Members

Member name | Description
Bmp | Specifies the format of the output image is BMP (Bitmap).
Gif | Specifies the format of the output image is GIF (Graphics Interchange Format).
Jpeg | Specifies the format of the output image is JPEG (Joint Photographic Experts Group).
Png | Specifies the format of the output image is PNG (Portable Network Graphics).

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


ImageElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement Class
Members See Also Send Feedback
Represents an image element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class ImageElement : Element
Visual Basic (Declaration)
Public Class ImageElement _
    Inherits Element
Visual C++
public ref class ImageElement : public Element

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ImageElement

See Also

ImageElement Members


ImageElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement Members
ImageElement Class Constructors Methods Properties See Also Send Feedback

The ImageElement type exposes the following members.

Constructors

Name | Description
ImageElement | Initializes a new instance of the ImageElement class.

Methods

Name | Description
Clone | Creates a copy of the current ImageElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromBase64 | Creates an ImageElement object from the specified Base64 string.
FromBinary | Overloaded.
FromFile | Creates an ImageElement object from the specified file.
FromImage | Creates an ImageElement object from the specified Image object.
FromUrl | Creates an ImageElement object from the specified URL string.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Height | Gets or sets the height of the element. (Inherited from Element.)
MultiPageCount | Gets the number of pages/frames contained in a multi-page image.
MultiPageIndex | Gets or sets the page/frame index (zero based) of a multi-page image to be used.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullImageUrl | Gets or sets the image file path or URL which will be displayed when the specified source image cannot be accessed or when the value of the field specified by any Data Binding properties are null references (Nothing in Visual Basic).
PreserveMetaData | Gets or sets whether the metadata (like EXIF) of the source image should be preserved for this ImageElement.
Source | Gets or sets the image source type for this ImageElement object.
SourceBase64 | Gets or sets the Base64 string of the image content.
SourceBinary | Gets or sets the binary content of the image.
SourceBinaryOffset | Gets or sets the number of bytes that must be skipped on the source image when generating the image based on the SourceBinary property
SourceDpi | Gets the resolution of the source image; in dots per inch (DPI).
SourceFile | Gets or sets the image file path or URL.
SourceImage | Gets or sets the content of the image.
UseSourceDpi | Gets or sets whether the resolution of the source image (DPI) should be used for creating this ImageElement.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ImageElement Class


ImageElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement Constructor
ImageElement Class See Also Send Feedback
Initializes a new instance of the ImageElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ImageElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageElement()

See Also

ImageElement Class


ImageElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement Methods
ImageElement Class See Also Send Feedback

The ImageElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current ImageElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FromBase64 | Creates an ImageElement object from the specified Base64 string.
FromBinary | Overloaded.
FromFile | Creates an ImageElement object from the specified file.
FromImage | Creates an ImageElement object from the specified Image object.
FromUrl | Creates an ImageElement object from the specified URL string.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

ImageElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.Clone Method
ImageElement Class See Also Send Feedback
Creates a copy of the current ImageElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current ImageElement.

See Also

ImageElement Class


FromBase64 Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromBase64 Method
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified Base64 string.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromBase64(
    string base64
)
Visual Basic (Declaration)
Public Shared Function FromBase64 ( _
    base64 As String _
) As ImageElement
Visual C++
public:
static ImageElement^ FromBase64(
    String^ base64
)

Parameters

base64
Type: System..::.String
A Base64 string from which to create the ImageElement object.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class


FromBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromBinary Method
ImageElement Class See Also Send Feedback

Overload List

Name | Description
FromBinary(array<Byte>[]()[]) | Creates an ImageElement object from the specified byte array.
FromBinary(array<Byte>[]()[], Int32) | Creates an ImageElement object from the specified byte array and offset.

See Also

ImageElement Class
ImageElement Members


FromBinary Method (Byte[])

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromBinary Method (array<Byte>[]()[])
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified byte array.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromBinary(
    byte[] binaryContent
)
Visual Basic (Declaration)
Public Shared Function FromBinary ( _
    binaryContent As Byte() _
) As ImageElement
Visual C++
public:
static ImageElement^ FromBinary(
    array<unsigned char>^ binaryContent
)

Parameters

binaryContent
Type: array< System..::.Byte >[]()[]
A byte array from which to create the ImageElement object.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class
FromBinary Overload


FromBinary Method (Byte[], Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromBinary Method (array<Byte>[]()[], Int32)
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified byte array and offset.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromBinary(
    byte[] binaryContent,
    int binaryContentOffset
)
Visual Basic (Declaration)
Public Shared Function FromBinary ( _
    binaryContent As Byte(), _
    binaryContentOffset As Integer _
) As ImageElement
Visual C++
public:
static ImageElement^ FromBinary(
    array<unsigned char>^ binaryContent,
    int binaryContentOffset
)

Parameters

binaryContent
Type: array< System..::.Byte >[]()[]
A byte array from which to create the ImageElement object.
binaryContentOffset
Type: System..::.Int32
The number of bytes that must be skipped on the specified byte array.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class
FromBinary Overload


FromFile Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromFile Method
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified file.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromFile(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function FromFile ( _
    fileName As String _
) As ImageElement
Visual C++
public:
static ImageElement^ FromFile(
    String^ fileName
)

Parameters

fileName
Type: System..::.String
A string that contains the name of the file from which to create the ImageElement object.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class


FromImage Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromImage Method
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified Image object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromImage(
    Image image
)
Visual Basic (Declaration)
Public Shared Function FromImage ( _
    image As Image _
) As ImageElement
Visual C++
public:
static ImageElement^ FromImage(
    Image^ image
)

Parameters

image
Type: System.Drawing..::.Image
Image from which to create the ImageElement object.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class


FromUrl Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.FromUrl Method
ImageElement Class See Also Send Feedback
Creates an ImageElement object from the specified URL string.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static ImageElement FromUrl(
    string url
)
Visual Basic (Declaration)
Public Shared Function FromUrl ( _
    url As String _
) As ImageElement
Visual C++
public:
static ImageElement^ FromUrl(
    String^ url
)

Parameters

url
Type: System..::.String
A URL string that points to the file from which to create the ImageElement object.

Return Value

The ImageElement object this method creates.

See Also

ImageElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.GetOutputImage Method
ImageElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

ImageElement Class
ImageElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.GetOutputImageBinary Method
ImageElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

ImageElement Class
ImageElement Members


ImageElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement Properties
ImageElement Class See Also Send Feedback

The ImageElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Height | Gets or sets the height of the element. (Inherited from Element.)
MultiPageCount | Gets the number of pages/frames contained in a multi-page image.
MultiPageIndex | Gets or sets the page/frame index (zero based) of a multi-page image to be used.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullImageUrl | Gets or sets the image file path or URL which will be displayed when the specified source image cannot be accessed or when the value of the field specified by any Data Binding properties are null references (Nothing in Visual Basic).
PreserveMetaData | Gets or sets whether the metadata (like EXIF) of the source image should be preserved for this ImageElement.
Source | Gets or sets the image source type for this ImageElement object.
SourceBase64 | Gets or sets the Base64 string of the image content.
SourceBinary | Gets or sets the binary content of the image.
SourceBinaryOffset | Gets or sets the number of bytes that must be skipped on the source image when generating the image based on the SourceBinary property
SourceDpi | Gets the resolution of the source image; in dots per inch (DPI).
SourceFile | Gets or sets the image file path or URL.
SourceImage | Gets or sets the content of the image.
UseSourceDpi | Gets or sets whether the resolution of the source image (DPI) should be used for creating this ImageElement.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ImageElement Class


MultiPageCount Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.MultiPageCount Property
ImageElement Class See Also Send Feedback
Gets the number of pages/frames contained in a multi-page image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int MultiPageCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property MultiPageCount As Integer
Visual C++
public:
property int MultiPageCount {
    int get ();
}

See Also

ImageElement Class


MultiPageIndex Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.MultiPageIndex Property
ImageElement Class See Also Send Feedback
Gets or sets the page/frame index (zero based) of a multi-page image to be used.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int MultiPageIndex { get; set; }
Visual Basic (Declaration)
Public Property MultiPageIndex As Integer
Visual C++
public:
property int MultiPageIndex {
    int get ();
    void set (int value);
}

See Also

ImageElement Class


NullImageUrl Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.NullImageUrl Property
ImageElement Class See Also Send Feedback
Gets or sets the image file path or URL which will be displayed when the specified source image cannot be accessed or when the value of the field specified by any Data Binding properties are null references (Nothing in Visual Basic).

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string NullImageUrl { get; set; }
Visual Basic (Declaration)
Public Property NullImageUrl As String
Visual C++
public:
property String^ NullImageUrl {
    String^ get ();
    void set (String^ value);
}

See Also

ImageElement Class


PreserveMetaData Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.PreserveMetaData Property
ImageElement Class See Also Send Feedback
Gets or sets whether the metadata (like EXIF) of the source image should be preserved for this ImageElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool PreserveMetaData { get; set; }
Visual Basic (Declaration)
Public Property PreserveMetaData As Boolean
Visual C++
public:
property bool PreserveMetaData {
    bool get ();
    void set (bool value);
}

See Also

ImageElement Class


Source Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.Source Property
ImageElement Class See Also Send Feedback
Gets or sets the image source type for this ImageElement object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ImageSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As ImageSource
Visual C++
public:
property ImageSource Source {
    ImageSource get ();
    void set (ImageSource value);
}

See Also

ImageElement Class


SourceBase64 Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceBase64 Property
ImageElement Class See Also Send Feedback
Gets or sets the Base64 string of the image content.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string SourceBase64 { get; set; }
Visual Basic (Declaration)
Public Property SourceBase64 As String
Visual C++
public:
property String^ SourceBase64 {
    String^ get ();
    void set (String^ value);
}

See Also

ImageElement Class


SourceBinary Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceBinary Property
ImageElement Class See Also Send Feedback
Gets or sets the binary content of the image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte[] SourceBinary { get; set; }
Visual Basic (Declaration)
Public Property SourceBinary As Byte()
Visual C++
public:
property array<unsigned char>^ SourceBinary {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

See Also

ImageElement Class


SourceBinaryOffset Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceBinaryOffset Property
ImageElement Class See Also Send Feedback
Gets or sets the number of bytes that must be skipped on the source image when generating the image based on the SourceBinary property

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int SourceBinaryOffset { get; set; }
Visual Basic (Declaration)
Public Property SourceBinaryOffset As Integer
Visual C++
public:
property int SourceBinaryOffset {
    int get ();
    void set (int value);
}

See Also

ImageElement Class


SourceDpi Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceDpi Property
ImageElement Class See Also Send Feedback
Gets the resolution of the source image; in dots per inch (DPI).

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int SourceDpi { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceDpi As Integer
Visual C++
public:
property int SourceDpi {
    int get ();
}

See Also

ImageElement Class


SourceFile Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceFile Property
ImageElement Class See Also Send Feedback
Gets or sets the image file path or URL.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string SourceFile { get; set; }
Visual Basic (Declaration)
Public Property SourceFile As String
Visual C++
public:
property String^ SourceFile {
    String^ get ();
    void set (String^ value);
}

See Also

ImageElement Class


SourceImage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.SourceImage Property
ImageElement Class See Also Send Feedback
Gets or sets the content of the image.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Image SourceImage { get; set; }
Visual Basic (Declaration)
Public Property SourceImage As Image
Visual C++
public:
property Image^ SourceImage {
    Image^ get ();
    void set (Image^ value);
}

See Also

ImageElement Class


UseSourceDpi Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageElement..::.UseSourceDpi Property
ImageElement Class See Also Send Feedback
Gets or sets whether the resolution of the source image (DPI) should be used for creating this ImageElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool UseSourceDpi { get; set; }
Visual Basic (Declaration)
Public Property UseSourceDpi As Boolean
Visual C++
public:
property bool UseSourceDpi {
    bool get ();
    void set (bool value);
}

See Also

ImageElement Class


ImageMetaDataReader Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader Class
Members See Also Send Feedback
Extract image metadata like EXIF

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class ImageMetaDataReader
Visual Basic (Declaration)
Public Class ImageMetaDataReader
Visual C++
public ref class ImageMetaDataReader

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.ImageMetaDataReader

See Also

ImageMetaDataReader Members


ImageMetaDataReader Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader Members
ImageMetaDataReader Class Constructors Methods See Also Send Feedback

The ImageMetaDataReader type exposes the following members.

Constructors

Name | Description
ImageMetaDataReader | Initializes a new instance of the ImageMetaDataReader class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExifMetadata | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageMetaDataReader Class


ImageMetaDataReader Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader Constructor
ImageMetaDataReader Class See Also Send Feedback
Initializes a new instance of the ImageMetaDataReader class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ImageMetaDataReader()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageMetaDataReader()

See Also

ImageMetaDataReader Class


ImageMetaDataReader Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader Methods
ImageMetaDataReader Class See Also Send Feedback

The ImageMetaDataReader type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetExifMetadata | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ImageMetaDataReader Class


GetExifMetadata Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader..::.GetExifMetadata Method
ImageMetaDataReader Class See Also Send Feedback

Overload List

Name | Description
GetExifMetadata(String) | Gets the EXIF tags and their values embedded in the specified image file.
GetExifMetadata(String, ExifTags) | Gets the metadata value for the specified EXIF tag in the specified image file.

See Also

ImageMetaDataReader Class
ImageMetaDataReader Members


GetExifMetadata Method (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader..::.GetExifMetadata Method (String)
ImageMetaDataReader Class See Also Send Feedback
Gets the EXIF tags and their values embedded in the specified image file.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static Dictionary<ExifTags, string> GetExifMetadata(
    string imageFileName
)
Visual Basic (Declaration)
Public Shared Function GetExifMetadata ( _
    imageFileName As String _
) As Dictionary(Of ExifTags, String)
Visual C++
public:
static Dictionary<ExifTags, String^>^ GetExifMetadata(
    String^ imageFileName
)

Parameters

imageFileName
Type: System..::.String
The image file containing EXIF metadata

Return Value

The EXIF tags and their values embedded in the specified image file.

See Also

ImageMetaDataReader Class
GetExifMetadata Overload


GetExifMetadata Method (String, ExifTags)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageMetaDataReader..::.GetExifMetadata Method (String, ExifTags)
ImageMetaDataReader Class See Also Send Feedback
Gets the metadata value for the specified EXIF tag in the specified image file.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static string GetExifMetadata(
    string imageFileName,
    ExifTags exifTag
)
Visual Basic (Declaration)
Public Shared Function GetExifMetadata ( _
    imageFileName As String, _
    exifTag As ExifTags _
) As String
Visual C++
public:
static String^ GetExifMetadata(
    String^ imageFileName,
    ExifTags exifTag
)

Parameters

imageFileName
Type: System..::.String
The image file containing EXIF metadata
exifTag
Type: Neodynamic.SDK.ImageDraw..::.ExifTags
The EXIF tag

Return Value

The metadata value for the specified EXIF tag in the specified image file.

See Also

ImageMetaDataReader Class
GetExifMetadata Overload


ImageSource Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ImageSource Enumeration
See Also Send Feedback
Specifies the source for an ImageElement object

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ImageSource
Visual Basic (Declaration)
Public Enumeration ImageSource
Visual C++
public enum class ImageSource

Members

Member name | Description
File | The image content must be get from a path or URL
Base64String | The image content must be get from a Base64 string
Binary | The image content must be get from a Byte array
Image | The image content must be get from a System.Drawing.Image object

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


LineCapStyle Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineCapStyle Enumeration
See Also Send Feedback
Specifies the available cap styles used to start and end a line element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum LineCapStyle
Visual Basic (Declaration)
Public Enumeration LineCapStyle
Visual C++
public enum class LineCapStyle

Members

Member name | Description
Flat |
Arrow |
Diamond |
Square |
Circle |
Pentagon |
Hexagon |
Octagon |
Star3Points |
Star3PointsHeavy |
Star4Points |
Star4PointsHeavy |
Star5Points |
Star5PointsHeavy |
Star6Points |
Star6PointsHeavy |
Burst12Points |
Burst16Points |
Burst20Points |
Burst24Points |
Rounded |
RoundedArrow |
RoundedDiamond |
RoundedSquare |
RoundedPentagon |
RoundedHexagon |
RoundedOctagon |
RoundedStar3Points |
RoundedStar4Points |
RoundedStar5Points |
RoundedStar6Points |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


LineOrientation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineOrientation Enumeration
See Also Send Feedback
Specifies the orientation for line shape elements.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum LineOrientation
Visual Basic (Declaration)
Public Enumeration LineOrientation
Visual C++
public enum class LineOrientation

Members

Member name | Description
Horizontal | Specifies a horizontal line.
Vertical | Specifies a vertical line.
DiagonalUp | Specifies a diagonal upward line.
DiagonalDown | Specifies a diagonal downward line.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


LineShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement Class
Members See Also Send Feedback
Represents a line shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class LineShapeElement : ShapeElement
Visual Basic (Declaration)
Public Class LineShapeElement _
    Inherits ShapeElement
Visual C++
public ref class LineShapeElement : public ShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.LineShapeElement

See Also

LineShapeElement Members


LineShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement Members
LineShapeElement Class Constructors Methods Properties See Also Send Feedback

The LineShapeElement type exposes the following members.

Constructors

Name | Description
LineShapeElement | Initializes a new instance of the LineShapeElement class.

Methods

Name | Description
Clone | Creates a copy of the current LineShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
EndLineCap | Gets or sets the cap style used to end a line element.
EndLineCapWidth | Gets or sets the width of the cap style used to end a line element.
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
Orientation | Gets or sets the line orientation.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StartLineCap | Gets or sets the cap style used to start a line element.
StartLineCapWidth | Gets or sets the width of the cap style used to start a line element.
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

LineShapeElement Class


LineShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement Constructor
LineShapeElement Class See Also Send Feedback
Initializes a new instance of the LineShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public LineShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
LineShapeElement()

See Also

LineShapeElement Class


LineShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement Methods
LineShapeElement Class See Also Send Feedback

The LineShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current LineShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

LineShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.Clone Method
LineShapeElement Class See Also Send Feedback
Creates a copy of the current LineShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current LineShapeElement.

See Also

LineShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.GetOutputImage Method
LineShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

LineShapeElement Class
LineShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.GetOutputImageBinary Method
LineShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

LineShapeElement Class
LineShapeElement Members


LineShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement Properties
LineShapeElement Class See Also Send Feedback

The LineShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
EndLineCap | Gets or sets the cap style used to end a line element.
EndLineCapWidth | Gets or sets the width of the cap style used to end a line element.
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
Orientation | Gets or sets the line orientation.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StartLineCap | Gets or sets the cap style used to start a line element.
StartLineCapWidth | Gets or sets the width of the cap style used to start a line element.
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

LineShapeElement Class


EndLineCap Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.EndLineCap Property
LineShapeElement Class See Also Send Feedback
Gets or sets the cap style used to end a line element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public LineCapStyle EndLineCap { get; set; }
Visual Basic (Declaration)
Public Property EndLineCap As LineCapStyle
Visual C++
public:
property LineCapStyle EndLineCap {
    LineCapStyle get ();
    void set (LineCapStyle value);
}

See Also

LineShapeElement Class


EndLineCapWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.EndLineCapWidth Property
LineShapeElement Class See Also Send Feedback
Gets or sets the width of the cap style used to end a line element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int EndLineCapWidth { get; set; }
Visual Basic (Declaration)
Public Property EndLineCapWidth As Integer
Visual C++
public:
property int EndLineCapWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to two.

See Also

LineShapeElement Class


Orientation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.Orientation Property
LineShapeElement Class See Also Send Feedback
Gets or sets the line orientation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public LineOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As LineOrientation
Visual C++
public:
property LineOrientation Orientation {
    LineOrientation get ();
    void set (LineOrientation value);
}

See Also

LineShapeElement Class


StartLineCap Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.StartLineCap Property
LineShapeElement Class See Also Send Feedback
Gets or sets the cap style used to start a line element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public LineCapStyle StartLineCap { get; set; }
Visual Basic (Declaration)
Public Property StartLineCap As LineCapStyle
Visual C++
public:
property LineCapStyle StartLineCap {
    LineCapStyle get ();
    void set (LineCapStyle value);
}

See Also

LineShapeElement Class


StartLineCapWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LineShapeElement..::.StartLineCapWidth Property
LineShapeElement Class See Also Send Feedback
Gets or sets the width of the cap style used to start a line element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StartLineCapWidth { get; set; }
Visual Basic (Declaration)
Public Property StartLineCapWidth As Integer
Visual C++
public:
property int StartLineCapWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to two.

See Also

LineShapeElement Class


LockAspectRatio Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
LockAspectRatio Enumeration
See Also Send Feedback
Specifies how element's proportions are maintained.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum LockAspectRatio
Visual Basic (Declaration)
Public Enumeration LockAspectRatio
Visual C++
public enum class LockAspectRatio

Members

Member name | Description
None | Specifies that element's proportions are not maintained.
WidthBased | Specifies that element's proportions are maintained based on the new width value.
HeightBased | Specifies that element's proportions are maintained based on the new height value.
Fit | Specifies that element's proportions are maintained based on the new width and height values.
FitIfMax | Specifies that element's proportions are maintained based on the new width and height values only if the source size is bigger than the fitting size; otherwise the element's size will not be altered.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


MailStamp Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Class
Members See Also Send Feedback
Defines an action that creates a mail stamp representation of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class MailStamp : Action
Visual Basic (Declaration)
Public NotInheritable Class MailStamp _
    Inherits Action
Visual C++
public ref class MailStamp sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.MailStamp

See Also

MailStamp Members


MailStamp Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Members
MailStamp Class Constructors Methods Properties See Also Send Feedback

The MailStamp type exposes the following members.

Constructors

Name | Description
MailStamp | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current MailStamp. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets the mail stamp background
Height | Gets or sets the mail stamp height
ImageBorderColor | Gets or sets the border color around the image
ImagePadding | Gets the amount of space to insert between the image and its margin in the mail stamp.
PerforationBorderColor | Gets or sets the border color of the perforations
PerforationHeight | Gets or sets the perforations height of the mail stamp
PerforationWidth | Gets or sets perforations width of the mail stamp
Width | Gets or sets the mail stamp width

See Also

MailStamp Class


MailStamp Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Constructor
MailStamp Class See Also Send Feedback

Overload List

Name | Description
MailStamp()()() | Initializes a new instance of the MailStamp class.
MailStamp(Int32, Int32, Padding, Color, Fill, Int32, Int32, Color) | Initializes a new instance of the MailStamp class width mail stamp settings.

See Also

MailStamp Class
MailStamp Members


MailStamp Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Constructor
MailStamp Class See Also Send Feedback
Initializes a new instance of the MailStamp class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MailStamp()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MailStamp()

See Also

MailStamp Class
MailStamp Overload


MailStamp Constructor (Int32, Int32, Padding, Color, Fill, Int32, Int32, Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Constructor (Int32, Int32, Padding, Color, Fill, Int32, Int32, Color)
MailStamp Class See Also Send Feedback
Initializes a new instance of the MailStamp class width mail stamp settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MailStamp(
    int width,
    int height,
    Padding imagePadding,
    Color imageBorderColor,
    Fill background,
    int perforationWidth,
    int perforationHeight,
    Color perforationBorderColor
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    imagePadding As Padding, _
    imageBorderColor As Color, _
    background As Fill, _
    perforationWidth As Integer, _
    perforationHeight As Integer, _
    perforationBorderColor As Color _
)
Visual C++
public:
MailStamp(
    int width,
    int height,
    Padding^ imagePadding,
    Color imageBorderColor,
    Fill^ background,
    int perforationWidth,
    int perforationHeight,
    Color perforationBorderColor
)

Parameters

width
Type: System..::.Int32
The mail stamp width
height
Type: System..::.Int32
The mail stamp height
imagePadding
Type: Neodynamic.SDK.ImageDraw..::.Padding
The amount of space to insert between the image and its margin in the mail stamp
imageBorderColor
Type: System.Drawing..::.Color
The border color around the image
background
Type: Neodynamic.SDK.ImageDraw..::.Fill
The mail stamp background
perforationWidth
Type: System..::.Int32
The perforations width of the mail stamp
perforationHeight
Type: System..::.Int32
The perforations height of the mail stamp
perforationBorderColor
Type: System.Drawing..::.Color
The border color of the perforations

See Also

MailStamp Class
MailStamp Overload


MailStamp Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Methods
MailStamp Class See Also Send Feedback

The MailStamp type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current MailStamp. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MailStamp Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.Clone Method
MailStamp Class See Also Send Feedback
Creates a copy of the current MailStamp.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current MailStamp.

See Also

MailStamp Class


MailStamp Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp Properties
MailStamp Class See Also Send Feedback

The MailStamp type exposes the following members.

Properties

Name | Description
Background | Gets the mail stamp background
Height | Gets or sets the mail stamp height
ImageBorderColor | Gets or sets the border color around the image
ImagePadding | Gets the amount of space to insert between the image and its margin in the mail stamp.
PerforationBorderColor | Gets or sets the border color of the perforations
PerforationHeight | Gets or sets the perforations height of the mail stamp
PerforationWidth | Gets or sets perforations width of the mail stamp
Width | Gets or sets the mail stamp width

See Also

MailStamp Class


Background Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.Background Property
MailStamp Class See Also Send Feedback
Gets the mail stamp background

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Fill
Visual C++
public:
property Fill^ Background {
    Fill^ get ();
}

See Also

MailStamp Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.Height Property
MailStamp Class See Also Send Feedback
Gets or sets the mail stamp height

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

MailStamp Class


ImageBorderColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.ImageBorderColor Property
MailStamp Class See Also Send Feedback
Gets or sets the border color around the image

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ImageBorderColor { get; set; }
Visual Basic (Declaration)
Public Property ImageBorderColor As Color
Visual C++
public:
property Color ImageBorderColor {
    Color get ();
    void set (Color value);
}

See Also

MailStamp Class


ImagePadding Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.ImagePadding Property
MailStamp Class See Also Send Feedback
Gets the amount of space to insert between the image and its margin in the mail stamp.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding ImagePadding { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImagePadding As Padding
Visual C++
public:
property Padding^ ImagePadding {
    Padding^ get ();
}

See Also

MailStamp Class


PerforationBorderColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.PerforationBorderColor Property
MailStamp Class See Also Send Feedback
Gets or sets the border color of the perforations

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color PerforationBorderColor { get; set; }
Visual Basic (Declaration)
Public Property PerforationBorderColor As Color
Visual C++
public:
property Color PerforationBorderColor {
    Color get ();
    void set (Color value);
}

See Also

MailStamp Class


PerforationHeight Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.PerforationHeight Property
MailStamp Class See Also Send Feedback
Gets or sets the perforations height of the mail stamp

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PerforationHeight { get; set; }
Visual Basic (Declaration)
Public Property PerforationHeight As Integer
Visual C++
public:
property int PerforationHeight {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

MailStamp Class


PerforationWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.PerforationWidth Property
MailStamp Class See Also Send Feedback
Gets or sets perforations width of the mail stamp

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PerforationWidth { get; set; }
Visual Basic (Declaration)
Public Property PerforationWidth As Integer
Visual C++
public:
property int PerforationWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

MailStamp Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MailStamp..::.Width Property
MailStamp Class See Also Send Feedback
Gets or sets the mail stamp width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

MailStamp Class


MakeTransparent Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Class
Members See Also Send Feedback
Defines an action that makes transparent color for an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class MakeTransparent : Action
Visual Basic (Declaration)
Public NotInheritable Class MakeTransparent _
    Inherits Action
Visual C++
public ref class MakeTransparent sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.MakeTransparent

See Also

MakeTransparent Members


MakeTransparent Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Members
MakeTransparent Class Constructors Methods Properties See Also Send Feedback

The MakeTransparent type exposes the following members.

Constructors

Name | Description
MakeTransparent | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current MakeTransparent. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Alpha | Gets or sets the alpha component value of the transparent color
Color | Gets or sets the transparent color
ColorTolerance | Gets or sets the color tolerance for transparency. Color Tolerance represents the tonal range of colors that will be converted to transparent taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be converted to transparent; otherwise, a wider range of tones will be converted.
ScanDirection | Gets or sets the direction of the pixel scanning process.
UseFirstPixel | Gets or sets whether the first pixel color of an image will be used as the transparent color

See Also

MakeTransparent Class


MakeTransparent Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Constructor
MakeTransparent Class See Also Send Feedback

Overload List

Name | Description
MakeTransparent()()() | Initializes a new instance of the MakeTransparent class making all white pixel transparent.
MakeTransparent(Boolean) | Initializes a new instance of the MakeTransparent class making the first pixel of an image as the transparent color if the specified parameter is true.
MakeTransparent(Color) | Initializes a new instance of the MakeTransparent class making the specified color as the transparent color.
MakeTransparent(Color, Byte) | Initializes a new instance of the MakeTransparent class making the specified color and the specified alpha component value as the transparent color

See Also

MakeTransparent Class
MakeTransparent Members


MakeTransparent Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Constructor
MakeTransparent Class See Also Send Feedback
Initializes a new instance of the MakeTransparent class making all white pixel transparent.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MakeTransparent()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MakeTransparent()

See Also

MakeTransparent Class
MakeTransparent Overload


MakeTransparent Constructor (Boolean)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Constructor (Boolean)
MakeTransparent Class See Also Send Feedback
Initializes a new instance of the MakeTransparent class making the first pixel of an image as the transparent color if the specified parameter is true.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MakeTransparent(
    bool useFirstPixel
)
Visual Basic (Declaration)
Public Sub New ( _
    useFirstPixel As Boolean _
)
Visual C++
public:
MakeTransparent(
    bool useFirstPixel
)

Parameters

useFirstPixel
Type: System..::.Boolean
Specifies whether the first pixel color of an image will be used as the transparent color

See Also

MakeTransparent Class
MakeTransparent Overload


MakeTransparent Constructor (Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Constructor (Color)
MakeTransparent Class See Also Send Feedback
Initializes a new instance of the MakeTransparent class making the specified color as the transparent color.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MakeTransparent(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
MakeTransparent(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
The transparent color

See Also

MakeTransparent Class
MakeTransparent Overload


MakeTransparent Constructor (Color, Byte)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Constructor (Color, Byte)
MakeTransparent Class See Also Send Feedback
Initializes a new instance of the MakeTransparent class making the specified color and the specified alpha component value as the transparent color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MakeTransparent(
    Color color,
    byte alpha
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color, _
    alpha As Byte _
)
Visual C++
public:
MakeTransparent(
    Color color,
    unsigned char alpha
)

Parameters

color
Type: System.Drawing..::.Color
The transparent color
alpha
Type: System..::.Byte
The alpha component value of the transparent color

See Also

MakeTransparent Class
MakeTransparent Overload


MakeTransparent Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Methods
MakeTransparent Class See Also Send Feedback

The MakeTransparent type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current MakeTransparent. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MakeTransparent Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.Clone Method
MakeTransparent Class See Also Send Feedback
Creates a copy of the current MakeTransparent.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current MakeTransparent.

See Also

MakeTransparent Class


MakeTransparent Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent Properties
MakeTransparent Class See Also Send Feedback

The MakeTransparent type exposes the following members.

Properties

Name | Description
Alpha | Gets or sets the alpha component value of the transparent color
Color | Gets or sets the transparent color
ColorTolerance | Gets or sets the color tolerance for transparency. Color Tolerance represents the tonal range of colors that will be converted to transparent taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be converted to transparent; otherwise, a wider range of tones will be converted.
ScanDirection | Gets or sets the direction of the pixel scanning process.
UseFirstPixel | Gets or sets whether the first pixel color of an image will be used as the transparent color

See Also

MakeTransparent Class


Alpha Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.Alpha Property
MakeTransparent Class See Also Send Feedback
Gets or sets the alpha component value of the transparent color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte Alpha { get; set; }
Visual Basic (Declaration)
Public Property Alpha As Byte
Visual C++
public:
property unsigned char Alpha {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

MakeTransparent Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.Color Property
MakeTransparent Class See Also Send Feedback
Gets or sets the transparent color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

MakeTransparent Class


ColorTolerance Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.ColorTolerance Property
MakeTransparent Class See Also Send Feedback
Gets or sets the color tolerance for transparency. Color Tolerance represents the tonal range of colors that will be converted to transparent taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be converted to transparent; otherwise, a wider range of tones will be converted.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte ColorTolerance { get; set; }
Visual Basic (Declaration)
Public Property ColorTolerance As Byte
Visual C++
public:
property unsigned char ColorTolerance {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

MakeTransparent Class


ScanDirection Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.ScanDirection Property
MakeTransparent Class See Also Send Feedback
Gets or sets the direction of the pixel scanning process.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ScanDirection ScanDirection { get; set; }
Visual Basic (Declaration)
Public Property ScanDirection As ScanDirection
Visual C++
public:
property ScanDirection ScanDirection {
    ScanDirection get ();
    void set (ScanDirection value);
}

See Also

MakeTransparent Class


UseFirstPixel Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MakeTransparent..::.UseFirstPixel Property
MakeTransparent Class See Also Send Feedback
Gets or sets whether the first pixel color of an image will be used as the transparent color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool UseFirstPixel { get; set; }
Visual Basic (Declaration)
Public Property UseFirstPixel As Boolean
Visual C++
public:
property bool UseFirstPixel {
    bool get ();
    void set (bool value);
}

See Also

MakeTransparent Class


MonochromeSettings Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings Class
Members See Also Send Feedback
Defines monochrome settings used for Black/White and WBMP conversion.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class MonochromeSettings
Visual Basic (Declaration)
Public Class MonochromeSettings
Visual C++
public ref class MonochromeSettings

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.MonochromeSettings

See Also

MonochromeSettings Members


MonochromeSettings Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings Members
MonochromeSettings Class Constructors Methods Properties See Also Send Feedback

The MonochromeSettings type exposes the following members.

Constructors

Name | Description
MonochromeSettings | Initializes a new instance of the MonochromeSettings class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DitherMethod | Gets or sets the dithering method to be used for monochrome conversion.
ReverseEffect | Gets or sets whether monochrome effect should be reversed.
Threshold | Gets or sets the threshold percentage. Values range from 0 to 100.

See Also

MonochromeSettings Class


MonochromeSettings Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings Constructor
MonochromeSettings Class See Also Send Feedback
Initializes a new instance of the MonochromeSettings class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MonochromeSettings()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MonochromeSettings()

See Also

MonochromeSettings Class


MonochromeSettings Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings Methods
MonochromeSettings Class See Also Send Feedback

The MonochromeSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MonochromeSettings Class


MonochromeSettings Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings Properties
MonochromeSettings Class See Also Send Feedback

The MonochromeSettings type exposes the following members.

Properties

Name | Description
DitherMethod | Gets or sets the dithering method to be used for monochrome conversion.
ReverseEffect | Gets or sets whether monochrome effect should be reversed.
Threshold | Gets or sets the threshold percentage. Values range from 0 to 100.

See Also

MonochromeSettings Class


DitherMethod Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings..::.DitherMethod Property
MonochromeSettings Class See Also Send Feedback
Gets or sets the dithering method to be used for monochrome conversion.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DitherMethod DitherMethod { get; set; }
Visual Basic (Declaration)
Public Property DitherMethod As DitherMethod
Visual C++
public:
property DitherMethod DitherMethod {
    DitherMethod get ();
    void set (DitherMethod value);
}

See Also

MonochromeSettings Class


ReverseEffect Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings..::.ReverseEffect Property
MonochromeSettings Class See Also Send Feedback
Gets or sets whether monochrome effect should be reversed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic (Declaration)
Public Property ReverseEffect As Boolean
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

See Also

MonochromeSettings Class


Threshold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MonochromeSettings..::.Threshold Property
MonochromeSettings Class See Also Send Feedback
Gets or sets the threshold percentage. Values range from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Threshold { get; set; }
Visual Basic (Declaration)
Public Property Threshold As Integer
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

See Also

MonochromeSettings Class


MuseumMatteFrame Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame Class
Members See Also Send Feedback
Defines an action that adds shadowed matte frame to an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class MuseumMatteFrame : Action
Visual Basic (Declaration)
Public NotInheritable Class MuseumMatteFrame _
    Inherits Action
Visual C++
public ref class MuseumMatteFrame sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.MuseumMatteFrame

See Also

MuseumMatteFrame Members


MuseumMatteFrame Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame Members
MuseumMatteFrame Class Constructors Methods Properties See Also Send Feedback

The MuseumMatteFrame type exposes the following members.

Constructors

Name | Description
MuseumMatteFrame | Initializes a new instance of the MuseumMatteFrame class.

Methods

Name | Description
Clone | Creates a copy of the current MuseumMatteFrame. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerBorderFill | Gets the inside border's fill style.
InnerBorderShadowColor | Gets or sets the shadow color for the inside border.
InnerBorderWidth | Gets or sets the inside border width.
OuterBorderFill | Gets the outside border's fill style.
OuterBorderShadowColor | Gets or sets the shadow color for the outside border.
OuterBorderWidth | Gets or sets the outside border width.

See Also

MuseumMatteFrame Class


MuseumMatteFrame Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame Constructor
MuseumMatteFrame Class See Also Send Feedback
Initializes a new instance of the MuseumMatteFrame class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public MuseumMatteFrame()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MuseumMatteFrame()

See Also

MuseumMatteFrame Class


MuseumMatteFrame Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame Methods
MuseumMatteFrame Class See Also Send Feedback

The MuseumMatteFrame type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current MuseumMatteFrame. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MuseumMatteFrame Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.Clone Method
MuseumMatteFrame Class See Also Send Feedback
Creates a copy of the current MuseumMatteFrame.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current MuseumMatteFrame.

See Also

MuseumMatteFrame Class


MuseumMatteFrame Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame Properties
MuseumMatteFrame Class See Also Send Feedback

The MuseumMatteFrame type exposes the following members.

Properties

Name | Description
InnerBorderFill | Gets the inside border's fill style.
InnerBorderShadowColor | Gets or sets the shadow color for the inside border.
InnerBorderWidth | Gets or sets the inside border width.
OuterBorderFill | Gets the outside border's fill style.
OuterBorderShadowColor | Gets or sets the shadow color for the outside border.
OuterBorderWidth | Gets or sets the outside border width.

See Also

MuseumMatteFrame Class


InnerBorderFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.InnerBorderFill Property
MuseumMatteFrame Class See Also Send Feedback
Gets the inside border's fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill InnerBorderFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property InnerBorderFill As Fill
Visual C++
public:
property Fill^ InnerBorderFill {
    Fill^ get ();
}

See Also

MuseumMatteFrame Class


InnerBorderShadowColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.InnerBorderShadowColor Property
MuseumMatteFrame Class See Also Send Feedback
Gets or sets the shadow color for the inside border.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color InnerBorderShadowColor { get; set; }
Visual Basic (Declaration)
Public Property InnerBorderShadowColor As Color
Visual C++
public:
property Color InnerBorderShadowColor {
    Color get ();
    void set (Color value);
}

See Also

MuseumMatteFrame Class


InnerBorderWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.InnerBorderWidth Property
MuseumMatteFrame Class See Also Send Feedback
Gets or sets the inside border width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int InnerBorderWidth { get; set; }
Visual Basic (Declaration)
Public Property InnerBorderWidth As Integer
Visual C++
public:
property int InnerBorderWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 1.

See Also

MuseumMatteFrame Class


OuterBorderFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.OuterBorderFill Property
MuseumMatteFrame Class See Also Send Feedback
Gets the outside border's fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill OuterBorderFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property OuterBorderFill As Fill
Visual C++
public:
property Fill^ OuterBorderFill {
    Fill^ get ();
}

See Also

MuseumMatteFrame Class


OuterBorderShadowColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.OuterBorderShadowColor Property
MuseumMatteFrame Class See Also Send Feedback
Gets or sets the shadow color for the outside border.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color OuterBorderShadowColor { get; set; }
Visual Basic (Declaration)
Public Property OuterBorderShadowColor As Color
Visual C++
public:
property Color OuterBorderShadowColor {
    Color get ();
    void set (Color value);
}

See Also

MuseumMatteFrame Class


OuterBorderWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
MuseumMatteFrame..::.OuterBorderWidth Property
MuseumMatteFrame Class See Also Send Feedback
Gets or sets the outside border width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int OuterBorderWidth { get; set; }
Visual Basic (Declaration)
Public Property OuterBorderWidth As Integer
Visual C++
public:
property int OuterBorderWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 1.

See Also

MuseumMatteFrame Class


OvalShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement Class
Members See Also Send Feedback
Represents an oval shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class OvalShapeElement : RectangleShapeElement
Visual Basic (Declaration)
Public Class OvalShapeElement _
    Inherits RectangleShapeElement
Visual C++
public ref class OvalShapeElement : public RectangleShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.RectangleShapeElement
Neodynamic.SDK.ImageDraw..::.OvalShapeElement

See Also

OvalShapeElement Members


OvalShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement Members
OvalShapeElement Class Constructors Methods Properties See Also Send Feedback

The OvalShapeElement type exposes the following members.

Constructors

Name | Description
OvalShapeElement | Initializes a new instance of the OvalShapeElement class

Methods

Name | Description
Clone | Creates a copy of the current OvalShapeElement. (Overrides RectangleShapeElement..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Corners | Gets or sets what corners should be rounded. (Inherited from RectangleShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

OvalShapeElement Class


OvalShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement Constructor
OvalShapeElement Class See Also Send Feedback
Initializes a new instance of the OvalShapeElement class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public OvalShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
OvalShapeElement()

See Also

OvalShapeElement Class


OvalShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement Methods
OvalShapeElement Class See Also Send Feedback

The OvalShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current OvalShapeElement. (Overrides RectangleShapeElement..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

OvalShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement..::.Clone Method
OvalShapeElement Class See Also Send Feedback
Creates a copy of the current OvalShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current OvalShapeElement.

See Also

OvalShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement..::.GetOutputImage Method
OvalShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

OvalShapeElement Class
OvalShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement..::.GetOutputImageBinary Method
OvalShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

OvalShapeElement Class
OvalShapeElement Members


OvalShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
OvalShapeElement Properties
OvalShapeElement Class See Also Send Feedback

The OvalShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Corners | Gets or sets what corners should be rounded. (Inherited from RectangleShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

OvalShapeElement Class


Padding Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Class
Members See Also Send Feedback
Represents padding information

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Padding
Visual Basic (Declaration)
Public Class Padding
Visual C++
public ref class Padding

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Padding

See Also

Padding Members


Padding Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Members
Padding Class Constructors Methods Properties See Also Send Feedback

The Padding type exposes the following members.

Constructors

Name | Description
Padding | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
Bottom | Gets or sets the padding value for the bottom edge.
Left | Gets or sets the padding value for the left edge.
Right | Gets or sets the padding value for the right edge.
Top | Gets or sets the padding value for the top edge.

See Also

Padding Class


Padding Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Constructor
Padding Class See Also Send Feedback

Overload List

Name | Description
Padding()()() | Initializes a new instance of the Padding class.
Padding(Int32) | Initializes a new instance of the Padding class using the supplied padding size for all edges.
Padding(Int32, Int32, Int32, Int32) | Initializes a new instance of the Padding class using a separate padding size for each edge.

See Also

Padding Class
Padding Members


Padding Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Constructor
Padding Class See Also Send Feedback
Initializes a new instance of the Padding class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Padding()

See Also

Padding Class
Padding Overload


Padding Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Constructor (Int32)
Padding Class See Also Send Feedback
Initializes a new instance of the Padding class using the supplied padding size for all edges.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding(
    int all
)
Visual Basic (Declaration)
Public Sub New ( _
    all As Integer _
)
Visual C++
public:
Padding(
    int all
)

Parameters

all
Type: System..::.Int32
The number of pixels to be used for padding for all edges.

See Also

Padding Class
Padding Overload


Padding Constructor (Int32, Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Constructor (Int32, Int32, Int32, Int32)
Padding Class See Also Send Feedback
Initializes a new instance of the Padding class using a separate padding size for each edge.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding(
    int left,
    int top,
    int right,
    int bottom
)
Visual Basic (Declaration)
Public Sub New ( _
    left As Integer, _
    top As Integer, _
    right As Integer, _
    bottom As Integer _
)
Visual C++
public:
Padding(
    int left,
    int top,
    int right,
    int bottom
)

Parameters

left
Type: System..::.Int32
The padding size, in pixels, for the left edge.
top
Type: System..::.Int32
The padding size, in pixels, for the top edge.
right
Type: System..::.Int32
The padding size, in pixels, for the right edge.
bottom
Type: System..::.Int32
The padding size, in pixels, for the bottom edge.

See Also

Padding Class
Padding Overload


Padding Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Methods
Padding Class See Also Send Feedback

The Padding type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

See Also

Padding Class


ToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.ToString Method
Padding Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the Padding object to a string representation, using the current CultureInfo. (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Converts the Padding object to a string representation, using the specified CultureInfo.

See Also

Padding Class
Padding Members


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.ToString Method
Padding Class See Also Send Feedback
Converts the Padding object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the Padding object in the current culture.

See Also

Padding Class
ToString Overload


ToString Method (CultureInfo)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.ToString Method (CultureInfo)
Padding Class See Also Send Feedback
Converts the Padding object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that contains the culture to represent the Padding.

Return Value

The string representation of the Padding object in the specified culture.

See Also

Padding Class
ToString Overload


Padding Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding Properties
Padding Class See Also Send Feedback

The Padding type exposes the following members.

Properties

Name | Description
Bottom | Gets or sets the padding value for the bottom edge.
Left | Gets or sets the padding value for the left edge.
Right | Gets or sets the padding value for the right edge.
Top | Gets or sets the padding value for the top edge.

See Also

Padding Class


Bottom Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.Bottom Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the bottom edge.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Bottom { get; set; }
Visual Basic (Declaration)
Public Property Bottom As Integer
Visual C++
public:
property int Bottom {
    int get ();
    void set (int value);
}

See Also

Padding Class


Left Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.Left Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the left edge.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Integer
Visual C++
public:
property int Left {
    int get ();
    void set (int value);
}

See Also

Padding Class


Right Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.Right Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the right edge.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Right { get; set; }
Visual Basic (Declaration)
Public Property Right As Integer
Visual C++
public:
property int Right {
    int get ();
    void set (int value);
}

See Also

Padding Class


Top Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Padding..::.Top Property
Padding Class See Also Send Feedback
Gets or sets the padding value for the top edge.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Integer
Visual C++
public:
property int Top {
    int get ();
    void set (int value);
}

See Also

Padding Class


PaddingConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter Class
Members See Also Send Feedback
Converts Padding objects from one data type to another. Access the PaddingConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class PaddingConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class PaddingConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class PaddingConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
Neodynamic.SDK.ImageDraw..::.PaddingConverter

See Also

PaddingConverter Members


PaddingConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter Members
PaddingConverter Class Constructors Methods See Also Send Feedback

The PaddingConverter type exposes the following members.

Constructors

Name | Description
PaddingConverter | Initializes a new instance of the PaddingConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaddingConverter Class


PaddingConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter Constructor
PaddingConverter Class See Also Send Feedback
Initializes a new instance of the PaddingConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PaddingConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PaddingConverter()

See Also

PaddingConverter Class


PaddingConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter Methods
PaddingConverter Class See Also Send Feedback

The PaddingConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PaddingConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.CanConvertFrom Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

PaddingConverter Class
PaddingConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
PaddingConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

PaddingConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.CanConvertTo Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

PaddingConverter Class
PaddingConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
PaddingConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

PaddingConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertFrom Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

PaddingConverter Class
PaddingConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
PaddingConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

PaddingConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertFromInvariantString Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertFromString Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertTo Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

PaddingConverter Class
PaddingConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
PaddingConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

PaddingConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertToInvariantString Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.ConvertToString Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.CreateInstance Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetCreateInstanceSupported Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetProperties Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetPropertiesSupported Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetStandardValues Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetStandardValuesExclusive Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.GetStandardValuesSupported Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PaddingConverter..::.IsValid Method
PaddingConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

PaddingConverter Class
PaddingConverter Members


PathShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Class
Members See Also Send Feedback
Represents a path shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class PathShapeElement : ClosedShapeElement
Visual Basic (Declaration)
Public Class PathShapeElement _
    Inherits ClosedShapeElement
Visual C++
public ref class PathShapeElement : public ClosedShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.PathShapeElement

See Also

PathShapeElement Members


PathShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Members
PathShapeElement Class Constructors Methods Properties See Also Send Feedback

The PathShapeElement type exposes the following members.

Constructors

Name | Description
PathShapeElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current PathShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ClosedPath | Gets or sets whether the path must be closed.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
PathPoints | Gets or sets a string containing pairs of point describing the path.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

PathShapeElement Class


PathShapeElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Constructor
PathShapeElement Class See Also Send Feedback

Overload List

Name | Description
PathShapeElement()()() | Initializes a new instance of the PathShapeElement class.
PathShapeElement(String) | Initializes a new instance of the PathShapeElement class with the specified number of pair points.

See Also

PathShapeElement Class
PathShapeElement Members


PathShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Constructor
PathShapeElement Class See Also Send Feedback
Initializes a new instance of the PathShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PathShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PathShapeElement()

See Also

PathShapeElement Class
PathShapeElement Overload


PathShapeElement Constructor (String)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Constructor (String)
PathShapeElement Class See Also Send Feedback
Initializes a new instance of the PathShapeElement class with the specified number of pair points.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PathShapeElement(
    string pathPoints
)
Visual Basic (Declaration)
Public Sub New ( _
    pathPoints As String _
)
Visual C++
public:
PathShapeElement(
    String^ pathPoints
)

Parameters

pathPoints
Type: System..::.String

See Also

PathShapeElement Class
PathShapeElement Overload


PathShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Methods
PathShapeElement Class See Also Send Feedback

The PathShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current PathShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

PathShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement..::.Clone Method
PathShapeElement Class See Also Send Feedback
Creates a copy of the current PathShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current PathShapeElement.

See Also

PathShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement..::.GetOutputImage Method
PathShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

PathShapeElement Class
PathShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement..::.GetOutputImageBinary Method
PathShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

PathShapeElement Class
PathShapeElement Members


PathShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement Properties
PathShapeElement Class See Also Send Feedback

The PathShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ClosedPath | Gets or sets whether the path must be closed.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
PathPoints | Gets or sets a string containing pairs of point describing the path.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

PathShapeElement Class


ClosedPath Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement..::.ClosedPath Property
PathShapeElement Class See Also Send Feedback
Gets or sets whether the path must be closed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ClosedPath { get; set; }
Visual Basic (Declaration)
Public Property ClosedPath As Boolean
Visual C++
public:
property bool ClosedPath {
    bool get ();
    void set (bool value);
}

See Also

PathShapeElement Class


PathPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PathShapeElement..::.PathPoints Property
PathShapeElement Class See Also Send Feedback
Gets or sets a string containing pairs of point describing the path.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string PathPoints { get; set; }
Visual Basic (Declaration)
Public Property PathPoints As String
Visual C++
public:
property String^ PathPoints {
    String^ get ();
    void set (String^ value);
}

See Also

PathShapeElement Class


PerspectiveOrientation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveOrientation Enumeration
See Also Send Feedback
Specifies the prespective view orientation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum PerspectiveOrientation
Visual Basic (Declaration)
Public Enumeration PerspectiveOrientation
Visual C++
public enum class PerspectiveOrientation

Members

Member name | Description
LeftToRight | Specifies the horizontal perspective orientation by setting up the vanishing point at the left of an element.
RightToLeft | Specifies the horizontal perspective orientation by setting up the vanishing point at the right of an element.
TopToBottom | Specifies the vertical perspective orientation by setting up the vanishing point at the top of an element.
BottomToTop | Specifies the vertical perspective orientation by setting up the vanishing point at the bottom of an element.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


PerspectiveReflection Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Class
Members See Also Send Feedback
Defines an action that adds perspective reflection to an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class PerspectiveReflection : Action
Visual Basic (Declaration)
Public NotInheritable Class PerspectiveReflection _
    Inherits Action
Visual C++
public ref class PerspectiveReflection sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.PerspectiveReflection

See Also

PerspectiveReflection Members


PerspectiveReflection Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Members
PerspectiveReflection Class Constructors Methods Properties See Also Send Feedback

The PerspectiveReflection type exposes the following members.

Constructors

Name | Description
PerspectiveReflection | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveReflection. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the direction of the perspective reflection. It is measured counterclockwise from the x-axis.
Length | Gets or sets the length of the perspective reflection
OffsetY | Gets or sets the Y-axis offset value for the perspective reflection.
Opacity | Gets or sets the percentage of transparency in the reflection
WidthPercentage | Gets or sets the width percentage of the perspective reflection based on the element's width

See Also

PerspectiveReflection Class


PerspectiveReflection Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Constructor
PerspectiveReflection Class See Also Send Feedback

Overload List

Name | Description
PerspectiveReflection()()() | Initializes a new instance of the PerspectiveReflection class.
PerspectiveReflection(Int32, Int32, Int32) | Initializes a new instance of the PerspectiveReflection class with reflection settings.

See Also

PerspectiveReflection Class
PerspectiveReflection Members


PerspectiveReflection Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Constructor
PerspectiveReflection Class See Also Send Feedback
Initializes a new instance of the PerspectiveReflection class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveReflection()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PerspectiveReflection()

See Also

PerspectiveReflection Class
PerspectiveReflection Overload


PerspectiveReflection Constructor (Int32, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Constructor (Int32, Int32, Int32)
PerspectiveReflection Class See Also Send Feedback
Initializes a new instance of the PerspectiveReflection class with reflection settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveReflection(
    int length,
    int widthPercentage,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    widthPercentage As Integer, _
    angle As Integer _
)
Visual C++
public:
PerspectiveReflection(
    int length,
    int widthPercentage,
    int angle
)

Parameters

length
Type: System..::.Int32
The length of the perspective reflection
widthPercentage
Type: System..::.Int32
The width percentage of the perspective reflection based on the element's width
angle
Type: System..::.Int32
The direction of the reflection

See Also

PerspectiveReflection Class
PerspectiveReflection Overload


PerspectiveReflection Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Methods
PerspectiveReflection Class See Also Send Feedback

The PerspectiveReflection type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveReflection. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerspectiveReflection Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.Clone Method
PerspectiveReflection Class See Also Send Feedback
Creates a copy of the current PerspectiveReflection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current PerspectiveReflection.

See Also

PerspectiveReflection Class


PerspectiveReflection Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection Properties
PerspectiveReflection Class See Also Send Feedback

The PerspectiveReflection type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the direction of the perspective reflection. It is measured counterclockwise from the x-axis.
Length | Gets or sets the length of the perspective reflection
OffsetY | Gets or sets the Y-axis offset value for the perspective reflection.
Opacity | Gets or sets the percentage of transparency in the reflection
WidthPercentage | Gets or sets the width percentage of the perspective reflection based on the element's width

See Also

PerspectiveReflection Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.Angle Property
PerspectiveReflection Class See Also Send Feedback
Gets or sets the direction of the perspective reflection. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

PerspectiveReflection Class


Length Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.Length Property
PerspectiveReflection Class See Also Send Feedback
Gets or sets the length of the perspective reflection

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

PerspectiveReflection Class


OffsetY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.OffsetY Property
PerspectiveReflection Class See Also Send Feedback
Gets or sets the Y-axis offset value for the perspective reflection.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int OffsetY { get; set; }
Visual Basic (Declaration)
Public Property OffsetY As Integer
Visual C++
public:
property int OffsetY {
    int get ();
    void set (int value);
}

See Also

PerspectiveReflection Class


Opacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.Opacity Property
PerspectiveReflection Class See Also Send Feedback
Gets or sets the percentage of transparency in the reflection

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Integer
Visual C++
public:
property int Opacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

PerspectiveReflection Class


WidthPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveReflection..::.WidthPercentage Property
PerspectiveReflection Class See Also Send Feedback
Gets or sets the width percentage of the perspective reflection based on the element's width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int WidthPercentage { get; set; }
Visual Basic (Declaration)
Public Property WidthPercentage As Integer
Visual C++
public:
property int WidthPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

PerspectiveReflection Class


PerspectiveShadow Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Class
Members See Also Send Feedback
Defines an action that adds perspective shadows to an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class PerspectiveShadow : Action
Visual Basic (Declaration)
Public NotInheritable Class PerspectiveShadow _
    Inherits Action
Visual C++
public ref class PerspectiveShadow sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.PerspectiveShadow

See Also

PerspectiveShadow Members


PerspectiveShadow Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Members
PerspectiveShadow Class Constructors Methods Properties See Also Send Feedback

The PerspectiveShadow type exposes the following members.

Constructors

Name | Description
PerspectiveShadow | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveShadow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the direction of the perspective shadow. It is measured counterclockwise from the x-axis.
Color | Gets or sets the color of the perspective shadow
Length | Gets or sets the length of the perspective shadow
OffsetY | Gets or sets the Y-axis offset value for the perspective shadow.
Opacity | Gets or sets the percentage of transparency in the shadow
Softness | Gets or sets the sharpness of the shadow
WidthPercentage | Gets or sets the width percentage of the perspective shadow based on the element's width

See Also

PerspectiveShadow Class


PerspectiveShadow Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Constructor
PerspectiveShadow Class See Also Send Feedback

Overload List

Name | Description
PerspectiveShadow()()() | Initializes a new instance of the PerspectiveShadow class.
PerspectiveShadow(Int32, Color, Int32, Int32) | Initializes a new instance of the PerspectiveShadow class with shadow settings.

See Also

PerspectiveShadow Class
PerspectiveShadow Members


PerspectiveShadow Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Constructor
PerspectiveShadow Class See Also Send Feedback
Initializes a new instance of the PerspectiveShadow class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveShadow()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PerspectiveShadow()

See Also

PerspectiveShadow Class
PerspectiveShadow Overload


PerspectiveShadow Constructor (Int32, Color, Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Constructor (Int32, Color, Int32, Int32)
PerspectiveShadow Class See Also Send Feedback
Initializes a new instance of the PerspectiveShadow class with shadow settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveShadow(
    int length,
    Color color,
    int widthPercentage,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    length As Integer, _
    color As Color, _
    widthPercentage As Integer, _
    angle As Integer _
)
Visual C++
public:
PerspectiveShadow(
    int length,
    Color color,
    int widthPercentage,
    int angle
)

Parameters

length
Type: System..::.Int32
The length of the perspective shadow
color
Type: System.Drawing..::.Color
The color of the shadow
widthPercentage
Type: System..::.Int32
The width percentage of the perspective shadow based on the element's width
angle
Type: System..::.Int32
The direction of the shadow

See Also

PerspectiveShadow Class
PerspectiveShadow Overload


PerspectiveShadow Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Methods
PerspectiveShadow Class See Also Send Feedback

The PerspectiveShadow type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveShadow. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerspectiveShadow Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Clone Method
PerspectiveShadow Class See Also Send Feedback
Creates a copy of the current PerspectiveShadow.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current PerspectiveShadow.

See Also

PerspectiveShadow Class


PerspectiveShadow Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow Properties
PerspectiveShadow Class See Also Send Feedback

The PerspectiveShadow type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the direction of the perspective shadow. It is measured counterclockwise from the x-axis.
Color | Gets or sets the color of the perspective shadow
Length | Gets or sets the length of the perspective shadow
OffsetY | Gets or sets the Y-axis offset value for the perspective shadow.
Opacity | Gets or sets the percentage of transparency in the shadow
Softness | Gets or sets the sharpness of the shadow
WidthPercentage | Gets or sets the width percentage of the perspective shadow based on the element's width

See Also

PerspectiveShadow Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Angle Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the direction of the perspective shadow. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

PerspectiveShadow Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Color Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the color of the perspective shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

PerspectiveShadow Class


Length Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Length Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the length of the perspective shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Length { get; set; }
Visual Basic (Declaration)
Public Property Length As Integer
Visual C++
public:
property int Length {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

PerspectiveShadow Class


OffsetY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.OffsetY Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the Y-axis offset value for the perspective shadow.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int OffsetY { get; set; }
Visual Basic (Declaration)
Public Property OffsetY As Integer
Visual C++
public:
property int OffsetY {
    int get ();
    void set (int value);
}

See Also

PerspectiveShadow Class


Opacity Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Opacity Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the percentage of transparency in the shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Integer
Visual C++
public:
property int Opacity {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

PerspectiveShadow Class


Softness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.Softness Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the sharpness of the shadow

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Softness { get; set; }
Visual Basic (Declaration)
Public Property Softness As Integer
Visual C++
public:
property int Softness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

PerspectiveShadow Class


WidthPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveShadow..::.WidthPercentage Property
PerspectiveShadow Class See Also Send Feedback
Gets or sets the width percentage of the perspective shadow based on the element's width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int WidthPercentage { get; set; }
Visual Basic (Declaration)
Public Property WidthPercentage As Integer
Visual C++
public:
property int WidthPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

PerspectiveShadow Class


PerspectiveView Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Class
Members See Also Send Feedback
Defines an action that simulates a perspective view of an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class PerspectiveView : Action
Visual Basic (Declaration)
Public Class PerspectiveView _
    Inherits Action
Visual C++
public ref class PerspectiveView : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.PerspectiveView

See Also

PerspectiveView Members


PerspectiveView Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Members
PerspectiveView Class Constructors Methods Properties See Also Send Feedback

The PerspectiveView type exposes the following members.

Constructors

Name | Description
PerspectiveView | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveView. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the perspective view angle.
Orientation | Gets or sets the perspective view orientation.

See Also

PerspectiveView Class


PerspectiveView Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Constructor
PerspectiveView Class See Also Send Feedback

Overload List

Name | Description
PerspectiveView()()() | Initializes a new instance of the PerspectiveView class.
PerspectiveView(PerspectiveOrientation, Int32) | Initializes a new instance of the PerspectiveView class with the specified perspective view orientation and angle.

See Also

PerspectiveView Class
PerspectiveView Members


PerspectiveView Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Constructor
PerspectiveView Class See Also Send Feedback
Initializes a new instance of the PerspectiveView class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveView()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PerspectiveView()

See Also

PerspectiveView Class
PerspectiveView Overload


PerspectiveView Constructor (PerspectiveOrientation, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Constructor (PerspectiveOrientation, Int32)
PerspectiveView Class See Also Send Feedback
Initializes a new instance of the PerspectiveView class with the specified perspective view orientation and angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveView(
    PerspectiveOrientation orientation,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    orientation As PerspectiveOrientation, _
    angle As Integer _
)
Visual C++
public:
PerspectiveView(
    PerspectiveOrientation orientation,
    int angle
)

Parameters

orientation
Type: Neodynamic.SDK.ImageDraw..::.PerspectiveOrientation
The perspective view orientation.
angle
Type: System..::.Int32
The perspective view angle.

See Also

PerspectiveView Class
PerspectiveView Overload


PerspectiveView Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Methods
PerspectiveView Class See Also Send Feedback

The PerspectiveView type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current PerspectiveView. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerspectiveView Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView..::.Clone Method
PerspectiveView Class See Also Send Feedback
Creates a copy of the current PerspectiveView.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current PerspectiveView.

See Also

PerspectiveView Class


PerspectiveView Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView Properties
PerspectiveView Class See Also Send Feedback

The PerspectiveView type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the perspective view angle.
Orientation | Gets or sets the perspective view orientation.

See Also

PerspectiveView Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView..::.Angle Property
PerspectiveView Class See Also Send Feedback
Gets or sets the perspective view angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 90.

See Also

PerspectiveView Class


Orientation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PerspectiveView..::.Orientation Property
PerspectiveView Class See Also Send Feedback
Gets or sets the perspective view orientation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PerspectiveOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As PerspectiveOrientation
Visual C++
public:
property PerspectiveOrientation Orientation {
    PerspectiveOrientation get ();
    void set (PerspectiveOrientation value);
}

See Also

PerspectiveView Class


Pixelate Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Class
Members See Also Send Feedback
Defines an action that pixelates an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Pixelate : Action
Visual Basic (Declaration)
Public Class Pixelate _
    Inherits Action
Visual C++
public ref class Pixelate : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Pixelate

See Also

Pixelate Members


Pixelate Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Members
Pixelate Class Constructors Methods Properties See Also Send Feedback

The Pixelate type exposes the following members.

Constructors

Name | Description
Pixelate | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Pixelate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fade | Gets or sets the fade percentage. Values range from 0 to 100.
PixelSize | Gets or sets the pixel size.

See Also

Pixelate Class


Pixelate Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Constructor
Pixelate Class See Also Send Feedback

Overload List

Name | Description
Pixelate()()() | Initializes a new instance of the Pixelate class.
Pixelate(Int32, Int32) | Initializes a new instance of the Pixelate class with the specified pixel size and fade percentage.

See Also

Pixelate Class
Pixelate Members


Pixelate Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Constructor
Pixelate Class See Also Send Feedback
Initializes a new instance of the Pixelate class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Pixelate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Pixelate()

See Also

Pixelate Class
Pixelate Overload


Pixelate Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Constructor (Int32, Int32)
Pixelate Class See Also Send Feedback
Initializes a new instance of the Pixelate class with the specified pixel size and fade percentage.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Pixelate(
    int pixelSize,
    int fade
)
Visual Basic (Declaration)
Public Sub New ( _
    pixelSize As Integer, _
    fade As Integer _
)
Visual C++
public:
Pixelate(
    int pixelSize,
    int fade
)

Parameters

pixelSize
Type: System..::.Int32
The pixel size.
fade
Type: System..::.Int32
The fade percentage.

See Also

Pixelate Class
Pixelate Overload


Pixelate Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Methods
Pixelate Class See Also Send Feedback

The Pixelate type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Pixelate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Pixelate Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate..::.Clone Method
Pixelate Class See Also Send Feedback
Creates a copy of the current Pixelate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Pixelate.

See Also

Pixelate Class


Pixelate Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate Properties
Pixelate Class See Also Send Feedback

The Pixelate type exposes the following members.

Properties

Name | Description
Fade | Gets or sets the fade percentage. Values range from 0 to 100.
PixelSize | Gets or sets the pixel size.

See Also

Pixelate Class


Fade Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate..::.Fade Property
Pixelate Class See Also Send Feedback
Gets or sets the fade percentage. Values range from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Fade { get; set; }
Visual Basic (Declaration)
Public Property Fade As Integer
Visual C++
public:
property int Fade {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

Pixelate Class


PixelSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Pixelate..::.PixelSize Property
Pixelate Class See Also Send Feedback
Gets or sets the pixel size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int PixelSize { get; set; }
Visual Basic (Declaration)
Public Property PixelSize As Integer
Visual C++
public:
property int PixelSize {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is less than 1.

See Also

Pixelate Class


Polaroid Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Class
Members See Also Send Feedback
Defines an action that creates a polaroid representation of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Polaroid : Action
Visual Basic (Declaration)
Public NotInheritable Class Polaroid _
    Inherits Action
Visual C++
public ref class Polaroid sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Polaroid

See Also

Polaroid Members


Polaroid Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Members
Polaroid Class Constructors Methods Properties See Also Send Feedback

The Polaroid type exposes the following members.

Constructors

Name | Description
Polaroid | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Polaroid. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets the polaroid background
BorderColor | Gets or sets the polaroid border color
BorderWidth | Gets or sets the width of the polaroid border
Corners | Gets or sets what polaroid corners will be rounded.
Font | Gets the font of the text
ForeColor | Gets or sets the color of the text
Height | Gets or sets the polaroid height
ImageBorderColor | Gets or sets the border color around the image
ImageBorderWidth | Gets or sets the width of the border around the image
ImageCorners | Gets or sets what image corners will be rounded.
ImagePadding | Gets the amount of space to insert between the image and its margin in the polaroid.
Roundness | Gets or sets the corner roundness
Text | Gets or sets the polaroid text or caption
TextAlignment | Gets or sets the alignment of the text
TextQuality | Gets or sets the quality of the text
Width | Gets or sets the polaroid width

See Also

Polaroid Class


Polaroid Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Constructor
Polaroid Class See Also Send Feedback

Overload List

Name | Description
Polaroid()()() | Initializes a new instance of the Polaroid class.
Polaroid(Int32, Int32, Padding, Color, Fill, Color, Int32, Font, Color, String, TextRenderingHint, StringAlignment) | Initializes a new instance of the Polaroid class with polaroid settings.

See Also

Polaroid Class
Polaroid Members


Polaroid Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Constructor
Polaroid Class See Also Send Feedback
Initializes a new instance of the Polaroid class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Polaroid()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Polaroid()

See Also

Polaroid Class
Polaroid Overload


Polaroid Constructor (Int32, Int32, Padding, Color, Fill, Color, Int32, Font, Color, String, TextRenderingHint, StringAlignment)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Constructor (Int32, Int32, Padding, Color, Fill, Color, Int32, Font, Color, String, TextRenderingHint, StringAlignment)
Polaroid Class See Also Send Feedback
Initializes a new instance of the Polaroid class with polaroid settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Polaroid(
    int width,
    int height,
    Padding imagePadding,
    Color imageBorderColor,
    Fill background,
    Color borderColor,
    int roundness,
    Font font,
    Color foreColor,
    string text,
    TextRenderingHint textQuality,
    StringAlignment textAlignment
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer, _
    imagePadding As Padding, _
    imageBorderColor As Color, _
    background As Fill, _
    borderColor As Color, _
    roundness As Integer, _
    font As Font, _
    foreColor As Color, _
    text As String, _
    textQuality As TextRenderingHint, _
    textAlignment As StringAlignment _
)
Visual C++
public:
Polaroid(
    int width,
    int height,
    Padding^ imagePadding,
    Color imageBorderColor,
    Fill^ background,
    Color borderColor,
    int roundness,
    Font^ font,
    Color foreColor,
    String^ text,
    TextRenderingHint textQuality,
    StringAlignment textAlignment
)

Parameters

width
Type: System..::.Int32
The polaroid width
height
Type: System..::.Int32
The polaroid height
imagePadding
Type: Neodynamic.SDK.ImageDraw..::.Padding
The amount of space to insert between the image and its margin in the polaroid
imageBorderColor
Type: System.Drawing..::.Color
The border color around the image
background
Type: Neodynamic.SDK.ImageDraw..::.Fill
The polaroid background
borderColor
Type: System.Drawing..::.Color
The polaroid border color
roundness
Type: System..::.Int32
The corner roundness
font
Type: Neodynamic.SDK.ImageDraw..::.Font
The font of the text
foreColor
Type: System.Drawing..::.Color
The color of the text
text
Type: System..::.String
The polaroid text or caption
textQuality
Type: System.Drawing.Text..::.TextRenderingHint
The quality of the text
textAlignment
Type: System.Drawing..::.StringAlignment
The alignment of the text

See Also

Polaroid Class
Polaroid Overload


Polaroid Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Methods
Polaroid Class See Also Send Feedback

The Polaroid type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Polaroid. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Polaroid Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Clone Method
Polaroid Class See Also Send Feedback
Creates a copy of the current Polaroid.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Polaroid.

See Also

Polaroid Class


Polaroid Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid Properties
Polaroid Class See Also Send Feedback

The Polaroid type exposes the following members.

Properties

Name | Description
Background | Gets the polaroid background
BorderColor | Gets or sets the polaroid border color
BorderWidth | Gets or sets the width of the polaroid border
Corners | Gets or sets what polaroid corners will be rounded.
Font | Gets the font of the text
ForeColor | Gets or sets the color of the text
Height | Gets or sets the polaroid height
ImageBorderColor | Gets or sets the border color around the image
ImageBorderWidth | Gets or sets the width of the border around the image
ImageCorners | Gets or sets what image corners will be rounded.
ImagePadding | Gets the amount of space to insert between the image and its margin in the polaroid.
Roundness | Gets or sets the corner roundness
Text | Gets or sets the polaroid text or caption
TextAlignment | Gets or sets the alignment of the text
TextQuality | Gets or sets the quality of the text
Width | Gets or sets the polaroid width

See Also

Polaroid Class


Background Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Background Property
Polaroid Class See Also Send Feedback
Gets the polaroid background

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Fill
Visual C++
public:
property Fill^ Background {
    Fill^ get ();
}

See Also

Polaroid Class


BorderColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.BorderColor Property
Polaroid Class See Also Send Feedback
Gets or sets the polaroid border color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic (Declaration)
Public Property BorderColor As Color
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

Polaroid Class


BorderWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.BorderWidth Property
Polaroid Class See Also Send Feedback
Gets or sets the width of the polaroid border

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int BorderWidth { get; set; }
Visual Basic (Declaration)
Public Property BorderWidth As Integer
Visual C++
public:
property int BorderWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Polaroid Class


Corners Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Corners Property
Polaroid Class See Also Send Feedback
Gets or sets what polaroid corners will be rounded.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners
Visual C++
public:
property Corners Corners {
    Corners get ();
    void set (Corners value);
}

See Also

Polaroid Class


Font Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Font Property
Polaroid Class See Also Send Feedback
Gets the font of the text

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

See Also

Polaroid Class


ForeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.ForeColor Property
Polaroid Class See Also Send Feedback
Gets or sets the color of the text

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

Polaroid Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Height Property
Polaroid Class See Also Send Feedback
Gets or sets the polaroid height

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Polaroid Class


ImageBorderColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.ImageBorderColor Property
Polaroid Class See Also Send Feedback
Gets or sets the border color around the image

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ImageBorderColor { get; set; }
Visual Basic (Declaration)
Public Property ImageBorderColor As Color
Visual C++
public:
property Color ImageBorderColor {
    Color get ();
    void set (Color value);
}

See Also

Polaroid Class


ImageBorderWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.ImageBorderWidth Property
Polaroid Class See Also Send Feedback
Gets or sets the width of the border around the image

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ImageBorderWidth { get; set; }
Visual Basic (Declaration)
Public Property ImageBorderWidth As Integer
Visual C++
public:
property int ImageBorderWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Polaroid Class


ImageCorners Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.ImageCorners Property
Polaroid Class See Also Send Feedback
Gets or sets what image corners will be rounded.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Corners ImageCorners { get; set; }
Visual Basic (Declaration)
Public Property ImageCorners As Corners
Visual C++
public:
property Corners ImageCorners {
    Corners get ();
    void set (Corners value);
}

See Also

Polaroid Class


ImagePadding Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.ImagePadding Property
Polaroid Class See Also Send Feedback
Gets the amount of space to insert between the image and its margin in the polaroid.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding ImagePadding { get; }
Visual Basic (Declaration)
Public ReadOnly Property ImagePadding As Padding
Visual C++
public:
property Padding^ ImagePadding {
    Padding^ get ();
}

See Also

Polaroid Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Roundness Property
Polaroid Class See Also Send Feedback
Gets or sets the corner roundness

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Polaroid Class


Text Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Text Property
Polaroid Class See Also Send Feedback
Gets or sets the polaroid text or caption

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Polaroid Class


TextAlignment Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.TextAlignment Property
Polaroid Class See Also Send Feedback
Gets or sets the alignment of the text

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public StringAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As StringAlignment
Visual C++
public:
property StringAlignment TextAlignment {
    StringAlignment get ();
    void set (StringAlignment value);
}

See Also

Polaroid Class


TextQuality Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.TextQuality Property
Polaroid Class See Also Send Feedback
Gets or sets the quality of the text

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextRenderingHint TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextRenderingHint
Visual C++
public:
property TextRenderingHint TextQuality {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}

See Also

Polaroid Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Polaroid..::.Width Property
Polaroid Class See Also Send Feedback
Gets or sets the polaroid width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Polaroid Class


PolygonShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Class
Members See Also Send Feedback
Represents a polygon shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class PolygonShapeElement : ClosedShapeElement
Visual Basic (Declaration)
Public Class PolygonShapeElement _
    Inherits ClosedShapeElement
Visual C++
public ref class PolygonShapeElement : public ClosedShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.PolygonShapeElement

See Also

PolygonShapeElement Members


PolygonShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Members
PolygonShapeElement Class Constructors Methods Properties See Also Send Feedback

The PolygonShapeElement type exposes the following members.

Constructors

Name | Description
PolygonShapeElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current PolygonShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
Sides | Gets or sets the number of sides of the polygon shape.
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

PolygonShapeElement Class


PolygonShapeElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Constructor
PolygonShapeElement Class See Also Send Feedback

Overload List

Name | Description
PolygonShapeElement()()() | Initializes a new instance of the PolygonShapeElement class.
PolygonShapeElement(Int32) | Initializes a new instance of the PolygonShapeElement class with the specified number of sides.

See Also

PolygonShapeElement Class
PolygonShapeElement Members


PolygonShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Constructor
PolygonShapeElement Class See Also Send Feedback
Initializes a new instance of the PolygonShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PolygonShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PolygonShapeElement()

See Also

PolygonShapeElement Class
PolygonShapeElement Overload


PolygonShapeElement Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Constructor (Int32)
PolygonShapeElement Class See Also Send Feedback
Initializes a new instance of the PolygonShapeElement class with the specified number of sides.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public PolygonShapeElement(
    int sides
)
Visual Basic (Declaration)
Public Sub New ( _
    sides As Integer _
)
Visual C++
public:
PolygonShapeElement(
    int sides
)

Parameters

sides
Type: System..::.Int32
The number of sides of the polygon shape.

See Also

PolygonShapeElement Class
PolygonShapeElement Overload


PolygonShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Methods
PolygonShapeElement Class See Also Send Feedback

The PolygonShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current PolygonShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

PolygonShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement..::.Clone Method
PolygonShapeElement Class See Also Send Feedback
Creates a copy of the current PolygonShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current PolygonShapeElement.

See Also

PolygonShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement..::.GetOutputImage Method
PolygonShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

PolygonShapeElement Class
PolygonShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement..::.GetOutputImageBinary Method
PolygonShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

PolygonShapeElement Class
PolygonShapeElement Members


PolygonShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement Properties
PolygonShapeElement Class See Also Send Feedback

The PolygonShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
Sides | Gets or sets the number of sides of the polygon shape.
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

PolygonShapeElement Class


Sides Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
PolygonShapeElement..::.Sides Property
PolygonShapeElement Class See Also Send Feedback
Gets or sets the number of sides of the polygon shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Sides { get; set; }
Visual Basic (Declaration)
Public Property Sides As Integer
Visual C++
public:
property int Sides {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

PolygonShapeElement Class


QuadrilateralPoints Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints Class
Members See Also Send Feedback
Represents the four points of a quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class QuadrilateralPoints
Visual Basic (Declaration)
Public Class QuadrilateralPoints
Visual C++
public ref class QuadrilateralPoints

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.QuadrilateralPoints

See Also

QuadrilateralPoints Members


QuadrilateralPoints Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints Members
QuadrilateralPoints Class Constructors Methods Properties See Also Send Feedback

The QuadrilateralPoints type exposes the following members.

Constructors

Name | Description
QuadrilateralPoints | Initializes a new instance of the QuadrilateralPoints class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
LowerLeftX | Gets or sets the x-coordinate of the lower-left corner of this quadrilateral shape.
LowerLeftY | Gets or sets the y-coordinate of the lower-left corner of this quadrilateral shape.
LowerRightX | Gets or sets the x-coordinate of the lower-right corner of this quadrilateral shape.
LowerRightY | Gets or sets the y-coordinate of the lower-right corner of this quadrilateral shape.
UpperLeftX | Gets or sets the x-coordinate of the upper-left corner of this quadrilateral shape.
UpperLeftY | Gets or sets the y-coordinate of the upper-left corner of this quadrilateral shape.
UpperRightX | Gets or sets the x-coordinate of the upper-right corner of this quadrilateral shape.
UpperRightY | Gets or sets the y-coordinate of the upper-right corner of this quadrilateral shape.

See Also

QuadrilateralPoints Class


QuadrilateralPoints Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints Constructor
QuadrilateralPoints Class See Also Send Feedback
Initializes a new instance of the QuadrilateralPoints class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public QuadrilateralPoints()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
QuadrilateralPoints()

See Also

QuadrilateralPoints Class


QuadrilateralPoints Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints Methods
QuadrilateralPoints Class See Also Send Feedback

The QuadrilateralPoints type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

QuadrilateralPoints Class


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.ToString Method
QuadrilateralPoints Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

QuadrilateralPoints Class


QuadrilateralPoints Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints Properties
QuadrilateralPoints Class See Also Send Feedback

The QuadrilateralPoints type exposes the following members.

Properties

Name | Description
LowerLeftX | Gets or sets the x-coordinate of the lower-left corner of this quadrilateral shape.
LowerLeftY | Gets or sets the y-coordinate of the lower-left corner of this quadrilateral shape.
LowerRightX | Gets or sets the x-coordinate of the lower-right corner of this quadrilateral shape.
LowerRightY | Gets or sets the y-coordinate of the lower-right corner of this quadrilateral shape.
UpperLeftX | Gets or sets the x-coordinate of the upper-left corner of this quadrilateral shape.
UpperLeftY | Gets or sets the y-coordinate of the upper-left corner of this quadrilateral shape.
UpperRightX | Gets or sets the x-coordinate of the upper-right corner of this quadrilateral shape.
UpperRightY | Gets or sets the y-coordinate of the upper-right corner of this quadrilateral shape.

See Also

QuadrilateralPoints Class


LowerLeftX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.LowerLeftX Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the x-coordinate of the lower-left corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LowerLeftX { get; set; }
Visual Basic (Declaration)
Public Property LowerLeftX As Integer
Visual C++
public:
property int LowerLeftX {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


LowerLeftY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.LowerLeftY Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the y-coordinate of the lower-left corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LowerLeftY { get; set; }
Visual Basic (Declaration)
Public Property LowerLeftY As Integer
Visual C++
public:
property int LowerLeftY {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


LowerRightX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.LowerRightX Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the x-coordinate of the lower-right corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LowerRightX { get; set; }
Visual Basic (Declaration)
Public Property LowerRightX As Integer
Visual C++
public:
property int LowerRightX {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


LowerRightY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.LowerRightY Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the y-coordinate of the lower-right corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LowerRightY { get; set; }
Visual Basic (Declaration)
Public Property LowerRightY As Integer
Visual C++
public:
property int LowerRightY {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


UpperLeftX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.UpperLeftX Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the x-coordinate of the upper-left corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int UpperLeftX { get; set; }
Visual Basic (Declaration)
Public Property UpperLeftX As Integer
Visual C++
public:
property int UpperLeftX {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


UpperLeftY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.UpperLeftY Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the y-coordinate of the upper-left corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int UpperLeftY { get; set; }
Visual Basic (Declaration)
Public Property UpperLeftY As Integer
Visual C++
public:
property int UpperLeftY {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


UpperRightX Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.UpperRightX Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the x-coordinate of the upper-right corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int UpperRightX { get; set; }
Visual Basic (Declaration)
Public Property UpperRightX As Integer
Visual C++
public:
property int UpperRightX {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


UpperRightY Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
QuadrilateralPoints..::.UpperRightY Property
QuadrilateralPoints Class See Also Send Feedback
Gets or sets the y-coordinate of the upper-right corner of this quadrilateral shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int UpperRightY { get; set; }
Visual Basic (Declaration)
Public Property UpperRightY As Integer
Visual C++
public:
property int UpperRightY {
    int get ();
    void set (int value);
}

See Also

QuadrilateralPoints Class


RectangleShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Class
Members See Also Send Feedback
Represents a rectangle shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class RectangleShapeElement : ClosedShapeElement
Visual Basic (Declaration)
Public Class RectangleShapeElement _
    Inherits ClosedShapeElement
Visual C++
public ref class RectangleShapeElement : public ClosedShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.RectangleShapeElement
Neodynamic.SDK.ImageDraw..::.OvalShapeElement

See Also

RectangleShapeElement Members


RectangleShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Members
RectangleShapeElement Class Constructors Methods Properties See Also Send Feedback

The RectangleShapeElement type exposes the following members.

Constructors

Name | Description
RectangleShapeElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current RectangleShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Corners | Gets or sets what corners should be rounded.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

RectangleShapeElement Class


RectangleShapeElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Constructor
RectangleShapeElement Class See Also Send Feedback

Overload List

Name | Description
RectangleShapeElement()()() | Initializes a new instance of the RectangleShapeElement class.
RectangleShapeElement(Int32, Int32) | Initializes a new instance of the RectangleShapeElement class with the specified size.

See Also

RectangleShapeElement Class
RectangleShapeElement Members


RectangleShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Constructor
RectangleShapeElement Class See Also Send Feedback
Initializes a new instance of the RectangleShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RectangleShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RectangleShapeElement()

See Also

RectangleShapeElement Class
RectangleShapeElement Overload


RectangleShapeElement Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Constructor (Int32, Int32)
RectangleShapeElement Class See Also Send Feedback
Initializes a new instance of the RectangleShapeElement class with the specified size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RectangleShapeElement(
    int width,
    int height
)
Visual Basic (Declaration)
Public Sub New ( _
    width As Integer, _
    height As Integer _
)
Visual C++
public:
RectangleShapeElement(
    int width,
    int height
)

Parameters

width
Type: System..::.Int32
The width of the rectangle shape.
height
Type: System..::.Int32
The height of the rectangle shape.

See Also

RectangleShapeElement Class
RectangleShapeElement Overload


RectangleShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Methods
RectangleShapeElement Class See Also Send Feedback

The RectangleShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RectangleShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

RectangleShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement..::.Clone Method
RectangleShapeElement Class See Also Send Feedback
Creates a copy of the current RectangleShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current RectangleShapeElement.

See Also

RectangleShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement..::.GetOutputImage Method
RectangleShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

RectangleShapeElement Class
RectangleShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement..::.GetOutputImageBinary Method
RectangleShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

RectangleShapeElement Class
RectangleShapeElement Members


RectangleShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement Properties
RectangleShapeElement Class See Also Send Feedback

The RectangleShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Corners | Gets or sets what corners should be rounded.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

RectangleShapeElement Class


Corners Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RectangleShapeElement..::.Corners Property
RectangleShapeElement Class See Also Send Feedback
Gets or sets what corners should be rounded.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners
Visual C++
public:
property Corners Corners {
    Corners get ();
    void set (Corners value);
}

See Also

RectangleShapeElement Class


RedEyeArea Structure

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Structure
Members See Also Send Feedback
Stores information of a rectangular area for applying red-eye removal. Information includes the location and size of the red-eye rectangular area as well as a threshold.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public struct RedEyeArea
Visual Basic (Declaration)
Public Structure RedEyeArea
Visual C++
public value class RedEyeArea

See Also

RedEyeArea Members


RedEyeArea Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Members
RedEyeArea Structure Constructors Methods Fields Properties See Also Send Feedback

The RedEyeArea type exposes the following members.

Constructors

Name | Description
RedEyeArea | Initializes a new instance of the RedEyeArea class with the specified location, size and threshold.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides ValueType..::.ToString()()().)

Fields

Name | Description
Empty | Represents a RedEyeArea structure with its properties left uninitialized.

Properties

Name | Description
Height | Gets or sets the height of this RedEyeArea structure.
Threshold | Gets or sets the threshold for detecting red pixels in this RedEyeArea structure.
Width | Gets or sets the width of this RedEyeArea structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RedEyeArea structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RedEyeArea structure.

See Also

RedEyeArea Structure


RedEyeArea Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Constructor
RedEyeArea Structure See Also Send Feedback
Initializes a new instance of the RedEyeArea class with the specified location, size and threshold.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RedEyeArea(
    int x,
    int y,
    int width,
    int height,
    int threshold
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Integer, _
    y As Integer, _
    width As Integer, _
    height As Integer, _
    threshold As Integer _
)
Visual C++
public:
RedEyeArea(
    int x,
    int y,
    int width,
    int height,
    int threshold
)

Parameters

x
Type: System..::.Int32
The x-coordinate of the upper-left corner of the red-eye rectangular area.
y
Type: System..::.Int32
The y-coordinate of the upper-left corner of the red-eye rectangular area.
width
Type: System..::.Int32
The width of the red-eye rectangular area.
height
Type: System..::.Int32
The height of the red-eye rectangular area.
threshold
Type: System..::.Int32
The threshold for detecting red pixels in the red-eye rectangular area.

See Also

RedEyeArea Structure


RedEyeArea Fields

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Fields
RedEyeArea Structure See Also Send Feedback

The RedEyeArea type exposes the following members.

Fields

Name | Description
Empty | Represents a RedEyeArea structure with its properties left uninitialized.

See Also

RedEyeArea Structure


Empty Field

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.Empty Field
RedEyeArea Structure See Also Send Feedback
Represents a RedEyeArea structure with its properties left uninitialized.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public static readonly RedEyeArea Empty
Visual Basic (Declaration)
Public Shared ReadOnly Empty As RedEyeArea
Visual C++
public:
static initonly RedEyeArea Empty

See Also

RedEyeArea Structure


RedEyeArea Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Methods
RedEyeArea Structure See Also Send Feedback

The RedEyeArea type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides ValueType..::.ToString()()().)

See Also

RedEyeArea Structure


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.ToString Method
RedEyeArea Structure See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

RedEyeArea Structure


RedEyeArea Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea Properties
RedEyeArea Structure See Also Send Feedback

The RedEyeArea type exposes the following members.

Properties

Name | Description
Height | Gets or sets the height of this RedEyeArea structure.
Threshold | Gets or sets the threshold for detecting red pixels in this RedEyeArea structure.
Width | Gets or sets the width of this RedEyeArea structure.
X | Gets or sets the x-coordinate of the upper-left corner of this RedEyeArea structure.
Y | Gets or sets the y-coordinate of the upper-left corner of this RedEyeArea structure.

See Also

RedEyeArea Structure


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.Height Property
RedEyeArea Structure See Also Send Feedback
Gets or sets the height of this RedEyeArea structure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

See Also

RedEyeArea Structure


Threshold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.Threshold Property
RedEyeArea Structure See Also Send Feedback
Gets or sets the threshold for detecting red pixels in this RedEyeArea structure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Threshold { get; set; }
Visual Basic (Declaration)
Public Property Threshold As Integer
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

RedEyeArea Structure


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.Width Property
RedEyeArea Structure See Also Send Feedback
Gets or sets the width of this RedEyeArea structure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

See Also

RedEyeArea Structure


X Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.X Property
RedEyeArea Structure See Also Send Feedback
Gets or sets the x-coordinate of the upper-left corner of this RedEyeArea structure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int X { get; set; }
Visual Basic (Declaration)
Public Property X As Integer
Visual C++
public:
property int X {
    int get ();
    void set (int value);
}

See Also

RedEyeArea Structure


Y Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeArea..::.Y Property
RedEyeArea Structure See Also Send Feedback
Gets or sets the y-coordinate of the upper-left corner of this RedEyeArea structure.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Integer
Visual C++
public:
property int Y {
    int get ();
    void set (int value);
}

See Also

RedEyeArea Structure


RedEyeAreasConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter Class
Members See Also Send Feedback
Converts RedEyeArea objects from one data type to another. Access the RedEyeAreasConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class RedEyeAreasConverter : TypeConverter
Visual Basic (Declaration)
Public Class RedEyeAreasConverter _
    Inherits TypeConverter
Visual C++
public ref class RedEyeAreasConverter : public TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
Neodynamic.SDK.ImageDraw..::.RedEyeAreasConverter

See Also

RedEyeAreasConverter Members


RedEyeAreasConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter Members
RedEyeAreasConverter Class Constructors Methods See Also Send Feedback

The RedEyeAreasConverter type exposes the following members.

Constructors

Name | Description
RedEyeAreasConverter | Initializes a new instance of the RedEyeAreasConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RedEyeAreasConverter Class


RedEyeAreasConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter Constructor
RedEyeAreasConverter Class See Also Send Feedback
Initializes a new instance of the RedEyeAreasConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RedEyeAreasConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RedEyeAreasConverter()

See Also

RedEyeAreasConverter Class


RedEyeAreasConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter Methods
RedEyeAreasConverter Class See Also Send Feedback

The RedEyeAreasConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RedEyeAreasConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.CanConvertFrom Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
RedEyeAreasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

RedEyeAreasConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.CanConvertTo Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
RedEyeAreasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

RedEyeAreasConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertFrom Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
RedEyeAreasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

RedEyeAreasConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertFromInvariantString Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertFromString Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertTo Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
RedEyeAreasConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

RedEyeAreasConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertToInvariantString Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.ConvertToString Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.CreateInstance Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetCreateInstanceSupported Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetProperties Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context and attributes. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetPropertiesSupported Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Returns whether this object supports properties, using the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetStandardValues Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetStandardValuesExclusive Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.GetStandardValuesSupported Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeAreasConverter..::.IsValid Method
RedEyeAreasConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

RedEyeAreasConverter Class
RedEyeAreasConverter Members


RedEyeRemoval Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval Class
Members See Also Send Feedback
Defines an action that performs Red-Eye removal from an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class RedEyeRemoval : Action
Visual Basic (Declaration)
Public NotInheritable Class RedEyeRemoval _
    Inherits Action
Visual C++
public ref class RedEyeRemoval sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.RedEyeRemoval

See Also

RedEyeRemoval Members


RedEyeRemoval Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval Members
RedEyeRemoval Class Constructors Methods Properties See Also Send Feedback

The RedEyeRemoval type exposes the following members.

Constructors

Name | Description
RedEyeRemoval | Initializes a new instance of the RedEyeRemoval class

Methods

Name | Description
Clone | Creates a copy of the current RedEyeRemoval. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
RedEyeAreas | Gets or sets the rectangular areas for applying red-eye correction.
Threshold | Gets or sets the threshold for detecting red pixels in all red-eye areas. It takes place if and only if all threshold values in each red-eye area is set up to zero.

See Also

RedEyeRemoval Class


RedEyeRemoval Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval Constructor
RedEyeRemoval Class See Also Send Feedback
Initializes a new instance of the RedEyeRemoval class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RedEyeRemoval()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RedEyeRemoval()

See Also

RedEyeRemoval Class


RedEyeRemoval Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval Methods
RedEyeRemoval Class See Also Send Feedback

The RedEyeRemoval type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RedEyeRemoval. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RedEyeRemoval Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval..::.Clone Method
RedEyeRemoval Class See Also Send Feedback
Creates a copy of the current RedEyeRemoval.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current RedEyeRemoval.

See Also

RedEyeRemoval Class


RedEyeRemoval Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval Properties
RedEyeRemoval Class See Also Send Feedback

The RedEyeRemoval type exposes the following members.

Properties

Name | Description
RedEyeAreas | Gets or sets the rectangular areas for applying red-eye correction.
Threshold | Gets or sets the threshold for detecting red pixels in all red-eye areas. It takes place if and only if all threshold values in each red-eye area is set up to zero.

See Also

RedEyeRemoval Class


RedEyeAreas Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval..::.RedEyeAreas Property
RedEyeRemoval Class See Also Send Feedback
Gets or sets the rectangular areas for applying red-eye correction.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RedEyeArea[] RedEyeAreas { get; set; }
Visual Basic (Declaration)
Public Property RedEyeAreas As RedEyeArea()
Visual C++
public:
property array<RedEyeArea>^ RedEyeAreas {
    array<RedEyeArea>^ get ();
    void set (array<RedEyeArea>^ value);
}

See Also

RedEyeRemoval Class


Threshold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RedEyeRemoval..::.Threshold Property
RedEyeRemoval Class See Also Send Feedback
Gets or sets the threshold for detecting red pixels in all red-eye areas. It takes place if and only if all threshold values in each red-eye area is set up to zero.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Threshold { get; set; }
Visual Basic (Declaration)
Public Property Threshold As Integer
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

RedEyeRemoval Class


ReflectionLocation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ReflectionLocation Enumeration
See Also Send Feedback
Specifies how the reflection of the image will be positioned.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ReflectionLocation
Visual Basic (Declaration)
Public Enumeration ReflectionLocation
Visual C++
public enum class ReflectionLocation

Members

Member name | Description
Auto | The reflection will be positioned just below of the image based on its dimensions.
Custom | The reflection position must be specified by ReflectionLocationX and ReflectionLocationY properties.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


RemovePixel Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Class
Members See Also Send Feedback
Defines an action that removes pixels from an element and automatically resizes it. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class RemovePixel : Action
Visual Basic (Declaration)
Public NotInheritable Class RemovePixel _
    Inherits Action
Visual C++
public ref class RemovePixel sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.RemovePixel

See Also

RemovePixel Members


RemovePixel Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Members
RemovePixel Class Constructors Methods Properties See Also Send Feedback

The RemovePixel type exposes the following members.

Constructors

Name | Description
RemovePixel | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current RemovePixel. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the color to be removed from the target element.
ColorTolerance | Gets or sets the color tolerance for removing pixels. Color Tolerance represents the tonal range of colors that will be removed taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be removed; otherwise, a wider range of tones will be removed.
ScanDirection | Gets or sets the direction of the pixel scanning process.

See Also

RemovePixel Class


RemovePixel Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Constructor
RemovePixel Class See Also Send Feedback

Overload List

Name | Description
RemovePixel()()() | Initializes a new instance of the RemovePixel class removing all white pixels.
RemovePixel(Color) | Initializes a new instance of the RemovePixel class removing the specified color pixels.

See Also

RemovePixel Class
RemovePixel Members


RemovePixel Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Constructor
RemovePixel Class See Also Send Feedback
Initializes a new instance of the RemovePixel class removing all white pixels.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RemovePixel()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RemovePixel()

See Also

RemovePixel Class
RemovePixel Overload


RemovePixel Constructor (Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Constructor (Color)
RemovePixel Class See Also Send Feedback
Initializes a new instance of the RemovePixel class removing the specified color pixels.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RemovePixel(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
RemovePixel(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
The color to be removed from the target element.

See Also

RemovePixel Class
RemovePixel Overload


RemovePixel Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Methods
RemovePixel Class See Also Send Feedback

The RemovePixel type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RemovePixel. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemovePixel Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel..::.Clone Method
RemovePixel Class See Also Send Feedback
Creates a copy of the current RemovePixel.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current RemovePixel.

See Also

RemovePixel Class


RemovePixel Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel Properties
RemovePixel Class See Also Send Feedback

The RemovePixel type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color to be removed from the target element.
ColorTolerance | Gets or sets the color tolerance for removing pixels. Color Tolerance represents the tonal range of colors that will be removed taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be removed; otherwise, a wider range of tones will be removed.
ScanDirection | Gets or sets the direction of the pixel scanning process.

See Also

RemovePixel Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel..::.Color Property
RemovePixel Class See Also Send Feedback
Gets or sets the color to be removed from the target element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

RemovePixel Class


ColorTolerance Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel..::.ColorTolerance Property
RemovePixel Class See Also Send Feedback
Gets or sets the color tolerance for removing pixels. Color Tolerance represents the tonal range of colors that will be removed taking the specified color as starting point. If you enter 0, only adjacent pixels of exactly the same tone as the specified color will be removed; otherwise, a wider range of tones will be removed.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public byte ColorTolerance { get; set; }
Visual Basic (Declaration)
Public Property ColorTolerance As Byte
Visual C++
public:
property unsigned char ColorTolerance {
    unsigned char get ();
    void set (unsigned char value);
}

See Also

RemovePixel Class


ScanDirection Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemovePixel..::.ScanDirection Property
RemovePixel Class See Also Send Feedback
Gets or sets the direction of the pixel scanning process.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ScanDirection ScanDirection { get; set; }
Visual Basic (Declaration)
Public Property ScanDirection As ScanDirection
Visual C++
public:
property ScanDirection ScanDirection {
    ScanDirection get ();
    void set (ScanDirection value);
}

See Also

RemovePixel Class


RemoveTransparency Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemoveTransparency Class
Members See Also Send Feedback
Defines an action that removes transparent pixels from an element and automatically resizes it. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class RemoveTransparency : Action
Visual Basic (Declaration)
Public Class RemoveTransparency _
    Inherits Action
Visual C++
public ref class RemoveTransparency : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.RemoveTransparency

See Also

RemoveTransparency Members


RemoveTransparency Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemoveTransparency Members
RemoveTransparency Class Constructors Methods See Also Send Feedback

The RemoveTransparency type exposes the following members.

Constructors

Name | Description
RemoveTransparency | Initializes a new instance of the RemoveTransparency class.

Methods

Name | Description
Clone | Creates a copy of the current RemoveTransparency. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveTransparency Class


RemoveTransparency Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemoveTransparency Constructor
RemoveTransparency Class See Also Send Feedback
Initializes a new instance of the RemoveTransparency class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RemoveTransparency()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RemoveTransparency()

See Also

RemoveTransparency Class


RemoveTransparency Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemoveTransparency Methods
RemoveTransparency Class See Also Send Feedback

The RemoveTransparency type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RemoveTransparency. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RemoveTransparency Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RemoveTransparency..::.Clone Method
RemoveTransparency Class See Also Send Feedback
Creates a copy of the current RemoveTransparency.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current RemoveTransparency.

See Also

RemoveTransparency Class


Resize Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Class
Members See Also Send Feedback
Defines an action that changes the size of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Resize : Action
Visual Basic (Declaration)
Public NotInheritable Class Resize _
    Inherits Action
Visual C++
public ref class Resize sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Resize

See Also

Resize Members


Resize Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Members
Resize Class Constructors Methods Properties See Also Send Feedback

The Resize type exposes the following members.

Constructors

Name | Description
Resize | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Resize. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the new image height
InterpolationMode | Gets or sets the interpolation mode to use
LockAspectRatio | Gets or sets how element's proportions are maintained
Width | Gets or sets the new image width

See Also

Resize Class


Resize Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Constructor
Resize Class See Also Send Feedback

Overload List

Name | Description
Resize()()() | Initializes a new instance of the Resize class.
Resize(Int32, Int32, LockAspectRatio, InterpolationMode) | Initializes a new instance of the Resize class with Resize settings.

See Also

Resize Class
Resize Members


Resize Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Constructor
Resize Class See Also Send Feedback
Initializes a new instance of the Resize class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Resize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Resize()

See Also

Resize Class
Resize Overload


Resize Constructor (Int32, Int32, LockAspectRatio, InterpolationMode)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Constructor (Int32, Int32, LockAspectRatio, InterpolationMode)
Resize Class See Also Send Feedback
Initializes a new instance of the Resize class with Resize settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Resize(
    int newWidth,
    int newHeight,
    LockAspectRatio lockAspectRatio,
    InterpolationMode interpolationMode
)
Visual Basic (Declaration)
Public Sub New ( _
    newWidth As Integer, _
    newHeight As Integer, _
    lockAspectRatio As LockAspectRatio, _
    interpolationMode As InterpolationMode _
)
Visual C++
public:
Resize(
    int newWidth,
    int newHeight,
    LockAspectRatio lockAspectRatio,
    InterpolationMode interpolationMode
)

Parameters

newWidth
Type: System..::.Int32
The new image width
newHeight
Type: System..::.Int32
The new image height
lockAspectRatio
Type: Neodynamic.SDK.ImageDraw..::.LockAspectRatio
A LockAspectRatio object that specifies how element's proportions are maintained
interpolationMode
Type: System.Drawing.Drawing2D..::.InterpolationMode
The interpolation mode to use

See Also

Resize Class
Resize Overload


Resize Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Methods
Resize Class See Also Send Feedback

The Resize type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Resize. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Resize Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize..::.Clone Method
Resize Class See Also Send Feedback
Creates a copy of the current Resize.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Resize.

See Also

Resize Class


Resize Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize Properties
Resize Class See Also Send Feedback

The Resize type exposes the following members.

Properties

Name | Description
Height | Gets or sets the new image height
InterpolationMode | Gets or sets the interpolation mode to use
LockAspectRatio | Gets or sets how element's proportions are maintained
Width | Gets or sets the new image width

See Also

Resize Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize..::.Height Property
Resize Class See Also Send Feedback
Gets or sets the new image height

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Resize Class


InterpolationMode Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize..::.InterpolationMode Property
Resize Class See Also Send Feedback
Gets or sets the interpolation mode to use

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public InterpolationMode InterpolationMode { get; set; }
Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual C++
public:
property InterpolationMode InterpolationMode {
    InterpolationMode get ();
    void set (InterpolationMode value);
}

See Also

Resize Class


LockAspectRatio Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize..::.LockAspectRatio Property
Resize Class See Also Send Feedback
Gets or sets how element's proportions are maintained

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public LockAspectRatio LockAspectRatio { get; set; }
Visual Basic (Declaration)
Public Property LockAspectRatio As LockAspectRatio
Visual C++
public:
property LockAspectRatio LockAspectRatio {
    LockAspectRatio get ();
    void set (LockAspectRatio value);
}

See Also

Resize Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Resize..::.Width Property
Resize Class See Also Send Feedback
Gets or sets the new image width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Resize Class


RichTextElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement Class
Members See Also Send Feedback
Represents a rich text element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class RichTextElement : Element
Visual Basic (Declaration)
Public Class RichTextElement _
    Inherits Element
Visual C++
public ref class RichTextElement : public Element

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.RichTextElement

See Also

RichTextElement Members


RichTextElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement Members
RichTextElement Class Constructors Methods Properties See Also Send Feedback

The RichTextElement type exposes the following members.

Constructors

Name | Description
RichTextElement | Initializes a new instance of the RichTextElement class

Methods

Name | Description
Clone | Creates a copy of the current RichTextElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
Background | Gets the background fill style.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Height | Gets or sets the height of the element. (Inherited from Element.)
LineSpacing | Gets or sets the space between lines of text.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the rich text displayed for a field when the field's value is null.
RichText | Gets or sets the rich text markup associated with this RichTextElement object.
Stretch | Gets or sets whether this RichTextElement object is automatically stretched to fit its size.
TextAlignment | Gets or sets the alignment of the text.
TextMargin | Gets the amount of space around text.
TextQuality | Gets or sets the quality of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

RichTextElement Class


RichTextElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement Constructor
RichTextElement Class See Also Send Feedback
Initializes a new instance of the RichTextElement class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RichTextElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RichTextElement()

See Also

RichTextElement Class


RichTextElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement Methods
RichTextElement Class See Also Send Feedback

The RichTextElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RichTextElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

RichTextElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.Clone Method
RichTextElement Class See Also Send Feedback
Creates a copy of the current RichTextElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current RichTextElement.

See Also

RichTextElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.GetOutputImage Method
RichTextElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

RichTextElement Class
RichTextElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.GetOutputImageBinary Method
RichTextElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

RichTextElement Class
RichTextElement Members


RichTextElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement Properties
RichTextElement Class See Also Send Feedback

The RichTextElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
Background | Gets the background fill style.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Height | Gets or sets the height of the element. (Inherited from Element.)
LineSpacing | Gets or sets the space between lines of text.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the rich text displayed for a field when the field's value is null.
RichText | Gets or sets the rich text markup associated with this RichTextElement object.
Stretch | Gets or sets whether this RichTextElement object is automatically stretched to fit its size.
TextAlignment | Gets or sets the alignment of the text.
TextMargin | Gets the amount of space around text.
TextQuality | Gets or sets the quality of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

RichTextElement Class


Background Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.Background Property
RichTextElement Class See Also Send Feedback
Gets the background fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Fill
Visual C++
public:
property Fill^ Background {
    Fill^ get ();
}

See Also

RichTextElement Class


ConvertEmptyStringToNull Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.ConvertEmptyStringToNull Property
RichTextElement Class See Also Send Feedback
Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ConvertEmptyStringToNull { get; set; }
Visual Basic (Declaration)
Public Property ConvertEmptyStringToNull As Boolean
Visual C++
public:
property bool ConvertEmptyStringToNull {
    bool get ();
    void set (bool value);
}

See Also

RichTextElement Class


LineSpacing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.LineSpacing Property
RichTextElement Class See Also Send Feedback
Gets or sets the space between lines of text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int LineSpacing { get; set; }
Visual Basic (Declaration)
Public Property LineSpacing As Integer
Visual C++
public:
property int LineSpacing {
    int get ();
    void set (int value);
}

See Also

RichTextElement Class


NullDisplayText Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.NullDisplayText Property
RichTextElement Class See Also Send Feedback
Gets or sets the rich text displayed for a field when the field's value is null.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string NullDisplayText { get; set; }
Visual Basic (Declaration)
Public Property NullDisplayText As String
Visual C++
public:
property String^ NullDisplayText {
    String^ get ();
    void set (String^ value);
}

See Also

RichTextElement Class


RichText Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.RichText Property
RichTextElement Class See Also Send Feedback
Gets or sets the rich text markup associated with this RichTextElement object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string RichText { get; set; }
Visual Basic (Declaration)
Public Property RichText As String
Visual C++
public:
property String^ RichText {
    String^ get ();
    void set (String^ value);
}

See Also

RichTextElement Class


Stretch Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.Stretch Property
RichTextElement Class See Also Send Feedback
Gets or sets whether this RichTextElement object is automatically stretched to fit its size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Stretch { get; set; }
Visual Basic (Declaration)
Public Property Stretch As Boolean
Visual C++
public:
property bool Stretch {
    bool get ();
    void set (bool value);
}

See Also

RichTextElement Class


TextAlignment Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.TextAlignment Property
RichTextElement Class See Also Send Feedback
Gets or sets the alignment of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public HorizontalAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As HorizontalAlignment
Visual C++
public:
property HorizontalAlignment TextAlignment {
    HorizontalAlignment get ();
    void set (HorizontalAlignment value);
}

See Also

RichTextElement Class


TextMargin Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.TextMargin Property
RichTextElement Class See Also Send Feedback
Gets the amount of space around text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding TextMargin { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextMargin As Padding
Visual C++
public:
property Padding^ TextMargin {
    Padding^ get ();
}

See Also

RichTextElement Class


TextQuality Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RichTextElement..::.TextQuality Property
RichTextElement Class See Also Send Feedback
Gets or sets the quality of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextRenderingHint TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextRenderingHint
Visual C++
public:
property TextRenderingHint TextQuality {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}

See Also

RichTextElement Class


Rotate Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Class
Members See Also Send Feedback
Defines an action that rotates an image. When rotated, an image pivots on its center point. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Rotate : Action
Visual Basic (Declaration)
Public NotInheritable Class Rotate _
    Inherits Action
Visual C++
public ref class Rotate sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Rotate

See Also

Rotate Members


Rotate Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Members
Rotate Class Constructors Methods Properties See Also Send Feedback

The Rotate type exposes the following members.

Constructors

Name | Description
Rotate | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Rotate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the rotation angle. It is measured counterclockwise from the x-axis.
InterpolationMode | Gets or sets the interpolation mode to use

See Also

Rotate Class


Rotate Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Constructor
Rotate Class See Also Send Feedback

Overload List

Name | Description
Rotate()()() | Initializes a new instance of the Rotate class.
Rotate(Int32, InterpolationMode) | Initializes a new instance of the Rotate class with Rotation settings.

See Also

Rotate Class
Rotate Members


Rotate Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Constructor
Rotate Class See Also Send Feedback
Initializes a new instance of the Rotate class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Rotate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Rotate()

See Also

Rotate Class
Rotate Overload


Rotate Constructor (Int32, InterpolationMode)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Constructor (Int32, InterpolationMode)
Rotate Class See Also Send Feedback
Initializes a new instance of the Rotate class with Rotation settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Rotate(
    int angle,
    InterpolationMode interpolationMode
)
Visual Basic (Declaration)
Public Sub New ( _
    angle As Integer, _
    interpolationMode As InterpolationMode _
)
Visual C++
public:
Rotate(
    int angle,
    InterpolationMode interpolationMode
)

Parameters

angle
Type: System..::.Int32
The rotation angle measured counterclockwise from the x-axis.
interpolationMode
Type: System.Drawing.Drawing2D..::.InterpolationMode
The interpolation mode to use.

See Also

Rotate Class
Rotate Overload


Rotate Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Methods
Rotate Class See Also Send Feedback

The Rotate type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Rotate. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rotate Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate..::.Clone Method
Rotate Class See Also Send Feedback
Creates a copy of the current Rotate.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Rotate.

See Also

Rotate Class


Rotate Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate Properties
Rotate Class See Also Send Feedback

The Rotate type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the rotation angle. It is measured counterclockwise from the x-axis.
InterpolationMode | Gets or sets the interpolation mode to use

See Also

Rotate Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate..::.Angle Property
Rotate Class See Also Send Feedback
Gets or sets the rotation angle. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

Rotate Class


InterpolationMode Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Rotate..::.InterpolationMode Property
Rotate Class See Also Send Feedback
Gets or sets the interpolation mode to use

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public InterpolationMode InterpolationMode { get; set; }
Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual C++
public:
property InterpolationMode InterpolationMode {
    InterpolationMode get ();
    void set (InterpolationMode value);
}

See Also

Rotate Class


RoundCorners Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Class
Members See Also Send Feedback
Defines an action that rounds image corners. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class RoundCorners : Action
Visual Basic (Declaration)
Public NotInheritable Class RoundCorners _
    Inherits Action
Visual C++
public ref class RoundCorners sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.RoundCorners

See Also

RoundCorners Members


RoundCorners Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Members
RoundCorners Class Constructors Methods Properties See Also Send Feedback

The RoundCorners type exposes the following members.

Constructors

Name | Description
RoundCorners | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current RoundCorners. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BorderColor | Gets or sets the border color
BorderWidth | Gets or sets the border width
Corners | Gets or sets what corners will be rounded.
Roundness | Gets or sets the corner roundness

See Also

RoundCorners Class


RoundCorners Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Constructor
RoundCorners Class See Also Send Feedback

Overload List

Name | Description
RoundCorners()()() | Initializes a new instance of the RoundCorners class.
RoundCorners(Int32, Color, Int32) | Initializes a new instance of the RoundCorners class with round settings.

See Also

RoundCorners Class
RoundCorners Members


RoundCorners Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Constructor
RoundCorners Class See Also Send Feedback
Initializes a new instance of the RoundCorners class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RoundCorners()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
RoundCorners()

See Also

RoundCorners Class
RoundCorners Overload


RoundCorners Constructor (Int32, Color, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Constructor (Int32, Color, Int32)
RoundCorners Class See Also Send Feedback
Initializes a new instance of the RoundCorners class with round settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public RoundCorners(
    int roundness,
    Color borderColor,
    int borderWidth
)
Visual Basic (Declaration)
Public Sub New ( _
    roundness As Integer, _
    borderColor As Color, _
    borderWidth As Integer _
)
Visual C++
public:
RoundCorners(
    int roundness,
    Color borderColor,
    int borderWidth
)

Parameters

roundness
Type: System..::.Int32
The corner roundness
borderColor
Type: System.Drawing..::.Color
The border color
borderWidth
Type: System..::.Int32

See Also

RoundCorners Class
RoundCorners Overload


RoundCorners Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Methods
RoundCorners Class See Also Send Feedback

The RoundCorners type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current RoundCorners. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RoundCorners Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners..::.Clone Method
RoundCorners Class See Also Send Feedback
Creates a copy of the current RoundCorners.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current RoundCorners.

See Also

RoundCorners Class


RoundCorners Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners Properties
RoundCorners Class See Also Send Feedback

The RoundCorners type exposes the following members.

Properties

Name | Description
BorderColor | Gets or sets the border color
BorderWidth | Gets or sets the border width
Corners | Gets or sets what corners will be rounded.
Roundness | Gets or sets the corner roundness

See Also

RoundCorners Class


BorderColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners..::.BorderColor Property
RoundCorners Class See Also Send Feedback
Gets or sets the border color

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic (Declaration)
Public Property BorderColor As Color
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

See Also

RoundCorners Class


BorderWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners..::.BorderWidth Property
RoundCorners Class See Also Send Feedback
Gets or sets the border width

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int BorderWidth { get; set; }
Visual Basic (Declaration)
Public Property BorderWidth As Integer
Visual C++
public:
property int BorderWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

RoundCorners Class


Corners Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners..::.Corners Property
RoundCorners Class See Also Send Feedback
Gets or sets what corners will be rounded.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Corners Corners { get; set; }
Visual Basic (Declaration)
Public Property Corners As Corners
Visual C++
public:
property Corners Corners {
    Corners get ();
    void set (Corners value);
}

See Also

RoundCorners Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
RoundCorners..::.Roundness Property
RoundCorners Class See Also Send Feedback
Gets or sets the corner roundness

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

RoundCorners Class


Scale Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Class
Members See Also Send Feedback
Defines an action that enlarges or reduces the size of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Scale : Action
Visual Basic (Declaration)
Public NotInheritable Class Scale _
    Inherits Action
Visual C++
public ref class Scale sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Scale

See Also

Scale Members


Scale Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Members
Scale Class Constructors Methods Properties See Also Send Feedback

The Scale type exposes the following members.

Constructors

Name | Description
Scale | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Scale. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
HeightPercentage | Gets or sets the new image height based on a percentage of the original height.
InterpolationMode | Gets or sets the interpolation mode to use.
WidthPercentage | Gets or sets the new image width based on a percentage of the original width.

See Also

Scale Class


Scale Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Constructor
Scale Class See Also Send Feedback

Overload List

Name | Description
Scale()()() | Initializes a new instance of the Scale class.
Scale(Int32, Int32, InterpolationMode) | Initializes a new instance of the Scale class with Scale settings.

See Also

Scale Class
Scale Members


Scale Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Constructor
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Scale()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Scale()

See Also

Scale Class
Scale Overload


Scale Constructor (Int32, Int32, InterpolationMode)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Constructor (Int32, Int32, InterpolationMode)
Scale Class See Also Send Feedback
Initializes a new instance of the Scale class with Scale settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Scale(
    int widthPercentage,
    int heightPercentage,
    InterpolationMode interpolationMode
)
Visual Basic (Declaration)
Public Sub New ( _
    widthPercentage As Integer, _
    heightPercentage As Integer, _
    interpolationMode As InterpolationMode _
)
Visual C++
public:
Scale(
    int widthPercentage,
    int heightPercentage,
    InterpolationMode interpolationMode
)

Parameters

widthPercentage
Type: System..::.Int32
The new image width based on a percentage of the original width.
heightPercentage
Type: System..::.Int32
The new image height based on a percentage of the original height.
interpolationMode
Type: System.Drawing.Drawing2D..::.InterpolationMode
The interpolation mode to use.

See Also

Scale Class
Scale Overload


Scale Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Methods
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Scale. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Scale Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale..::.Clone Method
Scale Class See Also Send Feedback
Creates a copy of the current Scale.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Scale.

See Also

Scale Class


Scale Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale Properties
Scale Class See Also Send Feedback

The Scale type exposes the following members.

Properties

Name | Description
HeightPercentage | Gets or sets the new image height based on a percentage of the original height.
InterpolationMode | Gets or sets the interpolation mode to use.
WidthPercentage | Gets or sets the new image width based on a percentage of the original width.

See Also

Scale Class


HeightPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale..::.HeightPercentage Property
Scale Class See Also Send Feedback
Gets or sets the new image height based on a percentage of the original height.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int HeightPercentage { get; set; }
Visual Basic (Declaration)
Public Property HeightPercentage As Integer
Visual C++
public:
property int HeightPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Scale Class


InterpolationMode Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale..::.InterpolationMode Property
Scale Class See Also Send Feedback
Gets or sets the interpolation mode to use.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public InterpolationMode InterpolationMode { get; set; }
Visual Basic (Declaration)
Public Property InterpolationMode As InterpolationMode
Visual C++
public:
property InterpolationMode InterpolationMode {
    InterpolationMode get ();
    void set (InterpolationMode value);
}

See Also

Scale Class


WidthPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Scale..::.WidthPercentage Property
Scale Class See Also Send Feedback
Gets or sets the new image width based on a percentage of the original width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int WidthPercentage { get; set; }
Visual Basic (Declaration)
Public Property WidthPercentage As Integer
Visual C++
public:
property int WidthPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

Scale Class


ScanDirection Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ScanDirection Enumeration
See Also Send Feedback
Specifies the direction of the pixel scanning process.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum ScanDirection
Visual Basic (Declaration)
Public Enumeration ScanDirection
Visual C++
public enum class ScanDirection

Members

Member name | Description
All |
LeftToRight |
RightToLeft |
TopToBottom |
BottomToTop |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


ShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended shape element class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public abstract class ShapeElement : Element
Visual Basic (Declaration)
Public MustInherit Class ShapeElement _
    Inherits Element
Visual C++
public ref class ShapeElement abstract : public Element

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.LineShapeElement

See Also

ShapeElement Members


ShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement Members
ShapeElement Class Constructors Methods Properties See Also Send Feedback

The ShapeElement type exposes the following members.

Constructors

Name | Description
ShapeElement | Initializes a new instance of the ShapeElement class

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object. (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages.
Roundness | Gets or sets the shape roundness
StrokeAntialias | Gets or sets whether stroke is antialiased.
StrokeDashStyle | Gets or sets the border dash style.
StrokeFill | Gets the border's fill style.
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape.
StrokeWidth | Gets or sets the border width.
Text | Gets or sets the text associated with this ShapeElement object.
TextAlignment | Gets or sets the alignment of the text.
TextForeColor | Gets or sets the foreground color of the text.
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.
TextPadding | Gets the amount of space around text in a shape.
TextQuality | Gets or sets the quality of the text.
TextStrokeColor | Gets or sets the color of the border along the outline of the text.
TextStrokeWidth | Gets or sets the width of the border along the outline of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ShapeElement Class


ShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement Constructor
ShapeElement Class See Also Send Feedback
Initializes a new instance of the ShapeElement class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
protected ShapeElement()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ShapeElement()

See Also

ShapeElement Class


ShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement Methods
ShapeElement Class See Also Send Feedback

The ShapeElement type exposes the following members.

Methods

Name | Description
Clone | When overridden in a derived class, creates an exact copy of this Element object. (Inherited from Element.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

ShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.GetOutputImage Method
ShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

ShapeElement Class
ShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.GetOutputImageBinary Method
ShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

ShapeElement Class
ShapeElement Members


ShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement Properties
ShapeElement Class See Also Send Feedback

The ShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages.
Roundness | Gets or sets the shape roundness
StrokeAntialias | Gets or sets whether stroke is antialiased.
StrokeDashStyle | Gets or sets the border dash style.
StrokeFill | Gets the border's fill style.
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape.
StrokeWidth | Gets or sets the border width.
Text | Gets or sets the text associated with this ShapeElement object.
TextAlignment | Gets or sets the alignment of the text.
TextForeColor | Gets or sets the foreground color of the text.
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.
TextPadding | Gets the amount of space around text in a shape.
TextQuality | Gets or sets the quality of the text.
TextStrokeColor | Gets or sets the color of the border along the outline of the text.
TextStrokeWidth | Gets or sets the width of the border along the outline of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

ShapeElement Class


ConvertEmptyStringToNull Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.ConvertEmptyStringToNull Property
ShapeElement Class See Also Send Feedback
Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ConvertEmptyStringToNull { get; set; }
Visual Basic (Declaration)
Public Property ConvertEmptyStringToNull As Boolean
Visual C++
public:
property bool ConvertEmptyStringToNull {
    bool get ();
    void set (bool value);
}

See Also

ShapeElement Class


Font Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.Font Property
ShapeElement Class See Also Send Feedback
Gets the Font object for the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

See Also

ShapeElement Class


NullDisplayText Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.NullDisplayText Property
ShapeElement Class See Also Send Feedback
Gets or sets the text displayed for a field when the field's value is null.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string NullDisplayText { get; set; }
Visual Basic (Declaration)
Public Property NullDisplayText As String
Visual C++
public:
property String^ NullDisplayText {
    String^ get ();
    void set (String^ value);
}

See Also

ShapeElement Class


RightToLeft Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.RightToLeft Property
ShapeElement Class See Also Send Feedback
Gets or sets whether the text should draw right-to-left for RTL languages.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

ShapeElement Class


Roundness Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.Roundness Property
ShapeElement Class See Also Send Feedback
Gets or sets the shape roundness

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Roundness { get; set; }
Visual Basic (Declaration)
Public Property Roundness As Integer
Visual C++
public:
property int Roundness {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to zero.

See Also

ShapeElement Class


StrokeAntialias Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.StrokeAntialias Property
ShapeElement Class See Also Send Feedback
Gets or sets whether stroke is antialiased.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool StrokeAntialias { get; set; }
Visual Basic (Declaration)
Public Property StrokeAntialias As Boolean
Visual C++
public:
property bool StrokeAntialias {
    bool get ();
    void set (bool value);
}

See Also

ShapeElement Class


StrokeDashStyle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.StrokeDashStyle Property
ShapeElement Class See Also Send Feedback
Gets or sets the border dash style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public DashStyle StrokeDashStyle { get; set; }
Visual Basic (Declaration)
Public Property StrokeDashStyle As DashStyle
Visual C++
public:
property DashStyle StrokeDashStyle {
    DashStyle get ();
    void set (DashStyle value);
}

See Also

ShapeElement Class


StrokeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.StrokeFill Property
ShapeElement Class See Also Send Feedback
Gets the border's fill style.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill StrokeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property StrokeFill As Fill
Visual C++
public:
property Fill^ StrokeFill {
    Fill^ get ();
}

See Also

ShapeElement Class


StrokeLineJoinStyle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.StrokeLineJoinStyle Property
ShapeElement Class See Also Send Feedback
Gets or sets the join style for the ends of two consecutive segments in a figure or shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public virtual LineJoin StrokeLineJoinStyle { get; set; }
Visual Basic (Declaration)
Public Overridable Property StrokeLineJoinStyle As LineJoin
Visual C++
public:
virtual property LineJoin StrokeLineJoinStyle {
    LineJoin get ();
    void set (LineJoin value);
}

See Also

ShapeElement Class


StrokeWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.StrokeWidth Property
ShapeElement Class See Also Send Feedback
Gets or sets the border width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StrokeWidth { get; set; }
Visual Basic (Declaration)
Public Property StrokeWidth As Integer
Visual C++
public:
property int StrokeWidth {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentException | The specified value is less than 0.

See Also

ShapeElement Class


Text Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.Text Property
ShapeElement Class See Also Send Feedback
Gets or sets the text associated with this ShapeElement object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

ShapeElement Class


TextAlignment Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextAlignment Property
ShapeElement Class See Also Send Feedback
Gets or sets the alignment of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

ShapeElement Class


TextForeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextForeColor Property
ShapeElement Class See Also Send Feedback
Gets or sets the foreground color of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color TextForeColor { get; set; }
Visual Basic (Declaration)
Public Property TextForeColor As Color
Visual C++
public:
property Color TextForeColor {
    Color get ();
    void set (Color value);
}

See Also

ShapeElement Class


TextMultiStrokeColors Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextMultiStrokeColors Property
ShapeElement Class See Also Send Feedback
Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string TextMultiStrokeColors { get; set; }
Visual Basic (Declaration)
Public Property TextMultiStrokeColors As String
Visual C++
public:
property String^ TextMultiStrokeColors {
    String^ get ();
    void set (String^ value);
}

See Also

ShapeElement Class


TextMultiStrokeWidths Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextMultiStrokeWidths Property
ShapeElement Class See Also Send Feedback
Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string TextMultiStrokeWidths { get; set; }
Visual Basic (Declaration)
Public Property TextMultiStrokeWidths As String
Visual C++
public:
property String^ TextMultiStrokeWidths {
    String^ get ();
    void set (String^ value);
}

See Also

ShapeElement Class


TextPadding Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextPadding Property
ShapeElement Class See Also Send Feedback
Gets the amount of space around text in a shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Padding TextPadding { get; }
Visual Basic (Declaration)
Public ReadOnly Property TextPadding As Padding
Visual C++
public:
property Padding^ TextPadding {
    Padding^ get ();
}

See Also

ShapeElement Class


TextQuality Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextQuality Property
ShapeElement Class See Also Send Feedback
Gets or sets the quality of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextRenderingHint TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextRenderingHint
Visual C++
public:
property TextRenderingHint TextQuality {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}

See Also

ShapeElement Class


TextStrokeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextStrokeColor Property
ShapeElement Class See Also Send Feedback
Gets or sets the color of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color TextStrokeColor { get; set; }
Visual Basic (Declaration)
Public Property TextStrokeColor As Color
Visual C++
public:
property Color TextStrokeColor {
    Color get ();
    void set (Color value);
}

See Also

ShapeElement Class


TextStrokeWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
ShapeElement..::.TextStrokeWidth Property
ShapeElement Class See Also Send Feedback
Gets or sets the width of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int TextStrokeWidth { get; set; }
Visual Basic (Declaration)
Public Property TextStrokeWidth As Integer
Visual C++
public:
property int TextStrokeWidth {
    int get ();
    void set (int value);
}

See Also

ShapeElement Class


Sharpen Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Sharpen Class
Members See Also Send Feedback
Defines an action that sharpen an element trying to enhance the overall visual impression. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Sharpen : Action
Visual Basic (Declaration)
Public NotInheritable Class Sharpen _
    Inherits Action
Visual C++
public ref class Sharpen sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Sharpen

See Also

Sharpen Members


Sharpen Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Sharpen Members
Sharpen Class Constructors Methods See Also Send Feedback

The Sharpen type exposes the following members.

Constructors

Name | Description
Sharpen | Initializes a new instance of the Sharpen class.

Methods

Name | Description
Clone | Creates a copy of the current Sharpen. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sharpen Class


Sharpen Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Sharpen Constructor
Sharpen Class See Also Send Feedback
Initializes a new instance of the Sharpen class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Sharpen()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Sharpen()

See Also

Sharpen Class


Sharpen Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Sharpen Methods
Sharpen Class See Also Send Feedback

The Sharpen type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Sharpen. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sharpen Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Sharpen..::.Clone Method
Sharpen Class See Also Send Feedback
Creates a copy of the current Sharpen.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Sharpen.

See Also

Sharpen Class


Silhouette Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Class
Members See Also Send Feedback
Defines an action that creates a Silhouette of an image. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Silhouette : Action
Visual Basic (Declaration)
Public NotInheritable Class Silhouette _
    Inherits Action
Visual C++
public ref class Silhouette sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Silhouette

See Also

Silhouette Members


Silhouette Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Members
Silhouette Class Constructors Methods Properties See Also Send Feedback

The Silhouette type exposes the following members.

Constructors

Name | Description
Silhouette | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Silhouette. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the Silhouette color.

See Also

Silhouette Class


Silhouette Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Constructor
Silhouette Class See Also Send Feedback

Overload List

Name | Description
Silhouette()()() | Initializes a new instance of the Silhouette class.
Silhouette(Color) | Initializes a new instance of the Silhouette class with the specified color.

See Also

Silhouette Class
Silhouette Members


Silhouette Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Constructor
Silhouette Class See Also Send Feedback
Initializes a new instance of the Silhouette class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Silhouette()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Silhouette()

See Also

Silhouette Class
Silhouette Overload


Silhouette Constructor (Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Constructor (Color)
Silhouette Class See Also Send Feedback
Initializes a new instance of the Silhouette class with the specified color.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Silhouette(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
Silhouette(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
The Silhouette color.

See Also

Silhouette Class
Silhouette Overload


Silhouette Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Methods
Silhouette Class See Also Send Feedback

The Silhouette type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Silhouette. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Silhouette Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette..::.Clone Method
Silhouette Class See Also Send Feedback
Creates a copy of the current Silhouette.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Silhouette.

See Also

Silhouette Class


Silhouette Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette Properties
Silhouette Class See Also Send Feedback

The Silhouette type exposes the following members.

Properties

Name | Description
Color | Gets or sets the Silhouette color.

See Also

Silhouette Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Silhouette..::.Color Property
Silhouette Class See Also Send Feedback
Gets or sets the Silhouette color.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

Silhouette Class


Skew Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Class
Members See Also Send Feedback
Defines an action that skews an element. Skewing an element transforms it by slanting it along the horizontal or vertical axis. When skewed, an element pivots on its origin point. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class Skew : Action
Visual Basic (Declaration)
Public Class Skew _
    Inherits Action
Visual C++
public ref class Skew : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Skew

See Also

Skew Members


Skew Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Members
Skew Class Constructors Methods Properties See Also Send Feedback

The Skew type exposes the following members.

Constructors

Name | Description
Skew | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Skew. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Angle | Gets or sets the skewing angle.
ConstrainProportions | Gets or sets whether maintaing the same proportions as the original.
Orientation | Gets or sets the skewing orientation.
Type | Gets or sets the skewing type.

See Also

Skew Class


Skew Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Constructor
Skew Class See Also Send Feedback

Overload List

Name | Description
Skew()()() | Initializes a new instance of the Skew class.
Skew(SkewType, SkewOrientation, Int32) | Initializes a new instance of the Skew class with the specified skewing type, orientation and angle.

See Also

Skew Class
Skew Members


Skew Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Constructor
Skew Class See Also Send Feedback
Initializes a new instance of the Skew class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Skew()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Skew()

See Also

Skew Class
Skew Overload


Skew Constructor (SkewType, SkewOrientation, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Constructor (SkewType, SkewOrientation, Int32)
Skew Class See Also Send Feedback
Initializes a new instance of the Skew class with the specified skewing type, orientation and angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Skew(
    SkewType type,
    SkewOrientation orientation,
    int angle
)
Visual Basic (Declaration)
Public Sub New ( _
    type As SkewType, _
    orientation As SkewOrientation, _
    angle As Integer _
)
Visual C++
public:
Skew(
    SkewType type,
    SkewOrientation orientation,
    int angle
)

Parameters

type
Type: Neodynamic.SDK.ImageDraw..::.SkewType
The skewing type
orientation
Type: Neodynamic.SDK.ImageDraw..::.SkewOrientation
The skewing orientation
angle
Type: System..::.Int32
The skewing angle

See Also

Skew Class
Skew Overload


Skew Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Methods
Skew Class See Also Send Feedback

The Skew type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Skew. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Skew Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew..::.Clone Method
Skew Class See Also Send Feedback
Creates a copy of the current Skew.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Skew.

See Also

Skew Class


Skew Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew Properties
Skew Class See Also Send Feedback

The Skew type exposes the following members.

Properties

Name | Description
Angle | Gets or sets the skewing angle.
ConstrainProportions | Gets or sets whether maintaing the same proportions as the original.
Orientation | Gets or sets the skewing orientation.
Type | Gets or sets the skewing type.

See Also

Skew Class


Angle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew..::.Angle Property
Skew Class See Also Send Feedback
Gets or sets the skewing angle.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Integer
Visual C++
public:
property int Angle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from -45 to 45.

See Also

Skew Class


ConstrainProportions Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew..::.ConstrainProportions Property
Skew Class See Also Send Feedback
Gets or sets whether maintaing the same proportions as the original.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ConstrainProportions { get; set; }
Visual Basic (Declaration)
Public Property ConstrainProportions As Boolean
Visual C++
public:
property bool ConstrainProportions {
    bool get ();
    void set (bool value);
}

See Also

Skew Class


Orientation Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew..::.Orientation Property
Skew Class See Also Send Feedback
Gets or sets the skewing orientation.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public SkewOrientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As SkewOrientation
Visual C++
public:
property SkewOrientation Orientation {
    SkewOrientation get ();
    void set (SkewOrientation value);
}

See Also

Skew Class


Type Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Skew..::.Type Property
Skew Class See Also Send Feedback
Gets or sets the skewing type.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public SkewType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As SkewType
Visual C++
public:
property SkewType Type {
    SkewType get ();
    void set (SkewType value);
}

See Also

Skew Class


SkewOrientation Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
SkewOrientation Enumeration
See Also Send Feedback
Specifies the direction used to skew an element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum SkewOrientation
Visual Basic (Declaration)
Public Enumeration SkewOrientation
Visual C++
public enum class SkewOrientation

Members

Member name | Description
Horizontal | Specifies a horizontal skewing.
Vertical | Specifies a vertical skewing.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


SkewType Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
SkewType Enumeration
See Also Send Feedback
Specifies the shape used to skew an element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum SkewType
Visual Basic (Declaration)
Public Enumeration SkewType
Visual C++
public enum class SkewType

Members

Member name | Description
Parallelogram | Specifies skewing an element to the shape of a parallelogram.
Trapezoid | Specifies skewing an element to the shape of a trapezoid.

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


Solarize Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Solarize Class
Members See Also Send Feedback
Defines an action that solarizes an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Solarize : Action
Visual Basic (Declaration)
Public NotInheritable Class Solarize _
    Inherits Action
Visual C++
public ref class Solarize sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Solarize

See Also

Solarize Members


Solarize Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Solarize Members
Solarize Class Constructors Methods See Also Send Feedback

The Solarize type exposes the following members.

Constructors

Name | Description
Solarize | Initializes a new instance of the Solarize class.

Methods

Name | Description
Clone | Creates a copy of the current Solarize. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Solarize Class


Solarize Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Solarize Constructor
Solarize Class See Also Send Feedback
Initializes a new instance of the Solarize class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Solarize()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Solarize()

See Also

Solarize Class


Solarize Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Solarize Methods
Solarize Class See Also Send Feedback

The Solarize type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Solarize. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Solarize Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Solarize..::.Clone Method
Solarize Class See Also Send Feedback
Creates a copy of the current Solarize.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Solarize.

See Also

Solarize Class


StarShapeElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Class
Members See Also Send Feedback
Represents a star shape element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class StarShapeElement : ClosedShapeElement
Visual Basic (Declaration)
Public Class StarShapeElement _
    Inherits ClosedShapeElement
Visual C++
public ref class StarShapeElement : public ClosedShapeElement

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.ShapeElement
Neodynamic.SDK.ImageDraw..::.ClosedShapeElement
Neodynamic.SDK.ImageDraw..::.StarShapeElement

See Also

StarShapeElement Members


StarShapeElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Members
StarShapeElement Class Constructors Methods Properties See Also Send Feedback

The StarShapeElement type exposes the following members.

Constructors

Name | Description
StarShapeElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current StarShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
InnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
Points | Gets or sets the number of points of the star shape.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

StarShapeElement Class


StarShapeElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Constructor
StarShapeElement Class See Also Send Feedback

Overload List

Name | Description
StarShapeElement()()() | Initializes a new instance of the StarShapeElement class.
StarShapeElement(Int32) | Initializes a new instance of the StarShapeElement class with the specified number of points of the star shape.

See Also

StarShapeElement Class
StarShapeElement Members


StarShapeElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Constructor
StarShapeElement Class See Also Send Feedback
Initializes a new instance of the StarShapeElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public StarShapeElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StarShapeElement()

See Also

StarShapeElement Class
StarShapeElement Overload


StarShapeElement Constructor (Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Constructor (Int32)
StarShapeElement Class See Also Send Feedback
Initializes a new instance of the StarShapeElement class with the specified number of points of the star shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public StarShapeElement(
    int points
)
Visual Basic (Declaration)
Public Sub New ( _
    points As Integer _
)
Visual C++
public:
StarShapeElement(
    int points
)

Parameters

points
Type: System..::.Int32
The number of points of the star shape

See Also

StarShapeElement Class
StarShapeElement Overload


StarShapeElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Methods
StarShapeElement Class See Also Send Feedback

The StarShapeElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current StarShapeElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

StarShapeElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement..::.Clone Method
StarShapeElement Class See Also Send Feedback
Creates a copy of the current StarShapeElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current StarShapeElement.

See Also

StarShapeElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement..::.GetOutputImage Method
StarShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

StarShapeElement Class
StarShapeElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement..::.GetOutputImageBinary Method
StarShapeElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

StarShapeElement Class
StarShapeElement Members


StarShapeElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement Properties
StarShapeElement Class See Also Send Feedback

The StarShapeElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source. (Inherited from ShapeElement.)
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Fill | Gets the shape's fill style. (Inherited from ClosedShapeElement.)
Font | Gets the Font object for the text. (Inherited from ShapeElement.)
Height | Gets or sets the height of the element. (Inherited from Element.)
InnerRadiusPercentage | Gets or sets the inner radius percentage of the star shape.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null. (Inherited from ShapeElement.)
Points | Gets or sets the number of points of the star shape.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. (Inherited from ShapeElement.)
Roundness | Gets or sets the shape roundness (Inherited from ShapeElement.)
StrokeAntialias | Gets or sets whether stroke is antialiased. (Inherited from ShapeElement.)
StrokeDashStyle | Gets or sets the border dash style. (Inherited from ShapeElement.)
StrokeFill | Gets the border's fill style. (Inherited from ShapeElement.)
StrokeLineJoinStyle | Gets or sets the join style for the ends of two consecutive segments in a figure or shape. (Inherited from ShapeElement.)
StrokeWidth | Gets or sets the border width. (Inherited from ShapeElement.)
Text | Gets or sets the text associated with this ShapeElement object. (Inherited from ShapeElement.)
TextAlignment | Gets or sets the alignment of the text. (Inherited from ShapeElement.)
TextForeColor | Gets or sets the foreground color of the text. (Inherited from ShapeElement.)
TextMultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas. (Inherited from ShapeElement.)
TextMultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas. (Inherited from ShapeElement.)
TextPadding | Gets the amount of space around text in a shape. (Inherited from ShapeElement.)
TextQuality | Gets or sets the quality of the text. (Inherited from ShapeElement.)
TextStrokeColor | Gets or sets the color of the border along the outline of the text. (Inherited from ShapeElement.)
TextStrokeWidth | Gets or sets the width of the border along the outline of the text. (Inherited from ShapeElement.)
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

StarShapeElement Class


InnerRadiusPercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement..::.InnerRadiusPercentage Property
StarShapeElement Class See Also Send Feedback
Gets or sets the inner radius percentage of the star shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int InnerRadiusPercentage { get; set; }
Visual Basic (Declaration)
Public Property InnerRadiusPercentage As Integer
Visual C++
public:
property int InnerRadiusPercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 1 to 100.

See Also

StarShapeElement Class


Points Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
StarShapeElement..::.Points Property
StarShapeElement Class See Also Send Feedback
Gets or sets the number of points of the star shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Points { get; set; }
Visual Basic (Declaration)
Public Property Points As Integer
Visual C++
public:
property int Points {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to three.

See Also

StarShapeElement Class


Stretch Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Class
Members See Also Send Feedback
Defines an action that stretches an image to fit a given size. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Stretch : Action
Visual Basic (Declaration)
Public NotInheritable Class Stretch _
    Inherits Action
Visual C++
public ref class Stretch sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Stretch

See Also

Stretch Members


Stretch Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Members
Stretch Class Constructors Methods Properties See Also Send Feedback

The Stretch type exposes the following members.

Constructors

Name | Description
Stretch | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Stretch. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Height | Gets or sets the new image height.
Width | Gets or sets the new image width.

See Also

Stretch Class


Stretch Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Constructor
Stretch Class See Also Send Feedback

Overload List

Name | Description
Stretch()()() | Initializes a new instance of the Stretch class.
Stretch(Int32, Int32) | Initializes a new instance of the Stretch class with the specified size.

See Also

Stretch Class
Stretch Members


Stretch Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Constructor
Stretch Class See Also Send Feedback
Initializes a new instance of the Stretch class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Stretch()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Stretch()

See Also

Stretch Class
Stretch Overload


Stretch Constructor (Int32, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Constructor (Int32, Int32)
Stretch Class See Also Send Feedback
Initializes a new instance of the Stretch class with the specified size.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Stretch(
    int newWidth,
    int newHeight
)
Visual Basic (Declaration)
Public Sub New ( _
    newWidth As Integer, _
    newHeight As Integer _
)
Visual C++
public:
Stretch(
    int newWidth,
    int newHeight
)

Parameters

newWidth
Type: System..::.Int32
The new image width.
newHeight
Type: System..::.Int32
The new image height.

See Also

Stretch Class
Stretch Overload


Stretch Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Methods
Stretch Class See Also Send Feedback

The Stretch type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Stretch. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Stretch Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch..::.Clone Method
Stretch Class See Also Send Feedback
Creates a copy of the current Stretch.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Stretch.

See Also

Stretch Class


Stretch Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch Properties
Stretch Class See Also Send Feedback

The Stretch type exposes the following members.

Properties

Name | Description
Height | Gets or sets the new image height.
Width | Gets or sets the new image width.

See Also

Stretch Class


Height Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch..::.Height Property
Stretch Class See Also Send Feedback
Gets or sets the new image height.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Height { get; set; }
Visual Basic (Declaration)
Public Property Height As Integer
Visual C++
public:
property int Height {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Stretch Class


Width Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Stretch..::.Width Property
Stretch Class See Also Send Feedback
Gets or sets the new image width.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int Width { get; set; }
Visual Basic (Declaration)
Public Property Width As Integer
Visual C++
public:
property int Width {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than or equal to one.

See Also

Stretch Class


TextElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Class
Members See Also Send Feedback
Represents a text element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class TextElement : Element
Visual Basic (Declaration)
Public Class TextElement _
    Inherits Element
Visual C++
public ref class TextElement : public Element

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.TextElement

See Also

TextElement Members


TextElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Members
TextElement Class Constructors Methods Properties See Also Send Feedback

The TextElement type exposes the following members.

Constructors

Name | Description
TextElement | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current TextElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
AutoSize | Gets or sets whether this TextElement object is automatically resized to display its entire contents.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
ForeColor | Gets or sets the foreground color of the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Multiline | Gets or sets whether the text can span more than one line.
MultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.
MultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages.
Sizing | Gets or sets the text sizing.
StrokeColor | Gets or sets the color of the border along the outline of the text.
StrokeWidth | Gets or sets the width of the border along the outline of the text.
Text | Gets or sets the text associated with this TextElement object.
TextAlignment | Gets or sets the alignment of the text.
TextQuality | Gets or sets the quality of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

TextElement Class


TextElement Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Constructor
TextElement Class See Also Send Feedback

Overload List

Name | Description
TextElement()()() | Initializes a new instance of the TextElement class.
TextElement(String, Font, Color, Color, Int32) | Initializes a new instance of the TextElement class with text settings.

See Also

TextElement Class
TextElement Members


TextElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Constructor
TextElement Class See Also Send Feedback
Initializes a new instance of the TextElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextElement()

See Also

TextElement Class
TextElement Overload


TextElement Constructor (String, Font, Color, Color, Int32)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Constructor (String, Font, Color, Color, Int32)
TextElement Class See Also Send Feedback
Initializes a new instance of the TextElement class with text settings.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextElement(
    string text,
    Font font,
    Color foreColor,
    Color strokeColor,
    int strokeWidth
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String, _
    font As Font, _
    foreColor As Color, _
    strokeColor As Color, _
    strokeWidth As Integer _
)
Visual C++
public:
TextElement(
    String^ text,
    Font^ font,
    Color foreColor,
    Color strokeColor,
    int strokeWidth
)

Parameters

text
Type: System..::.String
The text associated with this TextElement object.
font
Type: Neodynamic.SDK.ImageDraw..::.Font
The Font object to use.
foreColor
Type: System.Drawing..::.Color
The foreground color of the text.
strokeColor
Type: System.Drawing..::.Color
The color of the border along the outline of the text.
strokeWidth
Type: System..::.Int32
The width of the border along the outline of the text.

See Also

TextElement Class
TextElement Overload


TextElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Methods
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current TextElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

TextElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.Clone Method
TextElement Class See Also Send Feedback
Creates a copy of the current TextElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current TextElement.

See Also

TextElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.GetOutputImage Method
TextElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

TextElement Class
TextElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.GetOutputImageBinary Method
TextElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

TextElement Class
TextElement Members


TextElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement Properties
TextElement Class See Also Send Feedback

The TextElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
AutoSize | Gets or sets whether this TextElement object is automatically resized to display its entire contents.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
ForeColor | Gets or sets the foreground color of the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Multiline | Gets or sets whether the text can span more than one line.
MultiStrokeColors | Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.
MultiStrokeWidths | Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages.
Sizing | Gets or sets the text sizing.
StrokeColor | Gets or sets the color of the border along the outline of the text.
StrokeWidth | Gets or sets the width of the border along the outline of the text.
Text | Gets or sets the text associated with this TextElement object.
TextAlignment | Gets or sets the alignment of the text.
TextQuality | Gets or sets the quality of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

TextElement Class


AutoSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.AutoSize Property
TextElement Class See Also Send Feedback
Gets or sets whether this TextElement object is automatically resized to display its entire contents.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

TextElement Class


ConvertEmptyStringToNull Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.ConvertEmptyStringToNull Property
TextElement Class See Also Send Feedback
Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ConvertEmptyStringToNull { get; set; }
Visual Basic (Declaration)
Public Property ConvertEmptyStringToNull As Boolean
Visual C++
public:
property bool ConvertEmptyStringToNull {
    bool get ();
    void set (bool value);
}

See Also

TextElement Class


Font Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.Font Property
TextElement Class See Also Send Feedback
Gets the Font object for the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

See Also

TextElement Class


ForeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.ForeColor Property
TextElement Class See Also Send Feedback
Gets or sets the foreground color of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

TextElement Class


Multiline Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.Multiline Property
TextElement Class See Also Send Feedback
Gets or sets whether the text can span more than one line.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

TextElement Class


MultiStrokeColors Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.MultiStrokeColors Property
TextElement Class See Also Send Feedback
Gets or sets the serie of colors of the borders along the outline of the text. The colors must be specified in hexadecimal (hex) notation for the combination of Red, Green, and Blue channel values (RGB). Colors must be also separated by commas.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string MultiStrokeColors { get; set; }
Visual Basic (Declaration)
Public Property MultiStrokeColors As String
Visual C++
public:
property String^ MultiStrokeColors {
    String^ get ();
    void set (String^ value);
}

See Also

TextElement Class


MultiStrokeWidths Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.MultiStrokeWidths Property
TextElement Class See Also Send Feedback
Gets or sets the widths of the borders along the outline of the text. The widths of the borders must be specified as integer numbers and separated by commas.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string MultiStrokeWidths { get; set; }
Visual Basic (Declaration)
Public Property MultiStrokeWidths As String
Visual C++
public:
property String^ MultiStrokeWidths {
    String^ get ();
    void set (String^ value);
}

See Also

TextElement Class


NullDisplayText Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.NullDisplayText Property
TextElement Class See Also Send Feedback
Gets or sets the text displayed for a field when the field's value is null.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string NullDisplayText { get; set; }
Visual Basic (Declaration)
Public Property NullDisplayText As String
Visual C++
public:
property String^ NullDisplayText {
    String^ get ();
    void set (String^ value);
}

See Also

TextElement Class


RightToLeft Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.RightToLeft Property
TextElement Class See Also Send Feedback
Gets or sets whether the text should draw right-to-left for RTL languages.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic (Declaration)
Public Property RightToLeft As Boolean
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

See Also

TextElement Class


Sizing Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.Sizing Property
TextElement Class See Also Send Feedback
Gets or sets the text sizing.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextSizing Sizing { get; set; }
Visual Basic (Declaration)
Public Property Sizing As TextSizing
Visual C++
public:
property TextSizing Sizing {
    TextSizing get ();
    void set (TextSizing value);
}

See Also

TextElement Class


StrokeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.StrokeColor Property
TextElement Class See Also Send Feedback
Gets or sets the color of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color StrokeColor { get; set; }
Visual Basic (Declaration)
Public Property StrokeColor As Color
Visual C++
public:
property Color StrokeColor {
    Color get ();
    void set (Color value);
}

See Also

TextElement Class


StrokeWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.StrokeWidth Property
TextElement Class See Also Send Feedback
Gets or sets the width of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StrokeWidth { get; set; }
Visual Basic (Declaration)
Public Property StrokeWidth As Integer
Visual C++
public:
property int StrokeWidth {
    int get ();
    void set (int value);
}

See Also

TextElement Class


Text Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.Text Property
TextElement Class See Also Send Feedback
Gets or sets the text associated with this TextElement object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TextElement Class


TextAlignment Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.TextAlignment Property
TextElement Class See Also Send Feedback
Gets or sets the alignment of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

TextElement Class


TextQuality Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextElement..::.TextQuality Property
TextElement Class See Also Send Feedback
Gets or sets the quality of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextRenderingHint TextQuality { get; set; }
Visual Basic (Declaration)
Public Property TextQuality As TextRenderingHint
Visual C++
public:
property TextRenderingHint TextQuality {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}

See Also

TextElement Class


TextSizing Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSizing Enumeration
See Also Send Feedback
Specifies the text sizing.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum TextSizing
Visual Basic (Declaration)
Public Enumeration TextSizing
Visual C++
public enum class TextSizing

Members

Member name | Description
None |
FitToWidth |
FitToHeight |
Stretch |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


TextSpan Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan Class
Members See Also Send Feedback
A TextSpan is used to indicate a text inline container.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class TextSpan : ICloneable
Visual Basic (Declaration)
Public Class TextSpan _
    Implements ICloneable
Visual C++
public ref class TextSpan : ICloneable

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.TextSpan

See Also

TextSpan Members


TextSpan Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan Members
TextSpan Class Constructors Methods Properties See Also Send Feedback

The TextSpan type exposes the following members.

Constructors

Name | Description
TextSpan | Initializes a new instance of the TextSpan class

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromString | It loads a text span markup into this TextSpan object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
BackColor | Gets or sets the background color used by this TextSpan object.
BaselineOffset | Gets or sets a vertical offset value for the baseline of this TextSpan object.
CustomFontFile | Gets or sets the custom font file to use for this TextSpan object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
CustomFontFileFamilyIndex | Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.
FontBold | Gets or sets a value that indicates whether the font used by this TextSpan object is bold.
FontItalic | Gets or sets a value that indicates whether the font used by this TextSpan object is italic.
FontName | Gets or sets the face name of this TextSpan object.
FontSize | Gets or sets the size of the font used by this TextSpan object.
FontStrikeout | Gets or sets a value that indicates whether the font used by this TextSpan object specifies a horizontal line through the text.
FontUnderline | Gets or sets a value that indicates whether the font used by this TextSpan object is underlined.
FontUnit | Gets or sets the unit of measure for the font used by this TextSpan object.
ForeColor | Gets or sets the foreground color used by this TextSpan object.
Kerning | Gets or sets the spacing between the letters contained in this TextSpan object.
Text | Gets or sets the text.

See Also

TextSpan Class


TextSpan Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan Constructor
TextSpan Class See Also Send Feedback
Initializes a new instance of the TextSpan class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public TextSpan()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TextSpan()

See Also

TextSpan Class


TextSpan Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan Methods
TextSpan Class See Also Send Feedback

The TextSpan type exposes the following members.

Methods

Name | Description
Clone |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
LoadFromString | It loads a text span markup into this TextSpan object.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

TextSpan Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.Clone Method
TextSpan Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Object Clone()
Visual Basic (Declaration)
Public Function Clone As Object
Visual C++
public:
virtual Object^ Clone() sealed

Implements

ICloneable..::.Clone()()()

See Also

TextSpan Class


LoadFromString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.LoadFromString Method
TextSpan Class See Also Send Feedback
It loads a text span markup into this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public void LoadFromString(
    string textSpanMarkup
)
Visual Basic (Declaration)
Public Sub LoadFromString ( _
    textSpanMarkup As String _
)
Visual C++
public:
void LoadFromString(
    String^ textSpanMarkup
)

Parameters

textSpanMarkup
Type: System..::.String

See Also

TextSpan Class


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.ToString Method
TextSpan Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

See Also

TextSpan Class


TextSpan Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan Properties
TextSpan Class See Also Send Feedback

The TextSpan type exposes the following members.

Properties

Name | Description
BackColor | Gets or sets the background color used by this TextSpan object.
BaselineOffset | Gets or sets a vertical offset value for the baseline of this TextSpan object.
CustomFontFile | Gets or sets the custom font file to use for this TextSpan object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.
CustomFontFileFamilyIndex | Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.
FontBold | Gets or sets a value that indicates whether the font used by this TextSpan object is bold.
FontItalic | Gets or sets a value that indicates whether the font used by this TextSpan object is italic.
FontName | Gets or sets the face name of this TextSpan object.
FontSize | Gets or sets the size of the font used by this TextSpan object.
FontStrikeout | Gets or sets a value that indicates whether the font used by this TextSpan object specifies a horizontal line through the text.
FontUnderline | Gets or sets a value that indicates whether the font used by this TextSpan object is underlined.
FontUnit | Gets or sets the unit of measure for the font used by this TextSpan object.
ForeColor | Gets or sets the foreground color used by this TextSpan object.
Kerning | Gets or sets the spacing between the letters contained in this TextSpan object.
Text | Gets or sets the text.

See Also

TextSpan Class


BackColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.BackColor Property
TextSpan Class See Also Send Feedback
Gets or sets the background color used by this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color BackColor { get; set; }
Visual Basic (Declaration)
Public Property BackColor As Color
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

See Also

TextSpan Class


BaselineOffset Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.BaselineOffset Property
TextSpan Class See Also Send Feedback
Gets or sets a vertical offset value for the baseline of this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float BaselineOffset { get; set; }
Visual Basic (Declaration)
Public Property BaselineOffset As Single
Visual C++
public:
property float BaselineOffset {
    float get ();
    void set (float value);
}

See Also

TextSpan Class


CustomFontFile Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.CustomFontFile Property
TextSpan Class See Also Send Feedback
Gets or sets the custom font file to use for this TextSpan object. It can be specified as a relative URL or full path pointing out to the custom font file on local disk or; as an identifier stored in the appSettings section of Web.config file.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string CustomFontFile { get; set; }
Visual Basic (Declaration)
Public Property CustomFontFile As String
Visual C++
public:
property String^ CustomFontFile {
    String^ get ();
    void set (String^ value);
}

See Also

TextSpan Class


CustomFontFileFamilyIndex Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.CustomFontFileFamilyIndex Property
TextSpan Class See Also Send Feedback
Gets or sets the Font Family index of the type faces defined by the specified Custom Font File.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CustomFontFileFamilyIndex { get; set; }
Visual Basic (Declaration)
Public Property CustomFontFileFamilyIndex As Integer
Visual C++
public:
property int CustomFontFileFamilyIndex {
    int get ();
    void set (int value);
}

See Also

TextSpan Class


FontBold Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontBold Property
TextSpan Class See Also Send Feedback
Gets or sets a value that indicates whether the font used by this TextSpan object is bold.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool FontBold { get; set; }
Visual Basic (Declaration)
Public Property FontBold As Boolean
Visual C++
public:
property bool FontBold {
    bool get ();
    void set (bool value);
}

See Also

TextSpan Class


FontItalic Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontItalic Property
TextSpan Class See Also Send Feedback
Gets or sets a value that indicates whether the font used by this TextSpan object is italic.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool FontItalic { get; set; }
Visual Basic (Declaration)
Public Property FontItalic As Boolean
Visual C++
public:
property bool FontItalic {
    bool get ();
    void set (bool value);
}

See Also

TextSpan Class


FontName Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontName Property
TextSpan Class See Also Send Feedback
Gets or sets the face name of this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string FontName { get; set; }
Visual Basic (Declaration)
Public Property FontName As String
Visual C++
public:
property String^ FontName {
    String^ get ();
    void set (String^ value);
}

See Also

TextSpan Class


FontSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontSize Property
TextSpan Class See Also Send Feedback
Gets or sets the size of the font used by this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float FontSize { get; set; }
Visual Basic (Declaration)
Public Property FontSize As Single
Visual C++
public:
property float FontSize {
    float get ();
    void set (float value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not greater than zero.

See Also

TextSpan Class


FontStrikeout Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontStrikeout Property
TextSpan Class See Also Send Feedback
Gets or sets a value that indicates whether the font used by this TextSpan object specifies a horizontal line through the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool FontStrikeout { get; set; }
Visual Basic (Declaration)
Public Property FontStrikeout As Boolean
Visual C++
public:
property bool FontStrikeout {
    bool get ();
    void set (bool value);
}

See Also

TextSpan Class


FontUnderline Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontUnderline Property
TextSpan Class See Also Send Feedback
Gets or sets a value that indicates whether the font used by this TextSpan object is underlined.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool FontUnderline { get; set; }
Visual Basic (Declaration)
Public Property FontUnderline As Boolean
Visual C++
public:
property bool FontUnderline {
    bool get ();
    void set (bool value);
}

See Also

TextSpan Class


FontUnit Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.FontUnit Property
TextSpan Class See Also Send Feedback
Gets or sets the unit of measure for the font used by this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public GraphicsUnit FontUnit { get; set; }
Visual Basic (Declaration)
Public Property FontUnit As GraphicsUnit
Visual C++
public:
property GraphicsUnit FontUnit {
    GraphicsUnit get ();
    void set (GraphicsUnit value);
}

See Also

TextSpan Class


ForeColor Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.ForeColor Property
TextSpan Class See Also Send Feedback
Gets or sets the foreground color used by this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic (Declaration)
Public Property ForeColor As Color
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

See Also

TextSpan Class


Kerning Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.Kerning Property
TextSpan Class See Also Send Feedback
Gets or sets the spacing between the letters contained in this TextSpan object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public float Kerning { get; set; }
Visual Basic (Declaration)
Public Property Kerning As Single
Visual C++
public:
property float Kerning {
    float get ();
    void set (float value);
}

See Also

TextSpan Class


Text Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
TextSpan..::.Text Property
TextSpan Class See Also Send Feedback
Gets or sets the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

TextSpan Class


Tint Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Class
Members See Also Send Feedback
Defines an action that creates a tinted look of an element. This class cannot be inherited.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public sealed class Tint : Action
Visual Basic (Declaration)
Public NotInheritable Class Tint _
    Inherits Action
Visual C++
public ref class Tint sealed : public Action

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Action
Neodynamic.SDK.ImageDraw..::.Tint

See Also

Tint Members


Tint Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Members
Tint Class Constructors Methods Properties See Also Send Feedback

The Tint type exposes the following members.

Constructors

Name | Description
Tint | Overloaded.

Methods

Name | Description
Clone | Creates a copy of the current Tint. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets or sets the color used for tinting.

See Also

Tint Class


Tint Constructor

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Constructor
Tint Class See Also Send Feedback

Overload List

Name | Description
Tint()()() | Initializes a new instance of the Tint class.
Tint(Color) | Initializes a new instance of the Tint class with the specified color.

See Also

Tint Class
Tint Members


Tint Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Constructor
Tint Class See Also Send Feedback
Initializes a new instance of the Tint class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Tint()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Tint()

See Also

Tint Class
Tint Overload


Tint Constructor (Color)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Constructor (Color)
Tint Class See Also Send Feedback
Initializes a new instance of the Tint class with the specified color.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Tint(
    Color color
)
Visual Basic (Declaration)
Public Sub New ( _
    color As Color _
)
Visual C++
public:
Tint(
    Color color
)

Parameters

color
Type: System.Drawing..::.Color
The color used for tinting.

See Also

Tint Class
Tint Overload


Tint Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Methods
Tint Class See Also Send Feedback

The Tint type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current Tint. (Overrides Action..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Tint Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint..::.Clone Method
Tint Class See Also Send Feedback
Creates a copy of the current Tint.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Action Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Action
Visual C++
public:
virtual Action^ Clone() override

Return Value

A copy of the current Tint.

See Also

Tint Class


Tint Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint Properties
Tint Class See Also Send Feedback

The Tint type exposes the following members.

Properties

Name | Description
Color | Gets or sets the color used for tinting.

See Also

Tint Class


Color Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
Tint..::.Color Property
Tint Class See Also Send Feedback
Gets or sets the color used for tinting.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
    void set (Color value);
}

See Also

Tint Class


WarpShape Enumeration

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WarpShape Enumeration
See Also Send Feedback
Specifies the shape used for warping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public enum WarpShape
Visual Basic (Declaration)
Public Enumeration WarpShape
Visual C++
public enum class WarpShape

Members

Member name | Description
None |
CustomQuadrilateral |
Rectangle |
FadeRight |
FadeLeft |
FadeUp |
FadeDown |
SlantLeft |
SlantRight |
SlantUp |
SlantDown |
CascadeUp |
CascadeDown |
CirclePath |
SemicirclePathUp |
SemicirclePathDown |
SemicirclePathLeft |
SemicirclePathRight |

See Also

Neodynamic.SDK.ImageDraw Namespace
Neodynamic ImageDraw SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2010 Neodynamic - All rights reserved.


WordArtElement Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement Class
Members See Also Send Feedback
Represents a WordArt element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class WordArtElement : Element
Visual Basic (Declaration)
Public Class WordArtElement _
    Inherits Element
Visual C++
public ref class WordArtElement : public Element

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.Element
Neodynamic.SDK.ImageDraw..::.WordArtElement

See Also

WordArtElement Members


WordArtElement Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement Members
WordArtElement Class Constructors Methods Properties See Also Send Feedback

The WordArtElement type exposes the following members.

Constructors

Name | Description
WordArtElement | Initializes a new instance of the WordArtElement class.

Methods

Name | Description
Clone | Creates a copy of the current WordArtElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
AutoSize | Gets or sets whether this WordArtElement object is automatically resized to display its entire contents.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
ForeFill | Gets the foreground fill of the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Multiline | Gets or sets whether the text can span more than one line.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
StrokeFill | Gets the fill of the border along the outline of the text.
StrokeWidth | Gets or sets the width of the border along the outline of the text.
Text | Gets or sets the text associated with this WordArtElement object.
TextAlignment | Gets or sets the alignment of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
WordArtShape | Gets the WordArt shape.
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

WordArtElement Class


WordArtElement Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement Constructor
WordArtElement Class See Also Send Feedback
Initializes a new instance of the WordArtElement class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WordArtElement()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WordArtElement()

See Also

WordArtElement Class


WordArtElement Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement Methods
WordArtElement Class See Also Send Feedback

The WordArtElement type exposes the following members.

Methods

Name | Description
Clone | Creates a copy of the current WordArtElement. (Overrides Element..::.Clone()()().)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutputImage | Overloaded.
GetOutputImageBinary | Overloaded.
GetSize | Calculates the size of the element without applying any actions onto it. (Inherited from Element.)
GetSizeAfterActions | Calculates the new size of the element after applying the actions onto it. (Inherited from Element.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the String representation of this instance of a Element object. (Inherited from Element.)

See Also

WordArtElement Class


Clone Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.Clone Method
WordArtElement Class See Also Send Feedback
Creates a copy of the current WordArtElement.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Element Clone()
Visual Basic (Declaration)
Public Overrides Function Clone As Element
Visual C++
public:
virtual Element^ Clone() override

Return Value

A copy of the current WordArtElement.

See Also

WordArtElement Class


GetOutputImage Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.GetOutputImage Method
WordArtElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImage()()() | Returns a Bitmap object of the element. (Inherited from Element.)
GetOutputImage(Fill) | Returns a Bitmap object of the element. (Inherited from Element.)

See Also

WordArtElement Class
WordArtElement Members


GetOutputImageBinary Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.GetOutputImageBinary Method
WordArtElement Class See Also Send Feedback

Overload List

Name | Description
GetOutputImageBinary(ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)
GetOutputImageBinary(Fill, ImageDrawFormat) | Returns a byte array of the output image generated byt this element. (Inherited from Element.)

See Also

WordArtElement Class
WordArtElement Members


WordArtElement Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement Properties
WordArtElement Class See Also Send Feedback

The WordArtElement type exposes the following members.

Properties

Name | Description
Actions | Gets the Action objects that will applied on this Element object. (Inherited from Element.)
AutoSize | Gets or sets whether this WordArtElement object is automatically resized to display its entire contents.
ConvertEmptyStringToNull | Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.
Dpi | Gets or sets the resolution of the image representing this element; in dots per inch (DPI). Default value is 96. (Inherited from Element.)
Font | Gets the Font object for the text.
ForeFill | Gets the foreground fill of the text.
Height | Gets or sets the height of the element. (Inherited from Element.)
Multiline | Gets or sets whether the text can span more than one line.
Name | Gets or sets the string identifying the element. The element's name should be unique throughout the scope of the current output composite image. (Inherited from Element.)
NullDisplayText | Gets or sets the text displayed for a field when the field's value is null.
StrokeFill | Gets the fill of the border along the outline of the text.
StrokeWidth | Gets or sets the width of the border along the outline of the text.
Text | Gets or sets the text associated with this WordArtElement object.
TextAlignment | Gets or sets the alignment of the text.
Visible | Gets or sets whether this element is visible or hidden. (Inherited from Element.)
Width | Gets or sets the width of the element. (Inherited from Element.)
WordArtShape | Gets the WordArt shape.
X | Gets or sets the x-coordinate of the left side of the element (Inherited from Element.)
Y | Gets or sets the y-coordinate of the top side of the element (Inherited from Element.)

See Also

WordArtElement Class


AutoSize Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.AutoSize Property
WordArtElement Class See Also Send Feedback
Gets or sets whether this WordArtElement object is automatically resized to display its entire contents.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool AutoSize { get; set; }
Visual Basic (Declaration)
Public Property AutoSize As Boolean
Visual C++
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}

See Also

WordArtElement Class


ConvertEmptyStringToNull Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.ConvertEmptyStringToNull Property
WordArtElement Class See Also Send Feedback
Gets or sets a value indicating whether empty string values ("") are automatically converted to null values when the data field is updated in the data source.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool ConvertEmptyStringToNull { get; set; }
Visual Basic (Declaration)
Public Property ConvertEmptyStringToNull As Boolean
Visual C++
public:
property bool ConvertEmptyStringToNull {
    bool get ();
    void set (bool value);
}

See Also

WordArtElement Class


Font Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.Font Property
WordArtElement Class See Also Send Feedback
Gets the Font object for the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Font Font { get; }
Visual Basic (Declaration)
Public ReadOnly Property Font As Font
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

See Also

WordArtElement Class


ForeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.ForeFill Property
WordArtElement Class See Also Send Feedback
Gets the foreground fill of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill ForeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property ForeFill As Fill
Visual C++
public:
property Fill^ ForeFill {
    Fill^ get ();
}

See Also

WordArtElement Class


Multiline Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.Multiline Property
WordArtElement Class See Also Send Feedback
Gets or sets whether the text can span more than one line.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool Multiline { get; set; }
Visual Basic (Declaration)
Public Property Multiline As Boolean
Visual C++
public:
property bool Multiline {
    bool get ();
    void set (bool value);
}

See Also

WordArtElement Class


NullDisplayText Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.NullDisplayText Property
WordArtElement Class See Also Send Feedback
Gets or sets the text displayed for a field when the field's value is null.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string NullDisplayText { get; set; }
Visual Basic (Declaration)
Public Property NullDisplayText As String
Visual C++
public:
property String^ NullDisplayText {
    String^ get ();
    void set (String^ value);
}

See Also

WordArtElement Class


StrokeFill Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.StrokeFill Property
WordArtElement Class See Also Send Feedback
Gets the fill of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public Fill StrokeFill { get; }
Visual Basic (Declaration)
Public ReadOnly Property StrokeFill As Fill
Visual C++
public:
property Fill^ StrokeFill {
    Fill^ get ();
}

See Also

WordArtElement Class


StrokeWidth Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.StrokeWidth Property
WordArtElement Class See Also Send Feedback
Gets or sets the width of the border along the outline of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int StrokeWidth { get; set; }
Visual Basic (Declaration)
Public Property StrokeWidth As Integer
Visual C++
public:
property int StrokeWidth {
    int get ();
    void set (int value);
}

See Also

WordArtElement Class


Text Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.Text Property
WordArtElement Class See Also Send Feedback
Gets or sets the text associated with this WordArtElement object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

WordArtElement Class


TextAlignment Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.TextAlignment Property
WordArtElement Class See Also Send Feedback
Gets or sets the alignment of the text.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public ContentAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As ContentAlignment
Visual C++
public:
property ContentAlignment TextAlignment {
    ContentAlignment get ();
    void set (ContentAlignment value);
}

See Also

WordArtElement Class


WordArtShape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtElement..::.WordArtShape Property
WordArtElement Class See Also Send Feedback
Gets the WordArt shape.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WordArtShape WordArtShape { get; }
Visual Basic (Declaration)
Public ReadOnly Property WordArtShape As WordArtShape
Visual C++
public:
property WordArtShape^ WordArtShape {
    WordArtShape^ get ();
}

See Also

WordArtElement Class


WordArtShape Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape Class
Members See Also Send Feedback
Defines a WordArtShape object used to warp an element.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class WordArtShape
Visual Basic (Declaration)
Public Class WordArtShape
Visual C++
public ref class WordArtShape

Inheritance Hierarchy

System..::.Object
Neodynamic.SDK.ImageDraw..::.WordArtShape

See Also

WordArtShape Members


WordArtShape Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape Members
WordArtShape Class Constructors Methods Properties See Also Send Feedback

The WordArtShape type exposes the following members.

Constructors

Name | Description
WordArtShape | Initializes a new instance of the WordArtShape class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

Properties

Name | Description
CircleTextJustify | Gets or sets whether the text is fully justified in the circle path.
CircleTextLayout | Gets or sets how the text is layout when using Circle-based paths for warping.
CircleTextRangeAngle | Gets or sets the range angle, starting at CircleTextStartingAngle property, for the text in the circle path. It is measured counterclockwise from the x-axis.
CircleTextStartingAngle | Gets or sets the starting angle for the text in the circle path. It is measured counterclockwise from the x-axis.
QuadrilateralPoints | Gets the four points for the custom quadrilateral.
Shape | Gets or sets the shape used for warping.
ShapePercentage | Gets or sets the side percentage of the target element that will be warped. It is used for some quadrilateral shapes like Fade, Slant and Cascade. Values range from 0 to 100.

See Also

WordArtShape Class


WordArtShape Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape Constructor
WordArtShape Class See Also Send Feedback
Initializes a new instance of the WordArtShape class.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WordArtShape()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WordArtShape()

See Also

WordArtShape Class


WordArtShape Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape Methods
WordArtShape Class See Also Send Feedback

The WordArtShape type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overloaded.

See Also

WordArtShape Class


ToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.ToString Method
WordArtShape Class See Also Send Feedback

Overload List

Name | Description
ToString()()() | Converts the WordArtShape object to a string representation, using the current CultureInfo. (Overrides Object..::.ToString()()().)
ToString(CultureInfo) | Converts the WordArtShape object to a string representation, using the specified CultureInfo.

See Also

WordArtShape Class
WordArtShape Members


ToString Method

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.ToString Method
WordArtShape Class See Also Send Feedback
Converts the WordArtShape object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The string representation of the WordArtShape object in the current culture.

See Also

WordArtShape Class
ToString Overload


ToString Method (CultureInfo)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.ToString Method (CultureInfo)
WordArtShape Class See Also Send Feedback
Converts the WordArtShape object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ToString ( _
    culture As CultureInfo _
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::.CultureInfo
A CultureInfo that contains the culture to represent the WordArtShape.

Return Value

The string representation of the WordArtShape object in the specified culture.

See Also

WordArtShape Class
ToString Overload


WordArtShape Properties

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape Properties
WordArtShape Class See Also Send Feedback

The WordArtShape type exposes the following members.

Properties

Name | Description
CircleTextJustify | Gets or sets whether the text is fully justified in the circle path.
CircleTextLayout | Gets or sets how the text is layout when using Circle-based paths for warping.
CircleTextRangeAngle | Gets or sets the range angle, starting at CircleTextStartingAngle property, for the text in the circle path. It is measured counterclockwise from the x-axis.
CircleTextStartingAngle | Gets or sets the starting angle for the text in the circle path. It is measured counterclockwise from the x-axis.
QuadrilateralPoints | Gets the four points for the custom quadrilateral.
Shape | Gets or sets the shape used for warping.
ShapePercentage | Gets or sets the side percentage of the target element that will be warped. It is used for some quadrilateral shapes like Fade, Slant and Cascade. Values range from 0 to 100.

See Also

WordArtShape Class


CircleTextJustify Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.CircleTextJustify Property
WordArtShape Class See Also Send Feedback
Gets or sets whether the text is fully justified in the circle path.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public bool CircleTextJustify { get; set; }
Visual Basic (Declaration)
Public Property CircleTextJustify As Boolean
Visual C++
public:
property bool CircleTextJustify {
    bool get ();
    void set (bool value);
}

See Also

WordArtShape Class


CircleTextLayout Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.CircleTextLayout Property
WordArtShape Class See Also Send Feedback
Gets or sets how the text is layout when using Circle-based paths for warping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public CircleTextLayout CircleTextLayout { get; set; }
Visual Basic (Declaration)
Public Property CircleTextLayout As CircleTextLayout
Visual C++
public:
property CircleTextLayout CircleTextLayout {
    CircleTextLayout get ();
    void set (CircleTextLayout value);
}

See Also

WordArtShape Class


CircleTextRangeAngle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.CircleTextRangeAngle Property
WordArtShape Class See Also Send Feedback
Gets or sets the range angle, starting at CircleTextStartingAngle property, for the text in the circle path. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CircleTextRangeAngle { get; set; }
Visual Basic (Declaration)
Public Property CircleTextRangeAngle As Integer
Visual C++
public:
property int CircleTextRangeAngle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

WordArtShape Class


CircleTextStartingAngle Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.CircleTextStartingAngle Property
WordArtShape Class See Also Send Feedback
Gets or sets the starting angle for the text in the circle path. It is measured counterclockwise from the x-axis.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int CircleTextStartingAngle { get; set; }
Visual Basic (Declaration)
Public Property CircleTextStartingAngle As Integer
Visual C++
public:
property int CircleTextStartingAngle {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

WordArtShape Class


QuadrilateralPoints Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.QuadrilateralPoints Property
WordArtShape Class See Also Send Feedback
Gets the four points for the custom quadrilateral.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public QuadrilateralPoints QuadrilateralPoints { get; }
Visual Basic (Declaration)
Public ReadOnly Property QuadrilateralPoints As QuadrilateralPoints
Visual C++
public:
property QuadrilateralPoints^ QuadrilateralPoints {
    QuadrilateralPoints^ get ();
}

See Also

WordArtShape Class


Shape Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.Shape Property
WordArtShape Class See Also Send Feedback
Gets or sets the shape used for warping.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WarpShape Shape { get; set; }
Visual Basic (Declaration)
Public Property Shape As WarpShape
Visual C++
public:
property WarpShape Shape {
    WarpShape get ();
    void set (WarpShape value);
}

See Also

WordArtShape Class


ShapePercentage Property

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShape..::.ShapePercentage Property
WordArtShape Class See Also Send Feedback
Gets or sets the side percentage of the target element that will be warped. It is used for some quadrilateral shapes like Fade, Slant and Cascade. Values range from 0 to 100.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public int ShapePercentage { get; set; }
Visual Basic (Declaration)
Public Property ShapePercentage As Integer
Visual C++
public:
property int ShapePercentage {
    int get ();
    void set (int value);
}

Exceptions

Exception | Condition
System..::.ArgumentOutOfRangeException | The specified value is not range from 0 to 100.

See Also

WordArtShape Class


WordArtShapeConverter Class

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter Class
Members See Also Send Feedback
Converts WordArtShape objects from one data type to another. Access the WordArtShapeConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public class WordArtShapeConverter : ExpandableObjectConverter
Visual Basic (Declaration)
Public Class WordArtShapeConverter _
    Inherits ExpandableObjectConverter
Visual C++
public ref class WordArtShapeConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
System.ComponentModel..::.ExpandableObjectConverter
Neodynamic.SDK.ImageDraw..::.WordArtShapeConverter

See Also

WordArtShapeConverter Members


WordArtShapeConverter Members

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter Members
WordArtShapeConverter Class Constructors Methods See Also Send Feedback

The WordArtShapeConverter type exposes the following members.

Constructors

Name | Description
WordArtShapeConverter | Initializes a new instance of the WordArtShapeConverter class

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordArtShapeConverter Class


WordArtShapeConverter Constructor

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter Constructor
WordArtShapeConverter Class See Also Send Feedback
Initializes a new instance of the WordArtShapeConverter class

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public WordArtShapeConverter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WordArtShapeConverter()

See Also

WordArtShapeConverter Class


WordArtShapeConverter Methods

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter Methods
WordArtShapeConverter Class See Also Send Feedback

The WordArtShapeConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Overloaded.
CanConvertTo | Overloaded.
ConvertFrom | Overloaded.
ConvertFromInvariantString | Overloaded.
ConvertFromString | Overloaded.
ConvertTo | Overloaded.
ConvertToInvariantString | Overloaded.
ConvertToString | Overloaded.
CreateInstance | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetConvertFromException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetConvertToException | Returns an exception to throw when a conversion cannot be performed. (Inherited from TypeConverter.)
GetCreateInstanceSupported | Overloaded.
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetProperties | Overloaded.
GetPropertiesSupported | Overloaded.
GetStandardValues | Overloaded.
GetStandardValuesExclusive | Overloaded.
GetStandardValuesSupported | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsValid | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortProperties | Sorts a collection of properties. (Inherited from TypeConverter.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WordArtShapeConverter Class


CanConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.CanConvertFrom Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertFrom(Type) | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertFrom(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertFrom(ITypeDescriptorContext, Type).)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


CanConvertFrom Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.CanConvertFrom Method (ITypeDescriptorContext, Type)
WordArtShapeConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertFrom ( _
    context As ITypeDescriptorContext, _
    sourceType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
sourceType
Type: System..::.Type

See Also

WordArtShapeConverter Class
CanConvertFrom Overload


CanConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.CanConvertTo Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
CanConvertTo(Type) | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
CanConvertTo(ITypeDescriptorContext, Type) | (Overrides TypeConverter..::.CanConvertTo(ITypeDescriptorContext, Type).)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


CanConvertTo Method (ITypeDescriptorContext, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.CanConvertTo Method (ITypeDescriptorContext, Type)
WordArtShapeConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function CanConvertTo ( _
    context As ITypeDescriptorContext, _
    destinationType As Type _
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
destinationType
Type: System..::.Type

See Also

WordArtShapeConverter Class
CanConvertTo Overload


ConvertFrom Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertFrom Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFrom(Object) | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFrom(ITypeDescriptorContext, CultureInfo, Object) | (Overrides TypeConverter..::.ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertFrom Method (ITypeDescriptorContext, CultureInfo, Object)
WordArtShapeConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic (Declaration)
Public Overrides Function ConvertFrom ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object _
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object

See Also

WordArtShapeConverter Class
ConvertFrom Overload


ConvertFromInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertFromInvariantString Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromInvariantString(String) | Converts the given string to the type of this converter, using the invariant culture. (Inherited from TypeConverter.)
ConvertFromInvariantString(ITypeDescriptorContext, String) | Converts the given string to the type of this converter, using the invariant culture and the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


ConvertFromString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertFromString Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertFromString(String) | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, String) | Converts the given text to an object, using the specified context. (Inherited from TypeConverter.)
ConvertFromString(ITypeDescriptorContext, CultureInfo, String) | Converts the given text to an object, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


ConvertTo Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertTo Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertTo(Object, Type) | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type) | (Overrides TypeConverter..::.ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)

[image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertTo Method (ITypeDescriptorContext, CultureInfo, Object, Type)
WordArtShapeConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.ImageDraw
Assembly: Neodynamic.SDK.ImageDraw (in Neodynamic.SDK.ImageDraw.dll) Version: 3.0.2000.0 (3.0.2000.0)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic (Declaration)
Public Overrides Function ConvertTo ( _
    context As ITypeDescriptorContext, _
    culture As CultureInfo, _
    value As Object, _
    destinationType As Type _
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::.ITypeDescriptorContext
culture
Type: System.Globalization..::.CultureInfo
value
Type: System..::.Object
destinationType
Type: System..::.Type

See Also

WordArtShapeConverter Class
ConvertTo Overload


ConvertToInvariantString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertToInvariantString Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToInvariantString(Object) | Converts the specified value to a culture-invariant string representation. (Inherited from TypeConverter.)
ConvertToInvariantString(ITypeDescriptorContext, Object) | Converts the specified value to a culture-invariant string representation, using the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


ConvertToString Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.ConvertToString Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
ConvertToString(Object) | Converts the specified value to a string representation. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, Object) | Converts the given value to a string representation, using the given context. (Inherited from TypeConverter.)
ConvertToString(ITypeDescriptorContext, CultureInfo, Object) | Converts the given value to a string representation, using the specified context and culture information. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


CreateInstance Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.CreateInstance Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
CreateInstance(IDictionary) | Re-creates an Object given a set of property values for the object. (Inherited from TypeConverter.)
CreateInstance(ITypeDescriptorContext, IDictionary) | Creates an instance of the type that this TypeConverter is associated with, using the specified context, given a set of property values for the object. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetCreateInstanceSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetCreateInstanceSupported Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetCreateInstanceSupported()()() | Returns whether changing a value on this object requires a call to the CreateInstance(IDictionary) method to create a new value. (Inherited from TypeConverter.)
GetCreateInstanceSupported(ITypeDescriptorContext) | Returns whether changing a value on this object requires a call to CreateInstance(IDictionary) to create a new value, using the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetProperties Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetProperties Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetProperties(Object) | Returns a collection of properties for the type of array specified by the value parameter. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object) | Returns a collection of properties for the type of array specified by the value parameter, using the specified context. (Inherited from TypeConverter.)
GetProperties(ITypeDescriptorContext, Object, array<Attribute>[]()[]) | Gets a collection of properties for the type of object specified by the value parameter. (Inherited from ExpandableObjectConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetPropertiesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetPropertiesSupported Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetPropertiesSupported()()() | Returns whether this object supports properties. (Inherited from TypeConverter.)
GetPropertiesSupported(ITypeDescriptorContext) | Gets a value indicating whether this object supports properties using the specified context. (Inherited from ExpandableObjectConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetStandardValues Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetStandardValues Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValues()()() | Returns a collection of standard values from the default context for the data type this type converter is designed for. (Inherited from TypeConverter.)
GetStandardValues(ITypeDescriptorContext) | Returns a collection of standard values for the data type this type converter is designed for when provided with a format context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetStandardValuesExclusive Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetStandardValuesExclusive Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesExclusive()()() | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list. (Inherited from TypeConverter.)
GetStandardValuesExclusive(ITypeDescriptorContext) | Returns whether the collection of standard values returned from GetStandardValues()()() is an exclusive list of possible values, using the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


GetStandardValuesSupported Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.GetStandardValuesSupported Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
GetStandardValuesSupported()()() | Returns whether this object supports a standard set of values that can be picked from a list. (Inherited from TypeConverter.)
GetStandardValuesSupported(ITypeDescriptorContext) | Returns whether this object supports a standard set of values that can be picked from a list, using the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


IsValid Method

[image] [image]

Neodynamic ImageDraw SDK for .NET Class Reference
WordArtShapeConverter..::.IsValid Method
WordArtShapeConverter Class See Also Send Feedback

Overload List

Name | Description
IsValid(Object) | Returns whether the given value object is valid for this type. (Inherited from TypeConverter.)
IsValid(ITypeDescriptorContext, Object) | Returns whether the given value object is valid for this type and for the specified context. (Inherited from TypeConverter.)

See Also

WordArtShapeConverter Class
WordArtShapeConverter Members


Technical Support

Neodynamic ImageDraw SDK for .NET
Neodynamic Technical Support
When you purchase a licensed version of Neodynamic ImageDraw SDK for .NET you get access to FREE technical support.
Technical Support can be reached by email at support@neodynamic.com.

Before contacting technical support we recommend:
  • Read the product documentation.
  • Read FAQ at Neodynamic Website.
For more information about technical support visit www.neodynamic.com/support.

Visit Neodynamic's website.
Neodynamic ImageDraw SDK for .NET Documentation
Copyright © 2003 - 2008 Neodynamic - All rights reserved.