About Neodynamic Barcode Professional for XAML WinRT

Neodynamic Barcode Professional for XAML WinRT
What is Neodynamic Barcode Professional for XAML WinRT?
Neodynamic Barcode Professional for XAML WinRT is a lightweight dll component which generates high quality vector-based barcodes for XAML WinRT Windows Store Apps. Barcode Professional for XAML WinRT was designed and written from ground up to take advantage of WinRT API allowing software developers to add barcode generation and printing capabilities to Windows Store apps.

Barcode Professional is fully integrated with Microsoft Visual Studio 2012 products including Visual Studio 2012 Express for Windows 8.
Main Features
  • Can generate Linear and 2D Barcode Symbologies.
  • High Quality Vector-based barcode generation leveraging WinRT API.
  • Barcode rotation support (0, 90, 180, 270 degrees)
  • Automatically computes the checksum or check digits.
  • Automatically validates the value to encode.
  • No complex configurations.
  • Full design-time support for Visual Studio 2012 and VS 2012 Express for Windows 8.
  • Intellisense® support at Source Code and XAML Views.
Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Barcode Professional for XAML WinRT - Getting Started

Neodynamic Barcode Professional for XAML WinRT
Barcode Professional for XAML WinRT - Getting Started
  • System Requirements
  • Visual Studio 2012 and Express Edition for Windows 8 Toolbox Configuration
  • Render barcodes in Windows Store apps in few simple steps

    • Open the xaml file where you want to display the barcode
    • Drag & drop Barcode Professional from VS toolbox onto it
    • In the XAML View or Code-behind class just set the Symbology property to the barcode type you want to generate and the Code property to the value you want to encode. You can also change the barcode dimensions by using BarWidth, BarHeight, and other properties.
    • That's it! Test your app. NOTE: If the barcode is not displayed, then be sure the value you have specified to the Code property matches the barcode symbology requirements. Read more about each barcode symbology.

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


System Requirements

Neodynamic Barcode Professional for XAML WinRT
System Requirements
For developing applications with Neodynamic Barcode Professional for XAML WinRT, you must have the following system and software specifications:

• Microsoft Visual Studio 2012, or
• Microsoft Visual Studio 2012 Express for Windows 8

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Visual Studio 2008 Configuration

Neodynamic Barcode Professional for XAML WinRT
Microsoft Visual Studio 2012 & Express for Windows 8 Editions Configuration
  • Launch Visual Studio 2012 or Express Editions for Windows 8.
  • Create a new Windows Store Application project.
  • Open the Toolbox, right-click on it, and select Choose Items.
  • Select the Windows XAML Components tab.
    • Click on Browse button, and navigate to the folder you installed Barcode Professional for XAML WinRT.
    • Browse to the Bin folder, and select Neodynamic.WinRT.Barcode.dll from that dialog, and click on Open.
    • You should get BarcodeProfessional listed. Click on OK button.
  • The Barcode Professional control should now appear in the Toolbox. You can now drag & drop it onto any XAML file.

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


License Registration

Neodynamic Barcode Professional for XAML WinRT
License Registration
When you buy a commercial version of Neodynamic Barcode Professional for XAML WinRT you are provided with license information to register your licensed copy of Neodynamic Barcode Professional.

The registration process is very simple. In the class you're using Barcode Professional, set the LicenseOwner and LicenseKey static (shared in VB) properties with the license info you've received.
IMPORTANT
Please, keep in mind that the license info is case-sensitive!

VB.NET
' XAML WinRT App SAMPLE

Imports Neodynamic.WinRT

Partial Class MainPage
    Inherits Page

    Sub New

     ' Set up license info...
         BarcodeProfessional.LicenseOwner = "LICENSE-OWNER"
         BarcodeProfessional.LicenseKey = "LICENSE-KEY"

    End Sub
End Class

C#
// XAML WinRT App SAMPLE

using Neodynamic.WinRT;

public partial class MainPage : Page
{
    public MainPage()
    {
        // Set up license info...
        BarcodeProfessional.LicenseOwner = "LICENSE-OWNER";
        BarcodeProfessional.LicenseKey = "LICENSE-KEY";
    }
}
After you set these properties the TRIAL legend should disappear from the generated barcode.

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Trial Version

Neodynamic Barcode Professional for XAML WinRT
Trial Version
The Trial Version of Neodynamic Barcode Professional for XAML WinRT is fully functional and has no expiry date. The only limitation it has is that a TRIAL legend will appear on the generated barcode.

When you buy a licensed version of Barcode Professional you will receive license information to register your copy of Barcode Professional for XAML WinRT. For more information about the registration process view License Registration topic.

Distribution restrictions

If you are using a Trial Version, you should not distribute any of the files provided with it.

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Barcode Symbologies

Neodynamic Barcode Professional for XAML WinRT
General Barcode Symbology background information

What are Barcode Symbologies?
"A bar code (also barcode) is an optical machine-readable representation of data. Originally, bar codes represented data in the widths (lines) and the spacings of parallel lines and may be referred to as linear or 1D (1 dimensional) barcodes or symbologies. But they also come in patterns of squares, dots, hexagons and other geometric patterns within images termed 2D (2 dimensional) matrix codes or symbologies. In spite of there being no bars, 2D systems are generally referred to as barcodes as well." Wikipedia, The Free Encyclopedia.

Barcode Professional supports many of the most popular Barcode Symbologies available today, Linear (1D) and 2D Symbologies.

Barcode Symbologies supported by Barcode Professional for XAML WinRT
  • Aztec Code a.k.a. AIM Aztec Barcode, ANSI/AIM BC13 ITS/97/002
  • Code 128 a.k.a. ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C
  • Code 39 a.k.a. ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII
  • Code 93 a.k.a. ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII
  • Compact PDF417 a.k.a. Compact Portable Data File 417, Compact PDF 417, PDF417 Truncated
  • Data Matrix a.k.a. Data Matrix ECC200
  • EAN-13 a.k.a. European Article Number 13, EAN-13 Supplement 5/Five-digit Add-On, EAN-13 Supplement 2/Two-digit Add-On, EAN-13+5, EAN-13+2, EAN13, EAN13+5, EAN13+2, UPC-13, GTIN-13, GS1-13, EAN/UCC-13
  • EAN-13 CC-A a.k.a. EAN-13 Composite Barcode A, EAN-13 CC-A (CCA), EAN-13 Composite A, EAN-13 2D Composite A, EAN-13 Composite Component A
  • EAN-13 CC-B a.k.a. EAN-13 Composite Barcode B, EAN-13 CC-B (CCB), EAN-13 Composite B, EAN-13 2D Composite B, EAN-13 Composite Component B
  • EAN-8 a.k.a. European Article Number 8, EAN-8 Supplement 5/Five-digit Add-On, EAN-8 Supplement 2/Two-digit Add-On, EAN-8+5, EAN-8+2, EAN8, EAN8+5, EAN13+2, UPC-8, GTIN-8, GS1-8, EAN/UCC-8
  • EAN-8 CC-A a.k.a. EAN-8 Composite Barcode A, EAN-8 CC-A (CCA), EAN-8 Composite A, EAN-8 2D Composite A, EAN-8 Composite Component A
  • EAN-8 CC-B a.k.a. EAN-8 Composite Barcode B, EAN-8 CC-B (CCB), EAN-8 Composite B, EAN-8 2D Composite B, EAN-8 Composite Component B
  • EAN-99 a.k.a. European Article Number 99, EAN-99 Supplement 5/Five-digit Add-On, EAN-99 Supplement 2/Two-digit Add-On, EAN-99+5, EAN-99+2, EAN99, EAN99+5, EAN99+2, GTIN-99, GS1-99, Coupon Barcode
  • EAN-Velocity a.k.a. Velocity Barcode
  • GS1 DataBar Expanded (Formerly RSS Expanded - Reduced Space Symbology) barcode a.k.a. GS1 DataBar-14 Expanded, RSS Expanded, Reduced Space Symbology Expanded
  • GS1 DataBar Expanded (Formerly RSS Expanded - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar Expanded Composite Barcode A, GS1 DataBar Expanded CC-A (CCA), GS1 DataBar Expanded Composite A, GS1 DataBar Expanded 2D Composite A, GS1 DataBar Expanded Composite Component A
  • GS1 DataBar Expanded (Formerly RSS Expanded - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar Expanded Composite Barcode B, GS1 DataBar Expanded CC-B (CCB), GS1 DataBar Expanded Composite B, GS1 DataBar Expanded 2D Composite B, GS1 DataBar Expanded Composite Component B
  • GS1 DataBar Expanded Stacked (Formerly RSS Expanded Stacked - Reduced Space Symbology) barcode a.k.a. GS1 DataBar-14 Expanded Stacked , RSS Expanded Stacked , Reduced Space Symbology Expanded Stacked
  • GS1 DataBar Expanded Stacked (Formerly RSS Expanded Stacked - Reduced Space Symbology) CC-A Composite Barcode a.k.a. GS1 DataBar Expanded Stacked Composite Barcode A, GS1 DataBar Expanded Stacked CC-A (CCA), GS1 DataBar Expanded Stacked Composite A, GS1 DataBar Expanded Stacked 2D Composite A, GS1 DataBar Expanded Stacked Composite Component A
  • GS1 DataBar Expanded Stacked (Formerly RSS Expanded Stacked - Reduced Space Symbology) CC-B Composite Barcode a.k.a. GS1 DataBar Expanded Stacked Composite Barcode B, GS1 DataBar Expanded Stacked CC-B (CCB), GS1 DataBar Expanded Stacked Composite B, GS1 DataBar Expanded Stacked 2D Composite B, GS1 DataBar Expanded Stacked Composite Component B
  • GS1 DataBar Limited (Formerly RSS Limited - Reduced Space Symbology) barcode a.k.a. GS1 DataBar-14 Limited, RSS Limited, Reduced Space Symbology Limited
  • GS1 DataBar Limited (Formerly RSS Limited - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar Limited Composite Barcode A, GS1 DataBar Limited CC-A (CCA), GS1 DataBar Limited Composite A, GS1 DataBar Limited 2D Composite A, GS1 DataBar Limited Composite Component A
  • GS1 DataBar Limited (Formerly RSS Limited - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar Limited Composite Barcode B, GS1 DataBar Limited CC-B (CCB), GS1 DataBar Limited Composite B, GS1 DataBar Limited 2D Composite B, GS1 DataBar Limited Composite Component B
  • GS1 DataBar Omnidirectional/GS1 DataBar-14 (Formerly RSS-14 - Reduced Space Symbology) barcode a.k.a. RSS14, Reduced Space Symbology 14, GS1 DataBar-14
  • GS1 DataBar Omnidirectional/GS1 DataBar-14 (Formerly RSS-14 - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar-14 Composite Barcode A, GS1 DataBar-14 CC-A (CCA), GS1 DataBar-14 Composite A, GS1 DataBar-14 2D Composite A, GS1 DataBar-14 Composite Component A
  • GS1 DataBar Omnidirectional/GS1 DataBar-14 (Formerly RSS-14 - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar-14 Composite Barcode B, GS1 DataBar-14 CC-B (CCB), GS1 DataBar-14 Composite B, GS1 DataBar-14 2D Composite B, GS1 DataBar-14 Composite Component B
  • GS1 DataBar-14 Stacked (Formerly RSS-14 Stacked - Reduced Space Symbology) barcode a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
  • GS1 DataBar-14 Stacked (Formerly RSS-14 Stacked - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar-14 Stacked Composite Barcode A, GS1 DataBar-14 Stacked CC-A (CCA), GS1 DataBar-14 Stacked Composite A, GS1 DataBar-14 Stacked 2D Composite A, GS1 DataBar-14 Stacked Composite Component A
  • GS1 DataBar-14 Stacked (Formerly RSS-14 Stacked - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar-14 Stacked Composite Barcode B, GS1 DataBar-14 Stacked CC-B (CCB), GS1 DataBar-14 Stacked Composite B, GS1 DataBar-14 Stacked 2D Composite B, GS1 DataBar-14 Stacked Composite Component B
  • GS1 DataBar-14 Stacked Omnidirectional (Formerly RSS-14 Stacked Omnidirectional - Reduced Space Symbology) barcode a.k.a. RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional, GS1 DataBar Stacked Omnidirectional
  • GS1 DataBar-14 Stacked Omnidirectional (Formerly RSS-14 Stacked Omnidirectional - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar-14 Stacked Omnidirectional Composite Barcode A, GS1 DataBar-14 Stacked Omnidirectional CC-A (CCA), GS1 DataBar-14 Stacked Omnidirectional Composite A, GS1 DataBar-14 Stacked Omnidirectional 2D Composite A, GS1 DataBar-14 Stacked Omnidirectional Composite Component A
  • GS1 DataBar-14 Stacked Omnidirectional (Formerly RSS-14 Stacked Omnidirectional - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar-14 Stacked Omnidirectional Composite Barcode B, GS1 DataBar-14 Stacked Omnidirectional CC-B (CCB), GS1 DataBar-14 Stacked Omnidirectional Composite B, GS1 DataBar-14 Stacked Omnidirectional 2D Composite B, GS1 DataBar-14 Stacked Omnidirectional Composite Component B
  • GS1 DataBar-14 Truncated (Formerly RSS-14 Truncated - Reduced Space Symbology) barcode a.k.a. GS1 DataBar Truncated, RSS-14 Truncated, Reduced Space Symbology 14 Truncated
  • GS1 DataBar-14 Truncated (Formerly RSS-14 Truncated - Reduced Space Symbology) CC-A Composite barcode a.k.a. GS1 DataBar-14 Truncated Composite Barcode A, GS1 DataBar-14 Truncated CC-A (CCA), GS1 DataBar-14 Truncated Composite A, GS1 DataBar-14 Truncated 2D Composite A, GS1 DataBar-14 Truncated Composite Component A
  • GS1 DataBar-14 Truncated (Formerly RSS-14 Truncated - Reduced Space Symbology) CC-B Composite barcode a.k.a. GS1 DataBar-14 Truncated Composite Barcode B, GS1 DataBar-14 Truncated CC-B (CCB), GS1 DataBar-14 Truncated Composite B, GS1 DataBar-14 Truncated 2D Composite B, GS1 DataBar-14 Truncated Composite Component B
  • GS1 DataMatrix a.k.a. GS1 Data Matrix ECC200
  • GS1-128 (formerly UCC/EAN-128) Barcode a.k.a. EAN-128, UCC-128, USS-128, GS1 128, UCC.EAN-128, GTIN-128, UCC-12, EAN/UCC-13, EAN/UCC-14
  • GS1-128 (formerly UCC/EAN-128) CC-A a.k.a. GS1-128 Composite Barcode A, GS1-128 CC-A (CCA), GS1-128 Composite A, GS1-128 2D Composite A, GS1-128 Composite Component A
  • GS1-128 (formerly UCC/EAN-128) CC-B a.k.a. GS1-128 Composite Barcode B, GS1-128 CC-B (CCB), GS1-128 Composite B, GS1-128 2D Composite B, GS1-128 Composite Component B
  • GS1-128 (formerly UCC/EAN-128) CC-C a.k.a. GS1-128 Composite Barcode C, GS1-128 CC-C (CCC), GS1-128 Composite C, GS1-128 2D Composite C, GS1-128 Composite Component C
  • IATA 2 of 5 a.k.a. 2 of 5 IATA, 2/5 IATA, International Air Transport Assosiation 2 of 5
  • Industrial 2 of 5 a.k.a. 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5
  • Interleaved 2 of 5 a.k.a. ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved
  • ISBN a.k.a. International Standard Book Number, Bookland EAN, ISBN-13, ISBN-10, ISBN+5, ISBN+2, ISBN Supplement 5/Five-digit Add-On, ISBN Supplement 2/Two-digit Add-On
  • ISMN a.k.a. International Standard Music Number, ISMN-13, ISMN-10, ISMN+5, ISMN+2, ISMN Supplement 5/Five-digit Add-On, ISMN Supplement 2/Two-digit Add-On, ISO 10957
  • ISSN a.k.a. International Standard Serial Number, ISSN-13, ISSN-10, ISSN+5, ISSN+2, ISSN Supplement 5/Five-digit Add-On, ISSN Supplement 2/Two-digit Add-On
  • ITF-14 a.k.a. UPC Shipping Container Symbol ITF-14, ITF14, Case Code, UPC Case Code, EAN/UCC-14, EAN-14, UCC-14, DUN-14, GTIN-14
  • JAN-13 a.k.a. Japanese Article Number 13, JAN-13 Supplement 5/Five-digit Add-On, JAN-13 Supplement 2/Two-digit Add-On, JAN-13+5, JAN-13+2, JAN13, JAN13+5, JAN13+2
  • JAN-8 a.k.a. Japanese Article Number 8, JAN-8 Supplement 5/Five-digit Add-On, JAN-8 Supplement 2/Two-digit Add-On, JAN-8+5, JAN-8+2, JAN8, JAN8+5, JAN8+2
  • Macro PDF417 a.k.a. Macro Portable Data File 417, Macro PDF 417, MacroPDF417
  • Matrix 2 of 5 a.k.a. 2 of 5 Matrix, 2/5 Matrix
  • MaxiCode a.k.a. UPS MaxiCode, Maxi Code, UPS barcode, United Parcel Service MaxiCode
  • Micro PDF417 a.k.a. Micro Portable Data File 417, Micro PDF 417, MicroPDF417
  • Micro QR Code (Micro Quick Response Code) a.k.a. Denso Micro Barcode, Micro QRCode, Micro Quick Response Code, Micro QRCode Model 2, JIS X 0510, ISO/IEC18004
  • PDF417 a.k.a. Portable Data File 417, PDF 417, PDF417 Truncated
  • QR Code a.k.a. Denso Barcode, QRCode, Quick Response Code, JIS X 0510, ISO/IEC18004
  • SCC-14 a.k.a. Shipping Container Code, EAN/UCC 14, DUN-14, EAN-14, UCC-14, UPC Case Code, UPC Shipping Container Code, Distribution Unit Number 14, SCC14, DUN14, EAN14, UCC14, EAN/UCC-14, Despatch Unit Number 14, GTIN-14
  • Semacode a.k.a. URL Barcodes, Semacode Tag
  • SSCC-18 a.k.a. UPC-128 Shipping Container Code, Code 128 UPC Shipping Container Code, Serial Shipping Container Code, UCC-128, EAN-18, NVE (Nummer der Versandeinheit)
  • UCC/EAN-128 a.k.a. EAN-128, UCC-128, USS-128, GS1-128, UCC.EAN-128, GTIN-128
  • UCC/EAN-128 (now GS1-128) CC-A a.k.a. UCC/EAN-128 Composite Barcode A, UCC/EAN-128 CC-A (CCA), UCC/EAN-128 Composite A, UCC/EAN-128 2D Composite A, UCC/EAN-128 Composite Component A
  • UCC/EAN-128 (now GS1-128) CC-B a.k.a. UCC/EAN-128 Composite Barcode B, UCC/EAN-128 CC-B (CCB), UCC/EAN-128 Composite B, UCC/EAN-128 2D Composite B, UCC/EAN-128 Composite Component B
  • UCC/EAN-128 (now GS1-128) CC-C a.k.a. UCC/EAN-128 Composite Barcode C, UCC/EAN-128 CC-C (CCC), UCC/EAN-128 Composite C, UCC/EAN-128 2D Composite C, UCC/EAN-128 Composite Component C
  • UPC-A a.k.a. Universal Product Code version A, UPC-A Supplement 5/Five-digit Add-On, UPC-A Supplement 2/Two-digit Add-On, UPC-A+5, UPC-A+2, UPC Code, UPC Symbol, GTIN-12, GS1-12, UCC-12
  • UPC-A CC-A a.k.a. UPC-A Composite Barcode A, UPC-A CC-A (CCA), UPC-A Composite A, UPC-A 2D Composite A, UPC-A Composite Component A
  • UPC-A CC-B a.k.a. UPC-A Composite Barcode B, UPC-A CC-B (CCB), UPC-A Composite B, UPC-A 2D Composite B, UPC-A Composite Component B
  • UPC-E a.k.a. Universal Product Code version E, UPC-E Supplement 5/Five-digit Add-On, UPC-E Supplement 2/Two-digit Add-On, UPC-E+5, UPC-E+2, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead 0, GS1-12, UCC-12
  • UPC-E CC-A a.k.a. UPC-E Composite Barcode A, UPC-E CC-A (CCA), UPC-E Composite A, UPC-E 2D Composite A, UPC-E Composite Component A
  • UPC-E CC-B a.k.a. UPC-E Composite Barcode B, UPC-E CC-B (CCB), UPC-E Composite B, UPC-E 2D Composite B, UPC-E Composite Component B

Visit Neodynamic's website.

Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Aztec Code Barcode

This Symbology is also known as Aztec Barcode, ANSI/AIM BC13 ITS/97/002

Overview
Aztec Code is a two-dimensional matrix symbology containing dark and light square data modules. It has a finder pattern of concentric square rings centered on a single dark module located in the center of the symbol. A two-dimensional imaging device such as a CCD camera is necessary to scan the symbology. Aztec Code can encode all 8-bit values (0-127 ASCII and 128-255 ISO 8859-1, Latin Alphabet No.1) and performs Reed Solomon Error Correction based on user-selectable percentages (5% to 95%). Aztec Code is used for small item marking applications using a wide variety of printing and marking technologies.

Aztec Code implementation in Barcode Professional supports FNC1, Extended Channel Interpretation (ECI) and "Aztec Runes" which is a series of 256 small machine-readable marks compatible with Aztec Code, available for special applications.

Aztec Code Barcode

How to create Aztec Code barcodes using Barcode Professional

Note: Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Aztec Code barcode image, please follow these steps:
  • Set the Symbology property to AztecCode.
  • Set the AztecCodeFormat property.
  • Set the AztecCodeErrorCorrection property.
  • Set the AztecCodeRune property if needed to a value from 0 up to 255.
  • Setting up dimensions and quiet zones:
    • Set the AztecCodeModuleSize property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • If desired, you can use the tilde character "~" to specify special characters in the input data. To do that you must set the AztecCodeProcessTilde property to True. Read more about how it works.
How Actec Code tilde processing works
When working with Aztec Code tilde processing keep in mind the following rules:
  • ~1: is used to represent the FNC1 code
  • ~7NNNNNN: is used to specify the Extended Channel Interpretation (ECI) and NNNNNN is a value between 000000 and 999999. Default is ECI 000003 which represents the ISO 8859-1 Latin Alphabet No. 1
  • ~dNNN: is used to represent a byte value in decimal notation. NNN must be a numeric value ranging from 000 to 255
  • ~hXX: is used to represent a byte value in hexadecimal notation. XX must be a hexadecimal value ranging from 00 to FF
Example of Aztec Code barcode images
Code property = ABC 123456789 will produce the following barcode image:
Code property = My Tradermak® and Copyright© will produce the following barcode image:


Code 128 Barcode

This Symbology is also known as ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C

Overview
Code 128 is a linear bar code symbology capable of encoding the full 128-character ASCII character set and extended character sets. This Symbology includes a checksum digit for verification, and the barcode may also be verified character-by-character verifying the parity of each data byte. It has been widely implemented in many applications where a relatively large amount of data must be encoded in a relatively small amount of space.
Code 128 Code Sets
  • Code Set A (or Chars Set A) includes all of the standard upper case U.S. alphanumeric keyboard characters and punctuation characters together with the control characters, (i.e. characters with ASCII values from 0 to 95 inclusive), and seven special characters.
  • Code Set B (or Chars Set B) includes all of the standard upper case alphanumeric keyboard characters and punctuation characters together with the lower case alphabetic characters (i.e. characters with ASCII values from 32 to 127 inclusive), and seven special characters.
  • Code Set C (or Chars Set C) includes the set of 100 digit pairs from 00 to 99 inclusive, as well as three special characters. This allows numeric data to be encoded as two data digits per symbol character, at effectively twice the density of standard data.
Code 128 Special characters
The last seven characters of Code Sets A and B (character values 96 - 102) and the last three characters of Code Set C (character values 100 - 102) are special non-data characters with no ASCII character equivalents, which have particular significance to the bar code reading device.

Sample of a Code 128 Barcode

Sample of a Code 128 Barcode with Bearer Bars

How to create Code 128 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 128 barcode image, please follow these steps:
  • Set the Symbology property to Code128
  • Set the Code128CharSet property to one of the following values depending on your needs:
    • Auto: Barcode Professional will automatically switch between code sets to encode the ASCII values.
    • A: Barcode Professional will use the Char Set A which only supports ASCII values from 0 to 95
    • B: Barcode Professional will use the Char Set B which only supports ASCII values from 32 to 127
    • C: Barcode Professional will use the Char Set C which only supports pairs of digits
    • Barcode Professional allows explicit switching between Code 128 Char Sets. Read more about how it works.
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
  • Barcode Professional will automatically generate and append the checksum value.
    • Note: In this Symbology the checksum won't appear in the human readable text.
    • Tip: You can disable this behavior by setting up to False the AddChecksum property.
Example of a Code 128 barcode images
Code property = ABCD 12345 abcd and Code128CharSet property = Auto will produce the following barcode image:
Code property = ABCD 12345 abcd and Code128CharSet property = Auto and BearerBarStyle property = Frame and HorizontalRules will produce the following barcode images:
Code property = ABCD 12345 and Code128CharSet property = A will produce the following barcode image:
Code property = 12345 abcd and Code128CharSet property = B will produce the following barcode image:
Code property = 001122334455 abcd and Code128CharSet property = C will produce the following barcode image:
Explicit switching between Code 128 Char Sets
You can handle how the data must be encoded specifying some special chars that represent each Code 128 Char Set. The special chars that tell to Barcode Professional what Code Set must be used to encode the data that follows it are these:
  • É (Alt+0201) which indicates that the Char Set to use must be A
  • Ê (Alt+0202) which indicates that the Char Set to use must be B
  • Ë (Alt+0203) which indicates that the Char Set to use must be C
Important Note: When you specify that the data must be encoded using Char Set C, then the number of chars after it must be even!
Example of explicit switching between Code 128 Code Sets
Suppose you need to encode 3 alpha chars using Char Set A and 10 numeric digits using Char Set C. You can get it by setting up the following properties:
  • Set the Symbology property to Code128
  • Set the Code128CharSet property to Auto
  • Set the Code property to ÉABCË1234567890 (Notice the É (Alt+0201) char indicating that the data that follows it must be encoded using Char Set A, and the Ë (Alt+0203) char indicating that the data that follows it must be encoded using Char Set C)


Code 39 Barcode

This Symbology is also known as ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII

Overview
Code 39, the first alpha-numeric symbology to be developed, is still widely used-especially in non-retail environments. It is suitable for encoding general purpose alphanumeric data.
Code 39 is a discrete, variable-length symbology. It is self-checking in that a single print defect cannot transpose one character into another valid character. It is the standard barcode used by the United States Department of Defense, and is also used by the Health Industry Bar Code Council (HIBCC).
What kind of data can be encoded by Code 39?
  • The Standard Mode (Default implementation) can encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +
  • The Full ASCII Mode or Extended Version can encode all 128 ASCII characters
The * (asterisk) is not a true encodable character, but is the start and stop 'symbol' for Code 39.

Sample of a Code 39 Barcode

How to create Code 39 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 39 barcode image, please follow these steps:
  • Set the Symbology property to Code39
  • Set the AddChecksum property to False
  • By default, Code 39 can only encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +. If you need to encode all 128 ASCII characters, please set the Extended property to True
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • Code 39 utilizes asterisk characters as Start & Stop symbols and they are shown in the human readable text of a barcode image. You can rid of those characters from the human readable text by setting up the DisplayStartStopChar property to False
Example of Code 39 barcode images
Code property = ABC 123456789 will produce the following barcode image:
Code property = (abc) 123456789 and Extended property = True will produce the following barcode image:


Code 93 Barcode

This Symbology is also known as ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII

Overview
Code 93 was designed to complement and improve upon Code 39. Code 93 is similar in that it, like Code 39, can represent the full ASCII character set by using combinations of 2 characters.
It differs in that Code 93 is a continous, variable-length symbology and produces denser code.
Code 93 offers higher information density for alphanumeric data than either Code 39 or Code 128.
What kind of data can be encoded by Code 93?
  • The Standard Mode (Default implementation) can encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +
  • The Full ASCII Mode or Extended Version can encode all 128 ASCII characters
The * (asterisk) is not a true encodable character, but is the start and stop 'symbol' for Code 93.

Sample of a Code 93 Barcode

How to create Code 93 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 93 barcode image, please follow these steps:
  • Set the Symbology property to Code93
  • Set the AddChecksum property to False
  • By default, Code 93 can only encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +. If you need to encode all 128 ASCII characters, please set the Extended property to True
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • Code 93 utilizes asterisk characters as Start & Stop symbols and they are shown in the human readable text of a barcode image. You can rid of those characters from the human readable text by setting up the DisplayStartStopChar property to False
Example of Code 93 barcode images
Code property = ABC 123456789 will produce the following barcode image:
Code property = (abc) 123456789 and Extended property = True will produce the following barcode image:


Compact PDF417 Barcode

This Symbology is also known as Compact Portable Data File 417, Compact PDF 417, PDF417 Truncated

Overview
Compact PDF417, or Compact Portable Data File 417, has the same features as PDF417 standard. However, Compact PDF417 may be used where space considerations are a primary concern and symbol damage is unlikely. In an environment where label damage is unlikely (e.g. an office), the right row indicators, that PDF417 Symbols feature, may be omitted and the stop pattern may be reduced to one module width bar. This procedure reduces the non-data overhead from 4 codewords per row to 2 codewords per row, with some trade-off in decode performance and robustness, or the ability to withstand noise, damage, degradation, dust etc. This overhead reduction version is called Compact PDF417, which is fully decoder compatible with standard PDF417.

NOTE: In the original AIM USA (1994) and AIM Europe (1994) PDF417 specifications, the term Truncated PDF417 has been used in a technically synonymous manner. The name Compact PDF417 is preferred to avoid confusion with the more general use of the term 'truncated'.

Sample of a Compact PDF417 Barcode

How to create Compact PDF417 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Compact PDF417 barcode image, please follow these steps:
  • Set the Symbology property to CompactPdf417
  • Set the Pdf417CompactionType property to:
    • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
    • Binary: It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
    • Numeric: It allows efficient encoding of numeric data strings.
    • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
  • Set the Pdf417ErrorCorrectionLevel property. ISO/IEC standards recommend a minimum error correction level of 2.
  • Setting up dimensions and quiet zones:
    • In our PDF417 implementation the BarHeight property is calculated as BarWidth * BarRatio
      • Set the BarWidth property (Value is expressed in Inches)
      • Set the BarRatio property to an integer greater than or equal to 3
    • Set the Pdf417Rows property to a value ranging from 3 to 90. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the Pdf417Columns property to a value ranging from 1 to 30. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the QuietZone property to double of BarWidth (Value is expressed in Inches)
    • (Optional) Set the Pdf417AspectRatio property to a value ranging from 0 to 1. It's the ratio of the height to the overall width of the symbol. NOTE: For Pdf417AspectRatio property takes effect, Pdf417Rows and Pdf417Columns properties must be set to 0 (zero).
  • Set the Code property with the value to encode.
Example of a Compact PDF417 barcode image
Code property = 123456789 and Pdf417CompactionType property = Auto will produce the following barcode image:


DataMatrix Barcode

This Symbology is also known as Data Matrix, ECC200

Overview
DataMatrix is a two-dimensional (2D) barcode symbology which can store from 1 to about 2,000 characters.
DataMatrix ECC200 version supports advanced encoding error checking and correction algorithms (reed-solomon). Those algorithms allow the recognition of barcodes that are up to 60% damaged.
DataMatrix is being used to encode product and serial number information on electrical rating plates; to mark of surgical instruments in Japan; to identify lenses, circuit boards, and other items during manufacturing.
Barcode Professional supports all DataMatrix Formats, ECI (Extended Channel Interpretation), GS1 FNC1, Special functions like Reader Programming, Macro 05/06 and Structured Append symbols. The data represented in the symbol can be compressed using one of following encoding modes:

  • Auto: This mode will automatically switch between Data Matrix code sets to encode the specified value.
  • Ascii: it is used to encode data that mainly contains ASCII characters (0-127).
  • C40: it is used to encode data that mainly contains numeric and upper case characters.
  • Text: it is used to encode data that mainly contains numeric and lower case characters.
  • Base256: it is used to encode 8 bit values.

Sample of a DataMatrix Barcode

How to create DataMatrix barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a DataMatrix barcode image, please follow these steps:
  • Set the Symbology property to DataMatrix.
  • Set the DataMatrixEncoding property.
  • Set the DataMatrixFormat property.
  • Setting up dimensions and quiet zones:
    • Set the DataMatrixModuleSize property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • If desired, you can use the tilde character "~" to specify special characters in the input data. To do that you must set the DataMatrixProcessTilde property to True. Read more about how it works.
How DataMatrix tilde processing works
When working with DataMatrix tilde processing keep in mind the following rules:
  • ~1: is used to represent the FNC1 code
  • ~2: DEPRECATED! Use new Structured Append properties!
  • ~3: is used only at the very beginning of the symbol for the reader programming purpose. It cannot be used with Structured Append feature!
  • ~5: is used only at the very beginning of the symbol for MACRO 05. The header [)> + ASCII 30 + ASCII 05 + ASCII 29 will be transmitted by the barcode reader before the data in the message and the trailer ASCII 30 + ASCII 4 will be transmitted afterwards. It cannot be used with Structured Append feature!
  • ~6: is used only at the very beginning of the symbol for MACRO 06. The header [)> + ASCII 30 + ASCII 06 + ASCII 29 will be transmitted by the barcode reader before the data in the message and the trailer ASCII 30 + ASCII 4 will be transmitted afterwards. It cannot be used with Structured Append feature!
  • ~7NNNNNN: is used to specify the Extended Channel Interpretation (ECI) and NNNNNN is a value between 000000 and 999999. Default is ECI 000003 which represents the ISO 8859-1 Latin Alphabet No. 1
  • ~dNNN: is used to represent a byte value in decimal notation. NNN must be a numeric value ranging from 000 to 255
  • ~hXX: is used to represent a byte value in hexadecimal notation. XX must be a hexadecimal value ranging from 00 to FF
Example of a DataMatrix barcode image
Code property = ABC 123456789 will produce the following barcode image:


EAN/UPC Add On 2 Barcode

This Symbology is also known as EAN Supplement 2/Two-digit Add-On, EAN+2, UPC Supplement 2/Two-digit Add-On, UPC+2

Overview
The EAN/UPC Add-On Symbols were designed to encode information supplementary to that in the main barcode symbol on periodicals, hardback, and paperback books. Because they provide reduced security, use of Add-On Symbols shall be limited to applications where rules in the application specification governing data format and content provide appropriate safeguards.
A two-digit Add-On Symbol may be used in specific applications to accompany an EAN-13, UPC-A, or UPC-E Barcodes. In general, the two-digit Add-On barcode is positioned following the right Quiet Zone of the main symbol but can be drawn without requiring the presence of the mail symbol.

Sample of an EAN/UPC Add On 2 Barcode

How to create EAN/UPC Add On 2 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN/UPC Add On 2 barcode image, please follow these steps:
  • Set the Symbology property to EanUpcAddOn2
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property (Value is expressed in Inches)
    • Set the BarHeight property (Value is expressed in Inches)
  • Set the Code property with a 2-digit value


EAN/UPC Add On 5 Barcode

This Symbology is also known as EAN Supplement 5/Five-digit Add-On, EAN+5, UPC Supplement 5/Five-digit Add-On, UPC+5

Overview
The EAN/UPC Add-On Symbols were designed to encode information supplementary to that in the main barcode symbol on periodicals, hardback, and paperback books. Because they provide reduced security, use of Add-On Symbols shall be limited to applications where rules in the application specification governing data format and content provide appropriate safeguards.
A five-digit Add-On Symbol may be used in specific applications to accompany an EAN-13, UPC-A, or UPC-E Barcodes. In general, the five-digit Add-On barcode is positioned following the right Quiet Zone of the main symbol but can be drawn without requiring the presence of the mail symbol.

Sample of an EAN/UPC Add On 5 Barcode

How to create EAN/UPC Add On 5 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN/UPC Add On 5 barcode image, please follow these steps:
  • Set the Symbology property to EanUpcAddOn5
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property (Value is expressed in Inches)
    • Set the BarHeight property (Value is expressed in Inches)
  • Set the Code property with a 5-digit value


EAN-13 Barcode

This Symbology is also known as European Article Number 13, EAN-13 Supplement 5/Five-digit Add-On, EAN-13 Supplement 2/Two-digit Add-On, EAN-13+5, EAN-13+2, EAN13, EAN13+5, EAN13+2, UPC-13, GTIN-13, GS1-13, EAN/UCC-13

Overview
EAN-13, based upon the UPC-A standard, was implemented by the International Article Numbering Association (EAN) in Europe. EAN-13 is used worldwide for marking products often sold at retail point of sale. The numbers encoded in EAN-13 bar codes are product identification numbers a.k.a. Global Trade Item Numbers (GTIN) of GS1 System.
Because EAN-13 is a superset of UPC-A, this means that any software or hardware capable of reading an EAN-13 symbol will automatically be able to read an UPC-A symbol. The only difference between EAN-13 and UPC-A is that the number system code in UPC-A is a single digit from 0 through 9 whereas an EAN-13 number system code consists of two digits ranging from 00 through 99, which is essentially a country code.

Sample of an EAN-13 Barcode
The value to encode by EAN-13 has the following structure (a.k.a. GTIN-13):
  • 2 or 3 digits for Number System or Country Code
  • 5 or 4 digits for Manufacturer (Company) Code or prefix
  • 5 digits for Product Code
  • 1 digit for checksum
Each country has a numbering authority which assigns manufacturer codes to companies within its jurisdiction.
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of an EAN-13 Five-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create EAN-13 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN-13 barcode image, please follow these steps:
  • Set the Symbology property to Ean13
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following GTIN-13 structure:
    • 2 or 3 digits for Number System or Country Code
    • 5 or 4 digits for Manufacturer (Company) Code or prefix
    • 5 digits for Product Code
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
EAN-13 barcode images examples
Code property = 501234567890, AddChecksum property = True and DisplayLightMarginIndicator property = True will produce the following barcode image:
Code property = 501234567890, AddChecksum
            property = True and DisplayLightMarginIndicator property = True,
            EanUpcSupplement property = Digits5, and EanUpcSupplementCode
            property = 12345 will produce the following barcode image:


EAN-13 CC-A and CC-B Composite Barcodes

This Symbology is also known as EAN-13 Composite Barcode, EAN-13 CC-A (CCA), EAN-13 CC-B (CCB), EAN-13 Composite A, EAN-13 Composite B, EAN-13 2D Composite, EAN-13 Composite Component A, EAN-13 Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
EAN-13 Composite Barcode is an EAN-13 linear barcode linked to a 2D barcode called CC-A or CC-B.
  • EAN-13 is used worldwide for marking products often sold at retail point of sale. The numbers encoded in EAN-13 bar codes are product identification numbers a.k.a. Global Trade Item Numbers (GTIN) of GS1 System.
  • The 2D Composite Component that can be liked to EAN-13 can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create EAN-13 CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get EAN-13 CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to Ean13CCA or Ean13CCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
EAN-13 CC-A and CC-B barcode images examples
Code property = 3312345678903|991234-abcd (Primary Data = 3312345678903 and Secondary Data = 991234-abcd), Symbology property = Ean13CCA, AddChecksum property = True will produce the following barcode image:
Code property = 3312345678903|991234-abcd (Primary Data = 3312345678903 and Secondary Data = 991234-abcd), Symbology property = Ean13CCB, AddChecksum property = True will produce the following barcode image:


EAN-8 Barcode

This Symbology is also known as European Article Number 8, EAN-8 Supplement 5/Five-digit Add-On, EAN-8 Supplement 2/Two-digit Add-On, EAN-8+5, EAN-8+2, EAN8, EAN8+5, EAN13+2, UPC-8, GTIN-8, GS1-8, EAN/UCC-8

Overview
EAN-8 is the EAN equivalent of UPC-E in the sense that it provides a "short" barcode for small packages. The primary purpose of the EAN-8 code is to use as little space as possible.
EAN-8 is encoded using the three EAN-13 character sets and also has a check digit that is calculated in the same way as EAN-13.
The data digits in an EAN-8 symbol identify a particular product and manufacturer. Since a limited number of EAN-8 codes are available in each country, they are issued only for products with insufficient space for a normal EAN-13 symbol. For example, a 2-digit country code permits a total of only 100,000 item numbers.

Sample of an EAN-8 Barcode
The value to encode by EAN-8 has the following structure (a.k.a. GTIN-8):
  • 2 or 3 digits for Number System or Country Code
  • 5 or 4 digits for Product Code
  • 1 digit for checksum
Each country has a numbering authority which assigns manufacturer codes to companies within its jurisdiction.
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of an EAN-8 Two-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create EAN-8 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN-8 barcode image, please follow these steps:
  • Set the Symbology property to Ean8
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.86 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.925 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following structure (GTIN-8):
    • 2 or 3 digits for Number System or Country Code
    • 5 or 4 digits for Product Code
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
EAN-8 barcode images examples
Code property = 2012345, AddChecksum property = True and DisplayLightMarginIndicator property = True will produce the following barcode image:
Code property = 2012345, AddChecksum property = True and DisplayLightMarginIndicator property = True, EanUpcSupplement property = Digits2, and EanUpcSupplementCode property = 78 will produce the following barcode image:


EAN-8 CC-A and CC-B Composite Barcodes

This Symbology is also known as EAN-8 Composite Barcode, EAN-8 CC-A (CCA), EAN-8 CC-B (CCB), EAN-8 Composite A, EAN-8 Composite B, EAN-8 2D Composite, EAN-8 Composite Component A, EAN-8 Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
EAN-8 Composite Barcode is an EAN-8 linear barcode linked to a 2D barcode called CC-A or CC-B.
  • EAN-8 is derived from the longer European Article Number (EAN-13) code. It was introduced for use on small packages where an EAN-13 barcode would be too large.
  • The 2D Composite Component that can be liked to EAN-8 can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create EAN-8 CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get EAN-8 CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to Ean8CCA or Ean8CCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
EAN-8 CC-A and CC-B barcode images examples
Code property = 2012345|991234-abcd (Primary Data = 2012345 and Secondary Data = 991234-abcd), Symbology property = Ean8CCA, AddChecksum property = True will produce the following barcode image:
Code property = 2012345|991234-abcd (Primary Data = 2012345 and Secondary Data = 991234-abcd), Symbology property = Ean8CCB, AddChecksum property = True will produce the following barcode image:


EAN-99 Barcode

This Symbology is also known as European Article Number 99, EAN-99 Supplement 5/Five-digit Add-On, EAN-99 Supplement 2/Two-digit Add-On, EAN-99+5, EAN-99+2, EAN99, EAN99+5, EAN99+2, GTIN-99, GS1-99, Coupon Barcode

Overview
EAN-99 is a special form of the EAN-13, which just starts with "99". EAN 99 is used as an in-store coupon. These are coupons which are good only at that particular store and are actually distributed in the store in which they will be honored. Instead of a UPC code with a number system character of 5, an EAN code is used with a "country code" of 99.

Sample of an EAN-99 Barcode

How to create EAN-99 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN-99 barcode image, please follow these steps:
  • Set the Symbology property to Ean99
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following structure:
    • 2 digits for Number System or Country Code which MUST BE 99
    • 10 digits for content
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
EAN-99 barcode images examples
Code property = 990123456789 and AddChecksum property = True will produce the following barcode image:


EAN-Velocity Barcode

This Symbology is also known as Velocity Barcode

Overview
EAN-Velocity is not a proper Symbology, but just a shorter way to specify the message data.
It is a special version of EAN-8, with the first digit is 0 (zero) which is usually used for internal article numbering.

Sample of an EAN-Velocity Barcode

How to create EAN-Velocity barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an EAN-Velocity barcode image, please follow these steps:
  • Set the Symbology property to EanVelocity
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.86 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.925 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following structure:
    • 6 digits for content
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products.
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
EAN-Velocity barcode images examples
Code property = 123456 and AddChecksum property = True will produce the following barcode image:


GS1-128 (formerly UCC/EAN-128) Barcode

This Symbology is also known as EAN-128, UCC-128, USS-128, GS1 128, UCC.EAN-128, GTIN-128, UCC-12, EAN/UCC-13, EAN/UCC-14

Overview
The GS1-128 (formerly UCC/EAN-128) Symbology is a subset of the more general Code 128 Symbology. By agreement among AIM, Inc., GS1 (EAN International and the UCC), use of the Function 1 Character (FNC1) in Code 128 Symbols in the first symbol character position following the Start Character has been reserved exclusively for the GS1 System.
GS1-128 was developed to provide a worldwide format and standard for exchanging common data between companies. While other barcodes simply encode data with no respect for what the data represents, GS1-128 encodes data and encodes what that data represents.
The encodable character used by GS1-128 Symbology is as defined by the International ISO/IEC 646 Standard.
GS1-128 encodes the so called Element Strings which are composed of an Application Identifier (AI) plus a data field. GS1-128 has a list of predefined Application Identifiers (AI) which identifies the meaning and format of the data following it. The AI is a 2, 3, or 4-digit number and it is enclosed in parentheses when printed below the barcode (the parentheses are only for visual clarity, and are not encoded in the barcode!).

Sample of a GS1-128 Barcode

How to encode GS1-128 values using Barcode Professional products

Introduction
GS1-128 encodes the so called Element Strings which are composed of an Application Identifier (AI) plus a data field. Each AI identifies the meaning and format of the data following it. The GS1 System provides more than one hundred Element Strings which can be found on the GS1 General Specification and is summarized in the following table.
Show GS1-128 Application Identifiers
AI | Element String Description | Data Field length (without AI)
00 | Serial Shipping Container Code (SSCC) | 18
01 | Global Trade Item Number (GTIN) | 14
02 | GTIN of Contained Trade Items | 14
10 | Batch/Lot Number | variable, up to 20
11 | Production Date | 6
12 | Due Date | 6
13 | Packaging Date | 6
15 | Sell by Date (Quality Control) | 6
17 | Expiration Date | 6
20 | Product Variant | 2
21 | Serial Number | variable, up to 20
22 | Secondary Data Fields | variable, up to 29
240 | Additional Product Identification | variable, up to 30
241 | Customer Part Number | variable, up to 30
242 | Made-to-Order Variation Number | variable, up to 6
250 | Secondary Serial Number | variable, up to 30
251 | Reference to Source Entity | variable, up to 30
253 | Global Document Type Identifier | variable, 13-17
254 | GLN Extension Component | variable, up to 20
30 | Count of items | variable, up to 8
310y | Product Net Weight in kg | 6
311y | Product Length/1st Dimension, in meters | 6
312y | Product Width/Diameter/2nd Dimension, in meters | 6
313y | Product Depth/Thickness/Height/3rd Dimension, in meters | 6
314y | Product Area, in square meters | 6
315y | Product Net Volume, in liters | 6
316y | Product Net Volume, in cubic meters | 6
320y | Product Net Weight, in pounds | 6
321y | Product Length/1st Dimension, in inches | 6
322y | Product Length/1st Dimension, in feet | 6
323y | Product Length/1st Dimension, in yards | 6
324y | Product Width/Diameter/2nd Dimension, in inches | 6
325y | Product Width/Diameter/2nd Dimension, in feet | 6
326y | Product Width/Diameter/2nd Dimension, in yards | 6
327y | Product Depth/Thickness/Height/3rd Dimension, in inches | 6
328y | Product Depth/Thickness/Height/3rd Dimension, in feet | 6
329y | Product Depth/Thickness/3rd Dimension, in yards | 6
330y | Container Gross Weight (kg) | 6
331y | Container Length/1st Dimension (Meters) | 6
332y | Container Width/Diameter/2nd Dimension (Meters) | 6
333y | Container Depth/Thickness/3rd Dimension (Meters) | 6
334y | Container Area (Square Meters) | 6
335y | Container Gross Volume (Liters) | 6
336y | Container Gross Volume (Cubic Meters) | 6
340y | Container Gross Weight (Pounds) | 6
341y | Container Length/1st Dimension, in inches | 6
342y | Container Length/1st Dimension, in feet | 6
343y | Container Length/1st Dimension in, in yards | 6
344y | Container Width/Diameter/2nd Dimension, in inches | 6
345y | Container Width/Diameter/2nd Dimension, in feet | 6
346y | Container Width/Diameter/2nd Dimension, in yards | 6
347y | Container Depth/Thickness/Height/3rd Dimension, in inches | 6
348y | Container Depth/Thickness/Height/3rd Dimension, in feet | 6
349y | Container Depth/Thickness/Height/3rd Dimension, in yards | 6
350y | Product Area (Square Inches) | 6
351y | Product Area (Square Feet) | 6
352y | Product Area (Square Yards) | 6
353y | Container Area (Square Inches) | 6
354y | Container Area (Square Feet) | 6
355y | Container Area (Square Yards) | 6
356y | Net Weight (Troy Ounces) | 6
357y | Net Weight/Volume (Ounces) | 6
360y | Product Volume (Quarts) | 6
361y | Product Volume (Gallons) | 6
362y | Container Gross Volume (Quarts) | 6
363y | Container Gross Volume (U.S. Gallons) | 6
364y | Product Volume (Cubic Inches) | 6
365y | Product Volume (Cubic Feet) | 6
366y | Product Volume (Cubic Yards) | 6
367y | Container Gross Volume (Cubic Inches) | 6
368y | Container Gross Volume (Cubic Feet) | 6
369y | Container Gross Volume (Cubic Yards) | 6
37 | Number of Units Contained | variable, up to 8
390y | Amount payable (local currency) | variable, up to 15
391y | Amount payable (with ISO currency code) | variable, 3-18
392y | Amount payable per single item (local currency) | variable, up to 15
393y | Amount payable per single item (with ISO currency code) | variable, 3-18
400 | Customer Purchase Order Number | variable, up to 30
401 | Consignment Number | variable, up to 30
402 | Bill of Lading number | 17
403 | Routing code | variable, up to 30
410 | Ship To/Deliver To Location Code (Global Location Number) | 13
411 | Bill To/Invoice Location Code (Global Location Number) | 13
412 | Purchase From Location Code (Global Location Number) | 13
413 | Ship for, Deliver for, or Forward to Location Code (Global Location Number) | 13
414 | Identification of a physical location (Global Location Number) | 13
420 | Ship To/Deliver To Postal Code (Single Postal Authority) | variable, up to 20
421 | Ship To/Deliver To Postal Code (with ISO country code) | variable, 3-15
422 | Country of Origin (ISO country code) | 3
423 | Country or countries of initial processing | variable, 3-15
424 | Country of processing | 3
425 | Country of disassembly | 3
426 | Country of full process chain | 3
7001 | NATO Stock Number (NSN) | 13
7002 | UN/ECE Meat Carcasses and cuts classification | variable, up to 30
7003 | expiration date and time | 10
7004 | Active Potency | variable, up to 4
703n | Processor approval (with ISO country code) -- n indicates sequence number of several processors | variable, 3-30
8001 | Roll Products - Width/Length/Core Diameter/Direction/Splices | 14
8002 | Mobile phone identifier | variable, up to 20
8003 | Global Returnable Asset Identifier | variable, 14-30
8004 | Global Individual Asset Identifier | variable, up to 30
8005 | Price per Unit of Measure | 6
8006 | identification of the components of an item | 18
8007 | International Bank Account Number | variable, up to 30
8008 | Date/time of production | variable, 8-12
8018 | Global Service Relation Number | 18
8020 | Payment slip reference number | variable, up to 25
8100 | Coupon Extended Code: Number System and Offer | 6
8101 | Coupon Extended Code: Number System, Offer, End of Offer | 10
8102 | Coupon Extended Code: Number System preceded by 0 | 2
8110 | Coupon code ID (North America) | variable, up to 30
90 | Mutually Agreed Between Trading Partners | variable, up to 30
91-99 | Internal Company Codes | variable, up to 30
When encoding those element strings into a GS1-128 barcode, the FNC1 function character starts it and is automatically encoded by the Barcode Professional. Also notice that the AI has parentheses around it in the human readable text of a GS1-128 barcode, but the parentheses are not encoded in the barcode itself.
Encoding Single GS1-128 AIs
To encode a single element string like the Global Trade Item Number (GTIN) which AI is (01), you just need to specify the AI + Data Field to the Code property. For example, to encode GTIN 95012345678903 you should:
  • Set the Symbology property to GS1128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties based on your requirements (Values are expressed in Inches)
    • Set the QuietZone property to 10 times the BarWidth value or based on your requirements (Value is expressed in Inches)
  • Set the Code property with the value to encode. For example, Code = "(01)95012345678903" or Code = "0195012345678903" (NOTE: if you do not specify the parenthesis, then they will be automatically added by Barcode Professional in the Human Readable Text below the barcode)
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
Concatenation - Encoding multiple GS1-128 AIs into a single barcode
GS1-128 allows several Element Strings to be encoded in one barcode, a process called concatenation. Concatenation is advantageous because it means that the symbology elements are only needed once, and the space required for the symbol is smaller than when separate barcodes are used to encode each Element String. It also improves scanning accuracy, allowing for single scanning rather than multiple scanning. The various Element Strings can be transmitted from the bar code reader as a single full string.

When concatenating AIs, the FNC1 function character is used for marking the end of an AI. The AIs which require the usage of FNC1 are these ones: 10, 21, 22, 240, 241, 242, 250, 251, 253, 254, 30, 37, 390, 391, 392, 393, 400, 401, 402, 403, 420, 421, 422, 423, 424, 425, 426, 7001, 7002, 7003, 7004, 7030, 7031, 7032, 7033, 7034, 7035, 7036, 7037, 7038, 7039, 8001, 8002, 8003, 8004, 8005, 8006, 8007, 8008, 8018, 8020, 8100, 8101, 8102, 8110, 90, 91, 92, 93, 94, 95, 96, 97, 98, and 99. If some of these AIs are the last element string in the concatenation, then the FNC1 is NOT required. If the AI is not listed here, then it does NOT require an FNC1 character either!

If you specify the AIs between parentheses, then the Barcode Professional takes care of the FNC1 character and will automatically add FNC1 for those AIs requiring it based on the list above. For example, to concatenate AI 8005 Price per Unit of Measure (365 currency units) and AI 10 Batch Numbers (123456), you should:
  • Set the Symbology property to GS1128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties based on your requirements (Values are expressed in Inches)
    • Set the QuietZone property to 10 times the BarWidth value or based on your requirements (Value is expressed in Inches)
  • Set the Code property with the value to encode. For example, Code = "(8005)000365(10)123456" or Code = "8005000365È10123456" (NOTE: if you do not specify the parenthesis, then you will have to add an FNC1 character È (ASCII 200) for marking the end of the AIs which require an FNC1)
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)


GS1-128 (formerly UCC/EAN-128) CC-A, CC-B and CC-C Composite Barcodes

This Symbology is also known as GS1-128 Composite Barcode, GS1-128 CC-A (CCA), GS1-128 CC-B (CCB), GS1-128 CC-C (CCC), GS1-128 Composite A, GS1-128 Composite B, GS1-128 Composite C, GS1-128 2D Composite, GS1-128 Composite Component A, GS1-128 Composite Component B, GS1-128 Composite Component C

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1-128 Composite Barcode is an GS1-128 linear barcode linked to a 2D barcode called CC-A or CC-B or CC-C.
  • GS1-128 (formerly UCC/EAN-128) Symbology is a subset of the more general Code 128 Symbology. By agreement among AIM, Inc., GS1 (EAN International and the UCC), use of the Function 1 Character (FNC1) in Code 128 Symbols in the first symbol character position following the Start Character has been reserved exclusively for the GS1 System. GS1-128 was developed to provide a worldwide format and standard for exchanging common data between companies. While other barcodes simply encode data with no respect for what the data represents, GS1-128 encodes data and encodes what that data represents.
  • The 2D Composite Component that can be liked to GS1-128 can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.
    • CC-C: it is a PDF417 barcode which can encode up to 2361 digits(the greatest data capacity of the Composite Symbols). CC-C can be used as a 2D Composite Component within a GS1-128 Composite Symbol only.

How to create GS1-128 CC-A, CC-B and CC-C Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1-128 CC-A, CC-B and CC-C Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1128CCA or GS1128CCB or GS1128CCC
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties per your requeriments (By default, values are expressed in Inches)
    • Set the BarRatio property to 3
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1-128 CC-A, CC-B and CC-C barcode images examples
Code property = (01)03212345678906|1A1B2C3D4E5F6G7H8 (Primary Data = (01)03212345678906 and Secondary Data = 1A1B2C3D4E5F6G7H8), Symbology property = GS1128CCA, AddChecksum property = True will produce the following barcode image:
Code property = (01)03212345678906|1A1B2C3D4E5F6G7H8 (Primary Data = (01)03212345678906 and Secondary Data = 1A1B2C3D4E5F6G7H8), Symbology property = GS1128CCB, AddChecksum property = True will produce the following barcode image:
Code property = (01)03212345678906|1A1B2C3D4E5F6G7H8 (Primary Data = (01)03212345678906 and Secondary Data = 1A1B2C3D4E5F6G7H8), Symbology property = GS1128CCC, AddChecksum property = True will produce the following barcode image:


GS1 DataBar Expanded (Formerly RSS Expanded - Reduced Space Symbology) barcode

This Symbology is also known as GS1 DataBar-14 Expanded, RSS Expanded, Reduced Space Symbology Expanded

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar Expanded
GS1 DataBar Expanded is a variable length linear symbology capable of encoding up to 74 numeric or 41 alphabetic characters of AI Element String data. GS1 DataBar Expanded is designed to encode primary and supplementary data in items for Point-of-Sale (POS) and other applications. It has the same capabilities as a GS1-128 (UCC/EAN-128) barcode except that it is also designed to be scanned by omnidirectional slot scanners. It is designed for variable weight products, perishable products, traceable retail products, and coupons.

The user data to be encoded into a GS1 DataBar Expanded barcode shall always consist of application identifiers and data fields that comply with the data standard of the GS1 General Specifications, formatted exactly as they would be for encodation into a GS1-128 (UCC/EAN-128) barcode. The GS1-128 (UCC/EAN-128) rules for concatenation of AI element strings, such as the use of a FNC1 to separate a variable length element string from the element string following it, shall be followed when encoding a GS1 DataBar Expanded barcode.

Sample of a GS1 DataBar Expanded/RSS Expanded Barcode

How to create GS1 DataBar Expanded/RSS Expanded barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar Expanded/RSS Expanded barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarExpanded or RssExpanded
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.7072 (34 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with data complying GS1-128 (UCC/EAN-128) data format i.e. application identifiers (AIs) + data fields
Example of GS1 DataBar Expanded/RSS Expanded barcode images
Code property = (01)90614141000015(3202)000150 will produce the following barcode image:


GS1 DataBar Expanded (Formerly RSS Expanded - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar Expanded Composite Barcode, GS1 DataBar Expanded CC-A (CCA), GS1 DataBar Expanded CC-B (CCB), GS1 DataBar Expanded Composite A, GS1 DataBar Expanded Composite B, GS1 DataBar Expanded 2D Composite, GS1 DataBar Expanded Composite Component A, GS1 DataBar Expanded Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar Expanded (formerly RSS Expanded) Composite Barcode is an GS1 DataBar Expanded linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar Expanded is a variable length linear symbology capable of encoding up to 74 numeric or 41 alphabetic characters of AI Element String data. GS1 DataBar Expanded is designed to encode primary and supplementary data in items for Point-of-Sale (POS) and other applications. It has the same capabilities as a GS1-128 (UCC/EAN-128) barcode except that it is also designed to be scanned by omnidirectional slot scanners. It is designed for variable weight products, perishable products, traceable retail products, and coupons. The user data to be encoded into a GS1 DataBar Expanded barcode shall always consist of application identifiers and data fields that comply with the data standard of the GS1 General Specifications, formatted exactly as they would be for encodation into a GS1-128 (UCC/EAN-128) barcode. The GS1-128 (UCC/EAN-128) rules for concatenation of AI element strings, such as the use of a FNC1 to separate a variable length element string from the element string following it, shall be followed when encoding a GS1 DataBar Expanded barcode.
  • The 2D Composite Component that can be liked to GS1 DataBar Expanded can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar Expanded CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar Expanded CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBarExpandedCCA or GS1DataBarExpandedCCB or RssExpandedCCA or RssExpandedCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.7072 (34 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar Expanded CC-A and CC-B barcode images examples

NOTE: The Primary Data must comply GS1-128 (UCC/EAN-128) data format i.e. application identifiers (AIs) + data fields

Code property = (01)93712345678904(3103)001234|911A2B3C4D5E (Primary Data = (01)93712345678904(3103)001234 and Secondary Data = 911A2B3C4D5E), Symbology property = GS1DataBarExpandedCCA, AddChecksum property = True will produce the following barcode image:
Code property = (01)93712345678904(3103)001234|911A2B3C4D5E (Primary Data = (01)93712345678904(3103)001234 and Secondary Data = 911A2B3C4D5E), Symbology property = GS1DataBarExpandedCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar Expanded Stacked (Formerly RSS Expanded Stacked - Reduced Space Symbology) barcode

This Symbology is also known as GS1 DataBar-14 Expanded Stacked , RSS Expanded Stacked , Reduced Space Symbology Expanded Stacked

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar Expanded Stacked
The GS1 DataBar Expanded Stacked barcode is a multirow stacked version of GS1 DataBar Expanded. It can be printed in widths of 2 to 20 segments and can have from 2 to 11 rows. It is used when the symbol area or print mechanism is not wide enough to accommodate the full single-row GS1 DataBar Expanded Symbol. It is designed for variable weight products, perishable products, traceable retail products, and coupons.

The user data to be encoded into a GS1 DataBar Expanded barcode shall always consist of application identifiers and data fields that comply with the data standard of the GS1 General Specifications, formatted exactly as they would be for encodation into a GS1-128 (UCC/EAN-128) barcode. The GS1-128 (UCC/EAN-128) rules for concatenation of AI element strings, such as the use of a FNC1 to separate a variable length element string from the element string following it, shall be followed when encoding a GS1 DataBar Expanded barcode.

Sample of a GS1 DataBar Expanded Stacked/RSS Expanded Stacked Barcode

How to create GS1 DataBar Expanded Stacked/RSS Expanded Stacked barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar Expanded Stacked/RSS Expanded Stacked barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarExpandedStacked or RssExpandedStacked
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.7072 (34 * BarWidth) or higher (Value is expressed in Inches)
    • Set the SegmentsPerRow property to an even number ranging from 2 up to 22. Default is 4.
  • Set the Code property with data complying GS1-128 (UCC/EAN-128) data format i.e. application identifiers (AIs) + data fields
Example of GS1 DataBar Expanded Stacked/RSS Expanded Stacked barcode images
Code property = (01)90614141000015(3202)000150 will produce the following barcode image:


GS1 DataBar Expanded Stacked (Formerly RSS Expanded Stacked - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar Expanded Stacked Composite Barcode, GS1 DataBar Expanded Stacked CC-A (CCA), GS1 DataBar Expanded Stacked CC-B (CCB), GS1 DataBar Expanded Stacked Composite A, GS1 DataBar Expanded Stacked Composite B, GS1 DataBar Expanded Stacked 2D Composite, GS1 DataBar Expanded Stacked Composite Component A, GS1 DataBar Expanded Stacked Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar Expanded Stacked (formerly RSS Expanded Stacked) Composite Barcode is an GS1 DataBar Expanded Stacked linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar Expanded Stacked is a variable length linear symbology capable of encoding up to 74 numeric or 41 alphabetic characters of AI Element String data. GS1 DataBar Expanded Stacked is designed to encode primary and supplementary data in items for Point-of-Sale (POS) and other applications. It has the same capabilities as a GS1-128 (UCC/EAN-128) barcode except that it is also designed to be scanned by omnidirectional slot scanners. It is designed for variable weight products, perishable products, traceable retail products, and coupons. The user data to be encoded into a GS1 DataBar Expanded Stacked barcode shall always consist of application identifiers and data fields that comply with the data standard of the GS1 General Specifications, formatted exactly as they would be for encodation into a GS1-128 (UCC/EAN-128) barcode. The GS1-128 (UCC/EAN-128) rules for concatenation of AI element strings, such as the use of a FNC1 to separate a variable length element string from the element string following it, shall be followed when encoding a GS1 DataBar Expanded Stacked barcode.
  • The 2D Composite Component that can be liked to GS1 DataBar Expanded Stacked can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar Expanded Stacked CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar Expanded Stacked CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBarExpandedStackedCCA or GS1DataBarExpandedStackedCCB or RssExpandedStackedCCA or RssExpandedStackedCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.7072 (34 * BarWidth) or higher (Value is expressed in Inches)
    • Set the SegmentsPerRow property to an even number ranging from 2 up to 22. Default is 4.
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar Expanded Stacked CC-A and CC-B barcode images examples

NOTE: The Primary Data must comply GS1-128 (UCC/EAN-128) data format i.e. application identifiers (AIs) + data fields

Code property = (01)93712345678904(3103)001234|911A2B3C4D5E (Primary Data = (01)93712345678904(3103)001234 and Secondary Data = 911A2B3C4D5E), Symbology property = GS1DataBarExpandedStackedCCA, AddChecksum property = True will produce the following barcode image:
Code property = (01)93712345678904(3103)001234|911A2B3C4D5E (Primary Data = (01)93712345678904(3103)001234 and Secondary Data = 911A2B3C4D5E), Symbology property = GS1DataBarExpandedStackedCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar Limited (Formerly RSS Limited - Reduced Space Symbology) barcode

This Symbology is also known as GS1 DataBar-14 Limited, RSS Limited, Reduced Space Symbology Limited

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar Limited
GS1 DataBar Limited encodes the Element String AI (01), which is based on the GTIN-12, GTIN-8, GTIN-13, or GTIN-14 Data Structures, in a linear barcode symbol for use on small items that will not be scanned in an omnidirectional scanning environment. GS1 DataBar Limited is capable of encoding 4000000000000 (4 x 10 ^ 12) numbers values. These values are expressed as digits called Global Trade Item Numbers (GTINs). NOTE: The leading (01) is the implied application identifier (AI) and is not encoded in the symbol. The last digit, which is a check digit, is not directly encoded in the barcode.

Sample of a GS1 DataBar Limited/RSS Limited Barcode

How to create GS1 DataBar Limited/RSS Limited barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar Limited/RSS Limited barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarLimited or RssLimited
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.2080 (10 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with a 13-digit value representing a GTIN code excluding AI (01) and last check digit.
Example of GS1 DataBar Limited/RSS Limited barcode images
Code property = 0061414199999 will produce the following barcode image:


GS1 DataBar Limited (Formerly RSS Limited - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar Limited Composite Barcode, GS1 DataBar Limited CC-A (CCA), GS1 DataBar Limited CC-B (CCB), GS1 DataBar Limited Composite A, GS1 DataBar Limited Composite B, GS1 DataBar Limited 2D Composite, GS1 DataBar Limited Composite Component A, GS1 DataBar Limited Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar Limited (formerly RSS Limited) Composite Barcode is an GS1 DataBar Limited linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar Limited can identify small items and carry more information than the current EAN/UPC barcode. GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing. GS1 DataBar Limited encodes the Element String AI (01), which is based on the GTIN-12, GTIN-8, GTIN-13, or GTIN-14 Data Structures, in a linear barcode symbol for use on small items that will not be scanned in an omnidirectional scanning environment.
  • The 2D Composite Component that can be liked to GS1 DataBar Limited can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar Limited CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar Limited CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBarLimitedCCA or GS1DataBarLimitedCCB or RssLimitedCCA or RssLimitedCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.2080 (10 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar Limited CC-A and CC-B barcode images examples

NOTE: The Primary Data must be a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.

Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarLimitedCCA, AddChecksum property = True will produce the following barcode image:
Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarLimitedCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar Omnidirectional/GS1 DataBar-14 (Formerly RSS-14 - Reduced Space Symbology) barcode

This Symbology is also known as RSS14, Reduced Space Symbology 14, GS1 DataBar-14

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar Omnidirectional or DataBar-14
GS1 DataBar Omnidirectional or DataBar-14 encodes AI (01) in a linear symbol that can be scanned omnidirectionally by suitably programmed slot scanners. GS1 DataBar-14 is capable of encoding 20000000000000 (2 x 10 ^ 13) values. These values are expressed as 14 digits called Global Trade Item Numbers (GTINs). The first digit is a linkage flag. The following 13 digits are data characters. The 13 data characters plus an implied check digit form a GS1 14-digit item identification number including a leading Indicator digit. NOTE: The leading (01) is the implied application identifier (AI) and is not encoded in the symbol. The last digit, which is a check digit, is not directly encoded in the barcode.

Sample of a GS1 DataBar Omnidirectional/GS1 DataBar-14/RSS-14 Barcode

How to create GS1 DataBar Omnidirectional/GS1 DataBar-14/RSS-14 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar Omnidirectional/GS1 DataBar-14/RSS-14 barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarOmnidirectional or GS1DataBar14 or Rss14
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.6864 (33 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.
Example of GS1 DataBar Omnidirectional/GS1 DataBar-14/RSS-14 barcode images
Code property = 0061414199999 will produce the following barcode image:


GS1 DataBar Omnidirectional/GS1 DataBar-14 (Formerly RSS-14 - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar-14 Composite Barcode, GS1 DataBar-14 CC-A (CCA), GS1 DataBar-14 CC-B (CCB), GS1 DataBar-14 Composite A, GS1 DataBar-14 Composite B, GS1 DataBar-14 2D Composite, GS1 DataBar-14 Composite Component A, GS1 DataBar-14 Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar-14 (GS1 DataBar Omnidirectional formerly RSS-14) Composite Barcode is an GS1 DataBar-14 linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar-14 can identify small items and carry more information than the current EAN/UPC barcode. GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.
  • The 2D Composite Component that can be liked to GS1 DataBar-14 can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar-14 CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar-14 CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBar14CCA or GS1DataBar14CCB or GS1DataBarOmnidirectionalCCA or GS1DataBarOmnidirectionalCCB or Rss14CCA or Rss14CCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.6864 (33 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar-14 CC-A and CC-B barcode images examples

NOTE: The Primary Data must be a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.

Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBar14CCA, AddChecksum property = True will produce the following barcode image:
Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBar14CCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar-14 Stacked (Formerly RSS-14 Stacked - Reduced Space Symbology) barcode

This Symbology is also known as RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar-14 Stacked
GS1 DataBar-14 Stacked is a variation of the GS1 DataBar-14 Symbology that is stacked in two rows and used when the normal symbol would be too wide for the application. It is used for small item marking applications that will not need to be read by omnidirectional scanners. GS1 DataBar-14 Stacked encodes AI (01) in a linear symbol and is capable of encoding 20000000000000 (2 x 10 ^ 13) values. These values are expressed as 14 digits called Global Trade Item Numbers (GTINs). The first digit is a linkage flag. The following 13 digits are data characters. The 13 data characters plus an implied check digit form a GS1 14-digit item identification number including a leading Indicator digit. NOTE: The leading (01) is the implied application identifier (AI) and is not encoded in the symbol. The last digit, which is a check digit, is not directly encoded in the barcode.

Sample of a GS1 DataBar-14 Stacked/RSS-14 Stacked Barcode

How to create GS1 DataBar-14 Stacked/RSS-14 Stacked using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar-14 Stacked/RSS-14 Stacked barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarStacked or GS1DataBar14Stacked or Rss14Stacked
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
  • Set the Code property with a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.
Example of GS1 DataBar-14 Stacked/RSS-14 Stacked barcode images
Code property = 0061414199999 will produce the following barcode image:


GS1 DataBar-14 Stacked (Formerly RSS-14 Stacked - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar-14 Stacked Composite Barcode, GS1 DataBar-14 Stacked CC-A (CCA), GS1 DataBar-14 Stacked CC-B (CCB), GS1 DataBar-14 Stacked Composite A, GS1 DataBar-14 Stacked Composite B, GS1 DataBar-14 Stacked 2D Composite, GS1 DataBar-14 Stacked Composite Component A, GS1 DataBar-14 Stacked Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar-14 Stacked (formerly RSS-14 Stacked) Composite Barcode is an GS1 DataBar-14 Stacked linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar-14 Stacked can identify small items and carry more information than the current EAN/UPC barcode. GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing. GS1 DataBar-14 Stacked is a variation of the GS1 DataBar-14 Symbology that is stacked in two rows and used when the normal symbol would be too wide for the application. It is used for small item marking applications that will not need to be read by omnidirectional scanners.
  • The 2D Composite Component that can be liked to GS1 DataBar-14 Stacked can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar-14 Stacked CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar-14 Stacked CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBarStackedCCA or GS1DataBarStackedCCB or GS1DataBar14StackedCCA or GS1DataBar14StackedCCB or Rss14StackedCCA or Rss14StackedCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar-14 Stacked CC-A and CC-B barcode images examples

NOTE: The Primary Data must be a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.

Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarStackedCCA, AddChecksum property = True will produce the following barcode image:
Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarStackedCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar-14 Stacked Omnidirectional (Formerly RSS-14 Stacked Omnidirectional - Reduced Space Symbology) barcode

This Symbology is also known as RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional, GS1 DataBar Stacked Omnidirectional

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar-14 Stacked Omnidirectional
GS1 DataBar-14 Stacked Omnidirectional is a full height, two-row version of the GS1 DataBar-14 Barcode Symbol that is designed to be read by an omnidirectional scanner, such as a retail slot scanner. GS1 DataBar-14 Stacked Omnidirectional encodes AI (01) in a linear symbol and is capable of encoding 20000000000000 (2 x 10 ^ 13) values. These values are expressed as 14 digits called Global Trade Item Numbers (GTINs). The first digit is a linkage flag. The following 13 digits are data characters. The 13 data characters plus an implied check digit form a GS1 14-digit item identification number including a leading Indicator digit. NOTE: The leading (01) is the implied application identifier (AI) and is not encoded in the symbol. The last digit, which is a check digit, is not directly encoded in the barcode.

Sample of a GS1 DataBar-14 Stacked Omnidirectional/RSS-14 Stacked Omnidirectional Barcode

How to create GS1 DataBar-14 Stacked Omnidirectional/RSS-14 Stacked Omnidirectional using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar-14 Stacked Omnidirectional/RSS-14 Stacked Omnidirectional barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarStackedOmnidirectional or GS1DataBar14StackedOmnidirectional or Rss14StackedOmnidirectional
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.6864 (33 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.
Example of GS1 DataBar-14 Stacked Omnidirectional/RSS-14 Stacked Omnidirectional barcode images
Code property = 0061414199999 will produce the following barcode image:


GS1 DataBar-14 Stacked Omnidirectional (Formerly RSS-14 Stacked Omnidirectional - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar-14 Stacked Omnidirectional Composite Barcode, GS1 DataBar-14 Stacked Omnidirectional CC-A (CCA), GS1 DataBar-14 Stacked Omnidirectional CC-B (CCB), GS1 DataBar-14 Stacked Omnidirectional Composite A, GS1 DataBar-14 Stacked Omnidirectional Composite B, GS1 DataBar-14 Stacked Omnidirectional 2D Composite, GS1 DataBar-14 Stacked Omnidirectional Composite Component A, GS1 DataBar-14 Stacked Omnidirectional Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar-14 Stacked Omnidirectional (formerly RSS-14 Stacked Omnidirectional) Composite Barcode is an GS1 DataBar-14 Stacked Omnidirectional linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar-14 Stacked Omnidirectional can identify small items and carry more information than the current EAN/UPC barcode. GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing. GS1 DataBar-14 Stacked Omnidirectional is a full height, two-row version of the GS1 DataBar-14 Barcode Symbol that is designed to be read by an omnidirectional scanner, such as a retail slot scanner.
  • The 2D Composite Component that can be liked to GS1 DataBar-14 Stacked Omnidirectional can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar-14 Stacked Omnidirectional CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar-14 Stacked Omnidirectional CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBarStackedOmnidirectionalCCA or GS1DataBarStackedOmnidirectionalCCB or GS1DataBar14StackedOmnidirectionalCCA or GS1DataBar14StackedOmnidirectionalCCB or Rss14StackedOmnidirectionalCCA or Rss14StackedOmnidirectionalCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.6864 (33 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar-14 Stacked Omnidirectional CC-A and CC-B barcode images examples

NOTE: The Primary Data must be a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.

Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarStackedOmnidirectionalCCA, AddChecksum property = True will produce the following barcode image:
Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarStackedOmnidirectionalCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataBar-14 Truncated (Formerly RSS-14 Truncated - Reduced Space Symbology) barcode

This Symbology is also known as GS1 DataBar Truncated, RSS-14 Truncated, Reduced Space Symbology 14 Truncated

Overview
GS1 DataBar Family of bar codes
GS1 DataBar (formerly Reduced Space Symbols or RSS) symbols can identify small items and carry more information than the current EAN/UPC barcode (GS1 DataBar symbols will not necessarily replace EAN/UCC bar codes, as it will be left to the brand owner - the party responsible for specifying package design - to decide). GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.

GS1 DataBar is a family of linear barcode symbologies used within the GS1 System. There are three types of GS1 DataBar symbols, two of which have a number of versions optimized for different application requirements.

GS1 DataBar-14 Truncated
GS1 DataBar-14 Truncated encodes AI (01) in a linear symbol designed to be read by scanners such as wands, handheld lasers, and linear and 2D imagers. It cannot be read efficiently by omnidirectional flat-bed and presentation scanners. GS1 DataBar-14 Truncated is capable of encoding 20000000000000 (2 x 10 ^ 13) values. These values are expressed as 14 digits called Global Trade Item Numbers (GTINs). The first digit is a linkage flag. The following 13 digits are data characters. The 13 data characters plus an implied check digit form a GS1 14-digit item identification number including a leading Indicator digit. NOTE: The leading (01) is the implied application identifier (AI) and is not encoded in the symbol. The last digit, which is a check digit, is not directly encoded in the barcode.

Sample of a GS1 DataBar-14 Truncated/RSS-14 Truncated Barcode

How to create GS1 DataBar-14 Truncated/RSS-14 Truncated barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a GS1 DataBar-14 Truncated/RSS-14 Truncated barcode image, please follow these steps:
  • Set the Symbology property to GS1DataBarTruncated or GS1DataBar14Truncated or Rss14Truncated
  • Setting up dimensions:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarHeight property to 0.2704 (13 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.
Example of GS1 DataBar-14 Truncated/RSS-14 Truncated barcode images
Code property = 0061414199999, will produce the following barcode image:


GS1 DataBar-14 Truncated (Formerly RSS-14 Truncated - Reduced Space Symbology) CC-A and CC-B Composite Barcodes

This Symbology is also known as GS1 DataBar-14 Truncated Composite Barcode, GS1 DataBar-14 Truncated CC-A (CCA), GS1 DataBar-14 Truncated CC-B (CCB), GS1 DataBar-14 Truncated Composite A, GS1 DataBar-14 Truncated Composite B, GS1 DataBar-14 Truncated 2D Composite, GS1 DataBar-14 Truncated Composite Component A, GS1 DataBar-14 Truncated Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
GS1 DataBar-14 Truncated (formerly RSS-14 Truncated) Composite Barcode is an GS1 DataBar-14 Truncated linear barcode linked to a 2D barcode called CC-A or CC-B.
  • GS1 DataBar-14 Truncated can identify small items and carry more information than the current EAN/UPC barcode. GS1 DataBar enables GTIN identification for hard-to-mark products like fresh foods, jewelry and do-it-yourself hardware products and can carry GS1 Application Identifiers (AI) such as serial numbers, lot numbers, and expiration dates. This creates the opportunity for solutions supporting product authentication and traceability, product quality and effectiveness, variable measure product identification, and couponing.
  • The 2D Composite Component that can be liked to GS1 DataBar-14 Truncated can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create GS1 DataBar-14 Truncated CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get GS1 DataBar-14 Truncated CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to GS1DataBar14TruncatedCCA or GS1DataBar14TruncatedCCB or GS1DataBarTruncatedCCA or GS1DataBarTruncatedCCB or Rss14TruncatedCCA or Rss14TruncatedCCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.0208 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.2704 (13 * BarWidth) or higher (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
GS1 DataBar-14 Truncated CC-A and CC-B barcode images examples

NOTE: The Primary Data must be a 13-digit value representing a GTIN-14 code excluding AI (01) and last check digit.

Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarTruncatedCCA, AddChecksum property = True will produce the following barcode image:
Code property = 0361234567890|11990102 (Primary Data = 0361234567890 and Secondary Data = 11990102), Symbology property = GS1DataBarTruncatedCCB, AddChecksum property = True will produce the following barcode image:


GS1 DataMatrix Barcode

This Symbology is also known as GS1 2D DataMatrix

Overview
GS1 DataMatrix allows you to encode GS1 System Application Identifiers (AI) into DataMatrix 2D barcodes.
GS1 was developed to provide a worldwide format and standard for exchanging common data between companies. While other barcodes simply encode data with no respect for what the data represents, GS1 System encodes data and encodes what that data represents.
GS1 System has a list of Application Identifiers (AI). The Application Identifier is a 2, 3, or 4-digit number that identifies the type of data which follows. By convention, the Application Identifier is enclosed in parentheses when printed below the barcode (the parentheses are only for visual clarity, and are not encoded in the barcode).

GS1 DataNatrix is based on DataMatrix ECC200 barcode standard (ISO/IEC 16022), which is a two-dimensional (2D) barcode symbology which can store from 1 to about 2,000 characters, supporting advanced encoding error checking and correction algorithms (reed-solomon).

How to encode GS1 DataMatrix using Barcode Professional products

Introduction
GS1 System encodes the so called Element Strings which are composed of an Application Identifier (AI) plus a data field. Each AI identifies the meaning and format of the data following it. The code FNC1 (Function 1 Character) is generally used to concatenate two or more data fields in a unique barcode image (FNC1 is automatically handled by Barcode Professional products).
Examples
Encoding single AIs
The following example encodes a Global Trade Item Number (GTIN) 95012345678903 - with AI 01 (Shipping Contained Code) - into a GS1 DataMatrix barcode

Code property = (01)95012345678903 will produce the following barcode image:
Concatenation of AIs in a unique barcode image
  • Concatenation of the Pre-Defined Length Element Strings
    Concatenated Element Strings constructed from Application Identifiers with a pre-defined length do not require a Separator Character (FNC1). Each Element String is immediately followed by either the next Application Identifier or the Symbol Check Character and Stop Character.

    Example
    Concatenation of net weight (4 kg) with the associated Global Trade Item Number (GTIN) 95012345678903 does not require the use of a Separator Character (FNC1).

    AI 01 (Shipping Contained Code) has a pre-defined Element String length of 16 digits.
    AI 31 (Product Net Weight in Kg) has a pre-defined Element String length of 10 digits.

    Code property = (01)95012345678903(3102)000400 will produce the following barcode image:
  • Concatenation of Variable Length Data Strings
    Concatenating Element Strings of variable length involves the use of a Separator Character (FNC1). It is placed immediately after the last symbol character of a variable length data string and is followed by the Application Identifier of the next Element String. If the Element String is the last to be encoded, it is followed by the Symbol Check and Stop Characters and not the FNC1 Separator Character.

    Example
    Concatenation of AI 8005 Price per Unit of Measure (365 currency units) and AI 10 Batch Numbers (123456) requires the use of a Separator Character (FNC1) immediately after the price per unit of measure.

    Code property = (8005)000365(10)123456 will produce the following barcode image:


IATA 2 of 5 Barcode

This Symbology is also known as 2 of 5 IATA, 2/5 IATA, International Air Transport Assosiation 2 of 5

Overview
IATA 2 of 5 barcode is used by International Air Transport Assosiation (IATA) for the management of air cargo. The barcode is based on Industrial 2 of 5 standard requiring a mandatory check digit.

Sample of a IATA 2 of 5 Barcode

How to create IATA 2 of 5 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a IATA 2 of 5 barcode image, please follow these steps:
  • Set the Symbology property to IATA2of5
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Only numeric values are supported by this Symbology
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of a IATA 2 of 5 barcode image
Code property = 123456789 will produce the following barcode image:


Industrial 2 of 5 Barcode

This Symbology is also known as 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5

Overview
Industrial or Stanadard 2 of 5 is a low-density numeric symbology that has been with us since the 1960s. It has been used in the photofinishing and warehouse sorting industries, as well as sequentially numbering airline tickets. A more efficient implement of Industrial 2 of 5 is the Interleaved 2 of 5 symbology.

Sample of an Industrial 2 of 5 Barcode

How to create Industrial 2 of 5 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Industrial 2 of 5 barcode image, please follow these steps:
  • Set the Symbology property to Industrial2of5
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Only numeric values are supported by this Symbology
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of an Industrial 2 of 5 barcode image
Code property = 123456789 will produce the following barcode image:


Interleaved 2 of 5 Barcode

This Symbology is also known as ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved

Overview
Interleaved 2 of 5 is a higher-density numeric symbology based upon the Industrial 2 of 5 symbology. It is suitable for encoding general purpose all-numeric data and is used primarily in the distribution and warehouse industry. Interleaved 2 of 5 is essentially identical to Industrial 2 of 5 except for the fact that Interleaved 2 of 5 encodes information in both the bars and spaces while Standard 2 of 5 only encodes information in the bars. However, the encoding scheme is the same for both in terms of their use of wide and narrow elements for each element.

Sample of an Interleaved 2 of 5 Barcode

Sample of an Interleaved 2 of 5 Barcode with Bearer Bars

How to create Interleaved 2 of 5 (ITF 2/5) barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Interleaved 2 of 5 (ITF 2/5) barcode image, please follow these steps:
  • Set the Symbology property to Interleaved2of5
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Only numeric values are supported by this Symbology. The number of digits to encode (with or without the checksum) must be even, otherwise 0 (zero) will be added at the beginning of the value to encode.
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of an Interleaved 2 of 5 (ITF 2/5) barcode image
Code property = 1234567890123 will produce the following barcode image:
Code property = 1234567890123 and BearerBarStyle property = Frame and HorizontalRules will produce the following barcode images:


ISBN Barcode

This Symbology is also known as International Standard Book Number, Bookland EAN, ISBN-13, ISBN-10, ISBN+5, ISBN+2, ISBN Supplement 5/Five-digit Add-On, ISBN Supplement 2/Two-digit Add-On

Overview
ISBN stands for International Standard Book Number - a unique identifier assigned to each edition of every published book and book-like product. The purpose of the ISBN is to establish and identify one title or edition of a title from one specific publisher and is unique to that edition, allowing for more efficient marketing of products by booksellers, libraries, universities, wholesalers and distributors.
The ISBN was originally developed as a 10-digit number, which for more than three decades has performed extremely well as a catalog number for books. However, the International ISBN Agency has determined that sometime in the not-too-distant future they will begin to run out of 10-digit numbers for publishers. Accordingly, in January 2007, the ISBN will be redefined from a 10-digit to a 13-digit number.
Barcode Professional supports both ISBN-10 as well as ISBN-13 numbers and thus, you can pass to it both type of ISBNs as the value to encode. All ISBN-10 number is automatically converted to ISBN-13 by Barcode Professional.
The Components of an ISBN
The ISBN number is either 10 or 13 digits long and consists of four or five parts:
  • If 13-digit ISBN, a GS1 Prefix, either 978 or 979
  • The country of origin or language code
  • The publisher number which is assigned by the national ISBN agency
  • The item number
  • The checksum character which ensures that each ISBN is valid, meaning that the number is correct
Notes
  • The different parts can have different lengths and are usually separated by hyphens (-)
  • The "X" that you see at the end of some ISBNs is a Roman numeral, a way of putting the number "10" into a single digit
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only. For ISBN barcodes a Five-digit Add-On is usually used for the Retail Suggested Price.

Sample of an ISBN Five-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create ISBN barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an ISBN barcode image, please follow these steps:
  • Set the Symbology property to Isbn
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with an ISBN number. You can specify 10-digit ISBN as well as 13-digit ISBN
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to ISBN + number string
ISBN barcode images example
Code property = 0-7356-2153-5, DisplayLightMarginIndicator
            property = True, EanUpcSupplement property = Digits5, and EanUpcSupplementCode
            property = 90000, and Text property = ISBN 0-7356-2153-5 will
            produce the following barcode image:


ISMN Barcode

This Symbology is also known as International Standard Music Number, ISMN-13, ISMN-10, ISMN+5, ISMN+2, ISMN Supplement 5/Five-digit Add-On, ISMN Supplement 2/Two-digit Add-On, ISO 10957

Overview
The International Standard Music Number (ISMN) is a unique number for the identification of all printed music publications from all over the world, whether available for sale, hire or gratis--whether a part, a score, or an element in a multi-media kit.
The ISMN is designed to rationalize the processing and handling of printed music and the respective bibliographical data for publishing houses, the music trade and libraries.
The Components of an ISMN
The structure for ISMN numbers is the following:
  • The letter M used to distinguish the ISMN from the ISBN
  • 3 digits for Publisher identifier
  • 5 digits for Item identifier
  • 1 digit for checksum
Based on the ISMN number passed to Barcode Professional, it will generate an EAN-13 barcode representing the specified ISMN.
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of an ISMN Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create ISMN barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an ISMN barcode image, please follow these steps:
  • Set the Symbology property to Ismn
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with an ISMN number
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
ISMN barcode images example
Code property = M-345-12345-8 will produce the following barcode image:


ISSN Barcode

This Symbology is also known as International Standard Serial Number, ISSN-13, ISSN-10, ISSN+5, ISSN+2, ISSN Supplement 5/Five-digit Add-On, ISSN Supplement 2/Two-digit Add-On

Overview
The ISSN (International Standard Serial Number) is an eight-digit number which identifies periodical publications as such, including electronic serials.
The ISSN is a numeric code which is used as an identifier: it has no signification in itself and does not contain in itself any information referring to the origin or contents of the publication.
The ISSN takes the form of the acronym ISSN followed by two groups of four digits, separated by a hyphen. The eighth character is a control digit calculated according to a modulo 11 algorithm on the basis of the 7 preceding digits; this eighth control character may be an "X" if the result of the computing is equal to "10", in order to avoid any ambiguity.

Sample of an ISSN Barcode
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create ISSN barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an ISSN barcode image, please follow these steps:
  • Set the Symbology property to Issn
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with an ISSN number
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
ISSN barcode images example
Code property = 1234-5678 will produce the following barcode image:


ITF-14 Barcode

This Symbology is also known as UPC Shipping Container Symbol ITF-14, ITF14, Case Code, UPC Case Code, EAN/UCC-14, EAN-14, UCC-14, DUN-14, GTIN-14

Overview
The ITF-14 or UPC Shipping Container Symbol is used to mark cartons, cases, or pallets that contain products which have a UPC or EAN product identification number. The short-hand name for the symbol is "ITF-14", which is an acronym for "Interleaved 2 of 5" (the Barcode Symbology used) and 14 digits (the length of the container symbol).
The ITF-14 symbol has the following structure:
  • 1 digit for Packaging indicator
  • 2 digits for UPC numbering system or EAN prefix
  • 5 digits for Manufacturer identification number
  • 5 digits for Item identification number
  • 1 digit for Checksum which is automatically calculated by Barcode Professional
The value to encode passed to Barcode Professional must be 13 digits only because the 14th digit (the checksum) is automatically calculated by Barcode Professional products.

Sample of an ITF-14 Barcode with Bearer Bar

How to create ITF-14 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an ITF-14 barcode image, please follow these steps:
  • Set the Symbology property to Itf14
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the BarRatio property
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. You must specify the first 13 digits only because the checksum is automatically calculated
  • Setting up the Bearer Bars:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
Example of an ITF-14 barcode image
Code property = 1540014128876 and BearerBarStyle property = Frame and HorizontalRules will produce the following barcode images:


JAN-13 Barcode

This Symbology is also known as Japanese Article Number 13, JAN-13 Supplement 5/Five-digit Add-On, JAN-13 Supplement 2/Two-digit Add-On, JAN-13+5, JAN-13+2, JAN13, JAN13+5, JAN13+2

Overview
JAN-13 (Japanese Article Numbering) barcode Symbology is another name for EAN-13 barcode Symbology.
For JAN barcodes the first two digits must be 45 or 49 which identifies Japan.

Sample of a JAN-13 Barcode
The value to encode by JAN-13 has the following structure:
  • 2 digits for Number System or Country Code which MUST BE 49 or 45
  • 5 digits for Manufacturer (Company) Code or prefix
  • 5 digits for Product Code
  • 1 digit for checksum
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of a JAN-13 Five-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create JAN-13 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a JAN-13 barcode image, please follow these steps:
  • Set the Symbology property to Jan13
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following structure:
    • 2 digits for Number System or Country Code which MUST BE 45 or 49
    • 5 digits for Manufacturer (Company) Code or prefix
    • 5 digits for Product Code
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
JAN-13 barcode images examples
Code property = 490123456789, AddChecksum property = True and DisplayLightMarginIndicator property = True will produce the following barcode image:
Code property = 490123456789, AddChecksum
            property = True and DisplayLightMarginIndicator property = True,
            EanUpcSupplement property = Digits5, and EanUpcSupplementCode
            property = 12345 will produce the following barcode image:


JAN-8 Barcode

This Symbology is also known as Japanese Article Number 8, JAN-8 Supplement 5/Five-digit Add-On, JAN-8 Supplement 2/Two-digit Add-On, JAN-8+5, JAN-8+2, JAN8, JAN8+5, JAN8+2

Overview
JAN-8 (Japanese Article Numbering) barcode Symbology is another name for EAN-8 barcode Symbology.
For JAN barcodes the first two digits must be 45 or 49 which identifies Japan.

Sample of a JAN-8 Barcode
The value to encode by JAN-8 has the following structure:
  • 2 digits for Number System or Country Code which MUST BE 49 or 45
  • 5 digits for Product Code
  • 1 digit for checksum
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of a JAN-8 Two-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create JAN-8 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a JAN-8 barcode image, please follow these steps:
  • Set the Symbology property to Jan8
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.86 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.925 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with a value with the following structure:
    • 2 digits for Number System or Country Code which MUST BE 45 or 49
    • 5 digits for Product Code
    • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
JAN-8 barcode images examples
Code property = 4901234, AddChecksum property = True and DisplayLightMarginIndicator property = True will produce the following barcode image:
Code property = 4901234, AddChecksum property = True and DisplayLightMarginIndicator property = True, EanUpcSupplement property = Digits2, and EanUpcSupplementCode property = 78 will produce the following barcode image:


Macro PDF417 Barcode

This Symbology is also known as Macro Portable Data File 417, Macro PDF 417

Overview
Macro PDF417, or Macro Portable Data File 417, has the same features as PDF417 standard. Macro PDF417 provides a standard mechanism for creating a distributed representation of data files too large to be represented by set of single PDF417 symbols.

Macro PDF417 symbols differ from ordinary PDF417 symbols in that they contain additional control information in a zone called Macro PDF417 Control Block. Using Macro PDF417, large data files are split into several data segments and encoded into individual symbols. The Macro PDF417 decoder device uses the Control Block's information to reconstruct the file correctly, independent of symbol scanning order.

Sample of a Macro PDF417 Barcode sequence

How to create Macro PDF417 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a set of Macro PDF417 barcode images, please follow these steps:
  • Set the Symbology property to MacroPdf417
  • Set the Pdf417CompactionType property to:
    • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
    • Binary: It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
    • Numeric: It allows efficient encoding of numeric data strings.
    • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
  • Set the Pdf417ErrorCorrectionLevel property. ISO/IEC standards recommend a minimum error correction level of 2.
  • Setting up dimensions and quiet zones:
    • In our PDF417 implementation the BarHeight property is calculated as BarWidth * BarRatio
      • Set the BarWidth property (Value is expressed in Inches)
      • Set the BarRatio property to an integer greater than or equal to 3
    • Set the Pdf417Rows property to a value ranging from 3 to 90. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the Pdf417Columns property to a value ranging from 1 to 30. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the QuietZone property to double of BarWidth (Value is expressed in Inches)
    • (Optional) Set the Pdf417AspectRatio property to a value ranging from 0 to 1. It's the ratio of the height to the overall width of the symbol. NOTE: For Pdf417AspectRatio property takes effect, Pdf417Rows and Pdf417Columns properties must be set to 0 (zero).
  • Setting up the value to encode:
    • Split the value to encode in N segments.
    • Set the Pdf417SegmentCount to N
    • Set the Code property with the value to encode. You will have to set up the Code property N times to each segment's content.
    • Set the Pdf417SegmentIndex property to the current segment index you are encoding. It will be a value ranging from 0 to N-1
    • Set the Pdf417FileId property to the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Example of a Macro PDF417 barcode image
  • Value to encode: INVOICE #010264783 Customer: John Doe
  • Split the value to encode in N segments. Suppose we want to split that data in two (N = 2) segments:
    • Segment #1: INVOICE #010264783
    • Segment #2: Customer: John Doe
  • Common Settings for ALL segments:
    • Set the Pdf417FileId property to 123000 NOTE: Remember that the File ID must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
    • Set the Pdf417SegmentCount property to 2 (There are two segments)
  • Settings for EACH segments:
    • Encoding Segment #1:
      • Set the Pdf417SegmentIndex property to 0
      • Set the Code property to INVOICE #010264783

        The following Macro PDF417 barcode is generated:
    • Encoding Segment #2:
      • Set the Pdf417SegmentIndex property to 1
      • Set the Code property to Customer: John Doe

        The following Macro PDF417 barcode is generated:


Matrix 2 of 5 Barcode

This Symbology is also known as 2 of 5 Matrix, 2/5 Matrix

Overview
Matrix 2/5 is a linear barcode symbology which encodes numeric values only with an optional check digit.

Sample of a Matrix 2 of 5 Barcode

How to create Matrix 2 of 5 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Matrix 2 of 5 barcode image, please follow these steps:
  • Set the Symbology property to Matrix2of5
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Only numeric values are supported by this Symbology
  • Setting up the Bearer Bars if needed:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of a Matrix 2 of 5 barcode image
Code property = 123456789 will produce the following barcode image:


UPS MaxiCode Barcode

Also known as MaxiCode, Maxi Code, UPS barcode, United Parcel Service MaxiCode

Overview
MaxiCode is a fixed-size (approximately 1 inch by 1 inch) 2D matrix barcode symbology which is made up of offset rows of hexagonal modules arranged around a unique finder pattern. MaxiCode was originally created and used by United Parcel Service (UPS) for tracking and managing the shipment of packages.

MaxiCode barcode can encode 256 international characters; values 0-127, in accordance with ANSI X3.4, i.e. all 128 ASCII characters and values 128-255 in accordance with ISO 8859-1 (Latin Alphabet No. 1). Although the capacity of a MaxiCode symbol is not as high as other 2D matrix barcode symbologies, it was primarily designed to encode address data. The maximum data capacity in a single MaxiCode Symbol is 93 alphanumeric characters or 138 numeric characters.

MaxiCode features "Structured Append" which allows files of data to be represented in up to 8 MaxiCode symbols. The original data can be correctly reconstructed regardless of the order in which the symbols are scanned.

MaxiCode symbols are divided into a primary and a secondary message featuring Reed-Solomon error correction. In general, the Primary message normally encodes a postal code, a 3 digit country code and a 3 digit class of service number while the Secondary message normally encodes address data and any other required information. In addition, MaxiCode has modes which are used to define the structuring of the data and error correction within a symbol. The following modes are available:
MaxiCode Modes | Description
Mode 0 | It is obsolete and superseded by Modes 2 and 3.
Mode 1 | It is obsolete and superseded by Mode 4.
Mode 2 & 3 | Structured Carrier Message. Modes 2 and 3 are designed for use in the transport industry. They encode the destination address and the class of service as defined by the carrier.
Mode 4 | Standard Symbol. It indicates that the symbol employs Enhanced Error Correction (EEC) in the Primary Message and Standard Error Correction (SEC) for the Secondary Message.
Mode 5 | Full EEC. It indicates that the symbol employs Enhanced Error Correction (EEC) for both the Primary and Secondary Message.
Mode 6 | Reader Programming. It indicates that the symbol encodes a message used to program the reader system and that Standard Error Correction (SEC) is used for the Secondary Message. When a Mode 6 symbol is read no data shall be transmitted.

Special Message Structure when using Mode 2 and 3 (Structured Carrier Message)
MaxiCode Mode 2 and Mode 3 shall be reserved for use as a destination sortation symbol for use by carriers in the transport industry. In these modes, the primary message is always data specific and encodes postal code, country code and service class. The three primary data elements should be supplied in the above order separated by GS (Group Separator - ASCII 29) immediately followed by the secondary message contents. In addition, each data element shall be of the correct type, e.g. postal codes in mode 2 must be all numeric and in mode 3 it must be alphanumeric.

There are two standard message formats when using Mode 2 and Mode 3:

  • Messages Beginning with "[)>RS01GS": Messages which begin with the seven encoded data characters "[)>RS01GS" conform to particular open system standards and has the following structure:
    • [)>RS (Message Header)
    • 01GS (Format Header)
    • 2-digit representing the year (YY) of a date
    • Postal/Zip Code:
      • If Mode 2 (NUMERIC ONLY): 5-digit zip code + 4-digit zip code extension (if none exists, four zeros 0000 must be specified)
      • If Mode 3 (ALPHANUMERIC): 6-alphanumeric characters zip code (A through Z or 0 to 9)
    • GS
    • 3-digit country code (from ISO 3166) - NOTE: Mode 2 supports the US Country Code (840). For other country codes please use Mode 3 instead.
    • GS
    • 3-digit class of service
    • GS
    • <tracking number> (Mandatory Data for UPS)
    • GS<SCAC> (Mandatory Data for UPS)
    • GS<UPS shipper number>
    • GS<Julian day of pickup>
    • GS<shipment ID number>
    • GS<n/x> (Package n/x)
    • GS<package weight>
    • GS<address validation>
    • GS<ship to street address>
    • GS<ship to city>
    • GS<ship to state>
    • RS
    • EOT (End of Message)

      Where GS (ASCII 29) is used to separate fields in a message; RS (ASCII 30) is used to separate format types; and EOT (ASCII 4) is the end of transmission characters.

  • Messages NOT Beginning with "[)>RS01GS":
    • Postal/Zip Code:
      • If Mode 2 (NUMERIC ONLY): 5-digit zip code + 4-digit zip code extension (if none exists, four zeros 0000 must be specified)
      • If Mode 3 (ALPHANUMERIC): 6-alphanumeric characters zip code (A through Z or 0 to 9)
    • GS
    • 3-digit country code (from ISO 3166) - NOTE: Mode 2 supports the US Country Code (840). For other country codes please use Mode 3 instead.
    • GS
    • 3-digit class of service
    • GS
    • <The secondary message data in the required format>
    • EOT (End of Message)

      Where GS (ASCII 29) is used to separate fields in a message and EOT (ASCII 4) is the end of transmission characters.

Sample of a MaxiCode barcode

How to create MaxiCode barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a MaxiCode barcode image, please follow these steps:
  • Set the Symbology property to MaxiCode
  • Set the MaxiCodeMode property
  • Set the Code property with the value to encode. NOTE: To encode Mode 2 or 3, then please specify the message in the correct format/structure (more info above)
  • If desired, you can use the tilde character "~" to specify special characters in the input data e.g. ~013 is used to represent the ASCII character with the decimal value 13 (CR). To do that you must set the MaxiCodeProcessTilde property to True.

Examples of MaxiCode barcode images

Code property = ABC123456789 and MaxiCodeMode property = Mode4 will produce the following barcode image:

Code property = [)>~03001~029961Z00004951~029UPSN~02906X610~029159~0291234567~0291/1~029~029Y~029634 ALPHA DR~029PITTSBURGH~029PA~030~004 and MaxiCodeMode property = Mode2 and MaxiCodeProcessTilde property = True will produce the following barcode image (NOTE: Where ~029 is GS (ASCII 29); ~030 is RS (ASCII 30) and ~004 is EOT (ASCII 4)):

Code property = 524032140~029840~029001~029AIM USA~029634 ALPHA DRIVE~029PITTSBURGH~029PA~004 and MaxiCodeMode property = Mode3 and MaxiCodeProcessTilde property = True will produce the following barcode image (NOTE: Where ~029 is GS (ASCII 29) and ~004 is EOT (ASCII 4)):


Micro PDF417 Barcode

This Symbology is also known as Micro Portable Data File 417, Micro PDF 417, MicroPDF417

Overview
MicroPDF417 is a multi-row symbology which may be utilized by applications needing to encode a moderate amount of data in a two-dimensional (2D) symbol (up to 150 bytes, 250 alphanumeric characters, or 366 numeric digits), and when minimizing symbol size is a primary concern. MicroPDF417 is based on PDF417 standard. MicroPDF417, unlike PDF417, may only be printed in certain defined combinations of rows, columns, and error correction codewords, up to a maximum of four data columns by 44 rows.

The data is encoded using one of three compaction modes: Text compaction mode, Binary compaction mode, and Numeric compaction mode.
Barcode Professional products support the following MicroPDF417 Compaction modes
  • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
  • Binary: It allows encoding all 256 possible 8-bit byte values (ISO/IEC 8859-1). This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
  • Numeric: It allows efficient encoding of numeric data strings.
  • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
Micro PDF417 Versions
MicroPDF417 symbols conform to certain predefined combinations of numbers of rows, columns, and number of error-correction codewords.
Micro PDF417 Error Correction
Each MicroPDF417 symbol contains at least seven error correction codewords. The Error Correction codewords provide capability for both error detection and correction. The number of error correction codewords for a MicroPDF417 symbol is fixed for each symbol version.
Structured Append
MicroPDF417 uses the Macro PDF417 mechanism for Structured Append. This mechanism allows files of data to be represented logically and consecutively in a number of MicroPDF417 symbols. Up to 99 999 different MicroPDF417 symbols can be so linked or concatenated and be scanned in any sequence to enable the original data file to be correctly reconstructed.

Sample of a Micro PDF417 Barcode

How to create Micro PDF417 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Micro PDF417 barcode image, please follow these steps:
  • Set the Symbology property to MicroPdf417
  • Set the Pdf417CompactionType property to:
    • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
    • Binary: It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
    • Numeric: It allows efficient encoding of numeric data strings.
    • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
  • Setting up dimensions and quiet zones:
    • In our PDF417 implementation the BarHeight property is calculated as BarWidth * BarRatio
      • Set the BarWidth property (Value is expressed in Inches)
      • Set the BarRatio property to an integer greater than or equal to 2
    • Set the MicroPdf417Version property to the predefined combination of columns and rows. Specify Auto so that Barcode Professional can determine it automatically based on the value to encode.
    • Set the QuietZone property to double of BarWidth (Value is expressed in Inches)
  • Setting up the value to encode:
    • For single MicroPDF417 symbol:
      • Set the Code property with the value to encode
    • For Structured Append MicroPDF417 symbols:
      • Split the value to encode in N segments.
      • Set the Pdf417SegmentCount to N
      • Set the Code property with the value to encode. You will have to set up the Code property N times to each segment's content.
      • Set the Pdf417SegmentIndex property to the current segment index you are encoding. It will be a value ranging from 0 to N-1
      • Set the Pdf417FileId property to the File ID of the Micro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Example of a single Micro PDF417 barcode image

Code property = ABCDEFGHIJKLMNOPQRSTUVWXYZ1234567890 and BarRatio property = 4 and MicroPdf417Version property = V4X10 and Pdf417CompactionType property = Auto will produce the following barcode image:

Example of a Structured Appended Micro PDF417 barcode image
  • Value to encode: INVOICE #010264783 Customer: John Doe
  • Split the value to encode in N segments. Suppose we want to split that data in two (N = 2) segments:
    • Segment #1: INVOICE #010264783
    • Segment #2: Customer: John Doe
  • Common Settings for ALL segments:
    • Set the Pdf417FileId property to 123000 NOTE: Remember that the File ID must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
    • Set the Pdf417SegmentCount property to 2 (There are two segments)
  • Settings for EACH segments:
    • Set the BarRatio property to 4
    • Set the MicroPdf417Version to V4X10 (Both MicroPDF417 Symbols will have the same size)
    • Encoding Segment #1:
      • Set the Pdf417SegmentIndex property to 0
      • Set the Code property to INVOICE #010264783

        The following Micro PDF417 barcode is generated:
    • Encoding Segment #2:
      • Set the Pdf417SegmentIndex property to 1
      • Set the Code property to Customer: John Doe

        The following Micro PDF417 barcode is generated:


Micro QR Code Barcode

Micro QR Code (Micro Quick Response Code)

Also known as Denso Micro Barcode, Micro QRCode, Micro Quick Response Code, Micro QRCode Model 2, JIS X 0510, ISO/IEC18004

Overview
QR Code is a kind of 2-D (two-dimensional) symbology developed by Denso Wave (a division of Denso Corporation at the time) and released in 1994 with the primary aim of being a symbol that is easily interpreted by scanner equipment. Micro QR Code is a very small QR Code barcode that fits applications that require a smaller space and use smaller amounts of data, such as ID of printed circuit boards and electronics parts, etc.

Micro QR Code is capable of handling all types of data, such as numeric and alphabetic characters, Kanji, Kana, Hiragana, symbols, binary, and control codes.

The symbol versions of Micro QR Code range from Version 1 to Version 4. Each version has a different module configuration or number of modules (the module refers to the black and white dots that make up Micro QR Code). "Module configuration" refers to the number of modules contained in a symbol, commencing with Version 1 (11 x 11 modules) up to Version 4 (17 x 17 modules). Each higher version number comprises 2 additional modules per side. Each Micro QR Code symbol version has the maximum data capacity according to the amount of data, character type and error correction level.

Micro QR Code is not capable of storing much data (maximum 35 numeric characters). However, because it can store data for each symbol size more efficiently than QR Code, the size of Micro QR Code symbols does not significantly increase, even though the amount of data is increased.

Maximum Data Capacity for each Micro QR Code Symbol Version:
Symbol version | Number of modules | Error correction level | Numeric | Alphanumeric | Binary | Kanji
M1 | 11 | - | 5 | - | - | -
M2 | 13 | L | 10 | 6 | - | -
 |  | M | 8 | 5 | - | -
M3 | 15 | L | 23 | 14 | 9 | 6
 |  | M | 18 | 11 | 7 | 4
M4 | 17 | L | 35 | 21 | 15 | 9
 |  | M | 30 | 18 | 13 | 8
 |  | Q | 21 | 13 | 9 | 5

Sample of a MicroQR Code barcode

How to create Micro QR Code barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Micro QR Code barcode image, please follow these steps:
  • Set the Symbology property to MicroQRCode
  • Set the MicroQRCodeVersion property
  • Set the QRCodeErrorCorrectionLevel property
  • Set the QRCodeEncoding property
  • Setting up dimensions and quiet zones:
    • Set the QRCodeModuleSize property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode

Example of Micro QR Code barcode images

Code property = ABC123456789 will produce the following barcode image:


PDF417 Barcode

This Symbology is also known as Portable Data File 417, PDF 417, PDF417 Truncated

Overview
PDF417, or Portable Data File 417, is a two-dimensional (2D) stacked barcode symbology capable of encoding over a kilobyte of data per label. It was developed by Symbol Technologies (1989-1992) and is currently maintained by ISO/IEC.
Large amounts of text and data can be stored securely and inexpensively when using the PDF417 symbology. The printed symbol consists of several linear rows of stacked codewords. Each codeword represents 1 of 929 possible values from one of three different clusters. A different cluster is chosen for each row, repeating after every three rows.

The data is encoded using one of three compaction modes: Text compaction mode, Binary compaction mode, and Numeric compaction mode.
Barcode Professional products support the following PDF417 Compaction modes:
  • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
  • Binary: It allows encoding all 256 possible 8-bit byte values (ISO/IEC 8859-1). This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
  • Numeric: It allows efficient encoding of numeric data strings.
  • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
PDF417 Error Correction Level
PDF417 uses Reed Solomon error correction instead of check digits. This error correction allows the symbol to withstand some damage without causing loss of data. The error correction levels range from 0 to 8. The recommend minimum error correction level is 2.
Compact PDF417
Barcode Professional products support Compact PDF417 (formerly Truncated PDF417) version which omits the right-hand portion (right row indicator & stop pattern) in order to save space. Please refer to Compact PDF417 Symbology for further details.

Sample of a PDF417 Barcode

How to create PDF417 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a PDF417 barcode image, please follow these steps:
  • Set the Symbology property to Pdf417
  • Set the Pdf417CompactionType property to:
    • Text: It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
    • Binary: It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
    • Numeric: It allows efficient encoding of numeric data strings.
    • Auto: It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
  • Set the Pdf417ErrorCorrectionLevel property. ISO/IEC standards recommend a minimum error correction level of 2.
  • Setting up dimensions and quiet zones:
    • In our PDF417 implementation the BarHeight property is calculated as BarWidth * BarRatio
      • Set the BarWidth property (Value is expressed in Inches)
      • Set the BarRatio property to an integer greater than or equal to 3
    • Set the Pdf417Rows property to a value ranging from 3 to 90. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the Pdf417Columns property to a value ranging from 1 to 30. Specify zero (0) so that Barcode Professional can determine it automatically.
    • Set the QuietZone property to double of BarWidth (Value is expressed in Inches)
    • (Optional) Set the Pdf417AspectRatio property to a value ranging from 0 to 1. It's the ratio of the height to the overall width of the symbol. NOTE: For Pdf417AspectRatio property takes effect, Pdf417Rows and Pdf417Columns properties must be set to 0 (zero).
  • Set the Code property with the value to encode.
  • (Optional) Set the Pdf417Truncated to True if needed for generating a Compact PDF417 Symbol.
Example of a PDF417 barcode image
Code property = 123456789 and Pdf417CompactionType property = Auto will produce the following barcode image:
Code property = 123456789 and Pdf417CompactionType property = Auto and Pdf417Truncated property = True will produce the following barcode image:


QR Code Barcode

QR Code (Quick Response Code)

Also known as Denso Barcode, QRCode, Quick Response Code, JIS X 0510, ISO/IEC18004

Overview
QR Code is a kind of 2-D (two-dimensional) symbology developed by Denso Wave (a division of Denso Corporation at the time) and released in 1994 with the primary aim of being a symbol that is easily interpreted by scanner equipment.

QR Code is capable of handling all types of data, such as numeric and alphabetic characters, Kanji, Kana, Hiragana, symbols, binary, and control codes.

The symbol versions of QR Code range from Version 1 to Version 40. Each version has a different module configuration or number of modules (the module refers to the black and white dots that make up QR Code). "Module configuration" refers to the number of modules contained in a symbol, commencing with Version 1 (21 x 21 modules) up to Version 40 (177 x 177 modules). Each higher version number comprises 4 additional modules per side. Each QR Code symbol version has the maximum data capacity according to the amount of data, character type and error correction level. In other words, as the amount of data increases, more modules are required to comprise QR Code, resulting in larger QR Code symbols.

QR Code has error correction capability to restore data if the code is dirty or damaged. Four error correction levels are available for users to choose according to the operating environment. Raising this level improves error correction capability but also increases the amount of data QR Code size. To select error correction level, various factors such as the operating environment and QR Code size need to be considered. Level Q or H may be selected for factory environment where QR Code gets dirty, whereas Level L may be selected for clean environment with the large amount of data. Typically, Level M (15%) is most frequently selected. The QR Code error correction feature is implemented by adding a Reed-Solomon Code to the original data.

QR Code implementation in Barcode Professional supports FNC1 and Extended Channel Interpretation (ECI).

Sample of a QR Code barcode

How to create QR Code barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a QR Code barcode image, please follow these steps:
  • Set the Symbology property to QRCode
  • Set the QRCodeVersion property
  • Set the QRCodeErrorCorrectionLevel property
  • Set the QRCodeEncoding property
  • Setting up dimensions and quiet zones:
    • Set the QRCodeModuleSize property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode
  • If desired, you can use the tilde character "~" to specify special characters in the input data. To do that you must set the QRCodeProcessTilde property to True. Read more about how it works.
How QR Code tilde processing works
When working with QR Code tilde processing keep in mind the following rules:
  • ~1: is used to represent the FNC1 code
  • ~7NNNNNN: is used to specify the Extended Channel Interpretation (ECI) and NNNNNN is a value between 000000 and 999999. Default is ECI 000003 which represents the ISO 8859-1 Latin Alphabet No. 1
  • ~dNNN: is used to represent a byte value in decimal notation. NNN must be a numeric value ranging from 000 to 255
  • ~hXX: is used to represent a byte value in hexadecimal notation. XX must be a hexadecimal value ranging from 00 to FF
  • ~kXXXX: is used to represent a Kanji double-byte value in hexadecimal notation. XXXX must be a hexadecimal value of Shift JIS Kanji characters according to JIS X 0208:1997, Annex 1.

Example of QR Code barcode images

Code property = ABC 123456789 will produce the following barcode image:


SCC-14 Barcode

This Symbology is also known as Shipping Container Code, EAN/UCC 14, DUN-14, EAN-14, UCC-14, UPC Case Code, UPC Shipping Container Code, Distribution Unit Number 14, SCC14, DUN14, EAN14, UCC14, EAN/UCC-14, Despatch Unit Number 14, GTIN-14

Overview
SCC-14 (Shipping Container Code) is a 14-digit number assigned to fixed content shipping containers. The most widely used representation of SCC-14 is based on UCC/EAN-128 Barcode Symbology with the Application Identifier (AI) 01. However, other common implementation of SCC is called ITF-14.
The SCC-14 value to encode has the following structure:
  • 2 digits for UCC/EAN-128 Application Identifier (AI) which is always 01
  • 1 digit for Packaging indicator
  • 2 digits for UPC numbering system or EAN prefix
  • 5 digits for Manufacturer identification number
  • 5 digits for Item identification number
  • 1 digit for Checksum which is automatically calculated by Barcode Professional
The value to encode passed to Barcode Professional must be 15 digits with the following structure: 01 + 13 digits. The checksum is automatically calculated by Barcode Professional products.

Sample of a SCC-14 Barcode with Bearer Bar

How to create SCC-14 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a SCC-14 barcode image, please follow these steps:
  • Set the Symbology property to Scc14
  • Set the AddChecksum property to True
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 01 + 13 digits only
  • Setting up the Bearer Bars:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
Example of SCC-14 barcode images
Code property = 011061414100041 and BearerBarStyle property = Frame and HorizontalRules will produce the following barcode images:


Semacode Barcode

Also known as URL Barcodes, Semacode Tag

Overview
The fundamental concept of semacode is the URL barcode. A barcode is a machine readable visual tag, and a URL (Universal Resource Locators) is an internet address. Semacode Tag is the encoding of URLs into barcodes based on Data Matrix 2D Symbology.

Sample of a Semacode barcode

How to create Semacode barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Semacode barcode image, please follow these steps:
  • Set the Symbology property to Semacode
  • Setting up dimensions and quiet zones:
    • Set the DataMatrixModuleSize property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Specify the URL string you want to encode through out Semacode

Example of a Semacode barcode image

Code property = http://www.neodynamic.com will produce the following barcode image:


SSCC-18 Barcode

This Symbology is also known as UPC-128 Shipping Container Code, Code 128 UPC Shipping Container Code, Serial Shipping Container Code, UCC-128, EAN-18, NVE (Nummer der Versandeinheit)

Overview
This is a special version of UCC/EAN-128, with Application Identifier (AI) = 00. It is used to identify shipping containers by a serial number
An arbitrary SSCC-18 value to encode has a fixed length of 2+17+1 digits, with this structure: 00 [data] [checksum]
  • The "00" is the Application Identifier which identifies the data as SSCC-18
  • The [data] is a fixed length data structure of 17 digits. This is a unique number consisting of these parts:
    • 1 digit for Extension: The Extension digit has no predetermined logic; it is freely available to the member company (a member of the national EAN or UCC organization). In general it refers to Packaging Type
    • 7 digits for UCC/EAN Company Prefix: The EAN/UPC Company Prefix identifies the shipping company. It is assigned by the UCC or EAN to a member company. (In Germany this is called "BBN" - "Bundeseinheitliche Betriebsnummer".)
    • 9 digits for Serial Reference Number: The Serial Reference Number is assigned by the member company to identify an individual shipping container
  • The [checksum] is the application-specific mod 10 check digit which is automatically calculated by Barcode Professional products
The value to encode passed to Barcode Professional must be:
00 + Extension (1 digit) + Company Prefix (7 digits) + Serial Reference Number (9 digits)
Example: 0000614141123456789

Sample of a SSCC-18 Barcode with Bearer Bar

How to create SSCC-18 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a SSCC-18 barcode image, please follow these steps:
  • Set the Symbology property to Sscc18
  • Set the AddChecksum property to True
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 00 + 17 digits only
  • Setting up the Bearer Bars:
    • Set the BearerBarStyle property to Frame, or HorizontalRules
    • Set the BearerBarWidth property (Value is expressed in Inches)
Example of SSCC-18 barcode images
Code property = 0000614141123456789 and BearerBarStyle property = Frame and HorizontalRules will produce the following barcode images:


UPC-A Barcode

This Symbology is also known as Universal Product Code version A, UPC-A Supplement 5/Five-digit Add-On, UPC-A Supplement 2/Two-digit Add-On, UPC-A+5, UPC-A+2, UPC Code, UPC Symbol, GTIN-12, GS1-12, UCC-12

Overview
UPC-A is used for marking products which are sold at retail in the USA. The barcode identifies the manufacturer and specific product so point-of- sale cash register systems can automatically look up the price.
The UPC-A Code and the assignment of manufacturer ID numbers is controlled in the U.S.A. by the Uniform Code Council (UCC).

Sample of a UPC-A Barcode
The value to encode by UPC-A has the following structure (a.k.a. GTIN-12):
  • 1 digit for Number System (0: regular UPC codes, 1: reserved, 2: random weight items marked at the store, 3: National Drug Code and National Health Related Items code, 4: no format restrictions, for in-store use on non-food items, 5: for use on coupons, 6: reserved, 7: regular UPC codes, 8: reserved, 9: reserved)
  • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
  • 5 digits for Product Code which is assigned by the manufacturer
  • 1 digit for checksum
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of an UPC-A Two-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create UPC-A barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an UPC-A barcode image, please follow these steps:
  • Set the Symbology property to UpcA
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with one of the following structures:
    • You can specify full GTIN-12 digits:
      • 1 digit for Number System
      • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
      • 5 digits for Product Code which is assigned by the manufacturer
      • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
    • OR you can specify a 6-digit UPC-E code that will automatically be converted back to a full GTIN-12 UPC-A code.
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
UPC-A barcode images examples
Code property = 01234567890, AddChecksum property = True and DisplayLightMarginIndicator property = True will produce the following barcode image:
Code property = 01234567890, AddChecksum property = True and DisplayLightMarginIndicator property = True, EanUpcSupplement property = Digits2, and EanUpcSupplementCode property = 03 will produce the following barcode image:


UPC-A CC-A and CC-B Composite Barcodes

This Symbology is also known as UPC-A Composite Barcode, UPC-A CC-A (CCA), UPC-A CC-B (CCB), UPC-A Composite A, UPC-A Composite B, UPC-A 2D Composite, UPC-A Composite Component A, UPC-A Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
UPC-A Composite Barcode is an UPC-A linear barcode linked to a 2D barcode called CC-A or CC-B.
  • UPC-A is used for marking products which are sold at retail in the USA. The barcode identifies the manufacturer and specific product so point-of- sale cash register systems can automatically look up the price. The UPC-A Code and the assignment of manufacturer ID numbers is controlled in the U.S.A. by the Uniform Code Council (UCC). The numbers encoded in UPC-A bar codes are Global Trade Item Numbers (GTIN) of GS1 System.
  • The 2D Composite Component that can be liked to UPC-A can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create UPC-A CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get UPC-A CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to UpcACCA or UpcACCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
UPC-A CC-A and CC-B barcode images examples
Code property = 01234567890|991234-abcd (Primary Data = 01234567890 and Secondary Data = 991234-abcd), Symbology property = UpcACCA, AddChecksum property = True will produce the following barcode image:
Code property = 01234567890|991234-abcd (Primary Data = 01234567890 and Secondary Data = 991234-abcd), Symbology property = UpcACCB, AddChecksum property = True will produce the following barcode image:


UPC-E Barcode

This Symbology is also known as Universal Product Code version E, UPC-E Supplement 5/Five-digit Add-On, UPC-E Supplement 2/Two-digit Add-On, UPC-E+5, UPC-E+2, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead "0", GS1-12, UCC-12

Overview
UPC-E is a variation of UPC-A which allows for a more compact barcode by eliminating "extra" zeros.
Since the resulting UPC-E barcode is about half the size as an UPC-A barcode, UPC-E is generally used on products with very small packaging where a full UPC-A barcode couldn't reasonably fit.
A UPC-E barcode represents 6 digits with an implied number system 0. However, a Number System 1 can be used as well.

Sample of a UPC-E Barcode
The value to encode by UPC-E has the following structure and it's the same as for UPC-A (a.k.a. GTIN-12):
  • 1 digit for Number System (0: regular UPC codes, 1: reserved, 2: random weight items marked at the store, 3: National Drug Code and National Health Related Items code, 4: no format restrictions, for in-store use on non-food items, 5: for use on coupons, 6: reserved, 7: regular UPC codes, 8: reserved, 9: reserved)
  • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
  • 5 digits for Product Code which is assigned by the manufacturer
  • 1 digit for checksum
Add-On or Supplement code
The Add-On Symbols were designed to encode information supplementary to that in the main bar code symbol on periodicals and paperback books. The Add-On can be composed of 2 or 5 digits only.

Sample of an UPC-E Two-Digit Add-On Barcode
Light Margin Indicators - a greater than (>) and/or less than (<) character - are intended to protected the essential light areas to the left and right of the code that the barcode scanner needs to recognize the beginning and end.

How to create UPC-E barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an UPC-E barcode image, please follow these steps:
  • Set the Symbology property to UpcE
  • Change the Number System if needed by setting up the UpcESystem property to System0 or System1
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with one of the following structures:
    • You can specify full GTIN-12 digits:
      • 1 digit for Number System
      • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
      • 5 digits for Product Code which is assigned by the manufacturer
      • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
    • OR you can specify a 6-digit UPC-E code.
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to an Empty string
UPC-E barcode images examples
Code property = 01234567890 and AddChecksum property = True will produce the following barcode image:
Code property = 01234567890, AddChecksum property = True and DisplayLightMarginIndicator property = True, EanUpcSupplement property = Digits2, and EanUpcSupplementCode property = 03 will produce the following barcode image:


UPC-E CC-A and CC-B Composite Barcodes

This Symbology is also known as UPC-E Composite Barcode, UPC-E CC-A (CCA), UPC-E CC-B (CCB), UPC-E Composite A, UPC-E Composite B, UPC-E 2D Composite, UPC-E Composite Component A, UPC-E Composite Component B

Overview
In Barcode Composite Symbology, the linear component encodes the item's primary identification while the adjacent 2D Composite Component (abbreviated as CC) encodes supplementary data, such as a batch number and expiration date. The Composite Symbol always includes a linear component so that the primary identification is readable by all scanning technologies. The Composite Symbol always includes a multi-row 2D Composite Component that can be read with linear- and area-CCD scanners, and with linear and rastering laser scanners. The 2D Composite Component is printed above the linear component and both are separated by a separator pattern.
UPC-E Composite Barcode is an UPC-E linear barcode linked to a 2D barcode called CC-A or CC-B.
  • UPC-E is a variation of UPC-A which allows for a more compact barcode by eliminating "extra" zeros. Since the resulting UPC-E barcode is about half the size as an UPC-A barcode, UPC-E is generally used on products with very small packaging where a full UPC-A barcode couldn't reasonably fit. The numbers encoded in UPC-E bar codes are Global Trade Item Numbers (GTIN) of GS1 System.
  • The 2D Composite Component that can be liked to UPC-E can be one of the following depending on the amount of supplementary data to be encoded:
    • CC-A: it is a variant of MicroPDF417 barcode and the smallest of the 2D Composite Components which can encode up to 56 digits.
    • CC-B: it is a subset of MicroPDF417 barcode which can encode up to 338 digits. Encoding systems normally automatically select CC-B when the data to be encoded exceeds the capacity of CC-A.

How to create UPC-E CC-A and CC-B Composite Barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get UPC-E CC-A and CC-B Composite Barcode images, please follow these steps:
  • Set the Symbology property to UpcECCA or UpcECCB
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.013 (Value is expressed in Inches)
    • Set the BarRatio property to 3
    • Set the BarHeight property to 0.9 (Value is expressed in Inches)
    • If Guard Bars are needed:
      • Set the GuardBar property to True
      • Set the GuardBarHeight property to 0.965 (Value is expressed in Inches)
    • Set the QuietZone property to 0.091, 0, 0.091, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with the primary and secondary values separated by | char (See example below).
  • Add-On Settings if needed:
    • Set the EanUpcSupplement to Digits2 (Two-Digit Add-On) or Digits5 (Five-Digit Add-On)
    • Set the EanUpcSupplementCode with the Add-On value which must be 2 or 5 digits only
  • Drawn Light Margin Indicators if needed:
    • Set the DisplayLightMarginIndicator to True
  • Set the Text property to the Secondary Data which was encoded into the 2D Component
UPC-E CC-A and CC-B barcode images examples
Code property = 01234567890|991234-abcd (Primary Data = 01234567890 and Secondary Data = 991234-abcd), Symbology property = UpcECCA, AddChecksum property = True will produce the following barcode image:
Code property = 01234567890|991234-abcd (Primary Data = 01234567890 and Secondary Data = 991234-abcd), Symbology property = UpcECCB, AddChecksum property = True will produce the following barcode image:


Neodynamic.WinRT Namespace

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Neodynamic.WinRT Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarcodeProfessional | Neodynamic Barcode Professional lets you to quickly and easily generate high quality vector-based barcodes into Windows Store XAML WinRT applications.
Public class | BarcodeUtils | BarcodeUtils provides additional utilities related to barcode generation.

Enumerations

 | Enumeration | Description
Public enumeration | Alignment | Specifies the text alignment on the barcode image
Public enumeration | AztecCodeFormat | Specifies the Aztec Code Format to use on that symbology.
Public enumeration | BarcodeUnit | Specifies the unit of measure for barcode generation.
Public enumeration | BearerBarStyle | Specifies the bearer bars' type that must be drawn on the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcode symbologies.
Public enumeration | CodabarStartStopChar | Specifies the start and stop character for Codabar symbology.
Public enumeration | Code128 | Specifies the characters set to use in the Code 128 symbology.
Public enumeration | Code16k | Specifies the mode to use for Code16k symbology.
Public enumeration | DataMatrixEncoding | Specifies the DataMatrix Encoding to use on that symbology.
Public enumeration | DataMatrixFormat | Specifies the DataMatrix Format to use on that symbology.
Public enumeration | FIM | Specifies the facing identification mark (FIM) pattern to use on that symbology.
Public enumeration | FontUnit | Specifies the unit of measure for Font objects.
Public enumeration | Isbt128DataStructure | Specifies the ISBT 128 Data Structures.
Public enumeration | MaxiCodeModes | Specifies the MaxiCode modes.
Public enumeration | MicroPdf417Version | Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public enumeration | MicroQRCodeVersion | Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.
Public enumeration | MsiChecksum | Specifies the checksum method used for MSI barcodes
Public enumeration | Pdf417CompactionType | Specifies the Compaction Type to apply for PDF417 symbology.
Public enumeration | Pdf417ErrorCorrection | Specifies the Error Correction Level to apply for PDF417 symbology.
Public enumeration | QRCodeEncoding | Specifies the QR Code Encoding to use on that symbology.
Public enumeration | QRCodeErrorCorrectionLevel | Specifies the Error Correction Level to apply for QR Code symbology.
Public enumeration | QRCodeVersion | Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.
Public enumeration | Supplement | Specifies the supplement type to use with EAN and UPC symbologies.
Public enumeration | Symbology | Specifies the Barcode Symbology/Standard to be used.
Public enumeration | TelepenEncoding | Specifies the Telepen Encoding to use on that symbology.
Public enumeration | UpcE | Specifies the number system to use for UPC-E symbology.
Neodynamic Barcode Professional for XAML WinRT Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2012 Neodynamic - All rights reserved.


Alignment Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Alignment Enumeration
See Also Send Feedback
Specifies the text alignment on the barcode image

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Alignment
Visual Basic
Public Enumeration Alignment
Visual C++
public enum class Alignment

Members

Member name | Value | Description
AboveCenter | 0 |
AboveLeft | 1 |
AboveRight | 2 |
AboveJustify | 3 |
BelowCenter | 4 |
BelowLeft | 5 |
BelowRight | 6 |
BelowJustify | 7 |

See Also

Neodynamic.WinRT Namespace


AztecCodeFormat Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
AztecCodeFormat Enumeration
See Also Send Feedback
Specifies the Aztec Code Format to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum AztecCodeFormat
Visual Basic
Public Enumeration AztecCodeFormat
Visual C++
public enum class AztecCodeFormat

Members

Member name | Value | Description
Auto | 0 |
C15X15Compact | 1 |
C19X19 | 2 |
C19X19Compact | 3 |
C23X23 | 4 |
C23X23Compact | 5 |
C27X27 | 6 |
C27X27Compact | 7 |
C31X31 | 8 |
C37X37 | 9 |
C41X41 | 10 |
C45X45 | 11 |
C49X49 | 12 |
C53X53 | 13 |
C57X57 | 14 |
C61X61 | 15 |
C67X67 | 16 |
C71X71 | 17 |
C75X75 | 18 |
C79X79 | 19 |
C83X83 | 20 |
C87X87 | 21 |
C91X91 | 22 |
C95X95 | 23 |
C101X101 | 24 |
C105X105 | 25 |
C109X109 | 26 |
C113X113 | 27 |
C117X117 | 28 |
C121X121 | 29 |
C125X125 | 30 |
C131X131 | 31 |
C135X135 | 32 |
C139X139 | 33 |
C143X143 | 34 |
C147X147 | 35 |
C151X151 | 36 |

See Also

Neodynamic.WinRT Namespace


BarcodeProfessional Class

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Class
Members See Also Send Feedback
Neodynamic Barcode Professional lets you to quickly and easily generate high quality vector-based barcodes into Windows Store XAML WinRT applications.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public sealed class BarcodeProfessional : Canvas
Visual Basic
Public NotInheritable Class BarcodeProfessional _
    Inherits Canvas
Visual C++
public ref class BarcodeProfessional sealed : public Canvas

Inheritance Hierarchy

System..::..Object
DependencyObject
UIElement
FrameworkElement
Panel
Canvas
Neodynamic.WinRT..::..BarcodeProfessional

See Also

BarcodeProfessional Members
Neodynamic.WinRT Namespace


BarcodeProfessional Members

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Members
BarcodeProfessional Class Constructors Methods Fields Properties Events See Also Send Feedback

The BarcodeProfessional type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeProfessional | Initialize a new instance of the barcode control.

Methods

 | Name | Description
Public method | AddHandler | (Inherited from UIElement.)
Public method | Arrange | (Inherited from UIElement.)
Protected method | ArrangeOverride | (Inherited from FrameworkElement.)
Public method | CapturePointer | (Inherited from UIElement.)
Public method | ClearValue | (Inherited from DependencyObject.)
Public method | FindName | (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | (Inherited from UIElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetValue | (Inherited from DependencyObject.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | Measure | (Inherited from UIElement.)
Protected method | MeasureOverride | (Inherited from FrameworkElement.)
Protected method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | (Inherited from UIElement.)
Public method | put_AllowDrop | (Inherited from UIElement.)
Public method | put_Background | (Inherited from Panel.)
Public method | put_CacheMode | (Inherited from UIElement.)
Public method | put_ChildrenTransitions | (Inherited from Panel.)
Public method | put_Clip | (Inherited from UIElement.)
Public method | put_DataContext | (Inherited from FrameworkElement.)
Public method | put_FlowDirection | (Inherited from FrameworkElement.)
Public method | put_Height | (Inherited from FrameworkElement.)
Public method | put_HorizontalAlignment | (Inherited from FrameworkElement.)
Public method | put_IsDoubleTapEnabled | (Inherited from UIElement.)
Public method | put_IsHitTestVisible | (Inherited from UIElement.)
Public method | put_IsHoldingEnabled | (Inherited from UIElement.)
Public method | put_IsRightTapEnabled | (Inherited from UIElement.)
Public method | put_IsTapEnabled | (Inherited from UIElement.)
Public method | put_Language | (Inherited from FrameworkElement.)
Public method | put_ManipulationMode | (Inherited from UIElement.)
Public method | put_Margin | (Inherited from FrameworkElement.)
Public method | put_MaxHeight | (Inherited from FrameworkElement.)
Public method | put_MaxWidth | (Inherited from FrameworkElement.)
Public method | put_MinHeight | (Inherited from FrameworkElement.)
Public method | put_MinWidth | (Inherited from FrameworkElement.)
Public method | put_Name | (Inherited from FrameworkElement.)
Public method | put_Opacity | (Inherited from UIElement.)
Public method | put_Projection | (Inherited from UIElement.)
Public method | put_RenderTransform | (Inherited from UIElement.)
Public method | put_RenderTransformOrigin | (Inherited from UIElement.)
Public method | put_Resources | (Inherited from FrameworkElement.)
Public method | put_Style | (Inherited from FrameworkElement.)
Public method | put_Tag | (Inherited from FrameworkElement.)
Public method | put_Transitions | (Inherited from UIElement.)
Public method | put_UseLayoutRounding | (Inherited from UIElement.)
Public method | put_VerticalAlignment | (Inherited from FrameworkElement.)
Public method | put_Visibility | (Inherited from UIElement.)
Public method | put_Width | (Inherited from FrameworkElement.)
Public method | ReadLocalValue | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | (Inherited from UIElement.)
Public method | ReleasePointerCaptures | (Inherited from UIElement.)
Public method | RemoveHandler | (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | (Inherited from DependencyObject.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AddChecksumProperty |
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AztecCodeErrorCorrectionProperty |
AztecCodeFormatProperty |
AztecCodeModuleSizeProperty |
AztecCodeProcessTildeProperty |
AztecCodeRuneProperty |
BarcodeUnitProperty |
BarColorProperty |
BarHeightProperty |
BarRatioProperty |
BarWidthAdjustmentProperty |
BarWidthProperty |
BearerBarStyleProperty |
BearerBarWidthProperty |
CodabarStartCharProperty |
CodabarStopCharProperty |
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
Code128CharSetProperty |
Code16kModeProperty |
CodeAlignmentProperty |
CodeProperty |
DataMatrixEncodingProperty |
DataMatrixFileIdProperty |
DataMatrixFormatProperty |
DataMatrixModuleSizeProperty |
DataMatrixProcessTildeProperty |
DataMatrixSymbolCountProperty |
DataMatrixSymbolIndexProperty |
DisplayChecksumProperty |
DisplayCodeProperty |
DisplayLightMarginIndicatorProperty |
DisplayStartStopCharProperty |
EanUpcSupplementCodeProperty |
EanUpcSupplementProperty |
EanUpcSupplementSeparationProperty |
EanUpcSupplementTopMarginProperty |
EOT | End Of Transmission character (ASCII 4).
ExtendedProperty |
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontUnitProperty |
FontWeightProperty |
ForegroundProperty |
GS | Group Separator character (ASCII 29).
GuardBarHeightProperty |
GuardBarProperty |
HibcFormatHumanReadableTextProperty |
HumanReadableTextProperty |
Isbt128DataStructureProperty |
MaxiCodeModeProperty |
MaxiCodeProcessTildeProperty |
MaxiCodeSymbolCountProperty |
MaxiCodeSymbolIndexProperty |
MICRCharHeightProperty |
MICRCharSpacingProperty |
MICRCharWidthsProperty |
MicroPdf417VersionProperty |
MicroQRCodeVersionProperty |
MsiChecksumProperty |
Pdf417AspectRatioProperty |
Pdf417ColumnsProperty |
Pdf417CompactionTypeProperty |
Pdf417ErrorCorrectionLevelProperty |
Pdf417FileIdProperty |
Pdf417RowsProperty |
Pdf417SegmentCountProperty |
Pdf417SegmentIndexProperty |
Pdf417TruncatedProperty |
PharmacodeBarsSpacingProperty |
PharmacodeThickBarWidthProperty |
PharmacodeThinBarWidthProperty |
PlanetHeightShortBarProperty |
PlanetHeightTallBarProperty |
Postal4StateAddStartStopCharProperty |
Postal4StateBarsSpacingProperty |
Postal4StateTrackerBarHeightProperty |
Postal4StateTrackerBarWidthProperty |
PostnetHeightShortBarProperty |
PostnetHeightTallBarProperty |
QRCodeEncodingProperty |
QRCodeErrorCorrectionLevelProperty |
QRCodeModuleSizeProperty |
QRCodeProcessTildeProperty |
QRCodeVersionProperty |
QuietZoneProperty |
RS | Record Separator character (ASCII 30).
SegmentsPerRowProperty |
SymbologyProperty |
TelepenEncodingProperty |
TextAlignmentProperty |
TextFontFamilyProperty |
TextFontSizeProperty |
TextFontStretchProperty |
TextFontStyleProperty |
TextFontUnitProperty |
TextFontWeightProperty |
TextForegroundProperty |
TextProperty |
UpcESystemProperty |
UseLayoutRoundingProperty |
UseQuietZoneForTextProperty |
UspsFimPatternProperty |
UspsHorizontalBarsCountProperty |

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AddChecksum | Gets or sets whether checksum must be calculated and attached to the value to encode.
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology.
Public property | AztecCodeModuleSize | Gets or sets the Aztec Code module size. The unit of measure must be specified to BarcodeUnit property.
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character should be processed when Aztec Code is being generated.
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.
Public property | Background | (Inherited from Panel.)
Public property | BarcodeUnit | Gets or sets the unit of measure for the barcode.
Public property | BarColor | Gets or sets the bars' color of the barcode.
Public property | BarHeight | Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value.
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. The unit of measure must be specified to BarcodeUnit property.
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment.
Public property | BaseUri | (Inherited from FrameworkElement.)
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.
Public property | BearerBarWidth | Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | (Inherited from Panel.)
Public property | ChildrenTransitions | (Inherited from Panel.)
Public property | Clip | (Inherited from UIElement.)
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.
Public property | Code | Gets or sets the value to encode.
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.
Public property | CodeAlignment | Gets or sets the text alignment for Code property.
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DataMatrixEncoding | Gets or sets the DataMatrix Encoding to use on that symbology.
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.
Public property | DataMatrixFormat | Gets or sets the DataMatrix Format to use on that symbology.
Public property | DataMatrixModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character should be processed when DataMatrix code is being generated.
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode on the barcode.
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed on the barcode.
Public property | DisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed on the barcode.
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies.
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies.
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Extended | Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the name of the specified font for Code or HumanReadableText property.
Public property | FontSize | Gets or sets the font size for Code or HumanReadableText property. The unit of measure must be specified to FontUnit property.
Public property | FontStretch | Gets or sets the degree to which a font for Code or HumanReadableText property is condensed or expanded.
Public property | FontStyle | Gets or sets the font style for Code or HumanReadableText property.
Public property | FontUnit | Gets or sets the unit of measure for the font object.
Public property | FontWeight | Gets or sets the weight or thickness of the specified font for Code or HumanReadableText property.
Public property | Foreground | Gets or sets a brush that describes the foreground color for Code or HumanReadableText property.
Public property | GuardBar | Gets or sets whether guard bars must be drawn for EAN and UPC symbologies.
Public property | GuardBarHeight | Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.
Public property | Height | (Inherited from FrameworkElement.)
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated.
Public property | IsDoubleTapEnabled | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsHoldingEnabled | (Inherited from UIElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsRightTapEnabled | (Inherited from UIElement.)
Public property | IsTapEnabled | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
 | LicenseKey | Gets or sets the License Key for product registration.
 | LicenseOwner | Gets or sets the License Owner for product registration.
Public property | ManipulationMode | (Inherited from UIElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode.
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character should be processed when MaxiCode code is being generated.
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MICRCharHeight | Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.
Public property | MICRCharSpacing | Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.
Public property | MICRCharWidths | Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology.
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology.
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology.
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology.
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology.
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology.
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed).
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PointerCaptures | (Inherited from UIElement.)
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn on the barcode.
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | Projection | (Inherited from UIElement.)
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology.
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology.
Public property | QRCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeProcessTilde | Gets or sets whether tilde character should be processed when QR Code is being generated.
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology.
Public property | QuietZone | Gets or sets the quiet zones. The unit of measure must be specified to BarcodeUnit property.
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.
Public property | Style | (Inherited from FrameworkElement.)
Public property | Symbology | Gets or sets the barcode symbology/standard to generate.
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology.
Public property | Text | Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode.
Public property | TextAlignment | Gets or sets the text alignment for Text property.
Public property | TextFontFamily | Gets or sets the name of the specified font for Text property.
Public property | TextFontSize | Gets or sets the font size for Text property. The unit of measure must be specified to TextFontUnit property.
Public property | TextFontStretch | Gets or sets the degree to which a font for Text property is condensed or expanded.
Public property | TextFontStyle | Gets or sets the font style for Text property.
Public property | TextFontUnit | Gets or sets the unit of measure for the font object for Text property.
Public property | TextFontWeight | Gets or sets the weight or thickness of the specified font for Text property.
Public property | TextForeground | Gets or sets a brush that describes the foreground color for Text property.
Public property | Transitions | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology.
Public property | UseLayoutRounding | Gets or sets a value that determines whether to use rounding behavior that aligns layout to whole pixels.
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology.
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn.
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | Visibility | (Inherited from UIElement.)
Public property | Width | (Inherited from FrameworkElement.)

Events

 | Name | Description
Public event | DoubleTapped | (Inherited from UIElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | Holding | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | PointerCanceled | (Inherited from UIElement.)
Public event | PointerCaptureLost | (Inherited from UIElement.)
Public event | PointerEntered | (Inherited from UIElement.)
Public event | PointerExited | (Inherited from UIElement.)
Public event | PointerMoved | (Inherited from UIElement.)
Public event | PointerPressed | (Inherited from UIElement.)
Public event | PointerReleased | (Inherited from UIElement.)
Public event | PointerWheelChanged | (Inherited from UIElement.)
Public event | RightTapped | (Inherited from UIElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | Tapped | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

BarcodeProfessional Class
Neodynamic.WinRT Namespace


BarcodeProfessional Constructor

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Constructor
BarcodeProfessional Class See Also Send Feedback
Initialize a new instance of the barcode control.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public BarcodeProfessional()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeProfessional()

See Also

Neodynamic.WinRT Namespace


BarcodeProfessional Fields

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Fields
BarcodeProfessional Class See Also Send Feedback

The BarcodeProfessional type exposes the following members.

Fields

Name | Description
AddChecksumProperty |
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AztecCodeErrorCorrectionProperty |
AztecCodeFormatProperty |
AztecCodeModuleSizeProperty |
AztecCodeProcessTildeProperty |
AztecCodeRuneProperty |
BarcodeUnitProperty |
BarColorProperty |
BarHeightProperty |
BarRatioProperty |
BarWidthAdjustmentProperty |
BarWidthProperty |
BearerBarStyleProperty |
BearerBarWidthProperty |
CodabarStartCharProperty |
CodabarStopCharProperty |
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
Code128CharSetProperty |
Code16kModeProperty |
CodeAlignmentProperty |
CodeProperty |
DataMatrixEncodingProperty |
DataMatrixFileIdProperty |
DataMatrixFormatProperty |
DataMatrixModuleSizeProperty |
DataMatrixProcessTildeProperty |
DataMatrixSymbolCountProperty |
DataMatrixSymbolIndexProperty |
DisplayChecksumProperty |
DisplayCodeProperty |
DisplayLightMarginIndicatorProperty |
DisplayStartStopCharProperty |
EanUpcSupplementCodeProperty |
EanUpcSupplementProperty |
EanUpcSupplementSeparationProperty |
EanUpcSupplementTopMarginProperty |
EOT | End Of Transmission character (ASCII 4).
ExtendedProperty |
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
FontFamilyProperty |
FontSizeProperty |
FontStretchProperty |
FontStyleProperty |
FontUnitProperty |
FontWeightProperty |
ForegroundProperty |
GS | Group Separator character (ASCII 29).
GuardBarHeightProperty |
GuardBarProperty |
HibcFormatHumanReadableTextProperty |
HumanReadableTextProperty |
Isbt128DataStructureProperty |
MaxiCodeModeProperty |
MaxiCodeProcessTildeProperty |
MaxiCodeSymbolCountProperty |
MaxiCodeSymbolIndexProperty |
MICRCharHeightProperty |
MICRCharSpacingProperty |
MICRCharWidthsProperty |
MicroPdf417VersionProperty |
MicroQRCodeVersionProperty |
MsiChecksumProperty |
Pdf417AspectRatioProperty |
Pdf417ColumnsProperty |
Pdf417CompactionTypeProperty |
Pdf417ErrorCorrectionLevelProperty |
Pdf417FileIdProperty |
Pdf417RowsProperty |
Pdf417SegmentCountProperty |
Pdf417SegmentIndexProperty |
Pdf417TruncatedProperty |
PharmacodeBarsSpacingProperty |
PharmacodeThickBarWidthProperty |
PharmacodeThinBarWidthProperty |
PlanetHeightShortBarProperty |
PlanetHeightTallBarProperty |
Postal4StateAddStartStopCharProperty |
Postal4StateBarsSpacingProperty |
Postal4StateTrackerBarHeightProperty |
Postal4StateTrackerBarWidthProperty |
PostnetHeightShortBarProperty |
PostnetHeightTallBarProperty |
QRCodeEncodingProperty |
QRCodeErrorCorrectionLevelProperty |
QRCodeModuleSizeProperty |
QRCodeProcessTildeProperty |
QRCodeVersionProperty |
QuietZoneProperty |
RS | Record Separator character (ASCII 30).
SegmentsPerRowProperty |
SymbologyProperty |
TelepenEncodingProperty |
TextAlignmentProperty |
TextFontFamilyProperty |
TextFontSizeProperty |
TextFontStretchProperty |
TextFontStyleProperty |
TextFontUnitProperty |
TextFontWeightProperty |
TextForegroundProperty |
TextProperty |
UpcESystemProperty |
UseLayoutRoundingProperty |
UseQuietZoneForTextProperty |
UspsFimPatternProperty |
UspsHorizontalBarsCountProperty |

See Also

Neodynamic.WinRT Namespace


AddChecksumProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AddChecksumProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AddChecksumProperty
Visual Basic
Public Shared AddChecksumProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AddChecksumProperty

See Also

Neodynamic.WinRT Namespace


AI2 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AI2 Field
BarcodeProfessional Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char AI2
Visual Basic
Public Const AI2 As Char
Visual C++
public:
literal wchar_t AI2

See Also

Neodynamic.WinRT Namespace


AI3 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AI3 Field
BarcodeProfessional Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char AI3
Visual Basic
Public Const AI3 As Char
Visual C++
public:
literal wchar_t AI3

See Also

Neodynamic.WinRT Namespace


AI4 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AI4 Field
BarcodeProfessional Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char AI4
Visual Basic
Public Const AI4 As Char
Visual C++
public:
literal wchar_t AI4

See Also

Neodynamic.WinRT Namespace


AI5 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AI5 Field
BarcodeProfessional Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char AI5
Visual Basic
Public Const AI5 As Char
Visual C++
public:
literal wchar_t AI5

See Also

Neodynamic.WinRT Namespace


AztecCodeErrorCorrectionProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeErrorCorrectionProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AztecCodeErrorCorrectionProperty
Visual Basic
Public Shared AztecCodeErrorCorrectionProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AztecCodeErrorCorrectionProperty

See Also

Neodynamic.WinRT Namespace


AztecCodeFormatProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeFormatProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AztecCodeFormatProperty
Visual Basic
Public Shared AztecCodeFormatProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AztecCodeFormatProperty

See Also

Neodynamic.WinRT Namespace


AztecCodeModuleSizeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeModuleSizeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AztecCodeModuleSizeProperty
Visual Basic
Public Shared AztecCodeModuleSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AztecCodeModuleSizeProperty

See Also

Neodynamic.WinRT Namespace


AztecCodeProcessTildeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeProcessTildeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AztecCodeProcessTildeProperty
Visual Basic
Public Shared AztecCodeProcessTildeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AztecCodeProcessTildeProperty

See Also

Neodynamic.WinRT Namespace


AztecCodeRuneProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeRuneProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty AztecCodeRuneProperty
Visual Basic
Public Shared AztecCodeRuneProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AztecCodeRuneProperty

See Also

Neodynamic.WinRT Namespace


BarcodeUnitProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarcodeUnitProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarcodeUnitProperty
Visual Basic
Public Shared BarcodeUnitProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarcodeUnitProperty

See Also

Neodynamic.WinRT Namespace


BarColorProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarColorProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarColorProperty
Visual Basic
Public Shared BarColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarColorProperty

See Also

Neodynamic.WinRT Namespace


BarHeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarHeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarHeightProperty
Visual Basic
Public Shared BarHeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarHeightProperty

See Also

Neodynamic.WinRT Namespace


BarRatioProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarRatioProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarRatioProperty
Visual Basic
Public Shared BarRatioProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarRatioProperty

See Also

Neodynamic.WinRT Namespace


BarWidthAdjustmentProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarWidthAdjustmentProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarWidthAdjustmentProperty
Visual Basic
Public Shared BarWidthAdjustmentProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarWidthAdjustmentProperty

See Also

Neodynamic.WinRT Namespace


BarWidthProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarWidthProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BarWidthProperty
Visual Basic
Public Shared BarWidthProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BarWidthProperty

See Also

Neodynamic.WinRT Namespace


BearerBarStyleProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BearerBarStyleProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BearerBarStyleProperty
Visual Basic
Public Shared BearerBarStyleProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BearerBarStyleProperty

See Also

Neodynamic.WinRT Namespace


BearerBarWidthProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BearerBarWidthProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty BearerBarWidthProperty
Visual Basic
Public Shared BearerBarWidthProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ BearerBarWidthProperty

See Also

Neodynamic.WinRT Namespace


CodabarStartCharProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodabarStartCharProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty CodabarStartCharProperty
Visual Basic
Public Shared CodabarStartCharProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CodabarStartCharProperty

See Also

Neodynamic.WinRT Namespace


CodabarStopCharProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodabarStopCharProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty CodabarStopCharProperty
Visual Basic
Public Shared CodabarStopCharProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CodabarStopCharProperty

See Also

Neodynamic.WinRT Namespace


CODE128_FNC1 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CODE128_FNC1 Field
BarcodeProfessional Class See Also Send Feedback
Function 1 Symbol Character (FNC1) used by Code 128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char CODE128_FNC1
Visual Basic
Public Const CODE128_FNC1 As Char
Visual C++
public:
literal wchar_t CODE128_FNC1

See Also

Neodynamic.WinRT Namespace


CODE128_FNC2 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CODE128_FNC2 Field
BarcodeProfessional Class See Also Send Feedback
Function 2 Symbol Character (FNC2) used by Code 128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char CODE128_FNC2
Visual Basic
Public Const CODE128_FNC2 As Char
Visual C++
public:
literal wchar_t CODE128_FNC2

See Also

Neodynamic.WinRT Namespace


CODE128_FNC3 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CODE128_FNC3 Field
BarcodeProfessional Class See Also Send Feedback
Function 3 Symbol Character (FNC3) used by Code 128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char CODE128_FNC3
Visual Basic
Public Const CODE128_FNC3 As Char
Visual C++
public:
literal wchar_t CODE128_FNC3

See Also

Neodynamic.WinRT Namespace


CODE128_FNC4 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CODE128_FNC4 Field
BarcodeProfessional Class See Also Send Feedback
Function 4 Symbol Character (FNC4) used by Code 128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char CODE128_FNC4
Visual Basic
Public Const CODE128_FNC4 As Char
Visual C++
public:
literal wchar_t CODE128_FNC4

See Also

Neodynamic.WinRT Namespace


Code128CharSetProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Code128CharSetProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Code128CharSetProperty
Visual Basic
Public Shared Code128CharSetProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Code128CharSetProperty

See Also

Neodynamic.WinRT Namespace


Code16kModeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Code16kModeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Code16kModeProperty
Visual Basic
Public Shared Code16kModeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Code16kModeProperty

See Also

Neodynamic.WinRT Namespace


CodeAlignmentProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodeAlignmentProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty CodeAlignmentProperty
Visual Basic
Public Shared CodeAlignmentProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CodeAlignmentProperty

See Also

Neodynamic.WinRT Namespace


CodeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty CodeProperty
Visual Basic
Public Shared CodeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ CodeProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixEncodingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixEncodingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixEncodingProperty
Visual Basic
Public Shared DataMatrixEncodingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixEncodingProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixFileIdProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixFileIdProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixFileIdProperty
Visual Basic
Public Shared DataMatrixFileIdProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixFileIdProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixFormatProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixFormatProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixFormatProperty
Visual Basic
Public Shared DataMatrixFormatProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixFormatProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixModuleSizeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixModuleSizeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixModuleSizeProperty
Visual Basic
Public Shared DataMatrixModuleSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixModuleSizeProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixProcessTildeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixProcessTildeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixProcessTildeProperty
Visual Basic
Public Shared DataMatrixProcessTildeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixProcessTildeProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixSymbolCountProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixSymbolCountProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixSymbolCountProperty
Visual Basic
Public Shared DataMatrixSymbolCountProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixSymbolCountProperty

See Also

Neodynamic.WinRT Namespace


DataMatrixSymbolIndexProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixSymbolIndexProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DataMatrixSymbolIndexProperty
Visual Basic
Public Shared DataMatrixSymbolIndexProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DataMatrixSymbolIndexProperty

See Also

Neodynamic.WinRT Namespace


DisplayChecksumProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayChecksumProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DisplayChecksumProperty
Visual Basic
Public Shared DisplayChecksumProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DisplayChecksumProperty

See Also

Neodynamic.WinRT Namespace


DisplayCodeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayCodeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DisplayCodeProperty
Visual Basic
Public Shared DisplayCodeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DisplayCodeProperty

See Also

Neodynamic.WinRT Namespace


DisplayLightMarginIndicatorProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayLightMarginIndicatorProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DisplayLightMarginIndicatorProperty
Visual Basic
Public Shared DisplayLightMarginIndicatorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DisplayLightMarginIndicatorProperty

See Also

Neodynamic.WinRT Namespace


DisplayStartStopCharProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayStartStopCharProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty DisplayStartStopCharProperty
Visual Basic
Public Shared DisplayStartStopCharProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ DisplayStartStopCharProperty

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementCodeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementCodeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty EanUpcSupplementCodeProperty
Visual Basic
Public Shared EanUpcSupplementCodeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ EanUpcSupplementCodeProperty

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty EanUpcSupplementProperty
Visual Basic
Public Shared EanUpcSupplementProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ EanUpcSupplementProperty

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementSeparationProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementSeparationProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty EanUpcSupplementSeparationProperty
Visual Basic
Public Shared EanUpcSupplementSeparationProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ EanUpcSupplementSeparationProperty

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementTopMarginProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementTopMarginProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty EanUpcSupplementTopMarginProperty
Visual Basic
Public Shared EanUpcSupplementTopMarginProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ EanUpcSupplementTopMarginProperty

See Also

Neodynamic.WinRT Namespace


EOT Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EOT Field
BarcodeProfessional Class See Also Send Feedback
End Of Transmission character (ASCII 4).

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char EOT
Visual Basic
Public Const EOT As Char
Visual C++
public:
literal wchar_t EOT

See Also

Neodynamic.WinRT Namespace


ExtendedProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..ExtendedProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty ExtendedProperty
Visual Basic
Public Shared ExtendedProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ExtendedProperty

See Also

Neodynamic.WinRT Namespace


FNC1 Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FNC1 Field
BarcodeProfessional Class See Also Send Feedback
Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char FNC1
Visual Basic
Public Const FNC1 As Char
Visual C++
public:
literal wchar_t FNC1

See Also

Neodynamic.WinRT Namespace


FontFamilyProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontFamilyProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontFamilyProperty
Visual Basic
Public Shared FontFamilyProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontFamilyProperty

See Also

Neodynamic.WinRT Namespace


FontSizeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontSizeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontSizeProperty
Visual Basic
Public Shared FontSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontSizeProperty

See Also

Neodynamic.WinRT Namespace


FontStretchProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontStretchProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontStretchProperty
Visual Basic
Public Shared FontStretchProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontStretchProperty

See Also

Neodynamic.WinRT Namespace


FontStyleProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontStyleProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontStyleProperty
Visual Basic
Public Shared FontStyleProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontStyleProperty

See Also

Neodynamic.WinRT Namespace


FontUnitProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontUnitProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontUnitProperty
Visual Basic
Public Shared FontUnitProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontUnitProperty

See Also

Neodynamic.WinRT Namespace


FontWeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontWeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty FontWeightProperty
Visual Basic
Public Shared FontWeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ FontWeightProperty

See Also

Neodynamic.WinRT Namespace


ForegroundProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..ForegroundProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty ForegroundProperty
Visual Basic
Public Shared ForegroundProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ForegroundProperty

See Also

Neodynamic.WinRT Namespace


GS Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..GS Field
BarcodeProfessional Class See Also Send Feedback
Group Separator character (ASCII 29).

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char GS
Visual Basic
Public Const GS As Char
Visual C++
public:
literal wchar_t GS

See Also

Neodynamic.WinRT Namespace


GuardBarHeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..GuardBarHeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty GuardBarHeightProperty
Visual Basic
Public Shared GuardBarHeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ GuardBarHeightProperty

See Also

Neodynamic.WinRT Namespace


GuardBarProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..GuardBarProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty GuardBarProperty
Visual Basic
Public Shared GuardBarProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ GuardBarProperty

See Also

Neodynamic.WinRT Namespace


HibcFormatHumanReadableTextProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..HibcFormatHumanReadableTextProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty HibcFormatHumanReadableTextProperty
Visual Basic
Public Shared HibcFormatHumanReadableTextProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ HibcFormatHumanReadableTextProperty

See Also

Neodynamic.WinRT Namespace


HumanReadableTextProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..HumanReadableTextProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty HumanReadableTextProperty
Visual Basic
Public Shared HumanReadableTextProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ HumanReadableTextProperty

See Also

Neodynamic.WinRT Namespace


Isbt128DataStructureProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Isbt128DataStructureProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Isbt128DataStructureProperty
Visual Basic
Public Shared Isbt128DataStructureProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Isbt128DataStructureProperty

See Also

Neodynamic.WinRT Namespace


MaxiCodeModeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeModeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MaxiCodeModeProperty
Visual Basic
Public Shared MaxiCodeModeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MaxiCodeModeProperty

See Also

Neodynamic.WinRT Namespace


MaxiCodeProcessTildeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeProcessTildeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MaxiCodeProcessTildeProperty
Visual Basic
Public Shared MaxiCodeProcessTildeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MaxiCodeProcessTildeProperty

See Also

Neodynamic.WinRT Namespace


MaxiCodeSymbolCountProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeSymbolCountProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MaxiCodeSymbolCountProperty
Visual Basic
Public Shared MaxiCodeSymbolCountProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MaxiCodeSymbolCountProperty

See Also

Neodynamic.WinRT Namespace


MaxiCodeSymbolIndexProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeSymbolIndexProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MaxiCodeSymbolIndexProperty
Visual Basic
Public Shared MaxiCodeSymbolIndexProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MaxiCodeSymbolIndexProperty

See Also

Neodynamic.WinRT Namespace


MICRCharHeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharHeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MICRCharHeightProperty
Visual Basic
Public Shared MICRCharHeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MICRCharHeightProperty

See Also

Neodynamic.WinRT Namespace


MICRCharSpacingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharSpacingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MICRCharSpacingProperty
Visual Basic
Public Shared MICRCharSpacingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MICRCharSpacingProperty

See Also

Neodynamic.WinRT Namespace


MICRCharWidthsProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharWidthsProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MICRCharWidthsProperty
Visual Basic
Public Shared MICRCharWidthsProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MICRCharWidthsProperty

See Also

Neodynamic.WinRT Namespace


MicroPdf417VersionProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MicroPdf417VersionProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MicroPdf417VersionProperty
Visual Basic
Public Shared MicroPdf417VersionProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MicroPdf417VersionProperty

See Also

Neodynamic.WinRT Namespace


MicroQRCodeVersionProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MicroQRCodeVersionProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MicroQRCodeVersionProperty
Visual Basic
Public Shared MicroQRCodeVersionProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MicroQRCodeVersionProperty

See Also

Neodynamic.WinRT Namespace


MsiChecksumProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MsiChecksumProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty MsiChecksumProperty
Visual Basic
Public Shared MsiChecksumProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ MsiChecksumProperty

See Also

Neodynamic.WinRT Namespace


Pdf417AspectRatioProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417AspectRatioProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417AspectRatioProperty
Visual Basic
Public Shared Pdf417AspectRatioProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417AspectRatioProperty

See Also

Neodynamic.WinRT Namespace


Pdf417ColumnsProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417ColumnsProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417ColumnsProperty
Visual Basic
Public Shared Pdf417ColumnsProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417ColumnsProperty

See Also

Neodynamic.WinRT Namespace


Pdf417CompactionTypeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417CompactionTypeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417CompactionTypeProperty
Visual Basic
Public Shared Pdf417CompactionTypeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417CompactionTypeProperty

See Also

Neodynamic.WinRT Namespace


Pdf417ErrorCorrectionLevelProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417ErrorCorrectionLevelProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417ErrorCorrectionLevelProperty
Visual Basic
Public Shared Pdf417ErrorCorrectionLevelProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417ErrorCorrectionLevelProperty

See Also

Neodynamic.WinRT Namespace


Pdf417FileIdProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417FileIdProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417FileIdProperty
Visual Basic
Public Shared Pdf417FileIdProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417FileIdProperty

See Also

Neodynamic.WinRT Namespace


Pdf417RowsProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417RowsProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417RowsProperty
Visual Basic
Public Shared Pdf417RowsProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417RowsProperty

See Also

Neodynamic.WinRT Namespace


Pdf417SegmentCountProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417SegmentCountProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417SegmentCountProperty
Visual Basic
Public Shared Pdf417SegmentCountProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417SegmentCountProperty

See Also

Neodynamic.WinRT Namespace


Pdf417SegmentIndexProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417SegmentIndexProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417SegmentIndexProperty
Visual Basic
Public Shared Pdf417SegmentIndexProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417SegmentIndexProperty

See Also

Neodynamic.WinRT Namespace


Pdf417TruncatedProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417TruncatedProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Pdf417TruncatedProperty
Visual Basic
Public Shared Pdf417TruncatedProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Pdf417TruncatedProperty

See Also

Neodynamic.WinRT Namespace


PharmacodeBarsSpacingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeBarsSpacingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PharmacodeBarsSpacingProperty
Visual Basic
Public Shared PharmacodeBarsSpacingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PharmacodeBarsSpacingProperty

See Also

Neodynamic.WinRT Namespace


PharmacodeThickBarWidthProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeThickBarWidthProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PharmacodeThickBarWidthProperty
Visual Basic
Public Shared PharmacodeThickBarWidthProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PharmacodeThickBarWidthProperty

See Also

Neodynamic.WinRT Namespace


PharmacodeThinBarWidthProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeThinBarWidthProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PharmacodeThinBarWidthProperty
Visual Basic
Public Shared PharmacodeThinBarWidthProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PharmacodeThinBarWidthProperty

See Also

Neodynamic.WinRT Namespace


PlanetHeightShortBarProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PlanetHeightShortBarProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PlanetHeightShortBarProperty
Visual Basic
Public Shared PlanetHeightShortBarProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PlanetHeightShortBarProperty

See Also

Neodynamic.WinRT Namespace


PlanetHeightTallBarProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PlanetHeightTallBarProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PlanetHeightTallBarProperty
Visual Basic
Public Shared PlanetHeightTallBarProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PlanetHeightTallBarProperty

See Also

Neodynamic.WinRT Namespace


Postal4StateAddStartStopCharProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateAddStartStopCharProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Postal4StateAddStartStopCharProperty
Visual Basic
Public Shared Postal4StateAddStartStopCharProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Postal4StateAddStartStopCharProperty

See Also

Neodynamic.WinRT Namespace


Postal4StateBarsSpacingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateBarsSpacingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Postal4StateBarsSpacingProperty
Visual Basic
Public Shared Postal4StateBarsSpacingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Postal4StateBarsSpacingProperty

See Also

Neodynamic.WinRT Namespace


Postal4StateTrackerBarHeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateTrackerBarHeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Postal4StateTrackerBarHeightProperty
Visual Basic
Public Shared Postal4StateTrackerBarHeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Postal4StateTrackerBarHeightProperty

See Also

Neodynamic.WinRT Namespace


Postal4StateTrackerBarWidthProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateTrackerBarWidthProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty Postal4StateTrackerBarWidthProperty
Visual Basic
Public Shared Postal4StateTrackerBarWidthProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ Postal4StateTrackerBarWidthProperty

See Also

Neodynamic.WinRT Namespace


PostnetHeightShortBarProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PostnetHeightShortBarProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PostnetHeightShortBarProperty
Visual Basic
Public Shared PostnetHeightShortBarProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PostnetHeightShortBarProperty

See Also

Neodynamic.WinRT Namespace


PostnetHeightTallBarProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PostnetHeightTallBarProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty PostnetHeightTallBarProperty
Visual Basic
Public Shared PostnetHeightTallBarProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ PostnetHeightTallBarProperty

See Also

Neodynamic.WinRT Namespace


QRCodeEncodingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeEncodingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QRCodeEncodingProperty
Visual Basic
Public Shared QRCodeEncodingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QRCodeEncodingProperty

See Also

Neodynamic.WinRT Namespace


QRCodeErrorCorrectionLevelProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeErrorCorrectionLevelProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QRCodeErrorCorrectionLevelProperty
Visual Basic
Public Shared QRCodeErrorCorrectionLevelProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QRCodeErrorCorrectionLevelProperty

See Also

Neodynamic.WinRT Namespace


QRCodeModuleSizeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeModuleSizeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QRCodeModuleSizeProperty
Visual Basic
Public Shared QRCodeModuleSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QRCodeModuleSizeProperty

See Also

Neodynamic.WinRT Namespace


QRCodeProcessTildeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeProcessTildeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QRCodeProcessTildeProperty
Visual Basic
Public Shared QRCodeProcessTildeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QRCodeProcessTildeProperty

See Also

Neodynamic.WinRT Namespace


QRCodeVersionProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeVersionProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QRCodeVersionProperty
Visual Basic
Public Shared QRCodeVersionProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QRCodeVersionProperty

See Also

Neodynamic.WinRT Namespace


QuietZoneProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QuietZoneProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty QuietZoneProperty
Visual Basic
Public Shared QuietZoneProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ QuietZoneProperty

See Also

Neodynamic.WinRT Namespace


RS Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..RS Field
BarcodeProfessional Class See Also Send Feedback
Record Separator character (ASCII 30).

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public const char RS
Visual Basic
Public Const RS As Char
Visual C++
public:
literal wchar_t RS

See Also

Neodynamic.WinRT Namespace


SegmentsPerRowProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..SegmentsPerRowProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty SegmentsPerRowProperty
Visual Basic
Public Shared SegmentsPerRowProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ SegmentsPerRowProperty

See Also

Neodynamic.WinRT Namespace


SymbologyProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..SymbologyProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty SymbologyProperty
Visual Basic
Public Shared SymbologyProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ SymbologyProperty

See Also

Neodynamic.WinRT Namespace


TelepenEncodingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TelepenEncodingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TelepenEncodingProperty
Visual Basic
Public Shared TelepenEncodingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TelepenEncodingProperty

See Also

Neodynamic.WinRT Namespace


TextAlignmentProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextAlignmentProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextAlignmentProperty
Visual Basic
Public Shared TextAlignmentProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextAlignmentProperty

See Also

Neodynamic.WinRT Namespace


TextFontFamilyProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontFamilyProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontFamilyProperty
Visual Basic
Public Shared TextFontFamilyProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontFamilyProperty

See Also

Neodynamic.WinRT Namespace


TextFontSizeProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontSizeProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontSizeProperty
Visual Basic
Public Shared TextFontSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontSizeProperty

See Also

Neodynamic.WinRT Namespace


TextFontStretchProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontStretchProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontStretchProperty
Visual Basic
Public Shared TextFontStretchProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontStretchProperty

See Also

Neodynamic.WinRT Namespace


TextFontStyleProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontStyleProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontStyleProperty
Visual Basic
Public Shared TextFontStyleProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontStyleProperty

See Also

Neodynamic.WinRT Namespace


TextFontUnitProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontUnitProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontUnitProperty
Visual Basic
Public Shared TextFontUnitProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontUnitProperty

See Also

Neodynamic.WinRT Namespace


TextFontWeightProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontWeightProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextFontWeightProperty
Visual Basic
Public Shared TextFontWeightProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextFontWeightProperty

See Also

Neodynamic.WinRT Namespace


TextForegroundProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextForegroundProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextForegroundProperty
Visual Basic
Public Shared TextForegroundProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextForegroundProperty

See Also

Neodynamic.WinRT Namespace


TextProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty TextProperty
Visual Basic
Public Shared TextProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextProperty

See Also

Neodynamic.WinRT Namespace


UpcESystemProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UpcESystemProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty UpcESystemProperty
Visual Basic
Public Shared UpcESystemProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ UpcESystemProperty

See Also

Neodynamic.WinRT Namespace


UseLayoutRoundingProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UseLayoutRoundingProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty UseLayoutRoundingProperty
Visual Basic
Public Shared UseLayoutRoundingProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ UseLayoutRoundingProperty

See Also

Neodynamic.WinRT Namespace


UseQuietZoneForTextProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UseQuietZoneForTextProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty UseQuietZoneForTextProperty
Visual Basic
Public Shared UseQuietZoneForTextProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ UseQuietZoneForTextProperty

See Also

Neodynamic.WinRT Namespace


UspsFimPatternProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UspsFimPatternProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty UspsFimPatternProperty
Visual Basic
Public Shared UspsFimPatternProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ UspsFimPatternProperty

See Also

Neodynamic.WinRT Namespace


UspsHorizontalBarsCountProperty Field

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UspsHorizontalBarsCountProperty Field
BarcodeProfessional Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static DependencyProperty UspsHorizontalBarsCountProperty
Visual Basic
Public Shared UspsHorizontalBarsCountProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ UspsHorizontalBarsCountProperty

See Also

Neodynamic.WinRT Namespace


BarcodeProfessional Methods

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Methods
BarcodeProfessional Class See Also Send Feedback

The BarcodeProfessional type exposes the following members.

Methods

 | Name | Description
Public method | AddHandler | (Inherited from UIElement.)
Public method | Arrange | (Inherited from UIElement.)
Protected method | ArrangeOverride | (Inherited from FrameworkElement.)
Public method | CapturePointer | (Inherited from UIElement.)
Public method | ClearValue | (Inherited from DependencyObject.)
Public method | FindName | (Inherited from FrameworkElement.)
Protected method | FindSubElementsForTouchTargeting | (Inherited from UIElement.)
Public method | GetAnimationBaseValue | (Inherited from DependencyObject.)
Public method | GetValue | (Inherited from DependencyObject.)
Public method | InvalidateArrange | (Inherited from UIElement.)
Public method | InvalidateMeasure | (Inherited from UIElement.)
Public method | Measure | (Inherited from UIElement.)
Protected method | MeasureOverride | (Inherited from FrameworkElement.)
Protected method | OnApplyTemplate | (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | (Inherited from UIElement.)
Protected method | OnDisconnectVisualChildren | (Inherited from UIElement.)
Public method | put_AllowDrop | (Inherited from UIElement.)
Public method | put_Background | (Inherited from Panel.)
Public method | put_CacheMode | (Inherited from UIElement.)
Public method | put_ChildrenTransitions | (Inherited from Panel.)
Public method | put_Clip | (Inherited from UIElement.)
Public method | put_DataContext | (Inherited from FrameworkElement.)
Public method | put_FlowDirection | (Inherited from FrameworkElement.)
Public method | put_Height | (Inherited from FrameworkElement.)
Public method | put_HorizontalAlignment | (Inherited from FrameworkElement.)
Public method | put_IsDoubleTapEnabled | (Inherited from UIElement.)
Public method | put_IsHitTestVisible | (Inherited from UIElement.)
Public method | put_IsHoldingEnabled | (Inherited from UIElement.)
Public method | put_IsRightTapEnabled | (Inherited from UIElement.)
Public method | put_IsTapEnabled | (Inherited from UIElement.)
Public method | put_Language | (Inherited from FrameworkElement.)
Public method | put_ManipulationMode | (Inherited from UIElement.)
Public method | put_Margin | (Inherited from FrameworkElement.)
Public method | put_MaxHeight | (Inherited from FrameworkElement.)
Public method | put_MaxWidth | (Inherited from FrameworkElement.)
Public method | put_MinHeight | (Inherited from FrameworkElement.)
Public method | put_MinWidth | (Inherited from FrameworkElement.)
Public method | put_Name | (Inherited from FrameworkElement.)
Public method | put_Opacity | (Inherited from UIElement.)
Public method | put_Projection | (Inherited from UIElement.)
Public method | put_RenderTransform | (Inherited from UIElement.)
Public method | put_RenderTransformOrigin | (Inherited from UIElement.)
Public method | put_Resources | (Inherited from FrameworkElement.)
Public method | put_Style | (Inherited from FrameworkElement.)
Public method | put_Tag | (Inherited from FrameworkElement.)
Public method | put_Transitions | (Inherited from UIElement.)
Public method | put_UseLayoutRounding | (Inherited from UIElement.)
Public method | put_VerticalAlignment | (Inherited from FrameworkElement.)
Public method | put_Visibility | (Inherited from UIElement.)
Public method | put_Width | (Inherited from FrameworkElement.)
Public method | ReadLocalValue | (Inherited from DependencyObject.)
Public method | ReleasePointerCapture | (Inherited from UIElement.)
Public method | ReleasePointerCaptures | (Inherited from UIElement.)
Public method | RemoveHandler | (Inherited from UIElement.)
Public method | SetBinding | (Inherited from FrameworkElement.)
Public method | SetValue | (Inherited from DependencyObject.)
Public method | TransformToVisual | (Inherited from UIElement.)
Public method | UpdateLayout | (Inherited from UIElement.)

See Also

Neodynamic.WinRT Namespace


BarcodeProfessional Properties

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Properties
BarcodeProfessional Class See Also Send Feedback

The BarcodeProfessional type exposes the following members.

Properties

 | Name | Description
Public property | ActualHeight | (Inherited from FrameworkElement.)
Public property | ActualWidth | (Inherited from FrameworkElement.)
Public property | AddChecksum | Gets or sets whether checksum must be calculated and attached to the value to encode.
Public property | AllowDrop | (Inherited from UIElement.)
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology.
Public property | AztecCodeModuleSize | Gets or sets the Aztec Code module size. The unit of measure must be specified to BarcodeUnit property.
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character should be processed when Aztec Code is being generated.
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.
Public property | Background | (Inherited from Panel.)
Public property | BarcodeUnit | Gets or sets the unit of measure for the barcode.
Public property | BarColor | Gets or sets the bars' color of the barcode.
Public property | BarHeight | Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value.
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. The unit of measure must be specified to BarcodeUnit property.
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment.
Public property | BaseUri | (Inherited from FrameworkElement.)
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.
Public property | BearerBarWidth | Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.
Public property | CacheMode | (Inherited from UIElement.)
Public property | Children | (Inherited from Panel.)
Public property | ChildrenTransitions | (Inherited from Panel.)
Public property | Clip | (Inherited from UIElement.)
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.
Public property | Code | Gets or sets the value to encode.
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.
Public property | CodeAlignment | Gets or sets the text alignment for Code property.
Public property | DataContext | (Inherited from FrameworkElement.)
Public property | DataMatrixEncoding | Gets or sets the DataMatrix Encoding to use on that symbology.
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.
Public property | DataMatrixFormat | Gets or sets the DataMatrix Format to use on that symbology.
Public property | DataMatrixModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character should be processed when DataMatrix code is being generated.
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.
Public property | DesiredSize | (Inherited from UIElement.)
Public property | Dispatcher | (Inherited from DependencyObject.)
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode on the barcode.
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed on the barcode.
Public property | DisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed on the barcode.
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies.
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies.
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Extended | Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.
Public property | FlowDirection | (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the name of the specified font for Code or HumanReadableText property.
Public property | FontSize | Gets or sets the font size for Code or HumanReadableText property. The unit of measure must be specified to FontUnit property.
Public property | FontStretch | Gets or sets the degree to which a font for Code or HumanReadableText property is condensed or expanded.
Public property | FontStyle | Gets or sets the font style for Code or HumanReadableText property.
Public property | FontUnit | Gets or sets the unit of measure for the font object.
Public property | FontWeight | Gets or sets the weight or thickness of the specified font for Code or HumanReadableText property.
Public property | Foreground | Gets or sets a brush that describes the foreground color for Code or HumanReadableText property.
Public property | GuardBar | Gets or sets whether guard bars must be drawn for EAN and UPC symbologies.
Public property | GuardBarHeight | Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.
Public property | Height | (Inherited from FrameworkElement.)
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
Public property | HorizontalAlignment | (Inherited from FrameworkElement.)
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated.
Public property | IsDoubleTapEnabled | (Inherited from UIElement.)
Public property | IsHitTestVisible | (Inherited from UIElement.)
Public property | IsHoldingEnabled | (Inherited from UIElement.)
Public property | IsItemsHost | (Inherited from Panel.)
Public property | IsRightTapEnabled | (Inherited from UIElement.)
Public property | IsTapEnabled | (Inherited from UIElement.)
Public property | Language | (Inherited from FrameworkElement.)
 | LicenseKey | Gets or sets the License Key for product registration.
 | LicenseOwner | Gets or sets the License Owner for product registration.
Public property | ManipulationMode | (Inherited from UIElement.)
Public property | Margin | (Inherited from FrameworkElement.)
Public property | MaxHeight | (Inherited from FrameworkElement.)
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode.
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character should be processed when MaxiCode code is being generated.
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.
Public property | MaxWidth | (Inherited from FrameworkElement.)
Public property | MICRCharHeight | Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.
Public property | MICRCharSpacing | Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.
Public property | MICRCharWidths | Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology.
Public property | MinHeight | (Inherited from FrameworkElement.)
Public property | MinWidth | (Inherited from FrameworkElement.)
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology.
Public property | Name | (Inherited from FrameworkElement.)
Public property | Opacity | (Inherited from UIElement.)
Public property | Parent | (Inherited from FrameworkElement.)
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology.
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology.
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology.
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology.
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed).
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PointerCaptures | (Inherited from UIElement.)
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn on the barcode.
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | Projection | (Inherited from UIElement.)
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology.
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology.
Public property | QRCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeProcessTilde | Gets or sets whether tilde character should be processed when QR Code is being generated.
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology.
Public property | QuietZone | Gets or sets the quiet zones. The unit of measure must be specified to BarcodeUnit property.
Public property | RenderSize | (Inherited from UIElement.)
Public property | RenderTransform | (Inherited from UIElement.)
Public property | RenderTransformOrigin | (Inherited from UIElement.)
Public property | Resources | (Inherited from FrameworkElement.)
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.
Public property | Style | (Inherited from FrameworkElement.)
Public property | Symbology | Gets or sets the barcode symbology/standard to generate.
Public property | Tag | (Inherited from FrameworkElement.)
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology.
Public property | Text | Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode.
Public property | TextAlignment | Gets or sets the text alignment for Text property.
Public property | TextFontFamily | Gets or sets the name of the specified font for Text property.
Public property | TextFontSize | Gets or sets the font size for Text property. The unit of measure must be specified to TextFontUnit property.
Public property | TextFontStretch | Gets or sets the degree to which a font for Text property is condensed or expanded.
Public property | TextFontStyle | Gets or sets the font style for Text property.
Public property | TextFontUnit | Gets or sets the unit of measure for the font object for Text property.
Public property | TextFontWeight | Gets or sets the weight or thickness of the specified font for Text property.
Public property | TextForeground | Gets or sets a brush that describes the foreground color for Text property.
Public property | Transitions | (Inherited from UIElement.)
Public property | Triggers | (Inherited from FrameworkElement.)
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology.
Public property | UseLayoutRounding | Gets or sets a value that determines whether to use rounding behavior that aligns layout to whole pixels.
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology.
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn.
Public property | VerticalAlignment | (Inherited from FrameworkElement.)
Public property | Visibility | (Inherited from UIElement.)
Public property | Width | (Inherited from FrameworkElement.)

See Also

Neodynamic.WinRT Namespace


AddChecksum Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AddChecksum Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether checksum must be calculated and attached to the value to encode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool AddChecksum { get; set; }
Visual Basic
Public Property AddChecksum As Boolean
    Get
    Set
Visual C++
public:
property bool AddChecksum {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


AztecCodeErrorCorrection Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeErrorCorrection Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int AztecCodeErrorCorrection { get; set; }
Visual Basic
Public Property AztecCodeErrorCorrection As Integer
    Get
    Set
Visual C++
public:
property int AztecCodeErrorCorrection {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


AztecCodeFormat Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeFormat Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Aztec Code Format to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public AztecCodeFormat AztecCodeFormat { get; set; }
Visual Basic
Public Property AztecCodeFormat As AztecCodeFormat
    Get
    Set
Visual C++
public:
property AztecCodeFormat AztecCodeFormat {
    AztecCodeFormat get ();
    void set (AztecCodeFormat value);
}

See Also

Neodynamic.WinRT Namespace


AztecCodeModuleSize Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeModuleSize Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Aztec Code module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double AztecCodeModuleSize { get; set; }
Visual Basic
Public Property AztecCodeModuleSize As Double
    Get
    Set
Visual C++
public:
property double AztecCodeModuleSize {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


AztecCodeProcessTilde Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeProcessTilde Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether tilde character should be processed when Aztec Code is being generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool AztecCodeProcessTilde { get; set; }
Visual Basic
Public Property AztecCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool AztecCodeProcessTilde {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


AztecCodeRune Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..AztecCodeRune Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int AztecCodeRune { get; set; }
Visual Basic
Public Property AztecCodeRune As Integer
    Get
    Set
Visual C++
public:
property int AztecCodeRune {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


BarcodeUnit Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarcodeUnit Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the unit of measure for the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public BarcodeUnit BarcodeUnit { get; set; }
Visual Basic
Public Property BarcodeUnit As BarcodeUnit
    Get
    Set
Visual C++
public:
property BarcodeUnit BarcodeUnit {
    BarcodeUnit get ();
    void set (BarcodeUnit value);
}

See Also

Neodynamic.WinRT Namespace


BarColor Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarColor Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the bars' color of the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Color BarColor { get; set; }
Visual Basic
Public Property BarColor As Color
    Get
    Set
Visual C++
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}

See Also

Neodynamic.WinRT Namespace


BarHeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarHeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double BarHeight { get; set; }
Visual Basic
Public Property BarHeight As Double
    Get
    Set
Visual C++
public:
property double BarHeight {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


BarRatio Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarRatio Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double BarRatio { get; set; }
Visual Basic
Public Property BarRatio As Double
    Get
    Set
Visual C++
public:
property double BarRatio {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


BarWidth Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarWidth Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double BarWidth { get; set; }
Visual Basic
Public Property BarWidth As Double
    Get
    Set
Visual C++
public:
property double BarWidth {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


BarWidthAdjustment Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BarWidthAdjustment Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Bar Width Adjustment.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double BarWidthAdjustment { get; set; }
Visual Basic
Public Property BarWidthAdjustment As Double
    Get
    Set
Visual C++
public:
property double BarWidthAdjustment {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


BearerBarStyle Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BearerBarStyle Property
BarcodeProfessional Class See Also Send Feedback
Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public BearerBarStyle BearerBarStyle { get; set; }
Visual Basic
Public Property BearerBarStyle As BearerBarStyle
    Get
    Set
Visual C++
public:
property BearerBarStyle BearerBarStyle {
    BearerBarStyle get ();
    void set (BearerBarStyle value);
}

See Also

Neodynamic.WinRT Namespace


BearerBarWidth Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..BearerBarWidth Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double BearerBarWidth { get; set; }
Visual Basic
Public Property BearerBarWidth As Double
    Get
    Set
Visual C++
public:
property double BearerBarWidth {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


CodabarStartChar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodabarStartChar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public CodabarStartStopChar CodabarStartChar { get; set; }
Visual Basic
Public Property CodabarStartChar As CodabarStartStopChar
    Get
    Set
Visual C++
public:
property CodabarStartStopChar CodabarStartChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}

See Also

Neodynamic.WinRT Namespace


CodabarStopChar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodabarStopChar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public CodabarStartStopChar CodabarStopChar { get; set; }
Visual Basic
Public Property CodabarStopChar As CodabarStartStopChar
    Get
    Set
Visual C++
public:
property CodabarStartStopChar CodabarStopChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}

See Also

Neodynamic.WinRT Namespace


Code Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Code Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the value to encode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


Code128CharSet Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Code128CharSet Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Code128 Code128CharSet { get; set; }
Visual Basic
Public Property Code128CharSet As Code128
    Get
    Set
Visual C++
public:
property Code128 Code128CharSet {
    Code128 get ();
    void set (Code128 value);
}

See Also

Neodynamic.WinRT Namespace


Code16kMode Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Code16kMode Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Code16k Code16kMode { get; set; }
Visual Basic
Public Property Code16kMode As Code16k
    Get
    Set
Visual C++
public:
property Code16k Code16kMode {
    Code16k get ();
    void set (Code16k value);
}

See Also

Neodynamic.WinRT Namespace


CodeAlignment Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..CodeAlignment Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the text alignment for Code property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Alignment CodeAlignment { get; set; }
Visual Basic
Public Property CodeAlignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment CodeAlignment {
    Alignment get ();
    void set (Alignment value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixEncoding Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixEncoding Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the DataMatrix Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public DataMatrixEncoding DataMatrixEncoding { get; set; }
Visual Basic
Public Property DataMatrixEncoding As DataMatrixEncoding
    Get
    Set
Visual C++
public:
property DataMatrixEncoding DataMatrixEncoding {
    DataMatrixEncoding get ();
    void set (DataMatrixEncoding value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixFileId Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixFileId Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string DataMatrixFileId { get; set; }
Visual Basic
Public Property DataMatrixFileId As String
    Get
    Set
Visual C++
public:
property String^ DataMatrixFileId {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixFormat Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixFormat Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the DataMatrix Format to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public DataMatrixFormat DataMatrixFormat { get; set; }
Visual Basic
Public Property DataMatrixFormat As DataMatrixFormat
    Get
    Set
Visual C++
public:
property DataMatrixFormat DataMatrixFormat {
    DataMatrixFormat get ();
    void set (DataMatrixFormat value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixModuleSize Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixModuleSize Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double DataMatrixModuleSize { get; set; }
Visual Basic
Public Property DataMatrixModuleSize As Double
    Get
    Set
Visual C++
public:
property double DataMatrixModuleSize {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixProcessTilde Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixProcessTilde Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether tilde character should be processed when DataMatrix code is being generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool DataMatrixProcessTilde { get; set; }
Visual Basic
Public Property DataMatrixProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool DataMatrixProcessTilde {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixSymbolCount Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixSymbolCount Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int DataMatrixSymbolCount { get; set; }
Visual Basic
Public Property DataMatrixSymbolCount As Integer
    Get
    Set
Visual C++
public:
property int DataMatrixSymbolCount {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


DataMatrixSymbolIndex Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DataMatrixSymbolIndex Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int DataMatrixSymbolIndex { get; set; }
Visual Basic
Public Property DataMatrixSymbolIndex As Integer
    Get
    Set
Visual C++
public:
property int DataMatrixSymbolIndex {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


DisplayChecksum Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayChecksum Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether checksum value must be displayed after the value to encode on the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool DisplayChecksum { get; set; }
Visual Basic
Public Property DisplayChecksum As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayChecksum {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


DisplayCode Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayCode Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether the value to encode must be displayed on the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool DisplayCode { get; set; }
Visual Basic
Public Property DisplayCode As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayCode {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


DisplayLightMarginIndicator Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayLightMarginIndicator Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool DisplayLightMarginIndicator { get; set; }
Visual Basic
Public Property DisplayLightMarginIndicator As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayLightMarginIndicator {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


DisplayStartStopChar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..DisplayStartStopChar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether start and stop characters must be displayed on the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool DisplayStartStopChar { get; set; }
Visual Basic
Public Property DisplayStartStopChar As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayStartStopChar {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


EanUpcSupplement Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplement Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the supplement type to use with EAN and UPC symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Supplement EanUpcSupplement { get; set; }
Visual Basic
Public Property EanUpcSupplement As Supplement
    Get
    Set
Visual C++
public:
property Supplement EanUpcSupplement {
    Supplement get ();
    void set (Supplement value);
}

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementCode Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementCode Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the supplement value for EAN and UPC symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string EanUpcSupplementCode { get; set; }
Visual Basic
Public Property EanUpcSupplementCode As String
    Get
    Set
Visual C++
public:
property String^ EanUpcSupplementCode {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementSeparation Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementSeparation Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the gap separation between the barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double EanUpcSupplementSeparation { get; set; }
Visual Basic
Public Property EanUpcSupplementSeparation As Double
    Get
    Set
Visual C++
public:
property double EanUpcSupplementSeparation {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


EanUpcSupplementTopMargin Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..EanUpcSupplementTopMargin Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double EanUpcSupplementTopMargin { get; set; }
Visual Basic
Public Property EanUpcSupplementTopMargin As Double
    Get
    Set
Visual C++
public:
property double EanUpcSupplementTopMargin {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


Extended Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Extended Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool Extended { get; set; }
Visual Basic
Public Property Extended As Boolean
    Get
    Set
Visual C++
public:
property bool Extended {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


FontFamily Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontFamily Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the name of the specified font for Code or HumanReadableText property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic
Public Property FontFamily As FontFamily
    Get
    Set
Visual C++
public:
property FontFamily^ FontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}

See Also

Neodynamic.WinRT Namespace


FontSize Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontSize Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the font size for Code or HumanReadableText property. The unit of measure must be specified to FontUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double FontSize { get; set; }
Visual Basic
Public Property FontSize As Double
    Get
    Set
Visual C++
public:
property double FontSize {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


FontStretch Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontStretch Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the degree to which a font for Code or HumanReadableText property is condensed or expanded.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontStretch FontStretch { get; set; }
Visual Basic
Public Property FontStretch As FontStretch
    Get
    Set
Visual C++
public:
property FontStretch FontStretch {
    FontStretch get ();
    void set (FontStretch value);
}

See Also

Neodynamic.WinRT Namespace


FontStyle Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontStyle Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the font style for Code or HumanReadableText property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontStyle FontStyle { get; set; }
Visual Basic
Public Property FontStyle As FontStyle
    Get
    Set
Visual C++
public:
property FontStyle FontStyle {
    FontStyle get ();
    void set (FontStyle value);
}

See Also

Neodynamic.WinRT Namespace


FontUnit Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontUnit Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the unit of measure for the font object.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontUnit FontUnit { get; set; }
Visual Basic
Public Property FontUnit As FontUnit
    Get
    Set
Visual C++
public:
property FontUnit FontUnit {
    FontUnit get ();
    void set (FontUnit value);
}

See Also

Neodynamic.WinRT Namespace


FontWeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..FontWeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the weight or thickness of the specified font for Code or HumanReadableText property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontWeight FontWeight { get; set; }
Visual Basic
Public Property FontWeight As FontWeight
    Get
    Set
Visual C++
public:
property FontWeight FontWeight {
    FontWeight get ();
    void set (FontWeight value);
}

See Also

Neodynamic.WinRT Namespace


Foreground Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Foreground Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets a brush that describes the foreground color for Code or HumanReadableText property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic
Public Property Foreground As Brush
    Get
    Set
Visual C++
public:
property Brush^ Foreground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Neodynamic.WinRT Namespace


GuardBar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..GuardBar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether guard bars must be drawn for EAN and UPC symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool GuardBar { get; set; }
Visual Basic
Public Property GuardBar As Boolean
    Get
    Set
Visual C++
public:
property bool GuardBar {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


GuardBarHeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..GuardBarHeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double GuardBarHeight { get; set; }
Visual Basic
Public Property GuardBarHeight As Double
    Get
    Set
Visual C++
public:
property double GuardBarHeight {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


HibcFormatHumanReadableText Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..HibcFormatHumanReadableText Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool HibcFormatHumanReadableText { get; set; }
Visual Basic
Public Property HibcFormatHumanReadableText As Boolean
    Get
    Set
Visual C++
public:
property bool HibcFormatHumanReadableText {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


HumanReadableText Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..HumanReadableText Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string HumanReadableText { get; set; }
Visual Basic
Public Property HumanReadableText As String
    Get
    Set
Visual C++
public:
property String^ HumanReadableText {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


Isbt128DataStructure Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Isbt128DataStructure Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the ISBT 128 Data Structure to be generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Isbt128DataStructure Isbt128DataStructure { get; set; }
Visual Basic
Public Property Isbt128DataStructure As Isbt128DataStructure
    Get
    Set
Visual C++
public:
property Isbt128DataStructure Isbt128DataStructure {
    Isbt128DataStructure get ();
    void set (Isbt128DataStructure value);
}

See Also

Neodynamic.WinRT Namespace


LicenseKey Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..LicenseKey Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the License Key for product registration.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static string LicenseKey { get; set; }
Visual Basic
Public Shared Property LicenseKey As String
    Get
    Set
Visual C++
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


LicenseOwner Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..LicenseOwner Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the License Owner for product registration.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static string LicenseOwner { get; set; }
Visual Basic
Public Shared Property LicenseOwner As String
    Get
    Set
Visual C++
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


MaxiCodeMode Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeMode Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the MaxiCode mode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public MaxiCodeModes MaxiCodeMode { get; set; }
Visual Basic
Public Property MaxiCodeMode As MaxiCodeModes
    Get
    Set
Visual C++
public:
property MaxiCodeModes MaxiCodeMode {
    MaxiCodeModes get ();
    void set (MaxiCodeModes value);
}

See Also

Neodynamic.WinRT Namespace


MaxiCodeProcessTilde Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeProcessTilde Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether tilde character should be processed when MaxiCode code is being generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool MaxiCodeProcessTilde { get; set; }
Visual Basic
Public Property MaxiCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool MaxiCodeProcessTilde {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


MaxiCodeSymbolCount Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeSymbolCount Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int MaxiCodeSymbolCount { get; set; }
Visual Basic
Public Property MaxiCodeSymbolCount As Integer
    Get
    Set
Visual C++
public:
property int MaxiCodeSymbolCount {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


MaxiCodeSymbolIndex Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MaxiCodeSymbolIndex Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int MaxiCodeSymbolIndex { get; set; }
Visual Basic
Public Property MaxiCodeSymbolIndex As Integer
    Get
    Set
Visual C++
public:
property int MaxiCodeSymbolIndex {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


MICRCharHeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharHeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double MICRCharHeight { get; set; }
Visual Basic
Public Property MICRCharHeight As Double
    Get
    Set
Visual C++
public:
property double MICRCharHeight {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


MICRCharSpacing Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharSpacing Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string MICRCharSpacing { get; set; }
Visual Basic
Public Property MICRCharSpacing As String
    Get
    Set
Visual C++
public:
property String^ MICRCharSpacing {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


MICRCharWidths Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MICRCharWidths Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string MICRCharWidths { get; set; }
Visual Basic
Public Property MICRCharWidths As String
    Get
    Set
Visual C++
public:
property String^ MICRCharWidths {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


MicroPdf417Version Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MicroPdf417Version Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public MicroPdf417Version MicroPdf417Version { get; set; }
Visual Basic
Public Property MicroPdf417Version As MicroPdf417Version
    Get
    Set
Visual C++
public:
property MicroPdf417Version MicroPdf417Version {
    MicroPdf417Version get ();
    void set (MicroPdf417Version value);
}

See Also

Neodynamic.WinRT Namespace


MicroQRCodeVersion Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MicroQRCodeVersion Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Micro QR Code Version to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public MicroQRCodeVersion MicroQRCodeVersion { get; set; }
Visual Basic
Public Property MicroQRCodeVersion As MicroQRCodeVersion
    Get
    Set
Visual C++
public:
property MicroQRCodeVersion MicroQRCodeVersion {
    MicroQRCodeVersion get ();
    void set (MicroQRCodeVersion value);
}

See Also

Neodynamic.WinRT Namespace


MsiChecksum Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..MsiChecksum Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the checksum mode to be used on MSI symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public MsiChecksum MsiChecksum { get; set; }
Visual Basic
Public Property MsiChecksum As MsiChecksum
    Get
    Set
Visual C++
public:
property MsiChecksum MsiChecksum {
    MsiChecksum get ();
    void set (MsiChecksum value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417AspectRatio Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417AspectRatio Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double Pdf417AspectRatio { get; set; }
Visual Basic
Public Property Pdf417AspectRatio As Double
    Get
    Set
Visual C++
public:
property double Pdf417AspectRatio {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417Columns Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417Columns Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of columns to use for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int Pdf417Columns { get; set; }
Visual Basic
Public Property Pdf417Columns As Integer
    Get
    Set
Visual C++
public:
property int Pdf417Columns {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417CompactionType Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417CompactionType Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Compaction Type to apply for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Pdf417CompactionType Pdf417CompactionType { get; set; }
Visual Basic
Public Property Pdf417CompactionType As Pdf417CompactionType
    Get
    Set
Visual C++
public:
property Pdf417CompactionType Pdf417CompactionType {
    Pdf417CompactionType get ();
    void set (Pdf417CompactionType value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417ErrorCorrectionLevel Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417ErrorCorrectionLevel Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Error Correction Level to apply for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel { get; set; }
Visual Basic
Public Property Pdf417ErrorCorrectionLevel As Pdf417ErrorCorrection
    Get
    Set
Visual C++
public:
property Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel {
    Pdf417ErrorCorrection get ();
    void set (Pdf417ErrorCorrection value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417FileId Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417FileId Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string Pdf417FileId { get; set; }
Visual Basic
Public Property Pdf417FileId As String
    Get
    Set
Visual C++
public:
property String^ Pdf417FileId {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417Rows Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417Rows Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of rows to use for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int Pdf417Rows { get; set; }
Visual Basic
Public Property Pdf417Rows As Integer
    Get
    Set
Visual C++
public:
property int Pdf417Rows {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417SegmentCount Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417SegmentCount Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int Pdf417SegmentCount { get; set; }
Visual Basic
Public Property Pdf417SegmentCount As Integer
    Get
    Set
Visual C++
public:
property int Pdf417SegmentCount {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417SegmentIndex Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417SegmentIndex Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int Pdf417SegmentIndex { get; set; }
Visual Basic
Public Property Pdf417SegmentIndex As Integer
    Get
    Set
Visual C++
public:
property int Pdf417SegmentIndex {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


Pdf417Truncated Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Pdf417Truncated Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether the right side of PDF417 barcode is truncated (removed).

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool Pdf417Truncated { get; set; }
Visual Basic
Public Property Pdf417Truncated As Boolean
    Get
    Set
Visual C++
public:
property bool Pdf417Truncated {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


PharmacodeBarsSpacing Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeBarsSpacing Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PharmacodeBarsSpacing { get; set; }
Visual Basic
Public Property PharmacodeBarsSpacing As Double
    Get
    Set
Visual C++
public:
property double PharmacodeBarsSpacing {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PharmacodeThickBarWidth Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeThickBarWidth Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PharmacodeThickBarWidth { get; set; }
Visual Basic
Public Property PharmacodeThickBarWidth As Double
    Get
    Set
Visual C++
public:
property double PharmacodeThickBarWidth {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PharmacodeThinBarWidth Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PharmacodeThinBarWidth Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PharmacodeThinBarWidth { get; set; }
Visual Basic
Public Property PharmacodeThinBarWidth As Double
    Get
    Set
Visual C++
public:
property double PharmacodeThinBarWidth {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PlanetHeightShortBar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PlanetHeightShortBar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PlanetHeightShortBar { get; set; }
Visual Basic
Public Property PlanetHeightShortBar As Double
    Get
    Set
Visual C++
public:
property double PlanetHeightShortBar {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PlanetHeightTallBar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PlanetHeightTallBar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PlanetHeightTallBar { get; set; }
Visual Basic
Public Property PlanetHeightTallBar As Double
    Get
    Set
Visual C++
public:
property double PlanetHeightTallBar {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


Postal4StateAddStartStopChar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateAddStartStopChar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether start and stop characters must be added and drawn on the barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool Postal4StateAddStartStopChar { get; set; }
Visual Basic
Public Property Postal4StateAddStartStopChar As Boolean
    Get
    Set
Visual C++
public:
property bool Postal4StateAddStartStopChar {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


Postal4StateBarsSpacing Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateBarsSpacing Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double Postal4StateBarsSpacing { get; set; }
Visual Basic
Public Property Postal4StateBarsSpacing As Double
    Get
    Set
Visual C++
public:
property double Postal4StateBarsSpacing {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


Postal4StateTrackerBarHeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateTrackerBarHeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double Postal4StateTrackerBarHeight { get; set; }
Visual Basic
Public Property Postal4StateTrackerBarHeight As Double
    Get
    Set
Visual C++
public:
property double Postal4StateTrackerBarHeight {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


Postal4StateTrackerBarWidth Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Postal4StateTrackerBarWidth Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double Postal4StateTrackerBarWidth { get; set; }
Visual Basic
Public Property Postal4StateTrackerBarWidth As Double
    Get
    Set
Visual C++
public:
property double Postal4StateTrackerBarWidth {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PostnetHeightShortBar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PostnetHeightShortBar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PostnetHeightShortBar { get; set; }
Visual Basic
Public Property PostnetHeightShortBar As Double
    Get
    Set
Visual C++
public:
property double PostnetHeightShortBar {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


PostnetHeightTallBar Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..PostnetHeightTallBar Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double PostnetHeightTallBar { get; set; }
Visual Basic
Public Property PostnetHeightTallBar As Double
    Get
    Set
Visual C++
public:
property double PostnetHeightTallBar {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


QRCodeEncoding Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeEncoding Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the QR Code Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public QRCodeEncoding QRCodeEncoding { get; set; }
Visual Basic
Public Property QRCodeEncoding As QRCodeEncoding
    Get
    Set
Visual C++
public:
property QRCodeEncoding QRCodeEncoding {
    QRCodeEncoding get ();
    void set (QRCodeEncoding value);
}

See Also

Neodynamic.WinRT Namespace


QRCodeErrorCorrectionLevel Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeErrorCorrectionLevel Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Error Correction Level to apply for QR Code symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel { get; set; }
Visual Basic
Public Property QRCodeErrorCorrectionLevel As QRCodeErrorCorrectionLevel
    Get
    Set
Visual C++
public:
property QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel {
    QRCodeErrorCorrectionLevel get ();
    void set (QRCodeErrorCorrectionLevel value);
}

See Also

Neodynamic.WinRT Namespace


QRCodeModuleSize Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeModuleSize Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double QRCodeModuleSize { get; set; }
Visual Basic
Public Property QRCodeModuleSize As Double
    Get
    Set
Visual C++
public:
property double QRCodeModuleSize {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


QRCodeProcessTilde Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeProcessTilde Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether tilde character should be processed when QR Code is being generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool QRCodeProcessTilde { get; set; }
Visual Basic
Public Property QRCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool QRCodeProcessTilde {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


QRCodeVersion Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QRCodeVersion Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the QR Code Version to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public QRCodeVersion QRCodeVersion { get; set; }
Visual Basic
Public Property QRCodeVersion As QRCodeVersion
    Get
    Set
Visual C++
public:
property QRCodeVersion QRCodeVersion {
    QRCodeVersion get ();
    void set (QRCodeVersion value);
}

See Also

Neodynamic.WinRT Namespace


QuietZone Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..QuietZone Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the quiet zones. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Thickness QuietZone { get; set; }
Visual Basic
Public Property QuietZone As Thickness
    Get
    Set
Visual C++
public:
property Thickness QuietZone {
    Thickness get ();
    void set (Thickness value);
}

See Also

Neodynamic.WinRT Namespace


SegmentsPerRow Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..SegmentsPerRow Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int SegmentsPerRow { get; set; }
Visual Basic
Public Property SegmentsPerRow As Integer
    Get
    Set
Visual C++
public:
property int SegmentsPerRow {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


Symbology Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Symbology Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the barcode symbology/standard to generate.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Symbology Symbology { get; set; }
Visual Basic
Public Property Symbology As Symbology
    Get
    Set
Visual C++
public:
property Symbology Symbology {
    Symbology get ();
    void set (Symbology value);
}

See Also

Neodynamic.WinRT Namespace


TelepenEncoding Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TelepenEncoding Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the Telepen Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public TelepenEncoding TelepenEncoding { get; set; }
Visual Basic
Public Property TelepenEncoding As TelepenEncoding
    Get
    Set
Visual C++
public:
property TelepenEncoding TelepenEncoding {
    TelepenEncoding get ();
    void set (TelepenEncoding value);
}

See Also

Neodynamic.WinRT Namespace


Text Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..Text Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

See Also

Neodynamic.WinRT Namespace


TextAlignment Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextAlignment Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the text alignment for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Alignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As Alignment
    Get
    Set
Visual C++
public:
property Alignment TextAlignment {
    Alignment get ();
    void set (Alignment value);
}

See Also

Neodynamic.WinRT Namespace


TextFontFamily Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontFamily Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the name of the specified font for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontFamily TextFontFamily { get; set; }
Visual Basic
Public Property TextFontFamily As FontFamily
    Get
    Set
Visual C++
public:
property FontFamily^ TextFontFamily {
    FontFamily^ get ();
    void set (FontFamily^ value);
}

See Also

Neodynamic.WinRT Namespace


TextFontSize Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontSize Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the font size for Text property. The unit of measure must be specified to TextFontUnit property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public double TextFontSize { get; set; }
Visual Basic
Public Property TextFontSize As Double
    Get
    Set
Visual C++
public:
property double TextFontSize {
    double get ();
    void set (double value);
}

See Also

Neodynamic.WinRT Namespace


TextFontStretch Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontStretch Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the degree to which a font for Text property is condensed or expanded.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontStretch TextFontStretch { get; set; }
Visual Basic
Public Property TextFontStretch As FontStretch
    Get
    Set
Visual C++
public:
property FontStretch TextFontStretch {
    FontStretch get ();
    void set (FontStretch value);
}

See Also

Neodynamic.WinRT Namespace


TextFontStyle Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontStyle Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the font style for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontStyle TextFontStyle { get; set; }
Visual Basic
Public Property TextFontStyle As FontStyle
    Get
    Set
Visual C++
public:
property FontStyle TextFontStyle {
    FontStyle get ();
    void set (FontStyle value);
}

See Also

Neodynamic.WinRT Namespace


TextFontUnit Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontUnit Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the unit of measure for the font object for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontUnit TextFontUnit { get; set; }
Visual Basic
Public Property TextFontUnit As FontUnit
    Get
    Set
Visual C++
public:
property FontUnit TextFontUnit {
    FontUnit get ();
    void set (FontUnit value);
}

See Also

Neodynamic.WinRT Namespace


TextFontWeight Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextFontWeight Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the weight or thickness of the specified font for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FontWeight TextFontWeight { get; set; }
Visual Basic
Public Property TextFontWeight As FontWeight
    Get
    Set
Visual C++
public:
property FontWeight TextFontWeight {
    FontWeight get ();
    void set (FontWeight value);
}

See Also

Neodynamic.WinRT Namespace


TextForeground Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..TextForeground Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets a brush that describes the foreground color for Text property.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public Brush TextForeground { get; set; }
Visual Basic
Public Property TextForeground As Brush
    Get
    Set
Visual C++
public:
property Brush^ TextForeground {
    Brush^ get ();
    void set (Brush^ value);
}

See Also

Neodynamic.WinRT Namespace


UpcESystem Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UpcESystem Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number system to use for UPC-E symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public UpcE UpcESystem { get; set; }
Visual Basic
Public Property UpcESystem As UpcE
    Get
    Set
Visual C++
public:
property UpcE UpcESystem {
    UpcE get ();
    void set (UpcE value);
}

See Also

Neodynamic.WinRT Namespace


UseLayoutRounding Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UseLayoutRounding Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets a value that determines whether to use rounding behavior that aligns layout to whole pixels.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool UseLayoutRounding { get; set; }
Visual Basic
Public Property UseLayoutRounding As Boolean
    Get
    Set
Visual C++
public:
property bool UseLayoutRounding {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


UseQuietZoneForText Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UseQuietZoneForText Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public bool UseQuietZoneForText { get; set; }
Visual Basic
Public Property UseQuietZoneForText As Boolean
    Get
    Set
Visual C++
public:
property bool UseQuietZoneForText {
    bool get ();
    void set (bool value);
}

See Also

Neodynamic.WinRT Namespace


UspsFimPattern Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UspsFimPattern Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the USPS FIM pattern to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public FIM UspsFimPattern { get; set; }
Visual Basic
Public Property UspsFimPattern As FIM
    Get
    Set
Visual C++
public:
property FIM UspsFimPattern {
    FIM get ();
    void set (FIM value);
}

See Also

Neodynamic.WinRT Namespace


UspsHorizontalBarsCount Property

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional..::..UspsHorizontalBarsCount Property
BarcodeProfessional Class See Also Send Feedback
Gets or sets the number of horizontal bars to be drawn.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public int UspsHorizontalBarsCount { get; set; }
Visual Basic
Public Property UspsHorizontalBarsCount As Integer
    Get
    Set
Visual C++
public:
property int UspsHorizontalBarsCount {
    int get ();
    void set (int value);
}

See Also

Neodynamic.WinRT Namespace


BarcodeProfessional Events

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeProfessional Events
BarcodeProfessional Class See Also Send Feedback

The BarcodeProfessional type exposes the following members.

Events

 | Name | Description
Public event | DoubleTapped | (Inherited from UIElement.)
Public event | DragEnter | (Inherited from UIElement.)
Public event | DragLeave | (Inherited from UIElement.)
Public event | DragOver | (Inherited from UIElement.)
Public event | Drop | (Inherited from UIElement.)
Public event | GotFocus | (Inherited from UIElement.)
Public event | Holding | (Inherited from UIElement.)
Public event | KeyDown | (Inherited from UIElement.)
Public event | KeyUp | (Inherited from UIElement.)
Public event | LayoutUpdated | (Inherited from FrameworkElement.)
Public event | Loaded | (Inherited from FrameworkElement.)
Public event | LostFocus | (Inherited from UIElement.)
Public event | ManipulationCompleted | (Inherited from UIElement.)
Public event | ManipulationDelta | (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | (Inherited from UIElement.)
Public event | ManipulationStarted | (Inherited from UIElement.)
Public event | ManipulationStarting | (Inherited from UIElement.)
Public event | PointerCanceled | (Inherited from UIElement.)
Public event | PointerCaptureLost | (Inherited from UIElement.)
Public event | PointerEntered | (Inherited from UIElement.)
Public event | PointerExited | (Inherited from UIElement.)
Public event | PointerMoved | (Inherited from UIElement.)
Public event | PointerPressed | (Inherited from UIElement.)
Public event | PointerReleased | (Inherited from UIElement.)
Public event | PointerWheelChanged | (Inherited from UIElement.)
Public event | RightTapped | (Inherited from UIElement.)
Public event | SizeChanged | (Inherited from FrameworkElement.)
Public event | Tapped | (Inherited from UIElement.)
Public event | Unloaded | (Inherited from FrameworkElement.)

See Also

Neodynamic.WinRT Namespace


BarcodeUnit Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUnit Enumeration
See Also Send Feedback
Specifies the unit of measure for barcode generation.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum BarcodeUnit
Visual Basic
Public Enumeration BarcodeUnit
Visual C++
public enum class BarcodeUnit

Members

Member name | Value | Description
Inch | 0 | Specifies the inch as the unit of measure.
Millimeter | 1 | Specifies the millimeter as the unit of measure.
Centimeter | 2 | Specifies the centimeter as the unit of measure.
Mils | 3 | Specifies the Mils (one-thousandth of an inch) as the unit of measure.

See Also

Neodynamic.WinRT Namespace


BarcodeUtils Class

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils Class
Members See Also Send Feedback
BarcodeUtils provides additional utilities related to barcode generation.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public class BarcodeUtils
Visual Basic
Public Class BarcodeUtils
Visual C++
public ref class BarcodeUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.WinRT..::..BarcodeUtils

See Also

BarcodeUtils Members
Neodynamic.WinRT Namespace


BarcodeUtils Members

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils Members
BarcodeUtils Class Constructors Methods See Also Send Feedback

The BarcodeUtils type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeUtils |

Methods

Name | Description
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.

See Also

BarcodeUtils Class
Neodynamic.WinRT Namespace


BarcodeUtils Constructor

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils Constructor
BarcodeUtils Class See Also Send Feedback

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public BarcodeUtils()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeUtils()

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


BarcodeUtils Methods

[image] [image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils Methods
BarcodeUtils Class See Also Send Feedback

The BarcodeUtils type exposes the following members.

Methods

Name | Description
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.

See Also

BarcodeUtils Class
Neodynamic.WinRT Namespace


GetAustraliaPost4StateBarcodeChecksum Method

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils..::..GetAustraliaPost4StateBarcodeChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static string GetAustraliaPost4StateBarcodeChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPost4StateBarcodeChecksum ( _
    code As String _
) As String
Visual C++
public:
static String^ GetAustraliaPost4StateBarcodeChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post 4 State code.

Return Value

The checksum (Reed Solomon codewords) for an Australia Post 4 State code.

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


GetAustraliaPostDomesticEParcelChecksum Method

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils..::..GetAustraliaPostDomesticEParcelChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum for an Australia Post Domestic eParcel code.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static int GetAustraliaPostDomesticEParcelChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPostDomesticEParcelChecksum ( _
    code As String _
) As Integer
Visual C++
public:
static int GetAustraliaPostDomesticEParcelChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post Domestic eParcel code.

Return Value

The checksum for an Australia Post Domestic eParcel code.

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


GetCode39Checksum Method

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils..::..GetCode39Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum Modulus 43 used by Code 39 barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static string GetCode39Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode39Checksum ( _
    code As String _
) As String
Visual C++
public:
static String^ GetCode39Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 39 value.

Return Value

The checksum Modulus 43 used by Code 39 barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


GetCode93Checksum Method

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils..::..GetCode93Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the two-char checksum Modulus 47 used by Code 93 barcode.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static string GetCode93Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode93Checksum ( _
    code As String _
) As String
Visual C++
public:
static String^ GetCode93Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 93 value.

Return Value

The two-char checksum Modulus 47 used by Code 93 barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


GetModulus10Checksum Method

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BarcodeUtils..::..GetModulus10Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum Modulus 10 used by many barcode symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public static int GetModulus10Checksum(
    string code
)
Visual Basic
Public Shared Function GetModulus10Checksum ( _
    code As String _
) As Integer
Visual C++
public:
static int GetModulus10Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The code where the checksum will be computed on.

Return Value

The checksum Modulus 10.

See Also

BarcodeUtils Class
BarcodeUtils Members
Neodynamic.WinRT Namespace


BearerBarStyle Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
BearerBarStyle Enumeration
See Also Send Feedback
Specifies the bearer bars' type that must be drawn on the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcode symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum BearerBarStyle
Visual Basic
Public Enumeration BearerBarStyle
Visual C++
public enum class BearerBarStyle

Members

Member name | Value | Description
None | 0 | No bearer bars are drawn on the barcode
Frame | 1 | The bearer bars are drawn surrounding the symbol
HorizontalRules | 2 | The bearer bars are drawn at the top and bottom on the symbol

See Also

Neodynamic.WinRT Namespace


CodabarStartStopChar Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
CodabarStartStopChar Enumeration
See Also Send Feedback
Specifies the start and stop character for Codabar symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum CodabarStartStopChar
Visual Basic
Public Enumeration CodabarStartStopChar
Visual C++
public enum class CodabarStartStopChar

Members

Member name | Value | Description
A | 0 |
B | 1 |
C | 2 |
D | 3 |

See Also

Neodynamic.WinRT Namespace


Code128 Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Code128 Enumeration
See Also Send Feedback
Specifies the characters set to use in the Code 128 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Code128
Visual Basic
Public Enumeration Code128
Visual C++
public enum class Code128

Members

Member name | Value | Description
Auto | 0 | Barcode Professional will automatically switch between code sets to encode the ASCII values.
A | 1 | Barcode Professional will use the Char Set A which only supports ASCII values from 0 to 95
B | 2 | Barcode Professional will use the Char Set B which only supports ASCII values from 32 to 127
C | 3 | Barcode Professional will use the Char Set C which only supports pairs of digits

See Also

Neodynamic.WinRT Namespace


Code16k Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Code16k Enumeration
See Also Send Feedback
Specifies the mode to use for Code16k symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Code16k
Visual Basic
Public Enumeration Code16k
Visual C++
public enum class Code16k

Members

Member name | Value | Description
Mode0 | 0 | Barcode Professional will use the Code 128 Char Set A which only supports ASCII values from 0 to 95
Mode1 | 1 | Barcode Professional will use the Code 128 Char Set B which only supports ASCII values from 32 to 127
Mode2 | 2 | Barcode Professional will use the Code 128 Char Set C which only supports pairs of digits

See Also

Neodynamic.WinRT Namespace


DataMatrixEncoding Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
DataMatrixEncoding Enumeration
See Also Send Feedback
Specifies the DataMatrix Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum DataMatrixEncoding
Visual Basic
Public Enumeration DataMatrixEncoding
Visual C++
public enum class DataMatrixEncoding

Members

Member name | Value | Description
Auto | 0 |
Ascii | 1 | Used to encode data that mainly contains ASCII characters (0-127)
C40 | 2 | Used to encode data that mainly contains numeric and upper case characters
Text | 3 | Used to encode data that mainly contains numeric and lower case characters
Base256 | 4 | Used to encode 8 bit values

See Also

Neodynamic.WinRT Namespace


DataMatrixFormat Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
DataMatrixFormat Enumeration
See Also Send Feedback
Specifies the DataMatrix Format to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum DataMatrixFormat
Visual Basic
Public Enumeration DataMatrixFormat
Visual C++
public enum class DataMatrixFormat

Members

Member name | Value | Description
Auto | 0 |
C10X10 | 1 |
C12X12 | 2 |
C14X14 | 3 |
C16X16 | 4 |
C18X18 | 5 |
C20X20 | 6 |
C22X22 | 7 |
C24X24 | 8 |
C26X26 | 9 |
C32X32 | 10 |
C36X36 | 11 |
C40X40 | 12 |
C44X44 | 13 |
C48X48 | 14 |
C52X52 | 15 |
C64X64 | 16 |
C72X72 | 17 |
C80X80 | 18 |
C88X88 | 19 |
C96X96 | 20 |
C104X104 | 21 |
C120X120 | 22 |
C132X132 | 23 |
C144X144 | 24 |
C8X18 | 25 |
C8X32 | 26 |
C12X26 | 27 |
C12X36 | 28 |
C16X36 | 29 |
C16X48 | 30 |

See Also

Neodynamic.WinRT Namespace


FIM Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
FIM Enumeration
See Also Send Feedback
Specifies the facing identification mark (FIM) pattern to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum FIM
Visual Basic
Public Enumeration FIM
Visual C++
public enum class FIM

Members

Member name | Value | Description
A | 0 | Used for Courtesy Reply Mail (CRM) and Meter Reply Mail (MRM) with a preprinted barcode.
B | 1 | Used for Business Reply Mail (BRM) without a preprinted BRM ZIP+4 barcode.
C | 2 | Used for Business Reply Mail (BRM) with a preprinted BRM ZIP+4 barcode.
D | 3 | Used only with information based indicia (IBI) postage.

See Also

Neodynamic.WinRT Namespace


FontUnit Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
FontUnit Enumeration
See Also Send Feedback
Specifies the unit of measure for Font objects.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum FontUnit
Visual Basic
Public Enumeration FontUnit
Visual C++
public enum class FontUnit

Members

Member name | Value | Description
Inch | 0 | Specifies the inch as the unit of measure.
Millimeter | 1 | Specifies the millimeter as the unit of measure.
Pixel | 2 | Specifies the pixel as the unit of measure.
Point | 3 | Specifies the point (1/72 inch) as the unit of measure.

See Also

Neodynamic.WinRT Namespace


Isbt128DataStructure Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Isbt128DataStructure Enumeration
See Also Send Feedback
Specifies the ISBT 128 Data Structures.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Isbt128DataStructure
Visual Basic
Public Enumeration Isbt128DataStructure
Visual C++
public enum class Isbt128DataStructure

Members

Member name | Value | Description
DS001 | 0 | Donation Identification Number
DS002 | 1 | Blood Groups (ABO and RhD)
DS003 | 2 | Product Code
DS004 | 3 | Expiration Date
DS005 | 4 | Expiration Date and Time
DS006 | 5 | Collection Date
DS007 | 6 | Collection Date and Time
DS008 | 7 | Production Date
DS009 | 8 | Production Date and Time
DS010 | 9 | Special Testing: General
DS011 | 10 | Special Testing: Red Blood Cell Antigens (withdrawn)
DS012 | 11 | Special Testing: Red Blood Cell Antigens - General
DS013 | 12 | Special Testing: Red Blood Cell Antigens - Finnish
DS014 | 13 | Special Testing: Platelet HLA and Platelet-Specific Antigens
DS015 | 14 | Special Testing: HLA-A and -B Alleles
DS016 | 15 | Special Testing: HLA-DRB1 Alleles
DS017 | 16 | Container Manufacturer and Catalog Number
DS018 | 17 | Container Lot Number
DS019 | 18 | Donor Identification Number
DS020 | 19 | Staff Member Identification Number
DS021 | 20 | Manufacturer and Catalog Number: Items Other Than Containers
DS022 | 21 | Lot Number: Items Other Than Containers
DS023 | 22 | Compound Message
DS024 | 23 | Patient Date of Birth
DS025 | 24 | Patient Hospital Identification Number
DS026 | 25 | Expiration Month and Year

See Also

Neodynamic.WinRT Namespace


MaxiCodeModes Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
MaxiCodeModes Enumeration
See Also Send Feedback
Specifies the MaxiCode modes.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum MaxiCodeModes
Visual Basic
Public Enumeration MaxiCodeModes
Visual C++
public enum class MaxiCodeModes

Members

Member name | Value | Description
Mode2 | 2 | Indicates the symbol contains a Structured Carrier Message with a numeric postal code (U.S.).
Mode3 | 3 | Indicates the symbol contains a Structured Carrier Message with an alphanumeric postal code (non-U.S.).
Mode4 | 4 | Indicates the symbol contains general-purpose data, protected by the standard error correction.
Mode5 | 5 | Indicates the symbol contains general-purpose data, protected by enhanced error correction (EEC).
Mode6 | 6 | Reserved for symbols used to program internal parameters of MaxiCode readers.

See Also

Neodynamic.WinRT Namespace


MicroPdf417Version Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
MicroPdf417Version Enumeration
See Also Send Feedback
Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum MicroPdf417Version
Visual Basic
Public Enumeration MicroPdf417Version
Visual C++
public enum class MicroPdf417Version

Members

Member name | Value | Description
Auto | 0 |
V1X11 | 1 |
V1X14 | 2 |
V1X17 | 3 |
V1X20 | 4 |
V1X24 | 5 |
V1X28 | 6 |
V2X8 | 7 |
V2X11 | 8 |
V2X14 | 9 |
V2X17 | 10 |
V2X20 | 11 |
V2X23 | 12 |
V2X26 | 13 |
V3X6 | 14 |
V3X8 | 15 |
V3X10 | 16 |
V3X12 | 17 |
V3X15 | 18 |
V3X20 | 19 |
V3X26 | 20 |
V3X32 | 21 |
V3X38 | 22 |
V3X44 | 23 |
V4X4 | 24 |
V4X6 | 25 |
V4X8 | 26 |
V4X10 | 27 |
V4X12 | 28 |
V4X15 | 29 |
V4X20 | 30 |
V4X26 | 31 |
V4X32 | 32 |
V4X38 | 33 |
V4X44 | 34 |

See Also

Neodynamic.WinRT Namespace


MicroQRCodeVersion Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
MicroQRCodeVersion Enumeration
See Also Send Feedback
Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum MicroQRCodeVersion
Visual Basic
Public Enumeration MicroQRCodeVersion
Visual C++
public enum class MicroQRCodeVersion

Members

Member name | Value | Description
Auto | 0 |
M1 | 1 |
M2 | 2 |
M3 | 3 |
M4 | 4 |

See Also

Neodynamic.WinRT Namespace


MsiChecksum Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
MsiChecksum Enumeration
See Also Send Feedback
Specifies the checksum method used for MSI barcodes

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum MsiChecksum
Visual Basic
Public Enumeration MsiChecksum
Visual C++
public enum class MsiChecksum

Members

Member name | Value | Description
OneMod10 | 0 |
TwoMod10 | 1 |
Mod11AndMod10 | 2 |

See Also

Neodynamic.WinRT Namespace


Pdf417CompactionType Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Pdf417CompactionType Enumeration
See Also Send Feedback
Specifies the Compaction Type to apply for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Pdf417CompactionType
Visual Basic
Public Enumeration Pdf417CompactionType
Visual C++
public enum class Pdf417CompactionType

Members

Member name | Value | Description
Auto | 0 | It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
Binary | 1 | It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
Text | 2 | It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
Numeric | 3 | It allows encoding numeric data strings.

See Also

Neodynamic.WinRT Namespace


Pdf417ErrorCorrection Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Pdf417ErrorCorrection Enumeration
See Also Send Feedback
Specifies the Error Correction Level to apply for PDF417 symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Pdf417ErrorCorrection
Visual Basic
Public Enumeration Pdf417ErrorCorrection
Visual C++
public enum class Pdf417ErrorCorrection

Members

Member name | Value | Description
Level0 | 0 |
Level1 | 1 |
Level2 | 2 |
Level3 | 3 |
Level4 | 4 |
Level5 | 5 |
Level6 | 6 |
Level7 | 7 |
Level8 | 8 |

See Also

Neodynamic.WinRT Namespace


QRCodeEncoding Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
QRCodeEncoding Enumeration
See Also Send Feedback
Specifies the QR Code Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum QRCodeEncoding
Visual Basic
Public Enumeration QRCodeEncoding
Visual C++
public enum class QRCodeEncoding

Members

Member name | Value | Description
Auto | 0 |
Numeric | 1 | Used to encode data that mainly contains numeric characters
AlphaNumeric | 2 | Used to encode data that mainly contains alphanumeric characters
Kanji | 3 | Used to encode data that mainly contains Kanji characters
Byte | 4 | Used to encode 8 bit values

See Also

Neodynamic.WinRT Namespace


QRCodeErrorCorrectionLevel Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
QRCodeErrorCorrectionLevel Enumeration
See Also Send Feedback
Specifies the Error Correction Level to apply for QR Code symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum QRCodeErrorCorrectionLevel
Visual Basic
Public Enumeration QRCodeErrorCorrectionLevel
Visual C++
public enum class QRCodeErrorCorrectionLevel

Members

Member name | Value | Description
L | 0 | Approx. 7% of codewords can be restored. Error correction level L is appropriate for high symbol quality and/or the need for the smallest possible symbol.
M | 1 | Approx. 15% of codewords can be restored. Level M is described as Standard level and offers a good compromise between small size and increased reliability.
Q | 2 | Approx. 25% of codewords can be restored. Level Q is a High reliability level and suitable for more critical or poor print quality applications.
H | 3 | Approx. 30% of codewords can be restored. Level H offers the maximum achievable reliability.

See Also

Neodynamic.WinRT Namespace


QRCodeVersion Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
QRCodeVersion Enumeration
See Also Send Feedback
Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum QRCodeVersion
Visual Basic
Public Enumeration QRCodeVersion
Visual C++
public enum class QRCodeVersion

Members

Member name | Value | Description
Auto | 0 |
V01 | 1 |
V02 | 2 |
V03 | 3 |
V04 | 4 |
V05 | 5 |
V06 | 6 |
V07 | 7 |
V08 | 8 |
V09 | 9 |
V10 | 10 |
V11 | 11 |
V12 | 12 |
V13 | 13 |
V14 | 14 |
V15 | 15 |
V16 | 16 |
V17 | 17 |
V18 | 18 |
V19 | 19 |
V20 | 20 |
V21 | 21 |
V22 | 22 |
V23 | 23 |
V24 | 24 |
V25 | 25 |
V26 | 26 |
V27 | 27 |
V28 | 28 |
V29 | 29 |
V30 | 30 |
V31 | 31 |
V32 | 32 |
V33 | 33 |
V34 | 34 |
V35 | 35 |
V36 | 36 |
V37 | 37 |
V38 | 38 |
V39 | 39 |
V40 | 40 |

See Also

Neodynamic.WinRT Namespace


Supplement Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Supplement Enumeration
See Also Send Feedback
Specifies the supplement type to use with EAN and UPC symbologies.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Supplement
Visual Basic
Public Enumeration Supplement
Visual C++
public enum class Supplement

Members

Member name | Value | Description
None | 0 |
Digits2 | 1 |
Digits5 | 2 |

See Also

Neodynamic.WinRT Namespace


Symbology Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
Symbology Enumeration
See Also Send Feedback
Specifies the Barcode Symbology/Standard to be used.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum Symbology
Visual Basic
Public Enumeration Symbology
Visual C++
public enum class Symbology

Members

Member name | Value | Description
Codabar | 0 | Codabar a.k.a. ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar
Code11 | 1 | Code 11 a.k.a. Code11, USD-8, USD8
Code16k | 2 | Code 16K
Code39 | 3 | Code 39 a.k.a. ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII
Code93 | 4 | Code 93 a.k.a. ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII
Code128 | 5 | Code 128 a.k.a. ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C
DataMatrix | 6 | Data Matrix a.k.a. Data Matrix ECC200
Ean8 | 7 | EAN-8 a.k.a. European Article Number 8, EAN-8 Supplement 5/Five-digit Add-On, EAN-8 Supplement 2/Two-digit Add-On, EAN-8+5, EAN-8+2, EAN8, EAN8+5, EAN13+2, UPC-8, GTIN-8, GS1-8
Ean13 | 8 | EAN-13 a.k.a. European Article Number 13, EAN-13 Supplement 5/Five-digit Add-On, EAN-13 Supplement 2/Two-digit Add-On, EAN-13+5, EAN-13+2, EAN13, EAN13+5, EAN13+2, UPC-13, GTIN-13, GS1-13
Industrial2of5 | 9 | Industrial 2 of 5 a.k.a. 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5
Interleaved2of5 | 10 | Interleaved 2 of 5 a.k.a. ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved
Isbn | 11 | ISBN a.k.a. International Standard Book Number, Bookland EAN, ISBN-13, ISBN-10, ISBN+5, ISBN+2, ISBN Supplement 5/Five-digit Add-On, ISBN Supplement 2/Two-digit Add-On
Msi | 12 | MSI a.k.a. MSI/Plessey, Modified Plessey
Pdf417 | 13 | PDF417 a.k.a. Portable Data File 417, PDF 417, PDF417 Truncated
Planet | 14 | PLANET a.k.a. USPS PLANET Barcode, USPS Confirm Service Barcode
Postnet | 15 | POSTNET a.k.a. USPS POSTNET Barcode, USPS POSTal Numeric Encoding Technique Barcode, Delivery Point Barcode (DPBC), Postnet 3 of 5
UccEan128 | 16 | UCC/EAN-128 a.k.a. EAN-128, UCC-128, USS-128, GS1-128, UCC.EAN-128, GTIN-128
UpcA | 17 | UPC-A a.k.a. Universal Product Code version A, UPC-A Supplement 5/Five-digit Add-On, UPC-A Supplement 2/Two-digit Add-On, UPC-A+5, UPC-A+2, UPC Code, UPC Symbol, GTIN-12, GS1-12
UpcE | 18 | UPC-E a.k.a. Universal Product Code version E, UPC-E Supplement 5/Five-digit Add-On, UPC-E Supplement 2/Two-digit Add-On, UPC-E+5, UPC-E+2, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead 0, GS1-12
UspsOneCode4CB | 19 | USPS OneCode 4-State Customer Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
RoyalMail | 20 | British Royal Mail 4-State Customer Barcode a.k.a. RM4SCC, RoyalMail4SCC, British Royal Mail 4-State Customer Code and Royal Mail Barcode
AustraliaPost | 21 | Australia Post 4-state Barcode a.k.a. Australian 4-state postal barcode, Australia Post Customer Barcode
RoyalTpgPostKix | 22 | Royal TPG Post KIX 4-State Barcode a.k.a. Kix Barcode, Klantenindex (client index) Barcode, Dutch KIX 4-State Bar Code, Dutch KIX, TPG KIX, and TPGPOST KIX
Sscc18 | 23 | SSCC-18 a.k.a. UPC-128 Shipping Container Code, Code 128 UPC Shipping Container Code, Serial Shipping Container Code, UCC-128, EAN-18, NVE (Nummer der Versandeinheit)
Pzn | 24 | PZN a.k.a. Pharma-Zentral-Nummer, Pharmazentralnummer, Code PZN, CodePZN
DeutschePostLeitcode | 25 | Deutsche Post Leitcode Barcode a.k.a. German Postal 2 of 5 Leitcode, CodeLeitcode, Leitcode, Deutsche Post AG (DHL)
DeutschePostIdentcode | 26 | Deutsche Post Identcode Barcode a.k.a. German Postal 2 of 5 Identcode, Deutsche Post AG Identcode, Deutsche Frachtpost Identcode, Identcode, CodeIdentcode, Deutsche Post AG (DHL)
UspsTrayLabel | 27 | USPS Tray Label Barcode a.k.a. USPS 25 Tray label
UspsSackLabel | 28 | USPS Sack Label Barcode a.k.a. USPS 25 Sack label
EanVelocity | 29 | EAN-Velocity a.k.a. Velocity Barcode
SingaporePost | 30 | Singapore 4-State Postal Code Barcode a.k.a. Singapore 4-State Postal, SingPost 4-State, and SingPost Barcode
Jan8 | 31 | JAN-8 a.k.a. Japanese Article Number 8, JAN-8 Supplement 5/Five-digit Add-On, JAN-8 Supplement 2/Two-digit Add-On, JAN-8+5, JAN-8+2, JAN8, JAN8+5, JAN8+2
Jan13 | 32 | JAN-13 a.k.a. Japanese Article Number 13, JAN-13 Supplement 5/Five-digit Add-On, JAN-13 Supplement 2/Two-digit Add-On, JAN-13+5, JAN-13+2, JAN13, JAN13+5, JAN13+2
SwissPostParcel | 33 | Swiss PostParcel Barcode a.k.a. SwissPost Parcel Barcode, Switzerland Post Parcel Barcode
Opc | 34 | OPC a.k.a. Optical Product Code, VCA Barcode, VCA OPC, Vision Council of America OPC Barcode
Ean99 | 35 | EAN-99 a.k.a. European Article Number 99, EAN-99 Supplement 5/Five-digit Add-On, EAN-99 Supplement 2/Two-digit Add-On, EAN-99+5, EAN-99+2, EAN99, EAN99+5, EAN99+2, GTIN-99, GS1-99, Coupon Barcode
Itf14 | 36 | ITF-14 a.k.a. UPC Shipping Container Symbol ITF-14, ITF14, Case Code, UPC Case Code, EAN/UCC-14, EAN-14, UCC-14, DUN-14, GTIN-14
Scc14 | 37 | SCC-14 a.k.a. Shipping Container Code, EAN/UCC 14, DUN-14, EAN-14, UCC-14, UPC Case Code, UPC Shipping Container Code, Distribution Unit Number 14, SCC14, DUN14, EAN14, UCC14, EAN/UCC-14, Despatch Unit Number 14, GTIN-14
Issn | 38 | ISSN a.k.a. International Standard Serial Number, ISSN-13, ISSN-10, ISSN+5, ISSN+2, ISSN Supplement 5/Five-digit Add-On, ISSN Supplement 2/Two-digit Add-On
Ismn | 39 | ISMN a.k.a. International Standard Music Number, ISMN-13, ISMN-10, ISMN+5, ISMN+2, ISMN Supplement 5/Five-digit Add-On, ISMN Supplement 2/Two-digit Add-On, ISO 10957
NumlyNumber | 40 | Numly Number a.k.a. ESN, Electronic Serial Number, Electronic Standard Book Number, ESBN
QRCode | 41 | QR Code a.k.a. Quick Response Code, QRCode Model 2, JIS X 0510, ISO-IEC 18004
UspsFim | 42 | USPS FIM a.k.a. Facing Identification Marks, FIM A B C D
UspsHorizontalBars | 43 | USPS Horizontal Bars
Telepen | 44 | Telepen a.k.a. SB Telepen
Pharmacode | 45 | Pharmacode a.k.a. Pharmacode Laetus, Pharmaceutical Binary Code
Semacode | 46 | Semacode a.k.a. URL Barcode, Semacode Tag
Code32 | 47 | Code 32 a.k.a. Italian Pharmacode, IMH, Codice 32 Pharmacode, Codice Farmaceutico Italiano, Radix 32 Barcode
UspsPicUccEan128 | 48 | USPS PIC UCC/EAN-128 a.k.a. USPS Package Identification Code, USPS Confirmation Services Tracking Number Barcode
FedExGround96 | 49 | FedEx Ground 96 a.k.a. FedEx 96 Barcode, FedEx Ground 96 UCC/EAN-128, 96 Barcode
AztecCode | 50 | Aztec Code a.k.a. AIM Aztec Barcode, ANSI/AIM BC13 ITS/97/002
CompactPdf417 | 51 | Compact PDF417 a.k.a. Compact Portable Data File 417, Compact PDF 417, PDF417 Truncated
MacroPdf417 | 52 | Macro PDF417 a.k.a. Macro Portable Data File 417, Macro PDF 417, MacroPDF417
MicroPdf417 | 53 | Micro PDF417 a.k.a. Micro Portable Data File 417, Micro PDF 417, MicroPDF417
VicsBol | 54 | VICS BOL a.k.a. VICS Bill of Lading, Voluntary Interindustry Commerce Solutions Bill of Lading, BOL Barcode, 17-digit BOL, VICS standard Bill of Lading
VicsScacPro | 55 | VICS SCAC PRO a.k.a. VICS Bill of Lading SCAC PRO, Voluntary Interindustry Commerce Solutions Bill of Lading SCAC PRO, SCAC Barcode, PRO Barcode, VICS SCAC, VICS PRO, SCAC/Pro Barcode, Standard Carrier Alpha Code, Carrier SCAC Barcode
ItalianPost25 | 56 | Italian Post 25 a.k.a. Italian Post ITF 2/5, PosteItaliane Registered Mail Barcode, PosteItaliane ITF
Isbt128 | 57 | ISBT 128 a.k.a. ISBT Barcode, ISBT128, International Society of Blood Transfusion Barcode, ICCBBA 128, International Council for Commonality in Blood Banking Automation Barcode, Unique Donation Identification Barcode, American Association of Blood Banks AABB 128 Barcode, American Red Cross ARC Barcode
HibcLic39 | 58 | HIBC LIC 39 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 39, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcLic128 | 59 | HIBC LIC 128 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 128, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcPas39 | 60 | HIBC PAS 39 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 39, HIBC Health Care Services Provider Barcode
HibcPas128 | 61 | HIBC PAS 128 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 128, HIBC Health Care Services Provider Barcode
UspsIntelligentMail | 62 | USPS Intelligent Mail Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
EanUpcAddOn2 | 63 | EAN UPC Add On 2 a.k.a. EAN Supplement 2/Two-digit Add-On, EAN+2, UPC Supplement 2/Two-digit Add-On, UPC+2
EanUpcAddOn5 | 64 | EAN UPC Add On 5 a.k.a. EAN Supplement 5/Five-digit Add-On, EAN+5, UPC Supplement 5/Five-digit Add-On, UPC+5
UspsPicCode128 | 65 | USPS PIC Code 128 a.k.a. USPS Package Identification Code USS Code 128, USPS Confirmation Services Tracking Number Barcode USS Code 128
GS1DataBarOmnidirectional | 66 | GS1 DataBar Omnidirectional a.k.a. RSS14, Reduced Space Symbology 14
GS1DataBar14 | 67 | GS1 DataBar-14 a.k.a. GS1 DataBar Omnidirectional, RSS14, Reduced Space Symbology 14
Rss14 | 68 | RSS14 a.k.a. RSS 14, Reduced Space Symbology 14, GS1 DataBar Omnidirectional
GS1DataBarTruncated | 69 | GS1 DataBar Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated
GS1DataBar14Truncated | 70 | GS1 DataBar-14 Truncated a.k.a. GS1 DataBar Truncated, RSS 14 Truncated, Reduced Space Symbology 14 Truncated
Rss14Truncated | 71 | RSS14 Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated, GS1 DataBar Truncated
GS1DataBarStacked | 72 | GS1 DataBar Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar 14 Stacked
GS1DataBar14Stacked | 73 | GS1 DataBar-14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
Rss14Stacked | 74 | RSS14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
GS1DataBarStackedOmnidirectional | 75 | GS1 DataBar Stacked Omnidirectional a.k.a. GS1 DataBar-14 Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
GS1DataBar14StackedOmnidirectional | 76 | GS1 DataBar-14 Stacked Omnidirectional a.k.a. GS1 DataBar Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
Rss14StackedOmnidirectional | 77 | RSS14 Stacked Omnidirectional a.k.a. RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional, GS1 DataBar-14 Stacked Omnidirectional, GS1 DataBar Stacked Omnidirectional
GS1DataBarLimited | 78 | GS1 DataBar Limited a.k.a. GS1 DataBar-14 Limited, RSS Limited, Reduced Space Symbology Limited
RssLimited | 80 | RSS Limited a.k.a. Reduced Space Symbology Limited, GS1 DataBar-14 Limited, GS1 DataBar Limited
GS1DataBarExpanded | 81 | GS1 DataBar Expanded a.k.a. RSS Expanded, Reduced Space Symbology Expanded
RssExpanded | 82 | RSS Expanded a.k.a. GS1 DataBar Expanded, Reduced Space Symbology Expanded
GS1DataBarExpandedStacked | 83 | GS1 DataBar Expanded Stacked a.k.a. RSS Expanded Stacked, Reduced Space Symbology Expanded Stacked
RssExpandedStacked | 84 | RSS Expanded Stacked a.k.a. GS1 DataBar Expanded Stacked, Reduced Space Symbology Expanded Stacked
GS1128 | 85 | GS1-128 a.k.a. UCC/EAN-128, EAN-128, UCC-128, USS-128, UCC.EAN-128, GTIN-128
MaxiCode | 86 | MaxiCode a.k.a. UPS MaxiCode, Maxi Code, United Parcel Service MaxiCode
MicroQRCode | 87 | Micro QR Code a.k.a. Micro Quick Response Code, Micro QRCode Model 2
Matrix2of5 | 88 | Matrix 2 of 5 a.k.a. 2 of 5 Matrix, 2/5 Matrix
DanishPostal39 | 89 | Danish Postal 39 a.k.a. Danish PTT 39, Post Danmark A/S Barcode, Post Danmark Parcel Barcode
FrenchPostal39AR | 90 | French Postal 39 A/R a.k.a. French Postal A/R 39, La Poste A/R 39
IATA2of5 | 91 | IATA 2 of 5 a.k.a. International Air Transport Assosiation 2 of 5
AustraliaPostDomesticEParcelBarcode | 92 | Australia Post Domestic eParcel Barcode ak.a. Australia Post Domestic eParcel Article Barcode
UspsIntelligentMailContainerBarcode | 93 | USPS Intelligent Mail Container Barcode a.k.a. USPS IM Container Barcode, IM Container Barcode
KodakPatchCode | 94 | Kodak Patch Code
GS1DataMatrix | 95 | GS1 DataMatrix a.k.a. GS1 Data Matrix ECC200
Ean13CCA | 96 | EAN-13 CC-A a.k.a. European Article Number 13 with CC-A
Ean13CCB | 97 | EAN-13 CC-B a.k.a. European Article Number 13 with CC-B
Ean8CCA | 98 | EAN-8 CC-A a.k.a. European Article Number 8 with CC-A
Ean8CCB | 99 | EAN-8 CC-B a.k.a. European Article Number 8 with CC-B
UpcACCA | 100 | UPC-A CC-A a.k.a. Universal Product Code version A with CC-A
UpcACCB | 101 | UPC-A CC-B a.k.a. Universal Product Code version A with CC-B
UpcECCA | 102 | UPC-E CC-A a.k.a. Universal Product Code version E with CC-A
UpcECCB | 103 | UPC-E CC-B a.k.a. Universal Product Code version E with CC-B
UccEan128CCA | 104 | UCC/EAN-128 CC-A a.k.a. GS1-128 with CC-A
UccEan128CCB | 105 | UCC/EAN-128 CC-B a.k.a. GS1-128 with CC-B
UccEan128CCC | 106 | UCC/EAN-128 CC-C a.k.a. GS1-128 with CC-C
GS1128CCA | 107 | GS1-128 CC-A a.k.a. UCC/EAN-128 with CC-A
GS1128CCB | 108 | GS1-128 CC-B a.k.a. UCC/EAN-128 with CC-B
GS1128CCC | 109 | GS1-128 CC-C a.k.a. UCC/EAN-128 with CC-C
GS1DataBarOmnidirectionalCCA | 110 | GS1 DataBar Omnidirectional with CC-A a.k.a. RSS14 CC-A
GS1DataBar14CCA | 111 | GS1 DataBar-14 with CC-A a.k.a. RSS14 with CC-A
Rss14CCA | 112 | RSS14 CC-A
GS1DataBarOmnidirectionalCCB | 113 | GS1 DataBar Omnidirectional with CC-B a.k.a. RSS14 CC-B
GS1DataBar14CCB | 114 | GS1 DataBar-14 with CC-B a.k.a. RSS14 with CC-B
Rss14CCB | 115 | RSS14 CC-B
GS1DataBarTruncatedCCA | 116 | GS1 DataBar Truncated CC-A a.k.a. RSS 14 Truncated CC-A
GS1DataBar14TruncatedCCA | 117 | GS1 DataBar-14 Truncated CC-A a.k.a. RSS 14 Truncated CC-A
Rss14TruncatedCCA | 118 | RSS14 Truncated CC-A
GS1DataBarTruncatedCCB | 119 | GS1 DataBar Truncated CC-B a.k.a. RSS 14 Truncated CC-B
GS1DataBar14TruncatedCCB | 120 | GS1 DataBar-14 Truncated CC-B a.k.a. RSS 14 Truncated CC-B
Rss14TruncatedCCB | 121 | RSS14 Truncated CC-B
GS1DataBarLimitedCCA | 122 | GS1 DataBar Limited CC-A a.k.a. RSS Limited CC-A
RssLimitedCCA | 123 | RSS Limited CC-A
GS1DataBarLimitedCCB | 124 | GS1 DataBar Limited CC-B a.k.a. RSS Limited CC-B
RssLimitedCCB | 125 | RSS Limited CC-B
GS1DataBarStackedCCA | 126 | GS1 DataBar Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBar14StackedCCA | 127 | GS1 DataBar-14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
Rss14StackedCCA | 128 | RSS14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBarStackedCCB | 129 | GS1 DataBar Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBar14StackedCCB | 130 | GS1 DataBar-14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
Rss14StackedCCB | 131 | RSS14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBarStackedOmnidirectionalCCA | 132 | GS1 DataBar Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
GS1DataBar14StackedOmnidirectionalCCA | 133 | GS1 DataBar-14 Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
Rss14StackedOmnidirectionalCCA | 134 | RSS14 Stacked Omnidirectional CC-A
GS1DataBarStackedOmnidirectionalCCB | 135 | GS1 DataBar Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
GS1DataBar14StackedOmnidirectionalCCB | 136 | GS1 DataBar-14 Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
Rss14StackedOmnidirectionalCCB | 137 | RSS14 Stacked Omnidirectional CC-B
GS1DataBarExpandedCCA | 138 | GS1 DataBar Expanded CC-A a.k.a. RSS Expanded CC-A
RssExpandedCCA | 139 | RSS Expanded CC-A
GS1DataBarExpandedCCB | 140 | GS1 DataBar Expanded CC-B a.k.a. RSS Expanded CC-B
RssExpandedCCB | 141 | RSS Expanded CC-B
GS1DataBarExpandedStackedCCA | 142 | GS1 DataBar Expanded Stacked CC-A a.k.a. RSS Expanded Stacked CC-A
RssExpandedStackedCCA | 143 | RSS Expanded Stacked CC-A
GS1DataBarExpandedStackedCCB | 144 | GS1 DataBar Expanded Stacked CC-B a.k.a. RSS Expanded Stacked CC-B
RssExpandedStackedCCB | 145 | RSS Expanded Stacked CC-B
MICRE13B | 146 | MICR E13-B a.k.a. E-13-B, MICR E13B

See Also

Neodynamic.WinRT Namespace


TelepenEncoding Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
TelepenEncoding Enumeration
See Also Send Feedback
Specifies the Telepen Encoding to use on that symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum TelepenEncoding
Visual Basic
Public Enumeration TelepenEncoding
Visual C++
public enum class TelepenEncoding

Members

Member name | Value | Description
Ascii | 0 | Used to encode the full range of ASCII characters
Numeric | 1 | Used to encode pairs of numeric characters in double-density mode.

See Also

Neodynamic.WinRT Namespace


UpcE Enumeration

[image]

Neodynamic Barcode Professional for XAML WinRT Class Reference
UpcE Enumeration
See Also Send Feedback
Specifies the number system to use for UPC-E symbology.

Namespace: Neodynamic.WinRT
Assembly: Neodynamic.WinRT.Barcode (in Neodynamic.WinRT.Barcode.dll) Version: 1.0.4500.0 (1.0.4500.0)

Syntax

C#
public enum UpcE
Visual Basic
Public Enumeration UpcE
Visual C++
public enum class UpcE

Members

Member name | Value | Description
System0 | 0 |
System1 | 1 |

See Also

Neodynamic.WinRT Namespace


Technical Support

Neodynamic Barcode Professional for XAML WinRT
Neodynamic Technical Support
Get first-class support from real Exprets in barcoding field. When you purchase a licensed version of Neodynamic Barcode Professional for XAML WinRT you get access to FREE technical support.
Technical Support can be reached by email at support@neodynamic.com.

Before contacting technical support we recommend:
  • Read the product documentation.
  • Read FAQ at Neodynamic Website.
For more information about technical support visit www.neodynamic.com/support.

Visit Neodynamic's website.
Neodynamic Barcode Professional for XAML WinRT Documentation
Copyright © 2003 - 2012 Neodynamic - All rights reserved.


Australia Post 4-state Barcode

This Symbology is also known as Australian 4-state postal barcode, Australia Post Customer Barcode

Overview
This Symbology is used by Australia Post for Postal code and automatic mail sorting. Australia Post has chosen the 4-State Barcode, a derivation that is already used successfully by other postal administrations. It comprises four types of bars (the four states), each of which has a distinct name, value and barcode symbol.

4-State Barcode Bars

Sample of an Australia Post 4-State Barcode
This Symbology comes in several versions:
Short Name | Proper Name | FCC code | Structure (# bars)
37-CUST | "Standard Customer Barcode" ("Customer Barcode 1") | FCC = 11 | DPID (16)
37-REPL | "Reply Paid Barcode" | FCC = 45 | dto.
37-ROUT | "Routing Barcode" | FCC = 87 | dto.
37-REDI | "Redirection Barcode" | FCC = 92 | dto.
52-FF-MET | "Customer Barcode 2" | FCC = 59 | DPID (16) + CustInfo (16)
67-FF-MET | "Customer Barcode 3" | FCC = 62 | DPID (16) + CustInfo (31)
67-FF-MAN | (reserved) | FCC = 44 | dto.
Notes
  • The first number indicates the total number of bars in the barcode.
  • FCC stands for "Format Control Code".
  • DPID stands for "Delivery Point Identifier" (also named as "Sorting Code") which identifies destination of a piece of mail = 16 bars = 8 digits (using the N table).
  • CustInfo stands for "Customer Info". Free-format customer-specific data area, may contain any information not interpreted by Australia Post = 16 or 31 bars. If it is numeric only, it can be encoded using the N table, thus accommodating 8 or 15 digits. Otherwise the C table has to be used, thus accommodating 5 or 10 chars. However, Barcode Professional implementation is based on C encoding table only.
The value to encode has the following structure:
  • 2 digits for Format Control Code (FCC) which only valid values are: 11, 87, 45, 92, 59, 62, or 44 (See table above for more information about each FCC)
  • 8 digits for Sorting Code or Delivery Point Identifier (DPID)
  • Alpha numeric characters (free format) for Customer Information Field (only available for FCC equals to 59, 62, or 44)
    • For FCC equals to 59, this field is limited to 5 characters
    • For FCC equals to 62 or 44, this field is limited to 10 characters
  • Reed Solomon Error Correction
Barcode Professional implements C Encoding Table which allows you to encode Customer Information consisting of:
  • Uppercase characters, from A to Z
  • Lower case characters, from a to z
  • Space and # characters
  • Digits 0 to 9

How to create Australia Post 4-state barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Australia Post 4-State barcode image, please follow these steps:
  • Set the Symbology property to AustraliaPost
  • Setting up dimensions and quiet zones:
    • Set the Postal4StateTrackerBarWidth property to a value ranging from 0.016 to 0.024 (Values are expressed in Inches)
    • Set the Postal4StateTrackerBarHeight property to a value ranging from 0.039 to 0.063 (Values are expressed in Inches)
    • Set the Postal4StateBarsSpacing property to a value ranging from 0.016 to 0.028 (Values are expressed in Inches)
    • Set the QuietZone property to 0.24, 0.08, 0.24, 0.08 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Setting up the value to encode:
    • Set the Code property to a value with the following structure:
      • 2 digits for Format Control Code (FCC) which only valid values are 11, 87, 45, 92, 59, 62, or 44
      • 8 digits for Sorting Code or Delivery Point Identifier (DPID)
      • (Optional) Alpha numeric characters (free format) for Customer Information Field (only available for FCC equals to 59, 62, or 44)
        • For FCC equals to 59, this field is limited to 5 characters
        • For FCC equals to 62 or 44, this field is limited to 10 characters
    • Examples of values that can be set to the Code property based on the stated in the previous point:
      • 1139987520
      • 1167671415
      • 5932211324A124B
      • 5977665544C A P
      • 5956439111ABA 9
      • 6282224535555439
      • 6279438541AaaB 155
      • 6243289421CAM Num 20
    • Reed Solomon Error Correction is automatically calculated and appended by Barcode Professional.
      • Tip: You can rid of the Reed Solomon values from the Human Readable text by setting up to False the DisplayChecksum property.
  • Set the CodeAlignment property to AboveLeft
  • Set the Text property to an Empty string
Australia Post 4-State barcode images generated based on some values of point 3
Code property = 1139987520 will produce the following barcode image:
Code property = 5956439111ABA 9 will produce the following barcode image:
Code property = 6243289421CAM Num 20 will produce the following barcode image:


Australia Post Domestic eParcel Barcode

This Symbology is also known as Australia Post Domestic eParcel Article Barcode

Overview
Australia Post uses Domestic eParcel barcode for tracking consignments which are defined as a number or articles of the same product/service type, consigned to the same delivery address, and lodged at the same time. The Australia Post Domestic eParcel Barcode features the following format or structure:
  • Australia Post ID / RSD Trigger: 3-digit which must be always "997"
  • RSD Application ID: 3-digit, "016" for eParcel Post returns or "001" for all other services
  • Product Code: 2-digit numeric ID that defines the eParcel sub-product type. This should be associated with the appropriate Charge code.
  • Eye-readable Article No. (16-chars):
    • Merchant Location ID: 3-alphanumeric identifier provided by Australia Post to uniquely identify a lodgement location. A single customer may have multiple location IDs
    • Consignment Suffix: 7-digit ID which is provided by the customer. Allows a possible 10000000 cons. per Merchant Location before reuse of numbers is required
    • Article Suffix: 2-digit Position of article in consignment (eg. 01 is the first article, 02 the second etc. up to 20)
    • Service Code: 2-digit numeric ID that defines any special delivery conditions: "Signature compulsory", "Partial delivery allowed", "Cash To Collect" or "Call For Returns"
    • Last Article Indicator: 1-digit which indicates whether the article is the last of an eParcel consignment or not. Used by the scanner software to support the Consignment Management process: 1 = Not the last article in a multi-parcels con, 2 = Single consignment or last article in a multi-parcels consignment
    • Human readable check digit: 1-digit which is used to verify the validity of the eye-readable Article ID. Neodynamic provides Barcode Utilities for calculating this value.
  • Available character: 1-digit which must be always "0"
  • Destination postcode: 4-digit as defined in the delivery address. Used for automated sorting of parcels

Sample of an Australia Post Domestic eParcel Barcode

How to create Australia Post Domestic eParcel barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Australia Post Domestic eParcel barcode image, please follow these steps:
  • Set the Symbology property to AustraliaPostDomesticEParcelBarcode
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.014 (Values are expressed in Inches)
    • Set the BarHeight property to 0.63 (Values are expressed in Inches)
    • Set the Code property with the value to encode as aforementioned detailed and described.

Example of an Australia Post Domestic eParcel barcode image

Code property = 99700160DJS123456701021502000 will produce the following barcode image:


Codabar Barcode

This Symbology is also known as ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar

Overview
Codabar was developed in 1972 by Pitney Bowes, Inc. It is a discrete, self-checking symbology that may encode 16 different characters, plus an additional four start/stop characters.
This symbology is used by U.S. blood banks, photo labs, and on FedEx airbills. Since Codabar is self-checking, there is no established checksum digit. This symbology starts and finishes with one of four possible characters A, B, C, or D.

Sample of a Codabar Barcode

How to create Codabar barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Codabar barcode image, please follow these steps:
  • Set the Symbology property to Codabar
  • Set the AddChecksum property to False
  • Set the CodabarStartChar and CodabarStopChar properties
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
  • Codabar utilizes A, B, C, or D characters as Start & Stop symbols and they are shown in the human readable text of a barcode image. You can rid of those characters from the human readable text by setting up the DisplayStartStopChar property to False
Example of Codabar barcode images
Code property = 2030405060, CodabarStartChar property = B and CodabarStopChar property = D will produce the following barcode image:


Code 11 Barcode

This Symbology is also known as Code11, USD-8, USD8

Overview
Code 11 was developed as a high-density numeric-only symbology. The symbology is discrete and is able to encode the numbers 0 through 9, the dash symbol (-), and start/stop characters.
It is used primarily in labeling telecommunications equipment.
Code 11 is not terribly secure in that printing imperfections can quite easily convert one character into another valid character. Data integrity is obtained by using one, or sometimes two, check characters.

Sample of a Code 11 Barcode

How to create Code 11 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 11 barcode image, please follow these steps:
  • Set the Symbology property to Code11
  • Set the AddChecksum property to True
    • Tip: You can rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It can be numbers 0 through 9 and the dash symbol (-)
Example of Code 11 barcode images
Code property = 12345-67890 will produce the following barcode image:


Code 16K Barcode

This Symbology is also known as Code16K

Overview
Code 16K was developed by Ted Williams in 1989 to provide a simple to print and decode multiple row symbology. Williams also developed Code 128, and the structure of 16K is based on Code 128. The code is a continuous, variable-length symbology that can encode the complete ASCII 128-character set. It is mainly used in the health care industry.
This symbology has six modes 0 through 5, but Barcode Professional products only supports the Modes 0, 1, and 2.

Sample of a Code 16K Barcode

How to create Code 16K barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 16K barcode image, please follow these steps:
  • Set the Symbology property to Code16k
  • Set the Code16kMode to one of the following values depending on your needs:
    • Mode0: Barcode Professional will use the Code 128 Char Set A which only supports ASCII values from 0 to 95
    • Mode1: Barcode Professional will use the Code 128 Char Set B which only supports ASCII values from 32 to 127
    • Mode2: Barcode Professional will use the Code 128 Char Set C which only supports pairs of digits
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.
Example of a Code 16K barcode image
Code property = ABC 123456789 and Code16kMode property = Mode0 will produce the following barcode image:


Code 32 Barcode

Also known as Italian Pharmacode, IMH, Codice 32 Pharmacode, Codice Farmaceutico Italiano, Radix 32 Barcode

Overview
Code 32 is mainly used to encode pharmaceutical products in Italy. Code 32 is used to encode Italian Pharmacode which has the following structure:
  • 'A' character (ASCII 65) which is not really encoded
  • 8 digits for Pharmacode (It generally begins/is prefixed with 0 - zero)
  • 1 digit for Checksum module 10 which is automatically calculated by Barcode Professional
The value to encode passed to Barcode Professional must be 8 digits pharmacode only (prefix it with 0 zero if necessary) because the 9th digit (the checksum) is automatically calculated by Barcode Professional products.

Sample of a Code 32 barcode

How to create Code 32 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Code 32 barcode image, please follow these steps:
  • Set the Symbology property to Code32
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 8 digits pharmacode only (prefix it with 0 zero if necessary). The 9th digit (checksum) is automatically calculated and appended by Barcode Professional

Example of Code 32 barcode images

Code property = 01234567 will produce the following barcode image:

Example of Code 32 barcode images


Danish Postal 39 Barcode

This Symbology is also known as Danish PTT 39, Post Danmark A/S Barcode, Post Danmark Parcel Barcode

Overview
Danish Postal 39 is used by Danish Postal Service (Post Danmark A/S) for tracking Domestic and International Parcels. It based on Code 39 barcode symbology. Domestic barcodes normally consist of 11 digits followed by the letters DK, e.g. 12345678912DK while International barcodes are always preceded by the letters CC. The data content of the Danish Postal 39 barcode is 10-digit number or two-letters (CC, CK, CO, or CU) + 8-digit number; all followed by a 1-digit checksum which is automatically calculated and encoded by Barcode Professional.

Sample of a Danish Postal 39 Barcode

How to create Danish Postal 39 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Danish Postal 39 barcode image, please follow these steps:
  • Set the Symbology property to DanishPostal39
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode which must be a 10-digit number or two-letters (CC, CK, CO, or CU) + 8-digit number
Example of Danish Postal 39 barcode images
Code property = 1234567890 will produce the following barcode image:


Deutsche Post Identcode Barcode

This Symbology is also known as German Postal 2 of 5 Identcode, Deutsche Post AG Identcode, Deutsche Frachtpost Identcode, Identcode, CodeIdentcode, Deutsche Post AG (DHL)

Overview
Identcode barcode Symbology is used by German Post (Deutsche Post AG) (Deutsche Frachtpost).
The Identcode contains a tracking number providing an identification of the customer (sender) and the mail piece.
The value to encode length is fixed to 11 digits plus 1 digit checksum which is automatically calculated by Barcode Professional products. The value to encode must have the following structure:
  • 2 digits for ID of primary distribution center
  • 3 digits for Customer ID
  • 6 digits for Mailing number

Sample of a Deutsche Post Identcode Barcode

How to create Deutsche Post Identcode barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Deutsche Post Identcode barcode image, please follow these steps:
  • Set the Symbology property to DeutschePostIdentcode
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 11 digits:
    • 2 digits for ID of primary distribution center
    • 3 digits for Customer ID
    • 6 digits for Mailing number
Example of Deutsche Post Identcode barcode images
Code property = 56400000005 will produce the following barcode image:


Deutsche Post Leitcode Barcode

This Symbology is also known as German Postal 2 of 5 Leitcode, CodeLeitcode, Leitcode, Deutsche Post AG (DHL)

Overview
Leitcode barcode Symbology is used by German Post (Deutsche Post AG) (Deutsche Frachtpost). The Leitcode gives an indication of the destination.
The value to encode length is fixed to 13 digits plus 1 digit checksum which is automatically calculated by Barcode Professional products. The value to encode must have the following structure:
  • 5 digits for Postal code (Postleitzahl, PLZ)
  • 3 digits for Street ID/number
  • 3 digits for House number
  • 2 digits for Product code

Sample of a Deutsche Post Leitcode Barcode

How to create Deutsche Post Leitcode barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Deutsche Post Leitcode barcode image, please follow these steps:
  • Set the Symbology property to DeutschePostLeitcode
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 13 digits:
    • 5 digits for Postal code (Postleitzahl, PLZ)
    • 3 digits for Street ID/number
    • 3 digits for House number
    • 2 digits for Product code
Example of Deutsche Post Leitcode barcode images
Code property = 8173908300200 will produce the following barcode image:


FedEx Ground "96" Barcode

Also known as FedEx 96 Barcode, FedEx Ground "96" UCC/EAN-128, "96" Barcode

Overview
The primary bar code used as part of the FedEx Ground bar code strategy is a UCC/EAN Code 128 symbol. It is referred to as the "96" bar code because it always begins with a "96". The data content of the FedEx Ground "96" UCC/EAN Code 128 barcode is as specified below:
  • Application Identifier (AI): 2-digit number that identifies the barcode as a shipping label. In this case the Application Identifier is "96".
  • Serial Container Numeric Code (SCNC): 2-digit (11, 12, 13) that identifies the carrier as "FedEx Ground".
  • Class of Service: 3-digit number used to identify the FedEx Ground class of service.
  • FedEx Ground Shipper ID: 7-digit unique shipper identification number.
  • Package Number: 7-digit package serial number.
  • Modulus 10 Check digit: It is a digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed.

Sample of a FedEx Ground 96 Barcode

How to create FedEx Ground 96 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a FedEx Ground 96 barcode image, please follow these steps:
  • Set the Symbology property to FedExGround96
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.017 to 0.019 (Values are expressed in Inches)
    • Set the BarHeight property (Values are expressed in Inches)
    • Set the QuietZone property to a value 10 times the BarWidth value for left and right zones and 0.1 for top and bottom zones (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must begin with "96" followed by 19 or 20 digits

Example of FedEx Ground 96 barcode images

Code property = 9611804027471600040302 will produce the following barcode image:


French Postal 39 A/R Barcode

This Symbology is also known as French Postal A/R 39, La Poste A/R 39

Overview
French Postal 39 A/R is used by French Postal Service (La Poste) on registered letter forms ("Recommandé"). It based on Code 39 barcode symbology. The data content of the French Postal 39 A/R barcode is two-letters (RA or RB) + 8-digit number; all followed by a 1-digit checksum which is automatically calculated and encoded by Barcode Professional.

Sample of a French Postal 39 A/R Barcode

How to create French Postal 39 A/R barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a French Postal 39 A/R barcode image, please follow these steps:
  • Set the Symbology property to FrenchPostal39AR
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode which must be two-letters (RA or RB) + 8-digit number
Example of French Postal 39 A/R barcode images
Code property = RA12345678 will produce the following barcode image:


HIBC LIC 39 Barcode

This Symbology is also known as HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 39, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode

Overview
The HIBC LIC is used by Labelers (manufacturers) of health care products for identification purpose. Labelers can encode which is called "Primary Data" and "Secondary Data". In short, Primary Data identifies the labeler, the product code, and the unit of measure while Secondary Data is useful to distributors and providers and, at the discretion of the labeler, should be added. The Secondary Data is optional and is used in conjunction with Primary Data elements to encode quantity and/or expiration (expiry) date and/or Lot/Batch/Serial Number.

The HIBC LIC Primary and Secondary Data Structures are represented by a variant of Code 39 barcode.
HIBC LIC Primary Data Structure
The HIBC LIC Primary Data Structure format encodes:
  • "+" sign identifier of the HIBC Supplier Data Structure
  • 4 character Labeler Identification Code (LIC)
  • 1 to 13 character Product or Catalog Number (PCN)
  • 1-digit Unit of Measure Identifier (U/M)
  • a Checksum which is automatically calculated by Barcode Professional.
HIBC LIC Secondary Data Structure
The HIBC LIC secondary Data Structure format encodes:
  • "+" sign identifier of the HIBC Supplier Data Structure
  • Variable-length characters for Quantity/Date Fields
  • 0 to 13 characters for Lot/Batch/Serial Number Field
  • 1 character for Link Character (which is the Checksum from Primary Data Structure)
  • a Checksum which is automatically calculated by Barcode Professional.
Combining Primary and Secondary Codes in One Symbol
Labelers can encode in one only symbol both the Primary and Secondary Data by using the HIBC LIC Concatenation Format. In this case, a slash (/) is used as a delimiter between the Primary and Secondary Data. In addition, the Primary Data Link Character, the plus (+) at the start of the Secondary Data, and the Secondary Data Link Character are omitted. Only one Checksum at the end of the symbol is used which will verify the entire symbol.

Sample of a HIBC LIC 39 Barcode for Primary Data Structure

How to create HIBC LIC 39 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a HIBC LIC 39 barcode image, please follow these steps:
  • Set the Symbology property to HibcLic39
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property as required (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property to 0.1 (Value is expressed in Inches)
  • Set the Code property with the value to encode. Learn the different data encodings by referring to:
    • How to encode Primary Data
    • How to encode Secondary Data
    • How to encode Primary and Secondary Data in One Symbol
  • Set the HibcFormatHumanReadableText property. If true (default value), then Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
How to encode Primary Data
You can encode Primary Data Structure by just passing to Barcode Professional the Universal Product Number (UPN). UPN is composed of LIC + PCN + UM.
  • LIC is the Labeler Identification Code which is assigned by HIBCC. It identifies the labeler and begins with a letter, followed by 3 alphanumeric characters.
  • PCN is the Product/Catalogue Number which is assigned by the labeler. It identifies the item/drug/device and is made of 1 to 13 alphanumeric characters.
  • UM is the Unit of Measure which is assigned by the labeler. It is 1-digit and identifies the packaging configuration level of the item; e.g. Unit-Dose, Carton, Case, Master-Case, Pallet, etc.
Example of encoding Primary Data
How to encode Secondary Data
Barcode Professional provides an easy data format for encoding Secondary Data Structure. The Secondary Data fields Quantity, Date, and Lot/Batch/Serial Number are separated by # (Cross hatch or number sign) and you can optionally instruct to Barcode Professional for computing the "Link Character" by placing the "Primary Data" between parentheses at the end of the value to encode as is shown below.
QUANTITY#DATE#LOT_BATCH_SERIAL_NUM(PRIMARY_DATA)
Where:
  • QUANTITY is the quantity field. You must specify one of the following valid values for this field:
    • 0 (zero) if Quantity Field is NOT required
    • 2-digit for Quantity
    • 5-digit for Quantity
  • DATE is the expiration date field. You must specify one of the following valid values for this field:
    • 0 (zero) if Date Field is NOT required
    • 4-digit if using MMYY (month/year) Date format
    • Number 2 (two) followed by 6-digit if using MMDDYY (month/day/year) Date format
    • Number 3 (three) followed by 6-digit if using YYMMDD (year/month/day) Date format
    • Number 4 (four) followed by 8-digit if using YYMMDDHH (year/month/day/hour G.M.T.) Date format
    • Number 5 (five) followed by 5-digit if using YYJJJ (year/Julian day) Date format
    • Number 6 (six) followed by 7-digit if using YYJJJHH (year/Julian day/hour G.M.T.) Date format
    • Number 7 (seven) for Date Field is NULL
  • LOT_BATCH_SERIAL_NUM is the Lot/Batch/Serial Number field. You must specify one of the following valid values for this field:
    • - (Hyphen, dash, or minus sign) for Lot/Batch/Serial Number Field is NOT required
    • 1 to 13 alphanumeric characters (A-Z and 0-9)
  • (PRIMARY_DATA) is the Primary Data content which must be placed between parentheses if you want the "Link Character" to be computed by Barcode Professional. NOTE: This element is optional.
Example of encoding Secondary Data
How to encode Primary and Secondary Data in One Symbol
For encoding Primary and Secondary Data in one symbol, the following format must be used:
UPN/QUANTITY#DATE#LOT_BATCH_SERIAL_NUM
The / (slash) character is used as separator between both data structures and UPN, QUANTITY, DATE, and LOT_BATCH_SERIAL_NUM have the aforementioned meanings.
Example of encoding Primary and Secondary Data in One Symbol
Example of HIBC LIC 39 barcodes
  • Primary Data Example: Encoding LIC = A123, PCN = PROD7890, and UM = 5. Based on that info, then UPN = A123PROD78905

    Code property = A123PROD78905 will produce the following barcode image:

  • Secondary Data Example: Encoding Quantity = 10, Date = 12/15/94 23:00 G.M.T. (YYMMDDHH Date Format so Number 4 will be the prefix), and Lot = SN654. Primary Data for Link Character calculation = A123PROD78905.

    Code property = 10#494121523#SN654(A123PROD78905) will produce the following barcode image:

  • Primary and Secondary Data in One Symbol Example: Encoding for Primary Data LIC = A123, PCN = PROD7890, and UM = 5 i.e. UPN = A123PROD78905. For Secondary Data Quantity = 10, Date = 12/15/94 23:00 G.M.T. (YYMMDDHH Date Format so Number 4 will be the prefix), and Lot = SN654.

    Code property = A123PROD78905/10#494121523#SN654 will produce the following barcode image:


HIBC LIC 128 Barcode

This Symbology is also known as HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 128, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode.

Overview
The HIBC LIC is used by Labelers (manufacturers) of health care products for identification purpose. Labelers can encode which is called "Primary Data" and "Secondary Data". In short, Primary Data identifies the labeler, the product code, and the unit of measure while Secondary Data is useful to distributors and providers and, at the discretion of the labeler, should be added. The Secondary Data is optional and is used in conjunction with Primary Data elements to encode quantity and/or expiration (expiry) date and/or Lot/Batch/Serial Number.

The HIBC LIC Primary and Secondary Data Structures are represented by a variant of Code 128 barcode.
HIBC LIC Primary Data Structure
The HIBC LIC Primary Data Structure format encodes:
  • "+" sign identifier of the HIBC Supplier Data Structure
  • 4 character Labeler Identification Code (LIC)
  • 1 to 13 character Product or Catalog Number (PCN)
  • 1-digit Unit of Measure Identifier (U/M)
  • a Checksum which is automatically calculated by Barcode Professional.
HIBC LIC Secondary Data Structure
The HIBC LIC secondary Data Structure format encodes:
  • "+" sign identifier of the HIBC Supplier Data Structure
  • Variable-length characters for Quantity/Date Fields
  • 0 to 13 characters for Lot/Batch/Serial Number Field
  • 1 character for Link Character (which is the Checksum from Primary Data Structure)
  • a Checksum which is automatically calculated by Barcode Professional.
Combining Primary and Secondary Codes in One Symbol
Labelers can encode in one only symbol both the Primary and Secondary Data by using the HIBC LIC Concatenation Format. In this case, a slash (/) is used as a delimiter between the Primary and Secondary Data. In addition, the Primary Data Link Character, the plus (+) at the start of the Secondary Data, and the Secondary Data Link Character are omitted. Only one Checksum at the end of the symbol is used which will verify the entire symbol.

Sample of a HIBC LIC 128 Barcode for Primary Data Structure

How to create HIBC LIC 128 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a HIBC LIC 128 barcode image, please follow these steps:
  • Set the Symbology property to HibcLic128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property as required (Values are expressed in Inches)
    • Set the QuietZone property to 0.1 (Value is expressed in Inches)
  • Set the Code property with the value to encode. Learn the different data encodings by referring to:
    • How to encode Primary Data
    • How to encode Secondary Data
    • How to encode Primary and Secondary Data in One Symbol
  • Set the HibcFormatHumanReadableText property. If true (default value), then Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
How to encode Primary Data
You can encode Primary Data Structure by just passing to Barcode Professional the Universal Product Number (UPN). UPN is composed of LIC + PCN + UM.
  • LIC is the Labeler Identification Code which is assigned by HIBCC. It identifies the labeler and begins with a letter, followed by 3 alphanumeric characters.
  • PCN is the Product/Catalogue Number which is assigned by the labeler. It identifies the item/drug/device and is made of 1 to 13 alphanumeric characters.
  • UM is the Unit of Measure which is assigned by the labeler. It is 1-digit and identifies the packaging configuration level of the item; e.g. Unit-Dose, Carton, Case, Master-Case, Pallet, etc.
Example of encoding Primary Data
How to encode Secondary Data
Barcode Professional provides an easy data format for encoding Secondary Data Structure. The Secondary Data fields Quantity, Date, and Lot/Batch/Serial Number are separated by # (Cross hatch or number sign) and you can optionally instruct to Barcode Professional for computing the "Link Character" by placing the "Primary Data" between parentheses at the end of the value to encode as is shown below.
QUANTITY#DATE#LOT_BATCH_SERIAL_NUM(PRIMARY_DATA)
Where:
  • QUANTITY is the quantity field. You must specify one of the following valid values for this field:
    • 0 (zero) if Quantity Field is NOT required
    • 2-digit for Quantity
    • 5-digit for Quantity
  • DATE is the expiration date field. You must specify one of the following valid values for this field:
    • 0 (zero) if Date Field is NOT required
    • 4-digit if using MMYY (month/year) Date format
    • Number 2 (two) followed by 6-digit if using MMDDYY (month/day/year) Date format
    • Number 3 (three) followed by 6-digit if using YYMMDD (year/month/day) Date format
    • Number 4 (four) followed by 8-digit if using YYMMDDHH (year/month/day/hour G.M.T.) Date format
    • Number 5 (five) followed by 5-digit if using YYJJJ (year/Julian day) Date format
    • Number 6 (six) followed by 7-digit if using YYJJJHH (year/Julian day/hour G.M.T.) Date format
    • Number 7 (seven) for Date Field is NULL
  • LOT_BATCH_SERIAL_NUM is the Lot/Batch/Serial Number field. You must specify one of the following valid values for this field:
    • - (Hyphen, dash, or minus sign) for Lot/Batch/Serial Number Field is NOT required
    • 1 to 13 alphanumeric characters (A-Z and 0-9)
  • (PRIMARY_DATA) is the Primary Data content which must be placed between parentheses if you want the "Link Character" to be computed by Barcode Professional. NOTE: This element is optional.
Example of encoding Secondary Data
How to encode Primary and Secondary Data in One Symbol
For encoding Primary and Secondary Data in one symbol, the following format must be used:
UPN/QUANTITY#DATE#LOT_BATCH_SERIAL_NUM
The / (slash) character is used as separator between both data structures and UPN, QUANTITY, DATE, and LOT_BATCH_SERIAL_NUM have the aforementioned meanings.
Example of encoding Primary and Secondary Data in One Symbol
Example of HIBC LIC 128 barcodes
  • Primary Data Example: Encoding LIC = A123, PCN = PROD7890, and UM = 5. Based on that info, then UPN = A123PROD78905

    Code property = A123PROD78905 will produce the following barcode image:

  • Secondary Data Example: Encoding Quantity = 10, Date = 12/15/94 23:00 G.M.T. (YYMMDDHH Date Format so Number 4 will be the prefix), and Lot = SN654. Primary Data for Link Character calculation = A123PROD78905.

    Code property = 10#494121523#SN654(A123PROD78905) will produce the following barcode image:

  • Primary and Secondary Data in One Symbol Example: Encoding for Primary Data LIC = A123, PCN = PROD7890, and UM = 5 i.e. UPN = A123PROD78905. For Secondary Data Quantity = 10, Date = 12/15/94 23:00 G.M.T. (YYMMDDHH Date Format so Number 4 will be the prefix), and Lot = SN654.

    Code property = A123PROD78905/10#494121523#SN654 will produce the following barcode image:


HIBC PAS 39 Barcode

This Symbology is also known as HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 39, HIBC Health Care Services Provider Barcode

Overview
The HIBC PAS (Provider Applications Standard) is used by Providers of health care services for identification purpose. Providers can encode two kind of information for data structures which are described as "Where" (meaning where the data structure is located i.e. "where it is or what it is on") and "What" (meaning the nature of the data structure i.e. "what it is"). Providers can encode a given Data Structure by using one of the three HIBC PAS formats, depending on the length of the data structure and the available space to represent it. These formats may combine two or more data fields or may split data fields.

The HIBC PAS Data Structures are represented by a variant of Code 39 barcode.
HIBC PAS Single Data Structure
The HIBC PAS Single Data Structure format encodes:
  • "+/" is the Industry Standard Identifier for HIBC Provider Applications Standard
  • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
  • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
  • 1 to 15 alphanumeric characters for Data defined by the application
  • a Checksum which is automatically calculated by Barcode Professional.
HIBC PAS Split Data Fields Data Structure
If the length of the data field requires that a dual data structure ("split") format be used, encodation should be performed using the following formats:
  • The HIBC PAS First Data Structure format encodes:
    • "+/" sign identifier of the HIBC Supplier Data Structure
    • "1" (number/digit one) which indicates that this is the first data structure
    • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
    • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
    • 1 to 15 alphanumeric characters for Data defined by the application
    • a Checksum which is automatically calculated by Barcode Professional.
  • The HIBC PAS Second Data Structure format encodes:
    • "+/" sign identifier of the HIBC Supplier Data Structure
    • "2" (number/digit two) which indicates that this is the second data structure
    • 1 to 15 alphanumeric characters for Data defined by the application
    • 1 character for Link Character (which is the Checksum from First Data Structure)
    • a Checksum which is automatically calculated by Barcode Professional.
HIBC PAS Multiple Data Fields (Concatenated) in One Symbol
The data structure may contain more than one type of data when they share the same "where" flag. If this is the case, the fields are separated by slash (/) characters, and the first character in each field is defined as "what" the data is.

The HIBC PAS Multiple Data Fields format encodes:
  • "+/" is the Industry Standard Identifier for HIBC Provider Applications Standard
  • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
  • For each Data Fields which are separacted by slash (/) characters:
    • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
    • 1 to 15 alphanumeric characters for Data defined by the application
  • a Checksum which is automatically calculated by Barcode Professional.

Sample of a HIBC PAS 39 Barcode for Single Data Structure
(*) NOTES
  • 1-character flag is an uppercase letter A through Z (except Y)
  • 3-characters flag begins with a "Y" and are followed by an additional two characters, as defined by HIBCC
  • "Where" and "What" fields are either a single alphabetic character from A to Z (except Y), or a 3-character sequence beginning with "Y". Three character flag characters begin with a "Y" and are followed by an additional two characters, as defined by HIBCC. If the field contains the letter "Z", this signifies that the data structure which follows does not conform to the HIBC Provider Applications Standard Data Structure Format.
  • "Where" Flag Definitions (Please refer to HIBC Provider Applications Standard for further details)
    Flag Character | Meaning
    A | Patient
    B | Patient Care Record
    C | Specimen Container
    D | Direct Patient Image Item
    E | Business Record
    F | Medical Administration Record
    G | Library Reference material
    H | Devices and Materials
    I | Identification Card
    J | Product Container
    K | Asset
    L | through X Reserved for future definition by HIBCC
    Y | Expansion Flag Character
    Z | User Defined

  • "What" Flag Definitions (Please refer to HIBC Provider Applications Standard for further details)
    Flag Character | Meaning
    A | Labeler Identification Code (LIC):
    B | Service Identification
    C | Patient Identification
    D | Specimen Identification
    E | Personnel Identification
    F | Administrable Product Identification
    G | Implantable Product Information
    H | Hospital Item Identification
    I | Medical Procedure Identification
    J | Reimbursement Category
    K | Blood Product Identification
    L | Demographic Data
    M | Date/Time
    N | Asset Identification
    O | Purchase Order Number
    P | Dietary Item Identification
    Q | Manufacturer Serial Number
    R | Library Materials Identification
    S | Business Control Number
    T | Episode of Care Identification
    U | Health Industry Number (HIN)
    V and W | Reserved for future definition by HIBCC
    X | XML Document
    Y | Expansion Flag Character
    Z | User Defined

How to create HIBC PAS 39 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a HIBC PAS 39 barcode image, please follow these steps:
  • Set the Symbology property to HibcPas39
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property as required (Values are expressed in Inches)
    • Set the BarHeight property as required (Values are expressed in Inches)
    • Set the BarRatio property as required
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Learn the different data encodings by referring to:
    • How to encode Single Data Structure
    • How to encode Split Data Fields
    • How to encode Multiple Data Fields in One Symbol
  • Set the HibcFormatHumanReadableText property. If true (default value), then Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
How to encode Single Data Structure
You can encode Single Data Structure by just passing to Barcode Professional the "Where" Flag Character + "What" Flag Character + 1 to 15 alphanumeric characters for Data
WWAPPLICATION_DATA
Example of encoding Single Data Structure
How to encode Split Data Fields
Barcode Professional provides an easy data format for encoding Split Data Fields Structure.
  • For First Data Structure you must specify to Barcode Professional the "1" (number/digit one) + "Where" Flag Character + "What" Flag Character + 1 to 15 alphanumeric characters for first portion of the Data
    1WWFIRST_PORTION_DATA
  • For Second Data Structure you must specify to Barcode Professional the "2" (number/digit two) + 1 to 15 alphanumeric characters for remainder of the Data. You can optionally instruct to Barcode Professional for computing the "Link Character" by placing the "First Data Structure" between parentheses at the end of the value to encode as is shown below.
    2REMAINDER_DATA(FIRST_DATA_STRUCTURE)
    Example of encoding Split Data Fields
How to encode Multiple Data Fields in One Symbol
For encoding Multiple Data Fields Data in one symbol, the following format must be used:
WWFIRST_DATA/WSECOND_DATA/WTHIRD_DATA/…/WLAST_DATA
The / (slash) character is used as separator between all data structures.
Example of encoding Multiple Data Fields in One Symbol
Example of HIBC PAS 39 barcodes
  • Single Data Structure Example: Encoding Asset Tag - "Where" Flag = K, "What" Flag = N, and App Data = 12345.

    Code property = KN12345 will produce the following barcode image:

  • Split Data Fields Example: Encoding Director Patient Image (Split) Record
    • First Symbol: "Where" Flag = D, "What" Flag = I, and First Portion App Data = P98760.

      Code property = 1DIP98760 will produce the following barcode image:

    • Second Symbol: Remainder App Data = 54321. First Data for Link Character calculation = 1DIP98760

      Code property = 254321(1DIP98760) will produce the following barcode image:

  • Multiple Data Fields in One Symbol Example: Encoding Purchase Order:
    • "Where" Flag = E
    • First Field "What" Flag = A and App Data = H783
    • Second Field "What" Flag = Z and App Data = 34H159

    Code property = EAH783/Z34H159 will produce the following barcode image:


HIBC PAS 128 Barcode

This Symbology is also known as HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 128, HIBC Health Care Services Provider Barcode

Overview
The HIBC PAS (Provider Applications Standard) is used by Providers of health care services for identification purpose. Providers can encode two kind of information for data structures which are described as "Where" (meaning where the data structure is located i.e. "where it is or what it is on") and "What" (meaning the nature of the data structure i.e. "what it is"). Providers can encode a given Data Structure by using one of the three HIBC PAS formats, depending on the length of the data structure and the available space to represent it. These formats may combine two or more data fields or may split data fields.

The HIBC PAS Data Structures are represented by a variant of Code 128 barcode.
HIBC PAS Single Data Structure
The HIBC PAS Single Data Structure format encodes:
  • "+/" is the Industry Standard Identifier for HIBC Provider Applications Standard
  • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
  • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
  • 1 to 15 alphanumeric characters for Data defined by the application
  • a Checksum which is automatically calculated by Barcode Professional.
HIBC PAS Split Data Fields Data Structure
If the length of the data field requires that a dual data structure ("split") format be used, encodation should be performed using the following formats:
  • The HIBC PAS First Data Structure format encodes:
    • "+/" sign identifier of the HIBC Supplier Data Structure
    • "1" (number/digit one) which indicates that this is the first data structure
    • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
    • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
    • 1 to 15 alphanumeric characters for Data defined by the application
    • a Checksum which is automatically calculated by Barcode Professional.
  • The HIBC PAS Second Data Structure format encodes:
    • "+/" sign identifier of the HIBC Supplier Data Structure
    • "2" (number/digit two) which indicates that this is the second data structure
    • 1 to 15 alphanumeric characters for Data defined by the application
    • 1 character for Link Character (which is the Checksum from First Data Structure)
    • a Checksum which is automatically calculated by Barcode Professional.
HIBC PAS Multiple Data Fields (Concatenated) in One Symbol
The data structure may contain more than one type of data when they share the same "where" flag. If this is the case, the fields are separated by slash (/) characters, and the first character in each field is defined as "what" the data is.
The HIBC PAS Multiple Data Fields format encodes:
  • "+/" is the Industry Standard Identifier for HIBC Provider Applications Standard
  • 1 or 3 flag character(s) indicating "where" the data structure is located (*)
  • For each Data Fields which are separacted by slash (/) characters:
    • 1 or 3 flag character(s) indicating "what" the encoded data is (*)
    • 1 to 15 alphanumeric characters for Data defined by the application
  • a Checksum which is automatically calculated by Barcode Professional.

    Sample of a HIBC PAS 128 Barcode for Single Data Structure
(*) NOTES
  • 1-character flag is an uppercase letter A through Z (except Y)
  • 3-characters flag begins with a "Y" and are followed by an additional two characters, as defined by HIBCC
  • "Where" and "What" fields are either a single alphabetic character from A to Z (except Y), or a 3-character sequence beginning with "Y". Three character flag characters begin with a "Y" and are followed by an additional two characters, as defined by HIBCC. If the field contains the letter "Z", this signifies that the data structure which follows does not conform to the HIBC Provider Applications Standard Data Structure Format.
  • "Where" Flag Definitions (Please refer to HIBC Provider Applications Standard for further details)
    Flag Character | Meaning
    A | Patient
    B | Patient Care Record
    C | Specimen Container
    D | Direct Patient Image Item
    E | Business Record
    F | Medical Administration Record
    G | Library Reference material
    H | Devices and Materials
    I | Identification Card
    J | Product Container
    K | Asset
    L through X | Reserved for future definition by HIBCC
    Y | Expansion Flag Character
    Z | User Defined

  • "What" Flag Definitions (Please refer to HIBC Provider Applications Standard for further details)
    Flag Character | Meaning
    A | Labeler Identification Code (LIC):
    B | Service Identification
    C | Patient Identification
    D | Specimen Identification
    E | Personnel Identification
    F | Administrable Product Identification
    G | Implantable Product Information
    H | Hospital Item Identification
    I | Medical Procedure Identification
    J | Reimbursement Category
    K | Blood Product Identification
    L | Demographic Data
    M | Date/Time
    N | Asset Identification
    O | Purchase Order Number
    P | Dietary Item Identification
    Q | Manufacturer Serial Number
    R | Library Materials Identification
    S | Business Control Number
    T | Episode of Care Identification
    U | Health Industry Number (HIN)
    V and W | Reserved for future definition by HIBCC
    X | XML Document
    Y | Expansion Flag Character
    Z | User Defined

How to create HIBC PAS 128 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a HIBC PAS 128 barcode image, please follow these steps:
  • Set the Symbology property to HibcPas128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property as required (Values are expressed in Inches)
    • Set the BarHeight property as required (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. Learn the different data encodings by referring to:
    • How to encode Single Data Structure
    • How to encode Split Data Fields
    • How to encode Multiple Data Fields in One Symbol
  • Set the HibcFormatHumanReadableText property. If true (default value), then Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
How to encode Single Data Structure
You can encode Single Data Structure by just passing to Barcode Professional the "Where" Flag Character + "What" Flag Character + 1 to 15 alphanumeric characters for Data
WWAPPLICATION_DATA
Example of encoding Single Data Structure
How to encode Split Data Fields
Barcode Professional provides an easy data format for encoding Split Data Fields Structure.
  • For First Data Structure you must specify to Barcode Professional the "1" (number/digit one) + "Where" Flag Character + "What" Flag Character + 1 to 15 alphanumeric characters for first portion of the Data
    1WWFIRST_PORTION_DATA
  • For Second Data Structure you must specify to Barcode Professional the "2" (number/digit two) + 1 to 15 alphanumeric characters for remainder of the Data. You can optionally instruct to Barcode Professional for computing the "Link Character" by placing the "First Data Structure" between parentheses at the end of the value to encode as is shown below.
    2REMAINDER_DATA(FIRST_DATA_STRUCTURE)
    Example of encoding Split Data Fields
How to encode Multiple Data Fields Data in One Symbol
For encoding Multiple Data Fields Data in one symbol, the following format must be used:
WWFIRST_DATA/WSECOND_DATA/WTHIRD_DATA/…/WLAST_DATA
The / (slash) character is used as separator between all data structures.
Example of encoding Multiple Data Fields in One Symbol
Example of HIBC PAS 128 barcodes
  • Single Data Structure Example: Encoding Asset Tag - "Where" Flag = K, "What" Flag = N, and App Data = 12345.

    Code property = KN12345 will produce the following barcode image:

  • Split Data Fields Example: Encoding Director Patient Image (Split) Record
    • o First Symbol: "Where" Flag = D, "What" Flag = I, and First Portion App Data = P98760.

      Code property = 1DIP98760 will produce the following barcode image:

    • Second Symbol: Remainder App Data = 54321. First Data for Link Character calculation = 1DIP98760

      Code property = 254321(1DIP98760) will produce the following barcode image:

  • Multiple Data Fields in One Symbol Example: Encoding Purchase Order:
    • "Where" Flag = E
    • First Field "What" Flag = A and App Data = H783
    • Second Field "What" Flag = Z and App Data = 34H159

    Code property = EAH783/Z34H159 will produce the following barcode image:


ISBT 128 Barcode

This Symbology is also known as ISBT 128, ISBT Barcode, ISBT128, ISBT 128 Standard, International Society of Blood Transfusion Barcode, ICCBBA 128, International Council for Commonality in Blood Banking Automation Barcode, Unique Donation Identification Barcode, American Association of Blood Banks AABB 128 Barcode, American Red Cross ARC Barcode

Overview
The ISBT 128 Standard provides the specification for many of the elements of the information environment required in transfusion and transplantation. The standard, originally accepted by the ISBT Council in 1994 and maintained by ICCBBA, Inc; has gained widespread acceptance and is now endorsed by the AABB, European Plasma Fractionators Association, and European Blood Alliance.

ISBT 128 Standard, defines Data Structures that are graphically represented by barcodes. The data structures specified in ISBT 128 are simply the formal definitions of how information is to be identified and electronically presented. Some of these data structures are Unique Donation Identification, Blood Groups [ABO and RhD], Product Code, Expiration Date, Type of Donation (Volunteer, Directed, Autologous, etc), Red Cell Phenotyping Information, HLA Typing Information, CMV and other test results, Collection Container Catalog and Lot Number, Patient date of birth and identification number, etc.

Sample of an ISBT 128 Barcode for Donation Identification Number

How to create ISBT 128 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an ISBT 128 barcode image, please follow these steps:
  • Set the Symbology property to Isbt128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property to 0.39 (Values are expressed in Inches)
    • Set the QuietZone property to 0.1 (Value is expressed in Inches)
  • Set the Isbt128DataStructure property to DS001 (for Donation Identification Number), DS002 (for Blood Groups [ABO and RhD]), DS003 (for Product Code), DS004 (for Expiration Date), etc. (Please refer to ISBT 128 Standard and Barcode Professional Help docs for further details)
  • Set the Code property with the value to encode. It must match the data content/format for the selected Data Structure (Please refer to ISBT 128 Standard for further details)
NOTE: Some ISBT 128 Data Structures require a keyboard entry check character (called K) in order to verify correct manual entry of the data content. Although the check character K is not part of the data content coded in the barcode, Barcode Professional will calculate and display it at the end of the human readable text.
Example of ISBT 128 barcodes
  • ISBT 128 - Donation Identification Number (Data Structure 001)

    Code property = W12340412345600 and Isbt128DataStructure property = DS001 will produce the following barcode image:

  • ISBT 128 - Blood Groups [ABO and RhD] (Data Structure 002)

    Code property = 6200 ("A" Rh Positive) and Isbt128DataStructure property = DS002 will produce the following barcode image:

  • ISBT 128 - Donor Identification Number (Data Structure 019)

    Code property = W12340000001234567890 (DIN 1234567890) and Isbt128DataStructure property = DS019 will produce the following barcode image:


Italian Post 25 Barcode

This Symbology is also known as Italian Post ITF 2/5, PosteItaliane Registered Mail Barcode, PosteItaliane ITF

Overview
The Italian Post 25 barcode is used by Italian Post Office (PosteItaliane) in Registered Items product; a service providing legal certification of delivery and proving that items have been sent. Particularly useful for participation in public tenders or competitions, as well as for administrative and legal purposes. The Italian Post 25 is based on Interleaved 2 of 5 (ITF) standard.

The data content of the Italian Post 25 barcode is 11-digit number and a 1-digit checksum which can be automatically calculated and encoded by Barcode Professional if needed.

Sample of an Italian Post 25 Barcode

How to create Italian Post 25 barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an Italian Post 25 barcode image, please follow these steps:
  • Set the Symbology property to ItalianPost25
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property to 0.63 (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property to 0.2 (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must match the aforementioned structure i.e. 11-digit
Example of an Italian Post 25 barcode image
Code property = 12652325871 will produce the following barcode image:


Kodak Patch Code Information

Also known as Kodak Code, Kodak Path Barcode

Overview
Kodak Patch Code Information is a pattern of parallel, alternating black bars and spaces that is printed on a document. Kodak INnovation Series Scanners which have patch reading capability can recognize patch documents and automatically assign a document image level, increment the document image address, or perform "Color on the Fly" functionality.
Kodak Patch Code provides six different patterns:
  • Patch 2: Assigns image level 2 to the current document.
  • Patch 3: Assigns image level 3 to the current document.
  • Patch T / Transfer Patch: Assigns a predefined image level to the next document. The predefined image level is based upon the transfer patch definition which is defined for each application during installation. For example, if the transfer patch definition defined for the current mode is image level 2, then use of a transfer patch assigns image level 2 to the next document.
The next Patch Types (1, 4 and 6) can be used by the host for post-scan image control for the i800 Series Scanners (they are not used for image addressing). The Toggle Patch may be used to switch back and forth from bi-tonal and color scanning for the i280, 3590C Scanners and the i600 and i800 Series Scanners. This provides Color on the Fly during capture, with no need for post-scan processing by the host application.
  • Patch 1
  • Patch 4 / Toggle Patch
  • Patch 6

How to create Kodak Patch Code Information barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Kodak Patch Code barcode image, please follow these steps:
  • Set the Symbology property to KodakPatchCode
  • Set the Code property with the Patch Code type which must be an integer number ranging from 1 to 6 based on the following:
    • For Patch 2, specify "2"
    • For Patch 3, specify "3"
    • For Patch T / Transfer Patch, specify "5"
    • For Patch 1, specify "1"
    • For Patch 4 / Toggle Patch, specify "4"
    • For Patch 6, specify "6"
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.08 (+/-) 0.01 (Value is expressed in Inches)
    • Set the BarRatio property to 2.5
    • Set the BarHeight property to 0.75 (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)

Example of Kodak Patch Code barcode image

Code property = 2 will produce the following barcode image for Kodak Patch 2 Code:


MICR E13-B

This Symbology is also known as MICR E-13B, MICR E-13-B

Overview
MICR (Magnetic Ink Character Recognition) is a process by which documents are printed using magnetic ink and special fonts to create machine readable information for quick document processing.

Although traditionally MICR has been used to print accounting and routing information on bank checks and other negotiable documents, the magnetic encoding lends itself to any form of document processing.

One of the MICR character sets that are used worldwide is called E13-B or E-13B. MICR E13-B is mainly used in USA, Canada, Bermuda, Mexico, Panama, Colombia, United Kingdom, South Africa, Australia, Hong Kong, India, Japan, Kuala Lumpur, Malaysia, New Zealand, Philippines, Singapore, Taiwan, and Thailand.

The MICR E13-B characters consist of ten specially designed numbers (0 through 9) and four special symbols (Transit, Amount, On-Us, and Dash).
  • Transit symbol
    The Transit symbol tells the reader sorter that the numerals between these symbols are the routing number that identifies the institution on which the check is drawn and where the document should be sent for processing. Checks are not processed in branch offices, but in central processing locations, which ensures that documents take the shortest route and the shortest processing time.
  • Amount symbol
    The Amount symbol tells the reader sorter that the numbers between the symbols are the amount of the check in cents. You seldom see this symbol or the Amount field when you are developing an application, printing a MICR job, or servicing the MICR printer. The amount is normally added later by the bank. However, some customer applications may add the Amount field while printing checks.
  • On-Us symbol
    The On-Us symbol tells the reader sorter that the next few numbers identify the account. Because the issuing institution determines the content of the On-Us field, the bank branch on which the check is drawn may also be indicated. On larger business size checks, the On-Us symbol is also used to define a field on the left end of the check. This optional field, called the Auxiliary On-Us field, frequently contains a multiple digit serial number.
  • Dash symbol
    The Dash symbol is sometimes used as a separator within the On-Us Field, although reader sorter manufacturers discourage its use because of detection problems. Some banks use the Dash symbol to separate the bank branch number from the account number.

MICR E13-B in Barcode Professional

Barcode Professional products draw MICR E13-B characters using .NET Framework drawing engine i.e. our product DOES NOT use Fonts. Because Barcode Professional leverages .NET drawing engine, each MICR E13-B characters is produced in high quality symbols strictly matching the IS0 1004:1995(E) standard.

Encoding MICR E13-B characters with Barcode Professional
For encoding MICR E13-B characters you must use the following "mapping":
  • For digits 0 through 9, use the corresponding numeric character i.e. 0, 1, 2, 3, 4, 5, 6, 7, 8 and 9
  • For Transit Symbol, use one of the following characters: A or [ or ]
  • For Amount Symbol, use one of the following characters: B or # or $
  • For On-Us Symbol, use one of the following characters: C or @
  • For Dash Symbol, use one of the following characters: D or –
MICR E13-B characters size
All of the MICR E13-B characters are designed on a 7 by 9 matrix of 0.013 inch (0.33 mm) squares. The minimum character width is four squares (or 0.052 inch (1.3 mm)) for the numbers 1 and 2. The maximum width is 0.091 inch (2.3 mm) for the number 8, 0, and four special symbols. All characters except the On-Us and Dash symbols have a height of 0.117 inch (3 mm). The height of the On-Us symbol is 0.091 inch (2.3 mm), and the dash is 0.052 inch (1.3 mm).

Barcode Professional will render these character sizes by default although you could use the MICRCharWidths, MICRCharHeight and MICRCharSpacing properties if needed for customizing the MICR E13-B characters' sizes.

How to create MICR E13-B characters using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get MICR E13-B characters image, please follow these steps:
  • Set the Symbology property to MICRE13B
  • Set the Code property with the value to encode based on the character "mapping" described above.
  • If needed, change the character size by using MICRCharWidths, MICRCharHeight and MICRCharSpacing properties.
Example of MICR E13-B image
Code property = 1234567890ABCD will produce the following image (at 300 dpi):


MSI Barcode

This Symbology is also known as MSI/Plessey, Modified Plessey

Overview
MSI was developed by the MSI Data Corporation, based on the original Plessey Code.
MSI, also known as Modified Plessey, is used primarily to mark retail shelves for inventory control. MSI is a continuous, non-self-checking symbology.
While the length of an MSI barcode can be of any length, a given application usually implements a fixed-length code.

Sample of a MSI Barcode

How to create MSI barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a MSI barcode image, please follow these steps:
  • Set the Symbology property to Msi
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It can be numbers 0 through 9 only
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of MSI barcode images
Code property = 123456789 will produce the following barcode image:


Numly Number Barcode

This Symbology is also known as ESN, Electronic Serial Number, Electronic Standard Book Number, ESBN

Overview
A Numly Number is an ESN or Electronic Serial Number for all things digital. It is a unique identifier that allows an author or publisher to assign to content and track licensing of each id assignment. Numly Numbers are useful if you wish to identify each electronic distributed copy of any form of electronic media. Media types could include: Blogs, Emails, MP3s, Videos, PDFs, eBooks, Software, Websites, etc. Numly Numbers can also act a third-party content submission time stamps to aid in copyright proving instances and emails.
The Numly Number consists of a 19 digit number generated by an algorithm maintained by Numly.com.

Sample of a Numly Number Barcode

How to create Numly Number barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Numly Number barcode image, please follow these steps:
  • Set the Symbology property to NumlyNumber
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property (Value are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be the Numly Number which is composed of 19 digits separated (or not) by dash symbols (-)
Example of Numly Number barcode images
Code property = 27200-060121-189140-97 will produce the following barcode image:


OPC Barcode

This Symbology is also known as Optical Product Code, VCA Barcode, VCA OPC, Vision Council of America OPC Barcode

Overview
The key to the OPC system is the unique code and machine-readable symbol assigned to every product. This code allows simpler and more accurate product identification. The symbol makes possible the use of scanner-equipped data entry devices.
The OPC is a 10-digit, numeric code that identifies the product and the manufacturer. The structure of the OPC code is the following:
  • 5 digits for Manufacturer Identification Number assigned by the Optical Product Code Council, Inc.
  • 4 digits Item Identification Number assigned and controlled by the optical manufacturer. The item identification number must be unique to each individual product
  • 1 digit for checksum which is automatically calculated by Barcode Professional

Sample of an OPC Barcode

How to create OPC barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an OPC barcode image, please follow these steps:
  • Set the Symbology property to Opc
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.015 (Value id expressed in Inches)
    • Set the BarHeight property to 0.25 (Value is expressed in Inches)
    • Set the QuietZone property to 0.165, 0, 0.165, 0 - Left, Top, Right, Bottom (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 9 digits:
    • 5 digits for Manufacturer Identification Number assigned by the Optical Product Code Council, Inc.
    • 4 digits Item Identification Number assigned and controlled by the optical manufacturer. The item identification number must be unique to each individual product
Example of OPC barcode images
Code property = 020711721 will produce the following barcode image:


Pharmacode Barcode

Also known as Pharmacode Laetus, Pharmaceutical Binary Code

Overview
Pharmacode is a barcode standard, used in the pharmaceutical industry as a packing control system. The Pharmacode barcode is found extensively on the packaging of pharmaceutical products, usually on the flap of the box that contains the bottle, tube or sachets of pills within. It is designed to be readable despite printing errors. Pharmacode can represent only a single integer from 3 to 131070.

Sample of a Pharmacode Barcode

How to create Pharmacode barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Pharmacode barcode image, please follow these steps:
  • Set the Symbology property to Pharmacode
  • Setting up dimensions and quiet zones:
    • Set the PharmacodeThinBarWidth property to 0.02 or to a value ranging from 0.016 to 0.028 (Values are expressed in Inches)
    • Set the PharmacodeThickBarWidth property to 0.06 or to a value ranging from 0.051 to 0.1 (Values are expressed in Inches)
    • Set the PharmacodeBarsSpacing property to 0.04 or to a value ranging from 0.035 to 0.1 (Values are expressed in Inches)
    • Set the BarHeight property to 0.31 (Values are expressed in Inches)
  • Set the Code property with the value to encode. It must be a numeric value ranging from 3 to 131070. VERY IMPORTANT: Although any values in the last range are valid Pharmacodes, the following numbers MUST NOT BE USED because they will produce non-legible Pharmacode barcodes: 3, 6, 7, 14, 15, 30, 31, 62, 63, 126, 127, 254, 255, 510, 511, 1022, 1023, 2046, 2047, 4094, 4095, 8190, 8191, 16382, 16383, 32766, 32767, 65534, 65535, and 131070

Example of Pharmacode barcode images

Code property = 12345 will produce the following barcode image:


PLANET Barcode

This Symbology is also known as USPS PLANET Barcode, USPS Confirm Service Barcode

Overview
USPS Confirm service allows mailers to uniquely identify and track mail by placing an additional barcode, known as a PLANET Code, on the front of letter and flat mailpieces. The PLANET Code is a 12 -or 14- digit barcode - a “two-state” barcode similar in structure to the POSTNET Code address barcode used by mail processing equipment to sort the mail.
PLANET Codes consist of a series of tall and short bars. PLANET Code digit Symbology is the inverse of POSTNET Code digit Symbology; each POSTNET Code digit uses a combination of two tall and three short bars; each PLANET Code digit uses three tall and two short bars. PLANET Codes must begin and end with one long "framing bar".
All PLANET Codes include a check-sum digit or correction character. This digit must always be the single-digit number (i.e., 0–9) which, when added to the sum of the other digits in the barcode, results in a whole number that is a multiple of 10.
Depending on the type of Confirm mail, mailers must choose the appropriate PLANET Code format:
  • Destination Confirm to track outgoing mailings. PLANET Codes can be used to identify mail sent to customers
  • Origin Confirm to track incoming mail. PLANET Codes can be used to identify reply mail that customers send back
Destination Confirm PLANET Code Format
The Destination Confirm PLANET Code consists of the following elements:
  • Service Type ID: The first 2 digits represent the service (i.e., Destination Confirm) and the class/shape of the mail. Destination Confirm Service Type IDs are listed below
  • Subscriber ID: The next 5 digits identify the subscriber (assigned by the Postal Service)
  • Mailing ID: The next 4 or 6 digits are available to the mailer to use for their own identification purposes (e.g., mailings, clients, etc.)
  • Check-Sum Digit: The 12th or 14th digit is a check-sum digit that helps the Postal Service to detect errors
Mailers should use the PLANET Code in combination with the delivery point POSTNET Code to identify mailpieces uniquely.
Service Type IDs for Destination Confirm service:
  • 40 - First-Class Mail letters
  • 41 - First-Class Mail flats
  • 42 - Standard Mail letters
  • 43 - Standard Mail flats
  • 44 - Periodicals letters
  • 45 - Periodicals flats
  • 46 - First-Class Mail cards
  • 47 - Standard Mail cards
  • 22 - Residual Mail items
Origin Confirm PLANET Code Format
The Origin Confirm PLANET Code consists of the following elements:
  • Service Type ID: The first 2 digits represent the service (i.e., Origin Confirm) and the class/shape of the mail. Origin Confirm Service Type IDs are listed below
  • Customer ID: The next 9 or 11 digits are available to the subscriber to help identify the customer (i.e., mailer of reply mailpiece) or the reply mailpiece itself
  • Check-Sum Digit: The 12th or 14th digit is a check-sum digit that helps the Postal Service to detect errors
For Origin Confirm service, the Postal Service identifies the Confirm subscriber by the POSTNET Code preprinted on the reply mailpiece.
Service Type IDs for Origin Confirm service:
  • 50 - Courtesy reply letters
  • 51 - Courtesy reply flats
  • 52 - Business reply letters
  • 53 - Business reply flats
  • 54 - Business reply cards
  • 56 - QBRM letters
  • 57 - QBRM cards
  • 58 - Courtesy reply cards
  • 21 - Miscellaneous items

How to create USPS PLANET barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an USPS PLANET barcode image, please follow these steps:
  • Set the Symbology property to Planet
  • Setting up dimensions and quiet zones:
    • Set the PlanetHeightShortBar property to a value ranging from 0.04 to 0.06 (Values are expressed in Inches)
    • Set the PlanetHeightTalltBar property to a value ranging from 0.115 to 0.135 (Values are expressed in Inches)
    • Set the BarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the BarRatio property to 1 or 2 (Try 1 first)
    • Set the QuietZone property (Value is expressed in Inches)
  • Setting up the value to encode:
    • Set the Code property with a value with the following structure:
      • For Destination Confirm PLANET Code Format:
        • 2 digits for Service Type ID
        • 5 digits for Subscriber ID
        • 4 or 6 digits for Mailing ID
        • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
      • For Origin Confirm PLANET Code Format:
        • 2 digits for Service Type ID
        • 9 or 11 digits for Customer ID
        • 1 digit for Check-Sum ONLY if AddChecksum property is False, otherwise DO NOT specify the checksum digit because it will be automatically calculated by Barcode Professional products
  • Set the Text property to an Empty string
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
USPS PLANET barcode images samples
  • Destination Confirm PLANET Code Example
    Example of a PLANET Code for a First-Class Mail (40) letter containing a Subscriber ID of 12345 and utilizing numbers 235636 to identify the mailing. The checksum is not specified and is automatically calculated and appended by Barcode Professional
    Code property = 4012345235636 and AddChecksum property = True will produce the following barcode image:
  • Origin Confirm PLANET Code Example
    Example of a PLANET Code for a First-Class Mail (50) letter which identifies a customer with number 201-4023-5635. The checksum is not specified and is automatically calculated and appended by Barcode Professional.
    Code property = 5020140235635 and AddChecksum property = True will produce the following barcode image:


POSTNET Barcode

This Symbology is also known as USPS POSTNET Barcode, USPS POSTal Numeric Encoding Technique Barcode, Delivery Point Barcode (DPBC), Postnet 3 of 5

Overview
The POSTNET (POSTal Numeric Encoding Technique) barcode was developed by the US Postal Service to encode ZIP Code information on letter mail for rapid and reliable sorting by BCSs. The POSTNET barcode can represent a five-digit ZIP Code (32 bars), a nine-digit ZIP+4 code (52 bars), or an eleven-digit delivery point code (62 bars).
The Delivery Point Barcode (DPBC) is formed by adding 10 bars to an existing ZIP+4 barcode. The 10 bars represent two additional digits (normally the last two digits of the street address, post office box, rural route number, or highway contract route number).

The Delivery Point Barcode (DPBC) - USPS POSTNET
The POSTNET barcode is always printed in a format that begins and ends with a frame bar (full or tall bar). To ensure POSTNET accuracy during mail processing, a correction character a.k.a. Checksum (five bars) must be included immediately before the rightmost frame bar of all POSTNET barcodes.

How to create USPS POSTNET barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get an USPS POSTNET barcode image, please follow these steps:
  • Set the Symbology property to Postnet
  • Setting up dimensions and quiet zones:
    • Set the PostnetHeightShortBar property to a value ranging from 0.04 to 0.06 (Values are expressed in Inches)
    • Set the PostnetHeightTalltBar property to a value ranging from 0.115 to 0.135 (Values are expressed in Inches)
    • Set the BarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the BarRatio property to 1 or 2 (Try 1 first)
    • Set the QuietZone property (Value is expressed in Inches)
  • Setting up the value to encode:
    • Set the Code property with a value with the following structure:
      • For five-digit ZIP Code (32 bars): specify the 5 digits only
      • For nine-digit ZIP+4 code (52 bars): specify the 9 digits only
      • For eleven-digit delivery point code (62 bars): specify the 11 digits only
  • Set the Text property to an Empty string
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
USPS PLANET barcode images sample
Nine-digit ZIP+4 code (52 bars) POSTNET Example
Example of a POSTNET barcode for a nine-digit ZIP+4 code 20260-9900. The checksum is not specified and is automatically calculated and appended by Barcode Professional.
Code property = 202609900 and AddChecksum property = True will produce the following barcode image:


PZN Barcode

This Symbology is also known as Pharma-Zentral-Nummer, Pharmazentralnummer, Code PZN, CodePZN

Overview
PZN (Pharma-Zentral-Nummer) is used for distribution of pharmaceutical / health care products in Germany. The specification of this application is maintained at Informationsstelle für Arzneispezialitäten GmbH (IFA).
The value to encode length is fixed to 6 digits plus 1 digit checksum.

Sample of a PZN Barcode

How to create PZN barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a PZN barcode image, please follow these steps:
  • Set the Symbology property to Pzn
  • Set the AddChecksum property to True
  • Setting up dimensions and quiet zones:
    • Set the BarWidth and BarHeight properties (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 6 digits only. PZN letters and checksum value are automatically added by Barcode Professional
Example of PZN barcode images
Code property = 123456 will produce the following barcode image:


British Royal Mail 4-State Customer Barcode

This Symbology is also known as RM4SCC, RoyalMail4SCC, British Royal Mail 4-State Customer Code and Royal Mail Barcode

Overview
This Symbology is used by Royal Mail (United Kingdom) post office for Postal code and automatic mail sorting. It provides information about the address of the receiver.
It encodes alpha-numeric characters (0-9, A-Z), as well as start and stop bar characters. It comprises four types of bars (the four states), each of which has a distinct name, value and barcode symbol.

4-State Barcode Bars

Sample of a British Royal Mail 4-State Barcode

How to create British Royal Mail 4-State (RM4SCC) barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a British Royal Mail 4-State barcode image, please follow these steps:
  • Set the Symbology property to RoyalMail
  • Setting up dimensions and quiet zones:
    • Set the Postal4StateTrackerBarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the Postal4StateTrackerBarHeight property to a value ranging from 0.04 to 0.06 (Values are expressed in Inches)
    • Set the Postal4StateBarsSpacing property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the QuietZone property to 0.08 (Value is expressed in Inches)
  • Set the Code property with the value to encode i.e. with the postcode. The value to encode can contain numeric characters (0-9) and/or alpha characters (A-Z)
  • Barcode Professional will automatically generate the required Start & Stop bars
    • Tip: You can rid of those bars by setting up to False the Postal4StateAddStartStopChar property
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of a British Royal Mail 4-State Customer Code barcode image
Code property = ABC123 will produce the following barcode image:


Royal TPG Post KIX 4-State Barcode

This Symbology is also known as Kix Barcode, Klantenindex (client index) Barcode, Dutch KIX 4-State Bar Code, Dutch KIX, TPG KIX, and TPGPOST KIX

Overview
This Symbology is used by Royal Dutch TPG Post (Netherlands) for Postal code and automatic mail sorting. It provides information about the address of the receiver. It encodes alpha-numeric characters (0-9, A-Z). It comprises four types of bars (the four states), each of which has a distinct name, value and barcode symbol.

4-State Barcode Bars

Sample of a Royal TPG Post KIX 4-State barcode

How to create Royal TPG Post KIX 4-State barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Royal TPG Post KIX 4-State barcode image, please follow these steps:
  • Set the Symbology property to RoyalTpgPostKix
  • Setting up dimensions and quiet zones:
    • Set the Postal4StateTrackerBarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the Postal4StateTrackerBarHeight property to a value ranging from 0.04 to 0.06 (Values are expressed in Inches)
    • Set the Postal4StateBarsSpacing property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the QuietZone property to 0.08 (Value is expressed in Inches)
  • Set the Code property with the value to encode i.e. the KIX which is an acronym of "Klantenindex" (Dutch for "client index")
    • Examples of KIX values that can be set to the Code property. See how you get the KIX value from a given address
      • Address: Antwoordnummer 80430, 2130 VA HOOFDDORP
        KIX: 2130VA80430
      • Address: Havendijk 156-2, 1231 GF POSTDAM
        KIX: 1231GF156X2
      • Address: Havendijk 13 hs, 1231 FZ POSTDAM
        KIX: 1231FZ13XHS
Royal TPG Post KIX 4-State barcode images generated based on the KIX values of point 3
Code property = 2130VA80430 will produce the following barcode image:
Code property = 1231GF156X2 will produce the following barcode image:
Code property = 1231FZ13XHS will produce the following barcode image:


Singapore 4-State Postal Code Barcode

This Symbology is also known as Singapore 4-State Postal, SingPost 4-State, and SingPost Barcode

Overview
This Symbology is used by Singapore Post (SingPost) for Postal code and automatic mail sorting. It’s based on British Royal Mail 4-State Customer Code (RM4SCC) and provides information about the address of the receiver.
It encodes alpha-numeric characters (0-9, A-Z), as well as start and stop bar characters. It comprises four types of bars (the four states), each of which has a distinct name, value and barcode symbol.

4-State Barcode Bars

Sample of a Singapore 4-State Postal barcode

How to create Singapore 4-State Postal Code barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Singapore 4-State Postal Code barcode image, please follow these steps:
  • Set the Symbology property to SingaporePost
  • Setting up dimensions and quiet zones:
    • Set the Postal4StateTrackerBarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the Postal4StateTrackerBarHeight property to a value ranging from 0.04 to 0.06 (Values are expressed in Inches)
    • Set the Postal4StateBarsSpacing property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the QuietZone property to 0.08 (Value is expressed in Inches)
  • Set the Code property with the value to encode i.e. the postal code (6 digits) or the BRS (Business Reply Service) License Number code (4 chars). The value to encode can contain numeric characters (0-9) and/or alpha characters (A-Z)
  • Barcode Professional will automatically generate the required Start & Stop bars
    • Tip: You can rid of those bars by setting up to False the Postal4StateAddStartStopChar property
  • Barcode Professional will automatically generate and append the checksum value
    • Tip 1: You can disable this behavior by setting up to False the AddChecksum property
    • Tip 2: You can leave AddChecksum property set to True but rid of the checksum value from the Human Readable text by setting up to False the DisplayChecksum property
Example of a Singapore 4-State Postal Code barcode image
Code property = 529508 will produce the following barcode image:


Swiss PostParcel Barcode

This Symbology is also known as SwissPost Parcel Barcode, Switzerland Post Parcel Barcode

Overview
Used by Swiss Post, this Symbology is the basis for combining the flow of goods and information. It identifies each parcel and serves as a means of verifying mailing and delivery and checking the service offering. All parcels must have a unique barcode. The barcode is the requirement for automated processing.
The barcode serves as a means of identifying the item.
The structure of the Swiss Post Parcel barcode is 18 numeric digits:
  • 2 digits for Swiss Post reference
  • 8 digits for Franking license number
  • 8 digits for Item number

Sample of a Swiss PostParcel Barcode

How to create Swiss PostParcel barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Swiss PostParcel barcode image, please follow these steps:
  • Set the Symbology property to SwissPostParcel
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.015 to 0.020 (Values are expressed in Inches)
    • Set the BarHeight property to a value ranging from 0.79 to 0.91 (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 18 digits only
Example of Swiss PostParcel barcode images
Code property = 993413796700168509 will produce the following barcode image:


Telepen Barcode

Also known as Telepen Barcode, Telepen Numeric, Telepen Full ASCII, SB Electronic Systems Barcode

Overview
Telepen can be used to represent the full range of ASCII characters. This covers the standard set of printable characters including numbers, capital and lower-case letters and punctuation marks as well as the complete set of non-printable control characters such as carriage-return, line-feed, horizontal tab, etc.

Telepen can also be used to represent numeric data in double-density mode, where an ASCII character is re-interpreted as a pair of numeric characters. There is nothing in the barcode to distinguish between the 2 modes, and the interpretation of the data as ASCII or numeric is set only by the configuration of the reading device.

Telepen systems have been implemented in many countries and very widely in the UK. Most Universities and other academic libraries use Telepen, as do many public libraries. Other users include the motor industry, Ministry of Defense and innumerable well-known organizations for many different applications.

Sample of a Telepen Barcode

How to create Telepen barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Telepen barcode image, please follow these steps:
  • Set the Symbology property to Telepen
  • Set the TelepenEncoding property to:
    • Ascii: Allows to encode the full range of ASCII characters
    • Numeric: Allows to encode numeric data in double-density mode
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property (Value is expressed in Inches)
    • Set the BarHeight property (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode.

Example of Telepen barcode images

Code property = ABC12345 and TelepenEncoding = Ascii will produce the following barcode image:

Code property = 0123456789 and TelepenEncoding = Numeric will produce the following barcode image:


UCC/EAN-128 Barcode

This Symbology is also known as EAN-128, UCC-128, USS-128, GS1-128, UCC.EAN-128, GTIN-128, UCC-12, EAN/UCC-13, EAN/UCC-14

Overview
The UCC/EAN-128 Symbology is a subset of the more general Code 128 Symbology. By agreement among AIM, Inc., EAN International and the UCC (now GS1), use of the Function 1 Character (FNC1) in Code 128 Symbols in the first symbol character position following the Start Character has been reserved exclusively for the EAN.UCC System.
UCC/EAN-128 was developed to provide a worldwide format and standard for exchanging common data between companies. While other barcodes simply encode data with no respect for what the data represents, UCC/EAN-128 encodes data and encodes what that data represents.
UCC/EAN-128 has a list of Application Identifiers (AI). The Application Identifier is a 2, 3, or 4-digit number that identifies the type of data which follows. By convention, the Application Identifier is enclosed in parentheses when printed below the barcode (the parentheses are only for visual clarity, and are not encoded in the barcode).

Sample of a UCC/EAN-128 Barcode

How to encode UCC/EAN-128 values using Barcode Professional products

Introduction
UCC/EAN 128 encodes the so called Element Strings which are composed of an Application Identifier (AI) plus a data field. Each AI identifies the meaning and format of the data following it. Note that the AI has parentheses around it in the human readable text, but the parentheses are not encoded in the barcode. Barcode Professional is capable of determining the length of the AI automatically. However, if the length of the AI cannot be determined, then you can explicitly indicate such length prefixing it with one of the following special characters:
  • Ê (ASCII 202 / Alt+0202) - The AI is 2 digits long
  • Ë (ASCII 203 / Alt+0203) - The AI is 3 digits long
  • Ì (ASCII 204 / Alt+0204) - The AI is 4 digits long
  • Í (ASCII 205 / Alt+0205) - The AI is 5 digits long
The code FNC1 (Function 1 Character) is generally used to concatenate two or more data fields in a unique barcode image.
FNC1 does not have an ASCII representation, but Barcode Professional uses the following character to encode the code FNC1. Note: Barcode Professional will automatically add FNC1 character when necessary.
  • È (ASCII 200 / Alt+0200) - The code FNC1
By default, Barcode Professional tries to optimize the value to encode to generate the shortest barcode image by automatically switching between Code 128 char sets. However, you can handle how the data must be encoded specifying some special chars that represent each Code 128 Char Set. The special chars that tell to Barcode Professional what Code Set must be used to encode the data that follows it are these:
  • Ò (ASCII 210 / Alt+0210) which indicates that the Char Set to use must be A
  • Ó (ASCII 211 / Alt+0211) which indicates that the Char Set to use must be B
  • Ô (ASCII 212 / Alt+0212) which indicates that the Char Set to use must be C (Note: When you specify that the data must be encoded using Char Set C, then the number of chars after it must be even!)
IMPORTANT: When using this manual encoding, the FNC1 char must be also explicitly specified as part of the value to encode by using ASCII 200
Examples
Concatenation of AIs in a unique barcode image
  • Concatenation of the Pre-Defined Length Element Strings
    Concatenated Element Strings constructed from Application Identifiers with a pre-defined length do not require a Separator Character (FNC1). Each Element String is immediately followed by either the next Application Identifier or the Symbol Check Character and Stop Character.

    Example
    Concatenation of net weight (4 kg) with the associated Global Trade Item Number (GTIN) 95012345678903 does not require the use of a Separator Character (FNC1).

    AI 01 (Shipping Contained Code) has a pre-defined Element String length of 16 digits.
    AI 31 (Product Net Weight in Kg) has a pre-defined Element String length of 10 digits.

    Code property = 01950123456789033102000400 will produce the following barcode image:
    Notice that parenthesis enclosing AIs are automatically added by Barcode Professional in the human readable text zone.

    Explicitly specifying the length of AIs to fix parenthesis order in the human readable text
    You can use the special characters aforementioned to fix parenthesis order around AIs. Based on the example on this section, you can get the same result by specifying the following settings:

    Code property = Ê0195012345678903Ì3102000400 (The Ê (ASCII 202) character has been added before the first AI in order to fix parenthesis order and to specify an AI which length should be 2; and the Ì (ASCII 204) character has been added before the second AI in order to fix parenthesis order and to specify an AI which length should be 4)
  • Concatenation of Variable Length Data Strings
    Concatenating Element Strings of variable length involves the use of a Separator Character (FNC1). It is placed immediately after the last symbol character of a variable length data string and is followed by the Application Identifier of the next Element String. If the Element String is the last to be encoded, it is followed by the Symbol Check and Stop Characters and not the FNC1 Separator Character.

    Example
    Concatenation of AI 8005 Price per Unit of Measure (365 currency units) and AI 10 Batch Numbers (123456) requires the use of a Separator Character (FNC1) immediately after the price per unit of measure.

    Code property = 800500036510123456 will produce the following barcode image:
    Notice that parenthesis enclosing AIs are automatically added by Barcode Professional in the human readable text zone.

    Explicitly specifying the length of AIs to fix parenthesis order in the human readable text
    You can use the special characters aforementioned to fix parenthesis order around AIs. Based on the example on this section, you can get the same result by specifying the following settings:

    Code property = Ì8005000365Ê10123456 (The Ì (ASCII 204) character has been added before the first AI in order to fix parenthesis order and to specify an AI which length should be 4; and the Ê (ASCII 202) character has been added before the second AI in order to fix parenthesis order and to specify an AI which length should be 2)


USPS Facing Identification Marks Barcode

Also known as USPS FIM Barcode, FIM A, FIM B, FIM C, FIM D

Overview
The facing identification mark (FIM) is a pattern of vertical bars printed in the upper right portion of a mailpiece, to the left of the postage area.
The FIM uses a code that tells automated processing equipment some of what it needs to know to do its job. The FIM allows automatic facing (orientation) of the mail for cancellation (postmarking). The FIM also identifies reply mail that bears a preprinted barcode. Barcoded mail is then routed directly to a high-speed barcode sorter, bypassing slower manual sorting or optical character reader (OCR) processing.
Determine which FIM to use as follows:
  • FIM A is used for Courtesy Reply Mail (CRM) and Meter Reply Mail (MRM) with a preprinted barcode
  • FIM B is used for Business Reply Mail (BRM) without a preprinted BRM ZIP+4 barcode
  • FIM C is used for Business Reply Mail (BRM) with a preprinted BRM ZIP+4 barcode
  • FIM D is used only with information based indicia (IBI) postage
FIM Standards
Make sure the FIM meets the following standards:
  • The FIM clear zone must contain no printing other than the FIM pattern
  • Figure below shows the configuration of the clear zone and the correct location of the FIM
  • The rightmost bar of the FIM must be 2 inches +/- 1/8 inch from the right edge of each mailpiece
  • The FIM bars must be 5/8 inch high +/- 1/8 inch and 1/32 inch wide +/- 0.008 inch
  • The tops of the FIM bars must be no lower than 1/8 inch from the top edge of each mailpiece. They may extend over the top edge to the flap
  • The bottoms of the FIM bars should touch the bottom edge of the FIM clear zone but must not be more than 1/8 inch above or below that edge

Configuration of the clear zone and the correct location of the FIM

How to create USPS Facing Identification Marks (FIM) barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS FIM barcode image, please follow these steps:
  • Set the Symbology property to UspsFim
  • Set the UspsFimPattern property to A, B, C, or D
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.03125 (+/-) 0.008 (Value is expressed in Inches)
    • Set the BarHeight property to 0.625 (+/-) 0.125 (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)

Example of USPS FIM barcode images

UspsFimPattern property = A will produce the following barcode image for USPS FIM A:
UspsFimPattern property = B will produce the following barcode image for USPS FIM B:
UspsFimPattern property = C will produce the following barcode image for USPS FIM C:
UspsFimPattern property = D will produce the following barcode image for USPS FIM D:


USPS Horizontal Bars Barcode

Also known as USPS BRM Horizontal Bars

Overview
USPS Business Reply Mail (BRM) enables you to receive First-Class Mail back from customers while paying postage only on the pieces that your customers return. You may distribute cards, envelopes, self-mailers, and other types of mailpieces as BRM.

Six basic design elements are required on a BRM piece. One of these design elements is called Horizontal Bars. To help identify your mailpiece as BRM, you must print a series of horizontal bars below the "NO POSTAGE NECESSARY" endorsement on your BRM pieces. These bars must be uniform in length, thickness, and spacing. Each bar must be at least 1 inch long and 1/16 inch to 3/16 inch thick.

There must be at least a 1/2-inch clearance between the right edge of the ZIP Code in the delivery address and the left edge of the horizontal bars. The bottom bar in the series must be above (not on or below) the top of the delivery address line - the next-to-last line in the address, just above the line with the city, state, and ZIP Code
Size and location of Horizontal Bars

How to create USPS Horizontal Bars using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Horizontal Bars image, please follow these steps:
  • Set the Symbology property to UspsHorizontalBars
  • Set the UspsHorizontalBarsCount property
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.0625 to 0.1875 (Value is expressed in Inches)
    • Set the BarHeight property to 1 (Value is expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)

Example of USPS Horizontal Bars images

UspsHorizontalBarsCount property = 10 will produce the following barcode image for USPS Horizontal Bars:


USPS Intelligent Mail / OneCode 4-State Customer Barcode

This Symbology is also known as Intelligent Mail, OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode, USPS IM

Overview
Intelligent Mail Barcode (formerly OneCode 4-State Customer Barcode 4-CB) is the next generation in the evolution of USPS barcode technology. It does not replace existing barcodes - it offers a more effective alternative. Partnering with the Mailing Industry, the Postal Service developed the Intelligent Mail which increases the amount of information carried on letter and flats mail pieces and allows for expanded tracking capability, creating greater visibility into the mailstream.

Intelligent Mail is a height-modulated barcode using four distinct, vertical bar types. It encodes a 31-digit string into 65 vertical bars each representing one of four possible states: full bar, ascender, tracker, and descender.

4-State Barcode Bars
Intelligent Mail carries a payload 31 digits comprised of the following elements.
Type | Field | Digits
Tracking Code | Barcode Identifier | 2 (2nd digit must be 0–4)
 | Service Type Identifier | 3
 | Mailer Identifier | 6 or 9
 | Serial Number | 9 (when used with 6 digit Mailer ID) 6 (when used with 9 digit Mailer ID)
Routing Code | Delivery Point ZIP Code | 0, 5, 9, or 11
Table 1 – USPS Intelligent Mail Barcode Data Fields
For each of the fields in Table 1, except the Routing Code, leading or trailing zeros shall be provided to achieve the correct size. Spaces and nulls are not acceptable characters for padding. For ZIP Codes, which have one of four lengths, encoding shall provide padding beyond the digits to be encoded. No error detection and correction, such as a checksum with POSTNET or PLANET, shall be included as part of the data fields. The Intelligent Mail Barcode Data Fields are described as follows:
  • The Barcode Identifier is assigned by USPS for encoding the presort identification that is currently printed in human readable form on the optional endorsement line (OEL) as well as for future USPS use. This is two digits, with the second digit in the range of 0-4.
  • The Service Type Identifier is assigned by USPS for any combination of services requested on the mailpiece. The allowable encoding range is 000-999.
  • The Mailer or Customer Identifier is assigned by USPS as a unique identifier for each business entity. The allowable encoding range for the 6 digit Mailer ID is 000000-899999, while the allowable encoding range for the 9 digit Mailer ID is 900000000-999999999.
  • The Serial or Sequence Number is assigned by the mailer for tracking mailpieces. The allowable encoding range is 000000000-999999999 when used with a 6 digit Mailer ID and 000000-999999 when used with a 9 digit Mailer ID.
  • The Delivery Point ZIP Code is assigned by the mailer for routing the mailpiece. This replaces POSTNET for routing the mailpiece to its final delivery point. The length may be 0, 5, 9, or 11 digits. The allowable encoding ranges are no ZIP Code, 00000-99999, 000000000-999999999, and 00000000000-99999999999.

Sample of a USPS Intelligent Mail barcode

How to create USPS Intelligent Mail barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Intelligent Mail barcode image, please follow these steps:
  • Set the Symbology property to IntelligentMail or UspsOneCode4CB
  • Setting up dimensions and quiet zones:
    • Set the Postal4StateTrackerBarWidth property to a value ranging from 0.015 to 0.025 (Values are expressed in Inches)
    • Set the Postal4StateTrackerBarHeight property to a value ranging from 0.04 to 0.08 (Values are expressed in Inches)
    • Set the Postal4StateBarsSpacing property to a value ranging from 0.012 to 0.040 (Values are expressed in Inches)
    • Set the QuietZone property to 0.125, 0, 0.125, 0 - Left, Top, Right and Bottom zones (Value is expressed in Inches)
  • Setting up the value to encode:
    • Set the Code property with a value with the following structure:
      • 20 digits for Tracking Code which is composed of Barcode Identifier (2 digits and 2nd digit must be 0-4), Service Type Identifier (3 digits), Mailer or Customer Identifier (6 or 9 digits), and Serial or Sequence Number (9 or 6 digits depending on Mailer ID length)
      • (Optional) Routing Code (Delivery Point ZIP Code) which can be composed of 0, 5, 9, or 11 digits.
    • Examples of values that can be set to the Code property based on the stated in the previous rules:
      • 34160265194042788110
      • 9002580053457430457568477
      • 91562578054046449955601201455
      • 0445031376985619365776725552439
  • Set the CodeAlignment property to AboveLeft
  • Set the Text property to an Empty string
USPS OneCode 4-State Customer barcode images generated based on the values of point 3
Code property = 34160265194042788110 will produce the following barcode image:
Code property = 9002580053457430457568477 will produce the following barcode image:
Code property = 91562578054046449955601201455 will produce the following barcode image:
Code property = 0445031376985619365776725552439 will produce the following barcode image:


USPS Intelligent Mail Container Barcode

This Symbology is also known as USPS IM Container Barcode, IM Container Barcode

Overview
The Intelligent Mail Container barcode is used by USPS on mailer-generated pallet labels to uniquely identify pallets and similar containers (i.e. All Purpose Containers, hampers, pallet boxes, etc.) in addition to identifying the mail owner.

Two distinct data constructs are permitted. Both formats are 21-characters in length and will require mailers to encode their respective USPS-assigned 6- or 9-digit Mailer ID. The length of the mailer’s Mailer ID (6 or 9 digits) will dictate which format to follow.
6-digit Mailer ID Barcode Format:
  • Application Identifier: 2-digit which is "99".
  • Type Indicator: 1 alpha char which is "M"
  • Mailer ID: 6-digit USPS-assigned ID with the leading digit ranging from "0" through "8"
  • Serial Number: 12 alphanumeric chars. If the value in the fixed length Serial Number field is less than the required 12 characters, it shall be padded with either leading zeros OR leading dashes ("-", ASCII 45); however, leading zeros are recommended. For example, if the mailer opts for a container identifier of "123456", a value of "000000123456" OR "------123456" shall be encoded.
9-digit Mailer ID Barcode Format:
  • Application Identifier: 2-digit which is "99".
  • Type Indicator: 1 alpha char which is "M"
  • Mailer ID: 9-digit USPS-assigned ID with the leading digit being "9"
  • Serial Number: 9 alphanumeric chars. If the value in the fixed length Serial Number Field is less than the required 9 characters, it shall be padded with either leading zeros OR leading dashes ("-", ASCII 45); however, leading zeros are recommended. For example, if the mailer opts for a container identifier of "123456", a value of "000123456" OR "---123456" shall be encoded.

Sample of a USPS Intelligent Mail Container Barcode

How to create USPS Intelligent Mail Container Barcode using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Intelligent Mail Container Barcode image, please follow these steps:
  • Set the Symbology property to UspsIntelligentMailContainerBarcode
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.0225 to 0.0275 (Values are expressed in Inches). NOTE: The overall length of the barcode, measured from the leading edge of the first bar to the trailing edge of the last bar, shall not exceed 7.25 inches. An overall barcode length between 6.25 and 7.25 inches is recommended.
    • Set the BarHeight property to a value ranging from 0.75 to 1.1 (Values are expressed in Inches)
    • Set the QuietZone property to a value 10 times the BarWidth value for left and right zones and 0.125 for top and bottom zones (Value is expressed in Inches)
  • Set the Code property with the value to encode as stated above for 6-digit or 9-digit Mailer ID Barcode formats.
USPS OneCode 4-State Customer barcode images generated based on the values of point 3
Code property = 99M123456-----ABC1234 will produce the following barcode image:


USPS Package Identification Code (USS Code 128) Barcode

USPS Package Identification Code Barcode (USS Code 128)

Also known as USPS PIC Code 128, USPS Package Identification Code USS Code 128, USPS Confirmation Services Tracking Number Barcode USS Code 128

Overview
Privately printed domestic forms and labels feature a Package Identification Code (PIC) represented by a Code 128 barcode.
The Code 128 Barcode Format for Package Identification Code is made up of four fields totaling 20 characters. The four required data fields are:
  • Service Type Code (STC): Service Type Codes are 2-digit designators used to represent type of product and service used for each item. Use one of the following numbers depending on the service being used: Certified Mail (71), Insured Mail (73), Registered Mail (77), and Return Receipt for Merchandise (81).
  • Customer ID: 9-digit; DUNS number that uniquely identifies the customer
  • Package Sequence Number (PSN): 8-digit; fixed sequential number
  • Modulus 10 Check digit: It is a digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed.

Sample of a USPS Package Identification Code Barcode (USS Code 128) barcode

How to create Sample of a USPS Package Identification Code Barcode (USS Code 128) barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a Sample of a USPS Package Identification Code Barcode (USS Code 128) barcode image, please follow these steps:
  • Set the Symbology property to UspsPicCode128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.015 to 0.017 (Values are expressed in Inches)
    • Set the BarHeight property to 0.75 (Values are expressed in Inches)
    • Set the QuietZone property to 0.25, 0.125, 0.25, 0.125 (Values are expressed in Inches)
  • Set the Code property with the value to encode i.e. 19 or 20 digits

Example of a USPS Package Identification Code Barcode (USS Code 128) barcode image

Code property = 71123456789123456787 will produce the following barcode image:


USPS Package Identification Code (UCC/EAN-128 GS1-128)

Also known as USPS PIC UCC/EAN-128, USPS Package Identification Code, USPS Confirmation Services Tracking Number Barcode, USPS PIC Barcode

Overview
Confirmation Services uses standardized bar codes to uniquely identify mail pieces and to designate the type of service being requested. Using a Package Identification Code (PIC), commonly called a tracking number, will uniquely identify all Confirmation Services mail pieces. The PIC is printed in bar code format on the label and must be unique.
The UCC/EAN 128 Barcode Format for Package Identification Code is made up of five fields totaling 22 characters. The five required data fields are:
  • Application Identifier (AI): This is a code used within UCC/EAN Code 128 that identifies this as a Postal Service bar code. In this case the Application Identifiers (AIs) for Confirmation Services is "91"
  • Service Type Code (STC): Service Type Codes are 2-digit designators used to represent Postal Service classes of mail in conjunction with the type of postal service being requested. STCs are included in the Confirmation Services bar code to identify the class of mail and/or type of special services included on that specific mail item
  • Customer ID: 9-digit; DUNS number that uniquely identifies the customer
  • Package Sequence Number (PSN): 8-digit; fixed sequential number
  • Modulus 10 Check digit: It is a digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed
The Concatenated UCC/EAN 128 Barcode Format for Package Identification Code is made up of seven fields totaling 30 characters. The seven required data fields are:
  • Routing Application Identifier: In this case the Application Identifier is "420"
  • 5-digit ZIP Code
  • Tracking Application Identifier: In this case the Application Identifier is "91"
  • Service Type Code (STC): Service Type Codes are 2-digit designators used to represent Postal Service classes of mail in conjunction with the type of postal service being requested. STCs are included in the Confirmation Services bar code to identify the class of mail and/or type of special services included on that specific mail item
  • Customer ID: 9-digit; DUNS number that uniquely identifies the customer
  • Package Sequence Number (PSN): 8-digit; fixed sequential number
  • Modulus 10 Check digit: It is a digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed

Sample of a USPS Package Identification Code (PIC) barcode

How to create USPS Package Identification Code (PIC) barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Package Identification Code (PIC) barcode image, please follow these steps:
  • Set the Symbology property to UspsPicUccEan128
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to a value ranging from 0.015 to 0.017 (Values are expressed in Inches)
    • Set the BarHeight property to 0.765625 (Values are expressed in Inches)
    • Set the QuietZone property to 0.25, 0.15625, 0.25, 0.171875 - Left, Top, Right, and Bottom zones (Value is expressed in Inches)
  • Set the Code property with the value to encode:
    • For single barcodes: It must begin with "91" followed by 19 or 20 digits
    • For Concatenated barcodes: It must begin with "420" followed by 5-digit ZIP code and followed by "91" and 19 or 20 digits

Example of a USPS Package Identification Code (PIC) barcode image

Code property = 9102026837331000001016 will produce the following barcode image:
Code property = 420202609101026837331000001016 will produce the following barcode image:


USPS Sack Label Barcode

This Symbology is also known as USPS 25 Sack label

Overview
Sack Label is used by United States Postal Services (USPS) for labeling of postal sacks; for automation rate mailings; for periodicals and standard mail (letter size & flat size pieces).
It contains the "ZIP code" of the receiver and a "Content Identifier Number".
The value to encode length is fixed to 8 digits and it must have the following structure:
  • 5 digits for "ZIP code"
  • 3 digits for "Content Identifier Number" [CIN]
The "Content Identifier Number" [CIN] indicates this information:
  • mailing class (express, priority, first-class, periodicals, standard, package)
  • presorting / automation process
  • sack

Sample of a USPS Sack Label Barcode

How to create USPS Sack Label barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Sack Label barcode image, please follow these steps:
  • Set the Symbology property to UspsSackLabel
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.015 (Values are expressed in Inches)
    • Set the BarHeight property to 0.7 (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property to 0.15, 0, 0.15, 0 - Left, Top, Right, and Bottom zones (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 8 digits only
Example of a USPS Sack Label barcode image
Code property = 55116572 will produce the following barcode image:


USPS Tray Label Barcode

This Symbology is also known as USPS 25 Tray label

Overview
Tray Label is used by United States Postal Services (USPS) for labeling of postal trays; for automation rate mailings; for periodicals and standard mail (letter size & flat size pieces).
It contains the "ZIP code" of the receiver and a "Content Identifier Number".
The value to encode length is fixed to 10 digits and it must have the following structure:
  • 5 digits for "ZIP code"
  • 3 digits for "Content Identifier Number" [CIN]
  • 2 digits for "Processing Code"
The "Content Identifier Number" [CIN] indicates this information:
  • mailing class (express, priority, first-class, periodicals, standard, package)
  • presorting / automation process
  • tray
The "Processing code" indicates this information:
  • 07 = other

Sample of a USPS Tray Label Barcode

How to create USPS Tray Label barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a USPS Tray Label barcode image, please follow these steps:
  • Set the Symbology property to UspsTrayLabel
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.015 (Values are expressed in Inches)
    • Set the BarHeight property to 0.7 (Values are expressed in Inches)
    • Set the BarRatio property to 3
    • Set the QuietZone property to 0.15, 0, 0.15, 0 - Left, Top, Right, and Bottom zones (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must be 10 digits only
Example of a USPS Tray Label barcode image
Code property = 2230034401 will produce the following barcode image:


VICS BOL Barcode

This Symbology is also known as VICS Bill of Lading, Voluntary Interindustry Commerce Solutions Bill of Lading, BOL Barcode, 17-digit BOL, VICS standard Bill of Lading

Overview
The VICS standard Bill of Lading (BOL) number is based on UCC global standard identification system. It is a fixed length numeric number and is composed of sixteen digits and a check digit. The VICS standard Bill of Lading number is an identification number assigned by the shipper and is a mandatory part of the VICS standard Bill of Lading. The VICS BOL number structure supports its' use as a unique shipment identification tag within the total supply chain and as a primary key to corresponding shipment EDI data.

The data content of the VICS standard Bill of Lading (BOL) number is as specified below:
For Companies with a GS1.US (EAN.UCC) Company Prefix:
  • 7-digit GS1.US (EAN.UCC) Company Prefix (*)
  • 9-digit Serial number which is assigned by the shipper and unique for each Bill (*)
  • 1-digit Checksum which is a check digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed.
For Companies without a GS1.US (EAN.UCC) Company Prefix:
  • 2-digit encoding the value 04 (zero and four)
  • 14-digit Number assigned by the shipper
  • 1-digit Checksum which is a check digit added at the end of a sequence of numbers that validates the authenticity of the number. It can be automatically calculated and encoded by Barcode Professional if needed.

    Sample of a VICS standard Bill of Lading (BOL) Barcode
(*) Considerations about GS1.US (EAN.UCC) Company Prefix and Serial number:
  • The GS1.US (EAN.UCC) Company Prefix is the same prefix used in the U.P.C. and SSCC-18 numbers.
  • UCC assigned company prefixes will need to be converted to a GS1.US (EAN.UCC) Company Prefix. This is accomplished by adding a 0 (zero) to the left of the UCC Company Prefix.
  • For suppliers with legacy system applications that generate and use a 7-digit BOL number, then their GS1.US (EAN.UCC) company prefix is 0111111 and the 7-digit BOL must be prefixed with 00 to total 9-digit BOL.

How to create VICS BOL barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a VICS BOL barcode image, please follow these steps:
  • Set the Symbology property to VicsBol
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property to 0.5 (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must match the aforementioned structure i.e. 7-digit GS1.US (EAN.UCC) Company Prefix + 9-digit Serial number
  • Set the AddChecksum property to True
Example of a VICS BOL barcode image

Code property = 0614141123456791 (GS1.US Company Prefix = 0614141 and Serial number = 123456791) will produce the following barcode image:


VICS SCAC PRO Barcode

This Symbology is also known as VICS Bill of Lading SCAC PRO, Voluntary Interindustry Commerce Solutions Bill of Lading SCAC PRO, SCAC Barcode, PRO Barcode, VICS SCAC, VICS PRO, SCAC/Pro Barcode, Standard Carrier Alpha Code, Carrier SCAC Barcode

Overview
The VICS standard Bill of Lading (BOL) form features two barcodes, one for VICS BOL and one for carrier SCAC and PRO number. The SCAC/Pro number is determined by joining SCAC and Pro values. SCAC (Standard Carrier Alpha Code) is a four-letter alpha code identifying the carrier and assigned by the NMFTA (The National Motor Freight Traffic Association) while Pro Number is a unique number assigned by the carrier to identify a specific shipment.

The data content of the VICS SCAC/Pro barcode is as specified below:
  • Four (4) alpha characters for SCAC (as assigned to a given carrier by the NMFTA) (*)
  • 20-digit for PRO Number (**)

    Sample of a VICS SCAC/Pro Barcode
(*) If the SCAC is less than four characters in length, then a dash character (-) should be used to extend the field to four characters.
(**) Due to space limitations, numeric characters are recommended for the PRO number. If alpha characters are used, the number of characters that fit in the available space on the Bill of Lading form is diminished considerably.

How to create VICS SCAC/Pro barcodes using Barcode Professional

Note: Please refer to the Class Reference documentation for more information about the properties and methods stated in this document.
In order to get a VICS SCAC/Pro barcode image, please follow these steps:
  • Set the Symbology property to VicsScacPro
  • Setting up dimensions and quiet zones:
    • Set the BarWidth property to 0.01 (Values are expressed in Inches)
    • Set the BarHeight property to 0.5 (Values are expressed in Inches)
    • Set the QuietZone property (Value is expressed in Inches)
  • Set the Code property with the value to encode. It must match the aforementioned structure i.e. four (4) alpha characters for SCAC + 20-digit PRO number
  • Set the AddChecksum property to True
Example of a VICS SCAC/Pro barcode image

Code property = ABCD12345678901234567890 (SCAC = ABCD and PRO number = 12345678901234567890) will produce the following barcode image: