About Neodynamic Barcode Professional SDK 5.0 for .NET

Neodynamic Barcode Professional SDK for .NET
What is Neodynamic Barcode Professional SDK for .NET?
Neodynamic Barcode Professional SDK for .NET is a lightweight .NET assembly (DLL) which can be used for adding advanced barcode capabilities – such as barcode image generation and printing - to any .NET Framework-based applications. Barcode Professional supports most popular Linear (1D), Postal and 2D Barcode Symbologies/Standards all-in-one solution.

Barcode Professional SDK for does not require any special or complex configurations to use it in your .NET Applications; just add a reference to Barcode Professional DLL assembly, instantiate it in your preferred .NET language such as VB.NET and C#, set up barcode properties and that's it.

Other interesting features of Barcode Professional are its capability to use it in data-binding scenarios, to deliver barcode images from Web Services, and its reporting support in Crystal Report for .NET and Visual Studio ReportViewer Local Reports (RDLC).
Main Features
  • Can generate Linear, Postal and 2D Barcode Symbologies.
  • Can save the barcode in an image file as well as in a stream object.
  • Rotation of the barcode image.
  • Automatically computes the checksum or check digits.
  • Automatically validates the value to encode.
  • No complex configurations.
  • High Quality Printing support (.NET PrintDocument Class).
  • Crystal Reports support.
  • Visual Studio ReportViewer Local Reports (RDLC) support.
  • Binary, SOAP, and XML serialization support.
  • Data-Binding support
  • ASP.NET Web Services support
Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


License Registration

Neodynamic Barcode Professional SDK for .NET
License Registration
When you buy a commercial version of Barcode Professional you are provided with license information to register your licensed copy of Neodynamic Barcode Professional SDK for .NET.

The registration process is very simple and can be accomplished in two ways:

  • Codeless License Setting
    Codeless License Setting involves adding the license info in the Application's Configuration file (*.config). The license info must be specified in the BarcodeProSDK50LicenseOwner and BarcodeProSDK50LicenseKey entries in the appSettings section of *.config file. Example:
    <configuration>
  <appSettings>
    <add key="BarcodeProSDK50LicenseOwner" value="LICENSE-OWNER"/>
    <add key="BarcodeProSDK50LicenseKey" value="LICENSE-KEY"/>
  </appSettings>
  ...
</configuration>
  • Using License Properties in code
    In the class you're using BarcodeProfessional, set the LicenseOwner and LicenseKey static (shared in VB) properties with the license info you've received.
    IMPORTANT
    Please, keep in mind that the license info is case-sensitive!

    VB.NET
    ' WINDOWS FORMS SAMPLE

Imports Neodynamic.SDK.Barcode

Public Class Form1

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        BarcodeProfessional.LicenseOwner = "LICENSE-OWNER"
        BarcodeProfessional.LicenseKey = "LICENSE-KEY"

    End Sub

End Class

    C#
    // WINDOWS FORMS SAMPLE

using Neodynamic.SDK.Barcode;

public partial class Form1 : Form
{
    private void Form1_Load(object sender, EventArgs e)
    {
        BarcodeProfessional.LicenseOwner = "LICENSE-OWNER";
        BarcodeProfessional.LicenseKey = "LICENSE-KEY";
    }
}

After you set these properties the TRIAL legend should disappear from the generated image.

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Trial Version

Neodynamic Barcode Professional SDK for .NET
Trial Version
The Trial Version of Neodynamic Barcode Professional SDK for .NET is fully functional and has no expiry date. The only limitation it has is that a TRIAL legend will appear on the generated barcode image.

When you buy a licensed version of Barcode Professional you will receive license information to register your copy of Barcode Professional SDK for .NET. For more information about the registration process view License Registration topic.
Want to try Barcode Professional SDK without TRIAL watermark?
Neodynamic offers you a 30-day Evaluation License Key which will allow you to test the Barcode Professional SDK in fully-functional mode for 30 days! When the 30-day Evaluation License Key expires, the Barcode Professional SDK behavior backs to Trial mode. Request your 30-day Evaluation License Key

Distribution restrictions

If you are using a Trial Version, you should not distribute any of the files provided with it.

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


System Requirements

Neodynamic Barcode Professional SDK for .NET
System Requirements
For developing applications with Neodynamic Barcode Professional SDK for .NET, you must have the following system and software specifications:

Microsoft .NET Framework

Microsoft .NET Framework 2.0 or greater with its latest service pack.

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Installation and Configuration

Neodynamic Barcode Professional SDK for .NET
Installation and Configuration
Installing Neodynamic Barcode Professional SDK for .NET is very simple.
  • Download the latest version from Neodynamic's website.
  • Unzip the downloaded file onto your hard drive and launch the installation program double-clicking on it.
  • Follow the on-screen instructions.
Development Tools Configuration
Learn about how to configure Barcode Professional SDK for .NET with most popular .NET Development Tools.
  • How to configure Barcode Professional SDK for .NET in Microsoft Visual Studio and Express Editions...

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Visual Studio .NET Configuration

Neodynamic Barcode Professional SDK for .NET
Microsoft Visual Studio Configuration
  • Launch Visual Studio or any Visual Studio free Edition.
  • Create a new .NET project. For example, a Windows Forms Application or an ASP.NET Web Application project.
  • Add a reference to Neodynamic.SDK.Barcode.dll assembly (Project > Add Reference... OR Website > Add Reference...).
  • Select .NET tab. You should find the Neodynamic.SDK.Barcode.dll assembly listed.
    If you cannot find it...

    • Select Browse tab, and navigate to the folder you installed it to.
    • Browse to the Redistributable folder, and select the folder that matches the version of .NET Framework you are using.
    • Select Neodynamic.SDK.Barcode.dll from that dialog.
    • Click on OK button.
    Double-click on Barcode Professional assembly to select it, then click on OK.
  • The Barcode Professional assembly should now appear referenced to your project. You can now use Barcode Professional classes in your code.
  • Take a look at our Step-By-Step Guides & Articles at http://www.neodynamic.com/products/barcode/sdk-vb-net-csharp/articles/

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


First Steps with Barcode Professional SDK for .NET

Neodynamic Barcode Professional SDK for .NET
First Steps with Barcode Professional SDK for .NET
Barcode Professional SDK for .NET can be used in Visual Studio IDE for adding high quality barcode generation and printing support to your .NET Applications. Basically, when you need barcode features in an application, you must know what Barcode Symbology you need to generate as well as what data will be encoded into the barcode. Both information needs to be specified to Barcode Professional through the Symbology and Code properties respectively.
A simple barcode application sample
Suppose you need to encode a Code 128 barcode based on the data entered by a user into a TextBox in a Windows Forms application. Follows these steps:
  • Open Visual Studio and create a new Windows Forms project using your preferred .NET language VB or C#.
  • Drag a TextBox, a Button and a PictureBox control from VS toolbox onto the Form.
  • In your project, add a Reference to Neodynamic.SDK.Barcode.dll assembly.
  • Encoding a Code 128 barcode based on the specified value by the user. Double click on the Button control and add this code inside Click event.

    VB.NET
    Dim myBarcode As New Neodynamic.SDK.Barcode.BarcodeProfessional()
myBarcode.Symbology = Neodynamic.SDK.Barcode.Symbology.Code128
myBarcode.Code = Me.TextBox1.Text
Me.PictureBox1.Image = myBarcode.GetBarcodeImage()

    C#
    Neodynamic.SDK.Barcode.BarcodeProfessional myBarcode = new Neodynamic.SDK.Barcode.BarcodeProfessional();
myBarcode.Symbology = Neodynamic.SDK.Barcode.Symbology.Code128;
myBarcode.Code = this.TextBox1.Text;
this.PictureBox1.Image = myBarcode.GetBarcodeImage();
  • That's it. Just hit F5 to run your app. Then enter any text and clicking on the button, the barcode will be generated for such specified data.

Online Samples
We've developed many samples using Barcode Professional SDK for .NET in order to help you getting started.

The online up to date Step-By-Step Guides are available at http://www.neodynamic.com/products/barcode/sdk-vb-net-csharp/articles/

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Online Samples

Neodynamic Barcode Professional SDK for .NET
Neodynamic Barcode Professional SDK for .NET Online Samples
We've developed many samples using Barcode Professional SDK for .NET in order to help you getting started.

The online up to date Step-By-Step Guides are available at http://www.neodynamic.com/products/barcode/sdk-vb-net-csharp/articles/

Visit Neodynamic's website.

Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Printing Guide

Neodynamic Barcode Professional SDK for .NET
Barcode Professional Printing Guide

Overview
As you probably already know, most printing jobs within .NET Framework are performed by using the PrintDocument class which is part of System.Drawing.Printing namespace. The PrintDocument class is used to set the properties that describe what and where to print content such us strings, images and so on.
The main method the PrintDocument class features is Print which starts the document's printing process. After Print method is invoked, the PrintDocument raises a PrintPage event for each page to be printed. Here is where you should add your printing logic to an event handler for that event.

If your application needs to feature barcoding capabilities, it's also probably that printing documents containing barcode images are required as well.
BarcodeProfessional class features an overloaded method called DrawOnCanvas which lets you to draw the barcode image on any GDI+ Graphics object - an instance of System.Drawing.Graphics class. The PrintDocument's PrintPage event exposes a Graphics object where to paint the page content and here is where that Graphics object must be passed to the DrawOnCanvas method in order to get the barcode image printed.

This guide describes common scenarios regarding barcode printing using the PrintDocument class and Barcode Professional's DrawOnCanvas method:
  • How to print barcodes using PrintDocument class
  • How to print scaled barcodes using PrintDocument class
  • How to print barcodes that need to fit a given area using PrintDocument class

How to print barcodes using PrintDocument class
This is the simplest barcode printing scenario. Here, the Graphics object exposed by PrintDocument's PrintPage event must be passed to the Barcode Professional's DrawOnCanvas method in order to get the barcode printed at the specified point (x, y).

Example
Supposing you have already set an event handler for the PrintDocument's PrintPage event, the following code inside that handler procedure will create a Barcode Professional object and will print the generated barcode at the specified location (in this case x=1in, y=1in) in the document/page. IMPORTANT: The unit of measure for the barcode location/point must be specified to BarcodeUnit property of BarcodeProfessional object. By default it is INCH

VB.NET
Private Sub printDocumentObject_PrintPage(sender As Object, e As  System.Drawing.Printing.PrintPageEventArgs)
    'Create a Barcode Professional object
    Dim bcp As New BarcodeProfessional()
    'Barcode settings
    bcp.Symbology = Symbology.Code39
    bcp.Code = "123456789"
    '...
    'Print the barcode at x=1in, y=1in using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, New PointF(1, 1))
End Sub
C#
private void printDocumentObject_PrintPage(object sender, System.Drawing.Printing.PrintPageEventArgs e)
{
    //Create a Barcode Professional object
    BarcodeProfessional bcp = new BarcodeProfessional();
    //Barcode settings
    bcp.Symbology = Symbology.Code39;
    bcp.Code = "123456789";
    //...
    //Print the barcode at x=1in, y=1in using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, new PointF(1, 1));
}

How to print scaled barcodes using PrintDocument class
One version of DrawOnCanvas method lets you to print a scaled barcode image by specifying the scale parameter. For instance, if you want to scale down the original barcode to 50%, then the scale parameter must be specified as 0.5; if you want to scale up the original barcode to 200%, then the scale parameter must be specified as 2; and so on.

As the previous scenario, the Graphics object exposed by PrintDocument's PrintPage event must be passed to the Barcode Professional's DrawOnCanvas method in order to get the barcode printed at the specified point (x, y) and scaled at the specified value.

Example
Supposing you have already set an event handler for the PrintDocument's PrintPage event, the following code inside that handler procedure will create a Barcode Professional object and will print the generated barcode scaled down at 50% at the specified location (in this case x=2in, y=3in) in the document/page. IMPORTANT: The unit of measure for the barcode location/point must be specified to BarcodeUnit property of BarcodeProfessional object. By default it is INCH

VB.NET
Private Sub printDocumentObject_PrintPage(sender As Object, e As  System.Drawing.Printing.PrintPageEventArgs)
    'Create a Barcode Professional object
    Dim bcp As New BarcodeProfessional()
    'Barcode settings
    bcp.Symbology = Symbology.Code39
    bcp.Code = "123456789"
    '...
    'Print the barcode at x=2in, y=3in and scaled down at 50% using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, New PointF(2, 3), 0.5F)
End Sub
C#
private void printDocumentObject_PrintPage(object sender, System.Drawing.Printing.PrintPageEventArgs e)
{
    //Create a Barcode Professional object
    BarcodeProfessional bcp = new BarcodeProfessional();
    //Barcode settings
    bcp.Symbology = Symbology.Code39;
    bcp.Code = "123456789";
    //...
    //Print the barcode at x=2in, y=3in and scaled down at 50% using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, new PointF(2, 3), 0.5f);
}

How to print barcodes that need to fit a given area using PrintDocument class
It's very common to need to print the barcode in order it fits a given area, for instance: The barcode must be printed on an area of size 1.5 inch x 1 inch.
One version of DrawOnCanvas method lets you to accomplish that by specifying the target area through barsAreaSize parameter. Keep in mind the following points about the target area:
  • The target area's size (width and height) is measured in unit specified to BarcodeUnit property of the BarcodeProfessional object involved. By default it is INCH
  • The target area involves:

    • Width: it includes the barcode bars width plus left and right Quiet Zones (QuietZoneWidth property)
    • Height: it includes the barcode bar's height only
The target area on which the barcode must be drawn
The target area on which the barcode must be drawn

Again, as in the previous scenarios, the Graphics object exposed by PrintDocument's PrintPage event must be passed to the Barcode Professional's DrawOnCanvas method in order to get the barcode printed fitting the specified area.

Example
Supposing you have already set an event handler for the PrintDocument's PrintPage event, the following code inside that handler procedure will create a Barcode Professional object and will print the generated barcode in order it fits an area of size 2 inch x 1 inch.

VB.NET
Private Sub printDocumentObject_PrintPage(sender As Object, e As  System.Drawing.Printing.PrintPageEventArgs)
    'Create a Barcode Professional object
    Dim bcp As New BarcodeProfessional()
    'Barcode settings
    bcp.Symbology = Symbology.Code39
    bcp.Code = "123456789"
    'Set Quiet Zone to zero
    bcp.QuietZoneWidth = 0
    '...
    'Print the barcode to fit an area of size 2x1in using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, New PointF(0,0), New SizeF(2,1))
End Sub
C#
private void printDocumentObject_PrintPage(object sender, System.Drawing.Printing.PrintPageEventArgs e)
{
    //Create a Barcode Professional object
    BarcodeProfessional bcp = new BarcodeProfessional();
    //Barcode settings
    bcp.Symbology = Symbology.Code39;
    bcp.Code = "123456789";
    //Set Quiet Zone to zero
    bcp.QuietZoneWidth = 0;
    //...
    //Print the barcode to fit an area of size 2x1in using DrawOnCanvas method
    bcp.DrawOnCanvas(e.Graphics, new PointF(0,0), new SizeF(2,1));
}

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Barcode Symbologies

Neodynamic Barcode Professional SDK for .NET
Linear (1D), Postal and 2D Symbologies

"A bar code (also barcode) is an optical machine-readable representation of data. Originally, bar codes represented data in the widths (lines) and the spacings of parallel lines and may be referred to as linear or 1D (1 dimensional) barcodes or symbologies. But they also come in patterns of squares, dots, hexagons and other geometric patterns within images termed 2D (2 dimensional) matrix codes or symbologies. In spite of there being no bars, 2D systems are generally referred to as barcodes as well." Wikipedia, The Free Encyclopedia.

Barcode Professional supports many of the most popular Barcode Symbologies available today, Linear (1D), Postal and 2D Symbologies

Visit Neodynamic's website.

Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Neodynamic.SDK.Barcode Namespace

Neodynamic.SDK.Barcode Namespace Neodynamic Barcode Professional SDK for .NET Class Reference
Classes
 | Class | Description
Public class | BarcodeException | Represents errors that occur during barcode generation process
Public class | BarcodeProfessional | Neodynamic Barcode Professional allows you to quickly and easily add barcodes into any .NET applications.
Public class | BarcodeUtils | BarcodeUtils provides additional utilities related to barcode generation.
Public class | EpsCmykBarcodeColors | Represents all CMYK barcode colors used in EPS (Encapsulated PostScript) generation.
Public class | Margin | Represents margin information.
Structures
 | Structure | Description
Public structure | EpsCmykColor | Represents a CMYK (Cyan, Magenta, Yellow, and Key/Black) color.
Enumerations
 | Enumeration | Description
Public enumeration | Alignment | Specifies the text alignment on the barcode image
Public enumeration | AztecCodeFormat | Specifies the Aztec Code Format to use on that symbology.
Public enumeration | BarcodeUnit | Specifies the unit of measure for barcode generation.
Public enumeration | BearerBarStyle | Specifies the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.
Public enumeration | CodabarStartStopChar | Specifies the start and stop character for Codabar symbology.
Public enumeration | Code128 | Specifies the characters set to use in the Code 128 symbology.
Public enumeration | Code16k | Specifies the mode to use for Code16k symbology.
Public enumeration | DataMatrixEncoding | Specifies the DataMatrix Encoding to use on that symbology.
Public enumeration | DataMatrixFormat | Specifies the DataMatrix Format to use on that symbology.
Public enumeration | FIM | Specifies the facing identification mark (FIM) pattern to use on that symbology.
Public enumeration | HanXinCodeEncoding | Specifies the Han Xin Code Encoding to use on that symbology.
Public enumeration | HanXinCodeErrorCorrectionLevel | Specifies the Error Correction Level to apply for Han Xin Code symbology.
Public enumeration | HanXinCodeVersion | Specifies the Han Xin Code Version to use on that symbology. Version 1 (23 x 23 modules) to Version 84 (189 x 189 modules) increasing in steps of two modules per side.
Public enumeration | Isbt128DataStructure | Specifies the ISBT 128 Data Structures.
Public enumeration | ItfHmark | Specifies the seven type of H marks for ITF symbology.
Public enumeration | LogoPosition | Specified the position of a logo image on the barcode symbol.
Public enumeration | MaxiCodeModes | Specifies the MaxiCode modes.
Public enumeration | MicroPdf417Version | Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public enumeration | MicroQRCodeVersion | Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.
Public enumeration | MsiChecksum | Specifies the checksum method used for MSI barcodes
Public enumeration | Pdf417CompactionType | Specifies the Compaction Type to apply for PDF417 symbology.
Public enumeration | Pdf417ErrorCorrection | Specifies the Error Correction Level to apply for PDF417 symbology.
Public enumeration | QRCodeEncoding | Specifies the QR Code Encoding to use on that symbology.
Public enumeration | QRCodeErrorCorrectionLevel | Specifies the Error Correction Level to apply for QR Code symbology.
Public enumeration | QRCodeVersion | Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.
Public enumeration | Rotate | Specifies the rotation angle to apply on the barcode image. It is measured clockwise from the x-axis.
Public enumeration | Supplement | Specifies the supplement type to use with EAN and UPC symbologies.
Public enumeration | Symbology | Specifies the Barcode Symbology to be used.
Public enumeration | TelepenEncoding | Specifies the Telepen Encoding to use on that symbology.
Public enumeration | TiffCompression | Specifies the TIFF compression algorithm to be used when saving barcodes in such image format.
Public enumeration | UpcE | Specifies the number system to use for UPC-E symbology.

Neodynamic Barcode Professional SDK 5.0 for .NET Documentation Copyright © 2003-2016 Neodynamic - All rights reserved.

Send Feedback on this topic to http://www.neodynamic.com/support.


Alignment Enumeration

Alignment Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the text alignment on the barcode image

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Alignment
public enum Alignment
Public Enumeration Alignment
Public Enumeration Alignment
public enum class Alignment
public enum class Alignment
type Alignment
type Alignment
Members
Member name | Value | Description
AboveCenter | 0 |
AboveLeft | 1 |
AboveRight | 2 |
AboveJustify | 3 |
BelowCenter | 4 |
BelowLeft | 5 |
BelowRight | 6 |
BelowJustify | 7 |
See Also
Neodynamic.SDK.Barcode Namespace


AztecCodeFormat Enumeration

AztecCodeFormat Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Aztec Code Format to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum AztecCodeFormat
public enum AztecCodeFormat
Public Enumeration AztecCodeFormat
Public Enumeration AztecCodeFormat
public enum class AztecCodeFormat
public enum class AztecCodeFormat
type AztecCodeFormat
type AztecCodeFormat
Members
Member name | Value | Description
Auto | 0 |
C15X15Compact | 1 |
C19X19 | 2 |
C19X19Compact | 3 |
C23X23 | 4 |
C23X23Compact | 5 |
C27X27 | 6 |
C27X27Compact | 7 |
C31X31 | 8 |
C37X37 | 9 |
C41X41 | 10 |
C45X45 | 11 |
C49X49 | 12 |
C53X53 | 13 |
C57X57 | 14 |
C61X61 | 15 |
C67X67 | 16 |
C71X71 | 17 |
C75X75 | 18 |
C79X79 | 19 |
C83X83 | 20 |
C87X87 | 21 |
C91X91 | 22 |
C95X95 | 23 |
C101X101 | 24 |
C105X105 | 25 |
C109X109 | 26 |
C113X113 | 27 |
C117X117 | 28 |
C121X121 | 29 |
C125X125 | 30 |
C131X131 | 31 |
C135X135 | 32 |
C139X139 | 33 |
C143X143 | 34 |
C147X147 | 35 |
C151X151 | 36 |
See Also


BarcodeException Class

BarcodeException Class Neodynamic Barcode Professional SDK for .NET Class Reference
Represents errors that occur during barcode generation process
Inheritance Hierarchy
Online System Object
Online System Exception
Neodynamic.SDK.Barcode BarcodeException

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BarcodeException : Exception
public class BarcodeException : Exception
Public Class BarcodeException
    Inherits Exception
Public Class BarcodeException
    Inherits Exception
public ref class BarcodeException : public Exception
public ref class BarcodeException : public Exception
type BarcodeException =
    class
        inherit Exception
    end
type BarcodeException =
    class
        inherit Exception
    end
See Also
BarcodeException Members


BarcodeException Members

BarcodeException Members Neodynamic Barcode Professional SDK for .NET Class Reference

The BarcodeException type exposes the following members.
Constructors
 | Name | Description
Public method | BarcodeException(Int32) | Initializes a new instance of the BarcodeException class
Public method | BarcodeException(Int32, String) | Initializes a new instance of the BarcodeException class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
Fields
Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
GS1_INVALID_DATA |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |
Back to Top
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | ErrorCode |
 | Errors |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BarcodeException Class


BarcodeException Constructor

BarcodeException Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | BarcodeException(Int32) | Initializes a new instance of the BarcodeException class
Public method | BarcodeException(Int32, String) | Initializes a new instance of the BarcodeException class
Back to Top
See Also
BarcodeException Class
BarcodeException Members


BarcodeException Constructor (Int32)

BarcodeException Constructor (Int32) Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the BarcodeException class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BarcodeException(
    int errorCode
)
public BarcodeException(
    int errorCode
)
Public Sub New (
    errorCode As Integer
)
Public Sub New (
    errorCode As Integer
)
public:
BarcodeException(
    int errorCode
)
public:
BarcodeException(
    int errorCode
)
new :
        errorCode : int -> BarcodeException
new :
        errorCode : int -> BarcodeException

Parameters

errorCode
Type: Online System Int32
See Also
BarcodeException Class
BarcodeException Members
BarcodeException Overload


BarcodeException Constructor (Int32, String)

BarcodeException Constructor (Int32, String) Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the BarcodeException class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BarcodeException(
    int errorCode,
    string message
)
public BarcodeException(
    int errorCode,
    string message
)
Public Sub New (
    errorCode As Integer,
    message As String
)
Public Sub New (
    errorCode As Integer,
    message As String
)
public:
BarcodeException(
    int errorCode,
    String^ message
)
public:
BarcodeException(
    int errorCode,
    String^ message
)
new :
        errorCode : int *
        message : string -> BarcodeException
new :
        errorCode : int *
        message : string -> BarcodeException

Parameters

errorCode
Type: Online System Int32
message
Type: Online System String
See Also
BarcodeException Class
BarcodeException Members
BarcodeException Overload


BarcodeException Fields

BarcodeException Fields Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeException type exposes the following members.
Fields
Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
GS1_INVALID_DATA |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |
Back to Top
See Also
BarcodeException Class


BarcodeException.CHECKSUM_GEN_FAILED Field

BarcodeException CHECKSUM_GEN_FAILED Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CHECKSUM_GEN_FAILED
public const int CHECKSUM_GEN_FAILED
Public Const CHECKSUM_GEN_FAILED As Integer
Public Const CHECKSUM_GEN_FAILED As Integer
public:
literal int CHECKSUM_GEN_FAILED
public:
literal int CHECKSUM_GEN_FAILED
static val mutable CHECKSUM_GEN_FAILED: int
static val mutable CHECKSUM_GEN_FAILED: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.CODE_GEN_FAILED Field

BarcodeException CODE_GEN_FAILED Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CODE_GEN_FAILED
public const int CODE_GEN_FAILED
Public Const CODE_GEN_FAILED As Integer
Public Const CODE_GEN_FAILED As Integer
public:
literal int CODE_GEN_FAILED
public:
literal int CODE_GEN_FAILED
static val mutable CODE_GEN_FAILED: int
static val mutable CODE_GEN_FAILED: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID Field

BarcodeException CODE_NOT_VALID Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CODE_NOT_VALID
public const int CODE_NOT_VALID
Public Const CODE_NOT_VALID As Integer
Public Const CODE_NOT_VALID As Integer
public:
literal int CODE_NOT_VALID
public:
literal int CODE_NOT_VALID
static val mutable CODE_NOT_VALID: int
static val mutable CODE_NOT_VALID: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID_IN_CC Field

BarcodeException CODE_NOT_VALID_IN_CC Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CODE_NOT_VALID_IN_CC
public const int CODE_NOT_VALID_IN_CC
Public Const CODE_NOT_VALID_IN_CC As Integer
Public Const CODE_NOT_VALID_IN_CC As Integer
public:
literal int CODE_NOT_VALID_IN_CC
public:
literal int CODE_NOT_VALID_IN_CC
static val mutable CODE_NOT_VALID_IN_CC: int
static val mutable CODE_NOT_VALID_IN_CC: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field

BarcodeException CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
public const int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
Public Const CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT As Integer
Public Const CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT As Integer
public:
literal int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
public:
literal int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
static val mutable CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT: int
static val mutable CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NULL_OR_EMPTY Field

BarcodeException CODE_NULL_OR_EMPTY Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int CODE_NULL_OR_EMPTY
public const int CODE_NULL_OR_EMPTY
Public Const CODE_NULL_OR_EMPTY As Integer
Public Const CODE_NULL_OR_EMPTY As Integer
public:
literal int CODE_NULL_OR_EMPTY
public:
literal int CODE_NULL_OR_EMPTY
static val mutable CODE_NULL_OR_EMPTY: int
static val mutable CODE_NULL_OR_EMPTY: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.DATA_OVERFLOW Field

BarcodeException DATA_OVERFLOW Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DATA_OVERFLOW
public const int DATA_OVERFLOW
Public Const DATA_OVERFLOW As Integer
Public Const DATA_OVERFLOW As Integer
public:
literal int DATA_OVERFLOW
public:
literal int DATA_OVERFLOW
static val mutable DATA_OVERFLOW: int
static val mutable DATA_OVERFLOW: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.DATAMATRIX_INVALID_FILE_ID Field

BarcodeException DATAMATRIX_INVALID_FILE_ID Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int DATAMATRIX_INVALID_FILE_ID
public const int DATAMATRIX_INVALID_FILE_ID
Public Const DATAMATRIX_INVALID_FILE_ID As Integer
Public Const DATAMATRIX_INVALID_FILE_ID As Integer
public:
literal int DATAMATRIX_INVALID_FILE_ID
public:
literal int DATAMATRIX_INVALID_FILE_ID
static val mutable DATAMATRIX_INVALID_FILE_ID: int
static val mutable DATAMATRIX_INVALID_FILE_ID: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.GS1_INVALID_DATA Field

BarcodeException GS1_INVALID_DATA Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int GS1_INVALID_DATA
public const int GS1_INVALID_DATA
Public Const GS1_INVALID_DATA As Integer
Public Const GS1_INVALID_DATA As Integer
public:
literal int GS1_INVALID_DATA
public:
literal int GS1_INVALID_DATA
static val mutable GS1_INVALID_DATA: int
static val mutable GS1_INVALID_DATA: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED Field

BarcodeException PROCESS_TILDE_FAILED Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED
public const int PROCESS_TILDE_FAILED
Public Const PROCESS_TILDE_FAILED As Integer
Public Const PROCESS_TILDE_FAILED As Integer
public:
literal int PROCESS_TILDE_FAILED
public:
literal int PROCESS_TILDE_FAILED
static val mutable PROCESS_TILDE_FAILED: int
static val mutable PROCESS_TILDE_FAILED: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_DEC As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_DEC As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_DEC: int
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_DEC: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_HEX As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_HEX As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_HEX: int
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_HEX: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI: int
static val mutable PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
public const int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
Public Const PROCESS_TILDE_FAILED_INVALID_DM_MACRO As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_DM_MACRO As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
static val mutable PROCESS_TILDE_FAILED_INVALID_DM_MACRO: int
static val mutable PROCESS_TILDE_FAILED_INVALID_DM_MACRO: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_PR Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_DM_PR Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_DM_PR
public const int PROCESS_TILDE_FAILED_INVALID_DM_PR
Public Const PROCESS_TILDE_FAILED_INVALID_DM_PR As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_DM_PR As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_PR
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_PR
static val mutable PROCESS_TILDE_FAILED_INVALID_DM_PR: int
static val mutable PROCESS_TILDE_FAILED_INVALID_DM_PR: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_ECI Field

BarcodeException PROCESS_TILDE_FAILED_INVALID_ECI Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int PROCESS_TILDE_FAILED_INVALID_ECI
public const int PROCESS_TILDE_FAILED_INVALID_ECI
Public Const PROCESS_TILDE_FAILED_INVALID_ECI As Integer
Public Const PROCESS_TILDE_FAILED_INVALID_ECI As Integer
public:
literal int PROCESS_TILDE_FAILED_INVALID_ECI
public:
literal int PROCESS_TILDE_FAILED_INVALID_ECI
static val mutable PROCESS_TILDE_FAILED_INVALID_ECI: int
static val mutable PROCESS_TILDE_FAILED_INVALID_ECI: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.REED_SOLOMON_GEN_FAILED Field

BarcodeException REED_SOLOMON_GEN_FAILED Field Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const int REED_SOLOMON_GEN_FAILED
public const int REED_SOLOMON_GEN_FAILED
Public Const REED_SOLOMON_GEN_FAILED As Integer
Public Const REED_SOLOMON_GEN_FAILED As Integer
public:
literal int REED_SOLOMON_GEN_FAILED
public:
literal int REED_SOLOMON_GEN_FAILED
static val mutable REED_SOLOMON_GEN_FAILED: int
static val mutable REED_SOLOMON_GEN_FAILED: int

Field Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException Methods

BarcodeException Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeException type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetBaseException | When overridden in a derived class, returns the Online Exception that is the root cause of one or more subsequent exceptions. (Inherited from Online Exception.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetObjectData | When overridden in a derived class, sets the Online SerializationInfo with information about the exception. (Inherited from Online Exception.)
Public method | Online GetType | Gets the runtime type of the current instance. (Inherited from Online Exception.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Creates and returns a string representation of the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BarcodeException Class


BarcodeException Properties

BarcodeException Properties Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeException type exposes the following members.
Properties
 | Name | Description
Public property | Online Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Online Exception.)
Public property | ErrorCode |
 | Errors |
Public property | Online HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Online Exception.)
Protected property | Online HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Online Exception.)
Public property | Online InnerException | Gets the Online Exception instance that caused the current exception. (Inherited from Online Exception.)
Public property | Online Message | Gets a message that describes the current exception. (Inherited from Online Exception.)
Public property | Online Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Online Exception.)
Public property | Online StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Online Exception.)
Public property | Online TargetSite | Gets the method that throws the current exception. (Inherited from Online Exception.)
Back to Top
See Also
BarcodeException Class


BarcodeException.ErrorCode Property

BarcodeException ErrorCode Property Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ErrorCode { get; set; }
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
member ErrorCode : int with get, set
member ErrorCode : int with get, set

Property Value

Type: Online Int32
See Also
BarcodeException Class
BarcodeException Members


BarcodeException.Errors Property

BarcodeException Errors Property Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static Dictionary<int, string> Errors { get; }
public static Dictionary<int, string> Errors { get; }
Public Shared ReadOnly Property Errors As Dictionary(Of Integer, String)
    Get
Public Shared ReadOnly Property Errors As Dictionary(Of Integer, String)
    Get
public:
static property Dictionary<int, String^>^ Errors {
    Dictionary<int, String^>^ get ();
}
public:
static property Dictionary<int, String^>^ Errors {
    Dictionary<int, String^>^ get ();
}
static member Errors : Dictionary<int, string> with get
static member Errors : Dictionary<int, string> with get

Property Value

Type: Online Dictionary Online Int32, Online String
See Also
BarcodeException Class
BarcodeException Members


BarcodeProfessional Class

BarcodeProfessional Class Neodynamic Barcode Professional SDK for .NET Class Reference
Neodynamic Barcode Professional allows you to quickly and easily add barcodes into any .NET applications.
Inheritance Hierarchy
Online System Object
Neodynamic.SDK.Barcode BarcodeProfessional

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
[SerializableAttribute]
public class BarcodeProfessional : ISerializable,
    IXmlSerializable, IDisposable, ICloneable
[SerializableAttribute]
public class BarcodeProfessional : ISerializable,
    IXmlSerializable, IDisposable, ICloneable
<SerializableAttribute>
Public Class BarcodeProfessional
    Implements ISerializable, IXmlSerializable, IDisposable, ICloneable
<SerializableAttribute>
Public Class BarcodeProfessional
    Implements ISerializable, IXmlSerializable, IDisposable, ICloneable
[SerializableAttribute]
public ref class BarcodeProfessional : ISerializable,
    IXmlSerializable, IDisposable, ICloneable
[SerializableAttribute]
public ref class BarcodeProfessional : ISerializable,
    IXmlSerializable, IDisposable, ICloneable
[<SerializableAttribute>]
type BarcodeProfessional =
    class
        interface ISerializable
        interface IXmlSerializable
        interface IDisposable
        interface ICloneable
    end
[<SerializableAttribute>]
type BarcodeProfessional =
    class
        interface ISerializable
        interface IXmlSerializable
        interface IDisposable
        interface ICloneable
    end
See Also
BarcodeProfessional Members


BarcodeProfessional Members

BarcodeProfessional Members Neodynamic Barcode Professional SDK for .NET Class Reference

The BarcodeProfessional type exposes the following members.
Constructors
 | Name | Description
Public method | BarcodeProfessional | Initializes a new instance of the BarcodeProfessional class
Protected method | BarcodeProfessional(SerializationInfo, StreamingContext) | Initializes a new instance of the BarcodeProfessional class
Back to Top
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose | Releases all resources used by the BarcodeProfessional
Public method | DrawOnCanvas(Graphics) | Draws the barcode onto the graphics object at the origin point.
Public method | DrawOnCanvas(Graphics, PointF) | Draws the barcode onto the graphics object at the given point.
Public method | DrawOnCanvas(Graphics, PointF, SizeF) | Draws the barcode onto the specified graphics object fitting the bars into the specified size.
Public method | DrawOnCanvas(Graphics, PointF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Public method | DrawOnCanvas(Graphics, PointF, SizeF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBarcodeImage | Gets a System.Drawing.Image object of the barcode image.
Public method | GetBarcodeImage(ImageFormat) | Gets a byte array that represents the barcode image.
Public method | GetBarcodeImage(Single) | Gets a System.Drawing.Image object of the barcode image at the specified resolution.
Public method | GetBarcodeImage(ImageFormat, Single) | Gets a byte array that represents the barcode image at the specified resolution.
Public method | GetBarcodeImage(Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolution.
Public method | GetBarcodeImage(Single, Single) | Gets a System.Drawing.Image object of the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size.
Public method | GetBarcodeImage(ImageFormat, Single, Single) | Gets a byte array that represents the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(Single, Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size and resolutions.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetObjectData |
Public method | GetSchema |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadXml |
Public method | Save(Stream, ImageFormat) | Saves this barcode image to the specified Stream object in the specified format.
Public method | Save(String, ImageFormat) | Saves this barcode image to the specified file in the specified format.
Public method | Save(Stream, ImageFormat, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Public method | Save(Stream, ImageFormat, Single, SizeF) | Saves this barcode image to the specified Stream object in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(Stream, ImageFormat, Single, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single, SizeF) | Saves this barcode image to the specified file in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(String, ImageFormat, Single, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Public method | SaveEps(Stream, Encoding) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format.
Public method | SaveEps(String, Encoding) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(Stream, Encoding, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(String, Encoding, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteXml |
Back to Top
Fields
Name | Description
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
EOT | End Of Transmission character (ASCII 4).
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
GS | Group Separator character (ASCII 29).
RS | Record Separator character (ASCII 30).
Back to Top
Properties
 | Name | Description
Public property | AddChecksum | Gets or sets whether checksum must be generated and attached to the value to encode.
Public property | AntiAlias | Gets or sets whether AntiAlias effect must be applied to all the texts in the barcode image.
Public property | ArtBarImagePattern | Gets or sets the image file (path or Base64 string) that will be used as a pattern to fill all the bars that compose the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.
Public property | ArtLogoImage | Gets or sets the logo image file (path or Base64 string) that will be used to stamp it on top or bottom of the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.
Public property | ArtLogoImageOpacity | Gets or sets the opacity [from 1 to 100 (fully opaque)] of the image logo file. Default is 100.
Public property | ArtLogoImagePercentage | Gets or sets the percentage used to resize the logo image based on the barcode symbol size. Default is 20.
Public property | ArtLogoImagePosition | Gets or sets the position of the logo image file on the barcode symbol. Default is Top.
Public property | AutoSize | Gets or sets whether the barcode image is automatically resized to display its entire contents.
Public property | AztecCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Aztec Code in Byte Compaction mode. Default it ISO-8859-1.
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology.
Public property | AztecCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character should be processed when Aztec Code is being generated.
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.
Public property | BackColor | Gets or sets the background color.
Public property | BarcodePadding | Gets or sets the extra space inside the border. The unit of measure must be specified to BarcodeUnit property.
Public property | BarcodeUnit | Gets or sets the unit of measure for the barcode dimensions. Defauls is Inch. It must precede any barcode dimension properties settings.
Public property | BarColor | Gets or sets the bars' color of the barcode.
Public property | BarHeight | Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is called N value.
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is called X value. The unit of measure must be specified to BarcodeUnit property.
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment.
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.
Public property | BearerBarWidth | Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.
Public property | BorderColor | Gets or sets the barcode border's color.
Public property | BorderWidth | Gets or sets the barcode border's width. The unit of measure must be specified to BarcodeUnit property.
Public property | BottomMargin | Gets or sets the height of the margin below the barcode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.
Public property | Code | Gets or sets the value to encode.
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.
Public property | CodeAlignment | Gets or sets the text alignment for Code and HumanReadableText properties.
Public property | CodeFormatPattern | Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).
Public property | DataMatrixByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default it ISO-8859-1.
Public property | DataMatrixEncoding | Gets or sets the DataMatrix Encoding to use on that symbology.
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.
Public property | DataMatrixFormat | Gets or sets the DataMatrix Format to use on that symbology.
Public property | DataMatrixModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character should be processed when DataMatrix code is being generated.
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode in the barcode image.
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed in the barcode image.
Public property | DisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed in the barcode image.
Public property | EanUpcAutoBWAfor1278DigitsEnabled | Gets or sets whether the recommended Bar Width Adjustment for digits 1, 2, 7 and 8 by GS1 spec is enabled. Default is False.
Public property | EanUpcMagnificationFactor | Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies.
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies.
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the EAN/UPC barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Extended | Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.
Public property | Font | Gest or sets the Font object for using when rendering Code and HumanReadableText properties.
Public property | ForeColor | Gets or sets the text color for using when rendering Code and HumanReadableText properties.
Public property | GS1DataStrictValidation | Gets or sets whether to strictly validate the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. Default is false.
Public property | GuardBar | Gets or sets whether EAN/UPC guard bars must be drawn.
Public property | GuardBarHeight | Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.
Public property | HanXinCodeEncoding | Gets or sets the Han Xin Code Encoding to use on that symbology.
Public property | HanXinCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for Han Xin Code symbology.
Public property | HanXinCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeProcessTilde | Gets or sets whether tilde character should be processed when Han Xin Code is being generated.
Public property | HanXinCodeVersion | Gets or sets the Han Xin Code Version to use on that symbology.
Public property | Height | Gets or sets the height of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
Public property | HibcUseIsoIec15434Encoding | Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.
Public property | Image | Gets a System.Drawing.Image object of the barcode image.
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated.
Public property | IsCodeValid | Gets a value indicating whether the value to encode specified in the Code property is valid based on the Barcode Symbology specified in the Symbology property.
Public property | Itf14LeftHMark | Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.
Public property | Itf14RightHMark | Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.
 | LicenseKey | Gets or sets the License Key.
 | LicenseOwner | Gets or sets the License Owner.
Public property | MaxiCodeDrawPixelBasedSymbol | Gets or sets whether the MaxiCode symbol is drawn by using a Pixel Based method; otherwise, a Vector based method is used.
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode.
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character should be processed when MaxiCode code is being generated.
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.
Public property | MICRCharHeight | Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.
Public property | MICRCharSpacing | Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.
Public property | MICRCharWidths | Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology.
Public property | Monochrome | Gets or sets a value indicating whether the barcode image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology.
Public property | OutputSettings | Gets a list of settings that were used to generate the selected symbology.
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).
Public property | Pdf417ByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default it ISO-8859-1.
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology.
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology.
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology.
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology.
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed).
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn in the barcode image.
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default it ISO-8859-1.
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology.
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology.
Public property | QRCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeProcessTilde | Gets or sets whether tilde character should be processed when QR Code is being generated.
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology.
Public property | QuietZoneWidth | Gets or sets the quiet zone's width. The unit of measure must be specified to BarcodeUnit property.
Public property | Rotate | Gets or sets the rotation angle to apply on the barcode image.
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether barcode drawing should use device-specific pixel settings during rendering. Default value is false.
Public property | Symbology | Gets or sets the barcode symbology to generate.
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology.
Public property | Text | Gets or sets the additional text to show in the barcode image e.g.: Product ID. Note: This is not the value to encode nor the Human Readable Text.
Public property | TextAlignment | Gets or sets the text alignment for Text property.
Public property | TextFont | Gest or sets the Font object for using when rendering Text property.
Public property | TextForeColor | Gets or sets the text color for using when rendering Text property.
Public property | TextFormatPattern | Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).
Public property | TextRenderingHint | Gets or sets the quality of the text rendering. Note: it is available if AntiAlias property is False. Default is SystemDefault.
Public property | TiffCompression | Gets or sets the TIFF compression algorithm to be used when saving barcodes in such image format.
Public property | TopMargin | Gets or sets the height of the margin above the barcode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology.
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology.
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn.
Public property | Width | Gets or sets the width of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.
Back to Top
See Also
BarcodeProfessional Class


BarcodeProfessional Constructor

BarcodeProfessional Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | BarcodeProfessional | Initializes a new instance of the BarcodeProfessional class
Protected method | BarcodeProfessional(SerializationInfo, StreamingContext) | Initializes a new instance of the BarcodeProfessional class
Back to Top
See Also


BarcodeProfessional Constructor

BarcodeProfessional Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the BarcodeProfessional class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BarcodeProfessional()
public BarcodeProfessional()
Public Sub New
Public Sub New
public:
BarcodeProfessional()
public:
BarcodeProfessional()
new : unit -> BarcodeProfessional
new : unit -> BarcodeProfessional
See Also
BarcodeProfessional Overload


BarcodeProfessional Constructor (SerializationInfo, StreamingContext)

BarcodeProfessional Constructor (SerializationInfo, StreamingContext) Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the BarcodeProfessional class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
protected BarcodeProfessional(
    SerializationInfo info,
    StreamingContext context
)
protected BarcodeProfessional(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
protected:
BarcodeProfessional(
    SerializationInfo^ info,
    StreamingContext context
)
protected:
BarcodeProfessional(
    SerializationInfo^ info,
    StreamingContext context
)
new :
        info : SerializationInfo *
        context : StreamingContext -> BarcodeProfessional
new :
        info : SerializationInfo *
        context : StreamingContext -> BarcodeProfessional

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext
See Also
BarcodeProfessional Overload


BarcodeProfessional Fields

BarcodeProfessional Fields Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeProfessional type exposes the following members.
Fields
Name | Description
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
EOT | End Of Transmission character (ASCII 4).
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
GS | Group Separator character (ASCII 29).
RS | Record Separator character (ASCII 30).
Back to Top
See Also


BarcodeProfessional.AI2 Field

BarcodeProfessional AI2 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char AI2
public const char AI2
Public Const AI2 As Char
Public Const AI2 As Char
public:
literal wchar_t AI2
public:
literal wchar_t AI2
static val mutable AI2: char
static val mutable AI2: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.AI3 Field

BarcodeProfessional AI3 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char AI3
public const char AI3
Public Const AI3 As Char
Public Const AI3 As Char
public:
literal wchar_t AI3
public:
literal wchar_t AI3
static val mutable AI3: char
static val mutable AI3: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.AI4 Field

BarcodeProfessional AI4 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char AI4
public const char AI4
Public Const AI4 As Char
Public Const AI4 As Char
public:
literal wchar_t AI4
public:
literal wchar_t AI4
static val mutable AI4: char
static val mutable AI4: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.AI5 Field

BarcodeProfessional AI5 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char AI5
public const char AI5
Public Const AI5 As Char
Public Const AI5 As Char
public:
literal wchar_t AI5
public:
literal wchar_t AI5
static val mutable AI5: char
static val mutable AI5: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.CODE128_FNC1 Field

BarcodeProfessional CODE128_FNC1 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Function 1 Symbol Character (FNC1) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char CODE128_FNC1
public const char CODE128_FNC1
Public Const CODE128_FNC1 As Char
Public Const CODE128_FNC1 As Char
public:
literal wchar_t CODE128_FNC1
public:
literal wchar_t CODE128_FNC1
static val mutable CODE128_FNC1: char
static val mutable CODE128_FNC1: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.CODE128_FNC2 Field

BarcodeProfessional CODE128_FNC2 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Function 2 Symbol Character (FNC2) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char CODE128_FNC2
public const char CODE128_FNC2
Public Const CODE128_FNC2 As Char
Public Const CODE128_FNC2 As Char
public:
literal wchar_t CODE128_FNC2
public:
literal wchar_t CODE128_FNC2
static val mutable CODE128_FNC2: char
static val mutable CODE128_FNC2: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.CODE128_FNC3 Field

BarcodeProfessional CODE128_FNC3 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Function 3 Symbol Character (FNC3) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char CODE128_FNC3
public const char CODE128_FNC3
Public Const CODE128_FNC3 As Char
Public Const CODE128_FNC3 As Char
public:
literal wchar_t CODE128_FNC3
public:
literal wchar_t CODE128_FNC3
static val mutable CODE128_FNC3: char
static val mutable CODE128_FNC3: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.CODE128_FNC4 Field

BarcodeProfessional CODE128_FNC4 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Function 4 Symbol Character (FNC4) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char CODE128_FNC4
public const char CODE128_FNC4
Public Const CODE128_FNC4 As Char
Public Const CODE128_FNC4 As Char
public:
literal wchar_t CODE128_FNC4
public:
literal wchar_t CODE128_FNC4
static val mutable CODE128_FNC4: char
static val mutable CODE128_FNC4: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.EOT Field

BarcodeProfessional EOT Field Neodynamic Barcode Professional SDK for .NET Class Reference
End Of Transmission character (ASCII 4).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char EOT
public const char EOT
Public Const EOT As Char
Public Const EOT As Char
public:
literal wchar_t EOT
public:
literal wchar_t EOT
static val mutable EOT: char
static val mutable EOT: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.FNC1 Field

BarcodeProfessional FNC1 Field Neodynamic Barcode Professional SDK for .NET Class Reference
Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char FNC1
public const char FNC1
Public Const FNC1 As Char
Public Const FNC1 As Char
public:
literal wchar_t FNC1
public:
literal wchar_t FNC1
static val mutable FNC1: char
static val mutable FNC1: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.GS Field

BarcodeProfessional GS Field Neodynamic Barcode Professional SDK for .NET Class Reference
Group Separator character (ASCII 29).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char GS
public const char GS
Public Const GS As Char
Public Const GS As Char
public:
literal wchar_t GS
public:
literal wchar_t GS
static val mutable GS: char
static val mutable GS: char

Field Value

Type: Online Char
See Also


BarcodeProfessional.RS Field

BarcodeProfessional RS Field Neodynamic Barcode Professional SDK for .NET Class Reference
Record Separator character (ASCII 30).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public const char RS
public const char RS
Public Const RS As Char
Public Const RS As Char
public:
literal wchar_t RS
public:
literal wchar_t RS
static val mutable RS: char
static val mutable RS: char

Field Value

Type: Online Char
See Also


BarcodeProfessional Methods

BarcodeProfessional Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeProfessional type exposes the following members.
Methods
 | Name | Description
Public method | Clone |
Public method | Dispose |
Public method | DrawOnCanvas(Graphics) | Draws the barcode onto the graphics object at the origin point.
Public method | DrawOnCanvas(Graphics, PointF) | Draws the barcode onto the graphics object at the given point.
Public method | DrawOnCanvas(Graphics, PointF, SizeF) | Draws the barcode onto the specified graphics object fitting the bars into the specified size.
Public method | DrawOnCanvas(Graphics, PointF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Public method | DrawOnCanvas(Graphics, PointF, SizeF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | GetBarcodeImage | Gets a System.Drawing.Image object of the barcode image.
Public method | GetBarcodeImage(ImageFormat) | Gets a byte array that represents the barcode image.
Public method | GetBarcodeImage(Single) | Gets a System.Drawing.Image object of the barcode image at the specified resolution.
Public method | GetBarcodeImage(ImageFormat, Single) | Gets a byte array that represents the barcode image at the specified resolution.
Public method | GetBarcodeImage(Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolution.
Public method | GetBarcodeImage(Single, Single) | Gets a System.Drawing.Image object of the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size.
Public method | GetBarcodeImage(ImageFormat, Single, Single) | Gets a byte array that represents the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(Single, Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size and resolutions.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | GetObjectData |
Public method | GetSchema |
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | ReadXml |
Public method | Save(Stream, ImageFormat) | Saves this barcode image to the specified Stream object in the specified format.
Public method | Save(String, ImageFormat) | Saves this barcode image to the specified file in the specified format.
Public method | Save(Stream, ImageFormat, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Public method | Save(Stream, ImageFormat, Single, SizeF) | Saves this barcode image to the specified Stream object in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(Stream, ImageFormat, Single, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single, SizeF) | Saves this barcode image to the specified file in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(String, ImageFormat, Single, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Public method | SaveEps(Stream, Encoding) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format.
Public method | SaveEps(String, Encoding) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(Stream, Encoding, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(String, Encoding, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Public method | WriteXml |
Back to Top
See Also


BarcodeProfessional.Clone Method

BarcodeProfessional Clone Method Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Object Clone()
public Object Clone()
Public Function Clone As Object
Public Function Clone As Object
public:
virtual Object^ Clone() sealed
public:
virtual Object^ Clone() sealed
abstract Clone : unit -> Object
override Clone : unit -> Object
abstract Clone : unit -> Object
override Clone : unit -> Object

Return Value

Type: Online Object

Implements

Online ICloneable Clone
See Also


BarcodeProfessional.Dispose Method

BarcodeProfessional Dispose Method Neodynamic Barcode Professional SDK for .NET Class Reference
Releases all resources used by the BarcodeProfessional

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Dispose()
public void Dispose()
Public Sub Dispose
Public Sub Dispose
public:
virtual void Dispose() sealed
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

Online IDisposable Dispose
See Also


BarcodeProfessional.DrawOnCanvas Method

BarcodeProfessional DrawOnCanvas Method Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | DrawOnCanvas(Graphics) | Draws the barcode onto the graphics object at the origin point.
Public method | DrawOnCanvas(Graphics, PointF) | Draws the barcode onto the graphics object at the given point.
Public method | DrawOnCanvas(Graphics, PointF, SizeF) | Draws the barcode onto the specified graphics object fitting the bars into the specified size.
Public method | DrawOnCanvas(Graphics, PointF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Public method | DrawOnCanvas(Graphics, PointF, SizeF, Single) | Draws the barcode onto the graphics object at the given point and in the specified scale.
Back to Top
See Also


BarcodeProfessional.DrawOnCanvas Method (Graphics)

BarcodeProfessional DrawOnCanvas Method (Graphics) Neodynamic Barcode Professional SDK for .NET Class Reference
Draws the barcode onto the graphics object at the origin point.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawOnCanvas(
    Graphics graphic
)
public void DrawOnCanvas(
    Graphics graphic
)
Public Sub DrawOnCanvas (
    graphic As Graphics
)
Public Sub DrawOnCanvas (
    graphic As Graphics
)
public:
void DrawOnCanvas(
    Graphics^ graphic
)
public:
void DrawOnCanvas(
    Graphics^ graphic
)
member DrawOnCanvas :
        graphic : Graphics -> unit
member DrawOnCanvas :
        graphic : Graphics -> unit

Parameters

graphic
Type: Online System.Drawing Graphics
The Graphics object to draw with.
See Also
DrawOnCanvas Overload


BarcodeProfessional.DrawOnCanvas Method (Graphics, PointF)

BarcodeProfessional DrawOnCanvas Method (Graphics, PointF) Neodynamic Barcode Professional SDK for .NET Class Reference
Draws the barcode onto the graphics object at the given point.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt
)
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt
)
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF -> unit
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF -> unit

Parameters

graphic
Type: Online System.Drawing Graphics
The Graphics object to draw with. The unit of measure must be specified to BarcodeUnit property.
pt
Type: Online System.Drawing PointF
The point on the graphic object to begin drawing the barcode.
See Also
DrawOnCanvas Overload


BarcodeProfessional.DrawOnCanvas Method (Graphics, PointF, SizeF)

BarcodeProfessional DrawOnCanvas Method (Graphics, PointF, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Draws the barcode onto the specified graphics object fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    SizeF barsAreaSize
)
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    SizeF barsAreaSize
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    barsAreaSize As SizeF
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    barsAreaSize As SizeF
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    SizeF barsAreaSize
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    SizeF barsAreaSize
)
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        barsAreaSize : SizeF -> unit
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        barsAreaSize : SizeF -> unit

Parameters

graphic
Type: Online System.Drawing Graphics
The Graphics object to draw with.
pt
Type: Online System.Drawing PointF
The point on the graphic object to begin drawing the barcode. The unit of measure must be specified to BarcodeUnit property.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
DrawOnCanvas Overload


BarcodeProfessional.DrawOnCanvas Method (Graphics, PointF, Single)

BarcodeProfessional DrawOnCanvas Method (Graphics, PointF, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Draws the barcode onto the graphics object at the given point and in the specified scale.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    float scale
)
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    float scale
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    scale As Single
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    scale As Single
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    float scale
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    float scale
)
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        scale : float32 -> unit
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        scale : float32 -> unit

Parameters

graphic
Type: Online System.Drawing Graphics
The Graphics object to draw with. The unit of measure must be specified to BarcodeUnit property.
pt
Type: Online System.Drawing PointF
The point on the graphic object to begin drawing the barcode.
scale
Type: Online System Single
The value to scale the barcode.
See Also
DrawOnCanvas Overload


BarcodeProfessional.DrawOnCanvas Method (Graphics, PointF, SizeF, Single)

BarcodeProfessional DrawOnCanvas Method (Graphics, PointF, SizeF, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Draws the barcode onto the graphics object at the given point and in the specified scale.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    SizeF barsAreaSize,
    float scale
)
public void DrawOnCanvas(
    Graphics graphic,
    PointF pt,
    SizeF barsAreaSize,
    float scale
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    barsAreaSize As SizeF,
    scale As Single
)
Public Sub DrawOnCanvas (
    graphic As Graphics,
    pt As PointF,
    barsAreaSize As SizeF,
    scale As Single
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    SizeF barsAreaSize,
    float scale
)
public:
void DrawOnCanvas(
    Graphics^ graphic,
    PointF pt,
    SizeF barsAreaSize,
    float scale
)
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        barsAreaSize : SizeF *
        scale : float32 -> unit
member DrawOnCanvas :
        graphic : Graphics *
        pt : PointF *
        barsAreaSize : SizeF *
        scale : float32 -> unit

Parameters

graphic
Type: Online System.Drawing Graphics
The Graphics object to draw with. The unit of measure must be specified to BarcodeUnit property.
pt
Type: Online System.Drawing PointF
The point on the graphic object to begin drawing the barcode.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
scale
Type: Online System Single
The value to scale the barcode.
See Also
DrawOnCanvas Overload


BarcodeProfessional.GetBarcodeImage Method

BarcodeProfessional GetBarcodeImage Method Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | GetBarcodeImage | Gets a System.Drawing.Image object of the barcode image.
Public method | GetBarcodeImage(ImageFormat) | Gets a byte array that represents the barcode image.
Public method | GetBarcodeImage(Single) | Gets a System.Drawing.Image object of the barcode image at the specified resolution.
Public method | GetBarcodeImage(ImageFormat, Single) | Gets a byte array that represents the barcode image at the specified resolution.
Public method | GetBarcodeImage(Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolution.
Public method | GetBarcodeImage(Single, Single) | Gets a System.Drawing.Image object of the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size.
Public method | GetBarcodeImage(ImageFormat, Single, Single) | Gets a byte array that represents the barcode image at the specified horizontal and vertical resolutions.
Public method | GetBarcodeImage(Single, Single, SizeF) | Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolutions.
Public method | GetBarcodeImage(ImageFormat, Single, Single, SizeF) | Gets a byte array that represents the barcode image fitting the bars into the specified size and resolutions.
Back to Top
See Also


BarcodeProfessional.GetBarcodeImage Method

BarcodeProfessional GetBarcodeImage Method Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image GetBarcodeImage()
public Image GetBarcodeImage()
Public Function GetBarcodeImage As Image
Public Function GetBarcodeImage As Image
public:
Image^ GetBarcodeImage()
public:
Image^ GetBarcodeImage()
member GetBarcodeImage : unit -> Image
member GetBarcodeImage : unit -> Image

Return Value

Type: Online Image
A System.Drawing.Image object that represent the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (ImageFormat)

BarcodeProfessional GetBarcodeImage Method (ImageFormat) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a byte array that represents the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBarcodeImage(
    ImageFormat imageFormat
)
public byte[] GetBarcodeImage(
    ImageFormat imageFormat
)
Public Function GetBarcodeImage (
    imageFormat As ImageFormat
) As Byte()
Public Function GetBarcodeImage (
    imageFormat As ImageFormat
) As Byte()
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat
)
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat
)
member GetBarcodeImage :
        imageFormat : ImageFormat -> byte[]
member GetBarcodeImage :
        imageFormat : ImageFormat -> byte[]

Parameters

imageFormat
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for the barcode image.

Return Value

Type: Online Byte
A byte array representation of the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (Single)

BarcodeProfessional GetBarcodeImage Method (Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image at the specified resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image GetBarcodeImage(
    float dpi
)
public Image GetBarcodeImage(
    float dpi
)
Public Function GetBarcodeImage (
    dpi As Single
) As Image
Public Function GetBarcodeImage (
    dpi As Single
) As Image
public:
Image^ GetBarcodeImage(
    float dpi
)
public:
Image^ GetBarcodeImage(
    float dpi
)
member GetBarcodeImage :
        dpi : float32 -> Image
member GetBarcodeImage :
        dpi : float32 -> Image

Parameters

dpi
Type: Online System Single
The resolution, in dots per inch, of the output image.

Return Value

Type: Online Image
A System.Drawing.Image object that represent the barcode image at the specified resolution.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (ImageFormat, Single)

BarcodeProfessional GetBarcodeImage Method (ImageFormat, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a byte array that represents the barcode image at the specified resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float dpi
)
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float dpi
)
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    dpi As Single
) As Byte()
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    dpi As Single
) As Byte()
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float dpi
)
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float dpi
)
member GetBarcodeImage :
        imageFormat : ImageFormat *
        dpi : float32 -> byte[]
member GetBarcodeImage :
        imageFormat : ImageFormat *
        dpi : float32 -> byte[]

Parameters

imageFormat
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for the barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the output image.

Return Value

Type: Online Byte
A byte array representation of the barcode image at the specified resolution.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (Single, SizeF)

BarcodeProfessional GetBarcodeImage Method (Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image GetBarcodeImage(
    float dpi,
    SizeF barsAreaSize
)
public Image GetBarcodeImage(
    float dpi,
    SizeF barsAreaSize
)
Public Function GetBarcodeImage (
    dpi As Single,
    barsAreaSize As SizeF
) As Image
Public Function GetBarcodeImage (
    dpi As Single,
    barsAreaSize As SizeF
) As Image
public:
Image^ GetBarcodeImage(
    float dpi,
    SizeF barsAreaSize
)
public:
Image^ GetBarcodeImage(
    float dpi,
    SizeF barsAreaSize
)
member GetBarcodeImage :
        dpi : float32 *
        barsAreaSize : SizeF -> Image
member GetBarcodeImage :
        dpi : float32 *
        barsAreaSize : SizeF -> Image

Parameters

dpi
Type: Online System Single
The resolution, in dots per inch, of the output image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.

Return Value

Type: Online Image
A System.Drawing.Image object that represent the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (Single, Single)

BarcodeProfessional GetBarcodeImage Method (Single, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image at the specified horizontal and vertical resolutions.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image GetBarcodeImage(
    float xDpi,
    float yDpi
)
public Image GetBarcodeImage(
    float xDpi,
    float yDpi
)
Public Function GetBarcodeImage (
    xDpi As Single,
    yDpi As Single
) As Image
Public Function GetBarcodeImage (
    xDpi As Single,
    yDpi As Single
) As Image
public:
Image^ GetBarcodeImage(
    float xDpi,
    float yDpi
)
public:
Image^ GetBarcodeImage(
    float xDpi,
    float yDpi
)
member GetBarcodeImage :
        xDpi : float32 *
        yDpi : float32 -> Image
member GetBarcodeImage :
        xDpi : float32 *
        yDpi : float32 -> Image

Parameters

xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the output image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the output image.

Return Value

Type: Online Image
A System.Drawing.Image object that represent the barcode image at the specified horizontal and vertical resolutions.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (ImageFormat, Single, SizeF)

BarcodeProfessional GetBarcodeImage Method (ImageFormat, Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a byte array that represents the barcode image fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float dpi,
    SizeF barsAreaSize
)
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float dpi,
    SizeF barsAreaSize
)
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
) As Byte()
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
) As Byte()
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float dpi,
    SizeF barsAreaSize
)
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float dpi,
    SizeF barsAreaSize
)
member GetBarcodeImage :
        imageFormat : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> byte[]
member GetBarcodeImage :
        imageFormat : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> byte[]

Parameters

imageFormat
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for the barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the output image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.

Return Value

Type: Online Byte
A byte array representation of the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (ImageFormat, Single, Single)

BarcodeProfessional GetBarcodeImage Method (ImageFormat, Single, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a byte array that represents the barcode image at the specified horizontal and vertical resolutions.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float xDpi,
    float yDpi
)
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float xDpi,
    float yDpi
)
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    xDpi As Single,
    yDpi As Single
) As Byte()
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    xDpi As Single,
    yDpi As Single
) As Byte()
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float xDpi,
    float yDpi
)
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float xDpi,
    float yDpi
)
member GetBarcodeImage :
        imageFormat : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> byte[]
member GetBarcodeImage :
        imageFormat : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> byte[]

Parameters

imageFormat
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for the barcode image.
xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the output image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the output image.

Return Value

Type: Online Byte
A byte array representation of the barcode image at the specified horizontal and vertical resolutions.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (Single, Single, SizeF)

BarcodeProfessional GetBarcodeImage Method (Single, Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image fitting the bars into the specified size and resolutions.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image GetBarcodeImage(
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
public Image GetBarcodeImage(
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
Public Function GetBarcodeImage (
    xDpi As Single,
    yDpi As Single,
    barsAreaSize As SizeF
) As Image
Public Function GetBarcodeImage (
    xDpi As Single,
    yDpi As Single,
    barsAreaSize As SizeF
) As Image
public:
Image^ GetBarcodeImage(
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
public:
Image^ GetBarcodeImage(
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
member GetBarcodeImage :
        xDpi : float32 *
        yDpi : float32 *
        barsAreaSize : SizeF -> Image
member GetBarcodeImage :
        xDpi : float32 *
        yDpi : float32 *
        barsAreaSize : SizeF -> Image

Parameters

xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the output image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the output image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.

Return Value

Type: Online Image
A System.Drawing.Image object that represent the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetBarcodeImage Method (ImageFormat, Single, Single, SizeF)

BarcodeProfessional GetBarcodeImage Method (ImageFormat, Single, Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a byte array that represents the barcode image fitting the bars into the specified size and resolutions.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
public byte[] GetBarcodeImage(
    ImageFormat imageFormat,
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    xDpi As Single,
    yDpi As Single,
    barsAreaSize As SizeF
) As Byte()
Public Function GetBarcodeImage (
    imageFormat As ImageFormat,
    xDpi As Single,
    yDpi As Single,
    barsAreaSize As SizeF
) As Byte()
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
public:
array<unsigned char>^ GetBarcodeImage(
    ImageFormat^ imageFormat,
    float xDpi,
    float yDpi,
    SizeF barsAreaSize
)
member GetBarcodeImage :
        imageFormat : ImageFormat *
        xDpi : float32 *
        yDpi : float32 *
        barsAreaSize : SizeF -> byte[]
member GetBarcodeImage :
        imageFormat : ImageFormat *
        xDpi : float32 *
        yDpi : float32 *
        barsAreaSize : SizeF -> byte[]

Parameters

imageFormat
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for the barcode image.
xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the output image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the output image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.

Return Value

Type: Online Byte
A byte array representation of the barcode image.
See Also
GetBarcodeImage Overload


BarcodeProfessional.GetObjectData Method

BarcodeProfessional GetObjectData Method Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

Parameters

info
Type: Online System.Runtime.Serialization SerializationInfo
context
Type: Online System.Runtime.Serialization StreamingContext

Implements

Online ISerializable GetObjectData(SerializationInfo, StreamingContext)
See Also


BarcodeProfessional.GetSchema Method

BarcodeProfessional GetSchema Method Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public XmlSchema GetSchema()
public XmlSchema GetSchema()
Public Function GetSchema As XmlSchema
Public Function GetSchema As XmlSchema
public:
virtual XmlSchema^ GetSchema() sealed
public:
virtual XmlSchema^ GetSchema() sealed
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema
abstract GetSchema : unit -> XmlSchema
override GetSchema : unit -> XmlSchema

Return Value

Type: Online XmlSchema

Implements

Online IXmlSerializable GetSchema
See Also


BarcodeProfessional.ReadXml Method

BarcodeProfessional ReadXml Method Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void ReadXml(
    XmlReader reader
)
public void ReadXml(
    XmlReader reader
)
Public Sub ReadXml (
    reader As XmlReader
)
Public Sub ReadXml (
    reader As XmlReader
)
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed
public:
virtual void ReadXml(
    XmlReader^ reader
) sealed
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit
abstract ReadXml :
        reader : XmlReader -> unit
override ReadXml :
        reader : XmlReader -> unit

Parameters

reader
Type: Online System.Xml XmlReader

Implements

Online IXmlSerializable ReadXml(XmlReader)
See Also


BarcodeProfessional.Save Method

BarcodeProfessional Save Method Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | Save(Stream, ImageFormat) | Saves this barcode image to the specified Stream object in the specified format.
Public method | Save(String, ImageFormat) | Saves this barcode image to the specified file in the specified format.
Public method | Save(Stream, ImageFormat, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Public method | Save(Stream, ImageFormat, Single, SizeF) | Saves this barcode image to the specified Stream object in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(Stream, ImageFormat, Single, Single) | Saves this barcode image to the specified Stream object in the specified format and resolution.
Public method | Save(String, ImageFormat, Single, SizeF) | Saves this barcode image to the specified file in the specified format, resolution and fitting the bars into the specified size.
Public method | Save(String, ImageFormat, Single, Single) | Saves this barcode image to the specified file in the specified format and resolution.
Back to Top
See Also


BarcodeProfessional.Save Method (Stream, ImageFormat)

BarcodeProfessional Save Method (Stream, ImageFormat) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified Stream object in the specified format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    Stream stream,
    ImageFormat format
)
public void Save(
    Stream stream,
    ImageFormat format
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format
)
member Save :
        stream : Stream *
        format : ImageFormat -> unit
member Save :
        stream : Stream *
        format : ImageFormat -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
See Also
Save Overload


BarcodeProfessional.Save Method (String, ImageFormat)

BarcodeProfessional Save Method (String, ImageFormat) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified file in the specified format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    string filename,
    ImageFormat format
)
public void Save(
    string filename,
    ImageFormat format
)
Public Sub Save (
    filename As String,
    format As ImageFormat
)
Public Sub Save (
    filename As String,
    format As ImageFormat
)
public:
void Save(
    String^ filename,
    ImageFormat^ format
)
public:
void Save(
    String^ filename,
    ImageFormat^ format
)
member Save :
        filename : string *
        format : ImageFormat -> unit
member Save :
        filename : string *
        format : ImageFormat -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
See Also
Save Overload


BarcodeProfessional.Save Method (Stream, ImageFormat, Single)

BarcodeProfessional Save Method (Stream, ImageFormat, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified Stream object in the specified format and resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    Stream stream,
    ImageFormat format,
    float dpi
)
public void Save(
    Stream stream,
    ImageFormat format,
    float dpi
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    dpi As Single
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    dpi As Single
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float dpi
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float dpi
)
member Save :
        stream : Stream *
        format : ImageFormat *
        dpi : float32 -> unit
member Save :
        stream : Stream *
        format : ImageFormat *
        dpi : float32 -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the barcode image.
See Also
Save Overload


BarcodeProfessional.Save Method (String, ImageFormat, Single)

BarcodeProfessional Save Method (String, ImageFormat, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified file in the specified format and resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    string filename,
    ImageFormat format,
    float dpi
)
public void Save(
    string filename,
    ImageFormat format,
    float dpi
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    dpi As Single
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    dpi As Single
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float dpi
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float dpi
)
member Save :
        filename : string *
        format : ImageFormat *
        dpi : float32 -> unit
member Save :
        filename : string *
        format : ImageFormat *
        dpi : float32 -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the barcode image.
See Also
Save Overload


BarcodeProfessional.Save Method (Stream, ImageFormat, Single, SizeF)

BarcodeProfessional Save Method (Stream, ImageFormat, Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified Stream object in the specified format, resolution and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    Stream stream,
    ImageFormat format,
    float dpi,
    SizeF barsAreaSize
)
public void Save(
    Stream stream,
    ImageFormat format,
    float dpi,
    SizeF barsAreaSize
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float dpi,
    SizeF barsAreaSize
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float dpi,
    SizeF barsAreaSize
)
member Save :
        stream : Stream *
        format : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> unit
member Save :
        stream : Stream *
        format : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the barcode image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
Save Overload


BarcodeProfessional.Save Method (Stream, ImageFormat, Single, Single)

BarcodeProfessional Save Method (Stream, ImageFormat, Single, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified Stream object in the specified format and resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    Stream stream,
    ImageFormat format,
    float xDpi,
    float yDpi
)
public void Save(
    Stream stream,
    ImageFormat format,
    float xDpi,
    float yDpi
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    xDpi As Single,
    yDpi As Single
)
Public Sub Save (
    stream As Stream,
    format As ImageFormat,
    xDpi As Single,
    yDpi As Single
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float xDpi,
    float yDpi
)
public:
void Save(
    Stream^ stream,
    ImageFormat^ format,
    float xDpi,
    float yDpi
)
member Save :
        stream : Stream *
        format : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> unit
member Save :
        stream : Stream *
        format : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the barcode image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the barcode image.
See Also
Save Overload


BarcodeProfessional.Save Method (String, ImageFormat, Single, SizeF)

BarcodeProfessional Save Method (String, ImageFormat, Single, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified file in the specified format, resolution and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    string filename,
    ImageFormat format,
    float dpi,
    SizeF barsAreaSize
)
public void Save(
    string filename,
    ImageFormat format,
    float dpi,
    SizeF barsAreaSize
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    dpi As Single,
    barsAreaSize As SizeF
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float dpi,
    SizeF barsAreaSize
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float dpi,
    SizeF barsAreaSize
)
member Save :
        filename : string *
        format : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> unit
member Save :
        filename : string *
        format : ImageFormat *
        dpi : float32 *
        barsAreaSize : SizeF -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
dpi
Type: Online System Single
The resolution, in dots per inch, of the barcode image.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
Save Overload


BarcodeProfessional.Save Method (String, ImageFormat, Single, Single)

BarcodeProfessional Save Method (String, ImageFormat, Single, Single) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode image to the specified file in the specified format and resolution.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void Save(
    string filename,
    ImageFormat format,
    float xDpi,
    float yDpi
)
public void Save(
    string filename,
    ImageFormat format,
    float xDpi,
    float yDpi
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    xDpi As Single,
    yDpi As Single
)
Public Sub Save (
    filename As String,
    format As ImageFormat,
    xDpi As Single,
    yDpi As Single
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float xDpi,
    float yDpi
)
public:
void Save(
    String^ filename,
    ImageFormat^ format,
    float xDpi,
    float yDpi
)
member Save :
        filename : string *
        format : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> unit
member Save :
        filename : string *
        format : ImageFormat *
        xDpi : float32 *
        yDpi : float32 -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode image.
format
Type: Online System.Drawing.Imaging ImageFormat
The ImageFormat object for this barcode image.
xDpi
Type: Online System Single
The horizontal resolution, in dots per inch, of the barcode image.
yDpi
Type: Online System Single
The vertical resolution, in dots per inch, of the barcode image.
See Also
Save Overload


BarcodeProfessional.SaveEps Method

BarcodeProfessional SaveEps Method Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | SaveEps(Stream, Encoding) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format.
Public method | SaveEps(String, Encoding) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(Stream, Encoding, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space.
Public method | SaveEps(String, Encoding, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.
Public method | SaveEps(Stream, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Public method | SaveEps(String, Encoding, EpsCmykBarcodeColors, SizeF) | Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.
Back to Top
See Also


BarcodeProfessional.SaveEps Method (Stream, Encoding)

BarcodeProfessional SaveEps Method (Stream, Encoding) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    Stream stream,
    Encoding encoding
)
public void SaveEps(
    Stream stream,
    Encoding encoding
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding
)
member SaveEps :
        stream : Stream *
        encoding : Encoding -> unit
member SaveEps :
        stream : Stream *
        encoding : Encoding -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the stream object.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (String, Encoding)

BarcodeProfessional SaveEps Method (String, Encoding) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified file in EPS (Encapsulated PostScript) format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    string filename,
    Encoding encoding
)
public void SaveEps(
    string filename,
    Encoding encoding
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding
)
member SaveEps :
        filename : string *
        encoding : Encoding -> unit
member SaveEps :
        filename : string *
        encoding : Encoding -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the file stream object.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (Stream, Encoding, EpsCmykBarcodeColors)

BarcodeProfessional SaveEps Method (Stream, Encoding, EpsCmykBarcodeColors) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    Stream stream,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors
)
public void SaveEps(
    Stream stream,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors
)
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors -> unit
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the stream object.
cmykBarcodeColors
Type: Neodynamic.SDK.Barcode EpsCmykBarcodeColors
The CMYK colors for each part of the barcode.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (Stream, Encoding, SizeF)

BarcodeProfessional SaveEps Method (Stream, Encoding, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    Stream stream,
    Encoding encoding,
    SizeF barsAreaSize
)
public void SaveEps(
    Stream stream,
    Encoding encoding,
    SizeF barsAreaSize
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    barsAreaSize As SizeF
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    barsAreaSize As SizeF
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    SizeF barsAreaSize
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    SizeF barsAreaSize
)
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        barsAreaSize : SizeF -> unit
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        barsAreaSize : SizeF -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the stream object.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (String, Encoding, EpsCmykBarcodeColors)

BarcodeProfessional SaveEps Method (String, Encoding, EpsCmykBarcodeColors) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    string filename,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors
)
public void SaveEps(
    string filename,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors
)
member SaveEps :
        filename : string *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors -> unit
member SaveEps :
        filename : string *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the file stream object.
cmykBarcodeColors
Type: Neodynamic.SDK.Barcode EpsCmykBarcodeColors
The CMYK colors for each part of the barcode.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (String, Encoding, SizeF)

BarcodeProfessional SaveEps Method (String, Encoding, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified file in EPS (Encapsulated PostScript) format and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    string filename,
    Encoding encoding,
    SizeF barsAreaSize
)
public void SaveEps(
    string filename,
    Encoding encoding,
    SizeF barsAreaSize
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    barsAreaSize As SizeF
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    barsAreaSize As SizeF
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    SizeF barsAreaSize
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    SizeF barsAreaSize
)
member SaveEps :
        filename : string *
        encoding : Encoding *
        barsAreaSize : SizeF -> unit
member SaveEps :
        filename : string *
        encoding : Encoding *
        barsAreaSize : SizeF -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the file stream object.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (Stream, Encoding, EpsCmykBarcodeColors, SizeF)

BarcodeProfessional SaveEps Method (Stream, Encoding, EpsCmykBarcodeColors, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified Stream object and text encoding in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    Stream stream,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors,
    SizeF barsAreaSize
)
public void SaveEps(
    Stream stream,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors,
    SizeF barsAreaSize
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors,
    barsAreaSize As SizeF
)
Public Sub SaveEps (
    stream As Stream,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors,
    barsAreaSize As SizeF
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors,
    SizeF barsAreaSize
)
public:
void SaveEps(
    Stream^ stream,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors,
    SizeF barsAreaSize
)
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors *
        barsAreaSize : SizeF -> unit
member SaveEps :
        stream : Stream *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors *
        barsAreaSize : SizeF -> unit

Parameters

stream
Type: Online System.IO Stream
The Stream object to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the stream object.
cmykBarcodeColors
Type: Neodynamic.SDK.Barcode EpsCmykBarcodeColors
The CMYK colors for each part of the barcode.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
SaveEps Overload


BarcodeProfessional.SaveEps Method (String, Encoding, EpsCmykBarcodeColors, SizeF)

BarcodeProfessional SaveEps Method (String, Encoding, EpsCmykBarcodeColors, SizeF) Neodynamic Barcode Professional SDK for .NET Class Reference
Saves this barcode to the specified file in EPS (Encapsulated PostScript) format with CMYK color space and fitting the bars into the specified size.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void SaveEps(
    string filename,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors,
    SizeF barsAreaSize
)
public void SaveEps(
    string filename,
    Encoding encoding,
    EpsCmykBarcodeColors cmykBarcodeColors,
    SizeF barsAreaSize
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors,
    barsAreaSize As SizeF
)
Public Sub SaveEps (
    filename As String,
    encoding As Encoding,
    cmykBarcodeColors As EpsCmykBarcodeColors,
    barsAreaSize As SizeF
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors,
    SizeF barsAreaSize
)
public:
void SaveEps(
    String^ filename,
    Encoding^ encoding,
    EpsCmykBarcodeColors^ cmykBarcodeColors,
    SizeF barsAreaSize
)
member SaveEps :
        filename : string *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors *
        barsAreaSize : SizeF -> unit
member SaveEps :
        filename : string *
        encoding : Encoding *
        cmykBarcodeColors : EpsCmykBarcodeColors *
        barsAreaSize : SizeF -> unit

Parameters

filename
Type: Online System String
A string that contains the name of the file to which to save this barcode.
encoding
Type: Online System.Text Encoding
The Encoding object used for writing the file stream object.
cmykBarcodeColors
Type: Neodynamic.SDK.Barcode EpsCmykBarcodeColors
The CMYK colors for each part of the barcode.
barsAreaSize
Type: Online System.Drawing SizeF
The desired bars area size that the barcode must fit in. The unit of measure must be specified to BarcodeUnit property.
See Also
SaveEps Overload


BarcodeProfessional.WriteXml Method

BarcodeProfessional WriteXml Method Neodynamic Barcode Professional SDK for .NET Class Reference

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public void WriteXml(
    XmlWriter writer
)
public void WriteXml(
    XmlWriter writer
)
Public Sub WriteXml (
    writer As XmlWriter
)
Public Sub WriteXml (
    writer As XmlWriter
)
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed
public:
virtual void WriteXml(
    XmlWriter^ writer
) sealed
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit
abstract WriteXml :
        writer : XmlWriter -> unit
override WriteXml :
        writer : XmlWriter -> unit

Parameters

writer
Type: Online System.Xml XmlWriter

Implements

Online IXmlSerializable WriteXml(XmlWriter)
See Also


BarcodeProfessional Properties

BarcodeProfessional Properties Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeProfessional type exposes the following members.
Properties
 | Name | Description
Public property | AddChecksum | Gets or sets whether checksum must be generated and attached to the value to encode.
Public property | AntiAlias | Gets or sets whether AntiAlias effect must be applied to all the texts in the barcode image.
Public property | ArtBarImagePattern | Gets or sets the image file (path or Base64 string) that will be used as a pattern to fill all the bars that compose the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.
Public property | ArtLogoImage | Gets or sets the logo image file (path or Base64 string) that will be used to stamp it on top or bottom of the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.
Public property | ArtLogoImageOpacity | Gets or sets the opacity [from 1 to 100 (fully opaque)] of the image logo file. Default is 100.
Public property | ArtLogoImagePercentage | Gets or sets the percentage used to resize the logo image based on the barcode symbol size. Default is 20.
Public property | ArtLogoImagePosition | Gets or sets the position of the logo image file on the barcode symbol. Default is Top.
Public property | AutoSize | Gets or sets whether the barcode image is automatically resized to display its entire contents.
Public property | AztecCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Aztec Code in Byte Compaction mode. Default it ISO-8859-1.
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology.
Public property | AztecCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character should be processed when Aztec Code is being generated.
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.
Public property | BackColor | Gets or sets the background color.
Public property | BarcodePadding | Gets or sets the extra space inside the border. The unit of measure must be specified to BarcodeUnit property.
Public property | BarcodeUnit | Gets or sets the unit of measure for the barcode dimensions. Defauls is Inch. It must precede any barcode dimension properties settings.
Public property | BarColor | Gets or sets the bars' color of the barcode.
Public property | BarHeight | Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is called N value.
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is called X value. The unit of measure must be specified to BarcodeUnit property.
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment.
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.
Public property | BearerBarWidth | Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.
Public property | BorderColor | Gets or sets the barcode border's color.
Public property | BorderWidth | Gets or sets the barcode border's width. The unit of measure must be specified to BarcodeUnit property.
Public property | BottomMargin | Gets or sets the height of the margin below the barcode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.
Public property | Code | Gets or sets the value to encode.
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.
Public property | CodeAlignment | Gets or sets the text alignment for Code and HumanReadableText properties.
Public property | CodeFormatPattern | Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).
Public property | DataMatrixByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default it ISO-8859-1.
Public property | DataMatrixEncoding | Gets or sets the DataMatrix Encoding to use on that symbology.
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.
Public property | DataMatrixFormat | Gets or sets the DataMatrix Format to use on that symbology.
Public property | DataMatrixModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character should be processed when DataMatrix code is being generated.
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode in the barcode image.
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed in the barcode image.
Public property | DisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed in the barcode image.
Public property | EanUpcAutoBWAfor1278DigitsEnabled | Gets or sets whether the recommended Bar Width Adjustment for digits 1, 2, 7 and 8 by GS1 spec is enabled. Default is False.
Public property | EanUpcMagnificationFactor | Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies.
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies.
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the EAN/UPC barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Extended | Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.
Public property | Font | Gest or sets the Font object for using when rendering Code and HumanReadableText properties.
Public property | ForeColor | Gets or sets the text color for using when rendering Code and HumanReadableText properties.
Public property | GS1DataStrictValidation | Gets or sets whether to strictly validate the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. Default is false.
Public property | GuardBar | Gets or sets whether EAN/UPC guard bars must be drawn.
Public property | GuardBarHeight | Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.
Public property | HanXinCodeEncoding | Gets or sets the Han Xin Code Encoding to use on that symbology.
Public property | HanXinCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for Han Xin Code symbology.
Public property | HanXinCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeProcessTilde | Gets or sets whether tilde character should be processed when Han Xin Code is being generated.
Public property | HanXinCodeVersion | Gets or sets the Han Xin Code Version to use on that symbology.
Public property | Height | Gets or sets the height of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.
Public property | HibcUseIsoIec15434Encoding | Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.
Public property | Image | Gets a System.Drawing.Image object of the barcode image.
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated.
Public property | IsCodeValid | Gets a value indicating whether the value to encode specified in the Code property is valid based on the Barcode Symbology specified in the Symbology property.
Public property | Itf14LeftHMark | Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.
Public property | Itf14RightHMark | Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.
 | LicenseKey | Gets or sets the License Key.
 | LicenseOwner | Gets or sets the License Owner.
Public property | MaxiCodeDrawPixelBasedSymbol | Gets or sets whether the MaxiCode symbol is drawn by using a Pixel Based method; otherwise, a Vector based method is used.
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode.
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character should be processed when MaxiCode code is being generated.
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.
Public property | MICRCharHeight | Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.
Public property | MICRCharSpacing | Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.
Public property | MICRCharWidths | Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology.
Public property | Monochrome | Gets or sets a value indicating whether the barcode image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology.
Public property | OutputSettings | Gets a list of settings that were used to generate the selected symbology.
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).
Public property | Pdf417ByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default it ISO-8859-1.
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology.
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology.
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology.
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology.
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed).
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn in the barcode image.
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default it ISO-8859-1.
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology.
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology.
Public property | QRCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | QRCodeProcessTilde | Gets or sets whether tilde character should be processed when QR Code is being generated.
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology.
Public property | QuietZoneWidth | Gets or sets the quiet zone's width. The unit of measure must be specified to BarcodeUnit property.
Public property | Rotate | Gets or sets the rotation angle to apply on the barcode image.
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether barcode drawing should use device-specific pixel settings during rendering. Default value is false.
Public property | Symbology | Gets or sets the barcode symbology to generate.
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology.
Public property | Text | Gets or sets the additional text to show in the barcode image e.g.: Product ID. Note: This is not the value to encode nor the Human Readable Text.
Public property | TextAlignment | Gets or sets the text alignment for Text property.
Public property | TextFont | Gest or sets the Font object for using when rendering Text property.
Public property | TextForeColor | Gets or sets the text color for using when rendering Text property.
Public property | TextFormatPattern | Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).
Public property | TextRenderingHint | Gets or sets the quality of the text rendering. Note: it is available if AntiAlias property is False. Default is SystemDefault.
Public property | TiffCompression | Gets or sets the TIFF compression algorithm to be used when saving barcodes in such image format.
Public property | TopMargin | Gets or sets the height of the margin above the barcode bars. The unit of measure must be specified to BarcodeUnit property.
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology.
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology.
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn.
Public property | Width | Gets or sets the width of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.
Back to Top
See Also


BarcodeProfessional.AddChecksum Property

BarcodeProfessional AddChecksum Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether checksum must be generated and attached to the value to encode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AddChecksum { get; set; }
public bool AddChecksum { get; set; }
Public Property AddChecksum As Boolean
    Get
    Set
Public Property AddChecksum As Boolean
    Get
    Set
public:
property bool AddChecksum {
    bool get ();
    void set (bool value);
}
public:
property bool AddChecksum {
    bool get ();
    void set (bool value);
}
member AddChecksum : bool with get, set
member AddChecksum : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.AntiAlias Property

BarcodeProfessional AntiAlias Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether AntiAlias effect must be applied to all the texts in the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AntiAlias { get; set; }
public bool AntiAlias { get; set; }
Public Property AntiAlias As Boolean
    Get
    Set
Public Property AntiAlias As Boolean
    Get
    Set
public:
property bool AntiAlias {
    bool get ();
    void set (bool value);
}
public:
property bool AntiAlias {
    bool get ();
    void set (bool value);
}
member AntiAlias : bool with get, set
member AntiAlias : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.ArtBarImagePattern Property

BarcodeProfessional ArtBarImagePattern Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the image file (path or Base64 string) that will be used as a pattern to fill all the bars that compose the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ArtBarImagePattern { get; set; }
public string ArtBarImagePattern { get; set; }
Public Property ArtBarImagePattern As String
    Get
    Set
Public Property ArtBarImagePattern As String
    Get
    Set
public:
property String^ ArtBarImagePattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ArtBarImagePattern {
    String^ get ();
    void set (String^ value);
}
member ArtBarImagePattern : string with get, set
member ArtBarImagePattern : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.ArtLogoImage Property

BarcodeProfessional ArtLogoImage Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the logo image file (path or Base64 string) that will be used to stamp it on top or bottom of the barcode symbol. Note: this feature is not available when exporting the barcode symbol to EPS format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string ArtLogoImage { get; set; }
public string ArtLogoImage { get; set; }
Public Property ArtLogoImage As String
    Get
    Set
Public Property ArtLogoImage As String
    Get
    Set
public:
property String^ ArtLogoImage {
    String^ get ();
    void set (String^ value);
}
public:
property String^ ArtLogoImage {
    String^ get ();
    void set (String^ value);
}
member ArtLogoImage : string with get, set
member ArtLogoImage : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.ArtLogoImageOpacity Property

BarcodeProfessional ArtLogoImageOpacity Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the opacity [from 1 to 100 (fully opaque)] of the image logo file. Default is 100.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ArtLogoImageOpacity { get; set; }
public int ArtLogoImageOpacity { get; set; }
Public Property ArtLogoImageOpacity As Integer
    Get
    Set
Public Property ArtLogoImageOpacity As Integer
    Get
    Set
public:
property int ArtLogoImageOpacity {
    int get ();
    void set (int value);
}
public:
property int ArtLogoImageOpacity {
    int get ();
    void set (int value);
}
member ArtLogoImageOpacity : int with get, set
member ArtLogoImageOpacity : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.ArtLogoImagePercentage Property

BarcodeProfessional ArtLogoImagePercentage Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the percentage used to resize the logo image based on the barcode symbol size. Default is 20.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int ArtLogoImagePercentage { get; set; }
public int ArtLogoImagePercentage { get; set; }
Public Property ArtLogoImagePercentage As Integer
    Get
    Set
Public Property ArtLogoImagePercentage As Integer
    Get
    Set
public:
property int ArtLogoImagePercentage {
    int get ();
    void set (int value);
}
public:
property int ArtLogoImagePercentage {
    int get ();
    void set (int value);
}
member ArtLogoImagePercentage : int with get, set
member ArtLogoImagePercentage : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.ArtLogoImagePosition Property

BarcodeProfessional ArtLogoImagePosition Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the position of the logo image file on the barcode symbol. Default is Top.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public LogoPosition ArtLogoImagePosition { get; set; }
public LogoPosition ArtLogoImagePosition { get; set; }
Public Property ArtLogoImagePosition As LogoPosition
    Get
    Set
Public Property ArtLogoImagePosition As LogoPosition
    Get
    Set
public:
property LogoPosition ArtLogoImagePosition {
    LogoPosition get ();
    void set (LogoPosition value);
}
public:
property LogoPosition ArtLogoImagePosition {
    LogoPosition get ();
    void set (LogoPosition value);
}
member ArtLogoImagePosition : LogoPosition with get, set
member ArtLogoImagePosition : LogoPosition with get, set

Property Value

Type: LogoPosition
See Also


BarcodeProfessional.AutoSize Property

BarcodeProfessional AutoSize Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the barcode image is automatically resized to display its entire contents.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AutoSize { get; set; }
public bool AutoSize { get; set; }
Public Property AutoSize As Boolean
    Get
    Set
Public Property AutoSize As Boolean
    Get
    Set
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}
public:
property bool AutoSize {
    bool get ();
    void set (bool value);
}
member AutoSize : bool with get, set
member AutoSize : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.AztecCodeByteEncodingName Property

BarcodeProfessional AztecCodeByteEncodingName Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Encoding Name (Code Page) to be used for Aztec Code in Byte Compaction mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string AztecCodeByteEncodingName { get; set; }
public string AztecCodeByteEncodingName { get; set; }
Public Property AztecCodeByteEncodingName As String
    Get
    Set
Public Property AztecCodeByteEncodingName As String
    Get
    Set
public:
property String^ AztecCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ AztecCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
member AztecCodeByteEncodingName : string with get, set
member AztecCodeByteEncodingName : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.AztecCodeErrorCorrection Property

BarcodeProfessional AztecCodeErrorCorrection Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default is 23.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AztecCodeErrorCorrection { get; set; }
public int AztecCodeErrorCorrection { get; set; }
Public Property AztecCodeErrorCorrection As Integer
    Get
    Set
Public Property AztecCodeErrorCorrection As Integer
    Get
    Set
public:
property int AztecCodeErrorCorrection {
    int get ();
    void set (int value);
}
public:
property int AztecCodeErrorCorrection {
    int get ();
    void set (int value);
}
member AztecCodeErrorCorrection : int with get, set
member AztecCodeErrorCorrection : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.AztecCodeFormat Property

BarcodeProfessional AztecCodeFormat Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Aztec Code Format to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public AztecCodeFormat AztecCodeFormat { get; set; }
public AztecCodeFormat AztecCodeFormat { get; set; }
Public Property AztecCodeFormat As AztecCodeFormat
    Get
    Set
Public Property AztecCodeFormat As AztecCodeFormat
    Get
    Set
public:
property AztecCodeFormat AztecCodeFormat {
    AztecCodeFormat get ();
    void set (AztecCodeFormat value);
}
public:
property AztecCodeFormat AztecCodeFormat {
    AztecCodeFormat get ();
    void set (AztecCodeFormat value);
}
member AztecCodeFormat : AztecCodeFormat with get, set
member AztecCodeFormat : AztecCodeFormat with get, set

Property Value

Type: AztecCodeFormat
See Also


BarcodeProfessional.AztecCodeModuleSize Property

BarcodeProfessional AztecCodeModuleSize Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double AztecCodeModuleSize { get; set; }
public double AztecCodeModuleSize { get; set; }
Public Property AztecCodeModuleSize As Double
    Get
    Set
Public Property AztecCodeModuleSize As Double
    Get
    Set
public:
property double AztecCodeModuleSize {
    double get ();
    void set (double value);
}
public:
property double AztecCodeModuleSize {
    double get ();
    void set (double value);
}
member AztecCodeModuleSize : float with get, set
member AztecCodeModuleSize : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.AztecCodeProcessTilde Property

BarcodeProfessional AztecCodeProcessTilde Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether tilde character should be processed when Aztec Code is being generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool AztecCodeProcessTilde { get; set; }
public bool AztecCodeProcessTilde { get; set; }
Public Property AztecCodeProcessTilde As Boolean
    Get
    Set
Public Property AztecCodeProcessTilde As Boolean
    Get
    Set
public:
property bool AztecCodeProcessTilde {
    bool get ();
    void set (bool value);
}
public:
property bool AztecCodeProcessTilde {
    bool get ();
    void set (bool value);
}
member AztecCodeProcessTilde : bool with get, set
member AztecCodeProcessTilde : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.AztecCodeRune Property

BarcodeProfessional AztecCodeRune Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int AztecCodeRune { get; set; }
public int AztecCodeRune { get; set; }
Public Property AztecCodeRune As Integer
    Get
    Set
Public Property AztecCodeRune As Integer
    Get
    Set
public:
property int AztecCodeRune {
    int get ();
    void set (int value);
}
public:
property int AztecCodeRune {
    int get ();
    void set (int value);
}
member AztecCodeRune : int with get, set
member AztecCodeRune : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.BackColor Property

BarcodeProfessional BackColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the background color.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color BackColor { get; set; }
public Color BackColor { get; set; }
Public Property BackColor As Color
    Get
    Set
Public Property BackColor As Color
    Get
    Set
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}
member BackColor : Color with get, set
member BackColor : Color with get, set

Property Value

Type: Online Color
See Also


BarcodeProfessional.BarcodePadding Property

BarcodeProfessional BarcodePadding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the extra space inside the border. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Margin BarcodePadding { get; set; }
public Margin BarcodePadding { get; set; }
Public Property BarcodePadding As Margin
    Get
    Set
Public Property BarcodePadding As Margin
    Get
    Set
public:
property Margin^ BarcodePadding {
    Margin^ get ();
    void set (Margin^ value);
}
public:
property Margin^ BarcodePadding {
    Margin^ get ();
    void set (Margin^ value);
}
member BarcodePadding : Margin with get, set
member BarcodePadding : Margin with get, set

Property Value

Type: Margin
See Also


BarcodeProfessional.BarcodeUnit Property

BarcodeProfessional BarcodeUnit Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the unit of measure for the barcode dimensions. Defauls is Inch. It must precede any barcode dimension properties settings.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BarcodeUnit BarcodeUnit { get; set; }
public BarcodeUnit BarcodeUnit { get; set; }
Public Property BarcodeUnit As BarcodeUnit
    Get
    Set
Public Property BarcodeUnit As BarcodeUnit
    Get
    Set
public:
property BarcodeUnit BarcodeUnit {
    BarcodeUnit get ();
    void set (BarcodeUnit value);
}
public:
property BarcodeUnit BarcodeUnit {
    BarcodeUnit get ();
    void set (BarcodeUnit value);
}
member BarcodeUnit : BarcodeUnit with get, set
member BarcodeUnit : BarcodeUnit with get, set

Property Value

Type: BarcodeUnit
See Also


BarcodeProfessional.BarColor Property

BarcodeProfessional BarColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the bars' color of the barcode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color BarColor { get; set; }
public Color BarColor { get; set; }
Public Property BarColor As Color
    Get
    Set
Public Property BarColor As Color
    Get
    Set
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}
member BarColor : Color with get, set
member BarColor : Color with get, set

Property Value

Type: Online Color
See Also


BarcodeProfessional.BarHeight Property

BarcodeProfessional BarHeight Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the bars' height of the barcode. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BarHeight { get; set; }
public double BarHeight { get; set; }
Public Property BarHeight As Double
    Get
    Set
Public Property BarHeight As Double
    Get
    Set
public:
property double BarHeight {
    double get ();
    void set (double value);
}
public:
property double BarHeight {
    double get ();
    void set (double value);
}
member BarHeight : float with get, set
member BarHeight : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BarRatio Property

BarcodeProfessional BarRatio Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is called N value.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BarRatio { get; set; }
public double BarRatio { get; set; }
Public Property BarRatio As Double
    Get
    Set
Public Property BarRatio As Double
    Get
    Set
public:
property double BarRatio {
    double get ();
    void set (double value);
}
public:
property double BarRatio {
    double get ();
    void set (double value);
}
member BarRatio : float with get, set
member BarRatio : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BarWidth Property

BarcodeProfessional BarWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the narrow bars' width of the barcode. In barcode terminology this is called X value. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BarWidth { get; set; }
public double BarWidth { get; set; }
Public Property BarWidth As Double
    Get
    Set
Public Property BarWidth As Double
    Get
    Set
public:
property double BarWidth {
    double get ();
    void set (double value);
}
public:
property double BarWidth {
    double get ();
    void set (double value);
}
member BarWidth : float with get, set
member BarWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BarWidthAdjustment Property

BarcodeProfessional BarWidthAdjustment Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Bar Width Adjustment.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BarWidthAdjustment { get; set; }
public double BarWidthAdjustment { get; set; }
Public Property BarWidthAdjustment As Double
    Get
    Set
Public Property BarWidthAdjustment As Double
    Get
    Set
public:
property double BarWidthAdjustment {
    double get ();
    void set (double value);
}
public:
property double BarWidthAdjustment {
    double get ();
    void set (double value);
}
member BarWidthAdjustment : float with get, set
member BarWidthAdjustment : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BearerBarStyle Property

BarcodeProfessional BearerBarStyle Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or set the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BearerBarStyle BearerBarStyle { get; set; }
public BearerBarStyle BearerBarStyle { get; set; }
Public Property BearerBarStyle As BearerBarStyle
    Get
    Set
Public Property BearerBarStyle As BearerBarStyle
    Get
    Set
public:
property BearerBarStyle BearerBarStyle {
    BearerBarStyle get ();
    void set (BearerBarStyle value);
}
public:
property BearerBarStyle BearerBarStyle {
    BearerBarStyle get ();
    void set (BearerBarStyle value);
}
member BearerBarStyle : BearerBarStyle with get, set
member BearerBarStyle : BearerBarStyle with get, set

Property Value

Type: BearerBarStyle
See Also


BarcodeProfessional.BearerBarWidth Property

BarcodeProfessional BearerBarWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the bearer bars' width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BearerBarWidth { get; set; }
public double BearerBarWidth { get; set; }
Public Property BearerBarWidth As Double
    Get
    Set
Public Property BearerBarWidth As Double
    Get
    Set
public:
property double BearerBarWidth {
    double get ();
    void set (double value);
}
public:
property double BearerBarWidth {
    double get ();
    void set (double value);
}
member BearerBarWidth : float with get, set
member BearerBarWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BorderColor Property

BarcodeProfessional BorderColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the barcode border's color.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color BorderColor { get; set; }
public Color BorderColor { get; set; }
Public Property BorderColor As Color
    Get
    Set
Public Property BorderColor As Color
    Get
    Set
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}
member BorderColor : Color with get, set
member BorderColor : Color with get, set

Property Value

Type: Online Color
See Also


BarcodeProfessional.BorderWidth Property

BarcodeProfessional BorderWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the barcode border's width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BorderWidth { get; set; }
public double BorderWidth { get; set; }
Public Property BorderWidth As Double
    Get
    Set
Public Property BorderWidth As Double
    Get
    Set
public:
property double BorderWidth {
    double get ();
    void set (double value);
}
public:
property double BorderWidth {
    double get ();
    void set (double value);
}
member BorderWidth : float with get, set
member BorderWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.BottomMargin Property

BarcodeProfessional BottomMargin Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the height of the margin below the barcode bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double BottomMargin { get; set; }
public double BottomMargin { get; set; }
Public Property BottomMargin As Double
    Get
    Set
Public Property BottomMargin As Double
    Get
    Set
public:
property double BottomMargin {
    double get ();
    void set (double value);
}
public:
property double BottomMargin {
    double get ();
    void set (double value);
}
member BottomMargin : float with get, set
member BottomMargin : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.CodabarStartChar Property

BarcodeProfessional CodabarStartChar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodabarStartStopChar CodabarStartChar { get; set; }
public CodabarStartStopChar CodabarStartChar { get; set; }
Public Property CodabarStartChar As CodabarStartStopChar
    Get
    Set
Public Property CodabarStartChar As CodabarStartStopChar
    Get
    Set
public:
property CodabarStartStopChar CodabarStartChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}
public:
property CodabarStartStopChar CodabarStartChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}
member CodabarStartChar : CodabarStartStopChar with get, set
member CodabarStartChar : CodabarStartStopChar with get, set

Property Value

Type: CodabarStartStopChar
See Also


BarcodeProfessional.CodabarStopChar Property

BarcodeProfessional CodabarStopChar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public CodabarStartStopChar CodabarStopChar { get; set; }
public CodabarStartStopChar CodabarStopChar { get; set; }
Public Property CodabarStopChar As CodabarStartStopChar
    Get
    Set
Public Property CodabarStopChar As CodabarStartStopChar
    Get
    Set
public:
property CodabarStartStopChar CodabarStopChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}
public:
property CodabarStartStopChar CodabarStopChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}
member CodabarStopChar : CodabarStartStopChar with get, set
member CodabarStopChar : CodabarStartStopChar with get, set

Property Value

Type: CodabarStartStopChar
See Also


BarcodeProfessional.Code Property

BarcodeProfessional Code Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the value to encode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Code { get; set; }
public string Code { get; set; }
Public Property Code As String
    Get
    Set
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set
member Code : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.Code128CharSet Property

BarcodeProfessional Code128CharSet Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Code128 Code128CharSet { get; set; }
public Code128 Code128CharSet { get; set; }
Public Property Code128CharSet As Code128
    Get
    Set
Public Property Code128CharSet As Code128
    Get
    Set
public:
property Code128 Code128CharSet {
    Code128 get ();
    void set (Code128 value);
}
public:
property Code128 Code128CharSet {
    Code128 get ();
    void set (Code128 value);
}
member Code128CharSet : Code128 with get, set
member Code128CharSet : Code128 with get, set

Property Value

Type: Code128
See Also


BarcodeProfessional.Code16kMode Property

BarcodeProfessional Code16kMode Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Code16k Code16kMode { get; set; }
public Code16k Code16kMode { get; set; }
Public Property Code16kMode As Code16k
    Get
    Set
Public Property Code16kMode As Code16k
    Get
    Set
public:
property Code16k Code16kMode {
    Code16k get ();
    void set (Code16k value);
}
public:
property Code16k Code16kMode {
    Code16k get ();
    void set (Code16k value);
}
member Code16kMode : Code16k with get, set
member Code16kMode : Code16k with get, set

Property Value

Type: Code16k
See Also


BarcodeProfessional.CodeAlignment Property

BarcodeProfessional CodeAlignment Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the text alignment for Code and HumanReadableText properties.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Alignment CodeAlignment { get; set; }
public Alignment CodeAlignment { get; set; }
Public Property CodeAlignment As Alignment
    Get
    Set
Public Property CodeAlignment As Alignment
    Get
    Set
public:
property Alignment CodeAlignment {
    Alignment get ();
    void set (Alignment value);
}
public:
property Alignment CodeAlignment {
    Alignment get ();
    void set (Alignment value);
}
member CodeAlignment : Alignment with get, set
member CodeAlignment : Alignment with get, set

Property Value

Type: Alignment
See Also


BarcodeProfessional.CodeFormatPattern Property

BarcodeProfessional CodeFormatPattern Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string CodeFormatPattern { get; set; }
public string CodeFormatPattern { get; set; }
Public Property CodeFormatPattern As String
    Get
    Set
Public Property CodeFormatPattern As String
    Get
    Set
public:
property String^ CodeFormatPattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ CodeFormatPattern {
    String^ get ();
    void set (String^ value);
}
member CodeFormatPattern : string with get, set
member CodeFormatPattern : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.DataMatrixByteEncodingName Property

BarcodeProfessional DataMatrixByteEncodingName Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DataMatrixByteEncodingName { get; set; }
public string DataMatrixByteEncodingName { get; set; }
Public Property DataMatrixByteEncodingName As String
    Get
    Set
Public Property DataMatrixByteEncodingName As String
    Get
    Set
public:
property String^ DataMatrixByteEncodingName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DataMatrixByteEncodingName {
    String^ get ();
    void set (String^ value);
}
member DataMatrixByteEncodingName : string with get, set
member DataMatrixByteEncodingName : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.DataMatrixEncoding Property

BarcodeProfessional DataMatrixEncoding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the DataMatrix Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataMatrixEncoding DataMatrixEncoding { get; set; }
public DataMatrixEncoding DataMatrixEncoding { get; set; }
Public Property DataMatrixEncoding As DataMatrixEncoding
    Get
    Set
Public Property DataMatrixEncoding As DataMatrixEncoding
    Get
    Set
public:
property DataMatrixEncoding DataMatrixEncoding {
    DataMatrixEncoding get ();
    void set (DataMatrixEncoding value);
}
public:
property DataMatrixEncoding DataMatrixEncoding {
    DataMatrixEncoding get ();
    void set (DataMatrixEncoding value);
}
member DataMatrixEncoding : DataMatrixEncoding with get, set
member DataMatrixEncoding : DataMatrixEncoding with get, set

Property Value

Type: DataMatrixEncoding
See Also


BarcodeProfessional.DataMatrixFileId Property

BarcodeProfessional DataMatrixFileId Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string DataMatrixFileId { get; set; }
public string DataMatrixFileId { get; set; }
Public Property DataMatrixFileId As String
    Get
    Set
Public Property DataMatrixFileId As String
    Get
    Set
public:
property String^ DataMatrixFileId {
    String^ get ();
    void set (String^ value);
}
public:
property String^ DataMatrixFileId {
    String^ get ();
    void set (String^ value);
}
member DataMatrixFileId : string with get, set
member DataMatrixFileId : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.DataMatrixFormat Property

BarcodeProfessional DataMatrixFormat Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the DataMatrix Format to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public DataMatrixFormat DataMatrixFormat { get; set; }
public DataMatrixFormat DataMatrixFormat { get; set; }
Public Property DataMatrixFormat As DataMatrixFormat
    Get
    Set
Public Property DataMatrixFormat As DataMatrixFormat
    Get
    Set
public:
property DataMatrixFormat DataMatrixFormat {
    DataMatrixFormat get ();
    void set (DataMatrixFormat value);
}
public:
property DataMatrixFormat DataMatrixFormat {
    DataMatrixFormat get ();
    void set (DataMatrixFormat value);
}
member DataMatrixFormat : DataMatrixFormat with get, set
member DataMatrixFormat : DataMatrixFormat with get, set

Property Value

Type: DataMatrixFormat
See Also


BarcodeProfessional.DataMatrixModuleSize Property

BarcodeProfessional DataMatrixModuleSize Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double DataMatrixModuleSize { get; set; }
public double DataMatrixModuleSize { get; set; }
Public Property DataMatrixModuleSize As Double
    Get
    Set
Public Property DataMatrixModuleSize As Double
    Get
    Set
public:
property double DataMatrixModuleSize {
    double get ();
    void set (double value);
}
public:
property double DataMatrixModuleSize {
    double get ();
    void set (double value);
}
member DataMatrixModuleSize : float with get, set
member DataMatrixModuleSize : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.DataMatrixProcessTilde Property

BarcodeProfessional DataMatrixProcessTilde Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether tilde character should be processed when DataMatrix code is being generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DataMatrixProcessTilde { get; set; }
public bool DataMatrixProcessTilde { get; set; }
Public Property DataMatrixProcessTilde As Boolean
    Get
    Set
Public Property DataMatrixProcessTilde As Boolean
    Get
    Set
public:
property bool DataMatrixProcessTilde {
    bool get ();
    void set (bool value);
}
public:
property bool DataMatrixProcessTilde {
    bool get ();
    void set (bool value);
}
member DataMatrixProcessTilde : bool with get, set
member DataMatrixProcessTilde : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.DataMatrixSymbolCount Property

BarcodeProfessional DataMatrixSymbolCount Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DataMatrixSymbolCount { get; set; }
public int DataMatrixSymbolCount { get; set; }
Public Property DataMatrixSymbolCount As Integer
    Get
    Set
Public Property DataMatrixSymbolCount As Integer
    Get
    Set
public:
property int DataMatrixSymbolCount {
    int get ();
    void set (int value);
}
public:
property int DataMatrixSymbolCount {
    int get ();
    void set (int value);
}
member DataMatrixSymbolCount : int with get, set
member DataMatrixSymbolCount : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.DataMatrixSymbolIndex Property

BarcodeProfessional DataMatrixSymbolIndex Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int DataMatrixSymbolIndex { get; set; }
public int DataMatrixSymbolIndex { get; set; }
Public Property DataMatrixSymbolIndex As Integer
    Get
    Set
Public Property DataMatrixSymbolIndex As Integer
    Get
    Set
public:
property int DataMatrixSymbolIndex {
    int get ();
    void set (int value);
}
public:
property int DataMatrixSymbolIndex {
    int get ();
    void set (int value);
}
member DataMatrixSymbolIndex : int with get, set
member DataMatrixSymbolIndex : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.DisplayChecksum Property

BarcodeProfessional DisplayChecksum Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether checksum value must be displayed after the value to encode in the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisplayChecksum { get; set; }
public bool DisplayChecksum { get; set; }
Public Property DisplayChecksum As Boolean
    Get
    Set
Public Property DisplayChecksum As Boolean
    Get
    Set
public:
property bool DisplayChecksum {
    bool get ();
    void set (bool value);
}
public:
property bool DisplayChecksum {
    bool get ();
    void set (bool value);
}
member DisplayChecksum : bool with get, set
member DisplayChecksum : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.DisplayCode Property

BarcodeProfessional DisplayCode Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the value to encode must be displayed in the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisplayCode { get; set; }
public bool DisplayCode { get; set; }
Public Property DisplayCode As Boolean
    Get
    Set
Public Property DisplayCode As Boolean
    Get
    Set
public:
property bool DisplayCode {
    bool get ();
    void set (bool value);
}
public:
property bool DisplayCode {
    bool get ();
    void set (bool value);
}
member DisplayCode : bool with get, set
member DisplayCode : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.DisplayLightMarginIndicator Property

BarcodeProfessional DisplayLightMarginIndicator Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether light margin indicators must be displayed in the barcode image. Only available for EAN/UPC Symbologies.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisplayLightMarginIndicator { get; set; }
public bool DisplayLightMarginIndicator { get; set; }
Public Property DisplayLightMarginIndicator As Boolean
    Get
    Set
Public Property DisplayLightMarginIndicator As Boolean
    Get
    Set
public:
property bool DisplayLightMarginIndicator {
    bool get ();
    void set (bool value);
}
public:
property bool DisplayLightMarginIndicator {
    bool get ();
    void set (bool value);
}
member DisplayLightMarginIndicator : bool with get, set
member DisplayLightMarginIndicator : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.DisplayStartStopChar Property

BarcodeProfessional DisplayStartStopChar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether start and stop characters must be displayed in the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool DisplayStartStopChar { get; set; }
public bool DisplayStartStopChar { get; set; }
Public Property DisplayStartStopChar As Boolean
    Get
    Set
Public Property DisplayStartStopChar As Boolean
    Get
    Set
public:
property bool DisplayStartStopChar {
    bool get ();
    void set (bool value);
}
public:
property bool DisplayStartStopChar {
    bool get ();
    void set (bool value);
}
member DisplayStartStopChar : bool with get, set
member DisplayStartStopChar : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.EanUpcAutoBWAfor1278DigitsEnabled Property

BarcodeProfessional EanUpcAutoBWAfor1278DigitsEnabled Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the recommended Bar Width Adjustment for digits 1, 2, 7 and 8 by GS1 spec is enabled. Default is False.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool EanUpcAutoBWAfor1278DigitsEnabled { get; set; }
public bool EanUpcAutoBWAfor1278DigitsEnabled { get; set; }
Public Property EanUpcAutoBWAfor1278DigitsEnabled As Boolean
    Get
    Set
Public Property EanUpcAutoBWAfor1278DigitsEnabled As Boolean
    Get
    Set
public:
property bool EanUpcAutoBWAfor1278DigitsEnabled {
    bool get ();
    void set (bool value);
}
public:
property bool EanUpcAutoBWAfor1278DigitsEnabled {
    bool get ();
    void set (bool value);
}
member EanUpcAutoBWAfor1278DigitsEnabled : bool with get, set
member EanUpcAutoBWAfor1278DigitsEnabled : bool with get, set

Property Value

Type: Online Boolean
Remarks
The GS1 spec states that for digits 1, 2, 7 or 8; the bars (dark bars) and spaces (light bars) are reduced or enlarged by one-thirteenth of a module (BarWidth) to provide a uniform distribution of bar width tolerances and thus improve scanning reliability.
See Also


BarcodeProfessional.EanUpcMagnificationFactor Property

BarcodeProfessional EanUpcMagnificationFactor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public float EanUpcMagnificationFactor { get; set; }
public float EanUpcMagnificationFactor { get; set; }
Public Property EanUpcMagnificationFactor As Single
    Get
    Set
Public Property EanUpcMagnificationFactor As Single
    Get
    Set
public:
property float EanUpcMagnificationFactor {
    float get ();
    void set (float value);
}
public:
property float EanUpcMagnificationFactor {
    float get ();
    void set (float value);
}
member EanUpcMagnificationFactor : float32 with get, set
member EanUpcMagnificationFactor : float32 with get, set

Property Value

Type: Online Single
Remarks
EAN/UPC barcodes can be printed at various densities to accommodate a variety of printing and scanning processes. The significant dimensional parameter is X, the ideal width of a single module element. In Barcode Professional, this is specified with BarWidth property. For EAN/UPC symbols, the X-dimension at nominal size is 0.33 millimeter (= 0.013 inch). The "magnification factor" specifies the size of the barcode symbol as a whole by taking the nominal size as the 1.0 (100%) value.
See Also


BarcodeProfessional.EanUpcSupplement Property

BarcodeProfessional EanUpcSupplement Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the supplement type to use with EAN and UPC symbologies.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Supplement EanUpcSupplement { get; set; }
public Supplement EanUpcSupplement { get; set; }
Public Property EanUpcSupplement As Supplement
    Get
    Set
Public Property EanUpcSupplement As Supplement
    Get
    Set
public:
property Supplement EanUpcSupplement {
    Supplement get ();
    void set (Supplement value);
}
public:
property Supplement EanUpcSupplement {
    Supplement get ();
    void set (Supplement value);
}
member EanUpcSupplement : Supplement with get, set
member EanUpcSupplement : Supplement with get, set

Property Value

Type: Supplement
See Also


BarcodeProfessional.EanUpcSupplementCode Property

BarcodeProfessional EanUpcSupplementCode Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the supplement value for EAN and UPC symbologies.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string EanUpcSupplementCode { get; set; }
public string EanUpcSupplementCode { get; set; }
Public Property EanUpcSupplementCode As String
    Get
    Set
Public Property EanUpcSupplementCode As String
    Get
    Set
public:
property String^ EanUpcSupplementCode {
    String^ get ();
    void set (String^ value);
}
public:
property String^ EanUpcSupplementCode {
    String^ get ();
    void set (String^ value);
}
member EanUpcSupplementCode : string with get, set
member EanUpcSupplementCode : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.EanUpcSupplementSeparation Property

BarcodeProfessional EanUpcSupplementSeparation Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the gap separation between the EAN/UPC barcode and its supplement. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double EanUpcSupplementSeparation { get; set; }
public double EanUpcSupplementSeparation { get; set; }
Public Property EanUpcSupplementSeparation As Double
    Get
    Set
Public Property EanUpcSupplementSeparation As Double
    Get
    Set
public:
property double EanUpcSupplementSeparation {
    double get ();
    void set (double value);
}
public:
property double EanUpcSupplementSeparation {
    double get ();
    void set (double value);
}
member EanUpcSupplementSeparation : float with get, set
member EanUpcSupplementSeparation : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.EanUpcSupplementTopMargin Property

BarcodeProfessional EanUpcSupplementTopMargin Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the height of the margin above the EAN/UPC supplement bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double EanUpcSupplementTopMargin { get; set; }
public double EanUpcSupplementTopMargin { get; set; }
Public Property EanUpcSupplementTopMargin As Double
    Get
    Set
Public Property EanUpcSupplementTopMargin As Double
    Get
    Set
public:
property double EanUpcSupplementTopMargin {
    double get ();
    void set (double value);
}
public:
property double EanUpcSupplementTopMargin {
    double get ();
    void set (double value);
}
member EanUpcSupplementTopMargin : float with get, set
member EanUpcSupplementTopMargin : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Extended Property

BarcodeProfessional Extended Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the extended versions for Code 39 and/or Code 93 symbologies must be used.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Extended { get; set; }
public bool Extended { get; set; }
Public Property Extended As Boolean
    Get
    Set
Public Property Extended As Boolean
    Get
    Set
public:
property bool Extended {
    bool get ();
    void set (bool value);
}
public:
property bool Extended {
    bool get ();
    void set (bool value);
}
member Extended : bool with get, set
member Extended : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.Font Property

BarcodeProfessional Font Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gest or sets the Font object for using when rendering Code and HumanReadableText properties.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Font Font { get; set; }
public Font Font { get; set; }
Public Property Font As Font
    Get
    Set
Public Property Font As Font
    Get
    Set
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ Font {
    Font^ get ();
    void set (Font^ value);
}
member Font : Font with get, set
member Font : Font with get, set

Property Value

Type: Online Font
See Also


BarcodeProfessional.ForeColor Property

BarcodeProfessional ForeColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the text color for using when rendering Code and HumanReadableText properties.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color ForeColor { get; set; }
public Color ForeColor { get; set; }
Public Property ForeColor As Color
    Get
    Set
Public Property ForeColor As Color
    Get
    Set
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}
member ForeColor : Color with get, set
member ForeColor : Color with get, set

Property Value

Type: Online Color
See Also


BarcodeProfessional.GS1DataStrictValidation Property

BarcodeProfessional GS1DataStrictValidation Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether to strictly validate the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. Default is false.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GS1DataStrictValidation { get; set; }
public bool GS1DataStrictValidation { get; set; }
Public Property GS1DataStrictValidation As Boolean
    Get
    Set
Public Property GS1DataStrictValidation As Boolean
    Get
    Set
public:
property bool GS1DataStrictValidation {
    bool get ();
    void set (bool value);
}
public:
property bool GS1DataStrictValidation {
    bool get ();
    void set (bool value);
}
member GS1DataStrictValidation : bool with get, set
member GS1DataStrictValidation : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.GuardBar Property

BarcodeProfessional GuardBar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether EAN/UPC guard bars must be drawn.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool GuardBar { get; set; }
public bool GuardBar { get; set; }
Public Property GuardBar As Boolean
    Get
    Set
Public Property GuardBar As Boolean
    Get
    Set
public:
property bool GuardBar {
    bool get ();
    void set (bool value);
}
public:
property bool GuardBar {
    bool get ();
    void set (bool value);
}
member GuardBar : bool with get, set
member GuardBar : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.GuardBarHeight Property

BarcodeProfessional GuardBarHeight Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the guard bars' height. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double GuardBarHeight { get; set; }
public double GuardBarHeight { get; set; }
Public Property GuardBarHeight As Double
    Get
    Set
Public Property GuardBarHeight As Double
    Get
    Set
public:
property double GuardBarHeight {
    double get ();
    void set (double value);
}
public:
property double GuardBarHeight {
    double get ();
    void set (double value);
}
member GuardBarHeight : float with get, set
member GuardBarHeight : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.HanXinCodeByteEncodingName Property

BarcodeProfessional HanXinCodeByteEncodingName Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HanXinCodeByteEncodingName { get; set; }
public string HanXinCodeByteEncodingName { get; set; }
Public Property HanXinCodeByteEncodingName As String
    Get
    Set
Public Property HanXinCodeByteEncodingName As String
    Get
    Set
public:
property String^ HanXinCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HanXinCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
member HanXinCodeByteEncodingName : string with get, set
member HanXinCodeByteEncodingName : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.HanXinCodeEncoding Property

BarcodeProfessional HanXinCodeEncoding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Han Xin Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HanXinCodeEncoding HanXinCodeEncoding { get; set; }
public HanXinCodeEncoding HanXinCodeEncoding { get; set; }
Public Property HanXinCodeEncoding As HanXinCodeEncoding
    Get
    Set
Public Property HanXinCodeEncoding As HanXinCodeEncoding
    Get
    Set
public:
property HanXinCodeEncoding HanXinCodeEncoding {
    HanXinCodeEncoding get ();
    void set (HanXinCodeEncoding value);
}
public:
property HanXinCodeEncoding HanXinCodeEncoding {
    HanXinCodeEncoding get ();
    void set (HanXinCodeEncoding value);
}
member HanXinCodeEncoding : HanXinCodeEncoding with get, set
member HanXinCodeEncoding : HanXinCodeEncoding with get, set

Property Value

Type: HanXinCodeEncoding
See Also


BarcodeProfessional.HanXinCodeErrorCorrectionLevel Property

BarcodeProfessional HanXinCodeErrorCorrectionLevel Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Error Correction Level to apply for Han Xin Code symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel { get; set; }
public HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel { get; set; }
Public Property HanXinCodeErrorCorrectionLevel As HanXinCodeErrorCorrectionLevel
    Get
    Set
Public Property HanXinCodeErrorCorrectionLevel As HanXinCodeErrorCorrectionLevel
    Get
    Set
public:
property HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel {
    HanXinCodeErrorCorrectionLevel get ();
    void set (HanXinCodeErrorCorrectionLevel value);
}
public:
property HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel {
    HanXinCodeErrorCorrectionLevel get ();
    void set (HanXinCodeErrorCorrectionLevel value);
}
member HanXinCodeErrorCorrectionLevel : HanXinCodeErrorCorrectionLevel with get, set
member HanXinCodeErrorCorrectionLevel : HanXinCodeErrorCorrectionLevel with get, set

Property Value

Type: HanXinCodeErrorCorrectionLevel
See Also


BarcodeProfessional.HanXinCodeModuleSize Property

BarcodeProfessional HanXinCodeModuleSize Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double HanXinCodeModuleSize { get; set; }
public double HanXinCodeModuleSize { get; set; }
Public Property HanXinCodeModuleSize As Double
    Get
    Set
Public Property HanXinCodeModuleSize As Double
    Get
    Set
public:
property double HanXinCodeModuleSize {
    double get ();
    void set (double value);
}
public:
property double HanXinCodeModuleSize {
    double get ();
    void set (double value);
}
member HanXinCodeModuleSize : float with get, set
member HanXinCodeModuleSize : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.HanXinCodeProcessTilde Property

BarcodeProfessional HanXinCodeProcessTilde Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether tilde character should be processed when Han Xin Code is being generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HanXinCodeProcessTilde { get; set; }
public bool HanXinCodeProcessTilde { get; set; }
Public Property HanXinCodeProcessTilde As Boolean
    Get
    Set
Public Property HanXinCodeProcessTilde As Boolean
    Get
    Set
public:
property bool HanXinCodeProcessTilde {
    bool get ();
    void set (bool value);
}
public:
property bool HanXinCodeProcessTilde {
    bool get ();
    void set (bool value);
}
member HanXinCodeProcessTilde : bool with get, set
member HanXinCodeProcessTilde : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.HanXinCodeVersion Property

BarcodeProfessional HanXinCodeVersion Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Han Xin Code Version to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public HanXinCodeVersion HanXinCodeVersion { get; set; }
public HanXinCodeVersion HanXinCodeVersion { get; set; }
Public Property HanXinCodeVersion As HanXinCodeVersion
    Get
    Set
Public Property HanXinCodeVersion As HanXinCodeVersion
    Get
    Set
public:
property HanXinCodeVersion HanXinCodeVersion {
    HanXinCodeVersion get ();
    void set (HanXinCodeVersion value);
}
public:
property HanXinCodeVersion HanXinCodeVersion {
    HanXinCodeVersion get ();
    void set (HanXinCodeVersion value);
}
member HanXinCodeVersion : HanXinCodeVersion with get, set
member HanXinCodeVersion : HanXinCodeVersion with get, set

Property Value

Type: HanXinCodeVersion
See Also


BarcodeProfessional.Height Property

BarcodeProfessional Height Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the height of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Height { get; set; }
public double Height { get; set; }
Public Property Height As Double
    Get
    Set
Public Property Height As Double
    Get
    Set
public:
property double Height {
    double get ();
    void set (double value);
}
public:
property double Height {
    double get ();
    void set (double value);
}
member Height : float with get, set
member Height : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.HibcFormatHumanReadableText Property

BarcodeProfessional HibcFormatHumanReadableText Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HibcFormatHumanReadableText { get; set; }
public bool HibcFormatHumanReadableText { get; set; }
Public Property HibcFormatHumanReadableText As Boolean
    Get
    Set
Public Property HibcFormatHumanReadableText As Boolean
    Get
    Set
public:
property bool HibcFormatHumanReadableText {
    bool get ();
    void set (bool value);
}
public:
property bool HibcFormatHumanReadableText {
    bool get ();
    void set (bool value);
}
member HibcFormatHumanReadableText : bool with get, set
member HibcFormatHumanReadableText : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.HibcUseIsoIec15434Encoding Property

BarcodeProfessional HibcUseIsoIec15434Encoding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool HibcUseIsoIec15434Encoding { get; set; }
public bool HibcUseIsoIec15434Encoding { get; set; }
Public Property HibcUseIsoIec15434Encoding As Boolean
    Get
    Set
Public Property HibcUseIsoIec15434Encoding As Boolean
    Get
    Set
public:
property bool HibcUseIsoIec15434Encoding {
    bool get ();
    void set (bool value);
}
public:
property bool HibcUseIsoIec15434Encoding {
    bool get ();
    void set (bool value);
}
member HibcUseIsoIec15434Encoding : bool with get, set
member HibcUseIsoIec15434Encoding : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.HumanReadableText Property

BarcodeProfessional HumanReadableText Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string HumanReadableText { get; set; }
public string HumanReadableText { get; set; }
Public Property HumanReadableText As String
    Get
    Set
Public Property HumanReadableText As String
    Get
    Set
public:
property String^ HumanReadableText {
    String^ get ();
    void set (String^ value);
}
public:
property String^ HumanReadableText {
    String^ get ();
    void set (String^ value);
}
member HumanReadableText : string with get, set
member HumanReadableText : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.Image Property

BarcodeProfessional Image Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a System.Drawing.Image object of the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Image Image { get; }
public Image Image { get; }
Public ReadOnly Property Image As Image
    Get
Public ReadOnly Property Image As Image
    Get
public:
property Image^ Image {
    Image^ get ();
}
public:
property Image^ Image {
    Image^ get ();
}
member Image : Image with get
member Image : Image with get

Property Value

Type: Online Image
See Also


BarcodeProfessional.Isbt128DataStructure Property

BarcodeProfessional Isbt128DataStructure Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the ISBT 128 Data Structure to be generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Isbt128DataStructure Isbt128DataStructure { get; set; }
public Isbt128DataStructure Isbt128DataStructure { get; set; }
Public Property Isbt128DataStructure As Isbt128DataStructure
    Get
    Set
Public Property Isbt128DataStructure As Isbt128DataStructure
    Get
    Set
public:
property Isbt128DataStructure Isbt128DataStructure {
    Isbt128DataStructure get ();
    void set (Isbt128DataStructure value);
}
public:
property Isbt128DataStructure Isbt128DataStructure {
    Isbt128DataStructure get ();
    void set (Isbt128DataStructure value);
}
member Isbt128DataStructure : Isbt128DataStructure with get, set
member Isbt128DataStructure : Isbt128DataStructure with get, set

Property Value

Type: Isbt128DataStructure
See Also


BarcodeProfessional.IsCodeValid Property

BarcodeProfessional IsCodeValid Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a value indicating whether the value to encode specified in the Code property is valid based on the Barcode Symbology specified in the Symbology property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool IsCodeValid { get; }
public bool IsCodeValid { get; }
Public ReadOnly Property IsCodeValid As Boolean
    Get
Public ReadOnly Property IsCodeValid As Boolean
    Get
public:
property bool IsCodeValid {
    bool get ();
}
public:
property bool IsCodeValid {
    bool get ();
}
member IsCodeValid : bool with get
member IsCodeValid : bool with get

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.Itf14LeftHMark Property

BarcodeProfessional Itf14LeftHMark Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ItfHmark Itf14LeftHMark { get; set; }
public ItfHmark Itf14LeftHMark { get; set; }
Public Property Itf14LeftHMark As ItfHmark
    Get
    Set
Public Property Itf14LeftHMark As ItfHmark
    Get
    Set
public:
property ItfHmark Itf14LeftHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}
public:
property ItfHmark Itf14LeftHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}
member Itf14LeftHMark : ItfHmark with get, set
member Itf14LeftHMark : ItfHmark with get, set

Property Value

Type: ItfHmark
See Also


BarcodeProfessional.Itf14RightHMark Property

BarcodeProfessional Itf14RightHMark Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public ItfHmark Itf14RightHMark { get; set; }
public ItfHmark Itf14RightHMark { get; set; }
Public Property Itf14RightHMark As ItfHmark
    Get
    Set
Public Property Itf14RightHMark As ItfHmark
    Get
    Set
public:
property ItfHmark Itf14RightHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}
public:
property ItfHmark Itf14RightHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}
member Itf14RightHMark : ItfHmark with get, set
member Itf14RightHMark : ItfHmark with get, set

Property Value

Type: ItfHmark
See Also


BarcodeProfessional.LicenseKey Property

BarcodeProfessional LicenseKey Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the License Key.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LicenseKey { get; set; }
public static string LicenseKey { get; set; }
Public Shared Property LicenseKey As String
    Get
    Set
Public Shared Property LicenseKey As String
    Get
    Set
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}
static member LicenseKey : string with get, set
static member LicenseKey : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.LicenseOwner Property

BarcodeProfessional LicenseOwner Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the License Owner.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string LicenseOwner { get; set; }
public static string LicenseOwner { get; set; }
Public Shared Property LicenseOwner As String
    Get
    Set
Public Shared Property LicenseOwner As String
    Get
    Set
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}
static member LicenseOwner : string with get, set
static member LicenseOwner : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.MaxiCodeDrawPixelBasedSymbol Property

BarcodeProfessional MaxiCodeDrawPixelBasedSymbol Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the MaxiCode symbol is drawn by using a Pixel Based method; otherwise, a Vector based method is used.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MaxiCodeDrawPixelBasedSymbol { get; set; }
public bool MaxiCodeDrawPixelBasedSymbol { get; set; }
Public Property MaxiCodeDrawPixelBasedSymbol As Boolean
    Get
    Set
Public Property MaxiCodeDrawPixelBasedSymbol As Boolean
    Get
    Set
public:
property bool MaxiCodeDrawPixelBasedSymbol {
    bool get ();
    void set (bool value);
}
public:
property bool MaxiCodeDrawPixelBasedSymbol {
    bool get ();
    void set (bool value);
}
member MaxiCodeDrawPixelBasedSymbol : bool with get, set
member MaxiCodeDrawPixelBasedSymbol : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.MaxiCodeMode Property

BarcodeProfessional MaxiCodeMode Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the MaxiCode mode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MaxiCodeModes MaxiCodeMode { get; set; }
public MaxiCodeModes MaxiCodeMode { get; set; }
Public Property MaxiCodeMode As MaxiCodeModes
    Get
    Set
Public Property MaxiCodeMode As MaxiCodeModes
    Get
    Set
public:
property MaxiCodeModes MaxiCodeMode {
    MaxiCodeModes get ();
    void set (MaxiCodeModes value);
}
public:
property MaxiCodeModes MaxiCodeMode {
    MaxiCodeModes get ();
    void set (MaxiCodeModes value);
}
member MaxiCodeMode : MaxiCodeModes with get, set
member MaxiCodeMode : MaxiCodeModes with get, set

Property Value

Type: MaxiCodeModes
See Also


BarcodeProfessional.MaxiCodeProcessTilde Property

BarcodeProfessional MaxiCodeProcessTilde Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether tilde character should be processed when MaxiCode code is being generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool MaxiCodeProcessTilde { get; set; }
public bool MaxiCodeProcessTilde { get; set; }
Public Property MaxiCodeProcessTilde As Boolean
    Get
    Set
Public Property MaxiCodeProcessTilde As Boolean
    Get
    Set
public:
property bool MaxiCodeProcessTilde {
    bool get ();
    void set (bool value);
}
public:
property bool MaxiCodeProcessTilde {
    bool get ();
    void set (bool value);
}
member MaxiCodeProcessTilde : bool with get, set
member MaxiCodeProcessTilde : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.MaxiCodeSymbolCount Property

BarcodeProfessional MaxiCodeSymbolCount Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxiCodeSymbolCount { get; set; }
public int MaxiCodeSymbolCount { get; set; }
Public Property MaxiCodeSymbolCount As Integer
    Get
    Set
Public Property MaxiCodeSymbolCount As Integer
    Get
    Set
public:
property int MaxiCodeSymbolCount {
    int get ();
    void set (int value);
}
public:
property int MaxiCodeSymbolCount {
    int get ();
    void set (int value);
}
member MaxiCodeSymbolCount : int with get, set
member MaxiCodeSymbolCount : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.MaxiCodeSymbolIndex Property

BarcodeProfessional MaxiCodeSymbolIndex Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int MaxiCodeSymbolIndex { get; set; }
public int MaxiCodeSymbolIndex { get; set; }
Public Property MaxiCodeSymbolIndex As Integer
    Get
    Set
Public Property MaxiCodeSymbolIndex As Integer
    Get
    Set
public:
property int MaxiCodeSymbolIndex {
    int get ();
    void set (int value);
}
public:
property int MaxiCodeSymbolIndex {
    int get ();
    void set (int value);
}
member MaxiCodeSymbolIndex : int with get, set
member MaxiCodeSymbolIndex : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.MICRCharHeight Property

BarcodeProfessional MICRCharHeight Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the height of the MICR characters. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double MICRCharHeight { get; set; }
public double MICRCharHeight { get; set; }
Public Property MICRCharHeight As Double
    Get
    Set
Public Property MICRCharHeight As Double
    Get
    Set
public:
property double MICRCharHeight {
    double get ();
    void set (double value);
}
public:
property double MICRCharHeight {
    double get ();
    void set (double value);
}
member MICRCharHeight : float with get, set
member MICRCharHeight : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.MICRCharSpacing Property

BarcodeProfessional MICRCharSpacing Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the gap spacing between each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired spacing between each MICR char. The unit of measure must be specified to BarcodeUnit property IMPORTANT: Spacing is the distance between the right average edge of adjacent characters.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MICRCharSpacing { get; set; }
public string MICRCharSpacing { get; set; }
Public Property MICRCharSpacing As String
    Get
    Set
Public Property MICRCharSpacing As String
    Get
    Set
public:
property String^ MICRCharSpacing {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MICRCharSpacing {
    String^ get ();
    void set (String^ value);
}
member MICRCharSpacing : string with get, set
member MICRCharSpacing : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.MICRCharWidths Property

BarcodeProfessional MICRCharWidths Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the widths of each MICR character specified in the Code property. It must be a comma separated list of float point numbers (in InvariantCulture) specifying the desired width of each MICR char. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string MICRCharWidths { get; set; }
public string MICRCharWidths { get; set; }
Public Property MICRCharWidths As String
    Get
    Set
Public Property MICRCharWidths As String
    Get
    Set
public:
property String^ MICRCharWidths {
    String^ get ();
    void set (String^ value);
}
public:
property String^ MICRCharWidths {
    String^ get ();
    void set (String^ value);
}
member MICRCharWidths : string with get, set
member MICRCharWidths : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.MicroPdf417Version Property

BarcodeProfessional MicroPdf417Version Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MicroPdf417Version MicroPdf417Version { get; set; }
public MicroPdf417Version MicroPdf417Version { get; set; }
Public Property MicroPdf417Version As MicroPdf417Version
    Get
    Set
Public Property MicroPdf417Version As MicroPdf417Version
    Get
    Set
public:
property MicroPdf417Version MicroPdf417Version {
    MicroPdf417Version get ();
    void set (MicroPdf417Version value);
}
public:
property MicroPdf417Version MicroPdf417Version {
    MicroPdf417Version get ();
    void set (MicroPdf417Version value);
}
member MicroPdf417Version : MicroPdf417Version with get, set
member MicroPdf417Version : MicroPdf417Version with get, set

Property Value

Type: MicroPdf417Version
See Also


BarcodeProfessional.MicroQRCodeVersion Property

BarcodeProfessional MicroQRCodeVersion Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Micro QR Code Version to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MicroQRCodeVersion MicroQRCodeVersion { get; set; }
public MicroQRCodeVersion MicroQRCodeVersion { get; set; }
Public Property MicroQRCodeVersion As MicroQRCodeVersion
    Get
    Set
Public Property MicroQRCodeVersion As MicroQRCodeVersion
    Get
    Set
public:
property MicroQRCodeVersion MicroQRCodeVersion {
    MicroQRCodeVersion get ();
    void set (MicroQRCodeVersion value);
}
public:
property MicroQRCodeVersion MicroQRCodeVersion {
    MicroQRCodeVersion get ();
    void set (MicroQRCodeVersion value);
}
member MicroQRCodeVersion : MicroQRCodeVersion with get, set
member MicroQRCodeVersion : MicroQRCodeVersion with get, set

Property Value

Type: MicroQRCodeVersion
See Also


BarcodeProfessional.Monochrome Property

BarcodeProfessional Monochrome Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets a value indicating whether the barcode image must be converted to monochrome a.k.a. Black and White 1 bit per pixel format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Monochrome { get; set; }
public bool Monochrome { get; set; }
Public Property Monochrome As Boolean
    Get
    Set
Public Property Monochrome As Boolean
    Get
    Set
public:
property bool Monochrome {
    bool get ();
    void set (bool value);
}
public:
property bool Monochrome {
    bool get ();
    void set (bool value);
}
member Monochrome : bool with get, set
member Monochrome : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.MsiChecksum Property

BarcodeProfessional MsiChecksum Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the checksum mode to be used on MSI symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public MsiChecksum MsiChecksum { get; set; }
public MsiChecksum MsiChecksum { get; set; }
Public Property MsiChecksum As MsiChecksum
    Get
    Set
Public Property MsiChecksum As MsiChecksum
    Get
    Set
public:
property MsiChecksum MsiChecksum {
    MsiChecksum get ();
    void set (MsiChecksum value);
}
public:
property MsiChecksum MsiChecksum {
    MsiChecksum get ();
    void set (MsiChecksum value);
}
member MsiChecksum : MsiChecksum with get, set
member MsiChecksum : MsiChecksum with get, set

Property Value

Type: MsiChecksum
See Also


BarcodeProfessional.OutputSettings Property

BarcodeProfessional OutputSettings Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets a list of settings that were used to generate the selected symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Hashtable OutputSettings { get; }
public Hashtable OutputSettings { get; }
Public ReadOnly Property OutputSettings As Hashtable
    Get
Public ReadOnly Property OutputSettings As Hashtable
    Get
public:
property Hashtable^ OutputSettings {
    Hashtable^ get ();
}
public:
property Hashtable^ OutputSettings {
    Hashtable^ get ();
}
member OutputSettings : Hashtable with get
member OutputSettings : Hashtable with get

Property Value

Type: Online Hashtable
Remarks

Some barcode symbologies have properties with an Auto option which means that the algorithm should select it at runtime based on some parameters.

This list will contain the Property Name as the 'Key' and its runtime value as the 'Value'. E.g. if a QR Code was generated and QRCodeVersion property was set to Auto, then this list will containg an entry which 'Key' is "QRCodeVersion" and its value could be "V10" (for Version 10)

See Also


BarcodeProfessional.Pdf417AspectRatio Property

BarcodeProfessional Pdf417AspectRatio Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Pdf417AspectRatio { get; set; }
public double Pdf417AspectRatio { get; set; }
Public Property Pdf417AspectRatio As Double
    Get
    Set
Public Property Pdf417AspectRatio As Double
    Get
    Set
public:
property double Pdf417AspectRatio {
    double get ();
    void set (double value);
}
public:
property double Pdf417AspectRatio {
    double get ();
    void set (double value);
}
member Pdf417AspectRatio : float with get, set
member Pdf417AspectRatio : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Pdf417ByteEncodingName Property

BarcodeProfessional Pdf417ByteEncodingName Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Pdf417ByteEncodingName { get; set; }
public string Pdf417ByteEncodingName { get; set; }
Public Property Pdf417ByteEncodingName As String
    Get
    Set
Public Property Pdf417ByteEncodingName As String
    Get
    Set
public:
property String^ Pdf417ByteEncodingName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Pdf417ByteEncodingName {
    String^ get ();
    void set (String^ value);
}
member Pdf417ByteEncodingName : string with get, set
member Pdf417ByteEncodingName : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.Pdf417Columns Property

BarcodeProfessional Pdf417Columns Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of columns to use for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Pdf417Columns { get; set; }
public int Pdf417Columns { get; set; }
Public Property Pdf417Columns As Integer
    Get
    Set
Public Property Pdf417Columns As Integer
    Get
    Set
public:
property int Pdf417Columns {
    int get ();
    void set (int value);
}
public:
property int Pdf417Columns {
    int get ();
    void set (int value);
}
member Pdf417Columns : int with get, set
member Pdf417Columns : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.Pdf417CompactionType Property

BarcodeProfessional Pdf417CompactionType Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Compaction Type to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Pdf417CompactionType Pdf417CompactionType { get; set; }
public Pdf417CompactionType Pdf417CompactionType { get; set; }
Public Property Pdf417CompactionType As Pdf417CompactionType
    Get
    Set
Public Property Pdf417CompactionType As Pdf417CompactionType
    Get
    Set
public:
property Pdf417CompactionType Pdf417CompactionType {
    Pdf417CompactionType get ();
    void set (Pdf417CompactionType value);
}
public:
property Pdf417CompactionType Pdf417CompactionType {
    Pdf417CompactionType get ();
    void set (Pdf417CompactionType value);
}
member Pdf417CompactionType : Pdf417CompactionType with get, set
member Pdf417CompactionType : Pdf417CompactionType with get, set

Property Value

Type: Pdf417CompactionType
See Also


BarcodeProfessional.Pdf417ErrorCorrectionLevel Property

BarcodeProfessional Pdf417ErrorCorrectionLevel Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Error Correction Level to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel { get; set; }
public Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel { get; set; }
Public Property Pdf417ErrorCorrectionLevel As Pdf417ErrorCorrection
    Get
    Set
Public Property Pdf417ErrorCorrectionLevel As Pdf417ErrorCorrection
    Get
    Set
public:
property Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel {
    Pdf417ErrorCorrection get ();
    void set (Pdf417ErrorCorrection value);
}
public:
property Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel {
    Pdf417ErrorCorrection get ();
    void set (Pdf417ErrorCorrection value);
}
member Pdf417ErrorCorrectionLevel : Pdf417ErrorCorrection with get, set
member Pdf417ErrorCorrectionLevel : Pdf417ErrorCorrection with get, set

Property Value

Type: Pdf417ErrorCorrection
See Also


BarcodeProfessional.Pdf417FileId Property

BarcodeProfessional Pdf417FileId Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Pdf417FileId { get; set; }
public string Pdf417FileId { get; set; }
Public Property Pdf417FileId As String
    Get
    Set
Public Property Pdf417FileId As String
    Get
    Set
public:
property String^ Pdf417FileId {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Pdf417FileId {
    String^ get ();
    void set (String^ value);
}
member Pdf417FileId : string with get, set
member Pdf417FileId : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.Pdf417Rows Property

BarcodeProfessional Pdf417Rows Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of rows to use for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Pdf417Rows { get; set; }
public int Pdf417Rows { get; set; }
Public Property Pdf417Rows As Integer
    Get
    Set
Public Property Pdf417Rows As Integer
    Get
    Set
public:
property int Pdf417Rows {
    int get ();
    void set (int value);
}
public:
property int Pdf417Rows {
    int get ();
    void set (int value);
}
member Pdf417Rows : int with get, set
member Pdf417Rows : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.Pdf417SegmentCount Property

BarcodeProfessional Pdf417SegmentCount Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Pdf417SegmentCount { get; set; }
public int Pdf417SegmentCount { get; set; }
Public Property Pdf417SegmentCount As Integer
    Get
    Set
Public Property Pdf417SegmentCount As Integer
    Get
    Set
public:
property int Pdf417SegmentCount {
    int get ();
    void set (int value);
}
public:
property int Pdf417SegmentCount {
    int get ();
    void set (int value);
}
member Pdf417SegmentCount : int with get, set
member Pdf417SegmentCount : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.Pdf417SegmentIndex Property

BarcodeProfessional Pdf417SegmentIndex Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int Pdf417SegmentIndex { get; set; }
public int Pdf417SegmentIndex { get; set; }
Public Property Pdf417SegmentIndex As Integer
    Get
    Set
Public Property Pdf417SegmentIndex As Integer
    Get
    Set
public:
property int Pdf417SegmentIndex {
    int get ();
    void set (int value);
}
public:
property int Pdf417SegmentIndex {
    int get ();
    void set (int value);
}
member Pdf417SegmentIndex : int with get, set
member Pdf417SegmentIndex : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.Pdf417Truncated Property

BarcodeProfessional Pdf417Truncated Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether the right side of PDF417 barcode is truncated (removed).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Pdf417Truncated { get; set; }
public bool Pdf417Truncated { get; set; }
Public Property Pdf417Truncated As Boolean
    Get
    Set
Public Property Pdf417Truncated As Boolean
    Get
    Set
public:
property bool Pdf417Truncated {
    bool get ();
    void set (bool value);
}
public:
property bool Pdf417Truncated {
    bool get ();
    void set (bool value);
}
member Pdf417Truncated : bool with get, set
member Pdf417Truncated : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.PharmacodeBarsSpacing Property

BarcodeProfessional PharmacodeBarsSpacing Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the gap between Pharmacode bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PharmacodeBarsSpacing { get; set; }
public double PharmacodeBarsSpacing { get; set; }
Public Property PharmacodeBarsSpacing As Double
    Get
    Set
Public Property PharmacodeBarsSpacing As Double
    Get
    Set
public:
property double PharmacodeBarsSpacing {
    double get ();
    void set (double value);
}
public:
property double PharmacodeBarsSpacing {
    double get ();
    void set (double value);
}
member PharmacodeBarsSpacing : float with get, set
member PharmacodeBarsSpacing : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PharmacodeThickBarWidth Property

BarcodeProfessional PharmacodeThickBarWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the width of Pharmacode Thick Bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PharmacodeThickBarWidth { get; set; }
public double PharmacodeThickBarWidth { get; set; }
Public Property PharmacodeThickBarWidth As Double
    Get
    Set
Public Property PharmacodeThickBarWidth As Double
    Get
    Set
public:
property double PharmacodeThickBarWidth {
    double get ();
    void set (double value);
}
public:
property double PharmacodeThickBarWidth {
    double get ();
    void set (double value);
}
member PharmacodeThickBarWidth : float with get, set
member PharmacodeThickBarWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PharmacodeThinBarWidth Property

BarcodeProfessional PharmacodeThinBarWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the width of Pharmacode Thin Bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PharmacodeThinBarWidth { get; set; }
public double PharmacodeThinBarWidth { get; set; }
Public Property PharmacodeThinBarWidth As Double
    Get
    Set
Public Property PharmacodeThinBarWidth As Double
    Get
    Set
public:
property double PharmacodeThinBarWidth {
    double get ();
    void set (double value);
}
public:
property double PharmacodeThinBarWidth {
    double get ();
    void set (double value);
}
member PharmacodeThinBarWidth : float with get, set
member PharmacodeThinBarWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PlanetHeightShortBar Property

BarcodeProfessional PlanetHeightShortBar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the short bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PlanetHeightShortBar { get; set; }
public double PlanetHeightShortBar { get; set; }
Public Property PlanetHeightShortBar As Double
    Get
    Set
Public Property PlanetHeightShortBar As Double
    Get
    Set
public:
property double PlanetHeightShortBar {
    double get ();
    void set (double value);
}
public:
property double PlanetHeightShortBar {
    double get ();
    void set (double value);
}
member PlanetHeightShortBar : float with get, set
member PlanetHeightShortBar : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PlanetHeightTallBar Property

BarcodeProfessional PlanetHeightTallBar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the tall bars' height of Planet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PlanetHeightTallBar { get; set; }
public double PlanetHeightTallBar { get; set; }
Public Property PlanetHeightTallBar As Double
    Get
    Set
Public Property PlanetHeightTallBar As Double
    Get
    Set
public:
property double PlanetHeightTallBar {
    double get ();
    void set (double value);
}
public:
property double PlanetHeightTallBar {
    double get ();
    void set (double value);
}
member PlanetHeightTallBar : float with get, set
member PlanetHeightTallBar : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Postal4StateAddStartStopChar Property

BarcodeProfessional Postal4StateAddStartStopChar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether start and stop characters must be added and drawn in the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool Postal4StateAddStartStopChar { get; set; }
public bool Postal4StateAddStartStopChar { get; set; }
Public Property Postal4StateAddStartStopChar As Boolean
    Get
    Set
Public Property Postal4StateAddStartStopChar As Boolean
    Get
    Set
public:
property bool Postal4StateAddStartStopChar {
    bool get ();
    void set (bool value);
}
public:
property bool Postal4StateAddStartStopChar {
    bool get ();
    void set (bool value);
}
member Postal4StateAddStartStopChar : bool with get, set
member Postal4StateAddStartStopChar : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.Postal4StateBarsSpacing Property

BarcodeProfessional Postal4StateBarsSpacing Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the gap spacing between bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Postal4StateBarsSpacing { get; set; }
public double Postal4StateBarsSpacing { get; set; }
Public Property Postal4StateBarsSpacing As Double
    Get
    Set
Public Property Postal4StateBarsSpacing As Double
    Get
    Set
public:
property double Postal4StateBarsSpacing {
    double get ();
    void set (double value);
}
public:
property double Postal4StateBarsSpacing {
    double get ();
    void set (double value);
}
member Postal4StateBarsSpacing : float with get, set
member Postal4StateBarsSpacing : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Postal4StateTrackerBarHeight Property

BarcodeProfessional Postal4StateTrackerBarHeight Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the tracker bar's height. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Postal4StateTrackerBarHeight { get; set; }
public double Postal4StateTrackerBarHeight { get; set; }
Public Property Postal4StateTrackerBarHeight As Double
    Get
    Set
Public Property Postal4StateTrackerBarHeight As Double
    Get
    Set
public:
property double Postal4StateTrackerBarHeight {
    double get ();
    void set (double value);
}
public:
property double Postal4StateTrackerBarHeight {
    double get ();
    void set (double value);
}
member Postal4StateTrackerBarHeight : float with get, set
member Postal4StateTrackerBarHeight : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Postal4StateTrackerBarWidth Property

BarcodeProfessional Postal4StateTrackerBarWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the tracker bar's width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Postal4StateTrackerBarWidth { get; set; }
public double Postal4StateTrackerBarWidth { get; set; }
Public Property Postal4StateTrackerBarWidth As Double
    Get
    Set
Public Property Postal4StateTrackerBarWidth As Double
    Get
    Set
public:
property double Postal4StateTrackerBarWidth {
    double get ();
    void set (double value);
}
public:
property double Postal4StateTrackerBarWidth {
    double get ();
    void set (double value);
}
member Postal4StateTrackerBarWidth : float with get, set
member Postal4StateTrackerBarWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PostnetHeightShortBar Property

BarcodeProfessional PostnetHeightShortBar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the short bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PostnetHeightShortBar { get; set; }
public double PostnetHeightShortBar { get; set; }
Public Property PostnetHeightShortBar As Double
    Get
    Set
Public Property PostnetHeightShortBar As Double
    Get
    Set
public:
property double PostnetHeightShortBar {
    double get ();
    void set (double value);
}
public:
property double PostnetHeightShortBar {
    double get ();
    void set (double value);
}
member PostnetHeightShortBar : float with get, set
member PostnetHeightShortBar : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.PostnetHeightTallBar Property

BarcodeProfessional PostnetHeightTallBar Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the tall bars' height of Postnet symbology. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double PostnetHeightTallBar { get; set; }
public double PostnetHeightTallBar { get; set; }
Public Property PostnetHeightTallBar As Double
    Get
    Set
Public Property PostnetHeightTallBar As Double
    Get
    Set
public:
property double PostnetHeightTallBar {
    double get ();
    void set (double value);
}
public:
property double PostnetHeightTallBar {
    double get ();
    void set (double value);
}
member PostnetHeightTallBar : float with get, set
member PostnetHeightTallBar : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.QRCodeByteEncodingName Property

BarcodeProfessional QRCodeByteEncodingName Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string QRCodeByteEncodingName { get; set; }
public string QRCodeByteEncodingName { get; set; }
Public Property QRCodeByteEncodingName As String
    Get
    Set
Public Property QRCodeByteEncodingName As String
    Get
    Set
public:
property String^ QRCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
public:
property String^ QRCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}
member QRCodeByteEncodingName : string with get, set
member QRCodeByteEncodingName : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.QRCodeEncoding Property

BarcodeProfessional QRCodeEncoding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the QR Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRCodeEncoding QRCodeEncoding { get; set; }
public QRCodeEncoding QRCodeEncoding { get; set; }
Public Property QRCodeEncoding As QRCodeEncoding
    Get
    Set
Public Property QRCodeEncoding As QRCodeEncoding
    Get
    Set
public:
property QRCodeEncoding QRCodeEncoding {
    QRCodeEncoding get ();
    void set (QRCodeEncoding value);
}
public:
property QRCodeEncoding QRCodeEncoding {
    QRCodeEncoding get ();
    void set (QRCodeEncoding value);
}
member QRCodeEncoding : QRCodeEncoding with get, set
member QRCodeEncoding : QRCodeEncoding with get, set

Property Value

Type: QRCodeEncoding
See Also


BarcodeProfessional.QRCodeErrorCorrectionLevel Property

BarcodeProfessional QRCodeErrorCorrectionLevel Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Error Correction Level to apply for QR Code symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel { get; set; }
public QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel { get; set; }
Public Property QRCodeErrorCorrectionLevel As QRCodeErrorCorrectionLevel
    Get
    Set
Public Property QRCodeErrorCorrectionLevel As QRCodeErrorCorrectionLevel
    Get
    Set
public:
property QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel {
    QRCodeErrorCorrectionLevel get ();
    void set (QRCodeErrorCorrectionLevel value);
}
public:
property QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel {
    QRCodeErrorCorrectionLevel get ();
    void set (QRCodeErrorCorrectionLevel value);
}
member QRCodeErrorCorrectionLevel : QRCodeErrorCorrectionLevel with get, set
member QRCodeErrorCorrectionLevel : QRCodeErrorCorrectionLevel with get, set

Property Value

Type: QRCodeErrorCorrectionLevel
See Also


BarcodeProfessional.QRCodeModuleSize Property

BarcodeProfessional QRCodeModuleSize Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double QRCodeModuleSize { get; set; }
public double QRCodeModuleSize { get; set; }
Public Property QRCodeModuleSize As Double
    Get
    Set
Public Property QRCodeModuleSize As Double
    Get
    Set
public:
property double QRCodeModuleSize {
    double get ();
    void set (double value);
}
public:
property double QRCodeModuleSize {
    double get ();
    void set (double value);
}
member QRCodeModuleSize : float with get, set
member QRCodeModuleSize : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.QRCodeProcessTilde Property

BarcodeProfessional QRCodeProcessTilde Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether tilde character should be processed when QR Code is being generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool QRCodeProcessTilde { get; set; }
public bool QRCodeProcessTilde { get; set; }
Public Property QRCodeProcessTilde As Boolean
    Get
    Set
Public Property QRCodeProcessTilde As Boolean
    Get
    Set
public:
property bool QRCodeProcessTilde {
    bool get ();
    void set (bool value);
}
public:
property bool QRCodeProcessTilde {
    bool get ();
    void set (bool value);
}
member QRCodeProcessTilde : bool with get, set
member QRCodeProcessTilde : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.QRCodeVersion Property

BarcodeProfessional QRCodeVersion Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the QR Code Version to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public QRCodeVersion QRCodeVersion { get; set; }
public QRCodeVersion QRCodeVersion { get; set; }
Public Property QRCodeVersion As QRCodeVersion
    Get
    Set
Public Property QRCodeVersion As QRCodeVersion
    Get
    Set
public:
property QRCodeVersion QRCodeVersion {
    QRCodeVersion get ();
    void set (QRCodeVersion value);
}
public:
property QRCodeVersion QRCodeVersion {
    QRCodeVersion get ();
    void set (QRCodeVersion value);
}
member QRCodeVersion : QRCodeVersion with get, set
member QRCodeVersion : QRCodeVersion with get, set

Property Value

Type: QRCodeVersion
See Also


BarcodeProfessional.QuietZoneWidth Property

BarcodeProfessional QuietZoneWidth Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the quiet zone's width. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double QuietZoneWidth { get; set; }
public double QuietZoneWidth { get; set; }
Public Property QuietZoneWidth As Double
    Get
    Set
Public Property QuietZoneWidth As Double
    Get
    Set
public:
property double QuietZoneWidth {
    double get ();
    void set (double value);
}
public:
property double QuietZoneWidth {
    double get ();
    void set (double value);
}
member QuietZoneWidth : float with get, set
member QuietZoneWidth : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.Rotate Property

BarcodeProfessional Rotate Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the rotation angle to apply on the barcode image.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Rotate Rotate { get; set; }
public Rotate Rotate { get; set; }
Public Property Rotate As Rotate
    Get
    Set
Public Property Rotate As Rotate
    Get
    Set
public:
property Rotate Rotate {
    Rotate get ();
    void set (Rotate value);
}
public:
property Rotate Rotate {
    Rotate get ();
    void set (Rotate value);
}
member Rotate : Rotate with get, set
member Rotate : Rotate with get, set

Property Value

Type: Rotate
See Also


BarcodeProfessional.SegmentsPerRow Property

BarcodeProfessional SegmentsPerRow Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default is 4.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int SegmentsPerRow { get; set; }
public int SegmentsPerRow { get; set; }
Public Property SegmentsPerRow As Integer
    Get
    Set
Public Property SegmentsPerRow As Integer
    Get
    Set
public:
property int SegmentsPerRow {
    int get ();
    void set (int value);
}
public:
property int SegmentsPerRow {
    int get ();
    void set (int value);
}
member SegmentsPerRow : int with get, set
member SegmentsPerRow : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.SnapsToDevicePixels Property

BarcodeProfessional SnapsToDevicePixels Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets a value that determines whether barcode drawing should use device-specific pixel settings during rendering. Default value is false.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool SnapsToDevicePixels { get; set; }
public bool SnapsToDevicePixels { get; set; }
Public Property SnapsToDevicePixels As Boolean
    Get
    Set
Public Property SnapsToDevicePixels As Boolean
    Get
    Set
public:
property bool SnapsToDevicePixels {
    bool get ();
    void set (bool value);
}
public:
property bool SnapsToDevicePixels {
    bool get ();
    void set (bool value);
}
member SnapsToDevicePixels : bool with get, set
member SnapsToDevicePixels : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.Symbology Property

BarcodeProfessional Symbology Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the barcode symbology to generate.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Symbology Symbology { get; set; }
public Symbology Symbology { get; set; }
Public Property Symbology As Symbology
    Get
    Set
Public Property Symbology As Symbology
    Get
    Set
public:
property Symbology Symbology {
    Symbology get ();
    void set (Symbology value);
}
public:
property Symbology Symbology {
    Symbology get ();
    void set (Symbology value);
}
member Symbology : Symbology with get, set
member Symbology : Symbology with get, set

Property Value

Type: Symbology
See Also


BarcodeProfessional.TelepenEncoding Property

BarcodeProfessional TelepenEncoding Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the Telepen Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TelepenEncoding TelepenEncoding { get; set; }
public TelepenEncoding TelepenEncoding { get; set; }
Public Property TelepenEncoding As TelepenEncoding
    Get
    Set
Public Property TelepenEncoding As TelepenEncoding
    Get
    Set
public:
property TelepenEncoding TelepenEncoding {
    TelepenEncoding get ();
    void set (TelepenEncoding value);
}
public:
property TelepenEncoding TelepenEncoding {
    TelepenEncoding get ();
    void set (TelepenEncoding value);
}
member TelepenEncoding : TelepenEncoding with get, set
member TelepenEncoding : TelepenEncoding with get, set

Property Value

Type: TelepenEncoding
See Also


BarcodeProfessional.Text Property

BarcodeProfessional Text Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the additional text to show in the barcode image e.g.: Product ID. Note: This is not the value to encode nor the Human Readable Text.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string Text { get; set; }
public string Text { get; set; }
Public Property Text As String
    Get
    Set
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set
member Text : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.TextAlignment Property

BarcodeProfessional TextAlignment Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the text alignment for Text property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Alignment TextAlignment { get; set; }
public Alignment TextAlignment { get; set; }
Public Property TextAlignment As Alignment
    Get
    Set
Public Property TextAlignment As Alignment
    Get
    Set
public:
property Alignment TextAlignment {
    Alignment get ();
    void set (Alignment value);
}
public:
property Alignment TextAlignment {
    Alignment get ();
    void set (Alignment value);
}
member TextAlignment : Alignment with get, set
member TextAlignment : Alignment with get, set

Property Value

Type: Alignment
See Also


BarcodeProfessional.TextFont Property

BarcodeProfessional TextFont Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gest or sets the Font object for using when rendering Text property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Font TextFont { get; set; }
public Font TextFont { get; set; }
Public Property TextFont As Font
    Get
    Set
Public Property TextFont As Font
    Get
    Set
public:
property Font^ TextFont {
    Font^ get ();
    void set (Font^ value);
}
public:
property Font^ TextFont {
    Font^ get ();
    void set (Font^ value);
}
member TextFont : Font with get, set
member TextFont : Font with get, set

Property Value

Type: Online Font
See Also


BarcodeProfessional.TextForeColor Property

BarcodeProfessional TextForeColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the text color for using when rendering Text property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Color TextForeColor { get; set; }
public Color TextForeColor { get; set; }
Public Property TextForeColor As Color
    Get
    Set
Public Property TextForeColor As Color
    Get
    Set
public:
property Color TextForeColor {
    Color get ();
    void set (Color value);
}
public:
property Color TextForeColor {
    Color get ();
    void set (Color value);
}
member TextForeColor : Color with get, set
member TextForeColor : Color with get, set

Property Value

Type: Online Color
See Also


BarcodeProfessional.TextFormatPattern Property

BarcodeProfessional TextFormatPattern Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public string TextFormatPattern { get; set; }
public string TextFormatPattern { get; set; }
Public Property TextFormatPattern As String
    Get
    Set
Public Property TextFormatPattern As String
    Get
    Set
public:
property String^ TextFormatPattern {
    String^ get ();
    void set (String^ value);
}
public:
property String^ TextFormatPattern {
    String^ get ();
    void set (String^ value);
}
member TextFormatPattern : string with get, set
member TextFormatPattern : string with get, set

Property Value

Type: Online String
See Also


BarcodeProfessional.TextRenderingHint Property

BarcodeProfessional TextRenderingHint Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the quality of the text rendering. Note: it is available if AntiAlias property is False. Default is SystemDefault.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TextRenderingHint TextRenderingHint { get; set; }
public TextRenderingHint TextRenderingHint { get; set; }
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set
Public Property TextRenderingHint As TextRenderingHint
    Get
    Set
public:
property TextRenderingHint TextRenderingHint {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}
public:
property TextRenderingHint TextRenderingHint {
    TextRenderingHint get ();
    void set (TextRenderingHint value);
}
member TextRenderingHint : TextRenderingHint with get, set
member TextRenderingHint : TextRenderingHint with get, set

Property Value

Type: Online TextRenderingHint
See Also


BarcodeProfessional.TiffCompression Property

BarcodeProfessional TiffCompression Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the TIFF compression algorithm to be used when saving barcodes in such image format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public TiffCompression TiffCompression { get; set; }
public TiffCompression TiffCompression { get; set; }
Public Property TiffCompression As TiffCompression
    Get
    Set
Public Property TiffCompression As TiffCompression
    Get
    Set
public:
property TiffCompression TiffCompression {
    TiffCompression get ();
    void set (TiffCompression value);
}
public:
property TiffCompression TiffCompression {
    TiffCompression get ();
    void set (TiffCompression value);
}
member TiffCompression : TiffCompression with get, set
member TiffCompression : TiffCompression with get, set

Property Value

Type: TiffCompression
See Also


BarcodeProfessional.TopMargin Property

BarcodeProfessional TopMargin Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the height of the margin above the barcode bars. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double TopMargin { get; set; }
public double TopMargin { get; set; }
Public Property TopMargin As Double
    Get
    Set
Public Property TopMargin As Double
    Get
    Set
public:
property double TopMargin {
    double get ();
    void set (double value);
}
public:
property double TopMargin {
    double get ();
    void set (double value);
}
member TopMargin : float with get, set
member TopMargin : float with get, set

Property Value

Type: Online Double
See Also


BarcodeProfessional.UpcESystem Property

BarcodeProfessional UpcESystem Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number system to use for UPC-E symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public UpcE UpcESystem { get; set; }
public UpcE UpcESystem { get; set; }
Public Property UpcESystem As UpcE
    Get
    Set
Public Property UpcESystem As UpcE
    Get
    Set
public:
property UpcE UpcESystem {
    UpcE get ();
    void set (UpcE value);
}
public:
property UpcE UpcESystem {
    UpcE get ();
    void set (UpcE value);
}
member UpcESystem : UpcE with get, set
member UpcESystem : UpcE with get, set

Property Value

Type: UpcE
See Also


BarcodeProfessional.UseQuietZoneForText Property

BarcodeProfessional UseQuietZoneForText Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool UseQuietZoneForText { get; set; }
public bool UseQuietZoneForText { get; set; }
Public Property UseQuietZoneForText As Boolean
    Get
    Set
Public Property UseQuietZoneForText As Boolean
    Get
    Set
public:
property bool UseQuietZoneForText {
    bool get ();
    void set (bool value);
}
public:
property bool UseQuietZoneForText {
    bool get ();
    void set (bool value);
}
member UseQuietZoneForText : bool with get, set
member UseQuietZoneForText : bool with get, set

Property Value

Type: Online Boolean
See Also


BarcodeProfessional.UspsFimPattern Property

BarcodeProfessional UspsFimPattern Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the USPS FIM pattern to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public FIM UspsFimPattern { get; set; }
public FIM UspsFimPattern { get; set; }
Public Property UspsFimPattern As FIM
    Get
    Set
Public Property UspsFimPattern As FIM
    Get
    Set
public:
property FIM UspsFimPattern {
    FIM get ();
    void set (FIM value);
}
public:
property FIM UspsFimPattern {
    FIM get ();
    void set (FIM value);
}
member UspsFimPattern : FIM with get, set
member UspsFimPattern : FIM with get, set

Property Value

Type: FIM
See Also


BarcodeProfessional.UspsHorizontalBarsCount Property

BarcodeProfessional UspsHorizontalBarsCount Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the number of horizontal bars to be drawn.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public int UspsHorizontalBarsCount { get; set; }
public int UspsHorizontalBarsCount { get; set; }
Public Property UspsHorizontalBarsCount As Integer
    Get
    Set
Public Property UspsHorizontalBarsCount As Integer
    Get
    Set
public:
property int UspsHorizontalBarsCount {
    int get ();
    void set (int value);
}
public:
property int UspsHorizontalBarsCount {
    int get ();
    void set (int value);
}
member UspsHorizontalBarsCount : int with get, set
member UspsHorizontalBarsCount : int with get, set

Property Value

Type: Online Int32
See Also


BarcodeProfessional.Width Property

BarcodeProfessional Width Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the width of the barcode image if AutoSize property is not enabled. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Width { get; set; }
public double Width { get; set; }
Public Property Width As Double
    Get
    Set
Public Property Width As Double
    Get
    Set
public:
property double Width {
    double get ();
    void set (double value);
}
public:
property double Width {
    double get ();
    void set (double value);
}
member Width : float with get, set
member Width : float with get, set

Property Value

Type: Online Double
See Also


BarcodeUnit Enumeration

BarcodeUnit Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the unit of measure for barcode generation.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BarcodeUnit
public enum BarcodeUnit
Public Enumeration BarcodeUnit
Public Enumeration BarcodeUnit
public enum class BarcodeUnit
public enum class BarcodeUnit
type BarcodeUnit
type BarcodeUnit
Members
Member name | Value | Description
Inch | 0 | Specifies the inch as the unit of measure.
Millimeter | 1 | Specifies the millimeter as the unit of measure.
Centimeter | 2 | Specifies the centimeter as the unit of measure.
Mils | 3 | Specifies the Mils (one-thousandth of an inch) as the unit of measure.
See Also


BarcodeUtils Class

BarcodeUtils Class Neodynamic Barcode Professional SDK for .NET Class Reference
BarcodeUtils provides additional utilities related to barcode generation.
Inheritance Hierarchy
Online System Object
Neodynamic.SDK.Barcode BarcodeUtils

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class BarcodeUtils
public class BarcodeUtils
Public Class BarcodeUtils
Public Class BarcodeUtils
public ref class BarcodeUtils
public ref class BarcodeUtils
type BarcodeUtils =  class end
type BarcodeUtils =  class end
See Also
BarcodeUtils Members


BarcodeUtils Members

BarcodeUtils Members Neodynamic Barcode Professional SDK for .NET Class Reference

The BarcodeUtils type exposes the following members.
Constructors
 | Name | Description
Public method | BarcodeUtils | Initializes a new instance of the BarcodeUtils class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
 | GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
 | GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
 | GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
 | GetDeutschePostModulus11Checksum | It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode
 | GetDhlAwbChecksum | It computes the checksum Modulus 7 used by DHL AWB barcode.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.
 | GetPpnChecksum | It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GS1DataStrictValidation | It validates the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. An BarcodeException will be thrown in case of any errors.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BarcodeUtils Class


BarcodeUtils Constructor

BarcodeUtils Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the BarcodeUtils class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public BarcodeUtils()
public BarcodeUtils()
Public Sub New
Public Sub New
public:
BarcodeUtils()
public:
BarcodeUtils()
new : unit -> BarcodeUtils
new : unit -> BarcodeUtils
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils Methods

BarcodeUtils Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The BarcodeUtils type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
 | GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
 | GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
 | GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
 | GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
 | GetDeutschePostModulus11Checksum | It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode
 | GetDhlAwbChecksum | It computes the checksum Modulus 7 used by DHL AWB barcode.
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
 | GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.
 | GetPpnChecksum | It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
 | GS1DataStrictValidation | It validates the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. An BarcodeException will be thrown in case of any errors.
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
BarcodeUtils Class


BarcodeUtils.GetAustraliaPost4StateBarcodeChecksum Method

BarcodeUtils GetAustraliaPost4StateBarcodeChecksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetAustraliaPost4StateBarcodeChecksum(
    string code
)
public static string GetAustraliaPost4StateBarcodeChecksum(
    string code
)
Public Shared Function GetAustraliaPost4StateBarcodeChecksum (
    code As String
) As String
Public Shared Function GetAustraliaPost4StateBarcodeChecksum (
    code As String
) As String
public:
static String^ GetAustraliaPost4StateBarcodeChecksum(
    String^ code
)
public:
static String^ GetAustraliaPost4StateBarcodeChecksum(
    String^ code
)
static member GetAustraliaPost4StateBarcodeChecksum :
        code : string -> string
static member GetAustraliaPost4StateBarcodeChecksum :
        code : string -> string

Parameters

code
Type: Online System String
An Australia Post 4 State code.

Return Value

Type: Online String
The checksum (Reed Solomon codewords) for an Australia Post 4 State code.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetAustraliaPostDomesticEParcelChecksum Method

BarcodeUtils GetAustraliaPostDomesticEParcelChecksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the checksum for an Australia Post Domestic eParcel code.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetAustraliaPostDomesticEParcelChecksum(
    string code
)
public static int GetAustraliaPostDomesticEParcelChecksum(
    string code
)
Public Shared Function GetAustraliaPostDomesticEParcelChecksum (
    code As String
) As Integer
Public Shared Function GetAustraliaPostDomesticEParcelChecksum (
    code As String
) As Integer
public:
static int GetAustraliaPostDomesticEParcelChecksum(
    String^ code
)
public:
static int GetAustraliaPostDomesticEParcelChecksum(
    String^ code
)
static member GetAustraliaPostDomesticEParcelChecksum :
        code : string -> int
static member GetAustraliaPostDomesticEParcelChecksum :
        code : string -> int

Parameters

code
Type: Online System String
An Australia Post Domestic eParcel code.

Return Value

Type: Online Int32
The checksum for an Australia Post Domestic eParcel code.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetCode39Checksum Method

BarcodeUtils GetCode39Checksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the checksum Modulus 43 used by Code 39 barcode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetCode39Checksum(
    string code
)
public static string GetCode39Checksum(
    string code
)
Public Shared Function GetCode39Checksum (
    code As String
) As String
Public Shared Function GetCode39Checksum (
    code As String
) As String
public:
static String^ GetCode39Checksum(
    String^ code
)
public:
static String^ GetCode39Checksum(
    String^ code
)
static member GetCode39Checksum :
        code : string -> string
static member GetCode39Checksum :
        code : string -> string

Parameters

code
Type: Online System String
The Code 39 value.

Return Value

Type: Online String
The checksum Modulus 43 used by Code 39 barcode.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetCode93Checksum Method

BarcodeUtils GetCode93Checksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the two-char checksum Modulus 47 used by Code 93 barcode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetCode93Checksum(
    string code
)
public static string GetCode93Checksum(
    string code
)
Public Shared Function GetCode93Checksum (
    code As String
) As String
Public Shared Function GetCode93Checksum (
    code As String
) As String
public:
static String^ GetCode93Checksum(
    String^ code
)
public:
static String^ GetCode93Checksum(
    String^ code
)
static member GetCode93Checksum :
        code : string -> string
static member GetCode93Checksum :
        code : string -> string

Parameters

code
Type: Online System String
The Code 93 value.

Return Value

Type: Online String
The two-char checksum Modulus 47 used by Code 93 barcode.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetDeutschePostModulus11Checksum Method

BarcodeUtils GetDeutschePostModulus11Checksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetDeutschePostModulus11Checksum(
    string code
)
public static int GetDeutschePostModulus11Checksum(
    string code
)
Public Shared Function GetDeutschePostModulus11Checksum (
    code As String
) As Integer
Public Shared Function GetDeutschePostModulus11Checksum (
    code As String
) As Integer
public:
static int GetDeutschePostModulus11Checksum(
    String^ code
)
public:
static int GetDeutschePostModulus11Checksum(
    String^ code
)
static member GetDeutschePostModulus11Checksum :
        code : string -> int
static member GetDeutschePostModulus11Checksum :
        code : string -> int

Parameters

code
Type: Online System String
A valid 8-digit Deutsche Post Ident code.

Return Value

Type: Online Int32
The checksum for a valid 8-digit Deutsche Post Ident code.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetDhlAwbChecksum Method

BarcodeUtils GetDhlAwbChecksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the checksum Modulus 7 used by DHL AWB barcode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetDhlAwbChecksum(
    string code
)
public static int GetDhlAwbChecksum(
    string code
)
Public Shared Function GetDhlAwbChecksum (
    code As String
) As Integer
Public Shared Function GetDhlAwbChecksum (
    code As String
) As Integer
public:
static int GetDhlAwbChecksum(
    String^ code
)
public:
static int GetDhlAwbChecksum(
    String^ code
)
static member GetDhlAwbChecksum :
        code : string -> int
static member GetDhlAwbChecksum :
        code : string -> int

Parameters

code
Type: Online System String
A DHL AWB 9-digit code.

Return Value

Type: Online Int32
The checksum Modulus 7 used by DHL AWB barcode.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetModulus10Checksum Method

BarcodeUtils GetModulus10Checksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the checksum Modulus 10 used by many barcode symbologies.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static int GetModulus10Checksum(
    string code
)
public static int GetModulus10Checksum(
    string code
)
Public Shared Function GetModulus10Checksum (
    code As String
) As Integer
Public Shared Function GetModulus10Checksum (
    code As String
) As Integer
public:
static int GetModulus10Checksum(
    String^ code
)
public:
static int GetModulus10Checksum(
    String^ code
)
static member GetModulus10Checksum :
        code : string -> int
static member GetModulus10Checksum :
        code : string -> int

Parameters

code
Type: Online System String
The code where the checksum will be computed on.

Return Value

Type: Online Int32
The checksum Modulus 10.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetPpnChecksum Method

BarcodeUtils GetPpnChecksum Method Neodynamic Barcode Professional SDK for .NET Class Reference
It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static string GetPpnChecksum(
    string code
)
public static string GetPpnChecksum(
    string code
)
Public Shared Function GetPpnChecksum (
    code As String
) As String
Public Shared Function GetPpnChecksum (
    code As String
) As String
public:
static String^ GetPpnChecksum(
    String^ code
)
public:
static String^ GetPpnChecksum(
    String^ code
)
static member GetPpnChecksum :
        code : string -> string
static member GetPpnChecksum :
        code : string -> string

Parameters

code
Type: Online System String
An IFA PZN8 code with or without 11 prefix.

Return Value

Type: Online String
The 2-digit checksum Modulus 97 used by IFA PPN barcode.
See Also
BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GS1DataStrictValidation Method

BarcodeUtils GS1DataStrictValidation Method Neodynamic Barcode Professional SDK for .NET Class Reference
It validates the specified GS1 Element Strings i.e. Application Identifier plus Data Field based on GS1 General Specifications rules. An BarcodeException will be thrown in case of any errors.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public static void GS1DataStrictValidation(
    string gs1Data
)
public static void GS1DataStrictValidation(
    string gs1Data
)
Public Shared Sub GS1DataStrictValidation (
    gs1Data As String
)
Public Shared Sub GS1DataStrictValidation (
    gs1Data As String
)
public:
static void GS1DataStrictValidation(
    String^ gs1Data
)
public:
static void GS1DataStrictValidation(
    String^ gs1Data
)
static member GS1DataStrictValidation :
        gs1Data : string -> unit
static member GS1DataStrictValidation :
        gs1Data : string -> unit

Parameters

gs1Data
Type: Online System String
The GS1 Element Strings to be validated.
See Also
BarcodeUtils Class
BarcodeUtils Members


BearerBarStyle Enumeration

BearerBarStyle Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the bearer bars' type that must be drawn with the barcode image. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum BearerBarStyle
public enum BearerBarStyle
Public Enumeration BearerBarStyle
Public Enumeration BearerBarStyle
public enum class BearerBarStyle
public enum class BearerBarStyle
type BearerBarStyle
type BearerBarStyle
Members
Member name | Value | Description
None | 0 | No bearer bars are drawn on the barcode
Frame | 1 | The bearer bars are drawn surrounding the symbol
HorizontalRules | 2 | The bearer bars are drawn at the top and bottom on the symbol
See Also


CodabarStartStopChar Enumeration

CodabarStartStopChar Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the start and stop character for Codabar symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum CodabarStartStopChar
public enum CodabarStartStopChar
Public Enumeration CodabarStartStopChar
Public Enumeration CodabarStartStopChar
public enum class CodabarStartStopChar
public enum class CodabarStartStopChar
type CodabarStartStopChar
type CodabarStartStopChar
Members
Member name | Value | Description
A | 0 |
B | 1 |
C | 2 |
D | 3 |
See Also


Code128 Enumeration

Code128 Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the characters set to use in the Code 128 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Code128
public enum Code128
Public Enumeration Code128
Public Enumeration Code128
public enum class Code128
public enum class Code128
type Code128
type Code128
Members
Member name | Value | Description
Auto | 0 | Barcode Professional will automatically switch between code sets to encode the ASCII values.
A | 1 | Barcode Professional will use the Char Set A which only supports ASCII values from 0 to 95
B | 2 | Barcode Professional will use the Char Set B which only supports ASCII values from 32 to 127
C | 3 | Barcode Professional will use the Char Set C which only supports pairs of digits
See Also


Code16k Enumeration

Code16k Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the mode to use for Code16k symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Code16k
public enum Code16k
Public Enumeration Code16k
Public Enumeration Code16k
public enum class Code16k
public enum class Code16k
type Code16k
type Code16k
Members
Member name | Value | Description
Mode0 | 0 | Barcode Professional will use the Code 128 Char Set A which only supports ASCII values from 0 to 95
Mode1 | 1 | Barcode Professional will use the Code 128 Char Set B which only supports ASCII values from 32 to 127
Mode2 | 2 | Barcode Professional will use the Code 128 Char Set C which only supports pairs of digits
See Also


DataMatrixEncoding Enumeration

DataMatrixEncoding Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the DataMatrix Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataMatrixEncoding
public enum DataMatrixEncoding
Public Enumeration DataMatrixEncoding
Public Enumeration DataMatrixEncoding
public enum class DataMatrixEncoding
public enum class DataMatrixEncoding
type DataMatrixEncoding
type DataMatrixEncoding
Members
Member name | Value | Description
Auto | 0 |
Ascii | 1 | Used to encode data that mainly contains ASCII characters (0-127)
C40 | 2 | Used to encode data that mainly contains numeric and upper case characters
Text | 3 | Used to encode data that mainly contains numeric and lower case characters
Base256 | 4 | Used to encode 8 bit values
See Also


DataMatrixFormat Enumeration

DataMatrixFormat Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the DataMatrix Format to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum DataMatrixFormat
public enum DataMatrixFormat
Public Enumeration DataMatrixFormat
Public Enumeration DataMatrixFormat
public enum class DataMatrixFormat
public enum class DataMatrixFormat
type DataMatrixFormat
type DataMatrixFormat
Members
Member name | Value | Description
Auto | 0 |
C10X10 | 1 |
C12X12 | 2 |
C14X14 | 3 |
C16X16 | 4 |
C18X18 | 5 |
C20X20 | 6 |
C22X22 | 7 |
C24X24 | 8 |
C26X26 | 9 |
C32X32 | 10 |
C36X36 | 11 |
C40X40 | 12 |
C44X44 | 13 |
C48X48 | 14 |
C52X52 | 15 |
C64X64 | 16 |
C72X72 | 17 |
C80X80 | 18 |
C88X88 | 19 |
C96X96 | 20 |
C104X104 | 21 |
C120X120 | 22 |
C132X132 | 23 |
C144X144 | 24 |
C8X18 | 25 |
C8X32 | 26 |
C12X26 | 27 |
C12X36 | 28 |
C16X36 | 29 |
C16X48 | 30 |
See Also


EpsCmykBarcodeColors Class

EpsCmykBarcodeColors Class Neodynamic Barcode Professional SDK for .NET Class Reference
Represents all CMYK barcode colors used in EPS (Encapsulated PostScript) generation.
Inheritance Hierarchy
Online System Object
Neodynamic.SDK.Barcode EpsCmykBarcodeColors

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class EpsCmykBarcodeColors
public class EpsCmykBarcodeColors
Public Class EpsCmykBarcodeColors
Public Class EpsCmykBarcodeColors
public ref class EpsCmykBarcodeColors
public ref class EpsCmykBarcodeColors
type EpsCmykBarcodeColors =  class end
type EpsCmykBarcodeColors =  class end
See Also
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors Members

EpsCmykBarcodeColors Members Neodynamic Barcode Professional SDK for .NET Class Reference

The EpsCmykBarcodeColors type exposes the following members.
Constructors
 | Name | Description
Public method | EpsCmykBarcodeColors | Initializes a new instance of the EpsCmykBarcodeColors class
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | BackColor | Gets or sets the CMYK background color.
Public property | BarColor | Gets or sets the CMYK color for barcode bars.
Public property | BorderColor | Gets or sets the CMYK color for border.
Public property | ForeColor | Gets or sets the CMYK foreground color for value to encode text.
Public property | TextForeColor | Gets or sets the CMYK foreground color for optional text.
Public property | TransparentBackground | Gets or sets whether to use transparent or solid background.
Back to Top
See Also
EpsCmykBarcodeColors Class


EpsCmykBarcodeColors Constructor

EpsCmykBarcodeColors Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the EpsCmykBarcodeColors class

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykBarcodeColors()
public EpsCmykBarcodeColors()
Public Sub New
Public Sub New
public:
EpsCmykBarcodeColors()
public:
EpsCmykBarcodeColors()
new : unit -> EpsCmykBarcodeColors
new : unit -> EpsCmykBarcodeColors
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors Methods

EpsCmykBarcodeColors Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The EpsCmykBarcodeColors type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
EpsCmykBarcodeColors Class


EpsCmykBarcodeColors Properties

EpsCmykBarcodeColors Properties Neodynamic Barcode Professional SDK for .NET Class Reference
The EpsCmykBarcodeColors type exposes the following members.
Properties
 | Name | Description
Public property | BackColor | Gets or sets the CMYK background color.
Public property | BarColor | Gets or sets the CMYK color for barcode bars.
Public property | BorderColor | Gets or sets the CMYK color for border.
Public property | ForeColor | Gets or sets the CMYK foreground color for value to encode text.
Public property | TextForeColor | Gets or sets the CMYK foreground color for optional text.
Public property | TransparentBackground | Gets or sets whether to use transparent or solid background.
Back to Top
See Also
EpsCmykBarcodeColors Class


EpsCmykBarcodeColors.BackColor Property

EpsCmykBarcodeColors BackColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the CMYK background color.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykColor BackColor { get; set; }
public EpsCmykColor BackColor { get; set; }
Public Property BackColor As EpsCmykColor
    Get
    Set
Public Property BackColor As EpsCmykColor
    Get
    Set
public:
property EpsCmykColor BackColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
public:
property EpsCmykColor BackColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
member BackColor : EpsCmykColor with get, set
member BackColor : EpsCmykColor with get, set

Property Value

Type: EpsCmykColor
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors.BarColor Property

EpsCmykBarcodeColors BarColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the CMYK color for barcode bars.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykColor BarColor { get; set; }
public EpsCmykColor BarColor { get; set; }
Public Property BarColor As EpsCmykColor
    Get
    Set
Public Property BarColor As EpsCmykColor
    Get
    Set
public:
property EpsCmykColor BarColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
public:
property EpsCmykColor BarColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
member BarColor : EpsCmykColor with get, set
member BarColor : EpsCmykColor with get, set

Property Value

Type: EpsCmykColor
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors.BorderColor Property

EpsCmykBarcodeColors BorderColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the CMYK color for border.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykColor BorderColor { get; set; }
public EpsCmykColor BorderColor { get; set; }
Public Property BorderColor As EpsCmykColor
    Get
    Set
Public Property BorderColor As EpsCmykColor
    Get
    Set
public:
property EpsCmykColor BorderColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
public:
property EpsCmykColor BorderColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
member BorderColor : EpsCmykColor with get, set
member BorderColor : EpsCmykColor with get, set

Property Value

Type: EpsCmykColor
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors.ForeColor Property

EpsCmykBarcodeColors ForeColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the CMYK foreground color for value to encode text.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykColor ForeColor { get; set; }
public EpsCmykColor ForeColor { get; set; }
Public Property ForeColor As EpsCmykColor
    Get
    Set
Public Property ForeColor As EpsCmykColor
    Get
    Set
public:
property EpsCmykColor ForeColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
public:
property EpsCmykColor ForeColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
member ForeColor : EpsCmykColor with get, set
member ForeColor : EpsCmykColor with get, set

Property Value

Type: EpsCmykColor
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors.TextForeColor Property

EpsCmykBarcodeColors TextForeColor Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the CMYK foreground color for optional text.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public EpsCmykColor TextForeColor { get; set; }
public EpsCmykColor TextForeColor { get; set; }
Public Property TextForeColor As EpsCmykColor
    Get
    Set
Public Property TextForeColor As EpsCmykColor
    Get
    Set
public:
property EpsCmykColor TextForeColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
public:
property EpsCmykColor TextForeColor {
    EpsCmykColor get ();
    void set (EpsCmykColor value);
}
member TextForeColor : EpsCmykColor with get, set
member TextForeColor : EpsCmykColor with get, set

Property Value

Type: EpsCmykColor
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykBarcodeColors.TransparentBackground Property

EpsCmykBarcodeColors TransparentBackground Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets whether to use transparent or solid background.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public bool TransparentBackground { get; set; }
public bool TransparentBackground { get; set; }
Public Property TransparentBackground As Boolean
    Get
    Set
Public Property TransparentBackground As Boolean
    Get
    Set
public:
property bool TransparentBackground {
    bool get ();
    void set (bool value);
}
public:
property bool TransparentBackground {
    bool get ();
    void set (bool value);
}
member TransparentBackground : bool with get, set
member TransparentBackground : bool with get, set

Property Value

Type: Online Boolean
See Also
EpsCmykBarcodeColors Class
EpsCmykBarcodeColors Members


EpsCmykColor Structure

EpsCmykColor Structure Neodynamic Barcode Professional SDK for .NET Class Reference
Represents a CMYK (Cyan, Magenta, Yellow, and Key/Black) color.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public struct EpsCmykColor
public struct EpsCmykColor
Public Structure EpsCmykColor
Public Structure EpsCmykColor
public value class EpsCmykColor
public value class EpsCmykColor
[<SealedAttribute>]
type EpsCmykColor =  struct end
[<SealedAttribute>]
type EpsCmykColor =  struct end
See Also
EpsCmykColor Members


EpsCmykColor Members

EpsCmykColor Members Neodynamic Barcode Professional SDK for .NET Class Reference

The EpsCmykColor type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
Properties
 | Name | Description
Public property | Black | Gets or sets the black component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Cyan | Gets or sets the cyan component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Magenta | Gets or sets the magenta component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Yellow | Gets or sets the yellow component value (ranging from 0 to 1) of this EpsCymkColor structure.
Back to Top
See Also
EpsCmykColor Structure


EpsCmykColor Methods

EpsCmykColor Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The EpsCmykColor type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Indicates whether this instance and a specified object are equal. (Inherited from Online ValueType.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Returns the hash code for this instance. (Inherited from Online ValueType.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns the fully qualified type name of this instance. (Inherited from Online ValueType.)
Back to Top
See Also
EpsCmykColor Structure


EpsCmykColor Properties

EpsCmykColor Properties Neodynamic Barcode Professional SDK for .NET Class Reference
The EpsCmykColor type exposes the following members.
Properties
 | Name | Description
Public property | Black | Gets or sets the black component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Cyan | Gets or sets the cyan component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Magenta | Gets or sets the magenta component value (ranging from 0 to 1) of this EpsCymkColor structure.
Public property | Yellow | Gets or sets the yellow component value (ranging from 0 to 1) of this EpsCymkColor structure.
Back to Top
See Also
EpsCmykColor Structure


EpsCmykColor.Black Property

EpsCmykColor Black Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the black component value (ranging from 0 to 1) of this EpsCymkColor structure.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Black { get; set; }
public double Black { get; set; }
Public Property Black As Double
    Get
    Set
Public Property Black As Double
    Get
    Set
public:
property double Black {
    double get ();
    void set (double value);
}
public:
property double Black {
    double get ();
    void set (double value);
}
member Black : float with get, set
member Black : float with get, set

Property Value

Type: Online Double
See Also
EpsCmykColor Structure
EpsCmykColor Members


EpsCmykColor.Cyan Property

EpsCmykColor Cyan Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the cyan component value (ranging from 0 to 1) of this EpsCymkColor structure.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Cyan { get; set; }
public double Cyan { get; set; }
Public Property Cyan As Double
    Get
    Set
Public Property Cyan As Double
    Get
    Set
public:
property double Cyan {
    double get ();
    void set (double value);
}
public:
property double Cyan {
    double get ();
    void set (double value);
}
member Cyan : float with get, set
member Cyan : float with get, set

Property Value

Type: Online Double
See Also
EpsCmykColor Structure
EpsCmykColor Members


EpsCmykColor.Magenta Property

EpsCmykColor Magenta Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the magenta component value (ranging from 0 to 1) of this EpsCymkColor structure.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Magenta { get; set; }
public double Magenta { get; set; }
Public Property Magenta As Double
    Get
    Set
Public Property Magenta As Double
    Get
    Set
public:
property double Magenta {
    double get ();
    void set (double value);
}
public:
property double Magenta {
    double get ();
    void set (double value);
}
member Magenta : float with get, set
member Magenta : float with get, set

Property Value

Type: Online Double
See Also
EpsCmykColor Structure
EpsCmykColor Members


EpsCmykColor.Yellow Property

EpsCmykColor Yellow Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the yellow component value (ranging from 0 to 1) of this EpsCymkColor structure.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Yellow { get; set; }
public double Yellow { get; set; }
Public Property Yellow As Double
    Get
    Set
Public Property Yellow As Double
    Get
    Set
public:
property double Yellow {
    double get ();
    void set (double value);
}
public:
property double Yellow {
    double get ();
    void set (double value);
}
member Yellow : float with get, set
member Yellow : float with get, set

Property Value

Type: Online Double
See Also
EpsCmykColor Structure
EpsCmykColor Members


FIM Enumeration

FIM Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the facing identification mark (FIM) pattern to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum FIM
public enum FIM
Public Enumeration FIM
Public Enumeration FIM
public enum class FIM
public enum class FIM
type FIM
type FIM
Members
Member name | Value | Description
A | 0 | Used for Courtesy Reply Mail (CRM) and Meter Reply Mail (MRM) with a preprinted barcode.
B | 1 | Used for Business Reply Mail (BRM) without a preprinted BRM ZIP+4 barcode.
C | 2 | Used for Business Reply Mail (BRM) with a preprinted BRM ZIP+4 barcode.
D | 3 | Used only with information based indicia (IBI) postage.
See Also


HanXinCodeEncoding Enumeration

HanXinCodeEncoding Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Han Xin Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum HanXinCodeEncoding
public enum HanXinCodeEncoding
Public Enumeration HanXinCodeEncoding
Public Enumeration HanXinCodeEncoding
public enum class HanXinCodeEncoding
public enum class HanXinCodeEncoding
type HanXinCodeEncoding
type HanXinCodeEncoding
Members
Member name | Value | Description
Auto | 0 |
Numeric | 1 | Used to encode data that contains numeric characters
Text | 2 | Used to encode data from common symbols in ISO-8859-1
BinaryByte | 3 | Used to encode 8 bit values
ChineseReg1 | 4 | Used to encode Common Chinese Characters in Region 1 i.e. characters whose first byte value is in the range of B0(HEX) to D7(HEX) and second byte value is in the range of A1(HEX) to FE(HEX), and characters whose first byte value is in the range of A1(HEX) to A3(HEX), and second byte value is in the range of A1(HEX) to FE(HEX), and characters whose byte values are in the range of A8A1(HEX) to A8C0(HEX).
ChineseReg2 | 5 | Used to encode Common Chinese Characters in Region 2 i.e. characters whose first byte value is in the range of D8(HEX) to F7(HEX), and second byte value is in the range of A1(HEX) to FE(HEX).
GB18030Bytes2 | 6 | Used to encode the GB18030 2-byte region i.e. data from all characters (including the Common Chinese Characters in Regions 1 and 2) in GB18030 double-byte region.
GB18030Bytes4 | 7 | Used to encode the GB18030 4-byte region i.e. characters whose first byte value is in the range of 81(HEX) to FE(HEX), and second byte value is in the range of 30(HEX) to 39(HEX), and third byte value is in the range of 81(HEX) to FE(HEX), and fourth byte value is in the range of 30(HEX) to 39(HEX).
See Also


HanXinCodeErrorCorrectionLevel Enumeration

HanXinCodeErrorCorrectionLevel Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Error Correction Level to apply for Han Xin Code symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum HanXinCodeErrorCorrectionLevel
public enum HanXinCodeErrorCorrectionLevel
Public Enumeration HanXinCodeErrorCorrectionLevel
Public Enumeration HanXinCodeErrorCorrectionLevel
public enum class HanXinCodeErrorCorrectionLevel
public enum class HanXinCodeErrorCorrectionLevel
type HanXinCodeErrorCorrectionLevel
type HanXinCodeErrorCorrectionLevel
Members
Member name | Value | Description
L1 | 0 | Approx. 8% of codewords can be restored. L1 is appropriate for high symbol quality and/or the need for the smallest possible symbol.
L2 | 1 | Approx. 15% of codewords can be restored. L2 is described as Standard level and offers a good compromise between small size and increased reliability.
L3 | 2 | Approx. 23% of codewords can be restored. L3 is a High reliability level and suitable for more critical or poor print quality applications.
L4 | 3 | Approx. 30% of codewords can be restored. L4 offers the maximum achievable reliability.
See Also


HanXinCodeVersion Enumeration

HanXinCodeVersion Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Han Xin Code Version to use on that symbology. Version 1 (23 x 23 modules) to Version 84 (189 x 189 modules) increasing in steps of two modules per side.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum HanXinCodeVersion
public enum HanXinCodeVersion
Public Enumeration HanXinCodeVersion
Public Enumeration HanXinCodeVersion
public enum class HanXinCodeVersion
public enum class HanXinCodeVersion
type HanXinCodeVersion
type HanXinCodeVersion
Members
Member name | Value | Description
Auto | 0 |
V01 | 1 |
V02 | 2 |
V03 | 3 |
V04 | 4 |
V05 | 5 |
V06 | 6 |
V07 | 7 |
V08 | 8 |
V09 | 9 |
V10 | 10 |
V11 | 11 |
V12 | 12 |
V13 | 13 |
V14 | 14 |
V15 | 15 |
V16 | 16 |
V17 | 17 |
V18 | 18 |
V19 | 19 |
V20 | 20 |
V21 | 21 |
V22 | 22 |
V23 | 23 |
V24 | 24 |
V25 | 25 |
V26 | 26 |
V27 | 27 |
V28 | 28 |
V29 | 29 |
V30 | 30 |
V31 | 31 |
V32 | 32 |
V33 | 33 |
V34 | 34 |
V35 | 35 |
V36 | 36 |
V37 | 37 |
V38 | 38 |
V39 | 39 |
V40 | 40 |
V41 | 41 |
V42 | 42 |
V43 | 43 |
V44 | 44 |
V45 | 45 |
V46 | 46 |
V47 | 47 |
V48 | 48 |
V49 | 49 |
V50 | 50 |
V51 | 51 |
V52 | 52 |
V53 | 53 |
V54 | 54 |
V55 | 55 |
V56 | 56 |
V57 | 57 |
V58 | 58 |
V59 | 59 |
V60 | 60 |
V61 | 61 |
V62 | 62 |
V63 | 63 |
V64 | 64 |
V65 | 65 |
V66 | 66 |
V67 | 67 |
V68 | 68 |
V69 | 69 |
V70 | 70 |
V71 | 71 |
V72 | 72 |
V73 | 73 |
V74 | 74 |
V75 | 75 |
V76 | 76 |
V77 | 77 |
V78 | 78 |
V79 | 79 |
V80 | 80 |
V81 | 81 |
V82 | 82 |
V83 | 83 |
V84 | 84 |
See Also


Isbt128DataStructure Enumeration

Isbt128DataStructure Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the ISBT 128 Data Structures.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Isbt128DataStructure
public enum Isbt128DataStructure
Public Enumeration Isbt128DataStructure
Public Enumeration Isbt128DataStructure
public enum class Isbt128DataStructure
public enum class Isbt128DataStructure
type Isbt128DataStructure
type Isbt128DataStructure
Members
Member name | Value | Description
DS001 | 0 | Donation Identification Number
DS002 | 1 | Blood Groups (ABO and RhD)
DS003 | 2 | Product Code
DS004 | 3 | Expiration Date
DS005 | 4 | Expiration Date and Time
DS006 | 5 | Collection Date
DS007 | 6 | Collection Date and Time
DS008 | 7 | Production Date
DS009 | 8 | Production Date and Time
DS010 | 9 | Special Testing: General
DS011 | 10 | Special Testing: Red Blood Cell Antigens (withdrawn)
DS012 | 11 | Special Testing: Red Blood Cell Antigens - General
DS013 | 12 | Special Testing: Red Blood Cell Antigens - Finnish
DS014 | 13 | Special Testing: Platelet HLA and Platelet-Specific Antigens
DS015 | 14 | Special Testing: HLA-A and -B Alleles
DS016 | 15 | Special Testing: HLA-DRB1 Alleles
DS017 | 16 | Container Manufacturer and Catalog Number
DS018 | 17 | Container Lot Number
DS019 | 18 | Donor Identification Number
DS020 | 19 | Staff Member Identification Number
DS021 | 20 | Manufacturer and Catalog Number: Items Other Than Containers
DS022 | 21 | Lot Number: Items Other Than Containers
DS023 | 22 | Compound Message
DS024 | 23 | Patient Date of Birth
DS025 | 24 | Patient Hospital Identification Number
DS026 | 25 | Expiration Month and Year
DS027 | 26 | Infectious Markers
DS028 | 27 | Product Consignment
DS029 | 28 | Dimensions
DS030 | 29 | Red Cell Antigens with Test History
DS031 | 30 | Flexible Date and Time
DS032 | 31 | Product Divisions
DS033 | 32 | Processing Facility Information Code
DS034 | 33 | Processor Product Identification Code
See Also


ItfHmark Enumeration

ItfHmark Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the seven type of H marks for ITF symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum ItfHmark
public enum ItfHmark
Public Enumeration ItfHmark
Public Enumeration ItfHmark
public enum class ItfHmark
public enum class ItfHmark
type ItfHmark
type ItfHmark
Members
Member name | Value | Description
None | 0 |
Mark1 | 1 |
Mark2 | 2 |
Mark3 | 3 |
Mark4 | 4 |
Mark5 | 5 |
Mark6 | 6 |
Mark7 | 7 |
See Also


LogoPosition Enumeration

LogoPosition Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specified the position of a logo image on the barcode symbol.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum LogoPosition
public enum LogoPosition
Public Enumeration LogoPosition
Public Enumeration LogoPosition
public enum class LogoPosition
public enum class LogoPosition
type LogoPosition
type LogoPosition
Members
Member name | Value | Description
Top | 0 |
Bottom | 1 |
See Also


Margin Class

Margin Class Neodynamic Barcode Professional SDK for .NET Class Reference
Represents margin information.
Inheritance Hierarchy
Online System Object
Neodynamic.SDK.Barcode Margin

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public class Margin
public class Margin
Public Class Margin
Public Class Margin
public ref class Margin
public ref class Margin
type Margin =  class end
type Margin =  class end
See Also
Margin Members


Margin Members

Margin Members Neodynamic Barcode Professional SDK for .NET Class Reference

The Margin type exposes the following members.
Constructors
 | Name | Description
Public method | Margin | Initializes a new instance of the Margin class.
Public method | Margin(Double) | Initializes a new instance of the Margin class using the supplied margin size for all edges.
Public method | Margin(Double, Double, Double, Double) | Initializes a new instance of the Margin class using a separate margin size for each edge.
Back to Top
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
Properties
 | Name | Description
Public property | Bottom | Gets or sets the margin size for the bottom edge.
Public property | Left | Gets or sets the margin size for the left edge.
Public property | Right | Gets or sets the margin for the right edge.
Public property | Top | Gets or sets the margin size for the top edge.
Back to Top
See Also
Margin Class


Margin Constructor

Margin Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Overload List
 | Name | Description
Public method | Margin | Initializes a new instance of the Margin class.
Public method | Margin(Double) | Initializes a new instance of the Margin class using the supplied margin size for all edges.
Public method | Margin(Double, Double, Double, Double) | Initializes a new instance of the Margin class using a separate margin size for each edge.
Back to Top
See Also
Margin Class
Margin Members


Margin Constructor

Margin Constructor Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the Margin class.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Margin()
public Margin()
Public Sub New
Public Sub New
public:
Margin()
public:
Margin()
new : unit -> Margin
new : unit -> Margin
See Also
Margin Class
Margin Members
Margin Overload


Margin Constructor (Double)

Margin Constructor (Double) Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the Margin class using the supplied margin size for all edges.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Margin(
    double all
)
public Margin(
    double all
)
Public Sub New (
    all As Double
)
Public Sub New (
    all As Double
)
public:
Margin(
    double all
)
public:
Margin(
    double all
)
new :
        all : float -> Margin
new :
        all : float -> Margin

Parameters

all
Type: Online System Double
The margin size for all edges.
See Also
Margin Class
Margin Members
Margin Overload


Margin Constructor (Double, Double, Double, Double)

Margin Constructor (Double, Double, Double, Double) Neodynamic Barcode Professional SDK for .NET Class Reference
Initializes a new instance of the Margin class using a separate margin size for each edge.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public Margin(
    double left,
    double top,
    double right,
    double bottom
)
public Margin(
    double left,
    double top,
    double right,
    double bottom
)
Public Sub New (
    left As Double,
    top As Double,
    right As Double,
    bottom As Double
)
Public Sub New (
    left As Double,
    top As Double,
    right As Double,
    bottom As Double
)
public:
Margin(
    double left,
    double top,
    double right,
    double bottom
)
public:
Margin(
    double left,
    double top,
    double right,
    double bottom
)
new :
        left : float *
        top : float *
        right : float *
        bottom : float -> Margin
new :
        left : float *
        top : float *
        right : float *
        bottom : float -> Margin

Parameters

left
Type: Online System Double
The margin size for the left edge.
top
Type: Online System Double
The margin size for the top edge.
right
Type: Online System Double
The margin size for the right edge.
bottom
Type: Online System Double
The margin size for the bottom edge.
See Also
Margin Class
Margin Members
Margin Overload


Margin Methods

Margin Methods Neodynamic Barcode Professional SDK for .NET Class Reference
The Margin type exposes the following members.
Methods
 | Name | Description
Public method | Online Equals | Determines whether the specified Online Object is equal to the current Online Object. (Inherited from Online Object.)
Protected method | Online Finalize | Allows an Online Object to attempt to free resources and perform other cleanup operations before the Online Object is reclaimed by garbage collection. (Inherited from Online Object.)
Public method | Online GetHashCode | Serves as a hash function for a particular type. (Inherited from Online Object.)
Public method | Online GetType | Gets the Online Type of the current instance. (Inherited from Online Object.)
Protected method | Online MemberwiseClone | Creates a shallow copy of the current Online Object. (Inherited from Online Object.)
Public method | Online ToString | Returns a Online String that represents the current Online Object. (Inherited from Online Object.)
Back to Top
See Also
Margin Class


Margin Properties

Margin Properties Neodynamic Barcode Professional SDK for .NET Class Reference
The Margin type exposes the following members.
Properties
 | Name | Description
Public property | Bottom | Gets or sets the margin size for the bottom edge.
Public property | Left | Gets or sets the margin size for the left edge.
Public property | Right | Gets or sets the margin for the right edge.
Public property | Top | Gets or sets the margin size for the top edge.
Back to Top
See Also
Margin Class


Margin.Bottom Property

Margin Bottom Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the margin size for the bottom edge.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Bottom { get; set; }
public double Bottom { get; set; }
Public Property Bottom As Double
    Get
    Set
Public Property Bottom As Double
    Get
    Set
public:
property double Bottom {
    double get ();
    void set (double value);
}
public:
property double Bottom {
    double get ();
    void set (double value);
}
member Bottom : float with get, set
member Bottom : float with get, set

Property Value

Type: Online Double
See Also
Margin Class
Margin Members


Margin.Left Property

Margin Left Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the margin size for the left edge.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Left { get; set; }
public double Left { get; set; }
Public Property Left As Double
    Get
    Set
Public Property Left As Double
    Get
    Set
public:
property double Left {
    double get ();
    void set (double value);
}
public:
property double Left {
    double get ();
    void set (double value);
}
member Left : float with get, set
member Left : float with get, set

Property Value

Type: Online Double
See Also
Margin Class
Margin Members


Margin.Right Property

Margin Right Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the margin for the right edge.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Right { get; set; }
public double Right { get; set; }
Public Property Right As Double
    Get
    Set
Public Property Right As Double
    Get
    Set
public:
property double Right {
    double get ();
    void set (double value);
}
public:
property double Right {
    double get ();
    void set (double value);
}
member Right : float with get, set
member Right : float with get, set

Property Value

Type: Online Double
See Also
Margin Class
Margin Members


Margin.Top Property

Margin Top Property Neodynamic Barcode Professional SDK for .NET Class Reference
Gets or sets the margin size for the top edge.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public double Top { get; set; }
public double Top { get; set; }
Public Property Top As Double
    Get
    Set
Public Property Top As Double
    Get
    Set
public:
property double Top {
    double get ();
    void set (double value);
}
public:
property double Top {
    double get ();
    void set (double value);
}
member Top : float with get, set
member Top : float with get, set

Property Value

Type: Online Double
See Also
Margin Class
Margin Members


MaxiCodeModes Enumeration

MaxiCodeModes Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the MaxiCode modes.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MaxiCodeModes
public enum MaxiCodeModes
Public Enumeration MaxiCodeModes
Public Enumeration MaxiCodeModes
public enum class MaxiCodeModes
public enum class MaxiCodeModes
type MaxiCodeModes
type MaxiCodeModes
Members
Member name | Value | Description
Mode2 | 2 | Indicates the symbol contains a Structured Carrier Message with a numeric postal code (U.S.).
Mode3 | 3 | Indicates the symbol contains a Structured Carrier Message with an alphanumeric postal code (non-U.S.).
Mode4 | 4 | Indicates the symbol contains general-purpose data, protected by the standard error correction.
Mode5 | 5 | Indicates the symbol contains general-purpose data, protected by enhanced error correction (EEC).
Mode6 | 6 | Reserved for symbols used to program internal parameters of MaxiCode readers.
See Also


MicroPdf417Version Enumeration

MicroPdf417Version Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MicroPdf417Version
public enum MicroPdf417Version
Public Enumeration MicroPdf417Version
Public Enumeration MicroPdf417Version
public enum class MicroPdf417Version
public enum class MicroPdf417Version
type MicroPdf417Version
type MicroPdf417Version
Members
Member name | Value | Description
Auto | 0 |
V1X11 | 1 |
V1X14 | 2 |
V1X17 | 3 |
V1X20 | 4 |
V1X24 | 5 |
V1X28 | 6 |
V2X8 | 7 |
V2X11 | 8 |
V2X14 | 9 |
V2X17 | 10 |
V2X20 | 11 |
V2X23 | 12 |
V2X26 | 13 |
V3X6 | 14 |
V3X8 | 15 |
V3X10 | 16 |
V3X12 | 17 |
V3X15 | 18 |
V3X20 | 19 |
V3X26 | 20 |
V3X32 | 21 |
V3X38 | 22 |
V3X44 | 23 |
V4X4 | 24 |
V4X6 | 25 |
V4X8 | 26 |
V4X10 | 27 |
V4X12 | 28 |
V4X15 | 29 |
V4X20 | 30 |
V4X26 | 31 |
V4X32 | 32 |
V4X38 | 33 |
V4X44 | 34 |
See Also


MicroQRCodeVersion Enumeration

MicroQRCodeVersion Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MicroQRCodeVersion
public enum MicroQRCodeVersion
Public Enumeration MicroQRCodeVersion
Public Enumeration MicroQRCodeVersion
public enum class MicroQRCodeVersion
public enum class MicroQRCodeVersion
type MicroQRCodeVersion
type MicroQRCodeVersion
Members
Member name | Value | Description
Auto | 0 |
M1 | 1 |
M2 | 2 |
M3 | 3 |
M4 | 4 |
See Also


MsiChecksum Enumeration

MsiChecksum Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the checksum method used for MSI barcodes

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum MsiChecksum
public enum MsiChecksum
Public Enumeration MsiChecksum
Public Enumeration MsiChecksum
public enum class MsiChecksum
public enum class MsiChecksum
type MsiChecksum
type MsiChecksum
Members
Member name | Value | Description
OneMod10 | 0 |
TwoMod10 | 1 |
Mod11AndMod10 | 2 |
See Also


Pdf417CompactionType Enumeration

Pdf417CompactionType Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Compaction Type to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Pdf417CompactionType
public enum Pdf417CompactionType
Public Enumeration Pdf417CompactionType
Public Enumeration Pdf417CompactionType
public enum class Pdf417CompactionType
public enum class Pdf417CompactionType
type Pdf417CompactionType
type Pdf417CompactionType
Members
Member name | Value | Description
Auto | 0 | It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
Binary | 1 | It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
Text | 2 | It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
Numeric | 3 | It allows encoding numeric data strings.
See Also


Pdf417ErrorCorrection Enumeration

Pdf417ErrorCorrection Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Error Correction Level to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Pdf417ErrorCorrection
public enum Pdf417ErrorCorrection
Public Enumeration Pdf417ErrorCorrection
Public Enumeration Pdf417ErrorCorrection
public enum class Pdf417ErrorCorrection
public enum class Pdf417ErrorCorrection
type Pdf417ErrorCorrection
type Pdf417ErrorCorrection
Members
Member name | Value | Description
Level0 | 0 |
Level1 | 1 |
Level2 | 2 |
Level3 | 3 |
Level4 | 4 |
Level5 | 5 |
Level6 | 6 |
Level7 | 7 |
Level8 | 8 |
See Also


QRCodeEncoding Enumeration

QRCodeEncoding Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the QR Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum QRCodeEncoding
public enum QRCodeEncoding
Public Enumeration QRCodeEncoding
Public Enumeration QRCodeEncoding
public enum class QRCodeEncoding
public enum class QRCodeEncoding
type QRCodeEncoding
type QRCodeEncoding
Members
Member name | Value | Description
Auto | 0 |
Numeric | 1 | Used to encode data that mainly contains numeric characters
AlphaNumeric | 2 | Used to encode data that mainly contains alphanumeric characters
Kanji | 3 | Used to encode data that mainly contains Kanji characters
Byte | 4 | Used to encode 8 bit values
See Also


QRCodeErrorCorrectionLevel Enumeration

QRCodeErrorCorrectionLevel Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Error Correction Level to apply for QR Code symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum QRCodeErrorCorrectionLevel
public enum QRCodeErrorCorrectionLevel
Public Enumeration QRCodeErrorCorrectionLevel
Public Enumeration QRCodeErrorCorrectionLevel
public enum class QRCodeErrorCorrectionLevel
public enum class QRCodeErrorCorrectionLevel
type QRCodeErrorCorrectionLevel
type QRCodeErrorCorrectionLevel
Members
Member name | Value | Description
L | 0 | Approx. 7% of codewords can be restored. Error correction level L is appropriate for high symbol quality and/or the need for the smallest possible symbol.
M | 1 | Approx. 15% of codewords can be restored. Level M is described as Standard level and offers a good compromise between small size and increased reliability.
Q | 2 | Approx. 25% of codewords can be restored. Level Q is a High reliability level and suitable for more critical or poor print quality applications.
H | 3 | Approx. 30% of codewords can be restored. Level H offers the maximum achievable reliability.
See Also


QRCodeVersion Enumeration

QRCodeVersion Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum QRCodeVersion
public enum QRCodeVersion
Public Enumeration QRCodeVersion
Public Enumeration QRCodeVersion
public enum class QRCodeVersion
public enum class QRCodeVersion
type QRCodeVersion
type QRCodeVersion
Members
Member name | Value | Description
Auto | 0 |
V01 | 1 |
V02 | 2 |
V03 | 3 |
V04 | 4 |
V05 | 5 |
V06 | 6 |
V07 | 7 |
V08 | 8 |
V09 | 9 |
V10 | 10 |
V11 | 11 |
V12 | 12 |
V13 | 13 |
V14 | 14 |
V15 | 15 |
V16 | 16 |
V17 | 17 |
V18 | 18 |
V19 | 19 |
V20 | 20 |
V21 | 21 |
V22 | 22 |
V23 | 23 |
V24 | 24 |
V25 | 25 |
V26 | 26 |
V27 | 27 |
V28 | 28 |
V29 | 29 |
V30 | 30 |
V31 | 31 |
V32 | 32 |
V33 | 33 |
V34 | 34 |
V35 | 35 |
V36 | 36 |
V37 | 37 |
V38 | 38 |
V39 | 39 |
V40 | 40 |
See Also


Rotate Enumeration

Rotate Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the rotation angle to apply on the barcode image. It is measured clockwise from the x-axis.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Rotate
public enum Rotate
Public Enumeration Rotate
Public Enumeration Rotate
public enum class Rotate
public enum class Rotate
type Rotate
type Rotate
Members
Member name | Value | Description
None | 0 |
Degree90 | 1 |
Degree180 | 2 |
Degree270 | 3 |
See Also


Supplement Enumeration

Supplement Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the supplement type to use with EAN and UPC symbologies.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Supplement
public enum Supplement
Public Enumeration Supplement
Public Enumeration Supplement
public enum class Supplement
public enum class Supplement
type Supplement
type Supplement
Members
Member name | Value | Description
None | 0 |
Digits2 | 1 |
Digits5 | 2 |
See Also


Symbology Enumeration

Symbology Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Barcode Symbology to be used.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum Symbology
public enum Symbology
Public Enumeration Symbology
Public Enumeration Symbology
public enum class Symbology
public enum class Symbology
type Symbology
type Symbology
Members
Member name | Value | Description
Codabar | 0 | Codabar a.k.a. ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar
Code11 | 1 | Code 11 a.k.a. Code11, USD-8, USD8
Code16k | 2 | Code 16K
Code39 | 3 | Code 39 a.k.a. ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII
Code93 | 4 | Code 93 a.k.a. ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII
Code128 | 5 | Code 128 a.k.a. ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C
DataMatrix | 6 | Data Matrix a.k.a. Data Matrix ECC200
Ean8 | 7 | EAN-8 a.k.a. European Article Number 8, EAN-8 Supplement 5/Five-digit Add-On, EAN-8 Supplement 2/Two-digit Add-On, EAN-8+5, EAN-8+2, EAN8, EAN8+5, EAN13+2, UPC-8, GTIN-8, GS1-8
Ean13 | 8 | EAN-13 a.k.a. European Article Number 13, EAN-13 Supplement 5/Five-digit Add-On, EAN-13 Supplement 2/Two-digit Add-On, EAN-13+5, EAN-13+2, EAN13, EAN13+5, EAN13+2, UPC-13, GTIN-13, GS1-13
Industrial2of5 | 9 | Industrial 2 of 5 a.k.a. 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5
Interleaved2of5 | 10 | Interleaved 2 of 5 a.k.a. ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved
Isbn | 11 | ISBN a.k.a. International Standard Book Number, Bookland EAN, ISBN-13, ISBN-10, ISBN+5, ISBN+2, ISBN Supplement 5/Five-digit Add-On, ISBN Supplement 2/Two-digit Add-On
Msi | 12 | MSI a.k.a. MSI/Plessey, Modified Plessey
Pdf417 | 13 | PDF417 a.k.a. Portable Data File 417, PDF 417, PDF417 Truncated
Planet | 14 | PLANET a.k.a. USPS PLANET Barcode, USPS Confirm Service Barcode
Postnet | 15 | POSTNET a.k.a. USPS POSTNET Barcode, USPS POSTal Numeric Encoding Technique Barcode, Delivery Point Barcode (DPBC), Postnet 3 of 5
UccEan128 | 16 | UCC/EAN-128 a.k.a. EAN-128, UCC-128, USS-128, GS1-128, UCC.EAN-128, GTIN-128
UpcA | 17 | UPC-A a.k.a. Universal Product Code version A, UPC-A Supplement 5/Five-digit Add-On, UPC-A Supplement 2/Two-digit Add-On, UPC-A+5, UPC-A+2, UPC Code, UPC Symbol, GTIN-12, GS1-12
UpcE | 18 | UPC-E a.k.a. Universal Product Code version E, UPC-E Supplement 5/Five-digit Add-On, UPC-E Supplement 2/Two-digit Add-On, UPC-E+5, UPC-E+2, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead 0, GS1-12
UspsOneCode4CB | 19 | USPS OneCode 4-State Customer Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
RoyalMail | 20 | British Royal Mail 4-State Customer Barcode a.k.a. RM4SCC, RoyalMail4SCC, British Royal Mail 4-State Customer Code and Royal Mail Barcode
AustraliaPost | 21 | Australia Post 4-state Barcode a.k.a. Australian 4-state postal barcode, Australia Post Customer Barcode
RoyalTpgPostKix | 22 | Royal TPG Post KIX 4-State Barcode a.k.a. Kix Barcode, Klantenindex (client index) Barcode, Dutch KIX 4-State Bar Code, Dutch KIX, TPG KIX, and TPGPOST KIX
Sscc18 | 23 | SSCC-18 a.k.a. UPC-128 Shipping Container Code, Code 128 UPC Shipping Container Code, Serial Shipping Container Code, UCC-128, EAN-18, NVE (Nummer der Versandeinheit)
Pzn | 24 | PZN a.k.a. Pharma-Zentral-Nummer, Pharmazentralnummer, Code PZN, CodePZN
DeutschePostLeitcode | 25 | Deutsche Post Leitcode Barcode a.k.a. German Postal 2 of 5 Leitcode, CodeLeitcode, Leitcode, Deutsche Post AG (DHL)
DeutschePostIdentcode | 26 | Deutsche Post Identcode Barcode a.k.a. German Postal 2 of 5 Identcode, Deutsche Post AG Identcode, Deutsche Frachtpost Identcode, Identcode, CodeIdentcode, Deutsche Post AG (DHL)
UspsTrayLabel | 27 | USPS Tray Label Barcode a.k.a. USPS 25 Tray label
UspsSackLabel | 28 | USPS Sack Label Barcode a.k.a. USPS 25 Sack label
EanVelocity | 29 | EAN-Velocity a.k.a. Velocity Barcode
SingaporePost | 30 | Singapore 4-State Postal Code Barcode a.k.a. Singapore 4-State Postal, SingPost 4-State, and SingPost Barcode
Jan8 | 31 | JAN-8 a.k.a. Japanese Article Number 8, JAN-8 Supplement 5/Five-digit Add-On, JAN-8 Supplement 2/Two-digit Add-On, JAN-8+5, JAN-8+2, JAN8, JAN8+5, JAN8+2
Jan13 | 32 | JAN-13 a.k.a. Japanese Article Number 13, JAN-13 Supplement 5/Five-digit Add-On, JAN-13 Supplement 2/Two-digit Add-On, JAN-13+5, JAN-13+2, JAN13, JAN13+5, JAN13+2
SwissPostParcel | 33 | Swiss PostParcel Barcode a.k.a. SwissPost Parcel Barcode, Switzerland Post Parcel Barcode
Opc | 34 | OPC a.k.a. Optical Product Code, VCA Barcode, VCA OPC, Vision Council of America OPC Barcode
Ean99 | 35 | EAN-99 a.k.a. European Article Number 99, EAN-99 Supplement 5/Five-digit Add-On, EAN-99 Supplement 2/Two-digit Add-On, EAN-99+5, EAN-99+2, EAN99, EAN99+5, EAN99+2, GTIN-99, GS1-99, Coupon Barcode
Itf14 | 36 | ITF-14 a.k.a. UPC Shipping Container Symbol ITF-14, ITF14, Case Code, UPC Case Code, EAN/UCC-14, EAN-14, UCC-14, DUN-14, GTIN-14
Scc14 | 37 | SCC-14 a.k.a. Shipping Container Code, EAN/UCC 14, DUN-14, EAN-14, UCC-14, UPC Case Code, UPC Shipping Container Code, Distribution Unit Number 14, SCC14, DUN14, EAN14, UCC14, EAN/UCC-14, Despatch Unit Number 14, GTIN-14
Issn | 38 | ISSN a.k.a. International Standard Serial Number, ISSN-13, ISSN-10, ISSN+5, ISSN+2, ISSN Supplement 5/Five-digit Add-On, ISSN Supplement 2/Two-digit Add-On
Ismn | 39 | ISMN a.k.a. International Standard Music Number, ISMN-13, ISMN-10, ISMN+5, ISMN+2, ISMN Supplement 5/Five-digit Add-On, ISMN Supplement 2/Two-digit Add-On, ISO 10957
NumlyNumber | 40 | Numly Number a.k.a. ESN, Electronic Serial Number, Electronic Standard Book Number, ESBN
QRCode | 41 | QR Code a.k.a. Quick Response Code, QRCode Model 2, JIS X 0510, ISO-IEC 18004
UspsFim | 42 | USPS FIM a.k.a. Facing Identification Marks, FIM A B C D
UspsHorizontalBars | 43 | USPS Horizontal Bars
Telepen | 44 | Telepen a.k.a. SB Telepen
Pharmacode | 45 | Pharmacode a.k.a. Pharmacode Laetus, Pharmaceutical Binary Code
Semacode | 46 | Semacode a.k.a. URL Barcode, Semacode Tag
Code32 | 47 | Code 32 a.k.a. Italian Pharmacode, IMH, Codice 32 Pharmacode, Codice Farmaceutico Italiano, Radix 32 Barcode
UspsPicUccEan128 | 48 | USPS PIC UCC/EAN-128 a.k.a. USPS Package Identification Code, USPS Confirmation Services Tracking Number Barcode
FedExGround96 | 49 | FedEx Ground 96 a.k.a. FedEx 96 Barcode, FedEx Ground 96 UCC/EAN-128, 96 Barcode
AztecCode | 50 | Aztec Code a.k.a. AIM Aztec Barcode, ANSI/AIM BC13 ITS/97/002
CompactPdf417 | 51 | Compact PDF417 a.k.a. Compact Portable Data File 417, Compact PDF 417, PDF417 Truncated
MacroPdf417 | 52 | Macro PDF417 a.k.a. Macro Portable Data File 417, Macro PDF 417, MacroPDF417
MicroPdf417 | 53 | Micro PDF417 a.k.a. Micro Portable Data File 417, Micro PDF 417, MicroPDF417
VicsBol | 54 | VICS BOL a.k.a. VICS Bill of Lading, Voluntary Interindustry Commerce Solutions Bill of Lading, BOL Barcode, 17-digit BOL, VICS standard Bill of Lading
VicsScacPro | 55 | VICS SCAC PRO a.k.a. VICS Bill of Lading SCAC PRO, Voluntary Interindustry Commerce Solutions Bill of Lading SCAC PRO, SCAC Barcode, PRO Barcode, VICS SCAC, VICS PRO, SCAC/Pro Barcode, Standard Carrier Alpha Code, Carrier SCAC Barcode
ItalianPost25 | 56 | Italian Post 25 a.k.a. Italian Post ITF 2/5, PosteItaliane Registered Mail Barcode, PosteItaliane ITF
Isbt128 | 57 | ISBT 128 a.k.a. ISBT Barcode, ISBT128, International Society of Blood Transfusion Barcode, ICCBBA 128, International Council for Commonality in Blood Banking Automation Barcode, Unique Donation Identification Barcode, American Association of Blood Banks AABB 128 Barcode, American Red Cross ARC Barcode
HibcLic39 | 58 | HIBC LIC 39 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 39, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcLic128 | 59 | HIBC LIC 128 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 128, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcPas39 | 60 | HIBC PAS 39 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 39, HIBC Health Care Services Provider Barcode
HibcPas128 | 61 | HIBC PAS 128 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 128, HIBC Health Care Services Provider Barcode
UspsIntelligentMail | 62 | USPS Intelligent Mail Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
EanUpcAddOn2 | 63 | EAN UPC Add On 2 a.k.a. EAN Supplement 2/Two-digit Add-On, EAN+2, UPC Supplement 2/Two-digit Add-On, UPC+2
EanUpcAddOn5 | 64 | EAN UPC Add On 5 a.k.a. EAN Supplement 5/Five-digit Add-On, EAN+5, UPC Supplement 5/Five-digit Add-On, UPC+5
UspsPicCode128 | 65 | USPS PIC Code 128 a.k.a. USPS Package Identification Code USS Code 128, USPS Confirmation Services Tracking Number Barcode USS Code 128
GS1DataBarOmnidirectional | 66 | GS1 DataBar Omnidirectional a.k.a. RSS14, Reduced Space Symbology 14
GS1DataBar14 | 67 | GS1 DataBar-14 a.k.a. GS1 DataBar Omnidirectional, RSS14, Reduced Space Symbology 14
Rss14 | 68 | RSS14 a.k.a. RSS 14, Reduced Space Symbology 14, GS1 DataBar Omnidirectional
GS1DataBarTruncated | 69 | GS1 DataBar Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated
GS1DataBar14Truncated | 70 | GS1 DataBar-14 Truncated a.k.a. GS1 DataBar Truncated, RSS 14 Truncated, Reduced Space Symbology 14 Truncated
Rss14Truncated | 71 | RSS14 Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated, GS1 DataBar Truncated
GS1DataBarStacked | 72 | GS1 DataBar Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar 14 Stacked
GS1DataBar14Stacked | 73 | GS1 DataBar-14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
Rss14Stacked | 74 | RSS14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
GS1DataBarStackedOmnidirectional | 75 | GS1 DataBar Stacked Omnidirectional a.k.a. GS1 DataBar-14 Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
GS1DataBar14StackedOmnidirectional | 76 | GS1 DataBar-14 Stacked Omnidirectional a.k.a. GS1 DataBar Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
Rss14StackedOmnidirectional | 77 | RSS14 Stacked Omnidirectional a.k.a. RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional, GS1 DataBar-14 Stacked Omnidirectional, GS1 DataBar Stacked Omnidirectional
GS1DataBarLimited | 78 | GS1 DataBar Limited a.k.a. GS1 DataBar-14 Limited, RSS Limited, Reduced Space Symbology Limited
RssLimited | 80 | RSS Limited a.k.a. Reduced Space Symbology Limited, GS1 DataBar-14 Limited, GS1 DataBar Limited
GS1DataBarExpanded | 81 | GS1 DataBar Expanded a.k.a. RSS Expanded, Reduced Space Symbology Expanded
RssExpanded | 82 | RSS Expanded a.k.a. GS1 DataBar Expanded, Reduced Space Symbology Expanded
GS1DataBarExpandedStacked | 83 | GS1 DataBar Expanded Stacked a.k.a. RSS Expanded Stacked, Reduced Space Symbology Expanded Stacked
RssExpandedStacked | 84 | RSS Expanded Stacked a.k.a. GS1 DataBar Expanded Stacked, Reduced Space Symbology Expanded Stacked
GS1128 | 85 | GS1-128 a.k.a. UCC/EAN-128, EAN-128, UCC-128, USS-128, UCC.EAN-128, GTIN-128
MaxiCode | 86 | MaxiCode a.k.a. UPS MaxiCode, Maxi Code, United Parcel Service MaxiCode
MicroQRCode | 87 | Micro QR Code a.k.a. Micro Quick Response Code, Micro QRCode Model 2
Matrix2of5 | 88 | Matrix 2 of 5 a.k.a. 2 of 5 Matrix, 2/5 Matrix
DanishPostal39 | 89 | Danish Postal 39 a.k.a. Danish PTT 39, Post Danmark A/S Barcode, Post Danmark Parcel Barcode
FrenchPostal39AR | 90 | French Postal 39 A/R a.k.a. French Postal A/R 39, La Poste A/R 39
IATA2of5 | 91 | IATA 2 of 5 a.k.a. International Air Transport Assosiation 2 of 5
AustraliaPostDomesticEParcelBarcode | 92 | Australia Post Domestic eParcel Barcode ak.a. Australia Post Domestic eParcel Article Barcode
UspsIntelligentMailContainerBarcode | 93 | USPS Intelligent Mail Container Barcode a.k.a. USPS IM Container Barcode, IM Container Barcode
KodakPatchCode | 94 | Kodak Patch Code
GS1DataMatrix | 95 | GS1 DataMatrix a.k.a. GS1 Data Matrix ECC200
Ean13CCA | 96 | EAN-13 CC-A a.k.a. European Article Number 13 with CC-A
Ean13CCB | 97 | EAN-13 CC-B a.k.a. European Article Number 13 with CC-B
Ean8CCA | 98 | EAN-8 CC-A a.k.a. European Article Number 8 with CC-A
Ean8CCB | 99 | EAN-8 CC-B a.k.a. European Article Number 8 with CC-B
UpcACCA | 100 | UPC-A CC-A a.k.a. Universal Product Code version A with CC-A
UpcACCB | 101 | UPC-A CC-B a.k.a. Universal Product Code version A with CC-B
UpcECCA | 102 | UPC-E CC-A a.k.a. Universal Product Code version E with CC-A
UpcECCB | 103 | UPC-E CC-B a.k.a. Universal Product Code version E with CC-B
UccEan128CCA | 104 | UCC/EAN-128 CC-A a.k.a. GS1-128 with CC-A
UccEan128CCB | 105 | UCC/EAN-128 CC-B a.k.a. GS1-128 with CC-B
UccEan128CCC | 106 | UCC/EAN-128 CC-C a.k.a. GS1-128 with CC-C
GS1128CCA | 107 | GS1-128 CC-A a.k.a. UCC/EAN-128 with CC-A
GS1128CCB | 108 | GS1-128 CC-B a.k.a. UCC/EAN-128 with CC-B
GS1128CCC | 109 | GS1-128 CC-C a.k.a. UCC/EAN-128 with CC-C
GS1DataBarOmnidirectionalCCA | 110 | GS1 DataBar Omnidirectional with CC-A a.k.a. RSS14 CC-A
GS1DataBar14CCA | 111 | GS1 DataBar-14 with CC-A a.k.a. RSS14 with CC-A
Rss14CCA | 112 | RSS14 CC-A
GS1DataBarOmnidirectionalCCB | 113 | GS1 DataBar Omnidirectional with CC-B a.k.a. RSS14 CC-B
GS1DataBar14CCB | 114 | GS1 DataBar-14 with CC-B a.k.a. RSS14 with CC-B
Rss14CCB | 115 | RSS14 CC-B
GS1DataBarTruncatedCCA | 116 | GS1 DataBar Truncated CC-A a.k.a. RSS 14 Truncated CC-A
GS1DataBar14TruncatedCCA | 117 | GS1 DataBar-14 Truncated CC-A a.k.a. RSS 14 Truncated CC-A
Rss14TruncatedCCA | 118 | RSS14 Truncated CC-A
GS1DataBarTruncatedCCB | 119 | GS1 DataBar Truncated CC-B a.k.a. RSS 14 Truncated CC-B
GS1DataBar14TruncatedCCB | 120 | GS1 DataBar-14 Truncated CC-B a.k.a. RSS 14 Truncated CC-B
Rss14TruncatedCCB | 121 | RSS14 Truncated CC-B
GS1DataBarLimitedCCA | 122 | GS1 DataBar Limited CC-A a.k.a. RSS Limited CC-A
RssLimitedCCA | 123 | RSS Limited CC-A
GS1DataBarLimitedCCB | 124 | GS1 DataBar Limited CC-B a.k.a. RSS Limited CC-B
RssLimitedCCB | 125 | RSS Limited CC-B
GS1DataBarStackedCCA | 126 | GS1 DataBar Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBar14StackedCCA | 127 | GS1 DataBar-14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
Rss14StackedCCA | 128 | RSS14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBarStackedCCB | 129 | GS1 DataBar Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBar14StackedCCB | 130 | GS1 DataBar-14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
Rss14StackedCCB | 131 | RSS14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBarStackedOmnidirectionalCCA | 132 | GS1 DataBar Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
GS1DataBar14StackedOmnidirectionalCCA | 133 | GS1 DataBar-14 Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
Rss14StackedOmnidirectionalCCA | 134 | RSS14 Stacked Omnidirectional CC-A
GS1DataBarStackedOmnidirectionalCCB | 135 | GS1 DataBar Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
GS1DataBar14StackedOmnidirectionalCCB | 136 | GS1 DataBar-14 Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
Rss14StackedOmnidirectionalCCB | 137 | RSS14 Stacked Omnidirectional CC-B
GS1DataBarExpandedCCA | 138 | GS1 DataBar Expanded CC-A a.k.a. RSS Expanded CC-A
RssExpandedCCA | 139 | RSS Expanded CC-A
GS1DataBarExpandedCCB | 140 | GS1 DataBar Expanded CC-B a.k.a. RSS Expanded CC-B
RssExpandedCCB | 141 | RSS Expanded CC-B
GS1DataBarExpandedStackedCCA | 142 | GS1 DataBar Expanded Stacked CC-A a.k.a. RSS Expanded Stacked CC-A
RssExpandedStackedCCA | 143 | RSS Expanded Stacked CC-A
GS1DataBarExpandedStackedCCB | 144 | GS1 DataBar Expanded Stacked CC-B a.k.a. RSS Expanded Stacked CC-B
RssExpandedStackedCCB | 145 | RSS Expanded Stacked CC-B
MICRE13B | 146 | MICR E13-B a.k.a. E-13-B, MICR E13B
Ean14 | 147 | EAN-14 a.k.a. GTIN-14, UCC-14
Dun14Itf | 148 | DUN-14 ITF Version
Dun14Ean | 149 | DUN-14 GS1/EAN/UCC Version
GS1QRCode | 150 | GS1 QR Code
Ppn | 151 | PPN a.k.a. IFA PPN, IFA Pharmacy Product Number, IFA securPharm
IFAsecurPharm | 152 | IFA securPharm a.k.a. PPN
DhlAwb | 153 | DHL AWB
HibcLicDataMatrix | 154 | HIBC LIC Data Matrix
HibcLicQRCode | 155 | HIBC LIC QR Code
HibcLicAztecCode | 156 | HIBC LIC Aztec Code
HibcPasDataMatrix | 157 | HIBC PAS Data Matrix
HibcPasQRCode | 158 | HIBC PAS QR COde
HibcPasAztecCode | 159 | HIBC PAS Aztec Code
Isbt128DataMatrix | 160 | ISBT 128 Data Matrix
DeutschePostResponsePlusPostMatrix | 161 | Deutsche Post PostMatrix
DeutschePostBzl | 162 | Deutsche Post BZL
UspsIntelligentMailPackageBarcode | 163 | USPS Intelligent Mail Package Barcode a.k.a. USPS IMpb
HanXinCode | 164 | Han Xin Code a.k.a. 2D Chinese Barcode
JapanPost | 165 | Japan Post 4 State Customer Barcode a.k.a. Japanese Postal Barcode, Kasutama Barcode
KoreaPost | 166 | Korea Post Barcode a.k.a. Korean Postal Authority Barcode
DataLogic2of5 | 167 | Data Logic 2 of 5 Barcode a.k.a. China Post Barcode
See Also


TelepenEncoding Enumeration

TelepenEncoding Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the Telepen Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TelepenEncoding
public enum TelepenEncoding
Public Enumeration TelepenEncoding
Public Enumeration TelepenEncoding
public enum class TelepenEncoding
public enum class TelepenEncoding
type TelepenEncoding
type TelepenEncoding
Members
Member name | Value | Description
Ascii | 0 | Used to encode the full range of ASCII characters
Numeric | 1 | Used to encode pairs of numeric characters in double-density mode.
See Also


TiffCompression Enumeration

TiffCompression Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the TIFF compression algorithm to be used when saving barcodes in such image format.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum TiffCompression
public enum TiffCompression
Public Enumeration TiffCompression
Public Enumeration TiffCompression
public enum class TiffCompression
public enum class TiffCompression
type TiffCompression
type TiffCompression
Members
Member name | Value | Description
None | 0 | Specifies no compression.
LZW | 1 | Specifies the Lempel-Ziv-Welch (LZW) compression algorithm.
CCITT3 | 2 | Specifies the International Telegraph and Telephone Consultative Committee Group 3 (CCITT3) compression algorithm.
CCITT4 | 3 | Specifies the International Telegraph and Telephone Consultative Committee Group 4 (CCITT4) compression algorithm.
RLE | 4 | Specifies the Run-Length Encoding (RLE) compression algorithm.
See Also


UpcE Enumeration

UpcE Enumeration Neodynamic Barcode Professional SDK for .NET Class Reference
Specifies the number system to use for UPC-E symbology.

Namespace: Neodynamic.SDK.Barcode
Assembly: Neodynamic.SDK.Barcode (in Neodynamic.SDK.Barcode.dll) Version: 5.0.2000.0 (5.0.2016.0)
Syntax
C#
VB
C++
F#
View Colorized Copy to Clipboard Print
public enum UpcE
public enum UpcE
Public Enumeration UpcE
Public Enumeration UpcE
public enum class UpcE
public enum class UpcE
type UpcE
type UpcE
Members
Member name | Value | Description
System0 | 0 |
System1 | 1 |
See Also


Deployment

Neodynamic Barcode Professional SDK for .NET
Neodynamic Barcode Professional SDK for .NET Deployment
Deploying an application that uses Neodynamic Barcode Professional SDK for .NET is not different than any other application that uses custom .NET DLL Assemblies. All functionality of Barcode Professional is contained in a unique assembly (Neodynamic.SDK.Barcode.dll). For example, when deploying your ASP.NET Web application using Barcode Professional SDK, you must ensure that Neodynamic.SDK.Barcode.dll assembly is located in the BIN folder of your application. For Windows Forms/Console applications, you must ensure that Neodynamic.SDK.Barcode.dll assembly is located in the same folder of your application.

Where is the Neodynamic.SDK.Barcode.dll assembly for deployment?
Neodynamic provides Barcode Professional assemblies ready for deploying and targeting different platform versions of .NET Framework such as 32bit and 64bit.

The Neodynamic.SDK.Barcode.dll assembly for deploying is located in the Barcode Professional installation folder under Redistributable folder. You should deploy Neodynamic.SDK.Barcode.dll assembly based on the .NET Framework version which your .NET Application is running on.

Send comments on this topic. Visit Neodynamic's website.

Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.


Technical Support

Neodynamic Barcode Professional SDK for .NET
Neodynamic Technical Support
When you purchase a licensed version of Neodynamic Barcode Professional SDK for .NET you get access to FREE Priority-One technical support.
Technical Support can be reached at http://www.neodynamic.com/support.

Before contacting technical support we recommend:
  • Read the product documentation.
  • Take a look at some of our online articles at http://www.neodynamic.com/products/barcode/sdk-vb-net-csharp/articles/.

Visit Neodynamic's website.
Neodynamic Barcode Professional SDK for .NET Documentation
Copyright © 2003 - 2016 Neodynamic - All rights reserved.