About Neodynamic Barcode Reader SDK for .NET

Neodynamic Barcode Reader SDK for .NET
What is Neodynamic Barcode Reader SDK for .NET?
Neodynamic Barcode Reader SDK is an advanced library which allows you to add barcode recognition capabilities to your .NET applications. Barcode Reader SDK can recognize and decode most popular linear (1D) barcodes from digital images and bitmaps.

Barcode Reader SDK for does not require any special or complex configurations to use it in your .NET Applications; just add a reference to Barcode Reader DLL assembly, instantiate it in your preferred .NET language such as VB.NET and C#, set up the Reader properties and that's it.
Main Features
  • Recognizes and decodes most popular linear 1D barcode symbologies in an image.
  • Returns the string and binary values for each detected barcode.
  • Recognizes the type (symbology) of the detected barcode.
  • Can decode barcodes with 0, 90, 180, 270 degrees rotation.
  • Allows you to use checksum or check-digits for verifying barcodes.
  • Can be used in any .NET project like Windows Forms, ASP.NET, Windows Services, Console Apps, etc.
  • Works in security limited environments like ASP.NET Medium-Trust Level.
  • Supports the following image formats as sources: JPEG/JPG, PNG, TIFF, BMP, GIF, System.Drawing.Bitmap objects, and Memory image buffers (Byte Array and System.IO.Stream)

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


License Registration

Neodynamic Barcode Reader SDK for .NET
License Registration
When you buy a commercial version of Barcode Reader you are provided with license information to register your licensed copy of Neodynamic Barcode Reader SDK for .NET.

The registration process is very simple and can be accomplished in two ways:

  • Codeless License Setting
    Codeless License Setting involves adding the license info in the Application's Configuration file (*.config). The license info must be specified in the BarcodeReaderSDK10LicenseOwner and BarcodeReaderSDK10LicenseKey entries in the appSettings section of *.config file. Example:
    <configuration>
  <appSettings>
    <add key="BarcodeReaderSDK10LicenseOwner" value="LICENSE-OWNER"/>
    <add key="BarcodeReaderSDK10LicenseKey" value="LICENSE-KEY"/>
  </appSettings>
  ...
</configuration>
  • Using the license info in code
    Just specify the licenseOwner and licenseKey to the BarcodeReader class constructor with the license info you've received.
    IMPORTANT
    Please, keep in mind that the license info is case-sensitive!

    VB.NET
    ' WINDOWS FORMS SAMPLE

Imports Neodynamic.SDK.BarcodeReader

Public Class Form1

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

    Dim objBarcodeReader As New BarcodeReader("LICENSE-OWNER", "LICENSE-KEY")
    '...

    End Sub

End Class

    C#
    // WINDOWS FORMS SAMPLE

using Neodynamic.SDK.BarcodeReader;

public partial class Form1 : Form
{
    private void Form1_Load(object sender, EventArgs e)
    {
        BarcodeReader objBarcodeReader = new BarcodeReader("LICENSE-OWNER", "LICENSE-KEY");
    // ...
    }
}

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Trial Version

Neodynamic Barcode Reader SDK for .NET
Trial Version
The Trial version of Barcode Reader SDK will replace one character of the decoded barcode by an 'X' character. For example, if the real barcode value is "1234567890", then in Trial mode the Barcode Reader SDK may return "1234X67890" instead.

When you buy a licensed version of Barcode Reader you will receive license information to register your copy of Barcode Reader SDK for .NET. For more information about the registration process view License Registration topic.
How to try Barcode Reader SDK without limitations?
Neodynamic offers you a 30-day Evaluation License Key which will allow you to test the Barcode Reader SDK in fully-functional mode for 30 days! When the 30-day Evaluation License Key expires, the Barcode Reader SDK behavior backs to Trial mode. Request your 30-day Evaluation License Key emailing sales@neodynamic.com

Distribution restrictions

If you are using a Trial Version, you cannot distribute any of the files provided with it.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


System Requirements

Neodynamic Barcode Reader SDK for .NET
System Requirements
For developing applications with Neodynamic Barcode Reader SDK for .NET, you must have the following system and software specifications:

Microsoft .NET Framework

Microsoft .NET Framework 2.0 or greater with its latest service pack.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Installation and Configuration

Neodynamic Barcode Reader SDK for .NET
Installation and Configuration
Installing Neodynamic Barcode Reader SDK for .NET is very simple.
  • Download the latest version from Neodynamic's website.
  • Unzip the downloaded file onto your hard drive and launch the installation program double-clicking on it.
  • Follow the on-screen instructions.
Development Tools Configuration
Learn about how to configure Barcode Reader SDK for .NET with most popular .NET Development Tools.
  • How to configure Barcode Reader SDK for .NET in Microsoft Visual Studio and Express Editions...

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Visual Studio .NET Configuration

Neodynamic Barcode Reader SDK for .NET
Microsoft Visual Studio .NET and Express Editions Configuration
  • Launch Visual Studio or any Visual Studio Express Edition.
  • Create a new .NET project. For example, a Windows Forms Application or an ASP.NET Web Application project.
  • Add a reference to Neodynamic.SDK.BarcodeReader.dll assembly (Project > Add Reference... OR Website > Add Reference...).
  • Select .NET tab. You should find the Neodynamic.SDK.BarcodeReader.dll assembly listed.
    If you cannot find it...

    • Select Browse tab, and navigate to the folder you installed it to.
    • Browse to the Redistributable folder, and select the folder that matches the version of .NET Framework you are using.
    • Select Neodynamic.SDK.BarcodeReader.dll from that dialog.
    • Click on OK button.
    Double-click on Barcode Reader assembly to select it, then click on OK.
  • The Barcode Reader assembly should now appear referenced to your project. You can now use Barcode Reader classes in your code.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


First Steps with Barcode Reader SDK for .NET

Neodynamic Barcode Reader SDK for .NET
First Steps with Barcode Reader SDK for .NET
Barcode Reader SDK for .NET can be used in Visual Studio IDE for adding barcode recognition capabilities to your .NET Applications. You can use the Barcode Reader SDK to scan a digital image looking for the desired barcode symbology and decode it (meaning to get the data encoded by the barcode) inside your .NET application.
A simple sample code for barcode recognition
Suppose you need to decode the barcode symbols shown in the following image:

A sample image showing two barcode symbols.

This image contains an EAN-13 and a Code-128 barcodes. The following code will scan this image file looking for the barcodes and then shows the result in the Console window.

1. Open Visual Studio and create a new Console Application using your preferred .NET language.
2. Add a reference to System.Drawing.dll and Neodynamic.SDK.BarcodeReader.dll
3. Copy the following code in the Console's main method:

VB.NET
'Add the Barcode Reader namespace reference
Imports Neodynamic.SDK.BarcodeReader

'Create a BarcodeReader object
Dim myReader As New BarcodeReader()
'Add the barcode symbologies to be recognized
myReader.Symbology.Add(Symbology.Ean13)
myReader.Symbology.Add(Symbology.Code128)
'Set max num of barcode symbols to be detected
myReader.Hints.MaxNumOfBarcodes = 2
'Scan the source image and get result
Dim results As List(Of BarcodeScanResult) = myReader.Scan("c:\barcode_sample.jpg")
'Display scan result
For Each result As BarcodeScanResult In results
    Console.WriteLine("Barcode Type: " & result.Symbology.ToString())
    Console.WriteLine("Barcode Data: " + result.Text)
    Console.WriteLine("=============")
Next

C#
//Add the Barcode Reader namespace reference
using Neodynamic.SDK.BarcodeReader;

//Create a BarcodeReader object
BarcodeReader myReader = new BarcodeReader();
//Add the barcode symbologies to be recognized
myReader.Symbology.Add(Symbology.Ean13);
myReader.Symbology.Add(Symbology.Code128);
//Set max num of barcode symbols to be detected
myReader.Hints.MaxNumOfBarcodes = 2;
//Scan the source image and get result
List<BarcodeScanResult> results = myReader.Scan(@"c:\barcode_sample.jpg");
//Display scan result
foreach (BarcodeScanResult result in results)
{
    Console.WriteLine("Barcode Type: " + result.Symbology.ToString());
    Console.WriteLine("Barcode Data: " + result.Text);
    Console.WriteLine("=============");
}

Barcode Reader App Sample
We've developed a more complete Barcode Reader application which you can examine for more advanced settings. The sample app is provided with source code in C# and VB and you can find them in the installation folder of Barcode Reader SDK.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Adjusting the Scan settings

Neodynamic Barcode Reader SDK for .NET
Adjusting the Scan settings

In this section

  • Scanline Thickness and Distance
  • Scan Direction
  • Scan Timeout

Scanline Thickness and Distance
The Barcode Reader SDK uses the scanline approach for recognizing and decoding linear (1D) barcode symbols. A scanline is a set of pixels of the source image which are passed to the Reader for barcode recognition. Each scanline size is determined by the width of the source image (or the width of the Region of Interest) and the height by the specified value (in pixel unit) through the ScanlineThickness property of the BarcodeReaderHints object attached to the BarcodeReader object.

The Barcode Reader starts the scan process with one scanline and then continues to the next one until it finishes the recognition and decoding task. Each scanline can be separated by some gap which you can specify through the ScanlineDistance property of the BarcodeReaderHints object.

The following figure illustrates the Scanline Thickness and Distance concepts:

The scanline thickness and distance.

Tips for setting up the Scanline Thickness and Distance values:

  • If the barcode bars are very clear on the source image, then you can set up ScanlineThickness to 2 (or greater) and the ScanlineDistance to 5 (lesser or greater depending on your context).
  • If the barcode bars are poor or bad quality on the source image, then you can set up ScanlineThickness to 1 and the ScanlineDistance to 0. These settings provide the deepest scan level but with lower processing time.
Scan Direction
The Barcode Reader SDK allows you to set up the scan direction of the recognition process by using the ScanDirection property of the BarcodeReaderHints object attached to the BarcodeReader object.

You can set up the Scan Direction to one of the three possible options:

The following figure illustrates the Scanline Thickness and Distance concepts:

  • Downwards: This scan direction option instructs the Reader to start at the top of the source image (or Region of Interest) and then to continue downward for each next scanline step. You should opt for this option if you know the barcode symbols are usually located at the top zone of the source image.

    The scan direction 'Downwards'.

  • MiddleOutwards: This scan direction option instructs the Reader to start at the middle of the source image (or Region of Interest) and then to continue upward and downward for each next scanline step. You should opt for this option if you know the barcode symbols are usually located at the center zone of the source image.

    The scan direction 'MiddleOutwards'.

  • Upwards: This scan direction option instructs the Reader to start at the bottom of the source image (or Region of Interest) and then to continue upward for each next scanline step. You should opt for this option if you know the barcode symbols are usually located at the bottom zone of the source image.

    The scan direction 'Downwards'.

Scan Timeout
You can specify to the Barcode Reader the amount of time (in Milliseconds) after which the scan process will time out. This is done through the ScanTimeout property of the BarcodeReaderHints object attached to the BarcodeReader object. By default, the ScanTimeout property is set up to zero which indicates an infinite time-out period.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Setting up the Region of Interest

Neodynamic Barcode Reader SDK for .NET
Setting up the Region of Interest
When you specify a source image to the Barcode Reader, you can instruct the reader to scan it fully (by default) or just an inner region, zone or area. Of course, scanning the whole image will take more processing time than if you specify a smaller inner region. So, it’s very important you specify an inner region of the source image to the Barcode Reader when possible in order to speed up the recognition process. You do not need to know the exact region where the barcode is located in the source image because the Barcode Reader SDK provides you with different and flexible ways for doing that.

The region of interest is defined by the ScanRegion class and it can be specified to the Scan() method of the BarcodeReader object. The ScanRegion class is very flexible allowing you to specify a fixed rectangular region or a region based on percentage values.

  • Fixed Rectangular Regions
    To specify a rectangular region inside the source image, you have to create a System.Drawing.Rectangle object specifying the X and Y upper-left coordinates as well as the size of the region i.e. its Width and Height values (both the location and size must be specified in Pixel units). For example: Suppose your source image is 640x480 (px) and you know the barcode symbol is located approximately at 140px from the left and 120px from the top and the size is about 350px wide and 200px high.

    How to specify a fixed rectangular region of interest.

    To specify such region of interest you should write the following code:

    VB.NET
    Dim fixedRectRegion As New ScanRegion(New System.Drawing.Rectangle(140, 120, 350, 200))

    C#
    ScanRegion fixedRectRegion = new ScanRegion(new System.Drawing.Rectangle(140, 120, 350, 200));

  • Percentage-based Rectangular Regions
    To specify a percentage-based rectangular region inside the source image, you have to specify the StartX, EndX, StartY and EndY params (these values must be in the range of 0 to 100) of the ScanRegionPercentage class. The region is calculated by the Barcode Reader based on the dimensions of the source image and the specified percentage values. StartX and EndX represent the horizontal percentage-based zone of the source image while StartY and EndY are for the vertical orientation. The reference point for both, horizontal and vertical coordinates, is the upper-left corner of the source image. For example: Once again, suppose your source image is 640x480 (px) and you know the barcode symbol will be always covering the 50% and 33% of the image (horizontally and vertically centered respectively).

    How to specify a percentage-based rectangular region of interest.

    To specify such percentage-based region of interest you should write the following code:

    VB.NET
    Dim fixedRectRegion As New ScanRegion(New ScanRegionPercentage(25, 75, 33, 66))

    C#
    ScanRegion fixedRectRegion = new ScanRegion(new ScanRegionPercentage(25, 75, 33, 66));

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Setting up the Barcode Symbologies (types)

Neodynamic Barcode Reader SDK for .NET
Setting up the Barcode Symbologies (types)
The Barcode Reader SDK is capable of recognizing many of the supported symbologies (barcode types) on an image. However, it is very important you limit the number of barcode symbologies to be recognized by the Reader to the minimum necessary. This means that if you know you are going to deal with EAN-13 and/or Code 39 barcodes only, then just set up to the Reader these two symbologies only and not any other additional types.

Importance of the symbology order setting.
To specify the barcode symbologies to the Reader, you do that by using the Symbology property of the BarcodeReader object. This property is a list (System.Collections.Generic.List) of Symbology objects. The order you add the desired symbologies to the list is very important because the Reader will give high priority to the top (first added) symbologies when the recognition process is performing.
For example, if you need the Reader to recognize EAN-13, Code 39 and GS1-128 barcodes and you add to the Symbology property those objects in that order, then the Reader will invoke the internal EAN-13 decoder first, then the Code 39 decoder, and finally the GS1-128 decoder; while each scanline is being processed. So please be careful when you specify the list of barcode symbologies to the Reader by keeping in mind the order priority.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Setting up the Barcode Rotation or Orientation

Neodynamic Barcode Reader SDK for .NET
Setting up the Barcode Rotation or Orientation
The Barcode Reader SDK can recognize barcodes with 0, 90, 180 and 270 degrees clockwise rotation. You can instruct the Barcode Reader to detect barcodes at one only orientation or by combining some of them (like 0 + 90 degrees). If you are sure that all barcodes will appear oriented in a particular way, for example, all the barcodes are rotated 180 degrees; then you should take advantage of that by setting up 180 degrees barcode rotation to speed up the recognition process.

Barcode Rotation samples

To set up the barcode rotation, you use the BarcodeRotation property of the BarcodeReaderHints object which you must then attach to the BarcodeReader object. Please open the accompanying source code of the Barcode Reader sample app using Visual Studio 2005, 2008 or 2010 to learn how the BarcodeRotation can be set up using your preferred .NET language.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Reading Light Barcodes on Dark Background

Neodynamic Barcode Reader SDK for .NET
Reading Light Barcodes on Dark Background
Generally, all barcodes are printed with dark bars on a light background. It’s very common to find barcodes which bars are printed with black, blue, green, etc. colors while the spaces (gaps) between bars remain white or in a similar light color. However, it’s possible you find some barcodes which are printed with the opposite pattern i.e. they feature light bars (white color mostly) on a dark background like the one shown in the following picture.

A light barcode on a dark background.

To deal with these kinds of barcodes, you should enable the InvertSourceImage property of the BarcodeReaderHints object which you must then attach to the BarcodeReader object.
NOTE: Please be aware that if the InvertSourceImage property is enabled, then normal barcodes (i.e. those with dark bars on light backgrounds) will not be decoded!

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Setting up the number of barcodes to be detected

Neodynamic Barcode Reader SDK for .NET
Setting up the number of barcodes to be detected
By default, the Barcode Reader SDK tries to detect 1 (one) barcode symbol on the specified source image. If you need to detect more than one barcode symbol on the source image, then instruct this to the Reader by setting up the maximum number of barcode through the MaxNumOfBarcodes property of the BarcodeReaderHints object attached to the BarcodeReader object.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Setting up the minimum data length of the barcodes to be decoded

Neodynamic Barcode Reader SDK for .NET
Setting up the minimum data length of the barcodes to be decoded
You can help the Barcode Reader to avoid false-positives or misreading values by specifying the minimum number of the data of the barcodes to be decoded. This value depends on each barcode symbology and you can specify them using the available [Symbology]MinSymbolLength properties in the BarcodeReaderHints object attached to the BarcodeReader object.

For example, for specifying the minimum number of data characters for Code 39 symbology, you can use the Code39MinSymbolLength property of the BarcodeReaderHints object.

Please take advantage of this if you know the length of the data in your barcodes are fixed to a minimum length.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Enabling the Checksum or check-digits on some barcode symbologies

Neodynamic Barcode Reader SDK for .NET
Enabling the Checksum or check-digits on some barcode symbologies
Some barcode symbologies feature optional checksum/check-digit while for others this is mandatory.

For example, Code 128, GS1-128, EAN/UPC barcodes have a mandatory checksum/check-digit value which is used to ensure the reliability of the barcode symbol. For these kinds of symbologies, the Barcode Reader SDK takes advantage of the checksum and will only decode those barcodes which checksum is valid. If the checksum/check-digit is not valid, then the Barcode Reader will not decode the symbol.

On the other hand, there are some symbologies with optional checksum/check-digit like Code 39 and Interleaved 2 of 5. For example, some Code 39 barcodes are generated using a Mod43 checksum. If you know that the barcodes (of optional checksum symbologies) on the source image have a checksum/check-digit incorporated, then you should enable this on the BarcodeReaderHints object attached to the BarcodeReader object. For example, for Code 39 Mod43 checksum, you should enable (set it to True) the Code39EnableMod43Checksum property. Look at the properties of the BarcodeReaderHints object for additional checksums for other symbologies like Interleaved 2 of 5.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Handling the barcode scan results

Neodynamic Barcode Reader SDK for .NET
Handling the barcode scan results
The Barcode Reader SDK stores the barcode recognition results in a list of BarcodeScanResult objects. For each barcode detected and decoded by the Reader you get the encoded value as a string or byte array and the type of the barcode symbology.

There are two ways to handle the barcode recognition results in your code:

  • Getting a List of BarcodeScanResult objects which is returned by the Scan() method of the BarcodeReader object. If you opt for this approach, then the result will be available to you when the Scan() method finishes for any reasons.
  • Getting each BarcodeScanResult objects as soon as the Scan() method detects and decodes each of them. To work with this approach, you need to handle the BarcodeFound event of the BarcodeReader object.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Barcode Symbologies

Neodynamic Barcode Reader SDK for .NET
Barcode Symbologies supported by Barcode Reader SDK
  • Codabar a.k.a. ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar
  • Code 128 a.k.a. ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C
  • Code 39 a.k.a. ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII
  • Code 93 a.k.a. ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII
  • EAN-13 a.k.a. European Article Number 13, UPC-13, GTIN-13, GS1-13, EAN/UCC-13
  • EAN-8 a.k.a. European Article Number 8, UPC-8, GTIN-8, GS1-8, EAN/UCC-8
  • GS1-128 (formerly UCC/EAN-128) Barcode a.k.a. EAN-128, UCC-128, USS-128, GS1 128, UCC.EAN-128, GTIN-128, UCC-12, EAN/UCC-13, EAN/UCC-14
  • Industrial 2 of 5 a.k.a. 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5
  • Interleaved 2 of 5 a.k.a. ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved
  • UPC-A a.k.a. Universal Product Code version A, UPC Code, UPC Symbol, GTIN-12, GS1-12, UCC-12
  • UPC-E a.k.a. Universal Product Code version E, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead 0, GS1-12, UCC-12

Visit Neodynamic's website.

Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Codabar Barcode

This Symbology is also known as ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar

Overview
Codabar was developed in 1972 by Pitney Bowes, Inc. It is a discrete, self-checking symbology that may encode 16 different characters, plus an additional four start/stop characters.
This symbology is used by U.S. blood banks, photo labs, and on FedEx airbills. Since Codabar is self-checking, there is no established checksum digit. This symbology starts and finishes with one of four possible characters A, B, C, or D.

Sample of a Codabar Barcode


Code 128 Barcode

This Symbology is also known as ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C

Overview
Code 128 is a linear bar code symbology capable of encoding the full 128-character ASCII character set and extended character sets. This Symbology includes a checksum digit for verification, and the barcode may also be verified character-by-character verifying the parity of each data byte. It has been widely implemented in many applications where a relatively large amount of data must be encoded in a relatively small amount of space.
Code 128 Code Sets
  • Code Set A (or Chars Set A) includes all of the standard upper case U.S. alphanumeric keyboard characters and punctuation characters together with the control characters, (i.e. characters with ASCII values from 0 to 95 inclusive), and seven special characters.
  • Code Set B (or Chars Set B) includes all of the standard upper case alphanumeric keyboard characters and punctuation characters together with the lower case alphabetic characters (i.e. characters with ASCII values from 32 to 127 inclusive), and seven special characters.
  • Code Set C (or Chars Set C) includes the set of 100 digit pairs from 00 to 99 inclusive, as well as three special characters. This allows numeric data to be encoded as two data digits per symbol character, at effectively twice the density of standard data.
Code 128 Special characters
The last seven characters of Code Sets A and B (character values 96 - 102) and the last three characters of Code Set C (character values 100 - 102) are special non-data characters with no ASCII character equivalents, which have particular significance to the bar code reading device.

Sample of a Code 128 Barcode

Sample of a Code 128 Barcode with Bearer Bars


Code 39 Barcode

This Symbology is also known as ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII

Overview
Code 39, the first alpha-numeric symbology to be developed, is still widely used-especially in non-retail environments. It is suitable for encoding general purpose alphanumeric data.
Code 39 is a discrete, variable-length symbology. It is self-checking in that a single print defect cannot transpose one character into another valid character. It is the standard barcode used by the United States Department of Defense, and is also used by the Health Industry Bar Code Council (HIBCC).
What kind of data can be encoded by Code 39?
  • The Standard Mode (Default implementation) can encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +
  • The Full ASCII Mode or Extended Version can encode all 128 ASCII characters
The * (asterisk) is not a true encodable character, but is the start and stop 'symbol' for Code 39.

Sample of a Code 39 Barcode


Code 93 Barcode

This Symbology is also known as ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII

Overview
Code 93 was designed to complement and improve upon Code 39. Code 93 is similar in that it, like Code 39, can represent the full ASCII character set by using combinations of 2 characters.
It differs in that Code 93 is a continous, variable-length symbology and produces denser code.
Code 93 offers higher information density for alphanumeric data than either Code 39 or Code 128.
What kind of data can be encoded by Code 93?
  • The Standard Mode (Default implementation) can encode uppercase letters (A through Z), digits (0 through 9) and a handful of special characters like the *, -, $, %, (Space), ., /, and +
  • The Full ASCII Mode or Extended Version can encode all 128 ASCII characters
The * (asterisk) is not a true encodable character, but is the start and stop 'symbol' for Code 93.

Sample of a Code 93 Barcode


EAN-13 Barcode

This Symbology is also known as European Article Number 13, UPC-13, GTIN-13, GS1-13, EAN/UCC-13

Overview
EAN-13, based upon the UPC-A standard, was implemented by the International Article Numbering Association (EAN) in Europe. EAN-13 is used worldwide for marking products often sold at retail point of sale. The numbers encoded in EAN-13 bar codes are product identification numbers a.k.a. Global Trade Item Numbers (GTIN) of GS1 System.
Because EAN-13 is a superset of UPC-A, this means that any software or hardware capable of reading an EAN-13 symbol will automatically be able to read an UPC-A symbol. The only difference between EAN-13 and UPC-A is that the number system code in UPC-A is a single digit from 0 through 9 whereas an EAN-13 number system code consists of two digits ranging from 00 through 99, which is essentially a country code.

Sample of an EAN-13 Barcode
The value to encode by EAN-13 has the following structure (a.k.a. GTIN-13):
  • 2 or 3 digits for Number System or Country Code
  • 5 or 4 digits for Manufacturer (Company) Code or prefix
  • 5 digits for Product Code
  • 1 digit for checksum
Each country has a numbering authority which assigns manufacturer codes to companies within its jurisdiction.


EAN-8 Barcode

This Symbology is also known as European Article Number 8, UPC-8, GTIN-8, GS1-8, EAN/UCC-8

Overview
EAN-8 is the EAN equivalent of UPC-E in the sense that it provides a "short" barcode for small packages. The primary purpose of the EAN-8 code is to use as little space as possible.
EAN-8 is encoded using the three EAN-13 character sets and also has a check digit that is calculated in the same way as EAN-13.
The data digits in an EAN-8 symbol identify a particular product and manufacturer. Since a limited number of EAN-8 codes are available in each country, they are issued only for products with insufficient space for a normal EAN-13 symbol. For example, a 2-digit country code permits a total of only 100,000 item numbers.

Sample of an EAN-8 Barcode
The value to encode by EAN-8 has the following structure (a.k.a. GTIN-8):
  • 2 or 3 digits for Number System or Country Code
  • 5 or 4 digits for Product Code
  • 1 digit for checksum
Each country has a numbering authority which assigns manufacturer codes to companies within its jurisdiction.


GS1-128 (formerly UCC/EAN-128) Barcode

This Symbology is also known as EAN-128, UCC-128, USS-128, GS1 128, UCC.EAN-128, GTIN-128, UCC-12, EAN/UCC-13, EAN/UCC-14

Overview
The GS1-128 (formerly UCC/EAN-128) Symbology is a subset of the more general Code 128 Symbology. By agreement among AIM, Inc., GS1 (EAN International and the UCC), use of the Function 1 Character (FNC1) in Code 128 Symbols in the first symbol character position following the Start Character has been reserved exclusively for the GS1 System.
GS1-128 was developed to provide a worldwide format and standard for exchanging common data between companies. While other barcodes simply encode data with no respect for what the data represents, GS1-128 encodes data and encodes what that data represents.
The encodable character used by GS1-128 Symbology is as defined by the International ISO/IEC 646 Standard.
GS1-128 encodes the so called Element Strings which are composed of an Application Identifier (AI) plus a data field. GS1-128 has a list of predefined Application Identifiers (AI) which identifies the meaning and format of the data following it. The AI is a 2, 3, or 4-digit number and it is enclosed in parentheses when printed below the barcode (the parentheses are only for visual clarity, and are not encoded in the barcode!).

Sample of a GS1-128 Barcode


Industrial 2 of 5 Barcode

This Symbology is also known as 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5

Overview
Industrial or Stanadard 2 of 5 is a low-density numeric symbology that has been with us since the 1960s. It has been used in the photofinishing and warehouse sorting industries, as well as sequentially numbering airline tickets. A more efficient implement of Industrial 2 of 5 is the Interleaved 2 of 5 symbology.

Sample of an Industrial 2 of 5 Barcode


Interleaved 2 of 5 Barcode

This Symbology is also known as ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved

Overview
Interleaved 2 of 5 is a higher-density numeric symbology based upon the Industrial 2 of 5 symbology. It is suitable for encoding general purpose all-numeric data and is used primarily in the distribution and warehouse industry. Interleaved 2 of 5 is essentially identical to Industrial 2 of 5 except for the fact that Interleaved 2 of 5 encodes information in both the bars and spaces while Standard 2 of 5 only encodes information in the bars. However, the encoding scheme is the same for both in terms of their use of wide and narrow elements for each element.

Sample of an Interleaved 2 of 5 Barcode

Sample of an Interleaved 2 of 5 Barcode with Bearer Bars


UPC-A Barcode

This Symbology is also known as Universal Product Code version A, UPC Code, UPC Symbol, GTIN-12, GS1-12, UCC-12

Overview
UPC-A is used for marking products which are sold at retail in the USA. The barcode identifies the manufacturer and specific product so point-of- sale cash register systems can automatically look up the price.
The UPC-A Code and the assignment of manufacturer ID numbers is controlled in the U.S.A. by the Uniform Code Council (UCC).

Sample of a UPC-A Barcode
The value to encode by UPC-A has the following structure (a.k.a. GTIN-12):
  • 1 digit for Number System (0: regular UPC codes, 1: reserved, 2: random weight items marked at the store, 3: National Drug Code and National Health Related Items code, 4: no format restrictions, for in-store use on non-food items, 5: for use on coupons, 6: reserved, 7: regular UPC codes, 8: reserved, 9: reserved)
  • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
  • 5 digits for Product Code which is assigned by the manufacturer
  • 1 digit for checksum


UPC-E Barcode

This Symbology is also known as Universal Product Code version E, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead "0", GS1-12, UCC-12

Overview
UPC-E is a variation of UPC-A which allows for a more compact barcode by eliminating "extra" zeros.
Since the resulting UPC-E barcode is about half the size as an UPC-A barcode, UPC-E is generally used on products with very small packaging where a full UPC-A barcode couldn't reasonably fit.
A UPC-E barcode represents 6 digits with an implied number system 0. However, a Number System 1 can be used as well.

Sample of a UPC-E Barcode
The value to encode by UPC-E has the following structure and it's the same as for UPC-A (a.k.a. GTIN-12):
  • 1 digit for Number System (0: regular UPC codes, 1: reserved, 2: random weight items marked at the store, 3: National Drug Code and National Health Related Items code, 4: no format restrictions, for in-store use on non-food items, 5: for use on coupons, 6: reserved, 7: regular UPC codes, 8: reserved, 9: reserved)
  • 5 digits for Manufacturer (Company) Code or prefix. This number is assigned by the Uniform Code Council (UCC)
  • 5 digits for Product Code which is assigned by the manufacturer
  • 1 digit for checksum


Neodynamic.SDK.BarcodeReader Namespace

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
Neodynamic.SDK.BarcodeReader Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarcodeFoundEventArgs | It provides data for the BarcodeFound event.
Public class | BarcodeReader | It scans an image looking for barcode symbols. It can detect and decode most common barcode standards (a.k.a. symbologies) like Code 39, Code 128, GS1 128, EAN/UPC, etc.
Public class | BarcodeReaderException | It represents errors that occur during the barcode reader scan process.
Public class | BarcodeReaderHints | It provides some scanning and decoding hints to the Barcode Reader. It is useful for improving the barcode reader performance and accuracy.
Public class | BarcodeScanResult | It represents the scan result of a barcode symbol which was founded by the barcode reader.
Public class | ScanRegion | It represents a scan region of the target document or image.

Structures

 | Structure | Description
Public structure | ScanRegionPercentage | It represents a scan region using percentage values for both horizontal and vertical directions.

Delegates

 | Delegate | Description
Public delegate | BarcodeFoundEventHandler | It represents the method that will handle the BarcodeFound event of a BarcodeReader object.

Enumerations

 | Enumeration | Description
Public enumeration | BarcodeRotation | It specifies a barcode rotation.
Public enumeration | ScanDirection | It specifies a scan direction.
Public enumeration | Symbology | It specifies the barcode symbologies supported by the reader.
Neodynamic Barcode Reader SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2011 Neodynamic - All rights reserved.


BarcodeFoundEventArgs Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs Class
Members See Also Send Feedback
It provides data for the BarcodeFound event.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class BarcodeFoundEventArgs : EventArgs
Visual Basic
Public Class BarcodeFoundEventArgs _
    Inherits EventArgs
Visual C++
public ref class BarcodeFoundEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Neodynamic.SDK.BarcodeReader..::..BarcodeFoundEventArgs

See Also

BarcodeFoundEventArgs Members
Neodynamic.SDK.BarcodeReader Namespace


BarcodeFoundEventArgs Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs Members
BarcodeFoundEventArgs Class Constructors Methods Properties See Also Send Feedback

The BarcodeFoundEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeFoundEventArgs | Initializes a new instance of the BarcodeFoundEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarcodeScanResult | Gets a scan result object containing data about the detected barcode.

See Also

BarcodeFoundEventArgs Class


BarcodeFoundEventArgs Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs Constructor
BarcodeFoundEventArgs Class See Also Send Feedback
Initializes a new instance of the BarcodeFoundEventArgs class.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeFoundEventArgs(
    BarcodeScanResult barcodeScanResult
)
Visual Basic
Public Sub New ( _
    barcodeScanResult As BarcodeScanResult _
)
Visual C++
public:
BarcodeFoundEventArgs(
    BarcodeScanResult^ barcodeScanResult
)

Parameters

barcodeScanResult
Type: Neodynamic.SDK.BarcodeReader..::..BarcodeScanResult
The scan result object containing data about the detected barcode.

See Also

BarcodeFoundEventArgs Class


BarcodeFoundEventArgs Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs Methods
BarcodeFoundEventArgs Class See Also Send Feedback

The BarcodeFoundEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeFoundEventArgs Class


BarcodeFoundEventArgs Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs Properties
BarcodeFoundEventArgs Class See Also Send Feedback

The BarcodeFoundEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | BarcodeScanResult | Gets a scan result object containing data about the detected barcode.

See Also

BarcodeFoundEventArgs Class


BarcodeScanResult Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventArgs..::..BarcodeScanResult Property
BarcodeFoundEventArgs Class See Also Send Feedback
Gets a scan result object containing data about the detected barcode.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeScanResult BarcodeScanResult { get; }
Visual Basic
Public ReadOnly Property BarcodeScanResult As BarcodeScanResult
    Get
Visual C++
public:
property BarcodeScanResult^ BarcodeScanResult {
    BarcodeScanResult^ get ();
}

See Also

BarcodeFoundEventArgs Class


BarcodeFoundEventHandler Delegate

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeFoundEventHandler Delegate
See Also Send Feedback
It represents the method that will handle the BarcodeFound event of a BarcodeReader object.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public delegate void BarcodeFoundEventHandler(
    Object sender,
    BarcodeFoundEventArgs e
)
Visual Basic
Public Delegate Sub BarcodeFoundEventHandler ( _
    sender As Object, _
    e As BarcodeFoundEventArgs _
)
Visual C++
public delegate void BarcodeFoundEventHandler(
    Object^ sender,
    BarcodeFoundEventArgs^ e
)

Parameters

sender
Type: System..::..Object
The source of the event.
e
Type: Neodynamic.SDK.BarcodeReader..::..BarcodeFoundEventArgs
A BarcodeFoundEventArgs that contains the event data.

See Also

Neodynamic.SDK.BarcodeReader Namespace
Neodynamic Barcode Reader SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2011 Neodynamic - All rights reserved.


BarcodeReader Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Class
Members See Also Send Feedback
It scans an image looking for barcode symbols. It can detect and decode most common barcode standards (a.k.a. symbologies) like Code 39, Code 128, GS1 128, EAN/UPC, etc.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class BarcodeReader
Visual Basic
Public Class BarcodeReader
Visual C++
public ref class BarcodeReader

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.BarcodeReader..::..BarcodeReader

See Also

BarcodeReader Members


BarcodeReader Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Members
BarcodeReader Class Constructors Methods Properties Events See Also Send Feedback

The BarcodeReader type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeReader()()()() | Initializes a new instance of the BarcodeReader class
Public method | BarcodeReader(String, String) | Initializes a new instance of the BarcodeReader class with the specified license data.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Scan(array<Byte>[]()[][]) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object.
Public method | Scan(Bitmap) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object.
Public method | Scan(Stream) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object.
Public method | Scan(String) | It starts the scan process which will look for the specified barcode symbologies on the specified file.
Public method | Scan(array<Byte>[]()[][], ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object and region of interest.
Public method | Scan(Bitmap, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object and region of interest.
Public method | Scan(Stream, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object and region of interest.
Public method | Scan(String, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified file and region of interest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Hints | Gets or sets some hints to help the barcode reader accuracy and performance.
Public property | Symbology | Gets or sets the barcode symbologies to be detected and decoded.

Events

 | Name | Description
Public event | BarcodeFound | Occurs when the reader detects and sucessfully decodes a barcode symbol.

See Also

BarcodeReader Class


BarcodeReader Constructor

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Constructor
BarcodeReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BarcodeReader()()()() | Initializes a new instance of the BarcodeReader class
Public method | BarcodeReader(String, String) | Initializes a new instance of the BarcodeReader class with the specified license data.

See Also

BarcodeReader Class
BarcodeReader Members


BarcodeReader Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Constructor
BarcodeReader Class See Also Send Feedback
Initializes a new instance of the BarcodeReader class

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeReader()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeReader()

See Also

BarcodeReader Class
BarcodeReader Overload


BarcodeReader Constructor (String, String)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Constructor (String, String)
BarcodeReader Class See Also Send Feedback
Initializes a new instance of the BarcodeReader class with the specified license data.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeReader(
    string licenseOwner,
    string licenseKey
)
Visual Basic
Public Sub New ( _
    licenseOwner As String, _
    licenseKey As String _
)
Visual C++
public:
BarcodeReader(
    String^ licenseOwner,
    String^ licenseKey
)

Parameters

licenseOwner
Type: System..::..String
The License Owner string.
licenseKey
Type: System..::..String
The License Key string.

See Also

BarcodeReader Class
BarcodeReader Overload


BarcodeReader Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Methods
BarcodeReader Class See Also Send Feedback

The BarcodeReader type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Scan(array<Byte>[]()[][]) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object.
Public method | Scan(Bitmap) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object.
Public method | Scan(Stream) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object.
Public method | Scan(String) | It starts the scan process which will look for the specified barcode symbologies on the specified file.
Public method | Scan(array<Byte>[]()[][], ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object and region of interest.
Public method | Scan(Bitmap, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object and region of interest.
Public method | Scan(Stream, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object and region of interest.
Public method | Scan(String, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified file and region of interest.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeReader Class


Scan Method

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method
BarcodeReader Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Scan(array<Byte>[]()[][]) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object.
Public method | Scan(Bitmap) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object.
Public method | Scan(Stream) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object.
Public method | Scan(String) | It starts the scan process which will look for the specified barcode symbologies on the specified file.
Public method | Scan(array<Byte>[]()[][], ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object and region of interest.
Public method | Scan(Bitmap, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object and region of interest.
Public method | Scan(Stream, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object and region of interest.
Public method | Scan(String, ScanRegion) | It starts the scan process which will look for the specified barcode symbologies on the specified file and region of interest.

See Also

BarcodeReader Class
BarcodeReader Members


Scan Method (Byte[])

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (array<Byte>[]()[][])
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    byte[] imageBuffer
)
Visual Basic
Public Function Scan ( _
    imageBuffer As Byte() _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    array<unsigned char>^ imageBuffer
)

Parameters

imageBuffer
Type: array< System..::..Byte >[]()[][]
The array of bytes object which contains some barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (Bitmap)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (Bitmap)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    Bitmap image
)
Visual Basic
Public Function Scan ( _
    image As Bitmap _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    Bitmap^ image
)

Parameters

image
Type: System.Drawing..::..Bitmap
The System.Drawing.Bitmap object which contains some barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (Stream)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (Stream)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    Stream imageStream
)
Visual Basic
Public Function Scan ( _
    imageStream As Stream _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    Stream^ imageStream
)

Parameters

imageStream
Type: System.IO..::..Stream
The System.IO.Stream object which contains some barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (String)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (String)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified file.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    string filePath
)
Visual Basic
Public Function Scan ( _
    filePath As String _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    String^ filePath
)

Parameters

filePath
Type: System..::..String
The file path which contains some barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (Byte[], ScanRegion)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (array<Byte>[]()[][], ScanRegion)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified array of bytes object and region of interest.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    byte[] imageBuffer,
    ScanRegion regionOfInterest
)
Visual Basic
Public Function Scan ( _
    imageBuffer As Byte(), _
    regionOfInterest As ScanRegion _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    array<unsigned char>^ imageBuffer,
    ScanRegion^ regionOfInterest
)

Parameters

imageBuffer
Type: array< System..::..Byte >[]()[][]
The array of bytes object which contains some barcode symbols.
regionOfInterest
Type: Neodynamic.SDK.BarcodeReader..::..ScanRegion
The region of interest on the file where to look for the barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (Bitmap, ScanRegion)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (Bitmap, ScanRegion)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified System.Drawing.Bitmap object and region of interest.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    Bitmap image,
    ScanRegion regionOfInterest
)
Visual Basic
Public Function Scan ( _
    image As Bitmap, _
    regionOfInterest As ScanRegion _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    Bitmap^ image,
    ScanRegion^ regionOfInterest
)

Parameters

image
Type: System.Drawing..::..Bitmap
The System.Drawing.Bitmap object which contains some barcode symbols.
regionOfInterest
Type: Neodynamic.SDK.BarcodeReader..::..ScanRegion
The region of interest on the file where to look for the barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (Stream, ScanRegion)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (Stream, ScanRegion)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified System.IO.Stream object and region of interest.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    Stream imageStream,
    ScanRegion regionOfInterest
)
Visual Basic
Public Function Scan ( _
    imageStream As Stream, _
    regionOfInterest As ScanRegion _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    Stream^ imageStream,
    ScanRegion^ regionOfInterest
)

Parameters

imageStream
Type: System.IO..::..Stream
The System.IO.Stream object which contains some barcode symbols.
regionOfInterest
Type: Neodynamic.SDK.BarcodeReader..::..ScanRegion
The region of interest on the file where to look for the barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


Scan Method (String, ScanRegion)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Scan Method (String, ScanRegion)
BarcodeReader Class See Also Send Feedback
It starts the scan process which will look for the specified barcode symbologies on the specified file and region of interest.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<BarcodeScanResult> Scan(
    string filePath,
    ScanRegion regionOfInterest
)
Visual Basic
Public Function Scan ( _
    filePath As String, _
    regionOfInterest As ScanRegion _
) As List(Of BarcodeScanResult)
Visual C++
public:
List<BarcodeScanResult^>^ Scan(
    String^ filePath,
    ScanRegion^ regionOfInterest
)

Parameters

filePath
Type: System..::..String
The file path which contains some barcode symbols.
regionOfInterest
Type: Neodynamic.SDK.BarcodeReader..::..ScanRegion
The region of interest on the file where to look for the barcode symbols.

Return Value

It returns a list of BarcodeScanResult objects containing information about the detected barcodes. An empty list will indicate that no barcodes were found by the reader.

See Also

BarcodeReader Class
Scan Overload


BarcodeReader Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Properties
BarcodeReader Class See Also Send Feedback

The BarcodeReader type exposes the following members.

Properties

 | Name | Description
Public property | Hints | Gets or sets some hints to help the barcode reader accuracy and performance.
Public property | Symbology | Gets or sets the barcode symbologies to be detected and decoded.

See Also

BarcodeReader Class


Hints Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Hints Property
BarcodeReader Class See Also Send Feedback
Gets or sets some hints to help the barcode reader accuracy and performance.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeReaderHints Hints { get; set; }
Visual Basic
Public Property Hints As BarcodeReaderHints
    Get
    Set
Visual C++
public:
property BarcodeReaderHints^ Hints {
    BarcodeReaderHints^ get ();
    void set (BarcodeReaderHints^ value);
}

See Also

BarcodeReader Class


Symbology Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..Symbology Property
BarcodeReader Class See Also Send Feedback
Gets or sets the barcode symbologies to be detected and decoded.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public List<Symbology> Symbology { get; set; }
Visual Basic
Public Property Symbology As List(Of Symbology)
    Get
    Set
Visual C++
public:
property List<Symbology>^ Symbology {
    List<Symbology>^ get ();
    void set (List<Symbology>^ value);
}

Remarks

You can specify one or more barcode symbologies to be detected and decoded. This is a list of Symbology items and the order is important to determine which symbology is processed at each time. Use it to prioritize a symbology over others.

See Also

BarcodeReader Class


BarcodeReader Events

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader Events
BarcodeReader Class See Also Send Feedback

The BarcodeReader type exposes the following members.

Events

 | Name | Description
Public event | BarcodeFound | Occurs when the reader detects and sucessfully decodes a barcode symbol.

See Also

BarcodeReader Class


BarcodeFound Event

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReader..::..BarcodeFound Event
BarcodeReader Class See Also Send Feedback
Occurs when the reader detects and sucessfully decodes a barcode symbol.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public event BarcodeFoundEventHandler BarcodeFound
Visual Basic
Public Event BarcodeFound As BarcodeFoundEventHandler
Visual C++
public:
 event BarcodeFoundEventHandler^ BarcodeFound {
    void add (BarcodeFoundEventHandler^ value);
    void remove (BarcodeFoundEventHandler^ value);
}

See Also

BarcodeReader Class


BarcodeReaderException Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderException Class
Members See Also Send Feedback
It represents errors that occur during the barcode reader scan process.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class BarcodeReaderException : Exception
Visual Basic
Public Class BarcodeReaderException _
    Inherits Exception
Visual C++
public ref class BarcodeReaderException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Neodynamic.SDK.BarcodeReader..::..BarcodeReaderException

See Also

BarcodeReaderException Members


BarcodeReaderException Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderException Members
BarcodeReaderException Class Constructors Methods Properties See Also Send Feedback

The BarcodeReaderException type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeReaderException | Initializes a new instance of the BarcodeReaderException class with a specified error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BarcodeReaderException Class


BarcodeReaderException Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderException Constructor
BarcodeReaderException Class See Also Send Feedback
Initializes a new instance of the BarcodeReaderException class with a specified error message.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeReaderException(
    string message
)
Visual Basic
Public Sub New ( _
    message As String _
)
Visual C++
public:
BarcodeReaderException(
    String^ message
)

Parameters

message
Type: System..::..String
The message that describes the error.

See Also

BarcodeReaderException Class


BarcodeReaderException Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderException Methods
BarcodeReaderException Class See Also Send Feedback

The BarcodeReaderException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BarcodeReaderException Class


BarcodeReaderException Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderException Properties
BarcodeReaderException Class See Also Send Feedback

The BarcodeReaderException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Protected property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BarcodeReaderException Class


BarcodeReaderHints Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints Class
Members See Also Send Feedback
It provides some scanning and decoding hints to the Barcode Reader. It is useful for improving the barcode reader performance and accuracy.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class BarcodeReaderHints
Visual Basic
Public Class BarcodeReaderHints
Visual C++
public ref class BarcodeReaderHints

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.BarcodeReader..::..BarcodeReaderHints

See Also

BarcodeReaderHints Members


BarcodeReaderHints Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints Members
BarcodeReaderHints Class Constructors Methods Properties See Also Send Feedback

The BarcodeReaderHints type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeReaderHints | Initializes a new instance of the BarcodeReaderHints class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BarcodeRotation | Gets or sets the barcode orientation on the source image. Default is None (zero degrees).
Public property | CodabarEnableMod16Checksum | Gets or sets whether the reader should scan only Codabar barcodes that have a valid Mod 16 checksum. Default is false.
Public property | CodabarMinSymbolLength | Gets or sets the minimum number of characters a Codabar barcode should contain. Default is 5.
Public property | CodabarTransmitMod16Checksum | Gets or sets whether the reader should transmit the Mod 16 checksum for Codabar barcodes. Default is false.
Public property | CodabarTransmitStartStopChars | Gets or sets whether the reader should transmit the Codabar start and stop characters. Default is false.
Public property | Code128MinSymbolLength | Gets or sets the minimum number of characters a Code 128 barcode should contain. Default is 3.
Public property | Code39EnableFullAsciiMode | Gets or sets whether the reader should convert Code 39 data to full ASCII mode. Default is false.
Public property | Code39EnableMod43Checksum | Gets or sets whether the reader should scan only Code 39 barcodes that have a valid Mod 43 checksum. Default is false.
Public property | Code39MinSymbolLength | Gets or sets the minimum number of characters a Code 39 barcode should contain. Default is 3.
Public property | Code39TransmitMod43Checksum | Gets or sets whether the reader should transmit the Mod 43 checksum for Code 39 barcodes. Default is false.
Public property | Code93MinSymbolLength | Gets or sets the minimum number of characters a Code 93 barcode should contain. Default is 3.
Public property | EanUpcConvertUpcEtoUpcA | Gets or sets whether the reader should convert the UPC-E code to the UPC-A equivalent code. Default is false.
Public property | EanUpcDecodeUpcAasEan13 | Gets or sets whether the reader should decode UPC-A as EAN-13 barcodes. Default is true.
Public property | EanUpcTransmitChecksum | Gets or sets whether the reader should transmit the checksum/check-digit for any EAN/UPC barcodes. Default is true.
Public property | EanUpcTransmitLeadZeroOnUpcE | Gets or sets whether the reader should transmit a leading zero when decoding UPC-E barcodes. Default is true.
Public property | Industrial2of5EnableMod10Checksum | Gets or sets whether the reader should scan only Industrial 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.
Public property | Industrial2of5MinSymbolLength | Gets or sets the minimum number of characters a Industrial 2 of 5 barcode should contain. Default is 3.
Public property | Industrial2of5TransmitMod10Checksum | Gets or sets whether the reader should transmit the Mod 10 checksum for Industrial 2 of 5 barcodes. Default is false.
Public property | Interleaved2of5EnableMod10Checksum | Gets or sets whether the reader should scan only Interleaved 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.
Public property | Interleaved2of5MinSymbolLength | Gets or sets the minimum number of characters a Interleaved 2 of 5 barcode should contain. Default is 6.
Public property | InterleavedTransmitMod10Checksum | Gets or sets whether the reader should transmit the Mod 10 checksum for Interleaved 2 of 5 barcodes. Default is false.
Public property | InvertSourceImage | Gets or sets whether the reader should invert (convert to negative) the source image before starting the scanning process. Default is false.
Public property | MaxNumOfBarcodes | Gets or sets the maximum number of barcodes to be found and decoded. Setting up this to zero indicates that the number of barcodes is unknown. Default is 1.
Public property | ScanDirection | Gets or sets the scan direction used by the reader. Default is MiddleOutwards.
Public property | ScanlineDistance | Gets or sets the distance (in pixel unit) between scanline steps. Default is 0.
Public property | ScanlineThickness | Gets or sets the scanline thickness (in pixel unit). Default is 2.
Public property | ScanTimeout | Gets or sets the amount of time (in Milliseconds) after which the scan process will time out. Default is zero which indicates an infinite time-out period.

See Also

BarcodeReaderHints Class


BarcodeReaderHints Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints Constructor
BarcodeReaderHints Class See Also Send Feedback
Initializes a new instance of the BarcodeReaderHints class

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeReaderHints()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeReaderHints()

See Also

BarcodeReaderHints Class


BarcodeReaderHints Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints Methods
BarcodeReaderHints Class See Also Send Feedback

The BarcodeReaderHints type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeReaderHints Class


BarcodeReaderHints Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints Properties
BarcodeReaderHints Class See Also Send Feedback

The BarcodeReaderHints type exposes the following members.

Properties

 | Name | Description
Public property | BarcodeRotation | Gets or sets the barcode orientation on the source image. Default is None (zero degrees).
Public property | CodabarEnableMod16Checksum | Gets or sets whether the reader should scan only Codabar barcodes that have a valid Mod 16 checksum. Default is false.
Public property | CodabarMinSymbolLength | Gets or sets the minimum number of characters a Codabar barcode should contain. Default is 5.
Public property | CodabarTransmitMod16Checksum | Gets or sets whether the reader should transmit the Mod 16 checksum for Codabar barcodes. Default is false.
Public property | CodabarTransmitStartStopChars | Gets or sets whether the reader should transmit the Codabar start and stop characters. Default is false.
Public property | Code128MinSymbolLength | Gets or sets the minimum number of characters a Code 128 barcode should contain. Default is 3.
Public property | Code39EnableFullAsciiMode | Gets or sets whether the reader should convert Code 39 data to full ASCII mode. Default is false.
Public property | Code39EnableMod43Checksum | Gets or sets whether the reader should scan only Code 39 barcodes that have a valid Mod 43 checksum. Default is false.
Public property | Code39MinSymbolLength | Gets or sets the minimum number of characters a Code 39 barcode should contain. Default is 3.
Public property | Code39TransmitMod43Checksum | Gets or sets whether the reader should transmit the Mod 43 checksum for Code 39 barcodes. Default is false.
Public property | Code93MinSymbolLength | Gets or sets the minimum number of characters a Code 93 barcode should contain. Default is 3.
Public property | EanUpcConvertUpcEtoUpcA | Gets or sets whether the reader should convert the UPC-E code to the UPC-A equivalent code. Default is false.
Public property | EanUpcDecodeUpcAasEan13 | Gets or sets whether the reader should decode UPC-A as EAN-13 barcodes. Default is true.
Public property | EanUpcTransmitChecksum | Gets or sets whether the reader should transmit the checksum/check-digit for any EAN/UPC barcodes. Default is true.
Public property | EanUpcTransmitLeadZeroOnUpcE | Gets or sets whether the reader should transmit a leading zero when decoding UPC-E barcodes. Default is true.
Public property | Industrial2of5EnableMod10Checksum | Gets or sets whether the reader should scan only Industrial 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.
Public property | Industrial2of5MinSymbolLength | Gets or sets the minimum number of characters a Industrial 2 of 5 barcode should contain. Default is 3.
Public property | Industrial2of5TransmitMod10Checksum | Gets or sets whether the reader should transmit the Mod 10 checksum for Industrial 2 of 5 barcodes. Default is false.
Public property | Interleaved2of5EnableMod10Checksum | Gets or sets whether the reader should scan only Interleaved 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.
Public property | Interleaved2of5MinSymbolLength | Gets or sets the minimum number of characters a Interleaved 2 of 5 barcode should contain. Default is 6.
Public property | InterleavedTransmitMod10Checksum | Gets or sets whether the reader should transmit the Mod 10 checksum for Interleaved 2 of 5 barcodes. Default is false.
Public property | InvertSourceImage | Gets or sets whether the reader should invert (convert to negative) the source image before starting the scanning process. Default is false.
Public property | MaxNumOfBarcodes | Gets or sets the maximum number of barcodes to be found and decoded. Setting up this to zero indicates that the number of barcodes is unknown. Default is 1.
Public property | ScanDirection | Gets or sets the scan direction used by the reader. Default is MiddleOutwards.
Public property | ScanlineDistance | Gets or sets the distance (in pixel unit) between scanline steps. Default is 0.
Public property | ScanlineThickness | Gets or sets the scanline thickness (in pixel unit). Default is 2.
Public property | ScanTimeout | Gets or sets the amount of time (in Milliseconds) after which the scan process will time out. Default is zero which indicates an infinite time-out period.

See Also

BarcodeReaderHints Class


BarcodeRotation Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..BarcodeRotation Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the barcode orientation on the source image. Default is None (zero degrees).

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public BarcodeRotation BarcodeRotation { get; set; }
Visual Basic
Public Property BarcodeRotation As BarcodeRotation
    Get
    Set
Visual C++
public:
property BarcodeRotation BarcodeRotation {
    BarcodeRotation get ();
    void set (BarcodeRotation value);
}

See Also

BarcodeReaderHints Class


CodabarEnableMod16Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..CodabarEnableMod16Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should scan only Codabar barcodes that have a valid Mod 16 checksum. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool CodabarEnableMod16Checksum { get; set; }
Visual Basic
Public Property CodabarEnableMod16Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool CodabarEnableMod16Checksum {
    bool get ();
    void set (bool value);
}

Remarks

If you know the Codabar barcodes to be read have Mod 16 checksum, then you should enable this property.

See Also

BarcodeReaderHints Class


CodabarMinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..CodabarMinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Codabar barcode should contain. Default is 5.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int CodabarMinSymbolLength { get; set; }
Visual Basic
Public Property CodabarMinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int CodabarMinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


CodabarTransmitMod16Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..CodabarTransmitMod16Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the Mod 16 checksum for Codabar barcodes. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool CodabarTransmitMod16Checksum { get; set; }
Visual Basic
Public Property CodabarTransmitMod16Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool CodabarTransmitMod16Checksum {
    bool get ();
    void set (bool value);
}

Remarks

You must enable the CodabarEnableMod16Checksum property so the CodabarTransmitMod16Checksum property takes effect.

See Also

BarcodeReaderHints Class


CodabarTransmitStartStopChars Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..CodabarTransmitStartStopChars Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the Codabar start and stop characters. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool CodabarTransmitStartStopChars { get; set; }
Visual Basic
Public Property CodabarTransmitStartStopChars As Boolean
    Get
    Set
Visual C++
public:
property bool CodabarTransmitStartStopChars {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


Code128MinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code128MinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Code 128 barcode should contain. Default is 3.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int Code128MinSymbolLength { get; set; }
Visual Basic
Public Property Code128MinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int Code128MinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


Code39EnableFullAsciiMode Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code39EnableFullAsciiMode Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should convert Code 39 data to full ASCII mode. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Code39EnableFullAsciiMode { get; set; }
Visual Basic
Public Property Code39EnableFullAsciiMode As Boolean
    Get
    Set
Visual C++
public:
property bool Code39EnableFullAsciiMode {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


Code39EnableMod43Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code39EnableMod43Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should scan only Code 39 barcodes that have a valid Mod 43 checksum. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Code39EnableMod43Checksum { get; set; }
Visual Basic
Public Property Code39EnableMod43Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool Code39EnableMod43Checksum {
    bool get ();
    void set (bool value);
}

Remarks

If you know the Code 39 barcodes to be read have Mod 43 checksum, then you should enable this property.

See Also

BarcodeReaderHints Class


Code39MinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code39MinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Code 39 barcode should contain. Default is 3.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int Code39MinSymbolLength { get; set; }
Visual Basic
Public Property Code39MinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int Code39MinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


Code39TransmitMod43Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code39TransmitMod43Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the Mod 43 checksum for Code 39 barcodes. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Code39TransmitMod43Checksum { get; set; }
Visual Basic
Public Property Code39TransmitMod43Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool Code39TransmitMod43Checksum {
    bool get ();
    void set (bool value);
}

Remarks

You must enable the Code39EnableMod43Checksum property so the Code39TransmitMod43Checksum property takes effect.

See Also

BarcodeReaderHints Class


Code93MinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Code93MinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Code 93 barcode should contain. Default is 3.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int Code93MinSymbolLength { get; set; }
Visual Basic
Public Property Code93MinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int Code93MinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


EanUpcConvertUpcEtoUpcA Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..EanUpcConvertUpcEtoUpcA Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should convert the UPC-E code to the UPC-A equivalent code. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool EanUpcConvertUpcEtoUpcA { get; set; }
Visual Basic
Public Property EanUpcConvertUpcEtoUpcA As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcConvertUpcEtoUpcA {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


EanUpcDecodeUpcAasEan13 Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..EanUpcDecodeUpcAasEan13 Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should decode UPC-A as EAN-13 barcodes. Default is true.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool EanUpcDecodeUpcAasEan13 { get; set; }
Visual Basic
Public Property EanUpcDecodeUpcAasEan13 As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcDecodeUpcAasEan13 {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


EanUpcTransmitChecksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..EanUpcTransmitChecksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the checksum/check-digit for any EAN/UPC barcodes. Default is true.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool EanUpcTransmitChecksum { get; set; }
Visual Basic
Public Property EanUpcTransmitChecksum As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcTransmitChecksum {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


EanUpcTransmitLeadZeroOnUpcE Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..EanUpcTransmitLeadZeroOnUpcE Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit a leading zero when decoding UPC-E barcodes. Default is true.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool EanUpcTransmitLeadZeroOnUpcE { get; set; }
Visual Basic
Public Property EanUpcTransmitLeadZeroOnUpcE As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcTransmitLeadZeroOnUpcE {
    bool get ();
    void set (bool value);
}

See Also

BarcodeReaderHints Class


Industrial2of5EnableMod10Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Industrial2of5EnableMod10Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should scan only Industrial 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Industrial2of5EnableMod10Checksum { get; set; }
Visual Basic
Public Property Industrial2of5EnableMod10Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool Industrial2of5EnableMod10Checksum {
    bool get ();
    void set (bool value);
}

Remarks

If you know the Industrial 2 of 5 barcodes to be read have Mod 10 checksum, then you should enable this property.

See Also

BarcodeReaderHints Class


Industrial2of5MinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Industrial2of5MinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Industrial 2 of 5 barcode should contain. Default is 3.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int Industrial2of5MinSymbolLength { get; set; }
Visual Basic
Public Property Industrial2of5MinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int Industrial2of5MinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


Industrial2of5TransmitMod10Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Industrial2of5TransmitMod10Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the Mod 10 checksum for Industrial 2 of 5 barcodes. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Industrial2of5TransmitMod10Checksum { get; set; }
Visual Basic
Public Property Industrial2of5TransmitMod10Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool Industrial2of5TransmitMod10Checksum {
    bool get ();
    void set (bool value);
}

Remarks

You must enable the Industrial2of5EnableMod10Checksum property so the Industrial2of5TransmitMod10Checksum property takes effect.

See Also

BarcodeReaderHints Class


Interleaved2of5EnableMod10Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Interleaved2of5EnableMod10Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should scan only Interleaved 2 of 5 barcodes that have a valid Mod 10 checksum. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Interleaved2of5EnableMod10Checksum { get; set; }
Visual Basic
Public Property Interleaved2of5EnableMod10Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool Interleaved2of5EnableMod10Checksum {
    bool get ();
    void set (bool value);
}

Remarks

If you know the Interleaved 2 of 5 barcodes to be read have Mod 10 checksum, then you should enable this property.

See Also

BarcodeReaderHints Class


Interleaved2of5MinSymbolLength Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..Interleaved2of5MinSymbolLength Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the minimum number of characters a Interleaved 2 of 5 barcode should contain. Default is 6.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int Interleaved2of5MinSymbolLength { get; set; }
Visual Basic
Public Property Interleaved2of5MinSymbolLength As Integer
    Get
    Set
Visual C++
public:
property int Interleaved2of5MinSymbolLength {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


InterleavedTransmitMod10Checksum Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..InterleavedTransmitMod10Checksum Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should transmit the Mod 10 checksum for Interleaved 2 of 5 barcodes. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool InterleavedTransmitMod10Checksum { get; set; }
Visual Basic
Public Property InterleavedTransmitMod10Checksum As Boolean
    Get
    Set
Visual C++
public:
property bool InterleavedTransmitMod10Checksum {
    bool get ();
    void set (bool value);
}

Remarks

You must enable the Interleaved2of5EnableMod10Checksum property so the Interleaved2of5TransmitMod10Checksum property takes effect.

See Also

BarcodeReaderHints Class


InvertSourceImage Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..InvertSourceImage Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets whether the reader should invert (convert to negative) the source image before starting the scanning process. Default is false.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool InvertSourceImage { get; set; }
Visual Basic
Public Property InvertSourceImage As Boolean
    Get
    Set
Visual C++
public:
property bool InvertSourceImage {
    bool get ();
    void set (bool value);
}

Remarks

You should enable this property if the source image contains light barcodes on dark background.

See Also

BarcodeReaderHints Class


MaxNumOfBarcodes Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..MaxNumOfBarcodes Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the maximum number of barcodes to be found and decoded. Setting up this to zero indicates that the number of barcodes is unknown. Default is 1.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int MaxNumOfBarcodes { get; set; }
Visual Basic
Public Property MaxNumOfBarcodes As Integer
    Get
    Set
Visual C++
public:
property int MaxNumOfBarcodes {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


ScanDirection Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..ScanDirection Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the scan direction used by the reader. Default is MiddleOutwards.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanDirection ScanDirection { get; set; }
Visual Basic
Public Property ScanDirection As ScanDirection
    Get
    Set
Visual C++
public:
property ScanDirection ScanDirection {
    ScanDirection get ();
    void set (ScanDirection value);
}

See Also

BarcodeReaderHints Class


ScanlineDistance Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..ScanlineDistance Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the distance (in pixel unit) between scanline steps. Default is 0.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int ScanlineDistance { get; set; }
Visual Basic
Public Property ScanlineDistance As Integer
    Get
    Set
Visual C++
public:
property int ScanlineDistance {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


ScanlineThickness Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..ScanlineThickness Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the scanline thickness (in pixel unit). Default is 2.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int ScanlineThickness { get; set; }
Visual Basic
Public Property ScanlineThickness As Integer
    Get
    Set
Visual C++
public:
property int ScanlineThickness {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


ScanTimeout Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeReaderHints..::..ScanTimeout Property
BarcodeReaderHints Class See Also Send Feedback
Gets or sets the amount of time (in Milliseconds) after which the scan process will time out. Default is zero which indicates an infinite time-out period.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public int ScanTimeout { get; set; }
Visual Basic
Public Property ScanTimeout As Integer
    Get
    Set
Visual C++
public:
property int ScanTimeout {
    int get ();
    void set (int value);
}

See Also

BarcodeReaderHints Class


BarcodeRotation Enumeration

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeRotation Enumeration
See Also Send Feedback
It specifies a barcode rotation.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
[FlagsAttribute]
public enum BarcodeRotation
Visual Basic
<FlagsAttribute> _
Public Enumeration BarcodeRotation
Visual C++
[FlagsAttribute]
public enum class BarcodeRotation

Members

Member name | Description
None |
Degrees90 |
Degrees180 |
Degrees270 |
All |

See Also

Neodynamic.SDK.BarcodeReader Namespace
Neodynamic Barcode Reader SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2011 Neodynamic - All rights reserved.


BarcodeScanResult Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult Class
Members See Also Send Feedback
It represents the scan result of a barcode symbol which was founded by the barcode reader.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class BarcodeScanResult
Visual Basic
Public Class BarcodeScanResult
Visual C++
public ref class BarcodeScanResult

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.BarcodeReader..::..BarcodeScanResult

See Also

BarcodeScanResult Members


BarcodeScanResult Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult Members
BarcodeScanResult Class Methods Properties See Also Send Feedback

The BarcodeScanResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(BarcodeScanResult) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | RawBytes | Gets the bytes decoded from the barcode symbol.
Public property | Symbology | Gets the name of the symbology of the barcode symbol.
Public property | Text | Gets the text decoded from the barcode symbol.

See Also

BarcodeScanResult Class


BarcodeScanResult Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult Methods
BarcodeScanResult Class See Also Send Feedback

The BarcodeScanResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(BarcodeScanResult) |
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarcodeScanResult Class


Equals Method

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..Equals Method
BarcodeScanResult Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(BarcodeScanResult) |

See Also

BarcodeScanResult Class
BarcodeScanResult Members


Equals Method (Object)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..Equals Method (Object)
BarcodeScanResult Class See Also Send Feedback

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

See Also

BarcodeScanResult Class
Equals Overload


Equals Method (BarcodeScanResult)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..Equals Method (BarcodeScanResult)
BarcodeScanResult Class See Also Send Feedback

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public bool Equals(
    BarcodeScanResult barcodeScanResult
)
Visual Basic
Public Function Equals ( _
    barcodeScanResult As BarcodeScanResult _
) As Boolean
Visual C++
public:
bool Equals(
    BarcodeScanResult^ barcodeScanResult
)

Parameters

barcodeScanResult
Type: Neodynamic.SDK.BarcodeReader..::..BarcodeScanResult

See Also

BarcodeScanResult Class
Equals Overload


GetHashCode Method

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..GetHashCode Method
BarcodeScanResult Class See Also Send Feedback

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

See Also

BarcodeScanResult Class


BarcodeScanResult Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult Properties
BarcodeScanResult Class See Also Send Feedback

The BarcodeScanResult type exposes the following members.

Properties

 | Name | Description
Public property | RawBytes | Gets the bytes decoded from the barcode symbol.
Public property | Symbology | Gets the name of the symbology of the barcode symbol.
Public property | Text | Gets the text decoded from the barcode symbol.

See Also

BarcodeScanResult Class


RawBytes Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..RawBytes Property
BarcodeScanResult Class See Also Send Feedback
Gets the bytes decoded from the barcode symbol.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public byte[] RawBytes { get; }
Visual Basic
Public ReadOnly Property RawBytes As Byte()
    Get
Visual C++
public:
property array<unsigned char>^ RawBytes {
    array<unsigned char>^ get ();
}

See Also

BarcodeScanResult Class


Symbology Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..Symbology Property
BarcodeScanResult Class See Also Send Feedback
Gets the name of the symbology of the barcode symbol.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public Symbology Symbology { get; }
Visual Basic
Public ReadOnly Property Symbology As Symbology
    Get
Visual C++
public:
property Symbology Symbology {
    Symbology get ();
}

See Also

BarcodeScanResult Class


Text Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
BarcodeScanResult..::..Text Property
BarcodeScanResult Class See Also Send Feedback
Gets the text decoded from the barcode symbol.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public string Text { get; }
Visual Basic
Public ReadOnly Property Text As String
    Get
Visual C++
public:
property String^ Text {
    String^ get ();
}

See Also

BarcodeScanResult Class


ScanDirection Enumeration

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanDirection Enumeration
See Also Send Feedback
It specifies a scan direction.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public enum ScanDirection
Visual Basic
Public Enumeration ScanDirection
Visual C++
public enum class ScanDirection

Members

Member name | Description
Downwards |
MiddleOutwards |
Upwards |

See Also

Neodynamic.SDK.BarcodeReader Namespace
Neodynamic Barcode Reader SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2011 Neodynamic - All rights reserved.


ScanRegion Class

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Class
Members See Also Send Feedback
It represents a scan region of the target document or image.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public class ScanRegion
Visual Basic
Public Class ScanRegion
Visual C++
public ref class ScanRegion

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.BarcodeReader..::..ScanRegion

See Also

ScanRegion Members


ScanRegion Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Members
ScanRegion Class Constructors Methods Fields Properties See Also Send Feedback

The ScanRegion type exposes the following members.

Constructors

 | Name | Description
Public method | ScanRegion()()()() | Initializes a new instance of the ScanRegion class.
Public method | ScanRegion(Rectangle) | Initializes a new instance of the ScanRegion class with the specified rectangle.
Public method | ScanRegion(ScanRegionPercentage) | Initializes a new instance of the ScanRegion class with the specified percentage-based region data.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Empty | It represents an empty scan region.

Properties

 | Name | Description
Public property | RegionPercentage | Gets or sets a percentage-based scan region.
Public property | RegionRect | Gets or sets a fixed rectangular scan region. It must specified in Pixel units.

See Also

ScanRegion Class


ScanRegion Constructor

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Constructor
ScanRegion Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScanRegion()()()() | Initializes a new instance of the ScanRegion class.
Public method | ScanRegion(Rectangle) | Initializes a new instance of the ScanRegion class with the specified rectangle.
Public method | ScanRegion(ScanRegionPercentage) | Initializes a new instance of the ScanRegion class with the specified percentage-based region data.

See Also

ScanRegion Class
ScanRegion Members


ScanRegion Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Constructor
ScanRegion Class See Also Send Feedback
Initializes a new instance of the ScanRegion class.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanRegion()
Visual Basic
Public Sub New
Visual C++
public:
ScanRegion()

See Also

ScanRegion Class
ScanRegion Overload


ScanRegion Constructor (Rectangle)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Constructor (Rectangle)
ScanRegion Class See Also Send Feedback
Initializes a new instance of the ScanRegion class with the specified rectangle.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanRegion(
    Rectangle rect
)
Visual Basic
Public Sub New ( _
    rect As Rectangle _
)
Visual C++
public:
ScanRegion(
    Rectangle rect
)

Parameters

rect
Type: System.Drawing..::..Rectangle
The rectangle containing information about the location and size of the scan region.

See Also

ScanRegion Class
ScanRegion Overload


ScanRegion Constructor (ScanRegionPercentage)

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Constructor (ScanRegionPercentage)
ScanRegion Class See Also Send Feedback
Initializes a new instance of the ScanRegion class with the specified percentage-based region data.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanRegion(
    ScanRegionPercentage regionPercentage
)
Visual Basic
Public Sub New ( _
    regionPercentage As ScanRegionPercentage _
)
Visual C++
public:
ScanRegion(
    ScanRegionPercentage regionPercentage
)

Parameters

regionPercentage
Type: Neodynamic.SDK.BarcodeReader..::..ScanRegionPercentage
The percentage-based region data.

See Also

ScanRegion Class
ScanRegion Overload


ScanRegion Fields

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Fields
ScanRegion Class See Also Send Feedback

The ScanRegion type exposes the following members.

Fields

Name | Description
Empty | It represents an empty scan region.

See Also

ScanRegion Class


Empty Field

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion..::..Empty Field
ScanRegion Class See Also Send Feedback
It represents an empty scan region.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public static readonly ScanRegion Empty
Visual Basic
Public Shared ReadOnly Empty As ScanRegion
Visual C++
public:
static initonly ScanRegion^ Empty

See Also

ScanRegion Class


ScanRegion Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Methods
ScanRegion Class See Also Send Feedback

The ScanRegion type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScanRegion Class


ScanRegion Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion Properties
ScanRegion Class See Also Send Feedback

The ScanRegion type exposes the following members.

Properties

 | Name | Description
Public property | RegionPercentage | Gets or sets a percentage-based scan region.
Public property | RegionRect | Gets or sets a fixed rectangular scan region. It must specified in Pixel units.

See Also

ScanRegion Class


RegionPercentage Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion..::..RegionPercentage Property
ScanRegion Class See Also Send Feedback
Gets or sets a percentage-based scan region.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanRegionPercentage RegionPercentage { get; set; }
Visual Basic
Public Property RegionPercentage As ScanRegionPercentage
    Get
    Set
Visual C++
public:
property ScanRegionPercentage RegionPercentage {
    ScanRegionPercentage get ();
    void set (ScanRegionPercentage value);
}

See Also

ScanRegion Class


RegionRect Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegion..::..RegionRect Property
ScanRegion Class See Also Send Feedback
Gets or sets a fixed rectangular scan region. It must specified in Pixel units.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public Rectangle RegionRect { get; set; }
Visual Basic
Public Property RegionRect As Rectangle
    Get
    Set
Visual C++
public:
property Rectangle RegionRect {
    Rectangle get ();
    void set (Rectangle value);
}

See Also

ScanRegion Class


ScanRegionPercentage Structure

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Structure
Members See Also Send Feedback
It represents a scan region using percentage values for both horizontal and vertical directions.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public struct ScanRegionPercentage
Visual Basic
Public Structure ScanRegionPercentage
Visual C++
public value class ScanRegionPercentage

See Also

ScanRegionPercentage Members


ScanRegionPercentage Members

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Members
ScanRegionPercentage Structure Constructors Methods Fields Properties See Also Send Feedback

The ScanRegionPercentage type exposes the following members.

Constructors

 | Name | Description
Public method | ScanRegionPercentage | Initializes a new instance of the ScanRegionPercentage class with the specified sizes.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

Name | Description
Empty | It represents an empty percentage-based scan region.

Properties

 | Name | Description
Public property | EndX | Gets or sets the ending percentage value for the horizontal scan region. It must be greater than the StartX and less than or equal to 100.
Public property | EndY | Gets or sets the ending percentage value for the vertical scan region. It must be greater than the StartY and less than or equal to 100.
Public property | StartX | Gets or sets the starting percentage value for the horizontal scan region. It must be greater than or equal to zero.
Public property | StartY | Gets or sets the starting percentage value for the vertical scan region. It must be greater than or equal to zero.

See Also

ScanRegionPercentage Structure


ScanRegionPercentage Constructor

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Constructor
ScanRegionPercentage Structure See Also Send Feedback
Initializes a new instance of the ScanRegionPercentage class with the specified sizes.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public ScanRegionPercentage(
    double startX,
    double endX,
    double startY,
    double endY
)
Visual Basic
Public Sub New ( _
    startX As Double, _
    endX As Double, _
    startY As Double, _
    endY As Double _
)
Visual C++
public:
ScanRegionPercentage(
    double startX,
    double endX,
    double startY,
    double endY
)

Parameters

startX
Type: System..::..Double
The starting percentage value for the horizontal scan region. It must be greater than or equal to zero.
endX
Type: System..::..Double
The ending percentage value for the horizontal scan region. It must be greater than the startX and less than or equal to 100.
startY
Type: System..::..Double
The starting percentage value for the vertical scan region. It must be greater than or equal to zero.
endY
Type: System..::..Double
The ending percentage value for the vertical scan region. It must be greater than the startY and less than or equal to 100.

See Also

ScanRegionPercentage Structure


ScanRegionPercentage Fields

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Fields
ScanRegionPercentage Structure See Also Send Feedback

The ScanRegionPercentage type exposes the following members.

Fields

Name | Description
Empty | It represents an empty percentage-based scan region.

See Also

ScanRegionPercentage Structure


Empty Field

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage..::..Empty Field
ScanRegionPercentage Structure See Also Send Feedback
It represents an empty percentage-based scan region.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public static readonly ScanRegionPercentage Empty
Visual Basic
Public Shared ReadOnly Empty As ScanRegionPercentage
Visual C++
public:
static initonly ScanRegionPercentage Empty

See Also

ScanRegionPercentage Structure


ScanRegionPercentage Methods

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Methods
ScanRegionPercentage Structure See Also Send Feedback

The ScanRegionPercentage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ScanRegionPercentage Structure


ScanRegionPercentage Properties

[image] [image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage Properties
ScanRegionPercentage Structure See Also Send Feedback

The ScanRegionPercentage type exposes the following members.

Properties

 | Name | Description
Public property | EndX | Gets or sets the ending percentage value for the horizontal scan region. It must be greater than the StartX and less than or equal to 100.
Public property | EndY | Gets or sets the ending percentage value for the vertical scan region. It must be greater than the StartY and less than or equal to 100.
Public property | StartX | Gets or sets the starting percentage value for the horizontal scan region. It must be greater than or equal to zero.
Public property | StartY | Gets or sets the starting percentage value for the vertical scan region. It must be greater than or equal to zero.

See Also

ScanRegionPercentage Structure


EndX Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage..::..EndX Property
ScanRegionPercentage Structure See Also Send Feedback
Gets or sets the ending percentage value for the horizontal scan region. It must be greater than the StartX and less than or equal to 100.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public double EndX { get; set; }
Visual Basic
Public Property EndX As Double
    Get
    Set
Visual C++
public:
property double EndX {
    double get ();
    void set (double value);
}

See Also

ScanRegionPercentage Structure


EndY Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage..::..EndY Property
ScanRegionPercentage Structure See Also Send Feedback
Gets or sets the ending percentage value for the vertical scan region. It must be greater than the StartY and less than or equal to 100.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public double EndY { get; set; }
Visual Basic
Public Property EndY As Double
    Get
    Set
Visual C++
public:
property double EndY {
    double get ();
    void set (double value);
}

See Also

ScanRegionPercentage Structure


StartX Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage..::..StartX Property
ScanRegionPercentage Structure See Also Send Feedback
Gets or sets the starting percentage value for the horizontal scan region. It must be greater than or equal to zero.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public double StartX { get; set; }
Visual Basic
Public Property StartX As Double
    Get
    Set
Visual C++
public:
property double StartX {
    double get ();
    void set (double value);
}

See Also

ScanRegionPercentage Structure


StartY Property

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
ScanRegionPercentage..::..StartY Property
ScanRegionPercentage Structure See Also Send Feedback
Gets or sets the starting percentage value for the vertical scan region. It must be greater than or equal to zero.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public double StartY { get; set; }
Visual Basic
Public Property StartY As Double
    Get
    Set
Visual C++
public:
property double StartY {
    double get ();
    void set (double value);
}

See Also

ScanRegionPercentage Structure


Symbology Enumeration

[image]

Neodynamic Barcode Reader SDK for .NET Class Reference
Symbology Enumeration
See Also Send Feedback
It specifies the barcode symbologies supported by the reader.

Namespace: Neodynamic.SDK.BarcodeReader
Assembly: Neodynamic.SDK.BarcodeReader (in Neodynamic.SDK.BarcodeReader.dll) Version: 1.0.2000.0 (1.0.2000.0)

Syntax

C#
public enum Symbology
Visual Basic
Public Enumeration Symbology
Visual C++
public enum class Symbology

Members

Member name | Description
Code39 |
Code93 |
Code128 |
GS1_128 |
Ean13 |
Ean8 |
UpcA |
UpcE |
Code39TriOptic |
Codabar |
Industrial2of5 |
Interleaved2of5 |

See Also

Neodynamic.SDK.BarcodeReader Namespace
Neodynamic Barcode Reader SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2011 Neodynamic - All rights reserved.


Deployment

Neodynamic Barcode Reader SDK for .NET
Neodynamic Barcode Reader SDK for .NET - Deployment
Deploying an application that uses Neodynamic Barcode Reader SDK for .NET is not different than any other application that uses custom .NET DLL Assemblies. All functionality of Barcode Reader is contained in a unique assembly (Neodynamic.SDK.BarcodeReader.dll). For example, when deploying your ASP.NET Web application using Barcode Reader SDK, you must ensure that Neodynamic.SDK.BarcodeReader.dll assembly is located in the BIN folder of your application. For Windows Forms/Console applications, you must ensure that Neodynamic.SDK.BarcodeReader.dll assembly is located in the same folder of your application.
The Neodynamic.SDK.BarcodeReader.dll assembly for deploying is located in the Barcode Reader installation folder under Redistributable folder.

Send comments on this topic. Visit Neodynamic's website.

Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.


Technical Support

Neodynamic Barcode Reader SDK for .NET
Neodynamic Technical Support
When you purchase a licensed version of Neodynamic Barcode Reader SDK for .NET you get access to FREE technical support.
Technical Support can be reached by email at support@neodynamic.com.

Before contacting technical support we recommend:
  • Read the product documentation.
  • Read FAQ at Neodynamic Website.
For more information about technical support visit www.neodynamic.com/support.

Visit Neodynamic's website.
Neodynamic Barcode Reader SDK for .NET Documentation
Copyright © 2003 - 2011 Neodynamic - All rights reserved.