About Neodynamic ThermalLabel SDK for .NET

Neodynamic ThermalLabel SDK for .NET
About Neodynamic ThermalLabel SDK for .NET
Neodynamic ThermalLabel SDK for .NET is a lightweight class library (DLL) that lets you to design barcode labels and print them to Zebra Thermal Printers(*) by writing just pure .NET code in VB.NET or C#.

ThermalLabel SDK can be used for designing and printing from simple to complex labels layout supporting Texts, Barcodes, Graphics and Images, RFID Tags (**), and Shapes like circles, ellipses, rectangles, and lines.

ThermalLabel SDK also provides you a Visual Label Designer component (called ThermalLabelEditor) which you can incorporate into your own Windows .NET apps! With this WYSIWYG component, your end-users will be able to visually design barcode labels within your own apps.

In addition, while designing your labels; you can easily preview it as raster images (BMP, PNG, GIF, JPEG or TIFF) or as Adobe PDF documents. This allows you to work on your .NET developments without the need of having a physical thermal printer for testing.

ThermalLabel SDK supports Buffering, Caching, Data Binding as well as XML Templates.
(*) ThermalLabel SDK generates native printer commands in ZPL II® or EPL2®.

(**) RFID Tags are only available for ZPL-based printers.

Main Features
  • Thermal Label Items

    • Text items support including multi-line, content alignment, sizing, Unicode, RTL (Hebrew, Arabic, etc.), Custom and installed Windows TTF files, White Text On Black, rotation, horizontal alignment, counters, and text masking.
    • Barcode items support most popular Linear (1D), Postal & 2D Standards/Symbologies including Code 39, Code 128, GS1-128, GS1 DataBar (RSS-14), EAN 13 & UPC A, Postal (USPS, British Royal Mail, Australia Post, DHL, etc.), Data Matrix, QR Code, PDF 417, UPS MaxiCode, Micro QR Code, ALL EAN/UPC Composite Barcodes (CC-A, CC-B & CC-C), 2D Chinese Han Xin Code and many more.
    • Graphic, Image and Picture items support including images formats like GIF, JPG/JPEG, BMP, and PNG; monochrome conversion features like Threshold and Floyd-Steinberg algorithms and reversing; sources image like files, base64 as well as binary content.
    • RFID Tag Item (only for ZPL-based printers)
    • Shape items support including lines (horizontal, vertical, and diagonals), rectangles with rounded corners, circles and ellipses.

  • WYSIWYG Thermal Label Editor component can be embedded into your own Windows .NET apps to allow your end-users to visually design barcode labels.
  • Support for all Zebra Thermal Printers with ZPL® or ZPL II® (Zebra Programming Language) and EPL2 (Eltron Programming Language).
  • An unified object model which will allows you to create ONE label and print it to either ZPL or EPL printers getting the SAME output printing!
  • Print Orientation feature. You can print ThermalLabel objects in Portrait and Landscape orientation with 90, 180 & 270 degrees rotation
  • Export labels to raster images formats like PNG, BMP, GIF, JPEG and TIFF (including multipage TIFF)
  • Export labels to Adobe PDF without the need of any third-party software
  • Caching feature to ThermalLabel items to improve printing performance
  • Written entirely in managed C#.
  • Strong named assemblies for .NET Framework 3.5 or greater.
  • Lightweight assemblies for deployment.
  • XML Template support.
  • .NET Data Binding support.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


License Registration

Neodynamic ThermalLabel SDK for .NET
License Registration
When you buy a commercial version of ThermalLabel you are provided with license information to register your licensed copy of Neodynamic ThermalLabel SDK for .NET.

The registration process is very simple and can be accomplished in two ways:

  • Codeless License Setting
    Codeless License Setting involves adding the license info in the Application's Configuration file (*.config). The license info must be specified in the ThermalLabelSDK60LicenseOwner and ThermalLabelSDK60LicenseKey entries in the appSettings section of *.config file. Example:
    <configuration>
  <appSettings>
    <add key="ThermalLabelSDK60LicenseOwner" value="LICENSE-OWNER-FOR-SDK"/>
    <add key="ThermalLabelSDK60LicenseKey" value="LICENSE-KEY-FOR-SDK"/>
  </appSettings>
  ...
</configuration>

    For registering the ThermalLabel Editor component, the license info must be specified in the ThermalLabelEditor60LicenseOwner and ThermalLabelEditor60LicenseKey entries in the appSettings section of *.config file. Example:
    <configuration>
  <appSettings>
    <add key="ThermalLabelEditor60LicenseOwner" value="LICENSE-OWNER-FOR-EDITOR"/>
    <add key="ThermalLabelEditor60LicenseKey" value="LICENSE-KEY-FOR-EDITOR"/>
  </appSettings>
  ...
</configuration>

  • Using License Properties in code
    In the class you're using ThermalLabel, set the LicenseOwner and LicenseKey static (shared in VB) properties with the license info you've received.
    IMPORTANT
    Please, keep in mind that the license info is case-sensitive!

    Visual Basic

    ' WINDOWS FORMS SAMPLE

Imports Neodynamic.SDK.Printing
Imports Neodynamic.Windows.Forms.ThermalLabelEditor

Public Class Form1

    Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load

        ThermalLabel.LicenseOwner = "LICENSE-OWNER-FOR-SDK"
        ThermalLabel.LicenseKey = "LICENSE-KEY-FOR-SDK"

        ThermalLabelEditor.LicenseOwner = "LICENSE-OWNER-FOR-EDITOR"
        ThermalLabelEditor.LicenseKey = "LICENSE-KEY-FOR-EDITOR"
    End Sub

End Class

    C#

    // WINDOWS FORMS SAMPLE

using Neodynamic.SDK.Printing;
using Neodynamic.Windows.Forms.ThermalLabelEditor;

public partial class Form1 : Form
{
    private void Form1_Load(object sender, EventArgs e)
    {
        ThermalLabel.LicenseOwner = "LICENSE-OWNER-FOR-SDK";
        ThermalLabel.LicenseKey = "LICENSE-KEY-FOR-SDK";

        ThermalLabelEditor.LicenseOwner = "LICENSE-OWNER-FOR-EDITOR";
        ThermalLabelEditor.LicenseKey = "LICENSE-KEY-FOR-EDITOR";
    }
}

  • WebPrintJob in ASP.NET scenarios
    If you're using ThermalLabel in ASP.NET by creating WebPrintJob objects, then license info must be set to the LicenseOwner and LicenseKey properties of WebPrintJob class.
    IMPORTANT
    Please, keep in mind that the license info is case-sensitive!

    Visual Basic

    Protected Sub Page_Init(sender As Object, e As System.EventArgs) Handles Me.Init

        'is this a request for a WebPrintJob handler?
        If Not Request("webPrintJob") Is Nothing Then
            'Create a WebPrintJob obj
            Dim webPj As New WebPrintJob()

            'Set License Info
            webPj.LicenseOwner = "LICENSE-OWNER-FOR-SDK"
            webPj.LicenseKey = "LICENSE-KEY-FOR-SDK"

            'set a ThermalLabel obj
            webPj.ThermalLabel = GenerateBasicThermalLabel()

            '...

        End If

End Sub

    C#

    protected void Page_Init(object sender, EventArgs e)
{
    //is this a request for a WebPrintJob handler?
    if (Request["webPrintJob"] != null)
    {
        //Create a WebPrintJob obj
        WebPrintJob webPj = new WebPrintJob();

        //Set License Info
        webPj.LicenseOwner = "LICENSE-OWNER-FOR-SDK";
        webPj.LicenseKey = "LICENSE-KEY-FOR-SDK";

        //set a ThermalLabel obj
        webPj.ThermalLabel = GenerateBasicThermalLabel();

        //...

    }
}

After you set these properties the TRIAL legend should disappear from the generated labels and images.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Trial Version

Neodynamic ThermalLabel SDK for .NET
Trial Version
The Trial Version of Neodynamic ThermalLabel SDK for .NET is fully functional and has no expiry date. The only limitation it has is that a TRIAL legend will appear on the printed thermal label.

When you buy a licensed version of ThermalLabel you will receive license information to register your copy of ThermalLabel SDK for .NET. For more information about the registration process view License Registration topic.

Want to try ThermalLabel SDK without TRIAL watermark?
Neodynamic offers you a 30-day Evaluation License Key which will allow you to test the ThermalLabel SDK in fully-functional mode for 30 days! When the 30-day Evaluation License Key expires, the ThermalLabel SDK behavior backs to Trial mode. Request your 30-day Evaluation License Key

Distribution restrictions

If you are using a Trial Version, you should not distribute any of the files provided with it.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


System Requirements

Neodynamic ThermalLabel SDK for .NET
System Requirements
For developing applications with Neodynamic ThermalLabel SDK for .NET and ThermalLabel Editor, you must have the following system and software specifications:

Microsoft .NET Framework

Microsoft .NET Framework 3.5 (Client Profile) or greater with its latest service pack.
Thermal Printer

- All Zebra Thermal Printers supporting ZPL® or ZPL II® (Zebra Programming Language) with latest Firmware
- Any other Thermal Printers brands with ZPL emulation mode
- All Zebra Thermal Printers supporting EPL2® (Eltron Programming Language) with latest Firmware
- Any other Thermal Printers brands with EPL emulation mode

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Installation and Configuration

Neodynamic ThermalLabel SDK for .NET
Installation and Configuration
Installing Neodynamic ThermalLabel SDK for .NET is very simple.
  • Download the latest version from Neodynamic's website.
  • Unzip the downloaded file onto your hard drive and launch the installation program double-clicking on it.
  • Follow the on-screen instructions.

Development Tools Configuration
Learn about how to configure ThermalLabel SDK for .NET with most popular .NET Development Tools.
  • How to configure ThermalLabel SDK for .NET in Microsoft Visual Studio and Express Editions...

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Visual Studio .NET Configuration

Neodynamic ThermalLabel SDK for .NET
Microsoft Visual Studio .NET and Express Editions Configuration

To use the ThermalLabel SDK in Visual Studio
  • Launch Visual Studio or any Visual Studio Express Edition.
  • Create a new .NET project. For example, a Windows Forms Application project.
  • Add a reference to Neodynamic.SDK.ThermalLabel.dll assembly (Project > Add Reference...).
  • Select .NET tab. You should find the Neodynamic.SDK.ThermalLabel.dll assembly listed.
    If you cannot find it...

    • Select Browse tab, and navigate to the folder you installed it to.
    • Browse to the Redistributable folder.
    • Select Neodynamic.SDK.ThermalLabel.dll from that dialog.
    • Click on OK button.
    Double-click on ThermalLabel assembly to select it, then click on OK.
  • The ThermalLabel assembly should now appear referenced to your project. Now you can use ThermalLabel classes in your code.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Programming Object Model

Neodynamic ThermalLabel SDK for .NET
Programming Object Model
ThermalLabel SDK features the Programming Object Model which can be summarized in the following diagram:
ThermalLabel SDK Programming Object Model
  • ThermalLabel
    It is the label's rectangular area intended for placing items (Texts, Barcodes, Images, Graphics, Pictures and Shapes). ThermalLabel plays a key role because it is used for designing the thermal labels which will be printed or exported/saved to different document and image formats. ThermalLabel objects are sent to the Thermal Printer by using another object called PrintJob.

    • Items
      They are simple objects which are assembled together to design and create the output thermal label. All items are printed in the order that each of them has in the stack of items and in the location specified for each item through the X and Y properties. There are four main kinds of items: TextItem, BarcodeItem, ImageItem, RFIDTagItem, and ShapeItem (Lines, Rectangles, Circles, etc.)
  • PrintJob
    It is the object that specifies information about how a ThermalLabel object is printed, including the printer device settings and communication, label orientation, number of copies, etc. It also is used for exporting or saving a ThermalLabel object to raster image formats or Adobe PDF documents. Learn more about PrintJob...
  • PrintUtils
    It is used for printing jobs that are not directly related to label printing. You can use it to perform other tasks related to Thermal Printers like printer's devices settings. Learn more about PrintUtils...
The Programming Object Model is fairly self-explanatory and full documentation of all of the methods and properties of each main objects are provided in the Class Reference section of this help.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


ThermalLabel

Neodynamic ThermalLabel SDK for .NET
ThermalLabel Overview

In this section

  • The ThermalLabel object
  • Designing a Basic Label

The ThermalLabel object
The ThermalLabel object represents the label's rectangular area intended for placing items like texts, barcodes, images, graphics, pictures, and shapes. To design a label, the first thing to set up is the unit of measurement (inch, cm, mm, dots, point, or pica) through the UnitType property which will be used for sizing as well as items location purposes. After unit of measurement is set up, then you simply specify the label's size (Width & Height properties) and the gap separation (GapLength property) between labels on the same roll media.

Single Label size attributes

A roll media featuring single labels.

ThermalLabel object also supports multi-column label rolls i.e. the roll media contains more than one label per "row". In this case, the ThermalLabel object must be configured with the label size (Width & Height properties) of each individual label, the number of labels per row on the roll (LabelsPerRow property), the horizontal gap separation between labels (LabelsHorizontalGapLength property) and the vertical gap separation (GapLength property) between labels.

Multi-column Label size attributes

A roll media featuring 2 labels per row i.e. a multi-column label layout.

You can create as many items as you want to print on the label. Items are simple objects which are assembled together to design and create the output thermal label. All items are printed in the order that each of them has in the stack of items (which is the Items property of the ThemalLabel object) and in the location specified for each item through their X and Y properties. There are four main kinds of items which can be placed on the label: TextItem, BarcodeItem, ImageItem, RFIDTagItem, and ShapeItem (Lines, Rectangles, Circles, etc.)

Finaly, the PrintJob is the object that specifies information about how the ThermalLabel object is printed, including the printer device settings and communication, label orientation, number of copies, etc. It also is used for exporting or saving a ThermalLabel object to raster image formats or Adobe PDF documents which is very useful when you are in development/test phase or have no access to a physical thermal printer.

Designing a Basic Label
In this section you'll learn how to design a simple label with a text and a barcode items. In this sample, the physical label size is 4 inch wide and 3 inch high. On that label, we'll place a TextItem displaying "Thermal Label Test" string and a BarcodeItem encoding the "ABC 12345" string in Code 128 Symbology. The label to design will look like the following:

The following is the VB.NET and C# codes for generating that basic label. You should create a .NET project like a Windows Forms App and use the code below to print the label. You must have a Thermal Printer connected to your machine and a Windows Driver installed on your system or you can save the the label output to a raster image format or Adobe PDF. Notice that the printing process is launched by a PrintJob object.

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 2.5, 0.5, "Thermal Label Test")
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 2.5, 0.5, "Thermal Label Test");

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Fonts

Neodynamic ThermalLabel SDK for .NET
Fonts Overview
The Neodynamic.SDK.Printing.Font class is used with the Neodynamic.SDK.Printing.TextItem and Neodynamic.SDK.Printing.BarcodeItem objects and it determines how the characters' glyph looks like.

The Font class supports:

  • Native Printer Fonts (NPF)
  • ZPL Font 0
  • Installed Windows TTF Fonts
  • Custom TTF Font files i.e. Non-installed fonts
  • TTF Optimization on ZPL Printers

Native Printer Fonts (NPF)
The NPF is an abstraction on the complexity of dealing with different built-in printer fonts when printing simple text on labels while targeting both kinds of printers i.e. ZPL and EPL printers. The NPF provides you three fonts called NativePrinterFontA, NativePrinterFontB and NativePrinterFontS.

Basically, each of these fonts are provided by our SDK as TrueType (*.ttf) font files which need to be installed on the client machine where the SDK is being used. The TrueType fonts are used by our SDK when exporting labels to PDF documents or image files and by the ThermalLabelEditor component for displaying such font on items using the NPF. For printing process, the NPF TrueType files are not used as our SDK uses the built-in ZPL/EPL fonts that are internally associated to each NPF.

TIP: NPF has some limitations when comparing it to non-built in fonts, but you should use NPF whenever possible to boost the printing performance. If your text does not require any special formatting, then use a NPF for printing it.

The following table provides some info about the features that each of the NPF does support.

FEATURE | NativePrinterFontA | NativePrinterFontB | NativePrinterFontS
Font Type | Monospaced | - Scalable for ZPL - Monospaced for EPL | Monospaced
Fixed Sizes (in pts) – Measure of the upper-case chars height | 5pt, 10pt, 15pt, 20pt, and 25pt | 7pt, 14pt, 21pt, 28pt, and 35pt | 3pt (Only this size is allowed. Intended to be used with very small text)
Font Style | Normal | Bold | Normal
Characters Set | - All ASCII chars from 32 to 124 excluding the following chars: 92, 94 & 123 | - All ASCII chars from 32 to 124 excluding the following chars: 92, 94 & 123 | - ASCII chars from 65 to 90 (upper-case letters) and from 48 to 57 (digits)
Unicode Support | NO | NO | NO
Text Stretching | NO | NO | NO
Rotation | 0, 90, 180 & 270 degrees only | 0, 90, 180 & 270 degrees only | 0, 90, 180 & 270 degrees only
Rounded Borders | NO | NO | NO
Multi-line Text | NO | NO | NO
TrueType file matching | NativePrinterFontA.ttf glyphs are almost a perfect match to both ZPL/EPL font glyphs. | NativePrinterFontB.ttf glyphs are almost a perfect match to the ZPL font glyphs. For EPL printers, the font is very different and you should try it before going forward. | NativePrinterFontS.ttf glyphs are almost a perfect match to both ZPL/EPL font glyphs.
Char Glyph Appearance |  |  |

Screen/File Rendering vs. Printing Output

When using any of the NPF, you should be aware of the following regarding what you will get on screen or file and what you will get when printing:
  • NativePrinterFontA
    • The NativePrinterFontA.ttf file features almost identical characters’ glyph that matches the same built-in fonts of ZPL and EPL. This TrueType font will be used when you export/save a label to PDF documents or Image files.
    • When printing, both built-in fonts of ZPL and EPL will produce almost identical outputs if using 203 dpi printers. For EPL, the outputs at 300 or 600 dpi will be identical to the output at 203 dpi. But for ZPL, the outputs at 300 or 600 dpi will differ a bit from the output you get at 203 dpi. For ZPL printers at 300 or 600 dpi, you will notice that the font used in those printers features characters glyph which look a bit thinner (in their strokes) than the one used at 203 dpi. However, in ALL cases, the height and width of the characters will be very close.
  • NativePrinterFontB
    • The NativePrinterFontB.ttf file features almost identical characters’ glyph that matches the same built-in font of ZPL printers only. The built-in font used in EPL printers, features characters glyph that are very different from the one we did choose for ZPL. This TrueType font will be used when you export/save a label to PDF documents or Image files.
    • This NPF can be considered the “Bold” version. Problem is that in ZPL the font we did choose is “Scalable” while the one used for EPL is “Bitmapped”. When printing, the outputs produced by both built-in fonts of ZPL and EPL are VERY different because their nature i.e. Scalable vs. Bitmapped. What we’ve tried here was to match both fonts in their characters height. So, if you want or need to use a “bold” native printer font, then this is the correct one. If you are targeting just ZPL printers, then you will not have any problems at all. However, if you need to target EPL or both (EPL & ZPL), then we encourage you to make some test before going forward with this NPF. Remember that on screen or file rendering, the NativePrinterFontB.ttf TrueType file matches the ZPL built-in font NOT the EPL one.
  • NativePrinterFontS
    • The NativePrinterFontS.ttf file features almost identical characters’ glyph that matches the same built-in fonts of ZPL and EPL. This TrueType font will be used when you export/save a label to PDF documents or Image files.
    • When printing, both built-in fonts of ZPL and EPL will produce almost identical outputs.
ZPL Font 0
"ZPL Font 0" is a font that is shipped with any ZPL printer. It's a scalable type font that will improve printing performance. It also support multiline text as well as alignments. NOTE: the only limitation is that text rotation is not supported i.e. if rotated, it'll rendered as graphics commands.
This font is provided by our SDK as a TrueType (*.ttf) font file which need to be installed on the client machine where the SDK is being used. The TrueType font is used by our SDK when exporting labels to PDF documents or image files and by the ThermalLabelEditor component for displaying such font on items using the ZPL Font 0. However, for printing process, the TrueType file is not used as our SDK uses the built-in ZPL font.

In EPL printers, the text will be rendered as graphics commands.

Installed Windows TTF Fonts
Any TrueType font installed in the client can be used with the Font class on Neodynamic.SDK.Printing.TextItem and Neodynamic.SDK.Printing.BarcodeItem objects. With these kinds of fonts you can use all the rich text features available like full Unicode support, RTL languages, text stretching, text alignments, etc.

Custom TTF Font files i.e. Non-installed fonts
The custom TTF approach has the same text features as the Installed Windows TTF fonts but do not require you install the TTF on the client system. Instead, you can deploy the TTF file with your application and use the font’s path file. It is useful if you want to use dingbats fonts which you do not want to install on the client machine before using them.

TTF Optimization on ZPL Printers
When using a TTF font, at rendering time, the text items using them will be converted to ZPL or EPL graphics commands. If you're targeting ZPL printers, then you can upload those TTF files right to the printer's internal storage by assigning to them a name or identificator. ZPL printers allow you to set up font names up to 8 alphanumeric chars. By using our Neodynamic.SDK.Printing.PrintUtils class to upload any TTF file to the printer right from your own application. Look at the Visual Label Editor sample app which uses this feature.
The basic steps for using this feature are the following:
  1. Upload the TTF file to the printer and set a short name for it
  2. Set it to the Font property of TextItem objects. Then set the Font.Name subproperty to the TTF font and set the Font.NameAtPrinterStorage subproperty to the short name

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Text Items

Neodynamic ThermalLabel SDK for .NET
Text Items Overview

In this section

  • The TextItem object
  • Working with Fonts
  • Unicode and RTL text support
  • Text Alignment and Sizing
  • Borders and White Text On Black
  • Real Time Clock (RTC) support
  • TextItem samples

The TextItem object
A TextItem – represented by Neodynamic.SDK.Printing.TextItem class – simply wraps a text string that must be drawn/printed on the label. TextItem objects are created by specifying some basic properties such as X, Y, Width, Height, Text, Font, etc.

TextItem objects feature the following capabilities: Data Binding, Masking and Counters, text Alignment and multi-line; Rotation, Text Sizing, Unicode support, RTL (Hebrew, Arabic, etc.), Custom and installed Windows TTF files, White text on black, and rich Border settings.

After creating a TextItem object, it will printed on the label if you add it to the Items collection property of the ThermalLabel object.

Working with Fonts
In order to draw/print texts on a label you must specify Font settings on TextItem objects. The font to use with TextItem objects can be a Native Printer Font; any installed Windows Fonts on the client/target machine or a separated TTF font file which you can deploy with your application. The default font is NativePrinterFontA, 10pt. Please read more about Fonts...

Unicode and RTL text support
The TextItem object does support Unicode strings which means that you can set up the Text property of the TextItem object to any kind of characters (Note: to support Unicode characters, the Font you have set up for the TextItem must provide Unicode support too).

With TextItem objects you can also print text for RTL (Right to Left) languages like Arabic, Hebrew, etc. Again, it is important that the Font you set up for the TextItem object does support such language characters.

Text Alignment and Sizing
When you create a TextItem object, you are required to specify the area (X, Y, Width & Height) where the text must be allocated and printed. In that area, you can align the text to the left, right, center or justify it by setting up the TextAlignment property.

By default, the text is printed with the size specified in the Font property. However, there’re situations where you could require a text to fill its allocated area. For example, titles or legends that should be highlighted on the label like “IMPORTANT”, “NOTICE”, “WARNING”, “CAUTION”, “FRAGILE”, etc; are good candidates for this purpose. In order to make the text to fill the allocated area, you just need to set up the Sizing property to Stretch. When printing, the text will be scaled up and down to fullyfill the specified area.

Borders and White Text On Black
The TextItem object feature a rich Border settings allowing you to draw text inside a rectangular frame. The frame size is determined by the Width & Height properties of the TextItem and the stroke thickness is set up by using BorderThickness property. The frame can be set up so all corners be rounded or individually rounded i.e. maybe you want just the top corners be rounded and not the bottom ones. The corner roundness is set up by using CornerRadius property.

Another common design you found on thermal labels is known as White Text On Black. That’s a text which foreground is White printed over a Black area. To get the “White Text On Black” effect, you must set up the ForeColor property to White and the BackColor to Black. That’s it! This could be easily combined with the Stretch sizing feature if you need to highlight it on the label.

Real Time Clock (RTC) support
By using a special formats within text items, you can print time & date values from the printer's Real Time Clock when available. The following is the list of formats for RTC that you can embed into the Text property and their values at printing time.

{yy} Use it for 2-digit year number
{yyyy} Use it for 4-digit year number
{M} Use it for abbreviated month name
{m} Use it for month number
{d} Use it for day number

{H} Use it for the hour of the day (military), 00 to 23
{h} Use it for the hour of the day (civilian), 01 to 12
{p} Use it for AM/PM designation
{min} Use it for minutes
{sec} Use it for seconds

NOTES

RTC is Only supported for ZPL printers.
For EPL printers as wel as for PDF/Image outputs, date & time values are got from client OS when label is being generated.

TextItem samples
The following code creates a couple of TextItem objects using the Native Printer Fonts (NPF).

Label featuring Text Item objects using Native Printer Fonts

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'A sample text using NativePrinterFontA font
Dim txt1 As New TextItem(0.25, 0.25, 3.5, 0.5, "Sample of NPF A - 012345")
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt1.Font.Unit = FontUnit.Point
txt1.Font.Size = 10

'A sample text using NativePrinterFontB font
Dim txt2 As New TextItem(0.25, 0.75, 3.5, 0.5, "Sample of NPF B - 012345")
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontB
txt2.Font.Unit = FontUnit.Point
txt2.Font.Size = 14

'A sample text using NativePrinterFontB font
Dim txt3 As New TextItem(0.25, 1.5, 3.5, 0.25, "THIS IS A VERY SMALL TEXT USING NPF S")
txt3.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontS

'Add items to ThermalLabel object...
tLabel.Items.Add(txt1)
tLabel.Items.Add(txt2)
tLabel.Items.Add(txt3)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//A sample text using NativePrinterFontA font
TextItem txt1 = new TextItem(0.25, 0.25, 3.5, 0.5, "Sample of NPF A - 012345");
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt1.Font.Unit = FontUnit.Point;
txt1.Font.Size = 10;

//A sample text using NativePrinterFontB font
TextItem txt2 = new TextItem(0.25, 0.75, 3.5, 0.5, "Sample of NPF B - 012345");
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontB;
txt2.Font.Unit = FontUnit.Point;
txt2.Font.Size = 14;

//A sample text using NativePrinterFontB font
TextItem txt3 = new TextItem(0.25, 1.5, 3.5, 0.25, "THIS IS A VERY SMALL TEXT USING NPF S");
txt3.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontS;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt1);
tLabel.Items.Add(txt2);
tLabel.Items.Add(txt3);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

The following code creates a couple of TextItem objects with most of the features briefly described above.

Label featuring Text Item objects

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Hello World in Chinese
Dim txt1 As New TextItem(0.25, 0.25, 1, 0.5, "世界您好")
txt1.Font.Name = "Arial"
txt1.Font.Unit = FontUnit.Point
txt1.Font.Size = 18

'Hello World in Arabic (RTL)
Dim txt2 As New TextItem(2, 0.25, 1.5, 0.5, "مرحبا العالمي")
txt2.Font.Name = "Arial"
txt2.Font.Unit = FontUnit.Point
txt2.Font.Size = 18
txt2.RightToLeft = True

'Stretched text with White On Black effect
Dim txt3 As New TextItem(0.25, 0.75, 3, 0.75, "WHITE TEXT")
txt3.Font.Name = "Arial"
txt3.Sizing = TextSizing.Stretch
txt3.BackColor = Neodynamic.SDK.Printing.Color.Black
txt3.ForeColor = Neodynamic.SDK.Printing.Color.White
txt3.TextPadding = New FrameThickness(0.2)

'Multiline text with center alignment
Dim txt4 As New TextItem(0.25, 2, 3, 0.75, "Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.")
txt4.Font.Name = "Arial"
txt4.Font.Unit = FontUnit.Point
txt4.Font.Size = 8
txt4.Font.Bold = True
txt4.TextAlignment = TextAlignment.Center
txt4.BorderThickness = New FrameThickness(0.02)

'Add items to ThermalLabel object...
tLabel.Items.Add(txt1)
tLabel.Items.Add(txt2)
tLabel.Items.Add(txt3)
tLabel.Items.Add(txt4)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Hello World in Chinese
TextItem txt1 = new TextItem(0.25, 0.25, 1, 0.5, "世界您好");
txt1.Font.Name = "Arial";
txt1.Font.Unit = FontUnit.Point;
txt1.Font.Size = 18;

//Hello World in Arabic (RTL)
TextItem txt2 = new TextItem(2, 0.25, 1.5, 0.5, "مرحبا العالمي");
txt2.Font.Name = "Arial";
txt2.Font.Unit = FontUnit.Point;
txt2.Font.Size = 18;
txt2.RightToLeft = true;

//Stretched text with White On Black effect
TextItem txt3 = new TextItem(0.25, 0.75, 3, 0.75, "WHITE TEXT");
txt3.Font.Name = "Arial";
txt3.Sizing = TextSizing.Stretch;
txt3.BackColor = Neodynamic.SDK.Printing.Color.Black;
txt3.ForeColor = Neodynamic.SDK.Printing.Color.White;
txt3.TextPadding = new FrameThickness(0.2);

//Multiline text with center alignment
TextItem txt4 = new TextItem(0.25, 2, 3, 0.75, "Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.");
txt4.Font.Name = "Arial";
txt4.Font.Unit = FontUnit.Point;
txt4.Font.Size = 8;
txt4.Font.Bold = true;
txt4.TextAlignment = TextAlignment.Center;
txt4.BorderThickness = new FrameThickness(0.02);

//Add items to ThermalLabel object...
tLabel.Items.Add(txt1);
tLabel.Items.Add(txt2);
tLabel.Items.Add(txt3);
tLabel.Items.Add(txt4);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

The following sample uses a custom *.ttf font file. The following code uses a "dingbat" type font called RecycleIt which features a lot of recycling symbols.

NOTE
The RecycleIt font is used here for demo purpose only. Please read the license agreement of the fonts you will use in your apps before using them.
Label featuring Text Item objects using custom font files

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'A sample text using NativePrinterFontA font
Dim txt1 As New TextItem(0.25, 0.25, 3.5, 0.5, "Using Custom Font Files")
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt1.Font.Unit = FontUnit.Point
txt1.Font.Size = 10

'A sample text using a custom ttf font file
Dim txt2 As New TextItem(0.25, 0.75, 3.5, 0.5, "M 8 S Z I")
txt2.Font.CustomFontFile = "C:\Temp\CustomFonts\RecycleIt.ttf"
txt2.Font.CustomFontFileFamilyName = "RecycleIt"
txt2.Font.Unit = FontUnit.Point
txt2.Font.Size = 24

'Add items to ThermalLabel object...
tLabel.Items.Add(txt1)
tLabel.Items.Add(txt2)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//A sample text using NativePrinterFontA font
TextItem txt1 = new TextItem(0.25, 0.25, 3.5, 0.5, "Using Custom Font Files");
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt1.Font.Unit = FontUnit.Point;
txt1.Font.Size = 10;

//A sample text using a custom ttf font file
TextItem txt2 = new TextItem(0.25, 0.75, 3.5, 0.5, "M 8 S Z I");
txt2.Font.CustomFontFile = @"C:\Temp\CustomFonts\RecycleIt.ttf";
txt2.Font.CustomFontFileFamilyName = "RecycleIt";
txt2.Font.Unit = FontUnit.Point;
txt2.Font.Size = 24;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt1);
tLabel.Items.Add(txt2);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Barcode Items

Neodynamic ThermalLabel SDK for .NET
Barcode Items Overview

In this section

  • The BarcodeItem object
  • Working with Barcode Symbologies
  • Text on barcodes
  • Barcode Sizing
  • Barcode Rotation
  • BarcodeItem samples

The BarcodeItem object
A BarcodeItem – represented by Neodynamic.SDK.Printing.BarcodeItem class – lets you to generate bar codes (Linear 1D, 2D and Postal standards) that must be drawn/printed on the label. BarcodeItem objects are created by specifying some basic properties such as X, Y, Width, Height, Barcode Symbology, Value to encode, etc.

BarcodeItem objects feature the following capabilities: Data Binding, Masking and Counters, text Alignment, Rotation, barcode Sizing, rich Border settings, etc.

After creating a BarcodeItem object, it will printed on the label if you add it to the Items collection property of the ThermalLabel object.

Working with Barcode Symbologies
In order to draw/print barcodes on a label you must specify the Symbology property to the barcode standard you want to print and the Code property to the string you want to encode into the barcode.

BarcodeItem supports most popular Linear (1D), Postal, and 2D Symbologies/Standards including Code 39, Code 128, GS1-128, GS1 DataBar (RSS-14), EAN 13 & UPC, Postal (USPS, British Royal Mail, Australia Post, DHL, etc.), Data Matrix, QR Code, PDF 417, UPS MaxiCode, Micro QR Code, ALL EAN/UPC Composite Barcodes (CC-A, CC-B & CC-C) and many more barcode standards.
Each standard/symbology requires some settings like data formatting as sizing which are exclusive to it. You can learn more about each of them by referring to the Barcode Symbology Information Center available on this help document.

Text on barcodes
The BarcodeItem supports two kind of text to be placed along with the barcode bars:
  • Value to encode: The most important text you find along with the barcode is called the Human Readable Text. In the BarcodeItem you specify which value to encode by using the Code property. The string set up to that property will be printed on the barcode. However, there're some situations where you may want to use other string in a different format and the like. For those cases, you can set up the HumanReadableText property. If HumanReadableText property is not empty, then it will be printed on the barcode but the barcode will always encode the string you set up to the Code property!
  • Additional Text: In addition to print the text encoded into the barcode, you can provide other kind of texts for the barcode. This additional text is just informative i.e. it is not encoded into the barcode. You can specify it by using the Text property.
NOTE: 2D barcodes like Data Matrix, QR Code, PDF417, MaxiCode, etc; will not print the string you set up to the Code property. That's because these symbologies can encode non-printable characters. You can force some text to be printed along with these kind of barcodes by using either the HumandReadableText or Text properties.

Both kind of text do support alignment through the CodeAlignment and TextAlignment properties respectively.

Barcode Sizing
When you create a BarcodeItem object, you are required to specify the area (X, Y, Width & Height) where the barcode must be allocated and printed. You can size the barcode inside that area by using the following options:
  • General Size: The barcode size in general depends on the value to encode (the Code property), the symbology you are encoding (the Symbology property) and dimension-related properties like BarWidth, BarRatio, BarHeight, etc. You always should specify a size (Width & Height properties) large enough to fully contain the generated barcode otherwise if the size of the generated barcode is bigger than it, then the barcode will be cut of becoming unreadable after printing.
    You can also align the generated barcode inside the allocated area. This is configured by using the BarcodeAlignment property.
  • Fit To Size: If you want that the whole barcode (including the human readable text if any) fills the defined area, then you must set up the Sizing property to Fill option. Be careful when using this option because some barcodes can become unreadable if you force it to fill a size which is smaller than the size of the generated barcode as aforementioned stated in General Size.

Barcode Rotation
The BarcodeItem object does support rotation. The rotation can be done at any angle, in 90 degrees increments only, by specifying it to the RotationAngle property. The rotation angle range from 0 to 360 degrees measured clockwise from the x-axis.

BarcodeItem samples
The following code creates a couple of BarcodeItem objects with most of the features briefly described above.

Example #1: two linear Code 39 barcodes with borders and the human readable text with justify alignment. One of them is sizing to fill the specified area.

Label featuring Code 39 barcode Item objects

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a BarcodeItem object for encoding Code 39 symbology
Dim bc1 As New BarcodeItem(0.2, 0.2, 2, 1, BarcodeSymbology.Code39, "ABC123")
bc1.AddChecksum = False
bc1.CodeAlignment = BarcodeTextAlignment.BelowJustify
bc1.BarWidth = 0.01
bc1.BarHeight = 0.5
bc1.QuietZone = New FrameThickness(0)
bc1.BarcodeAlignment = BarcodeAlignment.MiddleCenter
bc1.BorderThickness = New FrameThickness(0.03)

'A second Code 39 barcode with sizing = Fill
Dim bc2 As BarcodeItem = CType(bc1.Clone(), BarcodeItem)
bc2.Y = 1.5
bc2.BarcodePadding = New FrameThickness(0.1)
bc2.Sizing = BarcodeSizing.Fill

'Add items to ThermalLabel object...
tLabel.Items.Add(bc1)
tLabel.Items.Add(bc2)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a BarcodeItem object for encoding Code 39 symbology
BarcodeItem bc1 = new BarcodeItem(0.2, 0.2, 2, 1, BarcodeSymbology.Code39, "ABC123");
bc1.AddChecksum = false;
bc1.CodeAlignment = BarcodeTextAlignment.BelowJustify;
bc1.BarWidth = 0.01;
bc1.BarHeight = 0.5;
bc1.QuietZone = new FrameThickness(0);
bc1.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
bc1.BorderThickness = new FrameThickness(0.03);

//A second Code 39 barcode with sizing = Fill
BarcodeItem bc2 = bc1.Clone() as BarcodeItem;
bc2.Y = 1.5;
bc2.BarcodePadding = new FrameThickness(0.1);
bc2.Sizing = BarcodeSizing.Fill;

//Add items to ThermalLabel object...
tLabel.Items.Add(bc1);
tLabel.Items.Add(bc2);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Example #2: an EAN-13 barcode with supplement/add-on code and a UPC-A barcode with rounded corners and rotated 90 degrees.

Label featuring EAN-13 and UPC-A barcode Item objects

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 5, 3)
tLabel.GapLength = 0.2

'Define a BarcodeItem object for encoding EAN-13 symbology
Dim bc1 As New BarcodeItem(0.2, 0.2, 2.5, 1.5, BarcodeSymbology.Ean13, "5012345678900")
bc1.BarWidth = 0.013
bc1.BarHeight = 1
bc1.EanUpcGuardBar = True
bc1.EanUpcGuardBarHeight = bc1.BarHeight + 5 * bc1.BarWidth
bc1.EanUpcSupplement = Supplement.Digits2
bc1.EanUpcSupplementCode = "74"
bc1.BarcodeAlignment = BarcodeAlignment.MiddleCenter
bc1.BorderThickness = New FrameThickness(0.03)
bc1.Font.Size = 5

'Define a BarcodeItem object for encoding UPC-A symbology
Dim bc2 As New BarcodeItem(3, 0.2, 2.5, 1.5, BarcodeSymbology.UpcA, "012345678905")
bc2.BarWidth = 0.013
bc2.BarHeight = 1
bc2.EanUpcGuardBar = True
bc2.EanUpcGuardBarHeight = bc1.BarHeight + 5 * bc1.BarWidth
bc2.BarcodeAlignment = BarcodeAlignment.MiddleCenter
bc2.BorderThickness = New FrameThickness(0.03)
bc2.CornerRadius = New RectangleCornerRadius(0.1)
bc2.RotationAngle = 90
bc2.Font.Size = 5

'Add items to ThermalLabel object...
tLabel.Items.Add(bc1)
tLabel.Items.Add(bc2)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 5, 3);
tLabel.GapLength = 0.2;

//Define a BarcodeItem object for encoding EAN-13 symbology
BarcodeItem bc1 = new BarcodeItem(0.2, 0.2, 2.5, 1.5, BarcodeSymbology.Ean13, "5012345678900");
bc1.BarWidth = 0.013;
bc1.BarHeight = 1;
bc1.EanUpcGuardBar = true;
bc1.EanUpcGuardBarHeight = bc1.BarHeight + 5 * bc1.BarWidth;
bc1.EanUpcSupplement = Supplement.Digits2;
bc1.EanUpcSupplementCode = "74";
bc1.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
bc1.BorderThickness = new FrameThickness(0.03);
bc1.Font.Size = 5;

//Define a BarcodeItem object for encoding UPC-A symbology
BarcodeItem bc2 = new BarcodeItem(3, 0.2, 2.5, 1.5, BarcodeSymbology.UpcA, "012345678905");
bc2.BarWidth = 0.013;
bc2.BarHeight = 1;
bc2.EanUpcGuardBar = true;
bc2.EanUpcGuardBarHeight = bc1.BarHeight + 5 * bc1.BarWidth;
bc2.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
bc2.BorderThickness = new FrameThickness(0.03);
bc2.CornerRadius = new RectangleCornerRadius(0.1);
bc2.RotationAngle = 90;
bc2.Font.Size = 5;

//Add items to ThermalLabel object...
tLabel.Items.Add(bc1);
tLabel.Items.Add(bc2);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Example #3: a PDF417 barcode, a Data Matrix and a ITF-14 barcode with Bearer Bars.

Label featuring PDF417, Data Matrix and ITF-14 barcode Item objects

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a BarcodeItem object for encoding PDF417 symbology
Dim bc1 As New BarcodeItem(0.2, 0.2, 2, 1, BarcodeSymbology.Pdf417, "PRODUCT CODE 98765")
bc1.BarWidth = 0.01
bc1.BarRatio = 3 'For PDF417, bar ratio should be >= 3

'Define a BarcodeItem object for encoding DataMatrix symbology
Dim bc2 As New BarcodeItem(3, 0.2, 2.5, 1.5, BarcodeSymbology.DataMatrix, "0123456789ABCDEF")
bc2.DataMatrixModuleSize = 0.04

'Define a BarcodeItem object for encoding ITF-14 symbology with Bearer Bars
Dim bc3 As New BarcodeItem(0.2, 1.5, 2, 1, BarcodeSymbology.Itf14, "1540014128876")
bc3.BarWidth = 0.01
bc3.BarHeight = 0.7
bc3.BearerBarStyle = BearerBarStyle.HorizontalRules
bc3.BearerBarThickness = 0.05
bc3.UseQuietZoneForText = True
bc3.Font.Size = 5

'Add items to ThermalLabel object...
tLabel.Items.Add(bc1)
tLabel.Items.Add(bc2)
tLabel.Items.Add(bc3)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a BarcodeItem object for encoding PDF417 symbology
BarcodeItem bc1 = new BarcodeItem(0.2, 0.2, 2, 1, BarcodeSymbology.Pdf417, "PRODUCT CODE 98765");
bc1.BarWidth = 0.01;
bc1.BarRatio = 3; //For PDF417, bar ratio should be >= 3

//Define a BarcodeItem object for encoding DataMatrix symbology
BarcodeItem bc2 = new BarcodeItem(3, 0.2, 2.5, 1.5, BarcodeSymbology.DataMatrix, "0123456789ABCDEF");
bc2.DataMatrixModuleSize = 0.04;

//Define a BarcodeItem object for encoding ITF-14 symbology with Bearer Bars
BarcodeItem bc3 = new BarcodeItem(0.2, 1.5, 2, 1, BarcodeSymbology.Itf14, "1540014128876");
bc3.BarWidth = 0.01;
bc3.BarHeight = 0.7;
bc3.BearerBarStyle = BearerBarStyle.HorizontalRules;
bc3.BearerBarThickness = 0.05;
bc3.UseQuietZoneForText = true;
bc3.Font.Size = 5;

//Add items to ThermalLabel object...
tLabel.Items.Add(bc1);
tLabel.Items.Add(bc2);
tLabel.Items.Add(bc3);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Image, Graphic and Picture Items

Neodynamic ThermalLabel SDK for .NET
Image, Graphic and Picture Items Overview

In this section

  • The ImageItem object
  • Image Resizing
  • Image Flipping and Rotation
  • Monochrome conversion
  • ImageItem samples

The ImageItem object
An ImageItem – represented by Neodynamic.SDK.Printing.ImageItem class – simply wraps an image, graphic or picture that must be drawn on the label. ImageItem objects are created by specifying some basic properties such as X, Y, Width, Height, Image source, etc.

The ImageItem object can wrap and manage the following image formats: BMP, GIF, JPEG, and PNG. The image content can be specified as a File path or URL, a base64 string, or a byte array. Once an image source is specified, you can control how to size, rotate, and flip it, as well as monochrome settings conversion supporting Threshold and Floyd-Steinberg algorithms and reversing.

After creating an ImageItem object, it will printed on the label if you add it to the Items collection property of the ThermalLabel object.

Image Resizing
When you create an ImageItem, you must specify the source image as well as its location inside the label (through X & Y properties) and its printed size. The printed size of the image is configured by using the Width, Height and LockAspectRatio properties as follows:
  • If LockAspectRatio = None, then the printed size of the image will be the one specified to Width & Height properties
  • If LockAspectRatio = WidthBased, then the printed size of the image will be the one specified to Width property and the Height will be automatically calculated maintaining the original proportions.
  • If LockAspectRatio = HeightBased, then the printed size of the image will be the one specified to Height property and the Width will be automatically calculated maintaining the original proportions.
  • If LockAspectRatio = Fit, then the printed size of the image will be the one specified to Width & Height properties maintaining the original proportions.

Image Flipping and Rotation
You can specify that the source image be flipped when printing. The flipping is configured by using the Flip property allowing you to flip the source image horizontally, vertically or both directions.

You can also rotate the source image if needed. The rotation can be done at any angle (in degrees) by specifying it to the RotationAngle property. The rotation angle range from 0 to 360 degrees measured clockwise from the x-axis.

Internally, the image processing actions are performed in the following order: Resize > Flip > Rotate

Monochrome conversion
When printing an image to a thermal printer, the source image must be converted to monochrome format i.e. black & white colors. It is important you work with images in such basic color scheme when specifying the source image in order to avoid losing quality. Anyway, ImageItem are processed to monochrome by using the MonochromeSettings property.

ThermalLable SDK provides four Dithering Methods for black & white conversion which are set up on the DitherMethod property of MonochromeSettings object:
  • Threshold: it is the simplest dithering method which any pixel value below the threshold becomes black and any pixel value above the threshold becomes white. It is useful for simple images like logos or symbols.
  • PatternDiffusion: this method uses a 4x4 dithering matrix to create a grouping of pixels that approximates the pixel group brightness. Use it for photos and other complicated images.
  • FloydSteinberg: it uses Floyd-Steinberg algorithm to keep a track of the error in brightness caused by the threshold, and diffusing it across an area. Use it for photos and other complicated images.
  • OtsuThreshold: it uses Otsu's method to automatically perform histogram shape-based image thresholding. Use it for simple images like logos or symbols.
By default, ImageItem will use OtsuThreshold method.

The MonochromeSettings property also allows you to create a "reverse" effect which means that the image shape will be printed as White On Black i.e. reversing the monochrome pixel conversion.

ImageItem samples
Example #1: Below is a sample logo in JPEG format. The figure under the logo image is a sample label featuring such image but printed as monochrome by using an ImageItem object.

Adventure Works Sample logo

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define an ImageItem object
Dim logo As New ImageItem(0.5, 0.5)
'Set image source...
logo.SourceFile = "C:\temp\Adventureworks.jpg"
'Set output size...
logo.Width = 2
logo.LockAspectRatio = LockAspectRatio.WidthBased
'monochrome settings
logo.MonochromeSettings.DitherMethod = DitherMethod.Threshold
logo.MonochromeSettings.Threshold = 80

'Add items to ThermalLabel object...
tLabel.Items.Add(logo)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define an ImageItem object
ImageItem logo = new ImageItem(0.5, 0.5);
//Set image source...
logo.SourceFile = @"C:\temp\Adventureworks.jpg";
//Set output size...
logo.Width = 2;
logo.LockAspectRatio = LockAspectRatio.WidthBased;
//monochrome settings
logo.MonochromeSettings.DitherMethod = DitherMethod.Threshold;
logo.MonochromeSettings.Threshold = 80;

//Add items to ThermalLabel object...
tLabel.Items.Add(logo);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Example #2: In this sample, we used the same logo but rotated it 90 degrees and reversed to get a White On Black effect.

Image Item rotated and reversed

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define an ImageItem object
Dim logo As New ImageItem(0.5, 0.5)
'Set image source...
logo.SourceFile = "C:\temp\Adventureworks.jpg"
'Set output size...
logo.Width = 2
logo.LockAspectRatio = LockAspectRatio.WidthBased
logo.RotationAngle = 90
'monochrome settings
logo.MonochromeSettings.DitherMethod = DitherMethod.Threshold
logo.MonochromeSettings.Threshold = 80
logo.MonochromeSettings.ReverseEffect = True

'Add items to ThermalLabel object...
tLabel.Items.Add(logo)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define an ImageItem object
ImageItem logo = new ImageItem(0.5, 0.5);
//Set image source...
logo.SourceFile = @"C:\temp\Adventureworks.jpg";
//Set output size...
logo.Width = 2;
logo.LockAspectRatio = LockAspectRatio.WidthBased;
logo.RotationAngle = 90;
//monochrome settings
logo.MonochromeSettings.DitherMethod = DitherMethod.Threshold;
logo.MonochromeSettings.Threshold = 80;
logo.MonochromeSettings.ReverseEffect = true;

//Add items to ThermalLabel object...
tLabel.Items.Add(logo);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


RFID Tag

Neodynamic ThermalLabel SDK for .NET
RFID Tag Items Overview

In this section

  • The RFIDTagItem object
  • RFIDTagItem samples

The RFIDTagItem object
A RFIDTagItem – represented by Neodynamic.SDK.Printing.RFIDTagItem class allows you to encode RFID tags in a label object. RFIDTagItem objects are created by specifying some basic properties such as type and data to encode.

NOTE: RFID Tags are only available for ZPL-based printers.

RFIDTagItem samples
Example #1: Encoding ASCII Data

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a RFIDTagItem object
Dim rfidTag As New RFIDTagItem()
'Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.ASCII
'Set data to encode...
rfidTag.DataToEncode = "My Data"

'Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra ZD500R"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a RFIDTagItem object
RFIDTagItem rfidTag = new RFIDTagItem();
//Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.ASCII;
//Set data to encode...
rfidTag.DataToEncode = "My Data";

//Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra ZD500R";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Example #2: Encoding HEX data

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a RFIDTagItem object
Dim rfidTag As New RFIDTagItem()
'Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.Hexadecimal
'Set data to encode...
rfidTag.DataToEncode = "4D792044617461" 'My Data

'Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra ZD500R"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a RFIDTagItem object
RFIDTagItem rfidTag = new RFIDTagItem();
//Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.Hexadecimal;
//Set data to encode...
rfidTag.DataToEncode = "4D792044617461"; //My Data

//Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra ZD500R";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Example #3: Encoding EPC data

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a RFIDTagItem object
Dim rfidTag As New RFIDTagItem()
'Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.EPC
'Set the EPC Data Structure
'TOTAL-BITS,PARTITION1-BITS,PARTITION2-BITS,...,PARTITIONn-BITS
rfidTag.EPCDataStructure = "96,8,3,3,20,24,38"
'Set data to encode...
rfidTag.DataToEncode = "16,3,5,78742,146165,1234567891"

'Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra ZD500R"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a RFIDTagItem object
RFIDTagItem rfidTag = new RFIDTagItem();
//Set data type...
rfidTag.DataFormat = RFIDTagDataFormat.EPC;
//Set the EPC Data Structure
//TOTAL-BITS,PARTITION1-BITS,PARTITION2-BITS,...,PARTITIONn-BITS
rfidTag.EPCDataStructure = "96,8,3,3,20,24,38";
//Set data to encode...
rfidTag.DataToEncode = "16,3,5,78742,146165,1234567891";

//Add items to ThermalLabel object...
tLabel.Items.Add(rfidTag);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra ZD500R";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Shape Items (Lines, Rectangles, Circles, Ellipses, Tables/Grids)

Neodynamic ThermalLabel SDK for .NET
Shape Items Overview
ThermalLabel SDK supports AutoShapes which are preset shapes like rectangles, circles, lines, and ellipses that can be placed on the label surface.

In This Section
  • Rectangle Item
  • Line Item
  • Circle and Ellipse Items

Rectangle Item
A Rectangle Item – represented by Neodynamic.SDK.Printing.RectangleShapeItem class – lets you draw rectangle shapes on the label. RectangleShapeItem objects are created by specifying some basic properties such as Width, Height, Fill, StrokeThickness, Roundness, etc.

RectangleShapeItem Sample:

By using RectangleShapeItem objects you can draw rectangles as well as rounded rectangles. The following figure is a sample label featuring rectangle shapes with different settings.

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define some RectangleShapeItem objects
Dim r1 As New RectangleShapeItem(0.5, 0.5, 1, 0.75)
r1.StrokeThickness = 0.03

'With rounded corners
Dim r2 As New RectangleShapeItem(0.5, 1.75, 1, 0.75)
r2.StrokeThickness = 0.03
r2.CornerRadius = New RectangleCornerRadius(0.2)

'With some rounded corners and black fill
Dim r3 As New RectangleShapeItem(2, 0.5, 1, 0.75)
r3.FillColor = Neodynamic.SDK.Printing.Color.Black
r3.CornerRadius = New RectangleCornerRadius(0.2, 0.2, 0, 0)

'Add items to ThermalLabel object...
tLabel.Items.Add(r1)
tLabel.Items.Add(r2)
tLabel.Items.Add(r3)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define some RectangleShapeItem objects
RectangleShapeItem r1 = new RectangleShapeItem(0.5, 0.5, 1, 0.75);
r1.StrokeThickness = 0.03;

//With rounded corners
RectangleShapeItem r2 = new RectangleShapeItem(0.5, 1.75, 1, 0.75);
r2.StrokeThickness = 0.03;
r2.CornerRadius = new RectangleCornerRadius(0.2);

//With some rounded corners and black fill
RectangleShapeItem r3 = new RectangleShapeItem(2, 0.5, 1, 0.75);
r3.FillColor = Neodynamic.SDK.Printing.Color.Black;
r3.CornerRadius = new RectangleCornerRadius(0.2, 0.2, 0, 0);

//Add items to ThermalLabel object...
tLabel.Items.Add(r1);
tLabel.Items.Add(r2);
tLabel.Items.Add(r3);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Line Item
A Line Item – represented by Neodynamic.SDK.Printing.LineShapeItem class – lets you draw lines on the label. LineShapeItem objects are created by specifying some basic properties such as Width, Height, Orientation, etc.

LineShapeItem Sample:

By using LineShapeItem objects you can draw lines at any orientation i.e. horizontal, vertical, diagonals up and down. The following figure is a sample label featuring some line shapes with different settings.

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define some LineShapeItem objects

'A simple horizontal line
Dim l1 As New LineShapeItem(0.5, 0.5, 1, 0.1)
l1.StrokeThickness = 0.1

'A diagonal up line
Dim l2 As New LineShapeItem(0.5, 1.75, 1, 0.75)
l2.StrokeThickness = 0.03
l2.Orientation = LineOrientation.DiagonalUp

'A simple vertical line
Dim l3 As New LineShapeItem(2, 0.5, 0.1, 2)
l3.StrokeThickness = 0.1
l3.Orientation = LineOrientation.Vertical

'Add items to ThermalLabel object...
tLabel.Items.Add(l1)
tLabel.Items.Add(l2)
tLabel.Items.Add(l3)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define some LineShapeItem objects

//A simple horizontal line
LineShapeItem l1 = new LineShapeItem(0.5, 0.5, 1, 0.1);
l1.StrokeThickness = 0.1;

//A diagonal up line
LineShapeItem l2 = new LineShapeItem(0.5, 1.75, 1, 0.75);
l2.StrokeThickness = 0.03;
l2.Orientation = LineOrientation.DiagonalUp;

//A simple vertical line
LineShapeItem l3 = new LineShapeItem(2, 0.5, 0.1, 2);
l3.StrokeThickness = 0.1;
l3.Orientation = LineOrientation.Vertical;

//Add items to ThermalLabel object...
tLabel.Items.Add(l1);
tLabel.Items.Add(l2);
tLabel.Items.Add(l3);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Circle and Ellipse Items
Circle and Ellipse items – represented by Neodynamic.SDK.Printing.CircleShapeItem and Neodynamic.SDK.Printing.EllipseShapeItem classes respectively– let you draw circle and ellipse/oval shapes on the label. Both kinds of objects are created by specifying some basic properties such as Width, Height, Fill, StrokeThickness, etc.

CircleShapeItem and EllipseShapeItem Sample:

By using CircleShapeItem and EllipseShapeItem objects you can draw circle, ellipse and oval shapes. The following figure is a sample label featuring such shapes.

Circle and Ellipse Items

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2

'Define a CircleShapeItem object
Dim c1 As New CircleShapeItem(0.5, 0.5, 1)
c1.StrokeThickness = 0.03

'Define a CircleShapeItem object with black fill
Dim c2 As New CircleShapeItem(0.5, 1.75, 1)
c2.FillColor = Neodynamic.SDK.Printing.Color.Black

'Define an EllipseShapeItem object
Dim e1 As New EllipseShapeItem(2, 0.5, 1, 0.75)
e1.StrokeThickness = 0.03

'Add items to ThermalLabel object...
tLabel.Items.Add(c1)
tLabel.Items.Add(c2)
tLabel.Items.Add(e1)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a CircleShapeItem object
CircleShapeItem c1 = new CircleShapeItem(0.5, 0.5, 1);
c1.StrokeThickness = 0.03;

//Define a CircleShapeItem object with black fill
CircleShapeItem c2 = new CircleShapeItem(0.5, 1.75, 1);
c2.FillColor = Neodynamic.SDK.Printing.Color.Black;

//Define an EllipseShapeItem object
EllipseShapeItem e1 = new EllipseShapeItem(2, 0.5, 1, 0.75);
e1.StrokeThickness = 0.03;

//Add items to ThermalLabel object...
tLabel.Items.Add(c1);
tLabel.Items.Add(c2);
tLabel.Items.Add(e1);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


ThermalLabel Editor Component

Neodynamic ThermalLabel SDK for .NET
The ThermalLabelEditor Component
The ThermalLabelEditor component is a first-class label designer component for .NET Windows desktop apps which main goal is to aid the users with the label design process providing a visual environment.

The ThermalLabelEditor features visual aids for the creation of label items, an undo/redo engine, Cut-Copy-Paste functionality, z-ordering, zooming, keyboard shortcuts for well-known common actions, In-place text edition for TextItem objects and many more features. It is also very customizable so you can skin it to match the app’s UI style on which it will be hosted.

The following is a screenshot of the sample app which is shipped with the ThermalLabel SDK package.

A sample Windows Forms app hosting the ThermalLabelEditor component.

On these screenshots you can see a ThermalLabel object on the editor’s design surface. Pay attention to that figure. What you see surrounded by the “rulers” is the ThermalLabelEditor component. The other part of the UI i.e. the menu, toolbar, status bar, dialog boxes for item’s properties, etc; will be designed and coded by you! That means you can create a Visual Label Designer within your own WPF or Windows Forms app by using whatever you want i.e. you may want to use a Ribbon menu instead of a standard one, dialog boxes instead of "Properties Window/Grid", etc. You are free to surround our ThermalLabelEditor component to match your UI app style!

ThermalLabelEditor System Requirements
The minimum system requirements for ThermalLabelEditor are:
  • ThermalLabel SDK 6.0 (Neodynamic.SDK.ThermalLabel.dll)
  • .NET Framework 3.5 SP1 (Client-Profile)

ThermalLabelEditor .NET assemblies (dll)
The ThermalLabelEditor component is shipped with a version for WPF and one for Windows Forms. Both classes are located in the same assembly called Neodynamic.Windows.ThermalLabelEditor.dll
Inside that assembly, the WPF and Windows Forms classes of the ThermalLabelEditor component are located under the following namespaces:
  • For WPF, the class path is Neodynamic.Windows.WPF.ThermalLabelEditor.ThermalLabelEditor
  • For Windows Forms, the class path is Neodynamic.Windows.Forms.ThermalLabelEditor.ThermalLabelEditor

Sample application projects
With the ThermalLabel SDk installer, we've shipped Windows Forms and WPF projects using the ThermalLabelEditor component. Open them using Visual Studio 2010 or greater to learn how the ThermalLabelEditor component works and how to interact with it in your own app. The Windows Forms project uses a "Properties Window" approach to allow the user to change/modify the data of each Item objects on the label while the WPF app uses a "Properties Dialog" approach for the same task.

IMPORTANT
These sample app projects, one for Windows Forms and one for WPF, are both very simple apps and do NOT demo ALL the ThermalLabel SDK and Editor features! They have errors, bugs, bad software development practices, etc.; meaning you cannot consider it as a sample of how to code apps! These apps were coded for demoing how you can interact with the ThermalLabelEditor component ONLY. Again, the sample apps are NOT our product but a sample of how your own app/code needs to interact with the ThermalLabelEditor component.

ThermalLabelEditor Features
  • Rulers
    The ThermalLabelEditor features rulers to help users with the measurement process. There are two rulers; one which runs at the top of the editor’s canvas and one which runs at the left side. The ruler’s unit of measurement automatically changes to match the current Unit set up on the ThermalLabel object which is being edited. You can change the ruler's background and foreground colors to match your UI style.
  • Items’ Selection and Handlers
    The items on the design surface can be selected by the user by “drawing” a rectangular selection around the desired items; or by left-clicking on the item. Multiple items can be selected by left-clicking on the items while holding down CTRL hey.
    Each time the user selects one or multiple items some visual handlers appear on the design surface. Handlers aid the users with full resize and move actions as well as rotation.
    You can also change the background and foreground colors of the handlers to match your UI style.
  • Keyboard-based Item’s Movement
    Users can move items on the editor’s surface by using the Arrow keys. For longer movements users can hold down CTRL key.
  • In-Place Text Edition
    Users can easily edit the text of a TextItem by double-clicking on it or by hitting F2 key. The In-Place Text Edition is even enabled if the TextItem is being rotated!
  • Picture Missing Aid
    When working with ImageItem objects, you can specify a custom image file which will displayed if the image source of the ImageItem cannot be found!
  • Picture Monochrome Conversion Tool
    The ImageItemUtils class feature a method which allows you to get the output when converting the image source of an ImageItem to black & white based on the MonochromeSettings options set up on such ImageItem object! It is useful for you to display to your users a preview of the image in black & white format by fine tuning the MonochromeSettings options.
  • Items’ Comments
    If the Item object has set up comments (by using the new Comments property) then the ThermalLabelEditor will display a tooltip/popup to the users when the mouse pointer is over the item.
  • High Quality Zoom
    ThermalLabelEditor provides you with a high quality zooming feature. User can zoom the editor’s surface from 10% up to 1000%
  • Undo/Redo
    ThermalLabelEditor allows users to undo/redo actions. You as the app developer are provided with methods and properties related to state of the editor’s design surface for Undo/Redo.
  • Cut-Copy-Paste
    ThermalLabelEditor also allows users to cut, copy and paste items on the editor’s design surface. You as the app developer are provided with methods and properties related to clipboard’s state of the editor’s design surface. NOTE: the “clipboard” used by the ThermalLabelEditor is for internal usage i.e. you cannot, for example, to copy an Item and then try to paste it on another app.
  • Items’ Z-Ordering
    Z-Ordering refers to index position of an Item in the Items collection property of the ThermalLabel object being edited. You as the app developer are provided with methods like BringForward, BringToFront, SendBackward and SendToBack.
  • Grid lines
    ThermalLabelEditor allows you to specify grid lines for better label design. The well known "Snap to Grid" feature is also supported.
  • Locking Items
    ThermalLabelEditor allows you to lock items on the editor surface so they cannot be moved accidentally.
  • Keyboard Shortcuts
    ThermalLabelEditor does support the following keyboard shortcuts:

    Action/Operation

    Keyboard Shortcut

    Clipboard Copy

    CTRL + C or CTRL + INSERT

    Clipboard Cut

    CTRL + X or SHIFT + DELETE

    Clipboard Paste

    CTRL + V or SHIFT + INSERT

    Undo

    CTRL + Z

    Redo

    CTRL + Y

    Select All Items

    CTRL + A

    Delete Selected Items

    DELETE

    Move Selected Items (Small Step)

    ARROW KEYS

    Move Selected Items (Long Step)

    CTRL + ARROW KEYS

    Edit TextItem

    F2

    Zoom In

    CTRL + PLUS SIGN

    Zoom Out

    CTRL + MINUS SIGN

    Zoom 100%

    CTRL + 0 (ZERO)

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Print Job

Neodynamic ThermalLabel SDK for .NET
Print Job
The PrintJob is the object that specifies information about how a ThermalLabel object is printed, including the printer device settings and communication, label orientation, number of copies, etc.

For more info about printer communication please refer to Thermal Printer Communication. For sample code about using PrintJob class please refer to ThermalLabel samples.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Printer Utilities

Neodynamic ThermalLabel SDK for .NET
Printer Utilities
ThermalLabel SDK does not only provide thermal label designing and printing but a set of commands for Zebra Thermal Printers administration too. ThermalLabel SDK features the PrintUtils object which is used for printing jobs that are not directly related to label printing like printer's memory devices administration. Please refer to PrintUtils class reference for more details.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Thermal Printer Communication

Neodynamic ThermalLabel SDK for .NET
Thermal Printer Communication
Thermal Printers can be connected by Serial Port (RS-232), Parallel Port (Centronics), USB and IP Ethernet network depending on the printer model. Printer communication with ThermalLabel SDK is handled by using PrinterCommunication class. However, that class is not directly used in .NET code but through a PrintJob object or the PrintUtils class.

In This Section
  • USB
  • Parallel Port (Centronics)
  • Serial Port (RS-232)
  • IP Ethernet Network

USB
If your printer is connected by USB, then you will have to install/configure a Windows Driver for the printer which can be the Zebra Universal Driver (ZUD) or the Windows built-in "Microsoft Generic Text Only" printer driver before trying to use it with ThermalLabel SDK. The following code is about how to configure printer communication for a Zebra printer connected by USB through a PrintJob object:
NOTE: These same settings are valid for the PrinterDriver option.

Visual Basic

'Create a PrintJob object
Dim pj As New PrintJob()
'Thermal Printer is connected through USB
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.USB
'Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203
'Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL
'Set Thermal Printer name
pj.PrinterSettings.PrinterName = "Zebra  TLP2844-Z"

C#

//Create a PrintJob object
PrintJob pj = new PrintJob();
//Thermal Printer is connected through USB
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.USB;
//Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203;
//Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL;
//Set Thermal Printer name
pj.PrinterSettings.PrinterName = "Zebra  TLP2844-Z";

Parallel Port (Centronics)
If your printer is connected by Parallel Port (Centronic), then you just need to know the parallel port name to specify it in the PrinterCommunication object. The following code is about how to configure printer communication for a Zebra printer connected by LPT1 Parallel Port through a PrintJob object:

Visual Basic

'Create a PrintJob object
Dim pj As New PrintJob()
'Thermal Printer is connected through Parallel Port
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Parallel
'Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203
'Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL
'Set Thermal Printer parallel port name
pj.PrinterSettings.ParallelPortName= "LPT1"

C#

//Create a PrintJob object
PrintJob pj = new PrintJob();
//Thermal Printer is connected through Parallel Port
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Parallel;
//Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203;
//Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL;
//Set Thermal Printer parallel port name
pj.PrinterSettings.ParallelPortName= "LPT1";

Serial Port (RS-232)
If your printer is connected by Serial Port (RS-232), then you need to know the Thermal Printer serial port settings to specify it in the PrinterCommunication object. Please refer to your Zebra Printer User Manual and look for the Serial Communication parameters. The following code is about how to configure printer communication for a Zebra printer connected by COM1 Serial Port through a PrintJob object:

Visual Basic

'Create a PrintJob object
Dim pj As New PrintJob()
'Thermal Printer is connected through Serial Port
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Serial
'Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203
'Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL
'Set Thermal Printer serial port settings
pj.PrinterSettings.Communication.SerialPortName = "COM1"
pj.PrinterSettings.Communication.SerialPortBaudRate = 9600
pj.PrinterSettings.Communication.SerialPortDataBits = 8
pj.PrinterSettings.Communication.SerialPortStopBits = System.IO.Ports.StopBits.One
pj.PrinterSettings.Communication.SerialPortParity = System.IO.Ports.Parity.None
pj.PrinterSettings.Communication.SerialPortFlowControl = System.IO.Ports.Handshake.XOnXOff

C#

//Create a PrintJob object
PrintJob pj = new PrintJob();
//Thermal Printer is connected through Serial Port
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Serial;
//Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203;
//Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL;
//Set Thermal Printer serial port settings
pj.PrinterSettings.Communication.SerialPortName = "COM1";
pj.PrinterSettings.Communication.SerialPortBaudRate = 9600;
pj.PrinterSettings.Communication.SerialPortDataBits = 8;
pj.PrinterSettings.Communication.SerialPortStopBits = System.IO.Ports.StopBits.One;
pj.PrinterSettings.Communication.SerialPortParity = System.IO.Ports.Parity.None;
pj.PrinterSettings.Communication.SerialPortFlowControl = System.IO.Ports.Handshake.XOnXOff;

IP Ethernet Network
If your printer is connected by an IP Ethernet network, then you just need to know the IP Address as well as the port number for the printer to specify them in the PrinterCommunication object. The following code is about how to configure printer communication for a Zebra printer connected by IP Ethernet through a PrintJob object:

Visual Basic

'Create a PrintJob object
Dim pj As New PrintJob()
'Thermal Printer is connected through IP network
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Network
'Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203
'Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL
'Set Thermal Printer network info
pj.PrinterSettings.Communication.NetworkIPAddress = System.Net.IPAddress.Parse("127.0.0.1")
pj.PrinterSettings.Communication.NetworkPort = 9100

C#

//Create a PrintJob object
PrintJob pj = new PrintJob();
//Thermal Printer is connected through IP network
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Network;
//Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203;
//Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL;
//Set Thermal Printer network info
pj.PrinterSettings.Communication.NetworkIPAddress = System.Net.IPAddress.Parse("127.0.0.1");
pj.PrinterSettings.Communication.NetworkPort = 9100;

In case you do not know which is the IP Address of the printer but the Host name, then you can use the following code instead:

Visual Basic

'Create a PrintJob object
Dim pj As New PrintJob()
'Thermal Printer is connected through IP network
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Network
'Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203
'Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL
'Set Thermal Printer network info
pj.PrinterSettings.PrinterName = "PRINTER HOST NAME"
pj.PrinterSettings.Communication.NetworkPort = 9100

C#

//Create a PrintJob object
PrintJob pj = new PrintJob();
//Thermal Printer is connected through IP network
pj.PrinterSettings.Communication.CommunicationType = CommunicationType.Network;
//Set Thermal Printer resolution
pj.PrinterSettings.Dpi = 203;
//Set Thermal Printer language
pj.PrinterSettings.ProgrammingLanguage = ProgrammingLanguage.ZPL;
//Set Thermal Printer network info
pj.PrinterSettings.PrinterName = "PRINTER HOST NAME";
pj.PrinterSettings.Communication.NetworkPort = 9100;

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Items Caching

Neodynamic ThermalLabel SDK for .NET
Items Caching
ThermalLabel SDK generates native printer commands which are sent to the printer through a PrintJob object. To improve printing performance, ThermalLabel SDK provides a caching mechanism which is set up on each item on a given ThermalLabel object.

When you activate the caching feature on an Item object, the native printer commands generated by that Item is sent to the printer’s memory device just once and is internally referenced with an identifier. When a new label needs to be sent to the printer, then the cached items just generate and send their identifiers which greatly improves printing time performance. The caching mechanism is automatic i.e. you do not need to care about how to handle it in your code.

Which items can be cached?
All items can be configured to be cached. Of course, the items which are eligible to be cached are those who their content/output does not change while processing the print job. That’s mean, you can cache all those items which are somehow “static”. For instance, a company logo or industry symbols are good candidates for caching. The same apply for those texts or legends which display static content.

How to enable items caching?
After you identify which items in the thermal label are eligible to be cached, you can enable it by setting up the UseCache property to True on the Item object. For identifying the item in the printer device memory cache, you can specify a unique ID using the CacheItemId property. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If you do not specify one, then a random ID will be assigned automatically at runtime.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Data Binding

Neodynamic ThermalLabel SDK for .NET
Data Binding
ThermalLabel SDK supports .NET Data Binding scenarios allowing you to print thermal labels bound to a data source such as custom .NET objects, XML files, Databases, ADO.NET, etc. The data binding settings are very simple. You set up a valid data source to the ThermalLabel object by using the DataSource property. In the label, items like TextItem, ImageItem and BarcodeItem can be bound to fields of the data source by using the DataField property. Below are a couple of data binding scenarios to help you getting started.

In This Section
  • Custom Object Data Binding scenario
  • XML file Data Binding scenario
  • ADO.NET Database Data Binding scenario

Custom Object Data Binding scenario
The following sample features a class called Product with two basic properties: Id and Name. A list of Product and a ThermalLabel objects will be used to perform data binding scenario printing a set of thermal labels for each product as shown in the following figure.

Custom Object Data Binding scenario

The Product class:

Visual Basic

Public Class Product

    Dim _id As String
    Dim _name As String

    Public Sub New(ByVal id As String, ByVal name As String)
        Me.Id = id
        Me.Name = name
    End Sub

    Public Property Id() As String
        Get
            Return _id
        End Get
        Set(ByVal value As String)
            _id = value
        End Set
    End Property

    Public Property Name() As String
        Get
            Return _name
        End Get
        Set(ByVal value As String)
            _name = value
        End Set
    End Property

End Class

C#

public class Product
{
    string _id;
    string _name;

    public Product(string id, string name)
    {
        this.Id = id;
        this.Name = name;
    }

    public string Id
    {
        get { return _id; }
        set { _id = value; }
    }

    public string Name
    {
        get { return _name; }
        set { _name = value; }
    }
}

ThermalLabel with Custom Object Data Binding

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 3, 2)
tLabel.GapLength = 0.2

'Define a TextItem object for product name
Dim txt As New TextItem(0.1, 0.1, 2.8, 0.5, "")
'set data field
txt.DataField = "Name"
'set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt.Font.Unit = FontUnit.Point
txt.Font.Size = 10
'set border
txt.BorderThickness = new FrameThickness(0.03)
'set alignment
txt.TextAlignment = TextAlignment.Center
txt.TextPadding = new FrameThickness(0, 0.1, 0, 0)

'Define a BarcodeItem object for encoding product id with a Code 128 symbology
Dim bc As New BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "")
'set data field
bc.DataField = "Id"
'set barcode size
bc.BarWidth = 0.01
bc.BarHeight = 0.75
'set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter
'set text alignment
bc.CodeAlignment = BarcodeTextAlignment.BelowCenter
'set border
bc.BorderThickness = new FrameThickness(0.03)

'Add items to ThermalLabel object...
tLabel.Items.Add(txt)
tLabel.Items.Add(bc)

'Create data source...
Dim products As New List(Of Product)
products.Add(New Product("OO2935", "Olive Oil"))
products.Add(New Product("CS4948", "Curry Sauce"))
products.Add(New Product("CH0094", "Chocolate"))
products.Add(New Product("MZ1027", "Mozzarella"))

'set data source...
tLabel.DataSource = products

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 3, 2);
tLabel.GapLength = 0.2;

//Define a TextItem object for product name
TextItem txt = new TextItem(0.1, 0.1, 2.8, 0.5, "");
//set data field
txt.DataField = "Name";
//set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt.Font.Unit = FontUnit.Point;
txt.Font.Size = 10;
//set border
txt.BorderThickness = new FrameThickness(0.03);
//set alignment
txt.TextAlignment = TextAlignment.Center;
txt.TextPadding = new FrameThickness(0, 0.1, 0, 0);

//Define a BarcodeItem object for encoding product id with a Code 128 symbology
BarcodeItem bc = new BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "");
//set data field
bc.DataField = "Id";
//set barcode size
bc.BarWidth = 0.01;
bc.BarHeight = 0.75;
//set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
//set text alignment
bc.CodeAlignment = BarcodeTextAlignment.BelowCenter;
//set border
bc.BorderThickness = new FrameThickness(0.03);

//Add items to ThermalLabel object...
tLabel.Items.Add(txt);
tLabel.Items.Add(bc);

//Create data source...
List<Product> products = new List<Product>();
products.Add(new Product("OO2935", "Olive Oil"));
products.Add(new Product("CS4948", "Curry Sauce"));
products.Add(new Product("CH0094", "Chocolate"));
products.Add(new Product("MZ1027", "Mozzarella"));

//set data source...
tLabel.DataSource = products;

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

XML file Data Binding scenario
The following sample features an XML file containing books info. An ADO.NET DataSet object wrapping the books info from the XML source and a ThermalLabel objects will be used to perform data binding scenario printing a set of thermal labels for each book as shown in the following figure.

XML file Data Binding scenario

Create an XML File in C:\temp\books.xml with the following content:

<Books xmlns="">
  <Book ISBN="0-7356-0562-9" Title="XML in Action" />
  <Book ISBN="0-7356-1377-X" Title="Introducing Microsoft .NET" />
  <Book ISBN="0-7356-1288-9" Title="Inside C#" />
  <Book ISBN="0-7356-1370-2" Title="Programming Microsoft Windows With C#" />
  <Book ISBN="0-7356-1448-2" Title="Microsoft C# Language Specifications" />
</Books>

ThermalLabel with an XML file Data Binding

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 3, 2)
tLabel.GapLength = 0.2

'Define a TextItem object for binding to book's title
Dim txt1 As New TextItem(0.1, 0.05, 2.8, 0.3, "")
'set data field
txt1.DataField = "Title"
'set font
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt1.Font.Unit = FontUnit.Point
txt1.Font.Size = 5
'set alignment
txt1.TextAlignment = TextAlignment.Left

'Define a TextItem object for binding to ISBN code
Dim txt2 As New TextItem(0.1, 0.3, 0.75, 0.5, "ISBN:")
'set data field
txt2.DataField = "ISBN"
txt2.DataFieldFormatString = "ISBN: {0}"
'set font
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt2.Font.Unit = FontUnit.Point
txt2.Font.Size = 10
'set alignment
txt2.TextAlignment = TextAlignment.Left

'Define a BarcodeItem object for encoding ISBN barcode
Dim bc As New BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Isbn, "")
'set data field
bc.DataField = "ISBN"
'set barcode size
bc.BarWidth = 0.013
bc.BarHeight = 1
bc.EanUpcGuardBar = True
bc.EanUpcGuardBarHeight = bc.BarHeight + 5 * bc.BarWidth
'set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter
'set font for human readable text
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
bc.Font.Unit = FontUnit.Point
bc.Font.Size = 5

'Add items to ThermalLabel object...
tLabel.Items.Add(txt1)
tLabel.Items.Add(txt2)
tLabel.Items.Add(bc)

'Create data source...
Dim books As New DataSet()
books.ReadXml("c:\temp\books.xml")

'set data source...
tLabel.DataSource = books

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 3, 2);
tLabel.GapLength = 0.2;

//Define a TextItem object for binding to book's title
TextItem txt1 = new TextItem(0.1, 0.05, 2.8, 0.3, "");
//set data field
txt1.DataField = "Title";
//set font
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt1.Font.Unit = FontUnit.Point;
txt1.Font.Size = 5;
//set alignment
txt1.TextAlignment = TextAlignment.Left;

//Define a TextItem object for binding to ISBN code
TextItem txt2 = new TextItem(0.1, 0.32, 2, 0.5, "");
//set data field
txt2.DataField = "ISBN";
txt2.DataFieldFormatString = "ISBN: {0}";
//set font
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt2.Font.Unit = FontUnit.Point;
txt2.Font.Size = 10;
//set alignment
txt2.TextAlignment = TextAlignment.Left;

//Define a BarcodeItem object for encoding ISBN barcode
BarcodeItem bc = new BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Isbn, "");
//set data field
bc.DataField = "ISBN";
//set barcode size
bc.BarWidth = 0.013;
bc.BarHeight = 1;
bc.EanUpcGuardBar = true;
bc.EanUpcGuardBarHeight = bc.BarHeight + 5 * bc.BarWidth;
//set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
//set font for human readable text
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
bc.Font.Unit = FontUnit.Point;
bc.Font.Size = 5;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt1);
tLabel.Items.Add(txt2);
tLabel.Items.Add(bc);

//Create data source...
DataSet books = new DataSet();
books.ReadXml(@"c:\temp\books.xml");

//set data source...
tLabel.DataSource = books;

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

ADO.NET Database Data Binding scenario
The following sample features an MS Access Database file (C:\Temp\DatabaseSample.mdb) containing an Employees table. An ADO.NET DataTable as well as a ThermalLabel objects will be used for data binding scenario printing a set of thermal labels for each employee as shown in the following figure.

ADO.NET Database Data Binding scenario

The structure of the Employees table in DatabaseSample.mdb file is as follows:

The structure of the Employees table in DatabaseSample.mdb

NOTE: Please copy the DatabaseSample.mdb to C:\Temp\DatabaseSample.mdb before testing the following code.

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 3, 2)
tLabel.GapLength = 0.2

'Define a couple of TextItem objects for Employee info
Dim txt1 As New TextItem(0.1, 0.05, 2.8, 0.3, "")
'set data field
txt1.DataField = "Name"
'set font
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt1.Font.Unit = FontUnit.Point
txt1.Font.Size = 10
'set alignment
txt1.TextAlignment = TextAlignment.Left

Dim txt2 As New TextItem(0.1, 0.35, 2.8, 0.3, "")
'set data field
txt2.DataField = "Address"
'set font
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt2.Font.Unit = FontUnit.Point
txt2.Font.Size = 5
'set alignment
txt2.TextAlignment = TextAlignment.Left

Dim txt3 As New TextItem(0.1, 0.65, 1.5, 0.3, "")
'set data field
txt3.DataField = "City"
'set font
txt3.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt3.Font.Unit = FontUnit.Point
txt3.Font.Size = 5
'set alignment
txt3.TextAlignment = TextAlignment.Left

Dim txt4 As New TextItem(1.6, 0.65, 0.5, 0.3, "")
'set data field
txt4.DataField = "State"
'set font
txt4.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt4.Font.Unit = FontUnit.Point
txt4.Font.Size = 5
'set alignment
txt4.TextAlignment = TextAlignment.Left

Dim txt5 As New TextItem(2.1, 0.65, 0.7, 0.3, "")
'set data field
txt5.DataField = "PostalCode"
'set font
txt5.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt5.Font.Unit = FontUnit.Point
txt5.Font.Size = 5
'set alignment
txt5.TextAlignment = TextAlignment.Left

'Define a BarcodeItem object for encoding the postal code in USPS Postnet
Dim bc As New BarcodeItem(0.1, 0.95, 2.8, 0.65, BarcodeSymbology.Postnet, "")
'set data field
bc.DataField = "PostalCode"
'set narrow bar width
bc.BarWidth = 0.02
'do not set a quiet zone
bc.QuietZone = new FrameThickness(0)
'set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.TopLeft
'hide human readable text
bc.DisplayCode = False

'Add items to ThermalLabel object...
tLabel.Items.Add(txt1)
tLabel.Items.Add(txt2)
tLabel.Items.Add(txt3)
tLabel.Items.Add(txt4)
tLabel.Items.Add(txt5)
tLabel.Items.Add(bc)

'Create data source...
Dim employees As New DataTable()
Using conn As New System.Data.OleDb.OleDbConnection("Provider= Microsoft.JET.OLEDB.4.0; Data Source=C:\temp\DataBaseSample.mdb")
    'open db connection...
    conn.Open()
    'execute db command...
    Using cmd As New System.Data.OleDb.OleDbCommand("SELECT TOP 6 * FROM Employees", conn)
        Using reader As System.Data.OleDb.OleDbDataReader = cmd.ExecuteReader()
            employees.Load(reader)
        End Using
    End Using
End Using

'set data source...
tLabel.DataSource = employees

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 3, 2);
tLabel.GapLength = 0.2;

//Define a couple of TextItem objects for Employee info
TextItem txt1 = new TextItem(0.1, 0.05, 2.8, 0.3, "");
//set data field
txt1.DataField = "Name";
//set font
txt1.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt1.Font.Unit = FontUnit.Point;
txt1.Font.Size = 10;
//set alignment
txt1.TextAlignment = TextAlignment.Left;

TextItem txt2 = new TextItem(0.1, 0.35, 2.8, 0.3, "");
//set data field
txt2.DataField = "Address";
//set font
txt2.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt2.Font.Unit = FontUnit.Point;
txt2.Font.Size = 5;
//set alignment
txt2.TextAlignment = TextAlignment.Left;

TextItem txt3 = new TextItem(0.1, 0.65, 1.5, 0.3, "");
//set data field
txt3.DataField = "City";
//set font
txt3.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt3.Font.Unit = FontUnit.Point;
txt3.Font.Size = 5;
//set alignment
txt3.TextAlignment = TextAlignment.Left;

TextItem txt4 = new TextItem(1.6, 0.65, 0.5, 0.3, "");
//set data field
txt4.DataField = "State";
//set font
txt4.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt4.Font.Unit = FontUnit.Point;
txt4.Font.Size = 5;
//set alignment
txt4.TextAlignment = TextAlignment.Left;

TextItem txt5 = new TextItem(2.1, 0.65, 0.7, 0.3, "");
//set data field
txt5.DataField = "PostalCode";
//set font
txt5.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt5.Font.Unit = FontUnit.Point;
txt5.Font.Size = 5;
//set alignment
txt5.TextAlignment = TextAlignment.Left;

//Define a BarcodeItem object for encoding the postal code in USPS Postnet
BarcodeItem bc = new BarcodeItem(0.1, 0.95, 2.8, 0.65, BarcodeSymbology.Postnet, "");
//set data field
bc.DataField = "PostalCode";
//set narrow bar width
bc.BarWidth = 0.02;
//do not set a quiet zone
bc.QuietZone = new FrameThickness(0);
//set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.TopLeft;
//hide human readable text
bc.DisplayCode = false;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt1);
tLabel.Items.Add(txt2);
tLabel.Items.Add(txt3);
tLabel.Items.Add(txt4);
tLabel.Items.Add(txt5);
tLabel.Items.Add(bc);

//Create data source...
DataTable employees = new DataTable();
using (System.Data.OleDb.OleDbConnection conn = new System.Data.OleDb.OleDbConnection(@"Provider= Microsoft.JET.OLEDB.4.0; Data Source=C:\temp\DataBaseSample.mdb"))
{
    //open db connection...
    conn.Open();
    //execute db command...
    using (System.Data.OleDb.OleDbCommand cmd = new System.Data.OleDb.OleDbCommand("SELECT TOP 6 * FROM Employees", conn))
    {
        using (System.Data.OleDb.OleDbDataReader reader = cmd.ExecuteReader())
        {
            employees.Load(reader);
        }
    }
}

//set data source...
tLabel.DataSource = employees;

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Counters

Neodynamic ThermalLabel SDK for .NET
Counters
Counters allow you to index data items by a selected increment or decrement value, making the data items to increase or decrease by a specified value each time a label is printed. Counters can be used with TextItem as well as BarcodeItem objects.

How it works?
A counter is set up on a TextItem or BarcodeItem object by using the CounterStep property. The CounterStep property can be set up to any integer number which specifies the increment or decrement step depending on if the interger value is positive or negative.
When you enable counter feature on a TextItem or BarcodeItem object, the first integer number found in the Text property (for TextItem objects) or Code property (for BarcodeItem objects) when scanning from right to left starts the indexing portion of the data item. If the alphanumeric field to be indexed ends with an alpha character, the data is scanned, character by character, from right to left until a numeric character is encountered.

The following sample features a Counter scenario for printing 10 labels with a Barcode Code-128 for values ranging from "ABC1" to "ABC10" and a text decreasing from 50 to 49.

A label using Counters feature

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 3, 2)
tLabel.GapLength = 0.2

'Define a TextItem object
Dim txt As New TextItem(0.1, 0.1, 2.8, 0.5, "Decreasing 50")
'set counter step for decreasing by 1
txt.CounterStep = -1
'set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt.Font.Unit = FontUnit.Point
txt.Font.Size = 10

'Define a BarcodeItem object
Dim bc As New BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "ABC01")
'set counter step for increasing by 1
bc.CounterStep = 1
'set barcode size
bc.BarWidth = 0.02
bc.BarHeight = 0.75
'set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter
'set font
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
bc.Font.Unit = FontUnit.Point
bc.Font.Size = 10

'Add items to ThermalLabel object...
tLabel.Items.Add(txt)
tLabel.Items.Add(bc)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Set num of labels to generate
    pj.Copies = 10
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 3, 2);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txt = new TextItem(0.1, 0.1, 2.8, 0.5, "Decreasing 50");
//set counter step for decreasing by 1
txt.CounterStep = -1;
//set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt.Font.Unit = FontUnit.Point;
txt.Font.Size = 10;

//Define a BarcodeItem object
BarcodeItem bc = new BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "ABC01");
//set counter step for increasing by 1
bc.CounterStep = 1;
//set barcode size
bc.BarWidth = 0.02;
bc.BarHeight = 0.75;
//set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
//set font
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
bc.Font.Unit = FontUnit.Point;
bc.Font.Size = 10;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt);
tLabel.Items.Add(bc);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Set num of labels to generate
    pj.Copies = 10;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Data Masking

Neodynamic ThermalLabel SDK for .NET
Data Masking
Data Masking allows you to serialize data items by specifying a Mask string as well as an increment string. Data Masking can be used with TextItem as well as BarcodeItem

Data Masking consists of the following concepts:

  • The input Mask string: The mask string must be specified to the Mask property of any TextItem or BarcodeItem objects. The length of the mask string defines the number of characters to be formatted or masked. The mask is aligned to the characters in the target string (i.e. the Text property for TextItem objects or the Code property for BarcodeItem objects) starting with the right-most position. The input mask string must consist of the following characters (a.k.a. Mask String placeholders):

    • D or d (for Decimal numeric 0-9)
    • H or h (for Hexadecimal 0–9 plus a-f or A-F)
    • O or o (for Octal 0–7)
    • A or a (for Alphabetic A–Z or a–z)
    • N or n (for Alphanumeric 0–9 plus A–Z or a–z)
    • % (Ignore character or skip)

  • The Mask Increment string: The mask increment string (which is set up by using the MaskIncrement property of any TextItem or BarcodeItem object) is the value to be added to the text on each label to be printed and should match the Mask string length. The default value for the increment is equivalent to a decimal value of 1 (one). The string is composed of any characters defined in the input mask string. Invalid characters are assumed to be equal to a value of 0 (zero) in that characters position. The increment value for alphabetic strings start with 'A' or 'a' as the zero placeholder. This means to increment an alphabetic character by one, a value of 'B' or 'b' must be in the increment string. For characters that do not get incremented, the '%' character needs to be added to the increment string.

In the following sample, each label features a TextItem which will serialize a product model ranging from "MDL-001/X" to "MDL-010/X" (i.e. the sequence will be MDL-001/X, MDL-002/X, MDL-003/X, ..., MDL-010/X) and a BarcodeItem which will serialize a product ID ranging from "PRD000-A" to "PRD900-J" (i.e. the sequence will be "PRD000-A", "PRD100-B", "PRD200-C", ..., "PRD900-J") in Code 128 symbology.

A label using Data Masking feature

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 3, 2)
tLabel.GapLength = 0.2

'Define a TextItem object
Dim txt As New TextItem(0.1, 0.1, 2.8, 0.5, "MDL-001/X")
'set Mask info...
txt.Mask = "%%%%ddd%%"
txt.MaskIncrement = "1%%"
'set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
txt.Font.Unit = FontUnit.Point
txt.Font.Size = 10

'Define a BarcodeItem object
Dim bc As New BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "PRD000-A")
'set Mask info...
bc.Mask = "%%%d%%%A"
bc.MaskIncrement = "1%%%B"
'set barcode size
bc.BarWidth = 0.02
bc.BarHeight = 0.75
'set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter
'set font
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA
bc.Font.Unit = FontUnit.Point
bc.Font.Size = 10

'Add items to ThermalLabel object...
tLabel.Items.Add(txt)
tLabel.Items.Add(bc)

'Create a PrintJob object
Using pj As New PrintJob()
    'Create PrinterSettings object
    Dim myPrinter As New PrinterSettings()
    myPrinter.Communication.CommunicationType = CommunicationType.USB
    myPrinter.Dpi = 203
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL
    myPrinter.PrinterName = "Zebra  TLP2844-Z"

    'Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter
    'Set num of labels to generate
    pj.Copies = 10
    'Print ThermalLabel object...
    pj.Print(tLabel)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 3, 2);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txt = new TextItem(0.1, 0.1, 2.8, 0.5, "MDL-001/X");
//set Mask info...
txt.Mask = "%%%%ddd%%";
txt.MaskIncrement = "1%%";
//set font
txt.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
txt.Font.Unit = FontUnit.Point;
txt.Font.Size = 10;

//Define a BarcodeItem object
BarcodeItem bc = new BarcodeItem(0.1, 0.57, 2.8, 1.3, BarcodeSymbology.Code128, "PRD000-A");
//set Mask info...
bc.Mask = "%%%d%%%A";
bc.MaskIncrement = "1%%%B";
//set barcode size
bc.BarWidth = 0.02;
bc.BarHeight = 0.75;
//set barcode alignment
bc.BarcodeAlignment = BarcodeAlignment.MiddleCenter;
//set font
bc.Font.Name = Neodynamic.SDK.Printing.Font.NativePrinterFontA;
bc.Font.Unit = FontUnit.Point;
bc.Font.Size = 10;

//Add items to ThermalLabel object...
tLabel.Items.Add(txt);
tLabel.Items.Add(bc);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Create PrinterSettings object
    PrinterSettings myPrinter = new PrinterSettings();
    myPrinter.Communication.CommunicationType = CommunicationType.USB;
    myPrinter.Dpi = 203;
    myPrinter.ProgrammingLanguage = ProgrammingLanguage.ZPL;
    myPrinter.PrinterName = "Zebra  TLP2844-Z";

    //Set PrinterSettings to PrintJob
    pj.PrinterSettings = myPrinter;
    //Set num of labels to generate
    pj.Copies = 10;
    //Print ThermalLabel object...
    pj.Print(tLabel);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Export Labels to Image

Neodynamic ThermalLabel SDK for .NET
Export Labels to Image

In this section

  • Supported Output Image Formats
  • How Labels to Image Works?
  • Labels to Image samples
Supported Output Image Formats
ThermalLabel SDK allows you to export/save the output label content to most popular raster image formats. The supported image formats are BMP (Bitmap), GIF (Graphics Interchange Format), JPEG (Joint Photographic Experts Group), PNG (Portable Network Graphics), and TIFF (Tagged Image File Format) including multi-page TIFF file.

How Labels to Image Works?
The object in charge for the exportation is the PrintJob. That means if you want to export a ThermalLabel object to some image file (or Stream), then you will need to do that by using a PrintJob object. Depending on the PrintJob settings, it is possible that after exportation, you get one file, multiple files or a multipage image file (only if TIFF format is selected).

To export a print job to an image file or stream you need to invoke the ExportToImage() method of the PrintJob object. That method asks you to specify the file or stream where to save the output content, the out image format by using an ImageSettings object, and an output resolution (DPI).

READ THIS CAREFULLY

Depending on the PrintJob & ThermalLabel scenario (Data Binding, Counters, Data Masking, Simgle Label, etc.) and the selected output Image Format, it is possible you get one file, multiple files or a multi-page image file.
  • If the scenario is Data Binding, Counters or Data Masking i.e. the PrintJob generates more than one ThermalLabel output, then you will get the following:
    • If you selected TIFF image format, you'll get One multi-page TIFF file .
    • If you selected BMP, GIF, PNG, or JPEG image formats, you'll get single image files As Many As thermal label objects. Those files will be named with the name specified to ExportToImage() method indexed from 1 to N.
  • If the PrintJob generates just one ThermalLabel output, then you will get One only image file in the specified format.

Labels to Image samples
Example #1: The following code will export a single ThermalLabel object to JPEG format at 300dpi

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test")
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Create a PrintJob object
Using pj As New PrintJob()
    'Save output to image...
    pj.ExportToImage(tLabel, "c:\temp\myLabel.jpg", New ImageSettings(ImageFormat.Jpeg), 300)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test");

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Save output to image...
    pj.ExportToImage(tLabel, @"c:\temp\myLabel.jpg", new ImageSettings(ImageFormat.Jpeg), 300);
}

Example #2: The following code will export a ThermalLabel object using Counters to a Multi-page TIFF file at 300dpi

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 1, 0.5, "This is a Counter: 0")
'Set counter
txtItem.CounterStep = 1
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set counter
bcItem.CounterStep = 1
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Create a PrintJob object
Using pj As New PrintJob()
    'Set number of copies
    pj.Copies = 5
    'Save output to image...
    pj.ExportToImage(tLabel, "c:\temp\myLabels.tif", New ImageSettings(ImageFormat.Tiff), 300)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test");
//Set counter
txtItem.CounterStep = 1;

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set counter
bcItem.CounterStep = 1;
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Set number of copies
    pj.Copies = 5;
    //Save output to image...
    pj.ExportToImage(tLabel, @"c:\temp\myLabels.tif", new ImageSettings(ImageFormat.Tiff), 300);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Export Labels to PDF

Neodynamic ThermalLabel SDK for .NET
Export Labels to PDF

In this section

  • Export to PDF Overview
  • Labels to PDF sample
Export to PDF Overview
ThermalLabel SDK allows you to export/save the output label content to Adobe PDF document format.

The object in charge for the exportation is the PrintJob. That means if you want to export a ThermalLabel object to a PDF document file (or Stream), then you will need to do that by using a PrintJob object. The generated PDF document will contain one page or multiple pages depending on the PrintJob settings.

To export a print job to a PDF file or stream you need to invoke the ExportToPdf() method of the PrintJob object. That method asks you to specify the file or stream where to save the output content and an output resolution (DPI).

Labels to PDF samples
Example #1: The following code will export a single ThermalLabel object to PDF format at 300dpi

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test")
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Create a PrintJob object
Using pj As New PrintJob()
    'Save output to PDF...
    pj.ExportToPdf(tLabel, "c:\temp\myLabel.pdf", 300)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test");

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Save output to PDF...
    pj.ExportToPdf(tLabel, @"c:\temp\myLabel.pdf", 300);
}

Example #2: The following code will export a ThermalLabel object using Counters to a Multi-page PDF file at 300dpi

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 1, 0.5, "This is a Counter: 0")
'Set counter
txtItem.CounterStep = 1
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set counter
bcItem.CounterStep = 1
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Create a PrintJob object
Using pj As New PrintJob()
    'Set number of copies
    pj.Copies = 5
    'Save output to PDF...
    pj.ExportToPdf(tLabel, "c:\temp\myLabels.pdf", 300)
End Using

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 1, 0.5, "Thermal Label Test");
//Set counter
txtItem.CounterStep = 1;

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set counter
bcItem.CounterStep = 1;
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Create a PrintJob object
using (PrintJob pj = new PrintJob())
{
    //Set number of copies
    pj.Copies = 5;
    //Save output to PDF...
    pj.ExportToPdf(tLabel, @"c:\temp\myLabels.pdf", 300);
}

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


ThermalLabel XML Templates

Neodynamic ThermalLabel SDK for .NET
ThermalLabel XML Templates
ThermalLabel SDK features XML Template i.e. you can instruct a ThermalLabel object for exporting/importing the label definition in XML text format. The following is a simple ThermalLabel object which can be saved as an XML Template by invoking the GetXmlTemplate() method:

Visual Basic

'Define a ThermalLabel object and set unit to inch and label size
Dim tLabel As New ThermalLabel(UnitType.Inch, 4, 3)
tLabel.GapLength = 0.2
'Define a TextItem object
Dim txtItem As New TextItem(0.2, 0.2, 2.5, 0.5, "Thermal Label Test")
'Define a BarcodeItem object
Dim bcItem As New BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345")
'Set bars height to .75inch
bcItem.BarHeight = 0.75
'Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104
'Add items to ThermalLabel object...
tLabel.Items.Add(txtItem)
tLabel.Items.Add(bcItem)
'Save label to XML file
System.IO.File.WriteAllText("C:\temp\myLabel.xml", tLabel.GetXmlTemplate())

C#

//Define a ThermalLabel object and set unit to inch and label size
ThermalLabel tLabel = new ThermalLabel(UnitType.Inch, 4, 3);
tLabel.GapLength = 0.2;

//Define a TextItem object
TextItem txtItem = new TextItem(0.2, 0.2, 2.5, 0.5, "Thermal Label Test");

//Define a BarcodeItem object
BarcodeItem bcItem = new BarcodeItem(0.2, 1, 2, 1, BarcodeSymbology.Code128, "ABC 12345");
//Set bars height to .75inch
bcItem.BarHeight = 0.75;
//Set bars width to 0.0104inch
bcItem.BarWidth = 0.0104;

//Add items to ThermalLabel object...
tLabel.Items.Add(txtItem);
tLabel.Items.Add(bcItem);

//Save label to XML file
System.IO.File.WriteAllText(@"C:\temp\myLabel.xml", tLabel.GetXmlTemplate());

The XML file will contain the following label description.

<?xml version="1.0" encoding="utf-8"?>
<ThermalLabel Width="4" Height="3" GapLength="0.2" UnitType="Inch" LabelsPerRow="1" LabelsHorizontalGapLength="0">
  <Items>
    <TextItem Name="" X="0.2" Y="0.2" DataField="" CacheItemId="" Width="2.5" Height="0.5" Text="Thermal Label Test" Font="NativePrinterFontA,10,Point,,,False" />
    <BarcodeItem Name="" X="0.2" Y="1" DataField="" CacheItemId="" Width="2" Height="1" Symbology="Code128" Code="ABC 12345" BarHeight="0.75" BearerBarThickness="0.05" EanUpcSupplementCode="0" Font="NativePrinterFontA,10,Point,,,False" QuietZone="0.1,0,0.1,0.02" TextFont="NativePrinterFontA,10,Point,,,False" />
  </Items>
</ThermalLabel>

Loading a ThermalLabel XML Template
For loading a ThermalLabel XML Template, you must invoke the LoadXmlTemplate() method on a ThermalLabel object. You must pass to the LoadXmlTemplate() method a string representation of the XML Template content. For example, based on the sample above, you can load the XML Template from a file as follows:

Visual Basic

'Create a ThermalLabel object for loading the XML template into it
Dim tLabel As New ThermalLabel()
'Load XML Template File
tLabel.LoadXmlTemplate(System.IO.File.ReadAllText("c:\temp\myLabel.xml"))

C#

//Create a ThermalLabel object for loading the XML template into it
ThermalLabel tLabel = new ThermalLabel();
//Load XML Template File
tLabel.LoadXmlTemplate(System.IO.File.ReadAllText(@"c:\temp\myLabel.xml"));

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Neodynamic.SDK.Printing Namespace

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Neodynamic.SDK.Printing Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarcodeException | Represents errors that occur during barcode generation process
Public class | BarcodeItem | Represents a barcode item. It can draw linear (1D), Postal and 2D barcodes.
Public class | BarcodeUtils | BarcodeUtils provides additional utilities related to barcode generation.
Public class | CircleShapeItem | Represents an ellipse rectangle shape item.
Public class | ClosedShapeItem | An abstract base class that provides basic functionality for any descended ClosedShapeItem class.
Public class | EllipseShapeItem | Represents an ellipse rectangle shape item.
Public class | Font | Encapsulates the font properties of texts.
Public class | FontConverter | Converts Font objects from one data type to another. Access the FontConverter class through the TypeDescriptor object.
Public class | FontNameConverter |
Public class | FrameThickness | Represents the thickness for the four sides of a frame.
Public class | FrameThicknessConverter | Converts FrameThickness objects from one data type to another. Access the FrameThicknessConverter class through the TypeDescriptor object.
Public class | ImageItem | Represents an image, picture or graphic item.
Public class | ImageSettings | Defines image output settings for saving labels to raster image formats
Public class | Item | An abstract base class that provides basic functionality for any descended Item class.
Public class | ItemCollection | Provides a collection of Item objects.
Public class | LineShapeItem | Represents a line shape item. Use it to create horizontal, vertical and diagonal lines.
Public class | LiteralItem | Represents a literal text item. Use it for sending raw printer commands.
Public class | MonochromeSettings | Defines monochrome settings used for Black/White conversion.
Public class | MultipleSelectionItem | Represents a collection of Item-derived classes which have been selected on the visual thermal label editor by the end-user.
Public class | PrinterCommunication | Specifies information about printer communication like USB, Serial Port RS-232, Parallel Port (Centronics), and Network (Ethernet) connectivity.
Public class | PrinterSettings | Specifies information about the thermal printer used to print out a label, including printer id/name, printing resolution (DPI) and device connection like USB, Serial Port, Parallel Port and Network.
Public class | PrintJob | Specifies information about how a thermal label is printed, including the printer device settings, label orientation, number of copies, etc.
Public class | PrintUtils | It specifies printing jobs that are not directly related to label printing but printer commands.
Public class | RectangleCornerRadius | Represents the radii of a rectangle's corners.
Public class | RectangleCornerRadiusConverter | Converts RectangleCornerRadius objects from one data type to another. Access the CornerRadiusConverter class through the TypeDescriptor object.
Public class | RectangleShapeItem | Represents a rectangle shape item.
Public class | RFIDTagItem | Represents a RFID Tag item. Use it for encoding a RFID Tag in a label.
Public class | ShapeItem | An abstract base class that provides basic functionality for any descended ShapeItem class.
Public class | TextItem | Represents a text item.
Public class | ThermalLabel | Represents a thermal label object.
Public class | WebPrintJob | Specifies information about how a thermal label is printed, including the printer device settings, label orientation, number of copies, etc. to be used in ASP.NET scenarios by using the TLClientPrint utility.
Public class | WebPrintJobGroup | A group of WebPrintJob objects to be used in ASP.NET scenarios through the TLClientPrint utility.

Enumerations

 | Enumeration | Description
Public enumeration | AztecCodeFormat | Specifies the Aztec Code Format to use on that symbology.
Public enumeration | BarcodeAlignment | Specifies the alignment of the barcode
Public enumeration | BarcodeErrorBehavior | Specifies what output type will be generated if an error occurs during barcode rendering.
Public enumeration | BarcodeSizing | Describes how barcode content is resized to fill its allocated space.
Public enumeration | BarcodeSymbology | Specifies the Barcode Symbology/Standard to be used.
Public enumeration | BarcodeTextAlignment | Specifies the text alignment on the barcode
Public enumeration | BearerBarStyle | Specifies the bearer bars' type that must be drawn on the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcode symbologies.
Public enumeration | CodabarStartStopChar | Specifies the start and stop character for Codabar symbology.
Public enumeration | Code128 | Specifies the characters set to use in the Code 128 symbology.
Public enumeration | Code16k | Specifies the mode to use for Code16k symbology.
Public enumeration | Color | Specifies a color.
Public enumeration | CommunicationType | Specifies the printer communication type.
Public enumeration | DataMatrixEncoding | Specifies the DataMatrix Encoding to use on that symbology.
Public enumeration | DataMatrixFormat | Specifies the DataMatrix Format to use on that symbology.
Public enumeration | DitherMethod | Specifies the dithering method to be used for Black/White conversion.
Public enumeration | FIM | Specifies the facing identification mark (FIM) pattern to use on that symbology.
Public enumeration | Flip | Specifies the axis used to flip the image.
Public enumeration | FontUnit | Specifies the unit of measure for Font objects.
Public enumeration | HanXinCodeEncoding | Specifies the Han Xin Code Encoding to use on that symbology.
Public enumeration | HanXinCodeErrorCorrectionLevel | Specifies the Error Correction Level to apply for Han Xin Code symbology.
Public enumeration | HanXinCodeVersion | Specifies the Han Xin Code Version to use on that symbology. Version 1 (23 x 23 modules) to Version 84 (189 x 189 modules) increasing in steps of two modules per side.
Public enumeration | ImageFormat | Specifies the supported image formats
Public enumeration | Isbt128DataStructure | Specifies the ISBT 128 Data Structures.
Public enumeration | ItfHmark | Specifies the seven type of H marks for ITF symbology.
Public enumeration | LineOrientation | Specifies the orientation for line shape items.
Public enumeration | LockAspectRatio | Specifies how image's proportions are maintained.
Public enumeration | MaxiCodeModes | Specifies the MaxiCode modes.
Public enumeration | MediaTracking | Specifies the media is being used (continuous or non-continuous) for purposes of tracking.
Public enumeration | MediaType | Specifies the type of media being used in the printer.
Public enumeration | MicroPdf417Version | Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.
Public enumeration | MicroQRCodeVersion | Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.
Public enumeration | MsiChecksum | Specifies the checksum method used for MSI barcodes
Public enumeration | Pdf417CompactionType | Specifies the Compaction Type to apply for PDF417 symbology.
Public enumeration | Pdf417ErrorCorrection | Specifies the Error Correction Level to apply for PDF417 symbology.
Public enumeration | PixelFormat | Specifies the supported pixel formats
Public enumeration | PrintMode | Specifies the print mode for the thermal printer.
Public enumeration | PrintOrientation | Specifies the page orientation used to print the thermal label.
Public enumeration | ProgrammingLanguage | Specifies the core programming language supported by the thermal printer.
Public enumeration | QRCodeEncoding | Specifies the QR Code Encoding to use on that symbology.
Public enumeration | QRCodeErrorCorrectionLevel | Specifies the Error Correction Level to apply for QR Code symbology.
Public enumeration | QRCodeVersion | Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.
Public enumeration | RFIDTagDataFormat | The RFID Tag Data Formats
Public enumeration | Supplement | Specifies the supplement type to use with EAN and UPC symbologies.
Public enumeration | TelepenEncoding | Specifies the Telepen Encoding to use on that symbology.
Public enumeration | TextAlignment | Specifies the text alignment.
Public enumeration | TextSizing | Specifies the text sizing.
Public enumeration | TiffCompression | Specifies the supported compression schemes for Tagged Image File Format (TIFF) bitmap images.
Public enumeration | UnitType | Specifies the unit of measurement.
Public enumeration | UpcE | Specifies the number system to use for UPC-E symbology.
Neodynamic ThermalLabel SDK for .NET Documentation

Send comments on this topic to support@neodynamic.com

Copyright © 2003-2015 Neodynamic - All rights reserved.


AztecCodeFormat Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
AztecCodeFormat Enumeration
See Also Send Feedback
Specifies the Aztec Code Format to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum AztecCodeFormat
Visual Basic
Public Enumeration AztecCodeFormat
Visual C++
public enum class AztecCodeFormat

Members

Member name | Value | Description
Auto | 0 |
C15X15Compact | 1 |
C19X19 | 2 |
C19X19Compact | 3 |
C23X23 | 4 |
C23X23Compact | 5 |
C27X27 | 6 |
C27X27Compact | 7 |
C31X31 | 8 |
C37X37 | 9 |
C41X41 | 10 |
C45X45 | 11 |
C49X49 | 12 |
C53X53 | 13 |
C57X57 | 14 |
C61X61 | 15 |
C67X67 | 16 |
C71X71 | 17 |
C75X75 | 18 |
C79X79 | 19 |
C83X83 | 20 |
C87X87 | 21 |
C91X91 | 22 |
C95X95 | 23 |
C101X101 | 24 |
C105X105 | 25 |
C109X109 | 26 |
C113X113 | 27 |
C117X117 | 28 |
C121X121 | 29 |
C125X125 | 30 |
C131X131 | 31 |
C135X135 | 32 |
C139X139 | 33 |
C143X143 | 34 |
C147X147 | 35 |
C151X151 | 36 |

See Also

Neodynamic.SDK.Printing Namespace


BarcodeAlignment Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeAlignment Enumeration
See Also Send Feedback
Specifies the alignment of the barcode

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BarcodeAlignment
Visual Basic
Public Enumeration BarcodeAlignment
Visual C++
public enum class BarcodeAlignment

Members

Member name | Value | Description
BottomCenter | 512 |
BottomLeft | 256 |
BottomRight | 1024 |
MiddleCenter | 32 |
MiddleLeft | 16 |
MiddleRight | 64 |
TopCenter | 2 |
TopLeft | 1 |
TopRight | 4 |

See Also


BarcodeErrorBehavior Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeErrorBehavior Enumeration
See Also Send Feedback
Specifies what output type will be generated if an error occurs during barcode rendering.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BarcodeErrorBehavior
Visual Basic
Public Enumeration BarcodeErrorBehavior
Visual C++
public enum class BarcodeErrorBehavior

Members

Member name | Value | Description
BlankImage | 0 | A blank image will be rendered.
ThrowException | 2 | An Exception will be thrown.

See Also


BarcodeException Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Class
Members See Also Send Feedback
Represents errors that occur during barcode generation process

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class BarcodeException : Exception
Visual Basic
Public Class BarcodeException
    Inherits Exception
Visual C++
public ref class BarcodeException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Neodynamic.SDK.Printing..::..BarcodeException

See Also

BarcodeException Members


BarcodeException Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Members
BarcodeException Class Constructors Fields Properties See Also Send Feedback

The BarcodeException type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeException(Int32) |
Public method | BarcodeException(Int32, String) |

Fields

Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |

Properties

 | Name | Description
Public property | ErrorCode |
 | Errors |

See Also

BarcodeException Class


BarcodeException Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor
BarcodeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BarcodeException(Int32) |
Public method | BarcodeException(Int32, String) |

See Also

BarcodeException Class
BarcodeException Members


BarcodeException Constructor (Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor (Int32)
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeException(
    int errorCode
)
Visual Basic
Public Sub New (
    errorCode As Integer
)
Visual C++
public:
BarcodeException(
    int errorCode
)

Parameters

errorCode
Type: System..::..Int32

See Also

BarcodeException Class
BarcodeException Members
BarcodeException Overload


BarcodeException Constructor (Int32, String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor (Int32, String)
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeException(
    int errorCode,
    string message
)
Visual Basic
Public Sub New (
    errorCode As Integer,
    message As String
)
Visual C++
public:
BarcodeException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::..Int32
message
Type: System..::..String

See Also

BarcodeException Class
BarcodeException Members
BarcodeException Overload


BarcodeException Fields

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Fields
BarcodeException Class See Also Send Feedback

The BarcodeException type exposes the following members.

Fields

Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |

See Also

BarcodeException Class


BarcodeException.CHECKSUM_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CHECKSUM_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CHECKSUM_GEN_FAILED
Visual Basic
Public Const CHECKSUM_GEN_FAILED As Integer
Visual C++
public:
literal int CHECKSUM_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.CODE_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CODE_GEN_FAILED
Visual Basic
Public Const CODE_GEN_FAILED As Integer
Visual C++
public:
literal int CODE_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CODE_NOT_VALID
Visual Basic
Public Const CODE_NOT_VALID As Integer
Visual C++
public:
literal int CODE_NOT_VALID

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID_IN_CC Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID_IN_CC Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CODE_NOT_VALID_IN_CC
Visual Basic
Public Const CODE_NOT_VALID_IN_CC As Integer
Visual C++
public:
literal int CODE_NOT_VALID_IN_CC

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
Visual Basic
Public Const CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT As Integer
Visual C++
public:
literal int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.CODE_NULL_OR_EMPTY Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NULL_OR_EMPTY Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int CODE_NULL_OR_EMPTY
Visual Basic
Public Const CODE_NULL_OR_EMPTY As Integer
Visual C++
public:
literal int CODE_NULL_OR_EMPTY

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.DATA_OVERFLOW Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..DATA_OVERFLOW Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int DATA_OVERFLOW
Visual Basic
Public Const DATA_OVERFLOW As Integer
Visual C++
public:
literal int DATA_OVERFLOW

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.DATAMATRIX_INVALID_FILE_ID Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..DATAMATRIX_INVALID_FILE_ID Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int DATAMATRIX_INVALID_FILE_ID
Visual Basic
Public Const DATAMATRIX_INVALID_FILE_ID As Integer
Visual C++
public:
literal int DATAMATRIX_INVALID_FILE_ID

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED
Visual Basic
Public Const PROCESS_TILDE_FAILED As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_DEC As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_HEX As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_DM_MACRO As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_MACRO

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_PR Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_DM_PR Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_DM_PR
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_DM_PR As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_PR

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.PROCESS_TILDE_FAILED_INVALID_ECI Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_ECI Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_ECI
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_ECI As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_ECI

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.REED_SOLOMON_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..REED_SOLOMON_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const int REED_SOLOMON_GEN_FAILED
Visual Basic
Public Const REED_SOLOMON_GEN_FAILED As Integer
Visual C++
public:
literal int REED_SOLOMON_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Properties
BarcodeException Class See Also Send Feedback

The BarcodeException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode |
 | Errors |

See Also

BarcodeException Class


BarcodeException.ErrorCode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..ErrorCode Property
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int ErrorCode { get; set; }
Visual Basic
Public Property ErrorCode As Integer
    Get
    Set
Visual C++
public:
property int ErrorCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members


BarcodeException.Errors Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..Errors Property
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static Dictionary<int, string> Errors { get; }
Visual Basic
Public Shared ReadOnly Property Errors As Dictionary(Of Integer, String)
    Get
Visual C++
public:
static property Dictionary<int, String^>^ Errors {
    Dictionary<int, String^>^ get ();
}

Property Value

Type: Dictionary <(Of <(<' Int32, String >)>)>

See Also

BarcodeException Class
BarcodeException Members


BarcodeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Class
Members See Also Send Feedback
Represents a barcode item. It can draw linear (1D), Postal and 2D barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class BarcodeItem : Item
Visual Basic
Public Class BarcodeItem
    Inherits Item
Visual C++
public ref class BarcodeItem : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..BarcodeItem

See Also

BarcodeItem Members


BarcodeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Members
BarcodeItem Class Constructors Methods Fields Properties Events See Also Send Feedback

The BarcodeItem type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeItem()()()() | Initializes a new instance of the BarcodeItem class.
Public method | BarcodeItem(Double, Double, Double, Double, BarcodeSymbology, String) | Initializes a new instance of the BarcodeItem class with the specified location, barcode symbology and value to encode.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current BarcodeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | GetAutoSize | Gets the size of the barcode that fits its content.
Public method | UpdateFrom | Updates this BarcodeItem object with the properties of the specified BarcodeItem object. (Overrides Item..::..UpdateFrom(Item).)

Fields

Name | Description
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
EOT | End Of Transmission character (ASCII 4).
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
GS | Group Separator character (ASCII 29).
RS | Record Separator character (ASCII 30).

Properties

 | Name | Description
Public property | AddChecksum | Gets or sets whether checksum must be calculated and attached to the value to encode. Default value is true
Public property | AztecCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Aztec Code symbology. Default value is "ISO-8859-1"
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default value is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology. Default value is Auto
Public property | AztecCodeModuleSize | Gets or sets the Aztec Code module size. The module is each indivual black square which composes the whole of Aztec Code symbol. Default value is 0.0417
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when Aztec Code is being generated. Default value is false
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only. Default value is -1 (disabled)
Public property | BackColor | Gets or sets the background color of the barcode. Default value is White
Public property | BarcodeAlignment | Gets or sets the barcode alignment. Default value is TopLeft
Public property | BarcodePadding | Gets or sets the amount of space between the container's border and the barcode content. The barcode padding is used only when Sizing property is set up to Fill. Default value is 0 (zero)
Public property | BarColor | Gets or sets the bars' color of the barcode. Default value is Black.
Public property | BarHeight | Gets or sets the bars' height of the barcode. Default value is 0.5
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value. Default value is 2
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. Default value is 0.0104
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment. Default value is 0 (zero)
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes. Default value is None
Public property | BearerBarThickness | Gets or sets the bearer bars' thickness. Default value is 0.05
Public property | BorderColor | Gets or sets the color of the border of the rectangle container. Default value is Black
Public property | BorderThickness | Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D. Default value is A
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D. Default value is A
Public property | Code | Gets or sets the value to encode. Default value is "1234567890"
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C. Default value is Auto
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2. Default value is Mode1
Public property | Code39FullAsciiMode | Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 39 symbology should be used. Default value is true
Public property | Code93FullAsciiMode | Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 93 symbology should be used. Default value is true
Public property | CodeAlignment | Gets or sets the text alignment for Code property. Default value is BelowCenter
Public property | CodeFormatPattern | Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | CounterStep | Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)
Public property | CounterUseLeadingZeros | Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | DataMatrixByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default value is "ISO-8859-1"
Public property | DataMatrixEncoding | Gets or sets the Data Matrix Encoding to use on that symbology. Default value is Auto
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments. Default value is "001001"
Public property | DataMatrixFormat | Gets or sets the Data Matrix Format to use on that symbology. Default value is Auto
Public property | DataMatrixModuleSize | Gets or sets the Data Matrix module size. The module is each indivual black square which composes the whole of Data Matrix symbol. Default value is 0.0417
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character '~' should be processed when Data Matrix code is being generated. Default value is false
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16. Default value is 1
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property. Default value is 1
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode on the barcode. Default value is true
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed on the barcode. Default value is true
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed on the barcode. Default value is true
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | EanUpcDisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the EAN/UPC barcodes. Default value is false
Public property | EanUpcGuardBar | Gets or sets whether guard bars must be drawn for EAN and UPC symbologies. Default value is true
Public property | EanUpcGuardBarHeight | Gets or sets the guard bars' height. In general, this value should be a bit greater than the BarHeight property. Default value is 0.55
Public property | EanUpcMagnificationFactor | Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies. Default value is None
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies. Default value is "0"
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the barcode and its supplement. Default value is 0.15
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. Default value is 0.15
Public property | ErrorBehavior | Gets or sets what output type Barcode Professional will generate if an error occurs during barcode rendering. Default is BlankImage.
Public property | Font | Gets the Font object for the value to encode i.e. the Code property. Default value is NativePrinterFontA, 10pt
Public property | ForeColor | Gets or sets the foreground color of the value to encode. Default value is Black
Public property | HanXinCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.
Public property | HanXinCodeEncoding | Gets or sets the Han Xin Code Encoding to use on that symbology.
Public property | HanXinCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for Han Xin Code symbology.
Public property | HanXinCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeProcessTilde | Gets or sets whether tilde character should be processed when Han Xin Code is being generated.
Public property | HanXinCodeVersion | Gets or sets the Han Xin Code Version to use on that symbology.
Public property | Height | Gets or sets the height of the rectangle container. Default value is 0.5
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore. Default value is true
Public property | HibcUseIsoIec15434Encoding | Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.
Public property | HideIfEmpty | Gets or sets whether the barcode symbol is not displayed or printed if the value to encode is empty. Default value is false
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property. Default value is an empty string
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated. Default value is DS001
Public property | Itf14LeftHMark | Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.
Public property | Itf14RightHMark | Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Mask | Gets or sets the input Mask for the value to encode. Default value is an empty string
Public property | MaskIncrement | Gets or sets the mask increment. The increment is the value to be added to the value to encode on each label to be printed. Default value is an empty string
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode. Default value is Mode4
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when MaxiCode code is being generated. Default value is false
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8. Default value is 1
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property. Default value is 1
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated. Default value is Auto
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology. Default value is Auto
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology. Default value is OneMod10
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one). Default value is 0 (zero)
Public property | Pdf417ByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default value is "ISO-8859-1".
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology. Default value is (Auto)
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology. Default value is Auto
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology. Default value is Level2
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments. Default value is "000"
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology. Default value is 0 (Auto)
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999. Default value is 0 (zero)
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property. Default value is 0 (zero)
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed). Default value is false
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. Default value is 0.0417
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. Default value is 0.0625
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. Default value is 0.0208
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. Default value is 0.1
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. Default value is 0.2
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn on the barcode. Default value is true
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. Default value is 0.0313
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. Default value is 0.08
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. Default value is 0.0208
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. Default value is 0.1
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. Default value is 0.2
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | QRCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default value is "ISO-8859-1"
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology. Default value is Auto
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology. Default value is M
Public property | QRCodeModuleSize | Gets or sets the QR Code module size. The module is each indivual black square which composes the whole of QR Code symbol. Default value is 0.0417
Public property | QRCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when QR Code is being generated. Default value is false
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology. Default value is Auto
Public property | QuietZone | Gets or sets the left, top, right and bottom quiet zones. Default value is 0.1, 0, 0.1, 0.02
Public property | RotationAngle | Gets or sets the rotation angle, in 90 degrees increments only, to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default value is 4.
Public property | Sizing | Gets or sets the barcode sizing. Default value is None
Public property | Symbology | Gets or sets the barcode symbology/standard to generate. Default value is Code39
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology. Default value is Ascii
Public property | Text | Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode. Default value is an empty string.
Public property | TextAlignment | Gets or sets the text alignment for Text property. Default value is AboveCenter
Public property | TextFont | Gets the Font object for the Text property. Default value is NativePrinterFontA, 10pt
Public property | TextForeColor | Gets or sets the foreground color of the text. Default value is Black
Public property | TextFormatPattern | Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology. Default value is System0
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties. Default value is false
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology. Default value is A
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn. Default value is 10
Public property | Width | Gets or sets the width of the rectangle container. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

BarcodeItem Class


BarcodeItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Constructor
BarcodeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BarcodeItem()()()() | Initializes a new instance of the BarcodeItem class.
Public method | BarcodeItem(Double, Double, Double, Double, BarcodeSymbology, String) | Initializes a new instance of the BarcodeItem class with the specified location, barcode symbology and value to encode.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Constructor
BarcodeItem Class See Also Send Feedback
Initializes a new instance of the BarcodeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeItem()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeItem()

See Also

BarcodeItem Class
BarcodeItem Members
BarcodeItem Overload


BarcodeItem Constructor (Double, Double, Double, Double, BarcodeSymbology, String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Constructor (Double, Double, Double, Double, BarcodeSymbology, String)
BarcodeItem Class See Also Send Feedback
Initializes a new instance of the BarcodeItem class with the specified location, barcode symbology and value to encode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeItem(
    double x,
    double y,
    double width,
    double height,
    BarcodeSymbology symbology,
    string code
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double,
    symbology As BarcodeSymbology,
    code As String
)
Visual C++
public:
BarcodeItem(
    double x,
    double y,
    double width,
    double height,
    BarcodeSymbology symbology,
    String^ code
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
width
Type: System..::..Double
The width of the item container.
height
Type: System..::..Double
The height of the item container.
symbology
Type: Neodynamic.SDK.Printing..::..BarcodeSymbology
The barcode symbology/standard to be generated.
code
Type: System..::..String
The value to encode.

See Also

BarcodeItem Class
BarcodeItem Members
BarcodeItem Overload


BarcodeItem Fields

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Fields
BarcodeItem Class See Also Send Feedback

The BarcodeItem type exposes the following members.

Fields

Name | Description
AI2 | Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI3 | Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI4 | Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
AI5 | Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.
CODE128_FNC1 | Function 1 Symbol Character (FNC1) used by Code 128 barcodes.
CODE128_FNC2 | Function 2 Symbol Character (FNC2) used by Code 128 barcodes.
CODE128_FNC3 | Function 3 Symbol Character (FNC3) used by Code 128 barcodes.
CODE128_FNC4 | Function 4 Symbol Character (FNC4) used by Code 128 barcodes.
EOT | End Of Transmission character (ASCII 4).
FNC1 | Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.
GS | Group Separator character (ASCII 29).
RS | Record Separator character (ASCII 30).

See Also

BarcodeItem Class


BarcodeItem.AI2 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AI2 Field
BarcodeItem Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 2-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char AI2
Visual Basic
Public Const AI2 As Char
Visual C++
public:
literal wchar_t AI2

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AI3 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AI3 Field
BarcodeItem Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 3-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char AI3
Visual Basic
Public Const AI3 As Char
Visual C++
public:
literal wchar_t AI3

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AI4 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AI4 Field
BarcodeItem Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 4-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char AI4
Visual Basic
Public Const AI4 As Char
Visual C++
public:
literal wchar_t AI4

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AI5 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AI5 Field
BarcodeItem Class See Also Send Feedback
Special character used to specify that an Application Identifier (AI) is 5-digits long. Used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char AI5
Visual Basic
Public Const AI5 As Char
Visual C++
public:
literal wchar_t AI5

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CODE128_FNC1 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CODE128_FNC1 Field
BarcodeItem Class See Also Send Feedback
Function 1 Symbol Character (FNC1) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char CODE128_FNC1
Visual Basic
Public Const CODE128_FNC1 As Char
Visual C++
public:
literal wchar_t CODE128_FNC1

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CODE128_FNC2 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CODE128_FNC2 Field
BarcodeItem Class See Also Send Feedback
Function 2 Symbol Character (FNC2) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char CODE128_FNC2
Visual Basic
Public Const CODE128_FNC2 As Char
Visual C++
public:
literal wchar_t CODE128_FNC2

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CODE128_FNC3 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CODE128_FNC3 Field
BarcodeItem Class See Also Send Feedback
Function 3 Symbol Character (FNC3) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char CODE128_FNC3
Visual Basic
Public Const CODE128_FNC3 As Char
Visual C++
public:
literal wchar_t CODE128_FNC3

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CODE128_FNC4 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CODE128_FNC4 Field
BarcodeItem Class See Also Send Feedback
Function 4 Symbol Character (FNC4) used by Code 128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char CODE128_FNC4
Visual Basic
Public Const CODE128_FNC4 As Char
Visual C++
public:
literal wchar_t CODE128_FNC4

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EOT Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EOT Field
BarcodeItem Class See Also Send Feedback
End Of Transmission character (ASCII 4).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char EOT
Visual Basic
Public Const EOT As Char
Visual C++
public:
literal wchar_t EOT

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.FNC1 Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..FNC1 Field
BarcodeItem Class See Also Send Feedback
Function 1 Symbol Character (FNC1) used by GS1-128 and UCC/EAN-128 barcodes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char FNC1
Visual Basic
Public Const FNC1 As Char
Visual C++
public:
literal wchar_t FNC1

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.GS Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..GS Field
BarcodeItem Class See Also Send Feedback
Group Separator character (ASCII 29).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char GS
Visual Basic
Public Const GS As Char
Visual C++
public:
literal wchar_t GS

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.RS Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..RS Field
BarcodeItem Class See Also Send Feedback
Record Separator character (ASCII 30).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const char RS
Visual Basic
Public Const RS As Char
Visual C++
public:
literal wchar_t RS

Field Value

Type: Char

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Methods
BarcodeItem Class See Also Send Feedback

The BarcodeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current BarcodeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | GetAutoSize | Gets the size of the barcode that fits its content.
Public method | UpdateFrom | Updates this BarcodeItem object with the properties of the specified BarcodeItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

BarcodeItem Class


BarcodeItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Clone Method
BarcodeItem Class See Also Send Feedback
Creates a copy of the current BarcodeItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current BarcodeItem.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..ConvertToUnit Method
BarcodeItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.GetAutoSize Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..GetAutoSize Method
BarcodeItem Class See Also Send Feedback
Gets the size of the barcode that fits its content.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Size GetAutoSize()
Visual Basic
Public Function GetAutoSize As Size
Visual C++
public:
Size GetAutoSize()

Return Value

Type: Size
The size of the barcode that fits its content.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..UpdateFrom Method
BarcodeItem Class See Also Send Feedback
Updates this BarcodeItem object with the properties of the specified BarcodeItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The BarcodeItem object that is used for updating this BarcodeItem object.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Properties
BarcodeItem Class See Also Send Feedback

The BarcodeItem type exposes the following members.

Properties

 | Name | Description
Public property | AddChecksum | Gets or sets whether checksum must be calculated and attached to the value to encode. Default value is true
Public property | AztecCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Aztec Code symbology. Default value is "ISO-8859-1"
Public property | AztecCodeErrorCorrection | Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default value is 23.
Public property | AztecCodeFormat | Gets or sets the Aztec Code Format to use on that symbology. Default value is Auto
Public property | AztecCodeModuleSize | Gets or sets the Aztec Code module size. The module is each indivual black square which composes the whole of Aztec Code symbol. Default value is 0.0417
Public property | AztecCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when Aztec Code is being generated. Default value is false
Public property | AztecCodeRune | Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only. Default value is -1 (disabled)
Public property | BackColor | Gets or sets the background color of the barcode. Default value is White
Public property | BarcodeAlignment | Gets or sets the barcode alignment. Default value is TopLeft
Public property | BarcodePadding | Gets or sets the amount of space between the container's border and the barcode content. The barcode padding is used only when Sizing property is set up to Fill. Default value is 0 (zero)
Public property | BarColor | Gets or sets the bars' color of the barcode. Default value is Black.
Public property | BarHeight | Gets or sets the bars' height of the barcode. Default value is 0.5
Public property | BarRatio | Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value. Default value is 2
Public property | BarWidth | Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. Default value is 0.0104
Public property | BarWidthAdjustment | Gets or sets the Bar Width Adjustment. Default value is 0 (zero)
Public property | BearerBarStyle | Gets or set the bearer bars' type that must be drawn with the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes. Default value is None
Public property | BearerBarThickness | Gets or sets the bearer bars' thickness. Default value is 0.05
Public property | BorderColor | Gets or sets the color of the border of the rectangle container. Default value is Black
Public property | BorderThickness | Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | CodabarStartChar | Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D. Default value is A
Public property | CodabarStopChar | Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D. Default value is A
Public property | Code | Gets or sets the value to encode. Default value is "1234567890"
Public property | Code128CharSet | Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C. Default value is Auto
Public property | Code16kMode | Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2. Default value is Mode1
Public property | Code39FullAsciiMode | Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 39 symbology should be used. Default value is true
Public property | Code93FullAsciiMode | Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 93 symbology should be used. Default value is true
Public property | CodeAlignment | Gets or sets the text alignment for Code property. Default value is BelowCenter
Public property | CodeFormatPattern | Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | CounterStep | Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)
Public property | CounterUseLeadingZeros | Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | DataMatrixByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default value is "ISO-8859-1"
Public property | DataMatrixEncoding | Gets or sets the Data Matrix Encoding to use on that symbology. Default value is Auto
Public property | DataMatrixFileId | Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments. Default value is "001001"
Public property | DataMatrixFormat | Gets or sets the Data Matrix Format to use on that symbology. Default value is Auto
Public property | DataMatrixModuleSize | Gets or sets the Data Matrix module size. The module is each indivual black square which composes the whole of Data Matrix symbol. Default value is 0.0417
Public property | DataMatrixProcessTilde | Gets or sets whether tilde character '~' should be processed when Data Matrix code is being generated. Default value is false
Public property | DataMatrixSymbolCount | Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16. Default value is 1
Public property | DataMatrixSymbolIndex | Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property. Default value is 1
Public property | DisplayChecksum | Gets or sets whether checksum value must be displayed after the value to encode on the barcode. Default value is true
Public property | DisplayCode | Gets or sets whether the value to encode must be displayed on the barcode. Default value is true
Public property | DisplayStartStopChar | Gets or sets whether start and stop characters must be displayed on the barcode. Default value is true
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | EanUpcDisplayLightMarginIndicator | Gets or sets whether light margin indicators must be displayed in the EAN/UPC barcodes. Default value is false
Public property | EanUpcGuardBar | Gets or sets whether guard bars must be drawn for EAN and UPC symbologies. Default value is true
Public property | EanUpcGuardBarHeight | Gets or sets the guard bars' height. In general, this value should be a bit greater than the BarHeight property. Default value is 0.55
Public property | EanUpcMagnificationFactor | Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).
Public property | EanUpcSupplement | Gets or sets the supplement type to use with EAN and UPC symbologies. Default value is None
Public property | EanUpcSupplementCode | Gets or sets the supplement value for EAN and UPC symbologies. Default value is "0"
Public property | EanUpcSupplementSeparation | Gets or sets the gap separation between the barcode and its supplement. Default value is 0.15
Public property | EanUpcSupplementTopMargin | Gets or sets the height of the margin above the EAN/UPC supplement bars. Default value is 0.15
Public property | ErrorBehavior | Gets or sets what output type Barcode Professional will generate if an error occurs during barcode rendering. Default is BlankImage.
Public property | Font | Gets the Font object for the value to encode i.e. the Code property. Default value is NativePrinterFontA, 10pt
Public property | ForeColor | Gets or sets the foreground color of the value to encode. Default value is Black
Public property | HanXinCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.
Public property | HanXinCodeEncoding | Gets or sets the Han Xin Code Encoding to use on that symbology.
Public property | HanXinCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for Han Xin Code symbology.
Public property | HanXinCodeModuleSize | Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.
Public property | HanXinCodeProcessTilde | Gets or sets whether tilde character should be processed when Han Xin Code is being generated.
Public property | HanXinCodeVersion | Gets or sets the Han Xin Code Version to use on that symbology.
Public property | Height | Gets or sets the height of the rectangle container. Default value is 0.5
Public property | HibcFormatHumanReadableText | Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore. Default value is true
Public property | HibcUseIsoIec15434Encoding | Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.
Public property | HideIfEmpty | Gets or sets whether the barcode symbol is not displayed or printed if the value to encode is empty. Default value is false
Public property | HumanReadableText | Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property. Default value is an empty string
Public property | Isbt128DataStructure | Gets or sets the ISBT 128 Data Structure to be generated. Default value is DS001
Public property | Itf14LeftHMark | Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.
Public property | Itf14RightHMark | Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Mask | Gets or sets the input Mask for the value to encode. Default value is an empty string
Public property | MaskIncrement | Gets or sets the mask increment. The increment is the value to be added to the value to encode on each label to be printed. Default value is an empty string
Public property | MaxiCodeMode | Gets or sets the MaxiCode mode. Default value is Mode4
Public property | MaxiCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when MaxiCode code is being generated. Default value is false
Public property | MaxiCodeSymbolCount | Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8. Default value is 1
Public property | MaxiCodeSymbolIndex | Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property. Default value is 1
Public property | MicroPdf417Version | Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated. Default value is Auto
Public property | MicroQRCodeVersion | Gets or sets the Micro QR Code Version to use on that symbology. Default value is Auto
Public property | MsiChecksum | Gets or sets the checksum mode to be used on MSI symbology. Default value is OneMod10
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | Pdf417AspectRatio | Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one). Default value is 0 (zero)
Public property | Pdf417ByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default value is "ISO-8859-1".
Public property | Pdf417Columns | Gets or sets the number of columns to use for PDF417 symbology. Default value is (Auto)
Public property | Pdf417CompactionType | Gets or sets the Compaction Type to apply for PDF417 symbology. Default value is Auto
Public property | Pdf417ErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for PDF417 symbology. Default value is Level2
Public property | Pdf417FileId | Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments. Default value is "000"
Public property | Pdf417Rows | Gets or sets the number of rows to use for PDF417 symbology. Default value is 0 (Auto)
Public property | Pdf417SegmentCount | Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999. Default value is 0 (zero)
Public property | Pdf417SegmentIndex | Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property. Default value is 0 (zero)
Public property | Pdf417Truncated | Gets or sets whether the right side of PDF417 barcode is truncated (removed). Default value is false
Public property | PharmacodeBarsSpacing | Gets or sets the gap between Pharmacode bars. Default value is 0.0417
Public property | PharmacodeThickBarWidth | Gets or sets the width of Pharmacode Thick Bars. Default value is 0.0625
Public property | PharmacodeThinBarWidth | Gets or sets the width of Pharmacode Thin Bars. Default value is 0.0208
Public property | PlanetHeightShortBar | Gets or sets the short bars' height of Planet symbology. Default value is 0.1
Public property | PlanetHeightTallBar | Gets or sets the tall bars' height of Planet symbology. Default value is 0.2
Public property | Postal4StateAddStartStopChar | Gets or sets whether start and stop characters must be added and drawn on the barcode. Default value is true
Public property | Postal4StateBarsSpacing | Gets or sets the gap spacing between bars. Default value is 0.0313
Public property | Postal4StateTrackerBarHeight | Gets or sets the tracker bar's height. Default value is 0.08
Public property | Postal4StateTrackerBarWidth | Gets or sets the tracker bar's width. Default value is 0.0208
Public property | PostnetHeightShortBar | Gets or sets the short bars' height of Postnet symbology. Default value is 0.1
Public property | PostnetHeightTallBar | Gets or sets the tall bars' height of Postnet symbology. Default value is 0.2
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | QRCodeByteEncodingName | Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default value is "ISO-8859-1"
Public property | QRCodeEncoding | Gets or sets the QR Code Encoding to use on that symbology. Default value is Auto
Public property | QRCodeErrorCorrectionLevel | Gets or sets the Error Correction Level to apply for QR Code symbology. Default value is M
Public property | QRCodeModuleSize | Gets or sets the QR Code module size. The module is each indivual black square which composes the whole of QR Code symbol. Default value is 0.0417
Public property | QRCodeProcessTilde | Gets or sets whether tilde character '~' should be processed when QR Code is being generated. Default value is false
Public property | QRCodeVersion | Gets or sets the QR Code Version to use on that symbology. Default value is Auto
Public property | QuietZone | Gets or sets the left, top, right and bottom quiet zones. Default value is 0.1, 0, 0.1, 0.02
Public property | RotationAngle | Gets or sets the rotation angle, in 90 degrees increments only, to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | SegmentsPerRow | Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default value is 4.
Public property | Sizing | Gets or sets the barcode sizing. Default value is None
Public property | Symbology | Gets or sets the barcode symbology/standard to generate. Default value is Code39
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | TelepenEncoding | Gets or sets the Telepen Encoding to use on that symbology. Default value is Ascii
Public property | Text | Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode. Default value is an empty string.
Public property | TextAlignment | Gets or sets the text alignment for Text property. Default value is AboveCenter
Public property | TextFont | Gets the Font object for the Text property. Default value is NativePrinterFontA, 10pt
Public property | TextForeColor | Gets or sets the foreground color of the text. Default value is Black
Public property | TextFormatPattern | Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UpcESystem | Gets or sets the number system to use for UPC-E symbology. Default value is System0
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | UseQuietZoneForText | Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties. Default value is false
Public property | UspsFimPattern | Gets or sets the USPS FIM pattern to use on that symbology. Default value is A
Public property | UspsHorizontalBarsCount | Gets or sets the number of horizontal bars to be drawn. Default value is 10
Public property | Width | Gets or sets the width of the rectangle container. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

BarcodeItem Class


BarcodeItem.AddChecksum Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AddChecksum Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether checksum must be calculated and attached to the value to encode. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool AddChecksum { get; set; }
Visual Basic
Public Property AddChecksum As Boolean
    Get
    Set
Visual C++
public:
property bool AddChecksum {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeByteEncodingName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeByteEncodingName Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Encoding Name (Code Page) to be used for Aztec Code symbology. Default value is "ISO-8859-1"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string AztecCodeByteEncodingName { get; set; }
Visual Basic
Public Property AztecCodeByteEncodingName As String
    Get
    Set
Visual C++
public:
property String^ AztecCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeErrorCorrection Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeErrorCorrection Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Error Correction Percentage to apply for Aztec Code symbology. Default value is 23.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int AztecCodeErrorCorrection { get; set; }
Visual Basic
Public Property AztecCodeErrorCorrection As Integer
    Get
    Set
Visual C++
public:
property int AztecCodeErrorCorrection {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeFormat Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeFormat Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Aztec Code Format to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public AztecCodeFormat AztecCodeFormat { get; set; }
Visual Basic
Public Property AztecCodeFormat As AztecCodeFormat
    Get
    Set
Visual C++
public:
property AztecCodeFormat AztecCodeFormat {
    AztecCodeFormat get ();
    void set (AztecCodeFormat value);
}

Property Value

Type: AztecCodeFormat

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeModuleSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeModuleSize Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Aztec Code module size. The module is each indivual black square which composes the whole of Aztec Code symbol. Default value is 0.0417

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double AztecCodeModuleSize { get; set; }
Visual Basic
Public Property AztecCodeModuleSize As Double
    Get
    Set
Visual C++
public:
property double AztecCodeModuleSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeProcessTilde Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeProcessTilde Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether tilde character '~' should be processed when Aztec Code is being generated. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool AztecCodeProcessTilde { get; set; }
Visual Basic
Public Property AztecCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool AztecCodeProcessTilde {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.AztecCodeRune Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..AztecCodeRune Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Aztec Code Rune value. It must be a value from 0 to 255 and is available for Aztec Code Compact Format only. Default value is -1 (disabled)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int AztecCodeRune { get; set; }
Visual Basic
Public Property AztecCodeRune As Integer
    Get
    Set
Visual C++
public:
property int AztecCodeRune {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BackColor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the background color of the barcode. Default value is White

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarcodeAlignment Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarcodeAlignment Property
BarcodeItem Class See Also Send Feedback
Gets or sets the barcode alignment. Default value is TopLeft

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeAlignment BarcodeAlignment { get; set; }
Visual Basic
Public Property BarcodeAlignment As BarcodeAlignment
    Get
    Set
Visual C++
public:
property BarcodeAlignment BarcodeAlignment {
    BarcodeAlignment get ();
    void set (BarcodeAlignment value);
}

Property Value

Type: BarcodeAlignment

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarcodePadding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarcodePadding Property
BarcodeItem Class See Also Send Feedback
Gets or sets the amount of space between the container's border and the barcode content. The barcode padding is used only when Sizing property is set up to Fill. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness BarcodePadding { get; set; }
Visual Basic
Public Property BarcodePadding As FrameThickness
    Get
    Set
Visual C++
public:
property FrameThickness^ BarcodePadding {
    FrameThickness^ get ();
    void set (FrameThickness^ value);
}

Property Value

Type: FrameThickness

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarColor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the bars' color of the barcode. Default value is Black.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color BarColor { get; set; }
Visual Basic
Public Property BarColor As Color
    Get
    Set
Visual C++
public:
property Color BarColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarHeight Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarHeight Property
BarcodeItem Class See Also Send Feedback
Gets or sets the bars' height of the barcode. Default value is 0.5

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BarHeight { get; set; }
Visual Basic
Public Property BarHeight As Double
    Get
    Set
Visual C++
public:
property double BarHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarRatio Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarRatio Property
BarcodeItem Class See Also Send Feedback
Gets or sets the wide bars' width compared to the narrow bars' width. In barcode terminology this is N value. Default value is 2

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BarRatio { get; set; }
Visual Basic
Public Property BarRatio As Double
    Get
    Set
Visual C++
public:
property double BarRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarWidth Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarWidth Property
BarcodeItem Class See Also Send Feedback
Gets or sets the narrow bars' width of the barcode. In barcode terminology this is X value. Default value is 0.0104

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BarWidth { get; set; }
Visual Basic
Public Property BarWidth As Double
    Get
    Set
Visual C++
public:
property double BarWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BarWidthAdjustment Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BarWidthAdjustment Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Bar Width Adjustment. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BarWidthAdjustment { get; set; }
Visual Basic
Public Property BarWidthAdjustment As Double
    Get
    Set
Visual C++
public:
property double BarWidthAdjustment {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BearerBarStyle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BearerBarStyle Property
BarcodeItem Class See Also Send Feedback
Gets or set the bearer bars' type that must be drawn with the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcodes. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BearerBarStyle BearerBarStyle { get; set; }
Visual Basic
Public Property BearerBarStyle As BearerBarStyle
    Get
    Set
Visual C++
public:
property BearerBarStyle BearerBarStyle {
    BearerBarStyle get ();
    void set (BearerBarStyle value);
}

Property Value

Type: BearerBarStyle

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BearerBarThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BearerBarThickness Property
BarcodeItem Class See Also Send Feedback
Gets or sets the bearer bars' thickness. Default value is 0.05

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BearerBarThickness { get; set; }
Visual Basic
Public Property BearerBarThickness As Double
    Get
    Set
Visual C++
public:
property double BearerBarThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BorderColor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the color of the border of the rectangle container. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.BorderThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..BorderThickness Property
BarcodeItem Class See Also Send Feedback
Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As FrameThickness
    Get
    Set
Visual C++
public:
property FrameThickness^ BorderThickness {
    FrameThickness^ get ();
    void set (FrameThickness^ value);
}

Property Value

Type: FrameThickness

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CodabarStartChar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CodabarStartChar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the start character for Codabar symbology. Possible values are: A, B, C or D. Default value is A

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CodabarStartStopChar CodabarStartChar { get; set; }
Visual Basic
Public Property CodabarStartChar As CodabarStartStopChar
    Get
    Set
Visual C++
public:
property CodabarStartStopChar CodabarStartChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}

Property Value

Type: CodabarStartStopChar

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CodabarStopChar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CodabarStopChar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the stop character for Codabar symbology. Possible values are: A, B, C or D. Default value is A

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CodabarStartStopChar CodabarStopChar { get; set; }
Visual Basic
Public Property CodabarStopChar As CodabarStartStopChar
    Get
    Set
Visual C++
public:
property CodabarStartStopChar CodabarStopChar {
    CodabarStartStopChar get ();
    void set (CodabarStartStopChar value);
}

Property Value

Type: CodabarStartStopChar

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Code Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Code Property
BarcodeItem Class See Also Send Feedback
Gets or sets the value to encode. Default value is "1234567890"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Code { get; set; }
Visual Basic
Public Property Code As String
    Get
    Set
Visual C++
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Code128CharSet Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Code128CharSet Property
BarcodeItem Class See Also Send Feedback
Gets or sets the characters set to use in the Code 128 symbology. Possible values are: Auto, A, B or C. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Code128 Code128CharSet { get; set; }
Visual Basic
Public Property Code128CharSet As Code128
    Get
    Set
Visual C++
public:
property Code128 Code128CharSet {
    Code128 get ();
    void set (Code128 value);
}

Property Value

Type: Code128

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Code16kMode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Code16kMode Property
BarcodeItem Class See Also Send Feedback
Gets or sets the mode to use for Code16k symbology. Modes supported are: Mode 0, 1, and 2. Default value is Mode1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Code16k Code16kMode { get; set; }
Visual Basic
Public Property Code16kMode As Code16k
    Get
    Set
Visual C++
public:
property Code16k Code16kMode {
    Code16k get ();
    void set (Code16k value);
}

Property Value

Type: Code16k

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Code39FullAsciiMode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Code39FullAsciiMode Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 39 symbology should be used. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Code39FullAsciiMode { get; set; }
Visual Basic
Public Property Code39FullAsciiMode As Boolean
    Get
    Set
Visual C++
public:
property bool Code39FullAsciiMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Code93FullAsciiMode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Code93FullAsciiMode Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the Full ASCII mode (a.k.a. Extended version) for Code 93 symbology should be used. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Code93FullAsciiMode { get; set; }
Visual Basic
Public Property Code93FullAsciiMode As Boolean
    Get
    Set
Visual C++
public:
property bool Code93FullAsciiMode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CodeAlignment Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CodeAlignment Property
BarcodeItem Class See Also Send Feedback
Gets or sets the text alignment for Code property. Default value is BelowCenter

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeTextAlignment CodeAlignment { get; set; }
Visual Basic
Public Property CodeAlignment As BarcodeTextAlignment
    Get
    Set
Visual C++
public:
property BarcodeTextAlignment CodeAlignment {
    BarcodeTextAlignment get ();
    void set (BarcodeTextAlignment value);
}

Property Value

Type: BarcodeTextAlignment

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CodeFormatPattern Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CodeFormatPattern Property
BarcodeItem Class See Also Send Feedback
Gets or sets the string pattern to format the Code property. The result of the format process is the one which will be encoded! Based on String.Format(). Default value is empty (Disabled).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string CodeFormatPattern { get; set; }
Visual Basic
Public Property CodeFormatPattern As String
    Get
    Set
Visual C++
public:
property String^ CodeFormatPattern {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CornerRadius Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CornerRadius Property
BarcodeItem Class See Also Send Feedback
Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As RectangleCornerRadius
    Get
    Set
Visual C++
public:
property RectangleCornerRadius^ CornerRadius {
    RectangleCornerRadius^ get ();
    void set (RectangleCornerRadius^ value);
}

Property Value

Type: RectangleCornerRadius

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CounterStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CounterStep Property
BarcodeItem Class See Also Send Feedback
Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int CounterStep { get; set; }
Visual Basic
Public Property CounterStep As Integer
    Get
    Set
Visual C++
public:
property int CounterStep {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.CounterUseLeadingZeros Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..CounterUseLeadingZeros Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool CounterUseLeadingZeros { get; set; }
Visual Basic
Public Property CounterUseLeadingZeros As Boolean
    Get
    Set
Visual C++
public:
property bool CounterUseLeadingZeros {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixByteEncodingName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixByteEncodingName Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Encoding Name (Code Page) to be used for DataMatrix in Byte Compaction mode. Default value is "ISO-8859-1"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataMatrixByteEncodingName { get; set; }
Visual Basic
Public Property DataMatrixByteEncodingName As String
    Get
    Set
Visual C++
public:
property String^ DataMatrixByteEncodingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixEncoding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixEncoding Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Data Matrix Encoding to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public DataMatrixEncoding DataMatrixEncoding { get; set; }
Visual Basic
Public Property DataMatrixEncoding As DataMatrixEncoding
    Get
    Set
Visual C++
public:
property DataMatrixEncoding DataMatrixEncoding {
    DataMatrixEncoding get ();
    void set (DataMatrixEncoding value);
}

Property Value

Type: DataMatrixEncoding

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixFileId Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixFileId Property
BarcodeItem Class See Also Send Feedback
Gets or sets the File ID of the Data Matrix symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 001 and 254) and must be the same for all data segments. Default value is "001001"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataMatrixFileId { get; set; }
Visual Basic
Public Property DataMatrixFileId As String
    Get
    Set
Visual C++
public:
property String^ DataMatrixFileId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixFormat Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixFormat Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Data Matrix Format to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public DataMatrixFormat DataMatrixFormat { get; set; }
Visual Basic
Public Property DataMatrixFormat As DataMatrixFormat
    Get
    Set
Visual C++
public:
property DataMatrixFormat DataMatrixFormat {
    DataMatrixFormat get ();
    void set (DataMatrixFormat value);
}

Property Value

Type: DataMatrixFormat

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixModuleSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixModuleSize Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Data Matrix module size. The module is each indivual black square which composes the whole of Data Matrix symbol. Default value is 0.0417

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double DataMatrixModuleSize { get; set; }
Visual Basic
Public Property DataMatrixModuleSize As Double
    Get
    Set
Visual C++
public:
property double DataMatrixModuleSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixProcessTilde Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixProcessTilde Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether tilde character '~' should be processed when Data Matrix code is being generated. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool DataMatrixProcessTilde { get; set; }
Visual Basic
Public Property DataMatrixProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool DataMatrixProcessTilde {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixSymbolCount Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixSymbolCount Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of Data Matrix symbols. Its value must be less than or equal to 16. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int DataMatrixSymbolCount { get; set; }
Visual Basic
Public Property DataMatrixSymbolCount As Integer
    Get
    Set
Visual C++
public:
property int DataMatrixSymbolCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DataMatrixSymbolIndex Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DataMatrixSymbolIndex Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Index for a Data Matrix symbol. Its value must be 1 up to 16 and must be less than or equal to the value in DataMatrixSegmentCount property. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int DataMatrixSymbolIndex { get; set; }
Visual Basic
Public Property DataMatrixSymbolIndex As Integer
    Get
    Set
Visual C++
public:
property int DataMatrixSymbolIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DisplayChecksum Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DisplayChecksum Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether checksum value must be displayed after the value to encode on the barcode. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool DisplayChecksum { get; set; }
Visual Basic
Public Property DisplayChecksum As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayChecksum {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DisplayCode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DisplayCode Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the value to encode must be displayed on the barcode. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool DisplayCode { get; set; }
Visual Basic
Public Property DisplayCode As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayCode {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.DisplayStartStopChar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..DisplayStartStopChar Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether start and stop characters must be displayed on the barcode. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool DisplayStartStopChar { get; set; }
Visual Basic
Public Property DisplayStartStopChar As Boolean
    Get
    Set
Visual C++
public:
property bool DisplayStartStopChar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcDisplayLightMarginIndicator Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcDisplayLightMarginIndicator Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether light margin indicators must be displayed in the EAN/UPC barcodes. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool EanUpcDisplayLightMarginIndicator { get; set; }
Visual Basic
Public Property EanUpcDisplayLightMarginIndicator As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcDisplayLightMarginIndicator {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcGuardBar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcGuardBar Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether guard bars must be drawn for EAN and UPC symbologies. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool EanUpcGuardBar { get; set; }
Visual Basic
Public Property EanUpcGuardBar As Boolean
    Get
    Set
Visual C++
public:
property bool EanUpcGuardBar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcGuardBarHeight Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcGuardBarHeight Property
BarcodeItem Class See Also Send Feedback
Gets or sets the guard bars' height. In general, this value should be a bit greater than the BarHeight property. Default value is 0.55

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double EanUpcGuardBarHeight { get; set; }
Visual Basic
Public Property EanUpcGuardBarHeight As Double
    Get
    Set
Visual C++
public:
property double EanUpcGuardBarHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcMagnificationFactor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcMagnificationFactor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Magnification Factor for EAN/UPC barcodes. Default is 0 (Zero/Disabled).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public float EanUpcMagnificationFactor { get; set; }
Visual Basic
Public Property EanUpcMagnificationFactor As Single
    Get
    Set
Visual C++
public:
property float EanUpcMagnificationFactor {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Remarks

EAN/UPC barcodes can be printed at various densities to accommodate a variety of printing and scanning processes. The significant dimensional parameter is X, the ideal width of a single module element. In Barcode Professional, this is specified with BarWidth property. For EAN/UPC symbols, the X-dimension at nominal size is 0.33 millimeter (= 0.013 inch). The "magnification factor" specifies the size of the barcode symbol as a whole by taking the nominal size as the 1.0 (100%) value.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcSupplement Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcSupplement Property
BarcodeItem Class See Also Send Feedback
Gets or sets the supplement type to use with EAN and UPC symbologies. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Supplement EanUpcSupplement { get; set; }
Visual Basic
Public Property EanUpcSupplement As Supplement
    Get
    Set
Visual C++
public:
property Supplement EanUpcSupplement {
    Supplement get ();
    void set (Supplement value);
}

Property Value

Type: Supplement

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcSupplementCode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcSupplementCode Property
BarcodeItem Class See Also Send Feedback
Gets or sets the supplement value for EAN and UPC symbologies. Default value is "0"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string EanUpcSupplementCode { get; set; }
Visual Basic
Public Property EanUpcSupplementCode As String
    Get
    Set
Visual C++
public:
property String^ EanUpcSupplementCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcSupplementSeparation Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcSupplementSeparation Property
BarcodeItem Class See Also Send Feedback
Gets or sets the gap separation between the barcode and its supplement. Default value is 0.15

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double EanUpcSupplementSeparation { get; set; }
Visual Basic
Public Property EanUpcSupplementSeparation As Double
    Get
    Set
Visual C++
public:
property double EanUpcSupplementSeparation {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.EanUpcSupplementTopMargin Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..EanUpcSupplementTopMargin Property
BarcodeItem Class See Also Send Feedback
Gets or sets the height of the margin above the EAN/UPC supplement bars. Default value is 0.15

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double EanUpcSupplementTopMargin { get; set; }
Visual Basic
Public Property EanUpcSupplementTopMargin As Double
    Get
    Set
Visual C++
public:
property double EanUpcSupplementTopMargin {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.ErrorBehavior Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..ErrorBehavior Property
BarcodeItem Class See Also Send Feedback
Gets or sets what output type Barcode Professional will generate if an error occurs during barcode rendering. Default is BlankImage.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeErrorBehavior ErrorBehavior { get; set; }
Visual Basic
Public Property ErrorBehavior As BarcodeErrorBehavior
    Get
    Set
Visual C++
public:
property BarcodeErrorBehavior ErrorBehavior {
    BarcodeErrorBehavior get ();
    void set (BarcodeErrorBehavior value);
}

Property Value

Type: BarcodeErrorBehavior

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Font Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Font Property
BarcodeItem Class See Also Send Feedback
Gets the Font object for the value to encode i.e. the Code property. Default value is NativePrinterFontA, 10pt

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font Font { get; }
Visual Basic
Public ReadOnly Property Font As Font
    Get
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

Property Value

Type: Font

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.ForeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..ForeColor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the foreground color of the value to encode. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeByteEncodingName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeByteEncodingName Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Encoding Name (Code Page) to be used for Han Xin Code Binary Byte Encoding mode. Default it ISO-8859-1.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string HanXinCodeByteEncodingName { get; set; }
Visual Basic
Public Property HanXinCodeByteEncodingName As String
    Get
    Set
Visual C++
public:
property String^ HanXinCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeEncoding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeEncoding Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Han Xin Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public HanXinCodeEncoding HanXinCodeEncoding { get; set; }
Visual Basic
Public Property HanXinCodeEncoding As HanXinCodeEncoding
    Get
    Set
Visual C++
public:
property HanXinCodeEncoding HanXinCodeEncoding {
    HanXinCodeEncoding get ();
    void set (HanXinCodeEncoding value);
}

Property Value

Type: HanXinCodeEncoding

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeErrorCorrectionLevel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeErrorCorrectionLevel Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Error Correction Level to apply for Han Xin Code symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel { get; set; }
Visual Basic
Public Property HanXinCodeErrorCorrectionLevel As HanXinCodeErrorCorrectionLevel
    Get
    Set
Visual C++
public:
property HanXinCodeErrorCorrectionLevel HanXinCodeErrorCorrectionLevel {
    HanXinCodeErrorCorrectionLevel get ();
    void set (HanXinCodeErrorCorrectionLevel value);
}

Property Value

Type: HanXinCodeErrorCorrectionLevel

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeModuleSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeModuleSize Property
BarcodeItem Class See Also Send Feedback
Gets or sets the module size. The unit of measure must be specified to BarcodeUnit property.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double HanXinCodeModuleSize { get; set; }
Visual Basic
Public Property HanXinCodeModuleSize As Double
    Get
    Set
Visual C++
public:
property double HanXinCodeModuleSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeProcessTilde Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeProcessTilde Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether tilde character should be processed when Han Xin Code is being generated.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool HanXinCodeProcessTilde { get; set; }
Visual Basic
Public Property HanXinCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool HanXinCodeProcessTilde {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HanXinCodeVersion Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HanXinCodeVersion Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Han Xin Code Version to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public HanXinCodeVersion HanXinCodeVersion { get; set; }
Visual Basic
Public Property HanXinCodeVersion As HanXinCodeVersion
    Get
    Set
Visual C++
public:
property HanXinCodeVersion HanXinCodeVersion {
    HanXinCodeVersion get ();
    void set (HanXinCodeVersion value);
}

Property Value

Type: HanXinCodeVersion

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Height Property
BarcodeItem Class See Also Send Feedback
Gets or sets the height of the rectangle container. Default value is 0.5

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HibcFormatHumanReadableText Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HibcFormatHumanReadableText Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the Human Readable Text is formatted as specified by HIBC Standards i.e. Zeros are displayed as Slashed-Zeros and the Space character is displayed as an Underscore. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool HibcFormatHumanReadableText { get; set; }
Visual Basic
Public Property HibcFormatHumanReadableText As Boolean
    Get
    Set
Visual C++
public:
property bool HibcFormatHumanReadableText {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HibcUseIsoIec15434Encoding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HibcUseIsoIec15434Encoding Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the ISO/IEC 15434 Protocol is used to encode the HIBC LIC or PAS Data Structures in 2D symbols. Default is False.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool HibcUseIsoIec15434Encoding { get; set; }
Visual Basic
Public Property HibcUseIsoIec15434Encoding As Boolean
    Get
    Set
Visual C++
public:
property bool HibcUseIsoIec15434Encoding {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HideIfEmpty Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HideIfEmpty Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the barcode symbol is not displayed or printed if the value to encode is empty. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool HideIfEmpty { get; set; }
Visual Basic
Public Property HideIfEmpty As Boolean
    Get
    Set
Visual C++
public:
property bool HideIfEmpty {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.HumanReadableText Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..HumanReadableText Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Human Readable Text to be displayed instead of the value to encode specified in the Code property. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string HumanReadableText { get; set; }
Visual Basic
Public Property HumanReadableText As String
    Get
    Set
Visual C++
public:
property String^ HumanReadableText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Isbt128DataStructure Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Isbt128DataStructure Property
BarcodeItem Class See Also Send Feedback
Gets or sets the ISBT 128 Data Structure to be generated. Default value is DS001

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Isbt128DataStructure Isbt128DataStructure { get; set; }
Visual Basic
Public Property Isbt128DataStructure As Isbt128DataStructure
    Get
    Set
Visual C++
public:
property Isbt128DataStructure Isbt128DataStructure {
    Isbt128DataStructure get ();
    void set (Isbt128DataStructure value);
}

Property Value

Type: Isbt128DataStructure

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Itf14LeftHMark Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Itf14LeftHMark Property
BarcodeItem Class See Also Send Feedback
Gets or sets the H mark type for the left side of ITF-14 barcode symbol. Default is None.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ItfHmark Itf14LeftHMark { get; set; }
Visual Basic
Public Property Itf14LeftHMark As ItfHmark
    Get
    Set
Visual C++
public:
property ItfHmark Itf14LeftHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}

Property Value

Type: ItfHmark

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Itf14RightHMark Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Itf14RightHMark Property
BarcodeItem Class See Also Send Feedback
Gets or sets the H mark type for the right side of ITF-14 barcode symbol. Default is None.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ItfHmark Itf14RightHMark { get; set; }
Visual Basic
Public Property Itf14RightHMark As ItfHmark
    Get
    Set
Visual C++
public:
property ItfHmark Itf14RightHMark {
    ItfHmark get ();
    void set (ItfHmark value);
}

Property Value

Type: ItfHmark

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Mask Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Mask Property
BarcodeItem Class See Also Send Feedback
Gets or sets the input Mask for the value to encode. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Mask { get; set; }
Visual Basic
Public Property Mask As String
    Get
    Set
Visual C++
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The length of the mask defines the number of characters to be formatted or masked. The mask is aligned to the characters in the target string starting with the right-most position.

The input mask can consist of the following characters: D or d (Decimal numeric 0-9) H or h (Hexadecimal 0–9 plus a-f or A-F) O or o (Octal 0–7) A or a (Alphabetic A–Z or a–z) N or n (Alphanumeric 0–9 plus A–Z or a–z) % (Ignore character or skip)

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MaskIncrement Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MaskIncrement Property
BarcodeItem Class See Also Send Feedback
Gets or sets the mask increment. The increment is the value to be added to the value to encode on each label to be printed. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string MaskIncrement { get; set; }
Visual Basic
Public Property MaskIncrement As String
    Get
    Set
Visual C++
public:
property String^ MaskIncrement {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The default value for the increment is equivalent to a decimal value of 1 (one). The string is composed of any characters defined in the input mask. Invalid characters are assumed to be equal to a value of 0 (zero) in that characters position.

The increment value for alphabetic strings start with 'A' or 'a' as the zero placeholder. This means to increment an alphabetic character by one, a value of 'B' or 'b' must be in the increment string.

For characters that do not get incremented, the '%' character needs to be added to the increment string.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MaxiCodeMode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MaxiCodeMode Property
BarcodeItem Class See Also Send Feedback
Gets or sets the MaxiCode mode. Default value is Mode4

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MaxiCodeModes MaxiCodeMode { get; set; }
Visual Basic
Public Property MaxiCodeMode As MaxiCodeModes
    Get
    Set
Visual C++
public:
property MaxiCodeModes MaxiCodeMode {
    MaxiCodeModes get ();
    void set (MaxiCodeModes value);
}

Property Value

Type: MaxiCodeModes

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MaxiCodeProcessTilde Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MaxiCodeProcessTilde Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether tilde character '~' should be processed when MaxiCode code is being generated. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool MaxiCodeProcessTilde { get; set; }
Visual Basic
Public Property MaxiCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool MaxiCodeProcessTilde {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MaxiCodeSymbolCount Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MaxiCodeSymbolCount Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of MaxiCode symbols in a Structured Appended format. Its value must be less than or equal to 8. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int MaxiCodeSymbolCount { get; set; }
Visual Basic
Public Property MaxiCodeSymbolCount As Integer
    Get
    Set
Visual C++
public:
property int MaxiCodeSymbolCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MaxiCodeSymbolIndex Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MaxiCodeSymbolIndex Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Symbol Index for a Structured Appended MaxiCode. Its value must be 1 up to 8 and must be less than the value in MaxiCodeSymbolCount property. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int MaxiCodeSymbolIndex { get; set; }
Visual Basic
Public Property MaxiCodeSymbolIndex As Integer
    Get
    Set
Visual C++
public:
property int MaxiCodeSymbolIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MicroPdf417Version Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MicroPdf417Version Property
BarcodeItem Class See Also Send Feedback
Gets or sets the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MicroPdf417Version MicroPdf417Version { get; set; }
Visual Basic
Public Property MicroPdf417Version As MicroPdf417Version
    Get
    Set
Visual C++
public:
property MicroPdf417Version MicroPdf417Version {
    MicroPdf417Version get ();
    void set (MicroPdf417Version value);
}

Property Value

Type: MicroPdf417Version

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MicroQRCodeVersion Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MicroQRCodeVersion Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Micro QR Code Version to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MicroQRCodeVersion MicroQRCodeVersion { get; set; }
Visual Basic
Public Property MicroQRCodeVersion As MicroQRCodeVersion
    Get
    Set
Visual C++
public:
property MicroQRCodeVersion MicroQRCodeVersion {
    MicroQRCodeVersion get ();
    void set (MicroQRCodeVersion value);
}

Property Value

Type: MicroQRCodeVersion

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.MsiChecksum Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..MsiChecksum Property
BarcodeItem Class See Also Send Feedback
Gets or sets the checksum mode to be used on MSI symbology. Default value is OneMod10

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MsiChecksum MsiChecksum { get; set; }
Visual Basic
Public Property MsiChecksum As MsiChecksum
    Get
    Set
Visual C++
public:
property MsiChecksum MsiChecksum {
    MsiChecksum get ();
    void set (MsiChecksum value);
}

Property Value

Type: MsiChecksum

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417AspectRatio Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417AspectRatio Property
BarcodeItem Class See Also Send Feedback
Gets or sets the ratio of the height to the overall width of the PDF417 symbol. Its value must be 0 (zero) up to 1 (one). Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Pdf417AspectRatio { get; set; }
Visual Basic
Public Property Pdf417AspectRatio As Double
    Get
    Set
Visual C++
public:
property double Pdf417AspectRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417ByteEncodingName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417ByteEncodingName Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Encoding Name (Code Page) to be used for PDF417 Byte Compaction mode. Default value is "ISO-8859-1".

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Pdf417ByteEncodingName { get; set; }
Visual Basic
Public Property Pdf417ByteEncodingName As String
    Get
    Set
Visual C++
public:
property String^ Pdf417ByteEncodingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417Columns Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417Columns Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of columns to use for PDF417 symbology. Default value is (Auto)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Pdf417Columns { get; set; }
Visual Basic
Public Property Pdf417Columns As Integer
    Get
    Set
Visual C++
public:
property int Pdf417Columns {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417CompactionType Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417CompactionType Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Compaction Type to apply for PDF417 symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Pdf417CompactionType Pdf417CompactionType { get; set; }
Visual Basic
Public Property Pdf417CompactionType As Pdf417CompactionType
    Get
    Set
Visual C++
public:
property Pdf417CompactionType Pdf417CompactionType {
    Pdf417CompactionType get ();
    void set (Pdf417CompactionType value);
}

Property Value

Type: Pdf417CompactionType

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417ErrorCorrectionLevel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417ErrorCorrectionLevel Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Error Correction Level to apply for PDF417 symbology. Default value is Level2

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel { get; set; }
Visual Basic
Public Property Pdf417ErrorCorrectionLevel As Pdf417ErrorCorrection
    Get
    Set
Visual C++
public:
property Pdf417ErrorCorrection Pdf417ErrorCorrectionLevel {
    Pdf417ErrorCorrection get ();
    void set (Pdf417ErrorCorrection value);
}

Property Value

Type: Pdf417ErrorCorrection

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417FileId Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417FileId Property
BarcodeItem Class See Also Send Feedback
Gets or sets the File ID of the Macro PDF417 symbol. Its value must be a sequence of codewords (Each codeword value must be a number between 000 and 899) and must be the same for all data segments. Default value is "000"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Pdf417FileId { get; set; }
Visual Basic
Public Property Pdf417FileId As String
    Get
    Set
Visual C++
public:
property String^ Pdf417FileId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417Rows Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417Rows Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of rows to use for PDF417 symbology. Default value is 0 (Auto)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Pdf417Rows { get; set; }
Visual Basic
Public Property Pdf417Rows As Integer
    Get
    Set
Visual C++
public:
property int Pdf417Rows {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417SegmentCount Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417SegmentCount Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of Macro PDF417 symbols. Its value must be less than or equal to 99999. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Pdf417SegmentCount { get; set; }
Visual Basic
Public Property Pdf417SegmentCount As Integer
    Get
    Set
Visual C++
public:
property int Pdf417SegmentCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417SegmentIndex Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417SegmentIndex Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Segment Index for a Macro PDF417 symbol. Its value must be 0 (zero) up to 99998 and must be less than the value in Pdf417SegmentCount property. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Pdf417SegmentIndex { get; set; }
Visual Basic
Public Property Pdf417SegmentIndex As Integer
    Get
    Set
Visual C++
public:
property int Pdf417SegmentIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Pdf417Truncated Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Pdf417Truncated Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether the right side of PDF417 barcode is truncated (removed). Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Pdf417Truncated { get; set; }
Visual Basic
Public Property Pdf417Truncated As Boolean
    Get
    Set
Visual C++
public:
property bool Pdf417Truncated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PharmacodeBarsSpacing Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PharmacodeBarsSpacing Property
BarcodeItem Class See Also Send Feedback
Gets or sets the gap between Pharmacode bars. Default value is 0.0417

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PharmacodeBarsSpacing { get; set; }
Visual Basic
Public Property PharmacodeBarsSpacing As Double
    Get
    Set
Visual C++
public:
property double PharmacodeBarsSpacing {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PharmacodeThickBarWidth Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PharmacodeThickBarWidth Property
BarcodeItem Class See Also Send Feedback
Gets or sets the width of Pharmacode Thick Bars. Default value is 0.0625

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PharmacodeThickBarWidth { get; set; }
Visual Basic
Public Property PharmacodeThickBarWidth As Double
    Get
    Set
Visual C++
public:
property double PharmacodeThickBarWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PharmacodeThinBarWidth Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PharmacodeThinBarWidth Property
BarcodeItem Class See Also Send Feedback
Gets or sets the width of Pharmacode Thin Bars. Default value is 0.0208

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PharmacodeThinBarWidth { get; set; }
Visual Basic
Public Property PharmacodeThinBarWidth As Double
    Get
    Set
Visual C++
public:
property double PharmacodeThinBarWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PlanetHeightShortBar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PlanetHeightShortBar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the short bars' height of Planet symbology. Default value is 0.1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PlanetHeightShortBar { get; set; }
Visual Basic
Public Property PlanetHeightShortBar As Double
    Get
    Set
Visual C++
public:
property double PlanetHeightShortBar {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PlanetHeightTallBar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PlanetHeightTallBar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the tall bars' height of Planet symbology. Default value is 0.2

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PlanetHeightTallBar { get; set; }
Visual Basic
Public Property PlanetHeightTallBar As Double
    Get
    Set
Visual C++
public:
property double PlanetHeightTallBar {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Postal4StateAddStartStopChar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Postal4StateAddStartStopChar Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether start and stop characters must be added and drawn on the barcode. Default value is true

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Postal4StateAddStartStopChar { get; set; }
Visual Basic
Public Property Postal4StateAddStartStopChar As Boolean
    Get
    Set
Visual C++
public:
property bool Postal4StateAddStartStopChar {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Postal4StateBarsSpacing Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Postal4StateBarsSpacing Property
BarcodeItem Class See Also Send Feedback
Gets or sets the gap spacing between bars. Default value is 0.0313

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Postal4StateBarsSpacing { get; set; }
Visual Basic
Public Property Postal4StateBarsSpacing As Double
    Get
    Set
Visual C++
public:
property double Postal4StateBarsSpacing {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Postal4StateTrackerBarHeight Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Postal4StateTrackerBarHeight Property
BarcodeItem Class See Also Send Feedback
Gets or sets the tracker bar's height. Default value is 0.08

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Postal4StateTrackerBarHeight { get; set; }
Visual Basic
Public Property Postal4StateTrackerBarHeight As Double
    Get
    Set
Visual C++
public:
property double Postal4StateTrackerBarHeight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Postal4StateTrackerBarWidth Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Postal4StateTrackerBarWidth Property
BarcodeItem Class See Also Send Feedback
Gets or sets the tracker bar's width. Default value is 0.0208

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Postal4StateTrackerBarWidth { get; set; }
Visual Basic
Public Property Postal4StateTrackerBarWidth As Double
    Get
    Set
Visual C++
public:
property double Postal4StateTrackerBarWidth {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PostnetHeightShortBar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PostnetHeightShortBar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the short bars' height of Postnet symbology. Default value is 0.1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PostnetHeightShortBar { get; set; }
Visual Basic
Public Property PostnetHeightShortBar As Double
    Get
    Set
Visual C++
public:
property double PostnetHeightShortBar {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.PostnetHeightTallBar Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..PostnetHeightTallBar Property
BarcodeItem Class See Also Send Feedback
Gets or sets the tall bars' height of Postnet symbology. Default value is 0.2

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double PostnetHeightTallBar { get; set; }
Visual Basic
Public Property PostnetHeightTallBar As Double
    Get
    Set
Visual C++
public:
property double PostnetHeightTallBar {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeByteEncodingName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeByteEncodingName Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Encoding Name (Code Page) to be used for QR Code Byte Compaction mode. Default value is "ISO-8859-1"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string QRCodeByteEncodingName { get; set; }
Visual Basic
Public Property QRCodeByteEncodingName As String
    Get
    Set
Visual C++
public:
property String^ QRCodeByteEncodingName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeEncoding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeEncoding Property
BarcodeItem Class See Also Send Feedback
Gets or sets the QR Code Encoding to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public QRCodeEncoding QRCodeEncoding { get; set; }
Visual Basic
Public Property QRCodeEncoding As QRCodeEncoding
    Get
    Set
Visual C++
public:
property QRCodeEncoding QRCodeEncoding {
    QRCodeEncoding get ();
    void set (QRCodeEncoding value);
}

Property Value

Type: QRCodeEncoding

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeErrorCorrectionLevel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeErrorCorrectionLevel Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Error Correction Level to apply for QR Code symbology. Default value is M

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel { get; set; }
Visual Basic
Public Property QRCodeErrorCorrectionLevel As QRCodeErrorCorrectionLevel
    Get
    Set
Visual C++
public:
property QRCodeErrorCorrectionLevel QRCodeErrorCorrectionLevel {
    QRCodeErrorCorrectionLevel get ();
    void set (QRCodeErrorCorrectionLevel value);
}

Property Value

Type: QRCodeErrorCorrectionLevel

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeModuleSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeModuleSize Property
BarcodeItem Class See Also Send Feedback
Gets or sets the QR Code module size. The module is each indivual black square which composes the whole of QR Code symbol. Default value is 0.0417

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double QRCodeModuleSize { get; set; }
Visual Basic
Public Property QRCodeModuleSize As Double
    Get
    Set
Visual C++
public:
property double QRCodeModuleSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeProcessTilde Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeProcessTilde Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether tilde character '~' should be processed when QR Code is being generated. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool QRCodeProcessTilde { get; set; }
Visual Basic
Public Property QRCodeProcessTilde As Boolean
    Get
    Set
Visual C++
public:
property bool QRCodeProcessTilde {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QRCodeVersion Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QRCodeVersion Property
BarcodeItem Class See Also Send Feedback
Gets or sets the QR Code Version to use on that symbology. Default value is Auto

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public QRCodeVersion QRCodeVersion { get; set; }
Visual Basic
Public Property QRCodeVersion As QRCodeVersion
    Get
    Set
Visual C++
public:
property QRCodeVersion QRCodeVersion {
    QRCodeVersion get ();
    void set (QRCodeVersion value);
}

Property Value

Type: QRCodeVersion

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.QuietZone Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..QuietZone Property
BarcodeItem Class See Also Send Feedback
Gets or sets the left, top, right and bottom quiet zones. Default value is 0.1, 0, 0.1, 0.02

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness QuietZone { get; set; }
Visual Basic
Public Property QuietZone As FrameThickness
    Get
    Set
Visual C++
public:
property FrameThickness^ QuietZone {
    FrameThickness^ get ();
    void set (FrameThickness^ value);
}

Property Value

Type: FrameThickness

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.RotationAngle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..RotationAngle Property
BarcodeItem Class See Also Send Feedback
Gets or sets the rotation angle, in 90 degrees increments only, to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Integer
    Get
    Set
Visual C++
public:
property int RotationAngle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not in 90 degrees increments.

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.SegmentsPerRow Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..SegmentsPerRow Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of segments per row to be used in GS1 DataBar Expanded Stacked or RSS Expanded Stacked symbologies. It must be an even number ranging from 2 up to 22. Default value is 4.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int SegmentsPerRow { get; set; }
Visual Basic
Public Property SegmentsPerRow As Integer
    Get
    Set
Visual C++
public:
property int SegmentsPerRow {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Sizing Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Sizing Property
BarcodeItem Class See Also Send Feedback
Gets or sets the barcode sizing. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeSizing Sizing { get; set; }
Visual Basic
Public Property Sizing As BarcodeSizing
    Get
    Set
Visual C++
public:
property BarcodeSizing Sizing {
    BarcodeSizing get ();
    void set (BarcodeSizing value);
}

Property Value

Type: BarcodeSizing

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Symbology Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Symbology Property
BarcodeItem Class See Also Send Feedback
Gets or sets the barcode symbology/standard to generate. Default value is Code39

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeSymbology Symbology { get; set; }
Visual Basic
Public Property Symbology As BarcodeSymbology
    Get
    Set
Visual C++
public:
property BarcodeSymbology Symbology {
    BarcodeSymbology get ();
    void set (BarcodeSymbology value);
}

Property Value

Type: BarcodeSymbology

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.TelepenEncoding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..TelepenEncoding Property
BarcodeItem Class See Also Send Feedback
Gets or sets the Telepen Encoding to use on that symbology. Default value is Ascii

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TelepenEncoding TelepenEncoding { get; set; }
Visual Basic
Public Property TelepenEncoding As TelepenEncoding
    Get
    Set
Visual C++
public:
property TelepenEncoding TelepenEncoding {
    TelepenEncoding get ();
    void set (TelepenEncoding value);
}

Property Value

Type: TelepenEncoding

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Text Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Text Property
BarcodeItem Class See Also Send Feedback
Gets or sets the additional text to show in the barcode image e.g. 'Product ID'. Note: This is not the value to encode. Default value is an empty string.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.TextAlignment Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..TextAlignment Property
BarcodeItem Class See Also Send Feedback
Gets or sets the text alignment for Text property. Default value is AboveCenter

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeTextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As BarcodeTextAlignment
    Get
    Set
Visual C++
public:
property BarcodeTextAlignment TextAlignment {
    BarcodeTextAlignment get ();
    void set (BarcodeTextAlignment value);
}

Property Value

Type: BarcodeTextAlignment

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.TextFont Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..TextFont Property
BarcodeItem Class See Also Send Feedback
Gets the Font object for the Text property. Default value is NativePrinterFontA, 10pt

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font TextFont { get; }
Visual Basic
Public ReadOnly Property TextFont As Font
    Get
Visual C++
public:
property Font^ TextFont {
    Font^ get ();
}

Property Value

Type: Font

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.TextForeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..TextForeColor Property
BarcodeItem Class See Also Send Feedback
Gets or sets the foreground color of the text. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color TextForeColor { get; set; }
Visual Basic
Public Property TextForeColor As Color
    Get
    Set
Visual C++
public:
property Color TextForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.TextFormatPattern Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..TextFormatPattern Property
BarcodeItem Class See Also Send Feedback
Gets or sets the string pattern to format the Text property. Based on String.Format(). Default value is empty (Disabled).

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string TextFormatPattern { get; set; }
Visual Basic
Public Property TextFormatPattern As String
    Get
    Set
Visual C++
public:
property String^ TextFormatPattern {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.UpcESystem Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..UpcESystem Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number system to use for UPC-E symbology. Default value is System0

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public UpcE UpcESystem { get; set; }
Visual Basic
Public Property UpcESystem As UpcE
    Get
    Set
Visual C++
public:
property UpcE UpcESystem {
    UpcE get ();
    void set (UpcE value);
}

Property Value

Type: UpcE

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.UseQuietZoneForText Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..UseQuietZoneForText Property
BarcodeItem Class See Also Send Feedback
Gets or sets whether quiet zones are used for drawing Text, Code and HumanReadableText properties. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool UseQuietZoneForText { get; set; }
Visual Basic
Public Property UseQuietZoneForText As Boolean
    Get
    Set
Visual C++
public:
property bool UseQuietZoneForText {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.UspsFimPattern Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..UspsFimPattern Property
BarcodeItem Class See Also Send Feedback
Gets or sets the USPS FIM pattern to use on that symbology. Default value is A

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FIM UspsFimPattern { get; set; }
Visual Basic
Public Property UspsFimPattern As FIM
    Get
    Set
Visual C++
public:
property FIM UspsFimPattern {
    FIM get ();
    void set (FIM value);
}

Property Value

Type: FIM

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.UspsHorizontalBarsCount Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..UspsHorizontalBarsCount Property
BarcodeItem Class See Also Send Feedback
Gets or sets the number of horizontal bars to be drawn. Default value is 10

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int UspsHorizontalBarsCount { get; set; }
Visual Basic
Public Property UspsHorizontalBarsCount As Integer
    Get
    Set
Visual C++
public:
property int UspsHorizontalBarsCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem..::..Width Property
BarcodeItem Class See Also Send Feedback
Gets or sets the width of the rectangle container. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

BarcodeItem Class
BarcodeItem Members


BarcodeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItem Events
BarcodeItem Class See Also Send Feedback

The BarcodeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

BarcodeItem Class


BarcodeSizing Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeSizing Enumeration
See Also Send Feedback
Describes how barcode content is resized to fill its allocated space.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BarcodeSizing
Visual Basic
Public Enumeration BarcodeSizing
Visual C++
public enum class BarcodeSizing

Members

Member name | Value | Description
None | 0 | The barcode content preserves size which is based on all barcode-related dimensions involved such as BarWidth, BarHeight, BarRatio, etc.
Fill | 1 | The barcode content is resized to fill the destination dimensions. The aspect ratio is not preserved.

See Also


BarcodeSymbology Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeSymbology Enumeration
See Also Send Feedback
Specifies the Barcode Symbology/Standard to be used.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BarcodeSymbology
Visual Basic
Public Enumeration BarcodeSymbology
Visual C++
public enum class BarcodeSymbology

Members

Member name | Value | Description
Codabar | 0 | Codabar a.k.a. ABC Codabar, CodaBar, USD-4, NW-7, Code 2 of 7, Monarch, Code-27, Ames code, Rationalized Codabar, 2 of 7 Code, ANSI/AIM Codabar, Uniform Symbology Specification Codabar, USS Codabar
Code11 | 1 | Code 11 a.k.a. Code11, USD-8, USD8
Code16k | 2 | Code 16K
Code39 | 3 | Code 39 a.k.a. ANSI/AIM Code 39, ANSI/AIM Code 39, Uniform Symbology Specification Code 39, USS Code 39, USS 39, Code 3/9, Code 3 of 9, USD-3, LOGMARS, Alpha39, Code 39 Extended, and Code 39 Full ASCII
Code93 | 4 | Code 93 a.k.a. ANSI/AIM Code 93, ANSI/AIM Code 93, Uniform Symbology Specification Code 93, USS Code 93, USS 93, Code 9/3, USS-93, USD-3, Code 93 Extended, and Code 93 Full ASCII
Code128 | 5 | Code 128 a.k.a. ANSI/AIM 128, ANSI/AIM Code 128, USS Code 128, Uniform Symbology Specification Code 128, Code 128 Code Set A, Code 128 Code Set B, Code 128 Code Set C, Code 128A, Code 128B, Code 128C
DataMatrix | 6 | Data Matrix a.k.a. Data Matrix ECC200
Ean8 | 7 | EAN-8 a.k.a. European Article Number 8, EAN-8 Supplement 5/Five-digit Add-On, EAN-8 Supplement 2/Two-digit Add-On, EAN-8+5, EAN-8+2, EAN8, EAN8+5, EAN13+2, UPC-8, GTIN-8, GS1-8
Ean13 | 8 | EAN-13 a.k.a. European Article Number 13, EAN-13 Supplement 5/Five-digit Add-On, EAN-13 Supplement 2/Two-digit Add-On, EAN-13+5, EAN-13+2, EAN13, EAN13+5, EAN13+2, UPC-13, GTIN-13, GS1-13
Industrial2of5 | 9 | Industrial 2 of 5 a.k.a. 2 of 5 Industrial, 2/5 Industrial, 2 of 5 Standard, Standard 2 of 5, 2/5 Standard, Code 2/5, 2 of 5, C 2 of 5
Interleaved2of5 | 10 | Interleaved 2 of 5 a.k.a. ANSI/AIM ITF 25, ANSI/AIM I-2/5, Uniform Symbology Specification ITF, USS ITF 2/5, ITF, I-2/5, 2 of 5 Interleaved, 2/5 Interleaved
Isbn | 11 | ISBN a.k.a. International Standard Book Number, Bookland EAN, ISBN-13, ISBN-10, ISBN+5, ISBN+2, ISBN Supplement 5/Five-digit Add-On, ISBN Supplement 2/Two-digit Add-On
Msi | 12 | MSI a.k.a. MSI/Plessey, Modified Plessey
Pdf417 | 13 | PDF417 a.k.a. Portable Data File 417, PDF 417, PDF417 Truncated
Planet | 14 | PLANET a.k.a. USPS PLANET Barcode, USPS Confirm Service Barcode
Postnet | 15 | POSTNET a.k.a. USPS POSTNET Barcode, USPS POSTal Numeric Encoding Technique Barcode, Delivery Point Barcode (DPBC), Postnet 3 of 5
UccEan128 | 16 | UCC/EAN-128 a.k.a. EAN-128, UCC-128, USS-128, GS1-128, UCC.EAN-128, GTIN-128
UpcA | 17 | UPC-A a.k.a. Universal Product Code version A, UPC-A Supplement 5/Five-digit Add-On, UPC-A Supplement 2/Two-digit Add-On, UPC-A+5, UPC-A+2, UPC Code, UPC Symbol, GTIN-12, GS1-12
UpcE | 18 | UPC-E a.k.a. Universal Product Code version E, UPC-E Supplement 5/Five-digit Add-On, UPC-E Supplement 2/Two-digit Add-On, UPC-E+5, UPC-E+2, UPC-E0, E0, UPC-E1, E1, GTIN-12 with lead 0, GS1-12
UspsOneCode4CB | 19 | USPS OneCode 4-State Customer Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
RoyalMail | 20 | British Royal Mail 4-State Customer Barcode a.k.a. RM4SCC, RoyalMail4SCC, British Royal Mail 4-State Customer Code and Royal Mail Barcode
AustraliaPost | 21 | Australia Post 4-state Barcode a.k.a. Australian 4-state postal barcode, Australia Post Customer Barcode
RoyalTpgPostKix | 22 | Royal TPG Post KIX 4-State Barcode a.k.a. Kix Barcode, Klantenindex (client index) Barcode, Dutch KIX 4-State Bar Code, Dutch KIX, TPG KIX, and TPGPOST KIX
Sscc18 | 23 | SSCC-18 a.k.a. UPC-128 Shipping Container Code, Code 128 UPC Shipping Container Code, Serial Shipping Container Code, UCC-128, EAN-18, NVE (Nummer der Versandeinheit)
Pzn | 24 | PZN a.k.a. Pharma-Zentral-Nummer, Pharmazentralnummer, Code PZN, CodePZN
DeutschePostLeitcode | 25 | Deutsche Post Leitcode Barcode a.k.a. German Postal 2 of 5 Leitcode, CodeLeitcode, Leitcode, Deutsche Post AG (DHL)
DeutschePostIdentcode | 26 | Deutsche Post Identcode Barcode a.k.a. German Postal 2 of 5 Identcode, Deutsche Post AG Identcode, Deutsche Frachtpost Identcode, Identcode, CodeIdentcode, Deutsche Post AG (DHL)
UspsTrayLabel | 27 | USPS Tray Label Barcode a.k.a. USPS 25 Tray label
UspsSackLabel | 28 | USPS Sack Label Barcode a.k.a. USPS 25 Sack label
EanVelocity | 29 | EAN-Velocity a.k.a. Velocity Barcode
SingaporePost | 30 | Singapore 4-State Postal Code Barcode a.k.a. Singapore 4-State Postal, SingPost 4-State, and SingPost Barcode
Jan8 | 31 | JAN-8 a.k.a. Japanese Article Number 8, JAN-8 Supplement 5/Five-digit Add-On, JAN-8 Supplement 2/Two-digit Add-On, JAN-8+5, JAN-8+2, JAN8, JAN8+5, JAN8+2
Jan13 | 32 | JAN-13 a.k.a. Japanese Article Number 13, JAN-13 Supplement 5/Five-digit Add-On, JAN-13 Supplement 2/Two-digit Add-On, JAN-13+5, JAN-13+2, JAN13, JAN13+5, JAN13+2
SwissPostParcel | 33 | Swiss PostParcel Barcode a.k.a. SwissPost Parcel Barcode, Switzerland Post Parcel Barcode
Opc | 34 | OPC a.k.a. Optical Product Code, VCA Barcode, VCA OPC, Vision Council of America OPC Barcode
Ean99 | 35 | EAN-99 a.k.a. European Article Number 99, EAN-99 Supplement 5/Five-digit Add-On, EAN-99 Supplement 2/Two-digit Add-On, EAN-99+5, EAN-99+2, EAN99, EAN99+5, EAN99+2, GTIN-99, GS1-99, Coupon Barcode
Itf14 | 36 | ITF-14 a.k.a. UPC Shipping Container Symbol ITF-14, ITF14, Case Code, UPC Case Code, EAN/UCC-14, EAN-14, UCC-14, DUN-14, GTIN-14
Scc14 | 37 | SCC-14 a.k.a. Shipping Container Code, EAN/UCC 14, DUN-14, EAN-14, UCC-14, UPC Case Code, UPC Shipping Container Code, Distribution Unit Number 14, SCC14, DUN14, EAN14, UCC14, EAN/UCC-14, Despatch Unit Number 14, GTIN-14
Issn | 38 | ISSN a.k.a. International Standard Serial Number, ISSN-13, ISSN-10, ISSN+5, ISSN+2, ISSN Supplement 5/Five-digit Add-On, ISSN Supplement 2/Two-digit Add-On
Ismn | 39 | ISMN a.k.a. International Standard Music Number, ISMN-13, ISMN-10, ISMN+5, ISMN+2, ISMN Supplement 5/Five-digit Add-On, ISMN Supplement 2/Two-digit Add-On, ISO 10957
NumlyNumber | 40 | Numly Number a.k.a. ESN, Electronic Serial Number, Electronic Standard Book Number, ESBN
QRCode | 41 | QR Code a.k.a. Quick Response Code, QRCode Model 2, JIS X 0510, ISO-IEC 18004
UspsFim | 42 | USPS FIM a.k.a. Facing Identification Marks, FIM A B C D
UspsHorizontalBars | 43 | USPS Horizontal Bars
Telepen | 44 | Telepen a.k.a. SB Telepen
Pharmacode | 45 | Pharmacode a.k.a. Pharmacode Laetus, Pharmaceutical Binary Code
Semacode | 46 | Semacode a.k.a. URL Barcode, Semacode Tag
Code32 | 47 | Code 32 a.k.a. Italian Pharmacode, IMH, Codice 32 Pharmacode, Codice Farmaceutico Italiano, Radix 32 Barcode
UspsPicUccEan128 | 48 | USPS PIC UCC/EAN-128 a.k.a. USPS Package Identification Code, USPS Confirmation Services Tracking Number Barcode
FedExGround96 | 49 | FedEx Ground 96 a.k.a. FedEx 96 Barcode, FedEx Ground 96 UCC/EAN-128, 96 Barcode
AztecCode | 50 | Aztec Code a.k.a. AIM Aztec Barcode, ANSI/AIM BC13 ITS/97/002
CompactPdf417 | 51 | Compact PDF417 a.k.a. Compact Portable Data File 417, Compact PDF 417, PDF417 Truncated
MacroPdf417 | 52 | Macro PDF417 a.k.a. Macro Portable Data File 417, Macro PDF 417, MacroPDF417
MicroPdf417 | 53 | Micro PDF417 a.k.a. Micro Portable Data File 417, Micro PDF 417, MicroPDF417
VicsBol | 54 | VICS BOL a.k.a. VICS Bill of Lading, Voluntary Interindustry Commerce Solutions Bill of Lading, BOL Barcode, 17-digit BOL, VICS standard Bill of Lading
VicsScacPro | 55 | VICS SCAC PRO a.k.a. VICS Bill of Lading SCAC PRO, Voluntary Interindustry Commerce Solutions Bill of Lading SCAC PRO, SCAC Barcode, PRO Barcode, VICS SCAC, VICS PRO, SCAC/Pro Barcode, Standard Carrier Alpha Code, Carrier SCAC Barcode
ItalianPost25 | 56 | Italian Post 25 a.k.a. Italian Post ITF 2/5, PosteItaliane Registered Mail Barcode, PosteItaliane ITF
Isbt128 | 57 | ISBT 128 a.k.a. ISBT Barcode, ISBT128, International Society of Blood Transfusion Barcode, ICCBBA 128, International Council for Commonality in Blood Banking Automation Barcode, Unique Donation Identification Barcode, American Association of Blood Banks AABB 128 Barcode, American Red Cross ARC Barcode
HibcLic39 | 58 | HIBC LIC 39 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 39, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcLic128 | 59 | HIBC LIC 128 a.k.a. HIBCC LIC, HIBC Labeler Identification Code, HIBC Supplier Labeling Standard Barcode, HIBC SLS Barcode, HIBC LIC Primary Data Structure, HIBC LIC Secondary Data Structure, HIBC Code 128, HIBC PCN Barcode, HIBC Universal Product Number, HIBC UPN Barcode, Health Industry Bar Code, Health Industry Business Communications Council Barcode
HibcPas39 | 60 | HIBC PAS 39 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 39, HIBC Health Care Services Provider Barcode
HibcPas128 | 61 | HIBC PAS 128 a.k.a. HIBCC PAS, HIBC Provider Applications Standard, HIBC Provider Applications Standard Barcode, HIBC PAS Barcode, HIBC PAS Data Structure, HIBC PAS Single Data Structure, HIBC PAS Split Data Field, HIBC PAS Multiple Data Field (Concatenated), HIBC PAS Code 128, HIBC Health Care Services Provider Barcode
UspsIntelligentMail | 62 | USPS Intelligent Mail Barcode a.k.a. OneCode 4CB, USPS 4CB, 4-CB, 4-State Customer Barcode, USPS OneCode Solution Barcode
EanUpcAddOn2 | 63 | EAN UPC Add On 2 a.k.a. EAN Supplement 2/Two-digit Add-On, EAN+2, UPC Supplement 2/Two-digit Add-On, UPC+2
EanUpcAddOn5 | 64 | EAN UPC Add On 5 a.k.a. EAN Supplement 5/Five-digit Add-On, EAN+5, UPC Supplement 5/Five-digit Add-On, UPC+5
UspsPicCode128 | 65 | USPS PIC Code 128 a.k.a. USPS Package Identification Code USS Code 128, USPS Confirmation Services Tracking Number Barcode USS Code 128
GS1DataBarOmnidirectional | 66 | GS1 DataBar Omnidirectional a.k.a. RSS14, Reduced Space Symbology 14
GS1DataBar14 | 67 | GS1 DataBar-14 a.k.a. GS1 DataBar Omnidirectional, RSS14, Reduced Space Symbology 14
Rss14 | 68 | RSS14 a.k.a. RSS 14, Reduced Space Symbology 14, GS1 DataBar Omnidirectional
GS1DataBarTruncated | 69 | GS1 DataBar Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated
GS1DataBar14Truncated | 70 | GS1 DataBar-14 Truncated a.k.a. GS1 DataBar Truncated, RSS 14 Truncated, Reduced Space Symbology 14 Truncated
Rss14Truncated | 71 | RSS14 Truncated a.k.a. RSS 14 Truncated, Reduced Space Symbology 14 Truncated, GS1 DataBar Truncated
GS1DataBarStacked | 72 | GS1 DataBar Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar 14 Stacked
GS1DataBar14Stacked | 73 | GS1 DataBar-14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
Rss14Stacked | 74 | RSS14 Stacked a.k.a. RSS 14 Stacked, Reduced Space Symbology 14 Stacked, GS1 DataBar Stacked
GS1DataBarStackedOmnidirectional | 75 | GS1 DataBar Stacked Omnidirectional a.k.a. GS1 DataBar-14 Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
GS1DataBar14StackedOmnidirectional | 76 | GS1 DataBar-14 Stacked Omnidirectional a.k.a. GS1 DataBar Stacked Omnidirectional, RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional
Rss14StackedOmnidirectional | 77 | RSS14 Stacked Omnidirectional a.k.a. RSS 14 Stacked Omnidirectional, Reduced Space Symbology 14 Stacked Omnidirectional, GS1 DataBar-14 Stacked Omnidirectional, GS1 DataBar Stacked Omnidirectional
GS1DataBarLimited | 78 | GS1 DataBar Limited a.k.a. GS1 DataBar-14 Limited, RSS Limited, Reduced Space Symbology Limited
RssLimited | 80 | RSS Limited a.k.a. Reduced Space Symbology Limited, GS1 DataBar-14 Limited, GS1 DataBar Limited
GS1DataBarExpanded | 81 | GS1 DataBar Expanded a.k.a. RSS Expanded, Reduced Space Symbology Expanded
RssExpanded | 82 | RSS Expanded a.k.a. GS1 DataBar Expanded, Reduced Space Symbology Expanded
GS1DataBarExpandedStacked | 83 | GS1 DataBar Expanded Stacked a.k.a. RSS Expanded Stacked, Reduced Space Symbology Expanded Stacked
RssExpandedStacked | 84 | RSS Expanded Stacked a.k.a. GS1 DataBar Expanded Stacked, Reduced Space Symbology Expanded Stacked
GS1128 | 85 | GS1-128 a.k.a. UCC/EAN-128, EAN-128, UCC-128, USS-128, UCC.EAN-128, GTIN-128
MaxiCode | 86 | MaxiCode a.k.a. UPS MaxiCode, Maxi Code, United Parcel Service MaxiCode
MicroQRCode | 87 | Micro QR Code a.k.a. Micro Quick Response Code, Micro QRCode Model 2
Matrix2of5 | 88 | Matrix 2 of 5 a.k.a. 2 of 5 Matrix, 2/5 Matrix
DanishPostal39 | 89 | Danish Postal 39 a.k.a. Danish PTT 39, Post Danmark A/S Barcode, Post Danmark Parcel Barcode
FrenchPostal39AR | 90 | French Postal 39 A/R a.k.a. French Postal A/R 39, La Poste A/R 39
IATA2of5 | 91 | IATA 2 of 5 a.k.a. International Air Transport Assosiation 2 of 5
AustraliaPostDomesticEParcelBarcode | 92 | Australia Post Domestic eParcel Barcode ak.a. Australia Post Domestic eParcel Article Barcode
UspsIntelligentMailContainerBarcode | 93 | USPS Intelligent Mail Container Barcode a.k.a. USPS IM Container Barcode, IM Container Barcode
KodakPatchCode | 94 | Kodak Patch Code
GS1DataMatrix | 95 | GS1 DataMatrix a.k.a. GS1 Data Matrix ECC200
Ean13CCA | 96 | EAN-13 CC-A a.k.a. European Article Number 13 with CC-A
Ean13CCB | 97 | EAN-13 CC-B a.k.a. European Article Number 13 with CC-B
Ean8CCA | 98 | EAN-8 CC-A a.k.a. European Article Number 8 with CC-A
Ean8CCB | 99 | EAN-8 CC-B a.k.a. European Article Number 8 with CC-B
UpcACCA | 100 | UPC-A CC-A a.k.a. Universal Product Code version A with CC-A
UpcACCB | 101 | UPC-A CC-B a.k.a. Universal Product Code version A with CC-B
UpcECCA | 102 | UPC-E CC-A a.k.a. Universal Product Code version E with CC-A
UpcECCB | 103 | UPC-E CC-B a.k.a. Universal Product Code version E with CC-B
UccEan128CCA | 104 | UCC/EAN-128 CC-A a.k.a. GS1-128 with CC-A
UccEan128CCB | 105 | UCC/EAN-128 CC-B a.k.a. GS1-128 with CC-B
UccEan128CCC | 106 | UCC/EAN-128 CC-C a.k.a. GS1-128 with CC-C
GS1128CCA | 107 | GS1-128 CC-A a.k.a. UCC/EAN-128 with CC-A
GS1128CCB | 108 | GS1-128 CC-B a.k.a. UCC/EAN-128 with CC-B
GS1128CCC | 109 | GS1-128 CC-C a.k.a. UCC/EAN-128 with CC-C
GS1DataBarOmnidirectionalCCA | 110 | GS1 DataBar Omnidirectional with CC-A a.k.a. RSS14 CC-A
GS1DataBar14CCA | 111 | GS1 DataBar-14 with CC-A a.k.a. RSS14 with CC-A
Rss14CCA | 112 | RSS14 CC-A
GS1DataBarOmnidirectionalCCB | 113 | GS1 DataBar Omnidirectional with CC-B a.k.a. RSS14 CC-B
GS1DataBar14CCB | 114 | GS1 DataBar-14 with CC-B a.k.a. RSS14 with CC-B
Rss14CCB | 115 | RSS14 CC-B
GS1DataBarTruncatedCCA | 116 | GS1 DataBar Truncated CC-A a.k.a. RSS 14 Truncated CC-A
GS1DataBar14TruncatedCCA | 117 | GS1 DataBar-14 Truncated CC-A a.k.a. RSS 14 Truncated CC-A
Rss14TruncatedCCA | 118 | RSS14 Truncated CC-A
GS1DataBarTruncatedCCB | 119 | GS1 DataBar Truncated CC-B a.k.a. RSS 14 Truncated CC-B
GS1DataBar14TruncatedCCB | 120 | GS1 DataBar-14 Truncated CC-B a.k.a. RSS 14 Truncated CC-B
Rss14TruncatedCCB | 121 | RSS14 Truncated CC-B
GS1DataBarLimitedCCA | 122 | GS1 DataBar Limited CC-A a.k.a. RSS Limited CC-A
RssLimitedCCA | 123 | RSS Limited CC-A
GS1DataBarLimitedCCB | 124 | GS1 DataBar Limited CC-B a.k.a. RSS Limited CC-B
RssLimitedCCB | 125 | RSS Limited CC-B
GS1DataBarStackedCCA | 126 | GS1 DataBar Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBar14StackedCCA | 127 | GS1 DataBar-14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
Rss14StackedCCA | 128 | RSS14 Stacked CC-A a.k.a. RSS 14 Stacked CC-A
GS1DataBarStackedCCB | 129 | GS1 DataBar Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBar14StackedCCB | 130 | GS1 DataBar-14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
Rss14StackedCCB | 131 | RSS14 Stacked CC-B a.k.a. RSS 14 Stacked CC-B
GS1DataBarStackedOmnidirectionalCCA | 132 | GS1 DataBar Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
GS1DataBar14StackedOmnidirectionalCCA | 133 | GS1 DataBar-14 Stacked Omnidirectional CC-A a.k.a. RSS 14 Stacked Omnidirectional CC-A
Rss14StackedOmnidirectionalCCA | 134 | RSS14 Stacked Omnidirectional CC-A
GS1DataBarStackedOmnidirectionalCCB | 135 | GS1 DataBar Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
GS1DataBar14StackedOmnidirectionalCCB | 136 | GS1 DataBar-14 Stacked Omnidirectional CC-B a.k.a. RSS 14 Stacked Omnidirectional CC-B
Rss14StackedOmnidirectionalCCB | 137 | RSS14 Stacked Omnidirectional CC-B
GS1DataBarExpandedCCA | 138 | GS1 DataBar Expanded CC-A a.k.a. RSS Expanded CC-A
RssExpandedCCA | 139 | RSS Expanded CC-A
GS1DataBarExpandedCCB | 140 | GS1 DataBar Expanded CC-B a.k.a. RSS Expanded CC-B
RssExpandedCCB | 141 | RSS Expanded CC-B
GS1DataBarExpandedStackedCCA | 142 | GS1 DataBar Expanded Stacked CC-A a.k.a. RSS Expanded Stacked CC-A
RssExpandedStackedCCA | 143 | RSS Expanded Stacked CC-A
GS1DataBarExpandedStackedCCB | 144 | GS1 DataBar Expanded Stacked CC-B a.k.a. RSS Expanded Stacked CC-B
RssExpandedStackedCCB | 145 | RSS Expanded Stacked CC-B
Ean14 | 146 | EAN-14 a.k.a. GTIN-14, UCC-14
Dun14Itf | 147 | DUN-14 ITF Version
Dun14Ean | 148 | DUN-14 GS1/EAN/UCC Version
GS1QRCode | 149 | GS1 QR Code
Ppn | 150 | PPN a.k.a. IFA PPN, IFA Pharmacy Product Number, IFA securPharm
IFAsecurPharm | 151 | IFA securPharm a.k.a. PPN
DhlAwb | 152 | DHL AWB
HibcLicDataMatrix | 153 | HIBC LIC Data Matrix
HibcLicQRCode | 154 | HIBC LIC QR Code
HibcLicAztecCode | 155 | HIBC LIC Aztec Code
HibcPasDataMatrix | 156 | HIBC PAS Data Matrix
HibcPasQRCode | 157 | HIBC PAS QR COde
HibcPasAztecCode | 158 | HIBC PAS Aztec Code
Isbt128DataMatrix | 159 | ISBT 128 Data Matrix
DeutschePostResponsePlusPostMatrix | 160 | Deutsche Post PostMatrix
DeutschePostBzl | 161 | Deutsche Post BZL
UspsIntelligentMailPackageBarcode | 162 | USPS Intelligent Mail Package Barcode a.k.a. USPS IMpb
HanXinCode | 163 | Han Xin Code a.k.a. 2D Chinese Barcode

See Also


BarcodeTextAlignment Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeTextAlignment Enumeration
See Also Send Feedback
Specifies the text alignment on the barcode

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BarcodeTextAlignment
Visual Basic
Public Enumeration BarcodeTextAlignment
Visual C++
public enum class BarcodeTextAlignment

Members

Member name | Value | Description
AboveCenter | 0 |
AboveLeft | 1 |
AboveRight | 2 |
AboveJustify | 3 |
BelowCenter | 4 |
BelowLeft | 5 |
BelowRight | 6 |
BelowJustify | 7 |

See Also


BarcodeUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils Class
Members See Also Send Feedback
BarcodeUtils provides additional utilities related to barcode generation.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class BarcodeUtils
Visual Basic
Public Class BarcodeUtils
Visual C++
public ref class BarcodeUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..BarcodeUtils

See Also

BarcodeUtils Members


BarcodeUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils Members
BarcodeUtils Class Constructors Methods See Also Send Feedback

The BarcodeUtils type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeUtils |

Methods

Name | Description
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetDeutschePostModulus11Checksum | It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode
GetDhlAwbChecksum | It computes the checksum Modulus 7 used by DHL AWB barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.
GetPpnChecksum | It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.

See Also

BarcodeUtils Class


BarcodeUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils Constructor
BarcodeUtils Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public BarcodeUtils()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeUtils()

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils Methods
BarcodeUtils Class See Also Send Feedback

The BarcodeUtils type exposes the following members.

Methods

Name | Description
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetDeutschePostModulus11Checksum | It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode
GetDhlAwbChecksum | It computes the checksum Modulus 7 used by DHL AWB barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.
GetPpnChecksum | It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.

See Also

BarcodeUtils Class


BarcodeUtils.GetAustraliaPost4StateBarcodeChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetAustraliaPost4StateBarcodeChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string GetAustraliaPost4StateBarcodeChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPost4StateBarcodeChecksum (
    code As String
) As String
Visual C++
public:
static String^ GetAustraliaPost4StateBarcodeChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post 4 State code.

Return Value

Type: String
The checksum (Reed Solomon codewords) for an Australia Post 4 State code.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetAustraliaPostDomesticEParcelChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetAustraliaPostDomesticEParcelChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum for an Australia Post Domestic eParcel code.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static int GetAustraliaPostDomesticEParcelChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPostDomesticEParcelChecksum (
    code As String
) As Integer
Visual C++
public:
static int GetAustraliaPostDomesticEParcelChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post Domestic eParcel code.

Return Value

Type: Int32
The checksum for an Australia Post Domestic eParcel code.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetCode39Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetCode39Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum Modulus 43 used by Code 39 barcode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string GetCode39Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode39Checksum (
    code As String
) As String
Visual C++
public:
static String^ GetCode39Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 39 value.

Return Value

Type: String
The checksum Modulus 43 used by Code 39 barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetCode93Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetCode93Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the two-char checksum Modulus 47 used by Code 93 barcode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string GetCode93Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode93Checksum (
    code As String
) As String
Visual C++
public:
static String^ GetCode93Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 93 value.

Return Value

Type: String
The two-char checksum Modulus 47 used by Code 93 barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetDeutschePostModulus11Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetDeutschePostModulus11Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the Modulus 11 checksum used by Deutsche Post Code 128 Identcode

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static int GetDeutschePostModulus11Checksum(
    string code
)
Visual Basic
Public Shared Function GetDeutschePostModulus11Checksum (
    code As String
) As Integer
Visual C++
public:
static int GetDeutschePostModulus11Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
A valid 8-digit Deutsche Post Ident code.

Return Value

Type: Int32
The checksum for a valid 8-digit Deutsche Post Ident code.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetDhlAwbChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetDhlAwbChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum Modulus 7 used by DHL AWB barcode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static int GetDhlAwbChecksum(
    string code
)
Visual Basic
Public Shared Function GetDhlAwbChecksum (
    code As String
) As Integer
Visual C++
public:
static int GetDhlAwbChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
A DHL AWB 9-digit code.

Return Value

Type: Int32
The checksum Modulus 7 used by DHL AWB barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetModulus10Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetModulus10Checksum Method
BarcodeUtils Class See Also Send Feedback
It computes the checksum Modulus 10 used by many barcode symbologies.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static int GetModulus10Checksum(
    string code
)
Visual Basic
Public Shared Function GetModulus10Checksum (
    code As String
) As Integer
Visual C++
public:
static int GetModulus10Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The code where the checksum will be computed on.

Return Value

Type: Int32
The checksum Modulus 10.

See Also

BarcodeUtils Class
BarcodeUtils Members


BarcodeUtils.GetPpnChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeUtils..::..GetPpnChecksum Method
BarcodeUtils Class See Also Send Feedback
It computes the 2-digit checksum Modulus 97 used by IFA PPN barcode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string GetPpnChecksum(
    string code
)
Visual Basic
Public Shared Function GetPpnChecksum (
    code As String
) As String
Visual C++
public:
static String^ GetPpnChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An IFA PZN8 code with or without 11 prefix.

Return Value

Type: String
The 2-digit checksum Modulus 97 used by IFA PPN barcode.

See Also

BarcodeUtils Class
BarcodeUtils Members


BearerBarStyle Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BearerBarStyle Enumeration
See Also Send Feedback
Specifies the bearer bars' type that must be drawn on the barcode. Bearer bar is only available for 2 of 5, Code 128 and UCC.EAN 128 barcode symbologies.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum BearerBarStyle
Visual Basic
Public Enumeration BearerBarStyle
Visual C++
public enum class BearerBarStyle

Members

Member name | Value | Description
None | 0 | No bearer bars are drawn on the barcode
Frame | 1 | The bearer bars are drawn surrounding the symbol
HorizontalRules | 2 | The bearer bars are drawn at the top and bottom on the symbol

See Also


CircleShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Class
Members See Also Send Feedback
Represents an ellipse rectangle shape item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class CircleShapeItem : EllipseShapeItem
Visual Basic
Public Class CircleShapeItem
    Inherits EllipseShapeItem
Visual C++
public ref class CircleShapeItem : public EllipseShapeItem

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..ClosedShapeItem
Neodynamic.SDK.Printing..::..EllipseShapeItem
Neodynamic.SDK.Printing..::..CircleShapeItem

See Also

CircleShapeItem Members


CircleShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Members
CircleShapeItem Class Constructors Methods Properties Events See Also Send Feedback

The CircleShapeItem type exposes the following members.

Constructors

 | Name | Description
Public method | CircleShapeItem()()()() | Initializes a new instance of the CircleShapeItem class.
Public method | CircleShapeItem(Double, Double, Double) | Initializes a new instance of the CircleShapeItem class with the specified location and size.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current EllipseShapeItem. (Inherited from EllipseShapeItem.)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this EllipseShapeItem object with the properties of the specified EllipseShapeItem object. (Inherited from EllipseShapeItem.)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero) (Inherited from EllipseShapeItem.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

CircleShapeItem Class


CircleShapeItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Constructor
CircleShapeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CircleShapeItem()()()() | Initializes a new instance of the CircleShapeItem class.
Public method | CircleShapeItem(Double, Double, Double) | Initializes a new instance of the CircleShapeItem class with the specified location and size.

See Also

CircleShapeItem Class
CircleShapeItem Members


CircleShapeItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Constructor
CircleShapeItem Class See Also Send Feedback
Initializes a new instance of the CircleShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CircleShapeItem()
Visual Basic
Public Sub New
Visual C++
public:
CircleShapeItem()

See Also

CircleShapeItem Class
CircleShapeItem Members
CircleShapeItem Overload


CircleShapeItem Constructor (Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Constructor (Double, Double, Double)
CircleShapeItem Class See Also Send Feedback
Initializes a new instance of the CircleShapeItem class with the specified location and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CircleShapeItem(
    double x,
    double y,
    double diameter
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    diameter As Double
)
Visual C++
public:
CircleShapeItem(
    double x,
    double y,
    double diameter
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
diameter
Type: System..::..Double
The diameter of the circle item.

See Also

CircleShapeItem Class
CircleShapeItem Members
CircleShapeItem Overload


CircleShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Methods
CircleShapeItem Class See Also Send Feedback

The CircleShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current EllipseShapeItem. (Inherited from EllipseShapeItem.)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this EllipseShapeItem object with the properties of the specified EllipseShapeItem object. (Inherited from EllipseShapeItem.)

See Also

CircleShapeItem Class


CircleShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Properties
CircleShapeItem Class See Also Send Feedback

The CircleShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero) (Inherited from EllipseShapeItem.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

CircleShapeItem Class


CircleShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CircleShapeItem Events
CircleShapeItem Class See Also Send Feedback

The CircleShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

CircleShapeItem Class


ClosedShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended ClosedShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public abstract class ClosedShapeItem : ShapeItem
Visual Basic
Public MustInherit Class ClosedShapeItem
    Inherits ShapeItem
Visual C++
public ref class ClosedShapeItem abstract : public ShapeItem

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..ClosedShapeItem
Neodynamic.SDK.Printing..::..EllipseShapeItem
Neodynamic.SDK.Printing..::..RectangleShapeItem

See Also

ClosedShapeItem Members


ClosedShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem Members
ClosedShapeItem Class Methods Properties Events See Also Send Feedback

The ClosedShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object. (Inherited from Item.)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object. (Inherited from Item.)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill.
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ClosedShapeItem Class


ClosedShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem Methods
ClosedShapeItem Class See Also Send Feedback

The ClosedShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object. (Inherited from Item.)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object. (Inherited from Item.)

See Also

ClosedShapeItem Class


ClosedShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem Properties
ClosedShapeItem Class See Also Send Feedback

The ClosedShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill.
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

ClosedShapeItem Class


ClosedShapeItem.FillColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem..::..FillColor Property
ClosedShapeItem Class See Also Send Feedback
Gets or sets the fill color. Default value is White which will produce a transparent fill.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color FillColor { get; set; }
Visual Basic
Public Property FillColor As Color
    Get
    Set
Visual C++
public:
property Color FillColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ClosedShapeItem Class
ClosedShapeItem Members


ClosedShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ClosedShapeItem Events
ClosedShapeItem Class See Also Send Feedback

The ClosedShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ClosedShapeItem Class


CodabarStartStopChar Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CodabarStartStopChar Enumeration
See Also Send Feedback
Specifies the start and stop character for Codabar symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum CodabarStartStopChar
Visual Basic
Public Enumeration CodabarStartStopChar
Visual C++
public enum class CodabarStartStopChar

Members

Member name | Value | Description
A | 0 |
B | 1 |
C | 2 |
D | 3 |

See Also


Code128 Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Code128 Enumeration
See Also Send Feedback
Specifies the characters set to use in the Code 128 symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Code128
Visual Basic
Public Enumeration Code128
Visual C++
public enum class Code128

Members

Member name | Value | Description
Auto | 0 | Barcode Professional will automatically switch between code sets to encode the ASCII values.
A | 1 | Barcode Professional will use the Char Set A which only supports ASCII values from 0 to 95
B | 2 | Barcode Professional will use the Char Set B which only supports ASCII values from 32 to 127
C | 3 | Barcode Professional will use the Char Set C which only supports pairs of digits

See Also


Code16k Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Code16k Enumeration
See Also Send Feedback
Specifies the mode to use for Code16k symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Code16k
Visual Basic
Public Enumeration Code16k
Visual C++
public enum class Code16k

Members

Member name | Value | Description
Mode0 | 0 | Barcode Professional will use the Code 128 Char Set A which only supports ASCII values from 0 to 95
Mode1 | 1 | Barcode Professional will use the Code 128 Char Set B which only supports ASCII values from 32 to 127
Mode2 | 2 | Barcode Professional will use the Code 128 Char Set C which only supports pairs of digits

See Also


Color Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Color Enumeration
See Also Send Feedback
Specifies a color.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Color
Visual Basic
Public Enumeration Color
Visual C++
public enum class Color

Members

Member name | Value | Description
Black | 0 |
White | 1 |

See Also


CommunicationType Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
CommunicationType Enumeration
See Also Send Feedback
Specifies the printer communication type.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum CommunicationType
Visual Basic
Public Enumeration CommunicationType
Visual C++
public enum class CommunicationType

Members

Member name | Value | Description
USB | 0 | Communicates to printer device through USB (Universal Serial Bus).
Serial | 1 | Communicates to printer device through Serial Port RS-232.
Parallel | 2 | Communicates to printer device through Parallel Port (Centronics).
Network | 3 | Communicates to printer device through Ethernet connection.
PrinterDriver | 4 | Communicates to printer device through an installed printer driver.
Stream | 5 | Communicates to printer device through a System.IO.Stream object.

See Also


DataMatrixEncoding Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
DataMatrixEncoding Enumeration
See Also Send Feedback
Specifies the DataMatrix Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum DataMatrixEncoding
Visual Basic
Public Enumeration DataMatrixEncoding
Visual C++
public enum class DataMatrixEncoding

Members

Member name | Value | Description
Auto | 0 |
Ascii | 1 | Used to encode data that mainly contains ASCII characters (0-127)
C40 | 2 | Used to encode data that mainly contains numeric and upper case characters
Text | 3 | Used to encode data that mainly contains numeric and lower case characters
Base256 | 4 | Used to encode 8 bit values

See Also


DataMatrixFormat Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
DataMatrixFormat Enumeration
See Also Send Feedback
Specifies the DataMatrix Format to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum DataMatrixFormat
Visual Basic
Public Enumeration DataMatrixFormat
Visual C++
public enum class DataMatrixFormat

Members

Member name | Value | Description
Auto | 0 |
C10X10 | 1 |
C12X12 | 2 |
C14X14 | 3 |
C16X16 | 4 |
C18X18 | 5 |
C20X20 | 6 |
C22X22 | 7 |
C24X24 | 8 |
C26X26 | 9 |
C32X32 | 10 |
C36X36 | 11 |
C40X40 | 12 |
C44X44 | 13 |
C48X48 | 14 |
C52X52 | 15 |
C64X64 | 16 |
C72X72 | 17 |
C80X80 | 18 |
C88X88 | 19 |
C96X96 | 20 |
C104X104 | 21 |
C120X120 | 22 |
C132X132 | 23 |
C144X144 | 24 |
C8X18 | 25 |
C8X32 | 26 |
C12X26 | 27 |
C12X36 | 28 |
C16X36 | 29 |
C16X48 | 30 |

See Also


DitherMethod Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
DitherMethod Enumeration
See Also Send Feedback
Specifies the dithering method to be used for Black/White conversion.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum DitherMethod
Visual Basic
Public Enumeration DitherMethod
Visual C++
public enum class DitherMethod

Members

Member name | Value | Description
Threshold | 0 | Any pixel below the threshold becomes black; otherwise it becomes white. Use it for logos or simple images.
PatternDiffusion | 1 | It uses a 4x4 dithering matrix to create a grouping of pixels that approximates the pixel group brightness. Use it for photos and other complicated images.
FloydSteinberg | 2 | It uses Floyd-Steinberg algorithm to keep a track of the error in brightness caused by the threshold, and diffusing it across an area. Use it for photos and other complicated images.
OtsuThreshold | 3 | It uses Otsu's method to automatically perform histogram shape-based image thresholding. Use it for logos or simple images.

See Also


EllipseShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Class
Members See Also Send Feedback
Represents an ellipse rectangle shape item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class EllipseShapeItem : ClosedShapeItem
Visual Basic
Public Class EllipseShapeItem
    Inherits ClosedShapeItem
Visual C++
public ref class EllipseShapeItem : public ClosedShapeItem

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..ClosedShapeItem
Neodynamic.SDK.Printing..::..EllipseShapeItem
Neodynamic.SDK.Printing..::..CircleShapeItem

See Also

EllipseShapeItem Members


EllipseShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Members
EllipseShapeItem Class Constructors Methods Properties Events See Also Send Feedback

The EllipseShapeItem type exposes the following members.

Constructors

 | Name | Description
Public method | EllipseShapeItem()()()() | Initializes a new instance of the EllipseShapeItem class.
Public method | EllipseShapeItem(Double, Double, Double, Double) | Initializes a new instance of the EllipseShapeItem class with the specified location and size.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current EllipseShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this EllipseShapeItem object with the properties of the specified EllipseShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

EllipseShapeItem Class


EllipseShapeItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Constructor
EllipseShapeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EllipseShapeItem()()()() | Initializes a new instance of the EllipseShapeItem class.
Public method | EllipseShapeItem(Double, Double, Double, Double) | Initializes a new instance of the EllipseShapeItem class with the specified location and size.

See Also

EllipseShapeItem Class
EllipseShapeItem Members


EllipseShapeItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Constructor
EllipseShapeItem Class See Also Send Feedback
Initializes a new instance of the EllipseShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public EllipseShapeItem()
Visual Basic
Public Sub New
Visual C++
public:
EllipseShapeItem()

See Also

EllipseShapeItem Class
EllipseShapeItem Members
EllipseShapeItem Overload


EllipseShapeItem Constructor (Double, Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Constructor (Double, Double, Double, Double)
EllipseShapeItem Class See Also Send Feedback
Initializes a new instance of the EllipseShapeItem class with the specified location and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public EllipseShapeItem(
    double x,
    double y,
    double width,
    double height
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
Visual C++
public:
EllipseShapeItem(
    double x,
    double y,
    double width,
    double height
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
width
Type: System..::..Double
The width of the item.
height
Type: System..::..Double
The height of the item.

See Also

EllipseShapeItem Class
EllipseShapeItem Members
EllipseShapeItem Overload


EllipseShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Methods
EllipseShapeItem Class See Also Send Feedback

The EllipseShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current EllipseShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this EllipseShapeItem object with the properties of the specified EllipseShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

EllipseShapeItem Class


EllipseShapeItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem..::..Clone Method
EllipseShapeItem Class See Also Send Feedback
Creates a copy of the current EllipseShapeItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current EllipseShapeItem.

See Also

EllipseShapeItem Class
EllipseShapeItem Members


EllipseShapeItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem..::..UpdateFrom Method
EllipseShapeItem Class See Also Send Feedback
Updates this EllipseShapeItem object with the properties of the specified EllipseShapeItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The EllipseShapeItem object that is used for updating this EllipseShapeItem object.

See Also

EllipseShapeItem Class
EllipseShapeItem Members


EllipseShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Properties
EllipseShapeItem Class See Also Send Feedback

The EllipseShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

EllipseShapeItem Class


EllipseShapeItem.RotationAngle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem..::..RotationAngle Property
EllipseShapeItem Class See Also Send Feedback
Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Integer
    Get
    Set
Visual C++
public:
property int RotationAngle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

EllipseShapeItem Class
EllipseShapeItem Members


EllipseShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EllipseShapeItem Events
EllipseShapeItem Class See Also Send Feedback

The EllipseShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

EllipseShapeItem Class


FIM Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FIM Enumeration
See Also Send Feedback
Specifies the facing identification mark (FIM) pattern to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum FIM
Visual Basic
Public Enumeration FIM
Visual C++
public enum class FIM

Members

Member name | Value | Description
A | 0 | Used for Courtesy Reply Mail (CRM) and Meter Reply Mail (MRM) with a preprinted barcode.
B | 1 | Used for Business Reply Mail (BRM) without a preprinted BRM ZIP+4 barcode.
C | 2 | Used for Business Reply Mail (BRM) with a preprinted BRM ZIP+4 barcode.
D | 3 | Used only with information based indicia (IBI) postage.

See Also


Flip Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Flip Enumeration
See Also Send Feedback
Specifies the axis used to flip the image.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Flip
Visual Basic
Public Enumeration Flip
Visual C++
public enum class Flip

Members

Member name | Value | Description
None | 0 | Specifies no flipping.
X | 1 | Specifies a horizontal flip.
Y | 2 | Specifies a vertical flip.
XY | 3 | Specifies a horizontal and vertical flip.

See Also


Font Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Class
Members See Also Send Feedback
Encapsulates the font properties of texts.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class Font : INotifyPropertyChanged
Visual Basic
Public Class Font
    Implements INotifyPropertyChanged
Visual C++
public ref class Font : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Font

See Also

Font Members


Font Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Members
Font Class Constructors Methods Fields Properties Events See Also Send Feedback

The Font type exposes the following members.

Constructors

 | Name | Description
Public method | Font()()()() | Initializes a new instance of the Font class.
Public method | Font(String, Single) | Initializes a new instance of the Font class with the specified font name and size.
Public method | Font(String, Single, FontUnit) | Initializes a new instance of the Font class with the specified font name, size and unit of measure.
Public method | Font(String, String, Single) | Initializes a new instance of the Font class with the specified custom font file and size.
Public method | Font(String, String, Double, FontUnit) | Initializes a new instance of the Font class with the specified custom font file, size and unit of measure.

Methods

 | Name | Description
 | GetNearestSizeForNativePrinterFonts | Gets the nearest fixed size for the specified Font object. The Font object should be one of the supported Native Printer Fonts.
Public method | ToString()()()() | Converts the Font object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the Font object to a string representation, using the specified CultureInfo.
Public method | UpdateFrom | Updates this Font object with the properties of the specified Font object.

Fields

Name | Description
NativePrinterFontA | The font name for the Native Printer Font A
NativePrinterFontB | The font name for the Native Printer Font B
NativePrinterFontS | The font name for the Native Printer Font S

Properties

 | Name | Description
Public property | Bold | Gets or sets a value that indicates whether this Font object is bold. Default value is false
Public property | CustomFontFile | Gets or sets the custom font file to use for this Font object. It's the full path pointing out to the custom font file on local disk. Default value is an empty string
Public property | CustomFontFileFamilyName | Gets or sets the Font Family name of the type faces defined by the specified Custom Font File. Default value is an empty string
Public property | IsBitmapFont | Gets or sets whether the specified font is a Bitmap Font a.k.a. Pixel Font. Default value is false
Public property | IsNativePrinterFont | Gets whether this font is a Native Printer Font.
Public property | Italic | Gets or sets a value that indicates whether this Font object is italic. Default value is false
Public property | Name | Gets or sets the face name of this Font object. Default value is NativePrinterFontA
Public property | NameAtPrinterStorage | Gets or sets the name of this Font object available in the Printer's internal storage including the drive location and name, for example B:ARIAL. IMPORTANT: The name must be 1 to 8 alphanumeric characters long.
Public property | Size | Gets or sets the size of this Font object. Default value is 10
Public property | Strikeout | Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font. Default value is false
Public property | Threshold | Gets or sets the threshold percentage used for converting the font glyphs to black and white graphics. Values range from 0 to 100. Default value is 90.
Public property | Underline | Gets or sets a value that indicates whether this Font object is underlined. Default value is false
Public property | Unit | Gets or sets the unit of measure for this Font object. Default value is Point

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

Font Class


Font Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor
Font Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Font()()()() | Initializes a new instance of the Font class.
Public method | Font(String, Single) | Initializes a new instance of the Font class with the specified font name and size.
Public method | Font(String, Single, FontUnit) | Initializes a new instance of the Font class with the specified font name, size and unit of measure.
Public method | Font(String, String, Single) | Initializes a new instance of the Font class with the specified custom font file and size.
Public method | Font(String, String, Double, FontUnit) | Initializes a new instance of the Font class with the specified custom font file, size and unit of measure.

See Also

Font Class
Font Members


Font Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor
Font Class See Also Send Feedback
Initializes a new instance of the Font class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font()
Visual Basic
Public Sub New
Visual C++
public:
Font()

See Also

Font Class
Font Members
Font Overload


Font Constructor (String, Single)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor (String, Single)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified font name and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font(
    string name,
    float size
)
Visual Basic
Public Sub New (
    name As String,
    size As Single
)
Visual C++
public:
Font(
    String^ name,
    float size
)

Parameters

name
Type: System..::..String
The name of the font.
size
Type: System..::..Single
The size of the font measured in Points.

See Also

Font Class
Font Members
Font Overload


Font Constructor (String, Single, FontUnit)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor (String, Single, FontUnit)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified font name, size and unit of measure.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font(
    string name,
    float size,
    FontUnit unit
)
Visual Basic
Public Sub New (
    name As String,
    size As Single,
    unit As FontUnit
)
Visual C++
public:
Font(
    String^ name,
    float size,
    FontUnit unit
)

Parameters

name
Type: System..::..String
The name of the font.
size
Type: System..::..Single
The size of the font.
unit
Type: Neodynamic.SDK.Printing..::..FontUnit
The unit of measure for the font.

See Also

Font Class
Font Members
Font Overload


Font Constructor (String, String, Single)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor (String, String, Single)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified custom font file and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font(
    string customFontFile,
    string customFontFileFamilyIndex,
    float size
)
Visual Basic
Public Sub New (
    customFontFile As String,
    customFontFileFamilyIndex As String,
    size As Single
)
Visual C++
public:
Font(
    String^ customFontFile,
    String^ customFontFileFamilyIndex,
    float size
)

Parameters

customFontFile
Type: System..::..String
The custom font file to use. It's the full path pointing out to the custom font file on local disk.
customFontFileFamilyIndex
Type: System..::..String
size
Type: System..::..Single
The size of the font measured in Points.

See Also

Font Class
Font Members
Font Overload


Font Constructor (String, String, Double, FontUnit)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Constructor (String, String, Double, FontUnit)
Font Class See Also Send Feedback
Initializes a new instance of the Font class with the specified custom font file, size and unit of measure.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font(
    string customFontFile,
    string customFontFileFamilyIndex,
    double size,
    FontUnit unit
)
Visual Basic
Public Sub New (
    customFontFile As String,
    customFontFileFamilyIndex As String,
    size As Double,
    unit As FontUnit
)
Visual C++
public:
Font(
    String^ customFontFile,
    String^ customFontFileFamilyIndex,
    double size,
    FontUnit unit
)

Parameters

customFontFile
Type: System..::..String
The custom font file to use. It's the full path pointing out to the custom font file on local disk.
customFontFileFamilyIndex
Type: System..::..String
size
Type: System..::..Double
The size of the font measured in Points.
unit
Type: Neodynamic.SDK.Printing..::..FontUnit
The unit of measure for the font.

See Also

Font Class
Font Members
Font Overload


Font Fields

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Fields
Font Class See Also Send Feedback

The Font type exposes the following members.

Fields

Name | Description
NativePrinterFontA | The font name for the Native Printer Font A
NativePrinterFontB | The font name for the Native Printer Font B
NativePrinterFontS | The font name for the Native Printer Font S

See Also

Font Class


Font.NativePrinterFontA Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..NativePrinterFontA Field
Font Class See Also Send Feedback
The font name for the Native Printer Font A

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const string NativePrinterFontA
Visual Basic
Public Const NativePrinterFontA As String
Visual C++
public:
literal String^ NativePrinterFontA

Field Value

Type: String

See Also

Font Class
Font Members


Font.NativePrinterFontB Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..NativePrinterFontB Field
Font Class See Also Send Feedback
The font name for the Native Printer Font B

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const string NativePrinterFontB
Visual Basic
Public Const NativePrinterFontB As String
Visual C++
public:
literal String^ NativePrinterFontB

Field Value

Type: String

See Also

Font Class
Font Members


Font.NativePrinterFontS Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..NativePrinterFontS Field
Font Class See Also Send Feedback
The font name for the Native Printer Font S

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public const string NativePrinterFontS
Visual Basic
Public Const NativePrinterFontS As String
Visual C++
public:
literal String^ NativePrinterFontS

Field Value

Type: String

See Also

Font Class
Font Members


Font Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Methods
Font Class See Also Send Feedback

The Font type exposes the following members.

Methods

 | Name | Description
 | GetNearestSizeForNativePrinterFonts | Gets the nearest fixed size for the specified Font object. The Font object should be one of the supported Native Printer Fonts.
Public method | ToString()()()() | Converts the Font object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the Font object to a string representation, using the specified CultureInfo.
Public method | UpdateFrom | Updates this Font object with the properties of the specified Font object.

See Also

Font Class


Font.GetNearestSizeForNativePrinterFonts Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..GetNearestSizeForNativePrinterFonts Method
Font Class See Also Send Feedback
Gets the nearest fixed size for the specified Font object. The Font object should be one of the supported Native Printer Fonts.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static double GetNearestSizeForNativePrinterFonts(
    Font font
)
Visual Basic
Public Shared Function GetNearestSizeForNativePrinterFonts (
    font As Font
) As Double
Visual C++
public:
static double GetNearestSizeForNativePrinterFonts(
    Font^ font
)

Parameters

font
Type: Neodynamic.SDK.Printing..::..Font
The Font object on which the nearest fixed size is calculated.

Return Value

Type: Double
The nearest fixed size for the specified Font object.

Remarks

Native Printer Fonts accept the following fixed sizes:

- NativePrinterFontS: 3pt (this font does support just this value only)

- NativePrinterFontA: 5pt, 10pt, 15pt, 20pt, and 25pt

- NativePrinterFontB: 7pt, 14pt, 21pt, 28pt, and 35pt

By using this method, you can get the nearest fixed size if the specified Font object has a different value for the font size.

See Also

Font Class
Font Members


Font.ToString Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..ToString Method
Font Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Converts the Font object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the Font object to a string representation, using the specified CultureInfo.

See Also

Font Class
Font Members


Font.ToString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..ToString Method
Font Class See Also Send Feedback
Converts the Font object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the Font object in the current culture.

See Also

Font Class
Font Members
ToString Overload


Font.ToString Method (CultureInfo)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..ToString Method (CultureInfo)
Font Class See Also Send Feedback
Converts the Font object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic
Public Function ToString (
    culture As CultureInfo
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
A CultureInfo that contains the culture to represent the Font.

Return Value

Type: String
The string representation of the Font object in the specified culture.

See Also

Font Class
Font Members
ToString Overload


Font.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..UpdateFrom Method
Font Class See Also Send Feedback
Updates this Font object with the properties of the specified Font object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void UpdateFrom(
    Font font
)
Visual Basic
Public Sub UpdateFrom (
    font As Font
)
Visual C++
public:
void UpdateFrom(
    Font^ font
)

Parameters

font
Type: Neodynamic.SDK.Printing..::..Font

See Also

Font Class
Font Members


Font Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Properties
Font Class See Also Send Feedback

The Font type exposes the following members.

Properties

 | Name | Description
Public property | Bold | Gets or sets a value that indicates whether this Font object is bold. Default value is false
Public property | CustomFontFile | Gets or sets the custom font file to use for this Font object. It's the full path pointing out to the custom font file on local disk. Default value is an empty string
Public property | CustomFontFileFamilyName | Gets or sets the Font Family name of the type faces defined by the specified Custom Font File. Default value is an empty string
Public property | IsBitmapFont | Gets or sets whether the specified font is a Bitmap Font a.k.a. Pixel Font. Default value is false
Public property | IsNativePrinterFont | Gets whether this font is a Native Printer Font.
Public property | Italic | Gets or sets a value that indicates whether this Font object is italic. Default value is false
Public property | Name | Gets or sets the face name of this Font object. Default value is NativePrinterFontA
Public property | NameAtPrinterStorage | Gets or sets the name of this Font object available in the Printer's internal storage including the drive location and name, for example B:ARIAL. IMPORTANT: The name must be 1 to 8 alphanumeric characters long.
Public property | Size | Gets or sets the size of this Font object. Default value is 10
Public property | Strikeout | Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font. Default value is false
Public property | Threshold | Gets or sets the threshold percentage used for converting the font glyphs to black and white graphics. Values range from 0 to 100. Default value is 90.
Public property | Underline | Gets or sets a value that indicates whether this Font object is underlined. Default value is false
Public property | Unit | Gets or sets the unit of measure for this Font object. Default value is Point

See Also

Font Class


Font.Bold Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Bold Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is bold. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Bold { get; set; }
Visual Basic
Public Property Bold As Boolean
    Get
    Set
Visual C++
public:
property bool Bold {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.CustomFontFile Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..CustomFontFile Property
Font Class See Also Send Feedback
Gets or sets the custom font file to use for this Font object. It's the full path pointing out to the custom font file on local disk. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string CustomFontFile { get; set; }
Visual Basic
Public Property CustomFontFile As String
    Get
    Set
Visual C++
public:
property String^ CustomFontFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Font Class
Font Members


Font.CustomFontFileFamilyName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..CustomFontFileFamilyName Property
Font Class See Also Send Feedback
Gets or sets the Font Family name of the type faces defined by the specified Custom Font File. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string CustomFontFileFamilyName { get; set; }
Visual Basic
Public Property CustomFontFileFamilyName As String
    Get
    Set
Visual C++
public:
property String^ CustomFontFileFamilyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Font Class
Font Members


Font.IsBitmapFont Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..IsBitmapFont Property
Font Class See Also Send Feedback
Gets or sets whether the specified font is a Bitmap Font a.k.a. Pixel Font. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool IsBitmapFont { get; set; }
Visual Basic
Public Property IsBitmapFont As Boolean
    Get
    Set
Visual C++
public:
property bool IsBitmapFont {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.IsNativePrinterFont Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..IsNativePrinterFont Property
Font Class See Also Send Feedback
Gets whether this font is a Native Printer Font.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool IsNativePrinterFont { get; }
Visual Basic
Public ReadOnly Property IsNativePrinterFont As Boolean
    Get
Visual C++
public:
property bool IsNativePrinterFont {
    bool get ();
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.Italic Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Italic Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is italic. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Italic { get; set; }
Visual Basic
Public Property Italic As Boolean
    Get
    Set
Visual C++
public:
property bool Italic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.Name Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Name Property
Font Class See Also Send Feedback
Gets or sets the face name of this Font object. Default value is NativePrinterFontA

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Font Class
Font Members


Font.NameAtPrinterStorage Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..NameAtPrinterStorage Property
Font Class See Also Send Feedback
Gets or sets the name of this Font object available in the Printer's internal storage including the drive location and name, for example B:ARIAL. IMPORTANT: The name must be 1 to 8 alphanumeric characters long.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string NameAtPrinterStorage { get; set; }
Visual Basic
Public Property NameAtPrinterStorage As String
    Get
    Set
Visual C++
public:
property String^ NameAtPrinterStorage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Font Class
Font Members


Font.Size Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Size Property
Font Class See Also Send Feedback
Gets or sets the size of this Font object. Default value is 10

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Size { get; set; }
Visual Basic
Public Property Size As Double
    Get
    Set
Visual C++
public:
property double Size {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not greater than zero.

See Also

Font Class
Font Members


Font.Strikeout Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Strikeout Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object specifies a horizontal line through the font. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Strikeout { get; set; }
Visual Basic
Public Property Strikeout As Boolean
    Get
    Set
Visual C++
public:
property bool Strikeout {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.Threshold Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Threshold Property
Font Class See Also Send Feedback
Gets or sets the threshold percentage used for converting the font glyphs to black and white graphics. Values range from 0 to 100. Default value is 90.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Threshold { get; set; }
Visual Basic
Public Property Threshold As Integer
    Get
    Set
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

Font Class
Font Members


Font.Underline Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Underline Property
Font Class See Also Send Feedback
Gets or sets a value that indicates whether this Font object is underlined. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Underline { get; set; }
Visual Basic
Public Property Underline As Boolean
    Get
    Set
Visual C++
public:
property bool Underline {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Font Class
Font Members


Font.Unit Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..Unit Property
Font Class See Also Send Feedback
Gets or sets the unit of measure for this Font object. Default value is Point

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FontUnit Unit { get; set; }
Visual Basic
Public Property Unit As FontUnit
    Get
    Set
Visual C++
public:
property FontUnit Unit {
    FontUnit get ();
    void set (FontUnit value);
}

Property Value

Type: FontUnit

See Also

Font Class
Font Members


Font Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font Events
Font Class See Also Send Feedback

The Font type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

Font Class


Font.PropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Font..::..PropertyChanged Event
Font Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

Font Class
Font Members


FontConverter Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter Class
Members See Also Send Feedback
Converts Font objects from one data type to another. Access the FontConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class FontConverter : ExpandableObjectConverter
Visual Basic
Public Class FontConverter
    Inherits ExpandableObjectConverter
Visual C++
public ref class FontConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..ExpandableObjectConverter
Neodynamic.SDK.Printing..::..FontConverter

See Also

FontConverter Members


FontConverter Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter Members
FontConverter Class Constructors Methods See Also Send Feedback

The FontConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FontConverter |

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FontConverter Class


FontConverter Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter Constructor
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FontConverter()
Visual Basic
Public Sub New
Visual C++
public:
FontConverter()

See Also

FontConverter Class
FontConverter Members


FontConverter Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter Methods
FontConverter Class See Also Send Feedback

The FontConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FontConverter Class


FontConverter.CanConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter..::..CanConvertFrom Method
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
sourceType
Type: System..::..Type

Return Value

Type: Boolean

See Also

FontConverter Class
FontConverter Members


FontConverter.CanConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter..::..CanConvertTo Method
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
destinationType
Type: System..::..Type

Return Value

Type: Boolean

See Also

FontConverter Class
FontConverter Members


FontConverter.ConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter..::..ConvertFrom Method
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value
)
Visual Basic
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object

Return Value

Type: Object

See Also

FontConverter Class
FontConverter Members


FontConverter.ConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontConverter..::..ConvertTo Method
FontConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

Return Value

Type: Object

See Also

FontConverter Class
FontConverter Members


FontNameConverter Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter Class
Members See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class FontNameConverter : StringConverter
Visual Basic
Public Class FontNameConverter
    Inherits StringConverter
Visual C++
public ref class FontNameConverter : public StringConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..StringConverter
Neodynamic.SDK.Printing..::..FontNameConverter

See Also

FontNameConverter Members


FontNameConverter Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter Members
FontNameConverter Class Constructors Methods See Also Send Feedback

The FontNameConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FontNameConverter |

Methods

 | Name | Description
Public method | GetStandardValues | (Overrides TypeConverter..::..GetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive | (Overrides TypeConverter..::..GetStandardValuesExclusive(ITypeDescriptorContext).)
Public method | GetStandardValuesSupported | (Overrides TypeConverter..::..GetStandardValuesSupported(ITypeDescriptorContext).)

See Also

FontNameConverter Class


FontNameConverter Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter Constructor
FontNameConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FontNameConverter()
Visual Basic
Public Sub New
Visual C++
public:
FontNameConverter()

See Also

FontNameConverter Class
FontNameConverter Members


FontNameConverter Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter Methods
FontNameConverter Class See Also Send Feedback

The FontNameConverter type exposes the following members.

Methods

 | Name | Description
Public method | GetStandardValues | (Overrides TypeConverter..::..GetStandardValues(ITypeDescriptorContext).)
Public method | GetStandardValuesExclusive | (Overrides TypeConverter..::..GetStandardValuesExclusive(ITypeDescriptorContext).)
Public method | GetStandardValuesSupported | (Overrides TypeConverter..::..GetStandardValuesSupported(ITypeDescriptorContext).)

See Also

FontNameConverter Class


FontNameConverter.GetStandardValues Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter..::..GetStandardValues Method
FontNameConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override TypeConverter..::..StandardValuesCollection GetStandardValues(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetStandardValues (
    context As ITypeDescriptorContext
) As TypeConverter..::..StandardValuesCollection
Visual C++
public:
virtual TypeConverter..::..StandardValuesCollection^ GetStandardValues(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

Return Value

Type: TypeConverter..::..StandardValuesCollection

See Also

FontNameConverter Class
FontNameConverter Members


FontNameConverter.GetStandardValuesExclusive Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter..::..GetStandardValuesExclusive Method
FontNameConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool GetStandardValuesExclusive(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetStandardValuesExclusive (
    context As ITypeDescriptorContext
) As Boolean
Visual C++
public:
virtual bool GetStandardValuesExclusive(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

Return Value

Type: Boolean

See Also

FontNameConverter Class
FontNameConverter Members


FontNameConverter.GetStandardValuesSupported Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontNameConverter..::..GetStandardValuesSupported Method
FontNameConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool GetStandardValuesSupported(
    ITypeDescriptorContext context
)
Visual Basic
Public Overrides Function GetStandardValuesSupported (
    context As ITypeDescriptorContext
) As Boolean
Visual C++
public:
virtual bool GetStandardValuesSupported(
    ITypeDescriptorContext^ context
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext

Return Value

Type: Boolean

See Also

FontNameConverter Class
FontNameConverter Members


FontUnit Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUnit Enumeration
See Also Send Feedback
Specifies the unit of measure for Font objects.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum FontUnit
Visual Basic
Public Enumeration FontUnit
Visual C++
public enum class FontUnit

Members

Member name | Value | Description
Inch | 0 | Specifies the inch as the unit of measure.
Millimeter | 1 | Specifies the millimeter as the unit of measure.
Pixel | 2 | Specifies the pixel as the unit of measure.
Point | 3 | Specifies the point (1/72 inch) as the unit of measure.

See Also


FrameThickness Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Class
Members See Also Send Feedback
Represents the thickness for the four sides of a frame.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class FrameThickness : INotifyPropertyChanged
Visual Basic
Public Class FrameThickness
    Implements INotifyPropertyChanged
Visual C++
public ref class FrameThickness : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..FrameThickness

See Also

FrameThickness Members


FrameThickness Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Members
FrameThickness Class Constructors Methods Operators Properties Events See Also Send Feedback

The FrameThickness type exposes the following members.

Constructors

 | Name | Description
Public method | FrameThickness()()()() | Initializes a new instance of the FrameThickness class.
Public method | FrameThickness(Double) | Initializes a new instance of the FrameThickness class with a specified uniform length on each side of the frame.
Public method | FrameThickness(Double, Double, Double, Double) | Initializes a new instance of the FrameThickness class with the specified length for each side of the frame.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(FrameThickness) |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | ToString()()()() | Converts the FrameThickness object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the FrameThickness object to a string representation, using the specified CultureInfo.

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | Bottom | Gets or sets the width of the lower side of the frame. Default value is 0 (zero)
Public property | Left | Gets or sets the width of the left side of the frame. Default value is 0 (zero)
Public property | Right | Gets or sets the width of the right side of the frame. Default value is 0 (zero)
Public property | Top | Gets or sets the width of the upper side of the frame. Default value is 0 (zero)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

FrameThickness Class


FrameThickness Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Constructor
FrameThickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | FrameThickness()()()() | Initializes a new instance of the FrameThickness class.
Public method | FrameThickness(Double) | Initializes a new instance of the FrameThickness class with a specified uniform length on each side of the frame.
Public method | FrameThickness(Double, Double, Double, Double) | Initializes a new instance of the FrameThickness class with the specified length for each side of the frame.

See Also

FrameThickness Class
FrameThickness Members


FrameThickness Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Constructor
FrameThickness Class See Also Send Feedback
Initializes a new instance of the FrameThickness class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness()
Visual Basic
Public Sub New
Visual C++
public:
FrameThickness()

See Also

FrameThickness Class
FrameThickness Members
FrameThickness Overload


FrameThickness Constructor (Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Constructor (Double)
FrameThickness Class See Also Send Feedback
Initializes a new instance of the FrameThickness class with a specified uniform length on each side of the frame.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness(
    double uniformLength
)
Visual Basic
Public Sub New (
    uniformLength As Double
)
Visual C++
public:
FrameThickness(
    double uniformLength
)

Parameters

uniformLength
Type: System..::..Double
The uniform length applied to all four sides of the frame.

See Also

FrameThickness Class
FrameThickness Members
FrameThickness Overload


FrameThickness Constructor (Double, Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Constructor (Double, Double, Double, Double)
FrameThickness Class See Also Send Feedback
Initializes a new instance of the FrameThickness class with the specified length for each side of the frame.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness(
    double left,
    double top,
    double right,
    double bottom
)
Visual Basic
Public Sub New (
    left As Double,
    top As Double,
    right As Double,
    bottom As Double
)
Visual C++
public:
FrameThickness(
    double left,
    double top,
    double right,
    double bottom
)

Parameters

left
Type: System..::..Double
The thickness for the left side of the frame.
top
Type: System..::..Double
The thickness for the upper side of the frame.
right
Type: System..::..Double
The thickness for the right side of the frame.
bottom
Type: System..::..Double
The thickness for the lower side of the frame.

See Also

FrameThickness Class
FrameThickness Members
FrameThickness Overload


FrameThickness Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Methods
FrameThickness Class See Also Send Feedback

The FrameThickness type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(FrameThickness) |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | ToString()()()() | Converts the FrameThickness object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the FrameThickness object to a string representation, using the specified CultureInfo.

See Also

FrameThickness Class


FrameThickness.Equals Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Equals Method
FrameThickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(FrameThickness) |

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.Equals Method (Object)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Equals Method (Object)
FrameThickness Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

Return Value

Type: Boolean

See Also

FrameThickness Class
FrameThickness Members
Equals Overload


FrameThickness.Equals Method (FrameThickness)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Equals Method (FrameThickness)
FrameThickness Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Equals(
    FrameThickness frameThickness
)
Visual Basic
Public Function Equals (
    frameThickness As FrameThickness
) As Boolean
Visual C++
public:
bool Equals(
    FrameThickness^ frameThickness
)

Parameters

frameThickness
Type: Neodynamic.SDK.Printing..::..FrameThickness

Return Value

Type: Boolean

See Also

FrameThickness Class
FrameThickness Members
Equals Overload


FrameThickness.GetHashCode Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..GetHashCode Method
FrameThickness Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Type: Int32

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.ToString Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..ToString Method
FrameThickness Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Converts the FrameThickness object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the FrameThickness object to a string representation, using the specified CultureInfo.

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.ToString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..ToString Method
FrameThickness Class See Also Send Feedback
Converts the FrameThickness object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the FrameThickness object in the current culture.

See Also

FrameThickness Class
FrameThickness Members
ToString Overload


FrameThickness.ToString Method (CultureInfo)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..ToString Method (CultureInfo)
FrameThickness Class See Also Send Feedback
Converts the FrameThickness object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic
Public Function ToString (
    culture As CultureInfo
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
A CultureInfo that contains the culture to represent the FrameThickness.

Return Value

Type: String
The string representation of the FrameThickness object in the specified culture.

See Also

FrameThickness Class
FrameThickness Members
ToString Overload


FrameThickness Operators

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Operators
FrameThickness Class See Also Send Feedback

The FrameThickness type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

FrameThickness Class


FrameThickness.Equality Operator

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Equality Operator
FrameThickness Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static bool operator ==(
    FrameThickness ft1,
    FrameThickness ft2
)
Visual Basic
Public Shared Operator = (
    ft1 As FrameThickness,
    ft2 As FrameThickness
) As Boolean
Visual C++
public:
static bool operator ==(
    FrameThickness^ ft1,
    FrameThickness^ ft2
)

Parameters

ft1
Type: Neodynamic.SDK.Printing..::..FrameThickness
ft2
Type: Neodynamic.SDK.Printing..::..FrameThickness

Return Value

Type: Boolean

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.Inequality Operator

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Inequality Operator
FrameThickness Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static bool operator !=(
    FrameThickness ft1,
    FrameThickness ft2
)
Visual Basic
Public Shared Operator <> (
    ft1 As FrameThickness,
    ft2 As FrameThickness
) As Boolean
Visual C++
public:
static bool operator !=(
    FrameThickness^ ft1,
    FrameThickness^ ft2
)

Parameters

ft1
Type: Neodynamic.SDK.Printing..::..FrameThickness
ft2
Type: Neodynamic.SDK.Printing..::..FrameThickness

Return Value

Type: Boolean

See Also

FrameThickness Class
FrameThickness Members


FrameThickness Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Properties
FrameThickness Class See Also Send Feedback

The FrameThickness type exposes the following members.

Properties

 | Name | Description
Public property | Bottom | Gets or sets the width of the lower side of the frame. Default value is 0 (zero)
Public property | Left | Gets or sets the width of the left side of the frame. Default value is 0 (zero)
Public property | Right | Gets or sets the width of the right side of the frame. Default value is 0 (zero)
Public property | Top | Gets or sets the width of the upper side of the frame. Default value is 0 (zero)

See Also

FrameThickness Class


FrameThickness.Bottom Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Bottom Property
FrameThickness Class See Also Send Feedback
Gets or sets the width of the lower side of the frame. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Bottom { get; set; }
Visual Basic
Public Property Bottom As Double
    Get
    Set
Visual C++
public:
property double Bottom {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.Left Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Left Property
FrameThickness Class See Also Send Feedback
Gets or sets the width of the left side of the frame. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Left { get; set; }
Visual Basic
Public Property Left As Double
    Get
    Set
Visual C++
public:
property double Left {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.Right Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Right Property
FrameThickness Class See Also Send Feedback
Gets or sets the width of the right side of the frame. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Right { get; set; }
Visual Basic
Public Property Right As Double
    Get
    Set
Visual C++
public:
property double Right {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

FrameThickness Class
FrameThickness Members


FrameThickness.Top Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..Top Property
FrameThickness Class See Also Send Feedback
Gets or sets the width of the upper side of the frame. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Top { get; set; }
Visual Basic
Public Property Top As Double
    Get
    Set
Visual C++
public:
property double Top {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

FrameThickness Class
FrameThickness Members


FrameThickness Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness Events
FrameThickness Class See Also Send Feedback

The FrameThickness type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

FrameThickness Class


FrameThickness.PropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThickness..::..PropertyChanged Event
FrameThickness Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

FrameThickness Class
FrameThickness Members


FrameThicknessConverter Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter Class
Members See Also Send Feedback
Converts FrameThickness objects from one data type to another. Access the FrameThicknessConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class FrameThicknessConverter : ExpandableObjectConverter
Visual Basic
Public Class FrameThicknessConverter
    Inherits ExpandableObjectConverter
Visual C++
public ref class FrameThicknessConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..ExpandableObjectConverter
Neodynamic.SDK.Printing..::..FrameThicknessConverter

See Also

FrameThicknessConverter Members


FrameThicknessConverter Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter Members
FrameThicknessConverter Class Constructors Methods See Also Send Feedback

The FrameThicknessConverter type exposes the following members.

Constructors

 | Name | Description
Public method | FrameThicknessConverter |

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FrameThicknessConverter Class


FrameThicknessConverter Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter Constructor
FrameThicknessConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThicknessConverter()
Visual Basic
Public Sub New
Visual C++
public:
FrameThicknessConverter()

See Also

FrameThicknessConverter Class
FrameThicknessConverter Members


FrameThicknessConverter Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter Methods
FrameThicknessConverter Class See Also Send Feedback

The FrameThicknessConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

FrameThicknessConverter Class


FrameThicknessConverter.CanConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter..::..CanConvertFrom Method
FrameThicknessConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
sourceType
Type: System..::..Type

Return Value

Type: Boolean

See Also

FrameThicknessConverter Class
FrameThicknessConverter Members


FrameThicknessConverter.CanConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter..::..CanConvertTo Method
FrameThicknessConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
destinationType
Type: System..::..Type

Return Value

Type: Boolean

See Also

FrameThicknessConverter Class
FrameThicknessConverter Members


FrameThicknessConverter.ConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter..::..ConvertFrom Method
FrameThicknessConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object source
)
Visual Basic
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    source As Object
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ source
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
source
Type: System..::..Object

Return Value

Type: Object

See Also

FrameThicknessConverter Class
FrameThicknessConverter Members


FrameThicknessConverter.ConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FrameThicknessConverter..::..ConvertTo Method
FrameThicknessConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

Return Value

Type: Object

See Also

FrameThicknessConverter Class
FrameThicknessConverter Members


HanXinCodeEncoding Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
HanXinCodeEncoding Enumeration
See Also Send Feedback
Specifies the Han Xin Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum HanXinCodeEncoding
Visual Basic
Public Enumeration HanXinCodeEncoding
Visual C++
public enum class HanXinCodeEncoding

Members

Member name | Value | Description
Auto | 0 |
Numeric | 1 | Used to encode data that contains numeric characters
Text | 2 | Used to encode data from common symbols in ISO-8859-1
BinaryByte | 3 | Used to encode 8 bit values
ChineseReg1 | 4 | Used to encode Common Chinese Characters in Region 1 i.e. characters whose first byte value is in the range of B0(HEX) to D7(HEX) and second byte value is in the range of A1(HEX) to FE(HEX), and characters whose first byte value is in the range of A1(HEX) to A3(HEX), and second byte value is in the range of A1(HEX) to FE(HEX), and characters whose byte values are in the range of A8A1(HEX) to A8C0(HEX).
ChineseReg2 | 5 | Used to encode Common Chinese Characters in Region 2 i.e. characters whose first byte value is in the range of D8(HEX) to F7(HEX), and second byte value is in the range of A1(HEX) to FE(HEX).
GB18030Bytes2 | 6 | Used to encode the GB18030 2-byte region i.e. data from all characters (including the Common Chinese Characters in Regions 1 and 2) in GB18030 double-byte region.
GB18030Bytes4 | 7 | Used to encode the GB18030 4-byte region i.e. characters whose first byte value is in the range of 81(HEX) to FE(HEX), and second byte value is in the range of 30(HEX) to 39(HEX), and third byte value is in the range of 81(HEX) to FE(HEX), and fourth byte value is in the range of 30(HEX) to 39(HEX).

See Also


HanXinCodeErrorCorrectionLevel Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
HanXinCodeErrorCorrectionLevel Enumeration
See Also Send Feedback
Specifies the Error Correction Level to apply for Han Xin Code symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum HanXinCodeErrorCorrectionLevel
Visual Basic
Public Enumeration HanXinCodeErrorCorrectionLevel
Visual C++
public enum class HanXinCodeErrorCorrectionLevel

Members

Member name | Value | Description
L1 | 0 | Approx. 8% of codewords can be restored. L1 is appropriate for high symbol quality and/or the need for the smallest possible symbol.
L2 | 1 | Approx. 15% of codewords can be restored. L2 is described as Standard level and offers a good compromise between small size and increased reliability.
L3 | 2 | Approx. 23% of codewords can be restored. L3 is a High reliability level and suitable for more critical or poor print quality applications.
L4 | 3 | Approx. 30% of codewords can be restored. L4 offers the maximum achievable reliability.

See Also


HanXinCodeVersion Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
HanXinCodeVersion Enumeration
See Also Send Feedback
Specifies the Han Xin Code Version to use on that symbology. Version 1 (23 x 23 modules) to Version 84 (189 x 189 modules) increasing in steps of two modules per side.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum HanXinCodeVersion
Visual Basic
Public Enumeration HanXinCodeVersion
Visual C++
public enum class HanXinCodeVersion

Members

Member name | Value | Description
Auto | 0 |
V01 | 1 |
V02 | 2 |
V03 | 3 |
V04 | 4 |
V05 | 5 |
V06 | 6 |
V07 | 7 |
V08 | 8 |
V09 | 9 |
V10 | 10 |
V11 | 11 |
V12 | 12 |
V13 | 13 |
V14 | 14 |
V15 | 15 |
V16 | 16 |
V17 | 17 |
V18 | 18 |
V19 | 19 |
V20 | 20 |
V21 | 21 |
V22 | 22 |
V23 | 23 |
V24 | 24 |
V25 | 25 |
V26 | 26 |
V27 | 27 |
V28 | 28 |
V29 | 29 |
V30 | 30 |
V31 | 31 |
V32 | 32 |
V33 | 33 |
V34 | 34 |
V35 | 35 |
V36 | 36 |
V37 | 37 |
V38 | 38 |
V39 | 39 |
V40 | 40 |
V41 | 41 |
V42 | 42 |
V43 | 43 |
V44 | 44 |
V45 | 45 |
V46 | 46 |
V47 | 47 |
V48 | 48 |
V49 | 49 |
V50 | 50 |
V51 | 51 |
V52 | 52 |
V53 | 53 |
V54 | 54 |
V55 | 55 |
V56 | 56 |
V57 | 57 |
V58 | 58 |
V59 | 59 |
V60 | 60 |
V61 | 61 |
V62 | 62 |
V63 | 63 |
V64 | 64 |
V65 | 65 |
V66 | 66 |
V67 | 67 |
V68 | 68 |
V69 | 69 |
V70 | 70 |
V71 | 71 |
V72 | 72 |
V73 | 73 |
V74 | 74 |
V75 | 75 |
V76 | 76 |
V77 | 77 |
V78 | 78 |
V79 | 79 |
V80 | 80 |
V81 | 81 |
V82 | 82 |
V83 | 83 |
V84 | 84 |

See Also


ImageFormat Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageFormat Enumeration
See Also Send Feedback
Specifies the supported image formats

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum ImageFormat
Visual Basic
Public Enumeration ImageFormat
Visual C++
public enum class ImageFormat

Members

Member name | Value | Description
Bmp | 0 | Specifies the format of the output image is BMP (Bitmap)
Gif | 1 | Specifies the format of the output image is GIF (Graphics Interchange Format)
Jpeg | 2 | Specifies the format of the output image is JPEG (Joint Photographic Experts Group)
Png | 3 | Specifies the format of the output image is PNG (Portable Network Graphics)
Tiff | 4 | Specifies the format of the output image is TIFF (Tagged Image File Format)

See Also


ImageItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Class
Members See Also Send Feedback
Represents an image, picture or graphic item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class ImageItem : Item
Visual Basic
Public Class ImageItem
    Inherits Item
Visual C++
public ref class ImageItem : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ImageItem

See Also

ImageItem Members


ImageItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Members
ImageItem Class Constructors Methods Properties Events See Also Send Feedback

The ImageItem type exposes the following members.

Constructors

 | Name | Description
Public method | ImageItem()()()() | Initializes a new instance of the ImageItem class.
Public method | ImageItem(Double, Double) | Initializes a new instance of the ImageItem class with the specified location.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current ImageItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this ImageItem object with the properties of the specified ImageItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Flip | Gets or sets the axis used for flipping. Default value is None
Public property | Height | Gets or sets the height of the image item. Default value is 0 (zero)
Public property | HideIfNotFound | Gets or sets whether the Image is not displayed or printed if it's not found. Default value is false
Public property | IsGrayscaleOrBlackWhite | Gets or sets whether the pixels composing the source image are grayscale or black and white based. Default is false.
Public property | LockAspectRatio | Gets or sets how source image's proportions are maintained if it is resized. Default value is None
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | MonochromeSettings | Gets the monochrome settings for Black/White conversion. Default value is OtsuThreshold
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on the source image. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | SourceBase64 | Gets or sets the Base64 string of the image content. Default value is an empty string
Public property | SourceBinary | Gets or sets the binary content of the image. Default value is Null
Public property | SourceFile | Gets or sets the image file path or URL. Default value is an empty string
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the image item. Default value is 0 (zero)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ImageItem Class


ImageItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Constructor
ImageItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageItem()()()() | Initializes a new instance of the ImageItem class.
Public method | ImageItem(Double, Double) | Initializes a new instance of the ImageItem class with the specified location.

See Also

ImageItem Class
ImageItem Members


ImageItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Constructor
ImageItem Class See Also Send Feedback
Initializes a new instance of the ImageItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ImageItem()
Visual Basic
Public Sub New
Visual C++
public:
ImageItem()

See Also

ImageItem Class
ImageItem Members
ImageItem Overload


ImageItem Constructor (Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Constructor (Double, Double)
ImageItem Class See Also Send Feedback
Initializes a new instance of the ImageItem class with the specified location.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ImageItem(
    double x,
    double y
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double
)
Visual C++
public:
ImageItem(
    double x,
    double y
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.

See Also

ImageItem Class
ImageItem Members
ImageItem Overload


ImageItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Methods
ImageItem Class See Also Send Feedback

The ImageItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current ImageItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this ImageItem object with the properties of the specified ImageItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

ImageItem Class


ImageItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..Clone Method
ImageItem Class See Also Send Feedback
Creates a copy of the current ImageItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current ImageItem.

See Also

ImageItem Class
ImageItem Members


ImageItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..ConvertToUnit Method
ImageItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

ImageItem Class
ImageItem Members


ImageItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..UpdateFrom Method
ImageItem Class See Also Send Feedback
Updates this ImageItem object with the properties of the specified ImageItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The ImageItem object that is used for updating this ImageItem object.

See Also

ImageItem Class
ImageItem Members


ImageItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Properties
ImageItem Class See Also Send Feedback

The ImageItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Flip | Gets or sets the axis used for flipping. Default value is None
Public property | Height | Gets or sets the height of the image item. Default value is 0 (zero)
Public property | HideIfNotFound | Gets or sets whether the Image is not displayed or printed if it's not found. Default value is false
Public property | IsGrayscaleOrBlackWhite | Gets or sets whether the pixels composing the source image are grayscale or black and white based. Default is false.
Public property | LockAspectRatio | Gets or sets how source image's proportions are maintained if it is resized. Default value is None
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | MonochromeSettings | Gets the monochrome settings for Black/White conversion. Default value is OtsuThreshold
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on the source image. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | SourceBase64 | Gets or sets the Base64 string of the image content. Default value is an empty string
Public property | SourceBinary | Gets or sets the binary content of the image. Default value is Null
Public property | SourceFile | Gets or sets the image file path or URL. Default value is an empty string
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the image item. Default value is 0 (zero)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

ImageItem Class


ImageItem.Flip Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..Flip Property
ImageItem Class See Also Send Feedback
Gets or sets the axis used for flipping. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Flip Flip { get; set; }
Visual Basic
Public Property Flip As Flip
    Get
    Set
Visual C++
public:
property Flip Flip {
    Flip get ();
    void set (Flip value);
}

Property Value

Type: Flip

See Also

ImageItem Class
ImageItem Members


ImageItem.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..Height Property
ImageItem Class See Also Send Feedback
Gets or sets the height of the image item. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ImageItem Class
ImageItem Members


ImageItem.HideIfNotFound Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..HideIfNotFound Property
ImageItem Class See Also Send Feedback
Gets or sets whether the Image is not displayed or printed if it's not found. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool HideIfNotFound { get; set; }
Visual Basic
Public Property HideIfNotFound As Boolean
    Get
    Set
Visual C++
public:
property bool HideIfNotFound {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ImageItem Class
ImageItem Members


ImageItem.IsGrayscaleOrBlackWhite Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..IsGrayscaleOrBlackWhite Property
ImageItem Class See Also Send Feedback
Gets or sets whether the pixels composing the source image are grayscale or black and white based. Default is false.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool IsGrayscaleOrBlackWhite { get; set; }
Visual Basic
Public Property IsGrayscaleOrBlackWhite As Boolean
    Get
    Set
Visual C++
public:
property bool IsGrayscaleOrBlackWhite {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ImageItem Class
ImageItem Members


ImageItem.LockAspectRatio Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..LockAspectRatio Property
ImageItem Class See Also Send Feedback
Gets or sets how source image's proportions are maintained if it is resized. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LockAspectRatio LockAspectRatio { get; set; }
Visual Basic
Public Property LockAspectRatio As LockAspectRatio
    Get
    Set
Visual C++
public:
property LockAspectRatio LockAspectRatio {
    LockAspectRatio get ();
    void set (LockAspectRatio value);
}

Property Value

Type: LockAspectRatio

See Also

ImageItem Class
ImageItem Members


ImageItem.MonochromeSettings Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..MonochromeSettings Property
ImageItem Class See Also Send Feedback
Gets the monochrome settings for Black/White conversion. Default value is OtsuThreshold

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MonochromeSettings MonochromeSettings { get; }
Visual Basic
Public ReadOnly Property MonochromeSettings As MonochromeSettings
    Get
Visual C++
public:
property MonochromeSettings^ MonochromeSettings {
    MonochromeSettings^ get ();
}

Property Value

Type: MonochromeSettings

See Also

ImageItem Class
ImageItem Members


ImageItem.RotationAngle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..RotationAngle Property
ImageItem Class See Also Send Feedback
Gets or sets the rotation angle to apply on the source image. It is measured clockwise from the x-axis. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Integer
    Get
    Set
Visual C++
public:
property int RotationAngle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

ImageItem Class
ImageItem Members


ImageItem.SourceBase64 Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..SourceBase64 Property
ImageItem Class See Also Send Feedback
Gets or sets the Base64 string of the image content. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string SourceBase64 { get; set; }
Visual Basic
Public Property SourceBase64 As String
    Get
    Set
Visual C++
public:
property String^ SourceBase64 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ImageItem Class
ImageItem Members


ImageItem.SourceBinary Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..SourceBinary Property
ImageItem Class See Also Send Feedback
Gets or sets the binary content of the image. Default value is Null

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public byte[] SourceBinary { get; set; }
Visual Basic
Public Property SourceBinary As Byte()
    Get
    Set
Visual C++
public:
property array<unsigned char>^ SourceBinary {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: array< Byte >[]()[][]

See Also

ImageItem Class
ImageItem Members


ImageItem.SourceFile Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..SourceFile Property
ImageItem Class See Also Send Feedback
Gets or sets the image file path or URL. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string SourceFile { get; set; }
Visual Basic
Public Property SourceFile As String
    Get
    Set
Visual C++
public:
property String^ SourceFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ImageItem Class
ImageItem Members


ImageItem.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem..::..Width Property
ImageItem Class See Also Send Feedback
Gets or sets the width of the image item. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ImageItem Class
ImageItem Members


ImageItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItem Events
ImageItem Class See Also Send Feedback

The ImageItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ImageItem Class


ImageSettings Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Class
Members See Also Send Feedback
Defines image output settings for saving labels to raster image formats

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class ImageSettings
Visual Basic
Public Class ImageSettings
Visual C++
public ref class ImageSettings

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..ImageSettings

See Also

ImageSettings Members


ImageSettings Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Members
ImageSettings Class Constructors Properties See Also Send Feedback

The ImageSettings type exposes the following members.

Constructors

 | Name | Description
Public method | ImageSettings()()()() | Initializes a new instance of the ImageSettings class.
Public method | ImageSettings(ImageFormat) | Initializes a new instance of the ImageSettings class with the specified image format.

Properties

 | Name | Description
Public property | ImageFormat | Gets or sets the image format of the resulting image. Default is JPEG.
Public property | JpegQualityLevel | Gets or sets a value that indicates the quality level of the resulting Joint Photographics Experts Group (JPEG) image. The quality level of the JPEG image is expressed numerically and must be between 1 and 100. 100 indicates the highest quality level, while 1 indicates the lowest. The default value is 80.
Public property | PixelFormat | Gets or sets the predefined pixel format of the resulting image. The default value is BGR32.
Public property | TiffCompression | Gets or sets a value that indicates the type of compression that is used by the resulting Tagged Image File Format (TIFF) image. Default is LZW.

See Also

ImageSettings Class


ImageSettings Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Constructor
ImageSettings Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ImageSettings()()()() | Initializes a new instance of the ImageSettings class.
Public method | ImageSettings(ImageFormat) | Initializes a new instance of the ImageSettings class with the specified image format.

See Also

ImageSettings Class
ImageSettings Members


ImageSettings Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Constructor
ImageSettings Class See Also Send Feedback
Initializes a new instance of the ImageSettings class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ImageSettings()
Visual Basic
Public Sub New
Visual C++
public:
ImageSettings()

See Also

ImageSettings Class
ImageSettings Members
ImageSettings Overload


ImageSettings Constructor (ImageFormat)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Constructor (ImageFormat)
ImageSettings Class See Also Send Feedback
Initializes a new instance of the ImageSettings class with the specified image format.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ImageSettings(
    ImageFormat imageFormat
)
Visual Basic
Public Sub New (
    imageFormat As ImageFormat
)
Visual C++
public:
ImageSettings(
    ImageFormat imageFormat
)

Parameters

imageFormat
Type: Neodynamic.SDK.Printing..::..ImageFormat
The image format.

See Also

ImageSettings Class
ImageSettings Members
ImageSettings Overload


ImageSettings Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings Properties
ImageSettings Class See Also Send Feedback

The ImageSettings type exposes the following members.

Properties

 | Name | Description
Public property | ImageFormat | Gets or sets the image format of the resulting image. Default is JPEG.
Public property | JpegQualityLevel | Gets or sets a value that indicates the quality level of the resulting Joint Photographics Experts Group (JPEG) image. The quality level of the JPEG image is expressed numerically and must be between 1 and 100. 100 indicates the highest quality level, while 1 indicates the lowest. The default value is 80.
Public property | PixelFormat | Gets or sets the predefined pixel format of the resulting image. The default value is BGR32.
Public property | TiffCompression | Gets or sets a value that indicates the type of compression that is used by the resulting Tagged Image File Format (TIFF) image. Default is LZW.

See Also

ImageSettings Class


ImageSettings.ImageFormat Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings..::..ImageFormat Property
ImageSettings Class See Also Send Feedback
Gets or sets the image format of the resulting image. Default is JPEG.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ImageFormat ImageFormat { get; set; }
Visual Basic
Public Property ImageFormat As ImageFormat
    Get
    Set
Visual C++
public:
property ImageFormat ImageFormat {
    ImageFormat get ();
    void set (ImageFormat value);
}

Property Value

Type: ImageFormat

See Also

ImageSettings Class
ImageSettings Members


ImageSettings.JpegQualityLevel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings..::..JpegQualityLevel Property
ImageSettings Class See Also Send Feedback
Gets or sets a value that indicates the quality level of the resulting Joint Photographics Experts Group (JPEG) image. The quality level of the JPEG image is expressed numerically and must be between 1 and 100. 100 indicates the highest quality level, while 1 indicates the lowest. The default value is 80.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int JpegQualityLevel { get; set; }
Visual Basic
Public Property JpegQualityLevel As Integer
    Get
    Set
Visual C++
public:
property int JpegQualityLevel {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ImageSettings Class
ImageSettings Members


ImageSettings.PixelFormat Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings..::..PixelFormat Property
ImageSettings Class See Also Send Feedback
Gets or sets the predefined pixel format of the resulting image. The default value is BGR32.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PixelFormat PixelFormat { get; set; }
Visual Basic
Public Property PixelFormat As PixelFormat
    Get
    Set
Visual C++
public:
property PixelFormat PixelFormat {
    PixelFormat get ();
    void set (PixelFormat value);
}

Property Value

Type: PixelFormat

See Also

ImageSettings Class
ImageSettings Members


ImageSettings.TiffCompression Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageSettings..::..TiffCompression Property
ImageSettings Class See Also Send Feedback
Gets or sets a value that indicates the type of compression that is used by the resulting Tagged Image File Format (TIFF) image. Default is LZW.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TiffCompression TiffCompression { get; set; }
Visual Basic
Public Property TiffCompression As TiffCompression
    Get
    Set
Visual C++
public:
property TiffCompression TiffCompression {
    TiffCompression get ();
    void set (TiffCompression value);
}

Property Value

Type: TiffCompression

See Also

ImageSettings Class
ImageSettings Members


Isbt128DataStructure Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Isbt128DataStructure Enumeration
See Also Send Feedback
Specifies the ISBT 128 Data Structures.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Isbt128DataStructure
Visual Basic
Public Enumeration Isbt128DataStructure
Visual C++
public enum class Isbt128DataStructure

Members

Member name | Value | Description
DS001 | 0 | Donation Identification Number
DS002 | 1 | Blood Groups (ABO and RhD)
DS003 | 2 | Product Code
DS004 | 3 | Expiration Date
DS005 | 4 | Expiration Date and Time
DS006 | 5 | Collection Date
DS007 | 6 | Collection Date and Time
DS008 | 7 | Production Date
DS009 | 8 | Production Date and Time
DS010 | 9 | Special Testing: General
DS011 | 10 | Special Testing: Red Blood Cell Antigens (withdrawn)
DS012 | 11 | Special Testing: Red Blood Cell Antigens - General
DS013 | 12 | Special Testing: Red Blood Cell Antigens - Finnish
DS014 | 13 | Special Testing: Platelet HLA and Platelet-Specific Antigens
DS015 | 14 | Special Testing: HLA-A and -B Alleles
DS016 | 15 | Special Testing: HLA-DRB1 Alleles
DS017 | 16 | Container Manufacturer and Catalog Number
DS018 | 17 | Container Lot Number
DS019 | 18 | Donor Identification Number
DS020 | 19 | Staff Member Identification Number
DS021 | 20 | Manufacturer and Catalog Number: Items Other Than Containers
DS022 | 21 | Lot Number: Items Other Than Containers
DS023 | 22 | Compound Message
DS024 | 23 | Patient Date of Birth
DS025 | 24 | Patient Hospital Identification Number
DS026 | 25 | Expiration Month and Year
DS027 | 26 | Infectious Markers
DS028 | 27 | Product Consignment
DS029 | 28 | Dimensions
DS030 | 29 | Red Cell Antigens with Test History
DS031 | 30 | Flexible Date and Time
DS032 | 31 | Product Divisions
DS033 | 32 | Processing Facility Information Code
DS034 | 33 | Processor Product Identification Code

See Also


Item Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended Item class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public abstract class Item : IXmlTemplate,
    INotifyPropertyChanged
Visual Basic
Public MustInherit Class Item
    Implements IXmlTemplate, INotifyPropertyChanged
Visual C++
public ref class Item abstract : IXmlTemplate,
    INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..BarcodeItem
Neodynamic.SDK.Printing..::..ImageItem
Neodynamic.SDK.Printing..::..LiteralItem
Neodynamic.SDK.Printing..::..MultipleSelectionItem
Neodynamic.SDK.Printing..::..RFIDTagItem
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..TextItem

See Also

Item Members


Item Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item Members
Item Class Methods Properties Events See Also Send Feedback

The Item type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object.
Public method | ConvertToUnit | Converts the properties' values from the current Unit to the new specified Unit.
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string.
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string
Public property | Dpi | Gets or sets the item resolution, in dots per inch.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false.
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false.
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string.
Public property | UnitType | Gets or sets the Unit of Measurement for the item.
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

Item Class


Item Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item Methods
Item Class See Also Send Feedback

The Item type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object.
Public method | ConvertToUnit | Converts the properties' values from the current Unit to the new specified Unit.
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object.

See Also

Item Class


Item.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Clone Method
Item Class See Also Send Feedback
When overridden in a derived class, creates an exact copy of this Item object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public abstract Item Clone()
Visual Basic
Public MustOverride Function Clone As Item
Visual C++
public:
virtual Item^ Clone() abstract

Return Value

Type: Item
The new Item object that this method creates.

See Also

Item Class
Item Members


Item.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..ConvertToUnit Method
Item Class See Also Send Feedback
Converts the properties' values from the current Unit to the new specified Unit.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public virtual void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overridable Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

Item Class
Item Members


Item.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..UpdateFrom Method
Item Class See Also Send Feedback
When overridden in a derived class, updates this Item object with the properties of the specified Item object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public abstract void UpdateFrom(
    Item item
)
Visual Basic
Public MustOverride Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) abstract

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The Item object that is used for updating this Item object.

See Also

Item Class
Item Members


Item Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item Properties
Item Class See Also Send Feedback

The Item type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string.
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string
Public property | Dpi | Gets or sets the item resolution, in dots per inch.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false.
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false.
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string.
Public property | UnitType | Gets or sets the Unit of Measurement for the item.
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)

See Also

Item Class


Item.CacheItemId Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..CacheItemId Property
Item Class See Also Send Feedback
Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string CacheItemId { get; set; }
Visual Basic
Public Property CacheItemId As String
    Get
    Set
Visual C++
public:
property String^ CacheItemId {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Item Class
Item Members


Item.Comments Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Comments Property
Item Class See Also Send Feedback
Gets or sets the comments associated to this item. Default is an empty string.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Comments { get; set; }
Visual Basic
Public Property Comments As String
    Get
    Set
Visual C++
public:
property String^ Comments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Item Class
Item Members


Item.DataField Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..DataField Property
Item Class See Also Send Feedback
Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataField { get; set; }
Visual Basic
Public Property DataField As String
    Get
    Set
Visual C++
public:
property String^ DataField {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Item Class
Item Members


Item.DataFieldFormatString Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..DataFieldFormatString Property
Item Class See Also Send Feedback
Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataFieldFormatString { get; set; }
Visual Basic
Public Property DataFieldFormatString As String
    Get
    Set
Visual C++
public:
property String^ DataFieldFormatString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The format syntax must be the same used for the System.String.Format() method of .NET Framework.

See Also

Item Class
Item Members


Item.Dpi Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Dpi Property
Item Class See Also Send Feedback
Gets or sets the item resolution, in dots per inch.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Dpi { get; set; }
Visual Basic
Public Property Dpi As Double
    Get
    Set
Visual C++
public:
property double Dpi {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Item Class
Item Members


Item.Locked Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Locked Property
Item Class See Also Send Feedback
Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Locked { get; set; }
Visual Basic
Public Property Locked As Boolean
    Get
    Set
Visual C++
public:
property bool Locked {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Item Class
Item Members


Item.Name Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Name Property
Item Class See Also Send Feedback
Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Item Class
Item Members


Item.PrintAsGraphic Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..PrintAsGraphic Property
Item Class See Also Send Feedback
Gets or sets whether the item's output is forced to be printed as a graphic. Default is false.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool PrintAsGraphic { get; set; }
Visual Basic
Public Property PrintAsGraphic As Boolean
    Get
    Set
Visual C++
public:
property bool PrintAsGraphic {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

Item Class
Item Members


Item.Tag Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Tag Property
Item Class See Also Send Feedback
Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Tag { get; set; }
Visual Basic
Public Property Tag As String
    Get
    Set
Visual C++
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

Item Class
Item Members


Item.UnitType Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..UnitType Property
Item Class See Also Send Feedback
Gets or sets the Unit of Measurement for the item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public UnitType UnitType { get; set; }
Visual Basic
Public Property UnitType As UnitType
    Get
    Set
Visual C++
public:
property UnitType UnitType {
    UnitType get ();
    void set (UnitType value);
}

Property Value

Type: UnitType

See Also

Item Class
Item Members


Item.UseCache Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..UseCache Property
Item Class See Also Send Feedback
Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool UseCache { get; set; }
Visual Basic
Public Property UseCache As Boolean
    Get
    Set
Visual C++
public:
property bool UseCache {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Remarks

An item should be cached if it displays fixed or static content, for instance, items which display company logos, industry symbols, text messages, etc. By caching this kind of items, you will get a better printing performance.

See Also

Item Class
Item Members


Item.X Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..X Property
Item Class See Also Send Feedback
Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double X { get; set; }
Visual Basic
Public Property X As Double
    Get
    Set
Visual C++
public:
property double X {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Item Class
Item Members


Item.Y Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..Y Property
Item Class See Also Send Feedback
Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Y { get; set; }
Visual Basic
Public Property Y As Double
    Get
    Set
Visual C++
public:
property double Y {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

Item Class
Item Members


Item Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item Events
Item Class See Also Send Feedback

The Item type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

Item Class


Item.PropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Item..::..PropertyChanged Event
Item Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

Item Class
Item Members


ItemCollection Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItemCollection Class
Members See Also Send Feedback
Provides a collection of Item objects.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class ItemCollection : Collection<Item>
Visual Basic
Public Class ItemCollection
    Inherits Collection(Of Item)
Visual C++
public ref class ItemCollection : public Collection<Item^>

Inheritance Hierarchy

System..::..Object
System.Collections.ObjectModel..::..Collection <(Of <(<' Item >)>)>
Neodynamic.SDK.Printing..::..ItemCollection

See Also

ItemCollection Members


ItemCollection Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItemCollection Members
ItemCollection Class Constructors Properties See Also Send Feedback

The ItemCollection type exposes the following members.

Constructors

 | Name | Description
Public method | ItemCollection |

Properties

 | Name | Description
Public property | Item | Gets the first Item in the collection which name is equal to the specified.

See Also

ItemCollection Class


ItemCollection Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItemCollection Constructor
ItemCollection Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ItemCollection()
Visual Basic
Public Sub New
Visual C++
public:
ItemCollection()

See Also

ItemCollection Class
ItemCollection Members


ItemCollection Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItemCollection Properties
ItemCollection Class See Also Send Feedback

The ItemCollection type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the first Item in the collection which name is equal to the specified.

See Also

ItemCollection Class


ItemCollection.Item Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItemCollection..::..Item Property
ItemCollection Class See Also Send Feedback
Gets the first Item in the collection which name is equal to the specified.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Item this[
    string name
] { get; }
Visual Basic
Public ReadOnly Default Property Item (
    name As String
) As Item
    Get
Visual C++
public:
property Item^ default[String^ name] {
    Item^ get (String^ name);
}

Parameters

name
Type: System..::..String

Property Value

Type: Item

See Also

ItemCollection Class
ItemCollection Members


ItfHmark Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ItfHmark Enumeration
See Also Send Feedback
Specifies the seven type of H marks for ITF symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum ItfHmark
Visual Basic
Public Enumeration ItfHmark
Visual C++
public enum class ItfHmark

Members

Member name | Value | Description
None | 0 |
Mark1 | 1 |
Mark2 | 2 |
Mark3 | 3 |
Mark4 | 4 |
Mark5 | 5 |
Mark6 | 6 |
Mark7 | 7 |

See Also


LineOrientation Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineOrientation Enumeration
See Also Send Feedback
Specifies the orientation for line shape items.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum LineOrientation
Visual Basic
Public Enumeration LineOrientation
Visual C++
public enum class LineOrientation

Members

Member name | Value | Description
Horizontal | 0 | Specifies a horizontal line.
Vertical | 1 | Specifies a vertical line.
DiagonalUp | 2 | Specifies a diagonal upward line.
DiagonalDown | 3 | Specifies a diagonal downward line.

See Also


LineShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Class
Members See Also Send Feedback
Represents a line shape item. Use it to create horizontal, vertical and diagonal lines.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class LineShapeItem : ShapeItem
Visual Basic
Public Class LineShapeItem
    Inherits ShapeItem
Visual C++
public ref class LineShapeItem : public ShapeItem

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..LineShapeItem

See Also

LineShapeItem Members


LineShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Members
LineShapeItem Class Constructors Methods Properties Events See Also Send Feedback

The LineShapeItem type exposes the following members.

Constructors

 | Name | Description
Public method | LineShapeItem()()()() | Initializes a new instance of the LineShapeItem class.
Public method | LineShapeItem(Double, Double, Double, Double) | Initializes a new instance of the LineShapeItem class with the specified location and size.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current LineShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this LineShapeItem object with the properties of the specified LineShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | Orientation | Gets or sets the line shape orientation. Default value is Horizontal
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

LineShapeItem Class


LineShapeItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Constructor
LineShapeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LineShapeItem()()()() | Initializes a new instance of the LineShapeItem class.
Public method | LineShapeItem(Double, Double, Double, Double) | Initializes a new instance of the LineShapeItem class with the specified location and size.

See Also

LineShapeItem Class
LineShapeItem Members


LineShapeItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Constructor
LineShapeItem Class See Also Send Feedback
Initializes a new instance of the LineShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LineShapeItem()
Visual Basic
Public Sub New
Visual C++
public:
LineShapeItem()

See Also

LineShapeItem Class
LineShapeItem Members
LineShapeItem Overload


LineShapeItem Constructor (Double, Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Constructor (Double, Double, Double, Double)
LineShapeItem Class See Also Send Feedback
Initializes a new instance of the LineShapeItem class with the specified location and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LineShapeItem(
    double x,
    double y,
    double width,
    double height
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
Visual C++
public:
LineShapeItem(
    double x,
    double y,
    double width,
    double height
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
width
Type: System..::..Double
The width of the item.
height
Type: System..::..Double
The height of the item.

See Also

LineShapeItem Class
LineShapeItem Members
LineShapeItem Overload


LineShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Methods
LineShapeItem Class See Also Send Feedback

The LineShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current LineShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Inherited from ShapeItem.)
Public method | UpdateFrom | Updates this LineShapeItem object with the properties of the specified LineShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

LineShapeItem Class


LineShapeItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem..::..Clone Method
LineShapeItem Class See Also Send Feedback
Creates a copy of the current LineShapeItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current LineShapeItem.

See Also

LineShapeItem Class
LineShapeItem Members


LineShapeItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem..::..UpdateFrom Method
LineShapeItem Class See Also Send Feedback
Updates this LineShapeItem object with the properties of the specified LineShapeItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The LineShapeItem object that is used for updating this LineShapeItem object.

See Also

LineShapeItem Class
LineShapeItem Members


LineShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Properties
LineShapeItem Class See Also Send Feedback

The LineShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | Orientation | Gets or sets the line shape orientation. Default value is Horizontal
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

LineShapeItem Class


LineShapeItem.Orientation Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem..::..Orientation Property
LineShapeItem Class See Also Send Feedback
Gets or sets the line shape orientation. Default value is Horizontal

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LineOrientation Orientation { get; set; }
Visual Basic
Public Property Orientation As LineOrientation
    Get
    Set
Visual C++
public:
property LineOrientation Orientation {
    LineOrientation get ();
    void set (LineOrientation value);
}

Property Value

Type: LineOrientation

See Also

LineShapeItem Class
LineShapeItem Members


LineShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LineShapeItem Events
LineShapeItem Class See Also Send Feedback

The LineShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

LineShapeItem Class


LiteralItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Class
Members See Also Send Feedback
Represents a literal text item. Use it for sending raw printer commands.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class LiteralItem : Item
Visual Basic
Public Class LiteralItem
    Inherits Item
Visual C++
public ref class LiteralItem : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..LiteralItem

See Also

LiteralItem Members


LiteralItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Members
LiteralItem Class Constructors Methods Properties Events See Also Send Feedback

The LiteralItem type exposes the following members.

Constructors

 | Name | Description
Public method | LiteralItem()()()() | Initializes a new instance of the LiteralItem class.
Public method | LiteralItem(String) | Initializes a new instance of the LiteralItem class with the specified text.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current LiteralItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this LiteralItem object with the properties of the specified LiteralItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | Text | Gets or sets the text. Default value is an empty string
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

LiteralItem Class


LiteralItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Constructor
LiteralItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LiteralItem()()()() | Initializes a new instance of the LiteralItem class.
Public method | LiteralItem(String) | Initializes a new instance of the LiteralItem class with the specified text.

See Also

LiteralItem Class
LiteralItem Members


LiteralItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Constructor
LiteralItem Class See Also Send Feedback
Initializes a new instance of the LiteralItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LiteralItem()
Visual Basic
Public Sub New
Visual C++
public:
LiteralItem()

See Also

LiteralItem Class
LiteralItem Members
LiteralItem Overload


LiteralItem Constructor (String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Constructor (String)
LiteralItem Class See Also Send Feedback
Initializes a new instance of the LiteralItem class with the specified text.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public LiteralItem(
    string text
)
Visual Basic
Public Sub New (
    text As String
)
Visual C++
public:
LiteralItem(
    String^ text
)

Parameters

text
Type: System..::..String
The text.

See Also

LiteralItem Class
LiteralItem Members
LiteralItem Overload


LiteralItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Methods
LiteralItem Class See Also Send Feedback

The LiteralItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current LiteralItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this LiteralItem object with the properties of the specified LiteralItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

LiteralItem Class


LiteralItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem..::..Clone Method
LiteralItem Class See Also Send Feedback
Creates a copy of the current LiteralItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current LiteralItem.

See Also

LiteralItem Class
LiteralItem Members


LiteralItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem..::..ConvertToUnit Method
LiteralItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

LiteralItem Class
LiteralItem Members


LiteralItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem..::..UpdateFrom Method
LiteralItem Class See Also Send Feedback
Updates this LiteralItem object with the properties of the specified LiteralItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The LiteralItem object that is used for updating this LiteralItem object.

See Also

LiteralItem Class
LiteralItem Members


LiteralItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Properties
LiteralItem Class See Also Send Feedback

The LiteralItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | Text | Gets or sets the text. Default value is an empty string
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

LiteralItem Class


LiteralItem.Text Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem..::..Text Property
LiteralItem Class See Also Send Feedback
Gets or sets the text. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

LiteralItem Class
LiteralItem Members


LiteralItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LiteralItem Events
LiteralItem Class See Also Send Feedback

The LiteralItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

LiteralItem Class


LockAspectRatio Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LockAspectRatio Enumeration
See Also Send Feedback
Specifies how image's proportions are maintained.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum LockAspectRatio
Visual Basic
Public Enumeration LockAspectRatio
Visual C++
public enum class LockAspectRatio

Members

Member name | Value | Description
None | 0 | Specifies that image's proportions are not maintained.
WidthBased | 1 | Specifies that image's proportions are maintained based on the new width value.
HeightBased | 2 | Specifies that image's proportions are maintained based on the new height value.
Fit | 3 | Specifies that image's proportions are maintained based on the new width and height values.

See Also


MaxiCodeModes Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MaxiCodeModes Enumeration
See Also Send Feedback
Specifies the MaxiCode modes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MaxiCodeModes
Visual Basic
Public Enumeration MaxiCodeModes
Visual C++
public enum class MaxiCodeModes

Members

Member name | Value | Description
Mode2 | 2 | Indicates the symbol contains a Structured Carrier Message with a numeric postal code (U.S.).
Mode3 | 3 | Indicates the symbol contains a Structured Carrier Message with an alphanumeric postal code (non-U.S.).
Mode4 | 4 | Indicates the symbol contains general-purpose data, protected by the standard error correction.
Mode5 | 5 | Indicates the symbol contains general-purpose data, protected by enhanced error correction (EEC).
Mode6 | 6 | Reserved for symbols used to program internal parameters of MaxiCode readers.

See Also


MediaTracking Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MediaTracking Enumeration
See Also Send Feedback
Specifies the media is being used (continuous or non-continuous) for purposes of tracking.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MediaTracking
Visual Basic
Public Enumeration MediaTracking
Visual C++
public enum class MediaTracking

Members

Member name | Value | Description
ContinuousMedia | 0 |
NonContinuousMediaWebSensing | 1 |
NonContinuousMediaMarkSensing | 2 |

See Also


MediaType Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MediaType Enumeration
See Also Send Feedback
Specifies the type of media being used in the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MediaType
Visual Basic
Public Enumeration MediaType
Visual C++
public enum class MediaType

Members

Member name | Value | Description
ThermalTransfer | 0 | This media uses a high-carbon black or colored ribbon. The ink on the ribbon is bonded to the media.
DirectThermal | 1 | This media is heat sensitive and requires no ribbon.

See Also


MicroPdf417Version Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MicroPdf417Version Enumeration
See Also Send Feedback
Specifies the MicroPDF417 version (a predefined combinations of numbers of columns and rows) to be generated.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MicroPdf417Version
Visual Basic
Public Enumeration MicroPdf417Version
Visual C++
public enum class MicroPdf417Version

Members

Member name | Value | Description
Auto | 0 |
V1X11 | 1 |
V1X14 | 2 |
V1X17 | 3 |
V1X20 | 4 |
V1X24 | 5 |
V1X28 | 6 |
V2X8 | 7 |
V2X11 | 8 |
V2X14 | 9 |
V2X17 | 10 |
V2X20 | 11 |
V2X23 | 12 |
V2X26 | 13 |
V3X6 | 14 |
V3X8 | 15 |
V3X10 | 16 |
V3X12 | 17 |
V3X15 | 18 |
V3X20 | 19 |
V3X26 | 20 |
V3X32 | 21 |
V3X38 | 22 |
V3X44 | 23 |
V4X4 | 24 |
V4X6 | 25 |
V4X8 | 26 |
V4X10 | 27 |
V4X12 | 28 |
V4X15 | 29 |
V4X20 | 30 |
V4X26 | 31 |
V4X32 | 32 |
V4X38 | 33 |
V4X44 | 34 |

See Also


MicroQRCodeVersion Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MicroQRCodeVersion Enumeration
See Also Send Feedback
Specifies the Micro QR Code Version to use on that symbology. Version M1 (11 x 11 modules) to Version M4 (17 x 17 modules) increasing in steps of two modules per side.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MicroQRCodeVersion
Visual Basic
Public Enumeration MicroQRCodeVersion
Visual C++
public enum class MicroQRCodeVersion

Members

Member name | Value | Description
Auto | 0 |
M1 | 1 |
M2 | 2 |
M3 | 3 |
M4 | 4 |

See Also


MonochromeSettings Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings Class
Members See Also Send Feedback
Defines monochrome settings used for Black/White conversion.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class MonochromeSettings : INotifyPropertyChanged
Visual Basic
Public Class MonochromeSettings
    Implements INotifyPropertyChanged
Visual C++
public ref class MonochromeSettings : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..MonochromeSettings

See Also

MonochromeSettings Members


MonochromeSettings Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings Members
MonochromeSettings Class Constructors Properties Events See Also Send Feedback

The MonochromeSettings type exposes the following members.

Constructors

 | Name | Description
Public method | MonochromeSettings |

Properties

 | Name | Description
Public property | DitherMethod | Gets or sets the dithering method to be used for monochrome conversion. Default value is OtsuThreshold.
Public property | ReverseEffect | Gets or sets whether monochrome effect should be reversed. Default value is false
Public property | Threshold | Gets or sets the threshold percentage. Values range from 0 to 100. Default value is 50.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

MonochromeSettings Class


MonochromeSettings Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings Constructor
MonochromeSettings Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MonochromeSettings()
Visual Basic
Public Sub New
Visual C++
public:
MonochromeSettings()

See Also

MonochromeSettings Class
MonochromeSettings Members


MonochromeSettings Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings Properties
MonochromeSettings Class See Also Send Feedback

The MonochromeSettings type exposes the following members.

Properties

 | Name | Description
Public property | DitherMethod | Gets or sets the dithering method to be used for monochrome conversion. Default value is OtsuThreshold.
Public property | ReverseEffect | Gets or sets whether monochrome effect should be reversed. Default value is false
Public property | Threshold | Gets or sets the threshold percentage. Values range from 0 to 100. Default value is 50.

See Also

MonochromeSettings Class


MonochromeSettings.DitherMethod Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings..::..DitherMethod Property
MonochromeSettings Class See Also Send Feedback
Gets or sets the dithering method to be used for monochrome conversion. Default value is OtsuThreshold.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public DitherMethod DitherMethod { get; set; }
Visual Basic
Public Property DitherMethod As DitherMethod
    Get
    Set
Visual C++
public:
property DitherMethod DitherMethod {
    DitherMethod get ();
    void set (DitherMethod value);
}

Property Value

Type: DitherMethod

See Also

MonochromeSettings Class
MonochromeSettings Members


MonochromeSettings.ReverseEffect Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings..::..ReverseEffect Property
MonochromeSettings Class See Also Send Feedback
Gets or sets whether monochrome effect should be reversed. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool ReverseEffect { get; set; }
Visual Basic
Public Property ReverseEffect As Boolean
    Get
    Set
Visual C++
public:
property bool ReverseEffect {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

MonochromeSettings Class
MonochromeSettings Members


MonochromeSettings.Threshold Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings..::..Threshold Property
MonochromeSettings Class See Also Send Feedback
Gets or sets the threshold percentage. Values range from 0 to 100. Default value is 50.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Threshold { get; set; }
Visual Basic
Public Property Threshold As Integer
    Get
    Set
Visual C++
public:
property int Threshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

MonochromeSettings Class
MonochromeSettings Members


MonochromeSettings Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings Events
MonochromeSettings Class See Also Send Feedback

The MonochromeSettings type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

MonochromeSettings Class


MonochromeSettings.PropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MonochromeSettings..::..PropertyChanged Event
MonochromeSettings Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

MonochromeSettings Class
MonochromeSettings Members


MsiChecksum Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MsiChecksum Enumeration
See Also Send Feedback
Specifies the checksum method used for MSI barcodes

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum MsiChecksum
Visual Basic
Public Enumeration MsiChecksum
Visual C++
public enum class MsiChecksum

Members

Member name | Value | Description
OneMod10 | 0 |
TwoMod10 | 1 |
Mod11AndMod10 | 2 |

See Also


MultipleSelectionItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Class
Members See Also Send Feedback
Represents a collection of Item-derived classes which have been selected on the visual thermal label editor by the end-user.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class MultipleSelectionItem : Item
Visual Basic
Public Class MultipleSelectionItem
    Inherits Item
Visual C++
public ref class MultipleSelectionItem : public Item

Remarks

This class is used by the visual thermal label editor component mainly and should never be used with the ThermalLabel SDK.

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..MultipleSelectionItem

See Also

MultipleSelectionItem Members


MultipleSelectionItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Members
MultipleSelectionItem Class Constructors Methods Properties Events See Also Send Feedback

The MultipleSelectionItem type exposes the following members.

Constructors

 | Name | Description
Public method | MultipleSelectionItem |

Methods

 | Name | Description
Public method | Clone | (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Items | Gets a collection of Item-derived classes.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

MultipleSelectionItem Class


MultipleSelectionItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Constructor
MultipleSelectionItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public MultipleSelectionItem()
Visual Basic
Public Sub New
Visual C++
public:
MultipleSelectionItem()

See Also

MultipleSelectionItem Class
MultipleSelectionItem Members


MultipleSelectionItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Methods
MultipleSelectionItem Class See Also Send Feedback

The MultipleSelectionItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | (Overrides Item..::..UpdateFrom(Item).)

See Also

MultipleSelectionItem Class


MultipleSelectionItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem..::..Clone Method
MultipleSelectionItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item

See Also

MultipleSelectionItem Class
MultipleSelectionItem Members


MultipleSelectionItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem..::..ConvertToUnit Method
MultipleSelectionItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

MultipleSelectionItem Class
MultipleSelectionItem Members


MultipleSelectionItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem..::..UpdateFrom Method
MultipleSelectionItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item

See Also

MultipleSelectionItem Class
MultipleSelectionItem Members


MultipleSelectionItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Properties
MultipleSelectionItem Class See Also Send Feedback

The MultipleSelectionItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Items | Gets a collection of Item-derived classes.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

MultipleSelectionItem Class


MultipleSelectionItem.Items Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem..::..Items Property
MultipleSelectionItem Class See Also Send Feedback
Gets a collection of Item-derived classes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ItemCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ItemCollection
    Get
Visual C++
public:
property ItemCollection^ Items {
    ItemCollection^ get ();
}

Property Value

Type: ItemCollection

See Also

MultipleSelectionItem Class
MultipleSelectionItem Members


MultipleSelectionItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
MultipleSelectionItem Events
MultipleSelectionItem Class See Also Send Feedback

The MultipleSelectionItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

MultipleSelectionItem Class


Pdf417CompactionType Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Pdf417CompactionType Enumeration
See Also Send Feedback
Specifies the Compaction Type to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Pdf417CompactionType
Visual Basic
Public Enumeration Pdf417CompactionType
Visual C++
public enum class Pdf417CompactionType

Members

Member name | Value | Description
Auto | 0 | It switches between Text, Binary and Numeric modes in order to minimize the number of codewords to be encoded.
Binary | 1 | It allows encoding all 256 possible 8-bit byte values. This includes all ASCII characters value from 0 to 127 inclusive and provides for international character set support.
Text | 2 | It allows encoding all printable ASCII characters, i.e. values from 32 to 126 inclusive in accordance with ISO/IEC 646, as well as selected control characters such as TAB (horizontal tab ASCII 9), LF (NL line feed, new line ASCII 10) and CR (carriage return ASCII 13).
Numeric | 3 | It allows encoding numeric data strings.

See Also


Pdf417ErrorCorrection Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Pdf417ErrorCorrection Enumeration
See Also Send Feedback
Specifies the Error Correction Level to apply for PDF417 symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Pdf417ErrorCorrection
Visual Basic
Public Enumeration Pdf417ErrorCorrection
Visual C++
public enum class Pdf417ErrorCorrection

Members

Member name | Value | Description
Level0 | 0 |
Level1 | 1 |
Level2 | 2 |
Level3 | 3 |
Level4 | 4 |
Level5 | 5 |
Level6 | 6 |
Level7 | 7 |
Level8 | 8 |

See Also


PixelFormat Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PixelFormat Enumeration
See Also Send Feedback
Specifies the supported pixel formats

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum PixelFormat
Visual Basic
Public Enumeration PixelFormat
Visual C++
public enum class PixelFormat

Members

Member name | Value | Description
BGR24 | 0 | BGR24 is a RGB format with 24 bits per pixel (BPP). Each color channel (Blue, Green, and Red) is allocated 8 bits per pixel (BPP).
BGR32 | 1 | BGR32 is a RGB format with 32 bits per pixel (BPP). Each color channel (Blue, Green, and Red) is allocated 8 bits per pixel (BPP).
BGRA32 | 2 | BGRA32 is a RGB format with 32 bits per pixel (BPP). Each color channel (Blue, Green, Red, and Alpha) is allocated 8 bits per pixel (BPP).
PBGRA32 | 3 | PBGRA32 is a RGB format with 32 bits per pixel (BPP). Each color channel (Blue, Green, Red, and Alpha) is allocated 8 bits per pixel (BPP). Each color channel is pre-multiplied by the alpha value.
Monochrome | 4 | Monochrome is a Black and White pixel format which displays one bit of data per pixel as either black or white.
CMYK32 | 5 | CMYK32 is a pixel format which displays 32 bits per pixel (BPP) with each color channel (Cyan, Magenta, Yellow, and Black) allocated 8 bits per pixel (BPP).

See Also


PrinterCommunication Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication Class
Members See Also Send Feedback
Specifies information about printer communication like USB, Serial Port RS-232, Parallel Port (Centronics), and Network (Ethernet) connectivity.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class PrinterCommunication
Visual Basic
Public Class PrinterCommunication
Visual C++
public ref class PrinterCommunication

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..PrinterCommunication

See Also

PrinterCommunication Members


PrinterCommunication Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication Members
PrinterCommunication Class Constructors Properties See Also Send Feedback

The PrinterCommunication type exposes the following members.

Constructors

 | Name | Description
Public method | PrinterCommunication |

Properties

 | Name | Description
Public property | CommunicationType | Gets or sets the printer communication type. Default value is USB
Public property | NetworkIPAddress | Gets or sets the Internet Protocol (IP) address assigned to the printer. Default value is None
Public property | NetworkPort | Gets or sets the port number assigned to the printer. Default value is 0
Public property | NetworkTimeout | Gets or sets the network amount of time in milliseconds. Default value is 1500
Public property | ParallelPortName | Gets or sets the parallel port name, for example LPT1. Default value is "LPT1"
Public property | SerialPortBaudRate | Gets or sets the serial port baud rate in bits per second. Default value is 9600
Public property | SerialPortDataBits | Gets or sets the serial port standard length of data bits per byte. Default value is 8
Public property | SerialPortFlowControl | Gets or sets the handshaking protocol for serial port transmission of data. Default value is XOnXOff
Public property | SerialPortName | Gets or sets the serial port name, for example COM1. Default value is "COM1"
Public property | SerialPortParity | Gets or sets the serial port parity-checking protocol. Default value is None
Public property | SerialPortStopBits | Gets or sets the serial port standard number of stopbits per byte. Default value is One
Public property | Stream | Gets or sets System.IO.Stream object for writing printer commands to. It is used only if the CommunicationType property is set up to Stream value. Default value is Null

See Also

PrinterCommunication Class


PrinterCommunication Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication Constructor
PrinterCommunication Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrinterCommunication()
Visual Basic
Public Sub New
Visual C++
public:
PrinterCommunication()

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication Properties
PrinterCommunication Class See Also Send Feedback

The PrinterCommunication type exposes the following members.

Properties

 | Name | Description
Public property | CommunicationType | Gets or sets the printer communication type. Default value is USB
Public property | NetworkIPAddress | Gets or sets the Internet Protocol (IP) address assigned to the printer. Default value is None
Public property | NetworkPort | Gets or sets the port number assigned to the printer. Default value is 0
Public property | NetworkTimeout | Gets or sets the network amount of time in milliseconds. Default value is 1500
Public property | ParallelPortName | Gets or sets the parallel port name, for example LPT1. Default value is "LPT1"
Public property | SerialPortBaudRate | Gets or sets the serial port baud rate in bits per second. Default value is 9600
Public property | SerialPortDataBits | Gets or sets the serial port standard length of data bits per byte. Default value is 8
Public property | SerialPortFlowControl | Gets or sets the handshaking protocol for serial port transmission of data. Default value is XOnXOff
Public property | SerialPortName | Gets or sets the serial port name, for example COM1. Default value is "COM1"
Public property | SerialPortParity | Gets or sets the serial port parity-checking protocol. Default value is None
Public property | SerialPortStopBits | Gets or sets the serial port standard number of stopbits per byte. Default value is One
Public property | Stream | Gets or sets System.IO.Stream object for writing printer commands to. It is used only if the CommunicationType property is set up to Stream value. Default value is Null

See Also

PrinterCommunication Class


PrinterCommunication.CommunicationType Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..CommunicationType Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the printer communication type. Default value is USB

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CommunicationType CommunicationType { get; set; }
Visual Basic
Public Property CommunicationType As CommunicationType
    Get
    Set
Visual C++
public:
property CommunicationType CommunicationType {
    CommunicationType get ();
    void set (CommunicationType value);
}

Property Value

Type: CommunicationType

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.NetworkIPAddress Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..NetworkIPAddress Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the Internet Protocol (IP) address assigned to the printer. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public IPAddress NetworkIPAddress { get; set; }
Visual Basic
Public Property NetworkIPAddress As IPAddress
    Get
    Set
Visual C++
public:
property IPAddress^ NetworkIPAddress {
    IPAddress^ get ();
    void set (IPAddress^ value);
}

Property Value

Type: IPAddress

Remarks

If the IP address is not specified i.e. it is IPAddress.None, then the PrinterName property of PrinterSettings class will be used as the Printer's Host Name.

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.NetworkPort Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..NetworkPort Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the port number assigned to the printer. Default value is 0

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int NetworkPort { get; set; }
Visual Basic
Public Property NetworkPort As Integer
    Get
    Set
Visual C++
public:
property int NetworkPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.NetworkTimeout Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..NetworkTimeout Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the network amount of time in milliseconds. Default value is 1500

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int NetworkTimeout { get; set; }
Visual Basic
Public Property NetworkTimeout As Integer
    Get
    Set
Visual C++
public:
property int NetworkTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.ParallelPortName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..ParallelPortName Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the parallel port name, for example LPT1. Default value is "LPT1"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string ParallelPortName { get; set; }
Visual Basic
Public Property ParallelPortName As String
    Get
    Set
Visual C++
public:
property String^ ParallelPortName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortBaudRate Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortBaudRate Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the serial port baud rate in bits per second. Default value is 9600

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int SerialPortBaudRate { get; set; }
Visual Basic
Public Property SerialPortBaudRate As Integer
    Get
    Set
Visual C++
public:
property int SerialPortBaudRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortDataBits Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortDataBits Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the serial port standard length of data bits per byte. Default value is 8

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int SerialPortDataBits { get; set; }
Visual Basic
Public Property SerialPortDataBits As Integer
    Get
    Set
Visual C++
public:
property int SerialPortDataBits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortFlowControl Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortFlowControl Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the handshaking protocol for serial port transmission of data. Default value is XOnXOff

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Handshake SerialPortFlowControl { get; set; }
Visual Basic
Public Property SerialPortFlowControl As Handshake
    Get
    Set
Visual C++
public:
property Handshake SerialPortFlowControl {
    Handshake get ();
    void set (Handshake value);
}

Property Value

Type: Handshake

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortName Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the serial port name, for example COM1. Default value is "COM1"

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string SerialPortName { get; set; }
Visual Basic
Public Property SerialPortName As String
    Get
    Set
Visual C++
public:
property String^ SerialPortName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortParity Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortParity Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the serial port parity-checking protocol. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Parity SerialPortParity { get; set; }
Visual Basic
Public Property SerialPortParity As Parity
    Get
    Set
Visual C++
public:
property Parity SerialPortParity {
    Parity get ();
    void set (Parity value);
}

Property Value

Type: Parity

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.SerialPortStopBits Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..SerialPortStopBits Property
PrinterCommunication Class See Also Send Feedback
Gets or sets the serial port standard number of stopbits per byte. Default value is One

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public StopBits SerialPortStopBits { get; set; }
Visual Basic
Public Property SerialPortStopBits As StopBits
    Get
    Set
Visual C++
public:
property StopBits SerialPortStopBits {
    StopBits get ();
    void set (StopBits value);
}

Property Value

Type: StopBits

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterCommunication.Stream Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterCommunication..::..Stream Property
PrinterCommunication Class See Also Send Feedback
Gets or sets System.IO.Stream object for writing printer commands to. It is used only if the CommunicationType property is set up to Stream value. Default value is Null

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Stream Stream { get; set; }
Visual Basic
Public Property Stream As Stream
    Get
    Set
Visual C++
public:
property Stream^ Stream {
    Stream^ get ();
    void set (Stream^ value);
}

Property Value

Type: Stream

See Also

PrinterCommunication Class
PrinterCommunication Members


PrinterSettings Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings Class
Members See Also Send Feedback
Specifies information about the thermal printer used to print out a label, including printer id/name, printing resolution (DPI) and device connection like USB, Serial Port, Parallel Port and Network.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class PrinterSettings
Visual Basic
Public Class PrinterSettings
Visual C++
public ref class PrinterSettings

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..PrinterSettings

See Also

PrinterSettings Members


PrinterSettings Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings Members
PrinterSettings Class Constructors Properties See Also Send Feedback

The PrinterSettings type exposes the following members.

Constructors

 | Name | Description
Public method | PrinterSettings |

Properties

 | Name | Description
Public property | Communication | Gets information about printer communication. Default value is USB
Public property | Dpi | Gets or sets the printing resolution, in dots per inch, that is supported by the printer. Default value is 203
Public property | PrinterName | Gets or sets the name of the printer. Default value is an empty string
Public property | ProgrammingLanguage | Gets or sets the core programming language supported by the printer. Default value is ZPL.
Public property | UseDefaultPrinter | Gets or sets whether to use the system's default printer name. Default is false.

See Also

PrinterSettings Class


PrinterSettings Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings Constructor
PrinterSettings Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrinterSettings()
Visual Basic
Public Sub New
Visual C++
public:
PrinterSettings()

See Also

PrinterSettings Class
PrinterSettings Members


PrinterSettings Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings Properties
PrinterSettings Class See Also Send Feedback

The PrinterSettings type exposes the following members.

Properties

 | Name | Description
Public property | Communication | Gets information about printer communication. Default value is USB
Public property | Dpi | Gets or sets the printing resolution, in dots per inch, that is supported by the printer. Default value is 203
Public property | PrinterName | Gets or sets the name of the printer. Default value is an empty string
Public property | ProgrammingLanguage | Gets or sets the core programming language supported by the printer. Default value is ZPL.
Public property | UseDefaultPrinter | Gets or sets whether to use the system's default printer name. Default is false.

See Also

PrinterSettings Class


PrinterSettings.Communication Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings..::..Communication Property
PrinterSettings Class See Also Send Feedback
Gets information about printer communication. Default value is USB

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrinterCommunication Communication { get; }
Visual Basic
Public ReadOnly Property Communication As PrinterCommunication
    Get
Visual C++
public:
property PrinterCommunication^ Communication {
    PrinterCommunication^ get ();
}

Property Value

Type: PrinterCommunication

See Also

PrinterSettings Class
PrinterSettings Members


PrinterSettings.Dpi Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings..::..Dpi Property
PrinterSettings Class See Also Send Feedback
Gets or sets the printing resolution, in dots per inch, that is supported by the printer. Default value is 203

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Dpi { get; set; }
Visual Basic
Public Property Dpi As Double
    Get
    Set
Visual C++
public:
property double Dpi {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

PrinterSettings Class
PrinterSettings Members


PrinterSettings.PrinterName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings..::..PrinterName Property
PrinterSettings Class See Also Send Feedback
Gets or sets the name of the printer. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string PrinterName { get; set; }
Visual Basic
Public Property PrinterName As String
    Get
    Set
Visual C++
public:
property String^ PrinterName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The printer name must be used when the printer communication type is USB, PrinterDriver (an installed Windows Driver) or Network (in case the host name is known and not its IP address).

See Also

PrinterSettings Class
PrinterSettings Members


PrinterSettings.ProgrammingLanguage Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings..::..ProgrammingLanguage Property
PrinterSettings Class See Also Send Feedback
Gets or sets the core programming language supported by the printer. Default value is ZPL.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ProgrammingLanguage ProgrammingLanguage { get; set; }
Visual Basic
Public Property ProgrammingLanguage As ProgrammingLanguage
    Get
    Set
Visual C++
public:
property ProgrammingLanguage ProgrammingLanguage {
    ProgrammingLanguage get ();
    void set (ProgrammingLanguage value);
}

Property Value

Type: ProgrammingLanguage

See Also

PrinterSettings Class
PrinterSettings Members


PrinterSettings.UseDefaultPrinter Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrinterSettings..::..UseDefaultPrinter Property
PrinterSettings Class See Also Send Feedback
Gets or sets whether to use the system's default printer name. Default is false.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool UseDefaultPrinter { get; set; }
Visual Basic
Public Property UseDefaultPrinter As Boolean
    Get
    Set
Visual C++
public:
property bool UseDefaultPrinter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PrinterSettings Class
PrinterSettings Members


PrintJob Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Class
Members See Also Send Feedback
Specifies information about how a thermal label is printed, including the printer device settings, label orientation, number of copies, etc.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class PrintJob : IDisposable
Visual Basic
Public Class PrintJob
    Implements IDisposable
Visual C++
public ref class PrintJob : IDisposable

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..PrintJob

See Also

PrintJob Members


PrintJob Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Members
PrintJob Class Constructors Methods Properties See Also Send Feedback

The PrintJob type exposes the following members.

Constructors

 | Name | Description
Public method | PrintJob()()()() | Initializes a new instance of the PrintJob class
Public method | PrintJob(PrinterSettings) | Initializes a new instance of the PrintJob class with the specified printer settings.

Methods

 | Name | Description
Public method | BufferFlush | Sends all currently buffered output commands to the printer. It requires buffer is enabled on this print job through BufferOutput property.
Public method | CleanCache | Clenas the cache on the printer's memory. Important: It must be invoked after the Print method i.e as the last step of the print job process.
Public method | Dispose |
Public method | ExportToImage(Stream, ImageSettings, Double) | Exports and saves this PrintJob to the specified Stream object and image settings.
Public method | ExportToImage(String, ImageSettings, Double) | Exports and saves this PrintJob to the specified file and image settings.
Public method | ExportToImage(ThermalLabel, Stream, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object and image settings.
Public method | ExportToImage(ThermalLabel, String, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified file and image settings.
Public method | ExportToPdf(Stream, Double) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(Stream, Double, Int32) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double, Int32) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.
Public method | GetNativePrinterCommands()()()() | Generates the native printer commands for this print job settings.
Public method | GetNativePrinterCommands(ThermalLabel) | Generates the native printer commands for this print job settings and the specified ThermalLabel object.
Public method | Print()()()() | Starts the thermal label's printing process.
Public method | Print(ThermalLabel) | Starts the printing process of the specified ThermalLabel object.
Public method | Print(List<(Of <<'(ThermalLabel>)>>)) | Starts the printing process of the specified group of ThermalLabel objects.
Public method | StartCache | Starts the caching process uploading to the printer's memory all items marked with UseCache on the ThermalLabel object. Important: It must be invoked before the Print method.

Properties

 | Name | Description
Public property | BufferOutput | Gets or sets a value indicating whether to buffer output printer commands. When the printer commands are buffered, the print job does not send them to the printer until the print job has been processed, or until the BufferFlush method is invoked. Default value is false i.e. the output is not buffered but sent to the printer while processing the print job.
Public property | Copies | Gets or sets the number of copies of the thermal label to print. Default value is 1
Public property | PrinterSettings | Gets or sets information about the thermal printer used for printing.
Public property | PrintOrientation | Gets or sets the page orientation used to print the thermal label. Default value is Portrait
Public property | Replicates | Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)
Public property | ThermalLabel | Gets or sets the ThermalLabel object to be printed out. Default value is Null

See Also

PrintJob Class


PrintJob Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Constructor
PrintJob Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PrintJob()()()() | Initializes a new instance of the PrintJob class
Public method | PrintJob(PrinterSettings) | Initializes a new instance of the PrintJob class with the specified printer settings.

See Also

PrintJob Class
PrintJob Members


PrintJob Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Constructor
PrintJob Class See Also Send Feedback
Initializes a new instance of the PrintJob class

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrintJob()
Visual Basic
Public Sub New
Visual C++
public:
PrintJob()

See Also

PrintJob Class
PrintJob Members
PrintJob Overload


PrintJob Constructor (PrinterSettings)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Constructor (PrinterSettings)
PrintJob Class See Also Send Feedback
Initializes a new instance of the PrintJob class with the specified printer settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrintJob(
    PrinterSettings printerSettings
)
Visual Basic
Public Sub New (
    printerSettings As PrinterSettings
)
Visual C++
public:
PrintJob(
    PrinterSettings^ printerSettings
)

Parameters

printerSettings
Type: Neodynamic.SDK.Printing..::..PrinterSettings
The printer settings which provides info about the target printer.

See Also

PrintJob Class
PrintJob Members
PrintJob Overload


PrintJob Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Methods
PrintJob Class See Also Send Feedback

The PrintJob type exposes the following members.

Methods

 | Name | Description
Public method | BufferFlush | Sends all currently buffered output commands to the printer. It requires buffer is enabled on this print job through BufferOutput property.
Public method | CleanCache | Clenas the cache on the printer's memory. Important: It must be invoked after the Print method i.e as the last step of the print job process.
Public method | Dispose |
Public method | ExportToImage(Stream, ImageSettings, Double) | Exports and saves this PrintJob to the specified Stream object and image settings.
Public method | ExportToImage(String, ImageSettings, Double) | Exports and saves this PrintJob to the specified file and image settings.
Public method | ExportToImage(ThermalLabel, Stream, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object and image settings.
Public method | ExportToImage(ThermalLabel, String, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified file and image settings.
Public method | ExportToPdf(Stream, Double) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(Stream, Double, Int32) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double, Int32) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.
Public method | GetNativePrinterCommands()()()() | Generates the native printer commands for this print job settings.
Public method | GetNativePrinterCommands(ThermalLabel) | Generates the native printer commands for this print job settings and the specified ThermalLabel object.
Public method | Print()()()() | Starts the thermal label's printing process.
Public method | Print(ThermalLabel) | Starts the printing process of the specified ThermalLabel object.
Public method | Print(List<(Of <<'(ThermalLabel>)>>)) | Starts the printing process of the specified group of ThermalLabel objects.
Public method | StartCache | Starts the caching process uploading to the printer's memory all items marked with UseCache on the ThermalLabel object. Important: It must be invoked before the Print method.

See Also

PrintJob Class


PrintJob.BufferFlush Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..BufferFlush Method
PrintJob Class See Also Send Feedback
Sends all currently buffered output commands to the printer. It requires buffer is enabled on this print job through BufferOutput property.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void BufferFlush()
Visual Basic
Public Sub BufferFlush
Visual C++
public:
void BufferFlush()

Remarks

Forces all currently buffered output commands to be sent to the printer. This method can be invoked multiple times during print job processing.

See Also

PrintJob Class
PrintJob Members


PrintJob.CleanCache Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..CleanCache Method
PrintJob Class See Also Send Feedback
Clenas the cache on the printer's memory. Important: It must be invoked after the Print method i.e as the last step of the print job process.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void CleanCache()
Visual Basic
Public Sub CleanCache
Visual C++
public:
void CleanCache()

See Also

PrintJob Class
PrintJob Members


PrintJob.Dispose Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Dispose Method
PrintJob Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

Implements

IDisposable..::..Dispose()()()()

See Also

PrintJob Class
PrintJob Members


PrintJob.ExportToImage Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToImage Method
PrintJob Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportToImage(Stream, ImageSettings, Double) | Exports and saves this PrintJob to the specified Stream object and image settings.
Public method | ExportToImage(String, ImageSettings, Double) | Exports and saves this PrintJob to the specified file and image settings.
Public method | ExportToImage(ThermalLabel, Stream, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object and image settings.
Public method | ExportToImage(ThermalLabel, String, ImageSettings, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified file and image settings.

See Also

PrintJob Class
PrintJob Members


PrintJob.ExportToImage Method (Stream, ImageSettings, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToImage Method (Stream, ImageSettings, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified Stream object and image settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToImage(
    Stream stream,
    ImageSettings imgSettings,
    double dpi
)
Visual Basic
Public Sub ExportToImage (
    stream As Stream,
    imgSettings As ImageSettings,
    dpi As Double
)
Visual C++
public:
void ExportToImage(
    Stream^ stream,
    ImageSettings^ imgSettings,
    double dpi
)

Parameters

stream
Type: System.IO..::..Stream
The Stream object to which to save the output image.
imgSettings
Type: Neodynamic.SDK.Printing..::..ImageSettings
The ImageSettings object.
dpi
Type: System..::..Double
The resolution for the output image.

See Also

PrintJob Class
PrintJob Members
ExportToImage Overload


PrintJob.ExportToImage Method (String, ImageSettings, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToImage Method (String, ImageSettings, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified file and image settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToImage(
    string pathFile,
    ImageSettings imgSettings,
    double dpi
)
Visual Basic
Public Sub ExportToImage (
    pathFile As String,
    imgSettings As ImageSettings,
    dpi As Double
)
Visual C++
public:
void ExportToImage(
    String^ pathFile,
    ImageSettings^ imgSettings,
    double dpi
)

Parameters

pathFile
Type: System..::..String
A string that contains the name of the file to which to save the output image.
imgSettings
Type: Neodynamic.SDK.Printing..::..ImageSettings
The ImageSettings object.
dpi
Type: System..::..Double
The resolution for the output image.

See Also

PrintJob Class
PrintJob Members
ExportToImage Overload


PrintJob.ExportToImage Method (ThermalLabel, Stream, ImageSettings, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToImage Method (ThermalLabel, Stream, ImageSettings, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified Stream object and image settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToImage(
    ThermalLabel thermalLabel,
    Stream stream,
    ImageSettings imgSettings,
    double dpi
)
Visual Basic
Public Sub ExportToImage (
    thermalLabel As ThermalLabel,
    stream As Stream,
    imgSettings As ImageSettings,
    dpi As Double
)
Visual C++
public:
void ExportToImage(
    ThermalLabel^ thermalLabel,
    Stream^ stream,
    ImageSettings^ imgSettings,
    double dpi
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
stream
Type: System.IO..::..Stream
The Stream object to which to save the output image.
imgSettings
Type: Neodynamic.SDK.Printing..::..ImageSettings
The ImageSettings object.
dpi
Type: System..::..Double
The resolution for the output image.

See Also

PrintJob Class
PrintJob Members
ExportToImage Overload


PrintJob.ExportToImage Method (ThermalLabel, String, ImageSettings, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToImage Method (ThermalLabel, String, ImageSettings, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified file and image settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToImage(
    ThermalLabel thermalLabel,
    string pathFile,
    ImageSettings imgSettings,
    double dpi
)
Visual Basic
Public Sub ExportToImage (
    thermalLabel As ThermalLabel,
    pathFile As String,
    imgSettings As ImageSettings,
    dpi As Double
)
Visual C++
public:
void ExportToImage(
    ThermalLabel^ thermalLabel,
    String^ pathFile,
    ImageSettings^ imgSettings,
    double dpi
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
pathFile
Type: System..::..String
A string that contains the name of the file to which to save the output image.
imgSettings
Type: Neodynamic.SDK.Printing..::..ImageSettings
The ImageSettings object.
dpi
Type: System..::..Double
The resolution for the output image.

See Also

PrintJob Class
PrintJob Members
ExportToImage Overload


PrintJob.ExportToPdf Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method
PrintJob Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExportToPdf(Stream, Double) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(Stream, Double, Int32) | Exports and saves this PrintJob to the specified Stream object in PDF format.
Public method | ExportToPdf(String, Double, Int32) | Exports and saves this PrintJob to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.
Public method | ExportToPdf(ThermalLabel, Stream, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.
Public method | ExportToPdf(ThermalLabel, String, Double, Int32) | Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.

See Also

PrintJob Class
PrintJob Members


PrintJob.ExportToPdf Method (Stream, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (Stream, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified Stream object in PDF format.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    Stream stream,
    double dpi
)
Visual Basic
Public Sub ExportToPdf (
    stream As Stream,
    dpi As Double
)
Visual C++
public:
void ExportToPdf(
    Stream^ stream,
    double dpi
)

Parameters

stream
Type: System.IO..::..Stream
The Stream object to which to save the output image in PDF format.
dpi
Type: System..::..Double
The resolution for the output image in the PDF Stream.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (String, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (String, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified PDF file.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    string pathFile,
    double dpi
)
Visual Basic
Public Sub ExportToPdf (
    pathFile As String,
    dpi As Double
)
Visual C++
public:
void ExportToPdf(
    String^ pathFile,
    double dpi
)

Parameters

pathFile
Type: System..::..String
A string that contains the name of the PDF file to which to save the output image.
dpi
Type: System..::..Double
The resolution for the output image in the PDF file.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (Stream, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (Stream, Double, Int32)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified Stream object in PDF format.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    Stream stream,
    double dpi,
    int outputQuality
)
Visual Basic
Public Sub ExportToPdf (
    stream As Stream,
    dpi As Double,
    outputQuality As Integer
)
Visual C++
public:
void ExportToPdf(
    Stream^ stream,
    double dpi,
    int outputQuality
)

Parameters

stream
Type: System.IO..::..Stream
The Stream object to which to save the output image in PDF format.
dpi
Type: System..::..Double
The resolution for the output image in the PDF Stream.
outputQuality
Type: System..::..Int32
The quality level for the label image in the PDF Stream which is in JPEG format. It must be an integer between 1 and 100.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (String, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (String, Double, Int32)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob to the specified PDF file.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    string pathFile,
    double dpi,
    int outputQuality
)
Visual Basic
Public Sub ExportToPdf (
    pathFile As String,
    dpi As Double,
    outputQuality As Integer
)
Visual C++
public:
void ExportToPdf(
    String^ pathFile,
    double dpi,
    int outputQuality
)

Parameters

pathFile
Type: System..::..String
A string that contains the name of the PDF file to which to save the output image.
dpi
Type: System..::..Double
The resolution for the output image in the PDF file.
outputQuality
Type: System..::..Int32
The quality level for the label image in the PDF file which is in JPEG format. It must be an integer between 1 and 100.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (ThermalLabel, Stream, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (ThermalLabel, Stream, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    ThermalLabel thermalLabel,
    Stream stream,
    double dpi
)
Visual Basic
Public Sub ExportToPdf (
    thermalLabel As ThermalLabel,
    stream As Stream,
    dpi As Double
)
Visual C++
public:
void ExportToPdf(
    ThermalLabel^ thermalLabel,
    Stream^ stream,
    double dpi
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
stream
Type: System.IO..::..Stream
The Stream object to which to save the output image in PDF format.
dpi
Type: System..::..Double
The resolution for the output image in the PDF Stream.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (ThermalLabel, String, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (ThermalLabel, String, Double)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    ThermalLabel thermalLabel,
    string pathFile,
    double dpi
)
Visual Basic
Public Sub ExportToPdf (
    thermalLabel As ThermalLabel,
    pathFile As String,
    dpi As Double
)
Visual C++
public:
void ExportToPdf(
    ThermalLabel^ thermalLabel,
    String^ pathFile,
    double dpi
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
pathFile
Type: System..::..String
A string that contains the name of the PDF file to which to save the output image.
dpi
Type: System..::..Double
The resolution for the output image in the PDF file.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (ThermalLabel, Stream, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (ThermalLabel, Stream, Double, Int32)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified Stream object in PDF format.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    ThermalLabel thermalLabel,
    Stream stream,
    double dpi,
    int outputQuality
)
Visual Basic
Public Sub ExportToPdf (
    thermalLabel As ThermalLabel,
    stream As Stream,
    dpi As Double,
    outputQuality As Integer
)
Visual C++
public:
void ExportToPdf(
    ThermalLabel^ thermalLabel,
    Stream^ stream,
    double dpi,
    int outputQuality
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
stream
Type: System.IO..::..Stream
The Stream object to which to save the output image in PDF format.
dpi
Type: System..::..Double
The resolution for the output image in the PDF Stream.
outputQuality
Type: System..::..Int32
The quality level for the label image in the PDF Stream which is in JPEG format. It must be an integer between 1 and 100.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.ExportToPdf Method (ThermalLabel, String, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ExportToPdf Method (ThermalLabel, String, Double, Int32)
PrintJob Class See Also Send Feedback
Exports and saves this PrintJob and ThermalLabel object to the specified PDF file.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void ExportToPdf(
    ThermalLabel thermalLabel,
    string pathFile,
    double dpi,
    int outputQuality
)
Visual Basic
Public Sub ExportToPdf (
    thermalLabel As ThermalLabel,
    pathFile As String,
    dpi As Double,
    outputQuality As Integer
)
Visual C++
public:
void ExportToPdf(
    ThermalLabel^ thermalLabel,
    String^ pathFile,
    double dpi,
    int outputQuality
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object.
pathFile
Type: System..::..String
A string that contains the name of the PDF file to which to save the output image.
dpi
Type: System..::..Double
The resolution for the output image in the PDF file.
outputQuality
Type: System..::..Int32
The quality level for the label image in the PDF file which is in JPEG format. It must be an integer between 1 and 100.

See Also

PrintJob Class
PrintJob Members
ExportToPdf Overload


PrintJob.GetNativePrinterCommands Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..GetNativePrinterCommands Method
PrintJob Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetNativePrinterCommands()()()() | Generates the native printer commands for this print job settings.
Public method | GetNativePrinterCommands(ThermalLabel) | Generates the native printer commands for this print job settings and the specified ThermalLabel object.

See Also

PrintJob Class
PrintJob Members


PrintJob.GetNativePrinterCommands Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..GetNativePrinterCommands Method
PrintJob Class See Also Send Feedback
Generates the native printer commands for this print job settings.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string GetNativePrinterCommands()
Visual Basic
Public Function GetNativePrinterCommands As String
Visual C++
public:
String^ GetNativePrinterCommands()

Return Value

Type: String
The native printer commands for this print job settings.

See Also

PrintJob Class
PrintJob Members
GetNativePrinterCommands Overload


PrintJob.GetNativePrinterCommands Method (ThermalLabel)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..GetNativePrinterCommands Method (ThermalLabel)
PrintJob Class See Also Send Feedback
Generates the native printer commands for this print job settings and the specified ThermalLabel object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string GetNativePrinterCommands(
    ThermalLabel thermalLabel
)
Visual Basic
Public Function GetNativePrinterCommands (
    thermalLabel As ThermalLabel
) As String
Visual C++
public:
String^ GetNativePrinterCommands(
    ThermalLabel^ thermalLabel
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object to print out.

Return Value

Type: String
The native printer commands for this print job settings and the specified ThermalLabel object.

See Also

PrintJob Class
PrintJob Members
GetNativePrinterCommands Overload


PrintJob.Print Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Print Method
PrintJob Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Print()()()() | Starts the thermal label's printing process.
Public method | Print(ThermalLabel) | Starts the printing process of the specified ThermalLabel object.
Public method | Print(List<(Of <<'(ThermalLabel>)>>)) | Starts the printing process of the specified group of ThermalLabel objects.

See Also

PrintJob Class
PrintJob Members


PrintJob.Print Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Print Method
PrintJob Class See Also Send Feedback
Starts the thermal label's printing process.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void Print()
Visual Basic
Public Sub Print
Visual C++
public:
void Print()

See Also

PrintJob Class
PrintJob Members
Print Overload


PrintJob.Print Method (ThermalLabel)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Print Method (ThermalLabel)
PrintJob Class See Also Send Feedback
Starts the printing process of the specified ThermalLabel object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void Print(
    ThermalLabel thermalLabel
)
Visual Basic
Public Sub Print (
    thermalLabel As ThermalLabel
)
Visual C++
public:
void Print(
    ThermalLabel^ thermalLabel
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
The ThermalLabel object to print out.

See Also

PrintJob Class
PrintJob Members
Print Overload


PrintJob.Print Method (List(ThermalLabel))

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Print Method (List<(Of <(<'ThermalLabel>)>)>)
PrintJob Class See Also Send Feedback
Starts the printing process of the specified group of ThermalLabel objects.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void Print(
    List<ThermalLabel> thermalLabelGroup
)
Visual Basic
Public Sub Print (
    thermalLabelGroup As List(Of ThermalLabel)
)
Visual C++
public:
void Print(
    List<ThermalLabel^>^ thermalLabelGroup
)

Parameters

thermalLabelGroup
Type: System.Collections.Generic..::..List <(Of <(<' ThermalLabel >)>)>
The group of ThermalLabel objects to print out.

See Also

PrintJob Class
PrintJob Members
Print Overload


PrintJob.StartCache Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..StartCache Method
PrintJob Class See Also Send Feedback
Starts the caching process uploading to the printer's memory all items marked with UseCache on the ThermalLabel object. Important: It must be invoked before the Print method.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void StartCache()
Visual Basic
Public Sub StartCache
Visual C++
public:
void StartCache()

See Also

PrintJob Class
PrintJob Members


PrintJob Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob Properties
PrintJob Class See Also Send Feedback

The PrintJob type exposes the following members.

Properties

 | Name | Description
Public property | BufferOutput | Gets or sets a value indicating whether to buffer output printer commands. When the printer commands are buffered, the print job does not send them to the printer until the print job has been processed, or until the BufferFlush method is invoked. Default value is false i.e. the output is not buffered but sent to the printer while processing the print job.
Public property | Copies | Gets or sets the number of copies of the thermal label to print. Default value is 1
Public property | PrinterSettings | Gets or sets information about the thermal printer used for printing.
Public property | PrintOrientation | Gets or sets the page orientation used to print the thermal label. Default value is Portrait
Public property | Replicates | Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)
Public property | ThermalLabel | Gets or sets the ThermalLabel object to be printed out. Default value is Null

See Also

PrintJob Class


PrintJob.BufferOutput Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..BufferOutput Property
PrintJob Class See Also Send Feedback
Gets or sets a value indicating whether to buffer output printer commands. When the printer commands are buffered, the print job does not send them to the printer until the print job has been processed, or until the BufferFlush method is invoked. Default value is false i.e. the output is not buffered but sent to the printer while processing the print job.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool BufferOutput { get; set; }
Visual Basic
Public Property BufferOutput As Boolean
    Get
    Set
Visual C++
public:
property bool BufferOutput {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

PrintJob Class
PrintJob Members


PrintJob.Copies Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Copies Property
PrintJob Class See Also Send Feedback
Gets or sets the number of copies of the thermal label to print. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Copies { get; set; }
Visual Basic
Public Property Copies As Integer
    Get
    Set
Visual C++
public:
property int Copies {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrintJob Class
PrintJob Members


PrintJob.PrinterSettings Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..PrinterSettings Property
PrintJob Class See Also Send Feedback
Gets or sets information about the thermal printer used for printing.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrinterSettings PrinterSettings { get; set; }
Visual Basic
Public Property PrinterSettings As PrinterSettings
    Get
    Set
Visual C++
public:
property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
    void set (PrinterSettings^ value);
}

Property Value

Type: PrinterSettings

See Also

PrintJob Class
PrintJob Members


PrintJob.PrintOrientation Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..PrintOrientation Property
PrintJob Class See Also Send Feedback
Gets or sets the page orientation used to print the thermal label. Default value is Portrait

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrintOrientation PrintOrientation { get; set; }
Visual Basic
Public Property PrintOrientation As PrintOrientation
    Get
    Set
Visual C++
public:
property PrintOrientation PrintOrientation {
    PrintOrientation get ();
    void set (PrintOrientation value);
}

Property Value

Type: PrintOrientation

See Also

PrintJob Class
PrintJob Members


PrintJob.Replicates Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..Replicates Property
PrintJob Class See Also Send Feedback
Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Replicates { get; set; }
Visual Basic
Public Property Replicates As Integer
    Get
    Set
Visual C++
public:
property int Replicates {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

PrintJob Class
PrintJob Members


PrintJob.ThermalLabel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintJob..::..ThermalLabel Property
PrintJob Class See Also Send Feedback
Gets or sets the ThermalLabel object to be printed out. Default value is Null

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ThermalLabel ThermalLabel { get; set; }
Visual Basic
Public Property ThermalLabel As ThermalLabel
    Get
    Set
Visual C++
public:
property ThermalLabel^ ThermalLabel {
    ThermalLabel^ get ();
    void set (ThermalLabel^ value);
}

Property Value

Type: ThermalLabel

See Also

PrintJob Class
PrintJob Members


PrintMode Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintMode Enumeration
See Also Send Feedback
Specifies the print mode for the thermal printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum PrintMode
Visual Basic
Public Enumeration PrintMode
Visual C++
public enum class PrintMode

Members

Member name | Value | Description
TearOff | 0 | After printing, the label advances so the web is over the tear bar. The label, with liner attached, can be torn off manually.
PeelOff | 1 | After printing, the label moves forward and activates a Label Available Sensor. Printing stops until the label is manually removed from the printer.
Rewind | 2 | The label and backing are rewound on an (optional) external rewind device. The next label is positioned under the printhead (no backfeed motion).
Applicator | 3 | When used with an application device, the label move far enough forward to be removed by the applicator and applied to an item.
Cutter | 4 | After printing, the media feeds forward and is automatically cut into predetermined lengths.
DelayedCutter | 5 | The label is cut when printer receives a "CutLabel" command.

See Also


PrintOrientation Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintOrientation Enumeration
See Also Send Feedback
Specifies the page orientation used to print the thermal label.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum PrintOrientation
Visual Basic
Public Enumeration PrintOrientation
Visual C++
public enum class PrintOrientation

Members

Member name | Value | Description
Portrait | 0 | Prints the thermal label in portrait orientation.
Portrait180 | 2 | Prints the thermal label in portrait orientation rotated 180 degrees.
Landscape90 | 1 | Prints the thermal label in landscape orientation rotated 90 degrees clockwise.
Landscape270 | 3 | Prints the thermal label in landscape orientation rotated 270 degrees clockwise.

See Also


PrintUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils Class
Members See Also Send Feedback
It specifies printing jobs that are not directly related to label printing but printer commands.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class PrintUtils
Visual Basic
Public Class PrintUtils
Visual C++
public ref class PrintUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..PrintUtils

See Also

PrintUtils Members


PrintUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils Members
PrintUtils Class Constructors Methods Properties See Also Send Feedback

The PrintUtils type exposes the following members.

Constructors

 | Name | Description
Public method | PrintUtils |

Methods

Name | Description
AutoSetLabelLength | It automatically sets the label length. Depending on the size of the label, the printer feeds one or more blank labels.
CopyObject | It is used to copy an object or group of objects from one storage device to another. It is similar to the copy function used in PCs.
CutLabel | It cuts the label when the printer is in the Delayed Cutter PRINT MODE.
DeleteObject | It deletes objects, graphics, fonts, and stored formats from printer's storage areas. Objects can be deleted selectively or in groups.
ExecuteCommand(String) | It sends the specified commands to the printer.
ExecuteCommand(String, PrinterSettings) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding, PrinterSettings) | It sends the specified commands to the printer.
PausePrinting | It stops printing after the current label is complete (if one is printing) and places the printer in Pause Mode.
PrintConfiguration | It prints the printer configuration label. The printer configuration label contains information about the printer setup, such as sensor type, network ID, ZPL mode, firmware version, and descriptive data on the R:, E:, B:, and A: devices.
PrintDirectory | It prints a label listing barcodes, objects stored in DRAM, or fonts.
ResetPrinter | It resets all of the printer's internal software, performs a power-on self-test (POST), clears the buffer and DRAM, and resets communication parameters and default values. This method performs the same function as a manual power-on reset.
SetDarkness | It adjusts the darkness relative to the current darkness setting.
SetMediaTracking | It sets the type of media used (continuous or non-continuous) for purposes of tracking.
SetMediaType | It selects the type of media being used (Thermal Transfer or Direct Thermal) in the printer.
SetPrinterFactoryConfiguration | It reloads the printer's factory configuration.
SetPrintMode | It determines the action the printer takes after a label or group of labels has printed.
StartPrinting | It causes a printer in Pause Mode to resume printing.
UploadUnboundedTrueTypeFont(array<Byte>[]()[][], String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.
UploadUnboundedTrueTypeFont(String, String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.

Properties

Name | Description
PrinterSettings | Gets or sets information about the thermal printer used for printing.

See Also

PrintUtils Class


PrintUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils Constructor
PrintUtils Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrintUtils()
Visual Basic
Public Sub New
Visual C++
public:
PrintUtils()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils Methods
PrintUtils Class See Also Send Feedback

The PrintUtils type exposes the following members.

Methods

Name | Description
AutoSetLabelLength | It automatically sets the label length. Depending on the size of the label, the printer feeds one or more blank labels.
CopyObject | It is used to copy an object or group of objects from one storage device to another. It is similar to the copy function used in PCs.
CutLabel | It cuts the label when the printer is in the Delayed Cutter PRINT MODE.
DeleteObject | It deletes objects, graphics, fonts, and stored formats from printer's storage areas. Objects can be deleted selectively or in groups.
ExecuteCommand(String) | It sends the specified commands to the printer.
ExecuteCommand(String, PrinterSettings) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding, PrinterSettings) | It sends the specified commands to the printer.
PausePrinting | It stops printing after the current label is complete (if one is printing) and places the printer in Pause Mode.
PrintConfiguration | It prints the printer configuration label. The printer configuration label contains information about the printer setup, such as sensor type, network ID, ZPL mode, firmware version, and descriptive data on the R:, E:, B:, and A: devices.
PrintDirectory | It prints a label listing barcodes, objects stored in DRAM, or fonts.
ResetPrinter | It resets all of the printer's internal software, performs a power-on self-test (POST), clears the buffer and DRAM, and resets communication parameters and default values. This method performs the same function as a manual power-on reset.
SetDarkness | It adjusts the darkness relative to the current darkness setting.
SetMediaTracking | It sets the type of media used (continuous or non-continuous) for purposes of tracking.
SetMediaType | It selects the type of media being used (Thermal Transfer or Direct Thermal) in the printer.
SetPrinterFactoryConfiguration | It reloads the printer's factory configuration.
SetPrintMode | It determines the action the printer takes after a label or group of labels has printed.
StartPrinting | It causes a printer in Pause Mode to resume printing.
UploadUnboundedTrueTypeFont(array<Byte>[]()[][], String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.
UploadUnboundedTrueTypeFont(String, String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.

See Also

PrintUtils Class


PrintUtils.AutoSetLabelLength Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..AutoSetLabelLength Method
PrintUtils Class See Also Send Feedback
It automatically sets the label length. Depending on the size of the label, the printer feeds one or more blank labels.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void AutoSetLabelLength()
Visual Basic
Public Shared Sub AutoSetLabelLength
Visual C++
public:
static void AutoSetLabelLength()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.CopyObject Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..CopyObject Method
PrintUtils Class See Also Send Feedback
It is used to copy an object or group of objects from one storage device to another. It is similar to the copy function used in PCs.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void CopyObject(
    string srcObjectInfo,
    string destObjectInfo
)
Visual Basic
Public Shared Sub CopyObject (
    srcObjectInfo As String,
    destObjectInfo As String
)
Visual C++
public:
static void CopyObject(
    String^ srcObjectInfo,
    String^ destObjectInfo
)

Parameters

srcObjectInfo
Type: System..::..String
The info of the stored object which will be copied. The info includes the printer's memory device where the object is stored as well as the object name and extension. The asterisk (*) character can be used as a wildcard allowing you to easily copy a selected group of objects.
destObjectInfo
Type: System..::..String
The info for the destination object. The info includes the printer's memory device where the object will be stored as well as the object name and extension. The asterisk (*) character can be used as a wildcard.

Remarks

- If the destination device does not have enough free space to store the object being copied, the task is canceled.

- Zebra files (Z:*.*) cannot be transferred. These files are copyrighted by Zebra Technologies.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.CutLabel Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..CutLabel Method
PrintUtils Class See Also Send Feedback
It cuts the label when the printer is in the Delayed Cutter PRINT MODE.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void CutLabel()
Visual Basic
Public Shared Sub CutLabel
Visual C++
public:
static void CutLabel()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.DeleteObject Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..DeleteObject Method
PrintUtils Class See Also Send Feedback
It deletes objects, graphics, fonts, and stored formats from printer's storage areas. Objects can be deleted selectively or in groups.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void DeleteObject(
    string objectInfo
)
Visual Basic
Public Shared Sub DeleteObject (
    objectInfo As String
)
Visual C++
public:
static void DeleteObject(
    String^ objectInfo
)

Parameters

objectInfo
Type: System..::..String
The object info to be deleted/removed. The info includes the printer's memory device where the object is stored as well as the object name and extension. The asterisk (*) character can be used as a wildcard allowing you to easily delete a selected group of objects.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.ExecuteCommand Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ExecuteCommand Method
PrintUtils Class See Also Send Feedback

Overload List

Name | Description
ExecuteCommand(String) | It sends the specified commands to the printer.
ExecuteCommand(String, PrinterSettings) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding) | It sends the specified commands to the printer.
ExecuteCommand(String, Encoding, PrinterSettings) | It sends the specified commands to the printer.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.ExecuteCommand Method (String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ExecuteCommand Method (String)
PrintUtils Class See Also Send Feedback
It sends the specified commands to the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void ExecuteCommand(
    string command
)
Visual Basic
Public Shared Sub ExecuteCommand (
    command As String
)
Visual C++
public:
static void ExecuteCommand(
    String^ command
)

Parameters

command
Type: System..::..String
The ZPL or EPL commands.

See Also

PrintUtils Class
PrintUtils Members
ExecuteCommand Overload


PrintUtils.ExecuteCommand Method (String, PrinterSettings)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ExecuteCommand Method (String, PrinterSettings)
PrintUtils Class See Also Send Feedback
It sends the specified commands to the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void ExecuteCommand(
    string command,
    PrinterSettings printerSettings
)
Visual Basic
Public Shared Sub ExecuteCommand (
    command As String,
    printerSettings As PrinterSettings
)
Visual C++
public:
static void ExecuteCommand(
    String^ command,
    PrinterSettings^ printerSettings
)

Parameters

command
Type: System..::..String
The ZPL or EPL commands.
printerSettings
Type: Neodynamic.SDK.Printing..::..PrinterSettings
Information about the thermal printer used for printing.

See Also

PrintUtils Class
PrintUtils Members
ExecuteCommand Overload


PrintUtils.ExecuteCommand Method (String, Encoding)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ExecuteCommand Method (String, Encoding)
PrintUtils Class See Also Send Feedback
It sends the specified commands to the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void ExecuteCommand(
    string command,
    Encoding encoding
)
Visual Basic
Public Shared Sub ExecuteCommand (
    command As String,
    encoding As Encoding
)
Visual C++
public:
static void ExecuteCommand(
    String^ command,
    Encoding^ encoding
)

Parameters

command
Type: System..::..String
The ZPL or EPL commands.
encoding
Type: System.Text..::..Encoding
The codepage or encoding which the commands string is encoded in.

See Also

PrintUtils Class
PrintUtils Members
ExecuteCommand Overload


PrintUtils.ExecuteCommand Method (String, Encoding, PrinterSettings)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ExecuteCommand Method (String, Encoding, PrinterSettings)
PrintUtils Class See Also Send Feedback
It sends the specified commands to the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void ExecuteCommand(
    string command,
    Encoding encoding,
    PrinterSettings printerSettings
)
Visual Basic
Public Shared Sub ExecuteCommand (
    command As String,
    encoding As Encoding,
    printerSettings As PrinterSettings
)
Visual C++
public:
static void ExecuteCommand(
    String^ command,
    Encoding^ encoding,
    PrinterSettings^ printerSettings
)

Parameters

command
Type: System..::..String
The ZPL or EPL commands.
encoding
Type: System.Text..::..Encoding
The codepage or encoding which the commands string is encoded in.
printerSettings
Type: Neodynamic.SDK.Printing..::..PrinterSettings
Information about the thermal printer used for printing.

See Also

PrintUtils Class
PrintUtils Members
ExecuteCommand Overload


PrintUtils.PausePrinting Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..PausePrinting Method
PrintUtils Class See Also Send Feedback
It stops printing after the current label is complete (if one is printing) and places the printer in Pause Mode.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void PausePrinting()
Visual Basic
Public Shared Sub PausePrinting
Visual C++
public:
static void PausePrinting()

Remarks

The effect of this method is not immediate. Therefore, several labels might print before a pause is performed. The operation is identical to pressing PAUSE on the control panel of the printer. The printer remains paused until PAUSE is pressed or a call to "StartPrinting" method.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.PrintConfiguration Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..PrintConfiguration Method
PrintUtils Class See Also Send Feedback
It prints the printer configuration label. The printer configuration label contains information about the printer setup, such as sensor type, network ID, ZPL mode, firmware version, and descriptive data on the R:, E:, B:, and A: devices.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void PrintConfiguration()
Visual Basic
Public Shared Sub PrintConfiguration
Visual C++
public:
static void PrintConfiguration()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.PrintDirectory Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..PrintDirectory Method
PrintUtils Class See Also Send Feedback
It prints a label listing barcodes, objects stored in DRAM, or fonts.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void PrintDirectory(
    string directoryInfo
)
Visual Basic
Public Shared Sub PrintDirectory (
    directoryInfo As String
)
Visual C++
public:
static void PrintDirectory(
    String^ directoryInfo
)

Parameters

directoryInfo
Type: System..::..String
The directory info. It includes the printer's memory device, object name and extensions. Wildcard characters like question mark and asterisk can be used. For example, "R:*.*" will print all objects stored in Printer DRAM memory.

Remarks

This method lets you to print a label listing barcodes, objects stored in DRAM, or fonts.

- For barcodes, the list shows the name of the bar code. - For fonts, the list shows the name of the font, the alphanumeric character identifier, and size. - For objects stored in DRAM, the list shows the name of the object, extension, size, and option flags.

The different drives of a Zebra thermal printer are the following: - R: Printer DRAM Library - B: Optional Memory (A card or factory installed) - E: Flash memory - A: Compact flash memory - Z: Internal ZPL II stored object library (Read-only)

The following is a list of commonly used object extensions found in a Zebra thermal printer: - .FNT: Font objects - .BAR: Barcode objects - .GRF: Graphic objects in Zebra image format - .PNG: Graphic objects in Portable Network Graphics (PNG) format. - * (asterik): For all objects

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.ResetPrinter Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..ResetPrinter Method
PrintUtils Class See Also Send Feedback
It resets all of the printer's internal software, performs a power-on self-test (POST), clears the buffer and DRAM, and resets communication parameters and default values. This method performs the same function as a manual power-on reset.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void ResetPrinter()
Visual Basic
Public Shared Sub ResetPrinter
Visual C++
public:
static void ResetPrinter()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.SetDarkness Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..SetDarkness Method
PrintUtils Class See Also Send Feedback
It adjusts the darkness relative to the current darkness setting.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void SetDarkness(
    double darkness
)
Visual Basic
Public Shared Sub SetDarkness (
    darkness As Double
)
Visual C++
public:
static void SetDarkness(
    double darkness
)

Parameters

darkness
Type: System..::..Double
- For ZPL printers: The darkness level which must range from -30 to 30, depending on current value of printer settings. NOTE: The darkness level for the XiIIIPlus printer must be 0 to 30 in increments of 0.1. - For EPL printers: The darkness level which must range from 0 to 15.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.SetMediaTracking Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..SetMediaTracking Method
PrintUtils Class See Also Send Feedback
It sets the type of media used (continuous or non-continuous) for purposes of tracking.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void SetMediaTracking(
    MediaTracking mediaTracking
)
Visual Basic
Public Shared Sub SetMediaTracking (
    mediaTracking As MediaTracking
)
Visual C++
public:
static void SetMediaTracking(
    MediaTracking mediaTracking
)

Parameters

mediaTracking
Type: Neodynamic.SDK.Printing..::..MediaTracking
The media to use (continuous or non-continuous) for purposes of tracking.

Remarks

The types of media can be categorized as follows:

- Continuous Media: this media has no physical characteristic (web, notch, perforation, mark, et cetera) to separate labels. The Label length is determined by the height property of a ThermalLabel object. - Non-continuous Media: this media has some type of physical characteristic (web, notch, perforation, mark, et cetera) to separate the labels.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.SetMediaType Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..SetMediaType Method
PrintUtils Class See Also Send Feedback
It selects the type of media being used (Thermal Transfer or Direct Thermal) in the printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void SetMediaType(
    MediaType mediaType
)
Visual Basic
Public Shared Sub SetMediaType (
    mediaType As MediaType
)
Visual C++
public:
static void SetMediaType(
    MediaType mediaType
)

Parameters

mediaType
Type: Neodynamic.SDK.Printing..::..MediaType
The type of media to use for printing.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.SetPrinterFactoryConfiguration Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..SetPrinterFactoryConfiguration Method
PrintUtils Class See Also Send Feedback
It reloads the printer's factory configuration.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void SetPrinterFactoryConfiguration()
Visual Basic
Public Shared Sub SetPrinterFactoryConfiguration
Visual C++
public:
static void SetPrinterFactoryConfiguration()

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.SetPrintMode Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..SetPrintMode Method
PrintUtils Class See Also Send Feedback
It determines the action the printer takes after a label or group of labels has printed.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void SetPrintMode(
    PrintMode printMode
)
Visual Basic
Public Shared Sub SetPrintMode (
    printMode As PrintMode
)
Visual C++
public:
static void SetPrintMode(
    PrintMode printMode
)

Parameters

printMode
Type: Neodynamic.SDK.Printing..::..PrintMode
The print mode. Be sure to select the appropriate value for the print mode being used to avoid unexpected results. Note that not all printers support all options. Please refer to the printer user manual for further details.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.StartPrinting Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..StartPrinting Method
PrintUtils Class See Also Send Feedback
It causes a printer in Pause Mode to resume printing.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void StartPrinting()
Visual Basic
Public Shared Sub StartPrinting
Visual C++
public:
static void StartPrinting()

Remarks

The operation is identical to pressing PAUSE on the control panel of the printer when the printer is already in Pause Mode.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.UploadUnboundedTrueTypeFont Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..UploadUnboundedTrueTypeFont Method
PrintUtils Class See Also Send Feedback

Overload List

Name | Description
UploadUnboundedTrueTypeFont(array<Byte>[]()[][], String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.
UploadUnboundedTrueTypeFont(String, String) | It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.

See Also

PrintUtils Class
PrintUtils Members


PrintUtils.UploadUnboundedTrueTypeFont Method (Byte[], String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..UploadUnboundedTrueTypeFont Method (array<Byte>[]()[][], String)
PrintUtils Class See Also Send Feedback
It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void UploadUnboundedTrueTypeFont(
    byte[] ttfBinaryContent,
    string printerFontName
)
Visual Basic
Public Shared Sub UploadUnboundedTrueTypeFont (
    ttfBinaryContent As Byte(),
    printerFontName As String
)
Visual C++
public:
static void UploadUnboundedTrueTypeFont(
    array<unsigned char>^ ttfBinaryContent,
    String^ printerFontName
)

Parameters

ttfBinaryContent
Type: array< System..::..Byte >[]()[][]
The Unbounded or Large True Type Font file binary content.
printerFontName
Type: System..::..String
The complete name for the destination font (including the drive location and name, for example B:ARIAL). IMPORTANT: The name must be 1 to 8 alphanumeric characters long.

See Also

PrintUtils Class
PrintUtils Members
UploadUnboundedTrueTypeFont Overload


PrintUtils.UploadUnboundedTrueTypeFont Method (String, String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..UploadUnboundedTrueTypeFont Method (String, String)
PrintUtils Class See Also Send Feedback
It uploads an Unbounded or Large True Type Font (a font which has more than 256 printable characters) to the printer's storage devices.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static void UploadUnboundedTrueTypeFont(
    string ttfFilePath,
    string printerFontName
)
Visual Basic
Public Shared Sub UploadUnboundedTrueTypeFont (
    ttfFilePath As String,
    printerFontName As String
)
Visual C++
public:
static void UploadUnboundedTrueTypeFont(
    String^ ttfFilePath,
    String^ printerFontName
)

Parameters

ttfFilePath
Type: System..::..String
The Unbounded or Large True Type Font file path.
printerFontName
Type: System..::..String
The complete name for the destination font (including the drive location and name, for example B:ARIAL). IMPORTANT: The name must be 1 to 8 alphanumeric characters long.

See Also

PrintUtils Class
PrintUtils Members
UploadUnboundedTrueTypeFont Overload


PrintUtils Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils Properties
PrintUtils Class See Also Send Feedback

The PrintUtils type exposes the following members.

Properties

Name | Description
PrinterSettings | Gets or sets information about the thermal printer used for printing.

See Also

PrintUtils Class


PrintUtils.PrinterSettings Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
PrintUtils..::..PrinterSettings Property
PrintUtils Class See Also Send Feedback
Gets or sets information about the thermal printer used for printing.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static PrinterSettings PrinterSettings { get; set; }
Visual Basic
Public Shared Property PrinterSettings As PrinterSettings
    Get
    Set
Visual C++
public:
static property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
    void set (PrinterSettings^ value);
}

Property Value

Type: PrinterSettings

See Also

PrintUtils Class
PrintUtils Members


ProgrammingLanguage Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ProgrammingLanguage Enumeration
See Also Send Feedback
Specifies the core programming language supported by the thermal printer.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum ProgrammingLanguage
Visual Basic
Public Enumeration ProgrammingLanguage
Visual C++
public enum class ProgrammingLanguage

Members

Member name | Value | Description
ZPL | 0 | Zebra Programming Language
EPL | 1 | Eltron Programming Language

See Also


QRCodeEncoding Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
QRCodeEncoding Enumeration
See Also Send Feedback
Specifies the QR Code Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum QRCodeEncoding
Visual Basic
Public Enumeration QRCodeEncoding
Visual C++
public enum class QRCodeEncoding

Members

Member name | Value | Description
Auto | 0 |
Numeric | 1 | Used to encode data that mainly contains numeric characters
AlphaNumeric | 2 | Used to encode data that mainly contains alphanumeric characters
Kanji | 3 | Used to encode data that mainly contains Kanji characters
Byte | 4 | Used to encode 8 bit values

See Also


QRCodeErrorCorrectionLevel Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
QRCodeErrorCorrectionLevel Enumeration
See Also Send Feedback
Specifies the Error Correction Level to apply for QR Code symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum QRCodeErrorCorrectionLevel
Visual Basic
Public Enumeration QRCodeErrorCorrectionLevel
Visual C++
public enum class QRCodeErrorCorrectionLevel

Members

Member name | Value | Description
L | 0 | Approx. 7% of codewords can be restored. Error correction level L is appropriate for high symbol quality and/or the need for the smallest possible symbol.
M | 1 | Approx. 15% of codewords can be restored. Level M is described as Standard level and offers a good compromise between small size and increased reliability.
Q | 2 | Approx. 25% of codewords can be restored. Level Q is a High reliability level and suitable for more critical or poor print quality applications.
H | 3 | Approx. 30% of codewords can be restored. Level H offers the maximum achievable reliability.

See Also


QRCodeVersion Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
QRCodeVersion Enumeration
See Also Send Feedback
Specifies the QR Code Version to use on that symbology. Version 1 (21 x 21 modules) to Version 40 (177 x 177 modules) increasing in steps of four modules per side.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum QRCodeVersion
Visual Basic
Public Enumeration QRCodeVersion
Visual C++
public enum class QRCodeVersion

Members

Member name | Value | Description
Auto | 0 |
V01 | 1 |
V02 | 2 |
V03 | 3 |
V04 | 4 |
V05 | 5 |
V06 | 6 |
V07 | 7 |
V08 | 8 |
V09 | 9 |
V10 | 10 |
V11 | 11 |
V12 | 12 |
V13 | 13 |
V14 | 14 |
V15 | 15 |
V16 | 16 |
V17 | 17 |
V18 | 18 |
V19 | 19 |
V20 | 20 |
V21 | 21 |
V22 | 22 |
V23 | 23 |
V24 | 24 |
V25 | 25 |
V26 | 26 |
V27 | 27 |
V28 | 28 |
V29 | 29 |
V30 | 30 |
V31 | 31 |
V32 | 32 |
V33 | 33 |
V34 | 34 |
V35 | 35 |
V36 | 36 |
V37 | 37 |
V38 | 38 |
V39 | 39 |
V40 | 40 |

See Also


RectangleCornerRadius Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Class
Members See Also Send Feedback
Represents the radii of a rectangle's corners.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class RectangleCornerRadius : INotifyPropertyChanged
Visual Basic
Public Class RectangleCornerRadius
    Implements INotifyPropertyChanged
Visual C++
public ref class RectangleCornerRadius : INotifyPropertyChanged

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..RectangleCornerRadius

See Also

RectangleCornerRadius Members


RectangleCornerRadius Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Members
RectangleCornerRadius Class Constructors Methods Operators Properties Events See Also Send Feedback

The RectangleCornerRadius type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleCornerRadius()()()() | Initializes a new instance of the RectangleCornerRadius class.
Public method | RectangleCornerRadius(Double) | Initializes a new instance of the RectangleCornerRadius class with a specified uniform radius value for every corner of the rectangle.
Public method | RectangleCornerRadius(Double, Double, Double, Double) | Initializes a new instance of the RectangleCornerRadius class with the specified radius values for each corner of the rectangle.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(RectangleCornerRadius) |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | ToString()()()() | Converts the RectangleCornerRadius object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the RectangleCornerRadius object to a string representation, using the specified CultureInfo.

Operators

Name | Description
Equality |
Inequality |

Properties

 | Name | Description
Public property | BottomLeft | Gets or sets the radius of the bottom-left corner. Default value is 0 (zero)
Public property | BottomRight | Gets or sets the radius of the bottom-right corner. Default value is 0 (zero)
Public property | TopLeft | Gets or sets the radius of the top-left corner. Default value is 0 (zero)
Public property | TopRight | Gets or sets the radius of the top-right corner. Default value is 0 (zero)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

RectangleCornerRadius Class


RectangleCornerRadius Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Constructor
RectangleCornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangleCornerRadius()()()() | Initializes a new instance of the RectangleCornerRadius class.
Public method | RectangleCornerRadius(Double) | Initializes a new instance of the RectangleCornerRadius class with a specified uniform radius value for every corner of the rectangle.
Public method | RectangleCornerRadius(Double, Double, Double, Double) | Initializes a new instance of the RectangleCornerRadius class with the specified radius values for each corner of the rectangle.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Constructor
RectangleCornerRadius Class See Also Send Feedback
Initializes a new instance of the RectangleCornerRadius class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius()
Visual Basic
Public Sub New
Visual C++
public:
RectangleCornerRadius()

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
RectangleCornerRadius Overload


RectangleCornerRadius Constructor (Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Constructor (Double)
RectangleCornerRadius Class See Also Send Feedback
Initializes a new instance of the RectangleCornerRadius class with a specified uniform radius value for every corner of the rectangle.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius(
    double uniformRadius
)
Visual Basic
Public Sub New (
    uniformRadius As Double
)
Visual C++
public:
RectangleCornerRadius(
    double uniformRadius
)

Parameters

uniformRadius
Type: System..::..Double
The radius value applied to every corner of the rectangle.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
RectangleCornerRadius Overload


RectangleCornerRadius Constructor (Double, Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Constructor (Double, Double, Double, Double)
RectangleCornerRadius Class See Also Send Feedback
Initializes a new instance of the RectangleCornerRadius class with the specified radius values for each corner of the rectangle.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius(
    double topLeft,
    double topRight,
    double bottomRight,
    double bottomLeft
)
Visual Basic
Public Sub New (
    topLeft As Double,
    topRight As Double,
    bottomRight As Double,
    bottomLeft As Double
)
Visual C++
public:
RectangleCornerRadius(
    double topLeft,
    double topRight,
    double bottomRight,
    double bottomLeft
)

Parameters

topLeft
Type: System..::..Double
The radius of the top-left corner.
topRight
Type: System..::..Double
The radius of the top-right corner.
bottomRight
Type: System..::..Double
The radius of the bottom-right corner.
bottomLeft
Type: System..::..Double
The radius of the bottom-left corner.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
RectangleCornerRadius Overload


RectangleCornerRadius Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Methods
RectangleCornerRadius Class See Also Send Feedback

The RectangleCornerRadius type exposes the following members.

Methods

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(RectangleCornerRadius) |
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | ToString()()()() | Converts the RectangleCornerRadius object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the RectangleCornerRadius object to a string representation, using the specified CultureInfo.

See Also

RectangleCornerRadius Class


RectangleCornerRadius.Equals Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..Equals Method
RectangleCornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Equals(Object) | (Overrides Object..::..Equals(Object).)
Public method | Equals(RectangleCornerRadius) |

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.Equals Method (Object)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..Equals Method (Object)
RectangleCornerRadius Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals (
    obj As Object
) As Boolean
Visual C++
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: System..::..Object

Return Value

Type: Boolean

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
Equals Overload


RectangleCornerRadius.Equals Method (RectangleCornerRadius)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..Equals Method (RectangleCornerRadius)
RectangleCornerRadius Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool Equals(
    RectangleCornerRadius cornerRadius
)
Visual Basic
Public Function Equals (
    cornerRadius As RectangleCornerRadius
) As Boolean
Visual C++
public:
bool Equals(
    RectangleCornerRadius^ cornerRadius
)

Parameters

cornerRadius
Type: Neodynamic.SDK.Printing..::..RectangleCornerRadius

Return Value

Type: Boolean

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
Equals Overload


RectangleCornerRadius.GetHashCode Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..GetHashCode Method
RectangleCornerRadius Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer
Visual C++
public:
virtual int GetHashCode() override

Return Value

Type: Int32

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.ToString Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..ToString Method
RectangleCornerRadius Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Converts the RectangleCornerRadius object to a string representation, using the current CultureInfo. (Overrides Object..::..ToString()()()().)
Public method | ToString(CultureInfo) | Converts the RectangleCornerRadius object to a string representation, using the specified CultureInfo.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.ToString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..ToString Method
RectangleCornerRadius Class See Also Send Feedback
Converts the RectangleCornerRadius object to a string representation, using the current CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the RectangleCornerRadius object in the current culture.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
ToString Overload


RectangleCornerRadius.ToString Method (CultureInfo)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..ToString Method (CultureInfo)
RectangleCornerRadius Class See Also Send Feedback
Converts the RectangleCornerRadius object to a string representation, using the specified CultureInfo.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string ToString(
    CultureInfo culture
)
Visual Basic
Public Function ToString (
    culture As CultureInfo
) As String
Visual C++
public:
String^ ToString(
    CultureInfo^ culture
)

Parameters

culture
Type: System.Globalization..::..CultureInfo
A CultureInfo that contains the culture to represent the RectangleCornerRadius.

Return Value

Type: String
The string representation of the RectangleCornerRadius object in the specified culture.

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members
ToString Overload


RectangleCornerRadius Operators

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Operators
RectangleCornerRadius Class See Also Send Feedback

The RectangleCornerRadius type exposes the following members.

Operators

Name | Description
Equality |
Inequality |

See Also

RectangleCornerRadius Class


RectangleCornerRadius.Equality Operator

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..Equality Operator
RectangleCornerRadius Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static bool operator ==(
    RectangleCornerRadius cr1,
    RectangleCornerRadius cr2
)
Visual Basic
Public Shared Operator = (
    cr1 As RectangleCornerRadius,
    cr2 As RectangleCornerRadius
) As Boolean
Visual C++
public:
static bool operator ==(
    RectangleCornerRadius^ cr1,
    RectangleCornerRadius^ cr2
)

Parameters

cr1
Type: Neodynamic.SDK.Printing..::..RectangleCornerRadius
cr2
Type: Neodynamic.SDK.Printing..::..RectangleCornerRadius

Return Value

Type: Boolean

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.Inequality Operator

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..Inequality Operator
RectangleCornerRadius Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static bool operator !=(
    RectangleCornerRadius cr1,
    RectangleCornerRadius cr2
)
Visual Basic
Public Shared Operator <> (
    cr1 As RectangleCornerRadius,
    cr2 As RectangleCornerRadius
) As Boolean
Visual C++
public:
static bool operator !=(
    RectangleCornerRadius^ cr1,
    RectangleCornerRadius^ cr2
)

Parameters

cr1
Type: Neodynamic.SDK.Printing..::..RectangleCornerRadius
cr2
Type: Neodynamic.SDK.Printing..::..RectangleCornerRadius

Return Value

Type: Boolean

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Properties
RectangleCornerRadius Class See Also Send Feedback

The RectangleCornerRadius type exposes the following members.

Properties

 | Name | Description
Public property | BottomLeft | Gets or sets the radius of the bottom-left corner. Default value is 0 (zero)
Public property | BottomRight | Gets or sets the radius of the bottom-right corner. Default value is 0 (zero)
Public property | TopLeft | Gets or sets the radius of the top-left corner. Default value is 0 (zero)
Public property | TopRight | Gets or sets the radius of the top-right corner. Default value is 0 (zero)

See Also

RectangleCornerRadius Class


RectangleCornerRadius.BottomLeft Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..BottomLeft Property
RectangleCornerRadius Class See Also Send Feedback
Gets or sets the radius of the bottom-left corner. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BottomLeft { get; set; }
Visual Basic
Public Property BottomLeft As Double
    Get
    Set
Visual C++
public:
property double BottomLeft {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.BottomRight Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..BottomRight Property
RectangleCornerRadius Class See Also Send Feedback
Gets or sets the radius of the bottom-right corner. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double BottomRight { get; set; }
Visual Basic
Public Property BottomRight As Double
    Get
    Set
Visual C++
public:
property double BottomRight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.TopLeft Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..TopLeft Property
RectangleCornerRadius Class See Also Send Feedback
Gets or sets the radius of the top-left corner. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double TopLeft { get; set; }
Visual Basic
Public Property TopLeft As Double
    Get
    Set
Visual C++
public:
property double TopLeft {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius.TopRight Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..TopRight Property
RectangleCornerRadius Class See Also Send Feedback
Gets or sets the radius of the top-right corner. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double TopRight { get; set; }
Visual Basic
Public Property TopRight As Double
    Get
    Set
Visual C++
public:
property double TopRight {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadius Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius Events
RectangleCornerRadius Class See Also Send Feedback

The RectangleCornerRadius type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes.

See Also

RectangleCornerRadius Class


RectangleCornerRadius.PropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadius..::..PropertyChanged Event
RectangleCornerRadius Class See Also Send Feedback
Occurs when a property value changes.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler
Visual C++
public:
virtual  event PropertyChangedEventHandler^ PropertyChanged {
    void add (PropertyChangedEventHandler^ value);
    void remove (PropertyChangedEventHandler^ value);
}

Value

Type: System.ComponentModel..::..PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

RectangleCornerRadius Class
RectangleCornerRadius Members


RectangleCornerRadiusConverter Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter Class
Members See Also Send Feedback
Converts RectangleCornerRadius objects from one data type to another. Access the CornerRadiusConverter class through the TypeDescriptor object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class RectangleCornerRadiusConverter : ExpandableObjectConverter
Visual Basic
Public Class RectangleCornerRadiusConverter
    Inherits ExpandableObjectConverter
Visual C++
public ref class RectangleCornerRadiusConverter : public ExpandableObjectConverter

Inheritance Hierarchy

System..::..Object
System.ComponentModel..::..TypeConverter
System.ComponentModel..::..ExpandableObjectConverter
Neodynamic.SDK.Printing..::..RectangleCornerRadiusConverter

See Also

RectangleCornerRadiusConverter Members


RectangleCornerRadiusConverter Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter Members
RectangleCornerRadiusConverter Class Constructors Methods See Also Send Feedback

The RectangleCornerRadiusConverter type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleCornerRadiusConverter |

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

RectangleCornerRadiusConverter Class


RectangleCornerRadiusConverter Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter Constructor
RectangleCornerRadiusConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadiusConverter()
Visual Basic
Public Sub New
Visual C++
public:
RectangleCornerRadiusConverter()

See Also

RectangleCornerRadiusConverter Class
RectangleCornerRadiusConverter Members


RectangleCornerRadiusConverter Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter Methods
RectangleCornerRadiusConverter Class See Also Send Feedback

The RectangleCornerRadiusConverter type exposes the following members.

Methods

 | Name | Description
Public method | CanConvertFrom | (Overrides TypeConverter..::..CanConvertFrom(ITypeDescriptorContext, Type).)
Public method | CanConvertTo | (Overrides TypeConverter..::..CanConvertTo(ITypeDescriptorContext, Type).)
Public method | ConvertFrom | (Overrides TypeConverter..::..ConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public method | ConvertTo | (Overrides TypeConverter..::..ConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)

See Also

RectangleCornerRadiusConverter Class


RectangleCornerRadiusConverter.CanConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter..::..CanConvertFrom Method
RectangleCornerRadiusConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertFrom(
    ITypeDescriptorContext context,
    Type sourceType
)
Visual Basic
Public Overrides Function CanConvertFrom (
    context As ITypeDescriptorContext,
    sourceType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertFrom(
    ITypeDescriptorContext^ context,
    Type^ sourceType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
sourceType
Type: System..::..Type

Return Value

Type: Boolean

See Also

RectangleCornerRadiusConverter Class
RectangleCornerRadiusConverter Members


RectangleCornerRadiusConverter.CanConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter..::..CanConvertTo Method
RectangleCornerRadiusConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override bool CanConvertTo(
    ITypeDescriptorContext context,
    Type destinationType
)
Visual Basic
Public Overrides Function CanConvertTo (
    context As ITypeDescriptorContext,
    destinationType As Type
) As Boolean
Visual C++
public:
virtual bool CanConvertTo(
    ITypeDescriptorContext^ context,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
destinationType
Type: System..::..Type

Return Value

Type: Boolean

See Also

RectangleCornerRadiusConverter Class
RectangleCornerRadiusConverter Members


RectangleCornerRadiusConverter.ConvertFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter..::..ConvertFrom Method
RectangleCornerRadiusConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertFrom(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object source
)
Visual Basic
Public Overrides Function ConvertFrom (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    source As Object
) As Object
Visual C++
public:
virtual Object^ ConvertFrom(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ source
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
source
Type: System..::..Object

Return Value

Type: Object

See Also

RectangleCornerRadiusConverter Class
RectangleCornerRadiusConverter Members


RectangleCornerRadiusConverter.ConvertTo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleCornerRadiusConverter..::..ConvertTo Method
RectangleCornerRadiusConverter Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Object ConvertTo(
    ITypeDescriptorContext context,
    CultureInfo culture,
    Object value,
    Type destinationType
)
Visual Basic
Public Overrides Function ConvertTo (
    context As ITypeDescriptorContext,
    culture As CultureInfo,
    value As Object,
    destinationType As Type
) As Object
Visual C++
public:
virtual Object^ ConvertTo(
    ITypeDescriptorContext^ context,
    CultureInfo^ culture,
    Object^ value,
    Type^ destinationType
) override

Parameters

context
Type: System.ComponentModel..::..ITypeDescriptorContext
culture
Type: System.Globalization..::..CultureInfo
value
Type: System..::..Object
destinationType
Type: System..::..Type

Return Value

Type: Object

See Also

RectangleCornerRadiusConverter Class
RectangleCornerRadiusConverter Members


RectangleShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Class
Members See Also Send Feedback
Represents a rectangle shape item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class RectangleShapeItem : ClosedShapeItem
Visual Basic
Public Class RectangleShapeItem
    Inherits ClosedShapeItem
Visual C++
public ref class RectangleShapeItem : public ClosedShapeItem

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..ClosedShapeItem
Neodynamic.SDK.Printing..::..RectangleShapeItem

See Also

RectangleShapeItem Members


RectangleShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Members
RectangleShapeItem Class Constructors Methods Properties Events See Also Send Feedback

The RectangleShapeItem type exposes the following members.

Constructors

 | Name | Description
Public method | RectangleShapeItem()()()() | Initializes a new instance of the RectangleShapeItem class.
Public method | RectangleShapeItem(Double, Double, Double, Double) | Initializes a new instance of the RectangleShapeItem class with the specified location and size.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current RectangleShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides ShapeItem..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this RectangleShapeItem object with the properties of the specified RectangleShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

RectangleShapeItem Class


RectangleShapeItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Constructor
RectangleShapeItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RectangleShapeItem()()()() | Initializes a new instance of the RectangleShapeItem class.
Public method | RectangleShapeItem(Double, Double, Double, Double) | Initializes a new instance of the RectangleShapeItem class with the specified location and size.

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Constructor
RectangleShapeItem Class See Also Send Feedback
Initializes a new instance of the RectangleShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleShapeItem()
Visual Basic
Public Sub New
Visual C++
public:
RectangleShapeItem()

See Also

RectangleShapeItem Class
RectangleShapeItem Members
RectangleShapeItem Overload


RectangleShapeItem Constructor (Double, Double, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Constructor (Double, Double, Double, Double)
RectangleShapeItem Class See Also Send Feedback
Initializes a new instance of the RectangleShapeItem class with the specified location and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleShapeItem(
    double x,
    double y,
    double width,
    double height
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double
)
Visual C++
public:
RectangleShapeItem(
    double x,
    double y,
    double width,
    double height
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
width
Type: System..::..Double
The width of the item.
height
Type: System..::..Double
The height of the item.

See Also

RectangleShapeItem Class
RectangleShapeItem Members
RectangleShapeItem Overload


RectangleShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Methods
RectangleShapeItem Class See Also Send Feedback

The RectangleShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current RectangleShapeItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides ShapeItem..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this RectangleShapeItem object with the properties of the specified RectangleShapeItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

RectangleShapeItem Class


RectangleShapeItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem..::..Clone Method
RectangleShapeItem Class See Also Send Feedback
Creates a copy of the current RectangleShapeItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current RectangleShapeItem.

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem..::..ConvertToUnit Method
RectangleShapeItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem..::..UpdateFrom Method
RectangleShapeItem Class See Also Send Feedback
Updates this RectangleShapeItem object with the properties of the specified RectangleShapeItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The RectangleShapeItem object that is used for updating this RectangleShapeItem object.

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Properties
RectangleShapeItem Class See Also Send Feedback

The RectangleShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | FillColor | Gets or sets the fill color. Default value is White which will produce a transparent fill. (Inherited from ClosedShapeItem.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | StrokeColor | Gets or sets the border color. Default value is Black (Inherited from ShapeItem.)
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01 (Inherited from ShapeItem.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1 (Inherited from ShapeItem.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

RectangleShapeItem Class


RectangleShapeItem.CornerRadius Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem..::..CornerRadius Property
RectangleShapeItem Class See Also Send Feedback
Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As RectangleCornerRadius
    Get
    Set
Visual C++
public:
property RectangleCornerRadius^ CornerRadius {
    RectangleCornerRadius^ get ();
    void set (RectangleCornerRadius^ value);
}

Property Value

Type: RectangleCornerRadius

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem.RotationAngle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem..::..RotationAngle Property
RectangleShapeItem Class See Also Send Feedback
Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Integer
    Get
    Set
Visual C++
public:
property int RotationAngle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

RectangleShapeItem Class
RectangleShapeItem Members


RectangleShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RectangleShapeItem Events
RectangleShapeItem Class See Also Send Feedback

The RectangleShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

RectangleShapeItem Class


RFIDTagDataFormat Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagDataFormat Enumeration
See Also Send Feedback
The RFID Tag Data Formats

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum RFIDTagDataFormat
Visual Basic
Public Enumeration RFIDTagDataFormat
Visual C++
public enum class RFIDTagDataFormat

Members

Member name | Value | Description
ASCII | 0 |
Hexadecimal | 1 |
EPC | 2 |

See Also


RFIDTagItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Class
Members See Also Send Feedback
Represents a RFID Tag item. Use it for encoding a RFID Tag in a label.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class RFIDTagItem : Item
Visual Basic
Public Class RFIDTagItem
    Inherits Item
Visual C++
public ref class RFIDTagItem : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..RFIDTagItem

See Also

RFIDTagItem Members


RFIDTagItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Members
RFIDTagItem Class Constructors Methods Properties Events See Also Send Feedback

The RFIDTagItem type exposes the following members.

Constructors

 | Name | Description
Public method | RFIDTagItem | Initializes a new instance of the RFIDTagItem class.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current RFIDTagItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this RFIDTagItem object with the properties of the specified RFIDTagItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | DataFormat | Gets or sets the format in which the data will be encoded. Default is ASCII.
Public property | DataToEncode | Gets or sets the data to encode. The format will depend on the value of the DataFormat property. Default is an empty string.
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | EPCDataStructure | Gets or sets the EPC Data Structure. Default value is an empty string.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

RFIDTagItem Class


RFIDTagItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Constructor
RFIDTagItem Class See Also Send Feedback
Initializes a new instance of the RFIDTagItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RFIDTagItem()
Visual Basic
Public Sub New
Visual C++
public:
RFIDTagItem()

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Methods
RFIDTagItem Class See Also Send Feedback

The RFIDTagItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current RFIDTagItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | Updates this RFIDTagItem object with the properties of the specified RFIDTagItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

RFIDTagItem Class


RFIDTagItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..Clone Method
RFIDTagItem Class See Also Send Feedback
Creates a copy of the current RFIDTagItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current RFIDTagItem.

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..ConvertToUnit Method
RFIDTagItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..UpdateFrom Method
RFIDTagItem Class See Also Send Feedback
Updates this RFIDTagItem object with the properties of the specified RFIDTagItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The RFIDTagItem object that is used for updating this RFIDTagItem object.

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Properties
RFIDTagItem Class See Also Send Feedback

The RFIDTagItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | DataFormat | Gets or sets the format in which the data will be encoded. Default is ASCII.
Public property | DataToEncode | Gets or sets the data to encode. The format will depend on the value of the DataFormat property. Default is an empty string.
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | EPCDataStructure | Gets or sets the EPC Data Structure. Default value is an empty string.
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

RFIDTagItem Class


RFIDTagItem.DataFormat Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..DataFormat Property
RFIDTagItem Class See Also Send Feedback
Gets or sets the format in which the data will be encoded. Default is ASCII.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RFIDTagDataFormat DataFormat { get; set; }
Visual Basic
Public Property DataFormat As RFIDTagDataFormat
    Get
    Set
Visual C++
public:
property RFIDTagDataFormat DataFormat {
    RFIDTagDataFormat get ();
    void set (RFIDTagDataFormat value);
}

Property Value

Type: RFIDTagDataFormat

Remarks

If EPC is used, then you must specify the EPC Data Structure through the EPSDataStructure property as well.

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem.DataToEncode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..DataToEncode Property
RFIDTagItem Class See Also Send Feedback
Gets or sets the data to encode. The format will depend on the value of the DataFormat property. Default is an empty string.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataToEncode { get; set; }
Visual Basic
Public Property DataToEncode As String
    Get
    Set
Visual C++
public:
property String^ DataToEncode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem.EPCDataStructure Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem..::..EPCDataStructure Property
RFIDTagItem Class See Also Send Feedback
Gets or sets the EPC Data Structure. Default value is an empty string.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string EPCDataStructure { get; set; }
Visual Basic
Public Property EPCDataStructure As String
    Get
    Set
Visual C++
public:
property String^ EPCDataStructure {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The EPC Data Structure must be specified as follows: TOTAL-BITS,PARTITION1-BITS,PARTITION2-BITS,...,PARTITIONn-BITS. For example, a data structure of three partitions that sum up to 96 bits, then specify this: 96,10,26,60

See Also

RFIDTagItem Class
RFIDTagItem Members


RFIDTagItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
RFIDTagItem Events
RFIDTagItem Class See Also Send Feedback

The RFIDTagItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

RFIDTagItem Class


ShapeItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem Class
Members See Also Send Feedback
An abstract base class that provides basic functionality for any descended ShapeItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public abstract class ShapeItem : Item
Visual Basic
Public MustInherit Class ShapeItem
    Inherits Item
Visual C++
public ref class ShapeItem abstract : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..ShapeItem
Neodynamic.SDK.Printing..::..ClosedShapeItem
Neodynamic.SDK.Printing..::..LineShapeItem

See Also

ShapeItem Members


ShapeItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem Members
ShapeItem Class Methods Properties Events See Also Send Feedback

The ShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object. (Inherited from Item.)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object. (Inherited from Item.)

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ShapeItem Class


ShapeItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem Methods
ShapeItem Class See Also Send Feedback

The ShapeItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | When overridden in a derived class, creates an exact copy of this Item object. (Inherited from Item.)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | UpdateFrom | When overridden in a derived class, updates this Item object with the properties of the specified Item object. (Inherited from Item.)

See Also

ShapeItem Class


ShapeItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem..::..ConvertToUnit Method
ShapeItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

ShapeItem Class
ShapeItem Members


ShapeItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem Properties
ShapeItem Class See Also Send Feedback

The ShapeItem type exposes the following members.

Properties

 | Name | Description
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Height | Gets or sets the height of the shape item. Default value is 1
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | StrokeColor | Gets or sets the border color. Default value is Black
Public property | StrokeThickness | Gets or sets the border thickness. Default value is 0.01
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the shape item. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

ShapeItem Class


ShapeItem.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem..::..Height Property
ShapeItem Class See Also Send Feedback
Gets or sets the height of the shape item. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ShapeItem Class
ShapeItem Members


ShapeItem.StrokeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem..::..StrokeColor Property
ShapeItem Class See Also Send Feedback
Gets or sets the border color. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color StrokeColor { get; set; }
Visual Basic
Public Property StrokeColor As Color
    Get
    Set
Visual C++
public:
property Color StrokeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ShapeItem Class
ShapeItem Members


ShapeItem.StrokeThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem..::..StrokeThickness Property
ShapeItem Class See Also Send Feedback
Gets or sets the border thickness. Default value is 0.01

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic
Public Property StrokeThickness As Double
    Get
    Set
Visual C++
public:
property double StrokeThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Exceptions

Exception | Condition
System..::..ArgumentException | The specified value is less than 0.

See Also

ShapeItem Class
ShapeItem Members


ShapeItem.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem..::..Width Property
ShapeItem Class See Also Send Feedback
Gets or sets the width of the shape item. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ShapeItem Class
ShapeItem Members


ShapeItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ShapeItem Events
ShapeItem Class See Also Send Feedback

The ShapeItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

ShapeItem Class


Supplement Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Supplement Enumeration
See Also Send Feedback
Specifies the supplement type to use with EAN and UPC symbologies.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum Supplement
Visual Basic
Public Enumeration Supplement
Visual C++
public enum class Supplement

Members

Member name | Value | Description
None | 0 |
Digits2 | 1 |
Digits5 | 2 |

See Also


TelepenEncoding Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TelepenEncoding Enumeration
See Also Send Feedback
Specifies the Telepen Encoding to use on that symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum TelepenEncoding
Visual Basic
Public Enumeration TelepenEncoding
Visual C++
public enum class TelepenEncoding

Members

Member name | Value | Description
Ascii | 0 | Used to encode the full range of ASCII characters
Numeric | 1 | Used to encode pairs of numeric characters in double-density mode.

See Also


TextAlignment Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextAlignment Enumeration
See Also Send Feedback
Specifies the text alignment.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum TextAlignment
Visual Basic
Public Enumeration TextAlignment
Visual C++
public enum class TextAlignment

Members

Member name | Value | Description
Left | 0 |
Center | 1 |
Right | 2 |
Justify | 3 |

See Also


TextItem Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Class
Members See Also Send Feedback
Represents a text item.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class TextItem : Item
Visual Basic
Public Class TextItem
    Inherits Item
Visual C++
public ref class TextItem : public Item

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..Item
Neodynamic.SDK.Printing..::..TextItem

See Also

TextItem Members


TextItem Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Members
TextItem Class Constructors Methods Properties Events See Also Send Feedback

The TextItem type exposes the following members.

Constructors

 | Name | Description
Public method | TextItem()()()() | Initializes a new instance of the TextItem class.
Public method | TextItem(Double, Double, Double, Double, String) | Initializes a new instance of the TextItem class with the specified location, size and text.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current TextItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | GetAutoSize | Gets the size of this TextItem that fits its content.
Public method | UpdateFrom | Updates this TextItem object with the properties of the specified TextItem object. (Overrides Item..::..UpdateFrom(Item).)

Properties

 | Name | Description
Public property | BackColor | Gets or sets the background color of the text. Default value is White
Public property | BorderColor | Gets or sets the color of the border of the rectangle container. Default value is Black
Public property | BorderThickness | Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | CounterStep | Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)
Public property | CounterUseLeadingZeros | Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false
Public property | CultureName | Gets or sets the Culture Name for text formatting. Default is en-US. Other sample values: de-DE, es-ES, etc. Any value supported by .NET CultureInfo class.
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Font | Gets the Font object for the text. Default value is Arial, 8pt
Public property | ForeColor | Gets or sets the foreground color of the text. Default value is Black
Public property | Height | Gets or sets the height of the text item. Default value is 0.5
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Mask | Gets or sets the input Mask for the text. Default value is an empty string
Public property | MaskIncrement | Gets or sets the mask increment. The increment is the value to be added to the text on each label to be printed. Default value is an empty string
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. Default value is false
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | Sizing | Gets or sets the text sizing. Default value is None
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | Text | Gets or sets the text. Default value is an empty string
Public property | TextAlignment | Gets or sets the alignment of the text. Default value is Left
Public property | TextPadding | Gets or sets the amount of space between the container's border and the text content. Default value is 0 (zero)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the text item. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

TextItem Class


TextItem Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Constructor
TextItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TextItem()()()() | Initializes a new instance of the TextItem class.
Public method | TextItem(Double, Double, Double, Double, String) | Initializes a new instance of the TextItem class with the specified location, size and text.

See Also

TextItem Class
TextItem Members


TextItem Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Constructor
TextItem Class See Also Send Feedback
Initializes a new instance of the TextItem class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TextItem()
Visual Basic
Public Sub New
Visual C++
public:
TextItem()

See Also

TextItem Class
TextItem Members
TextItem Overload


TextItem Constructor (Double, Double, Double, Double, String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Constructor (Double, Double, Double, Double, String)
TextItem Class See Also Send Feedback
Initializes a new instance of the TextItem class with the specified location, size and text.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TextItem(
    double x,
    double y,
    double width,
    double height,
    string text
)
Visual Basic
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double,
    text As String
)
Visual C++
public:
TextItem(
    double x,
    double y,
    double width,
    double height,
    String^ text
)

Parameters

x
Type: System..::..Double
The x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
y
Type: System..::..Double
The y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container.
width
Type: System..::..Double
The width of the item container.
height
Type: System..::..Double
The height of the item container.
text
Type: System..::..String
The text.

See Also

TextItem Class
TextItem Members
TextItem Overload


TextItem Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Methods
TextItem Class See Also Send Feedback

The TextItem type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current TextItem. (Overrides Item..::..Clone()()()().)
Public method | ConvertToUnit | (Overrides Item..::..ConvertToUnit(UnitType).)
Public method | GetAutoSize | Gets the size of this TextItem that fits its content.
Public method | UpdateFrom | Updates this TextItem object with the properties of the specified TextItem object. (Overrides Item..::..UpdateFrom(Item).)

See Also

TextItem Class


TextItem.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Clone Method
TextItem Class See Also Send Feedback
Creates a copy of the current TextItem.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override Item Clone()
Visual Basic
Public Overrides Function Clone As Item
Visual C++
public:
virtual Item^ Clone() override

Return Value

Type: Item
A copy of the current TextItem.

See Also

TextItem Class
TextItem Members


TextItem.ConvertToUnit Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..ConvertToUnit Method
TextItem Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void ConvertToUnit(
    UnitType unit
)
Visual Basic
Public Overrides Sub ConvertToUnit (
    unit As UnitType
)
Visual C++
public:
virtual void ConvertToUnit(
    UnitType unit
) override

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType

See Also

TextItem Class
TextItem Members


TextItem.GetAutoSize Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..GetAutoSize Method
TextItem Class See Also Send Feedback
Gets the size of this TextItem that fits its content.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Size GetAutoSize()
Visual Basic
Public Function GetAutoSize As Size
Visual C++
public:
Size GetAutoSize()

Return Value

Type: Size
The size of this TextItem that fits its content.

See Also

TextItem Class
TextItem Members


TextItem.UpdateFrom Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..UpdateFrom Method
TextItem Class See Also Send Feedback
Updates this TextItem object with the properties of the specified TextItem object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override void UpdateFrom(
    Item item
)
Visual Basic
Public Overrides Sub UpdateFrom (
    item As Item
)
Visual C++
public:
virtual void UpdateFrom(
    Item^ item
) override

Parameters

item
Type: Neodynamic.SDK.Printing..::..Item
The TextItem object that is used for updating this TextItem object.

See Also

TextItem Class
TextItem Members


TextItem Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Properties
TextItem Class See Also Send Feedback

The TextItem type exposes the following members.

Properties

 | Name | Description
Public property | BackColor | Gets or sets the background color of the text. Default value is White
Public property | BorderColor | Gets or sets the color of the border of the rectangle container. Default value is Black
Public property | BorderThickness | Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)
Public property | CacheItemId | Gets or sets the ID which will be assigned to the item in the cache. It must be a unique ID value for each item. The ID must be 1 to 8 alphanumeric [A-Z][0-9] characters long. If it's empty, then a random ID will be assigned automatically at runtime. Default value is an empty string (Inherited from Item.)
Public property | Comments | Gets or sets the comments associated to this item. Default is an empty string. (Inherited from Item.)
Public property | CornerRadius | Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)
Public property | CounterStep | Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)
Public property | CounterUseLeadingZeros | Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false
Public property | CultureName | Gets or sets the Culture Name for text formatting. Default is en-US. Other sample values: de-DE, es-ES, etc. Any value supported by .NET CultureInfo class.
Public property | DataField | Gets or sets the name of the field from the data source that contains the values to bind to this item. Default value is an empty string (Inherited from Item.)
Public property | DataFieldFormatString | Gets or sets the string that specifies the display format for the value of the data field. Default value is an empty string (Inherited from Item.)
Public property | Dpi | Gets or sets the item resolution, in dots per inch. (Inherited from Item.)
Public property | Font | Gets the Font object for the text. Default value is Arial, 8pt
Public property | ForeColor | Gets or sets the foreground color of the text. Default value is Black
Public property | Height | Gets or sets the height of the text item. Default value is 0.5
Public property | Locked | Gets or sets whether this item cannot be inadvertently moved nor resized in the visual editor surface. Default is false. (Inherited from Item.)
Public property | Mask | Gets or sets the input Mask for the text. Default value is an empty string
Public property | MaskIncrement | Gets or sets the mask increment. The increment is the value to be added to the text on each label to be printed. Default value is an empty string
Public property | Name | Gets or sets the programmatic identifier or name assigned to the item. Default value is an empty string (Inherited from Item.)
Public property | PrintAsGraphic | Gets or sets whether the item's output is forced to be printed as a graphic. Default is false. (Inherited from Item.)
Public property | RightToLeft | Gets or sets whether the text should draw right-to-left for RTL languages. Default value is false
Public property | RotationAngle | Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)
Public property | Sizing | Gets or sets the text sizing. Default value is None
Public property | Tag | Gets or sets an arbitrary string value that can be used to store custom information about this item. Default is an empty string. (Inherited from Item.)
Public property | Text | Gets or sets the text. Default value is an empty string
Public property | TextAlignment | Gets or sets the alignment of the text. Default value is Left
Public property | TextPadding | Gets or sets the amount of space between the container's border and the text content. Default value is 0 (zero)
Public property | UnitType | Gets or sets the Unit of Measurement for the item. (Inherited from Item.)
Public property | UseCache | Gets or sets whether the item should be cached in the printer's memory. An item cannot be cached if it's bound to some data source field through the DataField property. Default value is false (Inherited from Item.)
Public property | Width | Gets or sets the width of the text item. Default value is 1
Public property | X | Gets or sets the x-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)
Public property | Y | Gets or sets the y-coordinate of the upper-left corner of the item relative to the upper-left corner of its container. Default value is 0 (zero) (Inherited from Item.)

See Also

TextItem Class


TextItem.BackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..BackColor Property
TextItem Class See Also Send Feedback
Gets or sets the background color of the text. Default value is White

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color BackColor { get; set; }
Visual Basic
Public Property BackColor As Color
    Get
    Set
Visual C++
public:
property Color BackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

TextItem Class
TextItem Members


TextItem.BorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..BorderColor Property
TextItem Class See Also Send Feedback
Gets or sets the color of the border of the rectangle container. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color BorderColor { get; set; }
Visual Basic
Public Property BorderColor As Color
    Get
    Set
Visual C++
public:
property Color BorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

TextItem Class
TextItem Members


TextItem.BorderThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..BorderThickness Property
TextItem Class See Also Send Feedback
Gets or sets the thickness for each side of the rectangle container. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness BorderThickness { get; set; }
Visual Basic
Public Property BorderThickness As FrameThickness
    Get
    Set
Visual C++
public:
property FrameThickness^ BorderThickness {
    FrameThickness^ get ();
    void set (FrameThickness^ value);
}

Property Value

Type: FrameThickness

See Also

TextItem Class
TextItem Members


TextItem.CornerRadius Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..CornerRadius Property
TextItem Class See Also Send Feedback
Gets or sets the radii of a rectangle's corners. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public RectangleCornerRadius CornerRadius { get; set; }
Visual Basic
Public Property CornerRadius As RectangleCornerRadius
    Get
    Set
Visual C++
public:
property RectangleCornerRadius^ CornerRadius {
    RectangleCornerRadius^ get ();
    void set (RectangleCornerRadius^ value);
}

Property Value

Type: RectangleCornerRadius

See Also

TextItem Class
TextItem Members


TextItem.CounterStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..CounterStep Property
TextItem Class See Also Send Feedback
Gets or sets the step for the counter. The counter will increase (positive) or decrease (negative) by this number on every printed label. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int CounterStep { get; set; }
Visual Basic
Public Property CounterStep As Integer
    Get
    Set
Visual C++
public:
property int CounterStep {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

TextItem Class
TextItem Members


TextItem.CounterUseLeadingZeros Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..CounterUseLeadingZeros Property
TextItem Class See Also Send Feedback
Gets or sets whether leading zeros are printed or suppressed when using counters. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool CounterUseLeadingZeros { get; set; }
Visual Basic
Public Property CounterUseLeadingZeros As Boolean
    Get
    Set
Visual C++
public:
property bool CounterUseLeadingZeros {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TextItem Class
TextItem Members


TextItem.CultureName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..CultureName Property
TextItem Class See Also Send Feedback
Gets or sets the Culture Name for text formatting. Default is en-US. Other sample values: de-DE, es-ES, etc. Any value supported by .NET CultureInfo class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string CultureName { get; set; }
Visual Basic
Public Property CultureName As String
    Get
    Set
Visual C++
public:
property String^ CultureName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TextItem Class
TextItem Members


TextItem.Font Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Font Property
TextItem Class See Also Send Feedback
Gets the Font object for the text. Default value is Arial, 8pt

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Font Font { get; }
Visual Basic
Public ReadOnly Property Font As Font
    Get
Visual C++
public:
property Font^ Font {
    Font^ get ();
}

Property Value

Type: Font

See Also

TextItem Class
TextItem Members


TextItem.ForeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..ForeColor Property
TextItem Class See Also Send Feedback
Gets or sets the foreground color of the text. Default value is Black

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Color ForeColor { get; set; }
Visual Basic
Public Property ForeColor As Color
    Get
    Set
Visual C++
public:
property Color ForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

TextItem Class
TextItem Members


TextItem.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Height Property
TextItem Class See Also Send Feedback
Gets or sets the height of the text item. Default value is 0.5

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

TextItem Class
TextItem Members


TextItem.Mask Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Mask Property
TextItem Class See Also Send Feedback
Gets or sets the input Mask for the text. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Mask { get; set; }
Visual Basic
Public Property Mask As String
    Get
    Set
Visual C++
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The length of the mask defines the number of characters to be formatted or masked. The mask is aligned to the characters in the target string starting with the right-most position.

The input mask can consist of the following characters: D or d (Decimal numeric 0-9) H or h (Hexadecimal 0–9 plus a-f or A-F) O or o (Octal 0–7) A or a (Alphabetic A–Z or a–z) N or n (Alphanumeric 0–9 plus A–Z or a–z) % (Ignore character or skip)

See Also

TextItem Class
TextItem Members


TextItem.MaskIncrement Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..MaskIncrement Property
TextItem Class See Also Send Feedback
Gets or sets the mask increment. The increment is the value to be added to the text on each label to be printed. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string MaskIncrement { get; set; }
Visual Basic
Public Property MaskIncrement As String
    Get
    Set
Visual C++
public:
property String^ MaskIncrement {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Remarks

The default value for the increment is equivalent to a decimal value of 1 (one). The string is composed of any characters defined in the input mask. Invalid characters are assumed to be equal to a value of 0 (zero) in that characters position.

The increment value for alphabetic strings start with 'A' or 'a' as the zero placeholder. This means to increment an alphabetic character by one, a value of 'B' or 'b' must be in the increment string.

For characters that do not get incremented, the '%' character needs to be added to the increment string.

See Also

TextItem Class
TextItem Members


TextItem.RightToLeft Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..RightToLeft Property
TextItem Class See Also Send Feedback
Gets or sets whether the text should draw right-to-left for RTL languages. Default value is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool RightToLeft { get; set; }
Visual Basic
Public Property RightToLeft As Boolean
    Get
    Set
Visual C++
public:
property bool RightToLeft {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

TextItem Class
TextItem Members


TextItem.RotationAngle Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..RotationAngle Property
TextItem Class See Also Send Feedback
Gets or sets the rotation angle to apply on this item. It is measured clockwise from the x-axis. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int RotationAngle { get; set; }
Visual Basic
Public Property RotationAngle As Integer
    Get
    Set
Visual C++
public:
property int RotationAngle {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified value is not range from 0 to 360.

See Also

TextItem Class
TextItem Members


TextItem.Sizing Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Sizing Property
TextItem Class See Also Send Feedback
Gets or sets the text sizing. Default value is None

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TextSizing Sizing { get; set; }
Visual Basic
Public Property Sizing As TextSizing
    Get
    Set
Visual C++
public:
property TextSizing Sizing {
    TextSizing get ();
    void set (TextSizing value);
}

Property Value

Type: TextSizing

See Also

TextItem Class
TextItem Members


TextItem.Text Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Text Property
TextItem Class See Also Send Feedback
Gets or sets the text. Default value is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string Text { get; set; }
Visual Basic
Public Property Text As String
    Get
    Set
Visual C++
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

TextItem Class
TextItem Members


TextItem.TextAlignment Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..TextAlignment Property
TextItem Class See Also Send Feedback
Gets or sets the alignment of the text. Default value is Left

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic
Public Property TextAlignment As TextAlignment
    Get
    Set
Visual C++
public:
property TextAlignment TextAlignment {
    TextAlignment get ();
    void set (TextAlignment value);
}

Property Value

Type: TextAlignment

See Also

TextItem Class
TextItem Members


TextItem.TextPadding Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..TextPadding Property
TextItem Class See Also Send Feedback
Gets or sets the amount of space between the container's border and the text content. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public FrameThickness TextPadding { get; set; }
Visual Basic
Public Property TextPadding As FrameThickness
    Get
    Set
Visual C++
public:
property FrameThickness^ TextPadding {
    FrameThickness^ get ();
    void set (FrameThickness^ value);
}

Property Value

Type: FrameThickness

See Also

TextItem Class
TextItem Members


TextItem.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem..::..Width Property
TextItem Class See Also Send Feedback
Gets or sets the width of the text item. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

TextItem Class
TextItem Members


TextItem Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextItem Events
TextItem Class See Also Send Feedback

The TextItem type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from Item.)

See Also

TextItem Class


TextSizing Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TextSizing Enumeration
See Also Send Feedback
Specifies the text sizing.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum TextSizing
Visual Basic
Public Enumeration TextSizing
Visual C++
public enum class TextSizing

Members

Member name | Value | Description
None | 0 |
Stretch | 1 |

See Also


ThermalLabel Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Class
Members See Also Send Feedback
Represents a thermal label object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class ThermalLabel
Visual Basic
Public Class ThermalLabel
Visual C++
public ref class ThermalLabel

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..ThermalLabel

See Also

ThermalLabel Members


ThermalLabel Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Members
ThermalLabel Class Constructors Methods Properties See Also Send Feedback

The ThermalLabel type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalLabel()()()() | Initializes a new instance of the ThermalLabel class.
Public method | ThermalLabel(UnitType, Double, Double) | Initializes a new instance of the ThermalLabel class with the specified Unit of Measurement and size.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current ThermalLabel.
 | CreateFromXmlTemplate | Creates a ThermalLabel object based on the content of the specified XML Template.
Public method | GetXmlTemplate | Gets an XML Template for this ThermalLabel object.
Public method | LoadXmlTemplate | Restores this ThermalLabel object based on the content of the specified XML Template.

Properties

 | Name | Description
Public property | DataMember | Gets or sets the name of the list or table in the data source. Default is an empty string
Public property | DataSource | Gets or sets the data source for this thermal label. Default value is Null
Public property | DataSourceCultureInfo | Gets or sets the culture information used for formatting data source fields when binding to label items. Default is InvariantCulture
Public property | GapLength | Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | Height | Gets or sets the height of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1
Public property | IsContinuous | Gets or sets whether this ThermalLabel is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.
Public property | Items | Gets a collection of Item objects representing the individual items within the thermal label. Default value is an empty collection
Public property | LabelsHorizontalGapLength | Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | LabelsPerRow | Gets or sets the number of labels per row in the media roll. Default value is 1
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | MarkLength | Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | OffsetLength | Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | PrintSpeed | Gets or sets the media speed during printing. The value setting depends on the printer model and usually is in IPS (Inch Per Seconds). Look for it in the printer user manual.
Public property | UnitType | Gets or sets the Unit of Measurement for the thermal label. The Unit of Measurement affects the thermal label size as well as its items' dimensions and locations. Default value is Inch
Public property | Width | Gets or sets the width of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1

See Also

ThermalLabel Class


ThermalLabel Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Constructor
ThermalLabel Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ThermalLabel()()()() | Initializes a new instance of the ThermalLabel class.
Public method | ThermalLabel(UnitType, Double, Double) | Initializes a new instance of the ThermalLabel class with the specified Unit of Measurement and size.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Constructor
ThermalLabel Class See Also Send Feedback
Initializes a new instance of the ThermalLabel class.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ThermalLabel()
Visual Basic
Public Sub New
Visual C++
public:
ThermalLabel()

See Also

ThermalLabel Class
ThermalLabel Members
ThermalLabel Overload


ThermalLabel Constructor (UnitType, Double, Double)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Constructor (UnitType, Double, Double)
ThermalLabel Class See Also Send Feedback
Initializes a new instance of the ThermalLabel class with the specified Unit of Measurement and size.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ThermalLabel(
    UnitType unit,
    double width,
    double height
)
Visual Basic
Public Sub New (
    unit As UnitType,
    width As Double,
    height As Double
)
Visual C++
public:
ThermalLabel(
    UnitType unit,
    double width,
    double height
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType
The Unit of Measurement for the thermal label.
width
Type: System..::..Double
The width of the thermal label.
height
Type: System..::..Double
The height of the thermal label.

See Also

ThermalLabel Class
ThermalLabel Members
ThermalLabel Overload


ThermalLabel Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Methods
ThermalLabel Class See Also Send Feedback

The ThermalLabel type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a copy of the current ThermalLabel.
 | CreateFromXmlTemplate | Creates a ThermalLabel object based on the content of the specified XML Template.
Public method | GetXmlTemplate | Gets an XML Template for this ThermalLabel object.
Public method | LoadXmlTemplate | Restores this ThermalLabel object based on the content of the specified XML Template.

See Also

ThermalLabel Class


ThermalLabel.Clone Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..Clone Method
ThermalLabel Class See Also Send Feedback
Creates a copy of the current ThermalLabel.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ThermalLabel Clone()
Visual Basic
Public Function Clone As ThermalLabel
Visual C++
public:
ThermalLabel^ Clone()

Return Value

Type: ThermalLabel
A copy of the current ThermalLabel.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.CreateFromXmlTemplate Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..CreateFromXmlTemplate Method
ThermalLabel Class See Also Send Feedback
Creates a ThermalLabel object based on the content of the specified XML Template.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static ThermalLabel CreateFromXmlTemplate(
    string xmlTemplate
)
Visual Basic
Public Shared Function CreateFromXmlTemplate (
    xmlTemplate As String
) As ThermalLabel
Visual C++
public:
static ThermalLabel^ CreateFromXmlTemplate(
    String^ xmlTemplate
)

Parameters

xmlTemplate
Type: System..::..String
The content of the XML Template.

Return Value

Type: ThermalLabel
A ThermalLabel object based on the content of the specified XML Template.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.GetXmlTemplate Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..GetXmlTemplate Method
ThermalLabel Class See Also Send Feedback
Gets an XML Template for this ThermalLabel object.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string GetXmlTemplate()
Visual Basic
Public Function GetXmlTemplate As String
Visual C++
public:
String^ GetXmlTemplate()

Return Value

Type: String
An XML Template for this ThermalLabel object.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.LoadXmlTemplate Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..LoadXmlTemplate Method
ThermalLabel Class See Also Send Feedback
Restores this ThermalLabel object based on the content of the specified XML Template.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void LoadXmlTemplate(
    string xmlTemplate
)
Visual Basic
Public Sub LoadXmlTemplate (
    xmlTemplate As String
)
Visual C++
public:
void LoadXmlTemplate(
    String^ xmlTemplate
)

Parameters

xmlTemplate
Type: System..::..String
An XML Template for restoring this ThermalLabel object.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel Properties
ThermalLabel Class See Also Send Feedback

The ThermalLabel type exposes the following members.

Properties

 | Name | Description
Public property | DataMember | Gets or sets the name of the list or table in the data source. Default is an empty string
Public property | DataSource | Gets or sets the data source for this thermal label. Default value is Null
Public property | DataSourceCultureInfo | Gets or sets the culture information used for formatting data source fields when binding to label items. Default is InvariantCulture
Public property | GapLength | Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | Height | Gets or sets the height of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1
Public property | IsContinuous | Gets or sets whether this ThermalLabel is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.
Public property | Items | Gets a collection of Item objects representing the individual items within the thermal label. Default value is an empty collection
Public property | LabelsHorizontalGapLength | Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | LabelsPerRow | Gets or sets the number of labels per row in the media roll. Default value is 1
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | MarkLength | Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | OffsetLength | Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | PrintSpeed | Gets or sets the media speed during printing. The value setting depends on the printer model and usually is in IPS (Inch Per Seconds). Look for it in the printer user manual.
Public property | UnitType | Gets or sets the Unit of Measurement for the thermal label. The Unit of Measurement affects the thermal label size as well as its items' dimensions and locations. Default value is Inch
Public property | Width | Gets or sets the width of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1

See Also

ThermalLabel Class


ThermalLabel.DataMember Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..DataMember Property
ThermalLabel Class See Also Send Feedback
Gets or sets the name of the list or table in the data source. Default is an empty string

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string DataMember { get; set; }
Visual Basic
Public Property DataMember As String
    Get
    Set
Visual C++
public:
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.DataSource Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..DataSource Property
ThermalLabel Class See Also Send Feedback
Gets or sets the data source for this thermal label. Default value is Null

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public Object DataSource { get; set; }
Visual Basic
Public Property DataSource As Object
    Get
    Set
Visual C++
public:
property Object^ DataSource {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Remarks

The data source type supported are System.Data.DataSet, System.Data.DataTable, System.Data.DataView, System.Data.IDataReader, System.Collections.IEnumerable and path files for XML and CSV formats.

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.DataSourceCultureInfo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..DataSourceCultureInfo Property
ThermalLabel Class See Also Send Feedback
Gets or sets the culture information used for formatting data source fields when binding to label items. Default is InvariantCulture

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public CultureInfo DataSourceCultureInfo { get; set; }
Visual Basic
Public Property DataSourceCultureInfo As CultureInfo
    Get
    Set
Visual C++
public:
property CultureInfo^ DataSourceCultureInfo {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Property Value

Type: CultureInfo

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.GapLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..GapLength Property
ThermalLabel Class See Also Send Feedback
Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double GapLength { get; set; }
Visual Basic
Public Property GapLength As Double
    Get
    Set
Visual C++
public:
property double GapLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..Height Property
ThermalLabel Class See Also Send Feedback
Gets or sets the height of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.IsContinuous Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..IsContinuous Property
ThermalLabel Class See Also Send Feedback
Gets or sets whether this ThermalLabel is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool IsContinuous { get; set; }
Visual Basic
Public Property IsContinuous As Boolean
    Get
    Set
Visual C++
public:
property bool IsContinuous {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.Items Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..Items Property
ThermalLabel Class See Also Send Feedback
Gets a collection of Item objects representing the individual items within the thermal label. Default value is an empty collection

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ItemCollection Items { get; }
Visual Basic
Public ReadOnly Property Items As ItemCollection
    Get
Visual C++
public:
property ItemCollection^ Items {
    ItemCollection^ get ();
}

Property Value

Type: ItemCollection

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.LabelsHorizontalGapLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..LabelsHorizontalGapLength Property
ThermalLabel Class See Also Send Feedback
Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double LabelsHorizontalGapLength { get; set; }
Visual Basic
Public Property LabelsHorizontalGapLength As Double
    Get
    Set
Visual C++
public:
property double LabelsHorizontalGapLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.LabelsPerRow Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..LabelsPerRow Property
ThermalLabel Class See Also Send Feedback
Gets or sets the number of labels per row in the media roll. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int LabelsPerRow { get; set; }
Visual Basic
Public Property LabelsPerRow As Integer
    Get
    Set
Visual C++
public:
property int LabelsPerRow {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.LicenseKey Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..LicenseKey Property
ThermalLabel Class See Also Send Feedback
Gets or sets the license key info.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string LicenseKey { get; set; }
Visual Basic
Public Shared Property LicenseKey As String
    Get
    Set
Visual C++
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.LicenseOwner Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..LicenseOwner Property
ThermalLabel Class See Also Send Feedback
Gets or sets the license owner info.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public static string LicenseOwner { get; set; }
Visual Basic
Public Shared Property LicenseOwner As String
    Get
    Set
Visual C++
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.MarkLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..MarkLength Property
ThermalLabel Class See Also Send Feedback
Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double MarkLength { get; set; }
Visual Basic
Public Property MarkLength As Double
    Get
    Set
Visual C++
public:
property double MarkLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.OffsetLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..OffsetLength Property
ThermalLabel Class See Also Send Feedback
Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double OffsetLength { get; set; }
Visual Basic
Public Property OffsetLength As Double
    Get
    Set
Visual C++
public:
property double OffsetLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.PrintSpeed Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..PrintSpeed Property
ThermalLabel Class See Also Send Feedback
Gets or sets the media speed during printing. The value setting depends on the printer model and usually is in IPS (Inch Per Seconds). Look for it in the printer user manual.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string PrintSpeed { get; set; }
Visual Basic
Public Property PrintSpeed As String
    Get
    Set
Visual C++
public:
property String^ PrintSpeed {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.UnitType Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..UnitType Property
ThermalLabel Class See Also Send Feedback
Gets or sets the Unit of Measurement for the thermal label. The Unit of Measurement affects the thermal label size as well as its items' dimensions and locations. Default value is Inch

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public UnitType UnitType { get; set; }
Visual Basic
Public Property UnitType As UnitType
    Get
    Set
Visual C++
public:
property UnitType UnitType {
    UnitType get ();
    void set (UnitType value);
}

Property Value

Type: UnitType

See Also

ThermalLabel Class
ThermalLabel Members


ThermalLabel.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabel..::..Width Property
ThermalLabel Class See Also Send Feedback
Gets or sets the width of the thermal label. The unit of measurement is specified by UnitType property. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabel Class
ThermalLabel Members


TiffCompression Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
TiffCompression Enumeration
See Also Send Feedback
Specifies the supported compression schemes for Tagged Image File Format (TIFF) bitmap images.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum TiffCompression
Visual Basic
Public Enumeration TiffCompression
Visual C++
public enum class TiffCompression

Members

Member name | Value | Description
None | 0 | The Tagged Image File Format (TIFF) image is not compressed.
CCITT3 | 1 | The CCITT3 compression schema is used.
CCITT4 | 2 | The CCITT4 compression schema is used.
LZW | 3 | The LZW compression schema is used.
RLE | 4 | The RLE compression schema is used.
ZIP | 5 | The ZIP compression schema is used.

See Also


UnitType Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitType Enumeration
See Also Send Feedback
Specifies the unit of measurement.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum UnitType
Visual Basic
Public Enumeration UnitType
Visual C++
public enum class UnitType

Members

Member name | Value | Description
Cm | 0 | Measurement is in centimeters.
Inch | 1 | Measurement is in inches.
Mm | 2 | Measurement is in millimeters.
DotsPerInch | 3 | Measurement is in dots per inch (DPI).
Point | 4 | Measurement is in points. A point represents 1/72 of an inch.
Pica | 5 | Measurement is in picas. A pica represents 12 points.
Mils | 6 | Measurement is in mils. A mil represents 1/1000 of an inch.

See Also


UpcE Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UpcE Enumeration
See Also Send Feedback
Specifies the number system to use for UPC-E symbology.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public enum UpcE
Visual Basic
Public Enumeration UpcE
Visual C++
public enum class UpcE

Members

Member name | Value | Description
System0 | 0 |
System1 | 1 |

See Also


WebPrintJob Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob Class
Members See Also Send Feedback
Specifies information about how a thermal label is printed, including the printer device settings, label orientation, number of copies, etc. to be used in ASP.NET scenarios by using the TLClientPrint utility.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class WebPrintJob
Visual Basic
Public Class WebPrintJob
Visual C++
public ref class WebPrintJob

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..WebPrintJob

See Also

WebPrintJob Members


WebPrintJob Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob Members
WebPrintJob Class Constructors Methods Properties See Also Send Feedback

The WebPrintJob type exposes the following members.

Constructors

 | Name | Description
Public method | WebPrintJob |

Methods

 | Name | Description
Public method | CreateFromString |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Copies | Gets or sets the number of copies of the thermal label to print. Default value is 1
Public property | LicenseKey | Gets or sets the license key info.
Public property | LicenseOwner | Gets or sets the license owner info.
Public property | PrinterSettings | Gets or sets information about the thermal printer used for printing.
Public property | PrintOrientation | Gets or sets the page orientation used to print the thermal label. Default value is Portrait
Public property | Replicates | Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)
Public property | ShowPrintDialog | Gets or sets whether a custom Print Dialog is displayed at the client machine. Default is false
Public property | ThermalLabel | Gets or sets the ThermalLabel object to be printed out. Default value is Null
Public property | ThermalLabelGroup | Gets or sets a group of ThermalLabel objects to be printed out. Default value is Empty

See Also

WebPrintJob Class


WebPrintJob Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob Constructor
WebPrintJob Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public WebPrintJob()
Visual Basic
Public Sub New
Visual C++
public:
WebPrintJob()

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob Methods
WebPrintJob Class See Also Send Feedback

The WebPrintJob type exposes the following members.

Methods

 | Name | Description
Public method | CreateFromString |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

WebPrintJob Class


WebPrintJob.CreateFromString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..CreateFromString Method
WebPrintJob Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void CreateFromString(
    string webPrintJobData
)
Visual Basic
Public Sub CreateFromString (
    webPrintJobData As String
)
Visual C++
public:
void CreateFromString(
    String^ webPrintJobData
)

Parameters

webPrintJobData
Type: System..::..String

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.ToString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..ToString Method
WebPrintJob Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob Properties
WebPrintJob Class See Also Send Feedback

The WebPrintJob type exposes the following members.

Properties

 | Name | Description
Public property | Copies | Gets or sets the number of copies of the thermal label to print. Default value is 1
Public property | LicenseKey | Gets or sets the license key info.
Public property | LicenseOwner | Gets or sets the license owner info.
Public property | PrinterSettings | Gets or sets information about the thermal printer used for printing.
Public property | PrintOrientation | Gets or sets the page orientation used to print the thermal label. Default value is Portrait
Public property | Replicates | Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)
Public property | ShowPrintDialog | Gets or sets whether a custom Print Dialog is displayed at the client machine. Default is false
Public property | ThermalLabel | Gets or sets the ThermalLabel object to be printed out. Default value is Null
Public property | ThermalLabelGroup | Gets or sets a group of ThermalLabel objects to be printed out. Default value is Empty

See Also

WebPrintJob Class


WebPrintJob.Copies Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..Copies Property
WebPrintJob Class See Also Send Feedback
Gets or sets the number of copies of the thermal label to print. Default value is 1

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Copies { get; set; }
Visual Basic
Public Property Copies As Integer
    Get
    Set
Visual C++
public:
property int Copies {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.LicenseKey Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..LicenseKey Property
WebPrintJob Class See Also Send Feedback
Gets or sets the license key info.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string LicenseKey { get; set; }
Visual Basic
Public Property LicenseKey As String
    Get
    Set
Visual C++
public:
property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.LicenseOwner Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..LicenseOwner Property
WebPrintJob Class See Also Send Feedback
Gets or sets the license owner info.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public string LicenseOwner { get; set; }
Visual Basic
Public Property LicenseOwner As String
    Get
    Set
Visual C++
public:
property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.PrinterSettings Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..PrinterSettings Property
WebPrintJob Class See Also Send Feedback
Gets or sets information about the thermal printer used for printing.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrinterSettings PrinterSettings { get; set; }
Visual Basic
Public Property PrinterSettings As PrinterSettings
    Get
    Set
Visual C++
public:
property PrinterSettings^ PrinterSettings {
    PrinterSettings^ get ();
    void set (PrinterSettings^ value);
}

Property Value

Type: PrinterSettings

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.PrintOrientation Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..PrintOrientation Property
WebPrintJob Class See Also Send Feedback
Gets or sets the page orientation used to print the thermal label. Default value is Portrait

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public PrintOrientation PrintOrientation { get; set; }
Visual Basic
Public Property PrintOrientation As PrintOrientation
    Get
    Set
Visual C++
public:
property PrintOrientation PrintOrientation {
    PrintOrientation get ();
    void set (PrintOrientation value);
}

Property Value

Type: PrintOrientation

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.Replicates Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..Replicates Property
WebPrintJob Class See Also Send Feedback
Gets or sets the number of replicates of the thermal label to print. Default value is 0 (zero)

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public int Replicates { get; set; }
Visual Basic
Public Property Replicates As Integer
    Get
    Set
Visual C++
public:
property int Replicates {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.ShowPrintDialog Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..ShowPrintDialog Property
WebPrintJob Class See Also Send Feedback
Gets or sets whether a custom Print Dialog is displayed at the client machine. Default is false

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public bool ShowPrintDialog { get; set; }
Visual Basic
Public Property ShowPrintDialog As Boolean
    Get
    Set
Visual C++
public:
property bool ShowPrintDialog {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.ThermalLabel Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..ThermalLabel Property
WebPrintJob Class See Also Send Feedback
Gets or sets the ThermalLabel object to be printed out. Default value is Null

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public ThermalLabel ThermalLabel { get; set; }
Visual Basic
Public Property ThermalLabel As ThermalLabel
    Get
    Set
Visual C++
public:
property ThermalLabel^ ThermalLabel {
    ThermalLabel^ get ();
    void set (ThermalLabel^ value);
}

Property Value

Type: ThermalLabel

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJob.ThermalLabelGroup Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJob..::..ThermalLabelGroup Property
WebPrintJob Class See Also Send Feedback
Gets or sets a group of ThermalLabel objects to be printed out. Default value is Empty

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public List<ThermalLabel> ThermalLabelGroup { get; }
Visual Basic
Public ReadOnly Property ThermalLabelGroup As List(Of ThermalLabel)
    Get
Visual C++
public:
property List<ThermalLabel^>^ ThermalLabelGroup {
    List<ThermalLabel^>^ get ();
}

Property Value

Type: List <(Of <(<' ThermalLabel >)>)>

See Also

WebPrintJob Class
WebPrintJob Members


WebPrintJobGroup Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup Class
Members See Also Send Feedback
A group of WebPrintJob objects to be used in ASP.NET scenarios through the TLClientPrint utility.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public class WebPrintJobGroup
Visual Basic
Public Class WebPrintJobGroup
Visual C++
public ref class WebPrintJobGroup

Inheritance Hierarchy

System..::..Object
Neodynamic.SDK.Printing..::..WebPrintJobGroup

See Also

WebPrintJobGroup Members


WebPrintJobGroup Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup Members
WebPrintJobGroup Class Constructors Methods Properties See Also Send Feedback

The WebPrintJobGroup type exposes the following members.

Constructors

 | Name | Description
Public method | WebPrintJobGroup |

Methods

 | Name | Description
Public method | CreateFromString |
Public method | ToString | (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | PrintJobs | Gets a list of WebPrintJob objects. Default is an empty list.

See Also

WebPrintJobGroup Class


WebPrintJobGroup Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup Constructor
WebPrintJobGroup Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public WebPrintJobGroup()
Visual Basic
Public Sub New
Visual C++
public:
WebPrintJobGroup()

See Also

WebPrintJobGroup Class
WebPrintJobGroup Members


WebPrintJobGroup Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup Methods
WebPrintJobGroup Class See Also Send Feedback

The WebPrintJobGroup type exposes the following members.

Methods

 | Name | Description
Public method | CreateFromString |
Public method | ToString | (Overrides Object..::..ToString()()()().)

See Also

WebPrintJobGroup Class


WebPrintJobGroup.CreateFromString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup..::..CreateFromString Method
WebPrintJobGroup Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public void CreateFromString(
    string webPrintJobGroupData
)
Visual Basic
Public Sub CreateFromString (
    webPrintJobGroupData As String
)
Visual C++
public:
void CreateFromString(
    String^ webPrintJobGroupData
)

Parameters

webPrintJobGroupData
Type: System..::..String

See Also

WebPrintJobGroup Class
WebPrintJobGroup Members


WebPrintJobGroup.ToString Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup..::..ToString Method
WebPrintJobGroup Class See Also Send Feedback

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

Type: String

See Also

WebPrintJobGroup Class
WebPrintJobGroup Members


WebPrintJobGroup Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup Properties
WebPrintJobGroup Class See Also Send Feedback

The WebPrintJobGroup type exposes the following members.

Properties

 | Name | Description
Public property | PrintJobs | Gets a list of WebPrintJob objects. Default is an empty list.

See Also

WebPrintJobGroup Class


WebPrintJobGroup.PrintJobs Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
WebPrintJobGroup..::..PrintJobs Property
WebPrintJobGroup Class See Also Send Feedback
Gets a list of WebPrintJob objects. Default is an empty list.

Namespace: Neodynamic.SDK.Printing
Assembly: Neodynamic.SDK.ThermalLabel (in Neodynamic.SDK.ThermalLabel.dll) Version: 6.0.3500.0 (6.0.3515.430)

Syntax

C#
public List<WebPrintJob> PrintJobs { get; }
Visual Basic
Public ReadOnly Property PrintJobs As List(Of WebPrintJob)
    Get
Visual C++
public:
property List<WebPrintJob^>^ PrintJobs {
    List<WebPrintJob^>^ get ();
}

Property Value

Type: List <(Of <(<' WebPrintJob >)>)>

See Also

WebPrintJobGroup Class
WebPrintJobGroup Members


Neodynamic.Windows.Forms.ThermalLabelEditor Namespace

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace
Send Feedback

Classes

 | Class | Description
Public class | ThermalLabelEditor | ThermalLabelEditor lets end-users to graphically design barcode thermal labels inside your Windows Forms applications.


ThermalLabelEditor Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Class
Members See Also Send Feedback
ThermalLabelEditor lets end-users to graphically design barcode thermal labels inside your Windows Forms applications.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class ThermalLabelEditor : Control
Visual Basic
Public Class ThermalLabelEditor
    Inherits Control
Visual C++
public ref class ThermalLabelEditor : public Control

Inheritance Hierarchy

System..::..Object
System..::..MarshalByRefObject
System.ComponentModel..::..Component
System.Windows.Forms..::..Control
Neodynamic.Windows.Forms.ThermalLabelEditor..::..ThermalLabelEditor

See Also

ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Members
ThermalLabelEditor Class Constructors Methods Properties Events See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalLabelEditor |

Methods

 | Name | Description
Public method | BringForward | Brings the selected items one step closer to the front of the label surface.
Public method | BringToFront | Brings the selected items to the front of the label surface.
Public method | Close | Closes the current label document.
Public method | Copy | Copies the current selection in the editor to the internal Clipboard.
Public method | CreateThermalLabel | Creates a ThermalLabel object based on the current LabelDocument data and visual items.
Public method | Cut | Cuts the current selection in the editor and moves it to the internal Clipboard.
Public method | DeleteAll | Deletes all the items on the editor's surface.
Public method | DeleteSelectedItems | Deletes the selected items on the editor's surface.
Public method | EnableEditor | Enables the ThermalLabelEditor. Invoke it in the Form_Load event of the parent form hosting the editor.
Public method | LoadThermalLabel | Loads the specified ThermalLabel object on the editor's surface.
Public method | LockSelectedItems | Locks all the items in the current selection.
Public method | MoveSelectedItems | Moves the selected items by the specified horizontal and vertical offsets.
Public method | Paste | Pates the content of the internal Clipborad on the editor surface.
Public method | Redo | Performs a Redo action.
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.
Public method | SelectAll | Selects all the items on the editor's surface.
Public method | SelectItemByName | Selects an item by its name on the editor's surface.
Public method | SelectItemsByNames | Selects a set of items by their names on the editor's surface.
Public method | SendBackward | Sends the selected items one step toward the background of the label surface.
Public method | SendToBack | Sends the selected items to the background of the label surface.
Public method | Undo | Performs an Undo action.
Public method | UnlockSelectedItems | Unlocks all the items in the current selection.
Public method | UnselectAll | Unselects all the selected items on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateSelectionItemsProperties | Updates the properties of the selected items on the editor's surface.

Properties

 | Name | Description
Public property | ActiveTool | Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.
Public property | ActiveToolItem | Gets or sets the Item object which is added to the editor's surface by the end-user.
Public property | AdornerFrameBorderColor | Gets or sets the border color for the adorner's frame. Default is Black.
Public property | AdornerHandlerBackColor | Gets or sets the background color for the adorner's handlers. Default is Green.
Public property | AdornerHandlerBorderColor | Gets or sets the border color for the adorner's handlers. Default is Black.
Public property | AdornerHandlerHoverBackColor | Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.
Public property | AdornerSelectionBackColor | Gets or sets the background color for the selection adorner's frame.
Public property | AdornerSelectionBorderColor | Gets or sets the border color for the selection adorner's frame.
Public property | AngleSnap | Gets or sets the angle snap used for items' rotation. Default is 5 degrees.
Public property | ArrowKeysLargeStep | Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.
Public property | ArrowKeysShortStep | Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.
Public property | CanCopy | Gets whether a Clipboard Copy action can be performed.
Public property | CanCut | Gets whether a Clipboard Cut action can be performed.
Public property | CanPaste | Gets whether a Clipboard Paste action can be performed.
Public property | CanRedo | Gets whether the Redo action is available.
Public property | CanUndo | Gets whether the Undo action is available.
Public property | CurrentSelection | Gets the current selected item on the editor.
Public property | CurrentSelectionArea | Gets the location and size of the current selected items on the editor.
Public property | GridSize | Gets or sets the size of the grid in current unit. Default is zero.
Public property | ImageProcessingDpi | Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.
Public property | LabelDocument | Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.
Public property | LabelDocumentFrameBackColor | Gets or sets the background color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBackgroundImage | Gets or sets the background image for the label document frame on the editor's surface. Default is empty.
Public property | LabelDocumentFrameBorderColor | Gets or sets the border color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderThickness | Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.
Public property | LabelDocumentFrameCornerRadius | Gets or sets the radii of the corners of the label document frame. Default value is 10.
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | NoImageFileName | Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.
Public property | RFIDTagImageFileName | Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.
Public property | RulerBackColor | Gets or sets the background color for the editor's rulers. Default is SystemColors.Control
Public property | RulerForeColor | Gets or sets the foreground color for the number tags of the editor's rulers.
Public property | RulerLinesColor | Gets or sets the color for the lines which compose the editor's rulers.
Public property | RulerSelectionColor | Gets or sets the background color for the selection zone of the editor's rulers.
Public property | ShowGrid | Gets or sets whether grid is displayed. Default is false.
Public property | SnapToGrid | Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.
Public property | TextItemEditModeEnabled | Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.
Public property | Zoom | Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

Events

 | Name | Description
Public event | ClipboardStateChanged | Occurs when the state of the internal Clipboard changes.
Public event | NewItemCreated | Occurs when a new item is created on the editor's surface.
Public event | SelectionAreaChanged | Occurs when the editor's selection area changes.
Public event | SelectionChanged | Occurs when the editor's selection changes.
Public event | SelectionItemPropertyChanged | Occurs when any property of the selected item changes.
Public event | UndoStateChanged | Occurs when the undo state of the editor changes.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Constructor
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public ThermalLabelEditor()
Visual Basic
Public Sub New
Visual C++
public:
ThermalLabelEditor()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Methods
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Methods

 | Name | Description
Public method | BringForward | Brings the selected items one step closer to the front of the label surface.
Public method | BringToFront | Brings the selected items to the front of the label surface.
Public method | Close | Closes the current label document.
Public method | Copy | Copies the current selection in the editor to the internal Clipboard.
Public method | CreateThermalLabel | Creates a ThermalLabel object based on the current LabelDocument data and visual items.
Public method | Cut | Cuts the current selection in the editor and moves it to the internal Clipboard.
Public method | DeleteAll | Deletes all the items on the editor's surface.
Public method | DeleteSelectedItems | Deletes the selected items on the editor's surface.
Public method | EnableEditor | Enables the ThermalLabelEditor. Invoke it in the Form_Load event of the parent form hosting the editor.
Public method | LoadThermalLabel | Loads the specified ThermalLabel object on the editor's surface.
Public method | LockSelectedItems | Locks all the items in the current selection.
Public method | MoveSelectedItems | Moves the selected items by the specified horizontal and vertical offsets.
Public method | Paste | Pates the content of the internal Clipborad on the editor surface.
Public method | Redo | Performs a Redo action.
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.
Public method | SelectAll | Selects all the items on the editor's surface.
Public method | SelectItemByName | Selects an item by its name on the editor's surface.
Public method | SelectItemsByNames | Selects a set of items by their names on the editor's surface.
Public method | SendBackward | Sends the selected items one step toward the background of the label surface.
Public method | SendToBack | Sends the selected items to the background of the label surface.
Public method | Undo | Performs an Undo action.
Public method | UnlockSelectedItems | Unlocks all the items in the current selection.
Public method | UnselectAll | Unselects all the selected items on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateSelectionItemsProperties | Updates the properties of the selected items on the editor's surface.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.BringForward Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..BringForward Method
ThermalLabelEditor Class See Also Send Feedback
Brings the selected items one step closer to the front of the label surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void BringForward()
Visual Basic
Public Sub BringForward
Visual C++
public:
void BringForward()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.BringToFront Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..BringToFront Method
ThermalLabelEditor Class See Also Send Feedback
Brings the selected items to the front of the label surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void BringToFront()
Visual Basic
Public Sub BringToFront
Visual C++
public:
void BringToFront()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Close Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Close Method
ThermalLabelEditor Class See Also Send Feedback
Closes the current label document.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Copy Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Copy Method
ThermalLabelEditor Class See Also Send Feedback
Copies the current selection in the editor to the internal Clipboard.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Copy()
Visual Basic
Public Sub Copy
Visual C++
public:
void Copy()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CreateThermalLabel Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CreateThermalLabel Method
ThermalLabelEditor Class See Also Send Feedback
Creates a ThermalLabel object based on the current LabelDocument data and visual items.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public ThermalLabel CreateThermalLabel()
Visual Basic
Public Function CreateThermalLabel As ThermalLabel
Visual C++
public:
ThermalLabel^ CreateThermalLabel()

Return Value

Type: ThermalLabel
A ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Cut Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Cut Method
ThermalLabelEditor Class See Also Send Feedback
Cuts the current selection in the editor and moves it to the internal Clipboard.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Cut()
Visual Basic
Public Sub Cut
Visual C++
public:
void Cut()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.DeleteAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..DeleteAll Method
ThermalLabelEditor Class See Also Send Feedback
Deletes all the items on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void DeleteAll()
Visual Basic
Public Sub DeleteAll
Visual C++
public:
void DeleteAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.DeleteSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..DeleteSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Deletes the selected items on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void DeleteSelectedItems()
Visual Basic
Public Sub DeleteSelectedItems
Visual C++
public:
void DeleteSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.EnableEditor Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..EnableEditor Method
ThermalLabelEditor Class See Also Send Feedback
Enables the ThermalLabelEditor. Invoke it in the Form_Load event of the parent form hosting the editor.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void EnableEditor()
Visual Basic
Public Sub EnableEditor
Visual C++
public:
void EnableEditor()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LoadThermalLabel Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LoadThermalLabel Method
ThermalLabelEditor Class See Also Send Feedback
Loads the specified ThermalLabel object on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void LoadThermalLabel(
    ThermalLabel thermalLabel
)
Visual Basic
Public Sub LoadThermalLabel (
    thermalLabel As ThermalLabel
)
Visual C++
public:
void LoadThermalLabel(
    ThermalLabel^ thermalLabel
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
A ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LockSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LockSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Locks all the items in the current selection.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void LockSelectedItems()
Visual Basic
Public Sub LockSelectedItems
Visual C++
public:
void LockSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.MoveSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..MoveSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Moves the selected items by the specified horizontal and vertical offsets.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void MoveSelectedItems(
    double deltaX,
    double deltaY
)
Visual Basic
Public Sub MoveSelectedItems (
    deltaX As Double,
    deltaY As Double
)
Visual C++
public:
void MoveSelectedItems(
    double deltaX,
    double deltaY
)

Parameters

deltaX
Type: System..::..Double
The horizontal (X-axis) offset.
deltaY
Type: System..::..Double
The vertical (Y-axis) offset.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Paste Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Paste Method
ThermalLabelEditor Class See Also Send Feedback
Pates the content of the internal Clipborad on the editor surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Paste()
Visual Basic
Public Sub Paste
Visual C++
public:
void Paste()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Redo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Redo Method
ThermalLabelEditor Class See Also Send Feedback
Performs a Redo action.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Redo()
Visual Basic
Public Sub Redo
Visual C++
public:
void Redo()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method
ThermalLabelEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method (Stream)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method (Stream)
ThermalLabelEditor Class See Also Send Feedback
Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic
Public Sub Save (
    stream As Stream
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream where the ThermalLabel object will be saved.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Save Overload
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method (String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method (String)
ThermalLabelEditor Class See Also Send Feedback
Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save (
    fileName As String
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
A string that contains the name of the file (full path) to which to save the ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Save Overload
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectAll Method
ThermalLabelEditor Class See Also Send Feedback
Selects all the items on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectAll()
Visual Basic
Public Sub SelectAll
Visual C++
public:
void SelectAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectItemByName Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectItemByName Method
ThermalLabelEditor Class See Also Send Feedback
Selects an item by its name on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectItemByName(
    string itemName
)
Visual Basic
Public Sub SelectItemByName (
    itemName As String
)
Visual C++
public:
void SelectItemByName(
    String^ itemName
)

Parameters

itemName
Type: System..::..String
The name of the item to be selected.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectItemsByNames Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectItemsByNames Method
ThermalLabelEditor Class See Also Send Feedback
Selects a set of items by their names on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectItemsByNames(
    string[] itemNames
)
Visual Basic
Public Sub SelectItemsByNames (
    itemNames As String()
)
Visual C++
public:
void SelectItemsByNames(
    array<String^>^ itemNames
)

Parameters

itemNames
Type: array< System..::..String >[]()[][]

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SendBackward Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SendBackward Method
ThermalLabelEditor Class See Also Send Feedback
Sends the selected items one step toward the background of the label surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SendBackward()
Visual Basic
Public Sub SendBackward
Visual C++
public:
void SendBackward()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SendToBack Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SendToBack Method
ThermalLabelEditor Class See Also Send Feedback
Sends the selected items to the background of the label surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SendToBack()
Visual Basic
Public Sub SendToBack
Visual C++
public:
void SendToBack()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Undo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Undo Method
ThermalLabelEditor Class See Also Send Feedback
Performs an Undo action.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Undo()
Visual Basic
Public Sub Undo
Visual C++
public:
void Undo()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UnlockSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UnlockSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Unlocks all the items in the current selection.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UnlockSelectedItems()
Visual Basic
Public Sub UnlockSelectedItems
Visual C++
public:
void UnlockSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UnselectAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UnselectAll Method
ThermalLabelEditor Class See Also Send Feedback
Unselects all the selected items on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UnselectAll()
Visual Basic
Public Sub UnselectAll
Visual C++
public:
void UnselectAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method
ThermalLabelEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method (UnitType, Double, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method (UnitType, Double, Double, Int32)
ThermalLabelEditor Class See Also Send Feedback
Updates the LabelDocument object on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits
)
Visual Basic
Public Sub UpdateLabelDocument (
    unit As UnitType,
    width As Double,
    height As Double,
    numOfFractionalDigits As Integer
)
Visual C++
public:
void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType
The Unit of Measurement for the label document.
width
Type: System..::..Double
The width of the label document.
height
Type: System..::..Double
The height of the label document.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits to use with all floating-point values related to the label document.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
UpdateLabelDocument Overload
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method (UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method (UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean)
ThermalLabelEditor Class See Also Send Feedback
Updates the LabelDocument object on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits,
    double gapLength,
    double markLength,
    double offsetLength,
    int labelsPerRow,
    double labelsHorizontalGapLength,
    bool isContinuous
)
Visual Basic
Public Sub UpdateLabelDocument (
    unit As UnitType,
    width As Double,
    height As Double,
    numOfFractionalDigits As Integer,
    gapLength As Double,
    markLength As Double,
    offsetLength As Double,
    labelsPerRow As Integer,
    labelsHorizontalGapLength As Double,
    isContinuous As Boolean
)
Visual C++
public:
void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits,
    double gapLength,
    double markLength,
    double offsetLength,
    int labelsPerRow,
    double labelsHorizontalGapLength,
    bool isContinuous
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType
The Unit of Measurement for the label document.
width
Type: System..::..Double
The width of the label document.
height
Type: System..::..Double
The height of the label document.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits to use with all floating-point values related to the label document.
gapLength
Type: System..::..Double
The vertical gap length between labels.
markLength
Type: System..::..Double
The mark length or thickness between labels.
offsetLength
Type: System..::..Double
The offset length or thickness between labels.
labelsPerRow
Type: System..::..Int32
The number of labels per row in the media roll.
labelsHorizontalGapLength
Type: System..::..Double
The horizontal gap length between labels when the media roll contains more than one label per row.
isContinuous
Type: System..::..Boolean
Whether this document is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
UpdateLabelDocument Overload
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateSelectionItemsProperties Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateSelectionItemsProperties Method
ThermalLabelEditor Class See Also Send Feedback
Updates the properties of the selected items on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateSelectionItemsProperties()
Visual Basic
Public Sub UpdateSelectionItemsProperties
Visual C++
public:
void UpdateSelectionItemsProperties()

Remarks

When you present the selected items' properties to the end-user through some UI like a PropertyGrid control, a dialog box, etc. and the user modifies them, you must call this method so the changes are reflected on the selected items on the editor's surface.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Properties
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActiveTool | Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.
Public property | ActiveToolItem | Gets or sets the Item object which is added to the editor's surface by the end-user.
Public property | AdornerFrameBorderColor | Gets or sets the border color for the adorner's frame. Default is Black.
Public property | AdornerHandlerBackColor | Gets or sets the background color for the adorner's handlers. Default is Green.
Public property | AdornerHandlerBorderColor | Gets or sets the border color for the adorner's handlers. Default is Black.
Public property | AdornerHandlerHoverBackColor | Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.
Public property | AdornerSelectionBackColor | Gets or sets the background color for the selection adorner's frame.
Public property | AdornerSelectionBorderColor | Gets or sets the border color for the selection adorner's frame.
Public property | AngleSnap | Gets or sets the angle snap used for items' rotation. Default is 5 degrees.
Public property | ArrowKeysLargeStep | Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.
Public property | ArrowKeysShortStep | Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.
Public property | CanCopy | Gets whether a Clipboard Copy action can be performed.
Public property | CanCut | Gets whether a Clipboard Cut action can be performed.
Public property | CanPaste | Gets whether a Clipboard Paste action can be performed.
Public property | CanRedo | Gets whether the Redo action is available.
Public property | CanUndo | Gets whether the Undo action is available.
Public property | CurrentSelection | Gets the current selected item on the editor.
Public property | CurrentSelectionArea | Gets the location and size of the current selected items on the editor.
Public property | GridSize | Gets or sets the size of the grid in current unit. Default is zero.
Public property | ImageProcessingDpi | Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.
Public property | LabelDocument | Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.
Public property | LabelDocumentFrameBackColor | Gets or sets the background color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBackgroundImage | Gets or sets the background image for the label document frame on the editor's surface. Default is empty.
Public property | LabelDocumentFrameBorderColor | Gets or sets the border color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderThickness | Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.
Public property | LabelDocumentFrameCornerRadius | Gets or sets the radii of the corners of the label document frame. Default value is 10.
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | NoImageFileName | Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.
Public property | RFIDTagImageFileName | Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.
Public property | RulerBackColor | Gets or sets the background color for the editor's rulers. Default is SystemColors.Control
Public property | RulerForeColor | Gets or sets the foreground color for the number tags of the editor's rulers.
Public property | RulerLinesColor | Gets or sets the color for the lines which compose the editor's rulers.
Public property | RulerSelectionColor | Gets or sets the background color for the selection zone of the editor's rulers.
Public property | ShowGrid | Gets or sets whether grid is displayed. Default is false.
Public property | SnapToGrid | Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.
Public property | TextItemEditModeEnabled | Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.
Public property | Zoom | Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveTool Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveTool Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public EditorTool ActiveTool { get; set; }
Visual Basic
Public Property ActiveTool As EditorTool
    Get
    Set
Visual C++
public:
property EditorTool ActiveTool {
    EditorTool get ();
    void set (EditorTool value);
}

Property Value

Type: EditorTool

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveToolItem Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveToolItem Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the Item object which is added to the editor's surface by the end-user.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Item ActiveToolItem { get; set; }
Visual Basic
Public Property ActiveToolItem As Item
    Get
    Set
Visual C++
public:
property Item^ ActiveToolItem {
    Item^ get ();
    void set (Item^ value);
}

Property Value

Type: Item

Remarks

The Item object specified by this property must match the type which is currently set up to the ActiveTool property. For example, if the ActiveTool is set up to Text, then a new TextItem object needs to be specified to the ActiveToolItem property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerFrameBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerFrameBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the adorner's frame. Default is Black.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerFrameBorderColor { get; set; }
Visual Basic
Public Property AdornerFrameBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerFrameBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the adorner's handlers. Default is Green.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerBackColor { get; set; }
Visual Basic
Public Property AdornerHandlerBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the adorner's handlers. Default is Black.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerBorderColor { get; set; }
Visual Basic
Public Property AdornerHandlerBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerHoverBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerHoverBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerHoverBackColor { get; set; }
Visual Basic
Public Property AdornerHandlerHoverBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerHoverBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the selection adorner's frame.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerSelectionBackColor { get; set; }
Visual Basic
Public Property AdornerSelectionBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerSelectionBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the selection adorner's frame.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerSelectionBorderColor { get; set; }
Visual Basic
Public Property AdornerSelectionBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerSelectionBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.AngleSnap Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AngleSnap Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the angle snap used for items' rotation. Default is 5 degrees.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public int AngleSnap { get; set; }
Visual Basic
Public Property AngleSnap As Integer
    Get
    Set
Visual C++
public:
property int AngleSnap {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysLargeStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysLargeStep Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ArrowKeysLargeStep { get; set; }
Visual Basic
Public Property ArrowKeysLargeStep As Double
    Get
    Set
Visual C++
public:
property double ArrowKeysLargeStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysShortStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysShortStep Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ArrowKeysShortStep { get; set; }
Visual Basic
Public Property ArrowKeysShortStep As Double
    Get
    Set
Visual C++
public:
property double ArrowKeysShortStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCopy Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCopy Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Copy action can be performed.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanCopy { get; }
Visual Basic
Public ReadOnly Property CanCopy As Boolean
    Get
Visual C++
public:
property bool CanCopy {
    bool get ();
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCut Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCut Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Cut action can be performed.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanCut { get; }
Visual Basic
Public ReadOnly Property CanCut As Boolean
    Get
Visual C++
public:
property bool CanCut {
    bool get ();
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CanPaste Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanPaste Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Paste action can be performed.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanPaste { get; }
Visual Basic
Public ReadOnly Property CanPaste As Boolean
    Get
Visual C++
public:
property bool CanPaste {
    bool get ();
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CanRedo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanRedo Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether the Redo action is available.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanRedo { get; }
Visual Basic
Public ReadOnly Property CanRedo As Boolean
    Get
Visual C++
public:
property bool CanRedo {
    bool get ();
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CanUndo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanUndo Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether the Undo action is available.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanUndo { get; }
Visual Basic
Public ReadOnly Property CanUndo As Boolean
    Get
Visual C++
public:
property bool CanUndo {
    bool get ();
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelection Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelection Property
ThermalLabelEditor Class See Also Send Feedback
Gets the current selected item on the editor.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Item CurrentSelection { get; }
Visual Basic
Public ReadOnly Property CurrentSelection As Item
    Get
Visual C++
public:
property Item^ CurrentSelection {
    Item^ get ();
}

Property Value

Type: Item

Remarks

This property returns an Item-derived class representing the current selection on the editor.

If the selection is just one item only, then the returned object will be the Item-derived class of such object. For exmaple, if a Rectangle item is selected, then the returned object will be a RectangleShapeItem instance.

If the selection contains more than one item, then the returned object will be an instance of the MultipleSelectionItem class. The MultipleSelectionItem class contains some properties that are common to most Item-derived classes. That means that some properties of such class are common to all Item-derived classes, for example, the X and Y properties. Notice that the MultipleSelectionItem class also contains some properties that are common for a group of Item-derived classes and not to all. For example, the Font property is valid for TextItem and BarcodeItem object only.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelectionArea Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelectionArea Property
ThermalLabelEditor Class See Also Send Feedback
Gets the location and size of the current selected items on the editor.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public RectangleF CurrentSelectionArea { get; }
Visual Basic
Public ReadOnly Property CurrentSelectionArea As RectangleF
    Get
Visual C++
public:
property RectangleF CurrentSelectionArea {
    RectangleF get ();
}

Property Value

Type: RectangleF

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.GridSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..GridSize Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the size of the grid in current unit. Default is zero.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double GridSize { get; set; }
Visual Basic
Public Property GridSize As Double
    Get
    Set
Visual C++
public:
property double GridSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ImageProcessingDpi Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ImageProcessingDpi Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ImageProcessingDpi { get; set; }
Visual Basic
Public Property ImageProcessingDpi As Double
    Get
    Set
Visual C++
public:
property double ImageProcessingDpi {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocument Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocument Property
ThermalLabelEditor Class See Also Send Feedback
Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public LabelDocument LabelDocument { get; }
Visual Basic
Public ReadOnly Property LabelDocument As LabelDocument
    Get
Visual C++
public:
property LabelDocument^ LabelDocument {
    LabelDocument^ get ();
}

Property Value

Type: LabelDocument

Remarks

The LabelDocument object is a lightweight version of the ThermalLabel class and is automatically created when you load a ThermalLabel object through the LoadThermalLabel() method.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the label document frame on the editor's surface. Default is White.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color LabelDocumentFrameBackColor { get; set; }
Visual Basic
Public Property LabelDocumentFrameBackColor As Color
    Get
    Set
Visual C++
public:
property Color LabelDocumentFrameBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBackgroundImage Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBackgroundImage Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background image for the label document frame on the editor's surface. Default is empty.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public string LabelDocumentFrameBackgroundImage { get; set; }
Visual Basic
Public Property LabelDocumentFrameBackgroundImage As String
    Get
    Set
Visual C++
public:
property String^ LabelDocumentFrameBackgroundImage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the label document frame on the editor's surface. Default is White.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color LabelDocumentFrameBorderColor { get; set; }
Visual Basic
Public Property LabelDocumentFrameBorderColor As Color
    Get
    Set
Visual C++
public:
property Color LabelDocumentFrameBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderThickness Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double LabelDocumentFrameBorderThickness { get; set; }
Visual Basic
Public Property LabelDocumentFrameBorderThickness As Double
    Get
    Set
Visual C++
public:
property double LabelDocumentFrameBorderThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameCornerRadius Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameCornerRadius Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the radii of the corners of the label document frame. Default value is 10.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double LabelDocumentFrameCornerRadius { get; set; }
Visual Basic
Public Property LabelDocumentFrameCornerRadius As Double
    Get
    Set
Visual C++
public:
property double LabelDocumentFrameCornerRadius {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LicenseKey Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LicenseKey Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the license key info.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string LicenseKey { get; set; }
Visual Basic
Public Shared Property LicenseKey As String
    Get
    Set
Visual C++
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.LicenseOwner Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LicenseOwner Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the license owner info.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string LicenseOwner { get; set; }
Visual Basic
Public Shared Property LicenseOwner As String
    Get
    Set
Visual C++
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.NoImageFileName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..NoImageFileName Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public string NoImageFileName { get; set; }
Visual Basic
Public Property NoImageFileName As String
    Get
    Set
Visual C++
public:
property String^ NoImageFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.RFIDTagImageFileName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RFIDTagImageFileName Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public string RFIDTagImageFileName { get; set; }
Visual Basic
Public Property RFIDTagImageFileName As String
    Get
    Set
Visual C++
public:
property String^ RFIDTagImageFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the editor's rulers. Default is SystemColors.Control

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerBackColor { get; set; }
Visual Basic
Public Property RulerBackColor As Color
    Get
    Set
Visual C++
public:
property Color RulerBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerForeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerForeColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the foreground color for the number tags of the editor's rulers.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerForeColor { get; set; }
Visual Basic
Public Property RulerForeColor As Color
    Get
    Set
Visual C++
public:
property Color RulerForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerLinesColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerLinesColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the color for the lines which compose the editor's rulers.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerLinesColor { get; set; }
Visual Basic
Public Property RulerLinesColor As Color
    Get
    Set
Visual C++
public:
property Color RulerLinesColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerSelectionColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerSelectionColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the selection zone of the editor's rulers.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerSelectionColor { get; set; }
Visual Basic
Public Property RulerSelectionColor As Color
    Get
    Set
Visual C++
public:
property Color RulerSelectionColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ShowGrid Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ShowGrid Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether grid is displayed. Default is false.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic
Public Property ShowGrid As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SnapToGrid Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SnapToGrid Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool SnapToGrid { get; set; }
Visual Basic
Public Property SnapToGrid As Boolean
    Get
    Set
Visual C++
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.TextItemEditModeEnabled Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..TextItemEditModeEnabled Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool TextItemEditModeEnabled { get; set; }
Visual Basic
Public Property TextItemEditModeEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool TextItemEditModeEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.Zoom Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Zoom Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Events
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Events

 | Name | Description
Public event | ClipboardStateChanged | Occurs when the state of the internal Clipboard changes.
Public event | NewItemCreated | Occurs when a new item is created on the editor's surface.
Public event | SelectionAreaChanged | Occurs when the editor's selection area changes.
Public event | SelectionChanged | Occurs when the editor's selection changes.
Public event | SelectionItemPropertyChanged | Occurs when any property of the selected item changes.
Public event | UndoStateChanged | Occurs when the undo state of the editor changes.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.ClipboardStateChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ClipboardStateChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the state of the internal Clipboard changes.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler ClipboardStateChanged
Visual Basic
Public Event ClipboardStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ ClipboardStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to update the state of the classic Copy, Cut and Paste buttons of the UI by using the CanCopy, CanCut and CanPaste properties.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.NewItemCreated Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..NewItemCreated Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when a new item is created on the editor's surface.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler NewItemCreated
Visual Basic
Public Event NewItemCreated As EventHandler
Visual C++
public:
 event EventHandler^ NewItemCreated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionAreaChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionAreaChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the editor's selection area changes.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionAreaChanged
Visual Basic
Public Event SelectionAreaChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionAreaChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to present the selection's location and size to the end-user by using the CurrentSelectionArea property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the editor's selection changes.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to present the selection data to the end-user by using the CurrentSelection property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionItemPropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionItemPropertyChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when any property of the selected item changes.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionItemPropertyChanged
Visual Basic
Public Event SelectionItemPropertyChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionItemPropertyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


ThermalLabelEditor.UndoStateChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UndoStateChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the undo state of the editor changes.

Namespace: Neodynamic.Windows.Forms.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler UndoStateChanged
Visual Basic
Public Event UndoStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ UndoStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to update the Undo and Redo buttons of the UI by using the CanUndo and CanRedo properties.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.Forms.ThermalLabelEditor Namespace


Neodynamic.Windows.ThermalLabelEditor Namespace

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Neodynamic.Windows.ThermalLabelEditor Namespace
Send Feedback

Classes

 | Class | Description
Public class | BarcodeException | Represents errors that occur during barcode generation process
Public class | BarcodeItemUtils | Provides some utilities related to BarcodeItem objects.
Public class | FontUtils | Provides some utilities related to Fonts.
Public class | ImageItemUtils | Provides some utilities related to ImageItem objects.
Public class | LabelDocument | Represents a label document on the editor's surface.
Public class | UnitUtils | Provides some utilities related to Unit of Measurement.

Enumerations

 | Enumeration | Description
Public enumeration | EditorTool | Specifies the available tools on the visual label editor.


BarcodeException Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Class
Members See Also Send Feedback
Represents errors that occur during barcode generation process

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class BarcodeException : Exception
Visual Basic
Public Class BarcodeException
    Inherits Exception
Visual C++
public ref class BarcodeException : public Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
Neodynamic.Windows.ThermalLabelEditor..::..BarcodeException

See Also

BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Members
BarcodeException Class Constructors Fields Properties See Also Send Feedback

The BarcodeException type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeException(Int32) |
Public method | BarcodeException(Int32, String) |

Fields

Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |

Properties

 | Name | Description
Public property | ErrorCode |
 | Errors |

See Also

BarcodeException Class
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Constructor

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor
BarcodeException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BarcodeException(Int32) |
Public method | BarcodeException(Int32, String) |

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Constructor (Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor (Int32)
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public BarcodeException(
    int errorCode
)
Visual Basic
Public Sub New (
    errorCode As Integer
)
Visual C++
public:
BarcodeException(
    int errorCode
)

Parameters

errorCode
Type: System..::..Int32

See Also

BarcodeException Class
BarcodeException Members
BarcodeException Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Constructor (Int32, String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Constructor (Int32, String)
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public BarcodeException(
    int errorCode,
    string message
)
Visual Basic
Public Sub New (
    errorCode As Integer,
    message As String
)
Visual C++
public:
BarcodeException(
    int errorCode,
    String^ message
)

Parameters

errorCode
Type: System..::..Int32
message
Type: System..::..String

See Also

BarcodeException Class
BarcodeException Members
BarcodeException Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Fields

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Fields
BarcodeException Class See Also Send Feedback

The BarcodeException type exposes the following members.

Fields

Name | Description
CHECKSUM_GEN_FAILED |
CODE_GEN_FAILED |
CODE_NOT_VALID |
CODE_NOT_VALID_IN_CC |
CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT |
CODE_NULL_OR_EMPTY |
DATA_OVERFLOW |
DATAMATRIX_INVALID_FILE_ID |
PROCESS_TILDE_FAILED |
PROCESS_TILDE_FAILED_INVALID_CHAR_DEC |
PROCESS_TILDE_FAILED_INVALID_CHAR_HEX |
PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI |
PROCESS_TILDE_FAILED_INVALID_DM_MACRO |
PROCESS_TILDE_FAILED_INVALID_DM_PR |
PROCESS_TILDE_FAILED_INVALID_ECI |
REED_SOLOMON_GEN_FAILED |

See Also

BarcodeException Class
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CHECKSUM_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CHECKSUM_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CHECKSUM_GEN_FAILED
Visual Basic
Public Const CHECKSUM_GEN_FAILED As Integer
Visual C++
public:
literal int CHECKSUM_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CODE_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CODE_GEN_FAILED
Visual Basic
Public Const CODE_GEN_FAILED As Integer
Visual C++
public:
literal int CODE_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CODE_NOT_VALID Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CODE_NOT_VALID
Visual Basic
Public Const CODE_NOT_VALID As Integer
Visual C++
public:
literal int CODE_NOT_VALID

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CODE_NOT_VALID_IN_CC Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID_IN_CC Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CODE_NOT_VALID_IN_CC
Visual Basic
Public Const CODE_NOT_VALID_IN_CC As Integer
Visual C++
public:
literal int CODE_NOT_VALID_IN_CC

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT
Visual Basic
Public Const CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT As Integer
Visual C++
public:
literal int CODE_NOT_VALID_IN_EAN_UPC_SUPPLEMENT

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.CODE_NULL_OR_EMPTY Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..CODE_NULL_OR_EMPTY Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int CODE_NULL_OR_EMPTY
Visual Basic
Public Const CODE_NULL_OR_EMPTY As Integer
Visual C++
public:
literal int CODE_NULL_OR_EMPTY

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.DATA_OVERFLOW Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..DATA_OVERFLOW Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int DATA_OVERFLOW
Visual Basic
Public Const DATA_OVERFLOW As Integer
Visual C++
public:
literal int DATA_OVERFLOW

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.DATAMATRIX_INVALID_FILE_ID Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..DATAMATRIX_INVALID_FILE_ID Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int DATAMATRIX_INVALID_FILE_ID
Visual Basic
Public Const DATAMATRIX_INVALID_FILE_ID As Integer
Visual C++
public:
literal int DATAMATRIX_INVALID_FILE_ID

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED
Visual Basic
Public Const PROCESS_TILDE_FAILED As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_DEC Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_DEC As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_DEC

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_HEX Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_HEX As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_HEX

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_CHAR_KANJI

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_DM_MACRO Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_DM_MACRO
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_DM_MACRO As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_MACRO

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_DM_PR Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_DM_PR Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_DM_PR
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_DM_PR As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_DM_PR

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.PROCESS_TILDE_FAILED_INVALID_ECI Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..PROCESS_TILDE_FAILED_INVALID_ECI Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int PROCESS_TILDE_FAILED_INVALID_ECI
Visual Basic
Public Const PROCESS_TILDE_FAILED_INVALID_ECI As Integer
Visual C++
public:
literal int PROCESS_TILDE_FAILED_INVALID_ECI

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.REED_SOLOMON_GEN_FAILED Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..REED_SOLOMON_GEN_FAILED Field
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public const int REED_SOLOMON_GEN_FAILED
Visual Basic
Public Const REED_SOLOMON_GEN_FAILED As Integer
Visual C++
public:
literal int REED_SOLOMON_GEN_FAILED

Field Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException Properties
BarcodeException Class See Also Send Feedback

The BarcodeException type exposes the following members.

Properties

 | Name | Description
Public property | ErrorCode |
 | Errors |

See Also

BarcodeException Class
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.ErrorCode Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..ErrorCode Property
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public int ErrorCode { get; set; }
Visual Basic
Public Property ErrorCode As Integer
    Get
    Set
Visual C++
public:
property int ErrorCode {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeException.Errors Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeException..::..Errors Property
BarcodeException Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static Dictionary<int, string> Errors { get; }
Visual Basic
Public Shared ReadOnly Property Errors As Dictionary(Of Integer, String)
    Get
Visual C++
public:
static property Dictionary<int, String^>^ Errors {
    Dictionary<int, String^>^ get ();
}

Property Value

Type: Dictionary <(Of <(<' Int32, String >)>)>

See Also

BarcodeException Class
BarcodeException Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils Class
Members See Also Send Feedback
Provides some utilities related to BarcodeItem objects.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class BarcodeItemUtils
Visual Basic
Public Class BarcodeItemUtils
Visual C++
public ref class BarcodeItemUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.ThermalLabelEditor..::..BarcodeItemUtils

See Also

BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils Members
BarcodeItemUtils Class Constructors Methods See Also Send Feedback

The BarcodeItemUtils type exposes the following members.

Constructors

 | Name | Description
Public method | BarcodeItemUtils |

Methods

Name | Description
GenerateSampleCode | Generates a sample value to encode (code) based on the specified symbology.
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.

See Also

BarcodeItemUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils Constructor
BarcodeItemUtils Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public BarcodeItemUtils()
Visual Basic
Public Sub New
Visual C++
public:
BarcodeItemUtils()

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils Methods
BarcodeItemUtils Class See Also Send Feedback

The BarcodeItemUtils type exposes the following members.

Methods

Name | Description
GenerateSampleCode | Generates a sample value to encode (code) based on the specified symbology.
GetAustraliaPost4StateBarcodeChecksum | It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.
GetAustraliaPostDomesticEParcelChecksum | It computes the checksum for an Australia Post Domestic eParcel code.
GetCode39Checksum | It computes the checksum Modulus 43 used by Code 39 barcode.
GetCode93Checksum | It computes the two-char checksum Modulus 47 used by Code 93 barcode.
GetModulus10Checksum | It computes the checksum Modulus 10 used by many barcode symbologies.

See Also

BarcodeItemUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GenerateSampleCode Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GenerateSampleCode Method
BarcodeItemUtils Class See Also Send Feedback
Generates a sample value to encode (code) based on the specified symbology.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string GenerateSampleCode(
    BarcodeSymbology symbology
)
Visual Basic
Public Shared Function GenerateSampleCode (
    symbology As BarcodeSymbology
) As String
Visual C++
public:
static String^ GenerateSampleCode(
    BarcodeSymbology symbology
)

Parameters

symbology
Type: Neodynamic.SDK.Printing..::..BarcodeSymbology
The barcode symbology.

Return Value

Type: String
Returns a sample value to encode (code) based on the specified symbology.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GetAustraliaPost4StateBarcodeChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GetAustraliaPost4StateBarcodeChecksum Method
BarcodeItemUtils Class See Also Send Feedback
It computes the checksum (Reed Solomon codewords) for an Australia Post 4 State code.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string GetAustraliaPost4StateBarcodeChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPost4StateBarcodeChecksum (
    code As String
) As String
Visual C++
public:
static String^ GetAustraliaPost4StateBarcodeChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post 4 State code.

Return Value

Type: String
The checksum (Reed Solomon codewords) for an Australia Post 4 State code.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GetAustraliaPostDomesticEParcelChecksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GetAustraliaPostDomesticEParcelChecksum Method
BarcodeItemUtils Class See Also Send Feedback
It computes the checksum for an Australia Post Domestic eParcel code.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static int GetAustraliaPostDomesticEParcelChecksum(
    string code
)
Visual Basic
Public Shared Function GetAustraliaPostDomesticEParcelChecksum (
    code As String
) As Integer
Visual C++
public:
static int GetAustraliaPostDomesticEParcelChecksum(
    String^ code
)

Parameters

code
Type: System..::..String
An Australia Post Domestic eParcel code.

Return Value

Type: Int32
The checksum for an Australia Post Domestic eParcel code.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GetCode39Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GetCode39Checksum Method
BarcodeItemUtils Class See Also Send Feedback
It computes the checksum Modulus 43 used by Code 39 barcode.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string GetCode39Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode39Checksum (
    code As String
) As String
Visual C++
public:
static String^ GetCode39Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 39 value.

Return Value

Type: String
The checksum Modulus 43 used by Code 39 barcode.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GetCode93Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GetCode93Checksum Method
BarcodeItemUtils Class See Also Send Feedback
It computes the two-char checksum Modulus 47 used by Code 93 barcode.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string GetCode93Checksum(
    string code
)
Visual Basic
Public Shared Function GetCode93Checksum (
    code As String
) As String
Visual C++
public:
static String^ GetCode93Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The Code 93 value.

Return Value

Type: String
The two-char checksum Modulus 47 used by Code 93 barcode.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


BarcodeItemUtils.GetModulus10Checksum Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
BarcodeItemUtils..::..GetModulus10Checksum Method
BarcodeItemUtils Class See Also Send Feedback
It computes the checksum Modulus 10 used by many barcode symbologies.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static int GetModulus10Checksum(
    string code
)
Visual Basic
Public Shared Function GetModulus10Checksum (
    code As String
) As Integer
Visual C++
public:
static int GetModulus10Checksum(
    String^ code
)

Parameters

code
Type: System..::..String
The code where the checksum will be computed on.

Return Value

Type: Int32
The checksum Modulus 10.

See Also

BarcodeItemUtils Class
BarcodeItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


EditorTool Enumeration

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorTool Enumeration
See Also Send Feedback
Specifies the available tools on the visual label editor.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public enum EditorTool
Visual Basic
Public Enumeration EditorTool
Visual C++
public enum class EditorTool

Members

Member name | Value | Description
Pointer | 0 |
Rectangle | 1 |
Ellipse | 2 |
Line | 3 |
Text | 4 |
Barcode | 5 |
Image | 6 |
Literal | 7 |
RFIDTag | 8 |

See Also

Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils Class
Members See Also Send Feedback
Provides some utilities related to Fonts.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class FontUtils
Visual Basic
Public Class FontUtils
Visual C++
public ref class FontUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.ThermalLabelEditor..::..FontUtils

See Also

FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils Members
FontUtils Class Constructors Methods See Also Send Feedback

The FontUtils type exposes the following members.

Constructors

 | Name | Description
Public method | FontUtils |

Methods

Name | Description
ConvertToFont(Font) | Converts the specified System.Drawing.Font object to a Neodynamic.SDK.Printing.Font object.
ConvertToFont(FontFamily) | Converts the specified System.Windows.Media.FontFamily object to a Neodynamic.SDK.Printing.Font object.
ConvertToFontFamily | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Windows.Media.FontFamily object.
ConvertToGdiFont | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.Font object.
ConvertToGdiFontFamily | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.FontFamily object.

See Also

FontUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils Constructor
FontUtils Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public FontUtils()
Visual Basic
Public Sub New
Visual C++
public:
FontUtils()

See Also

FontUtils Class
FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils Methods
FontUtils Class See Also Send Feedback

The FontUtils type exposes the following members.

Methods

Name | Description
ConvertToFont(Font) | Converts the specified System.Drawing.Font object to a Neodynamic.SDK.Printing.Font object.
ConvertToFont(FontFamily) | Converts the specified System.Windows.Media.FontFamily object to a Neodynamic.SDK.Printing.Font object.
ConvertToFontFamily | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Windows.Media.FontFamily object.
ConvertToGdiFont | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.Font object.
ConvertToGdiFontFamily | Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.FontFamily object.

See Also

FontUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToFont Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToFont Method
FontUtils Class See Also Send Feedback

Overload List

Name | Description
ConvertToFont(Font) | Converts the specified System.Drawing.Font object to a Neodynamic.SDK.Printing.Font object.
ConvertToFont(FontFamily) | Converts the specified System.Windows.Media.FontFamily object to a Neodynamic.SDK.Printing.Font object.

See Also

FontUtils Class
FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToFont Method (Font)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToFont Method (Font)
FontUtils Class See Also Send Feedback
Converts the specified System.Drawing.Font object to a Neodynamic.SDK.Printing.Font object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static Font ConvertToFont(
    Font gdiFont
)
Visual Basic
Public Shared Function ConvertToFont (
    gdiFont As Font
) As Font
Visual C++
public:
static Font^ ConvertToFont(
    Font^ gdiFont
)

Parameters

gdiFont
Type: System.Drawing..::..Font
The System.Drawing.Font to be converted to a Neodynamic.SDK.Printing.Font object.

Return Value

Type: Font
A Neodynamic.SDK.Printing.Font object created based on the specified System.Drawing.Font object.

See Also

FontUtils Class
FontUtils Members
ConvertToFont Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToFont Method (FontFamily)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToFont Method (FontFamily)
FontUtils Class See Also Send Feedback
Converts the specified System.Windows.Media.FontFamily object to a Neodynamic.SDK.Printing.Font object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static Font ConvertToFont(
    FontFamily fontFamily
)
Visual Basic
Public Shared Function ConvertToFont (
    fontFamily As FontFamily
) As Font
Visual C++
public:
static Font^ ConvertToFont(
    FontFamily^ fontFamily
)

Parameters

fontFamily
Type: System.Windows.Media..::..FontFamily
The System.Windows.Media.FontFamily to be converted to a Neodynamic.SDK.Printing.Font object.

Return Value

Type: Font
A Neodynamic.SDK.Printing.Font object created based on the specified System.Windows.Media.FontFamily object.

See Also

FontUtils Class
FontUtils Members
ConvertToFont Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToFontFamily Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToFontFamily Method
FontUtils Class See Also Send Feedback
Converts the specified Neodynamic.SDK.Printing.Font object to a System.Windows.Media.FontFamily object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static FontFamily ConvertToFontFamily(
    Font font
)
Visual Basic
Public Shared Function ConvertToFontFamily (
    font As Font
) As FontFamily
Visual C++
public:
static FontFamily^ ConvertToFontFamily(
    Font^ font
)

Parameters

font
Type: Neodynamic.SDK.Printing..::..Font
The Neodynamic.SDK.Printing.Font to be converted to a System.Windows.Media.FontFamily object.

Return Value

Type: FontFamily
A System.Windows.Media.FontFamily object created based on the specified Neodynamic.SDK.Printing.Font object.

See Also

FontUtils Class
FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToGdiFont Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToGdiFont Method
FontUtils Class See Also Send Feedback
Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.Font object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static Font ConvertToGdiFont(
    Font font
)
Visual Basic
Public Shared Function ConvertToGdiFont (
    font As Font
) As Font
Visual C++
public:
static Font^ ConvertToGdiFont(
    Font^ font
)

Parameters

font
Type: Neodynamic.SDK.Printing..::..Font
The Neodynamic.SDK.Printing.Font to be converted to a System.Drawing.Font object.

Return Value

Type: Font
A System.Drawing.Font object created based on the specified Neodynamic.SDK.Printing.Font object.

Remarks

This method will not work for custom font files. If the Neodynamic.SDK.Printing.Font object is a custom font file, then invoke the ConvertToGdiFontFamily method instead.

See Also

FontUtils Class
FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


FontUtils.ConvertToGdiFontFamily Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
FontUtils..::..ConvertToGdiFontFamily Method
FontUtils Class See Also Send Feedback
Converts the specified Neodynamic.SDK.Printing.Font object to a System.Drawing.FontFamily object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static FontFamily ConvertToGdiFontFamily(
    Font font,
    out PrivateFontCollection fontCollection
)
Visual Basic
Public Shared Function ConvertToGdiFontFamily (
    font As Font,
    <OutAttribute> ByRef fontCollection As PrivateFontCollection
) As FontFamily
Visual C++
public:
static FontFamily^ ConvertToGdiFontFamily(
    Font^ font,
    [OutAttribute] PrivateFontCollection^% fontCollection
)

Parameters

font
Type: Neodynamic.SDK.Printing..::..Font
The Neodynamic.SDK.Printing.Font to be converted to a System.Drawing.FontFamily object.
fontCollection
Type: System.Drawing.Text..::..PrivateFontCollection %
A System.Drawing.Text.PrivateFontCollection object which needs to be disposed after using the created System.Drawing.FontFamily object.

Return Value

Type: FontFamily
A System.Drawing.FontFamily object created based on the specified Neodynamic.SDK.Printing.Font object.

See Also

FontUtils Class
FontUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils Class
Members See Also Send Feedback
Provides some utilities related to ImageItem objects.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class ImageItemUtils
Visual Basic
Public Class ImageItemUtils
Visual C++
public ref class ImageItemUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.ThermalLabelEditor..::..ImageItemUtils

See Also

ImageItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils Members
ImageItemUtils Class Constructors Methods See Also Send Feedback

The ImageItemUtils type exposes the following members.

Constructors

 | Name | Description
Public method | ImageItemUtils |

Methods

Name | Description
ConvertToBitmap | Converts an ImageItem object to a bitmap (System.Windows.Media.Imaging.WriteableBitmap) object.
ConvertToGdiBitmap | Converts an ImageItem object to a bitmap (System.Drawing.Bitmap) object.

See Also

ImageItemUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils Constructor
ImageItemUtils Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public ImageItemUtils()
Visual Basic
Public Sub New
Visual C++
public:
ImageItemUtils()

See Also

ImageItemUtils Class
ImageItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils Methods
ImageItemUtils Class See Also Send Feedback

The ImageItemUtils type exposes the following members.

Methods

Name | Description
ConvertToBitmap | Converts an ImageItem object to a bitmap (System.Windows.Media.Imaging.WriteableBitmap) object.
ConvertToGdiBitmap | Converts an ImageItem object to a bitmap (System.Drawing.Bitmap) object.

See Also

ImageItemUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils.ConvertToBitmap Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils..::..ConvertToBitmap Method
ImageItemUtils Class See Also Send Feedback
Converts an ImageItem object to a bitmap (System.Windows.Media.Imaging.WriteableBitmap) object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static WriteableBitmap ConvertToBitmap(
    ImageItem imageItem
)
Visual Basic
Public Shared Function ConvertToBitmap (
    imageItem As ImageItem
) As WriteableBitmap
Visual C++
public:
static WriteableBitmap^ ConvertToBitmap(
    ImageItem^ imageItem
)

Parameters

imageItem
Type: Neodynamic.SDK.Printing..::..ImageItem
The ImageItem object.

Return Value

Type: WriteableBitmap
A bitmap (System.Windows.Media.Imaging.WriteableBitmap) which represents the ImageItem object.

See Also

ImageItemUtils Class
ImageItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


ImageItemUtils.ConvertToGdiBitmap Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ImageItemUtils..::..ConvertToGdiBitmap Method
ImageItemUtils Class See Also Send Feedback
Converts an ImageItem object to a bitmap (System.Drawing.Bitmap) object.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static Bitmap ConvertToGdiBitmap(
    ImageItem imageItem
)
Visual Basic
Public Shared Function ConvertToGdiBitmap (
    imageItem As ImageItem
) As Bitmap
Visual C++
public:
static Bitmap^ ConvertToGdiBitmap(
    ImageItem^ imageItem
)

Parameters

imageItem
Type: Neodynamic.SDK.Printing..::..ImageItem
The ImageItem object.

Return Value

Type: Bitmap
A bitmap (System.Drawing.Bitmap) which represents the ImageItem object.

See Also

ImageItemUtils Class
ImageItemUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument Class
Members See Also Send Feedback
Represents a label document on the editor's surface.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class LabelDocument
Visual Basic
Public Class LabelDocument
Visual C++
public ref class LabelDocument

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.ThermalLabelEditor..::..LabelDocument

See Also

LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument Members
LabelDocument Class Constructors Properties See Also Send Feedback

The LabelDocument type exposes the following members.

Constructors

 | Name | Description
Public method | LabelDocument |

Properties

 | Name | Description
Public property | GapLength | Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | Height | Gets or sets the height of the label document.
Public property | IsContinuous | Gets or sets whether this document is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.
Public property | LabelsHorizontalGapLength | Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | LabelsPerRow | Gets or sets the number of labels per row in the media roll. Default value is 1
Public property | MarkLength | Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | NumOfFractionalDigits | Gets or sets the number of fractional digits to use with all floating-point values. Default is 4.
Public property | OffsetLength | Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | UnitType | Gets or sets the Unit of Measurement for the label document.
Public property | Width | Gets or sets the width of the label document.

See Also

LabelDocument Class
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument Constructor
LabelDocument Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public LabelDocument()
Visual Basic
Public Sub New
Visual C++
public:
LabelDocument()

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument Properties
LabelDocument Class See Also Send Feedback

The LabelDocument type exposes the following members.

Properties

 | Name | Description
Public property | GapLength | Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | Height | Gets or sets the height of the label document.
Public property | IsContinuous | Gets or sets whether this document is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.
Public property | LabelsHorizontalGapLength | Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | LabelsPerRow | Gets or sets the number of labels per row in the media roll. Default value is 1
Public property | MarkLength | Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | NumOfFractionalDigits | Gets or sets the number of fractional digits to use with all floating-point values. Default is 4.
Public property | OffsetLength | Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)
Public property | UnitType | Gets or sets the Unit of Measurement for the label document.
Public property | Width | Gets or sets the width of the label document.

See Also

LabelDocument Class
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.GapLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..GapLength Property
LabelDocument Class See Also Send Feedback
Gets or sets the vertical gap length between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double GapLength { get; set; }
Visual Basic
Public Property GapLength As Double
    Get
    Set
Visual C++
public:
property double GapLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.Height Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..Height Property
LabelDocument Class See Also Send Feedback
Gets or sets the height of the label document.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double Height { get; set; }
Visual Basic
Public Property Height As Double
    Get
    Set
Visual C++
public:
property double Height {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.IsContinuous Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..IsContinuous Property
LabelDocument Class See Also Send Feedback
Gets or sets whether this document is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes. Default is false.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool IsContinuous { get; set; }
Visual Basic
Public Property IsContinuous As Boolean
    Get
    Set
Visual C++
public:
property bool IsContinuous {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.LabelsHorizontalGapLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..LabelsHorizontalGapLength Property
LabelDocument Class See Also Send Feedback
Gets or sets the horizontal gap length between labels when the media roll contains more than one label per row. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double LabelsHorizontalGapLength { get; set; }
Visual Basic
Public Property LabelsHorizontalGapLength As Double
    Get
    Set
Visual C++
public:
property double LabelsHorizontalGapLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.LabelsPerRow Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..LabelsPerRow Property
LabelDocument Class See Also Send Feedback
Gets or sets the number of labels per row in the media roll. Default value is 1

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public int LabelsPerRow { get; set; }
Visual Basic
Public Property LabelsPerRow As Integer
    Get
    Set
Visual C++
public:
property int LabelsPerRow {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.MarkLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..MarkLength Property
LabelDocument Class See Also Send Feedback
Gets or sets the mark length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double MarkLength { get; set; }
Visual Basic
Public Property MarkLength As Double
    Get
    Set
Visual C++
public:
property double MarkLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.NumOfFractionalDigits Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..NumOfFractionalDigits Property
LabelDocument Class See Also Send Feedback
Gets or sets the number of fractional digits to use with all floating-point values. Default is 4.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public int NumOfFractionalDigits { get; set; }
Visual Basic
Public Property NumOfFractionalDigits As Integer
    Get
    Set
Visual C++
public:
property int NumOfFractionalDigits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Remarks

The number of fractional digits is used to round floating-point values like item's X and Y location, Width and Height, etc.

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.OffsetLength Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..OffsetLength Property
LabelDocument Class See Also Send Feedback
Gets or sets the offset length or thickness between labels. The unit of measurement is specified by UnitType property. Default value is 0 (zero)

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double OffsetLength { get; set; }
Visual Basic
Public Property OffsetLength As Double
    Get
    Set
Visual C++
public:
property double OffsetLength {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.UnitType Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..UnitType Property
LabelDocument Class See Also Send Feedback
Gets or sets the Unit of Measurement for the label document.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public UnitType UnitType { get; set; }
Visual Basic
Public Property UnitType As UnitType
    Get
    Set
Visual C++
public:
property UnitType UnitType {
    UnitType get ();
    void set (UnitType value);
}

Property Value

Type: UnitType

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


LabelDocument.Width Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
LabelDocument..::..Width Property
LabelDocument Class See Also Send Feedback
Gets or sets the width of the label document.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double Width { get; set; }
Visual Basic
Public Property Width As Double
    Get
    Set
Visual C++
public:
property double Width {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

LabelDocument Class
LabelDocument Members
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils Class
Members See Also Send Feedback
Provides some utilities related to Unit of Measurement.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class UnitUtils
Visual Basic
Public Class UnitUtils
Visual C++
public ref class UnitUtils

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.ThermalLabelEditor..::..UnitUtils

See Also

UnitUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils Members
UnitUtils Class Constructors Methods See Also Send Feedback

The UnitUtils type exposes the following members.

Constructors

 | Name | Description
Public method | UnitUtils |

Methods

Name | Description
Convert(FontUnit, Double, FontUnit, Int32) | Converts a font unit value to another font unit.
Convert(UnitType, Double, UnitType, Int32) | Converts a unit value to another unit.

See Also

UnitUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils Constructor
UnitUtils Class See Also Send Feedback

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public UnitUtils()
Visual Basic
Public Sub New
Visual C++
public:
UnitUtils()

See Also

UnitUtils Class
UnitUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils Methods
UnitUtils Class See Also Send Feedback

Methods

Name | Description
Convert(FontUnit, Double, FontUnit, Int32) | Converts a font unit value to another font unit.
Convert(UnitType, Double, UnitType, Int32) | Converts a unit value to another unit.

See Also

UnitUtils Class
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils.Convert Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils..::..Convert Method
UnitUtils Class See Also Send Feedback

Overload List

Name | Description
Convert(FontUnit, Double, FontUnit, Int32) | Converts a font unit value to another font unit.
Convert(UnitType, Double, UnitType, Int32) | Converts a unit value to another unit.

See Also

UnitUtils Class
UnitUtils Members
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils.Convert Method (FontUnit, Double, FontUnit, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils..::..Convert Method (FontUnit, Double, FontUnit, Int32)
UnitUtils Class See Also Send Feedback
Converts a font unit value to another font unit.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static double Convert(
    FontUnit fromUnit,
    double value,
    FontUnit toUnit,
    int numOfFractionalDigits
)
Visual Basic
Public Shared Function Convert (
    fromUnit As FontUnit,
    value As Double,
    toUnit As FontUnit,
    numOfFractionalDigits As Integer
) As Double
Visual C++
public:
static double Convert(
    FontUnit fromUnit,
    double value,
    FontUnit toUnit,
    int numOfFractionalDigits
)

Parameters

fromUnit
Type: Neodynamic.SDK.Printing..::..FontUnit
The font unit to convert from.
value
Type: System..::..Double
The value to convert to the new font unit.
toUnit
Type: Neodynamic.SDK.Printing..::..FontUnit
The new font unit which the specified value and unit will be converted to.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits for the conversion result.

Return Value

Type: Double
Returns the new value after converting the specified value and font unit to the new font unit.

See Also

UnitUtils Class
UnitUtils Members
Convert Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


UnitUtils.Convert Method (UnitType, Double, UnitType, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
UnitUtils..::..Convert Method (UnitType, Double, UnitType, Int32)
UnitUtils Class See Also Send Feedback
Converts a unit value to another unit.

Namespace: Neodynamic.Windows.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static double Convert(
    UnitType fromUnit,
    double value,
    UnitType toUnit,
    int numOfFractionalDigits
)
Visual Basic
Public Shared Function Convert (
    fromUnit As UnitType,
    value As Double,
    toUnit As UnitType,
    numOfFractionalDigits As Integer
) As Double
Visual C++
public:
static double Convert(
    UnitType fromUnit,
    double value,
    UnitType toUnit,
    int numOfFractionalDigits
)

Parameters

fromUnit
Type: Neodynamic.SDK.Printing..::..UnitType
The unit to convert from.
value
Type: System..::..Double
The value to convert to the new unit.
toUnit
Type: Neodynamic.SDK.Printing..::..UnitType
The new unit which the specified value and unit will be converted to.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits for the conversion result.

Return Value

Type: Double
Returns the new value after converting the specified value and unit to the new unit.

See Also

UnitUtils Class
UnitUtils Members
Convert Overload
Neodynamic.Windows.ThermalLabelEditor Namespace


Neodynamic.Windows.WPF.ThermalLabelEditor Namespace

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace
Send Feedback

Classes

 | Class | Description
Public class | EditorCommands | Provides a set of commands related to the ThermalLabelEditor component.
Public class | ThermalLabelEditor | ThermalLabelEditor lets end-users to graphically design barcode thermal labels inside your WPF Windows applications.


EditorCommands Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands Class
Members See Also Send Feedback
Provides a set of commands related to the ThermalLabelEditor component.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static class EditorCommands
Visual Basic
Public NotInheritable Class EditorCommands
Visual C++
public ref class EditorCommands abstract sealed

Inheritance Hierarchy

System..::..Object
Neodynamic.Windows.WPF.ThermalLabelEditor..::..EditorCommands

See Also

EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands Members
EditorCommands Class Properties See Also Send Feedback

The EditorCommands type exposes the following members.

Properties

Name | Description
BringForward | Gets the value that represents the BringForward command.
BringToFront | Gets the value that represents the BringToFront command.
Copy | Gets the value that represents the Copy command.
Cut | Gets the value that represents the Cut command.
DeleteAll | Gets the value that represents the DeleteAll command.
DeleteSelectedItems | Gets the value that represents the DeleteSelectedItems command.
Load | Gets the value that represents the Load command.
LockSelectedItems | Gets the value that represents the LockSelectedItems command.
Paste | Gets the value that represents the Paste command.
Redo | Gets the value that represents the Redo command.
Save | Gets the value that represents the Save command.
SelectAll | Gets the value that represents the SelectAll command.
SelectItemByName | Gets the value that represents the SelectItemByName command.
SelectItemsByNames | Gets the value that represents the SelectItemsByNames command.
SendBackward | Gets the value that represents the SendBackward command.
SendToBack | Gets the value that represents the SendToBack command.
Undo | Gets the value that represents the Undo command.
UnlockSelectedItems | Gets the value that represents the UnlockSelectedItems command.
UpdateLabelDocument | Gets the value that represents the UpdateLabelDocument command.
UpdateSelectionItemsProperties | Gets the value that represents the UpdateSelectionItemsProperties command.

See Also

EditorCommands Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands Properties
EditorCommands Class See Also Send Feedback

The EditorCommands type exposes the following members.

Properties

Name | Description
BringForward | Gets the value that represents the BringForward command.
BringToFront | Gets the value that represents the BringToFront command.
Copy | Gets the value that represents the Copy command.
Cut | Gets the value that represents the Cut command.
DeleteAll | Gets the value that represents the DeleteAll command.
DeleteSelectedItems | Gets the value that represents the DeleteSelectedItems command.
Load | Gets the value that represents the Load command.
LockSelectedItems | Gets the value that represents the LockSelectedItems command.
Paste | Gets the value that represents the Paste command.
Redo | Gets the value that represents the Redo command.
Save | Gets the value that represents the Save command.
SelectAll | Gets the value that represents the SelectAll command.
SelectItemByName | Gets the value that represents the SelectItemByName command.
SelectItemsByNames | Gets the value that represents the SelectItemsByNames command.
SendBackward | Gets the value that represents the SendBackward command.
SendToBack | Gets the value that represents the SendToBack command.
Undo | Gets the value that represents the Undo command.
UnlockSelectedItems | Gets the value that represents the UnlockSelectedItems command.
UpdateLabelDocument | Gets the value that represents the UpdateLabelDocument command.
UpdateSelectionItemsProperties | Gets the value that represents the UpdateSelectionItemsProperties command.

See Also

EditorCommands Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.BringForward Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..BringForward Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the BringForward command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand BringForward { get; }
Visual Basic
Public Shared ReadOnly Property BringForward As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ BringForward {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.BringToFront Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..BringToFront Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the BringToFront command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand BringToFront { get; }
Visual Basic
Public Shared ReadOnly Property BringToFront As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ BringToFront {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Copy Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Copy Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Copy command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Copy { get; }
Visual Basic
Public Shared ReadOnly Property Copy As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Copy {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Cut Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Cut Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Cut command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Cut { get; }
Visual Basic
Public Shared ReadOnly Property Cut As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Cut {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.DeleteAll Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..DeleteAll Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the DeleteAll command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand DeleteAll { get; }
Visual Basic
Public Shared ReadOnly Property DeleteAll As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ DeleteAll {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.DeleteSelectedItems Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..DeleteSelectedItems Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the DeleteSelectedItems command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand DeleteSelectedItems { get; }
Visual Basic
Public Shared ReadOnly Property DeleteSelectedItems As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ DeleteSelectedItems {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Load Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Load Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Load command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Load { get; }
Visual Basic
Public Shared ReadOnly Property Load As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Load {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

Remarks

The Load command requires a parameter which type must be string or Neodynamic.SDK.Printing.ThermalLabel. If it is a string type parameter, then it should be string containing an XML ThermalLabel template.

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.LockSelectedItems Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..LockSelectedItems Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the LockSelectedItems command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand LockSelectedItems { get; }
Visual Basic
Public Shared ReadOnly Property LockSelectedItems As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ LockSelectedItems {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Paste Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Paste Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Paste command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Paste { get; }
Visual Basic
Public Shared ReadOnly Property Paste As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Paste {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Redo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Redo Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Redo command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Redo { get; }
Visual Basic
Public Shared ReadOnly Property Redo As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Redo {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Save Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Save Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Save command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Save { get; }
Visual Basic
Public Shared ReadOnly Property Save As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Save {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

Remarks

The Save command requires a parameter which type must be string or System.IO.Stream in order to store the generated ThermalLabel object. If it is a string type parameter, then it should be a file path to be used for saving the ThermalLabel object.

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.SelectAll Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..SelectAll Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the SelectAll command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand SelectAll { get; }
Visual Basic
Public Shared ReadOnly Property SelectAll As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ SelectAll {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.SelectItemByName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..SelectItemByName Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the SelectItemByName command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand SelectItemByName { get; }
Visual Basic
Public Shared ReadOnly Property SelectItemByName As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ SelectItemByName {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.SelectItemsByNames Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..SelectItemsByNames Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the SelectItemsByNames command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand SelectItemsByNames { get; }
Visual Basic
Public Shared ReadOnly Property SelectItemsByNames As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ SelectItemsByNames {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.SendBackward Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..SendBackward Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the SendBackward command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand SendBackward { get; }
Visual Basic
Public Shared ReadOnly Property SendBackward As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ SendBackward {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.SendToBack Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..SendToBack Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the SendToBack command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand SendToBack { get; }
Visual Basic
Public Shared ReadOnly Property SendToBack As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ SendToBack {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.Undo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..Undo Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the Undo command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand Undo { get; }
Visual Basic
Public Shared ReadOnly Property Undo As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ Undo {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.UnlockSelectedItems Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..UnlockSelectedItems Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the UnlockSelectedItems command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand UnlockSelectedItems { get; }
Visual Basic
Public Shared ReadOnly Property UnlockSelectedItems As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ UnlockSelectedItems {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.UpdateLabelDocument Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..UpdateLabelDocument Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the UpdateLabelDocument command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand UpdateLabelDocument { get; }
Visual Basic
Public Shared ReadOnly Property UpdateLabelDocument As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ UpdateLabelDocument {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

Remarks

The UpdateLabelDocument command requires a parameter which type must be Neodynamic.Windows.ThermalLabelEditor.LabelDocument.

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


EditorCommands.UpdateSelectionItemsProperties Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
EditorCommands..::..UpdateSelectionItemsProperties Property
EditorCommands Class See Also Send Feedback
Gets the value that represents the UpdateSelectionItemsProperties command.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static RoutedCommand UpdateSelectionItemsProperties { get; }
Visual Basic
Public Shared ReadOnly Property UpdateSelectionItemsProperties As RoutedCommand
    Get
Visual C++
public:
static property RoutedCommand^ UpdateSelectionItemsProperties {
    RoutedCommand^ get ();
}

Property Value

Type: RoutedCommand

See Also

EditorCommands Class
EditorCommands Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Class

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Class
Members See Also Send Feedback
ThermalLabelEditor lets end-users to graphically design barcode thermal labels inside your WPF Windows applications.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public class ThermalLabelEditor : Grid
Visual Basic
Public Class ThermalLabelEditor
    Inherits Grid
Visual C++
public ref class ThermalLabelEditor : public Grid

Inheritance Hierarchy

System..::..Object
System.Windows.Threading..::..DispatcherObject
System.Windows..::..DependencyObject
System.Windows.Media..::..Visual
System.Windows..::..UIElement
System.Windows..::..FrameworkElement
System.Windows.Controls..::..Panel
System.Windows.Controls..::..Grid
Neodynamic.Windows.WPF.ThermalLabelEditor..::..ThermalLabelEditor

See Also

ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Members

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Members
ThermalLabelEditor Class Constructors Methods Fields Properties Events See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Constructors

 | Name | Description
Public method | ThermalLabelEditor |

Methods

 | Name | Description
Public method | BringForward | Brings the selected items one step closer to the front of the label surface.
Public method | BringToFront | Brings the selected items to the front of the label surface.
Public method | Close | Closes the current label document.
Public method | Copy | Copies the current selection in the editor to the internal Clipboard.
Public method | CreateThermalLabel | Creates a ThermalLabel object based on the current LabelDocument data and visual items.
Public method | Cut | Cuts the current selection in the editor and moves it to the internal Clipboard.
Public method | DeleteAll | Deletes all the items on the editor's surface.
Public method | DeleteSelectedItems | Deletes the selected items on the editor's surface.
Public method | LoadThermalLabel | Loads the specified ThermalLabel object on the editor's surface.
Public method | LockSelectedItems | Locks all the items in the current selection.
Public method | MoveSelectedItems | Moves the selected items by the specified horizontal and vertical offsets.
Public method | Paste | Pates the content of the internal Clipborad on the editor surface.
Public method | Redo | Performs a Redo action.
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.
Public method | SelectAll | Selects all the items on the editor's surface.
Public method | SelectItemByName | Selects an item by its name on the editor's surface.
Public method | SelectItemsByNames | Selects a set of items by their names on the editor's surface.
Public method | SendBackward | Sends the selected items one step toward the background of the label surface.
Public method | SendToBack | Sends the selected items to the background of the label surface.
Public method | Undo | Performs an Undo action.
Public method | UnlockSelectedItems | Unlocks all the items in the current selection.
Public method | UnselectAll | Unselects all the selected items on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateSelectionItemsProperties | Updates the properties of the selected items on the editor's surface.

Fields

Name | Description
ActiveToolItemProperty |
ActiveToolProperty |
AdornerFrameBorderColorProperty |
AdornerHandlerBackColorProperty |
AdornerHandlerBorderColorProperty |
AdornerHandlerHoverBackColorProperty |
AdornerSelectionBackColorProperty |
AdornerSelectionBorderColorProperty |
AngleSnapProperty |
ArrowKeysLargeStepProperty |
ArrowKeysShortStepProperty |
CanCopyProperty |
CanCutProperty |
CanPasteProperty |
CanRedoProperty |
CanUndoProperty |
CurrentSelectionAreaProperty |
CurrentSelectionProperty |
GridSizeProperty |
ImageProcessingDpiProperty |
LabelDocumentFrameBackgroundProperty |
LabelDocumentFrameBorderColorProperty |
LabelDocumentFrameBorderThicknessProperty |
LabelDocumentFrameCornerRadiusProperty |
LabelDocumentProperty |
NoImageFileNameProperty |
RFIDTagImageFileNameProperty |
RulerBackgroundProperty |
RulerForeColorProperty |
RulerLinesColorProperty |
RulerSelectionColorProperty |
ShowGridProperty |
SnapToGridProperty |
TextItemEditModeEnabledProperty |
ZoomProperty |

Properties

 | Name | Description
Public property | ActiveTool | Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.
Public property | ActiveToolItem | Gets or sets the Item object which is added to the editor's surface by the end-user.
Public property | AdornerFrameBorderColor | Gets or sets the border color for the adorner's frame. Default is Black.
Public property | AdornerHandlerBackColor | Gets or sets the background color for the adorner's handlers. Default is Green.
Public property | AdornerHandlerBorderColor | Gets or sets the border color for the adorner's handlers. Default is Black.
Public property | AdornerHandlerHoverBackColor | Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.
Public property | AdornerSelectionBackColor | Gets or sets the background color for the selection adorner's frame.
Public property | AdornerSelectionBorderColor | Gets or sets the border color for the selection adorner's frame.
Public property | AngleSnap | Gets or sets the angle snap used for items' rotation. Default is 5 degrees.
Public property | ArrowKeysLargeStep | Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.
Public property | ArrowKeysShortStep | Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.
Public property | CanCopy | Gets whether a Clipboard Copy action can be performed.
Public property | CanCut | Gets whether a Clipboard Cut action can be performed.
Public property | CanPaste | Gets whether a Clipboard Paste action can be performed.
Public property | CanRedo | Gets whether the Redo action is available.
Public property | CanUndo | Gets whether the Undo action is available.
Public property | CurrentSelection | Gets the current selected item on the editor.
Public property | CurrentSelectionArea | Gets the location and size of the current selected items on the editor.
Public property | GridSize | Gets or sets the size of the grid in current unit. Default is zero.
Public property | ImageProcessingDpi | Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.
Public property | LabelDocument | Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.
Public property | LabelDocumentFrameBackground | Gets or sets the background brush for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderColor | Gets or sets the border color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderThickness | Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.
Public property | LabelDocumentFrameCornerRadius | Gets or sets the radii of the corners of the label document frame. Default value is 10.
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | NoImageFileName | Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.
Public property | RFIDTagImageFileName | Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.
Public property | RulerBackground | Gets or sets the background brush for the editor's rulers. Default is SystemColors.ControlBrush
Public property | RulerForeColor | Gets or sets the foreground color for the number tags of the editor's rulers.
Public property | RulerLinesColor | Gets or sets the color for the lines which compose the editor's rulers.
Public property | RulerSelectionColor | Gets or sets the background color for the selection zone of the editor's rulers.
Public property | ShowGrid | Gets or sets whether grid is displayed. Default is false.
Public property | SnapToGrid | Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.
Public property | TextItemEditModeEnabled | Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.
Public property | Zoom | Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

Events

 | Name | Description
Public event | ClipboardStateChanged | Occurs when the state of the internal Clipboard changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two times on the editor's canvas.
Public event | NewItemCreated | Occurs when a new item is created on the editor's surface.
Public event | SelectionAreaChanged | Occurs when the editor's selection area changes.
Public event | SelectionChanged | Occurs when the editor's selection changes.
Public event | SelectionItemPropertyChanged | Occurs when any property of the selected item changes.
Public event | UndoStateChanged | Occurs when the undo state of the editor changes.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Constructor

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Constructor
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public ThermalLabelEditor()
Visual Basic
Public Sub New
Visual C++
public:
ThermalLabelEditor()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Fields

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Fields
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Fields

Name | Description
ActiveToolItemProperty |
ActiveToolProperty |
AdornerFrameBorderColorProperty |
AdornerHandlerBackColorProperty |
AdornerHandlerBorderColorProperty |
AdornerHandlerHoverBackColorProperty |
AdornerSelectionBackColorProperty |
AdornerSelectionBorderColorProperty |
AngleSnapProperty |
ArrowKeysLargeStepProperty |
ArrowKeysShortStepProperty |
CanCopyProperty |
CanCutProperty |
CanPasteProperty |
CanRedoProperty |
CanUndoProperty |
CurrentSelectionAreaProperty |
CurrentSelectionProperty |
GridSizeProperty |
ImageProcessingDpiProperty |
LabelDocumentFrameBackgroundProperty |
LabelDocumentFrameBorderColorProperty |
LabelDocumentFrameBorderThicknessProperty |
LabelDocumentFrameCornerRadiusProperty |
LabelDocumentProperty |
NoImageFileNameProperty |
RFIDTagImageFileNameProperty |
RulerBackgroundProperty |
RulerForeColorProperty |
RulerLinesColorProperty |
RulerSelectionColorProperty |
ShowGridProperty |
SnapToGridProperty |
TextItemEditModeEnabledProperty |
ZoomProperty |

See Also

ThermalLabelEditor Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveToolItemProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveToolItemProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ActiveToolItemProperty
Visual Basic
Public Shared ActiveToolItemProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ActiveToolItemProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveToolProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveToolProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ActiveToolProperty
Visual Basic
Public Shared ActiveToolProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ActiveToolProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerFrameBorderColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerFrameBorderColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerFrameBorderColorProperty
Visual Basic
Public Shared AdornerFrameBorderColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerFrameBorderColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBackColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBackColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerHandlerBackColorProperty
Visual Basic
Public Shared AdornerHandlerBackColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerHandlerBackColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBorderColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBorderColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerHandlerBorderColorProperty
Visual Basic
Public Shared AdornerHandlerBorderColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerHandlerBorderColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerHoverBackColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerHoverBackColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerHandlerHoverBackColorProperty
Visual Basic
Public Shared AdornerHandlerHoverBackColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerHandlerHoverBackColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBackColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBackColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerSelectionBackColorProperty
Visual Basic
Public Shared AdornerSelectionBackColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerSelectionBackColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBorderColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBorderColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AdornerSelectionBorderColorProperty
Visual Basic
Public Shared AdornerSelectionBorderColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AdornerSelectionBorderColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AngleSnapProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AngleSnapProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty AngleSnapProperty
Visual Basic
Public Shared AngleSnapProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ AngleSnapProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysLargeStepProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysLargeStepProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ArrowKeysLargeStepProperty
Visual Basic
Public Shared ArrowKeysLargeStepProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ArrowKeysLargeStepProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysShortStepProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysShortStepProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ArrowKeysShortStepProperty
Visual Basic
Public Shared ArrowKeysShortStepProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ArrowKeysShortStepProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCopyProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCopyProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CanCopyProperty
Visual Basic
Public Shared ReadOnly CanCopyProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CanCopyProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCutProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCutProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CanCutProperty
Visual Basic
Public Shared ReadOnly CanCutProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CanCutProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanPasteProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanPasteProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CanPasteProperty
Visual Basic
Public Shared ReadOnly CanPasteProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CanPasteProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanRedoProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanRedoProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CanRedoProperty
Visual Basic
Public Shared ReadOnly CanRedoProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CanRedoProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanUndoProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanUndoProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CanUndoProperty
Visual Basic
Public Shared ReadOnly CanUndoProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CanUndoProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelectionAreaProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelectionAreaProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CurrentSelectionAreaProperty
Visual Basic
Public Shared ReadOnly CurrentSelectionAreaProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CurrentSelectionAreaProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelectionProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelectionProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty CurrentSelectionProperty
Visual Basic
Public Shared ReadOnly CurrentSelectionProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ CurrentSelectionProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.GridSizeProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..GridSizeProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty GridSizeProperty
Visual Basic
Public Shared GridSizeProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ GridSizeProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ImageProcessingDpiProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ImageProcessingDpiProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ImageProcessingDpiProperty
Visual Basic
Public Shared ImageProcessingDpiProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ImageProcessingDpiProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBackgroundProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBackgroundProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty LabelDocumentFrameBackgroundProperty
Visual Basic
Public Shared LabelDocumentFrameBackgroundProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ LabelDocumentFrameBackgroundProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty LabelDocumentFrameBorderColorProperty
Visual Basic
Public Shared LabelDocumentFrameBorderColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ LabelDocumentFrameBorderColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderThicknessProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderThicknessProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty LabelDocumentFrameBorderThicknessProperty
Visual Basic
Public Shared LabelDocumentFrameBorderThicknessProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ LabelDocumentFrameBorderThicknessProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameCornerRadiusProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameCornerRadiusProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty LabelDocumentFrameCornerRadiusProperty
Visual Basic
Public Shared LabelDocumentFrameCornerRadiusProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ LabelDocumentFrameCornerRadiusProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static readonly DependencyProperty LabelDocumentProperty
Visual Basic
Public Shared ReadOnly LabelDocumentProperty As DependencyProperty
Visual C++
public:
static initonly DependencyProperty^ LabelDocumentProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.NoImageFileNameProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..NoImageFileNameProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty NoImageFileNameProperty
Visual Basic
Public Shared NoImageFileNameProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ NoImageFileNameProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RFIDTagImageFileNameProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RFIDTagImageFileNameProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty RFIDTagImageFileNameProperty
Visual Basic
Public Shared RFIDTagImageFileNameProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ RFIDTagImageFileNameProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerBackgroundProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerBackgroundProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty RulerBackgroundProperty
Visual Basic
Public Shared RulerBackgroundProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ RulerBackgroundProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerForeColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerForeColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty RulerForeColorProperty
Visual Basic
Public Shared RulerForeColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ RulerForeColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerLinesColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerLinesColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty RulerLinesColorProperty
Visual Basic
Public Shared RulerLinesColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ RulerLinesColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerSelectionColorProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerSelectionColorProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty RulerSelectionColorProperty
Visual Basic
Public Shared RulerSelectionColorProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ RulerSelectionColorProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ShowGridProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ShowGridProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ShowGridProperty
Visual Basic
Public Shared ShowGridProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ShowGridProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SnapToGridProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SnapToGridProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty SnapToGridProperty
Visual Basic
Public Shared SnapToGridProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ SnapToGridProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.TextItemEditModeEnabledProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..TextItemEditModeEnabledProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty TextItemEditModeEnabledProperty
Visual Basic
Public Shared TextItemEditModeEnabledProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ TextItemEditModeEnabledProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ZoomProperty Field

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ZoomProperty Field
ThermalLabelEditor Class See Also Send Feedback

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static DependencyProperty ZoomProperty
Visual Basic
Public Shared ZoomProperty As DependencyProperty
Visual C++
public:
static DependencyProperty^ ZoomProperty

Field Value

Type: DependencyProperty

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Methods

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Methods
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Methods

 | Name | Description
Public method | BringForward | Brings the selected items one step closer to the front of the label surface.
Public method | BringToFront | Brings the selected items to the front of the label surface.
Public method | Close | Closes the current label document.
Public method | Copy | Copies the current selection in the editor to the internal Clipboard.
Public method | CreateThermalLabel | Creates a ThermalLabel object based on the current LabelDocument data and visual items.
Public method | Cut | Cuts the current selection in the editor and moves it to the internal Clipboard.
Public method | DeleteAll | Deletes all the items on the editor's surface.
Public method | DeleteSelectedItems | Deletes the selected items on the editor's surface.
Public method | LoadThermalLabel | Loads the specified ThermalLabel object on the editor's surface.
Public method | LockSelectedItems | Locks all the items in the current selection.
Public method | MoveSelectedItems | Moves the selected items by the specified horizontal and vertical offsets.
Public method | Paste | Pates the content of the internal Clipborad on the editor surface.
Public method | Redo | Performs a Redo action.
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.
Public method | SelectAll | Selects all the items on the editor's surface.
Public method | SelectItemByName | Selects an item by its name on the editor's surface.
Public method | SelectItemsByNames | Selects a set of items by their names on the editor's surface.
Public method | SendBackward | Sends the selected items one step toward the background of the label surface.
Public method | SendToBack | Sends the selected items to the background of the label surface.
Public method | Undo | Performs an Undo action.
Public method | UnlockSelectedItems | Unlocks all the items in the current selection.
Public method | UnselectAll | Unselects all the selected items on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateSelectionItemsProperties | Updates the properties of the selected items on the editor's surface.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.BringForward Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..BringForward Method
ThermalLabelEditor Class See Also Send Feedback
Brings the selected items one step closer to the front of the label surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void BringForward()
Visual Basic
Public Sub BringForward
Visual C++
public:
void BringForward()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.BringToFront Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..BringToFront Method
ThermalLabelEditor Class See Also Send Feedback
Brings the selected items to the front of the label surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void BringToFront()
Visual Basic
Public Sub BringToFront
Visual C++
public:
void BringToFront()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Close Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Close Method
ThermalLabelEditor Class See Also Send Feedback
Closes the current label document.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Close()
Visual Basic
Public Sub Close
Visual C++
public:
void Close()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Copy Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Copy Method
ThermalLabelEditor Class See Also Send Feedback
Copies the current selection in the editor to the internal Clipboard.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Copy()
Visual Basic
Public Sub Copy
Visual C++
public:
void Copy()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CreateThermalLabel Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CreateThermalLabel Method
ThermalLabelEditor Class See Also Send Feedback
Creates a ThermalLabel object based on the current LabelDocument data and visual items.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public ThermalLabel CreateThermalLabel()
Visual Basic
Public Function CreateThermalLabel As ThermalLabel
Visual C++
public:
ThermalLabel^ CreateThermalLabel()

Return Value

Type: ThermalLabel
A ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Cut Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Cut Method
ThermalLabelEditor Class See Also Send Feedback
Cuts the current selection in the editor and moves it to the internal Clipboard.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Cut()
Visual Basic
Public Sub Cut
Visual C++
public:
void Cut()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.DeleteAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..DeleteAll Method
ThermalLabelEditor Class See Also Send Feedback
Deletes all the items on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void DeleteAll()
Visual Basic
Public Sub DeleteAll
Visual C++
public:
void DeleteAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.DeleteSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..DeleteSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Deletes the selected items on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void DeleteSelectedItems()
Visual Basic
Public Sub DeleteSelectedItems
Visual C++
public:
void DeleteSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LoadThermalLabel Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LoadThermalLabel Method
ThermalLabelEditor Class See Also Send Feedback
Loads the specified ThermalLabel object on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void LoadThermalLabel(
    ThermalLabel thermalLabel
)
Visual Basic
Public Sub LoadThermalLabel (
    thermalLabel As ThermalLabel
)
Visual C++
public:
void LoadThermalLabel(
    ThermalLabel^ thermalLabel
)

Parameters

thermalLabel
Type: Neodynamic.SDK.Printing..::..ThermalLabel
A ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LockSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LockSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Locks all the items in the current selection.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void LockSelectedItems()
Visual Basic
Public Sub LockSelectedItems
Visual C++
public:
void LockSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.MoveSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..MoveSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Moves the selected items by the specified horizontal and vertical offsets.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void MoveSelectedItems(
    double deltaX,
    double deltaY
)
Visual Basic
Public Sub MoveSelectedItems (
    deltaX As Double,
    deltaY As Double
)
Visual C++
public:
void MoveSelectedItems(
    double deltaX,
    double deltaY
)

Parameters

deltaX
Type: System..::..Double
The horizontal (X-axis) offset.
deltaY
Type: System..::..Double
The vertical (Y-axis) offset.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Paste Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Paste Method
ThermalLabelEditor Class See Also Send Feedback
Pates the content of the internal Clipborad on the editor surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Paste()
Visual Basic
Public Sub Paste
Visual C++
public:
void Paste()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Redo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Redo Method
ThermalLabelEditor Class See Also Send Feedback
Performs a Redo action.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Redo()
Visual Basic
Public Sub Redo
Visual C++
public:
void Redo()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method
ThermalLabelEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Save(Stream) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.
Public method | Save(String) | Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method (Stream)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method (Stream)
ThermalLabelEditor Class See Also Send Feedback
Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified stream.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Save(
    Stream stream
)
Visual Basic
Public Sub Save (
    stream As Stream
)
Visual C++
public:
void Save(
    Stream^ stream
)

Parameters

stream
Type: System.IO..::..Stream
The stream where the ThermalLabel object will be saved.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Save Overload
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Save Method (String)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Save Method (String)
ThermalLabelEditor Class See Also Send Feedback
Saves the ThermalLabel object based on the current LabelDocument data and visual items to the specified file name.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Save(
    string fileName
)
Visual Basic
Public Sub Save (
    fileName As String
)
Visual C++
public:
void Save(
    String^ fileName
)

Parameters

fileName
Type: System..::..String
A string that contains the name of the file (full path) to which to save the ThermalLabel object.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Save Overload
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectAll Method
ThermalLabelEditor Class See Also Send Feedback
Selects all the items on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectAll()
Visual Basic
Public Sub SelectAll
Visual C++
public:
void SelectAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectItemByName Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectItemByName Method
ThermalLabelEditor Class See Also Send Feedback
Selects an item by its name on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectItemByName(
    string itemName
)
Visual Basic
Public Sub SelectItemByName (
    itemName As String
)
Visual C++
public:
void SelectItemByName(
    String^ itemName
)

Parameters

itemName
Type: System..::..String
The name of the item to be selected.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectItemsByNames Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectItemsByNames Method
ThermalLabelEditor Class See Also Send Feedback
Selects a set of items by their names on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SelectItemsByNames(
    string[] itemNames
)
Visual Basic
Public Sub SelectItemsByNames (
    itemNames As String()
)
Visual C++
public:
void SelectItemsByNames(
    array<String^>^ itemNames
)

Parameters

itemNames
Type: array< System..::..String >[]()[][]

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SendBackward Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SendBackward Method
ThermalLabelEditor Class See Also Send Feedback
Sends the selected items one step toward the background of the label surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SendBackward()
Visual Basic
Public Sub SendBackward
Visual C++
public:
void SendBackward()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SendToBack Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SendToBack Method
ThermalLabelEditor Class See Also Send Feedback
Sends the selected items to the background of the label surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void SendToBack()
Visual Basic
Public Sub SendToBack
Visual C++
public:
void SendToBack()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Undo Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Undo Method
ThermalLabelEditor Class See Also Send Feedback
Performs an Undo action.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void Undo()
Visual Basic
Public Sub Undo
Visual C++
public:
void Undo()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UnlockSelectedItems Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UnlockSelectedItems Method
ThermalLabelEditor Class See Also Send Feedback
Unlocks all the items in the current selection.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UnlockSelectedItems()
Visual Basic
Public Sub UnlockSelectedItems
Visual C++
public:
void UnlockSelectedItems()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UnselectAll Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UnselectAll Method
ThermalLabelEditor Class See Also Send Feedback
Unselects all the selected items on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UnselectAll()
Visual Basic
Public Sub UnselectAll
Visual C++
public:
void UnselectAll()

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method
ThermalLabelEditor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32) | Updates the LabelDocument object on the editor's surface.
Public method | UpdateLabelDocument(UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean) | Updates the LabelDocument object on the editor's surface.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method (UnitType, Double, Double, Int32)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method (UnitType, Double, Double, Int32)
ThermalLabelEditor Class See Also Send Feedback
Updates the LabelDocument object on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits
)
Visual Basic
Public Sub UpdateLabelDocument (
    unit As UnitType,
    width As Double,
    height As Double,
    numOfFractionalDigits As Integer
)
Visual C++
public:
void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType
The Unit of Measurement for the label document.
width
Type: System..::..Double
The width of the label document.
height
Type: System..::..Double
The height of the label document.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits to use with all floating-point values related to the label document.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
UpdateLabelDocument Overload
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateLabelDocument Method (UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean)

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateLabelDocument Method (UnitType, Double, Double, Int32, Double, Double, Double, Int32, Double, Boolean)
ThermalLabelEditor Class See Also Send Feedback
Updates the LabelDocument object on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits,
    double gapLength,
    double markLength,
    double offsetLength,
    int labelsPerRow,
    double labelsHorizontalGapLength,
    bool isContinuous
)
Visual Basic
Public Sub UpdateLabelDocument (
    unit As UnitType,
    width As Double,
    height As Double,
    numOfFractionalDigits As Integer,
    gapLength As Double,
    markLength As Double,
    offsetLength As Double,
    labelsPerRow As Integer,
    labelsHorizontalGapLength As Double,
    isContinuous As Boolean
)
Visual C++
public:
void UpdateLabelDocument(
    UnitType unit,
    double width,
    double height,
    int numOfFractionalDigits,
    double gapLength,
    double markLength,
    double offsetLength,
    int labelsPerRow,
    double labelsHorizontalGapLength,
    bool isContinuous
)

Parameters

unit
Type: Neodynamic.SDK.Printing..::..UnitType
The Unit of Measurement for the label document.
width
Type: System..::..Double
The width of the label document.
height
Type: System..::..Double
The height of the label document.
numOfFractionalDigits
Type: System..::..Int32
The number of fractional digits to use with all floating-point values related to the label document.
gapLength
Type: System..::..Double
The vertical gap length between labels.
markLength
Type: System..::..Double
The mark length or thickness between labels.
offsetLength
Type: System..::..Double
The offset length or thickness between labels.
labelsPerRow
Type: System..::..Int32
The number of labels per row in the media roll.
labelsHorizontalGapLength
Type: System..::..Double
The horizontal gap length between labels when the media roll contains more than one label per row.
isContinuous
Type: System..::..Boolean
Whether this document is on a continuous media roll i.e. labels are not separated by gaps, spaces, notches, slots, or holes.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
UpdateLabelDocument Overload
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UpdateSelectionItemsProperties Method

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UpdateSelectionItemsProperties Method
ThermalLabelEditor Class See Also Send Feedback
Updates the properties of the selected items on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public void UpdateSelectionItemsProperties()
Visual Basic
Public Sub UpdateSelectionItemsProperties
Visual C++
public:
void UpdateSelectionItemsProperties()

Remarks

When you present the selected items' properties to the end-user through some UI like a PropertyGrid control, a dialog box, etc. and the user modifies them, you must call this method so the changes are reflected on the selected items on the editor's surface.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Properties

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Properties
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Properties

 | Name | Description
Public property | ActiveTool | Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.
Public property | ActiveToolItem | Gets or sets the Item object which is added to the editor's surface by the end-user.
Public property | AdornerFrameBorderColor | Gets or sets the border color for the adorner's frame. Default is Black.
Public property | AdornerHandlerBackColor | Gets or sets the background color for the adorner's handlers. Default is Green.
Public property | AdornerHandlerBorderColor | Gets or sets the border color for the adorner's handlers. Default is Black.
Public property | AdornerHandlerHoverBackColor | Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.
Public property | AdornerSelectionBackColor | Gets or sets the background color for the selection adorner's frame.
Public property | AdornerSelectionBorderColor | Gets or sets the border color for the selection adorner's frame.
Public property | AngleSnap | Gets or sets the angle snap used for items' rotation. Default is 5 degrees.
Public property | ArrowKeysLargeStep | Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.
Public property | ArrowKeysShortStep | Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.
Public property | CanCopy | Gets whether a Clipboard Copy action can be performed.
Public property | CanCut | Gets whether a Clipboard Cut action can be performed.
Public property | CanPaste | Gets whether a Clipboard Paste action can be performed.
Public property | CanRedo | Gets whether the Redo action is available.
Public property | CanUndo | Gets whether the Undo action is available.
Public property | CurrentSelection | Gets the current selected item on the editor.
Public property | CurrentSelectionArea | Gets the location and size of the current selected items on the editor.
Public property | GridSize | Gets or sets the size of the grid in current unit. Default is zero.
Public property | ImageProcessingDpi | Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.
Public property | LabelDocument | Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.
Public property | LabelDocumentFrameBackground | Gets or sets the background brush for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderColor | Gets or sets the border color for the label document frame on the editor's surface. Default is White.
Public property | LabelDocumentFrameBorderThickness | Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.
Public property | LabelDocumentFrameCornerRadius | Gets or sets the radii of the corners of the label document frame. Default value is 10.
 | LicenseKey | Gets or sets the license key info.
 | LicenseOwner | Gets or sets the license owner info.
Public property | NoImageFileName | Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.
Public property | RFIDTagImageFileName | Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.
Public property | RulerBackground | Gets or sets the background brush for the editor's rulers. Default is SystemColors.ControlBrush
Public property | RulerForeColor | Gets or sets the foreground color for the number tags of the editor's rulers.
Public property | RulerLinesColor | Gets or sets the color for the lines which compose the editor's rulers.
Public property | RulerSelectionColor | Gets or sets the background color for the selection zone of the editor's rulers.
Public property | ShowGrid | Gets or sets whether grid is displayed. Default is false.
Public property | SnapToGrid | Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.
Public property | TextItemEditModeEnabled | Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.
Public property | Zoom | Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveTool Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveTool Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the current active tool of the editor. Default is the Pointer tool used for selection action mainly.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public EditorTool ActiveTool { get; set; }
Visual Basic
Public Property ActiveTool As EditorTool
    Get
    Set
Visual C++
public:
property EditorTool ActiveTool {
    EditorTool get ();
    void set (EditorTool value);
}

Property Value

Type: EditorTool

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ActiveToolItem Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ActiveToolItem Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the Item object which is added to the editor's surface by the end-user.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Item ActiveToolItem { get; set; }
Visual Basic
Public Property ActiveToolItem As Item
    Get
    Set
Visual C++
public:
property Item^ ActiveToolItem {
    Item^ get ();
    void set (Item^ value);
}

Property Value

Type: Item

Remarks

The Item object specified by this property must match the type which is currently set up to the ActiveTool property. For example, if the ActiveTool is set up to Text, then a new TextItem object needs to be specified to the ActiveToolItem property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerFrameBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerFrameBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the adorner's frame. Default is Black.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerFrameBorderColor { get; set; }
Visual Basic
Public Property AdornerFrameBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerFrameBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the adorner's handlers. Default is Green.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerBackColor { get; set; }
Visual Basic
Public Property AdornerHandlerBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the adorner's handlers. Default is Black.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerBorderColor { get; set; }
Visual Basic
Public Property AdornerHandlerBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerHandlerHoverBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerHandlerHoverBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the adorner's handlers when the mouse pointer is over them. Default is Red.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerHandlerHoverBackColor { get; set; }
Visual Basic
Public Property AdornerHandlerHoverBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerHandlerHoverBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBackColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBackColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the selection adorner's frame.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerSelectionBackColor { get; set; }
Visual Basic
Public Property AdornerSelectionBackColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerSelectionBackColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AdornerSelectionBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AdornerSelectionBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the selection adorner's frame.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color AdornerSelectionBorderColor { get; set; }
Visual Basic
Public Property AdornerSelectionBorderColor As Color
    Get
    Set
Visual C++
public:
property Color AdornerSelectionBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.AngleSnap Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..AngleSnap Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the angle snap used for items' rotation. Default is 5 degrees.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public int AngleSnap { get; set; }
Visual Basic
Public Property AngleSnap As Integer
    Get
    Set
Visual C++
public:
property int AngleSnap {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysLargeStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysLargeStep Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the large step size in current unit when any of the arrow keys and the control key are pressed. Default is 0.1 inch.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ArrowKeysLargeStep { get; set; }
Visual Basic
Public Property ArrowKeysLargeStep As Double
    Get
    Set
Visual C++
public:
property double ArrowKeysLargeStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ArrowKeysShortStep Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ArrowKeysShortStep Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the short step size in current unit when any of the arrow keys are pressed. Default is 0.01 inch.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ArrowKeysShortStep { get; set; }
Visual Basic
Public Property ArrowKeysShortStep As Double
    Get
    Set
Visual C++
public:
property double ArrowKeysShortStep {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCopy Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCopy Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Copy action can be performed.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanCopy { get; private set; }
Visual Basic
Public Property CanCopy As Boolean
    Get
    Private Set
Visual C++
public:
property bool CanCopy {
    bool get ();
    private: void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanCut Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanCut Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Cut action can be performed.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanCut { get; private set; }
Visual Basic
Public Property CanCut As Boolean
    Get
    Private Set
Visual C++
public:
property bool CanCut {
    bool get ();
    private: void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanPaste Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanPaste Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether a Clipboard Paste action can be performed.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanPaste { get; private set; }
Visual Basic
Public Property CanPaste As Boolean
    Get
    Private Set
Visual C++
public:
property bool CanPaste {
    bool get ();
    private: void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanRedo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanRedo Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether the Redo action is available.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanRedo { get; private set; }
Visual Basic
Public Property CanRedo As Boolean
    Get
    Private Set
Visual C++
public:
property bool CanRedo {
    bool get ();
    private: void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CanUndo Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CanUndo Property
ThermalLabelEditor Class See Also Send Feedback
Gets whether the Undo action is available.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool CanUndo { get; private set; }
Visual Basic
Public Property CanUndo As Boolean
    Get
    Private Set
Visual C++
public:
property bool CanUndo {
    bool get ();
    private: void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelection Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelection Property
ThermalLabelEditor Class See Also Send Feedback
Gets the current selected item on the editor.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Item CurrentSelection { get; private set; }
Visual Basic
Public Property CurrentSelection As Item
    Get
    Private Set
Visual C++
public:
property Item^ CurrentSelection {
    Item^ get ();
    private: void set (Item^ value);
}

Property Value

Type: Item

Remarks

This property returns an Item-derived class representing the current selection on the editor.

If the selection is just one item only, then the returned object will be the Item-derived class of such object. For exmaple, if a Rectangle item is selected, then the returned object will be a RectangleShapeItem instance.

If the selection contains more than one item, then the returned object will be an instance of the MultipleSelectionItem class. The MultipleSelectionItem class contains some properties that are common to most Item-derived classes. That means that some properties of such class are common to all Item-derived classes, for example, the X and Y properties. Notice that the MultipleSelectionItem class also contains some properties that are common for a group of Item-derived classes and not to all. For example, the Font property is valid for TextItem and BarcodeItem object only.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.CurrentSelectionArea Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..CurrentSelectionArea Property
ThermalLabelEditor Class See Also Send Feedback
Gets the location and size of the current selected items on the editor.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Rect CurrentSelectionArea { get; private set; }
Visual Basic
Public Property CurrentSelectionArea As Rect
    Get
    Private Set
Visual C++
public:
property Rect CurrentSelectionArea {
    Rect get ();
    private: void set (Rect value);
}

Property Value

Type: Rect

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.GridSize Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..GridSize Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the size of the grid in current unit. Default is zero.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double GridSize { get; set; }
Visual Basic
Public Property GridSize As Double
    Get
    Set
Visual C++
public:
property double GridSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ImageProcessingDpi Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ImageProcessingDpi Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the DPI value which will be used for processing the ImageItem objects on the editor's surface. Default is 96 dpi.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double ImageProcessingDpi { get; set; }
Visual Basic
Public Property ImageProcessingDpi As Double
    Get
    Set
Visual C++
public:
property double ImageProcessingDpi {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocument Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocument Property
ThermalLabelEditor Class See Also Send Feedback
Gets the LabelDocument object that represents a ThermalLabel object on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public LabelDocument LabelDocument { get; private set; }
Visual Basic
Public Property LabelDocument As LabelDocument
    Get
    Private Set
Visual C++
public:
property LabelDocument^ LabelDocument {
    LabelDocument^ get ();
    private: void set (LabelDocument^ value);
}

Property Value

Type: LabelDocument

Remarks

The LabelDocument object is a lightweight version of the ThermalLabel class and is automatically created when you load a ThermalLabel object through the LoadThermalLabel() method.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBackground Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBackground Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background brush for the label document frame on the editor's surface. Default is White.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Brush LabelDocumentFrameBackground { get; set; }
Visual Basic
Public Property LabelDocumentFrameBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ LabelDocumentFrameBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the border color for the label document frame on the editor's surface. Default is White.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color LabelDocumentFrameBorderColor { get; set; }
Visual Basic
Public Property LabelDocumentFrameBorderColor As Color
    Get
    Set
Visual C++
public:
property Color LabelDocumentFrameBorderColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameBorderThickness Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameBorderThickness Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the thickness of the label document frame's border on the editor's surface. Default is 0.5.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double LabelDocumentFrameBorderThickness { get; set; }
Visual Basic
Public Property LabelDocumentFrameBorderThickness As Double
    Get
    Set
Visual C++
public:
property double LabelDocumentFrameBorderThickness {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LabelDocumentFrameCornerRadius Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LabelDocumentFrameCornerRadius Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the radii of the corners of the label document frame. Default value is 10.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double LabelDocumentFrameCornerRadius { get; set; }
Visual Basic
Public Property LabelDocumentFrameCornerRadius As Double
    Get
    Set
Visual C++
public:
property double LabelDocumentFrameCornerRadius {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LicenseKey Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LicenseKey Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the license key info.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string LicenseKey { get; set; }
Visual Basic
Public Shared Property LicenseKey As String
    Get
    Set
Visual C++
public:
static property String^ LicenseKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.LicenseOwner Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..LicenseOwner Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the license owner info.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public static string LicenseOwner { get; set; }
Visual Basic
Public Shared Property LicenseOwner As String
    Get
    Set
Visual C++
public:
static property String^ LicenseOwner {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.NoImageFileName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..NoImageFileName Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the image file name to display on the editor's surface when the source of an ImageItem cannot be found.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public string NoImageFileName { get; set; }
Visual Basic
Public Property NoImageFileName As String
    Get
    Set
Visual C++
public:
property String^ NoImageFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RFIDTagImageFileName Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RFIDTagImageFileName Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the image file name to display on the editor's surface for a RFIDTagItem.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public string RFIDTagImageFileName { get; set; }
Visual Basic
Public Property RFIDTagImageFileName As String
    Get
    Set
Visual C++
public:
property String^ RFIDTagImageFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerBackground Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerBackground Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background brush for the editor's rulers. Default is SystemColors.ControlBrush

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Brush RulerBackground { get; set; }
Visual Basic
Public Property RulerBackground As Brush
    Get
    Set
Visual C++
public:
property Brush^ RulerBackground {
    Brush^ get ();
    void set (Brush^ value);
}

Property Value

Type: Brush

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerForeColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerForeColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the foreground color for the number tags of the editor's rulers.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerForeColor { get; set; }
Visual Basic
Public Property RulerForeColor As Color
    Get
    Set
Visual C++
public:
property Color RulerForeColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerLinesColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerLinesColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the color for the lines which compose the editor's rulers.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerLinesColor { get; set; }
Visual Basic
Public Property RulerLinesColor As Color
    Get
    Set
Visual C++
public:
property Color RulerLinesColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.RulerSelectionColor Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..RulerSelectionColor Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the background color for the selection zone of the editor's rulers.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public Color RulerSelectionColor { get; set; }
Visual Basic
Public Property RulerSelectionColor As Color
    Get
    Set
Visual C++
public:
property Color RulerSelectionColor {
    Color get ();
    void set (Color value);
}

Property Value

Type: Color

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ShowGrid Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ShowGrid Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether grid is displayed. Default is false.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool ShowGrid { get; set; }
Visual Basic
Public Property ShowGrid As Boolean
    Get
    Set
Visual C++
public:
property bool ShowGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SnapToGrid Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SnapToGrid Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether items will be placed and sized according to the divisions of the grid. Default is false.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool SnapToGrid { get; set; }
Visual Basic
Public Property SnapToGrid As Boolean
    Get
    Set
Visual C++
public:
property bool SnapToGrid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.TextItemEditModeEnabled Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..TextItemEditModeEnabled Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets whether TextItem objects can enter in Edit Mode. Default is true.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public bool TextItemEditModeEnabled { get; set; }
Visual Basic
Public Property TextItemEditModeEnabled As Boolean
    Get
    Set
Visual C++
public:
property bool TextItemEditModeEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.Zoom Property

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..Zoom Property
ThermalLabelEditor Class See Also Send Feedback
Gets or sets the zoom percentage level of the editor's content. The valid range for zoom is 10% - 1000%. Default is 100 which means normal size.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public double Zoom { get; set; }
Visual Basic
Public Property Zoom As Double
    Get
    Set
Visual C++
public:
property double Zoom {
    double get ();
    void set (double value);
}

Property Value

Type: Double

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor Events

[image] [image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor Events
ThermalLabelEditor Class See Also Send Feedback

The ThermalLabelEditor type exposes the following members.

Events

 | Name | Description
Public event | ClipboardStateChanged | Occurs when the state of the internal Clipboard changes.
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two times on the editor's canvas.
Public event | NewItemCreated | Occurs when a new item is created on the editor's surface.
Public event | SelectionAreaChanged | Occurs when the editor's selection area changes.
Public event | SelectionChanged | Occurs when the editor's selection changes.
Public event | SelectionItemPropertyChanged | Occurs when any property of the selected item changes.
Public event | UndoStateChanged | Occurs when the undo state of the editor changes.

See Also

ThermalLabelEditor Class
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.ClipboardStateChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..ClipboardStateChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the state of the internal Clipboard changes.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler ClipboardStateChanged
Visual Basic
Public Event ClipboardStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ ClipboardStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to update the state of the classic Copy, Cut and Paste buttons of the UI by using the CanCopy, CanCut and CanPaste properties.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.MouseDoubleClick Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..MouseDoubleClick Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when a mouse button is clicked two times on the editor's canvas.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event MouseButtonEventHandler MouseDoubleClick
Visual Basic
Public Event MouseDoubleClick As MouseButtonEventHandler
Visual C++
public:
 event MouseButtonEventHandler^ MouseDoubleClick {
    void add (MouseButtonEventHandler^ value);
    void remove (MouseButtonEventHandler^ value);
}

Value

Type: System.Windows.Input..::..MouseButtonEventHandler

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.NewItemCreated Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..NewItemCreated Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when a new item is created on the editor's surface.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler NewItemCreated
Visual Basic
Public Event NewItemCreated As EventHandler
Visual C++
public:
 event EventHandler^ NewItemCreated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionAreaChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionAreaChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the editor's selection area changes.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionAreaChanged
Visual Basic
Public Event SelectionAreaChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionAreaChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to present the selection's location and size to the end-user by using the CurrentSelectionArea property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the editor's selection changes.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionChanged
Visual Basic
Public Event SelectionChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to present the selection data to the end-user by using the CurrentSelection property.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.SelectionItemPropertyChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..SelectionItemPropertyChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when any property of the selected item changes.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler SelectionItemPropertyChanged
Visual Basic
Public Event SelectionItemPropertyChanged As EventHandler
Visual C++
public:
 event EventHandler^ SelectionItemPropertyChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


ThermalLabelEditor.UndoStateChanged Event

[image]

Neodynamic ThermalLabel SDK for .NET Class Reference
ThermalLabelEditor..::..UndoStateChanged Event
ThermalLabelEditor Class See Also Send Feedback
Occurs when the undo state of the editor changes.

Namespace: Neodynamic.Windows.WPF.ThermalLabelEditor
Assembly: Neodynamic.Windows.ThermalLabelEditor (in Neodynamic.Windows.ThermalLabelEditor.dll) Version: 6.0.3500.0 (6.0.3515.409)

Syntax

C#
public event EventHandler UndoStateChanged
Visual Basic
Public Event UndoStateChanged As EventHandler
Visual C++
public:
 event EventHandler^ UndoStateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: System..::..EventHandler

Remarks

Handle this event to update the Undo and Redo buttons of the UI by using the CanUndo and CanRedo properties.

See Also

ThermalLabelEditor Class
ThermalLabelEditor Members
Neodynamic.Windows.WPF.ThermalLabelEditor Namespace


Online Samples

Neodynamic ThermalLabel SDK for .NET
Online Samples & Guides
We've developed many samples using ThermalLabel SDK for .NET in order to help you getting started.

The list of up to date Step-By-Step Guides are available at http://neodynamic.com/products/printing/thermal-label/sdk-vb-net-csharp/articles/

Visit Neodynamic's website.

Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Barcode Symbologies

Neodynamic ThermalLabel SDK for .NET
Linear (1D), Postal and 2D Symbologies

"A bar code (also barcode) is an optical machine-readable representation of data. Originally, bar codes represented data in the widths (lines) and the spacings of parallel lines and may be referred to as linear or 1D (1 dimensional) barcodes or symbologies. But they also come in patterns of squares, dots, hexagons and other geometric patterns within images termed 2D (2 dimensional) matrix codes or symbologies. In spite of there being no bars, 2D systems are generally referred to as barcodes as well." Wikipedia, The Free Encyclopedia.

ThermalLabel SDK supports many of the most popular Barcode Symbologies available today, Linear (1D), Postal and 2D Symbologies

Visit Neodynamic's website.

Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Deployment

Neodynamic ThermalLabel SDK for .NET
Neodynamic ThermalLabel SDK for .NET Deployment

ThermalLabel SDK Deployment
Deploying an application that uses Neodynamic ThermalLabel SDK for .NET is not different than any other application that uses custom .NET DLL Assemblies. All functionality of ThermalLabel is contained in a unique assembly (Neodynamic.SDK.ThermalLabel.dll). For example, when deploying your ASP.NET Web application using ThermalLabel SDK, you must ensure that Neodynamic.SDK.ThermalLabel.dll assembly is located in the BIN folder of your application. For Windows Forms/Console applications, you must ensure that Neodynamic.SDK.ThermalLabel.dll assembly is located in the same folder of your application.

ThermalLabelEditor Deployment
If your project is referencing the ThermalLabelEditor component (Neodynamic.Windows.ThermalLabel.dll) then you will need to distribute this file with your application. ThermalLabelEditor relies on the ThermalLabel SDK component so when you deploy your app using the ThermalLabelEditor, then you will have to deploy the ThermalLabel SDK dll too i.e. both the Neodynamic.SDK.ThermalLabel.dll and Neodynamic.Windows.ThermalLabel.dll assemblies must be located in the same folder of your application.

Native Printer Font (NPF) Deployment
You must ensure that the installation program of your application will install the Native Printer Font files that you will find in the installation folder of our product.
IMPORTANT
You cannot deploy or use the Native Printer Font files outside our product.

Send comments on this topic. Visit Neodynamic's website.

Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.


Technical Support

Neodynamic ThermalLabel SDK for .NET
Neodynamic Technical Support
When you purchase a licensed version of Neodynamic ThermalLabel SDK for .NET you get access to FREE technical support.
Technical Support can be reached by email at support@neodynamic.com.

Before contacting technical support we recommend:
  • Read the product documentation.
  • Read FAQ at Neodynamic Website.
For more information about technical support visit www.neodynamic.com/support.

Visit Neodynamic's website.
Neodynamic ThermalLabel SDK for .NET Documentation
Copyright © 2003 - Neodynamic - All rights reserved.