HFNetChkPro 4 にようこそ

HFNetChkPro 4.3 にようこそ

HFNetChkPro 4.3 - 次世代のセキュリティパッチ管理 にようこそ。この新バージョンには、時間を節約し、システムの安全を確保するために強化された機能が多数含まれています。HFNetChkPro 4.3の直感的に操作できるドラッグ アンド ドロップ インターフェースは、簡単なテンプレート設定やビルトイン テストグループとともに、高速スキャンやパッチ導入を容易にします。パッチ最大深刻度情報が必要ですか。HFNetChkPro 4.3の新しい脅威解析情報を使えば、クリックするだけでMIcrosoftから、リンク、Bugtraq、CVE情報までの重大度をチェックすることができます。

HFNetChkPro 4.3 は次のオペレーティングシステムやアプリケーションでセキュリティパッチ評価や PatchPushTM を行なうことができます。

  • Windows NT 4.0、 2000、XP およびServer 2003

  • Exchange Server

  • SQL Server

  • Microsoft Office、Outlook および Office installation pointsを含む

  • Java Virtual Machine

  • Internet Explorer

  • Internet Information Services (IIS)

  • Windows Media Player

  • Microsoft Data Access Components (MDAC)

  • ISA Server

  • Commerce Server

  • .NET Framework


最新情報

HFNetChkPro V4.2では、別個のダウンロードセンターを使用せずにドイツ語とフランス語のバッチを自動的にダウンロードし、導入できるようになりました。 英語、ドイツ語、フランス語その他の言語のパッチのダウンロードの詳細は 各国語のパッチについて をご覧ください。


HFNetChkPro 4 バージョン

HFNetChkPro 4には次の2つの版があります。

  • HFNetChkPro 未登録版
    HFNetChkPro 未登録版は台数の制限なくマシンを何台でもスキャンして不足しているパッチを調べることができますが、パッチのダウンロードや導入、含まれているレポートの表示はできません。

  • HFNetChkPro
    HFNetChkProには、詳細レポート、テクニカルサポート、10台以上のマシンのスキャンとパッチ導入が含まれています。 このバージョンではMicrosoft SQLバックエンドデータベースをサポートすることもできます。 このオプションに関する詳細は、最寄りのShavlik販売代理店にお問合せください。

お使いのHFNetChkProのバージョンを確認するには、アプリケーションのメインページのタイトルバーをご覧ください。 または ヘルプ > バージョン情報 を選択してもバージョンの詳細が確認できます。


システム要件

HFNetChkProはWindows 2000 SP 3またはそれ以上、Windows XP と Windows 2003 サーバーシステムにインストールできます。 ただし、次のアプリケーションやシステムコンポーネントが必要となります。

  • Internet Explorer 5.5以上

  • Microsoft Windows Installer version 2.0

  • Microsoft Data Access Components (MDAC) 2.7 SP1 以上

  • Microsoft XML Parser 3.0 SP2以上または Microsoft XML 4.0
    最高の XML パーシング性能を達成するには、 MSXML 3 と MSXML 4の両方をインストールします。

  • Microsoft Jet 4.0 SP8 以上

インストーラはこれらの必要なアプリケーションの英語版、フランス語版またはドイツ語版を自動的にダウンロードしようとします。 必要なアプリケーションが不足していて、インストールを再度クリックした場合は、これらの事前必要条件を迂回することができます。 ただし、この場合は実際に前提レベルであることを確認してください。 これらのコンポーネントをインストールすると、システムの再起動が必要となる場合があることにご留意ください。


HFNetChkPro 4 が他製品を引き離している理由

機能

使いやすさ | HFNetChkPro 4はインストールやパッチのプッシュが数分でできます。
リアルタイムのパッチ確認 | HFNetChkPro4は、セキュリティパッチがリリースされた瞬間にアップデートされるXMLデータファイルを使用しています。
エージェントを使用しないオペレーション | スキャンするマシンにエージェントソフトウェアをインストール必要がありません。
パッチの代替 | スキャン中は、スキャンされるプラットフォームに必要かつ該当するパッチだけが評価されます。 不要なパッチや代替されたパッチは必要とされない限り提示されません。.
Microsoftによって推奨されるテクノロジー | HFNetChkPro4は、Microsoft Baseline Security AnalyzerやSMS Feature Pack の原動力となっているものと同じエンジンをもとに構築されており、Microsoft Security Bulletin ウェブサイトで使用されているデータベーススキーマとまったく同じものを使用しています。

セキュリティと整合性

詳細にわたるパッチ解析と確認 | パッチステータス判定のために、ファイルのバージョン、チェックサム、レジストリキーが評価されます。 レジストリーキーおよび/または最小ファイルバージョンだけに依頼するソリューションでは、Microsoftから再リリースされたパッチも含め、正当なファイルとトロイの木馬に冒されたファイルとを区別することができません。
チェックサムの再計算 | ファイル チェックサムは、スプーフされやすいファイルのヘッダから読み取られる代わりに、スキャンしているマシンによって再計算されます。
外部確認データ | パッチ確認テストに使用されるファイルデータは、スキャンされるマシンとは関係のない署名されたソースから取得されます。 リモートマシンのレジストリに保存されているファイルバージョンデータを使用したパッチ確認は、有効な結果を常に提供できるとは限りません。
データファイルのスプーフ予防 | MSSecure XML ファイルは、有効で明確に署名されたCABファイルまたはSSLロケーションから取得された場合にのみパースされます。
トロイの木馬感染予防 | ファイルはすべて、パッチ導入前にデジタルに確認されます。


スキャニングエンジンの概要

HFNeｔChkPro 4 アプリケーションは、Shavlik Technologies社がMicrosoftのために開発した業界をリードするHFNetChk.exeエンジンをもとに構築されています。 HFNetChkProエンジンは、 Windows NT 4.0、Windows 2000、Windows XP、Windows Server 2003をはじめ、Exchange Server や SQL Serverなどの一般的なシステムコンポーネントやサーバーアプリケーションに対しても、Microsoftセキュリティパッチ評価を行ないます。

HFNetChkProエンジンは、各製品に対してMicrosoftのどのセキュリティhotfixが利用できるかという情報を含むExtensible Markup Language (XML) ファイルを使用します。XMLファイルにはセキュリティブレティン名とタイトルに加え、製品固有のセキュリティhotfixに関する以下のような詳細データが含まれています。

  • 各hotfixパッケージ内のファイルとそれらのファイルバージョンおよびチェックサム、

  • hotfixインストールパッケージによって使用されるレジストリキー、

  • どのパッチが他のどのパッチの代替となるかについての情報、

  • 関連するMicrosoft Knowledge Baseアーティクル番号、

  • パッチ脆弱性による脅威についてのサードパーティ分析、

  • Bugtraq (BugtraqID) からの追加情報、Mitre.org (CVEID)のホストによるCommon Vulnerabilities and Exposures (CVE) データベースとのクロスリファレンスなど。

MSSecure.xml と呼ばれるXMLファイルは、Shavlik Technologiesが開発し、ホストを行なっています。

HFNetChkPro 4 を（ファイル入力の詳細指定オプションを使用しないで）実行する場合、プログラムは各製品に利用できるhotfixを特定するために、このXMLファイルのコピーをダウンロードしなければなりません。XMLファイル - デジタル署名された.cabファイル - は、Shavlikのウェブサイトから圧縮ファイル形式で取得できます。 HFNetChkPro 4 はCAB ファイルをダウンロードし、デジタル署名を確認した上でCABファイルをローカルコンピュータ上で解凍します。CABファイルはZIPファイルとよく似た圧縮ファイルです。CABファイルが見つからない、またはダウンロードできない場合、HFNetChkPro 4はSSL（https）経由でShavlikのウェブサイトから圧縮されていないファイルのコピーをダウンロードしようとします。

CABファイルが解凍されると、HFNetChkPro 4はお使いのコンピュータ（または指定されたコンピュータ）をスキャンし、オペレーティングシステム、サービスパック、実行されているプログラムを判定します。HFNetChkPro 4は次に、XMLファイルをパースして、コンピュータにインストールされているソフトウェアの組み合わせに対して利用できるセキュリティパッチを特定します。お使いのコンピュータで利用できるパッチでまだインストールされていないものは結果の欄に [image] として表示されます。デフォルト設定では、HFNetChkPro 4の結果には、コンピュータをアップデートするのに必要なパッチだけが表示されるようになっています。HFNetChkPro 4 はロールアップパッケージを認識しますが、 他のパッチで代替されるものでないパッチは表示しません。


マシンの列挙

ドメイン名によってスキャンする場合、HFNetChkPro はそのドメインでマシンを列挙するために幾つかのことを行ないます。

  • 適切なパーミッションを持つ管理ユーザーとしてスキャンを行なう場合、HFNetChkProはドメインコントローラにコンタクトを取り、そのマシンアカウントのリストを列挙することを試みます。

  • マシンはまた、ネットワーク参照リストからも列挙されます。これはNetwork Neighborhoodまたはそれと類似する'net view /domain:domainname'を表示するときにドメインごとに見られるマシンのリストと同じものです。 HFNetChkProがUDP ポート 137 (NetBIOS ネームサービス)を使って参照リストを列挙する場合、マシン名を列挙するための特別なパーミッションは不要です。 スキャンするマシンがネットワークに接続されたばかりの場合は、そのマシンが参照マスタと同期化してリストが利用できるようになるまでに最高15分かかります。 戻されたマシンリストは、現在オンラインまたは15分以内までオンラインだったマシンを示しています。 レジストリ変更によって「非表示」になっているマシンはネットワーク参照リストにマシン名が伝播されないため、表示されません。 スキャンするマシンが参照リストにアクセスできない場合、あるいは参照リストがアップデートされないフィルタデバイスの背後にある場合などでは、そのマシンは表示されません。


パッチステータスの判定

HFNetChkPro 4 はスキャンされる各マシンについての詳細解析を行なって、パッチステータスを正確に判定します。 他のパッチ管理システムと異なり、HFNetChkProエンジンは、レジストリキーの存在に全面的に依存する従来のパッチ検出のはるか先を行くものです。

特定のパッチがそのコンピュータにインストールされているかどうかをHFNetChkPro 4が判定するために、通常3つのアイテムが評価されます。

  • パッチによってインストールされているレジストリキー

  • パッチによってインストールされたすべてのファイルのバージョン、および

  • パッチによってインストールされた各ファイルのチェックサム

デフォルトのQuickScan設定では、HFNetChkProは、MSSecure XMLファイルのファイルバージョンとスキャンされているコンピュータ上のファイルバージョンを比較します。スキャンされているコンピュータ上のファイルバージョンが、XMLファイルに保管されているものより低い場合は、それに関連するセキュリティパッチがインストールされていない ( [image]) と識別され、結果が画面に表示されます。

FullScan設定（またはカスタムスキャンテンプレートを作成する場合）では、ファイルチェックサムの評価はファイル確認に追加して行なわれます。

パッチがなぜインストールされていないと見なされるかについての詳細は、「アイテムの理由」として HFNetChkPro出力に表示されます。


ファイルバージョンとチェックサム解析

システムがそのシステムに該当するパッチのパッチ解析に「合格」するためには、そのパッチに関連するすべてのファイルのファイルバージョン（FullScanを使用している場合はチェックサムも含める）がMSSecure XMLファイルに含まれているものすべてと一致しなければなりません。

  • パッチに関連するファイルのバージョンが（対象となるシステムで）予期されたものより低い場合、パッチが見つからないと見なされ、システムで検出されたファイルバージョンと（XMLファイルで）予期されたファイルバージョンの両方が「不足しているパッチ」メッセージとともに結果に表示されます。

  • 「注と警告を参照」がカスタムスキャンテンプレートによって選択され、システムのファイルバージョンが予期されるものより高い場合、システム上のファイルが予期されているより最新であるという警告メッセージとともに、既存のファイルバージョンと予期されるファイルバージョンの両方が表示されます。これは、より最近のセキュリティブレティン関連hotfixが存在する、あるいはトロイの木馬化されたファイルが存在する可能性があることを示しています。

  • システムのファイルバージョンが予期されるものと一致し、システム上のファイルのチェックサムとXMLファイルに保存されているチェックサムが異なるものである場合は、「パッチの不足」と見なされます。 (英語以外のシステムをスキャンする場合、英語以外のパッチのチェックサムはXMLファイルに保存されているものと異なるため、チェックサム解析は自動的に使用不可とされます。 XMLファイルの今後のバージョンでは、すべての言語のすべてのパッチのチェックサムが含まれるようになります。）

  • チェックサム解析は、リモートファイルのコンテントをスキャンシステムにマップし、そこでチェックサムを再計算して、MSSecure XMLファイルによって予期されるものと比較することによって行なわれます。 そのため、チェックサムスキャンはデフォルトのQuickScanより長く時間がかかることがあります。


パッチの代替の判定

HFNetChkProの利点のひとつは、お使いのマシンでアップデートされることが必要なパッチだけを表示し、新しいパッチで代替された古いパッチを表示しないことです。

最近のMicrosoftセキュリティパッチの多くが「Cumulative Rollup（累積ロールアップ）」パッチとしてリリースされています。 ロールアップパッチには、その製品に対してこれまでにリリースされたセキュリティパッチすべてと、もっとも最近発表された事項に対する修復が含まれています。 初期のパッチをすべて網羅する累積パッチは、初期のパッチに取って代わります。 （パッチが代替されるためには、古いパッチのファイルがすべて新しいパッチに含まれていること、新しいパッチのファイルバージョンがすべて古いパッチのバージョン以上であること（またはファイルバージョンとチェックサムが古いパッチのものと同じであること）、そして、新しく取って代わるほうのパッチ内に関連する有効なレジストリキーが含まれていることが必要です。）

これまでにリリースされたセキュリティロールアップパッチの中でよく知られているものには、ブレティン MS01-041 (Q299444)で発表されたWindows NT 4.0 SP6a SRPやブレティンMS02-001で発表されたWindows 2000 post SP2 Security Rollup package (Q311401)があります。 これらのロールアップのほかに、Internet Explorer、Internet Information Services、SQL Serverに最近リリースされたパッチの多くが、ロールアップとしてリリースされています。

MSSecure.xml ファイルには、代替される各パッチの情報が含まれています。 HFNetChkProはパッチの代替コードを評価して、スキャンされる各システムに該当する非代替パッチを特定します。 適用性に関する代替パッチには特に注意が払われます。 以下に例を挙げます。

  • パッチAはWindows 2000 Service Pack 1 (SP1)に適用性がある。

  • パッチBはパッチAに取って代わり、Windows 2000 SP1 と SP2のどちらにも適用できる。

  • パッチCはパッチBに取って代わり、 Windows 2000 SP2に適用できる。

HFNetChkProはWindows 2000 SP2マシンにパッチCがあること、そして、XMLファイルではパッチBはパッチCで代替されたとマークされているにも関わらず、Windows 2000 SP1 マシンにパッチBがあることを正しくスキャンします。


明確にインストールされたパッチを特定

明確にインストールされたファイルを特定するためには、幾つかの基準が満たされなければなりません。

  • インストールされるマシンに書き込まれるレジストリキーがパッチに含まれていること*、そしてこのレジストリキーが MSSecure XMLファイルに存在すること**です。

  • スキャンされるマシンにレジストリキーが存在することが必要です。

  • リモートシステムに書き込まれるパッチのファイル（XMLファイルで定義される）はすべて、XMLファイルに記録されているバージョンと同等あるいはそれ以上でなければなりません。 リモートシステムのファイルバージョンのいずれかが予期されるものよりも低い場合、レジストリキーが存在していても、そのパッチはインストールされていないと見なされます。

*幾つかのタイプのパッチでは、インストール先のステムにレジストリキーを書き込みません。特にSQL Serverのパッチでこれが顕著です。 この場合、パッチが適用されたことが明確に示されないので、ある時点でSQLパッチ（あるいはそれと似たパッチ）が確かにインストールされたかとうかを判定することはできません。 これらのシステムが最新の状態であることを確かめるには、システムのスキャンを行なって、「パッチの不足」として表示されるSQLパッチがないことを確認します。

** HFNetChkPro 4がパッチを導入する場合は、HKLM\Software\Microsoft\Updates\Shavlikの下でリモートシステムに独自のレジストリキーを書き込みます。 このデータはシステム侵入を防止するために暗号化されます。 ですから、パッチ導入中（SQLパッチ、Officeパッチなど）通常はレジストリキーを書き込まない場合でも、HFNetChkPro 4アプリケーションはレジストリキーを書き込み、後で評価を行なうときにスキャナによって読み取れるようにします。 アプリケーションは、これらのパッチがすべてインストールされており、アプリケーションをインストールするのにどのアカウントが使用されたか、パッチがいつインストールされたかを読み取ることができます。 この情報はパッチ詳細パネルに表示されるとともに、パッチサマリーウィンドウの「見つかったパッチ」のテキストにマウスを動かしても表示されます。


正しくインストールされたパッチを特定

HFNetChkPro 4 は「正しくインストールされたパッチ」をスキャンして特定することもできます。 正しくインストールされたパッチは、他のパッチに 取って代わる 単一のパッチをインストールする状況を言います。 これらの状況では、インストールされていないが新しいパッチによって 取って代わられた パッチも、正しくインストールされたと見なされます。これは、各ファイルに予期されたファイルバージョン、あるいはそれ以上のファイルバージョンがあるためです。 たとえば、新しいWin2K SP2マシンをインストールし、次にパッチMS02-001をインストールしたとします。 このパッチはSP2の20の古いhotfixに 取って代わる ので、1つのパッチを「インストール」したただけで20のパッチを正しくインストールしたことになります。


HFNetChkProの登録

HFNetChkPro 4 の登録

HFNetChkPro 4が初めてダウンロードされてインストールされるときには、未登録版のプログラムです。 HFNetChkProの使用目的が、10台までのマシンにパッチのダウンロードや導入を行なうだけで、複雑なレポート機能は特に必要としないのであれば、Shavlikに 登録 して登録キーを入手するだけで、そのままこのバージョンを使用し続けることができます。 さらに多くのマシンを管理する場合あるいは複雑なレポート機能を必要とする場合には、Pro登録キーをお買い上げいただくことが必要となります。

HFNetChkProまたはHFNetChkPro限定版をアクティブにするには、HFNetChkPro 4をインストールしてライセンスキーを入力するだけです。 HFNetChkPro 4をすでにダウンロードし、インストールした場合は、Proライセンスキーを入力すると限定版をProインストールにすることができます。 限定版のキーでHFNetChkProをすでにアクティブにしてある場合でも、これが使えます。

どちらの場合でも、ShavlikからEメールで登録キーを入手することになります。 登録キーは25文字のコードで、プログラムをアンロックするために入力するものです。 プログラムを登録するには、メインスクリーンのライセンス情報の下にあるライセンスキーの入力 オプションをクリックするか、ヘルプ > ライセンスキーの入力をメニューから選択します。

これにより、登録ウィザードが起動します。 最初の画面にはShavlikの連絡先が表示され、それに続く画面で、25文字のコードを5文字づつ区切って入力することが求められます。 キーコードはアクティベーションキーウィンドウにタイプしても、コピーして貼り付けてもかまいません。 キーを貼り付けるには、Shavlikから受け取ったEメールに記載されている25文字のキーをハイライトし、CTRLキーとCを同時に押してクリップボードにコピーします。アクティベーションアプレットがクリップボードのキーを認識し、それを使用したいかどうか尋ねるメッセージが表示されます。 「はい」を選択して、キーをアクティベーションキーウィンドウに貼り付けます。

有効なキーコードを入力すると、完了のボタンがクリックできるようになります。 完了のボタンをクリックすると、キーコードがShavlikのサーバーで確認されます。 この手順が完了すると、お手元のHFNetChkProのコピーが登録され、メインスクリーンのライセンス情報部分が消えます。 新しいライセンスキーを入力する必要がある場合は、ヘルプ > ライセンスキーを入力に進みます。

オフラインで作業していてインターネットに接続されていない場合は、自動的に確認キーを入手することはできません。 その代わりに、手動でアクティベーションを行なうように指示が表示されます。 アクティベーションアプレットが、 license@shavlik.comにEメールできるテキストファイルを作成します。 Shavlik はEメールでファイルを返信し、インストールすることでアクティベーションを登録できるようにします。

そのキーを使ってインストールできる数には限りがあります。 ライセンスキーを入れると、Shavlikのウェブサーバーに連絡が行き、そのライセンスキーに幾つインストールが残っているかを調べます。 またアクティベーションが残っている場合は、Shavlikのサーバーが確認キーを生成し、HFNetChkProコンソールに返信します。 確認キーはレジストリに保存され、インストールされているハードウェアごとに固有のものとなります。 ソフトウェアをアンインストールしても確認キーは削除されないので、後日ソフトウェアを再インストールしたときにまた使用できます。この再インストールはインストール数制限の中には数えられません。

HFNetChkPro限定版を使用していて、インストール数が尽きてしまった場合は、Shavlikのウェブサイトで 登録フォーム に記入し、さらに3回インストールが行なえる新しいキーを請求することができます。 HFNetChkProのお客様で、インストール数が尽きてしまった場合は、セールス担当者に連絡してインストール数を増やしてもらってください。

許可されているインストール数は、Proライセンスキーを記載したEメールに書かれています。


HFNetChkPro 4 ホームページ

HFNetChkPro 4ユーザーインターフェース、またはホームページは最高のコントロール性とユーザーにとっての簡易性を主体にデザインされました。 下の画面図とナビゲーション機能の説明をお読みいただけば、HFNetChkPro 4の優れた性能の概要がおわかりいただけることと思います。

1

QuickLaunchは、スキャンをクリック1回で開始できるようにします。

マイコンピュータのスキャン をクリックすると、ローカルマシンのデフォルトスキャンがただちに開始されます。 最新のスキャンファイルが自動的にダウンロードされ、ユーザーの介入なしでスキャンがただちに開始されます。

オプションを指定したり、ローカルスキャンを異なる時間にスケジュールする場合には、 詳細 オプションをクリックします。

マイ ドメインのスキャン をクリックすると、ローカルドメインのデフォルトスキャンがただちに開始されます。 最新のスキャンファイルが自動的にダウンロードされ、ユーザーの介入なしでスキャンがただちに開始されます。

オプションを指定したり、ローカルスキャンを異なる時間にスケジュールする場合には、 詳細 オプションをクリックします。

特定のコンピュータやIPアドレス、IPアドレス範囲、ドメインをスキャンする場合は、スキャンするコンピュータを選択 オプションをクリックします。

特定のシステムをスキャンするために必要な情報が入力できるよう、新しいウィンドウが開きます。

2

この部分には、ヘルプの使い方やニュースへのリンクを含むHFNetChkPro 4 関係の情報が提供されます。

3

ユーザーインターフェースのこの部分に、ステータスメッセージが表示されます。 HFNetChkProのアップデートが利用可能な場合は、その通知がここに表示されます。

4

詳細情報

スキャンは、メインスクリーンのスキャン対象 ボックスからオプションを選択するだけで、簡単に開始できます。

マイ マシン | これをクリックすると、ローカルマシンのQuickScan または FullScan のどちらかが選べるようになります。
マイ ドメイン | これをクリックするとローカルマシンが関連付けられている ドメインのQuickScanまたはFullScanができるようになります。
マイ テスト マシン | 実際のネットワーク環境を代表するようなマシン グループのスキャンを実行します。
ネットワーク全体 | Microsoftネットワークでビジブルなすべてのマシンをスキャンします。
新しいマシン グループ | マシンのカスタムグループを作成します。 新しく作成されたグループは、簡単にスキャンが開始できるよう スキャン対象 のボックスに追加されます。

5

詳細情報

スキャンは、メインスクリーンのスキャン方法 ボックスからオプションを選択するだけで、簡単に開始できます。

QuickScan | 不足しているパッチとインストールされているパッチをスキャンし、チェックサムを無視します。 スキャンパッチデータはxml.shavlik.comからダウンロードされます。
FullScan | 不足しているパッチとインストールされているパッチをスキャンします。 xml.shavlik.comからのパッチデータファイルを使って、スキャン中にファイルチェックサムを評価します。 スキャン中、注や警告が表示されます。

新しいスキャンテンプレートを作成するには、 新しいスキャンテンプレート オプションをクリックし、表示される説明に従います。

6

詳細情報

パッチグループとは、スキャンや導入を行なおうとしているパッチの集合です。 パッチグループは、組織で承認されている必要あるいは必須のパッチを示すこともあります。 新しいグループを追加するには、新しいパッチグループをクリックします。

7

詳細情報

お気に入りはスキャンするマシンの集合とそれらのマシンのスキャン方法です。 新しいお気に入りの作成を行なうには、新しいお気に入りをクリックします。 お気に入りにはローカルマシンあるいは スキャン対象 で作成された特別のグループのどれでも追加することができ、スキャンタイプは2つの標準スキャンのいずれか、あるいは新しいカスタムスキャンテンプレートを選ぶことができます。

8

詳細情報

導入テンプレートは、パッチ導入で使用した設定を保存し、後の導入で簡単に利用できるようにするものです。?標準テンプレートの 設定を表示 するには、標準をクリックします。 新しいテンプレートの作成を行なうには、新しい導入テンプレートをクリックします。

9

HFNetChkProでスキャンされた様々なオペレーティングシステムやアプリケーションのパッチに関する詳細情報を表示します。 MSSecure XML ファイルにリストされているパッチの全リストを表示するには、 すべてのパッチをクリックします。

ソフトウェアの特定のバージョンに関するパッチ情報を表示するには、製品名の左の + 印をクリックします。 Gold、SP1などのバージョンそれぞれに関連する別のパッチがあります。 著しく重複している部分もありますが、この情報ツリーを使えば特定のシステムでどのパッチが利用できるかがわかり、それらに関する情報を読むことができます。 パッチについてさらに詳しい情報を入手するには、希望するソフトウェアパッケージとバージョンをクリックします。 右上のウィンドウにパッチのリストが表示され、この中からパッチを選択してクリックすると、さらに詳細が表示されます。


HFNetChkPro 4 スキャン インターフェース

1

このウィンドウには、このセッションでスキャンされたターゲットのサマリーが表示されます。 パッチ別サマリー をクリックすると、インストールされたものも不足しているものも含め、スキャンされたマシンに関連するパッチがすべてリストされます。 マシンサマリーを入手するには、このウィンドウのリストでマシン名をクイックします。

2

これもサマリーウィンドウです。 パッチ別サマリー がある場合、または1のウィンドウでマシンが選択されている場合、このウィンドウに選択された項目と関連するパッチのリスト が表示されます。 この例では、システムWin2Kが選択されています。 したがって、このウィンドウには、このシステムに関連するすべてのパッチが表示されています。

１のウィンドウでスキャンやドメインが選択されている場合、このウィンドウには マシンサマリーリストが表示されます。

マシン名またはIPアドレスによって、スキャンされたマシンのリストを表示することができます。 表示タイプを変更するには、メニューバーから ［表示 > ...別マシン］を選択します。

3

詳細情報

インターフェースのこのセクションは、上記で何が選択されているかによって変わります。 スキャンが選択されている場合、このウィンドウには スキャンサマリーが表示されます。マシンが選択されていると、このウィンドウには マシンサマリーが表示されます。 パッチが選択されていると パッチ詳細 が表示されます。

4

詳細情報

スキャンは、メインスクリーンのスキャン対象 ボックスからオプションを選択するだけで、簡単に開始できます。

マイ マシン | これをクリックすると、ローカルマシンのQuickScan または FullScan のどちらかが選べるようになります。
マイ ドメイン | これをクリックするとローカルマシンが関連付けられている ドメインのQuickScanまたはFullScanができるようになります。
マイ テスト マシン | 実際のネットワーク環境を代表するようなマシン グループのスキャンを実行します。
ネットワーク全体 | Microsoftネットワークでビジブルなすべてのマシンをスキャンします。
新しいマシン グループ | マシンのカスタムグループを作成します。 新しく作成されたグループは、簡単にスキャンが開始できるよう スキャン対象 のボックスに追加されます。

5

詳細情報

スキャンは、メインスクリーンのスキャン方法 ボックスからオプションを選択するだけで、簡単に開始できます。

QuickScan | 不足しているパッチとインストールされているパッチをスキャンし、チェックサムを無視します。 スキャンパッチデータはxml.shavlik.comからダウンロードされます。
FullScan | 不足しているパッチとインストールされているパッチをスキャンします。 xml.shavlik.comからのパッチデータファイルを使って、スキャン中にファイルチェックサムを評価します。 スキャン中、注や警告が表示されます。

新しいスキャンテンプレートの作成を行なうには、 新しいスキャンテンプレート オプションをクリックし、表示される説明に従います。

6

詳細情報

パッチグループは、スキャンや導入を行なおうとしているパッチの集合です。 パッチグループはあなたの組織で承認されている必要あるいは必須パッチを示すこともあります。 新しいグループを追加するには、新しいパッチグループをクリックします。

7

詳細情報

お気に入りはスキャンするマシンの集合とそれらのマシンのスキャン方法です。 新しいお気に入りの作成を行なうには、新しいお気に入りをクリックします。 お気に入りにはローカルマシンあるいは スキャン対象 で作成された特別のグループのどれでも追加することができ、スキャンタイプは2つの標準スキャンのいずれか、あるいは新しいスキャンテンプレートを選ぶことができます。

8

今日行なったスキャンはすべて 今日のスキャンに含まれます。 今日行なったスキャンの結果を開くには、これをクリックと、スキャンサマリーウィンドウが表示されます。 それより以前に行なわれたスキャンは最近のアイテムのセクションに表示されます（下記の11番を参照）。

9

今日行なった導入はすべて 今日の導入に含まれます。 今日行なった導入の結果を開くには、これをクリックすると、導入サマリーウィンドウが表示されます。 それより以前に行なわれた導入は最近のアイテムのセクションに表示されます（下記の11番を参照）。

10

詳細情報

導入テンプレートは、パッチ導入で使用した設定を保存し、後の導入で簡単に利用できるようにするものです。 標準テンプレートの設定を表示するには 標準をクリックします。 新しいテンプレートの作成を行なうには、新しい導入テンプレートをクリックします。

11

最近のアイテムは、最近行なったパッチのスキャンや導入のリストを表示します。 アイテムを選択してクリックすると、そのアイテムの結果が開きます。 15日経過すると、このウィンドウのアイテムはアーカイブのウィンドウに移動します。(この日 数は、［ツール > オプション > アプリケーションオプション > 表示］で設定できます。)

12

HFNetChkProでスキャンされた様々なオペレーティングシステムやアプリケーションのパッチに関する詳細情報を表示します。 MSSecure XML ファイルにリストされているパッチの全リストを表示するには、 すべてのパッチをクリックします。

ソフトウェアの特定のバージョンに関するパッチ情報を表示するには、製品名の左の + 印をクリックします。 Gold、SP1などのバージョンそれぞれに関連する別のパッチがあります。 著しく重複している部分もありますが、この情報ツリーを使えば特定のシステムでどのパッチが利用できるかがわかり、それらに関する情報を読むことができます。 パッチについてさらに詳しい情報を入手するには、希望するソフトウェアパッケージとバージョンをクリックします。 右上のウィンドウにパッチのリストが表示され、この中からパッチを選択してクリックすると、さらに詳細が表示されます。

13

ユーザーインターフェースのこの部分に、ステータスメッセージが表示されます。 HFNetChkProのアップデートが利用可能な場合は、その通知がここに表示されます。


事前に必要なファイルのスキャン

正しくスキャンが行なわれるためには、以下の基準が満たされていなければなりません。

ローカルマシンをスキャンする場合

  • ローカルマシンのシステム管理者であること。

  • マシンが、インターネット上のサイト（httpまたはhppsを通じて）、あるいは別の具体的な場所（ローカルマシン上またはネットワーク内で指定される場所）からパッチでターベースXMLファイルを入手できること。

  • ローカルマシンのワークステーションサービスが開始されていること。
    （注：サーバーサービスはローカルマシンで開始される必要はありません。）

リモートマシンをスキャンするには、上記のローカルスキャンに必要な項目すべてに加えて以下が必要となります。

  • リモートマシンにローカルの管理者権限を有していること、またこのマシンにスキャンを行なうワークステーションからログオンできること。

  • ファイルとプリント共有ができること。

  • リモートマシンから、NetBIOS (tcp139) または Direct Host (tcp445) ポートにアクセスできること。

  • リモートマシンでサーバーサービスが実行されていること。
    （注：サーバーサービスはリモートマシンで開始される必要はありません。）

  • リモートマシンでリモートレジストリサービスが実行されていること。

  • リモートマシンで %systemroot% シェア (通常は C$ またはそれと同様) がアクセス可能であること。

Windows XPとSimple File Sharingに関する特別な注意

Simple File Sharingが使用可能になっている場合、リモートユーザーは全員ゲストとして認証されるので、リモートマシンのシステム管理とレジストリ編集はリモートコンピュータから予期されるように機能せず、また管理者シェア（C$など）の接続ができません。 ゲストアカウントとは管理者特権を有しません。

Windows XP Professional を使用している場合は、次のMicrosoft Knowledge Baseアーティクルを参照して、この機能とSimple File Sharingを使用不可にする方法を学んでください。

http://support.microsoft.com/default.aspx?scid=kb;ja-jp;304040

Windows XP Home Editionを使用している場合は、Simple File Sharing機能を使用付加にすることができないので（Microsoftではこのようにデザインしていると述べています）、リモートスキャンはこのオペレーティングシステムでは使えません。


QuickScan と FullScan

QuickScan と FullScan はHFNetChkPro 4で提供されているデフォルトのスキャンテンプレートです。 この2つのテンプレートの主な違いは次の点です。

  • A QuickScan はファイルチェックサムを評価しませんが、 FullScan は評価します。 その結果、 QuickScan のほうが速くなります。

  • FullScan はスキャン中に注や警告を表示します。

どちらのスキャンテンプレートも変更することはできず、以下の特徴があります。

  • xml.shavlik.comからのパッチデータを使用します。

  • スキャンエンジンは64台のマシンまで同時にスキャンできます。

  • インストールされているブレティンや不足しているブレティンをすべてレポートします。

これらのデフォルトテンプレートでは不十分な場合は、 新しいスキャンテンプレートを作成することができます。


ドラッグアンドドロップ スキャン

スキャン対象、スキャン方法、パッチグループ または導入テンプレート からアイテムを該当する相手側アイテムにドラッグしてドロップすることで、スキャンを簡単かつ迅速に開始することができます。

たとえば、マイ マシン を QuickScan を使ってスキャンする場合は、マイ マシン アイコンをサイドバーから QuickScan アイコンにドラッグします。

ドラッグアンドドロップスキャンのもう一つの方法として、カスタム マシングループのスキャンをあらかじめ指定された パッチグループの中で行なうには、マシングループアイコンやその他の スキャン対象 アイテムを サイドバーから希望するパッチグループアイコンまでドラッグできます。

この方法でスキャンを開始する場合はスケジュールウィンドウが表示され、そのウィンドウから 今すぐスキャン をクリックしてスキャンを開始します。


スキャン実行ダイアログ

パッチスキャンを実行しようとすると、このダイアログボックスが表示されます。

いつスキャンを実行するかを決める3つの選択肢があります。 最初の選択肢は 今すぐ実行で、 今すぐスキャン ボタンをクリックすると同時にスキャンが開始されます。 二番目の選択肢は一度実行する時間で、選択された日時にスキャンが実行されます。 最後の選択肢は 毎回実行する時間で、システム管理者が指定の日時に指定の反復方法で定期的にパッチスキャンを行なえるようにします。 たとえば、このオプションを使えば、毎晩午前零時、あるいは土曜日の午後9時、月曜日から金曜日まで毎晩午後11時など、指定した時間に指定の間隔でスキャンが実行できます。

このダイアログを再び表示しないを選択すると、これ以後はスキャン実施のスケジュール設定を省略して、ただちにスキャンが実行されるようになります。 このオプションを選択した後で、再度このプロンプトを使用可能にしたい場合は ツール > オプション > スキャンオプション で［今すぐ実行]ダイアログを表示を選択します。

スキャン後にパッチを自動導入 を選択すると、スキャン実行ウィンドウが拡大されて、パッチがいつ、どのように導入されるかが選択できるようになります。

注： スキャン後にパッチを自動導入のオプションは、 今すぐ実行が使用可能になっているときだけ選択できます。 スケジュール済みスキャンでは使えません。

導入方法 ドロップダウンボックスには、このスキャンで使用できる導入テンプレートがリストされています。 新しい導入テンプレートを作成するには、 新規ボタンをクリックします。

さらに、ただちにインストールをクリックするとスキャン後ただちに導入が開始され、 スケジュール時を選択すると後の日時に導入が行なわれるよう指定できます。

選択したパッチをリモートマシンに（導入バッチファイルとともに）コピーしたいが、パッチのインストールはしたくない、という場合には、［パッチを選択されたマシンに、インストールせずにコピーします］オプションを選択することができます。 こうすると、リモートマシンのコンソールから手動でバッチファイルが実行できます。

希望のオプションを選択したら、今すぐスキャン ボタンをクリックします。

スキャンのスケジュールを設定するには、システム管理者がテンプレートとスキャンするマシングループを定義する お気に入りを作成することが必要です。 新しいお気に入りを作成するのに必要な情報を尋ねるメッセージが今すぐスキャン または お気に入りの作成 ボタンをクリックした後で表示されます。 さらに、スケジュール済みタスクがスキャンするマシンに作成され、指定の日時にスキャンを開始します。 スケジュール済みタスクを表示するには、導入されるコンピュータで ［スタート > コントロールパネル > スケジュール済みタスク］を選択するか、リモートでタスクスケジューラを表示します。


セキュリティ属性の入力

セキュリティ属性は、スキャンされ、パッチが導入されるマシンのユーザー認証に使用されるユーザー名とパスワードから構成されます。 デフォルトでは、 HFNetChkPro 4 は、ターゲット マシン(複数の場合もあり) に自動的にログインしてスキャンし、パッチのコピーや導入を行なうのに現在用いられているログオン時のセキュリティ属性を使用します。 現在ログインしているユーザーセキュリティ属性に管理者権限が含まれない場合は、別のセキュリティ属性を入力することが必要です。 HFNetChkPro 4は、入力された別のセキュリティ属性を使って自動的にターゲットマシンにログインします。 どの場合でも、セキュリティ属性は強力な暗号技術を使って保存され、このセキュリティ属性を入力した本人以外が利用することはできません。

  • ドメイン\ユーザーを入力すると、 HFNetChkPro 4はドメインアカウント権限を使用します。

  • <Target Machine>\Userを入力すると、HFNetChkProはターゲットのローカルアカウント権限を使用します。

  • マシン名やドメイン名を入力しないと、スキャナはconsolemachinename\userを使おうとします。 これに成功しないと、次にremotemachinename\userを使用することを試みます。

  • '.\username' はスキャナがリモートマシン名をユーザー名の先頭に追加するようにします。

マシンにセキュリティ属性を指定

個々のマシンやマシングループにセキュリティ属性を指定することができます。

マシン グループ

マシングループのすべてのマシンにセキュリティ属性を指定するには、そのグループのプロパティを開きます。 をクリックすると（ グループセキュリティ属性 の下にあります）、セキュリティ属性の設定 ダイアログボックスが開きます。 そのグループに該当するセキュリティ属性を入力し、OKをクリックします。

詳細は マシングループについてをご覧ください。

スキャンするコンピュータを選択

セキュリティ属性は、HFNetChkProのホームページのスキャンするコンピュータを選択 オプションを使っても入力することができます。 システム名、ドメイン、IPアドレスまたはIPアドレス範囲をクリックし、ショートカットメニューから セキュリティ属性の設定/変更 を選択します。 セキュリティ属性が適用されると、 [image] が [image] に変わります。

スキャン後

スキャンインターフェース

特定のマシンに別のセキュリティ属性を適用するには、スキャン後、スキャンサマリーのマシン名を右クリックします。

セキュリティ属性の設定 ウィンドウに、システムの管理ユーザーのセキュリティ属性を入力します。

メニューの使用

セキュリティ属性を適用するのには、 マシン > セキュリティ属性の変更 を使うこともできます。この場合、マシンはマシンサマリーから選択します。


スキャン履歴

一連のスキャンを終えた後でも、これまで行なったスキャンの結果がクリックひとつで取得できます。 今日スキャンを行なった場合には、 今日のスキャンというタイトルのウィンドウがHFNetChkPro 4の左部分に開きます。 このリストの上でマウスを動かすと、下図のような情報が表示されます。

その日が終了すると 今日のスキャンは画面の左側、ほぼ一番下の 最近のアイテムと名付けられたアーカイブに移動します。 最近のアイテム には、スキャンだけでなく最近行なわれた導入も含まれています。

さらに、［ツール > アイテムの管理］を選択して、これまでに行なったスキャンの詳細リストを取得することもできます。

これらの項目はすべて、最近のアイテム にも表示されます。 特定のスキャン履歴を削除したいときには、希望のアイテムを選択し、選択したものを削除 をクリックします。 スキャン履歴をすべて削除するには、すべて削除 を選択します。


スキャンオプションメニュー

追加のスキャンオプションを ツール > オプション > スキャンオプション メニューで設定できます。

デフォルトのお気に入り | パッチスキャンを行なうときにデフォルトとして設定したい お気に入り。
デフォルトのスキャン テンプレート | パッチスキャンを行なうときにデフォルトとして設定したい スキャンテンプレート。
スキャン後にステータス ダイアログボックスを閉じる | スキャン終了後、スキャンステータス を自動的に閉じる。
[今すぐ実行]ダイアログを表示 | HFNetChkPro 4 ホームページ の マイコンピュータのスキャン または マイ ドメインのスキャン アイコンの詳細 をクリックした後で スキャン実行 ウィンドウを表示します。 ［このダイアログを再度表示しない］を選択すると、スキャン実行 ウィンドウが表示されなくなります。
スキャン中に自動的にパッチ詳細をインポート | スキャンが実行されるたびに、パッチ詳細がパッチデータファイルからインポートされます。
パッチ データ ファイルのキャッシュされたコピーを使用する場合に警告します。 | HFNetChkPro 4がパッチデータファイルのキャッシュされたコピーを使ってパッチスキャンを行なおうとすると、メッセージが表示されます。


Quick scan

ローカルマシンでQuickScanを実行

ユーザーの介入なしでローカルマシンのスキャンをただちに開始するには、ホームページの マイ コンピュータのスキャン ボタンまたはメニューバーアイコンの マイ コンピュータのスキャン ( [image]) をクリックします。 これにより、スキャンステータス ウィンドウが開きます。 このプロセス中、最新のパッチデータファイルが自動的にダウンロードされ（システム管理者がファイルのダウンロードオプションを変更した場合は別）、マシンがスキャンされた後、スキャンサマリーが表示されます。


Full Scanの実行

ローカルコンピュータでFullScanを実行

ローカルコンピュータでFullScan を開始するには、スキャン対象 ボックスの マイ マシン をクリックします。 マシン グループ ダイアログボックスが開いたら、スキャンタイプを FullScan に変更し スキャン開始 ボタン ( [image]) をクリックします。 管理者権限を持つユーザーのセキュリティ属性を適用することが必要な場合は、 ( [image]) アイコンをクリックし、適切なユーザー名とパスワードを入力します。 詳細は セキュリティ属性の入力 をご覧ください。

スキャン開始 ボタンをクリックすると、スケジュールウィンドウが表示されます。 これにより、スキャンを今すぐ実行したり、一度実行する時間や毎回実行する時間を設定することができます。

FullScanを開始するには、スケジュールウィンドウの 今すぐスキャン ボタンをクリックします。

QuickScan と同様、FullScan でもスキャンを実行する前に、最新のパッチリストがまずダウンロードされます。

アドバイス

FullScan の一番上のマイ マシン を ドラッグ アンド ドロップ してローカルマシンでFullScanを開始することもできます。


ドメインスキャンの実行

入力された セキュリティ属性 がドメインのすべてのマシンに対して適切である限り、スキャンするマシンのローカルドメイン内のすべてのマシンのスキャンをひとつのステップで自動的に行なうことができます。

ドメインスキャンはスキャンするマシンと同じドメイン内のすべてのマシンをスキャンし、以下の幾つかの方法で開始することができます。

  • まず、ホームページで、マイ ドメインのスキャン ボタンをクリックします。 これにより、ただちにスキャンが開始されます。 ドメインスキャンのスケジュールを設定するには、詳細 をクリックして好きゃジュールダイアログボックスを開き、マイ ドメイン をスキャン対象に、そしてQuickScan をスキャン方法として選択します。

  • 次に、メニューバーの マイ ドメインのスキャン [image] ボタンをクリックします。

  • その後、マイ ドメイン マシングループ を選択し、スキャン開始 アイコンをクリックします。

ドメインスキャン中、最新のパッチデータファイルが自動的にダウンロードされ（システム管理者がファイルのダウンロードオプションを変更した場合は別）、マシンがスキャンされた後、スキャンサマリー が提供されます。 スキャン中、HFNetChkProのステータスウィンドウが表示され、問題が生じた場合にはそのウィンドウで通知されます。


スキャンするマシンを選択

スキャンするコンピュータを選択

HFNetChkPro 4 では、デフォルトのQuickScanに含めるマシンを簡単に設定することができます。 ホームページの スキャンするコンピュータを選択 ボタンをクリックすると「何をスキャンしますか？」という見出しで始まるセクションが開きます。ここに、様々な条件のマシンを追加することができます。

コンピュータの追加 | ネットワークのコンピュータでスキャンしたいものの名前をタイプし、 [image] をクリックします。
IP アドレスの追加 | ネットワークのコンピュータでスキャンしたいもののIPアドレスをタイプし、 [image] をクリックします。
IP 範囲の追加 | スキャンしたいマシンのスキャン開始IPアドレスと終了IPアドレスを入力し、 [image] をクリックします。
ドメインの追加 | ドメイン名を入力すると、そのドメインのマシンすべてがスキャンされます。 ドメイン名を入力し、 [image] をクリックします。

スキャンしたいマシンの情報を入力すると、このセクションの中央に下図のようなマシンリストが表示されます。

    • このリストから項目を削除するには、その項目をクリックし、メニューから アイテムの削除 を選択します。

    • 特定の項目のセキュリティ属性を設定あるいは変更したい場合は、その項目をクリックし、 セキュリティ属性の設定/変更 を選択して、適切なユーザー名とパスワードを入力します。 項目にセキュリティ属性が設定されている場合は、 [image] が表示され、 [image] は表示されません。

    • 特定の項目からセキュリティ属性を削除するには、その項目をクリックし、セキュリティ属性の削除 を選択します。 選択を確認するようにというメッセージは表示されません。

希望のものを選択後、マシングループ を作成します。これには詳細選択 オプションを選択し、マシングループ名と説明を入力します。

デフォルトのスキャンテンプレート を使ってスキャンを開始するには、 スキャン開始 ボタンをクリックします。 別のスキャンテンプレート を使用する、あるいはこのスキャンのスケジュールを設定する場合は、 詳細スキャンオプション を選択します。


マシングループについて

HFNetChkPro 4 はマシングループを使って、特定のスキャンに含まれるマシンを管理します。 ローカルマシンの マイ マシン さえ、スキャングループと見なされます。 以下がデフォルトのスキャングループに含まれます。

マイ マシン | このグループには、ローカルマシンのみが含まれます。
マイ ドメイン | スキャンするコンピュータが属するドメイン内のすべてのマシンを含みます。
マイ テスト マシン | 実際のネットワーク環境を代表するようなマシン グループ。 通常スキャンされる各タイプのマシンがこのグループに含まれて、テストに使用されます。
ネットワーク全体 | Network Neighborhoodで現在表示可能なすべてのマシンを含みます。
新しいマシン グループ | マシンのカスタムグループを作成します。

マシングループの詳細を表示するには、タイトルをクリックします。 下の例では、マイ マシン の詳細を示しています。

各マシングループの詳細には、幾つかの共通事項があります。

  • マシングループの詳細画面にはすべて、スキャン開始 ボタンと、利用できるスキャンテンプレートを示すドロップダウンリストがあります。

  • 各マシングループは、グループ内のすべてのマシンに共通のセキュリティ属性を提供することができます。 （マシングループ内の個々のマシンに指定されたセキュリティ属性は、指定された グループセキュリティ属性 に優先します。） これらのセキュリティ属性を変更するには、セキュリティ属性のアイコン [image] をクリックします。 セキュリティ属性が適用されると、アイコンが [image] のように表示されます。

  • ウィンドウの右側のグループ名の下に、少なくとも3つのオプションが上の図のように表示されます。

    コピー

    このマシングループを新しいグループにコピーします。 このボタンをクリックすると、新しいマシングループの作成 ダイアログボックスが表示され、デフォルト名の「（コピーされるグループ名）のコピー」とコピーされるグループと同じ説明が示されます。 この情報を入力すると、新しいグループにマシンを追加するようにというメッセージが表示されます。

    すべてを表示

    表示可能な複数のマシンを持つグループでは、グループ内のすべてのマシンが表示されます。 デフォルトマシングループの マイ マシン と マイ ドメイン は列挙されないことに注意してください。

    すべてを非表示

    このグループのマシン名を非表示にします。


マシングループの作成

新しいマシングループを作成するには、スキャン対象 ボックスから 新しいマシングループ をクリックします。 またはメインメニューから［ファイル > 新しいマシングループ］を選択することもできます。 これにより、新しいマシングループの作成 ダイアログボックスが下のように表示されます。

このボックスに、新しいマシングループの特徴を説明する名称（例、Win2K DCs）とコメント（例、'Windows 2000 Domain Controller machines）を入力します。 保存 ボタンに続けて 閉じる ボタンをクリックし、新しいグループを作成するか、キャンセル または 閉じる をクリックして操作を中止します。

アドバイス

スキャン結果から複数のマシンを選択し（CTRLキーを押しながらマシンを選択）、右クリックして グループの作成 を選択し、マシングループを作成することもできます。


マイ テスト マシンについて

マイ テストマシン グループについて

重要なプロダクションシステムでの展開を行なう前に、パッチやサービスパックのテストを行なうことの重要性は、多くのシステム管理者が痛感していることです。 Shavlikではこうしたニーズに応え、この目的で使用するためのデフォルトグループを用意しました。

このグループは、他のグループと同じように使用できます。 ラボマシンまたは優先度の低いプロダクションシステムを追加するだけです。 ネットワークのプロダクションシステムをカバーするためには、グループ内にマシンをうまく選りすぐって含めることが必要です。

このグループにマシンを追加するにあたっての詳細は、以下のトピックを参照してください。

  • マシン名でマシングループにマシンを追加

  • グループにドメインを追加

  • グループにorganizational unitsを追加

  • IPアドレスでマシンを追加

  • マシングループにファイルをリンク


マシングループの設定

マシングループの設定には、新しいマシンの追加とマシンの削除が含まれます。 HFNetChkPro 4 はマシングループに卓越した柔軟性を提供し、一台のマシンあるいは複数のマシンの追加、IPアドレスによるマシン追加、さらにはファイルリストからのマシン追加までを可能にしています。

マシングループ設定ウィンドウの一番上にグループのタイトルが、そしてそのすぐ下に幾つかのオプションが表示されます。

コピー | このマシングループのコピーを作成します。 このオプションを選択すると 新しいマシングループの作成 ダイアログボックスが開きます。 グループ名は「（マシングループ名）のコピー」とあらかじめ定義され、説明もコピーされていますが、どちらも変更することができます。
削除 | 選択したマシングループを削除します。 削除を確認するウィンドウが開きます。
名称変更 | グループの新しい名前と説明を入力するウィンドウが開きます。
すべてのエンティティを削除 | このグループに指定されたすべてのマシンを削除します。 このオプションを選択すると、削除を確認するウィンドウが開きます。
すべてを表示 | マシングループ内のすべてのメンバーを表示します。
すべてを非表示 | マシングループ内のすべてのメンバーを非表示にします。 その結果、各小見出しの見出しだけが表示されます。


マシン名でマシンを追加

マシン名によるマシングループへのマシンの追加

マシングループにマシンを追加する方法のひとつに、マシン名を使うものがあります。 HFNetChkPro 4の他のタスクのほとんどと同様に、使用するマシン名を提供するために多くの方法が用意されています。

最初の方法は最も簡単な方法で、マシングループに追加するマシン名をタイプして [image] をクリックするものです。

ネットワークの参照 | Microsoftネットワークのすべてのコンテントをリストしたウィンドウが開き、各ドメイン、ワークグループ、マシン名の隣に選択用のボックスが表示されます。 各グループの横の + と - の記号を使って、これらを拡大してカスタムグループに追加するマシンを探し、選択用ボックスにチェックマークを付けます。
インポート元のファイル | 指定のテキスト ファイルからマシン リストをインポートできます。 テキストファイルからインポートする代わりに、マシン名を動的にテキストファイルにリンクさせることもできます。
すべてのマシンを削除 | グループからすべてのマシンを削除するには、このオプションを選択します。

マシンがマシン名で追加されている場合、個々のマシンがネットワークブラウザから選択されているか、ファイルからマシン名が追加されています。このセクションに新しい項目が表示されます。

をクリックすると、その項目がただちに削除されます。 アイコンをクリックすると選択したマシンのセキュリティ属性が変更できるようになります。 特定のマシンにセキュリティ属性が適用されると、このアイコンは [image] のように表示されます。


ドメインの追加

グループにドメインを追加

マシングループにマシンを追加するもうひとつの方法は、ドメインによるものです。 マシングループをドメインに追加すると、ドメイン メンバーシップの特性によって、ドメイン内のすべてのマシンが自動的にグループの一部になります。

最初の方法は最も簡単な方法で、マシングループに追加するドメイン名をタイプして次のアイコン をクリックするものです。

ネットワークの参照 | Microsoftネットワークのすべてのコンテントをリストしたウィンドウが開き、各ドメイン、ワークグループ、マシン名の隣に選択用のボックスが表示されます。 各グループの横の + と - の記号を使って、これらを拡大してカスタムグループに追加するドメインを探し、選択用ボックスにチェックマークを付けます。
インポート元のファイル | 指定のテキスト ファイルからドメイン名をインポートできます。 テキストファイルからインポートする代わりに、ドメイン名を動的にテキストファイルにリンクさせることもできます。
すべてのマシンを削除 | グループからすべてのドメインを削除するには、このオプションを選択します。

ドメインがドメイン名で追加されている場合、個々のドメインがネットワークブラウザから選択されているか、ファイルからドメイン名が追加されています。このセクションに新しい項目が表示されます。

をクリックすると、その項目がただちに削除されます。 アイコンをクリックすると選択したマシンのセキュリティ属性が変更できるようになります。 特定のマシンにセキュリティ属性が適用されると、このアイコンは [image] のように表示されます。


Organizational Unitで追加

グループにOrganizational Unitを追加

特に大きなネットワークの場合、企業は複数のOrganizational Unitを作成してActive Directoryを分割することがしばしばあります。 HFNetChkPro 4 のマシングループはActive Cirectoryの特定のOrganizational Unitを含むことができます。 たとえば、営業部門のマシンをすべて含むマシングループを作成することができます。

マシングループにorganizational unitを追加する最も簡単な方法は、名称をタイプして [image] をクリックするものです。 LDAPのフルフォーマットにOUが追加されます。 たとえば、domain example.comからSales OUを追加するためのフォーマットは example/ou=sales,dc=example,dc=com です。

親OUを選択すると、すべての子OUがスキャンに含まれます。

アクティブ ディレクトリの参照

Microsoftネットワークのすべてのコンテントをリストしたウィンドウが開き、各ドメインとワークグループの隣に選択用のボックスが表示されます。 各グループの横の + と - の記号を使って、これらを拡大してカスタムグループに追加するorganizational unitまたは個々のマシンを探し、選択用ボックスにチェックマークを付けます。

リモートドメインのActive Directory階層の参照に使用するセキュリティ属性を設定するには、ドメインを選択して セキュリティ属性の設定 ボタンをクリックし、リモートドメインへの許可を持つユーザー名とパスワードを入力します。

すべての Organizational Unit の削除

グループからすべてのorganizational unitを削除するには、このオプションを選択します。

Organizational unitセクションに項目が追加されると、他の情報の下に表示されます。

をクリックすると、その項目がただちに削除されます。左側の [image] アイコンをクリックすると選択したorganizational unitのセキュリティ属性が変更できるようになります。 右側の [image] をクリックすると、Active Directoryを参照するためのセキュリティ属性を指定することができます。 セキュリティ属性が適用されると、アイコンが [image] のように表示されます。


IPアドレスでマシンを追加

IPアドレスによるマシングループへのマシンの追加

マシングループにマシンを追加する3番目の方法は、IPアドレスによるものです。 この方法でグループにマシンを追加するのには、2つの方法があります。 ひとつは単一のIPアドレスを追加するもの、もうひとつはIPアドレス範囲を追加するものです。

最初の方法は最も簡単な方法で、マシングループに追加するマシンのIPアドレスをタイプして [image] をクリックするものです。 同様に、マシングループにIPアドレス範囲を追加するには、IP範囲の追加セクションに希望する 範囲の開始点と終了点を入力し、 [image] をクリックします。

インポート元のファイル | 指定のテキスト ファイルからIPアドレスまたはIP範囲をインポートできます。 テキストファイルからインポートする代わりに、IP情報を動的にテキストファイルにリンクさせることもできます。 IP範囲は、IPアドレスの開始点と終了点の間にダッシュを含みます。 172.16.1.1-172.16.1.255
すべての IP アドレスの削除 すべての IP 範囲の削除 | すべてのIPアドレスまたはIP範囲をグループから削除する場合に、このオプションを選択します。

マシンがIPアドレス/IP範囲で追加された場合、あるいはIPアドレスのファイルから追加された場合には、新しい項目がこのセクションに表示されます。

をクリックすると、その項目がただちに削除されます。 アイコンをクリックすると選択したIPアドレスまたはIPアドレス範囲のセキュリティ属性が変更できるようになります。 IPアドレス範囲にセキュリティ属性を適用すると、その範囲のすべてのマシンで使用されるようになります。 セキュリティ属性が適用されると、アイコンが [image] のように表示されます。


マシングループにファイルをリンク

HFNetChkPro 4 では、マシングループを最新状態に維持するダイナミックメカニズムを提供しています。これは、マシングループが時折変更され、アップデートするための簡単な方法が必要なときに特に役立つ機能です。 マシングループにファイルをリンクすることは、コンテントをインポートするのとは異なるものです。 コンテントのインポートは一度だけの操作で、そのファイルからインポートされた情報はマシングループの一部となります。

マシングループにファイルをリンクすると、そのファイルに加えた変更はすべて以後のスキャンに反映されます。 つまり、スキャン終了後から次のスキャンを行なうまでの間にリンクされたファイルにマシンを追加したり、ファイルからマシンを削除した場合、次のスキャンでは追加したマシンはスキャンされますが、削除したマシンはスキャンされません。

マシン ファイルのリンク | マシン名を含むファイル名を入力します。 一行にマシン名をひとつだけ入力し、改行します。 サンプル: machine1 machine2 dc mail dbserver
ドメイン ファイルのリンク | ドメイン名を含むファイル名を入力します。 一行にドメイン名をひとつだけ入力し、改行します。 サンプル: example shavlik corp redmond dmz
IP アドレス ファイルのリンク | IPアドレスを含むファイル名を入力します。 一行にIPアドレスをひとつだけ入力し、改行します。 サンプル: 192.168.29.132 10.1.1.10 172.16.1.5
IP 範囲ファイルのリンク | IP範囲を含むファイル名を入力します。 IP範囲として容認されるフォーマットは x.x.x.x-y.y.y.y です。 一行にひとつだけ入力し、改行します。 サンプル: 192.168.29.1-192.168.29.5 172.16.2.20-172.16.2.99
すべてのリンク ファイルを削除 | グループにリンクされたファイルをすべて削除します。

ファイルが追加されると、下の画面のようなセクションが表示されます。

をクリックすると、その項目がただちに削除されます。 アイコンをクリックすると選択したファイルのセキュリティ属性が変更できるようになります。 ファイルにセキュリティ属性を適用すると、そのファイルのすべてのマシンまたはIPアドレスで使用されるようになります。 セキュリティ属性が適用されると、アイコンが [image] のように表示されます。


スキャンテンプレートについて

HFNetChkPro 4 には2つの標準テンプレートが用意されています。QuickScan と FullScan がその２つです。 これらはほとんどのスキャン操作に十分なものですが、システム管理者によってはマシンのスキャンにさらに高いレベルの柔軟性を求めることがあります。 このため、HFNetChkProでは、システム管理者がスキャンするマシンに合わせて完全にカスタマイズしたカスタムスキャンテンプレートを作成できる機能を搭載しています。

スキャンテンプレートは以下の情報を含みます。

  • XMLデータファイルの場所

  • チェックサムが評価されるかどうか

  • 警告と注を使用あるいは使用しないようにする機能

  • 小数あるいは多数のマシンを同時にスキャンするオプション

  • ログファイルを作成するオプション

  • 何をスキャンするか、あるいは無視するかをカスタマイズする機能

  • パッチフィルタ

  • 自動導入を行なうためにスキャンテンプレートと導入テンプレートを関連させる機能


スキャンテンプレートの作成

新しいスキャンテンプレートを作成するには、スキャン方法 メニューから 新しいスキャンテンプレートの作成 オプションをクリックします。 これにより、利用できるスキャンテンプレートのオプションのほとんどを含むウィンドウが表示されます。

名称

このスキャンテンプレートに付ける名前

コメント

テンプレートの説明

スキャナ設定

XMLデータファイルの保存場所はどこですか？ ShavlikからダウンロードしたデフォルトのMSSecure XMLデータファイルをスキャン中に使用できるほか、ローカルマシンに保存されているこのファイルのローカルコピー、マップされたネットワークドライブ、UNCロケーション、あるいはHTTPパスをスキャンエンジンに指定することができます。 場所を選択するには、項目の隣の選択用ボックスをクリックします。

チェックサムを使用

スキャンエンジンに、スキャンされるシステムのファイルのチェックサムとパッチデータベースファイル（mssecure.xml）を評価するよう指示します。 英語以外の言語のシステムをスキャンする場合、チェックサムは評価されません。

警告を表示

スキャン中に発生した警告をすべて表示します。

注と警告を表示

スキャン中に発生した注と警告をすべて表示します。

スキャナ ログ ファイルを作成

スキャンプロセスにログファイルを作成します。 これは、問題に遭遇してShavlikのサポートに連絡が必要な場合に特に役立ちます。

同時にスキャンされるマシン

HFNetChkPro 4 では同時に64台までのマシンをスキャンすることができます。 スキャンされるマシンが多くなるほど、必要とされるレットワークリソースも増加します。 速度の遅いリンクでスキャンする場合は、この数を減らしてください。

スキャン対象

スキャン中に不足しているパッチだけを対象とするのか、不足しているパッチとインストールされているパッチの両方を対象とするのかを選択することができます。 不足しているパッチとインストールされたパッチの両方を対象とする場合は、 正しくインストールされたパッチ を結果に含むことができます。

フィルタ パッチ

フィルタ パッチのオプションを選択すると、スキャンテンプレートのダイアログボックスが開き、幾つかの基準に基づいてフィルタパッチを行えるようにするオプションが表示されます。

指定された項目をスキャン | スキャナに以下の基準だけを含むことを示します。
指定された項目を省略 | スキャナに 以下の項目を含めないことを示します。
最大深刻度 | ユーザーが指定した深刻度レベル - 無視、低、中、高、クリティカル - のいずれをスキャナが省略すべきか含めるべきかを決めます。
ファイル | Qnumbersの無効な改行区切りで指定されたパッチをスキャンするか無視するかを決めます。
パッチ グループ | 特定のパッチグループにリストされているパッチをスキャンするか省略するかを決めます。
製品の種類 | 選択された製品のパッチをスキャンするか省略するかを決めます。

自動導入

導入テンプレート を使って、スキャンテンプレートに関連したパッチを自動的に導入できるようにします。?ご注意ください： スキャンテンプレートが自動導入を使用するよう設定されていて、そのスキャンテンプレートが スケジュール済みスキャン で使用されている場合には、自動導入は行なわれません。 これは予想される状態で故障ではありません。

このスキャンテンプレートに必要な選択をすべて行なったら 保存 と閉じる ボタンをクリックして選択した内容を保存します。 変更を保存せずにウィンドウを閉じるには、キャンセル または 閉じる ボタンをクリックします。


スキャンテンプレートの操作

カスタムスキャンテンプレートは右の図のように、スキャン方法 ボックス の新しいスキャンテンプレート の下に表示されます。 スキャン方法 ボックスからテンプレートが選択されると、ウィンドウの右部分にその詳細が表示されます。

たとえば、「Sample scan template」という名前のスキャンテンプレートが選択されたとすると、次のような画面が表示されます。

この画面から実行できる操作が幾つかあります。

これをデフォルトのマイ テンプレートにする | このオプションを選ぶと、現在選択されているテンプレートがデフォルトとして使用されます。
編集 | この編集オプションを選ぶとスキャンテンプレートダイアログボックスが表示され、変更が追加できるようになります。
コピー | 選択したテンプレートをコピーします。 これを選ぶと、「（選択されたテンプレート名）のコピー」と名付けられたスキャンテンプレートダイアログボックスが開き、現在のテンプレートと同じ説明と設定が表示されます。
削除 | 現在のテンプレートを削除します。

お気に入り が作成されていて、このテンプレートがそれに指定されている場合は、どの お気に入り （単数または複数）が使用されているかが表示されます。


デフォルトのスキャンテンプレートを指定

HFNetChkPro 4 のどのスキャンテンプレートをデフォルトとして使用するかを指定するには、次のうちの1つの方法を取ります。

スキャンテンプレートの詳細で、［これをデフォルトのスキャンテンプレートにする］を選択します。 または、テンプレートのアイコンを右クリックして、ショートカットメニューから［デフォルトの作成］を選択します。 あるいは、［ツール > オプション > スキャンオプション > 一般］を選び、デフォルトスキャンテンプレートを指定します。

デフォルトテンプレートを指定すると、スキャンテンプレートを示していたアイコンが僅かに変わり、 [image] のように緑のチェックマークが追加されます。 さらに、このテンプレートは、クリックするだけで開始されるすべてのスキャン操作で使用されるようになります。


パッチグループについて

HFNetChkPro 4 には調べたいパッチだけをスキャンする機能があります。 たとえば、A会社のパッチ承認制度では４つのパッチを組織の必須パッチとして認定しているとします。 これらの4つだけをスキャンし、準拠報告書を受け取り、次に、これらの特定の項目をパッチできるようにすることを希望しています。 パッチグループを作成することにより、これらの選択されたパッチだけをスキャンできるようにできます。

たとえば、パッチ03-013があなたの組織にクリティカルなパッチだとします。 このパッチだけでパッチグループを作成することができます。 グループを作成するには、リストからパッチを参照し、製品とサービスパック、パッチを選択します。 HFNetChkPro 4 は選択された製品とサービスパックだけでなく、QNumberのすべてのインスタンスをスキャンします。 パッチグループをマシングループの上にドラッグ アンド ドロップして、選択したパッチ(03-013)だけがスキャンされるようにすることもできます。 注：HFNetChkPro 4 が選択したパッチをスキャンする場合には、特定のパッチだけをスキャンするよう指定していても、常にすべてのサービスパックをスキャンしてすべてのサービスのステータスをレポートします。


パッチグループの作成

パッチグループを作成するには２つの方法があります。 最もわかりやすい方法は、コンソールの左側のパッチグループの下にある新しいパッチグループ をクリックするものです。 これにより、パッチグループ設定ダイアログボックスが表示されます。 このダイアログボックスに、新しいパッチグループの名前、グループに指定するパッチのリスト、コメントを入力します。

名称 | このパッチグループに付ける名前。
選択されたパッチ | このグループにパッチを追加するには、参照 ボタンをクリックします。 これにより、現在利用できるパッチをすべてリストしたウィンドウが、左の図のように表示されます。 グループにパッチを指定するには、リストを参照し、グループに含めたいパッチの横のボックスにチェックマークを付けます。 このリストはブレティンIDまたはQNumber別に並べ替えることができます。 作業が終了したら OK ボタンをクリックします。
コメント | パッチグループに関連するコメント。

作業が終わったら、保存 と 閉じるをクリックします。

パッチグループを作成するもうひとつの方法

通常のスキャンを行なった後、不足しているパッチとインストールされたパッチのリストを表示し、SHIFTキーまたはCTRLキーを押しながら、この結果から複数のパッチを選択します。 右クリックして マッチグループの作成を選択します。 これにより、パッチグループの中でこれらのパッチをスキャンして、レポート機能から準拠レポートを作成できるようになります。


パッチグループの操作

パッチグループが作成されたら、コンソールの左側のパッチグループを選択して、グループ内に何が含まれているかを見ることができます。

パッチグループにパッチを追加したり、グループから削除するには、パッチグループ名をダブルクリックします。 これにより、パッチグループ設定ウィンドウ が表示されます。

希望するスキャンテンプレートでパッチを使用するには フィルタ パッチ を選択し、指定した項目をスキャン または指定した項目を省略 のどちらかを選び、作成したパッチグループを選択します。

これで、パッチグループが ドラッグ アンド ドロップ スキャン で使用できるようになります。


お気に入りの作成

お気に入りはスキャンするマシンの集合とそれらのマシンのスキャン方法です。 新しいお気に入りを作成するには、新しいお気に入り をクリックします。 お気に入りにはローカルマシンあるいは スキャン対象 で作成された特別のグループのどれでも追加することができ、スキャンタイプは2つの標準スキャンのいずれか、あるいは新しいスキャンテンプレートを選ぶことができます。

新しいお気に入りを作成すると、新しいお気に入りオプションの下に お気に入り ウィンドウが表示されます。 お気に入りには次の3つの情報が必要とされます。

  • 名称 。これは 新しいお気に入り オプションが選択されたときに定義されます。

  • スキャン対象 項目。 これには、マイ マシン、マイ ドメイン、ネットワーク全体 またはスキャン対象を使って作成されたマシングループをどのようにでも組み合わせることができます。

  • スキャン方法 項目。 これには、QuickScan、FullScan 、または スキャン方法.を使って作成したカスタムスキャンテンプレートから選択した項目を含めることができます。

以下の手順にしたがって、新しいお気に入りを作成します。

  1. お気に入りに「Domain Controllers」などの独自の名称を付けます。

  2. 必要であれば、コメントも追加します。 例、「このお気に入りにはFullScanを使用するドメインコントローラのみを含む」など。

  3. これをデフォルトのお気に入りとして使用する場合は、これをデフォルトのわたしのお気に入りにする の横のボックスにチェックマークを付けます。

  4. スキャン対象 ボックスで、このお気に入りに含めるマシンを選択します。 希望するマシングループがリストにない場合は、新規 ボタンをクリックして、新しいマシングループを作成します。 複数のマシングループを選択することができます。

  5. スキャン方法 ボックスから、実行するスキャンタイプを選択します。

  6. 保存 ボタンをクリックし、新しいお気に入りを保存します。

ホームページの新しいお気に入り セクションの下のお気に入り に、新しい項目が表示されます。


スキャンサマリー結果

スキャン結果の解釈： スキャンサマリー

スキャンサマリーは、スキャン日、パッチデータを含むXMLファイルのバージョンと日付、スキャンマシンと使用されたテンプレートなどの情報を提供します。

サマリーの下半分には、スキャン中に発見された事柄が表示されます。

スキャン日 | スキャンが行なわれた日付と時刻。
使用されている XML バージョン | スキャンを行なうのに使用されたmssecure.xmlのバージョン。
XML 日 | 前述のファイルの日付。
スキャン実行者 | スキャンを行なったユーザーの名前。
使用されているテンプレート | スキャンを行なうのに使用されたテンプレート。
スキャンしたマシン | スキャンされたマシン数。 ローカルスキャンを行なう場合、この数は常に1となります。
スキャンされていないマシン | スキャンされなかったマシン数。 スイッチが入っていないマシンは省略されます。あるいは、スキャン実行を阻む何かがあったと見られます。
不足しているサービスパック | スキャンされたマシン間で不足しているサービスパック数の合計。
不足しているパッチ | スキャンされたマシン間で不足しているパッチ数の合計。
見つかったパッチ | スキャンされたマシン間で見つかったパッチ数の合計。


マシンサマリー結果

スキャン結果の解釈： マシンサマリー

HFNetChkPro 4 は様々な方法で膨大な量の情報を提供します。 画面の上部のウィンドウには選択されたスキャンのコンピュータとスキャン結果の一覧が表示されます。

コラムの見出しをクリックして、情報別に表を並べ替えることができます。

このウィンドウには、スキャンされた各マシンで発見された事柄の概要が表示されます。 上に示されている概要から、XP2という名称のコンピュータにパッチが16インストールされており、サービスパック1つとパッチ1つが不足していることがわかります。 Win2Kという名称のマシンではパッチ26個とサービスパック3つが不足、WINNTでは19のパッチが不足しています。

スキャンされたシステムに、パッチリストのパッチが幾つインストールされているかを示します。

スキャンされたシステムで、非代替パッチが幾つ不足しているかを示します。

スキャンされたシステムで、サービスパックが幾つ不足しているかを示します。

クリティカルなパッチ数を示します。

重大深刻度の高いパッチ数を示します。

重大深刻度が中程度のパッチ数を示します。

重大深刻度が低のパッチ数を示します。

無視されているパッチ数を示します。

マシンリストからマシン名をダブルクリックすると、画面の通知部分にマシン結果が表示されます。

このサマリーには、マシンにインストールされている正確な製品名や各製品のパッチステータスなどの詳細情報が表示されます。

見つかったパッチ | スキャンエンジンが、スキャンシステムにすでにインストールされていることを発見したパッチ数
不足しているパッチ | スキャンエンジンによって不足していることが発見された非代替パッチ数
不足しているサービスパック | スキャンエンジンによって不足していることが発見されたサービスパック数


パッチサマリー結果

スキャン結果の解釈： パッチサマリー

特定のマシンのパッチ詳細を表示するには、スキャンサマリーからマシン名をダブルクリックします。 マシンサマリー ウィンドウの内容が変更され、スキャンによるパッチサマリーが表示されます。

列の見出しをクリックして、情報別にパッチサマリーを並べ替えることができます。

タイプ

通知タイプ

スキャンされたオペレーティングシステムまたはアプリケーションに関する追加情報を表示します。 スキャンできなかったパッチに関する情報が、追加項目として表示されます。

スキャンされたシステムに適用可能であるにも関わらず現在使用されていないパッチを示します。 パッチが見つからなかったと見なされた理由については、パッチ詳細ウィンドウの アイテムの理由の説明をご覧ください。

この行に記載されているパッチは、製品コラムにリストされている製品に対して不足しているサービスパックとして識別されています。 サービスパックが見つからなかったと見なされた理由については、パッチ詳細ウィンドウの アイテムの理由の説明をご覧ください。

このアイテムでパッチが利用できますが、スキャンエンジンはそれがすでにインストールされていると判断しました。 ただし、これはそのパッチが必ずしもHFNetChkProNoteによってインストールされたことを意味するものではありません。 システム管理者によって手動でインストールされた、あるいはWindows Updateを利用した結果インストールされた場合もあります。

有効にインストールされたパッチがスキャン結果に表示されるためには、不足しているパッチとインストールされたパッチの両方をスキャンするオプションを含むカスタムスキャンテンプレートを使用することが必要です。 有効にインストールされたというステータスは、パッチが明確にインストールされたわけではありませんが、スキャンされたコンピュータで見つかった情報が、パッチによって示された脆弱性が矯正されたことを示しています。 これは代替パッチやロールアップパッチなどの他のパッチが、同じファイルをアップデートしていることが原因となっていることもあります。

アイテム

パッチについて説明しているMicrosoft Security Bulletin アーティクルを意味します。

QNumber

パッチに関する情報を含む Microsoft Knowledge Base アーティクルを意味します。

Microsoft重大度レベル

Microsoftでは、パッチに関連する脆弱性に対する脅威という観点で、4つの重大度レベルを指定しています。

Microsoftはこのパッチに関する問題を クリティカル と見ています。

Microsoft はこのパッチに関する問題を、修正することが 重要 なものと見ています。

関連する脆弱性の重大度は 中 です。

セキュリティに関するリスクははらんでいますが、Microsoftではそのリスクを 低と見ています。

最大深刻度

最大深刻度とはユーザーによってもたらされた脅威で、重大度レベルは特定の脆弱性に関連しています。 Microsoft はパッチを使用しないことによる脆弱性の一般的な重大度や脅威を妥当に評価することができますが、最もクリティカルなパッチさえ、組織においてその脆弱性が大きな脅威となっていない場合には緊急な必要性を常に呼び起こすとは限りません。 したがって、HFNetChkProではシステム管理者が各パッチにカスタムレベルの重大深刻度を指定できるメカニズムを用意しています。 重大深刻度を手動で設定するには、パッチ詳細を表示します。

クリティカル

高

中

低

無視

重大深刻度の設定なし

注

このコラムにアイコンが表示される場合は、このパッチに関連する注があることを意味します。 これらの注は、パッチ詳細に表示されます。また、アイコンの上にマウスを置いても表示されます。 これらのコメントはShavlik Technologiesのセキュリティチームにより提供されます。

ダウンロード済み

このアイコンがグレーになっている場合は、パッチがまだダウンロードされていません。 緑色になっている場合は、パッチがすでにダウンロードされて確認済みであることを示します。

導入

このスキャンでパッチ導入が行なわれた場合には、導入ステータスがここにリストされます。 この情報は一般に PatchPushTM Trackerで見つかったものを反映しています。

製品

パッチによって影響を受ける製品をリストします。

説明

フローの簡単な説明を提供します。

コメント

HFNetChkPro はシステム管理者に、パッチについてコメントする機能を提供します。 コメントが作成された場合は、このコラムに表示されます。


パッチの詳細情報

スキャン結果の解釈：パッチの詳細情報

HFNetChkPro 4は、システム管理者がパッチの適用性や重大度について十分な情報に基づいた決定を行なえるように、各パッチごとに膨大な量の情報を提供します。 パッチの詳細を見るには、画面上部のウィンドウからパッチを選択すると画面下部のウィンドウに結果が表示されます。

パッチ情報画面には、誰がいつインストールしたかがわかっている場合はそれを含むパッチインストールステータスの詳細、重大深刻度や重大度に関する情報、そして何より重要なものとして、ファイル名、ファイルバージョン、ファイル日、ファイル場所、チェックサムを含むパッチに含まれるすべてのファイルのリストが表示されます。 この情報は、リモートマシンのパッチステータスを判断するのに役立つものです。

HFNetChkPro はパッチに関する豊富な情報を提供します。

ステータス

選択したマシンのパッチステータスを特定します。

スキャンされたオペレーティングシステムまたはアプリケーションに関する追加情報を表示します。 スキャンできなかったパッチに関する情報が、参考アイテムとして表示されます。

スキャンされたシステムに適用可能であるにも関わらず現在使用されていないパッチを示します。 パッチが見つからなかったと見なされた理由については、パッチ詳細ウィンドウの アイテムの理由の説明をご覧ください。

ここに記載されているパッチは、製品コラムにリストされている製品に対して不足しているサービスパックとして識別されています。 サービスパックが見つからなかったと見なされた理由については、パッチ詳細ウィンドウの アイテムの理由の説明をご覧ください。

このアイテムでパッチが利用できますが、スキャンエンジンはそれがすでにインストールされていると判断しました。 ただし、これはそのパッチが必ずしもHFNetChkProNoteによってインストールされたことを意味するものではありません。 システム管理者によって手動でインストールされた、あるいはWindows Updateを利用した結果インストールされた場合もあります。

マシンが何も選択されていない場合、このセクションは「インストールパッチ」と表示されます。

Microsoft 重大度

Microsoftでは、パッチに関連する脆弱性に対する脅威という観点で、4つの重大度レベルを指定しています。

Microsoftはこのパッチに関する問題を クリティカル と見ています。

Microsoft はこのパッチに関する問題を、修正することが 重要 なものと見ています。

関連する脆弱性の重大度は 中 です。

セキュリティに関するリスクははらんでいますが、Microsoftではそのリスクを 低と見ています。

最大深刻度

最大深刻度とはユーザーによってもたらされた脅威で、重大度レベルは特定の脆弱性に関連しています。 Microsoft はパッチの脆弱性の一般的な重大度を妥当に評価することができますが、最もクリティカルなパッチさえ、組織においてその脆弱性が大きな脅威となっていない場合には緊急な必要性を常に呼び起こすとは限りません。 したがって、HFNetChkProではシステム管理者が各パッチにカスタムレベルの重大深刻度を指定できるメカニズムを用意しています。 重大深刻度を指定するには、追加をクリックし、表示されるショートカットメニューからオプションをひとつ選択します。 パッチにカスタム最大深刻度を指定すると、フラッグの色が変わり、「追加」というテキストが「変更」に変わります。

クリティカル

高

中

低

無視

重大深刻度の設定なし

CVEID

これはパッチに関連する情報が掲載されているCommon Vulnerabilities and Exposuresウェブサイトへのリンクです。 このリンクをクリックするとお使いのブラウザでCVEウェブサイトが開きます。

Bugtraq ID

これはパッチに関連する情報が掲載されているSecurityFocusウェブサイトへのリンクです。 このリンクをクリックするとお使いのブラウザでSecurityFocus ウェブサイトが開きます。

パッチ ダウンロード ステータス

パッチがダウンロードされる前は、ステータスは「ダウンロードされていない」と表示され、パッチがダウンロードできるサイトへのリンクが表示されます。 リンクをクリックするとダイアログボックスが開き、パッチのダウンロードに必要な空きディスク容量、スキャンシステムで利用できるスペース空き容量合計、パッチをダウンロードするかどうかの確認などが表示されます。 はいをクリックするとパッチがダウンロードされ、パッチ名とダウンロードされた日時およびパッチを削除するかどうかのオプションが表示されます。

コメント

パッチに関するコメントを記入する欄を提供します。 コメントの追加や編集を行なうには、 コメントの追加/編集をクリックします。

説明部分

パッチの説明部分には、短い名前とパッチによって修正された問題の概要が表示されます。 これは、パッチに関する情報すべてをひとめで見ることができるので、非常に便利です。 この部分には、フローに関するさらに詳細な情報を提供するMicrosoft Security Bulletin アーティクルとKnowledge Baseアーティクルへのリンクも表示されています。

レジストリ詳細

ここには、パッチがインストールされたときにシステムに書き込まれることがあるレジストリキーが表示されます。

ファイル詳細

パッチによって修正されたファイルの情報が表示されます。

パッチ詳細ウィンドウの下部に4つのタブがあります。 最初の1つのタブ、［パッチ情報］については上記に説明されています。 不足 タブは、選択されたスキャンによってパッチがインストールされてなく脆弱性があることがわかったマシンのリストを見るのに使います。 インストール済みタブは、パッチがインストールされているマシンを列挙します。


不足しているパッチ

影響を受けているファイルが予期されているバージョンより古いバージョンであったり、無効なチェックサムを有している場合に、パッチが不足していると見られます。 パッチがなぜインストールされていないと見なされるかについての詳細は、「アイテムの理由」として HFNetChkPro出力に表示されます。

ただし、このアイテムが不足と見なされるべきでないという理由がある場合には（HFNetChkProを使ってすでにパッチがインストールされているなど）、さらに問題を追及する必要があります。


パッチの非表示

パッチ アイテムの非表示

パッチアイテムの非表示機能は パッチサマリー結果から利用できます。 この機能を使うと、レポート用にスキャン結果でパッチを非表示にすることができます。

この機能を使うには、非表示にしたいパッチを右クリックし、パッチアイテムの非表示を選択します。 これにより、そのパッチがパッチサマリー結果でただちに非表示になります。

メニューバーからパッチ > パッチアイテムの非表示を選択することもできます。

非表示にしたパッチを見るには、ツール > オプション > 表示オプション > 一般 メニューを開き、「非表示のパッチアイテム」の横にチェックマークを付けます。

非表示にしたパッチを通常の表示状態に戻すには、非表示とマークされたパッチを右クリックし、パッチアイテムの非表示のチェックマークを外します。


パッチのダウンロード

パッチとサービスパックのダウンロード

HFNetChkPro は導入プロセスの一環として、自動的に必要なパッチをダウンロードするため、前もって手動でダウンロードする必要がありません。 ただし、HFNetChkProは導入前にパッチを手動でダウンロードすることもできます。 これには幾つかの方法があります。

英語のパッチ：

ひとつだけパッチをダウンロードする場合

  • パッチ詳細画面でダウンロードオプションをクリックします。

  • パッチサマリーでパッチを右クリックし、パッチのダウンロード > 選択済みを選びます。

  • パッチを選択したら、メインメニューからパッチ > パッチのダウンロード > 選択済みを選びます。

複数のパッチをダウンロードする場合

  • パッチサマリーから希望する複数のパッチを選択し、パッチのひとつを右クリックして、 パッチのダウンロード > 選択済みを選びます。

  • 希望する複数のパッチを選択したら、メインメニューから パッチ > パッチのダウンロード >選択済みを選びます。

すべてのパッチをダウンロードする場合

  • パッチサマリーでパッチを右クリックし、パッチのダウンロード > すべてを選びます。

  • メインメニューからパッチ > パッチのダウンロード > すべてを選びます。

サービスパックをダウンロードする場合

  • パッチサマリーでパッチを右クリックし、パッチのダウンロード > すべてのサービスパックを選びます。

  • メインメニューからパッチ > パッチのダウンロード > すべてのサービスパックを選びます。

パッチのダウンロードに支障が生じた場合は、Internet Explorerのキャッシュファイルをクリアした上でもう一度ダウンロードを試みてください。

英語以外のパッチについては、各国語のパッチについてをご覧ください。


英語以外の言語のパッチのダウンロード

HFNetChkPro が英語以外の言語のパッチをサポートできるよう設定されている場合（言語サポートオプションへのアクセスを参照）、パッチのダウンロードを開始すると次のダイアログが表示されます。

ダウンロードするパッチの言語の横のチェックボックスにチェックマークを付け、OKをクリックします。

このダイアログボックスには次のオプションもあります。

  • チェックした言語をデフォルトとして保存： 選択した言語をデフォルトの言語にする場合は、このチェックボックスにチェックマークを付けます。 デフォルトの言語を設定するもうひとつの方法として、HFNetChkProメニューから ツール > オプション > 言語サポート を選択することもできます（言語サポートオプションの設定を参照）。

  • このダイアログを再び表示しない： このメッセージをあらかじめ表示せずにHFNetChkPro が自動的にデフォルト言語のパッチをダウンロードするようにしたい場合は、このチェックボックスにチェックマークを付けます。 このダイアログを再び表示するにはHFNetChkProメニューから ツール > オプション >言語サポート を選択し、ダウンロード時に言語を尋ねるのチェックボックスにチェックマークを付けます。


ダウンロード センター

HFNetChkProは、パッチを保存するためのダウンロードセンターを複数サポートしています。 別個のダウンロードセンターは各国語のパッチサポートに不可欠です。 ただし、これ以外の理由でも別個のダウンロードセンターを利用することが望ましい場合があります。

たとえば、複数のサーバーを使ってパッチを保存する場合、パッチの各保存場所に別々のダウンロードセンターを指定することができます。

ダウンロードセンターを使用するには、ツール > オプション> ダウンロードオプションを選択します。

新しいダウンロードセンターを作成ｓるには、新規 をクリックし、新しいダウンロードセンターの名称とファイルが配置されるパスを入力します。 このパスにはUNCパスまたはドライブ文字のパスが使用できます。


パッチ導入の概要

HFNetChkPro 4 では、マウスをクリックするだけで、ローカルとリモートのパッチ導入が簡単に行なえます。 一台のマネージメントコンソールから、単一のマシンまたは多数のマシンにパッチを導入することが可能です。


パッチ導入前に必要なファイル

導入を正しく行なうためには、事前に必要なファイルのスキャンに加え、パッチされるマシンでWindows Task Schedulerが使用可能になっていることが必要です。

Windowsから [スタート > 設定 > コントロールパネル >Administrative Tools> Services] を選択し、［Task Scheduler］を右クリックします。


パッチ導入のセキュリティ

Shavlik はHFNetChkProで行なうパッチ導入のセキュリティ確保に真剣に取り組んでいます。 そのため、パッチは必ず3つ以上の署名確認チェックを受け、厳しいセキュリティチェックを要求されるリモートマシンに保存されます。 この3つの署名チェックにパスしないパッチは導入されません。

パッチがMicrosoftからダウンロードされると、Microsoftによってデジタル署名されていれば緑色のダウンロードアイコンとしてのみ表示されます。 ダウンロードが完了しなかった場合、あるいはファイルが署名されていない場合には、ダウンロード済みとして表示されません。 ファイルがダウンロードされたが署名されていない旨を伝えるエラーメッセージが表示されることもあります。

導入中、パッチがリモートシステムにコピーされる際には、パッチに署名がない限り、コピーが開始されることはありません。 これは、ダウンロードセンターに保存されているパッチに手が加えられるのを防ぐためです。 パッチがプッシュされる前に、正当なファイルであることを確かめるために必ず署名が確認されます。

パッチが導入先にコピーされた後、スケジュールされている導入時間まで待つ場合もあります。 その間にパッチに手が加えられるのを防止するために、マシンにパッチが導入される前にもう一度署名が確認されます。 さらに、リモートマシンにHFNetChkProが直接作成したパッチはLOCALSYSTEMとローカルシステム管理者にのみ許可が設定されているので、他のユーザーが導入ディレクトリからファイルの変更、追加、削除を行なうことはできないようになっています。


HFNetChkPro 4のマシンの数え方

HFNetChkPro 4の導入ライセンス管理方法

導入が行なわれると、HFNetChkPro 4はすでに保存されていないマシンについてはそのマシン名をデータベースに記録します。 その時点から、導入に利用できる残数が各導入対象から差し引かれていきます。

ヘルプ > バージョン情報を使えば、幾つライセンスが使用されたかを簡単に調べることができます。 下の画面では、50のライセンスのうち、1つがすでに使用されていることを示しています。


導入のテスト

HFNetChkPro 4は、導入するパッチのテスト導入を行なうことができます。 これはパッチを後で導入するようにスケジュールした場合に特に役立ちます。 導入のテストを行なうことで、システム管理者は導入時に起こる恐れのある問題を事前に解決し、導入が失敗するのを防ぐことができます。

パッチ、パッチグループ、複数のマシンへのパッチの導入をテストするには、それぞれ該当するものを選択します。 次に、［導入］を選択し、 テスト導入を選びます。 これはパッチを右クリックして、導入 > テスト導入を選択するか、メインメニューからパッチ > 導入 > テスト導入 を選択しても行なえます。

スキャンされたマシンすべてへの導入またはドメイン内のスキャンされたメンバーすべてのテスト導入を行なう場合には、メニュー選択時にこれらが考慮されます。 たとえば、スキャンされたマシンすべてへの導入テストを選択する場合は、メニューオプションは パッチ > スキャンマシンへの導入パッチ..> テスト導入となります。

テスト導入は検出した内容に基づいて、合格または不合格の結果を戻します。 たとえば、ワークステーションやスケジュールサービスが特定のマシンで開始されていない場合、HFNetChkProはそのマシンにパッチを導入できないので、不合格の結果が戻されます。

下に挙げるのは、テスト導入の合格例です。

テスト導入

良好:Localhost が、Workstation Service を起動しています。

良好:Localhost が有効な NetBios または Direct Host サービスを起動しています。

********** Test 192.168.1.105 **********

Test 1) 192.168.1.105- 良好：あなたはこのコンピュータ上での指定のセキュリティ属性を使用している管理者です。

Test 2) 192.168.1.105- 良好：リモート コンピュータが Remote Registry Service を起動しています。

Test 3) 192.168.1.105- 良好：リモート コンピュータが Server Service を起動しています。

Test 4) 192.168.1.105- 良好：リモート コンピュータが Workstation Service を起動しています。

Test 5) 192.168.1.105- 良好：リモート コンピュータが NetBios または Direct Host サービスを起動しています。

Test 6) 192.168.1.105- 良好：このコンピュータ上のリモートレジストリにアクセスできます。

Test 7) 192.168.1.105- 良好：リモート コンピュータのワークステーション情報にアクセスできます。

Test 8) 192.168.1.105- 注：ユーザーがリモート コンピュータにログインしました:

>EXAMPLE\Administrator

Test 9) 192.168.1.105- 良好：リモートコンピュータでSchedulerが起動しています。

Test 10) 192.168.1.105- 良好：テスト アップグレードをコピーするためのリモート ディレクトリを作成しました。

Test 11) 192.168.1.105- 良好：テスト アップデート ファイルをコピーしました。

Test 12) 192.168.1.105- 良好：リモート タスクが正しくスケジュールされました。

Test 13) 192.168.1.105- 良好：スケジュールされたテストが正しく実行されました。

*****

192.168.1.105- パスの全般的評価。 パッチのインストールはできません。

*****


導入構成設定

このダイアログボックスは、標準の導入テンプレートを使ってパッチが選択したマシンに導入されることを示しています。 別の導入テンプレートを使用する場合は、ドロップダウンリストから選択するか、 新しい導入テンプレートを作成します。この場合は新規ボタンをクリックします。

上の例では、パッチがただちに導入されるようになっていますが、パッチを選択したマシンにコピーするだけ、あるいは後で導入するようにスケジュールできるオプションもあります。

あとで導入するようにスケジュールする場合は、スケジュール時のオプションを選択し、パッチがインストールされる日付と時刻を選択します。 ファイルはただちにコピーされますが、パッチのインストールはスケジュールされた導入時刻まで開始されません。 スキャンを行なうマシンが、パッチ導入予定時刻に利用できる状態になっている必要はありません。

上の例でクリックされている 詳細ボタンは、どのパッチがどのマシンに導入されるかのリストをはじめ、導入に含まれるものをすべて詳細に表示します。

選択したオプションで導入を開始するには、導入ボタンをクリックします。 導入を取り消すには、キャンセルをクリックします。


導入のモニタリング

導入プロセス全体を通じて、 HFNetChkPro 4はシステム管理者に経過を知らせるためのステータス情報を提供します。 最初のステータス情報は、導入 ボタンが 導入構成設定 ウィンドウでクリックされた直後に表示されます。

このステータスウィンドウを見れば、システム管理者はパッチのダウンロードがひとめでわかります。 導入前に各パッチがダウンロードされていなければなりません。

選択したパッチがすべてダウンロードされた後で、マシンへの導入が実際に開始されます。

対象となるマシンにファイルがコピーされると、PatchPush Trackerが起動します。

この二番目のステータスウィンドウは、導入中に実際の導入に関する情報を提供します。

このウィンドウを見れば、システム管理者はこの導入のプロセスがひとめでわかります。 これらのオプションはすべて、異なる導入テンプレートを作成して使用することでカスタマイズされています。 上記の例で使用されている導入テンプレートはHFNetChkPro の標準テンプレートで、60秒の間隔を置いて最高10回にわたってパッチの導入を試みた場合は、リモートマシンの再起動を行う必要があることを示しています。

リモートマシンにパッチがコピーされ、パッチ導入がそのマシンで開始された後は、導入ウィンドウでマシン名をクリックして導入のステータスに関するさらに詳しい情報を見ることができます。

上のウィンドウには導入のステータスが示されています。 この例では、2つのパッチがWINNTというマシンに正しくコピーされてスケジュールが設定され、現在のステータスが、「実行済み - リブート待ち」であることを示しています。 プロセスのステータスについてさらに最新の情報を見るには、クリックしてリモート ログ情報をクエリーします。 これにより、マシンのリモートログがクエリーされ、パッチステータスに関するさらに詳しい情報が得られます。

イベント ログ メッセージ

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\Q314147_NTE_SP6A_x86_ENU.exe.

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\Q313829_NTE_SP6A_NAD_x86_ENU.exe.

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\qchain.exe. ?

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\Commandline4.exe.

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\silent.exe.

ID 8201 (Copy File) 3 Information Sun May 11 14:58:14 2003 Copy File \\192.168.1.107\C$\WINNT\ShavlikProPatches\Shavlik-4008\Shav.Deploy.2003.05.11.02.58.PM.81D226B75C644585B9331CAE00FBCC32.bat.

ID 8197 (General) 3 Information Sun May 11 15:01:14 2003 Set PATHTOFIXES=C:\WINNT\ShavlikProPatches\Shavlik-4008".

ID 8197 (General) 3 Information Sun May 11 15:01:21 2003 Execute (C:\WINNT\ShavlikProPatches\Shavlik-4008\qchain.exe).

ID 8197 (General) 3 Information Sun May 11 15:01:21 2003 Rebooting machine.

ID 8195 (Forced Reboot) 3 Information Sun May 11 15:01:21 2003 Forced Reboot for installation of patches.

ID 8197 (General) 3 Information Sun May 11 15:01:22 2003 Finished with 'C:\WINNT\ShavlikProPatches\Shavlik-4008\Shav.Deploy.2003.05.11.02.58.PM.81D226B75C644585B9331CAE00FBCC32.bat'.Rename


導入のキャンセル

パッチ導入をキャンセルするには、導入マシンリストのマシン名を右クリックし、ショートカットメニューから 導入のキャンセルを選択します。 メニューバーからファイル > 導入のキャンセルを選択することもできます。

PatchPushTM Trackerを使っても導入をキャンセルすることができます。


導入履歴

一連のスキャンを終えた後でも、これまで行なった導入の結果がクリックひとつで取得できます。 今日導入を行なった場合には、 今日の導入というタイトルのウィンドウがHFNetChkPro 4の左部分に開きます。 このリストの上でマウスを動かすと、下図のような詳細情報が表示されます。

その日が終了すると 今日の導入は画面の左側、ほぼ一番下の 最近のアイテムと名付けられたアーカイブに移動します。 最近のアイテム には、導入だけでなく最近行なわれたスキャンも含まれています。

さらに、［ツール > アイテムの管理］を選択して、これまでに行なったスキャンの詳細リストを取得することもできます。

これらの項目はすべて、最近のアイテム にも表示されます。 特定の導入履歴を削除したいときには、希望のアイテムを選択し、選択したものを削除 をクリックします。 導入履歴をすべて削除するには、すべて削除 を選択します。


幾つかのパッチの導入

スキャン後、選択したマシンに導入するパッチをパッチサマリーウィンドウから選ぶことができます。 CTRLキーを押しながらパッチを選ぶと複数のパッチが選択できます。 SHIFTキーを押している間に最初のパッチと最後のパッチを選ぶと、その間のパッチがすべて選択されます。

導入するパッチのひとつを右クリックし、導入 > 選択されたパッチをショートカットメニューから選びます。

または

パッチ> 導入 > 選択されたパッチをメインメニューから選びます。

導入で［今すぐ実行］ダイアログのオプションが選択されていると、導入構成設定 ウィンドウが開きます。 それ以外の場合は、デフォルトの導入テンプレートを使って導入がただちに開始されます。


一連のパッチの導入

マシンに一連のパッチを簡単に導入することができます。 マシンに不足しているパッチをすべて導入するには、パッチを右クリックして導入 > すべての不足しているパッチを選択します。 「見つかったパッチ」として表示されていないすべてのパッチが選択したマシンに導入されます。

または

パッチ（複数） > 導入 > すべての不足しているパッチをメインメニューから選びます。

導入で［今すぐ実行］ダイアログのオプションが選択されていると、導入構成設定 ウィンドウが開きます。 それ以外の場合は、デフォルトの導入テンプレートを使って導入がただちに開始されます。


選択したマシンにパッチを導入

選択した複数のマシンにパッチを導入するには、導入したいパッチをまず選びます。 パッチは［マシンサマリー］または［パッチ別サマリー］から選ぶことができます。 パッチを選択したらパッチ情報ウィンドウの［不足］タブを開いて、そのスキャンで選択したファイルが不足しているマシンをすべて表示することができます。 CTRL キーまたは SHIFT キーを押しながらこのパッチを導入するマシンをクリックし、右クリックして、 マシンによって導入 > 選択されたマシン...を選択します。 メニューバーから マシン > マシンによって導入 > 選択されたマシン...を選択してもこの操作を行なうことができます。


サービスパックの導入

サービスパックの導入はパッチの導入とは異なった方法で行なわれます。 Microsoftではすべてのパッチの前にサービスパックを適用することを推奨しているので、 HFNetChkProは、同じ導入の中ではサービスパックとパッチの両方を導入することができないようにしています。 このため、 すべての不足しているパッチを導入を選択すると、文字通りすべての不足しているパッチを導入しますが、サービスパックはこの操作に含まれません。

単一のマシンへの導入

一台のマシンに最新のサービスパックを導入するには、スキャン結果からマシンを選択し、右クリックしてパッチを［マシン名］に導入...> 最新のサービスパック...を選択します。

これと同じ操作は、メインメニューから マシン > パッチを［マシン名］に導入...> 最新のサービスパック... を選択しても行なえます。

複数のマシンへの導入

サービスパックを複数のマシンに導入するには、［マシンサマリー］または［パッチ別サマリー］からサービスパックを選択し、パッチ情報ウィンドウの［不足］タブをクリックします。 CTRLキーまたはSHIFTキーを押しながらサービスパックの導入先の複数のマシンを選択し、右クリックして、マシンによって導入 > 選択されたマシンを選びます。

メニューバーから マシン > マシンによって導入 > 選択されたマシン...を選んでもこの操作を行なうことができます。


最大深刻度によって導入

パッチに対する必要度に基づいてパッチを導入することもできます。 たとえば、影響の少ないパッチは週末に適用し、セキュリティに重要なパッチはただちに導入するようにできます。 このために、HFNetChkPro 4 はシステム管理者がユーザー定義による最大深刻度に基づいてパッチの導入ができるようにしています。 パッチの最大深刻度はパッチ詳細 画面で設定できます。

最大深刻度によってパッチを導入するには：

パッチを右クリックし、導入 > 最大深刻度を基準 > { 導入するパッチの最大深刻度 }を選択します。

または

パッチ > 最大深刻度を基準 > { 導入するパッチの最大深刻度}を選択します。

スキャンされたマシンすべて、あるいはドメインのスキャンされたマシンすべてに導入する場合は、メニューオプションは パッチ > スキャンマシンに導入...> 最大深刻度を基準 > { 導入するパッチの最大深刻度}となります。

導入で［今すぐ実行］ダイアログのオプションが選択されていると、導入構成設定 ウィンドウが開きます。 それ以外の場合は、デフォルトの導入テンプレートを使って導入がただちに開始されます。


ドメインメンバーすべてに導入

ドメインのすべてのメンバーにパッチを導入

単一のドメイン内のすべてのメンバーにパッチを導入することができます。 各ドメインはスキャンサマリーにリストされます。 ドメインのスキャンされた全メンバーにすべての不足しているパッチを導入するには、ドメイン名を右クリックし、パッチを{ドメイン名} マシン }に導入 > すべての不足しているパッチを選択します。

あるいは、パッチを導入するドメインを選び、メインメニューからパッチ > パッチを{ドメイン名} マシン}に導入 > すべての不足しているパッチを選ぶこともできます。

導入で［今すぐ実行］ダイアログのオプションが選択されていると、導入構成設定 ウィンドウが開きます。 それ以外の場合は、デフォルトの導入テンプレートを使って導入がただちに開始されます。


スキャンされたマシンすべてに導入

パッチをスキャンされたマシンすべてに導入

HFNetChkPro は、パッチや一連のパッチを一度に一台のマシンに導入するだけではありません。 スキャン終了後、すべての不足しているパッチをただちにマシンに導入するように設定することができます。 この機能は、ワンステップでアップデートができるので、ドメインのスキャンを行なう場合に特に便利です。 自動導入オプションの選択はスキャン実行ダイアログで行ないます。 このダイアログにアクセスするには、メインスクリーンのスキャン対象ボックスのオプションを選択するか、詳細ボタンをクリックします。このボタンはホームページのマイ コンピュータのスキャンとマイ ドメインのスキャンアイコンの下にあります。

注： 自動導入はスケジュール済みスキャンでは使えません。

スキャンされたマシンに不足しているパッチをすべて導入するもうひとつの方法は、スキャンを右クリックし、スキャンマシンにパッチを導入...> すべての不足しているパッチを選択するものです。 あるいは、メインメニューから パッチ > スキャンマシンにパッチを導入...> すべての不足しているパッチを選択します。

導入で［今すぐ実行］ダイアログのオプションが選択されていると、導入構成設定 ウィンドウが開きます。 それ以外の場合は、デフォルトの導入テンプレートを使って導入がただちに開始されます。


導入テンプレートについて

マシンにパッチを導入する際、HFNetChkPro 4 は、導入後に導入対象をリブートするか、リモートマシンにどの程度の速さでパッチをコピーするかなど、数多くの異なるオプションを提供します。

導入テンプレートには以下の情報を含みます。

  • リモートマシンにパッチをコピーするのに使用される速度

  • 導入中、リモートマシンでダイアログボックスを表示するかどうかの選択

  • Microsoft Officeのパッチをどのように導入するか

  • 導入前、導入中、導入後に行なうこと

  • 導入対象の再起動についてのオプション

標準の導入テンプレートにはShavlikが推奨する導入オプションと以下のパラメータが含まれています。

  • パッチ コピー再試行まで、10秒待つ

  • 導入実行中にターゲット マシン上でリモート ダイアログ ウィンドウを表示しない

  • Office インストール:各マシンにパッチをプッシュする

    • できるだけフル ファイル パッチをプッシュする

  • パッチ実行前....

    • SQL Server をシャットダウンしない

    • IIS Server をシャットダウンしない

  • パッチ実行中 ...

    • アンインストール用バックアップ ファイル

    • 'クワイエット モード'でパッチを実行

  • 導入実行後....

    • テンポラリ導入ファイルを削除しない

  • ターゲット マシンのリブート

    • 実行後ただちにリブート

    • リブートする前に接続されているマシンに警告しない

    • リスタートを10回試行する

    • リスタートの試行間隔は60秒


導入テンプレートの作成

新しい導入テンプレートを作成するには、導入テンプレート メニューから 新しい導入テンプレートの作成 オプションをクリックします。 これにより、利用できる導入テンプレートを含むウィンドウが表示されます。

名称

この導入テンプレートに付ける名前

説明

この導入テンプレートの説明

コピー速度

リモートマシンにパッチをコピーする際に希望する速度です。 1 が一番遅く、5が一番速い速度となります。 コピー速度が速くなるほと、ネットワークの帯域を多く使用するようになります。

再試行期間

パッチのコピーに失敗した場合に再試行を行なう間隔を、0秒から100秒の間で設定することができます。

リモート ダイアログ

導入がアクティブになっている時に導入対象にログインしたユーザーが使用できるよう、ダイアログボックスを作成します。 ここで、ダイアログボックスのタイトルとキャプションの両方を設定できます。

Office の導入

Officeのパッチは他のパッチと異なる方法で取り扱われます。 OfficeのパッチはオリジナルのCDを必要とします。 これは、パッチが完全なファイルでないためです。 パッチは、オリジナルのファイルをパッチコードで変更するのに必要な違いだけを提供します。

Administrative Installation Point

システム管理者はOffice Administrative Install Point (AIP)を作成し、この場所からクライアントマシンにOfficeをインストールすることができます。 次にHotfixesをAIPにインストールし、リモートクライアントマシンにAIPからインストールをアップデートするよう指示できます。 このアップデートプロセスは実際は、各マシンにOfficeすべてをインストールしなおすことです。次にAIPのすべてがリモートマシンにコピーされます。 このインストールポイントは、技術的に言えば、特別なセットアップコマンドで事前に必要なファイルをネットワーク共有するだけのことです。

Administrative Installation Pointフィールドに、Office AIP MSI ファイルへのフルUNCパスを入力します。 \\officeserver\office\proplus.msiがその例です。 セキュリティ属性に設定ボタンを押して、リモートマシンでUNCロケーションにアクセスするためのセキュリティ属性を提供します。

OfficeパッチにAIPを指定した場合、この導入テンプレートを使ってOfficeパッチをインストールすることを選択すると、パッチが導入されるマシンはすべて指定されたOfficeAIPに同期化されます。

各マシンにパッチをプッシュする

あるいは、リモートのOfficeクライアントにパッチを直接導入することを選択することもできます。 できる限り、リモートマシンにフルファイルパッチをプッシュし、Officeメディアに静的場所を指定するようにします。 そうしないと、Officeパッチがすべて正しく導入できるとは限らなくなります。

オリジナルのインストールメディアへのパス

Officeの特定のバージョンのインストールに使用される、オリジナルのインストールメディアへのUNCパスを指定します。 \\corpserver\officeがその例です。 セキュリティ属性に設定ボタンを押して、リモートマシンでUNCロケーションにアクセスするためのセキュリティ属性を提供します。 リモートマシンがオリジナルのインストールメディアにアクセスできない場合、Officeのインストールに失敗することがあります。

パッチ導入

パッチの前、パッチ中、パッチ後に選択できる多くのオプションがあります。

以前

SQL Serverにサービスが停止することを警告して、SQL ServerとIIISをシャットダウンすることができます。 この設定に関わらず、SQLまたはIISパッチがそれぞれリモートマシンに適用されると、これらのサービスは自動的にシャットダウンされます。 OSやそれに類似するhotfixをインストールするとき、特にインストール後マシンをリブートする場合は、この設定を使って、これらのサービスをシャットダウンします。

進行中

支障が生じた場合にアンインストールできるよう、導入中に変更が加えられるファイルをすべてバックアップするようHFNetChkPro を設定することができます。 「クワイエット モード」は使用可能にも使用不可にもできます。 クワイエット モードを使うと、ユーザーは導入が実行されていることに気づきません。

後

スキャン完了後、導入プロセスで作成されたテンポラリファイルを削除することができます。

リブート オプション

すべてのパッチの導入に成功した後、リモートシステムをどうするかについて幾つかオプションがあります。 そのまま操作を続けることもできれば、リブートすることもできます。 導入対象をリブートすることを選んだ場合には、リブートの再試行回数（1から100まで）と再試行の間隔（1秒から100秒まで）を設定することができます。 そのマシンにクライアントが接続されている場合は、システムを再起動する前に警告するよう指示することができます。

この導入テンプレートに必要な選択をすべて行なったら 保存 と閉じる ボタンをクリックして選択した内容を保存します。 変更を保存せずにウィンドウを閉じるには、キャンセル または 閉じる ボタンをクリックします。


導入テンプレートを使う

カスタム導入テンプレートは新しい導入テンプレート の下に含まれています。これは右の図のように 導入テンプレート ボックスの中に表示されます。 導入テンプレート ボックスからテンプレートが選択されると、ウィンドウの右部分にその詳細が表示されます。

たとえば、「Sample template」という名前の導入テンプレートが選択されたとすると、次のような画面が表示されます。

この画面から実行できる操作が幾つかあります。

これをデフォルトのマイ テンプレートにする | このオプションを選ぶと、現在選択されているテンプレートがデフォルトとして使用されます。
編集 | この編集オプションを選ぶと導入テンプレートダイアログボックスが表示され、変更が追加できるようになります。
コピー | 選択したテンプレートをコピーします。 これを選ぶと、「（選択されたテンプレート名）のコピー」と名付けられた導入テンプレートダイアログボックスが開き、現在のテンプレートと同じ説明と設定が表示されます。
削除 | 現在のテンプレートを削除します。

スキャンテンプレートを作成して、この導入 テンプレートをそれに指定すると、どのスキャンテンプレートが使用されているかについても表示が行なわれます。


パッチのアンインストール

HFNetChkPro 4 には、選択したパッチをアンインストールする機能があります。 ただし、この機能は 見つかったパッチとしてリストされているパッチにのみ適用され、スキャン結果に表示される 有効なインストール が行なわれたパッチには適用されません。 すべてのパッチがアンインストールできるわけではありません。

HFNetChkProを使ってパッチがアンインストールできるかどうか判断するには、スキャンを開き、パッチサマリーを表示します。 パッチを選択し、右クリックします。 選択をアンインストールがアクティブになっていれば、そのパッチはアンインストールできます。 パッチを選択し、［パッチ > 選択をアンインストール］メニューを表示しても同じ結果が得られます。

ご注意ください。

選択をアンインストール のオプションが利用可能か否かを判断できる方法は、上記に挙げたものだけです。


PatchPush™ Tracker について

About the PatchPush™ Tracker

HFNetChkPro 4 にはPatchPush™ Trackerと呼ばれる機能が含まれています。 この機能は、導入のステータスをモニターするための単一のコンソールを提供できるようにデザインされています。 PatchPush™ Tracker は、パッチが導入されたマシンからステータスメッセージを受信したShavlik HFNetChkPro Serviceを使用します。 このサービスはHFNetChkPro インストール時にインストールされ開始されます。 このサービスが停止すると、PatchPush™ Tracker はパッチ導入状態に関する情報をアップデートしなくなります。

HFNetChkPro Serviceの開始、停止、設定は ツール > オプション > 導入オプションから行なうことができます。

HFNetChkPro Service が正しく動作するためには、IPアドレスとリッスンするためのポートが指定されていなければなりません。 デフォルトでは、HFNetChkPro Service は TCP ポート 4750でリッスンします。 マルチホームマシンの場合は、HFNetChkPro Serviceが使用しスキャンするネットワークのIPアドレスを選択することが必要です。 このサービスが停止すると、PatchPush™ Tracker はパッチ導入状態に関する情報をアップデートしなくなります。

PatchPush™ Trackerを開始するには、 ツール > PatchPush Trackerの起動 を選択するか、PatchPush™ Tracker アイコン [image] をツールバーから選びます。

PatchPush™ Tracker ウィンドウは、パッチ導入ステータスに関する情報の一覧を表示します。 Trackerの各行には、パッチとそのステータス情報、パッチが導入されるマシン、パッチの説明、パッチ導入のスケジュール、最後にステータス情報が取得された時間が示されています。

ステータス情報は、導入に問題が生じた際にトラブルシューティングを行なう助けとなります。

  • 緑色： パッチの導入に成功

  • 黄色： 不良セキュリティ属性が原因で再スキャンに失敗*

  • 赤： 導入が完全に行なわれず、さらに調査が必要**

  • 青色： パッチのインストールが完了していません。 ステータスの青色が続く場合は、リモートマシンがPatchPush™ Trackerと通信できないことを示していることが考えられます。

*再スキャン操作は、Shavlik HFNetChkPro Serviceによって実際に開始されます。 デフォルトでは、このサービスはローカルシステムアカウントとして実行されます。 ローカルシステムにはリモートパッチスキャンを行なうための適切なセキュリティ属性がないので、 ツール > オプション > 導入オプション > CLOUCに入力して、セキュリティ属性をサービスに指定することができます。 または、最初のスキャンを開始する前にマシングループのセキュリティ属性の設定ダイアログで設定したセキュリティ属性を、再試行の目的でサービスに指定することもできます。

** PatchPush™ Tracker で失敗が表示される最も一般的な理由のひとつは、導入を完了するのにリブートが必要なパッチに導入テンプレートで「リブートしない」が指定されていることです。 PatchPush™ Trackerで「失敗」が表示されている場合は、問題のあるパッチのパッチ詳細を見て、パッチのインストールを完了するのにリブートが必要かどうかを調べます。

PatchPushのキャンセル

完了していないPatchPushをキャンセルするには、PatchPush™ Trackerから導入をキャンセルしたい行を選択し、プッシュのキャンセルをクリックします。 または選択した行を右クリックし、PatchPushを削除を選択します。


切断モード

切断モードは、インターネットに接続していないHFNetChkPro コンソールからスキャンを行なうときに役立ちます。 切断モードは、スキャンと導入だけ行い、Shavlikのウェブサイトからデータファイルのダウンロードは行なわない場合にも役立ちます。

注： 切断モード中にパッチを導入するためには、パッチがすでにダウンロードセンター内に保存されていなければなりません。 パッチファイルがダウンロードセンターに保存されていないと、HFNetChkProがパッチファイルをダウンロードしますが、このプロセスは失敗します。

切断モードを使用可能にするには、HFNetChkProメニューバーから ツール > 接続なしで実行 を選択します。 別の場所が特に指定されない限り、Officeのスキャンには、\ShavlikDataFilesディレクトリのPD4.xml ファイル、および4.2.XX.XディレクトリのMSSecure.xmlファイルが使用されます。

PD4.xml ファイルに別の場所を指定するには、ツール > オプション > Offline オプションを開きます。 切断モードでアプリケーションを実行 にチェックマークが付いている場合、これら2つのデータファイルの場所を入力することができます。 これらの場所はネットワークドライブの文字やUNCパス、HTTP\Sロケーションとして入力できます。

MSSecure.xmlに別の場所を指定するには、MSSecure.xmlファイルの場所を参照するスキャンテンプレートを作成します。 これらの場所には、ネットワークドライブの文字やUNCパス、HTTP\Sロケーションが選択できます。


Shavlik データファイル

インターネットに接続されていないコンソールから切断モードで実行する場合には、Shavlik データファイル、CommandLine4.exe、MSSecure.xml、PD4.xml、を手動で管理することが必要となります。 これらのファイルをShavlikのウェブサイトからダウンロードし、フロッピーディスクやFTPその他の方法でHFNetChkPro コンソールに移すことができます。

これらのデータファイルは、次の場所から安全なCABバージョンとしてダウンロードすることもできます。

CommandLine4.cab

http://xml.shavlik.com/jp/commandline4.cab

HFNetChk.cab

http://xml.shavlik.com/jp/hfnetchk.cab

PD4.cab

http://xml.shavlik.com/jp/pd4.cab

あるいは、以下の場所から圧縮されていない（非CAB）ファイルをダウンロードすることもできます（これは、お使いのファイアウォールがCABファイルのダウンロードを禁止している場合に役立ちます）。 下記のXMLアイテムでは、右クリックして 名前を付けて保存を選択するようにしてください。

CommandLine4.exe

https://xml.shavlik.com/jp/commandline4.exe

PD4.xml

https://xml.shavlik.com/jp/pd4.xml

ファイルの場所

次に以下のファイルを..\HFNetChkPro4\ShavlikDataFilesフォルダにコピーします。

  • commandline4.cab

  • pd4.cab

次のファイルは..\HFNetChkPro4\%version% フォルダ (例. HFNetChkPro4\4.2.0.0)に保存します。

  • mssecure.cab


各国語のパッチについて

HFNetChkPro は、英語、ドイツ語、フランス語を使うシステムにパッチを自動的にダウンロードします。 ドイツ語とフランス語のパッチのサポートについては 言語サポートオプションへのアクセスを参照してください。

他の言語のシステムでスキャンや導入を行なう場合は、それぞれの言語に対して独自のダウンロードセンターを作成することができます。 ダウンロードセンターを作成する際には、これらのパッチをダウンロードできるよう「インターナショナル モード」にチェックマークが付いていることを確認します。 詳細は 新しいダウンロードセンターの作成を参照してください。


言語サポートオプションへのアクセス

HFNetChkProが英語、フランス語、ドイツ語のパッチへのプロンプトを提供できるようにするには、ツール > オプション > 言語サポートを選択します。 ダウンロードオプション - 言語サポート画面が表示されます。

この画面についての詳細は 言語サポートオプションの設定を参照してください。


言語サポートオプションの設定

言語サポート画面には以下のオプションが表示されます。

  • ダウンロード ステータス インジケータにこの言語を使用： ドロップダウンリストをクリックし、ダウンロード ステータス インジケータにしようする言語を選択します。 たとえば、ドイツ語を選択するとします。パッチのダウンロード ステータス インジケータがこのように見える場合 [image] （カラー）、ドイツ語版のパッチがダウンロードされたことを示しています。しかし、ダウンロード ステータス インジケータがこのように見える場合 [image] （透明）には、ドイツ語版のパッチはダウンロードされていません。

他の言語のパッチのダウンロード ステータスについての詳細は、パッチサマリーのパッチ詳細セクションを参照してください。

  • ダウンロード時に言語を尋ねる： パッチのダウンロードを開始するたびに HFNetChkProが言語を尋ねるようにするには、このチェックボックスに印を付けます（英語以外の言語のパッチのダウンロードを参照）。 このオプションが使用可能になっていないと、HFNetChkProはダウンロードするデフォルト言語リストで選択されている言語のパッチを自動的にダウンロードします。

  • ツールバーに [ダウンロード センター] オプションを表示： ダウンロード センターのドロップダウンリストをツールバーに表示したい場合は、このチェックボックスに印を付けます。 例：

ダウンロード センターのドロップダウンリストが必要となるのは、英語、フランス語、ドイツ語以外の言語のパッチをダウンロードする場合です（新しいダウンロード センターの作成を参照）。 複数のダウンロード センターを使用していない場合は、このドロップダウンリストをインターフェースから外しておくと困惑を避けることができます。

  • ダウンロードするデフォルト言語： このリストからデフォルト言語に指定する言語を選択します。 この次にパッチをダウンロードする際には、パッチのデフォルト言語版が自動的にダウンロードされます。


新しいダウンロード センターの作成

メインメニューから ツール > オプション > ダウンロード オプションを選択し、次のダイアログボックスを表示します。

右側上部にダウンロード センターが表示されます。 ダウンロードでは、英語のダウンロード センターがひとつだけとなっています。 新規をクリックして、外国語のパッチ用に新しいダウンロード センターを作成します。

ダウンロード センターには3つの要素から構成されています。

  1. ダウンロード センター ディレクトリへのパス

  2. ダウンロード センターの名称

  3. インターナショナル モード

ステップ1

まず、ダウンロード ディレクトリを選択します。これはどの場所でもかまいません。 ここにパスを直接入力するか、［...］ボタンをクリックして、希望の場所を参照します。

ステップ2および3

パスを選択したら、ダウンロード センターに名前を付け、インターナショナル モードを選択します。 インターナショナル モードは英語以外のすべてのダウンロード センターに選択されます。

OK をクリックして、新しいダウンロード センターを作成し、パッチを受信できるようにします。

ダウンロード センターを使った外国語のパッチのダウンロードに関する詳細は、新しいダウンロードセンターの作成、外国語のパッチのダウンロードおよび 外国語を使うマシングループの作成を参照してください。


新しいダウンロード センターの作成

HFNetChkProのメニューバーには、ダウンロード センターが選択できるドロップダウンメニューが含まれています。デフォルトではこれは英語になっています。 外国語を使用するマシンにパッチをダウンロードするには、正しいダウンロード センターを選択することが必要です。 この例では、ロシア語が選択されています。


外国語のパッチのダウンロード

ダウンロード センターにパッチをダウンロードする準備ができました。 HFNetChkProでは、このタスクはスキャン後を含む様々な時期に行なうことができます。 ここでは、利用できるパッチのリストから選択されたパッチをダウンロードする場合を例として説明します。

左側のナビゲータ ウィンドウでパッチ情報をスクロールし、 Windows 2000 Professionalのパッチを選択します。

パッチのリストが表示されたら、その中からひとつ選択します（この例ではMS02-071）。 パッチ ダウンロード ステータスの下のウィンドウに ...としてダウンロードというタイトルが付いたハイパーリンクが表示されています。 英語のダウンロード センターを使用する場合は、これは普通 ダウンロードと表示されます。 しかし、外国語のパッチでは正しいパッチをダウンロードするために、もう少し手をかけることが必要です。

...としてダウンロードのURLをクリックします。

...としてダウンロード リンクをクリックすると、パッチについて説明するMicrosoft のウェブページが表示されます。

正しい言語のダウンロード（この場合はロシア語）までナビゲートし、Goをクリックします。 次のページが表示されます。

このページに表示されているダウンロード リンクをクリックしてダウンロードを開始します（この場合は [image] ）。 プロンプトに応えて Saveを選択します。

CTRLキーとVを同時に押すと、正しいダウンロード パスがダウンロード センターに自動的に貼り付けられ、正しいターゲットファイル名が下図のようにダイアログボックスに挿入されます。 ダウンロード センターの場所を貼り付けられなかった場合は、このダウンロード センターのパッチを保存しているパスを参照します。

これで、パッチは正しいダウンロード センターに正しい名前で保存され、HFNetChkProがパッチファイルを管理できるようになります。 パッチ情報画面に戻ると、パッチがダウンロードされ、導入が可能なことが表示されています。


外国語を使うマシングループの作成

複数のダウンロード センターのサポートに加え、HFNetChkPro には異なる言語タイプを使うマシンを管理するのに とても役立つ機能が用意されています。 マシングループ機能を使うと、スキャンやパッチ導入を行う特定のマシンを選択することができます。

マシングループを作成するには、左側のナビゲート ウィンドウの新しいマシングループをクリックします。

次にこのグループにマシンを追加します。 これには幾つかの方法があります。 マシン名とIPアドレスを直接入力することもできるし、ネットワークの参照オプションを選択してNetwork Neighborhoodから選ぶこともできます。

これで、グループをスキャンして不足しているパッチを見つけたり、上に表示されているように不足しているパッチをダウンロードしたり、通常通り導入することができます。


エージェントの管理

ツール -> エージェントの管理 機能は将来使用できるように用意されています。


プロキシのサポート

HFNetChkPro は、セットアップウィザードがInternet Explorerのプロキシ設定を使ってインターネット接続性試験を行い、プロキシサーバーの設定が必要かどうかを判断します。 HFNetChkPro がこれらの設定を使ってインターネットにアクセスできない場合または、ブラウザを起動してインターネットを使用するたびにユーザー名とパスワードの入力が要求される場合には、セットアップウィザードを使ってプロキシオプションを設定することが必要です。

ツール > オプション > プロキシ オプション を選択します。

プロキシ情報が必要？ボタンをクリックしてテストを実行し、HFNetChkPro が必要に応じて情報にアクセスできるかを調べます。 テストに合格した場合は...

それ以上の作業は必要ありません。 しかし、HFNetChkProがインターネットに接続できない場合は...

ここでプロキシ設定を行ないます。

Image - ProxyOptionsGeneral.gif

上記で説明されているように、お使いのプロキシサーバーから特に許可を得る必要がない場合には、HFNetChkProはInternet Explorerのプロキシ設定を使用します。 許可が必要な場合は、ユーザー名、パスワードおよび パスワードの確認の各フィールドに入力します。 必要なフィールドに入力したら、テストをクリックして、もう一度接続性のテストを行ないます。 確認が終わったら、プロキシ セキュリティ属性の保存と プロキシサーバーの使用の両方にチェックマークを付け、OKをクリックして設定を保存します。


エラーメッセージ

HFNetChkPro 4 スキャナ エラーメッセージ

エラー：200 - システムが見つかりません。 スキャンは実行されませんでした。
これは、指定のコンピュータが見つからず、スキャンできなかったことを意味します。 このマシンがネットワーク上にあって、ホスト名または IP アドレスが正しいことを確認してください。

エラー：201 - システムが見つかりません。 <system error message>
ネットワークの障害が原因で、指定のマシンのスキャンができません。 コンピュータ（スキャンを実行するマシン）がネットワークに正しく接続され、指定のマシンにリモートでログインできることを確認してください。

エラー：202 - システムが見つかりません。 スキャンは実行されませんでした。
スキャン進行中に、ネットワーク エラーまたはシステム エラーが発生しました。 スキャンを実行するマシンがネットワークに正しく接続され、スキャン対象のマシンがまだネットワークに接続されていることを確認してください。 さらに、リモート マシンがサーバー サービスを実行中であることを確認します。

エラー：230 - スキャンは実行されませんでした。 <system error message>
一般ネットワークエラーが発生しました。 詳細は、システムの説明書を参照してください。

エラー：235 - システムが見つかりません。あるいはNetBIOSポートにファイアウォールが設定されています。 スキャンは実行されませんでした。
おそらく指定の IP アドレスのマシンがありません。 このアドレスにマシンがないと、パーソナル ファイアウォールまたはポート フィルタリング デバイスがtcp ポート 139 と 445 宛てのパケットをドロップしている可能性があります。

エラー：261 - システムが見つかりましたが、NetBIOSポートをリッスンしていません。スキャンは実行されませんでした。
この IP アドレスにはマシンがありますが、リッスンしていないか、tcp ポート 139 および 445 へのアクセスをブロックしています。

エラー：301 - スキャンには SystemRoot シェア アクセスが必要です。
リモート マシンのシステム シェアに接続できません。 これは、システム管理者が systemroot (通常、C$ またはこれに類似) をアンシェアにしたか、レジストリを通して AutoShareServer(Wks) を使用不可にしたときに起こります。

エラー：451 - スキャンには管理者権限が必要です。 スキャンは実行されませんでした。
スキャンを実行する現在のユーザーまたは指定のユーザー アカウントが、スキャン対象のマシンに対する管理権限を持っていません。 指定のアカウントが、スキャン対象のマシン上でのローカル管理者グループのメンバーであるか（または、ローカル管理権限を有するグループのメンバーであるか）確認してください。

エラー：452 - HFNetChk がこのマシンをスキャンできません。 このマシンに対する管理者権限を持っていて、ワークステーションからこのマシンにログイン可能であることを確認してください。 スキャンは実行されませんでした。
リモートマシンでサーバーサービスが使用可能になっていて、このマシンにリモートでログオンできることを確認してください。 スキャンを行なうマシンでワークステーション サービスが実行されていることを確認します。

エラー：501 - リモート レジストリ アクセスが拒否されました。 スキャンは実行されませんでした。
スキャン対象のマシン上でリモート レジストリ サービスが使用可能になっていることを確認してください。

エラー：502 - スキャンは実行されませんでした。 レジストリの読み取りエラー <system error message>
一般ネットワークエラーが発生しました。 詳細は、システムの説明書を参照してください。

エラー：503 - スキャンは実行されませんでした。 レジストリの読み取りエラー。
一般レジストリ エラーが発生しました。 これ以上の情報はありません。

エラー：553 - レジストリの読み取り不可。 リモート レジストリ サービスの実行中であることを確認してください。 スキャンは実行されませんでした。
スキャン対象のマシン上でリモート レジストリ サービスが使用可能になっていることを確認してください。

エラー：621 - マシンが Windows (NT 4、2000、XP または .NET)ではありません。スキャンは実行されませんでした。
スキャン対象のマシンは、このツールがサポートする製品ではないようです。 SMBサービスを実行している非 Microsoft プラットフォームであるか、Microsoft 製品をエミュレートしている製品である可能性があります。

エラー：622 - マシンの OS を認識できません。 トレースをオンにして実行し、トレース結果をテクニカル サポートに送ってください。 スキャンは実行されませんでした。
指定のマシンの OS が判明しません。 おそらく、ベータ版またはリリースされていないバージョンの Microsoft OS をスキャンしたためです。

エラー：623 - マシンのサービスパックを認識できません。 トレースをオンにして実行し、トレース結果をテクニカル サポートに送ってください。 スキャンは実行されませんでした。
指定のマシンのサービスパックが判明しません。 おそらく、ベータ版またはリリースされていないバージョンの Microsoft サービスパックをスキャンしたためです。

エラー：701 - File http://xml.shavlik.com/mssecure.cab がダウンロードされませんでした。
セキュリティ パッチ情報を含んでいる、署名付きの圧縮 CAB ファイルが、指定された場所から取得できません。 スキャンを実行するマシンがネットワークに接続されていないか、その他の理由で指定されたファイルまたは場所にアクセスできないためと考えられます。 CAB ファイルを取得できない場合、https を介して圧縮されていない XML ファイルへのアクセスが試みられます。

エラー：702 - File http://xml.shavlik.com/mssecure.xml がダウンロードされませんでした。mssecure.cab.のローカルコピーを探そうとしています。
セキュリティ パッチ情報を含んでいる、圧縮されていない XML ファイルが、指定された場所から ｈｔｔｐｓ を介して取得できません。 スキャンを実行するマシンがネットワークに接続されていないか、その他の理由で指定されたファイルまたは場所にアクセスできないためと考えられます。 XML ファイルをネットワークから取得できないと、ローカル マシン上でこのファイルの既存バージョンを探そうとします。


レポートの概要

HFNetChkPro 4で使用されるレポート

HFNetChkPro 4では次のレポートが利用できます。 HFNetChkPro 限定版では、最初のレポート「凝縮パッチリスト」のみが利用できます。

レポートを選択するには、メニューバーの ギャラリーのレポート アイコン -- [image] -- をクリックし、画面上部のドロップダウンメニューからレポートを選びます。

凝縮パッチ リスト

各スキャン済みホストに対するマシン名およびパッチ ステータスを表示する 6 カラムの凝縮レポート。パッチ アイテムは、ブレティン番号 (MS00-000) として表示されます。

CSV 用の凝縮パッチ リスト

このレポートは、CSV エクスポート用に最適な形式のデータを出力するように設計されています。.出力は、各パッチが1行に示されるシンプル テキスト形式です。パッチのステータスを表すアイコンを示す代わりに、M、F、I の文字で示します。Mは不足、Fは見つかった、Iは参照をそれぞれ意味します。

導入シート ステータス

このレポートは、導入シート情報のリストを示します。ライセンスされたシート、使用済みシート、使用可能なシートが含まれます。注：このオプションにはフィルタ機能はありません。

マシン/OSリスト

このレポートは、スキャンされた各マシンの OS のリストを示します。注：このオプションにはフィルタ機能はありません。

パッチ別マシン

BulletinID と Qnumber によって並べ替えられる各マシンのパッチ ステータスを表示します。

スキャンされていないマシン

このレポートは、スキャンされなかったすべてのマシンと、スキャンされなかった理由のリストを示します。注：このオプションにはフィルタ機能はありません。

不足している SP

このレポートは、サポート製品に対するサービスパックが不足しているすべてのマシンの概要を示します。このレポートは、単純な条件のフィルタをスキップして、ただちに詳細条件フィルタを表示します。

パッチ注釈情報

このレポートは、すべてのパッチ注釈のリストを示します。

パッチ最大深刻度情報

このレポートは、条件によってグループ分けされたすべてのパッチのリストを示します。これによって、ネットワーク管理者が、「クリティカル」や「高」として分類されたパッチを容易に見分けることができます。

パッチ リスト

［不足］、［見つかった］、［参照用］、［警告］ によって並べ替えられた後、ユーザー プレファレンスによって並べ替えられたすべてのスキャン済みマシンに対する全パッチの短縮リスト（処理されたパッチごとに1行）。

マシン別パッチ

マシン名によって並べ替えられる各マシンのパッチ ステータスを表示。

マシン詳細別パッチ

マシン名によって並べ替えられる各パッチの詳しいリスト。各パッチに対して、レポートに全サマリーと理由が示されます。数千台のコンピュータに対して実行すると、このレポートには長時間かかります。

スキャン/導入履歴

このレポートは、システム全体のすべてのスキャンと導入のリストを示し、個々のスキャンと導入を誰が実行したかを示します。


基本のフィルタリング

基本のレポート フィルタ

HFNetChkProのレポート インターフェースは、どのようなフィルタリングでも使用できるようにデザインされています。 ギャラリーのレポートを開くとウィンドウが表示され、そこから必要な選択をすべて行なうことができます。

レポートの選択

ウィンドウの上部で、実行するレポートを選びます。 リストからリポートを選ぶとそのレポートの説明が表示され、ウィンドウの下部にはレポートの見本が表示されます。

レポートのフィルタリング

HFNetChkPro 4のレポートユーティリティには、強力なフィルタリング オプションが含まれています。 選択したレポートによっては、基本または 詳細 フィルタリングのいずれかを選ぶことができます。

基本のフィルタリングは、どのスキャン、どのパッチグループ、どのレベルの最大深刻度、どの製品についてレポートするかを選択できます。 さらに細かい分類や異なる分類方法が必要な場合は、 詳細フィルタ オプション を選択します。

レポートの表示

必要な選択を行なったら、レポートの作成をクリックして結果を表示します。


詳細フィルタリング

詳細レポート条件

詳細レポート条件ツールを使うと、スキャン結果をさらに絞り込んで、より意味のある情報を得ることができます。

フィールド

ユーザーがフィルタできる関連フィールドはすべてここに表示されます。 フィールドタイプに基づいて演算子のコンボ ボックスが適切に変形し、関連する演算子のみを含むようにします。 フィールドが「選択フィールド」と定義される場合は、値のコンボ ボックスが、対応する値のみ（例、マシン名）を選択できるようにします。

演算子

(=) このフィールドが、「値」のテキストと正確に一致しなければならないことを意味しています。

(<>) このフィールドが、「値」のテキストと等しくなってはならないことを意味しています。

(IN) ユーザーが値の「,」区切リストを提供し、フィールドが「値」のテキスト要素のひとつに正確に一致しなければならないことを意味しています。

NOT (IN) ユーザーが値の「,」区切リストを提供し、フィールドが「値」のテキスト要素のひとつと等しくてはならないことを意味しています。

(NULL) フィールドがデータベースのNULLでなければならないことを意味しています。

(NOT NULL) フィールドがデータベースのNULLであってはならないことを意味しています。

(>)、(<)、(<=)、(>=) はそれぞれ、「より大きい」、「より小さい」、「以下」、「以上」を意味しています。 値をフィルタアウトするために、数字の比較（値に基づく）またはアルファ比較（アルファベットに基づく）が行なわれます。

(LIKE) フィールドが提供されているワイルドカードの詳述に一致しなければならないことを意味しています。 %はどれでも、どの長さでも一致することを意味し、「 _ 」は 「 _ 」の文字数で指定されている長さのみに一致することを意味しています。 詳細は、SQL Server Books Online を参照するか、「SELECT」の記述の「LIKE」を見直してください。

(IS BLANK)、(IS NOT BLANK) は、テキストフィールドに空のストリング値がある、あるいは空のストリング値がない、ことを意味しています。

(LAST) 過去N日、N週、Nか月、N四半期またはN年を指定することができ、Criteria Builderがその期間の開始と現在の期間の終了を選びます。(例、 3/1/2002の「Last 2 Years」は、 1/1/2000 から 12/31/2002までの範囲となります。)

((X)ToDate) ある期間（日、週、月、四半期または年）から特定の日付を「日付」に指定し、Criteria Builderが今日までを含めて、その期間の開始を選択します。(例、 3/1/2002の 「(X)今日 年 」は、 1/1/2002 から 3/1/2002までの範囲となります。)

(Previous) ある期間（日、週、月、四半期または年）から特定の過去の日付を指定し、Criteria Builderがその期間の最終日までを含めて、その期間の開始を選択します。(例、 3/1/2002の「Previous Year」は、 1/1/2001 から 12/31/2001までの範囲となります。)

条件

レポート条件を設定したら、追加>> ボタンをクリックして ［条件] のウィンドウに追加します。 これにより、［条件］ウィンドウで使用されるAND>>、 OR>>、切り替え、グループ、アングループおよびすべてを クリアのコマンドがアクティブになります。 これらのコマンドを使って、順序の変更やグループの作成など、レポート条件をさらに細かく設定することができます。

例

ドメイン内でパッチ Q814078が不足しているすべてのマシンを表示したいとします。 パッチ リストレポートを選択し、レポート条件を追加して、次の詳細フィルタを作成します。


エクスポート

レポートのエクスポート

Report Viewerからレポートを様々な形式でエクスポートすることができます。

Report Viewerからのエクスポートには、RTF、PDF、HTML、XLS、TIF、TXT 、HFRの形式が使用できます。

ファイルをエクスポートするには、レポート実行後、ツールバーの エクスポートボタンをクリックします。 レポートのエクスポート ボックスから希望の形式とオプション、エクスポートファイル名を選択し、OKをクリックします。


レポート：凝縮パッチ リスト

各スキャン済みホストに対するマシン名およびパッチ ステータスを表示する 6 カラムの凝縮レポート。パッチ アイテムは、ブレティン番号 (MS00-000) として表示されます。

このレポートは、 パッチサマリーおよびマシンサマリーと同じ命名法を使用している各マシンとスキャンのパッチステータスを表示します。

サンプル


レポート：導入シート ステータス

このレポートは、導入シート情報のリストを示します。ライセンスされたシート、使用済みシート、使用可能なシートが含まれます。


レポート：CSV 用の凝縮パッチ リスト

このレポートはまずCSVエクスポートに最適な形式でデータを出力し、次にExcelにインポートできるようデザインされています。出力は、各パッチが1行に示されるシンプル テキスト形式です。パッチのステータスを表すアイコンを示す代わりに、M、F、I 、Wの文字で示します。Mは不足、Fは見つかった、Iは参照、Wは警告をそれぞれ意味します。

サンプル


レポート：マシン/OSリスト

このレポートは、スキャンされた各マシンの OS のリストを示します。注：このレポートにはフィルタ機能はありません。

サンプル


レポート：パッチ別マシン

BulletinID と Qnumber によって並べ替えられる各マシンのパッチ ステータスを表示します。

サンプル


レポート：スキャンされていないマシン

このレポートは、スキャンされなかったすべてのマシンと、スキャンされなかった理由のリストを示します。注：このオプションにはフィルタ機能はありません。

サンプル


レポート：不足している SP

このレポートは、サポート製品に対するサービスパックが不足しているすべてのマシンの概要を示します。このレポートは、単純な条件のフィルタをスキップして、ただちに詳細条件フィルタを表示します。

サンプル


レポート：パッチ注釈情報

このレポートは、すべてのパッチ注釈のリストを示します。

サンプル


レポート：パッチ最大深刻度情報

このレポートは、条件によってグループ分けされたすべてのパッチのリストを示します。これによって、ネットワーク管理者が、「クリティカル」や「高」として分類されたパッチを容易に見分けることができます。

サンプル


レポート：パッチ リスト

［不足］、［見つかった］、［参照用］、［警告］ によって並べ替えられた後、ユーザー プレファレンスによって並べ替えられたすべてのスキャン済みマシンに対する全パッチの短縮リストです（処理されたパッチごとに1行）。

サンプル


レポート：マシン別パッチ

マシン名によって並べ替えられる各マシンのパッチ ステータスを表示します。

サンプル


レポート：マシン詳細別パッチ

マシン名によって並べ替えられる各パッチの詳しいリスト。各パッチに対して、レポートに全サマリーと理由が示されます。数千台のコンピュータに対して実行すると、このレポートには長時間かかります。

サンプル


レポート：スキャン/導入履歴

このレポートは、システム全体のすべてのスキャンと導入のリストを示し、個々のスキャンと導入を誰が実行したかを示します。

サンプル


データベースの圧縮

HFNetChkPro はスキャン結果と導入結果をShavlikScans.mdbと呼ばれるJETデータベースに保存します。 このファイルはC:\Program Files\Shavlik Technologies\HFNetChkPro4などにあります。

MDBファイルはスキャンや導入を行なうたびに大きくなります。 ディスクスペースを節約し、パフォーマンスを高めるために、必要に応じてこのファイルを圧縮することをお薦めします。 これには、メニューバーからツール > データベースの圧縮/修復 を選択します。

コマンドラインを使ってMDBファイルを手動で圧縮するには、以下の手順にしたがいます。

1) HFNetChkProを終了します。

2) コマンド プロンプトを開きます。

3) C:\Program Files\Shavlik Technologies\HFNetChkPro4\4.0.XX.X ディレクトリ（ScanBrowser.exe がある）に進みます。

4) コマンド プロンプトで以下をタイプします。

stScanBrowser.exe /repair


サポートを受けるには

HFNetChkPro 4の技術サポートを利用するには、次のオプションがあります。

  • オンラインサポートURL

  • 評価版サポート用Eメールアドレス