コントロールリファレンス

ResizeKit2 VB/Delphi/C++Builderを使用してのアプリケーションの開発は、リサイズコントロールをデザイン時にフォームに配置し、必要な場合はそのコントロールのプロパティを設定します。

リサイズコントロール

リサイズコントロールは、フォーム上に表示されている全てのコントロールとそのフォントのサイズを自動的に調整（リサイズ）します。

※グリッド・スプレッド系コントロール内のセルのフォントサイズやセルサイズなどは、リサイズの対象外となります。

※サードパーティ製（市販）コントロールでもほとんどがリサイズ可能ですが、一部のものや新しいコントロールについてはリサイズ対象外となる場合があります。

【表記上の注意】

●カスタムプロパティやカスタムイベントの型の表記は、以下の通りです。

表記 | VisualBasic | C++Builder | Delphi
integer | Integer | short | SmallInt
long | Long | long | Longint
double | Double | double | Double
string | String | AnsiString/UnicodeString | String
bool | Boolean | bool | Boolean

●カスタムプロパティ、カスタムイベントの【書式】中のコントロール名の表記は以下の通りです。

表記 | 意味
resizecontrolname | リサイズコントロール名を示します。

＜ActiveX＞ ActiveXコントロール用書式

＜VCL＞ VCL用書式

※記述がActiveXとVCLに分れていない場合はActiveXコントロール用の書式となります。

●解説の中のプログラムについては、VisualBasic用のコーディング例になります。

●フォームデザイン時の注意（VCL）

ResizeKitコントロールを配置したフォームのプロパティを

AutoScroll: False

Scaled: False

Position: poDefaultPosOnly or poDesigned or poScreenCenter

に設定して下さい。

●プロパティ一覧

カスタムプロパティ | 内容
Enabled | リサイズ機能の設定
FormHeight | フォーム初期表示時の高さの設定
FormMaxHeight | フォームの最大高さの設定
FormMaxWidth | フォームの最大幅の設定
FormMinHeight | フォームの最小高さの設定
FormMinWidth | フォームの最小幅の設定
FormPos | フォームの表示位置の設定
FormWidth | フォーム初期表示時の幅の設定
NoResizeCtl | リサイズを行わないコントロールの設定
NoResizeFntCtl | フォントのリサイズを行わないコントロールの設定
ResizeFont | 全コントロールのフォントのリサイズ有無の設定
ValidTaskbar | リサイズ時におけるタスクバーのサイズの考慮の有無を設定

●メソッド一覧

カスタムメソッド | 内容
DynamicAdd | 動的にコントロールを追加した際にリサイズ対象コントロールを更新
DynamicDelete | 動的にコントロールを削除した際にリサイズ対象コントロールを更新

メソッドはVCL専用です。

●イベント一覧

カスタムイベント | 内容
ExitResize | リサイズの直後に発生


ActiveX VisualBasic用です。

ActiveX
  VisualBasic用です。


bool型

VisualBasic | Boolean
C++Builder | bool
Delphi | Boolean


double型

VisualBasic | Double
C++Builder | double
Delphi | Double


DynamicAdd（リサイズコントロール／カスタムメソッド）

【機能】

動的にコントロールを追加した際にリサイズ対象コントロールを更新します。

【書式】

(1)C++Builder     [form.]resizekitcontrolname->DynamicAdd()

(2)Delphi           [form.]resizekitcontrolname.DynamicAdd

【引数】

ありません。

【戻り値】

ありません。

【解説】

動的にコントロールを追加した後にフォームのリサイズを行い、追加したコントロールがリサイズされない場合は当メソッドを実行してください。実行するタイミングは動的にコントロールを追加した後です。

当メソッドを実行しなくても、動的に追加したコントロールはほとんどの場合、正しくリサイズされますが、コントロールの追加と削除を繰り返す場合などは当メソッドを実行することをお勧めいたします。

当メソッドはVCL専用です。


DynamicDelete（リサイズコントロール／カスタムメソッド）

【機能】

動的にコントロールを削除した際にリサイズ対象コントロールを更新します。

【書式】

(1)C++Builder     [form.]resizekitcontrolname->DynamicDelete()

(2)Delphi           [form.]resizekitcontrolname.DynamicDelete

【引数】

ありません。

【戻り値】

ありません。

【解説】

動的にコントロールを削除した後にフォームのリサイズを行い、コントロールが正しくリサイズされない場合は当メソッドを実行してください。実行するタイミングは動的にコントロールを削除した後です。

当メソッドを実行しなくても、ほとんどの場合、正しくリサイズされますが、コントロールを削除した後に別のコントロールを追加してリサイズを行う場合は当メソッドを実行することをお勧めいたします。

当メソッドはVCL専用です。


Enabled（リサイズコントロール／カスタムプロパティ）

【機能】

リサイズ機能の設定を行います。

【書式】

[form.]resizecontrolname.Enabled [ = bool ]

【設定値】

値 | 説明
True | リサイズの機能を有効にする（初期値）
False | リサイズの機能を無効にする

【解説】

Enabled プロパティをFalseに設定した場合は、フォームを拡大縮小してもリサイズ機能は働きません。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


ExitResize（リサイズコントロール／カスタムイベント）

【機能】

フォームをリサイズした直後に発生します。

【書式】

＜ActiveX＞ Sub resizecontrolname_ExitResize(ByVal XScale As Double, ByVal YScale As Double)

＜VCL＞ form.resizecontrolname ExitResize(Sender: TObject; XScale, YScale: Double)

【引数】

XScale: 初期表示時のフォームの幅に対する、リサイズ後のフォームの幅の倍率

（リサイズ後のフォームの幅／初期表示時のフォームの幅）

YScale: 初期表示時のフォームの高さに対する、リサイズ後のフォームの高さの倍率

（リサイズ後のフォームの高さ／初期表示時のフォームの高さ）

【解説】

フォームをリサイズした直後に行いたい処理をイベント内に記述します。

例）

Private Sub ResizeKit1_ExitResize(ByVal XScale As Double, ByVal YScale As Double)

Dim Mes As String

Mes = "フォームの初期表示時の" & vbCr

Mes = Mes & "「幅」に対して" & Left(CStr(XScale), 5) & "倍" & vbCr

Mes = Mes & "「高さ」に対して" & Left(CStr(YScale), 5) & "倍" & vbCr

Mes = Mes & "でリサイズされました。"

MsgBox Mes

End Sub


FormHeight, FormWidth（リサイズコントロール／カスタムプロパティ）

【機能】

フォームを初期表示する時の高さや幅をピクセル単位で設定します。

【書式】

[form.]resizecontrolname.FormHeight [ = long ]

[form.]resizecontrolname.FormWidth [ = long ]

【設定値】

正の整数。（最小値は0です。）

初期値は0（フォームの高さ、幅の設定なし）です。

【解説】

FormHeight プロパティとFormWidthプロパティに、共に0より大きい値が設定されている場合、設定された値を基にフォームを表示します。

対象となるのはプログラムの初期起動時など、そのフォームを初めて表示した場合に限られます。

これらのプロパティの片方が0、もしくは両方が0の場合は、フォームの高さや幅はデザイン時の値、又はプログラム中で設定された値になります。

これらのプロパティの設定値は、FormMaxHeight、FormMaxWidth、FormMinHeight、FormMinWidthの各プロパティに設定した範囲内の値を設定して下さい。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


FormMaxHeight, FormMaxWidth（リサイズコントロール／カスタムプロパティ）

【機能】

フォームの最大の高さや幅をピクセル単位で設定します。

【書式】

[form.]resizecontrolname.FormMaxHeight [ = long ]

[form.]resizecontrolname.FormMaxWidth [ = long ]

【設定値】

正の整数。（最小値は0です。）

初期値は0（フォームの最大高さ、幅の設定なし）です。

【解説】

FormMaxHeight プロパティとFormMaxWidthプロパティに、共に0より大きい値が設定されている場合、その値がフォームを大きくする時の最大値となります。

設定値以上にフォームを大きくしようとしてもできませんので注意して下さい。

これらのプロパティの片方が0、もしくは両方が0の場合は、フォームの高さや幅の最大値は設定されません。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


FormMinHeight, FormMinWidth（リサイズコントロール／カスタムプロパティ）

【機能】

フォームの最小の高さや幅をピクセル単位で設定します。

【書式】

[form.]resizecontrolname.FormMinHeight [ = long ]

[form.]resizecontrolname.FormMinWidth [ = long ]

【設定値】

正の整数。（最小値は0です。）

初期値は0（フォームの最小高さ、幅の設定なし）です。

【解説】

FormMinHeight プロパティとFormMinWidthプロパティに、共に０より大きい値が設定されている場合、その値がフォームを小さくする時の最小値となります。

設定値以下にフォームを小さくしようとしてもできませんので注意して下さい。

これらのプロパティの片方が0、もしくは両方が0の場合は、フォームの高さや幅の最小値は設定されません。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


FormPos（リサイズコントロール／カスタムプロパティ）

【機能】

フォームの表示位置を設定します。

【書式】

＜ActiveX＞ [form.]resizecontrolname.FormPos [ = Integer ]

＜VCL＞ [form.]resizecontrolname.FormPos [ := TResizeFormPos ]

【設定値】

値 | 説明
0(rpDefault) | デフォルト（初期又は直前のフォーム位置のまま）
1(rpTopLeft) | 左上
2(rpTopCenter) | 上中央
3(rpTopRight) | 右上
4(rpMiddleLeft) | 左
5(rpMiddleCenter) | 中央
6(rpMiddleRight) | 右
7(rpBottomLeft) | 左下
8(rpBottomCenter) | 下中央
9(rpBottomRight) | 右下

数値はActiveXコントロール用の記述で、()内の記述はVCL用です。

初期値は0(rpDefault)です。

VCL 用のTResizeFormPosは以下の様に定義されています。

TResizeFormPos = (rpDefault, rpTopLeft, rpTopCenter, rpTopRight, rpMiddleLeft, rpMiddleCenter, rpMiddleRight, rpBottomLeft, rpBottomCenter, rpBottomRight);

【値の設定】　デザイン時、実行時

【値の参照】　実行時


integer型

VisualBasic | Integer
C++Builder | short
Delphi | SmallInt


long型

VisualBasic | Long
C++Builder | long
Delphi | Longint


NoResizeCtl（リサイズコントロール／カスタムプロパティ）

【機能】

リサイズを行わないコントロールを設定します。

【書式】

[form.]resizecontrolname.NoResizeCtl [ = string ]

【設定値】

フォーム上に配置してあるコントロール名。

複数指定する場合はセミコロンで区切って下さい。

例）ResizeKit1.NoResizeCtl = "Command1;File1;List1"

又、VisualBasicの場合にコントロール配列を指定する場合は、インデックスも含めて指定して下さい。

コントロール名だけで全てのコントロール配列を対象にする事はできません。

例）フォーム上にCommand1(0),Command1(1),Command1(2)がある時にResizeKit1.NoResizeCtl = "Command1(0);Command1(1)"と指定するとCommand1(0),Command1(1)のリサイズは行われずに、Command1(2)のみリサイズが行われます。

【解説】

VCL の場合は指定するコントロールのParentFontプロパティをFalseに設定して下さい。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


NoResizeFntCtl（リサイズコントロール／カスタムプロパティ）

【機能】

フォントのリサイズを行わないコントロールを設定します。

【書式】

[form.]resizecontrolname.NoResizeFntCtl [ = string ]

【設定値】

フォーム上に配置してあるコントロール名。

複数指定する場合はセミコロンで区切って下さい。

例）ResizeKit1.NoResizeFntCtl = "Command1;File1;List1"

又、VisualBasicの場合にコントロール配列を指定する場合は、インデックスも含めて指定して下さい。

コントロール名だけで全てのコントロール配列を対象にする事はできません。

例）フォーム上にCommand1(0),Command1(1),Command1(2)がある時にResizeKit1.NoResizeFntCtl
 = "Command1(0);Command1(1)"と指定するとCommand1(0),Command1(1)のフォントは変更されずに、Command1(2)のフォントのみ変更されます。
全てのコントロール配列のフォントを変更したくない場合はResizeKit1.NoResizeFntCtl = "Command1(0);Command1(1);Command1(2)"と指定します。

【解説】

ResizeFont プロパティがTrueの場合でも、NoResizeFntCtlプロパティで指定されたコントロールのみ、フォントのリサイズを行いません。

VCL の場合は指定するコントロールのParentFontプロパティをFalseに設定して下さい。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


ResizeFont（リサイズコントロール／カスタムプロパティ）

【機能】

フォーム上の全コントロールのフォントのリサイズの有無を設定します。

【書式】

[form.]resizecontrolname.ResizeFont [ = bool ]

【設定値】

値 | 説明
True | フォントのリサイズをする（初期値）
False | フォントのリサイズをしない

【解説】

ResizeFont プロパティがTrueの場合でも、NoResizeFntCtlプロパティで指定されたコントロールのフォントのリサイズは行いません。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


ResizeKit VB/Delphi/C++Builderプログラミングマニュアル

フォームリサイズコンポーネント

ResizeKit

VB

Delphi

C++Builder

プログラミングマニュアル


string型

VisualBasic | String
C++Builder | AnsiString or UnicodeString
Delphi | String


ValidTaskbar（リサイズコントロール／カスタムプロパティ）

【機能】

リサイズ時におけるタスクバーのサイズの考慮の有無を設定します。

【書式】

[form.]resizecontrolname.ValidTaskbar [ = bool ]

【設定値】

値 | 説明
True | リサイズ時にタスクバーのサイズを考慮する（初期値）
False | リサイズ時にタスクバーのサイズを考慮しない

【解説】

ValidTaskbar プロパティが有効となるのは、フォームのサイズがスクリーンのサイズより大きい場合です。

【値の設定】　デザイン時、実行時

【値の参照】　実行時


VCL Delphi､C++Builder用です。

VCL
  Delphi､C++Builder用です。