TeeChart

TeeChart プログラミングガイド

TeeChart アセンブリ

解説

TeeChart Pro .NETチャーティングライブラリーへようこそ。

TeeChartの使用方法についての詳細はTeeChartチュートリアルやTChartクラスを参照してください。

必要条件

アセンブリ：TeeChart.dll

© 2002-2008 Steema Software SL. All rights reserved.
Localized by Newtone


Steema.TeeChart

Steema.TeeChart 名前空間

名前空間の階層構造

パブリック クラス

Editor | チャートエディタ。
Texts | テキストメッセージおよびダイアログの定数。
TeeEvent | 内部使用。基本的なチャートのイベントクラス。
GalleryPanel | 系列ギャラリを保持するために派生したWinForms Panelクラス。
TChart | Windowsフォームに使用される基本的なChartクラス。
AllowScrollEventArgs | AllowScrollイベントで使用されるイベントの引数クラス。
GalleryChart | ギャラリパネルに表示するための内部チャートクラス。
GalleryChartCollection | 内部使用。ギャラリのチャートリスト。
ButtonColor | ダイアログボタンの色。
ButtonPen | ダイアログボタンのペン。
GetAxisDrawLabelEventArgs |
AxisLabels | 軸ラベル特性。
AxisLabelsItems | カスタムラベルのリスト。
AxisLabelItem |
AxisTitle | 軸タイトル特性。
Axis | すべての軸特性にアクセスします。
AxisLinePen | 軸の線を描くペンを設定します。
GridPen | 各軸ラベルの位置にグリッド線を描くペンの種類を設定します。
TicksPen | 軸線に沿って軸マーカを描くペンの種類を設定します。
CustomAxes | カスタム系列のリストにアクセスするために使用されます。
DepthAxis | 奥軸の特性。
Axes | すべてのTChart軸のリストにアクセスします。カスタム軸と奥軸を含んでいます。
Chart | チャートコンテンツ。使用については、TChartやWebChartを参照してください。
ChartToolTip | ツールチップ。
TeeChartException | 基本的なTeeChartの例外クラス。
TeeEventListeners | TeeChartコンポーネントのインターコミュニケーションのリストです。
TeeMouseEvent | 内部使用。マウスイベント。
NotifySeriesEventArgs |
ChangeOrderEventArgs |
DblClickSeriesEventArgs |
ChartListBox | ChartListBoxコンポーネントクラス。
Commander | Commanderコントロール。
SetLabelEventArgs | CommanderのラベルテキストをサポートするためのEventArgs。
SymbolDrawEventArgs |
LegendItems | LegendItemの凡例項目を保持するためのシリアライズされたリストクラスです。
LegendItem | このクラスは、凡例に配置される各項目の特性について説明します。
LegendSymbol | 凡例のシンボル特性。
Legend | チャートの凡例特性にアクセスします。
LegendTitle |
Page | チャートのページ特性。
Panel | チャートのパネル特性。
ChartPrintJob | このクラスは、印刷時にチャートのアクセスを提供します。
Margins | 各ページの印刷のマージンにアクセスします。
Printer | チャートの印刷特性。
SerializeEventArgs | GetAxisLabelイベントのデータを提供します。GetAxisLabelEventHandlerを参照してください。
GetAxisLabelEventArgs | GetAxisLabelイベントのデータを提供します。GetAxisLabelEventHandlerを参照してください。
GetNextAxisLabelEventArgs | GetNextAxisLabelイベントのデータを提供します。GetNextAxisLabelEventHandlerを参照してください。
GetAxesChartRectEventArgs |
GetLegendRectEventArgs | GetLegendRectイベントのデータを提供します。GetLegendRectEventHandlerを参照してください。
GetLegendTextEventArgs | GetLegendTextイベントのデータを提供します。GetLegendTextEventHandlerを参照してください。
GetLegendPosEventArgs | GetLegendPosイベントのデータを提供します。GetLegendPosEventHandlerを参照してください。
Title | 基本的なタイトルの特性。
Header | チャートの上部に表示されるテキスト。
Footer | チャートの下部に表示されるテキスト。
Utils | このクラスは、チャートのユーティリティプロシージャを含んでいます。
Wall | 軸を補足する壁パネルの特性。
Walls | 壁の特性にアクセスします。
LeftWall | チャートの左側の壁パネル。
RightWall | チャートの右側の壁パネル。
BackWall | チャートの背面の壁パネル。
BottomWall | チャートの下側の壁パネル。
ZoomScroll | 内部使用。ズームおよびスクロールのサポートをします。
Scroll | チャートのマウススクロール特性。
Zoom | tChart1.Zoomプロパティで使用されます。マウスズーム属性を定義します。

パブリック インターフェイス

IChart | 共通のチャート特性のインターフェイス。
ITeeEventListener | コンポーネント間のコミュニケーションをサポートします。

パブリック デリゲート

SeriesEventHandler | 共通の系列のイベントハンドラ。
AllowScrollEventHandler | スクロールのイベントハンドラ。
GetAxisDrawLabelEventHandler |
AxisCalcPosLabelsEventHandler |
PaintChartEventHandler | チャート描画のイベントハンドラ。
ChartPrintEventHandler | チャート印刷のイベントハンドラ。
ChangeActiveEventHandler |
ChangeColorEventHandler |
ChangeOrderEventHandler |
OtherItemsChangeEventHandler |
RefreshEventHandler |
RemovedSeriesEventHandler |
EditSeriesEventHandler | ChartListBoxのイベントハンドラ。
SetLabelEventHandler | CommanderのSetLabelのイベントハンドラ。
SymbolDrawEventHandler |
GetAxisLabelEventHandler | AxisLabelのイベントハンドラ。
GetNextAxisLabelEventHandler | GetNextAxisLabelのイベントハンドラ。
GetLegendRectEventHandler | GetLegendRectのイベントハンドラ。
GetLegendPosEventHandler | GetLegendPosのイベントハンドラ。
GetLegendTextEventHandler | GetLegendTextのイベントハンドラ。
SerializeEventHandler | シリアライズタイプのイベントハンドラ。
GetAxesChartRectEventHandler |
CompareEventHandler | 内部使用。Sortのイベントハンドラ。
SwapEventHandler | 内部使用。Sortのイベントハンドラ。

パブリック 列挙体

AxisLabelAlign | 軸ラベルの位置を設定します。
AxisLabelStyle | Styleプロパティの使用可能な値を定義します。
PositionUnits | Axis.Labels.PositionUnitsプロパティの単位を指定します。
ChartClickedPartStyle |
MouseEventKinds | マウスの状態を表します。
CheckBoxesStyle | 凡例項目のインタラクティブボックスの外観を定義します。
LegendSymbolPosition | 凡例のカラーボックス（シンボル）の位置を定義します。
LegendSymbolSize | 凡例のカラーボックス（シンボル）のサイズを定義する単位です。
LegendStyles | LegendStyleプロパティの使用可能な値です。
LegendTextStyles | TextStyleプロパティの使用可能な値です。
LegendAlignments | Alignmentプロパティの使用可能な値です。
PanelMarginUnits | MarginUnitsプロパティの使用可能な値です。
PrintMarginUnits | MarginUnitsプロパティのための単位を設定します。
DateTimeSteps | DateTimeステップを定義します。
RegistryValueKind |
ScrollModes | Allowプロパティの使用可能な値です。
ZoomDirections | Directionプロパティの使用可能な値です。

パブリック 構造体

ChartClickedPart

プロテクト クラス

AxisDraw

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart 階層構造

System.Object

Steema.TeeChart.Chart.ChartToolTip

Steema.TeeChart.ChartPrintJob

Steema.TeeChart.Margins

Steema.TeeChart.TeeEvent

Steema.TeeChart.TeeMouseEvent

Steema.TeeChart.Texts

Steema.TeeChart.Utils

System.Collections.ArrayList

Steema.TeeChart.AxisLabelsItems

Steema.TeeChart.GalleryPanel.GalleryChartCollection

Steema.TeeChart.LegendItems

Steema.TeeChart.TeeEventListeners

System.Collections.CollectionBase

Steema.TeeChart.CustomAxes

System.EventArgs

Steema.TeeChart.ChangeOrderEventArgs

Steema.TeeChart.Commander.SetLabelEventArgs

Steema.TeeChart.DblClickSeriesEventArgs

Steema.TeeChart.GetAxesChartRectEventArgs

Steema.TeeChart.GetAxisDrawLabelEventArgs

Steema.TeeChart.GetAxisLabelEventArgs

Steema.TeeChart.GetLegendPosEventArgs

Steema.TeeChart.GetLegendRectEventArgs

Steema.TeeChart.GetLegendTextEventArgs

Steema.TeeChart.GetNextAxisLabelEventArgs

Steema.TeeChart.NotifySeriesEventArgs

Steema.TeeChart.SerializeEventArgs

Steema.TeeChart.SymbolDrawEventArgs

Steema.TeeChart.TChart.AllowScrollEventArgs

System.Exception

Steema.TeeChart.TeeChartException

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Axes

Steema.TeeChart.Axis

Steema.TeeChart.DepthAxis

Steema.TeeChart.Axis.AxisDraw

Steema.TeeChart.Chart

Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Axis.AxisLinePen

Steema.TeeChart.Axis.GridPen

Steema.TeeChart.Axis.TicksPen

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.AxisLabelItem

Steema.TeeChart.AxisLabels

Steema.TeeChart.AxisTitle

Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.Legend

Steema.TeeChart.Title

Steema.TeeChart.Footer

Steema.TeeChart.Header

Steema.TeeChart.LegendTitle

Steema.TeeChart.Panel

Steema.TeeChart.Wall

Steema.TeeChart.Walls.BackWall

Steema.TeeChart.Walls.BottomWall

Steema.TeeChart.Walls.LeftWall

Steema.TeeChart.Walls.RightWall

Steema.TeeChart.LegendItem

Steema.TeeChart.LegendSymbol

Steema.TeeChart.Page

Steema.TeeChart.Printer

Steema.TeeChart.Walls

Steema.TeeChart.ZoomScroll

Steema.TeeChart.Scroll

Steema.TeeChart.Zoom

System.Windows.Forms.Control

Steema.TeeChart.Editor

Steema.TeeChart.TChart

Steema.TeeChart.GalleryPanel.GalleryChart

System.Windows.Forms.ButtonBase

System.Windows.Forms.Button

Steema.TeeChart.ButtonColor

Steema.TeeChart.ButtonPen

System.Windows.Forms.ListControl

System.Windows.Forms.ListBox

Steema.TeeChart.ChartListBox

System.Windows.Forms.ScrollableControl

System.Windows.Forms.Panel

Steema.TeeChart.GalleryPanel

System.Windows.Forms.ToolBar

Steema.TeeChart.Commander

参照

SteemaTeeChart 名前空間


Steema.TeeChart.Axes

Steema.TeeChart.Axes クラス

TChart軸のリストにアクセスする為のクラス。 カスタム軸と奥軸を含んでいます。

この型のすべてのメンバの一覧については、Axes メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Axes : TeeBase , IComponent, IDisposable

解説

データを見やすく表示するためにスケールに連動して軸はチャートに置かれます。通常、下図のように軸にはX軸、Y軸、Z軸があります。

TeeChartは、5つの主軸（左・上・右・下・奥）があります。複数の系列を同じチャート上に描画する場合、各系列のために異なる軸スケールを持つ各軸と関連付ることができます。

左軸と右軸はY軸を示します。
上軸と下軸はX軸を示します。
奥軸はZ軸を示します。

複数軸
TeeChart for .Net 2Jは、実行時で複数軸を表示できます。複数軸は、独自のスケール軸を任意の開始/終了ポイントでチャート上のどこにでも配置できます。

下図は複数軸の使用例です。

詳細についてはチュートリアルの「第4章 - 軸の制御」を参照してください。

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Axes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axes 全メンバ

Axes 概要

コンストラクタ

Constructor

パブリック フィールド

NumFixedAxes

パブリック メソッド

CreateNewAxis |
Draw |
IndexOf |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StringItems |

パブリック プロパティ

Bottom | 下軸のラベルと書式属性を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Count | カスタム軸の数を返します。
Custom | 指定したインデックスのカスタム軸にアクセスします。
Depth | 奥軸のラベルと書式属性を定義します。
DepthTop | 奥軸のラベルと書式属性を定義します。
DrawBehind | 系列の前面/背面に軸を描画します。
Item | 指定したインデックスの軸にアクセスします。
Left | 左軸のラベルと書式属性を定義します。
Right | 右軸のラベルと書式属性を定義します。
Top | 上軸のラベルと書式属性を定義します。
Visible | すべてのチャート軸を表示/非表示します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeCustom

参照

Axes クラス | Steema.TeeChart 名前空間


Axes コンストラクタ

Steema.TeeChart.Axes コンストラクタ

public Axes(Chart c)

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axes フィールド

パブリック フィールド

NumFixedAxes

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Axes クラス | Steema.TeeChart 名前空間


NumFixedAxes

Steema.TeeChart.Axes.NumFixedAxes フィールド

public Int32 NumFixedAxes

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axes メソッド

パブリック メソッド

CreateNewAxis |
Draw |
IndexOf |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StringItems |

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeCustom

参照

Axes クラス | Steema.TeeChart 名前空間


CreateNewAxis

Steema.TeeChart.Axes.CreateNewAxis メソッド

public static Axis CreateNewAxis(Chart chart)

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Axes.Draw メソッド

オーバーロードの一覧

public Void Draw()
public Void Draw(Steema.TeeChart.Drawing.Graphics3D)

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Axes.Draw メソッド

public Void Draw()

参照

Draw オーバーロードの一覧 | Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Axes.Draw メソッド

public Void Draw(Graphics3D g)

参照

Draw オーバーロードの一覧 | Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


IndexOf

Steema.TeeChart.Axes.IndexOf メソッド

public Int32 IndexOf(Axis a)

解説

このメソッドは、軸コレクションの指定した軸のインデックスを取得します。

例

[C#]
private void button1_Click(object sender, System.EventArgs e) {
      MessageBox.Show(tChart1.Axes.IndexOf(tChart1.Axes.Left).ToString());
}

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


SetChart

Steema.TeeChart.Axes.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


ShouldSerializeCustom

Steema.TeeChart.Axes.ShouldSerializeCustom メソッド

protected abstract Boolean ShouldSerializeCustom()

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


StringItems

Steema.TeeChart.Axes.StringItems メソッド

public String[] StringItems()

解説

すべてのチャート軸の文字列名を取得する際に便利です。

例

[C#]
private void button1_Click(object sender, System.EventArgs e) {
      string[] axes = tChart1.Axes.StringItems();
      string listAxes="";
      foreach(string s in axes) {
        listAxes = s + " " + listAxes;
      }
      MessageBox.Show(listAxes);
}

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axes プロパティ

パブリック プロパティ

Bottom | 下軸のラベルと書式属性を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Count | カスタム軸の数を返します。
Custom | 指定したインデックスのカスタム軸にアクセスします。
Depth | 奥軸のラベルと書式属性を定義します。
DepthTop | チャートの左上角の奥軸を返します。
DrawBehind | 系列の前面/背面に軸を描画します。
Item | 指定したインデックスの軸にアクセスします。
Left | 左軸のラベルと書式属性を定義します。
Right | 右軸のラベルと書式属性を定義します。
Top | 上軸のラベルと書式属性を定義します。
Visible | すべてのチャート軸を表示/非表示します。

参照

Axes クラス | Steema.TeeChart 名前空間


Bottom

Steema.TeeChart.Axes.Bottom プロパティ

下軸のラベルと書式属性を定義します。
public Axis Bottom {get;}

解説

下軸のラベルと書式属性を定義します。また、系列ポイントの配置場所についても制御します。

すべてのTChartクラスは5つのAxis（左・上・右・下・奥）を持っています。

詳細につきましてはAxesのヘルプを参照してください。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Count

Steema.TeeChart.Axes.Count プロパティ

カスタム軸の数を返します。

public Int32 Count {get;}

解説

カスタム軸の数を返します。

例

[C#]

//チャート内のカスタム軸の数;
MessageBox.Show (tChart1.Axes.Count);

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Custom

Steema.TeeChart.Axes.Custom プロパティ

指定したインデックスのカスタム軸にアクセスします。
public CustomAxes Custom {get;}

解説

指定したインデックスのカスタム軸にアクセスします。

例

[C#]

//カスタム軸の特性を変更します。

 Axes a = tChart1.Axes;

a.Custom[0].Labels.Font.Bold=true;
a.Custom[0].Labels.Font.Color=Color.Blue;

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Depth

Steema.TeeChart.Axes.Depth プロパティ

奥軸
public Axis Depth {get;}

解説

奥軸またはZ軸の特性にアクセスします。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


DepthTop

Steema.TeeChart.Axes.DepthTop プロパティ

チャートの左上の端に配置する奥軸を返します。

public Axis DepthTop {get;}

解説

チャートの左上の端に配置する奥軸を返します。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


DrawBehind

Steema.TeeChart.Axes.DrawBehind プロパティ

系列の前面/背面に軸を描画します。

public Boolean DrawBehind {get; set;}

解説

デフォルト値：true。

系列の前面に軸の描画を有効/無効にします。falseの場合、軸は系列上に描画されます。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Item

Steema.TeeChart.Axes.Item プロパティ

指定したインデックスの軸にアクセスします。
public Axis Item(Int32 index) {get;}

解説

指定したインデックスの軸にアクセスします。

例

[
C#]
private void button1_Click(object sender, System.EventArgs e) {
      Steema.TeeChart.Axis myAxis = tChart1.Axes[0];
      myAxis.OtherSide = true;
}

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Left

Steema.TeeChart.Axes.Left プロパティ

左軸のラベルと書式属性を定義します。
public Axis Left {get;}

解説

左軸のラベルと書式属性を定義します。また、系列ポイントの配置場所についても制御します。

すべてのTChartクラスは5つのAxis（左・上・右・下・奥）を持っています。

例

[C#]

tChart1.Axes.Left.Visible = true;

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Right

Steema.TeeChart.Axes.Right プロパティ

右軸のラベルと書式属性を定義します。
public Axis Right {get;}

解説

右軸のラベルと書式属性を定義します。また、系列ポイントの配置場所についても制御します。

すべてのTChartクラスは5つのAxis（左・上・右・下・奥）を持っています。

詳細につきましてはAxesのヘルプを参照してください。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Top

Steema.TeeChart.Axes.Top プロパティ

上軸のラベルと書式属性を定義します。
public Axis Top {get;}

解説

上軸のラベルと書式属性を定義します。また、系列ポイントの配置場所についても制御します。

すべてのTChartクラスは5つのAxis（左・上・右・下・奥）を持っています。

上の軸は、以下のように定義済みです：

Horizontal = true
OtherSide = true

詳細につきましてはAxesのヘルプを参照してください。

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Visible

Steema.TeeChart.Axes.Visible プロパティ

すべてのチャート軸を表示/非表示します。

public Boolean Visible {get; set;}

解説

デフォルト値：true

一度に5つのチャート軸を表示/非表示します。

各軸は、それぞれのVisibleプロパティにより表示/非表示します。

例

[C#]

tChart1.Axes.Visible = true;

参照

Axes クラス | Axes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis

Steema.TeeChart.Axis クラス

すべての軸の特性にアクセスします。

この型のすべてのメンバの一覧については、Axis メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Axis : TeeBase , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis 全メンバ

Axis 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

GetAxisDrawLabel

パブリック フィールド

AxisClickGap
IAxisSize
IEndPos
IsDepthAxis
IStartPos

パブリック メソッド

AdjustMaxMin | 従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。
AdjustMaxMinRect | Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
CalcLabelStyle | 最も論理的な軸ラベルスタイルを返します。
CalcMinMax | 関連付けされている系列の最小値および最大値を返します。
CalcPosPoint | 指定したピクセル単位の画面座標に該当する軸スケール値を返します。
CalcPosValue | 指定した軸スケール値に該当する画面座標値をピクセル単位で返します。
CalcSizeValue | 指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。
CalcXPosValue | 指定したValueパラメータに該当する水平座標値をピクセル単位で返します。
CalcXYIncrement | 計算された軸ラベルのインクリメントを返します。
CalcYPosValue | 軸スケールでValueパラメータに該当する垂直座標位置をピクセル単位で返します。
Clicked | XとY座標値が軸の位置に近いかどうかを返します。
DateTimeDefaultFormat | astepパラメーターの値により、時間か日付を返します。
DateTimeIncrement | DateTimeインクリメントのための定数を設定します。
Draw | 現在の軸スケールで指定した画面位置に軸を表示します。
DrawAxisLabel | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
DrawTitle | 内部使用。チャート描写中にタイトルを表示します。
FindDateTimeStep | 内部使用。軸のDatetimeインクリメントを返します。
InternalCalcRange | 内部使用。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsCustom | 軸がカスタム軸の場合、trueを返します。
MaxLabelsWidth | すべての軸ラベルの最大幅をピクセル単位で返します。
Scroll | Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。
SetMinMax | 軸の最小スケールおよび最大スケールを変更します。
TitleOrName |

パブリック プロパティ

Automatic | 関連付けられている系列に基づいて軸の最大値および最小値を計算します。
AutomaticMaximum | 軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。
AutomaticMinimum | 軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。
AxisPen | 軸を描くペンの種類を設定します。
CalcIncrement | 計算された軸ラベルのインクリメントを返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
EndPosition | 軸の終了位置を0～100%で設定します。
Grid | チャートグリッドを描くペンを設定します。
GridCentered | このプロパティの代わりにAxis.Grid.Centeredプロパティを使用してください。
Horizontal | カスタム軸を水平軸として描画するかどうか設定します。
Increment | 軸ラベル間での最小ステップを設定します。日付時間軸のためのDateTimeStepsが使用できます。
Inverted | 軸の最小値と最大値のスケールを交換します。
IsDateTime | 指定された軸の値がDateTimeかどうかを返します。
Labels | 軸ラベルの特性にアクセスします。
LabelsOnAxis | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Logarithmic | Trueの場合、軸を対数関数でスケールします。
LogarithmicBase | AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。
Maximum | 軸の最大値を設定します。
MaximumOffset | 軸の最大位置にマージンとして残す量をピクセル単位で設定します。
MaxXValue | 指定した軸の最大X値を返します。
MaxYValue | 指定した軸の最大Y値を返します。
MinAxisIncrement | デフォルト値：1e-12。最小の軸インクリメントを取得/設定します。
Minimum | 軸の最小値を設定します。
MinimumOffset | 軸の最小位置にマージンとして残す量をピクセル単位で設定します。
MinorGrid | 副目盛の特性を設定します。
MinorTickCount | 軸の副目盛の数を定義します。
MinorTicks | 軸の副目盛を描くペンを定義します。
MinXValue | 指定した軸の最小X値を返します。
MinYValue | 指定した軸の最小Y値を返します。
OtherSide | 軸を反対側へ移動します。
PosAxis | 旧式：Positionプロパティを使用してください。
Position | 軸を描画する位置を設定します。
PositionUnits | 軸の位置を定義するPositionPercentプロパティの単位を設定します。
RelativePosition | 軸の位置をチャートに対する0～100%で設定します。
StartPosition | 軸の開始位置を0～100%で設定します。
TickOnLabelsOnly | 軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。
Ticks | 軸の線に沿った軸マーカを描くペンの種類を定義します。
TicksInner | 軸の線の内側に軸マーカを描くペンの種類を定義します。
Title | 軸タイトルの特性にアクセスします。
TitleSize | タイトルとチャート間の距離を自動的に計算します。
Visible | 一度に5つの全チャート軸を表示/非表示します。
ZPosition | チャートの深さに沿ってZ軸の位置を設定します。

プロテクト フィールド

bVisible
FAxisDraw
iHideBackGrid
iHideSideGrid
InternalUse (TeeBaseの継承元)
posTitle
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

CalcRect | 軸を作成する際にチャートで使用される内部的メソッド。
Dispose |
DoGetAxisDrawLabel |
DrawAxisLabel | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
InflateAxisPos |
InternalCalcLabelStyle |
OnDisposing |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetInverted |
SetStringProperty (TeeBaseの継承元) |
ShouldSerializeAutomatic |
ShouldSerializeHorizontal |
ShouldSerializeMaximum |
ShouldSerializeMinimum |
ShouldSerializeOtherSide |
ShouldSerializeZPosition |

参照

Axis クラス | Steema.TeeChart 名前空間


Axis コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Axis コンストラクタ

オーバーロードの一覧

public Axis()
public Axis(Steema.TeeChart.Chart)
public Axis(System.Boolean, System.Boolean, Steema.TeeChart.Chart)
public Axis(System.ComponentModel.IContainer)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Axis コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Axis コンストラクタ

public Axis()

参照

Axis コンストラクタのオーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Axis コンストラクタ

Steema.TeeChart.Axis コンストラクタ

public Axis(Chart c)

参照

Axis コンストラクタのオーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Axis コンストラクタ

Steema.TeeChart.Axis コンストラクタ

public Axis(Boolean horiz,
     Boolean isOtherSide,
     Chart c)

参照

Axis コンストラクタのオーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Axis コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Axis コンストラクタ

public Axis(IContainer container)

参照

Axis コンストラクタのオーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis イベント

パブリック イベント

GetAxisDrawLabel

参照

Axis クラス | Steema.TeeChart 名前空間


GetAxisDrawLabel

Steema.TeeChart.Axis.GetAxisDrawLabel イベント

public GetAxisDrawLabelEventHandler  GetAxisDrawLabel

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis フィールド

パブリック フィールド

AxisClickGap
IAxisSize
IEndPos
IsDepthAxis
IStartPos

プロテクト フィールド

bVisible
FAxisDraw
iHideBackGrid
iHideSideGrid
InternalUse (TeeBaseの継承元)
posTitle
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Axis クラス | Steema.TeeChart 名前空間


AxisClickGap

TeeChartプログラミングガイド

Steema.TeeChart.Axis.AxisClickGap フィールド

public Int32 AxisClickGap

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


bVisible

TeeChartプログラミングガイド

Steema.TeeChart.Axis.bVisible フィールド

protected Boolean bVisible

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


FAxisDraw

Steema.TeeChart.Axis.FAxisDraw フィールド

protected internal AxisDraw FAxisDraw

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IAxisSize

TeeChartプログラミングガイド

Steema.TeeChart.Axis.IAxisSize フィールド

public Int32 IAxisSize

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IEndPos

TeeChartプログラミングガイド

Steema.TeeChart.Axis.IEndPos フィールド

public Int32 IEndPos

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


iHideBackGrid

TeeChartプログラミングガイド

Steema.TeeChart.Axis.iHideBackGrid フィールド

protected internal Boolean iHideBackGrid

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


iHideSideGrid

Steema.TeeChart.Axis.iHideSideGrid フィールド

protected internal Boolean iHideSideGrid

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IsDepthAxis

TeeChartプログラミングガイド

Steema.TeeChart.Axis.IsDepthAxis フィールド

public Boolean IsDepthAxis

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IStartPos

TeeChartプログラミングガイド

Steema.TeeChart.Axis.IStartPos フィールド

public Int32 IStartPos

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


labelIncr

Steema.TeeChart.Axis.labelIncr フィールド

protected internal Double labelIncr

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


posTitle

Steema.TeeChart.Axis.posTitle フィールド

protected internal Int32 posTitle

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis メソッド

パブリック メソッド

AdjustMaxMin | 従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。
AdjustMaxMinRect | Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
CalcLabelStyle | 最も論理的な軸ラベルスタイルを返します。
CalcMinMax | 関連付けされている系列の最小値および最大値を返します。
CalcPosPoint | 指定したピクセル単位の画面座標に該当する軸スケール値を返します。
CalcPosValue | 指定した軸スケール値に該当する画面座標値をピクセル単位で返します。
CalcSizeValue | 指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。
CalcXPosValue | 指定したValueパラメータに該当する水平座標値をピクセル単位で返します。
CalcXYIncrement | 計算された軸ラベルのインクリメントを返します。
CalcYPosValue | 軸スケールでValueパラメータに該当する垂直座標位置をピクセル単位で返します。
Clicked | XとY座標値が軸の位置に近いかどうかを返します。
DateTimeDefaultFormat | astepパラメーターの値により、時間か日付を返します。
DateTimeIncrement | DateTimeインクリメントのための定数を設定します。
Draw | 現在の軸スケールで指定した画面位置に軸を表示します。
DrawAxisLabel | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
DrawTitle | 内部使用。チャート描写中にタイトルを表示します。
FindDateTimeStep | 内部使用。軸のDatetimeインクリメントを返します。
InternalCalcRange | 内部使用。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsCustom | 軸がカスタム軸の場合、trueを返します。
MaxLabelsWidth | すべての軸ラベルの最大幅をピクセル単位で返します。
Scroll | Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。
SetMinMax | 軸の最小スケールおよび最大スケールを変更します。
TitleOrName |

プロテクト メソッド

CalcRect | 軸を作成する際にチャートで使用される内部的メソッド。
Dispose |
DoGetAxisDrawLabel |
DrawAxisLabel | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
InflateAxisPos |
InternalCalcLabelStyle |
OnDisposing |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetInverted |
SetStringProperty (TeeBaseの継承元) |
ShouldSerializeAutomatic |
ShouldSerializeHorizontal |
ShouldSerializeMaximum |
ShouldSerializeMinimum |
ShouldSerializeOtherSide |
ShouldSerializeZPosition |

参照

Axis クラス | Steema.TeeChart 名前空間


AdjustMaxMin

TeeChartプログラミングガイド

Steema.TeeChart.Axis.AdjustMaxMin メソッド

従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。

public Void AdjustMaxMin()

解説

従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。
Axis.Automaticプロパティがtrueの場合、このメソッドが自動的に呼び出されます。
ChartのZoom.Undoメソッドは、左、右、上、下軸に対してこのメソッドを呼び出します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect メソッド

Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。

public Void AdjustMaxMinRect(Rectangle rect)

解説

このメソッドは軸を表示している間、内部的に呼び出されます。

Rectパラメーターは、ChartRectに適用するためにピクセル単位でマージンを設定します。
軸はRectパラメーターの位置を使用して、適切な最大値および最小値を再計算します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect メソッド

Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
public Void AdjustMaxMinRect(Rectangle rect)

参照

AdjustMaxMinRect オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AdjustMaxMinRect

Steema.TeeChart.Axis.AdjustMaxMinRect メソッド

Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
public Void AdjustMaxMinRect(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

AdjustMaxMinRect オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AxisRect

Steema.TeeChart.Axis.AxisRect メソッド

public Rectangle AxisRect()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcLabelStyle

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcLabelStyle メソッド

最も論理的な軸ラベルスタイルを返します。

public AxisLabelStyle CalcLabelStyle()

解説

このメソッドは、最も論理的な軸ラベルスタイルを返します。これは、チャート内のアクティブ系列の数や系列のポイントラベルに基づいて最適なラベルスタイルを計算します。LabelStyleプロパティは、この処理を行うためのにtalAutoに設定しなければなりません。
LabelStyleがtalAutoに設定されていない場合、LabelStyleプロパティの値が返されます。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcMinMax

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcMinMax メソッド

関連付けされている系列の最小値および最大値を返します。

public Void CalcMinMax(Double& min,
     Double& max)

解説

関連付けされている系列の最小値および最大値を返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcPosPoint

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcPosPoint メソッド

指定したピクセル単位の画面座標に該当する軸スケール値を返します。

public Double CalcPosPoint(Int32 value)

パラメーター

value
ピクセル単位の画面座標値

戻り値

軸スケール値

解説

指定したピクセル単位の画面座標に該当する軸スケール値を返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcPosValue メソッド

指定した軸スケール値に該当する画面座標値をピクセル単位で返します。

public Int32 CalcPosValue(Double value)

パラメーター

value
軸スケール値

戻り値

ピクセル単位の画面座標値

解説

指定した軸スケール値に該当する画面座標値をピクセル単位で返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcRect

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcRect メソッド

軸を作成する際にチャートで使用される内部的なメソッド

protected internal Void CalcRect(Rectangle& r,
     Boolean inflateChartRectangle)

パラメーター

r
チャートの矩形
inflateChartRectangle
壁許容（標準の軸のみ）

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcSizeValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcSizeValue メソッド

指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。

public Int32 CalcSizeValue(Double value)

解説

指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcXPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcXPosValue メソッド

指定したValueパラメーターに該当する水平座標値をピクセル単位で返します。

public Int32 CalcXPosValue(Double value)

パラメーター

value
軸の値

戻り値

ピクセル単位の水平座標値

解説

チャートに何かを描画して、ある値の水平座標値を知りたい場合にこのメソッドが便利です。

例

下軸は最小値20と最大値1000に設定されています。値500を表わす垂直線を描く場合は以下のようになります。
[C#]

private void tChart1_OnAfterDraw(object sender, TeeChart.Drawing.Graphics3D g)
{
int X = tChart1.Axes.Bottom.CalcXPosValue(500);
tChart1.Graphics3D.MoveTo(X, tChart1.Axes.Bottom.Position);
tChart1.Graphics3D.LineTo(X, tChart1.Axes.Top.Position);
}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcXYIncrement

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcXYIncrement メソッド

計算された軸ラベルのインクリメントを返します。

public Double CalcXYIncrement(Int32 maxLabelSize)

パラメーター

maxLabelSize
ピクセル単位でのラベルサイズの最大値

戻り値

軸単位でのインクリメントのサイズ

解説

計算された軸ラベルのインクリメントを返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcYPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcYPosValue メソッド

軸スケールでValueパラメーターに該当する垂直座標位置をピクセル単位で返します。

public Int32 CalcYPosValue(Double value)

パラメーター

value
軸の値

戻り値

ピクセル単位の垂直座標位置

解説

軸スケールでValueパラメーターに該当する垂直座標位置をピクセル単位で返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Clicked メソッド

オーバーロードの一覧

XとY座標値が軸の位置に近いかどうかを返します。

public Boolean Clicked(System.Drawing.Point)

XとY座標値が軸の位置に近いかどうかを返します。

public Boolean Clicked(System.Int32, System.Int32)

解説

XとY座標値が軸の位置に近いかどうかを返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Clicked メソッド

XとY座標値が軸の位置に近いかどうかを返します。

public Boolean Clicked(Point xy)

パラメーター

xy
XとY座標値

戻り値

指定したパラメーターが軸上あるいは軸に近い場合trueを返します。

参照

Clicked オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Clicked メソッド

XとY座標値が軸の位置に近いかどうかを返します。

public Boolean Clicked(Int32 x,
     Int32 y)

パラメーター

x
ピクセル単位のx位置
y
ピクセル単位のy位置

戻り値

指定したパラメーターが軸上あるいは軸に近い場合trueを返します。

参照

Clicked オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Clone

Steema.TeeChart.Axis.Clone メソッド

public virtual Object Clone()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DateTimeDefaultFormat

TeeChartプログラミングガイド

Steema.TeeChart.Axis.DateTimeDefaultFormat メソッド

astepパラメーターの値により、時間か日付を返します。

public String DateTimeDefaultFormat(Double astep)

解説

astepパラメーターの値が一日より小さい値は「時間」、それより大きい値は「日付」を返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DateTimeIncrement

Steema.TeeChart.Axis.DateTimeIncrement メソッド

DateTimeインクリメントのための定数を設定します。
public Void DateTimeIncrement(Boolean isDateTime,
     Boolean increment,
     Double& value,
     Double anIncrement,
     DateTimeSteps tmpWhichDatetime)

解説

DateTimeインクリメントのための定数を設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Dispose

Steema.TeeChart.Axis.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DoGetAxisDrawLabel

Steema.TeeChart.Axis.DoGetAxisDrawLabel メソッド

protected internal abstract Void DoGetAxisDrawLabel(Object sender,
     Int32& x,
     Int32& y,
     Int32& z,
     String& text,
     Boolean& drawlabel)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

オーバーロードの一覧

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(System.Boolean)

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Int32, System.Int32)

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean)

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Double, System.Double, System.Int32, System.Int32)

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(System.Int32, System.Int32, System.Int32, System.Boolean, System.Double, System.Double, System.Double, System.Int32, System.Int32)

解説

このメソッドはAxis.ParentChart.Canvasを使用して、完全な軸（目盛、グリッド、ラベル、タイトル）を描画します。通常、Drawメソッドを直接的に呼び出す必要はありません。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(Boolean calcPosAxis)

パラメーター

calcPosAxis
軸のラベルを表示するためにスペースが必要な場合はTrueを設定してください。

参照

Draw オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Int32 aStartPos,
     Int32 aEndPos)

参照

Draw オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible)

参照

Draw オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Double aMinimum,
     Double aMaximum,
     Int32 aStartPosition,
     Int32 aEndPosition)

参照

Draw オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Draw メソッド

現在の軸スケールで指定した画面位置に軸を表示します。

public Void Draw(Int32 posLabels,
     Int32 posTitle,
     Int32 posAxis,
     Boolean gridVisible,
     Double aMinimum,
     Double aMaximum,
     Double aIncrement,
     Int32 aStartPos,
     Int32 aEndPos)

参照

Draw オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel メソッド

オーバーロードの一覧

指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。

public Void DrawAxisLabel(System.Int32, System.Int32, System.Int32, System.String, Steema.TeeChart.Drawing.TextShape)
public Void DrawAxisLabel(Steema.TeeChart.Drawing.ChartFont, System.Int32, System.Int32, System.Int32, System.String, Steema.TeeChart.Drawing.TextShape)

指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定し、fパラメーターによりフォントを設定します。

protected internal Void DrawAxisLabel(Steema.TeeChart.Drawing.ChartFont, System.Int32, System.Int32, System.Int32, System.String, Steema.TeeChart.Drawing.TextShape, System.Boolean)

解説

指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel メソッド

指定したXY座標と角度で軸ラベル（文字列）を描きます。
public Void DrawAxisLabel(Int32 x,
     Int32 y,
     Int32 angle,
     String st,
     TextShape labelItem)

参照

DrawAxisLabel オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel メソッド

public Void DrawAxisLabel(ChartFont f,
     Int32 x,
     Int32 y,
     Int32 angle,
     String st,
     TextShape format)

参照

DrawAxisLabel オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DrawAxisLabel

Steema.TeeChart.Axis.DrawAxisLabel メソッド

指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定し、fパラメーターによりフォントを設定します。
protected internal Void DrawAxisLabel(ChartFont f,
     Int32 x,
     Int32 y,
     Int32 angle,
     String st,
     TextShape format,
     Boolean isTitle)

参照

DrawAxisLabel オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


DrawTitle

TeeChartプログラミングガイド

Steema.TeeChart.Axis.DrawTitle メソッド

TeeChartの内部使用。チャート描写中にタイトルを表示します。

public Void DrawTitle(Int32 x,
     Int32 y)

解説

TeeChartの内部使用。チャート描写中にタイトルを表示します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


FindDateTimeStep

TeeChartプログラミングガイド

Steema.TeeChart.Axis.FindDateTimeStep メソッド

内部使用。軸のDatetimeインクリメントを返します。

public static DateTimeSteps FindDateTimeStep(Double stepValue)

パラメーター

stepValue
要求するインクリメント

戻り値

解説

このメソッドは、double値をDateTimeSteps列挙体に変換する際に便利です。

例

[C#]
private void button1_Click(object sender, System.EventArgs e) {
      Steema.TeeChart.DateTimeSteps myStep;
      myStep = Steema.TeeChart.Axis.FindDateTimeStep(TimeSpan.FromDays(2).TotalDays);
      tChart1.Axes.Bottom.Increment = Steema.TeeChart.Utils.DateTimeStep[(int)myStep];
 }

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


InflateAxisPos

Steema.TeeChart.Axis.InflateAxisPos メソッド

protected internal Int32 InflateAxisPos(Int32 value,
     Int32 amount)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


InflateAxisRect

Steema.TeeChart.Axis.InflateAxisRect メソッド

protected internal Void InflateAxisRect(Int32 value,
     Rectangle& r)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


InternalCalcLabelStyle

Steema.TeeChart.Axis.InternalCalcLabelStyle メソッド

protected abstract AxisLabelStyle InternalCalcLabelStyle()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


InternalCalcRange

Steema.TeeChart.Axis.InternalCalcRange メソッド

内部使用。
public Void InternalCalcRange()

解説

内部使用。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IsCustom

Steema.TeeChart.Axis.IsCustom メソッド

軸がカスタム軸の場合、trueに返します。
public Boolean IsCustom()

解説

軸がカスタム軸の場合、trueに返します。

例

[C#]
Steema.TeeChart.Axis myAxis = new Steema.TeeChart.Axis();
private void Form1_Load(object sender, System.EventArgs e)
     {
          line1.FillSampleValues(10);
          line2.FillSampleValues(10);

        tab
          myAxis.Horizontal = false;
          myAxis.RelativePosition = 10;
          line2.CustomVertAxis = myAxis;
          tChart1.Axes.Custom.Add (myAxis);
     }
}
     private void button1_Click(object sender, System.EventArgs e)
     {
          //..
          if (myAxis.IsCustom())
          {
               myAxis.AxisPen.Color= Color.Red;
               tChart1.Refresh();
          }
     }

}

[VB.NET]
Dim myAxis As New Steema.TeeChart.Axis

Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
     Line1.FillSampleValues(10)
     Line2.FillSampleValues(10)

     myAxis.Horizontal = False
     myAxis.RelativePosition = 10
     Line2.CustomVertAxis = myAxis
     TChart1.Axes.Custom.Add(myAxis)

   End Sub

   Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    tab
     If (myAxis.IsCustom()) Then
          myAxis.AxisPen.Color = Color.Red
         TChart1.Refresh()
     End If
End Sub

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MaxLabelsWidth

Steema.TeeChart.Axis.MaxLabelsWidth メソッド

すべての軸ラベルの最大幅をピクセル単位で返します。
public Int32 MaxLabelsWidth()

戻り値

ピクセル単位の最大幅

解説

すべての軸ラベルの最大幅をピクセル単位で返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


OnDisposing

Steema.TeeChart.Axis.OnDisposing メソッド

protected internal abstract Void OnDisposing()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Scroll

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Scroll メソッド

Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。

public Void Scroll(Double offset,
     Boolean checkLimits)

解説

Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。系列の範囲外にある軸をスクロールするには、CheckLimitsパラメーターはfalseにしてください。

例

チャートをクリックすると、下軸を150ポイントスクロールします。

[C#]

private void button1_Click_1(object sender, System.EventArgs e)
{
     tChart1.Axes.Bottom.Scroll(150,false);
}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


SetChart

Steema.TeeChart.Axis.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


SetInverted

Steema.TeeChart.Axis.SetInverted メソッド

protected abstract Void SetInverted(Boolean Value)

解説

タイトルを設定したかどうかによって軸のタイトルまたは名前を返します。

例

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
myCustomAxis.Title.Text = "My Own Axis";
MessageBox.Show(myCustomAxis.TitleOrName());
// タイトルを設定していない場合、例えば「左軸」を返します。
}

[VB.Net]
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    myCustomAxis.Title.Text = "My Own Axis"
    MessageBox.Show(myCustomAxis.TitleOrName())
    'タイトルを設定していない場合、例えば「左軸」を返します。
End Sub

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


SetMinMax

TeeChartプログラミングガイド

Steema.TeeChart.Axis.SetMinMax メソッド

オーバーロードの一覧

軸の最小スケールおよび最大スケールを変更します。

public Void SetMinMax(System.DateTime, System.DateTime)

軸の最小スケールおよび最大スケールを変更します。

public Void SetMinMax(System.Double, System.Double)

解説

現在の軸の最小スケールおよび最大スケールを変更します。Axis.Automaticプロパティは、falseに設定されていなければなりません。

例

[C#]
ここでは、以下を呼び出します。

tChart1.Axes.Bottom.SetMinMax (100, 300);

上記のコードは、以下のコードと同様です。

tChart1.Axes.Bottom.Automatic = false;
tChart1.Axes.Bottom.Maximum = 300;
tChart1.Axes.Bottom.Minimum = 100;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


SetMinMax

TeeChartプログラミングガイド

Steema.TeeChart.Axis.SetMinMax メソッド

軸の最小スケールと最大スケールを変更します。

public Void SetMinMax(DateTime minDate,
     DateTime maxDate)

パラメーター

minDate
軸の最小スケール
maxDate
軸の最大スケール

参照

SetMinMax オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


SetMinMax

TeeChartプログラミングガイド

Steema.TeeChart.Axis.SetMinMax メソッド

現在の軸の最小スケールや最大スケールを変更します。

public Void SetMinMax(Double min,
     Double max)

パラメーター

min
軸の最小スケール
max
軸の最大スケール

参照

SetMinMax オーバーロードの一覧 | Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeAutomatic

Steema.TeeChart.Axis.ShouldSerializeAutomatic メソッド

protected Boolean ShouldSerializeAutomatic()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeHorizontal

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ShouldSerializeHorizontal メソッド

protected Boolean ShouldSerializeHorizontal()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeMaximum

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ShouldSerializeMaximum メソッド

protected virtual Boolean ShouldSerializeMaximum()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeMinimum

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ShouldSerializeMinimum メソッド

protected virtual Boolean ShouldSerializeMinimum()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeOtherSide

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ShouldSerializeOtherSide メソッド

protected Boolean ShouldSerializeOtherSide()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ShouldSerializeZPosition

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ShouldSerializeZPosition メソッド

protected Boolean ShouldSerializeZPosition()

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


TitleOrName

Steema.TeeChart.Axis.TitleOrName メソッド

public String TitleOrName()

解説

タイトルが設定している（していない）場合、依存している軸のタイトルあるいは名称を返します。

例

[C#]
private void button1_Click(object sender, System.EventArgs e)
{
myCustomAxis.Title.Text = "My Own Axis";
MessageBox.Show(myCustomAxis.TitleOrName());
// タイトルを設定しない場合、たとえば「左軸」を返します。
}

[VB.Net]
Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
    myCustomAxis.Title.Text = "My Own Axis"
    MessageBox.Show(myCustomAxis.TitleOrName())
    ' タイトルを設定しない場合、たとえば「左軸」を返します。
End Sub

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis プロパティ

パブリック プロパティ

Automatic | 関連付けられている系列に基づいて軸の最大値および最小値を計算します。
AutomaticMaximum | 軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。
AutomaticMinimum | 軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。
AxisPen | 軸を描くペンの種類を設定します。
CalcIncrement | 計算された軸ラベルのインクリメントを返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
EndPosition | 軸の終了位置を0～100%で設定します。
Grid | チャートグリッドを描くペンを設定します。
GridCentered | trueの場合、ポイントをグリッド線の中間に移動させます。
Horizontal | カスタム軸を水平軸として描画するかどうか設定します。
Increment | 軸ラベル間での最小ステップを設定します。日付時間軸のためのDateTimeStepsが使用できます。
Inverted | 軸の最小値と最大値のスケールを交換します。
IsDateTime | 指定された軸の値がDateTimeかどうかを返します。
Labels | 軸ラベルの特性にアクセスします。
LabelsOnAxis | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Logarithmic | Trueの場合、軸を対数関数でスケールします。
LogarithmicBase | AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。
Maximum | 軸の最大値を設定します。
MaximumOffset | 軸の最大位置にマージンとして残す量をピクセル単位で設定します。
MaxXValue | 指定した軸の最大X値を返します。
MaxYValue | 指定した軸の最大Y値を返します。
MinAxisIncrement | デフォルト値：1e-12。最小の軸インクリメントを取得/設定します。
Minimum | 軸の最小値を設定します。
MinimumOffset | 軸の最小位置にマージンとして残す量をピクセル単位で設定します。
MinorGrid | 副目盛の特性を設定します。
MinorTickCount | 軸の副目盛の数を定義します。
MinorTicks | 軸の副目盛を描くペンを定義します。
MinXValue | 指定した軸の最小X値を返します。
MinYValue | 指定した軸の最小Y値を返します。
OtherSide | 軸を反対側へ移動します。
PosAxis | 旧式：Positionプロパティを使用してください。
Position | 軸を描画する位置を設定します。
PositionUnits | 軸の位置を定義するRelativePositionプロパティの単位を設定します。
RelativePosition | 軸の位置をチャートに対する0～100%で設定します。
StartEndPositionUnits | StartPositionプロパティとEndPositionプロパティの位置の単位（ピクセルあるいは百分率）を定義します。
StartPosition | 軸の開始位置を0～100%で設定します。
TickOnLabelsOnly | 軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。
Ticks | 軸の線に沿った軸マーカを描くペンの種類を定義します。
TicksInner | 軸の線に沿って軸マーカを描くペンの種類を定義します。
Title | 軸タイトルの特性にアクセスします。
TitleSize | タイトルとチャート間の距離を自動的に計算します。
Visible | 一度に5つの全チャート軸を表示/非表示します。
ZPosition | チャートの深さに沿ってZ軸の位置を設定します。

参照

Axis クラス | Steema.TeeChart 名前空間


Automatic

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Automatic プロパティ

関連付けられている系列に基づいて軸の最大値および最小値を計算します。

public Boolean Automatic {get; set;}

解説

trueの場合、軸の最大値および最小値は関連付けられている系列に基づいて計算されます。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AutomaticMaximum

Steema.TeeChart.Axis.AutomaticMaximum プロパティ

軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。

public Boolean AutomaticMaximum {get; set;}

解説

デフォルト値：true

軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AutomaticMinimum

TeeChartプログラミングガイド

Steema.TeeChart.Axis.AutomaticMinimum プロパティ

軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。

public Boolean AutomaticMinimum {get; set;}

解説

デフォルト値：true

軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


AxisPen

Steema.TeeChart.Axis.AxisPen プロパティ

軸を描くペンの種類を設定します。
public AxisLinePen AxisPen {get; set;}

解説

軸の線を描くペンの種類を設定します。これは、軸の最小値から最大値までの線を描きます。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


CalcIncrement

TeeChartプログラミングガイド

Steema.TeeChart.Axis.CalcIncrement プロパティ

計算された軸ラベルのインクリメントを返します。

public Double CalcIncrement {get;}

解説

計算された軸ラベルのインクリメントを返します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


EndPosition

TeeChartプログラミングガイド

Steema.TeeChart.Axis.EndPosition プロパティ

軸の終了位置を0～100%で設定します。

public Double EndPosition {get; set;}

解説

軸の終了位置を0～100%で設定します。たとえば、垂直軸のEndPositionが75の場合、チャートの上から75%下がった位置に軸を設定します。

例

[C#]

//左垂直軸の設定
tChart1.Axes.Left.StartPosition = 25;
tChart1.Axes.Left.EndPosition  = 10;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Grid

Steema.TeeChart.Axis.Grid プロパティ

チャートグリッドを描くペンを設定します。
public GridPen Grid {get; set;}

解説

各軸ラベル位置に軸線を描くペンの種類を設定します。

副目盛からグリッド線を表示させるためには、MinorGridプロパティを使用してください。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


GridCentered

TeeChartプログラミングガイド

Steema.TeeChart.Axis.GridCentered プロパティ

public Boolean GridCentered {get; set;}

旧式

このプロパティの代わりにAxis.Grid.Centeredプロパティを使用してください。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Horizontal

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Horizontal プロパティ

カスタム軸を水平軸として描画するかどうか設定します。

public Boolean Horizontal {get; set;}

解説

trueの場合、カスタム軸を水平軸として描画します。falseの場合、カスタム軸を垂直軸として描画します。

例

[C#]

tChart1.Axes.Custom.Add(new Axis());
tChart1.Axes.Custom[0].Horizontal=true;
tChart1.Axes.Custom[0].PositionPercent=50;
tChart1[0].CustomHorizAxis=tChart1.Axes.Custom[0];

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Increment

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Increment プロパティ

軸ラベル間での最小ステップを設定します。日付時間軸のためのDateTimeStepsが使用できます。

public Double Increment {get; set;}

解説

軸ラベル間の最小ステップを設定します。これは、正の数値あるいはDateTime値で設定してください。TChartは最初の軸ラベルステップとしてこの値を使用します。 すべてのラベルに十分なスペースがなければ、TChartはもっとも大きな数字を計算します。DateTime値に対して、DateTimeStep定数配列を使用することができます。

例

[C#]
private void Form1_Load(object sender, System.EventArgs e) {
     DateTime now = DateTime.Now;
     Random rnd = new Random();
     tChart1.Aspect.View3D = false;
     bar1.Marks.Visible = false;
     tChart1.Axes.Bottom.Labels.DateTimeFormat = "T";
     tChart1.Axes.Bottom.Labels.Angle = 90;
     for(int i = 0; i < 100; ++i){
        bar1.Add(now,rnd.Next(100));
        now = now.AddSeconds(1);
    }
}
private void button1_Click(object sender, System.EventArgs e) {
     tChart1.Axes.Bottom.Increment=Steema.TeeChart.Utils.DateTimeStep[(int)Steema.TeeChart.DateTimeSteps.ThirtySeconds];
}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Inverted

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Inverted プロパティ

軸の最小値と最大値のスケールを交換します。

public Boolean Inverted {get; set;}

解説

デフォルト値：false

trueの場合、軸の最小値と最大値のスケールを交換します。軸ラベルと系列ポイントは、これに従って描画されます。これは、垂直および水平の両方の軸に適用されます。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


IsDateTime

TeeChartプログラミングガイド

Steema.TeeChart.Axis.IsDateTime プロパティ

指定された軸の値がDateTimeかどうかを返します。

public Boolean IsDateTime {get;}

解説

各チャート軸は、標準の数値あるいはDateTime値の設定があります。これは、指定された軸の値がDateTimeかどうかを返します。DateTime値を持つアクティブ系列が一つでも関連していれば、その軸は"DateTime"になります。

例

[C#]

If (tChart1.Axes.Bottom.IsDateTime)
   ......

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Labels

Steema.TeeChart.Axis.Labels プロパティ

軸ラベルの特性にアクセスします。
public AxisLabels Labels {get;}

解説

軸ラベルの特性にアクセスします。

例

[C#]

tChart1.Axes.Left.Labels.Style = talText;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


OnAxis

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.OnAxis プロパティ

ラベルを軸の最小値と最大値に描画するかしないかを制御します。
public Boolean OnAxis {get; set;}

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Logarithmic

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Logarithmic プロパティ

Trueの場合、軸を対数関数でスケールします。

public Boolean Logarithmic {get; set;}

解説

Trueの場合、軸を対数関数でスケールします。軸の最小値と最大値は0以上の数値にしなければなりません。軸をDateTime型にすることはできません。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


LogarithmicBase

TeeChartプログラミングガイド

Steema.TeeChart.Axis.LogarithmicBase プロパティ

AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。

public Double LogarithmicBase {get; set;}

解説

AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Maximum

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Maximum プロパティ

軸の最大値を設定します。

public Double Maximum {get; set;}

解説

軸の最大値とは、軸が従属系列のポイント値をスケールに使用する最大値です。
これは、任意の数値やDateTime値に設定できます。
これは、Axis.Minimumプロパティの値より大きい値にしなければなりません。

最重要：
Axis.Automaticプロパティはfalseにしなければなりません。
Axis.Automaticがtrueの場合、軸は最大値や最小値を従属系列の最大値や最小値に設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MaximumOffset

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MaximumOffset プロパティ

軸の最大位置にマージンとして残す量をピクセル単位で設定します。

public Int32 MaximumOffset {get; set;}

解説

軸の最大位置にマージンとして残す量をピクセル単位で設定します。

このプロパティは、軸の境界の最も近い所にポイントを表示したくない場合に便利です。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MaximumRound

Steema.TeeChart.Axis.MaximumRound プロパティ

最も近い整数値に軸の最大値を丸めます。
public Boolean MaximumRound {get; set;}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MaxXValue プロパティ

指定した軸の最大X値を返します。

public Double MaxXValue {get;}

解説

指定した軸の計算された最大水平値を返します。これは、Axis.TopあるいはAxis.Bottomになります。
計算されたとは、この軸に関連付けられている全ての系列のポイントの最大値を返します。水平方向の軸を持つ系列だけが対象になります。

例

[C#]
tChart1.Axes.Bottom.Automatic = false;
tChart1.Axes.Bottom.Maximum = tChart1.Axes.Bottom.MaxXValue;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MaxYValue プロパティ

指定した軸の最大Y値を返します。

public Double MaxYValue {get;}

解説

指定した軸の計算された最大垂直値を返します。これは、Axis.LeftあるいはAxis.Rightになります。
計算されたとは、この軸に関連付けられている全ての系列のポイントの最大値を返します。垂直方向の軸を持つ系列だけが対象になります。

例

[C#]
tChart1.Axes.Left.Automatic = false;
tChart1.Axes.Left.Maximum = tChart1.Axes.Left.MaxYValue;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinAxisIncrement

Steema.TeeChart.Axis.MinAxisIncrement プロパティ

デフォルト値：1e-12。最小の軸インクリメントを取得/設定します。
public Double MinAxisIncrement {get; set;}

解説

デフォルト値: 1e-12

最小の軸インクリメントを取得/設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Minimum

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Minimum プロパティ

軸の最小値を設定します。

public Double Minimum {get; set;}

解説

軸が従属系列のポイント値をスケールに使用する最小値です。
これは、任意の数値やDateTime値に設定できます。
これは、Axis.Maximumプロパティの値よりも小さい値にしなければなりません。

最重要：
Axis.Automaticプロパティは、falseにしなければなりません。
Axis.Automaticがtrueの場合、軸は最大値や最小値を従属系列の最大値や最小値に設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinimumOffset

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MinimumOffset プロパティ

軸の最小位置にマージンとして残す量をピクセル単位で設定します。

public Int32 MinimumOffset {get; set;}

解説

軸の最小位置にマージンとして残す量をピクセル単位で設定します。

このプロパティは、軸の境界の最も近い所にポイントを表示したくない場合に便利です。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinimumRound

Steema.TeeChart.Axis.MinimumRound プロパティ

最も近い整数値に軸の最小値を丸めます。
public Boolean MinimumRound {get; set;}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinorGrid

Steema.TeeChart.Axis.MinorGrid プロパティ

副目盛の特性を設定します。
public ChartPen MinorGrid {get; set;}

解説

副目盛の特性を設定します。MinorGrid.Visibleのデフォルトはfalseです。

例

[C#]

tChart1.Axes.Bottom.MinorGrid.Style = DashStyle.Dot;
tChart1.Axes.Bottom.MinorGrid.Color = Color.Red;
tChart1.Axes.Bottom.MinorGrid.Visible = true;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinorTickCount

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MinorTickCount プロパティ

軸の副目盛の数を定義します。軸の副目盛とは、軸の主目盛の間にある目盛のことです。

public Int32 MinorTickCount {get; set;}

解説

デフォルト値：3

軸の副目盛の数を定義します。軸の副目盛とは、軸の主目盛の間にある目盛のことです。
これは、ゼロよりも大きく、かつ主目盛間のピクセル数の半分よりも小さい正数でなければなりません。そうしないと、副目盛が「オーバーラップ」してしまいます。

例

このコードは、軸の副目盛の数を設定します。

[C#]
tChart1.Axes.Left.MinorTickCount = 4;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinorTicks

Steema.TeeChart.Axis.MinorTicks プロパティ

軸の副目盛を描くペンを定義します。
public TicksPen MinorTicks {get; set;}

解説

軸の副目盛を描くペンを定義します。副目盛は、MinorTicks.Visibleプロパティがtrueの場合にのみ表示されます。

例

[C#]

tChart1.Axes.Bottom.MinorTickCount = 5;
tChart1.Axes.Bottom.MinorTicks.Length = 8;
tChart1.Axes.Bottom.MinorTicks.Visible = true;
tChart1.Axes.Bottom.MinorTicks.Color = Color.Yellow;
tChart1.Axes.Bottom.MinorTicks.Width = 2;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MinXValue プロパティ

指定した軸の最小X値を返します。

public Double MinXValue {get;}

解説

指定した軸の計算された最小水平値を返します。これは、Axis.TopあるいはAxis.Bottomになります。
計算されたとは、この軸に関連付けられている全ての系列のポイントの最小値を返します。水平方向の軸を持つ系列だけが対象になります。

例

[C#]

tChart1.Axes.Top.Automatic = false;
tChart1.Axes.Top.Minimum = TChart1.Axes.Top.MinXValue;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Axis.MinYValue プロパティ

指定した軸の最小Y値を返します。

public Double MinYValue {get;}

解説

指定した軸の計算された最小垂直値を返します。これは、Axis.LeftあるいはAxis.Rightになります。
計算されたとは、この軸に関連付けられている全ての系列のポイントの最小値を返します。垂直方向の軸を持つ系列だけが対象になります。

例

[C#]

tChart1.Axes.Right.Automatic = false;
tChart1.Axes.Right.Minimum = tChart1.Axes.Right.MinYValue;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


OtherSide

TeeChartプログラミングガイド

Steema.TeeChart.Axis.OtherSide プロパティ

軸を反対側へ移動します。

public Boolean OtherSide {get; set;}

解説

軸を反対側へ移動します。このプロパティは、カスタム軸を追加した際にラベルを反対側に表示させる場合に便利です。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


PosAxis

TeeChartプログラミングガイド

Steema.TeeChart.Axis.PosAxis プロパティ

このプロパティの代わりにPositionプロパティを使用してください。

public Int32 PosAxis {get;}

旧式

このプロパティの代わりにPositionプロパティを使用してください。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Position

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Position プロパティ

軸を描画する位置を設定します。

public Int32 Position {get;}

解説

チャートパネルに相対的な軸位置をピクセル単位で返します。水平軸はY位置の数値で、垂直軸はX位置の数値になります。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


PositionUnits

Steema.TeeChart.Axis.PositionUnits プロパティ

軸の位置を定義するRelativePositionプロパティの単位を設定します。
public PositionUnits PositionUnits {get; set;}

解説

デフォルト値：Percent
軸の位置を定義するRelativePositionプロパティの単位を設定します。

Percent（デフォルト）の場合、RelativePositionプロパティ値はチャートの全体の百分率単位になります。

Pixelsの場合、RelativePositionプロパティ値はピクセル単位になります。

メモ：RelativePositionプロパティは、前のバージョンとの互換性により、改名されていません。

例

[C#]

tChart1.Axes.Left.PositionUnits = Steema.TeeChart.PositionUnits.Pixels;
tChart1.Axes.Left.RelativePosition =10;    //  <--- 10 ピクセル（10%ではありません）

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


RelativePosition

TeeChartプログラミングガイド

Steema.TeeChart.Axis.RelativePosition プロパティ

軸の位置をチャートに対する0～100%で設定します。

public Double RelativePosition {get; set;}

解説

軸の位置をチャートに対する0～100%で設定します。水平軸は上が0となります。垂直軸は左が0となります。

例

[C#]

tChart1.Axes.Left.PositionPercent = 50;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


StartEndPositionUnits

Steema.TeeChart.Axis.StartEndPositionUnits プロパティ

StartPositionプロパティとEndPositionプロパティの位置の単位（ピクセルあるいは百分率）を定義します。
public PositionUnits StartEndPositionUnits {get; set;}

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


StartPosition

TeeChartプログラミングガイド

Steema.TeeChart.Axis.StartPosition プロパティ

軸の開始位置を0～100%で設定します。

public Double StartPosition {get; set;}

解説

軸の開始位置を0～100%でで設定します。たとえば、垂直軸のStartPositionが75の場合、チャートのトップから75%下がった位置に軸のトップを設定します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


TickOnLabelsOnly

TeeChartプログラミングガイド

Steema.TeeChart.Axis.TickOnLabelsOnly プロパティ

軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。

public Boolean TickOnLabelsOnly {get; set;}

解説

デフォルト値：true

軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。このプロパティが設定されていないと、これらは軸がインクリメントするすべての位置で描かれます。Axis.Labels.Separationプロパティが0（デフォルト値：10）よりも大きい値の場合、軸は軸ラベルがオーバーラップしないようにIncrementプロパティを増加させます。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Ticks

Steema.TeeChart.Axis.Ticks プロパティ

軸の線に沿った軸マーカを描くペンの種類を定義します。
public TicksPen Ticks {get; set;}

解説

軸の線に沿った軸マーカを描くペンの種類を定義します。
目盛の位置は、Axis.Increment、Axis.Labels.Separation、Axis.Labels.Styleプロパティに基づいて計算されます。
Ticks、MinorTicks、TicksInnerの3種類の目盛が用意されています。
これらはVisibleプロパティを使用して表示/非表示に設定できます。
TickLengthプロパティは、軸の目盛の長さを論理ピクセルで定義します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


TicksInner

Steema.TeeChart.Axis.TicksInner プロパティ

軸の線に沿って軸マーカを描くペンの種類を定義します。
public TicksPen TicksInner {get; set;}

解説

軸の線に沿って軸マーカを描くペンの種類を定義します。これは、Ticksプロパティと同じことを行いますが、線はチャート境界の内側に描かれます。
このプロパティは、Axis.Increment、Axis.Labels.Separation、Axis.Labels.Styleプロパティに基づいて計算されます。
Ticks、MinorTicks、TicksInnerの3種類の目盛が用意されています。
これらはVisibleプロパティを使用して表示/非表示に設定できます。
TickInnerLengthプロパティは、軸の内側目盛の長さを論理ピクセルで定義します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Title

Steema.TeeChart.Axis.Title プロパティ

軸タイトルの特性にアクセスします。
public AxisTitle Title {get; set;}

解説

軸のサブクラスです。これには、軸タイトルに関するすべてのプロパティが含まれます。
軸タイトルは、軸の近くに描かれるテキストの文字列です。
軸タイトルのテキストを指定するには、Textプロパティを使用してください。FontおよびAngleプロパティを使用して書式を設定してください。

例

[C#]

tChart1.Axes.Bottom.Title.Text = "Products";

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


TitleSize

TeeChartプログラミングガイド

Steema.TeeChart.Axis.TitleSize プロパティ

public Int32 TitleSize {get; set;}

旧式

このプロパティの代わりにAxis.Title.CustomSizeプロパティを使用してください。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Axis.Visible プロパティ

一度に5つの全チャート軸を表示/非表示します。

public Boolean Visible {get; set;}

解説

軸の線、目盛、グリッド、ラベル、タイトルを表示/非表示にします。デザイン時および実行時に変更できます。

例

[C#]

tChart1.Axes.Bottom.Visible = false;

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


ZPosition

TeeChartプログラミングガイド

Steema.TeeChart.Axis.ZPosition プロパティ

チャートの深さに沿ってZ軸の位置を設定します。

public Double ZPosition {get; set;}

解説

深さの合計のパーセントとして、深さ方向に沿ってZ軸の位置を設定します。
チャートの前面に軸を配置するためには負の値を設定し、チャートの背面に軸を配置するためには100%以上の値を設定することができます。

3Dあるいは直交表示モードで、軸の線をどこに表示するか制御します。

例

[C#]

tChart1.Axes.Bottom.ZPosition = 100;  // 100%後ろに左軸を移動します。

参照

Axis クラス | Axis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisDraw

Steema.TeeChart.Axis.AxisDraw クラス

この型のすべてのメンバの一覧については、AxisDraw メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
protected internal class AxisDraw : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

AxisDraw メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisDraw 全メンバ

AxisDraw 概要

パブリック メソッド

Draw |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

コンストラクタ

Steema.TeeChart.Axis.AxisDraw

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisDraw クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisDraw フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

AxisDraw クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisDraw メソッド

パブリック メソッド

Draw |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisDraw クラス | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Axis+AxisDraw.Draw メソッド

public Void Draw(Boolean calcPosAxis)

参照

AxisDraw クラス | AxisDraw メンバ | Steema.TeeChart 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SetChart

Steema.TeeChart.Axis+AxisDraw.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

AxisDraw クラス | AxisDraw メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisDraw プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

AxisDraw クラス | Steema.TeeChart 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


AxisDraw コンストラクタ

Steema.TeeChart.Axis+AxisDraw コンストラクタ

public Axis+AxisDraw(Axis a)

参照

AxisDraw クラス | AxisDraw メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisLinePen

Steema.TeeChart.Axis.AxisLinePen クラス

軸の線を描くペンを設定します。

この型のすべてのメンバの一覧については、AxisLinePen メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public sealed class AxisLinePen : ChartPen , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisLinePen 全メンバ

AxisLinePen 概要

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Style (ChartPenの継承元) | キャンバス上に線を描くペンのスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width | AxisLinePenの幅を設定します。

コンストラクタ

Steema.TeeChart.Axis.AxisLinePen..ctor オーバーロード

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

AxisLinePen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisLinePen フィールド

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
custom (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

AxisLinePen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisLinePen メソッド

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

AxisLinePen クラス | Steema.TeeChart 名前空間


AssignPen

Steema.TeeChart.Axis+AxisLinePen.AssignPen メソッド

protected abstract Void AssignPen(ChartPen p)

参照

AxisLinePen クラス | AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.AxisLinePen プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Style (ChartPenの継承元) | キャンバス上に線を描くペンのスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width | AxisLinePenの幅を設定します。

参照

AxisLinePen クラス | Steema.TeeChart 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Axis+AxisLinePen.Width プロパティ

AxisLinePenの幅を設定します。

public virtual Int32 Width {get; set;}

解説

デフォルト値：2

軸を描くAxisLinePenの幅を設定します。

例

[C#]

tChart1.Axes.Left.AxisPen.Width = 4;

参照

AxisLinePen クラス | AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+AxisLinePen コンストラクタ

オーバーロードの一覧

public Axis+AxisLinePen()
public Axis+AxisLinePen(Steema.TeeChart.Chart)

参照

AxisLinePen クラス | AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+AxisLinePen コンストラクタ

public Axis+AxisLinePen()

参照

Axis.AxisLinePen コンストラクタのオーバーロードの一覧 | AxisLinePen クラス | AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+AxisLinePen コンストラクタ

public Axis+AxisLinePen(Chart c)

参照

Axis.AxisLinePen コンストラクタのオーバーロードの一覧 | AxisLinePen クラス | AxisLinePen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.GridPen

Steema.TeeChart.Axis.GridPen クラス

各軸ラベルの位置にグリッド線を描くために使用するペンの種類を設定します。

この型のすべてのメンバの一覧については、GridPen メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public class GridPen : ChartPen , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.GridPen 全メンバ

GridPen 概要

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

パブリック プロパティ

Centered | グリッドを中央に並べます。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawEvery |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Style | グリッド線のスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width (ChartPenの継承元) | ペンが描く線の幅を設定します。
ZPosition |

コンストラクタ

Steema.TeeChart.Axis.GridPen..ctor オーバーロード

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

GridPen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.GridPen フィールド

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
custom (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

GridPen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.GridPen メソッド

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

GridPen クラス | Steema.TeeChart 名前空間


AssignPen

Steema.TeeChart.Axis+GridPen.AssignPen メソッド

protected abstract Void AssignPen(ChartPen p)

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.GridPen プロパティ

パブリック プロパティ

Centered | グリッドを中央に並べます。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawEvery |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Style | グリッド線のスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width (ChartPenの継承元) | ペンが描く線の幅を設定します。
ZPosition |

参照

GridPen クラス | Steema.TeeChart 名前空間


Centered

TeeChartプログラミングガイド

Steema.TeeChart.Axis+GridPen.Centered プロパティ

グリッドを中央に並べます。

public Boolean Centered {get; set;}

解説

デフォルト値：false

グリッドを中央に並べます。

例

[C#]

tChart1.Axes.Bottom.Grid.Centered = true;

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


DrawEvery

Steema.TeeChart.Axis+GridPen.DrawEvery プロパティ

public Int32 DrawEvery {get; set;}

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Style

TeeChartプログラミングガイド

Steema.TeeChart.Axis+GridPen.Style プロパティ

グリッド線のスタイルを設定します。

public virtual DashStyle Style {get; set;}

解説

垂直グリッドおよび水平グリッドは、個々にスタイルを設定できます。

例

[C#]

tChart1.Axes.Bottom.Grid.Style = DashStyle.DashDotDot;

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


ZPosition

Steema.TeeChart.Axis+GridPen.ZPosition プロパティ

public Double ZPosition {get; set;}

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+GridPen コンストラクタ

オーバーロードの一覧

public Axis+GridPen()
public Axis+GridPen(Steema.TeeChart.Chart)

参照

GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+GridPen コンストラクタ

public Axis+GridPen()

参照

Axis.GridPen コンストラクタのオーバーロードの一覧 | GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+GridPen コンストラクタ

public Axis+GridPen(Chart c)

参照

Axis.GridPen コンストラクタのオーバーロードの一覧 | GridPen クラス | GridPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.TicksPen

Steema.TeeChart.Axis.TicksPen クラス

軸線に沿って軸マーカを描くペンの種類を設定します。

この型のすべてのメンバの一覧については、TicksPen メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.ChartPen
public class TicksPen : ChartPen , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.TicksPen 全メンバ

TicksPen 概要

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Length | 軸の目盛の長さをピクセル単位で取得/設定します。
Style (ChartPenの継承元) | キャンバス上に線を描くペンのスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width (ChartPenの継承元) | ペンが描く線の幅を設定します。

コンストラクタ

Steema.TeeChart.Axis.TicksPen..ctor オーバーロード

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeLength
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

TicksPen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.TicksPen フィールド

プロテクト フィールド

bVisible (ChartPenの継承元)
cColor (ChartPenの継承元)
custom (ChartPenの継承元)
defaultColor (ChartPenの継承元)
defaultEndCap (ChartPenの継承元)
defaultVisible (ChartPenの継承元)
handle (ChartPenの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TicksPen クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.TicksPen メソッド

パブリック メソッド

Assign (ChartPenの継承元)
Clone (ChartPenの継承元)
Invalidate (ChartPenの継承元)

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor (ChartPenの継承元)
ShouldSerializeDashPattern (ChartPenの継承元)
ShouldSerializeEndCap (ChartPenの継承元)
ShouldSerializeLength
ShouldSerializeStyle (ChartPenの継承元)
ShouldSerializeVisible (ChartPenの継承元)

参照

TicksPen クラス | Steema.TeeChart 名前空間


AssignPen

Steema.TeeChart.Axis+TicksPen.AssignPen メソッド

protected abstract Void AssignPen(ChartPen p)

参照

TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


ShouldSerializeLength

Steema.TeeChart.Axis+TicksPen.ShouldSerializeLength メソッド

protected abstract Boolean ShouldSerializeLength()

参照

TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis.TicksPen プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (ChartPenの継承元) | 描画上で線を描くペンの色を設定します。
DashCap (ChartPenの継承元) | 点線の各セグメントの終了スタイルを設定します。
DashPattern (ChartPenの継承元) |
DrawingPen (ChartPenの継承元) | 内部的なDrawing.Penプロパティにアクセスします。
EndCap (ChartPenの継承元) | 線の終了スタイルを設定します。
Length | 軸の目盛の長さをピクセル単位で取得/設定します。
Style (ChartPenの継承元) | キャンバス上に線を描くペンのスタイルを設定します。
Transparency (ChartPenの継承元) | 0～100%までの透明度を設定します。
Visible (ChartPenの継承元) | ペンが描く線を表示/非表示にします。
Width (ChartPenの継承元) | ペンが描く線の幅を設定します。

参照

TicksPen クラス | Steema.TeeChart 名前空間


Length

TeeChartプログラミングガイド

Steema.TeeChart.Axis+TicksPen.Length プロパティ

軸の目盛の長さをピクセル単位で取得/設定します。

public Int32 Length {get; set;}

解説

軸の目盛の長さをピクセル単位で取得/設定します。

例

[C#]

tChart1.Axes.Bottom.Ticks.Length =10;

参照

TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+TicksPen コンストラクタ

オーバーロードの一覧

public Axis+TicksPen()
public Axis+TicksPen(Steema.TeeChart.Chart)
public Axis+TicksPen(Steema.TeeChart.Drawing.ChartPen, Steema.TeeChart.Chart)

参照

TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+TicksPen コンストラクタ

public Axis+TicksPen()

参照

Axis.TicksPen コンストラクタのオーバーロードの一覧 | TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+TicksPen コンストラクタ

public Axis+TicksPen(Chart c)

参照

Axis.TicksPen コンストラクタのオーバーロードの一覧 | TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Axis+TicksPen コンストラクタ

public Axis+TicksPen(ChartPen p,
     Chart c)

参照

Axis.TicksPen コンストラクタのオーバーロードの一覧 | TicksPen クラス | TicksPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisCalcPosLabelsEventHandler

Steema.TeeChart.AxisCalcPosLabelsEventHandler デリゲート

public delegate AxisCalcPosLabelsEventHandler (Axis axis,
     Int32 value)

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelAlign

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabelAlign 列挙体

軸ラベルの位置を設定します。

[Serializable]
public enum AxisLabelAlign : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Default | デフォルト位置
Opposite | デフォルト位置の反対側にラベルを表示します

参照

Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelItem

Steema.TeeChart.AxisLabelItem クラス

この型のすべてのメンバの一覧については、AxisLabelItem メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class AxisLabelItem : TextShape , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

AxisLabelItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelItem 全メンバ

AxisLabelItem 概要

コンストラクタ

Constructor

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
Repaint | ラベルを更新します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Value | ラベルの軸の値。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisLabelItem クラス | Steema.TeeChart 名前空間


AxisLabelItem コンストラクタ

Steema.TeeChart.AxisLabelItem コンストラクタ

public AxisLabelItem(Chart c)

参照

AxisLabelItem クラス | AxisLabelItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelItem フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

AxisLabelItem クラス | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelItem メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
Repaint | ラベルを更新します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

AxisLabelItem クラス | Steema.TeeChart 名前空間


Repaint

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabelItem.Repaint メソッド

ラベルを更新します。
public Void Repaint()

参照

AxisLabelItem クラス | AxisLabelItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelItem プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Value | ラベルの軸の値。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisLabelItem クラス | Steema.TeeChart 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabelItem.Value プロパティ

ラベルの軸の値。

public Double Value {get; set;}

参照

AxisLabelItem クラス | AxisLabelItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabels

Steema.TeeChart.AxisLabels クラス

軸ラベルの特性。

この型のすべてのメンバの一覧については、AxisLabels メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class AxisLabels : TextShape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

AxisLabels メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabels 全メンバ

AxisLabels 概要

コンストラクタ

Constructor 軸ラベルの特性にアクセスします。

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | 「クリックされた」ラベルのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
LabelHeight | Valueパラメーターの軸ラベルの高さを返します。
LabelValue | Valueパラメーターに該当するラベルの文字列を返します。
LabelWidth | Valueパラメーターの軸ラベルの幅に返します。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
SplitInLines | 指定した文字列を区切り記号の位置で改行します。

パブリック プロパティ

Align | 軸ラベルの位置を設定します。
Alternate | 軸ラベルを2行または2列で描画するよう設定します。
Angle | 各軸ラベルの回転を度数単位で設定します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomSize | 目盛とタイトルの間にある軸ラベルのスペースを変更します。
DateTimeFormat | 軸ラベルを描く標準のDateTime書式の文字列指定子です。
ExactDateTime | Axis.Incrementプロパティが正確なDateTimeステップで軸ラベルを計算するかどうかを制御します。
Exponent | 指数形式で軸ラベルの表示を有効/無効にします。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Items | カスタムラベルにアクセスします。
LabelsAsLocalTime | trueの場合、UTC(UTC: Coordinated Universal Time)ではなく現地時間でDateTimeラベルを表示します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
MultiLine | 複数行のラベルを有効/無効にします。
OnAxis | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
RoundFirstLabel | 軸ラベルを自動的に最も近い値に丸めるかどうか制御します。
Separation | 軸ラベル間の最小距離をパーセントで指定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Style | 軸ラベルのスタイルを設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
ValueFormat | 軸ラベルの書式を指定します。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

axisvaluesformat
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bExponent
bImageBevel (Shapeの継承元)
bOnAxis
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iAngle
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSeparation
iStyle
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
labelPos
position
pPen (Shapeの継承元)
sDatetimeformat
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisLabels クラス | Steema.TeeChart 名前空間


AxisLabels コンストラクタ

Steema.TeeChart.AxisLabels コンストラクタ

軸ラベルのラベルの特性にアクセスします。
public AxisLabels(Axis a)

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabels フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

axisvaluesformat
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bExponent
bImageBevel (Shapeの継承元)
bOnAxis
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iAngle
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSeparation
iStyle
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
labelPos
position
pPen (Shapeの継承元)
sDatetimeformat
Steema.TeeChart.Drawing.TeeBase.Tag

参照

AxisLabels クラス | Steema.TeeChart 名前空間


axisvaluesformat

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.axisvaluesformat フィールド

protected internal String axisvaluesformat

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


bExponent

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.bExponent フィールド

protected internal Boolean bExponent

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


bOnAxis

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.bOnAxis フィールド

protected internal Boolean bOnAxis

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


iAngle

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.iAngle フィールド

protected internal Int32 iAngle

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


isEAxisValueFormat

Steema.TeeChart.AxisLabels.isEAxisValueFormat フィールド

protected internal Int32 isEAxisValueFormat

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


iSeparation

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.iSeparation フィールド

protected internal Int32 iSeparation

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


iStyle

Steema.TeeChart.AxisLabels.iStyle フィールド

protected internal AxisLabelStyle iStyle

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


labelPos

Steema.TeeChart.AxisLabels.labelPos フィールド

protected internal ArrayList labelPos

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


position

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.position フィールド

protected internal Int32 position

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


sDatetimeformat

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.sDatetimeformat フィールド

protected internal String sDatetimeformat

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabels メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | 「クリックされた」ラベルのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
LabelHeight | Valueパラメーターの軸ラベルの高さを返します。
LabelValue | Valueパラメーターに該当するラベルの文字列を返します。
LabelWidth | Valueパラメーターの軸ラベルの幅に返します。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
SplitInLines | 指定した文字列を区切り記号の位置で改行します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent
ShouldSerializeVisible (Shapeの継承元)

参照

AxisLabels クラス | Steema.TeeChart 名前空間


Clicked

Steema.TeeChart.AxisLabels.Clicked メソッド

「クリックされた」ラベルのインデックスを返します。
public Int32 Clicked(Int32 X,
     Int32 Y)

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


LabelHeight

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.LabelHeight メソッド

Valueパラメーターの軸ラベルの高さを返します。

public Int32 LabelHeight(Double value)

パラメーター

value
軸の値

戻り値

ピクセル単位の軸ラベルの高さ

解説

Valueパラメーターの軸ラベルの高さを返します。軸形式の指定や、軸ラベルフォントやラベル回転やスタイルに使用します。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


LabelValue

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.LabelValue メソッド

Valueパラメーターに該当するラベルの文字列を返します。

public String LabelValue(Double value)

解説

Valueパラメーターに該当するラベルの文字列を返します。これは軸形式の指定に使用します。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


LabelWidth

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.LabelWidth メソッド

Valueパラメーターの軸ラベルの幅を返します。

public Int32 LabelWidth(Double value)

パラメーター

value
軸の値

戻り値

ピクセル単位の軸ラベルの幅

解説

Valueパラメータの軸ラベル幅を返します。軸形式の指定や、軸ラベルフォントやラベル回転やスタイルに使用します。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


ShouldSerializeTransparent

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.ShouldSerializeTransparent メソッド

protected virtual Boolean ShouldSerializeTransparent()

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


SplitInLines

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.SplitInLines メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
指定した文字列を区切り記号の位置で改行します。

public Void SplitInLines(String& s,
     String separator)

パラメーター

s
入力文字列
separator
改行に使用される区切り記号文字列

解説

このメソッドは、指定した文字列（s）を区切り記号の（separator）の位置で改行します。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabels プロパティ

パブリック プロパティ

Align | 軸ラベルの位置を設定します。
Alternate | 軸ラベルを2行または2列で描画するよう設定します。
Angle | 各軸ラベルの回転を度数単位で設定します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomSize | 目盛とタイトルの間にある軸ラベルのスペースを変更します。
DateTimeFormat | 軸ラベルを描く標準のDateTime書式の文字列指定子です。
ExactDateTime | Axis.Incrementプロパティが正確なDateTimeステップで軸ラベルを計算するかどうかを制御します。
Exponent | 指数形式で軸ラベルの表示を有効/無効にします。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Items | カスタムラベルにアクセスします。
LabelsAsLocalTime | trueの場合、UTC(UTC: Coordinated Universal Time)ではなく現地時間でDateTimeラベルを表示します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
MultiLine | 複数行のラベルを有効/無効にします。
OnAxis | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
RoundFirstLabel | 軸ラベルを自動的に最も近い値に丸めるかどうか制御します。
Separation | 軸ラベル間の最小距離をパーセントで指定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Style | 軸ラベルのスタイルを設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
ValueFormat | 軸ラベルの書式を指定します。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisLabels クラス | Steema.TeeChart 名前空間


Align

Steema.TeeChart.AxisLabels.Align プロパティ

軸ラベルの位置を設定します。
public AxisLabelAlign Align {get; set;}

解説

軸ラベルのデフォルト位置は、関連する軸に依存します。下軸は、デフォルトにより軸の下側にラベルを表示します。上軸は、軸の上側にラベルを表示します。

Default：デフォルト位置
Opposite：デフォルト位置の反対側にラベルを表示します。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Alternate

Steema.TeeChart.AxisLabels.Alternate プロパティ

軸ラベルを2行または2列で描画するよう設定します。

public Boolean Alternate {get; set;}

解説

trueの場合、最初の軸ラベルは軸線の近くに1つ、次の軸ラベルはその下に表示されます。

水平軸や回転なしのラベルと使用すると効果的です。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Angle

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.Angle プロパティ

各軸ラベルの回転を度数単位で設定します。

public Int32 Angle {get; set;}

解説

デフォルト値：0

各軸ラベルの回転を度数単位で設定します。有効な角度の値は0、90、180、270、360です。

プリンタやビデオドライバによっては回転させたフォントや計算した回転フォント寸法を描画できないものもあります。回転したフォントを持っているメタファイルのチャートは、少し異なる座標にテキストを置く場合があります。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


CustomSize

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.CustomSize プロパティ

目盛とタイトルの間にある軸ラベルのスペースを変更します。

public Int32 CustomSize {get; set;}

解説

目盛とタイトルの間にある軸ラベルのスペースを変更することができます。

例

[C#]

tChart1.Axes.Bottom.Labels.CustomSize = 15;

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


DateTimeFormat

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.DateTimeFormat プロパティ

軸ラベルを描く基本的なDateTime書式の文字列指定子です。

public String DateTimeFormat {get; set;}

解説

ChartのAxisLabelsは、DateTimeFormatプロパティを持っています。DateTimeFormatは、基本的なDateTime書式の文字列指定子です。チャート軸は、軸ラベルを描く際にこれを使用します。

シンボル | 表示
c | 与えられた日付をShortDateFormatグローバル変数や、LongTimeFormatグローバル変数で表示します。DateTime値の断片的な部分がゼロの場合、時間は表示されません。
d | 日付を返します。1桁の場合、先頭に0が付きません(1～31)。
dd | 日付を返します。1桁の場合、先頭に0が付きます(01～31)。
ddd | 曜日を英語(省略形)で返します(Sun～Sat)。
dddd | 曜日を英語(フルネーム)で返します(Sunday-Saturday)。
ddddd | 年、月、日を含む短い形式で表した日付を返します。
dddddd | 年、月、日を含む長い形式で表した日付を返します。
M | 月を表す数値を返します。1桁の場合、先頭に0が付きません(1～12)。ただし、hやhhの直後にmを指定した場合、月ではなく時間の「分」と解釈されます。
MM | 月を表す数値を返します。1桁の場合、先頭に0が付きます(01～12)。ただし、hやhhの直後にmmを指定した場合、月ではなく時間の「分」と解釈されます。
MMM | 月の名前を英語(省略形)の文字列に変換して返します(Jan～Dec)。
mmmm | 月の名前を英語(フルネーム)で返します(January～December)。
yy | 西暦の年を下2桁の数値で返します(00～99)。
yyyy | 西暦の年を4桁の数値で返します(0000～9999)。
h | 時間を返します。1桁の場合、先頭に0が付きません(0～23)。
hh | 時間を返します。1桁の場合、先頭に0が付きます(00～23)。
m | 分を返します。1桁の場合、先頭に0が付きません(0～59)。
mm | 分を返します。1桁の場合、先頭に0が付きます(00～59)。
s | 秒を返します。1桁の場合、先頭に0が付きません(0～59)。
ss | 秒を返します。1桁の場合、先頭に0が付きます(00～59)。
zzz | ミリ秒を返します(0.000 - 0.999)。
t | 与えられた時間をShortTimeFormatグローバル変数で表示します。
tt | 与えられた時間をLongTimeFormatグローバル変数で表示します。
am/pm | 時刻が正午以前の場合は小文字でamを表示し、正午～午後11時59分の間は小文字でpmを表示します。
a/p | 時刻が正午以前の場合は小文字でaを表示し、正午～午後11時59分の間は小文字でpを表示します。
ampm | 12時間制"が選択されていて、時刻が正午以前の場合は午前を表すTimeAMStringグローバル変数を、正午～午後11時59分の間は午後を表すTimePMStringグローバル変数で表示します。
/ | 日付の区切り記号です。日付を年、月、日で区切ることができます。
: | 時刻の区切り記号です。時刻を時間、分、秒で区切ることができます。
'xx'/"xx" | 文字の括りは、シングルコーテーションおよびダブルコーテーションの両方が使用できます。

フォーマットシンボルは、大文字や小文字の両方を使用できます。

文字列が空の場合、日付や時間の値は、「c」フォーマットになります。

例

[C#]

((Line)tChart3[0]).XValues.DateTime=true;
tChart3.Axes.Bottom.Labels.DateTimeFormat="dd/MM/yyyy";

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


ExactDateTime

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.ExactDateTime プロパティ

Axis.Incrementプロパティが正確なDateTimeステップで軸ラベルを計算するかどうかを制御します。

public Boolean ExactDateTime {get; set;}

解説

デフォルト値：false

Axis.Incrementプロパティが正確なDateTimeステップで軸ラベルを計算するかどうかを制御します。

これは、Axis.IncrementプロパティがDateTimeStep定数値になっている場合、非常に便利です。

例

[C#]
tChart1.Axes.Bottom.Increment=GetDateTimeStep(Steema.TeeChart.DateTimeSteps.OneMonth);

この例では、Incrementプロパティは、厳密な1月であると想定します。従って、軸ラベルが以下になっているとします。

'1-April-1996'

その次の軸ラベルは以下のようになります。

'1-May-1996'

そして次のラベルは以下のとおりです。

'1-June-1996'

ExactDateTimeがFalse（デフォルト値）になっていると、OneMonthインクリメントは30日になり、軸は1ヶ月が何日あるかを計算しません。

SeriesのXValuesあるいはYValuesプロパティは、DateTimeプロパティをtrueにしなければなりません（水平軸ではXvalues、および垂直軸ではYValues）。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Exponent

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.Exponent プロパティ

指数形式で軸ラベルの表示を有効/無効にします。

public Boolean Exponent {get; set;}

解説

デフォルト値：false

指数形式で軸ラベルの表示を有効/無効にします。

例

[C#]
tChart1.Axes.Left.Labels.Exponent=true;
tChart1.Axes.Left.Labels.ValueFormat="00e-0";

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Items

Steema.TeeChart.AxisLabels.Items プロパティ

カスタムラベルにアクセスします。
public AxisLabelsItems Items {get;}

解説

軸ラベルのデフォルトの書式オブジェクト。

フォント、背景色、透明度、影、グラデーションなどを設定するプロパティを含んでいます。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


LabelsAsLocalTime

Steema.TeeChart.AxisLabels.LabelsAsLocalTime プロパティ

trueの場合、UTC(UTC: Coordinated Universal Time)ではなく現地時間でDateTimeラベルを表示します。
public Boolean LabelsAsLocalTime {get; set;}

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


MultiLine

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.MultiLine プロパティ

複数行のラベルを有効/無効にします。

public Boolean MultiLine {get; set;}

解説

複数行のラベルを有効/無効にします。DateTimeラベルにスペースを使用する場合、TeeChartは自動的に複数行のテキストにラベルを行分けします。他のラベルタイプに複数行のテキストを行分けしたい場合、'\n'またはOnGetAxisLabelイベントでSplitInLinesメソッドを使用してください。

例

[C#]

DateTime値：1/2/1999 12:00:00は、Multilineプロパティをtrueに設定すると次のように表示されます。

1/2/1999
12:00:00

((Line)tChart1[1]).XValues.DateTime=true;
tChart1.Axes.Bottom.Labels.DateTimeFormat="dd/MM/yyyy" +'\n'+"hh/mm/ss";
tChart1.Axes.Bottom.Labels.MultiLine = true;

DateTime以外のラベルの場合は、"myLabel1stLine" + '\n + "MyLabel2ndLine"とするか、あるいはSplitInLinesメソッドを使用してください。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


RoundFirstLabel

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.RoundFirstLabel プロパティ

軸ラベルを自動的に最も近い値に丸めるかどうか制御します。

public Boolean RoundFirstLabel {get; set;}

解説

デフォルト値：true

実行時専用。軸ラベルを自動的に最も近い値に丸めるかどうか制御します。これは、DateTimeおよびDateTime以外の両方の軸値に適用されます。

例

軸を最小値：70 最大値：585と指定。

[C#]

tChart1.Axes.Left.Labels.RoundFirstLabel = true;

軸ラベル： 100 200 300 400 500

tChart1.Axes.Left.Labels.RoundFirstLabel = false;

軸ラベル： 85 185 285 385 485 585

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Separation

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.Separation プロパティ

軸ラベル間の最小距離をパーセントで指定します。

public Int32 Separation {get; set;}

解説

デフォルト値：10

軸ラベル間の最小距離をパーセントで指定します。
「0」に設定すると、ラベルがオーバーラップされたままの状態になります（クリッピングは実行されません）。
Labels.Font.Size、Labels.Angleプロパティ、Axis.Incrementプロパティによりラベルの表示も異なります。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Style

Steema.TeeChart.AxisLabels.Style プロパティ

軸ラベルのスタイルを設定します。
public AxisLabelStyle Style {get; set;}

解説

Axis.Label.StyleプロパティをtalAutoに設定すると、軸のラベルが自動的に設定されます。
系列にXLabelsがある場合、Label.StyleプロパティにはtalTextが設定されます。
XLabelsがなければ、Label.StyleプロパティにはtalValueが設定されます。
軸にアクティブな系列が関連付けされていない場合、Label.StyleプロパティにはtalNoneが設定されます。

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


ValueFormat

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabels.ValueFormat プロパティ

軸ラベルの書式を指定します。

public String ValueFormat {get; set;}

解説

デフォルト値：'#,##0.###'

このプロパティは、軸ラベルの書式を指定します。これは軸に関連する系列がXValues.DateTimeかYValues.DateTimeプロパティがFalseに設定されている場合に効果があります。

DateTime軸ラベルの場合には、AxisLabels.DateTimeFormat プロパティを使用してください。

このプロパティは、標準的な書式に関する文字列指定子です。

チャート軸は、これを使用して軸ラベルを描きます。

チャート系列は、これを使用してマーカを描きます。

例

書式文字列 1234 -1234 0.5 0
0 1234 -1234 1 0
0.00 1234.00 -1234.00 0.50 0.00
#.## 1234 -1234 .5
##0.00 1,234.00 -1,234.00 0.50 0.00
#,##0.00;(#,##0.00) 1,234.00 (1,234.00) 0.50 0.00
#,##0.00;;Zero 1,234.00 -1,234.00 0.50 Zero
0.000E+00 1.234E+03 -1.234E+03 5.000E-01 0.000E+00
#.###E-0 1.234E3 -1.234E3 5E-1 0E0

参照

AxisLabels クラス | AxisLabels メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelsItems

Steema.TeeChart.AxisLabelsItems クラス

カスタムラベルのリスト。

この型のすべてのメンバの一覧については、AxisLabelsItems メンバを参照してください。

System.Object
System.Collections.Generic.List<AxisLabelItem>
public class AxisLabelsItems : List<AxisLabelItem>
, IList<AxisLabelItem>
, ICollection<AxisLabelItem>
, IEnumerable<AxisLabelItem>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelsItems 全メンバ

AxisLabelsItems 概要

コンストラクタ

Constructor

パブリック メソッド

Add | 指定したインデックス番目のラベル特性にアクセスします。
Clear | カスタムラベルのリストを削除します。
CopyFrom |

参照

AxisLabelsItems クラス | Steema.TeeChart 名前空間


AxisLabelsItems コンストラクタ

Steema.TeeChart.AxisLabelsItems コンストラクタ

public AxisLabelsItems(Axis a)

参照

AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelsItems メソッド

パブリック メソッド

Add | 指定したインデックス番目のラベル特性にアクセスします。
Clear | カスタムラベルのリストを削除します。
CopyFrom |

参照

AxisLabelsItems クラス | Steema.TeeChart 名前空間


Add

Steema.TeeChart.AxisLabelsItems.Add メソッド

オーバーロードの一覧

新しいラベルを追加します。

public AxisLabelItem Add(System.Double)

テキストと新しいラベルを追加します。

public AxisLabelItem Add(System.Double, System.String)

解説

新しいラベルを追加します。

参照

AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Add

Steema.TeeChart.AxisLabelsItems.Add メソッド

新しいラベルを追加します。
public AxisLabelItem Add(Double value)

パラメーター

value
軸のデータ値

戻り値

新しいAxisLabelItem

参照

Add オーバーロードの一覧 | AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Add

Steema.TeeChart.AxisLabelsItems.Add メソッド

テキストと新しいラベルを追加します。
public AxisLabelItem Add(Double value,
     String text)

パラメーター

value
ラベルテキスト
text
軸のデータ値

戻り値

新しいAxisLabelItem

参照

Add オーバーロードの一覧 | AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.AxisLabelsItems.Clear メソッド

カスタムラベルのリストを削除します。
public Void Clear()

解説

カスタムラベルのリストを削除します。

参照

AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


CopyFrom

Steema.TeeChart.AxisLabelsItems.CopyFrom メソッド

public Void CopyFrom(AxisLabelsItems Source)

解説

内部使用。
Sourceリストからすべてのアイテムオブジェクトをコピー（複製）します。

参照

AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelsItems プロパティ

パブリック プロパティ

Item 指定したインデックスのラベル特性にアクセスします。

参照

AxisLabelsItems クラス | Steema.TeeChart 名前空間


Item

Steema.TeeChart.AxisLabelsItems.Item プロパティ

指定したインデックスのラベル特性にアクセスします。
public AxisLabelItem Item(Int32 index) {get;}

解説

指定したインデックスのラベル特性にアクセスします。

参照

AxisLabelsItems クラス | AxisLabelsItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisLabelStyle

TeeChartプログラミングガイド

Steema.TeeChart.AxisLabelStyle 列挙体

Styleプロパティの使用可能な値を定義します。

[Serializable]
public enum AxisLabelStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Auto | 自動スタイル選択。
None | ラベルなし。
Value | 軸のMinimumプロパティとMaximumプロパティに基づいた軸ラベルになります。
Mark | 各系列ポイントは、SeriesMarksスタイルを使用するラベルが設定されます。
Text | 各系列ポイントは、Series.XLabels文字列をしようするラベルが設定されます。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle

Steema.TeeChart.AxisTitle クラス

軸タイトルの特性。

この型のすべてのメンバの一覧については、AxisTitle メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public sealed class AxisTitle : TextShape , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

AxisTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle 全メンバ

AxisTitle 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

Angle | 各軸のラベルに回転を度数単位で設定します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Caption | 各軸のタイトルを表示する文字列を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomSize | 軸ラベルとチャートパネルの枠との間のスペースを設定します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle コンストラクタ

オーバーロードの一覧

public AxisTitle()
public AxisTitle(Steema.TeeChart.Chart)

参照

AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle コンストラクタ

public AxisTitle()

参照

AxisTitle コンストラクタのオーバーロードの一覧 | AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle コンストラクタ

public AxisTitle(Chart c)

参照

AxisTitle コンストラクタのオーバーロードの一覧 | AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

AxisTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

AxisTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.AxisTitle プロパティ

パブリック プロパティ

Angle | 各軸のラベルに回転を度数単位で設定します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Caption | 各軸のタイトルを表示する文字列を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomSize | 軸ラベルとチャートパネルの枠との間のスペースを設定します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

AxisTitle クラス | Steema.TeeChart 名前空間


Angle

TeeChartプログラミングガイド

Steema.TeeChart.AxisTitle.Angle プロパティ

各軸のラベルに回転を度数単位で設定します。

public Int32 Angle {get; set;}

解説

軸がタイトルを表示するために、このプロパティを使用します。Axis.Titleプロパティを参照してください。

例

[C#]

tChart1.Axes.Left.Title.Caption = 'My Left Axis';

参照

AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


Caption

TeeChartプログラミングガイド

Steema.TeeChart.AxisTitle.Caption プロパティ

各軸のタイトルを表示する文字列を設定します。

public String Caption {get; set;}

解説

各軸のタイトルを表示する文字列を設定します。空の場合、タイトルは表示されません。軸タイトルの書式を制御するにはAngleプロパティやFontプロパティを使用してください。

参照

AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


CustomSize

TeeChartプログラミングガイド

Steema.TeeChart.AxisTitle.CustomSize プロパティ

軸ラベルとチャートパネルの枠との間のスペースを設定します。

public Int32 CustomSize {get; set;}

解説

軸ラベルとチャートパネルの枠との間のスペースを設定するために使用してください。

参照

AxisTitle クラス | AxisTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonColor

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor クラス

ダイアログボタンの色。

この型のすべてのメンバの一覧については、ButtonColor メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ButtonBase
System.Windows.Forms.Button
public class ButtonColor : Button , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
, IButtonControl

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ButtonColor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonColor 全メンバ

ButtonColor 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Color
FlatStyle

プロテクト メソッド

OnClick
OnPaint

参照

ButtonColor クラス | Steema.TeeChart 名前空間


ButtonColor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor コンストラクタ

オーバーロードの一覧

public ButtonColor()
public ButtonColor(System.Drawing.Color)

参照

ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


ButtonColor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor コンストラクタ

public ButtonColor()

参照

ButtonColor コンストラクタのオーバーロードの一覧 | ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


ButtonColor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor コンストラクタ

public ButtonColor(Color c)

参照

ButtonColor コンストラクタのオーバーロードの一覧 | ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonColor メソッド

プロテクト メソッド

OnClick
OnPaint

参照

ButtonColor クラス | Steema.TeeChart 名前空間


OnClick

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor.OnClick メソッド

protected virtual Void OnClick(EventArgs e)

参照

ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


OnPaint

TeeChartプログラミングガイド

Steema.TeeChart.ButtonColor.OnPaint メソッド

protected virtual Void OnPaint(PaintEventArgs pe)

参照

ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonColor プロパティ

パブリック プロパティ

Color
FlatStyle

参照

ButtonColor クラス | Steema.TeeChart 名前空間


Color

Steema.TeeChart.ButtonColor.Color プロパティ

public Color Color {get; set;}

解説

ボタンの色を設定します。

参照

ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


FlatStyle

Steema.TeeChart.ButtonColor.FlatStyle プロパティ

public FlatStyle FlatStyle {get; set;}

解説

ボタンのスタイルを設定します。

Flat ボタンは常にフラットで表示されます。
Popup ボタン上にマウスカーソルが移動すると3Dで表示され、それ以外の位置にカーソルがある場合はフラットで表示されます。
Standard ボタンは常に3Dで表示されます。
System ボタンはユーザーのオペレーティングシステムにより制御されます。

参照

ButtonColor クラス | ButtonColor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonPen

TeeChartプログラミングガイド

Steema.TeeChart.ButtonPen クラス

ダイアログボタンのペン。

この型のすべてのメンバの一覧については、ButtonPen メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ButtonBase
System.Windows.Forms.Button
public class ButtonPen : Button , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
, IButtonControl

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ButtonPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonPen 全メンバ

ButtonPen 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Pen

プロテクト メソッド

OnClick
OnPaint

参照

ButtonPen クラス | Steema.TeeChart 名前空間


ButtonPen コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ButtonPen コンストラクタ

オーバーロードの一覧

public ButtonPen()
public ButtonPen(Steema.TeeChart.Drawing.ChartPen)

参照

ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


ButtonPen コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ButtonPen コンストラクタ

public ButtonPen()

参照

ButtonPen コンストラクタのオーバーロードの一覧 | ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


ButtonPen コンストラクタ

Steema.TeeChart.ButtonPen コンストラクタ

public ButtonPen(ChartPen p)

参照

ButtonPen コンストラクタのオーバーロードの一覧 | ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonPen メソッド

プロテクト メソッド

OnClick
OnPaint

参照

ButtonPen クラス | Steema.TeeChart 名前空間


OnClick

TeeChartプログラミングガイド

Steema.TeeChart.ButtonPen.OnClick メソッド

protected virtual Void OnClick(EventArgs e)

参照

ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


OnPaint

TeeChartプログラミングガイド

Steema.TeeChart.ButtonPen.OnPaint メソッド

protected virtual Void OnPaint(PaintEventArgs pe)

参照

ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ButtonPen プロパティ

パブリック プロパティ

Pen

参照

ButtonPen クラス | Steema.TeeChart 名前空間


Pen

Steema.TeeChart.ButtonPen.Pen プロパティ

public ChartPen Pen {get; set;}

解説

現在、TButtonPenに関連付けられているペンです。

参照

ButtonPen クラス | ButtonPen メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChangeActiveEventHandler

Steema.TeeChart.ChangeActiveEventHandler デリゲート

public delegate ChangeActiveEventHandler (Object sender,
     NotifySeriesEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.ChangeColorEventHandler

Steema.TeeChart.ChangeColorEventHandler デリゲート

public delegate ChangeColorEventHandler (Object sender,
     NotifySeriesEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.ChangeOrderEventArgs

Steema.TeeChart.ChangeOrderEventArgs クラス

この型のすべてのメンバの一覧については、ChangeOrderEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class ChangeOrderEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ChangeOrderEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChangeOrderEventArgs 全メンバ

ChangeOrderEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Series1
Series2

参照

ChangeOrderEventArgs クラス | Steema.TeeChart 名前空間


ChangeOrderEventArgs コンストラクタ

Steema.TeeChart.ChangeOrderEventArgs コンストラクタ

public ChangeOrderEventArgs(Series s1,
     Series s2)

参照

ChangeOrderEventArgs クラス | ChangeOrderEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChangeOrderEventArgs プロパティ

パブリック プロパティ

Series1
Series2

参照

ChangeOrderEventArgs クラス | Steema.TeeChart 名前空間


Series1

Steema.TeeChart.ChangeOrderEventArgs.Series1 プロパティ

public Series Series1 {get;}

解説

このツールに関連付けられている最初の系列の設定や取得を行います。

参照

ChangeOrderEventArgs クラス | ChangeOrderEventArgs メンバ | Steema.TeeChart 名前空間


Series2

Steema.TeeChart.ChangeOrderEventArgs.Series2 プロパティ

public Series Series2 {get;}

解説

このツールに関連付けられている2番目の系列の設定や取得を行います。

参照

ChangeOrderEventArgs クラス | ChangeOrderEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChangeOrderEventHandler

Steema.TeeChart.ChangeOrderEventHandler デリゲート

public delegate ChangeOrderEventHandler (Object sender,
     ChangeOrderEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Chart

Steema.TeeChart.Chart クラス

チャートコンテンツ。使用については、TChart と WebChartを参照してください。

この型のすべてのメンバの一覧については、Chart メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Chart : TeeBase , IComponent, IDisposable
, ISerializable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Chart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart 全メンバ

Chart 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

AutoRepaint
CancelMouse
ChartRect
ClipWhenMetafiling
ClipWhenPrinting
iOpenGL
iWorldMaps

パブリック メソッド

ActiveSeriesLegend | 凡例のItemIndex位置に該当するアクティブな系列を返します。
Bitmap | 指定したファイル名に現在のチャートイメージを保存します。
CalcClickedPart |
CanClip | チャートの描画キャンバスが線や多角形をクリッピングする機能があるかどうか返します。
Clone |
CountActiveSeries | アクティブな（表示している）系列の数を返します。
DoKeyDown |
DoMouseDown |
DoMouseMove |
DoMouseUp |
Draw | 指定したキャンバスにチャートを描画します。
FormattedLegend | 凡例の位置に該当するテキストの文字列を返します。
FormattedValueLegend | 指定した系列とポイントインデックスに該当する凡例の文字列を返します。
FreeSeriesColor | どの系列にも使用されていないデフォルトカラーパレットの色を返します。
GetASeries | 最初のアクティブな系列を返します。
GetAxisSeries | 指定した軸に依存する最初の系列を返します。
GetObjectData |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsAxisVisible |
IsFreeSeriesColor | Colorパラメーターが他の系列で使用されていないかどうかを返します。
MaxMarkWidth | すべてのアクティブな系列のマーカの最大幅をピクセル単位で返します。
MaxTextWidth | すべての系列ラベルの最大幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
Metafile |
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
SeriesLegend | 凡例のスタイルが｢Series｣の場合、凡例の｢ItemIndex｣位置に該当する系列を返します。｢OnlyActive｣パラメーターがfalseの場合、すべての系列を対象とします。
SeriesTitleLegend | 系列タイトルの文字列を返します。
UndoZoom |

パブリック プロパティ

Aspect | チャートのビュー特性にアクセスします。
Axes | 軸オブジェクトのリストにアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartBounds | 読み込み専用。チャートの4サイド(左、上、右、下）を取得するために使用されます。
Export | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Footer | チャートの下部に描くテキストや書式特性を定義します。
Graphics3D | TeeChartの描画についてのプロパティやメソッドにアクセスします。
Header | チャートの上部に描くテキストや書式特性を定義します。
Height | チャートの高さをピクセル単位で設定します。
Import | チャートのインポートについてのプロパティやメソッドにアクセスします。
Item | デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
Legend | 凡例の特性にアクセスします。.
Listeners | ITeeEventListenerインターフェイスを実装するオブジェクトの配列リストを返します。
MaxZOrder | 実行時および読取専用。チャートの奥行きを系列の数で示します。Chart.View3DプロパティがTrueの場合、各系列はZオーダーを持ちます。系列のZオーダーは、系列が表示される際にZ軸に沿って順序を定義します。このプロパティは、すべてのアクティブな系列の中で最大のZオーダーです。系列の中には、同じZオーダーを共有するものもあります（積み重ねバー、積み重ね面、など）。
Page | チャートの複数ページ特性にアクセスします。
Panel | チャート背面の可視属性を設定します。
Panning | スクロールする方向を設定したり、スクロールを拒否します。
Parent | ChartのIChart親クラスを取得/設定します。
Printer | 印刷に関連したプロパティやメソッドにアクセスします。
SerializedTag | カスタムなタグオブジェクトを保持します。
Series | チャートに含まれる系列のリストにアクセスします。
SubFooter | フッターの上に表示されるテキストを定義します。
SubHeader | ヘッダーの下に表示されるテキストを定義します。
SubTitle |
Title |
Tools | チャート内に含まれているツールコンポーネントのコレクションです。
ToolTip | カーソルにテキストボックスを表示します。
Walls | チャートの左、下、背面の壁特性にアクセスします。
Width | チャートの幅をピクセル単位で設定します。
Zoom | チャートのズーム特性にアクセスします。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
iPage
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

BroadcastEvent
BroadcastKeyEvent
BroadcastMouseEvent
BroadcastToolEvent
CheckZoomPanning
Dispose
initVars
InternalMinMax
IsValidDataSource
MultiLineTextWidth
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeListeners

参照

Chart クラス | Steema.TeeChart 名前空間


Chart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Chart コンストラクタ

オーバーロードの一覧

public Chart()
public Chart(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Chart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Chart コンストラクタ

public Chart()

参照

Chart コンストラクタのオーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Chart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Chart コンストラクタ

public Chart(SerializationInfo info,
     StreamingContext context)

参照

Chart コンストラクタのオーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart フィールド

パブリック フィールド

AutoRepaint
CancelMouse
ChartRect
ClipWhenMetafiling
ClipWhenPrinting
iOpenGL
iWorldMaps

プロテクト フィールド

InternalUse (TeeBaseの継承元)
iPage
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Chart クラス | Steema.TeeChart 名前空間


AutoRepaint

TeeChartプログラミングガイド

Steema.TeeChart.Chart.AutoRepaint フィールド

public Boolean AutoRepaint

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


CancelMouse

TeeChartプログラミングガイド

Steema.TeeChart.Chart.CancelMouse フィールド

public Boolean CancelMouse

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ChartRect

TeeChartプログラミングガイド

Steema.TeeChart.Chart.ChartRect フィールド

public Rectangle ChartRect

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ClipWhenMetafiling

TeeChartプログラミングガイド

Steema.TeeChart.Chart.ClipWhenMetafiling フィールド

public Boolean ClipWhenMetafiling

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ClipWhenPrinting

TeeChartプログラミングガイド

Steema.TeeChart.Chart.ClipWhenPrinting フィールド

public Boolean ClipWhenPrinting

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


iOpenGL

Steema.TeeChart.Chart.iOpenGL フィールド

public Boolean iOpenGL

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


iPage

Steema.TeeChart.Chart.iPage フィールド

protected internal Page iPage

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


iWorldMaps

Steema.TeeChart.Chart.iWorldMaps フィールド

public Boolean iWorldMaps

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart メソッド

パブリック メソッド

ActiveSeriesLegend | 凡例のItemIndex位置に該当するアクティブな系列を返します。
Bitmap | 指定したファイル名に現在のチャートイメージを保存します。
CalcClickedPart |
CanClip | チャートの描画キャンバスが線や多角形をクリッピングする機能があるかどうか返します。
Clone |
CountActiveSeries | アクティブな（表示している）系列の数を返します。
DoKeyDown |
DoMouseDown |
DoMouseMove |
DoMouseUp |
Draw | 指定したキャンバスにチャートを描画します。
FormattedLegend | 凡例の位置に該当するテキストの文字列を返します。
FormattedValueLegend | 指定した系列とポイントインデックスに該当する凡例の文字列を返します。
FreeSeriesColor | どの系列にも使用されていないデフォルトカラーパレットの色を返します。
GetASeries | 最初のアクティブな系列を返します。
GetAxisSeries | 指定した軸に依存する最初の系列を返します。
GetObjectData |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsAxisVisible |
IsFreeSeriesColor | Colorパラメーターが他の系列で使用されていないかどうかを返します。
MaxMarkWidth | すべてのアクティブな系列のマーカの最大幅をピクセル単位で返します。
MaxTextWidth | すべての系列ラベルの最大幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
Metafile |
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
SeriesLegend | 凡例のスタイルが｢Series｣の場合、凡例の｢ItemIndex｣位置に該当する系列を返します。｢OnlyActive｣パラメーターがfalseの場合、すべての系列を対象とします。
SeriesTitleLegend | 系列タイトルの文字列を返します。
UndoZoom |

プロテクト メソッド

BroadcastEvent
BroadcastKeyEvent
BroadcastMouseEvent
BroadcastToolEvent
CheckZoomPanning
Dispose
initVars
InternalMinMax
IsValidDataSource
MultiLineTextWidth
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeListeners

参照

Chart クラス | Steema.TeeChart 名前空間


ActiveSeriesLegend

Steema.TeeChart.Chart.ActiveSeriesLegend メソッド

凡例のItemIndex位置に該当するアクティブな系列を返します。
public Series ActiveSeriesLegend(Int32 itemIndex)

解説

凡例のItemIndex位置に該当するアクティブな系列を返します。

全系列がアクティブの場合、これはChart1.Seriesプロパティと同じ機能になります。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Bitmap

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Bitmap メソッド

オーバーロードの一覧

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap(System.Int32, System.Int32, System.Drawing.Imaging.PixelFormat)

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap(System.Int32, System.Int32)

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap()

解説

指定したファイル名に現在のチャートイメージを保存します。有効なパス名およびBMP拡張子のファイル名を指定してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Bitmap

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Bitmap メソッド

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap(Int32 width,
     Int32 height,
     PixelFormat pixelformat)

参照

Bitmap オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Bitmap

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Bitmap メソッド

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap(Int32 width,
     Int32 height)

参照

Bitmap オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Bitmap

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Bitmap メソッド

指定したファイル名に現在のチャートイメージを保存します。

public Bitmap Bitmap()

参照

Bitmap オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastEvent

Steema.TeeChart.Chart.BroadcastEvent メソッド

protected internal Void BroadcastEvent(Series s,
     SeriesEventStyle e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastKeyEvent

Steema.TeeChart.Chart.BroadcastKeyEvent メソッド

protected internal abstract Void BroadcastKeyEvent(KeyEventArgs e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastMouseEvent

Steema.TeeChart.Chart.BroadcastMouseEvent メソッド

オーバーロードの一覧

protected internal abstract Void BroadcastMouseEvent(Steema.TeeChart.MouseEventKinds, System.Windows.Forms.MouseEventArgs, System.Windows.Forms.Keys)
protected internal abstract Void BroadcastMouseEvent(Steema.TeeChart.MouseEventKinds, System.Windows.Forms.MouseEventArgs, System.Windows.Forms.Cursor&)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastMouseEvent

Steema.TeeChart.Chart.BroadcastMouseEvent メソッド

protected internal abstract Void BroadcastMouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Keys modKeys)

参照

BroadcastMouseEvent オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastMouseEvent

Steema.TeeChart.Chart.BroadcastMouseEvent メソッド

protected internal abstract Void BroadcastMouseEvent(MouseEventKinds kind,
     MouseEventArgs e)

参照

BroadcastMouseEvent オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


BroadcastToolEvent

TeeChartプログラミングガイド

Steema.TeeChart.Chart.BroadcastToolEvent メソッド

protected internal virtual Void BroadcastToolEvent(EventArgs e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


CalcClickedPart

Steema.TeeChart.Chart.CalcClickedPart メソッド

public Void CalcClickedPart(Point Pos,
     ChartClickedPart& Part)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


CanClip

TeeChartプログラミングガイド

Steema.TeeChart.Chart.CanClip メソッド

チャートの描画キャンバスが線や多角形をクリッピングする機能があるかどうか返します。

public Boolean CanClip()

戻り値

チャートの描画キャンバスが線や多角形をクリッピングする機能があるかどうか返します。

解説

チャートの描画キャンバスが線や多角形をクリッピングする機能があるかどうか返します。

クリッピングとは開発者が指定した矩形や多角形の外側の描画を非表示にすることです。

チャートが3DのOpenGLで表示されている場合、このメソッドはfalseを返します。

TeeClipWhenPrinting定数がtrueでチャートがプリントされた場合、このメソッドはfalseを返します。

またはTeeClipWhenMetafiling定数がtrueでチャートがメタファイルイメージに変換される場合はfalseを返します。

参照：

ClipPointsプロパティ
TeeClipWhenPrinting定数
TeeClipWhenMetafiling定数
ClipCanvasグローバルプロシージャ
UnClipCanvasグローバルプロシージャ
ClipRoundRectangleグローバルプロシージャ
ClipPolygonグローバルプロシージャ

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


CheckZoomPanning

TeeChartプログラミングガイド

Steema.TeeChart.Chart.CheckZoomPanning メソッド

protected internal virtual Void CheckZoomPanning(MouseEventArgs e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Clone

Steema.TeeChart.Chart.Clone メソッド

public virtual Object Clone()

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


CountActiveSeries

TeeChartプログラミングガイド

Steema.TeeChart.Chart.CountActiveSeries メソッド

アクティブな（表示している）系列の数を返します。

public Int32 CountActiveSeries()

戻り値

アクティブな（表示している）系列の数。

解説

Activeプロパティがtrueに設定されている系列の数を返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Dispose

Steema.TeeChart.Chart.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


DoKeyDown

Steema.TeeChart.Chart.DoKeyDown メソッド

public abstract Void DoKeyDown(KeyEventArgs e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


DoMouseDown

Steema.TeeChart.Chart.DoMouseDown メソッド

public abstract Void DoMouseDown(Boolean IsDoubleClick,
     MouseEventArgs e,
     Keys Shift)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


DoMouseMove

TeeChartプログラミングガイド

Steema.TeeChart.Chart.DoMouseMove メソッド

public virtual Void DoMouseMove(Int32 x,
     Int32 y,
     Cursor& c)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


DoMouseUp

TeeChartプログラミングガイド

Steema.TeeChart.Chart.DoMouseUp メソッド

public virtual Void DoMouseUp(MouseEventArgs e)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


DoPanelPaint

Steema.TeeChart.Chart.DoPanelPaint メソッド

public Void DoPanelPaint(Graphics g,
     Rectangle r)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Draw メソッド

オーバーロードの一覧

指定したキャンバスにチャートを描画します。

public Void Draw(System.Drawing.Graphics)
public Void Draw(System.Drawing.Graphics, System.Boolean)
public Void Draw(System.Drawing.Graphics, System.Drawing.Rectangle)
public Void Draw(System.Drawing.Graphics, System.Drawing.Rectangle, System.Boolean)

解説

指定したキャンバスと領域にチャートを描画するために使用してください。

これは、チャートをカスタマイズして印刷する場合にも使用できます。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Draw メソッド

指定したキャンバスにチャートを描画します。
public Void Draw(Graphics g)

参照

Draw オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Draw メソッド

public Void Draw(Graphics g,
     Boolean noTools)

参照

Draw オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Draw メソッド

public Void Draw(Graphics g,
     Rectangle r)

参照

Draw オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Draw メソッド

public Void Draw(Graphics g,
     Rectangle r,
     Boolean noTools)

参照

Draw オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


FormattedLegend

TeeChartプログラミングガイド

Steema.TeeChart.Chart.FormattedLegend メソッド

凡例の位置に該当するテキストの文字列を返します。

public String FormattedLegend(Int32 seriesOrValueIndex)

解説

凡例の位置に該当するテキストの文字列を返します。
凡例の位置は、Legend.LegendStyleプロパティに依存します。LegendStyleがSeriesの場合、テキスト文字列はSeriesOrValueIndex番目のアクティブ系列のタイトルになります。LegendStyleがValuesの場合、テキスト文字列はチャートの最初のアクティブ系列の書式化されたSeriesOrValueIndex番目の値になります。LegendStyleがAutoで、チャートにアクティブ系列が1つしかない場合、LegendStyleはValuesになります。アクティブ系列が1つ以上ある場合、LegendStyleはSeriesになります。

値は、LegendTextStyleプロパティに従って書式化されます。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


FormattedValueLegend

Steema.TeeChart.Chart.FormattedValueLegend メソッド

指定した系列とポイントインデックスに該当する凡例の文字列を返します。
public String FormattedValueLegend(Series aSeries,
     Int32 valueIndex)

解説

このメソッドは、Chart.Legendで表示されている系列ポイント値の文字列を返します。
ValueIndexパラメーターはポイントインデックスです。
Legend.TextStyleプロパティや他のすべてのTChartLegendプロパティは、文字列を作成するために使用されます。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


FreeSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Chart.FreeSeriesColor メソッド

どの系列にも使用されていないデフォルトカラーパレットの色を返します。

public Color FreeSeriesColor(Boolean checkBackground)

解説

どの系列にも使用されていないデフォルトカラーパレットの色を返します。CheckBackGroundパラメーターは、チャートの背面の色も確認の対象とするかしないか制御します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


GetASeries

Steema.TeeChart.Chart.GetASeries メソッド

最初のアクティブな系列を返します。
public Series GetASeries()

解説

このメソッドは、チャートの最初のアクティブな系列を返します。チャートに系列がない場合あるいはアクティブ系列がない場合、このメソッドはnullを返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


GetAxisSeries

Steema.TeeChart.Chart.GetAxisSeries メソッド

指定した軸に属する最初の系列を返します。
public Series GetAxisSeries(Axis axis)

解説

指定した軸に属する最初の系列を返します。軸に属している系列がない場合、nullを返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


GetObjectData

TeeChartプログラミングガイド

Steema.TeeChart.Chart.GetObjectData メソッド

public virtual Void GetObjectData(SerializationInfo info,
     StreamingContext context)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


initVars

Steema.TeeChart.Chart.initVars メソッド

protected Void initVars()

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


InternalMinMax

Steema.TeeChart.Chart.InternalMinMax メソッド

protected internal Double InternalMinMax(Axis aAxis,
     Boolean isMin,
     Boolean isX)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


IsAxisVisible

Steema.TeeChart.Chart.IsAxisVisible メソッド

public Boolean IsAxisVisible(Axis a)

解説

このメソッドは、指定した軸パラメータが表示されているかどうか値を返します。

例

[C#]
例えば、右軸が表示されているかどうか以下のようにしてチェックできます。

Steema.TeeChart.Chart myChart = tChart1.Chart;
MessageBox.Show(myChart.IsAxisVisible(tChart1.Axes.Right).ToString());

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


IsFreeSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Chart.IsFreeSeriesColor メソッド

Colorパラメーターが他の系列で使用されていないかどうかを返します。

public Boolean IsFreeSeriesColor(Color color,
     Boolean checkBackground)

パラメーター

color
色
checkBackground
trueの場合、チャートの背面もチェックの対象に含めます。

解説

Colorパラメーターが他の系列で使用されていないかどうかを返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


IsValidDataSource

Steema.TeeChart.Chart.IsValidDataSource メソッド

protected internal Boolean IsValidDataSource(Series s,
     Object source)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MaxMarkWidth

TeeChartプログラミングガイド

Steema.TeeChart.Chart.MaxMarkWidth メソッド

すべてのアクティブな系列のマーカの最大幅をピクセル単位で返します。

public Int32 MaxMarkWidth()

解説

アクティブな系列のマーカの最大幅を返します。系列のマーカは表示されていなければなりません。
系列マーカの最大幅を適応させるためにチャートのマージンを調節する際に使用できます。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MaxTextWidth

TeeChartプログラミングガイド

Steema.TeeChart.Chart.MaxTextWidth メソッド

すべての系列ラベルの最大幅をピクセル単位で返します。

public Int32 MaxTextWidth()

解説

すべての系列ラベルの最大幅をピクセル単位で返します。
これはラベルを持つ系列にのみ適用されます。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MaxXValue

Steema.TeeChart.Chart.MaxXValue メソッド

系列のX値リストの最大値を返します。
public Double MaxXValue(Axis axis)

解説

系列のX値リストの最大値を返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MaxYValue

Steema.TeeChart.Chart.MaxYValue メソッド

現在の全系列のYポイント値の最大値を返します。
public Double MaxYValue(Axis axis)

解説

現在の全系列のYポイント値の最大値を返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.Chart.Metafile メソッド

オーバーロードの一覧

public Metafile Metafile(Steema.TeeChart.Chart, System.Int32, System.Int32)
public Metafile Metafile(System.IO.Stream, Steema.TeeChart.Chart, System.Int32, System.Int32, System.Drawing.Imaging.EmfType)
public Metafile Metafile(System.IO.Stream, Steema.TeeChart.Chart, System.Int32, System.Int32)
public Metafile Metafile(System.Drawing.Graphics, System.IO.Stream, Steema.TeeChart.Chart, System.Int32, System.Int32, System.Drawing.Imaging.EmfType)

解説

チャート内容を使用してメタファイルイメージを作成/返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.Chart.Metafile メソッド

public Metafile Metafile(Chart aChart,
     Int32 width,
     Int32 height)

参照

Metafile オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.Chart.Metafile メソッド

public Metafile Metafile(Stream stream,
     Chart aChart,
     Int32 width,
     Int32 height,
     EmfType type)

参照

Metafile オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.Chart.Metafile メソッド

public Metafile Metafile(Stream stream,
     Chart aChart,
     Int32 width,
     Int32 height)

参照

Metafile オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.Chart.Metafile メソッド

public Metafile Metafile(Graphics gRef,
     Stream stream,
     Chart aChart,
     Int32 width,
     Int32 height,
     EmfType type)

参照

Metafile オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MinXValue

Steema.TeeChart.Chart.MinXValue メソッド

系列のX値リストの最小値を返します。
public Double MinXValue(Axis axis)

解説

系列のX値リストの最小値を返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MinYValue

Steema.TeeChart.Chart.MinYValue メソッド

系列のY値リストの最小値を返します。
public Double MinYValue(Axis axis)

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MultiLineTextWidth

TeeChartプログラミングガイド

Steema.TeeChart.Chart.MultiLineTextWidth メソッド

オーバーロードの一覧

protected internal Int32 MultiLineTextWidth(System.String)
protected internal Int32 MultiLineTextWidth(System.String, System.Int32&)

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MultiLineTextWidth

TeeChartプログラミングガイド

Steema.TeeChart.Chart.MultiLineTextWidth メソッド

protected internal Int32 MultiLineTextWidth(String s)

参照

MultiLineTextWidth オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MultiLineTextWidth

TeeChartプログラミングガイド

Steema.TeeChart.Chart.MultiLineTextWidth メソッド

protected internal Int32 MultiLineTextWidth(String s,
     Int32& numLines)

参照

MultiLineTextWidth オーバーロードの一覧 | Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SeriesLegend

Steema.TeeChart.Chart.SeriesLegend メソッド

凡例のスタイルが｢Series｣の場合、凡例の｢ItemIndex｣位置に該当する系列を返します。｢OnlyActive｣パラメーターがfalseの場合、すべての系列を対象とします。
public Series SeriesLegend(Int32 itemIndex,
     Boolean onlyActive)

解説

凡例のスタイルが｢Series｣の場合、凡例の｢ItemIndex｣位置に該当する系列を返します。｢OnlyActive｣パラメーターがfalseの場合、すべての系列を対象とします。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SeriesTitleLegend

TeeChartプログラミングガイド

Steema.TeeChart.Chart.SeriesTitleLegend メソッド

系列タイトルの文字列を返します。

public String SeriesTitleLegend(Int32 seriesIndex,
     Boolean onlyActive)

解説

系列タイトルの文字列を返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ShouldSerializeListeners

Steema.TeeChart.Chart.ShouldSerializeListeners メソッド

protected abstract Boolean ShouldSerializeListeners()

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


UndoZoom

TeeChartプログラミングガイド

Steema.TeeChart.Chart.UndoZoom メソッド

public Void UndoZoom()

旧式

このメソッドの代わりにtChart1.Zoom.Undoメソッドを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart プロパティ

パブリック プロパティ

Aspect | チャートのビュー特性にアクセスします。
Axes | 軸オブジェクトのリストにアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartBounds | 読み込み専用。チャートの4サイド(左、上、右、下）を取得するために使用されます。
Export | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Footer | チャートの下部に描くテキストや書式特性を定義します。
Graphics3D | TeeChartの描画についてのプロパティやメソッドにアクセスします。
Header | チャートの上部に描くテキストや書式特性を定義します。
Height | チャートの高さをピクセル単位で設定します。
Import | チャートのインポートについてのプロパティやメソッドにアクセスします。
Item | デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
Legend | 凡例の特性にアクセスします。.
Listeners | ITeeEventListenerインターフェイスを実装するオブジェクトの配列リストを返します。
MaxZOrder | 実行時および読取専用。チャートの奥行きを系列の数で示します。Chart.View3DプロパティがTrueの場合、各系列はZオーダーを持ちます。系列のZオーダーは、系列が表示される際にZ軸に沿って順序を定義します。このプロパティは、すべてのアクティブな系列の中で最大のZオーダーです。系列の中には、同じZオーダーを共有するものもあります（積み重ねバー、積み重ね面、など）。
Page | チャートの複数ページ特性にアクセスします。
Panel | チャート背面の可視属性を設定します。
Panning | スクロールする方向を設定したり、スクロールを拒否します。
Parent | ChartのIChart親クラスを取得/設定します。
Printer | 印刷に関連したプロパティやメソッドにアクセスします。
SerializedTag | カスタムなタグオブジェクトを保持します。
Series | チャートに含まれる系列のリストにアクセスします。
SubFooter | フッターの上に表示されるテキストを定義します。
SubHeader | ヘッダーの下に表示されるテキストを定義します。
SubTitle |
Title |
Tools | チャート内に含まれているツールコンポーネントのコレクションです。
ToolTip | カーソルにテキストボックスを表示します。
Walls | チャートの左、下、背面の壁特性にアクセスします。
Width | チャートの幅をピクセル単位で設定します。
Zoom | チャートのズーム特性にアクセスします。

参照

Chart クラス | Steema.TeeChart 名前空間


Aspect

Steema.TeeChart.Chart.Aspect プロパティ

3Dビュー特性。
public Aspect Aspect {get;}

解説

チャートのビュー特性を設定するために使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Axes

Steema.TeeChart.Chart.Axes プロパティ

軸オブジェクトのリストにアクセスします。
public Axes Axes {get;}

解説

このプロパティは、5つの軸（上、左、右、下、奥）とカスタム軸にアクセスします。

例

[C#]
/全ての軸を非表示;
tChart.Axes.Visible = false;

//左軸のみ非表示;
tChart.Axes.Left.Visible = false;

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ChartBounds

TeeChartプログラミングガイド

Steema.TeeChart.Chart.ChartBounds プロパティ

読み込み専用。チャートの4サイド(左、上、右、下）を取得するために使用されます。

public Rectangle ChartBounds {get;}

読み込み専用

解説

チャートの4サイド(左、上、右、下）を取得するために使用されます。

例

[C#]

チャートと一緒にリサイズするので、チャートにオブジェクトを追加する際に使用することができます。

private void tChart3_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Pen.Color=Color.Yellow;
     g.Line(g.Chart.ChartBounds.Left+50,g.Chart.ChartBounds.Top+50,
     g.Chart.ChartBounds.Right-50,g.Chart.ChartBounds.Bottom-50);
}

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Export

Steema.TeeChart.Chart.Export プロパティ

チャートのエクスポートについてのプロパティやメソッドにアクセスします。
public Exports Export {get;}

解説

チャートのエクスポートについてのプロパティやメソッドにアクセスするために使用してください。

例

[C#]
TChart1.Export.SaveToBitmapFile("c:\temp\mychart.bmp")

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Footer

Steema.TeeChart.Chart.Footer プロパティ

チャートの下部に描くテキストや書式特性を定義します。
public Footer Footer {get;}

解説

チャートの下部に描くテキストや書式特性を定義します。Textプロパティを使用して、フッター行を入力したり、Visibleプロパティをtrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Graphics3D

Steema.TeeChart.Chart.Graphics3D プロパティ

TeeChartの描画についてのプロパティやメソッドにアクセスします。
public Graphics3D Graphics3D {get; set;}

解説

TeeChartの描画についてのプロパティやメソッドにアクセスするために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Chart.Graphics3D.TextOut(135,145,"My Text");
}

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Header

Steema.TeeChart.Chart.Header プロパティ

チャートの上部に描くテキストや書式特性を定義します。
public Header Header {get;}

解説

チャートの上部に描くテキストや書式特性を定義します。Textプロパティを使用して、ヘッダー行を入力したり、Visibleプロパティをtrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Height プロパティ

チャートの高さをピクセル単位で設定します。

public Int32 Height {get; set;}

解説

チャートの高さをピクセル単位で設定します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Import

Steema.TeeChart.Chart.Import プロパティ

チャートのインポートのプロパティやメソッドにアクセスします。
public Imports Import {get;}

解説

チャートのインポートのプロパティやメソッドにアクセスします。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Item

Steema.TeeChart.Chart.Item プロパティ

デフォルトインデックス ( 例：tChart1[0].Color=Color.Blue; は、tChart1.Series[0].Color=Color.Blue; と同等です )。
public Series Item(Int32 index) {get; set;}

解説

デフォルトインデックス ( 例：tChart1[0].Color=Color.Blue; は、tChart1.Series[0].Color=Color.Blue; と同等です )。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Legend

Steema.TeeChart.Chart.Legend プロパティ

凡例の特性についてアクセスします。
public Legend Legend {get;}

解説

系列と系列値のチャートのテキストと描画の属性を定義します。
Legendクラスは矩形を描き、チャートの各系列に対して（あるいは系列のポイントに対して）の系列の文字列を出力します（あるいはポイント）。
凡例を描くために使用するテキストを制御するには、Legend.LegendStyleプロパティやLegend.TextStyleプロパティを使用します。
凡例は、Legend.Alignmentプロパティを使用して、チャートの左・右・上・下に配置できます。
凡例を表示/非表示にする場合は、Legend.Visibleプロパティを使用します。
Invertedプロパティは、凡例の項目を逆から表示します。
Frame、Font、Colorプロパティを使用して、凡例の外観を変更することができます。
Legend.ColorWidthプロパティは、各項目のカラーボックス（シンボル）のパーセント幅を定義します。
Legend.FirstValueプロパティは、最初の凡例項目を描くためにどの系列（あるいは系列ポイント）を使用するかを制御します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Listeners

Steema.TeeChart.Chart.Listeners プロパティ

ITeeEventListenerインターフェイスを実装するオブジェクトの配列リストを返します。
public List<ITeeEventListener> Listeners {get; set;}

解説

ITeeEventListenerインターフェイスを実装するオブジェクトの配列リストを返します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


MaxZOrder

Steema.TeeChart.Chart.MaxZOrder プロパティ

実行時および読取専用。チャートの奥行きを系列の数で示します。Chart.View3DプロパティがTrueの場合、各系列はZオーダーを持ちます。系列のZオーダーは、系列が表示される際にZ軸に沿って順序を定義します。このプロパティは、すべてのアクティブな系列の中で最大のZオーダーです。系列の中には、同じZオーダーを共有するものもあります（積み重ねバー、積み重ね面、など）。
public Int32 MaxZOrder {get;}

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Page

Steema.TeeChart.Chart.Page プロパティ

チャートの複数ページを設定するために使用してください。
public Page Page {get;}

解説

チャートの複数ページを設定するために使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Panel

Steema.TeeChart.Chart.Panel プロパティ

チャートパネルの特性にアクセスします。
public Panel Panel {get;}

解説

チャートパネルの特性にアクセスします。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Panning

Steema.TeeChart.Chart.Panning プロパティ

スクロールする方向を設定したり、スクロールを拒否します。
public Scroll Panning {get;}

解説

スクロールする方向を設定したり、スクロールを拒否します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Parent

Steema.TeeChart.Chart.Parent プロパティ

ChartのIChart親クラスを取得/設定します。
public IChart Parent {get; set;}

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Printer

Steema.TeeChart.Chart.Printer プロパティ

印刷に関連するプロパティやメソッドにアクセスします。
public Printer Printer {get;}

解説

印刷に関連するプロパティやメソッドにアクセスします。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SerializedTag

Steema.TeeChart.Chart.SerializedTag プロパティ

カスタムなタグオブジェクトを保持します。
public Object SerializedTag {get; set;}

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.Chart.Series プロパティ

チャートに含まれる系列のリストにアクセスします。
public SeriesCollection Series {get;}

解説

チャートに含まれる系列のリストにアクセスします。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SubFooter

Steema.TeeChart.Chart.SubFooter プロパティ

フッターの上に表示するテキストについて定義します。
public Footer SubFooter {get;}

解説

チャートの下部で、フッターテキストの上に表示するテキストや書式特性について定義します。Textプロパティを使用して、サブフッター行を入力したり、Visibleプロパティをtrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更できます。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SubHeader

Steema.TeeChart.Chart.SubHeader プロパティ

ヘッダーの下に表示するテキストについて定義します。
public Header SubHeader {get;}

解説

チャートの上部で、ヘッダーテキストの下に表示するテキストや書式特性について定義します。Textプロパティを使用して、サブヘッダー行を入力したり、Visibleプロパティをtrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更できます。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


SubTitle

Steema.TeeChart.Chart.SubTitle プロパティ

public Header SubTitle {get;}

旧式

このプロパティの代わりに、SubHeaderプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Title

Steema.TeeChart.Chart.Title プロパティ

public Header Title {get;}

旧式

このプロパティの代わりに、Headerプロパティを使用してください。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Tools

Steema.TeeChart.Chart.Tools プロパティ

チャート内に含まれているツールコンポーネントのコレクションです。
public ToolsCollection Tools {get;}

解説

チャートにリンクされているツールのリストです。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


ToolTip

Steema.TeeChart.Chart.ToolTip プロパティ

カーソルにテキストボックスを表示します。
public ChartToolTip ToolTip {get;}

解説

カーソルにテキストボックスを表示します。

例

[C#]

この例は、ツールチップにすべてのY値の合計を表示します。

tChart1[0].Chart.ToolTip.Text="Value " + tChart1[0].YValues.Total.ToString();
tChart1[0].Chart.ToolTip.Show();
tChart1[0].Chart.ToolTip.InitialDelay=50;

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Walls

Steema.TeeChart.Chart.Walls プロパティ

チャートの左、下、背面の壁の特性にアクセスします。
public Walls Walls {get;}

解説

チャートの左、下、背面の壁の特性にアクセスするために使用してください。

例

[C#]

tChart1.Walls.Visible = false;

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Chart.Width プロパティ

チャートの幅をピクセル単位で設定します。
public Int32 Width {get; set;}

解説

チャートの幅をピクセル単位で設定します。

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Zoom

Steema.TeeChart.Chart.Zoom プロパティ

チャートのズームの特性にアクセスします。
public Zoom Zoom {get;}

解説

チャートのズームの特性にアクセスします。

例

[C#]
tChart1.Zoom.Enable = true;

参照

Chart クラス | Chart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart.ChartToolTip

TeeChartプログラミングガイド

Steema.TeeChart.Chart.ChartToolTip クラス

ツールチップ。

この型のすべてのメンバの一覧については、ChartToolTip メンバを参照してください。

System.Object
public class ChartToolTip : Object

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ChartToolTip メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart.ChartToolTip 全メンバ

ChartToolTip 概要

パブリック フィールド

Text

パブリック メソッド

Hide | ツールチップを非表示します。
Show | ツールチップを表示します。

パブリック プロパティ

AutoPopDelay | ツールチップを表示するテキストと時間を設定します。
InitialDelay | ツールチップを表示する前のタイムラグを設定します。

コンストラクタ

Steema.TeeChart.Chart.ChartToolTip..ctor

参照

ChartToolTip クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Chart.ChartToolTip フィールド

パブリック フィールド

Text

参照

ChartToolTip クラス | Steema.TeeChart 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Chart+ChartToolTip.Text フィールド

public String Text

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart.ChartToolTip メソッド

Pパブリック メソッド

Hide | ツールチップを非表示にします。
Show | ツールチップを表示します。

参照

ChartToolTip クラス | Steema.TeeChart 名前空間


Hide

TeeChartプログラミングガイド

Steema.TeeChart.Chart+ChartToolTip.Hide メソッド

ツールチップを非表示にします。

public Void Hide()

解説

ツールチップを非表示にするために使用してください。このプロパティは、Visibleプロパティをfalseに設定します。

非表示にしても、プロパティとメソッドは使用できます。

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


Show

TeeChartプログラミングガイド

Steema.TeeChart.Chart+ChartToolTip.Show メソッド

ツールチップを表示します。

public Void Show()

解説

以前に非表示に設定したツールチップを表示するために、このメソッドを使用してください。

このメソッドはVisibleプロパティをtrueに設定します。

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Chart.ChartToolTip プロパティ

パブリック プロパティ

AutoPopDelay | ツールチップを表示するテキストと時間を設定します。
InitialDelay | ツールチップを表示する前のタイムラグを設定します。

参照

ChartToolTip クラス | Steema.TeeChart 名前空間


AutoPopDelay

Steema.TeeChart.Chart+ChartToolTip.AutoPopDelay プロパティ

ツールチップを表示するテキストと時間を設定します。
public Int32 AutoPopDelay {get; set;}

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


InitialDelay

Steema.TeeChart.Chart+ChartToolTip.InitialDelay プロパティ

ツールチップを表示する前のタイムラグを設定します。
public Int32 InitialDelay {get; set;}

解説

ツールチップを表示する前のタイムラグを設定します。

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


ChartToolTip コンストラクタ

Steema.TeeChart.Chart+ChartToolTip コンストラクタ

public Chart+ChartToolTip(Chart c)

参照

ChartToolTip クラス | ChartToolTip メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartClickedPart

Steema.TeeChart.ChartClickedPart 値型

この型のすべてのメンバの一覧については、ChartClickedPart メンバを参照してください。

System.Object
System.ValueType
public sealed struct ChartClickedPart : ValueType

参照

ChartClickedPart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartClickedPart 全メンバ

ChartClickedPart 概要

パブリック フィールド

AAxis
ASeries
Part
PointIndex

参照

ChartClickedPart 構造体 | Steema.TeeChart 名前空間


Steema.TeeChart.ChartClickedPart フィールド

パブリック フィールド

AAxis
ASeries
Part
PointIndex

参照

ChartClickedPart 構造体 | Steema.TeeChart 名前空間


AAxis

Steema.TeeChart.ChartClickedPart.AAxis フィールド

public Axis AAxis

参照

ChartClickedPart 構造体 | ChartClickedPart メンバ | Steema.TeeChart 名前空間


ASeries

Steema.TeeChart.ChartClickedPart.ASeries フィールド

public Series ASeries

参照

ChartClickedPart 構造体 | ChartClickedPart メンバ | Steema.TeeChart 名前空間


Part

Steema.TeeChart.ChartClickedPart.Part フィールド

public ChartClickedPartStyle Part

参照

ChartClickedPart 構造体 | ChartClickedPart メンバ | Steema.TeeChart 名前空間


PointIndex

Steema.TeeChart.ChartClickedPart.PointIndex フィールド

public Int32 PointIndex

参照

ChartClickedPart 構造体 | ChartClickedPart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartClickedPartStyle

Steema.TeeChart.ChartClickedPartStyle 列挙体

[Serializable]
public sealed enum ChartClickedPartStyle : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None |
Legend |
Axis |
Series |
Header |
Foot |
ChartRect |
SeriesMarks |
SubHeader |
SubFoot |
AxisTitle |

参照

Steema.TeeChart 名前空間


Steema.TeeChart.ChartListBox

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox クラス

ChartListBoxコンポーネントクラス。

この型のすべてのメンバの一覧については、ChartListBox メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ListControl
System.Windows.Forms.ListBox
public class ChartListBox : ListBox , IComponent, IDisposable
, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject
, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit
, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke
, IWin32Window

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ChartListBox メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartListBox 全メンバ

ChartListBox 概要

コンストラクタ

Constructor オーバーロード。Windows.Formsクラスのコンポジションデザイナーサポートのために必要です。

パブリック イベント

ChangeActive
ChangeColor
ChangeOrder
EditSeries
OtherItemsChange
RefreshEvent
RemovedSeries

パブリック メソッド

ChangeTypeSeries | 指定したインデックスの系列の系列型を変更します。
ClearItems |
CloneSeries | 新しい系列にSeries(Seriesindex)を複製します。
DeleteSeries | 現在選択されている系列を削除するかどうか設定します。削除された場合、trueを返します。
DoRefresh |
FillSeries | チャートの系列をTChartListboxに出力します。
HideEditor |
SelectAll | TChartListBoxにあるすべての系列を選択します。
Series | 指定したインデックスの系列にアクセスします。
ShowEditor |
TeeEvent |

パブリック プロパティ

AllowAddSeries | 系列の追加を有効/無効にします。
AllowDeleteSeries | 系列の削除を有効/無効にします。
AskDelete | 系列を削除するかどうかを「はい/いいえ」で確認します。
Chart | TChartListboxに接続するチャートを設定します。
CheckStyle | 各リスト項目にチェックボックスまたはラジオボタンを表示します。
DrawMode |
EnableChangeColor | ChartListBox内での系列色の変更を有効/無効にします。
EnableChangeType | ChartListBox内での系列型の変更を有効/無効にします。
EnableDragSeries | ChartListBox内での系列のドラッグを有効/無効にします。
Item |
ItemHeight | StyleプロパティがOwnerDrawFixedの場合、リストボックスの項目の高さを制御します。
Items | 項目を追加、挿入、削除、移動するために使用してください。
MultiSelect |
OtherItems | ChartListboxの内容を制御する外部コントロールを更新します。
SelectedSeries | 選択された系列の系列リストのインデックス値を取得/設定します。
SelectionMode |
SeriesGroup | アクティブな系列グループを取得/設定します。
ShowActiveCheck | 系列リストに｢アクティブ系列｣のチェックボックスを表示/非表示にします。
ShowSeriesColor | 系列リストに「系列色」ボックスを表示/非表示にします。
ShowSeriesIcon | 系列リストに｢系列型アイコン｣を表示/非表示にします。
ShowSeriesTitle | 系列リストに｢系列タイトル｣を表示/非表示にします。

プロテクト メソッド

OnChangeActive
OnChangeColor
OnChangeOrder
OnClick
OnDoubleClick
OnDragDrop
OnDragOver
OnDrawItem
OnKeyUp
OnMouseDown
OnMouseMove
OnMouseUp
OnOtherItemsChange
OnRefresh
OnRemovedSeries

参照

ChartListBox クラス | Steema.TeeChart 名前空間


ChartListBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox コンストラクタ

オーバーロードの一覧

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public ChartListBox(System.ComponentModel.IContainer)

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public ChartListBox()

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ChartListBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox コンストラクタ

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public ChartListBox(IContainer container)

参照

ChartListBox コンストラクタのオーバーロードの一覧 | ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ChartListBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox コンストラクタ

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public ChartListBox()

参照

ChartListBox コンストラクタのオーバーロードの一覧 | ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartListBox イベント

パブリック イベント

ChangeActive
ChangeColor
ChangeOrder
EditSeries
OtherItemsChange
RefreshEvent
RemovedSeries

参照

ChartListBox クラス | Steema.TeeChart 名前空間


ChangeActive

Steema.TeeChart.ChartListBox.ChangeActive イベント

public ChangeActiveEventHandler  ChangeActive

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ChangeColor

Steema.TeeChart.ChartListBox.ChangeColor イベント

public ChangeColorEventHandler  ChangeColor

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ChangeOrder

Steema.TeeChart.ChartListBox.ChangeOrder イベント

public ChangeOrderEventHandler  ChangeOrder

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


EditSeries

Steema.TeeChart.ChartListBox.EditSeries イベント

public EditSeriesEventHandler  EditSeries

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OtherItemsChange

Steema.TeeChart.ChartListBox.OtherItemsChange イベント

public OtherItemsChangeEventHandler  OtherItemsChange

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


RefreshEvent

Steema.TeeChart.ChartListBox.RefreshEvent イベント

public RefreshEventHandler  RefreshEvent

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


RemovedSeries

Steema.TeeChart.ChartListBox.RemovedSeries イベント

public RemovedSeriesEventHandler  RemovedSeries

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartListBox メソッド

パブリック メソッド

ChangeTypeSeries | 指定したインデックスの系列の系列型を変更します。
ClearItems |
CloneSeries | 新しい系列にSeries(Seriesindex)を複製します。
DeleteSeries | 現在選択されている系列を削除するかどうか設定します。削除された場合、trueを返します。
DoRefresh |
FillSeries | チャートの系列をTChartListboxに出力します。
HideEditor |
SelectAll | TChartListBoxにあるすべての系列を選択します。
Series | 指定したインデックスの系列にアクセスします。
ShowEditor |
TeeEvent |

プロテクト メソッド

OnChangeActive
OnChangeColor
OnChangeOrder
OnClick
OnDoubleClick
OnDragDrop
OnDragOver
OnDrawItem
OnKeyUp
OnMouseDown
OnMouseMove
OnMouseUp
OnOtherItemsChange
OnRefresh
OnRemovedSeries

参照

ChartListBox クラス | Steema.TeeChart 名前空間


ChangeTypeSeries

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ChangeTypeSeries メソッド

指定したインデックスの系列の系列型を変更します。

public Void ChangeTypeSeries()

解説

指定したインデックスの系列の系列型を変更します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ClearItems

Steema.TeeChart.ChartListBox.ClearItems メソッド

public Void ClearItems()

解説

TChartListboxから系列アイテムを削除します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


CloneSeries

Steema.TeeChart.ChartListBox.CloneSeries メソッド

新しい系列にSeries(Seriesindex)を複製します。
public Series CloneSeries()

解説

選択された系列を新しい系列として複製します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


DeleteSeries

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.DeleteSeries メソッド

現在選択されている系列を削除するかどうか設定します。削除された場合、trueを返します。

public Boolean DeleteSeries()

解説

系列のチャートリストから指定されたASeriesパラメーターを削除します（破棄はしません）。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


DoRefresh

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.DoRefresh メソッド

public Void DoRefresh()

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


FillSeries

Steema.TeeChart.ChartListBox.FillSeries メソッド

チャートの系列をTChartListboxに出力します。
public Void FillSeries(Series oldSeries)

解説

チャートの系列をTChartListboxに出力します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


HideEditor

Steema.TeeChart.ChartListBox.HideEditor メソッド

public Void HideEditor()

解説

系列タイトルを変更するために使用するインラインエディタボックスを無効にします。

デフォルトでは、リストボックスの項目上でF2キーを押すとインラインエディタボックスが表示されます。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnChangeActive

Steema.TeeChart.ChartListBox.OnChangeActive メソッド

protected abstract Void OnChangeActive(NotifySeriesEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnChangeColor

Steema.TeeChart.ChartListBox.OnChangeColor メソッド

protected abstract Void OnChangeColor(NotifySeriesEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnChangeOrder

Steema.TeeChart.ChartListBox.OnChangeOrder メソッド

protected abstract Void OnChangeOrder(ChangeOrderEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnClick

Steema.TeeChart.ChartListBox.OnClick メソッド

protected abstract Void OnClick(EventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnDoubleClick

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.OnDoubleClick メソッド

protected virtual Void OnDoubleClick(EventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnDragDrop

Steema.TeeChart.ChartListBox.OnDragDrop メソッド

protected abstract Void OnDragDrop(DragEventArgs drgevent)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnDragOver

Steema.TeeChart.ChartListBox.OnDragOver メソッド

protected abstract Void OnDragOver(DragEventArgs drgevent)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnDrawItem

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.OnDrawItem メソッド

protected virtual Void OnDrawItem(DrawItemEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnKeyUp

Steema.TeeChart.ChartListBox.OnKeyUp メソッド

protected abstract Void OnKeyUp(KeyEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnMouseDown

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.OnMouseDown メソッド

protected virtual Void OnMouseDown(MouseEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnMouseMove

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.OnMouseMove メソッド

protected virtual Void OnMouseMove(MouseEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnMouseUp

Steema.TeeChart.ChartListBox.OnMouseUp メソッド

protected abstract Void OnMouseUp(MouseEventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnOtherItemsChange

Steema.TeeChart.ChartListBox.OnOtherItemsChange メソッド

protected abstract Void OnOtherItemsChange(EventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnRefresh

Steema.TeeChart.ChartListBox.OnRefresh メソッド

protected abstract Void OnRefresh(EventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OnRemovedSeries

Steema.TeeChart.ChartListBox.OnRemovedSeries メソッド

protected abstract Void OnRemovedSeries(EventArgs e)

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


SelectAll

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.SelectAll メソッド

TChartListBoxにあるすべての系列を選択します。

public Void SelectAll()

解説

TChartListBoxにあるすべての系列を選択します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.ChartListBox.Series メソッド

指定したインデックスの系列にアクセスします。
public Series Series(Int32 index)

解説

指定したインデックスの系列型を返します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ShowEditor

Steema.TeeChart.ChartListBox.ShowEditor メソッド

public Void ShowEditor()

解説

系列タイトルを変更するために使用するインラインエディタボックスを表示します。

デフォルトでは、リストボックスの項目上でF2キーを押すとインラインエディタボックスが表示されます。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


TeeEvent

Steema.TeeChart.ChartListBox.TeeEvent メソッド

public virtual Void TeeEvent(TeeEvent e)

解説

内部使用。
ITeeEventListenerのイベントを提供します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartListBox プロパティ

パブリック プロパティ

AllowAddSeries | 系列の追加を有効/無効にします。
AllowDeleteSeries | 系列の削除を有効/無効にします。
AskDelete | 系列を削除するかどうかを「はい/いいえ」で確認します。
Chart | TChartListboxに接続するチャートを設定します。
CheckStyle | 各リスト項目にチェックボックスまたはラジオボタンを表示します。
DrawMode |
EnableChangeColor | ChartListBox内での系列色の変更を有効/無効にします。
EnableChangeType | ChartListBox内での系列型の変更を有効/無効にします。
EnableDragSeries | ChartListBox内での系列のドラッグを有効/無効にします。
Item |
ItemHeight | StyleプロパティがOwnerDrawFixedの場合、リストボックスの項目の高さを制御します。
Items | 項目を追加、挿入、削除、移動するために使用してください。
MultiSelect |
OtherItems | ChartListboxの内容を制御する外部コントロールを更新します。
SelectedSeries | 選択された系列の系列リストのインデックス値を取得/設定します。
SelectionMode |
SeriesGroup | アクティブな系列グループを取得/設定します。
ShowActiveCheck | 系列リストに｢アクティブ系列｣のチェックボックスを表示/非表示にします。
ShowSeriesColor | 系列リストに「系列色」ボックスを表示/非表示にします。
ShowSeriesIcon | 系列リストに｢系列型アイコン｣を表示/非表示にします。
ShowSeriesTitle | 系列リストに｢系列タイトル｣を表示/非表示にします。

参照

ChartListBox クラス | Steema.TeeChart 名前空間


AllowAddSeries

Steema.TeeChart.ChartListBox.AllowAddSeries プロパティ

系列の追加を有効/無効にします。

public Boolean AllowAddSeries {get; set;}

解説

系列の追加を有効/無効にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


AllowDeleteSeries

Steema.TeeChart.ChartListBox.AllowDeleteSeries プロパティ

系列の削除を有効/無効にします。

public Boolean AllowDeleteSeries {get; set;}

解説

系列の削除を有効/無効にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


AskDelete

Steema.TeeChart.ChartListBox.AskDelete プロパティ

系列を削除するかどうかを「はい/いいえ」で確認します。

public Boolean AskDelete {get; set;}

解説

系列を削除するかどうかを「はい/いいえ」で確認します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Chart

Steema.TeeChart.ChartListBox.Chart プロパティ

TChartListboxに接続するチャートを設定します。
public TChart Chart {get; set;}

解説

TChartListboxに接続するチャートを設定します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


CheckStyle

Steema.TeeChart.ChartListBox.CheckStyle プロパティ

各リスト項目にチェックボックスまたはラジオボタンを表示します。

public CheckBoxesStyle CheckStyle {get; set;}

解説

デフォルト値：cbsCheck

各リスト項目にチェックボックスまたはラジオボタンを表示します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


DrawMode

Steema.TeeChart.ChartListBox.DrawMode プロパティ

public DrawMode DrawMode {get; set;}

解説

デフォルト値：OwnerDrawFixed

コントロールのエレメントをどのように描画するか指定します。これは、System.Windows.Forms.DrawModeを使用します。
3つのオプションがあります：
Normal;
OwnerDrawFixed; // デフォルト
OwnerDrawVariable;

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


EnableChangeColor

Steema.TeeChart.ChartListBox.EnableChangeColor プロパティ

ChartListBox内での系列色の変更を有効/無効にします。

public Boolean EnableChangeColor {get; set;}

解説

ChartListBox内での系列色の変更を有効/無効にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


EnableChangeType

Steema.TeeChart.ChartListBox.EnableChangeType プロパティ

ChartListBox内での系列型の変更を有効/無効にします。

public Boolean EnableChangeType {get; set;}

解説

ChartListBox内での系列型の変更を有効/無効にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


EnableDragSeries

Steema.TeeChart.ChartListBox.EnableDragSeries プロパティ

ChartListBox内での系列のドラッグを有効/無効にします。

public Boolean EnableDragSeries {get; set;}

解説

ChartListBox内での系列のドラッグを有効/無効にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Item

Steema.TeeChart.ChartListBox.Item プロパティ

public Series Item(Int32 index) {get; set;}

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ItemHeight

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ItemHeight プロパティ

StyleプロパティがOwnerDrawFixedの場合、リストボックスの項目の高さを制御します。

public Int32 ItemHeight {get; set;}

解説

StyleプロパティがOwnerDrawFixedの場合、リストボックスの項目の高さを制御します。またリストボックスの高さにも影響します。IntegralHeightプロパティがtrueの場合、リストボックスの高さは常にItemHeight値のインクリメントになります。

StyleプロパティがStandardあるいはOwnerDrawVariableの場合、ItemHeightの値は無効になります。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Items

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.Items プロパティ

項目を追加、挿入、削除、移動するために使用してください。

public ObjectCollection Items {get;}

解説

項目を追加、挿入、削除、移動するために使用してください。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


MultiSelect

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.MultiSelect プロパティ

public Boolean MultiSelect {get; set;}

解説

ChartListBoxで1項目以上選択できるかどうかを指定します。このプロパティがtrueの場合、ChartListBoxで複数項目を選択できます。SelCountプロパティは選択した項目の数を示します。このプロパティがfalseの場合、ItemIndexプロパティで指定た1項目だけが選択されます。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


OtherItems

Steema.TeeChart.ChartListBox.OtherItems プロパティ

ChartListboxの内容を制御する外部コントロールを更新します。

public ObjectCollection OtherItems {get; set;}

解説

ChartListboxの内容を制御する外部コントロールを更新します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


SelectedSeries

Steema.TeeChart.ChartListBox.SelectedSeries プロパティ

選択された系列の系列リストのインデックス値を取得/設定します。
public Series SelectedSeries {get; set;}

解説

選択された系列の系列リストのインデックス値を取得/設定します。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


SelectionMode

Steema.TeeChart.ChartListBox.SelectionMode プロパティ

public SelectionMode SelectionMode {get; set;}

解説

デフォルト値：MultiExtended

リストボックスの選択モードを指定します。
4つのオプションがあります。
None;
MultiSimple
MultiExtended
One

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


SeriesGroup

Steema.TeeChart.ChartListBox.SeriesGroup プロパティ

アクティブな系列グループを取得/設定します。
public SeriesGroup SeriesGroup {get; set;}

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ShowActiveCheck

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ShowActiveCheck プロパティ

系列リストに｢アクティブ系列｣のチェックボックスを表示/非表示にします。

public Boolean ShowActiveCheck {get; set;}

解説

デフォルト値：true

系列リストに「アクティブ系列」のチェックボックスを表示/非表示にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ShowSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ShowSeriesColor プロパティ

系列リストに「系列色」ボックスを表示/非表示にします。

public Boolean ShowSeriesColor {get; set;}

解説

デフォルト値：true

系列リストに「系列色」ボックスを表示/非表示にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ShowSeriesIcon

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ShowSeriesIcon プロパティ

系列リストに｢系列型アイコン｣を表示/非表示にします。

public Boolean ShowSeriesIcon {get; set;}

解説

デフォルト値：true

系列リストに「系列型アイコン」を表示/非表示にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


ShowSeriesTitle

TeeChartプログラミングガイド

Steema.TeeChart.ChartListBox.ShowSeriesTitle プロパティ

系列リストに｢系列タイトル｣を表示/非表示にします。

public Boolean ShowSeriesTitle {get; set;}

解説

デフォルト値：true

系列リストに｢系列タイトル｣を表示/非表示にします。

参照

ChartListBox クラス | ChartListBox メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartPrintEventHandler

TeeChartプログラミングガイド

Steema.TeeChart.ChartPrintEventHandler デリゲート

チャート印刷のイベントハンドラ

public virtual Void Invoke(Object sender,
     PrintPageEventArgs e)

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SteemaTeeChartChartPrintEve 名前空間


Steema.TeeChart.ChartPrintJob

TeeChartプログラミングガイド

Steema.TeeChart.ChartPrintJob クラス

このクラスは、印刷時にチャートのアクセスを提供します。

この型のすべてのメンバの一覧については、ChartPrintJob メンバを参照してください。

System.Object
public class ChartPrintJob : Object

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ChartPrintJob メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartPrintJob 全メンバ

ChartPrintJob 概要

コンストラクタ

Constructor

パブリック プロパティ

Chart
ChartRect

参照

ChartPrintJob クラス | Steema.TeeChart 名前空間


ChartPrintJob コンストラクタ

Steema.TeeChart.ChartPrintJob コンストラクタ

public ChartPrintJob(Chart c,
     Rectangle r)

参照

ChartPrintJob クラス | ChartPrintJob メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ChartPrintJob プロパティ

パブリック プロパティ

Chart
ChartRect

参照

ChartPrintJob クラス | Steema.TeeChart 名前空間


Chart

Steema.TeeChart.ChartPrintJob.Chart プロパティ

public Chart Chart {get;}

解説

印刷時にチャートを返します。

参照

ChartPrintJob クラス | ChartPrintJob メンバ | Steema.TeeChart 名前空間


ChartRect

Steema.TeeChart.ChartPrintJob.ChartRect プロパティ

public Rectangle ChartRect {get;}

解説

印刷のマージンが適用された後の印刷矩形座標を返します。座標は、プリンタデバイスの単位（プリンタのピクセル）で表されます。

参照

ChartPrintJob クラス | ChartPrintJob メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.CheckBoxesStyle

Steema.TeeChart.CheckBoxesStyle 列挙体

凡例項目のインタラクティブボックスの外観を定義します。

[Serializable]
public sealed enum CheckBoxesStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Check | ボックスをチェックボックスで表示します。
Radio | ボックスをラジオボタンで表示します。

参照

Steema.TeeChart 名前空間 | CheckStyle


Steema.TeeChart.Commander

TeeChartプログラミングガイド

Steema.TeeChart.Commander クラス

Commanderコントロール。

この型のすべてのメンバの一覧については、Commander メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ToolBar
public class Commander : ToolBar , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Commander メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander 全メンバ

Commander 概要

コンストラクタ

Constructor

パブリック イベント

SetLabel

パブリック メソッド

TeeEvent 内部使用。ITeeEventListenerのイベントを提供します。

パブリック プロパティ

Buttons |
Chart |
Editor |
LabelText | TeeCommanderナビゲーターバーのラベルテキストにアクセスします。
LabelValues | TeeCommanderのステータスメッセージの表示を有効/無効にします。

プロテクト メソッド

Dispose | 使用したリソースを削除します。
OnSetLabel |

参照

Commander クラス | Steema.TeeChart 名前空間


Commander コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Commander コンストラクタ

public Commander()

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander イベント

パブリック イベント

SetLabel

参照

Commander クラス | Steema.TeeChart 名前空間


SetLabel

Steema.TeeChart.Commander.SetLabel イベント

public SetLabelEventHandler  SetLabel

解説

このイベントは、TeeCommanderがラベル（ヘルプテキスト）を表示する時に発生します。

TeeCommanderのボタンをクリックすると、ラベルは更新されます。

ラベルテキストを取得したり、TeeCommanderパネル以外の場所にラベルテキストを表示するために使用できます。

LabelTextプロパティやLabelValuesプロパティを参照してください。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander メソッド

パブリック メソッド

TeeEvent 内部使用。ITeeEventListenerのイベントを提供します。

プロテクト メソッド

Dispose | 使用したリソースを削除します。
OnSetLabel |

参照

Commander クラス | Steema.TeeChart 名前空間


Dispose

Steema.TeeChart.Commander.Dispose メソッド

使用したリソースを削除します。
protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


OnSetLabel

TeeChartプログラミングガイド

Steema.TeeChart.Commander.OnSetLabel メソッド

protected internal Void OnSetLabel(Object sender,
     String statusText)

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


TeeEvent

Steema.TeeChart.Commander.TeeEvent メソッド

内部使用。ITeeEventListenerのイベントを提供します。
public virtual Void TeeEvent(TeeEvent e)

解説

内部使用。
ITeeEventListenerのイベントを提供します。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander プロパティ

パブリック プロパティ

Buttons |
Chart |
Editor |
LabelText | TeeCommanderナビゲーターバーのラベルテキストにアクセスします。
LabelValues | TeeCommanderのステータスメッセージの表示を有効/無効にします。

参照

Commander クラス | Steema.TeeChart 名前空間


Buttons

Steema.TeeChart.Commander.Buttons プロパティ

public ToolBarButton[] Buttons {get; set;}

解説

TeeCommanderコントロール上に表示するボタンの配列を定義します。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Chart

Steema.TeeChart.Commander.Chart プロパティ

public TChart Chart {get; set;}

解説

TCustomPanel（TChartあるいはTDraw3D）をTeeCommanderコンポーネントに接続します。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Editor

Steema.TeeChart.Commander.Editor プロパティ

public Editor Editor {get; set;}

解説

TeeCommanderのエディタ特性を定義するTeeChartエディタを選択します。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


LabelText

TeeChartプログラミングガイド

Steema.TeeChart.Commander.LabelText プロパティ

TeeCommanderナビゲーターバーのラベルテキストにアクセスします。

public String LabelText {get; set;}

解説

TeeCommanderナビゲーターバーのラベルテキストを返します。異なるTeeCommanderモードのデフォルトテキストは以下のようになります。

3D：度数単位の仰角と回転。
Drag：ピクセル単位の水平および垂直のオフセット。
Zoom：チャート全体のズームパーセント。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


LabelValues

TeeChartプログラミングガイド

Steema.TeeChart.Commander.LabelValues プロパティ

TeeCommanderのステータスメッセージの表示を有効/無効にします。

public Boolean LabelValues {get; set;}

解説

デフォルト値：true

TeeCommanderのステータスメッセージの表示を有効/無効にします。例：回転や仰角の角度。

参照

Commander クラス | Commander メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander.SetLabelEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Commander.SetLabelEventArgs クラス

SetLabelイベントのデータを提供します。

この型のすべてのメンバの一覧については、SetLabelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class SetLabelEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SetLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander.SetLabelEventArgs 全メンバ

SetLabelEventArgs 概要

パブリック プロパティ

StatusMsg

コンストラクタ

Steema.TeeChart.Commander.SetLabelEventArgs

参照

SetLabelEventArgs クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Commander.SetLabelEventArgs プロパティ

パブリック プロパティ

StatusMsg

参照

SetLabelEventArgs クラス | Steema.TeeChart 名前空間


StatusMsg

TeeChartプログラミングガイド

Steema.TeeChart.Commander+SetLabelEventArgs.StatusMsg プロパティ

public String StatusMsg {get;}

参照

SetLabelEventArgs クラス | SetLabelEventArgs メンバ | Steema.TeeChart 名前空間


SetLabelEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Commander+SetLabelEventArgs コンストラクタ

public Commander+SetLabelEventArgs(String statusText)

参照

SetLabelEventArgs クラス | SetLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Commander.SetLabelEventHandler

Steema.TeeChart.Commander.SetLabelEventHandler デリゲート

CommanderのSetLabelのイベントハンドラ。
public delegate SetLabelEventHandler (Object sender,
     SetLabelEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.CustomAxes

TeeChartプログラミングガイド

Steema.TeeChart.CustomAxes クラス

カスタムな系列リストにアクセスするために使用されます。

この型のすべてのメンバの一覧については、CustomAxes メンバを参照してください。

System.Object
System.Collections.CollectionBase
public class CustomAxes : CollectionBase , IList, ICollection
, IEnumerable

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

CustomAxes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.CustomAxes 全メンバ

CustomAxes 概要

コンストラクタ

Constructor

パブリック メソッド

Add | カスタム軸を追加します。
Clear | 全ての系列を消去（および任意で破棄）します。
IndexOf |
New | チャートにカスタム軸を作成/追加します。
Remove | 指定したインデックスのカスタム軸を削除します。
RemoveAll | すべてのカスタム軸を削除します。

パブリック プロパティ

Item

プロテクト メソッド

OnInsertComplete

参照

CustomAxes クラス | Steema.TeeChart 名前空間


CustomAxes コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.CustomAxes コンストラクタ

public CustomAxes()

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.CustomAxes メソッド

パブリック メソッド

Add | カスタム軸を追加します。
Clear | 全ての系列を消去（および任意で破棄）します。
IndexOf |
New | チャートにカスタム軸を作成/追加します。
Remove | 指定したインデックスのカスタム軸を削除します。
RemoveAll | すべてのカスタム軸を削除します。

プロテクト メソッド

OnInsertComplete

参照

CustomAxes クラス | Steema.TeeChart 名前空間


Add

Steema.TeeChart.CustomAxes.Add メソッド

カスタム軸を追加します。
public Axis Add(Axis axis)

解説

カスタム軸を追加します。垂直軸を追加する場合、Horizontal変数はfalseに設定してください。新しい軸を系列に接続する場合は、系列のVerticalAxisCustom/HorizontalAxisCustomプロパティを使用してください。

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.CustomAxes.Clear メソッド

オーバーロードの一覧

全ての系列を消去（および任意で破棄）します。

public Void Clear(System.Boolean)

全ての系列を消去および破棄します。

public Void Clear()

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.CustomAxes.Clear メソッド

全ての系列を消去（および任意で破棄）します。
public Void Clear(Boolean dispose)

参照

Clear オーバーロードの一覧 | CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.CustomAxes.Clear メソッド

全ての系列を消去および破棄します。
public Void Clear()

参照

Clear オーバーロードの一覧 | CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


IndexOf

Steema.TeeChart.CustomAxes.IndexOf メソッド

public Int32 IndexOf(Axis a)

解説

指定した値を持つポイントのインデックスを返します。

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


New

Steema.TeeChart.CustomAxes.New メソッド

チャートにカスタム軸を作成/追加します。
public Axis New()

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


OnInsertComplete

TeeChartプログラミングガイド

Steema.TeeChart.CustomAxes.OnInsertComplete メソッド

protected virtual Void OnInsertComplete(Int32 index,
     Object value)

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Remove

Steema.TeeChart.CustomAxes.Remove メソッド

指定したインデックスのカスタム軸を削除します。
public Void Remove(Axis a)

解説

指定したインデックスのカスタム軸を削除します。軸に関連している系列はデフォルトの軸に設定されます。

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


RemoveAll

TeeChartプログラミングガイド

Steema.TeeChart.CustomAxes.RemoveAll メソッド

すべてのカスタム軸を削除します。

public Void RemoveAll()

解説

すべてのカスタム軸を削除します。軸に関連してる系列はデフォルトの軸に設定されます。

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.CustomAxes プロパティ

パブリック プロパティ

Item

参照

CustomAxes クラス | Steema.TeeChart 名前空間


Item

Steema.TeeChart.CustomAxes.Item プロパティ

public Axis Item(Int32 index) {get; set;}

参照

CustomAxes クラス | CustomAxes メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DateTimeSteps

TeeChartプログラミングガイド

Steema.TeeChart.DateTimeSteps 列挙体

DateTimeステップを定義します。

[Serializable]
public enum DateTimeSteps : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
OneMillisecond | ミリ秒のタイムスパンを定義します。
OneSecond | 1秒のタイムスパンを定義します。
FiveSeconds | 5秒のタイムスパンを定義します。
TenSeconds | 10秒のタイムスパンを定義します。
FifteenSeconds | 15秒のタイムスパンを定義します。
ThirtySeconds | 30秒のタイムスパンを定義します。
OneMinute | 1分のタイムスパンを定義します。
FiveMinutes | 5分のタイムスパンを定義します。
TenMinutes | 10分のタイムスパンを定義します。
FifteenMinutes | 15分のタイムスパンを定義します。
ThirtyMinutes | 30分のタイムスパンを定義します。
OneHour | 1時間のタイムスパンを定義します。
TwoHours | 2時間のタイムスパンを定義します。
SixHours | 6時間のタイムスパンを定義します。
TwelveHours | 12時間のタイムスパンを定義します。
OneDay | 1日間のタイムスパンを定義します。
TwoDays | 2日間のタイムスパンを定義します。
ThreeDays | 3日間のタイムスパンを定義します。
OneWeek | 1週間のタイムスパンを定義します。
HalfMonth | 半月のタイムスパンを定義します。
OneMonth | 1ヶ月のタイムスパンを定義します。
TwoMonths | 2ヶ月のタイムスパンを定義します。
ThreeMonths | 3ヶ月のタイムスパンを定義します。
FourMonths | 4ヶ月のタイムスパンを定義します。
SixMonths | 6ヶ月のタイムスパンを定義します。
OneYear | 1年のタイムスパンを定義します。
None | 自動的なタイムスパンを定義します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.DblClickSeriesEventArgs

Steema.TeeChart.DblClickSeriesEventArgs クラス

この型のすべてのメンバの一覧については、DblClickSeriesEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class DblClickSeriesEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

DblClickSeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DblClickSeriesEventArgs 全メンバ

DblClickSeriesEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Index

参照

DblClickSeriesEventArgs クラス | Steema.TeeChart 名前空間


DblClickSeriesEventArgs コンストラクタ

Steema.TeeChart.DblClickSeriesEventArgs コンストラクタ

public DblClickSeriesEventArgs(Int32 i)

参照

DblClickSeriesEventArgs クラス | DblClickSeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DblClickSeriesEventArgs プロパティ

パブリック プロパティ

Index

参照

DblClickSeriesEventArgs クラス | Steema.TeeChart 名前空間


Index

Steema.TeeChart.DblClickSeriesEventArgs.Index プロパティ

public Int32 Index {get;}

参照

DblClickSeriesEventArgs クラス | DblClickSeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis

Steema.TeeChart.DepthAxis クラス

奥軸の特性。

この型のすべてのメンバの一覧については、DepthAxis メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Axis
public class DepthAxis : Axis , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

DepthAxis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis 全メンバ

DepthAxis 概要

コンストラクタ

Constructor

パブリック イベント

GetAxisDrawLabel (Axisの継承元)

パブリック フィールド

IAxisSize (Axisの継承元)
IEndPos (Axisの継承元)
IsDepthAxis (Axisの継承元)
IStartPos (Axisの継承元)

パブリック メソッド

AdjustMaxMin (Axisの継承元) | 従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。
AdjustMaxMinRect (Axisの継承元) | Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
CalcLabelStyle (Axisの継承元) | 最も論理的な軸ラベルスタイルを返します。
CalcMinMax (Axisの継承元) | 関連付けされている系列の最小値および最大値を返します。
CalcPosPoint (Axisの継承元) | 指定したピクセル単位の画面座標に該当する軸スケール値を返します。
CalcPosValue (Axisの継承元) | 指定した軸スケール値に該当する画面座標値をピクセル単位で返します。
CalcSizeValue (Axisの継承元) | 指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。
CalcXPosValue (Axisの継承元) | 指定したValueパラメータに該当する水平座標値をピクセル単位で返します。
CalcXYIncrement (Axisの継承元) | 計算された軸ラベルのインクリメントを返します。
CalcYPosValue (Axisの継承元) | 軸スケールでValueパラメータに該当する垂直座標位置をピクセル単位で返します。
Clicked (Axisの継承元) | XとY座標値が軸の位置に近いかどうかを返します。
DateTimeDefaultFormat (Axisの継承元) | astepパラメーターの値により、時間か日付を返します。
DateTimeIncrement (Axisの継承元) | DateTimeインクリメントのための定数を設定します。
Draw (Axisの継承元) | 現在の軸スケールで指定した画面位置に軸を表示します。
DrawAxisLabel (Axisの継承元) | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
DrawTitle (Axisの継承元) | 内部使用。チャート描写中にタイトルを表示します。
InternalCalcRange (Axisの継承元) | 内部使用。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsCustom (Axisの継承元) | 軸がカスタム軸の場合、trueを返します。
MaxLabelsWidth (Axisの継承元) | すべての軸ラベルの最大幅をピクセル単位で返します。
Scroll (Axisの継承元) | Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。
SetMinMax (Axisの継承元) | 軸の最小スケールおよび最大スケールを変更します。
TitleOrName (Axisの継承元) |

パブリック プロパティ

Automatic (Axisの継承元) | 関連付けられている系列に基づいて軸の最大値および最小値を計算します。
AutomaticMaximum (Axisの継承元) | 軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。
AutomaticMinimum (Axisの継承元) | 軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。
AxisPen (Axisの継承元) | 軸を描くペンの種類を設定します。
CalcIncrement (Axisの継承元) | 計算された軸ラベルのインクリメントを返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
EndPosition (Axisの継承元) | 軸の終了位置を0～100%で設定します。
Grid (Axisの継承元) | チャートグリッドを描くペンを設定します。
GridCentered (Axisの継承元) |
Horizontal (Axisの継承元) | カスタム軸を水平軸として描画するかどうか設定します。
Increment (Axisの継承元) | 軸ラベル間での最小ステップを設定します。日付時間軸のためのDateTimeStepsが使用できます。
Inverted (Axisの継承元) | 軸の最小値と最大値のスケールを交換します。
IsDateTime (Axisの継承元) | 指定された軸の値がDateTimeかどうかを返します。
Labels (Axisの継承元) | 軸ラベルの特性にアクセスします。
LabelsOnAxis (Axisの継承元) | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Logarithmic (Axisの継承元) | Trueの場合、軸を対数関数でスケールします。
LogarithmicBase (Axisの継承元) | AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。
Maximum (Axisの継承元) | 軸の最大値を設定します。
MaximumOffset (Axisの継承元) | 軸の最大位置にマージンとして残す量をピクセル単位で設定します。
MaxXValue (Axisの継承元) | 指定した軸の最大X値を返します。
MaxYValue (Axisの継承元) | 指定した軸の最大Y値を返します。
MinAxisIncrement (Axisの継承元) | デフォルト値：1e-12。最小の軸インクリメントを取得/設定します。
Minimum (Axisの継承元) | 軸の最小値を設定します。
MinimumOffset (Axisの継承元) | 軸の最小位置にマージンとして残す量をピクセル単位で設定します。
MinorGrid (Axisの継承元) | 副目盛の特性を設定します。
MinorTickCount (Axisの継承元) | 軸の副目盛の数を定義します。
MinorTicks (Axisの継承元) | 軸の副目盛を描くペンを定義します。
MinXValue (Axisの継承元) | 指定した軸の最小X値を返します。
MinYValue (Axisの継承元) | 指定した軸の最小Y値を返します。
OtherSide (Axisの継承元) | 軸を反対側へ移動します。
PosAxis (Axisの継承元) | 旧式：Positionプロパティを使用してください。
Position (Axisの継承元) | 軸を描画する位置を設定します。
PositionUnits (Axisの継承元) | 軸の位置を定義するPositionPercentプロパティの単位を設定します。
RelativePosition (Axisの継承元) | 軸の位置をチャートに対する0～100%で設定します。
StartPosition (Axisの継承元) | 軸の開始位置を0～100%で設定します。
TickOnLabelsOnly (Axisの継承元) | 軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。
Ticks (Axisの継承元) | 軸の線に沿った軸マーカを描くペンの種類を定義します。
TicksInner (Axisの継承元) | 軸の線の内側に軸マーカを描くペンの種類を定義します。
Title (Axisの継承元) | 軸タイトルの特性にアクセスします。
TitleSize (Axisの継承元) |
Visible | 奥軸を表示/非表示にします。
ZPosition (Axisの継承元) | チャートの深さに沿ってZ軸の位置を設定します。

プロテクト フィールド

bVisible (Axisの継承元)
FAxisDraw (Axisの継承元)
iHideBackGrid (Axisの継承元)
iHideSideGrid (Axisの継承元)
InternalUse (TeeBaseの継承元)
posTitle (Axisの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

CalcRect (Axisの継承元) | 軸を作成する際にチャートで使用される内部的メソッド。
Dispose (Axisの継承元) |
DoGetAxisDrawLabel (Axisの継承元) |
DrawAxisLabel (Axisの継承元) | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
InflateAxisPos (Axisの継承元) |
InternalCalcLabelStyle |
OnDisposing (Axisの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Axisの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetInverted |
SetStringProperty (TeeBaseの継承元) |
ShouldSerializeAutomatic (Axisの継承元) |
ShouldSerializeHorizontal (Axisの継承元) |
ShouldSerializeMaximum (Axisの継承元) |
ShouldSerializeMinimum (Axisの継承元) |
ShouldSerializeOtherSide (Axisの継承元) |
ShouldSerializeZPosition (Axisの継承元) |

参照

DepthAxis クラス | Steema.TeeChart 名前空間


DepthAxis コンストラクタ

Steema.TeeChart.DepthAxis コンストラクタ

public DepthAxis(Boolean horiz,
     Boolean isOtherSide,
     Chart c)

参照

DepthAxis クラス | DepthAxis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis イベント

パブリック イベント

GetAxisDrawLabel (Axisの継承元)

参照

DepthAxis クラス | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis フィールド

パブリック フィールド

IAxisSize (Axisの継承元)
IEndPos (Axisの継承元)
IsDepthAxis (Axisの継承元)
IStartPos (Axisの継承元)

プロテクト フィールド

bVisible (Axisの継承元)
FAxisDraw (Axisの継承元)
iHideBackGrid (Axisの継承元)
iHideSideGrid (Axisの継承元)
InternalUse (TeeBaseの継承元)
posTitle (Axisの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

DepthAxis クラス | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis メソッド

パブリック メソッド

AdjustMaxMin (Axisの継承元) | 従属系列の最大値や最小値に基づいて軸の最大値および最小値を計算します。
AdjustMaxMinRect (Axisの継承元) | Rectパラメーターの位置を使用して、最大値および最小値を再計算するために内部的に呼び出されます。
CalcLabelStyle (Axisの継承元) | 最も論理的な軸ラベルスタイルを返します。
CalcMinMax (Axisの継承元) | 関連付けされている系列の最小値および最大値を返します。
CalcPosPoint (Axisの継承元) | 指定したピクセル単位の画面座標に該当する軸スケール値を返します。
CalcPosValue (Axisの継承元) | 指定した軸スケール値に該当する画面座標値をピクセル単位で返します。
CalcSizeValue (Axisの継承元) | 指定した軸スケールのValueパラメーターに該当するサイズをピクセル単位で返します。
CalcXPosValue (Axisの継承元) | 指定したValueパラメータに該当する水平座標値をピクセル単位で返します。
CalcXYIncrement (Axisの継承元) | 計算された軸ラベルのインクリメントを返します。
CalcYPosValue (Axisの継承元) | 軸スケールでValueパラメータに該当する垂直座標位置をピクセル単位で返します。
Clicked (Axisの継承元) | XとY座標値が軸の位置に近いかどうかを返します。
DateTimeDefaultFormat (Axisの継承元) | astepパラメーターの値により、時間か日付を返します。
DateTimeIncrement (Axisの継承元) | DateTimeインクリメントのための定数を設定します。
Draw (Axisの継承元) | 現在の軸スケールで指定した画面位置に軸を表示します。
DrawAxisLabel (Axisの継承元) | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
DrawTitle (Axisの継承元) | 内部使用。チャート描写中にタイトルを表示します。
InternalCalcRange (Axisの継承元) | 内部使用。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsCustom (Axisの継承元) | 軸がカスタム軸の場合、trueを返します。
MaxLabelsWidth (Axisの継承元) | すべての軸ラベルの最大幅をピクセル単位で返します。
Scroll (Axisの継承元) | Offsetパラメータで指定された分、軸の最大値と最小値を「スクロール」もしくは移動します。
SetMinMax (Axisの継承元) | 軸の最小スケールおよび最大スケールを変更します。
TitleOrName (Axisの継承元) |

プロテクト メソッド

CalcRect (Axisの継承元) | 軸を作成する際にチャートで使用される内部的メソッド。
Dispose (Axisの継承元) |
DoGetAxisDrawLabel (Axisの継承元) |
DrawAxisLabel (Axisの継承元) | 指定したXY座標で軸ラベルを描画します。Angleパラメーターによりラベルの角度を設定します。
InflateAxisPos (Axisの継承元) |
InternalCalcLabelStyle |
OnDisposing (Axisの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Axisの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetInverted |
SetStringProperty (TeeBaseの継承元) |
ShouldSerializeAutomatic (Axisの継承元) |
ShouldSerializeHorizontal (Axisの継承元) |
ShouldSerializeMaximum (Axisの継承元) |
ShouldSerializeMinimum (Axisの継承元) |
ShouldSerializeOtherSide (Axisの継承元) |
ShouldSerializeZPosition (Axisの継承元) |

参照

DepthAxis クラス | Steema.TeeChart 名前空間


InternalCalcLabelStyle

Steema.TeeChart.DepthAxis.InternalCalcLabelStyle メソッド

protected abstract AxisLabelStyle InternalCalcLabelStyle()

参照

DepthAxis クラス | DepthAxis メンバ | Steema.TeeChart 名前空間


SetInverted

Steema.TeeChart.DepthAxis.SetInverted メソッド

protected abstract Void SetInverted(Boolean Value)

参照

DepthAxis クラス | DepthAxis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.DepthAxis プロパティ

パブリック プロパティ

Automatic (Axisの継承元) | 関連付けられている系列に基づいて軸の最大値および最小値を計算します。
AutomaticMaximum (Axisの継承元) | 軸に関連する系列の最大値に基づいて、自動的に最大値を調整するかどうかを制御します。
AutomaticMinimum (Axisの継承元) | 軸に関連する系列の最小値に基づいて、自動的に最小値を調整するかどうかを制御します。
AxisPen (Axisの継承元) | 軸を描くペンの種類を設定します。
CalcIncrement (Axisの継承元) | 計算された軸ラベルのインクリメントを返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
EndPosition (Axisの継承元) | 軸の終了位置を0～100%で設定します。
Grid (Axisの継承元) | チャートグリッドを描くペンを設定します。
GridCentered (Axisの継承元) |
Horizontal (Axisの継承元) | カスタム軸を水平軸として描画するかどうか設定します。
Increment (Axisの継承元) | 軸ラベル間での最小ステップを設定します。日付時間軸のためのDateTimeStepsが使用できます。
Inverted (Axisの継承元) | 軸の最小値と最大値のスケールを交換します。
IsDateTime (Axisの継承元) | 指定された軸の値がDateTimeかどうかを返します。
Labels (Axisの継承元) | 軸ラベルの特性にアクセスします。
LabelsOnAxis (Axisの継承元) | ラベルを軸の最小値と最大値に描画するかしないかを制御します。
Logarithmic (Axisの継承元) | Trueの場合、軸を対数関数でスケールします。
LogarithmicBase (Axisの継承元) | AxisのLogarithmicプロパティがTrueの場合、対数の基準を定義します。
Maximum (Axisの継承元) | 軸の最大値を設定します。
MaximumOffset (Axisの継承元) | 軸の最大位置にマージンとして残す量をピクセル単位で設定します。
MaxXValue (Axisの継承元) | 指定した軸の最大X値を返します。
MaxYValue (Axisの継承元) | 指定した軸の最大Y値を返します。
MinAxisIncrement (Axisの継承元) | デフォルト値：1e-12。最小の軸インクリメントを取得/設定します。
Minimum (Axisの継承元) | 軸の最小値を設定します。
MinimumOffset (Axisの継承元) | 軸の最小位置にマージンとして残す量をピクセル単位で設定します。
MinorGrid (Axisの継承元) | 副目盛の特性を設定します。
MinorTickCount (Axisの継承元) | 軸の副目盛の数を定義します。
MinorTicks (Axisの継承元) | 軸の副目盛を描くペンを定義します。
MinXValue (Axisの継承元) | 指定した軸の最小X値を返します。
MinYValue (Axisの継承元) | 指定した軸の最小Y値を返します。
OtherSide (Axisの継承元) | 軸を反対側へ移動します。
PosAxis (Axisの継承元) | 旧式：Positionプロパティを使用してください。
Position (Axisの継承元) | 軸を描画する位置を設定します。
PositionUnits (Axisの継承元) | 軸の位置を定義するRelativePositionプロパティの単位を設定します。
RelativePosition (Axisの継承元) | 軸の位置をチャートに対する0～100%で設定します。
StartEndPositionUnits (Axisの継承元) | StartPositionプロパティとEndPositionプロパティの位置の単位（ピクセルあるいは百分率）を定義します。
StartPosition (Axisの継承元) | 軸の開始位置を0～100%で設定します。
TickOnLabelsOnly (Axisの継承元) | 軸目盛と軸グリッドがラベルの位置と一致したところだけ描かれるように設定します。
Ticks (Axisの継承元) | 軸の線に沿った軸マーカを描くペンの種類を定義します。
TicksInner (Axisの継承元) | 軸の線に沿って軸マーカを描くペンの種類を定義します。
Title (Axisの継承元) | 軸タイトルの特性にアクセスします。
TitleSize (Axisの継承元) |
Visible | 奥軸を表示/非表示にします。
ZPosition (Axisの継承元) | チャートの深さに沿ってZ軸の位置を設定します。

参照

DepthAxis クラス | Steema.TeeChart 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.DepthAxis.Visible プロパティ

奥軸を表示/非表示にします。

public Boolean Visible {get; set;}

解説

デフォルト値：false

奥軸を表示/非表示にします。

例

[C#]

tChart1.Axes.Depth.Visible = true;

参照

DepthAxis クラス | DepthAxis メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Editor

Steema.TeeChart.Editor クラス

チャートエディタ。

この型のすべてのメンバの一覧については、Editor メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
public class Editor : Control , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

例

 public void LocalShowEditor()
{
    Steema.TeeChart.Editor editor = new Steema.TeeChart.Editor(tChart1);

    editor.HelpFileName="myHelpFile.chm"; //TeeChartで使用するヘルプをmyHelpFile.chmに設定します。
    editor.Title="My Charting App - Chart Editor";

    Steema.TeeChart.Editors.ChartEditorOptions[] options=new Steema.TeeChart.Editors.ChartEditorOptions[2];

    options[0]=Steema.TeeChart.Editors.ChartEditorOptions.Help;
    options[1]=Steema.TeeChart.Editors.ChartEditorOptions.Add;
    options[1]=Steema.TeeChart.Editors.ChartEditorOptions.Delete;

    editor.Options=options;

    editor.ShowModal();
}

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Editor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Editor 全メンバ

Editor 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

CloseEditor
ShowEditor

パブリック メソッド

Show | チャートエディタダイアログを表示します。
ShowModal | チャートエディタダイアログを表示します。

パブリック プロパティ

AutoRepaint | チャートエディタでプロパティを修正する間、チャートの自動再描画を有効/無効にします。
Chart | 編集されるChartコントロールを取得/設定します。
DefaultTab | チャートエディタを表示する際の最初に表示するタブを取得/設定します。
HelpFileName | チャートエディタで、ヘルプボタンをクリックした時に表示するヘルプファイルのパスやファイル名を取得/設定します。
HideTabs | チャートエディタのタブを非表示にします。
HighLightTabs | Trueの場合、エディタタブは「強調表示」されます。
Options |
Title | チャートエディタダイアログのキャプションを取得/設定します。タイトルが設定されていない場合、デフォルトのキャプションが使用されます。

プロテクト メソッド

Dispose 使用したリソースを削除します。

参照

Editor クラス | Steema.TeeChart 名前空間


Editor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Editor コンストラクタ

オーバーロードの一覧

public Editor(System.ComponentModel.IContainer)
public Editor(Steema.TeeChart.TChart)
public Editor()

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Editor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Editor コンストラクタ

public Editor(IContainer container)

参照

Editor コンストラクタのオーバーロードの一覧 | Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Editor コンストラクタ

Steema.TeeChart.Editor コンストラクタ

public Editor(TChart c)

参照

Editor コンストラクタのオーバーロードの一覧 | Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Editor コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Editor コンストラクタ

public Editor()

参照

Editor コンストラクタのオーバーロードの一覧 | Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Editor イベント

パブリック イベント

CloseEditor
ShowEditor

参照

Editor クラス | Steema.TeeChart 名前空間


CloseEditor

TeeChartプログラミングガイド

Steema.TeeChart.Editor.CloseEditor イベント

public EventHandler  CloseEditor

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


ShowEditor

TeeChartプログラミングガイド

Steema.TeeChart.Editor.ShowEditor イベント

public EventHandler  ShowEditor

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Editor メソッド

パブリック メソッド

Show | チャートエディタダイアログを表示します。
ShowModal | チャートエディタダイアログを表示します。

プロテクト メソッド

Dispose 使用したリソースを削除します。

参照

Editor クラス | Steema.TeeChart 名前空間


Dispose

Steema.TeeChart.Editor.Dispose メソッド

使用したリソースを削除します
protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Show

Steema.TeeChart.Editor.Show メソッド

チャートエディタダイアログを表示します。
public static DialogResult Show(TChart c)

パラメーター

c
編集するTChartコントロール。

戻り値

Escapeキーあるいは「閉じる」ボタンを押すと1を返します。

解説

チャートエディタダイアログを表示します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


ShowModal

TeeChartプログラミングガイド

Steema.TeeChart.Editor.ShowModal メソッド

オーバーロードの一覧

チャートエディタダイアログを表示します。

public DialogResult ShowModal(System.Windows.Forms.Control)

チャートエディタダイアログを表示します。

public DialogResult ShowModal()

解説

モーダルモードでフォームを表示します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


ShowModal

TeeChartプログラミングガイド

Steema.TeeChart.Editor.ShowModal メソッド

チャートエディタダイアログを表示します。

public DialogResult ShowModal(Control owner)

パラメーター

owner
ダイアログのオーナー

参照

ShowModal オーバーロードの一覧 | Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


ShowModal

TeeChartプログラミングガイド

Steema.TeeChart.Editor.ShowModal メソッド

チャートエディタダイアログを表示します。

public DialogResult ShowModal()

参照

ShowModal オーバーロードの一覧 | Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Editor プロパティ

パブリック プロパティ

AutoRepaint | チャートエディタでプロパティを修正する間、チャートの自動再描画を有効/無効にします。
Chart | 編集されるChartコントロールを取得/設定します。
DefaultTab | チャートエディタを表示する際の最初に表示するタブを取得/設定します。
HelpFileName | チャートエディタで、ヘルプボタンをクリックした時に表示するヘルプファイルのパスやファイル名を取得/設定します。
HideTabs | チャートエディタのタブを非表示にします。
HighLightTabs | Trueの場合、エディタタブは「強調表示」されます。
Options |
Title | チャートエディタダイアログのキャプションを取得/設定します。タイトルが設定されていない場合、デフォルトのキャプションが使用されます。

参照

Editor クラス | Steema.TeeChart 名前空間


AutoRepaint

TeeChartプログラミングガイド

Steema.TeeChart.Editor.AutoRepaint プロパティ

チャートエディターでプロパティを修正する間、チャートの自動再描画を有効/無効にします。

public Boolean AutoRepaint {get; set;}

解説

チャートエディターでプロパティを修正する間、チャートの自動再描画を有効/無効にします。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Chart

Steema.TeeChart.Editor.Chart プロパティ

編集されるChartコントロールを取得/設定します。
public TChart Chart {get; set;}

解説

編集されるChartコントロールを取得/設定します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


DefaultTab

Steema.TeeChart.Editor.DefaultTab プロパティ

チャートエディタを表示する際の最初に表示するタブを取得/設定します。
public ChartEditorTabs DefaultTab {get; set;}

解説

チャートエディタを表示する際の最初に表示するタブを取得/設定します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


HelpFileName

TeeChartプログラミングガイド

Steema.TeeChart.Editor.HelpFileName プロパティ

チャートエディターで、ヘルプボタンをクリックした時に表示するヘルプファイルのパスやファイル名を取得/設定します。

public String HelpFileName {get; set;}

解説

チャートエディターで、ヘルプボタンをクリックした時に表示するヘルプファイルのパスやファイル名を取得/設定します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


HideTabs

Steema.TeeChart.Editor.HideTabs プロパティ

TeeChartのエディタタブを非表示にします。

public ChartEditorTabs[] HideTabs {get; set;}

解説

TeeChartのエディタタブを非表示にします。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


HighLightTabs

Steema.TeeChart.Editor.HighLightTabs プロパティ

Trueの場合、エディタタブは「強調表示」されます。

public Boolean HighLightTabs {get; set;}

解説

Trueの場合、エディタタブは「強調表示」されます。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Options

Steema.TeeChart.Editor.Options プロパティ

public ChartEditorOptions[] Options {get; set;}

解説

チャートエディタの最初のページで使用するボタンのオプションを設定します。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Title

TeeChartプログラミングガイド

Steema.TeeChart.Editor.Title プロパティ

チャートエディタダイアログのキャプションを取得/設定します。タイトルが設定されていない場合、デフォルトのキャプションが使用されます。

public String Title {get; set;}

解説

チャートエディタダイアログのキャプションを取得/設定します。タイトルを設定されていない場合、デフォルトのキャプションが使用されます。

参照

Editor クラス | Editor メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.EditSeriesEventHandler

Steema.TeeChart.EditSeriesEventHandler デリゲート

ChartListBoxの編集のイベントハンドラ。
public delegate EditSeriesEventHandler (ChartListBox sender,
     Series s)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Footer

Steema.TeeChart.Footer クラス

チャートの下部に表示されるテキスト。

この型のすべてのメンバの一覧については、Footer メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
Steema.TeeChart.Title
public class Footer : Title , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Footer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Footer 全メンバ

Footer 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked (Titleの継承元) | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw (Titleの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AdjustFrame (Titleの継承元) | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment (Titleの継承元) | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Titleの継承元) | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Titleの継承元) | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop (Titleの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Titleの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Footer クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Footer コンストラクタ

オーバーロードの一覧

public Footer()
public Footer(Steema.TeeChart.Chart)
public Footer(Steema.TeeChart.Chart, System.Boolean)

参照

Footer クラス | Footer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Footer コンストラクタ

public Footer()

参照

Footer コンストラクタのオーバーロードの一覧 | Footer クラス | Footer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Footer コンストラクタ

public Footer(Chart c)

参照

Footer コンストラクタのオーバーロードの一覧 | Footer クラス | Footer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Footer コンストラクタ

public Footer(Chart c,
     Boolean startVisible)

参照

Footer コンストラクタのオーバーロードの一覧 | Footer クラス | Footer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Footer フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop (Titleの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Footer クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Footer メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked (Titleの継承元) | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw (Titleの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Titleの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Footer クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Footer プロパティ

パブリック プロパティ

AdjustFrame (Titleの継承元) | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment (Titleの継承元) | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Titleの継承元) | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Titleの継承元) | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Footer クラス | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel クラス

系列ギャラリを保持するために派生したWinFormsパネルクラス。

この型のすべてのメンバの一覧については、GalleryPanel メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.Panel
public class GalleryPanel : Panel , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel 全メンバ

GalleryPanel 概要

コンストラクタ

Constructor

パブリック イベント

OnChangeChart | チャートがギャラリで選択（クリック）されると発生します。
OnSelectedChart | チャートがギャラリで選択（ダブルクリック）されると発生します。
OnSubSelected | 系列のサブスタイルがサブギャラリで選択されると発生します。

パブリック フィールド

Charts | ギャラリパネルで表示しているチャートのリストです。
CheckMaximize | ギャラリパネルが最大化表示されている場合、各系列を表示しているチャートの軸を表示/非表示にします。
CursorDisabled | 無効な系列型用のマウスカーソル。
FunctionsVisible | 関数タブを表示/非表示にします。
GalleryNumCols | ギャラリパネルの列数。
GalleryNumRows | ギャラリパネルの行数。
LastSelectedChart |
SelectedChart |
SelectedSeries |

パブリック メソッド

ApplyPalette |
CreateGalleryPage |
CreateGallerySeries |
GalleryPages |
SetSubSelected | サブギャラリから選択されたチャートを設定します。

パブリック プロパティ

ColorPaletteIndex |
DisplaySub | 左下の角の小さい矢をクリックした場合にギャラリパネルがサブギャラリを表示するかどうかを取得/設定します。
FunctionType | 現在選択した関数型を返します。関数以外の場合はnullを返します。
InitArgs | 付加的なチャート初期化引数。
NumCols | チャートのギャラリパネルに表示する系列型の列数を設定します。
NumRows | チャートのギャラリパネルに表示する系列型の行数を設定します。
SeriesType |
Smooth |
SubIndex | 選択されたサブチャートのインデックスを取得します。
View3D | ギャラリパネルに表示されている系列型を3D/2Dで表示します。

プロテクト メソッド

OnKeyDown
OnResize

参照

GalleryPanel クラス | Steema.TeeChart 名前空間


GalleryPanel コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel コンストラクタ

public GalleryPanel()

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel イベント

パブリック イベント

OnChangeChart | チャートがギャラリで選択（クリック）されると発生します。
OnSelectedChart | チャートがギャラリで選択（ダブルクリック）されると発生します。
OnSubSelected | 系列のサブスタイルがサブギャラリで選択されると発生します。

参照

GalleryPanel クラス | Steema.TeeChart 名前空間


OnChangeChart

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.OnChangeChart イベント

このイベントは、チャートがギャラリで選択（クリック）されると発生します。

public EventHandler  OnChangeChart

解説

このイベントは、チャートがギャラリーで選択（クリック）されると発生します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


OnSelectedChart

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.OnSelectedChart イベント

このイベントは、チャートがギャラリで選択（ダブルクリック）されると発生します。

public EventHandler  OnSelectedChart

解説

このイベントは、チャートがギャラリで選択（ダブルクリック）されると発生します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


OnSubSelected

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.OnSubSelected イベント

このイベントは、系列のサブスタイルがサブギャラリで選択されると発生します。

public EventHandler  OnSubSelected

解説

このイベントは、サブギャラリパネルでチャートをクリック（選択）すると発生します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel フィールド

パブリック フィールド

Charts | ギャラリパネルに表示しているチャートのリスト。
CheckMaximize | ギャラリパネルが最大化表示されている場合、各系列を表示しているチャートの軸を表示/非表示にします。
CursorDisabled | 無効になった系列型用のマウスカーソル。
FunctionsVisible | 関数タブを表示/非表示にします。
GalleryNumCols | ギャラリパネルの列数。
GalleryNumRows | ギャラリパネルの行数。
LastSelectedChart |
SelectedChart |
SelectedSeries |

参照

GalleryPanel クラス | Steema.TeeChart 名前空間


Charts

Steema.TeeChart.GalleryPanel.Charts フィールド

ギャラリパネルで表示しているチャートのリストです。
public GalleryChartCollection Charts

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CheckMaximize

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.CheckMaximize フィールド

ギャラリパネルが最大化表示されている場合、各系列を表示しているチャートの軸を表示/非表示にします。

public Boolean CheckMaximize

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CursorDisabled

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.CursorDisabled フィールド

無効な系列型用のマウスカーソル。

public Cursor CursorDisabled

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


FunctionsVisible

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.FunctionsVisible フィールド

関数タブを表示/非表示にします。

public Boolean FunctionsVisible

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


GalleryNumCols

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.GalleryNumCols フィールド

ギャラリパネルの列数。

public Int32 GalleryNumCols

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


GalleryNumRows

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.GalleryNumRows フィールド

ギャラリパネルの行数。

public Int32 GalleryNumRows

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


LastSelectedChart

Steema.TeeChart.GalleryPanel.LastSelectedChart フィールド

public GalleryChart LastSelectedChart

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


SelectedChart

Steema.TeeChart.GalleryPanel.SelectedChart フィールド

public GalleryChart SelectedChart

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


SelectedSeries

Steema.TeeChart.GalleryPanel.SelectedSeries フィールド

public Series SelectedSeries

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel メソッド

パブリック メソッド

ApplyPalette |
CreateGalleryPage |
CreateGallerySeries |
GalleryPages |
SetSubSelected | サブギャラリから選択されたチャートを設定します。

プロテクト メソッド

OnKeyDown
OnResize

参照

GalleryPanel クラス | Steema.TeeChart 名前空間


ApplyPalette

Steema.TeeChart.GalleryPanel.ApplyPalette メソッド

public Void ApplyPalette(Int32 galleryPaletteIndex)

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CreateGalleryPage

Steema.TeeChart.GalleryPanel.CreateGalleryPage メソッド

オーバーロードの一覧

public Void CreateGalleryPage(System.String)
public Void CreateGalleryPage(System.String, System.Boolean)

解説

ギャラリページのインスタンスを作成します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CreateGalleryPage

Steema.TeeChart.GalleryPanel.CreateGalleryPage メソッド

public Void CreateGalleryPage(String pageName)

解説

ギャラリページのインスタンスを作成します。

参照

CreateGalleryPage オーバーロードの一覧 | GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CreateGalleryPage

Steema.TeeChart.GalleryPanel.CreateGalleryPage メソッド

public Void CreateGalleryPage(String pageName,
     Boolean functions)

解説

ギャラリページのインスタンスを作成します。

参照

CreateGalleryPage オーバーロードの一覧 | GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


CreateGallerySeries

Steema.TeeChart.GalleryPanel.CreateGallerySeries メソッド

public Void CreateGallerySeries(Type seriesType)

解説

ギャラリ系列のインスタンスを作成するために使用してください。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


GalleryPages

Steema.TeeChart.GalleryPanel.GalleryPages メソッド

public static String GalleryPages(Int32 index)

解説

インデックスで選択されたページの特性にアクセスします。
これは、ギャラリページ上の情報を取得できます。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


OnKeyDown

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.OnKeyDown メソッド

protected virtual Void OnKeyDown(KeyEventArgs e)

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


OnResize

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.OnResize メソッド

protected virtual Void OnResize(EventArgs e)

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


SetSubSelected

Steema.TeeChart.GalleryPanel.SetSubSelected メソッド

サブギャラリから選択されたチャートを設定します。
public Void SetSubSelected(Series s,
     Int32 index)

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel プロパティ

パブリック プロパティ

DisplaySub | 左下の角の小さい矢をクリックした場合にギャラリパネルがサブギャラリを表示するかどうかを取得/設定します。
FunctionType | 現在選択した関数型を返します。関数以外の場合はnullを返します。
NumCols | チャートのギャラリパネルに表示する系列型の列数を設定します。
NumRows | チャートのギャラリパネルに表示する系列型の行数を設定します。
SeriesType |
Smooth |
SubIndex | 選択されたサブチャートのインデックスを取得します。
View3D | ギャラリパネルに表示されている系列型を3D/2Dで表示します。

参照

GalleryPanel クラス | Steema.TeeChart 名前空間


ColorPaletteIndex

Steema.TeeChart.GalleryPanel.ColorPaletteIndex プロパティ

public static Int32 ColorPaletteIndex {get; set;}

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


DisplaySub

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.DisplaySub プロパティ

左下の角の小さい矢印をクリックした場合にギャラリパネルがサブギャラリを表示するかどうかを取得/設定します。

public Boolean DisplaySub {get; set;}

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


FunctionType

Steema.TeeChart.GalleryPanel.FunctionType プロパティ

現在選択した関数型を返します。関数以外の場合はnullを返します。
public Type FunctionType {get;}

解説

現在選択した関数型を返します。関数以外の場合はnullを返します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


InitArgs

Steema.TeeChart.GalleryPanel.InitArgs プロパティ

付加的なチャート初期化引数。
public Object[] InitArgs {get;}

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


NumCols

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.NumCols プロパティ

public Int32 NumCols {get; set;}

解説

チャートのギャラリパネルに表示する系列型の列数を設定します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


NumRows

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.NumRows プロパティ

public Int32 NumRows {get; set;}

解説

チャートのギャラリパネルに表示する系列型の行数を設定します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


SeriesType

Steema.TeeChart.GalleryPanel.SeriesType プロパティ

public Type SeriesType {get;}

解説

系列型を返します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Smooth

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.Smooth プロパティ

public SmoothingMode Smooth {get; set;}

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


SubIndex

Steema.TeeChart.GalleryPanel.SubIndex プロパティ

選択されたサブチャートのインデックスを取得します。
public Int32 SubIndex {get;}

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


View3D

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel.View3D プロパティ

public Boolean View3D {get; set;}

解説

デフォルト値：true

ギャラリパネルに表示されている系列型を3D/2Dで表示します。

参照

GalleryPanel クラス | GalleryPanel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart

Steema.TeeChart.GalleryPanel.GalleryChart クラス

ギャラリパネルに表示するための内部チャートクラス。

この型のすべてのメンバの一覧については、GalleryChart メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Steema.TeeChart.TChart
public class GalleryChart : TChart , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISynchronizeInvoke, IWin32Window
, ISerializable, IChart

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

GalleryChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart 全メンバ

GalleryChart 概要

コンストラクタ

Steema.TeeChart.GalleryPanel.GalleryChart..ctor 新しいギャラリダイアログを作成します。

パブリック イベント

AfterDraw (TChartの継承元)
AllowScroll (TChartの継承元)
BeforeDraw (TChartの継承元)
BeforeDrawAxes (TChartの継承元)
BeforeDrawSeries (TChartの継承元)
ChartPrint (TChartの継承元)
ClickAxis (TChartの継承元)
ClickBackground (TChartの継承元)
ClickLegend (TChartの継承元)
ClickSeries (TChartの継承元)
ClickTitle (TChartの継承元)
GetAxesChartRect (TChartの継承元)
GetAxisLabel (TChartの継承元)
GetLegendPos (TChartの継承元)
GetLegendRect (TChartの継承元)
GetLegendText (TChartの継承元)
GetNextAxisLabel (TChartの継承元)
Scroll (TChartの継承元)
UndoneZoom (TChartの継承元)
Zoomed (TChartの継承元)

パブリック フィールド

GalleryColor 選択したチャートグラデーションを変更するための色。

パブリック メソッド

AboutBox (TChartの継承元) |
AddSeries (TChartの継承元) | チャートに新しい系列を追加します。
Clear (TChartの継承元) | チャートをデフォルト値にリセットします。
DoAfterDraw |
DoInvalidate (TChartの継承元) |
Draw (TChartの継承元) | 指定したキャンバスや領域にチャートを描画します。
ExchangeSeries (TChartの継承元) |
GetObjectData (TChartの継承元) |
RemoveAllSeries (TChartの継承元) |
ShowEditor (TChartの継承元) | TeeChartのエディタダイアログを表示します。

パブリック プロパティ

ApplyZOrder (TChartの継承元) |
Aspect (TChartの継承元) | チャートのビュー特性にアクセスします。
AutoRepaint (TChartの継承元) | ポイントが追加された際にチャートの再描画を有効/無効にします。
Axes (TChartの継承元) | 各軸にアクセスします。
BackColor (TChartの継承元) | チャート矩形を塗りつぶす色を設定します。
Bitmap (TChartの継承元) | チャートで描画されたビットマップイメージを返します。
Canvas (TChartの継承元) |
Chart (TChartの継承元) | 描画するチャートを定義します。
ClipPoints (TChartの継承元) |
Export (TChartの継承元) | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Font (TChartの継承元) | フォント特性を定義します。
Footer (TChartの継承元) | チャートの下部に描くテキストや書式特性を定義します。
ForeColor (TChartの継承元) | TChartオブジェクトの前面の色を取得します。
Frame (TChartの継承元) | 旧式。チャートの背面の周りの枠の特性を設定します。このプロパティの代わりにtChart1.Walls.Back.Penプロパティを使用してください。
GetCursorPos (TChartの継承元) |
Graphics3D (TChartの継承元) | TeeChartの描画プロパティやメソッドにアクセスするために使用してください。
Header (TChartの継承元) | チャートの上部に描くテキストや書式特性を定義します。
Import (TChartの継承元) | チャートのインポートについてのプロパティやメソッドにアクセスします。
Item (TChartの継承元) | デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
Legend (TChartの継承元) | 凡例の特性にアクセスします。
Metafile (TChartの継承元) | チャートで描画されたメタファイルイメージを返します。
Metafiling (TChartの継承元) | チャートがメタファイルイメージに内部で描画している場合、trueを返します。
Page (TChartの継承元) | チャートの複数ページ特性にアクセスします。
Panel (TChartの継承元) | チャート背面の可視属性を設定します。
Panning (TChartの継承元) | チャートのパン特性にアクセスします。
Printer (TChartの継承元) | 印刷に関連したプロパティやメソッドにアクセスします。
Printing (TChartの継承元) | 印刷するチャートを取得/設定します。
Series (TChartの継承元) | チャートに含まれる系列のリストにアクセスします。
SeriesCount (TChartの継承元) | 旧式。チャート内の系列の数を返します。このプロパティの代わりにtChart1.Series.Countプロパティを使用してください。
Site (TChartの継承元) | TChartコントロールのサイトを取得/設定します。
SubFooter (TChartの継承元) | フッターの上に表示されるテキストを定義します。
SubHeader (TChartの継承元) | ヘッダーの下に表示されるテキストを定義します。
Text (TChartの継承元) | フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定します。
TimerEnabled (TChartの継承元) | 旧式。チャートを自動的に再描画する内部タイマーを有効/無効にします。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
TimerInterval (TChartの継承元) | 旧式。チャートを自動的に再描画するミリ秒単位のインターバルを取得/設定します。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
Tools (TChartの継承元) | チャート内に含まれているツールコンポーネントのコレクションです。
Walls (TChartの継承元) | チャートの左、下、背面の壁特性にアクセスします。
Zoom (TChartの継承元) | チャートのズーム特性にアクセスします。

プロテクト メソッド

Dispose (TChartの継承元) | 使用したリソースを空にします。
initVars (TChartの継承元) |
OnDoubleClick (TChartの継承元) |
OnKeyDown |
OnMouseDown (TChartの継承元) |
OnMouseEnter |
OnMouseLeave |
OnMouseMove (TChartの継承元) |
OnMouseUp (TChartの継承元) |
OnMouseWheel (TChartの継承元) |
OnPaint (TChartの継承元) |

プロテクト プロパティ

DefaultSize (TChartの継承元)

参照

GalleryChart クラス | Steema.TeeChart 名前空間


GalleryChart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel+GalleryChart コンストラクタ

新しいギャラリダイアログを作成します。

public GalleryPanel+GalleryChart(SmoothingMode smooth)

パラメーター

smooth
ギャラリにアンチエイリアシングされたチャートを表示するにはtrueに設定してください。

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart イベント

パブリック イベント

AfterDraw (TChartの継承元)
AllowScroll (TChartの継承元)
BeforeDraw (TChartの継承元)
BeforeDrawAxes (TChartの継承元)
BeforeDrawSeries (TChartの継承元)
ChartPrint (TChartの継承元)
ClickAxis (TChartの継承元)
ClickBackground (TChartの継承元)
ClickLegend (TChartの継承元)
ClickSeries (TChartの継承元)
ClickTitle (TChartの継承元)
GetAxesChartRect (TChartの継承元)
GetAxisLabel (TChartの継承元)
GetLegendPos (TChartの継承元)
GetLegendRect (TChartの継承元)
GetLegendText (TChartの継承元)
GetNextAxisLabel (TChartの継承元)
Scroll (TChartの継承元)
UndoneZoom (TChartの継承元)
Zoomed (TChartの継承元)

参照

GalleryChart クラス | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart フィールド

パブリック フィールド

GalleryColor 選択したチャートのグラデーションを変更するための色。

参照

GalleryChart クラス | Steema.TeeChart 名前空間


GalleryColor

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel+GalleryChart.GalleryColor フィールド

選択したチャートのグラデーションを変更するための色。

public Color GalleryColor

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart メソッド

パブリック メソッド

AboutBox (TChartの継承元) |
AddSeries (TChartの継承元) | チャートに新しい系列を追加します。
Clear (TChartの継承元) | チャートをデフォルト値にリセットします。
DoAfterDraw |
DoInvalidate (TChartの継承元) |
Draw (TChartの継承元) | 指定したキャンバスや領域にチャートを描画します。
ExchangeSeries (TChartの継承元) |
GetObjectData (TChartの継承元) |
RemoveAllSeries (TChartの継承元) |
ShowEditor (TChartの継承元) | TeeChartのエディタダイアログを表示します。

プロテクト メソッド

Dispose (TChartの継承元) | 使用したリソースを空にします。
initVars (TChartの継承元) |
OnDoubleClick (TChartの継承元) |
OnKeyDown |
OnMouseDown (TChartの継承元) |
OnMouseEnter |
OnMouseLeave |
OnMouseMove (TChartの継承元) |
OnMouseUp (TChartの継承元) |
OnMouseWheel (TChartの継承元) |
OnPaint (TChartの継承元) |

参照

GalleryChart クラス | Steema.TeeChart 名前空間


DoAfterDraw

Steema.TeeChart.GalleryPanel+GalleryChart.DoAfterDraw メソッド

public Void DoAfterDraw(Object sender,
     Graphics3D g)

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


OnKeyDown

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel+GalleryChart.OnKeyDown メソッド

protected virtual Void OnKeyDown(KeyEventArgs e)

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


OnMouseEnter

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel+GalleryChart.OnMouseEnter メソッド

protected virtual Void OnMouseEnter(EventArgs e)

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


OnMouseLeave

TeeChartプログラミングガイド

Steema.TeeChart.GalleryPanel+GalleryChart.OnMouseLeave メソッド

protected virtual Void OnMouseLeave(EventArgs e)

参照

GalleryChart クラス | GalleryChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChart プロパティ

パブリック プロパティ

ApplyZOrder (TChartの継承元) |
Aspect (TChartの継承元) | チャートのビュー特性にアクセスします。
AutoRepaint (TChartの継承元) | ポイントが追加された際にチャートの再描画を有効/無効にします。
Axes (TChartの継承元) | 各軸にアクセスします。
BackColor (TChartの継承元) | チャート矩形を塗りつぶす色を設定します。
Bitmap (TChartの継承元) | チャートで描画されたビットマップイメージを返します。
Canvas (TChartの継承元) |
Chart (TChartの継承元) | 描画するチャートを定義します。
ClipPoints (TChartの継承元) |
Export (TChartの継承元) | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Font (TChartの継承元) | フォント特性を定義します。
Footer (TChartの継承元) | チャート下部に表示されるテキストを定義します。
ForeColor (TChartの継承元) | TChartオブジェクトの前面の色を取得します。
Frame (TChartの継承元) | チャートの背面の周りの枠の特性を設定します。このプロパティの代わりにtChart1.Walls.Back.Penプロパティを使用してください。
GetCursorPos (TChartの継承元) |
Graphics3D (TChartの継承元) | TeeChartの描画プロパティやメソッドにアクセスするために使用してください。
Header (TChartの継承元) | チャート上部に表示されるテキストを定義します。
Import (TChartの継承元) | チャートのインポートのプロパティやメソッドにアクセスします。
Item (TChartの継承元) | デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
Legend (TChartの継承元) | 凡例の特性にアクセスします。
Metafile (TChartの継承元) | チャートで描画されたメタファイルイメージを返します。
Metafiling (TChartの継承元) | チャートがメタファイルイメージに内部で描画している場合、trueを返します。
Page (TChartの継承元) | チャートの複数ページ特性にアクセスします。
Panel (TChartの継承元) | チャート背面の可視属性を設定します。
Panning (TChartの継承元) | チャートのパン特性にアクセスします。
Printer (TChartの継承元) | 印刷に関連したプロパティやメソッドにアクセスします。
Printing (TChartの継承元) | 印刷するチャートを取得/設定します。
Series (TChartの継承元) | チャートに含まれる系列のリストにアクセスします。
SeriesCount (TChartの継承元) | チャート内の系列数を返します。このプロパティの代わりにTChart.Series.Countプロパティを使用してください。
Site (TChartの継承元) | TChartコントロールのサイトを取得/設定します。
SubFooter (TChartの継承元) | フッターの上に表示されるテキストを定義します。
SubHeader (TChartの継承元) | ヘッダーの下に表示されるテキストを定義します。
Text (TChartの継承元) | フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定します。
TimerEnabled (TChartの継承元) | チャートを自動的に再描画する内部タイマーを有効/無効にします。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
TimerInterval (TChartの継承元) | チャートを自動的に再描画するミリ秒単位のインターバルを取得/設定します。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
Tools (TChartの継承元) | チャート内に含まれているツールコンポーネントのコレクションです。
Walls (TChartの継承元) | チャートの左、下、背面の壁特性にアクセスします。
Zoom (TChartの継承元) | チャートのズーム特性にアクセスします。

プロテクト プロパティ

DefaultSize (TChartの継承元)

参照

GalleryChart クラス | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChartCollection

Steema.TeeChart.GalleryPanel.GalleryChartCollection クラス

内部使用。ギャラリのチャート一覧。

この型のすべてのメンバの一覧については、GalleryChartCollection メンバを参照してください。

System.Object
System.Collections.Generic.List<GalleryPanel+GalleryChart>
public class GalleryChartCollection : List<GalleryChart>
, IList<GalleryChart>
, ICollection<GalleryChart>
, IEnumerable<GalleryChart>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

GalleryChartCollection メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChartCollection 全メンバ

GalleryChartCollection 概要

コンストラクタ

Steema.TeeChart.GalleryPanel.GalleryChartCollection..ctor

パブリック メソッド

Clear

参照

GalleryChartCollection クラス | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel+GalleryChartCollection コンストラクタ

public GalleryPanel+GalleryChartCollection()

参照

GalleryChartCollection クラス | GalleryChartCollection メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChartCollection メソッド

パブリック メソッド

Clear

参照

GalleryChartCollection クラス | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.GalleryPanel+GalleryChartCollection.Clear メソッド

public Void Clear()

参照

GalleryChartCollection クラス | GalleryChartCollection メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GalleryPanel.GalleryChartCollection プロパティ

パブリック プロパティ

Item

参照

GalleryChartCollection クラス | Steema.TeeChart 名前空間


Item

Steema.TeeChart.GalleryPanel+GalleryChartCollection.Item プロパティ

public GalleryChart Item(Int32 index) {get;}

参照

GalleryChartCollection クラス | GalleryChartCollection メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxesChartRectEventArgs

Steema.TeeChart.GetAxesChartRectEventArgs クラス

この型のすべてのメンバの一覧については、GetAxesChartRectEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetAxesChartRectEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

GetAxesChartRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxesChartRectEventArgs 全メンバ

GetAxesChartRectEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

AxesChartRect

参照

GetAxesChartRectEventArgs クラス | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxesChartRectEventArgs コンストラクタ

public GetAxesChartRectEventArgs(Rectangle rect)

参照

GetAxesChartRectEventArgs クラス | GetAxesChartRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxesChartRectEventArgs プロパティ

パブリック プロパティ

AxesChartRect

参照

GetAxesChartRectEventArgs クラス | Steema.TeeChart 名前空間


AxesChartRect

Steema.TeeChart.GetAxesChartRectEventArgs.AxesChartRect プロパティ

public Rectangle AxesChartRect {get; set;}

参照

GetAxesChartRectEventArgs クラス | GetAxesChartRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxesChartRectEventHandler

Steema.TeeChart.GetAxesChartRectEventHandler デリゲート

public delegate GetAxesChartRectEventHandler (Object sender,
     GetAxesChartRectEventArgs e)

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisDrawLabelEventArgs

Steema.TeeChart.GetAxisDrawLabelEventArgs クラス

この型のすべてのメンバの一覧については、GetAxisDrawLabelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetAxisDrawLabelEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisDrawLabelEventArgs 全メンバ

GetAxisDrawLabelEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

DrawLabel | trueの場合、ラベルを描画します。
Text |
X |
Y |
Z |

参照

GetAxisDrawLabelEventArgs クラス | Steema.TeeChart 名前空間


GetAxisDrawLabelEventArgs コンストラクタ

Steema.TeeChart.GetAxisDrawLabelEventArgs コンストラクタ

public GetAxisDrawLabelEventArgs(Int32 X,
     Int32 Y,
     Int32 Z,
     String Text,
     Boolean DrawLabel)

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisDrawLabelEventArgs プロパティ

パブリック プロパティ

DrawLabel | trueの場合、ラベルを描画します。
Text |
X |
Y |
Z |

参照

GetAxisDrawLabelEventArgs クラス | Steema.TeeChart 名前空間


DrawLabel

Steema.TeeChart.GetAxisDrawLabelEventArgs.DrawLabel プロパティ

trueの場合、ラベルを描画します。

public Boolean DrawLabel {get; set;}

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Text

Steema.TeeChart.GetAxisDrawLabelEventArgs.Text プロパティ

public String Text {get; set;}

解説

Labelアイテムのテキストを取得/設定します。

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


X

Steema.TeeChart.GetAxisDrawLabelEventArgs.X プロパティ

public Int32 X {get; set;}

解説

Labelアイテムの特定のX座標を取得/設定します。

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Y

Steema.TeeChart.GetAxisDrawLabelEventArgs.Y プロパティ

public Int32 Y {get; set;}

解説

Labelアイテムの特定のY座標を取得/設定します。

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Z

Steema.TeeChart.GetAxisDrawLabelEventArgs.Z プロパティ

public Int32 Z {get; set;}

解説

Labelアイテムの特定のZ座標を取得/設定します。

参照

GetAxisDrawLabelEventArgs クラス | GetAxisDrawLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisDrawLabelEventHandler

Steema.TeeChart.GetAxisDrawLabelEventHandler デリゲート

public delegate GetAxisDrawLabelEventHandler (Object sender,
     GetAxisDrawLabelEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisLabelEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.GetAxisLabelEventArgs クラス

GetAxisLabelイベントのデータを提供します。GetAxisLabelEventHandlerを参照してください。

この型のすべてのメンバの一覧については、GetAxisLabelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetAxisLabelEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisLabelEventArgs 全メンバ

GetAxisLabelEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

LabelText | 軸ラベルテキストを修正します。
Series | 読み込み専用。ラベル系列。
ValueIndex | 読み込み専用。ラベルのインデックス。

参照

GetAxisLabelEventArgs クラス | Steema.TeeChart 名前空間


GetAxisLabelEventArgs コンストラクタ

Steema.TeeChart.GetAxisLabelEventArgs コンストラクタ

public GetAxisLabelEventArgs(Series s,
     Int32 valueIndex,
     String labelText)

参照

GetAxisLabelEventArgs クラス | GetAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisLabelEventArgs プロパティ

パブリック プロパティ

LabelText | 軸ラベルテキストを修正します。
Series | 読み込み専用。ラベル系列。
ValueIndex | 読み込み専用。ラベルのインデックス。

参照

GetAxisLabelEventArgs クラス | Steema.TeeChart 名前空間


LabelText

TeeChartプログラミングガイド

Steema.TeeChart.GetAxisLabelEventArgs.LabelText プロパティ

軸ラベルテキストを修正します。

public String LabelText {get; set;}

解説

ValueIndexで指定する軸ラベルテキストを修正するために使用します。

例

[C]

private void button1_Click(object sender, System.EventArgs e)
{
     barSeries1.Add(13,"1st");
     barSeries1.Add(25,"2nd");
     barSeries1.Add(23,"3rd");
     barSeries1.Add(14,"4th");
     barSeries1.Add(26,"5th");
}

private void tChart1_GetAxisLabel(object sender, Steema.TeeChart.TChart.GetAxisLabelEventArgs e)
{
     if (sender == tChart1.Axes.Bottom && e.ValueIndex>3)
        e.LabelText=e.LabelText+" Add text";
}

参照

GetAxisLabelEventArgs クラス | GetAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.GetAxisLabelEventArgs.Series プロパティ

読み込み専用。ラベル系列。
public Series Series {get;}

解説

チャートコンポーネントが保持し、描画する系列のリストです。

参照

GetAxisLabelEventArgs クラス | GetAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


ValueIndex

TeeChartプログラミングガイド

Steema.TeeChart.GetAxisLabelEventArgs.ValueIndex プロパティ

読み込み専用。ラベルのインデックス。

public Int32 ValueIndex {get;}

解説

系列の値にアクセスするために使用されます。値を検索または変更するためにValueIndexプロパティを使用することができます。

例

[C#]

private void button1_Click(object sender, System.EventArgs e)
{
     barSeries1.Add(3,"1st");
     barSeries1.Add(5,"2nd");
     barSeries1.Add(3,"3rd");
     barSeries1.Add(4,"4th");
     barSeries1.Add(6,"5th");
}

private void tChart1_GetAxisLabel(object sender, Steema.TeeChart.GetAxisLabelEventArgs e)
{
     if (sender == tChart1.Axes.Bottom && e.ValueIndex>3)
        e.LabelText=e.LabelText+" my label";
}
e.ValueIndexは、Labels.StyleがTextあるいはMarksではない場合、常に-1になります。
メモ：数値は文字に変換する必要があります。
例

private void tChart1_GetAxisLabel(object sender, Steema.TeeChart.GetAxisLabelEventArgs e)
{
     if (sender == tChart1.Axes.Bottom && e.ValueIndex>3)
        e.LabelText=e.LabelText+" "+e.ValueIndex.ToString();
}

参照

GetAxisLabelEventArgs クラス | GetAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetAxisLabelEventHandler

Steema.TeeChart.GetAxisLabelEventHandler デリゲート

AxisLabelのイベントハンドラ。
public delegate GetAxisLabelEventHandler (Object sender,
     GetAxisLabelEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendPosEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendPosEventArgs クラス

GetLegendPosイベントのデータを提供します。GetLegendPosEventHandlerを参照してください。

この型のすべてのメンバの一覧については、GetLegendPosEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetLegendPosEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendPosEventArgs 全メンバ

GetLegendPosEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Index
X
XColor
Y

参照

GetLegendPosEventArgs クラス | Steema.TeeChart 名前空間


GetLegendPosEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendPosEventArgs コンストラクタ

public GetLegendPosEventArgs(Int32 index,
     Int32 x,
     Int32 y,
     Int32 xColor)

参照

GetLegendPosEventArgs クラス | GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendPosEventArgs プロパティ

パブリック プロパティ

Index
X
XColor
Y

参照

GetLegendPosEventArgs クラス | Steema.TeeChart 名前空間


Index

Steema.TeeChart.GetLegendPosEventArgs.Index プロパティ

public Int32 Index {get;}

解説

凡例項目のインデックスを取得します。

参照

GetLegendPosEventArgs クラス | GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


X

Steema.TeeChart.GetLegendPosEventArgs.X プロパティ

public Int32 X {get; set;}

解説

凡例項目の特定のX座標を取得/設定します。

参照

GetLegendPosEventArgs クラス | GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


XColor

Steema.TeeChart.GetLegendPosEventArgs.XColor プロパティ

public Int32 XColor {get; set;}

解説

凡例項目の特定のXColor座標を取得/設定します。

参照

GetLegendPosEventArgs クラス | GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


Y

Steema.TeeChart.GetLegendPosEventArgs.Y プロパティ

public Int32 Y {get; set;}

解説

凡例項目の特定のY座標を取得/設定します。

参照

GetLegendPosEventArgs クラス | GetLegendPosEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendPosEventHandler

Steema.TeeChart.GetLegendPosEventHandler デリゲート

GetLegendPosのイベントハンドラ。
public delegate GetLegendPosEventHandler (Object sender,
     GetLegendPosEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendRectEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendRectEventArgs クラス

GetLegendRectイベントのデータを提供します。GetLegendRectEventHandlerを参照してください。

この型のすべてのメンバの一覧については、GetLegendRectEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetLegendRectEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetLegendRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendRectEventArgs 全メンバ

GetLegendRectEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Rectangle

参照

GetLegendRectEventArgs クラス | Steema.TeeChart 名前空間


GetLegendRectEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendRectEventArgs コンストラクタ

public GetLegendRectEventArgs(Rectangle rect)

参照

GetLegendRectEventArgs クラス | GetLegendRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendRectEventArgs プロパティ

パブリック プロパティ

Rectangle

参照

GetLegendRectEventArgs クラス | Steema.TeeChart 名前空間


Rectangle

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendRectEventArgs.Rectangle プロパティ

public Rectangle Rectangle {get; set;}

参照

GetLegendRectEventArgs クラス | GetLegendRectEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendRectEventHandler

Steema.TeeChart.GetLegendRectEventHandler デリゲート

GetLegendRectのイベントハンドラ。
public delegate GetLegendRectEventHandler (Object sender,
     GetLegendRectEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendTextEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendTextEventArgs クラス

GetLegendTextイベントのデータを提供します。GetLegendTextEventHandlerを参照してください。

この型のすべてのメンバの一覧については、GetLegendTextEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetLegendTextEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetLegendTextEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendTextEventArgs 全メンバ

GetLegendTextEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Index |
LegendStyle |
Text | 凡例の値にテキストを設定します。

参照

GetLegendTextEventArgs クラス | Steema.TeeChart 名前空間


GetLegendTextEventArgs コンストラクタ

Steema.TeeChart.GetLegendTextEventArgs コンストラクタ

public GetLegendTextEventArgs(LegendStyles legendStyle,
     Int32 index,
     String text)

参照

GetLegendTextEventArgs クラス | GetLegendTextEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendTextEventArgs プロパティ

パブリック プロパティ

Index |
LegendStyle |
Text | 凡例の値にテキストを設定します。

参照

GetLegendTextEventArgs クラス | Steema.TeeChart 名前空間


Index

Steema.TeeChart.GetLegendTextEventArgs.Index プロパティ

public Int32 Index {get;}

解説

凡例のインデックスを指定するために使用してください。

参照

GetLegendTextEventArgs クラス | GetLegendTextEventArgs メンバ | Steema.TeeChart 名前空間


LegendStyle

Steema.TeeChart.GetLegendTextEventArgs.LegendStyle プロパティ

public LegendStyles LegendStyle {get;}

解説

デフォルト値：lsAuto

チャートの凡例に、どの項目を表示するかを定義します。

lsSeriesスタイルは、チャート内のアクティブなすべての系列のSeries.Titleを表示します。系列タイトルが空の場合、系列のNameプロパティが使用されます。

lsValuesスタイルは、チャートで最初にアクティブな系列の各ポイント値の文字列を表示します。

lsLastValuesスタイルは、チャートでアクティブなすべての系列の最後のポイント値やSeries.Titleを表示します。これは、リアルタイムのチャートの表示のような新しいポイントが各系列の最後に追加される場合に利用できます。

lsAuto（デフォルト）スタイルは、チャートでアクティブな系列が1つ以上ある場合はlsSeries、1つしかない場合はlsValuesとみなされます。

Legend.TextStyleプロパティは、系列のポイント値の書式を定義します。

参照

GetLegendTextEventArgs クラス | GetLegendTextEventArgs メンバ | Steema.TeeChart 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.GetLegendTextEventArgs.Text プロパティ

凡例の値にテキストを設定します。

public String Text {get; set;}

解説

凡例の値に表示するテキストを設定します。

例

[C]

private void tChart1_GetLegendText(object sender, Steema.TeeChart.TChart.GetLegendTextEventArgs e)
{
     if (e.Index < 3)
        e.Text = e.Text + " my text";
}

参照

GetLegendTextEventArgs クラス | GetLegendTextEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetLegendTextEventHandler

Steema.TeeChart.GetLegendTextEventHandler デリゲート

GetLegendTextのイベントハンドラ。
public delegate GetLegendTextEventHandler (Object sender,
     GetLegendTextEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.GetNextAxisLabelEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.GetNextAxisLabelEventArgs クラス

GetNextAxisLabelイベントのデータを提供します。GetNextAxisLabelEventHandlerを参照してください。

この型のすべてのメンバの一覧については、GetNextAxisLabelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetNextAxisLabelEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

GetNextAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetNextAxisLabelEventArgs 全メンバ

GetNextAxisLabelEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

LabelIndex
LabelValue
Stop

参照

GetNextAxisLabelEventArgs クラス | Steema.TeeChart 名前空間


GetNextAxisLabelEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.GetNextAxisLabelEventArgs コンストラクタ

public GetNextAxisLabelEventArgs(Int32 labelIndex,
     Double labelValue,
     Boolean doStop)

参照

GetNextAxisLabelEventArgs クラス | GetNextAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetNextAxisLabelEventArgs プロパティ

パブリック プロパティ

LabelIndex
LabelValue
Stop

参照

GetNextAxisLabelEventArgs クラス | Steema.TeeChart 名前空間


LabelIndex

Steema.TeeChart.GetNextAxisLabelEventArgs.LabelIndex プロパティ

public Int32 LabelIndex {get;}

解説

LabelIndexパラメーターは、ラベルのインデックスを示します。

参照

GetNextAxisLabelEventArgs クラス | GetNextAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


LabelValue

Steema.TeeChart.GetNextAxisLabelEventArgs.LabelValue プロパティ

public Double LabelValue {get; set;}

解説

LabelValueパラメーターは、必要な軸ラベル値を指定します。

参照

GetNextAxisLabelEventArgs クラス | GetNextAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Stop

Steema.TeeChart.GetNextAxisLabelEventArgs.Stop プロパティ

public Boolean Stop {get; set;}

解説

Stopパラメータはデフォルトではfalseになっています。最初にこのイベントを呼び出した際にtrueになっていない場合、TeeChartはデフォルトの軸ラベルを描画します。

参照

GetNextAxisLabelEventArgs クラス | GetNextAxisLabelEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.GetNextAxisLabelEventHandler

Steema.TeeChart.GetNextAxisLabelEventHandler デリゲート

GetNextAxisLabelのイベントハンドラ
public delegate GetNextAxisLabelEventHandler (Object sender,
     GetNextAxisLabelEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Header

Steema.TeeChart.Header クラス

チャートの上部に表示されるテキスト。

この型のすべてのメンバの一覧については、Header メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
Steema.TeeChart.Title
public class Header : Title , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Header メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Header 全メンバ

Header 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked (Titleの継承元) | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw (Titleの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AdjustFrame (Titleの継承元) | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment (Titleの継承元) | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Titleの継承元) | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Titleの継承元) | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop (Titleの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Titleの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Header クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Header コンストラクタ

オーバーロードの一覧

public Header()
public Header(Steema.TeeChart.Chart)
public Header(Steema.TeeChart.Chart, System.Boolean)

参照

Header クラス | Header メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Header コンストラクタ

public Header()

参照

Header コンストラクタのオーバーロードの一覧 | Header クラス | Header メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Header コンストラクタ

public Header(Chart c)

参照

Header コンストラクタのオーバーロードの一覧 | Header クラス | Header メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Header コンストラクタ

public Header(Chart c,
     Boolean startVisible)

参照

Header コンストラクタのオーバーロードの一覧 | Header クラス | Header メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Header フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop (Titleの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Header クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Header メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked (Titleの継承元) | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw (Titleの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Titleの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Header クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Header プロパティ

パブリック プロパティ

AdjustFrame (Titleの継承元) | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment (Titleの継承元) | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Titleの継承元) | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Titleの継承元) | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Header クラス | Steema.TeeChart 名前空間


Steema.TeeChart.IChart

Steema.TeeChart.IChart Interface

共通のチャート特性のインターフェイス。
public interface IChart

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

IChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.IChart 全メンバ

IChart 概要

パブリック メソッド

CheckBackground
CheckClickSeries
CheckGetAxisLabelAssigned
CheckTitle
DoAfterDraw
DoAllowScroll
DoBeforeDraw
DoBeforeDrawAxes
DoBeforeDrawSeries
DoChartPrint
DoClickAxis
DoClickLegend
DoClickSeries
DoGetAxesChartRect
DoGetAxisLabel
DoGetLegendPos
DoGetLegendRectangle
DoGetLegendSize
DoGetLegendText
DoGetNextAxisLabel
DoInvalidate
DoScroll
DoSetControlStyle
DoUndoneZoom
DoZoomed
DrawBackColor
FindParentForm
GetContainer
GetControl
GetCursor
IsWebForm
PointToScreen
RefreshControl
SetChart
SetCursor

参照

IChart インターフェイス | Steema.TeeChart 名前空間


Steema.TeeChart.IChart メソッド

パブリック メソッド

CheckBackground
CheckClickSeries
CheckGetAxisLabelAssigned
CheckTitle
DoAfterDraw
DoAllowScroll
DoBeforeDraw
DoBeforeDrawAxes
DoBeforeDrawSeries
DoChartPrint
DoClickAxis
DoClickLegend
DoClickSeries
DoGetAxesChartRect
DoGetAxisLabel
DoGetLegendPos
DoGetLegendRectangle
DoGetLegendSize
DoGetLegendText
DoGetNextAxisLabel
DoInvalidate
DoScroll
DoSetControlStyle
DoUndoneZoom
DoZoomed
DrawBackColor
FindParentForm
GetContainer
GetControl
GetCursor
IsWebForm
PointToScreen
RefreshControl
SetChart
SetCursor

参照

IChart インターフェイス | Steema.TeeChart 名前空間


CheckBackground

Steema.TeeChart.IChart.CheckBackground メソッド

public abstract Void CheckBackground(Object sender,
     MouseEventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


CheckClickSeries

Steema.TeeChart.IChart.CheckClickSeries メソッド

public abstract Boolean CheckClickSeries()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


CheckGetAxisLabelAssigned

Steema.TeeChart.IChart.CheckGetAxisLabelAssigned メソッド

public abstract Boolean CheckGetAxisLabelAssigned()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


CheckTitle

Steema.TeeChart.IChart.CheckTitle メソッド

public abstract Void CheckTitle(Title ATitle,
     MouseEventArgs e,
     Keys Shift)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoAfterDraw

Steema.TeeChart.IChart.DoAfterDraw メソッド

public abstract Void DoAfterDraw()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoAllowScroll

Steema.TeeChart.IChart.DoAllowScroll メソッド

public abstract Boolean DoAllowScroll(Axis a,
     Double Delta,
     Double& Min,
     Double& Max)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoBeforeDraw

Steema.TeeChart.IChart.DoBeforeDraw メソッド

public abstract Void DoBeforeDraw()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoBeforeDrawAxes

Steema.TeeChart.IChart.DoBeforeDrawAxes メソッド

public abstract Void DoBeforeDrawAxes()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoBeforeDrawSeries

Steema.TeeChart.IChart.DoBeforeDrawSeries メソッド

public abstract Void DoBeforeDrawSeries()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoChartPrint

Steema.TeeChart.IChart.DoChartPrint メソッド

public abstract Void DoChartPrint(Object sender,
     PrintPageEventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoClickAxis

Steema.TeeChart.IChart.DoClickAxis メソッド

public abstract Void DoClickAxis(Axis a,
     MouseEventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoClickLegend

Steema.TeeChart.IChart.DoClickLegend メソッド

public abstract Void DoClickLegend(Object sender,
     MouseEventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoClickSeries

Steema.TeeChart.IChart.DoClickSeries メソッド

public abstract Void DoClickSeries(Object sender,
     Series s,
     Int32 valueIndex,
     MouseEventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetAxesChartRect

Steema.TeeChart.IChart.DoGetAxesChartRect メソッド

public abstract Void DoGetAxesChartRect(Object sender,
     Rectangle& rect)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetAxisLabel

Steema.TeeChart.IChart.DoGetAxisLabel メソッド

public abstract Void DoGetAxisLabel(Object sender,
     Series s,
     Int32 valueIndex,
     String& labelText)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetLegendPos

Steema.TeeChart.IChart.DoGetLegendPos メソッド

public abstract Void DoGetLegendPos(Object sender,
     Int32 index,
     Int32& X,
     Int32& Y,
     Int32& XColor)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetLegendRectangle

Steema.TeeChart.IChart.DoGetLegendRectangle メソッド

public abstract Void DoGetLegendRectangle(Object sender,
     Rectangle& rect)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetLegendSize

Steema.TeeChart.IChart.DoGetLegendSize メソッド

public abstract Void DoGetLegendSize(Object sender,
     Int32& Size)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetLegendText

Steema.TeeChart.IChart.DoGetLegendText メソッド

public abstract Void DoGetLegendText(Object sender,
     LegendStyles LegendStyle,
     Int32 Index,
     String& Text)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoGetNextAxisLabel

Steema.TeeChart.IChart.DoGetNextAxisLabel メソッド

public abstract Void DoGetNextAxisLabel(Object sender,
     Int32 labelIndex,
     Double& labelValue,
     Boolean& Stop)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoInvalidate

Steema.TeeChart.IChart.DoInvalidate メソッド

public abstract Void DoInvalidate()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoScroll

Steema.TeeChart.IChart.DoScroll メソッド

public abstract Void DoScroll(Object sender,
     EventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoSetControlStyle

Steema.TeeChart.IChart.DoSetControlStyle メソッド

public abstract Void DoSetControlStyle()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoUndoneZoom

Steema.TeeChart.IChart.DoUndoneZoom メソッド

public abstract Void DoUndoneZoom(Object sender,
     EventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DoZoomed

Steema.TeeChart.IChart.DoZoomed メソッド

public abstract Void DoZoomed(Object sender,
     EventArgs e)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


DrawBackColor

Steema.TeeChart.IChart.DrawBackColor メソッド

public abstract Void DrawBackColor(Graphics3D g)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


FindParentForm

Steema.TeeChart.IChart.FindParentForm メソッド

public abstract Object FindParentForm()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


GetContainer

Steema.TeeChart.IChart.GetContainer メソッド

public abstract IContainer GetContainer()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


GetControl

Steema.TeeChart.IChart.GetControl メソッド

public abstract Control GetControl()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


GetCursor

Steema.TeeChart.IChart.GetCursor メソッド

public abstract Cursor GetCursor()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


IsWebForm

Steema.TeeChart.IChart.IsWebForm メソッド

public abstract Boolean IsWebForm()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


PointToScreen

Steema.TeeChart.IChart.PointToScreen メソッド

public abstract Point PointToScreen(Point p)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


RefreshControl

Steema.TeeChart.IChart.RefreshControl メソッド

public abstract Void RefreshControl()

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


SetChart

Steema.TeeChart.IChart.SetChart メソッド

public abstract Void SetChart(Chart c)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


SetCursor

Steema.TeeChart.IChart.SetCursor メソッド

public abstract Void SetCursor(Cursor c)

参照

IChart インターフェイス | IChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ITeeEventListener

TeeChartプログラミングガイド

Steema.TeeChart.ITeeEventListener インターフェイス

コンポーネント間のコミュニケーションをサポートします。

public abstract interface ITeeEventListener

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

ITeeEventListener メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ITeeEventListener 全メンバ

ITeeEventListener 概要

パブリック メソッド

TeeEvent

参照

ITeeEventListener インターフェイス | Steema.TeeChart 名前空間


Steema.TeeChart.ITeeEventListener メソッド

パブリック メソッド

TeeEvent

参照

ITeeEventListener インターフェイス | Steema.TeeChart 名前空間


TeeEvent

Steema.TeeChart.ITeeEventListener.TeeEvent メソッド

public abstract Void TeeEvent(TeeEvent e)

参照

ITeeEventListener インターフェイス | ITeeEventListener メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend

Steema.TeeChart.Legend クラス

チャートの凡例特性にアクセスします。

この型のすべてのメンバの一覧については、Legend メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class Legend : TextShapePosition , IComponent, IDisposable
, ICloneable

解説

Legendには、書式や大きさに関するプロパティが多数用意されています。

凡例はチャートの系列タイトルや書式化した系列値を出力した矩形です。LegendStyleプロパティを設定することにより、これらを変更することができます。

Alignmentプロパティは、凡例の位置を定義します。
凡例はチャートの上、左、右、下に配置することができます。またはTopLeftPosプロパティを使用してカスタム位置に配置することができます。

左や右の凡例の位置揃えは、各アイテムを縦方向に一列に揃えた凡例を定義します。

上や下の凡例の位置揃えは、各項目を横方向に一行あるいは複数行に揃えた凡例を定義します。

凡例自体が、チャートのスペースに合わせて表示する項目を自動的に減らします。

ResizeChartプロパティは、チャートのポイントスペースを減らすために、凡例のサイズを使用すべきかどうかを制御します。

GetLegendRectイベントは、凡例のサイズと位置の変更ができます。

GetLegendPosイベントは、凡例のアイテムの位置をXY座標で指定することができます。

HorizMarginプロパティやVertMarginプロパティは、チャートと凡例との左右および上下のマージンを制御します。

これらにより、ほぼ完全に凡例の制御を行うことができます。詳細につきましては｢チュートリアル 第5章 - 凡例のデザイン｣を参照してください。

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend 全メンバ

Legend 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

ColumnWidthAuto
ColumnWidths
Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | クリックされた凡例ポイントのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
FormattedLegend | 凡例の位置に該当するテキストの文字列を返します。
FormattedValue | 指定した系列とポイントインデックス値に該当する凡例のテキストを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint |

パブリック プロパティ

Alignment | 凡例の位置を定義します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CheckBoxes | 凡例のチェックボックスの表示を有効/無効にします。
ClipText (TextShapeの継承元) |
Color | 凡例ボックスの背面の色を設定します。
CurrentPage | チャートがページ分割されている場合、凡例を現在のページ項目のみの表示にするかどうか定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
DividingLines | 凡例の分割線のペンの属性を設定します。
FirstValue | 最初に表示される凡例項目のインデックス値を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
FontSeriesColor | 凡例テキストのフォント色を系列色と同じ色にするかどうか設定します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
HorizMargin | 凡例とチャート矩形の間にあるマージンを画面ピクセル数で定義します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Inverted | Trueの場合、凡例の内容を反対方向に描画します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
LegendStyle | チャートの凡例にどの項目を表示するかを定義します。
Lines | 凡例のテキスト行の配列にアクセスします。
MaxNumRows | 凡例の位置が上あるいは下の場合、表示する凡例の最大行を定義します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
ResizeChart | 凡例とチャートが重なって描画しないようにチャートを自動的にリサイズするかどうか定義します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Series | 凡例に表示する系列を設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Symbol | 各凡例の項目に対応するカラーボックス（シンボル）の幅や位置を設定します。
Text | 凡例にテキストを追加します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
TextStyle | 凡例のテキスト項目の書式化のスタイルを定義します。
Title | 凡例の上部に表示するタイトルテキストや、その特性を設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
TopLeftPos | 凡例の上端の位置をチャート全体の高さに対するパーセントで設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Vertical | 読み込み専用。凡例が左あるいは右に表示されている場合、Trueを返します。
VertMargin | 凡例とチャート矩形の間の垂直マージンをピクセル単位で定義します。
VertSpacing | 凡例の項目と項目の間の垂直スペースをピクセル単位で設定します。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape
CalcBounds (TextShapeの継承元)
DoMouseDown
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Legend クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Legend コンストラクタ

オーバーロードの一覧

public Legend()
public Legend(Steema.TeeChart.Chart)

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend コンストラクタ

public Legend()

参照

Legend コンストラクタのオーバーロードの一覧 | Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend コンストラクタ

public Legend(Chart c)

参照

Legend コンストラクタのオーバーロードの一覧 | Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend フィールド

パブリック フィールド

ColumnWidthAuto
ColumnWidths
Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Legend クラス | Steema.TeeChart 名前空間


ColumnWidthAuto

TeeChartプログラミングガイド

Steema.TeeChart.Legend.ColumnWidthAuto フィールド

public Boolean ColumnWidthAuto

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


ColumnWidths

TeeChartプログラミングガイド

Steema.TeeChart.Legend.ColumnWidths フィールド

public Int32[] ColumnWidths

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | クリックされた凡例ポイントのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
FormattedLegend | 凡例の位置に該当するテキストの文字列を返します。
FormattedValue | 指定した系列とポイントインデックス値に該当する凡例のテキストを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint |

プロテクト メソッド

AssignShape
CalcBounds (TextShapeの継承元)
DoMouseDown
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Legend クラス | Steema.TeeChart 名前空間


AssignShape

Steema.TeeChart.Legend.AssignShape メソッド

protected abstract Void AssignShape(Shape s)

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Legend.Clicked メソッド

クリックされた凡例ポイントのインデックスを返します。

public Int32 Clicked(Int32 x,
     Int32 y)

解説

クリックされた凡例ポイントのインデックスを返します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


DoMouseDown

TeeChartプログラミングガイド

Steema.TeeChart.Legend.DoMouseDown メソッド

protected internal Boolean DoMouseDown(Int32 x,
     Int32 y)

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


FormattedLegend

TeeChartプログラミングガイド

Steema.TeeChart.Legend.FormattedLegend メソッド

凡例の位置に該当するテキストの文字列を返します。

public String FormattedLegend(Int32 seriesOrValueIndex)

解説

凡例の位置に該当するテキストの文字列を返します。

凡例の位置は、Legend.LegendStyleプロパティに依存しています。LegendStyleがlsSeriesの場合、テキスト文字列はSeriesOrValueIndex番目のアクティブな系列タイトルになります。LegendStyleがlsValuesの場合、テキスト文字列はチャートの最初のアクティブな系列のSeriesOrValueIndex番目の値で書式化されます。LegendStyleがlsAutoで、チャートにアクティブな系列が1つしかない場合、LegendStyleはlsValuesであるとみなされます。アクティブな系列が1つ以上あると、LegendStyleはlsSeriesになります。

値は、LegendTextStyleプロパティに従って書式化されます。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


FormattedValue

Steema.TeeChart.Legend.FormattedValue メソッド

指定した系列とポイントインデックス値に該当する凡例テキストを返します。
public String FormattedValue(Series aSeries,
     Int32 valueIndex)

解説

指定した系列とポイントインデックス値に該当する凡例のテキストを返します。Legend.LegendTextStyleプロパティは、ポイント値やラベルを書式化するために使用されます。

例

このコードは、凡例の5番目のテキストを表示します。

[C#]

MsgBox tChart1.Legend.FormattedValue(0, 3)

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Legend.Paint メソッド

public override Void Paint(Graphics3D g,
     Rectangle rect)

解説

チャートに複数の凡例を描くために使用されます。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Legend プロパティ

パブリック プロパティ

Alignment | 凡例の位置を定義します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CheckBoxes | 凡例のチェックボックスの表示を有効/無効にします。
ClipText (TextShapeの継承元) |
Color | 凡例ボックスの背面の色を設定します。
CurrentPage | チャートがページ分割されている場合、凡例を現在のページ項目のみの表示にするかどうか定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
DividingLines | 凡例の分割線のペンの属性を設定します。
FirstValue | 最初に表示される凡例項目のインデックス値を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
FontSeriesColor | 凡例テキストのフォント色を系列色と同じ色にするかどうか設定します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
HorizMargin | 凡例とチャート矩形の間にあるマージンを画面ピクセル数で定義します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Inverted | Trueの場合、凡例の内容を反対方向に描画します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
LegendStyle | チャートの凡例にどの項目を表示するかを定義します。
Lines | 凡例のテキスト行の配列にアクセスします。
MaxNumRows | 凡例の位置が上あるいは下の場合、表示する凡例の最大行を定義します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
ResizeChart | 凡例とチャートが重なって描画しないようにチャートを自動的にリサイズするかどうか定義します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Series | 凡例に表示する系列を設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Symbol | 各凡例の項目に対応するカラーボックス（シンボル）の幅や位置を設定します。
Text | 凡例にテキストを追加します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
TextStyle | 凡例のテキスト項目の書式化のスタイルを定義します。
Title | 凡例の上部に表示するタイトルテキストや、その特性を設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
TopLeftPos | 凡例の上端の位置をチャート全体の高さに対するパーセントで設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Vertical | 読み込み専用。凡例が左あるいは右に表示されている場合、Trueを返します。
VertMargin | 凡例とチャート矩形の間の垂直マージンをピクセル単位で定義します。
VertSpacing | 凡例の項目と項目の間の垂直スペースをピクセル単位で設定します。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Legend クラス | Steema.TeeChart 名前空間


Alignment

Steema.TeeChart.Legend.Alignment プロパティ

凡例の位置を定義します。
public LegendAlignments Alignment {get; set;}

解説

デフォルト値：Right

凡例の位置を定義します。

凡例は、チャートの上、左、右、下に配置することができます。

凡例の左および右揃えは、各項目を垂直方向に一列に揃えた凡例を定義します。

凡例の上および下揃えは、各項目を水平方向に一行あるいは複数行に揃えた凡例を定義します。

凡例自体が、チャートのスペースに合わせて表示する項目を自動的に減らします。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


CheckBoxes

TeeChartプログラミングガイド

Steema.TeeChart.Legend.CheckBoxes プロパティ

凡例のチェックボックスの表示を有効/無効にします。

public Boolean CheckBoxes {get; set;}

解説

凡例のチェックボックスの表示を有効/無効にします。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Legend.Color プロパティ

凡例ボックスの背面の色を設定します。

public Color Color {get; set;}

解説

デフォルト値：White

凡例ボックスの背面の色を設定します。

例

[C#]

((Bar)tChart1[0]).Chart.Legend.Color = Color.Blue;

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


CurrentPage

TeeChartプログラミングガイド

Steema.TeeChart.Legend.CurrentPage プロパティ

チャートがページ分割されている場合、凡例を現在のページ項目のみの表示にするかどうか定義します。

public Boolean CurrentPage {get; set;}

解説

チャートがページ分割されている場合、凡例を現在のページ項目のみの表示にするかどうか定義します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


DividingLines

Steema.TeeChart.Legend.DividingLines プロパティ

凡例の分割線のペンの属性を設定します。
public ChartPen DividingLines {get; set;}

解説

凡例の分割線のペンの属性を設定します。

凡例が左揃えあるいは右揃えの場合は水平方向の分割線を描画し、上揃えあるいは下揃えの場合は垂直方向の分割線を描画します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


FirstValue

TeeChartプログラミングガイド

Steema.TeeChart.Legend.FirstValue プロパティ

最初に表示される凡例項目のインデックス値を定義します。

public Int32 FirstValue {get; set;}

解説

デフォルト値：0

最初に表示される凡例項目のインデックス値を定義します。凡例には、すべてのアクティブな系列の名前、あるいは1つの系列のすべてのポイントを表示することができます。

このプロパティは、アクティブな系列の数、あるいは系列ポイントの数を越えないよう適切に設定されます。

このプロパティを使用して、凡例に系列やポイントの特定のサブセットを表示することもできます。

これは、ゼロ以上の値で、かつアクティブな系列の数あるいは系列ポイントの数よりも小さくしなければなりません。

凡例の各スタイルの説明については、Legend.LegendStyleを参照してください。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


FontSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Legend.FontSeriesColor プロパティ

凡例テキストのフォント色を系列色と同じ色にするかどうか設定します。

public Boolean FontSeriesColor {get; set;}

解説

凡例テキストのフォント色を系列色と同じ色にするかどうか設定します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


HorizMargin

TeeChartプログラミングガイド

Steema.TeeChart.Legend.HorizMargin プロパティ

凡例とチャート矩形の間にあるマージンを画面ピクセル数で定義します。

public Int32 HorizMargin {get; set;}

解説

デフォルト値：0

凡例とチャート矩形の間にあるマージンを画面ピクセル数で定義します。デフォルトでは、凡例は全体の凡例の幅に基づく、あらかじめ決められたマージンを計算します。

これは、凡例の位置が左揃えあるいは右揃えになっている場合のみ使用されます。上揃えもしくは下揃えの場合は、Verticalmarginプロパティを使用します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Inverted

TeeChartプログラミングガイド

Steema.TeeChart.Legend.Inverted プロパティ

Trueの場合、凡例の内容を反対方向に描画します。

public Boolean Inverted {get; set;}

解説

デフォルト値：false

Trueの場合、凡例の内容を反対方向に描画します。凡例の位置が左あるいは右に設定されている場合、一番上から下に向かって凡例の内容を表示します。また上あるいは下に設定されている場合、左から右に向かって凡例の内容を表示します。Legend.FirstValueプロパティを使用して、最初の凡例の文字列項目のValueIndexを定義することができます。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Items

Steema.TeeChart.Legend.Items プロパティ

LegendItemオブジェクトのリスト。
public LegendItems Items {get; set;}

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


LegendStyle

Steema.TeeChart.Legend.LegendStyle プロパティ

チャートの凡例にどの項目を表示するかを定義します。
public LegendStyles LegendStyle {get; set;}

解説

デフォルト値：Auto

チャートの凡例にどの項目を表示するかを定義します。

Seriesが指定された場合、チャート内のすべてのアクティブな系列のSeries.Titleを表示します。系列タイトルが空の場合、系列のNameプロパティが使用されます。

Valuesが指定された場合、チャート内で最初のアクティブな系列のすべてのポイント値の文字列を表示します。

LastValuesが指定された場合、チャートのすべてのアクティブな系列の最後のポイント値やSeries.Titleを表示します。これは、リアルタイムのチャートの表示のような新しいポイントが各系列の最後に追加される場合に利用できます。

Auto（デフォルト）が指定された場合、チャートのアクティブな系列が1つ以上ある場合はSeries、1つしかない場合はValuesとみなされます。

Legend.TextStyleプロパティは、系列のポイント値の書式を定義します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Lines

Steema.TeeChart.Legend.Lines プロパティ

凡例のテキスト行の配列にアクセスします。
public String[] Lines {get;}

解説

凡例のテキスト行の配列にアクセスします。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


MaxNumRows

TeeChartプログラミングガイド

Steema.TeeChart.Legend.MaxNumRows プロパティ

凡例の位置が上あるいは下の場合、表示する凡例の最大行を定義します。

public Int32 MaxNumRows {get; set;}

解説

凡例の位置が上あるいは下の場合、表示する凡例の最大行を定義します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


ResizeChart

TeeChartプログラミングガイド

Steema.TeeChart.Legend.ResizeChart プロパティ

凡例とチャートが重なって描画しないようにチャートを自動的にリサイズするかどうか定義します。

public Boolean ResizeChart {get; set;}

解説

デフォルト値：true

凡例とチャートが重なって描画しないようにチャートを自動的にリサイズするかどうか定義します。このプロパティががtrueの場合、Legend.HorizMarginプロパティやLegend.VertMarginプロパティが、チャートのパネルサイズを縮小するピクセル量を制御します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.Legend.Series プロパティ

凡例に表示する系列を設定します。
public Series Series {get; set;}

解説

凡例に表示する系列を設定します。
デフォルトでは、凡例はShowInLegend=Trueの最初のアクティブな系列を選択します。
これは、LegendStyleが「Values」の時のみ有効です。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Symbol

Steema.TeeChart.Legend.Symbol プロパティ

各凡例の項目に対応するカラーボックス（シンボル）の幅や位置を設定します。
public LegendSymbol Symbol {get; set;}

解説

各凡例の項目に対応するカラーボックス（シンボル）の幅や位置を設定します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Legend.Text プロパティ

凡例にテキストを追加します。

public String Text {get; set;}

解説

凡例にテキストを追加します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


TextStyle

Steema.TeeChart.Legend.TextStyle プロパティ

凡例のテキスト項目の書式化のスタイルを定義します。
public LegendTextStyles TextStyle {get; set;}

解説

デフォルト値：LeftValue

凡例のテキスト項目の書式化のスタイルを定義します。

Plainは、ポイントラベルの文字列のみを表示します。

LeftValueは、系列のポイント値を左寄せで表示します。

RightValueは、系列のポイント値を右寄せで表示します。

LeftPercentは、系列のポイント値の百分率を左寄せで表示します。

RightPercentは、系列のポイン値の百分率を右寄せで表示します。

XValueは、系列ポイントのX値を表示します。 これは、X（水平）値を持つ系列のみ有効です。

Valueは、SeriesのValueFormatプロパティを使用して書式化された系列のポイント値を表示します。Percentは、Series PercentFormatプロパティを使用して書式化された系列のポイント値の百分率を表示します。

例

これらは、いろいろな凡例のTextStyle値の例です。

Plain Summer
LeftValue 1234 Summer
RightValue Summer 1234

LeftPercent 5.1 % Summer
RightPercent Summer 5.1 %
**XValue 4321

**X値を持つ系列にのみ適用。Series.Addメソッドを参照してください。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Title

Steema.TeeChart.Legend.Title プロパティ

凡例の上部に表示するタイトルテキストや、その特性を設定します。
public LegendTitle Title {get; set;}

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


TopLeftPos

TeeChartプログラミングガイド

Steema.TeeChart.Legend.TopLeftPos プロパティ

凡例の上端の位置をチャート全体の高さに対するパーセントで指定します。

public Int32 TopLeftPos {get; set;}

解説

デフォルト値：10

凡例の上端の位置をチャート全体の高さに対するパーセントで設定します。

これは、Legend.AlignmentプロパティがLeftあるいはRightになっている場合のみ使用されます。TopあるいはBottomの場合は、ChartのMarginTopプロパティおよびMarginBottomプロパティを使用してください。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Vertical

TeeChartプログラミングガイド

Steema.TeeChart.Legend.Vertical プロパティ

読込み専用。凡例が左あるいは右に表示されている場合、Trueを返します。

public Boolean Vertical {get;}

解説

読込み専用。凡例が左あるいは右に表示されている場合、Trueを返します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


VertMargin

TeeChartプログラミングガイド

Steema.TeeChart.Legend.VertMargin プロパティ

凡例とチャート矩形の間の垂直マージンをピクセル単位で定義します。

public Int32 VertMargin {get; set;}

解説

デフォルト値：0

凡例とチャート矩形の間の垂直マージンをピクセル単位で定義します。Legend.ResizeChartプロパティはtrueで、Legend.AlignmentプロパティはTopあるいはBottomでなければなりません。0の場合、該当するチャートマージンプロパティは、マージンのピクセル量を定義します（Legend.Alignment = Top の代わりにChart.MarginTopを、Legend.Alignment = Bottomの代わりにChart.MarginBottomを使用してください）。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


VertSpacing

TeeChartプログラミングガイド

Steema.TeeChart.Legend.VertSpacing プロパティ

凡例の項目と項目の間の垂直スペースをピクセル単位で設定します。

public Int32 VertSpacing {get; set;}

解説

凡例の項目と項目の間の垂直スペースをピクセル単位で設定します。

参照

Legend クラス | Legend メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendAlignments

TeeChartプログラミングガイド

Steema.TeeChart.LegendAlignments 列挙体

Alignmentプロパティの使用可能な値です。

[Serializable]
public enum LegendAlignments : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Left | TChartの左側に凡例を配置します。
Right | TChartの右側に凡例を配置します。
Top | TChartの上側に凡例を配置します。
Bottom | TChartの下側に凡例を配置します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem

Steema.TeeChart.LegendItem クラス

このクラスは、凡例に配置される各項目の特性について説明します。

この型のすべてのメンバの一覧については、LegendItem メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public sealed class LegendItem : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

LegendItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem 全メンバ

LegendItem 概要

コンストラクタ

コンストラクタ

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Align | テキストの整列オプションを取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Left | 参照された凡例項目の左位置を取得/設定します。
SymbolRectangle | 凡例項目のシンボルの矩形を取得/設定します。
Text | 参照された凡例項目のテキストを取得/設定します。
Text2 | 2列目の凡例項目に表示されたテキストを返します。
Top | 参照された凡例項目の上位置を取得/設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

LegendItem クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem コンストラクタ

public LegendItem(Legend legend)

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

LegendItem クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

LegendItem クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItem プロパティ

パブリック プロパティ

Align | テキストの整列オプションを取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Left | 参照された凡例項目の左位置を取得/設定します。
SymbolRectangle | 凡例項目のシンボルの矩形を取得/設定します。
Text | 参照された凡例項目のテキストを取得/設定します。
Text2 | 2列目の凡例項目に表示されたテキストを返します。
Top | 参照された凡例項目の上位置を取得/設定します。

参照

LegendItem クラス | Steema.TeeChart 名前空間


Align

Steema.TeeChart.LegendItem.Align プロパティ

テキストの整列オプションを取得/設定します。
public StringAlignment Align {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Left

Steema.TeeChart.LegendItem.Left プロパティ

参照された凡例項目の左位置を取得/設定します。
public Int32 Left {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


SymbolRectangle

Steema.TeeChart.LegendItem.SymbolRectangle プロパティ

凡例項目のシンボルの矩形を取得/設定します。
public Rectangle SymbolRectangle {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Text

Steema.TeeChart.LegendItem.Text プロパティ

参照された凡例項目のテキストを取得/設定します。
public String Text {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Text2

Steema.TeeChart.LegendItem.Text2 プロパティ

2列目の凡例項目に表示されたテキストを返します。
public String Text2 {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Top

Steema.TeeChart.LegendItem.Top プロパティ

参照された凡例項目の上位置を取得/設定します。
public Int32 Top {get; set;}

参照

LegendItem クラス | LegendItem メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItems

Steema.TeeChart.LegendItems クラス

LegendItemの凡例項目を保持するためのシリアライズされたリストクラスです。

この型のすべてのメンバの一覧については、LegendItems メンバを参照してください。

System.Object
System.Collections.ArrayList
public sealed class LegendItems : ArrayList , IList, ICollection
, IEnumerable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

LegendItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItems 全メンバ

LegendItems 概要

コンストラクタ

コンストラクタ

パブリック プロパティ

Custom | Trueの場合、凡例は凡例項目を表示するための自動計算を行わず、代わりにItemsプロパティを使用します。
Item | 指定されたインデックス番目のラベル特性にアクセスします。

参照

LegendItems クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItems コンストラクタ

public LegendItems(Legend legend)

参照

LegendItems クラス | LegendItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendItems プロパティ

パブリック プロパティ

Custom | Trueの場合、凡例は凡例項目を表示するための自動計算を行わず、代わりにItemsプロパティを使用します。
Item | 指定されたインデックス番目のラベル特性にアクセスします。

参照

LegendItems クラス | Steema.TeeChart 名前空間


Custom

Steema.TeeChart.LegendItems.Custom プロパティ

Trueの場合、凡例は凡例項目を表示するための自動計算を行わず、代わりにItemsプロパティを使用します。
public Boolean Custom {get; set;}

参照

LegendItems クラス | LegendItems メンバ | Steema.TeeChart 名前空間


Item

Steema.TeeChart.LegendItems.Item プロパティ

指定されたインデックス番目のラベル特性にアクセスします。
public LegendItem Item(Int32 index) {get; set;}

参照

LegendItems クラス | LegendItems メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendStyles

Steema.TeeChart.LegendStyles 列挙体

LegendStyleプロパティの使用可能な値です。
[Serializable]
public sealed enum LegendStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Auto | チャートに複数の系列がある場合、系列タイトルを表示します。
Series | 系列タイトルを表示します（チャートに系列が1つしかない場合も同様）。
Values | チャートの最初のアクティブな系列の値を表示します。
LastValues | チャートの各アクティブな系列の最後の値を表示します（Seriesに類似）。
Palette | MaxNumRowsプロパティで定義されたパレットのエントリー数を表示します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol

Steema.TeeChart.LegendSymbol クラス

凡例のシンボル特性。

この型のすべてのメンバの一覧については、LegendSymbol メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class LegendSymbol : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

LegendSymbol メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol 全メンバ

LegendSymbol 概要

コンストラクタ

Constructor

パブリック イベント

OnSymbolDraw

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Continous | trueの場合、凡例の各カラーボックス（シンボル）はくっついて（垂直方向の空白なし）表示されます。
DefaultPen | trueの場合、凡例のカラーボックス（シンボル）の枠を描くために系列のPenプロパティを使用します。
Pen | 凡例のカラーボックス（シンボル）の枠を描くペンを設定します。
Position | カラーボックス（シンボル）の位置を設定します。
Shadow | 凡例シンボルの周りの影を設定します。
Squared | trueの場合、凡例のカラーボックス（シンボル）は正方形にリサイズされます。
Visible | 凡例のカラーボックス（シンボル）を表示/非表示にします。
Width | 凡例のカラーボックス（シンボル）の幅を設定します。
WidthUnits | カラーボックス（シンボル）の幅を設定するWidthプロパティの単位を設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

DoOnSymbolDraw
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializePen

参照

LegendSymbol クラス | Steema.TeeChart 名前空間


LegendSymbol コンストラクタ

Steema.TeeChart.LegendSymbol コンストラクタ

public LegendSymbol(Legend legend)

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol イベント

パブリック イベント

OnSymbolDraw

参照

LegendSymbol クラス | Steema.TeeChart 名前空間


OnSymbolDraw

Steema.TeeChart.LegendSymbol.OnSymbolDraw イベント

public SymbolDrawEventHandler  OnSymbolDraw

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

LegendSymbol クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

DoOnSymbolDraw
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializePen

参照

LegendSymbol クラス | Steema.TeeChart 名前空間


DoOnSymbolDraw

Steema.TeeChart.LegendSymbol.DoOnSymbolDraw メソッド

protected internal abstract Void DoOnSymbolDraw(Object sender,
     Series series,
     Int32 valueIndex,
     Rectangle R)

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


ShouldSerializePen

Steema.TeeChart.LegendSymbol.ShouldSerializePen メソッド

protected abstract Boolean ShouldSerializePen()

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbol プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Continous | trueの場合、凡例の各カラーボックス（シンボル）はくっついて（垂直方向の空白なし）表示されます。
DefaultPen | trueの場合、凡例のカラーボックス（シンボル）の枠を描くために系列のPenプロパティを使用します。
Pen | 凡例のカラーボックス（シンボル）の枠を描くペンを設定します。
Position | カラーボックス（シンボル）の位置を設定します。
Shadow | 凡例シンボルの周りの影を設定します。
Squared | trueの場合、凡例のカラーボックス（シンボル）は正方形にリサイズされます。
Visible | 凡例のカラーボックス（シンボル）を表示/非表示にします。
Width | 凡例のカラーボックス（シンボル）の幅を設定します。
WidthUnits | カラーボックス（シンボル）の幅を設定するWidthプロパティの単位を設定します。

参照

LegendSymbol クラス | Steema.TeeChart 名前空間


Continous

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbol.Continous プロパティ

trueに設定された場合、凡例の各カラーボックス（シンボル）はくっついて（垂直方向の空白なし）表示されます。

public Boolean Continous {get; set;}

解説

デフォルト値：false

trueに設定された場合、凡例の各カラーボックス（シンボル）はくっついて（垂直方向の空白なし）表示されます。falseに設定された場合、凡例の各カラーボックスは離れて表示されます。

例

[C#]

tChart1.Legend.Symbol.Continous = true;

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


DefaultPen

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbol.DefaultPen プロパティ

trueの場合、凡例のカラーボックス（シンボル）の枠を描くために系列のPenプロパティを使用します。

public Boolean DefaultPen {get; set;}

解説

trueの場合、凡例のカラーボックス（シンボル）の枠を描くために系列のPenプロパティを使用します。

falseの場合、凡例のカラーボックス（シンボル）のPenプロパティを使用します。

例

[C#]

tChart1.Legend.Symbol.DefaultPen = false;
tChart1.Legend.Symbol.Pen.Color = Color.Green;

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Pen

Steema.TeeChart.LegendSymbol.Pen プロパティ

凡例のカラーボックス（シンボル）の枠を描くペンを設定します。
public ChartPen Pen {get;}

解説

凡例のカラーボックス（シンボル）の枠を描くペンを設定します。

デフォルトでは、このプロパティは使用されません。その代わりに系列のペンが使用されます。

このプロパティを使用するためには、最初にDefaultPenプロパティをfalseに設定してください。

例

[C#]

tChart1.Legend.Symbol.DefaultPen = false;
tChart1.Legend.Symbol.Pen.Color = Color.Green;

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Position

Steema.TeeChart.LegendSymbol.Position プロパティ

カラーボックス（シンボル）の位置を設定します。
public LegendSymbolPosition Position {get; set;}

解説

デフォルト値：Left
カラーボックス（シンボル）の位置を設定します。以下の値が使用可能です。

Left 凡例項目の左にカラーボックス（シンボル）を配置します。
Right 凡例項目の右にカラーボックス（シンボル）を配置します。

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Shadow

Steema.TeeChart.LegendSymbol.Shadow プロパティ

凡例シンボルの周りの影を設定します。
public Shadow Shadow {get;}

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Squared

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbol.Squared プロパティ

trueの場合、凡例のカラーボックス（シンボル）は正方形にリサイズされます。

public Boolean Squared {get; set;}

解説

trueの場合、凡例のカラーボックス（シンボル）は正方形にリサイズされます。

falseの場合、凡例のカラーボックス（シンボル）の高さは凡例のフォントサイズにより定義され、幅はWidthプロパティやWidthUnitsプロパティを使用して計算されます。

例

[C#]

tChart1.Legend.Symbol.Squared = true;

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbol.Visible プロパティ

凡例のカラーボックス（シンボル）を表示/非表示にします。

public Boolean Visible {get; set;}

解説

凡例のカラーボックス（シンボル）を表示/非表示にします。

例

[C#]

tChart1.Legend.Symbol.Visible = checkBox1.Checked;

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbol.Width プロパティ

凡例のカラーボックス（シンボル）の幅を設定します。

public Int32 Width {get; set;}

解説

デフォルト値：20

凡例のカラーボックス（シンボル）の幅を設定します。

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


WidthUnits

Steema.TeeChart.LegendSymbol.WidthUnits プロパティ

シンボルの幅を設定するWidthプロパティの単位を設定します。
public LegendSymbolSize WidthUnits {get; set;}

解説

デフォルト値：Percent

シンボルの幅を設定するWidthプロパティの単位を設定します。

- Percentは、パーセント単位
- Pixelsは、ピクセル単位

参照

LegendSymbol クラス | LegendSymbol メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbolPosition

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbolPosition 列挙体

凡例のカラーボックス（シンボル）の位置を定義します。

[Serializable]
public enum LegendSymbolPosition : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Left | 凡例のカラーボックス（シンボル）は、凡例項目の左側に表示します。
Right | 凡例のカラーボックス（シンボル）は、凡例項目の右側に表示します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.LegendSymbolSize

TeeChartプログラミングガイド

Steema.TeeChart.LegendSymbolSize 列挙体

凡例のカラーボックス（シンボル）のサイズを定義する単位をです。

[Serializable]
public enum LegendSymbolSize : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Percent | 凡例の幅のパーセンテージとして単位を定義します。
Pixels | ピクセルとして単位を定義します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.LegendTextStyles

TeeChartプログラミングガイド

Steema.TeeChart.LegendTextStyles 列挙体

TextStyleプロパティの使用可能な値です。

[Serializable]
public enum LegendTextStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Plain | 系列ポイントラベルの文字列のみ表示します。
LeftValue | 系列のポイント値を左寄せで表示します。
RightValue | 系列のポイント値を右寄せで表示します。
LeftPercent | 系列のポイント値の百分率を左寄せで表示します。
RightPercent | 系列のポイン値の百分率を右寄せで表示します。
XValue | 系列ポイントのX値を表示します。
Value | 系列のポイント値を表示します。
Percent | 系列のポイント値の百分率を表示します。
XAndValue | 系列ポイントのX値とポイント値を表示します。
XAndPercent | 系列ポイントのX値とポイント値の百分率を表示します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle

Steema.TeeChart.LegendTitle クラス

この型のすべてのメンバの一覧については、LegendTitle メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public sealed class LegendTitle : TextShape , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

LegendTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle 全メンバ

LegendTitle 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

LegendTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle コンストラクタ

オーバーロードの一覧

public LegendTitle(Steema.TeeChart.Chart)
public LegendTitle(Steema.TeeChart.Chart, System.Boolean)

参照

LegendTitle クラス | LegendTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle コンストラクタ

public LegendTitle(Chart c)

参照

LegendTitle コンストラクタのオーバーロードの一覧 | LegendTitle クラス | LegendTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle コンストラクタ

public LegendTitle(Chart c,
     Boolean startVisible)

参照

LegendTitle コンストラクタのオーバーロードの一覧 | LegendTitle クラス | LegendTitle メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

LegendTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

LegendTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.LegendTitle プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

LegendTitle クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Margins

TeeChartプログラミングガイド

Steema.TeeChart.Margins クラス

各ページの印刷マージンにアクセスします。

この型のすべてのメンバの一覧については、Margins メンバを参照してください。

System.Object
public class Margins : Object

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Margins メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Margins 全メンバ

Margins 概要

コンストラクタ

Constructor 用紙の大きさの百分率あるいはインチによるマージンを設定します。PrintMarginUnits

パブリック プロパティ

Bottom | 用紙の大きさの割合により下マージンを設定します。
Left | 用紙の大きさの割合により左マージンを設定します。
Right | 用紙の大きさの割合により右マージンを設定します。
Top | 用紙の大きさの割合により上マージンを設定します。

参照

Margins クラス | Steema.TeeChart 名前空間


Margins コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Margins コンストラクタ

用紙の大きさの百分率あるいはインチによるマージンを設定します。PrintMarginUnits

public Margins(Int32 l,
     Int32 t,
     Int32 r,
     Int32 b)

参照

Margins クラス | Margins メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Margins プロパティ

パブリック プロパティ

Bottom | 用紙の大きさの割合により下マージンを設定します。
Left | 用紙の大きさの割合により左マージンを設定します。
Right | 用紙の大きさの割合により右マージンを設定します。
Top | 用紙の大きさの割合により上マージンを設定します。

参照

Margins クラス | Steema.TeeChart 名前空間


Bottom

TeeChartプログラミングガイド

Steema.TeeChart.Margins.Bottom プロパティ

用紙の大きさの割合により下マージンを設定します。

public Int32 Bottom {get; set;}

解説

用紙の大きさの割合により下マージンを設定します。

参照

Margins クラス | Margins メンバ | Steema.TeeChart 名前空間


Left

TeeChartプログラミングガイド

Steema.TeeChart.Margins.Left プロパティ

用紙の大きさの割合により左マージンを設定します。

public Int32 Left {get; set;}

解説

用紙の大きさの割合により左マージンを設定します。

参照

Margins クラス | Margins メンバ | Steema.TeeChart 名前空間


Right

TeeChartプログラミングガイド

Steema.TeeChart.Margins.Right プロパティ

用紙の大きさの割合により右マージンを設定します。

public Int32 Right {get; set;}

解説

用紙の大きさの割合により右マージンを設定します。

参照

Margins クラス | Margins メンバ | Steema.TeeChart 名前空間


Top

TeeChartプログラミングガイド

Steema.TeeChart.Margins.Top プロパティ

用紙の大きさの割合により上マージンを設定します。

public Int32 Top {get; set;}

解説

用紙の大きさの割合により上マージンを設定します。

参照

Margins クラス | Margins メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.MouseEventKinds

Steema.TeeChart.MouseEventKinds 列挙体

マウスの状態を表します。
[Serializable]
public sealed enum MouseEventKinds : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Down | マウスボタンが押された状態です。
Move | マウスが移動している状態です。
Up | マウスボタンが離された状態です。
Wheel | マウスホイールが操作された状態です。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.NotifySeriesEventArgs

Steema.TeeChart.NotifySeriesEventArgs クラス

この型のすべてのメンバの一覧については、NotifySeriesEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class NotifySeriesEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

NotifySeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.NotifySeriesEventArgs 全メンバ

NotifySeriesEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Series

参照

NotifySeriesEventArgs クラス | Steema.TeeChart 名前空間


NotifySeriesEventArgs コンストラクタ

Steema.TeeChart.NotifySeriesEventArgs コンストラクタ

public NotifySeriesEventArgs(Series s)

参照

NotifySeriesEventArgs クラス | NotifySeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.NotifySeriesEventArgs プロパティ

パブリック プロパティ

Series

参照

NotifySeriesEventArgs クラス | Steema.TeeChart 名前空間


Series

Steema.TeeChart.NotifySeriesEventArgs.Series プロパティ

public Series Series {get;}

参照

NotifySeriesEventArgs クラス | NotifySeriesEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.OtherItemsChangeEventHandler

Steema.TeeChart.OtherItemsChangeEventHandler デリゲート

public delegate OtherItemsChangeEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Page

Steema.TeeChart.Page クラス

チャートのページ特性。

この型のすべてのメンバの一覧については、Page メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Page : TeeBase , IComponent, IDisposable

解説

TeeChartは、チャートを複数ページに分けられます。これは大きなデータを見やすくしたり、データ画面を｢時間で分割している場合｣に便利です。

詳細につきましては、｢チュートリアル 第3章 - チャートのページング｣を参照してください。

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Page メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Page 全メンバ

Page 概要

コンストラクタ

Constructor

パブリック メソッド

FirstValueIndex | カレントページの最初のポイントインデックスを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Next | 次のページに移動します。
Previous | 前のページに移動します。

パブリック プロパティ

AutoScale | 各ページのY軸をスケーリングするために、trueに設定してください。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Count | チャートページ数を返します。
Current | 現在のページ数を取得/設定します。
MaxPointsPerPage | ページ毎に表示されるポイント数を取得/設定します。
ScaleLastPage | 最後のチャートページの表示方法を制御します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Page クラス | Steema.TeeChart 名前空間


Page コンストラクタ

Steema.TeeChart.Page コンストラクタ

public Page(Chart c)

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Page フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Page クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Page メソッド

パブリック メソッド

FirstValueIndex | カレントページの最初のポイントインデックスを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Next | 次のページに移動します。
Previous | 前のページに移動します。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Page クラス | Steema.TeeChart 名前空間


FirstValueIndex

Steema.TeeChart.Page.FirstValueIndex メソッド

カレントページの最初のポイントインデックスを返します。
public Int32 FirstValueIndex()

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Next

TeeChartプログラミングガイド

Steema.TeeChart.Page.Next メソッド

次のページに移動します。

public Void Next()

解説

MaxPointsPerPageプロパティがゼロよりも大きい値になっていると、TeeChartはポイント値を自動的にページに分割します。このメソッドを呼び出すのとPage = Page + 1は同じ結果になります。Countプロパティは、総ページ数を返します。

例

[C#]

private void button1_Click(object sender, System.EventArgs e)
{
     tChart1.Page.Next();
}

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Previous

TeeChartプログラミングガイド

Steema.TeeChart.Page.Previous メソッド

前のページに移動します。

public Void Previous()

解説

MaxPointsPerPageプロパティがゼロより大きい場合、TeeChartは自動的にポイント値をページに分割します。このメソッドを呼び出すのはPage = Page - 1 と同等です。Countプロパティは総ページ数を返します。

例

[C#]

private void button6_Click(object sender, System.EventArgs e)
{
     tChart1.Page.Previous();
}

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Page プロパティ

パブリック プロパティ

AutoScale | 各ページのY軸をスケーリングするために、trueに設定してください。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Count | チャートページ数を返します。
Current | 現在のページ数を取得/設定します。
MaxPointsPerPage | ページ毎に表示されるポイント数を取得/設定します。
ScaleLastPage | 最後のチャートページの表示方法を制御します。

参照

Page クラス | Steema.TeeChart 名前空間


AutoScale

Steema.TeeChart.Page.AutoScale プロパティ

各ページのY軸をスケーリングするために、trueに設定してください。
public Boolean AutoScale {get; set;}

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Count

TeeChartプログラミングガイド

Steema.TeeChart.Page.Count プロパティ

チャートページ数を返します。

public Int32 Count {get;}

解説

チャートのページ数を返します。TChart.Page.MaxPointsPerPageプロパティは、ゼロより大きい値に設定してください。

TChart.Page.Currentプロパティは、現在表示するページを設定します。

例

[C#]

このコードは、チャートを最後のページへ移動します。

private void button1_Click(object sender, System.EventArgs e)
{
     tChart1.Page.Current = tChart1.Page.Count;
}

このコードは、チャートを最初のページへ移動します。

private void button2_Click(object sender, System.EventArgs e)
{
     tChart1.Page.Current = 1;
}

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Current

TeeChartプログラミングガイド

Steema.TeeChart.Page.Current プロパティ

現在のページ数を取得/設定します。

public Int32 Current {get; set;}

解説

実行時専用。

MaxPointsPerPageプロパティがゼロより大きい値の場合、TChart.Page.Currentプロパティはチャートの現在表示するページを設定します。

TChart.Page.MaxPointsPerPageプロパティがゼロより大きい値の場合、TeeChartはすべての系列ポイントを「ページ」に分割します。

各ページは、異なった始点と終点のX座標に割り当てられます。

TChart.Page.NumPagesプロパティはページの合計数を表します。このページ数は、系列ポイント数の合計をMaxPointsPerPageプロパティで割った数と同じです。

TChart.Page.PreviousメソッドやTChart.Page.Nextメソッドは、Currentプロパティを進めたり、戻したりします。

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


MaxPointsPerPage

TeeChartプログラミングガイド

Steema.TeeChart.Page.MaxPointsPerPage プロパティ

ページ毎に表示されるポイント数を取得/設定します。

public Int32 MaxPointsPerPage {get; set;}

解説

デフォルト値：0

「TeeChart AutoPaging」を制御します。

このプロパティをゼロより大きい数字に設定すると、TeeChartが系列ポイントを内部でページ単位に分割します。

Chart.PageプロパティやChart.NumPagesプロパティを使用してチャートのページを操作することができます。

各ページについて、TeeChartが自動的に該当する系列ポイントを計算して表示します。

最後のページには他のページよりも少ない数のポイントを持たせることができます。Chart.ScaleLastPageを使用して、最後のページを「伸縮」させるかどうかを制御することができます。

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


ScaleLastPage

TeeChartプログラミングガイド

Steema.TeeChart.Page.ScaleLastPage プロパティ

最後のチャートページの表示方法を制御します。

public Boolean ScaleLastPage {get; set;}

解説

デフォルト値：true

最後のチャートページの表示方法を制御します。これは、TChart.MaxPointsPerPageプロパティの値がゼロより大きい場合にのみ有効です。trueの場合、最後のチャートページは他のページと同じ水平方向のスケールを持ちます。falseの場合、最後のチャートページのスケールは最後のページの可視ポイント数に基づいて調整されます。

参照

Page クラス | Page メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.PaintChartEventHandler

Steema.TeeChart.PaintChartEventHandler デリゲート

チャート描画のイベントハンドラ。
public delegate PaintChartEventHandler (Object sender,
     Graphics3D g)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Panel

Steema.TeeChart.Panel クラス

チャートのパネル特性。

この型のすべてのメンバの一覧については、Panel メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
[Serializable]
public class Panel : Shape , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Panel 全メンバ

Panel 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
BackImageClear |
Clone (Shapeの継承元) |
Draw | 指定したキャンバスや領域にチャートを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

パブリック プロパティ

BackImageInside | 旧式：Walls.Back.Imageプロパティを使用してください。
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderPen |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
MarginBottom | チャート描画のパーセントとして下マージンを設定します。
MarginLeft | チャート描画のパーセントとして左マージンを設定します。
MarginRight | チャート描画のパーセントとして右マージンを設定します。
MarginTop | チャート描画のパーセントとして上マージンを設定します。
MarginUnits | マージンの単位を設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible | パネルを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Panel クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Panel コンストラクタ

オーバーロードの一覧

public Panel()
public Panel(Steema.TeeChart.Chart)

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Panel コンストラクタ

public Panel()

参照

Panel コンストラクタのオーバーロードの一覧 | Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Panel コンストラクタ

public Panel(Chart c)

参照

Panel コンストラクタのオーバーロードの一覧 | Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Panel フィールド

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Panel クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Panel メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
BackImageClear |
Clone (Shapeの継承元) |
Draw | 指定したキャンバスや領域にチャートを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Panel クラス | Steema.TeeChart 名前空間


BackImageClear

TeeChartプログラミングガイド

Steema.TeeChart.Panel.BackImageClear メソッド

public Void BackImageClear()

旧式

このメソッドの代わりにPanel.Image.Disposeを使用してください。

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Panel.Draw メソッド

指定したキャンバスや領域にチャートを描画します。
public Void Draw(Graphics3D g,
     Rectangle& r)

解説

指定したキャンバスや領域にチャートを描画します。

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Panel プロパティ

パブリック プロパティ

BackImageInside | 旧式：Walls.Back.Imageプロパティを使用してください。
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderPen |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
MarginBottom | チャート描画のパーセントとして下マージンを設定します。
MarginLeft | チャート描画のパーセントとして左マージンを設定します。
MarginRight | チャート描画のパーセントとして右マージンを設定します。
MarginTop | チャート描画のパーセントとして上マージンを設定します。
MarginUnits | マージンの単位を設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible | パネルを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

参照

Panel クラス | Steema.TeeChart 名前空間


BackImageInside

TeeChartプログラミングガイド

Steema.TeeChart.Panel.BackImageInside プロパティ

このプロパティの代わりにWalls.Back.Imageプロパティを使用してください。

public Boolean BackImageInside {get; set;}

旧式

このプロパティの代わりにWalls.Back.Imageプロパティを使用してください。

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


BorderPen

Steema.TeeChart.Panel.BorderPen プロパティ

public ChartPen BorderPen {get; set;}

旧式

このプロパティの代わりに、Penプロパティを使用してください。

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


MarginBottom

TeeChartプログラミングガイド

Steema.TeeChart.Panel.MarginBottom プロパティ

チャート描画のパーセントとして下マージンを設定します。

public Double MarginBottom {get; set;}

解説

デフォルト値：8

各TeeChart.Panelクラスには、4つのマージンプロパティ（MarginLeft、MarginRight、MarginTop、MarginBottom）がります。

これらのプロパティは、チャート描画キャンバスの高さ（上と下のマージン用）と幅（左と右のマージン用）のパーセントとして表現されます。デフォルト値は、上と下のマージンが8で、左と右のマージンが12です。

これらは、MarginUnitsプロパティの変更によりパーセントからピクセルへ単位を変更できます。

例

[C#]

このプロパティは、デザイン時や実行時に変更できます。

tChart1.Panel.MarginBottom = 12;

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


MarginLeft

TeeChartプログラミングガイド

Steema.TeeChart.Panel.MarginLeft プロパティ

チャート描画のパーセントとして左マージンを設定します。

public Double MarginLeft {get; set;}

解説

デフォルト値：12

各TeeChart.Panelクラスには、4つのマージンプロパティ（MarginLeft、MarginRight、MarginTop、MarginBottom）がります。

これらのプロパティは、チャート描画キャンバスの高さ（上と下のマージン用）と幅（左と右のマージン用）のパーセントとして表現されます。デフォルト値は、上と下のマージンが8で、左と右のマージンが12です。

これらは、MarginUnitsプロパティの変更によりパーセントからピクセルへ単位を変更できます。

例

[C#]

このプロパティは、デザイン時や実行時に変更できます。

tChart1.Panel.MarginLeft = 10;

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


MarginRight

TeeChartプログラミングガイド

Steema.TeeChart.Panel.MarginRight プロパティ

チャート描画のパーセントとして右マージンを設定します。

public Double MarginRight {get; set;}

解説

デフォルト値：12

各TeeChart.Panelクラスには、4つのマージンプロパティ（MarginLeft、MarginRight、MarginTop、MarginBottom）がります。

これらのプロパティは、チャート描画キャンバスの高さ（上と下のマージン用）と幅（左と右のマージン用）のパーセントとして表現されます。デフォルト値は、上と下のマージンが8で、左と右のマージンが12です。

これらは、MarginUnitsプロパティの変更によりパーセントからピクセルへ単位を変更できます。

例

[C#]

このプロパティは、デザイン時や実行時に変更できます。

tChart1.Panel.MarginRight = 10;

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


MarginTop

TeeChartプログラミングガイド

Steema.TeeChart.Panel.MarginTop プロパティ

チャート描画のパーセントとして上マージンを設定します。

public Double MarginTop {get; set;}

解説

デフォルト値：8

各TeeChart.Panelクラスには、4つのマージンプロパティ（MarginLeft、MarginRight、MarginTop、MarginBottom）がります。

これらのプロパティは、チャート描画キャンバスの高さ（上と下のマージン用）と幅（左と右のマージン用）のパーセントとして表現されます。デフォルト値は、上と下のマージンが8で、左と右のマージンが12です。

これらは、MarginUnitsプロパティの変更によりパーセントからピクセルへ単位を変更できます。

例

[C#]

このプロパティは、デザイン時や実行時に変更できます。

tChart1.Panel.MarginUnits = PanelMarginUnits.Pixels;
tChart1.Panel.MarginTop = 20;

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


MarginUnits

Steema.TeeChart.Panel.MarginUnits プロパティ

マージンの単位を設定します。
public PanelMarginUnits MarginUnits {get; set;}

解説

デフォルト値：Percent

マージンの単位を設定します。全体のチャートの幅/高さの割合か、あるいはパネル枠からのピクセル数としての単位を設定します。

例

[C#]

private void Form1_Load(object sender, System.EventArgs e)
{
     tChart1.Panel.MarginBottom = 20;
     tChart1.Panel.MarginLeft = 16;
     tChart1.Panel.MarginRight = 16;
     tChart1.Panel.MarginTop = 20;

     tChart1.Panel.MarginUnits = PanelMarginUnits.Pixels;
}

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Panel.Visible プロパティ

パネルを表示/非表示にします。

public Boolean Visible {get; set;}

解説

パネルを表示/非表示にします。

参照

Panel クラス | Panel メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.PanelMarginUnits

TeeChartプログラミングガイド

Steema.TeeChart.PanelMarginUnits 列挙体

MarginUnitsプロパティの使用可能な値です。

[Serializable]
public enum PanelMarginUnits : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Percent | パネルサイズのパーセンテージとして単位を定義します。
Pixels | ピクセルとして単位を定義します。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.PositionUnits

TeeChartプログラミングガイド

Steema.TeeChart.PositionUnits 列挙体

Axis.Labels.PositionUnitsプロパティの単位を指定します。

[Serializable]
public enum PositionUnits : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Percent | チャートサイズに対する水平または垂直のパーセント単位。
Pixels | ピクセル単位。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Printer

Steema.TeeChart.Printer クラス

チャートの印刷特性。

この型のすべてのメンバの一覧については、Printer メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class Printer : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Printer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Printer 全メンバ

Printer 概要

コンストラクタ

Constructor

パブリック メソッド

BeginPrint | 複数チャートの印刷を開始します。
EndPrint | 複数チャートの印刷を終了します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Preview | チャートの印刷プレビュー画面を表示します。
Print | 現在選択されているプリンタにチャートを送ります。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Grayscale | trueの場合、グレースケールのチャートを印刷します。
Landscape | 現在選択されているプリンタの印刷向きを横向きに設定します。
Margins | 用紙サイズのパーセントとして左、上、右、下の4つのマージンを設定します。
MarginUnits | プリンタのマージンの単位を設定します。
PrintDocument | 現在選択されているプリンタに送るチャートを選択します。
PrintPanelBackground | falseの場合、チャートパネルを透明に印刷します。
Proportional | 画面に比例してチャートの印刷サイズを設定します。
Resolution | チャートの印刷解像度をパーセント単位（1から100）で設定します。
UseAntiAlias | trueの場合、ペンにアンチエイリアスを適用します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Printer クラス | Steema.TeeChart 名前空間


Printer コンストラクタ

Steema.TeeChart.Printer コンストラクタ

public Printer(Chart c)

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Printer フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Printer クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Printer メソッド

パブリック メソッド

BeginPrint | 複数チャートの印刷を開始します。
EndPrint | 複数チャートの印刷を終了します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Preview | チャートの印刷プレビュー画面を表示します。
Print | 現在選択されているプリンタにチャートを送ります。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Printer クラス | Steema.TeeChart 名前空間


BeginPrint

Steema.TeeChart.Printer.BeginPrint メソッド

複数チャートの印刷を開始します。
public Void BeginPrint()

解説

複数チャートの印刷を開始します。印刷の終了は、EndPrintメソッドを使用してください。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


EndPrint

Steema.TeeChart.Printer.EndPrint メソッド

複数チャートの印刷を終了します。
public Void EndPrint()

解説

複数チャートの印刷を終了します。印刷を開始するにはBeginPrintメソッドを使用してください。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Preview

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Preview メソッド

チャートの印刷プレビュー画面を表示します。

public Void Preview()

解説

チャートの印刷プレビュー画面を表示します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Print

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Print メソッド

オーバーロードの一覧

現在選択されているプリンタにチャートを送ります。

public Void Print()

現在選択されているプリンタにチャートを送ります。

public Void Print(System.Boolean)

矩形（左、上、幅、高さ）にチャートを印刷します。

public Void Print(Steema.TeeChart.Chart, System.Drawing.Rectangle)

矩形（左、上、幅、高さ）に印刷します。

public Void Print(System.Drawing.Rectangle)

解説

現在選択されているプリンタにチャートを送ります。現在の印刷方向（縦または横）は印刷前に変更できます。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Print

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Print メソッド

現在指定したプリンタにチャートを送ります。

public Void Print()

参照

Print オーバーロードの一覧 | Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Print

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Print メソッド

現在選択されているプリンタにチャートを送ります。

public Void Print(Boolean landscape)

パラメーター

landscape
現在選択されているプリンタにチャートを送ります。

参照

Print オーバーロードの一覧 | Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Print

Steema.TeeChart.Printer.Print メソッド

矩形（左、上、幅、高さ）にチャートを印刷します。
public Void Print(Chart c,
     Rectangle r)

参照

Print オーバーロードの一覧 | Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Print

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Print メソッド

矩形(左、上、幅、高さ）に印刷します。

public Void Print(Rectangle r)

参照

Print オーバーロードの一覧 | Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Printer プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Grayscale | trueの場合、 チャートをグレースケールで印刷します。
Landscape | 現在の印刷方向を横に設定します。
Margins | 用紙サイズのパーセントとして左、上、右、下の4つのマージンを設定します。
MarginUnits | プリンタのマージンの単位を設定します。
PrintDocument | 現在指定したプリンタに送るチャートを選択します。
PrintPanelBackground | falseの場合、チャートパネルを透明に印刷します。
Proportional | 画面に比例してチャートの印刷サイズを設定します。
Resolution | チャートの印刷解像度をパーセント単位（1から100）で設定します。
UseAntiAlias | trueの場合、ペンにアンチエイリアスを適用します。

参照

Printer クラス | Steema.TeeChart 名前空間


Grayscale

Steema.TeeChart.Printer.Grayscale プロパティ

trueの場合、グレースケールのチャートを印刷します。
public Boolean Grayscale {get; set;}

解説

trueの場合、グレースケールのチャートを印刷します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Landscape

Steema.TeeChart.Printer.Landscape プロパティ

現在選択されているプリンタの印刷向きを横向きに設定します。
public Boolean Landscape {get; set;}

解説

現在選択されているプリンタの印刷向きを横向きに設定します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Margins

Steema.TeeChart.Printer.Margins プロパティ

用紙サイズのパーセントとして左、上、右、下の4つのマージンを設定します。
public Margins Margins {get; set;}

解説

このプロパティは、左、上、右、下の4つのマージンを設定します。

これらは、用紙サイズのパーセントで設定します。

例

[C#]
private void Form1_Load(object sender, System.EventArgs e) {
     commander1.Chart = tChart1;
     line1.FillSampleValues(20);
     tChart1.Printer.Margins.Right = 50;
}

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


MarginUnits

Steema.TeeChart.Printer.MarginUnits プロパティ

プリンタのマージンの単位を設定します。
public PrintMarginUnits MarginUnits {get; set;}

解説

マージンの単位をHundredthsInchあるいはPercentのどちらかに設定します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


PrintDocument

Steema.TeeChart.Printer.PrintDocument プロパティ

現在選択されているプリンタに送るチャートを選択します。
public PrintDocument PrintDocument {get; set;}

解説

現在選択されているプリンタに送るチャートを選択します。現在のプリンタの印刷の向きは、印刷を行う前に変更することができます。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


PrintPanelBackground

Steema.TeeChart.Printer.PrintPanelBackground プロパティ

falseの場合、チャートパネルを透明に印刷します。
public Boolean PrintPanelBackground {get; set;}

解説

falseの場合、チャートパネルを透明に印刷します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Proportional

Steema.TeeChart.Printer.Proportional プロパティ

画面に比例してチャートの印刷サイズを設定します。
public Boolean Proportional {get; set;}

解説

画面に比例してチャートの印刷サイズを設定します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Resolution

TeeChartプログラミングガイド

Steema.TeeChart.Printer.Resolution プロパティ

チャートの印刷解像度をパーセント単位（1から100）で設定します。

public Int32 Resolution {get; set;}

解説

チャートの印刷解像度をパーセント単位（1から100）で設定します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


UseAntiAlias

Steema.TeeChart.Printer.UseAntiAlias プロパティ

trueの場合、ペンにアンチエイリアスを適用します。
public Boolean UseAntiAlias {get; set;}

解説

trueの場合、ペンにアンチエイリアスを適用します。

参照

Printer クラス | Printer メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.PrintMarginUnits

TeeChartプログラミングガイド

Steema.TeeChart.PrintMarginUnits 列挙体

MarginUnitsプロパティのための単位を設定します。

[Serializable]
public enum PrintMarginUnits : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Percent | 用紙の幅と高さの百分率単位。
HundredthsInch | 標準1/100インチ単位。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.RefreshEventHandler

Steema.TeeChart.RefreshEventHandler デリゲート

public delegate RefreshEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.RemovedSeriesEventHandler

Steema.TeeChart.RemovedSeriesEventHandler デリゲート

public delegate RemovedSeriesEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Scroll

Steema.TeeChart.Scroll クラス

チャートのマウススクロール特性。

この型のすべてのメンバの一覧については、Scroll メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.ZoomScroll
public class Scroll : ZoomScroll , IComponent, IDisposable

解説

TeeChartをスクロールするには、Steema.TeeChart.Axis.Automaticプロパティをfalseに設定してください。

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Scroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Scroll 全メンバ

Scroll 概要

コンストラクタ

Constructor

パブリック フィールド

x0 (ZoomScrollの継承元)
x1 (ZoomScrollの継承元)
y0 (ZoomScrollの継承元)
y1 (ZoomScrollの継承元)

パブリック メソッド

Activate (ZoomScrollの継承元) | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check (ZoomScrollの継承元) | X1がX0より小さい場合、X0とX1 座標を交換します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Active (ZoomScrollの継承元) | チャートのズームやスクロールを有効/無効にします。
Allow | 指定したScrollModesを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
KeyShift (ZoomScrollの継承元) | ズームを開始するためのオプションとしてキーボードボタンを設定します。
MouseButton | スクロールのためのマウスボタンを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Scroll クラス | Steema.TeeChart 名前空間


Scroll コンストラクタ

Steema.TeeChart.Scroll コンストラクタ

public Scroll(Chart c)

参照

Scroll クラス | Scroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Scroll フィールド

パブリック フィールド

x0 (ZoomScrollの継承元)
x1 (ZoomScrollの継承元)
y0 (ZoomScrollの継承元)
y1 (ZoomScrollの継承元)

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Scroll クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Scroll メソッド

パブリック メソッド

Activate (ZoomScrollの継承元) | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check (ZoomScrollの継承元) | X1がX0より小さい場合、X0とX1 座標を交換します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Scroll クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Scroll プロパティ

パブリック プロパティ

Active (ZoomScrollの継承元) | チャートのズームやスクロールを有効/無効にします。
Allow | 指定したScrollModesを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
KeyShift (ZoomScrollの継承元) | ズームを開始する特別な条件としてキーボードボタンを設定します。
MouseButton | スクロールのためのマウスボタンを設定します。

参照

Scroll クラス | Steema.TeeChart 名前空間


Allow

Steema.TeeChart.Scroll.Allow プロパティ

指定したScrollModesを有効/無効にします。
public ScrollModes Allow {get; set;}

解説

実行時のスクロールを制御します。

使用可能な値：

None スクロールを無効にします。
Horizontal 水平スクロールのみ有効にします。
Vertical 垂直スクロールのみ有効にします。
Both 水平・垂直スクロールを有効にします。

参照

Scroll クラス | Scroll メンバ | Steema.TeeChart 名前空間


MouseButton

TeeChartプログラミングガイド

Steema.TeeChart.Scroll.MouseButton プロパティ

スクロールのためのマウスボタンを設定します。

public MouseButtons MouseButton {get; set;}

解説

スクロールのためのマウスボタンを設定します。

参照

Scroll クラス | Scroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ScrollModes

TeeChartプログラミングガイド

Steema.TeeChart.ScrollModes 列挙体

Allowプロパティの使用可能な値です。

[Serializable]
public enum ScrollModes : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | スクロールを無効にします。
Vertical | 垂直スクロールのみ有効にします。
Horizontal | 水平スクロールのみ有効にします。
Both | 水平・垂直スクロールを有効にします。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.SerializeEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.SerializeEventArgs クラス

GetAxisLabelイベントのデータを提供します。GetAxisLabelEventHandlerを参照してください。

この型のすべてのメンバの一覧については、SerializeEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class SerializeEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SerializeEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SerializeEventArgs 全メンバ

SerializeEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Type | シリアライゼーションに追加するタイプを設定します。
TypeName | シリアライズするタイプの名称にアクセスします。

参照

SerializeEventArgs クラス | Steema.TeeChart 名前空間


SerializeEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.SerializeEventArgs コンストラクタ

public SerializeEventArgs(String tName,
     Type t)

参照

SerializeEventArgs クラス | SerializeEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SerializeEventArgs プロパティ

パブリック プロパティ

Type | シリアライゼーションに追加するタイプを設定します。
TypeName | シリアライズするタイプの名称にアクセスします。

参照

SerializeEventArgs クラス | Steema.TeeChart 名前空間


Type

Steema.TeeChart.SerializeEventArgs.Type プロパティ

シリアライゼーションに追加するタイプを設定します。
public Type Type {get; set;}

解説

シリアライゼーションに追加するタイプを設定します。

参照

SerializeEventArgs クラス | SerializeEventArgs メンバ | Steema.TeeChart 名前空間


TypeName

Steema.TeeChart.SerializeEventArgs.TypeName プロパティ

シリアライズするタイプの名称にアクセスします。
public String TypeName {get;}

解説

シリアライズするタイプの名称にアクセスします。

参照

SerializeEventArgs クラス | SerializeEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SerializeEventHandler

Steema.TeeChart.SerializeEventHandler デリゲート

シリアライズタイプのイベントハンドラ。
public delegate SerializeEventHandler (Object sender,
     SerializeEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.SymbolDrawEventArgs

Steema.TeeChart.SymbolDrawEventArgs クラス

この型のすべてのメンバの一覧については、SymbolDrawEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class SymbolDrawEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SymbolDrawEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SymbolDrawEventArgs 全メンバ

SymbolDrawEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Rect
Series
ValueIndex

参照

SymbolDrawEventArgs クラス | Steema.TeeChart 名前空間


SymbolDrawEventArgs コンストラクタ

Steema.TeeChart.SymbolDrawEventArgs コンストラクタ

public SymbolDrawEventArgs(Series s,
     Int32 valind,
     Rectangle r)

参照

SymbolDrawEventArgs クラス | SymbolDrawEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SymbolDrawEventArgs プロパティ

パブリック プロパティ

Rect
Series
ValueIndex

参照

SymbolDrawEventArgs クラス | Steema.TeeChart 名前空間


Rect

Steema.TeeChart.SymbolDrawEventArgs.Rect プロパティ

public Rectangle Rect {get; set;}

参照

SymbolDrawEventArgs クラス | SymbolDrawEventArgs メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.SymbolDrawEventArgs.Series プロパティ

public Series Series {get; set;}

参照

SymbolDrawEventArgs クラス | SymbolDrawEventArgs メンバ | Steema.TeeChart 名前空間


ValueIndex

Steema.TeeChart.SymbolDrawEventArgs.ValueIndex プロパティ

public Int32 ValueIndex {get; set;}

参照

SymbolDrawEventArgs クラス | SymbolDrawEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.SymbolDrawEventHandler

Steema.TeeChart.SymbolDrawEventHandler デリゲート

public delegate SymbolDrawEventHandler (Object sender,
     SymbolDrawEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.TChart

TeeChartプログラミングガイド

Steema.TeeChart.TChart クラス

Windowsフォームに使用される基本的なChartクラス。

この型のすべてのメンバの一覧については、TChart メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
[Serializable]
public class TChart : Control , IComponent, IDisposable
, IOleControl, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject
, IOleWindow, IViewObject, IViewObject2, IPersist, IPersistStreamInit
, IPersistPropertyBag, IPersistStorage, IQuickActivate, ISynchronizeInvoke
, IWin32Window

解説

TChartは、WindowsフォームのTeeChartライブラリの主要コンポーネントで、その他すべてのTeeChartオブジェクトを保持しています。下図は、TChartクラスの主なTeeChartオブジェクトを示しています。

TChartオブジェクトは、デザイン時や実行時にWindowsフォームへ追加することができます。実行時で、下記のようなコードが使用できます。

[C#]
private void Form1_Load(object sender, System.EventArgs e) {
     Steema.TeeChart.TChart tChart1 = new Steema.TeeChart.TChart();
     tChart1.Header.Lines = new string[] {"TeeChart"};
     tChart1.Location = new System.Drawing.Point(32, 32);
     tChart1.Name = "tChart1";
     tChart1.Size = new System.Drawing.Size(528, 264);
     tChart1.TabIndex = 0;

     this.Controls.AddRange(new System.Windows.Forms.Control[] {tChart1});
}

[VB.Net]
Private Sub Form1_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    Dim TChart1 As Steema.TeeChart.TChart = New Steema.TeeChart.TChart()
    TChart1.Header.Lines = New String() {"TeeChart"}
    TChart1.Location = New System.Drawing.Point(32, 32)
    TChart1.Name = "TChart1"
    TChart1.Size = New System.Drawing.Size(528, 264)
    TChart1.TabIndex = 0

    Me.Controls.AddRange(New System.Windows.Forms.Control() {TChart1})
End Sub

コードを使用してチャートに系列を追加することもできます。

[C#]
Steema.TeeChart.Styles.Bar bar1 = new Steema.TeeChart.Styles.Bar(tChart1.Chart);
bar1.FillSampleValues(20);
[VB.Net]
Dim Bar1 As New Steema.TeeChart.Styles.Bar(TChart1.Chart)
Bar1.FillSampleValues(20)

あるいは...

[C#]
tChart1.Series.Add(new Steema.TeeChart.Styles.Pie());
tChart1.Series[0].FillSampleValues(20);
[VB.Net]
TChart1.Series.Add(New Steema.TeeChart.Styles.Pie())
TChart1.Series(0).FillSampleValues(20)

TChartオブジェクトはいくつでも1つのWindowsフォームに共存できます。Webフォーム環境でTeeChartを使用するために、Steema.TeeChart.Web.WebChartクラスを使用してください。

TeeChartでのチャートの作成方法に関する詳細は、TeeChartチュートリアルを参照してください。

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

TChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart 全メンバ

TChart 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDraw
AllowScroll
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ChartPrint
ClickAxis
ClickBackground
ClickLegend
ClickSeries
ClickTitle
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel
Scroll
UndoneZoom
Zoomed

パブリック メソッド

AboutBox |
AddSeries | チャートに新しい系列を追加します。
Clear | チャートをデフォルト値にリセットします。
DoInvalidate |
Draw | 指定したキャンバスや領域にチャートを描画します。
ExchangeSeries |
GetObjectData |
RemoveAllSeries |
ShowEditor | TeeChartのエディタダイアログを表示します。

パブリック プロパティ

ApplyZOrder |
Aspect | チャートのビュー特性にアクセスします。
AutoRepaint | ポイントが追加された際にチャートの再描画を有効/無効にします。
Axes | 各軸にアクセスします。
BackColor | チャート矩形を塗りつぶす色を設定します。
Bitmap | チャートで描画されたビットマップイメージを返します。
Canvas | TeeChartの描画についてのプロパティやメソッドにアクセスします。
Chart | 描画するチャートを定義します。
ClipPoints |
Export | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Font | フォント特性を定義します。
Footer | チャートの下部に描くテキストや書式特性を定義します。
ForeColor | TChartオブジェクトの前面の色を取得します。
Frame | 旧式。チャートの背面の周りの枠の特性を設定します。このプロパティの代わりにtChart1.Walls.Back.Penプロパティを使用してください。
GetCursorPos |
Graphics3D | TeeChartの描画プロパティやメソッドにアクセスするために使用してください。
Header | チャートの上部に描くテキストや書式特性を定義します。
Import | チャートのインポートについてのプロパティやメソッドにアクセスします。
Item | デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
Legend | 凡例の特性にアクセスします。
Metafile | チャートで描画されたメタファイルイメージを返します。
Metafiling | チャートがメタファイルイメージに内部で描画している場合、trueを返します。
Page | チャートの複数ページ特性にアクセスします。
Panel | チャート背面の可視属性を設定します。
Panning | チャートのパン特性にアクセスします。
Printer | 印刷に関連したプロパティやメソッドにアクセスします。
Printing | 印刷するチャートを取得/設定します。
Series | チャートに含まれる系列のリストにアクセスします。
SeriesCount | 旧式。チャート内の系列の数を返します。このプロパティの代わりにtChart1.Series.Countプロパティを使用してください。
Site | TChartコントロールのサイトを取得/設定します。
SubFooter | フッターの上に表示されるテキストを定義します。
SubHeader | ヘッダーの下に表示されるテキストを定義します。
Text | フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定します。
TimerEnabled | 旧式。チャートを自動的に再描画する内部タイマーを有効/無効にします。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
TimerInterval | 旧式。チャートを自動的に再描画するミリ秒単位のインターバルを取得/設定します。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
Tools | チャート内に含まれているツールコンポーネントのコレクションです。
Walls | チャートの左、下、背面の壁特性にアクセスします。
Zoom | チャートのズーム特性にアクセスします。

プロテクト メソッド

Dispose | 使用したリソースを空にします。
initVars |
OnDoubleClick |
OnKeyDown |
OnMouseDown |
OnMouseLeave |
OnMouseMove |
OnMouseUp |
OnMouseWheel |
OnPaint |

プロテクト プロパティ

DefaultSize

参照

TChart クラス | Steema.TeeChart 名前空間


TChart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TChart コンストラクタ

オーバーロードの一覧

public TChart(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
public TChart()

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


TChart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TChart コンストラクタ

public TChart(SerializationInfo info,
     StreamingContext context)

参照

TChart コンストラクタのオーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


TChart コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TChart コンストラクタ

public TChart()

参照

TChart コンストラクタのオーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart イベント

パブリック イベント

AfterDraw
AllowScroll
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ChartPrint
ClickAxis
ClickBackground
ClickLegend
ClickSeries
ClickTitle
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel
Scroll
UndoneZoom
Zoomed

参照

TChart クラス | Steema.TeeChart 名前空間


AfterDraw

Steema.TeeChart.TChart.AfterDraw イベント

public PaintChartEventHandler  AfterDraw

解説

このイベントは、TChartがすべての系列を描画した直後に発生します。

警告：

このイベントの中で、TChartを再描画させるプロパティを変更しないでください。無限ループになります。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


AllowScroll

Steema.TeeChart.TChart.AllowScroll イベント

public AllowScrollEventHandler  AllowScroll

解説

チャートをスクロールする際に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


BeforeDraw

Steema.TeeChart.TChart.BeforeDraw イベント

public PaintChartEventHandler  BeforeDraw

解説

このイベントは、すべてのチャートを描画する前で、チャートの背景を描画した後に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


BeforeDrawAxes

Steema.TeeChart.TChart.BeforeDrawAxes イベント

public PaintChartEventHandler  BeforeDrawAxes

解説

すべてのチャート軸を描く直前に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


BeforeDrawSeries

Steema.TeeChart.TChart.BeforeDrawSeries イベント

public PaintChartEventHandler  BeforeDrawSeries

解説

すべてのチャート系列を描画する直前と、チャート軸を描画した直後（軸が系列の背面にある場合）に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ChartPrint

Steema.TeeChart.TChart.ChartPrint イベント

public ChartPrintEventHandler  ChartPrint

解説

このイベントは、チャートが印刷される時に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClickAxis

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ClickAxis イベント

public MouseEventHandler  ClickAxis

解説

ClickAxisイベントは、ユーザがチャート軸のサブクラス上でクリックすると必ず発生します。

Senderパラメーターは、イベントが発生したチャートクラスを示します。

Axisパラメーターは、該当するクリックされたチャート軸です。左、右、上、下のチャート軸のサブクラスになります。

Button、Shift、X、Yパラメーターは、軸をクリックした時にマウスボタンやマウスカーソル座標を定義します。

このイベントは、OnClickBackGroundイベントより優先度が高く、OnClickSeriesイベントより低くなっています。

例

[C#]

private void tChart1_ClickAxis(object sender, System.Windows.Forms.MouseEventArgs e)
{
     if ((Steema.TeeChart.Axis)sender==tChart1.Axes.Bottom)
        MessageBox.Show("Clicked Bottom Axis!!!");
}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClickBackground

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ClickBackground イベント

public MouseEventHandler  ClickBackground

解説

このイベントは、軸、系列ポイント、チャートの凡例を除くチャートスペース上をクリックすると発生します。

これはすべてのマウスイベントの中で一番低い優先度になります。

Senderパラメーターは、イベントを発生させたチャートクラスを示します。

Button、Shift、X、Yパラメーターは、チャートがクリックされた時のマウスボタンやマウスカーソル座標を示します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClickLegend

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ClickLegend イベント

public MouseEventHandler  ClickLegend

解説

このイベントは、チャートの凡例矩形上をクリックすると発生します。

Senderパラメーターは、イベントを発生させたチャートクラスです。

Button、Shift、X、Yのパラメーターは、チャートの凡例をクリックした時のマウスボタンやマウスカーソル座標を示します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClickSeries

Steema.TeeChart.TChart.ClickSeries イベント

public SeriesEventHandler  ClickSeries

解説

このイベントは、TChart系列のポイント上でクリックすると発生します。Senderパラメーターは、イベントを発生させたTChartクラスを示します。Seriesパラメーターは、クリックされた系列クラスです。ValueIndexパラメーターは、クリックされた系列のポイントインデックスを示します。また系列にはクリックされたポイントを個々に取得するためのClickイベントを保持しています。Button、Shift、X、Yパラメーターは、系列ポイントをクリックした時のマウスボタンやマウスカーソル座標を示します。

例

[C#]
このイベントプロシージャは、クリックされた系列ポイントを表示します。

private void tChart1_ClickSeries(object sender, Steema.TeeChart.Styles.Series s, int valueIndex, System.Windows.Forms.MouseEventArgs e)
{
     MessageBox.Show("Clicked Series: " + s.TitleOrName() + " at point: " + valueIndex.ToString());
}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClickTitle

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ClickTitle イベント

public MouseEventHandler  ClickTitle

解説

このイベントは、チャートのタイトル、サブタイトル、フッター、サブフッターをクリックした際に発生します。

例

[C#]

private void tChart1_ClickTitle(object sender, System.Windows.Forms.MouseEventArgs e)
{
     MessageBox.Show(tChart1.Text.ToString());

}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetAxesChartRect

Steema.TeeChart.TChart.GetAxesChartRect イベント

public GetAxesChartRectEventHandler  GetAxesChartRect

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetAxisLabel

Steema.TeeChart.TChart.GetAxisLabel イベント

public GetAxisLabelEventHandler  GetAxisLabel

解説

このイベントは、各軸ラベルが描画される度に発生します。このイベントには、2つの異なる使用法があります。

1) : 軸ラベルが値。この場合、Seriesパラメーターはnilになり、ValueIndexは-1になります。
2) : 軸ラベルが系列ポイント。Seriesパラメーターは有効な系列になり、ValueIndexは現在の系列ポイントの位置になります。異なる軸ラベルを描画するためには、LabelTextパラメーターを使用して変更できます。

例

[C#]

private void WebChart2_GetAxisLabel(object sender, Steema.TeeChart.GetAxisLabelEventArgs e)
{
     //軸ラベルのテキストを変更します。
     if ((Steema.TeeChart.Axis)sender==WebChart2.Chart.Axes.Bottom)
    {
        switch (e.LabelText.Substring(e.LabelText.Length-1,1))
        {
            case "0": e.LabelText="init. 0"; break;
            case "1": e.LabelText=e.LabelText+"st"; break;
            case "2": e.LabelText=e.LabelText+"nd"; break;
            case "3": e.LabelText=e.LabelText+"rd"; break;
            default: e.LabelText=e.LabelText+"th"; break;
        }
    }
}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetLegendPos

Steema.TeeChart.TChart.GetLegendPos イベント

public GetLegendPosEventHandler  GetLegendPos

解説

このイベントは、凡例項目が表示される時に発生します。

このイベントを使用して、特定のX、Y、および（あるいは）XColorの指定ができます。

チャートクラスは、このイベントを呼び出す前にデフォルトのX、YやXColorパラメーターを計算します。

Senderパラメーターは、イベントを発生させたTChartクラスです。

Indexパラメーターは、表示される凡例項目番号に対応しています。これは、Legend.LegendStyleプロパティにより、アクティブな系列タイトルあるいは系列のポイントインデックスのどちらかになります。

例

[C#]

private void tChart1_GetLegendRect(object sender, Steema.TeeChart.TChart.GetLegendRectEventArgs e)
   {
      //全体の凡例の枠矩形を左へ移動
      e.Rectangle=new Rectangle(e.Rectangle.Left-100,e.Rectangle.Top-20,e.Rectangle.Width,e.Rectangle.Height);
   }

private void tChart1_GetLegendPos(object sender, Steema.TeeChart.TChart.GetLegendPosEventArgs e)
   {
      //凡例の内容を移動
      e.X=e.X-100;
      e.XColor=e.XColor-100;
   }

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetLegendRect

Steema.TeeChart.TChart.GetLegendRect イベント

public GetLegendRectEventHandler  GetLegendRect

解説

このイベントは、TChartの凡例が表示される時に発生します。

このイベントを使用して、凡例位置やサイズを強制的に指定できます。

Rectパラメーターは、デフォルトの凡例位置やサイズを画面ピクセルで設定します。

Legend.ResizeChartプロパティをfalseに設定しない限り、凡例の描画後に使用可能なチャートスペースは凡例と重ならないように縮小します。

このイベントを使用する場合、凡例内容を正確な座標位置に置くためにTChart.OnGetLegendPosイベントも使用してください。

例

[C#]

private void tChart1_GetLegendRect(object sender, Steema.TeeChart.TChart.GetLegendRectEventArgs e)
   {
      //全体の凡例の枠矩形を左に移動
      e.Rectangle=new Rectangle(e.Rectangle.Left-100,e.Rectangle.Top-20,e.Rectangle.Width,e.Rectangle.Height);
   }

private void tChart1_GetLegendPos(object sender, Steema.TeeChart.TChart.GetLegendPosEventArgs e)
   {
      //凡例の内容を移動
      e.X=e.X-100;
      e.XColor=e.XColor-100;
   }

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetLegendText

Steema.TeeChart.TChart.GetLegendText イベント

public GetLegendTextEventHandler  GetLegendText

解説

このイベントを使用して、TChartLegend が描画する文字列をオーバーライドできます。

TChartLegendは、2つのモード（あるいはLegendStyles）を持っています。

Series 凡例は系列名あるいはタイトルを含みます。
Values 凡例は系列値あるいはラベルを含みます。

LegendStyleがAutoに設定されていて、チャートに複数のアクティブ系列がある場合、TChartLegendはSeriesモードで描画します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetNextAxisLabel

Steema.TeeChart.TChart.GetNextAxisLabel イベント

public GetNextAxisLabelEventHandler  GetNextAxisLabel

解説

このイベントは、カスタムな軸ラベルを定義するために使用されます。このイベントを使用して軸ラベルの位置や値をカスタマイズできます。

このイベントは、MoreLabelsパラメーターをfalseに設定するかLabelValueパラメーターが軸の最大値より大きくなるまで繰り返し呼び出されます。

デフォルトではMoreLabelsパラメーターはtrueです。これはこのイベントを呼び出した時点でfalseに設定されないと、TeeChartはデフォルトの軸ラベルを描画します。

Senderパラメーターは、軸のサブクラスを示します。これは、ChartのAxes.Left、Axes.Right、Axes.Top、Axes.BottomのAxesクラスです。

LabelIndexパラメーターは、ラベルのインデックスです。

LabelValueパラメーターは、指定した軸ラベルの値でなければなりません。

デフォルトの軸ラベルのテキストを上書きするには、TChart.GetAxisLabelイベントを使用してください。

例

[C#]

private void tChart1_GetNextAxisLabel(object sender, Steema.TeeChart.TChart.GetNextAxisLabelEventArgs e)
{
      if (sender == tChart1.Axes.Left)
   {
         /* 垂直の左軸で、ゼロから始まり
         ラベルインクリメントが250の
         正の値のラベルのみ表示します。*/

         if (e.LabelValue>=250)
         e.LabelValue=e.LabelValue+250;
         else e.LabelValue=250;

         /* 1000までのラベルとする */

         if (e.LabelValue>999)
         e.Stop=true;
        else
        e.Stop=false;
    }
}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Scroll

TeeChartプログラミングガイド

Steema.TeeChart.TChart.Scroll イベント

public EventHandler  Scroll

解説

このイベントは、チャート内で右マウスボタンをドラッグしてチャートをスクロールする際に発生します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


UndoneZoom

TeeChartプログラミングガイド

Steema.TeeChart.TChart.UndoneZoom イベント

public EventHandler  UndoneZoom

解説

チャート軸をその最大値や最小値にリセットされると発生します。左マウスボタンで右下から左上に矩形を描くようにドラッグするとズームを元に戻すことができます。また、TChart.Zoom.Undoを呼び出すことによりズームを元に戻すことができます。この両方の方法でイベントが発生します。このイベントは、軸スケールの変更に対応するTChart.ZoomedイベントやTChart.Scrollイベントと共に使用できます。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Zoomed

TeeChartプログラミングガイド

Steema.TeeChart.TChart.Zoomed イベント

public EventHandler  Zoomed

解説

このイベントは、チャートをズームすると発生します。
チャートは、左マウスボタンで左上から右下に矩形を描くようにドラッグするとズームします。

ズームは実行時にマウスをドラッグすることにより実行されます。あるいはTChart.ZoomRectメソッドあるいはTChart.ZoomPercentメソッドを呼び出してズームすることもできます。

このイベントは、新しい軸スケールを表示するためにチャートクラスを再描画する前に呼び出されます。

このイベントは、軸スケールの変更を確認するためにTChart.UndoZoomイベントやTChart.Scrollイベントと共に使用できます。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart メソッド

パブリック メソッド

AboutBox |
AddSeries | チャートに新しい系列を追加します。
Clear | チャートをデフォルト値にリセットします。
DoInvalidate |
Draw | 指定したキャンバスや領域にチャートを描画します。
ExchangeSeries |
GetObjectData |
RemoveAllSeries |
ShowEditor | TeeChartのエディタダイアログを表示します。

プロテクト メソッド

Dispose | 使用したリソースを空にします。
initVars |
OnDoubleClick |
OnKeyDown |
OnMouseDown |
OnMouseLeave |
OnMouseMove |
OnMouseUp |
OnMouseWheel |
OnPaint |

参照

TChart クラス | Steema.TeeChart 名前空間


AboutBox

TeeChartプログラミングガイド

Steema.TeeChart.TChart.AboutBox メソッド

public Void AboutBox()

旧式

このメソッドの代わりに、Steema.TeeChart.Editors.AboutBox.ShowModalメソッドを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


AddSeries

Steema.TeeChart.TChart.AddSeries メソッド

チャートに新しい系列を追加します。
public Series AddSeries(Series s)

旧式

このメソッドの代わりにSeries.Addメソッドを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.TChart.Clear メソッド

チャートをデフォルト値にリセットします。
public Void Clear()

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Dispose

Steema.TeeChart.TChart.Dispose メソッド

使用したリソースを削除します。
protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


DoInvalidate

Steema.TeeChart.TChart.DoInvalidate メソッド

public abstract Void DoInvalidate()

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.TChart.Draw メソッド

指定したキャンバスや領域にチャートを描画します。
public Void Draw(Graphics g)

解説

指定したキャンバスや領域にチャートを描画します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.TChart.Draw メソッド

チャートの値を計算するために、チャートを内部で描画します（他にはチャートが実際に画面に描画される時だけチャートの値が計算されます）。
public Void Draw()

参照

Draw オーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.TChart.Draw メソッド

希望するキャンバスや領域にチャートを描画します。
public abstract Void Draw(Graphics g)

参照

Draw オーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ExchangeSeries

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ExchangeSeries メソッド

public Void ExchangeSeries(Int32 series1,
     Int32 series2)

旧式

このメソッドの代わりにTChart.Series.Exchangeメソッドを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetObjectData

TeeChartプログラミングガイド

Steema.TeeChart.TChart.GetObjectData メソッド

public virtual Void GetObjectData(SerializationInfo info,
     StreamingContext context)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


initVars

Steema.TeeChart.TChart.initVars メソッド

protected Void initVars()

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnDoubleClick

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnDoubleClick メソッド

protected virtual Void OnDoubleClick(EventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnKeyDown

Steema.TeeChart.TChart.OnKeyDown メソッド

protected abstract Void OnKeyDown(KeyEventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnMouseDown

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnMouseDown メソッド

protected virtual Void OnMouseDown(MouseEventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnMouseLeave

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnMouseLeave メソッド

protected virtual Void OnMouseLeave(EventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnMouseMove

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnMouseMove メソッド

protected virtual Void OnMouseMove(MouseEventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnMouseUp

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnMouseUp メソッド

protected virtual Void OnMouseUp(MouseEventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnMouseWheel

Steema.TeeChart.TChart.OnMouseWheel メソッド

protected abstract Void OnMouseWheel(MouseEventArgs e)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


OnPaint

TeeChartプログラミングガイド

Steema.TeeChart.TChart.OnPaint メソッド

protected virtual Void OnPaint(PaintEventArgs pe)

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


RemoveAllSeries

TeeChartプログラミングガイド

Steema.TeeChart.TChart.RemoveAllSeries メソッド

public Void RemoveAllSeries()

旧式

このメソッドの代わりにTChart.Series.Clearメソッドを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ShowEditor

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ShowEditor メソッド

オーバーロードの一覧

TeeChartのエディタダイアログを表示します。

public Boolean ShowEditor(System.ComponentModel.ITypeDescriptorContext)

TeeChartのエディタダイアログを表示します。

public Boolean ShowEditor()

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ShowEditor

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ShowEditor メソッド

TeeChartのエディタダイアログを表示します。

public Boolean ShowEditor(ITypeDescriptorContext context)

参照

ShowEditor オーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ShowEditor

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ShowEditor メソッド

TeeChartのエディタダイアログを表示します。
public Boolean ShowEditor()

参照

ShowEditor オーバーロードの一覧 | TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart プロパティ

パブリック プロパティ

ApplyZOrder |
Aspect | チャートのビュー特性にアクセスします。
AutoRepaint | ポイントが追加された際にチャートの再描画を有効/無効にします。
Axes | 各軸にアクセスします。
BackColor | チャート矩形を塗りつぶす色を設定します。
Bitmap | チャートで描画されたビットマップイメージを返します。
Canvas | TeeChartの描画についてのプロパティやメソッドにアクセスします。
Chart | 描画するチャートを定義します。
ClipPoints |
Export | チャートのエクスポートについてのプロパティやメソッドにアクセスします。
Font | フォント特性を定義します。
Footer | チャート下部に表示されるテキストを定義します。
ForeColor | TChartオブジェクトの前面の色を取得します。
Frame | 旧式。チャートの背面の周りの枠の特性を設定します。このプロパティの代わりにtChart1.Walls.Back.Penプロパティを使用してください。
GetCursorPos |
Graphics3D | TeeChartの描画プロパティやメソッドにアクセスするために使用してください。
Header | チャート上部に表示されるテキストを定義します。
Import | チャートのインポートのプロパティやメソッドにアクセスします。
Item | デフォルトインデックス。（例：tChart1[0].Color=Color.Blue;はtChart1.Series[0].Color=Color.Blue; と同等です。）
Legend | 凡例の特性にアクセスします。
Metafile | チャートで描画されたメタファイルイメージを返します。
Metafiling | チャートがメタファイルイメージに内部で描画している場合、trueを返します。
Page | チャートの複数ページ特性にアクセスします。
Panel | チャート背面の可視属性を設定します。
Panning | チャートのパン特性にアクセスします。
Printer | 印刷に関連したプロパティやメソッドにアクセスします。
Printing | 印刷するチャートを取得/設定します。
Series | チャートに含まれる系列のリストにアクセスします。
SeriesCount | 旧式。チャート内の系列の数を返します。このプロパティの代わりにTChart.Series.Countプロパティを使用してください。
Site | TChartコントロールのサイトを取得/設定します。
SubFooter | フッターの上に表示されるテキストを定義します。
SubHeader | ヘッダーの下に表示されるテキストを定義します。
Text | フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定します。
TimerEnabled | 旧式。チャートを自動的に再描画する内部タイマーを有効/無効にします。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
TimerInterval | 旧式。チャートを自動的に再描画するミリ秒単位のインターバルを取得/設定します。このプロパティの代わりに標準のTimerコンポーネントを使用してください。
Tools | チャート内に含まれているツールコンポーネントのコレクションです。
Walls | チャートの左、下、背面の壁特性にアクセスします。
Zoom | チャートのズーム特性にアクセスします。

プロテクト プロパティ

DefaultSize

参照

TChart クラス | Steema.TeeChart 名前空間


ApplyZOrder

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ApplyZOrder プロパティ

public Boolean ApplyZOrder {get; set;}

旧式

このプロパティの代わりにSeries.ApplyZOrderプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Aspect

Steema.TeeChart.TChart.Aspect プロパティ

チャートのビュー特性にアクセスします。
public Aspect Aspect {get;}

解説

チャートのビュー特性にアクセスします。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


AutoRepaint

TeeChartプログラミングガイド

Steema.TeeChart.TChart.AutoRepaint プロパティ

ポイントが追加された際にチャートの再描画を有効/無効にします。

public Boolean AutoRepaint {get; set;}

解説

デフォルト値：true

チャート系列に多くのポイントを追加する場合、チャートの再描画を無効にするためには、このプロパティをfalseに設定してください。すべてのポイントを追加した後、このプロパティをtrueにして、Repaintメソッドでチャートを再描画してください。

例

[C#]

tChart1.AutoRepaint = false;
Random r = new Random();
for(int i = 0; i <500; i++)
{
     tChart1[0].Add (i,r.Next(800),Color.Blue);
}
tChart1.AutoRepaint = true;
tChart1.Refresh();

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Axes

Steema.TeeChart.TChart.Axes プロパティ

各軸にアクセスします。
public Axes Axes {get;}

解説

このプロパティは、各軸（上軸、左軸、右軸、下軸など）へのアクセスを有効にします。

例

[C#]

tChart1.Axes.Visible = false;  //すべての軸を非表示にします。

tChart1.Axes.Left.Visible = false;   //左軸のみ非表示にします。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


BackColor

Steema.TeeChart.TChart.BackColor プロパティ

チャート矩形を塗りつぶす色を設定します。
public Color BackColor {get; set;}

解説

このプロパティは、チャート矩形を塗りつぶす色を設定します。チャート矩形は、軸の間の画面領域です。このプロパティにclTeeColorを設定すると、矩形の塗りつぶしは行いません。従ってグラデーションや背面のビットマップが表示できます。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Bitmap

Steema.TeeChart.TChart.Bitmap プロパティ

チャートで描画されたビットマップイメージを返します。
public Bitmap Bitmap {get;}

解説

チャートで描画されたビットマップイメージを返します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Canvas

Steema.TeeChart.TChart.Canvas プロパティ

public Graphics3D Canvas {get; set;}

旧式

このプロパティの代わりに、Graphics3Dプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Chart

Steema.TeeChart.TChart.Chart プロパティ

描画するチャートを定義します。
public Chart Chart {get; set;}

解説

描画するチャートを定義します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ClipPoints

TeeChartプログラミングガイド

Steema.TeeChart.TChart.ClipPoints プロパティ

public Boolean ClipPoints {get; set;}

旧式

このプロパティの代わりにAspect.ClipPointsプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


DefaultSize

TeeChartプログラミングガイド

Steema.TeeChart.TChart.DefaultSize プロパティ

protected virtual Size DefaultSize {get;}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Export

Steema.TeeChart.TChart.Export プロパティ

チャートのエクスポートについてのプロパティやメソッドにアクセスします。
public Exports Export {get;}

解説

チャートのエクスポートについてのプロパティやメソッドにアクセスするために使用してください。

例

[C#]

tChart1.Export.Save("c:\temp\mychart.bmp");

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Font

TeeChartプログラミングガイド

Steema.TeeChart.TChart.Font プロパティ

フォント特性を定義します。

public Font Font {get;}

解説

フォント特性を定義します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Footer

Steema.TeeChart.TChart.Footer プロパティ

チャート下部に表示されるテキストを定義します。
public Footer Footer {get;}

解説

チャートの下部に表示するテキストや書式特性を定義します。Textプロパティを使用して、フッター行を入力したり、VisibleをTrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


ForeColor

Steema.TeeChart.TChart.ForeColor プロパティ

TChartオブジェクトの前面の色を取得します。
public Color ForeColor {get;}

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Frame

Steema.TeeChart.TChart.Frame プロパティ

チャートの背面の周りの枠の特性を設定します。このプロパティの代わりにtChart1.Walls.Back.Penプロパティを使用してください。
public ChartPen Frame {get;}

解説

このプロパティの代わりに、TChart.Walls.Back.Penプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


GetCursorPos

TeeChartプログラミングガイド

Steema.TeeChart.TChart.GetCursorPos プロパティ

public Point GetCursorPos {get;}

旧式

このプロパティの代わりにMousePositionプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Graphics3D

Steema.TeeChart.TChart.Graphics3D プロパティ

TeeChartの描画プロパティやメソッドにアクセスするために使用してください。
public Graphics3D Graphics3D {get; set;}

解説

TeeChartの描画プロパティやメソッドにアクセスするために使用してください。

例

[C#]

tChart1.Graphics3D.TextOut(30,30,"My message");

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Header

Steema.TeeChart.TChart.Header プロパティ

チャート上部に表示されるテキストを定義します。
public Header Header {get;}

解説

チャートの上部に表示するテキストや書式特性を定義します。Textプロパティを使用して、ヘッダー行を入力したり、VisibleをTrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Import

Steema.TeeChart.TChart.Import プロパティ

チャートのインポートのプロパティやメソッドにアクセスします。
public Imports Import {get;}

解説

チャートのインポートのプロパティやメソッドにアクセスします。

例

[C#]

tChart1.Import.Template.Load("c:\\myfile.ten");

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Item

Steema.TeeChart.TChart.Item プロパティ

デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。
public Series Item(Int32 index) {get; set;}

解説

デフォルトのインデックス ( 例：tChart1[0].Color=Color.Blue; は tChart1.Series[0].Color=Color.Blue; と同じです )。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Legend

Steema.TeeChart.TChart.Legend プロパティ

凡例の特性にアクセスします。
public Legend Legend {get;}

解説

系列と系列値のチャートのテキストと描画の属性を定義します。

Legendクラスは矩形を描き、チャートの各系列に対して（あるいは系列のポイントに対して）の系列（あるいはポイント）の文字列を出力します。

凡例を描くために使用するテキストを制御するには、Legend.LegendStyleプロパティやLegend.TextStyleプロパティを使用します。

凡例は、Legend.Alignmentプロパティを使用して、チャートの左・右・上・下に配置できます。

凡例を表示/非表示にする場合は、Legend.Visibleプロパティを使用します。

Invertedプロパティは、凡例の項目を逆から表示します。

Frame、Font、Colorプロパティを使用して、凡例の外観を変更することができます。

Legend.ColorWidthプロパティは、各項目のカラーボックス（シンボル）のパーセント幅を定義します。

Legend.FirstValueプロパティは、最初の凡例項目を描くためにどの系列（あるいは系列ポイント）を使用するかを制御します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Metafile

Steema.TeeChart.TChart.Metafile プロパティ

チャートで描画されたメタファイルイメージを返します。
public Metafile Metafile {get;}

解説

チャートで描画されたメタファイルイメージを返します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Metafiling

Steema.TeeChart.TChart.Metafiling プロパティ

チャートがメタファイルイメージに内部で描画している場合、trueを返します。
public Boolean Metafiling {get;}

解説

チャートがメタファイルイメージに内部で描画している場合、trueを返します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Page

Steema.TeeChart.TChart.Page プロパティ

チャートの複数ページ特性にアクセスします。
public Page Page {get;}

解説

チャートの複数ページ特性にアクセスするために使用してください。

IPageインターフェイスを参照してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Panel

Steema.TeeChart.TChart.Panel プロパティ

チャート背面の可視属性を設定します。
public Panel Panel {get;}

解説

このプロパティを使用して、パネルのすべてのプロパティにアクセスできます。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Panning

Steema.TeeChart.TChart.Panning プロパティ

チャートのパン特性にアクセスします。
public Scroll Panning {get;}

解説

チャートのパン特性にアクセスします。

スクロールのスピードは以下に依存します。

系列と系列ポイントの数。
チャートの幅と高さ。
コンピュータとビデオカードの処理速度。
ビデオ解像度と色の数。
Windowsのバージョンとビデオドライバ。
マウスをドラッグするスピード。

例

Chart.Panning.Allowプロパティを変更して、水平/垂直スクロールを無効に設定できます。

//スクロールの無効
tChart1.Chart.Panning.Allow = Steema.TeeChart.ScrollModes.None;

//また、Horizontal、Vertical、Bothも設定できます

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Printer

Steema.TeeChart.TChart.Printer プロパティ

印刷に関連したプロパティやメソッドにアクセスします。
public Printer Printer {get;}

解説

印刷に関連したプロパティやメソッドにアクセスします。

例

[C#]

tChart1.Printer.Print();

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Printing

Steema.TeeChart.TChart.Printing プロパティ

印刷するチャートを取得/設定します。
public Boolean Printing {get; set;}

解説

実行時および読込み専用。印刷するチャートを取得/設定します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Series

Steema.TeeChart.TChart.Series プロパティ

チャートに含まれる系列のリストにアクセスします。
public SeriesCollection Series {get;}

解説

TeeChartの系列は、リボン系列、 縦棒系列、 円系列などのようなデータ表示メソッド型です。必要に応じて、チャートに異なった系列型を混合させることができます。つまり、デザインはTeeChartで定義された｢チャート型｣に制限されません。

詳細につきましては｢チュートリアル 第6章 - 系列について｣を参照してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


SeriesCount

TeeChartプログラミングガイド

Steema.TeeChart.TChart.SeriesCount プロパティ

チャート内の系列数を返します。このプロパティの代わりにTChart.Series.Countプロパティを使用してください。

public Int32 SeriesCount {get;}

旧式

このプロパティの代わりにTChart.Series.Countプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Site

Steema.TeeChart.TChart.Site プロパティ

TChartコントロールのサイトを取得/設定します。
public override ISite Site {get; set;}

解説

TChartコントロールのサイトを取得/設定します。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


SubFooter

Steema.TeeChart.TChart.SubFooter プロパティ

フッターの上に表示されるテキストを定義します。
public Footer SubFooter {get;}

解説

チャートの下部で、フッターテキストの上に表示するテキストや書式特性を定義します。Textプロパティを使用して、サブフッター行を入力したり、VisibleをTrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


SubHeader

Steema.TeeChart.TChart.SubHeader プロパティ

ヘッダーの下に表示されるテキストを定義します。
public Header SubHeader {get;}

解説

チャートの上部で、ヘッダーテキストの下に表示するテキストや書式特性を定義します。Textプロパティを使用して、サブヘッダー行を入力したり、VisibleをTrueに設定してFontプロパティ、Frameプロパティ、Brushプロパティを変更したりします。テキストの出力位置を制御するには、Alignmentプロパティを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.TChart.Text プロパティ

フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定します。

public virtual String Text {get; set;}

解説

フッター、ヘッダー、サブフッター、サブヘッダーのテキストを設定するために使用してください。

例

[C#]

tChart1.Footer.Text = "My Footer";

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


TimerEnabled

TeeChartプログラミングガイド

Steema.TeeChart.TChart.TimerEnabled プロパティ

チャートを自動的に再描画する内部タイマーを有効/無効にします。このプロパティの代わりに標準のTimerコンポーネントを使用してください。

public Boolean TimerEnabled {get; set;}

旧式

このプロパティの代わりに標準のTimerコンポーネントを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


TimerInterval

TeeChartプログラミングガイド

Steema.TeeChart.TChart.TimerInterval プロパティ

チャートを自動的に再描画するミリ秒単位のインターバルを取得/設定します。このプロパティの代わりに標準のTimerコンポーネントを使用してください。

public Int32 TimerInterval {get; set;}

旧式

このプロパティの代わりに標準のTimerコンポーネントを使用してください。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Tools

Steema.TeeChart.TChart.Tools プロパティ

チャート内に含まれているツールコンポーネントのコレクションです。
public ToolsCollection Tools {get;}

解説

チャート内に含まれているツールコンポーネントのコレクションです。

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Walls

Steema.TeeChart.TChart.Walls プロパティ

チャートの左、下、背面の壁特性にアクセスします。
public Walls Walls {get;}

解説

チャートの左、下、背面の壁特性にアクセスするために使用してください。

例

[C#]

tChart1.Walls.Visible = false;

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Zoom

Steema.TeeChart.TChart.Zoom プロパティ

チャートのズーム特性にアクセスします。
public Zoom Zoom {get;}

解説

チャートのズーム特性にアクセスします。

例

[C#]

tChart1.Zoom.Allow = true;

参照

TChart クラス | TChart メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart.AllowScrollEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.TChart.AllowScrollEventArgs クラス

AllowScrollイベントのデータを提供します。

この型のすべてのメンバの一覧については、AllowScrollEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class AllowScrollEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

AllowScrollEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart.AllowScrollEventArgs 全メンバ

AllowScrollEventArgs 概要

コンストラクタ

Steema.TeeChart.TChart.AllowScrollEventArgs

パブリック フィールド

AllowScroll
Max
Min

参照

AllowScrollEventArgs クラス | Steema.TeeChart 名前空間


AllowScrollEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TChart+AllowScrollEventArgs コンストラクタ

public TChart+AllowScrollEventArgs(Double min,
     Double max,
     Boolean allowScroll)

参照

AllowScrollEventArgs クラス | AllowScrollEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart.AllowScrollEventArgs フィールド

パブリック フィールド

AllowScroll
Max
Min

参照

AllowScrollEventArgs クラス | Steema.TeeChart 名前空間


AllowScroll

TeeChartプログラミングガイド

Steema.TeeChart.TChart+AllowScrollEventArgs.AllowScroll フィールド

public Boolean AllowScroll

解説

trueに設定すると、実行時にマウスのドラッグによるスクロールを有効にします。

参照

AllowScrollEventArgs クラス | AllowScrollEventArgs メンバ | Steema.TeeChart 名前空間


Max

TeeChartプログラミングガイド

Steema.TeeChart.TChart+AllowScrollEventArgs.Max フィールド

public Double Max

参照

AllowScrollEventArgs クラス | AllowScrollEventArgs メンバ | Steema.TeeChart 名前空間


Min

TeeChartプログラミングガイド

Steema.TeeChart.TChart+AllowScrollEventArgs.Min フィールド

public Double Min

参照

AllowScrollEventArgs クラス | AllowScrollEventArgs メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TChart.AllowScrollEventHandler

Steema.TeeChart.TChart.AllowScrollEventHandler デリゲート

スクロールのイベントハンドラ。
public delegate AllowScrollEventHandler (Axis a,
     AllowScrollEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.TChart.SeriesEventHandler

Steema.TeeChart.TChart.SeriesEventHandler デリゲート

共通の系列のイベントハンドラ。
public delegate SeriesEventHandler (Object sender,
     Series s,
     Int32 valueIndex,
     MouseEventArgs e)

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Steema.TeeChart 名前空間


Steema.TeeChart.TeeChartException

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException クラス

基本的なTeeChart の例外クラス。

この型のすべてのメンバの一覧については、TeeChartException メンバを参照してください。

System.Object
System.Exception
[Serializable]
public class TeeChartException : Exception
, ISerializable

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

TeeChartException メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeChartException 全メンバ

TeeChartException 概要

コンストラクタ

Constructor オーバーロード

参照

TeeChartException クラス | Steema.TeeChart 名前空間


TeeChartException コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException コンストラクタ

オーバーロードの一覧

public TeeChartException()
public TeeChartException(System.String, System.Exception)
protected TeeChartException(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)
public TeeChartException(System.String)

参照

TeeChartException クラス | TeeChartException メンバ | Steema.TeeChart 名前空間


TeeChartException コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException コンストラクタ

public TeeChartException()

参照

TeeChartException コンストラクタのオーバーロードの一覧 | TeeChartException クラス | TeeChartException メンバ | Steema.TeeChart 名前空間


TeeChartException コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException コンストラクタ

public TeeChartException(String message,
     Exception e)

参照

TeeChartException コンストラクタのオーバーロードの一覧 | TeeChartException クラス | TeeChartException メンバ | Steema.TeeChart 名前空間


TeeChartException コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException コンストラクタ

protected TeeChartException(SerializationInfo info,
     StreamingContext context)

参照

TeeChartException コンストラクタのオーバーロードの一覧 | TeeChartException クラス | TeeChartException メンバ | Steema.TeeChart 名前空間


TeeChartException コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeChartException コンストラクタ

public TeeChartException(String message)

参照

TeeChartException コンストラクタのオーバーロードの一覧 | TeeChartException クラス | TeeChartException メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEvent

TeeChartプログラミングガイド

Steema.TeeChart.TeeEvent クラス

内部使用。基本的なChartイベントクラス。

この型のすべてのメンバの一覧については、TeeEvent メンバを参照してください。

System.Object
public class TeeEvent : Object

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

TeeEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEvent 全メンバ

TeeEvent 概要

コンストラクタ

Constructor

パブリック フィールド

sender

参照

TeeEvent クラス | Steema.TeeChart 名前空間


TeeEvent コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeEvent コンストラクタ

public TeeEvent()

参照

TeeEvent クラス | TeeEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEvent フィールド

パブリック フィールド

sender

参照

TeeEvent クラス | Steema.TeeChart 名前空間


sender

Steema.TeeChart.TeeEvent.sender フィールド

public Chart sender

参照

TeeEvent クラス | TeeEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEventListeners

TeeChartプログラミングガイド

Steema.TeeChart.TeeEventListeners クラス

TeeChartコンポーネントのインターコミュニケーションの一覧です。

この型のすべてのメンバの一覧については、TeeEventListeners メンバを参照してください。

System.Object
System.Collections.ArrayList
public class TeeEventListeners : ArrayList , IList, ICollection
, IEnumerable, ICloneable

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

TeeEventListeners メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEventListeners 全メンバ

TeeEventListeners 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

TeeEventListeners クラス | Steema.TeeChart 名前空間


TeeEventListeners コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeEventListeners コンストラクタ

public TeeEventListeners()

参照

TeeEventListeners クラス | TeeEventListeners メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeEventListeners プロパティ

パブリック プロパティ

Item

参照

TeeEventListeners クラス | Steema.TeeChart 名前空間


Item

Steema.TeeChart.TeeEventListeners.Item プロパティ

public ITeeEventListener Item(Int32 index) {get; set;}

参照

TeeEventListeners クラス | TeeEventListeners メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeMouseEvent

Steema.TeeChart.TeeMouseEvent クラス

内部使用。マウスイベント。

この型のすべてのメンバの一覧については、TeeMouseEvent メンバを参照してください。

System.Object
Steema.TeeChart.TeeEvent
public class TeeMouseEvent : TeeEvent

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

TeeMouseEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeMouseEvent 全メンバ

TeeMouseEvent 概要

コンストラクタ

Constructor

パブリック フィールド

Button
Event
mArgs
ModifierKeys
sender (TeeEventの継承元)

参照

TeeMouseEvent クラス | Steema.TeeChart 名前空間


TeeMouseEvent コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.TeeMouseEvent コンストラクタ

public TeeMouseEvent()

参照

TeeMouseEvent クラス | TeeMouseEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.TeeMouseEvent フィールド

パブリック フィールド

Button
Event
mArgs
ModifierKeys
sender (TeeEventの継承元)

参照

TeeMouseEvent クラス | Steema.TeeChart 名前空間


Button

TeeChartプログラミングガイド

Steema.TeeChart.TeeMouseEvent.Button フィールド

public MouseButtons Button

参照

TeeMouseEvent クラス | TeeMouseEvent メンバ | Steema.TeeChart 名前空間


Event

Steema.TeeChart.TeeMouseEvent.Event フィールド

public MouseEventKinds Event

参照

TeeMouseEvent クラス | TeeMouseEvent メンバ | Steema.TeeChart 名前空間


mArgs

TeeChartプログラミングガイド

Steema.TeeChart.TeeMouseEvent.mArgs フィールド

public MouseEventArgs mArgs

参照

TeeMouseEvent クラス | TeeMouseEvent メンバ | Steema.TeeChart 名前空間


ModifierKeys

Steema.TeeChart.TeeMouseEvent.ModifierKeys フィールド

public Keys ModifierKeys

参照

TeeMouseEvent クラス | TeeMouseEvent メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Texts

TeeChartプログラミングガイド

Steema.TeeChart.Texts クラス

テキストメッセージやダイアログの定数。

この型のすべてのメンバの一覧については、Texts メンバを参照して下さい。

System.Object
public class Texts : Object

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Texts メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Texts 全メンバ

Texts 概要

コンストラクタ

Constructor

パブリック フィールド

About
AddNewGroup
ADOConnection
All
AllDataFilter
AllFilesFilter
AllPictureFilter
AllSeries
AnnotationDesc
AnnotationSummary
AnnotationTool
AnswerVectorIndex
ApplyColorPalette
AsBMP
AsEMF
AsFlex
AsGIF
AsJPEG
AskDataSet
AskDataSource
AskLanguage
AsPCX
AsPDF
AsPNG
AsPS
AsSVG
AsTIFF
AsVML
AsXAML
AxisArrowDesc
AxisArrowSummary
AxisArrowTool
AxisDlgValue
AxisIncrementNeg
AxisLabels
AxisLabelSep
AxisLogBase
AxisLogDateTime
AxisLogNotPositive
AxisMaxMin
AxisMinMax
AxisScrollDesc
AxisScrollSummary
AxisScrollTool
AxisTitle
BannerTool
BannerToolDesc
BannerToolSummary
BaseLine
BlackIsBackTheme
BlueSkyTheme
BMPFilter
Border
BottomAxis
Box
BrowseImage
BusinessTheme
CalcPeriod
CalendarSeries
Cancel
CandleBar
CandleNoClose
CandleNoOpen
CanNotCreateTempChart
CanNotEmailChart
CannotFindEditor
CanNotFindTempPath
CannotLoadChartFromURL
CannotLoadSeriesDataFromURL
CantDeleteAncestor
CarriageReturnChar
ChangeGroupName
ChangeSeriesTitle
CharForHeight
ChartImageDesc
ChartImageSummary
ChartWizard
CheckPointerSize
Circle
CircularSeries
ClassicTheme
Clear
ClearImage
ClearMessage
ClipSeries
ClipSeriesDesc
ClipSeriesSummary
ColorBandDesc
ColorBandSummary
ColorBandTool
ColorGridSeriesRangeExceed
ColorLineDesc
ColorLineSummary
ColorLineTool
ColorPalette
ColorRange
Colors
Column
ColumnSeparator
CommanMsg3D
CommanMsgChart
CommanMsgCopy
CommanMsgDepth
CommanMsgDepthing
CommanMsgDepthLabel
CommanMsgEdit
CommanMsgMove
CommanMsgMoveLabel
CommanMsgMoving
CommanMsgNormal
CommanMsgNormalLabel
CommanMsgNormalPieLabel
CommanMsgPanel
CommanMsgPieExploding
CommanMsgPrint
CommanMsgRotate
CommanMsgRotateLabel
CommanMsgRotating
CommanMsgSave
CommanMsgZoom
CommanMsgZooming
CommanMsgZoomLabel
Cone
Confirm
Copyright
Cover
Cross
Cube
Current
CursorTool
CursorToolDesc
CursorToolSummary
CustomAxes
CustomAxesEditor
DarkPen
DataSet
DataSource
DataTableTool
DataTableToolDesc
DataTableToolSummary
DateTime
DateTimeFormat
Default
DefaultDemoTee
DefaultEditorHeight
DefaultEditorSize
DefaultFontName
DefaultFontSize
DefaultPercentOf
DefaultPercentOf2
DefaultTheme
DefLogValueFormat
DefPercentFormat
DefValueFormat
Delete
DeltaPointSeries
DepthAxis
DepthTopAxis
DesignFolderNotFound
DesiredIncrement
DiagCross
Diamond
DotFrame
Dotted
Down
DownTri
DragMarksDesc
DragMarksSummary
DragMarksTool
DragPoint
DragPointDesc
DragPointSummary
DrawLineDesc
DrawLineSummary
DrawLineTool
Edit
EditChart
Editing
Ellipse
EMFFilter
EmptyTeeFile
EnterDateTime
ExcelFilter
ExcelTheme
ExpAverageWeight
ExpFinish
Exploded
ExpNext
ExportChart
ExportPanelNotSet
ExtraLegendDesc
ExtraLegendSummary
ExtraLegendTool
ExtrOut
FaderTool
FaderToolSummary
FibonacciTool
FibonacciToolDesc
FieldNotFound
FieldsSeparator
FileSize
Filled
FillSample
First
FittingError
FlexFilter
Foot
FunctionAdd
FunctionADX
FunctionAverage
FunctionBollinger
FunctionCCI
FunctionCLV
FunctionCompress
FunctionCompressOHLC
FunctionCorrelation
FunctionCount
FunctionCross
FunctionCumulative
FunctionCurveFitting
FunctionCustom
FunctionDivide
FunctionDownSampling
FunctionExpAverage
FunctionExpMovAve
FunctionExpTrend
FunctionHigh
FunctionHistogram
FunctionLogTrend
FunctionLow
FunctionMACD
FunctionMedian
FunctionMode
FunctionMomentum
FunctionMomentumDiv
FunctionMovingAverage
FunctionMultiply
FunctionNone
FunctionOBV
FunctionPerf
FunctionPerimeter
FunctionPeriod
FunctionPVO
FunctionRMS
FunctionRSI
FunctionSAR
FunctionSmooth
FunctionStdDeviation
FunctionStochastic
FunctionSubtract
FunctionTrend
FunctionVariance
FunnelBelow
FunnelExceed
FunnelPercent
FunnelSegment
FunnelSeries
FunnelWithin
Gallery3D
GalleryArea
GalleryArrow
GalleryBar
GalleryBar3D
GalleryBarJoin
GalleryBezier
GalleryBigCandle
GalleryBoxPlot
GalleryBubble
GalleryCandle
GalleryCircled
GalleryCircularGauge
GalleryClock
GalleryColorGrid
GalleryContour
GalleryCursor
GalleryDarvas
GalleryDonut
GalleryError
GalleryErrorBar
GalleryExtended
GalleryFastLine
GalleryFinancial
GalleryFunctions
GalleryGantt
GalleryGauge
GalleryGauges
GalleryHighLow
GalleryHistogram
GalleryHorizBar
GalleryHorizBoxPlot
GalleryHorizLine
GalleryIsoSurface
GalleryKagi
GalleryLine
GalleryLinearGauge
GalleryLinePoint
GalleryLogoFont
GalleryMap
GalleryNumericGauge
GalleryOrgChart
GalleryPie
GalleryPoint
GalleryPoint3D
GalleryPointFigure
GalleryPolar
GalleryPolarBar
GalleryPyramid
GalleryRadar
GalleryRenko
GallerySamples
GalleryShape
GallerySmith
GalleryStandard
GalleryStats
GallerySurface
GalleryTagCloud
GalleryTower
GalleryTriSurface
GalleryVector3D
GalleryVerticalLinearGauge
GalleryVolume
GalleryVolumePipe
GalleryWaterFall
GalleryWindRose
GalleryWorldMap
GalleryWorldMaps
GanttSample1
GanttSample10
GanttSample2
GanttSample3
GanttSample4
GanttSample5
GanttSample6
GanttSample7
GanttSample8
GanttSample9
GanttTool
GanttToolDesc
GanttToolSummary
GIFFilter
Gradient
GrayscaleTheme
Grid3D
GridBandDesc
GridBandSummary
GridBandTool
GridTranspose
GridTransposeDesc
GridTransposeSummary
GroupName
Height
HelperScriptAnnotation
Hollow
HorizAreaSeries
HorizHistogramSeries
HorizLine
HotspotSummary
HotspotTool
HTMLFilter
Image
ImageBarSeries
ImagePointSeries
ImageTool
ImageToolSummary
ImportChart
ImportTeeChart
ImportTeeChartFile
IncorrectMaxMinValue
Index
Insert
InvalidEditorClass
InvalidTeeFile
InvPyramid
JPEGFilter
Labels
Last
LEDGauge
LeftAxis
Legend
LegendColorWidth
LegendFirstValue
LegendPaleteToolDesc
LegendPaletteTool
LegendPaletteToolSummary
LegendScrollBarDesc
LegendScrollBarSummary
LightTool
LightToolDesc
LightToolSummary
Line
Lines
LineSeparator
Load
LoadChart
LowBezierPoints
Magnify
MagnifySummary
MappingAfrica
MappingAsia
MappingAustralia
MappingCentralAmerica
MappingEurope
MappingEurope15
MappingEurope27
MappingMiddleEast
MappingNorthAmerica
MappingSouthAmerica
MappingSpain
MappingUSA
MappingUSAHawaiiAlaska
MappingWorld
MapSeries
MarkerTool
Marks
MarksTipDesc
MarksTipSummary
MarksTipTool
Maximum
MaxPointsPerPage
MildOut
Minimum
MissingEditorClass
NearestPointDesc
NearestPointSummary
NearestTool
NewSeriesTitle
Next
No
NoBorder
NoCircle
NoGrid
NoHigh
NoLine
NoLines
NoLow
None
NoPoint
Normal
NoSeriesSelected
OnlineSupport
OpenTeeChartFile
OpenTextFile
OpenXmlThemeFile
OperaTheme
OpportunityValues
Options
Origin
PageNumber
PageOfPages
Patterns
PCXFilter
PDFFilter
Percent3D
Period
PeriodRange
PieOther
PieSample1
PieSample2
PieSample3
PieSample4
PieSample5
PieSample6
PieSample7
PieSample8
PieTool
PieToolDesc
PieToolSummary
PNGFilter
Point2D
Points
PolarDegreeSymbol
PolarGridSeries
PolyDegreeRange
Positions
Post
Preview
PrintPreview
Prior
Property
PSFilter
Pyramid
QuoteValues
RandomTheme
Rectangle
RectangleTool
RectangleToolDesc
RefreshData
RefreshInterval
RightAxis
RotateDesc
RotateSummary
RotateTool
SaveChart
SaveChartToFile
Scale
ScrollBarTool
ScrollTool
ScrollToolDesc
ScrollToolSummary
SelectedSeries
SelectFolder
SelectorTool
SelectorToolDesc
SelectorToolSummary
SelectPictureFile
SelfStack
SemiPie
Separator
Series
SeriesAnimationDesc
SeriesAnimationSummary
SeriesAnimTool
SeriesBandTool
SeriesBandToolDesc
SeriesBandToolSummary
SeriesDelete
SeriesHotspotDesc
SeriesInvDataSource
SeriesList
SeriesParentNoSelf
SeriesRegionTool
SeriesRegionToolSummary
SeriesSetDataSource
SeriesStatsTool
SeriesStatsToolDesc
SeriesStatsToolSummary
SeriesTextFieldZero
SeriesTranspose
SeriesTransposeDesc
SeriesTransposeSummary
Shadow
ShapeGallery1
ShapeGallery2
SideAll
Sides
SingleColor
SingleRecord
SmallDotsPen
SmithReactance
SmithResistance
Stack
Stack100
Stairs
Star
SubChartChartName
SubChartNewChart
SubChartNewName
SubChartRenameChart
SubChartTool
SubChartToolSummary
Summary
SupportURL
SureToApply
SureToDelete
SurfaceNearestTool
SurfaceNearestToolDesc
SurfaceNearestToolSummary
SVGFilter
TabDelimiter
TeeChart
TeeChartExceptionString
TeeChartPocketEval
TeeChartTheme
TeeFiles
TeeFilesExtension
TENFilter
Test
Text
TextFile
TextFilter
TextSrcURL
Themes
ThemeSelector
TIFFFilter
Title
TopAxis
Transparency
Triangle
TriSurfaceAllColinear
TriSurfaceLess
TriSurfaceSimilar
TxtFilesExtension
Up
Value
ValuesAngle
ValuesArrowEndX
ValuesArrowEndY
ValuesBar
ValuesBubbleRadius
ValuesClose
ValuesDate
ValuesFormat
ValuesGanttEnd
ValuesGanttNextTask
ValuesGanttStart
ValuesHigh
ValuesLow
ValuesOffset
ValuesOpen
ValuesPie
ValuesStdError
ValuesVectorEndZ
ValuesX
ValuesY
ValuesZ
VertLine
View3D
VMLFilter
WarningHIColor
WEBTheme
WireFrame
WizardSureToClose
WizardTab
WMFFilter
WrongTeeFileFormat
XAMLFilter
XMLFile
XMLFilter
XPTheme
Yes
ZoomTool
ZoomToolDesc
ZoomToolSummary

参照

Texts クラス | Steema.TeeChart 名前空間


Texts コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Texts コンストラクタ

protected Texts()

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Texts フィールド

パブリック フィールド

About
AddNewGroup
ADOConnection
All
AllDataFilter
AllFilesFilter
AllPictureFilter
AllSeries
AnnotationDesc
AnnotationSummary
AnnotationTool
AnswerVectorIndex
ApplyColorPalette
AsBMP
AsEMF
AsFlex
AsGIF
AsJPEG
AskDataSet
AskDataSource
AskLanguage
AsPCX
AsPDF
AsPNG
AsPS
AsSVG
AsTIFF
AsVML
AsXAML
AxisArrowDesc
AxisArrowSummary
AxisArrowTool
AxisDlgValue
AxisIncrementNeg
AxisLabels
AxisLabelSep
AxisLogBase
AxisLogDateTime
AxisLogNotPositive
AxisMaxMin
AxisMinMax
AxisScrollDesc
AxisScrollSummary
AxisScrollTool
AxisTitle
BannerTool
BannerToolDesc
BannerToolSummary
BaseLine
BlackIsBackTheme
BlueSkyTheme
BMPFilter
Border
BottomAxis
Box
BrowseImage
BusinessTheme
CalcPeriod
CalendarSeries
Cancel
CandleBar
CandleNoClose
CandleNoOpen
CanNotCreateTempChart
CanNotEmailChart
CannotFindEditor
CanNotFindTempPath
CannotLoadChartFromURL
CannotLoadSeriesDataFromURL
CantDeleteAncestor
CarriageReturnChar
ChangeGroupName
ChangeSeriesTitle
CharForHeight
ChartImageDesc
ChartImageSummary
ChartWizard
CheckPointerSize
Circle
CircularSeries
ClassicTheme
Clear
ClearImage
ClearMessage
ClipSeries
ClipSeriesDesc
ClipSeriesSummary
ColorBandDesc
ColorBandSummary
ColorBandTool
ColorGridSeriesRangeExceed
ColorLineDesc
ColorLineSummary
ColorLineTool
ColorPalette
ColorRange
Colors
Column
ColumnSeparator
CommanMsg3D
CommanMsgChart
CommanMsgCopy
CommanMsgDepth
CommanMsgDepthing
CommanMsgDepthLabel
CommanMsgEdit
CommanMsgMove
CommanMsgMoveLabel
CommanMsgMoving
CommanMsgNormal
CommanMsgNormalLabel
CommanMsgNormalPieLabel
CommanMsgPanel
CommanMsgPieExploding
CommanMsgPrint
CommanMsgRotate
CommanMsgRotateLabel
CommanMsgRotating
CommanMsgSave
CommanMsgZoom
CommanMsgZooming
CommanMsgZoomLabel
Cone
Confirm
Copyright
Cover
Cross
Cube
Current
CursorTool
CursorToolDesc
CursorToolSummary
CustomAxes
CustomAxesEditor
DarkPen
DataSet
DataSource
DataTableTool
DataTableToolDesc
DataTableToolSummary
DateTime
DateTimeFormat
Default
DefaultDemoTee
DefaultEditorHeight
DefaultEditorSize
DefaultFontName
DefaultFontSize
DefaultPercentOf
DefaultPercentOf2
DefaultTheme
DefLogValueFormat
DefPercentFormat
DefValueFormat
Delete
DeltaPointSeries
DepthAxis
DepthTopAxis
DesignFolderNotFound
DesiredIncrement
DiagCross
Diamond
DotFrame
Dotted
Down
DownTri
DragMarksDesc
DragMarksSummary
DragMarksTool
DragPoint
DragPointDesc
DragPointSummary
DrawLineDesc
DrawLineSummary
DrawLineTool
Edit
EditChart
Editing
Ellipse
EMFFilter
EmptyTeeFile
EnterDateTime
ExcelFilter
ExcelTheme
ExpAverageWeight
ExpFinish
Exploded
ExpNext
ExportChart
ExportPanelNotSet
ExtraLegendDesc
ExtraLegendSummary
ExtraLegendTool
ExtrOut
FaderTool
FaderToolSummary
FibonacciTool
FibonacciToolDesc
FieldNotFound
FieldsSeparator
FileSize
Filled
FillSample
First
FittingError
FlexFilter
Foot
FunctionAdd
FunctionADX
FunctionAverage
FunctionBollinger
FunctionCCI
FunctionCLV
FunctionCompress
FunctionCompressOHLC
FunctionCorrelation
FunctionCount
FunctionCross
FunctionCumulative
FunctionCurveFitting
FunctionCustom
FunctionDivide
FunctionDownSampling
FunctionExpAverage
FunctionExpMovAve
FunctionExpTrend
FunctionHigh
FunctionHistogram
FunctionLogTrend
FunctionLow
FunctionMACD
FunctionMedian
FunctionMode
FunctionMomentum
FunctionMomentumDiv
FunctionMovingAverage
FunctionMultiply
FunctionNone
FunctionOBV
FunctionPerf
FunctionPerimeter
FunctionPeriod
FunctionPVO
FunctionRMS
FunctionRSI
FunctionSAR
FunctionSmooth
FunctionStdDeviation
FunctionStochastic
FunctionSubtract
FunctionTrend
FunctionVariance
FunnelBelow
FunnelExceed
FunnelPercent
FunnelSegment
FunnelSeries
FunnelWithin
Gallery3D
GalleryArea
GalleryArrow
GalleryBar
GalleryBar3D
GalleryBarJoin
GalleryBezier
GalleryBigCandle
GalleryBoxPlot
GalleryBubble
GalleryCandle
GalleryCircled
GalleryCircularGauge
GalleryClock
GalleryColorGrid
GalleryContour
GalleryCursor
GalleryDarvas
GalleryDonut
GalleryError
GalleryErrorBar
GalleryExtended
GalleryFastLine
GalleryFinancial
GalleryFunctions
GalleryGantt
GalleryGauge
GalleryGauges
GalleryHighLow
GalleryHistogram
GalleryHorizBar
GalleryHorizBoxPlot
GalleryHorizLine
GalleryIsoSurface
GalleryKagi
GalleryLine
GalleryLinearGauge
GalleryLinePoint
GalleryLogoFont
GalleryMap
GalleryNumericGauge
GalleryOrgChart
GalleryPie
GalleryPoint
GalleryPoint3D
GalleryPointFigure
GalleryPolar
GalleryPolarBar
GalleryPyramid
GalleryRadar
GalleryRenko
GallerySamples
GalleryShape
GallerySmith
GalleryStandard
GalleryStats
GallerySurface
GalleryTagCloud
GalleryTower
GalleryTriSurface
GalleryVector3D
GalleryVerticalLinearGauge
GalleryVolume
GalleryVolumePipe
GalleryWaterFall
GalleryWindRose
GalleryWorldMap
GalleryWorldMaps
GanttSample1
GanttSample10
GanttSample2
GanttSample3
GanttSample4
GanttSample5
GanttSample6
GanttSample7
GanttSample8
GanttSample9
GanttTool
GanttToolDesc
GanttToolSummary
GIFFilter
Gradient
GrayscaleTheme
Grid3D
GridBandDesc
GridBandSummary
GridBandTool
GridTranspose
GridTransposeDesc
GridTransposeSummary
GroupName
Height
HelperScriptAnnotation
Hollow
HorizAreaSeries
HorizHistogramSeries
HorizLine
HotspotSummary
HotspotTool
HTMLFilter
Image
ImageBarSeries
ImagePointSeries
ImageTool
ImageToolSummary
ImportChart
ImportTeeChart
ImportTeeChartFile
IncorrectMaxMinValue
Index
Insert
InvalidEditorClass
InvalidTeeFile
InvPyramid
JPEGFilter
Labels
Last
LEDGauge
LeftAxis
Legend
LegendColorWidth
LegendFirstValue
LegendPaleteToolDesc
LegendPaletteTool
LegendPaletteToolSummary
LegendScrollBarDesc
LegendScrollBarSummary
LightTool
LightToolDesc
LightToolSummary
Line
Lines
LineSeparator
Load
LoadChart
LowBezierPoints
Magnify
MagnifySummary
MappingAfrica
MappingAsia
MappingAustralia
MappingCentralAmerica
MappingEurope
MappingEurope15
MappingEurope27
MappingMiddleEast
MappingNorthAmerica
MappingSouthAmerica
MappingSpain
MappingUSA
MappingUSAHawaiiAlaska
MappingWorld
MapSeries
MarkerTool
Marks
MarksTipDesc
MarksTipSummary
MarksTipTool
Maximum
MaxPointsPerPage
MildOut
Minimum
MissingEditorClass
NearestPointDesc
NearestPointSummary
NearestTool
NewSeriesTitle
Next
No
NoBorder
NoCircle
NoGrid
NoHigh
NoLine
NoLines
NoLow
None
NoPoint
Normal
NoSeriesSelected
OnlineSupport
OpenTeeChartFile
OpenTextFile
OpenXmlThemeFile
OperaTheme
OpportunityValues
Options
Origin
PageNumber
PageOfPages
Patterns
PCXFilter
PDFFilter
Percent3D
Period
PeriodRange
PieOther
PieSample1
PieSample2
PieSample3
PieSample4
PieSample5
PieSample6
PieSample7
PieSample8
PieTool
PieToolDesc
PieToolSummary
PNGFilter
Point2D
Points
PolarDegreeSymbol
PolarGridSeries
PolyDegreeRange
Positions
Post
Preview
PrintPreview
Prior
Property
PSFilter
Pyramid
QuoteValues
RandomTheme
Rectangle
RectangleTool
RectangleToolDesc
RefreshData
RefreshInterval
RightAxis
RotateDesc
RotateSummary
RotateTool
SaveChart
SaveChartToFile
Scale
ScrollBarTool
ScrollTool
ScrollToolDesc
ScrollToolSummary
SelectedSeries
SelectFolder
SelectorTool
SelectorToolDesc
SelectorToolSummary
SelectPictureFile
SelfStack
SemiPie
Separator
Series
SeriesAnimationDesc
SeriesAnimationSummary
SeriesAnimTool
SeriesBandTool
SeriesBandToolDesc
SeriesBandToolSummary
SeriesDelete
SeriesHotspotDesc
SeriesInvDataSource
SeriesList
SeriesParentNoSelf
SeriesRegionTool
SeriesRegionToolSummary
SeriesSetDataSource
SeriesStatsTool
SeriesStatsToolDesc
SeriesStatsToolSummary
SeriesTextFieldZero
SeriesTranspose
SeriesTransposeDesc
SeriesTransposeSummary
Shadow
ShapeGallery1
ShapeGallery2
SideAll
Sides
SingleColor
SingleRecord
SmallDotsPen
SmithReactance
SmithResistance
Stack
Stack100
Stairs
Star
SubChartChartName
SubChartNewChart
SubChartNewName
SubChartRenameChart
SubChartTool
SubChartToolSummary
Summary
SupportURL
SureToApply
SureToDelete
SurfaceNearestTool
SurfaceNearestToolDesc
SurfaceNearestToolSummary
SVGFilter
TabDelimiter
TeeChart
TeeChartExceptionString
TeeChartPocketEval
TeeChartTheme
TeeFiles
TeeFilesExtension
TENFilter
Test
Text
TextFile
TextFilter
TextSrcURL
Themes
ThemeSelector
TIFFFilter
Title
TopAxis
Transparency
Triangle
TriSurfaceAllColinear
TriSurfaceLess
TriSurfaceSimilar
TxtFilesExtension
Up
Value
ValuesAngle
ValuesArrowEndX
ValuesArrowEndY
ValuesBar
ValuesBubbleRadius
ValuesClose
ValuesDate
ValuesFormat
ValuesGanttEnd
ValuesGanttNextTask
ValuesGanttStart
ValuesHigh
ValuesLow
ValuesOffset
ValuesOpen
ValuesPie
ValuesStdError
ValuesVectorEndZ
ValuesX
ValuesY
ValuesZ
VertLine
View3D
VMLFilter
WarningHIColor
WEBTheme
WireFrame
WizardSureToClose
WizardTab
WMFFilter
WrongTeeFileFormat
XAMLFilter
XMLFile
XMLFilter
XPTheme
Yes
ZoomTool
ZoomToolDesc
ZoomToolSummary

参照

Texts クラス | Steema.TeeChart 名前空間


About

TeeChartプログラミングガイド

Steema.TeeChart.Texts.About フィールド

public String About

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AddNewGroup

Steema.TeeChart.Texts.AddNewGroup フィールド

public String AddNewGroup

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ADOConnection

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ADOConnection フィールド

public String ADOConnection

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


All

TeeChartプログラミングガイド

Steema.TeeChart.Texts.All フィールド

public String All

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AllDataFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AllDataFilter フィールド

public String AllDataFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AllFilesFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AllFilesFilter フィールド

public String AllFilesFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AllPictureFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AllPictureFilter フィールド

public String AllPictureFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AllSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AllSeries フィールド

public String AllSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AnnotationDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AnnotationDesc フィールド

public const String AnnotationDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AnnotationSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AnnotationSummary フィールド

public String AnnotationSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AnnotationTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AnnotationTool フィールド

public String AnnotationTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AnswerVectorIndex

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AnswerVectorIndex フィールド

public String AnswerVectorIndex

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ApplyColorPalette

Steema.TeeChart.Texts.ApplyColorPalette フィールド

public String ApplyColorPalette

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsBMP

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsBMP フィールド

public String AsBMP

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsEMF

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsEMF フィールド

public String AsEMF

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsFlex

Steema.TeeChart.Texts.AsFlex フィールド

public String AsFlex

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsGIF

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsGIF フィールド

public String AsGIF

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsJPEG

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsJPEG フィールド

public String AsJPEG

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AskDataSet

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AskDataSet フィールド

public String AskDataSet

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AskDataSource

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AskDataSource フィールド

public String AskDataSource

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AskLanguage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AskLanguage フィールド

public String AskLanguage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsPCX

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsPCX フィールド

public String AsPCX

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsPDF

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsPDF フィールド

public String AsPDF

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsPNG

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsPNG フィールド

public String AsPNG

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsPS

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsPS フィールド

public String AsPS

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsSVG

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsSVG フィールド

public String AsSVG

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsTIFF

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsTIFF フィールド

public String AsTIFF

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsVML

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AsVML フィールド

public String AsVML

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AsXAML

Steema.TeeChart.Texts.AsXAML フィールド

public String AsXAML

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisArrowDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisArrowDesc フィールド

public const String AxisArrowDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisArrowSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisArrowSummary フィールド

public String AxisArrowSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisArrowTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisArrowTool フィールド

public String AxisArrowTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisDlgValue

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisDlgValue フィールド

public String AxisDlgValue

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisIncrementNeg

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisIncrementNeg フィールド

public String AxisIncrementNeg

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisLabels

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisLabels フィールド

public String AxisLabels

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisLabelSep

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisLabelSep フィールド

public String AxisLabelSep

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisLogBase

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisLogBase フィールド

public String AxisLogBase

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisLogDateTime

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisLogDateTime フィールド

public String AxisLogDateTime

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisLogNotPositive

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisLogNotPositive フィールド

public String AxisLogNotPositive

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisMaxMin

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisMaxMin フィールド

public String AxisMaxMin

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisMinMax

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisMinMax フィールド

public String AxisMinMax

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisScrollDesc

Steema.TeeChart.Texts.AxisScrollDesc フィールド

public const String AxisScrollDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisScrollSummary

Steema.TeeChart.Texts.AxisScrollSummary フィールド

public String AxisScrollSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisScrollTool

Steema.TeeChart.Texts.AxisScrollTool フィールド

public String AxisScrollTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


AxisTitle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.AxisTitle フィールド

public String AxisTitle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BannerTool

Steema.TeeChart.Texts.BannerTool フィールド

public String BannerTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BannerToolDesc

Steema.TeeChart.Texts.BannerToolDesc フィールド

public const String BannerToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BannerToolSummary

Steema.TeeChart.Texts.BannerToolSummary フィールド

public String BannerToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BaseLine

Steema.TeeChart.Texts.BaseLine フィールド

public String BaseLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BlackIsBackTheme

Steema.TeeChart.Texts.BlackIsBackTheme フィールド

public String BlackIsBackTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BlueSkyTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.BlueSkyTheme フィールド

public String BlueSkyTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BMPFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.BMPFilter フィールド

public String BMPFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Border

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Border フィールド

public String Border

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BottomAxis

TeeChartプログラミングガイド

Steema.TeeChart.Texts.BottomAxis フィールド

public String BottomAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Box

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Box フィールド

public String Box

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BrowseImage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.BrowseImage フィールド

public String BrowseImage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


BusinessTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.BusinessTheme フィールド

public String BusinessTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CalcPeriod

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CalcPeriod フィールド

public String CalcPeriod

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CalendarSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CalendarSeries フィールド

public String CalendarSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Cancel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Cancel フィールド

public String Cancel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CandleBar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CandleBar フィールド

public String CandleBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CandleNoClose

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CandleNoClose フィールド

public String CandleNoClose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CandleNoOpen

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CandleNoOpen フィールド

public String CandleNoOpen

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CanNotCreateTempChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CanNotCreateTempChart フィールド

public String CanNotCreateTempChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CanNotEmailChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CanNotEmailChart フィールド

public String CanNotEmailChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CannotFindEditor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CannotFindEditor フィールド

public String CannotFindEditor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CanNotFindTempPath

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CanNotFindTempPath フィールド

public String CanNotFindTempPath

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CannotLoadChartFromURL

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CannotLoadChartFromURL フィールド

public String CannotLoadChartFromURL

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CannotLoadSeriesDataFromURL

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CannotLoadSeriesDataFromURL フィールド

public String CannotLoadSeriesDataFromURL

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CantDeleteAncestor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CantDeleteAncestor フィールド

public String CantDeleteAncestor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CarriageReturnChar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CarriageReturnChar フィールド

public const Char CarriageReturnChar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ChangeGroupName

Steema.TeeChart.Texts.ChangeGroupName フィールド

public String ChangeGroupName

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ChangeSeriesTitle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ChangeSeriesTitle フィールド

public String ChangeSeriesTitle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CharForHeight

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CharForHeight フィールド

public const String CharForHeight

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ChartImageDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ChartImageDesc フィールド

public const String ChartImageDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ChartImageSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ChartImageSummary フィールド

public String ChartImageSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ChartWizard

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ChartWizard フィールド

public String ChartWizard

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CheckPointerSize

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CheckPointerSize フィールド

public String CheckPointerSize

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Circle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Circle フィールド

public String Circle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CircularSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CircularSeries フィールド

public String CircularSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClassicTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ClassicTheme フィールド

public String ClassicTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Clear

Steema.TeeChart.Texts.Clear フィールド

public String Clear

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClearImage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ClearImage フィールド

public String ClearImage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClearMessage

Steema.TeeChart.Texts.ClearMessage フィールド

public String ClearMessage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClipSeries

Steema.TeeChart.Texts.ClipSeries フィールド

public String ClipSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClipSeriesDesc

Steema.TeeChart.Texts.ClipSeriesDesc フィールド

public const String ClipSeriesDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ClipSeriesSummary

Steema.TeeChart.Texts.ClipSeriesSummary フィールド

public String ClipSeriesSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorBandDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorBandDesc フィールド

public const String ColorBandDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorBandSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorBandSummary フィールド

public String ColorBandSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorBandTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorBandTool フィールド

public String ColorBandTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorGridSeriesRangeExceed

Steema.TeeChart.Texts.ColorGridSeriesRangeExceed フィールド

public String ColorGridSeriesRangeExceed

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorLineDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorLineDesc フィールド

public const String ColorLineDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorLineSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorLineSummary フィールド

public String ColorLineSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorLineTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorLineTool フィールド

public String ColorLineTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorPalette

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorPalette フィールド

public String ColorPalette

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColorRange

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColorRange フィールド

public String ColorRange

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Colors

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Colors フィールド

public String Colors

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Column

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Column フィールド

public String Column

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ColumnSeparator

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ColumnSeparator フィールド

public const Char ColumnSeparator

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsg3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsg3D フィールド

public String CommanMsg3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgChart フィールド

public String CommanMsgChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgCopy

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgCopy フィールド

public String CommanMsgCopy

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgDepth

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgDepth フィールド

public String CommanMsgDepth

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgDepthing

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgDepthing フィールド

public String CommanMsgDepthing

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgDepthLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgDepthLabel フィールド

public String CommanMsgDepthLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgEdit

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgEdit フィールド

public String CommanMsgEdit

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgMove

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgMove フィールド

public String CommanMsgMove

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgMoveLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgMoveLabel フィールド

public String CommanMsgMoveLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgMoving

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgMoving フィールド

public String CommanMsgMoving

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgNormal

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgNormal フィールド

public String CommanMsgNormal

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgNormalLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgNormalLabel フィールド

public String CommanMsgNormalLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgNormalPieLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgNormalPieLabel フィールド

public String CommanMsgNormalPieLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgPanel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgPanel フィールド

public String CommanMsgPanel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgPieExploding

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgPieExploding フィールド

public String CommanMsgPieExploding

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgPrint

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgPrint フィールド

public String CommanMsgPrint

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgRotate

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgRotate フィールド

public String CommanMsgRotate

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgRotateLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgRotateLabel フィールド

public String CommanMsgRotateLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgRotating

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgRotating フィールド

public String CommanMsgRotating

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgSave

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgSave フィールド

public String CommanMsgSave

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgZoom

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgZoom フィールド

public String CommanMsgZoom

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgZooming

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgZooming フィールド

public String CommanMsgZooming

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CommanMsgZoomLabel

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CommanMsgZoomLabel フィールド

public String CommanMsgZoomLabel

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Cone

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Cone フィールド

public String Cone

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Confirm

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Confirm フィールド

public String Confirm

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Copyright

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Copyright フィールド

public const String Copyright

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Cover

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Cover フィールド

public String Cover

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Cross

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Cross フィールド

public String Cross

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Cube

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Cube フィールド

public String Cube

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Current

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Current フィールド

public String Current

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CursorTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CursorTool フィールド

public String CursorTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CursorToolDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CursorToolDesc フィールド

public const String CursorToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CursorToolSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CursorToolSummary フィールド

public String CursorToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CustomAxes

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CustomAxes フィールド

public String CustomAxes

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


CustomAxesEditor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.CustomAxesEditor フィールド

public String CustomAxesEditor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DarkPen

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DarkPen フィールド

public String DarkPen

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DataSet

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DataSet フィールド

public String DataSet

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DataSource

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DataSource フィールド

public String DataSource

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DataTableTool

Steema.TeeChart.Texts.DataTableTool フィールド

public String DataTableTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DataTableToolDesc

Steema.TeeChart.Texts.DataTableToolDesc フィールド

public const String DataTableToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DataTableToolSummary

Steema.TeeChart.Texts.DataTableToolSummary フィールド

public String DataTableToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DateTime

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DateTime フィールド

public String DateTime

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DateTimeFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DateTimeFormat フィールド

public String DateTimeFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Default

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Default フィールド

public String Default

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultDemoTee

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultDemoTee フィールド

public String DefaultDemoTee

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultEditorHeight

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultEditorHeight フィールド

public String DefaultEditorHeight

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultEditorSize

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultEditorSize フィールド

public String DefaultEditorSize

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultFontName

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultFontName フィールド

public String DefaultFontName

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultFontSize

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultFontSize フィールド

public String DefaultFontSize

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultPercentOf

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultPercentOf フィールド

public String DefaultPercentOf

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultPercentOf2

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultPercentOf2 フィールド

public String DefaultPercentOf2

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefaultTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefaultTheme フィールド

public String DefaultTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefLogValueFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefLogValueFormat フィールド

public const String DefLogValueFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefPercentFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefPercentFormat フィールド

public const String DefPercentFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DefValueFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DefValueFormat フィールド

public const String DefValueFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Delete

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Delete フィールド

public String Delete

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DeltaPointSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DeltaPointSeries フィールド

public String DeltaPointSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DepthAxis

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DepthAxis フィールド

public String DepthAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DepthTopAxis

Steema.TeeChart.Texts.DepthTopAxis フィールド

public String DepthTopAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DesignFolderNotFound

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DesignFolderNotFound フィールド

public String DesignFolderNotFound

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DesiredIncrement

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DesiredIncrement フィールド

public String DesiredIncrement

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DiagCross

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DiagCross フィールド

public String DiagCross

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Diamond

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Diamond フィールド

public String Diamond

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DotFrame

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DotFrame フィールド

public String DotFrame

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Dotted

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Dotted フィールド

public String Dotted

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Down

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Down フィールド

public String Down

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DownTri

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DownTri フィールド

public String DownTri

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragMarksDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragMarksDesc フィールド

public const String DragMarksDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragMarksSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragMarksSummary フィールド

public String DragMarksSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragMarksTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragMarksTool フィールド

public String DragMarksTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragPoint

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragPoint フィールド

public String DragPoint

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragPointDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragPointDesc フィールド

public const String DragPointDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DragPointSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DragPointSummary フィールド

public String DragPointSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DrawLineDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DrawLineDesc フィールド

public const String DrawLineDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DrawLineSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DrawLineSummary フィールド

public String DrawLineSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


DrawLineTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.DrawLineTool フィールド

public String DrawLineTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Edit

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Edit フィールド

public String Edit

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


EditChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.EditChart フィールド

public String EditChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Editing

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Editing フィールド

public String Editing

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Ellipse

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Ellipse フィールド

public String Ellipse

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


EMFFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.EMFFilter フィールド

public String EMFFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


EmptyTeeFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.EmptyTeeFile フィールド

public String EmptyTeeFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


EnterDateTime

TeeChartプログラミングガイド

Steema.TeeChart.Texts.EnterDateTime フィールド

public String EnterDateTime

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExcelFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExcelFilter フィールド

public String ExcelFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExcelTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExcelTheme フィールド

public String ExcelTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExpAverageWeight

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExpAverageWeight フィールド

public String ExpAverageWeight

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExpFinish

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExpFinish フィールド

public String ExpFinish

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Exploded

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Exploded フィールド

public String Exploded

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExpNext

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExpNext フィールド

public String ExpNext

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExportChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExportChart フィールド

public String ExportChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExportPanelNotSet

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExportPanelNotSet フィールド

public String ExportPanelNotSet

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExtraLegendDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExtraLegendDesc フィールド

public const String ExtraLegendDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExtraLegendSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExtraLegendSummary フィールド

public String ExtraLegendSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExtraLegendTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExtraLegendTool フィールド

public String ExtraLegendTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ExtrOut

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ExtrOut フィールド

public String ExtrOut

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FaderTool

Steema.TeeChart.Texts.FaderTool フィールド

public String FaderTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FaderToolSummary

Steema.TeeChart.Texts.FaderToolSummary フィールド

public String FaderToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FibonacciTool

Steema.TeeChart.Texts.FibonacciTool フィールド

public String FibonacciTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FibonacciToolDesc

Steema.TeeChart.Texts.FibonacciToolDesc フィールド

public String FibonacciToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FieldNotFound

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FieldNotFound フィールド

public String FieldNotFound

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FieldsSeparator

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FieldsSeparator フィールド

public const Char FieldsSeparator

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FileSize

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FileSize フィールド

public String FileSize

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Filled

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Filled フィールド

public String Filled

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FillSample

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FillSample フィールド

public String FillSample

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


First

TeeChartプログラミングガイド

Steema.TeeChart.Texts.First フィールド

public String First

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FittingError

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FittingError フィールド

public String FittingError

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FlexFilter

Steema.TeeChart.Texts.FlexFilter フィールド

public String FlexFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Foot

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Foot フィールド

public String Foot

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionAdd

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionAdd フィールド

public String FunctionAdd

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionADX

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionADX フィールド

public String FunctionADX

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionAverage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionAverage フィールド

public String FunctionAverage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionBollinger

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionBollinger フィールド

public String FunctionBollinger

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCCI

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCCI フィールド

public String FunctionCCI

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCLV

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCLV フィールド

public String FunctionCLV

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCompress

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCompress フィールド

public String FunctionCompress

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCompressOHLC

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCompressOHLC フィールド

public String FunctionCompressOHLC

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCorrelation

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCorrelation フィールド

public String FunctionCorrelation

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCount

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCount フィールド

public String FunctionCount

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCross

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCross フィールド

public String FunctionCross

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCumulative

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCumulative フィールド

public String FunctionCumulative

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCurveFitting

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCurveFitting フィールド

public String FunctionCurveFitting

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionCustom

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionCustom フィールド

public String FunctionCustom

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionDivide

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionDivide フィールド

public String FunctionDivide

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionDownSampling

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionDownSampling フィールド

public String FunctionDownSampling

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionExpAverage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionExpAverage フィールド

public String FunctionExpAverage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionExpMovAve

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionExpMovAve フィールド

public String FunctionExpMovAve

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionExpTrend

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionExpTrend フィールド

public String FunctionExpTrend

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionHigh

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionHigh フィールド

public String FunctionHigh

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionHistogram

Steema.TeeChart.Texts.FunctionHistogram フィールド

public String FunctionHistogram

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionLogTrend

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionLogTrend フィールド

public String FunctionLogTrend

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionLow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionLow フィールド

public String FunctionLow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMACD

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionMACD フィールド

public String FunctionMACD

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMedian

Steema.TeeChart.Texts.FunctionMedian フィールド

public String FunctionMedian

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMode

Steema.TeeChart.Texts.FunctionMode フィールド

public String FunctionMode

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMomentum

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionMomentum フィールド

public String FunctionMomentum

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMomentumDiv

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionMomentumDiv フィールド

public String FunctionMomentumDiv

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMovingAverage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionMovingAverage フィールド

public String FunctionMovingAverage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionMultiply

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionMultiply フィールド

public String FunctionMultiply

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionNone

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionNone フィールド

public String FunctionNone

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionOBV

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionOBV フィールド

public String FunctionOBV

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionPerf

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionPerf フィールド

public String FunctionPerf

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionPerimeter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionPerimeter フィールド

public String FunctionPerimeter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionPeriod

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionPeriod フィールド

public String FunctionPeriod

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionPVO

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionPVO フィールド

public String FunctionPVO

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionRMS

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionRMS フィールド

public String FunctionRMS

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionRSI

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionRSI フィールド

public String FunctionRSI

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionSAR

Steema.TeeChart.Texts.FunctionSAR フィールド

public String FunctionSAR

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionSmooth

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionSmooth フィールド

public String FunctionSmooth

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionStdDeviation

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionStdDeviation フィールド

public String FunctionStdDeviation

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionStochastic

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionStochastic フィールド

public String FunctionStochastic

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionSubtract

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionSubtract フィールド

public String FunctionSubtract

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionTrend

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionTrend フィールド

public String FunctionTrend

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunctionVariance

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunctionVariance フィールド

public String FunctionVariance

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelBelow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelBelow フィールド

public String FunnelBelow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelExceed

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelExceed フィールド

public String FunnelExceed

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelPercent

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelPercent フィールド

public String FunnelPercent

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelSegment

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelSegment フィールド

public String FunnelSegment

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelSeries フィールド

public String FunnelSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


FunnelWithin

TeeChartプログラミングガイド

Steema.TeeChart.Texts.FunnelWithin フィールド

public String FunnelWithin

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Gallery3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Gallery3D フィールド

public String Gallery3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryArea

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryArea フィールド

public String GalleryArea

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryArrow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryArrow フィールド

public String GalleryArrow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBar フィールド

public String GalleryBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBar3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBar3D フィールド

public String GalleryBar3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBarJoin

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBarJoin フィールド

public String GalleryBarJoin

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBezier

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBezier フィールド

public String GalleryBezier

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBigCandle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBigCandle フィールド

public String GalleryBigCandle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBoxPlot

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBoxPlot フィールド

public String GalleryBoxPlot

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryBubble

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryBubble フィールド

public String GalleryBubble

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryCandle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryCandle フィールド

public String GalleryCandle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryCircled

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryCircled フィールド

public String GalleryCircled

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryCircularGauge

Steema.TeeChart.Texts.GalleryCircularGauge フィールド

public String GalleryCircularGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryClock

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryClock フィールド

public String GalleryClock

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryColorGrid

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryColorGrid フィールド

public String GalleryColorGrid

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryContour

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryContour フィールド

public String GalleryContour

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryCursor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryCursor フィールド

public String GalleryCursor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryDarvas

Steema.TeeChart.Texts.GalleryDarvas フィールド

public String GalleryDarvas

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryDonut

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryDonut フィールド

public String GalleryDonut

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryError

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryError フィールド

public String GalleryError

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryErrorBar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryErrorBar フィールド

public String GalleryErrorBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryExtended

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryExtended フィールド

public String GalleryExtended

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryFastLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryFastLine フィールド

public String GalleryFastLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryFinancial

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryFinancial フィールド

public String GalleryFinancial

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryFunctions

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryFunctions フィールド

public String GalleryFunctions

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryGantt

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryGantt フィールド

public String GalleryGantt

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryGauge

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryGauge フィールド

public String GalleryGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryGauges

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryGauges フィールド

public String GalleryGauges

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryHighLow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryHighLow フィールド

public String GalleryHighLow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryHistogram

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryHistogram フィールド

public String GalleryHistogram

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryHorizBar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryHorizBar フィールド

public String GalleryHorizBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryHorizBoxPlot

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryHorizBoxPlot フィールド

public String GalleryHorizBoxPlot

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryHorizLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryHorizLine フィールド

public String GalleryHorizLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryIsoSurface

Steema.TeeChart.Texts.GalleryIsoSurface フィールド

public String GalleryIsoSurface

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryKagi

Steema.TeeChart.Texts.GalleryKagi フィールド

public String GalleryKagi

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryLine フィールド

public String GalleryLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryLinearGauge

Steema.TeeChart.Texts.GalleryLinearGauge フィールド

public String GalleryLinearGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryLinePoint

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryLinePoint フィールド

public String GalleryLinePoint

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryLogoFont

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryLogoFont フィールド

public String GalleryLogoFont

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryMap

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryMap フィールド

public String GalleryMap

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryNumericGauge

Steema.TeeChart.Texts.GalleryNumericGauge フィールド

public String GalleryNumericGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryOrgChart

Steema.TeeChart.Texts.GalleryOrgChart フィールド

public String GalleryOrgChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPie

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPie フィールド

public String GalleryPie

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPoint

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPoint フィールド

public String GalleryPoint

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPoint3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPoint3D フィールド

public String GalleryPoint3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPointFigure

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPointFigure フィールド

public String GalleryPointFigure

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPolar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPolar フィールド

public String GalleryPolar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPolarBar

Steema.TeeChart.Texts.GalleryPolarBar フィールド

public String GalleryPolarBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryPyramid

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryPyramid フィールド

public String GalleryPyramid

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryRadar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryRadar フィールド

public String GalleryRadar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryRenko

Steema.TeeChart.Texts.GalleryRenko フィールド

public String GalleryRenko

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GallerySamples

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GallerySamples フィールド

public String GallerySamples

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryShape

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryShape フィールド

public String GalleryShape

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GallerySmith

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GallerySmith フィールド

public String GallerySmith

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryStandard

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryStandard フィールド

public String GalleryStandard

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryStats

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryStats フィールド

public String GalleryStats

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GallerySurface

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GallerySurface フィールド

public String GallerySurface

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryTagCloud

Steema.TeeChart.Texts.GalleryTagCloud フィールド

public String GalleryTagCloud

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryTower

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryTower フィールド

public String GalleryTower

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryTriSurface

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryTriSurface フィールド

public String GalleryTriSurface

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryVector3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryVector3D フィールド

public String GalleryVector3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryVerticalLinearGauge

Steema.TeeChart.Texts.GalleryVerticalLinearGauge フィールド

public String GalleryVerticalLinearGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryVolume

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryVolume フィールド

public String GalleryVolume

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryVolumePipe

Steema.TeeChart.Texts.GalleryVolumePipe フィールド

public String GalleryVolumePipe

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryWaterFall

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryWaterFall フィールド

public String GalleryWaterFall

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryWindRose

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GalleryWindRose フィールド

public String GalleryWindRose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryWorldMap

Steema.TeeChart.Texts.GalleryWorldMap フィールド

public String GalleryWorldMap

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GalleryWorldMaps

Steema.TeeChart.Texts.GalleryWorldMaps フィールド

public String GalleryWorldMaps

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample1

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample1 フィールド

public String GanttSample1

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample10

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample10 フィールド

public String GanttSample10

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample2

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample2 フィールド

public String GanttSample2

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample3

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample3 フィールド

public String GanttSample3

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample4

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample4 フィールド

public String GanttSample4

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample5

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample5 フィールド

public String GanttSample5

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample6

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample6 フィールド

public String GanttSample6

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample7

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample7 フィールド

public String GanttSample7

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample8

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample8 フィールド

public String GanttSample8

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttSample9

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttSample9 フィールド

public String GanttSample9

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttTool フィールド

public String GanttTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttToolDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttToolDesc フィールド

public const String GanttToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GanttToolSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GanttToolSummary フィールド

public String GanttToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GIFFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GIFFilter フィールド

public String GIFFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Gradient

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Gradient フィールド

public String Gradient

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GrayscaleTheme

Steema.TeeChart.Texts.GrayscaleTheme フィールド

public String GrayscaleTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Grid3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Grid3D フィールド

public String Grid3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridBandDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridBandDesc フィールド

public const String GridBandDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridBandSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridBandSummary フィールド

public String GridBandSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridBandTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridBandTool フィールド

public String GridBandTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridTranspose

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridTranspose フィールド

public String GridTranspose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridTransposeDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridTransposeDesc フィールド

public const String GridTransposeDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GridTransposeSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.GridTransposeSummary フィールド

public String GridTransposeSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


GroupName

Steema.TeeChart.Texts.GroupName フィールド

public String GroupName

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Height フィールド

public String Height

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HelperScriptAnnotation

Steema.TeeChart.Texts.HelperScriptAnnotation フィールド

public String HelperScriptAnnotation

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Hollow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Hollow フィールド

public String Hollow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HorizAreaSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.HorizAreaSeries フィールド

public String HorizAreaSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HorizHistogramSeries

Steema.TeeChart.Texts.HorizHistogramSeries フィールド

public String HorizHistogramSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HorizLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.HorizLine フィールド

public String HorizLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HotspotSummary

Steema.TeeChart.Texts.HotspotSummary フィールド

public String HotspotSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HotspotTool

Steema.TeeChart.Texts.HotspotTool フィールド

public String HotspotTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


HTMLFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.HTMLFilter フィールド

public String HTMLFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Image

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Image フィールド

public String Image

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImageBarSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImageBarSeries フィールド

public String ImageBarSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImagePointSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImagePointSeries フィールド

public String ImagePointSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImageTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImageTool フィールド

public String ImageTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImageToolSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImageToolSummary フィールド

public String ImageToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImportChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImportChart フィールド

public String ImportChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImportTeeChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImportTeeChart フィールド

public String ImportTeeChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ImportTeeChartFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ImportTeeChartFile フィールド

public String ImportTeeChartFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


IncorrectMaxMinValue

TeeChartプログラミングガイド

Steema.TeeChart.Texts.IncorrectMaxMinValue フィールド

public String IncorrectMaxMinValue

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Index

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Index フィールド

public String Index

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Insert

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Insert フィールド

public String Insert

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


InvalidEditorClass

TeeChartプログラミングガイド

Steema.TeeChart.Texts.InvalidEditorClass フィールド

public String InvalidEditorClass

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


InvalidTeeFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.InvalidTeeFile フィールド

public String InvalidTeeFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


InvPyramid

TeeChartプログラミングガイド

Steema.TeeChart.Texts.InvPyramid フィールド

public String InvPyramid

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


JPEGFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.JPEGFilter フィールド

public String JPEGFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Labels

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Labels フィールド

public String Labels

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Last

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Last フィールド

public String Last

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LEDGauge

Steema.TeeChart.Texts.LEDGauge フィールド

public String LEDGauge

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LeftAxis

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LeftAxis フィールド

public String LeftAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Legend

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Legend フィールド

public String Legend

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendColorWidth

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LegendColorWidth フィールド

public String LegendColorWidth

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendFirstValue

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LegendFirstValue フィールド

public String LegendFirstValue

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendPaleteToolDesc

Steema.TeeChart.Texts.LegendPaleteToolDesc フィールド

public const String LegendPaleteToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendPaletteTool

Steema.TeeChart.Texts.LegendPaletteTool フィールド

public String LegendPaletteTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendPaletteToolSummary

Steema.TeeChart.Texts.LegendPaletteToolSummary フィールド

public String LegendPaletteToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendScrollBarDesc

Steema.TeeChart.Texts.LegendScrollBarDesc フィールド

public const String LegendScrollBarDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LegendScrollBarSummary

Steema.TeeChart.Texts.LegendScrollBarSummary フィールド

public String LegendScrollBarSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LightTool

Steema.TeeChart.Texts.LightTool フィールド

public String LightTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LightToolDesc

Steema.TeeChart.Texts.LightToolDesc フィールド

public const String LightToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LightToolSummary

Steema.TeeChart.Texts.LightToolSummary フィールド

public String LightToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Line

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Line フィールド

public String Line

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Lines

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Lines フィールド

public String Lines

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LineSeparator

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LineSeparator フィールド

public const Char LineSeparator

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Load

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Load フィールド

public String Load

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LoadChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LoadChart フィールド

public String LoadChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


LowBezierPoints

TeeChartプログラミングガイド

Steema.TeeChart.Texts.LowBezierPoints フィールド

public String LowBezierPoints

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Magnify

Steema.TeeChart.Texts.Magnify フィールド

public String Magnify

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MagnifySummary

Steema.TeeChart.Texts.MagnifySummary フィールド

public String MagnifySummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingAfrica

Steema.TeeChart.Texts.MappingAfrica フィールド

public String MappingAfrica

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingAsia

Steema.TeeChart.Texts.MappingAsia フィールド

public String MappingAsia

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingAustralia

Steema.TeeChart.Texts.MappingAustralia フィールド

public String MappingAustralia

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingCentralAmerica

Steema.TeeChart.Texts.MappingCentralAmerica フィールド

public String MappingCentralAmerica

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingEurope

Steema.TeeChart.Texts.MappingEurope フィールド

public String MappingEurope

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingEurope15

Steema.TeeChart.Texts.MappingEurope15 フィールド

public String MappingEurope15

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingEurope27

Steema.TeeChart.Texts.MappingEurope27 フィールド

public String MappingEurope27

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingMiddleEast

Steema.TeeChart.Texts.MappingMiddleEast フィールド

public String MappingMiddleEast

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingNorthAmerica

Steema.TeeChart.Texts.MappingNorthAmerica フィールド

public String MappingNorthAmerica

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingSouthAmerica

Steema.TeeChart.Texts.MappingSouthAmerica フィールド

public String MappingSouthAmerica

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingSpain

Steema.TeeChart.Texts.MappingSpain フィールド

public String MappingSpain

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingUSA

Steema.TeeChart.Texts.MappingUSA フィールド

public String MappingUSA

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingUSAHawaiiAlaska

Steema.TeeChart.Texts.MappingUSAHawaiiAlaska フィールド

public String MappingUSAHawaiiAlaska

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MappingWorld

Steema.TeeChart.Texts.MappingWorld フィールド

public String MappingWorld

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MapSeries

Steema.TeeChart.Texts.MapSeries フィールド

public String MapSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MarkerTool

Steema.TeeChart.Texts.MarkerTool フィールド

public String MarkerTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Marks

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Marks フィールド

public String Marks

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MarksTipDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MarksTipDesc フィールド

public const String MarksTipDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MarksTipSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MarksTipSummary フィールド

public String MarksTipSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MarksTipTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MarksTipTool フィールド

public String MarksTipTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Maximum

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Maximum フィールド

public String Maximum

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MaxPointsPerPage

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MaxPointsPerPage フィールド

public String MaxPointsPerPage

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MildOut

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MildOut フィールド

public String MildOut

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Minimum

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Minimum フィールド

public String Minimum

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


MissingEditorClass

TeeChartプログラミングガイド

Steema.TeeChart.Texts.MissingEditorClass フィールド

public String MissingEditorClass

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NearestPointDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NearestPointDesc フィールド

public const String NearestPointDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NearestPointSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NearestPointSummary フィールド

public String NearestPointSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NearestTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NearestTool フィールド

public String NearestTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NewSeriesTitle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NewSeriesTitle フィールド

public String NewSeriesTitle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Next

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Next フィールド

public String Next

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


No

TeeChartプログラミングガイド

Steema.TeeChart.Texts.No フィールド

public String No

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoBorder

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoBorder フィールド

public String NoBorder

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoCircle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoCircle フィールド

public String NoCircle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoGrid

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoGrid フィールド

public String NoGrid

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoHigh

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoHigh フィールド

public String NoHigh

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoLine フィールド

public String NoLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoLines

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoLines フィールド

public String NoLines

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoLow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoLow フィールド

public String NoLow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


None

TeeChartプログラミングガイド

Steema.TeeChart.Texts.None フィールド

public String None

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoPoint

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoPoint フィールド

public String NoPoint

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Normal

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Normal フィールド

public String Normal

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


NoSeriesSelected

TeeChartプログラミングガイド

Steema.TeeChart.Texts.NoSeriesSelected フィールド

public String NoSeriesSelected

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OnlineSupport

TeeChartプログラミングガイド

Steema.TeeChart.Texts.OnlineSupport フィールド

public String OnlineSupport

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OpenTeeChartFile

Steema.TeeChart.Texts.OpenTeeChartFile フィールド

public String OpenTeeChartFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OpenTextFile

Steema.TeeChart.Texts.OpenTextFile フィールド

public String OpenTextFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OpenXmlThemeFile

Steema.TeeChart.Texts.OpenXmlThemeFile フィールド

public String OpenXmlThemeFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OperaTheme

Steema.TeeChart.Texts.OperaTheme フィールド

public String OperaTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


OpportunityValues

TeeChartプログラミングガイド

Steema.TeeChart.Texts.OpportunityValues フィールド

public String OpportunityValues

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Options

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Options フィールド

public String Options

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Origin

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Origin フィールド

public String Origin

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PageNumber

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PageNumber フィールド

public String PageNumber

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PageOfPages

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PageOfPages フィールド

public String PageOfPages

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Patterns

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Patterns フィールド

public String Patterns

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PCXFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PCXFilter フィールド

public String PCXFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PDFFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PDFFilter フィールド

public String PDFFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Percent3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Percent3D フィールド

public String Percent3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Period

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Period フィールド

public String Period

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PeriodRange

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PeriodRange フィールド

public String PeriodRange

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieOther

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieOther フィールド

public String PieOther

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample1

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample1 フィールド

public String PieSample1

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample2

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample2 フィールド

public String PieSample2

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample3

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample3 フィールド

public String PieSample3

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample4

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample4 フィールド

public String PieSample4

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample5

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample5 フィールド

public String PieSample5

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample6

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample6 フィールド

public String PieSample6

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample7

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample7 フィールド

public String PieSample7

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieSample8

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieSample8 フィールド

public String PieSample8

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieTool フィールド

public String PieTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieToolDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieToolDesc フィールド

public const String PieToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PieToolSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PieToolSummary フィールド

public String PieToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PNGFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PNGFilter フィールド

public String PNGFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Point2D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Point2D フィールド

public String Point2D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Points

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Points フィールド

public String Points

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PolarDegreeSymbol

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PolarDegreeSymbol フィールド

public const String PolarDegreeSymbol

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PolarGridSeries

Steema.TeeChart.Texts.PolarGridSeries フィールド

public String PolarGridSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PolyDegreeRange

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PolyDegreeRange フィールド

public String PolyDegreeRange

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Positions

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Positions フィールド

public String Positions

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Post

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Post フィールド

public String Post

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Preview

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Preview フィールド

public String Preview

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PrintPreview

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PrintPreview フィールド

public String PrintPreview

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Prior

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Prior フィールド

public String Prior

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Property

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Property フィールド

public String Property

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


PSFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.PSFilter フィールド

public String PSFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Pyramid

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Pyramid フィールド

public String Pyramid

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


QuoteValues

TeeChartプログラミングガイド

Steema.TeeChart.Texts.QuoteValues フィールド

public String QuoteValues

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RandomTheme

Steema.TeeChart.Texts.RandomTheme フィールド

public String RandomTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Rectangle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Rectangle フィールド

public String Rectangle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RectangleTool

Steema.TeeChart.Texts.RectangleTool フィールド

public String RectangleTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RectangleToolDesc

Steema.TeeChart.Texts.RectangleToolDesc フィールド

public const String RectangleToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RefreshData

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RefreshData フィールド

public String RefreshData

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RefreshInterval

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RefreshInterval フィールド

public String RefreshInterval

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RightAxis

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RightAxis フィールド

public String RightAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RotateDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RotateDesc フィールド

public const String RotateDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RotateSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RotateSummary フィールド

public String RotateSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


RotateTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.RotateTool フィールド

public String RotateTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SaveChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SaveChart フィールド

public String SaveChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SaveChartToFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SaveChartToFile フィールド

public String SaveChartToFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Scale

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Scale フィールド

public String Scale

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ScrollBarTool

Steema.TeeChart.Texts.ScrollBarTool フィールド

public String ScrollBarTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ScrollTool

Steema.TeeChart.Texts.ScrollTool フィールド

public String ScrollTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ScrollToolDesc

Steema.TeeChart.Texts.ScrollToolDesc フィールド

public const String ScrollToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ScrollToolSummary

Steema.TeeChart.Texts.ScrollToolSummary フィールド

public String ScrollToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectedSeries

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SelectedSeries フィールド

public String SelectedSeries

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectFolder

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SelectFolder フィールド

public String SelectFolder

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectorTool

Steema.TeeChart.Texts.SelectorTool フィールド

public String SelectorTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectorToolDesc

Steema.TeeChart.Texts.SelectorToolDesc フィールド

public const String SelectorToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectorToolSummary

Steema.TeeChart.Texts.SelectorToolSummary フィールド

public String SelectorToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelectPictureFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SelectPictureFile フィールド

public String SelectPictureFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SelfStack

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SelfStack フィールド

public String SelfStack

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SemiPie

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SemiPie フィールド

public String SemiPie

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Separator

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Separator フィールド

public String Separator

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Series

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Series フィールド

public String Series

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesAnimationDesc

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesAnimationDesc フィールド

public const String SeriesAnimationDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesAnimationSummary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesAnimationSummary フィールド

public String SeriesAnimationSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesAnimTool

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesAnimTool フィールド

public String SeriesAnimTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesBandTool

Steema.TeeChart.Texts.SeriesBandTool フィールド

public String SeriesBandTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesBandToolDesc

Steema.TeeChart.Texts.SeriesBandToolDesc フィールド

public const String SeriesBandToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesBandToolSummary

Steema.TeeChart.Texts.SeriesBandToolSummary フィールド

public String SeriesBandToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesDelete

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesDelete フィールド

public String SeriesDelete

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesHotspotDesc

Steema.TeeChart.Texts.SeriesHotspotDesc フィールド

public const String SeriesHotspotDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesInvDataSource

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesInvDataSource フィールド

public String SeriesInvDataSource

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesList

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesList フィールド

public String SeriesList

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesParentNoSelf

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesParentNoSelf フィールド

public String SeriesParentNoSelf

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesRegionTool

Steema.TeeChart.Texts.SeriesRegionTool フィールド

public String SeriesRegionTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesRegionToolSummary

Steema.TeeChart.Texts.SeriesRegionToolSummary フィールド

public String SeriesRegionToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesSetDataSource

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesSetDataSource フィールド

public String SeriesSetDataSource

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesStatsTool

Steema.TeeChart.Texts.SeriesStatsTool フィールド

public String SeriesStatsTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesStatsToolDesc

Steema.TeeChart.Texts.SeriesStatsToolDesc フィールド

public const String SeriesStatsToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesStatsToolSummary

Steema.TeeChart.Texts.SeriesStatsToolSummary フィールド

public String SeriesStatsToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesTextFieldZero

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SeriesTextFieldZero フィールド

public String SeriesTextFieldZero

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesTranspose

Steema.TeeChart.Texts.SeriesTranspose フィールド

public String SeriesTranspose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesTransposeDesc

Steema.TeeChart.Texts.SeriesTransposeDesc フィールド

public const String SeriesTransposeDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SeriesTransposeSummary

Steema.TeeChart.Texts.SeriesTransposeSummary フィールド

public String SeriesTransposeSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Shadow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Shadow フィールド

public String Shadow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ShapeGallery1

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ShapeGallery1 フィールド

public String ShapeGallery1

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ShapeGallery2

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ShapeGallery2 フィールド

public String ShapeGallery2

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SideAll

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SideAll フィールド

public String SideAll

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Sides

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Sides フィールド

public String Sides

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SingleColor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SingleColor フィールド

public String SingleColor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SingleRecord

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SingleRecord フィールド

public String SingleRecord

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SmallDotsPen

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SmallDotsPen フィールド

public String SmallDotsPen

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SmithReactance

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SmithReactance フィールド

public String SmithReactance

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SmithResistance

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SmithResistance フィールド

public String SmithResistance

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Stack

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Stack フィールド

public String Stack

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Stack100

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Stack100 フィールド

public String Stack100

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Stairs

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Stairs フィールド

public String Stairs

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Star

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Star フィールド

public String Star

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartChartName

Steema.TeeChart.Texts.SubChartChartName フィールド

public String SubChartChartName

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartNewChart

Steema.TeeChart.Texts.SubChartNewChart フィールド

public String SubChartNewChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartNewName

Steema.TeeChart.Texts.SubChartNewName フィールド

public String SubChartNewName

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartRenameChart

Steema.TeeChart.Texts.SubChartRenameChart フィールド

public String SubChartRenameChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartTool

Steema.TeeChart.Texts.SubChartTool フィールド

public String SubChartTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SubChartToolSummary

Steema.TeeChart.Texts.SubChartToolSummary フィールド

public String SubChartToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Summary

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Summary フィールド

public String Summary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SupportURL

Steema.TeeChart.Texts.SupportURL フィールド

public String SupportURL

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SureToApply

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SureToApply フィールド

public String SureToApply

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SureToDelete

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SureToDelete フィールド

public String SureToDelete

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SurfaceNearestTool

Steema.TeeChart.Texts.SurfaceNearestTool フィールド

public String SurfaceNearestTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SurfaceNearestToolDesc

Steema.TeeChart.Texts.SurfaceNearestToolDesc フィールド

public const String SurfaceNearestToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SurfaceNearestToolSummary

Steema.TeeChart.Texts.SurfaceNearestToolSummary フィールド

public String SurfaceNearestToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


SVGFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.SVGFilter フィールド

public String SVGFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TabDelimiter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TabDelimiter フィールド

public String TabDelimiter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeChart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TeeChart フィールド

public const String TeeChart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeChartExceptionString

Steema.TeeChart.Texts.TeeChartExceptionString フィールド

public String TeeChartExceptionString

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeChartPocketEval

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TeeChartPocketEval フィールド

public const String TeeChartPocketEval

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeChartTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TeeChartTheme フィールド

public String TeeChartTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeFiles

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TeeFiles フィールド

public String TeeFiles

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TeeFilesExtension

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TeeFilesExtension フィールド

public String TeeFilesExtension

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TENFilter

Steema.TeeChart.Texts.TENFilter フィールド

public String TENFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Test

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Test フィールド

public String Test

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Text フィールド

public String Text

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TextFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TextFile フィールド

public String TextFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TextFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TextFilter フィールド

public String TextFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TextSrcURL

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TextSrcURL フィールド

public String TextSrcURL

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Themes

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Themes フィールド

public String Themes

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ThemeSelector

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ThemeSelector フィールド

public String ThemeSelector

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TIFFFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TIFFFilter フィールド

public String TIFFFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Title

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Title フィールド

public String Title

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TopAxis

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TopAxis フィールド

public String TopAxis

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Transparency フィールド

public String Transparency

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Triangle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Triangle フィールド

public String Triangle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TriSurfaceAllColinear

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TriSurfaceAllColinear フィールド

public String TriSurfaceAllColinear

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TriSurfaceLess

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TriSurfaceLess フィールド

public String TriSurfaceLess

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TriSurfaceSimilar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.TriSurfaceSimilar フィールド

public String TriSurfaceSimilar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


TxtFilesExtension

Steema.TeeChart.Texts.TxtFilesExtension フィールド

public String TxtFilesExtension

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Up

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Up フィールド

public String Up

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Value フィールド

public String Value

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesAngle

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesAngle フィールド

public String ValuesAngle

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesArrowEndX

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesArrowEndX フィールド

public String ValuesArrowEndX

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesArrowEndY

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesArrowEndY フィールド

public String ValuesArrowEndY

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesBar

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesBar フィールド

public String ValuesBar

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesBubbleRadius

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesBubbleRadius フィールド

public String ValuesBubbleRadius

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesClose

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesClose フィールド

public String ValuesClose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesDate

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesDate フィールド

public String ValuesDate

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesFormat フィールド

public String ValuesFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesGanttEnd

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesGanttEnd フィールド

public String ValuesGanttEnd

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesGanttNextTask

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesGanttNextTask フィールド

public String ValuesGanttNextTask

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesGanttStart

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesGanttStart フィールド

public String ValuesGanttStart

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesHigh

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesHigh フィールド

public String ValuesHigh

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesLow

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesLow フィールド

public String ValuesLow

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesOffset

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesOffset フィールド

public String ValuesOffset

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesOpen

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesOpen フィールド

public String ValuesOpen

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesPie

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesPie フィールド

public String ValuesPie

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesStdError

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesStdError フィールド

public String ValuesStdError

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesVectorEndZ

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesVectorEndZ フィールド

public String ValuesVectorEndZ

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesX

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesX フィールド

public const String ValuesX

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesY

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesY フィールド

public const String ValuesY

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ValuesZ

TeeChartプログラミングガイド

Steema.TeeChart.Texts.ValuesZ フィールド

public const String ValuesZ

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


VertLine

TeeChartプログラミングガイド

Steema.TeeChart.Texts.VertLine フィールド

public String VertLine

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


View3D

TeeChartプログラミングガイド

Steema.TeeChart.Texts.View3D フィールド

public String View3D

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


VMLFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.VMLFilter フィールド

public String VMLFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WarningHIColor

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WarningHIColor フィールド

public String WarningHIColor

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WEBTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WEBTheme フィールド

public String WEBTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WireFrame

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WireFrame フィールド

public String WireFrame

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WizardSureToClose

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WizardSureToClose フィールド

public String WizardSureToClose

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WizardTab

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WizardTab フィールド

public String WizardTab

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WMFFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WMFFilter フィールド

public String WMFFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


WrongTeeFileFormat

TeeChartプログラミングガイド

Steema.TeeChart.Texts.WrongTeeFileFormat フィールド

public String WrongTeeFileFormat

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


XAMLFilter

Steema.TeeChart.Texts.XAMLFilter フィールド

public String XAMLFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


XMLFile

TeeChartプログラミングガイド

Steema.TeeChart.Texts.XMLFile フィールド

public String XMLFile

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


XMLFilter

TeeChartプログラミングガイド

Steema.TeeChart.Texts.XMLFilter フィールド

public String XMLFilter

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


XPTheme

TeeChartプログラミングガイド

Steema.TeeChart.Texts.XPTheme フィールド

public String XPTheme

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Yes

TeeChartプログラミングガイド

Steema.TeeChart.Texts.Yes フィールド

public String Yes

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ZoomTool

Steema.TeeChart.Texts.ZoomTool フィールド

public String ZoomTool

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ZoomToolDesc

Steema.TeeChart.Texts.ZoomToolDesc フィールド

public const String ZoomToolDesc

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


ZoomToolSummary

Steema.TeeChart.Texts.ZoomToolSummary フィールド

public String ZoomToolSummary

参照

Texts クラス | Texts メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title

Steema.TeeChart.Title クラス

基本的なタイトル特性。

この型のすべてのメンバの一覧については、Title メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class Title : TextShapePosition , IComponent, IDisposable
, ICloneable

解説

チャートにヘッダー、フッター、軸タイトル、系列タイトルを追加するために使用してください。チャートキャンバス上のどこにでも付加的なタイトルを追加できます。

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title 全メンバ

Title 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AdjustFrame | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Title クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Title コンストラクタ

オーバーロードの一覧

public Title()
public Title(Steema.TeeChart.Chart)

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title コンストラクタ

public Title()

参照

Title コンストラクタのオーバーロードの一覧 | Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title コンストラクタ

public Title(Chart c)

参照

Title コンストラクタのオーバーロードの一覧 | Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
onTop
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Title クラス | Steema.TeeChart 名前空間


onTop

TeeChartプログラミングガイド

Steema.TeeChart.Title.onTop フィールド

protected Boolean onTop

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clicked | マウスカーソルがチャートタイトルの矩形境界内にあるかどうかを返します。
Clone (Shapeの継承元) |
DoDraw |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft (TextShapePositionの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop (TextShapePositionの継承元)
ShouldSerializeTransparent
ShouldSerializeVisible (Shapeの継承元)

参照

Title クラス | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Title.Clicked メソッド

オーバーロードの一覧

マウスカーソルがチャートタイトルの矩形範囲内にあるかどうかを返します。

public virtual Boolean Clicked(System.Int32, System.Int32)

マウスカーソルがチャートタイトルの矩形範囲内にあるかどうかを返します。

public virtual Boolean Clicked(System.Drawing.Point)

解説

マウスカーソルがチャートタイトル内にあるかどうかを返します。
Title.Visibleプロパティはtrueにしなければなりません。

タイトル矩形のサイズは、Title.Pen.VisibleプロパティやTitle.AdjustFrameプロパティに依存します。

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Title.Clicked メソッド

マウスカーソルがチャートタイトルの矩形内にあるかどうかを返します。

public virtual Boolean Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Title クラス | Title メンバ | Steema.TeeChart 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Title.Clicked メソッド

マウスカーソルがチャートのタイトル矩形内にあるかどうかを返します。

public virtual Boolean Clicked(Point p)

参照

Clicked オーバーロードの一覧 | Title クラス | Title メンバ | Steema.TeeChart 名前空間


DoDraw

Steema.TeeChart.Title.DoDraw メソッド

public Void DoDraw(Graphics3D g,
     Rectangle& rect,
     Boolean CustomOnly)

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


ShouldSerializeTransparent

TeeChartプログラミングガイド

Steema.TeeChart.Title.ShouldSerializeTransparent メソッド

protected virtual Boolean ShouldSerializeTransparent()

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Title プロパティ

パブリック プロパティ

AdjustFrame | trueの場合、チャートのヘッダーやフッターの枠をチャート全体のサイズに合わせます。
Alignment | チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。
AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left | ヘッダーまたはフッターテキストの左位置を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top | ヘッダーまたはフッターテキストの上位置を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

Title クラス | Steema.TeeChart 名前空間


AdjustFrame

TeeChartプログラミングガイド

Steema.TeeChart.Title.AdjustFrame プロパティ

trueの場合、チャートのヘッダーやフッターの枠をチャート全体の寸法に合わせます。

public Boolean AdjustFrame {get; set;}

解説

デフォルト値：true

チャートのヘッダーやフッターの枠をチャート全体のサイズあるいはタイトルテキストの幅に合わせるかどうかを制御します。これは、Chart.HeaderプロパティあるいはChart.Footer.Visibleプロパティがtrueの場合にのみ有効です。

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Alignment

TeeChartプログラミングガイド

Steema.TeeChart.Title.Alignment プロパティ

チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。

public StringAlignment Alignment {get; set;}

解説

デフォルト値：Center

チャート矩形内でチャートのヘッダーやフッターテキストの位置をどのように揃えるかを制御します。

ヘッダーあるいはフッターは、オプションにより枠で囲むことができます。

例

[C#]

tChart1.Footer.Alignment = TitleAlignments.Left;

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Left

TeeChartプログラミングガイド

Steema.TeeChart.Title.Left プロパティ

ヘッダーまたはフッターテキストの左位置を取得/設定します。

public Int32 Left {get; set;}

解説

ヘッダーまたはフッターテキストの左位置を取得/設定するために使用してください。

解説

[C#]

tChart1.Header.CustomPosition = true;
tChart1.Header.Left = 130;
tChart1.Header.Top = 20;
tChart1.Header.Text = "MY CHART";

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Top

TeeChartプログラミングガイド

Steema.TeeChart.Title.Top プロパティ

ヘッダーまたはフッターテキストの上位置を取得/設定します。

public Int32 Top {get; set;}

解説

ヘッダーまたはフッターテキストの上位置を取得/設定するために使用してください。

例

[C#]

tChart1.Header.CustomPosition = true;
tChart1.Header.Left = 130;
tChart1.Header.Top = 20;
tChart1.Header.Text = "MY CHART";

参照

Title クラス | Title メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Utils

TeeChartプログラミングガイド

Steema.TeeChart.Utils クラス

このクラスは、チャートのユーティリティプロシージャを含んでいます。

この型のすべてのメンバの一覧については、Utils メンバを参照してください。

System.Object
public class Utils : Object

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

Utils メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Utils 全メンバ

Utils 概要

パブリック フィールド

DateTimeStep | DateTimeSteps.GetDateTimeStepを定義するためのdouble値の配列。
DefaultNodeHeight |
FunctionGalleryPage |
FunctionTypesOf | チャートの関数型のリスト。
PiStep |
SeriesGalleryCount |
SeriesGalleryPage |
SeriesTypesOf |
TeeChartKeyName |
TeeChartRoot |
TeeChartSubKey |
ToolTypesOf | チャートのツールクラスのリスト。

パブリック メソッド

AutoLanguage |
CalcColorBlend |
ColorArrayToHexArray |
ColorIsEmpty |
ColorToHex |
DarkenColor |
DateTime |
DateTimeDefaultFormat |
DateTimeToStr |
DesignTime |
DrawCheckBox |
EnableControls |
ErrorMessage | メッセージダイアログボックスでTeeChartの例外エラーを表示します。
FormatFloat |
FromArgb |
FromLTRB |
GalleryByType |
GalleryStyle |
GetDateTimeStep | Incrementを設定するために使用される軸スケールでDateTimeSteps値を返します。
GetMouseButton |
HexArrayToColorArray |
HexToColor |
Int | dパラメーターの整数部を返します。
IsNullOrEmpty |
IsPrivateFont |
Language |
MulDiv |
Odd |
PointAtDistance |
RegisterFunction |
RegisterSeries |
RegisterTool |
Registry_GetValue |
Registry_SetValue |
RememberEditor |
Round |
SeriesTypesIndex |
SetLength |
ShareFolder |
SinCos |
Sort |
Sqr |
StringToDouble |
StringToInt |
SwapDouble |
SwapFloat |
SwapInteger |
TeeDistance |
ThemeFolder |
TimeToStr |
ToolTypeIndex | ツールインスタンスのToolTypesOfリスト内のインデックスを返します。
ToRectangle |
UnRegisterSeries |
VirtualShare |
YesNo | 「はい」と「いいえ」のボタン付きのメッセージボックスを表示します。
YesNoDelete | 「はい」と「いいえ」のボタン付きの削除ダイアログを表示します。

パブリック プロパティ

EmptyColor
FunctionTypesCount
PrivateFonts
SeriesTypesCount
ToolTypesCount

参照

Utils クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Utils フィールド

パブリック フィールド

DateTimeStep | DateTimeSteps.GetDateTimeStepを定義するためのdouble値の配列。
DefaultNodeHeight |
FunctionGalleryPage |
FunctionTypesOf | チャートの関数型のリスト。
PiStep |
SeriesGalleryCount |
SeriesGalleryPage |
SeriesTypesOf |
TeeChartKeyName |
TeeChartRoot |
TeeChartSubKey |
ToolTypesOf | チャートのツールクラスのリスト。

参照

Utils クラス | Steema.TeeChart 名前空間


DateTimeStep

TeeChartプログラミングガイド

Steema.TeeChart.Utils.DateTimeStep フィールド

DateTimeSteps.GetDateTimeStepを定義するためのDouble値の配列。

public Double[] DateTimeStep

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DefaultNodeHeight

Steema.TeeChart.Utils.DefaultNodeHeight フィールド

public Int32 DefaultNodeHeight

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FunctionGalleryPage

Steema.TeeChart.Utils.FunctionGalleryPage フィールド

public ArrayList FunctionGalleryPage

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FunctionTypesOf

Steema.TeeChart.Utils.FunctionTypesOf フィールド

public ArrayList FunctionTypesOf

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


PiStep

TeeChartプログラミングガイド

Steema.TeeChart.Utils.PiStep フィールド

public Double PiStep

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesGalleryCount

Steema.TeeChart.Utils.SeriesGalleryCount フィールド

public ArrayList SeriesGalleryCount

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesGalleryPage

Steema.TeeChart.Utils.SeriesGalleryPage フィールド

public ArrayList SeriesGalleryPage

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesTypesOf

Steema.TeeChart.Utils.SeriesTypesOf フィールド

public ArrayList SeriesTypesOf

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TeeChartKeyName

Steema.TeeChart.Utils.TeeChartKeyName フィールド

public String TeeChartKeyName

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TeeChartRoot

Steema.TeeChart.Utils.TeeChartRoot フィールド

public String TeeChartRoot

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TeeChartSubKey

Steema.TeeChart.Utils.TeeChartSubKey フィールド

public String TeeChartSubKey

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToolTypesOf

Steema.TeeChart.Utils.ToolTypesOf フィールド

public ArrayList ToolTypesOf

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Utils メソッド

パブリック メソッド

AutoLanguage |
CalcColorBlend |
ColorArrayToHexArray |
ColorIsEmpty |
ColorToHex |
DarkenColor |
DateTime |
DateTimeDefaultFormat |
DateTimeToStr |
DesignTime |
DrawCheckBox |
EnableControls |
ErrorMessage | メッセージダイアログボックスでTeeChartの例外エラーを表示します。
FormatFloat |
FromArgb |
FromLTRB |
GalleryByType |
GalleryStyle |
GetDateTimeStep | Incrementを設定するために使用される軸スケールでDateTimeSteps値を返します。
GetMouseButton |
HexArrayToColorArray |
HexToColor |
Int | dパラメーターの整数部を返します。
IsNullOrEmpty |
IsPrivateFont |
Language |
MulDiv |
Odd |
PointAtDistance |
RegisterFunction |
RegisterSeries |
RegisterTool |
Registry_GetValue |
Registry_SetValue |
RememberEditor |
Round |
SeriesTypesIndex |
SetLength |
ShareFolder |
SinCos |
Sort |
Sqr |
StringToDouble |
StringToInt |
SwapDouble |
SwapFloat |
SwapInteger |
TeeDistance |
ThemeFolder |
TimeToStr |
ToolTypeIndex | ツールインスタンスのToolTypesOfリスト内のインデックスを返します。
ToRectangle |
UnRegisterSeries |
VirtualShare |
YesNo | 「はい」と「いいえ」のボタン付きのメッセージボックスを表示します。
YesNoDelete | 「はい」と「いいえ」のボタン付きの削除ダイアログを表示します。

参照

Utils クラス | Steema.TeeChart 名前空間


AutoLanguage

Steema.TeeChart.Utils.AutoLanguage メソッド

public static Boolean AutoLanguage()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


CalcColorBlend

Steema.TeeChart.Utils.CalcColorBlend メソッド

public static Color CalcColorBlend(Color start,
     Color end,
     Int32 percentage)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ColorArrayToHexArray

Steema.TeeChart.Utils.ColorArrayToHexArray メソッド

public static String[] ColorArrayToHexArray(Color[] Colors)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ColorIsEmpty

Steema.TeeChart.Utils.ColorIsEmpty メソッド

public static Boolean ColorIsEmpty(Color color)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ColorToHex

Steema.TeeChart.Utils.ColorToHex メソッド

オーバーロードの一覧

public static String ColorToHex(System.Drawing.Color)
public static String ColorToHex(System.Drawing.Color, System.Boolean)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ColorToHex

Steema.TeeChart.Utils.ColorToHex メソッド

public static String ColorToHex(Color color)

参照

ColorToHex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ColorToHex

Steema.TeeChart.Utils.ColorToHex メソッド

public static String ColorToHex(Color color,
     Boolean ARGB)

参照

ColorToHex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DarkenColor

Steema.TeeChart.Utils.DarkenColor メソッド

public static Color DarkenColor(Color AColor,
     Int32 Percentage)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTime

Steema.TeeChart.Utils.DateTime メソッド

オーバーロードの一覧

public static Double DateTime(System.DateTime)
public static DateTime DateTime(System.Double)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTime

Steema.TeeChart.Utils.DateTime メソッド

public static Double DateTime(DateTime value)

参照

DateTime オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTime

Steema.TeeChart.Utils.DateTime メソッド

public static DateTime DateTime(Double value)

参照

DateTime オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTimeDefaultFormat

TeeChartプログラミングガイド

Steema.TeeChart.Utils.DateTimeDefaultFormat メソッド

public static String DateTimeDefaultFormat(Double tmpValue)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.DateTimeToStr メソッド

オーバーロードの一覧

public static String DateTimeToStr(System.Double)
public static String DateTimeToStr(System.DateTime)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.DateTimeToStr メソッド

public static String DateTimeToStr(Double datetime)

参照

DateTimeToStr オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DateTimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.DateTimeToStr メソッド

public static String DateTimeToStr(DateTime datetime)

参照

DateTimeToStr オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DesignTime

Steema.TeeChart.Utils.DesignTime メソッド

public static String DesignTime()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


DrawCheckBox

Steema.TeeChart.Utils.DrawCheckBox メソッド

public static Void DrawCheckBox(Int32 x,
     Int32 y,
     Graphics g,
     Boolean drawChecked,
     Color backColor,
     Boolean CheckBox)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


EnableControls

Steema.TeeChart.Utils.EnableControls メソッド

public static Void EnableControls(Boolean enable,
     Control[] controls)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ErrorMessage

Steema.TeeChart.Utils.ErrorMessage メソッド

メッセージダイアログボックスでTeeChartの例外エラーを表示します。
public static Boolean ErrorMessage(String s)

パラメーター

s
ダイアログに表示するカスタムなテキスト。

戻り値

ユーザーが「OK」ボタンを選択した場合、Trueを返します。

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FormatFloat

TeeChartプログラミングガイド

Steema.TeeChart.Utils.FormatFloat メソッド

public static String FormatFloat(String format,
     Double value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FromArgb

Steema.TeeChart.Utils.FromArgb メソッド

オーバーロードの一覧

public static Color FromArgb(System.Int32, System.Drawing.Color)
public static Color FromArgb(System.Int32, System.Int32, System.Int32)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FromArgb

Steema.TeeChart.Utils.FromArgb メソッド

public static Color FromArgb(Int32 alpha,
     Color baseColor)

参照

FromArgb オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FromArgb

Steema.TeeChart.Utils.FromArgb メソッド

public static Color FromArgb(Int32 r,
     Int32 g,
     Int32 b)

参照

FromArgb オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FromLTRB

Steema.TeeChart.Utils.FromLTRB メソッド

public static Rectangle FromLTRB(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


GalleryByType

Steema.TeeChart.Utils.GalleryByType メソッド

public static Boolean GalleryByType()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


GalleryStyle

Steema.TeeChart.Utils.GalleryStyle メソッド

public static Int32 GalleryStyle()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


GetDateTimeStep

Steema.TeeChart.Utils.GetDateTimeStep メソッド

Incrementプロパティを設定するために使用される軸スケールとしてのDateTimeSteps値を返します。
public static Double GetDateTimeStep(DateTimeSteps value)

パラメーター

value
Steema.TeeChart.DateTimeSteps

戻り値

軸の値

解説

Incrementプロパティを設定するために使用される軸スケールとしてのDateTimeSteps値を返します。

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


GetMouseButton

Steema.TeeChart.Utils.GetMouseButton メソッド

public static MouseButtons GetMouseButton(MouseEventArgs e)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


HexArrayToColorArray

Steema.TeeChart.Utils.HexArrayToColorArray メソッド

public static Color[] HexArrayToColorArray(String[] Colors)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


HexToColor

Steema.TeeChart.Utils.HexToColor メソッド

public static Color HexToColor(String color)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Int

Steema.TeeChart.Utils.Int メソッド

dパラメーターの整数部を返します。
public static Double Int(Double d)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


IsNullOrEmpty

Steema.TeeChart.Utils.IsNullOrEmpty メソッド

public static Boolean IsNullOrEmpty(String s)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


IsPrivateFont

Steema.TeeChart.Utils.IsPrivateFont メソッド

オーバーロードの一覧

public static Boolean IsPrivateFont(System.String, System.Drawing.FontFamily&)
public static Boolean IsPrivateFont(System.String)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


IsPrivateFont

Steema.TeeChart.Utils.IsPrivateFont メソッド

public static Boolean IsPrivateFont(String name,
     FontFamily& privateFontFamily)

参照

IsPrivateFont オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


IsPrivateFont

Steema.TeeChart.Utils.IsPrivateFont メソッド

public static Boolean IsPrivateFont(String name)

参照

IsPrivateFont オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Language

Steema.TeeChart.Utils.Language メソッド

public static Int32 Language()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


MulDiv

Steema.TeeChart.Utils.MulDiv メソッド

public static Int32 MulDiv(Int32 Number,
     Int32 Numerator,
     Int32 Denominator)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Odd

Steema.TeeChart.Utils.Odd メソッド

public static Boolean Odd(Int32 value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


PointAtDistance

TeeChartプログラミングガイド

Steema.TeeChart.Utils.PointAtDistance メソッド

public static Point PointAtDistance(Point AFrom,
     Point ATo,
     Int32 ADist)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


RegisterFunction

Steema.TeeChart.Utils.RegisterFunction メソッド

public static Void RegisterFunction(Type functionType,
     Int32 galleryPage)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


RegisterSeries

Steema.TeeChart.Utils.RegisterSeries メソッド

public static Void RegisterSeries(Type seriesType,
     Type editorType,
     Int32 galleryPage,
     Int32 galleryCount)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


RegisterTool

Steema.TeeChart.Utils.RegisterTool メソッド

public static Void RegisterTool(Type toolType,
     Type editorType)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Registry_GetValue

Steema.TeeChart.Utils.Registry_GetValue メソッド

public static Object Registry_GetValue(String keyName,
     String valueName,
     Object defaultValue)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Registry_SetValue

Steema.TeeChart.Utils.Registry_SetValue メソッド

public static Void Registry_SetValue(String keyName,
     String valueName,
     Object value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Registry_SetValue

Steema.TeeChart.Utils.Registry_SetValue メソッド

public static Void Registry_SetValue(String keyName,
     String valueName,
     Object value)

参照

Registry_SetValue オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Registry_SetValue

Steema.TeeChart.Utils.Registry_SetValue メソッド

public static Void Registry_SetValue(String keyName,
     String valueName,
     Object value,
     RegistryValueKind valueKind)

参照

Registry_SetValue オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


RememberEditor

Steema.TeeChart.Utils.RememberEditor メソッド

public static Boolean RememberEditor()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Round

TeeChartプログラミングガイド

Steema.TeeChart.Utils.Round メソッド

オーバーロードの一覧

public static Int32 Round(System.Single)
public static Int32 Round(System.Double)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Round

TeeChartプログラミングガイド

Steema.TeeChart.Utils.Round メソッド

public static Int32 Round(Single value)

参照

Round オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Round

TeeChartプログラミングガイド

Steema.TeeChart.Utils.Round メソッド

public static Int32 Round(Double value)

参照

Round オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesTypesIndex

TeeChartプログラミングガイド

Steema.TeeChart.Utils.SeriesTypesIndex メソッド

オーバーロードの一覧

public static Int32 SeriesTypesIndex(Steema.TeeChart.Styles.Series)
public static Int32 SeriesTypesIndex(System.Type)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesTypesIndex

Steema.TeeChart.Utils.SeriesTypesIndex メソッド

public static Int32 SeriesTypesIndex(Series s)

参照

SeriesTypesIndex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesTypesIndex

TeeChartプログラミングガイド

Steema.TeeChart.Utils.SeriesTypesIndex メソッド

public static Int32 SeriesTypesIndex(Type seriesType)

参照

SeriesTypesIndex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SetLength

Steema.TeeChart.Utils.SetLength メソッド

public static Array SetLength(Array S,
     Int32 NewLength,
     Type ElementType)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ShareFolder

Steema.TeeChart.Utils.ShareFolder メソッド

public static String ShareFolder()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SinCos

TeeChartプログラミングガイド

Steema.TeeChart.Utils.SinCos メソッド

public static Void SinCos(Double angle,
     Double& resultSin,
     Double& resultCos)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Sort

Steema.TeeChart.Utils.Sort メソッド

public static Void Sort(Int32 startIndex,
     Int32 endIndex,
     CompareEventHandler compareFunction,
     SwapEventHandler swap)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Sqr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.Sqr メソッド

public static Double Sqr(Double value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


StringToDouble

TeeChartプログラミングガイド

Steema.TeeChart.Utils.StringToDouble メソッド

public static Double StringToDouble(String text,
     Double value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


StringToInt

Steema.TeeChart.Utils.StringToInt メソッド

public static Int32 StringToInt(String text,
     Int32 value)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SwapDouble

Steema.TeeChart.Utils.SwapDouble メソッド

public static Void SwapDouble(Double& a,
     Double& b)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SwapFloat

Steema.TeeChart.Utils.SwapFloat メソッド

public static Void SwapFloat(Single& a,
     Single& b)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SwapInteger

Steema.TeeChart.Utils.SwapInteger メソッド

public static Void SwapInteger(Int32& a,
     Int32& b)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TeeDistance

Steema.TeeChart.Utils.TeeDistance メソッド

public static Double TeeDistance(Double x,
     Double y)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ThemeFolder

Steema.TeeChart.Utils.ThemeFolder メソッド

public static String ThemeFolder()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.TimeToStr メソッド

オーバーロードの一覧

public static String TimeToStr(System.Double)
public static String TimeToStr(System.DateTime)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.TimeToStr メソッド

public static String TimeToStr(Double datetime)

参照

TimeToStr オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


TimeToStr

TeeChartプログラミングガイド

Steema.TeeChart.Utils.TimeToStr メソッド

public static String TimeToStr(DateTime datetime)

参照

TimeToStr オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex メソッド

ツールインスタンスのToolTypesOfリスト内のインデックスを返します。
public static Int32 ToolTypeIndex(Tool tool)

パラメーター

tool
リスト内で検索するツール

解説

ツールインスタンスのToolTypesOfリスト内のインデックスを返します。

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex メソッド

ツールインスタンスのToolTypesOfリスト内のインデックスを返します。
public static Int32 ToolTypeIndex(Tool tool)

パラメーター

tool
リスト内で検索するツール

参照

ToolTypeIndex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToolTypeIndex

Steema.TeeChart.Utils.ToolTypeIndex メソッド

ツールインスタンスのToolTypesOfリスト内のインデックスを返します。
public static Int32 ToolTypeIndex(Type tool)

パラメーター

tool
リスト内で検索するツール

参照

ToolTypeIndex オーバーロードの一覧 | Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToRectangle

Steema.TeeChart.Utils.ToRectangle メソッド

public static Rectangle ToRectangle(RectangleF rect)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


UnRegisterSeries

Steema.TeeChart.Utils.UnRegisterSeries メソッド

public static Void UnRegisterSeries(Type seriesType)

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


VirtualShare

Steema.TeeChart.Utils.VirtualShare メソッド

public static String VirtualShare()

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


YesNo

Steema.TeeChart.Utils.YesNo メソッド

「はい」と「いいえ」のボタン付きのメッセージボックスを表示します。
public static Boolean YesNo(String s)

パラメーター

s
メッセージボックスに表示するテキスト。

戻り値

｢はい｣が選択された場合trueを返します。

解説

「はい」と「いいえ」のボタン付きのメッセージボックスを表示します。

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


YesNoDelete

Steema.TeeChart.Utils.YesNoDelete メソッド

「はい」と「いいえ」のボタン付きの削除ダイアログを表示します。
public static Boolean YesNoDelete(String s)

パラメーター

s
ダイアログに表示するテキスト

戻り値

ユーザが｢はい｣を選択するとtrueを返します。

解説

「はい」と「いいえ」のボタン付きの削除ダイアログを表示します。

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Utils プロパティ

パブリック プロパティ

FunctionTypesCount
PrivateFonts
SeriesTypesCount
ToolTypesCount

参照

Utils クラス | Steema.TeeChart 名前空間


EmptyColor

Steema.TeeChart.Utils.EmptyColor プロパティ

public static Color EmptyColor {get;}

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


FunctionTypesCount

Steema.TeeChart.Utils.FunctionTypesCount プロパティ

public static Int32 FunctionTypesCount {get;}

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


PrivateFonts

Steema.TeeChart.Utils.PrivateFonts プロパティ

public static PrivateFontCollection PrivateFonts {get; set;}

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


SeriesTypesCount

Steema.TeeChart.Utils.SeriesTypesCount プロパティ

public static Int32 SeriesTypesCount {get;}

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


ToolTypesCount

Steema.TeeChart.Utils.ToolTypesCount プロパティ

public static Int32 ToolTypesCount {get;}

参照

Utils クラス | Utils メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Utils.CompareEventHandler

TeeChartプログラミングガイド

Steema.TeeChart.Utils.CompareEventHandler デリゲート

内部使用。Sortのイベントハンドラ。

public virtual Int32 Invoke(Int32 a,
     Int32 b)

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SteemaTeeChartUtilsCompareEve 名前空間


Steema.TeeChart.Utils.RegistryValueKind

Steema.TeeChart.Utils.RegistryValueKind 列挙体

[Serializable]
public sealed enum RegistryValueKind : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Binary |
DWord |
ExpandString |
MultiString |
QWord |
String |
Unknown |

参照

Steema.TeeChart 名前空間


Steema.TeeChart.Utils.SwapEventHandler

TeeChartプログラミングガイド

Steema.TeeChart.Utils.SwapEventHandler デリゲート

内部使用。Sortのイベントハンドラ。

public virtual Void Invoke(Int32 a,
     Int32 b)

必要条件

名前空間： Steema.TeeChart

アセンブリ：TeeChart.dll

参照

SteemaTeeChartUtilsSwapEve 名前空間


Steema.TeeChart.Wall

Steema.TeeChart.Wall クラス

軸を補足する壁パネルの特性。

この型のすべてのメンバの一覧については、Wall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class Wall : Shape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

Wall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Wall 全メンバ

Wall 概要

コンストラクタ

Constructor

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティを指定したシェープから他のシェープへ割り当てます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

パブリック プロパティ

ApplyDark | trueの場合、3Dチャートの壁に影を付けます。
AutoHide |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bApplyDark
bAutoHide
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize
iTop (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls

プロテクト メソッド

PrepareGraphics
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

ShouldDark
ShouldDraw

参照

Wall クラス | Steema.TeeChart 名前空間


Wall コンストラクタ

Steema.TeeChart.Wall コンストラクタ

public Wall(Chart c,
     Walls w)

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Wall フィールド

プロテクト フィールド

bApplyDark
bAutoHide
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls

参照

Wall クラス | Steema.TeeChart 名前空間


bApplyDark

TeeChartプログラミングガイド

Steema.TeeChart.Wall.bApplyDark フィールド

protected Boolean bApplyDark

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


bAutoHide

Steema.TeeChart.Wall.bAutoHide フィールド

protected internal Boolean bAutoHide

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


iSize

TeeChartプログラミングガイド

Steema.TeeChart.Wall.iSize フィールド

protected internal Int32 iSize

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


walls

Steema.TeeChart.Wall.walls フィールド

protected Walls walls

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Wall メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティを指定したシェープから他のシェープへ割り当てます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

プロテクト メソッド

PrepareGraphics
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Wall クラス | Steema.TeeChart 名前空間


PrepareGraphics

Steema.TeeChart.Wall.PrepareGraphics メソッド

protected Void PrepareGraphics(Graphics3D g)

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Wall プロパティ

パブリック プロパティ

ApplyDark | trueの場合、3Dチャートの壁に影を付けます。
AutoHide |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

ShouldDark
ShouldDraw

参照

Wall クラス | Steema.TeeChart 名前空間


ApplyDark

TeeChartプログラミングガイド

Steema.TeeChart.Wall.ApplyDark プロパティ

trueの場合、3Dチャートの壁に影を付けます。

public Boolean ApplyDark {get; set;}

解説

デフォルト値：true

trueの場合、3Dチャートの壁に影を付けます。

例

[C#]

このボタンは、ApplyDarkプロパティをtrue/falseに切り替えます。

private void button4_Click(object sender, System.EventArgs e)
{
     tChart1.Walls.Left.ApplyDark =! tChart1.Walls.Left.ApplyDark;
}

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


AutoHide

Steema.TeeChart.Wall.AutoHide プロパティ

public Boolean AutoHide {get; set;}

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


ShouldDark

Steema.TeeChart.Wall.ShouldDark プロパティ

protected Boolean ShouldDark {get;}

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


ShouldDraw

Steema.TeeChart.Wall.ShouldDraw プロパティ

protected internal Boolean ShouldDraw {get;}

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


Size

Steema.TeeChart.Wall.Size プロパティ

チャートの壁の厚さを設定します。

public Int32 Size {get; set;}

解説

チャートの壁の厚さを設定します。

例

[C#]

tChart1.Walls.Bottom.Size = 15;

参照

Wall クラス | Wall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls

Steema.TeeChart.Walls クラス

壁の特性にアクセスします。

この型のすべてのメンバの一覧については、Walls メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Walls : TeeBase , IComponent, IDisposable

解説

チャートの壁は、チャート領域を強調するためにチャート矩形の側面、下、背面に置かれる境界です。チャートの壁は、データスケールに関連するどの情報も含まない視覚的コンポーネントです。TeeChart Pro .NET 2Jには4つの壁（左、右、下、背面）を持っています。各壁は色付けやサイズ変更が可能です。

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Walls メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls 全メンバ

Walls 概要

コンストラクタ

Constructor

パブリック メソッド

CalcWallSize | 指定した軸の壁の厚さを計算します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で壁を描画するために使用してください。

パブリック プロパティ

Back | チャートの背面の壁を塗りつぶすペンやブラシを定義します。
Bottom | チャートの下の壁を塗りつぶすペンやブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Left | チャートの左の壁を塗りつぶすペンやブラシを定義します。
Right | チャートの右の壁を塗りつぶすペンやブラシを定義します。
Size |
View3D | すべてのチャートの壁を3Dで描画します。
Visible | すべてのチャートの壁を表示/非表示にします。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Walls クラス | Steema.TeeChart 名前空間


Walls コンストラクタ

Steema.TeeChart.Walls コンストラクタ

public Walls(Chart c)

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Walls クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls メソッド

パブリック メソッド

CalcWallSize | 指定した軸の壁の厚さを計算します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で壁を描画するために使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Walls クラス | Steema.TeeChart 名前空間


CalcWallSize

Steema.TeeChart.Walls.CalcWallSize メソッド

指定した軸の壁の厚さを計算します。
public Int32 CalcWallSize(Axis a)

解説

指定した軸の壁の厚さを計算します。

例

[C#]

MessageBox.Show("Size"+tChart1.Walls.CalcWallSize(tChart1.Axes.Left).ToString());

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Walls.Paint メソッド

矩形を表す「r」で右壁を描画するために使用してください。
public Void Paint(Graphics3D g,
     Rectangle r)

解説

矩形を表す「r」で右壁を描画するために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(50,50,100,100);
     tChart1.Walls.Paint(g,r);
}

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls プロパティ

パブリック プロパティ

Back | チャートの背面の壁を塗りつぶすペンやブラシを定義します。
Bottom | チャートの下の壁を塗りつぶすペンやブラシを定義します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Left | チャートの左の壁を塗りつぶすペンとブラシを定義します。
Right | チャートの右の壁を塗りつぶすペンとブラシを定義します。
Size |
View3D | すべてのチャートの壁を3Dで表示します。
Visible | すべてのチャートの壁を表示/非表示にします。

参照

Walls クラス | Steema.TeeChart 名前空間


Back

Steema.TeeChart.Walls.Back プロパティ

チャートの背面の壁を塗りつぶすペンやブラシを定義します。
public BackWall Back {get;}

解説

チャートの背面の壁を塗りつぶすペンやブラシを定義します。IWallプロパティは、Brush、Color、Dark3D、Gradient、Pen、Size 、Transparentプロパティが使用可能です。tChart.Aspect.View3DプロパティとtChart.Walls.Visibleプロパティは、tChart.Walls.Back、tChart.Walls.Bottom、tChart.Walls.Left、tChart.Walls.Rightを使用するためにtrueに設定しなければなりません。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Bottom

Steema.TeeChart.Walls.Bottom プロパティ

チャートの下の壁を塗りつぶすペンやブラシを定義します。
public BottomWall Bottom {get;}

解説

このプロパティは、チャートの下の壁を塗りつぶすペンやブラシを定義します。IWallプロパティはBrush、Color、Dark3D、Gradient、Pen、Size、Transparentプロパティが使用可能です。tChart.Aspect.View3DプロパティやtChart.Walls.Visibleプロパティは、tChart.Walls.Back、tChart.Walls.Bottom、tChart.Walls.Left、tChart.Walls.Rightを使用するためにtrueに設定しなければなりません。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Left

Steema.TeeChart.Walls.Left プロパティ

チャートの左壁を塗りつぶすペンとブラシを定義します。
public LeftWall Left {get;}

解説

tChart.Walls.Leftプロパティは、チャートの左壁を塗りつぶすペンとブラシを定義します。使用可能なIWallプロパティは、Brush、Color、Dark3D、Gradient、Pen、Size 、Transparentプロパティです。tChart.Aspect.View3DプロパティとtChart.Walls.Visibleプロパティは、tChart.Walls.Back、tChart.Walls.Bottom、tChart.Walls.Left、tChart.Walls.Rightを使用するためにtrueに設定しなければなりません。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Right

Steema.TeeChart.Walls.Right プロパティ

チャートの右壁を塗りつぶすペンとブラシを定義します。
public RightWall Right {get;}

解説

tChart.Walls.Rightプロパティは、チャートの右壁を塗りつぶすペンとブラシを定義します。使用可能なIWallプロパティは、Brush、Color、Dark3D、Gradient、Pen、Size 、Transparentプロパティです。tChart.Aspect.View3DプロパティとtChart.Walls.Visibleプロパティは、t.Walls.Back、tChart.Walls.Bottom、tChart.Walls.Left、tChart.Walls.Rightを使用するためにtrueに設定しなければなりません。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Size

Steema.TeeChart.Walls.Size プロパティ

public Int32 Size {set;}

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


View3D

Steema.TeeChart.Walls.View3D プロパティ

すべてのチャートの壁を3Dで描画します。
public Boolean View3D {get; set;}

解説

すべてのチャートの壁を3Dで描画します。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Visible

Steema.TeeChart.Walls.Visible プロパティ

すべてのチャートの壁を表示/非表示にします。

public Boolean Visible {get; set;}

解説

デフォルト値：true

tChart.Walls.Visibleは、3D効果をシミュレートするために左と下の｢壁｣を描画します。Chart.Aspect.Chart3DPercentプロパティを使用して3Dの壁の割合を制御できます。Chart.Aspect.View3Dプロパティは、Walls.Visibleプロパティを制御（オン/オフ）します。

参照

Walls クラス | Walls メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BackWall

Steema.TeeChart.Walls.BackWall クラス

チャートの背面の壁パネルです。

この型のすべてのメンバの一覧については、BackWall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class BackWall : Wall , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

BackWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BackWall 全メンバ

BackWall 概要

コンストラクタ

Steema.TeeChart.Walls.BackWall..ctor

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で背面壁を描画するために使用してください。

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

BackWall クラス | Steema.TeeChart 名前空間


BackWall コンストラクタ

Steema.TeeChart.Walls+BackWall コンストラクタ

public Walls+BackWall(Chart c,
     Walls w)

参照

BackWall クラス | BackWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BackWall フィールド

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

参照

BackWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BackWall メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で背面壁を描画するために使用してください。

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

BackWall クラス | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Walls+BackWall.Paint メソッド

矩形を表す「rect」で背面の壁を描画するために使用してください。
public override Void Paint(Graphics3D g,
     Rectangle rect)

解説

矩形を表す「rect」で背面の壁を描画するために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(50,50,100,100);
     tChart1.Walls.Back.Paint(g,r);
     tChart1.Walls.Bottom.Paint(g,r);
     tChart1.Walls.Left.Paint(g,r);
     tChart1.Walls.Right.Paint(g,r);
}

参照

BackWall クラス | BackWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BackWall プロパティ

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

BackWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BottomWall

Steema.TeeChart.Walls.BottomWall クラス

チャートの下側の壁パネルです。

この型のすべてのメンバの一覧については、BottomWall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class BottomWall : Wall , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

BottomWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BottomWall 全メンバ

BottomWall 概要

コンストラクタ

Steema.TeeChart.Walls.BottomWall..ctor

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で下壁を描画するために使用してください。

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

BottomWall クラス | Steema.TeeChart 名前空間


BottomWall コンストラクタ

Steema.TeeChart.Walls+BottomWall コンストラクタ

public Walls+BottomWall(Chart c,
     Walls w)

参照

BottomWall クラス | BottomWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BottomWall フィールド

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

参照

BottomWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BottomWall メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で下壁を描画するために使用してください。

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

BottomWall クラス | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Walls+BottomWall.Paint メソッド

矩形を表す「rect」で下壁を描画するために使用してください。
public override Void Paint(Graphics3D g,
     Rectangle rect)

解説

矩形を表す「rect」で下壁を描画するために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(50,50,100,100);
     tChart1.Walls.Back.Paint(g,r);
     tChart1.Walls.Bottom.Paint(g,r);
     tChart1.Walls.Left.Paint(g,r);
     tChart1.Walls.Right.Paint(g,r);
}

参照

BottomWall クラス | BottomWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.BottomWall プロパティ

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

BottomWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.LeftWall

Steema.TeeChart.Walls.LeftWall クラス

チャートの左側の壁パネルです。

この型のすべてのメンバの一覧については、LeftWall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class LeftWall : Wall , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

LeftWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.LeftWall 全メンバ

LeftWall 概要

コンストラクタ

Steema.TeeChart.Walls.LeftWall..ctor

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で左壁を描画するために使用してください。

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 左壁の背面を塗りつぶす色を指定します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

LeftWall クラス | Steema.TeeChart 名前空間


LeftWall コンストラクタ

Steema.TeeChart.Walls+LeftWall コンストラクタ

public Walls+LeftWall(Chart c,
     Walls w)

参照

LeftWall クラス | LeftWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.LeftWall フィールド

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

参照

LeftWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.LeftWall メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で左壁を描画するために使用してください。

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

LeftWall クラス | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Walls+LeftWall.Paint メソッド

矩形を表す「rect」で左壁を描画するために使用してください。
public override Void Paint(Graphics3D g,
     Rectangle rect)

解説

矩形を表す「rect」で左壁を描画するために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(50,50,100,100);
     tChart1.Walls.Back.Paint(g,r);
     tChart1.Walls.Bottom.Paint(g,r);
     tChart1.Walls.Left.Paint(g,r);
     tChart1.Walls.Right.Paint(g,r);
}

参照

LeftWall クラス | LeftWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.LeftWall プロパティ

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 左壁の背面を塗りつぶす色を指定します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

LeftWall クラス | Steema.TeeChart 名前空間


Color

Steema.TeeChart.Walls+LeftWall.Color プロパティ

左壁の背面を塗りつぶす色を指定します。
public Color Color {get; set;}

解説

左壁の背面を塗りつぶす色を指定します。

参照

LeftWall クラス | LeftWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.RightWall

Steema.TeeChart.Walls.RightWall クラス

チャートの右側の壁パネルです。

この型のすべてのメンバの一覧については、RightWall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Wall
public class RightWall : Wall , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart 名前空間

アセンブリ: TeeChart.dll

参照

RightWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.RightWall 全メンバ

RightWall 概要

コンストラクタ

Steema.TeeChart.Walls.RightWall..ctor

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で右壁を描画するために使用してください。

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible | 右壁を表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

RightWall クラス | Steema.TeeChart 名前空間


RightWall コンストラクタ

Steema.TeeChart.Walls+RightWall コンストラクタ

public Walls+RightWall(Chart c,
     Walls w)

参照

RightWall クラス | RightWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.RightWall フィールド

プロテクト フィールド

bApplyDark (Wallの継承元)
bAutoHide (Wallの継承元)
bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSize (Wallの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
walls (Wallの継承元)

参照

RightWall クラス | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.RightWall メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | 矩形を表す「r」で右壁を描画するために使用してください。

プロテクト メソッド

AssignShape (Shapeの継承元)
PrepareGraphics (Wallの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

RightWall クラス | Steema.TeeChart 名前空間


Paint

Steema.TeeChart.Walls+RightWall.Paint メソッド

矩形を表す「rect」で右壁を描画するために使用してください。
public override Void Paint(Graphics3D g,
     Rectangle rect)

解説

矩形を表す「rect」で右壁を描画するために使用してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(50,50,100,100);
     tChart1.Walls.Back.Paint(g,r);
     tChart1.Walls.Bottom.Paint(g,r);
     tChart1.Walls.Left.Paint(g,r);
     tChart1.Walls.Right.Paint(g,r);
}

参照

RightWall クラス | RightWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Walls.RightWall プロパティ

パブリック プロパティ

ApplyDark (Wallの継承元) | trueの場合、3Dチャートの壁に影を付けます。
AutoHide (Wallの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Size (Wallの継承元) | チャートの壁の厚さを設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible | 右壁を表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

ShouldDark (Wallの継承元)
ShouldDraw (Wallの継承元)

参照

RightWall クラス | Steema.TeeChart 名前空間


Visible

Steema.TeeChart.Walls+RightWall.Visible プロパティ

右壁を表示/非表示します。

public Boolean Visible {get; set;}

解説

右壁を表示/非表示します。

参照

RightWall クラス | RightWall メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Zoom

Steema.TeeChart.Zoom クラス

tChart1.Zoomプロパティで使用されます。マウスズーム属性を定義します。

この型のすべてのメンバの一覧については、Zoom メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.ZoomScroll
public class Zoom : ZoomScroll , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

Zoom メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Zoom 全メンバ

Zoom 概要

コンストラクタ

Constructor 新しいズームインスタンスを作成します。

パブリック フィールド

AnimatedFactor | 動画ズームの｢スピード｣を制御します。
x0 (ZoomScrollの継承元) |
x1 (ZoomScrollの継承元) |
y0 (ZoomScrollの継承元) |
y1 (ZoomScrollの継承元) |

パブリック メソッド

Activate (ZoomScrollの継承元) | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check (ZoomScrollの継承元) | X1がX0より小さい場合、X0とX1 座標を交換します。
Draw | ズームを行うためにチャートをドラッグすると矩形を表示します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Undo | チャート軸を最大値および最小値に再スケールします。
ZoomPercent | 指定されたPercentZoomのズームイン/ズームアウトを現在の軸スケールに適用します。
ZoomRect | チャート矩形をズームします（ピクセル単位）。

パブリック プロパティ

Active (ZoomScrollの継承元) | チャートのズームやスクロールを有効/無効にします。
Allow | trueの場合、実行時にマウスのドラッグによるズームを有効にします。
Animated | trueの場合、ズームを動的に行います。
AnimatedSteps | 一連の動画ズームのステップ数を定義します。
Brush | マウスドラッグしたズーム領域を塗りつぶすためのブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Direction | 選択した領域でズーム方向を設定します。
KeyShift (ZoomScrollの継承元) | ズームを開始するためのオプションとしてキーボードボタンを設定します。
MinPixels | ズームを適用する最小ピクセル数を設定します。
MouseButton | ズームで使用するマウスボタンを設定します。
Pen | ズーム領域の矩形を描くペンを設定します。
Zoomed | チャートの軸スケールをすべてのチャートポイントに適合させるかどうかを定義します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元) |
SetChart | ペンやブラシのチャート特性を調整する基本的なSetChartメソッドをオーバーライドします。
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

Zoom クラス | Steema.TeeChart 名前空間


Zoom コンストラクタ

Steema.TeeChart.Zoom コンストラクタ

新しいズームインスタンスを作成します。
public Zoom(Chart c)

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Zoom フィールド

パブリック フィールド

AnimatedFactor | 動画ズームの「スピード」を制御します。
x0 (ZoomScrollの継承元) |
x1 (ZoomScrollの継承元) |
y0 (ZoomScrollの継承元) |
y1 (ZoomScrollの継承元) |

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Zoom クラス | Steema.TeeChart 名前空間


AnimatedFactor

Steema.TeeChart.Zoom.AnimatedFactor フィールド

動画ズームの｢スピード｣を制御します。

public Double AnimatedFactor

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Zoom メソッド

パブリック メソッド

Activate (ZoomScrollの継承元) | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check (ZoomScrollの継承元) | X1がX0より小さい場合、X0とX1 座標を交換します。
Draw | ズームを行うためにチャートをドラッグすると矩形を表示します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Undo | チャート軸を最大値および最小値に再スケールします。
ZoomPercent | 指定されたPercentZoomのズームイン/ズームアウトを現在の軸スケールに適用します。
ZoomRect | チャート矩形をズームします（ピクセル単位）。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元) |
SetChart | ペンやブラシのチャート特性を調整する基本的なSetChartメソッドをオーバーライドします。
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

Zoom クラス | Steema.TeeChart 名前空間


Draw

Steema.TeeChart.Zoom.Draw メソッド

ズーム操作のためにチャート上でマウスドラッグしている間、矩形を描画します。
public Void Draw()

解説

ズーム操作のためにチャート上でマウスドラッグしている間、矩形を描画します。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


SetChart

Steema.TeeChart.Zoom.SetChart メソッド

ペンやブラシのチャート特性を調整する基本的なSetChartメソッドをオーバーライドします。
protected abstract Void SetChart(Chart c)

解説

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Undo

Steema.TeeChart.Zoom.Undo メソッド

チャート軸を最大値および最小値に再スケールします。

public Void Undo()

解説

チャート軸を最大値や最小値に再スケールします。各軸は、1つもしくはそれ以上の系列クラスに「依存」しています。従って、軸の値はこれらに関連する系列の最大値や最小値に依存することになります。また、Undoは実行時に行われたスクロールの復元も行います。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


ZoomPercent

Steema.TeeChart.Zoom.ZoomPercent メソッド

指定されたPercentZoomのズームイン/ズームアウトを現在の軸スケールに適用します。
public Void ZoomPercent(Double percentZoom)

解説

指定されたPercentZoomのズームイン/ズームアウトを現在の軸スケールに適用します。PercentZoomが100%以上の値になっている場合、ズームアウトが実行されます。PercentZoomが100%以下の値になっている場合、ズームインが実行されます。Animatedプロパティは、ズームを直接1ステップで行うか、あるいは複数のズームを行って動画効果を出すかを制御します。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


ZoomRect

Steema.TeeChart.Zoom.ZoomRect メソッド

チャート矩形をズームします（ピクセル単位）。
public Void ZoomRect(Rectangle r)

解説

チャートの内容をズームします。矩形パラメータは、ズームするチャート領域の矩形座標（ピクセル単位）を定義します。このメソッドの呼び出しは、実行時に手動でチャート上を左マウスボタンでドラッグして矩形を描くことと同様です。

チャートのサイズより小さい矩形パラメータを指定することによりズームインが実行され、チャートのサイズより大きい矩形パラメータを指定することによりズームアウトが実行されます。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Zoom プロパティ

パブリック プロパティ

Active (ZoomScrollの継承元) | チャートのズームやスクロールを有効/無効にします。
Allow | trueの場合、実行時にマウスのドラッグによるズームを有効にします。
Animated | trueの場合、ズームを動的に行います。
AnimatedSteps | 一連の動画ズームのステップ数を定義します。
Brush | マウスドラッグしたズーム領域を塗りつぶすためのブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Direction | 選択した領域でズーム方向を設定します。
KeyShift (ZoomScrollの継承元) | ズームを開始するためのオプションとしてキーボードボタンを設定します。
MinPixels | ズームを適用する最小ピクセル数を設定します。
MouseButton | ズームで使用するマウスボタンを設定します。
Pen | ズーム領域の矩形を描くペンを設定します。
Zoomed | チャートの軸スケールをすべてのチャートポイントに適合させるかどうかを定義します。

参照

Zoom クラス | Steema.TeeChart 名前空間


Allow

Steema.TeeChart.Zoom.Allow プロパティ

trueの場合、実行時にマウスのドラッグによるズームを有効にします。

public Boolean Allow {get; set;}

解説

trueの場合、実行時にマウスのドラッグによるズームを有効にします。

例

[C#]

tChart1.Zoom.Allow = true;

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Animated

Steema.TeeChart.Zoom.Animated プロパティ

trueの場合、ズームを動的に行います。

public Boolean Animated {get; set;}

解説

デフォルト値：false

ズームを即時または動的に行うかどうか制御します。AnimatedStepsプロパティは、ズームステップの数を制御します。Animatedズームは、ポイント数が多い場合に便利です。

AnimatedがTrueの場合、ズームは連続的なズームで実行されます。ズームステップの数は AnimatedSteps プロパティを使用して変更できます。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


AnimatedSteps

Steema.TeeChart.Zoom.AnimatedSteps プロパティ

一連の動画ズームのステップ数を定義します。

public Int32 AnimatedSteps {get; set;}

解説

デフォルト値：8

一連の動画ズームのステップ数を定義します。ステップ数が大きいとズームの速度が遅くなります。このプロパティを有効にするためには、Animatedプロパティをtrueにしなければなりません。

例

[C#]

このコードは、動画ズーム機能をオンにします。

tChart1.Zoom.Animated = true;
tChart1.Zoom.AnimatedSteps = 4;

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Brush

Steema.TeeChart.Zoom.Brush プロパティ

マウスドラッグで指定されたズーム領域を塗りつぶすブラシを定義します。
public ChartBrush Brush {get;}

解説

マウスドラッグで指定されたズーム領域を塗りつぶすブラシを定義します。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Direction

Steema.TeeChart.Zoom.Direction プロパティ

選択された領域でズームの方向を設定します。
public ZoomDirections Direction {get; set;}

解説

デフォルト値：Both

選択された領域でズームの方向（水平方向、垂直方向、両方）を設定します。例：Horizontalは、選択されたズーム領域で水平方向のみズームします（垂直方向はズームされません）。

例

[C#]

tChart1.Zoom.Direction = ZoomDirections.Horizontal;

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


MinPixels

Steema.TeeChart.Zoom.MinPixels プロパティ

ズームを適用する最小ピクセル数を設定します。

public Int32 MinPixels {get; set;}

解説

マウスドラッグによるズームを適用するための最小ピクセル数を設定します。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


MouseButton

Steema.TeeChart.Zoom.MouseButton プロパティ

ズームで使用するマウスボタンを設定します。

public MouseButtons MouseButton {get; set;}

解説

デフォルト値：Left

ズームで使用するマウスボタンを設定します。スクロールはデフォルトで右のマウスボタンを使用します。

例

[C#]

tChart1.Zoom.MouseButton = MouseButtons.Right;

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Pen

Steema.TeeChart.Zoom.Pen プロパティ

ズーム領域の矩形を描くペンを設定します。
public ChartPen Pen {get;}

解説

マウスをドラッグしてズーム領域の矩形を描くペンを設定します。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Zoomed

Steema.TeeChart.Zoom.Zoomed プロパティ

チャートの軸スケールをすべてのチャートポイントに適合させるかどうかを定義します。
public Boolean Zoomed {get; set;}

解説

実行時専用。

チャートの軸スケールをすべてのチャートポイントに適合させるかどうかを定義します。

ユーザが実行時にマウスを使用してチャートに対してズームやスクロールを行う場合には、これをTrueに設定します。

Zoom.Undoメソッドは、このプロパティをFalseに設定し、すべての系列ポイントを表示するように軸スケールをリセットします。

デフォルト値はTrueです。これは、チャートが最初に表示される時点で、ズームもスクロールも適用されていないことになります。

参照

Zoom クラス | Zoom メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ZoomDirections

Steema.TeeChart.ZoomDirections 列挙体

Directionプロパティの使用可能な値です。

[Serializable]
public enum ZoomDirections : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Horizontal | 水平方向のズームのみ有効。
Vertical | 垂直方向のズームのみ有効。
Both | 水平・垂直方向のズームが有効。

参照

Steema.TeeChart 名前空間


Steema.TeeChart.ZoomScroll

Steema.TeeChart.ZoomScroll クラス

内部使用。ズームおよびスクロールのサポートをします。

この型のすべてのメンバの一覧については、ZoomScroll メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class ZoomScroll : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart

アセンブリ: TeeChart.dll

参照

ZoomScroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ZoomScroll 全メンバ

ZoomScroll 概要

コンストラクタ

Constructor

パブリック フィールド

x0
x1
y0
y1

パブリック メソッド

Activate | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check | X1がX0より小さい場合、X0とX1 座標を交換します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Active | チャートのズームやスクロールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
KeyShift | ズームを開始するためのオプションとしてキーボードボタンを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ZoomScroll クラス | Steema.TeeChart 名前空間


ZoomScroll コンストラクタ

Steema.TeeChart.ZoomScroll コンストラクタ

public ZoomScroll(Chart c)

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ZoomScroll フィールド

パブリック フィールド

x0
x1
y0
y1

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ZoomScroll クラス | Steema.TeeChart 名前空間


x0

Steema.TeeChart.ZoomScroll.x0 フィールド

public Int32 x0

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


x1

Steema.TeeChart.ZoomScroll.x1 フィールド

public Int32 x1

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


y0

Steema.TeeChart.ZoomScroll.y0 フィールド

public Int32 y0

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


y1

Steema.TeeChart.ZoomScroll.y1 フィールド

public Int32 y1

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ZoomScroll メソッド

パブリック メソッド

Activate | 内部使用。X,Y座標からズームまたはスクロールを開始します。
Check | X1がX0より小さい場合、X0とX1 座標を交換します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ZoomScroll クラス | Steema.TeeChart 名前空間


Activate

Steema.TeeChart.ZoomScroll.Activate メソッド

内部使用。X,Y座標からズームまたはスクロールを開始します。

public Void Activate(Int32 x,
     Int32 y)

解説

内部使用。X,Y座標からズームまたはスクロールを開始します。

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


Check

Steema.TeeChart.ZoomScroll.Check メソッド

X1がX0より小さい場合、X0とX1座標を交換します。

public Void Check()

解説

X1がX0より小さい場合、X0とX1座標を交換します。
Y0やY1プロパティも同様です。

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


SetActive

Steema.TeeChart.ZoomScroll.SetActive メソッド

protected abstract Void SetActive(Boolean value)

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.ZoomScroll プロパティ

パブリック プロパティ

Active | チャートのズームやスクロールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
KeyShift | ズームを開始する特別な条件としてキーボードボタンを設定します。

解説

ZoomScrollプロパティにアクセスします。

参照

ZoomScroll クラス | Steema.TeeChart 名前空間


Active

Steema.TeeChart.ZoomScroll.Active プロパティ

チャートのズームやスクロールを有効/無効にします。

public Boolean Active {get; set;}

解説

チャートのズームやスクロールを有効/無効にします（ズーム中やスクロール中は、trueを返します）。

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


KeyShift

Steema.TeeChart.ZoomScroll.KeyShift プロパティ

ズームを開始する特別な条件としてキーボードボタンを設定します。
public Keys KeyShift {get; set;}

参照

ZoomScroll クラス | ZoomScroll メンバ | Steema.TeeChart 名前空間


Steema.TeeChart.Data

Steema.TeeChart.Data 名前空間

名前空間の階層構造

パブリック 構造体

SHPHeader
SHPRecordHeader

パブリック クラス

SHP TeeSHPの概要。

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.Mapping.dll


Steema.TeeChart.Data 階層構造

System.Object

Steema.TeeChart.Data.SHP

参照

SteemaTeeChartData 名前空間


Steema.TeeChart.Data.ChartAggregate

Steema.TeeChart.Data.ChartAggregate 列挙体

集計のグループ構成。
[Serializable]
public sealed enum ChartAggregate : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None |
Sum |
Count |
High |
Low |
Average |

参照

Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.CrossTabSource

Steema.TeeChart.Data.CrossTabSource クラス

データベースレコードのCrossTabから複数の系列を描画します。 このコンポーネントは、Series.DataSourceプロパティに割り当てられていなければなりません。

この型のすべてのメンバの一覧については、CrossTabSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
[Serializable]
public class CrossTabSource : SeriesSource , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.CrossTabSource 全メンバ

CrossTabSource 概要

コンストラクタ

Constructor オーバーロード。後でデータソース内容を設定する場合、このコンストラクタを使用してください。

パブリック メソッド

RefreshData CrossTabSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

パブリック プロパティ

CaseSensitive | このプロパティがTrueの場合、データベース内のラベルあるいはグループテキストの大文字や小文字を区別します。従って、最終的なチャートに新しい系列あるいはグループを作成します。
DataSource | CrossTabSourceに関連付けられたデータソースを取得/設定します。
Formula | 系列にポイントを追加するためにCrossTabSourceがどのようにデータベースの値を使用するか設定します。
GroupField | グループ化するフィールドとして使用されるデータセット内のフィールドを設定します。このフィールド内の異なる値は、付加的な系列を作成するために使用されます。
LabelField | 系列ポイントにラベル（テキスト）を追加するための、データセット内のフィールドを設定します。
Series | データソースとする系列を設定します。
ValueField | CrossTabSourceチャートの累積を実行するための、データセット内の値フィールドを設定します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

CrossTabSource クラス | Steema.TeeChart.Data 名前空間


CrossTabSource コンストラクタ

Steema.TeeChart.Data.CrossTabSource コンストラクタ

オーバーロードの一覧

後でデータソース内容を設定する場合、このコンストラクタを使用してください。

public CrossTabSource()

データソースが既に使用可能な場合、このコンストラクタを使用してください。

public CrossTabSource(System.Object)

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


CrossTabSource コンストラクタ

Steema.TeeChart.Data.CrossTabSource コンストラクタ

後でデータソース内容を設定する場合、このコンストラクタを使用してください。
public CrossTabSource()

参照

CrossTabSource コンストラクタのオーバーロードの一覧 | CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


CrossTabSource コンストラクタ

Steema.TeeChart.Data.CrossTabSource コンストラクタ

データソースが既に使用可能な場合、このコンストラクタを使用してください。
public CrossTabSource(Object source)

参照

CrossTabSource コンストラクタのオーバーロードの一覧 | CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.CrossTabSource メソッド

パブリック メソッド

RefreshData CrossTabSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

CrossTabSource クラス | Steema.TeeChart.Data 名前空間


RefreshData

Steema.TeeChart.Data.CrossTabSource.RefreshData メソッド

CrossTabSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。
public override Void RefreshData()

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.CrossTabSource プロパティ

パブリック プロパティ

CaseSensitive | このプロパティがTrueの場合、データベース内のラベルあるいはグループテキストの大文字や小文字を区別します。従って、最終的なチャートに新しい系列あるいはグループを作成します。
DataSource | CrossTabSourceに関連付けられたデータソースを取得/設定します。
Formula | 系列にポイントを追加するためにCrossTabSourceがどのようにデータベースの値を使用するか設定します。
GroupField | グループ化するフィールドとして使用されるデータセット内のフィールドを設定します。このフィールド内の異なる値は、付加的な系列を作成するために使用されます。
LabelField | 系列ポイントにラベル（テキスト）を追加するための、データセット内のフィールドを設定します。
Series | データソースとする系列を設定します。
ValueField | CrossTabSourceチャートの累積を実行するための、データセット内の値フィールドを設定します。

参照

CrossTabSource クラス | Steema.TeeChart.Data 名前空間


CaseSensitive

Steema.TeeChart.Data.CrossTabSource.CaseSensitive プロパティ

このプロパティがTrueの場合、データベース内のラベルあるいはグループテキストの大文字や小文字を区別します。従って、最終的なチャートに新しい系列あるいはグループを作成します。
public Boolean CaseSensitive {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


DataSource

Steema.TeeChart.Data.CrossTabSource.DataSource プロパティ

CrossTabSourceに関連付けられたデータソースを取得/設定します。
public Object DataSource {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Formula

Steema.TeeChart.Data.CrossTabSource.Formula プロパティ

系列にポイントを追加するためにCrossTabSourceがどのようにデータベースの値を使用するか設定します。
public GroupFormula Formula {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


GroupField

Steema.TeeChart.Data.CrossTabSource.GroupField プロパティ

グループ化するフィールドとして使用されるデータセット内のフィールドを設定します。 このフィールド内の異なる値は、付加的な系列を作成するために使用されます。
public String GroupField {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


LabelField

Steema.TeeChart.Data.CrossTabSource.LabelField プロパティ

系列ポイントにラベル（テキスト）を追加するための、データセット内のフィールドを設定します。
public String LabelField {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Series

Steema.TeeChart.Data.CrossTabSource.Series プロパティ

データソースとする系列を設定します。
public Series Series {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


ValueField

Steema.TeeChart.Data.CrossTabSource.ValueField プロパティ

CrossTabSourceチャートの累積を実行するための、データセット内の値フィールドを設定します。
public String ValueField {get; set;}

参照

CrossTabSource クラス | CrossTabSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.DataGroup

TeeChartプログラミングガイド

Steema.TeeChart.Data.DataGroup 列挙体

タイムスパンのグループ構成。

[Serializable]
public enum DataGroup : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Hour |
Day |
Week |
WeekDay |
Month |
Quarter |
Year |
None |

参照

Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.DataSeriesSource

Steema.TeeChart.Data.DataSeriesSource クラス

データベースのSeries.DataSourceコンポーネントを定義する抽象クラス。

この型のすべてのメンバの一覧については、DataSeriesSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
public abstract class DataSeriesSource : SeriesSource , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

DataSeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.DataSeriesSource 全メンバ

DataSeriesSource 概要

コンストラクタ

Constructor

パブリック メソッド

IsTeeDataSet |
IsValidSource | オブジェクトが有効なソ－スの場合、trueを返します。
RefreshData (SeriesSourceの継承元) | ソースからのデータで系列を描画します。

パブリック プロパティ

Series (SeriesSourceの継承元) データソースとする系列を設定します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

DataSeriesSource クラス | Steema.TeeChart.Data 名前空間


DataSeriesSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.DataSeriesSource コンストラクタ

protected DataSeriesSource()

参照

DataSeriesSource クラス | DataSeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.DataSeriesSource メソッド

パブリック メソッド

IsTeeDataSet |
IsValidSource | オブジェクトが有効なソ－スの場合、trueを返します。
RefreshData (SeriesSourceの継承元) | ソースからのデータで系列を描画します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

DataSeriesSource クラス | Steema.TeeChart.Data 名前空間


IsTeeDataSet

Steema.TeeChart.Data.DataSeriesSource.IsTeeDataSet メソッド

public static Boolean IsTeeDataSet(Object o)

参照

DataSeriesSource クラス | DataSeriesSource メンバ | Steema.TeeChart.Data 名前空間


IsValidSource

TeeChartプログラミングガイド

Steema.TeeChart.Data.DataSeriesSource.IsValidSource メソッド

オブジェクトが有効なソースの場合、trueを返します。

public static Boolean IsValidSource(Object c)

解説

オブジェクトが有効なソースの場合、trueを返します。

参照

DataSeriesSource クラス | DataSeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.DataSeriesSource プロパティ

パブリック プロパティ

Series (SeriesSourceの継承元) データソースとする系列を設定します。

参照

DataSeriesSource クラス | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.GroupFormula

Steema.TeeChart.Data.GroupFormula 列挙体

CrossTabがデータセットフィールド値を累算するか、レコードを数えるかを定義します。
[Serializable]
public sealed enum GroupFormula : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Count |
Sum |
Min |
Max |
Product |

参照

Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SeriesSource

TeeChartプログラミングガイド

Steema.TeeChart.Data.SeriesSource クラス

Series.DataSourceコンポーネントを定義する抽象クラス。

この型のすべてのメンバの一覧については、SeriesSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
[Serializable]
public abstract class SeriesSource : Component
, IComponent, IDisposable

必要条件

名前空間： Steema.TeeChart.Data

アセンブリ：TeeChart.dll

参照

SeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SeriesSource 全メンバ

SeriesSource 概要

コンストラクタ

Constructor

パブリック メソッド

RefreshData ソースからのデータで系列を描画します。

パブリック プロパティ

Series データソースとする系列を設定します。

プロテクト メソッド

Dispose

参照

SeriesSource クラス | Steema.TeeChart.Data 名前空間


SeriesSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SeriesSource コンストラクタ

protected SeriesSource()

参照

SeriesSource クラス | SeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SeriesSource メソッド

パブリック メソッド

RefreshData ソースからのデータで系列を描画します。

プロテクト メソッド

Dispose

参照

SeriesSource クラス | Steema.TeeChart.Data 名前空間


Dispose

Steema.TeeChart.Data.SeriesSource.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

SeriesSource クラス | SeriesSource メンバ | Steema.TeeChart.Data 名前空間


RefreshData

TeeChartプログラミングガイド

Steema.TeeChart.Data.SeriesSource.RefreshData メソッド

ソースからのデータで系列を描画します。

public virtual Void RefreshData()

解説

ソースからのデータで系列を描画します。

参照

SeriesSource クラス | SeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SeriesSource プロパティ

パブリック プロパティ

Series データソースとする系列を設定します。

参照

SeriesSource クラス | Steema.TeeChart.Data 名前空間


Series

Steema.TeeChart.Data.SeriesSource.Series プロパティ

データソースとする系列を設定します。
public Series Series {get; set;}

解説

データソースとする系列を設定します。

参照

SeriesSource クラス | SeriesSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SingleRecordSource

Steema.TeeChart.Data.SingleRecordSource クラス

単一データセットからフィールドで系列に出力します。 このコンポーネントは、Series.DataSourceプロパティに割り当てられていなければなりません。

この型のすべてのメンバの一覧については、SingleRecordSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
Steema.TeeChart.Data.DataSeriesSource
public class SingleRecordSource : DataSeriesSource , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SingleRecordSource 全メンバ

SingleRecordSource 概要

コンストラクタ

Constructor オーバーロード。SingleRecordSource クラスの新しいインスタンスを初期化します。

パブリック メソッド

RefreshData SingleRecordSource のデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSource メソッドを使用してください。

パブリック プロパティ

DataSource | SingleRecordSourceに関連付けられたデータソースを取得/設定します。
Position | 系列に出力するデータセットの行を取得/設定します。
RecordCurrency | レコードを移動する時、データソースの位置をたどるために CurrencyManager を RecordCurrency に設定してください。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。
ValueMembers | SingleRecordSourceのフィールド名を保持します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

SingleRecordSource クラス | Steema.TeeChart.Data 名前空間


SingleRecordSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource コンストラクタ

オーバーロードの一覧

SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource()

データソースとフィールド名を使用して、SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource(System.Object, System.String[])

データソースとフィールド名および CurrencyManager を使用して、SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource(System.Object, System.String[], System.Windows.Forms.CurrencyManager)

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


SingleRecordSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource コンストラクタ

SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource()

参照

SingleRecordSource コンストラクタのオーバーロードの一覧 | SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


SingleRecordSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource コンストラクタ

データソースとフィールド名を使用して、SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource(Object source,
     String[] fields)

参照

SingleRecordSource コンストラクタのオーバーロードの一覧 | SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


SingleRecordSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource コンストラクタ

データソースとフィールド名および CurrencyManager を使用して、SingleRecordSource クラスの新しいインスタンスを初期化します。

public SingleRecordSource(Object source,
     String[] fields,
     CurrencyManager manager)

参照

SingleRecordSource コンストラクタのオーバーロードの一覧 | SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SingleRecordSource メソッド

パブリック メソッド

RefreshData SingleRecordSourceのデータソースから系列を更新します。このメソッドを直接呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

SingleRecordSource クラス | Steema.TeeChart.Data 名前空間


RefreshData

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource.RefreshData メソッド

SingleRecordSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

public virtual Void RefreshData()

解説

SingleRecordSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SingleRecordSource プロパティ

パブリック プロパティ

DataSource | SingleRecordSourceに関連付けられたデータソースを取得/設定します。
Position | 系列に出力するデータセットの行を取得/設定します。
RecordCurrency | レコードを移動する時、データソースの位置をたどるために CurrencyManager を RecordCurrency に設定してください。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。
ValueMembers | SingleRecordSourceのフィールド名を保持します。

参照

SingleRecordSource クラス | Steema.TeeChart.Data 名前空間


DataSource

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource.DataSource プロパティ

SingleRecordSourceに関連付けられたデータソースを取得/設定します。

public Object DataSource {get; set;}

解説

SingleRecordSourceに関連付けられたデータソースを取得/設定します。

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Position

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource.Position プロパティ

系列に出力するデータセットの行を取得/設定します。

public Int32 Position {get; set;}

解説

系列に出力するデータセットの行を取得/設定します。

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


RecordCurrency

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource.RecordCurrency プロパティ

レコードを移動する時、データソースの位置をたどるために CurrencyManager を RecordCurrency に設定してください。

public CurrencyManager RecordCurrency {get; set;}

例

myCurrencyManager = (CurrencyManager)this.BindingContext[sourceTable];
singleRecordSource1.RecordCurrency = myCurrencyManager;

解説

レコードを移動する時、データソースの位置をたどるために CurrencyManager を RecordCurrency に設定してください。

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Value 全メンバ

TeeChartプログラミングガイド

Steema.TeeChart.Data.SingleRecordSource.ValueMembers プロパティ

SingleRecordSourceのフィールド名を保持します。

public String[] ValueMembers {get; set;}

解説

SingleRecordSourceのフィールド名を保持します。

参照

SingleRecordSource クラス | SingleRecordSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SummarySource

Steema.TeeChart.Data.SummarySource クラス

データセットからサマリーフィールドで系列に出力します。 このコンポーネントはSeries.DataSourceプロパティに割り当てられていなければなりません。

この型のすべてのメンバの一覧については、SummarySource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
Steema.TeeChart.Data.DataSeriesSource
public class SummarySource : DataSeriesSource , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

SummarySource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SummarySource 全メンバ

SummarySource 概要

コンストラクタ

Constructor オーバーロード。 後でサマリーソースの内容を設定する場合、このコンストラクタを使用してください。

パブリック メソッド

RefreshData SingleRecordSourceのデータソースから系列を更新します。 直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

パブリック プロパティ

DataSource | SingleRecordSourceに関連付けられたデータソースを取得/設定します。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

SummarySource クラス | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SummarySource コンストラクタ

Steema.TeeChart.Data.SummarySource コンストラクタ

オーバーロードの一覧

後でサマリーソースの内容を設定する場合、このコンストラクタを使用してください。

public SummarySource()

既に使用可能なデータソースがある場合、このコンストラクタを使用してください。

public SummarySource(System.Object)

参照

SummarySource クラス | SummarySource メンバ | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SummarySource コンストラクタ

Steema.TeeChart.Data.SummarySource コンストラクタ

後でサマリーソースの内容を設定する場合、このコンストラクタを使用してください。
public SummarySource()

参照

SummarySource コンストラクタのオーバーロードの一覧 | SummarySource クラス | SummarySource メンバ | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SummarySource コンストラクタ

Steema.TeeChart.Data.SummarySource コンストラクタ

既に使用可能なデータソースがある場合、このコンストラクタを使用してください。
public SummarySource(Object source)

参照

SummarySource コンストラクタのオーバーロードの一覧 | SummarySource クラス | SummarySource メンバ | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Data.SummarySource メソッド

パブリック メソッド

RefreshData SingleRecordSourceのデータソースから系列を更新します。 直接このメソッドを呼び出す必要はありません。 CheckDataSourceメソッドを使用してください。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

SummarySource クラス | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


RefreshData

Steema.TeeChart.Data.SummarySource.RefreshData メソッド

SingleRecordSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。
public override Void RefreshData()

解説

SingleRecordSourceのデータソースから系列を更新します。直接このメソッドを呼び出す必要はありません。CheckDataSourceメソッドを使用してください。

参照

SummarySource クラス | SummarySource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SummarySource プロパティ

パブリック プロパティ

DataSource | SingleRecordSourceに関連付けられたデータソースを取得/設定します。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。

参照

SummarySource クラス | Steema.TeeChart.Data 名前空間


DataSource

Steema.TeeChart.Data.SummarySource.DataSource プロパティ

SingleRecordSourceに関連付けられたデータソースを取得/設定します。
public Object DataSource {get; set;}

参照

SummarySource クラス | SummarySource メンバ | Steema.TeeChart.Data 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Data.TextField

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextField クラス

ソースのTextfield特性。

この型のすべてのメンバの一覧については、TextField メンバを参照してください。

System.Object
[Serializable]
public class TextField : Object

必要条件

名前空間： Steema.TeeChart.Data

アセンブリ：TeeChart.dll

参照

TextField メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextField 全メンバ

TextField 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Index | 追加されたテキストソースのフィールドのインデックスを保持します。
Name | 追加されたテキストソースのフィールドの名前を保持します。

参照

TextField クラス | Steema.TeeChart.Data 名前空間


TextField コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextField コンストラクタ

オーバーロードの一覧

public TextField()
public TextField(System.Int32, System.String)

参照

TextField クラス | TextField メンバ | Steema.TeeChart.Data 名前空間


TextField コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextField コンストラクタ

public TextField()

参照

TextField コンストラクタのオーバーロードの一覧 | TextField クラス | TextField メンバ | Steema.TeeChart.Data 名前空間


TextField コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextField コンストラクタ

public TextField(Int32 index,
     String name)

参照

TextField コンストラクタのオーバーロードの一覧 | TextField クラス | TextField メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextField プロパティ

パブリック プロパティ

Index | 追加されたテキストソースのフィールドのインデックスを保持します。
Name | 追加されたテキストソースのフィールドの名前を保持します。

参照

TextField クラス | Steema.TeeChart.Data 名前空間


Index

Steema.TeeChart.Data.TextField.Index プロパティ

追加されたテキストソースのフィールドのインデックスを保持します。
public Int32 Index {get; set;}

参照

TextField クラス | TextField メンバ | Steema.TeeChart.Data 名前空間


Name

Steema.TeeChart.Data.TextField.Name プロパティ

追加されたテキストソースのフィールドの名前を保持します。
public String Name {get; set;}

参照

TextField クラス | TextField メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextFieldCollection

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextFieldCollection クラス

TextFieldコレクション。

この型のすべてのメンバの一覧については、TextFieldCollection メンバを参照してください。

System.Object
System.Collections.CollectionBase
[Serializable]
public class TextFieldCollection : CollectionBase
, IList, ICollection, IEnumerable

必要条件

名前空間： Steema.TeeChart.Data

アセンブリ：TeeChart.dll

参照

TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextFieldCollection 全メンバ

TextFieldCollection 概要

パブリック メソッド

Add | TextFieldCollectionにテキストソースのフィールドを追加します。
AddRange |
Insert | TextFieldCollectionの指定したインデックスにテキストソースのフィールドを挿入します。
Remove | TextFieldCollectionからテキストソースのフィールドを削除します。

パブリック プロパティ

Item

参照

TextFieldCollection クラス | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextFieldCollection メソッド

パブリック メソッド

Add | TextFieldCollectionにテキストソースのフィールドを追加します。
AddRange |
Insert | TextFieldCollectionの指定したインデックスにテキストソースのフィールドを挿入します。
Remove | TextFieldCollectionからテキストソースのフィールドを削除します。

参照

TextFieldCollection クラス | Steema.TeeChart.Data 名前空間


Add

Steema.TeeChart.Data.TextFieldCollection.Add メソッド

オーバーロードの一覧

TextFieldCollectionにテキストソースのフィールドを追加します。

public Int32 Add(Steema.TeeChart.Data.TextField)

TextFieldCollectionにテキストソースのフィールドを追加します。

public Int32 Add(System.Int32, System.String)

参照

TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Add

Steema.TeeChart.Data.TextFieldCollection.Add メソッド

TextFieldCollectionにテキストソースのフィールドを追加します。
public Int32 Add(TextField field)

参照

Add オーバーロードの一覧 | TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Add

Steema.TeeChart.Data.TextFieldCollection.Add メソッド

TextFieldCollectionにテキストソースのフィールドを追加します。
public Int32 Add(Int32 index,
     String name)

参照

Add オーバーロードの一覧 | TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


AddRange

Steema.TeeChart.Data.TextFieldCollection.AddRange メソッド

public Void AddRange(TextField[] fields)

解説

値やラベルなどの配列を追加する必要がある場合に使用することができます。

例

[C#]

ラベルを含む文字列の配列を使用して、以下のように系列ラベルに割り当てることができます。

string[] labelStr = new string[] "a","b","c","d","e";
Steema.TeeChart.Styles.StringList labels = new Steema.TeeChart.Styles.StringList(5);
labels.AddRange(labelStr);
int[] values = new int[] 1, 2, 3, 4, 5,;
line1.Add(values);
line1.Labels = labels;
テキストに下軸のラベルスタイルを設定する場合、系列のラベルを表示します。系列がXラベルを含み、ラベルをカスタマイズして表示したい場合はAxisイベントを使用してください。

参照

TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Insert

Steema.TeeChart.Data.TextFieldCollection.Insert メソッド

TextFieldCollectionの指定したインデックスにテキストソースのフィールドを挿入します。
public Void Insert(Int32 index,
     TextField field)

参照

TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Remove

Steema.TeeChart.Data.TextFieldCollection.Remove メソッド

TextFieldCollectionからテキストソースのフィールドを削除します。
public Void Remove(TextField field)

参照

TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextFieldCollection プロパティ

パブリック プロパティ

Item

参照

TextFieldCollection クラス | Steema.TeeChart.Data 名前空間


Item

Steema.TeeChart.Data.TextFieldCollection.Item プロパティ

public TextField Item(Int32 index) {get;}

参照

TextFieldCollection クラス | TextFieldCollection メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextSource

Steema.TeeChart.Data.TextSource クラス

単一データセットのフィールドで系列に出力します。 このコンポーネントは、Series.DataSourceプロパティに割り当てられていなければなりません。

この型のすべてのメンバの一覧については、TextSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
[Serializable]
public class TextSource : SeriesSource , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

TextSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextSource 全メンバ

TextSource 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Add |
IsURL | FileNameプロパティが「http://」で始まる場合、trueを返します。
LoadFromFile |
LoadFromStream |
LoadFromStrings |
LoadFromURL |
RefreshData |

パブリック プロパティ

DecimalSeparator | TextSourceの数値を読むために使用する10進のセパレーターを指定します。
Fields |
FileName |
HeaderLines |
Separator |
Series (SeriesSourceの継承元) | データソースとする系列を設定します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

TextSource クラス | Steema.TeeChart.Data 名前空間


TextSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextSource コンストラクタ

オーバーロードの一覧

public TextSource()
public TextSource(System.String)

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


TextSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextSource コンストラクタ

public TextSource()

参照

TextSource コンストラクタのオーバーロードの一覧 | TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


TextSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextSource コンストラクタ

public TextSource(String fileName)

参照

TextSource コンストラクタのオーバーロードの一覧 | TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextSource メソッド

パブリック メソッド

Add |
IsURL | FileNameプロパティが「http://」で始まる場合、trueを返します。
LoadFromFile |
LoadFromStream |
LoadFromStrings |
LoadFromURL |
RefreshData |

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

TextSource クラス | Steema.TeeChart.Data 名前空間


Add

Steema.TeeChart.Data.TextSource.Add メソッド

public Void Add(StreamReader r)

解説

テキストソースファイルにフィールドを追加します。フィールド名は、SeriesのValueListの値を定義するために使用される名前と一致しなければなりません。最初の列のインデックスは、1から始まります。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


IsURL

TeeChartプログラミングガイド

Steema.TeeChart.Data.TextSource.IsURL メソッド

FileNameプロパティが｢http://｣で始まる場合、trueを返します。

public Boolean IsURL()

解説

FileNameプロパティが｢http://｣で始まる場合、trueを返します。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


LoadFromFile

Steema.TeeChart.Data.TextSource.LoadFromFile メソッド

public Void LoadFromFile(String AFileName)

解説

ファイルからデータを読込むためにこのメソッドを使用してください。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


LoadFromStream

Steema.TeeChart.Data.TextSource.LoadFromStream メソッド

public Void LoadFromStream(Stream Stream)

解説

ストリームオブジェクトからデータを読込むためにこのメソッドを使用してください。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


LoadFromStrings

Steema.TeeChart.Data.TextSource.LoadFromStrings メソッド

public Void LoadFromStrings(String[] Strings)

解説

文字列リソースからデータを読込むためにこのメソッドを使用してください。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


LoadFromURL

Steema.TeeChart.Data.TextSource.LoadFromURL メソッド

public Void LoadFromURL(String AURL)

解説

URLリソースからデータを読込みます。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


RefreshData

Steema.TeeChart.Data.TextSource.RefreshData メソッド

public override Void RefreshData()

解説

TextSourceのDatasourceから系列を更新します。このメソッドは直接呼び出す必要はありません。もし、更新したい場合は、CheckDataSourceメソッドを使用してください。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.TextSource プロパティ

パブリック プロパティ

DecimalSeparator | TextSourceの数値を読むために使用する10進のセパレーターを指定します。
Fields |
FileName |
HeaderLines |
Separator |
Series (SeriesSourceの継承元) | データソースとする系列を設定します。

参照

TextSource クラス | Steema.TeeChart.Data 名前空間


DecimalSeparator

Steema.TeeChart.Data.TextSource.DecimalSeparator プロパティ

TextSource内で整数と小数点を区別するためのセパレータを指定します。

public Char DecimalSeparator {get; set;}

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


Fields

Steema.TeeChart.Data.TextSource.Fields プロパティ

public TextFieldCollection Fields {get;}

解説

TSeriesTextFieldsのプロパティやメソッドにアクセスします。このプロパティは、系列にデータソースのデータを追加するために設定しなければなりません。SeriesTextSourceのフィールドをセットアップするには、Addメソッドを使用してください。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


FileName

Steema.TeeChart.Data.TextSource.FileName プロパティ

public String FileName {get; set;}

解説

系列にデータをインポートするための、SeriesSourceオブジェクトで使用されるファイルを設定します。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


HeaderLines

Steema.TeeChart.Data.TextSource.HeaderLines プロパティ

public Int32 HeaderLines {get; set;}

解説

テキストソースファイルのデータのヘッダーとして設定する行数を定義します。データがソーステキストファイルから取得されると、ヘッダー行の内容は無効になります。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


Separator

Steema.TeeChart.Data.TextSource.Separator プロパティ

public Char Separator {get; set;}

解説

テキストソースファイル内のフィールドを区切るキャラクタを設定します。

標準のcsvファイル（カンマで区切られた変数）のキャラクタは、通常コンマです。従って、このプロパティは「,」となります。

参照

TextSource クラス | TextSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.XmlSource

Steema.TeeChart.Data.XmlSource クラス

XML系列データソース。

この型のすべてのメンバの一覧については、XmlSource メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Data.SeriesSource
[Serializable]
public class XmlSource : SeriesSource , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.dll

参照

XmlSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.XmlSource 全メンバ

XmlSource 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Load |
RefreshData (SeriesSourceの継承元) | ソースからのデータで系列を描画します。

パブリック プロパティ

Chart |
DataMember | XMLインポートのデータのターゲットとして使用するValueListを取得/設定します。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。
SeriesNode |

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

XmlSource クラス | Steema.TeeChart.Data 名前空間


XmlSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.XmlSource コンストラクタ

オーバーロードの一覧

public XmlSource()
public XmlSource(Steema.TeeChart.Styles.Series)
public XmlSource(Steema.TeeChart.Chart)

参照

XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


XmlSource コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Data.XmlSource コンストラクタ

public XmlSource()

参照

XmlSource コンストラクタのオーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


XmlSource コンストラクタ

Steema.TeeChart.Data.XmlSource コンストラクタ

public XmlSource(Series s)

参照

XmlSource コンストラクタのオーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


XmlSource コンストラクタ

Steema.TeeChart.Data.XmlSource コンストラクタ

public XmlSource(Chart c)

参照

XmlSource コンストラクタのオーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.XmlSource メソッド

パブリック メソッド

Load |
RefreshData (SeriesSourceの継承元) | ソースからのデータで系列を描画します。

プロテクト メソッド

Dispose (SeriesSourceの継承元)

参照

XmlSource クラス | Steema.TeeChart.Data 名前空間


Load

Steema.TeeChart.Data.XmlSource.Load メソッド

オーバーロードの一覧

public Void Load(System.String[])
public Void Load(System.String)
public Void Load(System.Xml.XmlDocument)

解説

このメソッドは、SeriesSourceオブジェクトにファイルをロードするために、FileNameプロパティあるいはURLプロパティを使用して系列にデータを設定します。

TextBoxからXMLをインポート。
例
[C#]
protected override void button1_Click(object sender, System.EventArgs e)
            tChart1.Series.RemoveAllSeries();
            Steema.TeeChart.Styles.Points points1 = new Steema.TeeChart.Styles.Points(tChart1.Chart);
            points1.Title = "Points Series";
            xmlSource1.Series = points1;
            xmlSource1.SeriesNode = "Points Series";
            xmlSource1.Load(textBox2.Lines);

            tChart1.Refresh();

URLからXMLをインポート
例
[C#]
protected override void button2_Click(object sender, System.EventArgs e)
            tChart1.Series.RemoveAllSeries();
            xmlSource1.Chart = tChart1.Chart;
            xmlSource1.Load("http://www.steema.com/SampleNETData.xml");

            tChart1.Refresh();

参照

XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Load

Steema.TeeChart.Data.XmlSource.Load メソッド

public Void Load(String[] xmlLines)

参照

Load オーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Load

Steema.TeeChart.Data.XmlSource.Load メソッド

public Void Load(String fileName)

参照

Load オーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Load

Steema.TeeChart.Data.XmlSource.Load メソッド

public Void Load(XmlDocument d)

参照

Load オーバーロードの一覧 | XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.XmlSource プロパティ

パブリック プロパティ

Chart |
DataMember | XMLインポートのデータのターゲットとして使用するValueListを取得/設定します。
Series (SeriesSourceの継承元) | データソースとする系列を設定します。
SeriesNode |

参照

XmlSource クラス | Steema.TeeChart.Data 名前空間


Chart

Steema.TeeChart.Data.XmlSource.Chart プロパティ

public Chart Chart {get; set;}

解説

XMLソースから系列や系列データを追加するチャートコンポーネントを取得/設定します。

URLからXMLをインポートします。
例
[C#]
protected override void button2_Click(object sender, System.EventArgs e)
            tChart1.Series.RemoveAllSeries();
            xmlSource1.Chart = tChart1.Chart;
            xmlSource1.Load("http://www.steema.com/SampleNETData.xml");

            tChart1.Refresh();

参照

XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


DataMember

Steema.TeeChart.Data.XmlSource.DataMember プロパティ

XMLインポートのデータのターゲットとして使用するValueListを取得/設定します。
public String DataMember {get; set;}

解説

XMLインポートのデータのターゲットとして使用するValueListを取得/設定します。

参照

XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


SeriesNode

Steema.TeeChart.Data.XmlSource.SeriesNode プロパティ

public String SeriesNode {get; set;}

解説

XMLソースデータに複数の系列が存在する場合、このプロパティに指定した系列名のみをインポートします。

TextBoxからXMLのインポート
例
[C#]
protected override void button1_Click(object sender, System.EventArgs e)
            tChart1.Series.RemoveAllSeries();
            Steema.TeeChart.Styles.Points points1 = new Steema.TeeChart.Styles.Points(tChart1.Chart);
            points1.Title = "Points Series";
            xmlSource1.Series = points1;
            xmlSource1.SeriesNode = "Points Series";
            xmlSource1.Load(textBox2.Lines);

            tChart1.Refresh();

参照

XmlSource クラス | XmlSource メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Drawing

Steema.TeeChart.Drawing 名前空間

名前空間の階層構造

パブリック クラス

TeeBase | チャートエレメントの共通の特性クラス。
Shape | チャートのシェープエレメントの基本クラス。
Graphics3D | 主要のチャート描画エレメントにアクセスします。
Graphics3DVec | 全ベクタイメージ形式の抽象クラス。キーエレメントは、内部ビットマップやUseBuffered = falseです。
Graphics3DVML |
Graphics3DSVG | Graphics3DSVGの概要。
Graphics3DEPS | Postscriptキャンバス。
TextShape | テキストを持つチャートのシェープエレメントの基本クラス。
ChartPen | 共通のチャートペン。
TextShapePosition | シェープのカスタム位置。
Graphics3DPDF | AdobeのPDFキャンバス。
Graphics3DGdiPlus | 主要のチャート描画エレメントにアクセスします。
Shadow | 影を描くためのプロパティ。
Graphics3DXAML |
GraphicsFonts | 使用されたすべてのフォントを保存する抽象クラスです。
GraphicsFont | 個々のフォントの抽象クラスです。
Aspect | チャートのビュー特性を設定します。
PointXYZ | XYZのポイントホルダー
ChartBrush | 共通のチャートブラシ。
GradientStyle |
Gradient | グラデーション特性。
ChartFont | 共通のチャートフォント。
Bevel | ベベル（枠)を表示するためのプロパティ。
ImageBevel | ベベル（枠)を表示するためのプロパティ。
ShapeSize | サイズホルダー。
View3DEvent | 動作に関するAspectの通知クラス。
GraphicsImages | 使用したイメージをすべて保存します。
GraphicsImage | 個々のイメージのプロパティ。
Graphics3DHotSpot | TestCの概要。
Filter |
FilterRegion |
ResizeFilter |
CropFilter |
ZoomFilter |

パブリック インタフェース

IOpenGL
IGLLightsource
IGLPosition

パブリック 構造体

PointDouble | XYポイントホルダー
Point3D | XYZポイントホルダー
Triangle3D | 三角形エレメントホルダー
Triangle2D | 三角形2Dエレメントホルダー
TTFontData |
RGB |

パブリック 列挙体

SurfaceStyle |
CanvasType |
PathGradientMode |
BevelStyles | ベベル（チャート矩形枠）のスタイルを定義します。
ImageMode | イメージの表示特性を定義します。
TextFormat |
TextShapeStyle | テキストを含むシェープのスタイルを定義します。
SmoothStretchOption |

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Drawing 階層構造

System.Object

Steema.TeeChart.Drawing.Filter

Steema.TeeChart.Drawing.ResizeFilter

Steema.TeeChart.Drawing.CropFilter

Steema.TeeChart.Drawing.ZoomFilter

Steema.TeeChart.Drawing.FilterRegion

Steema.TeeChart.Drawing.GraphicsFont

Steema.TeeChart.Drawing.GraphicsImage

Steema.TeeChart.Drawing.PointXYZ

Steema.TeeChart.Drawing.ShapeSize

Steema.TeeChart.TeeEvent

Steema.TeeChart.Drawing.View3DEvent

System.Collections.ArrayList

Steema.TeeChart.Drawing.GraphicsFonts

Steema.TeeChart.Drawing.GraphicsImages

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Aspect

Steema.TeeChart.Drawing.Bevel

Steema.TeeChart.Drawing.ChartBrush

Steema.TeeChart.Drawing.ChartFont

Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Drawing.Gradient

Steema.TeeChart.Drawing.GradientStyle

Steema.TeeChart.Drawing.Graphics3D

Steema.TeeChart.Drawing.Graphics3DGdiPlus

Steema.TeeChart.Drawing.Graphics3DHotSpot

Steema.TeeChart.Drawing.Graphics3DVec

Steema.TeeChart.Drawing.Graphics3DEPS

Steema.TeeChart.Drawing.Graphics3DPDF

Steema.TeeChart.Drawing.Graphics3DSVG

Steema.TeeChart.Drawing.Graphics3DVML

Steema.TeeChart.Drawing.Graphics3DXAML

Steema.TeeChart.Drawing.ImageBevel

Steema.TeeChart.Drawing.Shadow

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.Drawing.TextShapePosition

参照

SteemaTeeChartDrawing 名前空間


Steema.TeeChart.Drawing.Aspect

Steema.TeeChart.Drawing.Aspect クラス

チャートのビュー特性。

この型のすべてのメンバの一覧については、Aspect メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class Aspect : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Aspect 全メンバ

Aspect 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Height3D
Width3D

パブリック メソッド

Assign | Seriesコンポーネントから他のコンポーネントへすべてのプロパティをコピーします。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

ApplyZOrder | Trueの場合、複数の系列を異なる3Dの"Z"（深さ）位置で描画します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Chart3DPercent | Z方向の深さを0から100%のパーセントで取得/設定します。
ClipPoints | Trueの場合、系列ポイントがチャート軸の矩形の外側に表示されないように制限します。
ColorPaletteIndex | チャートで使用されるカラーパレットのインデックスを格納します。
Elevation | 3Dの仰角の角度を取得/設定します。
ElevationFloat | Floatとして3D仰角の角度を取得/設定します。
HorizOffset | ピクセル単位（正あるいは負の値）で水平方向のチャートの移動量を設定します。
OrthoAngle | 直交モード（Orthogonalプロパティがtrue）に設定されている場合、奥軸の傾斜角度を0から90度で設定します。
Orthogonal | Trueの場合、チャートを3Dのように深さを傾斜角度で描画します。
Perspective | 3Dの遠近効果率を設定します。
Rotation | 3D回転の回転角度を取得/設定します。
RotationFloat | Floatとして3D回転の角度を取得/設定します。
SmoothingMode | チャートを作成するための、スピードあるいは描画品質を選択します。
TextRenderingHint | テキストを作成するための、スピードあるいは描画品質を選択します。
ThemeIndex |
Tilt | 3Dモードで、チャートの傾斜角度を度数単位で取得/設定します。
VertOffset | ピクセル単位（正あるいは負の値）で垂直方向のチャートの移動量を設定します。
View3D | 3D描画モードに設定します。
Zoom | 3Dモードで、ズームのパーセント率を取得/設定します。
ZoomText | Trueの場合、すべてのテキストはZoomプロパティによりリサイズされます。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Aspect クラス | Steema.TeeChart.Drawing 名前空間


Aspect コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect コンストラクタ

オーバーロードの一覧

public Aspect()
public Aspect(Steema.TeeChart.Chart)

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Aspect コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect コンストラクタ

public Aspect()

参照

Aspect コンストラクタのオーバーロードの一覧 | Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Aspect コンストラクタ

Steema.TeeChart.Drawing.Aspect コンストラクタ

public Aspect(Chart c)

参照

Aspect コンストラクタのオーバーロードの一覧 | Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Aspect フィールド

パブリック フィールド

Height3D
Width3D

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Aspect クラス | Steema.TeeChart.Drawing 名前空間


Height3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Height3D フィールド

public Int32 Height3D

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Width3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Width3D フィールド

public Int32 Width3D

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Aspect メソッド

パブリック メソッド

Assign | Seriesコンポーネントから他のコンポーネントへすべてのプロパティをコピーします。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Aspect クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.Aspect.Assign メソッド

Seriesコンポーネントから他のコンポーネントへすべてのプロパティをコピーします。
public Void Assign(Aspect a)

解説

Seriesコンポーネントから他のコンポーネントへすべてのプロパティをコピーします。
これは、コピー元とコピー先の共有するプロパティのみコピーされます。

次のコードは、Series2からSeries1にすべてのプロパティをコピーします。

tChart1.Series[0].Assign(tChart1.Series[1]);

一部の系列型は、プロパティを割り当てた後に、プロパティ値を初期化します。 たとえば、リボン系列のPointer.Visibleプロパティのデフォルトはfalseになっていますが、このリボン系列コンポーネントを散布図系列コンポーネントにプロパティをコピーした後は、Pointer.Visibleプロパティはtrueに初期化されます。

メモ：系列のイベントは割り当てられませんが、系列のDataSourceプロパティやFunctionTypeプロパティは割り当てられます。Assignは、たとえばCloneChartSeriesメソッドやChangeSeriesTypeメソッドにより使用されます。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Aspect プロパティ

パブリック プロパティ

ApplyZOrder | Trueの場合、複数の系列を異なる3Dの"Z"（深さ）位置で描画します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Chart3DPercent | Z方向の深さを0から100%のパーセントで取得/設定します。
ClipPoints | Trueの場合、系列ポイントがチャート軸の矩形の外側に表示されないように制限します。
ColorPaletteIndex | チャートで使用されているColorPaletteのインデックスを保持します。
Elevation | 3Dの仰角の角度を取得/設定します。
ElevationFloat | Floatとして3D仰角の角度を取得/設定します。
HorizOffset | ピクセル単位（正あるいは負の値）の水平方向のチャートの移動量を設定します。
OrthoAngle | 直交モード（Orthogonalプロパティがtrue）に設定されている場合、奥軸の傾斜角度を0から90度で設定します。
Orthogonal | Trueの場合、チャートを3Dのように深さを傾斜角度で描画します。
Perspective | 3Dの遠近効果率を設定します。
Rotation | 3D回転の回転角度を取得/設定します。
RotationFloat | Floatとして3D回転の角度を取得/設定します。
SmoothingMode | チャートを作成するための、スピードあるいは描画品質を選択します。
TextRenderingHint | テキストを作成するための、スピードあるいは描画品質を選択します。
ThemeIndex |
Tilt | 3Dモードで、チャートの傾斜角度を度数単位で取得/設定します。
VertOffset | ピクセル単位（正あるいは負の値）の垂直方向のチャートの移動量を設定します。
View3D | 3D描画モードに設定します。
Zoom | 3Dモードで、ズームのパーセント率を取得/設定します。
ZoomText | Trueの場合、すべてのテキストはZoomプロパティによりリサイズされます。

参照

Aspect クラス | Steema.TeeChart.Drawing 名前空間


ApplyZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.ApplyZOrder プロパティ

Trueの場合、複数の系列を異なる3Dの"Z"（深さ）位置で描画します。

public Boolean ApplyZOrder {get; set;}

解説

実行時専用。

同じTChartクラス内に複数の系列が存在する場合、異なるZ位置に描画するかどうか制御します。Falseの場合、すべての系列は同じZ位置に描画されます。

これは、TChart.Aspect.View3Dプロパティがtrueになっているか、同じチャートに1つ以上の系列がある場合にのみ有効です。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Chart3DPercent

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Chart3DPercent プロパティ

Z方向の深さを0から100%のパーセントで取得/設定します。

public Int32 Chart3DPercent {get; set;}

解説

デフォルト値：15

Chart.Aspect.View3Dがtrueの場合、チャートの大きさと深さとのサイズの比率を示します。1から100%までパーセントを指定できます。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


ClipPoints

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.ClipPoints プロパティ

Trueの場合、系列ポイントがチャート軸の矩形の外側に表示されないように制限します。

public Boolean ClipPoints {get; set;}

解説

Trueの場合、系列ポイントがチャート軸の外側に表示されません。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


ColorPaletteIndex

Steema.TeeChart.Drawing.Aspect.ColorPaletteIndex プロパティ

チャートで使用されるカラーパレットのインデックスを格納します。

public Int32 ColorPaletteIndex {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Elevation

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Elevation プロパティ

3Dの仰角の角度を取得/設定します。

public Int32 Elevation {get; set;}

解説

指定した回転角度（0から360度）でチャートの前面を回転させます。大きい値を設定すると、チャートの上部が後ろへ行くように縦方向に回転します。
重要：このプロパティを有効にさせるために、Orthogonalプロパティをfalseに設定しなければなりません。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


ElevationFloat

Steema.TeeChart.Drawing.Aspect.ElevationFloat プロパティ

Floatとして3D仰角の角度を取得/設定します。
public Double ElevationFloat {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


HorizOffset

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.HorizOffset プロパティ

ピクセル単位（正あるいは負の値）の水平方向のチャートの移動量を設定します。

public Int32 HorizOffset {get; set;}

解説

デフォルト値：0
設定された値でチャートの全体を水平方向に移動します。2Dまたは3D直行チャートでは適用されません。正の値はチャートを右に移動し、負の値は左へ移動させます。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


HorizOffsetFloat

Steema.TeeChart.Drawing.Aspect.HorizOffsetFloat プロパティ

水平移動量（正あるいは負）をピクセル単位で取得/設定します。
public Double HorizOffsetFloat {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


OrthoAngle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.OrthoAngle プロパティ

直交モード（Orthogonalプロパティがtrue）に設定されている場合、奥軸の傾斜角度を0から90度で設定します。

public Int32 OrthoAngle {get; set;}

解説

デフォルト値：45

直交モード（Orthogonalプロパティがtrue）に設定されている場合、奥軸の傾斜角度を0から90度で設定します。

例

[C#]
tChart1.Aspect.OrthoAngle = 60;

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間 | Orthogonal


Orthogonal

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Orthogonal プロパティ

Trueの時、チャートを3Dのように深さを傾斜角度で描画します。

public Boolean Orthogonal {get; set;}

解説

デフォルト値：true

チャートを3Dのように深さを傾斜角度で描画します。チャートの下部は、いつも水平方向です。falseでチャートが3Dの場合は、本当の3Dモードで描画されます。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Perspective

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Perspective プロパティ

3Dの遠近効果率を設定します。

public Int32 Perspective {get; set;}

解説

チャートの描画を行う場合に遠近方向（距離）を考慮して、その距離を調整します。

Orthogonalプロパティをfalseに設定しなければなりません。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Rotation

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Rotation プロパティ

3D回転の回転角度を取得/設定します。

public Int32 Rotation {get; set;}

解説

回転角度（0から360度）で前面の回転を設定します。大きい値を設定すると、チャートの右側が後ろへ行くように横方向に回転します。
重要：このプロパティを有効にさせるために、Orthogonalプロパティをfalseに設定しなければなりません。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


RotationFloat

Steema.TeeChart.Drawing.Aspect.RotationFloat プロパティ

Floatとして3D回転の角度を取得/設定します。
public Double RotationFloat {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


SmoothingMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.SmoothingMode プロパティ

チャートを作成するための、スピードあるいは描画品質を選択します。

public SmoothingMode SmoothingMode {get; set;}

解説

チャートを作成するための、スピードあるいは描画品質を選択します。

AntiAlias - アンチエイリアス処理されたレタリングを指定します。
Default - 既定のモードを指定します。
HighQuality - 高品質で低速なレンダリングを指定します。
HighSpeed - 高速で、低品質のレンダリングを指定します。
Invalid - 無効なモードを指定します。
None - アンチエイリアス処理しないことを指定します。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


TextRenderingHint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.TextRenderingHint プロパティ

テキストを作成するための、スピードあるいは描画品質を選択します。

public TextRenderingHint TextRenderingHint {get; set;}

AntiAlias - アンチエイリアス処理されたグリフ ビットマップを使用して、ヒンティングなしに各文字を描画することを指定します。アンチエイリアスによって品質が向上します。ヒンティングがオフにされるため、ステム幅の違いが目立ちます。
AntiAliasGridFit - アンチエイリアス処理されたグリフ ビットマップを使用して、ヒンティングありで各文字を描画することを指定します。アンチエイリアスによってより高い品質が得られますが、パフォーマンスは大きく低下します。
ClearTypeGridFit - グリフ CT ビットマップを使用して、ヒンティングありで各文字を描画することを指定します。最高の品質設定です。ClearType テキスト フォント機能を利用するときに使用します。
SingleBitPerPixel - グリフ ビットマップを使用して、各文字を描画することを指定します。ヒンティングは使用されません。
SingleBitPerPixelGridFit - グリフ ビットマップを使用して、各文字を描画することを指定します。ヒンティングを使用して、文字のステム部分と曲線部分の見た目を向上します。
SystemDefault - グリフ ビットマップを使用し、システムの既定のレンダリング ヒントで各文字を描画することを指定します。ユーザーがシステムで選択した、すべてのフォント スムージング設定を使用してテキストを描画します。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


ThemeIndex

Steema.TeeChart.Drawing.Aspect.ThemeIndex プロパティ

public Int32 ThemeIndex {get; set;}

解説

リスト内の指定したインデックスのテーマのTChartThemeクラスリファレンスを返します。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Tilt

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Tilt プロパティ

3Dモードで、チャートの傾斜角度を度数単位で取得/設定します。

public Int32 Tilt {get; set;}

解説

チャートを傾斜させます。2Dあるいは3Dの直交チャートではサポートされません。

（TChart.Aspect.Orthogonal = falseに設定してください）。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


VertOffset

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.VertOffset プロパティ

ピクセル単位（正あるいは負の値）の垂直方向のチャートの移動量を設定します。

public Int32 VertOffset {get; set;}

解説

デフォルト値：0
設定された値でチャートの全体を垂直方向に移動します。2Dまたは3D直行チャートでは適用されません。正の値はチャートを下に移動し、負の値は上へ移動させます。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


VertOffsetFloat

Steema.TeeChart.Drawing.Aspect.VertOffsetFloat プロパティ

垂直移動量（正あるいは負）をピクセル単位で取得/設定します。
public Double VertOffsetFloat {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


View3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.View3D プロパティ

3D描画モードに設定します。

public Boolean View3D {get; set;}

解説

デフォルト値：true

3D効果をシミュレートして各系列を描画します。Chart.Aspect.Chart3DPercentプロパティを使用して、3Dの比率を制御することができます。Chart.Walls.Visibleは、View3Dプロパティに依存します。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間 | Orthogonal


ZOffset

Steema.TeeChart.Drawing.Aspect.ZOffset プロパティ

public Double ZOffset {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Zoom

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.Zoom プロパティ

3Dモードで、ズームのパーセント率を取得/設定します。

public Int32 Zoom {get; set;}

解説

チャートの全体をズームします。ズームの値を大きくすると、チャート全体を大きく表示します。また、チャート領域内のマウスのドラッグによるズームとは異なります。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間 | View3D


ZoomFloat

Steema.TeeChart.Drawing.Aspect.ZoomFloat プロパティ

3Dモードにおいてズームの割合を取得/設定します。
public Double ZoomFloat {get; set;}

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間 | View3D


ZoomText

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Aspect.ZoomText プロパティ

Trueの場合、すべてのテキストはZoomプロパティによりリサイズされます。

public Boolean ZoomText {get; set;}

解説

デフォルト値：true

falseの場合、テキストサイズはAspect.Zoomプロパティによるズームを無視して一定のままになります。

参照

Aspect クラス | Aspect メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Aspect.TTeeView3DScrolled

Steema.TeeChart.Drawing.Aspect.TTeeView3DScrolled デリゲート

public delegate TTeeView3DScrolled (Boolean IsHoriz)

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Bevel

Steema.TeeChart.Drawing.Bevel クラス

ベベル（枠）を表示するためのプロパティ。

この型のすべてのメンバの一覧については、Bevel メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class Bevel : TeeBase , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Bevel 全メンバ

Bevel 概要

コンストラクタ

Constructor

パブリック メソッド

Assign | 全プロパティをベベルから他のベベルへ割り当てます。
Clone |
Draw | 矩形パラメーターの周りにベベルを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColorOne | ベベルの左側と上側の色を設定します。
ColorTwo | ベベルの右側と下側の色を設定します。
Inner | 内側ベベルのスタイルを取得/設定します。
Outer | 外側ベベルのスタイルを取得/設定します。
Width | ベベルの幅をピクセル単位で取得/設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Bevel クラス | Steema.TeeChart.Drawing 名前空間


Bevel コンストラクタ

Steema.TeeChart.Drawing.Bevel コンストラクタ

public Bevel(Chart c)

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Bevel フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

Bevel クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Bevel メソッド

パブリック メソッド

Assign | 全プロパティをベベルから他のベベルへ割り当てます。
Clone |
Draw | 矩形パラメーターの周りにベベルを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Bevel クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.Bevel.Assign メソッド

すべてのプロパティをBevelから他のBevelへ割り当てます。
public Void Assign(Bevel b)

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.Bevel.Clone メソッド

public virtual Object Clone()

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Bevel.Draw メソッド

矩形パラメーターの周りにベベルを描きます。
public Void Draw(Graphics3D g,
     Rectangle rect)

解説

矩形パラメーターの周りにベベルを描きます。

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Bevel プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColorOne | ベベルの左側と上側の色を設定します。
ColorTwo | ベベルの右側と下側の色を設定します。
Inner | 内側ベベルのスタイルを取得/設定します。
Outer | 外側ベベルのスタイルを取得/設定します。
Width | ベベルの幅をピクセル単位で取得/設定します。

参照

Bevel クラス | Steema.TeeChart.Drawing 名前空間


ColorOne

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Bevel.ColorOne プロパティ

ベベルの左側と上側の色を設定します。

public Color ColorOne {get; set;}

解説

ベベルの左側と上側の色を設定します。ColorTwoプロパティは右側と下側の色を設定します。

例

[C#]

tChart1.Panel.Bevel.ColorOne = System.Drawing.Color.Beige;
tChart1.Panel.Bevel.ColorTwo = System.Drawing.Color.Blue;

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


ColorTwo

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Bevel.ColorTwo プロパティ

ベベルの右側と下側の色を設定します。

public Color ColorTwo {get; set;}

解説

ベベルの右側と下側の色を設定します。ColorOneプロパティは左側と上側の色を設定します。

例

[C#]

tChart1.Panel.Bevel.ColorOne = System.Drawing.Color.Beige;
tChart1.Panel.Bevel.ColorTwo = System.Drawing.Color.Blue;

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Inner

Steema.TeeChart.Drawing.Bevel.Inner プロパティ

内側ベベルのスタイルを取得/設定します。
public BevelStyles Inner {get; set;}

解説

チャートパネルの枠の内側ベベルのスタイルを設定します。

使用可能なスタイル：
None
Lowered
Raised

例

[C#]

tChart1.Panel.Bevel.Inner = Steema.TeeChart.Drawing.BevelStyles.Lowered;

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Outer

Steema.TeeChart.Drawing.Bevel.Outer プロパティ

外側ベベルのスタイルを取得/設定します。
public BevelStyles Outer {get; set;}

解説

チャートパネルの枠の外側ベベルのスタイルを設定します。

使用可能なスタイル：
None
Lowered
Raised

例

[C#]

tChart1.Panel.Bevel.Outer = Steema.TeeChart.Drawing.BevelStyles.Raised;

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Bevel.Width プロパティ

ベベル（TeeChartパネルの枠）の幅をピクセル単位で取得/設定します。
public Int32 Width {get; set;}

解説

ベベル（TeeChartパネルの枠）の幅をピクセル単位で取得/設定します。

例

[C#]

tChart1.Panel.Bevel.Width = 2;

参照

Bevel クラス | Bevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.BevelStyles

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.BevelStyles 列挙体

ベベル（チャート矩形枠）のスタイルを定義します。

[Serializable]
public enum BevelStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | なし
Lowered | 凹
Raised | 凸

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CanvasType

Steema.TeeChart.Drawing.CanvasType 列挙体

[Serializable]
public sealed enum CanvasType : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
GDIplus |
HotSpot |
PDF |
EPS |
SVG |
VML |
XAML |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush

Steema.TeeChart.Drawing.ChartBrush クラス

共通のチャートブラシ。

この型のすべてのメンバの一覧については、ChartBrush メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class ChartBrush : TeeBase , IComponent, IDisposable
, ICloneable

解説

スミス系列を塗りつぶすブラシを定義します。

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush 全メンバ

ChartBrush 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

ClearImage | 関連するすべてのビットマップイメージからChartBrushを削除します。
Clone |
Invalidate | キャンバス全体を再描画する必要がある場合に使用してください。
LoadImage | 指定したパスからChartBrushにビットマップをロードします。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 領域を塗りつぶす色を定義します。
DrawingBrush | 内部的なDrawing.Brushにアクセスします。
ForegroundColor | Solidプロパティがfalseの場合、チャートの前景色を取得/設定します。
Gradient | グラデーション特性について定義します。
GradientVisible |
Image | ブラシ領域のパターンとして表示するイメージを定義します。
ImageMode | 描画するブラシイメージのスタイルを定義します。
ImageTransparent | ブラシイメージを透明に設定します。
Solid | 指定した色で領域を塗りつぶします。ForegroundColorプロパティで指定された色は使用されません。
Style | 領域の塗りつぶし、あるいはパターンのスタイルを定義します。
Transparency | 0～100%までの透明度を設定します。
Visible | Falseの場合、ブラシは空になります。
WrapMode | 描画するブラシイメージのスタイルを定義します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartBrush クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush コンストラクタ

オーバーロードの一覧

public ChartBrush()
public ChartBrush(Steema.TeeChart.Chart, System.Boolean)
public ChartBrush(Steema.TeeChart.Chart)
public ChartBrush(Steema.TeeChart.Chart, System.Drawing.Color)
public ChartBrush(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean)
public ChartBrush(Steema.TeeChart.Chart, System.Drawing.Brush)

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ChartBrush コンストラクタ

Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush()

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ChartBrush コンストラクタ

Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush(Chart c,
     Boolean startVisible)

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ChartBrush コンストラクタ

Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush(Chart c)

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ChartBrush コンストラクタ

Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush(Chart c,
     Color aColor)

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ChartBrush コンストラクタ

Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush(Chart c,
     Color aColor,
     Boolean startVisible)

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush コンストラクタ

public ChartBrush(Chart c,
     Brush brush)

参照

ChartBrush コンストラクタのオーバーロードの一覧 | ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ChartBrush クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush メソッド

パブリック メソッド

ClearImage | 関連するすべてのビットマップイメージからChartBrushを削除します。
Clone |
Invalidate | キャンバス全体を再描画する必要がある場合に使用してください。
LoadImage | 指定したパスからChartBrushにビットマップをロードします。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartBrush クラス | Steema.TeeChart.Drawing 名前空間


ClearImage

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.ClearImage メソッド

関連するすべてのビットマップイメージからChartBrushを削除します。

public Void ClearImage()

解説

関連するすべてのビットマップイメージからChartBrushを削除します。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.ChartBrush.Clone メソッド

public virtual Object Clone()

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Invalidate

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Invalidate メソッド

キャンバス全体を再描画する必要がある場合に使用してください。

public virtual Void Invalidate()

解説

キャンバス全体を再描画する必要がある場合に使用してください。キャンバスを再描画する必要がある領域が複数ある場合、このメソッドは再描画によるチラツキを避けて、キャンバス全体を一度に再描画します。実際に再描画される前に何度もこのメソッドを呼び出しても問題はありません。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


LoadImage

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.LoadImage メソッド

指定したパスからChartBrushにビットマップをロードします。

public Void LoadImage(String fileName)

解説

指定したパスからChartBrushにビットマップをロードします。

例

[C#]

tChart1.Panel.Brush.LoadImage(@"C:\Images\FileName.bmp");

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.ChartBrush.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartBrush プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 領域を塗りつぶす色を定義します。
DrawingBrush | 内部的なDrawing.Brushにアクセスします。
ForegroundColor | Solidプロパティがfalseの場合、チャートの前景色を取得/設定します。
Gradient | グラデーション特性について定義します。
GradientVisible |
Image | ブラシ領域のパターンとして表示するイメージを定義します。
ImageMode | 描画するブラシイメージのスタイルを定義します。
ImageTransparent | ブラシイメージを透明に設定します。
Solid | 指定した色で領域を塗りつぶします。ForegroundColorプロパティで指定された色は使用されません。
Style | 領域の塗りつぶし、あるいはパターンのスタイルを定義します。
Transparency | 0～100%までの透明度を設定します。
Visible | Falseの場合、ブラシは空になります。
WrapMode | 描画するブラシイメージのスタイルを定義します。

参照

ChartBrush クラス | Steema.TeeChart.Drawing 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Color プロパティ

領域を塗りつぶす色を定義します。

public Color Color {get; set;}

解説

領域を塗りつぶす色を定義します。

例

[C#]

tChart1.Panel.Brush.Color = Color.Beige;

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.DrawingBrush プロパティ

内部的なDrawing.Brushをアクセスします。

public Brush DrawingBrush {get;}

読み込み専用

解説

内部的なDrawing.Brushにアクセスします。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ForegroundColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.ForegroundColor プロパティ

Solidプロパティがfalseの場合、チャートの前景色を取得/設定します。

public Color ForegroundColor {get; set;}

解説

チャートの前景色を取得/設定します。

例

[C#]

tChart1.Panel.Brush.Style = System.Drawing.Drawing2D.HatchStyle.Cross;
tChart1.Panel.Brush.ForegroundColor = Color.White;

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Gradient

Steema.TeeChart.Drawing.ChartBrush.Gradient プロパティ

グラデーションについて定義します。
public Gradient Gradient {get; set;}

解説

グラデーションについて定義します。グラデーションは、StartColorプロパティ、MidColorプロパティ、EndColorプロパティを使用して指定した領域を塗りつぶします。Gradient.Directionプロパティの設定により描画出力を制御できます。グラデーション描画を表示/非表示するためにVisibleプロパティを使用してください。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


GradientVisible

Steema.TeeChart.Drawing.ChartBrush.GradientVisible プロパティ

public Boolean GradientVisible {get;}

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Image

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Image プロパティ

ブラシ領域のパターンとして表示するイメージを定義します。

public Image Image {get; set;}

解説

ブラシ領域のパターンとして表示するイメージを定義します。

メモ：WindowsのGDI制限のため、小さいビットマップにしなければなりません。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ImageMode

Steema.TeeChart.Drawing.ChartBrush.ImageMode プロパティ

描画するブラシイメージのスタイルを定義します。
public ImageMode ImageMode {get; set;}

解説

描画するブラシイメージのスタイルを定義します。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


ImageTransparent

Steema.TeeChart.Drawing.ChartBrush.ImageTransparent プロパティ

ブラシイメージを透明に設定します。
public Boolean ImageTransparent {get; set;}

解説

ブラシイメージを透明に設定します。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Solid

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Solid プロパティ

指定した色で領域を塗りつぶします。ForegroundColorプロパティで指定された色は使用されません。

public Boolean Solid {get; set;}

解説

指定した色で領域を塗りつぶします。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Style

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Style プロパティ

領域の塗りつぶし、あるいはパターンのスタイルを定義します。

public HatchStyle Style {get; set;}

解説

描画キャンバス上で領域の塗りつぶし、あるいはパターンのスタイルを定義します。

例

[C#]

tChart1.Panel.Brush.Style = System.Drawing.Drawing2D.HatchStyle.DarkVertical;

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Transparency プロパティ

0～100%までの透明度を設定します。

public Int32 Transparency {get; set;}

解説

0～100%までの透明度を設定します。このプロパティが0の場合、前面のみが表示されます。このプロパティが100の場合、背面のみが表示されます。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.Visible プロパティ

ブラシが線を描くかどうか設定します。Falseの場合、ブラシは空です。

public Boolean Visible {get; set;}

解説

ブラシが線を描くかどうか設定します。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


WrapMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartBrush.WrapMode プロパティ

ChartBrushオブジェクトのラップモードを示すWrapMode列挙体を取得/設定します。

public WrapMode WrapMode {get; set;}

解説

ブラシは、シェープをどのように塗りつぶすかを定義するために、この列挙体を使用します。

参照

ChartBrush クラス | ChartBrush メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont

Steema.TeeChart.Drawing.ChartFont クラス

共通のチャートフォント。

この型のすべてのメンバの一覧については、ChartFont メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class ChartFont : TeeBase , IComponent, IDisposable
, ICloneable

解説

すべてのTeeChartのテキストやフォントの表示特性についてのプロパティを含んでいます。

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont 全メンバ

ChartFont 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone |
Invalidate | キャンバス全体を再描画する必要がある場合に使用してください。
ShouldDrawShadow |

パブリック プロパティ

Bold | テキストのフォントを太字に設定します。
Brush | フォントのブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | テキストのフォントの色を定義します。
DrawingFont |
Gradient | フォントにグラデーションを適用します。
Italic | テキストのフォントの斜体を有効/無効にします。
Name | テキストのフォント型を定義します。
Shadow | フォントの影の特性にアクセスします。
Size | テキストのフォントサイズをポイント単位で設定します。
SizeFloat | Font.Unitを使用できるようにするために、float型のemサイズでテキストのフォントサイズを設定します。
Strikeout | フォントの打ち消し線を有効/無効にします。
Underline | フォントの下線を有効/無効します。
Unit | フォントの大きさの単位を取得/設定します。
UsePrivateFont | ChartFontクラスにTeeChart専用のフォントを含むかどうか設定/返します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartFont クラス | Steema.TeeChart.Drawing 名前空間


ChartFont コンストラクタ

Steema.TeeChart.Drawing.ChartFont コンストラクタ

オーバーロードの一覧

public ChartFont()
public ChartFont(Steema.TeeChart.Chart)

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


ChartFont コンストラクタ

Steema.TeeChart.Drawing.ChartFont コンストラクタ

public ChartFont()

参照

ChartFont コンストラクタのオーバーロードの一覧 | ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


ChartFont コンストラクタ

Steema.TeeChart.Drawing.ChartFont コンストラクタ

public ChartFont(Chart c)

参照

ChartFont コンストラクタのオーバーロードの一覧 | ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont コンストラクタ

public ChartFont(Chart c,
     Font font)

参照

ChartFont コンストラクタのオーバーロードの一覧 | ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ChartFont クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont メソッド

パブリック メソッド

Clone |
Invalidate | キャンバス全体を再描画する必要がある場合に使用してください。
ShouldDrawShadow |

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartFont クラス | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.ChartFont.Clone メソッド

public virtual Object Clone()

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Invalidate

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Invalidate メソッド

キャンバス全体を再描画する必要がある場合に使用してください。

public virtual Void Invalidate()

解説

キャンバス全体を再描画する必要がある場合に使用してください。キャンバスを再描画する必要がある領域が複数ある場合、このメソッドは再描画によるチラツキを避けて、キャンバス全体を一度に再描画します。実際に再描画される前に何度もこのメソッドを呼び出しても問題はありません。

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.ChartFont.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


ShouldDrawShadow

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.ShouldDrawShadow メソッド

public Boolean ShouldDrawShadow()

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartFont プロパティ

パブリック プロパティ

Bold | テキストのフォントを太字に設定します。
Brush | フォントのブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | テキストのフォントの色を定義します。
DrawingFont |
Gradient | フォントにグラデーションを適用します。
Italic | テキストのフォントの斜体を有効/無効にします。
Name | テキストのフォント型を定義します。
Shadow | フォントの影の特性にアクセスします。
Size | テキストのフォントサイズをポイント単位で設定します。
SizeFloat | Font.Unitを使用できるようにするために、float型のemサイズでテキストのフォントサイズを設定します。
Strikeout | フォントの打ち消し線を有効/無効にします。
Underline | フォントの下線を有効/無効します。
Unit | フォントの大きさの単位を取得/設定します。
UsePrivateFont | ChartFontクラスにTeeChart専用のフォントを含むかどうか設定/返します。

参照

ChartFont クラス | Steema.TeeChart.Drawing 名前空間


Bold

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Bold プロパティ

テキストのフォントを太字に設定します。

public Boolean Bold {get; set;}

解説

テキストのフォントを太字に設定します。

例

[C#]

tChart1.Header.Font.Bold =true;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Brush

Steema.TeeChart.Drawing.ChartFont.Brush プロパティ

フォントのブラシ特性を設定します。
public ChartBrush Brush {get;}

解説

フォントのブラシ特性を設定します。

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Color プロパティ

テキストのフォントの色を定義します。

public Color Color {get; set;}

解説

テキストのフォントの色を定義します。

例

[C#]

tChart1.Header.Font.Color = Color.Yellow;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


DrawingFont

Steema.TeeChart.Drawing.ChartFont.DrawingFont プロパティ

public Font DrawingFont {get; set;}

解説

フォントのキャラクタ設定を定義します。フォントのどんな値が有効か定義するために、フォントベンダにより提供された情報を確認してください。

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Gradient

Steema.TeeChart.Drawing.ChartFont.Gradient プロパティ

フォントにグラデーションを適用します。
public Gradient Gradient {get;}

解説

フォントにグラデーションを適用します。

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Italic

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Italic プロパティ

テキストのフォントの斜体を有効/無効にします。

public Boolean Italic {get; set;}

解説

trueの場合、テキストのフォントを斜体に設定します。

例

[C#]

tChart1.Header.Font.Italic = true;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Name

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Name プロパティ

テキストのフォント型を定義します。

public String Name {get; set;}

解説

テキストのフォント型を定義します。

例

[C#]

tChart1.Header.Font.Name = "Times New Roman";

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Shadow

Steema.TeeChart.Drawing.ChartFont.Shadow プロパティ

フォントの影の特性にアクセスします。
public Shadow Shadow {get;}

解説

フォントの影の特性にアクセスします。

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Size

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Size プロパティ

テキストのフォントサイズをポイント単位で設定します。

public Int32 Size {get; set;}

解説

テキストのフォントサイズをポイント単位で設定します（タイトル、ラベル、など）。キャンバスにカスタムなテキストのサイズを定義する場合、Font.Heightプロパティを使用してください。

例

[C#]

tChart1.Header.Font.Size = 12;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


SizeFloat

Steema.TeeChart.Drawing.ChartFont.SizeFloat プロパティ

Font.Unitを使用できるようにするために、float型のemサイズでテキストのフォントサイズを設定します。
public Single SizeFloat {get; set;}

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Strikeout

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Strikeout プロパティ

フォントの打ち消し線を有効/無効にします。

public Boolean Strikeout {get; set;}

解説

フォントの打ち消し線を有効/無効にします。

例

[C#]

tChart1.Header.Font.Strikeout = true;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Underline

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartFont.Underline プロパティ

フォントの下線を有効/無効にします。

public Boolean Underline {get; set;}

解説

フォントの下線を有効/無効にします。

例

[C#]

tChart1.Header.Font.Underline = true;

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Unit

Steema.TeeChart.Drawing.ChartFont.Unit プロパティ

フォントの大きさの単位を取得/設定します。
public GraphicsUnit Unit {get; set;}

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


UsePrivateFont

Steema.TeeChart.Drawing.ChartFont.UsePrivateFont プロパティ

ChartFontクラスにTeeChart専用のフォントを含むかどうか設定/返します。
public Boolean UsePrivateFont {get; set;}

参照

ChartFont クラス | ChartFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen

Steema.TeeChart.Drawing.ChartPen クラス

共通のチャートペン。

この型のすべてのメンバの一覧については、ChartPen メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class ChartPen : TeeBase , IComponent
, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen 全メンバ

ChartPen 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Assign |
Clone |
CreateNewChartPen | 新しいChartPenオブジェクトを作成して、Chartプロパティを設定します。
Invalidate |
NewFromType | 既存のChartPenオブジェクトのSystem.Typeから新しいChartPenオブジェクトを作成します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 描画上で線を描くペンの色を設定します。
DashCap | 点線の各セグメントの終了スタイルを設定します。
DashPattern |
DrawingPen | 内部的なDrawing.Penプロパティにアクセスします。
EndCap | 線の終了スタイルを設定します。
Style | キャンバス上に線を描くペンのスタイルを設定します。
Transparency | 0～100%までの透明度を設定します。
Visible | ペンが描く線を表示/非表示にします。
Width | ペンが描く線の幅を設定します。

プロテクト フィールド

bVisible
cColor
defaultColor
defaultEndCap
defaultVisible
handle
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor
ShouldSerializeDashPattern
ShouldSerializeEndCap
ShouldSerializeStyle
ShouldSerializeVisible

参照

ChartPen クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen コンストラクタ

オーバーロードの一覧

public ChartPen()
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean)
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Pen)
public ChartPen(Steema.TeeChart.Chart)
public ChartPen(System.Drawing.Color)
public ChartPen(Steema.TeeChart.Chart, System.Boolean)
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color)
public ChartPen(Steema.TeeChart.Chart, System.Drawing.Color, System.Boolean, System.Drawing.Drawing2D.LineCap)

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen()

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c,
     Color startColor,
     Boolean startVisible)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c,
     Pen pen)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Color c)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c,
     Boolean startVisible)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c,
     Color startColor)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ChartPen コンストラクタ

Steema.TeeChart.Drawing.ChartPen コンストラクタ

public ChartPen(Chart c,
     Color startColor,
     Boolean startVisible,
     LineCap cap)

参照

ChartPen コンストラクタのオーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen フィールド

プロテクト フィールド

bVisible
cColor
custom
defaultColor
defaultEndCap
defaultVisible
handle
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

ChartPen クラス | Steema.TeeChart.Drawing 名前空間


bVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.bVisible フィールド

protected internal Boolean bVisible

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


cColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.cColor フィールド

protected Color cColor

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


custom

Steema.TeeChart.Drawing.ChartPen.custom フィールド

protected Pen custom

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


defaultColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.defaultColor フィールド

protected internal Color defaultColor

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


defaultEndCap

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.defaultEndCap フィールド

protected internal LineCap defaultEndCap

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


defaultVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.defaultVisible フィールド

protected internal Boolean defaultVisible

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


handle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.handle フィールド

protected Pen handle

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen メソッド

パブリック メソッド

Assign |
Clone |
CreateNewChartPen | 新しいChartPenオブジェクトを作成して、Chartプロパティを設定します。
Invalidate |
NewFromType | 既存のChartPenオブジェクトのSystem.Typeから新しいChartPenオブジェクトを作成します。

プロテクト メソッド

AssignPen
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeColor
ShouldSerializeDashPattern
ShouldSerializeEndCap
ShouldSerializeStyle
ShouldSerializeVisible

参照

ChartPen クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.ChartPen.Assign メソッド

オーバーロードの一覧

public Void Assign(Steema.TeeChart.Drawing.ChartPen)
public Void Assign(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Color)

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.ChartPen.Assign メソッド

public Void Assign(ChartPen p)

参照

Assign オーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.ChartPen.Assign メソッド

public Void Assign(ChartPen p,
     Color AColor)

参照

Assign オーバーロードの一覧 | ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


AssignPen

Steema.TeeChart.Drawing.ChartPen.AssignPen メソッド

protected abstract Void AssignPen(ChartPen p)

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.ChartPen.Clone メソッド

public virtual Object Clone()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


CreateNewChartPen

Steema.TeeChart.Drawing.ChartPen.CreateNewChartPen メソッド

新しいChartPenオブジェクトを作成して、Chartプロパティを設定します。
public static ChartPen CreateNewChartPen(Chart chart,
     Type type)

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Invalidate

Steema.TeeChart.Drawing.ChartPen.Invalidate メソッド

public override Void Invalidate()

解説

キャンバス全体を再描画する必要がある場合、このメソッドを使用します。キャンバス内の複数領域を再描画する必要がある場合、このメソッドはチラツキを避けるために、ウィンドウ全体を一度に再描画させます。実際に再描画される前にこのメソッドを何度呼び出しても構いません。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


NewFromType

Steema.TeeChart.Drawing.ChartPen.NewFromType メソッド

既存のChartPenオブジェクトのSystem.Typeから新しいChartPenオブジェクトを作成します。
public static ChartPen NewFromType(Type type)

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.ShouldSerializeColor メソッド

protected virtual Boolean ShouldSerializeColor()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeDashPattern

Steema.TeeChart.Drawing.ChartPen.ShouldSerializeDashPattern メソッド

protected Boolean ShouldSerializeDashPattern()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeEndCap

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.ShouldSerializeEndCap メソッド

protected Boolean ShouldSerializeEndCap()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeStyle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.ShouldSerializeStyle メソッド

protected virtual Boolean ShouldSerializeStyle()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.ShouldSerializeVisible メソッド

protected virtual Boolean ShouldSerializeVisible()

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ChartPen プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 描画上で線を描くペンの色を設定します。
DashCap | 点線の各セグメントの終了スタイルを設定します。
DashPattern |
DrawingPen | 内部的なDrawing.Penプロパティにアクセスします。
EndCap | 線の終了スタイルを設定します。
Style | キャンバス上に線を描くペンのスタイルを設定します。
Transparency | 0～100%までの透明度を設定します。
Visible | ペンが描く線を表示/非表示にします。
Width | ペンが描く線の幅を設定します。

参照

ChartPen クラス | Steema.TeeChart.Drawing 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.Color プロパティ

描画上で線を描くペンの色を設定します。

public Color Color {get; set;}

解説

描画上で線を描くペンが使用する色を設定します。

このプロパティは、Color.Red、Color.Greenなどのような.NETの色定数が使用できます。
TeeChart独自の特別な色定数はclTeeColorです。これは｢デフォルト色｣です。

各TeeChartの描画オブジェクトには、異なるデフォルト色があります。例えば、tChart.FrameプロパティにはColor.Blackのデフォルト色があります。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


DashCap

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.DashCap プロパティ

点線の各セグメントの終了スタイルを設定します。

public DashCap DashCap {get; set;}

解説

点線の各セグメントの終了スタイルを設定します。

例

[C#]

private void tChart1_AfterDraw_1(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Pen.DashCap = System.Drawing.Drawing2D.DashCap.Triangle;
}

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


DashPattern

Steema.TeeChart.Drawing.ChartPen.DashPattern プロパティ

public Single[] DashPattern {get; set;}

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


DrawingPen

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.DrawingPen プロパティ

内部的なDrawing.Penプロパティにアクセスします。

public Pen DrawingPen {get;}

読み込み専用

解説

内部的なDrawing.Penプロパティにアクセスします。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


EndCap

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.EndCap プロパティ

線の終了スタイルを設定します。

public LineCap EndCap {get; set;}

解説

線の終了スタイルを設定します。

例

[C#]

private void tChart1_AfterDraw_1(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{

     g.Pen.EndCap = System.Drawing.Drawing2D.LineCap.RoundAnchor;

     g.Line(g.Chart.ChartBounds.Left+50,g.Chart.ChartBounds.Top+50,
        g.Chart.ChartBounds.Right-50,g.Chart.ChartBounds.Bottom-50);

}

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Style

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.Style プロパティ

キャンパス上に線を描くペンのスタイルを設定します。

public virtual DashStyle Style {get; set;}

解説

キャンパス上に線を描くペンのスタイルを設定します。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.Transparency プロパティ

0～100%までの透明度を設定します。

public Int32 Transparency {get; set;}

解説

0～100%までの透明度を設定します。このプロパティが0の場合、前面のみが表示されます。このプロパティが100の場合、背面のみが表示されます。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.Visible プロパティ

ペンが描く線を表示/非表示にします。

public Boolean Visible {get; set;}

解説

ペンが描く線を表示/非表示にします。

例

[C#]
tChart.Frameは、Visibleプロパティをfalseに設定することで表示にできます。

fChart1.Frame.Visible = false;

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ChartPen.Width プロパティ

ペンが描く線の幅を設定します。

public virtual Int32 Width {get; set;}

解説

ペンが描く線の幅を設定します。

参照

ChartPen クラス | ChartPen メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter

Steema.TeeChart.Drawing.CropFilter クラス

この型のすべてのメンバの一覧については、CropFilter メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.Filter
Steema.TeeChart.Drawing.ResizeFilter
public class CropFilter : ResizeFilter

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter 全メンバ

CropFilter 概要

コンストラクタ

Constructor

パブリック フィールド

Lines (Filterの継承元)

パブリック メソッド

Apply

パブリック プロパティ

Enabled (Filterの継承元)
Height (ResizeFilterの継承元)
Left
Region (Filterの継承元)
Smooth
Top
Width (ResizeFilterの継承元)

プロテクト フィールド

AllowRegion (Filterの継承元)

プロテクト メソッド

CalcLines (Filterの継承元)

参照

CropFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter コンストラクタ

public CropFilter()

参照

CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter フィールド

パブリック フィールド

Lines (Filterの継承元)

プロテクト フィールド

AllowRegion (Filterの継承元)

参照

CropFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter メソッド

パブリック メソッド

Apply

プロテクト メソッド

CalcLines (Filterの継承元)

参照

CropFilter クラス | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.CropFilter.Apply メソッド

オーバーロードの一覧

public override Void Apply(System.Drawing.Bitmap&, System.Drawing.Rectangle)

参照

CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.CropFilter.Apply メソッド

public override Void Apply(Bitmap& bitmap,
     Rectangle rect)

参照

Apply オーバーロードの一覧 | CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.CropFilter プロパティ

パブリック プロパティ

Enabled (Filterの継承元)
Height (ResizeFilterの継承元)
Left
Region (Filterの継承元)
Smooth
Top
Width (ResizeFilterの継承元)

参照

CropFilter クラス | Steema.TeeChart.Drawing 名前空間


Left

Steema.TeeChart.Drawing.CropFilter.Left プロパティ

public Int32 Left {get; set;}

参照

CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Smooth

Steema.TeeChart.Drawing.CropFilter.Smooth プロパティ

public Boolean Smooth {get; set;}

参照

CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Top

Steema.TeeChart.Drawing.CropFilter.Top プロパティ

public Int32 Top {get; set;}

参照

CropFilter クラス | CropFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.EdgeStyles

Steema.TeeChart.Drawing.EdgeStyles 列挙体

隣接するサーフェスとサーフェスの間の縁のスタイルを定義します。
[Serializable]
public sealed enum EdgeStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Flat | 平ら
Curved | 曲線
None | 特別な縁処理なし

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter

Steema.TeeChart.Drawing.Filter クラス

この型のすべてのメンバの一覧については、Filter メンバを参照してください。

System.Object
public class Filter : Object

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Filter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter 全メンバ

Filter 概要

コンストラクタ

Constructor

パブリック フィールド

Lines

パブリック メソッド

Apply
ApplyTo
BlendBitmaps
SmoothBitmap
SmoothStretch

パブリック プロパティ

Enabled
Region

プロテクト フィールド

AllowRegion

プロテクト メソッド

CalcLines

参照

Filter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter コンストラクタ

public Filter()

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter フィールド

パブリック フィールド

Lines

プロテクト フィールド

AllowRegion

参照

Filter クラス | Steema.TeeChart.Drawing 名前空間


AllowRegion

Steema.TeeChart.Drawing.Filter.AllowRegion フィールド

protected Boolean AllowRegion

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Lines

Steema.TeeChart.Drawing.Filter.Lines フィールド

public RGB[] Lines

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter メソッド

パブリック メソッド

Apply
ApplyTo
BlendBitmaps
SmoothBitmap
SmoothStretch

プロテクト メソッド

CalcLines

参照

Filter クラス | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.Filter.Apply メソッド

オーバーロードの一覧

public Void Apply(System.Drawing.Bitmap&)
public abstract Void Apply(System.Drawing.Bitmap&, System.Drawing.Rectangle)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.Filter.Apply メソッド

public Void Apply(Bitmap& bitmap)

参照

Apply オーバーロードの一覧 | Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.Filter.Apply メソッド

public abstract Void Apply(Bitmap& bitmap,
     Rectangle rect)

参照

Apply オーバーロードの一覧 | Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


ApplyTo

Steema.TeeChart.Drawing.Filter.ApplyTo メソッド

public static Void ApplyTo(Bitmap& bitmap)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


BlendBitmaps

Steema.TeeChart.Drawing.Filter.BlendBitmaps メソッド

public static Bitmap BlendBitmaps(Double percent,
     Bitmap source,
     Bitmap destination,
     Point origin)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


CalcLines

Steema.TeeChart.Drawing.Filter.CalcLines メソッド

protected Void CalcLines(Bitmap bitmap)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


ColorToHLS

Steema.TeeChart.Drawing.Filter.ColorToHLS メソッド

public static Void ColorToHLS(Color c,
     Single& Hue,
     Single& Luminance,
     Single& Saturation)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


HLSToColor

Steema.TeeChart.Drawing.Filter.HLSToColor メソッド

public static Color HLSToColor(Single H,
     Single L,
     Single S)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


SmoothBitmap

Steema.TeeChart.Drawing.Filter.SmoothBitmap メソッド

public static Bitmap SmoothBitmap(Bitmap bitmap,
     Int32 width,
     Int32 height)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


SmoothStretch

Steema.TeeChart.Drawing.Filter.SmoothStretch メソッド

オーバーロードの一覧

public static Void SmoothStretch(System.Drawing.Bitmap, System.Drawing.Bitmap&)
public static Void SmoothStretch(System.Drawing.Bitmap, System.Drawing.Bitmap&, Steema.TeeChart.Drawing.SmoothStretchOption)

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


SmoothStretch

Steema.TeeChart.Drawing.Filter.SmoothStretch メソッド

public static Void SmoothStretch(Bitmap src,
     Bitmap& dst)

参照

SmoothStretch オーバーロードの一覧 | Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


SmoothStretch

Steema.TeeChart.Drawing.Filter.SmoothStretch メソッド

public static Void SmoothStretch(Bitmap src,
     Bitmap& dst,
     SmoothStretchOption option)

参照

SmoothStretch オーバーロードの一覧 | Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Filter プロパティ

パブリック プロパティ

Enabled
Region

参照

Filter クラス | Steema.TeeChart.Drawing 名前空間


Enabled

Steema.TeeChart.Drawing.Filter.Enabled プロパティ

public Boolean Enabled {get; set;}

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Region

Steema.TeeChart.Drawing.Filter.Region プロパティ

public FilterRegion Region {get; set;}

参照

Filter クラス | Filter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.FilterRegion

Steema.TeeChart.Drawing.FilterRegion クラス

この型のすべてのメンバの一覧については、FilterRegion メンバを参照してください。

System.Object
public class FilterRegion : Object

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.FilterRegion 全メンバ

FilterRegion 概要

コンストラクタ

Constructor

パブリック メソッド

SetRectangle

パブリック プロパティ

Height
Left
Top
Width

参照

FilterRegion クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.FilterRegion コンストラクタ

public FilterRegion()

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.FilterRegion メソッド

パブリック メソッド

SetRectangle

参照

FilterRegion クラス | Steema.TeeChart.Drawing 名前空間


SetRectangle

Steema.TeeChart.Drawing.FilterRegion.SetRectangle メソッド

public Void SetRectangle(Rectangle rect)

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.FilterRegion プロパティ

パブリック プロパティ

Height
Left
Top
Width

参照

FilterRegion クラス | Steema.TeeChart.Drawing 名前空間


Height

Steema.TeeChart.Drawing.FilterRegion.Height プロパティ

public Int32 Height {get; set;}

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Left

Steema.TeeChart.Drawing.FilterRegion.Left プロパティ

public Int32 Left {get; set;}

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Top

Steema.TeeChart.Drawing.FilterRegion.Top プロパティ

public Int32 Top {get; set;}

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Width

Steema.TeeChart.Drawing.FilterRegion.Width プロパティ

public Int32 Width {get; set;}

参照

FilterRegion クラス | FilterRegion メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Gradient

Steema.TeeChart.Drawing.Gradient クラス

グラデーション特性。

この型のすべてのメンバの一覧については、Gradient メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Gradient : TeeBase , IComponent, IDisposable, ICloneable

解説

Gradientクラスは、さまざまなオブジェクトを色で塗りつぶします。オブジェクトはチャートパネル、凡例、バー系列、タイトル、マーカ、背面などのようなGradientクラスを含みます。

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Gradient 全メンバ

Gradient 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Assign | Gradientパラメーター特性をCanvas.Gradientオブジェクトにコピーします。
Clone |
Draw | グラデーションの色や方向の特性を使用してキャンバス領域を塗りつぶします。
DrawingBrush | 指定したpパラメーターの領域を塗りつぶすブラシを設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Angle | グラデーションの角度を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomTargetRectangle | グラデーションにカスタムな矩形を定義するために、このプロパティに矩形を割り当ててください。
Direction | グラデーションの塗りつぶしが適用される方向を指定します。
EndColor | グラデーションの終了色を設定します。
ExtendedColorPalette | グラデーションに3色（開始色、中央色、終了色）以上の色を使用するために、このプロパティに色配列を設定してください。
GammaCorrection | 表示される色のガンマ補正を有効/無効にします。
MiddleColor | グラデーションの中央色を設定します。
Sigma | SigmaFocusプロパティやSigmaScaleプロパティの使用を有効にします。
SigmaFocus | 開始色と終了色との比率を取得/設定します。
SigmaScale | 0から1までの色の比率を取得/設定します。
StartColor | グラデーションの開始色を設定します。
Style | グラデーションの塗りつぶしが適用される方向を指定します。
Transparency | 透明度をパーセント単位で取得/設定します。
UseMiddle | グラデーション描画をする際にMiddleColorプロパティを使用するかどうか設定します。
Visible | 画面上のグラデーション描画を有効/無効にします。
WrapMode | 塗りつぶしを繰り返すために、多角形のグラデーションにのみ使用されます。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeCustomTargetRectangle
ShouldSerializeDirection
ShouldSerializeEndColor
ShouldSerializeExtendedColorPalette
ShouldSerializeMiddleColor
ShouldSerializeStartColor
ShouldSerializeUseMiddle
ShouldSerializeVisible

参照

Gradient クラス | Steema.TeeChart.Drawing 名前空間


Gradient コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient コンストラクタ

オーバーロードの一覧

public Gradient()
public Gradient(Steema.TeeChart.Chart)

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Gradient コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient コンストラクタ

public Gradient()

参照

Gradient コンストラクタのオーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Gradient コンストラクタ

Steema.TeeChart.Drawing.Gradient コンストラクタ

public Gradient(Chart c)

参照

Gradient コンストラクタのオーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Gradient フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Gradient クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Gradient メソッド

パブリック メソッド

Assign | Gradientパラメーター特性をCanvas.Gradientオブジェクトにコピーします。
Clone |
Draw | グラデーションの色や方向の特性を使用してキャンバス領域を塗りつぶします。
DrawingBrush | 指定したpパラメーターの領域を塗りつぶすブラシを設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeCustomTargetRectangle
ShouldSerializeDirection
ShouldSerializeEndColor
ShouldSerializeExtendedColorPalette
ShouldSerializeMiddleColor
ShouldSerializeStartColor
ShouldSerializeUseMiddle
ShouldSerializeVisible

参照

Gradient クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.Gradient.Assign メソッド

public Void Assign(Gradient value)

解説

Canvas.GradientオブジェクトにGradientパラメータ特性をコピーします。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.Gradient.Clone メソッド

public virtual Object Clone()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.Draw メソッド

オーバーロードの一覧

グラデーションの色や方向を使用してキャンバス領域を塗りつぶします。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Int32, System.Int32)

グラデーションの色や方向を使用してキャンバス領域を塗りつぶします。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Point[])

グラデーションの色や方向を使用してキャンバス領域を塗りつぶします。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

解説

グラデーションの色や方向の特性を使用して、Rectパラメーターで定義されたキャンバス領域を塗りつぶします。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Gradient.Draw メソッド

グラデーションの色や方向を使用してキャンバス領域を塗りつぶします。
public Void Draw(Graphics3D g,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

Draw オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Gradient.Draw メソッド

グラデーションの色や方向の特性を使用してキャンバス領域を塗りつぶします。
public Void Draw(Graphics3D g,
     Point[] p)

参照

Draw オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Gradient.Draw メソッド

グラデーションの色や方向の特性を使用してキャンバス領域を塗りつぶします。
public Void Draw(Graphics3D g,
     Rectangle rect)

参照

Draw オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush メソッド

オーバーロードの一覧

指定したpパラメーターの領域を塗りつぶすブラシを設定します。

public Brush DrawingBrush(System.Drawing.Point[])

「size」正方形のブラシを定義するために、x,yポイント座標を使用します。

public Brush DrawingBrush(System.Drawing.Size)
public Brush DrawingBrush(System.Drawing.RectangleF)

指定したrectパラメーターの矩形領域を塗りつぶすブラシを設定します。

public Brush DrawingBrush(System.Drawing.Rectangle)

解説

領域を塗りつぶすブラシを設定します。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush メソッド

指定したpパラメーターの領域を塗りつぶすブラシを設定します。
public Brush DrawingBrush(Point[] p)

参照

DrawingBrush オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush メソッド

「size」正方形のブラシを定義するために、x,yポイント座標を使用します。
public Brush DrawingBrush(Size size)

参照

DrawingBrush オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush メソッド

public Brush DrawingBrush(RectangleF rect)

参照

DrawingBrush オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


DrawingBrush

Steema.TeeChart.Drawing.Gradient.DrawingBrush メソッド

指定したrectパラメーターの矩形領域を塗りつぶすブラシを設定します。

public Brush DrawingBrush(Rectangle rect)

参照

DrawingBrush オーバーロードの一覧 | Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeCustomTargetPolygon

Steema.TeeChart.Drawing.Gradient.ShouldSerializeCustomTargetPolygon メソッド

protected abstract Boolean ShouldSerializeCustomTargetPolygon()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeCustomTargetRectangle

Steema.TeeChart.Drawing.Gradient.ShouldSerializeCustomTargetRectangle メソッド

protected abstract Boolean ShouldSerializeCustomTargetRectangle()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeDirection

Steema.TeeChart.Drawing.Gradient.ShouldSerializeDirection メソッド

protected abstract Boolean ShouldSerializeDirection()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeEndColor

Steema.TeeChart.Drawing.Gradient.ShouldSerializeEndColor メソッド

protected abstract Boolean ShouldSerializeEndColor()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeExtendedColorPalette

Steema.TeeChart.Drawing.Gradient.ShouldSerializeExtendedColorPalette メソッド

protected abstract Boolean ShouldSerializeExtendedColorPalette()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeMiddleColor

Steema.TeeChart.Drawing.Gradient.ShouldSerializeMiddleColor メソッド

protected abstract Boolean ShouldSerializeMiddleColor()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeStartColor

Steema.TeeChart.Drawing.Gradient.ShouldSerializeStartColor メソッド

protected abstract Boolean ShouldSerializeStartColor()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeUseMiddle

Steema.TeeChart.Drawing.Gradient.ShouldSerializeUseMiddle メソッド

protected abstract Boolean ShouldSerializeUseMiddle()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeVisible

Steema.TeeChart.Drawing.Gradient.ShouldSerializeVisible メソッド

protected abstract Boolean ShouldSerializeVisible()

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Gradient プロパティ

パブリック プロパティ

Angle | グラデーションの角度を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomTargetRectangle | グラデーションにカスタムな矩形を定義するために、このプロパティに矩形を割り当ててください。
Direction | グラデーションの塗りつぶしが適用される方向を指定します。
EndColor | グラデーションの終了色を設定します。
ExtendedColorPalette | グラデーションに3色（開始色、中央色、終了色）以上の色を使用するために、このプロパティに色配列を設定してください。
GammaCorrection | 表示される色のガンマ補正を有効/無効にします。
MiddleColor | グラデーションの中央色を設定します。
Sigma | SigmaFocusプロパティやSigmaScaleプロパティの使用を有効にします。
SigmaFocus | 開始色と終了色との比率を取得/設定します。
SigmaScale | 0から1までの色の比率を取得/設定します。
StartColor | グラデーションの開始色を設定します。
Style | グラデーションの塗りつぶしが適用される方向を指定します。
Transparency | 透明度をパーセント単位で取得/設定します。
UseMiddle | グラデーション描画をする際にMiddleColorプロパティを使用するかどうか設定します。
Visible | 画面上のグラデーション描画を有効/無効にします。
WrapMode | 塗りつぶしを繰り返すために、多角形のグラデーションにのみ使用されます。

参照

Gradient クラス | Steema.TeeChart.Drawing 名前空間


Angle

Steema.TeeChart.Drawing.Gradient.Angle プロパティ

描画されているグラデーションの角度の微調整をします。
public Double Angle {get; set;}

解説

描画されているグラデーションの角度の微調整をします。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


CustomTargetPolygon

Steema.TeeChart.Drawing.Gradient.CustomTargetPolygon プロパティ

グラデーションにカスタムな矩形を定義するために、このプロパティに矩形を割り当ててください。
public Point[] CustomTargetPolygon {get; set;}

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


CustomTargetRectangle

Steema.TeeChart.Drawing.Gradient.CustomTargetRectangle プロパティ

グラデーションにカスタムな矩形を定義するために、このプロパティに矩形を割り当ててください。
public Rectangle CustomTargetRectangle {get; set;}

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Direction

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.Direction プロパティ

グラデーションの塗りつぶしが適用される方向を指定します。

public LinearGradientMode Direction {get; set;}

解説

デフォルト値：TopBottom

グラデーションの塗りつぶしが適用される方向を指定します。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


EndColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.EndColor プロパティ

グラデーションの終了色を設定します。

public Color EndColor {get; set;}

解説

デフォルト値：Yellow

グラデーションの終了色を設定します。グラデーションはStartColorプロパティ、MidColorプロパティ、EndColorプロパティの3色から構成されます。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


ExtendedColorPalette

Steema.TeeChart.Drawing.Gradient.ExtendedColorPalette プロパティ

グラデーションに3色（開始色、中央色、終了色）以上の色を使用するために、このプロパティに色配列を設定してください。
public Color[] ExtendedColorPalette {get; set;}

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


GammaCorrection

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.GammaCorrection プロパティ

表示される色のガンマ補正を有効/無効にします。

public Boolean GammaCorrection {get; set;}

解説

表示される色のガンマ補正を有効/無効にします。trueの場合、全体的な明るさや色の彩度を調整します。

例

[C#]

tChart1.Panel.Brush.Gradient.EndColor = Color.LemonChiffon;
tChart1.Panel.Brush.Gradient.GammaCorrection = true;
tChart1.Panel.Brush.Gradient.Sigma = true;
tChart1.Panel.Brush.Gradient.SigmaFocus = 0.741F;
tChart1.Panel.Brush.Gradient.StartColor = Color.CornflowerBlue;
tChart1.Panel.Brush.Gradient.Visible = true;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


MiddleColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.MiddleColor プロパティ

グラデーションの中央色を設定します。

public Color MiddleColor {get; set;}

解説

デフォルト値：None

グラデーションの中央色を設定します。グラデーションはStartColorプロパティ、MidColorプロパティ、EndColorプロパティの3色から構成されます。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Sigma

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.Sigma プロパティ

SigmaFocusプロパティやSigmaScaleプロパティの使用を有効にします。

public Boolean Sigma {get; set;}

解説

中央色としてEndColorプロパティおよび境界部分にStartColorプロパティを使用するベル型曲線に基づいたグラデーションを有効にします。

例

[C#]

tChart1.Panel.Brush.Gradient.EndColor = Color.LemonChiffon;
tChart1.Panel.Brush.Gradient.GammaCorrection = true;
tChart1.Panel.Brush.Gradient.Sigma = true;
tChart1.Panel.Brush.Gradient.SigmaFocus = 0.741F;
tChart1.Panel.Brush.Gradient.StartColor = Color.CornflowerBlue;
tChart1.Panel.Brush.Gradient.Visible = true;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


SigmaFocus

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.SigmaFocus プロパティ

開始色と終了色との比率を取得/設定します。

public Single SigmaFocus {get; set;}

解説

デフォルト値：0.5F

OFから1Fまでの値を設定することにより、どこに中央色を強くするかを定義します。0.5Fの値は、オブジェクトの中央に配置します。

例

[C#]

tChart1.Panel.Brush.Gradient.EndColor = Color.LemonChiffon;
tChart1.Panel.Brush.Gradient.GammaCorrection = true;
tChart1.Panel.Brush.Gradient.Sigma = true;
tChart1.Panel.Brush.Gradient.SigmaFocus = 0.741F;
tChart1.Panel.Brush.Gradient.StartColor = Color.CornflowerBlue;
tChart1.Panel.Brush.Gradient.Visible = true;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


SigmaScale

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.SigmaScale プロパティ

0から1までの色の比率を取得/設定します。

public Single SigmaScale {get; set;}

解説

デフォルト値：1F

0Fから1Fまでの値を設定することにより、中央色の輝度を定義できます。1Fの値は最大輝度の設定をします。

例

[C#]

tChart1.Panel.Brush.Gradient.EndColor = Color.LemonChiffon;
tChart1.Panel.Brush.Gradient.GammaCorrection = true;
tChart1.Panel.Brush.Gradient.Sigma = true;
tChart1.Panel.Brush.Gradient.SigmaFocus = 0.741F;
tChart1.Panel.Brush.Gradient.SigmaScale = 0.8F;
tChart1.Panel.Brush.Gradient.StartColor = Color.CornflowerBlue;
tChart1.Panel.Brush.Gradient.Visible = true;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


StartColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.StartColor プロパティ

グラデーションの開始色を設定します。

public Color StartColor {get; set;}

解説

デフォルト値：White

グラデーションの開始色を設定します。グラデーションはStartColorプロパティ、MidColorプロパティ、EndColorプロパティの3色から構成されます。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Style

Steema.TeeChart.Drawing.Gradient.Style プロパティ

グラデーションの塗りつぶしが適用される方向を指定します。
public GradientStyle Style {get; set;}

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

Steema.TeeChart.Drawing.Gradient.Transparency プロパティ

透明度をパーセント単位で取得/設定します。
public Int32 Transparency {get; set;}

解説

パーセント単位でグラデーションの透明度を取得/設定します。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


UseMiddle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.UseMiddle プロパティ

グラデーション描画をする際にMiddleColorプロパティを使用するかどうか設定します。

public Boolean UseMiddle {get; set;}

解説

デフォルト値：false

グラデーション描画をする際にMiddleColorプロパティを使用するかどうか設定します。

例

[C#]

tChart1.Panel.Gradient.UseMiddle = true;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.Visible プロパティ

画面上のグラデーション描画を有効/無効にします。

public Boolean Visible {get; set;}

解説

デフォルト値：false

画面上のグラデーション描画を有効/無効にします。

例

[C#]

以下のコードがグラデーションの塗りつぶしを作成します。

System.Drawing.Drawing2D;を使用

tChart1.Panel.Gradient.Visible = true;
tChart1.Panel.Gradient.Direction = LinearGradientMode.BackwardDiagonal;
tChart1.Panel.Gradient.StartColor = Color.Red;
tChart1.Panel.Gradient.MiddleColor =  Color.White;
tChart1.Panel.Gradient.EndColor = Color.Blue;

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


WrapMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Gradient.WrapMode プロパティ

塗りつぶしを繰り返すために、多角形のグラデーションにのみ使用されます。

public WrapMode WrapMode {get; set;}

解説

ブラシは、どのようにシェープを塗りつぶすかを定義するためにこの列挙体を使用します。
塗りつぶしを繰り返すために、多角形のグラデーションにのみ使用されます。

参照

Gradient クラス | Gradient メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle

Steema.TeeChart.Drawing.GradientStyle クラス

この型のすべてのメンバの一覧については、GradientStyle メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class GradientStyle : TeeBase , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle 全メンバ

GradientStyle 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

CenterXOffset | 非リニアグラデーションの中央からのXピクセルオフセットを取得/設定します。
CenterYOffset | 非リニアグラデーションの中央からのYピクセルオフセットを取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Direction | グラデーションの塗りつぶしが適用される方向を指定します。
Visible | Trueの場合、指定された非リニアグラデーションスタイルを適用します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GradientStyle クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle コンストラクタ

オーバーロードの一覧

public GradientStyle()
public GradientStyle(Steema.TeeChart.Chart)

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle コンストラクタ

public GradientStyle()

参照

GradientStyle コンストラクタのオーバーロードの一覧 | GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle コンストラクタ

public GradientStyle(Chart c)

参照

GradientStyle コンストラクタのオーバーロードの一覧 | GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

GradientStyle クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle メソッド

パブリック メソッド

Clone |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GradientStyle クラス | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.GradientStyle.Clone メソッド

public virtual Object Clone()

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GradientStyle プロパティ

パブリック プロパティ

CenterXOffset | 非リニアグラデーションの中央からのXピクセルオフセットを取得/設定します。
CenterYOffset | 非リニアグラデーションの中央からのYピクセルオフセットを取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Direction | グラデーションの塗りつぶしが適用される方向を指定します。
Visible | Trueの場合、指定された非リニアグラデーションスタイルを適用します。

参照

GradientStyle クラス | Steema.TeeChart.Drawing 名前空間


CenterXOffset

Steema.TeeChart.Drawing.GradientStyle.CenterXOffset プロパティ

非リニアグラデーションの中央からのXピクセルオフセットを取得/設定します。
public Int32 CenterXOffset {get; set;}

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


CenterYOffset

Steema.TeeChart.Drawing.GradientStyle.CenterYOffset プロパティ

非リニアグラデーションの中央からのYピクセルオフセットを取得/設定します。
public Int32 CenterYOffset {get; set;}

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Direction

Steema.TeeChart.Drawing.GradientStyle.Direction プロパティ

グラデーションの塗りつぶしが適用される方向を指定します。
public PathGradientMode Direction {get; set;}

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Visible

Steema.TeeChart.Drawing.GradientStyle.Visible プロパティ

Trueの場合、指定された非リニアグラデーションスタイルを適用します。
public Boolean Visible {get; set;}

参照

GradientStyle クラス | GradientStyle メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D

Steema.TeeChart.Drawing.Graphics3D クラス

この型のすべてのメンバの一覧については、Graphics3D メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public abstract class Graphics3D : TeeBase , IComponent, IDisposable

解説

必要な機能が標準のTeeChartプロパティやメソッドにない場合、TeeChartのカスタム描画のキャンバスメソッドを使用して独自に追加することができます。カスタム描画は、チャートパネルに独自のオブジェクトやテキストを出力することが可能です。また、カスタムキャンバスも、さまざまな3Dオブジェクトをサポートします。

これらのオブジェクトはGraphics3Dクラスのインスタンスから使用できます。尚、このクラスはAfterDrawのようなイベントに渡されます。TeeChartキャンバスへの描画に関する詳細については、「チュートリアル 第13章 - チャートパネルのカスタム描画」を参照してください。

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D 全メンバ

Graphics3D 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints
IPointDoubles
Monochrome
PiStep

パブリック メソッド

ApplyBright | cパラメーターをより明るい色に変換します。
ApplyDark | cパラメーターをより暗い色に変換します。
Arc | 4座標で定義した矩形内に弧を描きます。
Arrow | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint |
Calc3DPos | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcBitmap |
CalcLines |
CalcRect3D | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。
Cone | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull | 2DのXYポイントの凸面体の境界ポイントを計算します。
CrossingLines | 2つの線が交差する場合、trueを返します。
Cube | 立方体を描画します。
Cylinder | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation |
Draw | 矩形rにイメージを描画します。
DrawBeziers | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate |
Ellipse | 境界矩形rに楕円を描きます。
EllipseEnh | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation |
EndBlending | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle |
FillRegion |
FontTextHeight | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin |
FrontPlaneEnd |
GetChartPolygon | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle | 角の丸い矩形を含んでいるPointDouble配列を返します。
GetDefaultColor | グローバルなColorPalette配列変数から色を返します。
GetDefaultPattern | 多数の使用可能なブラシスタイルの内部パレットから有効なWindowsのブラシスタイルを返します。
HorizCone | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 指定した位置に水平直線を描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | 指定した座標位置に線を描きます。
LineTo | 現在のペンの位置から新しい座標に線を描きます。
LineWithZ |
MeasureString | 指定したフォントの文字列のSizeFを返します。
MoveTo | LineToメソッドを呼び出す前に線の開始位置を設定します。
OrientRectangle | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel |
PaintImageBevel | 指定した矩形の周りにカスタムな枠を描画します。
Pie | パイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane | Z深さオフセットで多角形描きます。
PlaneFour3D | 4ポイントの多角形を描画します。
PointAtDistance | "From"ポイントから"To"ポイント－"distance"ピクセルのポイントを返します。
PointFromCircle | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral |
PointInEllipse | pがLeft、Top、Right、Bottomで指定された楕円境界内にある場合、trueを返します。
PointInHorizTriangle | pが水平三角形の中にある場合、trueを返します。
PointInLine |
PointInLineTolerance | ポイントTがPoint1とPoint2の間の線の近くにあるかどうか返します。
PointInPolygon | pがpolyの多角形の中にある場合、trueを返します。
PointInRect |
PointInTriangle | pが(x0,y0)、(x0とx1の中央,y1)、(x1,y0)の垂直三角形の中にある場合、trueを返します。
Polygon | Z位置オフセットで多角形を描きます。
PolygonBounds | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble |
PolygonRect | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix |
PrepareDrawImage | 描画するためにチャートキャンバスを用意します。
Projection | 内部使用。境界矩形の投影座標を計算します。
PushMatrix |
Pyramid | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF |
RectangleWithZ |
RectangleY | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ | 指定したパラメータの位置に水平の矩形を描画します。
RectCenter |
RectFromPolygon | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate |
RotateLabel | RotDegreeの回転角度で、指定したXYZ座標に回転したテキスト文字列を出力します。
RoundRectangle | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign |
ShadowSmooth |
ShowImage |
Sphere | 球を描画します。
SphereEnh | 内部使用。3Dの球体。
StartBlending | OpenGLの透明度をサポートします。
Surface3D |
TeeCull |
TextHeight | テキストの高さをピクセル単位で返します。
TextOut | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate |
Transparency | Colorパラメーターの値に基づいたパーセント率を返します。
TransparentColor | 「A」値を変更した後のColorパラメーターを返します。
Triangle | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | Z深さ位置で (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter | チャートの垂直方向に対する中央の座標値を返します。
ColorPalette |
Font | テキストの出力に使用されるフォント属性を定義します。
FontHeight | ピクセル単位でフォントの高さを定義します。
Gradient | グラデーションについて定義します。
Pen | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
ScreenHeight | チャートパネルの高さをピクセル単位で返します。
ScreenWidth | チャートパネルの幅をピクセル単位で返します。
SmoothingMode | スムーシング（アンチエイリアシング）モード。
Supports3DText | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode
aspect
aTextRenderingHint
g
gradientZ
hasClipRegion
iCanvasType
ifont
InternalUse (TeeBaseの継承元)
IPoints
irotationCenter
IsOpenGL
oldRegion
stringFormat
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

CalcArcAngles | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle |
CorrectRectangle |
DisposeObj |
DoDrawString |
GetRotationCenter |
GetSupports3DText |
InitWindow |
InternalCylinder |
IsRectangle |
Line | 指定した座標位置に線を描きます。
PolygonFour |
Rad2Deg | ラジアン値から度値を返します。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3D クラス | Steema.TeeChart.Drawing 名前空間


Graphics3D コンストラクタ

Steema.TeeChart.Drawing.Graphics3D コンストラクタ

public Graphics3D(Chart c)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D フィールド

パブリック フィールド

FourPoints
g
IPointDoubles
Monochrome
PiStep

プロテクト フィールド

aSmoothingMode
aspect
aTextRenderingHint
hasClipRegion
iCanvasType
InternalUse (TeeBaseの継承元)
IPoints
IsOpenGL
oldRegion
stringFormat
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3D クラス | Steema.TeeChart.Drawing 名前空間


aSmoothingMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.aSmoothingMode フィールド

protected SmoothingMode aSmoothingMode

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


aspect

Steema.TeeChart.Drawing.Graphics3D.aspect フィールド

protected internal Aspect aspect

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


aTextRenderingHint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.aTextRenderingHint フィールド

protected TextRenderingHint aTextRenderingHint

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FourPoints

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.FourPoints フィールド

public Point[] FourPoints

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


g

Steema.TeeChart.Drawing.Graphics3D.g フィールド

public Graphics g

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


gradientZ

Steema.TeeChart.Drawing.Graphics3D.gradientZ フィールド

protected internal Int32 gradientZ

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


hasClipRegion

Steema.TeeChart.Drawing.Graphics3D.hasClipRegion フィールド

protected internal Boolean hasClipRegion

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


iCanvasType

Steema.TeeChart.Drawing.Graphics3D.iCanvasType フィールド

protected CanvasType iCanvasType

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ifont

Steema.TeeChart.Drawing.Graphics3D.ifont フィールド

protected ChartFont ifont

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


IPointDoubles

Steema.TeeChart.Drawing.Graphics3D.IPointDoubles フィールド

public PointDouble[] IPointDoubles

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


IPoints

Steema.TeeChart.Drawing.Graphics3D.IPoints フィールド

protected internal Point[] IPoints

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


irotationCenter

Steema.TeeChart.Drawing.Graphics3D.irotationCenter フィールド

protected Point3DDouble irotationCenter

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


IsOpenGL

Steema.TeeChart.Drawing.Graphics3D.IsOpenGL フィールド

protected internal Boolean IsOpenGL

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Monochrome

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Monochrome フィールド

public Boolean Monochrome

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


oldRegion

Steema.TeeChart.Drawing.Graphics3D.oldRegion フィールド

protected internal Region oldRegion

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PiStep

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PiStep フィールド

public Double PiStep

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


stringFormat

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.stringFormat フィールド

protected StringFormat stringFormat

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D メソッド

パブリック メソッド

ApplyBright | cパラメーターをより明るい色に変換します。
ApplyDark | cパラメーターをより暗い色に変換します。
Arc | 4座標で定義した矩形内に弧を描きます。
Arrow | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint |
Calc3DPos | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcBitmap |
CalcLines |
CalcRect3D | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。
Cone | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull | 2DのXYポイントの凸面体の境界ポイントを計算します。
CrossingLines | 2つの線が交差する場合、trueを返します。
Cube | 立方体を描画します。
Cylinder | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation |
Draw | 矩形rにイメージを描画します。
DrawBeziers | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate |
Ellipse | 境界矩形rに楕円を描きます。
EllipseEnh | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation |
EndBlending | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle |
FillRegion |
FontTextHeight | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin |
FrontPlaneEnd |
GetChartPolygon | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle | 角の丸い矩形を含んでいるPointDouble配列を返します。
GetDefaultColor | グローバルなColorPalette配列変数から色を返します。
GetDefaultPattern | 多数の使用可能なブラシスタイルの内部パレットから有効なWindowsのブラシスタイルを返します。
HorizCone | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 指定した位置に水平直線を描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | 指定した座標位置に線を描きます。
LineTo | 現在のペンの位置から新しい座標に線を描きます。
LineWithZ |
MeasureString | 指定したフォントの文字列のSizeFを返します。
MoveTo | LineToメソッドを呼び出す前に線の開始位置を設定します。
OrientRectangle | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel |
PaintImageBevel | 指定した矩形の周りにカスタムな枠を描画します。
Pie | パイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane | Z深さオフセットで多角形描きます。
PlaneFour3D | 4ポイントの多角形を描画します。
PointAtDistance | "From"ポイントから"To"ポイント－"distance"ピクセルのポイントを返します。
PointFromCircle | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral |
PointInEllipse | pがLeft、Top、Right、Bottomで指定された楕円境界内にある場合、trueを返します。
PointInHorizTriangle | pが水平三角形の中にある場合、trueを返します。
PointInLine |
PointInLineTolerance | ポイントTがPoint1とPoint2の間の線の近くにあるかどうか返します。
PointInPolygon | pがpolyの多角形の中にある場合、trueを返します。
PointInRect |
PointInTriangle | pが(x0,y0)、(x0とx1の中央,y1)、(x1,y0)の垂直三角形の中にある場合、trueを返します。
Polygon | Z位置オフセットで多角形を描きます。
PolygonBounds | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble |
PolygonRect | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix |
PrepareDrawImage | 描画するためにチャートキャンバスを用意します。
Projection | 内部使用。境界矩形の投影座標を計算します。
PushMatrix |
Pyramid | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF |
RectangleWithZ |
RectangleY | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ | 指定したパラメータの位置に水平の矩形を描画します。
RectCenter |
RectFromPolygon | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate |
RotateLabel | RotDegreeの回転角度で、指定したXYZ座標に回転したテキスト文字列を出力します。
RoundRectangle | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign |
ShadowSmooth |
ShowImage |
Sphere | 球を描画します。
SphereEnh | 内部使用。3Dの球体。
StartBlending | OpenGLの透明度をサポートします。
Surface3D |
TeeCull |
TextHeight | テキストの高さをピクセル単位で返します。
TextOut | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate |
Transparency | Colorパラメーターの値に基づいたパーセント率を返します。
TransparentColor | 「A」値を変更した後のColorパラメーターを返します。
Triangle | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | Z深さ位置で (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

CalcArcAngles | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle |
CorrectRectangle |
DisposeObj |
DoDrawString |
GetRotationCenter |
GetSupports3DText |
InitWindow |
InternalCylinder |
IsRectangle |
Line | 指定した座標位置に線を描きます。
PolygonFour |
Rad2Deg | ラジアン値から度値を返します。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3D クラス | Steema.TeeChart.Drawing 名前空間


ApplyBright

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ApplyBright メソッド

cパラメーターをより明るい色に変換します。

public static Void ApplyBright(Color& c,
     Byte howMuch)

解説

cパラメーターをより明るい色に変換します。howMuchパラメーターは、明るさのインクリメントの量を設定します。バーの側面や円の3D領域を描画するための明るい色を計算するためにStyles.Bar系列やStyles.Pie系列で使用されます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ApplyDark

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ApplyDark メソッド

cパラメーターをより暗い色に変換します。

public static Void ApplyDark(Color& c,
     Byte howMuch)

解説

cパラメーターをより暗い色に変換します。howMuchパラメーターは、暗さのインクリメントの量を設定します。バーの側面や円の3D領域を描画するための暗い色を計算するためにStyles.Bar系列やStyles.Pie系列で使用されます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc メソッド

オーバーロードの一覧

public abstract Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)
public Void Arc(System.Drawing.Rectangle, System.Single, System.Single)

4座標で定義された矩形内に弧を描きます。

public abstract Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

解説

現在のペンで楕円状の曲線で弧を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Arc

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Arc メソッド

4座標で定義された矩形内に弧を描きます。

public virtual Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc メソッド

public Void Arc(Rectangle rect,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3D.Arc メソッド

4座標で定義された矩形内に弧を描きます。
public abstract Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Arrow

Steema.TeeChart.Drawing.Graphics3D.Arrow メソッド

ピクセル単位のheadWidthパラメーターとheadHeightパラメーターのサイズの矢印ヘッドを持つ線を描画します。
public abstract Void Arrow(Boolean filled,
     Point fromPoint,
     Point toPoint,
     Int32 headWidth,
     Int32 headHeight,
     Int32 z)

解説

ピクセル単位のheadWidthパラメーターとheadHeightパラメーターのサイズの矢印ヘッドを持つ線を描画します。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{

     g.Pen.Color = Color.Green;
     g.Brush.Visible = true;
     g.Brush.Color=Color.Yellow;

     Point p1 = new Point(40,60);
     Point p2 = new Point (120,150);
     g.Arrow(true,p1,p2,10,10,3);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint メソッド

オーバーロードの一覧

public Point Calc3DPoint(Steema.TeeChart.Drawing.Point3D)
public Point Calc3DPoint(System.Int32, System.Int32, System.Int32)
public Point Calc3DPoint(System.Drawing.Point, System.Int32)

解説

ポイントpのXY位置をピクセル単位で計算/返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPoint

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint メソッド

public Point Calc3DPoint(Point3D p)

参照

Calc3DPoint オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPoint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint メソッド

public Point Calc3DPoint(Int32 x,
     Int32 y,
     Int32 z)

参照

Calc3DPoint オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPoint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Calc3DPoint メソッド

public Point Calc3DPoint(Point p,
     Int32 z)

参照

Calc3DPoint オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

オーバーロードの一覧

XYZの3D座標のpのXY位置をピクセル単位で計算し、返します。

public abstract Void Calc3DPos(System.Drawing.Point&, System.Int32, System.Int32, System.Int32)
public abstract Void Calc3DPos(Steema.TeeChart.Drawing.PointDouble&, System.Double, System.Double, System.Double)

Zの3D座標のpのXY位置をピクセル単位で計算し、返します。

public Void Calc3DPos(System.Drawing.Point&, System.Drawing.Point, System.Int32)
public Void Calc3DPos(Steema.TeeChart.Drawing.PointDouble&, Steema.TeeChart.Drawing.PointDouble, System.Double)

XYZの3D座標のXY位置をピクセル単位で計算し、返します。

public Void Calc3DPos(System.Int32&, System.Int32&, System.Int32)
public Void Calc3DPos(System.Double&, System.Double&, System.Double)

解説

XYZの3D座標のXY位置をピクセル単位で計算し、返します。
XYZの3D座標が軸から返されるかどうかを使用してカスタム描画中に使用できます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

XYZの3D座標のpのXY位置をピクセル単位で計算し、返します。
public abstract Void Calc3DPos(Point& p,
     Int32 x,
     Int32 y,
     Int32 z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

public abstract Void Calc3DPos(PointDouble& p,
     Double x,
     Double y,
     Double z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

Zの3D座標のpのXY位置をピクセル単位で計算し、返します。

public Void Calc3DPos(Point& p,
     Point source,
     Int32 z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

public Void Calc3DPos(PointDouble& p,
     PointDouble source,
     Double z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

XYZの3D座標のXY位置をピクセル単位で計算し、返します。

public Void Calc3DPos(Int32& x,
     Int32& y,
     Int32 z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calc3DPos

Steema.TeeChart.Drawing.Graphics3D.Calc3DPos メソッド

public Void Calc3DPos(Double& x,
     Double& y,
     Double z)

参照

Calc3DPos オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcArcAngles

Steema.TeeChart.Drawing.Graphics3D.CalcArcAngles メソッド

(x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。

protected Void CalcArcAngles(Int32 X1,
     Int32 Y1,
     Int32 X2,
     Int32 Y2,
     Int32 X3,
     Int32 Y3,
     Int32 X4,
     Int32 Y4,
     Double& startangle,
     Double& sweepangle)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcArcPoints

Steema.TeeChart.Drawing.Graphics3D.CalcArcPoints メソッド

x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。

protected Void CalcArcPoints(Int32 X1,
     Int32 Y1,
     Int32 X2,
     Int32 Y2,
     Double startAngle,
     Double sweepAngle,
     Int32& X3,
     Int32& Y3,
     Int32& X4,
     Int32& Y4)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcBitmap

Steema.TeeChart.Drawing.Graphics3D.CalcBitmap メソッド

public static Void CalcBitmap(RGB[,] Lines,
     Bitmap& bitmap)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcLines

Steema.TeeChart.Drawing.Graphics3D.CalcLines メソッド

public static Void CalcLines(RGB[,]& Lines,
     Bitmap bitmap)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcRect3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D メソッド

3D矩形座標の位置をピクセル単位で計算して返します。

public Rectangle CalcRect3D(Rectangle r,
     Int32 z)

解説

3D矩形座標の位置をピクセル単位で計算して返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcRect3D

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D メソッド

3D矩形座標の位置をピクセル単位で計算して返します。
public RectangleF CalcRect3D(RectangleF r,
     Int32 z)

参照

CalcRect3D オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CalcRect3D

Steema.TeeChart.Drawing.Graphics3D.CalcRect3D メソッド

3D矩形座標の位置をピクセル単位で計算して返します。
public Rectangle CalcRect3D(Rectangle r,
     Int32 z)

参照

CalcRect3D オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calculate2DPosition

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Calculate2DPosition メソッド

座標のXY位置をピクセル単位で計算して返します。

public Void Calculate2DPosition(Int32& x,
     Int32& y,
     Int32 z)

解説

座標のXY位置をピクセル単位で計算して返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition メソッド

オーバーロードの一覧

XYZの3D座標のXY位置をピクセル単位で計算して返します。

public Point Calculate3DPosition(Steema.TeeChart.Drawing.Point3D)

XYZの3D座標のXY位置をピクセル単位で計算して返します。

public Point Calculate3DPosition(System.Int32, System.Int32, System.Int32)

XYZの3D座標のXY位置をピクセル単位で計算して返します。

public Point Calculate3DPosition(System.Drawing.Point, System.Int32)

解説

XYZの3D座標のXY位置をピクセル単位で計算して返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition メソッド

XYZの3D座標のXY位置をピクセル単位で計算して返します。
public Point Calculate3DPosition(Point3D P)

参照

Calculate3DPosition オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition メソッド

XYZの3D座標のXY位置をピクセル単位で計算して返します。

public Point Calculate3DPosition(Int32 x,
     Int32 y,
     Int32 z)

参照

Calculate3DPosition オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Calculate3DPosition

Steema.TeeChart.Drawing.Graphics3D.Calculate3DPosition メソッド

XYZの3D座標のXY位置をピクセル単位で計算して返します。

public Point Calculate3DPosition(Point P,
     Int32 z)

参照

Calculate3DPosition オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3D.ClearClipRegions メソッド

public abstract Void ClearClipRegions()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipCube

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipCube メソッド

立方体のWindows GDIクリッピング領域を作成します。

public virtual Void ClipCube(Rectangle rect,
     Int32 minZ,
     Int32 maxZ)

解説

Windows GDIクリッピング領域を作成し、TChart描画のデバイスコンテキストのハンドルで選択します。
クリッピング領域は指定した立方体座標以外の描画を防ぐために使用されます。
UnClipRectangleメソッドは、TChartの描画キャンバスに適応されるクリッピング領域を削除します。
このメソッドは、系列あるいはカスタム描画が指定した矩形座標以外で描画されることを防ぐために使用できます。

メモ：印刷やメタファイル作成はクリッピング領域を論理ピクセルで対応しません。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipEllipse メソッド

public virtual Void ClipEllipse(Rectangle r)

解説

Windows GDIクリッピング領域を作成し、TChart描画のデバイスコンテキストのハンドルで選択します。
クリッピング領域は指定した楕円座標以外の描画を防ぐために使用されます。
UnClipRectangleメソッドは、TChartの描画キャンバスに適応されるクリッピング領域を削除します。
このメソッドは、系列あるいはカスタム描画が指定した矩形座標以外で描画されることを防ぐために使用できます。

メモ：印刷やメタファイル作成はクリッピング領域を論理ピクセルで対応しません。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipPolygon メソッド

public virtual Void ClipPolygon(Point[] p)

解説

Windows GDIクリッピング領域を作成し、TChart描画のデバイスコンテキストのハンドルで選択します。
クリッピング領域は指定した多角形座標以外の描画を防ぐために使用されます。
UnClipRectangleメソッドは、TChartの描画キャンバスに適応されるクリッピング領域を削除します。
このメソッドは、系列あるいはカスタム描画が指定した矩形座標以外で描画されることを防ぐために使用できます。

メモ：印刷やメタファイル作成はクリッピング領域を論理ピクセルで対応しません。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle メソッド

オーバーロードの一覧

public virtual Void ClipRectangle(System.Drawing.Rectangle)

Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。

public Void ClipRectangle(System.Int32, System.Int32, System.Int32, System.Int32)

解説

Windows GDIクリッピング領域を作成し、TChart描画のデバイスコンテキストのハンドルで選択します。
クリッピング領域は指定した矩形座標以外の描画を防ぐために使用されます。
UnClipRectangleメソッドは、TChartの描画キャンバスに適応されるクリッピング領域を削除します。
このメソッドは、系列あるいはカスタム描画が指定した矩形座標以外で描画されることを防ぐために使用できます。

メモ：印刷やメタファイル作成はクリッピング領域を論理ピクセルで対応しません。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle メソッド

public virtual Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ClipRectangle メソッド

Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。

public Void ClipRectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

ClipRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cone

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Cone メソッド

オーバーロードの一覧

円錐を描きます。OPENGL専用で使用してください。

public Void Cone(System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

円錐を描きます。OPENGL専用で使用してください。

public Void Cone(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

円錐パーセントで円錐を描きます。OPENGL専用で使用してください。

public Void Cone(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean, System.Int32)

解説

円錐を描きます。ConePercentパラメーターは円錐の底辺のパーセント率により頂点のサイズを設定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cone

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Cone メソッド

円錐を描きます。OPenGL専用で使用してください。

public Void Cone(Boolean vertical,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Cone オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cone

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Cone メソッド

円錐を描画します。OpenGL専用で使用してください。

public Void Cone(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Cone オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cone

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Cone メソッド

円錐パーセントで円錐を描きます。OPENGL専用で使用してください。

public Void Cone(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides,
     Int32 conePercent)

参照

Cone オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ConvexHull

Steema.TeeChart.Drawing.Graphics3D.ConvexHull メソッド

2Dのxyポイントの凸面の境界ポイントを計算します。オリジナル。
public Boolean ConvexHull(Point[]& p,
     Int32& size)

解説

2Dのxyポイントの凸面の境界ポイントを計算します。オリジナル。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CorrectAngle

Steema.TeeChart.Drawing.Graphics3D.CorrectAngle メソッド

オーバーロードの一覧

protected internal Int32 CorrectAngle(System.Int32)
protected internal Double CorrectAngle(System.Double)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CorrectAngle

Steema.TeeChart.Drawing.Graphics3D.CorrectAngle メソッド

protected internal Int32 CorrectAngle(Int32 rotAngle)

参照

CorrectAngle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CorrectAngle

Steema.TeeChart.Drawing.Graphics3D.CorrectAngle メソッド

protected internal Double CorrectAngle(Double rotAngle)

参照

CorrectAngle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CorrectRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.CorrectRectangle メソッド

protected Rectangle CorrectRectangle(Rectangle r)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CrossingLines

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.CrossingLines メソッド

2つの線が交差する場合、trueを返します。

public static Boolean CrossingLines(Double x1,
     Double y1,
     Double x2,
     Double y2,
     Double x3,
     Double y3,
     Double x4,
     Double y4,
     Double& x,
     Double& y)

解説

2つの線が交差する場合、trueを返します。

最初の線は、X1Y1からX2Y2までの座標として定義されます。
次の線は、X3Y3からX4Y4までの座標として定義されます。

線が交差する場合、XY参照パラメーターは交差している場所を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube メソッド

オーバーロードの一覧

任意で影付きの立方体を描画します。

public abstract Void Cube(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

立方体を描画します。

public Void Cube(System.Drawing.Rectangle, System.Int32, System.Int32)

任意で影付きの立方体を描画します。

public Void Cube(System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

解説

任意で上側と右側に影付きの立方体を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube メソッド

任意で影付きの立方体を描画します。
public abstract Void Cube(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Cube オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube メソッド

立方体を描画します。
public Void Cube(Rectangle r,
     Int32 z0,
     Int32 z1)

参照

Cube オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cube

Steema.TeeChart.Drawing.Graphics3D.Cube メソッド

任意で影付きの立方体を描画します。
public Void Cube(Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Cube オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Cylinder

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Cylinder メソッド

円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。

public Void Cylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

解説

円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     Rectangle r = new Rectangle(80,130,100,170)
     g.Cylinder(true,r,1,10,true);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DisableRotation

Steema.TeeChart.Drawing.Graphics3D.DisableRotation メソッド

public abstract Void DisableRotation()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DisposeObj

Steema.TeeChart.Drawing.Graphics3D.DisposeObj メソッド

protected internal Void DisposeObj()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DoDrawString

Steema.TeeChart.Drawing.Graphics3D.DoDrawString メソッド

protected abstract Void DoDrawString(Int32 x,
     Int32 y,
     String text,
     ChartBrush aBrush)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Draw メソッド

オーバーロードの一覧

public virtual Void Draw(System.Drawing.Rectangle, System.Drawing.Image)
public virtual Void Draw(System.Int32, System.Int32, System.Drawing.Image)

矩形rにイメージを描画します。

public Void Draw(System.Drawing.Rectangle, System.Drawing.Image, Steema.TeeChart.Drawing.ImageMode)

解説

Drawメソッドは、指定した描画キャンバスや領域にチャートを描画するために使用してください。

これは、チャートをカスタマイズして印刷する場合にも使用できます。
あるいは、TeeChart.Drawメソッドを使用してどんな位置にでもイメージを描画できます。次の例を参照してください。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)

tChart1.Graphics3D.Draw(new Rectangle(20,20,80,80),imageList1.Images[1]);

上記のコードは、固定した位置にイメージを作成します。しかし、TeeChartの軸や系列のCalcXPosメソッドやCalcYPosメソッドを使用して、チャートのポイント位置および値の位置を検索できます。Drawメソッドを使用してAfterDrawイベントで、データポイントなどにイメージを置くことができます。CalcXPos/CalcYPosメソッドの使用についての詳細は、TeeChartチュートリアルの「チャートパネルのカスタム描画」を参照してください。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Draw メソッド

public virtual Void Draw(Rectangle r,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2003 Steema Software SL. All rights reserved.


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Draw メソッド

public virtual Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2003 Steema Software SL. All rights reserved.


Draw

Steema.TeeChart.Drawing.Graphics3D.Draw メソッド

矩形rにイメージを描画します。
public Void Draw(Rectangle r,
     Image image,
     ImageMode mode,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers メソッド

オーバーロードの一覧

Point配列pのベジェスプライン曲線を描画します。

public abstract Void DrawBeziers(System.Drawing.Point[])

ZオフセットでPoint配列pのベジェスプライン曲線を描画します。

public abstract Void DrawBeziers(System.Int32, System.Drawing.Point[])

解説

Point配列pのベジェスプライン曲線を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers メソッド

pのベジェスプライン曲線を描画します。

public virtual Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3D.DrawBeziers メソッド

zオフセットでpのベジェスプライン曲線を描画します。
public abstract Void DrawBeziers(Int32 z,
     Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3D.DrawPath メソッド

GraphicsPathを描きます。
public abstract Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Elevate

Steema.TeeChart.Drawing.Graphics3D.Elevate メソッド

public abstract Void Elevate(Int32 angle)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

オーバーロードの一覧

public abstract Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

Z位置で境界Rect (X1,Y1,X2,Y2)に楕円を描きます。

public abstract Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

境界矩形rに楕円を描きます。

public Void Ellipse(System.Drawing.Rectangle)

Z位置で境界矩形に楕円を描きます。

public Void Ellipse(System.Drawing.Rectangle, System.Int32)

Z位置と角度で境界矩形rに楕円を描きます。

public Void Ellipse(System.Drawing.Rectangle, System.Int32, System.Double)

Z位置と角度で境界矩形(Left, Top, Right, Bottom)に楕円を描きます。

public Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double)

解説

楕円を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

public virtual Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

Z深さで指定した座標(X1,Y1,X2,Y2)に楕円を描きます。
public abstract Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

指定した矩形rに楕円を描きます。
public Void Ellipse(Rectangle r)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

z深さで矩形rに楕円を描きます。
public Void Ellipse(Rectangle r,
     Int32 z)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

指定したz深さとangle角度で矩形rに楕円を描きます。

public Void Ellipse(Rectangle r,
     Int32 z,
     Double angle)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Ellipse メソッド

Z深さで指定した座標(Left,Top,Right,Bottom)とangle角度で楕円を描きます。

public Void Ellipse(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z,
     Double angle)

参照

Ellipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EllipseEnh

Steema.TeeChart.Drawing.Graphics3D.EllipseEnh メソッド

オーバーロードの一覧

指定したZ位置と(X1,Y1,X2,Y2)の境界矩形内に拡張した楕円を描きます。

public abstract Void EllipseEnh(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

内部使用。拡張した球体。

public Void EllipseEnh(System.Int32, System.Int32, System.Int32, System.Int32)

解説

指定したZ位置と(X1,Y1,X2,Y2)の境界矩形内に拡張した楕円を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EllipseEnh

Steema.TeeChart.Drawing.Graphics3D.EllipseEnh メソッド

Z深さで指定した座標(X1,Y1,X2,Y2)に拡張した楕円を描きます。
public abstract Void EllipseEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

参照

EllipseEnh オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EllipseEnh

Steema.TeeChart.Drawing.Graphics3D.EllipseEnh メソッド

内部使用。拡張した球体。
public Void EllipseEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

EllipseEnh オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EnableRotation

Steema.TeeChart.Drawing.Graphics3D.EnableRotation メソッド

public abstract Void EnableRotation()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EndBlending

Steema.TeeChart.Drawing.Graphics3D.EndBlending メソッド

OpenGLの透明度をサポートします。

public abstract Void EndBlending()

解説

透明処理を終了します。
BlendパラメータはキャンバスのBeginBlending <TTeeCanvas.BeginBlending.html>メソッドを呼び出す際に取得したTTeeBlendオブジェクトでなければなりません。
このメソッドはBlendオブジェクトを自動的に解放します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.EraseBackground メソッド

public virtual Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

指定した矩形領域の背景を削除します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FillRectangle

Steema.TeeChart.Drawing.Graphics3D.FillRectangle メソッド

public abstract Void FillRectangle(Brush brush,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

解説

現在のブラシを使用して矩形領域を塗りつぶします。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FontTextHeight

Steema.TeeChart.Drawing.Graphics3D.FontTextHeight メソッド

キャンバスに出力するテキストのフォントの高さを定義します。
public Int32 FontTextHeight(ChartFont f)

解説

キャンバスに出力するテキストのフォントの高さを定義します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FourPointsFromRect

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.FourPointsFromRect メソッド

TFourPoints 構造体を返します。（4つのTPoint レコードの配列）

public Point[] FourPointsFromRect(Rectangle r,
     Int32 z)

解説

現在のRotationプロパティやElevationプロパティを使用して、"Z"パラメーターの深さに位置するそれぞれの角の位置を計算した後で、"R" 矩形パラメーターのそれぞれの角の2Dのxy位置を含むTFourPoints （4つのTPoint レコードの配列）構造体を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FrontPlaneBegin

Steema.TeeChart.Drawing.Graphics3D.FrontPlaneBegin メソッド

protected internal Void FrontPlaneBegin()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FrontPlaneEnd

Steema.TeeChart.Drawing.Graphics3D.FrontPlaneEnd メソッド

protected internal Void FrontPlaneEnd()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetChartPolygon

Steema.TeeChart.Drawing.Graphics3D.GetChartPolygon メソッド

矩形からZで移動された領域を返します。
public abstract Region GetChartPolygon(Rectangle rect,
     Int32 minZ,
     Int32 maxZ)

解説

矩形からZで移動された領域を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle メソッド

オーバーロードの一覧

角の丸い矩形を含んでいるPointDouble配列を返します。

public PointDouble[] GetClipRoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32, System.Int32)

角の丸い矩形を含んでいるPointDouble配列を返します。

public PointDouble[] GetClipRoundRectangle(System.Byte[]&, System.Drawing.Rectangle, System.Int32, System.Int32, System.Int32)

角の丸い矩形を含んでいるPointDouble配列を返します。

public PointDouble[] GetClipRoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle メソッド

角の丸い矩形を含んでいるPointDouble配列を返します。
public PointDouble[] GetClipRoundRectangle(Rectangle rect,
     Int32 roundWidth,
     Int32 roundHeight,
     Int32 width)

参照

GetClipRoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle メソッド

角の丸い矩形を含んでいるPointDouble配列を返します。
public PointDouble[] GetClipRoundRectangle(Byte[]& pathPointType,
     Rectangle rect,
     Int32 roundWidth,
     Int32 roundHeight,
     Int32 width)

参照

GetClipRoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetClipRoundRectangle

Steema.TeeChart.Drawing.Graphics3D.GetClipRoundRectangle メソッド

角の丸い矩形を含んでいるPointDouble配列を返します。
public PointDouble[] GetClipRoundRectangle(Rectangle rect,
     Int32 borderRound,
     Int32 width)

参照

GetClipRoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetDefaultColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.GetDefaultColor メソッド

グローバルなColorPalette配列変数から色を返します。

public static Color GetDefaultColor(Int32 index)

解説

デフォルト配列パレット内の色を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetDefaultPattern

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.GetDefaultPattern メソッド

多数の使用可能なブラシスタイルの内部パレットから有効なWindowsのブラシスタイルを返します。

public static HatchStyle GetDefaultPattern(Int32 index)

解説

多数の使用可能なブラシスタイルの内部パレットから有効なWindowsのブラシスタイルを返します。indexパラメーターはこれらの可能な場合のうちの一つになります。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetRotationCenter

Steema.TeeChart.Drawing.Graphics3D.GetRotationCenter メソッド

protected abstract PointXYZ GetRotationCenter()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


GetSupports3DText

Steema.TeeChart.Drawing.Graphics3D.GetSupports3DText メソッド

protected abstract Boolean GetSupports3DText()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


HorizCone

Steema.TeeChart.Drawing.Graphics3D.HorizCone メソッド

円錐を描きます。OPENGL専用で使用してください。
public Void HorizCone(Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides,
     Int32 conePercent)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine メソッド

オーバーロードの一覧

public abstract Void HorizontalLine(System.Int32, System.Int32, System.Int32)

指定した位置に水平直線を描きます。

public abstract Void HorizontalLine(System.Int32, System.Int32, System.Int32, System.Int32)

解説

(Left,Y,Z) から (Right,Y,Z) に水平直線を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine メソッド

public virtual Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

参照

HorizontalLine オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

Steema.TeeChart.Drawing.Graphics3D.HorizontalLine メソッド

指定した位置に水平直線を描きます。
public abstract Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y,
     Int32 z)

参照

HorizontalLine オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3D.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


InternalCylinder

Steema.TeeChart.Drawing.Graphics3D.InternalCylinder メソッド

protected abstract Void InternalCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


IsRectangle

Steema.TeeChart.Drawing.Graphics3D.IsRectangle メソッド

protected Boolean IsRectangle(Point[] p)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

オーバーロードの一覧

protected abstract Void Line(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Point, System.Drawing.Point)
public abstract Void Line(System.Int32, System.Int32, System.Int32, System.Int32)

指定した深さと座標位置に線を描きます。

public abstract Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

指定した深さと座標位置に線を描きます。

public Void Line(System.Drawing.Point, System.Drawing.Point, System.Int32)

指定した座標位置に線を描きます。

public Void Line(System.Drawing.Point, System.Drawing.Point)

指定した異なる開始/終了の深さと座標位置に線を描きます。

public Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

解説

現在のペンを使用して指定した座標位置に線を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

protected abstract Void Line(ChartPen p,
     Point a,
     Point b)

参照

Line オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

指定した深さと座標位置に線を描きます。
public Void Line(Point p0,
     Point p1,
     Int32 z)

パラメーター

p0
開始xy
p1
終了xy
z
深さオフセット

参照

Line オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

指定した座標位置に線を描きます。
public Void Line(Point p0,
     Point p1)

パラメーター

p0
開始xy
p1
終了xy

参照

Line オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

指定した座標の位置に線を描きます。
public Void Line(Point p0,
     Point p1)

パラメーター

p0
開始xy
p1
終了xy

参照

Line オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3D.Line メソッド

public abstract Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

参照

Line オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public Void LineTo(System.Drawing.Point, System.Int32)

z深さオフセットで現在の位置から終了座標に線を描きます。

public abstract Void LineTo(System.Int32, System.Int32, System.Int32)

Point3D pに線を描きます。

public abstract Void LineTo(Steema.TeeChart.Drawing.Point3D)
public abstract Void LineTo(System.Int32, System.Int32)

解説

現在のPenPos（MoveToメソッドを参照）から新しい座標に線を描きます。Point pまたはzパラメーターを持つ/持たないint xやint yを使用して、LineToメソッドは終了座標を設定するために4つのオーバーロードがあります。

例

[C#]
// zオフセットなしで線を描きます;
tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.LineTo メソッド

public virtual Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo メソッド

z深さオフセットで現在位置から終了座標に線を描きます。
public abstract Void LineTo(Int32 x,
     Int32 y,
     Int32 z)

参照

LineTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo メソッド

Point3D pに線を描きます。
public abstract Void LineTo(Point3D p)

参照

LineTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3D.LineTo メソッド

3Dポイントに線を描きます。
public Void LineTo(Point3D p)

参照

LineTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


LineWithZ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.LineWithZ メソッド

public Void LineWithZ(Int32 x,
     Int32 y,
     Int32 x1,
     Int32 y1,
     Int32 z)

旧式

このメソッドの代わりにLineメソッドを使用してください。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MeasureString

Steema.TeeChart.Drawing.Graphics3D.MeasureString メソッド

指定したフォントの文字列のSizeFを返します。
public abstract SizeF MeasureString(ChartFont f,
     String text)

解説

指定したフォントの文字列のSizeFを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

オーバーロードの一覧

LineToメソッドを呼び出す前に3DのPoint pで線の開始位置を設定します。

public abstract Void MoveTo(Steema.TeeChart.Drawing.Point3D)

LineToメソッドを呼び出す前にz深さオフセットとPoint pで線の開始位置を設定します。

public abstract Void MoveTo(System.Drawing.Point, System.Int32)

LineToメソッドを呼び出す前にx、y、z座標で線の開始位置を設定します。

public abstract Void MoveTo(System.Int32, System.Int32, System.Int32)

LineToメソッドを呼び出す前にx、y座標で線の開始位置を設定します。

public abstract Void MoveTo(System.Int32, System.Int32)

LineToメソッドを呼び出す前にPoint pで線の開始位置を設定します。

public Void MoveTo(System.Drawing.Point)

解説

LineToメソッドを呼び出す前に線の開始位置を設定します。

例

[C#]

tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

LineToメソッドを呼び出す前に3DのPoint pで線の開始位置を設定します。
public abstract Void MoveTo(Point3D p)

参照

MoveTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

LineToメソッドを呼び出す前にz深さオフセットとPoint pで線の開始位置を設定します。
public abstract Void MoveTo(Point p,
     Int32 z)

参照

MoveTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

LineToメソッドを呼び出す前にx、y、z座標で線の開始位置を設定します。
public abstract Void MoveTo(Int32 x,
     Int32 y,
     Int32 z)

参照

MoveTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

LineToメソッドを呼び出す前にxとy座標で線の開始位置を設定します。
public abstract Void MoveTo(Int32 x,
     Int32 y)

参照

MoveTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3D.MoveTo メソッド

LineToメソッドを呼び出す前にPoint pで線の開始位置を設定します。
public Void MoveTo(Point p)

参照

MoveTo オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


OrientRectangle

Steema.TeeChart.Drawing.Graphics3D.OrientRectangle メソッド

矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。

public Void OrientRectangle(Rectangle& rect)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PaintBevel

Steema.TeeChart.Drawing.Graphics3D.PaintBevel メソッド

public Void PaintBevel(BevelStyles bevel,
     Rectangle rect,
     Int32 width,
     Color one,
     Color two)

解説

指定したパラメーターの矩形の周りにベベルを描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PaintImageBevel

Steema.TeeChart.Drawing.Graphics3D.PaintImageBevel メソッド

指定した矩形の周りにカスタムな枠を描画します。

public Void PaintImageBevel(Rectangle rect,
     Int32 width,
     ChartPen pen,
     ChartBrush brush,
     Int32 borderRound)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie メソッド

オーバーロードの一覧

public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double, System.Boolean, System.Boolean, System.Int32, System.Int32, Steema.TeeChart.Drawing.EdgeStyles)

開始角度、終了角度、ドーナツパーセントを使用して3Dのパイスライスを描きます。

public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double, System.Boolean, System.Boolean, System.Int32, System.Int32, Steema.TeeChart.Drawing.EdgeStyles)

パイスライスを描きます。

public Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

開始角度、終了角度を使用してパイスライスを描きます。

public abstract Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double)

解説

パイスライスを描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie メソッド

public abstract Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xOffset,
     Int32 yOffset,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

参照

Pie オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie メソッド

開始角度、終了角度、ドーナツパーセントを使用して3Dのパイスライスを描きます。
public abstract Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

参照

Pie オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie メソッド

パイスライスを描きます。
public Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Pie オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D.Pie メソッド

開始角度、終了角度を使用してパイスライスを描きます。
public abstract Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Double startAngle,
     Double endAngle)

参照

Pie オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Pixel メソッド

public virtual Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane メソッド

オーバーロードの一覧

Z深さオフセットで多角形描きます。

public abstract Void Plane(System.Drawing.Point, System.Drawing.Point, System.Int32, System.Int32)

Z深さオフセットで多角形描きます。

public abstract Void Plane(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

異なる開始/終了のZ深さオフセットで多角形を描きます。

public Void Plane(System.Int32, System.Int32, System.Drawing.Point[])

解説

多角形を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane メソッド

Z深さオフセットで多角形を描きます。
public abstract Void Plane(Point p1,
     Point p2,
     Int32 z0,
     Int32 z1)

参照

Plane オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Plane

Steema.TeeChart.Drawing.Graphics3D.Plane メソッド

Z深さオフセットで多角形描きます。
public abstract Void Plane(Point p1,
     Point p2,
     Point p3,
     Point p4,
     Int32 z)

参照

Plane オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Plane

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Plane メソッド

異なる開始/終了のz深さオフセットで多角形を描きます。

public Void Plane(Int32 z0,
     Int32 z1,
     Point[] p)

参照

Plane オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PlaneFour3D

Steema.TeeChart.Drawing.Graphics3D.PlaneFour3D メソッド

4ポイントの多角形を描画します。
public abstract Void PlaneFour3D(Int32 z0,
     Int32 z1,
     Point[] p)

解説

4ポイントの多角形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointAtDistance

Steema.TeeChart.Drawing.Graphics3D.PointAtDistance メソッド

"From"ポイントから"To"ポイント－"distance"ピクセルのポイントを返します。
public static Point PointAtDistance(Point From,
     Point To,
     Int32 distance)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle メソッド

オーバーロードの一覧

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double)

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double, System.Int32)

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。Z位置がゼロ以上の場合、オプションでTeeChartの3D領域にポイントを移動します。

public PointDouble PointFromCircle(System.Drawing.Rectangle, System.Double, System.Int32, System.Boolean)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle メソッド

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees)

参照

PointFromCircle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle メソッド

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees,
     Int32 zPos)

参照

PointFromCircle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromCircle

Steema.TeeChart.Drawing.Graphics3D.PointFromCircle メソッド

指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。Z位置がゼロ以上の場合、オプションでTeeChartの3D領域にポイントを移動します。
public PointDouble PointFromCircle(Rectangle rectBounds,
     Double degrees,
     Int32 zPos,
     Boolean clockWise)

参照

PointFromCircle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse メソッド

オーバーロードの一覧

指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。

public PointDouble PointFromEllipse(System.Drawing.Rectangle, System.Double)

指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。Z位置がゼロ以上の場合、オプションでTeeChartの3D領域にポイントを移動します。

public PointDouble PointFromEllipse(System.Drawing.Rectangle, System.Double, System.Int32)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse メソッド

指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
public PointDouble PointFromEllipse(Rectangle rectBounds,
     Double degrees)

参照

PointFromEllipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromEllipse

Steema.TeeChart.Drawing.Graphics3D.PointFromEllipse メソッド

指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。Z位置がゼロ以上の場合、オプションでTeeChartの3D領域にポイントを移動します。
public PointDouble PointFromEllipse(Rectangle rectBounds,
     Double degrees,
     Int32 zPos)

参照

PointFromEllipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointFromSpiral

Steema.TeeChart.Drawing.Graphics3D.PointFromSpiral メソッド

public PointDouble PointFromSpiral(Rectangle rectBounds,
     Double degrees,
     Double twist)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInEllipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse メソッド

オーバーロードの一覧

pがLeft、Top、Right、Bottomで指定された楕円境界内にある場合、trueを返します。

public static Boolean PointInEllipse(System.Drawing.Point, System.Int32, System.Int32, System.Int32, System.Int32)

pがRectで指定された楕円境界内にある場合、trueを返します。

public static Boolean PointInEllipse(System.Drawing.Point, System.Drawing.Rectangle)

解説

pがRectで指定された楕円境界内にある場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInEllipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse メソッド

pがLeft、Top、Right、Bottomで指定された楕円境界内にある場合、trueを返します。

public static Boolean PointInEllipse(Point p,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

PointInEllipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInEllipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInEllipse メソッド

pがRectで指定された楕円境界内にある場合、trueを返します。

public static Boolean PointInEllipse(Point p,
     Rectangle rect)

参照

PointInEllipse オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInHorizTriangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInHorizTriangle メソッド

pが水平三角形の中にある場合、trueを返します。

public static Boolean PointInHorizTriangle(Point p,
     Int32 y0,
     Int32 y1,
     Int32 x0,
     Int32 x1)

解説

pが水平三角形の中にある場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInLine

Steema.TeeChart.Drawing.Graphics3D.PointInLine メソッド

public static Boolean PointInLine(Point p,
     Point fromPoint,
     Point toPoint)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInLineTolerance

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInLineTolerance メソッド

ポイントTがPoint1とPoint2の間の線の近くにあるかどうか返します。

public static Boolean PointInLineTolerance(Point p,
     Int32 px,
     Int32 py,
     Int32 qx,
     Int32 qy,
     Int32 tolerance)

解説

ポイントTがPoint1とPoint2の間の線の近くにある場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInPolygon

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon メソッド

オーバーロードの一覧

public static Boolean PointInPolygon(System.Drawing.Point, Steema.TeeChart.Drawing.Triangle2D)

pがpolyの多角形の中にある場合、trueを返します。

public static Boolean PointInPolygon(System.Drawing.Point, System.Drawing.Point[])

解説

pがpolyの多角形の中にある場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInPolygon

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon メソッド

public static Boolean PointInPolygon(Point p,
     Triangle2D triangle)

参照

PointInPolygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInPolygon

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInPolygon メソッド

pがpolyの多角形の中にある場合、trueを返します。
public static Boolean PointInPolygon(Point p,
     Point[] poly)

参照

PointInPolygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInRect

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.PointInRect メソッド

public static Boolean PointInRect(Rectangle rect,
     Int32 x,
     Int32 y)

旧式

このメソッドの代わりにRectangle.Containsメソッドを使用してください。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle メソッド

オーバーロードの一覧

Pがp0, p1, p2の垂直三角形の中にある場合、trueを返します。

public static Boolean PointInTriangle(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)

Pが(x0,y0)、(x0とx1の中央,y1)、(x1,y0)の垂直三角形の中にある場合、trueを返します。

public static Boolean PointInTriangle(System.Drawing.Point, System.Int32, System.Int32, System.Int32, System.Int32)

解説

Pが(x0,y0)、(x0とx1の中央,y1)、(x1,y0)の垂直三角形の中にある場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle メソッド

Pがp0, p1, p2の垂直三角形の中にある場合、trueを返します。
public static Boolean PointInTriangle(Point p,
     Point p0,
     Point p1,
     Point p2)

参照

PointInTriangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PointInTriangle

Steema.TeeChart.Drawing.Graphics3D.PointInTriangle メソッド

Pが(x0,y0)、(x0とx1の中央,y1)、(x1,y0)の垂直三角形の中にある場合、trueを返します。
public static Boolean PointInTriangle(Point p,
     Int32 x0,
     Int32 x1,
     Int32 y0,
     Int32 y1)

参照

PointInTriangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon メソッド

オーバーロードの一覧

Z位置オフセットで多角形を描きます。

public abstract Void Polygon(System.Int32, System.Drawing.Point[])
public abstract Void Polygon(Steema.TeeChart.Drawing.PointDouble[])
public abstract Void Polygon(Steema.TeeChart.Drawing.Point3D[])
public abstract Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon メソッド

Z位置オフセットで多角形を描きます。
public abstract Void Polygon(Int32 z,
     Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon メソッド

public abstract Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon メソッド

public abstract Void Polygon(Point3D[] p)

参照

Polygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3D.Polygon メソッド

public abstract Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonBounds

Steema.TeeChart.Drawing.Graphics3D.PolygonBounds メソッド

多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。

public Rectangle PolygonBounds(Point[] p)

解説

多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonFour

Steema.TeeChart.Drawing.Graphics3D.PolygonFour メソッド

protected internal abstract Void PolygonFour()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonFourDouble

Steema.TeeChart.Drawing.Graphics3D.PolygonFourDouble メソッド

public abstract Void PolygonFourDouble()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect メソッド

p配列パラメーターで設定された矩形を返します。
public Rectangle PolygonRect(Point[] p)

解説

p配列パラメーターで設定された矩形を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect メソッド

p配列パラメーターで設定された矩形を返します。
public RectangleF PolygonRect(PointF[] p)

参照

PolygonRect オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PolygonRect

Steema.TeeChart.Drawing.Graphics3D.PolygonRect メソッド

p配列パラメーターで設定された矩形を返します。
public Rectangle PolygonRect(Point[] p)

参照

PolygonRect オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline メソッド

オーバーロードの一覧

public abstract Void Polyline(System.Drawing.Point[])
public abstract Void Polyline(System.Int32, System.Drawing.Point[])

解説

Pointパラメータの全てのポイントを接続するラインセグメントを描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline メソッド

public abstract Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3D.Polyline メソッド

public abstract Void Polyline(Int32 z,
     Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PopMatrix

Steema.TeeChart.Drawing.Graphics3D.PopMatrix メソッド

public abstract Void PopMatrix()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3D.PrepareDrawImage メソッド

描画のためのチャートキャンバスを用意します。
public abstract Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Projection

Steema.TeeChart.Drawing.Graphics3D.Projection メソッド

内部使用。境界矩形の投影座標を計算します。
public abstract Void Projection(Int32 maxDepth,
     Rectangle r)

パラメーター

maxDepth
シェープの最大深さ。
r
投影されるシェープの矩形。

解説

内部使用。境界矩形の投影座標を計算します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PushMatrix

Steema.TeeChart.Drawing.Graphics3D.PushMatrix メソッド

public abstract Void PushMatrix()

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid メソッド

オーバーロードの一覧

任意で影付きの垂直あるいは水平の四角錐を描きます。

public abstract Void Pyramid(System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Boolean)

任意で影付きの垂直あるいは水平の四角錐を描きます。

public Void Pyramid(System.Boolean, System.Drawing.Rectangle, System.Int32, System.Int32, System.Boolean)

解説

任意で影付きの垂直あるいは水平の四角錐を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid メソッド

任意で影付きの垂直あるいは水平の四角錐を描きます。
public abstract Void Pyramid(Boolean vertical,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Pyramid オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pyramid

Steema.TeeChart.Drawing.Graphics3D.Pyramid メソッド

任意で影付きの垂直あるいは水平の四角錐を描きます。
public Void Pyramid(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Pyramid オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


PyramidTrunc

Steema.TeeChart.Drawing.Graphics3D.PyramidTrunc メソッド

上部の切り取られた四角錐を描画します。厚さの設定もできます。
public abstract Void PyramidTrunc(Rectangle r,
     Int32 startZ,
     Int32 endZ,
     Int32 truncX,
     Int32 truncZ)

解説

上部の切り取られた四角錐を描画します。厚さの設定もできます。

例

[C#]

private void tChart1_AfterDraw_1(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Pen.Color=Color.Yellow;
     g.Pen.Width = 2;
     Rectangle r = new Rectangle(50,50,300,200);
     tChart1.Graphics3D.PyramidTrunc(r,10,15,20,15);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rad2Deg

Steema.TeeChart.Drawing.Graphics3D.Rad2Deg メソッド

ラジアン値から度値を返します。
protected static Single Rad2Deg(Double radian)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle メソッド

オーバーロードの一覧

public abstract Void Rectangle(System.Drawing.Rectangle)

z深さで設定した座標間に矩形を描きます。

public Void Rectangle(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

z深さに矩形rを描きます。

public abstract Void Rectangle(System.Drawing.Rectangle, System.Int32)

設定した座標間に矩形を描きます。

public Void Rectangle(System.Int32, System.Int32, System.Int32, System.Int32)

解説

矩形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle メソッド

public abstract Void Rectangle(Rectangle r)

参照

Rectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle メソッド

z深さで設定した座標間に矩形を描きます。
public Void Rectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z)

参照

Rectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle メソッド

z深さに矩形rを描きます。
public abstract Void Rectangle(Rectangle r,
     Int32 z)

参照

Rectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3D.Rectangle メソッド

設定した座標間に矩形を描きます。
public Void Rectangle(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

Rectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleF

Steema.TeeChart.Drawing.Graphics3D.RectangleF メソッド

オーバーロードの一覧

public Void RectangleF(System.Drawing.RectangleF)
public Void RectangleF(System.Single, System.Single, System.Single, System.Single, System.Int32)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleF

Steema.TeeChart.Drawing.Graphics3D.RectangleF メソッド

public Void RectangleF(RectangleF r)

参照

RectangleF オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleF

Steema.TeeChart.Drawing.Graphics3D.RectangleF メソッド

public Void RectangleF(Single left,
     Single top,
     Single right,
     Single bottom,
     Int32 z)

参照

RectangleF オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleWithZ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.RectangleWithZ メソッド

public Void RectangleWithZ(Rectangle r,
     Int32 z)

旧式

このメソッドの代わりにRectangleメソッドを使用してください。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleY

Steema.TeeChart.Drawing.Graphics3D.RectangleY メソッド

指定したパラメータの位置に水平の矩形を描画します。
public abstract Void RectangleY(Int32 left,
     Int32 top,
     Int32 right,
     Int32 z0,
     Int32 z1)

解説

指定したパラメータの位置に水平の矩形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectangleZ

Steema.TeeChart.Drawing.Graphics3D.RectangleZ メソッド

指定したパラメータの位置に水平の矩形を描画します。
public abstract Void RectangleZ(Int32 left,
     Int32 top,
     Int32 bottom,
     Int32 z0,
     Int32 z1)

解説

指定したパラメータの位置に水平の矩形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectCenter

Steema.TeeChart.Drawing.Graphics3D.RectCenter メソッド

public static Void RectCenter(Rectangle r,
     Int32& x,
     Int32& y)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectFromPolygon

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon メソッド

指定したXYポイントの配列の境界矩形を返します。

public Rectangle RectFromPolygon(Int32 num,
     Point[] p)

解説

指定したXYポイントの配列の境界矩形を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectFromPolygon

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon メソッド

指定したXYポイントの配列の境界矩形を返します。
public Rectangle RectFromPolygon(Int32 num,
     Point[] p)

参照

RectFromPolygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectFromPolygon

Steema.TeeChart.Drawing.Graphics3D.RectFromPolygon メソッド

指定したXYポイントの配列の境界矩形を返します。
public Rectangle RectFromPolygon(Int32 num,
     PointDouble[] p)

参照

RectFromPolygon オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RectFromRectZ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.RectFromRectZ メソッド

3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。

public Rectangle RectFromRectZ(Rectangle r,
     Int32 z)

解説

3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
これは、3Dで回転した矩形に透明度を適用するために使用されます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Rotate

Steema.TeeChart.Drawing.Graphics3D.Rotate メソッド

public abstract Void Rotate(Int32 angle)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3D.RotateLabel メソッド

オーバーロードの一覧

public abstract Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

RotDegreeの回転角度で、指定したXYZ座標に回転したテキスト文字列を出力します。

public abstract Void RotateLabel(System.Int32, System.Int32, System.Int32, System.String, System.Double)

解説

RotDegreeの回転角度で、指定した座標に回転したテキスト文字列を出力します。RotDegreeの値は0～360の間でなければなりません。文字列はチャートの描画キャンバスに出力されます。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.RotateLabel メソッド

public virtual Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3D.RotateLabel メソッド

RotDegreeの回転角度で、指定したxyz座標に回転したテキスト文字列を出力します。
public abstract Void RotateLabel(Int32 x,
     Int32 y,
     Int32 z,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle メソッド

オーバーロードの一覧

角の丸い矩形を描画します。

public Void RoundRectangle(System.Drawing.Rectangle)
public Void RoundRectangle(System.Drawing.Rectangle, System.Int32)
public Void RoundRectangle(System.Drawing.Rectangle, System.Int32, System.Int32)

解説

角の丸い矩形を描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle メソッド

角の丸い矩形を描画します。
public Void RoundRectangle(Rectangle r)

参照

RoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle メソッド

public Void RoundRectangle(Rectangle r,
     Int32 round)

参照

RoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RoundRectangle

Steema.TeeChart.Drawing.Graphics3D.RoundRectangle メソッド

public Void RoundRectangle(Rectangle r,
     Int32 roundWidth,
     Int32 roundHeight)

参照

RoundRectangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3D.SetClipRegion メソッド

public abstract Void SetClipRegion(Region region)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SetRotationCenter

Steema.TeeChart.Drawing.Graphics3D.SetRotationCenter メソッド

protected abstract Void SetRotationCenter(PointXYZ val)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SetTextAlign

Steema.TeeChart.Drawing.Graphics3D.SetTextAlign メソッド

public abstract Void SetTextAlign(StringAlignment a)

解説

TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ShadowSmooth

Steema.TeeChart.Drawing.Graphics3D.ShadowSmooth メソッド

public static Void ShadowSmooth(Bitmap bitmap,
     Bitmap back,
     Int32 left,
     Int32 top,
     Int32 width,
     Int32 height,
     Int32 horz,
     Int32 vert,
     Double smoothness,
     Boolean fullDraw,
     Graphics3D aCanvas,
     Boolean clip)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3D.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

ほかの位置にキャンバスをコピーします。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Sphere

Steema.TeeChart.Drawing.Graphics3D.Sphere メソッド

球体を描きます。
public abstract Void Sphere(Int32 x,
     Int32 y,
     Int32 z,
     Double radius)

解説

球体を描きます。

例
[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Sphere(250,250,10,30);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SphereEnh

Steema.TeeChart.Drawing.Graphics3D.SphereEnh メソッド

オーバーロードの一覧

内部使用。3Dの球体。

public abstract Void SphereEnh(System.Int32, System.Int32, System.Int32, System.Int32)
public abstract Void SphereEnh(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

解説

内部使用。3Dの球体。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SphereEnh

Steema.TeeChart.Drawing.Graphics3D.SphereEnh メソッド

内部使用。3Dの球体。
public abstract Void SphereEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

SphereEnh オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SphereEnh

Steema.TeeChart.Drawing.Graphics3D.SphereEnh メソッド

public abstract Void SphereEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

参照

SphereEnh オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


StartBlending

Steema.TeeChart.Drawing.Graphics3D.StartBlending メソッド

OpenGLの透明度をサポートします。

public abstract Void StartBlending(Double transparency)

パラメーター

transparency
%

解説

混合（透明）処理のキャンバスを開始します。
矩形Rは2Dの透明領域を定義し、Transparencyパラメーターは透明度になります。
このメソッドはEndBlendingに渡されなければならないTTeeBlendオブジェクトのインスタンスを返します。
EndBlendingメソッドはテンポラリの重ね合わせオブジェクトを自動的に解放します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Surface3D

Steema.TeeChart.Drawing.Graphics3D.Surface3D メソッド

public abstract Void Surface3D(SurfaceStyle style,
     Boolean sameBrush,
     Int32 numXValues,
     Int32 numZValues,
     Surface surface)

解説

サーフェスを描画するための内部メソッドです。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull メソッド

オーバーロードの一覧

public abstract Boolean TeeCull(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)
public abstract Boolean TeeCull(System.Drawing.Point[])

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull メソッド

public abstract Boolean TeeCull(Point p0,
     Point p1,
     Point p2)

参照

TeeCull オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TeeCull

Steema.TeeChart.Drawing.Graphics3D.TeeCull メソッド

public abstract Boolean TeeCull(Point[] P)

参照

TeeCull オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight メソッド

オーバーロードの一覧

テキスト文字列の垂直サイズをピクセル単位で返します。

public abstract Single TextHeight(System.String)

ChartFontのfパラメーターの垂直テキストサイズをピクセル単位で返します。

public abstract Single TextHeight(Steema.TeeChart.Drawing.ChartFont, System.String)

解説

文字列"St"パラメーターの垂直サイズをピクセル単位で返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight メソッド

テキスト文字列の垂直サイズをピクセル単位で返します。
public abstract Single TextHeight(String text)

戻り値

テキスト文字列のピクセル単位での高さ。

参照

TextHeight オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextHeight

Steema.TeeChart.Drawing.Graphics3D.TextHeight メソッド

ChartFontのfパラメーターの垂直テキストサイズをピクセル単位で返します。
public abstract Single TextHeight(ChartFont f,
     String text)

戻り値

ChartFontのfパラメーターのピクセル単位での高さ。

参照

TextHeight オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut メソッド

オーバーロードの一覧

指定したxyz画面座標に2Dで回転なしのラベルを表示します。

public abstract Void TextOut(System.Int32, System.Int32, System.Int32, System.String)

指定したxy画面座標に2Dで回転なしのラベルを表示します。

public abstract Void TextOut(System.Int32, System.Int32, System.String)

指定したxy画面座標とフォントで2Dの回転なしのラベルを表示します。

public Void TextOut(Steema.TeeChart.Drawing.ChartFont, System.Int32, System.Int32, System.String)

解説

指定したtextパラメーターをXY画面座標に表示します。textパラメーターは現在のキャンバス内に出力されます。XとY座標は、チャート矩形内に収まる位置に設定しなければなりません。これは、現在のChart.Drawing.Font属性を使用します。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.TextOut(80,40, "My message");
}

例 2

[C#]

このコードは、TChart1の中央位置にメッセージを表示します。

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.TextOut((tChart1.Left + tChart1.Width)/2,(tChart1.Top + tChart1.Height)/2,"Welcome");
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut メソッド

指定したxyz画面座標に2Dで回転なしのラベルを表示します。
public abstract Void TextOut(Int32 x,
     Int32 y,
     Int32 z,
     String text)

参照

TextOut オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut メソッド

指定したxy画面座標に2Dで回転なしのラベルを表示します。
public abstract Void TextOut(Int32 x,
     Int32 y,
     String text)

参照

TextOut オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextOut

Steema.TeeChart.Drawing.Graphics3D.TextOut メソッド

指定したxy画面座標に2Dで回転なしのラベルを表示します。
public Void TextOut(ChartFont f,
     Int32 x,
     Int32 y,
     String text)

参照

TextOut オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth メソッド

オーバーロードの一覧

テキスト文字列の水平サイズをピクセル単位で返します。

public abstract Single TextWidth(System.String)

ChartFont f の水平テキストサイズをピクセル単位で返します。

public abstract Single TextWidth(Steema.TeeChart.Drawing.ChartFont, System.String)

解説

文字列 "St" パラメーターの水平サイズをピクセル単位で返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth メソッド

テキスト文字列の水平サイズをピクセル単位で返します。
public abstract Single TextWidth(String text)

参照

TextWidth オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextWidth

Steema.TeeChart.Drawing.Graphics3D.TextWidth メソッド

ChartFont f の水平テキストサイズをピクセル単位で返します。
public abstract Single TextWidth(ChartFont f,
     String text)

参照

TextWidth オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Translate

Steema.TeeChart.Drawing.Graphics3D.Translate メソッド

public abstract Void Translate(Int32 x,
     Int32 y,
     Int32 z)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Transparency メソッド

Colorパラメーターの値に基づいたパーセント率を返します。

public static Int32 Transparency(Color color)

戻り値

0から100%のパーセント率

解説

透明度のパーセント率を設定する0から100%の間の値です。透明度が0の場合、前面だけが表示されます。透明度が100の場合、背面だけが表示されます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TransparentColor

Steema.TeeChart.Drawing.Graphics3D.TransparentColor メソッド

「A」値を変更した後のColorパラメーターを返します。
public static Color TransparentColor(Int32 transparency,
     Color color)

パラメーター

transparency
0から100%までの透明度
color
A色

戻り値

透明度を適応した色。

解説

「A」値を変更した後のColorパラメーターを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3D.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle メソッド

オーバーロードの一覧

三角形を描きます。

public abstract Void Triangle(Steema.TeeChart.Drawing.Triangle3D)

Z位置に三角形を描きます。

public abstract Void Triangle(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

解説

三角形を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle メソッド

三角形を描きます。
public abstract Void Triangle(Triangle3D p)

参照

Triangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Triangle

Steema.TeeChart.Drawing.Graphics3D.Triangle メソッド

Z位置に三角形を描きます。
public abstract Void Triangle(Point p0,
     Point p1,
     Point p2,
     Int32 z)

参照

Triangle オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.UnClip メソッド

public virtual Void UnClip()

解説

チャート描画に適応されるクリッピング領域を削除します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


UnClipRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.UnClipRectangle メソッド

チャートキャンバスに適用されるクリッピング領域をすべて削除します。

public Void UnClipRectangle()

解説

チャートキャンバスに適用されるクリッピング領域をすべて削除します。クリッピング領域は、矩形の座標外に描画しないために使用されます。これは、マーカや系列ポイントをChartRectの矩形の外側に表示しておくために内部で使用されます。

メモ：メタファイルはクリッピング領域を適用しません。メタファイル形式は、印刷の際に使用されます。つまり、クリッピングは実行されません。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ValidState

Steema.TeeChart.Drawing.Graphics3D.ValidState メソッド

チャートキャンバスが描画できる場合、trueを返します。
public abstract Boolean ValidState()

解説

チャートキャンバスが描画できる場合、trueを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

Steema.TeeChart.Drawing.Graphics3D.VerticalLine メソッド

オーバーロードの一覧

public abstract Void VerticalLine(System.Int32, System.Int32, System.Int32)

Z深さ位置で (X,Top) から (X,Bottom) に垂直線を描きます。

public abstract Void VerticalLine(System.Int32, System.Int32, System.Int32, System.Int32)

解説

垂直線を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.VerticalLine メソッド

public virtual Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

参照

VerticalLine オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

Steema.TeeChart.Drawing.Graphics3D.VerticalLine メソッド

z深さ位置で (X,Top) から (X,Bottom) に垂直線を描きます。
public abstract Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom,
     Int32 z)

参照

VerticalLine オーバーロードの一覧 | Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ZLine

Steema.TeeChart.Drawing.Graphics3D.ZLine メソッド

(X,Y,Z0) から (X,Y,Z1)に線を描きます。
public abstract Void ZLine(Int32 x,
     Int32 y,
     Int32 z0,
     Int32 z1)

解説

(X,Y,Z0) から (X,Y,Z1)に線を描きます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D プロパティ

パブリック プロパティ

BackColor | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter | チャートの垂直方向に対する中央の座標値を返します。
ColorPalette |
Font | テキストの出力に使用されるフォント属性を定義します。
FontHeight | ピクセル単位でフォントの高さを定義します。
Gradient | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
ScreenHeight | チャートパネルの高さをピクセル単位で返します。
ScreenWidth | チャートパネルの幅をピクセル単位で返します。
SmoothingMode | スムーシング（アンチエイリアシング）モード。
Supports3DText | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3D クラス | Steema.TeeChart.Drawing 名前空間


BackColor

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.BackColor プロパティ

テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。

public Color BackColor {get; set;}

解説

テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。Brush.Visibleプロパティはtrueに設定しなければなりません。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Brush.Visible = true;
     g.Brush.Style = HatchStyle.DiagonalCross;
     g.BackColor = Color.Yellow;

     Rectangle r = new Rectangle(100,100,145,155);
     g.Rectangle(r,10);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Brush

Steema.TeeChart.Drawing.Graphics3D.Brush プロパティ

キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
public ChartBrush Brush {get; set;}

解説

キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。Brush.Visibleプロパティをtrueに設定しなければなりません。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Brush.Visible = true;
     g.Brush.Style = HatchStyle.DiagonalCross;
     g.BackColor = Color.Yellow;

     Rectangle r = new Rectangle(100,100,145,155);
     g.Rectangle(r,10);
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


CanvasType

Steema.TeeChart.Drawing.Graphics3D.CanvasType プロパティ

チャートを描くために使用するキャンバスのタイプを取得します。
public CanvasType CanvasType {get;}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ChartXCenter

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ChartXCenter プロパティ

チャートの水平方向に対する中央の座標値を返します。

public Int32 ChartXCenter {get;}

解説

チャートの水平方向に対する中央の座標値を返します。

これはChart1.Width / 2と同じではありません。チャートマージン、軸マージン、凡例幅、などがチャートの水平サイズから最初に引かれるからです。

たとえば、円系列は円の中心を返すためにChartXCenterを使用します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ChartYCenter

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ChartYCenter プロパティ

チャートの垂直方向に対する中央の座標値を返します。

public Int32 ChartYCenter {get;}

解説

チャートの垂直方向に対する中央の座標値を返します。

これはChart1.Height / 2と同じではありません。チャートマージン、軸マージン、凡例幅、などがチャートの垂直サイズから最初に引かれるからです。

たとえば、円系列は円の中心を返すためにChartYCenterを使用します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ColorPalette

Steema.TeeChart.Drawing.Graphics3D.ColorPalette プロパティ

public static Color[] ColorPalette {get; set;}

解説

色の配列を取得/設定します。
この配列は、系列のColorEachプロパティがtrueの場合に、系列のデフォルトの色や各系列ポイントの色を定義するために使用されます。

GetDefaultColorメソッドはこの変数を使用します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Font

Steema.TeeChart.Drawing.Graphics3D.Font プロパティ

キャンバスに出力するテキストのフォントを定義します。
public ChartFont Font {get; set;}

解説

キャンバスに出力するテキストのフォントを定義します。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     g.Chart.Graphics3D.Font.Bold =true;
     g.Chart.Graphics3D.Font.Size = 40;
     g.Chart.Graphics3D.Font.Brush.Transparency = 70;
     g.Chart.Graphics3D.TextOut(150,160,"My Chart");
}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


FontHeight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.FontHeight プロパティ

ピクセル単位でフォントの高さを定義します。

public Int32 FontHeight {get;}

読み込み専用

解説

キャンバスのフォントの高さを返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Gradient

Steema.TeeChart.Drawing.Graphics3D.Gradient プロパティ

キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
public Gradient Gradient {get; set;}

解説

キャンバスの矩形背景を塗りつぶすグラデーションを定義します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Pen

Steema.TeeChart.Drawing.Graphics3D.Pen プロパティ

キャンバスに線を描くペンの種類を取得/設定します。
public ChartPen Pen {get; set;}

解説

キャンバスに線を描くペンの種類を取得/設定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RotationCenter

Steema.TeeChart.Drawing.Graphics3D.RotationCenter プロパティ

Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
public PointXYZ RotationCenter {get; set;}

解説

0から359度の間の整数で設定してください。この角度は、円（あるいは極）を回転させるために、コードにより変更できます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


RotationCenterFloat

Steema.TeeChart.Drawing.Graphics3D.RotationCenterFloat プロパティ

Aspect.Rotationプロパティの使用のための回転の中心のピクセル位置（X,Y,Zを使用）を設定します。
public Point3DDouble RotationCenterFloat {get; set;}

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ScreenHeight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.ScreenHeight プロパティ

チャートパネルの高さをピクセル単位で返します。

public static Int32 ScreenHeight {get;}

解説

読込み専用

チャートパネルの高さをピクセル単位で返します。パネルの高さに関連する描画を行うには、Canvasメソッドを使用してください。TChart.Heightプロパティを使用しないでください。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


ScreenWidth

Steema.TeeChart.Drawing.Graphics3D.ScreenWidth プロパティ

ピクセル単位でチャートパネルの幅を返します。
public static Int32 ScreenWidth {get;}

解説

ピクセル単位でチャートパネルの幅を返します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SmoothingMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.SmoothingMode プロパティ

スムーシング（アンチエイリアシング）モード。

public SmoothingMode SmoothingMode {get; set;}

カスタム描画の時のグラフィックペンのアンチエイリアスモードを設定するために使用してください。

AntiAlias - アンチエイリアス処理されたレタリングを指定します。
Default - 既定のモードを指定します。
HighQuality - 高品質で低速なレンダリングを指定します。
HighSpeed - 高速で、低品質のレンダリングを指定します。
Invalid - 無効なモードを指定します。
None - アンチエイリアス処理しないことを指定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Supports3DText

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.Supports3DText プロパティ

キャンバスが3Dテキストをサポートするかどうかを返します。

public Boolean Supports3DText {get; set;}

解説

キャンバスが3Dテキストをサポートするかどうかを返します。

例

[C#]

MessageBox.Show(tChart1.Chart.Graphics3D.Supports3DText.ToString());

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


SupportsFullRotation

Steema.TeeChart.Drawing.Graphics3D.SupportsFullRotation プロパティ

キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
public abstract Boolean SupportsFullRotation {get;}

解説

キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。

例

[C#]

MessageBox.Show(tChart1.Chart.Graphics3D.SupportsFullRotation.ToString());

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextAlign

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.TextAlign プロパティ

TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。

public StringAlignment TextAlign {get; set;}

解説

TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


TextRenderingHint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.TextRenderingHint プロパティ

テキスト作成するための、スピードあるいは描画品質を選択します。

public TextRenderingHint TextRenderingHint {get; set;}

カスタムテキストを出力する時の、スピードあるいは描画品質を選択します。

AntiAlias - アンチエイリアス処理されたグリフ ビットマップを使用して、ヒンティングなしに各文字を描画することを指定します。アンチエイリアスによって品質が向上します。ヒンティングがオフにされるため、ステム幅の違いが目立ちます。
AntiAliasGridFit - アンチエイリアス処理されたグリフ ビットマップを使用して、ヒンティングありで各文字を描画することを指定します。アンチエイリアスによってより高い品質が得られますが、パフォーマンスは大きく低下します。
ClearTypeGridFit - グリフ CT ビットマップを使用して、ヒンティングありで各文字を描画することを指定します。最高の品質設定です。ClearType テキスト フォント機能を利用するときに使用します。
SingleBitPerPixel - グリフ ビットマップを使用して、各文字を描画することを指定します。ヒンティングは使用されません。
SingleBitPerPixelGridFit - グリフ ビットマップを使用して、各文字を描画することを指定します。ヒンティングを使用して、文字のステム部分と曲線部分の見た目を向上します。
SystemDefault - グリフ ビットマップを使用し、システムの既定のレンダリング ヒントで各文字を描画することを指定します。ユーザーがシステムで選択した、すべてのフォント スムージング設定を使用してテキストを描画します。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


UseBuffer

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.UseBuffer プロパティ

画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。

public Boolean UseBuffer {get; set;}

解説

最初に内部キャンバスにアイテムを描画し、その後、画面に描画します。これは画面のチラツキを防ぎます。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


XCenter

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.XCenter プロパティ

3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。

public Int32 XCenter {get; set;}

解説

3Dキャンバスの中央のX座標をピクセル単位で取得/設定するために使用してください。

ピクセル座標システムの原点は、ウィンドウの左上の角になります。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


YCenter

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3D.YCenter プロパティ

3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

public Int32 YCenter {get; set;}

解説

3Dキャンバスの中央のY座標をピクセル単位で取得/設定するために使用してください。

ピクセル座標システムの原点は、ウィンドウの左上の角になります。

参照

Graphics3D クラス | Graphics3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D.Pie3D

Steema.TeeChart.Drawing.Graphics3D.Pie3D クラス

この型のすべてのメンバの一覧については、Pie3D メンバを参照してください。

System.Object
public class Pie3D : Object

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Pie3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D.Pie3D 全メンバ

Pie3D 概要

パブリック フィールド

OldColor

パブリック メソッド

Pie
PointD

コンストラクタ

Steema.TeeChart.Drawing.Graphics3D.Pie3D..ctor

参照

Pie3D クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D.Pie3D フィールド

パブリック フィールド

OldColor

参照

Pie3D クラス | Steema.TeeChart.Drawing 名前空間


OldColor

Steema.TeeChart.Drawing.Graphics3D+Pie3D.OldColor フィールド

public Color OldColor

参照

Pie3D クラス | Pie3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D.Pie3D メソッド

パブリック メソッド

Pie
PointD

参照

Pie3D クラス | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3D+Pie3D.Pie メソッド

public Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

参照

Pie3D クラス | Pie3D メンバ | Steema.TeeChart.Drawing 名前空間


PointD

Steema.TeeChart.Drawing.Graphics3D+Pie3D.PointD メソッド

public PointDouble PointD(Rectangle rect,
     Double angle,
     Int32 z)

参照

Pie3D クラス | Pie3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3D+Pie3D コンストラクタ

public Graphics3D+Pie3D(Graphics3D graphics)

参照

Pie3D クラス | Pie3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DEPS

Steema.TeeChart.Drawing.Graphics3DEPS クラス

Postscriptキャンバス。

この型のすべてのメンバの一覧については、Graphics3DEPS メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DEPS : Graphics3DVec , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DEPS 全メンバ

Graphics3DEPS 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | x,y座標にイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DEPS クラス | Steema.TeeChart.Drawing 名前空間


Graphics3DEPS コンストラクタ

Steema.TeeChart.Drawing.Graphics3DEPS コンストラクタ

public Graphics3DEPS(EPSData epsdata,
     Chart c)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DEPS フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DEPS クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DEPS メソッド

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | x,y座標にイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DEPS クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DEPS.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

解説

現在のペンを使用して楕円状の弧を描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DEPS.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DEPS.Arc メソッド

現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DEPS.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DEPS.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。

public override Void ClipEllipse(Rectangle r)

解説

楕円のWindows GDIクリッピング領域を作成します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DEPS.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。

public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DEPS.ClipRectangle メソッド

オーバーロードの一覧

矩形のWindows GDIクリッピング領域を作成します。

public override Void ClipRectangle(System.Drawing.Rectangle)

解説

矩形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DEPS.ClipRectangle メソッド

矩形のWindows GDIクリッピング領域を作成します。

public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


DoText

Steema.TeeChart.Drawing.Graphics3DEPS.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degangle,
     Color c)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DEPS.Draw メソッド

オーバーロードの一覧

矩形「r」内にイメージを描画します。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

x,y座標にイメージを描画します。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

解説

イメージを描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DEPS.Draw メソッド

矩形「r」内にイメージを描画します。

public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DEPS.Draw メソッド

x,y座標にイメージを描画します。

public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DEPS.DrawBeziers メソッド

オーバーロードの一覧

Point配列pのベジェスプライン曲線を描画します。

public override Void DrawBeziers(System.Drawing.Point[])

解説

ベジェスプライン曲線を描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DEPS.DrawBeziers メソッド

Point配列pのベジェスプライン曲線を描画します。

public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3DEPS.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DEPS.Ellipse メソッド

オーバーロードの一覧

指定した座標内に楕円を描画します。

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

解説

楕円を描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DEPS.Ellipse メソッド

指定した座標内に楕円を描画します。

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

Steema.TeeChart.Drawing.Graphics3DEPS.EraseBackground メソッド

指定した矩形領域の背景をクリアします。

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

指定した矩形領域の背景をクリアします。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DEPS.FillRegion メソッド

領域の内側を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶしの特性を定義します。
region
塗りつぶす領域を定義します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DEPS.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DEPS.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DEPS.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(System.Int32, System.Int32)

解説

現在のペンの位置から新しい座標に線を描きます。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DEPS.LineTo メソッド

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

Steema.TeeChart.Drawing.Graphics3DEPS.Pixel メソッド

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DEPS.PointToStr メソッド

protected abstract String PointToStr(Int32 x,
     Int32 y)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DEPS.PointToStr メソッド

protected abstract String PointToStr(Double X,
     Double Y)

参照

PointToStr オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DEPS.PointToStr メソッド

protected abstract String PointToStr(Int32 x,
     Int32 y)

参照

PointToStr オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DEPS.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

多角形を描きます。

public override Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DEPS.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DEPS.Polygon メソッド

多角形を描きます。
public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DEPS.Polyline メソッド

オーバーロードの一覧

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(System.Drawing.Point[])

解説

zの変位でのPoint配列pを接続するラインセグメントを描画します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DEPS.Polyline メソッド

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DEPS.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DEPS.RotateLabel メソッド

オーバーロードの一覧

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

解説

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。RotDegreeの値は0から360までの値でなければなりません。文字列はチャートの描画キャンバスに出力されます。

例
[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DEPS.RotateLabel メソッド

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。

public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DEPS.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DEPS.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

キャンバスを別の位置にコピーします。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DEPS.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DEPS.UnClip メソッド

チャートキャンバスに適用されるすべてのクリッピング領域を削除します。

public override Void UnClip()

解説

チャートキャンバスに適用されるすべてのクリッピング領域を削除します。

参照

Graphics3DEPS クラス | Graphics3DEPS メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DEPS プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DEPS クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex

Steema.TeeChart.Drawing.Graphics3DFlex クラス

この型のすべてのメンバの一覧については、Graphics3DFlex メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DFlex : Graphics3DVec , IComponent, IDisposable
, ICanvasHyperlinks, ICanvasToolTips

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex 全メンバ

Graphics3DFlex 概要

コンストラクタ

コンストラクタ

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

AddLink |
AddToolTip |
Arc |
Arrow (Graphics3Dの継承元) | ピクセル単位のheadWidthパラメーターとheadHeightパラメーターのサイズの矢印ヘッドを持つ線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算し、返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算して返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算して返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse |
ClipPolygon |
ClipRectangle |
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2Dのxyポイントの凸面の境界ポイントを計算します。オリジナル。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw |
DrawBeziers |
DrawPath |
Elevate (Graphics3Dの継承元) |
Ellipse |
EllipseEnh (Graphics3Dの継承元) | 指定したZ位置と(X1,Y1,X2,Y2)の境界矩形内に拡張した楕円を描きます。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground |
FillRectangle (Graphics3Dの継承元) |
FillRegion |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | TFourPoints 構造体を返します。（4つのTPoint レコードの配列）
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZで移動された領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平方向の線を描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo |
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 上部の切り取られた四角錐を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイントの配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球体を描きます。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | ChartFontのfパラメーターの垂直テキストサイズをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定したxyz画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | Z位置に三角形を描きます。
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0) から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
EmbeddedImages |
Font (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントを定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
ImagePath |
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティの使用のための回転の中心のピクセル位置（X,Y,Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティの使用のための回転の中心のピクセル位置（X,Y,Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキスト作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DFlex クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex コンストラクタ

public Graphics3DFlex(Stream istream,
     Chart c)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

参照

Graphics3DFlex クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex メソッド

パブリック メソッド

AddLink |
AddToolTip |
Arc |
Arrow (Graphics3Dの継承元) | ピクセル単位のheadWidthパラメーターとheadHeightパラメーターのサイズの矢印ヘッドを持つ線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算し、返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算して返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算して返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse |
ClipPolygon |
ClipRectangle |
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2Dのxyポイントの凸面の境界ポイントを計算します。オリジナル。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw |
DrawBeziers |
DrawPath |
Elevate (Graphics3Dの継承元) |
Ellipse |
EllipseEnh (Graphics3Dの継承元) | 指定したZ位置と(X1,Y1,X2,Y2)の境界矩形内に拡張した楕円を描きます。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground |
FillRectangle (Graphics3Dの継承元) |
FillRegion |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | TFourPoints 構造体を返します。（4つのTPoint レコードの配列）
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZで移動された領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平方向の線を描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo |
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 上部の切り取られた四角錐を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイントの配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球体を描きます。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | ChartFontのfパラメーターの垂直テキストサイズをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定したxyz画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | Z位置に三角形を描きます。
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0) から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DFlex クラス | Steema.TeeChart.Drawing 名前空間


AddLink

Steema.TeeChart.Drawing.Graphics3DFlex.AddLink メソッド

public virtual Void AddLink(Int32 x,
     Int32 y,
     String Text,
     String URL,
     String Hint)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


AddToolTip

Steema.TeeChart.Drawing.Graphics3DFlex.AddToolTip メソッド

public virtual Void AddToolTip(String Entity,
     String ToolTip)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DFlex.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)
public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DFlex.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DFlex.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DFlex.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DFlex.ClipEllipse メソッド

public override Void ClipEllipse(Rectangle r)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DFlex.ClipPolygon メソッド

public override Void ClipPolygon(Point[] p)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DFlex.ClipRectangle メソッド

オーバーロードの一覧

public override Void ClipRectangle(System.Drawing.Rectangle)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DFlex.ClipRectangle メソッド

public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


DoText

Steema.TeeChart.Drawing.Graphics3DFlex.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degangle,
     Color c)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DFlex.Draw メソッド

オーバーロードの一覧

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)
public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DFlex.Draw メソッド

public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DFlex.Draw メソッド

public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DFlex.DrawBeziers メソッド

オーバーロードの一覧

public override Void DrawBeziers(System.Drawing.Point[])

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DFlex.DrawBeziers メソッド

public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3DFlex.DrawPath メソッド

public override Void DrawPath(Pen pen,
     GraphicsPath path)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DFlex.Ellipse メソッド

オーバーロードの一覧

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DFlex.Ellipse メソッド

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

Steema.TeeChart.Drawing.Graphics3DFlex.EraseBackground メソッド

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DFlex.FillRegion メソッド

public override Void FillRegion(Brush brush,
     Region region)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DFlex.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DFlex.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DFlex.LineTo メソッド

オーバーロードの一覧

public override Void LineTo(System.Int32, System.Int32)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DFlex.LineTo メソッド

public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

Steema.TeeChart.Drawing.Graphics3DFlex.Pixel メソッド

public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DFlex.PointToStr メソッド

オーバーロードの一覧

protected abstract String PointToStr(System.Int32, System.Int32)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DFlex.PointToStr メソッド

protected abstract String PointToStr(Int32 X,
     Int32 Y)

参照

PointToStr オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DFlex.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])
public override Void Polygon(System.Drawing.Point[])

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DFlex.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DFlex.Polygon メソッド

public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DFlex.Polyline メソッド

オーバーロードの一覧

public override Void Polyline(System.Drawing.Point[])

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DFlex.Polyline メソッド

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DFlex.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DFlex.RotateLabel メソッド

オーバーロードの一覧

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DFlex.RotateLabel メソッド

public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DFlex.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DFlex.ShowImage メソッド

public override Void ShowImage(Graphics g)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DFlex.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DFlex.UnClip メソッド

public override Void UnClip()

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DFlex プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
EmbeddedImages |
Font (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントを定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
ImagePath |
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティの使用のための回転の中心のピクセル位置（X,Y,Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティの使用のための回転の中心のピクセル位置（X,Y,Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキスト作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DFlex クラス | Steema.TeeChart.Drawing 名前空間


EmbeddedImages

Steema.TeeChart.Drawing.Graphics3DFlex.EmbeddedImages プロパティ

public Boolean EmbeddedImages {get; set;}

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


ImagePath

Steema.TeeChart.Drawing.Graphics3DFlex.ImagePath プロパティ

public String ImagePath {get; set;}

参照

Graphics3DFlex クラス | Graphics3DFlex メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus

Steema.TeeChart.Drawing.Graphics3DGdiPlus クラス

主要のチャート描画エレメントにアクセスします。

この型のすべてのメンバの一覧については、Graphics3DGdiPlus メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
public class Graphics3DGdiPlus : Graphics3D , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus 全メンバ

Graphics3DGdiPlus 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions | クライアントのクリップ領域を含む、チャートキャンバスに適用されるすべてのクリッピング領域を削除します。
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 水平直線を描画します。
IniWindow |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | 座標間に線を描きます。
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo | LineToメソッドを呼び出す前に線の開始位置を設定します。
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | 開始角度、終了角度を使用してパイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState |
VerticalLine | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Graphics | グラフィックの描画にアクセスします。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
currentX
currentY
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString |
Full3DCylinder |
GetInferiorBounds | 内部使用。InternalCylinderをサポートします。
GetRotationCenter (Graphics3Dの継承元) |
GetSuperiorBounds | 内部使用。InternalCylinderをサポートします。
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder |
IsRectangle (Graphics3Dの継承元) |
Line | 座標間に線を描きます。
PlotCylinderEllipse | 内部使用。InternalCylinderをサポートします。
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DGdiPlus クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus コンストラクタ

オーバーロードの一覧

public Graphics3DGdiPlus()
public Graphics3DGdiPlus(Steema.TeeChart.Chart)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus コンストラクタ

public Graphics3DGdiPlus()

参照

Graphics3DGdiPlus コンストラクタのオーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus コンストラクタ

public Graphics3DGdiPlus(Chart c)

参照

Graphics3DGdiPlus コンストラクタのオーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
currentX
currentY
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DGdiPlus クラス | Steema.TeeChart.Drawing 名前空間


currentX

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.currentX フィールド

protected Int32 currentX

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


currentY

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.currentY フィールド

protected Int32 currentY

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus メソッド

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions | クライアントのクリップ領域を含む、チャートキャンバスに適用されるすべてのクリッピング領域を削除します。
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 水平直線を描画します。
IniWindow |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | 座標間に線を描きます。
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo | LineToメソッドを呼び出す前に線の開始位置を設定します。
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | 開始角度、終了角度を使用してパイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState |
VerticalLine | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString |
Full3DCylinder |
GetInferiorBounds | 内部使用。InternalCylinderをサポートします。
GetRotationCenter (Graphics3Dの継承元) |
GetSuperiorBounds | 内部使用。InternalCylinderをサポートします。
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder |
IsRectangle (Graphics3Dの継承元) |
Line | 座標間に線を描きます。
PlotCylinderEllipse | 内部使用。InternalCylinderをサポートします。
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DGdiPlus クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Arc メソッド

オーバーロードの一覧

4座標で定義された矩形内に弧を描きます。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

現在のペンで楕円状の曲線で弧を描きます。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

解説

現在のペンで楕円状の曲線で弧を描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Arc

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Arc メソッド

4座標で定義された矩形内に弧を描きます。

public virtual Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Arc

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Arc メソッド

現在のペンで楕円状の曲線で弧を描きます。

public virtual Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ClearClipRegions メソッド

クライアントのクリップ領域を含む、チャートキャンバスに適用されるすべてのクリッピング領域を削除します。

public override Void ClearClipRegions()

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。
public override Void ClipEllipse(Rectangle r)

解説

Rect座標パラメータの内側に含まれる楕円の内側あるいは外側にキャンバスの出力を制限します。

InvertedパラメータがTrueの場合、楕円の外側のみにキャンバスの出力を制限します。

InvertedパラメータがFalseの場合、楕円の内側のみにキャンバスの出力を制限します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。
public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ClipRectangle メソッド

オーバーロードの一覧

矩形のWindows GDI クリッピング領域を作成します。

public override Void ClipRectangle(System.Drawing.Rectangle)

解説

ClipRectangleメソッドは、Windows GDIのクリッピング領域を作成して、それをTChart.Canvasのデバイスコンテキストハンドルに選択します。

UnClipRectangleメソッドは、TChart.Canvasに適用されている全てのクリッピング領域を削除します。

このメソッドを使用すると、系列やカスタム描画が設定した矩形範囲まで描画されます。

メモ:メタファイルを印刷および作成すると、クリッピング領域を論理ピクセルで受け付けなくなります。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ClipRectangle メソッド

矩形のWindows GDIクリッピング領域を作成します。

public virtual Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


DoDrawString

Steema.TeeChart.Drawing.Graphics3DGdiPlus.DoDrawString メソッド

protected abstract Void DoDrawString(Int32 x,
     Int32 y,
     String text,
     ChartBrush aBrush)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Draw メソッド

オーバーロードの一覧

public Void Draw(System.Drawing.Point[], System.Drawing.Image, System.Boolean)

矩形rにイメージを描画します。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

x,y座標にイメージを描画します。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

解説

指定したキャンバスや領域にチャートを描画するために使用してください。

これは、カスタマイズしたチャートを印刷する場合にも使用できます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Draw メソッド

矩形rにイメージを描画します。

public virtual Void Draw(Rectangle r,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Draw メソッド

x、y座標にイメージを描画します。

public virtual Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Draw メソッド

x,y座標にイメージを描画します。
public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DGdiPlus.DrawBeziers メソッド

オーバーロードの一覧

Point配列pをベジェ曲線で描きます。

public override Void DrawBeziers(System.Drawing.Point[])

解説

Point配列pをベジェ曲線で描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.DrawBeziers メソッド

pのベジェスプライン曲線を描画します。

public virtual Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3DGdiPlus.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Ellipse メソッド

オーバーロードの一覧

2つの座標間に楕円を描画します。

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

解説

2つの座標間に楕円を描画します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Ellipse メソッド

指定した座標内に楕円を描画します。

public virtual Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

Steema.TeeChart.Drawing.Graphics3DGdiPlus.EraseBackground メソッド

Left、Top、Right、Bottomで定義した矩形範囲の背面を削除します。
public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

Left、Top、Right、Bottomで定義した矩形範囲の背面を削除します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DGdiPlus.FillRegion メソッド

指定した領域内を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶし特性を定義します。
region
塗りつぶし領域を定義します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Full3DCylinder

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Full3DCylinder メソッド

protected Void Full3DCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


GetInferiorBounds

Steema.TeeChart.Drawing.Graphics3DGdiPlus.GetInferiorBounds メソッド

内部使用。InternalCylinderをサポートします。

protected Void GetInferiorBounds(Boolean vertical,
     PathData pData,
     Single& xPoint,
     Single& yPoint)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


GetSuperiorBounds

Steema.TeeChart.Drawing.Graphics3DGdiPlus.GetSuperiorBounds メソッド

内部使用。InternalCylinderをサポートします。

protected Void GetSuperiorBounds(Boolean vertical,
     PathData pData,
     Single& xPoint,
     Single& yPoint)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

Steema.TeeChart.Drawing.Graphics3DGdiPlus.HorizontalLine メソッド

オーバーロードの一覧

水平直線を描きます。

public override Void HorizontalLine(System.Int32, System.Int32, System.Int32)

解説

Left,Y,ZからRight,Y,Zまでの線を描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.HorizontalLine メソッド

水平直線を描きます。

public virtual Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

参照

HorizontalLine オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DGdiPlus.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


IniWindow

Steema.TeeChart.Drawing.Graphics3DGdiPlus.IniWindow メソッド

public Void IniWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


InternalCylinder

Steema.TeeChart.Drawing.Graphics3DGdiPlus.InternalCylinder メソッド

protected abstract Void InternalCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Line メソッド

オーバーロードの一覧

protected override Void Line(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Point, System.Drawing.Point)

座標間に線を描きます。

public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32)

解説

座標間に線を描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Line メソッド

protected override Void Line(ChartPen p,
     Point a,
     Point b)

参照

Line オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Line

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Line メソッド

座標間に線を描きます。

public virtual Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

参照

Line オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DGdiPlus.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(System.Int32, System.Int32)

解説

現在のペンの位置（MoveToメソッドを参照）から新しい座標に線を描きます。

例

[C#]
// Zオフセットなしで線を描きます。
tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.LineTo メソッド

現在のペンの位置から新しい座標に線を描きます。

public virtual Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


MeasureString

Steema.TeeChart.Drawing.Graphics3DGdiPlus.MeasureString メソッド

public override SizeF MeasureString(ChartFont f,
     String text)

解説

指定したフォントの文字列のSizeFを返します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3DGdiPlus.MoveTo メソッド

オーバーロードの一覧

LineToメソッドを呼び出す前にxとy座標で線の開始位置を設定します。

public override Void MoveTo(System.Int32, System.Int32)

解説

LineToメソッドを呼び出す前にxとy座標で線の開始位置を設定します。

例

[C#]

tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3DGdiPlus.MoveTo メソッド

LineToメソッドを呼び出す前に、線の描画を開始するxy座標を設定します。

public override Void MoveTo(Int32 x,
     Int32 y)

参照

MoveTo オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Pie メソッド

オーバーロードの一覧

StartAngleやEnd Angleを使用してパイスライスを描きます。

public override Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double)

解説

パイスライスを描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Pie

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Pie メソッド

StartAngleやEnd Angleを使用してパイスライスを描きます。

public virtual Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Double startAngle,
     Double endAngle)

参照

Pie オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Pixel メソッド

Pen.Widthを使用してOLE_Colorに3Dピクセルを設定します。
public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用してOLE_Colorに3Dピクセルを設定します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


PlotCylinderEllipse

Steema.TeeChart.Drawing.Graphics3DGdiPlus.PlotCylinderEllipse メソッド

内部使用。InternalCylinderをサポートします。
protected GraphicsPath PlotCylinderEllipse(Boolean vertical,
     Matrix m,
     GraphicsPath gPath,
     Int32 left,
     Int32 top,
     Int32 width,
     Int32 height,
     PointF& p1,
     PointF& p2)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

多角形を描きます。

public override Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Polygon メソッド

多角形を描きます。
public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Polyline メソッド

オーバーロードの一覧

z深さでp配列のすべてのポイントを接続するラインセグメントを描画します。

public override Void Polyline(System.Drawing.Point[])

解説

z深さでp配列のすべてのポイントを接続するラインセグメントを描画します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Polyline メソッド

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DGdiPlus.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画するためにチャートキャンバスを用意します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Rectangle メソッド

オーバーロードの一覧

矩形を描きます。

public override Void Rectangle(System.Drawing.Rectangle)

解説

矩形を描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Rectangle メソッド

矩形を描きます。
public override Void Rectangle(Rectangle r)

参照

Rectangle オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DGdiPlus.RotateLabel メソッド

オーバーロードの一覧

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

解説

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。RotDegree値は、0～360の間で指定してください。チャートの描画キャンバス上に文字列を出力します。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.RotateLabel メソッド

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。

public virtual Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DGdiPlus.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

ほかの位置にキャンバスをコピーします。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DGdiPlus.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DGdiPlus.UnClip メソッド

チャートキャンバスに適用されるクリッピング領域をすべて削除します。
public override Void UnClip()

解説

チャートキャンバスに適用されるクリッピング領域をすべて削除します。クリッピング領域は、矩形の座標外に描画しないために使用されます。これは、マーカや系列ポイントをChartRectの矩形の外側に表示しておくために内部で使用されます。

メモ：メタファイルはクリッピング領域を受け付けません。メタファイルフォーマットは、印刷の際に使用されます。つまり、クリッピングは実行されません。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


ValidState

Steema.TeeChart.Drawing.Graphics3DGdiPlus.ValidState メソッド

public override Boolean ValidState()

解説

チャートキャンバスが描画できる場合、trueを返します。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

Steema.TeeChart.Drawing.Graphics3DGdiPlus.VerticalLine メソッド

オーバーロードの一覧

(X,Top)から(X,Bottom)まで垂直線を描きます。

public override Void VerticalLine(System.Int32, System.Int32, System.Int32)

解説

垂直線を描きます。

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.VerticalLine メソッド

(X,Top) から (X,Bottom)に垂直線を描きます。

public virtual Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

参照

VerticalLine オーバーロードの一覧 | Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DGdiPlus プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Graphics | グラフィックの描画にアクセスします。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DGdiPlus クラス | Steema.TeeChart.Drawing 名前空間


Graphics

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Graphics3DGdiPlus.Graphics プロパティ

グラフィックの描画にアクセスします。

public Graphics Graphics {get;}

参照

Graphics3DGdiPlus クラス | Graphics3DGdiPlus メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DPDF

Steema.TeeChart.Drawing.Graphics3DPDF クラス

AdobeのPDFキャンバス。

この型のすべてのメンバの一覧については、Graphics3DPDF メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DPDF : Graphics3DVec , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DPDF 全メンバ

Graphics3DPDF 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | x,y座標にイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | 開始角度、終了角度を使用してパイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DPDF クラス | Steema.TeeChart.Drawing 名前空間


Graphics3DPDF コンストラクタ

Steema.TeeChart.Drawing.Graphics3DPDF コンストラクタ

public Graphics3DPDF(PDFData pdfdata,
     Chart c)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DPDF フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DPDF クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DPDF メソッド

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | x,y座標にイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | 開始角度、終了角度を使用してパイスライスを描きます。
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DPDF クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DPDF.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

解説

現在のペンを使用して楕円状の弧を描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DPDF.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DPDF.Arc メソッド

現在のペンを使用して楕円状の弧を描画するには、このメソッドを使用してください。

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DPDF.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DPDF.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。

public override Void ClipEllipse(Rectangle r)

解説

Rect座標パラメーターに含まれる楕円領域の内側または外側に出力を制限します。

InvertedパラメーターがTrueの場合、楕円の外側にのみ出力されます。

InvertedがFalseの場合、楕円の内側にのみ出力できます。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DPDF.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。

public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DPDF.ClipRectangle メソッド

オーバーロードの一覧

矩形のクリッピング領域を作成します。

public override Void ClipRectangle(System.Drawing.Rectangle)

解説

Windows GDIクリッピング領域を作成し、TChart.Canvasのデバイスコンテキストのハンドルで選択します。

UnClipRectangleメソッドは、TChart.Canvasに適応されるすべてのクリッピング領域を削除します。

このメソッドは、系列あるいはカスタム描画を指定した矩形座標外に描画させないために使用できます。

メモ：印刷やメタファイル作成は、論理ピクセルでのクリッピング領域に対応しません。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DPDF.ClipRectangle メソッド

矩形のクリッピング領域を作成します。

public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


DoText

Steema.TeeChart.Drawing.Graphics3DPDF.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double rotrad,
     Color c)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DPDF.Draw メソッド

オーバーロードの一覧

矩形「r」内にイメージを描画します。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

x,y座標にイメージを描画します。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

解説

このメソッドを使用して、指定したキャンバスや領域にチャートを描画します。

また、PrintChartを使用して、カスタマイズしたチャートを印刷することもできます。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DPDF.Draw メソッド

矩形「r」内にイメージを描画します。

public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DPDF.Draw メソッド

x,y座標にイメージを描画します。

public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DPDF.DrawBeziers メソッド

オーバーロードの一覧

Point配列pのベジェスプライン曲線を描画します。

public override Void DrawBeziers(System.Drawing.Point[])

解説

Point配列pのベジェスプライン曲線を描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DPDF.DrawBeziers メソッド

Point配列pのベジェスプライン曲線を描画します。

public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3DPDF.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DPDF.Ellipse メソッド

オーバーロードの一覧

指定した座標間に楕円を描画します。

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

解説

指定した座標間に楕円を描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DPDF.Ellipse メソッド

指定した座標間に楕円を描画します。

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

Steema.TeeChart.Drawing.Graphics3DPDF.EraseBackground メソッド

指定した矩形領域の背景をクリアします。

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

指定した矩形領域の背景をクリアします。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DPDF.FillRegion メソッド

領域の内側を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶしの特性を定義します。
region
塗りつぶす領域を定義します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DPDF.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DPDF.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DPDF.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(System.Int32, System.Int32)

解説

現在のペンの位置（MoveToを参照）から新しい座標に線を描きます。LineToメソッドには、Point pまたはzパラメーターを持つ/持たない x(int) や y(int) を使用して終了座標を設定する4つのオーバーロードがあります。

例

[C#]
// Zオフセットなしの線を描きます。;
tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DPDF.LineTo メソッド

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3DPDF.Pie メソッド

オーバーロードの一覧

StartAngleやEndAngleを使用してパイスライスを描画します。

public override Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double)

解説

パイスライスを描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Pie

Steema.TeeChart.Drawing.Graphics3DPDF.Pie メソッド

StartAngleやEndAngleを使用してパイスライスを描画します。

public override Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Double startAngle,
     Double endAngle)

参照

Pie オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

Steema.TeeChart.Drawing.Graphics3DPDF.Pixel メソッド

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DPDF.PointToStr メソッド

protected abstract String PointToStr(Int32 x,
     Int32 y)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DPDF.PointToStr メソッド

protected abstract String PointToStr(PointDouble p)

参照

PointToStr オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DPDF.PointToStr メソッド

protected abstract String PointToStr(Point p)

参照

PointToStr オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DPDF.PointToStr メソッド

protected abstract String PointToStr(Int32 x,
     Int32 y)

参照

PointToStr オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DPDF.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

多角形を描きます。

public override Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DPDF.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DPDF.Polygon メソッド

多角形を描きます。
public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DPDF.Polyline メソッド

オーバーロードの一覧

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(System.Drawing.Point[])

解説

zの変位でのPoint配列pを接続するラインセグメントを描画します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DPDF.Polyline メソッド

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DPDF.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DPDF.RotateLabel メソッド

オーバーロードの一覧

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

解説

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。RotDegreeの値は0から360の間でなければなりません。文字列はチャートの描画キャンバスに出力されます。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DPDF.RotateLabel メソッド

指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。

public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DPDF.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DPDF.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

キャンバスを別の位置にコピーします。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DPDF.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DPDF.UnClip メソッド

チャートキャンバスに適用されるすべてのクリッピング領域を削除します。

public override Void UnClip()

解説

チャートキャンバスに適用されるすべてのクリッピング領域を削除します。クリッピング領域は指定した矩形座標外に描画しないために使用されます。マーカや系列ポイントをChartRectの矩形の外側に描画するために内部的に使用されます。

メモ：メタファイルはクリッピング領域を適用しません。メタファイル形式は印刷の際に使用されるので、クリッピングは実行されません。

参照

Graphics3DPDF クラス | Graphics3DPDF メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DPDF プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DPDF クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DSVG

Steema.TeeChart.Drawing.Graphics3DSVG クラス

Graphics3DSVGの概略説明。

この型のすべてのメンバの一覧については、Graphics3DSVG メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DSVG : Graphics3DVec , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DSVG 全メンバ

Graphics3DSVG 概要

コンストラクタ

Constructor

パブリック フィールド

AntiAliasing
DocType
FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DSVG クラス | Steema.TeeChart.Drawing 名前空間


Graphics3DSVG コンストラクタ

Steema.TeeChart.Drawing.Graphics3DSVG コンストラクタ

public Graphics3DSVG(Stream istream,
     Chart c)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DSVG フィールド

パブリック フィールド

AntiAliasing
DocType
FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DSVG クラス | Steema.TeeChart.Drawing 名前空間


AntiAliasing

Steema.TeeChart.Drawing.Graphics3DSVG.AntiAliasing フィールド

public Boolean AntiAliasing

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DocType

Steema.TeeChart.Drawing.Graphics3DSVG.DocType フィールド

public String DocType

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Drawing.Graphics3DSVG メソッド

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DSVG クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DSVG.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

現在のペンで楕円状の曲線で弧を描きます。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

解説

現在のペンで楕円状の曲線で弧を描きます。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DSVG.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Arc

Steema.TeeChart.Drawing.Graphics3DSVG.Arc メソッド

現在のペンで楕円状の曲線で弧を描きます。
public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DSVG.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DSVG.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。
public override Void ClipEllipse(Rectangle r)

解説

Rect座標パラメータの内側に含まれる楕円の内側あるいは外側にキャンバスの出力を制限します。

InvertedパラメータがTrueの場合、楕円の外側のみにキャンバスの出力を制限します。

InvertedパラメータがFalseの場合、楕円の内側のみにキャンバスの出力を制限します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DSVG.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。
public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DSVG.ClipRectangle メソッド

オーバーロードの一覧

矩形のWindows GDIクリッピング領域を作成します。

public override Void ClipRectangle(System.Drawing.Rectangle)

解説

Windows GDIクリッピング領域を作成し、それを選択してTChart.Canvasデバイスコンテキストハンドルに入れます。

UnClipRectangleメソッドは、TChart.Canvasに適用されるすべてのクリッピング領域を削除します。

このメソッドを使用すると、系列やカスタム描画が設定した矩形範囲まで描画されます。

メモ:メタファイルを印刷および作成すると、クリッピング領域を論理ピクセルで受け付けなくなります。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DSVG.ClipRectangle メソッド

矩形のWindows GDIクリッピング領域を作成します。
public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DoText

Steema.TeeChart.Drawing.Graphics3DSVG.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degangle,
     Color c)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DSVG.Draw メソッド

オーバーロードの一覧

矩形rにイメージを描画します。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

x、y座標にイメージを描画します。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

解説

指定したキャンバスと領域にチャートを描画するために使用してください。

これは、カスタマイズしたチャートを印刷する場合にも使用できます。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DSVG.Draw メソッド

矩形ｒにイメージを描画します。
public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Draw

Steema.TeeChart.Drawing.Graphics3DSVG.Draw メソッド

X、Y座標にイメージを描画します。
public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DSVG.DrawBeziers メソッド

オーバーロードの一覧

Point配列pをベジェ曲線で描きます。

public override Void DrawBeziers(System.Drawing.Point[])

解説

Point配列pをベジェ曲線で描きます。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DSVG.DrawBeziers メソッド

Point配列pをベジェ曲線で描きます。
public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DrawPath

Steema.TeeChart.Drawing.Graphics3DSVG.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DSVG.Ellipse メソッド

オーバーロードの一覧

2つの座標間に楕円を描画します。

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

解説

2つの座標間に楕円を描画します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DSVG.Ellipse メソッド

2つの座標間に楕円を描画します。
public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


EraseBackground

Steema.TeeChart.Drawing.Graphics3DSVG.EraseBackground メソッド

Left、Top、Right、Bottomで定義した背面を削除します。
public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

Left、Top、Right、Bottomで定義した背面を削除します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DSVG.FillRegion メソッド

領域の内側を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶしの特性を定義します。
region
塗りつぶす領域を定義します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DSVG.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DSVG.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DSVG.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(System.Int32, System.Int32)

解説

現在のペンの位置（MoveToメソッドを参照）から新しい座標に線を描きます。

例

[C#]
// Zオフセットなしで線を描きます。
tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DSVG.LineTo メソッド

現在のペンの位置から新しい座標に線を描きます。
public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Pixel

Steema.TeeChart.Drawing.Graphics3DSVG.Pixel メソッド

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。
public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DSVG.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

多角形を描きます。

public override Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DSVG.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DSVG.Polygon メソッド

多角形を描きます。
public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DSVG.Polyline メソッド

オーバーロードの一覧

Z深さでp配列のすべてのポイントを接続するラインセグメントを描きます。

public override Void Polyline(System.Drawing.Point[])

解説

Z深さでp配列のすべてのポイントを接続するラインセグメントを描きます。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DSVG.Polyline メソッド

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DSVG.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DSVG.RotateLabel メソッド

オーバーロードの一覧

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

解説

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。RotDegree値は0～360の間で設定してください。文字列はチャートの描画キャンバスに出力されます。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DSVG.RotateLabel メソッド

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。
public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DSVG.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DSVG.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

キャンバスをほかの位置へコピーします。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DSVG.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DSVG.UnClip メソッド

チャートキャンバスに適用されるクリッピング領域をすべて削除します。
public override Void UnClip()

解説

チャートキャンバスに適用されるクリッピング領域をすべて削除します。クリッピング領域は、矩形の座標外に描画しないために使用されます。これは、マーカや系列ポイントをChartRectの矩形の外側に表示しておくために内部で使用されます。

メモ：メタファイルはクリッピング領域を受け付けません。メタファイルフォーマットは、印刷の際に使用されます。つまり、クリッピングは実行されません。

参照

Graphics3DSVG クラス | Graphics3DSVG メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DSVG プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DSVG クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVec

Steema.TeeChart.Drawing.Graphics3DVec クラス

全ベクタイメージ形式の抽象クラス。キーエレメントは、内部ビットマップやUseBuffered = falseです。

この型のすべてのメンバの一覧については、Graphics3DVec メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
public abstract class Graphics3DVec : Graphics3D , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVec 全メンバ

Graphics3DVec 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc (Graphics3Dの継承元) |
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions (Graphics3Dの継承元) |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse (Graphics3Dの継承元) |
ClipPolygon (Graphics3Dの継承元) |
ClipRectangle (Graphics3Dの継承元) | Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw (Graphics3Dの継承元) |
DrawBeziers (Graphics3Dの継承元) | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath (Graphics3Dの継承元) | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse (Graphics3Dの継承元) | 境界矩形rに楕円を描きます。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground (Graphics3Dの継承元) |
FillRectangle (Graphics3Dの継承元) |
FillRegion (Graphics3Dの継承元) |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line |
LineTo (Graphics3Dの継承元) | 現在のペンの位置から新しい座標に線を描きます。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel (Graphics3Dの継承元) |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon (Graphics3Dの継承元) | Z位置オフセットで多角形を描きます。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline (Graphics3Dの継承元) |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage (Graphics3Dの継承元) | 描画するためにチャートキャンバスを用意します。
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel (Graphics3Dの継承元) | RotDegreeの回転角度で、指定したXYZ座標に回転したテキスト文字列を出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion (Graphics3Dの継承元) |
SetTextAlign (Graphics3Dの継承元) |
ShowImage (Graphics3Dの継承元) |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip (Graphics3Dの継承元) |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx
fy
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream
m_string
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID
swFromStream
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr

プロテクト メソッド

AddToStream | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString |
DoText |
FixSeparator |
FloatToStr |
FontDPI |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow (Graphics3Dの継承元) |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse (Graphics3Dの継承元) |

参照

Graphics3DVec クラス | Steema.TeeChart.Drawing 名前空間


Graphics3DVec コンストラクタ

Steema.TeeChart.Drawing.Graphics3DVec コンストラクタ

public Graphics3DVec(Stream stream,
     Chart c)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVec フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx
fy
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream
m_string
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DVec クラス | Steema.TeeChart.Drawing 名前空間


fx

Steema.TeeChart.Drawing.Graphics3DVec.fx フィールド

protected Int32 fx

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


fy

Steema.TeeChart.Drawing.Graphics3DVec.fy フィールド

protected Int32 fy

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


istream

Steema.TeeChart.Drawing.Graphics3DVec.istream フィールド

protected Stream istream

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


m_string

Steema.TeeChart.Drawing.Graphics3DVec.m_string フィールド

protected String m_string

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


SupportsID

Steema.TeeChart.Drawing.Graphics3DVec.SupportsID フィールド

protected Boolean SupportsID

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


swFromStream

Steema.TeeChart.Drawing.Graphics3DVec.swFromStream フィールド

protected StreamWriter swFromStream

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


tmpStr

Steema.TeeChart.Drawing.Graphics3DVec.tmpStr フィールド

protected StringBuilder tmpStr

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVec メソッド

パブリック メソッド

Arc (Graphics3Dの継承元) |
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions (Graphics3Dの継承元) |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse (Graphics3Dの継承元) |
ClipPolygon (Graphics3Dの継承元) |
ClipRectangle (Graphics3Dの継承元) | Windows GDIクリッピング領域を作成し、TChartキャンバスのデバイスコンテキストのハンドルで選択します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw (Graphics3Dの継承元) |
DrawBeziers (Graphics3Dの継承元) | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath (Graphics3Dの継承元) | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse (Graphics3Dの継承元) | 境界矩形rに楕円を描きます。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground (Graphics3Dの継承元) |
FillRectangle (Graphics3Dの継承元) |
FillRegion (Graphics3Dの継承元) |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line |
LineTo (Graphics3Dの継承元) | 現在のペンの位置から新しい座標に線を描きます。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel (Graphics3Dの継承元) |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon (Graphics3Dの継承元) | Z位置オフセットで多角形を描きます。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline (Graphics3Dの継承元) |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage (Graphics3Dの継承元) | 描画するためにチャートキャンバスを用意します。
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel (Graphics3Dの継承元) | RotDegreeの回転角度で、指定したXYZ座標に回転したテキスト文字列を出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion (Graphics3Dの継承元) |
SetTextAlign (Graphics3Dの継承元) |
ShowImage (Graphics3Dの継承元) |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip (Graphics3Dの継承元) |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString |
DoText |
FixSeparator |
FloatToStr |
FontDPI |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow (Graphics3Dの継承元) |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line |
PointToStr |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse (Graphics3Dの継承元) |

参照

Graphics3DVec クラス | Steema.TeeChart.Drawing 名前空間


AddToStream

Steema.TeeChart.Drawing.Graphics3DVec.AddToStream メソッド

内部ストリームにテキストを追加します。
protected abstract Void AddToStream(String text)

パラメーター

text
ストリームに追加されるテキスト。

解説

内部ストリームにテキストを追加します。

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


DoDrawString

Steema.TeeChart.Drawing.Graphics3DVec.DoDrawString メソッド

protected abstract Void DoDrawString(Int32 x,
     Int32 y,
     String text,
     ChartBrush aBrush)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


DoText

Steema.TeeChart.Drawing.Graphics3DVec.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degangle,
     Color c)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


FixSeparator

Steema.TeeChart.Drawing.Graphics3DVec.FixSeparator メソッド

protected String FixSeparator(String text)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


FloatToStr

Steema.TeeChart.Drawing.Graphics3DVec.FloatToStr メソッド

protected abstract String FloatToStr(Double value)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


FontDPI

Steema.TeeChart.Drawing.Graphics3DVec.FontDPI メソッド

protected Single FontDPI()

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

Steema.TeeChart.Drawing.Graphics3DVec.HorizontalLine メソッド

オーバーロードの一覧

水平方向の線を描きます。

public override Void HorizontalLine(System.Int32, System.Int32, System.Int32)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


HorizontalLine

Steema.TeeChart.Drawing.Graphics3DVec.HorizontalLine メソッド

水平方向の線を描きます。
public override Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

参照

HorizontalLine オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DVec.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3DVec.Line メソッド

オーバーロードの一覧

protected override Void Line(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Point, System.Drawing.Point)
public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3DVec.Line メソッド

protected override Void Line(ChartPen p,
     Point a,
     Point b)

参照

Line オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Line

Steema.TeeChart.Drawing.Graphics3DVec.Line メソッド

public override Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

参照

Line オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


MeasureString

Steema.TeeChart.Drawing.Graphics3DVec.MeasureString メソッド

public override SizeF MeasureString(ChartFont f,
     String text)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3DVec.MoveTo メソッド

オーバーロードの一覧

public override Void MoveTo(System.Int32, System.Int32)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


MoveTo

Steema.TeeChart.Drawing.Graphics3DVec.MoveTo メソッド

public override Void MoveTo(Int32 x,
     Int32 y)

参照

MoveTo オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DVec.PointToStr メソッド

protected abstract String PointToStr(Int32 X,
     Int32 Y)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DVec.PointToStr メソッド

protected abstract String PointToStr(PointDouble p)

参照

PointToStr オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DVec.PointToStr メソッド

protected abstract String PointToStr(Point p)

参照

PointToStr オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DVec.PointToStr メソッド

protected abstract String PointToStr(Int32 X,
     Int32 Y)

参照

PointToStr オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


PointToStr

Steema.TeeChart.Drawing.Graphics3DVec.PointToStr メソッド

protected abstract String PointToStr(Double X,
     Double Y)

参照

PointToStr オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3DVec.Rectangle メソッド

オーバーロードの一覧

矩形を描きます。

public override Void Rectangle(System.Drawing.Rectangle)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Rectangle

Steema.TeeChart.Drawing.Graphics3DVec.Rectangle メソッド

矩形を描きます。
public override Void Rectangle(Rectangle r)

参照

Rectangle オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

Steema.TeeChart.Drawing.Graphics3DVec.VerticalLine メソッド

オーバーロードの一覧

(X,Top) から (X,Bottom) に垂直線を描きます。

public override Void VerticalLine(System.Int32, System.Int32, System.Int32)

参照

Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


VerticalLine

Steema.TeeChart.Drawing.Graphics3DVec.VerticalLine メソッド

(X,Top) から (X,Bottom) に垂直線を描きます。
public override Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

参照

VerticalLine オーバーロードの一覧 | Graphics3DVec クラス | Graphics3DVec メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVec プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DVec クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVML

Steema.TeeChart.Drawing.Graphics3DVML クラス

この型のすべてのメンバの一覧については、Graphics3DVML メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DVML : Graphics3DVec , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVML 全メンバ

Graphics3DVML 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DVML クラス | Steema.TeeChart.Drawing 名前空間


Graphics3DVML コンストラクタ

Steema.TeeChart.Drawing.Graphics3DVML コンストラクタ

public Graphics3DVML(Stream istream,
     Chart c)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVML フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DVML クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVML メソッド

パブリック メソッド

Arc | 現在のペンを使用して楕円状の弧を描くためには、このメソッドを使用してください。
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw | 矩形rにイメージを描画します。
DrawBeziers | Point配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
Elevate (Graphics3Dの継承元) |
Ellipse | 指定した座標内に楕円を描画します。
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground | 指定した矩形領域の背景をクリアします。
FillRectangle (Graphics3Dの継承元) |
FillRegion | 領域の内側を塗りつぶします。
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo | 現在のペンの位置から新しい座標に線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel | Pen.Widthを使用して、3DピクセルをOLE_Colorに設定します。
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon | 指定したGDIブラシを使用して多角形を描画します。
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline | zの変位でのPoint配列pを接続するラインセグメントを描画します。
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel | 指定したxy座標にRotDegreeの回転角度で回転させたテキストを出力します。
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

Graphics3DVML クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DVML.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

現在のペンで楕円状の曲線で弧を描きます。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

解説

現在のペンで楕円状の曲線で弧を描きます。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DVML.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Arc

Steema.TeeChart.Drawing.Graphics3DVML.Arc メソッド

現在のペンで楕円状の曲線で弧を描きます。
public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DVML.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DVML.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。
public override Void ClipEllipse(Rectangle r)

解説

Rect座標パラメータの内側に含まれる楕円の内側あるいは外側にキャンバスの出力を制限します。

InvertedパラメータがTrueの場合、楕円の外側のみにキャンバスの出力を制限します。

InvertedパラメータがFalseの場合、楕円の内側のみにキャンバスの出力を制限します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DVML.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。
public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DVML.ClipRectangle メソッド

オーバーロードの一覧

矩形のWindows GDIクリッピング領域を作成します。

public override Void ClipRectangle(System.Drawing.Rectangle)

解説

Windows GDIクリッピング領域を作成し、それを選択してTChart.Canvasデバイスコンテキストハンドルに入れます。

UnClipRectangleメソッドは、TChart.Canvasに適用されるすべてのクリッピング領域を削除します。

このメソッドを使用すると、系列やカスタム描画が設定した矩形範囲まで描画されます。

メモ:メタファイルを印刷および作成すると、クリッピング領域を論理ピクセルで受け付けなくなります。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DVML.ClipRectangle メソッド

矩形のWindows GDIクリッピング領域を作成します。
public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DoText

Steema.TeeChart.Drawing.Graphics3DVML.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degAngle,
     Color c)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DVML.Draw メソッド

オーバーロードの一覧

矩形rにイメージを描画します。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

x、y座標にイメージを描画します。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

解説

指定したキャンバスと領域にチャートを描画するために使用してください。

これは、カスタマイズしたチャートを印刷する場合にも使用できます。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DVML.Draw メソッド

矩形rにイメージを描画します。
public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Draw

Steema.TeeChart.Drawing.Graphics3DVML.Draw メソッド

x、y座標にイメージを描画します。
public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DVML.DrawBeziers メソッド

オーバーロードの一覧

Point配列pをベジェ曲線で描きます。

public override Void DrawBeziers(System.Drawing.Point[])

解説

Point配列pをベジェ曲線で描きます。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DVML.DrawBeziers メソッド

Point配列pをベジェ曲線で描きます。
public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DrawPath

Steema.TeeChart.Drawing.Graphics3DVML.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DVML.Ellipse メソッド

オーバーロードの一覧

2つの座標間に楕円を描画します。

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

解説

2つの座標間に楕円を描画します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DVML.Ellipse メソッド

2つの座標間に楕円を描画します。
public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


EraseBackground

Steema.TeeChart.Drawing.Graphics3DVML.EraseBackground メソッド

Left、Top、Right、Bottomで定義した背面を削除します。
public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

解説

Left、Top、Right、Bottomで定義した背面を削除します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DVML.FillRegion メソッド

領域の内側を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶしの特性を定義します。
region
塗りつぶす領域を定義します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DVML.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DVML.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush b,
     Rectangle r,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DVML.LineTo メソッド

オーバーロードの一覧

現在のペンの位置から新しい座標に線を描きます。

public override Void LineTo(System.Int32, System.Int32)

解説

現在のペンの位置（MoveToメソッドを参照）から新しい座標に線を描きます。

例

[C#]
// Zオフセットなしで線を描きます。
tChart1.Graphics3D.MoveTo(150,180);
tChart1.Graphics3D.LineTo(250, 250);

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DVML.LineTo メソッド

現在のペンの位置から新しい座標に線を描きます。
public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Pixel

Steema.TeeChart.Drawing.Graphics3DVML.Pixel メソッド

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。
public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

解説

Pen.Widthを使用して、OLE_Colorに3Dピクセルを設定します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DVML.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

多角形を描きます。

public override Void Polygon(System.Drawing.Point[])

解説

z位置のオフセットで多角形を描画します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DVML.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DVML.Polygon メソッド

多角形を描きます。
public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DVML.Polyline メソッド

オーバーロードの一覧

Z深さでp配列のすべてのポイントを接続するラインセグメントを描きます。

public override Void Polyline(System.Drawing.Point[])

解説

Z深さでp配列のすべてのポイントを接続するラインセグメントを描きます。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DVML.Polyline メソッド

zの変位でのPoint配列pを接続するラインセグメントを描画します。

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DVML.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DVML.RotateLabel メソッド

オーバーロードの一覧

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

解説

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。RotDegree値は0～360の間で設定してください。文字列はチャートの描画キャンバスに出力されます。

例

[C#]

private void tChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
tChart1.Graphics3D.RotateLabel(100,100,10,"Value",50);
}

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DVML.RotateLabel メソッド

RotDegreeの回転角度で、指定したxy座標に回転したテキスト文字列を出力します。
public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DVML.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DVML.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

解説

ほかの位置にキャンバスをコピーします。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DVML.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DVML.UnClip メソッド

チャートキャンバスに適用されるクリッピング領域をすべて削除します。
public override Void UnClip()

解説

チャートキャンバスに適用されるクリッピング領域をすべて削除します。クリッピング領域は、矩形の座標外に描画しないために使用されます。これは、マーカや系列ポイントをChartRectの矩形の外側に表示しておくために内部で使用されます。

メモ：メタファイルはクリッピング領域を受け付けません。メタファイルフォーマットは、印刷の際に使用されます。つまり、クリッピングは実行されません。

参照

Graphics3DVML クラス | Graphics3DVML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DVML プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DVML クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML

Steema.TeeChart.Drawing.Graphics3DXAML クラス

この型のすべてのメンバの一覧については、Graphics3DXAML メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
Steema.TeeChart.Drawing.Graphics3DVec
public class Graphics3DXAML : Graphics3DVec , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML 全メンバ

Graphics3DXAML 概要

コンストラクタ

Constructor

パブリック フィールド

FourPoints (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

パブリック メソッド

Arc |
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse |
ClipPolygon |
ClipRectangle |
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw |
DrawBeziers |
DrawPath |
Elevate (Graphics3Dの継承元) |
Ellipse |
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground |
FillRectangle (Graphics3Dの継承元) |
FillRegion |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo |
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角を行えるかどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
g (Graphics3Dの継承元)
gradientZ (Graphics3Dの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
ifont (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
irotationCenter (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
SupportsID (Graphics3DVecの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpStr (Graphics3DVecの継承元)

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |
XAMLGradient |
XAMLPen |

参照

Graphics3DXAML クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML コンストラクタ

public Graphics3DXAML(Stream istream,
     Chart c)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML フィールド

パブリック フィールド

FourPoints (Graphics3Dの継承元)
g (Graphics3Dの継承元)
IPointDoubles (Graphics3Dの継承元)
Monochrome (Graphics3Dの継承元)

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元)
aspect (Graphics3Dの継承元)
aTextRenderingHint (Graphics3Dの継承元)
fx (Graphics3DVecの継承元)
fy (Graphics3DVecの継承元)
hasClipRegion (Graphics3Dの継承元)
iCanvasType (Graphics3Dの継承元)
InternalUse (TeeBaseの継承元)
IPoints (Graphics3Dの継承元)
IsOpenGL (Graphics3Dの継承元)
istream (Graphics3DVecの継承元)
m_string (Graphics3DVecの継承元)
oldRegion (Graphics3Dの継承元)
stringFormat (Graphics3Dの継承元)
swFromStream (Graphics3DVecの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Graphics3DXAML クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML メソッド

パブリック メソッド

Arc |
Arrow (Graphics3Dの継承元) | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos (Graphics3Dの継承元) | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse |
ClipPolygon |
ClipRectangle |
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube (Graphics3Dの継承元) | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation (Graphics3Dの継承元) |
Draw |
DrawBeziers |
DrawPath |
Elevate (Graphics3Dの継承元) |
Ellipse |
EllipseEnh (Graphics3Dの継承元) | Z位置で(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。
EnableRotation (Graphics3Dの継承元) |
EndBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
EraseBackground |
FillRectangle (Graphics3Dの継承元) |
FillRegion |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine (Graphics3DVecの継承元) | 水平直線を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line (Graphics3DVecの継承元) |
LineTo |
LineWithZ (Graphics3Dの継承元) |
MeasureString (Graphics3DVecの継承元) |
MoveTo (Graphics3DVecの継承元) |
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie (Graphics3Dの継承元) |
Pixel |
Plane (Graphics3Dの継承元) | Z深さオフセットで多角形描きます。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix (Graphics3Dの継承元) |
PrepareDrawImage |
Projection (Graphics3Dの継承元) | 内部使用。境界矩形の投影座標を計算します。
PushMatrix (Graphics3Dの継承元) |
Pyramid (Graphics3Dの継承元) | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc (Graphics3Dの継承元) | 角錐台を描画します。厚さの設定もできます。
Rectangle (Graphics3DVecの継承元) | 矩形を描きます。
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectangleZ (Graphics3Dの継承元) | 指定したパラメータの位置に水平の矩形を描画します。
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate (Graphics3Dの継承元) |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetTextAlign (Graphics3Dの継承元) |
ShowImage |
Sphere (Graphics3Dの継承元) | 球を描画します。
SphereEnh (Graphics3Dの継承元) |
StartBlending (Graphics3Dの継承元) | OpenGLの透明度をサポートします。
Surface3D (Graphics3Dの継承元) |
TeeCull (Graphics3Dの継承元) |
TextHeight (Graphics3Dの継承元) | テキストの高さをピクセル単位で返します。
TextOut (Graphics3Dの継承元) | 指定した画面座標に2Dで回転なしのラベルを表示します。
TextWidth (Graphics3Dの継承元) | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate (Graphics3Dの継承元) |
Triangle (Graphics3Dの継承元) | 三角形を描画します。
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine (Graphics3DVecの継承元) | (X,Top)から(X,Bottom)に垂直線を描きます。
ZLine (Graphics3Dの継承元) | (X,Y,Z0)から (X,Y,Z1)に線を描きます。

プロテクト メソッド

AddToStream (Graphics3DVecの継承元) | 内部ストリームにテキストを追加します。
CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DisposeObj (Graphics3Dの継承元) |
DoDrawString (Graphics3DVecの継承元) |
DoText |
FixSeparator (Graphics3DVecの継承元) |
FloatToStr (Graphics3DVecの継承元) |
FontDPI (Graphics3DVecの継承元) |
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText (Graphics3Dの継承元) |
InitWindow |
InternalCylinder (Graphics3Dの継承元) |
InternalRect |
IsRectangle (Graphics3Dの継承元) |
Line (Graphics3DVecの継承元) |
PointToStr (Graphics3DVecの継承元) |
PolygonFour (Graphics3Dの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |
XAMLGradient |
XAMLPen |

参照

Graphics3DXAML クラス | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DXAML.Arc メソッド

オーバーロードの一覧

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)
public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DXAML.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Arc

Steema.TeeChart.Drawing.Graphics3DXAML.Arc メソッド

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 x3,
     Int32 y3,
     Int32 x4,
     Int32 y4)

参照

Arc オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.Graphics3DXAML.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ClipEllipse

Steema.TeeChart.Drawing.Graphics3DXAML.ClipEllipse メソッド

public override Void ClipEllipse(Rectangle r)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ClipPolygon

Steema.TeeChart.Drawing.Graphics3DXAML.ClipPolygon メソッド

public override Void ClipPolygon(Point[] p)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DXAML.ClipRectangle メソッド

オーバーロードの一覧

public override Void ClipRectangle(System.Drawing.Rectangle)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ClipRectangle

Steema.TeeChart.Drawing.Graphics3DXAML.ClipRectangle メソッド

public override Void ClipRectangle(Rectangle r)

参照

ClipRectangle オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


DoText

Steema.TeeChart.Drawing.Graphics3DXAML.DoText メソッド

protected abstract Void DoText(Int32 x,
     Int32 y,
     String text,
     Double degangle,
     Color c)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DXAML.Draw メソッド

オーバーロードの一覧

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)
public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DXAML.Draw メソッド

public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Graphics3DXAML.Draw メソッド

public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DXAML.DrawBeziers メソッド

オーバーロードの一覧

public override Void DrawBeziers(System.Drawing.Point[])

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


DrawBeziers

Steema.TeeChart.Drawing.Graphics3DXAML.DrawBeziers メソッド

public override Void DrawBeziers(Point[] p)

参照

DrawBeziers オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


DrawPath

Steema.TeeChart.Drawing.Graphics3DXAML.DrawPath メソッド

public override Void DrawPath(Pen pen,
     GraphicsPath path)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DXAML.Ellipse メソッド

オーバーロードの一覧

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Ellipse

Steema.TeeChart.Drawing.Graphics3DXAML.Ellipse メソッド

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


EraseBackground

Steema.TeeChart.Drawing.Graphics3DXAML.EraseBackground メソッド

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


FillRegion

Steema.TeeChart.Drawing.Graphics3DXAML.FillRegion メソッド

public override Void FillRegion(Brush brush,
     Region region)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


InitWindow

Steema.TeeChart.Drawing.Graphics3DXAML.InitWindow メソッド

protected internal abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


InternalRect

Steema.TeeChart.Drawing.Graphics3DXAML.InternalRect メソッド

protected abstract Void InternalRect(ChartBrush brush,
     Rectangle Rect,
     Boolean UsePen,
     Boolean IsRound)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DXAML.LineTo メソッド

オーバーロードの一覧

public override Void LineTo(System.Int32, System.Int32)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


LineTo

Steema.TeeChart.Drawing.Graphics3DXAML.LineTo メソッド

public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Pixel

Steema.TeeChart.Drawing.Graphics3DXAML.Pixel メソッド

public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DXAML.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])
public override Void Polygon(System.Drawing.Point[])

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DXAML.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Polygon

Steema.TeeChart.Drawing.Graphics3DXAML.Polygon メソッド

public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DXAML.Polyline メソッド

オーバーロードの一覧

public override Void Polyline(System.Drawing.Point[])

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Polyline

Steema.TeeChart.Drawing.Graphics3DXAML.Polyline メソッド

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.Graphics3DXAML.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DXAML.RotateLabel メソッド

オーバーロードの一覧

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


RotateLabel

Steema.TeeChart.Drawing.Graphics3DXAML.RotateLabel メソッド

public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


SetClipRegion

Steema.TeeChart.Drawing.Graphics3DXAML.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


ShowImage

Steema.TeeChart.Drawing.Graphics3DXAML.ShowImage メソッド

protected internal abstract Void ShowImage(Graphics g)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.Graphics3DXAML.TransparentEllipse メソッド

protected internal abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


UnClip

Steema.TeeChart.Drawing.Graphics3DXAML.UnClip メソッド

public override Void UnClip()

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


XAMLGradient

Steema.TeeChart.Drawing.Graphics3DXAML.XAMLGradient メソッド

protected Void XAMLGradient()

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


XAMLPen

Steema.TeeChart.Drawing.Graphics3DXAML.XAMLPen メソッド

protected String XAMLPen()

参照

Graphics3DXAML クラス | Graphics3DXAML メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Graphics3DXAML プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation (Graphics3Dの継承元) | キャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

Graphics3DXAML クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFont

Steema.TeeChart.Drawing.GraphicsFont クラス

個々のフォントの抽象クラスです。

この型のすべてのメンバの一覧については、GraphicsFont メンバを参照してください。

System.Object
public abstract class GraphicsFont : Object

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFont 全メンバ

GraphicsFont 概要

コンストラクタ

Constructor

パブリック メソッド

DictFontName
Equals

パブリック プロパティ

FontData
GraphicsFontName
Index
ObjectNumber

プロテクト フィールド

m_fontname

プロテクト メソッド

GetFontName

参照

GraphicsFont クラス | Steema.TeeChart.Drawing 名前空間


GraphicsFont コンストラクタ

Steema.TeeChart.Drawing.GraphicsFont コンストラクタ

public GraphicsFont(GraphicsFonts fonts,
     ChartFont f)

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFont フィールド

プロテクト フィールド

m_fontname

参照

GraphicsFont クラス | Steema.TeeChart.Drawing 名前空間


m_fontname

Steema.TeeChart.Drawing.GraphicsFont.m_fontname フィールド

protected String m_fontname

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFont メソッド

パブリック メソッド

DictFontName
Equals

プロテクト メソッド

GetFontName

参照

GraphicsFont クラス | Steema.TeeChart.Drawing 名前空間


DictFontName

Steema.TeeChart.Drawing.GraphicsFont.DictFontName メソッド

public abstract String DictFontName()

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Equals

Steema.TeeChart.Drawing.GraphicsFont.Equals メソッド

public Boolean Equals(ChartFont font)

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


GetFontName

Steema.TeeChart.Drawing.GraphicsFont.GetFontName メソッド

protected abstract String GetFontName(ChartFont f)

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFont プロパティ

パブリック プロパティ

FontData
GraphicsFontName
Index
ObjectNumber

参照

GraphicsFont クラス | Steema.TeeChart.Drawing 名前空間


FontData

Steema.TeeChart.Drawing.GraphicsFont.FontData プロパティ

public TTFontData FontData {get;}

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


GraphicsFontName

Steema.TeeChart.Drawing.GraphicsFont.GraphicsFontName プロパティ

public String GraphicsFontName {get; set;}

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Index

Steema.TeeChart.Drawing.GraphicsFont.Index プロパティ

public Int32 Index {get;}

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


ObjectNumber

Steema.TeeChart.Drawing.GraphicsFont.ObjectNumber プロパティ

public Int32 ObjectNumber {get; set;}

参照

GraphicsFont クラス | GraphicsFont メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFonts

Steema.TeeChart.Drawing.GraphicsFonts クラス

使用されたすべてのフォントを保存する抽象クラスです。

この型のすべてのメンバの一覧については、GraphicsFonts メンバを参照してください。

System.Object
System.Collections.ArrayList
public abstract class GraphicsFonts : ArrayList , IList, ICollection
, IEnumerable, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

GraphicsFonts メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFonts 全メンバ

GraphicsFonts 概要

コンストラクタ

Constructor

パブリック メソッド

Add
FindFont

参照

GraphicsFonts クラス | Steema.TeeChart.Drawing 名前空間


GraphicsFonts コンストラクタ

Steema.TeeChart.Drawing.GraphicsFonts コンストラクタ

protected GraphicsFonts()

参照

GraphicsFonts クラス | GraphicsFonts メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsFonts メソッド

パブリック メソッド

Add
FindFont

参照

GraphicsFonts クラス | Steema.TeeChart.Drawing 名前空間


Add

Steema.TeeChart.Drawing.GraphicsFonts.Add メソッド

public override Int32 Add(ChartFont font)

参照

GraphicsFonts クラス | GraphicsFonts メンバ | Steema.TeeChart.Drawing 名前空間


FindFont

Steema.TeeChart.Drawing.GraphicsFonts.FindFont メソッド

public Int32 FindFont(ChartFont font)

参照

GraphicsFonts クラス | GraphicsFonts メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImage

Steema.TeeChart.Drawing.GraphicsImage クラス

個々のイメージのプロパティ。

この型のすべてのメンバの一覧については、GraphicsImage メンバを参照してください。

System.Object
public class GraphicsImage : Object

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImage 全メンバ

GraphicsImage 概要

コンストラクタ

Constructor

パブリック フィールド

ImageStream

パブリック メソッド

DictImageName

パブリック プロパティ

ImageFormat
ImageHeight
ImagePixelFormat
ImageWidth
Index
ObjectNumber

参照

GraphicsImage クラス | Steema.TeeChart.Drawing 名前空間


GraphicsImage コンストラクタ

Steema.TeeChart.Drawing.GraphicsImage コンストラクタ

public GraphicsImage(GraphicsImages images,
     Image image)

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImage フィールド

パブリック フィールド

ImageStream

参照

GraphicsImage クラス | Steema.TeeChart.Drawing 名前空間


ImageStream

Steema.TeeChart.Drawing.GraphicsImage.ImageStream フィールド

public Stream ImageStream

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImage メソッド

パブリック メソッド

DictImageName

参照

GraphicsImage クラス | Steema.TeeChart.Drawing 名前空間


DictImageName

Steema.TeeChart.Drawing.GraphicsImage.DictImageName メソッド

public String DictImageName()

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImage プロパティ

パブリック プロパティ

ImageFormat
ImageHeight
ImagePixelFormat
ImageWidth
Index
ObjectNumber

参照

GraphicsImage クラス | Steema.TeeChart.Drawing 名前空間


ImageFormat

Steema.TeeChart.Drawing.GraphicsImage.ImageFormat プロパティ

public ImageFormat ImageFormat {get;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


ImageHeight

Steema.TeeChart.Drawing.GraphicsImage.ImageHeight プロパティ

public Int32 ImageHeight {get;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


ImagePixelFormat

Steema.TeeChart.Drawing.GraphicsImage.ImagePixelFormat プロパティ

public PixelFormat ImagePixelFormat {get;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


ImageWidth

Steema.TeeChart.Drawing.GraphicsImage.ImageWidth プロパティ

public Int32 ImageWidth {get;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Index

Steema.TeeChart.Drawing.GraphicsImage.Index プロパティ

public Int32 Index {get;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


ObjectNumber

Steema.TeeChart.Drawing.GraphicsImage.ObjectNumber プロパティ

public Int32 ObjectNumber {get; set;}

参照

GraphicsImage クラス | GraphicsImage メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImages

Steema.TeeChart.Drawing.GraphicsImages クラス

使用したイメージをすべて保存します。

この型のすべてのメンバの一覧については、GraphicsImages メンバを参照してください。

System.Object
System.Collections.ArrayList
public class GraphicsImages : ArrayList , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

GraphicsImages メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImages 全メンバ

GraphicsImages 概要

コンストラクタ

Constructor

パブリック メソッド

Add
FindImage

パブリック プロパティ

Item

参照

GraphicsImages クラス | Steema.TeeChart.Drawing 名前空間


GraphicsImages コンストラクタ

Steema.TeeChart.Drawing.GraphicsImages コンストラクタ

public GraphicsImages()

参照

GraphicsImages クラス | GraphicsImages メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImages メソッド

パブリック メソッド

Add
FindImage

参照

GraphicsImages クラス | Steema.TeeChart.Drawing 名前空間


Add

Steema.TeeChart.Drawing.GraphicsImages.Add メソッド

public Int32 Add(Image image)

参照

GraphicsImages クラス | GraphicsImages メンバ | Steema.TeeChart.Drawing 名前空間


FindImage

Steema.TeeChart.Drawing.GraphicsImages.FindImage メソッド

public Int32 FindImage(Image image)

参照

GraphicsImages クラス | GraphicsImages メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.GraphicsImages プロパティ

パブリック プロパティ

Item

参照

GraphicsImages クラス | Steema.TeeChart.Drawing 名前空間


Item

Steema.TeeChart.Drawing.GraphicsImages.Item プロパティ

public GraphicsImage Item(Int32 index) {get;}

参照

GraphicsImages クラス | GraphicsImages メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasHyperlinks

Steema.TeeChart.Drawing.ICanvasHyperlinks インターフェイス

public interface ICanvasHyperlinks

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ICanvasHyperlinks メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasHyperlinks 全メンバ

ICanvasHyperlinks 概要

パブリック メソッド

AddLink

参照

ICanvasHyperlinks インターフェイス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasHyperlinks メソッド

パブリック メソッド

AddLink

参照

ICanvasHyperlinks インターフェイス | Steema.TeeChart.Drawing 名前空間


AddLink

Steema.TeeChart.Drawing.ICanvasHyperlinks.AddLink メソッド

public abstract Void AddLink(Int32 x,
     Int32 y,
     String Text,
     String URL,
     String Hint)

参照

ICanvasHyperlinks インターフェイス | ICanvasHyperlinks メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasToolTips

Steema.TeeChart.Drawing.ICanvasToolTips インターフェイス

public interface ICanvasToolTips

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ICanvasToolTips メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasToolTips 全メンバ

ICanvasToolTips 概要

パブリック メソッド

AddToolTip

参照

ICanvasToolTips インターフェイス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ICanvasToolTips メソッド

パブリック メソッド

AddToolTip

参照

ICanvasToolTips インターフェイス | Steema.TeeChart.Drawing 名前空間


AddToolTip

Steema.TeeChart.Drawing.ICanvasToolTips.AddToolTip メソッド

public abstract Void AddToolTip(String Entity,
     String ToolTip)

参照

ICanvasToolTips インターフェイス | ICanvasToolTips メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLLightsource

Steema.TeeChart.Drawing.IGLLightsource インターフェイス

public interface IGLLightsource

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLLightsource 全メンバ

IGLLightsource 概要

パブリック メソッド

GLColor

パブリック プロパティ

Color
FixedPosition
Position
Visible

参照

IGLLightsource インターフェイス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLLightsource メソッド

パブリック メソッド

GLColor

参照

IGLLightsource インターフェイス | Steema.TeeChart.Drawing 名前空間


GLColor

Steema.TeeChart.Drawing.IGLLightsource.GLColor メソッド

public abstract Single[] GLColor()

解説

アルファ値を含むRGBの色配列。

参照

IGLLightsource インターフェイス | IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLLightsource プロパティ

パブリック プロパティ

Color
FixedPosition
Position
Visible

参照

IGLLightsource インターフェイス | Steema.TeeChart.Drawing 名前空間


Color

Steema.TeeChart.Drawing.IGLLightsource.Color プロパティ

public abstract Color Color {get; set;}

解説

デフォルト値：clWhite

GLLightオブジェクトの色を定義します。
デフォルトではOpenGLのライトの色は白（clWhite ）です。このプロパティをグレー ( 例： clDkGray, clSilver ) に設定するとライトの明るさを変更できます。

参照

IGLLightsource インターフェイス | IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


FixedPosition

Steema.TeeChart.Drawing.IGLLightsource.FixedPosition プロパティ

public abstract Boolean FixedPosition {get; set;}

解説

デフォルト値: false
ライトの位置を固定させるか、あるいはパネルと連動して回転させるかを取得/設定します。

デフォルトは、Positionプロパティが3D座標のライトのXYZ位置を定義しますが、これらの座標値はパネルのView3DOptionsの回転角度に応じて回転されます。

参照

IGLLightsource インターフェイス | IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


Position

Steema.TeeChart.Drawing.IGLLightsource.Position プロパティ

public abstract IGLPosition Position {get; set;}

解説

キャンバスのライトソースのXYZ座標を設定します。

ライトの3D回転を無効にするには、FixedPositionプロパティを参照してください。

参照

IGLLightsource インターフェイス | IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


Visible

Steema.TeeChart.Drawing.IGLLightsource.Visible プロパティ

public abstract Boolean Visible {get; set;}

解説

ライトを表示/非表示にします。GLLightを表示/非表示にするには、このプロパティを使用してください。

参照

IGLLightsource インターフェイス | IGLLightsource メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLPosition

Steema.TeeChart.Drawing.IGLPosition インターフェイス

public interface IGLPosition

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

IGLPosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLPosition 全メンバ

IGLPosition 概要

パブリック プロパティ

X
Y
Z

参照

IGLPosition インターフェイス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IGLPosition プロパティ

パブリック プロパティ

X
Y
Z

参照

IGLPosition インターフェイス | Steema.TeeChart.Drawing 名前空間


X

Steema.TeeChart.Drawing.IGLPosition.X プロパティ

public abstract Double X {get; set;}

解説

IGLPositionのX座標を設定します。

参照

IGLPosition インターフェイス | IGLPosition メンバ | Steema.TeeChart.Drawing 名前空間


Y

Steema.TeeChart.Drawing.IGLPosition.Y プロパティ

public abstract Double Y {get; set;}

解説

IGLPositionのY座標を設定します。

参照

IGLPosition インターフェイス | IGLPosition メンバ | Steema.TeeChart.Drawing 名前空間


Z

Steema.TeeChart.Drawing.IGLPosition.Z プロパティ

public abstract Double Z {get; set;}

解説

IGLPositionのZ座標を設定します。

参照

IGLPosition インターフェイス | IGLPosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageBevel

Steema.TeeChart.Drawing.ImageBevel クラス

矩形の周りにベベル（枠）を描画するためのプロパティ。

この型のすべてのメンバの一覧については、ImageBevel メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class ImageBevel : TeeBase , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageBevel 全メンバ

ImageBevel 概要

コンストラクタ

Constructor

パブリック メソッド

Assign | 全プロパティをベベルから他のベベルへ割り当てます。
Clone |
Draw | 矩形パラメーターの周りにベベルを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Brush | イメージのベベルのブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Pen | イメージのベベルのペン特性を設定します。
Visible | イメージのベベルを表示/非表示します。
Width | 指定した幅のイメージベベルを描画します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ImageBevel クラス | Steema.TeeChart.Drawing 名前空間


ImageBevel コンストラクタ

Steema.TeeChart.Drawing.ImageBevel コンストラクタ

public ImageBevel(Chart c)

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageBevel フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ImageBevel クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageBevel メソッド

パブリック メソッド

Assign | 全プロパティをベベルから他のベベルへ割り当てます。
Clone |
Draw | 矩形パラメーターの周りにベベルを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ImageBevel クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.ImageBevel.Assign メソッド

ベベルから別のベベルにすべてのプロパティを割り当てます。

public Void Assign(ImageBevel b)

解説

ベベルから別のベベルにすべてのプロパティを割り当てます。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.ImageBevel.Clone メソッド

public virtual Object Clone()

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.ImageBevel.Draw メソッド

指定した矩形領域の周りにベベルを描画します。

public Void Draw(Graphics3D g,
     Rectangle rect,
     Int32 borderRound)

解説

指定した矩形領域の周りにベベルを描画します。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageBevel プロパティ

パブリック プロパティ

Brush | イメージのベベルのブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Pen | イメージのベベルのペン特性を設定します。
Visible | イメージのベベルを表示/非表示します。
Width | 指定した幅のイメージのベベルを描画します。

参照

ImageBevel クラス | Steema.TeeChart.Drawing 名前空間


Brush

Steema.TeeChart.Drawing.ImageBevel.Brush プロパティ

イメージのベベルのブラシ特性を設定します。
public ChartBrush Brush {get; set;}

解説

イメージのベベルのブラシ特性を設定します。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Pen

Steema.TeeChart.Drawing.ImageBevel.Pen プロパティ

イメージのベベルのペン特性を設定します。
public ChartPen Pen {get; set;}

解説

イメージのベベルのペン特性を設定します。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Visible

Steema.TeeChart.Drawing.ImageBevel.Visible プロパティ

イメージのベベルを表示/非表示します。

public Boolean Visible {get; set;}

解説

イメージのベベルを表示/非表示します。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Width

Steema.TeeChart.Drawing.ImageBevel.Width プロパティ

指定した幅のイメージのベベルを描画します。

public Int32 Width {get; set;}

解説

指定した幅のイメージのベベルを描画します。

参照

ImageBevel クラス | ImageBevel メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ImageMode

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ImageMode 列挙体

イメージの表示特性を定義します。

[Serializable]
public enum ImageMode : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Normal | イメージをそのまま表示します。
Stretch | イメージをストレッチで表示します。
Tile | イメージをタイルで表示します。
Center | イメージをそのまま中央に表示します。

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IOpenGL

Steema.TeeChart.Drawing.IOpenGL インターフェイス

public interface IOpenGL

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ：TeeChart.dll

参照

IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IOpenGL 全メンバ

IOpenGL 概要

パブリック メソッド

SetChart

パブリック プロパティ

Active
AmbientLight
DrawStyle
FontExtrusion
FontOutlines
Light0
Light1
Light2
ShadeQuality
Shininess

参照

IOpenGL インターフェイス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IOpenGL メソッド

パブリック メソッド

SetChart

参照

IOpenGL インターフェイス | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.IOpenGL.SetChart メソッド

public abstract Void SetChart(Chart c)

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.IOpenGL プロパティ

パブリック プロパティ

Active
AmbientLight
DrawStyle
FontExtrusion
FontOutlines
Light0
Light1
Light2
ShadeQuality
Shininess

参照

IOpenGL インターフェイス | Steema.TeeChart.Drawing 名前空間


Active

Steema.TeeChart.Drawing.IOpenGL.Active プロパティ

public abstract Boolean Active {get; set;}

解説

OpenGLを使用してチャートを描画するには、このプロパティをTrueに設定してください。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


AmbientLight

Steema.TeeChart.Drawing.IOpenGL.AmbientLight プロパティ

public abstract Int32 AmbientLight {get; set;}

解説

デフォルト値：8

アンビエント光の割合（0～100%までの値）を設定します。
アンビエント光とは、あらゆる方向から照らす環境光です。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


DrawStyle

Steema.TeeChart.Drawing.IOpenGL.DrawStyle プロパティ

public abstract SurfaceStyle DrawStyle {get; set;}

解説

例えば、ポイント、線、または塗りつぶしで描画するためにOpenGLのPolygonModeを設定します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


FontExtrusion

Steema.TeeChart.Drawing.IOpenGL.FontExtrusion プロパティ

public abstract Int32 FontExtrusion {get; set;}

解説

フォントの字体に適用するZ深さを取得/設定します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


FontOutlines

Steema.TeeChart.Drawing.IOpenGL.FontOutlines プロパティ

public abstract Boolean FontOutlines {get; set;}

解説

trueの場合、フォントの輪郭だけを描画します（塗りつぶしなし）。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Light0

Steema.TeeChart.Drawing.IOpenGL.Light0 プロパティ

public abstract IGLLightsource Light0 {get;}

解説

最初のライトソースを取得します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Light1

Steema.TeeChart.Drawing.IOpenGL.Light1 プロパティ

public abstract IGLLightsource Light1 {get;}

解説

2番目のライトソースを取得します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Light2

Steema.TeeChart.Drawing.IOpenGL.Light2 プロパティ

public abstract IGLLightsource Light2 {get;}

解説

3番目のライトソースを取得します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


ShadeQuality

Steema.TeeChart.Drawing.IOpenGL.ShadeQuality プロパティ

public abstract Boolean ShadeQuality {get; set;}

解説

OpenGLのShadingModelを取得/設定します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Shininess

Steema.TeeChart.Drawing.IOpenGL.Shininess プロパティ

public abstract Double Shininess {get; set;}

解説

OpenGLのShadingModelを取得/設定します。

参照

IOpenGL インターフェイス | IOpenGL メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PathGradientMode

Steema.TeeChart.Drawing.PathGradientMode 列挙体

[Serializable]
public sealed enum PathGradientMode : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
FromCenter |
Radial |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Point3D 構造体

XYZポイントホルダー。

この型のすべてのメンバの一覧については、Point3D メンバを参照してください。

System.Object
System.ValueType
public struct Point3D : ValueType

参照

Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D 全メンバ

Point3D 概要

パブリック フィールド

Empty
X
Y
Z

参照

Point3D 構造体 | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D コンストラクタ

オーバーロードの一覧

public Point3D(System.Int32, System.Int32, System.Int32)
public Point3D(System.Drawing.Point, System.Int32)

参照

Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D コンストラクタ

public Point3D(Int32 x,
     Int32 y,
     Int32 z)

参照

Point3D コンストラクタのオーバーロードの一覧 | Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D コンストラクタ

public Point3D(Point point,
     Int32 z)

参照

Point3D コンストラクタのオーバーロードの一覧 | Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3D フィールド

パブリック フィールド

Empty
X
Y
Z

参照

Point3D 構造体 | Steema.TeeChart.Drawing 名前空間


Empty

Steema.TeeChart.Drawing.Point3D.Empty フィールド

public Point3D Empty

参照

Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


X

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Point3D.X フィールド

public Int32 X

参照

Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Y

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Point3D.Y フィールド

public Int32 Y

参照

Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Z

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Point3D.Z フィールド

public Int32 Z

参照

Point3D 構造体 | Point3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3DDouble

Steema.TeeChart.Drawing.Point3DDouble 値型

XYZポイントホルダー。

この型のすべてのメンバの一覧については、Point3DDouble メンバを参照してください。

System.Object
System.ValueType
public sealed struct Point3DDouble : ValueType

参照

Point3DDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3DDouble 全メンバ

Point3DDouble 概要

パブリック フィールド

X
Y
Z

参照

Point3DDouble 構造体 | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Point3DDouble フィールド

パブリック フィールド

X
Y
Z

参照

Point3DDouble 構造体 | Steema.TeeChart.Drawing 名前空間


X

Steema.TeeChart.Drawing.Point3DDouble.X フィールド

public Double X

参照

Point3DDouble 構造体 | Point3DDouble メンバ | Steema.TeeChart.Drawing 名前空間


Y

Steema.TeeChart.Drawing.Point3DDouble.Y フィールド

public Double Y

参照

Point3DDouble 構造体 | Point3DDouble メンバ | Steema.TeeChart.Drawing 名前空間


Z

Steema.TeeChart.Drawing.Point3DDouble.Z フィールド

public Double Z

参照

Point3DDouble 構造体 | Point3DDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointDouble

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointDouble 構造体

XY ポイントホルダー

この型のすべてのメンバの一覧については、PointDouble メンバを参照してください。

System.Object
System.ValueType
public struct PointDouble : ValueType

参照

PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointDouble 全メンバ

PointDouble 概要

コンストラクタ

Constructor

パブリック フィールド

Empty

パブリック メソッド

Round
RoundF

パブリック プロパティ

IsEmpty
X
Y

参照

PointDouble 構造体 | Steema.TeeChart.Drawing 名前空間


PointDouble コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointDouble コンストラクタ

public PointDouble(Double x,
     Double y)

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointDouble フィールド

パブリック フィールド

Empty

参照

PointDouble 構造体 | Steema.TeeChart.Drawing 名前空間


Empty

Steema.TeeChart.Drawing.PointDouble.Empty フィールド

public readonly PointDouble Empty

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointDouble メソッド

パブリック メソッド

Round
RoundF

参照

PointDouble 構造体 | Steema.TeeChart.Drawing 名前空間


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint メソッド

オーバーロードの一覧

public static PointDouble[] FromPoint(System.Drawing.Point[])
public static PointDouble FromPoint(System.Drawing.Point)

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint メソッド

public static PointDouble[] FromPoint(Point[] point)

参照

FromPoint オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


FromPoint

Steema.TeeChart.Drawing.PointDouble.FromPoint メソッド

public static PointDouble FromPoint(Point point)

参照

FromPoint オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Round

Steema.TeeChart.Drawing.PointDouble.Round メソッド

オーバーロードの一覧

public static Point Round(Steema.TeeChart.Drawing.PointDouble)
public static Point[] Round(Steema.TeeChart.Drawing.PointDouble[])

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Round

Steema.TeeChart.Drawing.PointDouble.Round メソッド

public static Point Round(PointDouble value)

参照

Round オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Round

Steema.TeeChart.Drawing.PointDouble.Round メソッド

public static Point[] Round(PointDouble[] value)

参照

Round オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF メソッド

オーバーロードの一覧

public static PointF RoundF(Steema.TeeChart.Drawing.PointDouble)
public static PointF[] RoundF(Steema.TeeChart.Drawing.PointDouble[])

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF メソッド

public static PointF RoundF(PointDouble value)

参照

RoundF オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


RoundF

Steema.TeeChart.Drawing.PointDouble.RoundF メソッド

public static PointF[] RoundF(PointDouble[] value)

参照

RoundF オーバーロードの一覧 | PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointDouble プロパティ

パブリック プロパティ

IsEmpty
X
Y

参照

PointDouble 構造体 | Steema.TeeChart.Drawing 名前空間


IsEmpty

Steema.TeeChart.Drawing.PointDouble.IsEmpty プロパティ

public Boolean IsEmpty {get;}

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


X

Steema.TeeChart.Drawing.PointDouble.X プロパティ

public Double X {get; set;}

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Y

Steema.TeeChart.Drawing.PointDouble.Y プロパティ

public Double Y {get; set;}

参照

PointDouble 構造体 | PointDouble メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointXYZ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ クラス

XYZポイントホルダー。

この型のすべてのメンバの一覧については、PointXYZ メンバを参照してください。

System.Object
public class PointXYZ : Object

必要条件

名前空間： Steema.TeeChart.Drawing

アセンブリ：TeeChart.dll

参照

PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointXYZ 全メンバ

PointXYZ 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

X | X位置をピクセル単位で取得/設定します。
Y | Y位置をピクセル単位で取得/設定します。
Z | Z位置をピクセル単位で取得/設定します。

参照

PointXYZ クラス | Steema.TeeChart.Drawing 名前空間


PointXYZ コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ コンストラクタ

オーバーロードの一覧

public PointXYZ()
public PointXYZ(System.Int32, System.Int32, System.Int32)

参照

PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


PointXYZ コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ コンストラクタ

public PointXYZ()

参照

PointXYZ コンストラクタのオーバーロードの一覧 | PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


PointXYZ コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ コンストラクタ

public PointXYZ(Int32 x,
     Int32 y,
     Int32 z)

参照

PointXYZ コンストラクタのオーバーロードの一覧 | PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.PointXYZ プロパティ

パブリック プロパティ

X | X位置をピクセル単位で取得/設定します。
Y | Y位置をピクセル単位で取得/設定します。
Z | Z位置をピクセル単位で取得/設定します。

参照

PointXYZ クラス | Steema.TeeChart.Drawing 名前空間


X

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ.X プロパティ

X位置をピクセル単位で取得/設定します。

public Int32 X {get; set;}

解説

X位置をピクセル単位で取得/設定します。

参照

PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


Y

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ.Y プロパティ

Y位置をピクセル単位で取得/設定します。

public Int32 Y {get; set;}

解説

Y位置をピクセル単位で取得/設定します。

参照

PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


Z

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.PointXYZ.Z プロパティ

Z位置をピクセル単位で取得/設定します。

public Int32 Z {get; set;}

解説

Z位置をピクセル単位で取得/設定します。

参照

PointXYZ クラス | PointXYZ メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter

Steema.TeeChart.Drawing.ResizeFilter クラス

この型のすべてのメンバの一覧については、ResizeFilter メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.Filter
public class ResizeFilter : Filter

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter 全メンバ

ResizeFilter 概要

コンストラクタ

Constructor

パブリック フィールド

Lines (Filterの継承元)

パブリック メソッド

Apply

パブリック プロパティ

Enabled (Filterの継承元)
Height
Region (Filterの継承元)
Width

プロテクト フィールド

AllowRegion (Filterの継承元)

プロテクト メソッド

CalcLines (Filterの継承元)

参照

ResizeFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter コンストラクタ

public ResizeFilter()

参照

ResizeFilter クラス | ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter フィールド

パブリック フィールド

Lines (Filterの継承元)

プロテクト フィールド

AllowRegion (Filterの継承元)

参照

ResizeFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter メソッド

パブリック メソッド

Apply

プロテクト メソッド

CalcLines (Filterの継承元)

参照

ResizeFilter クラス | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.ResizeFilter.Apply メソッド

オーバーロードの一覧

public override Void Apply(System.Drawing.Bitmap&, System.Drawing.Rectangle)

参照

ResizeFilter クラス | ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.ResizeFilter.Apply メソッド

public override Void Apply(Bitmap& bitmap,
     Rectangle rect)

参照

Apply オーバーロードの一覧 | ResizeFilter クラス | ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ResizeFilter プロパティ

パブリック プロパティ

Enabled (Filterの継承元)
Height
Region (Filterの継承元)
Width

参照

ResizeFilter クラス | Steema.TeeChart.Drawing 名前空間


Height

Steema.TeeChart.Drawing.ResizeFilter.Height プロパティ

public Int32 Height {get; set;}

参照

ResizeFilter クラス | ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Width

Steema.TeeChart.Drawing.ResizeFilter.Width プロパティ

public Int32 Width {get; set;}

参照

ResizeFilter クラス | ResizeFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.RGB

Steema.TeeChart.Drawing.RGB 値型

この型のすべてのメンバの一覧については、RGB メンバを参照してください。

System.Object
System.ValueType
public sealed struct RGB : ValueType

参照

RGB メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.RGB 全メンバ

RGB 概要

パブリック フィールド

Alpha
Blue
Green
Red

参照

RGB 構造体 | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.RGB フィールド

パブリック フィールド

Alpha
Blue
Green
Red

参照

RGB 構造体 | Steema.TeeChart.Drawing 名前空間


Alpha

Steema.TeeChart.Drawing.RGB.Alpha フィールド

public Byte Alpha

参照

RGB 構造体 | RGB メンバ | Steema.TeeChart.Drawing 名前空間


Blue

Steema.TeeChart.Drawing.RGB.Blue フィールド

public Byte Blue

参照

RGB 構造体 | RGB メンバ | Steema.TeeChart.Drawing 名前空間


Green

Steema.TeeChart.Drawing.RGB.Green フィールド

public Byte Green

参照

RGB 構造体 | RGB メンバ | Steema.TeeChart.Drawing 名前空間


Red

Steema.TeeChart.Drawing.RGB.Red フィールド

public Byte Red

参照

RGB 構造体 | RGB メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shadow

Steema.TeeChart.Drawing.Shadow クラス

影を描くためのプロパティ。

この型のすべてのメンバの一覧については、Shadow メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Shadow : TeeBase , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shadow 全メンバ

Shadow 概要

コンストラクタ

Constructor オーバーロード。チャートの影のコンストラクタ。

パブリック メソッド

Assign | 影の｢値｣の特性を割り当てます。
Clone |
Draw | Rect矩形パラメーターの周りの影を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Brush | 影を塗りつぶすブラシ特性を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 影の色を取得/設定します。
Height | 影の垂直サイズをピクセル単位で設定します。
HorizSize |
Size | 影のサイズをピクセル単位で取得/設定します。
Transparency | 0～100%までの影の透明度を設定します。
VertSize |
Visible | 影を表示/非表示します。
Width | 影の水平サイズをピクセル単位で設定します。

プロテクト フィールド

bBrush
bVisible
defaultSize
defaultVisible
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight
ShouldSerializeVisible
ShouldSerializeWidth

参照

Shadow クラス | Steema.TeeChart.Drawing 名前空間


Shadow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow コンストラクタ

オーバーロードの一覧

チャートの影のコンストラクタ。

public Shadow(Steema.TeeChart.Chart)

チャートの影のコンストラクタ。影のサイズを定義します。

public Shadow(Steema.TeeChart.Chart, System.Int32)

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Shadow コンストラクタ

Steema.TeeChart.Drawing.Shadow コンストラクタ

チャートの影のコンストラクタ。
public Shadow(Chart c)

参照

Shadow コンストラクタのオーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Shadow コンストラクタ

Steema.TeeChart.Drawing.Shadow コンストラクタ

チャートの影のコンストラクタ。影のサイズを定義します。
public Shadow(Chart c,
     Int32 size)

参照

Shadow コンストラクタのオーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shadow フィールド

プロテクト フィールド

bBrush
bVisible
defaultSize
defaultVisible
InternalUse (TeeBaseの継承元)

参照

Shadow クラス | Steema.TeeChart.Drawing 名前空間


bBrush

Steema.TeeChart.Drawing.Shadow.bBrush フィールド

protected ChartBrush bBrush

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


bVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.bVisible フィールド

protected internal Boolean bVisible

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


defaultSize

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.defaultSize フィールド

protected internal Int32 defaultSize

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


defaultVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.defaultVisible フィールド

protected internal Boolean defaultVisible

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


fullDraw

Steema.TeeChart.Drawing.Shadow.fullDraw フィールド

protected Boolean fullDraw

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shadow メソッド

パブリック メソッド

Assign | 影の｢値｣の特性を割り当てます。
Clone |
Draw | Rect矩形パラメーターの周りの影を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight
ShouldSerializeVisible
ShouldSerializeWidth

参照

Shadow クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.Shadow.Assign メソッド

影の「値」の特性を割り当てます。
public Void Assign(Shadow value)

解説

すべてのプロパティをソースの影からSelfにコピーします。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.Shadow.Clone メソッド

public virtual Object Clone()

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

オーバーロードの一覧

Rect矩形パラメーターの周りの影を描画します。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

左上と右下の位置を示すパラメーターで定義された楕円の周りに影を描画します。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Int32, System.Int32)

Point配列パラメーターで定義された多角形の周りに影を描画します。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Int32, System.Int32, System.Drawing.Point[])

Rect矩形パラメーターの周りの影を描画します。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle, System.Int32, System.Int32)

解説

キャンバスを使用して、Rect矩形パラメーターの周りの影を描画します。

影を描画するためにHeightプロパティ、Widthプロパティ、Transparencyプロパティを使用してください。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

Rect矩形パラメーターの周りの影を描画します。
public Void Draw(Graphics3D g,
     Rectangle rect)

参照

Draw オーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

左上と右下の位置を示すパラメーターで定義された楕円の周りに影を描画します。
public Void Draw(Graphics3D g,
     Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Draw オーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

Point配列パラメーターで定義された多角形の周りに影を描画します。
public Void Draw(Graphics3D g,
     Int32 aWidth,
     Int32 aHeight,
     Point[] points)

参照

Draw オーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

Rect矩形パラメーターの周りの影を描画します。
public Void Draw(Graphics3D g,
     Rectangle rect,
     Int32 angle,
     Int32 aZ)

参照

Draw オーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Draw

Steema.TeeChart.Drawing.Shadow.Draw メソッド

points配列パラメーターにより定義された多角形の周りの影を描画します。
public Void Draw(Graphics3D g,
     Int32 aWidth,
     Int32 aHeight,
     PointDouble[] points)

参照

Draw オーバーロードの一覧 | Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.Shadow.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeHeight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.ShouldSerializeHeight メソッド

protected virtual Boolean ShouldSerializeHeight()

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.ShouldSerializeVisible メソッド

protected virtual Boolean ShouldSerializeVisible()

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeWidth

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.ShouldSerializeWidth メソッド

protected virtual Boolean ShouldSerializeWidth()

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shadow プロパティ

パブリック プロパティ

Brush | 影を塗りつぶすブラシ特性を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 影の色を取得/設定します。
Height | 影の垂直サイズをピクセル単位で設定します。
HorizSize |
Size | 影のサイズをピクセル単位で取得/設定します。
Transparency | 0～100%までの影の透明度を設定します。
VertSize |
Visible | 影を表示/非表示します。
Width | 影の水平サイズをピクセル単位で設定します。

参照

Shadow クラス | Steema.TeeChart.Drawing 名前空間


Brush

Steema.TeeChart.Drawing.Shadow.Brush プロパティ

影を塗りつぶすブラシ特性を定義します。
public ChartBrush Brush {get;}

解説

影を塗りつぶすブラシ特性を定義します。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Color プロパティ

影の色を取得/設定します。

public Color Color {get; set;}

解説

影の色を取得/設定します。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Height プロパティ

影の垂直サイズをピクセル単位で設定します。

public Int32 Height {get; set;}

解説

影の垂直サイズをピクセル単位で設定します。

例

[C#]

tChart1.Legend.Shadow.Visible = true;
tChart1.Legend.Shadow.Width = 10;
tChart1.Legend.Shadow.Height = 20;
tChart1.Legend.Shadow.Color = Color.DarkRed;
tChart1.Legend.Shadow.Transparency = 50;

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


HorizSize

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.HorizSize プロパティ

public Int32 HorizSize {get; set;}

旧式

このプロパティの代わりにWidthプロパティを使用してください。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Size

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Size プロパティ

影のサイズをピクセル単位で取得/設定します。

public Size Size {get; set;}

解説

HorizSizeプロパティとVertSizeプロパティの最大値を返します。

このプロパティを設定すると、HorizSizeプロパティとVertSizeプロパティを同じ値で設定します。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Transparency プロパティ

0～100%までの影の透明度を設定します。

public Int32 Transparency {get; set;}

解説

0～100%までの影の透明度を設定します。このプロパティが0の場合、前面のみが表示されます。このプロパティが100の場合、背面のみが表示されます。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


VertSize

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.VertSize プロパティ

public Int32 VertSize {get; set;}

旧式

このプロパティの代わりにHeightプロパティを使用してください。

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Visible プロパティ

影を表示/非表示します。

public Boolean Visible {get; set;}

解説

影を表示/非表示します。

例

[C#]

tChart1.Legend.Shadow.Visible = true;
tChart1.Legend.Shadow.Width = 10;
tChart1.Legend.Shadow.Color = Color.DarkRed;
tChart1.Legend.Shadow.Transparency = 50;

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shadow.Width プロパティ

影の水平サイズをピクセル単位で設定します。

public Int32 Width {get; set;}

解説

影の水平サイズをピクセル単位で設定します。

例

[C#]

tChart1.Legend.Shadow.Visible = true;
tChart1.Legend.Shadow.Width = 10;
tChart1.Legend.Shadow.Height = 20;
tChart1.Legend.Shadow.Color = Color.DarkRed;
tChart1.Legend.Shadow.Transparency = 50;

参照

Shadow クラス | Shadow メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Drawing.Shape クラス

チャートのシェープエレメントの基本クラス。

この型のすべてのメンバの一覧については、Shape メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Shape : TeeBase , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

Shape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shape 全メンバ

Shape 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Assign | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone |
CreateNewShape | 新しいShapeオブジェクトを作成してChartプロパティを設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NewFromType | 既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
Paint |

パブリック プロパティ

Bevel | シェープのベベル特性を設定します。
BevelInner |
BevelOuter |
BevelWidth |
BorderRound | チャートの枠を丸くします。
Bottom | シェープ矩形の下座標を取得/設定します。
Brush | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | シェープの色を定義します。
Gradient | シェープのグラデーション特性を設定します。
Height | シェープの高さを取得/設定します。
Image | シェープの背面に表示するイメージを設定します。
ImageBevel | シェープのベベル特性を設定します。
ImageMode | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent | シェープのイメージを透明に設定します。
Left | シェープ矩形の左座標を取得/設定します。
Pen | シェープを描くペンを指定します。
Right | シェープ矩形の右座標を取得/設定します。
Shadow | シェープの影の特性を定義します。
ShapeBounds | シェープの境界を定義します。
Top | シェープ矩形の上座標を取得/設定します。
Transparency | 0～100%までのシェープの透明度を設定します。
Transparent | シェープの透明度を有効/無効にします。
Visible | シェープを表示/非表示にします。
Width | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel
bBorderRound
bBrush
bImageBevel
bTransparent
defaultVisible
iBottom
iHeight
iLeft
InternalUse (TeeBaseの継承元)
iRight
iTop
iWidth
pPen
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom
ShouldSerializeLeft
ShouldSerializeRight
ShouldSerializeTop
ShouldSerializeTransparent
ShouldSerializeVisible

参照

Shape クラス | Steema.TeeChart.Drawing 名前空間


Shape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape コンストラクタ

オーバーロードの一覧

public Shape()
public Shape(Steema.TeeChart.Chart)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Shape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape コンストラクタ

public Shape()

参照

Shape コンストラクタのオーバーロードの一覧 | Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Shape コンストラクタ

Steema.TeeChart.Drawing.Shape コンストラクタ

public Shape(Chart c)

参照

Shape コンストラクタのオーバーロードの一覧 | Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shape フィールド

プロテクト フィールド

bBevel
bBorderRound
bBrush
bImageBevel
bTransparent
defaultVisible
iBottom
iHeight
iLeft
InternalUse (TeeBaseの継承元)
iRight
iTop
iWidth
pPen
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Shape クラス | Steema.TeeChart.Drawing 名前空間


bBevel

Steema.TeeChart.Drawing.Shape.bBevel フィールド

protected Bevel bBevel

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


bBorderRound

Steema.TeeChart.Drawing.Shape.bBorderRound フィールド

protected Int32 bBorderRound

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


bBrush

Steema.TeeChart.Drawing.Shape.bBrush フィールド

protected ChartBrush bBrush

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


bImageBevel

Steema.TeeChart.Drawing.Shape.bImageBevel フィールド

protected ImageBevel bImageBevel

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


bTransparent

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.bTransparent フィールド

protected Boolean bTransparent

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


defaultVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.defaultVisible フィールド

protected internal Boolean defaultVisible

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iBottom

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.iBottom フィールド

protected Int32 iBottom

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iHeight

Steema.TeeChart.Drawing.Shape.iHeight フィールド

protected Int32 iHeight

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iLeft

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.iLeft フィールド

protected Int32 iLeft

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iRight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.iRight フィールド

protected Int32 iRight

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iTop

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.iTop フィールド

protected Int32 iTop

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


iWidth

Steema.TeeChart.Drawing.Shape.iWidth フィールド

protected Int32 iWidth

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


pPen

Steema.TeeChart.Drawing.Shape.pPen フィールド

protected internal ChartPen pPen

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shape メソッド

パブリック メソッド

Assign | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone |
CreateNewShape | 新しいShapeオブジェクトを作成してChartプロパティを設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NewFromType | 既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
Paint |

プロテクト メソッド

AssignShape
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom
ShouldSerializeLeft
ShouldSerializeRight
ShouldSerializeTop
ShouldSerializeTransparent
ShouldSerializeVisible

参照

Shape クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.Shape.Assign メソッド

すべてのプロパティを指定したシェープから他のシェープへ割り当てます。
public Void Assign(Shape s)

解説

すべてのプロパティを指定したシェープから他のシェープへ割り当てます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


AssignShape

Steema.TeeChart.Drawing.Shape.AssignShape メソッド

protected abstract Void AssignShape(Shape s)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Clone

Steema.TeeChart.Drawing.Shape.Clone メソッド

public virtual Object Clone()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


CreateNewShape

Steema.TeeChart.Drawing.Shape.CreateNewShape メソッド

新しいShapeオブジェクトを作成してChartプロパティを設定します。
public static Shape CreateNewShape(Chart chart,
     Type type)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


NewFromType

Steema.TeeChart.Drawing.Shape.NewFromType メソッド

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
public static Shape NewFromType(Type type)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Paint

Steema.TeeChart.Drawing.Shape.Paint メソッド

public abstract Void Paint(Graphics3D g,
     Rectangle rect)

解説

矩形rectにシェープを描画します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.Shape.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeBottom

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeBottom メソッド

protected virtual Boolean ShouldSerializeBottom()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeLeft

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeLeft メソッド

protected virtual Boolean ShouldSerializeLeft()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeRight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeRight メソッド

protected virtual Boolean ShouldSerializeRight()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeTop

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeTop メソッド

protected virtual Boolean ShouldSerializeTop()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeTransparent

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeTransparent メソッド

protected virtual Boolean ShouldSerializeTransparent()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeVisible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShouldSerializeVisible メソッド

protected virtual Boolean ShouldSerializeVisible()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Shape プロパティ

パブリック プロパティ

Bevel | シェープのベベル特性を設定します。
BevelInner |
BevelOuter |
BevelWidth |
BorderRound | チャートの枠を丸くします。
Bottom | シェープ矩形の下座標を取得/設定します。
Brush | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | シェープの色を定義します。
Gradient | シェープのグラデーション特性を設定します。
Height | シェープの高さを取得/設定します。
Image | シェープの背面に表示するイメージを設定します。
ImageBevel | シェープのベベル特性を設定します。
ImageMode | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent | シェープのイメージを透明に設定します。
Left | シェープ矩形の左座標を取得/設定します。
Pen | シェープを描くペンを指定します。
Right | シェープ矩形の右座標を取得/設定します。
Shadow | シェープの影の特性を定義します。
ShapeBounds | シェープの境界を定義します。
Top | シェープ矩形の上座標を取得/設定します。
Transparency | 0～100%までのシェープの透明度を設定します。
Transparent | シェープの透明度を有効/無効にします。
Visible | シェープを表示/非表示にします。
Width | シェープの幅を取得/設定します。

参照

Shape クラス | Steema.TeeChart.Drawing 名前空間


Bevel

Steema.TeeChart.Drawing.Shape.Bevel プロパティ

シェープのベベル特性を設定します。
public Bevel Bevel {get;}

解説

シェープのベベル特性を設定します。

例

[C#]

tChart1.Legend.Bevel.ColorOne = System.Drawing.Color.Red;
tChart1.Legend.Bevel.ColorTwo = System.Drawing.Color.Yellow;
tChart1.Legend.Bevel.Inner = Steema.TeeChart.Drawing.BevelStyles.Lowered;
tChart1.Legend.Bevel.Outer = Steema.TeeChart.Drawing.BevelStyles.Raised;

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


BevelInner

Steema.TeeChart.Drawing.Shape.BevelInner プロパティ

public BevelStyles BevelInner {get; set;}

旧式

このプロパティの代わりに、Bevel.Innerプロパティを使用してください。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


BevelOuter

Steema.TeeChart.Drawing.Shape.BevelOuter プロパティ

public BevelStyles BevelOuter {get; set;}

旧式

このプロパティの代わりに、Bevel.Outerプロパティを使用してください。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


BevelWidth

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.BevelWidth プロパティ

public Int32 BevelWidth {get; set;}

旧式

このプロパティの代わりにBevel.Widthプロパティを使用してください。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


BorderRound

Steema.TeeChart.Drawing.Shape.BorderRound プロパティ

チャートの枠を丸くします。
public Int32 BorderRound {get; set;}

例

このプロパティの使用例です。

private void numericUpDown1_ValueChanged(object sender, System.EventArgs e) {
    tChart1.Panel.BorderRound = (int)numericUpDown1.Value;
}

解説

チャートの枠を丸くします。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Bottom

Steema.TeeChart.Drawing.Shape.Bottom プロパティ

シェープ矩形の下座標を取得/設定します。
public Int32 Bottom {get; set;}

解説

シェープ矩形の下座標を取得/設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Brush

Steema.TeeChart.Drawing.Shape.Brush プロパティ

シェープの背面を塗りつぶすブラシの種類を設定します。
public ChartBrush Brush {get; set;}

解説

シェープの背面を塗りつぶすブラシの種類を設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.Color プロパティ

シェープの色を定義します。

public Color Color {get; set;}

解説

シェープの色を定義します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Gradient

Steema.TeeChart.Drawing.Shape.Gradient プロパティ

シェープのグラデーション特性を設定します。
public Gradient Gradient {get; set;}

解説

シェープのグラデーション特性を設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Height

Steema.TeeChart.Drawing.Shape.Height プロパティ

シェープの高さを設定します。

public Int32 Height {get; set;}

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Image

Steema.TeeChart.Drawing.Shape.Image プロパティ

シェープの背面に表示するイメージを設定します。
public Image Image {get; set;}

解説

シェープの背面に表示するイメージを設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ImageBevel

Steema.TeeChart.Drawing.Shape.ImageBevel プロパティ

シェープのベベル特性を設定します。

public ImageBevel ImageBevel {get;}

解説

シェープのベベル特性を設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ImageMode

Steema.TeeChart.Drawing.Shape.ImageMode プロパティ

設定されたシェープの背面イメージの表示スタイルを設定します。
public ImageMode ImageMode {get; set;}

解説

設定されたシェープの背面イメージの表示スタイルを設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ImageTransparent

Steema.TeeChart.Drawing.Shape.ImageTransparent プロパティ

シェープのイメージを透明に設定します。
public Boolean ImageTransparent {get; set;}

解説

シェープのイメージを透明に設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Left

Steema.TeeChart.Drawing.Shape.Left プロパティ

シェープ矩形の左座標を取得/設定します。
public Int32 Left {get; set;}

解説

シェープ矩形の左座標を取得/設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Pen

Steema.TeeChart.Drawing.Shape.Pen プロパティ

シェープを描くペンを指定します。
public ChartPen Pen {get; set;}

解説

シェープを描くペンを指定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Right

Steema.TeeChart.Drawing.Shape.Right プロパティ

シェープ矩形の右座標を取得/設定します。
public Int32 Right {get; set;}

解説

シェープ矩形の右座標を取得/設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Shadow

Steema.TeeChart.Drawing.Shape.Shadow プロパティ

シェープの影の特性を定義します。
public Shadow Shadow {get;}

解説

シェープの影の特性を定義します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


ShapeBounds

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.ShapeBounds プロパティ

シェープの境界を定義します。

public Rectangle ShapeBounds {get; set;}

解説

シェープの境界を定義します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Top

Steema.TeeChart.Drawing.Shape.Top プロパティ

シェープ矩形の上座標を取得/設定します。
public Int32 Top {get; set;}

解説

シェープ矩形の上座標を取得/設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.Transparency プロパティ

0～100%までのシェープの透明度を設定します。

public Int32 Transparency {get; set;}

解説

0～100%までのシェープの透明度を設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Transparent

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.Transparent プロパティ

シェープの透明度を有効/無効にします。

public Boolean Transparent {get; set;}

解説

シェープの透明度を有効/無効にします。このプロパティがTrueの場合、透明度のパーセント率を設定するTransparencyプロパティを参照してください。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Shape.Visible プロパティ

シェープを表示/非表示にします。

public Boolean Visible {get; set;}

解説

シェープを表示/非表示にします。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Width

Steema.TeeChart.Drawing.Shape.Width プロパティ

シェープの幅を設定します。

public Int32 Width {get; set;}

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ShapeSize

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ShapeSize クラス

サイズホルダー。

この型のすべてのメンバの一覧については、ShapeSize メンバを参照してください。

System.Object
public class ShapeSize : Object

必要条件

名前空間： Steema.TeeChart.Drawing

アセンブリ：TeeChart.dll

参照

ShapeSize メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ShapeSize 全メンバ

ShapeSize 概要

コンストラクタ

Constructor

パブリック フィールド

Height
Width

参照

ShapeSize クラス | Steema.TeeChart.Drawing 名前空間


ShapeSize コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ShapeSize コンストラクタ

public ShapeSize()

参照

ShapeSize クラス | ShapeSize メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ShapeSize フィールド

パブリック フィールド

Height
Width

参照

ShapeSize クラス | Steema.TeeChart.Drawing 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ShapeSize.Height フィールド

public Int32 Height

参照

ShapeSize クラス | ShapeSize メンバ | Steema.TeeChart.Drawing 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.ShapeSize.Width フィールド

public Int32 Width

参照

ShapeSize クラス | ShapeSize メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.SmoothStretchOption

Steema.TeeChart.Drawing.SmoothStretchOption 列挙体

[Serializable]
public sealed enum SmoothStretchOption : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
BestQuality |
BestPerformance |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.SurfaceStyle

Steema.TeeChart.Drawing.SurfaceStyle 列挙体

[Serializable]
public sealed enum SurfaceStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Solid |
Wire |
Dot |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeBase

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase クラス

チャートエレメントの共通の特性クラス。

この型のすべてのメンバの一覧については、TeeBase メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
[Serializable]
public class TeeBase : Component , IComponent
, IDisposable

必要条件

名前空間： Steema.TeeChart.Drawing

アセンブリ：TeeChart.dll

参照

TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeBase 全メンバ

TeeBase 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Invalidate キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse

プロテクト メソッド

SetBooleanProperty
SetChart
SetColorProperty
SetDoubleProperty
SetFloatProperty
SetIntegerProperty
SetStringProperty

参照

TeeBase クラス | Steema.TeeChart.Drawing 名前空間


TeeBase コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase コンストラクタ

オーバーロードの一覧

public TeeBase(Steema.TeeChart.Chart)
public TeeBase()

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


TeeBase コンストラクタ

Steema.TeeChart.Drawing.TeeBase コンストラクタ

public TeeBase(Chart c)

参照

TeeBase コンストラクタのオーバーロードの一覧 | TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


TeeBase コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase コンストラクタ

public TeeBase()

参照

TeeBase コンストラクタのオーバーロードの一覧 | TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeBase フィールド

プロテクト フィールド

InternalUse

参照

TeeBase クラス | Steema.TeeChart.Drawing 名前空間


InternalUse

Steema.TeeChart.Drawing.TeeBase.InternalUse フィールド

protected internal Boolean InternalUse

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeBase メソッド

パブリック メソッド

Invalidate キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty
SetChart
SetColorProperty
SetDoubleProperty
SetFloatProperty
SetIntegerProperty
SetStringProperty

参照

TeeBase クラス | Steema.TeeChart.Drawing 名前空間


Invalidate

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.Invalidate メソッド

キャンバス全体を再描画する必要がある場合に使用してください。

public virtual Void Invalidate()

解説

キャンバス全体を再描画する必要がある場合に使用してください。キャンバスを再描画する必要がある領域が複数ある場合、このメソッドは再描画によるチラツキを避けて、キャンバス全体を一度に再描画します。実際に再描画される前に何度もこのメソッドを呼び出しても問題はありません。

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetBooleanProperty

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.SetBooleanProperty メソッド

protected Void SetBooleanProperty(Boolean& variable,
     Boolean value)

パラメーター

variable
変更するためのBoolean変数
value
新しい値

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.TeeBase.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetColorProperty

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.SetColorProperty メソッド

protected Void SetColorProperty(Color& variable,
     Color value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetDoubleProperty

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.SetDoubleProperty メソッド

protected Void SetDoubleProperty(Double& variable,
     Double value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetFloatProperty

Steema.TeeChart.Drawing.TeeBase.SetFloatProperty メソッド

protected Void SetFloatProperty(Single& variable,
     Single value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetIntegerProperty

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.SetIntegerProperty メソッド

protected Void SetIntegerProperty(Int32& variable,
     Int32 value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


SetStringProperty

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TeeBase.SetStringProperty メソッド

protected Void SetStringProperty(String& variable,
     String value)

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeBase プロパティ

パブリック プロパティ

Chart オブジェクトに関連付けるチャートを設定します。

参照

TeeBase クラス | Steema.TeeChart.Drawing 名前空間


Chart

Steema.TeeChart.Drawing.TeeBase.Chart プロパティ

オブジェクトに関連付けるチャートを設定します。
public Chart Chart {get; set;}

解説

オブジェクトに関連付けるチャートを設定します。

参照

TeeBase クラス | TeeBase メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TeeFontStyle

Steema.TeeChart.Drawing.TeeFontStyle 列挙体

[Serializable]
public sealed enum TeeFontStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Bitmap |
Normal |
Outline |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextFormat

Steema.TeeChart.Drawing.TextFormat 列挙体

[Serializable]
public sealed enum TextFormat : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Normal |
Html |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShape

Steema.TeeChart.Drawing.TextShape クラス

テキストを持つチャートのシェープエレメントの基本クラス。

この型のすべてのメンバの一覧については、TextShape メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class TextShape : Shape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShape 全メンバ

TextShape 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size

パブリック メソッド

Assign | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText |
Color (Shapeの継承元) | シェープの色を定義します。
Font | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text | シェープ内にカスタマイズされた文字列を表示します。
TextAlign |
TextFormat | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape
CalcBounds
DrawString
DrawText
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength

参照

TextShape クラス | Steema.TeeChart.Drawing 名前空間


TextShape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape コンストラクタ

オーバーロードの一覧

public TextShape()
public TextShape(Steema.TeeChart.Chart)

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


TextShape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape コンストラクタ

public TextShape()

参照

TextShape コンストラクタのオーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


TextShape コンストラクタ

Steema.TeeChart.Drawing.TextShape コンストラクタ

public TextShape(Chart c)

参照

TextShape コンストラクタのオーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShape フィールド

パブリック フィールド

Size

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TextShape クラス | Steema.TeeChart.Drawing 名前空間


defaultText

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.defaultText フィールド

protected internal String defaultText

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


iDrawText

Steema.TeeChart.Drawing.TextShape.iDrawText フィールド

protected internal Boolean iDrawText

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Size

Steema.TeeChart.Drawing.TextShape.Size フィールド

public ShapeSize Size

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShape メソッド

パブリック メソッド

Assign | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape
CalcBounds
DrawString
DrawText
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

TextShape クラス | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.TextShape.Assign メソッド

オーバーロードの一覧

すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。

public Void Assign(Steema.TeeChart.Drawing.TextShape)

解説

すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Assign

Steema.TeeChart.Drawing.TextShape.Assign メソッド

すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
public Void Assign(TextShape s)

参照

Assign オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


AssignShape

Steema.TeeChart.Drawing.TextShape.AssignShape メソッド

protected abstract Void AssignShape(Shape s)

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


CalcBounds

Steema.TeeChart.Drawing.TextShape.CalcBounds メソッド

オーバーロードの一覧

protected internal Void CalcBounds()
protected internal Void CalcBounds(Steema.TeeChart.Drawing.Graphics3D)

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


CalcBounds

Steema.TeeChart.Drawing.TextShape.CalcBounds メソッド

protected internal Void CalcBounds()

参照

CalcBounds オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


CalcBounds

Steema.TeeChart.Drawing.TextShape.CalcBounds メソッド

protected internal Void CalcBounds(Graphics3D g)

参照

CalcBounds オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


DrawRectRotated

Steema.TeeChart.Drawing.TextShape.DrawRectRotated メソッド

指定した回転角度でシェープ矩形を描画します。
public Void DrawRectRotated(Graphics3D g,
     Rectangle rect,
     Int32 angle,
     Int32 aZ)

解説

指定した回転角度でシェープ矩形を描画します。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


DrawString

Steema.TeeChart.Drawing.TextShape.DrawString メソッド

protected abstract Void DrawString(Graphics3D g,
     Int32 x,
     Int32 y,
     Int32 t,
     Int32 tmpHeight,
     String[] s)

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


DrawText

Steema.TeeChart.Drawing.TextShape.DrawText メソッド

オーバーロードの一覧

protected internal Void DrawText(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)
protected internal Void DrawText()

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


DrawText

Steema.TeeChart.Drawing.TextShape.DrawText メソッド

protected internal Void DrawText(Graphics3D g,
     Rectangle rect)

参照

DrawText オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


DrawText

Steema.TeeChart.Drawing.TextShape.DrawText メソッド

protected internal Void DrawText()

参照

DrawText オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Paint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.Paint メソッド

オーバーロードの一覧

チャートキャンバスにTextShapeオブジェクトを描画します。

public virtual Void Paint(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Rectangle)

チャートキャンバスにTextShapeオブジェクトを描画します。

public Void Paint()

解説

チャートキャンバスにTextShapeオブジェクトを描画します。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Paint

Steema.TeeChart.Drawing.TextShape.Paint メソッド

チャートキャンバスにTextShapeオブジェクトを描画します。
public override Void Paint(Graphics3D g,
     Rectangle rect)

参照

Paint オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Paint

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.Paint メソッド

チャートキャンバスにTextShapeのオブジェクトを描画します。

public Void Paint()

参照

Paint オーバーロードの一覧 | TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


SetChart

Steema.TeeChart.Drawing.TextShape.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeLines

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.ShouldSerializeLines メソッド

protected virtual Boolean ShouldSerializeLines()

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShape プロパティ

パブリック プロパティ

AutoSize |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText |
Color (Shapeの継承元) | シェープの色を定義します。
Font | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text | シェープ内にカスタマイズされた文字列を表示します。
TextAlign |
TextFormat | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength

参照

TextShape クラス | Steema.TeeChart.Drawing 名前空間


AutoSize

Steema.TeeChart.Drawing.TextShape.AutoSize プロパティ

public Boolean AutoSize {get; set;}

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


ClipText

Steema.TeeChart.Drawing.TextShape.ClipText プロパティ

public Boolean ClipText {get; set;}

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Font

Steema.TeeChart.Drawing.TextShape.Font プロパティ

ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
public ChartFont Font {get; set;}

解説

ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Lines

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.Lines プロパティ

テキスト行の配列にアクセスします。

public String[] Lines {get; set;}

解説

TeeChartのテキストオブジェクト（TeeChartのヘッダー、軸タイトル、など）に複数行のテキストを追加するために使用してください。

例

[C#]
string[] header = new string[] {"First Line", "Second Line"};
Steema.TeeChart.Chart tChart1 = WebChart1.Chart;
BarSeries barSeries1 = new BarSeries(tChart1);
barSeries1.FillSampleValues(20);
tChart1.Header.Lines = header;

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


LinesLength

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.LinesLength プロパティ

protected Int32 LinesLength {get;}

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


ShadowSize

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.ShadowSize プロパティ

public Int32 ShadowSize {get; set;}

旧式

このプロパティの代わりにShadow.Sizeプロパティを使用してください。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


ShapeStyle

Steema.TeeChart.Drawing.TextShape.ShapeStyle プロパティ

シェープのスタイルを矩形または角の丸い矩形に設定します。
public TextShapeStyle ShapeStyle {get; set;}

解説

シェープのスタイルを矩形または角の丸い矩形に設定します。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShape.Text プロパティ

シェープ内でカスタマイズされた文字列を表示します。

public String Text {get; set;}

解説

シェープ内にカスタマイズされた文字列を表示します。

テキスト表示を制御するためにFontプロパティやAligmentプロパティが使用できます。

メモ：メタファイルを作成する際やチャートをズームする際に、さまざまな値のためにシェープのフォントサイズを変更する場合があります。

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


TextAlign

Steema.TeeChart.Drawing.TextShape.TextAlign プロパティ

public StringAlignment TextAlign {get; set;}

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


TextFormat

Steema.TeeChart.Drawing.TextShape.TextFormat プロパティ

テキストを標準またはHTML形式のどちらで表示するかを定義します。

public TextFormat TextFormat {get; set;}

参照

TextShape クラス | TextShape メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition

Steema.TeeChart.Drawing.TextShapePosition クラス

シェープのカスタム位置。

この型のすべてのメンバの一覧については、TextShapePosition メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class TextShapePosition : TextShape , IComponent, IDisposable
, ICloneable

解説

アノテーションツールのテキストボックスやテキストのデフォルト位置を定義します。

例

[C#]

private void Form1_Load(object sender, System.EventArgs e)
{
     Steema.TeeChart.Annotation annotation1 = new Steema.TeeChart.Annotation(tChart1.Chart);
     annotation1.Position = Steema.TeeChart.AnnotationPositions.RightTop;
     annotation1.Active = true;
     annotation1.Text = "test text";
}

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition 全メンバ

TextShapePosition 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom
ShouldSerializeLeft
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight
ShouldSerializeTop
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

TextShapePosition クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition コンストラクタ

オーバーロードの一覧

public TextShapePosition()
public TextShapePosition(Steema.TeeChart.Chart)

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition コンストラクタ

public TextShapePosition()

参照

TextShapePosition コンストラクタのオーバーロードの一覧 | TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition コンストラクタ

public TextShapePosition(Chart c)

参照

TextShapePosition コンストラクタのオーバーロードの一覧 | TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TextShapePosition クラス | Steema.TeeChart.Drawing 名前空間


bCustomPosition

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.bCustomPosition フィールド

protected Boolean bCustomPosition

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom
ShouldSerializeLeft
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight
ShouldSerializeTop
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

TextShapePosition クラス | Steema.TeeChart.Drawing 名前空間


AssignShape

Steema.TeeChart.Drawing.TextShapePosition.AssignShape メソッド

protected abstract Void AssignShape(Shape s)

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeBottom

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.ShouldSerializeBottom メソッド

protected virtual Boolean ShouldSerializeBottom()

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeLeft

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.ShouldSerializeLeft メソッド

protected virtual Boolean ShouldSerializeLeft()

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeRight

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.ShouldSerializeRight メソッド

protected virtual Boolean ShouldSerializeRight()

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


ShouldSerializeTop

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.ShouldSerializeTop メソッド

protected virtual Boolean ShouldSerializeTop()

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapePosition プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

TextShapePosition クラス | Steema.TeeChart.Drawing 名前空間


CustomPosition

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapePosition.CustomPosition プロパティ

TextShapeのカスタム位置の設定を有効/無効にします。

public Boolean CustomPosition {get; set;}

解説

このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。

参照

TextShapePosition クラス | TextShapePosition メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TextShapeStyle

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.TextShapeStyle 列挙体

テキストを含むシェープのスタイルを定義します。

[Serializable]
public enum TextShapeStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Rectangle | 矩形のシェープを定義します。
RoundRectangle | 角の丸い矩形のシェープを定義します。

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ThreeDPlane

Steema.TeeChart.Drawing.ThreeDPlane 列挙体

方向。
[Serializable]
public sealed enum ThreeDPlane : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
cpX |
cpY |
cpZ |

参照

Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle2D

Steema.TeeChart.Drawing.Triangle2D 構造体

三角形2Dエレメントホルダー。

この型のすべてのメンバの一覧については、Triangle2D メンバを参照してください。

System.Object
System.ValueType
public sealed struct Triangle2D : ValueType

参照

Triangle2D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle2D 全メンバ

Triangle2D 概要

パブリック フィールド

p0
p1
p2

参照

Triangle2D 構造体 | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle2D フィールド

パブリック フィールド

p0
p1
p2

参照

Triangle2D 構造体 | Steema.TeeChart.Drawing 名前空間


p0

Steema.TeeChart.Drawing.Triangle2D.p0 フィールド

public Point p0

参照

Triangle2D 構造体 | Triangle2D メンバ | Steema.TeeChart.Drawing 名前空間


p1

Steema.TeeChart.Drawing.Triangle2D.p1 フィールド

public Point p1

参照

Triangle2D 構造体 | Triangle2D メンバ | Steema.TeeChart.Drawing 名前空間


p2

Steema.TeeChart.Drawing.Triangle2D.p2 フィールド

public Point p2

参照

Triangle2D 構造体 | Triangle2D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle3D

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.Triangle3D 構造体

三角形エレメントホルダー

この型のすべてのメンバの一覧については、Triangle3Dメンバを参照してください。

System.Object
System.ValueType
public struct Triangle3D : ValueType

参照

Triangle3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle3D 全メンバ

Triangle3D 概要

パブリック フィールド

p0
p1
p2

参照

Triangle3D 構造体 | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.Triangle3D フィールド

パブリック フィールド

p0
p1
p2

参照

Triangle3D 構造体 | Steema.TeeChart.Drawing 名前空間


p0

Steema.TeeChart.Drawing.Triangle3D.p0 フィールド

public Point3D p0

参照

Triangle3D 構造体 | Triangle3D メンバ | Steema.TeeChart.Drawing 名前空間


p1

Steema.TeeChart.Drawing.Triangle3D.p1 フィールド

public Point3D p1

参照

Triangle3D 構造体 | Triangle3D メンバ | Steema.TeeChart.Drawing 名前空間


p2

Steema.TeeChart.Drawing.Triangle3D.p2 フィールド

public Point3D p2

参照

Triangle3D 構造体 | Triangle3D メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TTFontData

Steema.TeeChart.Drawing.TTFontData 構造体

この型のすべてのメンバの一覧については、TTFontData メンバを参照してください。

System.Object
System.ValueType
public sealed struct TTFontData : ValueType

参照

TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TTFontData 全メンバ

TTFontData 概要

コンストラクタ

Constructor

パブリック フィールド

Ascent
AvgWidth
CapHeight
Descent
FirstChar
FontBBox
ItalicAngle
LastChar
MaxWidth
Widths

参照

TTFontData 構造体 | Steema.TeeChart.Drawing 名前空間


TTFontData コンストラクタ

Steema.TeeChart.Drawing.TTFontData コンストラクタ

public TTFontData(ChartFont f)

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.TTFontData フィールド

パブリック フィールド

Ascent
AvgWidth
CapHeight
Descent
FirstChar
FontBBox
ItalicAngle
LastChar
MaxWidth
Widths

参照

TTFontData 構造体 | Steema.TeeChart.Drawing 名前空間


Ascent

Steema.TeeChart.Drawing.TTFontData.Ascent フィールド

public Int32 Ascent

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


AvgWidth

Steema.TeeChart.Drawing.TTFontData.AvgWidth フィールド

public Int32 AvgWidth

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


CapHeight

Steema.TeeChart.Drawing.TTFontData.CapHeight フィールド

public Int32 CapHeight

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


Descent

Steema.TeeChart.Drawing.TTFontData.Descent フィールド

public Int32 Descent

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


FirstChar

Steema.TeeChart.Drawing.TTFontData.FirstChar フィールド

public Int32 FirstChar

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


FontBBox

Steema.TeeChart.Drawing.TTFontData.FontBBox フィールド

public Rectangle FontBBox

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


ItalicAngle

Steema.TeeChart.Drawing.TTFontData.ItalicAngle フィールド

public Int32 ItalicAngle

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


LastChar

Steema.TeeChart.Drawing.TTFontData.LastChar フィールド

public Int32 LastChar

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


MaxWidth

Steema.TeeChart.Drawing.TTFontData.MaxWidth フィールド

public Int32 MaxWidth

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


Widths

Steema.TeeChart.Drawing.TTFontData.Widths フィールド

public Int32[] Widths

参照

TTFontData 構造体 | TTFontData メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.View3DEvent

Steema.TeeChart.Drawing.View3DEvent クラス

動作に関するAspectの通知クラス。

この型のすべてのメンバの一覧については、View3DEvent メンバを参照してください。

System.Object
Steema.TeeChart.TeeEvent
public class View3DEvent : TeeEvent

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

View3DEvent メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.View3DEvent 全メンバ

View3DEvent 概要

コンストラクタ

Constructor

パブリック フィールド

sender (TeeEventの継承元)

参照

View3DEvent クラス | Steema.TeeChart.Drawing 名前空間


View3DEvent コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Drawing.View3DEvent コンストラクタ

public View3DEvent()

参照

View3DEvent クラス | View3DEvent メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.View3DEvent フィールド

パブリック フィールド

sender (TeeEventの継承元)

参照

View3DEvent クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter

Steema.TeeChart.Drawing.ZoomFilter クラス

この型のすべてのメンバの一覧については、ZoomFilter メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.Filter
public class ZoomFilter : Filter

必要条件

名前空間: Steema.TeeChart.Drawing 名前空間

アセンブリ: TeeChart.dll

参照

ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter 全メンバ

ZoomFilter 概要

コンストラクタ

Constructor

パブリック フィールド

Lines (Filterの継承元)

パブリック メソッド

Apply

パブリック プロパティ

Enabled (Filterの継承元)
Percent
Region (Filterの継承元)
Smooth

プロテクト フィールド

AllowRegion (Filterの継承元)

プロテクト メソッド

CalcLines (Filterの継承元)

参照

ZoomFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter コンストラクタ

public ZoomFilter()

参照

ZoomFilter クラス | ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter フィールド

パブリック フィールド

Lines (Filterの継承元)

プロテクト フィールド

AllowRegion (Filterの継承元)

参照

ZoomFilter クラス | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter メソッド

パブリック メソッド

Apply

プロテクト メソッド

CalcLines (Filterの継承元)

参照

ZoomFilter クラス | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.ZoomFilter.Apply メソッド

オーバーロードの一覧

public override Void Apply(System.Drawing.Bitmap&, System.Drawing.Rectangle)

参照

ZoomFilter クラス | ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Apply

Steema.TeeChart.Drawing.ZoomFilter.Apply メソッド

public override Void Apply(Bitmap& bitmap,
     Rectangle rect)

参照

Apply オーバーロードの一覧 | ZoomFilter クラス | ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Drawing.ZoomFilter プロパティ

パブリック プロパティ

Enabled (Filterの継承元)
Percent
Region (Filterの継承元)
Smooth

参照

ZoomFilter クラス | Steema.TeeChart.Drawing 名前空間


Percent

Steema.TeeChart.Drawing.ZoomFilter.Percent プロパティ

public Double Percent {get; set;}

参照

ZoomFilter クラス | ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Smooth

Steema.TeeChart.Drawing.ZoomFilter.Smooth プロパティ

public Boolean Smooth {get; set;}

参照

ZoomFilter クラス | ZoomFilter メンバ | Steema.TeeChart.Drawing 名前空間


Steema.TeeChart.Export

Steema.TeeChart.Export 名前空間

名前空間の階層構造

パブリック クラス

SerializeBinder | 内部使用。インポートバインダー。
ExportFormat | 共通のエクスポート特性。
Exports | イメージやデータとしてチャートを保存するためのエクスポート形式。
DataExport | TeeChartのデータエクスポート形式にアクセスします。
DataExportFormat | すべてのデータエクスポートクラスの共通メソッド。
XMLFormat | XMLにチャートデータをエクスポートします。
TextFormat | テキストにチャートデータをエクスポートします。
HTMLFormat | HTMLテーブルにチャートデータをエクスポートします。
ExcelFormat | Excelのスプレッドシートにチャートデータをエクスポートします。
ThemeExport | XMLテーマ形式にチャートデータをエクスポートします。
TemplateExport | ネイティブ｢ten｣テンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
ImageExport | チャートイメージのエクスポートの基本的なメソッドのクラス。
ImageFormats | 内部使用。使用可能なイメージ形式。
ImageExportFormat | 基本クラス。共通のエクスポート特性。
BitmapFormat | ビットマップのエクスポートのためのクラス。
MetafileFormat | メタファイルのエクスポート形式。
JPEGFormat | チャートのJPEGイメージ特性のクラス。
PNGFormat | PNGイメージのエクスポート形式。
GIFFormat | GIFイメージのエクスポート形式。
TIFFFormat | TIFFイメージのエクスポート形式。
PDFFormat | Adobe PDFのエクスポート形式。
VMLFormat | VMLのエクスポート形式。
XAMLFormat | XAMLのエクスポート形式。
SVGFormat | SVGのエクスポート形式。
EPSFormat | EPSのエクスポート形式。
PDFPage |
PDFData | PDFDataの概要。
PDFFonts | すべての使用されるフォントを保持します。
PDFFont |
EPSPage |
EPSData | EPSDataの概要。
EPSFonts |
EPSFont |

パブリック インタフェース

ICustomSerialization

パブリック 列挙体

PictureFormats | チャートイメージのエクスポート形式です。
BMPColorReduction | ビットマップイメージの減色タイプを定義します。
GIFColorReduction | GIFイメージの減色タイプを定義します。
TIFFCompression | TIFFイメージの圧縮タイプを定義します。

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Export 階層構造

System.Object

Steema.TeeChart.Drawing.GraphicsFont

Steema.TeeChart.Export.EPSData.EPSFont

Steema.TeeChart.Export.PDFData.PDFFont

Steema.TeeChart.Export.DataExport

Steema.TeeChart.Export.EPSData

Steema.TeeChart.Export.EPSPage

Steema.TeeChart.Export.ExportFormat

Steema.TeeChart.Export.DataExportFormat

Steema.TeeChart.Export.HTMLFormat

Steema.TeeChart.Export.ExcelFormat

Steema.TeeChart.Export.TextFormat

Steema.TeeChart.Export.XMLFormat

Steema.TeeChart.Export.ImageExportFormat

Steema.TeeChart.Export.BitmapFormat

Steema.TeeChart.Export.EPSFormat

Steema.TeeChart.Export.GIFFormat

Steema.TeeChart.Export.JPEGFormat

Steema.TeeChart.Export.MetafileFormat

Steema.TeeChart.Export.PDFFormat

Steema.TeeChart.Export.PNGFormat

Steema.TeeChart.Export.SVGFormat

Steema.TeeChart.Export.TIFFFormat

Steema.TeeChart.Export.VMLFormat

Steema.TeeChart.Export.XAMLFormat

Steema.TeeChart.Export.TemplateExport

Steema.TeeChart.Export.ThemeExport

Steema.TeeChart.Export.Exports

Steema.TeeChart.Export.ImageExport

Steema.TeeChart.Export.ImageFormats

Steema.TeeChart.Export.PDFData

Steema.TeeChart.Export.PDFPage

System.Collections.ArrayList

Steema.TeeChart.Drawing.GraphicsFonts

Steema.TeeChart.Export.EPSData.EPSFonts

Steema.TeeChart.Export.PDFData.PDFFonts

System.Runtime.Serialization.SerializationBinder

Steema.TeeChart.Export.SerializeBinder

参照

SteemaTeeChartExport 名前空間


Steema.TeeChart.Export.BitmapFormat

Steema.TeeChart.Export.BitmapFormat クラス

ビットマップのエクスポートのためのクラス。

この型のすべてのメンバの一覧については、BitmapFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class BitmapFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

BitmapFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.BitmapFormat 全メンバ

BitmapFormat 概要

コンストラクタ

Constructor チャートのビットマップ形式のコンストラクタ。

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。

パブリック プロパティ

ColorReduction | ビットマップイメージの色形式特性を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

BitmapFormat クラス | Steema.TeeChart.Export 名前空間


BitmapFormat コンストラクタ

Steema.TeeChart.Export.BitmapFormat コンストラクタ

チャートのビットマップ形式のコンストラクタ。
public BitmapFormat(Chart c)

参照

BitmapFormat クラス | BitmapFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.BitmapFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルト拡張子文字列です。

参照

BitmapFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.BitmapFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。

参照

BitmapFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.BitmapFormat プロパティ

パブリック プロパティ

ColorReduction | ビットマップイメージの色形式特性を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

BitmapFormat クラス | Steema.TeeChart.Export 名前空間


ColorReduction

Steema.TeeChart.Export.BitmapFormat.ColorReduction プロパティ

ビットマップイメージの色形式特性を設定します。
public BMPColorReduction ColorReduction {get; set;}

参照

BitmapFormat クラス | BitmapFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.BitmapFormat.BMPColorReduction

TeeChartプログラミングガイド

Steema.TeeChart.Export.BitmapFormat.BMPColorReduction 列挙体

ビットマップイメージの減色タイプを定義します。

[Serializable]
public enum BMPColorReduction : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Default | デフォルトの減色。
GrayScale | グレースケールの減色。

参照

Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExport

TeeChartプログラミングガイド

Steema.TeeChart.Export.DataExport クラス

TeeChartのデータエクスポート形式にアクセスします。

この型のすべてのメンバの一覧については、DataExport メンバを参照してください。

System.Object
public class DataExport : Object

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

DataExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExport 全メンバ

DataExport 概要

コンストラクタ

Constructor チャートのデータエクスポート形式にアクセスするクラスのコンストラクタ。

パブリック プロパティ

Excel | Excel形式としてチャートをエクスポートします。
HTML | HTMLテーブルとしてチャートをエクスポートします。
Text | テキストとしてチャートをエクスポートします。
XML | XMLデータ形式にチャートをエクスポートします。

参照

DataExport クラス | Steema.TeeChart.Export 名前空間


DataExport コンストラクタ

Steema.TeeChart.Export.DataExport コンストラクタ

チャートのデータエクスポート形式にアクセスするクラスのコンストラクタ。
public DataExport(Chart c)

参照

DataExport クラス | DataExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExport プロパティ

パブリック プロパティ

Excel | Excel形式としてチャートをエクスポートします。
HTML | HTMLテーブルとしてチャートをエクスポートします。
Text | テキストとしてチャートをエクスポートします。
XML | XMLデータ形式にチャートをエクスポートします。

参照

DataExport クラス | Steema.TeeChart.Export 名前空間


Excel

Steema.TeeChart.Export.DataExport.Excel プロパティ

Excelスプレッドシート形式としてチャートをエクスポートします。
public ExcelFormat Excel {get;}

解説

Excelスプレッドシート形式としてチャートをエクスポートします。

参照

DataExport クラス | DataExport メンバ | Steema.TeeChart.Export 名前空間


HTML

Steema.TeeChart.Export.DataExport.HTML プロパティ

HTMLテーブル形式としてチャートをエクスポートします。
public HTMLFormat HTML {get;}

解説

HTMLテーブル形式としてチャートをエクスポートします。

参照

DataExport クラス | DataExport メンバ | Steema.TeeChart.Export 名前空間


Text

Steema.TeeChart.Export.DataExport.Text プロパティ

テキスト形式としてチャートをエクスポートします。
public TextFormat Text {get;}

解説

テキスト形式としてチャートをエクスポートします。

参照

DataExport クラス | DataExport メンバ | Steema.TeeChart.Export 名前空間


XML

Steema.TeeChart.Export.DataExport.XML プロパティ

XMLデータ形式にチャートをエクスポートします。
public XMLFormat XML {get;}

解説

XMLデータ形式にチャートをエクスポートします。

参照

DataExport クラス | DataExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExportFormat

Steema.TeeChart.Export.DataExportFormat クラス

すべてのデータエクスポートクラスの共通メソッド。

この型のすべてのメンバの一覧については、DataExportFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
public class DataExportFormat : ExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExportFormat 全メンバ

DataExportFormat 概要

コンストラクタ

Constructor オーバーロード。すべてのチャート系列のデータエクスポートコンストラクタ。

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルタイプのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard | クリップボードへチャートデータをコピーします。
Save | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

パブリック プロパティ

IncludeHeader | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series | データをエクスポートする系列を設定します。
TextLineSeparator | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat データ形式の記述名を返します。

参照

DataExportFormat クラス | Steema.TeeChart.Export 名前空間


DataExportFormat コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Export.DataExportFormat コンストラクタ

オーバーロードの一覧

public DataExportFormat()

すべてのチャート系列のデータエクスポートコンストラクタ。

public DataExportFormat(Steema.TeeChart.Chart)

系列を指定したデータエクスポートコンストラクタ。

public DataExportFormat(Steema.TeeChart.Chart, Steema.TeeChart.Styles.Series)

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


DataExportFormat コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Export.DataExportFormat コンストラクタ

public DataExportFormat()

参照

DataExportFormat コンストラクタのオーバーロードの一覧 | DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


DataExportFormat コンストラクタ

Steema.TeeChart.Export.DataExportFormat コンストラクタ

すべてのチャート系列のデータエクスポートコンストラクタ。
public DataExportFormat(Chart c)

参照

DataExportFormat コンストラクタのオーバーロードの一覧 | DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


DataExportFormat コンストラクタ

Steema.TeeChart.Export.DataExportFormat コンストラクタ

指定した系列のデータエクスポートコンストラクタ。
public DataExportFormat(Chart c,
     Series s)

参照

DataExportFormat コンストラクタのオーバーロードの一覧 | DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExportFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

DataExportFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExportFormat メソッド

パブリック メソッド

CopyToClipboard | クリップボードへチャートデータをコピーします。
Save | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

参照

DataExportFormat クラス | Steema.TeeChart.Export 名前空間


CopyToClipboard

Steema.TeeChart.Export.DataExportFormat.CopyToClipboard メソッド

クリップボードへチャートデータをコピーします。
public abstract Void CopyToClipboard()

解説

クリップボードへチャートデータをコピーします。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.DataExportFormat.Save メソッド

オーバーロードの一覧

チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

public abstract Void Save(System.IO.Stream)

チャートをデータエクスポート形式でファイルに保存します。

public Void Save(System.String)

解説

チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.DataExportFormat.Save メソッド

チャートをデータエクスポート形式でストリームに保存します。

public virtual Void Save(Stream stream)

参照

Save オーバーロードの一覧 | DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.DataExportFormat.Save メソッド

チャートをデータエクスポート形式でファイルに保存します。

public Void Save(String fileName)

パラメーター

fileName
文字列　例："c:\tempFiles\MyChart.xml"

参照

Save オーバーロードの一覧 | DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.DataExportFormat プロパティ

パブリック プロパティ

IncludeHeader | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series | データをエクスポートする系列を設定します。
TextLineSeparator | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat データ形式の記述名を返します。

参照

DataExportFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.DataExportFormat.DataFormat プロパティ

データ形式の記述名を返します。
protected abstract String DataFormat {get;}

解説

データ形式の記述名を返します。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


IncludeHeader

Steema.TeeChart.Export.DataExportFormat.IncludeHeader プロパティ

エクスポートするデータに系列値リスト名を含めるかどうか設定します。
public Boolean IncludeHeader {get; set;}

解説

エクスポートデータ内に基となるデータ系列のヘッダーを含めるかどうか設定します。ヘッダーは、通常系列タイトル、あるいは設定されていない場合は系列名になります。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


IncludeIndex

Steema.TeeChart.Export.DataExportFormat.IncludeIndex プロパティ

エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
public Boolean IncludeIndex {get; set;}

解説

デフォルト値：False

エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


IncludeLabels

Steema.TeeChart.Export.DataExportFormat.IncludeLabels プロパティ

エクスポートするデータにラベルを含めるかどうか設定します。
public Boolean IncludeLabels {get; set;}

解説

デフォルト値：False

エクスポートするデータにラベルを含めるかどうか設定します。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


IncludeSeriesTitle

Steema.TeeChart.Export.DataExportFormat.IncludeSeriesTitle プロパティ

エクスポートするデータに系列タイトルを含めます。

public Boolean IncludeSeriesTitle {get; set;}

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Series

Steema.TeeChart.Export.DataExportFormat.Series プロパティ

データをエクスポートする系列を設定します。
public Series Series {get; set;}

解説

エクスポートのデータソースとしてDataExportコンポーネントにより使用されます。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


TextLineSeparator

Steema.TeeChart.Export.DataExportFormat.TextLineSeparator プロパティ

アスキーエクスポート形式のための区切り記号を取得/設定します。
public String TextLineSeparator {get; set;}

解説

アスキーエクスポート形式のための区切り記号を取得/設定します。

参照

DataExportFormat クラス | DataExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData

Steema.TeeChart.Export.EPSData クラス

EPSDataの概要。

この型のすべてのメンバの一覧については、EPSData メンバを参照してください。

System.Object
public class EPSData : Object

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

EPSData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData 全メンバ

EPSData 概要

コンストラクタ

Constructor

パブリック プロパティ

Fonts
Images
Position
Stream

参照

EPSData クラス | Steema.TeeChart.Export 名前空間


EPSData コンストラクタ

Steema.TeeChart.Export.EPSData コンストラクタ

public EPSData(Stream stream)

参照

EPSData クラス | EPSData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData プロパティ

パブリック プロパティ

Fonts
Images
Position
Stream

参照

EPSData クラス | Steema.TeeChart.Export 名前空間


Fonts

Steema.TeeChart.Export.EPSData.Fonts プロパティ

public EPSFonts Fonts {get; set;}

参照

EPSData クラス | EPSData メンバ | Steema.TeeChart.Export 名前空間


Images

Steema.TeeChart.Export.EPSData.Images プロパティ

public GraphicsImages Images {get; set;}

参照

EPSData クラス | EPSData メンバ | Steema.TeeChart.Export 名前空間


Position

Steema.TeeChart.Export.EPSData.Position プロパティ

public Int32 Position {get; set;}

参照

EPSData クラス | EPSData メンバ | Steema.TeeChart.Export 名前空間


Stream

Steema.TeeChart.Export.EPSData.Stream プロパティ

public Stream Stream {get; set;}

参照

EPSData クラス | EPSData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFont

Steema.TeeChart.Export.EPSData.EPSFont クラス

この型のすべてのメンバの一覧については、EPSFont メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.GraphicsFont
public class EPSFont : GraphicsFont

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

EPSFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFont 全メンバ

EPSFont 概要

パブリック メソッド

DictFontName
Equals (GraphicsFontの継承元)

パブリック プロパティ

EPSFontName
FontData (GraphicsFontの継承元)
GraphicsFontName (GraphicsFontの継承元)
Index (GraphicsFontの継承元)
ObjectNumber (GraphicsFontの継承元)

コンストラクタ

Steema.TeeChart.Export.EPSData.EPSFont..ctor

プロテクト フィールド

m_fontname (GraphicsFontの継承元)

プロテクト メソッド

GetFontName

参照

EPSFont クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFont フィールド

プロテクト フィールド

m_fontname (GraphicsFontの継承元)

参照

EPSFont クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFont メソッド

パブリック メソッド

DictFontName
Equals (GraphicsFontの継承元)

プロテクト メソッド

GetFontName

参照

EPSFont クラス | Steema.TeeChart.Export 名前空間


DictFontName

Steema.TeeChart.Export.EPSData+EPSFont.DictFontName メソッド

public override String DictFontName()

参照

EPSFont クラス | EPSFont メンバ | Steema.TeeChart.Export 名前空間


GetFontName

Steema.TeeChart.Export.EPSData+EPSFont.GetFontName メソッド

protected abstract String GetFontName(ChartFont f)

参照

EPSFont クラス | EPSFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFont プロパティ

パブリック プロパティ

EPSFontName
FontData (GraphicsFontの継承元)
GraphicsFontName (GraphicsFontの継承元)
Index (GraphicsFontの継承元)
ObjectNumber (GraphicsFontの継承元)

参照

EPSFont クラス | Steema.TeeChart.Export 名前空間


EPSFontName

Steema.TeeChart.Export.EPSData+EPSFont.EPSFontName プロパティ

public String EPSFontName {get;}

参照

EPSFont クラス | EPSFont メンバ | Steema.TeeChart.Export 名前空間


EPSFont コンストラクタ

Steema.TeeChart.Export.EPSData+EPSFont コンストラクタ

public EPSData+EPSFont(EPSFonts fonts,
     ChartFont f)

参照

EPSFont クラス | EPSFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFonts

Steema.TeeChart.Export.EPSData.EPSFonts クラス

この型のすべてのメンバの一覧については、EPSFonts メンバを参照してください。

System.Object
System.Collections.ArrayList
Steema.TeeChart.Drawing.GraphicsFonts
public class EPSFonts : GraphicsFonts , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

EPSFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFonts 全メンバ

EPSFonts 概要

パブリック メソッド

Add
FindFont (GraphicsFontsの継承元 )

パブリック プロパティ

Item

コンストラクタ

Steema.TeeChart.Export.EPSData.EPSFonts

参照

EPSFonts クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFonts メソッド

パブリック メソッド

Add
FindFont (GraphicsFontsの継承元)

参照

EPSFonts クラス | Steema.TeeChart.Export 名前空間


Add

Steema.TeeChart.Export.EPSData+EPSFonts.Add メソッド

public override Int32 Add(ChartFont font)

参照

EPSFonts クラス | EPSFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSData.EPSFonts プロパティ

パブリック プロパティ

Item

参照

EPSFonts クラス | Steema.TeeChart.Export 名前空間


Item

Steema.TeeChart.Export.EPSData+EPSFonts.Item プロパティ

public EPSFont Item(Int32 index) {get;}

参照

EPSFonts クラス | EPSFonts メンバ | Steema.TeeChart.Export 名前空間


EPSFonts コンストラクタ

Steema.TeeChart.Export.EPSData+EPSFonts コンストラクタ

public EPSData+EPSFonts()

参照

EPSFonts クラス | EPSFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSFormat

Steema.TeeChart.Export.EPSFormat クラス

EPSエクスポート形式。

この型のすべてのメンバの一覧については、EPSFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class EPSFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

EPSFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSFormat 全メンバ

EPSFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをEPSイメージで保存します。

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

EPSFormat クラス | Steema.TeeChart.Export 名前空間


EPSFormat コンストラクタ

Steema.TeeChart.Export.EPSFormat コンストラクタ

public EPSFormat(Chart c)

参照

EPSFormat クラス | EPSFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

EPSFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをEPSページで保存します。

参照

EPSFormat クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.EPSFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.IO.Stream)

参照

EPSFormat クラス | EPSFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.EPSFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | EPSFormat クラス | EPSFormat メンバ | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.EPSFormat.SaveToFile メソッド

チャートをEPSページで保存します。

public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
ファイル名

参照

EPSFormat クラス | EPSFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSFormat プロパティ

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

EPSFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.EPSFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

EPSFormat クラス | EPSFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSPage

Steema.TeeChart.Export.EPSPage クラス

この型のすべてのメンバの一覧については、EPSPage メンバを参照してください。

System.Object
public class EPSPage : Object

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

EPSPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSPage 全メンバ

EPSPage 概要

コンストラクタ

Constructor

パブリック メソッド

ConstructPage

パブリック プロパティ

epsData

参照

EPSPage クラス | Steema.TeeChart.Export 名前空間


EPSPage コンストラクタ

Steema.TeeChart.Export.EPSPage コンストラクタ

public EPSPage(Stream s,
     Int32 Width,
     Int32 Height)

参照

EPSPage クラス | EPSPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSPage メソッド

パブリック メソッド

ConstructPage

参照

EPSPage クラス | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.EPSPage.ConstructPage メソッド

オーバーロードの一覧

public Void ConstructPage(System.IO.Stream)
public Void ConstructPage()

参照

EPSPage クラス | EPSPage メンバ | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.EPSPage.ConstructPage メソッド

public Void ConstructPage(Stream s)

参照

ConstructPage オーバーロードの一覧 | EPSPage クラス | EPSPage メンバ | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.EPSPage.ConstructPage メソッド

public Void ConstructPage()

参照

ConstructPage オーバーロードの一覧 | EPSPage クラス | EPSPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.EPSPage プロパティ

パブリック プロパティ

epsData

参照

EPSPage クラス | Steema.TeeChart.Export 名前空間


epsData

Steema.TeeChart.Export.EPSPage.epsData プロパティ

public EPSData epsData {get;}

参照

EPSPage クラス | EPSPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExcelFormat

Steema.TeeChart.Export.ExcelFormat クラス

Excelのスプレッドシート形式にチャートデータをエクスポート。

この型のすべてのメンバの一覧については、ExcelFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.DataExportFormat
Steema.TeeChart.Export.HTMLFormat
public class ExcelFormat : HTMLFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

ExcelFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExcelFormat 全メンバ

ExcelFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルタイプのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

ExcelFormat クラス | Steema.TeeChart.Export 名前空間


ExcelFormat コンストラクタ

Steema.TeeChart.Export.ExcelFormat コンストラクタ

public ExcelFormat(Chart c)

参照

ExcelFormat クラス | ExcelFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExcelFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

ExcelFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExcelFormat メソッド

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save | チャートデータをExcel形式でストリームに保存します。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームに保存します。

参照

ExcelFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExcelFormat プロパティ

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

ExcelFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExportFormat

TeeChartプログラミングガイド

Steema.TeeChart.Export.ExportFormat クラス

共通のエクスポート特性。

この型のすべてのメンバの一覧については、ExportFormat メンバを参照してください。

System.Object
public class ExportFormat : Object

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

ExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExportFormat 全メンバ

ExportFormat 概要

パブリック フィールド

FileExtension エクスポートするファイルのデフォルトの拡張子文字列です。

参照

ExportFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ExportFormat フィールド

パブリック フィールド

FileExtension エクスポートするファイルのデフォルトの拡張子文字列です。

参照

ExportFormat クラス | Steema.TeeChart.Export 名前空間


FileExtension

TeeChartプログラミングガイド

Steema.TeeChart.Export.ExportFormat.FileExtension フィールド

エクスポートするファイルのデフォルトの拡張子文字列です。

public String FileExtension

参照

ExportFormat クラス | ExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.Exports

TeeChartプログラミングガイド

Steema.TeeChart.Export.Exports クラス

イメージやデータとしてチャートを保存するためのエクスポート形式。

この型のすべてのメンバの一覧については、Exports メンバを参照してください。

System.Object
public class Exports : Object

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

Exports メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.Exports 全メンバ

Exports 概要

コンストラクタ

Constructor

パブリック メソッド

GetBase64 |
InternalSaveViewState | 内部使用。チャートを保存します。
ShowExportDialog | エクスポートダイアログを表示します。

パブリック プロパティ

Data | データ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
Image | イメージ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
Template | ネイティブ｢ten｣テンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
Theme | テーマテンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。

参照

Exports クラス | Steema.TeeChart.Export 名前空間


Exports コンストラクタ

Steema.TeeChart.Export.Exports コンストラクタ

public Exports(Chart c)

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.Exports メソッド

パブリック メソッド

GetBase64 |
InternalSaveViewState | 内部使用。チャートを保存します。
ShowExportDialog | エクスポートダイアログを表示します。

参照

Exports クラス | Steema.TeeChart.Export 名前空間


GetBase64

Steema.TeeChart.Export.Exports.GetBase64 メソッド

public String GetBase64(Stream mstr)

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


InternalSaveViewState

Steema.TeeChart.Export.Exports.InternalSaveViewState メソッド

内部使用。チャートを保存します。
public Object InternalSaveViewState(Chart chart)

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


ShowExportDialog

Steema.TeeChart.Export.Exports.ShowExportDialog メソッド

オーバーロードの一覧

エクスポートダイアログを表示します。

public Void ShowExportDialog()

エクスポート形式のためのエクスポートダイアログを表示します。

public Void ShowExportDialog(Steema.TeeChart.Export.ExportFormat)

解説

エクスポートダイアログを表示します。

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


ShowExportDialog

TeeChartプログラミングガイド

Steema.TeeChart.Export.Exports.ShowExportDialog メソッド

エクスポートダイアログを表示します。

public Void ShowExportDialog()

参照

ShowExportDialog オーバーロードの一覧 | Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


ShowExportDialog

Steema.TeeChart.Export.Exports.ShowExportDialog メソッド

エクスポート形式のためのエクスポートダイアログを表示します。
public Void ShowExportDialog(ExportFormat expFmt)

参照

ShowExportDialog オーバーロードの一覧 | Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.Exports プロパティ

パブリック プロパティ

Data | データ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
Image | イメージ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
Template | ネイティブ｢ten｣テンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。

参照

Exports クラス | Steema.TeeChart.Export 名前空間


Data

Steema.TeeChart.Export.Exports.Data プロパティ

データ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
public DataExport Data {get;}

解説

データ形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


Image

Steema.TeeChart.Export.Exports.Image プロパティ

イメージ形式にチャートをエクスポートします。
public ImageExport Image {get;}

解説

イメージ形式にチャートをエクスポートします。

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


Template

Steema.TeeChart.Export.Exports.Template プロパティ

ネイティブ｢ten｣テンプレート形式に、チャートをエクスポートするためのプロパティおよびメソッドにアクセスします。
public TemplateExport Template {get;}

解説

ネイティブ｢ten｣テンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間


Theme

Steema.TeeChart.Export.Exports.Theme プロパティ

Theme テンプレートへのチャートのエクスポート。
public ThemeExport Theme {get;}

参照

Exports クラス | Exports メンバ | Steema.TeeChart.Export 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Export.FlexFormat

Steema.TeeChart.Export.FlexFormat クラス

Flexエクスポート形式。無償のAdobeR Flex 2 SDKで入手可能なmxmlc.exeを使用してコンパイルしてください。

この型のすべてのメンバの一覧については、FlexFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class FlexFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexFormat 全メンバ

FlexFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをFlexイメージで保存します。

パブリック プロパティ

EmbeddedImages |
Height (ImageExportFormatの継承元) | イメージの高さを設定します。
ImagePath |
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

FlexFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexFormat コンストラクタ

public FlexFormat(Chart c)

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

FlexFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save |
SaveToFile | Flexイメージとしてチャートを保存します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

参照

FlexFormat クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.FlexFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.String)
public override Void Save(System.IO.Stream)

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.FlexFormat.Save メソッド

public override Void Save(String FileName)

参照

Save オーバーロードの一覧 | FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.FlexFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.FlexFormat.SaveToFile メソッド

Flexイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
ファイル名

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexFormat プロパティ

パブリック プロパティ

EmbeddedImages |
Height (ImageExportFormatの継承元) | イメージの高さを設定します。
ImagePath |
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

FlexFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.FlexFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


EmbeddedImages

Steema.TeeChart.Export.FlexFormat.EmbeddedImages プロパティ

public Boolean EmbeddedImages {get; set;}

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


ImagePath

Steema.TeeChart.Export.FlexFormat.ImagePath プロパティ

public String ImagePath {get; set;}

参照

FlexFormat クラス | FlexFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions

Steema.TeeChart.Export.FlexOptions クラス

この型のすべてのメンバの一覧については、FlexOptions メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
public class FlexOptions : Form , IComponent, IDisposable, IOleControl
, IOleObject, IOleInPlaceObject, IOleInPlaceActiveObject, IOleWindow
, IViewObject, IViewObject2, IPersist, IPersistStreamInit, IPersistPropertyBag
, IPersistStorage, IQuickActivate, ISupportOleDropSource, IDropTarget
, ISynchronizeInvoke, IWin32Window, IArrangedElement, IBindableComponent
, IContainerControl

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions 全メンバ

FlexOptions 概要

コンストラクタ

コンストラクタ

パブリック フィールド

cbDelete
tbTemp

パブリック メソッド

bCompile_Click

パブリック プロパティ

Panel

プロテクト メソッド

Dispose 使用したリソースを削除します。

参照

FlexOptions クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions コンストラクタ

public FlexOptions(Chart c)

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions フィールド

パブリック フィールド

cbDelete
tbTemp

参照

FlexOptions クラス | Steema.TeeChart.Export 名前空間


cbDelete

Steema.TeeChart.Export.FlexOptions.cbDelete フィールド

public CheckBox cbDelete

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


tbTemp

Steema.TeeChart.Export.FlexOptions.tbTemp フィールド

public TextBox tbTemp

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions メソッド

パブリック メソッド

bCompile_Click

プロテクト メソッド

Dispose 使用したリソースを削除します。

参照

FlexOptions クラス | Steema.TeeChart.Export 名前空間


bCompile_Click

Steema.TeeChart.Export.FlexOptions.bCompile_Click メソッド

public Void bCompile_Click(Object sender,
     EventArgs e)

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Dispose

Steema.TeeChart.Export.FlexOptions.Dispose メソッド

使用したリソースを削除します。
protected override Void Dispose(Boolean disposing)

パラメーター

disposing
マネージド・リソースを解放しなければならない場合はTrue、そうでなければFalseを設定してください。

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.FlexOptions プロパティ

パブリック プロパティ

Panel

参照

FlexOptions クラス | Steema.TeeChart.Export 名前空間


Panel

Steema.TeeChart.Export.FlexOptions.Panel プロパティ

public Chart Panel {get; set;}

参照

FlexOptions クラス | FlexOptions メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat

Steema.TeeChart.Export.GIFFormat クラス

GIFイメージのエクスポート形式。

この型のすべてのメンバの一覧については、GIFFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class GIFFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

GIFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat 全メンバ

GIFFormat 概要

コンストラクタ

Constructor GIFエクスポート形式のコンストラクタ

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | GIFイメージとしてチャートを保存します。

パブリック プロパティ

ColorReduction | GIFイメージの減色を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

GIFFormat クラス | Steema.TeeChart.Export 名前空間


GIFFormat コンストラクタ

Steema.TeeChart.Export.GIFFormat コンストラクタ

GIFエクスポート形式のコンストラクタ。
public GIFFormat(Chart c)

参照

GIFFormat クラス | GIFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

GIFFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | GIFイメージとしてチャートを保存します。

参照

GIFFormat クラス | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.GIFFormat.SaveToFile メソッド

GIFイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

解説

GIFイメージとしてチャートを保存します。

参照

GIFFormat クラス | GIFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat プロパティ

パブリック プロパティ

ColorReduction | GIFイメージの減色を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

GIFFormat クラス | Steema.TeeChart.Export 名前空間


ColorReduction

Steema.TeeChart.Export.GIFFormat.ColorReduction プロパティ

GIFイメージの減色を設定します。
public GIFColorReduction ColorReduction {get; set;}

解説

GIFイメージの減色を設定します。

参照

GIFFormat クラス | GIFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.GIFFormat.GIFColorReduction

TeeChartプログラミングガイド

Steema.TeeChart.Export.GIFFormat.GIFColorReduction 列挙体

GIFイメージの減色タイプを定義します。

[Serializable]
public enum GIFColorReduction : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 減色なし。
GrayScale | グレースケールのGIFイメージ。

参照

Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.HTMLFormat

Steema.TeeChart.Export.HTMLFormat クラス

HTMLテーブルにチャートエデータをエクスポート。

この型のすべてのメンバの一覧については、HTMLFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.DataExportFormat
public class HTMLFormat : DataExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

HTMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.HTMLFormat 全メンバ

HTMLFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルタイプのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

HTMLFormat クラス | Steema.TeeChart.Export 名前空間


HTMLFormat コンストラクタ

Steema.TeeChart.Export.HTMLFormat コンストラクタ

public HTMLFormat(Chart c)

参照

HTMLFormat クラス | HTMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.HTMLFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

HTMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.HTMLFormat メソッド

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

参照

HTMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.HTMLFormat プロパティ

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

HTMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExport

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExport クラス

チャートイメージのエクスポートの基本的なメソッドのクラス。

この型のすべてのメンバの一覧については、ImageExport メンバを参照してください。

System.Object
public class ImageExport : Object

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

ImageExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExport 全メンバ

ImageExport 概要

コンストラクタ

Constructor

パブリック プロパティ

Bitmap | ビットマップ形式としてチャートをエクスポートします。
EPS | EPS形式としてチャートをエクスポートします。
GIF | GIF形式としてチャートをエクスポートします。
JPEG | JPEG形式としてチャートをエクスポートします。
Metafile | メタファイル形式としてチャートをエクスポートします。
PDF | PDF形式としてチャートをエクスポートします。
PNG | PNG形式としてチャートをエクスポートします。
SVG | SVG形式としてチャートをエクスポートします。
TIFF | TIFF形式としてチャートをエクスポートします。
VML | VML形式としてチャートをエクスポートします。
XAML | XAMLとしてチャートをエクスポートします。

参照

ImageExport クラス | Steema.TeeChart.Export 名前空間


ImageExport コンストラクタ

Steema.TeeChart.Export.ImageExport コンストラクタ

public ImageExport(Chart c)

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExport プロパティ

パブリック プロパティ

Bitmap | ビットマップ形式としてチャートをエクスポートします。
EPS | EPS形式としてチャートをエクスポートします。
GIF | GIF形式としてチャートをエクスポートします。
JPEG | JPEG形式としてチャートをエクスポートします。
Metafile | メタファイル形式としてチャートをエクスポートします。
PDF | PDF形式としてチャートをエクスポートします。
PNG | PNG形式としてチャートをエクスポートします。
SVG | SVG形式としてチャートをエクスポートします。
TIFF | TIFF形式としてチャートをエクスポートします。
VML | VML形式としてチャートをエクスポートします。

参照

ImageExport クラス | Steema.TeeChart.Export 名前空間


Bitmap

Steema.TeeChart.Export.ImageExport.Bitmap プロパティ

ビットマップ形式としてチャートをエクスポートします。
public BitmapFormat Bitmap {get;}

解説

ビットマップ形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


EPS

Steema.TeeChart.Export.ImageExport.EPS プロパティ

チャートをEPS形式でエクスポートします。

public EPSFormat EPS {get;}

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


Flex

Steema.TeeChart.Export.ImageExport.Flex プロパティ

Flexとしてチャートをエクスポートします。
public FlexFormat Flex {get;}

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


GIF

Steema.TeeChart.Export.ImageExport.GIF プロパティ

GIF形式としてチャートをエクスポートします。
public GIFFormat GIF {get;}

解説

GIF形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


JPEG

Steema.TeeChart.Export.ImageExport.JPEG プロパティ

JPEG形式としてチャートをエクスポートします。
public JPEGFormat JPEG {get;}

解説

JPEG形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


Metafile

Steema.TeeChart.Export.ImageExport.Metafile プロパティ

メタファイル形式としてチャートをエクスポートします。
public MetafileFormat Metafile {get;}

解説

メタファイル形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


PDF

Steema.TeeChart.Export.ImageExport.PDF プロパティ

チャートをPDF形式でエクスポートします。

public PDFFormat PDF {get;}

解説

チャートをPDF形式でエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


PNG

Steema.TeeChart.Export.ImageExport.PNG プロパティ

PNG形式としてチャートをエクスポートします。
public PNGFormat PNG {get;}

解説

PNG形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


SVG

Steema.TeeChart.Export.ImageExport.SVG プロパティ

SVG形式としてチャートをエクスポートします。
public SVGFormat SVG {get;}

解説

SVG形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


TIFF

Steema.TeeChart.Export.ImageExport.TIFF プロパティ

TIFF形式としてチャートをエクスポートします。
public TIFFFormat TIFF {get;}

解説

TIFF形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


VML

Steema.TeeChart.Export.ImageExport.VML プロパティ

VML形式としてチャートをエクスポートします。
public VMLFormat VML {get;}

解説

VML形式としてチャートをエクスポートします。

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


XAML

Steema.TeeChart.Export.ImageExport.XAML プロパティ

XAMLとしてチャートをエクスポートします。
public XAMLFormat XAML {get;}

参照

ImageExport クラス | ImageExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExportFormat

Steema.TeeChart.Export.ImageExportFormat クラス

基本クラス。共通のエクスポート特性。

この型のすべてのメンバの一覧については、ImageExportFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
public class ImageExportFormat : ExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExportFormat 全メンバ

ImageExportFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard | クリップボードにイメージをコピーします。
Save | ストリームにイメージを保存します。

パブリック プロパティ

Height | エクスポートするイメージの高さを設定します。
Width | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

ImageExportFormat クラス | Steema.TeeChart.Export 名前空間


ImageExportFormat コンストラクタ

Steema.TeeChart.Export.ImageExportFormat コンストラクタ

public ImageExportFormat(Chart c)

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExportFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

ImageExportFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExportFormat メソッド

パブリック メソッド

CopyToClipboard | クリップボードにイメージをコピーします。
Save | ストリームにイメージを保存します。

参照

ImageExportFormat クラス | Steema.TeeChart.Export 名前空間


CopyToClipboard

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.CopyToClipboard メソッド

クリップボードにイメージをコピーします。

public virtual Void CopyToClipboard()

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.ImageExportFormat.Save メソッド

オーバーロードの一覧

ファイルにイメージを保存します。

public abstract Void Save(System.String)

ストリームにイメージを保存します。

public abstract Void Save(System.IO.Stream)

ストリームにイメージを保存します。

public abstract Void Save(System.IO.Stream, System.Drawing.Bitmap, System.Int32, System.Int32)

解説

ストリームあるいはファイルにイメージを保存します。

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.Save メソッド

ストリームにイメージを保存します。

public virtual Void Save(Stream stream)

解説

ストリームにイメージを保存するために使用してください。

参照

Save オーバーロードの一覧 | ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.Save メソッド

ファイルにイメージを保存します。

public virtual Void Save(String FileName)

パラメーター

FileName
ファイル名 例："c:\tempImages\myImage.bmp"

解説

ファイルにイメージを保存するために使用してください。

例

[C#]

tChart1.Export.Image.GIF.Width=xxx;
tChart1.Export.Image.GIF.Height=xxx;
tChart1.Export.Image.GIF.Save(@"c:.gif");

参照

Save オーバーロードの一覧 | ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.ImageExportFormat.Save メソッド

ストリームにイメージを保存します。
public abstract Void Save(Stream stream,
     Bitmap b,
     Int32 width,
     Int32 height)

参照

Save オーバーロードの一覧 | ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


SupportsTransparent

Steema.TeeChart.Export.ImageExportFormat.SupportsTransparent メソッド

protected abstract Boolean SupportsTransparent()

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageExportFormat プロパティ

パブリック プロパティ

Height | エクスポートするイメージの高さを設定します。
Width | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

ImageExportFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.DataFormat プロパティ

protected virtual String DataFormat {get;}

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Format

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.Format プロパティ

エクスポートするチャートイメージのイメージ形式をアクセスします。

protected ImageFormat Format {get;}

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.Height プロパティ

エクスポートするイメージの高さを設定します。

public Int32 Height {get; set;}

解説

エクスポートするイメージの高さを変更するために使用してください。

例

[C#]

tChart1.Export.Image.GIF.Width=xxx;
tChart1.Export.Image.GIF.Height=xxx;
tChart1.Export.Image.GIF.Save(@"c:.gif");

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageExportFormat.Width プロパティ

エクスポートするイメージの幅を設定します。

public Int32 Width {get; set;}

解説

エクスポートするイメージの幅を変更するために使用してください。

例

[C#]

tChart1.Export.Image.GIF.Width=xxx;
tChart1.Export.Image.GIF.Height=xxx;
tChart1.Export.Image.GIF.Save(@"c:.gif");

参照

ImageExportFormat クラス | ImageExportFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageFormats

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageFormats クラス

内部使用。使用可能なイメージ形式。

この型のすべてのメンバの一覧については、ImageFormats メンバを参照してください。

System.Object
public class ImageFormats : Object

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

ImageFormats メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageFormats 全メンバ

ImageFormats 概要

コンストラクタ

Constructor

パブリック フィールド

Count

参照

ImageFormats クラス | Steema.TeeChart.Export 名前空間


ImageFormats コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageFormats コンストラクタ

public ImageFormats()

参照

ImageFormats クラス | ImageFormats メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ImageFormats フィールド

パブリック フィールド

Count

参照

ImageFormats クラス | Steema.TeeChart.Export 名前空間


Count

TeeChartプログラミングガイド

Steema.TeeChart.Export.ImageFormats.Count フィールド

public Int32 Count

参照

ImageFormats クラス | ImageFormats メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.JPEGFormat

Steema.TeeChart.Export.JPEGFormat クラス

チャートのJPEGイメージ特性のクラス。

この型のすべてのメンバの一覧については、JPEGFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class JPEGFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

JPEGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.JPEGFormat 全メンバ

JPEGFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | JPEGファイルとしてチャートを保存します。

パブリック プロパティ

GrayScale | trueの場合、イメージはグレースケールとしてエクスポートします。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Quality | パーセント単位でJPEGイメージの品質を設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

JPEGFormat クラス | Steema.TeeChart.Export 名前空間


JPEGFormat コンストラクタ

Steema.TeeChart.Export.JPEGFormat コンストラクタ

public JPEGFormat(Chart c)

参照

JPEGFormat クラス | JPEGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.JPEGFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

JPEGFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.JPEGFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | JPEGファイルとしてチャートを保存します。

参照

JPEGFormat クラス | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.JPEGFormat.SaveToFile メソッド

JPEGファイルとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

解説

JPEGファイルとしてチャートを保存します。

参照

JPEGFormat クラス | JPEGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.JPEGFormat プロパティ

パブリック プロパティ

GrayScale | trueの場合、イメージはグレースケールとしてエクスポートします。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Quality | パーセント単位でJPEGイメージの品質を設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

JPEGFormat クラス | Steema.TeeChart.Export 名前空間


GrayScale

Steema.TeeChart.Export.JPEGFormat.GrayScale プロパティ

デフォルト値：false。trueの場合、イメージはグレースケールとしてエクスポートします。
public Boolean GrayScale {get; set;}

解説

デフォルト値：false

trueの場合、イメージはグレースケールとしてエクスポートします。

参照

JPEGFormat クラス | JPEGFormat メンバ | Steema.TeeChart.Export 名前空間


Quality

Steema.TeeChart.Export.JPEGFormat.Quality プロパティ

デフォルト値：95。パーセント単位でJPEGイメージの品質を設定します。
public Int32 Quality {get; set;}

解説

デフォルト値：95

パーセント単位でJPEGイメージの品質を設定します。100の値は、最高品質になります。

参照

JPEGFormat クラス | JPEGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.MetafileFormat

Steema.TeeChart.Export.MetafileFormat クラス

メタファイルのエクスポート形式。

この型のすべてのメンバの一覧については、MetafileFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class MetafileFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.MetafileFormat 全メンバ

MetafileFormat 概要

コンストラクタ

Constructor

パブリック フィールド

bEnhanced |
FileExtension (ExportFormatの継承元) | エクスポートするファイルタイプのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard | クリップボードにメタファイルとしてチャートを保存します。
Save | ストリームにメタファイルとしてチャートを保存します。
SaveToFile | メタファイルとしてチャートを保存します。

パブリック プロパティ

EMFFormat | メタファイルエクスポートの拡張型。
Enhanced | Trueの場合、メタファイルは拡張型に設定されます。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト メソッド

SupportsTransparent

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式をアクセスします。

参照

MetafileFormat クラス | Steema.TeeChart.Export 名前空間


MetafileFormat コンストラクタ

Steema.TeeChart.Export.MetafileFormat コンストラクタ

public MetafileFormat(Chart c)

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.MetafileFormat フィールド

パブリック フィールド

bEnhanced |
FileExtension (ExportFormatの継承元) | エクスポートするファイルのデフォルトの拡張子文字列です。

参照

MetafileFormat クラス | Steema.TeeChart.Export 名前空間


bEnhanced

TeeChartプログラミングガイド

Steema.TeeChart.Export.MetafileFormat.bEnhanced フィールド

public Boolean bEnhanced

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.MetafileFormat メソッド

パブリック メソッド

CopyToClipboard | クリップボードにメタファイルとしてチャートを保存します。
Save | ストリームにメタファイルとしてチャートを保存します。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | メタファイルとしてチャートを保存します。

参照

MetafileFormat クラス | Steema.TeeChart.Export 名前空間


CopyToClipboard

TeeChartプログラミングガイド

Steema.TeeChart.Export.MetafileFormat.CopyToClipboard メソッド

クリップボードにメタファイルとしてチャートを保存します。

public virtual Void CopyToClipboard()

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.MetafileFormat.Save メソッド

オーバーロードの一覧

ストリームにメタファイルとしてチャートを保存します。

public override Void Save(System.IO.Stream)

ファイルにメタファイルとしてチャートを保存します。

public override Void Save(System.String)

解説

メタファイルとしてチャートを保存します。

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.MetafileFormat.Save メソッド

ストリームにメタファイルとしてチャートを保存します。

public virtual Void Save(Stream stream)

参照

Save オーバーロードの一覧 | MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.MetafileFormat.Save メソッド

メタファイルとしてチャートを保存します。
public override Void Save(String FileName)

参照

Save オーバーロードの一覧 | MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.MetafileFormat.SaveToFile メソッド

メタファイルとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


SupportsTransparent

Steema.TeeChart.Export.MetafileFormat.SupportsTransparent メソッド

protected abstract Boolean SupportsTransparent()

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.MetafileFormat プロパティ

パブリック プロパティ

EMFFormat | メタファイルエクスポートの拡張型。
Enhanced | Trueの場合、メタファイルは拡張型に設定されます。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式をアクセスします。

参照

MetafileFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

TeeChartプログラミングガイド

Steema.TeeChart.Export.MetafileFormat.DataFormat プロパティ

protected virtual String DataFormat {get;}

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


EMFFormat

Steema.TeeChart.Export.MetafileFormat.EMFFormat プロパティ

メタファイルエクスポートの拡張型。

public EmfType EMFFormat {get; set;}

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Enhanced

Steema.TeeChart.Export.MetafileFormat.Enhanced プロパティ

Trueの場合、メタファイルは、拡張メタファイルに設定されます。
public Boolean Enhanced {get; set;}

参照

MetafileFormat クラス | MetafileFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData

Steema.TeeChart.Export.PDFData クラス

PDFDataの概要。

この型のすべてのメンバの一覧については、PDFData メンバを参照してください。

System.Object
public class PDFData : Object

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

PDFData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData 全メンバ

PDFData 概要

コンストラクタ

Constructor

パブリック プロパティ

Fonts
Images
Position
Stream

参照

PDFData クラス | Steema.TeeChart.Export 名前空間


PDFData コンストラクタ

Steema.TeeChart.Export.PDFData コンストラクタ

public PDFData(Stream stream)

参照

PDFData クラス | PDFData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData プロパティ

パブリック プロパティ

Fonts
Images
Position
Stream

参照

PDFData クラス | Steema.TeeChart.Export 名前空間


Fonts

Steema.TeeChart.Export.PDFData.Fonts プロパティ

public PDFFonts Fonts {get; set;}

参照

PDFData クラス | PDFData メンバ | Steema.TeeChart.Export 名前空間


Images

Steema.TeeChart.Export.PDFData.Images プロパティ

public GraphicsImages Images {get; set;}

参照

PDFData クラス | PDFData メンバ | Steema.TeeChart.Export 名前空間


Position

Steema.TeeChart.Export.PDFData.Position プロパティ

public Int32 Position {get; set;}

参照

PDFData クラス | PDFData メンバ | Steema.TeeChart.Export 名前空間


Stream

Steema.TeeChart.Export.PDFData.Stream プロパティ

public Stream Stream {get; set;}

参照

PDFData クラス | PDFData メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFont

Steema.TeeChart.Export.PDFData.PDFFont クラス

この型のすべてのメンバの一覧については、PDFFont メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.GraphicsFont
public class PDFFont : GraphicsFont

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

PDFFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFont 全メンバ

PDFFont 概要

パブリック メソッド

DictFontName
Equals (GraphicsFontの継承元)

パブリック プロパティ

FontData (GraphicsFontの継承元)
GraphicsFontName (GraphicsFontの継承元)
Index (GraphicsFontの継承元)
ObjectNumber (GraphicsFontの継承元)

コンストラクタ

Steema.TeeChart.Export.PDFData.PDFFont

プロテクト フィールド

m_fontname (GraphicsFontの継承元)

プロテクト メソッド

GetFontName

参照

PDFFont クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFont フィールド

プロテクト フィールド

m_fontname (GraphicsFontの継承元)

参照

PDFFont クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFont メソッド

パブリック メソッド

DictFontName
Equals (GraphicsFontの継承元)

プロテクト メソッド

GetFontName

参照

PDFFont クラス | Steema.TeeChart.Export 名前空間


DictFontName

Steema.TeeChart.Export.PDFData+PDFFont.DictFontName メソッド

public override String DictFontName()

参照

PDFFont クラス | PDFFont メンバ | Steema.TeeChart.Export 名前空間


GetFontName

Steema.TeeChart.Export.PDFData+PDFFont.GetFontName メソッド

protected abstract String GetFontName(ChartFont f)

参照

PDFFont クラス | PDFFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFont プロパティ

パブリック プロパティ

FontData (GraphicsFontの継承元)
GraphicsFontName (GraphicsFontの継承元)
Index (GraphicsFontの継承元)
ObjectNumber (GraphicsFontの継承元)

参照

PDFFont クラス | Steema.TeeChart.Export 名前空間


FontBBox

Steema.TeeChart.Export.PDFData+PDFFont.FontBBox プロパティ

public Rectangle FontBBox {get;}

参照

PDFFont クラス | PDFFont メンバ | Steema.TeeChart.Export 名前空間


PDFFont コンストラクタ

Steema.TeeChart.Export.PDFData+PDFFont コンストラクタ

public PDFData+PDFFont(PDFFonts fonts,
     ChartFont f)

参照

PDFFont クラス | PDFFont メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFonts

Steema.TeeChart.Export.PDFData.PDFFonts クラス

この型のすべてのメンバの一覧については、PDFFonts メンバを参照してください。

System.Object
System.Collections.ArrayList
Steema.TeeChart.Drawing.GraphicsFonts
public class PDFFonts : GraphicsFonts , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

PDFFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFonts 全メンバ

PDFFonts 概要

パブリック メソッド

Add | リストに新しいフォントを追加します。
FindFont (GraphicsFontsの継承元) |

パブリック プロパティ

Item

コンストラクタ

Steema.TeeChart.Export.PDFData.PDFFonts

参照

PDFFonts クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFonts メソッド

パブリック メソッド

Add | リストに新しいフォントを追加します。
FindFont (GraphicsFontsの継承元) |

参照

PDFFonts クラス | Steema.TeeChart.Export 名前空間


Add

Steema.TeeChart.Export.PDFData+PDFFonts.Add メソッド

public override Int32 Add(ChartFont font)

解説

リストに新しいフォントを追加します。

参照

PDFFonts クラス | PDFFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFData.PDFFonts プロパティ

パブリック プロパティ

Item

参照

PDFFonts クラス | Steema.TeeChart.Export 名前空間


Item

Steema.TeeChart.Export.PDFData+PDFFonts.Item プロパティ

public PDFFont Item(Int32 index) {get;}

参照

PDFFonts クラス | PDFFonts メンバ | Steema.TeeChart.Export 名前空間


PDFFonts コンストラクタ

Steema.TeeChart.Export.PDFData+PDFFonts コンストラクタ

public PDFData+PDFFonts()

参照

PDFFonts クラス | PDFFonts メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFFormat

Steema.TeeChart.Export.PDFFormat クラス

AdobeのPDFエクスポート形式。

この型のすべてのメンバの一覧については、PDFFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class PDFFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

PDFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFFormat 全メンバ

PDFFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをPDFイメージで保存します。

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

PDFFormat クラス | Steema.TeeChart.Export 名前空間


PDFFormat コンストラクタ

Steema.TeeChart.Export.PDFFormat コンストラクタ

public PDFFormat(Chart c)

参照

PDFFormat クラス | PDFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

PDFFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをPDFイメージで保存します。

参照

PDFFormat クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.PDFFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.IO.Stream)

参照

PDFFormat クラス | PDFFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.PDFFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | PDFFormat クラス | PDFFormat メンバ | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.PDFFormat.SaveToFile メソッド

チャートをPDFイメージで保存します。

public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
ファイル名

解説

チャートをPDFイメージで保存します。

参照

PDFFormat クラス | PDFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFFormat プロパティ

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

PDFFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.PDFFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

PDFFormat クラス | PDFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFPage

Steema.TeeChart.Export.PDFPage クラス

この型のすべてのメンバの一覧については、PDFPage メンバを参照してください。

System.Object
public class PDFPage : Object

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ：TeeChart.dll

参照

PDFPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFPage 全メンバ

PDFPage 概要

コンストラクタ

Constructor

パブリック メソッド

ConstructPage

パブリック プロパティ

pdfData

参照

PDFPage クラス | Steema.TeeChart.Export 名前空間


PDFPage コンストラクタ

Steema.TeeChart.Export.PDFPage コンストラクタ

public PDFPage(Stream s,
     Int32 Width,
     Int32 Height)

参照

PDFPage クラス | PDFPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFPage メソッド

パブリック メソッド

ConstructPage

参照

PDFPage クラス | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.PDFPage.ConstructPage メソッド

オーバーロードの一覧

public Void ConstructPage(System.IO.Stream)
public Void ConstructPage()

参照

PDFPage クラス | PDFPage メンバ | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.PDFPage.ConstructPage メソッド

public Void ConstructPage(Stream s)

参照

ConstructPage オーバーロードの一覧 | PDFPage クラス | PDFPage メンバ | Steema.TeeChart.Export 名前空間


ConstructPage

Steema.TeeChart.Export.PDFPage.ConstructPage メソッド

public Void ConstructPage()

参照

ConstructPage オーバーロードの一覧 | PDFPage クラス | PDFPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PDFPage プロパティ

パブリック プロパティ

pdfData

参照

PDFPage クラス | Steema.TeeChart.Export 名前空間


pdfData

Steema.TeeChart.Export.PDFPage.pdfData プロパティ

public PDFData pdfData {get;}

参照

PDFPage クラス | PDFPage メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PictureFormats

Steema.TeeChart.Export.PictureFormats 列挙体

チャートイメージのエクスポート形式です。
[Serializable]
public sealed enum PictureFormats : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Bitmap | ビットマップのイメージ形式
Metafile | メタファイルのイメージ形式
JPEG | JPEGのイメージ形式
PNG | PNGのイメージ形式
GIF | GIFのイメージ形式
TIFF | TIFFのイメージ形式
PDF | PDFのイメージ形式
VML | VMLのイメージ形式
SVG | SVGのイメージ形式
EPS | EPSのイメージ形式
XAML | XAMLのイメージ形式

参照

Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PNGFormat

Steema.TeeChart.Export.PNGFormat クラス

PNGイメージのエクスポート形式。

この型のすべてのメンバの一覧については、PNGFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class PNGFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

PNGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PNGFormat 全メンバ

PNGFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。

パブリック プロパティ

GrayScale | trueの場合、イメージはグレースケールとしてエクスポートします。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

PNGFormat クラス | Steema.TeeChart.Export 名前空間


PNGFormat コンストラクタ

Steema.TeeChart.Export.PNGFormat コンストラクタ

public PNGFormat(Chart c)

参照

PNGFormat クラス | PNGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PNGFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

PNGFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PNGFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。

参照

PNGFormat クラス | Steema.TeeChart.Export 名前空間


CopyToClipboard

Steema.TeeChart.Export.PNGFormat.CopyToClipboard メソッド

public override Void CopyToClipboard()

参照

PNGFormat クラス | PNGFormat メンバ | Steema.TeeChart.Export 名前空間


SupportsTransparent

Steema.TeeChart.Export.PNGFormat.SupportsTransparent メソッド

protected abstract Boolean SupportsTransparent()

参照

PNGFormat クラス | PNGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.PNGFormat プロパティ

パブリック プロパティ

GrayScale | trueの場合、イメージはグレースケールとしてエクスポートします。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

PNGFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.PNGFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

PNGFormat クラス | PNGFormat メンバ | Steema.TeeChart.Export 名前空間


GrayScale

Steema.TeeChart.Export.PNGFormat.GrayScale プロパティ

trueの場合、イメージはグレースケールとしてエクスポートします。
public Boolean GrayScale {get; set;}

解説

trueの場合、イメージはグレースケールとしてエクスポートします。

参照

PNGFormat クラス | PNGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SerializeBinder

TeeChartプログラミングガイド

Steema.TeeChart.Export.SerializeBinder クラス

内部使用。インポートバインダー。

この型のすべてのメンバの一覧については、SerializeBinder メンバを参照してください。

System.Object
System.Runtime.Serialization.SerializationBinder
public class SerializeBinder : SerializationBinder

必要条件

名前空間： Steema.TeeChart.Export

アセンブリ：TeeChart.dll

参照

SerializeBinder メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SerializeBinder 全メンバ

SerializeBinder 概要

コンストラクタ

Constructor

パブリック メソッド

BindToType

参照

SerializeBinder クラス | Steema.TeeChart.Export 名前空間


SerializeBinder コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Export.SerializeBinder コンストラクタ

public SerializeBinder()

参照

SerializeBinder クラス | SerializeBinder メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SerializeBinder メソッド

パブリック メソッド

BindToType

参照

SerializeBinder クラス | Steema.TeeChart.Export 名前空間


BindToType

TeeChartプログラミングガイド

Steema.TeeChart.Export.SerializeBinder.BindToType メソッド

public virtual Type BindToType(String assemblyName,
     String typeName)

参照

SerializeBinder クラス | SerializeBinder メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SVGFormat

Steema.TeeChart.Export.SVGFormat クラス

SVGエクスポート形式。

この型のすべてのメンバの一覧については、SVGFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class SVGFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

SVGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SVGFormat 全メンバ

SVGFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをSVGイメージで保存します。

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

SVGFormat クラス | Steema.TeeChart.Export 名前空間


SVGFormat コンストラクタ

Steema.TeeChart.Export.SVGFormat コンストラクタ

public SVGFormat(Chart c)

参照

SVGFormat クラス | SVGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SVGFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

SVGFormat クラス | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Export.SVGFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save |
SaveToFile | SVGイメージとしてチャートを保存します。

参照

SVGFormat クラス | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Save

Steema.TeeChart.Export.SVGFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.IO.Stream)

参照

SVGFormat クラス | SVGFormat メンバ | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Save

Steema.TeeChart.Export.SVGFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | SVGFormat クラス | SVGFormat メンバ | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SaveToFile

Steema.TeeChart.Export.SVGFormat.SaveToFile メソッド

SVGイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
字列としてのファイル名

解説

SVGイメージとしてチャートを保存します。

参照

SVGFormat クラス | SVGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.SVGFormat プロパティ

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

SVGFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.SVGFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

SVGFormat クラス | SVGFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport

Steema.TeeChart.Export.TemplateExport クラス

ネイティブ「ten」テンプレート形式でチャートをエクスポートするためのプロパティおよびメソッドにアクセスします。

この型のすべてのメンバの一覧については、TemplateExport メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
public sealed class TemplateExport : ExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport 全メンバ

TemplateExport 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

Save | ネイティブな｢ten｣テンプレートとしてファイルにチャートを保存します。
Serialize |

パブリック プロパティ

IncludeData trueの場合、テンプレートはチャートデータを含みます。

参照

TemplateExport クラス | Steema.TeeChart.Export 名前空間


TemplateExport コンストラクタ

Steema.TeeChart.Export.TemplateExport コンストラクタ

public TemplateExport(Chart c)

参照

TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

TemplateExport クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport メソッド

パブリック メソッド

Save | ネイティブな｢ten｣テンプレートとしてファイルにチャートを保存します。
Serialize |

参照

TemplateExport クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.TemplateExport.Save メソッド

オーバーロードの一覧

ネイティブな｢ten｣テンプレートとしてファイルにチャートを保存します。

public Void Save(System.String)

ネイティブな｢ten｣テンプレートとしてストリームにチャートを保存します。

public Void Save(System.IO.Stream)

解説

ネイティブな「ten」テンプレートとしてチャートを保存します。

参照

TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport.Save メソッド

ネイティブな｢ten｣テンプレートとしてファイルにチャートを保存します。

public Void Save(String FileName)

パラメーター

FileName
文字列。例：[C#] "c:\\myCharts\\myChart.ten"

参照

Save オーバーロードの一覧 | TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Save

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport.Save メソッド

ネイティブな｢ten｣テンプレートとしてストリームにチャートを保存します。

public Void Save(Stream stream)

参照

Save オーバーロードの一覧 | TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Serialize

Steema.TeeChart.Export.TemplateExport.Serialize メソッド

オーバーロードの一覧

public Void Serialize(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

バイナリフォーマッタを使用してストリームにチャートをシリアライズします。

public Void Serialize(System.IO.Stream)

解説

バイナリフォーマッタを使用してストリームにチャートをシリアライズします。

参照

TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Serialize

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport.Serialize メソッド

public Void Serialize(SerializationInfo info,
     StreamingContext context)

参照

Serialize オーバーロードの一覧 | TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Serialize

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport.Serialize メソッド

バイナリフォーマッタを使用してストリームにチャートをシリアライズします。

public Void Serialize(Stream stream)

パラメーター

ストリーム

参照

Serialize オーバーロードの一覧 | TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport プロパティ

パブリック プロパティ

IncludeData trueの場合、テンプレートはチャートデータを含みます。

参照

TemplateExport クラス | Steema.TeeChart.Export 名前空間


IncludeData

Steema.TeeChart.Export.TemplateExport.IncludeData プロパティ

trueの場合、テンプレートはチャートデータを含みます。
public Boolean IncludeData {get; set;}

解説

trueの場合、テンプレートはチャートデータを含みます。

参照

TemplateExport クラス | TemplateExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport.ICustomSerialization

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport.ICustomSerialization インターフェイス

public interface ICustomSerialization

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

ICustomSerialization メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport.ICustomSerialization 全メンバ

ICustomSerialization 概要

パブリック メソッド

DeSerialize
Serialize

参照

ICustomSerialization インターフェイス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TemplateExport.ICustomSerialization メソッド

パブリック メソッド

DeSerialize
Serialize

参照

ICustomSerialization インターフェイス | Steema.TeeChart.Export 名前空間


DeSerialize

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport+ICustomSerialization.DeSerialize メソッド

public abstract Void DeSerialize(SerializationInfo info)

参照

ICustomSerialization インターフェイス | ICustomSerialization メンバ | Steema.TeeChart.Export 名前空間


Serialize

TeeChartプログラミングガイド

Steema.TeeChart.Export.TemplateExport+ICustomSerialization.Serialize メソッド

public abstract Void Serialize(SerializationInfo info)

参照

ICustomSerialization インターフェイス | ICustomSerialization メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TextFormat

Steema.TeeChart.Export.TextFormat クラス

テキストにチャートデータをエクスポート。

この型のすべてのメンバの一覧については、TextFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.DataExportFormat
public class TextFormat : DataExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

TextFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TextFormat 全メンバ

TextFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) | エクスポートするファイルタイプのデフォルトの拡張子文字列です。
TextDelimiter |

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

TextFormat クラス | Steema.TeeChart.Export 名前空間


TextFormat コンストラクタ

Steema.TeeChart.Export.TextFormat コンストラクタ

public TextFormat(Chart c)

参照

TextFormat クラス | TextFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TextFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) | エクスポートするファイルのデフォルトの拡張子文字列です。
TextDelimiter |

参照

TextFormat クラス | Steema.TeeChart.Export 名前空間


TextDelimiter

TeeChartプログラミングガイド

Steema.TeeChart.Export.TextFormat.TextDelimiter フィールド

public String TextDelimiter

参照

TextFormat クラス | TextFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TextFormat メソッド

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

参照

TextFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TextFormat プロパティ

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

TextFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport

Steema.TeeChart.Export.ThemeExport クラス

XMLテーマ形式にチャートデータをエクスポートします。

この型のすべてのメンバの一覧については、ThemeExport メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
public class ThemeExport : ExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport 全メンバ

ThemeExport 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

Save XMLの「テーマ」ファイルにチャート特性を保存します。

パブリック プロパティ

SaveWithBase64

参照

ThemeExport クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport コンストラクタ

public ThemeExport(Chart c)

参照

ThemeExport クラス | ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

ThemeExport クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport メソッド

パブリック メソッド

Save XMLの「テーマ」ファイルにチャート特性を保存します。

参照

ThemeExport クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.ThemeExport.Save メソッド

オーバーロードの一覧

XMLの「テーマ」ファイルにチャート特性を保存します。

public Void Save(System.String)

XMLの「テーマ」ストリームにチャート特性を保存します。

public Void Save(System.IO.Stream)

参照

ThemeExport クラス | ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.ThemeExport.Save メソッド

XMLの「テーマ」ファイルにチャート特性を保存します。
public Void Save(String FileName)

参照

Save オーバーロードの一覧 | ThemeExport クラス | ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.ThemeExport.Save メソッド

XMLの「テーマ」ストリームにチャート特性を保存します。
public Void Save(Stream stream)

参照

Save オーバーロードの一覧 | ThemeExport クラス | ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.ThemeExport プロパティ

パブリック プロパティ

SaveWithBase64

参照

ThemeExport クラス | Steema.TeeChart.Export 名前空間


SaveWithBase64

Steema.TeeChart.Export.ThemeExport.SaveWithBase64 プロパティ

public Boolean SaveWithBase64 {get; set;}

参照

ThemeExport クラス | ThemeExport メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat

Steema.TeeChart.Export.TIFFFormat クラス

TIFFイメージのエクスポート形式。

この型のすべてのメンバの一覧については、TIFFFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class TIFFFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat 全メンバ

TIFFFormat 概要

コンストラクタ

Constructor TIFFFormatコンストラクタ

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | TIFFイメージとしてチャートを保存します。

パブリック プロパティ

Compression | TIFF圧縮を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

TIFFFormat クラス | Steema.TeeChart.Export 名前空間


TIFFFormat コンストラクタ

Steema.TeeChart.Export.TIFFFormat コンストラクタ

TIFFFormat コンストラクタ。
public TIFFFormat(Chart c)

参照

TIFFFormat クラス | TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

TIFFFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save (ImageExportFormatの継承元) | ストリームにイメージを保存します。
SaveToFile | TIFFイメージとしてチャートを保存します。

参照

TIFFFormat クラス | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.TIFFFormat.SaveToFile メソッド

TIFFイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

解説

TIFFイメージとしてチャートを保存します。

参照

TIFFFormat クラス | TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


SupportsTransparent

Steema.TeeChart.Export.TIFFFormat.SupportsTransparent メソッド

protected abstract Boolean SupportsTransparent()

参照

TIFFFormat クラス | TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat プロパティ

パブリック プロパティ

Compression | TIFF圧縮を設定します。
Height (ImageExportFormatの継承元) | エクスポートするイメージの高さを設定します。
Width (ImageExportFormatの継承元) | エクスポートするイメージの幅を設定します。

プロテクト プロパティ

DataFormat (ImageExportFormatの継承元) |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

TIFFFormat クラス | Steema.TeeChart.Export 名前空間


Compression

Steema.TeeChart.Export.TIFFFormat.Compression プロパティ

TIFF圧縮を設定します。
public TIFFCompression Compression {get; set;}

参照

TIFFFormat クラス | TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.TIFFFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

TIFFFormat クラス | TIFFFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.TIFFFormat.TIFFCompression

TeeChartプログラミングガイド

Steema.TeeChart.Export.TIFFFormat.TIFFCompression 列挙体

TIFFイメージの圧縮タイプです。

[Serializable]
public enum TIFFCompression : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
LZW | TIFFのLZW圧縮を定義します。
RLE | TIFFのRLE圧縮を定義します。

参照

Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.VMLFormat

Steema.TeeChart.Export.VMLFormat クラス

VMLエクスポート形式。

この型のすべてのメンバの一覧については、VMLFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class VMLFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

VMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.VMLFormat 全メンバ

VMLFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをVMLイメージで保存します。

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

VMLFormat クラス | Steema.TeeChart.Export 名前空間


VMLFormat コンストラクタ

Steema.TeeChart.Export.VMLFormat コンストラクタ

public VMLFormat(Chart c)

参照

VMLFormat クラス | VMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.VMLFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

VMLFormat クラス | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Export.VMLFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save |
SaveToFile | VMLイメージとしてチャートを保存します。

参照

VMLFormat クラス | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Save

Steema.TeeChart.Export.VMLFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.IO.Stream)

参照

VMLFormat クラス | VMLFormat メンバ | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Save

Steema.TeeChart.Export.VMLFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | VMLFormat クラス | VMLFormat メンバ | Steema.TeeChart.Export 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SaveToFile

Steema.TeeChart.Export.VMLFormat.SaveToFile メソッド

VMLイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

解説

VMLイメージとしてチャートを保存します。

参照

VMLFormat クラス | VMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.VMLFormat プロパティ

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

VMLFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.VMLFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

VMLFormat クラス | VMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat

Steema.TeeChart.Export.XAMLFormat クラス

XAMLエクスポート形式。

この型のすべてのメンバの一覧については、XAMLFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.ImageExportFormat
public class XAMLFormat : ImageExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat 全メンバ

XAMLFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | イメージをクリップボードにコピーします。
Save |
SaveToFile | チャートをXAMLイメージで保存します。

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト メソッド

SupportsTransparent (ImageExportFormatの継承元)

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

XAMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat コンストラクタ

public XAMLFormat(Chart c)

参照

XAMLFormat クラス | XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

XAMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat メソッド

パブリック メソッド

CopyToClipboard (ImageExportFormatの継承元) | クリップボードにイメージをコピーします。
Save |
SaveToFile | XAMLイメージとしてチャートを保存します。

参照

XAMLFormat クラス | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.XAMLFormat.Save メソッド

オーバーロードの一覧

public override Void Save(System.IO.Stream)

参照

XAMLFormat クラス | XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


Save

Steema.TeeChart.Export.XAMLFormat.Save メソッド

public override Void Save(Stream stream)

参照

Save オーバーロードの一覧 | XAMLFormat クラス | XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


SaveToFile

Steema.TeeChart.Export.XAMLFormat.SaveToFile メソッド

XAMLイメージとしてチャートを保存します。
public static Void SaveToFile(Chart c,
     String fileName)

パラメーター

c
保存するチャート
fileName
文字列としてのファイル名

参照

XAMLFormat クラス | XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XAMLFormat プロパティ

パブリック プロパティ

Height (ImageExportFormatの継承元) | イメージの高さを設定します。
Width (ImageExportFormatの継承元) | イメージの幅を設定します。

プロテクト プロパティ

DataFormat |
Format (ImageExportFormatの継承元) | エクスポートするチャートイメージのイメージ形式にアクセスします。

参照

XAMLFormat クラス | Steema.TeeChart.Export 名前空間


DataFormat

Steema.TeeChart.Export.XAMLFormat.DataFormat プロパティ

protected abstract String DataFormat {get;}

参照

XAMLFormat クラス | XAMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XMLFormat

Steema.TeeChart.Export.XMLFormat クラス

XMLにチャートデータをエクスポート。

この型のすべてのメンバの一覧については、XMLFormat メンバを参照してください。

System.Object
Steema.TeeChart.Export.ExportFormat
Steema.TeeChart.Export.DataExportFormat
public class XMLFormat : DataExportFormat

必要条件

名前空間: Steema.TeeChart.Export 名前空間

アセンブリ: TeeChart.dll

参照

XMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XMLFormat 全メンバ

XMLFormat 概要

コンストラクタ

Constructor

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルタイプのデフォルトの拡張子文字列です。

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

XMLFormat クラス | Steema.TeeChart.Export 名前空間


XMLFormat コンストラクタ

Steema.TeeChart.Export.XMLFormat コンストラクタ

public XMLFormat(Chart c)

参照

XMLFormat クラス | XMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XMLFormat フィールド

パブリック フィールド

FileExtension (ExportFormatの継承元) エクスポートするファイルのデフォルトの拡張子文字列です。

参照

XMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XMLFormat メソッド

パブリック メソッド

CopyToClipboard (DataExportFormatの継承元) | クリップボードへチャートデータをコピーします。
Save (DataExportFormatの継承元) | チャートをデータエクスポート形式でストリームあるいはファイルに保存します。

参照

XMLFormat クラス | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Export.XMLFormat プロパティ

パブリック プロパティ

IncludeHeader (DataExportFormatの継承元) | エクスポートするデータに系列値リスト名を含めるかどうか設定します。
IncludeIndex (DataExportFormatの継承元) | エクスポートするデータに系列ポイントのインデックスを含めるかどうか設定します。
IncludeLabels (DataExportFormatの継承元) | エクスポートするデータにラベルを含めるかどうか設定します。
IncludeSeriesTitle (DataExportFormatの継承元) | エクスポートするデータに系列タイトルを含めるかどうか設定します。
Series (DataExportFormatの継承元) | データをエクスポートする系列を設定します。
TextLineSeparator (DataExportFormatの継承元) | アスキーエクスポート形式のための区切り記号を取得/設定します。

プロテクト プロパティ

DataFormat (DataExportFormatの継承元) データ形式の記述名を返します。

参照

XMLFormat クラス | Steema.TeeChart.Export 名前空間


IncludeColors

Steema.TeeChart.Export.XMLFormat.IncludeColors プロパティ

エクスポートするデータに、系列のデータソースのポイントの色を含めるかどうかを取得/設定します。
public Boolean IncludeColors {get; set;}

参照

XMLFormat クラス | XMLFormat メンバ | Steema.TeeChart.Export 名前空間


Steema.TeeChart.Functions

Steema.TeeChart.Functions 名前空間

名前空間の階層構造

パブリック クラス

Function | 基本関数（和、差分、最大、最小、平均、計算）。
Moving | 内部使用。移動計算関数の基本クラス。
Stochastic | 確率関数。
CustomSorted | 昇順でソートされたソース系列の値を使用して値を計算するために、メディアン関数やモード関数で使用される抽象的な中間クラスです。
MedianFunction | ソース系列の中央値を計算します。中央値は昇順でソートされたソース系列の値の「中間」の値を返すという点で平均値とは異なります。中央値が複数ある場合、この関数はそれらの平均値を返します。
BaseTrend | 内部使用。さまざまなトレンド関数の基本クラス。
ExpTrendFunction | 指数トレンド関数は、指数(e)の重み付けを使用すること以外はトレンド関数と同様です。
TrendFunction | トレンド関数。
CorrelationFunction | 相関関数。
PolyFitting | フィッティング関数の基本クラス。
DownSampling | 複数の異なるメソッドを使用して、系列内のポイント数を減らします。
MovingAverage | 移動平均値関数。
Add | 和関数。
ManySeries | 内部使用。複数系列の関数計算の基本クラス。
Subtract | 差分関数。
Multiply | 積関数。
Divide | 商関数。
High | 最大関数。ソース系列の最大値を返します。
Low | 最小関数。ソース系列の最小値を返します。
Average | 平均値関数。
Count | 計算関数。
Cumulative | 累積関数。この関数は、最初のポイントから開始する系列値を集計します。例：次のような値：1 2 3 累積関数の結果：1 3 6 ( 1=1, 1+2=3, 1+2+3=6 )
Momentum | 運動量関数。
MomentumDivision | 商運動量関数。
ExpAverage | 指数平均値関数。
ExpMovAverage | 指数移動平均値関数。
ADXFunction | ADX関数は通常、相場のトレンドを検証するために金融トレンドアプリケーションで使用されます。40以上のADX値の場合は、トレンドの終了を意味します。20以下のADX値の場合は、トレンドの横ばいを示しています。
Smoothing | スムーズ関数。
Performance | パフォーマンス関数。
Spline | スプラインスムージング。
RootMeanSquare | 誤差の2乗関数。
ModeFunction | モード関数は、最も頻繁に使用されたソース系列の値を返します。
SARFunction | パラボリックSAR（ストップ・アンド・リバース）指標。
PVOFunction | PVO関数。
Regression |
Poly |
CompressOHLC | コンプレッション関数。
CompressGetDateEventArgs | CompressGetDateHandlerのEventArgs。
CLVFunction | CLV関数。
MACDFunction | 金融チャートで使用するMACD（移動平均収束拡散）関数。
StdDeviation | 標準偏差関数。
PerimeterFunction | 境界関数。
OBVFunction | OBV関数。
Custom | y=f(x)関数。
CalculateEventArgs | CalculateEventHandlerのEventArgs。
RSIFunction | RSI関数は、金融データに基づいてパーセントの値を計算するリボン系列の派生コンポーネントです。 RSI関数は、OHLC系列または任意のSeries派生コンポーネント（例：キャンドル）と接続されていなければなりません。移動平均値関数のように、RSIは前回のPeriodのポイントを使用して新しいポイント値Yを計算します。 式は次のようになります。 Upの場合：始値より大きいすべての終値を足して、足した回数で割る。 Downの場合：始値より低いすべての終値を足して、足した回数で割る。 RSI = 100.0 - ( 100.0 / ( 1.0 + Math.Abs( Ups / Downs ) ) )
HistogramFunction | データからヒストグラムあるいは累積ヒストグラムを作成します。
CCIFunction | CCI関数。
CrossPoints | クロスポイント関数。
Bollinger | ボリンジャーの概要。
VarianceFunction | 分散関数。

パブリック 列挙体

TrendStyles | トレンドのスタイルを定義します。
DownSamplingMethod | DownSamplingメソッドのタイプを定義します。
PeriodStyles | 関数のピリオドのスタイルを設定します。
PeriodAligns | ソース系列によってどのように関数を配置するか定義します。
CompressionPeriod | Compressプロパティの使用可能な値です。
RSIStyle | RSIFunction.Styleプロパティで使用されます。

パブリック デリゲート

CompressGetDateHandler |
CalculateEventHandler | 内部使用。関数計算のイベントハンドラ。

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Functions 階層構造

System.Object

Steema.TeeChart.Functions.Poly

Steema.TeeChart.Functions.Regression

Steema.TeeChart.Functions.Spline

System.EventArgs

Steema.TeeChart.Functions.CalculateEventArgs

Steema.TeeChart.Functions.CompressGetDateEventArgs

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Functions.Function

Steema.TeeChart.Functions.Add

Steema.TeeChart.Functions.ADXFunction

Steema.TeeChart.Functions.Average

Steema.TeeChart.Functions.BaseTrend

Steema.TeeChart.Functions.CorrelationFunction

Steema.TeeChart.Functions.ExpTrendFunction

Steema.TeeChart.Functions.TrendFunction

Steema.TeeChart.Functions.Bollinger

Steema.TeeChart.Functions.CCIFunction

Steema.TeeChart.Functions.CLVFunction

Steema.TeeChart.Functions.CompressOHLC

Steema.TeeChart.Functions.Count

Steema.TeeChart.Functions.CrossPoints

Steema.TeeChart.Functions.Cumulative

Steema.TeeChart.Functions.Custom

Steema.TeeChart.Functions.CustomSorted

Steema.TeeChart.Functions.MedianFunction

Steema.TeeChart.Functions.ModeFunction

Steema.TeeChart.Functions.DownSampling

Steema.TeeChart.Functions.ExpMovAverage

Steema.TeeChart.Functions.High

Steema.TeeChart.Functions.HistogramFunction

Steema.TeeChart.Functions.Low

Steema.TeeChart.Functions.ManySeries

Steema.TeeChart.Functions.Divide

Steema.TeeChart.Functions.Multiply

Steema.TeeChart.Functions.Subtract

Steema.TeeChart.Functions.Moving

Steema.TeeChart.Functions.ExpAverage

Steema.TeeChart.Functions.MACDFunction

Steema.TeeChart.Functions.Momentum

Steema.TeeChart.Functions.MomentumDivision

Steema.TeeChart.Functions.MovingAverage

Steema.TeeChart.Functions.Performance

Steema.TeeChart.Functions.RSIFunction

Steema.TeeChart.Functions.Stochastic

Steema.TeeChart.Functions.OBVFunction

Steema.TeeChart.Functions.PerimeterFunction

Steema.TeeChart.Functions.PolyFitting

Steema.TeeChart.Functions.PVOFunction

Steema.TeeChart.Functions.RootMeanSquare

Steema.TeeChart.Functions.SARFunction

Steema.TeeChart.Functions.Smoothing

Steema.TeeChart.Functions.StdDeviation

Steema.TeeChart.Functions.VarianceFunction

参照

SteemaTeeChartFunctions 名前空間


Steema.TeeChart.Functions.Add

Steema.TeeChart.Functions.Add クラス

和関数。

この型のすべてのメンバの一覧については、Add メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Add : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Add メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Add 全メンバ

Add 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Add クラス | Steema.TeeChart.Functions 名前空間


Add コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Add コンストラクタ

public Add()

参照

Add クラス | Add メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Add フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Add クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Add メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Add クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Add.Calculate メソッド

ソース系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

ソース系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Add クラス | Add メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Add.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して和関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して和関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Add クラス | Add メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Add.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Add クラス | Add メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Add プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Add クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction

Steema.TeeChart.Functions.ADXFunction クラス

ADX関数は通常、相場のトレンドを検証するために金融トレンドアプリケーションで使用されます。40以上のADX値の場合は、トレンドの終了を意味します。20以下のADX値の場合は、トレンドの横ばいを示しています。

この型のすべてのメンバの一覧については、ADXFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ADXFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction 全メンバ

ADXFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
DMDown | ダウン線（折れ線系列）の特性にアクセスします。DMDownはADX関数の（折れ線型の）サブ系列です。
DMUp | アップ線（折れ線系列）の特性にアクセスします。DMUpはADX関数の（折れ線型の）サブ系列です。
DownLinePen | ADXのダウン線を描くペンを取得します。DMDown.Penプロパティに該当します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
UpLinePen ADXのアップ線を描くペンを取得します。DMUp.Penプロパティに該当します。
aDXFunction1.UpLinePen.Color = Color.Blue ;

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ADXFunction クラス | Steema.TeeChart.Functions 名前空間


ADXFunction コンストラクタ

Steema.TeeChart.Functions.ADXFunction コンストラクタ

オーバーロードの一覧

public ADXFunction()
public ADXFunction(Steema.TeeChart.Chart)

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


ADXFunction コンストラクタ

Steema.TeeChart.Functions.ADXFunction コンストラクタ

public ADXFunction()

参照

ADXFunction コンストラクタのオーバーロードの一覧 | ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


ADXFunction コンストラクタ

Steema.TeeChart.Functions.ADXFunction コンストラクタ

public ADXFunction(Chart c)

参照

ADXFunction コンストラクタのオーバーロードの一覧 | ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction コンストラクタ

public ADXFunction(FastLine dmDown,
     FastLine dmUp)

参照

ADXFunction コンストラクタのオーバーロードの一覧 | ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

ADXFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction メソッド

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ADXFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.ADXFunction.AddPoints メソッド

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

public override Void AddPoints(Array source)

解説

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Clear

Steema.TeeChart.Functions.ADXFunction.Clear メソッド

public override Void Clear()

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.ADXFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Dispose

Steema.TeeChart.Functions.ADXFunction.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ADXFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
DMDown | ダウン線（折れ線系列）の特性にアクセスします。DMDownはADX関数の（折れ線型の）サブ系列です。
DMUp | アップ線（折れ線系列）の特性にアクセスします。DMUpはADX関数の（折れ線型の）サブ系列です。
DownLinePen | ADXのダウン線を描くペンを取得します。DMDown.Penプロパティに該当します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
UpLinePen ADXのアップ線を描くペンを取得します。DMUp.Penプロパティに該当します。
aDXFunction1.UpLinePen.Color = Color.Blue ;

参照

ADXFunction クラス | Steema.TeeChart.Functions 名前空間


DMDown

Steema.TeeChart.Functions.ADXFunction.DMDown プロパティ

ダウン線（折れ線系列）の特性にアクセスします。DMDownはADX関数の（折れ線型の）サブ系列です。
public FastLine DMDown {get;}

戻り値

ダウン線（折れ線系列）の特性にアクセスします。

DMDownはADX関数の（折れ線型の）サブ系列です。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


DMUp

Steema.TeeChart.Functions.ADXFunction.DMUp プロパティ

アップ線（折れ線系列）の特性にアクセスします。DMUpはADX関数の（折れ線型の）サブ系列です。
public FastLine DMUp {get;}

解説

アップ線（折れ線系列）の特性にアクセスします。

DMUpはADX関数の（折れ線型の）サブ系列です。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


DownLinePen

Steema.TeeChart.Functions.ADXFunction.DownLinePen プロパティ

ADXのダウン線を描くペンを定義します。DMDown.Penプロパティに該当します。
public ChartPen DownLinePen {get; set;}

解説

ADXのダウン線を描くペンを定義します。DMDown.Penプロパティに該当します。

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


UpLinePen

Steema.TeeChart.Functions.ADXFunction.UpLinePen プロパティ

ADXのアップ線を描くペンを取得します。DMUp.Penプロパティに該当します。
aDXFunction1.UpLinePen.Color = Color.Blue ;

public ChartPen UpLinePen {get; set;}

解説

ADXのアップ線を描くペンを取得します。DMUp.Penプロパティに該当します。

例

aDXFunction1.UpLinePen.Color = Color.Blue ;

参照

ADXFunction クラス | ADXFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Average

Steema.TeeChart.Functions.Average クラス

平均値関数。

この型のすべてのメンバの一覧については、Average メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
[Serializable]
public class Average : Function , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Average メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Average 全メンバ

Average 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls | 平均値関数の計算でNullポイントを含めるかどうかを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Average クラス | Steema.TeeChart.Functions 名前空間


Average コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Average コンストラクタ

オーバーロードの一覧

public Average()
public Average(System.Boolean)

参照

Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Average コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Average コンストラクタ

public Average()

参照

Average コンストラクタのオーバーロードの一覧 | Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Average コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Average コンストラクタ

public Average(Boolean UseNulls)

参照

Average コンストラクタのオーバーロードの一覧 | Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Average フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Average クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Average メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Average クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Average.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Average.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列リスト（SourceSeriesList）に対して平均値関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列リスト（SourceSeriesList）に対して平均値関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Average.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Average プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls | 平均値関数の計算でNullポイントを含めるかどうかを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Average クラス | Steema.TeeChart.Functions 名前空間


IncludeNulls

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Average.IncludeNulls プロパティ

平均値関数の計算でNullポイントを含めるかどうかを設定します。

public Boolean IncludeNulls {get; set;}

解説

デフォルト値：true

系列のNullポイント以外のみを使用して平均値を計算するためには、このプロパティをfalseに設定してください。

このプロパティがtrueの場合、Null値をゼロとみなして全ての系列ポイントを使用して平均値を計算します。

例

:
[C#]

TeeFunction1.IncludeNulls = false;

参照

Average クラス | Average メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.BaseTrend

Steema.TeeChart.Functions.BaseTrend クラス

内部使用。さまざまなトレンド関数の基本クラス。

この型のすべてのメンバの一覧については、BaseTrend メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class BaseTrend : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.BaseTrend 全メンバ

BaseTrend 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany |
CalculateTrend | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle | トレンドラインを計算するさまざまな方法を定義します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod |
Coefficient | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

BaseTrend クラス | Steema.TeeChart.Functions 名前空間


BaseTrend コンストラクタ

Steema.TeeChart.Functions.BaseTrend コンストラクタ

オーバーロードの一覧

public BaseTrend()
public BaseTrend(Steema.TeeChart.Chart)

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


BaseTrend コンストラクタ

Steema.TeeChart.Functions.BaseTrend コンストラクタ

public BaseTrend()

参照

BaseTrend コンストラクタのオーバーロードの一覧 | BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


BaseTrend コンストラクタ

Steema.TeeChart.Functions.BaseTrend コンストラクタ

public BaseTrend(Chart c)

参照

BaseTrend コンストラクタのオーバーロードの一覧 | BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.BaseTrend フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle
updating (Functionの継承元)

参照

BaseTrend クラス | Steema.TeeChart.Functions 名前空間


iTrendStyle

Steema.TeeChart.Functions.BaseTrend.iTrendStyle フィールド

protected internal TrendStyles iTrendStyle

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.BaseTrend メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany |
CalculateTrend | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod |
Coefficient | Calculates trendline first order parameter
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

BaseTrend クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.BaseTrend.Calculate メソッド

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

ソース系列に対して関数を実行します。firstIndexとlastIndexパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


CalculateAllPoints

Steema.TeeChart.Functions.BaseTrend.CalculateAllPoints メソッド

protected abstract Void CalculateAllPoints(Series source,
     ValueList notMandatorySource)

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

Steema.TeeChart.Functions.BaseTrend.CalculateMany メソッド

public override Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列リスト（SourceSeriesList）に対して関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

ソース系列のリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


CalculatePeriod

Steema.TeeChart.Functions.BaseTrend.CalculatePeriod メソッド

protected abstract Void CalculatePeriod(Series source,
     Double tmpX,
     Int32 firstIndex,
     Int32 lastIndex)

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


CalculateTrend

Steema.TeeChart.Functions.BaseTrend.CalculateTrend メソッド

式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。

public Boolean CalculateTrend(Series s,
     Int32 firstIndex,
     Int32 lastIndex,
     Double& m,
     Double& b)

パラメーター

s
firstIndex
lastIndex
m
計算されるラインパラメーター
b
計算されるラインパラメーター

戻り値

解説

式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Coefficient

Steema.TeeChart.Functions.BaseTrend.Coefficient メソッド

FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。

protected Double Coefficient(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

戻り値

FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。

解説

FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
この結果は、-1から1までの数で、ソース系列のX値とY値がどのように関連しているかを示しています。値がまったく無関係の場合、ゼロになります。

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.BaseTrend プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle | トレンドラインを計算するさまざまな方法を定義します。

参照

BaseTrend クラス | Steema.TeeChart.Functions 名前空間


TrendStyle

Steema.TeeChart.Functions.BaseTrend.TrendStyle プロパティ

トレンドラインを計算するさまざまな方法を定義します。

public TrendStyles TrendStyle {get; set;}

参照

BaseTrend クラス | BaseTrend メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger

Steema.TeeChart.Functions.Bollinger クラス

ボリンジャーの概要。

この型のすべてのメンバの一覧については、Bollinger メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Bollinger : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger 全メンバ

Bollinger 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Deviation | 上限や下限のボリンジャーバンド値を計算するために使用される標準偏差乗数を定義します。
Exponential | trueの場合、指数移動平均値関数を使用して中間値を計算します。falseの場合、標準の移動平均値を使用して中間値を計算します。
LowBand | 下限値（中間値 - 偏差 * 標準偏差）を保存します。上限値（中間値 + 偏差 * 標準偏差）はParentSeriesに保存されます。
LowBandPen | 下限線を描くペンを設定します。LowBand.Penプロパティに該当します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
UpperBandPen | 上限線を描くペンを設定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Bollinger クラス | Steema.TeeChart.Functions 名前空間


Bollinger コンストラクタ

Steema.TeeChart.Functions.Bollinger コンストラクタ

オーバーロードの一覧

public Bollinger()
public Bollinger(Steema.TeeChart.Chart)

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Bollinger コンストラクタ

Steema.TeeChart.Functions.Bollinger コンストラクタ

public Bollinger()

参照

Bollinger コンストラクタのオーバーロードの一覧 | Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Bollinger コンストラクタ

Steema.TeeChart.Functions.Bollinger コンストラクタ

public Bollinger(Chart c)

参照

Bollinger コンストラクタのオーバーロードの一覧 | Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger コンストラクタ

public Bollinger(FastLine lowBand)

参照

Bollinger コンストラクタのオーバーロードの一覧 | Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Bollinger クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Bollinger クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.Bollinger.AddPoints メソッド

public override Void AddPoints(Array source)

解説

ソース系列からすべてのポイントを取得し、関数を実行して、最後にその結果を親系列に記憶させます。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Clear

Steema.TeeChart.Functions.Bollinger.Clear メソッド

protected abstract Void Clear()

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Bollinger.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Dispose

Steema.TeeChart.Functions.Bollinger.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Bollinger プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Deviation | 上限や下限のボリンジャーバンド値を計算するために使用される標準偏差乗数を定義します。
Exponential | trueの場合、指数移動平均値関数を使用して中間値を計算します。 falseの場合、標準の移動平均値を使用して中間値を計算します。
LowBand | 下限値（中間値 - 偏差 * 標準偏差）を保存します。上限値（中間値 + 偏差 * 標準偏差）はParentSeriesに保存されます。
LowBandPen | 下限線を描くペンを設定します。 LowBand.Penプロパティに該当します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
UpperBandPen | 上限線を描くペンを設定します。

参照

Bollinger クラス | Steema.TeeChart.Functions 名前空間


Deviation

Steema.TeeChart.Functions.Bollinger.Deviation プロパティ

上限や下限のボリンジャーバンド値を計算するために使用される標準偏差乗数を定義します。

public Double Deviation {get; set;}

解説

デフォルト値：2

上限や下限のボリンジャーバンド値を計算するために使用される標準偏差乗数を定義します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Exponential

Steema.TeeChart.Functions.Bollinger.Exponential プロパティ

trueの場合、中間値を計算するために指数移動平均値関数が使用されます。
falseの場合は、標準の移動平均値関数を使用して中間値を計算します。

public Boolean Exponential {get; set;}

解説

デフォルト値：True
trueの場合、指数移動平均値関数を使用して中間値を計算します。
falseの場合、標準の移動平均値関数を使用して中間値を計算します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


LowBand

Steema.TeeChart.Functions.Bollinger.LowBand プロパティ

下限値（中間値 - 偏差 * 標準偏差）を保存します。上限値（中間値 + 偏差 * 標準偏差）はParentSeriesに保存されます。

public Series LowBand {get;}

解説

下限値（中間値 - 偏差 * 標準偏差）を保存します。上限値（中間値 + 偏差 * 標準偏差）はParentSeriesに保存されます。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


LowBandPen

Steema.TeeChart.Functions.Bollinger.LowBandPen プロパティ

下限線を描くペンを設定します。LowBand.Penプロパティに該当します。
public ChartPen LowBandPen {get; set;}

解説

下限線を描くペンを設定します。
LowBand.Penプロパティに該当します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


UpperBandPen

Steema.TeeChart.Functions.Bollinger.UpperBandPen プロパティ

上限線を描くペンを設定します。

public ChartPen UpperBandPen {get;}

解説

上限線を描くペンを設定します。

参照

Bollinger クラス | Bollinger メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CalculateEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CalculateEventArgs クラス

CalculateEventHandlerのEventArgs。

この型のすべてのメンバの一覧については、CalculateEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class CalculateEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Functions

アセンブリ：TeeChart.dll

参照

CalculateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CalculateEventArgs 全メンバ

CalculateEventArgs 概要

コンストラクタ

Constructor

パブリック フィールド

Y

パブリック プロパティ

X 現在のXパラメーターを返します。

参照

CalculateEventArgs クラス | Steema.TeeChart.Functions 名前空間


CalculateEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CalculateEventArgs コンストラクタ

public CalculateEventArgs(Double x,
     Double y)

参照

CalculateEventArgs クラス | CalculateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CalculateEventArgs フィールド

パブリック フィールド

Y

参照

CalculateEventArgs クラス | Steema.TeeChart.Functions 名前空間


Y

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CalculateEventArgs.Y フィールド

public Double Y

参照

CalculateEventArgs クラス | CalculateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CalculateEventArgs プロパティ

パブリック プロパティ

X 現在のXパラメーターを返します。

参照

CalculateEventArgs クラス | Steema.TeeChart.Functions 名前空間


X

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CalculateEventArgs.X プロパティ

現在のXパラメーターを返します。

public Double X {get;}

解説

現在のXパラメーターを返します。
X値は、StartXプロパティの値で開始し、OnCalculateイベントの呼び出し毎にPeriod値でインクリメントされます。

参照

CalculateEventArgs クラス | CalculateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CalculateEventHandler

Steema.TeeChart.Functions.CalculateEventHandler デリゲート

内部使用。関数計算のイベントハンドラ。
public delegate CalculateEventHandler (Object sender,
     CalculateEventArgs e)

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CCIFunction

Steema.TeeChart.Functions.CCIFunction クラス

CCI関数。

この型のすべてのメンバの一覧については、CCIFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CCIFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

CCIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CCIFunction 全メンバ

CCIFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Constant | 平均偏差値を乗算する値を取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CCIFunction クラス | Steema.TeeChart.Functions 名前空間


CCIFunction コンストラクタ

Steema.TeeChart.Functions.CCIFunction コンストラクタ

オーバーロードの一覧

public CCIFunction()
public CCIFunction(Steema.TeeChart.Chart)

参照

CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CCIFunction コンストラクタ

Steema.TeeChart.Functions.CCIFunction コンストラクタ

public CCIFunction()

参照

CCIFunction コンストラクタのオーバーロードの一覧 | CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CCIFunction コンストラクタ

Steema.TeeChart.Functions.CCIFunction コンストラクタ

public CCIFunction(Chart c)

参照

CCIFunction コンストラクタのオーバーロードの一覧 | CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CCIFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

CCIFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CCIFunction メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CCIFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.CCIFunction.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.CCIFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CCIFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Constant | 平均偏差値を乗算する値を取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

CCIFunction クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Constant

Steema.TeeChart.Functions.CCIFunction.Constant プロパティ

平均偏差値を乗算する値を取得/設定します。
public Double Constant {get; set;}

解説

デフォルト値：0.015

平均偏差値を乗算する値を取得/設定します。

参照

CCIFunction クラス | CCIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CLVFunction

Steema.TeeChart.Functions.CLVFunction クラス

CLV関数。

この型のすべてのメンバの一覧については、CLVFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CLVFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CLVFunction 全メンバ

CLVFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Accumulate | CLV関数の結果を累算します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Volume | CLV関数の結果を乗算するボリューム系列を取得/設定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CLVFunction クラス | Steema.TeeChart.Functions 名前空間


CLVFunction コンストラクタ

Steema.TeeChart.Functions.CLVFunction コンストラクタ

オーバーロードの一覧

public CLVFunction()
public CLVFunction(Steema.TeeChart.Chart)

参照

CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CLVFunction コンストラクタ

Steema.TeeChart.Functions.CLVFunction コンストラクタ

public CLVFunction()

参照

CLVFunction コンストラクタ オーバーロードの一覧 | CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CLVFunction コンストラクタ

Steema.TeeChart.Functions.CLVFunction コンストラクタ

public CLVFunction(Chart c)

参照

CLVFunction コンストラクタのオーバーロードの一覧 | CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CLVFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

CLVFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CLVFunction メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CLVFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.CLVFunction.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.CLVFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CLVFunction プロパティ

パブリック プロパティ

Accumulate | CLV関数の結果を累算します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Volume | CLV関数の結果を乗算するボリューム系列を取得/設定します。

参照

CLVFunction クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Accumulate

Steema.TeeChart.Functions.CLVFunction.Accumulate プロパティ

CLV関数の結果を累算します。
public Boolean Accumulate {get; set;}

解説

デフォルト値：true

このプロパティがtrueの場合、CLV関数の結果は、前のポイント計算を使用して累積されます。

参照

CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Volume

Steema.TeeChart.Functions.CLVFunction.Volume プロパティ

CLV関数の結果を乗算するボリューム系列を取得/設定します。
public Series Volume {get; set;}

解説

CLV関数の結果を乗算するボリューム系列を取得/設定します。
ボリューム値のソースとして使用される系列です。

デフォルトにより、このプロパティは「nil」（空）です。
ボリューム値はCLV計算を掛けるために使用されません。

参照

CLVFunction クラス | CLVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressGetDateEventArgs

Steema.TeeChart.Functions.CompressGetDateEventArgs クラス

CompressGetDateHandlerのEventArgs。

この型のすべてのメンバの一覧については、CompressGetDateEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class CompressGetDateEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

CompressGetDateEventArgs メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.CompressGetDateEventArgs 全メンバ

CompressGetDateEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Date | コンプレッション関数のValueIndexの日付値を取得します。
Source | コンプレッション関数のソース系列を取得します。
ValueIndex | コンプレッション関数のValueIndexを取得します。

参照

CompressGetDateEventArgs クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CompressGetDateEventArgs コンストラクタ

Steema.TeeChart.Functions.CompressGetDateEventArgs コンストラクタ

public CompressGetDateEventArgs(Series source,
     Int32 valueIndex,
     DateTime date)

参照

CompressGetDateEventArgs クラス | CompressGetDateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressGetDateEventArgs プロパティ

パブリック プロパティ

Date | コンプレッション関数のValueIndexの日付値を取得します。
Source | コンプレッション関数のソース系列を取得します。
ValueIndex | コンプレッション関数のValueIndexを取得します。

参照

CompressGetDateEventArgs クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Date

Steema.TeeChart.Functions.CompressGetDateEventArgs.Date プロパティ

コンプレッション関数のValueIndexの日付値を取得します。
public DateTime Date {get;}

解説

コンプレッション関数のValueIndexの日付値を取得します。

参照

CompressGetDateEventArgs クラス | CompressGetDateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Source

Steema.TeeChart.Functions.CompressGetDateEventArgs.Source プロパティ

コンプレッション関数のソース系列を取得します。
public Series Source {get;}

解説

コンプレッション関数のソース系列を取得します。

参照

CompressGetDateEventArgs クラス | CompressGetDateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


ValueIndex

Steema.TeeChart.Functions.CompressGetDateEventArgs.ValueIndex プロパティ

コンプレッション関数のValueIndexを取得します。
public Int32 ValueIndex {get;}

解説

コンプレッション関数のValueIndexを取得します。

参照

CompressGetDateEventArgs クラス | CompressGetDateEventArgs メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressGetDateHandler

Steema.TeeChart.Functions.CompressGetDateHandler デリゲート

public delegate CompressGetDateHandler (Object sender,
     CompressGetDateEventArgs e)

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressionPeriod

Steema.TeeChart.Functions.CompressionPeriod 列挙体

Compressプロパティの使用可能な値です。
[Serializable]
public sealed enum CompressionPeriod : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
ocDay | 日間
ocWeek | 週間
ocMonth | 月間
ocBiMonth | 2ヶ月に1度
ocQuarter | 四半期
ocYear | 年間

参照

Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.CompressOHLC

Steema.TeeChart.Functions.CompressOHLC クラス

コンプレッション関数。

この型のすべてのメンバの一覧については、CompressOHLC メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CompressOHLC : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressOHLC 全メンバ

CompressOHLC 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

OnGetDate

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Compress | CompressionPeriod列挙体で定義した通りにコンプレッションのピリオドを取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CompressOHLC クラス | Steema.TeeChart.Functions 名前空間


CompressOHLC コンストラクタ

Steema.TeeChart.Functions.CompressOHLC コンストラクタ

オーバーロードの一覧

public CompressOHLC()
public CompressOHLC(Steema.TeeChart.Chart)

参照

CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CompressOHLC コンストラクタ

Steema.TeeChart.Functions.CompressOHLC コンストラクタ

public CompressOHLC()

参照

CompressOHLC コンストラクタのオーバーロードの一覧 | CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


CompressOHLC コンストラクタ

Steema.TeeChart.Functions.CompressOHLC コンストラクタ

public CompressOHLC(Chart c)

参照

CompressOHLC コンストラクタのオーバーロードの一覧 | CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressOHLC イベント

パブリック イベント

OnGetDate

参照

CompressOHLC クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


OnGetDate

Steema.TeeChart.Functions.CompressOHLC.OnGetDate イベント

public CompressGetDateHandler  OnGetDate

参照

CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressOHLC フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

CompressOHLC クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressOHLC メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CompressOHLC クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.CompressOHLC.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.CompressOHLC.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CompressOHLC プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Compress | CompressionPeriod列挙体で定義した通りにコンプレッションのピリオドを取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

CompressOHLC クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Compress

Steema.TeeChart.Functions.CompressOHLC.Compress プロパティ

CompressionPeriod列挙体で定義した通りにコンプレッションのピリオドを取得/設定します。
public CompressionPeriod Compress {get; set;}

参照

CompressOHLC クラス | CompressOHLC メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CorrelationFunction

Steema.TeeChart.Functions.CorrelationFunction クラス

相関関数。

この型のすべてのメンバの一覧については、CorrelationFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class CorrelationFunction : BaseTrend , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

CorrelationFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CorrelationFunction 全メンバ

CorrelationFunction 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

CorrelationFunction クラス | Steema.TeeChart.Functions 名前空間


CorrelationFunction コンストラクタ

Steema.TeeChart.Functions.CorrelationFunction コンストラクタ

public CorrelationFunction()

参照

CorrelationFunction クラス | CorrelationFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CorrelationFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
updating (Functionの継承元)

参照

CorrelationFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CorrelationFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

CorrelationFunction クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.CorrelationFunction.Calculate メソッド

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

ソース系列に対して関数を実行します。firstIndexとlastIndexパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

CorrelationFunction クラス | CorrelationFunction メンバ | Steema.TeeChart.Functions 名前空間


CalculatePeriod

Steema.TeeChart.Functions.CorrelationFunction.CalculatePeriod メソッド

protected abstract Void CalculatePeriod(Series source,
     Double tmpX,
     Int32 firstIndex,
     Int32 lastIndex)

参照

CorrelationFunction クラス | CorrelationFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.CorrelationFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

CorrelationFunction クラス | CorrelationFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CorrelationFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

参照

CorrelationFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Count

Steema.TeeChart.Functions.Count クラス

計算関数。

この型のすべてのメンバの一覧については、Count メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Count : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Count メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Count 全メンバ

Count 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Count クラス | Steema.TeeChart.Functions 名前空間


Count コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Count コンストラクタ

public Count()

参照

Count クラス | Count メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Count フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Count クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Count メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Count クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Count.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Count クラス | Count メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Count.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して計算関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して計算関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Count クラス | Count メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Count.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Count クラス | Count メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Count プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Count クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CrossPoints

Steema.TeeChart.Functions.CrossPoints クラス

クロスポイント関数。

この型のすべてのメンバの一覧については、CrossPoints メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CrossPoints : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CrossPoints 全メンバ

CrossPoints 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CrossPoints クラス | Steema.TeeChart.Functions 名前空間


CrossPoints コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CrossPoints コンストラクタ

オーバーロードの一覧

public CrossPoints()
public CrossPoints(Steema.TeeChart.Chart)

参照

CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


CrossPoints コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.CrossPoints コンストラクタ

public CrossPoints()

参照

CrossPoints コンストラクタのオーバーロードの一覧 | CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


CrossPoints コンストラクタ

Steema.TeeChart.Functions.CrossPoints コンストラクタ

public CrossPoints(Chart c)

参照

CrossPoints コンストラクタのオーバーロードの一覧 | CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CrossPoints フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

CrossPoints クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CrossPoints メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CrossPoints クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.CrossPoints.AddPoints メソッド

public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.CrossPoints.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


DoCalculation

Steema.TeeChart.Functions.CrossPoints.DoCalculation メソッド

protected abstract Void DoCalculation(Series source,
     ValueList notMandatorySource)

参照

CrossPoints クラス | CrossPoints メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CrossPoints プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

CrossPoints クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Cumulative

Steema.TeeChart.Functions.Cumulative クラス

累積関数。 累積関数は、最初のポイントから開始する系列値を集計します。 例： 次のような値：1 2 3 累積関数の結果：1 3 6 ( 1=1, 1+2=3 and 1+2+3=6 )

この型のすべてのメンバの一覧については、Cumulative メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Cumulative : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Cumulative 全メンバ

Cumulative 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Cumulative クラス | Steema.TeeChart.Functions 名前空間


Cumulative コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Cumulative コンストラクタ

オーバーロードの一覧

public Cumulative()
public Cumulative(Steema.TeeChart.Chart)

参照

Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Cumulative コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Cumulative コンストラクタ

public Cumulative()

参照

Cumulative コンストラクタのオーバーロードの一覧 | Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Cumulative コンストラクタ

Steema.TeeChart.Functions.Cumulative コンストラクタ

public Cumulative(Chart c)

参照

Cumulative コンストラクタのオーバーロードの一覧 | Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Cumulative フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Cumulative クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Cumulative メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Cumulative クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Cumulative.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Cumulative.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して累積関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して累積関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Cumulative.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Cumulative クラス | Cumulative メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Cumulative プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Cumulative クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom

Steema.TeeChart.Functions.Custom クラス

y=f(x)関数。

この型のすべてのメンバの一覧については、Custom メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Custom : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom 全メンバ

Custom 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

CalculateEvent

パブリック フィールド

X

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
NumPoints | ポイント数を取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
StartX | ｢X｣パラメーターの初期値を取得/設定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Custom クラス | Steema.TeeChart.Functions 名前空間


Custom コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom コンストラクタ

オーバーロードの一覧

public Custom()
public Custom(Steema.TeeChart.Chart)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Custom コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom コンストラクタ

public Custom()

参照

Custom コンストラクタのオーバーロードの一覧 | Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Custom コンストラクタ

Steema.TeeChart.Functions.Custom コンストラクタ

public Custom(Chart c)

参照

Custom コンストラクタのオーバーロードの一覧 | Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom イベント

パブリック イベント

CalculateEvent

参照

Custom クラス | Steema.TeeChart.Functions 名前空間


CalculateEvent

Steema.TeeChart.Functions.Custom.CalculateEvent イベント

public CalculateEventHandler  CalculateEvent

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom フィールド

パブリック フィールド

X

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Custom クラス | Steema.TeeChart.Functions 名前空間


X

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom.X フィールド

public Double X

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom メソッド

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Custom クラス | Steema.TeeChart.Functions 名前空間


AddPoints

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom.AddPoints メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

public virtual Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Custom.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Custom プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
NumPoints | ポイント数を取得/設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
StartX | ｢X｣パラメーターの初期値を取得/設定します。

参照

Custom クラス | Steema.TeeChart.Functions 名前空間


NumPoints

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom.NumPoints プロパティ

ポイント数を取得/設定します。

public Int32 NumPoints {get; set;}

解説

ポイント数を取得/設定します。

関数は、OnCalculateイベントを呼び出します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


StartX

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Custom.StartX プロパティ

｢X｣パラメーターの初期値を取得/設定します。

public Double StartX {get; set;}

解説

｢X｣パラメーターの初期値を取得/設定します。

これは、OnCalculateイベントを呼び出すための開始値値です。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CustomSorted

Steema.TeeChart.Functions.CustomSorted クラス

昇順でソートされたソース系列の値を使用して値を計算するために、メディアン関数やモード関数で使用される抽象的な中間クラスです。

この型のすべてのメンバの一覧については、CustomSorted メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class CustomSorted : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CustomSorted 全メンバ

CustomSorted 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany |
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls | Trueの場合、ソース系列のnull値も含めて計算されます。デフォルト値はTrueです。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmp
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CustomSorted クラス | Steema.TeeChart.Functions 名前空間


CustomSorted コンストラクタ

Steema.TeeChart.Functions.CustomSorted コンストラクタ

オーバーロードの一覧

public CustomSorted()
public CustomSorted(Steema.TeeChart.Chart)

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


CustomSorted コンストラクタ

Steema.TeeChart.Functions.CustomSorted コンストラクタ

public CustomSorted()

参照

CustomSorted コンストラクタのオーバーロードの一覧 | CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


CustomSorted コンストラクタ

Steema.TeeChart.Functions.CustomSorted コンストラクタ

public CustomSorted(Chart c)

参照

CustomSorted コンストラクタのオーバーロードの一覧 | CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CustomSorted フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount
InternalUse (TeeBaseの継承元)
tmp
updating (Functionの継承元)

参照

CustomSorted クラス | Steema.TeeChart.Functions 名前空間


iCount

Steema.TeeChart.Functions.CustomSorted.iCount フィールド

protected internal Int32 iCount

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


tmp

Steema.TeeChart.Functions.CustomSorted.tmp フィールド

protected internal Double[] tmp

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CustomSorted メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany |
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

CustomSorted クラス | Steema.TeeChart.Functions 名前空間


CalcResult

Steema.TeeChart.Functions.CustomSorted.CalcResult メソッド

protected internal abstract Double CalcResult()

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.CustomSorted.Calculate メソッド

public override Double Calculate(Series source,
     Int32 first,
     Int32 last)

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

Steema.TeeChart.Functions.CustomSorted.CalculateMany メソッド

public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.CustomSorted プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls | Trueの場合、ソース系列のnull値も含めて計算されます。デフォルト値はTrueです。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

CustomSorted クラス | Steema.TeeChart.Functions 名前空間


IncludeNulls

Steema.TeeChart.Functions.CustomSorted.IncludeNulls プロパティ

デフォルト値：True
Trueの場合、ソース系列のnull値も含めて計算されます。

public Boolean IncludeNulls {get; set;}

参照

CustomSorted クラス | CustomSorted メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Divide

Steema.TeeChart.Functions.Divide クラス

商関数。

この型のすべてのメンバの一覧については、Divide メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Divide : ManySeries , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Divide メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Divide 全メンバ

Divide 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Divide クラス | Steema.TeeChart.Functions 名前空間


Divide コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Divide コンストラクタ

public Divide()

参照

Divide クラス | Divide メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Divide フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Divide クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Divide メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Divide クラス | Steema.TeeChart.Functions 名前空間


CalculateValue

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Divide.CalculateValue メソッド

protected virtual Double CalculateValue(Double result,
     Double value)

参照

Divide クラス | Divide メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Divide.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Divide クラス | Divide メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Divide プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Divide クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSampling

Steema.TeeChart.Functions.DownSampling クラス

複数の異なるメソッドを使用して、系列内のポイント数を減らします。

この型のすべてのメンバの一覧については、DownSampling メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class DownSampling : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSampling 全メンバ

DownSampling 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。
Reduce | 配列のポイント数を減少させます。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
DisplayedPointCount |
Method |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
ReducedSize | 減らされたサイズを返します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Tolerance | DownSamplingメソッドの許容範囲を取得/設定します。許容範囲内のポイントはすべて1つ、あるいは2つのポイントで置換されます。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

DownSampling クラス | Steema.TeeChart.Functions 名前空間


DownSampling コンストラクタ

Steema.TeeChart.Functions.DownSampling コンストラクタ

オーバーロードの一覧

public DownSampling()
public DownSampling(Steema.TeeChart.Chart)

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DownSampling コンストラクタ

Steema.TeeChart.Functions.DownSampling コンストラクタ

public DownSampling()

参照

DownSampling コンストラクタのオーバーロードの一覧 | DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DownSampling コンストラクタ

Steema.TeeChart.Functions.DownSampling コンストラクタ

public DownSampling(Chart c)

参照

DownSampling コンストラクタのオーバーロードの一覧 | DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSampling フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

DownSampling クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSampling メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。
Reduce | 配列のポイント数を減少させます。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

DownSampling クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.DownSampling.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.DownSampling.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Reduce

Steema.TeeChart.Functions.DownSampling.Reduce メソッド

配列のポイント数を減少させます。
public Int32 Reduce(DownSamplingMethod algorithm,
     Double tol,
     Int32 lbound,
     Int32 ubound,
     Series s,
     Double[]& rx,
     Double[]& ry,
     ColorList& colors,
     Color color)

パラメーター

algorithm
減少アルゴリズム
tol
許容範囲
lbound
x,y配列の最小境界
ubound
x,y配列の最大境界
x
x配列
y
y配列
rx
減少された値を持つx配列
ry
減少された値を持つy配列

戻り値

減少された配列のサイズ

解説

配列のポイント数を減少させます。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSampling プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
DisplayedPointCount |
Method |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
ReducedSize | 減らされたサイズを返します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Tolerance | DownSamplingメソッドの許容範囲を取得/設定します。許容範囲内のポイントはすべて1つ、あるいは2つのポイントで置換されます。

参照

DownSampling クラス | Steema.TeeChart.Functions 名前空間


DisplayedPointCount

Steema.TeeChart.Functions.DownSampling.DisplayedPointCount プロパティ

public Int32 DisplayedPointCount {get; set;}

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Method

Steema.TeeChart.Functions.DownSampling.Method プロパティ

public DownSamplingMethod Method {get; set;}

解説

減少についてのSampleMethodメソッドを定義します。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


ReducedSize

Steema.TeeChart.Functions.DownSampling.ReducedSize プロパティ

減らされたポイント数を返します。
public Int32 ReducedSize {get;}

解説

減らされたポイント数を返します。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Tolerance

Steema.TeeChart.Functions.DownSampling.Tolerance プロパティ

DownSamplingメソッドの許容範囲を取得/設定します。許容範囲内のポイントはすべて1つ、あるいは2つのポイントで置換されます。
public Double Tolerance {get; set;}

解説

DownSamplingメソッドの許容範囲を取得/設定します。許容範囲内のポイントはすべて1つ、あるいは2つのポイントで置換されます。

参照

DownSampling クラス | DownSampling メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.DownSamplingMethod

Steema.TeeChart.Functions.DownSamplingMethod 列挙体

DownSamplingメソッドのタイプを定義します。
[Serializable]
public sealed enum DownSamplingMethod : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Max | ポイントのグループをグループの最大値に置換します。
Min | ポイントのグループをグループの最小値に置換します。
MinMax | ポイントのグループを2つのポイント（グループの最小値とグループの最大値）に置換します。
MinMaxFirstLast | ポイントのグループを2つのポイント（グループの最小値と最大）に置換します。1つのグループの最後の値から次のグループの最初の値まで描画します。
MinMaxFirstLastNull | ポイントのグループを2つのポイント（最小値と最大値のグループ）で置換します。1グループの末尾の値から次のグループの先頭の値まで描画します。グループの最初のnullのみ描画せずに計算に含めます。
Average | ポイントのグループをグループの平均値に置換します。

参照

Steema.TeeChart.Functions 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.ExpAverage

Steema.TeeChart.Functions.ExpAverage クラス

指数平均値関数。

この型のすべてのメンバの一覧については、ExpAverage メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class ExpAverage : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

ExpAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpAverage 全メンバ

ExpAverage 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Weight | 指数平均値を計算するために使用する重みを指定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ExpAverage クラス | Steema.TeeChart.Functions 名前空間


ExpAverage コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ExpAverage コンストラクタ

public ExpAverage()

参照

ExpAverage クラス | ExpAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpAverage フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

ExpAverage クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpAverage メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ExpAverage クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.ExpAverage.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

ExpAverage クラス | ExpAverage メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.ExpAverage.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

ExpAverage クラス | ExpAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpAverage プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Weight | 指数平均値を計算するために使用する重みを指定します。

参照

ExpAverage クラス | Steema.TeeChart.Functions 名前空間


Weight

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ExpAverage.Weight プロパティ

指数平均値を計算するために使用する重みを指定します。

public Double Weight {get; set;}

解説

デフォルト値：0.2
指数平均値を計算するために使用する重みを指定します。

次の式は、各指数平均値関数ポイントを計算するために使用されています。

指数平均値（ポイント）＝指数平均値（前のポイント）×（１－重さ）＋重さ×ポイント値

参照

ExpAverage クラス | ExpAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpMovAverage

Steema.TeeChart.Functions.ExpMovAverage クラス

指数移動平均値関数。

この型のすべてのメンバの一覧については、ExpMovAverage メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ExpMovAverage : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpMovAverage 全メンバ

ExpMovAverage 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ExpMovAverage クラス | Steema.TeeChart.Functions 名前空間


ExpMovAverage コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ExpMovAverage コンストラクタ

オーバーロードの一覧

public ExpMovAverage()
public ExpMovAverage(Steema.TeeChart.Chart)

参照

ExpMovAverage クラス | ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


ExpMovAverage コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ExpMovAverage コンストラクタ

public ExpMovAverage()

参照

ExpMovAverage コンストラクタのオーバーロードの一覧 | ExpMovAverage クラス | ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


ExpMovAverage コンストラクタ

Steema.TeeChart.Functions.ExpMovAverage コンストラクタ

public ExpMovAverage(Chart c)

参照

ExpMovAverage コンストラクタのオーバーロードの一覧 | ExpMovAverage クラス | ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpMovAverage フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

ExpMovAverage クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpMovAverage メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ExpMovAverage クラス | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.ExpMovAverage.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

ExpMovAverage クラス | ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


DoCalculation

Steema.TeeChart.Functions.ExpMovAverage.DoCalculation メソッド

protected abstract Void DoCalculation(Series source,
     ValueList notMandatorySource)

参照

ExpMovAverage クラス | ExpMovAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpMovAverage プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

ExpMovAverage クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpTrendFunction

Steema.TeeChart.Functions.ExpTrendFunction クラス

指数トレンド関数は、指数(e)の重み付けを使用すること以外はトレンド関数と同様です。

この型のすべてのメンバの一覧については、ExpTrendFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class ExpTrendFunction : BaseTrend , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

ExpTrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpTrendFunction 全メンバ

ExpTrendFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (BaseTrendの継承元) |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod (BaseTrendの継承元) |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

ExpTrendFunction クラス | Steema.TeeChart.Functions 名前空間


ExpTrendFunction コンストラクタ

Steema.TeeChart.Functions.ExpTrendFunction コンストラクタ

オーバーロードの一覧

public ExpTrendFunction()
public ExpTrendFunction(Steema.TeeChart.Chart)

参照

ExpTrendFunction クラス | ExpTrendFunction メンバ | Steema.TeeChart.Functions 名前空間


ExpTrendFunction コンストラクタ

Steema.TeeChart.Functions.ExpTrendFunction コンストラクタ

public ExpTrendFunction()

参照

ExpTrendFunction コンストラクタのオーバーロードの一覧 | ExpTrendFunction クラス | ExpTrendFunction メンバ | Steema.TeeChart.Functions 名前空間


ExpTrendFunction コンストラクタ

Steema.TeeChart.Functions.ExpTrendFunction コンストラクタ

public ExpTrendFunction(Chart c)

参照

ExpTrendFunction コンストラクタのオーバーロードの一覧 | ExpTrendFunction クラス | ExpTrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpTrendFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
updating (Functionの継承元)

参照

ExpTrendFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpTrendFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (BaseTrendの継承元) |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod (BaseTrendの継承元) |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

ExpTrendFunction クラス | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.ExpTrendFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

ExpTrendFunction クラス | ExpTrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ExpTrendFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

参照

ExpTrendFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Function

Steema.TeeChart.Functions.Function クラス

基本関数（和、差分、最大、最小、平均値、計算）。

この型のすべてのメンバの一覧については、Function メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Function : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Function メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Function 全メンバ

Function 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle | Periodプロパティのスタイルを設定します。
Series | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod
dPeriod
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating

プロテクト メソッド

AddFunctionXY
CalculateAllPoints
CalculateByPeriod
CalculatePeriod
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList

参照

Function クラス | Steema.TeeChart.Functions 名前空間


Function コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function コンストラクタ

オーバーロードの一覧

public Function()
public Function(Steema.TeeChart.Chart)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Function コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function コンストラクタ

public Function()

参照

Function コンストラクタのオーバーロードの一覧 | Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Function コンストラクタ

Steema.TeeChart.Functions.Function コンストラクタ

public Function(Chart c)

参照

Function コンストラクタのオーバーロードの一覧 | Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Function フィールド

プロテクト フィールド

CanUsePeriod
dPeriod
InternalUse (TeeBaseの継承元)
updating

参照

Function クラス | Steema.TeeChart.Functions 名前空間


CanUsePeriod

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.CanUsePeriod フィールド

protected Boolean CanUsePeriod

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


dPeriod

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.dPeriod フィールド

protected Double dPeriod

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


updating

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.updating フィールド

protected Boolean updating

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Function メソッド

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY
CalculateAllPoints
CalculateByPeriod
CalculatePeriod
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList

参照

Function クラス | Steema.TeeChart.Functions 名前空間


AddFunctionXY

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.AddFunctionXY メソッド

protected Void AddFunctionXY(Boolean yMandatorySource,
     Double tmpX,
     Double tmpY)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


AddPoints

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.AddPoints メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

public virtual Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Function.Calculate メソッド

指定したソース系列に対して関数を実行します。
public abstract Double Calculate(Series source,
     Int32 first,
     Int32 last)

解説

指定したソース系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


CalculateAllPoints

Steema.TeeChart.Functions.Function.CalculateAllPoints メソッド

protected abstract Void CalculateAllPoints(Series source,
     ValueList notMandatorySource)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


CalculateByPeriod

Steema.TeeChart.Functions.Function.CalculateByPeriod メソッド

protected Void CalculateByPeriod(Series source,
     ValueList notMandatorySource)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


CalculatePeriod

Steema.TeeChart.Functions.Function.CalculatePeriod メソッド

protected abstract Void CalculatePeriod(Series source,
     Double tmpX,
     Int32 firstIndex,
     Int32 lastIndex)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Clear

Steema.TeeChart.Functions.Function.Clear メソッド

protected abstract Void Clear()

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Function.Description メソッド

public abstract String Description()

解説

説明テキストを取得します。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Dispose

Steema.TeeChart.Functions.Function.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


DoCalculation

Steema.TeeChart.Functions.Function.DoCalculation メソッド

protected abstract Void DoCalculation(Series source,
     ValueList notMandatorySource)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


HideSeries

Steema.TeeChart.Functions.Function.HideSeries メソッド

protected abstract Void HideSeries(Series ASeries)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


PrepareSeries

Steema.TeeChart.Functions.Function.PrepareSeries メソッド

protected abstract Void PrepareSeries(Series ASeries)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Recalculate

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.Recalculate メソッド

親系列にCheckDataSourceメソッドを実行します。

public Void Recalculate()

解説

親系列にCheckDataSourceメソッドを実行します。

基本的に親系列のすべてのポイントは再計算されます。

再計算は内部のIUpdateフラグがfalseに設定されている場合のみ実行されます。

IUpdateをfalseに設定するために、TeeFunctionのReCalculateメソッドを実行する前にTeeFunctionのEndUpdateメソッドを実行することができます。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


ValueList

Steema.TeeChart.Functions.Function.ValueList メソッド

protected ValueList ValueList(Series s)

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Function プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle | Periodプロパティのスタイルを設定します。
Series | TTeeFunctionの親のTChartSeriesを返します。

参照

Function クラス | Steema.TeeChart.Functions 名前空間


Period

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Function.Period プロパティ

いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。

public Double Period {get; set;}

解説

いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
たとえば、TAverageTeeFunction は、このプロパティを使用してポイントあるいはX範囲が、このPeriod数を超過するごとに、新しい平均値ポイントを計算させます。

メモ：TTeeFunction.PeriodStyleプロパティを使用して「ポイント数」あるいは「X範囲」としてPeriodプロパティの単位を交換できます。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


PeriodAlign

Steema.TeeChart.Functions.Function.PeriodAlign プロパティ

ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
public PeriodAligns PeriodAlign {get; set;}

解説

デフォルト値：Center

ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。関数のピリオドがゼロより大きい場合、関数の結果は、関数のピリオドの「中心」位置にデフォルトで系列に追加されます。このプロパティを以下のように設定して変更できます。

- First 関数の結果は各ピリオドの最初の位置に描画します。）
- Center （関数の結果は各ピリオドの中央の位置に描画します。）
- Last （関数の結果は各ピリオドの最後の位置に描画します。）

例

TeeFunction1.PeriodAlign = Center ; // <-- デフォルトは中央になります。

「First」と「Last」の定数は、各ピリオドの最初と最後のX座標で計算します。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


PeriodStyle

Steema.TeeChart.Functions.Function.PeriodStyle プロパティ

Periodプロパティのスタイルを設定します。
public PeriodStyles PeriodStyle {get; set;}

解説

デフォルト値：NumPoints

Periodプロパティのスタイルを設定します。デフォルトは、Periodプロパティがポイント数単位で指定されることになります。Rangeは、Periodプロパティが値の範囲で指定されることになります。

PeriodをRange（範囲）として定義できることはDateTime系列を使用する場合や、一ヶ月または一日といったDateTimeステップで関数のPeriodを表現する場合にとても便利です。

例えば、DateTimeのソース系列に標準の平均値関数を使用し、一ヶ月間のピリオドを設定して販売の月平均関数を描画する事が可能です：

{ Series1を配置して、実行時にDateTimeデータ値を使用して描画してください。 }

Series2.SetFunction( TAverageTeeFunction.Create );

Series2.FunctionType.PeriodStyle = Range;

Series2.FunctionType.Period = DateTimeStep[ dtOneMonth ];

Series2.DataSource = Series1 ;

これは、Series1のデータの月ごとの平均値を表示します。
Series1のポイントは、DateTimeピリオドで関数を計算する場合、日付でソートされていなければなりません。

範囲はDateTimeを使用していない系列でも使用できます。

Series2.SetFunction( TAverageTeeFunction.Create ) ;
Series2.FunctionType.PeriodStyle = Range;
Series2.FunctionType.Period = 100;
Series2.DataSource = Series1 ;

これは100ポイント毎のグループの平均を計算します。

( X >=0, X<100のポイントは最初の平均値を計算するために使用されます。X >=100, X<200のポイントは二番目の平均値を計算するために使用されます。といった具合になります。 )

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Series

Steema.TeeChart.Functions.Function.Series プロパティ

TTeeFunctionの親のTChartSeriesを返します。
public Series Series {get; set;}

解説

実行および読み込み専用。

TTeeFunctionの親のTChartSeriesを返します。TChartは、実際に描画するためにSeriesを使用します。

参照

Function クラス | Function メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.High

Steema.TeeChart.Functions.High クラス

最大関数。ソース系列の最大値を返します。

この型のすべてのメンバの一覧については、High メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class High : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

High メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.High 全メンバ

High 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

High クラス | Steema.TeeChart.Functions 名前空間


High コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.High コンストラクタ

public High()

参照

High クラス | High メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.High フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

High クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.High メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

High クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.High.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

High クラス | High メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.High.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して最大値関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して最大値関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

High クラス | High メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.High.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

High クラス | High メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.High プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

High クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction

Steema.TeeChart.Functions.HistogramFunction クラス

データからヒストグラムあるいは累積ヒストグラムを作成します。

この型のすべてのメンバの一覧については、HistogramFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class HistogramFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction 全メンバ

HistogramFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Histogram | data配列からヒストグラムを作成します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Cumulative |
NumBins |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

HistogramFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction コンストラクタ

オーバーロードの一覧

public HistogramFunction()
public HistogramFunction(Steema.TeeChart.Chart)

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction コンストラクタ

public HistogramFunction()

参照

HistogramFunction コンストラクタのオーバーロードの一覧 | HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction コンストラクタ

public HistogramFunction(Chart c)

参照

HistogramFunction コンストラクタのオーバーロードの一覧 | HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

参照

HistogramFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.HistogramFunction メソッド

パブリック メソッド

AddPoints | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Histogram | data配列からヒストグラムを作成します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

HistogramFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.HistogramFunction.AddPoints メソッド

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.HistogramFunction.Description メソッド

public override String Description()

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Histogram

Steema.TeeChart.Functions.HistogramFunction.Histogram メソッド

data配列からヒストグラムを作成します。
public static Void Histogram(Double[] data,
     Int32 lb,
     Int32 ub,
     Double[]& bins,
     Double[]& counts,
     Int32 nbins,
     Double min,
     Double max)

パラメーター

data
ヒストグラムのデータを定義します。
lb
データの下限。
ub
データの上限。
bins
binの中心点を返します。
counts
各binの個数を返します。
nbins
ヒストグラムで使用されたbinの数。binsとcountsの数が合っていなければなりません。
min
ヒストグラムで使用される最小値。 一般的にはデータの最小値です。
max
ヒストグラムで使用される最大値。 一般的にはデータの最大値です。

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.HistogramFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Cumulative |
NumBins |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

HistogramFunction クラス | Steema.TeeChart.Functions 名前空間


Cumulative

Steema.TeeChart.Functions.HistogramFunction.Cumulative プロパティ

public Boolean Cumulative {get; set;}

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


NumBins

Steema.TeeChart.Functions.HistogramFunction.NumBins プロパティ

public Int32 NumBins {get; set;}

参照

HistogramFunction クラス | HistogramFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Low

Steema.TeeChart.Functions.Low クラス

最小関数。ソース系列の最小値を返します。

この型のすべてのメンバの一覧については、Low メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Low : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Low メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Low 全メンバ

Low 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Low クラス | Steema.TeeChart.Functions 名前空間


Low コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Low コンストラクタ

public Low()

参照

Low クラス | Low メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Low フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Low クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Low メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Low クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Low.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Low クラス | Low メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Low.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して最小関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeriesList,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して最小関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

Low クラス | Low メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Low.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Low クラス | Low メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Low プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Low クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction

Steema.TeeChart.Functions.MACDFunction クラス

金融チャートで使用するMACD（移動平均収束拡散）関数。

この型のすべてのメンバの一覧については、MACDFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MACDFunction : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction 全メンバ

MACDFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Histogram | MACD関数で内部的に計算された（ボリューム型の）サブ系列を返します。
HistogramPen | MACD関数のヒストグラム線を描くペンを設定します。
MACDExp | MACD関数で内部的に計算された（折れ線型の）二番目のサブ系列を返します。
MACDExpPen | MACDの指数線を描くペンを設定します。
MACDPen | MACDの線を描くペンを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period2 | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period3 | MACD関数の計算に使用されるサンプルの数を定義します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MACDFunction クラス | Steema.TeeChart.Functions 名前空間


MACDFunction コンストラクタ

Steema.TeeChart.Functions.MACDFunction コンストラクタ

オーバーロードの一覧

public MACDFunction()
public MACDFunction(Steema.TeeChart.Chart)

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


MACDFunction コンストラクタ

Steema.TeeChart.Functions.MACDFunction コンストラクタ

public MACDFunction()

参照

MACDFunction コンストラクタのオーバーロードの一覧 | MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


MACDFunction コンストラクタ

Steema.TeeChart.Functions.MACDFunction コンストラクタ

public MACDFunction(Chart c)

参照

MACDFunction コンストラクタのオーバーロードの一覧 | MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction コンストラクタ

public MACDFunction(FastLine macdExp,
     Volume histogram)

参照

MACDFunction コンストラクタのオーバーロードの一覧 | MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

MACDFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MACDFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.MACDFunction.AddPoints メソッド

public override Void AddPoints(Array source)

解説

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Clear

Steema.TeeChart.Functions.MACDFunction.Clear メソッド

protected abstract Void Clear()

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.MACDFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Dispose

Steema.TeeChart.Functions.MACDFunction.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MACDFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Histogram | MACD関数で内部的に計算された（ボリューム型の）サブ系列を返します。
HistogramPen | MACD関数のヒストグラム線を描くペンを設定します。
MACDExp | MACD関数で内部的に計算された（折れ線型の）二番目のサブ系列を返します。
MACDExpPen | MACDの指数線を描くペンを設定します。
MACDPen | MACDの線を描くペンを設定します。
Period (Functionの継承元) | ポイント数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period2 | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period3 | MACD関数の計算に使用されるサンプルの数を定義します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

MACDFunction クラス | Steema.TeeChart.Functions 名前空間


Histogram

Steema.TeeChart.Functions.MACDFunction.Histogram プロパティ

MACD関数で内部的に計算された（ボリューム型の）サブ系列を返します。

public Volume Histogram {get;}

解説

MACD関数で内部的に計算された（ボリューム型の）サブ系列を返します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


HistogramPen

Steema.TeeChart.Functions.MACDFunction.HistogramPen プロパティ

MACD関数のヒストグラム線を描くペンを設定します。
public ChartPen HistogramPen {get; set;}

解説

MACD関数のヒストグラム線を描くペンを設定します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


MACDExp

Steema.TeeChart.Functions.MACDFunction.MACDExp プロパティ

MACD関数で内部的に計算された（折れ線型の）二番目のサブ系列を返します。

public FastLine MACDExp {get;}

解説

MACD関数で内部的に計算された（折れ線型の）二番目のサブ系列を返します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


MACDExpPen

Steema.TeeChart.Functions.MACDFunction.MACDExpPen プロパティ

MACDの指数線を描くペンを設定します。

public ChartPen MACDExpPen {get;}

解説

MACDの指数線を描くペンを設定します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


MACDPen

Steema.TeeChart.Functions.MACDFunction.MACDPen プロパティ

MACDの線を描くペンを設定します。
public ChartPen MACDPen {get; set;}

解説

MACDの線を描くペンを設定します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Period2

Steema.TeeChart.Functions.MACDFunction.Period2 プロパティ

ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。

public Double Period2 {get; set;}

解説

ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。

例えば、平均値関数は「Period」のポイントの数またはX範囲を超える度に、新しい平均値ポイントを計算します。

Function.PeriodStyleプロパティを使用して、ポイントの数かX範囲に切り替えることができます。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Period3

Steema.TeeChart.Functions.MACDFunction.Period3 プロパティ

MACD関数の計算に使用されるサンプルの数を定義します。

public Double Period3 {get; set;}

解説

MACD関数の計算に使用されるサンプルの数を定義します。

参照

MACDFunction クラス | MACDFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ManySeries

Steema.TeeChart.Functions.ManySeries クラス

内部使用。複数系列の関数計算の基本クラス。

この型のすべてのメンバの一覧については、ManySeries メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class ManySeries : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

ManySeries メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ManySeries 全メンバ

ManySeries 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ManySeries クラス | Steema.TeeChart.Functions 名前空間


ManySeries コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ManySeries コンストラクタ

public ManySeries()

参照

ManySeries クラス | ManySeries メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ManySeries フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

ManySeries クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ManySeries メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ManySeries クラス | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ManySeries.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

ManySeries クラス | ManySeries メンバ | Steema.TeeChart.Functions 名前空間


CalculateValue

TeeChartプログラミングガイド

Steema.TeeChart.Functions.ManySeries.CalculateValue メソッド

protected virtual Double CalculateValue(Double result,
     Double value)

参照

ManySeries クラス | ManySeries メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ManySeries プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

ManySeries クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MedianFunction

Steema.TeeChart.Functions.MedianFunction クラス

ソース系列の中央値を計算します。中央値は昇順でソートされたソース系列の値の「中間」の値を返すという点で平均値とは異なります。中央値が複数ある場合、この関数はそれらの平均値を返します。

この型のすべてのメンバの一覧については、MedianFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.CustomSorted
public class MedianFunction : CustomSorted , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MedianFunction 全メンバ

MedianFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (CustomSortedの継承元) |
CalculateMany (CustomSortedの継承元) |
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls (CustomSortedの継承元) | Trueの場合、ソース系列のnull値も含めて計算されます。デフォルト値はTrueです。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount (CustomSortedの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmp (CustomSortedの継承元)
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MedianFunction クラス | Steema.TeeChart.Functions 名前空間


MedianFunction コンストラクタ

Steema.TeeChart.Functions.MedianFunction コンストラクタ

オーバーロードの一覧

public MedianFunction()
public MedianFunction(Steema.TeeChart.Chart)

参照

MedianFunction クラス | MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


MedianFunction コンストラクタ

Steema.TeeChart.Functions.MedianFunction コンストラクタ

public MedianFunction()

参照

MedianFunction コンストラクタのオーバーロードの一覧 | MedianFunction クラス | MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


MedianFunction コンストラクタ

Steema.TeeChart.Functions.MedianFunction コンストラクタ

public MedianFunction(Chart c)

参照

MedianFunction コンストラクタのオーバーロードの一覧 | MedianFunction クラス | MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MedianFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount (CustomSortedの継承元)
InternalUse (TeeBaseの継承元)
tmp (CustomSortedの継承元)
updating (Functionの継承元)

参照

MedianFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MedianFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (CustomSortedの継承元) |
CalculateMany (CustomSortedの継承元) |
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MedianFunction クラス | Steema.TeeChart.Functions 名前空間


CalcResult

Steema.TeeChart.Functions.MedianFunction.CalcResult メソッド

protected internal abstract Double CalcResult()

参照

MedianFunction クラス | MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.MedianFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

MedianFunction クラス | MedianFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MedianFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls (CustomSortedの継承元) | Trueの場合、ソース系列のnull値を含めて計算します。デフォルト値はTrueです。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

MedianFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ModeFunction

Steema.TeeChart.Functions.ModeFunction クラス

モード関数は、最も頻繁に使用されたソース系列の値を返します。

この型のすべてのメンバの一覧については、ModeFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.CustomSorted
public class ModeFunction : CustomSorted , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ModeFunction 全メンバ

ModeFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (CustomSortedの継承元) |
CalculateMany (CustomSortedの継承元) |
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls (CustomSortedの継承元) | Trueの場合、ソース系列のnull値も含めて計算されます。デフォルト値はTrueです。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount (CustomSortedの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmp (CustomSortedの継承元)
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ModeFunction クラス | Steema.TeeChart.Functions 名前空間


ModeFunction コンストラクタ

Steema.TeeChart.Functions.ModeFunction コンストラクタ

オーバーロードの一覧

public ModeFunction()
public ModeFunction(Steema.TeeChart.Chart)

参照

ModeFunction クラス | ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


ModeFunction コンストラクタ

Steema.TeeChart.Functions.ModeFunction コンストラクタ

public ModeFunction()

参照

ModeFunction コンストラクタのオーバーロードの一覧 | ModeFunction クラス | ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


ModeFunction コンストラクタ

Steema.TeeChart.Functions.ModeFunction コンストラクタ

public ModeFunction(Chart c)

参照

ModeFunction コンストラクタのオーバーロードの一覧 | ModeFunction クラス | ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ModeFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
iCount (CustomSortedの継承元)
InternalUse (TeeBaseの継承元)
tmp (CustomSortedの継承元)
updating (Functionの継承元)

参照

ModeFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ModeFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (CustomSortedの継承元) |
CalculateMany (CustomSortedの継承元) |
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalcResult
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

ModeFunction クラス | Steema.TeeChart.Functions 名前空間


CalcResult

Steema.TeeChart.Functions.ModeFunction.CalcResult メソッド

protected internal abstract Double CalcResult()

参照

ModeFunction クラス | ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.ModeFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

ModeFunction クラス | ModeFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.ModeFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
IncludeNulls (CustomSortedの継承元) | Trueの場合、ソース系列のnull値を含めて計算します。デフォルト値はTrueです。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

ModeFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Momentum

Steema.TeeChart.Functions.Momentum クラス

運動量関数。

この型のすべてのメンバの一覧については、Momentum メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Momentum : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Momentum メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Momentum 全メンバ

Momentum 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Momentum クラス | Steema.TeeChart.Functions 名前空間


Momentum コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Momentum コンストラクタ

public Momentum()

参照

Momentum クラス | Momentum メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Momentum フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Momentum クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Momentum メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Momentum クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Momentum.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Momentum クラス | Momentum メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Momentum.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Momentum クラス | Momentum メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Momentum プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Momentum クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MomentumDivision

Steema.TeeChart.Functions.MomentumDivision クラス

商運動量関数。

この型のすべてのメンバの一覧については、MomentumDivision メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MomentumDivision : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

MomentumDivision メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MomentumDivision 全メンバ

MomentumDivision 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MomentumDivision クラス | Steema.TeeChart.Functions 名前空間


MomentumDivision コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.MomentumDivision コンストラクタ

public MomentumDivision()

参照

MomentumDivision クラス | MomentumDivision メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MomentumDivision フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

MomentumDivision クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MomentumDivision メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MomentumDivision クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.MomentumDivision.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

MomentumDivision クラス | MomentumDivision メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.MomentumDivision.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

MomentumDivision クラス | MomentumDivision メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MomentumDivision プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

MomentumDivision クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Moving

Steema.TeeChart.Functions.Moving クラス

内部使用。移動計算関数の基本クラス。

この型のすべてのメンバの一覧については、Moving メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Moving : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Moving メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Moving 全メンバ

Moving 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Moving クラス | Steema.TeeChart.Functions 名前空間


Moving コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Moving コンストラクタ

オーバーロードの一覧

public Moving()
public Moving(Steema.TeeChart.Chart)

参照

Moving クラス | Moving メンバ | Steema.TeeChart.Functions 名前空間


Moving コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Moving コンストラクタ

public Moving()

参照

Moving コンストラクタのオーバーロードの一覧 | Moving クラス | Moving メンバ | Steema.TeeChart.Functions 名前空間


Moving コンストラクタ

Steema.TeeChart.Functions.Moving コンストラクタ

public Moving(Chart c)

参照

Moving コンストラクタのオーバーロードの一覧 | Moving クラス | Moving メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Moving フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Moving クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Moving メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description (Functionの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Moving クラス | Steema.TeeChart.Functions 名前空間


DoCalculation

Steema.TeeChart.Functions.Moving.DoCalculation メソッド

protected abstract Void DoCalculation(Series source,
     ValueList notMandatorySource)

参照

Moving クラス | Moving メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Moving プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Moving クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MovingAverage

Steema.TeeChart.Functions.MovingAverage クラス

移動平均値関数。

この型のすべてのメンバの一覧については、MovingAverage メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class MovingAverage : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MovingAverage 全メンバ

MovingAverage 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Weighted | 該当するXポイント値を使用して移動平均値を計算するにはこのプロパティをtrueに設定してください。
WeightedIndex | 重みとしてソースポイントインデックスを使用して移動平均値を計算するにはこのプロパティをtrueに設定してください。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose (Functionの継承元)
DoCalculation
HideSeries (Functionの継承元)
PrepareSeries (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MovingAverage クラス | Steema.TeeChart.Functions 名前空間


MovingAverage コンストラクタ

Steema.TeeChart.Functions.MovingAverage コンストラクタ

オーバーロードの一覧

public MovingAverage()
public MovingAverage(Steema.TeeChart.Chart)

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


MovingAverage コンストラクタ

Steema.TeeChart.Functions.MovingAverage コンストラクタ

public MovingAverage()

参照

MovingAverage コンストラクタのオーバーロードの一覧 | MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


MovingAverage コンストラクタ

Steema.TeeChart.Functions.MovingAverage コンストラクタ

public MovingAverage(Chart c)

参照

MovingAverage コンストラクタのオーバーロードの一覧 | MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MovingAverage フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

MovingAverage クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MovingAverage メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
Dispose (Functionの継承元)
DoCalculation
HideSeries (Functionの継承元)
PrepareSeries (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

MovingAverage クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.MovingAverage.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series sourceSeries,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.MovingAverage.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


DoCalculation

Steema.TeeChart.Functions.MovingAverage.DoCalculation メソッド

protected abstract Void DoCalculation(Series source,
     ValueList notMandatorySource)

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.MovingAverage プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Weighted | 該当するXポイント値を使用して移動平均値を計算するにはこのプロパティをTrueに設定してください。
WeightedIndex | 重みとしてソースポイントインデックスを使用して移動平均値を計算するにはこのプロパティをTrueに設定してください。

参照

MovingAverage クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Weighted

Steema.TeeChart.Functions.MovingAverage.Weighted プロパティ

該当するXポイント値を使用して移動平均値を計算するにはこのプロパティをtrueに設定してください。
public Boolean Weighted {get; set;}

解説

デフォルト値：false

移動平均ポイントを該当するXポイント値を計算に使用するかどうか制御します。

false（デフォルト）の場合、Y値を加算してポイントの数で除算します。

trueの場合、各座標の(Y値)×(X値)の合計をすべてのXポイント数の合計で除算します。

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


WeightedIndex

Steema.TeeChart.Functions.MovingAverage.WeightedIndex プロパティ

重みとしてソースポイントインデックスを使用して移動平均値を計算するにはこのプロパティをtrueに設定してください。
public Boolean WeightedIndex {get; set;}

解説

重みとしてソースポイントインデックスを使用して移動平均値を計算するにはこのプロパティをtrueに設定してください。

これは、Weightedプロパティの使用とは異なります。

Weightedプロパティも参照してください。

参照

MovingAverage クラス | MovingAverage メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Multiply

Steema.TeeChart.Functions.Multiply クラス

積関数。

この型のすべてのメンバの一覧については、Multiply メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Multiply : ManySeries , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Multiply メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Multiply 全メンバ

Multiply 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Multiply クラス | Steema.TeeChart.Functions 名前空間


Multiply コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Multiply コンストラクタ

public Multiply()

参照

Multiply クラス | Multiply メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Multiply フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Multiply クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Multiply メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Multiply クラス | Steema.TeeChart.Functions 名前空間


CalculateValue

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Multiply.CalculateValue メソッド

protected virtual Double CalculateValue(Double result,
     Double value)

参照

Multiply クラス | Multiply メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Multiply.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Multiply クラス | Multiply メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Multiply プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Multiply クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.OBVFunction

Steema.TeeChart.Functions.OBVFunction クラス

OBV関数。

この型のすべてのメンバの一覧については、OBVFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class OBVFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

OBVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.OBVFunction 全メンバ

OBVFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Volume | OBV関数の結果を乗算するボリューム系列を取得/設定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

OBVFunction クラス | Steema.TeeChart.Functions 名前空間


OBVFunction コンストラクタ

Steema.TeeChart.Functions.OBVFunction コンストラクタ

オーバーロードの一覧

public OBVFunction()
public OBVFunction(Steema.TeeChart.Chart)

参照

OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


OBVFunction コンストラクタ

Steema.TeeChart.Functions.OBVFunction コンストラクタ

public OBVFunction()

参照

OBVFunction コンストラクタのオーバーロードの一覧 | OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


OBVFunction コンストラクタ

Steema.TeeChart.Functions.OBVFunction コンストラクタ

public OBVFunction(Chart c)

参照

OBVFunction コンストラクタのオーバーロードの一覧 | OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.OBVFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

OBVFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.OBVFunction メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

OBVFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.OBVFunction.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.OBVFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.OBVFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Volume | OBV関数の結果を乗算するボリューム系列を取得/設定します。

参照

OBVFunction クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Volume

Steema.TeeChart.Functions.OBVFunction.Volume プロパティ

OBV関数の結果を乗算するボリューム系列を取得/設定します。
public Series Volume {get; set;}

参照

OBVFunction クラス | OBVFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Performance

Steema.TeeChart.Functions.Performance クラス

パフォーマンス関数。

この型のすべてのメンバの一覧については、Performance メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Performance : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Performance メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Performance 全メンバ

Performance 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Performance クラス | Steema.TeeChart.Functions 名前空間


Performance コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Performance コンストラクタ

オーバーロードの一覧

public Performance()
public Performance(Steema.TeeChart.Chart)

参照

Performance クラス | Performance メンバ | Steema.TeeChart.Functions 名前空間


Performance コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Performance コンストラクタ

public Performance()

参照

Performance コンストラクタのオーバーロードの一覧 | Performance クラス | Performance メンバ | Steema.TeeChart.Functions 名前空間


Performance コンストラクタ

Steema.TeeChart.Functions.Performance コンストラクタ

public Performance(Chart c)

参照

Performance コンストラクタのオーバーロードの一覧 | Performance クラス | Performance メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Performance フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Performance クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Performance メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Performance クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Performance.Calculate メソッド

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Performance クラス | Performance メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Performance.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Performance クラス | Performance メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Performance プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Performance クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PerimeterFunction

Steema.TeeChart.Functions.PerimeterFunction クラス

境界関数。

この型のすべてのメンバの一覧については、PerimeterFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PerimeterFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PerimeterFunction 全メンバ

PerimeterFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PerimeterFunction クラス | Steema.TeeChart.Functions 名前空間


PerimeterFunction コンストラクタ

Steema.TeeChart.Functions.PerimeterFunction コンストラクタ

オーバーロードの一覧

public PerimeterFunction()
public PerimeterFunction(Steema.TeeChart.Chart)

参照

PerimeterFunction クラス | PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


PerimeterFunction コンストラクタ

Steema.TeeChart.Functions.PerimeterFunction コンストラクタ

public PerimeterFunction()

参照

PerimeterFunction コンストラクタのオーバーロードの一覧 | PerimeterFunction クラス | PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


PerimeterFunction コンストラクタ

Steema.TeeChart.Functions.PerimeterFunction コンストラクタ

public PerimeterFunction(Chart c)

参照

PerimeterFunction コンストラクタのオーバーロードの一覧 | PerimeterFunction クラス | PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PerimeterFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

PerimeterFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PerimeterFunction メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PerimeterFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.PerimeterFunction.AddPoints メソッド

public override Void AddPoints(Array source)

解説

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

PerimeterFunction クラス | PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.PerimeterFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

PerimeterFunction クラス | PerimeterFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PerimeterFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

PerimeterFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PeriodAligns

TeeChartプログラミングガイド

Steema.TeeChart.Functions.PeriodAligns 列挙体

ソース系列によってどのように関数を配置するか定義します。

[Serializable]
public enum PeriodAligns : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
First | 関数ピリオドの最初のポイントで関数を配置します。
Center | 関数ピリオドの中央のポイントで関数を配置します。
Last | 関数ピリオドの最後のポイントで関数を配置します。

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PeriodStyles

TeeChartプログラミングガイド

Steema.TeeChart.Functions.PeriodStyles 列挙体

関数のピリオドのスタイルを設定します。

[Serializable]
public enum PeriodStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
NumPoints | ポイント数で関数のピリオドを定義します。
Range | ポイントの範囲で関数のピリオドを定義します。

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Poly

Steema.TeeChart.Functions.Poly クラス

この型のすべてのメンバの一覧については、Poly メンバを参照してください。

System.Object
public class Poly : Object

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

Poly メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Poly 全メンバ

Poly 概要

コンストラクタ

Constructor

パブリック フィールド

maxDegree
PolyCoeff

パブリック メソッド

PolyEval | 多項式の指数とXの係数を使用して関数を計算します。
PolyFit | 多項式カーブフィッティングを計算します。

パブリック プロパティ

PolyDegree

参照

Poly クラス | Steema.TeeChart.Functions 名前空間


Poly コンストラクタ

Steema.TeeChart.Functions.Poly コンストラクタ

public Poly()

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Poly フィールド

パブリック フィールド

maxDegree
PolyCoeff

参照

Poly クラス | Steema.TeeChart.Functions 名前空間


maxDegree

Steema.TeeChart.Functions.Poly.maxDegree フィールド

public Int32 maxDegree

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


PolyCoeff

Steema.TeeChart.Functions.Poly.PolyCoeff フィールド

public Double[] PolyCoeff

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Poly メソッド

パブリック メソッド

PolyEval | 多項式の指数とXの係数を使用して関数を計算します。
PolyFit | 多項式カーブフィッティングを計算します。

参照

Poly クラス | Steema.TeeChart.Functions 名前空間


PolyEval

Steema.TeeChart.Functions.Poly.PolyEval メソッド

多項式の指数とXの係数を使用して関数を計算します。

public Double PolyEval(Double x)

解説

多項式の指数とXの係数を使用して関数を計算します。

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


PolyFit

Steema.TeeChart.Functions.Poly.PolyFit メソッド

多項式カーブフィッティングを計算します。

public Void PolyFit(Int32 numPoints,
     Double[] x,
     Double[] y)

パラメーター

numPoints
フィットさせるポイントの数
x
Xの値
y
Yの値

解説

ガウスアルゴリズムを使用して、指定したポイントの範囲に多項式の指数を適用します。ポイントはXやY配列に保持されます。

このアルゴリズムは、XやY配列の大きさとNumPointsパラメーターが同じであると判断します。
その結果（適用した多項式の係数）は、Steema.TeeChart.Functions.Poly.PolyCoeff配列に返されます。

Steema.TeeChart.Functions.Poly.PolyCoeff配列の大きさは自動的に調整されます。

Steema.TeeChart.Functions.Poly.PolyCoeff係数を取得するサンプルについては、TeeChartのFeaturesデモ（「全ての機能」タブの「ようこそ !」→「関数」→「拡張」→「多項式カーブフィッティング」→「係数の検出」）を参照してください。

多項式カーブフィッティング関数に渡せるポイントの最大数は32600です。

指数の最大数はおよそ20です（CPUによって異なります）。

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Poly プロパティ

パブリック プロパティ

PolyDegree

参照

Poly クラス | Steema.TeeChart.Functions 名前空間


PolyDegree

Steema.TeeChart.Functions.Poly.PolyDegree プロパティ

public Int32 PolyDegree {get; set;}

参照

Poly クラス | Poly メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PolyFitting

Steema.TeeChart.Functions.PolyFitting クラス

フィッティング関数の基本クラス。

この型のすべてのメンバの一覧については、PolyFitting メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PolyFitting : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PolyFitting 全メンバ

PolyFitting 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Coefficient | 計算されたぴったりの係数を返します。
Description |
GetCurveYValue | 係数を使用して関数を計算します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Factor |
FirstCalcPoint |
FirstPoint |
LastCalcPoint |
LastPoint |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
PolyDegree |
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PolyFitting クラス | Steema.TeeChart.Functions 名前空間


PolyFitting コンストラクタ

Steema.TeeChart.Functions.PolyFitting コンストラクタ

オーバーロードの一覧

public PolyFitting()
public PolyFitting(Steema.TeeChart.Chart)

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Polyfitting コンストラクタ

Steema.TeeChart.Functions.PolyFitting コンストラクタ

public PolyFitting()

参照

PolyFitting コンストラクタのオーバーロードの一覧 | PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Polyfitting コンストラクタ

Steema.TeeChart.Functions.PolyFitting コンストラクタ

public PolyFitting(Chart c)

参照

PolyFitting コンストラクタのオーバーロードの一覧 | PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PolyFitting フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

PolyFitting クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PolyFitting メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Coefficient | 計算されたぴったりの係数を返します。
Description |
GetCurveYValue | 係数を使用して関数を計算します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PolyFitting クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.PolyFitting.AddPoints メソッド

public override Void AddPoints(Array source)

解説

ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Coefficient

Steema.TeeChart.Functions.PolyFitting.Coefficient メソッド

計算されたぴったりの係数を返します。

public Double Coefficient(Int32 index)

解説

計算されたぴったりの係数を返します。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.PolyFitting.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


GetCurveYValue

Steema.TeeChart.Functions.PolyFitting.GetCurveYValue メソッド

係数を使用して関数を計算します。

public Double GetCurveYValue(Series s,
     Double x)

パラメーター

s
値を含む系列
x
評価する値

戻り値

計算された多項式係数を使用するy(x)

解説

X値パラメーターに一致するY値を返します。

Y値を計算するために内部のカーブフィッティング多項式を使用します。

このメソッドは、系列を描画した後に呼び出すことができます。

内部の多項式係数は、系列が描画される直前に計算されます。

TCurveFittingFunctionは、各データソース系列のポイントに対して1ポイント描画します。

各Xポイント座標に一致する正確なY値を計算するために、GetCurveYValueメソッドを内部的に呼び出します。

X値とY値は、関連付けられた軸スケール単位で表されます。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PolyFitting プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Factor |
FirstCalcPoint |
FirstPoint |
LastCalcPoint |
LastPoint |
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
PolyDegree |
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

PolyFitting クラス | Steema.TeeChart.Functions 名前空間


Factor

Steema.TeeChart.Functions.PolyFitting.Factor プロパティ

public Int32 Factor {get; set;}

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


FirstCalcPoint

Steema.TeeChart.Functions.PolyFitting.FirstCalcPoint プロパティ

public Int32 FirstCalcPoint {get; set;}

解説

多項式の係数計算に使用される最初のポイントを定義します。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


FirstPoint

Steema.TeeChart.Functions.PolyFitting.FirstPoint プロパティ

public Int32 FirstPoint {get; set;}

解説

デフォルト値：-1

FirstPointプロパティとLastPointプロパティを使用して、多項式の係数とポイント値の計算に使用されるポイントのサブセットを限定できます。

デフォルトは、すべてのデータソースのポイントを使用して計算します。

FirstPointプロパティと LastPointプロパティを設定した後に、すべてのポイント値を再計算させるCheckDataSourceメソッドを呼び出さなければなりません。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


LastCalcPoint

Steema.TeeChart.Functions.PolyFitting.LastCalcPoint プロパティ

public Int32 LastCalcPoint {get; set;}

解説

多項式の係数計算に使用される最後のポイントを定義します。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


LastPoint

Steema.TeeChart.Functions.PolyFitting.LastPoint プロパティ

public Int32 LastPoint {get; set;}

解説

デフォルト値：-1

FirstPointプロパティとLastPointプロパティを使用して、多項式の係数とポイント値の計算に使用されるポイントのサブセットを限定できます。

デフォルトは、すべてのデータソースのポイントを使用して計算します。

FirstPointプロパティと LastPointプロパティを設定した後に、すべてのポイント値を再計算させるCheckDataSourceメソッドを呼び出さなければなりません。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


PolyDegree

Steema.TeeChart.Functions.PolyFitting.PolyDegree プロパティ

public Int32 PolyDegree {get; set;}

解説

多項式に含まれている指数を取得/設定します。

警告：

より多くの指数で、より多くの調整が実現できますが、10以上の値は処理が遅くなります。

参照

PolyFitting クラス | PolyFitting メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PVOFunction

Steema.TeeChart.Functions.PVOFunction クラス

PVO関数。

この型のすべてのメンバの一覧については、PVOFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class PVOFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PVOFunction 全メンバ

PVOFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Percentage | 2つの移動平均値の差をパーセント率にするかどうかを制御します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period2 | 2番目の指数移動平均値のピリオドを定義します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PVOFunction クラス | Steema.TeeChart.Functions 名前空間


PVOFunction コンストラクタ

Steema.TeeChart.Functions.PVOFunction コンストラクタ

オーバーロードの一覧

public PVOFunction()
public PVOFunction(Steema.TeeChart.Chart)

参照

PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


PVOFunction コンストラクタ

Steema.TeeChart.Functions.PVOFunction コンストラクタ

public PVOFunction()

参照

PVOFunction コンストラクタのオーバーロードの一覧 | PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


PVOFunction コンストラクタ

Steema.TeeChart.Functions.PVOFunction コンストラクタ

public PVOFunction(Chart c)

参照

PVOFunction コンストラクタのオーバーロードの一覧 | PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PVOFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

PVOFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PVOFunction メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

PVOFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.PVOFunction.AddPoints メソッド

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
public override Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。

参照

PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.PVOFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.PVOFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Percentage | 2つの移動平均値の差をパーセント率にするかどうかを制御します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
Period2 | 2番目の指数移動平均値のピリオドを定義します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

PVOFunction クラス | Steema.TeeChart.Functions 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Percentage

Steema.TeeChart.Functions.PVOFunction.Percentage プロパティ

2つの移動平均値の差をパーセント率にするかどうかを制御します。
public Boolean Percentage {get; set;}

解説

デフォルト値：true

2つの移動平均値の差をパーセント率にするかどうかを制御します。

参照

PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Period2

Steema.TeeChart.Functions.PVOFunction.Period2 プロパティ

2番目の指数移動平均値のピリオドを定義します。
public Int32 Period2 {get; set;}

解説

デフォルト値：26

2番目の指数移動平均値のピリオドを定義します。

最初の平均値のピリオドを設定するには、Periodプロパティを使用してください。

参照

PVOFunction クラス | PVOFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Regression

Steema.TeeChart.Functions.Regression クラス

この型のすべてのメンバの一覧については、Regression メンバを参照してください。

System.Object
public class Regression : Object

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Regression メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Regression 全メンバ

Regression 概要

コンストラクタ

Constructor

パブリック メソッド

LinearRegression 重み付けあり/なしの一般的な最小二乗法の線形回帰。

参照

Regression クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Regression コンストラクタ

public Regression()

参照

Regression クラス | Regression メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Regression メソッド

パブリック メソッド

LinearRegression 重み付けあり/なしの一般的な最小二乗法の線形回帰。

参照

Regression クラス | Steema.TeeChart.Functions 名前空間


LinearRegression

Steema.TeeChart.Functions.Regression.LinearRegression メソッド

重み付けあり/なしの一般的な最小二乗法の線形回帰。
public static Void LinearRegression(Int32 numpoints,
     Double[] x,
     Double[] y,
     Double[] weights,
     Double[]& coeffs)

パラメーター

numpoints
x配列内のポイント数。
x
x値の配列。xとyの大きさは同じでなければなりません。
y
y値の配列。xとyの大きさは同じでなければなりません。
weights
ポイントの重み付け。null の場合、線形回帰に重み付けが使用されます。
coeffs
線形回帰の係数を返します。

参照

Regression クラス | Regression メンバ | Steema.TeeChart.Functions 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.RootMeanSquare

Steema.TeeChart.Functions.RootMeanSquare クラス

誤差の２乗関数。

この型のすべてのメンバの一覧については、RootMeanSquare メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class RootMeanSquare : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RootMeanSquare 全メンバ

RootMeanSquare 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Complete | RMS式を定義します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

RootMeanSquare クラス | Steema.TeeChart.Functions 名前空間


RootMeanSquare コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.RootMeanSquare コンストラクタ

オーバーロードの一覧

public RootMeanSquare()
public RootMeanSquare(Steema.TeeChart.Chart)

参照

RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


RootMeanSquare コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.RootMeanSquare コンストラクタ

public RootMeanSquare()

参照

RootMeanSquare コンストラクタのオーバーロードの一覧 | RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


RootMeanSquare コンストラクタ

Steema.TeeChart.Functions.RootMeanSquare コンストラクタ

public RootMeanSquare(Chart c)

参照

RootMeanSquare コンストラクタのオーバーロードの一覧 | RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RootMeanSquare フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

RootMeanSquare クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RootMeanSquare メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

RootMeanSquare クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.RootMeanSquare.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.RootMeanSquare.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して誤差の2乗関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して誤差の2乗関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.RootMeanSquare.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RootMeanSquare プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Complete | RMS式を定義します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

RootMeanSquare クラス | Steema.TeeChart.Functions 名前空間


Complete

TeeChartプログラミングガイド

Steema.TeeChart.Functions.RootMeanSquare.Complete プロパティ

RMS式を定義します。

public Boolean Complete {get; set;}

解説

RMS 定式を定義します。

RMS = Sqrt(Sum(Sqr(x[i]))/NumPoints) ... Complete = true
RMS = Sqrt(Sum(Sqr(x[i]))/(NumPoints-1)) ... Complete = false

参照

RootMeanSquare クラス | RootMeanSquare メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIFunction

Steema.TeeChart.Functions.RSIFunction クラス

RSI関数は、金融データに基づいてパーセントの値を計算するリボン系列の派生コンポーネントです。RSI関数は、OHLC系列または任意のSeries派生コンポーネント（例：キャンドル系列）と接続されていなければなりません。移動平均値関数のように、RSIは前回のPeriodのポイントを使用して新しいポイント値Yを計算します。 式は次のようになります。 Upの場合：始値より大きいすべての終値を足して、足した回数で割る。 Downの場合：始値より低いすべての終値を足して、足した回数で割る。 RSI = 100.0 - ( 100.0 / ( 1.0 + Math.Abs( Ups / Downs ) ) )

この型のすべてのメンバの一覧については、RSIFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class RSIFunction : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIFunction 全メンバ

RSIFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Style | RSI関数に始値と終値のどちらを使用するかを設定します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

RSIFunction クラス | Steema.TeeChart.Functions 名前空間


RSIFunction コンストラクタ

Steema.TeeChart.Functions.RSIFunction コンストラクタ

オーバーロードの一覧

public RSIFunction()
public RSIFunction(Steema.TeeChart.Chart)

参照

RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


RSIFunction コンストラクタ

Steema.TeeChart.Functions.RSIFunction コンストラクタ

public RSIFunction()

参照

RSIFunction コンストラクタのオーバーロードの一覧 | RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


RSIFunction コンストラクタ

Steema.TeeChart.Functions.RSIFunction コンストラクタ

public RSIFunction(Chart c)

参照

RSIFunction コンストラクタのオーバーロードの一覧 | RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

RSIFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate |
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

RSIFunction クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.RSIFunction.Calculate メソッド

public override Double Calculate(Series source,
     Int32 first,
     Int32 last)

解説

ソース系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.RSIFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
Style | RSI関数に始値と終値のどちらを使用するかを設定します。

参照

RSIFunction クラス | Steema.TeeChart.Functions 名前空間


Style

Steema.TeeChart.Functions.RSIFunction.Style プロパティ

RSI関数に始値と終値のどちらを使用するかを設定します。

public RSIStyle Style {get; set;}

解説

RSI関数に始値と終値のどちらを使用するかを設定します。

参照

RSIFunction クラス | RSIFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.RSIStyle

Steema.TeeChart.Functions.RSIStyle 列挙体

Styleプロパティで使用されます。

[Serializable]
public sealed enum RSIStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
OpenClose | 各始値と比較した終値を使用します。
Close | 前日の終値と比較した終値を使用します。

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction

Steema.TeeChart.Functions.SARFunction クラス

パラボリックSAR（ストップ・アンド・リバース）指標。

この型のすべてのメンバの一覧については、SARFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class SARFunction : Function , IComponent, IDisposable

解説

Welles Wilder氏によって開発されたパラボリックSARは価格凍結の跡をたどるための設定に使用します。SARはストップ・アンド・リバース（Stop And Reversal）の略です。これはロングポジション（買い）とショートポジション（売り）に対して退去ポイントを作成するよう設計されています。ポジションの最初の段階で反動または変動を考慮しますが、変動が頂点に達すると（ロングポジションの場合は）上向きに、（ショートポジションの場合は）下向きに加速します。

パラボリックSARは移動平均と同様に価格チャートのあちこちに描画されます。SAR値を計算する式の基礎は上述した通りです。

パラボリックSARは優れた退去ポイントを提供します。価格が SARを下回ったときにロングポジションを打ち切り、価格がSARを上回ったときにはショートポジションを打ち切ってください。

ロング（つまり価格が SARを上回った）の場合、SARは価格変動の向きに関係なく毎日上昇します。SAR量は価格変動量に応じて上昇します。Wilder氏はトレンド（または指向）市場でこの指標の使用をお勧めしています。安全性が上昇傾向の場合は、ロングポジション（買い）のみを取り、下降傾向の場合はショートポジション（売り）を取ってください。

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

SARFunction メンバ | Steema.TeeChart.Functions 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Functions.SARFunction 全メンバ

SARFunction 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

AccelerationFactor | Wilder氏が考案した加速係数を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
MaxStep | SAR計算における最大ステップを定義します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

SARFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction コンストラクタ

オーバーロードの一覧

public SARFunction()
public SARFunction(Steema.TeeChart.Chart)

参照

SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction コンストラクタ

public SARFunction()

参照

SARFunction コンストラクタのオーバーロードの一覧 | SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction コンストラクタ

public SARFunction(Chart c)

参照

SARFunction コンストラクタのオーバーロードの一覧 | SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

参照

SARFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction メソッド

パブリック メソッド

AddPoints |
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

SARFunction クラス | Steema.TeeChart.Functions 名前空間


AddPoints

Steema.TeeChart.Functions.SARFunction.AddPoints メソッド

public override Void AddPoints(Array source)

参照

SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.SARFunction.Description メソッド

public override String Description()

参照

SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.SARFunction プロパティ

パブリック プロパティ

AccelerationFactor | Wilder氏が考案した加速係数を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
MaxStep | SAR計算における最大ステップを定義します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

SARFunction クラス | Steema.TeeChart.Functions 名前空間


AccelerationFactor

Steema.TeeChart.Functions.SARFunction.AccelerationFactor プロパティ

Wilder氏が考案した加速係数を定義します。
public Double AccelerationFactor {get; set;}

参照

SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


MaxStep

Steema.TeeChart.Functions.SARFunction.MaxStep プロパティ

SAR計算における最大ステップを定義します。
public Double MaxStep {get; set;}

参照

SARFunction クラス | SARFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Smoothing

Steema.TeeChart.Functions.Smoothing クラス

スムーズ関数。

この型のすべてのメンバの一覧については、Smoothing メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class Smoothing : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Smoothing 全メンバ

Smoothing 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Factor | スムーズポイントを描画するためのソースポイントに対する倍数を取得/設定します。
Interpolate | trueの場合、スムーズカーブは、必ずソースポイントの上部を通るように描画します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Smoothing クラス | Steema.TeeChart.Functions 名前空間


Smoothing コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Smoothing コンストラクタ

オーバーロードの一覧

public Smoothing()
public Smoothing(Steema.TeeChart.Chart)

参照

Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Smoothing コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Smoothing コンストラクタ

public Smoothing()

参照

Smoothing コンストラクタのオーバーロードの一覧 | Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Smoothing コンストラクタ

Steema.TeeChart.Functions.Smoothing コンストラクタ

public Smoothing(Chart c)

参照

Smoothing コンストラクタのオーバーロードの一覧 | Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Smoothing フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Smoothing クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Smoothing メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Smoothing クラス | Steema.TeeChart.Functions 名前空間


AddPoints

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Smoothing.AddPoints メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
Source系列からすべてのポイントを取得し、スムーズ関数を実行して結果を親系列に記憶させます。

public virtual Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、スムーズ関数を実行して結果を親系列に記憶させます。

参照

Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Smoothing.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Smoothing プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Factor | スムーズポイントを描画するためのソースポイントに対する倍数を取得/設定します。
Interpolate | trueの場合、スムーズカーブは、必ずソースポイントの上部を通るように描画します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Smoothing クラス | Steema.TeeChart.Functions 名前空間


Factor

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Smoothing.Factor プロパティ

スムーズポイントを描画するためのソースポイントに対する倍数を取得/設定します。

public Int32 Factor {get; set;}

解説

デフォルト値：4

スムーズポイントを描画するためのソースポイントに対する倍数を取得/設定します。

たとえば、4の値はスムーズポイントがソースポイント数の4倍になります。

より大きい値を設定するとスムーズポイントは、よりスムーズな結果を表示します。

参照

Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Interpolate

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Smoothing.Interpolate プロパティ

trueの場合、スムーズカーブは、必ずソースポイントの上部を通るように描画します。

public Boolean Interpolate {get; set;}

解説

デフォルト値：false

trueの場合、スムーズカーブは、必ずソースポイントの上部を通るように描画します。

falseの場合、スムーズカーブは、必ずしもソースポイントの上部を通るとは限りません。

参照

Smoothing クラス | Smoothing メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Spline

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline クラス

スプラインスムージング。

この型のすべてのメンバの一覧については、Spline メンバを参照してください。

System.Object
public class Spline : Object

必要条件

名前空間： Steema.TeeChart.Functions

アセンブリ：TeeChart.dll

参照

Spline メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Spline 全メンバ

Spline 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoint | 指定したXとYの値で新しいソースポイントを追加します。
Clear | すべてのソースポイントを削除します。
Rebuild | 内部のポイントリストから新しい滑らかにしたポイントを計算します。
SetKnuckle |
Value | 改ざんされたポイントを返します。

パブリック プロパティ

Build | スプラインが既にスムースポイントを計算したことを示します。
Fragments | スムースポイントの数を取得/設定します。
Interpolated | trueの場合、スプラインカーブは、必ずソースポイントの上部を通るように描画します。
Item |
NumberOfVertices | ソースポイントの数を返します。

参照

Spline クラス | Steema.TeeChart.Functions 名前空間


Spline コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline コンストラクタ

public Spline()

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Spline メソッド

パブリック メソッド

AddPoint | 指定したXとYの値で新しいソースポイントを追加します。
Clear | すべてのソースポイントを削除します。
Rebuild | 内部のポイントリストから新しい滑らかにしたポイントを計算します。
SetKnuckle |
Value | 改ざんされたポイントを返します。

参照

Spline クラス | Steema.TeeChart.Functions 名前空間


AddPoint

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.AddPoint メソッド

指定したXとYの値で新しいソースポイントを追加します。

public Void AddPoint(Double X,
     Double Y)

解説

指定したXとYの値で新しいソースポイントを追加します。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Clear メソッド

すべてのソースポイントを削除します。

public Void Clear()

解説

すべてのソースポイントを削除します。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Rebuild

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Rebuild メソッド

内部のポイントリストから新しい滑らかにしたポイントを計算します。

public Void Rebuild()

解説

内部のポイントリストから新しい滑らかにしたポイントを計算します。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


SetKnuckle

Steema.TeeChart.Functions.Spline.SetKnuckle メソッド

public Void SetKnuckle(Int32 index,
     Boolean value)

解説

Indexのソースポイントをコントロールポイントに作成します。
デフォルトでは、TSmoothingFunctionはいかなるソースポイントもコントロールポイントとして設定しません。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Value メソッド

改ざんされたポイントを返します。

public PointF Value(Double Parameter)

解説

改ざんされたポイントを返します。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Spline プロパティ

パブリック プロパティ

Build | スプラインが既にスムースポイントを計算したことを示します。
Fragments | スムースポイントの数を取得/設定します。
Interpolated | trueの場合、スプラインカーブは、必ずソースポイントの上部を通るように描画します。
Item |
NumberOfVertices | ソースポイントの数を返します。

参照

Spline クラス | Steema.TeeChart.Functions 名前空間


Build

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Build プロパティ

スプラインが既にスムースポイントを計算したことを示します。

public Boolean Build {get; set;}

解説

スプラインが既にスムースポイントを計算したことを示します。

スプラインにスムースポイントを再構築させるためには、このプロパティをfalseに設定してください。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Fragments

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Fragments プロパティ

スムースポイントの数を取得/設定します。

public Int32 Fragments {get; set;}

解説

スムースポイントの数を取得/設定します。
ソースポイントの積でなければなりません。

例

:
[C#]

BSpline1.Fragments = BSpline1.Count * 4 ;

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Interpolated

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Interpolated プロパティ

trueの場合、スプラインカーブは、必ずソースポイントの上部を通るように描画します。

public Boolean Interpolated {get; set;}

解説

デフォルト値：false

trueの場合、スプラインカーブは、必ずソースポイントの上部を通るように描画します。
falseの場合、スプラインカーブは、必ずしもソースポイントの上部を通るとは限りません。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.Item プロパティ

public PointF Item(Int32 index) {get; set;}

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


NumberOfVertices

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Spline.NumberOfVertices プロパティ

ソースポイントの数を返します。

public Int32 NumberOfVertices {get;}

解説

ソースポイントの数を返します。

コントロールポイント（SetKnuckle(index, true)）が存在する場合、交点の数は2つ増加されます。

参照

Spline クラス | Spline メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.StdDeviation

Steema.TeeChart.Functions.StdDeviation クラス

標準偏差関数。

この型のすべてのメンバの一覧については、StdDeviation メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class StdDeviation : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.StdDeviation 全メンバ

StdDeviation 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Complete |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

StdDeviation クラス | Steema.TeeChart.Functions 名前空間


StdDeviation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.StdDeviation コンストラクタ

オーバーロードの一覧

public StdDeviation()
public StdDeviation(Steema.TeeChart.Chart)

参照

StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


StdDeviation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.StdDeviation コンストラクタ

public StdDeviation()

参照

StdDeviation コンストラクタのオーバーロードの一覧 | StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


StdDeviation コンストラクタ

Steema.TeeChart.Functions.StdDeviation コンストラクタ

public StdDeviation(Chart c)

参照

StdDeviation コンストラクタのオーバーロードの一覧 | StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.StdDeviation フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

StdDeviation クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.StdDeviation メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

StdDeviation クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.StdDeviation.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

TeeChartプログラミングガイド

Steema.TeeChart.Functions.StdDeviation.CalculateMany メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
系列のリスト（SourceSeriesList）に対して標準偏差関数を実行します。

public virtual Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

解説

系列のリスト（SourceSeriesList）に対して標準偏差関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

SourceSeriesのリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.StdDeviation.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.StdDeviation プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Complete |
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

StdDeviation クラス | Steema.TeeChart.Functions 名前空間


Complete

Steema.TeeChart.Functions.StdDeviation.Complete プロパティ

public Boolean Complete {get; set;}

解説

ソース系列の標準偏差を有効にします。

参照

StdDeviation クラス | StdDeviation メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Stochastic

Steema.TeeChart.Functions.Stochastic クラス

確率関数。

この型のすべてのメンバの一覧については、Stochastic メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.Moving
public class Stochastic : Moving , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Stochastic 全メンバ

Stochastic 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Stochastic クラス | Steema.TeeChart.Functions 名前空間


Stochastic コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Stochastic コンストラクタ

オーバーロードの一覧

public Stochastic()
public Stochastic(Steema.TeeChart.Chart)

参照

Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Stochastic コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Stochastic コンストラクタ

public Stochastic()

参照

Stochastic コンストラクタのオーバーロードの一覧 | Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Stochastic コンストラクタ

Steema.TeeChart.Functions.Stochastic コンストラクタ

public Stochastic(Chart c)

参照

Stochastic コンストラクタのオーバーロードの一覧 | Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Stochastic フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Stochastic クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Stochastic メソッド

パブリック メソッド

AddPoints | Source系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 指定したソース系列に対して関数を実行します。
CalculateMany (Functionの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Movingの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Stochastic クラス | Steema.TeeChart.Functions 名前空間


AddPoints

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Stochastic.AddPoints メソッド

このメソッドは内部で使用されるため、直接呼び出す必要はありません。
Source系列からすべてのポイントを取得し、確率関数を実行して結果を親系列に記憶させます。

public virtual Void AddPoints(Array source)

解説

Source系列からすべてのポイントを取得し、確率関数を実行して結果を親系列に記憶させます。

参照

Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.Stochastic.Calculate メソッド

SourceSeries系列に対して関数を実行します。
public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

SourceSeries系列に対して関数を実行します。firstとlastパラメーターは、計算に使用する最初と最後のポイントのValueIndexになります。

1つのSourceSeriesにカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Stochastic.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Stochastic クラス | Stochastic メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Stochastic プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Stochastic クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Subtract

Steema.TeeChart.Functions.Subtract クラス

差分関数。

この型のすべてのメンバの一覧については、Subtract メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.ManySeries
public class Subtract : ManySeries , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ: TeeChart.dll

参照

Subtract メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Subtract 全メンバ

Subtract 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Subtract クラス | Steema.TeeChart.Functions 名前空間


Subtract コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Subtract コンストラクタ

public Subtract()

参照

Subtract クラス | Subtract メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Subtract フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

Subtract クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Subtract メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (Functionの継承元) | 指定したソース系列に対して関数を実行します。
CalculateMany (ManySeriesの継承元) | 系列のリスト（SourceSeriesList）に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
CalculateValue
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

Subtract クラス | Steema.TeeChart.Functions 名前空間


CalculateValue

TeeChartプログラミングガイド

Steema.TeeChart.Functions.Subtract.CalculateValue メソッド

protected virtual Double CalculateValue(Double result,
     Double value)

参照

Subtract クラス | Subtract メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.Subtract.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

Subtract クラス | Subtract メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.Subtract プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

Subtract クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendFunction

Steema.TeeChart.Functions.TrendFunction クラス

トレンド関数。

この型のすべてのメンバの一覧については、TrendFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
Steema.TeeChart.Functions.BaseTrend
public class TrendFunction : BaseTrend , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

TrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendFunction 全メンバ

TrendFunction 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (BaseTrendの継承元) |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod (BaseTrendの継承元) |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

TrendFunction クラス | Steema.TeeChart.Functions 名前空間


TrendFunction コンストラクタ

Steema.TeeChart.Functions.TrendFunction コンストラクタ

public TrendFunction()

参照

TrendFunction クラス | TrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
iTrendStyle (BaseTrendの継承元)
updating (Functionの継承元)

参照

TrendFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate (BaseTrendの継承元) |
CalculateMany (BaseTrendの継承元) |
CalculateTrend (BaseTrendの継承元) | 式：y=m*x+bのトレンドラインのパラメーターのmとbを計算します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元) |
CalculateAllPoints (BaseTrendの継承元) |
CalculateByPeriod (Functionの継承元) |
CalculatePeriod (BaseTrendの継承元) |
Coefficient (BaseTrendの継承元) | FirstIndexからLastIndexまでのソース系列のポイント値の相関係数を返します。
DoCalculation (Functionの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |
ValueList (Functionの継承元) |

参照

TrendFunction クラス | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.TrendFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

TrendFunction クラス | TrendFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。
TrendStyle (BaseTrendの継承元) | トレンドラインを計算するさまざまな方法を定義します。

参照

TrendFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.TrendStyles

Steema.TeeChart.Functions.TrendStyles 列挙体

トレンドのスタイルを定義します。

[Serializable]
public sealed enum TrendStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Normal | 標準
Logarithmic | 対数
Exponential | 指数

参照

Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.VarianceFunction

Steema.TeeChart.Functions.VarianceFunction クラス

分散関数。

この型のすべてのメンバの一覧については、VarianceFunction メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Functions.Function
public class VarianceFunction : Function , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Functions 名前空間

アセンブリ：TeeChart.dll

参照

VarianceFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.VarianceFunction 全メンバ

VarianceFunction 概要

コンストラクタ

Constructor

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 系列「s」パラメータに対して関数を実行します。
CalculateMany | すべてのソース系列に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | いくつのポイントあるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
updating (Functionの継承元)

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

VarianceFunction クラス | Steema.TeeChart.Functions 名前空間


VarianceFunction コンストラクタ

Steema.TeeChart.Functions.VarianceFunction コンストラクタ

public VarianceFunction()

参照

VarianceFunction クラス | VarianceFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.VarianceFunction フィールド

プロテクト フィールド

CanUsePeriod (Functionの継承元)
dPeriod (Functionの継承元)
InternalUse (TeeBaseの継承元)
updating (Functionの継承元)

参照

VarianceFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.VarianceFunction メソッド

パブリック メソッド

AddPoints (Functionの継承元) | ソース系列からすべてのポイントを取得し、関数を実行して結果を親系列に記憶させます。
Calculate | 系列「s」パラメータに対して関数を実行します。
CalculateMany | すべてのソース系列に対して関数を実行します。
Clear (Functionの継承元) |
Description |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Recalculate (Functionの継承元) | 親系列にCheckDataSourceメソッドを実行します。

プロテクト メソッド

AddFunctionXY (Functionの継承元)
CalculateAllPoints (Functionの継承元)
CalculateByPeriod (Functionの継承元)
CalculatePeriod (Functionの継承元)
DoCalculation (Functionの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ValueList (Functionの継承元)

参照

VarianceFunction クラス | Steema.TeeChart.Functions 名前空間


Calculate

Steema.TeeChart.Functions.VarianceFunction.Calculate メソッド

系列「s」パラメータに対して関数を実行します。

public override Double Calculate(Series s,
     Int32 firstIndex,
     Int32 lastIndex)

解説

ソース系列に対して関数を実行します。firstIndexとlastIndexパラメーターは計算に使用する最初と最後のポイントのValueIndexになります。

1つのソース系列にカスタマイズした計算を実行するためにCalculate関数をオーバーライドすることができます。

参照

VarianceFunction クラス | VarianceFunction メンバ | Steema.TeeChart.Functions 名前空間


CalculateMany

Steema.TeeChart.Functions.VarianceFunction.CalculateMany メソッド

すべてのソース系列に対して関数を実行します。

public override Double CalculateMany(ArrayList sourceSeries,
     Int32 valueIndex)

解説

系列リスト（SourceSeriesList）に対して関数を実行します。ValueIndexパラメーターは、リスト内の各系列のポイントのValueIndexを定義します。

ソース系列のリストに対してカスタマイズした計算を実行するためにCalculateMany関数をオーバーライドすることができます。

参照

VarianceFunction クラス | VarianceFunction メンバ | Steema.TeeChart.Functions 名前空間


Description

Steema.TeeChart.Functions.VarianceFunction.Description メソッド

public override String Description()

解説

説明テキストを取得します。

参照

VarianceFunction クラス | VarianceFunction メンバ | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Functions.VarianceFunction プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Period (Functionの継承元) | ポイントの数あるいはX範囲で、新しいポイントの計算を実行させるかを制御します。
PeriodAlign (Functionの継承元) | ソース系列のポイントのために確保されたスペース内で、どこに関数ポイントを配置するかを設定します。
PeriodStyle (Functionの継承元) | Periodプロパティのスタイルを設定します。
Series (Functionの継承元) | TTeeFunctionの親のTChartSeriesを返します。

参照

VarianceFunction クラス | Steema.TeeChart.Functions 名前空間


Steema.TeeChart.Import

Steema.TeeChart.Import 名前空間

名前空間の階層構造

パブリック クラス

Imports | このクラスは、チャートのインポートの基本的な機能を保持します。
ThemeImport | テーマのxmlファイルインポート
TemplateImport | チャートのテンプレート、ネイティブ形式のインポート。

必要条件

名前空間: Steema.TeeChart.Import 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Import 階層構造

System.Object

Steema.TeeChart.Import.Imports

Steema.TeeChart.Import.TemplateImport

Steema.TeeChart.Import.ThemeImport

参照

SteemaTeeChartImport 名前空間


Steema.TeeChart.Import.Imports

TeeChartプログラミングガイド

Steema.TeeChart.Import.Imports クラス

このクラスは、チャートのインポートの基本的な機能を保持します。

この型のすべてのメンバの一覧については、Imports メンバを参照してください。

System.Object
public class Imports : Object

必要条件

名前空間： Steema.TeeChart.Import

アセンブリ：TeeChart.dll

参照

Imports メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports 全メンバ

Imports 概要

コンストラクタ

Constructor オーバーロード。デフォルトのコンストラクタ。

パブリック メソッド

DecodeBase64 |
DeserializeFrom | TeeChartの内部使用。仮想デシリアライズメソッド。
InternalLoadViewState | 内部使用。保存したチャートをロードします。
ShowImportDialog | インポートダイアログを表示します。

パブリック プロパティ

Template | テンプレートのインポートにアクセスします。
Theme | テーマのインポートにアクセスします。

プロテクト フィールド

chart

参照

Imports クラス | Steema.TeeChart.Import 名前空間


Imports コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Import.Imports コンストラクタ

オーバーロードの一覧

デフォルトのコンストラクタ。

public Imports()

チャートのインポートのためのコンストラクタ。

public Imports(Steema.TeeChart.Chart)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Imports コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Import.Imports コンストラクタ

デフォルトのコンストラクタ。

public Imports()

参照

Imports コンストラクタのオーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Imports コンストラクタ

Steema.TeeChart.Import.Imports コンストラクタ

チャートのインポートのためのコンストラクタ。
public Imports(Chart c)

参照

Imports コンストラクタのオーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports フィールド

プロテクト フィールド

chart

参照

Imports クラス | Steema.TeeChart.Import 名前空間


chart

Steema.TeeChart.Import.Imports.chart フィールド

protected Chart chart

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports メソッド

パブリック メソッド

DecodeBase64 |
DeserializeFrom | TeeChartの内部使用。仮想デシリアライズメソッド。
InternalLoadViewState | 内部使用。保存したチャートをロードします。
ShowImportDialog | インポートダイアログを表示します。

参照

Imports クラス | Steema.TeeChart.Import 名前空間


DecodeBase64

Steema.TeeChart.Import.Imports.DecodeBase64 メソッド

public MemoryStream DecodeBase64(String base64String)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


DeserializeFrom

Steema.TeeChart.Import.Imports.DeserializeFrom メソッド

TeeChartの内部使用。仮想デシリアライズメソッド。
public abstract Void DeserializeFrom(SerializationInfo info,
     StreamingContext context)

解説

TeeChartの内部使用。仮想デシリアライズメソッド。

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


InternalLoadViewState

Steema.TeeChart.Import.Imports.InternalLoadViewState メソッド

内部使用。保存したチャートをロードします。
public Void InternalLoadViewState(MemoryStream savedState,
     Chart& chart)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


ShowImportDialog

Steema.TeeChart.Import.Imports.ShowImportDialog メソッド

インポートダイアログを表示します。
public Void ShowImportDialog()

解説

インポートダイアログを表示します。

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports プロパティ

パブリック プロパティ

Template | テンプレートのインポートにアクセスします。
Theme | テーマのインポートにアクセスします。

参照

Imports クラス | Steema.TeeChart.Import 名前空間


Template

Steema.TeeChart.Import.Imports.Template プロパティ

テンプレートのインポートにアクセスします。
public TemplateImport Template {get;}

解説

テンプレートのインポートにアクセスします。

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Theme

Steema.TeeChart.Import.Imports.Theme プロパティ

テンプレートのインポートにアクセスします。
public ThemeImport Theme {get;}

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports.MyBinder

Steema.TeeChart.Import.Imports.MyBinder クラス

この型のすべてのメンバの一覧については、MyBinder メンバを参照してください。

System.Object
System.Reflection.Binder
public class MyBinder : Binder

必要条件

名前空間: Steema.TeeChart.Import 名前空間

アセンブリ: TeeChart.dll

参照

MyBinder メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports.MyBinder 全メンバ

MyBinder 概要

パブリック メソッド

BindToField
BindToMethod
ChangeType
ReorderArgumentArray
SelectMethod
SelectProperty

コンストラクタ

Steema.TeeChart.Import.Imports.MyBinder..ctor

参照

MyBinder クラス | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports.MyBinder メソッド

パブリック メソッド

BindToField
BindToMethod
ChangeType
ReorderArgumentArray
SelectMethod
SelectProperty

参照

MyBinder クラス | Steema.TeeChart.Import 名前空間


BindToField

Steema.TeeChart.Import.Imports+MyBinder.BindToField メソッド

public override FieldInfo BindToField(BindingFlags bindingAttr,
     FieldInfo[] match,
     Object value,
     CultureInfo culture)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


BindToMethod

Steema.TeeChart.Import.Imports+MyBinder.BindToMethod メソッド

public override MethodBase BindToMethod(BindingFlags bindingAttr,
     MethodBase[] match,
     Object[]& args,
     ParameterModifier[] modifiers,
     CultureInfo culture,
     String[] names,
     Object& state)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


ChangeType

Steema.TeeChart.Import.Imports+MyBinder.ChangeType メソッド

public override Object ChangeType(Object value,
     Type myChangeType,
     CultureInfo culture)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


ReorderArgumentArray

Steema.TeeChart.Import.Imports+MyBinder.ReorderArgumentArray メソッド

public override Void ReorderArgumentArray(Object[]& args,
     Object state)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


SelectMethod

Steema.TeeChart.Import.Imports+MyBinder.SelectMethod メソッド

public override MethodBase SelectMethod(BindingFlags bindingAttr,
     MethodBase[] match,
     Type[] types,
     ParameterModifier[] modifiers)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


SelectProperty

Steema.TeeChart.Import.Imports+MyBinder.SelectProperty メソッド

public override PropertyInfo SelectProperty(BindingFlags bindingAttr,
     PropertyInfo[] match,
     Type returnType,
     Type[] indexes,
     ParameterModifier[] modifiers)

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.Imports+MyBinder コンストラクタ

public Imports+MyBinder()

参照

MyBinder クラス | MyBinder メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.TemplateImport

Steema.TeeChart.Import.TemplateImport クラス

チャートのテンプレート、ネイティブ形式のインポート。

この型のすべてのメンバの一覧については、TemplateImport メンバを参照してください。

System.Object
Steema.TeeChart.Import.Imports
public sealed class TemplateImport : Imports

必要条件

名前空間: Steema.TeeChart.Import 名前空間

アセンブリ: TeeChart.dll

参照

TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.TemplateImport 全メンバ

TemplateImport 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

DecodeBase64 (Importsの継承元) |
DeserializeFrom (Importsの継承元) | TeeChartの内部使用。仮想デシリアライズメソッド。
FromURL | URLからTeeChartのテンプレートをロードします。
InternalLoadViewState (Importsの継承元) | 内部使用。保存したチャートをロードします。
Load | ストリームからテンプレートをロードします。
LoadFileDialog | インポートファイルの選択ダイアログを表示します。
ShowImportDialog (Importsの継承元) | インポートダイアログを表示します。

パブリック プロパティ

CustomType | シリアライズ時やカスタムな要素のサポート時に、チャートから派生した独自のクラス名に設定したこの型名を使用してください。
FileExtension | インポートするテンプレートファイルのデフォルトの拡張子を取得/設定します。
Template (Importsの継承元) | テンプレートのインポートにアクセスします。
Theme (Importsの継承元) | テーマのインポートにアクセスします。

プロテクト フィールド

chart (Importsの継承元)

参照

TemplateImport クラス | Steema.TeeChart.Import 名前空間


TemplateImport コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Import.TemplateImport コンストラクタ

オーバーロードの一覧

public TemplateImport()
public TemplateImport(Steema.TeeChart.Chart)

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


TemplateImport コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Import.TemplateImport コンストラクタ

public TemplateImport()

参照

TemplateImport コンストラクタのオーバーロードの一覧 | TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


TemplateImport コンストラクタ

Steema.TeeChart.Import.TemplateImport コンストラクタ

public TemplateImport(Chart c)

参照

TemplateImport コンストラクタのオーバーロードの一覧 | TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.TemplateImport フィールド

プロテクト フィールド

chart (Importsの継承元)

参照

TemplateImport クラス | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.TemplateImport メソッド

パブリック メソッド

DecodeBase64 (Importsの継承元) |
DeserializeFrom (Importsの継承元) | TeeChartの内部使用。仮想デシリアライズメソッド。
FromURL | URLからTeeChartのテンプレートにロードします。
InternalLoadViewState (Importsの継承元) | 内部使用。保存したチャートをロードします。
Load | ストリームからテンプレートをロードします。
LoadFileDialog | インポートファイルの選択ダイアログを表示します。
ShowImportDialog (Importsの継承元) | インポートダイアログを表示します。

参照

TemplateImport クラス | Steema.TeeChart.Import 名前空間


FromURL

Steema.TeeChart.Import.TemplateImport.FromURL メソッド

URLからTeeChartのテンプレートをロードします。
public Void FromURL(String url)

パラメーター

url
string eg. "http://www.steema.com/demo.ten"

解説

URLからTeeChartのテンプレートをロードします。

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.TemplateImport.Load メソッド

オーバーロードの一覧

ストリームからテンプレートをロードします。

public Void Load(System.IO.Stream)

ファイルからテンプレートをロードします。

public Void Load(System.String)

解説

テンプレートをロードします。

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.TemplateImport.Load メソッド

ストリームからテンプレートをロードします。
public Void Load(Stream stream)

解説

ストリームからテンプレートをロードします。

参照

Load オーバーロードの一覧 | TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.TemplateImport.Load メソッド

ファイルからチャートのテンプレートをロードします。
public Void Load(String fileName)

パラメーター

fileName
文字列g 例：[C#] "c:\\myCharts\\myChart.ten" あるいは @"c:\myCharts\myChart.ten"

解説

ファイルからチャートのテンプレートをロードします。

参照

Load オーバーロードの一覧 | TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


LoadFileDialog

Steema.TeeChart.Import.TemplateImport.LoadFileDialog メソッド

インポートファイルの選択ダイアログを表示します。
public Void LoadFileDialog()

解説

インポートファイルの選択ダイアログを表示します。

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.TemplateImport プロパティ

パブリック プロパティ

CustomType | シリアライズ時やカスタムな要素のサポート時に、チャートから派生した独自のクラス名に設定したこの型名を使用してください。
FileExtension | インポートするテンプレートファイルのデフォルトの拡張子文字列を取得/設定します。
Template (Importsの継承元) | テンプレートのインポートにアクセスします。
Theme (Importsの継承元) | テーマのインポートにアクセスします。

参照

TemplateImport クラス | Steema.TeeChart.Import 名前空間


CustomType

Steema.TeeChart.Import.TemplateImport.CustomType プロパティ

シリアライズ時やカスタムな要素のサポート時に、チャートから派生した独自のクラス名に設定したこの型名を使用してください。
public String CustomType {get; set;}

例

 MyChart myChart = new MyChart();
 myChart.Import.Template.CustomType = myChart.ToString();
 myChart = (MyChart)(myChart.Import.Template.Load(@"c:\output\customChart.ten"));

 //従って、customChart.tenファイルは前にMyChartからエクスポートしたものです。

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


FileExtension

Steema.TeeChart.Import.TemplateImport.FileExtension プロパティ

インポートするテンプレートファイルのデフォルトの拡張子文字列です。
public String FileExtension {get; set;}

解説

インポートするテンプレートファイルのデフォルトの拡張子文字列です。

参照

TemplateImport クラス | TemplateImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport

Steema.TeeChart.Import.ThemeImport クラス

テーマのxmlファイルインポート

この型のすべてのメンバの一覧については、ThemeImport メンバを参照してください。

System.Object
Steema.TeeChart.Import.Imports
public sealed class ThemeImport : Imports

必要条件

名前空間: Steema.TeeChart.Import 名前空間

アセンブリ: TeeChart.dll

参照

ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport 全メンバ

ThemeImport 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

DecodeBase64 (Importsの継承元) |
DeserializeFrom (Importsの継承元) | TeeChartの内部使用。仮想デシリアライズメソッド。
FromURL | URLからTeeChartテーマをロードします。
InternalLoadViewState (Importsの継承元) | 内部使用。保存したチャートをロードします。
Load | ストリームからテンプレートをロードします。
LoadFileDialog | インポートファイルの選択ダイアログを表示します。
ShowImportDialog (Importsの継承元) | インポートダイアログを表示します。

パブリック プロパティ

FileExtension | インポートするテンプレートファイルのデフォルトの拡張子文字列を取得/設定します。
Template (Importsの継承元) | テンプレートのインポートにアクセスします。
Theme (Importsの継承元) | テーマのインポートにアクセスします。

プロテクト フィールド

chart (Importsの継承元)

参照

ThemeImport クラス | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport コンストラクタ

オーバーロードの一覧

public ThemeImport()
public ThemeImport(Steema.TeeChart.Chart)

参照

ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport コンストラクタ

public ThemeImport()

参照

ThemeImport コンストラクタのオーバーロードの一覧 | ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport コンストラクタ

public ThemeImport(Chart c)

参照

ThemeImport コンストラクタのオーバーロードの一覧 | ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport フィールド

プロテクト フィールド

chart (Importsの継承元)

参照

ThemeImport クラス | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport メソッド

パブリック メソッド

DecodeBase64 (Importsの継承元) |
DeserializeFrom (Importsの継承元) | TeeChartの内部使用。仮想デシリアライズメソッド。
FromURL | URLからTeeChartテーマをロードします。
InternalLoadViewState (Importsの継承元) | 内部使用。保存したチャートをロードします。
Load | ストリームからテンプレートをロードします。
LoadFileDialog | インポートファイルの選択ダイアログを表示します。
ShowImportDialog (Importsの継承元) | インポートダイアログを表示します。

参照

ThemeImport クラス | Steema.TeeChart.Import 名前空間


FromURL

Steema.TeeChart.Import.ThemeImport.FromURL メソッド

URLからTeeChartテーマをロードします。
public Chart FromURL(String url)

パラメーター

url
文字列。例："http://www.steema.com/theme.xml"

参照

ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.ThemeImport.Load メソッド

オーバーロードの一覧

ストリームからチャートテーマをロードします。

public Chart Load(System.IO.Stream)

ファイルからチャートテーマをロードします。

public Chart Load(System.String)

参照

ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.ThemeImport.Load メソッド

ストリームからチャートテーマをロードします。
public Chart Load(Stream stream)

参照

Load オーバーロードの一覧 | ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Load

Steema.TeeChart.Import.ThemeImport.Load メソッド

ファイルからチャートテーマをロードします。
public Chart Load(String fileName)

パラメーター

fileName
文字列。例：[C#] "c:\\myCharts\\myTheme.xml" あるいは @"c:\myCharts\myTheme.xml"

参照

Load オーバーロードの一覧 | ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


LoadFileDialog

Steema.TeeChart.Import.ThemeImport.LoadFileDialog メソッド

インポートファイルの選択ダイアログを表示します。
public Void LoadFileDialog()

参照

ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Import.ThemeImport プロパティ

パブリック プロパティ

FileExtension | Default extension for imported template file
Template (Importsの継承元) | Access Template import
Theme (Importsの継承元) | Access Template import

参照

ThemeImport クラス | Steema.TeeChart.Import 名前空間


FileExtension

Steema.TeeChart.Import.ThemeImport.FileExtension プロパティ

インポートするテンプレートファイルのデフォルトの拡張子文字列を取得/設定します。
public String FileExtension {get; set;}

参照

ThemeImport クラス | ThemeImport メンバ | Steema.TeeChart.Import 名前空間


Steema.TeeChart.Styles

Steema.TeeChart.Styles 名前空間

名前空間の階層構造

パブリック 列挙体

WorldMapType

パブリック クラス

World 世界地図系列。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.Mapping.dll


Steema.TeeChart.Styles 階層構造

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Styles.Series

Steema.TeeChart.Styles.Custom3D

Steema.TeeChart.Styles.Custom3DPalette

Steema.TeeChart.Styles.Map

Steema.TeeChart.Styles.World

参照

SteemaTeeChartStyles 名前空間


Steema.TeeChart.Styles.Area

Steema.TeeChart.Styles.Area クラス

面系列。

この型のすべてのメンバの一覧については、Area メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Area : Custom , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Area メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Area 全メンバ

Area 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AreaBrush | 面の背面領域を塗りつぶすブラシの種類を設定します。
AreaLines | 面領域の垂直線を描くペンの種類を設定します。
AreaLinesPen |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | 面領域のグラデーションについて設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiArea | 面系列が複数存在する場合、どのように表示するかを定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin | すべての面系列ポイントの原点となる軸値を設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StackGroup |
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TopGradient | 上部の3D面領域を塗りつぶすグラデーションを定義します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin | 面をOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Area クラス | Steema.TeeChart.Styles 名前空間


Area コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area コンストラクタ

オ－バーロードの一覧

public Area(Steema.TeeChart.Chart)
public Area()

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Area コンストラクタ

Steema.TeeChart.Styles.Area コンストラクタ

public Area(Chart c)

参照

Area コンストラクタのオーバーロードの一覧 | Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Area コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area コンストラクタ

public Area()

参照

Area コンストラクタのオーバーロードの一覧 | Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Area イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Area クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Area フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Area クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Area メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Area クラス | Steema.TeeChart.Styles 名前空間


CalcZOrder

Steema.TeeChart.Styles.Area.CalcZOrder メソッド

protected internal abstract Void CalcZOrder()

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Area.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


GetOriginPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.GetOriginPos メソッド

protected virtual Int32 GetOriginPos(Int32 valueIndex)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.MaxXValue メソッド

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.MinXValue メソッド

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.MinYValue メソッド

系列のY値のリストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値のリストの最小値を返します。複数のY値リスト持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

例

[C#]

この例では、左軸を設定するためにMinYValueが使用されます。

tChart1.Axes.Left.Automatic = false;
tChart1.Axes.Left.Minimum = areaSeries1.MinYValue();

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Area.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.Area.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


SameClassOrigin

Steema.TeeChart.Styles.Area.SameClassOrigin メソッド

protected abstract Boolean SameClassOrigin(Series s)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Area.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Area プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AreaBrush | 面の背面領域を塗りつぶすブラシの種類を設定します。
AreaLines | 面領域の垂直線を描くペンの種類を設定します。
AreaLinesPen |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | 面領域のグラデーションについて設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiArea | 面系列が複数存在する場合、どのように表示するかを定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin | すべての面系列ポイントの原点となる軸値を設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StackGroup |
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TopGradient | 上部の3D面領域を塗りつぶすグラデーションを定義します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin | 面をOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Area クラス | Steema.TeeChart.Styles 名前空間


AreaBrush

Steema.TeeChart.Styles.Area.AreaBrush プロパティ

面の背面領域を塗りつぶすブラシの種類を設定します。
public ChartBrush AreaBrush {get;}

解説

デフォルト値：Solid

面の背面領域を塗りつぶすブラシの種類を設定します。Series.Colorプロパティを使用して面の背面の色を制御できます。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


AreaLines

Steema.TeeChart.Styles.Area.AreaLines プロパティ

面領域の垂直線を描くペンの種類を設定します。
public ChartPen AreaLines {get;}

解説

面領域の垂直線を描くペンの種類を設定します。デフォルトでは、AreaLines.Visibleプロパティはfalseですので、最初にこのプロパティをtrueに設定しなければなりません。AreaBrushプロパティを使用して面のブラシスタイルを制御できます。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


AreaLinesPen

Steema.TeeChart.Styles.Area.AreaLinesPen プロパティ

public ChartPen AreaLinesPen {get;}

旧式

このプロパティの代わりにAreaLinesプロパティを使用してください。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Area.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.Area.Gradient プロパティ

面領域のグラデーションについて設定します。
public Gradient Gradient {get;}

解説

面領域のグラデーションについて設定します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


MultiArea

Steema.TeeChart.Styles.Area.MultiArea プロパティ

面系列が複数存在する場合、どのように表示するかを定義します。
public MultiAreas MultiArea {get; set;}

解説

デフォルト値：None

面系列が複数存在する場合、どのように表示するか定義します。デフォルトは、すべての面が他の面の後ろに描画されます。StackedおよびStacked100は、各面を積み重ねて描画します。Stacked100は、個々のポイントを共通の0～100軸スケールを使用して百分率で表示します。系列を積み重ねていく順番は、Chart.SeriesListプロパティに依存します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Origin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.Origin プロパティ

すべての面系列ポイントの原点となる軸値を設定します。

public Double Origin {get; set;}

解説

指定した面系列の原点となるY値を設定します。

例

[C#]

Steema.TeeChart.Styles.Area Series1 = new Steema.TeeChart.Styles.Area();
tChart1.Series.Add(Series1);
Series1.UseOrigin = true;
Series1.Origin = 100;

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


StackGroup

Steema.TeeChart.Styles.Area.StackGroup プロパティ

public Int32 StackGroup {get; set;}

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


TopGradient

Steema.TeeChart.Styles.Area.TopGradient プロパティ

上部の3D面領域を塗りつぶすグラデーションを定義します。
public Gradient TopGradient {get;}

解説

上部の3D面領域を塗りつぶすグラデーションを定義します。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


UseOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Area.UseOrigin プロパティ

面をOriginプロパティ値に下揃えするかどうかを定義します。

public Boolean UseOrigin {get; set;}

解説

デフォルト値：false

面ポイントの下の位置を定義するY値（Originプロパティを使用）の設定を有効/無効にします。

参照

Area クラス | Area メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow

Steema.TeeChart.Styles.Arrow クラス

矢印系列。

この型のすべてのメンバの一覧については、Arrow メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Arrow : Points , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Arrow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow 全メンバ

Arrow 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 系列に新しい矢印ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
ArrowHeight | 矢印のヘッドのサイズをピクセル単位で定義します。
ArrowWidth | 矢印の幅をピクセル単位で定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndXValues | 矢印のX1の値を設定します。
EndYValues | 矢印のY1値を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartXValues | 矢印のX0値を設定します。
StartYValues | 矢印のY0値を設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Arrow クラス | Steema.TeeChart.Styles 名前空間


Arrow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow コンストラクタ

オーバーロードの一覧

public Arrow()
public Arrow(Steema.TeeChart.Chart)

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Arrow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow コンストラクタ

public Arrow()

参照

Arrow コンストラクタのオーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Arrow コンストラクタ

Steema.TeeChart.Styles.Arrow コンストラクタ

public Arrow(Chart c)

参照

Arrow コンストラクタのオーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Arrow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Arrow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow メソッド

パブリック メソッド

Add | 系列に新しい矢印ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Arrow クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.Add メソッド

オーバーロードの一覧

開始と終了座標で矢印を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double)

開始と終了座標とラベルで矢印を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.String)

開始と終了座標と色で矢印を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Drawing.Color)

開始と終了座標、ラベル、色で矢印を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

解説

系列に新しい矢印ポイントを追加します。リストの矢印の位置を返します。位置はゼロから開始します。

各矢印は2つのポイントで作成されます：

(X0,Y0) 矢印ポイントの開始位置

(X1,Y1) 矢印ポイントの終了位置

Label （オーバーロードのオプション）
Color （オーバーロードのオプション）

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.Add メソッド

開始座標と終了座標で矢印を追加します。

public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1)

参照

Add オーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.Add メソッド

開始と終了座標とラベルで矢印を追加します。

public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     String text)

参照

Add オーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.Add メソッド

開始と終了座標と色で矢印を追加します。

public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     Color color)

参照

Add オーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.Add メソッド

開始座標、終了座標、ラベル、色で矢印を追加します。

public Int32 Add(Double x0,
     Double y0,
     Double x1,
     Double y1,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.DrawValue メソッド

内部的に呼び出されます。指定したValueIndexパラメーターの系列ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。直接呼び出す必要はありません。指定したValueIndexパラメーターの系列ポイントを描画します。

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Arrow.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

現在の全系列のY値リストの最大値を返します。

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列の場合、この最小値は全ての系列のY値リスト内の最小値になります

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Arrow.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Arrow プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
ArrowHeight | 矢印のヘッドのサイズをピクセル単位で定義します。
ArrowWidth | 矢印の幅をピクセル単位で定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndXValues | 矢印のX1の値を設定します。
EndYValues | 矢印のY1値を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartXValues | 矢印のX0値を設定します。
StartYValues | 矢印のY0値を設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Arrow クラス | Steema.TeeChart.Styles 名前空間


ArrowHeight

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.ArrowHeight プロパティ

矢印のヘッドのサイズをピクセル単位で定義します。

public Int32 ArrowHeight {get; set;}

解説

矢印のヘッドのサイズをピクセル単位で定義します。ArrowWidthプロパティも使用して、矢印の全サイズを定義できます。

例

[C#]

Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[3];
a.ArrowHeight = 10;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


ArrowWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Arrow.ArrowWidth プロパティ

矢印の幅をピクセル単位で定義します。

public Int32 ArrowWidth {get; set;}

解説

デフォルト値：4

矢印の幅をピクセル単位で定義します。

例

[C]

Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[0];
a.ArrowWidth = 8;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Arrow.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


EndXValues

Steema.TeeChart.Styles.Arrow.EndXValues プロパティ

矢印のX1の値を設定します。
public ValueList EndXValues {get; set;}

解説

各矢印は(X0,Y0)および(X1,Y1)の座標値を持っています。
EndXValuesプロパティは、X1値のリストです。

例

このコードは、6番目の矢印ポイントのX1座標値を123に設定します。

[C#]
Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[0];
a.EndXValues[5]=123;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


EndYValues

Steema.TeeChart.Styles.Arrow.EndYValues プロパティ

矢印のY1値を設定します。
public ValueList EndYValues {get; set;}

解説

各矢印は(X0,Y0)および(X1,Y1)の座標値を持っています。

EndYValuesプロパティは、Y1値のリストです。

例

このコードは最初の矢印ポイントのY1座標値を変更します。

[C#]

Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[0];
a.EndYValues[0]=150;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


StartXValues

Steema.TeeChart.Styles.Arrow.StartXValues プロパティ

矢印のX0値を設定します。
public ValueList StartXValues {get; set;}

解説

各矢印は(X0,Y0)および(X1,Y1)の座標値を持っています。

StartXValuesプロパティは、X0値のリストです。

StartXValues.DateTimeプロパティのデフォルト値はtrueです。

例

このコードは最初の矢印ポイントのX0座標値を変更します。

[C#]

Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[0];
a.StartXValues[0]=80;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


StartYValues

Steema.TeeChart.Styles.Arrow.StartYValues プロパティ

矢印のY0値を設定します。
public ValueList StartYValues {get; set;}

解説

各矢印は(X0,Y0)および(X1,Y1)の座標値を持っています。

StartYValuesプロパティはY0値のリストです。

例

このコードは最初の矢印ポイントのY0座標値を変更します。

[C#]

Steema.TeeChart.Styles.Arrow a=(Steema.TeeChart.Styles.Arrow)tChart1[0];
a.StartYValues[0]=350;

参照

Arrow クラス | Arrow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ArrowHeadStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ArrowHeadStyles 列挙体

[Serializable]
public enum ArrowHeadStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None |
Line |
Solid |

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar

Steema.TeeChart.Styles.Bar クラス

縦棒系列コンポーネントは、垂直バーとしてすべてのポイントを出力します。

この型のすべてのメンバの一覧については、Bar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
public class Bar : CustomBar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Bar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar 全メンバ

Bar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward |
DrawTickLine |
DrawTickLines (CustomBarの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Bar クラス | Steema.TeeChart.Styles 名前空間


Bar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar コンストラクタ

オーバーロードの一覧

public Bar()
public Bar(Steema.TeeChart.Chart)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Bar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar コンストラクタ

public Bar()

参照

Bar コンストラクタのオーバーロードの一覧 | Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Bar コンストラクタ

Steema.TeeChart.Styles.Bar コンストラクタ

public Bar(Chart c)

参照

Bar コンストラクタのオーバーロードの一覧 | Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Bar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Bar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward |
DrawTickLine |
DrawTickLines (CustomBarの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Bar クラス | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.CalcXPos メソッド

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

この座標値は水平軸に対応する系列を使用して計算されます。

例

左上部の角から各ポイントに線を描く場合は次のようになります。

[C#]

if (tChart1[0].Count>0)
     for (int i=0;i<tChart1[0].Count;i++)
    {
        //系列のインデックスを使用
        int tmpX=tChart1[0].CalcXPos(i); //ピクセル値を返す
        int tmpY=tChart1[0].CalcYPos(i);

        //0,0からポイントへ線を描く

        tChart1.Graphics3D.Line(0,0,tmpX,tmpY);
    }

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.CalcYPos メソッド

指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。

public virtual Int32 CalcYPos(Int32 valueIndex)

解説

指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。

この座標値は垂直軸に対応する系列を使用して計算されます。

例

左上部の角から各ポイントに線を描く場合以下のようになります。

[C#]

if (tChart1[0].Count>0)
     for (int i=0;i<tChart1[0].Count;i++)
    {
        //系列のインデックスを使用
        int tmpX=tChart1[0].CalcXPos(i); //ピクセル値を返す
        int tmpY=tChart1[0].CalcYPos(i);

        //0,0からポイントへ線を描く

        tChart1.Graphics3D.Line(0,0,tmpX,tmpY);
    }

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


DrawBar

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.DrawBar メソッド

内部使用。

public virtual Void DrawBar(Int32 barIndex,
     Int32 startPos,
     Int32 endPos)

解説

StartPosやEndPosパラメーターをピクセル位置として使用して、各バーを表示するために内部的に使用されます。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Bar.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position p)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


DrawSeriesForward

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.DrawSeriesForward メソッド

protected virtual Boolean DrawSeriesForward(Int32 valueIndex)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


DrawTickLine

Steema.TeeChart.Styles.Bar.DrawTickLine メソッド

protected abstract Void DrawTickLine(Int32 tickPos,
     BarStyles aStyle)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.DrawValue メソッド

内部的に呼び出されます。指定したValueIndexパラメーターの系列ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。直接呼び出す必要はありません。指定したValueIndexパラメーターの系列ポイントを描画します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Bar.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


GetOriginPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.GetOriginPos メソッド

指定したバーの表示原点の画面座標値をピクセル単位で返します。

public Int32 GetOriginPos(Int32 valueIndex)

解説

指定したバーの表示原点の画面座標値をピクセル単位で返します。
MultiBarプロパティがStackedあるいはStacked100以外の場合、このメソッドは始点の画面座標値を返します。
複数のバー系列が積み重ねられている場合、このメソッドは、各系列の異なる画面座標値を返します。
ValueIndexパラメーターは、、バーのインデックスを指定します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


InternalCalcMarkLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.InternalCalcMarkLength メソッド

protected virtual Int32 InternalCalcMarkLength(Int32 valueIndex)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


InternalClicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.InternalClicked メソッド

protected virtual Boolean InternalClicked(Int32 valueIndex,
     Point point)

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


MoreSameZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.MoreSameZOrder メソッド

protected virtual Boolean MoreSameZOrder()

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Bar クラス | Steema.TeeChart.Styles 名前空間


BarWidthPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar.BarWidthPercent プロパティ

使用するバー幅全体に対する割合を定義します。

public Int32 BarWidthPercent {get; set;}

解説

デフォルト値：70

使用するバー幅全体に対する割合を定義します。BarWidthPercent = 100に設定すると、バー間の間隔が無くなります。Page.MaxPointsPerPageプロパティを使用すると、同時に表示するバーの数を制御できます。BarWidthプロパティやBarHeightプロパティは、バーの寸法をピクセル単位で示します。

メモ：
BarWidthが0に設定されている時のみ、BarwidthPercentの設定が有効になります。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Bar.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Bar クラス | Bar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D

Steema.TeeChart.Styles.Bar3D クラス

3D バー系列。

この型のすべてのメンバの一覧については、Bar3D メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class Bar3D : Bar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D 全メンバ

Bar3D 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 指定したパラメーターで新しいバーを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (Barの継承元) | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
OffsetValues |
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Bar3D クラス | Steema.TeeChart.Styles 名前空間


Bar3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D コンストラクタ

オーバーロードの一覧

public Bar3D()
public Bar3D(Steema.TeeChart.Chart)

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Bar3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D コンストラクタ

public Bar3D()

参照

Bar3D コンストラクタのオーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Bar3D コンストラクタ

Steema.TeeChart.Styles.Bar3D コンストラクタ

public Bar3D(Chart c)

参照

Bar3D コンストラクタのオーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Bar3D クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Bar3D クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D メソッド

パブリック メソッド

Add | 指定したパラメーターで新しいバーを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (Barの継承元) | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack |
ValueListOfAxis (Seriesの継承元) |

参照

Bar3D クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.Add メソッド

オーバーロードの一覧

X値、Y値、Yの開始ポイント、色でバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

X値、Y値、Yの開始ポイントでバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double)

オフセットとラベルを持つX、Y値でバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

X値、Y値、Yの開始ポイント、ラベル、色でバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

解説

X値、Y値、バーのYの開始ポイント、テキスト、色でバーを追加します。

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.Add メソッド

X値、Y値、Yの開始ポイント、色でバーを追加します。

public Int32 Add(Double x,
     Double y,
     Double offset,
     Color color)

参照

Add オーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.Add メソッド

X値、Y値、Yの開始ポイントでバーを追加します。

public Int32 Add(Double x,
     Double y,
     Double offset)

参照

Add オーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.Add メソッド

オフセットとラベルを持つX、Y値でバーを追加します。

public Int32 Add(Double x,
     Double y,
     Double offset,
     String text)

参照

Add オーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.Add メソッド

X値、Y値、Yの開始ポイント、ラベル、色でバーを追加します。

public Int32 Add(Double x,
     Double y,
     Double offset,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


GetOriginValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.GetOriginValue メソッド

protected internal virtual Double GetOriginValue(Int32 valueIndex)

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


PointOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.PointOrigin メソッド

指定したvalueIndexパラメーターに該当するポイントの原点を返します。

public virtual Double PointOrigin(Int32 valueIndex,
     Boolean sumAll)

解説

指定したvalueIndexパラメーターに該当するポイントの原点を返します。sumAllパラメーターは縦棒系列あるいは横棒系列のみ有効で、バーを積み重ねている場合に、このパラメーターをtrueに設定するとバーの高さの和を返し、falseに設定すると各バーの原点を返します。

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


SubGalleryStack

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bar3D.SubGalleryStack メソッド

protected virtual Boolean SubGalleryStack()

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bar3D プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
OffsetValues |
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Bar3D クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Bar3D.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


OffsetValues

Steema.TeeChart.Styles.Bar3D.OffsetValues プロパティ

public ValueList OffsetValues {get; set;}

解説

各バーポイントの異なる原点の値を指定します。
これは、「3D積み重ね」チャート型を作成するために標準のバー系列コンポーネントで使用できます。

例

[C#]

bar3DSeries1.OffsetValues[2] =25;

参照

Bar3D クラス | Bar3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin

Steema.TeeChart.Styles.BarJoin クラス

バージョイン系列。

この型のすべてのメンバの一覧については、BarJoin メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class BarJoin : Bar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

BarJoin メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin 全メンバ

BarJoin 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Barの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Barの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
JoinPen | 各バーポイント間に線を描くペンを設定します。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

BarJoin クラス | Steema.TeeChart.Styles 名前空間


BarJoin コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BarJoin コンストラクタ

オーバーロードの一覧

public BarJoin()
public BarJoin(Steema.TeeChart.Chart)

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


BarJoin コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BarJoin コンストラクタ

public BarJoin()

参照

BarJoin コンストラクタのオーバーロードの一覧 | BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


BarJoin コンストラクタ

Steema.TeeChart.Styles.BarJoin コンストラクタ

public BarJoin(Chart c)

参照

BarJoin コンストラクタのオーバーロードの一覧 | BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

BarJoin クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

BarJoin クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Barの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Barの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

BarJoin クラス | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BarJoin.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


DrawBar

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BarJoin.DrawBar メソッド

内部使用。

public virtual Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

解説

StartPosやEndPosパラメーターをピクセル位置として使用して、各バーを表示するために内部的に使用されます。

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BarJoin.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.BarJoin.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarJoin プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
JoinPen | 各バーポイント間に線を描くペンを設定します。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

BarJoin クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.BarJoin.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


JoinPen

Steema.TeeChart.Styles.BarJoin.JoinPen プロパティ

各バーポイント間に線を描くペンを設定します。
public ChartPen JoinPen {get;}

解説

バー ジョイン系列のバーポイント間に線を描くペンを設定します。

参照

BarJoin クラス | BarJoin メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BarStyles

Steema.TeeChart.Styles.BarStyles 列挙体

BarStyleプロパティの使用可能な値です。
[Serializable]
public sealed enum BarStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Rectangle | 各バー系列のポイントを矩形で描画します。
Pyramid | 各バー系列のポイントを四角錐で描画します。
InvPyramid | 各バー系列のポイントを倒立四角錐で描画します。
Cylinder | 各バー系列のポイントを円筒で描画します。
Ellipse | 各バー系列のポイントを楕円で描画します。
Arrow | 各バー系列のポイントを矢印で描画します。
RectGradient | 各バー系列のポイントをグラデーション矩形で描画します。
Cone | 各バー系列のポイントを円錐で描画します。
InvArrow | 各バー系列のポイントを倒立矢印で描画します。
InvCone | 各バー系列のポイントを倒立円錐で描画します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine

Steema.TeeChart.Styles.BaseLine クラス

TeeChartの系列型の数により継承された抽象系列クラス。

この型のすべてのメンバの一覧については、BaseLine メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public abstract class BaseLine : Series , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

BaseLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine 全メンバ

BaseLine 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMinMaxValue |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

BaseLine クラス | Steema.TeeChart.Styles 名前空間


BaseLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BaseLine コンストラクタ

オーバーロードの一覧

protected BaseLine()
protected BaseLine(Steema.TeeChart.Chart)

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


BaseLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.BaseLine コンストラクタ

protected BaseLine()

参照

BaseLine コンストラクタのオーバーロードの一覧 | BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


BaseLine コンストラクタ

Steema.TeeChart.Styles.BaseLine コンストラクタ

protected BaseLine(Chart c)

参照

BaseLine コンストラクタのオーバーロードの一覧 | BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

BaseLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

BaseLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMinMaxValue |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

BaseLine クラス | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.BaseLine.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


CalcMinMaxValue

Steema.TeeChart.Styles.BaseLine.CalcMinMaxValue メソッド

protected internal Double CalcMinMaxValue(Boolean isMin)

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.BaseLine.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.BaseLine プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

BaseLine クラス | Steema.TeeChart.Styles 名前空間


LinePen

Steema.TeeChart.Styles.BaseLine.LinePen プロパティ

すべてのポイントを接続する線を描くペンの種類を定義します。
public ChartPen LinePen {get; set;}

解説

すべてのポイントを接続する線を描くペンの種類を定義します。
このプロパティは、以下の方法で使用することができるリボン系列クラスを含む多くの系列クラスによって継承されます。

例

[C#]

((Steema.TeeChart.Styles.Line)tChart1[2]).LinePen.Color = Color.Red;
((Steema.TeeChart.Styles.Line)tChart1[2]).LinePen.Chart.Axes.Left.Ticks.Color = Color.Blue;

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


TreatNulls

Steema.TeeChart.Styles.BaseLine.TreatNulls プロパティ

public TreatNullsStyle TreatNulls {get; set;}

参照

BaseLine クラス | BaseLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier

Steema.TeeChart.Styles.Bezier クラス

ベジェ系列。

この型のすべてのメンバの一覧については、Bezier メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Bezier : Custom , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Bezier メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier 全メンバ

Bezier 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery | 内部使用。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Bezier クラス | Steema.TeeChart.Styles 名前空間


Bezier コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bezier コンストラクタ

オーバーロードの一覧

public Bezier()
public Bezier(Steema.TeeChart.Chart)

参照

Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


Bezier コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bezier コンストラクタ

public Bezier()

参照

Bezier コンストラクタのオーバーロードの一覧 | Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


Bezier コンストラクタ

Steema.TeeChart.Styles.Bezier コンストラクタ

public Bezier(Chart c)

参照

Bezier コンストラクタのオーバーロードの一覧 | Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Bezier クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Bezier クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery | 内部使用。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Bezier クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Bezier.Draw メソッド

public override Void Draw()

参照

Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Bezier.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Bezier.PrepareForGallery メソッド

内部使用。
public override Void PrepareForGallery(Boolean IsEnabled)

参照

Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bezier プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Bezier クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Bezier.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Bezier クラス | Bezier メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box

Steema.TeeChart.Styles.Box クラス

縦ボックスプロット系列。

この型のすべてのメンバの一覧については、Box メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomBox
public class Box : CustomBox , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Box メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box 全メンバ

Box 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (CustomBoxの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomBoxの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomBoxの継承元) | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomBoxの継承元) |
ReconstructFromData (CustomBoxの継承元) | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 (CustomBoxの継承元) | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 (CustomBoxの継承元) | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box (CustomBoxの継承元) | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExtrOut (CustomBoxの継承元) | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 (CustomBoxの継承元) | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 (CustomBoxの継承元) | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median (CustomBoxの継承元) | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen (CustomBoxの継承元) | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut (CustomBoxの継承元) | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 (CustomBoxの継承元) | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 (CustomBoxの継承元) | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position (CustomBoxの継承元) | ボックスプロット系列の位置を指定します。
Quartile1 (CustomBoxの継承元) | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 (CustomBoxの継承元) | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues (CustomBoxの継承元) | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues (CustomBoxの継承元) | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength (CustomBoxの継承元) | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen (CustomBoxの継承元) | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition (CustomBoxの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical (CustomBoxの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomBoxの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomBoxの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomBoxの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomBoxの継承元) |
GetDataSource (CustomBoxの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBoxの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Box クラス | Steema.TeeChart.Styles 名前空間


Box コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Box コンストラクタ

オーバーロードの一覧

public Box()
public Box(Steema.TeeChart.Chart)

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


Box コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Box コンストラクタ

public Box()

参照

Box コンストラクタのオーバーロードの一覧 | Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


Box コンストラクタ

Steema.TeeChart.Styles.Box コンストラクタ

public Box(Chart c)

参照

Box コンストラクタのオーバーロードの一覧 | Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Box クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition (CustomBoxの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical (CustomBoxの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Box クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box メソッド

パブリック メソッド

Add (CustomBoxの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomBoxの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomBoxの継承元) | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomBoxの継承元) |
ReconstructFromData (CustomBoxの継承元) | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomBoxの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomBoxの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomBoxの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomBoxの継承元) |
GetDataSource (CustomBoxの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBoxの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Box クラス | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Box.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

Steema.TeeChart.Styles.Box.MaxYValue メソッド

public override Double MaxYValue()

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Box.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

Steema.TeeChart.Styles.Box.MinYValue メソッド

public override Double MinYValue()

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Box プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 (CustomBoxの継承元) | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 (CustomBoxの継承元) | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box (CustomBoxの継承元) | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExtrOut (CustomBoxの継承元) | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 (CustomBoxの継承元) | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 (CustomBoxの継承元) | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median (CustomBoxの継承元) | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen (CustomBoxの継承元) | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut (CustomBoxの継承元) | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 (CustomBoxの継承元) | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 (CustomBoxの継承元) | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position (CustomBoxの継承元) | ボックスプロット系列の位置を指定します。
Quartile1 (CustomBoxの継承元) | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 (CustomBoxの継承元) | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues (CustomBoxの継承元) | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues (CustomBoxの継承元) | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength (CustomBoxの継承元) | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen (CustomBoxの継承元) | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Box クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Box.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Box クラス | Box メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble

Steema.TeeChart.Styles.Bubble クラス

泡系列。

この型のすべてのメンバの一覧については、Bubble メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Bubble : Points , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Bubble メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble 全メンバ

Bubble 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 新しい泡ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | デザイン時や実行時にDataSourceプロパティを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 泡の色の指定を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
RadiusValues | 各泡ポイントの半径値を保持するTListオブジェクトです。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Squared | 泡サイズをどのように計算するかを定義します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Bubble クラス | Steema.TeeChart.Styles 名前空間


Bubble コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble コンストラクタ

オーバーロードの一覧

public Bubble()
public Bubble(Steema.TeeChart.Chart)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Bubble コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble コンストラクタ

public Bubble()

参照

Bubble コンストラクタのオーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Bubble コンストラクタ

Steema.TeeChart.Styles.Bubble コンストラクタ

public Bubble(Chart c)

参照

Bubble コンストラクタのオーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Bubble クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Bubble クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble メソッド

パブリック メソッド

Add | 新しい泡ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | デザイン時や実行時にDataSourceプロパティを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Bubble クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Add メソッド

オーバーロードの一覧

新しい泡ポイントを追加します。

public virtual Void Add(System.Data.DataView)

X値、Y値、半径値、色を指定して新しい泡ポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

X値、Y値、半径値を指定して新しい泡ポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double)

X値、Y値、半径値、ラベルを指定して新しい泡ポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

X値、Y値、半径値、ラベル、色を指定して新しい泡ポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Add メソッド

新しい泡ポイントを追加します。

public virtual Void Add(DataView view)

参照

Add オーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Add メソッド

X値、Y値、半径値を指定して新しい泡ポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double radius)

参照

Add オーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Add メソッド

X値、Y値、半径値、ラベルを指定して新しい泡ポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double radius,
     String text)

参照

Add オーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Add メソッド

X値、Y値、半径値、ラベル、色を指定して新しい泡ポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double radius,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Bubble.Add メソッド

X値、Y値、半径値、ラベル、色を指定して新しい泡ポイントを追加します。
public Int32 Add(Double x,
     Double y,
     Double radius,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


ClickedPointer

Steema.TeeChart.Styles.Bubble.ClickedPointer メソッド

public override Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Bubble.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle r)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.DrawValue メソッド

内部的に呼び出されます。指定したValueIndexパラメーターの系列ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。直接呼び出す必要はありません。指定したValueIndexパラメーターの系列ポイントを描画します。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Bubble.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Bubble.IsValidSourceOf メソッド

デザイン時や実行時にDataSourceプロパティを有効にします。
public override Boolean IsValidSourceOf(Series value)

解説

ValueパラメーターがSelfと同等な場合、falseを返します。
デザイン時や実行時にDataSourceプロパティを有効にするために使用されます。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.MaxZValue メソッド

Z値の最大値を返します。

public virtual Double MaxZValue()

解説

Z値の最大値を返します。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.MinZValue メソッド

Z値の最小値を返します。

public virtual Double MinZValue()

解説

Z値の最小値を返します。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Bubble プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 泡の色の指定を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
RadiusValues | 各泡ポイントの半径値を保持するTListオブジェクトです。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Squared | 泡サイズをどのように計算するかを定義します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Bubble クラス | Steema.TeeChart.Styles 名前空間


ColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.ColorEach プロパティ

泡の色の指定を有効/無効にします。

public Boolean ColorEach {get; set;}

解説

デフォルト値：true

泡の色の指定を有効/無効にします。falseの場合、すべてのポイントはSeriesのSeries.Colorプロパティを使用して描画します。trueの場合、指定した色で各ポイントを描画します。

このプロパティは、デザイン時や実行時に変更できます。

例

[C#]

((Steema.TeeChart.Styles.Bubble)tChart1[0]).ColorEach = true;

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Bubble.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


RadiusValues

Steema.TeeChart.Styles.Bubble.RadiusValues プロパティ

各泡ポイントの半径値を保持するTListオブジェクトです。
public ValueList RadiusValues {get; set;}

解説

各泡ポイントの半径値を保持するTListオブジェクトです。RadiusValues.Valueプロパティを使用して半径値を変更できます。

例

これは最初の泡ポイントの半径を45.1に設定します。
ポイントを追加や削除するには、AddBubbleメソッドやDeleteメソッドを使用してください。

[C#]

((Steema.TeeChart.Styles.Bubble)tChart1.Series[0]).RadiusValues.Value[0] = 45.1;

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Squared

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Bubble.Squared プロパティ

泡サイズをどのように計算するかを定義します。

public Boolean Squared {get; set;}

解説

デフォルト値：true

泡サイズをどのように計算するかを定義します。デフォルトでは、水平方向および垂直方向の泡サイズは各泡の半径に等しくなっています。falseの場合、泡の水平および垂直方向のサイズは、系列の軸スケールに基づいて独立して計算されます。

参照

Bubble クラス | Bubble メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar

Steema.TeeChart.Styles.Calendar クラス

カレンダー系列。

この型のすべてのメンバの一覧については、Calendar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Calendar : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar 全メンバ

Calendar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Change |
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
DayOneColumn |
DayOneRow |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
MonthClick | 次月ボタンや前月ボタンのクリックイベントを処理します。
NextMonth | 翌月を表示します。
PrepareForGallery |
PreviousMonth | 前月を表示します。
RectCell | 指定したカレンダー系列のセルの枠として定義される2D矩形の境界を返します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetCell | 選択された日付セルを設定するために、マウスクリックを使用することができます。
SetNextPrevious | 次/前ボタンを設定するためにマウスクリックを使用できます。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Columns | カレンダー系列の列数を返します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
Date | カレンダーグリッドのセルの日付を設定します。
Days | カレンダーの日付のカレンダーセルの外観特性を定義します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
Month |
Months | 月の名前のカレンダーセルの外観を定義します。
NextMonthButton | カレンダーを「翌月」にスクロールするボタンを返します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ペン特性のエレメント。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PopupMenu |
PreviousMonthButton | カレンダーを「前月」にスクロールするボタンを返します。
Rows | カレンダー系列の行数を返します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Sunday | すべての日曜のカレンダーセルの外観を定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Today | 当日のカレンダーセルの外観を定義します。
Trailing | 前月および次月の日付のカレンダーセルの外観を定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WeekDays | 曜日タイトルのカレンダーセルの外観を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawCell |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Calendar クラス | Steema.TeeChart.Styles 名前空間


Calendar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar コンストラクタ

オーバーロードの一覧

public Calendar()
public Calendar(Steema.TeeChart.Chart)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Calendar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar コンストラクタ

public Calendar()

参照

Calendar コンストラクタのオーバーロードの一覧 | Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Calendar コンストラクタ

Steema.TeeChart.Styles.Calendar コンストラクタ

public Calendar(Chart c)

参照

Calendar コンストラクタのオーバーロードの一覧 | Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Change |
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Calendar クラス | Steema.TeeChart.Styles 名前空間


Change

Steema.TeeChart.Styles.Calendar.Change イベント

public CalendarChangeEventHandler  Change

解説

カレンダー系列。このイベントは、異なるカレンダーの日付をクリックした時に発生します。

Valueパラメーターは、新しい日付を示します。ユーザの日付変更をオーバーライドしてこの値を変更できます。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
DayOneColumn |
DayOneRow |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Calendar クラス | Steema.TeeChart.Styles 名前空間


DayOneColumn

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.DayOneColumn フィールド

public Int32 DayOneColumn

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


DayOneRow

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.DayOneRow フィールド

public Int32 DayOneRow

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加しいます。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
MonthClick | 次月ボタンや前月ボタンのクリックイベントを処理します。
NextMonth | 翌月を表示します。
PrepareForGallery |
PreviousMonth | 前月を表示します。
RectCell | 指定したカレンダー系列のセルの枠として定義される2D矩形の境界を返します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetCell | 選択された日付セルを設定するために、マウスクリックを使用することができます。
SetNextPrevious | 次/前ボタンを設定するためにマウスクリックを使用できます。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawCell |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Calendar クラス | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのインデックスを返します。「クリックされた」とはXとY座標値がポイント画面領域の境界内にあることを意味します。｢触れた｣のポイントがなければ、Clickedは-1を返します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Clicked メソッド

系列の｢クリックした｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.Calendar.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Calendar.Draw メソッド

public override Void Draw()

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


DrawCell

Steema.TeeChart.Styles.Calendar.DrawCell メソッド

protected Void DrawCell(CalendarCell cell,
     Int32 Column,
     Int32 Row,
     String text)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


MonthClick

Steema.TeeChart.Styles.Calendar.MonthClick メソッド

次月ボタンや前月ボタンのクリックイベントを処理します。
public Void MonthClick(Object sender,
     EventArgs e)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


MouseEvent

Steema.TeeChart.Styles.Calendar.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


NextMonth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.NextMonth メソッド

翌月を表示します。

public Void NextMonth()

解説

翌月を表示します。

例

[C#]

((Steema.TeeChart.Styles.Calendar)tChart1[4]).NextMonth();

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Calendar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


PreviousMonth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.PreviousMonth メソッド

前月を表示します。

public Void PreviousMonth()

解説

前月を表示します。

例

[C#]

((Steema.TeeChart.Styles.Calendar)tChart1[4]).PreviousMonth();

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


RectCell

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.RectCell メソッド

指定したカレンダー系列のセルの枠として定義される2D矩形の境界を返します。

public Rectangle RectCell(Int32 Column,
     Int32 Row)

解説

指定したカレンダー系列のセルの枠として定義される2D矩形の境界を返します。左上は列が0で行が0です。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


SetActive

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.SetActive メソッド

protected virtual Void SetActive(Boolean value)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


SetCell

Steema.TeeChart.Styles.Calendar.SetCell メソッド

選択された日付セルを設定するために、マウスクリックを使用することができます。

public Void SetCell(Int32 x,
     Int32 y)

パラメーター

x
Xのピクセル位置
y
Yのピクセル位置

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Calendar.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


SetNextPrevious

Steema.TeeChart.Styles.Calendar.SetNextPrevious メソッド

次/前ボタンを設定するためにマウスクリックを使用できます。
public Boolean SetNextPrevious(Int32 x,
     Int32 y)

パラメーター

x
ピクセル単位のX位置
y
ピクセル単位のY位置

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Columns | カレンダー系列の列数を返します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
Date | カレンダーグリッドのセルの日付を設定します。
Days | カレンダーの日付のカレンダーセルの外観特性を定義します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
Month |
Months | 月の名前のカレンダーセルの外観を定義します。
NextMonthButton | カレンダーを「翌月」にスクロールするボタンを返します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ペン特性のエレメント。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PopupMenu |
PreviousMonthButton | カレンダーを「前月」にスクロールするボタンを返します。
Rows | カレンダー系列の行数を返します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Sunday | すべての日曜のカレンダーセルの外観を定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Today | 当日のカレンダーセルの外観を定義します。
Trailing | 前月および次月の日付のカレンダーセルの外観を定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WeekDays | 曜日タイトルのカレンダーセルの外観を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Calendar クラス | Steema.TeeChart.Styles 名前空間


Columns

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Columns プロパティ

カレンダー系列の列数を返します。

public Int32 Columns {get;}

解説

カレンダー系列の列数を返します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Date

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Date プロパティ

カレンダーグリッドのセルの日付を設定します。

public DateTime Date {get; set;}

解説

double値で強調する日（"今日"）を定義し、カレンダー系列に関連する月を表示させます。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Date = DateTime.FromOADate(24584);

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Days

Steema.TeeChart.Styles.Calendar.Days プロパティ

カレンダーの日付のカレンダーセルの外観特性を定義します。
public CalendarCell Days {get;}

解説

当日、前後月の日付および日曜以外の日付のカレンダーセルの外観特性（フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Days.Font.Name = 'Verdana';

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Calendar.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Month

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Month プロパティ

public Int32 Month {get;}

解説

現在表示している月の月数を返します。

例

MessageBox.Show(calendarSeries1.Month.ToString());

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Months

Steema.TeeChart.Styles.Calendar.Months プロパティ

月の名前のカレンダーセルの外観を定義します。
public CalendarCellUpper Months {get;}

解説

カレンダー系列の月の名前のカレンダーセルの外観特性（フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Months.UpperCase = true;

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


NextMonthButton

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.NextMonthButton プロパティ

カレンダーを「翌月」にスクロールするボタンを返します。

public Button NextMonthButton {get;}

解説

カレンダーを「翌月」にスクロールするボタンを返します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Calendar.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get;}

解説

軸の矢印のペン特性を設定します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


PopupMenu

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.PopupMenu プロパティ

public ContextMenu PopupMenu {get;}

解説

すべての月名を表示するポップアップメニューの特性について定義します（ポップアップメニューは、カレンダー系列の月名を左クリックすると表示されます）。

このポップアップメニューは、要求する月への表示のために使用されます。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


PreviousMonthButton

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.PreviousMonthButton プロパティ

カレンダーを「前月」にスクロールするボタンを返します。

public Button PreviousMonthButton {get;}

解説

カレンダーを「前月」にスクロールするボタンを返します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Rows

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.Rows プロパティ

カレンダー系列の行数を返します。

public Int32 Rows {get;}

解説

カレンダー系列の行数を返します。

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Sunday

Steema.TeeChart.Styles.Calendar.Sunday プロパティ

すべての日曜のカレンダーセルの外観を定義します。
public CalendarCell Sunday {get;}

解説

カレンダー系列のすべての日曜のカレンダーセルの外観特性（フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Sunday.Color = Color.Green;

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Today

Steema.TeeChart.Styles.Calendar.Today プロパティ

当日のカレンダーセルの外観を定義します。
public CalendarCell Today {get;}

解説

カレンダー系列の当日のカレンダーセルの外観特性(フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Today.ShapeStyle = fosRoundRectangle;

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Trailing

Steema.TeeChart.Styles.Calendar.Trailing プロパティ

前月および次月の日付のカレンダーセルの外観を定義します。
public CalendarCell Trailing {get;}

解説

カレンダー系列の前後月の表示（当月に表示される前月の終わりの日付と翌月の初めの日付）のカレンダーセルの外観特性（フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Trailing.Visible = false;

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


WeekDays

Steema.TeeChart.Styles.Calendar.WeekDays プロパティ

曜日タイトルのカレンダーセルの外観を定義します。
public CalendarCellUpper WeekDays {get;}

解説

カレンダー系列の曜日タイトルのカレンダーセルの外観特性（フォント、色など）を定義します。

例

[C#]

Steema.TeeChart.Styles.Calendar Series1 = new Steema.TeeChart.Styles.Calendar();
tChart1.Series.Add(Series1);
Series1.Weekdays.Format = 'dddd';

参照

Calendar クラス | Calendar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCell

Steema.TeeChart.Styles.Calendar.CalendarCell クラス

カレンダーセルの特性。

この型のすべてのメンバの一覧については、CalendarCell メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class CalendarCell : TextShape , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CalendarCell メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCell 全メンバ

CalendarCell 概要

パブリック フィールド

Series
Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

コンストラクタ

Steema.TeeChart.Styles.Calendar.CalendarCell..ctor オーバーロード

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

CalendarCell クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCell フィールド

パブリック フィールド

Series
Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

CalendarCell クラス | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.Calendar+CalendarCell.Series フィールド

public Calendar Series

参照

CalendarCell クラス | CalendarCell メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCell メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

CalendarCell クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCell プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

CalendarCell クラス | Steema.TeeChart.Styles 名前空間


CalendarCell コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCell コンストラクタ

オーバーロードの一覧

public Calendar+CalendarCell()
public Calendar+CalendarCell(Steema.TeeChart.Styles.Calendar)

参照

CalendarCell クラス | CalendarCell メンバ | Steema.TeeChart.Styles 名前空間


Calendar+CalendarCell コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCell コンストラクタ

public Calendar+CalendarCell()

参照

CalendarCell コンストラクタのオーバーロードの一覧 | CalendarCell クラス | CalendarCell メンバ | Steema.TeeChart.Styles 名前空間


Calendar+CalendarCell コンストラクタ

Steema.TeeChart.Styles.Calendar+CalendarCell コンストラクタ

public Calendar+CalendarCell(Calendar s)

参照

CalendarCell コンストラクタのオーバーロードの一覧 | CalendarCell クラス | CalendarCell メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCellUpper

Steema.TeeChart.Styles.Calendar.CalendarCellUpper クラス

カレンダー系列の上部の行セルについての書式情報です。

この型のすべてのメンバの一覧については、CalendarCellUpper メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Styles.Calendar+CalendarCell
public sealed class CalendarCellUpper : CalendarCell , IComponent
, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCellUpper 全メンバ

CalendarCellUpper 概要

パブリック フィールド

Series (Calendar+CalendarCellの継承元)
Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Format | 月や曜日の日付値書式を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
UpperCase | 大文字で月と曜日の表示を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

コンストラクタ

Steema.TeeChart.Styles.Calendar.CalendarCellUpper..ctor オーバーロード

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

CalendarCellUpper クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCellUpper フィールド

パブリック フィールド

Series (Calendar+CalendarCellの継承元)
Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

CalendarCellUpper クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCellUpper メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

CalendarCellUpper クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarCellUpper プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Format | 月や曜日の日付値書式を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
UpperCase | 大文字で月と曜日の表示を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

CalendarCellUpper クラス | Steema.TeeChart.Styles 名前空間


Format

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCellUpper.Format プロパティ

月や曜日の日付値書式を定義します。

public String Format {get; set;}

解説

月や曜日の日付値書式を定義します。

参照

CalendarCellUpper クラス | CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


UpperCase

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCellUpper.UpperCase プロパティ

大文字で月と曜日の表示を有効/無効にします。

public Boolean UpperCase {get; set;}

解説

大文字で月と曜日の表示を有効/無効にします。

参照

CalendarCellUpper クラス | CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


CalendarCellUpper コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCellUpper コンストラクタ

オーバーロードの一覧

public Calendar+CalendarCellUpper()
public Calendar+CalendarCellUpper(Steema.TeeChart.Styles.Calendar)

参照

CalendarCellUpper クラス | CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


Calendar+CalendarCellUpper コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarCellUpper コンストラクタ

public Calendar+CalendarCellUpper()

参照

CalendarCellUpper コンストラクタのオーバーロードの一覧 | CalendarCellUpper クラス | CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


Calendar+CalendarCellUpper コンストラクタ

Steema.TeeChart.Styles.Calendar+CalendarCellUpper コンストラクタ

public Calendar+CalendarCellUpper(Calendar s)

参照

CalendarCellUpper コンストラクタのオーバーロードの一覧 | CalendarCellUpper クラス | CalendarCellUpper メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs クラス

Change イベントのデータを提供します。

この型のすべてのメンバの一覧については、CalendarChangeEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class CalendarChangeEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

CalendarChangeEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs 全メンバ

CalendarChangeEventArgs 概要

パブリック プロパティ

Date 日付を設定/取得します。

コンストラクタ

Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs

参照

CalendarChangeEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarChangeEventArgs プロパティ

パブリック プロパティ

Date 日付を設定/取得します。

参照

CalendarChangeEventArgs クラス | Steema.TeeChart.Styles 名前空間


Date

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarChangeEventArgs.Date プロパティ

日付を設定/取得します。

public DateTime Date {get; set;}

解説

カレンダーのグリッドの日付セルを設定します。

例

[C#]

calendarSeries1.Date = System.DateTime.FromOADate(37700);

参照

CalendarChangeEventArgs クラス | CalendarChangeEventArgs メンバ | Steema.TeeChart.Styles 名前空間


CalendarChangeEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Calendar+CalendarChangeEventArgs コンストラクタ

public Calendar+CalendarChangeEventArgs(DateTime dateTime)

参照

CalendarChangeEventArgs クラス | CalendarChangeEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Calendar.CalendarChangeEventHandler

Steema.TeeChart.Styles.Calendar.CalendarChangeEventHandler デリゲート

Changeイベントのデリゲート。
public delegate CalendarChangeEventHandler (Calendar sender,
     CalendarChangeEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Callout

Steema.TeeChart.Styles.Callout クラス

マーカの引出線の特性にアクセスします。

この型のすべてのメンバの一覧については、Callout メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
public class Callout : SeriesPointer , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Callout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Callout 全メンバ

Callout 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Draw (SeriesPointerの継承元) | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Arrow |
ArrowHead |
ArrowHeadSize |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | Sets ポインタの水平サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Draw
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

Callout クラス | Steema.TeeChart.Styles 名前空間


Callout コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Callout コンストラクタ

オーバーロードの一覧

public Callout()
public Callout(Steema.TeeChart.Styles.Series)

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Callout コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Callout コンストラクタ

public Callout()

参照

Callout コンストラクタのオーバーロードの一覧 | Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Callout コンストラクタ

Steema.TeeChart.Styles.Callout コンストラクタ

public Callout(Series s)

参照

Callout コンストラクタのオーバーロードの一覧 | Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Callout フィールド

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Callout クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Callout メソッド

パブリック メソッド

Draw (SeriesPointerの継承元) | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

Draw
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

Callout クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Callout.Draw メソッド

オーバーロードの一覧

protected internal Void Draw(System.Drawing.Color, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32, System.Boolean)

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Callout.Draw メソッド

protected internal Void Draw(Color c,
     Point pFrom,
     Point pMid,
     Point pTo,
     Int32 z,
     Boolean hasMid)

参照

Draw オーバーロードの一覧 | Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Callout.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Callout プロパティ

パブリック プロパティ

Arrow |
ArrowHead |
ArrowHeadSize |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを定義します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの垂直サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

参照

Callout クラス | Steema.TeeChart.Styles 名前空間


Arrow

Steema.TeeChart.Styles.Callout.Arrow プロパティ

public ChartPen Arrow {get; set;}

解説

系列マーカと系列ポイント間の線を表示する際に使用されるペンを設定します。また、アノテーションと系列ポイントを接続する線を描くアノテーションツールでも使用されます。

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


ArrowHead

Steema.TeeChart.Styles.Callout.ArrowHead プロパティ

public ArrowHeadStyles ArrowHead {get; set;}

解説

引き出し線の終わりに「矢印」ヘッドを表示するかどうか設定します。

オプションは、ArrowHeadStyle Enumを参照してください。

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


ArrowHeadSize

Steema.TeeChart.Styles.Callout.ArrowHeadSize プロパティ

public Int32 ArrowHeadSize {get; set;}

解説

引き出し線の末端に表示する矢頭サイズをピクセル単位で定義します。

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Distance

Steema.TeeChart.Styles.Callout.Distance プロパティ

public Int32 Distance {get; set;}

解説

系列ポイントと引き出し線との間の長さをピクセル単位で定義します。

参照

Callout クラス | Callout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle

Steema.TeeChart.Styles.Candle クラス

キャンドル系列。

この型のすべてのメンバの一覧については、Candle メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
public class Candle : OHLC , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Candle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle 全メンバ

Candle 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedCandle | Point pがValueIndex番目のキャンドルポイントの境界内にある場合、trueを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
CandleWidth | キャンドルの幅をピクセル単位で設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DownCloseColor | 終値が始値より大きい場合のキャンドルの色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighLowPen | 「高値」や「安値」の線を描くために使用されるペンを定義します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowClose | 終値を表示するかどうか設定します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
ShowOpen | 始値を表示するかどうか設定します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Style | キャンドルのポイントスタイルを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpCloseColor | 始値が終値より大きい時のキャンドルの色を設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Candle クラス | Steema.TeeChart.Styles 名前空間


Candle コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle コンストラクタ

オーバーロードの一覧

public Candle(Steema.TeeChart.Chart)
public Candle()

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Candle コンストラクタ

Steema.TeeChart.Styles.Candle コンストラクタ

public Candle(Chart c)

参照

Candle コンストラクタのオーバーロードの一覧 | Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Candle コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle コンストラクタ

public Candle()

参照

Candle コンストラクタのオーバーロードの一覧 | Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前に、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
ClickPointer (CustomPointの継承元) | ポイントがクリックされると発生します。
DblClick (Seriesの継承元) | ダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタの描画の際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Candle クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Candle クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle メソッド

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedCandle | Point pがValueIndex番目のキャンドルポイントの境界内にある場合、trueを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Candle クラス | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Candle.Clicked メソッド

オーバーロードの一覧

系列の「クリックされた」ポイントのValueIndexを返します。

public override Int32 Clicked(System.Int32, System.Int32)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Candle.Clicked メソッド

系列の「クリックされた」ポイントのValueIndexを返します。
public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


ClickedCandle

Steema.TeeChart.Styles.Candle.ClickedCandle メソッド

Point pがValueIndex番目のキャンドルポイントの境界内にある場合、trueを返します。
public Boolean ClickedCandle(Int32 valueIndex,
     Point p)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Candle.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.Candle.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.DrawValue メソッド

内部的に呼び出されます。指定したValueIndexパラメーターの系列ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。直接呼び出す必要はありません。指定したValueIndexパラメーターの系列ポイントを描画します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Candle.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.Candle.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 index)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Candle.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Candle.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Candle.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Candle プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
CandleWidth | キャンドルの幅をピクセル単位で設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DownCloseColor | 終値が始値より大きい場合のキャンドルの色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighLowPen | 「高値」や「安値」の線を描くために使用されるペンを定義します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowClose | 終値を表示するかどうか設定します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
ShowOpen | 始値を表示するかどうか設定します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Style | キャンドルのポイントスタイルを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpCloseColor | 始値が終値より大きい時のキャンドルの色を設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Candle クラス | Steema.TeeChart.Styles 名前空間


CandleWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.CandleWidth プロパティ

キャンドルの幅をピクセル単位で設定します。

public Int32 CandleWidth {get; set;}

解説

デフォルト値：6

キャンドルの幅をピクセル単位で設定します。これは、画面チャートのピクセルに基づいています。
印刷の場合、この数はプリンター幅と画面幅の間の比較によって加減されます。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Candle.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


DownCloseColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.DownCloseColor プロパティ

終値が始値より大きい場合のキャンドルの色を設定します。

public Color DownCloseColor {get; set;}

解説

デフォルトは、UpCloseColorはWhiteでDownCloseColorはRedです。

各キャンドルは、始値や終値により異なった色で塗りつぶされます。

始値が終値より大きい場合、UpCloseColorプロパティで設定された色になります。

終値が始値と等しいか大きい場合、DownCloseColorプロパティで設定された色になります。

例

デザイン時または実行時に色値を変更できます。

[C#]

((Steema.TeeChart.Styles.Calendar)tChart1[5]).UpCloseColor = Color.DarkCyan;
((Steema.TeeChart.Styles.Calendar)tChart1[5]).DownCloseColor = Color.Coral;

ChartクラスのCandleSeries1を強制的に再描画します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


HighLowPen

Steema.TeeChart.Styles.Candle.HighLowPen プロパティ

「高値」や「安値」の線を描くために使用されるペンを定義します。
public ChartPen HighLowPen {get;}

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Candle.Pen プロパティ

public ChartPen Pen {get;}

解説

ペン特性のエレメント。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


ShowClose

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.ShowClose プロパティ

終値を表示するかどうか設定します。

public Boolean ShowClose {get; set;}

解説

デフォルト値：true

終値を表示をするかどうか設定します。このプロパティは、CandleSeries.CandleStyleがcsCandleBarに設定されている場合にのみ有効です。CandleWidthプロパティは、始値と終値の幅をピクセル単位で定義します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


ShowOpen

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.ShowOpen プロパティ

始値を表示するかどうか設定します。

public Boolean ShowOpen {get; set;}

解説

デフォルト値：true

始値の表示をするかどうか設定します。このプロパティは、CandleSeries.CandleStyleがcsCandleBarに設定されている場合にのみ有効です。CandleWidthプロパティは、始値と終値の幅をピクセル単位で定義します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.Candle.Style プロパティ

キャンドルのポイントスタイルを定義します。
public CandleStyles Style {get; set;}

解説

デフォルト値：CandleStick

キャンドルのポイントスタイルを定義します。CandleStickの場合は、垂直方向の矩形で各キャンドルポイントを描画します。CandleBarの場合は、垂直線を描画し、始値と終値のポイントを水平線で描画します。キャンドルの色と幅は設定できます。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


UpCloseColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Candle.UpCloseColor プロパティ

始値が終値より大きい時のキャンドルの色を設定します。

public Color UpCloseColor {get; set;}

解説

デフォルトは、UpCloseColorは白でDownCloseColorは赤です。

各キャンドルは、始値と終値により異なる色で塗りつぶされます。

始値が終値より大きい場合、UpCloseColorプロパティで設定された色になります。

終値が始値より大きいか等しい場合、DownCloseColorプロパティで設定された色になります。

例

デザイン時または実行時に色の値を変更できます。

[C#]

((Steema.TeeChart.Styles.Calendar)tChart1[5]).UpCloseColor = Color.DarkCyan;
((Steema.TeeChart.Styles.Calendar)tChart1[5]).DownCloseColor = Color.Coral;

CandleSeries1を含むChartクラスを強制的に再描画します。

参照

Candle クラス | Candle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CandleStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CandleStyles 列挙体

Styleプロパティの使用可能な値です。
[Serializable]
public enum CandleStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
CandleStick | 始値と終値の垂直方向の目盛を持つ垂直方向の矩形で描画されます。
CandleBar | 始値と終値の水平方向の目盛を持つ垂直方向の線で描画されます。
OpenClose | 始値と終値の垂直方向の目盛なしの垂直方向の矩形で描画されます。
Line | 線で描画されます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CellsOrientation

Steema.TeeChart.Styles.CellsOrientation 値型

この型のすべてのメンバの一覧については、CellsOrientation メンバを参照してください。

System.Object
System.ValueType
public sealed struct CellsOrientation : ValueType

参照

CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CellsOrientation 全メンバ

CellsOrientation 概要

パブリック フィールド

EndX
EndZ
IncX
IncZ
InitX
InitZ

参照

CellsOrientation 構造体 | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CellsOrientation フィールド

パブリック フィールド

EndX
EndZ
IncX
IncZ
InitX
InitZ

参照

CellsOrientation 構造体 | Steema.TeeChart.Styles 名前空間


EndX

Steema.TeeChart.Styles.CellsOrientation.EndX フィールド

public Int32 EndX

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


EndZ

Steema.TeeChart.Styles.CellsOrientation.EndZ フィールド

public Int32 EndZ

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


IncX

Steema.TeeChart.Styles.CellsOrientation.IncX フィールド

public Int32 IncX

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


IncZ

Steema.TeeChart.Styles.CellsOrientation.IncZ フィールド

public Int32 IncZ

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


InitX

Steema.TeeChart.Styles.CellsOrientation.InitX フィールド

public Int32 InitX

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


InitZ

Steema.TeeChart.Styles.CellsOrientation.InitZ フィールド

public Int32 InitZ

参照

CellsOrientation 構造体 | CellsOrientation メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular

Steema.TeeChart.Styles.Circular クラス

サークル系列。

この型のすべてのメンバの一覧については、Circular メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Circular : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Circular メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular 全メンバ

Circular 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
PiDegree | 定数のΦ/180を表します。
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle | XYパラメーターから円の中心までの角度を返します。
PointToRadius | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor | 楕円を塗りつぶす色を設定します。
Circled | サークル系列を楕円あるいは円で描画します。
CircleGradient | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight | 円の高さを返します。
CircleRect | 円に隣接する矩形を返します。
CircleWidth | 円の幅を返します。
CircleXCenter | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RotationAngle | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight
iCircleWidth
iCircleXCenter
iCircleYCenter
InternalUse (TeeBaseの継承元)
iXRadius
iYRadius
lastVisible (Seriesの継承元)
rCircleRect
rotDegree
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect |
AssociatedToAxis |
CalcCircleBackColor |
CalcCircleGradient |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties |
SetRotationAngle |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Circular クラス | Steema.TeeChart.Styles 名前空間


Circular コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular コンストラクタ

オーバーロードの一覧

public Circular()
public Circular(Steema.TeeChart.Chart)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Circular コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular コンストラクタ

public Circular()

参照

Circular コンストラクタ オーバーロードの一覧 | Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Circular コンストラクタ

Steema.TeeChart.Styles.Circular コンストラクタ

public Circular(Chart c)

参照

Circular コンストラクタのオーバーロードの一覧 | Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Circular クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
PiDegree | 定数のΦ/180を表します。
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight
iCircleWidth
iCircleXCenter
iCircleYCenter
InternalUse (TeeBaseの継承元)
iXRadius
iYRadius
lastVisible (Seriesの継承元)
rCircleRect
rotDegree
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Circular クラス | Steema.TeeChart.Styles 名前空間


iCircleHeight

Steema.TeeChart.Styles.Circular.iCircleHeight フィールド

protected Int32 iCircleHeight

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


iCircleWidth

Steema.TeeChart.Styles.Circular.iCircleWidth フィールド

protected Int32 iCircleWidth

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


iCircleXCenter

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.iCircleXCenter フィールド

protected Int32 iCircleXCenter

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


iCircleYCenter

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.iCircleYCenter フィールド

protected Int32 iCircleYCenter

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


iXRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.iXRadius フィールド

protected Int32 iXRadius

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


iYRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.iYRadius フィールド

protected Int32 iYRadius

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


PiDegree

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.PiDegree フィールド

定数のΦ/180を表します。
public const Double PiDegree

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


rCircleRect

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.rCircleRect フィールド

protected Rectangle rCircleRect

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


rotDegree

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.rotDegree フィールド

protected Double rotDegree

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle | XYパラメーターから円の中心までの角度を返します。
PointToRadius | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect |
AssociatedToAxis |
CalcCircleBackColor |
CalcCircleGradient |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties |
SetRotationAngle |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Circular クラス | Steema.TeeChart.Styles 名前空間


AdjustCircleRect

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.AdjustCircleRect メソッド

protected Void AdjustCircleRect()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


AngleToPos

Steema.TeeChart.Styles.Circular.AngleToPos メソッド

指定した角度と半径の画面位置を返します。
public abstract Void AngleToPos(Double angle,
     Double aXRadius,
     Double aYRadius,
     Int32& x,
     Int32& y)

解説

指定した角度と半径の画面位置を返します。

最初のパラメーターのAngle（角度）は、デフォルトとして「東」をゼロ度の反時計周りとして角度を指定してください。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.Circular.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


AssociatedToAxis

Steema.TeeChart.Styles.Circular.AssociatedToAxis メソッド

protected internal abstract Boolean AssociatedToAxis(Axis a)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CalcCircleBackColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CalcCircleBackColor メソッド

protected Color CalcCircleBackColor()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CalcCircleGradient

Steema.TeeChart.Styles.Circular.CalcCircleGradient メソッド

protected Gradient CalcCircleGradient()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CalcRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CalcRadius メソッド

protected Void CalcRadius()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.Circular.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


OnDisposing

Steema.TeeChart.Styles.Circular.OnDisposing メソッド

protected internal abstract Void OnDisposing()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


PointToAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.PointToAngle メソッド

XYパラメーターから円の中心までの角度を返します。
public Double PointToAngle(Int32 x,
     Int32 y)

解説

このメソッドは、XYパラメーターから円の中心までの角度を返します。これは、現在、正円でのみ動作します。

角度を計算するために使用される式：

result:=ArcTan(Abs(y-YCenter)/Abs(x-XCenter));
角度は0から2*PIのラジアンで返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


PointToRadius

Steema.TeeChart.Styles.Circular.PointToRadius メソッド

XYポイントから円の中心までの半径を返します。
public Double PointToRadius(Int32 x,
     Int32 y)

解説

チャートの左軸スケールを使用してXYポイント座標に該当する半径値をピクセル単位で返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.Circular.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Rotate

Steema.TeeChart.Styles.Circular.Rotate メソッド

回転しているチャートの角度を返します。
public Void Rotate(Int32 angle)

解説

回転しているチャートの角度を返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


SetActive

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.SetActive メソッド

protected abstract Void SetActive(Boolean value)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Circular.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


SetParent プロパティ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.SetParentProperties メソッド

protected abstract Void SetParentProperties(Boolean enableParentProps)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


SetRotationAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.SetRotationAngle メソッド

protected Void SetRotationAngle(Int32 value)

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeCircleBackColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.ShouldSerializeCircleBackColor メソッド

protected abstract Boolean ShouldSerializeCircleBackColor()

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Circular プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor | 楕円を塗りつぶす色を設定します。
Circled | サークル系列を楕円あるいは円で描画します。
CircleGradient | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight | 円の高さを返します。
CircleRect | 円に隣接する矩形を返します。
CircleWidth | 円の幅を返します。
CircleXCenter | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RotationAngle | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Circular クラス | Steema.TeeChart.Styles 名前空間


CircleBackColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleBackColor プロパティ

楕円を塗りつぶす色を設定します。

public Color CircleBackColor {get; set;}

解説

デフォルト値：clTeeColor

楕円を塗りつぶす色を設定します。clTeeColorに設定するとtChart.Panel.Colorの色にCircledSeriesを使用します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Circled

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.Circled プロパティ

サークル系列を楕円あるいは円で描画します。

public Boolean Circled {get; set;}

解説

デフォルト値：false

円系列などのCircledSeriesを楕円状に描くか、XとY半径を同じ（つまり円）にして描くかを定義します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleGradient

Steema.TeeChart.Styles.Circular.CircleGradient プロパティ

楕円を塗りつぶすグラデーションを設定します。
public Gradient CircleGradient {get; set;}

解説

楕円を塗りつぶすグラデーションを設定します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleHeight

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleHeight プロパティ

円の高さを返します。

public Int32 CircleHeight {get;}

解説

実行時および読込み専用。

円の高さを返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleRect

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleRect プロパティ

円に隣接する矩形を返します。

public Rectangle CircleRect {get;}

解説

読込み専用。

デフォルト位置（仰角、回転などの置換は適用されません）の円（例えば円系列）に隣接している矩形をピクセル単位で返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleWidth プロパティ

円の幅を返します。

public Int32 CircleWidth {get;}

解説

実行時および読込み専用。

円の幅を返します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleXCenter

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleXCenter プロパティ

楕円の中心の正確な水平位置をピクセル単位で返します。

public Int32 CircleXCenter {get;}

解説

実行時および読込み専用。楕円の中心の正確な水平位置をピクセル単位で返します。

楕円の半径はCircledSeries.XRadiusやYRadiusプロパティにより設定されます。AngleToPoint関数は角度からXとYの画面座標に切り替えます。PointToAngle関数はXY画面位置から角度に切り替えます。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CircleYCenter

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.CircleYCenter プロパティ

楕円の中心の正確な垂直位置をピクセル単位で返します。

public Int32 CircleYCenter {get;}

解説

実行時および読込み専用。楕円の中心の正確な垂直位置をピクセル単位で返します。
楕円の半径はCircledSeries.XRadiusやYRadiusプロパティにより設定されます。AngleToPoint関数は角度からXやYの画面座標に切り替えます。PointToAngle関数はXY画面位置から角度に切り替えます。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CustomXRadius

Steema.TeeChart.Styles.Circular.CustomXRadius プロパティ

楕円の水平半径をピクセル単位で設定します。
public Int32 CustomXRadius {get; set;}

解説

デフォルト値：0

楕円領域を計算するために使用される水平の大きさをピクセル単位で示します。
ゼロに設定すると、サークル系列が自動的に適切な楕円半径を計算します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


CustomYRadius

Steema.TeeChart.Styles.Circular.CustomYRadius プロパティ

楕円の垂直半径をピクセル単位で設定します。
public Int32 CustomYRadius {get; set;}

解説

デフォルト値：0

楕円領域を計算するために使用される垂直の大きさをピクセル単位で示します。
ゼロに設定すると、サークル系列が自動的に適切な楕円半径を計算します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


RotationAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.RotationAngle プロパティ

チャートの回転角度を設定します。

public Int32 RotationAngle {get; set;}

解説

0～359までの有効な整数を指定できます。この角度は、円系列（あるいは極系列）を回転するためにコードにより変更できます。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


XRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.XRadius プロパティ

楕円の水平方向の半径のサイズをピクセル単位で設定/返します。

public Int32 XRadius {get;}

解説

楕円の水平方向の半径のサイズをピクセル単位で設定/返します。CircledSeries.Circledプロパティは、両方の半径が画面のX/Y比率と比例しなければならない場合に制御します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


YRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Circular.YRadius プロパティ

楕円の垂直方向の半径のサイズをピクセル単位で設定/返します。

public Int32 YRadius {get;}

解説

楕円の垂直方向の半径のサイズをピクセル単位で設定/返します。CircledSeries.Circledプロパティは両方の半径が画面のX/Y比率と比例しなければならない場合に制御します。

参照

Circular クラス | Circular メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge

Steema.TeeChart.Styles.CircularGauge クラス

円形ゲージ系列。

この型のすべてのメンバの一覧については、CircularGauge メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class CircularGauge : Circular , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge 全メンバ

CircularGauge 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged | ゲージ系列のValueプロパティが変更されると発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis | 円形ゲージの軸特性を取得します。
Center | ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndPoint | ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush | 円形ゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | フレームは、円形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
GreenLine | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue | 「緑線」マーカの開始値を取得/設定します。
Hand | 針オブジェクトの特性を取得/設定します。
HandDistance | ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
HandOffset | 針の後部と中心までの長さをピクセル単位で定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsInside | ゲージの軸ラベルを外側/内側に表示します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 円形ゲージの曲がった軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue | 「赤線」マーカの開始値を取得/設定します。
RotateLabels | Trueの場合、円形ゲージの軸のカーブに沿った回転付きのラベルを表示します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TotalAngle | ゲージ軸の大きさを度数で取得/設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Circularの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
OnValueChanged |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CircularGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge コンストラクタ

オーバーロードの一覧

public CircularGauge()
public CircularGauge(Steema.TeeChart.Chart)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge コンストラクタ

public CircularGauge()

参照

CircularGauge コンストラクタのオーバーロードの一覧 | CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge コンストラクタ

public CircularGauge(Chart c)

参照

CircularGauge コンストラクタのオーバーロードの一覧 | CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged | ゲージ系列のValueプロパティが変更されると発生します。

参照

CircularGauge クラス | Steema.TeeChart.Styles 名前空間


ValueChanged

Steema.TeeChart.Styles.CircularGauge.ValueChanged イベント

ゲージ系列のValueプロパティが変更された際に発生します。
public GaugesChangeHandler  ValueChanged

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CircularGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Circularの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
OnValueChanged |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CircularGauge クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.CircularGauge.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.CircularGauge.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.CircularGauge.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.CircularGauge.Draw メソッド

public override Void Draw()

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


OnValueChanged

Steema.TeeChart.Styles.CircularGauge.OnValueChanged メソッド

protected abstract Void OnValueChanged(EventArgs e)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CircularGauge.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.CircularGauge.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CircularGauge プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis | 円形ゲージの軸特性を取得します。
Center | ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndPoint | ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush | 円形ゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | フレームは、円形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
GreenLine | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue | 「緑線」マーカの開始値を取得/設定します。
Hand | 針オブジェクトの特性を取得/設定します。
HandDistance | ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
HandOffset | 針の後部と中心までの長さをピクセル単位で定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsInside | ゲージの軸ラベルを外側/内側に表示します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 円形ゲージの曲がった軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue | 「赤線」マーカの開始値を取得/設定します。
RotateLabels | Trueの場合、円形ゲージの軸のカーブに沿った回転付きのラベルを表示します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TotalAngle | ゲージ軸の大きさを度数で取得/設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CircularGauge クラス | Steema.TeeChart.Styles 名前空間


Axis

Steema.TeeChart.Styles.CircularGauge.Axis プロパティ

円形ゲージの軸特性を取得します。
public Axis Axis {get;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Center

Steema.TeeChart.Styles.CircularGauge.Center プロパティ

ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
public GaugeSeriesPointer Center {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.CircularGauge.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


EndPoint

Steema.TeeChart.Styles.CircularGauge.EndPoint プロパティ

値を指す針の前方にあるポインタ特性にアクセスします。
public SeriesPointer EndPoint {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


FaceBrush

Steema.TeeChart.Styles.CircularGauge.FaceBrush プロパティ

円形ゲージの計器盤のChartBrush特性を取得/設定します。
public ChartBrush FaceBrush {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Frame

Steema.TeeChart.Styles.CircularGauge.Frame プロパティ

フレームは、円形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
public TFrame Frame {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


GaugeColorPalette

Steema.TeeChart.Styles.CircularGauge.GaugeColorPalette プロパティ

円形ゲージのカラーパレットを取得/設定します。
public Color[] GaugeColorPalette {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLine

Steema.TeeChart.Styles.CircularGauge.GreenLine プロパティ

「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
public GaugeSeriesPointer GreenLine {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLineEndValue

Steema.TeeChart.Styles.CircularGauge.GreenLineEndValue プロパティ

「緑線」マーカの終了値を取得/設定します。
public Double GreenLineEndValue {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLineStartValue

Steema.TeeChart.Styles.CircularGauge.GreenLineStartValue プロパティ

「緑線」マーカの開始値を取得/設定します。
public Double GreenLineStartValue {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Hand

Steema.TeeChart.Styles.CircularGauge.Hand プロパティ

針オブジェクトの特性を取得/設定します。
public GaugeSeriesPointer Hand {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


HandDistance

Steema.TeeChart.Styles.CircularGauge.HandDistance プロパティ

ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
public Int32 HandDistance {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


HandOffset

Steema.TeeChart.Styles.CircularGauge.HandOffset プロパティ

針の後部と中心までの長さをピクセル単位で定義します。
public Int32 HandOffset {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


LabelsInside

Steema.TeeChart.Styles.CircularGauge.LabelsInside プロパティ

ゲージの軸ラベルを外側/内側に表示します。
public Boolean LabelsInside {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Maximum

Steema.TeeChart.Styles.CircularGauge.Maximum プロパティ

ゲージの最大値を取得/設定します。
public Double Maximum {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Minimum

Steema.TeeChart.Styles.CircularGauge.Minimum プロパティ

ゲージの最小値を取得/設定します。
public Double Minimum {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


MinorTickDistance

Steema.TeeChart.Styles.CircularGauge.MinorTickDistance プロパティ

円形ゲージの曲がった軸から離す副目盛の位置（距離）をピクセル単位で設定します。
public Int32 MinorTickDistance {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


MinorTicks

Steema.TeeChart.Styles.CircularGauge.MinorTicks プロパティ

軸の副目盛の特性を取得/設定します。
public GaugeSeriesPointer MinorTicks {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLine

Steema.TeeChart.Styles.CircularGauge.RedLine プロパティ

「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
public GaugeSeriesPointer RedLine {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLineEndValue

Steema.TeeChart.Styles.CircularGauge.RedLineEndValue プロパティ

「赤線」マーカの終了値を取得/設定します。
public Double RedLineEndValue {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLineStartValue

Steema.TeeChart.Styles.CircularGauge.RedLineStartValue プロパティ

「赤線」マーカの開始値を取得/設定します。
public Double RedLineStartValue {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


RotateLabels

Steema.TeeChart.Styles.CircularGauge.RotateLabels プロパティ

Trueの場合、円形ゲージの軸のカーブに沿った回転付きのラベルを表示します。
public Boolean RotateLabels {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Ticks

Steema.TeeChart.Styles.CircularGauge.Ticks プロパティ

軸の目盛の特性を取得/設定します。
public GaugeSeriesPointer Ticks {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


TotalAngle

Steema.TeeChart.Styles.CircularGauge.TotalAngle プロパティ

ゲージ軸の大きさを度数で取得/設定します。
public Double TotalAngle {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Value

Steema.TeeChart.Styles.CircularGauge.Value プロパティ

ゲージの矢印線の位置を取得/設定します。
public Double Value {get; set;}

参照

CircularGauge クラス | CircularGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock

Steema.TeeChart.Styles.Clock クラス

時計系列。

この型のすべてのメンバの一覧については、Clock メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Custom2DPolar
public class Clock : Custom2DPolar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Clock メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock 全メンバ

Clock 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom2DPolarの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Custom2DPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PenHours | 時計の短針のペンを定義します。
PenMinutes | 時計の長針のペンを定義します。
PenSeconds | 時計の秒針のペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Style | 時計の時間表示のスタイルをローマ数字あるいは10進に設定します。
Timer | 時計系列で使用されるタイマーを返します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Clock クラス | Steema.TeeChart.Styles 名前空間


Clock コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Clock コンストラクタ

オーバーロードの一覧

public Clock()
public Clock(Steema.TeeChart.Chart)

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Clock コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Clock コンストラクタ

public Clock()

参照

Clock コンストラクタのオーバーロードの一覧 | Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Clock コンストラクタ

Steema.TeeChart.Styles.Clock コンストラクタ

public Clock(Chart c)

参照

Clock コンストラクタのオーバーロードの一覧 | Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Clock クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Clock クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom2DPolarの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Custom2DPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Clock クラス | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.Clock.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Clock.Draw メソッド

public override Void Draw()

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


GetCircleLabel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Clock.GetCircleLabel メソッド

protected virtual String GetCircleLabel(Double angle,
     Int32 index)

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Clock.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Clock.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Clock プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PenHours | 時計の短針のペンを定義します。
PenMinutes | 時計の長針のペンを定義します。
PenSeconds | 時計の秒針のペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Style | 時計の時間表示のスタイルをローマ数字あるいは10進に設定します。
Timer | 時計系列で使用されるタイマーを返します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Clock クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Clock.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


PenHours

Steema.TeeChart.Styles.Clock.PenHours プロパティ

時計の短針のペンを定義します。
public ChartPen PenHours {get;}

解説

時計の短針のペンを定義します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


PenMinutes

Steema.TeeChart.Styles.Clock.PenMinutes プロパティ

時計の長針のペンを定義します。
public ChartPen PenMinutes {get;}

解説

時計の長針のペンを定義します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


PenSeconds

Steema.TeeChart.Styles.Clock.PenSeconds プロパティ

時計の秒針のペンを定義します。
public ChartPen PenSeconds {get;}

解説

時計の秒針のペンを定義します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.Clock.Style プロパティ

時計の時間表示のスタイルをローマ数字あるいは10進に設定します。
public ClockStyles Style {get; set;}

解説

デフォルト値：Roman

時計の時間表示のスタイルをローマ数字あるいは10進に設定します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Timer

Steema.TeeChart.Styles.Clock.Timer プロパティ

時計系列で使用されるタイマーを返します。
public Timer Timer {get;}

解説

内部タイマーは実行時に時計の秒針を表示するために使用されます。
TimerIntervalプロパティを一秒未満に設定すると必要以上にCPUのリソースを消費します。

参照

Clock クラス | Clock メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ClockStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ClockStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum ClockStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Decimal | 時計の時間表示を10進にします。
Roman | 時計の時間表示をローマ数字にします。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid

Steema.TeeChart.Styles.ColorGrid クラス

カラーグリッド系列は、色のセルのグリッドを描画します。

この型のすべてのメンバの一覧については、ColorGrid メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class ColorGrid : Custom3DGrid , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid 全メンバ

ColorGrid 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue |
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue |
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Bitmap | カラーグリッド内にビットマップを表示するために使用してください。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
CenteredPoints |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XStep |
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZStep |
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

ColorGrid クラス | Steema.TeeChart.Styles 名前空間


ColorGrid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid コンストラクタ

オーバーロードの一覧

public ColorGrid(Steema.TeeChart.Chart)
public ColorGrid()

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


ColorGrid コンストラクタ

Steema.TeeChart.Styles.ColorGrid コンストラクタ

public ColorGrid(Chart c)

参照

ColorGrid コンストラクタのオーバーロードの一覧 | ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


ColorGrid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid コンストラクタ

public ColorGrid()

参照

ColorGrid コンストラクタのオーバーロードの一覧 | ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

ColorGrid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

ColorGrid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue |
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue |
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

ColorGrid クラス | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.ColorGrid.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのValueIndexを返します。

public override Int32 Clicked(System.Int32, System.Int32)

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.ColorGrid.Clicked メソッド

系列で「クリックされた」ポイントのValueIndexを返します。

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.ColorGrid.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.ColorGrid.Draw メソッド

public override Void Draw()

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.ColorGrid.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.ColorGrid.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MaxZValue メソッド

public virtual Double MaxZValue()

解説

カラーグリッド系列の最大Z値を返します。
CenteredPointsプロパティによりこの最大値は最大Z値プラス0.5になります。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MinXValue メソッド

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorGrid.MinZValue メソッド

public virtual Double MinZValue()

解説

カラーグリッド系列の最小Z値を返します。
CenteredPointsプロパティによりこの最小値は最小Z値より0.5少ない値になります。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.ColorGrid.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorGrid プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Bitmap | カラーグリッド内にビットマップを表示するために使用してください。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
CenteredPoints |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XStep |
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZStep |
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

ColorGrid クラス | Steema.TeeChart.Styles 名前空間


Bitmap

Steema.TeeChart.Styles.ColorGrid.Bitmap プロパティ

カラーグリッド内にビットマップを表示するために使用してください。
public Bitmap Bitmap {get; set;}

例

この例は、ColorGrid.Bitmapプロパティの使用方法を説明しています。

private void SetFlower() {
    MemoryStream ms = new MemoryStream();
    Image flower = pictureBox1.Image;
    flower.Save(ms, System.Drawing.Imaging.ImageFormat.Jpeg);
    Bitmap bm = new Bitmap(ms);
    colorGrid1.Bitmap = bm;
}

解説

カラーグリッド内にビットマップを表示するために使用してください。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


CenteredPoints

Steema.TeeChart.Styles.ColorGrid.CenteredPoints プロパティ

public Boolean CenteredPoints {get; set;}

解説

デフォルト値：True

このプロパティは、「X」値と「Z」値をどのように考慮するか制御します。

Trueの場合、X値とZ値は各グリッドセルの中央ポイントを定義します。
Falseの場合、X値とZ値はグリッドセルの「角」地を定義します。

従って、Falseの場合、1つ少ない列と1つ少ないグリッドセルの行があります。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.ColorGrid.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


XStep

Steema.TeeChart.Styles.ColorGrid.XStep プロパティ

public Int32 XStep {get; set;}

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


ZStep

Steema.TeeChart.Styles.ColorGrid.ZStep プロパティ

public Int32 ZStep {get; set;}

参照

ColorGrid クラス | ColorGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList

Steema.TeeChart.Styles.ColorList クラス

このクラスは、SeriesのColorsプロパティによって操作されます。

この型のすべてのメンバの一覧については、ColorList メンバを参照してください。

System.Object
System.Collections.Generic.List<System.Drawing.Color>
[Serializable]
public sealed class ColorList : List<Color>
, IList<Color>, ICollection<Color>, IEnumerable<Color>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList 全メンバ

ColorList 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

ColorList クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList コンストラクタ

オーバーロードの一覧

public ColorList()
public ColorList(System.Int32)

参照

ColorList クラス | ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList コンストラクタ

public ColorList()

参照

ColorList コンストラクタのオーバーロードの一覧 | ColorList クラス | ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList コンストラクタ

public ColorList(Int32 capacity)

参照

ColorList コンストラクタのオーバーロードの一覧 | ColorList クラス | ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList コンストラクタ

public ColorList(Color[] colors)

参照

ColorList コンストラクタのオーバーロードの一覧 | ColorList クラス | ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ColorList プロパティ

パブリック プロパティ

Item

参照

ColorList クラス | Steema.TeeChart.Styles 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ColorList.Item プロパティ

public Color Item(Int32 index) {get; set;}

参照

ColorList クラス | ColorList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour

Steema.TeeChart.Styles.Contour クラス

等高線系列はXYZポイントのカスタム配列から「等高線」を計算し、描画します。

この型のすべてのメンバの一覧については、Contour メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class Contour : Custom3DGrid , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour 全メンバ

Contour 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
DrawLevel |
GetLevel |
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
LinesColor | デフォルトの等高線レベルの線のペン色。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | 「クリックされた」ポイントのインデックス。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateAutoLevels |
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutomaticLevels | 等高線系列を自動レベルに設定します。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ContourMarks | 等高線マーカの特別な特性を取得/設定します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DrawingAlgorithm | 等高線系列のレベル構造と描画アルゴリズム。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FillLevels | Trueの場合、等高線レベルを塗りつぶします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | 系列の境界を表すフレーム特性を定義します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GetZAxis | 関連付けられているZ軸を返します。3Dモードの場合、深さ軸を返し、その他は系列のデフォルトの垂直軸を返します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Levels | 指定したインデックスにより等高線レベルの特性にアクセスします。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumLevels | 等高線系列のレベル数を設定します。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 等高線系列のポインタ特性を取得/設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YPosition | 等高線系列のY軸の高さを設定します。
YPositionLevel | YPositionプロパティの設定を有効/無効にします。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iModifyingLevels
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Contour クラス | Steema.TeeChart.Styles 名前空間


Contour コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour コンストラクタ

オーバーロードの一覧

public Contour(Steema.TeeChart.Chart)
public Contour()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Contour コンストラクタ

Steema.TeeChart.Styles.Contour コンストラクタ

public Contour(Chart c)

参照

Contour コンストラクタのオーバーロードの一覧 | Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Contour コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour コンストラクタ

public Contour()

参照

Contour コンストラクタのオーバーロードの一覧 | Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
DrawLevel |
GetLevel |
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Contour クラス | Steema.TeeChart.Styles 名前空間


DrawLevel

Steema.TeeChart.Styles.Contour.DrawLevel イベント

public DrawLevelEventHandler  DrawLevel

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


GetLevel

Steema.TeeChart.Styles.Contour.GetLevel イベント

public GetLevelEventHandler  GetLevel

解説

レベルを追加する前にレベルに関連する変更を加えるために、このイベントを使用してください。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
LinesColor | デフォルトの等高線レベルの線のペン色。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iModifyingLevels
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Contour クラス | Steema.TeeChart.Styles 名前空間


iModifyingLevels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.iModifyingLevels フィールド

protected internal Boolean iModifyingLevels

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


LinesColor

Steema.TeeChart.Styles.Contour.LinesColor フィールド

デフォルトの等高線レベルの線のペン色。
public Color LinesColor

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | 「クリックされた」ポイントのインデックス。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateAutoLevels |
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Contour クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Contour.Clicked メソッド

オーバーロードの一覧

「クリックされた」ポイントのインデックス。

public override Int32 Clicked(System.Int32, System.Int32)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Contour.Clicked メソッド

「クリックされた」ポイントのインデックス。
public override Int32 Clicked(Int32 x,
     Int32 y)

パラメーター

x
画面X位置。
y
画面Y位置。

戻り値

「クリックされた」ポイントのインデックス。

参照

Clicked オーバーロードの一覧 | Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


CreateAutoLevels

Steema.TeeChart.Styles.Contour.CreateAutoLevels メソッド

public Void CreateAutoLevels()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Contour.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Contour.Draw メソッド

public override Void Draw()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Contour.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Contour.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


DrawMarks

Steema.TeeChart.Styles.Contour.DrawMarks メソッド

protected abstract Void DrawMarks()

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.Contour.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 legendIndex)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Contour.LegendString メソッド

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Contour.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Contour.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutomaticLevels | 等高線系列を自動レベルに設定します。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ContourMarks | 等高線マーカの特別な特性を取得/設定します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DrawingAlgorithm | 等高線系列のレベル構造と描画アルゴリズム。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FillLevels | Trueの場合、等高線レベルを塗りつぶします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | 系列の境界を表すフレーム特性を定義します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GetZAxis | 関連付けられているZ軸を返します。3Dモードの場合、深さ軸を返し、その他は系列のデフォルトの垂直軸を返します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Levels | 指定したインデックスにより等高線レベルの特性にアクセスします。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumLevels | 等高線系列のレベル数を設定します。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 等高線系列のポインタ特性を取得/設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YPosition | 等高線系列のY軸の高さを設定します。
YPositionLevel | YPositionプロパティの設定を有効/無効にします。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Contour クラス | Steema.TeeChart.Styles 名前空間


AutomaticLevels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.AutomaticLevels プロパティ

等高線系列を自動レベルに設定します。

public Boolean AutomaticLevels {get; set;}

解説

等高線系列を自動レベルに設定します。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


ContourMarks

Steema.TeeChart.Styles.Contour.ContourMarks プロパティ

等高線マーカの特別な特性を取得/設定します。
public ContourSeriesMarks ContourMarks {get; set;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Contour.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


DrawingAlgorithm

Steema.TeeChart.Styles.Contour.DrawingAlgorithm プロパティ

等高線系列のレベル構造と描画アルゴリズム。
public ContourConstruction DrawingAlgorithm {get; set;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


FillLevels

Steema.TeeChart.Styles.Contour.FillLevels プロパティ

Trueの場合、等高線レベルを塗りつぶします。
public Boolean FillLevels {get; set;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Frame

Steema.TeeChart.Styles.Contour.Frame プロパティ

系列の境界を表すフレーム特性を定義します。
public ChartPen Frame {get; set;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


GetZAxis

Steema.TeeChart.Styles.Contour.GetZAxis プロパティ

関連付けられているZ軸を返します。3Dモードの場合、深さ軸を返し、その他は系列のデフォルトの垂直軸を返します。
public Axis GetZAxis {get;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Levels

Steema.TeeChart.Styles.Contour.Levels プロパティ

指定したインデックスにより等高線レベルの特性にアクセスします。
public List<ContourLevel> Levels {get; set;}

解説

指定したインデックスにより等高線レベルの特性にアクセスします。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


NumLevels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.NumLevels プロパティ

等高線系列のレベル数を設定します。

public Int32 NumLevels {get; set;}

解説

等高線系列のレベル数を設定します。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Pointer

Steema.TeeChart.Styles.Contour.Pointer プロパティ

等高線系列のポインタ特性を取得/設定します。
public SeriesPointer Pointer {get; set;}

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


YPosition

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.YPosition プロパティ

等高線系列のY軸の高さを設定します。

public Double YPosition {get; set;}

解説

YPositionLevelプロパティをtrueに設定した場合、このプロパティを使用することで等高線系列のY軸の高さを設定することができます。チャートに複数の等高線系列を追加する場合、このプロパティを使用することで、レイヤーを有効/無効に設定できます。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


YPositionLevel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.YPositionLevel プロパティ

YPositionプロパティの設定を有効/無効にします。

public Boolean YPositionLevel {get; set;}

解説

等高線系列を表示するためには、YPositionプロパティと一緒に使用し、Y軸のレベルを定義してください。

参照

Contour クラス | Contour メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.ContourDraw

Steema.TeeChart.Styles.Contour.ContourDraw クラス

等高線系列クラスの合成。

この型のすべてのメンバの一覧については、ContourDraw メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class ContourDraw : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ContourDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.ContourDraw 全メンバ

ContourDraw 概要

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

コンストラクタ

Steema.TeeChart.Styles.Contour.ContourDraw..ctor

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Draw | メイン描画ルーチン。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

ContourDraw クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.ContourDraw フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ContourDraw クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.ContourDraw メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

Draw | メイン描画ルーチン。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

ContourDraw クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Contour+ContourDraw.Draw メソッド

メイン描画ルーチン。
protected internal Void Draw()

参照

ContourDraw クラス | ContourDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.ContourDraw プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) このオブジェクトに関連しているチャート。

参照

ContourDraw クラス | Steema.TeeChart.Styles 名前空間


ContourDraw コンストラクタ

Steema.TeeChart.Styles.Contour+ContourDraw コンストラクタ

public Contour+ContourDraw(Contour cSeries)

参照

ContourDraw クラス | ContourDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.DrawLevelEventArgs

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs クラス

DrawLevelイベントのイベントデータ。

この型のすべてのメンバの一覧については、DrawLevelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class DrawLevelEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

DrawLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.DrawLevelEventArgs 全メンバ

DrawLevelEventArgs 概要

パブリック プロパティ

LevelIndex 指定したインデックスにより等高線レベルの特性にアクセスします。

コンストラクタ

Steema.TeeChart.Styles.Contour.DrawLevelEventArgs..ctor

参照

DrawLevelEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.DrawLevelEventArgs プロパティ

パブリック プロパティ

LevelIndex 指定したインデックスにより等高線レベルの特性にアクセスします。

参照

DrawLevelEventArgs クラス | Steema.TeeChart.Styles 名前空間


LevelIndex

Steema.TeeChart.Styles.Contour+DrawLevelEventArgs.LevelIndex プロパティ

指定したインデックスにより等高線レベルの特性にアクセスします。
public Int32 LevelIndex {get;}

参照

DrawLevelEventArgs クラス | DrawLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour+DrawLevelEventArgs コンストラクタ

public Contour+DrawLevelEventArgs(Int32 LevelIndex)

参照

DrawLevelEventArgs クラス | DrawLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.DrawLevelEventHandler

Steema.TeeChart.Styles.Contour.DrawLevelEventHandler デリゲート

DrawLevelイベントのデリゲート。
public delegate DrawLevelEventHandler (Contour sender,
     DrawLevelEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.GetLevelEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour.GetLevelEventArgs クラス

GetLevelイベントのデータを提供します。

この型のすべてのメンバの一覧については、GetLevelEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetLevelEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

GetLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.GetLevelEventArgs 全メンバ

GetLevelEventArgs 概要

パブリック プロパティ

Color | 等高線系列のレベルの色を設定します。
LevelIndex | 指定したインデックスにより等高線レベルの特性にアクセスします。
Value | Value配列の値を取得/設定します。

コンストラクタ

Steema.TeeChart.Styles.Contour.GetLevelEventArgs

参照

GetLevelEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.GetLevelEventArgs プロパティ

パブリック プロパティ

Color | 等高線系列のレベルの色を設定します。
LevelIndex | 指定したインデックスにより等高線レベルの特性にアクセスします。
Value | Value配列の値を取得/設定します。

参照

GetLevelEventArgs クラス | Steema.TeeChart.Styles 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.Color プロパティ

等高線系列のレベルの色を設定します。

public Color Color {get; set;}

解説

等高線系列のレベルの色を設定します。

参照

GetLevelEventArgs クラス | GetLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


LevelIndex

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.LevelIndex プロパティ

指定したインデックスにより等高線レベルの特性にアクセスします。

public Int32 LevelIndex {get;}

解説

指定したインデックスにより等高線レベルの特性にアクセスします。

参照

GetLevelEventArgs クラス | GetLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour+GetLevelEventArgs.Value プロパティ

Value配列の値を取得/設定します。

public Double Value {get; set;}

解説

Value配列の値を取得/設定します。

参照

GetLevelEventArgs クラス | GetLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


GetLevelEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Contour+GetLevelEventArgs コンストラクタ

public Contour+GetLevelEventArgs(Int32 LevelIndex,
     Double Value,
     Color Color)

参照

GetLevelEventArgs クラス | GetLevelEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Contour.GetLevelEventHandler

Steema.TeeChart.Styles.Contour.GetLevelEventHandler デリゲート

GetLevelイベントのデリゲート。
public delegate GetLevelEventHandler (Contour sender,
     GetLevelEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourConstruction

Steema.TeeChart.Styles.ContourConstruction 列挙体

等高線レベルの構造アルゴリズム。
[Serializable]
public sealed enum ContourConstruction : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Fast | レベルは分割されません（速い）。
Segments | 各レベルは分割されます（遅い）。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ContourLevel クラス

等高線系列の「レベル」特性。

この型のすべてのメンバの一覧については、ContourLevel メンバを参照してください。

System.Object
public class ContourLevel : Object

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevel 全メンバ

ContourLevel 概要

コンストラクタ

Constructor

パブリック メソッド

Clicked
ClickedSegment
DefaultPen
GetSegmentPoints
ShouldSerializePen

パブリック プロパティ

Color | 等高線系列のレベルの色を取得/設定します。
Pen | 等高線レベルのペン特性を取得/設定します。
Segments |
UpToValue | ContourLevelの範囲の値を設定します。

参照

ContourLevel クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevel コンストラクタ

public ContourLevel(Contour cs,
     Int32 levelindex)

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevel メソッド

パブリック メソッド

Clicked
ClickedSegment
DefaultPen
GetSegmentPoints
ShouldSerializePen

参照

ContourLevel クラス | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.ContourLevel.Clicked メソッド

public Boolean Clicked(Int32 x,
     Int32 y,
     Int32& segmentindex,
     Int32& pointindex)

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


ClickedSegment

Steema.TeeChart.Styles.ContourLevel.ClickedSegment メソッド

public Boolean ClickedSegment(Int32 x,
     Int32 y,
     Int32 segmentindex,
     Int32& pointindex)

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


DefaultPen

Steema.TeeChart.Styles.ContourLevel.DefaultPen メソッド

public Boolean DefaultPen()

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


GetSegmentPoints

Steema.TeeChart.Styles.ContourLevel.GetSegmentPoints メソッド

public Point[] GetSegmentPoints(Int32 segmentindex)

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializePen

Steema.TeeChart.Styles.ContourLevel.ShouldSerializePen メソッド

public Boolean ShouldSerializePen()

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevel プロパティ

パブリック プロパティ

Color | 等高線系列のレベルの色を取得/設定します。
Pen | 等高線レベルのペン特性を取得/設定します。
Segments |
UpToValue | ContourLevelの範囲の値を設定します。

参照

ContourLevel クラス | Steema.TeeChart.Styles 名前空間


Color

Steema.TeeChart.Styles.ContourLevel.Color プロパティ

等高線系列のレベルの色を取得/設定します。
public Color Color {get; set;}

解説

等高線系列のレベルの色を取得/設定します。

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.ContourLevel.Pen プロパティ

等高線レベルのペン特性を取得/設定します。
public ChartPen Pen {get; set;}

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Segments

Steema.TeeChart.Styles.ContourLevel.Segments プロパティ

public List<LevelSegment> Segments {get;}

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


UpToValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ContourLevel.UpToValue プロパティ

ContourLevelの範囲の値を設定します。

public Double UpToValue {get; set;}

解説

ContourLevelの範囲の値です。等高線系列のデータ範囲内でContourLevel.Colorを適用させる範囲を設定します。

参照

ContourLevel クラス | ContourLevel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ContourLevels クラス

このクラスは、等高線系列のY位置レベルに関する情報を保持しています。

この型のすべてのメンバの一覧については、ContourLevels メンバを参照してください。

System.Object
System.Collections.ArrayList
public class ContourLevels : ArrayList , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

ContourLevels メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevels 全メンバ

ContourLevels 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

ContourLevels クラス | Steema.TeeChart.Styles 名前空間


ContourLevels コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ContourLevels コンストラクタ

public ContourLevels()

参照

ContourLevels クラス | ContourLevels メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevels コンストラクタ

public ContourLevels()

参照

ContourLevels コンストラクタのオーバーロードの一覧 | ContourLevels クラス | ContourLevels メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevels コンストラクタ

public ContourLevels(ICollection c)

参照

ContourLevels コンストラクタのオーバーロードの一覧 | ContourLevels クラス | ContourLevels メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourLevels プロパティ

パブリック プロパティ

Item

参照

ContourLevels クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.ContourLevels.Item プロパティ

public ContourLevel Item(Int32 index) {get; set;}

解説

特性を読込み/変更するためにインデックスによりContourLevelsリストの各レベルにアクセスします。

参照

ContourLevels クラス | ContourLevels メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks

Steema.TeeChart.Styles.ContourSeriesMarks クラス

この型のすべてのメンバの一覧については、ContourSeriesMarks メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class ContourSeriesMarks : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks 全メンバ

ContourSeriesMarks 概要

コンストラクタ

Constructor

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

AntiOverlap |
AtSegments |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColorLevel |
Density |
Margin |
Visible |

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ContourSeriesMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks コンストラクタ

public ContourSeriesMarks(Contour cs)

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

ContourSeriesMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ContourSeriesMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ContourSeriesMarks プロパティ

パブリック プロパティ

AntiOverlap |
AtSegments |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColorLevel |
Density |
Margin |
Visible |

参照

ContourSeriesMarks クラス | Steema.TeeChart.Styles 名前空間


AntiOverlap

Steema.TeeChart.Styles.ContourSeriesMarks.AntiOverlap プロパティ

public Boolean AntiOverlap {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


AtSegments

Steema.TeeChart.Styles.ContourSeriesMarks.AtSegments プロパティ

public Boolean AtSegments {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ColorLevel

Steema.TeeChart.Styles.ContourSeriesMarks.ColorLevel プロパティ

public Boolean ColorLevel {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Density

Steema.TeeChart.Styles.ContourSeriesMarks.Density プロパティ

public Int32 Density {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Margin

Steema.TeeChart.Styles.ContourSeriesMarks.Margin プロパティ

public Int32 Margin {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Visible

Steema.TeeChart.Styles.ContourSeriesMarks.Visible プロパティ

public Boolean Visible {get; set;}

参照

ContourSeriesMarks クラス | ContourSeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom

Steema.TeeChart.Styles.Custom クラス

TeeChart系列型の数により継承された基本系列クラス。

この型のすべてのメンバの一覧については、Custom メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
public class Custom : CustomPoint , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Custom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom 全メンバ

Custom 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity | 不透度を0から100%で設定します。
OutLine | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush
bClickableLine
bColorEach (Seriesの継承元)
bDark3D
calcVisiblePoints (Seriesの継承元)
drawArea
DrawBetweenPoints (Seriesの継承元)
drawLine
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Custom クラス | Steema.TeeChart.Styles 名前空間


Custom コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom コンストラクタ

オーバーロードの一覧

public Custom()
public Custom(Steema.TeeChart.Chart)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Custom コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom コンストラクタ

public Custom()

参照

Custom コンストラクタのオーバーロードの一覧 | Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Custom コンストラクタ

Steema.TeeChart.Styles.Custom コンストラクタ

public Custom(Chart c)

参照

Custom コンストラクタのオーバーロードの一覧 | Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Custom クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush
bClickableLine
bColorEach (Seriesの継承元)
bDark3D
calcVisiblePoints (Seriesの継承元)
drawArea
DrawBetweenPoints (Seriesの継承元)
drawLine
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Custom クラス | Steema.TeeChart.Styles 名前空間


bAreaBrush

Steema.TeeChart.Styles.Custom.bAreaBrush フィールド

protected ChartBrush bAreaBrush

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


bClickableLine

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.bClickableLine フィールド

protected Boolean bClickableLine

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


bDark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.bDark3D フィールド

protected Boolean bDark3D

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


drawArea

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.drawArea フィールド

protected Boolean drawArea

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


drawLine

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.drawLine フィールド

protected Boolean drawLine

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


pAreaLines

Steema.TeeChart.Styles.Custom.pAreaLines フィールド

protected ChartPen pAreaLines

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Custom クラス | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.Custom.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Clicked メソッド

オーバーロードの一覧

ポイントがXY 位置にあるかどうか計算します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

ポイントがXY 位置にあるかどうか計算します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Clicked メソッド

ポイントがXY 位置にあるかどうか計算します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

戻り値

ポイントのインデックス。

参照

Clicked オーバーロードの一覧 | Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.Custom.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Custom.Draw メソッド

public override Void Draw()

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Custom.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。直接このメソッドを呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


GetAreaBrushColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.GetAreaBrushColor メソッド

protected Color GetAreaBrushColor(Color c)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Custom.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Custom.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Custom.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity | 不透度を0から100%で設定します。
OutLine | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Custom クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Custom.Brush プロパティ

ブラシの特性を設定します。
public ChartBrush Brush {get;}

解説

ブラシの特性を設定します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


ClickableLine

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.ClickableLine プロパティ

ポイント間の線上でマウスクリックを有効にするかどうか定義します。

public Boolean ClickableLine {get; set;}

解説

デフォルト値：true（散布図系列ではfalse）

ポイント間の線上でマウスクリックを有効にするかどうか定義します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


ColorEachLine

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.ColorEachLine プロパティ

系列の接続している各線の色を有効/無効にします。

public Boolean ColorEachLine {get; set;}

解説

系列の接続している各線の色を有効/無効にします。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Dark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Dark3D プロパティ

3Dのリボン系列の影の色を有効/無効にします。

public Boolean Dark3D {get; set;}

解説

デフォルト値：true

3Dのリボン系列の影の色を有効/無効にします。

例

private void Form1_Load(object sender, System.EventArgs e)
{
     Steema.TeeChart.Styles.Line Series1 = new Steema.TeeChart.Styles.Line();
     tChart1.Series.Add(Series1);
     Series1.FillSampleValues(25);
     tChart1.Aspect.View3D = true;
     tChart1.Aspect.Chart3DPercent = 100;
     Series1.Color = Color.Yellow;
}

private void button1_Click_1(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Line)tChart1[0]).Dark3D = !((Steema.TeeChart.Styles.Line)tChart1[0]).Dark3D;
}

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


InvertedStairs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.InvertedStairs プロパティ

Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。

public Boolean InvertedStairs {get; set;}

解説

このプロパティは、リボン系列や面系列の描画を制御します。

Stairsプロパティがtrueに設定されている場合、このプロパティをtrueに設定するとステップの方向を変更できます。Stairsプロパティを参照してください。

一般的には、系列は各ポイント間を一本の線で描きます。これにより、線は「山」のような形状で表示されます。しかし、Stairsプロパティをtrueに設定すると、系列はポイントの各ペア間を水平線と垂直線で描きます。つまり「階段」状の外観になります。これは一部の金融関係のチャートとしてよく使用されます。InvertedStairsプロパティをtrueに設定すると、階段を反転させることができます。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


LineHeight

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.LineHeight プロパティ

線の高さをピクセル単位で定義します。

public Int32 LineHeight {get; set;}

解説

線の高さをピクセル単位で定義します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Opacity

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Opacity プロパティ

不透明度を0から100%で設定します。

public Int32 Opacity {get; set;}

解説

不透明度を0から100%で設定します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


OutLine

Steema.TeeChart.Styles.Custom.OutLine プロパティ

系列の線のアウトラインのペンを定義します。
public ChartPen OutLine {get;}

解説

系列の線のアウトラインのペンを定義します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Stairs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Stairs プロパティ

各ポイントを接続する線を階段状にします。

public Boolean Stairs {get; set;}

解説

このプロパティは、リボン系列や面系列の描画を制御します。

通常の状況では、各線ポイントの間に線を描きます。これにより、線が「山」型の形状で表示されます。しかし、このプロパティsをtrueに設定すると、系列はポイントのそれぞれのペアの間に2つの線を描きます。このようにして、「階段」の形状を出します。これは、一部の金融チャートを表示する際に特によく使用されます。

このプロパティがtrueに設定されていて、InvertedStairsプロパティをtrueに設定すると、ステップの方向を変更することができます。

[C#]

private void button1_Click(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Line)tChart1[0]).Stairs =! ((Steema.TeeChart.Styles.Line)tChart1[0]).Stairs;
}

private void button3_Click(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Line)tChart1[0]).InvertedStairs =! ((Steema.TeeChart.Styles.Line)tChart1[0]).InvertedStairs;
}

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom.Transparency プロパティ

0～100%までの透明度を設定します。

public Int32 Transparency {get; set;}

解説

デフォルト値：0

0～100%までの透明度を設定します。

参照

Custom クラス | Custom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar

Steema.TeeChart.Styles.Custom2DPolar クラス

風向図系列と時計系列の継承元クラス。

この型のすべてのメンバの一覧については、Custom2DPolar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Custom2DPolar : CustomPolar , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar 全メンバ

Custom2DPolar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Custom2DPolar クラス | Steema.TeeChart.Styles 名前空間


Custom2DPolar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom2DPolar コンストラクタ

オーバーロードの一覧

public Custom2DPolar()
public Custom2DPolar(Steema.TeeChart.Chart)

参照

Custom2DPolar クラス | Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


Custom2DPolar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom2DPolar コンストラクタ

public Custom2DPolar()

参照

Custom2DPolar コンストラクタのオーバーロードの一覧 | Custom2DPolar クラス | Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


Custom2DPolar コンストラクタ

Steema.TeeChart.Styles.Custom2DPolar コンストラクタ

public Custom2DPolar(Chart c)

参照

Custom2DPolar コンストラクタのオーバーロードの一覧 | Custom2DPolar クラス | Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Custom2DPolar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Custom2DPolar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Custom2DPolar クラス | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Custom2DPolar.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

Custom2DPolar クラス | Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Custom2DPolar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Custom2DPolar クラス | Custom2DPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom2DPolar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Custom2DPolar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D

Steema.TeeChart.Styles.Custom3D クラス

Custom3D系列。

この型のすべてのメンバの一覧については、Custom3D メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public abstract class Custom3D : Series , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D 全メンバ

Custom3D 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis |

参照

Custom3D クラス | Steema.TeeChart.Styles 名前空間


Custom3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D コンストラクタ

オーバーロードの一覧

protected Custom3D()
protected Custom3D(Steema.TeeChart.Chart)

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Custom3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D コンストラクタ

protected Custom3D()

参照

Custom3D コンストラクタのオーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Custom3D コンストラクタ

Steema.TeeChart.Styles.Custom3D コンストラクタ

protected Custom3D(Chart c)

参照

Custom3D コンストラクタのオーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Custom3D クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues
yMandatory (Seriesの継承元)

参照

Custom3D クラス | Steema.TeeChart.Styles 名前空間


vzValues

Steema.TeeChart.Styles.Custom3D.vzValues フィールド

protected ValueList vzValues

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D メソッド

パブリック メソッド

Add | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis |

参照

Custom3D クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

オーバーロードの一覧

3D系列にDataViewを追加します。

public virtual Void Add(System.Data.DataView)

X,Y,Zの配列を追加します。

public Void Add(System.Array, System.Array, System.Array)

3D系列に新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double)

3D系列に新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

3D系列に新しいポイントとラベルを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

3D系列に新しいポイント、ラベル、色を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

3D系列に新しい日付時間ポイント、ラベル、色を追加します。

public Int32 Add(System.DateTime, System.Double, System.Double, System.String, System.Drawing.Color)

解説

3D系列に新しいポイントを追加します。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列にDataViewを追加します。

public virtual Void Add(DataView view)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

X、Y、Zの配列を追加します。

public Void Add(Array xValues,
     Array yValues,
     Array zValues)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列に新しいポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double z)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列に新しいポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double z,
     Color color)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列に新しいポイントとラベルを追加します。

public Int32 Add(Double x,
     Double y,
     Double z,
     String text)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列に新しいポイント、ラベル、色を追加します。

public Int32 Add(Double x,
     Double y,
     Double z,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列に新しい日付時間ポイント、ラベル、色を追加します。
public Int32 Add(DateTime aDate,
     Double y,
     Double z,
     String text,
     Color color)

パラメーター

aDate
日付時間値
y
Y値
z
Z値
text
ポイントのテキスト
color
ポイントの色

戻り値

追加したポイントのインデックス

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Custom3D.Add メソッド

3D系列にDataViewを追加します。
public override Void Add(DataView view)

参照

Add オーバーロードの一覧 | Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


BackFaced

Steema.TeeChart.Styles.Custom3D.BackFaced メソッド

protected Boolean BackFaced()

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


CalcZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.CalcZOrder メソッド

protected internal virtual Void CalcZOrder()

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


CalcZPos

Steema.TeeChart.Styles.Custom3D.CalcZPos メソッド

public Int32 CalcZPos(Int32 valueIndex)

解説

ValueIndex番目のポイントのZ位置のピクセル値を返します。
戻り値のオフセットを設定するためにChartのWidth3DとHeight3Dの置換を使用します。
これは、すべてのTeeChartの3Dモード、直交、3D、OpenGLで正確な処理を行います。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Custom3D.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Custom3D.IsValidSourceOf メソッド

指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
public override Boolean IsValidSourceOf(Series value)

解説

ValueパラメーターがSelfと同じ場合、falseを返します。
デザイン時および実行時にDataSourceプロパティを有効にするために使用されます。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.MaxZValue メソッド

最大のZ値を返します。

public virtual Double MaxZValue()

解説

最大のZ値を返します。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.MinZValue メソッド

Z値の最小値を返します。

public virtual Double MinZValue()

解説

Z値の最小値を返します。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.Custom3D.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


ValueListOfAxis

Steema.TeeChart.Styles.Custom3D.ValueListOfAxis メソッド

protected internal abstract ValueList ValueListOfAxis(Axis a)

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3D プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues | Zポイント位置を設定する値。

参照

Custom3D クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Custom3D.Item プロパティ

XYZのポイント特性。
public SeriesXYZPoint Item(Int32 index) {get;}

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


TimesZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3D.TimesZOrder プロパティ

内部使用。

public Int32 TimesZOrder {get; set;}

解説

デフォルト値：3

Z軸（奥軸）の深さをサーフェスあるいは等高線の幅や高さに応じて設定します。デフォルトで、サーフェスの深さは、リボン系列の深さの3倍です。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


ZValues

Steema.TeeChart.Styles.Custom3D.ZValues プロパティ

Zポイント位置を設定する値。
public ValueList ZValues {get;}

解説

サーフェスポイントのZ値を含んでいます。このプロパティは標準的なIValueList のオブジェクトです。Z値を変更するために使用できます。

参照

Custom3D クラス | Custom3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid

Steema.TeeChart.Styles.Custom3DGrid クラス

Custom3DGrid系列。

この型のすべてのメンバの一覧については、Custom3DGrid メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Custom3DGrid : Custom3DPalette , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid 全メンバ

Custom3DGrid 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid | X値とZ値が同じ距離かどうかを設定します。
Item | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues | サーフェスの水平サイズをポイント数で設定します。
NumZValues | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex
iGridIndexFilled
iInGallery
iNextXCell
iNextZCell
InternalUse (TeeBaseの継承元)
iNumXValues
iNumZValues
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0
valueIndex1
valueIndex2
valueIndex3
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Custom3DGrid クラス | Steema.TeeChart.Styles 名前空間


Custom3DGrid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid コンストラクタ

オーバーロードの一覧

public Custom3DGrid()
public Custom3DGrid(Steema.TeeChart.Chart)

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Custom3DGrid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid コンストラクタ

public Custom3DGrid()

参照

Custom3DGrid コンストラクタのオーバーロードの一覧 | Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Custom3DGrid コンストラクタ

Steema.TeeChart.Styles.Custom3DGrid コンストラクタ

public Custom3DGrid(Chart c)

参照

Custom3DGrid コンストラクタのオーバーロードの一覧 | Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Custom3DGrid クラス | Steema.TeeChart.Styles 名前空間


GetYValue

Steema.TeeChart.Styles.Custom3DGrid.GetYValue イベント

サーフェス系列が値のグリッドを再作成させる時に発生します。
public GetYValueEventHandler  GetYValue

解説

サーフェス系列が値のグリッドを再作成させる時に発生します。ReCreateValuesメソッドを呼び出すと強制的にサーフェス系列を再作成します。指定したX値やZ値に該当するY値を返します。通常、XパラメーターやZパラメーターに基づいた値を計算する式やアルゴリズムを配置します。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex
iGridIndexFilled
iInGallery
iNextXCell
iNextZCell
InternalUse (TeeBaseの継承元)
iNumXValues
iNumZValues
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0
valueIndex1
valueIndex2
valueIndex3
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Custom3DGrid クラス | Steema.TeeChart.Styles 名前空間


gridIndex

Steema.TeeChart.Styles.Custom3DGrid.gridIndex フィールド

protected PCellsRow gridIndex

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iGridIndexFilled

Steema.TeeChart.Styles.Custom3DGrid.iGridIndexFilled フィールド

protected Boolean iGridIndexFilled

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iInGallery

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.iInGallery フィールド

protected Boolean iInGallery

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iNextXCell

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.iNextXCell フィールド

protected internal Int32 iNextXCell

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iNextZCell

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.iNextZCell フィールド

protected internal Int32 iNextZCell

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iNumXValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.iNumXValues フィールド

protected internal Int32 iNumXValues

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


iNumZValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.iNumZValues フィールド

protected internal Int32 iNumZValues

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


ReuseGridIndex

Steema.TeeChart.Styles.Custom3DGrid.ReuseGridIndex フィールド

public Boolean ReuseGridIndex

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


valueIndex0

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.valueIndex0 フィールド

protected internal Int32 valueIndex0

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


valueIndex1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.valueIndex1 フィールド

protected internal Int32 valueIndex1

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


valueIndex2

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.valueIndex2 フィールド

protected internal Int32 valueIndex2

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


valueIndex3

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.valueIndex3 フィールド

protected internal Int32 valueIndex3

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Custom3DGrid クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


AddValues

Steema.TeeChart.Styles.Custom3DGrid.AddValues メソッド

protected abstract Void AddValues(Array source)

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.Clear メソッド

すべての系列値を削除します。

public virtual Void Clear()

解説

すべての系列値を削除します。従属系列は通知されます。系列に追加される新しいポイントがない場合、何も描画されません。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


CreateValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.CreateValues メソッド

NumZサイズによりNumXのサーフェスグリッドを作成します。

public Void CreateValues(Int32 numX,
     Int32 numZ)

解説

NumZサイズによりNumXのサーフェスグリッドを作成します。ユーザーがY値を設定できるように各グリッドポイント毎にOnGetYValueイベントが発生します。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


DoGetYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.DoGetYValue メソッド

protected Void DoGetYValue(Int32 x,
     Int32 z,
     Double& Value)

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


ExistFourGridIndex

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.ExistFourGridIndex メソッド

protected internal Boolean ExistFourGridIndex(Int32 x,
     Int32 z)

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex メソッド

オーバーロードの一覧

public Void FillGridIndex(System.Int32)
public Void FillGridIndex()

解説

内部使用。
このメソッドは、サーフェスあるいは等高線プロットを配置する内部グリッドテンプレートを作成するために系列により呼び出されます。

正確なグリッドのX値やZ値を系列に渡す場合、FillGridIndexメソッドは何も行いません。

X値とZ値が浮動小数点あるいは、ソートされていない場合、FillGridIndexメソッドはグリッドを作成し、XとZ座標をソートします。

その結果グリッドは、全てのポイントのインデックスとして描画に使用されます。

四角いグリッドに収まらないXYZ値を持っている場合、サーフェス（三角）系列を使用することができます。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex メソッド

public Void FillGridIndex(Int32 StartIndex)

参照

FillGridIndex オーバーロードの一覧 | Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


FillGridIndex

Steema.TeeChart.Styles.Custom3DGrid.FillGridIndex メソッド

public Void FillGridIndex()

参照

FillGridIndex オーバーロードの一覧 | Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid | X値とZ値が同じ距離かどうかを設定します。
Item | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues | サーフェスの水平サイズをポイント数で設定します。
NumZValues | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Custom3DGrid クラス | Steema.TeeChart.Styles 名前空間


IrregularGrid

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.IrregularGrid プロパティ

X値とZ値が同じ距離かどうかを設定します。

public Boolean IrregularGrid {get; set;}

解説

X値とZ値が同じ距離かどうかを設定します。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Custom3DGrid.Item プロパティ

系列のセル値に簡単にアクセスするための2次元配列プロパティです。
public Int32 Item(Int32 x,
     Int32 z) {get; set;}

解説

系列のセル値に簡単にアクセスするための2次元配列プロパティです。

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


NumXValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.NumXValues プロパティ

サーフェスの水平サイズをポイント数で設定します。

public Int32 NumXValues {get; set;}

解説

デフォルト値：20

サーフェスの水平サイズをポイント数で設定します。サーフェスは、NumXValues x NumZValues サイズのグリッドです。NumXValuesを変更することにより強制的にすべての値をサーフェスに再作成させます。

例

このコードはサーフェスのグリッドサイズを変更します。

[C#]
Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.NumXValues = 50;
Series1.NumZValues = 40;

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


NumZValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.NumZValues プロパティ

サーフェスの深さのサイズをポイント数で設定します。

public Int32 NumZValues {get; set;}

解説

デフォルト値：20

サーフェスの深さのサイズをポイント数で設定します。サーフェスは、NumXValues x NumZValuesサイズのグリッドです。NumZValuesを変更することにより強制的にすべての値をサーフェスに再作成させます。

例

このコードはサーフェスのグリッドサイズを変更します。

[C#]
Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.NumZValues = 10;
Series1.NumXValues = 15;

参照

Custom3DGrid クラス | Custom3DGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.CellsRow

Steema.TeeChart.Styles.Custom3DGrid.CellsRow クラス

この型のすべてのメンバの一覧については、CellsRow メンバを参照してください。

System.Object
System.Collections.Generic.List<System.Int32>
protected sealed class CellsRow : List<Int32> , IList<Int32>
, ICollection<Int32>, IEnumerable<Int32>, IEnumerable, IList
, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CellsRow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.CellsRow 全メンバ

CellsRow 概要

コンストラクタ

Steema.TeeChart.Styles.Custom3DGrid.CellsRow..ctor

参照

CellsRow クラス | Steema.TeeChart.Styles 名前空間


CellsRow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid+CellsRow コンストラクタ

public Custom3DGrid+CellsRow()

参照

CellsRow クラス | CellsRow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.CellsRow プロパティ

パブリック プロパティ

Item

参照

CellsRow クラス | Steema.TeeChart.Styles 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid+CellsRow.Item プロパティ

public Int32 Item(Int32 index) {get; set;}

参照

CellsRow クラス | CellsRow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs クラス

GetYValueイベントのデータを提供します。

この型のすべてのメンバの一覧については、GetYValueEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetYValueEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

GetYValueEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs 全メンバ

GetYValueEventArgs 概要

パブリック プロパティ

Value | 系列ポイントのY値
X | 系列ポイントのX値
Z | 系列ポイントのZ値

コンストラクタ

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs

参照

GetYValueEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventArgs プロパティ

パブリック プロパティ

Value | 系列ポイントのY値
X | 系列ポイントのX値
Z | 系列ポイントのZ値

参照

GetYValueEventArgs クラス | Steema.TeeChart.Styles 名前空間


Value

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.Value プロパティ

系列ポイントのY値。
public Double Value {get; set;}

解説

系列のセル値に簡単にアクセスするための2次元配列プロパティです。

Series1.Value[ 12, 10 ]:= 456.78 ; // <-- 12番目の行、10番目の列

系列は、この配列プロパティを使用する場合、AddXYZメソッドを使用することで内部的に適切な値を追加します。

参照

GetYValueEventArgs クラス | GetYValueEventArgs メンバ | Steema.TeeChart.Styles 名前空間


X

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.X プロパティ

系列ポイントのX値。
public Int32 X {get;}

解説

系列ポイントのX値。

参照

GetYValueEventArgs クラス | GetYValueEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Z

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs.Z プロパティ

系列ポイントのZ値。
public Int32 Z {get;}

解説

系列ポイントのZ値。

参照

GetYValueEventArgs クラス | GetYValueEventArgs メンバ | Steema.TeeChart.Styles 名前空間


GetYValueEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid+GetYValueEventArgs コンストラクタ

public Custom3DGrid+GetYValueEventArgs(Int32 X,
     Int32 Z,
     Double Value)

参照

GetYValueEventArgs クラス | GetYValueEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventHandler

Steema.TeeChart.Styles.Custom3DGrid.GetYValueEventHandler デリゲート

GetYValueイベントのデリゲート。
public delegate GetYValueEventHandler (Series sender,
     GetYValueEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.PCellsRow

Steema.TeeChart.Styles.Custom3DGrid.PCellsRow クラス

この型のすべてのメンバの一覧については、PCellsRow メンバを参照してください。

System.Object
System.Collections.Generic.List<Custom3DGrid+CellsRow>
protected sealed class PCellsRow : List<CellsRow>
, IList<CellsRow>
, ICollection<CellsRow>
, IEnumerable<CellsRow>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PCellsRow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.PCellsRow 全メンバ

PCellsRow 概要

コンストラクタ

Steema.TeeChart.Styles.Custom3DGrid.PCellsRow..ctor

参照

PCellsRow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DGrid.PCellsRow プロパティ

パブリック プロパティ

Item

参照

PCellsRow クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Custom3DGrid+PCellsRow.Item プロパティ

public CellsRow Item(Int32 index) {get; set;}

参照

PCellsRow クラス | PCellsRow メンバ | Steema.TeeChart.Styles 名前空間


PCellsRow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DGrid+PCellsRow コンストラクタ

public Custom3DGrid+PCellsRow()

参照

PCellsRow クラス | PCellsRow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette

Steema.TeeChart.Styles.Custom3DPalette クラス

Custom3DPalette系列スタイル。

この型のすべてのメンバの一覧については、Custom3DPalette メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
public class Custom3DPalette : Custom3D , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette 全メンバ

Custom3DPalette 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndColor | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette | カラーパレットのリストにアクセスします。
PaletteMin | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep | パレット色の間隔を設定します。
PaletteSteps | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle | カラーパレットの淡い/濃いを選択します。
Pen | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange
bUsePalette
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps
lastVisible (Seriesの継承元)
sameBrush
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateDefaultPalette |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Custom3DPalette クラス | Steema.TeeChart.Styles 名前空間


Custom3DPalette コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette コンストラクタ

オーバーロードの一覧

public Custom3DPalette(Steema.TeeChart.Chart)
public Custom3DPalette()

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Custom3DPalette コンストラクタ

Steema.TeeChart.Styles.Custom3DPalette コンストラクタ

public Custom3DPalette(Chart c)

参照

Custom3DPalette コンストラクタのオーバーロードの一覧 | Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Custom3DPalette コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette コンストラクタ

public Custom3DPalette()

参照

Custom3DPalette コンストラクタのオーバーロードの一覧 | Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Custom3DPalette クラス | Steema.TeeChart.Styles 名前空間


GetValueColor

Steema.TeeChart.Styles.Custom3DPalette.GetValueColor イベント

サーフェスのポリゴンが表示される度に発生します。このイベントを使用して各サーフェスのポリゴンに特定の色を設定できます。
public GetColorEventHandler  GetValueColor

解説

サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。このイベントを使用することにより時間が消費されます。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange
bUsePalette
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps
lastVisible (Seriesの継承元)
sameBrush
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Custom3DPalette クラス | Steema.TeeChart.Styles 名前空間


bUseColorRange

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.bUseColorRange フィールド

protected internal Boolean bUseColorRange

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


bUsePalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.bUsePalette フィールド

protected internal Boolean bUsePalette

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


iPaletteSteps

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.iPaletteSteps フィールド

protected internal Int32 iPaletteSteps

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


sameBrush

Steema.TeeChart.Styles.Custom3DPalette.sameBrush フィールド

protected Boolean sameBrush

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateDefaultPalette |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Custom3DPalette クラス | Steema.TeeChart.Styles 名前空間


AddPalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.AddPalette メソッド

パレットリストに色を追加します。

public Int32 AddPalette(Double aValue,
     Color aColor)

パラメーター

aValue
データ値
aColor
色

戻り値

新しいパレット色のインデックス

解説

新しいパレットを作成するには、このメソッドを使用してください。

例

[C#]

このコードはパレットを作成し、系列に適用します。

private void Form1_Load(object sender, System.EventArgs e)

surface1.FillSampleValues();

private void button1_Click(object sender, System.EventArgs e)

//新しいパレットを適用
surface1.PaletteSteps=7;
surface1.ClearPalette();
double dataRange=surface1.YValues.Maximum-surface1.YValues.Minimum;
double minVal=surface1.YValues.Minimum;
surface1.AddPalette(minVal+(dataRange*0.1),Color.DarkBlue);
surface1.AddPalette(minVal+(dataRange*0.2),Color.Blue);
surface1.AddPalette(minVal+(dataRange*0.3),Color.LightBlue);
surface1.AddPalette(minVal+(dataRange*0.5),Color.Yellow);
surface1.AddPalette(minVal+(dataRange*0.7),Color.YellowGreen);
surface1.AddPalette(minVal+(dataRange*0.8),Color.LightGreen);
surface1.AddPalette(minVal+(dataRange*0.9),Color.Green);
surface1.UseColorRange=false;
surface1.UsePalette=true;
tChart1.Refresh();

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


AddValues

Steema.TeeChart.Styles.Custom3DPalette.AddValues メソッド

protected abstract Void AddValues(Array source)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


CalcColorRange

Steema.TeeChart.Styles.Custom3DPalette.CalcColorRange メソッド

protected internal Void CalcColorRange()

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


ClearPalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.ClearPalette メソッド

すべてのパレット情報を削除します。

public Void ClearPalette()

解説

すべてのパレット情報を削除します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


CreateDefaultPalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.CreateDefaultPalette メソッド

protected internal Void CreateDefaultPalette(Int32 numSteps)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Custom3DPalette.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Custom3DPalette.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Custom3DPalette.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


GetValueColorValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.GetValueColorValue メソッド

protected internal Color GetValueColorValue(Double aValue)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.LegendItemColor メソッド

protected internal virtual Color LegendItemColor(Int32 legendIndex)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Custom3DPalette.LegendString メソッド

指定したインデックスの凡例項目の書式化された文字列を返します。
public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

解説

指定したLegendIndex番目のポイントのLegendTextStyleによる凡例の書式文字列を返します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


OriginalValueColor

Steema.TeeChart.Styles.Custom3DPalette.OriginalValueColor メソッド

protected internal Color OriginalValueColor(Int32 valueIndex)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Custom3DPalette.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Custom3DPalette.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


SetSameBrush

Steema.TeeChart.Styles.Custom3DPalette.SetSameBrush メソッド

protected abstract Boolean SetSameBrush()

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Custom3DPalette.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


ValueColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.ValueColor メソッド

インデックスポイントの色を返します。

public virtual Color ValueColor(Int32 valueIndex)

解説

指定した位置でポイントの色を取得/設定します。インデックスは、ゼロから開始します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndColor | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette | カラーパレットのリストにアクセスします。
PaletteMin | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep | パレット色の間隔を設定します。
PaletteSteps | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle | カラーパレットの淡い/濃いを選択します。
Pen | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Custom3DPalette クラス | Steema.TeeChart.Styles 名前空間


BlueFactor

Steema.TeeChart.Styles.Custom3DPalette.BlueFactor プロパティ

ARGBコンポーネントの青のアルファ値を設定します。
public Double BlueFactor {get; set;}

解説

ARGBコンポーネントの青のアルファ値を設定します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Custom3DPalette.Brush プロパティ

サーフェスポリゴンを塗りつぶすブラシを定義します。
public ChartBrush Brush {get; set;}

解説

サーフェスポリゴンを描くブラシの種類を設定します。UsePaletteプロパティとUseColorRangeプロパティがfalseの場合のみ有効です。

例

このコードはサーフェスのブラシを変更します。

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.UsePalette = false;
Series1.UseColorRange = false;
Series1.Brush.Style = DiagCross;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


EndColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.EndColor プロパティ

終了範囲パレット色を設定します。サーフェスポリゴンを塗りつぶすパレットを作成するために使用される3色のうちの1つを設定します。

public Color EndColor {get; set;}

解説

デフォルト値：White

終了範囲パレット色を設定します。UseColorRangeプロパティがtrueの場合、サーフェス系列はStartColorプロパティ、MidColorプロパティ、EndColorプロパティを使用してカラーパレットを作成します。

例

このコードは色範囲パレットを変更します。

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.UseColorRange = true;
Series1.StartColor = Color.White;
Series1.EndColor = Color.Yellow;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


GreenFactor

Steema.TeeChart.Styles.Custom3DPalette.GreenFactor プロパティ

ARGBコンポーネントの緑のアルファ値を設定します。
public Double GreenFactor {get; set;}

解説

ARGBコンポーネントの緑のアルファ値を設定します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


MidColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.MidColor プロパティ

中央範囲パレット色を設定します。サーフェスポリゴンを塗りつぶすパレットを作成するために使用される3色のうちの1つを設定します。

public Color MidColor {get; set;}

解説

中央範囲パレット色を設定します。UseColorRangeプロパティがtrueの場合、サーフェス系列はStartColorプロパティ、MidColorプロパティ、EndColorプロパティを使用してカラーパレットを作成します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Palette

Steema.TeeChart.Styles.Custom3DPalette.Palette プロパティ

カラーパレットのリストにアクセスします。
public List<GridPalette> Palette {get;}

解説

カラーパレットのリストにアクセスします。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteMin

Steema.TeeChart.Styles.Custom3DPalette.PaletteMin プロパティ

UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
public Double PaletteMin {get; set;}

解説

UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteRange

Steema.TeeChart.Styles.Custom3DPalette.PaletteRange プロパティ

デフォルトのカラーパレットで色の範囲を設定します。
public Double PaletteRange {get; set;}

解説

デフォルトのカラーパレットで色の範囲を設定します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteStep

Steema.TeeChart.Styles.Custom3DPalette.PaletteStep プロパティ

パレット色の間隔を設定します。
public Double PaletteStep {get; set;}

解説

パレット色の間隔を設定します。

PaletteMinプロパティ、UsePaletteMinプロパティ、PaletteStepsプロパティを参照してください。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteSteps

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.PaletteSteps プロパティ

デフォルトのカラーパレットのエントリー数を設定します。

public Int32 PaletteSteps {get; set;}

解説

デフォルト値：32

デフォルトのカラーパレットのエントリー数を設定します。この数を多くすると、より多くの異なる色がサーフェスのポリゴンを塗りつぶすために使用されます。このプロパティを設定すると、サーフェス系列はデフォルトのカラーパレットを再作成します。

例

[C#]
Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.PaletteSteps = 100;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteStyle

Steema.TeeChart.Styles.Custom3DPalette.PaletteStyle プロパティ

カラーパレットの淡い/濃い/グレースケールを選択します。
public PaletteStyles PaletteStyle {get; set;}

解説

カラーパレットの淡い/濃い/グレースケールを選択します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Custom3DPalette.Pen プロパティ

サーフェスのポリゴンを描くペンを設定します。
public ChartPen Pen {get; set;}

解説

サーフェスのポリゴンを描くペンの種類を設定します。Pen.Visibleプロパティをfalseに設定することにより非表示になります。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


RedFactor

Steema.TeeChart.Styles.Custom3DPalette.RedFactor プロパティ

ARGBコンポーネントの赤のアルファ値を設定します。
public Double RedFactor {get; set;}

解説

ARGBコンポーネントの赤のアルファ値を設定します。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


StartColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.StartColor プロパティ

開始範囲パレット色を設定します。サーフェスポリゴンを塗りつぶすパレットを作成するために使用される3色のうちの1つを設定します。

public Color StartColor {get; set;}

解説

デフォルト値：Navy

開始範囲パレット色を設定します。UseColorRangeプロパティがtrueの場合、サーフェス系列はStartColorプロパティ、MidColorプロパティ、EndColorプロパティを使用してカラーパレットを作成します。

例

このコードはグラデーションカラーパレットを赤から白に作成します。

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.UseColorRange = true;
Series1.StartColor = Color.Red;
Series1.EndColor = Color.White;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


UseColorRange

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.UseColorRange プロパティ

サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。

public Boolean UseColorRange {get; set;}

解説

デフォルト値：true

このプロパティがtrueの場合、サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットが使用されます。パレットはStartColorプロパティ、MidColorプロパティ、EndColorプロパティの3色で設定されます。UseColorRangeプロパティとUsePaletteプロパティの両方がfalseの場合、すべてのサーフェスポリゴンはサーフェスのSeries.Colorで塗りつぶされます。

例

このコードはグラデーションカラーパレットを緑から青に作成します。

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.StartColor = Color.Green;
Series1.EndColor = Color.Blue;
Series1.UseColorRange = true;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


UsePalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.UsePalette プロパティ

サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを使用します。

public Boolean UsePalette {get; set;}

解説

デフォルト値：false

マルチカラーパレットでサーフェスのポリゴンを塗りつぶすことを示します。PaletteStepsプロパティは、パレットのエントリー数を設定します。

PaletteStepsの代わりに、サーフェス系列の色を定義するためにUseColorRangeプロパティあるいはSeriesのColorEachPointを使用しても構いません。

例

これはマルチカラーパレットでサーフェスのポリゴンを塗りつぶします。

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.UsePalette = true;

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


UsePaletteMin

Steema.TeeChart.Styles.Custom3DPalette.UsePaletteMin プロパティ

UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
public Boolean UsePaletteMin {get; set;}

解説

デフォルト値：false

PaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。

このプロパティがfalse（デフォルト）の場合、カラーパレットは、最も低い系列のY値から始まるように計算されます。

参照

Custom3DPalette クラス | Custom3DPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs クラス

GetValueColorイベントのデータを提供します。

この型のすべてのメンバの一覧については、GetColorEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetColorEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

GetColorEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs 全メンバ

GetColorEventArgs 概要

パブリック プロパティ

Color | 系列ポイントの色を取得/設定します。
ValueIndex | 系列のValueListの値のインデックス。

コンストラクタ

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs

参照

GetColorEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventArgs プロパティ

パブリック プロパティ

Color | 系列ポイントの色を取得/設定します。
ValueIndex | 系列のValueListの値のインデックス。

参照

GetColorEventArgs クラス | Steema.TeeChart.Styles 名前空間


Color

Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs.Color プロパティ

系列ポイントの色を取得/設定します。
public Color Color {get; set;}

解説

系列ポイントの色を取得/設定します。

参照

GetColorEventArgs クラス | GetColorEventArgs メンバ | Steema.TeeChart.Styles 名前空間


ValueIndex

Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs.ValueIndex プロパティ

系列のValueList内の値のインデックス。
public Int32 ValueIndex {get;}

解説

系列のValueList内の値のインデックス。

参照

GetColorEventArgs クラス | GetColorEventArgs メンバ | Steema.TeeChart.Styles 名前空間


GetColorEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Custom3DPalette+GetColorEventArgs コンストラクタ

public Custom3DPalette+GetColorEventArgs(Int32 valueIndex,
     Color color)

参照

GetColorEventArgs クラス | GetColorEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Custom3DPalette.GetColorEventHandler

Steema.TeeChart.Styles.Custom3DPalette.GetColorEventHandler デリゲート

GetValueColorイベントのデリゲート
public delegate GetColorEventHandler (Series sender,
     GetColorEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar

Steema.TeeChart.Styles.CustomBar クラス

CustomBar系列。

この型のすべてのメンバの一覧については、CustomBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class CustomBar : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar 全メンバ

CustomBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin | 両端のマージンをピクセル単位で返します。
BarRectangle | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle | バーのスタイルを設定します。
Brush | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent | バーの移動をバーサイズに対する割合で定義します。
Origin | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins | チャート矩形とバーとの間にマージンを設定します。
StackGroup | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent
bColorEach (Seriesの継承元)
bDark3D
bUseOrigin
calcVisiblePoints (Seriesの継承元)
conePercent
customBarSize
dOrigin
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds
IBarSize
iMultiBar
InternalUse (TeeBaseの継承元)
INumBars
IOrderPos
IPreviousCount
lastVisible (Seriesの継承元)
NormalBarColor
pPen
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMarkLength |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawTickLine |
DrawTickLines |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue |
MinMandatoryValue |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin |
SubGalleryStack |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX

参照

CustomBar クラス | Steema.TeeChart.Styles 名前空間


CustomBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar コンストラクタ

オーバーロードの一覧

public CustomBar(Steema.TeeChart.Chart)
public CustomBar()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CustomBar コンストラクタ

Steema.TeeChart.Styles.CustomBar コンストラクタ

public CustomBar(Chart c)

参照

CustomBar コンストラクタのオーバーロードの一覧 | CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CustomBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar コンストラクタ

public CustomBar()

参照

CustomBar コンストラクタのオーバーロードの一覧 | CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomBar クラス | Steema.TeeChart.Styles 名前空間


GetBarStyle

Steema.TeeChart.Styles.CustomBar.GetBarStyle イベント

系列のバーが描画される際に発生します。
public GetBarStyleEventHandler  GetBarStyle

解説

このイベントは、各バーが表示される毎に発生します。各バーポイントにさまざまなバースタイルを指定できます。このイベントを使用して、BarStyleプロパティをオーバーライドします。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent
bColorEach (Seriesの継承元)
bDark3D
bUseOrigin
calcVisiblePoints (Seriesの継承元)
conePercent
customBarSize
dOrigin
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds
IBarSize
iMultiBar
InternalUse (TeeBaseの継承元)
INumBars
IOrderPos
IPreviousCount
lastVisible (Seriesの継承元)
NormalBarColor
pPen
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomBar クラス | Steema.TeeChart.Styles 名前空間


barSizePercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.barSizePercent フィールド

protected internal Int32 barSizePercent

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


bDark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.bDark3D フィールド

protected Boolean bDark3D

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


bUseOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.bUseOrigin フィールド

protected Boolean bUseOrigin

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


conePercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.conePercent フィールド

protected Int32 conePercent

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


customBarSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.customBarSize フィールド

protected Int32 customBarSize

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


dOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.dOrigin フィールド

protected Double dOrigin

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


iBarBounds

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.iBarBounds フィールド

protected Rectangle iBarBounds

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


IBarSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.IBarSize フィールド

protected Int32 IBarSize

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


iMultiBar

Steema.TeeChart.Styles.CustomBar.iMultiBar フィールド

protected MultiBars iMultiBar

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


INumBars

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.INumBars フィールド

protected Int32 INumBars

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


IOrderPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.IOrderPos フィールド

protected Int32 IOrderPos

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


IPreviousCount

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.IPreviousCount フィールド

protected Int32 IPreviousCount

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


NormalBarColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.NormalBarColor フィールド

protected Color NormalBarColor

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


pPen

Steema.TeeChart.Styles.CustomBar.pPen フィールド

protected ChartPen pPen

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin | 両端のマージンをピクセル単位で返します。
BarRectangle | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMarkLength |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawTickLine |
DrawTickLines |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue |
MinMandatoryValue |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin |
SubGalleryStack |
ValueListOfAxis (Seriesの継承元) |

参照

CustomBar クラス | Steema.TeeChart.Styles 名前空間


ApplyBarOffset

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.ApplyBarOffset メソッド

protected Int32 ApplyBarOffset(Int32 position)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarMargin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarMargin メソッド

右端および左端のマージンをピクセル単位で返します。

public Int32 BarMargin()

戻り値

ピクセル単位の両端のマージン。

解説

右端および左端のマージンをピクセル単位で返します。SideMarginsプロパティは、マージンを両端に付加するかどうか制御します。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarRectangle メソッド

オーバーロードの一覧

内部使用。

public Void BarRectangle(System.Drawing.Color, System.Drawing.Rectangle)

内部使用。

public Void BarRectangle(System.Drawing.Color, System.Int32, System.Int32, System.Int32, System.Int32)

解説

パラメーター座標値やBarColorパラメーターを使用して縦棒や横棒ポイントを表示します。

これは、系列の各ポイントを内部的に呼び出します。

BarStyleプロパティは、各ポイントのスタイルを設定します。（例：矩形、楕円、四角錐など）

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarRectangle メソッド

内部使用。

public Void BarRectangle(Color barColor,
     Rectangle r)

参照

BarRectangle オーバーロードの一覧 | CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarRectangle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarRectangle メソッド

内部使用。

public Void BarRectangle(Color barColor,
     Int32 aLeft,
     Int32 aTop,
     Int32 aRight,
     Int32 aBottom)

参照

BarRectangle オーバーロードの一覧 | CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CalcDepthPositions

Steema.TeeChart.Styles.CustomBar.CalcDepthPositions メソッド

protected internal abstract Void CalcDepthPositions()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CalcMarkLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.CalcMarkLength メソッド

protected Int32 CalcMarkLength(Int32 valueIndex)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CalcZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.CalcZOrder メソッド

protected internal virtual Void CalcZOrder()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.Clicked メソッド

オーバーロードの一覧

系列で「クリックされた」ポイントのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で「クリックされた」ポイントのインデックスを返します。「クリックされた」とは、XとY座標値が、ポイント画面領域の境界内にあることを意味します。「触れた」のポイントがなければ、Clickedは-1を返します。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.Clicked メソッド

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.CustomBar.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DoGetBarStyle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.DoGetBarStyle メソッド

protected BarStyles DoGetBarStyle(Int32 valueIndex)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.CustomBar.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DrawTickLine

Steema.TeeChart.Styles.CustomBar.DrawTickLine メソッド

protected abstract Void DrawTickLine(Int32 tickPos,
     BarStyles aStyle)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DrawTickLines

Steema.TeeChart.Styles.CustomBar.DrawTickLines メソッド

protected abstract Void DrawTickLines(Int32 startPos,
     Int32 endPos,
     BarStyles aStyle)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


InternalApplyBarMargin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.InternalApplyBarMargin メソッド

protected Void InternalApplyBarMargin(Int32& marginA,
     Int32& marginB)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


InternalCalcMarkLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.InternalCalcMarkLength メソッド

protected virtual Int32 InternalCalcMarkLength(Int32 valueIndex)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


InternalClicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.InternalClicked メソッド

protected virtual Boolean InternalClicked(Int32 valueIndex,
     Point point)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


InternalGetOriginPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.InternalGetOriginPos メソッド

protected Int32 InternalGetOriginPos(Int32 valueIndex,
     Int32 defaultOrigin)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


MaxMandatoryValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.MaxMandatoryValue メソッド

protected Double MaxMandatoryValue(Double value)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


MinMandatoryValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.MinMandatoryValue メソッド

protected Double MinMandatoryValue(Double value)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.CustomBar.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


PointOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.PointOrigin メソッド

内部使用。

public virtual Double PointOrigin(Int32 valueIndex,
     Boolean sumAll)

解説

1つ以上の系列ポイントの合計値を返します。縦棒系列、横棒系列、面系列などの積み重ねあるいは百分率の積み重ねスタイルを持つ系列型のみにより使用されます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CustomBar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.CustomBar.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SetBarSizePercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.SetBarSizePercent メソッド

protected internal Void SetBarSizePercent(Int32 value)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.CustomBar.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SetDefaultCylinderGradient

Steema.TeeChart.Styles.CustomBar.SetDefaultCylinderGradient メソッド

protected Void SetDefaultCylinderGradient(Color barColor,
     LinearGradientMode gradientDirection)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SetPenBrushBar

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.SetPenBrushBar メソッド

protected Void SetPenBrushBar(Color barColor)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.CustomBar.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeYOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.ShouldSerializeYOrigin メソッド

protected virtual Boolean ShouldSerializeYOrigin()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SubGalleryStack

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.SubGalleryStack メソッド

protected virtual Boolean SubGalleryStack()

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle | バーのスタイルを設定します。
Brush | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent | バーの移動をバーサイズに対する割合で定義します。
Origin | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins | チャート矩形とバーとの間にマージンを設定します。
StackGroup | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX

参照

CustomBar クラス | Steema.TeeChart.Styles 名前空間


AutoMarkPosition

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.AutoMarkPosition プロパティ

オーバーラップを避けるためにマーカを自動的に移動させます。

public Boolean AutoMarkPosition {get; set;}

解説

デフォルト値：true

バー系列のマーカがオーバーラップする可能性がある場合に、マーカを再配置するかどうかを制御します。テキストが長かったり、フォントサイズが大きすぎたりしてマーカがオーバーラップする影響を最小限にするために、マーカはバーの上端位置に移動されます。

falseの場合、チェックは実行されず、すべてのマーカは棒の上端位置に対してMark.ArrowLengthの距離で描かれます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarBounds

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarBounds プロパティ

表示されているバーポイントのサイズを定義する矩形を返します。

public Rectangle BarBounds {get;}

解説

実行時および読込み専用。

表示されているバーポイントのサイズを定義する矩形を返します。

これは、バー系列のDrawValueメソッドが呼び出されている場合のみ計算される内部変数を返します。

｢継承されたDrawValue｣メソッドを呼び出した後で、カスタム派生系列でのみこのプロパティを使用してください。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarBoundsMidX

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.BarBoundsMidX プロパティ

protected Int32 BarBoundsMidX {get;}

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


BarStyle

Steema.TeeChart.Styles.CustomBar.BarStyle プロパティ

バーのスタイルを設定します。
public BarStyles BarStyle {get; set;}

解説

デフォルト値：Rectangle

バーのスタイルを設定します。

例

このコードは、バーのスタイルを四角錐に設定します。

[C#]

Steema.TeeChart.Styles.Bar Series1 = new Steema.TeeChart.Styles.Bar();
tChart1.Series.Add(Series1);
Series1.BarStyle = Pyramid;

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.CustomBar.Brush プロパティ

バーを塗りつぶすブラシを定義します。
public ChartBrush Brush {get;}

解説

バーを塗りつぶすブラシを定義します。Brush.ColorプロパティやBrush.Styleプロパティを設定できます。BarBrush.StyleがbsSolidと異なる場合、Series.Colorの色は背景バーの色になります。

例

このコードはパターン付きでバーを表示します。

[C#]

Steema.TeeChart.Styles.Bar Series1 = new Steema.TeeChart.Styles.Bar();
tChart1.Series.Add(Series1);
Series1.FillSampleValues (20);
Series1.Brush.Style = System.Drawing.Drawing2D.HatchStyle.Cross;
Series1.Brush.Color = Color.white;
Series1.Color = Color Red;

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


CustomBarWidth

Steema.TeeChart.Styles.CustomBar.CustomBarWidth プロパティ

public Int32 CustomBarWidth {get; set;}

解説

デフォルト値：0

固定したバーの幅をピクセル単位で定義します。BarWidthプロパティを使用して現在のバーの幅をピクセル単位で取得できます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Dark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.Dark3D プロパティ

3D効果を表すためにバーの側面を暗くするかどうか制御します。

public Boolean Dark3D {get; set;}

解説

デフォルト値：true

このプロパティは、バーの側面を影の色で塗りつぶすかどうかを制御します。これは、Chart.Aspect.View3Dがtrueの場合にのみ有効です。 ハイカラービデオモード（256色以上）では、暗い色を256色や16色モードよりもはるかに優れた画像を表示します。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


DepthPercent

Steema.TeeChart.Styles.CustomBar.DepthPercent プロパティ

カスタムバーの「Z」深さ方向の割合（0～100%）を定義します。

バーが必要とする「Z」方向の深さを0～100%で設定します。

public Int32 DepthPercent {get; set;}

解説

デフォルト値：100

カスタムバーの「Z」深さの割合（0～100%）を定義します。

デフォルト値は100です。従って、系列が使用可能なZ深さの全領域を使用してカスタムバーを描画します。

デフォルト値：100

バーが必要とする「Z」方向の深さを0～100%で設定します。

デフォルトは、バーは、系列の使用可能な全てのZ（深さ）スペースを使用して描画されます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.CustomBar.Gradient プロパティ

バーを塗りつぶすグラデーション特性を設定します。
public Gradient Gradient {get; set;}

解説

CustomBar系列のバーを塗りつぶすグラデーション特性を設定します。StartColorプロパティ、MidColorプロパティ、EndColorプロパティの3色を使用して塗りつぶします。Directionプロパティを設定することにより、描画出力を制御することができます。Visibleプロパティを使用して、塗りつぶしを有効/無効にすることができます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


GradientRelative

Steema.TeeChart.Styles.CustomBar.GradientRelative プロパティ

グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
public Boolean GradientRelative {get; set;}

解説

グラデーションが有効の場合、一番高いバーに基づいて色を計算します。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


MultiBar

Steema.TeeChart.Styles.CustomBar.MultiBar プロパティ

同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
public MultiBars MultiBar {get; set;}

解説

同じチャート内に複数のバー系列が存在する場合、併置、積み重ねなし、または積み重ね等から選択して描画できます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


OffsetPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.OffsetPercent プロパティ

バーの移動をバーサイズに対する割合で定義します。

public Int32 OffsetPercent {get; set;}

解説

デフォルト値：0

バーの移動をバーサイズに対する割合で定義します。移動は、縦棒系列の場合、水平方向で、横棒系列の場合垂直方向です。このプロパティは、「オーバーレイ」バーチャートを作成するために使用します。正の値、もしくは負の値を指定することができます。

例

このコードは、オーバーレイバーチャートを作成するように3つのバー系列のOffsetPercentを設定します。

[C#]

private void button4_Click(object sender, System.EventArgs e)
{
((Steema.TeeChart.Styles.Bar)tChart1[0]).OffsetPercent=50;
((Steema.TeeChart.Styles.Bar)tChart1[1]).OffsetPercent=0;
((Steema.TeeChart.Styles.Bar)tChart1[2]).OffsetPercent=-50;
}

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Origin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.Origin プロパティ

すべてのバーポイントの基準となる軸の始点を設定します。

public Double Origin {get; set;}

解説

デフォルト値：0

このプロパティは、すべてのバーポイントの基準となる軸の視点を設定します。
このプロパティを使用する場合、UseOriginプロパティをtrue（デフォルト）に設定する必要があります。
バーの値が原点より大きい場合1つの方向に表示され、バーの値が原点より小さい場合逆方向に表示されます。
このプロパティは縦棒系列と横棒系列に適用されます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.CustomBar.Pen プロパティ

バーの矩形を描くペンの種類を定義します。
public ChartPen Pen {get;}

解説

バーの矩形を描くペンの種類を定義します。 BarPen.Visible = falseに設定して、これらの線を非表示にできます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


SideMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.SideMargins プロパティ

チャート矩形とバーとの間にマージンを設定します。

public Boolean SideMargins {get; set;}

解説

デフォルト値：true

最初と最後に表示されているバーをチャート矩形から離すかどうかを制御します。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


StackGroup

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.StackGroup プロパティ

同じチャート内に積み重ね系列のグループ化を設定します。

public Int32 StackGroup {get; set;}

解説

同じチャート内に積み重ね系列のグループ化を設定します。

例

[C#]

このコードは、5系列を作成し、系列の各ValueIndexに5個の積み重ねを行います。（例：10個の積み重ねバー）

private void button2_Click(object sender, System.EventArgs e)
{
barSeries1.FillSampleValues(6);
barSeries2.FillSampleValues(6);
barSeries3.FillSampleValues(6);
barSeries4.FillSampleValues(6);
barSeries5.FillSampleValues(6);
barSeries1.MultiBar = MultiBars.Stacked;
}

このコードは、2グループの積み重ね系列を作成します。2個の積み重ね系列と3個の積み重ね系列になります。ValueIndexポイントの各値にそれぞれの積み重ねグループを作成します。(例：10データポイントに20個の積み重ねバー、各インデックスポイントに2つ）

private void button2_Click(object sender, System.EventArgs e)
{
((Steema.TeeChart.Styles.Bar)tChart1[0]).StackGroup = 0;
((Steema.TeeChart.Styles.Bar)tChart1[1]).StackGroup = 0;
((Steema.TeeChart.Styles.Bar)tChart1[2]).StackGroup = 1;
((Steema.TeeChart.Styles.Bar)tChart1[3]).StackGroup = 1;
((Steema.TeeChart.Styles.Bar)tChart1[4]).StackGroup = 1;
}

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


TickLines

Steema.TeeChart.Styles.CustomBar.TickLines プロパティ

各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
public ChartPen TickLines {get;}

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


UseOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.UseOrigin プロパティ

バーをOriginプロパティ値に下揃えするかどうかを定義します。

public Boolean UseOrigin {get; set;}

解説

デフォルト値：true

バーをOriginプロパティ値に下揃えするかどうかを定義します。

falseの場合、すべてのバー値の最長値がバーの原点の値として使用されます。

trueの場合、Originプロパティがバーの開始点として使用されます。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


YOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.YOrigin プロパティ

このプロパティの代わりにOriginプロパティを使用してください。

public Double YOrigin {get; set;}

旧式

このプロパティの代わりにOriginプロパティを使用してください。

参照

CustomBar クラス | CustomBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs クラス

GetBarStyle イベントのデータを提供します。

この型のすべてのメンバの一覧については、GetBarStyleEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetBarStyleEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

GetBarStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs 全メンバ

GetBarStyleEventArgs 概要

パブリック プロパティ

Style | バー系列のバーのスタイルを設定します。
ValueIndex | 系列のValueListの値のインデックス。

コンストラクタ

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs

参照

GetBarStyleEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventArgs プロパティ

パブリック プロパティ

Style | バー系列のバーのスタイルを設定します。
ValueIndex | 系列のValueListの値のインデックス。

参照

GetBarStyleEventArgs クラス | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs.Style プロパティ

バー系列のBarStyle。
public BarStyles Style {get; set;}

解説

バー系列のBarStyle。

参照

GetBarStyleEventArgs クラス | GetBarStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


ValueIndex

Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs.ValueIndex プロパティ

系列のValueList内の値のインデックス。
public Int32 ValueIndex {get;}

解説

系列のValueList内の値のインデックス。

参照

GetBarStyleEventArgs クラス | GetBarStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


GetBarStyleEventArgs コンストラクタ

Steema.TeeChart.Styles.CustomBar+GetBarStyleEventArgs コンストラクタ

public CustomBar+GetBarStyleEventArgs(Int32 valueIndex,
     BarStyles style)

参照

GetBarStyleEventArgs クラス | GetBarStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBar.GetBarStyleEventHandler

Steema.TeeChart.Styles.CustomBar.GetBarStyleEventHandler デリゲート

GetBarStyleイベントのデリゲート。
public delegate GetBarStyleEventHandler (CustomBar sender,
     GetBarStyleEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox

Steema.TeeChart.Styles.CustomBox クラス

CustomBox系列。

この型のすべてのメンバの一覧については、CustomBox メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class CustomBox : Points , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox 全メンバ

CustomBox 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
ReconstructFromData | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Pointsの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ExtrOut | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position | ボックスプロット系列の位置を指定します。
Quartile1 | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomBox クラス | Steema.TeeChart.Styles 名前空間


CustomBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox コンストラクタ

オーバーロードの一覧

public CustomBox()
public CustomBox(Steema.TeeChart.Chart)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


CustomBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox コンストラクタ

public CustomBox()

参照

CustomBox コンストラクタのオーバーロードの一覧 | CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


CustomBox コンストラクタ

Steema.TeeChart.Styles.CustomBox コンストラクタ

public CustomBox(Chart c)

参照

CustomBox コンストラクタのオーバーロードの一覧 | CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomBox クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomBox クラス | Steema.TeeChart.Styles 名前空間


dPosition

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.dPosition フィールド

protected Double dPosition

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


IVertical

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.IVertical フィールド

protected Boolean IVertical

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox メソッド

パブリック メソッド

Add | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
ReconstructFromData | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomBox クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.CustomBox.Add メソッド

オーバーロードの一覧

CustomBoxのx移動位置と値を追加します。

public Void Add(System.Double, System.Double[])

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.CustomBox.Add メソッド

CustomBoxのx移動位置と値を追加します。
public Void Add(Double aPosition,
     Double[] values)

参照

Add オーバーロードの一覧 | CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.CustomBox.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.CustomBox.Draw メソッド

public override Void Draw()

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.CustomBox.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

Steema.TeeChart.Styles.CustomBox.DrawValue メソッド

系列の｢ValueIndex｣ポイントを描画します。
public override Void DrawValue(Int32 index)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.CustomBox.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


GetDataSource

Steema.TeeChart.Styles.CustomBox.GetDataSource メソッド

protected internal abstract Object GetDataSource()

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CustomBox.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


ReconstructFromData

Steema.TeeChart.Styles.CustomBox.ReconstructFromData メソッド

系列データからボックスプロットを再構築します。
public Void ReconstructFromData()

解説

系列データからボックスプロットを再構築します。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.CustomBox.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomBox プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Pointsの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ExtrOut | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position | ボックスプロット系列の位置を指定します。
Quartile1 | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CustomBox クラス | Steema.TeeChart.Styles 名前空間


AdjacentPoint1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.AdjacentPoint1 プロパティ

隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Int32 AdjacentPoint1 {get; set;}

解説

隣接ポイントより下のSampleValuesを取得するために使用してください。AdjacentPoint1はInnerFence1以下ではない、InnerFence1に一番近いデータポイントです。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


AdjacentPoint3

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.AdjacentPoint3 プロパティ

隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Int32 AdjacentPoint3 {get; set;}

解説

隣接ポイントより上のSampleValuesを取得するために使用してください。AdjacentPoint3はInnerFence3以上ではない、InnerFence3に一番近いデータポイントです。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Box

Steema.TeeChart.Styles.CustomBox.Box プロパティ

CustomBox系列のボックスの外観を制御します。
public SeriesPointer Box {get;}

解説

CustomBox系列ボックスの外観を制御します。ボックスは、Pen、Brush、Draw3D、Visibleなどのボックスの形式属性を制御するプロパティを含んでいます。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


ExtrOut

Steema.TeeChart.Styles.CustomBox.ExtrOut プロパティ

極値の外観を制御します。
public SeriesPointer ExtrOut {get;}

解説

極値の外観を制御するために使用してください。このプロパティには、Pen、Brush、Draw3D、Visibleなどの極値の書式属性を制御するプロパティが含まれています。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


InnerFence1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.InnerFence1 プロパティ

内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double InnerFence1 {get; set;}

解説

内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


InnerFence3

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.InnerFence3 プロパティ

内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double InnerFence3 {get; set;}

解説

内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Median

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.Median プロパティ

中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double Median {get; set;}

解説

中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタムな値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


MedianPen

Steema.TeeChart.Styles.CustomBox.MedianPen プロパティ

中央値の線を描くペンを定義します。
public ChartPen MedianPen {get;}

解説

中央値の線の色やスタイルを定義するPenオブジェクトを含んでいます。中央値のペンの色あるいはスタイルを変更するために使用してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


MildOut

Steema.TeeChart.Styles.CustomBox.MildOut プロパティ

外れ値の外観を制御します。
public SeriesPointer MildOut {get;}

解説

外れ値の外観を制御するために使用してください。このプロパティには、Pen、Brush、Draw3D、Visibleなどの外れ値の書式属性を変更するプロパティを含んでいます。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


OuterFence1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.OuterFence1 プロパティ

外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double OuterFence1 {get; set;}

解説

外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


OuterFence3

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.OuterFence3 プロパティ

外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double OuterFence3 {get; set;}

解説

外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Position

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.Position プロパティ

ボックスプロット系列の位置を指定します。

public Double Position {get; set;}

解説

ボックスプロット系列の位置を指定します。系列が縦ボックスプロット系列の場合、水平軸の位置を指定します。系列が横ボックスプロット系列の場合、垂直軸の位置を指定します。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Quartile1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.Quartile1 プロパティ

第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double Quartile1 {get; set;}

解説

第１四分位数のSampleValuesを取得するために使用してください。データのほぼ25%がQuartile1と同等かQuartile1以下です。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Quartile3

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.Quartile3 プロパティ

第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。

public Double Quartile3 {get; set;}

解説

第３四分位数のSampleValuesを取得するために使用してください。データのほぼ75%がQuartile3と同等またはQuartile3以下になります。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、TCustomBoxSeriesのデフォルトの計算アルゴリズムをオーバーライドします。

メモ：カスタム値を使用する場合、UseCustomValuesプロパティをtrueに設定してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


SampleValues

Steema.TeeChart.Styles.CustomBox.SampleValues プロパティ

系列の値にアクセスするために使用してください。
public ValueList SampleValues {get;}

解説

系列の値にアクセスするために使用してください。

警告：内部的なアルゴリズム（UseCustomValuesプロパティ = false）を使用している場合、このプロパティが昇順でソートされていなければなりません。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


UseCustomValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.UseCustomValues プロパティ

ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。

public Boolean UseCustomValues {get; set;}

解説

デフォルト値：false

ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。

デフォルト（内部）のアルゴリズムは以下のステップを行います。

1. Median、Quartile1、Quartile3、IQRの値を検出します。

2. 以下の方程式を使用してInnerFence1とInnerFence3を検出します。
InnerFence1 = Quartile1 - WhiskerLength*IQR
InnerFence3 = Quartile3 + WhiskerLength*IQR

3. AdjacentPoint1とAdjacentPoint3を検出します。

4. 以下の方程式を使用してOuterFence1とOuterFence3を検出します。
OuterFence1 = Quartile1 - 2*WhiskerLength*IQR
OuterFence3 = Quartile3 + 2*WhiskerLength*IQR

5. 中央値に描く内部の線でQuartile1とQuartile3の終わりにボックスを作成します。

6. 隣接ポイントを示し、隣接ポイントを線でボックスに接続します。内側フェンスと外側フェンスの間のすべてのデータポイントを位置付け、シンボルで表します。これらのポイントは外れ値としてみなされます。そのの他シンボルで外側フェンス超えるデータポイントを示します。これらのポイントは極値とみなされます。

メモ：このプロパティをtrueに設定するとMedian、Quartile1、Quartile3、InnerFence1、InnerFence3、OuterFence1、OuterFence3、AdjacentPoint1、AdjacentPoint3プロパティも定義しなければなりません。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


WhiskerLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomBox.WhiskerLength プロパティ

ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。

public Double WhiskerLength {get; set;}

解説

デフォルト値：1.50
このプロパティは、ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


WhiskerPen

Steema.TeeChart.Styles.CustomBox.WhiskerPen プロパティ

ひげを描くペンを定義します。
public ChartPen WhiskerPen {get;}

解説

ひげの色やスタイルを変更するために使用してください。

参照

CustomBox クラス | CustomBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError

Steema.TeeChart.Styles.CustomError クラス

CustomErrorSeries系列。

この型のすべてのメンバの一覧については、CustomError メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class CustomError : Bar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomError メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError 全メンバ

CustomError 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description (Barの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ErrorPen | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle | エラー系列のスタイルを定義します。
ErrorValues | 各バーに該当するエラー値を取得/設定します。
ErrorWidth | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

CustomError クラス | Steema.TeeChart.Styles 名前空間


CustomError コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError コンストラクタ

オーバーロードの一覧

public CustomError()
public CustomError(Steema.TeeChart.Chart)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


CustomError コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError コンストラクタ

public CustomError()

参照

CustomError コンストラクタのオーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


CustomError コンストラクタ

Steema.TeeChart.Styles.CustomError コンストラクタ

public CustomError(Chart c)

参照

CustomError コンストラクタのオーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomError クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomError クラス | Steema.TeeChart.Styles 名前空間


bDrawBar

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.bDrawBar フィールド

protected Boolean bDrawBar

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


iErrorStyle

Steema.TeeChart.Styles.CustomError.iErrorStyle フィールド

protected ErrorStyles iErrorStyle

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError メソッド

パブリック メソッド

Add | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomError クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.Add メソッド

オーバーロードの一覧

選択した色とラベルで新しいエラーバーポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

系列にラベルを持つ新しいエラーバーポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

系列に新しいエラーバーポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double)

選択した色で系列に新しいエラーバーポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

解説

新しいエラーバーポイントを追加します。

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.Add メソッド

選択した色とラベルで新しいエラーバーポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double errorValue,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.Add メソッド

系列にラベルを持つ新しいエラーバーポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double errorValue,
     String text)

参照

Add オーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.Add メソッド

系列に新しいエラーバーポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double errorValue)

参照

Add オーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.Add メソッド

選択した色で系列に新しいエラーバーポイントを追加します。

public Int32 Add(Double x,
     Double y,
     Double errorValue,
     Color color)

参照

Add オーバーロードの一覧 | CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


AddValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.AddValue メソッド

系列に新しいエラーバーポイントを追加します。

public Int32 AddValue(Double y,
     Double errorValue)

戻り値

追加したポイントのValueListインデックス。

解説

y値とエラー値のみを持つ新しいエラーバーポイントを追加します。

例

[C#]

errorSeries1.AddValue(28,2);

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


DrawBar

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.DrawBar メソッド

開始と終了のピクセル座標を使用してエラーバーポイントを表示します。

public virtual Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

解説

内部使用。
開始と終了のピクセル座標を使用してエラーバーポイントを表示します。

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.CustomError.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle r)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CustomError.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomError プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description (Barの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ErrorPen | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle | エラー系列のスタイルを定義します。
ErrorValues | 各バーに該当するエラー値を取得/設定します。
ErrorWidth | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

CustomError クラス | Steema.TeeChart.Styles 名前空間


ErrorPen

Steema.TeeChart.Styles.CustomError.ErrorPen プロパティ

エラーバー上部にエラー｢T｣を描くペンを定義します。
public ChartPen ErrorPen {get;}

解説

エラーバー上部にエラー｢T｣を描くペンを定義します。

例

このコードはエラーバーの外観を変更します。

[C#]

Steema.TeeChart.Styles.ErrorBar Series1 = new Steema.TeeChart.Styles.ErrorBar();
tChart1.Series.Add(Series1);
Series1.ErrorPen.Visible = true;
Series1.ErrorPen.Width = 2;
Series1.ErrorPen.Color = Color.Blue;
Series1.ErrorPen.Style = DashStyle.Solid;

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


ErrorStyle

Steema.TeeChart.Styles.CustomError.ErrorStyle プロパティ

ErrorStylesによりエラー系列のスタイルを定義します。
public ErrorStyles ErrorStyle {get; set;}

解説

ErrorStylesによりエラー系列のスタイルを定義します。

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


ErrorValues

Steema.TeeChart.Styles.CustomError.ErrorValues プロパティ

各バーに該当するエラー値を取得/設定します。
public ValueList ErrorValues {get;}

解説

各バーに該当するエラー値を管理します。エラー値は各バーの上部に｢T｣と表示されます。

例

このコードは最初のエラーバーのエラー値を変更します。

[C#]

Steema.TeeChart.Styles.ErrorBar Series1 = new Steema.TeeChart.Styles.ErrorBar();
tChart1.Series.Add(Series1);
Series1.ErrorValues.Value[0] = 34.56;

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


ErrorWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomError.ErrorWidth プロパティ

エラー｢T｣の水平サイズを設定します。

public Int32 ErrorWidth {get; set;}

解説

デフォルト値：100

エラー｢T｣の水平サイズを設定します。サイズは、ピクセル単位またはErrorWidthUnitsプロパティによるバー幅の割合のどちらかで表現されます。

例

このコードはエラー｢T｣の幅を34ピクセルに設定します。

[C#]

Steema.TeeChart.Styles.ErrorBar Series1 = new Steema.TeeChart.Styles.ErrorBar();
tChart1.Series.Add(Series1);
Series1.ErrorWidthUnits = ErrorWidthUnits.Pixels;
Series1.ErrorWidth = 34;

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


ErrorWidthUnits

Steema.TeeChart.Styles.CustomError.ErrorWidthUnits プロパティ

ErrorWidthプロパティのための単位を設定します。
public ErrorWidthUnits ErrorWidthUnits {get; set;}

解説

デフォルト値：Percent

ErrorWidthプロパティがピクセル単位あるいはバー幅の割合のどちらで表現されるかどうかを設定します。デフォルトではエラー｢T｣の幅はバー幅の100%です。

例

このコードはエラー｢T｣の幅をバー幅の25%に設定します。

[C#]

Steema.TeeChart.Styles.ErrorBar Series1 = new Steema.TeeChart.Styles.ErrorBar();
tChart1.Series.Add(Series1);
Series1.ErrorWidthUnits = ErrorWidthUnits.Percent;
Series1.ErrorWidth = 25;

参照

CustomError クラス | CustomError メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge

Steema.TeeChart.Styles.CustomGauge クラス

この型のすべてのメンバの一覧については、CustomGauge メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class CustomGauge : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge 全メンバ

CustomGauge 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged | ゲージ系列のValueプロパティが変更されると発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
BlackPalette |
BluesPalette |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetGaugePaletteColor | GaugeColorPalette内の指定したインデックスの色を返します。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
GreenLine | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue | 「緑線」マーカの開始値を取得/設定します。
Hand | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue
fgreenLineStartValue
firstVisible (Seriesの継承元)
fmaximum
fminimum
fredLineEndValue
fredLineStartValue
INewRectangle
InternalUse (TeeBaseの継承元)
IOrigRectangle
IRange
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis |
DrawAxisMinorTick |
DrawAxisTick |
DrawColorLines |
DrawFace |
DrawFrame |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged |
PaintLegend (Seriesの継承元) |
PrepareGraphics |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge コンストラクタ

オーバーロードの一覧

public CustomGauge()
public CustomGauge(Steema.TeeChart.Chart)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge コンストラクタ

public CustomGauge()

参照

CustomGauge コンストラクタのオーバーロードの一覧 | CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge コンストラクタ

public CustomGauge(Chart c)

参照

CustomGauge コンストラクタのオーバーロードの一覧 | CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged | ゲージ系列のValueプロパティが変更されると発生します。

参照

CustomGauge クラス | Steema.TeeChart.Styles 名前空間


ValueChanged

Steema.TeeChart.Styles.CustomGauge.ValueChanged イベント

ゲージ系列のValueプロパティが変更されると発生します。
public GaugesChangeHandler  ValueChanged

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
BlackPalette |
BluesPalette |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue
fgreenLineStartValue
firstVisible (Seriesの継承元)
fmaximum
fminimum
fredLineEndValue
fredLineStartValue
INewRectangle
InternalUse (TeeBaseの継承元)
IOrigRectangle
IRange
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomGauge クラス | Steema.TeeChart.Styles 名前空間


BlackPalette

Steema.TeeChart.Styles.CustomGauge.BlackPalette フィールド

public Color[] BlackPalette

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


BluesPalette

Steema.TeeChart.Styles.CustomGauge.BluesPalette フィールド

public Color[] BluesPalette

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fgreenLineEndValue

Steema.TeeChart.Styles.CustomGauge.fgreenLineEndValue フィールド

protected Double fgreenLineEndValue

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fgreenLineStartValue

Steema.TeeChart.Styles.CustomGauge.fgreenLineStartValue フィールド

protected Double fgreenLineStartValue

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fmaximum

Steema.TeeChart.Styles.CustomGauge.fmaximum フィールド

protected Double fmaximum

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fminimum

Steema.TeeChart.Styles.CustomGauge.fminimum フィールド

protected Double fminimum

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fredLineEndValue

Steema.TeeChart.Styles.CustomGauge.fredLineEndValue フィールド

protected Double fredLineEndValue

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


fredLineStartValue

Steema.TeeChart.Styles.CustomGauge.fredLineStartValue フィールド

protected Double fredLineStartValue

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


INewRectangle

Steema.TeeChart.Styles.CustomGauge.INewRectangle フィールド

protected Rectangle INewRectangle

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


IOrigRectangle

Steema.TeeChart.Styles.CustomGauge.IOrigRectangle フィールド

protected Rectangle IOrigRectangle

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


IRange

Steema.TeeChart.Styles.CustomGauge.IRange フィールド

protected Double IRange

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetGaugePaletteColor | GaugeColorPalette内の指定したインデックスの色を返します。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis |
DrawAxisMinorTick |
DrawAxisTick |
DrawColorLines |
DrawFace |
DrawFrame |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged |
PaintLegend (Seriesの継承元) |
PrepareGraphics |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomGauge クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.CustomGauge.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.CustomGauge.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.CustomGauge.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.CustomGauge.Draw メソッド

public override Void Draw()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawAxis

Steema.TeeChart.Styles.CustomGauge.DrawAxis メソッド

protected abstract Void DrawAxis(Graphics3D g)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawAxisMinorTick

Steema.TeeChart.Styles.CustomGauge.DrawAxisMinorTick メソッド

protected abstract Void DrawAxisMinorTick(Graphics3D g,
     Point Inner,
     Point Outer)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawAxisTick

Steema.TeeChart.Styles.CustomGauge.DrawAxisTick メソッド

protected abstract Void DrawAxisTick(Graphics3D g,
     Point Inner,
     Point InnerPlus,
     Point InnerMinus,
     Point Outer,
     Point OuterPlus,
     Point OuterMinus)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawColorLines

Steema.TeeChart.Styles.CustomGauge.DrawColorLines メソッド

protected abstract Void DrawColorLines(Graphics3D g)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawFace

Steema.TeeChart.Styles.CustomGauge.DrawFace メソッド

protected abstract Void DrawFace(Graphics3D g)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawFrame

Steema.TeeChart.Styles.CustomGauge.DrawFrame メソッド

protected abstract Void DrawFrame()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawHand

Steema.TeeChart.Styles.CustomGauge.DrawHand メソッド

protected abstract Void DrawHand(Graphics3D g)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GetAxis

Steema.TeeChart.Styles.CustomGauge.GetAxis メソッド

protected abstract Axis GetAxis()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GetGaugePaletteColor

Steema.TeeChart.Styles.CustomGauge.GetGaugePaletteColor メソッド

GaugeColorPalette内の指定したインデックスの色を返します。
public static Color GetGaugePaletteColor(Int32 Index,
     Color[] GaugeColorPalette)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


IsDefaultAxis

Steema.TeeChart.Styles.CustomGauge.IsDefaultAxis メソッド

protected abstract Boolean IsDefaultAxis()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


OnValueChanged

Steema.TeeChart.Styles.CustomGauge.OnValueChanged メソッド

protected abstract Void OnValueChanged(EventArgs e)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


PrepareGraphics

Steema.TeeChart.Styles.CustomGauge.PrepareGraphics メソッド

protected abstract Graphics3D PrepareGraphics(ChartPen pen,
     ChartBrush brush)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


SetAxisOnce

Steema.TeeChart.Styles.CustomGauge.SetAxisOnce メソッド

protected abstract Void SetAxisOnce()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


SetValue

Steema.TeeChart.Styles.CustomGauge.SetValue メソッド

protected abstract Void SetValue(Double value)

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


SetValues

Steema.TeeChart.Styles.CustomGauge.SetValues メソッド

protected abstract Void SetValues()

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomGauge プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
GreenLine | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue | 「緑線」マーカの開始値を取得/設定します。
Hand | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CustomGauge クラス | Steema.TeeChart.Styles 名前空間


Axis

Steema.TeeChart.Styles.CustomGauge.Axis プロパティ

線形ゲージの軸特性を取得します。
public Axis Axis {get;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


FaceBrush

Steema.TeeChart.Styles.CustomGauge.FaceBrush プロパティ

カスタムゲージの計器盤のChartBrush特性を取得/設定します。
public ChartBrush FaceBrush {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Frame

Steema.TeeChart.Styles.CustomGauge.Frame プロパティ

フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
public TFrame Frame {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GaugeColorPalette

Steema.TeeChart.Styles.CustomGauge.GaugeColorPalette プロパティ

円形ゲージのカラーパレットを取得/設定します。
public Color[] GaugeColorPalette {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLine

Steema.TeeChart.Styles.CustomGauge.GreenLine プロパティ

「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
public GaugeSeriesPointer GreenLine {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLineEndValue

Steema.TeeChart.Styles.CustomGauge.GreenLineEndValue プロパティ

「緑線」マーカの終了値を取得/設定します。
public Double GreenLineEndValue {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


GreenLineStartValue

Steema.TeeChart.Styles.CustomGauge.GreenLineStartValue プロパティ

「緑線」マーカの開始値を取得/設定します。
public Double GreenLineStartValue {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Hand

Steema.TeeChart.Styles.CustomGauge.Hand プロパティ

針オブジェクトの特性を取得/設定します。
public GaugeSeriesPointer Hand {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Horizontal

Steema.TeeChart.Styles.CustomGauge.Horizontal プロパティ

数値ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
public Boolean Horizontal {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Maximum

Steema.TeeChart.Styles.CustomGauge.Maximum プロパティ

ゲージの最大値を取得/設定します。
public Double Maximum {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Minimum

Steema.TeeChart.Styles.CustomGauge.Minimum プロパティ

ゲージの最小値を取得/設定します。
public Double Minimum {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


MinorTickDistance

Steema.TeeChart.Styles.CustomGauge.MinorTickDistance プロパティ

軸から離す副目盛の位置（距離）をピクセル単位で設定します。
public Int32 MinorTickDistance {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


MinorTicks

Steema.TeeChart.Styles.CustomGauge.MinorTicks プロパティ

軸の副目盛の特性を取得/設定します。
public GaugeSeriesPointer MinorTicks {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLine

Steema.TeeChart.Styles.CustomGauge.RedLine プロパティ

「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
public GaugeSeriesPointer RedLine {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLineEndValue

Steema.TeeChart.Styles.CustomGauge.RedLineEndValue プロパティ

「赤線」マーカの終了値を取得/設定します。
public Double RedLineEndValue {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


RedLineStartValue

Steema.TeeChart.Styles.CustomGauge.RedLineStartValue プロパティ

「赤線」マーカの開始値を取得/設定します。
public Double RedLineStartValue {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Ticks

Steema.TeeChart.Styles.CustomGauge.Ticks プロパティ

軸の目盛の特性を取得/設定します。
public GaugeSeriesPointer Ticks {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Value

Steema.TeeChart.Styles.CustomGauge.Value プロパティ

ゲージの矢印線の位置を取得/設定します。
public Double Value {get; set;}

参照

CustomGauge クラス | CustomGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint

Steema.TeeChart.Styles.CustomImagePoint クラス

この型のすべてのメンバの一覧については、CustomImagePoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class CustomImagePoint : Points , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint 全メンバ

CustomImagePoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetImage |
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Pointsの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
PointImage |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomImagePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint コンストラクタ

オーバーロードの一覧

public CustomImagePoint()
public CustomImagePoint(Steema.TeeChart.Chart)

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint コンストラクタ

public CustomImagePoint()

参照

CustomImagePoint コンストラクタのオーバーロードの一覧 | CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint コンストラクタ

public CustomImagePoint(Chart c)

参照

CustomImagePoint コンストラクタのオーバーロードの一覧 | CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetImage |
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomImagePoint クラス | Steema.TeeChart.Styles 名前空間


GetImage

Steema.TeeChart.Styles.CustomImagePoint.GetImage イベント

public GetImageEvent  GetImage

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomImagePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomImagePoint クラス | Steema.TeeChart.Styles 名前空間


DrawValue

Steema.TeeChart.Styles.CustomImagePoint.DrawValue メソッド

public override Void DrawValue(Int32 valueIndex)

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CustomImagePoint.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomImagePoint プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Pointsの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
PointImage |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CustomImagePoint クラス | Steema.TeeChart.Styles 名前空間


PointImage

Steema.TeeChart.Styles.CustomImagePoint.PointImage プロパティ

public Image PointImage {get; set;}

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Transparent

Steema.TeeChart.Styles.CustomImagePoint.Transparent プロパティ

public Boolean Transparent {get; set;}

参照

CustomImagePoint クラス | CustomImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint

Steema.TeeChart.Styles.CustomPoint クラス

TeeChartの系列型の数により継承された基本系列クラス。

この型のすべてのメンバの一覧については、CustomPoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class CustomPoint : BaseLine , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint 全メンバ

CustomPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked
lastVisible (Seriesの継承元)
point
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomPoint クラス | Steema.TeeChart.Styles 名前空間


CustomPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint コンストラクタ

オーバーロードの一覧

public CustomPoint()
public CustomPoint(Steema.TeeChart.Chart)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CustomPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint コンストラクタ

public CustomPoint()

参照

CustomPoint コンストラクタのオーバーロードの一覧 | CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CustomPoint コンストラクタ

Steema.TeeChart.Styles.CustomPoint コンストラクタ

public CustomPoint(Chart c)

参照

CustomPoint コンストラクタのオーバーロードの一覧 | CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomPoint クラス | Steema.TeeChart.Styles 名前空間


ClickPointer

Steema.TeeChart.Styles.CustomPoint.ClickPointer イベント

このイベントは、ポイントがクリックされると発生します。
public ClickPointerEventHandler  ClickPointer

解説

このイベントは、ポイントがクリックされると発生します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


GetPointerStyle

Steema.TeeChart.Styles.CustomPoint.GetPointerStyle イベント

このイベントは、系列ポイントを描画する直前に発生します。
public GetPointerStyleEventHandler  GetPointerStyle

解説

このイベントは、ポイントを描画する直前に発生します。

このイベントを使用して、ペン、ポインタのスタイル、色などの特性を変更できます。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomPoint クラス | Steema.TeeChart.Styles 名前空間


iStacked

Steema.TeeChart.Styles.CustomPoint.iStacked フィールド

protected CustomStack iStacked

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


point

Steema.TeeChart.Styles.CustomPoint.point フィールド

protected internal SeriesPointer point

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomPoint クラス | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.CustomPoint.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.CalcXPos メソッド

指定したValueIndexのポイントの水平画面座標をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

指定したValueIndexのポイントの水平画面座標をピクセル単位で返します。

この座標は水平軸に関連している系列を使用して計算されます。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.CalcYPos メソッド

指定したValueIndexのポイントの垂直画面座標をピクセル単位で返します。

public virtual Int32 CalcYPos(Int32 valueIndex)

解説

指定したValueIndexのポイントの垂直画面座標をピクセル単位で返します。

この座標値は垂直軸に関連した系列を使用して計算されます。

例

系列ポイントの垂直画面座標を調べる場合、以下のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


CalcZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.CalcZOrder メソッド

protected internal virtual Void CalcZOrder()

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのValueIndex を返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのValueIndexを返します。「クリックされた」とは、XとY座標値が、ポイント画面領域の境界内にあることを意味します。「触れた」のポイントがなければ、Clickedは-1を返します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.Clicked メソッド

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


ClickedPointer

Steema.TeeChart.Styles.CustomPoint.ClickedPointer メソッド

内部使用。
public abstract Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

解説

内部使用。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.CustomPoint.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.CustomPoint.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


DrawPointer

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.DrawPointer メソッド

キャンバスに系列ポインタを描画します。

public Void DrawPointer(Int32 aX,
     Int32 aY,
     Color aColor,
     Int32 valueIndex)

解説

キャンバスの指定したaX、aYの画面ピクセル座標値に、ValueIndex番目の系列のポインタを描画します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.CustomPoint.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


GetOriginPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.GetOriginPos メソッド

protected virtual Int32 GetOriginPos(Int32 valueIndex)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.CustomPoint.MaxXValue メソッド

系列のX値リストの最大値を返します。
public override Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

Steema.TeeChart.Styles.CustomPoint.MinXValue メソッド

系列のX値リストの最小値を返します。
public override Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.CustomPoint.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


OnClickPointer

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPoint.OnClickPointer メソッド

protected Void OnClickPointer(Int32 valueIndex,
     Int32 x,
     Int32 y)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPoint.OnGetPointerStyle メソッド

protected Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPoint.OnGetPointerStyle メソッド

protected Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style)

参照

OnGetPointerStyle オーバーロードの一覧 | CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPoint.OnGetPointerStyle メソッド

protected Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style,
     Color& aColor)

参照

OnGetPointerStyle オーバーロードの一覧 | CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


SameClassOrigin

Steema.TeeChart.Styles.CustomPoint.SameClassOrigin メソッド

protected abstract Boolean SameClassOrigin(Series s)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.CustomPoint.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CustomPoint クラス | Steema.TeeChart.Styles 名前空間


Pointer

Steema.TeeChart.Styles.CustomPoint.Pointer プロパティ

系列ポインタの特性を設定します。
public SeriesPointer Pointer {get;}

解説

このプロパティは、散布図系列、リボン系列、泡系列などのその他すべての派生散布図系列クラスのサブクラスです。
散布図系列の各ポイントは、Pointerプロパティを使用して描画されます。
Pointerプロパティには、Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Stacked

Steema.TeeChart.Styles.CustomPoint.Stacked プロパティ

複数系列をどのように描画するか定義します。
public CustomStack Stacked {get; set;}

解説

散布図系列の積み重ねオプションを設定します。

CustomSeriesStack.None: 積み重ねなし。全ての系列は、各Z位置で描画されます。

CustomSeriesStack.Overlap: 系列は、同じZ位置で描画されます（全ての系列は、同じZOrder位置になります）。これは、同じ系列ポイントが重なって描画されます。

CustomSeriesStack.Stack: 積み重ね系列は、系列の低い順から上に向かって描画します。各ポイント値は、下に系列が存在する場合、そのポイントと加算した位置に描画されます。

CustomSeriesStack.Stack100: チャートの下から上を使用して各ポイントを百分率で描画します。

参照

CustomPoint クラス | CustomPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint.ClickPointerEventHandler

Steema.TeeChart.Styles.CustomPoint.ClickPointerEventHandler デリゲート

ClickPointerイベントのデリゲート。
public delegate ClickPointerEventHandler (CustomPoint series,
     Int32 valueIndex,
     Int32 x,
     Int32 y)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPoint.GetPointerStyleEventHandler

Steema.TeeChart.Styles.CustomPoint.GetPointerStyleEventHandler デリゲート

GetPointerStyleイベントのデリゲート。
public delegate GetPointerStyleEventHandler (CustomPoint series,
     GetPointerStyleEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar

Steema.TeeChart.Styles.CustomPolar クラス

CustomPolar系列。

この型のすべてのメンバの一覧については、CustomPolar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class CustomPolar : Circular , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar 全メンバ

CustomPolar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawRing |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues | 各極ポイントの角度値リストを取得します。
Brush | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont | サークル系列（例：レーダーあるいは極系列）のラベルのフォント特性を設定します。
CircleLabelsInside | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | ポインタの書式属性を制御します。
RadiusIncrement | リンググリッド線を描くインクリメントを設定します。
RadiusValues | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | 0～100%までの透明度を設定します。.
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount
InternalUse (TeeBaseの継承元)
iPointer
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomPolar クラス | Steema.TeeChart.Styles 名前空間


CustomPolar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar コンストラクタ

オーバーロードの一覧

public CustomPolar()
public CustomPolar(Steema.TeeChart.Chart)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CustomPolar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar コンストラクタ

public CustomPolar()

参照

CustomPolar コンストラクタのオーバーロードの一覧 | CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CustomPolar コンストラクタ

Steema.TeeChart.Styles.CustomPolar コンストラクタ

public CustomPolar(Chart c)

参照

CustomPolar コンストラクタのオーバーロードの一覧 | CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

CustomPolar クラス | Steema.TeeChart.Styles 名前空間


GetPointerStyle

Steema.TeeChart.Styles.CustomPolar.GetPointerStyle イベント

系列ポイントを描画する際に発生します。
public GetPointerStyleEventHandler  GetPointerStyle

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount
InternalUse (TeeBaseの継承元)
iPointer
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

CustomPolar クラス | Steema.TeeChart.Styles 名前空間


IMaxValuesCount

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.IMaxValuesCount フィールド

protected Int32 IMaxValuesCount

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


iPointer

Steema.TeeChart.Styles.CustomPolar.iPointer フィールド

protected SeriesPointer iPointer

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawRing |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

CustomPolar クラス | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.CustomPolar.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CalcXPos メソッド

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

この座標値は水平軸に関連した系列を使用して計算されます。

例

系列ポイントの水平画面座標値を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CalcXYPos

Steema.TeeChart.Styles.CustomPolar.CalcXYPos メソッド

protected internal Void CalcXYPos(Double xvalue,
     Double yvalue,
     Double aRadius,
     Int32& x,
     Int32& y)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CalcYPos メソッド

指定したValueIndexの系列値の垂直画面座標をピクセル単位で返します。

public virtual Int32 CalcYPos(Int32 valueIndex)

解説

指定したValueIndexの系列値の垂直画面座標をピクセル単位で返します。

この座標値は垂直軸に関連した系列を使用して計算されます。

例

系列ポイントの垂直画面座標値を調べる場合は、次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.CustomPolar.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.CustomPolar.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DoAfterDrawValues

Steema.TeeChart.Styles.CustomPolar.DoAfterDrawValues メソッド

protected internal abstract Void DoAfterDrawValues()

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.CustomPolar.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.CustomPolar.Draw メソッド

public override Void Draw()

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.CustomPolar.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.CustomPolar.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawPolarCircle

Steema.TeeChart.Styles.CustomPolar.DrawPolarCircle メソッド

protected abstract Void DrawPolarCircle(Int32 HalfWidth,
     Int32 HalfHeight,
     Int32 Z)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawRing

Steema.TeeChart.Styles.CustomPolar.DrawRing メソッド

public Void DrawRing(Double value,
     Int32 z)

解説

指定したvalueパラメータ値の半径で極チャートにリングを描きます。

Zパラメータは、リングを表示するZ位置を定義します。
Z位置の前か後ろにリングを描画するかによって、TPolarSeriesのStartZプロパティ、あるいはEndZプロパティを使用できます。（これは、極系列を正面の状態で見ると違いがわかりませんが、極系列を横向きになるように回転させ、深さを大きくすることにより理解できます）。

Series1.DrawRing(1234, Series1.EndZ );

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


DrawZone

Steema.TeeChart.Styles.CustomPolar.DrawZone メソッド

public Void DrawZone(Double Min,
     Double Max,
     Int32 z)

解説

軸スケールの最小値から最大値に（ドーナツのような）楕円「ゾーン」を描画します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.CustomPolar.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


GetCircleLabel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.GetCircleLabel メソッド

protected virtual String GetCircleLabel(Double angle,
     Int32 index)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


GetXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.GetXValue メソッド

protected virtual Double GetXValue(Int32 valueIndex)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


InternalDrawValue

Steema.TeeChart.Styles.CustomPolar.InternalDrawValue メソッド

protected abstract Void InternalDrawValue(Int32 valueIndex,
     Int32 X,
     Int32 Y)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.CustomPolar.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 index)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.CustomPolar.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle メソッド

public abstract Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle メソッド

public abstract Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style)

参照

OnGetPointerStyle オーバーロードの一覧 | CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.CustomPolar.OnGetPointerStyle メソッド

public abstract Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style,
     Color& aColor)

参照

OnGetPointerStyle オーバーロードの一覧 | CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.CustomPolar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.CustomPolar.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues | 各極ポイントの角度値リストを取得します。
Brush | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont | サークル系列（例：レーダーあるいは極系列）のラベルのフォント特性を設定します。
CircleLabelsInside | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement | リンググリッド線を描くインクリメントを設定します。
RadiusValues | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | 0～100%までの透明度を設定します。
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

CustomPolar クラス | Steema.TeeChart.Styles 名前空間


AngleIncrement

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.AngleIncrement プロパティ

反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。

public Double AngleIncrement {get; set;}

解説

反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。0の開始角度は一番右の極座標に置かれます。有効範囲は0～359度です。

Chart.Axis.Bottom.Gridプロパティを使用することで、グリッド線のペンを制御できます。

例

[C#]

Steema.TeeChart.Styles.Polar Series1 = new Steema.TeeChart.Styles.Polar();
tChart1.Series.Add(Series1);
Series1.AngleIncrement = 45;

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


AngleValues

Steema.TeeChart.Styles.CustomPolar.AngleValues プロパティ

各極ポイントの角度値リストを取得します。
public ValueList AngleValues {get;}

解説

各極ポイントの角度値リストです。

このプロパティは、各極ポイントの角度値を保持するTListオブジェクトです。AngleValues.Value[ ]プロパティを使用して、角度値を変更することができます。

例

[C#]

Series1.AngleValues.Value[0] = 270;

これは最初のポイントの角度を270に設定します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.CustomPolar.Brush プロパティ

極のブラシを設定します。
public ChartBrush Brush {get;}

解説

極のブラシを設定します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CircleLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CircleLabels プロパティ

サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。

public Boolean CircleLabels {get; set;}

解説

サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CircleLabelsFont

Steema.TeeChart.Styles.CustomPolar.CircleLabelsFont プロパティ

public ChartFont CircleLabelsFont {get;}

解説

サークル系列（例：レーダーあるいは極系列）のラベルのフォント特性を設定します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CircleLabelsInside

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CircleLabelsInside プロパティ

外円の内側に軸ラベルの表示を有効/無効にします。

public Boolean CircleLabelsInside {get; set;}

解説

外円の内側に軸ラベルの表示を有効/無効にします。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CircleLabelsRotated

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CircleLabelsRotated プロパティ

このプロパティはサークル系列（例：レーダーあるいは極系列）のラベルを回転します。このプロパティがtrueの場合、ラベルは90度回転します。

public Boolean CircleLabelsRotated {get; set;}

解説

このプロパティはサークル系列（例：レーダーあるいは極系列）のラベルを回転します。このプロパティがtrueの場合、ラベルは90度回転します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CirclePen

Steema.TeeChart.Styles.CustomPolar.CirclePen プロパティ

外円を描くペンの種類を定義します。
public ChartPen CirclePen {get;}

解説

すべてのCustomPolar系列の継承系列の外円を描くペンの種類を定義します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


ClockWiseLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.ClockWiseLabels プロパティ

時計回りで外円ラベルの表示を有効/無効にします。

public Boolean ClockWiseLabels {get; set;}

解説

時計回りで外円ラベルの表示を有効/無効にします。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


CloseCircle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.CloseCircle プロパティ

最初と最後の極系列のポイント間に線を描きます。

public Boolean CloseCircle {get; set;}

解説

デフォルト値：true

最初と最後の極系列のポイント間に線を描くかどうかを設定します。trueの場合は、最初と最後の極系列のポイント間に接続線を描きます。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Font

Steema.TeeChart.Styles.CustomPolar.Font プロパティ

ラベルのフォントを設定します。
public ChartFont Font {get;}

解説

ラベルのフォントを設定します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


LabelsMargin

Steema.TeeChart.Styles.CustomPolar.LabelsMargin プロパティ

CustomPolarの円とラベルの間の距離を定義します。
public Int32 LabelsMargin {get; set;}

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.CustomPolar.Pen プロパティ

極系列ポイントの接続線を描くペンを設定します。
public ChartPen Pen {get;}

解説

極系列ポイントの接続線を描くペンの種類を設定します。ポイントは、Pointer.Visibleプロパティをtrueに設定することにより表示されます。CirclePenプロパティを使用して円を描くペンを設定できます。

例

これは極系列の線の色を青に変更します。

[C#]

Steema.TeeChart.Styles.Polar Series1 = new Steema.TeeChart.Styles.Polar();
tChart1.Series.Add(Series1);
Series1.Pen.Color = Color.Blue;

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Pointer

Steema.TeeChart.Styles.CustomPolar.Pointer プロパティ

このプロパティには、Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
public SeriesPointer Pointer {get;}

解説

散布図系列、リボン系列、泡系列、極系列、キャンドル系列などのその他すべての派生散布図系列クラスのサブクラスです。

極系列の各ポイントは、Pointerプロパティを使用して描かれます。

このプロパティには、Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


RadiusIncrement

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.RadiusIncrement プロパティ

リンググリッド線を描くインクリメントを設定します。

public Double RadiusIncrement {get; set;}

解説

極系列を使用する場合、Chart.Axes.Left.Incrementプロパティと同様にアクセスできます。

リンググリッド線を描くために、極の半径スケールでインクリメントを設定します。エディタの極系列ページに、このプロパティがあります。

極チャートにどのようなグリッド線を表示させるか制御するためには、PolarSeries.AngleIncrementプロパティと一緒に使用してください。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


RadiusValues

Steema.TeeChart.Styles.CustomPolar.RadiusValues プロパティ

各極ポイントの半径値のリストを取得します。
public ValueList RadiusValues {get;}

解説

各極ポイントの半径値のリストです。

各極ポイントの半径値を保持するTListオブジェクトです。RadiusValues.Value[ ]プロパティを使用して、半径値を変更することができます。

例

これは最初のポイントの半径を49に設定します。

[C#]

Series1.RadiusValues.Value[0] = 49;

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomPolar.Transparency プロパティ

0～100%の割合で透明度を設定します。

public Int32 Transparency {get; set;}

解説

デフォルト値：0

0～100%の割合で透明度を設定します。

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


TreatNulls

Steema.TeeChart.Styles.CustomPolar.TreatNulls プロパティ

public TreatNullsStyle TreatNulls {get; set;}

参照

CustomPolar クラス | CustomPolar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomPolar.GetPointerStyleEventHandler

Steema.TeeChart.Styles.CustomPolar.GetPointerStyleEventHandler デリゲート

GetPointerStyleイベントのデリゲート。
public delegate GetPointerStyleEventHandler (CustomPolar series,
     GetPointerStyleEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.CustomStack

TeeChartプログラミングガイド

Steema.TeeChart.Styles.CustomStack 列挙体

Stackedプロパティの使用可能な値です。

[Serializable]
public enum CustomStack : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 全ての系列は、各Z位置で描画されます。
Overlap | 系列は、同じZ位置で描画されます。これは同じ系列ポイントがオーバーラップして描画されます。
Stack | 前の系列の上に積み重ねて系列を描画します。
Stack100 | 各系列を共通の0～100の軸スケールで積み重ねて描画されます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas

Steema.TeeChart.Styles.Darvas クラス

ダーバス系列。

この型のすべてのメンバの一覧については、Darvas メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
public class Darvas : OHLC , IComponent, IDisposable, ICloneable

解説

ダーバスボックスは、ニコラス・ダーバスの本「私は株で200万ドル儲けた」のページから採用しました。 ボックスは、トレンドを正常化するために使用されます。株価の価格がボックスの上部を越えている場合、「買い」シグナルが示されます。 株価の価格がボックスの下部より下回っている場合、「売り」シグナルが示されます。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas 全メンバ

Darvas 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
Boxes |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
NumBoxes |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Darvas クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas コンストラクタ

オーバーロードの一覧

public Darvas(Steema.TeeChart.Chart)
public Darvas()

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas コンストラクタ

public Darvas(Chart c)

参照

Darvas コンストラクタのオーバーロードの一覧 | Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas コンストラクタ

public Darvas()

参照

Darvas コンストラクタのオーバーロードの一覧 | Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Darvas クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
Boxes |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
NumBoxes |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Darvas クラス | Steema.TeeChart.Styles 名前空間


Boxes

Steema.TeeChart.Styles.Darvas.Boxes フィールド

public Rectangle[] Boxes

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


NumBoxes

Steema.TeeChart.Styles.Darvas.NumBoxes フィールド

public Int32 NumBoxes

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas メソッド

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Darvas クラス | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Darvas.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Darvas.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Darvas.Draw メソッド

public override Void Draw()

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Darvas プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Darvas クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Darvas.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

Darvas クラス | Darvas メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.DigitalFont

Steema.TeeChart.Styles.DigitalFont 列挙体

[Serializable]
public sealed enum DigitalFont : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Bar |
Dot |

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut

Steema.TeeChart.Styles.Donut クラス

ドーナツ系列。

この型のすべてのメンバの一覧については、Donut メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.Pie
public class Donut : Pie , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Donut メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut 全メンバ

Donut 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

Angles (Pieの継承元) |
bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
BelongsToOtherSlice (Pieの継承元) | 指定したインデックスのスライスがOthersliceプロパティに該当する場合、trueを返します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Pieの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Pieの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Pieの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Pieの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Pieの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pieの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleSize (Pieの継承元) | 全スライスの合計角度を度数単位（0～360）で設定します。
AutoMarkPosition (Pieの継承元) | trueの場合、各マーカはオーバーラップしないように表示されます。
Brush (Pieの継承元) | 円系列を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Pieの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
Dark3D (Pieの継承元) | 3D効果を与えるために円の側面に影をつけます。
DarkPen (Pieの継承元) |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DonutPercent |
EndZ (Seriesの継承元) | 内部使用。
ExplodeBiggest (Pieの継承元) | 指定した値で円系列の中心から最も大きな値のスライスを分割します。
ExplodedSlice (Pieの継承元) | パイスライスを分割するためのプロパティにアクセスします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MarksPie (Pieの継承元) |
MiddleZ (Seriesの継承元) | 内部使用。
MultiPie (Pieの継承元) | 複数の円系列が存在する場合、自動的に円を配置するように設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OtherSlice (Pieの継承元) | パイスライスのグループ化を設定します。
Pen (Pieの継承元) | パイのペン特性を設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PieValues (Pieの継承元) | パイスライス値を保持します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow (Pieの継承元) | 円系列のオフセットの影を定義します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SliceHeight (Pieの継承元) | 各パイスライスを異なる高さに設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UsePatterns (Pieの継承元) | 異なるブラシパターンスタイルでパイスライスを塗りつぶします。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
iDonutPercent (Pieの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Pieの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcExplodedRadius (Pieの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Pieの継承元) |
CountLegendItems (Pieの継承元) |
CreateSubGallery (Pieの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Pieの継承元) |
DoBeforeDrawChart (Pieの継承元) |
DoBeforeDrawValues (Pieの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Pieの継承元) |
DrawMark (Pieの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Pieの継承元) |
DrawPie (Pieの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Pieの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Pieの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Pieの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Pieの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Pieの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDonutPercent (Pieの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Donut クラス | Steema.TeeChart.Styles 名前空間


Donut コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Donut コンストラクタ

オーバーロードの一覧

public Donut()
public Donut(Steema.TeeChart.Chart)

参照

Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


Donut コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Donut コンストラクタ

public Donut()

参照

Donut コンストラクタのオーバーロードの一覧 | Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


Donut コンストラクタ

Steema.TeeChart.Styles.Donut コンストラクタ

public Donut(Chart c)

参照

Donut コンストラクタのオーバーロードの一覧 | Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Donut クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut フィールド

パブリック フィールド

Angles (Pieの継承元) |
bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
iDonutPercent (Pieの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Donut クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
BelongsToOtherSlice (Pieの継承元) | 指定したインデックスのスライスがOthersliceプロパティに該当する場合、trueを返します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Pieの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Pieの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Pieの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Pieの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (Pieの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pieの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Pieの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcExplodedRadius (Pieの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Pieの継承元) |
CountLegendItems (Pieの継承元) |
CreateSubGallery (Pieの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Pieの継承元) |
DoBeforeDrawChart (Pieの継承元) |
DoBeforeDrawValues (Pieの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Pieの継承元) |
DrawMark (Pieの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Pieの継承元) |
DrawPie (Pieの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Pieの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Pieの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Pieの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Pieの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Pieの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDonutPercent (Pieの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Donut クラス | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Donut.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Donut プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleSize (Pieの継承元) | 全スライスの合計角度を度数単位（0～360）で設定します。
AutoMarkPosition (Pieの継承元) | trueの場合、各マーカはオーバーラップしないように表示されます。
Brush (Pieの継承元) | 円系列を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Pieの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
Dark3D (Pieの継承元) | 3D効果を与えるために円の側面に影をつけます。
DarkPen (Pieの継承元) |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DonutPercent |
EndZ (Seriesの継承元) | 内部使用。
ExplodeBiggest (Pieの継承元) | 指定した値で円系列の中心から最も大きな値のスライスを分割します。
ExplodedSlice (Pieの継承元) | パイスライスを分割するためのプロパティにアクセスします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MarksPie (Pieの継承元) |
MiddleZ (Seriesの継承元) | 内部使用。
MultiPie (Pieの継承元) | 複数の円系列が存在する場合、自動的に円を配置するように設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OtherSlice (Pieの継承元) | パイスライスのグループ化を設定します。
Pen (Pieの継承元) | パイのペン特性を設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PieValues (Pieの継承元) | パイスライス値を保持します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow (Pieの継承元) | 円系列のオフセットの影を定義します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SliceHeight (Pieの継承元) | 各パイスライスを異なる高さに設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UsePatterns (Pieの継承元) | 異なるブラシパターンスタイルでパイスライスを塗りつぶします。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Donut クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Donut.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


DonutPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Donut.DonutPercent プロパティ

public Int32 DonutPercent {get; set;}

解説

中心の穴の大きさを設定します。

参照

Donut クラス | Donut メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error

Steema.TeeChart.Styles.Error クラス

エラー系列。

この型のすべてのメンバの一覧については、Error メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
Steema.TeeChart.Styles.CustomError
public class Error : CustomError , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Error メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error 全メンバ

Error 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (CustomErrorの継承元) | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue (CustomErrorの継承元) | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (CustomErrorの継承元) | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomErrorの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomErrorの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomErrorの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ErrorPen (CustomErrorの継承元) | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle (CustomErrorの継承元) | エラー系列のスタイルを定義します。
ErrorValues (CustomErrorの継承元) | 各バーに該当するエラー値を取得/設定します。
ErrorWidth (CustomErrorの継承元) | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits (CustomErrorの継承元) | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar (CustomErrorの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle (CustomErrorの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomErrorの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomErrorの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomErrorの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomErrorの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Error クラス | Steema.TeeChart.Styles 名前空間


Error コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Error コンストラクタ

オーバーロードの一覧

public Error()
public Error(Steema.TeeChart.Chart)

参照

Error クラス | Error メンバ | Steema.TeeChart.Styles 名前空間


Error コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Error コンストラクタ

public Error()

参照

Error コンストラクタのオーバーロードの一覧 | Error クラス | Error メンバ | Steema.TeeChart.Styles 名前空間


Error コンストラクタ

Steema.TeeChart.Styles.Error コンストラクタ

public Error(Chart c)

参照

Error コンストラクタのオーバーロードの一覧 | Error クラス | Error メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Error クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar (CustomErrorの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle (CustomErrorの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Error クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error メソッド

パブリック メソッド

Add (CustomErrorの継承元) | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue (CustomErrorの継承元) | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (CustomErrorの継承元) | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomErrorの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomErrorの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomErrorの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomErrorの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomErrorの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomErrorの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomErrorの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Error クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Error プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ErrorPen (CustomErrorの継承元) | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle (CustomErrorの継承元) | エラー系列のスタイルを定義します。
ErrorValues (CustomErrorの継承元) | 各バーに該当するエラー値を取得/設定します。
ErrorWidth (CustomErrorの継承元) | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits (CustomErrorの継承元) | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

Error クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Error.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Error クラス | Error メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar

Steema.TeeChart.Styles.ErrorBar クラス

エラーバー系列。

この型のすべてのメンバの一覧については、ErrorBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
Steema.TeeChart.Styles.CustomError
public class ErrorBar : CustomError , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar 全メンバ

ErrorBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (CustomErrorの継承元) | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue (CustomErrorの継承元) | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (CustomErrorの継承元) | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomErrorの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomErrorの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ErrorPen (CustomErrorの継承元) | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle (CustomErrorの継承元) | エラー系列のスタイルを定義します。
ErrorValues (CustomErrorの継承元) | 各バーに該当するエラー値を取得/設定します。
ErrorWidth (CustomErrorの継承元) | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits (CustomErrorの継承元) | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar (CustomErrorの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle (CustomErrorの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomErrorの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomErrorの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomErrorの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomErrorの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

ErrorBar クラス | Steema.TeeChart.Styles 名前空間


ErrorBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ErrorBar コンストラクタ

オーバーロードの一覧

public ErrorBar()
public ErrorBar(Steema.TeeChart.Chart)

参照

ErrorBar クラス | ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


ErrorBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ErrorBar コンストラクタ

public ErrorBar()

参照

ErrorBar コンストラクタのオーバーロードの一覧 | ErrorBar クラス | ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


ErrorBar コンストラクタ

Steema.TeeChart.Styles.ErrorBar コンストラクタ

public ErrorBar(Chart c)

参照

ErrorBar コンストラクタのオーバーロードの一覧 | ErrorBar クラス | ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

ErrorBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bDrawBar (CustomErrorの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iErrorStyle (CustomErrorの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

ErrorBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar メソッド

パブリック メソッド

Add (CustomErrorの継承元) | 選択した色とラベルで新しいエラーバーポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddValue (CustomErrorの継承元) | 系列に新しいエラーバーポイントを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar (CustomErrorの継承元) | 開始と終了のピクセル座標を使用してエラーバーポイントを表示します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomErrorの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomErrorの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomErrorの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomErrorの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomErrorの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomErrorの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

ErrorBar クラス | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.ErrorBar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

ErrorBar クラス | ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorBar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
ErrorPen (CustomErrorの継承元) | エラーバー上部にエラー｢T｣を描くペンを定義します。
ErrorStyle (CustomErrorの継承元) | エラー系列のスタイルを定義します。
ErrorValues (CustomErrorの継承元) | 各バーに該当するエラー値を取得/設定します。
ErrorWidth (CustomErrorの継承元) | エラー｢T｣の水平サイズを設定します。
ErrorWidthUnits (CustomErrorの継承元) | ErrorWidthプロパティのための単位を設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

ErrorBar クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.ErrorBar.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

ErrorBar クラス | ErrorBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ErrorStyles 列挙体

ErrorStyleプロパティの使用可能な値です。

[Serializable]
public enum ErrorStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Left | 左軸から右方向に向かってX軸のインデックス値まで伸びるエラー値を表示します。
Right | 右軸から左方向に向かってX軸のインデックス値まで伸びるエラー値を表示します。
LeftRight | 左軸から右軸まで伸びるエラー値を表示します。
Top | Tで表すエラー値を表示します。
Bottom | 倒立Tで表すエラー値を表示します。
TopBottom | エで表すエラー値を表示します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ErrorWidthUnits

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ErrorWidthUnits 列挙体

ErrorWidthUnitsプロパティの使用可能な値です。

[Serializable]
public enum ErrorWidthUnits : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Percent | エラーの幅をチャートサイズの割合で定義します。
Pixels | エラーの幅をピクセル単位で定義します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine

Steema.TeeChart.Styles.FastLine クラス

折れ線系列は、ポイントを可能な限り速く描画する非常にシンプルな系列コンポーネントです。

この型のすべてのメンバの一覧については、FastLine メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class FastLine : BaseLine , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

FastLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine 全メンバ

FastLine 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoRepaint |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DrawAllPoints |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IgnoreNulls |
InvertedStairs |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stairs |
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

FastLine クラス | Steema.TeeChart.Styles 名前空間


FastLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine コンストラクタ

オーバーロードの一覧

public FastLine(Steema.TeeChart.Chart)
public FastLine()

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


FastLine コンストラクタ

Steema.TeeChart.Styles.FastLine コンストラクタ

public FastLine(Chart c)

参照

FastLine コンストラクタのオーバーロードの一覧 | FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


FastLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine コンストラクタ

public FastLine()

参照

FastLine コンストラクタのオーバーロードの一覧 | FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

FastLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

FastLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

FastLine クラス | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのインデックスを返します。｢クリックされた｣とは、XとY座標値がポイント画面領域の境界内にあることを意味します。｢触れた｣のポイントがない場合、Clickedは-1を返します。

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.Clicked メソッド

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.FastLine.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.FastLine.Draw メソッド

public override Void Draw()

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.FastLine.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.FastLine.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 index)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.FastLine.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

Steema.TeeChart.Styles.FastLine.MaxYValue メソッド

public override Double MaxYValue()

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

Steema.TeeChart.Styles.FastLine.MinYValue メソッド

public override Double MinYValue()

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.FastLine.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.FastLine.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.FastLine.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.FastLine プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoRepaint |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DrawAllPoints |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IgnoreNulls |
InvertedStairs |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stairs |
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

FastLine クラス | Steema.TeeChart.Styles 名前空間


AutoRepaint

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.AutoRepaint プロパティ

public Boolean AutoRepaint {get; set;}

解説

デフォルト値：true

折れ線系列に多くのポイントを追加している最中のチャートの再描画を無効にするためには、このプロパティをfalseに設定してください。すべてのポイントを追加した後、このプロパティをtrueにして、Repaintメソッドでチャートを再描画してください。

例

[C#]

private void button1_Click(object sender, System.EventArgs e)
{

     tChart1.AutoRepaint = false;
     Random r = new Random();
     for(int i = 0; i <500; i++)
    {
        tChart1[4].Add (i,r.Next(800),Color.Blue);
                        tab
    }
     fastLineSeries1.AutoRepaint = true;
     tChart1.Refresh();
}

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.FastLine.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


DrawAllPoints

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.DrawAllPoints プロパティ

public Boolean DrawAllPoints {get; set;}

解説

デフォルト値：true

falseの場合、Xピクセル位置に最初のポイントのみを描画します。trueの場合、多くのポイントの反復が1つのX位置で生じる場合、スピードを早めます。

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


IgnoreNulls

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.IgnoreNulls プロパティ

public Boolean IgnoreNulls {get; set;}

解説

デフォルト値：true

スピードの理由により、折れ線系列はIgnoreNullsプロパティがfalseの場合のみnull（空）値をサポートします。

デフォルトではすべてのポイントが表示されます。

折れ線系列のnullポイントを非表示にするためには、このプロパティをfalseに設定してください。

例

[C#]

fastLine1.Add(300);
fastLine1.Add(350);
fastLine1.Add(200);
fastLine1.Add(400);
fastLine1.Add();
fastLine1.Add(425);
fastLine1.Add(380);
fastLine1.IgnoreNulls = false;

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


InvertedStairs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.InvertedStairs プロパティ

public Boolean InvertedStairs {get; set;}

解説

折れ線系列の描画を制御します。

Stairsプロパティがtrueに設定されている場合、このプロパティをtrueに設定すると階段の方向が反対になります。

一般的には、折れ線系列は各ポイント間を一本の線で描きます。
これにより、線は「山」のような形状で表示されます。
ただし、StairsプロパティをTrueに設定すると、系列はポイントの各ペア間を水平線と垂直線で描きます。つまり「階段」状の外観になります。

これは一部の金融関係のチャートとしてよく使用されます。

例

[C#]

fastLine1.Stairs = true;
fastLine1.InvertedStairs =! fastLine1.InvertedStairs;

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Stairs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.Stairs プロパティ

public Boolean Stairs {get; set;}

解説

折れ線系列の描画を制御します。

通常では、系列は各ポイント間を一本の線で描きます。
これにより線は「山」のような形状で表示されます。
しかし、このプロパティをtrueに設定すると、系列はポイントの各ペア間を水平線と垂直線で描きます。つまり「階段」状の外観になります。
これは、一部の金融関係のチャートとしてよく使用されます。

このプロパティがtrueに設定されていて、InvertedStairsプロパティをtrueに設定すると、ステップの方向を変えることができます。

例

[C#]

fastLine1.Stairs = true;
fastLine1.InvertedStairs =! fastLine1.InvertedStairs;

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.FastLine.Transparency プロパティ

public Int32 Transparency {get; set;}

解説

折れ線系列の透明度をパーセントで設定します。

例

[C#]

fastLineSeries1.Transparency = 50;

参照

FastLine クラス | FastLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel

Steema.TeeChart.Styles.Funnel クラス

ファネル系列。

この型のすべてのメンバの一覧については、Funnel メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Funnel : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Funnel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel 全メンバ

Funnel 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 系列に新しいファネルセグメントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
Recalc | 全てのクォート値とオポチュニティ値を使用して、ファネルチャートを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

AboveColor | オポチュニティ値がクォート値より大きい場合のファネルセグメントの色を設定します。
Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoUpdate | ポイントを追加する度にファネル系列を再建築するかどうか定義します。
BelowColor | オポチュニティ値がクォート値よりDifferenceLimitプロパティ値%以下の場合のファネルセグメントの色を設定します。
Brush | ファネル系列のブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DifferenceLimit | ファネルセグメントの色を定義するために使用される差（クォート%で表現）を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinesPen | ファネル系列のポリゴンが接する線の色やスタイルを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
OpportunityValues |
Pen | ファネルチャートを描くペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
QuotesSorted | 追加されたセグメントがQuoteValuesプロパティ値で降順にソートされます。
QuoteValues | ファネル系列のクォート値にアクセスします。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WithinColor | クォート値 > オポチュニティ値 > (100 - DifferenceLimit) * クォート値 / 100の場合のファネルセグメントに使用される色を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Funnel クラス | Steema.TeeChart.Styles 名前空間


Funnel コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel コンストラクタ

オーバーロードの一覧

public Funnel(Steema.TeeChart.Chart)
public Funnel()

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Funnel コンストラクタ

Steema.TeeChart.Styles.Funnel コンストラクタ

public Funnel(Chart c)

参照

Funnel コンストラクタのオーバーロードの一覧 | Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Funnel コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel コンストラクタ

public Funnel()

参照

Funnel コンストラクタのオーバーロードの一覧 | Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Funnel クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Funnel クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel メソッド

パブリック メソッド

Add | 系列に新しいファネルセグメントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
Recalc | 全てのクォート値とオポチュニティ値を使用して、ファネルチャートを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Funnel クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.Add メソッド

オーバーロードの一覧

系列に新しいファネルセグメントを追加します。

public Int32 Add(System.Double, System.Double, System.String, System.Drawing.Color)

解説

系列に新しいファネルセグメントを追加します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.Add メソッド

系列に新しいファネルセグメントを追加します。

public Int32 Add(Double aQuote,
     Double aOpportunity,
     String aLabel,
     Color aColor)

参照

Add オーバーロードの一覧 | Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.Funnel.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Funnel.Draw メソッド

public override Void Draw()

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Funnel.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Funnel.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


GetMarkText

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.GetMarkText メソッド

protected internal virtual String GetMarkText(Int32 valueIndex)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.LegendItemColor メソッド

protected internal virtual Color LegendItemColor(Int32 LegendIndex)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Funnel.LegendString メソッド

指定したインデックスの凡例項目の書式化された文字列を返します。
public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

解説

指定したLegendIndex番目の凡例項目のLegendTextStyleによる書式文字列を返します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Recalc

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.Recalc メソッド

全てのクォート値とオポチュニティ値を使用して、ファネルチャートを再構築します。

public Void Recalc()

解説

全てのクォート値とオポチュニティ値を使用して、ファネルチャートを再構築します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Funnel.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Funnel プロパティ

パブリック プロパティ

AboveColor | オポチュニティ値がクォート値より大きい場合のファネルセグメントの色を設定します。
Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoUpdate | ポイントを追加する度にファネル系列を再建築するかどうか定義します。
BelowColor | オポチュニティ値がクォート値よりDifferenceLimitプロパティ値%以下の場合のファネルセグメントの色を設定します。
Brush | ファネル系列のブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DifferenceLimit | ファネルセグメントの色を定義するために使用される差（クォート%で表現）を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinesPen | ファネル系列のポリゴンが接する線の色やスタイルを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
OpportunityValues |
Pen | ファネルチャートを描くペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
QuotesSorted | 追加されたセグメントがQuoteValuesプロパティ値で降順にソートされます。
QuoteValues | ファネル系列のクォート値にアクセスします。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WithinColor | クォート値 > オポチュニティ値 > (100 - DifferenceLimit) * クォート値 / 100の場合のファネルセグメントに使用される色を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Funnel クラス | Steema.TeeChart.Styles 名前空間


AboveColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.AboveColor プロパティ

オポチュニティ値がクォート値より大きい場合のファネルセグメントの色を設定します。

public Color AboveColor {get; set;}

解説

デフォルト値：Green

オポチュニティ値がクォート値より大きい場合のファネルセグメントの色を設定します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


AutoUpdate

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.AutoUpdate プロパティ

ポイントを追加する度にファネル系列を再建築するかどうか定義します。

public Boolean AutoUpdate {get; set;}

解説

デフォルト値：true

このプロパティがtrueに設定されている場合、ファネル系列はポイントが追加される度に再建築されます。ファネル系列の描画を速くするためには、このプロパティをfalseに設定して、すべてのポイントを追加した後にRecalculateメソッドを呼び出してください。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


BelowColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.BelowColor プロパティ

オポチュニティ値がクォート値よりDifferenceLimitプロパティ値%以下の場合のファネルセグメントの色を設定します。

public Color BelowColor {get; set;}

解説

デフォルト値：Red

オポチュニティ値がクォート値よりDifferenceLimitプロパティ値%以下の場合のファネルセグメントの色を設定します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Funnel.Brush プロパティ

ファネル系列のブラシを定義します。
public ChartBrush Brush {get;}

解説

ファネル系列のブラシを定義します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Funnel.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


DifferenceLimit

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.DifferenceLimit プロパティ

ファネルセグメントの色を定義するために使用される差（クォート%で表現）を設定します。

public Double DifferenceLimit {get; set;}

解説

デフォルト値：30.0

ファネルセグメントの色を定義するために内部アルゴリズムで使用される差（クォート%で表現）を設定します。

オポチュニティ値 ＜ (100 - DifferenceLimit) * クォート値 / 100の場合、ファネルセグメントの色はBelowColorプロパティを使用します。
クォート値 ＞ オポチュニティ値 ＞ (100 - DifferenceLimit) * クォート値 / 100の場合、ファネルセグメントの色はWithinColorプロパティを使用します。
オポチュニティ値 ＞ クォート値の場合、ファネルセグメントの色はAboveColorプロパティを使用します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


LinesPen

Steema.TeeChart.Styles.Funnel.LinesPen プロパティ

ファネル系列のポリゴンが接する線の色やスタイルを設定します。
public ChartPen LinesPen {get;}

解説

ファネル系列のポリゴンが接する線の色やスタイルを設定します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


OpportunityValues

Steema.TeeChart.Styles.Funnel.OpportunityValues プロパティ

public ValueList OpportunityValues {get;}

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Funnel.Pen プロパティ

ファネルチャートを描くためのペンを設定します。
public ChartPen Pen {get;}

解説

ペン特性のエレメント。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


QuotesSorted

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.QuotesSorted プロパティ

追加されたセグメントがQuoteValuesプロパティ値で降順にソートされます。

public Boolean QuotesSorted {get; set;}

解説

デフォルト値：false

trueの場合、追加されたセグメントがQuoteValuesプロパティ値で降順にソートされます。このプロパティをfalseに設定すると、内部的なアルゴリズムソートが有効になります。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


QuoteValues

Steema.TeeChart.Styles.Funnel.QuoteValues プロパティ

ファネル系列のクォート値にアクセスします。
public ValueList QuoteValues {get;}

解説

ファネル系列のクォート値にアクセスします。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


WithinColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Funnel.WithinColor プロパティ

クォート値 > オポチュニティ値 > (100 - DifferenceLimit) * クォート値 / 100の場合のファネルセグメントに使用される色を定義します。

public Color WithinColor {get; set;}

解説

デフォルト値：Yellow

クォート値 > オポチュニティ値 > (100 - DifferenceLimit) * クォート値 / 100の場合のファネルセグメントに使用される色を定義します。

参照

Funnel クラス | Funnel メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt

Steema.TeeChart.Styles.Gantt クラス

ガント系列。

この型のすべてのメンバの一覧については、Gantt メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class Gantt : Points , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Gantt メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt 全メンバ

Gantt 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add |
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列ソースがガントの場合、trueを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ConnectingPen |
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndValues |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NextTasks |
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartValues |
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Gantt クラス | Steema.TeeChart.Styles 名前空間


Gantt コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt コンストラクタ

オーバーロードの一覧

public Gantt()
public Gantt(Steema.TeeChart.Chart)

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Gantt コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt コンストラクタ

public Gantt()

参照

Gantt コンストラクタのオーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Gantt コンストラクタ

Steema.TeeChart.Styles.Gantt コンストラクタ

public Gantt(Chart c)

参照

Gantt コンストラクタのオーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Gantt クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Gantt クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt メソッド

パブリック メソッド

Add |
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列ソースがガントの場合、trueを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Gantt クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

オーバーロードの一覧

public override Void Add(System.Data.DataView)
public Int32 Add(System.DateTime, System.DateTime, System.Double, System.String)
public Int32 Add(System.DateTime, System.DateTime, System.Double, System.String, System.Drawing.Color)
public Int32 Add(System.DateTime, System.DateTime, System.Double, System.Drawing.Color)

開始・終了座標と色で新しいガントバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

開始・終了座標で系列に新しいガントバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double)

開始・終了座標とラベルで新しいガントバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

開始・終了座標、ラベル、色で新しいガントバーを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

解説

新しいガントバーを追加します。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

public override Void Add(DataView view)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Gantt.Add メソッド

public override Void Add(DataView view)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     String text)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

public Int32 Add(DateTime start,
     DateTime endDate,
     Double y,
     Color color)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

開始、終了座標と色で新しいガントバーを追加します。

public Int32 Add(Double start,
     Double endDate,
     Double Y,
     Color color)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

開始と終了座標で系列に新しいガントバーを追加します。

public Int32 Add(Double start,
     Double endDate,
     Double y)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.Add メソッド

開始、終了座標とラベルで新しいガントバーを追加します。

public Int32 Add(Double start,
     Double endDate,
     Double y,
     String text)

参照

Add オーバーロードの一覧 | Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


ClickedPointer

Steema.TeeChart.Styles.Gantt.ClickedPointer メソッド

内部使用。
public override Boolean ClickedPointer(Int32 valueIndex,
     Int32 tmpX,
     Int32 tmpY,
     Int32 x,
     Int32 y)

解説

内部使用。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Gantt.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position aPosition)

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Gantt.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Gantt.IsValidSourceOf メソッド

系列ソースがガントの場合、trueを返します。
public override Boolean IsValidSourceOf(Series value)

解説

ValueパラメーターがSelfと同じ場合、falseを返します。
デザイン時および実行時にDataSourceプロパティを有効にします。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Gantt.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Gantt.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gantt プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ConnectingPen |
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndValues |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NextTasks |
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartValues |
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Gantt クラス | Steema.TeeChart.Styles 名前空間


ConnectingPen

Steema.TeeChart.Styles.Gantt.ConnectingPen プロパティ

public ChartPen ConnectingPen {get;}

解説

ガントバーを接続する任意の線を描くペンの種類を設定します。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Gantt.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


EndValues

Steema.TeeChart.Styles.Gantt.EndValues プロパティ

public ValueList EndValues {get;}

解説

ガントバーの終了日付値を定義します。開始のガントバーポイントは、TGanttSeries.StartValues プロパティに保持されています。

StartValuesプロパティやEndValuesプロパティは、DateTime値あるいはDouble値のどちらでも指定できます。

どちらも、標準のTChartValueListコンポーネントです。つまり、X値あるいはY値にアクセスするのと同じメソッドでこれらの値にアクセスできます。

ガントバーポイントを追加するためには、TGanttSeries.Addメソッドを使用してください。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


NextTasks

Steema.TeeChart.Styles.Gantt.NextTasks プロパティ

public ValueList NextTasks {get;}

解説

このプロパティは、各ガントバーが接続されているガントバーインデックスを持つTListコンポーネントです。

ガントバーがTGanttSeriesに追加されると、デフォルトではそのNextTask値に-1が代入されます。これは、ガントバーがその他のすべてのガントバーに接続されていないことを意味します。

有効なバーインデックスをNextTaskに設定する必要があります。

例

[C#]

次のコードは、2つのガントバーを線で接続します。

Gantt1.FillSampleValues(6)
Gantt1.NextTasks(1) = 5 '2番目のバーと6番目のバーを接続

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


StartValues

Steema.TeeChart.Styles.Gantt.StartValues プロパティ

public ValueList StartValues {get;}

解説

ガントバーの開始日付値を定義します。終了のガントバーポイントは、TGanttSeries.EndValuesリストプロパティに保持されています。

StartValuesプロパティやEndValuesプロパティは、DateTime値あるいはDouble値のどちらでも指定することができます。

どちらも標準のTChartValueListコンポーネントです。つまり、X値やY値にアクセスするのと同じメソッドでこれらの値にアクセスできます。

ガントバーポイントを追加するためには、TGanttSeries.Addメソッドを使用してください。

参照

Gantt クラス | Gantt メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugePointerStyles

Steema.TeeChart.Styles.GaugePointerStyles 値型

この型のすべてのメンバの一覧については、GaugePointerStyles メンバを参照してください。

System.Object
System.ValueType
[Serializable]
public sealed struct GaugePointerStyles : ValueType

参照

GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugePointerStyles 全メンバ

GaugePointerStyles 概要

コンストラクタ

Constructor

パブリック フィールド

Center
ColorLine
Hand
MinorTick
Tick
Value

パブリック メソッド

Equals
GetHashCode
op_Equality
op_Implicit
op_Inequality

参照

GaugePointerStyles 構造体 | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugePointerStyles コンストラクタ

public GaugePointerStyles(Int32 value)

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugePointerStyles フィールド

パブリック フィールド

Center
ColorLine
Hand
MinorTick
Tick
Value

参照

GaugePointerStyles 構造体 | Steema.TeeChart.Styles 名前空間


Center

Steema.TeeChart.Styles.GaugePointerStyles.Center フィールド

public GaugePointerStyles Center

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


ColorLine

Steema.TeeChart.Styles.GaugePointerStyles.ColorLine フィールド

public GaugePointerStyles ColorLine

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Hand

Steema.TeeChart.Styles.GaugePointerStyles.Hand フィールド

public GaugePointerStyles Hand

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


MinorTick

Steema.TeeChart.Styles.GaugePointerStyles.MinorTick フィールド

public GaugePointerStyles MinorTick

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Tick

Steema.TeeChart.Styles.GaugePointerStyles.Tick フィールド

public GaugePointerStyles Tick

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Value

Steema.TeeChart.Styles.GaugePointerStyles.Value フィールド

public Int32 Value

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugePointerStyles メソッド

パブリック メソッド

Equals
GetHashCode
op_Equality
op_Implicit
op_Inequality

参照

GaugePointerStyles 構造体 | Steema.TeeChart.Styles 名前空間


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals メソッド

オーバーロードの一覧

public override Boolean Equals(System.Object)
public Boolean Equals(Steema.TeeChart.Styles.GaugePointerStyles)

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals メソッド

public override Boolean Equals(Object obj)

参照

Equals オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Equals

Steema.TeeChart.Styles.GaugePointerStyles.Equals メソッド

public Boolean Equals(GaugePointerStyles p)

参照

Equals オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


GetHashCode

Steema.TeeChart.Styles.GaugePointerStyles.GetHashCode メソッド

public override Int32 GetHashCode()

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Equality

Steema.TeeChart.Styles.GaugePointerStyles.op_Equality メソッド

public static Boolean op_Equality(GaugePointerStyles a,
     GaugePointerStyles b)

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit メソッド

オーバーロードの一覧

public static GaugePointerStyles op_Implicit(Steema.TeeChart.Styles.PointerStyles)
public static GaugePointerStyles op_Implicit(System.Int32)
public static Int32 op_Implicit(Steema.TeeChart.Styles.GaugePointerStyles)
public static PointerStyles op_Implicit(Steema.TeeChart.Styles.GaugePointerStyles)

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit メソッド

public static GaugePointerStyles op_Implicit(PointerStyles PointerStyle)

参照

op_Implicit オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit メソッド

public static GaugePointerStyles op_Implicit(Int32 PointerStyle)

参照

op_Implicit オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit メソッド

public static Int32 op_Implicit(GaugePointerStyles PointerStyle)

参照

op_Implicit オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Implicit

Steema.TeeChart.Styles.GaugePointerStyles.op_Implicit メソッド

public static PointerStyles op_Implicit(GaugePointerStyles PointerStyle)

参照

op_Implicit オーバーロードの一覧 | GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


op_Inequality

Steema.TeeChart.Styles.GaugePointerStyles.op_Inequality メソッド

public static Boolean op_Inequality(GaugePointerStyles a,
     GaugePointerStyles b)

参照

GaugePointerStyles 構造体 | GaugePointerStyles メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges

Steema.TeeChart.Styles.Gauges クラス

ゲージ系列。

この型のすべてのメンバの一覧については、Gauges メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Gauges : Circular , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Gauges メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges 全メンバ

Gauges 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
OnChange | ゲージ系列のValueプロパティが変更された際に発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Center | ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndPoint | ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HandDistance | ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
HandStyle | ゲージの針のスタイルを定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsInside | ゲージの軸ラベルを外側/内側に表示します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ゲージを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TotalAngle | ゲージ軸の大きさを度数で取得/設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Circularの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Gauges クラス | Steema.TeeChart.Styles 名前空間


Gauges コンストラクタ

Steema.TeeChart.Styles.Gauges コンストラクタ

オーバーロードの一覧

public Gauges()
public Gauges(Steema.TeeChart.Chart)

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Gauges コンストラクタ

Steema.TeeChart.Styles.Gauges コンストラクタ

public Gauges()

参照

Gauges コンストラクタのオーバーロードの一覧 | Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Gauges コンストラクタ

Steema.TeeChart.Styles.Gauges コンストラクタ

public Gauges(Chart c)

参照

Gauges コンストラクタのオーバーロードの一覧 | Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされたされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントがダブルクリックされた際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。
OnChange | ゲージのValueプロパティが変更されると発生します。

参照

Gauges クラス | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


OnChange

Steema.TeeChart.Styles.Gauges.OnChange イベント

ゲージのValueプロパティが変更されると発生します。
public GaugesChangeHandler  OnChange

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Gauges クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Circularの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Gauges クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.Gauges.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Draw

Steema.TeeChart.Styles.Gauges.Draw メソッド

public override Void Draw()

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Gauges.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Gauges.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Gauges プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Center | ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndPoint | ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HandDistance | ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
HandStyle | ゲージの針のスタイルを定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsInside | ゲージの軸ラベルを外側/内側に表示します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum | ゲージの最小値を取得/設定します。
MinorTickDistance | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ゲージを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TotalAngle | ゲージ軸の大きさを度数で取得/設定します。
Value | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Gauges クラス | Steema.TeeChart.Styles 名前空間


Center

Steema.TeeChart.Styles.Gauges.Center プロパティ

ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。
public SeriesPointer Center {get;}

解説

ゲージの中心にあるシェープの外観を制御するプロパティをアクセスします。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Gauges.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


EndPoint

Steema.TeeChart.Styles.Gauges.EndPoint プロパティ

ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。
public SeriesPointer EndPoint {get;}

解説

ゲージの矢印の終点にあるシェープの外観を制御するプロパティをアクセスします。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


HandDistance

Steema.TeeChart.Styles.Gauges.HandDistance プロパティ

ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。
public Int32 HandDistance {get; set;}

解説

デフォルト値：24

ゲージの軸とゲージの矢印線の終点との距離をピクセル単位で設定します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


HandStyle

Steema.TeeChart.Styles.Gauges.HandStyle プロパティ

ゲージの針のスタイルを定義します。
public HandStyle HandStyle {get; set;}

解説

デフォルト値：hsLine

ゲージは、直線（hsLineスタイル）あるいは三角形（hsTriangleスタイル）として矢印を表示できます。

Series1.HandStyle := hsTriangle ;

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


LabelsInside

Steema.TeeChart.Styles.Gauges.LabelsInside プロパティ

ゲージの軸ラベルを外側/内側に表示します。
public Boolean LabelsInside {get; set;}

解説

デフォルト値：true

ゲージの軸ラベルを外側/内側に表示します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Maximum

Steema.TeeChart.Styles.Gauges.Maximum プロパティ

ゲージの最大値を取得/設定します。
public Double Maximum {get; set;}

解説

デフォルト値：100

ゲージの最大値を取得/設定します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Minimum

Steema.TeeChart.Styles.Gauges.Minimum プロパティ

ゲージの最小値を取得/設定します。
public Double Minimum {get; set;}

解説

デフォルト値：0

ゲージの最小値を取得/設定します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


MinorTickDistance

Steema.TeeChart.Styles.Gauges.MinorTickDistance プロパティ

軸から離す副目盛の位置（距離）をピクセル単位で設定します。
public Int32 MinorTickDistance {get; set;}

解説

デフォルト値：0 ピクセル

軸から離す副目盛の位置（距離）をピクセル単位で設定します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Gauges.Pen プロパティ

ゲージを描くペンを設定します。
public ChartPen Pen {get;}

解説

ゲージを描くペンを設定します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


TotalAngle

Steema.TeeChart.Styles.Gauges.TotalAngle プロパティ

ゲージ軸の大きさを度数で取得/設定します。
public Double TotalAngle {get; set;}

解説

デフォルト値：90度

ゲージ軸の大きさを度数で取得/設定します。

RotationAngleプロパティと一緒に使用してください。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Value

Steema.TeeChart.Styles.Gauges.Value プロパティ

ゲージの矢印線の位置を取得/設定します。
public Double Value {get; set;}

解説

デフォルト値：0

ゲージの矢印線の位置を取得/設定します。

ゲージの最小値と最大値の間の数値にしなければなりません。

このプロパティの値を変更すると、ゲージ矢印は新しい位置に自動的に再描画されます。
FullRepaintプロパティは、チャートの全体を再描画するか、あるいはゲージの矢印線のみを再描画するか制御します。

参照

Gauges クラス | Gauges メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugesChangeHandler

Steema.TeeChart.Styles.GaugesChangeHandler デリゲート

ゲージ系列のOnChangeイベントハンドラ。
public delegate GaugesChangeHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SteemaTeeChartStylesGaugesChan 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.GaugeSeriesPointer

Steema.TeeChart.Styles.GaugeSeriesPointer クラス

SeriesPointerから派生されており、このクラスは、円形ゲージ系列に独特ななポインタスタイルを実装します。

この型のすべてのメンバの一覧については、GaugeSeriesPointer メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
public class GaugeSeriesPointer : SeriesPointer , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugeSeriesPointer 全メンバ

GaugeSeriesPointer 概要

コンストラクタ

Constructor

パブリック メソッド

Clone (SeriesPointerの継承元) |
Draw |
DrawColorLine |
DrawShadow |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
Shadow |
StartZ (SeriesPointerの継承元) |
Style |
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible

参照

GaugeSeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugeSeriesPointer コンストラクタ

public GaugeSeriesPointer(Chart c,
     Series s)

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugeSeriesPointer フィールド

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

GaugeSeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugeSeriesPointer メソッド

パブリック メソッド

Clone (SeriesPointerの継承元) |
Draw |
DrawColorLine |
DrawShadow |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible

参照

GaugeSeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw メソッド

オーバーロードの一覧

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point)
public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.GaugePointerStyles)

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw メソッド

public Void Draw(Graphics3D g,
     Point Inner,
     Point InnerPlus,
     Point InnerMinus,
     Point Outer,
     Point OuterPlus,
     Point OuterMinus)

参照

Draw オーバーロードの一覧 | GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.GaugeSeriesPointer.Draw メソッド

public Void Draw(Graphics3D g,
     Boolean is3D,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     Color colorValue,
     GaugePointerStyles aStyle)

参照

Draw オーバーロードの一覧 | GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


DrawColorLine

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawColorLine メソッド

public Void DrawColorLine(Graphics3D g,
     Single StartAngle,
     Single EndAngle,
     Rectangle Container)

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


DrawShadow

Steema.TeeChart.Styles.GaugeSeriesPointer.DrawShadow メソッド

public Void DrawShadow(Graphics3D g,
     Single angle,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     GaugePointerStyles aStyle)

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeVisible

Steema.TeeChart.Styles.GaugeSeriesPointer.ShouldSerializeVisible メソッド

protected abstract Boolean ShouldSerializeVisible()

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GaugeSeriesPointer プロパティ

パブリック プロパティ

Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
Shadow |
StartZ (SeriesPointerの継承元) |
Style |
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

参照

GaugeSeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Shadow

Steema.TeeChart.Styles.GaugeSeriesPointer.Shadow プロパティ

public Shadow Shadow {get; set;}

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.GaugeSeriesPointer.Style プロパティ

public GaugePointerStyles Style {get; set;}

参照

GaugeSeriesPointer クラス | GaugeSeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetImageEvent

Steema.TeeChart.Styles.GetImageEvent デリゲート

public delegate GetImageEvent (CustomImagePoint sender,
     Int32 valueIndex,
     Image image)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetPointerStyleEventArgs

Steema.TeeChart.Styles.GetPointerStyleEventArgs クラス

GetPointerStyleイベントのデータ。

この型のすべてのメンバの一覧については、GetPointerStyleEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetPointerStyleEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

GetPointerStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetPointerStyleEventArgs 全メンバ

GetPointerStyleEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Style | 系列ポインタのスタイルを設定します。
ValueIndex | 系列のValueList内の値のインデックスを取得します。

参照

GetPointerStyleEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetPointerStyleEventArgs コンストラクタ

public GetPointerStyleEventArgs(Int32 valueIndex,
     PointerStyles style)

参照

GetPointerStyleEventArgs クラス | GetPointerStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetPointerStyleEventArgs プロパティ

パブリック プロパティ

Style | 系列ポインタのスタイルを設定します。
ValueIndex | 系列のValueList内の値のインデックスを取得します。

参照

GetPointerStyleEventArgs クラス | Steema.TeeChart.Styles 名前空間


Color

Steema.TeeChart.Styles.GetPointerStyleEventArgs.Color プロパティ

系列のポインタ色を取得/設定します。
public Color Color {get; set;}

参照

GetPointerStyleEventArgs クラス | GetPointerStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.GetPointerStyleEventArgs.Style プロパティ

系列ポインタのスタイルを設定します。
public PointerStyles Style {get; set;}

参照

GetPointerStyleEventArgs クラス | GetPointerStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


ValueIndex

Steema.TeeChart.Styles.GetPointerStyleEventArgs.ValueIndex プロパティ

系列のValueList内の値のインデックスを取得します。
public Int32 ValueIndex {get;}

参照

GetPointerStyleEventArgs クラス | GetPointerStyleEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetSeriesMarkEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GetSeriesMarkEventArgs クラス

GetSeriesMarkイベントのデータを提供します。

この型のすべてのメンバの一覧については、GetSeriesMarkEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GetSeriesMarkEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

GetSeriesMarkEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetSeriesMarkEventArgs 全メンバ

GetSeriesMarkEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

MarkText | 系列マーカのテキストを取得/設定します。
ValueIndex | 系列のValueListの値のインデックス。

参照

GetSeriesMarkEventArgs クラス | Steema.TeeChart.Styles 名前空間


GetSeriesMarkEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GetSeriesMarkEventArgs コンストラクタ

public GetSeriesMarkEventArgs(Int32 valueIndex,
     String markText)

参照

GetSeriesMarkEventArgs クラス | GetSeriesMarkEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GetSeriesMarkEventArgs プロパティ

パブリック プロパティ

MarkText | 系列マーカのテキストを取得/設定します。
ValueIndex | 系列のValueListの値のインデックス。

参照

GetSeriesMarkEventArgs クラス | Steema.TeeChart.Styles 名前空間


MarkText

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GetSeriesMarkEventArgs.MarkText プロパティ

系列マーカのテキストを取得/設定します。

public String MarkText {get; set;}

解説

系列マーカのテキストを変更するために使用されます。

例

[C#]

private void button1_Click(object sender, System.EventArgs e)
{
     barSeries1.Add(3,"1st");
     barSeries1.Add(5,"2nd");
     barSeries1.Add(3,"3rd");
     barSeries1.Add(4,"4th");
     barSeries1.Add(6,"5th");
}

private void barSeries1_GetSeriesMark(Steema.TeeChart.Styles.Series series, Steema.TeeChart.Styles.GetSeriesMarkEventArgs e)
{
     if (barSeries1.YValues[e.ValueIndex]>3)

        e.MarkText="Limit exceeded!";
}

参照

GetSeriesMarkEventArgs クラス | GetSeriesMarkEventArgs メンバ | Steema.TeeChart.Styles 名前空間


ValueIndex

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GetSeriesMarkEventArgs.ValueIndex プロパティ

系列のValueListの値のインデックス。

public Int32 ValueIndex {get;}

解説

このプロパティは、変更するマーカのインデックスを設定するためにMarkTextプロパティと共に使用されます。

例

[C#]

private void button1_Click(object sender, System.EventArgs e)
{
     barSeries1.Add(3,"1st");
     barSeries1.Add(5,"2nd");
     barSeries1.Add(3,"3rd");
     barSeries1.Add(4,"4th");
     barSeries1.Add(6,"5th");
}

private void barSeries1_GetSeriesMark(Steema.TeeChart.Styles.Series series, Steema.TeeChart.Styles.GetSeriesMarkEventArgs e)
{
     if (barSeries1.YValues[e.ValueIndex]>3)

        e.MarkText="Limit exceeded!";
}

参照

GetSeriesMarkEventArgs クラス | GetSeriesMarkEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridColorPalette

Steema.TeeChart.Styles.GridColorPalette クラス

パレット特性を定義します。

この型のすべてのメンバの一覧については、GridColorPalette メンバを参照してください。

System.Object
public class GridColorPalette : Object

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridColorPalette 全メンバ

GridColorPalette 概要

コンストラクタ

Constructor

パブリック プロパティ

EndColor |
MidColor |
Palette | カラーパレットのリストにアクセスします。
PaletteMin |
PaletteStep |
PaletteSteps |
PaletteStyle |
StartColor |
UseColorRange |
UsePalette |
UsePaletteMin |

参照

GridColorPalette クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridColorPalette コンストラクタ

public GridColorPalette(Custom3DPalette series)

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridColorPalette プロパティ

パブリック プロパティ

EndColor |
MidColor |
Palette | カラーパレットのリストにアクセスします。
PaletteMin |
PaletteStep |
PaletteSteps |
PaletteStyle |
StartColor |
UseColorRange |
UsePalette |
UsePaletteMin |

参照

GridColorPalette クラス | Steema.TeeChart.Styles 名前空間


EndColor

Steema.TeeChart.Styles.GridColorPalette.EndColor プロパティ

public Color EndColor {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


MidColor

Steema.TeeChart.Styles.GridColorPalette.MidColor プロパティ

public Color MidColor {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


Palette

Steema.TeeChart.Styles.GridColorPalette.Palette プロパティ

カラーパレットのリストにアクセスします。
public List<GridPalette> Palette {get;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteMin

Steema.TeeChart.Styles.GridColorPalette.PaletteMin プロパティ

public Double PaletteMin {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteStep

Steema.TeeChart.Styles.GridColorPalette.PaletteStep プロパティ

public Double PaletteStep {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteSteps

Steema.TeeChart.Styles.GridColorPalette.PaletteSteps プロパティ

public Int32 PaletteSteps {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


PaletteStyle

Steema.TeeChart.Styles.GridColorPalette.PaletteStyle プロパティ

public PaletteStyles PaletteStyle {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


StartColor

Steema.TeeChart.Styles.GridColorPalette.StartColor プロパティ

public Color StartColor {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


UseColorRange

Steema.TeeChart.Styles.GridColorPalette.UseColorRange プロパティ

public Boolean UseColorRange {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


UsePalette

Steema.TeeChart.Styles.GridColorPalette.UsePalette プロパティ

public Boolean UsePalette {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


UsePaletteMin

Steema.TeeChart.Styles.GridColorPalette.UsePaletteMin プロパティ

public Boolean UsePaletteMin {get; set;}

参照

GridColorPalette クラス | GridColorPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridPalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GridPalette 構造体

パレット値を保持するためにCustom3DPalette系列で使用されます。

この型のすべてのメンバの一覧については、GridPalette メンバを参照してください。

System.Object
System.ValueType
public struct GridPalette : ValueType

参照

GridPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridPalette 全メンバ

GridPalette 概要

コンストラクタ

Constructor

パブリック フィールド

Color
UpToValue

参照

GridPalette 構造体 | Steema.TeeChart.Styles 名前空間


GridPalette コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GridPalette コンストラクタ

public GridPalette(Double aValue,
     Color aColor)

参照

GridPalette 構造体 | GridPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.GridPalette フィールド

パブリック フィールド

Color
UpToValue

参照

GridPalette 構造体 | Steema.TeeChart.Styles 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GridPalette.Color フィールド

public Color Color

参照

GridPalette 構造体 | GridPalette メンバ | Steema.TeeChart.Styles 名前空間


UpToValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.GridPalette.UpToValue フィールド

public Double UpToValue

参照

GridPalette 構造体 | GridPalette メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HandStyle

Steema.TeeChart.Styles.HandStyle 列挙体

HandStyleプロパティの使用可能な値を定義します。
[Serializable]
public sealed enum HandStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Line | 直線のゲージ針。
Triangle | 三角形のゲージ針。

参照

Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.HighLow

Steema.TeeChart.Styles.HighLow クラス

High-Low系列。

この型のすべてのメンバの一覧については、HighLow メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class HighLow : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HighLow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HighLow 全メンバ

HighLow 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | High-Low系列に新しい高値と安値を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | ポイントがXY位置にあるかどうか計算します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列ソースがHigh-Lowの場合、trueを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighBrush |
HighPen |
HighValues |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LowBrush |
LowPen |
LowValues |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HighLow クラス | Steema.TeeChart.Styles 名前空間


HighLow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow コンストラクタ

オーバーロードの一覧

public HighLow()
public HighLow(Steema.TeeChart.Chart)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


HighLow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow コンストラクタ

public HighLow()

参照

HighLow コンストラクタのオーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


HighLow コンストラクタ

Steema.TeeChart.Styles.HighLow コンストラクタ

public HighLow(Chart c)

参照

HighLow コンストラクタのオーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HighLow イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

HighLow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HighLow フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HighLow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HighLow メソッド

パブリック メソッド

Add | High-Low系列に新しい高値と安値を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | ポイントがXY位置にあるかどうか計算します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列ソースがHigh-Lowの場合、trueを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HighLow クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

オーバーロードの一覧

High-Low系列に新しい高値と安値を追加します。

public Int32 Add(System.Double, System.Double, System.Double)

High-Low系列に色と新しい高値と安値を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Drawing.Color)

High-Low系列にラベルと新しい高値と安値を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String)

High-Low系列にラベルと色と新しい高値と安値を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.String, System.Drawing.Color)
public override Void Add(System.Data.DataView)

解説

High-Low系列に新しい高値と安値を追加します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

High-Low系列に新しい高値と安値を追加します。
public Int32 Add(Double x,
     Double h,
     Double l)

参照

Add オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

High-Low系列に色と新しい高値と安値を追加します。
public Int32 Add(Double x,
     Double h,
     Double l,
     Color color)

参照

Add オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

High-Low系列にラベルと新しい高値と安値を追加します。
public Int32 Add(Double x,
     Double h,
     Double l,
     String text)

参照

Add オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

High-Low系列にラベルと色と新しい高値と安値を追加します。
public Int32 Add(Double x,
     Double h,
     Double l,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.HighLow.Add メソッド

public override Void Add(DataView view)

参照

Add オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.HighLow.Clicked メソッド

オーバーロードの一覧

任意のポイントがXY位置にあるかどうか計算します。

public override Int32 Clicked(System.Int32, System.Int32)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.HighLow.Clicked メソッド

任意のポイントがXY位置にあるかどうか計算します。
public override Int32 Clicked(Int32 x,
     Int32 y)

戻り値

ポイントインデックス

参照

Clicked オーバーロードの一覧 | HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.HighLow.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.HighLow.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.HighLow.IsValidSourceOf メソッド

系列ソースがHig-hLowの場合、trueを返します。
public override Boolean IsValidSourceOf(Series value)

解説

ValueパラメーターがSelfと同じ場合、falseを返します。
デザイン時および実行時にDataSourceプロパティを有効にします。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HighLow.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.HighLow.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.HighLow.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HighLow プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighBrush |
HighPen |
HighValues |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LowBrush |
LowPen |
LowValues |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

HighLow クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HighLow.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


HighBrush

Steema.TeeChart.Styles.HighLow.HighBrush プロパティ

public ChartBrush HighBrush {get;}

解説

高値のブラシ特性を定義します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


HighPen

Steema.TeeChart.Styles.HighLow.HighPen プロパティ

public ChartPen HighPen {get;}

解説

高値のペン特性を定義するために、このプロパティを設定してください。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


HighValues

Steema.TeeChart.Styles.HighLow.HighValues プロパティ

public ValueList HighValues {get;}

解説

高値のためのValueListプロパティにアクセスします。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


LowBrush

Steema.TeeChart.Styles.HighLow.LowBrush プロパティ

public ChartBrush LowBrush {get;}

解説

安値のブラシ特性を定義します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


LowPen

Steema.TeeChart.Styles.HighLow.LowPen プロパティ

public ChartPen LowPen {get;}

解説

安値のペン特性を定義します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


LowValues

Steema.TeeChart.Styles.HighLow.LowValues プロパティ

public ValueList LowValues {get;}

解説

安値のためのValueListプロパティにアクセスします。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.HighLow.Pen プロパティ

public ChartPen Pen {get;}

解説

High-Low系列の垂直分割線のペン特性を定義します。

参照

HighLow クラス | HighLow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram

Steema.TeeChart.Styles.Histogram クラス

ヒストグラム系列。

この型のすべてのメンバの一覧については、Histogram メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
public class Histogram : BaseLine , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Histogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram 全メンバ

Histogram 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LinesPen |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
previous
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalcRectangle |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |
VisiblePoints |

参照

Histogram クラス | Steema.TeeChart.Styles 名前空間


Histogram コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram コンストラクタ

オーバーロードの一覧

public Histogram()
public Histogram(Steema.TeeChart.Chart)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Histogram コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram コンストラクタ

public Histogram()

参照

Histogram コンストラクタのオーバーロードの一覧 | Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Histogram コンストラクタ

Steema.TeeChart.Styles.Histogram コンストラクタ

public Histogram(Chart c)

参照

Histogram コンストラクタのオーバーロードの一覧 | Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Histogram クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
previous
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Histogram クラス | Steema.TeeChart.Styles 名前空間


previous

Steema.TeeChart.Styles.Histogram.previous フィールド

protected internal Int32 previous

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalcRectangle |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |
VisiblePoints |

参照

Histogram クラス | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


CalcRectangle

Steema.TeeChart.Styles.Histogram.CalcRectangle メソッド

protected internal abstract Rectangle CalcRectangle(Int32 valueIndex)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Histogram.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Histogram.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Histogram.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Histogram.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Histogram.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Histogram.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Histogram.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


VisiblePoints

Steema.TeeChart.Styles.Histogram.VisiblePoints メソッド

protected internal Int32 VisiblePoints()

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Histogram プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LinesPen |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Histogram クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Histogram.Brush プロパティ

public ChartBrush Brush {get;}

解説

ヒストグラム系列のブラシを定義します。

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Histogram.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


LinesPen

Steema.TeeChart.Styles.Histogram.LinesPen プロパティ

public ChartPen LinesPen {get;}

解説

すべてのポイントを接続している線を描画するペンの種類を定義します。

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Histogram.Transparency プロパティ

public Int32 Transparency {get; set;}

解説

デフォルト値：0

透明度を0から100%で設定します。

参照

Histogram クラス | Histogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea

Steema.TeeChart.Styles.HorizArea クラス

横面系列。

この型のすべてのメンバの一覧については、HorizArea メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.Area
public class HorizArea : Area , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HorizArea メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea 全メンバ

HorizArea 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Areaの継承元) |
MaxYValue (Areaの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Areaの継承元) |
MinYValue (Areaの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Areaの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AreaBrush (Areaの継承元) | 面の背面領域を塗りつぶすブラシの種類を設定します。
AreaLines (Areaの継承元) | 面領域の垂直線を描くペンの種類を設定します。
AreaLinesPen (Areaの継承元) |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (Areaの継承元) | 面領域のグラデーションについて設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiArea (Areaの継承元) | 面系列が複数存在する場合、どのように表示するかを定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin (Areaの継承元) | すべての面系列ポイントの原点となる軸値を設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StackGroup (Areaの継承元) |
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TopGradient (Areaの継承元) | 上部の3D面領域を塗りつぶすグラデーションを定義します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin (Areaの継承元) | 面をOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (Areaの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Areaの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (Areaの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Areaの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (Areaの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizArea クラス | Steema.TeeChart.Styles 名前空間


HorizArea コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizArea コンストラクタ

オーバーロードの一覧

public HorizArea(Steema.TeeChart.Chart)
public HorizArea()

参照

HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


HorizArea コンストラクタ

Steema.TeeChart.Styles.HorizArea コンストラクタ

public HorizArea(Chart c)

参照

HorizArea コンストラクタのオーバーロードの一覧 | HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


HorizArea コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizArea コンストラクタ

public HorizArea()

参照

HorizArea コンストラクタのオーバーロードの一覧 | HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

HorizArea クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HorizArea クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Areaの継承元) |
MaxYValue (Areaの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Areaの継承元) |
MinYValue (Areaの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Areaの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (Areaの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Areaの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (Areaの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Areaの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (Areaの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizArea クラス | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.HorizArea.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.HorizArea.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizArea.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizArea プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AreaBrush (Areaの継承元) | 面の背面領域を塗りつぶすブラシの種類を設定します。
AreaLines (Areaの継承元) | 面領域の垂直線を描くペンの種類を設定します。
AreaLinesPen (Areaの継承元) |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (Areaの継承元) | 面領域のグラデーションについて設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiArea (Areaの継承元) | 面系列が複数存在する場合、どのように表示するかを定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin (Areaの継承元) | すべての面系列ポイントの原点となる軸値を設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StackGroup (Areaの継承元) |
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TopGradient (Areaの継承元) | 上部の3D面領域を塗りつぶすグラデーションを定義します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin (Areaの継承元) | 面をOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

HorizArea クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HorizArea.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

HorizArea クラス | HorizArea メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar

Steema.TeeChart.Styles.HorizBar クラス

横棒系列。

この型のすべてのメンバの一覧については、HorizBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
public class HorizBar : CustomBar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HorizBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar 全メンバ

HorizBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 垂直方向のバーの位置は、｢実際の｣Y位置＋バー幅になります。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarHeightPercent | バーの高さの割合を0～100%で設定します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward |
DrawTickLine |
DrawTickLines (CustomBarの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

HorizBar クラス | Steema.TeeChart.Styles 名前空間


HorizBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar コンストラクタ

オーバーロードの一覧

public HorizBar()
public HorizBar(Steema.TeeChart.Chart)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


HorizBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar コンストラクタ

public HorizBar()

参照

HorizBar コンストラクタのオーバーロードの一覧 | HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


HorizBar コンストラクタ

Steema.TeeChart.Styles.HorizBar コンストラクタ

public HorizBar(Chart c)

参照

HorizBar コンストラクタのオーバーロードの一覧 | HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

HorizBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HorizBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 垂直方向のバーの位置は、｢実際の｣Y位置＋バー幅になります。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery (CustomBarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward |
DrawTickLine |
DrawTickLines (CustomBarの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength |
InternalClicked |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizBar クラス | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& leftMargin,
     Int32& rightMargin)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& topMargin,
     Int32& bottomMargin)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.CalcXPos メソッド

ValueIndexの系列値の水平画面座標値をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

ValueIndexの系列値の水平画面座標値をピクセル単位で返します。

この座標値は水平軸に対応した系列を使用して計算されます。

例

系列ポイントの水平画面座標値を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.CalcYPos メソッド

垂直方向のバーの位置は、｢実際の｣Y位置＋バー幅になります。

public virtual Int32 CalcYPos(Int32 valueIndex)

解説

ValueIndexの系列値の垂直画面座標値をピクセル単位で返します。

この座標値は垂直軸に対応した系列を使用して計算されます。

例

系列ポイントの垂直画面座標値を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.HorizBar.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


DrawSeriesForward

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.DrawSeriesForward メソッド

protected virtual Boolean DrawSeriesForward(Int32 valueIndex)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


DrawTickLine

Steema.TeeChart.Styles.HorizBar.DrawTickLine メソッド

protected abstract Void DrawTickLine(Int32 tickPos,
     BarStyles aStyle)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.HorizBar.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


GetOriginPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.GetOriginPos メソッド

protected virtual Int32 GetOriginPos(Int32 valueIndex)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


InternalCalcMarkLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.InternalCalcMarkLength メソッド

protected virtual Int32 InternalCalcMarkLength(Int32 valueIndex)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


InternalClicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.InternalClicked メソッド

protected virtual Boolean InternalClicked(Int32 valueIndex,
     Point point)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.MinYValue メソッド

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.HorizBar.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarHeightPercent | バーの高さの割合を0～100%で設定します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

HorizBar クラス | Steema.TeeChart.Styles 名前空間


BarHeightPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBar.BarHeightPercent プロパティ

0から100でバーの高さの割合を定義します。

public Int32 BarHeightPercent {get; set;}

解説

0から100でバーの高さの割合を定義します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HorizBar.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

HorizBar クラス | HorizBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox

Steema.TeeChart.Styles.HorizBox クラス

横ボックスプロット系列は、水平方向のボックス系列を描画します。

この型のすべてのメンバの一覧については、HorizBox メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomBox
public class HorizBox : CustomBox , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HorizBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox 全メンバ

HorizBox 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (CustomBoxの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomBoxの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomBoxの継承元) | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomBoxの継承元) |
ReconstructFromData (CustomBoxの継承元) | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 (CustomBoxの継承元) | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 (CustomBoxの継承元) | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box (CustomBoxの継承元) | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExtrOut (CustomBoxの継承元) | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 (CustomBoxの継承元) | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 (CustomBoxの継承元) | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median (CustomBoxの継承元) | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen (CustomBoxの継承元) | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut (CustomBoxの継承元) | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 (CustomBoxの継承元) | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 (CustomBoxの継承元) | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position (CustomBoxの継承元) | ボックスプロット系列の位置を指定します。
Quartile1 (CustomBoxの継承元) | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 (CustomBoxの継承元) | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues (CustomBoxの継承元) | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues (CustomBoxの継承元) | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength (CustomBoxの継承元) | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen (CustomBoxの継承元) | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition (CustomBoxの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical (CustomBoxの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomBoxの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomBoxの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomBoxの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomBoxの継承元) |
GetDataSource (CustomBoxの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBoxの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizBox クラス | Steema.TeeChart.Styles 名前空間


HorizBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBox コンストラクタ

オーバーロードの一覧

public HorizBox()
public HorizBox(Steema.TeeChart.Chart)

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


HorizBox コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBox コンストラクタ

public HorizBox()

参照

HorizBox コンストラクタのオーバーロードの一覧 | HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


HorizBox コンストラクタ

Steema.TeeChart.Styles.HorizBox コンストラクタ

public HorizBox(Chart c)

参照

HorizBox コンストラクタのオーバーロードの一覧 | HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

HorizBox クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
dPosition (CustomBoxの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
IVertical (CustomBoxの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HorizBox クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox メソッド

パブリック メソッド

Add (CustomBoxの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomBoxの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomBoxの継承元) | 系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomBoxの継承元) |
ReconstructFromData (CustomBoxの継承元) | 系列データからボックスプロットを再構築します。
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomBoxの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomBoxの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomBoxの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomBoxの継承元) |
GetDataSource (CustomBoxの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBoxの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizBox クラス | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.HorizBox.MaxXValue メソッド

public override Double MaxXValue()

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBox.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

Steema.TeeChart.Styles.HorizBox.MinXValue メソッド

public override Double MinXValue()

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizBox.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値はすべての系列のY値リスト内の最小値になります。

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizBox プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AdjacentPoint1 (CustomBoxの継承元) | 隣接ポイントより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
AdjacentPoint3 (CustomBoxの継承元) | 隣接ポイントより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Box (CustomBoxの継承元) | CustomBox系列のボックスの外観を制御します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExtrOut (CustomBoxの継承元) | 極値の外観を制御します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InnerFence1 (CustomBoxの継承元) | 内側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
InnerFence3 (CustomBoxの継承元) | 内側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Median (CustomBoxの継承元) | 中央値を取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
MedianPen (CustomBoxの継承元) | 中央値の線を描くペンを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MildOut (CustomBoxの継承元) | 外れ値の外観を制御します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OuterFence1 (CustomBoxの継承元) | 外側フェンスより下のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
OuterFence3 (CustomBoxの継承元) | 外側フェンスより上のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
Position (CustomBoxの継承元) | ボックスプロット系列の位置を指定します。
Quartile1 (CustomBoxの継承元) | 第１四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
Quartile3 (CustomBoxの継承元) | 第３四分位数のSampleValuesを取得するために使用してください。ボックスプロットを作成するために、このプロパティに独自の値を設定すると、CustomBox系列のデフォルトの計算アルゴリズムをオーバーライドします。
SampleValues (CustomBoxの継承元) | 系列の値にアクセスするために使用してください。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
UseCustomValues (CustomBoxの継承元) | ボックスを作成する内部のアルゴリズムをオーバーライドする場合、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WhiskerLength (CustomBoxの継承元) | ひげの長さをIQR単位で定義します（IQR = 第3四分位数 - 第1四分位数）。
WhiskerPen (CustomBoxの継承元) | ひげを描くペンを定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

HorizBox クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HorizBox.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

HorizBox クラス | HorizBox メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram

Steema.TeeChart.Styles.HorizHistogram クラス

横ヒストグラム系列。

この型のすべてのメンバの一覧については、HorizHistogram メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.Histogram
public class HorizHistogram : Histogram , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram 全メンバ

HorizHistogram 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Histogramの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Histogramの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Histogramの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Histogramの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LinesPen (Histogramの継承元) |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Histogramの継承元) |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
previous (Histogramの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Histogramの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalcRectangle |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Histogramの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Histogramの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Histogramの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Histogramの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |
VisiblePoints (Histogramの継承元) |

参照

HorizHistogram クラス | Steema.TeeChart.Styles 名前空間


HorizHistogram コンストラクタ

Steema.TeeChart.Styles.HorizHistogram コンストラクタ

オーバーロードの一覧

public HorizHistogram(Steema.TeeChart.Chart)
public HorizHistogram()

参照

HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


HorizHistogram コンストラクタ

Steema.TeeChart.Styles.HorizHistogram コンストラクタ

public HorizHistogram(Chart c)

参照

HorizHistogram コンストラクタのオーバーロードの一覧 | HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


HorizHistogram コンストラクタ

Steema.TeeChart.Styles.HorizHistogram コンストラクタ

public HorizHistogram()

参照

HorizHistogram コンストラクタのオーバーロードの一覧 | HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

HorizHistogram クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
previous (Histogramの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HorizHistogram クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (BaseLineの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Histogramの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Histogramの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Histogramの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Histogramの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalcRectangle |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Histogramの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Histogramの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Histogramの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Histogramの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |
VisiblePoints (Histogramの継承元) |

参照

HorizHistogram クラス | Steema.TeeChart.Styles 名前空間


CalcRectangle

Steema.TeeChart.Styles.HorizHistogram.CalcRectangle メソッド

protected internal abstract Rectangle CalcRectangle(Int32 valueIndex)

参照

HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.HorizHistogram.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.HorizHistogram.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizHistogram プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Histogramの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LinesPen (Histogramの継承元) |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Histogramの継承元) |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

HorizHistogram クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HorizHistogram.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

HorizHistogram クラス | HorizHistogram メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine

Steema.TeeChart.Styles.HorizLine クラス

横リボン系列。

この型のすべてのメンバの一覧については、HorizLine メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.Line
public class HorizLine : Line , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

HorizLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine 全メンバ

HorizLine 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Lineの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (Lineの継承元) | 線のグラデーションを定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Lineの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizLine クラス | Steema.TeeChart.Styles 名前空間


HorizLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizLine コンストラクタ

オーバーロードの一覧

public HorizLine(Steema.TeeChart.Chart)
public HorizLine()

参照

HorizLine クラス | HorizLine メンバ | Steema.TeeChart.Styles 名前空間


HorizLine コンストラクタ

Steema.TeeChart.Styles.HorizLine コンストラクタ

public HorizLine(Chart c)

参照

HorizLine コンストラクタのオーバーロードの一覧 | HorizLine クラス | HorizLine メンバ | Steema.TeeChart.Styles 名前空間


HorizLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizLine コンストラクタ

public HorizLine()

参照

HorizLine コンストラクタのオーバーロードの一覧 | HorizLine クラス | HorizLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

HorizLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

HorizLine クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Lineの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Lineの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

HorizLine クラス | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.HorizLine.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

HorizLine クラス | HorizLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizLine プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
ClickableLine (Customの継承元) | ポイント間の線の上のマウスクリックを認めるかどうか設定します。
Color (Seriesの継承元) | 系列ポイントを描く際のデフォルトの色です。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | ポイントを接続している各線を異なる色で描画します。
ColorEachPoint (Seriesの継承元) | 旧式：ColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 保存した色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列のために指定した水平のカスタム軸。
CustomVertAxis (Seriesの継承元) | 系列のために指定した垂直のカスタム軸。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | このプロパティを使用してオブジェクトにデータをロードします。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのLabelフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くためのプロパティを定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：Series.Colorプロパティを使用してください。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタ内に表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を返します。

参照

HorizLine クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.HorizLine.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

HorizLine クラス | HorizLine メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.HorizontalAxis

TeeChartプログラミングガイド

Steema.TeeChart.Styles.HorizontalAxis 列挙体

HorizAxisプロパティの使用可能な値です。

[Serializable]
public enum HorizontalAxis : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Top | 上軸に系列を関連付けます。
Bottom | 下軸に系列を関連付けます。
Both | 上軸と下軸に系列を関連付けます。
Custom | カスタム軸に系列を関連付けます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar

Steema.TeeChart.Styles.ImageBar クラス

イメージバー系列。

この型のすべてのメンバの一覧については、ImageBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomBar
Steema.TeeChart.Styles.Bar
public class ImageBar : Bar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ImageBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar 全メンバ

ImageBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。バーを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Barの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Barの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Image |
ImageTiled |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

ImageBar クラス | Steema.TeeChart.Styles 名前空間


ImageBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ImageBar コンストラクタ

オーバーロードの一覧

public ImageBar()
public ImageBar(Steema.TeeChart.Chart)

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


ImageBar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ImageBar コンストラクタ

public ImageBar()

参照

ImageBar コンストラクタのオーバーロードの一覧 | ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


ImageBar コンストラクタ

Steema.TeeChart.Styles.ImageBar コンストラクタ

public ImageBar(Chart c)

参照

ImageBar コンストラクタのオーバーロードの一覧 | ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetBarStyle (CustomBarの継承元) | 系列のバーが描画される際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

ImageBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
barSizePercent (CustomBarの継承元)
bColorEach (Seriesの継承元)
bDark3D (CustomBarの継承元)
bUseOrigin (CustomBarの継承元)
calcVisiblePoints (Seriesの継承元)
conePercent (CustomBarの継承元)
customBarSize (CustomBarの継承元)
dOrigin (CustomBarの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iBarBounds (CustomBarの継承元)
IBarSize (CustomBarの継承元)
iMultiBar (CustomBarの継承元)
InternalUse (TeeBaseの継承元)
INumBars (CustomBarの継承元)
IOrderPos (CustomBarの継承元)
IPreviousCount (CustomBarの継承元)
lastVisible (Seriesの継承元)
NormalBarColor (CustomBarの継承元)
pPen (CustomBarの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

ImageBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BarMargin (CustomBarの継承元) | 両端のマージンをピクセル単位で返します。
BarRectangle (CustomBarの継承元) | 内部使用。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Barの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomBarの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawBar | 内部使用。バーを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Barの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetOriginPos (Barの継承元) | 指定したバーの表示原点の画面座標値をピクセル単位で返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Barの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Barの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Barの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Barの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointOrigin (CustomBarの継承元) | 内部使用。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (CustomBarの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
ApplyBarOffset (CustomBarの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (CustomBarの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Barの継承元) |
CalcMarkLength (CustomBarの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Barの継承元) |
CalcZOrder (CustomBarの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (CustomBarの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomBarの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetBarStyle (CustomBarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomBarの継承元) |
DrawMark (Barの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Barの継承元) |
DrawTickLine (Barの継承元) |
DrawTickLines (CustomBarの継承元) |
GetBounds (Barの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalApplyBarMargin (CustomBarの継承元) |
InternalCalcMarkLength (Barの継承元) |
InternalClicked (Barの継承元) |
InternalColor (Seriesの継承元) |
InternalGetOriginPos (CustomBarの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MaxMandatoryValue (CustomBarの継承元) |
MinMandatoryValue (CustomBarの継承元) |
ModifySeriesColors (CustomBarの継承元) |
MoreSameZOrder (Barの継承元) |
MouseEvent (Seriesの継承元) |
NumSampleValues (CustomBarの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (CustomBarの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBarSizePercent (CustomBarの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomBarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDefaultCylinderGradient (CustomBarの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetPenBrushBar (CustomBarの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeYOrigin (CustomBarの継承元) |
SubGalleryStack (CustomBarの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

ImageBar クラス | Steema.TeeChart.Styles 名前空間


DrawBar

Steema.TeeChart.Styles.ImageBar.DrawBar メソッド

内部使用。バーを描画します。
public override Void DrawBar(Int32 BarIndex,
     Int32 StartPos,
     Int32 EndPos)

解説

内部使用。バーを描画します。

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.ImageBar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImageBar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AutoMarkPosition (CustomBarの継承元) | オーバーラップを避けるためにマーカを自動的に移動させます。
BarBounds (CustomBarの継承元) | 表示されているバーポイントのサイズを定義する矩形を返します。
BarStyle (CustomBarの継承元) | バーのスタイルを設定します。
BarWidthPercent (Barの継承元) | 使用するバー幅全体に対する割合を定義します。
Brush (CustomBarの継承元) | バーを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomBarWidth (CustomBarの継承元) |
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (CustomBarの継承元) | 3D効果を表すためにバーの側面を暗くするかどうか制御します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthPercent (CustomBarの継承元) | バーが必要とする「Z」方向の深さを0～100%で設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient (CustomBarの継承元) | バーを塗りつぶすグラデーション特性を設定します。
GradientRelative (CustomBarの継承元) | グラデーションが有効の場合、一番高いバーに基づいて色を計算します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Image |
ImageTiled |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MultiBar (CustomBarの継承元) | 同じチャート内に複数のバー系列が存在する場合、各バーの描画する位置を定義します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OffsetPercent (CustomBarの継承元) | バーの移動をバーサイズに対する割合で定義します。
Origin (CustomBarの継承元) | すべてのバーポイントが使用する共通の描画始点を設定します。
Pen (CustomBarの継承元) | バーの矩形を描くペンの種類を定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideMargins (CustomBarの継承元) | チャート矩形とバーとの間にマージンを設定します。
StackGroup (CustomBarの継承元) | 同じチャート内に積み重ね系列のグループ化を設定します。
StartZ (Seriesの継承元) | 内部使用。
TickLines (CustomBarの継承元) | 各バーの各軸グリッド位置に線を描画するために使用するペンを定義します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseOrigin (CustomBarの継承元) | バーをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YOrigin (CustomBarの継承元) | 旧式：このプロパティの代わりにOriginプロパティを使用してください。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト プロパティ

BarBoundsMidX (CustomBarの継承元)

参照

ImageBar クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.ImageBar.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


Image

Steema.TeeChart.Styles.ImageBar.Image プロパティ

public Image Image {get; set;}

解説

バーポイントのイメージを設定するために使用してください。null(nil) の場合、バーポイントにイメージが表示されません。

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


ImageTiled

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ImageBar.ImageTiled プロパティ

public Boolean ImageTiled {get; set;}

解説

デフォルト値：false

trueの場合、イメージバーのイメージはバー毎にタイルされます。デフォルトではイメージはストレッチされます。

参照

ImageBar クラス | ImageBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint

Steema.TeeChart.Styles.ImagePoint クラス

この型のすべてのメンバの一覧については、ImagePoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
Steema.TeeChart.Styles.CustomImagePoint
public class ImagePoint : CustomImagePoint , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint 全メンバ

ImagePoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetImage (CustomImagePointの継承元) |
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomImagePointの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomImagePointの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
PointImage (CustomImagePointの継承元) |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent (CustomImagePointの継承元) |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

ImagePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint コンストラクタ

オーバーロードの一覧

public ImagePoint()
public ImagePoint(Steema.TeeChart.Chart)

参照

ImagePoint クラス | ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint コンストラクタ

public ImagePoint()

参照

ImagePoint コンストラクタのオーバーロードの一覧 | ImagePoint クラス | ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint コンストラクタ

public ImagePoint(Chart c)

参照

ImagePoint コンストラクタのオーバーロードの一覧 | ImagePoint クラス | ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetImage (CustomImagePointの継承元) |
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

ImagePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

ImagePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomImagePointの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (CustomImagePointの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Pointsの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

ImagePoint クラス | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.ImagePoint.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

ImagePoint クラス | ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ImagePoint プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Pointsの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
PointImage (CustomImagePointの継承元) |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent (CustomImagePointの継承元) |
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

ImagePoint クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.ImagePoint.Description プロパティ

public override String Description {get;}

参照

ImagePoint クラス | ImagePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface

Steema.TeeChart.Styles.IsoSurface クラス

Iso サーフェス系列。

この型のすべてのメンバの一覧については、IsoSurface メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
Steema.TeeChart.Styles.Surface
public class IsoSurface : Surface , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface 全メンバ

IsoSurface 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation (Surfaceの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Surfaceの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints (Surfaceの継承元) |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BandPen |
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DotFrame (Surfaceの継承元) | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells (Surfaceの継承元) |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush (Surfaceの継承元) | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines (Surfaceの継承元) |
Sides |
SmoothPalette (Surfaceの継承元) | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
UseYPosition |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall (Surfaceの継承元) | ウォーターフォールとしての表示を有効/無効にします。
WaterLines (Surfaceの継承元) | 値ラインを描くペンを設定します。
WireFrame (Surfaceの継承元) | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YPosition |
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall (Surfaceの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX (Surfaceの継承元)
iCalcY (Surfaceの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points (Surfaceの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex (Surfaceの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Surfaceの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast |
ShouldDrawSides |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

IsoSurface クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface コンストラクタ

オーバーロードの一覧

public IsoSurface()
public IsoSurface(Steema.TeeChart.Chart)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface コンストラクタ

public IsoSurface()

参照

IsoSurface コンストラクタのオーバーロードの一覧 | IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface コンストラクタ

public IsoSurface(Chart c)

参照

IsoSurface コンストラクタのオーバーロードの一覧 | IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

IsoSurface クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall (Surfaceの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX (Surfaceの継承元)
iCalcY (Surfaceの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points (Surfaceの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

IsoSurface クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation (Surfaceの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Surfaceの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints (Surfaceの継承元) |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex (Surfaceの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Surfaceの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast |
ShouldDrawSides |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

IsoSurface クラス | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.IsoSurface.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.IsoSurface.Draw メソッド

public override Void Draw()

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


DrawCell

Steema.TeeChart.Styles.IsoSurface.DrawCell メソッド

protected internal abstract Void DrawCell(Int32 x,
     Int32 z)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


DrawSidePortion

Steema.TeeChart.Styles.IsoSurface.DrawSidePortion メソッド

protected abstract Void DrawSidePortion(Point[] P,
     Int32 z0,
     Int32 z1)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.IsoSurface.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


SetSameBrush

Steema.TeeChart.Styles.IsoSurface.SetSameBrush メソッド

protected abstract Boolean SetSameBrush()

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.IsoSurface.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


ShouldDrawFast

Steema.TeeChart.Styles.IsoSurface.ShouldDrawFast メソッド

protected abstract Boolean ShouldDrawFast()

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


ShouldDrawSides

Steema.TeeChart.Styles.IsoSurface.ShouldDrawSides メソッド

protected abstract Boolean ShouldDrawSides()

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IsoSurface プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BandPen |
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DotFrame (Surfaceの継承元) | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells (Surfaceの継承元) |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush (Surfaceの継承元) | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines (Surfaceの継承元) |
Sides |
SmoothPalette (Surfaceの継承元) | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
UseYPosition |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall (Surfaceの継承元) | ウォーターフォールとしての表示を有効/無効にします。
WaterLines (Surfaceの継承元) | 値ラインを描くペンを設定します。
WireFrame (Surfaceの継承元) | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YPosition |
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

IsoSurface クラス | Steema.TeeChart.Styles 名前空間


BandPen

Steema.TeeChart.Styles.IsoSurface.BandPen プロパティ

public ChartPen BandPen {get; set;}

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.IsoSurface.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Sides

Steema.TeeChart.Styles.IsoSurface.Sides プロパティ

public SurfaceSides Sides {get; set;}

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


UseYPosition

Steema.TeeChart.Styles.IsoSurface.UseYPosition プロパティ

public Boolean UseYPosition {get; set;}

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


YPosition

Steema.TeeChart.Styles.IsoSurface.YPosition プロパティ

public Double YPosition {get; set;}

参照

IsoSurface クラス | IsoSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IWorldMaps

Steema.TeeChart.Styles.IWorldMaps インタフェース

public interface IWorldMaps

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

IWorldMaps メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IWorldMaps 全メンバ

IWorldMaps 概要

パブリック メソッド

GetWorldMapTypeNames
ParseWorldMapTypeName

パブリック プロパティ

InGallery

参照

IWorldMaps インターフェイス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IWorldMaps メソッド

パブリック メソッド

GetWorldMapTypeNames
ParseWorldMapTypeName

参照

IWorldMaps インターフェイス | Steema.TeeChart.Styles 名前空間


GetWorldMapTypeNames

Steema.TeeChart.Styles.IWorldMaps.GetWorldMapTypeNames メソッド

public abstract String[] GetWorldMapTypeNames()

参照

IWorldMaps インターフェイス | IWorldMaps メンバ | Steema.TeeChart.Styles 名前空間


ParseWorldMapTypeName

Steema.TeeChart.Styles.IWorldMaps.ParseWorldMapTypeName メソッド

public abstract Object ParseWorldMapTypeName(String name)

参照

IWorldMaps インターフェイス | IWorldMaps メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.IWorldMaps プロパティ

パブリック プロパティ

InGallery

参照

IWorldMaps インターフェイス | Steema.TeeChart.Styles 名前空間


InGallery

Steema.TeeChart.Styles.IWorldMaps.InGallery プロパティ

public abstract Boolean InGallery {get; set;}

参照

IWorldMaps インターフェイス | IWorldMaps メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi

Steema.TeeChart.Styles.Kagi クラス

かぎ足金融チャート。

この型のすべてのメンバの一覧については、Kagi メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Kagi : Custom , IComponent, IDisposable, ICloneable

解説

一見、かぎ足チャートはスウィングチャートに似ています。スウィングチャート同様、かぎ足チャートは時間軸がなく連続する垂直線で作成されますが、かぎ足チャートの場合は垂直線は単にバーの高値や低値ではなく、終値の動きだけに基づいています。もう1つの違いは、かぎ足チャートの線の太さは終値が前の列の上部または下部に強い影響を与えるときに変わります。

かぎ足チャートの構造：

反転値：絶対値または相対値を選んでください。ご自身のデータの最初の終値を注目してください。これは基準価格と呼ばれます。Day 2 の終値がDay 1 の終値（基準価格）を上回った場合、UpSwing スタイルを使用してDay 1 の終値からDay 2 の終値まで上向きに垂直線を描画してください。Day 2 の終値がDay 1 の終値（基準価格）を下回った場合、DownPen スタイルを使用してDay 1 の終値からDay 2 の終値まで下向きに垂直線を描画してください。Day 2 の終値とDay 1 の終値（基準価格）が同じ場合は何も描画しないでください。代わりに、Day 3が終わるまで待って、この日の終値とDay 1 の終値（基準価格）を比べてください。終値が上昇（下降）し続けている場合、値動きの多い少ないに関係なく、かぎ足チャートを各日の終値まで上向き（または下向き）に描画し続けてください。終値があらかじめ定義した数銭以下で反対方向（反転値）に変動した場合、「屈折線」と呼ばれる短い水平線を描画し、次にその日の終値に新しい下降線を描画します。かぎ足の線が下降し続けていて、その終値が反転値を上回って上昇した場合、屈折線を書き、次にその日の終値に上昇線を描画します。

垂直方向の描画のペンスタイルは次の法則で定義されます。DownSwing ラインが前のスウィングより高く延びた場合、そのポイント以降はペンスタイルは UpSwing ペンに変更されます。UpSwing ラインが前のスウィングより低くなった場合は UpSwing ペンは DownSwing ペンに変わります。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Kagi メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.Kagi 全メンバ

Kagi 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

AbsoluteReversal | False の場合、反転量はパーセントで表されます。それ以外は絶対値で表されます。
Active (Seriesの継承元) | 系列を表示/非表示にします。
BasePrice | 基準価格。例：最初の終値。
Brush (Customの継承元) | ブラシの特性を設定します。
BuySymbol | 買いシンボルを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | 取引の終値です。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSwing | 下降線の外観を制御します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
ReversalAmount | 反転量（パーセントあるいは絶対値）。
SellSymbol | 売りシンボルを定義します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSwing | 上昇線の外観を制御します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Kagi クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi コンストラクタ

オーバーロードの一覧

public Kagi()
public Kagi(Steema.TeeChart.Chart)

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi コンストラクタ

public Kagi()

参照

Kagi コンストラクタのオーバーロードの一覧 | Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi コンストラクタ

public Kagi(Chart c)

参照

Kagi コンストラクタのオーバーロードの一覧 | Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Kagi クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Kagi クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Kagi クラス | Steema.TeeChart.Styles 名前空間


CountLegendItems

Steema.TeeChart.Styles.Kagi.CountLegendItems メソッド

protected internal abstract Int32 CountLegendItems()

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Kagi.Draw メソッド

public override Void Draw()

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.Kagi.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 index)

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Kagi.LegendString メソッド

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.Kagi.MaxXValue メソッド

public override Double MaxXValue()

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.Kagi.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Kagi.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Kagi.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Kagi プロパティ

パブリック プロパティ

AbsoluteReversal | False の場合、反転量はパーセントで表されます。それ以外は絶対値で表されます。
Active (Seriesの継承元) | 系列を表示/非表示にします。
BasePrice | 基準価格。例：最初の終値。
Brush (Customの継承元) | ブラシの特性を設定します。
BuySymbol | 買いシンボルを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | 取引の終値です。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色でポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイントにマウスカーソルが触れた際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | データソースを指定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSwing | 下降線の外観を制御します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのLabelフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透明度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
ReversalAmount | 反転量（パーセントあるいは絶対値）。
SellSymbol | 売りシンボルを定義します。
SeriesColor (Seriesの継承元) | このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタ内に表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSwing | 上昇線の外観を制御します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を返します。

参照

Kagi クラス | Steema.TeeChart.Styles 名前空間


AbsoluteReversal

Steema.TeeChart.Styles.Kagi.AbsoluteReversal プロパティ

False の場合、反転量はパーセントで表されます。それ以外は絶対値で表されます。
public Boolean AbsoluteReversal {get; set;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


BasePrice

Steema.TeeChart.Styles.Kagi.BasePrice プロパティ

基準価格。例：最初の終値。
public Double BasePrice {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


BuySymbol

Steema.TeeChart.Styles.Kagi.BuySymbol プロパティ

買いシンボルを定義します。
public SeriesPointer BuySymbol {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


CloseValues

Steema.TeeChart.Styles.Kagi.CloseValues プロパティ

取引の終値です。
public ValueList CloseValues {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Kagi.Description プロパティ

public override String Description {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


DownSwing

Steema.TeeChart.Styles.Kagi.DownSwing プロパティ

下降線の外観を制御します。
public ChartPen DownSwing {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


ReversalAmount

Steema.TeeChart.Styles.Kagi.ReversalAmount プロパティ

反転量（パーセントあるいは絶対値）。
public Double ReversalAmount {get; set;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


SellSymbol

Steema.TeeChart.Styles.Kagi.SellSymbol プロパティ

売りシンボルを定義します。
public SeriesPointer SellSymbol {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


UpSwing

Steema.TeeChart.Styles.Kagi.UpSwing プロパティ

上昇線の外観を制御します。
public ChartPen UpSwing {get;}

参照

Kagi クラス | Kagi メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelPoint

Steema.TeeChart.Styles.LevelPoint 値型

この型のすべてのメンバの一覧については、LevelPoint メンバを参照してください。

System.Object
System.ValueType
public sealed struct LevelPoint : ValueType

参照

LevelPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelPoint 全メンバ

LevelPoint 概要

パブリック フィールド

X
Y

参照

LevelPoint 構造体 | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelPoint フィールド

パブリック フィールド

X
Y

参照

LevelPoint 構造体 | Steema.TeeChart.Styles 名前空間


X

Steema.TeeChart.Styles.LevelPoint.X フィールド

public Double X

参照

LevelPoint 構造体 | LevelPoint メンバ | Steema.TeeChart.Styles 名前空間


Y

Steema.TeeChart.Styles.LevelPoint.Y フィールド

public Double Y

参照

LevelPoint 構造体 | LevelPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegment

Steema.TeeChart.Styles.LevelSegment クラス

この型のすべてのメンバの一覧については、LevelSegment メンバを参照してください。

System.Object
public class LevelSegment : Object

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

LevelSegment メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegment 全メンバ

LevelSegment 概要

コンストラクタ

Constructor

パブリック フィールド

Count
Points

参照

LevelSegment クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegment コンストラクタ

public LevelSegment()

参照

LevelSegment クラス | LevelSegment メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegment フィールド

パブリック フィールド

Count
Points

参照

LevelSegment クラス | Steema.TeeChart.Styles 名前空間


Count

Steema.TeeChart.Styles.LevelSegment.Count フィールド

public Int32 Count

参照

LevelSegment クラス | LevelSegment メンバ | Steema.TeeChart.Styles 名前空間


Points

Steema.TeeChart.Styles.LevelSegment.Points フィールド

public LevelPoint[] Points

参照

LevelSegment クラス | LevelSegment メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegments

Steema.TeeChart.Styles.LevelSegments クラス

この型のすべてのメンバの一覧については、LevelSegments メンバを参照してください。

System.Object
System.Collections.ArrayList
public class LevelSegments : ArrayList , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

LevelSegments メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegments 全メンバ

LevelSegments 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

LevelSegments クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegments コンストラクタ

public LevelSegments()

参照

LevelSegments クラス | LevelSegments メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LevelSegments プロパティ

パブリック プロパティ

Item

参照

LevelSegments クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.LevelSegments.Item プロパティ

public LevelSegment Item(Int32 index) {get; set;}

参照

LevelSegments クラス | LevelSegments メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line

Steema.TeeChart.Styles.Line クラス

リボン系列。

この型のすべてのメンバの一覧については、Line メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Line : Custom , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Line メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line 全メンバ

Line 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | 線のグラデーションを定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Line クラス | Steema.TeeChart.Styles 名前空間


Line コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Line コンストラクタ

オーバーロードの一覧

public Line(Steema.TeeChart.Chart)
public Line()

参照

Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Line コンストラクタ

Steema.TeeChart.Styles.Line コンストラクタ

public Line(Chart c)

参照

Line コンストラクタのオーバーロードの一覧 | Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Line コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Line コンストラクタ

public Line()

参照

Line コンストラクタのオーバーロードの一覧 | Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Line クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Line クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Line クラス | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Line.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Line.SetSubGallery メソッド

public override Void SetSubGallery(Int32 Index)

参照

Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Line プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | 線のグラデーションを定義します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Line クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Line.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.Line.Gradient プロパティ

線のグラデーションを定義します。
public Gradient Gradient {get;}

解説

線のグラデーションを定義します。

参照

Line クラス | Line メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge

Steema.TeeChart.Styles.LinearGauge クラス

線形ゲージ系列。

この型のすべてのメンバの一覧については、LinearGauge メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
public class LinearGauge : CustomGauge , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge 全メンバ

LinearGauge 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MaxValueIndicator | 線形ゲージの最大インジケータの特性について取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseValueColorPalette | ValueColorPaletteプロパティを使用し、線形ゲージの針のカスタムなグラデーションスキーマを定義するにはTrueに設定してください。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueAreaBrush | 線形ゲージのスライダーのブラシ特性を取得/設定します。
ValueColorPalette | カスタムなグラデーションカラーのスキーマを定義する色の配列。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomGaugeの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (CustomGaugeの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines |
DrawFace |
DrawFrame (CustomGaugeの継承元) |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

LinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge コンストラクタ

オーバーロードの一覧

public LinearGauge()
public LinearGauge(Steema.TeeChart.Chart)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge コンストラクタ

public LinearGauge()

参照

LinearGauge コンストラクタのオーバーロードの一覧 | LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge コンストラクタ

public LinearGauge(Chart c)

参照

LinearGauge コンストラクタのオーバーロードの一覧 | LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

参照

LinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

LinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (CustomGaugeの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines |
DrawFace |
DrawFrame (CustomGaugeの継承元) |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

LinearGauge クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.LinearGauge.Draw メソッド

public override Void Draw()

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawAxis

Steema.TeeChart.Styles.LinearGauge.DrawAxis メソッド

protected abstract Void DrawAxis(Graphics3D g)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawColorLines

Steema.TeeChart.Styles.LinearGauge.DrawColorLines メソッド

protected abstract Void DrawColorLines(Graphics3D g)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawFace

Steema.TeeChart.Styles.LinearGauge.DrawFace メソッド

protected abstract Void DrawFace(Graphics3D g)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawHand

Steema.TeeChart.Styles.LinearGauge.DrawHand メソッド

protected abstract Void DrawHand(Graphics3D g)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


GetAxis

Steema.TeeChart.Styles.LinearGauge.GetAxis メソッド

protected abstract Axis GetAxis()

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.LinearGauge.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.LinearGauge.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


SetValue

Steema.TeeChart.Styles.LinearGauge.SetValue メソッド

protected abstract Void SetValue(Double value)

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


SetValues

Steema.TeeChart.Styles.LinearGauge.SetValues メソッド

protected abstract Void SetValues()

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinearGauge プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MaxValueIndicator | 線形ゲージの最大インジケータの特性について取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseValueColorPalette | ValueColorPaletteプロパティを使用し、線形ゲージの針のカスタムなグラデーションスキーマを定義するにはTrueに設定してください。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueAreaBrush | 線形ゲージのスライダーのブラシ特性を取得/設定します。
ValueColorPalette | カスタムなグラデーションカラーのスキーマを定義する色の配列。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

LinearGauge クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.LinearGauge.Description プロパティ

public override String Description {get;}

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


MaxValueIndicator

Steema.TeeChart.Styles.LinearGauge.MaxValueIndicator プロパティ

線形ゲージの最大インジケータの特性について取得/設定します。
public GaugeSeriesPointer MaxValueIndicator {get; set;}

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


UseValueColorPalette

Steema.TeeChart.Styles.LinearGauge.UseValueColorPalette プロパティ

ValueColorPaletteプロパティを使用し、線形ゲージの針のカスタムなグラデーションスキーマを定義するにはTrueに設定してください。
public Boolean UseValueColorPalette {get; set;}

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


ValueAreaBrush

Steema.TeeChart.Styles.LinearGauge.ValueAreaBrush プロパティ

線形ゲージのスライダーのブラシ特性を取得/設定します。
public ChartBrush ValueAreaBrush {get; set;}

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間


ValueColorPalette

Steema.TeeChart.Styles.LinearGauge.ValueColorPalette プロパティ

カスタムなグラデーションカラーのスキーマを定義する色の配列。
public Color[] ValueColorPalette {get; set;}

参照

LinearGauge クラス | LinearGauge メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.LinePoint

Steema.TeeChart.Styles.LinePoint クラス

ラインポイント系列。

この型のすべてのメンバの一覧については、LinePoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Points
public class LinePoint : Points , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

LinePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinePoint 全メンバ

LinePoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

LinePoint クラス | Steema.TeeChart.Styles 名前空間


LinePoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.LinePoint コンストラクタ

オーバーロードの一覧

public LinePoint()
public LinePoint(Steema.TeeChart.Chart)

参照

LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


LinePoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.LinePoint コンストラクタ

public LinePoint()

参照

LinePoint コンストラクタのオーバーロードの一覧 | LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


LinePoint コンストラクタ

Steema.TeeChart.Styles.LinePoint コンストラクタ

public LinePoint(Chart c)

参照

LinePoint コンストラクタのオーバーロードの一覧 | LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinePoint イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

LinePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinePoint フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

LinePoint クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinePoint メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Pointsの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra (Pointsの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Pointsの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Pointsの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach (Pointsの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

LinePoint クラス | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.LinePoint.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.LinePoint.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.LinePoint.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.LinePoint プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen (Pointsの継承元) | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

LinePoint クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.LinePoint.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

LinePoint クラス | LinePoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map

Steema.TeeChart.Styles.Map クラス

マップ系列。

この型のすべてのメンバの一覧については、Map メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Map : Custom3DPalette , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Map メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map 全メンバ

Map 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddShape | マップ系列に新しいシェープを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear |
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | マップ系列で「クリックされた」ポイントのValueIndexを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue |
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue |
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。
LabelMember |
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃い/グレースケールを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shapes | Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | マップ系列の透明度を設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues |
YValues |
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeShapes |
ValueListOfAxis (Custom3Dの継承元) |

参照

Map クラス | Steema.TeeChart.Styles 名前空間


Map コンストラクタ

Steema.TeeChart.Styles.Map コンストラクタ

オーバーロードの一覧

public Map()
public Map(Steema.TeeChart.Chart)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Map コンストラクタ

Steema.TeeChart.Styles.Map コンストラクタ

public Map()

参照

Map コンストラクタのオーバーロードの一覧 | Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Map コンストラクタ

Steema.TeeChart.Styles.Map コンストラクタ

public Map(Chart c)

参照

Map コンストラクタのオーバーロードの一覧 | Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Map クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Map クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddShape | マップ系列に新しいシェープを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear |
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked | マップ系列で「クリックされた」ポイントのValueIndexを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue |
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue |
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeShapes |
ValueListOfAxis (Custom3Dの継承元) |

参照

Map クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.Map.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


AddShape

Steema.TeeChart.Styles.Map.AddShape メソッド

マップ系列に新しいシェープを追加します。

public Void AddShape(Int32[] X,
     Int32[] Y,
     String Text)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

Steema.TeeChart.Styles.Map.CalcHorizMargins メソッド

protected internal abstract Void CalcHorizMargins(Int32& leftMargin,
     Int32& rightMargin)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

Steema.TeeChart.Styles.Map.CalcVerticalMargins メソッド

protected internal abstract Void CalcVerticalMargins(Int32& topMargin,
     Int32& bottomMargin)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Clear

Steema.TeeChart.Styles.Map.Clear メソッド

public override Void Clear()

解説

すべてのマップソースを削除します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Map.Clicked メソッド

オーバーロードの一覧

マップ系列で「クリックされた」ポイントのValueIndexを返します。

public override Int32 Clicked(System.Int32, System.Int32)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Map.Clicked メソッド

マップ系列で「クリックされた」ポイントのValueIndexを返します。

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Map.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Map.Delete メソッド

オーバーロードの一覧

public override Void Delete(System.Int32)
public override Void Delete(System.Int32, System.Int32, System.Boolean)

解説

現在選択されているマップを削除します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Map.Delete メソッド

public override Void Delete(Int32 index)

参照

Delete オーバーロードの一覧 | Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Map.Delete メソッド

public override Void Delete(Int32 index,
     Int32 count,
     Boolean removeGap)

参照

Delete オーバーロードの一覧 | Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.Map.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Map.Draw メソッド

public override Void Draw()

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Map.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

Steema.TeeChart.Styles.Map.DrawValue メソッド

public override Void DrawValue(Int32 index)

解説

TeeChartにより内部的に呼び出されます。直接呼び出す必要はありません。
指定したValueIndexパラメーターの系列ポイントを描画します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Map.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Map.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.Map.MaxXValue メソッド

public override Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

Steema.TeeChart.Styles.Map.MaxYValue メソッド

public override Double MaxYValue()

解説

現在の全系列のYポイント値の最大値を返します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

Steema.TeeChart.Styles.Map.MinXValue メソッド

public override Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

Steema.TeeChart.Styles.Map.MinYValue メソッド

public override Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.Map.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Map.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Map.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeShapes

Steema.TeeChart.Styles.Map.ShouldSerializeShapes メソッド

protected abstract Boolean ShouldSerializeShapes()

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Map プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。
LabelMember |
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃い/グレースケールを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shapes | Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency | マップ系列の透明度を設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues |
YValues |
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Map クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Map.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Map.Item プロパティ

マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。

public Polygon Item(Int32 index) {get;}

解説

マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


LabelMember

Steema.TeeChart.Styles.Map.LabelMember プロパティ

public String LabelMember {get; set;}

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Shapes

Steema.TeeChart.Styles.Map.Shapes プロパティ

Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。

public PolygonList Shapes {get; set;}

解説

Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Transparency

Steema.TeeChart.Styles.Map.Transparency プロパティ

マップ系列の透明度を設定します。
public Int32 Transparency {get; set;}

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


XValues

Steema.TeeChart.Styles.Map.XValues プロパティ

public ValueList XValues {get;}

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


YValues

Steema.TeeChart.Styles.Map.YValues プロパティ

public ValueList YValues {get;}

参照

Map クラス | Map メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapAction

Steema.TeeChart.Styles.MapAction 列挙体

ホットスポットのマップのデフォルトのアクションタイプを定義します。

[Serializable]
public sealed enum MapAction : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Mark | MarksStylesに応じてマウスオーバーのマーカを表示します。
URL | URLに接続します。ポイントのURLは、ホットスポットのイベントで個別に設定できます。
Script | Javascript関数に基づいたページを実行します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapRegion

Steema.TeeChart.Styles.MapRegion クラス

この型のすべてのメンバの一覧については、MapRegion メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class MapRegion : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ：TeeChart.dll

参照

MapRegion メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapRegion 全メンバ

MapRegion 概要

コンストラクタ

Constructor オーバーロードされたコンストラクタ

パブリック メソッド

GetMap | チャートに定義されたマップを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
MapAction | マップ領域の主なアクションを設定します。このアクションは、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）を使用してオーバーライドできます。
PointPolygonList | MapRegionの現在の系列のPointPolygonListを返します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

GetPolygons | 内部使用。系列のPolygonListを取得します。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

MapRegion クラス | Steema.TeeChart.Styles 名前空間


MapRegion コンストラクタ

Steema.TeeChart.Styles.MapRegion コンストラクタ

オーバーロードの一覧

コンストラクタ。

public MapRegion(Steema.TeeChart.Styles.Series)

コンストラクタ。

public MapRegion(Steema.TeeChart.Tools.SeriesHotspot)

参照

MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


MapRegion コンストラクタ

Steema.TeeChart.Styles.MapRegion コンストラクタ

コンストラクタ。

public MapRegion(Series s)

パラメーター

s
MapRegionを作成する系列

参照

MapRegion コンストラクタ オーバーロードの一覧 | MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


MapRegion コンストラクタ

Steema.TeeChart.Styles.MapRegion コンストラクタ

コンストラクタ。

public MapRegion(SeriesHotspot h)

パラメーター

h
MapRegionを適用するHotspotツール

参照

MapRegion コンストラクタ オーバーロードの一覧 | MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapRegion フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

MapRegion クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapRegion メソッド

パブリック メソッド

GetMap | チャートに定義されたマップを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

GetPolygons | 内部使用。系列のPolygonListを取得します。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

MapRegion クラス | Steema.TeeChart.Styles 名前空間


GetMap

Steema.TeeChart.Styles.MapRegion.GetMap メソッド

チャートに定義されたマップを返します。
public String GetMap(MarksStyles style,
     Rectangle bounds)

パラメーター

style
デフォルトのマウスオーバーのヒントスタイル

戻り値

参照

MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


GetPolygons

Steema.TeeChart.Styles.MapRegion.GetPolygons メソッド

内部使用。系列のPolygonListを取得します。

protected internal PointPolygonList GetPolygons(Series s)

参照

MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MapRegion プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
MapAction | マップ領域の主なアクションを設定します。このアクションは、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）を使用してオーバーライドできます。
PointPolygonList | MapRegionの現在の系列のPointPolygonListを返します。

参照

MapRegion クラス | Steema.TeeChart.Styles 名前空間


MapAction

Steema.TeeChart.Styles.MapRegion.MapAction プロパティ

マップ領域の主なアクションを設定します。このアクションは、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）を使用してオーバーライドできます。

public MapAction MapAction {get; set;}

参照

MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


PointPolygonList

Steema.TeeChart.Styles.MapRegion.PointPolygonList プロパティ

MapRegionの現在の系列のPointPolygonListを返します。

public PointPolygonList PointPolygonList {get;}

参照

MapRegion クラス | MapRegion メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksCallout

Steema.TeeChart.Styles.MarksCallout クラス

この型のすべてのメンバの一覧については、MarksCallout メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
Steema.TeeChart.Styles.Callout
public class MarksCallout : Callout , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

MarksCallout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksCallout 全メンバ

MarksCallout 概要

コンストラクタ

Constructor

パブリック メソッド

Draw (SeriesPointerの継承元) | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Arrow (Calloutの継承元) |
ArrowHead (Calloutの継承元) |
ArrowHeadSize (Calloutの継承元) |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance (Calloutの継承元) |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
Length | データポイントとマーカの間の長さを取得/設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | Sets ポインタの水平サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Draw (Calloutの継承元)
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

MarksCallout クラス | Steema.TeeChart.Styles 名前空間


MarksCallout コンストラクタ

Steema.TeeChart.Styles.MarksCallout コンストラクタ

public MarksCallout(Series s)

参照

MarksCallout クラス | MarksCallout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksCallout フィールド

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

MarksCallout クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksCallout メソッド

パブリック メソッド

Draw (SeriesPointerの継承元) | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

Draw (Calloutの継承元)
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (SeriesPointerの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

MarksCallout クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksCallout プロパティ

パブリック プロパティ

Arrow (Calloutの継承元) |
ArrowHead (Calloutの継承元) |
ArrowHeadSize (Calloutの継承元) |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance (Calloutの継承元) |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを定義します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
Length | データポイントとマーカの間の長さを取得/設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの垂直サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。

参照

MarksCallout クラス | Steema.TeeChart.Styles 名前空間


Length

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MarksCallout.Length プロパティ

データポイントとマーカの間の長さを取得/設定します。

public Int32 Length {get; set;}

参照

MarksCallout クラス | MarksCallout メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItem

Steema.TeeChart.Styles.MarksItem クラス

この型のすべてのメンバの一覧については、MarksItem メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class MarksItem : TextShape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

MarksItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItem 全メンバ

MarksItem 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

ChartMarkColor
Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

MarksItem クラス | Steema.TeeChart.Styles 名前空間


MarksItem コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MarksItem コンストラクタ

オーバーロードの一覧

public MarksItem()
public MarksItem(Steema.TeeChart.Chart)

参照

MarksItem クラス | MarksItem メンバ | Steema.TeeChart.Styles 名前空間


MarksItem コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MarksItem コンストラクタ

public MarksItem()

参照

MarksItem コンストラクタのオーバーロードの一覧 | MarksItem クラス | MarksItem メンバ | Steema.TeeChart.Styles 名前空間


MarksItem コンストラクタ

Steema.TeeChart.Styles.MarksItem コンストラクタ

public MarksItem(Chart c)

参照

MarksItem コンストラクタのオーバーロードの一覧 | MarksItem クラス | MarksItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItem フィールド

パブリック フィールド

ChartMarkColor
Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

MarksItem クラス | Steema.TeeChart.Styles 名前空間


ChartMarkColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MarksItem.ChartMarkColor フィールド

public Color ChartMarkColor

参照

MarksItem クラス | MarksItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItem メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapeの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

MarksItem クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItem プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

MarksItem クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItems

Steema.TeeChart.Styles.MarksItems クラス

この型のすべてのメンバの一覧については、MarksItems メンバを参照してください。

System.Object
System.Collections.Generic.List<MarksItem>
public class MarksItems : List<MarksItem>
, IList<MarksItem>
, ICollection<MarksItem>
, IEnumerable<MarksItem>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

MarksItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItems 全メンバ

MarksItems 概要

コンストラクタ

Constructor

パブリック メソッド

Clear

パブリック プロパティ

Item

参照

MarksItems クラス | Steema.TeeChart.Styles 名前空間


MarksItems コンストラクタ

Steema.TeeChart.Styles.MarksItems コンストラクタ

public MarksItems(SeriesMarks s)

参照

MarksItems クラス | MarksItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItems メソッド

パブリック メソッド

Clear

参照

MarksItems クラス | Steema.TeeChart.Styles 名前空間


Clear

Steema.TeeChart.Styles.MarksItems.Clear メソッド

public Void Clear()

参照

MarksItems クラス | MarksItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksItems プロパティ

パブリック プロパティ

Item

参照

MarksItems クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.MarksItems.Item プロパティ

public MarksItem Item(Int32 index) {get;}

解説

Index番目のマーカの書式オブジェクトを返します。

参照

MarksItems クラス | MarksItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MarksStyles

Steema.TeeChart.Styles.MarksStyles 列挙体

Styleプロパティの使用可能な値です。
[Serializable]
public sealed enum MarksStyles : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Value | ポイント値を表示します。
Percent | ポイント値を百分率で表示します。
Label | 関連するポイントラベルを表示します。
LabelPercent | ポイントラベルと百分率値を表示します。
LabelValue | ポイントラベルとポイント値を表示します。
Legend | チャートの凡例に表示されるものすべてを表示します。
PercentTotal | ポイントを示す割合を「of」という文字と、全ポイントの絶対値の合計を一緒に表示します。
LabelPercentTotal | ポイントラベルと「PercentTotal」スタイルを一緒に表示します。
XValue | ポイントのX値を表示します。
XY | ポイントのX値とY値を表示します。
SeriesTitle | ポイントの系列タイトルを表示します。
PointIndex | ポイントインデックスを表示します。
PercentRelative | 最初のポイント値と比較したポイントパーセントを表示します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MultiAreas

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MultiAreas 列挙体

MultiAreaプロパティの使用可能な値です。

[Serializable]
public enum MultiAreas : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 面は他の面の後ろに描画されます。
Stacked | 各面を積み重ねて描画します。
Stacked100 | 個々のポイントを共通の0～100軸スケールに調整します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MultiBars

TeeChartプログラミングガイド

Steema.TeeChart.Styles.MultiBars 列挙体

MultiBarプロパティの使用可能な値です。

[Serializable]
public enum MultiBars : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 他のバー系列の後ろに描画されます。
Side | 各ポイントは他のバー系列の各ポイントの隣に描画します。
Stacked | インデックスが同じポイントを積み重ねて描画します。
Stacked100 | 共通の0～100の軸スケールで積み重ねて描画されます。
SideAll | 系列毎に並列で描画します。
SelfStack | 各バー系列毎に全ポイントを1つに積み重ねて表示します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.MultiPies

Steema.TeeChart.Styles.MultiPies 列挙体

PieクラスのMultiPieプロパティの使用可能な値です。
[Serializable]
public sealed enum MultiPies : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Automatic | 複数の円系列は、自動的に計算されたチャートスペースを使用して描画されます（デフォルト）。
Disabled | 複数の円系列は、カスタムなChartRect位置あるいはオーバーラップを使用して描画されます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge

Steema.TeeChart.Styles.NumericGauge クラス

数値ゲージ系列。

この型のすべてのメンバの一覧については、NumericGauge メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
public class NumericGauge : CustomGauge , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge 全メンバ

NumericGauge 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
LCDPalette |
LEDPalette |
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomGaugeの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DigitalFontType | デジタルのフォントスタイルを取得/設定します。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Markers | テキストあるいは数字を表示する数値ゲージのマーカコレクションです。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TextMarker | 数値ゲージの「テキスト（例：FREQ）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UnitsMarker | 数値ゲージの「単位（例：MHz）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValueMarker | 数値ゲージの「値」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomGaugeの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis (CustomGaugeの継承元) |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines (CustomGaugeの継承元) |
DrawFace |
DrawFrame (CustomGaugeの継承元) |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue (CustomGaugeの継承元) |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

NumericGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge コンストラクタ

オーバーロードの一覧

public NumericGauge()
public NumericGauge(Steema.TeeChart.Chart)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge コンストラクタ

public NumericGauge()

参照

NumericGauge コンストラクタのオーバーロードの一覧 | NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge コンストラクタ

public NumericGauge(Chart c)

参照

NumericGauge コンストラクタのオーバーロードの一覧 | NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

参照

NumericGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
LCDPalette |
LEDPalette |
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

NumericGauge クラス | Steema.TeeChart.Styles 名前空間


LCDPalette

Steema.TeeChart.Styles.NumericGauge.LCDPalette フィールド

public Color[] LCDPalette

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


LEDPalette

Steema.TeeChart.Styles.NumericGauge.LEDPalette フィールド

public Color[] LEDPalette

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomGaugeの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis (CustomGaugeの継承元) |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines (CustomGaugeの継承元) |
DrawFace |
DrawFrame (CustomGaugeの継承元) |
DrawHand |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue (CustomGaugeの継承元) |
SetValueList (Seriesの継承元) |
SetValues |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

NumericGauge クラス | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.NumericGauge.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.NumericGauge.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawFace

Steema.TeeChart.Styles.NumericGauge.DrawFace メソッド

protected abstract Void DrawFace(Graphics3D g)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


DrawHand

Steema.TeeChart.Styles.NumericGauge.DrawHand メソッド

protected abstract Void DrawHand(Graphics3D g)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


GetAxis

Steema.TeeChart.Styles.NumericGauge.GetAxis メソッド

protected abstract Axis GetAxis()

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.NumericGauge.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.NumericGauge.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.NumericGauge.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


SetValues

Steema.TeeChart.Styles.NumericGauge.SetValues メソッド

protected abstract Void SetValues()

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.NumericGauge プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DigitalFontType | デジタルのフォントスタイルを取得/設定します。
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Markers | テキストあるいは数字を表示する数値ゲージのマーカコレクションです。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TextMarker | 数値ゲージの「テキスト（例：FREQ）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UnitsMarker | 数値ゲージの「単位（例：MHz）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValueMarker | 数値ゲージの「値」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

NumericGauge クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.NumericGauge.Description プロパティ

public override String Description {get;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


DigitalFontType

Steema.TeeChart.Styles.NumericGauge.DigitalFontType プロパティ

デジタルのフォントスタイルを取得/設定します。
public DigitalFont DigitalFontType {get; set;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Markers

Steema.TeeChart.Styles.NumericGauge.Markers プロパティ

テキストあるいは数字を表示する数値ゲージのマーカコレクションです。
public MarkersCollection Markers {get; set;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


TextMarker

Steema.TeeChart.Styles.NumericGauge.TextMarker プロパティ

数値ゲージの「テキスト（例：FREQ）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
public Marker TextMarker {get; set;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


UnitsMarker

Steema.TeeChart.Styles.NumericGauge.UnitsMarker プロパティ

数値ゲージの「単位（例：MHz）」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
public Marker UnitsMarker {get; set;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


ValueMarker

Steema.TeeChart.Styles.NumericGauge.ValueMarker プロパティ

数値ゲージの「値」を定義するMarkerオブジェクトを取得/設定します。これは、シェープのフォント、ブラシ、ペンの特性にアクセスできます。
public Marker ValueMarker {get; set;}

参照

NumericGauge クラス | NumericGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC

Steema.TeeChart.Styles.OHLC クラス

OHLCは、始値、終値、高値、安値のリストを保持する基本系列クラスです。

この型のすべてのメンバの一覧については、OHLC メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class OHLC : Custom , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OHLC メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC 全メンバ

OHLC 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues
vLowValues
vOpenValues
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

OHLC クラス | Steema.TeeChart.Styles 名前空間


OHLC コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC コンストラクタ

オーバーロードの一覧

public OHLC(Steema.TeeChart.Chart)
public OHLC()

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


OHLC コンストラクタ

Steema.TeeChart.Styles.OHLC コンストラクタ

public OHLC(Chart c)

参照

OHLC コンストラクタのオーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


OHLC コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC コンストラクタ

public OHLC()

参照

OHLC コンストラクタのオーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

OHLC クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues
vLowValues
vOpenValues
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

OHLC クラス | Steema.TeeChart.Styles 名前空間


vHighValues

Steema.TeeChart.Styles.OHLC.vHighValues フィールド

protected ValueList vHighValues

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


vLowValues

Steema.TeeChart.Styles.OHLC.vLowValues フィールド

protected ValueList vLowValues

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


vOpenValues

Steema.TeeChart.Styles.OHLC.vOpenValues フィールド

protected ValueList vOpenValues

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC メソッド

パブリック メソッド

Add | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

OHLC クラス | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

オーバーロードの一覧

指定したインデックスと始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(System.Int32, System.Double, System.Double, System.Double, System.Double)

指定したインデックスと始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double)

指定した始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double)

指定した日付時間と始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(System.DateTime, System.Double, System.Double, System.Double, System.Double)

OHLC系列にDataViewを追加します。

public override Void Add(System.Data.DataView)

解説

系列に新しい株価ポイントを追加します。新しく追加したポイントに該当するポイントインデックスを返します。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

指定したインデックスと始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(Int32 index,
     Double open,
     Double high,
     Double low,
     Double close)

戻り値

追加したポイントのValueListインデックス。

参照

Add オーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

指定したインデックスと始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(Double index,
     Double open,
     Double high,
     Double low,
     Double close)

戻り値

追加したポイントのValueListインデックス。

参照

Add オーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

指定した始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(Double open,
     Double high,
     Double low,
     Double close)

戻り値

追加したポイントのValueListインデックス。

参照

Add オーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

指定した日付時間と始値、高値、安値、終値を持つ新しいポイントを追加します。

public Int32 Add(DateTime aDate,
     Double open,
     Double high,
     Double low,
     Double close)

戻り値

追加したポイントのValueListインデックス。

参照

Add オーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.Add メソッド

OHLC系列にDataViewを追加します。
public virtual Void Add(DataView view)

参照

Add オーバーロードの一覧 | OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.OHLC.IsValidSourceOf メソッド

系列のデータソースを有効にします。
public override Boolean IsValidSourceOf(Series value)

パラメーター

value
有効にする系列。

戻り値

値が系列のデータソースの場合、trueを返します。

解説

ValueパラメーターがSelfパラメーターと同じ場合、falseを返します。
これは、デザイン時や実行時にDataSourceプロパティを有効にするために使用されます。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.OHLC.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OHLC プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

OHLC クラス | Steema.TeeChart.Styles 名前空間


CloseValues

Steema.TeeChart.Styles.OHLC.CloseValues プロパティ

すべての株価の終値を取得/設定します。
public ValueList CloseValues {get; set;}

解説

このプロパティは、すべての株価の終値を保持するために使用されます。

X値あるいはY値にアクセスする方法と同様に終値にアクセスできます。

例

[C#]

// これは3番目のキャンドルの終値を増加させます。
((Steema.TeeChart.Styles.Candle)tChart1[1]).CloseValues[2] =((Steema.TeeChart.Styles.Candle)tChart1[1]).CloseValues[2]+1;

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


DateValues

Steema.TeeChart.Styles.OHLC.DateValues プロパティ

すべての株価の日付値を取得/設定します。
public ValueList DateValues {get; set;}

解説

このプロパティは、すべての株価の日付値を保持するために使用されます。

X値あるいはY値にアクセスする方法と同様に日付値にアクセスできます。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


HighValues

Steema.TeeChart.Styles.OHLC.HighValues プロパティ

すべての株価の高値を取得/設定します。
public ValueList HighValues {get; set;}

解説

このプロパティは、すべての株価の高値を保持するために使用されます。X値あるいはY値にアクセスする方法と同様に高値にアクセスできます。

例

[C#]

// これは3番目のキャンドルの高値を増減させます。
((Steema.TeeChart.Styles.Candle)tChart1[1]).HighValues[2] =((Steema.TeeChart.Styles.Candle)tChart1[1]).HighValues[2]+1;

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.OHLC.Item プロパティ

ポイント特性。
public SeriesOHLCPoint Item(Int32 index) {get;}

解説

ポイント特性。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


LowValues

Steema.TeeChart.Styles.OHLC.LowValues プロパティ

すべての株価の安値を取得/設定します。
public ValueList LowValues {get; set;}

解説

すべての株価の安値を保持するために使用されます。X値あるいはY値にアクセスする方法と同様に安値にアクセスできます。

例

[C#]

//このコードは安値を終値と同じ値にします。

for (int i=0;i<((Steema.TeeChart.Styles.Candle)tChart1[0]).Count;i++)
     ((Steema.TeeChart.Styles.Candle)tChart1[0]).LowValues[i] =
        ((Steema.TeeChart.Styles.Candle)tChart1[0]).CloseValues[i];

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


OpenValues

Steema.TeeChart.Styles.OHLC.OpenValues プロパティ

すべての株価の始値を取得/設定します。
public ValueList OpenValues {get; set;}

解説

すべての株価の始値を保持するために使用されます。
X値あるいはY値にアクセスする方法と同様に始値にアクセスできます。

参照

OHLC クラス | OHLC メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItem

Steema.TeeChart.Styles.OrgItem クラス

この型のすべてのメンバの一覧については、OrgItem メンバを参照してください。

System.Object
public class OrgItem : Object

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItem 全メンバ

OrgItem 概要

コンストラクタ

Constructor

パブリック メソッド

AddBrother
AddChild

パブリック プロパティ

Format
Index
Series
Superior
Text

参照

OrgItem クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItem コンストラクタ

public OrgItem(OrgItems Collection)

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItem メソッド

パブリック メソッド

AddBrother
AddChild

参照

OrgItem クラス | Steema.TeeChart.Styles 名前空間


AddBrother

Steema.TeeChart.Styles.OrgItem.AddBrother メソッド

public OrgItem AddBrother(String Text)

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


AddChild

Steema.TeeChart.Styles.OrgItem.AddChild メソッド

public OrgItem AddChild(String Text)

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItem プロパティ

パブリック プロパティ

Format
Index
Series
Superior
Text

参照

OrgItem クラス | Steema.TeeChart.Styles 名前空間


Format

Steema.TeeChart.Styles.OrgItem.Format プロパティ

public OrgShape Format {get; set;}

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Index

Steema.TeeChart.Styles.OrgItem.Index プロパティ

public Int32 Index {get; set;}

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.OrgItem.Series プロパティ

public OrgSeries Series {get;}

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Superior

Steema.TeeChart.Styles.OrgItem.Superior プロパティ

public Int32 Superior {get; set;}

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Text

Steema.TeeChart.Styles.OrgItem.Text プロパティ

public String Text {get; set;}

参照

OrgItem クラス | OrgItem メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItemList

Steema.TeeChart.Styles.OrgItemList クラス

OrgItemのリスト。

この型のすべてのメンバの一覧については、OrgItemList メンバを参照してください。

System.Object
System.Collections.Generic.List<OrgItem>
[Serializable]
public class OrgItemList : List<OrgItem>
, IList<OrgItem>
, ICollection<OrgItem>
, IEnumerable<OrgItem>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgItemList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItemList 全メンバ

OrgItemList 概要

コンストラクタ

Constructor

参照

OrgItemList クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItemList コンストラクタ

public OrgItemList()

参照

OrgItemList クラス | OrgItemList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItemList プロパティ

パブリック プロパティ

Item

参照

OrgItemList クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.OrgItemList.Item プロパティ

public OrgItem Item(Int32 index) {get;}

参照

OrgItemList クラス | OrgItemList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItems

Steema.TeeChart.Styles.OrgItems クラス

この型のすべてのメンバの一覧については、OrgItems メンバを参照してください。

System.Object
System.Collections.CollectionBase
public class OrgItems : CollectionBase , IList, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItems 全メンバ

OrgItems 概要

コンストラクタ

Constructor

パブリック メソッド

Add
AddRange
Assign
IndexOf
LevelOf

パブリック プロパティ

Item

参照

OrgItems クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItems コンストラクタ

public OrgItems(OrgSeries Series)

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItems メソッド

パブリック メソッド

Add
AddRange
Assign
IndexOf
LevelOf

参照

OrgItems クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgItems.Add メソッド

オーバーロードの一覧

public Int32 Add(Steema.TeeChart.Styles.OrgItem)
public OrgItem Add()

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgItems.Add メソッド

public Int32 Add(OrgItem i)

参照

Add オーバーロードの一覧 | OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgItems.Add メソッド

public OrgItem Add()

参照

Add オーバーロードの一覧 | OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


AddRange

Steema.TeeChart.Styles.OrgItems.AddRange メソッド

public Void AddRange(ICollection c)

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Assign

Steema.TeeChart.Styles.OrgItems.Assign メソッド

public Void Assign(OrgItems value)

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


IndexOf

Steema.TeeChart.Styles.OrgItems.IndexOf メソッド

public Int32 IndexOf(OrgItem l)

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


LevelOf

Steema.TeeChart.Styles.OrgItems.LevelOf メソッド

public Int32 LevelOf(OrgItem i)

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgItems プロパティ

パブリック プロパティ

Item

参照

OrgItems クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.OrgItems.Item プロパティ

public OrgItem Item(Int32 index) {get; set;}

参照

OrgItems クラス | OrgItems メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgLineStyle

Steema.TeeChart.Styles.OrgLineStyle 列挙体

組織図チャートのアイテム間の接続線スタイルを定義します。
[Serializable]
public sealed enum OrgLineStyle : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
lsSquared | 垂直線と水平線として接続線を描画します。
lsDiagonal | 右下がり斜線として接続線を描画します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries

Steema.TeeChart.Styles.OrgSeries クラス

組織図チャート。

この型のすべてのメンバの一覧については、OrgSeries メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class OrgSeries : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries 全メンバ

OrgSeries 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add |
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstChild |
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Bounds | 境界矩形。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Format | 組織図チャートのアイテムのデフォルトフォーマットを取得/設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | 組織図チャートのアイテムです。
Items | 組織図チャートのアイテムです。
ItemSpacing | 組織図チャートアイテム間の垂直および水平のスペースを取得/設定します。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineStyle | 接続線の描画スタイルを取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

OrgSeries クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries コンストラクタ

オーバーロードの一覧

public OrgSeries()
public OrgSeries(Steema.TeeChart.Chart)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries コンストラクタ

public OrgSeries()

参照

OrgSeries コンストラクタのオーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries コンストラクタ

public OrgSeries(Chart c)

参照

OrgSeries コンストラクタのオーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

OrgSeries クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

OrgSeries クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries メソッド

パブリック メソッド

Add |
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstChild |
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

OrgSeries クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgSeries.Add メソッド

オーバーロードの一覧

public Int32 Add(System.String, System.Int32)
public Int32 Add(System.String)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgSeries.Add メソッド

public Int32 Add(String aText,
     Int32 aSuperior)

参照

Add オーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.OrgSeries.Add メソッド

public Int32 Add(String aText)

参照

Add オーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.OrgSeries.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.OrgSeries.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

Steema.TeeChart.Styles.OrgSeries.CalcXPos メソッド

public override Int32 CalcXPos(Int32 index)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

Steema.TeeChart.Styles.OrgSeries.CalcYPos メソッド

public override Int32 CalcYPos(Int32 index)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


ClearLists

Steema.TeeChart.Styles.OrgSeries.ClearLists メソッド

protected abstract Void ClearLists()

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.OrgSeries.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.OrgSeries.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.OrgSeries.Delete メソッド

オーバーロードの一覧

public override Void Delete(System.Int32)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.OrgSeries.Delete メソッド

public override Void Delete(Int32 index)

参照

Delete オーバーロードの一覧 | OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.OrgSeries.Draw メソッド

public override Void Draw()

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


FirstChild

Steema.TeeChart.Styles.OrgSeries.FirstChild メソッド

public Int32 FirstChild(Int32 valueindex)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.OrgSeries.IsValidSourceOf メソッド

public override Boolean IsValidSourceOf(Series value)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.OrgSeries.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Bounds | 境界矩形。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Format | 組織図チャートのアイテムのデフォルトフォーマットを取得/設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item | 組織図チャートのアイテムです。
Items | 組織図チャートのアイテムです。
ItemSpacing | 組織図チャートアイテム間の垂直および水平のスペースを取得/設定します。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineStyle | 接続線の描画スタイルを取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

OrgSeries クラス | Steema.TeeChart.Styles 名前空間


Bounds

Steema.TeeChart.Styles.OrgSeries.Bounds プロパティ

境界矩形。
public Rectangle Bounds {get;}

解説

すべての項目を囲む最小矩形。

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.OrgSeries.Description プロパティ

public override String Description {get;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Format

Steema.TeeChart.Styles.OrgSeries.Format プロパティ

組織図チャートのアイテムのデフォルトフォーマットを取得/設定します。
public OrgShape Format {get; set;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.OrgSeries.Item プロパティ

組織図チャートのアイテムです。
public OrgItem Item(Int32 index) {get; set;}

パラメーター

index
Itemsコレクション内のアイテムのインデックス。

戻り値

組織図チャートのアイテム。

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Items

Steema.TeeChart.Styles.OrgSeries.Items プロパティ

組織図チャートのアイテムです。
public OrgItems Items {get; set;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


ItemSpacing

Steema.TeeChart.Styles.OrgSeries.ItemSpacing プロパティ

組織図チャートアイテム間の垂直および水平のスペースを取得/設定します。
public Spacing ItemSpacing {get; set;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


LineStyle

Steema.TeeChart.Styles.OrgSeries.LineStyle プロパティ

接続線の描画スタイルを取得/設定します。
public OrgLineStyle LineStyle {get; set;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.OrgSeries.Pen プロパティ

public ChartPen Pen {get;}

参照

OrgSeries クラス | OrgSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries.OrgDraw

Steema.TeeChart.Styles.OrgSeries.OrgDraw クラス

全項目の描画がこのクラス内で行われます。

この型のすべてのメンバの一覧については、OrgDraw メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class OrgDraw : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgDraw メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.OrgSeries.OrgDraw 全メンバ

OrgDraw 概要

コンストラクタ

Steema.TeeChart.Styles.OrgSeries.OrgDraw..ctor

パブリック メソッド

Draw |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Bounds |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

OrgDraw クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries+OrgDraw コンストラクタ

public OrgSeries+OrgDraw(OrgSeries s)

参照

OrgDraw クラス | OrgDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries.OrgDraw フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

OrgDraw クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries.OrgDraw メソッド

パブリック メソッド

Draw |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

OrgDraw クラス | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.OrgSeries+OrgDraw.Draw メソッド

public Void Draw()

参照

OrgDraw クラス | OrgDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgSeries.OrgDraw プロパティ

パブリック プロパティ

Bounds |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。

参照

OrgDraw クラス | Steema.TeeChart.Styles 名前空間


Bounds

Steema.TeeChart.Styles.OrgSeries+OrgDraw.Bounds プロパティ

public Rectangle Bounds {get;}

参照

OrgDraw クラス | OrgDraw メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape

Steema.TeeChart.Styles.OrgShape クラス

組織図チャートアイテムの基礎シェープクラスです。

この型のすべてのメンバの一覧については、OrgShape メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
Steema.TeeChart.Drawing.TextShapePosition
public class OrgShape : TextShapePosition , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

OrgShape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape 全メンバ

OrgShape 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Size (TextShapeの継承元)

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

OrgShape クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape コンストラクタ

オーバーロードの一覧

public OrgShape()
public OrgShape(Steema.TeeChart.Chart)

参照

OrgShape クラス | OrgShape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape コンストラクタ

public OrgShape()

参照

OrgShape コンストラクタのオーバーロードの一覧 | OrgShape クラス | OrgShape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape コンストラクタ

public OrgShape(Chart c)

参照

OrgShape コンストラクタのオーバーロードの一覧 | OrgShape クラス | OrgShape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape フィールド

パブリック フィールド

Size (TextShapeの継承元)

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bCustomPosition (TextShapePositionの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

OrgShape クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。

プロテクト メソッド

AssignShape (TextShapePositionの継承元)
CalcBounds (TextShapeの継承元)
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (TextShapePositionの継承元)
ShouldSerializeLeft
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (TextShapePositionの継承元)
ShouldSerializeTop
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

OrgShape クラス | Steema.TeeChart.Styles 名前空間


ShouldSerializeLeft

Steema.TeeChart.Styles.OrgShape.ShouldSerializeLeft メソッド

protected abstract Boolean ShouldSerializeLeft()

参照

OrgShape クラス | OrgShape メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeTop

Steema.TeeChart.Styles.OrgShape.ShouldSerializeTop メソッド

protected abstract Boolean ShouldSerializeTop()

参照

OrgShape クラス | OrgShape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.OrgShape プロパティ

パブリック プロパティ

AutoSize (TextShapeの継承元) |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
CustomPosition (TextShapePositionの継承元) | このプロパティをtrueに設定すると、TextShapeのカスタム位置が有効になります。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines (TextShapeの継承元) | テキスト行の配列にアクセスします。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

OrgShape クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PaletteList

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PaletteList クラス

GridPaletteオブジェクトのコレクション。

この型のすべてのメンバの一覧については、PaletteList メンバを参照してください。

System.Object
System.Collections.ArrayList
public class PaletteList : ArrayList , IList, ICollection, IEnumerable
, ICloneable

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

PaletteList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PaletteList 全メンバ

PaletteList 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

PaletteList クラス | Steema.TeeChart.Styles 名前空間


PaletteList コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PaletteList コンストラクタ

public PaletteList()

参照

PaletteList クラス | PaletteList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PaletteList プロパティ

パブリック プロパティ

Item

参照

PaletteList クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.PaletteList.Item プロパティ

public GridPalette Item(Int32 index) {get; set;}

参照

PaletteList クラス | PaletteList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PaletteStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PaletteStyles 列挙体

PaletteStyleプロパティの使用可能な値です。

[Serializable]
public enum PaletteStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Pale | 薄いパレットにします。
Strong | 濃いパレットにします。
GrayScale | グレースケールパレットにします。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie

Steema.TeeChart.Styles.Pie クラス

円系列。

この型のすべてのメンバの一覧については、Pie メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Pie : Circular , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Pie メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie 全メンバ

Pie 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

Angles |
bBrush (Seriesの継承元) |
BelongsToOther |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
BelongsToOtherSlice | 指定したインデックスのスライスがOthersliceプロパティに該当する場合、trueを返します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleSize | 全スライスの合計角度を度数単位（0～360）で設定します。
AutoMarkPosition | trueの場合、各マーカはオーバーラップしないように表示されます。
Brush | 円系列を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
Dark3D | 3D効果を与えるために円の側面に影をつけます。
DarkPen |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExplodeBiggest | 指定した値で円系列の中心から最も大きな値のスライスを分割します。
ExplodedSlice | パイスライスを分割するためのプロパティにアクセスします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MarksPie |
MiddleZ (Seriesの継承元) | 内部使用。
MultiPie | 複数の円系列が存在する場合、自動的に円を配置するように設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OtherSlice | パイスライスのグループ化を設定します。
Pen | パイのペン特性を設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PieValues | パイスライス値を保持します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow | 円系列のオフセットの影を定義します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SliceHeight | 各パイスライスを異なる高さに設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UsePatterns | 異なるブラシパターンスタイルでパイスライスを塗りつぶします。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
iDonutPercent
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcExplodedRadius |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists |
CountLegendItems |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries |
DrawPie |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDonutPercent |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Pie クラス | Steema.TeeChart.Styles 名前空間


Pie コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie コンストラクタ

オーバーロードの一覧

public Pie()
public Pie(Steema.TeeChart.Chart)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Pie コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie コンストラクタ

public Pie()

参照

Pie コンストラクタのオーバーロードの一覧 | Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Pie コンストラクタ

Steema.TeeChart.Styles.Pie コンストラクタ

public Pie(Chart c)

参照

Pie コンストラクタのオーバーロードの一覧 | Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Pie クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie フィールド

パブリック フィールド

Angles |
bBrush (Seriesの継承元) |
BelongsToOther |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
iDonutPercent
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Pie クラス | Steema.TeeChart.Styles 名前空間


Angles

Steema.TeeChart.Styles.Pie.Angles フィールド

public PieAngle[] Angles

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


BelongsToOther

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.BelongsToOther フィールド

public Int32 BelongsToOther

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


iDonutPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.iDonutPercent フィールド

protected Int32 iDonutPercent

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
BelongsToOtherSlice | 指定したインデックスのスライスがOthersliceプロパティに該当する場合、trueを返します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcExplodedRadius |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists |
CountLegendItems |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries |
DrawPie |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDonutPercent |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Pie クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


BelongsToOtherSlice

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.BelongsToOtherSlice メソッド

指定したインデックスのスライスがOthersliceプロパティに該当する場合、trueを返します。

public Boolean BelongsToOtherSlice(Int32 valueIndex)

解説

ValueIndexのパイスライス値が｢その他｣スライスのグループ内にある場合、trueを返します。

｢その他｣スライスはOtherSliceプロパティで制御され、複数の小さいスライスを１つのスライスにまとめるために使用されます。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


CalcExplodedRadius

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.CalcExplodedRadius メソッド

protected Void CalcExplodedRadius(Int32 valueIndex,
     Int32& aXRadius,
     Int32& aYRadius)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.CalcXPos メソッド

ValueIndexの系列値の水平画面座標値をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

ValueIndexの系列値の水平画面座標値をピクセル単位で返します。
この座標値は水平軸に対応する系列を使用して計算されます。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


ClearLists

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.ClearLists メソッド

protected virtual Void ClearLists()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.Clicked メソッド

オーバーロードの一覧

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

XYパラメーターのピクセル座標を含むポイントインデックスを返します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.Clicked メソッド

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Pie.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DoAfterDrawValues

Steema.TeeChart.Styles.Pie.DoAfterDrawValues メソッド

protected internal abstract Void DoAfterDrawValues()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.Pie.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Pie.Draw メソッド

public override Void Draw()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Pie.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Pie.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawMarksSeries

Steema.TeeChart.Styles.Pie.DrawMarksSeries メソッド

protected abstract Void DrawMarksSeries(Series s,
     Boolean& ActiveRegion)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawPie

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.DrawPie メソッド

protected internal Void DrawPie(Int32 valueIndex)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawPie

Steema.TeeChart.Styles.Pie.DrawPie メソッド

protected internal Void DrawPie(Graphics3D g,
     Int32 valueIndex)

参照

DrawPie オーバーロードの一覧 | Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawPie

Steema.TeeChart.Styles.Pie.DrawPie メソッド

protected internal Void DrawPie(Int32 valueIndex)

参照

DrawPie オーバーロードの一覧 | Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Pie.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean is3D)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Pie.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


LegendToValueIndex

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.LegendToValueIndex メソッド

protected internal virtual Int32 LegendToValueIndex(Int32 legendIndex)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Pie.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.Pie.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Pie.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


SetDonutPercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.SetDonutPercent メソッド

protected Void SetDonutPercent(Int32 value)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Pie.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleSize | 全スライスの合計角度を度数単位（0～360）で設定します。
AutoMarkPosition | trueの場合、各マーカはオーバーラップしないように表示されます。
Brush | 円系列を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
Dark3D | 3D効果を与えるために円の側面に影をつけます。
DarkPen |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
ExplodeBiggest | 指定した値で円系列の中心から最も大きな値のスライスを分割します。
ExplodedSlice | パイスライスを分割するためのプロパティにアクセスします。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MarksPie |
MiddleZ (Seriesの継承元) | 内部使用。
MultiPie | 複数の円系列が存在する場合、自動的に円を配置するように設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
OtherSlice | パイスライスのグループ化を設定します。
Pen | パイのペン特性を設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PieValues | パイスライス値を保持します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow | 円系列のオフセットの影を定義します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SliceHeight | 各パイスライスを異なる高さに設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UsePatterns | 異なるブラシパターンスタイルでパイスライスを塗りつぶします。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Pie クラス | Steema.TeeChart.Styles 名前空間


AngleSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.AngleSize プロパティ

全スライスの合計角度を度数単位（0～360）で設定します。

public Int32 AngleSize {get; set;}

解説

表示されたパイスライスの内部的な角度を設定します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


AutoMarkPosition

Steema.TeeChart.Styles.Pie.AutoMarkPosition プロパティ

trueの場合、各マーカはオーバーラップしないように表示されます。
public Boolean AutoMarkPosition {get; set;}

解説

trueの場合、円系列は、各マーカが他のマーカにオーバーラップしないように表示します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


BevelPercent

Steema.TeeChart.Styles.Pie.BevelPercent プロパティ

円の深さの割合としてベベルを取得/設定します。
public Int32 BevelPercent {get; set;}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Pie.Brush プロパティ

円系列を塗りつぶすブラシを設定します。
public ChartBrush Brush {get;}

解説

円系列を塗りつぶすブラシを設定します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


ColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.ColorEach プロパティ

異なる色でポイントを描画します。

public Boolean ColorEach {get; set;}

解説

異なる色でポイントを描画します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Dark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.Dark3D プロパティ

3D効果を与えるために円の側面に影をつけます。

public Boolean Dark3D {get; set;}

解説

デフォルト値：true

trueの場合、円の3D効果の画面領域にパイスライスの色よりも暗い色で塗りつぶします。この色は、16000色もしくはそれ以上のカラービデオモードではより鮮明に見えます。

パイスライスのRGBカラーは、より暗い色を出すために40段階の階調が用意されます。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


DarkPen

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.DarkPen プロパティ

public Boolean DarkPen {get; set;}

解説

falseの場合、円の枠をグレーに設定します。
trueの場合、枠は選択した色を使用して描かれます。

例

[C#]

private void Form1_Load(object sender, System.EventArgs e)
{
     checkBox1.Checked =false;
     checkBox1.CheckState = System.Windows.Forms.CheckState.Checked;
     checkBox1.FlatStyle = System.Windows.Forms.FlatStyle.Flat;
     checkBox1.Name = "checkBox1";
     checkBox1.Size = new System.Drawing.Size(70, 24);
     checkBox1.TabIndex = 0;
     checkBox1.Text = "DarkPen";
     checkBox1.CheckedChanged += new System.EventHandler(this.checkBox1_CheckedChanged);

}

private void checkBox1_CheckedChanged(object sender, System.EventArgs e)
{
     pie1.DarkPen =! checkBox1.Checked;
}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Pie.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


EdgeStyle

Steema.TeeChart.Styles.Pie.EdgeStyle プロパティ

ベベルのエッジスタイルを取得/設定します。
public EdgeStyles EdgeStyle {get; set;}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


ExplodeBiggest

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.ExplodeBiggest プロパティ

指定した値で円系列の中心から最も大きな値のスライスを分割します。

public Int32 ExplodeBiggest {get; set;}

解説

指定した値で、円系列の中心から最も大きな値のスライスを分割します。0を指定した場合、分割は行われません。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


ExplodedSlice

Steema.TeeChart.Styles.Pie.ExplodedSlice プロパティ

パイスライスを分割するためのプロパティにアクセスします。
public ExplodedSliceList ExplodedSlice {get;}

解説

パイスライスを分割するためのプロパティにアクセスします。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


MarksPie

Steema.TeeChart.Styles.Pie.MarksPie プロパティ

public PieMarks MarksPie {get; set;}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


MultiPie

Steema.TeeChart.Styles.Pie.MultiPie プロパティ

複数の円系列が存在する場合、自動的に円を配置するように設定します。
public MultiPies MultiPie {get; set;}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


OtherSlice

Steema.TeeChart.Styles.Pie.OtherSlice プロパティ

パイスライスのグループ化を設定します。
public PieOtherSlice OtherSlice {get;}

解説

パイスライスのグループ化を設定します。たとえば、円系列で「その他」スライスとしてグループ値を設定し、それに該当する値のスライスを1つのスライスにまとめます。グループは、パーセント未満あるいは値未満で設定します（Otherslice.Styleを参照してください）。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Pie.Pen プロパティ

パイのペン特性を設定します。
public ChartPen Pen {get;}

解説

パイのペン特性を設定します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


PieValues

Steema.TeeChart.Styles.Pie.PieValues プロパティ

パイスライス値を保持します。
public ValueList PieValues {get;}

解説

パイスライス値を保持します。これは標準の配列なので、以下のようにアクセスすることができます。

例

[C#]

double tmp = ((Steema.TeeChart.Styles.Pie)tChart1[0]).PieValues[3];

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Shadow

Steema.TeeChart.Styles.Pie.Shadow プロパティ

円系列のオフセットの影を定義します。
public PieShadow Shadow {get;}

解説

円系列のオフセットの影を定義します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


SliceHeight

Steema.TeeChart.Styles.Pie.SliceHeight プロパティ

各パイスライスに異なった高さを指定するために、このプロパティを使用してください。

public SliceValueList SliceHeight {get;}

解説

各パイスライスに異なった高さを指定するために、このプロパティを使用してください。

デフォルトでは、最高値（100%）を使用してすべてのパイスライスを表示します。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Transparency

Steema.TeeChart.Styles.Pie.Transparency プロパティ

0～100%の透明度を設定します。
public Int32 Transparency {get; set;}

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


UsePatterns

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.UsePatterns プロパティ

異なるブラシパターンスタイルでパイスライスを塗りつぶします。

public Boolean UsePatterns {get; set;}

解説

デフォルト値：false

trueの場合、パイスライスは異なるブラシパターンスタイルを使用して塗りつぶされます。6つの異なるパターンスタイルがあります。

参照

Pie クラス | Pie メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.ExplodedSliceList

Steema.TeeChart.Styles.Pie.ExplodedSliceList クラス

各パイスライスにつき1つ、分割効果のパーセントを保持するためのリスト。

この型のすべてのメンバの一覧については、ExplodedSliceList メンバを参照してください。

System.Object
System.Collections.Generic.List<System.Int32>
public class ExplodedSliceList : List<Int32> , IList<Int32>
, ICollection<Int32>, IEnumerable<Int32>, IEnumerable, IList
, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ExplodedSliceList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.ExplodedSliceList 全メンバ

ExplodedSliceList 概要

コンストラクタ

Steema.TeeChart.Styles.Pie.ExplodedSliceList

パブリック プロパティ

Item

参照

ExplodedSliceList クラス | Steema.TeeChart.Styles 名前空間


ExplodedSliceList コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+ExplodedSliceList コンストラクタ

public Pie+ExplodedSliceList(Int32 capacity)

参照

ExplodedSliceList クラス | ExplodedSliceList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.ExplodedSliceList プロパティ

パブリック プロパティ

Item

参照

ExplodedSliceList クラス | Steema.TeeChart.Styles 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+ExplodedSliceList.Item プロパティ

public Int32 Item(Int32 index) {get; set;}

参照

ExplodedSliceList クラス | ExplodedSliceList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie.PieAngle 構造体

各パイスライスの角度を保持するために円系列により使用される内部ストラクチャ。

この型のすべてのメンバの一覧については、PieAngle メンバを参照してください。

System.Object
System.ValueType
public struct PieAngle : ValueType

参照

PieAngle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieAngle 全メンバ

PieAngle 概要

パブリック フィールド

EndAngle
MidAngle
StartAngle

パブリック メソッド

Contains 指定したangleパラメーターがパイスライス内の場合、trueを返します。

参照

PieAngle 構造体 | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieAngle フィールド

パブリック フィールド

EndAngle
MidAngle
StartAngle

参照

PieAngle 構造体 | Steema.TeeChart.Styles 名前空間


EndAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieAngle.EndAngle フィールド

public Double EndAngle

参照

PieAngle 構造体 | PieAngle メンバ | Steema.TeeChart.Styles 名前空間


MidAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieAngle.MidAngle フィールド

public Double MidAngle

参照

PieAngle 構造体 | PieAngle メンバ | Steema.TeeChart.Styles 名前空間


StartAngle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieAngle.StartAngle フィールド

public Double StartAngle

参照

PieAngle 構造体 | PieAngle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieAngle メソッド

パブリック メソッド

Contains 指定したangleパラメーターがパイスライス内の場合、trueを返します。

参照

PieAngle 構造体 | Steema.TeeChart.Styles 名前空間


Contains

Steema.TeeChart.Styles.Pie+PieAngle.Contains メソッド

指定したangleパラメーターがパイスライス内の場合、trueを返します。
public Boolean Contains(Double angle)

参照

PieAngle 構造体 | PieAngle メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieMarks

Steema.TeeChart.Styles.Pie.PieMarks クラス

円系列のマーカをカスタマイズします。

この型のすべてのメンバの一覧については、PieMarks メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class PieMarks : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PieMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieMarks 全メンバ

PieMarks 概要

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
LegSize |
VertCenter |

コンストラクタ

Steema.TeeChart.Styles.Pie.PieMarks..ctor

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieMarks フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

PieMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieMarks メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieMarks プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
LegSize |
VertCenter |

参照

PieMarks クラス | Steema.TeeChart.Styles 名前空間


LegSize

Steema.TeeChart.Styles.Pie+PieMarks.LegSize プロパティ

public Int32 LegSize {get; set;}

参照

PieMarks クラス | PieMarks メンバ | Steema.TeeChart.Styles 名前空間


VertCenter

Steema.TeeChart.Styles.Pie+PieMarks.VertCenter プロパティ

public Boolean VertCenter {get; set;}

参照

PieMarks クラス | PieMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie+PieMarks コンストラクタ

public Pie+PieMarks(Chart c,
     Series s)

参照

PieMarks クラス | PieMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieOtherSlice

Steema.TeeChart.Styles.Pie.PieOtherSlice クラス

円系列は、OtherSliceプロパティでこのクラスを使用します。

この型のすべてのメンバの一覧については、PieOtherSlice メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class PieOtherSlice : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieOtherSlice 全メンバ

PieOtherSlice 概要

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 「その他（1つにまとめられた）」スライスの色を設定します。
Legend | 「その他（1つにまとめられた）」スライスの凡例特性を設定します。
Style | ｢その他｣のパイスライスをグループ化する値あるいはパーセントを設定します。
Text | 「その他（1つにまとめられた）」スライスのタイトルを設定します。
Value | 「その他」スライスにグループ化するための値（値あるいはパーセント）を設定します。

コンストラクタ

Steema.TeeChart.Styles.Pie.PieOtherSlice

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieOtherSlice クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieOtherSlice フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

PieOtherSlice クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieOtherSlice メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieOtherSlice クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieOtherSlice プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 「その他（1つにまとめられた）」スライスの色を設定します。
Legend | 「その他（1つにまとめられた）」スライスの凡例特性を設定します。
Style | ｢その他｣のパイスライスをグループ化する値あるいはパーセントを設定します。
Text | 「その他（1つにまとめられた）」スライスのタイトルを設定します。
Value | 「その他」スライスにグループ化するための値（値あるいはパーセント）を設定します。

参照

PieOtherSlice クラス | Steema.TeeChart.Styles 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieOtherSlice.Color プロパティ

「その他（1つにまとめられた）」スライスの色を設定します。

public Color Color {get; set;}

解説

「その他（1つにまとめられた）」スライスの色を設定します。

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Legend

Steema.TeeChart.Styles.Pie+PieOtherSlice.Legend プロパティ

「その他（1つにまとめられた）」スライスの凡例特性を設定します。
public Legend Legend {get; set;}

例

この例は、PieOtherSlice.Legendプロパティの使用法です。

// 10以下の値をグループ化して「Other」とします。
pie1.OtherSlice.Style=Steema.TeeChart.Styles.PieOtherStyles.BelowValue;
pie1.OtherSlice.Value=10;
pie1.OtherSlice.Text = "Other";
pie1.OtherSlice.Legend.Visible = true;
pie1.OtherSlice.Legend.CustomPosition = true;
pie1.OtherSlice.Legend.Left = 350;
pie1.OtherSlice.Legend.Top = 150;

解説

「その他（1つにまとめられた）」スライスの凡例特性を設定します。

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.Pie+PieOtherSlice.Style プロパティ

｢その他｣のパイスライスをグループ化する値あるいはパーセントを設定します。
public PieOtherStyles Style {get; set;}

解説

｢その他｣のパイスライスをグループ化するために値あるいはパーセントのどちらを使用するかを設定します。EPieOtherStyle=(None, BelowPercent, BelowValue);　値/パーセントを設定するために、Valueプロパティを使用してください。

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieOtherSlice.Text プロパティ

「その他（1つにまとめられた）」スライスのタイトルを設定します。

public String Text {get; set;}

解説

デフォルト値：Other

「その他（1つにまとめられた）」スライスのタイトルを設定します。

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pie+PieOtherSlice.Value プロパティ

「その他」スライスにグループ化するための値（値あるいはパーセント）を設定します。

public Double Value {get; set;}

解説

「その他」スライスにグループ化するための値（値あるいはパーセント）を設定します。

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


PieOtherSlice コンストラクタ

Steema.TeeChart.Styles.Pie+PieOtherSlice コンストラクタ

public Pie+PieOtherSlice(Chart c,
     Series s)

参照

PieOtherSlice クラス | PieOtherSlice メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieShadow

Steema.TeeChart.Styles.Pie.PieShadow クラス

円系列はShadowプロパティで、このクラスを使用します。

この型のすべてのメンバの一覧については、PieShadow メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shadow
public class PieShadow : Shadow , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PieShadow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieShadow 全メンバ

PieShadow 概要

パブリック メソッド

Assign (Shadowの継承元) | 影の｢値｣の特性を割り当てます。
Clone (Shadowの継承元) |
Draw (Shadowの継承元) | Rect矩形パラメーターの周りの影を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Brush (Shadowの継承元) | 影を塗りつぶすブラシ特性を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shadowの継承元) | 影の色を取得/設定します。
Height (Shadowの継承元) | 影の垂直サイズをピクセル単位で設定します。
HorizSize (Shadowの継承元) |
Size (Shadowの継承元) | 影のサイズをピクセル単位で取得/設定します。
Transparency (Shadowの継承元) | 0～100%までの影の透明度を設定します。
VertSize (Shadowの継承元) |
Visible (Shadowの継承元) | 影を表示/非表示します。
Width (Shadowの継承元) | 影の水平サイズをピクセル単位で設定します。

コンストラクタ

Steema.TeeChart.Styles.Pie.PieShadow..ctor

プロテクト フィールド

bBrush (Shadowの継承元)
bVisible (Shadowの継承元)
defaultSize (Shadowの継承元)
defaultVisible (Shadowの継承元)
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (Shadowの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Shadowの継承元)
ShouldSerializeVisible (Shadowの継承元)
ShouldSerializeWidth (Shadowの継承元)

参照

PieShadow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieShadow フィールド

プロテクト フィールド

bBrush (Shadowの継承元)
bVisible (Shadowの継承元)
defaultSize (Shadowの継承元)
defaultVisible (Shadowの継承元)
InternalUse (TeeBaseの継承元)

参照

PieShadow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieShadow メソッド

パブリック メソッド

Assign (Shadowの継承元) | 影の｢値｣の特性を割り当てます。
Clone (Shadowの継承元) |
Draw (Shadowの継承元) | Rect矩形パラメーターの周りの影を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (Shadowの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Shadowの継承元)
ShouldSerializeVisible (Shadowの継承元)
ShouldSerializeWidth (Shadowの継承元)

参照

PieShadow クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.PieShadow プロパティ

パブリック プロパティ

Brush (Shadowの継承元) | 影を塗りつぶすブラシ特性を定義します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Color (Shadowの継承元) | 影の色を取得/設定します。
Height (Shadowの継承元) | 影の垂直サイズをピクセル単位で設定します。
HorizSize (Shadowの継承元) |
Size (Shadowの継承元) | 影のサイズをピクセル単位で取得/設定します。
Transparency (Shadowの継承元) | 0～100%までの影の透明度を設定します。
VertSize (Shadowの継承元) |
Visible (Shadowの継承元) | 影を表示/非表示にします。
Width (Shadowの継承元) | 影の水平サイズをピクセル単位で設定します。

参照

PieShadow クラス | Steema.TeeChart.Styles 名前空間


PieShadow コンストラクタ

Steema.TeeChart.Styles.Pie+PieShadow コンストラクタ

public Pie+PieShadow(Chart c)

参照

PieShadow クラス | PieShadow メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.SliceValueList

Steema.TeeChart.Styles.Pie.SliceValueList クラス

この型のすべてのメンバの一覧については、SliceValueList メンバを参照してください。

System.Object
System.Collections.Generic.List<System.Int32>
public class SliceValueList : List<Int32> , IList<Int32>
, ICollection<Int32>, IEnumerable<Int32>, IEnumerable, IList
, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SliceValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.SliceValueList 全メンバ

SliceValueList 概要

パブリック フィールド

OwnerSeries

パブリック プロパティ

Item

コンストラクタ

Steema.TeeChart.Styles.Pie.SliceValueList

参照

SliceValueList クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.SliceValueList フィールド

パブリック フィールド

OwnerSeries

参照

SliceValueList クラス | Steema.TeeChart.Styles 名前空間


OwnerSeries

Steema.TeeChart.Styles.Pie+SliceValueList.OwnerSeries フィールド

public Series OwnerSeries

参照

SliceValueList クラス | SliceValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pie.SliceValueList プロパティ

パブリック プロパティ

Item

参照

SliceValueList クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Pie+SliceValueList.Item プロパティ

public Int32 Item(Int32 index) {get; set;}

参照

SliceValueList クラス | SliceValueList メンバ | Steema.TeeChart.Styles 名前空間


SliceValueList コンストラクタ

Steema.TeeChart.Styles.Pie+SliceValueList コンストラクタ

public Pie+SliceValueList()

参照

SliceValueList クラス | SliceValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PieOtherStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PieOtherStyles 列挙体

PieOtherSliceクラスのStyle プロパティの使用可能な値です。

[Serializable]
public enum PieOtherStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | ｢その他｣のスライスは生成されません（デフォルト)。
BelowPercent | 指定した%未満の値を持つスライスがグループ化されます。
BelowValue | 指定した値未満の値を持つスライスがグループ化されます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointerStyles

Steema.TeeChart.Styles.PointerStyles 列挙体

Styleプロパティの使用可能な値です。
[Serializable]
public sealed enum PointerStyles : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Rectangle | ポインタを正方形で表示します。
Circle | ポインタを円で表示します。
Triangle | ポインタを三角形で表示します。
DownTriangle | ポインタを倒立三角形で表示します。
Cross | ポインタを交差線で表示します。
DiagCross | ポインタを斜め交差線で表示します。
Star | ポインタを星形で表示します。
Diamond | ポインタを菱形で表示します。
SmallDot | ポインタを点で表示します。
Nothing | ポインタを表示しません。
LeftTriangle | ポインタを左向き三角形で表示します。
RightTriangle | ポインタを右向き三角形で表示します。
Sphere | ポインタを球で表示します。
PolishedSphere | ポインタを光沢のある球で表示します。
Hexagon | ポインタを六角形で表示します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure

Steema.TeeChart.Styles.PointFigure クラス

ポイント＆フィギュア系列。

この型のすべてのメンバの一覧については、PointFigure メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
Steema.TeeChart.Styles.OHLC
public class PointFigure : OHLC , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure 全メンバ

PointFigure 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BoxSize |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSymbol |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
ReversalAmount |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSymbol |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PointFigure クラス | Steema.TeeChart.Styles 名前空間


PointFigure コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure コンストラクタ

オーバーロードの一覧

public PointFigure()
public PointFigure(Steema.TeeChart.Chart)

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


PointFigure コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure コンストラクタ

public PointFigure()

参照

PointFigure コンストラクタのオーバーロードの一覧 | PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


PointFigure コンストラクタ

Steema.TeeChart.Styles.PointFigure コンストラクタ

public PointFigure(Chart c)

参照

PointFigure コンストラクタのオーバーロードの一覧 | PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

PointFigure クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vHighValues (OHLCの継承元)
vLowValues (OHLCの継承元)
vOpenValues (OHLCの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

PointFigure クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure メソッド

パブリック メソッド

Add (OHLCの継承元) | 系列に新しい株価ポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (OHLCの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (OHLCの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue (OHLCの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (OHLCの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (OHLCの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PointFigure クラス | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.PointFigure.Draw メソッド

public override Void Draw()

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.LegendItemColor メソッド

protected internal virtual Color LegendItemColor(Int32 index)

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.PointFigure.LegendString メソッド

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

解説

LegendIndex番目のポイントをLegendTextStyleで凡例の文字列を返します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.MaxXValue メソッド

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.MinXValue メソッド

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.PointFigure.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.PointFigure.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointFigure プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BoxSize |
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues (OHLCの継承元) | すべての株価の終値を取得/設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DateValues (OHLCの継承元) | すべての株価の日付値を取得/設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSymbol |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HighValues (OHLCの継承元) | すべての株価の高値を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (OHLCの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
LowValues (OHLCの継承元) | すべての株価の安値を取得/設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OpenValues (OHLCの継承元) | すべての株価の始値を取得/設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
ReversalAmount |
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSymbol |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

PointFigure クラス | Steema.TeeChart.Styles 名前空間


BoxSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.BoxSize プロパティ

public Double BoxSize {get; set;}

解説

デフォルト値：1

BoxSize自体は同じ列に新しいシンボルを描くための最小変動価格を定義します。

BoxSizeによるReversalAmountの乗数は、新しいシンボルの列を追加する前に許容される最大価格差を定義します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.PointFigure.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


DownSymbol

Steema.TeeChart.Styles.PointFigure.DownSymbol プロパティ

public SeriesPointer DownSymbol {get;}

解説

価格が下がる期間に描画されるシンボルを設定します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


ReversalAmount

TeeChartプログラミングガイド

Steema.TeeChart.Styles.PointFigure.ReversalAmount プロパティ

public Double ReversalAmount {get; set;}

解説

デフォルト値：3

BoxSizeプロパティの乗数を設定します。

BoxSizeによるReversalAmountの乗数は、新しいシンボルの列を追加する前に許容される最大価格差を定義します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


UpSymbol

Steema.TeeChart.Styles.PointFigure.UpSymbol プロパティ

public SeriesPointer UpSymbol {get;}

解説

価格が上がる期間に描画されるシンボルを定義します。

参照

PointFigure クラス | PointFigure メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygon

Steema.TeeChart.Styles.PointPolygon クラス

系列ポイントの定義やマップ領域の属性を保持します。

この型のすべてのメンバの一覧については、PointPolygon メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class PointPolygon : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ：TeeChart.dll

参照

PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygon 全メンバ

PointPolygon 概要

コンストラクタ

Constructor コンストラクタ

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Attributes | この文字列は各系列ポイントを個別に操作するためにチャートのマップを設定したり、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）で修正することができます。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Coordinates | PointPolygonの座標リストを取得/設定します。
HREF | マウスでクリックした領域のURLの文字列を取得/設定します。例えば、この文字列をHotspotイベント（SeriesHotspotEventHandler引数を参照）でオーバーライドすると、そのクリックしたポイントのURLのパラメーターを作成できます。
IncludePolygon | ポリゴンをHTML領域マップに含めるかどうか定義します。チャート矩形の外側にあるポリゴンは、自動的に非表示にされます。
PointStyle | マップ領域の座標スタイルを設定します。
Title | デフォルトのタイトルはホットスポットツールのStyleプロパティで設定されます。MapActionが'Mark'に設定されている場合、系列ポイント上にマウスが移動するとStyleプロパティに応じてタイトルを表示します。Hotspotイベント（SeriesHotspotEventHandler引数を参照）でタイトルをオーバーライドしたり、他のMapActionのアクションと一緒に設定できます。
ValueIndex | 多角形に関連付けられている系列ポイント値のインデックスを取得/設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PointPolygon クラス | Steema.TeeChart.Styles 名前空間


PointPolygon コンストラクタ

Steema.TeeChart.Styles.PointPolygon コンストラクタ

コンストラクタ。

public PointPolygon(Int32 vIndex,
     Int32[] coords,
     PolygonStyle pStyle)

パラメーター

vIndex
系列ポイントのインデックス
coords
ポイントの座標リスト
pStyle

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygon フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

PointPolygon クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygon メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PointPolygon クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygon プロパティ

パブリック プロパティ

Attributes | この文字列は各系列ポイントを個別に操作するためにチャートのマップを設定したり、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）で修正することができます。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Coordinates | PointPolygonの座標リストを取得/設定します。
HREF | マウスでクリックした領域のURLの文字列を取得/設定します。例えば、この文字列をHotspotイベント（SeriesHotspotEventHandler引数を参照）でオーバーライドすると、そのクリックしたポイントのURLのパラメーターを作成できます。
IncludePolygon | ポリゴンをHTML領域マップに含めるかどうか定義します。チャート矩形の外側にあるポリゴンは、自動的に非表示にされます。
PointStyle | マップ領域の座標スタイルを設定します。
Title | デフォルトのタイトルはホットスポットツールのStyleプロパティで設定されます。MapActionが'Mark'に設定されている場合、系列ポイント上にマウスが移動するとStyleプロパティに応じてタイトルを表示します。Hotspotイベント（SeriesHotspotEventHandler引数を参照）でタイトルをオーバーライドしたり、他のMapActionのアクションと一緒に設定できます。
ValueIndex | 多角形に関連付けられている系列ポイント値のインデックスを取得/設定します。

参照

PointPolygon クラス | Steema.TeeChart.Styles 名前空間


Attributes

Steema.TeeChart.Styles.PointPolygon.Attributes プロパティ

この文字列は各系列ポイントを個別に操作するためにチャートのマップを設定したり、Hotspotイベント（GetHTMLMapとSeriesHotspotEventHandler引数を参照）で変更することができます。

public String Attributes {get; set;}

例

private void hotspot1_GetHTMLMap(Steema.TeeChart.Tools.Hotspot sender, Steema.TeeChart.Tools.SeriesHotspotEventArgs e)
{
//HREFアクションが設定されていても、タイトルの設定や変更ができます。
//e.PointPolygon.Title="My Point Index: "+e.PointPolygon.ValueIndex.ToString();
//e.PointPolygon.HREF="http://www.steema.com/cgi-bin/examplescript?var1="+e.PointPolygon.ValueIndex.ToString();
e.PointPolygon.Attributes="onClick=\"Javascript:DrillDownFunc("+e.Series.ToString()+", " +e.PointPolygon.ValueIndex.ToString()+")\"";
}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


Coordinates

Steema.TeeChart.Styles.PointPolygon.Coordinates プロパティ

PointPolygonの座標リストを取得/設定します。

public Int32[] Coordinates {get; set;}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


HREF

Steema.TeeChart.Styles.PointPolygon.HREF プロパティ

マウスでクリックした領域のURLの文字列を取得/設定します。例えば、この文字列をHotspotイベント（SeriesHotspotEventHandler引数を参照）でオーバーライドすると、そのクリックしたポイントのURLのパラメーターを作成できます。

public String HREF {get; set;}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


IncludePolygon

Steema.TeeChart.Styles.PointPolygon.IncludePolygon プロパティ

ポリゴンをHTML領域マップに含めるかどうか定義します。チャート矩形の外側にあるポリゴンは、自動的に非表示にされます。
public Boolean IncludePolygon {get; set;}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


PointStyle

Steema.TeeChart.Styles.PointPolygon.PointStyle プロパティ

マップ領域の座標スタイルを設定します。

public PolygonStyle PointStyle {get; set;}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


Title

Steema.TeeChart.Styles.PointPolygon.Title プロパティ

デフォルトのタイトルは、ホットスポットツールのStyleプロパティで設定されます。MapActionが'Mark'に設定されている場合、系列ポイント上にマウスが移動するとStyleプロパティに応じてタイトルを表示します。Hotspotイベント（SeriesHotspotEventHandler引数を参照）でタイトルをオーバーライドしたり、他のMapActionのアクションと一緒に設定できます。

public String Title {get; set;}

例

private void hotspot1_GetHTMLMap(Steema.TeeChart.Tools.Hotspot sender, Steema.TeeChart.Tools.SeriesHotspotEventArgs e)
{
//HREFが設定されていても、タイトルの設定や変更ができます。
e.PointPolygon.Title="My Point Index: "+e.PointPolygon.ValueIndex.ToString();
e.PointPolygon.HREF="http://www.steema.com/cgi-bin/examplescript?var1="+e.PointPolygon.ValueIndex.ToString();
//e.PointPolygon.Attributes="onClick=\"Javascript:ActivateFunc("+e.PointPolygon.ValueIndex.ToString()+")\"";
}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


ValueIndex

Steema.TeeChart.Styles.PointPolygon.ValueIndex プロパティ

多角形に関連付けられている系列ポイント値のインデックスを取得/設定します。

public Int32 ValueIndex {get; set;}

参照

PointPolygon クラス | PointPolygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygonList

Steema.TeeChart.Styles.PointPolygonList クラス

系列のポイント座標を表す多角形のリスト。

この型のすべてのメンバの一覧については、PointPolygonList メンバを参照してください。

System.Object
System.Collections.CollectionBase
public class PointPolygonList : CollectionBase , IList, ICollection
, IEnumerable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ：TeeChart.dll

参照

PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygonList 全メンバ

PointPolygonList 概要

コンストラクタ

Constructor

パブリック メソッド

Add
AddRange
Assign
IndexOf
RemoveRange

パブリック プロパティ

Item |
Item |
Series | PolygonListを持つマップ系列を返します。

参照

PointPolygonList クラス | Steema.TeeChart.Styles 名前空間


PointPolygonList コンストラクタ

Steema.TeeChart.Styles.PointPolygonList コンストラクタ

public PointPolygonList(Series s)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygonList メソッド

パブリック メソッド

Add
AddRange
Assign
IndexOf
RemoveRange

参照

PointPolygonList クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.PointPolygonList.Add メソッド

public Int32 Add(PointPolygon value)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


AddRange

Steema.TeeChart.Styles.PointPolygonList.AddRange メソッド

public Void AddRange(ICollection c)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Assign

Steema.TeeChart.Styles.PointPolygonList.Assign メソッド

public Void Assign(PointPolygonList Value)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


IndexOf

Steema.TeeChart.Styles.PointPolygonList.IndexOf メソッド

public Int32 IndexOf(Series s)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


RemoveRange

Steema.TeeChart.Styles.PointPolygonList.RemoveRange メソッド

public Void RemoveRange(Int32 index,
     Int32 count)

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PointPolygonList プロパティ

パブリック プロパティ

Item |
Item |
Series | PolygonListを持つマップ系列を返します。

参照

PointPolygonList クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.PointPolygonList.Item プロパティ

public PointPolygon Item(String AName) {get;}

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.PointPolygonList.Series プロパティ

PolygonListを持つマップ系列を返します。

public Series Series {get; set;}

参照

PointPolygonList クラス | PointPolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points

Steema.TeeChart.Styles.Points クラス

散布図系列。

この型のすべてのメンバの一覧については、Points メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
[Serializable]
public class Points : CustomPoint , IComponent
, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Points メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points 全メンバ

Points 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPointの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Points クラス | Steema.TeeChart.Styles 名前空間


Points コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points コンストラクタ

オーバーロードの一覧

public Points(Steema.TeeChart.Chart)
public Points()

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


Points コンストラクタ

Steema.TeeChart.Styles.Points コンストラクタ

public Points(Chart c)

参照

Points コンストラクタのオーバーロードの一覧 | Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


Points コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points コンストラクタ

public Points()

参照

Points コンストラクタのオーバーロードの一覧 | Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Points クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Points クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPointの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPointの継承元) | 系列で｢クリックされた｣ポイントのインデックスを返します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPointの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (CustomPointの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (CustomPointの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CanDoExtra |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPointの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPointの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPointの継承元) |
SetColorEach |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Points クラス | Steema.TeeChart.Styles 名前空間


CanDoExtra

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points.CanDoExtra メソッド

protected virtual Boolean CanDoExtra()

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Points.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


GetSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points.GetSeriesColor メソッド

protected virtual Color GetSeriesColor()

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Points.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


SetColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points.SetColorEach メソッド

protected virtual Void SetColorEach(Boolean value)

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Points.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | ポイントを接続する線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls (BaseLineの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Points クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Points.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


LinePen

Steema.TeeChart.Styles.Points.LinePen プロパティ

ポイントを接続する線を描くペンを設定します。
public ChartPen LinePen {get;}

解説

ポイントを接続する線を描くペンを設定します。

例

[C#]

private void button1_Click_1(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Points)tChart1[0]).LinePen.Color= Color.Red;
}

参照

Points クラス | Points メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D

Steema.TeeChart.Styles.Points3D クラス

3D散布系列。 各ポイントはXYZ座標を持っています。

この型のすべてのメンバの一覧については、Points3D メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
public class Points3D : Custom3D , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Points3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D 全メンバ

Points3D 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle |
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BaseLine | 3D 散布系列の各ポイントから床に伸びる線を描くペンを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthSize | 3D散布系列の深さを定義します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZ ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | 3D 散布系列の各ポイントから床に伸びる線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 散布図系列の各ポイントは、Pointerプロパティを使用して描かれます。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Points3D クラス | Steema.TeeChart.Styles 名前空間


Points3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D コンストラクタ

オーバーロードの一覧

public Points3D(Steema.TeeChart.Chart)
public Points3D()

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Points3D コンストラクタ

Steema.TeeChart.Styles.Points3D コンストラクタ

public Points3D(Chart c)

参照

Points3D コンストラクタのオーバーロードの一覧 | Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Points3D コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D コンストラクタ

public Points3D()

参照

Points3D コンストラクタのオーバーロードの一覧 | Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle |
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Points3D クラス | Steema.TeeChart.Styles 名前空間


GetPointerStyle

Steema.TeeChart.Styles.Points3D.GetPointerStyle イベント

public GetPointerStyleEventHandler  GetPointerStyle

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Points3D クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Points3D クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& TopMargin,
     Int32& BottomMargin)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのValueIndexを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのValueIndexを返します。｢クリックされた｣とは、XとY座標値がポイントの画面領域の境界内にあることを意味します。｢触れた｣のポイントがない場合、Clickedは-1を返します。

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.Clicked メソッド

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Points3D.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Points3D.Draw メソッド

public override Void Draw()

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Points3D.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle r)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Points3D.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Points3D.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.MaxZValue メソッド

Zの最大値を返します。

public virtual Double MaxZValue()

解説

Zの最大値を返します。

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Points3D.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


OnGetPointerStyle

Steema.TeeChart.Styles.Points3D.OnGetPointerStyle メソッド

protected Void OnGetPointerStyle(Int32 valueIndex,
     PointerStyles& style,
     Color& aColor)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Points3D.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Points3D.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Points3D.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BaseLine | 3D 散布系列の各ポイントから床に伸びる線を描くペンを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
DepthSize | 3D散布系列の深さを定義します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LinePen | 3D 散布系列の各ポイントから床に伸びる線を描くペンを設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | 散布図系列の各ポイントは、Pointerプロパティを使用して描かれます。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TreatNulls |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Points3D クラス | Steema.TeeChart.Styles 名前空間


BaseLine

Steema.TeeChart.Styles.Points3D.BaseLine プロパティ

3D 散布系列の各ポイントから床に伸びる線を描くペンを設定します。
public ChartPen BaseLine {get;}

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


DepthSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Points3D.DepthSize プロパティ

3D散布系列の深さを定義します。

public Double DepthSize {get; set;}

解説

3D散布系列の深さを定義します。

例

[C#]

((Steema.TeeChart.Styles.Points3D)tChart1[0]).DepthSize = 3;

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Points3D.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


LinePen

Steema.TeeChart.Styles.Points3D.LinePen プロパティ

3D散布系列のポイントを接続する線を描くペンを設定します。
public ChartPen LinePen {get;}

解説

3D散布系列のポイントを接続する線を描くペンを設定します。

例

[C#]

private void button1_Click_1(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Points3D)tChart1[0]).LinePen.Color= Color.Red;
}

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Pointer

Steema.TeeChart.Styles.Points3D.Pointer プロパティ

散布図系列の各ポイントは、Pointerプロパティを使用して描画されます。
public SeriesPointer Pointer {get;}

解説

散布図系列、リボン系列、泡系列などのその他すべての派生散布図系列コンポーネントのサブクラスです。

散布図系列の各ポイントは、Pointerプロパティを使用して描画されます。

Pointerには、Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがいくつかあります。

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


TreatNulls

Steema.TeeChart.Styles.Points3D.TreatNulls プロパティ

public TreatNullsStyle TreatNulls {get; set;}

参照

Points3D クラス | Points3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Points3D.GetPointerStyleEventHandler

Steema.TeeChart.Styles.Points3D.GetPointerStyleEventHandler デリゲート

GetPointerStyleイベントのデリゲート。
public delegate GetPointerStyleEventHandler (Points3D series,
     GetPointerStyleEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar

Steema.TeeChart.Styles.Polar クラス

極系列。

この型のすべてのメンバの一覧については、Polar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Polar : CustomPolar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Polar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar 全メンバ

Polar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (CustomPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Polar クラス | Steema.TeeChart.Styles 名前空間


Polar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Polar コンストラクタ

オーバーロードの一覧

public Polar()
public Polar(Steema.TeeChart.Chart)

参照

Polar クラス | Polar メンバ | Steema.TeeChart.Styles 名前空間


Polar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Polar コンストラクタ

public Polar()

参照

Polar コンストラクタのオーバーロードの一覧 | Polar クラス | Polar メンバ | Steema.TeeChart.Styles 名前空間


Polar コンストラクタ

Steema.TeeChart.Styles.Polar コンストラクタ

public Polar(Chart c)

参照

Polar コンストラクタのオーバーロードの一覧 | Polar クラス | Polar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Polar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Polar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (CustomPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Polar クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Polar.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Polar クラス | Polar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Polar クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Polar.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Polar クラス | Polar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar

Steema.TeeChart.Styles.PolarBar クラス

極棒系列。

この型のすべてのメンバの一覧については、PolarBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Polar
public class PolarBar : Polar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PolarBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar 全メンバ

PolarBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (CustomPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Polarの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolarBar クラス | Steema.TeeChart.Styles 名前空間


PolarBar コンストラクタ

Steema.TeeChart.Styles.PolarBar コンストラクタ

オーバーロードの一覧

public PolarBar()
public PolarBar(Steema.TeeChart.Chart)

参照

PolarBar クラス | PolarBar メンバ | Steema.TeeChart.Styles 名前空間


PolarBar コンストラクタ

Steema.TeeChart.Styles.PolarBar コンストラクタ

public PolarBar()

参照

PolarBar コンストラクタのオーバーロードの一覧 | PolarBar クラス | PolarBar メンバ | Steema.TeeChart.Styles 名前空間


PolarBar コンストラクタ

Steema.TeeChart.Styles.PolarBar コンストラクタ

public PolarBar(Chart c)

参照

PolarBar コンストラクタのオーバーロードの一覧 | PolarBar クラス | PolarBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

PolarBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

PolarBar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery (CustomPolarの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Polarの継承元) |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel (CustomPolarの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolarBar クラス | Steema.TeeChart.Styles 名前空間


InternalDrawValue

Steema.TeeChart.Styles.PolarBar.InternalDrawValue メソッド

protected abstract Void InternalDrawValue(Int32 index,
     Int32 X,
     Int32 Y)

参照

PolarBar クラス | PolarBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarBar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

PolarBar クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.PolarBar.Description プロパティ

public override String Description {get;}

参照

PolarBar クラス | PolarBar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid

Steema.TeeChart.Styles.PolarGrid クラス

極グリッド系列。

この型のすべてのメンバの一覧については、PolarGrid メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class PolarGrid : CustomPolar , IComponent, IDisposable
, ICloneable

解説

セルの円形グリッドとして値の配列を描画します。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid 全メンバ

PolarGrid 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddCell | 極グリッド系列に新しいセルを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
CellValues | 極グリッドのセル値を取得/設定します。
Centered | Trueの場合、外円ラベルをセルの中央に配置します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumSectors | 極グリッドのセレクタの数を定義します。
NumTracks | 極グリッドのトラック数を定義します。
Palette | 極グリッドのカラーパレット特性にアクセスします。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CellPolygon |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolarGrid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid コンストラクタ

オーバーロードの一覧

public PolarGrid()
public PolarGrid(Steema.TeeChart.Chart)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid コンストラクタ

public PolarGrid()

参照

PolarGrid コンストラクタのオーバーロードの一覧 | PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid コンストラクタ

public PolarGrid(Chart c)

参照

PolarGrid コンストラクタのオーバーロードの一覧 | PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

PolarGrid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

PolarGrid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddCell | 極グリッド系列に新しいセルを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CellPolygon |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue (CustomPolarの継承元) |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolarGrid クラス | Steema.TeeChart.Styles 名前空間


AddCell

Steema.TeeChart.Styles.PolarGrid.AddCell メソッド

極グリッド系列に新しいセルを追加します。
public Int32 AddCell(Int32 sector,
     Int32 track,
     Double value)

パラメーター

sector
セルのセクタ。
track
セルのトラック。
value
セルの値[sector,track].

戻り値

追加されたセルのインデックス。

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.PolarGrid.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.PolarGrid.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

Steema.TeeChart.Styles.PolarGrid.CalcXPos メソッド

public override Int32 CalcXPos(Int32 valueIndex)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

Steema.TeeChart.Styles.PolarGrid.CalcYPos メソッド

public override Int32 CalcYPos(Int32 valueIndex)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


CellPolygon

Steema.TeeChart.Styles.PolarGrid.CellPolygon メソッド

protected Void CellPolygon(Int32 valueindex,
     Point[]& Points)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.PolarGrid.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.PolarGrid.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

Steema.TeeChart.Styles.PolarGrid.CountLegendItems メソッド

protected internal abstract Int32 CountLegendItems()

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


DoAfterDrawValues

Steema.TeeChart.Styles.PolarGrid.DoAfterDrawValues メソッド

protected internal abstract Void DoAfterDrawValues()

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.PolarGrid.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


DrawPolarCircle

Steema.TeeChart.Styles.PolarGrid.DrawPolarCircle メソッド

protected abstract Void DrawPolarCircle(Int32 HalfWidth,
     Int32 HalfHeight,
     Int32 Z)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

Steema.TeeChart.Styles.PolarGrid.DrawValue メソッド

public override Void DrawValue(Int32 valueIndex)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


GetCircleLabel

Steema.TeeChart.Styles.PolarGrid.GetCircleLabel メソッド

protected abstract String GetCircleLabel(Double angle,
     Int32 index)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.PolarGrid.IsValidSourceOf メソッド

public override Boolean IsValidSourceOf(Series value)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.PolarGrid.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 index)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.PolarGrid.LegendString メソッド

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.PolarGrid.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.PolarGrid.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.PolarGrid.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolarGrid プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
CellValues | 極グリッドのセル値を取得/設定します。
Centered | Trueの場合、外円ラベルをセルの中央に配置します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumSectors | 極グリッドのセレクタの数を定義します。
NumTracks | 極グリッドのトラック数を定義します。
Palette | 極グリッドのカラーパレット特性にアクセスします。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

PolarGrid クラス | Steema.TeeChart.Styles 名前空間


CellValues

Steema.TeeChart.Styles.PolarGrid.CellValues プロパティ

極グリッドのセル値を取得/設定します。
public ValueList CellValues {get; set;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Centered

Steema.TeeChart.Styles.PolarGrid.Centered プロパティ

Trueの場合、外円ラベルをセルの中央に配置します。
public Boolean Centered {get; set;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.PolarGrid.Description プロパティ

public override String Description {get;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


NumSectors

Steema.TeeChart.Styles.PolarGrid.NumSectors プロパティ

極グリッドのセレクタの数を定義します。
public Int32 NumSectors {get; set;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


NumTracks

Steema.TeeChart.Styles.PolarGrid.NumTracks プロパティ

極グリッドのトラック数を定義します。
public Int32 NumTracks {get; set;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Palette

Steema.TeeChart.Styles.PolarGrid.Palette プロパティ

極グリッドのカラーパレット特性にアクセスします。
public GridColorPalette Palette {get; set;}

参照

PolarGrid クラス | PolarGrid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polygon

Steema.TeeChart.Styles.Polygon クラス

この型のすべてのメンバの一覧については、Polygon メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Polygon : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ：TeeChart.dll

参照

Polygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polygon 全メンバ

Polygon 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

ParentSeries

パブリック メソッド

Add | 多角形に境界座標を追加します。多角形は座標順に描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1)からポイント3 (X2,Y2) ）。
Bounds | 多角形で使用される最大矩形領域をピクセル単位で返します。
CalcPoints |
Draw |
GetPoints | 多角形のすべてのポイント座標を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Visible | 多角形がチャートのChartRect矩形内に収まる場合、Trueを返します。

パブリック プロパティ

Brush | 多角形を塗りつぶすブラシの種類を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Closed | Trueの場合、PolygonのPenプロパティとBrushプロパティを使用して多角形を表示/塗りつぶします。Falseの場合、Penプロパティを使用して多角線を表示します。
Color | 多角形を塗りつぶす色やブラシのパターンを設定します。
Gradient | 多角形のグラデーション効果の種類を定義します。
Index |
ParentBrush | Trueに設定すると、多角形は親系列（マップ系列）と同じブラシを使用します。Falseの場合、多角形は独自のBrushプロパティを使用します。
ParentPen | Trueに設定すると、多角形は親系列と同じペンを使用します。Falseの場合、多角形は独自のPenプロパティを使用します。
Pen | 多角形の枠を描くペンを設定します。
Points | 多角形の境界を定義するPointList座標にアクセスします。
Text | 多角形のラベルに表示する文字列を設定します。
Transparency | 多角形を塗りつぶす透明度を設定します。透明度が0の場合、前面だけが表示されます。透明度が100の場合、背面だけが表示されます。
Z | 3Dマップ系列のZ軸の位置を設定します。チャートによってZ平面位置を設定し、Z値の低い順から前面に描画されます。マップ系列は2Dで表示され、Z値を多角形（例：人口統計学用のマップ）の値に使用します。カラーパレットを使用すると、Z値は多角形の色に設定されます。

プロテクト フィールド

FPoints
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Polygon クラス | Steema.TeeChart.Styles 名前空間


Polygon コンストラクタ

Steema.TeeChart.Styles.Polygon コンストラクタ

オーバーロードの一覧

public Polygon(Steema.TeeChart.Chart)
public Polygon(Steema.TeeChart.Styles.PolygonList, Steema.TeeChart.Chart)

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Polygon コンストラクタ

Steema.TeeChart.Styles.Polygon コンストラクタ

public Polygon(Chart AChart)

参照

Polygon コンストラクタのオーバーロードの一覧 | Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Polygon コンストラクタ

Steema.TeeChart.Styles.Polygon コンストラクタ

public Polygon(PolygonList Collection,
     Chart AChart)

参照

Polygon コンストラクタのオーバーロードの一覧 | Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polygon フィールド

プロテクト フィールド

FPoints
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Polygon クラス | Steema.TeeChart.Styles 名前空間


FPoints

Steema.TeeChart.Styles.Polygon.FPoints フィールド

protected internal PolygonSeries FPoints

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polygon メソッド

パブリック メソッド

Add | 多角形に境界座標を追加します。多角形は座標順に描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1)からポイント3 (X2,Y2) ）。
Bounds | 多角形で使用される最大矩形領域をピクセル単位で返します。
CalcPoints |
Draw |
GetPoints | 多角形のすべてのポイント座標を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Visible | 多角形がチャートのChartRect矩形内に収まる場合、Trueを返します。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Polygon クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Polygon.Add メソッド

オーバーロードの一覧

多角形を描画するための境界座標を追加します。多角形は座標順で描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1) からポイント3 (X2,Y2) ）。

public Int32 Add(System.Drawing.Point)

多角形を描画するための境界座標を追加します。多角形は座標順で描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1) からポイント3 (X2,Y2) ）。

public Int32 Add(System.Double, System.Double)

解説

多角形を描画するための境界座標を追加します。多角形は座標順で描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1) からポイント3 (X2,Y2) ）。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Polygon.Add メソッド

多角形を描画するための境界座標を追加します。多角形は座標順で描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1) からポイント3 (X2,Y2) ）。

public Int32 Add(Point Point)

参照

Add オーバーロードの一覧 | Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Polygon.Add メソッド

多角形を描画するための境界座標を追加します。多角形は座標順で描画されます（例：ポイント1 (X0,Y0) からポイント2 (X1,Y1) 、ポイント2 (X1,Y1) からポイント3 (X2,Y2) ）。

public Int32 Add(Double X,
     Double Y)

参照

Add オーバーロードの一覧 | Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Bounds

Steema.TeeChart.Styles.Polygon.Bounds メソッド

多角形で使用される最大矩形領域をピクセル単位で返します。

public Rectangle Bounds()

解説

多角形で使用される最大矩形領域をピクセル単位で返します。

最大矩形領域の座標は、現在の3D Canvasパラメーター（Rotation、Elevation、Zoomなど）を使用して計算されます。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


CalcPoints

Steema.TeeChart.Styles.Polygon.CalcPoints メソッド

public Void CalcPoints(Int32 xoffset,
     Int32 yoffset)

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Polygon.Draw メソッド

public Void Draw(Graphics3D g,
     Int32 ValueIndex)

解説

チャートキャンバスに多角形を描画します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


GetPoints

Steema.TeeChart.Styles.Polygon.GetPoints メソッド

多角形のすべてのポイント座標を返します。

public Point[] GetPoints()

解説

多角形のすべてのポイント座標を返します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Visible

Steema.TeeChart.Styles.Polygon.Visible メソッド

多角形がチャートのChartRect矩形内に収まる場合、Trueを返します。

public Boolean Visible()

解説

多角形がチャートのChartRect矩形内に収まる場合、Trueを返します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Polygon プロパティ

パブリック プロパティ

Brush | 多角形を塗りつぶすブラシの種類を定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Closed | Trueの場合、PolygonのPenプロパティとBrushプロパティを使用して多角形を表示/塗りつぶします。 Falseの場合、Penプロパティを使用して多角線を表示します。
Color | 多角形を塗りつぶす色やブラシのパターンを設定します。
Gradient | 多角形のグラデーション効果の種類を定義します。
Index |
ParentBrush | Trueに設定すると、多角形は親系列（マップ系列）と同じブラシを使用します。Falseの場合、多角形は独自のBrushプロパティを使用します。
ParentPen | Trueに設定すると、多角形は親系列と同じペンを使用します。Falseの場合、多角形は独自のPenプロパティを使用します。
Pen | 多角形の枠を描くペンを設定します。
Points | 多角形の境界を定義するPointList座標にアクセスします。
Text | 多角形のラベルに表示する文字列を設定します。
Transparency | 多角形を塗りつぶす透明度を設定します。透明度が0の場合、前面だけが表示されます。透明度が100の場合、背面だけが表示されます。
Z | 3Dマップ系列のZ軸の位置を設定します。チャートによってZ平面位置を設定し、Z値の低い順から前面に描画されます。マップ系列は2Dで表示され、Z値を多角形（例：人口統計学用のマップ）の値に使用します。カラーパレットを使用すると、Z値は多角形の色に設定されます。

参照

Polygon クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Polygon.Brush プロパティ

多角形を塗りつぶすブラシの種類を定義します。

public ChartBrush Brush {get;}

解説

多角形を塗りつぶすブラシの種類を定義します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Closed

Steema.TeeChart.Styles.Polygon.Closed プロパティ

Trueの場合、PolygonのPenプロパティとBrushプロパティを使用して多角形を表示/塗りつぶします。Falseの場合、Penプロパティを使用して多角線を表示します。

public Boolean Closed {get; set;}

解説

デフォルト値：True

Trueの場合、PolygonのPenプロパティとBrushプロパティを使用して多角形を表示/塗りつぶします。

Falseの場合、Penプロパティを使用して多角線を表示します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Color

Steema.TeeChart.Styles.Polygon.Color プロパティ

多角形を塗りつぶす色やブラシのパターンを設定します。

public Color Color {get; set;}

解説

多角形を塗りつぶす色やブラシのパターンを設定します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.Polygon.Gradient プロパティ

多角形のグラデーション効果の種類を定義します。

public Gradient Gradient {get;}

解説

多角形のグラデーション効果の種類を定義します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Index

Steema.TeeChart.Styles.Polygon.Index プロパティ

public Int32 Index {get; set;}

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


ParentBrush

Steema.TeeChart.Styles.Polygon.ParentBrush プロパティ

Trueに設定すると、多角形は親系列（マップ系列）と同じブラシを使用します。Falseの場合、多角形は独自のBrushプロパティを使用します。

public Boolean ParentBrush {get; set;}

解説

Trueに設定すると、多角形は親系列（マップ系列）と同じブラシを使用します。Falseの場合、多角形は独自のBrushプロパティを使用します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


ParentPen

Steema.TeeChart.Styles.Polygon.ParentPen プロパティ

Trueに設定すると、多角形は親系列と同じペンを使用します。Falseの場合、多角形は独自のPenプロパティを使用します。

public Boolean ParentPen {get; set;}

解説

Trueに設定すると、多角形は親系列と同じペンを使用します。Falseの場合、多角形は独自のPenプロパティを使用します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


ParentSeries

Steema.TeeChart.Styles.Polygon.ParentSeries プロパティ

public Map ParentSeries {get; set;}

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Polygon.Pen プロパティ

多角形の枠を描くペンを設定します。
public ChartPen Pen {get; set;}

解説

多角形の枠を描くペンを設定します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Points

Steema.TeeChart.Styles.Polygon.Points プロパティ

多角形の境界を定義するPointList座標にアクセスします。

public PolygonSeries Points {get; set;}

解説

多角形の境界を定義する PointList座標にアクセスします。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Text

Steema.TeeChart.Styles.Polygon.Text プロパティ

多角形のラベルに表示する文字列を指定します。

public String Text {get; set;}

解説

多角形のラベルに表示する文字列を指定します。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Transparency

Steema.TeeChart.Styles.Polygon.Transparency プロパティ

多角形を塗りつぶす透明度を設定します。このプロパティが0の場合、前面のみが表示されます。このプロパティが100の場合、背面のみが表示されます。

public Int32 Transparency {get; set;}

解説

多角形を塗りつぶす透明度を設定します。このプロパティが0の場合、前面のみが表示されます。このプロパティが100の場合、背面のみが表示されます。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Z

Steema.TeeChart.Styles.Polygon.Z プロパティ

3Dマップ系列のZ軸の位置を設定します。チャートによってZ平面位置を設定し、Z値の低い順から前面に描画されます。マップ系列は2Dで表示され、Z値を多角形（例：人口統計学用のマップ）の値に使用します。カラーパレットを使用すると、Z値は多角形の色に設定されます。

public Double Z {get; set;}

解説

3Dマップ系列のZ軸の位置を設定します。チャートによってZ平面位置を設定し、Z値の低い順から前面に描画されます。
マップ系列は2Dで表示され、Z値を多角形（例：人口統計学用のマップ）の値に使用します。カラーパレットを使用すると、Ｚ値は多角形の色に設定されます。

参照

Polygon クラス | Polygon メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonList

Steema.TeeChart.Styles.PolygonList クラス

ValueListオブジェクトのコレクション。

この型のすべてのメンバの一覧については、PolygonList メンバを参照してください。

System.Object
System.Collections.CollectionBase
[Serializable]
public class PolygonList : CollectionBase , IList
, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ：TeeChart.dll

参照

PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonList 全メンバ

PolygonList 概要

コンストラクタ

Constructor

パブリック メソッド

Add
AddRange
Assign
IndexOf
RemoveRange

パブリック プロパティ

Item |
Item |
Owner | PolygonListを所有するマップ系列を返します。

参照

PolygonList クラス | Steema.TeeChart.Styles 名前空間


PolygonList コンストラクタ

Steema.TeeChart.Styles.PolygonList コンストラクタ

public PolygonList(Map MapSeries)

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonList メソッド

パブリック メソッド

Add
AddRange
Assign
IndexOf
RemoveRange

参照

PolygonList クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.PolygonList.Add メソッド

public Int32 Add(Polygon value)

解説

Polygon配列の終わりに新しい多角形を追加します。新しく追加した多角形を返します。

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


AddRange

Steema.TeeChart.Styles.PolygonList.AddRange メソッド

public Void AddRange(ICollection c)

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Assign

Steema.TeeChart.Styles.PolygonList.Assign メソッド

public Void Assign(PolygonList Value)

解説

すべてのプロパティをPoltgonListから他のPoltgonListに割り当てます。

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


IndexOf

Steema.TeeChart.Styles.PolygonList.IndexOf メソッド

public Int32 IndexOf(Series s)

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


OnClear

Steema.TeeChart.Styles.PolygonList.OnClear メソッド

protected abstract Void OnClear()

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


RemoveRange

Steema.TeeChart.Styles.PolygonList.RemoveRange メソッド

public Void RemoveRange(Int32 index,
     Int32 count)

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonList プロパティ

パブリック プロパティ

Item |
Item |
Owner | PolygonListを所有するマップ系列を返します。

参照

PolygonList クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.PolygonList.Item プロパティ

public Polygon Item(String AName) {get;}

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Owner

Steema.TeeChart.Styles.PolygonList.Owner プロパティ

PolygonListを所有するマップ系列を返します。

public Map Owner {get; set;}

解説

PolygonListを所有するマップ系列を返します。

参照

PolygonList クラス | PolygonList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries

Steema.TeeChart.Styles.PolygonSeries クラス

多角形系列はSeriesの継承系列です。 マップ系列で描画される多角形シェープを定義するためには、多角形系列を使用してください。多角形系列には、多角形の境界を定義するポイント座標があります。このクラスは、ポイントのValueListと各マップ系列のサブ系列（各多角形はチャート系列です）の個別の特性を記憶します。マップ系列が多角形を系列の内部コレクションとして扱うので、各多角形を系列として処理する必要はありません。

この型のすべてのメンバの一覧については、PolygonSeries メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class PolygonSeries : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries 全メンバ

PolygonSeries 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
Polygon |
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPolygon
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolygonSeries クラス | Steema.TeeChart.Styles 名前空間


PolygonSeries コンストラクタ

Steema.TeeChart.Styles.PolygonSeries コンストラクタ

オーバーロードの一覧

public PolygonSeries(Steema.TeeChart.Chart)
public PolygonSeries()

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


PolygonSeries コンストラクタ

Steema.TeeChart.Styles.PolygonSeries コンストラクタ

public PolygonSeries(Chart c)

参照

PolygonSeries コンストラクタのオーバーロードの一覧 | PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


PolygonSeries コンストラクタ

Steema.TeeChart.Styles.PolygonSeries コンストラクタ

public PolygonSeries()

参照

PolygonSeries コンストラクタのオーバーロードの一覧 | PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

PolygonSeries クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPolygon
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

PolygonSeries クラス | Steema.TeeChart.Styles 名前空間


iPolygon

Steema.TeeChart.Styles.PolygonSeries.iPolygon フィールド

protected internal Polygon iPolygon

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
Polygon |
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

PolygonSeries クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.PolygonSeries.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.PolygonSeries.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Polygon

Steema.TeeChart.Styles.PolygonSeries.Polygon メソッド

public Polygon Polygon()

解説

マップ系列で指定した多角形のポイント座標、Z座標、形式プロパティ（Brush、Color、Penなど）のクラスを返します。

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.PolygonSeries.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


SetActive

Steema.TeeChart.Styles.PolygonSeries.SetActive メソッド

protected abstract Void SetActive(Boolean value)

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


SetSeriesColor

Steema.TeeChart.Styles.PolygonSeries.SetSeriesColor メソッド

protected abstract Void SetSeriesColor(Color value)

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonSeries プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Seriesの継承元) | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

PolygonSeries クラス | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.PolygonSeries.Pen プロパティ

public ChartPen Pen {get; set;}

解説

多角形の枠を描くペンを設定します。

参照

PolygonSeries クラス | PolygonSeries メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.PolygonStyle

Steema.TeeChart.Styles.PolygonStyle 列挙体

マップ領域の座標スタイルを設定します。

[Serializable]
public sealed enum PolygonStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Poly | 多角形。多角形の領域を表す3つ以上の座標を取得します。
Rect | 矩形。4つの座標（x1, y1, x2, y2）を取得します。
Circle | 円。3つの座標（中心x、中心y、半径）を取得します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid

Steema.TeeChart.Styles.Pyramid クラス

ピラミッド系列。

この型のすべてのメンバの一覧については、Pyramid メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Pyramid : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid 全メンバ

Pyramid 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward | 系列が昇順あるいは降順のどちらでポイントを描画する必要があるかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ピラミッド系列のブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ペン特性のエレメント。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SizePercent | チャート軸に接しているピラミッドのベースサイズを設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Pyramid クラス | Steema.TeeChart.Styles 名前空間


Pyramid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid コンストラクタ

オーバーロードの一覧

public Pyramid(Steema.TeeChart.Chart)
public Pyramid()

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Pyramid コンストラクタ

Steema.TeeChart.Styles.Pyramid コンストラクタ

public Pyramid(Chart c)

参照

Pyramid コンストラクタのオーバーロードの一覧 | Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Pyramid コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid コンストラクタ

public Pyramid()

参照

Pyramid コンストラクタのオーバーロードの一覧 | Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Pyramid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Pyramid クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward | 系列が昇順あるいは降順のどちらでポイントを描画する必要があるかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Seriesの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Seriesの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Pyramid クラス | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Pyramid.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Pyramid.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


DrawValuesForward

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.DrawValuesForward メソッド

系列が昇順あるいは降順のどちらでポイントを描画する必要があるかを返します。

public virtual Boolean DrawValuesForward()

解説

系列が昇順あるいは降順のどちらでポイントを描画する必要があるかを返します。
たとえば、水平軸のInvertedプロパティがtrueの場合、一部の系列は降順でポイントを描画する必要があります。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Pyramid.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Pyramid.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Pyramid プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ピラミッド系列のブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | ペン特性のエレメント。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SizePercent | チャート軸に接しているピラミッドのベースサイズを設定します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Pyramid クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Pyramid.Brush プロパティ

ピラミッド系列のブラシ特性を設定します。
public ChartBrush Brush {get;}

解説

ピラミッド系列のブラシ特性を設定します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Pyramid.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Pyramid.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get;}

解説

ピラミッド系列のペン特性を設定します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


SizePercent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Pyramid.SizePercent プロパティ

チャート軸に接しているピラミッドのベースサイズを設定します。

public Int32 SizePercent {get; set;}

解説

デフォルト値：50

チャート軸に接しているピラミッドのベースサイズを設定します。

参照

Pyramid クラス | Pyramid メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar

Steema.TeeChart.Styles.Radar クラス

レーダー系列。

この型のすべてのメンバの一覧については、Radar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
public class Radar : CustomPolar , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Radar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar 全メンバ

Radar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Radar クラス | Steema.TeeChart.Styles 名前空間


Radar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar コンストラクタ

オーバーロードの一覧

public Radar()
public Radar(Steema.TeeChart.Chart)

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


Radar コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar コンストラクタ

public Radar()

参照

Radar コンストラクタのオーバーロードの一覧 | Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


Radar コンストラクタ

Steema.TeeChart.Styles.Radar コンストラクタ

public Radar(Chart c)

参照

Radar コンストラクタのオーバーロードの一覧 | Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Radar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Radar クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (CustomPolarの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Radar クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


GetCircleLabel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar.GetCircleLabel メソッド

protected virtual String GetCircleLabel(Double angle,
     Int32 index)

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


GetXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar.GetXValue メソッド

protected virtual Double GetXValue(Int32 valueIndex)

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Radar.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Radar.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Radar プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Radar クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Radar.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Radar クラス | Radar メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko

Steema.TeeChart.Styles.Renko クラス

練行足チャート金融インジケータ。

この型のすべてのメンバの一覧については、Renko メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
public class Renko : Custom , IComponent, IDisposable, ICloneable

解説

練行足チャートはトレンド系のテクニックです。これは日本語の「レンガ」が語源です。練行足チャートでは、あらかじめ一定の値幅（箱の大きさと同じ）を決めておき、その値幅を満たす値動き（常に箱の大きさと同じ）があった場合のみ、その前の箱に対する値動き方向にレンガが描画されます。

練行足チャートは常に終値に基づいています。練行足のレンガはその日の終値と前のレンガ（高いか安い）と比較した後に描画されます。「箱の大きさ」が指定されます。この箱の大きさは、箱を表示するかどうかを決める最低値動きを表します。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Renko メンバ | Steema.TeeChart.Styles 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.Renko 全メンバ

Renko 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BoxSize | 練行足チャートのボックスサイズを取得/設定します。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | 取引の終値です。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSwingColor | ダウントレンドの色を取得/設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSwingColor | アップトレンドの色を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Renko クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko コンストラクタ

オーバーロードの一覧

public Renko()
public Renko(Steema.TeeChart.Chart)

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko コンストラクタ

public Renko()

参照

Renko コンストラクタのオーバーロードの一覧 | Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko コンストラクタ

public Renko(Chart c)

参照

Renko コンストラクタのオーバーロードの一覧 | Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Renko クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Renko クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Customの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue |
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue |
MinYValue |
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Customの継承元) |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Customの継承元) |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds (Customの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Customの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Renko クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.Renko.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

Steema.TeeChart.Styles.Renko.CountLegendItems メソッド

protected internal abstract Int32 CountLegendItems()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Renko.Draw メソッド

public override Void Draw()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

Steema.TeeChart.Styles.Renko.LegendItemColor メソッド

protected internal abstract Color LegendItemColor(Int32 index)

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Renko.LegendString メソッド

public override String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.Renko.MaxXValue メソッド

public override Double MaxXValue()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

Steema.TeeChart.Styles.Renko.MaxYValue メソッド

public override Double MaxYValue()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

Steema.TeeChart.Styles.Renko.MinXValue メソッド

public override Double MinXValue()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

Steema.TeeChart.Styles.Renko.MinYValue メソッド

public override Double MinYValue()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.Renko.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Renko.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Renko プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BoxSize | 練行足チャートのボックスサイズを取得/設定します。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
CloseValues | 取引の終値です。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DownSwingColor | ダウントレンドの色を取得/設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UpSwingColor | アップトレンドの色を取得/設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Renko クラス | Steema.TeeChart.Styles 名前空間


BoxSize

Steema.TeeChart.Styles.Renko.BoxSize プロパティ

練行足チャートのボックスサイズを取得/設定します。
public Double BoxSize {get; set;}

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


CloseValues

Steema.TeeChart.Styles.Renko.CloseValues プロパティ

取引の終値です。
public ValueList CloseValues {get;}

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Renko.Description プロパティ

public override String Description {get;}

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


DownSwingColor

Steema.TeeChart.Styles.Renko.DownSwingColor プロパティ

ダウントレンドの色を取得/設定します。
public Color DownSwingColor {get; set;}

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


UpSwingColor

Steema.TeeChart.Styles.Renko.UpSwingColor プロパティ

アップトレンドの色を取得/設定します。
public Color UpSwingColor {get; set;}

参照

Renko クラス | Renko メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series

Steema.TeeChart.Styles.Series クラス

すべてのTeeChart系列型の基本クラス。

この型のすべてのメンバの一覧については、Series メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class Series : TeeBase , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series 全メンバ

Series 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click | 系列ポイントをマウスでクリックした際に発生します。
DblClick | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

AutoDepth | 内部使用の定数フィールド。
AutoZOrder | 内部使用の定数フィールド。
bBrush |
GetHorizAxis | 系列に関連している水平軸を返します。
GetVertAxis | 系列に関連している垂直軸を返します。
HasZValues | 系列がZ値を持っている場合trueを返します。
mandatory |
manualData |
notMandatory |
UseAxis | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 指定したパラメーターでポイントを追加します。
AddNull | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignDispose |
AssignFormat |
AssignValues | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate | ポイントを追加後に一度で関数を再計算します。
CalcPosValue | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
ChangeType | 指定した系列オブジェクトを他のクラスの新しい系列オブジェクトに変更します。
CheckDataSource | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone | 指定した系列を新しい系列として複製します。
CreateNewSeries | 新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。
Delete | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列のデータソースを有効にします。
LegendString | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
NewFromType | 既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
PrepareForGallery |
RefreshSeries | すべての関連する系列のポイントを再計算します。
Repaint | 強制的にチャートを再描画します。
SetNull | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor | 指定したインデックスのポイントの色を返します。
ValueMarkText | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource |
XScreenToValue | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 異なる色で系列ポイントを描画します。
ColorEachPoint | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember | データソースのColorフィールドを取得/設定します。
Colors | 系列のための色の配列にアクセスします。
Count | 系列内のポイント数を返します。
Cursor | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis | 系列に関連付ける垂直カスタム軸を設定します。
DataSource | 系列にロードさせるデータソースを設定します。
DefaultNullValue | 系列内のヌル値として使用される値を設定/返します。
Depth | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ | 内部使用。
FirstVisibleIndex | 系列の最初の可視ポイントのインデックスを返します。
Function | 値を計算する関数オブジェクトを設定します。
HorizAxis | 系列に関連付ける水平軸を設定します。
Item | ポイント特性。
LabelMember | データソースのラベルフィールドを取得/設定します。
Labels | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex | 系列の最後の可視ポイントのインデックスを返します。
Marks | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ | 内部使用。
NumGallerySeries | 内部使用。
PercentFormat | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData |
ShowInLegend | 凡例に系列のタイトルを表示します。
StartZ | 内部使用。
Title | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat | ポイント値を表示するための書式を設定します。
ValuesLists | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis | 系列に関連付ける垂直軸を設定します。
Visible | 系列を表示/非表示にします。
XValues | 水平ポイント位置を設定する値。
YValues | 垂直ポイント位置を設定する値。
ZOrder | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint
bActive
bColorEach
calcVisiblePoints
DrawBetweenPoints
firstVisible
InternalUse (TeeBaseの継承元)
lastVisible
sLabels
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor
vxValues
vyValues
yMandatory

プロテクト メソッド

AddChartValue |
Added |
AddSampleValues |
AddValues |
AssociatedToAxis |
CalcDepthPositions |
CalcFirstLastPage |
CalcHorizMargins |
CalculateMarkPosition |
CalcVerticalMargins |
CalcZOrder |
CanAddRandomPoints |
CheckMouse |
ClearLists |
CountLegendItems |
CreateSubGallery |
Dispose |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues |
DoGetSeriesMark |
DrawLegendShape |
DrawMark |
DrawMarks |
DrawMarksSeries |
DrawSeriesForward |
GetBounds |
GetDataSource |
GetDefaultColor |
GetMarkText |
GetOriginValue |
GetSeriesColor |
InternalColor |
LegendItemColor |
LegendToValueIndex |
MoreSameZOrder | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent |
NumSampleValues |
OnDisposing |
PaintLegend |
PrepareLegendCanvas |
RandomBounds |
RecalcGetAxis |
SameClass | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor |
SetStringProperty (TeeBaseの継承元) |
SetValueList |
ShouldSerializeColors |
ShouldSerializeLabels |
ValueListOfAxis |

参照

Series クラス | Steema.TeeChart.Styles 名前空間


Series コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series コンストラクタ

オーバーロードの一覧

protected Series(Steema.TeeChart.Chart)

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public Series(System.ComponentModel.IContainer)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Series コンストラクタ

Steema.TeeChart.Styles.Series コンストラクタ

protected Series(Chart c)

参照

Series コンストラクタのオーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Series コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series コンストラクタ

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public Series(IContainer container)

参照

Series コンストラクタのオーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series イベント

パブリック イベント

AfterDrawValues | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click | 系列ポイントをマウスでクリックした際に発生します。
DblClick | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Series クラス | Steema.TeeChart.Styles 名前空間


AfterDrawValues

Steema.TeeChart.Styles.Series.AfterDrawValues イベント

すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
public PaintChartEventHandler  AfterDrawValues

解説

すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


BeforeDrawValues

Steema.TeeChart.Styles.Series.BeforeDrawValues イベント

すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
public PaintChartEventHandler  BeforeDrawValues

解説

すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Click

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Click イベント

このイベントは、系列ポイントがクリックされた際に発生します。

public MouseEventHandler  Click

解説

TChartSeriesコンポーネントは、ユーザが系列ポイントをクリックすると通知します。各TChartのSeriesコンポーネントは、マウス座標がポイントの画面領域上にあるかどうか計算します。例えば、円系列のポイント領域はパイスライスです。バー系列はクリックされたバー領域を検地します。ValueIndexパラメーターは系列のポイントのインデックスです。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DblClick

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DblClick イベント

チャート上をマウスでダブルクリックした際に発生します。

public MouseEventHandler  DblClick

解説

このイベントは、ユーザがチャート上でダブルクリックすると発生します。Senderパラメーターはこのイベントを発生させたチャートコンポーネントを指定します。

例

[C#]

private void Form1_DoubleClick(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.TChart)sender).Enabled = true;
     MessageBox.Show("You've double-clicked the Chart!!");
}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetSeriesMark

Steema.TeeChart.Styles.Series.GetSeriesMark イベント

各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
public GetSeriesMarkEventHandler  GetSeriesMark

解説

各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MouseEnter

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MouseEnter イベント

マウスカーソルが系列のポイントに｢触れる｣と発生します。

public EventHandler  MouseEnter

解説

このイベントは、マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeaveイベントは、マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MouseLeave

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MouseLeave イベント

マウスカーソルが系列のポイントから｢離れる｣と発生します。

public EventHandler  MouseLeave

解説

このイベントは、マウスカーソルが系列のポイントから「離れる」と発生します。
MouseEnterイベントは、マウスカーソルが系列のポイントに「触れる」と発生します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series フィールド

パブリック フィールド

AutoDepth | 内部使用の定数フィールド。
AutoZOrder | 内部使用の定数フィールド。
bBrush |
GetHorizAxis | 系列に関連している水平軸を返します。
GetVertAxis | 系列に関連している垂直軸を返します。
HasZValues | 系列がZ値を持っている場合trueを返します。
mandatory |
manualData |
notMandatory |
UseAxis | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint
bActive
bColorEach
calcVisiblePoints
DrawBetweenPoints
firstVisible
InternalUse (TeeBaseの継承元)
lastVisible
sLabels
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor
vxValues
vyValues
yMandatory

参照

Series クラス | Steema.TeeChart.Styles 名前空間


AllowSinglePoint

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AllowSinglePoint フィールド

protected internal Boolean AllowSinglePoint

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AutoDepth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AutoDepth フィールド

内部使用の定数フィールド。

public Int32 AutoDepth

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AutoZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AutoZOrder フィールド

内部使用の定数フィールド。

public Int32 AutoZOrder

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


bActive

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.bActive フィールド

protected internal Boolean bActive

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


bBrush

Steema.TeeChart.Styles.Series.bBrush フィールド

public ChartBrush bBrush

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


bColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.bColorEach フィールド

protected Boolean bColorEach

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


calcVisiblePoints

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.calcVisiblePoints フィールド

protected Boolean calcVisiblePoints

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawBetweenPoints

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DrawBetweenPoints フィールド

protected Boolean DrawBetweenPoints

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


firstVisible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.firstVisible フィールド

protected internal Int32 firstVisible

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetHorizAxis

Steema.TeeChart.Styles.Series.GetHorizAxis フィールド

系列に関連している水平軸を返します。
public Axis GetHorizAxis

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetVertAxis

Steema.TeeChart.Styles.Series.GetVertAxis フィールド

系列に関連している垂直軸を返します。
public Axis GetVertAxis

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


HasZValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.HasZValues フィールド

系列がZ値を持っている場合trueを返します。

public Boolean HasZValues

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


lastVisible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.lastVisible フィールド

protected internal Int32 lastVisible

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


mandatory

Steema.TeeChart.Styles.Series.mandatory フィールド

public ValueList mandatory

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


manualData

Steema.TeeChart.Styles.Series.manualData フィールド

public Boolean manualData

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


notMandatory

Steema.TeeChart.Styles.Series.notMandatory フィールド

public ValueList notMandatory

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


sLabels

Steema.TeeChart.Styles.Series.sLabels フィールド

protected internal StringList sLabels

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


UseAxis

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.UseAxis フィールド

系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

public Boolean UseAxis

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


UseSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.UseSeriesColor フィールド

protected internal Boolean UseSeriesColor

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


vxValues

Steema.TeeChart.Styles.Series.vxValues フィールド

protected internal ValueList vxValues

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


vyValues

Steema.TeeChart.Styles.Series.vyValues フィールド

protected internal ValueList vyValues

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


yMandatory

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.yMandatory フィールド

protected internal Boolean yMandatory

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series メソッド

パブリック メソッド

Add | 指定したパラメーターでポイントを追加します。
AddNull | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignDispose |
AssignFormat |
AssignValues | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate | ポイントを追加後に一度で関数を再計算します。
CalcPosValue | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
ChangeType | 指定した系列オブジェクトを他のクラスの新しい系列オブジェクトに変更します。
CheckDataSource | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone | 指定した系列を新しい系列として複製します。
CreateNewSeries | 新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。
Delete | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | 系列のデータソースを有効にします。
LegendString | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値リストの最大値を返します。
MaxYValue | 系列のY値リストの最大値を返します。
MaxZValue | Z値の最大値を返します。
MinXValue | 系列のX値リストの最小値を返します。
MinYValue | 系列のY値リストの最小値を返します。
MinZValue | Z値の最小値を返します。
NewFromType | 既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
PrepareForGallery |
RefreshSeries | すべての関連する系列のポイントを再計算します。
Repaint | 強制的にチャートを再描画します。
SetNull | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor | 指定したインデックスのポイントの色を返します。
ValueMarkText | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource |
XScreenToValue | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue |
Added |
AddSampleValues |
AddValues |
AssociatedToAxis |
CalcDepthPositions |
CalcFirstLastPage |
CalcHorizMargins |
CalculateMarkPosition |
CalcVerticalMargins |
CalcZOrder |
CanAddRandomPoints |
CheckMouse |
ClearLists |
CountLegendItems |
CreateSubGallery |
Dispose |
DoAfterDrawValues |
DoBeforeDrawChart |
DoBeforeDrawValues |
DoGetSeriesMark |
DrawLegendShape |
DrawMark |
DrawMarks |
DrawMarksSeries |
DrawSeriesForward |
GetBounds |
GetDataSource |
GetDefaultColor |
GetMarkText |
GetOriginValue |
GetSeriesColor |
InternalColor |
LegendItemColor |
LegendToValueIndex |
MoreSameZOrder | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent |
NumSampleValues |
OnDisposing |
PaintLegend |
PrepareLegendCanvas |
RandomBounds |
RecalcGetAxis |
SameClass | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor |
SetStringProperty (TeeBaseの継承元) |
SetValueList |
ShouldSerializeColors |
ShouldSerializeLabels |
ValueListOfAxis |

参照

Series クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

オーバーロードの一覧

IListインターフェイスを実装するオブジェクトのコレクションを追加します。

public Void Add(System.Collections.IList)

IDataReaderインターフェイスを実装するデータセットを追加します。

public Void Add(System.Data.IDataReader)

DataTableを追加します。

public abstract Void Add(System.Data.DataTable)

DataViewを追加します。

public abstract Void Add(System.Data.DataView)

指定したDateTimeの「x」と倍精度浮動小数点値の「y」で新しいポイントを追加します。

public Int32 Add(System.DateTime, System.Double)

指定したDateTimeの「x」とDateTimeの「y」で新しいポイントを追加します。

public Int32 Add(System.DateTime, System.DateTime)

指定したDateTimeの「x」、倍精度浮動小数点値の「y」、色で新しいポイントを追加します。

public Int32 Add(System.DateTime, System.Double, System.Drawing.Color)

指定したDateTimeの「x」、倍精度浮動小数点値の「y」、テキストで新しいポイントを追加します。

public Int32 Add(System.DateTime, System.Double, System.String)

新しいnull（透明）ポイントを追加します。

public Int32 Add()

指定した値で新しいポイントを追加します。

public Int32 Add(System.Int32)

指定した値で新しいポイントを追加します。

public Int32 Add(System.Double)

指定した値で新しいポイントを追加します。

public Int32 Add(System.Int64)

整数の配列を追加します。

public Void Add(System.Int64[])

指定した値で新しいポイントを追加します。

public Int32 Add(System.Single)

指定した値とテキストで新しいポイントを追加します。

public Int32 Add(System.Double, System.String)

指定したx値、y値で新しいポイントを追加します。

public Int32 Add(System.Double, System.Double)

xとyのピクセル座標を追加します。

public Int32 Add(System.Drawing.PointF)

指定したx値、y値、テキストで新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.String)

指定したx値、y値、テキスト、色で新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.String, System.Drawing.Color)

系列に新しいDatetimeポイント、ラベル、色を追加します。

public Int32 Add(System.DateTime, System.Double, System.String, System.Drawing.Color)

指定したx値、y値、色で新しいポイントを追加します。

public Int32 Add(System.Double, System.Double, System.Drawing.Color)

指定した値、テキスト、色で新しいポイントを追加します。

public Int32 Add(System.Double, System.String, System.Drawing.Color)

指定した値と色で新しいポイントを追加します。

public Int32 Add(System.Double, System.Drawing.Color)

指定したテキストで新しいnullポイントを追加します。

public Int32 Add(System.String)

ソース系列にすべてのポイントを追加します。

public Void Add(Steema.TeeChart.Styles.Series)

XとYの配列を追加します。

public Void Add(System.Array, System.Array)

倍精度浮動小数点値の配列を追加します。

public Void Add(System.Double[])

浮動小数点値の配列を追加します。

public Void Add(System.Single[])

整数値の配列を追加します。

public Void Add(System.Int32[])

解説

系列に新しいポイントあるいは配列を追加するために使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

IListインターフェイスを実装するオブジェクトのコレクションを追加します。
public Void Add(IList list)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

IDataReaderインターフェイスを実装するデータセットを追加します。
public Void Add(IDataReader r)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

DataTableを追加します。
public abstract Void Add(DataTable table)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

DataViewを追加します。
public abstract Void Add(DataView view)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したDateTimeの「x」と倍精度浮動小数点値の「y」で新しいポイントを追加します。
public Int32 Add(DateTime x,
     Double y)

戻り値

追加したポイントのValueListのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したDateTimeの「x」とDateTimeの「y」で新しいポイントを追加します。
public Int32 Add(DateTime x,
     DateTime y)

戻り値

追加したポイントのValueListのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したDateTimeの「x」、倍精度浮動小数点値の「y」、色で新しいポイントを追加します。
public Int32 Add(DateTime x,
     Double y,
     Color c)

戻り値

追加したポイントのValueListのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したDateTimeの「x」、倍精度浮動小数点値の「y」、テキストで新しいポイントを追加します。
public Int32 Add(DateTime x,
     Double y,
     String text)

戻り値

追加したポイントのValueListのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

新しいnull（透明）ポイントを追加します。
public Int32 Add()

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値で新しいポイントを追加します。
public Int32 Add(Int32 value)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値で新しいポイントを追加します。
public Int32 Add(Double value)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値で新しいポイントを追加します。
public Int32 Add(Int64 value)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

整数の配列を追加します。
public Void Add(Int64[] values)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値で新しいポイントを追加します。
public Int32 Add(Single value)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値とテキストで新しいポイントを追加します。
public Int32 Add(Double value,
     String text)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したx値、y値で新しいポイントを追加します。
public Int32 Add(Double x,
     Double y)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

xとyのピクセル座標を追加します。
public Int32 Add(PointF p)

戻り値

追加したポイントのValueListのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したx値、y値、テキストで新しいポイントを追加します。
public Int32 Add(Double x,
     Double y,
     String text)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したx値、y値、テキスト、色で新しいポイントを追加します。
public Int32 Add(Double x,
     Double y,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

系列に新しいDatetimeポイント、ラベル、色を追加します。
public Int32 Add(DateTime aDate,
     Double y,
     String text,
     Color color)

パラメーター

aDate
日付時間値
y
Y値
text
ポイントのテキスト
color
ポイントの色

戻り値

追加したポイントのインデックス。

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したx値、y値、色で新しいポイントを追加します。
public Int32 Add(Double x,
     Double y,
     Color color)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値、テキスト、色で新しいポイントを追加します。
public Int32 Add(Double value,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定した値と色で新しいポイントを追加します。
public Int32 Add(Double value,
     Color color)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

指定したテキストで新しいnullポイントを追加します。
public Int32 Add(String text)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

ソース系列にすべてのポイントを追加します。
public Void Add(Series source)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

XとYの配列を追加します。
public Void Add(Array xValues,
     Array yValues)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

倍精度浮動小数点値の配列を追加します。
public Void Add(Double[] values)
系列に整数の配列を追加するために、このメソッドを使用してください。配列はY値を含んでおり、X値は自動的に増加されます。

例
private void button1_Click(object sender, System.EventArgs e)
{
int[] myVals = new int[5] {1, 2, 3, 4, 5};

line1.Add(myVals);
}

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

浮動小数点値の配列を追加します。
public Void Add(Single[] values)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Series.Add メソッド

整数値の配列を追加します。
public Void Add(Int32[] values)

参照

Add オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AddChartValue

Steema.TeeChart.Styles.Series.AddChartValue メソッド

protected internal Int32 AddChartValue(Series source,
     Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Added

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Added メソッド

protected internal virtual Void Added()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AddNull

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AddNull メソッド

このメソッドの代わりに、パラメーターなしでAddメソッドを使用してください。

public Int32 AddNull()

旧式

このメソッドの代わりに、パラメーターなしでAddメソッドを使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AddNullXY

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AddNullXY メソッド

このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。

public Int32 AddNullXY(Double x,
     Double y)

旧式

このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AddValues

Steema.TeeChart.Styles.Series.AddValues メソッド

protected abstract Void AddValues(Array source)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Assign

Steema.TeeChart.Styles.Series.Assign メソッド

指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
public Void Assign(Series source)

解説

指定した系列コンポーネントから他のコンポーネントへ全てのプロパティをコピーします。
これは、コピー元とコピー先の共有するプロパティのみコピーされます。

以下のコードは、Series2からSeries1に全てのプロパティをコピーします。

Series1.Assign( Series2 ) ;

一部の系列型は、プロパティを割り当てた後に、プロパティ値を初期化します。たとえば、リボン系列のPointer.Visibleプロパティのデフォルトはfalseになっていますが、このリボン系列を散布図系列にプロパティをコピーした後は、Pointer.Visibleプロパティはtrueに初期化されます。

メモ：系列のイベントは割り当てられませんが、系列のDataSourceプロパティやFunctionTypeプロパティは割り当てられます。
Assignは、たとえばCloneChartSeriesメソッドやChangeSeriesTypeメソッドにより使用されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AssignDispose

Steema.TeeChart.Styles.Series.AssignDispose メソッド

public static Void AssignDispose(Series& s,
     Series newSeries)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.Series.AssignFormat メソッド

public abstract Void AssignFormat(Series source)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AssignValues

Steema.TeeChart.Styles.Series.AssignValues メソッド

ソース系列から全ての値を追加します。
public Void AssignValues(Series source)

解説

指定した系列から現在の系列に全ての値を割り当てます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


AssociatedToAxis

Steema.TeeChart.Styles.Series.AssociatedToAxis メソッド

protected internal abstract Boolean AssociatedToAxis(Axis a)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


BeginUpdate

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.BeginUpdate メソッド

ポイントを追加後に一度で関数を再計算します。

public Void BeginUpdate()

解説

ポイントを追加後に一度で関数を再計算します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcDepthPositions

Steema.TeeChart.Styles.Series.CalcDepthPositions メソッド

protected internal abstract Void CalcDepthPositions()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcFirstLastPage

Steema.TeeChart.Styles.Series.CalcFirstLastPage メソッド

protected internal Void CalcFirstLastPage(Int32& First,
     Int32& Last)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcHorizMargins メソッド

protected internal virtual Void CalcHorizMargins(Int32& leftMargin,
     Int32& rightMargin)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcPosValue メソッド

「Value」パラメーターの座標位置をピクセル単位で返します。

public Int32 CalcPosValue(Double value)

解説

軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalculateMarkPosition

Steema.TeeChart.Styles.Series.CalculateMarkPosition メソッド

protected Void CalculateMarkPosition(TextShape shape,
     String aText,
     Int32 xPos,
     Int32 yPos,
     Position position)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcVerticalMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcVerticalMargins メソッド

protected internal virtual Void CalcVerticalMargins(Int32& topMargin,
     Int32& bottomMargin)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcXPos メソッド

ValueIndexの系列値の水平画面座標をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 index)

解説

ValueIndexの系列値の水平画面座標をピクセル単位で返します。

この座標値は水平軸に関連した系列を使用して計算されます。

例

系列ポイントの水平画面座標を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcXPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcXPosValue メソッド

指定したValueパラメーターの水平画面座標をピクセル単位で返します。

public Int32 CalcXPosValue(Double value)

解説

指定したValueパラメーターの水平画面座標をピクセル単位で返します。

この座標値は水平軸に関連した系列を使用して計算されます。

例

1234.56 の値の水平画面座標を調べる場合、以下のようになります。

int tmpX=tChart3[0].CalcXPosValue(1234.56);

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcXSizeValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcXSizeValue メソッド

水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。

public Int32 CalcXSizeValue(Double value)

解説

水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。

この座標値は、水平軸に関連した系列を使用して計算されます。

例

X値=12.1に該当する画面ピクセルサイズを調べる場合は、以下のようになります。

[C#]

int tmpX=tChart1[0].CalcXSizeValue(12.1);

これは、tmpが12.1のオフセットが必要な水平ピクセルの量であることを意味します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcYPos メソッド

ValueIndexの系列値の垂直画面座標をピクセル単位で返します。

public virtual Int32 CalcYPos(Int32 index)

解説

ValueIndexの系列値の垂直画面座標をピクセル単位で返します。

この座標値は垂直軸に関連する系列を使用して計算されます。

例

系列ポイントの垂直画面座標を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcYPosValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcYPosValue メソッド

指定したValueパラメーターの垂直画面座標をピクセル単位で返します。

public Int32 CalcYPosValue(Double value)

解説

指定したValueパラメーターの垂直画面座標をピクセル単位で返します。

この座標値は垂直軸に関連した系列を使用して計算されます。

例

[C#]
Graphics3D g = tChart3.Graphics3D;

int tmpX=tChart3[0].CalcXPosValue(4);

int tmpY=tChart3[0].CalcYPosValue(4);

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcYSizeValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcYSizeValue メソッド

垂直の軸スケール単位で指定したValueパラメーターに該当する垂直画面寸法（サイズ）をピクセル単位で返します。

public Int32 CalcYSizeValue(Double value)

解説

垂直の軸スケール単位で指定したValueパラメーターに該当する垂直画面寸法（サイズ）をピクセル単位で返します。

この座標値は垂直軸に関連した系列を使用して計算されます。

例

Y値＝5.32に該当する画面ピクセルサイズを調べる場合は、以下のようになります。

int tmpY=tChart1[0].CalcYSizeValue(5.32);

これは、tmpが5.32のオフセットが必要な垂直ピクセルの量であることを意味します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CalcZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CalcZOrder メソッド

protected internal virtual Void CalcZOrder()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CanAddRandomPoints

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CanAddRandomPoints メソッド

protected internal Boolean CanAddRandomPoints()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ChangeType

Steema.TeeChart.Styles.Series.ChangeType メソッド

指定した系列オブジェクトを他のクラスの新しい系列オブジェクトに変更します。
public static Void ChangeType(Series& s,
     Type newType)

解説

指定した系列オブジェクトを他のクラスの新しい系列オブジェクトに変更します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CheckDataSource

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CheckDataSource メソッド

データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。

public Void CheckDataSource()

解説

データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。系列にリアルタイムで新しいデータや変更されたデータを表示する場合は、このメソッドを定期的に呼び出してください。親チャートは、すべての変更を反映するように再描画されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CheckMouse

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CheckMouse メソッド

protected internal Boolean CheckMouse(Cursor& c,
     Int32 x,
     Int32 y)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CheckOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CheckOrder メソッド

X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。

public Void CheckOrder()

解説

X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
XValuesやYValuesのソートタイプがloNone以外の場合、系列ポイントのソート順を更新します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Clear メソッド

系列からすべてのポイント、テキスト、色を削除します。

public virtual Void Clear()

解説

すべての系列値を削除します。従属する系列は通知されます。新しいポイントが系列に追加されない場合、何も描画されません。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ClearLists

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ClearLists メソッド

protected virtual Void ClearLists()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのValueIndexを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)
public Int32 Clicked(System.Drawing.Point)

解説

系列で｢クリックされた｣ポイントのValueIndexを返します。「クリックされた」とは、XとY座標値が、ポイント画面領域の境界内にあることを意味します。「触れた」のポイントがなければ、Clickedは-1を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Clicked メソッド

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Clicked メソッド

public Int32 Clicked(Point p)

参照

Clicked オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Clone

Steema.TeeChart.Styles.Series.Clone メソッド

指定した系列を新しい系列として複製します。
public virtual Object Clone()

解説

指定したSeries(Seriesindex)を新しい系列として複製します。このメソッドは、新しい系列のインデックスを返します。

例

[C#]

Dim tmpindex As Integer
tmpindex = TChart1.CloneSeries(0)
TChart1.Series(tmpindex).Color = vbYellow

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ConvertArray

Steema.TeeChart.Styles.Series.ConvertArray メソッド

protected internal Double[] ConvertArray(Array a,
     Int32 numPoints)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CountLegendItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.CountLegendItems メソッド

protected internal virtual Int32 CountLegendItems()

See Also

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries メソッド

オーバーロードの一覧

新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type, System.Int32)

新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type, System.Int32, System.Object[])

新しい系列オブジェクトを作成してName、Chart、Functionプロパティを設定します。

public static Series CreateNewSeries(Steema.TeeChart.Chart, System.Type, System.Type)

解説

新しい系列オブジェクトを作成してName、Chart、Functionプロパティを設定します。

これは内部メソッドで、ほとんど使用されません。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries メソッド

新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction,
     Int32 subIndex)

参照

CreateNewSeries オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries メソッド

新しい系列オブジェクトを作成してName、Chart、Sub-Style、Functionプロパティを設定します。
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction,
     Int32 subIndex,
     Object[] initArgs)

参照

CreateNewSeries オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CreateNewSeries

Steema.TeeChart.Styles.Series.CreateNewSeries メソッド

新しい系列オブジェクトを作成してName、Chart、Functionプロパティを設定します。
public static Series CreateNewSeries(Chart chart,
     Type type,
     Type aFunction)

参照

CreateNewSeries オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Series.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Series.Delete メソッド

オーバーロードの一覧

public abstract Void Delete(System.Int32, System.Int32)

指定したインデックスから指定したポイント数を削除します。RemoveGapパラメーターがtrueの場合、ValueListのFillSequenceを呼び出します。

public abstract Void Delete(System.Int32, System.Int32, System.Boolean)

指定したインデックスのポイントを削除します。X値は変わりません。

public abstract Void Delete(System.Int32)

解説

系列値リストから指定したインデックスのポイントを削除します。チャートは自動的に再描画されます。従属系列は再計算されます。

例

リボン系列の8番目のポイントを削除する場合、以下のようになります。

tChart1[0].Delete(7)

これにより、Series(0)の系列の8番目のポイントが完全に削除されます。チャートが再描画され、従属する全ての系列（データソースがSeries(0)の系列）は、再計算され再描画されます。

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Series.Delete メソッド

public abstract Void Delete(Int32 index,
     Int32 count)

参照

Delete オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Series.Delete メソッド

Indexパラメーターのポイントから、countパラメーターのポイント数を削除します。RemoveGapパラメーターがtrueの場合、ValueListのFillSequenceメソッドを呼び出します。
public abstract Void Delete(Int32 index,
     Int32 count,
     Boolean removeGap)

参照

Delete オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Delete

Steema.TeeChart.Styles.Series.Delete メソッド

指定したインデックスのポイントを削除します。X値は変わりません。
public abstract Void Delete(Int32 index)

参照

Delete オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.Series.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DoAfterDrawValues

Steema.TeeChart.Styles.Series.DoAfterDrawValues メソッド

protected internal abstract Void DoAfterDrawValues()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DoBeforeDrawChart メソッド

protected internal virtual Void DoBeforeDrawChart()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.Series.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DoGetSeriesMark

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DoGetSeriesMark メソッド

protected Void DoGetSeriesMark(Int32 valueIndex,
     String& markText)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Series.Draw メソッド

public abstract Void Draw()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Series.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Series.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawMarks

Steema.TeeChart.Styles.Series.DrawMarks メソッド

protected abstract Void DrawMarks()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawMarksSeries

Steema.TeeChart.Styles.Series.DrawMarksSeries メソッド

protected abstract Void DrawMarksSeries(Series s,
     Boolean& ActiveRegion)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawSeries

Steema.TeeChart.Styles.Series.DrawSeries メソッド

チャートキャンバスに系列を描画します。
public Void DrawSeries()

解説

チャートキャンバスに系列を描画します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawSeriesForward

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DrawSeriesForward メソッド

protected virtual Boolean DrawSeriesForward(Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 index)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。このメソッドは系列の｢ValueIndex｣ポイントを描画します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DrawValuesForward

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DrawValuesForward メソッド

系列が昇順または降順でポイントを描画するかどうかを返します。

public virtual Boolean DrawValuesForward()

戻り値

系列の値が0からCount-1へ表示される場合、trueを返します。

解説

系列が昇順または降順でポイントを描画するかどうかを返します。
たとえば、水平軸のInvertedプロパティがTrueの場合のように、一部の系列は降順（最後のポイントから最初のポイントに向かって描く）でポイントを描画する必要があります。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


EndUpdate

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.EndUpdate メソッド

BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。

public Void EndUpdate()

解説

ソース系列に多くの値を追加/修正する場合に、ポイントの追加後に1度で計算させるために使用します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


FillSampleValues

Steema.TeeChart.Styles.Series.FillSampleValues メソッド

オーバーロードの一覧

系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。

public Void FillSampleValues()

指定したNumValuesのランダムポイントを追加します。

public abstract Void FillSampleValues(System.Int32)

解説

各系列は系列クラスを他の系列クラスあるいはデータセット（テーブル、SQL、TClientDataset）クラスに接続しない限り、デザイン時にランダムな値を描きます。

このメソッドは、系列にランダムな値を追加し、再描画します。

例

[C#]

tChart1[0].FillSampleValues (20);

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


FillSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.FillSampleValues メソッド

系列にランダムなポイントを追加します。各系列クラスはランダムなポイントを追加する数を設定します。

public Void FillSampleValues()

参照

FillSampleValues オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


FillSampleValues

Steema.TeeChart.Styles.Series.FillSampleValues メソッド

指定したNumValuesのランダムポイントを追加します。
public abstract Void FillSampleValues(Int32 numValues)

パラメーター

numValues
追加するランダム値のポイント数

参照

FillSampleValues オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


FirstDisplayedIndex

Steema.TeeChart.Styles.Series.FirstDisplayedIndex メソッド

系列を描画する際に最初に描画される系列ポイントのインデックスを返します。

public Int32 FirstDisplayedIndex()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.Series.GalleryChanged3D メソッド

public abstract Void GalleryChanged3D(Boolean Is3D)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetBitmapEditor

Steema.TeeChart.Styles.Series.GetBitmapEditor メソッド

指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
public Image GetBitmapEditor()

解説

指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Series.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetDataSource

Steema.TeeChart.Styles.Series.GetDataSource メソッド

protected internal abstract Object GetDataSource()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetDefaultColor

Steema.TeeChart.Styles.Series.GetDefaultColor メソッド

protected internal Color GetDefaultColor(Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetMarkText

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.GetMarkText メソッド

protected internal virtual String GetMarkText(Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetMarkValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.GetMarkValue メソッド

系列マーカで表示されているポイント値を返します。

public Double GetMarkValue(Int32 valueIndex)

解説

指定したインデックスに該当する系列マーカで表示されているポイント値を返します。ほとんどの系列はYValue[ ValueIndex ] を返します。しかし、横棒系列のような特定な系列は、XValueを返します。このメソッドを使用して値を取得できます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetOriginValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.GetOriginValue メソッド

protected internal virtual Double GetOriginValue(Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


GetSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.GetSeriesColor メソッド

protected virtual Color GetSeriesColor()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


InternalColor

Steema.TeeChart.Styles.Series.InternalColor メソッド

protected internal Color InternalColor(Int32 valueIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


IsNull

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.IsNull メソッド

系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null」とみなします。

public Boolean IsNull(Int32 index)

パラメーター

index
ポイントインデックス

戻り値

ポイントの色がColor.Transparentの場合、True を返します。

解説

このメソッドを使用して指定したインデックスのポイント値が「null」かどうか確認します。AddNullメソッドを参照してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Series.IsValidSourceOf メソッド

系列のデータソースを有効にします。
public abstract Boolean IsValidSourceOf(Series value)

パラメーター

value
有効にする系列。

戻り値

値が系列のデータソースの場合、trueを返します。

解説

ValueパラメーターがSelfパラメーターと同じ場合、falseを返します。
これは、デザイン時や実行時にDataSourceプロパティを有効にするために使用されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


LegendItemColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.LegendItemColor メソッド

protected internal virtual Color LegendItemColor(Int32 index)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


LegendString

Steema.TeeChart.Styles.Series.LegendString メソッド

指定したLegendIndexポイントに該当する書式化された文字列を返します。
public abstract String LegendString(Int32 legendIndex,
     LegendTextStyles legendTextStyle)

解説

指定したLegendIndexポイントに該当する書式化された文字列を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


LegendToValueIndex

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.LegendToValueIndex メソッド

protected internal virtual Int32 LegendToValueIndex(Int32 legendIndex)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MaxMarkWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MaxMarkWidth メソッド

すべての系列マーカの最大幅を返します。

public Int32 MaxMarkWidth()

解説

すべての系列マーカの最大幅を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MaxXValue メソッド

系列のX値リストの最大値を返します。

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MaxYValue メソッド

系列のY値リストの最大値を返します。

public virtual Double MaxYValue()

解説

系列のY値リストの最大値を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MaxZValue メソッド

Z値の最大値を返します。

public virtual Double MaxZValue()

解説

Z値の最大値を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MinXValue メソッド

系列のX値リストの最小値を返します。

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MinYValue メソッド

系列のY値リストの最小値を返します。

public virtual Double MinYValue()

解説

系列のY値リストの最小値を返します。複数のY値リストを持つ一部の系列では、この最小値は全ての系列のY値リスト内の最小値になります。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MinZValue メソッド

Z値の最小値を返します。

public virtual Double MinZValue()

解説

Z値の最小値を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Series.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MoreSameZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.MoreSameZOrder メソッド

同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。

protected virtual Boolean MoreSameZOrder()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MouseEvent

Steema.TeeChart.Styles.Series.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


NewFromType

Steema.TeeChart.Styles.Series.NewFromType メソッド

オーバーロードの一覧

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。

public static Series NewFromType(System.Type)

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。

public static Series NewFromType(System.Type, System.Object[])

解説

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


NewFromType

Steema.TeeChart.Styles.Series.NewFromType メソッド

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
public static Series NewFromType(Type type)

参照

NewFromType オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


NewFromType

Steema.TeeChart.Styles.Series.NewFromType メソッド

既存の系列オブジェクトのSystem.Typeから新しい系列を作成します。
public static Series NewFromType(Type type,
     Object[] initArgs)

参照

NewFromType オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


OnDisposing

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.OnDisposing メソッド

protected internal virtual Void OnDisposing()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


PaintLegend

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.PaintLegend メソッド

protected internal Void PaintLegend(Graphics g,
     Rectangle r)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Series.PrepareForGallery メソッド

public abstract Void PrepareForGallery(Boolean IsEnabled)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.Series.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


RandomBounds

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.RandomBounds メソッド

protected SeriesRandom RandomBounds(Int32 numValues)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


RecalcGetAxis

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.RecalcGetAxis メソッド

protected Void RecalcGetAxis()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


RefreshSeries

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.RefreshSeries メソッド

すべての関連する系列のポイントを再計算します。

public Void RefreshSeries()

解説

すべての関連する系列のポイントを再計算します。各系列は、DataSourceプロパティを持っています。データソースが有効なSeriesあるいはDataSetクラスの場合、系列はすべてのポイント値をデータソースから取得し、これを系列ポイントとして追加します。RefreshSeriesメソッドは、系列のすべてのポイント値をクリアし、ポイントをDataSourceクラスから再度取得します。更新処理は系列ツリーに対して再帰的に実行されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Repaint

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Repaint メソッド

強制的にチャートを再描画します。

public Void Repaint()

解説

強制的にチャートを再描画します。通常は、Repaintを直接呼び出すことはありません。これは、内部的にプロパティを変更する際、派生したTChartSeriesコンポーネント内で使用されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SameClass

Steema.TeeChart.Styles.Series.SameClass メソッド

指定したsパラメーターと同じクラスの場合、Trueを返します。
protected Boolean SameClass(Series s)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ScreenPointToValuePoint

Steema.TeeChart.Styles.Series.ScreenPointToValuePoint メソッド

軸の境界間に画面位置の該当するPointDouble値を返します。
public abstract PointDouble ScreenPointToValuePoint(Int32 x,
     Int32 y)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetActive

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SetActive メソッド

protected virtual Void SetActive(Boolean value)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Series.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SetColorEach メソッド

protected virtual Void SetColorEach(Boolean value)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetHorizontal

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SetHorizontal メソッド

protected Void SetHorizontal()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetNull

Steema.TeeChart.Styles.Series.SetNull メソッド

オーバーロードの一覧

指定した系列ポイントをnull(透明）ポイントに設定します。

public Void SetNull(System.Int32)

null（透明）ポイントあるいは普通のポイントに切り替えます。

public Void SetNull(System.Int32, System.Boolean)

解説

指定したポイントインデックスのポイントを非表示にします。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetNull

Steema.TeeChart.Styles.Series.SetNull メソッド

指定した系列ポイントをnull(透明）ポイントに設定します。
public Void SetNull(Int32 valueIndex)

参照

SetNull オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetNull

Steema.TeeChart.Styles.Series.SetNull メソッド

null（透明）ポイントあるいは普通のポイントに切り替えます。
public Void SetNull(Int32 valueIndex,
     Boolean isnull)

パラメーター

valueIndex
ポイントインデックス。
isNull
Trueの場合、nullポイントになり、Falseの場合は普通のポイントになります。

参照

SetNull オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetSeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SetSeriesColor メソッド

protected virtual Void SetSeriesColor(Color value)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Series.SetSubGallery メソッド

サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
public abstract Void SetSubGallery(Int32 index)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SetValueList

Steema.TeeChart.Styles.Series.SetValueList メソッド

protected Void SetValueList(ValueList l,
     ValueList value)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeColors

Steema.TeeChart.Styles.Series.ShouldSerializeColors メソッド

protected abstract Boolean ShouldSerializeColors()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeLabels

Steema.TeeChart.Styles.Series.ShouldSerializeLabels メソッド

protected abstract Boolean ShouldSerializeLabels()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SortByLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SortByLabels メソッド

オーバーロードの一覧

Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、「X」値は失われます（「X」値は再度番号付けされます）。

public Void SortByLabels(Steema.TeeChart.Styles.ValueListOrder)
public Void SortByLabels()

解説

系列ポイントのテキストラベルを使用して系列ポイントを再ソートします。

｢Order｣パラメーターは昇順あるいは降順に設定できます。

メモ：ラベルテキストを使用してポイントをソート後、｢X｣値は失われます。（｢X｣値は再度番号を付けられます。）
このため、ポイントをソート後はソートを戻したり、｢元に戻す｣ことはできません。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SortByLabels

Steema.TeeChart.Styles.Series.SortByLabels メソッド

ラベル（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
public Void SortByLabels(ValueListOrder order)

参照

SortByLabels オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SortByLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SortByLabels メソッド

public Void SortByLabels()

参照

SortByLabels オーバーロードの一覧 | Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


TitleOrName

Steema.TeeChart.Styles.Series.TitleOrName メソッド

旧式：このメソッドの代わりにToString()メソッドを使用してください。
public String TitleOrName()

解説

旧式：このメソッドの代わりにToString()メソッドを使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ToString

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ToString メソッド

系列のTitleプロパティに設定されている文字列を返します。

public virtual String ToString()

戻り値

系列のTitleプロパティに設定されている文字列を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValueColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ValueColor メソッド

指定したインデックスのポイントの色を返します。

public virtual Color ValueColor(Int32 valueIndex)

解説

指定したインデックスのポイントの色を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValueListOfAxis

Steema.TeeChart.Styles.Series.ValueListOfAxis メソッド

protected internal abstract ValueList ValueListOfAxis(Axis a)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValueMarkText

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ValueMarkText メソッド

指定したインデックスポイントのマーカの文字列を返します。

public String ValueMarkText(Int32 index)

解説

指定したインデックスポイントのマーカの文字列を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValuePointToScreenPoint

Steema.TeeChart.Styles.Series.ValuePointToScreenPoint メソッド

軸の境界間に値位置の該当する画面ポイント値を返します。
public abstract Point ValuePointToScreenPoint(Double x,
     Double y)

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


WriteToDataSource

Steema.TeeChart.Styles.Series.WriteToDataSource メソッド

public Void WriteToDataSource()

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


XScreenToValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.XScreenToValue メソッド

画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
public Double XScreenToValue(Int32 screenPos)

解説

画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。

例

220ピクセルの垂直画面座標の左軸の値を計算します。

[C#]

value = tChart1.Axis.Left.CalcPosPoint(220);

XScreenToValueメソッドあるいはYScreenToValueメソッドでも同じ情報を取得できます。

[C#]

value = tChart1.Series.XScreenToValue(220);

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


YScreenToValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.YScreenToValue メソッド

画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

public Double YScreenToValue(Int32 screenPos)

解説

指定した垂直画面座標に該当する数値の値を返します。値は、Series.GetVertAxisに基づいています。

例

[C#]

//マウス位置の座標を表示します。

private void tChart1_MouseMove(object sender,
System.Windows.Forms.MouseEventArgs e)
label1.Text = "(X, Y) = (" + points1.XScreenToValue(e.X)+ ", " +
points1.YScreenToValue(e.Y) + ")";

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series プロパティ

パブリック プロパティ

Active | 系列を表示/非表示にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach | 異なる色で系列ポイントを描画します。
ColorEachPoint | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember | データソースのColorフィールドを取得/設定します。
Colors | 系列のための色の配列にアクセスします。
Count | 系列内のポイント数を返します。
Cursor | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis | 系列に関連付ける垂直カスタム軸を設定します。
DataSource | 系列にロードさせるデータソースを設定します。
DefaultNullValue | 系列内のヌル値として使用される値を設定/返します。
Depth | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ | 内部使用。
FirstVisibleIndex | 系列の最初の可視ポイントのインデックスを返します。
Function | 値を計算する関数オブジェクトを設定します。
HorizAxis | 系列に関連付ける水平軸を設定します。
Item | ポイント特性。
LabelMember | データソースのラベルフィールドを取得/設定します。
Labels | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex | 系列の最後の可視ポイントのインデックスを返します。
Marks | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ | 内部使用。
NumGallerySeries | 内部使用。
PercentFormat | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData |
ShowInLegend | 凡例に系列のタイトルを表示します。
StartZ | 内部使用。
Title | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat | ポイント値を表示するための書式を設定します。
ValuesLists | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis | 系列に関連付ける垂直軸を設定します。
Visible | 系列を表示/非表示にします。
XValues | 水平ポイント位置を設定する値。
YValues | 垂直ポイント位置を設定する値。
ZOrder | 系列が描画される奥軸の位置を取得/設定します。

参照

Series クラス | Steema.TeeChart.Styles 名前空間


Active

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Active プロパティ

系列を表示/非表示にします。

public Boolean Active {get; set;}

解説

系列を表示/非表示にします。デザイン時または実行時に変更できます。非表示にした場合、すべてのポイント値が保存されているので表示する際に、再度値を設定する必要はありません。系列に関連しているチャート軸は、変更に合わせて調整するために再スケーリングされます。

例

[C#]

private void button1_Click_1(object sender, System.EventArgs e)
{
     ((Steema.TeeChart.Styles.Bar)tChart1[0]).Active =! ((Steema.TeeChart.Styles.Bar)tChart1[0]).Active;
}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Color プロパティ

系列ポイントのデフォルトの色を取得/設定します。

public Color Color {get; set;}

解説

デフォルト値：Color.Empty

系列ポイントをデフォルトの色を取得/設定します。このプロパティ値は、有効な色であればどれでも構いません。Empty色を使用してポイントを追加すると、「SeriesColor」色で描画されます。このプロパティは、系列に対応するデフォルトの色です。
新しい系列コンポーネントをチャートに配置する場合、TeeChartがこのプロパティに自由な色を指定します（同じチャートで別の系列が使用していない色）。いくつかの系列は、ColorEachPointプロパティを持っています。これをtrueに設定すると、異なる色で各ポイントを描画します。します。つまり、SeriesColorを使用しません。

また、SeriesColorは、凡例のシンボルの描画にも使用されます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ColorEach

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ColorEach プロパティ

異なる色でポイントを描画します。

public Boolean ColorEach {get; set;}

解説

デフォルト値：false。

系列ポイントの描画する色を制御します。これがfalseの場合、すべてのポイントはSeriesのSeries.Colorプロパティを使用して描画されます。trueの場合、各系列ポイントはそれぞれに該当するポイント色で「色付け」されます。ポイント色は、Series.PointColorプロパティに保持されます。ポイントがColor.Emptyの色値を持っている場合、TeeChartが定義した有効な色値がそのポイントを描画するために使用されます。

このプロパティは、デザイン時および実行時で変更できます。

例

[C#]

((Steema.TeeChart.Styles.Points)tChart1[0]).ColorEach = true;

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ColorEachPoint

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ColorEachPoint プロパティ

このプロパティの代わりにColorEachプロパティを使用してください。

public Boolean ColorEachPoint {get; set;}

旧式

このプロパティの代わりにColorEachプロパティを使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ColorMember

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ColorMember プロパティ

データソースのColorフィールドを取得/設定します。

public String ColorMember {get; set;}

解説

データソースのColorフィールドを取得/設定します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Colors

Steema.TeeChart.Styles.Series.Colors プロパティ

系列のための色の配列にアクセスします。
public ColorList Colors {get; set;}

解説

TeeChartコンポーネントのほとんどのColorプロパティは、clTeeColorの定数値を設定できます。これはDelphiのclScrollBar（あるいは 数値で-1)と同等です。
これは、clTeeColorを持つためにとても重要な機能です。
チャートの系列に新しいポイントを追加してポイントの色をclTeeColorを指定すると、各ポイントに異なる色を割り当てます（詳細はTChartのSeries.ColorEachプロパティを参照してください）。

チャートに新しい系列を配置してTChartのSeries.SerieColorプロパティにclTeeColorを設定すると、各系列に異なる色を割り当てます。
いくつかの系列型はそのPenプロパティやBrushプロパティにclTeeColorを設定できます。つまりPenプロパティやBrushプロパティに設定された色ではなく強制的に実際のポイント色を使用します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Count

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Count プロパティ

系列内のポイント数を返します。

public Int32 Count {get;}

解説

系列のポイント数を返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Cursor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Cursor プロパティ

系列ポイントにマウスカーソルが触れた際に使用されるイメージを設定します。

public Cursor Cursor {get; set;}

解説

デフォルト値：Default

系列ポイントにマウスカーソルが触れた際に使用されるイメージを設定します。各系列はマウスが動くたびにポイントの交点をマウス座標値で定義します。いろいろな種類のカーソルが利用できます。SeriesのZOrderは、クリックされた系列ポイントを計算するために系列を調べる際の順序を定義します。

カーソルタイプ:

Default デフォルトカーソル。通常はcrArrow。
AppStarting
Arrow
Cross
Hand
Help
HSplit
IBeam
No
NoMove2D
NoMoveHoriz
NoMoveVert
PanEast
PanNE
PanNorth
PanNW
PanSE
PanSouth
PanSW
PanWest
SizeAll
SizeNESW
SizeNS
SizeNWSE
SizeWE
UpArrow
VSplit
WaitCursor

例

[C#]

((Steema.TeeChart.Styles.Points)tChart1[0]).Cursor = Cursors.Hand;

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CustomHorizAxis

Steema.TeeChart.Styles.Series.CustomHorizAxis プロパティ

系列に関連付ける水平カスタム軸を設定します。
public Axis CustomHorizAxis {get; set;}

解説

チャートに新しい水平カスタム軸を追加後、カスタム軸を系列に接続するために、このプロパティを使用してください。

軸のPositionPercentプロパティなどと共に、チャートの色んな場所に軸を表示することができます。
スクロール、ズーム、軸のヒット検出も、作成したカスタム軸に適応します。
数行のコードが必要なように、拡張的な軸の作成は実行時のみ可能です。

例

[C#]

Steema.TeeChart.Axis ax;
tChart1.Axes.Custom.Add(ax = new Steema.TeeChart.Axis());
ax.Horizontal = true;
ax.RelativePosition = 50;
tChart1.Series[1].HorizAxis = Steema.TeeChart.Styles.HorizontalAxis.Custom;
tChart1.Series[1].CustomHorizAxis = ax;
ax.Title.Text="My Extra Axis";
ax.AxisPen.Color=Color.Green;

軸の色あるいは軸タイトルのような新しく作成された軸の特性を変更できます。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


CustomVertAxis

Steema.TeeChart.Styles.Series.CustomVertAxis プロパティ

系列に関連付ける垂直カスタム軸を設定します。
public Axis CustomVertAxis {get; set;}

解説

チャートに新しい垂直カスタム軸を追加後、カスタム軸を系列に接続するために、このプロパティを使用してください。

例

[C#]

この例はカスタム軸をズームする場合、オフセットの最小値や最大値がいくつズーム領域に正確に調整されるか表示します。

myVerticalCustomAxis.SetMinMax(
     myVerticalCustomAxis.CalcPosPoint (Chart1.Zoom.y1),
     myVerticalCustomAxis.CalcPosPoint(Chart1.Zoom.y0));

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DataSource

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.DataSource プロパティ

データソースを指定します。

public Object DataSource {get; set;}

解説

すべての系列は、オプションで「ポイントプロバイダ」（あるいはデータソース）に接続できます。
このプロパティが指定されない場合、ポイントはコードを追加しなければなりません。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


DefaultNullValue

Steema.TeeChart.Styles.Series.DefaultNullValue プロパティ

系列内のヌル値として使用される値を設定/返します。
public Double DefaultNullValue {get; set;}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Depth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Depth プロパティ

系列ポイントあるいは、相互を接続する線の深さを設定します。

public Int32 Depth {get; set;}

解説

系列ポイントあるいは、相互を接続する線の深さを設定します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Series.Description プロパティ

説明テキストを取得します。
public abstract String Description {get;}

解説

説明テキストを取得します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


EndZ

Steema.TeeChart.Styles.Series.EndZ プロパティ

内部使用。
public Int32 EndZ {get;}

解説

内部使用。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


FirstVisibleIndex

Steema.TeeChart.Styles.Series.FirstVisibleIndex プロパティ

系列の最初の可視ポイントのインデックスを返します。
public Int32 FirstVisibleIndex {get;}

解説

系列の最初の可視ポイントのインデックスを返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Function

Steema.TeeChart.Styles.Series.Function プロパティ

値を計算する関数オブジェクトを設定します。
public Function Function {get; set;}

解説

値を計算する関数オブジェクトを設定します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


HorizAxis

Steema.TeeChart.Styles.Series.HorizAxis プロパティ

系列に関連付ける水平軸を設定します。
public HorizontalAxis HorizAxis {get; set;}

解説

系列がどの水平軸（上軸あるいは下軸）で水平方向にスケールさせるか設定します。

例

水平軸はデザイン時や実行時に変更できます。

[C#]

tChart1[0].HorizAxis = HorizontalAxis.Top;

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.Series.Item プロパティ

ポイント特性。
public SeriesXYPoint Item(Int32 index) {get;}

解説

ポイント特性。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


LabelMember

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.LabelMember プロパティ

データソースのLabelフィールドを取得/設定します。

public String LabelMember {get; set;}

解説

データソースのLabelフィールドを取得/設定します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Labels

Steema.TeeChart.Styles.Series.Labels プロパティ

系列ポイントのラベルリストにアクセスします。
public StringList Labels {get; set;}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


LastVisibleIndex

Steema.TeeChart.Styles.Series.LastVisibleIndex プロパティ

系列の最後の可視ポイントのインデックスを返します。
public Int32 LastVisibleIndex {get;}

解説

系列の最後の可視ポイントのインデックスを返します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Marks

Steema.TeeChart.Styles.Series.Marks プロパティ

各系列ポイントの近くにマーカを描くための特性を定義します。
public SeriesMarks Marks {get; set;}

解説

各系列ポイントの近くにマーカを描くための特性を定義します。

マーカは、テキスト文字列を持つ色付きの矩形と、どのポイントがどのマーカに対応しているかを示す線から構成されています。

描画されるマーカは系列型によって異なります。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


MiddleZ

Steema.TeeChart.Styles.Series.MiddleZ プロパティ

内部使用。
public Int32 MiddleZ {get;}

解説

内部使用。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


NumGallerySeries

Steema.TeeChart.Styles.Series.NumGallerySeries プロパティ

内部使用。
public abstract Int32 NumGallerySeries {get;}

解説

内部使用。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


PercentFormat

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.PercentFormat プロパティ

パーセントとしてポイント値を表示するための書式を設定します。

public String PercentFormat {get; set;}

解説

TChartのSeriesクラスは、PercentFormatプロパティを持っています。PercentFormatは、標準的な書式文字列指定子です。これは、系列マーカのパーセントスタイルの図を描くために使用されます。ValueFormatも参照してください。

例

[C#]

tChart1[0].PercentFormat = "##0.0# %";

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SeriesColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SeriesColor プロパティ

このプロパティの代わりにSeries.Colorプロパティを使用してください。

public Color SeriesColor {get; set;}

旧式

このプロパティの代わりにSeries.Colorプロパティを使用してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


SeriesData

Steema.TeeChart.Styles.Series.SeriesData プロパティ

public String SeriesData {get; set;}

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ShowInLegend

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ShowInLegend プロパティ

凡例に系列のタイトルを表示します。

public Boolean ShowInLegend {get; set;}

解説

デフォルト値：true

系列のタイトルをChart.Legend内に表示するかどうかを制御します。これは、LegendStyleがSeriesもしくはLastValuesの場合にのみ有効です。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


StartZ

Steema.TeeChart.Styles.Series.StartZ プロパティ

内部使用。
public Int32 StartZ {get;}

解説

内部使用。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Title

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Title プロパティ

凡例やエディタ内に表示する系列のタイトルを設定します。

public String Title {get; set;}

解説

デフォルトではタイトルは空になっています。

すべての系列は、文字列型のTitleプロパティを持っています。Titleプロパティは、系列の解説を描くためにTChart.Legendで使用されます。Titleが空になっていると、凡例を描くために系列のクラス名が使用されます。デザイン時や実行時にタイトルを設定するとチャートが再描画されます。

例

[C#]

tChart1[0].Title = "Total Population";

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValueFormat

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ValueFormat プロパティ

ポイント値を表示するための書式を設定します。

public String ValueFormat {get; set;}

解説

デフォルト値：'#,##0.###'

軸のラベルに適用する書式を指定します。これは、軸に関連する系列がXValues.DateTimeあるいはYValues.DateTimeプロパティがfalseに設定されている場合に効果があります。

DateTime軸ラベルの場合は、AxisLabels.DateTimeFormatプロパティを使用してください。

ValueFormatプロパティは、標準的な書式に関する文字列指定子です。

チャート軸は、これを使用して軸ラベルを描きます。

チャート系列は、これを使用してマーカを描きます。

例

書式文字列- | 1234 | -1234 | 0.5 | 0
1234 | -1234 | 0.5 | 0 |
0 | 1234 | -1234 | 1 | 0
0.00 | 1234.00 | -1234.00 | 0.50 | 0.00
#.## | 1234 | -1234 | .5 |
#,##0.00 | 1,234.00 | -1,234.00 | 0.50 | 0.00
#,##0.00;(#,##0.00) | 1,234.00 | (1,234.00) | 0.50 | 0.00
#,##0.00;;Zero | 1,234.00 | -1,234.00 | 0.50 | Zero
0.000E+00 | 1.234E+03 | -1.234E+03 | 5.000E-01 | 0.000E+00
#.###E-0 | 1.234E3 | -1.234E3 | 5E-1 | 0E0

例

1.
tChart1[0].ValueFormat = "#,##0.00";
        //この場合は、10.00, 25.00, 150.00のように小数部2桁の書式でラベルを表示します。

2.
tChart1[0].ValueFormat = "#,##0.##";
        //この場合は、10, 25, 150のように小数部なしの書式でラベルを表示します。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ValuesLists

Steema.TeeChart.Styles.Series.ValuesLists プロパティ

系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
public List<ValueList> ValuesLists {get;}

解説

系列のTeeChartValueListsのリストにアクセスします。

TLineSeries やTBarSeriesのようないくつかの標準系列型はXやY値といった2つのValueListsを持っています。TCandleSeries のような他の系列はDateValues、OpenValues、HighValues、LowValuesやCloseValuesのようなより多くのリストを持っています。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


VertAxis

Steema.TeeChart.Styles.Series.VertAxis プロパティ

系列に関連付ける垂直軸を設定します。
public VerticalAxis VertAxis {get; set;}

解説

系列がどの垂直軸（左軸あるいは右軸）で垂直方向にスケールさせるか設定します。デザイン時や実行時に垂直軸を変更することができます。

例

[C#]

tChart1[0].VertAxis = VerticalAxis.Right;

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Visible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.Visible プロパティ

系列を表示/非表示にします。

public Boolean Visible {get; set;}

解説

系列をを表示/非表示にします。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


XValues

Steema.TeeChart.Styles.Series.XValues プロパティ

水平ポイント位置を設定する値。
public ValueList XValues {get;}

解説

デフォルトでは、すべての系列はXValuesプロパティを持っています。これは、ポイント値が実行時に格納されるIValueListです。さらにデフォルトでは、XValuesはパブリックプロパティになっています。リボン系列、縦棒系列、散布図系列など派生した一部の系列はこれを作成します。GanttSeries.StartValuesなど、別のもっと親しみやすい名前を付けてこれを作成する系列もあります。

警告：

値を直接Delete（削除）、Clear（クリア）あるいはAdd（追加）することはできません。これらを行うには、系列の同等のメソッドを呼び出す必要があります。

例

[C#]

XValuesプロパティを使用していろいろなことができます。
たとえば、値を変更することができます(つまり、チャートを再描画します）。
これは、5番目のポイントの水平値を10に変更します。

tChart1[0]..XValues[5] = 10

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


YValues

Steema.TeeChart.Styles.Series.YValues プロパティ

垂直ポイント位置を設定する値。
public ValueList YValues {get;}

解説

値を直接Delete（削除）、Clear（クリア）もしくはAdd（追加）することはできません。これらを行う場合は、系列の同等のメソッドを呼び出す必要があります。

例

YValuesプロパティを使用していろいろなことができます。
例えばしきい値を超えると警告がでるように設定できます。

[C#]
Graphics3D g=tChart3.Graphics3D;

//データがしきい値の600以上になると、テキストを出力します。
if (tChart3[0].YValues[i]>600)
g.TextOut(tmpX,tmpY,"Warning !! X: "+tChart3[0].XValues[i].ToString()+", Y: "+tChart3[0].YValues[i].ToString());

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


ZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.ZOrder プロパティ

系列が描画される奥軸の位置を返します。

public Int32 ZOrder {get; set;}

解説

実行時、読込み専用。

このプロパティは、系列が描画される奥軸の位置を返します。

これは、TChart.Aspect.View3Dプロパティがtrueになっているか、同じチャートに1つ以上の系列がある場合にのみ有効です。

このプロパティを直接変更することはできません。順序を変更する場合は、TChart.SeriesListプロパティを使用してください。

このプロパティは、各系列に対してチャートを描く直前に計算されます。

TChart.ApplyZOrderプロパティは、系列に異なるZ位置を指定するかどうかを制御します。これがFalseの場合、すべての系列は同じZ平面に描かれます。

TChart.MaxZOrderプロパティは、すべての系列のZOrder値の中でもっとも高い値を返します。

このプロパティのサンプルとしてLastValu.PASのユニット例を参照してください。

参照

Series クラス | Series メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.GetSeriesMarkEventHandler

Steema.TeeChart.Styles.Series.GetSeriesMarkEventHandler デリゲート

GetSeriesMarkイベントのデリゲート。
public delegate GetSeriesMarkEventHandler (Series series,
     GetSeriesMarkEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.SeriesRandom

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SeriesRandom 構造体

系列にランダム値を追加するために内部的に使用されます。

この型のすべてのメンバの一覧については、SeriesRandom メンバを参照してください。

System.Object
System.ValueType
public struct SeriesRandom : ValueType

参照

SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.SeriesRandom 全メンバ

SeriesRandom 概要

パブリック フィールド

DifY
MinY
StepX
tmpX
tmpY

パブリック メソッド

Random

参照

SeriesRandom 構造体 | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.SeriesRandom フィールド

パブリック フィールド

DifY
MinY
StepX
tmpX
tmpY

参照

SeriesRandom 構造体 | Steema.TeeChart.Styles 名前空間


DifY

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.DifY フィールド

public Double DifY

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


MinY

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.MinY フィールド

public Double MinY

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


StepX

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.StepX フィールド

public Double StepX

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


tmpX

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.tmpX フィールド

public Double tmpX

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


tmpY

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.tmpY フィールド

public Double tmpY

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.SeriesRandom メソッド

パブリック メソッド

Random

参照

SeriesRandom 構造体 | Steema.TeeChart.Styles 名前空間


Random

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series+SeriesRandom.Random メソッド

public Double Random()

参照

SeriesRandom 構造体 | SeriesRandom メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Series.SubGalleryEventHandler

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Series.SubGalleryEventHandler デリゲート

public virtual Chart Invoke(String Name)

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

SteemaTeeChartStylesSeriesSubGalleryEve 名前空間


Steema.TeeChart.Styles.SeriesCollection

Steema.TeeChart.Styles.SeriesCollection クラス

このクラスは系列オブジェクトのコレクションで、ChartのSeriesプロパティに操作されます。

この型のすべてのメンバの一覧については、SeriesCollection メンバを参照してください。

System.Object
System.Collections.CollectionBase
public sealed class SeriesCollection : CollectionBase , IList
, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesCollection 全メンバ

SeriesCollection 概要

コンストラクタ

Constructor

パブリック メソッド

ActiveUseAxis |
Add |
AddGroup | グループリストに新しい系列グループを追加します。
Clear | 全ての系列を削除します（また、必要に応じて解放することもできます）。
Exchange | 系列のZ位置を別の系列と入れ替えることにより、系列の順番を変更します。
FillItems | すべての系列をItemsリストまたは配列パラメーターに追加します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
MoveTo |
Remove | 系列リストから指定した系列を削除します。
RemoveAllSeries | チャートからすべての系列を削除します。削除した系列は解放されません。
WithTitle |

パブリック プロパティ

AllActive | リスト内の全系列がアクティブ（可視）の場合、Trueを返します。
ApplyZOrder | trueの場合、同じチャートの複数系列を異なるZ位置に設定します。
Chart | チャートコンポーネントを定義します。
Groups | 系列グループのリストです。
Item |

参照

SeriesCollection クラス | Steema.TeeChart.Styles 名前空間


SeriesCollection コンストラクタ

Steema.TeeChart.Styles.SeriesCollection コンストラクタ

public SeriesCollection(Chart c)

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesCollection メソッド

パブリック メソッド

ActiveUseAxis |
Add |
AddGroup | グループリストに新しい系列グループを追加します。
Clear | 全ての系列を削除します（また、必要に応じて解放することもできます）。
Exchange | 系列のZ位置を別の系列と入れ替えることにより、系列の順番を変更します。
FillItems | すべての系列をItemsリストまたは配列パラメーターに追加します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
MoveTo |
Remove | 系列リストから指定した系列を削除します。
RemoveAllSeries | チャートからすべての系列を削除します。削除した系列は解放されません。
WithTitle |

参照

SeriesCollection クラス | Steema.TeeChart.Styles 名前空間


ActiveUseAxis

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.ActiveUseAxis メソッド

public Boolean ActiveUseAxis()

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.SeriesCollection.Add メソッド

オーバーロードの一覧

public Series Add(System.Type)

チャートに新しい系列インスタンスを追加します。

public Series Add(Steema.TeeChart.Styles.Series)

解説

チャートに新しい系列インスタンスを追加します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Add

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.Add メソッド

public Series Add(Type type)

参照

Add オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.SeriesCollection.Add メソッド

チャートに新しい系列のインスタンスを追加します。
public Series Add(Series s)

パラメーター

s
追加する系列インスタンス。

戻り値

同じ系列。

参照

Add オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


AddGroup

Steema.TeeChart.Styles.SeriesCollection.AddGroup メソッド

グループリストに新しい系列グループを追加します。
public SeriesGroup AddGroup(String name)

パラメーター

name
新しい系列グループ名

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.Clear メソッド

オーバーロードの一覧

すべての系列を削除（オプションで解放）します。

public Void Clear(System.Boolean)

すべての系列を削除および解放します。

public Void Clear()

解説

すべての系列の値を削除します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.Clear メソッド

すべての系列を削除(および任意で解放）します。

public Void Clear(Boolean dispose)

参照

Clear オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.Clear メソッド

すべての系列を削除します。

public Void Clear()

参照

Clear オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Exchange

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.Exchange メソッド

系列のZ位置を他の系列と入れ替えることにより、系列の順番を変更します。

public Void Exchange(Int32 series1,
     Int32 series2)

解説

系列のZ位置を他の系列と入れ替えることにより、系列の順番を変更します。
チャートは、新しい系列の順番を反映するように再描画されます。
これは、TChart.SeriesListプロパティにアクセスします。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


FillItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.FillItems メソッド

オーバーロードの一覧

すべての系列をItemsリストまたは配列パラメーターに追加します。

public Void FillItems(System.Windows.Forms.ListBox+ObjectCollection)

すべての系列をseriesCollectionパラメーターからItemsリストまたは配列パラメーターに追加します。

public Void FillItems(System.Windows.Forms.ListBox+ObjectCollection, Steema.TeeChart.Styles.SeriesCollection)

解説

すべての系列をItemsリストまたは配列パラメーターに追加します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


FillItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.FillItems メソッド

すべての系列をItemsリストまたは配列パラメーターに追加します。
public Void FillItems(ObjectCollection items)

参照

FillItems オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


FillItems

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.FillItems メソッド

すべての系列をseriesCollectionパラメーターからItemsリストまたは配列パラメーターに追加します。
public Void FillItems(ObjectCollection items,
     SeriesCollection seriesCollection)

参照

FillItems オーバーロードの一覧 | SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


IndexOf

Steema.TeeChart.Styles.SeriesCollection.IndexOf メソッド

指定した値を持つポイントのインデックスを返します。
public Int32 IndexOf(Series s)

解説

指定した値を持つポイントのインデックスを返します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


MoveTo

Steema.TeeChart.Styles.SeriesCollection.MoveTo メソッド

public Void MoveTo(Series s,
     Int32 index)

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Remove

Steema.TeeChart.Styles.SeriesCollection.Remove メソッド

系列リストから指定した系列を削除します。
public Void Remove(Series s)

解説

系列リストから指定した系列を削除します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


RemoveAllSeries

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.RemoveAllSeries メソッド

チャートからすべての系列を削除します。削除した系列は解放されません。

public Void RemoveAllSeries()

解説

チャートのSeriesListにあるすべての系列を削除します。削除した系列は解放されません。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


WithTitle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.WithTitle メソッド

public Series WithTitle(String title)

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesCollection プロパティ

パブリック プロパティ

AllActive | リスト内の全系列がアクティブ（可視）の場合、Trueを返します。
ApplyZOrder | trueの場合、同じチャートの複数系列を異なるZ位置に設定します。
Chart | チャートコンポーネントを定義します。
Groups | 系列グループのリストです。
Item |

参照

SeriesCollection クラス | Steema.TeeChart.Styles 名前空間


AllActive

Steema.TeeChart.Styles.SeriesCollection.AllActive プロパティ

リスト内の全系列がアクティブ（可視）の場合、Trueを返します。
public Boolean AllActive {get; set;}

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


ApplyZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesCollection.ApplyZOrder プロパティ

trueの場合、同じチャートの複数系列を異なるZ位置に設定します。

public Boolean ApplyZOrder {get; set;}

解説

実行時専用。
同じTChartコンポーネントに複数の系列がある場合、異なるZ位置に表示するかどうかを設定します。
これはTChart.View3Dプロパティがtrueで、同じチャートに複数の系列がある場合のみ有効です。
falseの場合、すべての系列はチャートのZスペース全体に描かれます。系列がオーバーラップしていると、チャートの出力がわかりにくくなることがあります。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Chart

Steema.TeeChart.Styles.SeriesCollection.Chart プロパティ

チャートコンポーネントを定義します。
public Chart Chart {get;}

解説

チャートコンポーネントを定義します。

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Groups

Steema.TeeChart.Styles.SeriesCollection.Groups プロパティ

系列グループのリストです。
public SeriesGroups Groups {get;}

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.SeriesCollection.Item プロパティ

public Series Item(Int32 index) {get; set;}

参照

SeriesCollection クラス | SeriesCollection メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesEvent

Steema.TeeChart.Styles.SeriesEvent クラス

すべてのSeriesクラスイベント。

この型のすべてのメンバの一覧については、SeriesEvent メンバを参照してください。

System.Object
Steema.TeeChart.TeeEvent
public class SeriesEvent : TeeEvent

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesEvent メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesEvent 全メンバ

SeriesEvent 概要

コンストラクタ

Constructor

パブリック フィールド

Event
sender (TeeEventの継承元)
Series

参照

SeriesEvent クラス | Steema.TeeChart.Styles 名前空間


SeriesEvent コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesEvent コンストラクタ

public SeriesEvent()

参照

SeriesEvent クラス | SeriesEvent メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesEvent フィールド

パブリック フィールド

Event
sender (TeeEventの継承元)
Series

参照

SeriesEvent クラス | Steema.TeeChart.Styles 名前空間


Event

Steema.TeeChart.Styles.SeriesEvent.Event フィールド

public SeriesEventStyle Event

参照

SeriesEvent クラス | SeriesEvent メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.SeriesEvent.Series フィールド

public Series Series

参照

SeriesEvent クラス | SeriesEvent メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesEventStyle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesEventStyle 列挙体

内部使用。

[Serializable]
public enum SeriesEventStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Add |
Remove |
RemoveAll |
ChangeTitle |
ChangeColor |
Swap |
ChangeActive |
DataChanged |

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroup

Steema.TeeChart.Styles.SeriesGroup クラス

系列のグループ特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesGroup メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class SeriesGroup : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroup 全メンバ

SeriesGroup 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Hide | グループ内の全系列のActiveプロパティをFalseに設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Show | グループ内の全系列のActiveプロパティをTrueに設定します。
ToString |

パブリック プロパティ

Active | グループ内の全ての系列がアクティブ（可視）の場合、Yesを返します。アクティブ系列が存在しない場合、Noを返します。系列の一部がアクティブの場合、Some を返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Name | グループ名を設定します。
Series | このグループに属する系列リストです。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesGroup クラス | Steema.TeeChart.Styles 名前空間


SeriesGroup コンストラクタ

Steema.TeeChart.Styles.SeriesGroup コンストラクタ

オーバーロードの一覧

public SeriesGroup()
public SeriesGroup(Steema.TeeChart.Chart)

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


SeriesGroup コンストラクタ

Steema.TeeChart.Styles.SeriesGroup コンストラクタ

public SeriesGroup()

参照

SeriesGroup コンストラクタのオーバーロードの一覧 | SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


SeriesGroup コンストラクタ

Steema.TeeChart.Styles.SeriesGroup コンストラクタ

public SeriesGroup(Chart c)

参照

SeriesGroup コンストラクタのオーバーロードの一覧 | SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroup フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesGroup クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroup メソッド

パブリック メソッド

Hide | グループ内の全系列のActiveプロパティをFalseに設定します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Show | グループ内の全系列のActiveプロパティをTrueに設定します。
ToString |

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesGroup クラス | Steema.TeeChart.Styles 名前空間


Hide

Steema.TeeChart.Styles.SeriesGroup.Hide メソッド

グループ内の全系列のActiveプロパティをFalseに設定します。
public Void Hide()

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Show

Steema.TeeChart.Styles.SeriesGroup.Show メソッド

グループ内の全系列のActiveプロパティをTrueに設定します。
public Void Show()

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


ToString

Steema.TeeChart.Styles.SeriesGroup.ToString メソッド

public override String ToString()

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroup プロパティ

パブリック プロパティ

Active | グループ内の全ての系列がアクティブ（可視）の場合、Yesを返します。アクティブ系列が存在しない場合、Noを返します。系列の一部がアクティブの場合、Some を返します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Name | グループ名を設定します。
Series | このグループに属する系列リストです。

参照

SeriesGroup クラス | Steema.TeeChart.Styles 名前空間


Active

Steema.TeeChart.Styles.SeriesGroup.Active プロパティ

グループ内の全ての系列がアクティブ（可視）の場合、Yesを返します。アクティブ系列が存在しない場合、Noを返します。系列の一部がアクティブの場合、Some を返します。
public SeriesGroupActive Active {get; set;}

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Name

Steema.TeeChart.Styles.SeriesGroup.Name プロパティ

グループ名を設定します。
public String Name {get; set;}

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.SeriesGroup.Series プロパティ

このグループに属する系列のリストです。
public SeriesCollection Series {get; set;}

参照

SeriesGroup クラス | SeriesGroup メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroupActive

Steema.TeeChart.Styles.SeriesGroupActive 列挙体

Activeプロパティの使用可能な値です。
[Serializable]
public sealed enum SeriesGroupActive : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Yes | グループ内の全ての系列がアクティブ（可視）。
No | グループ内にアクティブな系列がない。
Some | グループ内の一部の系列がアクティブ。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroups

Steema.TeeChart.Styles.SeriesGroups クラス

系列のグループ特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesGroups メンバを参照してください。

System.Object
System.Collections.CollectionBase
public sealed class SeriesGroups : CollectionBase , IList, ICollection
, IEnumerable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroups 全メンバ

SeriesGroups 概要

コンストラクタ

Constructor

パブリック メソッド

Add | リストに新しい系列グループを追加します。
Contains | 指定した系列パラメーターが、どのグループに含まれているかをインデックスで返します。どのグループにも含まれていない場合は-1を返します。
FindByName |

パブリック プロパティ

Item リスト内のindex番目に系列グループを取得/設定します。

参照

SeriesGroups クラス | Steema.TeeChart.Styles 名前空間


SeriesGroups コンストラクタ

Steema.TeeChart.Styles.SeriesGroups コンストラクタ

public SeriesGroups(Chart c)

参照

SeriesGroups クラス | SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroups メソッド

パブリック メソッド

Add | リストに新しい系列グループを追加します。
Contains | 指定した系列パラメーターが、どのグループに含まれているかをインデックスで返します。どのグループにも含まれていない場合は-1を返します。
FindByName |

参照

SeriesGroups クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.SeriesGroups.Add メソッド

リストに新しい系列グループを追加します。
public SeriesGroup Add(String name)

パラメーター

name
新しい系列グループ名。

参照

SeriesGroups クラス | SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


Contains

Steema.TeeChart.Styles.SeriesGroups.Contains メソッド

指定した系列パラメーターが、どのグループに含まれているかをインデックスで返します。どのグループにも含まれていない場合は-1を返します。
public Int32 Contains(Series s)

参照

SeriesGroups クラス | SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


FindByName

Steema.TeeChart.Styles.SeriesGroups.FindByName メソッド

public SeriesGroup FindByName(String Name,
     Boolean CaseSensitive)

参照

SeriesGroups クラス | SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesGroups プロパティ

パブリック プロパティ

Item リスト内のindex番目に系列グループを取得/設定します。

参照

SeriesGroups クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.SeriesGroups.Item プロパティ

リスト内のインデックス位置にSeriesGroupを取得/設定します。
public SeriesGroup Item(Int32 index) {get; set;}

参照

SeriesGroups クラス | SeriesGroups メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks

Steema.TeeChart.Styles.SeriesMarks クラス

系列マーカ特性。

この型のすべてのメンバの一覧については、SeriesMarks メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
Steema.TeeChart.Drawing.TextShape
public class SeriesMarks : TextShape , IComponent, IDisposable
, ICloneable

解説

マーカは、系列の各データポイントに関連したラベルを示します。マーカは、データ値、ポイントのテキスト説明、または全体のすべてのポイント値に関係する割合などとして、いくつかの方法で表示されます。マーカは通常、系列ポイントに対して併置、上部、または下部に表示されます。マーカは実行時に位置を変更したりプロパティを変更したりできます。

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks 全メンバ

SeriesMarks 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

CheckMarkArrowColor | trueの場合、ポイントが同じ色を持っている場合にマーカ矢印のペンの色が変更されます。
Size (TextShapeの継承元) |

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clear | すべてのマーカ位置とマーカ項目を削除します。
Clicked | 指定したパラメーターに該当するマーカのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
PercentString | 指定したポイントの｢パーセント｣値を表す文字列を返します。
ResetPositions | マーカをデフォルト位置に再設定します。
TextWidth | 指定したValueIndexのマーカテキストの幅をピクセル単位で返します。これは、マーカテキストが複数行かどうか確認します。

パブリック プロパティ

Angle | 各ポイントマーカに適用させる角度を0～360度で設定します。
Arrow | 系列ポイントとマーカを接続する線のペンの種類を定義します。
ArrowLength | 系列ポイントとマーカを接続する線の長さをピクセル単位で定義します。
AutoSize (TextShapeの継承元) |
BackColor |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Callout | マーカの引き出し線の特性にアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Clip | trueの場合、マーカをチャート軸スペース内だけで描画します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
DrawEvery | スキップして表示するマーカの数を設定します（デフォルト値：1。すべてのマーカが表示されます）。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Frame |
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Items |
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines |
MultiLine | trueの場合、マーカテキストを複数行に分割します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Positions |
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Series |
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Style | 系列のマーカの表示スタイルを設定します。
Symbol |
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。
ZPosition | マーカのZ位置をピクセル単位で設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bClip
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultArrowLength
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSeries
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
markerStyle
pPen (Shapeの継承元)
pPositions
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AllSeriesVisible
AntiOverlap
ApplyArrowLength
AssignShape
CalcBounds (TextShapeの継承元)
ConvertTo2D
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
InternalDraw
MarkItem
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeArrowLength
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

SeriesMarks クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks コンストラクタ

オーバーロードの一覧

public SeriesMarks()
public SeriesMarks(Steema.TeeChart.Chart)
public SeriesMarks(Steema.TeeChart.Styles.Series)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks コンストラクタ

public SeriesMarks()

参照

SeriesMarks コンストラクタのオーバーロードの一覧 | SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks コンストラクタ

public SeriesMarks(Chart c)

参照

SeriesMarks コンストラクタのオーバーロードの一覧 | SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks コンストラクタ

public SeriesMarks(Series s)

参照

SeriesMarks コンストラクタのオーバーロードの一覧 | SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks フィールド

パブリック フィールド

CheckMarkArrowColor | trueの場合、ポイントが同じ色を持っている場合にマーカ矢印のペンの色が変更されます。
Size (TextShapeの継承元) |

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bClip
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultArrowLength
defaultText (TextShapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iDrawText (TextShapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iSeries
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
markerStyle
pPen (Shapeの継承元)
pPositions
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesMarks クラス | Steema.TeeChart.Styles 名前空間


bClip

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.bClip フィールド

protected internal Boolean bClip

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


CheckMarkArrowColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.CheckMarkArrowColor フィールド

trueの場合、ポイントが同じ色を持っている場合にマーカ矢印のペンの色が変更されます。

public Boolean CheckMarkArrowColor

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


defaultArrowLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.defaultArrowLength フィールド

protected internal Int32 defaultArrowLength

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


iSeries

Steema.TeeChart.Styles.SeriesMarks.iSeries フィールド

protected internal Series iSeries

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


markerStyle

Steema.TeeChart.Styles.SeriesMarks.markerStyle フィールド

protected internal MarksStyles markerStyle

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


pPositions

Steema.TeeChart.Styles.SeriesMarks.pPositions フィールド

protected MarkPositions pPositions

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks メソッド

パブリック メソッド

Assign (TextShapeの継承元) | すべてのプロパティをTextShapeから他のTextShapeへ割り当てます。
Clear | すべてのマーカ位置とマーカ項目を削除します。
Clicked | 指定したパラメーターに該当するマーカのインデックスを返します。
Clone (Shapeの継承元) |
DrawRectRotated (TextShapeの継承元) | 指定した回転角度でシェープ矩形を描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (TextShapeの継承元) | チャートキャンバスにTextShapeオブジェクトを描画します。
PercentString | 指定したポイントの｢パーセント｣値を表す文字列を返します。
ResetPositions | マーカをデフォルト位置に再設定します。
TextWidth | 指定したValueIndexのマーカテキストの幅をピクセル単位で返します。これは、マーカテキストが複数行かどうか確認します。

プロテクト メソッド

AllSeriesVisible
AntiOverlap
ApplyArrowLength
AssignShape
CalcBounds (TextShapeの継承元)
ConvertTo2D
DrawString (TextShapeの継承元)
DrawText (TextShapeの継承元)
InternalDraw
MarkItem
SetBooleanProperty (TeeBaseの継承元)
SetChart (TextShapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeArrowLength
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeLines (TextShapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

SeriesMarks クラス | Steema.TeeChart.Styles 名前空間


AllSeriesVisible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.AllSeriesVisible メソッド

protected internal Boolean AllSeriesVisible()

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


AntiOverlap

Steema.TeeChart.Styles.SeriesMarks.AntiOverlap メソッド

protected internal Void AntiOverlap(Int32 first,
     Int32 valueIndex,
     Position aPos)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ApplyArrowLength

Steema.TeeChart.Styles.SeriesMarks.ApplyArrowLength メソッド

protected internal Void ApplyArrowLength(Position& aPos)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


AssignShape

Steema.TeeChart.Styles.SeriesMarks.AssignShape メソッド

protected abstract Void AssignShape(Shape s)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Clear

Steema.TeeChart.Styles.SeriesMarks.Clear メソッド

すべてのマーカ位置とマーカ項目を削除します。
public Void Clear()

解説

すべてのマーカ位置とマーカ項目を削除します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Clicked メソッド

オーバーロードの一覧

XYピクセルポイントパラメーターに該当するマーカのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

pポイントパラメーターに該当するマーカのインデックスを返します。

public virtual Int32 Clicked(System.Drawing.Point)

解説

指定したパラメーターに該当するマーカのインデックスを返します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Clicked メソッド

XYピクセルポイントパラメーターに該当するマーカのインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

戻り値

XYポイントに該当するマーカのインデックス。

参照

Clicked オーバーロードの一覧 | SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Clicked メソッド

pポイントパラメーターに該当するマーカのインデックスを返します。

public virtual Int32 Clicked(Point p)

参照

Clicked オーバーロードの一覧 | SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ConvertTo2D

Steema.TeeChart.Styles.SeriesMarks.ConvertTo2D メソッド

protected internal Void ConvertTo2D(Position aPos,
     Point& p)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


InternalDraw

Steema.TeeChart.Styles.SeriesMarks.InternalDraw メソッド

protected internal Void InternalDraw(Int32 index,
     Color aColor,
     String st,
     Position aPos)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


MarkItem

Steema.TeeChart.Styles.SeriesMarks.MarkItem メソッド

protected internal TextShape MarkItem(Int32 valueIndex)

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


PercentString

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.PercentString メソッド

指定したポイントの｢パーセント｣値を表す文字列を返します。

public String PercentString(Int32 valueIndex,
     Boolean addTotal)

解説

指定したポイントの｢パーセント｣値を表す文字列を返します。例：｢25%｣
｢AddTotal｣パラメーターがtrueの場合、｢25% of 1234｣と返します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ResetPositions

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.ResetPositions メソッド

マーカをデフォルト位置に再設定します。

public Void ResetPositions()

解説

マーカをデフォルト位置に再設定します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeArrowLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.ShouldSerializeArrowLength メソッド

protected virtual Boolean ShouldSerializeArrowLength()

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


TextWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.TextWidth メソッド

指定したValueIndexのマーカテキストの幅をピクセル単位で返します。これは、マーカテキストが複数行かどうか確認します。

public Int32 TextWidth(Int32 valueIndex)

解説

指定したValueIndexのマーカテキストの幅をピクセル単位で返します。
これは、マーカテキストが複数行かどうか確認します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks プロパティ

パブリック プロパティ

Angle | 各ポイントマーカに適用させる角度を0～360度で設定します。
Arrow | 系列ポイントとマーカを接続する線のペンの種類を定義します。
ArrowLength | 系列ポイントとマーカを接続する線の長さをピクセル単位で定義します。
AutoSize (TextShapeの継承元) |
BackColor |
Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Callout | マーカの引き出し線の特性にアクセスします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Clip | trueの場合、マーカをチャート軸スペース内だけで描画します。
ClipText (TextShapeの継承元) |
Color (Shapeの継承元) | シェープの色を定義します。
DrawEvery | スキップして表示するマーカの数を設定します（デフォルト値：1。すべてのマーカが表示されます）。
Font (TextShapeの継承元) | ShapeSeries.Textプロパティの出力に使用されるフォント属性を定義します。
Frame |
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Items |
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Lines |
MultiLine | trueの場合、マーカテキストを複数行に分割します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Positions |
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Series |
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShadowSize (TextShapeの継承元) |
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
ShapeStyle (TextShapeの継承元) | シェープのスタイルを矩形または角の丸い矩形に設定します。
Style | 系列のマーカの表示スタイルを設定します。
Symbol |
Text (TextShapeの継承元) | シェープ内にカスタマイズされた文字列を表示します。
TextAlign (TextShapeの継承元) |
TextFormat (TextShapeの継承元) | Textプロパティが標準あるいはHTMLスタイルとして表示されるかどうか設定します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。
ZPosition | マーカのZ位置をピクセル単位で設定します。

プロテクト プロパティ

LinesLength (TextShapeの継承元)

参照

SeriesMarks クラス | Steema.TeeChart.Styles 名前空間


Angle

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Angle プロパティ

各ポイントマーカに適用させる角度を0～360度で設定します。

public Double Angle {get; set;}

解説

各ポイントマーカに適用させる角度を0～360度で設定します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Arrow

Steema.TeeChart.Styles.SeriesMarks.Arrow プロパティ

系列ポイントとマーカを接続する線のペンの種類を定義します。
public ChartPen Arrow {get;}

解説

系列ポイントとマーカを接続する線のペンの種類を定義します。

各系列クラスは、それぞれ異なる方法でマーカの処理を行います。従って、Arrowの座標値は、各系列型に特有なものになります。

デフォルトのArrowペンは幅1ピクセルの白の実線で定義されています。

例

[C#]
tChart1[0].Marks.Arrow.Visible = false;

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ArrowLength

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.ArrowLength プロパティ

系列ポイントとマーカを接続する線の長さをピクセル単位で定義します。

public Int32 ArrowLength {get; set;}

解説

デフォルト値：16

系列ポイントとマーカを接続する線の長さをピクセル単位で定義します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


BackColor

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.BackColor プロパティ

public Color BackColor {get; set;}

旧式

このプロパティの代わりにColorプロパティを使用してください。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Callout

Steema.TeeChart.Styles.SeriesMarks.Callout プロパティ

マーカの引き出し線の特性にアクセスします。
public MarksCallout Callout {get;}

解説

系列ポイントとマーカを接続する線の特性にアクセスします。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Clip

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Clip プロパティ

trueの場合、マーカをチャート内だけで描画します。

public Boolean Clip {get; set;}

解説

デフォルト値：true

マーカをチャート範囲外でクリップするかどうか定義します。

デフォルトは、マーカが軸のラベル、タイトル、凡例などにほとんど影響を与えずに、チャート内だけで描画されます。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


DrawEvery

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.DrawEvery プロパティ

スキップして表示するマーカの数を設定します（デフォルト値：1。すべてのマーカが表示されます）。

public Int32 DrawEvery {get; set;}

解説

描画される一連のマーカの数を設定するために使用してください。このプロパティを2に設定すると、1番目、3番目、5番目・・・と描画します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Frame

Steema.TeeChart.Styles.SeriesMarks.Frame プロパティ

public ChartPen Frame {get;}

解説

このプロパティの代わりに、Penプロパティを使用してください。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Items

Steema.TeeChart.Styles.SeriesMarks.Items プロパティ

public MarksItems Items {get;}

解説

マーカアイテムのコレクションを返します。
各マーカアイテムは、独自の書式（色、フォント、影、など）を持っています。
デフォルトにより、アイテムは空なのでデフォルトのマーカ形式が使用されています。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Lines

Steema.TeeChart.Styles.SeriesMarks.Lines プロパティ

public String[] Lines {get; set;}

解説

実行時にユーザーによりチャート上に描かれた線のリストを含んでいます。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


MultiLine

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.MultiLine プロパティ

trueの場合、マーカテキストを複数行に分割します。

public Boolean MultiLine {get; set;}

解説

軸ラベルの複数行を有効/無効に設定します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Positions

Steema.TeeChart.Styles.SeriesMarks.Positions プロパティ

public MarkPositions Positions {get;}

解説

系列マーカのカスタム位置の特性にアクセスするために使用してください。

TeeChart Pro .Netには、TeeChartの系列マーカがオーバーラップしないようにデザインされた多くのアルゴリズムの数があります。しかし、自動的にマーカ位置を生成したくない場合、以下の例のようなコードでいつでもマーカを移動させることができます。
（チャートでマーカ位置を変更するドラッグマーカツールも使用できます。）

例

[C#]

private void Form1_Load(object sender, System.EventArgs e)
      tChart1.Aspect.View3D = false;
      pie1.FillSampleValues(20);
      pie1.Circled = true;
      Bitmap b=tChart1.Bitmap;

      Steema.TeeChart.Styles.SeriesMarks.Position mp3 =
pie1.Marks.Positions[3];
      mp3.Custom=true;
      mp3.ArrowTo.X=mp3.ArrowTo.X-50;
      mp3.LeftTop.X=mp3.LeftTop.X-50;

      pie1.Marks.Positions[5].Custom=true;

pie1.Marks.Positions[5].ArrowTo.Y=pie1.Marks.Positions[5].ArrowTo.Y+50;

pie1.Marks.Positions[5].LeftTop.Y=pie1.Marks.Positions[5].LeftTop.Y+50;

      tChart1.Refresh();

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.SeriesMarks.Series プロパティ

public Series Series {get;}

解説

実行時、読込み専用。

このプロパティは、TSeriesMarksサブコンポーネントを保持するSeriesコンポーネントを返します。

すべての系列型は、TSeriesMarksクラスのMarksサブコンポーネントを保持しています。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.SeriesMarks.Style プロパティ

系列のマーカの表示スタイルを設定します。
public MarksStyles Style {get; set;}

解説

デフォルト値：Label

系列のマーカの表示スタイルを設定します。Style値がそれぞれ異なっていると、マーカは異なったテキストを出力します。複数のオプションが用意されています。また、TChartのSeries.OnGetMarkTextイベントの使用や、デフォルトの系列マーカテキストをオーバーライドすることもできます。
マーカスタイルには以下のようなものがあります。

Value
ポイント値を示します。通常はY値になりますが、横棒系列だけはデフォルトがX値です。TChartのSeries.ValueFormatプロパティは、出力される文字列を書式化するために使用されます。

例："1234"

Percent
ポイント値を百分率で示します。TChartのSeries.PercentFormatプロパティは、パーセント値を書式化するために使用されます。
例："12 %"

Label
関連するポイントラベルを表示します。
例："Cars"
注意：
ポイントにラベルがない場合（ラベルが空）、ポイント値が使用されます。特定のポイントに空のラベルを示すためにTChartのSeries.OnGetMarkTextイベントが使用できます。

LabelPercent
ポイントラベルと百分率値を表示します。TChartのSeries.PercentFormatプロパティは、百分率値を書式化するために使用されます。
例："Cars 12 %"

LabelValue
ポイントラベルとポイント値を表示します。TChartのSeries.ValueFormatプロパティは、出力される文字列を書式化するために使用されます。
例："Cars 1234"

Legend
チャートの凡例に表示されているものをすべて表示します。使用可能な値のリストについては、TChartのLegend.TextStyleプロパティを参照してください。

PercentTotal
ポイントを示す百分率を「of」という文字と、全ポイントの絶対値の合計を一緒に示します。TChartのSeries.PercentFormatプロパティは、百分率値を書式化するために使用されます。
例："12 % of 1234"
メモ：
Teengineユニットの「PercentOf」定数を使用することにより、「of」という文字を変更したり、あるいは各国語に合わせたりすることができます。

スペイン語での例： PercentOf := 'sobre';
出力： "12 % sobre 1234"

LabelPercentTotal
ポイントラベルを、出力する「PercentTotal」スタイルと一緒に表示します。TChartのSeries.PercentFormatプロパティは、百分率値を書式化するために使用されます。

例："Cars 12 % of 1234"

XValue
ポイントのX値を表示します(Valueと同じ。ただし、Y値ではなくX値で示される)。
例："21/6/2003"

XY
ポイントのX値とY値を表示します。
例："21/6/2003 356"

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Symbol

Steema.TeeChart.Styles.SeriesMarks.Symbol プロパティ

public Symbols Symbol {get;}

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


ZPosition

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.ZPosition プロパティ

マーカのZ位置をピクセル単位で設定します。

public Int32 ZPosition {get; set;}

解説

マーカのZ位置をピクセル単位で設定します。

参照

SeriesMarks クラス | SeriesMarks メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.MarkPositions

Steema.TeeChart.Styles.SeriesMarks.MarkPositions クラス

系列マーカの位置。

この型のすべてのメンバの一覧については、MarkPositions メンバを参照してください。

System.Object
System.Collections.Generic.List<SeriesMarks+Position>
public class MarkPositions : List<Position>
, IList<Position>
, ICollection<Position>
, IEnumerable<Position>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

MarkPositions メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.MarkPositions 全メンバ

MarkPositions 概要

コンストラクタ

Steema.TeeChart.Styles.SeriesMarks.MarkPositions..ctor

パブリック メソッド

ExistCustom | マーカがカスタムな位置にあるかどうか確認します。
MoveTo |

パブリック プロパティ

Item

参照

MarkPositions クラス | Steema.TeeChart.Styles 名前空間


MarkPositions コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+MarkPositions コンストラクタ

public SeriesMarks+MarkPositions()

参照

MarkPositions クラス | MarkPositions メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.MarkPositions メソッド

パブリック メソッド

ExistCustom | マーカがカスタムな位置にあるかどうか確認します。
MoveTo |

参照

MarkPositions クラス | Steema.TeeChart.Styles 名前空間


ExistCustom

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.ExistCustom メソッド

マーカがカスタムな位置にあるかどうか確認します。

public Boolean ExistCustom()

戻り値

カスタムな位置にある場合、trueを返します。

参照

MarkPositions クラス | MarkPositions メンバ | Steema.TeeChart.Styles 名前空間


MoveTo

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.MoveTo メソッド

public Void MoveTo(Position& position,
     Int32 xpos,
     Int32 ypos)

参照

MarkPositions クラス | MarkPositions メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.MarkPositions プロパティ

パブリック プロパティ

Item

参照

MarkPositions クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.SeriesMarks+MarkPositions.Item プロパティ

public Position Item(Int32 index) {get; set;}

参照

MarkPositions クラス | MarkPositions メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Position

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks.Position クラス

系列マーカの位置。

この型のすべてのメンバの一覧については、Position メンバを参照してください。

System.Object
public class Position : Object

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

Position メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Position 全メンバ

Position 概要

コンストラクタ

Steema.TeeChart.Styles.SeriesMarks.Position..ctor

パブリック フィールド

ArrowFix
ArrowFrom
ArrowTo
Custom
HasMid
Height
LeftTop
MidPoint
Width

パブリック メソッド

Assign

パブリック プロパティ

Bounds 指定したインデックスのマーカの矩形範囲を返します。

参照

Position クラス | Steema.TeeChart.Styles 名前空間


Position コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position コンストラクタ

public SeriesMarks+Position()

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Position フィールド

パブリック フィールド

ArrowFix
ArrowFrom
ArrowTo
Custom
HasMid
Height
LeftTop
MidPoint
Width

参照

Position クラス | Steema.TeeChart.Styles 名前空間


ArrowFix

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowFix フィールド

public Boolean ArrowFix

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


ArrowFrom

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowFrom フィールド

public Point ArrowFrom

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


ArrowTo

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.ArrowTo フィールド

public Point ArrowTo

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Custom

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.Custom フィールド

public Boolean Custom

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


HasMid

Steema.TeeChart.Styles.SeriesMarks+Position.HasMid フィールド

public Boolean HasMid

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Height

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.Height フィールド

public Int32 Height

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


LeftTop

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.LeftTop フィールド

public Point LeftTop

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


MidPoint

Steema.TeeChart.Styles.SeriesMarks+Position.MidPoint フィールド

public Point MidPoint

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Width

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.Width フィールド

public Int32 Width

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Position メソッド

パブリック メソッド

Assign

参照

Position クラス | Steema.TeeChart.Styles 名前空間


Assign

Steema.TeeChart.Styles.SeriesMarks+Position.Assign メソッド

public Void Assign(Position source)

解説

系列コンポーネントから、ほかの系列コンポーネントへすべてのプロパティを割り当てます。

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Position プロパティ

パブリック プロパティ

Bounds 指定したインデックスのマーカの矩形範囲を返します。

参照

Position クラス | Steema.TeeChart.Styles 名前空間


Bounds

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesMarks+Position.Bounds プロパティ

指定したインデックスのマーカの矩形範囲を返します。

public Rectangle Bounds {get;}

解説

指定したインデックスのマーカの矩形範囲を返します。

参照

Position クラス | Position メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Symbols

Steema.TeeChart.Styles.SeriesMarks.Symbols クラス

系列マーカのシンボル。

この型のすべてのメンバの一覧については、Symbols メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class Symbols : Shape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Symbols メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Symbols 全メンバ

Symbols 概要

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

パブリック プロパティ

Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

コンストラクタ

Steema.TeeChart.Styles.SeriesMarks.Symbols..ctor

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Symbols クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Symbols フィールド

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Symbols クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Symbols メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Shapeの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

Symbols クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesMarks.Symbols プロパティ

パブリック プロパティ

Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープのイメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
Pen (Shapeの継承元) | シェープを描くペンを定義します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | シェープの透明度を0～100%で設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を設定します。

参照

Symbols クラス | Steema.TeeChart.Styles 名前空間


Symbols コンストラクタ

Steema.TeeChart.Styles.SeriesMarks+Symbols コンストラクタ

public SeriesMarks+Symbols(Chart c)

参照

Symbols クラス | Symbols メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesOHLCPoint

Steema.TeeChart.Styles.SeriesOHLCPoint クラス

このクラスは、XYZポイント特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesOHLCPoint メンバを参照してください。

System.Object
Steema.TeeChart.Styles.SeriesPoint
public class SeriesOHLCPoint : SeriesPoint

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesOHLCPoint 全メンバ

SeriesOHLCPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Close | 指定したインデックスのポイントの終値。
Color (SeriesPointの継承元) | 指定したインデックスのポイントの色。
Date | 指定したインデックスのポイントの日付値。
High | 指定したインデックスのポイントの高値。
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
Low | 指定したインデックスのポイントの安値。
Open | 指定したインデックスのポイントの始値。

参照

SeriesOHLCPoint クラス | Steema.TeeChart.Styles 名前空間


SeriesOHLCPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesOHLCPoint コンストラクタ

オーバーロードの一覧

public SeriesOHLCPoint()
public SeriesOHLCPoint(Steema.TeeChart.Styles.OHLC, System.Int32)

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesOHLCPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesOHLCPoint コンストラクタ

public SeriesOHLCPoint()

参照

SeriesOHLCPoint コンストラクタのオーバーロードの一覧 | SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesOHLCPoint コンストラクタ

Steema.TeeChart.Styles.SeriesOHLCPoint コンストラクタ

public SeriesOHLCPoint(OHLC s,
     Int32 i)

参照

SeriesOHLCPoint コンストラクタのオーバーロードの一覧 | SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesOHLCPoint プロパティ

パブリック プロパティ

Close | 指定したインデックスのポイントの終値。
Color (SeriesPointの継承元) | 指定したインデックスのポイントの色。
Date | 指定したインデックスのポイントの日付値。
High | 指定したインデックスのポイントの高値。
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
Low | 指定したインデックスのポイントの安値。
Open | 指定したインデックスのポイントの始値。

参照

SeriesOHLCPoint クラス | Steema.TeeChart.Styles 名前空間


Close

Steema.TeeChart.Styles.SeriesOHLCPoint.Close プロパティ

指定したインデックスのポイントの終値を取得/設定します。
public Double Close {get; set;}

解説

全ての株価の終値を保持するために使用されます。

XあるいはY値にアクセスする方法と同様に終値にアクセスできます。

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Date

Steema.TeeChart.Styles.SeriesOHLCPoint.Date プロパティ

指定したインデックスのポイントの日付値を取得/設定します。
public Double Date {get; set;}

解説

全ての株価の日付値を保持するために使用されます。XあるいはY値にアクセスする方法と同様に日付値にアクセスできます。

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


High

Steema.TeeChart.Styles.SeriesOHLCPoint.High プロパティ

指定したインデックスのポイントの高値を取得/設定します。
public Double High {get; set;}

解説

全ての株価の高値を保持するために使用されます。XあるいはY値にアクセスする方法と同様に高値にアクセスできます。

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Low

Steema.TeeChart.Styles.SeriesOHLCPoint.Low プロパティ

指定したインデックスのポイントの安値を取得/設定します。
public Double Low {get; set;}

解説

全ての株価の安値を保持するために使用されます。XあるいはY値にアクセスする方法と同様に安値にアクセスできます。

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Open

Steema.TeeChart.Styles.SeriesOHLCPoint.Open プロパティ

指定したインデックスのポイントの始値を取得/設定します。
public Double Open {get; set;}

解説

全ての株価の始値を保持するために使用されます。

XあるいはY値にアクセスする方法と同様に始値にアクセスできます。

参照

SeriesOHLCPoint クラス | SeriesOHLCPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPoint

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPoint クラス

このクラスは、ポイント特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesPoint メンバを参照してください。

System.Object
public class SeriesPoint : Object

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPoint 全メンバ

SeriesPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Color | 指定したインデックスのポイントの色。
Label | 指定したインデックスのポイントのラベル。

参照

SeriesPoint クラス | Steema.TeeChart.Styles 名前空間


SeriesPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPoint コンストラクタ

オーバーロードの一覧

public SeriesPoint()
public SeriesPoint(Steema.TeeChart.Styles.Series, System.Int32)

参照

SeriesPoint クラス | SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPoint コンストラクタ

public SeriesPoint()

参照

SeriesPoint コンストラクタのオーバーロードの一覧 | SeriesPoint クラス | SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesPoint コンストラクタ

Steema.TeeChart.Styles.SeriesPoint コンストラクタ

public SeriesPoint(Series s,
     Int32 i)

参照

SeriesPoint コンストラクタのオーバーロードの一覧 | SeriesPoint クラス | SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPoint プロパティ

パブリック プロパティ

Color | 指定したインデックスのポイントの色。
Label | 指定したインデックスのポイントのラベル。

参照

SeriesPoint クラス | Steema.TeeChart.Styles 名前空間


Color

Steema.TeeChart.Styles.SeriesPoint.Color プロパティ

インデックス付けされたポントの色。
public Color Color {get; set;}

解説

インデックス付けされたポントの色。

参照

SeriesPoint クラス | SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


Label

Steema.TeeChart.Styles.SeriesPoint.Label プロパティ

インデックス付けされたポイントのラベル。
public String Label {get; set;}

解説

インデックス付けされたポイントのラベル。

参照

SeriesPoint クラス | SeriesPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPointer

Steema.TeeChart.Styles.SeriesPointer クラス

一部の系列は、SeriesPointerクラスを返すPointerプロパティを持っています。Pointerは、各Y座標に描画されるシェープ形状です。

この型のすべてのメンバの一覧については、SeriesPointer メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public class SeriesPointer : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPointer 全メンバ

SeriesPointer 概要

コンストラクタ

Constructor

パブリック メソッド

Draw | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Brush | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | ポインタの色を設定します。
Dark3D | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Draw3D | 3Dモードでポインタを描画します。
EndZ |
Gradient | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ |
Pen | 系列ポインタの枠を描くためのペンを設定します。
Series |
StartZ |
Style | ポインタのスタイルを設定します。
Transparency | ポインタの透明度を0～100%で設定します。
VertSize | Sets ポインタの水平サイズをピクセル単位で取得/設定します。
Visible | ポインタを表示/非表示にします。

プロテクト フィールド

AllowChangeSize
bVisible
InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

GetBounds
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible

参照

SeriesPointer クラス | Steema.TeeChart.Styles 名前空間


SeriesPointer コンストラクタ

Steema.TeeChart.Styles.SeriesPointer コンストラクタ

public SeriesPointer(Chart c,
     Series s)

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPointer フィールド

プロテクト フィールド

AllowChangeSize
aSeries
bVisible
InternalUse (TeeBaseの継承元)
PXMinus
PXPlus
PYMinus
PYPlus
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesPointer クラス | Steema.TeeChart.Styles 名前空間


AllowChangeSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.AllowChangeSize フィールド

protected internal Boolean AllowChangeSize

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


aSeries

Steema.TeeChart.Styles.SeriesPointer.aSeries フィールド

protected Series aSeries

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


bVisible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.bVisible フィールド

protected internal Boolean bVisible

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


PXMinus

Steema.TeeChart.Styles.SeriesPointer.PXMinus フィールド

protected Int32 PXMinus

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


PXPlus

Steema.TeeChart.Styles.SeriesPointer.PXPlus フィールド

protected Int32 PXPlus

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


PYMinus

Steema.TeeChart.Styles.SeriesPointer.PYMinus フィールド

protected Int32 PYMinus

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


PYPlus

Steema.TeeChart.Styles.SeriesPointer.PYPlus フィールド

protected Int32 PYPlus

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPointer メソッド

パブリック メソッド

Draw | 内部使用。ポインタを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

GetBounds
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible

参照

SeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Clone

Steema.TeeChart.Styles.SeriesPointer.Clone メソッド

public Object Clone()

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Draw メソッド

オーバーロードの一覧

内部使用。ポインタを描画します。

public Void Draw(Steema.TeeChart.Drawing.Graphics3D, System.Boolean, System.Int32, System.Int32, System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.PointerStyles)
public Void Draw(System.Int32, System.Int32, System.Drawing.Color)
public Void Draw(System.Int32, System.Int32, System.Drawing.Color, Steema.TeeChart.Styles.PointerStyles)

解説

このメソッドは、指定したpx、pyの画面ピクセル座標にポインタを描画します。
ポインタは、現在のHorizSizeとVertSizeのサイズで描画されます。
これは、SeriesPointer.DrawPointerメソッドを呼び出します。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw メソッド

内部使用。ポインタを描画します。
public Void Draw(Graphics3D g,
     Boolean is3D,
     Int32 px,
     Int32 py,
     Int32 tmpHoriz,
     Int32 tmpVert,
     Color colorValue,
     PointerStyles aStyle)

参照

Draw オーバーロードの一覧 | SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Draw メソッド

public Void Draw(Int32 px,
     Int32 py,
     Color colorValue)

参照

Draw オーバーロードの一覧 | SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.SeriesPointer.Draw メソッド

public Void Draw(Int32 px,
     Int32 py,
     Color colorValue,
     PointerStyles aStyle)

参照

Draw オーバーロードの一覧 | SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.SeriesPointer.GetBounds メソッド

protected internal Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.SeriesPointer.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


ShouldSerializeVisible

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.ShouldSerializeVisible メソッド

protected virtual Boolean ShouldSerializeVisible()

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesPointer プロパティ

パブリック プロパティ

Brush | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Color | ポインタの色を設定します。
Dark3D | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Draw3D | 3Dモードでポインタを描画します。
EndZ |
Gradient | ポインタ内部を塗りつぶすグラデーションを定義します。
HorizSize | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ |
Pen | 系列ポインタの枠を描くためのペンを設定します。
Series |
StartZ |
Style | ポインタのスタイルを設定します。
Transparency | ポインタの透明度を0～100%で設定します。
VertSize | ポインタの垂直サイズをピクセル単位で取得/設定します。
Visible | ポインタを表示/非表示にします。

参照

SeriesPointer クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.SeriesPointer.Brush プロパティ

系列ポインタを塗りつぶすブラシを設定します。
public ChartBrush Brush {get; set;}

解説

系列ポインタを塗りつぶすブラシの種類を設定します。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Color プロパティ

ポインタの色を設定します。

public Color Color {get; set;}

解説

ポインタの色を設定します。

例

[C#]

lineSeries1.Pointer.Color = Color.Yellow;

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Dark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Dark3D プロパティ

3Dモードでポインタの側面を暗い色で塗りつぶします。

public Boolean Dark3D {get; set;}

解説

デフォルト値：true

3Dモードでポインタの側面を暗い色で塗りつぶします。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Draw3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Draw3D プロパティ

3Dモードでポインタを描画します。

public Boolean Draw3D {get; set;}

解説

デフォルト値：true

系列ポインタを3Dで描画するかどうかを制御します。現在、3Dで描画できるのは矩形のポインタのみです。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


EndZ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.EndZ プロパティ

public Int32 EndZ {get;}

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.SeriesPointer.Gradient プロパティ

ポインタ内部を塗りつぶすグラデーションを設定します。
public Gradient Gradient {get;}

解説

ポインタ内部を塗りつぶすグラデーションを設定します。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


HorizSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.HorizSize プロパティ

ポインタの水平サイズをピクセル単位で取得/設定します。

public Int32 HorizSize {get; set;}

解説

デフォルト値：4

倫理的なピクセルで系列ポインタの幅を指定します。

散布図系列から派生した系列は、通常HorizSizeプロパティとVertSizeプロパティをオーバーライドします。

たとえば、泡系列は、現在のHorizSizeやVertSizeを設定するためにRadiusプロパティを使用します。従って、これらのプロパティは、その系列の中で効果がありません。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


InflateMargins

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.InflateMargins プロパティ

ポインタを完全に表示させるために軸を再スケールするかどうか設定します。

public Boolean InflateMargins {get; set;}

解説

ポインタを完全に表示させるために軸を再スケールするかどうか設定します。このプロパティがfalseの場合、チャート軸のスケールがそのまま使用され、軸の限界に近いポイントは部分的に表示されます。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


MiddleZ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.MiddleZ プロパティ

public Int32 MiddleZ {get;}

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.SeriesPointer.Pen プロパティ

系列ポインタの枠を描くためのペンを設定します。
public ChartPen Pen {get; set;}

解説

系列ポインタの枠を描くためのペンを設定します。

Pen.Visibleプロパティをfalseに設定すると非表示になります。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Series

Steema.TeeChart.Styles.SeriesPointer.Series プロパティ

public Series Series {get;}

解説

実行時および読み込み専用。

PointerサブコンポーネントのTChartSeriesオーナーを返します。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


StartZ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.StartZ プロパティ

public Int32 StartZ {get;}

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.SeriesPointer.Style プロパティ

ポインタのスタイルを設定します。
public PointerStyles Style {get; set;}

解説

デフォルト値：Rectangle

系列ポインタを表示する形状を定義します。

デフォルトのスタイルは、Pointer.Draw3Dプロパティをtrueに設定することによりオプションで3Dモードにすることができます。

SeriesのPointer.Visibleプロパティは、trueでなければなりません。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.Transparency プロパティ

ポインタの透明度を0～100%で設定します。

public Int32 Transparency {get; set;}

解説

ポインタの透明度を0～100%で設定します。

例

[C#]

lineSeries1.Pointer.Transparency = 50;

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


VertSize

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesPointer.VertSize プロパティ

ポインタの垂直サイズをピクセル単位で取得/設定します。

public Int32 VertSize {get; set;}

解説

デフォルト値：4

倫理的なピクセルで系列ポインタの高さを指定します。

散布図系列から派生した系列は、通常HorizSizeプロパティとVertSizeプロパティをオーバーライドします。

たとえば、泡系列は、現在のHorizSizeやVertSizeを設定するためにRadiusプロパティを使用します。従って、これらのプロパティは、その系列の中で効果がありません。

例

[C#]

//ガントチャートでバーの幅（厚さ）を指定する方法は以下のようになります。

Steema.TeeChart.Styles.Gantt gantt1 = new
Steema.TeeChart.Styles.Gantt(tChart1);
gantt1.FillSampleValues(6);
gantt1.Pointer.VertSize = 20;

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Visible

Steema.TeeChart.Styles.SeriesPointer.Visible プロパティ

ポインタを表示/非表示にします。
public Boolean Visible {get; set;}

解説

系列ポインタを表示/非表示にします。

散布図系列（あるいは散布図系列から派生している系列クラス）を使用する場合、このプロパティをfalseに設定すると、何も表示しなくなります。

ポインタはリボン系列あるいは面系列と一緒に使用すると便利です。

ポイントが可視になっていると、4つのチャート軸（左、右、上、下）に適用されるマージンが追加されます。
これは、ポイントとちょうど軸の限界の位置に表示するためです。

IPointer.InflateMarginsプロパティをfalseに設定することにより、このマージンの追加を無効にすることができます。

ポイントは、IPointer.Brushプロパティを使用して塗りつぶされます。

参照

SeriesPointer クラス | SeriesPointer メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYPoint

Steema.TeeChart.Styles.SeriesXYPoint クラス

このクラスは、XYポイント特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesXYPoint メンバを参照してください。

System.Object
Steema.TeeChart.Styles.SeriesPoint
public class SeriesXYPoint : SeriesPoint

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYPoint 全メンバ

SeriesXYPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Color (SeriesPointの継承元) | 指定したインデックスのポイントの色。
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
X | 指定したインデックスのポイントのX値。
Y | 指定したインデックスのポイントのY値。

参照

SeriesXYPoint クラス | Steema.TeeChart.Styles 名前空間


SeriesXYPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesXYPoint コンストラクタ

オーバーロードの一覧

public SeriesXYPoint()
public SeriesXYPoint(Steema.TeeChart.Styles.Series, System.Int32)

参照

SeriesXYPoint クラス | SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesXYPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesXYPoint コンストラクタ

public SeriesXYPoint()

参照

SeriesXYPoint コンストラクタのオーバーロードの一覧 | SeriesXYPoint クラス | SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesXYPoint コンストラクタ

Steema.TeeChart.Styles.SeriesXYPoint コンストラクタ

public SeriesXYPoint(Series s,
     Int32 i)

参照

SeriesXYPoint コンストラクタのオーバーロードの一覧 | SeriesXYPoint クラス | SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYPoint プロパティ

パブリック プロパティ

Color (SeriesPointの継承元) | 指定したインデックスのポイントの色
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
X | 指定したインデックスのポイントのX値。
Y | 指定したインデックスのポイントのY値。

参照

SeriesXYPoint クラス | Steema.TeeChart.Styles 名前空間


X

Steema.TeeChart.Styles.SeriesXYPoint.X プロパティ

指定したインデックスのポイントのX値。
public Double X {get; set;}

解説

各データポイントのValueListにアクセスするために使用してください。

例

line1.Points[3].X=50;
// リボン系列の2番目のX値を50に設定します。

参照

SeriesXYPoint クラス | SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


Y

Steema.TeeChart.Styles.SeriesXYPoint.Y プロパティ

インデックス付けされたポイントのY値。
public Double Y {get; set;}

解説

インデックス付けされたポイントのY値。

参照

SeriesXYPoint クラス | SeriesXYPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYZPoint

Steema.TeeChart.Styles.SeriesXYZPoint クラス

このクラスは、XYZポイント特性にアクセスします。

この型のすべてのメンバの一覧については、SeriesXYZPoint メンバを参照してください。

System.Object
Steema.TeeChart.Styles.SeriesPoint
Steema.TeeChart.Styles.SeriesXYPoint
public class SeriesXYZPoint : SeriesXYPoint

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SeriesXYZPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYZPoint 全メンバ

SeriesXYZPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック プロパティ

Color (SeriesPointの継承元) | 指定したインデックスのポイントの色。
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
X (SeriesXYPointの継承元) | 指定したインデックスのポイントのX値。
Y (SeriesXYPointの継承元) | 指定したインデックスのポイントのY値。
Z | 指定したインデックスのポイントのZ値。

参照

SeriesXYZPoint クラス | Steema.TeeChart.Styles 名前空間


SeriesXYZPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesXYZPoint コンストラクタ

オーバーロードの一覧

public SeriesXYZPoint()
public SeriesXYZPoint(Steema.TeeChart.Styles.Custom3D, System.Int32)

参照

SeriesXYZPoint クラス | SeriesXYZPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesXYZPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.SeriesXYZPoint コンストラクタ

public SeriesXYZPoint()

参照

SeriesXYZPoint コンストラクタのオーバーロードの一覧 | SeriesXYZPoint クラス | SeriesXYZPoint メンバ | Steema.TeeChart.Styles 名前空間


SeriesXYZPoint コンストラクタ

Steema.TeeChart.Styles.SeriesXYZPoint コンストラクタ

public SeriesXYZPoint(Custom3D s,
     Int32 i)

参照

SeriesXYZPoint コンストラクタのオーバーロードの一覧 | SeriesXYZPoint クラス | SeriesXYZPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SeriesXYZPoint プロパティ

パブリック プロパティ

Color (SeriesPointの継承元) | 指定したインデックスのポイントの色。
Label (SeriesPointの継承元) | 指定したインデックスのポイントのラベル。
X (SeriesXYPointの継承元) | 指定したインデックスのポイントのX値。
Y (SeriesXYPointの継承元) | 指定したインデックスのポイントのY値。
Z | 指定したインデックスのポイントのZ値。

参照

SeriesXYZPoint クラス | Steema.TeeChart.Styles 名前空間


Z

Steema.TeeChart.Styles.SeriesXYZPoint.Z プロパティ

インデックス付けされたZ値。
public Double Z {get; set;}

解説

インデックス付けされたZ値。

参照

SeriesXYZPoint クラス | SeriesXYZPoint メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape

Steema.TeeChart.Styles.Shape クラス

シェープ系列。

この型のすべてのメンバの一覧については、Shape メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class Shape : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Shape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape 全メンバ

Shape 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | sパラメーターがSelfと同じ場合、falseを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | シェープの背面を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | シェープ系列のテキストを出力するフォントを定義します。
Format |
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | シェープ系列のグラデーション特性にアクセスします。
HorizAlignment | シェープ系列内のテキストの水平方向の揃え位置を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | シェープ系列を描くペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Style | シェープ系列をチャート上にどのように表示するかを定義します。
Text | シェープ内にカスタマイズした文字列を表示します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent | シェープの内側を塗りつぶすシェープのブラシ属性を使用するかどうか設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAlignment | シェープ系列内のテキストの垂直方向の揃え位置を設定します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
X0 | シェープ系列の左座標を定義します。
X1 | シェープ系列の右座標を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
XYStyle |
Y0 | シェープ系列の上座標を定義します。
Y1 | シェープ系列の下座標を定義します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder |
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Shape クラス | Steema.TeeChart.Styles 名前空間


Shape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape コンストラクタ

オーバーロードの一覧

public Shape()
public Shape(Steema.TeeChart.Chart)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Shape コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape コンストラクタ

public Shape()

参照

Shape コンストラクタのオーバーロードの一覧 | Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Shape コンストラクタ

Steema.TeeChart.Styles.Shape コンストラクタ

public Shape(Chart c)

参照

Shape コンストラクタのオーバーロードの一覧 | Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Shape クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Shape クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf | sパラメーターがSelfと同じ場合、falseを返します。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder |
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Shape クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


CalcZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.CalcZOrder メソッド

protected internal virtual Void CalcZOrder()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのインデックスを返します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Clicked メソッド

系列で｢クリックされた｣ポイント値のインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Shape.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.Shape.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Shape.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Shape.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Shape.IsValidSourceOf メソッド

sパラメーターがSelfと同じ場合、falseを返します。
public override Boolean IsValidSourceOf(Series s)

解説

sパラメーターがSelfと同じ場合、falseを返します。
デザイン時および実行時にDataSourceプロパティを有効にするために使用されます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Shape.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


MoreSameZOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.MoreSameZOrder メソッド

protected virtual Boolean MoreSameZOrder()

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Shape.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Shape.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Shape.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Shape プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | シェープの背面を塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | シェープ系列のテキストを出力するフォントを定義します。
Format |
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | シェープ系列のグラデーション特性にアクセスします。
HorizAlignment | シェープ系列内のテキストの水平方向の揃え位置を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | シェープ系列を描くペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Style | シェープ系列をチャート上にどのように表示するかを定義します。
Text | シェープ内にカスタマイズした文字列を表示します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparent | シェープの内側を塗りつぶすシェープのブラシ属性を使用するかどうか設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAlignment | シェープ系列内のテキストの垂直方向の揃え位置を設定します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
X0 | シェープ系列の左座標を定義します。
X1 | シェープ系列の右座標を定義します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
XYStyle |
Y0 | シェープ系列の上座標を定義します。
Y1 | シェープ系列の下座標を定義します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Shape クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Shape.Brush プロパティ

シェープの背面を塗りつぶすブラシを設定します。
public ChartBrush Brush {get;}

解説

シェープの背面を塗りつぶすブラシを設定します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Shape.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Font

Steema.TeeChart.Styles.Shape.Font プロパティ

シェープ系列のテキストを出力するフォントを定義します。
public ChartFont Font {get;}

解説

TChartShape.Textの文字列を出力するために使用されるフォント属性を定義します。自動的にフォントのサイズは変更されません。従って、シェープテキストがシェープの境界を越えないように、適切なフォントサイズを指定しなければなりません。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Format

Steema.TeeChart.Styles.Shape.Format プロパティ

public TextShape Format {get;}

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.Shape.Gradient プロパティ

シェープ系列のグラデーション特性にアクセスします。
public Gradient Gradient {get;}

解説

シェープ系列のグラデーション特性にアクセスします。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


HorizAlignment

Steema.TeeChart.Styles.Shape.HorizAlignment プロパティ

シェープ系列内のテキストの水平方向の揃え位置を設定します。
public ShapeTextHorizAlign HorizAlignment {get; set;}

解説

デフォルト値：Centre

シェープ系列内のテキストの水平方向の揃え位置を設定します（左、中央、右）。

例

[C#]

shapeSeries1.HorizAlignment = ShapeTextHorizAlign.Right;

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Shape.Pen プロパティ

シェープ系列を描くペンを定義します。
public ChartPen Pen {get;}

解説

シェープ系列を描くペンを定義します。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Style

Steema.TeeChart.Styles.Shape.Style プロパティ

シェープ系列をチャート上にどのように表示するかを定義します。
public ShapeStyles Style {get; set;}

解説

デフォルト値：Circle
シェープ系列をチャート上にどのように表示するかを定義します。
以下は使用可能な値です。

Rectangle 矩形
Circle 円
VertLine 垂直線
HorizLine 水平線
Triangle 三角形
InvertTriangle 倒立三角形
Line 直線
Diamond 菱形
Cube 立方体
Cross 交差線
DiagCross 斜め交差線
Star 星形
Pyramid 四角錐
InvertPyramid 倒立四角錐

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Text プロパティ

シェープ内にカスタマイズした文字列を表示します。

public String[] Text {get; set;}

解説

シェープ内にカスタマイズした文字列を表示します。

FontプロパティやAligmentプロパティを使用して、テキストの表示を制御できます。

メモ：メタファイルを作成する時やチャートをズームする時などは、シェープのフォントサイズの値を変更しなければならない場合があります。

例

[C#]

string[] shapeSeriesText = new string[1];
shapeSeriesText[0] = "MY TEXT";
shapeSeries1.Text = shapeSeriesText;

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Transparent

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Transparent プロパティ

シェープの内側を塗りつぶすシェープのブラシ属性を使用するかどうか設定します。

public Boolean Transparent {get; set;}

解説

デフォルト値：false

シェープの内側を塗りつぶすシェープのブラシ属性を使用するかどうかを設定します。

falseに設定されていると、シェープはその背景を描画しません。つまり、シェープ系列の後景にあるチャート内容は透けてシェープ内に表示されることになります。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


VertAlignment

Steema.TeeChart.Styles.Shape.VertAlignment プロパティ

シェープ系列内のテキストの垂直方向の揃え位置を設定します。
public ShapeTextVertAlign VertAlignment {get; set;}

解説

シェープ系列内のテキストの垂直方向の揃え位置を設定します（上、中央、下）。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


X0

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.X0 プロパティ

シェープ系列の左座標を定義します。

public Double X0 {get; set;}

解説

シェープ系列の左座標を定義します。

値は、軸座標で設定します。

XScreenToValueメソッドやYScreenToValueメソッドのような複数のTChartやSeriesのメソッドを使用して、画面ピクセル座標から値へ、あるいはその逆へ変換できます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


X1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.X1 プロパティ

シェープ系列の右座標を定義します。

public Double X1 {get; set;}

解説

シェープ系列の右座標を定義します。

値は、軸座標で設定します。

XScreenToValueメソッドやYScreenToValueメソッドのような複数のTChartやSeriesのメソッドを使用して、画面ピクセル座標から値へ、あるいはその逆へ変換できます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


XYStyle

Steema.TeeChart.Styles.Shape.XYStyle プロパティ

public ShapeXYStyles XYStyle {get; set;}

解説

デフォルト値：Axis

Axis、AxisOrigin、Pixelsが使用できます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Y0

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Y0 プロパティ

シェープ系列の上座標を定義します。

public Double Y0 {get; set;}

解説

シェープ系列の上座標を定義します。

値は、軸座標で設定します。

XScreenToValueメソッドやYScreenToValueメソッドのような複数のTChartやSeriesのメソッドを使用して、画面ピクセル座標から値へ、あるいはその逆へ変換できます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Y1

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Shape.Y1 プロパティ

シェープ系列の下座標を定義します。

public Double Y1 {get; set;}

解説

シェープ系列の下座標を定義します。

値は、軸座標で設定します。

XScreenToValueメソッドやYScreenToValueメソッドのような複数のTChartやSeriesのメソッドを使用して、画面ピクセル座標から値へ、あるいはその逆へ変換できます。

参照

Shape クラス | Shape メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ShapeStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ShapeStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum ShapeStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Rectangle | 矩形
Circle | 円
VertLine | 垂直線
HorizLine | 水平線
Triangle | 三角形
InvertTriangle | 倒立三角形
Line | 直線
Diamond | 菱形
Cube | 立方体
Cross | 交差線
DiagCross | 斜め交差線
Star | 星型
Pyramid | 四角錐
InvertPyramid | 倒立四角錐

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ShapeTextHorizAlign

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ShapeTextHorizAlign 列挙体

HorizAlignmentプロパティの使用可能な値です。

[Serializable]
public enum ShapeTextHorizAlign : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Left | テキストを水平方向の左に揃えます。
Center | テキストを水平方向の中央に揃えます。
Right | テキストを水平方向の右に揃えます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ShapeTextVertAlign

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ShapeTextVertAlign 列挙体

VertAlignmentプロパティの使用可能な値です。

[Serializable]
public enum ShapeTextVertAlign : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Top | テキストを垂直方向の上部に揃えます。
Center | テキストを垂直方向の中央に揃えます。
Bottom | テキストを垂直方向の下部に揃えます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ShapeXYStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ShapeXYStyles 列挙体

XYStyleプロパティの使用可能な値です。

[Serializable]
public enum ShapeXYStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Pixels | X,Y座標値をピクセルで定義します。0,0はパネルの左上です。
Axis | X,Yを軸単位で定義します。
AxisOrigin | 軸単位で左と上を定義して、ピクセルで右と下を定義します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Sides

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Sides 列挙体

今後使用予定

[Serializable]
public enum Sides : Enum , IComparable, IFormattable
, IConvertible

パブリック メンバ

メンバ名 説明

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith

Steema.TeeChart.Styles.Smith クラス

スミス系列。

この型のすべてのメンバの一覧については、Smith メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
public class Smith : Circular , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Smith メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith 全メンバ

Smith 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint |
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint |
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | チャートを塗りつぶすブラシを定義します。
CCirclePen | スミス系列のリアクタンスサークルを描画するペンを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CirclePen | スミス系列の外円を描くペンを定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
CLabels | リアクタンスのラベル(定数）を表示/非表示にします。
CLabelsFont | xCircle（リアクタンスサークル）のラベルのフォントを定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
ImagSymbol |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | スミス系列のチャートを描画するペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | スミス系列のチャートを描画するペンを定義します。
RCirclePen | スミス系列のレジスタンスサークルを描画するペンを定義します。
RLabels | レジスタンスのラベル（定数）を表示/非表示にします。
RLabelsFont | rCircle（レジスタンスサークル）のラベルのフォントを定義します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Smith クラス | Steema.TeeChart.Styles 名前空間


Smith コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith コンストラクタ

オーバーロードの一覧

public Smith()
public Smith(Steema.TeeChart.Chart)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Smith コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith コンストラクタ

public Smith()

参照

Smith コンストラクタのオーバーロードの一覧 | Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Smith コンストラクタ

Steema.TeeChart.Styles.Smith コンストラクタ

public Smith(Chart c)

参照

Smith コンストラクタのオーバーロードの一覧 | Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Smith クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
InternalUse (TeeBaseの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Smith クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Circularの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked | 系列で｢クリックされた｣ポイントのインデックスを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint |
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint |
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Smith クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.CalcXPos メソッド

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

public virtual Int32 CalcXPos(Int32 valueIndex)

解説

この座標値は水平軸に対応する系列を使用して計算されます。

指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。

この座標値は、水平軸に関連付けされている系列を使用して計算されます。

例

系列ポイントの水平画面座標値を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.CalcYPos メソッド

指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。

public virtual Int32 CalcYPos(Int32 valueIndex)

解説

指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。

この座標値は、垂直軸に関連付けされている系列を使用して計算されます。

例

系列ポイントの垂直画面座標値を調べる場合は次のようになります。

[C#]

if (tChart3[0].Count>0)
for (int i=0;i<tChart3[0].Count;i++)
{
//系列のインデックスを使用
int tmpX=tChart3[0].CalcXPos(i); //ピクセル値を返す
int tmpY=tChart3[0].CalcYPos(i);
}

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.Clicked メソッド

オーバーロードの一覧

系列で｢クリックされた｣ポイントのインデックスを返します。

public virtual Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのインデックスを返します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.Clicked メソッド

系列で｢クリックされた｣ポイント値のインデックスを返します。

public virtual Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.Smith.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Smith.Draw メソッド

public override Void Draw()

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Smith.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle rect)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Smith.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Smith.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


ScreenPointToValuePoint

Steema.TeeChart.Styles.Smith.ScreenPointToValuePoint メソッド

public override PointDouble ScreenPointToValuePoint(Int32 x,
     Int32 y)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Smith.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


ValuePointToScreenPoint

Steema.TeeChart.Styles.Smith.ValuePointToScreenPoint メソッド

public override Point ValuePointToScreenPoint(Double resist,
     Double react)

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Smith プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | チャートを塗りつぶすブラシを定義します。
CCirclePen | スミス系列のリアクタンスサークルを描画するペンを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CirclePen | スミス系列の外円を描くペンを定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
CLabels | リアクタンスのラベル(定数）を表示/非表示にします。
CLabelsFont | xCircle（リアクタンスサークル）のラベルのフォントを定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
ImagSymbol |
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen | スミス系列のチャートを描画するペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer | スミス系列のチャートを描画するペンを定義します。
RCirclePen | スミス系列のレジスタンスサークルを描画するペンを定義します。
RLabels | レジスタンスのラベル（定数）を表示/非表示にします。
RLabelsFont | rCircle（レジスタンスサークル）のラベルのフォントを定義します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Smith クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.Smith.Brush プロパティ

チャートを塗りつぶすブラシを定義します。
public ChartBrush Brush {get;}

解説

チャートを塗りつぶすブラシを定義します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CCirclePen

Steema.TeeChart.Styles.Smith.CCirclePen プロパティ

スミス系列のリアクタンスサークルを描画するペンを定義します。
public GridPen CCirclePen {get;}

解説

xCircle（リアクタンスサークル）のペン。

スミス系列のリアクタンスサークルの色やスタイルを変更するために使用してください。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CirclePen

Steema.TeeChart.Styles.Smith.CirclePen プロパティ

スミス系列の外円を描くペンを定義します。
public ChartPen CirclePen {get;}

解説

レジスタンス = 0 rCircleペン。（外円）

スミス系列の外円の色やスタイルを変更するために使用してください。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.CLabels プロパティ

リアクタンスのラベル(定数）を表示/非表示にします。

public Boolean CLabels {get; set;}

解説

xCircleのラベルを表示/非表示にします。

trueに設定すると、リアクタンスのラベルが表示されます。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


CLabelsFont

Steema.TeeChart.Styles.Smith.CLabelsFont プロパティ

xCircle（リアクタンスサークル）のラベルのフォントを定義します。
public ChartFont CLabelsFont {get;}

解説

xCircle（リアクタンスサークル）のラベルのフォントを定義します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Smith.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


ImagSymbol

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.ImagSymbol プロパティ

public String ImagSymbol {get; set;}

解説

スミス系列の周りに軸ラベルと共に表示する虚数シンボルテキストを設定します。

デフォルトは、小文字｢i｣です。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.Smith.Pen プロパティ

スミス系列のチャートを描画するペンを定義します。
public ChartPen Pen {get;}

解説

スミス系列のチャートを描画するペンを定義します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Pointer

Steema.TeeChart.Styles.Smith.Pointer プロパティ

系列ポインタの特性を設定します。
public SeriesPointer Pointer {get;}

解説

このプロパティには、Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


RCirclePen

Steema.TeeChart.Styles.Smith.RCirclePen プロパティ

スミス系列のレジスタンスサークルを描画するペンを定義します。
public GridPen RCirclePen {get;}

解説

rCircle（レジスタンスサークル）のペン。

スミス系列のレジスタンスサークルの色やスタイルを変更するために使用してください。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


RLabels

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Smith.RLabels プロパティ

レジスタンスのラベル（定数）を表示/非表示にします。

public Boolean RLabels {get; set;}

解説

rCircle（レジスタンスサークル）のラベルを表示/非表示にします。

レジスタンスのラベル（定数）を表示/非表示にするために使用してください。trueに設定すると、レジスタンスのラベルが表示されます。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


RLabelsFont

Steema.TeeChart.Styles.Smith.RLabelsFont プロパティ

rCircle（レジスタンスサークル）のラベルのフォントを定義します。
public ChartFont RLabelsFont {get;}

解説

rCircle（レジスタンスサークル）のラベルのフォントを定義します。

参照

Smith クラス | Smith メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing

Steema.TeeChart.Styles.Spacing クラス

この型のすべてのメンバの一覧については、Spacing メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Spacing : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Spacing メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing 全メンバ

Spacing 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Horizontal |
Vertical |

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Spacing クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing コンストラクタ

オーバーロードの一覧

public Spacing()
public Spacing(Steema.TeeChart.Styles.Series)

参照

Spacing クラス | Spacing メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing コンストラクタ

public Spacing()

参照

Spacing コンストラクタのオーバーロードの一覧 | Spacing クラス | Spacing メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing コンストラクタ

public Spacing(Series s)

参照

Spacing コンストラクタのオーバーロードの一覧 | Spacing クラス | Spacing メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Spacing クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing メソッド

パブリック メソッド

Invalidate (TeeBaseの継承元) キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Spacing クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Spacing プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Horizontal |
Vertical |

参照

Spacing クラス | Steema.TeeChart.Styles 名前空間


Horizontal

Steema.TeeChart.Styles.Spacing.Horizontal プロパティ

public Int32 Horizontal {get; set;}

参照

Spacing クラス | Spacing メンバ | Steema.TeeChart.Styles 名前空間


Vertical

Steema.TeeChart.Styles.Spacing.Vertical プロパティ

public Int32 Vertical {get; set;}

参照

Spacing クラス | Spacing メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.StringList

Steema.TeeChart.Styles.StringList クラス

このクラスは、SeriesのLabelsプロパティにより操作されます。

この型のすべてのメンバの一覧については、StringList メンバを参照してください。

System.Object
System.Collections.Generic.List<System.String>
[Serializable]
public class StringList : List<String>
, IList<String>, ICollection<String>, IEnumerable<String>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

StringList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.StringList 全メンバ

StringList 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

IndexOf

パブリック プロパティ

Item

参照

StringList クラス | Steema.TeeChart.Styles 名前空間


StringList コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.StringList コンストラクタ

オーバーロードの一覧

public StringList()
public StringList(System.Int32)

参照

StringList クラス | StringList メンバ | Steema.TeeChart.Styles 名前空間


StringList コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.StringList コンストラクタ

public StringList()

参照

StringList コンストラクタのオーバーロードの一覧 | StringList クラス | StringList メンバ | Steema.TeeChart.Styles 名前空間


StringList コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.StringList コンストラクタ

public StringList(Int32 capacity)

参照

StringList コンストラクタのオーバーロードの一覧 | StringList クラス | StringList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.StringList メソッド

パブリック メソッド

IndexOf

参照

StringList クラス | Steema.TeeChart.Styles 名前空間


IndexOf

Steema.TeeChart.Styles.StringList.IndexOf メソッド

public Int32 IndexOf(String value,
     Boolean caseSensitive)

参照

StringList クラス | StringList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.StringList プロパティ

パブリック プロパティ

Item

参照

StringList クラス | Steema.TeeChart.Styles 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Styles.StringList.Item プロパティ

public String Item(Int32 index) {get; set;}

参照

StringList クラス | StringList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface

Steema.TeeChart.Styles.Surface クラス

サーフェス系列。

この型のすべてのメンバの一覧については、Surface メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
public class Surface : Custom3DGrid , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Surface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface 全メンバ

Surface 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DotFrame | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines |
SmoothPalette | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall | ウォーターフォールとしての表示を有効/無効にします。
WaterLines | 値ラインを描くペンを設定します。
WireFrame | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX
iCalcY
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast |
ShouldDrawSides |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Surface クラス | Steema.TeeChart.Styles 名前空間


Surface コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface コンストラクタ

オーバーロードの一覧

public Surface(Steema.TeeChart.Chart)
public Surface()

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Surface コンストラクタ

Steema.TeeChart.Styles.Surface コンストラクタ

public Surface(Chart c)

参照

Surface コンストラクタのオーバーロードの一覧 | Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Surface コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface コンストラクタ

public Surface()

参照

Surface コンストラクタのオーバーロードの一覧 | Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Surface クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX
iCalcY
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Surface クラス | Steema.TeeChart.Styles 名前空間


bWaterFall

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface.bWaterFall フィールド

protected internal Boolean bWaterFall

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


iCalcX

Steema.TeeChart.Styles.Surface.iCalcX フィールド

protected internal Int32 iCalcX

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


iCalcY

Steema.TeeChart.Styles.Surface.iCalcY フィールド

protected internal Int32 iCalcY

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Points

Steema.TeeChart.Styles.Surface.Points フィールド

protected Point[] Points

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast |
ShouldDrawSides |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Surface クラス | Steema.TeeChart.Styles 名前空間


CellsOrientation

Steema.TeeChart.Styles.Surface.CellsOrientation メソッド

public CellsOrientation CellsOrientation()

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Surface.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

解説

系列で｢クリックされた｣ポイントのValueIndexを返します。
「クリックされた」とは、XとY座標値が、ポイント画面領域の境界内にあることを意味します。
「触れた」のポイントがなければ、Clickedは-1を返します。

サーフェス系列については、CellsOrientationメソッドを参照してください。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Surface.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Surface.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Surface.Draw メソッド

public override Void Draw()

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


DrawCell

Steema.TeeChart.Styles.Surface.DrawCell メソッド

protected internal abstract Void DrawCell(Int32 x,
     Int32 z)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


DrawSidePortion

Steema.TeeChart.Styles.Surface.DrawSidePortion メソッド

protected abstract Void DrawSidePortion(Point[] P,
     Int32 z0,
     Int32 z1)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


FastCalcPoints

Steema.TeeChart.Styles.Surface.FastCalcPoints メソッド

public Boolean FastCalcPoints(Int32 x,
     Int32 z,
     Point3D& p0,
     Point3D& p1,
     Color& color0,
     Color& color1)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


FourGridIndex

Steema.TeeChart.Styles.Surface.FourGridIndex メソッド

protected Boolean FourGridIndex(Int32 x,
     Int32 z)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Surface.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.Surface.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Surface.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


ShouldDrawFast

Steema.TeeChart.Styles.Surface.ShouldDrawFast メソッド

protected abstract Boolean ShouldDrawFast()

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


ShouldDrawSides

Steema.TeeChart.Styles.Surface.ShouldDrawSides メソッド

protected abstract Boolean ShouldDrawSides()

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Surface プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
DotFrame | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines |
SmoothPalette | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall | ウォーターフォールとしての表示を有効/無効にします。
WaterLines | 値ラインを描くペンを設定します。
WireFrame | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Surface クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Surface.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


DotFrame

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface.DotFrame プロパティ

ドットグリット（ピクセル）としてサーフェス系列を設定します。

public Boolean DotFrame {get; set;}

解説

デフォルト値：false

ドットグリッド（ピクセル）としてサーフェス系列を設定します。これは、WireFrameと似ていますが、サーフェスのポイントの間に線が描画されません。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


HideCells

Steema.TeeChart.Styles.Surface.HideCells プロパティ

public Boolean HideCells {get; set;}

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


SideBrush

Steema.TeeChart.Styles.Surface.SideBrush プロパティ

サーフェス系列の側面を塗りつぶすブラシを設定します。
public ChartBrush SideBrush {get; set;}

解説

サーフェス系列の側面を塗りつぶす場合に使用する色やパターンを指定します。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


SideLines

Steema.TeeChart.Styles.Surface.SideLines プロパティ

public ChartPen SideLines {get; set;}

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


SmoothPalette

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface.SmoothPalette プロパティ

サーフェス系列のセルの色を設定します。

public Boolean SmoothPalette {get; set;}

解説

デフォルト値：false
サーフェス系列のセルの色を設定するために使用してください。trueに設定した場合、各セルは4つ角の色の平均として計算された色を使用して塗りつぶされます。 falseに設定した場合、1つ角の色のみが使用されます。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


WaterFall

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface.WaterFall プロパティ

ウォーターフォールとしての表示を有効/無効にします。

public Boolean WaterFall {get; set;}

解説

デフォルト値：false

trueの場合、チャートをウォーターフォールとして表示します。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


WaterLines

Steema.TeeChart.Styles.Surface.WaterLines プロパティ

値ラインを描くペンを設定します。
public ChartPen WaterLines {get;}

解説

値ラインを描くペンを設定します。

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


WireFrame

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Surface.WireFrame プロパティ

グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。

public Boolean WireFrame {get; set;}

解説

デフォルト値：false

trueの場合、サーフェスポリゴンは塗りつぶされません。Surface.Pen.Visibleがtrue(デフォルト)の場合、サーフェスのポイントは接続線と共に｢グリッド｣あるいは｢ワイヤーフレーム｣として表示されます。

例

[C#]

Steema.TeeChart.Styles.Surface Series1 = new Steema.TeeChart.Styles.Surface();
tChart1.Series.Add(Series1);
Series1.WireFrame = true;
Series1.Pen.Color = Color.Red;

参照

Surface クラス | Surface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SurfaceSides

Steema.TeeChart.Styles.SurfaceSides クラス

この型のすべてのメンバの一覧については、SurfaceSides メンバを参照してください。

System.Object
public class SurfaceSides : Object

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

SurfaceSides メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SurfaceSides 全メンバ

SurfaceSides 概要

コンストラクタ

Constructor

パブリック プロパティ

Brush
Levels
Pen

参照

SurfaceSides クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SurfaceSides コンストラクタ

public SurfaceSides(Surface Series)

参照

SurfaceSides クラス | SurfaceSides メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.SurfaceSides プロパティ

パブリック プロパティ

Brush
Levels
Pen

参照

SurfaceSides クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.SurfaceSides.Brush プロパティ

public ChartBrush Brush {get; set;}

参照

SurfaceSides クラス | SurfaceSides メンバ | Steema.TeeChart.Styles 名前空間


Levels

Steema.TeeChart.Styles.SurfaceSides.Levels プロパティ

public Boolean Levels {get; set;}

参照

SurfaceSides クラス | SurfaceSides メンバ | Steema.TeeChart.Styles 名前空間


Pen

Steema.TeeChart.Styles.SurfaceSides.Pen プロパティ

public ChartPen Pen {get; set;}

参照

SurfaceSides クラス | SurfaceSides メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud

Steema.TeeChart.Styles.TagCloud クラス

この型のすべてのメンバの一覧については、TagCloud メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class TagCloud : Custom3DPalette , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud 全メンバ

TagCloud 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
DrawTag | このイベントは、タグを表示する時やタグの幅や高さをピクセル単位で計算するためにタグのテキストやフォントが使用される際に呼び出されます。このイベントは、各タグに異なるフォントサイズをカスタマイズするために使用できます。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
Positions |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddTag | 指定したテキストと値（アクセス頻度）でタグを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetTagFontSize | 指定した値インデックスのタグのフォントサイズを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
Sort |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
Filter | タグを表示するフィルタ文字列を取得/設定します。このプロパティに設定された文字列を含むタグのみが表示されます。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | タグのフォント特性を取得/設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | グラデーションを取得/設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TagSeparation | 水平方向のタグ間のスペースを百分率で取得/設定します。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnDrawTag |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

TagCloud クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud コンストラクタ

オーバーロードの一覧

public TagCloud(Steema.TeeChart.Chart)
public TagCloud()

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud コンストラクタ

public TagCloud(Chart c)

参照

TagCloud コンストラクタのオーバーロードの一覧 | TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud コンストラクタ

public TagCloud()

参照

TagCloud コンストラクタのオーバーロードの一覧 | TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
DrawTag | このイベントは、タグを表示する時やタグの幅や高さをピクセル単位で計算するためにタグのテキストやフォントが使用される際に呼び出されます。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

TagCloud クラス | Steema.TeeChart.Styles 名前空間


DrawTag

Steema.TeeChart.Styles.TagCloud.DrawTag イベント

このイベントは、タグを表示する時やタグの幅や高さをピクセル単位で計算するためにタグのテキストやフォントが使用される際に呼び出されます。
このイベントは、各タグに異なるフォントサイズをカスタマイズするために使用できます。
public TagCloudDrawTagEventHandler  DrawTag

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
Positions |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

TagCloud クラス | Steema.TeeChart.Styles 名前空間


Positions

Steema.TeeChart.Styles.TagCloud.Positions フィールド

public Rectangle[] Positions

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddTag | 指定したテキストと値（アクセス頻度）でタグを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos |
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos |
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetTagFontSize | 指定した値インデックスのタグのフォントサイズを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
Sort |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnDrawTag |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

TagCloud クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.TagCloud.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


AddTag

Steema.TeeChart.Styles.TagCloud.AddTag メソッド

指定したテキストと値（アクセス頻度）でタグを追加します。
public Int32 AddTag(String Text,
     Double Value)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


CalcXPos

Steema.TeeChart.Styles.TagCloud.CalcXPos メソッド

public override Int32 CalcXPos(Int32 index)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


CalcYPos

Steema.TeeChart.Styles.TagCloud.CalcYPos メソッド

public override Int32 CalcYPos(Int32 index)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.TagCloud.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.TagCloud.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.TagCloud.Draw メソッド

public override Void Draw()

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.TagCloud.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


GetTagFontSize

Steema.TeeChart.Styles.TagCloud.GetTagFontSize メソッド

指定した値インデックスのタグのフォントサイズを返します。
public Int32 GetTagFontSize(Int32 ValueIndex)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


OnDrawTag

Steema.TeeChart.Styles.TagCloud.OnDrawTag メソッド

protected abstract Void OnDrawTag(TagCloudDrawTagEventArgs e)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.TagCloud.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.TagCloud.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Sort

Steema.TeeChart.Styles.TagCloud.Sort メソッド

オーバーロードの一覧

public Void Sort(Steema.TeeChart.Styles.TagCloudOrder)
public Void Sort(Steema.TeeChart.Styles.TagCloudOrder, Steema.TeeChart.Styles.ValueListOrder)

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Sort

Steema.TeeChart.Styles.TagCloud.Sort メソッド

public Void Sort(TagCloudOrder SortBy)

参照

Sort オーバーロードの一覧 | TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Sort

Steema.TeeChart.Styles.TagCloud.Sort メソッド

public Void Sort(TagCloudOrder SortBy,
     ValueListOrder Order)

参照

Sort オーバーロードの一覧 | TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloud プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
Filter | タグを表示するフィルタ文字列を取得/設定します。このプロパティに設定された文字列を含むタグのみが表示されます。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font | タグのフォント特性を取得/設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
Gradient | グラデーションを取得/設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TagSeparation | 水平方向のタグ間のスペースを百分率で取得/設定します。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

TagCloud クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.TagCloud.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Filter

Steema.TeeChart.Styles.TagCloud.Filter プロパティ

タグを表示するフィルタ文字列を取得/設定します。このプロパティに設定された文字列を含むタグのみが表示されます。
public String Filter {get; set;}

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Font

Steema.TeeChart.Styles.TagCloud.Font プロパティ

タグのフォント特性を取得/設定します。
public ChartFont Font {get; set;}

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Gradient

Steema.TeeChart.Styles.TagCloud.Gradient プロパティ

グラデーションを取得/設定します。
public Gradient Gradient {get; set;}

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


TagSeparation

Steema.TeeChart.Styles.TagCloud.TagSeparation プロパティ

水平方向のタグ間のスペースを百分率で取得/設定します。
public Int32 TagSeparation {get; set;}

参照

TagCloud クラス | TagCloud メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs クラス

この型のすべてのメンバの一覧については、TagCloudDrawTagEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class TagCloudDrawTagEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

TagCloudDrawTagEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs 全メンバ

TagCloudDrawTagEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

ValueIndex

参照

TagCloudDrawTagEventArgs クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs コンストラクタ

public TagCloudDrawTagEventArgs(Int32 index)

参照

TagCloudDrawTagEventArgs クラス | TagCloudDrawTagEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudDrawTagEventArgs プロパティ

パブリック プロパティ

ValueIndex

参照

TagCloudDrawTagEventArgs クラス | Steema.TeeChart.Styles 名前空間


ValueIndex

Steema.TeeChart.Styles.TagCloudDrawTagEventArgs.ValueIndex プロパティ

public Int32 ValueIndex {get; set;}

参照

TagCloudDrawTagEventArgs クラス | TagCloudDrawTagEventArgs メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudDrawTagEventHandler

Steema.TeeChart.Styles.TagCloudDrawTagEventHandler デリゲート

public delegate TagCloudDrawTagEventHandler (Object sender,
     TagCloudDrawTagEventArgs e)

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TagCloudOrder

Steema.TeeChart.Styles.TagCloudOrder 列挙体

[Serializable]
public sealed enum TagCloudOrder : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Text |
Value |
None |

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame

Steema.TeeChart.Styles.TFrame クラス

TFrameオブジェクトは矩形で定義した楕円または円の外側の縁に3つのバンドの枠を描画します。

この型のすべてのメンバの一覧については、TFrame メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class TFrame : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame 全メンバ

TFrame 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

CalcWidth | Widthプロパティと矩形Rectを使用してピクセル単位のTFrameオブジェクトの幅を計算します。
Draw | Rectで定義された境界内にTFrameオブジェクトを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Circled | 円形あるいは矩形の枠に描画を切り替えます。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
InnerBand | 内側バンドのChartBrush特性を取得/設定します。
MiddleBand | 中央バンドのChartBrush特性を取得/設定します。
OuterBand | 外側バンドのChartBrush特性を取得/設定します。
Visible | TFrameオブジェクトを表示/非表示にします。
Width | 境界矩形のパーセントとしてTFrameオブジェクトの幅を取得/設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

TFrame クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame コンストラクタ

オーバーロードの一覧

public TFrame(Steema.TeeChart.Chart, System.Drawing.Color[])
public TFrame(Steema.TeeChart.Chart, System.Drawing.Color[], System.Boolean)
public TFrame()

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame コンストラクタ

public TFrame(Chart c,
     Color[] gColorPalette)

参照

TFrame コンストラクタのオーバーロードの一覧 | TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame コンストラクタ

public TFrame(Chart c,
     Color[] gColorPalette,
     Boolean circle)

参照

TFrame コンストラクタのオーバーロードの一覧 | TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame コンストラクタ

public TFrame()

参照

TFrame コンストラクタのオーバーロードの一覧 | TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TFrame クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame メソッド

パブリック メソッド

CalcWidth | Widthプロパティと矩形Rectを使用してピクセル単位のTFrameオブジェクトの幅を計算します。
Draw | Rectで定義された境界内にTFrameオブジェクトを描画します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

TFrame クラス | Steema.TeeChart.Styles 名前空間


CalcWidth

Steema.TeeChart.Styles.TFrame.CalcWidth メソッド

Widthプロパティと矩形Rectを使用してピクセル単位のTFrameオブジェクトの幅を計算します。
public Int32 CalcWidth(Rectangle Rect)

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.TFrame.Draw メソッド

Rectで定義された境界内にTFrameオブジェクトを描画します。
public Void Draw(Rectangle Rect)

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TFrame プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Circled | 円形あるいは矩形の枠に描画を切り替えます。
GaugeColorPalette | 円形ゲージのカラーパレットを取得/設定します。
InnerBand | 内側バンドのChartBrush特性を取得/設定します。
MiddleBand | 中央バンドのChartBrush特性を取得/設定します。
OuterBand | 外側バンドのChartBrush特性を取得/設定します。
Visible | TFrameオブジェクトを表示/非表示にします。
Width | 境界矩形のパーセントとしてTFrameオブジェクトの幅を取得/設定します。

参照

TFrame クラス | Steema.TeeChart.Styles 名前空間


Circled

Steema.TeeChart.Styles.TFrame.Circled プロパティ

円形あるいは矩形の枠に描画を切り替えます。
public Boolean Circled {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


GaugeColorPalette

Steema.TeeChart.Styles.TFrame.GaugeColorPalette プロパティ

円形ゲージのカラーパレットを取得/設定します。
public Color[] GaugeColorPalette {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


InnerBand

Steema.TeeChart.Styles.TFrame.InnerBand プロパティ

内側バンドのChartBrush特性を取得/設定します。
public ChartBrush InnerBand {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


MiddleBand

Steema.TeeChart.Styles.TFrame.MiddleBand プロパティ

中央バンドのChartBrush特性を取得/設定します。
public ChartBrush MiddleBand {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


OuterBand

Steema.TeeChart.Styles.TFrame.OuterBand プロパティ

外側バンドのChartBrush特性を取得/設定します。
public ChartBrush OuterBand {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Visible

Steema.TeeChart.Styles.TFrame.Visible プロパティ

TFrameオブジェクトを表示/非表示にします。
public Boolean Visible {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Width

Steema.TeeChart.Styles.TFrame.Width プロパティ

境界矩形のパーセントとしてTFrameオブジェクトの幅を取得/設定します。
public Int32 Width {get; set;}

参照

TFrame クラス | TFrame メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower

Steema.TeeChart.Styles.Tower クラス

タワー系列。

この型のすべてのメンバの一覧については、Tower メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
[Serializable]
public class Tower : Custom3DGrid , IComponent
, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Tower メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower 全メンバ

Tower 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue |
MinXValue |
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue |
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Origin |
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentDepth |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PercentWidth |
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TowerStyle |
Transparency |
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UseOrigin |
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Tower クラス | Steema.TeeChart.Styles 名前空間


Tower コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower コンストラクタ

オーバーロードの一覧

public Tower()
public Tower(Steema.TeeChart.Chart)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Tower コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower コンストラクタ

public Tower()

参照

Tower コンストラクタのオーバーロードの一覧 | Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Tower コンストラクタ

Steema.TeeChart.Styles.Tower コンストラクタ

public Tower(Chart c)

参照

Tower コンストラクタのオーバーロードの一覧 | Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Tower クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Tower クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue |
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue |
MinXValue |
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue |
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Tower クラス | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Tower.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.Tower.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Tower.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.Tower.Draw メソッド

public override Void Draw()

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.Tower.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.MaxXValue メソッド

public virtual Double MaxXValue()

解説

系列のX値リストの最大値を返します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.MaxZValue メソッド

public virtual Double MaxZValue()

解説

系列のZ値の配列の最大値を返します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.MinXValue メソッド

public virtual Double MinXValue()

解説

系列のX値リストの最小値を返します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.MinZValue メソッド

public virtual Double MinZValue()

解説

系列のZ値の配列の最小値を返します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Tower.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Tower.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Tower プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D |
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Origin |
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentDepth |
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
PercentWidth |
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
TowerStyle |
Transparency |
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UseOrigin |
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Tower クラス | Steema.TeeChart.Styles 名前空間


Dark3D

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.Dark3D プロパティ

public Boolean Dark3D {get; set;}

解説

デフォルト値：true

trueの場合、暗い色を使用して立方体の右と上の側面を描画します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Tower.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Origin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.Origin プロパティ

public Double Origin {get; set;}

解説

ポイントの「原点」となる軸の垂直位置を定義します。
原点より低い値を持つポイントは「負」として考慮されます。

デフォルトでは、このプロパティは使用されません。その代わり、系列のY値の最小値が原点として使用されます。

このプロパティを有効にするためには、UseOriginプロパティをtrueに設定してください。

例

[C#]

tower1.FillSampleValues(10);
tower1.UseOrigin = true ;
tower1.Origin = ( tower1.YValues.MinValue + tower1.YValues.MaxValue ) / 2 ;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


PercentDepth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.PercentDepth プロパティ

public Int32 PercentDepth {get; set;}

解説

デフォルト値：100

タワーの「Z」深さのサイズをパーセントで設定します。

例

[C#]

tower1.FillSampleValues(5);
tower1.PercentDepth = 50;
tower1.PercentWidth = 50;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


PercentWidth

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.PercentWidth プロパティ

public Int32 PercentWidth {get; set;}

解説

デフォルト値：100

タワーの「X」幅のサイズをパーセントで設定します。

例

[C#]

tower1.FillSampleValues(5);
tower1.PercentDepth = 50;
tower1.PercentWidth = 50;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


TowerStyle

Steema.TeeChart.Styles.Tower.TowerStyle プロパティ

public TowerStyles TowerStyle {get; set;}

解説

デフォルト値：Cube
タワー系列の表示スタイルです。

使用可能なスタイル：

Cube
Rectangle
Cover
Cylinder
Arrow
Cone
Pyramid

例

[C#]

tower1.TowerStyle = Steema.TeeChart.Styles.TowerStyles.Arrow;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.Transparency プロパティ

public Int32 Transparency {get; set;}

解説

デフォルト値：0（不透明）

タワーポイントの透明度を0～100%で設定します。

例

[C#]

tower1.Transparency = 75;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


UseOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Tower.UseOrigin プロパティ

public Boolean UseOrigin {get; set;}

解説

デフォルト値：false

trueの場合、Originプロパティの値に下揃えします。
falseの場合、系列のY値の最小値になります（負の値は含みません）。

例

[C#]

tower1.FillSampleValues(10);
tower1.UseOrigin = true ;
tower1.Origin = ( tower1.YValues.MinValue + tower1.YValues.MaxValue ) / 2 ;

参照

Tower クラス | Tower メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TowerStyles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TowerStyles 列挙体

TowerStyleプロパティの使用可能な値をです。

[Serializable]
public enum TowerStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Cube | タワー系列のポイントを立方体として設定します。
Rectangle | タワー系列のポイントを矩形として設定します。
Cover | タワー系列のポイントをカバーとして設定します。
Cylinder | タワー系列のポイントを円筒として設定します。
Arrow | タワー系列のポイントを矢印として設定します。
Cone | タワー系列のポイントを円錐として設定します。
Pyramid | タワー系列のポイントを四角錐として設定します。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TreatNullsStyle

Steema.TeeChart.Styles.TreatNullsStyle 列挙体

nullポイントの取扱方法を定義します。
[Serializable]
public sealed enum TreatNullsStyle : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
DoNotPaint | nullポイントは描画されませんが、その他の計算では使用されます。
Skip | nullポイントは描画および計算においてスキップされます。
Ignore | nullポイントは完全に無視されます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface

Steema.TeeChart.Styles.TriSurface クラス

サーフェス(三角)系列。

この型のすべてのメンバの一覧については、TriSurface メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class TriSurface : Custom3DPalette , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface 全メンバ

TriSurface 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
CacheTriangles |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
NumTriangles |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | すべてのサーフェス（三角）系列の値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideTriangles | 他の三角形から隠される三角形を非表示にします。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Outline | サーフェス(三角)系列の枠の色やスタイルを設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
ImprovedTriangles
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

TriSurface クラス | Steema.TeeChart.Styles 名前空間


TriSurface コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface コンストラクタ

オーバーロードの一覧

public TriSurface(Steema.TeeChart.Chart)
public TriSurface()

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


TriSurface コンストラクタ

Steema.TeeChart.Styles.TriSurface コンストラクタ

public TriSurface(Chart c)

参照

TriSurface コンストラクタのオーバーロードの一覧 | TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


TriSurface コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface コンストラクタ

public TriSurface()

参照

TriSurface コンストラクタのオーバーロードの一覧 | TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

TriSurface クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
CacheTriangles |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
NumTriangles |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
ImprovedTriangles
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

TriSurface クラス | Steema.TeeChart.Styles 名前空間


CacheTriangles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.CacheTriangles フィールド

public Boolean CacheTriangles

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


ImprovedTriangles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.ImprovedTriangles フィールド

protected Boolean ImprovedTriangles

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


NumTriangles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.NumTriangles フィールド

public Int32 NumTriangles

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear | すべてのサーフェス（三角）系列の値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

TriSurface クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.Clear メソッド

すべてのサーフェス（三角）系列の値を削除します。

public virtual Void Clear()

解説

すべてのサーフェス（三角）系列の値を削除します。従属系列は通知されます。系列に新しいポイントが追加されない場合、何も描画されません。

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.TriSurface.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.TriSurface.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawValues

Steema.TeeChart.Styles.TriSurface.DoBeforeDrawValues メソッド

protected internal abstract Void DoBeforeDrawValues()

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.TriSurface.Draw メソッド

public override Void Draw()

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.TriSurface.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String s,
     Position position)

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.TriSurface プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideTriangles | 他の三角形から隠される三角形を非表示にします。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Outline | サーフェス(三角)系列の枠の色やスタイルを設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

TriSurface クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.TriSurface.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


HideTriangles

TeeChartプログラミングガイド

Steema.TeeChart.Styles.TriSurface.HideTriangles プロパティ

他の三角形から隠される三角形を非表示にします。

public Boolean HideTriangles {get; set;}

解説

デフォルト値：true

他の三角形から隠される三角形を表示する前に非表示にします。

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Outline

Steema.TeeChart.Styles.TriSurface.Outline プロパティ

サーフェス(三角)系列の枠の色やスタイルを設定します。
public ChartPen Outline {get;}

解説

サーフェス(三角)系列の枠の色やスタイルを変更するために使用してください。

参照

TriSurface クラス | TriSurface メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList

Steema.TeeChart.Styles.ValueList クラス

系列のデータポイント値を保持する配列。

この型のすべてのメンバの一覧については、ValueList メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public sealed class ValueList : TeeBase , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList 全メンバ

ValueList 概要

コンストラクタ

Constructor オーバーロード

パブリック フィールド

Capacity
Count
DefaultCapacity
Name
TempValue
Value

パブリック メソッド

AsDateTime |
Clear |
FillSequence | IValueListクラスのすべての値の番号を付け直します。この時、初期値はゼロから開始します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Locate |
RemoveAt |
RemoveRange |
Sort | 系列ポイントが異なる座標で表示されるように、系列値リスト内でその位置を取り換え、系列ポイントの順序を再編成します。

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
DataMember | 値リストのソースとして使用するフィールドを取得/設定します。
DateTime | 値を数字かあるいはDateTime値のどちらで表示するか設定します。
First | 最初のポイント値を返します。
Item |
Last | 最後のポイント値を返します。
Maximum | リスト内の最大値を返します。
MaxValue |
Minimum | リスト内の最小値を返します。
MinValue |
Order | ポイントを自動的にソートするか、あるいは元の位置に表示するかを設定します。
Range |
Total | すべてのIValueList値の合計を返します。
TotalABS | リスト内のすべての絶対値の合計を返します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ValueList クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList コンストラクタ

オーバーロードの一覧

public ValueList()
public ValueList(Steema.TeeChart.Styles.Series, System.String)
public ValueList(Steema.TeeChart.Styles.Series, System.String, System.Int32)

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList コンストラクタ

public ValueList()

参照

ValueList コンストラクタのオーバーロードの一覧 | ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList コンストラクタ

public ValueList(Series s,
     String name)

参照

ValueList コンストラクタのオーバーロードの一覧 | ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList コンストラクタ

public ValueList(Series s,
     String name,
     Int32 initialCapacity)

参照

ValueList コンストラクタのオーバーロードの一覧 | ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList フィールド

パブリック フィールド

Capacity
Count
DefaultCapacity
Name
TempValue
Value

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ValueList クラス | Steema.TeeChart.Styles 名前空間


Capacity

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Capacity フィールド

public Int32 Capacity

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Count

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Count フィールド

public Int32 Count

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


DefaultCapacity

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.DefaultCapacity フィールド

public Int32 DefaultCapacity

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Name

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Name フィールド

public String Name

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


TempValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.TempValue フィールド

public Double TempValue

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Value フィールド

public Double[] Value

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList メソッド

パブリック メソッド

AsDateTime |
Clear |
FillSequence | IValueListクラスのすべての値の番号を付け直します。この時、初期値はゼロから開始します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Locate |
RemoveAt |
RemoveRange |
Sort | 系列ポイントが異なる座標で表示されるように、系列値リスト内でその位置を取り換え、系列ポイントの順序を再編成します。

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ValueList クラス | Steema.TeeChart.Styles 名前空間


AsDateTime

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.AsDateTime メソッド

public DateTime AsDateTime(Int32 index)

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Clear メソッド

public Void Clear()

解説

系列値リストからValueIndexポイントを削除します。チャートは自動的に再描画されます。従属系列は再計算されます。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


FillSequence

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.FillSequence メソッド

IValueListクラスのすべての値の番号を付け直します。この時、初期値はゼロから開始します。

public Void FillSequence()

解説

IValueListクラスのすべての値の番号を付け直します。この時、初期値はゼロから開始します。

警告：FillSequenceを呼び出すと、IValueListにある値はすべて削除されます。

IValueList.Sortメソッドの例を参照してください。ポイントを実行時に削除する場合は、FillSequenceを使用してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


IndexOf

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.IndexOf メソッド

指定した値に該当するポイントインデックスを返します。

public Int32 IndexOf(Double value)

解説

指定した値に該当するポイントインデックスを返します。Y値に基づいたX座標値を計算するため、もしくはその逆にも使用できます。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Locate

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Locate メソッド

public Int32 Locate(Double value)

旧式

このメソッドの代わりにIndexOfメソッドを使用してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


RemoveAt

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.RemoveAt メソッド

public Void RemoveAt(Int32 index)

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


RemoveRange

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.RemoveRange メソッド

public Void RemoveRange(Int32 index,
     Int32 count)

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Sort

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Sort メソッド

系列ポイントが異なる座標で表示されるように、系列値リスト内でその位置を取り換え、系列ポイントの順序を再編成します。

public Void Sort()

解説

系列ポイントが異なる座標で表示されるように、系列値リスト内でその位置を取り換え、系列ポイントの順序を再編成します。デフォルトでは、系列はX座標値を使用して昇順でポイントをソートするように設定されています。これは、以下のコードで行うことができます。

TChart1.Series( 0 ).XValues.Order = loAscending

TChart1.Series( 0 ).YValues.Order = loNone

デフォルトでは、系列はポイントのValueIndexを使用してポイントを描きます。ただし、水平軸を反転させるなど一般的でない状況の場合を除きます。

重要メモ：系列ポイントの順序を再編成しても、ポイントのX座標値は変わりません。X座標値を持たない系列ポイントには、そのポイントの水平方向の位置を定義するためにユニークでインクリメンタルな数字が割り当てられます。自動ポイントインデックスは、ゼロから始まります。系列ポイントを自動的にX値でソートする場合、すべてのポイントのX座標値を変更する必要があります。

例

[C#]

このコードは、Y値を降順にして系列の順序を再編成します。

bar1.Add(new int [8]{23,25,30,34,26,18,33,20});

//メモ：XYポイントをソートする時は、XValues.FillSequenceを呼び出さないでください。

bar1.XValues.Order = Steema.TeeChart.Styles.ValueListOrder.None;
bar1.YValues.Order = Steema.TeeChart.Styles.ValueListOrder.Descending;
bar1.YValues.Sort();
bar1.XValues.FillSequence();

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueList プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
DataMember | 値リストのソースとして使用するフィールドを取得/設定します。
DateTime | 値を数字かあるいはDateTime値のどちらで表示するか設定します。
First | 最初のポイント値を返します。
Item |
Last | 最後のポイント値を返します。
Maximum | リスト内の最大値を返します。
MaxValue |
Minimum | リスト内の最小値を返します。
MinValue |
Order | ポイントを自動的にソートするか、あるいは元の位置に表示するかを設定します。
Range |
Total | すべてのIValueList値の合計を返します。
TotalABS | リスト内のすべての絶対値の合計を返します。

参照

ValueList クラス | Steema.TeeChart.Styles 名前空間


DataMember

Steema.TeeChart.Styles.ValueList.DataMember プロパティ

値リストのソースとして使用するフィールドを取得/設定します。
public String DataMember {get; set;}

解説

値リストのソースとして使用するフィールドを取得/設定します。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


DateTime

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.DateTime プロパティ

値を数字かあるいはDateTime値のどちらで表示するか設定します。

public Boolean DateTime {get; set;}

解説

TeeChartにより、値を数字かあるいはDateTime値のどちらかで表示することができます。各系列の値リストはDateTimeプロパティを持っています。DateTimeプロパティは、数字がどの型であるかをTeeChartに知らせます。水平（X軸）や垂直（Y軸）のデフォルト値は、数字形式（DateTimeはFalse）になっています。DateTimeは、設計時や実行時の両方で変更できます。変更されると、チャートが再描画されます。このプロパティは、チャート軸のラベルとして描く場合など、値をテキストに変換しなければならない時に必ず使用されます。軸ラベルは、DateTimeプロパティの設定に従って、DateTimeあるいは数字形式で描かれます。

また、チャート系列のValueFormatやチャート軸のDateTimeFormatの書式文字列を設定して、値の表示方法を制御することもできます。

例

[C#]

Steema.TeeChart.Styles.Bubble Series1 = new Steema.TeeChart.Styles.Bubble();
tChart1.Series.Add(Series1);
Series1.RadiusValues.DateTime =true;

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


First

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.First プロパティ

最初のポイント値を返します。

public Double First {get;}

解説

最初のポイント値を返します。

例

これは、0のインデックス値と同じ値です。

[C#]

tChart1[0].YValues.Value[0] =103.96;
MessageBox.Show(tChart1[0].YValues.First.ToString());

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Item

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Item プロパティ

public Double Item(Int32 index) {get; set;}

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Last

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Last プロパティ

最後のポイント値を返します。

public Double Last {get;}

解説

最後のポイント値を返します。これはCount - 1 のインデックス値と同じ値です。

例

[C#]

これはCount - 1 のインデックス値と同じ値です。

tChart1.Series[0].XValues.FillSequence();
tChart1.Series[0].YValues.Value[tChart1.Series[0].Count -1] = 12.34;
MessageBox.Show(tChart1.Series[0].YValues.Last.ToString());

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Maximum

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Maximum プロパティ

リスト内の最大値を返します。

public Double Maximum {get;}

解説

リスト内の最大値を返します。

系列に新しいポイントが追加される場合、IValueListオブジェクトはMaximumプロパティ、Minimumプロパティ、TotalABSプロパティを計算します。

これは、XValuesやYValuesなどのようなすべての系列の値リストです。

例

[C#]

以下のコードは、最大値のマーカのみを表示します。

     private void Form1_Load(object sender, System.EventArgs e)

         fastLine1.FillSampleValues(10);
         fastLine1.Marks.Visible = true;

     private void fastLine1_GetSeriesMark(Steema.TeeChart.Styles.Series series, Steema.TeeChart.Styles.GetSeriesMarkEventArgs e)

         if (series.YValues.Value[e.ValueIndex] != series.YValues.Maximum )

            e.MarkText = "";

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


MaxValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.MaxValue プロパティ

public Double MaxValue {get;}

旧式

このプロパティの代わりにMaximumプロパティを使用してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Minimum

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Minimum プロパティ

リスト内の最小値を返します。

public Double Minimum {get;}

解説

実行時および読込み専用。リスト内の最小値を返します。詳細はIValueList.Maximumプロパティを参照してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


MinValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.MinValue プロパティ

public Double MinValue {get;}

旧式

このプロパティの代わりにMinimumプロパティを使用してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Order

Steema.TeeChart.Styles.ValueList.Order プロパティ

ポイントを自動的にソートするか、あるいは元の位置に表示するかを設定します。
public ValueListOrder Order {get; set;}

解説

実行時専用。ポイントを自動的にソートするか、あるいは常に元の位置に表示するかを定義します。これは、デフォルトで系列のXValuesが左から右に線を描く際に使用されます。XValues.OrderプロパティをloNoneに設定すると、ポイント作成時のポイントの順序を優先します。これはポリゴンを描く際に利用できます。

例

[C#]

このコードは、三角形を描く新しいリボン系列クラスを作成します。既にリボン系列をSeries(0)として定義してあるものとします。

tChart1[0].Clear();
tChart1[0].XValues.Order = Steema.TeeChart.ValueListOrder.None;
tChart1[0].Add(-100,0,Color.Red);
tChart1[0].Add(0,100,Color.Blue);
tChart1[0].Add(100,0,Color.Green);
tChart1[0].Add(-100,0,Color.Yellow);

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Range

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Range プロパティ

public Double Range {get;}

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Total

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.Total プロパティ

すべてのIValueList値の合計を返します。

public Double Total {get;}

解説

すべてのIValueList値の合計を保持しています。適切なメソッドを使用してポイント値を追加、削除、変更すると、Totalは自動的にインクリメントやデクリメントされます。

ポイント値の合計を事前に計算しておく必要がある状況で、ポイント値に対する計算速度を上げるために、一部の関数で使用されます。

例

[C#]

MessageBox.Show("Total Sales are:"+tChart1[0].YValues.Total.ToString());

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


TotalABS

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueList.TotalABS プロパティ

リスト内のすべての絶対値の合計を返します。

public Double TotalABS {get;}

解説

実行時および読込み専用。

リスト内のすべての値の合計を返します。値は絶対値に変換されます。

たとえば、円系列は各パイスライスが占める割合を計算するためにこのプロパティを使用します。

詳細については、IValueList.Maximumプロパティを参照してください。

参照

ValueList クラス | ValueList メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValueListOrder

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValueListOrder 列挙体

Orderプロパティの使用可能な値です。

[Serializable]
public enum ValueListOrder : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 値はValueListに追加された順番でソートされます。
Ascending | 値は昇順でソートされます。
Descending | 値は降順でソートされます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValuesLists

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValuesLists クラス

このクラスは、ValueListオブジェクトのコレクションです。

この型のすべてのメンバの一覧については、ValuesLists メンバを参照してください。

System.Object
System.Collections.ArrayList
[Serializable]
public class ValuesLists : ArrayList , IList
, ICollection, IEnumerable, ICloneable

必要条件

名前空間： Steema.TeeChart.Styles

アセンブリ：TeeChart.dll

参照

ValuesLists メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValuesLists 全メンバ

ValuesLists 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

ValuesLists クラス | Steema.TeeChart.Styles 名前空間


ValuesLists コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.ValuesLists コンストラクタ

public ValuesLists()

参照

ValuesLists クラス | ValuesLists メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.ValuesLists プロパティ

パブリック プロパティ

Item

参照

ValuesLists クラス | Steema.TeeChart.Styles 名前空間


Item

Steema.TeeChart.Styles.ValuesLists.Item プロパティ

public ValueList Item(Int32 i) {get;}

参照

ValuesLists クラス | ValuesLists メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Vector3D

Steema.TeeChart.Styles.Vector3D クラス

3D ベクタ系列。

この型のすべてのメンバの一覧については、Vector3D メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
public class Vector3D : Custom3DPalette , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Vector3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Vector3D 全メンバ

Vector3D 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add | 系列に新しい3Dのベクタ線を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値配列の最大値を返します。
MaxYValue | 系列のY値配列の最大値を返します。
MaxZValue | 系列のZ値配列の最大値を返します。
MinXValue | 系列のX値配列の最小値を返します。
MinYValue | 系列のY値配列の最小値を返します。
MinZValue | 系列のZ値配列の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
ArrowHeight | 矢印の高さをピクセル単位で取得/設定します。
ArrowWidth | 矢印の幅をピクセル単位で取得/設定します。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndArrow | ベクタ線の終了座標に矢印を描画するために使用されるペンを設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndXValues | ベクタ線の終点のX座標を表す値のリストです。
EndYValues | ベクタ線の終点のY座標を表す値のリストです。
EndZ (Seriesの継承元) | 内部使用。
EndZValues | ベクタ線の終点のZ座標を表す値のリストです。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartArrow | ベクタ線の開始座標に矢印を描画するために使用されるペンを設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Vector3D クラス | Steema.TeeChart.Styles 名前空間


Vector3D コンストラクタ

Steema.TeeChart.Styles.Vector3D コンストラクタ

オーバーロードの一覧

public Vector3D(Steema.TeeChart.Chart)
public Vector3D()

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Vector3D コンストラクタ

Steema.TeeChart.Styles.Vector3D コンストラクタ

public Vector3D(Chart c)

参照

Vector3D コンストラクタのオーバーロードの一覧 | Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


Vector3D コンストラクタ

Steema.TeeChart.Styles.Vector3D コンストラクタ

public Vector3D()

参照

Vector3D コンストラクタのオーバーロードの一覧 | Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.Vector3D イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントがダブルクリックされた際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに｢触れる｣と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから｢離れる｣と発生します。

参照

Vector3D クラス | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.Vector3D フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Vector3D クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Vector3D メソッド

パブリック メソッド

Add | 系列に新しい3Dのベクタ線を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Seriesの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf |
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue | 系列のX値配列の最大値を返します。
MaxYValue | 系列のY値配列の最大値を返します。
MaxZValue | 系列のZ値配列の最大値を返します。
MinXValue | 系列のX値配列の最小値を返します。
MinYValue | 系列のY値配列の最小値を返します。
MinZValue | 系列のZ値配列の最小値を返します。
PrepareForGallery (Custom3DPaletteの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Custom3DPaletteの継承元) |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Custom3DPaletteの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Custom3DPaletteの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Vector3D クラス | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Vector3D.Add メソッド

オーバーロードの一覧

軸値として(x0, y0, z0)から(x1, y1, z1)に新しい3Dのベクタ線を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double)

軸値として(x0, y0, z0)から(x1, y1, z1)に指定したテキストと色と一緒に新しい3Dのベクタ線を追加します。

public Int32 Add(System.Double, System.Double, System.Double, System.Double, System.Double, System.Double, System.String, System.Drawing.Color)

解説

系列に新しい3Dのベクタ線を追加します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


Add

Steema.TeeChart.Styles.Vector3D.Add メソッド

軸値として(x0, y0, z0)から(x1, y1, z1)に新しい3Dのベクタ線を追加します。
public Int32 Add(Double x0,
     Double y0,
     Double z0,
     Double x1,
     Double y1,
     Double z1)

参照

Add オーバーロードの一覧 | Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Add

Steema.TeeChart.Styles.Vector3D.Add メソッド

軸値として(x0, y0, z0)から(x1, y1, z1)に指定したテキストと色と一緒に新しい3Dのベクタ線を追加します。
public Int32 Add(Double x0,
     Double y0,
     Double z0,
     Double x1,
     Double y1,
     Double z1,
     String text,
     Color color)

参照

Add オーバーロードの一覧 | Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


AddSampleValues

Steema.TeeChart.Styles.Vector3D.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


DrawValue

Steema.TeeChart.Styles.Vector3D.DrawValue メソッド

public override Void DrawValue(Int32 valueIndex)

解説

TeeChartにより内部的に呼び出されます。このメソッドを直接呼び出す必要はありません。このメソッドは、系列の「ValueIndex」のポイントを描画します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Vector3D.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


IsValidSourceOf

Steema.TeeChart.Styles.Vector3D.IsValidSourceOf メソッド

public override Boolean IsValidSourceOf(Series value)

解説

ValueパラメーターがSelfと同じ場合、falseを返します。
デザイン時および実行時にDataSourceプロパティを有効にするために使用されます。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MaxXValue

Steema.TeeChart.Styles.Vector3D.MaxXValue メソッド

系列のX値配列の最大値を返します。
public override Double MaxXValue()

解説

系列のX値配列の最大値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MaxYValue

Steema.TeeChart.Styles.Vector3D.MaxYValue メソッド

系列のY値配列の最大値を返します。
public override Double MaxYValue()

解説

系列のY値配列の最大値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MaxZValue

Steema.TeeChart.Styles.Vector3D.MaxZValue メソッド

系列のZ値配列の最大値を返します。
public override Double MaxZValue()

解説

系列のZ値配列の最大値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MinXValue

Steema.TeeChart.Styles.Vector3D.MinXValue メソッド

系列のX値配列の最小値を返します。
public override Double MinXValue()

解説

系列のX値配列の最小値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MinYValue

Steema.TeeChart.Styles.Vector3D.MinYValue メソッド

系列のY値配列の最小値を返します。
public override Double MinYValue()

解説

系列のY値配列の最小値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


MinZValue

Steema.TeeChart.Styles.Vector3D.MinZValue メソッド

系列のZ値配列の最小値を返します。
public override Double MinZValue()

解説

系列のZ値配列の最小値を返します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.Vector3D.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Styles.Vector3D プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
ArrowHeight | 矢印の高さをピクセル単位で取得/設定します。
ArrowWidth | 矢印の幅をピクセル単位で取得/設定します。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description | 説明のテキストを取得します。
EndArrow | ベクタ線の終了座標に矢印を描画するために使用されるペンを設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndXValues | ベクタ線の終点のX座標を表す値のリストです。
EndYValues | ベクタ線の終点のY座標を表す値のリストです。
EndZ (Seriesの継承元) | 内部使用。
EndZValues | ベクタ線の終点のZ座標を表す値のリストです。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Custom3Dの継承元) | XYZのポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartArrow | ベクタ線の開始座標に矢印を描画するために使用されるペンを設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Vector3D クラス | Steema.TeeChart.Styles 名前空間


ArrowHeight

Steema.TeeChart.Styles.Vector3D.ArrowHeight プロパティ

矢印の高さをピクセル単位で取得/設定します。
public Int32 ArrowHeight {get; set;}

解説

矢印の高さをピクセル単位で取得/設定します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


ArrowWidth

Steema.TeeChart.Styles.Vector3D.ArrowWidth プロパティ

矢印の幅をピクセル単位で取得/設定します。
public Int32 ArrowWidth {get; set;}

解説

矢印の幅をピクセル単位で取得/設定します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Vector3D.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


EndArrow

Steema.TeeChart.Styles.Vector3D.EndArrow プロパティ

ベクタ線の終了座標に矢印を描画するために使用されるペンを設定します。
public ChartPen EndArrow {get;}

解説

ベクタ線の終了座標に矢印を描画するために使用されるペンを設定します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


EndXValues

Steema.TeeChart.Styles.Vector3D.EndXValues プロパティ

ベクタ線の終点のX座標を表す値のリストです。
public ValueList EndXValues {get;}

解説

ベクタ線の終点のX座標を表す値のリストです。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


EndYValues

Steema.TeeChart.Styles.Vector3D.EndYValues プロパティ

ベクタ線の終点のY座標を表す値のリストです。
public ValueList EndYValues {get;}

解説

ベクタ線の終点のY座標を表す値のリストです。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


EndZValues

Steema.TeeChart.Styles.Vector3D.EndZValues プロパティ

ベクタ線の終点のZ座標を表す値のリストです。
public ValueList EndZValues {get;}

解説

ベクタ線の終点のZ座標を表す値のリストです。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


StartArrow

Steema.TeeChart.Styles.Vector3D.StartArrow プロパティ

ベクタ線の開始座標に矢印を描画するために使用されるペンを設定します。
public ChartPen StartArrow {get;}

解説

ベクタ線の開始座標に矢印を描画するために使用されるペンを設定します。

参照

Vector3D クラス | Vector3D メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalAxis

TeeChartプログラミングガイド

Steema.TeeChart.Styles.VerticalAxis 列挙体

VertAxisプロパティの使用可能な値です。

[Serializable]
public enum VerticalAxis : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Left | 左軸に系列を関連付けます。
Right | 右軸に系列を関連付けます。
Both | 左軸と右軸に系列を関連付けます。
Custom | カスタム軸に系列を関連付けます。

参照

Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge

Steema.TeeChart.Styles.VerticalLinearGauge クラス

縦線形ゲージ系列。

この型のすべてのメンバの一覧については、VerticalLinearGauge メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.CustomGauge
Steema.TeeChart.Styles.LinearGauge
public class VerticalLinearGauge : LinearGauge , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

VerticalLinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge 全メンバ

VerticalLinearGauge 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (LinearGaugeの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (LinearGaugeの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MaxValueIndicator (LinearGaugeの継承元) | 線形ゲージの最大インジケータの特性について取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseValueColorPalette (LinearGaugeの継承元) | ValueColorPaletteプロパティを使用し、線形ゲージの針のカスタムなグラデーションスキーマを定義するにはTrueに設定してください。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueAreaBrush (LinearGaugeの継承元) | 線形ゲージのスライダーのブラシ特性を取得/設定します。
ValueColorPalette (LinearGaugeの継承元) | カスタムなグラデーションカラーのスキーマを定義する色の配列。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomGaugeの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (CustomGaugeの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis (LinearGaugeの継承元) |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines (LinearGaugeの継承元) |
DrawFace (LinearGaugeの継承元) |
DrawFrame (CustomGaugeの継承元) |
DrawHand (LinearGaugeの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis (LinearGaugeの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (LinearGaugeの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue (LinearGaugeの継承元) |
SetValueList (Seriesの継承元) |
SetValues (LinearGaugeの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

VerticalLinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge コンストラクタ

オーバーロードの一覧

public VerticalLinearGauge()
public VerticalLinearGauge(Steema.TeeChart.Chart)

参照

VerticalLinearGauge クラス | VerticalLinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge コンストラクタ

public VerticalLinearGauge()

参照

VerticalLinearGauge コンストラクタのオーバーロードの一覧 | VerticalLinearGauge クラス | VerticalLinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge コンストラクタ

public VerticalLinearGauge(Chart c)

参照

VerticalLinearGauge コンストラクタのオーバーロードの一覧 | VerticalLinearGauge クラス | VerticalLinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。
ValueChanged (CustomGaugeの継承元) | ゲージ系列のValueプロパティが変更されると発生します。

参照

VerticalLinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
fgreenLineEndValue (CustomGaugeの継承元)
fgreenLineStartValue (CustomGaugeの継承元)
firstVisible (Seriesの継承元)
fmaximum (CustomGaugeの継承元)
fminimum (CustomGaugeの継承元)
fredLineEndValue (CustomGaugeの継承元)
fredLineStartValue (CustomGaugeの継承元)
INewRectangle (CustomGaugeの継承元)
InternalUse (TeeBaseの継承元)
IOrigRectangle (CustomGaugeの継承元)
IRange (CustomGaugeの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

VerticalLinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Seriesの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (LinearGaugeの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (LinearGaugeの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (CustomGaugeの継承元) |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (CustomGaugeの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (CustomGaugeの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawAxis (LinearGaugeの継承元) |
DrawAxisMinorTick (CustomGaugeの継承元) |
DrawAxisTick (CustomGaugeの継承元) |
DrawColorLines (LinearGaugeの継承元) |
DrawFace (LinearGaugeの継承元) |
DrawFrame (CustomGaugeの継承元) |
DrawHand (LinearGaugeの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark (Seriesの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAxis (LinearGaugeの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
IsDefaultAxis (CustomGaugeの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Seriesの継承元) |
OnValueChanged (CustomGaugeの継承元) |
PaintLegend (Seriesの継承元) |
PrepareGraphics (CustomGaugeの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetAxisOnce (CustomGaugeの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (LinearGaugeの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValue (LinearGaugeの継承元) |
SetValueList (Seriesの継承元) |
SetValues (LinearGaugeの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

VerticalLinearGauge クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VerticalLinearGauge プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Axis (CustomGaugeの継承元) | 線形ゲージの軸特性を取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FaceBrush (CustomGaugeの継承元) | カスタムゲージの計器盤のChartBrush特性を取得/設定します。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Frame (CustomGaugeの継承元) | フレームは、線形ゲージを囲む3つ（内側・中央・外側）のバンドからなるオブジェクトです。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GaugeColorPalette (CustomGaugeの継承元) | 円形ゲージのカラーパレットを取得/設定します。
GreenLine (CustomGaugeの継承元) | 「緑線」オブジェクトは、低下あるいは最小値を示すグラデーション付きの曲線を描画します。
GreenLineEndValue (CustomGaugeの継承元) | 「緑線」マーカの終了値を取得/設定します。
GreenLineStartValue (CustomGaugeの継承元) | 「緑線」マーカの開始値を取得/設定します。
Hand (CustomGaugeの継承元) | 針オブジェクトの特性を取得/設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Horizontal (CustomGaugeの継承元) | 線形ゲージを水平あるいは垂直のどちらで描画するかを取得/設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
Maximum (CustomGaugeの継承元) | ゲージの最大値を取得/設定します。
MaxValueIndicator (LinearGaugeの継承元) | 線形ゲージの最大インジケータの特性について取得/設定します。
MiddleZ (Seriesの継承元) | 内部使用。
Minimum (CustomGaugeの継承元) | ゲージの最小値を取得/設定します。
MinorTickDistance (CustomGaugeの継承元) | 軸から離す副目盛の位置（距離）をピクセル単位で設定します。
MinorTicks (CustomGaugeの継承元) | 軸の副目盛の特性を取得/設定します。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedLine (CustomGaugeの継承元) | 「赤線」オブジェクトは、上昇あるいは最大値を示すグラデーション付きの曲線を描画します。
RedLineEndValue (CustomGaugeの継承元) | 「赤線」マーカの終了値を取得/設定します。
RedLineStartValue (CustomGaugeの継承元) | 「赤線」マーカの開始値を取得/設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Ticks (CustomGaugeの継承元) | 軸の目盛の特性を取得/設定します。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseValueColorPalette (LinearGaugeの継承元) | ValueColorPaletteプロパティを使用し、線形ゲージの針のカスタムなグラデーションスキーマを定義するにはTrueに設定してください。
Value (CustomGaugeの継承元) | ゲージの矢印線の位置を取得/設定します。
ValueAreaBrush (LinearGaugeの継承元) | 線形ゲージのスライダーのブラシ特性を取得/設定します。
ValueColorPalette (LinearGaugeの継承元) | カスタムなグラデーションカラーのスキーマを定義する色の配列。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

VerticalLinearGauge クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.VerticalLinearGauge.Description プロパティ

public override String Description {get;}

参照

VerticalLinearGauge クラス | VerticalLinearGauge メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume

Steema.TeeChart.Styles.Volume クラス

ボリューム系列。

この型のすべてのメンバの一覧については、Volume メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.BaseLine
Steema.TeeChart.Styles.CustomPoint
Steema.TeeChart.Styles.Custom
[Serializable]
public class Volume : Custom , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Volume メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume 全メンバ

Volume 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InflateMargins | ボリューム線にフィットするように軸を広げます。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin | 指定したボリューム系列の原点として使用されるY値を定義します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin | ボリュームポイントをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
point (CustomPointの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Volume クラス | Steema.TeeChart.Styles 名前空間


Volume コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume コンストラクタ

オーバーロードの一覧

public Volume(Steema.TeeChart.Chart)
public Volume()

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Volume コンストラクタ

Steema.TeeChart.Styles.Volume コンストラクタ

public Volume(Chart c)

参照

Volume コンストラクタのオーバーロードの一覧 | Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Volume コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume コンストラクタ

public Volume()

参照

Volume コンストラクタのオーバーロードの一覧 | Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
ClickPointer (CustomPointの継承元) | 系列ポインタがクリックされた際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPointの継承元) | 系列ポインタを描画する直前に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Volume クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bAreaBrush (Customの継承元)
bClickableLine (Customの継承元)
bColorEach (Seriesの継承元)
bDark3D (Customの継承元)
calcVisiblePoints (Seriesの継承元)
drawArea (Customの継承元)
DrawBetweenPoints (Seriesの継承元)
drawLine (Customの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iStacked (CustomPointの継承元)
lastVisible (Seriesの継承元)
pAreaLines (Customの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

Volume クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Customの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPointの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (Customの継承元) | ポイントがXY位置にあるかどうか計算します。
ClickedPointer (CustomPointの継承元) | 内部使用。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Customの継承元) |
DrawPointer (CustomPointの継承元) | キャンバスに系列ポインタを描画します。
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (CustomPointの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (CustomPointの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (CustomPointの継承元) | 系列のX値リストの最小値を返します。
MinYValue (CustomPointの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins |
CalcMinMaxValue (BaseLineの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Customの継承元) |
CalcZOrder (CustomPointの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Customの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape |
DrawMark (CustomPointの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetAreaBrushColor (Customの継承元) |
GetBounds |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginPos (CustomPointの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnClickPointer (CustomPointの継承元) |
OnDisposing (Seriesの継承元) |
OnGetPointerStyle (CustomPointの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Seriesの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SameClassOrigin (CustomPointの継承元) |
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Customの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

Volume クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume.AddSampleValues メソッド

protected virtual Void AddSampleValues(Int32 numValues)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


CalcHorizMargins

Steema.TeeChart.Styles.Volume.CalcHorizMargins メソッド

protected internal abstract Void CalcHorizMargins(Int32& LeftMargin,
     Int32& RightMargin)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Volume.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


DrawLegendShape

Steema.TeeChart.Styles.Volume.DrawLegendShape メソッド

protected abstract Void DrawLegendShape(Graphics3D g,
     Int32 valueIndex,
     Rectangle r)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume.DrawValue メソッド

内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。

public virtual Void DrawValue(Int32 valueIndex)

解説

TeeChartで内部的に呼び出されます。直接呼び出す必要はありません。系列の｢ValueIndex｣ポイントを描画します。

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


GetBounds

Steema.TeeChart.Styles.Volume.GetBounds メソッド

protected internal abstract Int32[] GetBounds(Int32 index,
     PolygonStyle& p)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.Volume.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume.NumSampleValues メソッド

protected internal virtual Int32 NumSampleValues()

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.Volume.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean isEnabled)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Volume.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Volume プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush (Customの継承元) | ブラシの特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClickableLine (Customの継承元) | ポイント間の線上でマウスクリックを有効にするかどうか定義します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachLine (Customの継承元) | 系列の接続している各線の色を有効/無効にします。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
Dark3D (Customの継承元) | 3Dのリボン系列の影の色を有効/無効にします。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InflateMargins | ボリューム線にフィットするように軸を広げます。
InvertedStairs (Customの継承元) | Stairsプロパティがtrueの場合、このプロパティをtrueに設定するとステップの方向を変更できます。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineHeight (Customの継承元) | 線の高さをピクセル単位で定義します。
LinePen (BaseLineの継承元) | すべてのポイントを接続する線を描くペンの種類を定義します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Opacity (Customの継承元) | 不透度を0から100%で設定します。
Origin | 指定したボリューム系列の原点として使用されるY値を定義します。
OutLine (Customの継承元) | 系列の線のアウトラインのペンを定義します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPointの継承元) | 系列ポインタの特性を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
Stacked (CustomPointの継承元) | 複数系列をどのように描画するか定義します。
Stairs (Customの継承元) | 各ポイントを接続する線を階段状にします。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Customの継承元) | 0～100%までの透明度を設定します。
TreatNulls (BaseLineの継承元) |
UseOrigin | ボリュームポイントをOriginプロパティ値に下揃えするかどうかを定義します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

Volume クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Volume.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


InflateMargins

Steema.TeeChart.Styles.Volume.InflateMargins プロパティ

ボリューム線にフィットするように軸を広げます。
public Boolean InflateMargins {get; set;}

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Origin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume.Origin プロパティ

指定したボリューム系列の原点として使用されるY値を定義します。

public Double Origin {get; set;}

解説

指定したボリューム系列の原点として使用されるY値を定義します。

例

[C#]

Steema.TeeChart.Styles.Volume Series1 = new Steema.TeeChart.Styles.Volume();
tChart1.Series.Add(Series1);
Series1.FillSampleValues(10);
Series1.UseOrigin = true;
Series1.Origin = 200;

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


UseOrigin

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Volume.UseOrigin プロパティ

ボリュームポイントをOriginプロパティ値に下揃えするかどうか定義します。

public Boolean UseOrigin {get; set;}

解説

デフォルト値：false

ボリュームポイントの原点となる位置を定義するY値（Originプロパティを使用）の設定を有効/無効にします。

参照

Volume クラス | Volume メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe

Steema.TeeChart.Styles.VolumePipe クラス

ボリュームパイプ系列。

この型のすべてのメンバの一覧については、VolumePipe メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
public class VolumePipe : Series , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe 全メンバ

VolumePipe 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
BoundingPoints |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
IPolyList |
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ボリュームパイプ系列のブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ConePercent | 円錐のパーセントを設定します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineAsPointColor | 各ポイントの色にLinePen色を設定します。
LinesPen | ボリュームパイプ系列の線のペン特性を設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Separation | セグメント間の分離を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

VolumePipe クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe コンストラクタ

オーバーロードの一覧

public VolumePipe()
public VolumePipe(Steema.TeeChart.Chart)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe コンストラクタ

public VolumePipe()

参照

VolumePipe コンストラクタのオーバーロードの一覧 | VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe コンストラクタ

public VolumePipe(Chart c)

参照

VolumePipe コンストラクタのオーバーロードの一覧 | VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

VolumePipe クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
BoundingPoints |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
IPolyList |
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
lastVisible (Seriesの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

VolumePipe クラス | Steema.TeeChart.Styles 名前空間


BoundingPoints

Steema.TeeChart.Styles.VolumePipe.BoundingPoints フィールド

public Point[] BoundingPoints

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


IPolyList

Steema.TeeChart.Styles.VolumePipe.IPolyList フィールド

public ArrayList IPolyList

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Seriesの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
PrepareForGallery (Seriesの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AssociatedToAxis (Seriesの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Seriesの継承元) |
DrawMark |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Seriesの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues |
OnDisposing (Seriesの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

VolumePipe クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.VolumePipe.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.VolumePipe.Clicked メソッド

オーバーロードの一覧

public override Int32 Clicked(System.Int32, System.Int32)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Clicked

Steema.TeeChart.Styles.VolumePipe.Clicked メソッド

public override Int32 Clicked(Int32 x,
     Int32 y)

参照

Clicked オーバーロードの一覧 | VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Dispose

Steema.TeeChart.Styles.VolumePipe.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


DoBeforeDrawChart

Steema.TeeChart.Styles.VolumePipe.DoBeforeDrawChart メソッド

protected internal abstract Void DoBeforeDrawChart()

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.VolumePipe.Draw メソッド

public override Void Draw()

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


DrawMark

Steema.TeeChart.Styles.VolumePipe.DrawMark メソッド

protected internal abstract Void DrawMark(Int32 valueIndex,
     String st,
     Position aPosition)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


DrawValue

Steema.TeeChart.Styles.VolumePipe.DrawValue メソッド

public override Void DrawValue(Int32 index)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


ModifySeriesColors

Steema.TeeChart.Styles.VolumePipe.ModifySeriesColors メソッド

protected abstract Void ModifySeriesColors(Color color)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


NumSampleValues

Steema.TeeChart.Styles.VolumePipe.NumSampleValues メソッド

protected internal abstract Int32 NumSampleValues()

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


PrepareLegendCanvas

Steema.TeeChart.Styles.VolumePipe.PrepareLegendCanvas メソッド

protected abstract Void PrepareLegendCanvas(Graphics3D g,
     Int32 valueIndex,
     Color& backColor,
     ChartBrush& aBrush)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.VolumePipe.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.VolumePipe プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
Brush | ボリュームパイプ系列のブラシ特性を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
ConePercent | 円錐のパーセントを設定します。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
LineAsPointColor | 各ポイントの色にLinePen色を設定します。
LinesPen | ボリュームパイプ系列の線のペン特性を設定します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Separation | セグメント間の分離を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

VolumePipe クラス | Steema.TeeChart.Styles 名前空間


Brush

Steema.TeeChart.Styles.VolumePipe.Brush プロパティ

ボリュームパイプ系列のブラシ特性を設定します。
public ChartBrush Brush {get;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


ConePercent

Steema.TeeChart.Styles.VolumePipe.ConePercent プロパティ

円錐のパーセントを設定します。
public Int32 ConePercent {get; set;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.VolumePipe.Description プロパティ

public override String Description {get;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


LineAsPointColor

Steema.TeeChart.Styles.VolumePipe.LineAsPointColor プロパティ

各ポイントの色にLinePen色を設定します。
public Boolean LineAsPointColor {get; set;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


LinesPen

Steema.TeeChart.Styles.VolumePipe.LinesPen プロパティ

ボリュームパイプ系列の線のペン特性を設定します。
public ChartPen LinesPen {get; set;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Separation

Steema.TeeChart.Styles.VolumePipe.Separation プロパティ

セグメント間の分離を設定します。
public Int32 Separation {get; set;}

参照

VolumePipe クラス | VolumePipe メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall

Steema.TeeChart.Styles.Waterfall クラス

ウォーターフォール系列は、サーフェスと同様に各Z位置に1つの垂直「スライス」を描画します。

この型のすべてのメンバの一覧については、Waterfall メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Custom3DGrid
Steema.TeeChart.Styles.Surface
public class Waterfall : Surface , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall 全メンバ

Waterfall 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation (Surfaceの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Surfaceの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Surfaceの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints (Surfaceの継承元) |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Surfaceの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DotFrame (Surfaceの継承元) | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells (Surfaceの継承元) |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush (Surfaceの継承元) | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines (Surfaceの継承元) |
SmoothPalette (Surfaceの継承元) | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall (Surfaceの継承元) | ウォーターフォールとしての表示を有効/無効にします。
WaterLines (Surfaceの継承元) | 値ラインを描くペンを設定します。
WireFrame (Surfaceの継承元) | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall (Surfaceの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX (Surfaceの継承元)
iCalcY (Surfaceの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points (Surfaceの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell (Surfaceの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion (Surfaceの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex (Surfaceの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Surfaceの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast (Surfaceの継承元) |
ShouldDrawSides (Surfaceの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Waterfall クラス | Steema.TeeChart.Styles 名前空間


Waterfall コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Waterfall コンストラクタ

オーバーロードの一覧

public Waterfall(Steema.TeeChart.Chart)
public Waterfall()

参照

Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Waterfall コンストラクタ

Steema.TeeChart.Styles.Waterfall コンストラクタ

public Waterfall(Chart c)

参照

Waterfall コンストラクタのオーバーロードの一覧 | Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Waterfall コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.Waterfall コンストラクタ

public Waterfall()

参照

Waterfall コンストラクタのオーバーロードの一覧 | Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描いた直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面ある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | チャート上をマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
GetYValue (Custom3DGridの継承元) | サーフェス系列がグリッド値を再作成させる時に発生します。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

Waterfall クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
ReuseGridIndex (Custom3DGridの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
bWaterFall (Surfaceの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
gridIndex (Custom3DGridの継承元)
iCalcX (Surfaceの継承元)
iCalcY (Surfaceの継承元)
iGridIndexFilled (Custom3DGridの継承元)
iInGallery (Custom3DGridの継承元)
iNextXCell (Custom3DGridの継承元)
iNextZCell (Custom3DGridの継承元)
InternalUse (TeeBaseの継承元)
iNumXValues (Custom3DGridの継承元)
iNumZValues (Custom3DGridの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
Points (Surfaceの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
valueIndex0 (Custom3DGridの継承元)
valueIndex1 (Custom3DGridの継承元)
valueIndex2 (Custom3DGridの継承元)
valueIndex3 (Custom3DGridの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

Waterfall クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat (Seriesの継承元) |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CellsOrientation (Surfaceの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Custom3DGridの継承元) | すべての系列値を削除します。
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Surfaceの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
CreateValues (Custom3DGridの継承元) | NumZサイズによりNumXのサーフェスグリッドを作成します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (Surfaceの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Seriesの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FastCalcPoints (Surfaceの継承元) |
FillGridIndex (Custom3DGridの継承元) |
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom3DPaletteの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
PrepareForGallery (Surfaceの継承元) |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues (Custom3DGridの継承元) |
AddValues (Custom3DGridの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery |
Dispose (Seriesの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DGridの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DoGetYValue (Custom3DGridの継承元) |
DrawCell (Surfaceの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Custom3Dの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
DrawSidePortion (Surfaceの継承元) |
ExistFourGridIndex (Custom3DGridの継承元) |
FourGridIndex (Surfaceの継承元) |
GetBounds (Seriesの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Custom3DGridの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Surfaceの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldDrawFast (Surfaceの継承元) |
ShouldDrawSides (Surfaceの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

Waterfall クラス | Steema.TeeChart.Styles 名前空間


CreateSubGallery

Steema.TeeChart.Styles.Waterfall.CreateSubGallery メソッド

protected internal abstract Void CreateSubGallery(SubGalleryEventHandler AddSubChart)

参照

Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.Waterfall.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.Waterfall プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のためのアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
DotFrame (Surfaceの継承元) | ドットグリッド（ピクセル）としてサーフェス系列を設定します。
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のためのアルファ値を設定します。
HideCells (Surfaceの継承元) |
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
IrregularGrid (Custom3DGridの継承元) | X値とZ値が同じ距離かどうかを設定します。
Item (Custom3DGridの継承元) | 系列のセル値に簡単にアクセスするための2次元配列プロパティです。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
NumXValues (Custom3DGridの継承元) | サーフェスの水平サイズをポイント数で設定します。
NumZValues (Custom3DGridの継承元) | サーフェスの深さのサイズをポイント数で設定します。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃いを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のためのアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
SideBrush (Surfaceの継承元) | サーフェス系列の側面を塗りつぶすブラシを設定します。
SideLines (Surfaceの継承元) |
SmoothPalette (Surfaceの継承元) | サーフェス系列のセルの色を設定します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
WaterFall (Surfaceの継承元) | ウォーターフォールとしての表示を有効/無効にします。
WaterLines (Surfaceの継承元) | 値ラインを描くペンを設定します。
WireFrame (Surfaceの継承元) | グリッドあるいはワイヤーフレームとしてサーフェスポリゴンを表示します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

Waterfall クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.Waterfall.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

Waterfall クラス | Waterfall メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose

Steema.TeeChart.Styles.WindRose クラス

風向図系列。

この型のすべてのメンバの一覧については、WindRose メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Circular
Steema.TeeChart.Styles.CustomPolar
Steema.TeeChart.Styles.Custom2DPolar
public class WindRose : Custom2DPolar , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.dll

参照

WindRose メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose 全メンバ

WindRose 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom2DPolarの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MirrorAngles |
MirrorLabels |
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | ポインタの書式属性を制御します。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。.
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

WindRose クラス | Steema.TeeChart.Styles 名前空間


WindRose コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.WindRose コンストラクタ

オーバーロードの一覧

public WindRose()
public WindRose(Steema.TeeChart.Chart)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


WindRose コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Styles.WindRose コンストラクタ

public WindRose()

参照

WindRose コンストラクタのオーバーロードの一覧 | WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


WindRose コンストラクタ

Steema.TeeChart.Styles.WindRose コンストラクタ

public WindRose(Chart c)

参照

WindRose コンストラクタのオーバーロードの一覧 | WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetPointerStyle (CustomPolarの継承元) | 系列ポイントを描画する際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

WindRose クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
iCircleHeight (Circularの継承元)
iCircleWidth (Circularの継承元)
iCircleXCenter (Circularの継承元)
iCircleYCenter (Circularの継承元)
IMaxValuesCount (CustomPolarの継承元)
InternalUse (TeeBaseの継承元)
iPointer (CustomPolarの継承元)
iXRadius (Circularの継承元)
iYRadius (Circularの継承元)
lastVisible (Seriesの継承元)
rCircleRect (Circularの継承元)
rotDegree (Circularの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
yMandatory (Seriesの継承元)

参照

WindRose クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose メソッド

パブリック メソッド

Add (Seriesの継承元) | 指定したパラメーターでポイントを追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AngleToPos (Circularの継承元) | 指定した角度と半径の画面位置を返します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (CustomPolarの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Seriesの継承元) | 系列からすべてのポイント、テキスト、色を削除します。
Clicked (CustomPolarの継承元) |
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Seriesの継承元) | 指定したインデックスのポイントを削除します。X値は変わりません。
Draw (CustomPolarの継承元) |
DrawRing (CustomPolarの継承元) |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (CustomPolarの継承元) | 内部的に呼び出されます。系列の｢ValueIndex｣ポイントを描画します。
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
DrawZone (CustomPolarの継承元) |
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues (Seriesの継承元) | 系列の描画を確認するためにランダム値を追加します。各系列クラスはランダムなポイントをいくつ追加するか設定します。
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D (Custom2DPolarの継承元) |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Seriesの継承元) | 系列のデータソースを有効にします。
LegendString (Seriesの継承元) | 指定したLegendIndexポイントに該当する書式化された文字列を返します。
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Seriesの継承元) | 系列のX値リストの最大値を返します。
MaxYValue (Seriesの継承元) | 系列のY値リストの最大値を返します。
MaxZValue (Seriesの継承元) | Z値の最大値を返します。
MinXValue (Seriesの継承元) | 系列のX値リストの最小値を返します。
MinYValue (Seriesの継承元) | 系列のY値リストの最小値を返します。
MinZValue (Seriesの継承元) | Z値の最小値を返します。
OnGetPointerStyle (CustomPolarの継承元) |
PointToAngle (Circularの継承元) | XYパラメーターから円の中心までの角度を返します。
PointToRadius (Circularの継承元) | XYポイントから円の中心までの半径を返します。
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
Rotate (Circularの継承元) | 回転しているチャートの角度を返します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery (Seriesの継承元) | サブギャラリダイアログに表示するために、インデックス番目の系列スタイルを作成して準備します。
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Seriesの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Seriesの継承元) |
AdjustCircleRect (Circularの継承元) |
AssociatedToAxis (Circularの継承元) |
CalcCircleBackColor (Circularの継承元) |
CalcCircleGradient (Circularの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Seriesの継承元) |
CalcRadius (Circularの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Seriesの継承元) |
CalcXYPos (CustomPolarの継承元) |
CalcZOrder (Seriesの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Seriesの継承元) |
CreateSubGallery (Seriesの継承元) |
Dispose (Seriesの継承元) |
DoAfterDrawValues (CustomPolarの継承元) |
DoBeforeDrawChart (Seriesの継承元) |
DoBeforeDrawValues (CustomPolarの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (CustomPolarの継承元) |
DrawMark (CustomPolarの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawPolarCircle (CustomPolarの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (CustomPolarの継承元) |
GetCircleLabel |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetXValue |
InternalColor (Seriesの継承元) |
InternalDrawValue (CustomPolarの継承元) |
LegendItemColor (CustomPolarの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (CustomPolarの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Seriesの継承元) |
OnDisposing (Circularの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Circularの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Circularの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (CustomPolarの継承元) |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetParentProperties (Circularの継承元) |
SetRotationAngle (Circularの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeCircleBackColor (Circularの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ValueListOfAxis (Seriesの継承元) |

参照

WindRose クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.WindRose.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.WindRose.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


GetCircleLabel

TeeChartプログラミングガイド

Steema.TeeChart.Styles.WindRose.GetCircleLabel メソッド

protected virtual String GetCircleLabel(Double angle,
     Int32 index)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


GetXValue

Steema.TeeChart.Styles.WindRose.GetXValue メソッド

protected abstract Double GetXValue(Int32 valueIndex)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.WindRose.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WindRose プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
AngleIncrement (CustomPolarの継承元) | 反時計回りで分割グリッド線を描くために使用される度数単位の角度を設定します。
AngleValues (CustomPolarの継承元) | 各極ポイントの角度値リストを取得します。
Brush (CustomPolarの継承元) | 極のブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CircleBackColor (Circularの継承元) | 楕円を塗りつぶす色を設定します。
Circled (Circularの継承元) | サークル系列を楕円あるいは円で描画します。
CircleGradient (Circularの継承元) | 楕円を塗りつぶすグラデーションを設定します。
CircleHeight (Circularの継承元) | 円の高さを返します。
CircleLabels (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベル特性にアクセスします。
CircleLabelsFont (CustomPolarの継承元) |
CircleLabelsInside (CustomPolarの継承元) | 外円の内側に軸ラベルの表示を有効/無効にします。
CircleLabelsRotated (CustomPolarの継承元) | サークル系列（例：レーダーあるいは極系列）のラベルを回転します。
CirclePen (CustomPolarの継承元) | 外円を描くペンの種類を定義します。
CircleRect (Circularの継承元) | 円に隣接する矩形を返します。
CircleWidth (Circularの継承元) | 円の幅を返します。
CircleXCenter (Circularの継承元) | 楕円の中心の正確な水平位置をピクセル単位で返します。
CircleYCenter (Circularの継承元) | 楕円の中心の正確な垂直位置をピクセル単位で返します。
ClockWiseLabels (CustomPolarの継承元) | 時計回りで外円ラベルの表示を有効/無効にします。
CloseCircle (CustomPolarの継承元) | 極系列の最初と最後のポイント間に線を描きます。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
CustomXRadius (Circularの継承元) | 楕円の水平半径をピクセル単位で設定します。
CustomYRadius (Circularの継承元) | 楕円の垂直半径をピクセル単位で設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description |
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Font (CustomPolarの継承元) | ラベルのフォントを設定します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
Item (Seriesの継承元) | ポイント特性。
LabelMember (Seriesの継承元) | データソースのラベルフィールドを取得/設定します。
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LabelsMargin (CustomPolarの継承元) | CustomPolarの円とラベルの間の距離を定義します。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MiddleZ (Seriesの継承元) | 内部使用。
MirrorAngles |
MirrorLabels |
NumGallerySeries (Seriesの継承元) | 内部使用。
Pen (CustomPolarの継承元) | 極系列ポイントの接続線を描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
Pointer (CustomPolarの継承元) | Pen、Brush、Draw3D、Visibleなどのポイントの書式属性を制御するためのプロパティがあります。
RadiusIncrement (CustomPolarの継承元) | リンググリッド線を描くインクリメントを設定します。
RadiusValues (CustomPolarの継承元) | 各極ポイントの半径値のリストを取得します。
RotationAngle (Circularの継承元) | チャートの回転角度を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartZ (Seriesの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (CustomPolarの継承元) | 0～100%までの透明度を設定します。
TreatNulls (CustomPolarの継承元) |
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XRadius (Circularの継承元) | 楕円の水平方向の半径のサイズをピクセル単位で取得/設定します。
XValues (Seriesの継承元) | 水平ポイント位置を設定する値。
YRadius (Circularの継承元) | 楕円の垂直方向の半径のサイズをピクセル単位で取得/設定します。
YValues (Seriesの継承元) | 垂直ポイント位置を設定する値。
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。

参照

WindRose クラス | Steema.TeeChart.Styles 名前空間


Description

Steema.TeeChart.Styles.WindRose.Description プロパティ

public override String Description {get;}

解説

説明テキストを取得します。

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


MirrorAngles

Steema.TeeChart.Styles.WindRose.MirrorAngles プロパティ

public Boolean MirrorAngles {get; set;}

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


MirrorLabels

Steema.TeeChart.Styles.WindRose.MirrorLabels プロパティ

public Boolean MirrorLabels {get; set;}

参照

WindRose クラス | WindRose メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Themes

Steema.TeeChart.Themes 名前空間

名前空間の階層構造

パブリック クラス

Theme | テーマの概要。
CustomTheme | カスタムテーマの概要。
TeeChartTheme | デフォルトテーマの概要。
GrayscaleTheme | グレースケールテーマの概要。
ColorPalettes |
RandomTheme |
ThemeProperties |
ExcelTheme | Excelテーマの概要。
BusinessTheme | 業務テーマの概要。
WebTheme | Webテーマの概要。
ClassicTheme | クラシックテーマの概要。
XPTheme | WindowsXPテーマの概要。
BlueSkyTheme | BlueSkyテーマの概要。
OperaTheme |

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Themes 階層構造

System.Object

Steema.TeeChart.Themes.ThemeProperties

System.Collections.Generic.List

Steema.TeeChart.Themes.ColorPalettes

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Themes.Theme

Steema.TeeChart.Themes.CustomTheme

Steema.TeeChart.Themes.TeeChartTheme

Steema.TeeChart.Themes.BlueSkyTheme

Steema.TeeChart.Themes.BusinessTheme

Steema.TeeChart.Themes.XPTheme

Steema.TeeChart.Themes.ClassicTheme

Steema.TeeChart.Themes.ExcelTheme

Steema.TeeChart.Themes.GrayscaleTheme

Steema.TeeChart.Themes.OperaTheme

Steema.TeeChart.Themes.RandomTheme

Steema.TeeChart.Themes.WebTheme

参照

SteemaTeeChartThemes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme

Steema.TeeChart.Themes.BlackIsBackTheme クラス

この型のすべてのメンバの一覧については、BlackIsBackTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
Steema.TeeChart.Themes.OperaTheme
public class BlackIsBackTheme : OperaTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

BlackIsBackTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme 全メンバ

BlackIsBackTheme 概要

コンストラクタ

コンストラクタ

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BlackIsBackTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme コンストラクタ

public BlackIsBackTheme(Chart c)

参照

BlackIsBackTheme クラス | BlackIsBackTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

BlackIsBackTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BlackIsBackTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.BlackIsBackTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

BlackIsBackTheme クラス | BlackIsBackTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.BlackIsBackTheme.ToString メソッド

public override String ToString()

参照

BlackIsBackTheme クラス | BlackIsBackTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlackIsBackTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

BlackIsBackTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlueSkyTheme

Steema.TeeChart.Themes.BlueSkyTheme クラス

BlueSkyテーマ。

この型のすべてのメンバの一覧については、BlueSkyTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class BlueSkyTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

BlueSkyTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlueSkyTheme 全メンバ

BlueSkyTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BlueSkyTheme クラス | Steema.TeeChart.Themes 名前空間


BlueSkyTheme コンストラクタ

Steema.TeeChart.Themes.BlueSkyTheme コンストラクタ

public BlueSkyTheme(Chart c)

参照

BlueSkyTheme クラス | BlueSkyTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlueSkyTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

BlueSkyTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlueSkyTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BlueSkyTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.BlueSkyTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

BlueSkyTheme クラス | BlueSkyTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.BlueSkyTheme.ToString メソッド

public override String ToString()

参照

BlueSkyTheme クラス | BlueSkyTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BlueSkyTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

BlueSkyTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BusinessTheme

Steema.TeeChart.Themes.BusinessTheme クラス

業務テーマの概要。

この型のすべてのメンバの一覧については、BusinessTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class BusinessTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

BusinessTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BusinessTheme 全メンバ

BusinessTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BusinessTheme クラス | Steema.TeeChart.Themes 名前空間


BusinessTheme コンストラクタ

Steema.TeeChart.Themes.BusinessTheme コンストラクタ

public BusinessTheme(Chart c)

参照

BusinessTheme クラス | BusinessTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BusinessTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

BusinessTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BusinessTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

BusinessTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.BusinessTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

BusinessTheme クラス | BusinessTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.BusinessTheme.ToString メソッド

public override String ToString()

参照

BusinessTheme クラス | BusinessTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.BusinessTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

BusinessTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ClassicTheme

Steema.TeeChart.Themes.ClassicTheme クラス

クラシックテーマの概要。

この型のすべてのメンバの一覧については、ClassicTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class ClassicTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

ClassicTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ClassicTheme 全メンバ

ClassicTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ClassicTheme クラス | Steema.TeeChart.Themes 名前空間


ClassicTheme コンストラクタ

Steema.TeeChart.Themes.ClassicTheme コンストラクタ

public ClassicTheme(Chart c)

参照

ClassicTheme クラス | ClassicTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ClassicTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ClassicTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ClassicTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ClassicTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.ClassicTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

ClassicTheme クラス | ClassicTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.ClassicTheme.ToString メソッド

public override String ToString()

参照

ClassicTheme クラス | ClassicTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ClassicTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

ClassicTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ColorPalettes

Steema.TeeChart.Themes.ColorPalettes クラス

この型のすべてのメンバの一覧については、ColorPalettes メンバを参照してください。

System.Object
System.Collections.Generic.List<System.String>
[Serializable]
public sealed class ColorPalettes : List<String>
, IList<String>, ICollection<String>, IEnumerable<String>
, IEnumerable, IList, ICollection

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ColorPalettes 全メンバ

ColorPalettes 概要

コンストラクタ

Constructor

パブリック メソッド

ApplyPalette
ColorPaletteChanged
IsInPalette

参照

ColorPalettes クラス | Steema.TeeChart.Themes 名前空間


ColorPalettes コンストラクタ

Steema.TeeChart.Themes.ColorPalettes コンストラクタ

public ColorPalettes()

参照

ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ColorPalettes メソッド

パブリック メソッド

ApplyPalette
ColorPaletteChanged
IsInPalette

参照

ColorPalettes クラス | Steema.TeeChart.Themes 名前空間


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette メソッド

オーバーロードの一覧

public static Void ApplyPalette(Steema.TeeChart.Chart, System.Int32)
public static Void ApplyPalette(Steema.TeeChart.Chart, System.Drawing.Color[])

解説

チャートのカラーパレットをIndexで指定したカラーパレットと入れ替えます。

「clTeeColor」の場合、系列の色や系列ポイントの色はPaletteを参照します。

参照

ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette メソッド

public static Void ApplyPalette(Chart custom,
     Int32 Index)

参照

ApplyPalette オーバーロードの一覧 | ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


ApplyPalette

Steema.TeeChart.Themes.ColorPalettes.ApplyPalette メソッド

public static Void ApplyPalette(Chart custom,
     Color[] Palette)

参照

ApplyPalette オーバーロードの一覧 | ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


ColorPaletteChanged

Steema.TeeChart.Themes.ColorPalettes.ColorPaletteChanged メソッド

public static Void ColorPaletteChanged(Chart custom,
     Color[] Palette)

参照

ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


IsInPalette

Steema.TeeChart.Themes.ColorPalettes.IsInPalette メソッド

public static Boolean IsInPalette(Color color,
     Color[] Palette)

参照

ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ColorPalettes プロパティ

パブリック プロパティ

Item

参照

ColorPalettes クラス | Steema.TeeChart.Themes 名前空間


Item

Steema.TeeChart.Themes.ColorPalettes.Item プロパティ

public String Item(Int32 index) {get;}

参照

ColorPalettes クラス | ColorPalettes メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme

Steema.TeeChart.Themes.CustomTheme クラス

カスタムテーマの概要。

この型のすべてのメンバの一覧については、CustomTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
public class CustomTheme : Theme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme 全メンバ

CustomTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries
ChangeAspect
ChangeAxes
ChangeAxis
ChangeHeader
ChangeLegend
ChangePanel
ChangeSeries
ChangeWall
ChangeWalls
ResetHeaderGradient
ResetLegendGradient
ResetPanelGradient
ResetSeriesMarksGradient
ResetWallGradient
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

CustomTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme コンストラクタ

public CustomTheme(Chart c)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

CustomTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme メソッド

パブリック メソッド

Apply |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries
ChangeAspect
ChangeAxes
ChangeAxis
ChangeHeader
ChangeLegend
ChangePanel
ChangeSeries
ChangeWall
ChangeWalls
ResetHeaderGradient
ResetLegendGradient
ResetPanelGradient
ResetSeriesMarksGradient
ResetWallGradient
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

CustomTheme クラス | Steema.TeeChart.Themes 名前空間


Apply

Steema.TeeChart.Themes.CustomTheme.Apply メソッド

オーバーロードの一覧

public override Void Apply(Steema.TeeChart.Chart)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


Apply

Steema.TeeChart.Themes.CustomTheme.Apply メソッド

public override Void Apply(Chart AChart)

参照

Apply オーバーロードの一覧 | CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeAllSeries

Steema.TeeChart.Themes.CustomTheme.ChangeAllSeries メソッド

protected internal abstract Void ChangeAllSeries(SeriesCollection ChartSeries)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeAspect

Steema.TeeChart.Themes.CustomTheme.ChangeAspect メソッド

protected internal abstract Void ChangeAspect(Aspect ChartAspect)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeAxes

Steema.TeeChart.Themes.CustomTheme.ChangeAxes メソッド

protected internal abstract Void ChangeAxes(Axes ChartAxes)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeAxis

Steema.TeeChart.Themes.CustomTheme.ChangeAxis メソッド

protected internal abstract Void ChangeAxis(Axis ChartAxis)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeHeader

Steema.TeeChart.Themes.CustomTheme.ChangeHeader メソッド

protected internal abstract Void ChangeHeader(Header ChartHeader)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeLegend

Steema.TeeChart.Themes.CustomTheme.ChangeLegend メソッド

protected internal abstract Void ChangeLegend(Legend ChartLegend)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangePanel

Steema.TeeChart.Themes.CustomTheme.ChangePanel メソッド

protected internal abstract Void ChangePanel(Panel ChartPanel)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeSeries

Steema.TeeChart.Themes.CustomTheme.ChangeSeries メソッド

protected internal abstract Void ChangeSeries(Series ChartSeries)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeWall

Steema.TeeChart.Themes.CustomTheme.ChangeWall メソッド

protected internal abstract Void ChangeWall(Wall ChartWall,
     Color AColor)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ChangeWalls

Steema.TeeChart.Themes.CustomTheme.ChangeWalls メソッド

protected internal abstract Void ChangeWalls(Walls ChartWalls)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ResetHeaderGradient

Steema.TeeChart.Themes.CustomTheme.ResetHeaderGradient メソッド

protected internal abstract Void ResetHeaderGradient(Gradient ChartGradient)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ResetLegendGradient

Steema.TeeChart.Themes.CustomTheme.ResetLegendGradient メソッド

protected internal abstract Void ResetLegendGradient(Gradient ChartGradient)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ResetPanelGradient

Steema.TeeChart.Themes.CustomTheme.ResetPanelGradient メソッド

protected internal abstract Void ResetPanelGradient(Gradient ChartGradient)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ResetSeriesMarksGradient

Steema.TeeChart.Themes.CustomTheme.ResetSeriesMarksGradient メソッド

protected internal abstract Void ResetSeriesMarksGradient(Gradient ChartGradient)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ResetWallGradient

Steema.TeeChart.Themes.CustomTheme.ResetWallGradient メソッド

protected internal abstract Void ResetWallGradient(Gradient ChartGradient)

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.CustomTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.CustomTheme.ToString メソッド

public override String ToString()

参照

CustomTheme クラス | CustomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.CustomTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

CustomTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ExcelTheme

Steema.TeeChart.Themes.ExcelTheme クラス

Microsoft Excelテーマの概要。

この型のすべてのメンバの一覧については、ExcelTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class ExcelTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

ExcelTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ExcelTheme 全メンバ

ExcelTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ExcelTheme クラス | Steema.TeeChart.Themes 名前空間


ExcelTheme コンストラクタ

Steema.TeeChart.Themes.ExcelTheme コンストラクタ

public ExcelTheme(Chart c)

参照

ExcelTheme クラス | ExcelTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ExcelTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

ExcelTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ExcelTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ExcelTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.ExcelTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

ExcelTheme クラス | ExcelTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.ExcelTheme.ToString メソッド

public override String ToString()

参照

ExcelTheme クラス | ExcelTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ExcelTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

ExcelTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.GrayscaleTheme

Steema.TeeChart.Themes.GrayscaleTheme クラス

グレースケールテーマの概要。

この型のすべてのメンバの一覧については、GrayscaleTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class GrayscaleTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

GrayscaleTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.GrayscaleTheme 全メンバ

GrayscaleTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GrayscaleTheme クラス | Steema.TeeChart.Themes 名前空間


GrayscaleTheme コンストラクタ

Steema.TeeChart.Themes.GrayscaleTheme コンストラクタ

public GrayscaleTheme(Chart c)

参照

GrayscaleTheme クラス | GrayscaleTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.GrayscaleTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

GrayscaleTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.GrayscaleTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GrayscaleTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.GrayscaleTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

GrayscaleTheme クラス | GrayscaleTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.GrayscaleTheme.ToString メソッド

public override String ToString()

参照

GrayscaleTheme クラス | GrayscaleTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.GrayscaleTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

GrayscaleTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme

Steema.TeeChart.Themes.OperaTheme クラス

この型のすべてのメンバの一覧については、OperaTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class OperaTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

OperaTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme 全メンバ

OperaTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

OperaTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme コンストラクタ

public OperaTheme(Chart c)

参照

OperaTheme クラス | OperaTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

OperaTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

OperaTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.OperaTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

OperaTheme クラス | OperaTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.OperaTheme.ToString メソッド

public override String ToString()

参照

OperaTheme クラス | OperaTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.OperaTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

OperaTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme

Steema.TeeChart.Themes.RandomTheme クラス

この型のすべてのメンバの一覧については、RandomTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class RandomTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

RandomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme 全メンバ

RandomTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
RandomColor |

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues (TeeChartThemeの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

RandomTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme コンストラクタ

public RandomTheme(Chart c)

参照

RandomTheme クラス | RandomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

RandomTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues (TeeChartThemeの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

RandomTheme クラス | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.RandomTheme.ToString メソッド

public override String ToString()

参照

RandomTheme クラス | RandomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.RandomTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
RandomColor |

参照

RandomTheme クラス | Steema.TeeChart.Themes 名前空間


RandomColor

Steema.TeeChart.Themes.RandomTheme.RandomColor プロパティ

public static Color RandomColor {get;}

参照

RandomTheme クラス | RandomTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme

Steema.TeeChart.Themes.TeeChartTheme クラス

TeeChart デフォルトテーマの概要。

この型のすべてのメンバの一覧については、TeeChartTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
public class TeeChartTheme : CustomTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

TeeChartTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme 全メンバ

TeeChartTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

TeeChartTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme コンストラクタ

public TeeChartTheme(Chart c)

参照

TeeChartTheme クラス | TeeChartTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TeeChartTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

TeeChartTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.TeeChartTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

TeeChartTheme クラス | TeeChartTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.TeeChartTheme.ToString メソッド

public override String ToString()

参照

TeeChartTheme クラス | TeeChartTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.TeeChartTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

TeeChartTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.Theme

Steema.TeeChart.Themes.Theme クラス

テーマの概要。

この型のすべてのメンバの一覧については、Theme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
[Serializable]
public abstract class Theme : TeeBase , IComponent
, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

Theme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.Theme 全メンバ

Theme 概要

コンストラクタ

Constructor

パブリック フィールド

ClassicPalette
CoolPalette
ExcelPalette
GrayscalePalette
MacOSPalette
ModernPalette
OperaPalette
PastelsPalette
RainbowPalette
SolidPalette
TeeChartPalette
VictorianPalette
WarmPalette
WebPalette
WindowsVistaPalette
WindowsXPPalette

パブリック メソッド

Apply |
ApplyChartTheme |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ReadFromXML |
RegisterChartThemes |
ToString |
WriteToXML |

パブリック プロパティ

Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartThemes |
ColorPalettes |

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Theme クラス | Steema.TeeChart.Themes 名前空間


Theme コンストラクタ

Steema.TeeChart.Themes.Theme コンストラクタ

public Theme(Chart c)

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.Theme フィールド

パブリック フィールド

ClassicPalette
CoolPalette
ExcelPalette
GrayscalePalette
MacOSPalette
ModernPalette
OperaPalette
PastelsPalette
RainbowPalette
SolidPalette
TeeChartPalette
VictorianPalette
WarmPalette
WebPalette
WindowsVistaPalette
WindowsXPPalette

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Theme クラス | Steema.TeeChart.Themes 名前空間


ClassicPalette

Steema.TeeChart.Themes.Theme.ClassicPalette フィールド

public Color[] ClassicPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


CoolPalette

Steema.TeeChart.Themes.Theme.CoolPalette フィールド

public Color[] CoolPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ExcelPalette

Steema.TeeChart.Themes.Theme.ExcelPalette フィールド

public Color[] ExcelPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


GrayscalePalette

Steema.TeeChart.Themes.Theme.GrayscalePalette フィールド

public Color[] GrayscalePalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


MacOSPalette

Steema.TeeChart.Themes.Theme.MacOSPalette フィールド

public Color[] MacOSPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ModernPalette

Steema.TeeChart.Themes.Theme.ModernPalette フィールド

public Color[] ModernPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


OnBlackPalette

Steema.TeeChart.Themes.Theme.OnBlackPalette フィールド

public Color[] OnBlackPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


OperaPalette

Steema.TeeChart.Themes.Theme.OperaPalette フィールド

public Color[] OperaPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


PastelsPalette

Steema.TeeChart.Themes.Theme.PastelsPalette フィールド

public Color[] PastelsPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


RainbowPalette

Steema.TeeChart.Themes.Theme.RainbowPalette フィールド

public Color[] RainbowPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


SolidPalette

Steema.TeeChart.Themes.Theme.SolidPalette フィールド

public Color[] SolidPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


TeeChartPalette

Steema.TeeChart.Themes.Theme.TeeChartPalette フィールド

public Color[] TeeChartPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


VictorianPalette

Steema.TeeChart.Themes.Theme.VictorianPalette フィールド

public Color[] VictorianPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WarmPalette

Steema.TeeChart.Themes.Theme.WarmPalette フィールド

public Color[] WarmPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WebPalette

Steema.TeeChart.Themes.Theme.WebPalette フィールド

public Color[] WebPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WindowsVistaPalette

Steema.TeeChart.Themes.Theme.WindowsVistaPalette フィールド

public Color[] WindowsVistaPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WindowsXPPalette

Steema.TeeChart.Themes.Theme.WindowsXPPalette フィールド

public Color[] WindowsXPPalette

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.Theme メソッド

パブリック メソッド

Apply |
ApplyChartTheme |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ReadFromXML |
RegisterChartThemes |
ToString |
WriteToXML |

プロテクト メソッド

SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Theme クラス | Steema.TeeChart.Themes 名前空間


Apply

Steema.TeeChart.Themes.Theme.Apply メソッド

オーバーロードの一覧

public abstract Void Apply(Steema.TeeChart.Chart)
public Void Apply()

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Apply

Steema.TeeChart.Themes.Theme.Apply メソッド

public abstract Void Apply(Chart AChart)

参照

Apply オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Apply

Steema.TeeChart.Themes.Theme.Apply メソッド

public Void Apply()

参照

Apply オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

オーバーロードの一覧

public static Void ApplyChartTheme(System.String, Steema.TeeChart.Chart)
public static Void ApplyChartTheme(System.IO.Stream, Steema.TeeChart.Chart)
public static Void ApplyChartTheme(Steema.TeeChart.Themes.Theme, Steema.TeeChart.Chart)
public static Void ApplyChartTheme(Steema.TeeChart.Themes.Theme, Steema.TeeChart.Chart, System.Int32)
public static Void ApplyChartTheme(System.IO.Stream, Steema.TeeChart.Chart, System.Int32)

解説

Chartパラメーターにテーマを適用します。

デフォルトテーマのカラーパレットを使用するには、PaletteIndexパラメーターを「-1」に設定してください。

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

public static Void ApplyChartTheme(String ThemeFile,
     Chart CustomChart)

参照

ApplyChartTheme オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

public static Void ApplyChartTheme(Stream ThemeStream,
     Chart CustomChart)

参照

ApplyChartTheme オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

public static Void ApplyChartTheme(Theme ThemeClass,
     Chart CustomChart)

参照

ApplyChartTheme オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

public static Void ApplyChartTheme(Theme ThemeClass,
     Chart CustomChart,
     Int32 PaletteIndex)

参照

ApplyChartTheme オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ApplyChartTheme

Steema.TeeChart.Themes.Theme.ApplyChartTheme メソッド

public static Void ApplyChartTheme(Stream ThemeStream,
     Chart CustomChart,
     Int32 PaletteIndex)

参照

ApplyChartTheme オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ReadFromXML

Steema.TeeChart.Themes.Theme.ReadFromXML メソッド

オーバーロードの一覧

public static Void ReadFromXML(System.String)
public static Void ReadFromXML(System.IO.Stream)

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ReadFromXML

Steema.TeeChart.Themes.Theme.ReadFromXML メソッド

public static Void ReadFromXML(String fileName)

参照

ReadFromXML オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ReadFromXML

Steema.TeeChart.Themes.Theme.ReadFromXML メソッド

public static Void ReadFromXML(Stream stream)

参照

ReadFromXML オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


RegisterChartThemes

Steema.TeeChart.Themes.Theme.RegisterChartThemes メソッド

public static Void RegisterChartThemes()

解説

テーマの内部リストに新しいテーマクラスを追加します。

TChartThemeSelectorのフォームは、この内部リストに使用可能なテーマを表示します。

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.Theme.ToString メソッド

public override String ToString()

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WriteToXML

Steema.TeeChart.Themes.Theme.WriteToXML メソッド

オーバーロードの一覧

public Void WriteToXML(System.String)
public Void WriteToXML(System.IO.Stream)

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WriteToXML

Steema.TeeChart.Themes.Theme.WriteToXML メソッド

public Void WriteToXML(String fileName)

参照

WriteToXML オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


WriteToXML

Steema.TeeChart.Themes.Theme.WriteToXML メソッド

public Void WriteToXML(Stream stream)

参照

WriteToXML オーバーロードの一覧 | Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.Theme プロパティ

Steema.TeeChart.Themes.ThemeProperties クラス

この型のすべてのメンバの一覧については、ThemeProperties メンバを参照してください。

System.Object
public class ThemeProperties : Object , IThemeProperties

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


ChartThemes

Steema.TeeChart.Themes.Theme.ChartThemes プロパティ

public static List<Type> ChartThemes {get;}

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


ColorPalettes

Steema.TeeChart.Themes.Theme.ColorPalettes プロパティ

public static ColorPalettes ColorPalettes {get;}

解説

グローバル変数型。
この変数は、使用可能なすべてのカラーパレットを記憶します。
カラーパレットは、チャートのテーマで使用されますが、単独でも使用できます。

参照

Theme クラス | Theme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemeProperties 全メンバ

ThemeProperties 概要

コンストラクタ

Constructor

パブリック メソッド

Read
Write

パブリック プロパティ

AspectSmoothingMode
AspectTextRenderingHint
AxesBottomGridCentered
AxesBottomGridVisible
AxesTopGridVisible
AxisAxisPenColor
AxisAxisPenWidth
AxisGridCentered
AxisGridColor
AxisGridStyle
AxisGridVisible
AxisGridWidth
AxisLabelsFontBold
AxisLabelsFontColor
AxisLabelsFontName
AxisLabelsFontSize
AxisMinorGridColor
AxisMinorGridVisible
AxisMinorTickCount
AxisMinorTicksLength
AxisMinorTicksVisible
AxisTicksColor
AxisTicksInnerColor
AxisTicksInnerLength
AxisTicksInnerVisible
AxisTicksLength
AxisTitleFontColor
AxisTitleFontName
Base64
HeaderColor
HeaderFontBold
HeaderFontColor
HeaderFontName
HeaderFontSize
HeaderGradientDirection
HeaderGradientEndColor
HeaderGradientMiddleColor
HeaderGradientSigma
HeaderGradientSigmaFocus
HeaderGradientSigmaScale
HeaderGradientStartColor
HeaderGradientVisible
HeaderPenColor
HeaderPenVisible
HeaderPenWidth
HeaderShadowSize
HeaderShadowTransparency
HeaderTransparency
Instance
LegendDividingLinesColor
LegendDividingLinesVisible
LegendFontColor
LegendFontName
LegendFontSize
LegendGradientDirection
LegendGradientEndColor
LegendGradientMiddleColor
LegendGradientSigma
LegendGradientSigmaFocus
LegendGradientSigmaScale
LegendGradientStartColor
LegendGradientVisible
LegendPenColor
LegendPenStyle
LegendPenVisible
LegendPenWidth
LegendShadowColor
LegendShadowHeight
LegendShadowTransparency
LegendShadowWidth
LegendSymbolDefaultPen
LegendSymbolPenVisible
LegendSymbolSquared
LegendTransparent
Palette
PanelBevelInner
PanelBevelOuter
PanelBevelWidth
PanelBorderRound
PanelColor
PanelGradientDirection
PanelGradientEndColor
PanelGradientMiddleColor
PanelGradientSigma
PanelGradientSigmaFocus
PanelGradientSigmaScale
PanelGradientStartColor
PanelGradientVisible
PanelPenColor
PanelPenStyle
PanelPenVisible
PanelPenWidth
PanelShadowColor
PanelShadowSize
PanelShadowVisible
SeriesMarksArrowColor
SeriesMarksFontColor
SeriesMarksFontName
SeriesMarksFontSize
SeriesMarksGradientDirection
SeriesMarksGradientEndColor
SeriesMarksGradientMiddleColor
SeriesMarksGradientSigma
SeriesMarksGradientSigmaFocus
SeriesMarksGradientSigmaScale
SeriesMarksGradientStartColor
SeriesMarksGradientVisible
SeriesMarksTransparent
WallApplyDark
WallGradientDirection
WallGradientEndColor
WallGradientMiddleColor
WallGradientSigma
WallGradientSigmaFocus
WallGradientSigmaScale
WallGradientStartColor
WallGradientVisible
WallPenColor
WallPenStyle
WallPenVisible
WallPenWidth
WallsBackColor
WallsBackGradientDirection
WallsBackGradientEndColor
WallsBackGradientMiddleColor
WallsBackGradientSigma
WallsBackGradientSigmaFocus
WallsBackGradientSigmaScale
WallsBackGradientStartColor
WallsBackGradientVisible
WallsBackTransparent
WallsBottomColor
WallSize
WallsLeftColor
WallsRightColor

プロテクト メソッド

serializer_UnknownAttribute
serializer_UnknownNode

参照

ThemeProperties クラス | Steema.TeeChart.Themes.Theme 名前空間


Steema.TeeChart.Themes.ThemeProperties コンストラクタ

public ThemeProperties()

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemeProperties メソッド

パブリック メソッド

Read
Write

プロテクト メソッド

serializer_UnknownAttribute
serializer_UnknownNode

参照

ThemeProperties クラス | Steema.TeeChart.Themes 名前空間


Read

Steema.TeeChart.Themes.ThemeProperties.Read メソッド

オーバーロードの一覧

public Void Read(System.String)
public Void Read(System.IO.Stream)

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Read

Steema.TeeChart.Themes.ThemeProperties.Read メソッド

public Void Read(String fileName)

参照

Read オーバーロードの一覧 | ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Read

Steema.TeeChart.Themes.ThemeProperties.Read メソッド

public Void Read(Stream stream)

参照

Read オーバーロードの一覧 | ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


serializer_UnknownAttribute

Steema.TeeChart.Themes.ThemeProperties.serializer_UnknownAttribute メソッド

protected Void serializer_UnknownAttribute(Object sender,
     XmlAttributeEventArgs e)

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


serializer_UnknownNode

Steema.TeeChart.Themes.ThemeProperties.serializer_UnknownNode メソッド

protected Void serializer_UnknownNode(Object sender,
     XmlNodeEventArgs e)

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Write

Steema.TeeChart.Themes.ThemeProperties.Write メソッド

オーバーロードの一覧

public Void Write(System.String)
public Void Write(System.IO.Stream)

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Write

Steema.TeeChart.Themes.ThemeProperties.Write メソッド

public Void Write(String fileName)

参照

Write オーバーロードの一覧 | ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Write

Steema.TeeChart.Themes.ThemeProperties.Write メソッド

public Void Write(Stream stream)

参照

Write オーバーロードの一覧 | ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemeProperties プロパティ

パブリック プロパティ

AspectSmoothingMode
AspectTextRenderingHint
AxesBottomGridCentered
AxesBottomGridVisible
AxesTopGridVisible
AxisAxisPenColor
AxisAxisPenWidth
AxisGridCentered
AxisGridColor
AxisGridStyle
AxisGridVisible
AxisGridWidth
AxisLabelsFontBold
AxisLabelsFontColor
AxisLabelsFontName
AxisLabelsFontSize
AxisMinorGridColor
AxisMinorGridVisible
AxisMinorTickCount
AxisMinorTicksLength
AxisMinorTicksVisible
AxisTicksColor
AxisTicksInnerColor
AxisTicksInnerLength
AxisTicksInnerVisible
AxisTicksLength
AxisTitleFontColor
AxisTitleFontName
Base64
HeaderColor
HeaderFontBold
HeaderFontColor
HeaderFontName
HeaderFontSize
HeaderGradientDirection
HeaderGradientEndColor
HeaderGradientMiddleColor
HeaderGradientSigma
HeaderGradientSigmaFocus
HeaderGradientSigmaScale
HeaderGradientStartColor
HeaderGradientVisible
HeaderPenColor
HeaderPenVisible
HeaderPenWidth
HeaderShadowSize
HeaderShadowTransparency
HeaderTransparency
Instance
LegendDividingLinesColor
LegendDividingLinesVisible
LegendFontColor
LegendFontName
LegendFontSize
LegendGradientDirection
LegendGradientEndColor
LegendGradientMiddleColor
LegendGradientSigma
LegendGradientSigmaFocus
LegendGradientSigmaScale
LegendGradientStartColor
LegendGradientVisible
LegendPenColor
LegendPenStyle
LegendPenVisible
LegendPenWidth
LegendShadowColor
LegendShadowHeight
LegendShadowTransparency
LegendShadowWidth
LegendSymbolDefaultPen
LegendSymbolPenVisible
LegendSymbolSquared
LegendTransparent
Palette
PanelBevelInner
PanelBevelOuter
PanelBevelWidth
PanelBorderRound
PanelColor
PanelGradientDirection
PanelGradientEndColor
PanelGradientMiddleColor
PanelGradientSigma
PanelGradientSigmaFocus
PanelGradientSigmaScale
PanelGradientStartColor
PanelGradientVisible
PanelPenColor
PanelPenStyle
PanelPenVisible
PanelPenWidth
PanelShadowColor
PanelShadowSize
PanelShadowVisible
SeriesMarksArrowColor
SeriesMarksFontColor
SeriesMarksFontName
SeriesMarksFontSize
SeriesMarksGradientDirection
SeriesMarksGradientEndColor
SeriesMarksGradientMiddleColor
SeriesMarksGradientSigma
SeriesMarksGradientSigmaFocus
SeriesMarksGradientSigmaScale
SeriesMarksGradientStartColor
SeriesMarksGradientVisible
SeriesMarksTransparent
WallApplyDark
WallGradientDirection
WallGradientEndColor
WallGradientMiddleColor
WallGradientSigma
WallGradientSigmaFocus
WallGradientSigmaScale
WallGradientStartColor
WallGradientVisible
WallPenColor
WallPenStyle
WallPenVisible
WallPenWidth
WallsBackColor
WallsBackGradientDirection
WallsBackGradientEndColor
WallsBackGradientMiddleColor
WallsBackGradientSigma
WallsBackGradientSigmaFocus
WallsBackGradientSigmaScale
WallsBackGradientStartColor
WallsBackGradientVisible
WallsBackTransparent
WallsBottomColor
WallSize
WallsLeftColor
WallsRightColor

参照

ThemeProperties クラス | Steema.TeeChart.Themes 名前空間


AspectSmoothingMode

Steema.TeeChart.Themes.ThemeProperties.AspectSmoothingMode プロパティ

public virtual String AspectSmoothingMode {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AspectTextRenderingHint

Steema.TeeChart.Themes.ThemeProperties.AspectTextRenderingHint プロパティ

public virtual String AspectTextRenderingHint {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxesBottomGridCentered

Steema.TeeChart.Themes.ThemeProperties.AxesBottomGridCentered プロパティ

public virtual Boolean AxesBottomGridCentered {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxesBottomGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxesBottomGridVisible プロパティ

public virtual Boolean AxesBottomGridVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxesTopGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxesTopGridVisible プロパティ

public virtual Boolean AxesTopGridVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisAxisPenColor

Steema.TeeChart.Themes.ThemeProperties.AxisAxisPenColor プロパティ

public virtual String AxisAxisPenColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisAxisPenWidth

Steema.TeeChart.Themes.ThemeProperties.AxisAxisPenWidth プロパティ

public virtual Int32 AxisAxisPenWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisGridCentered

Steema.TeeChart.Themes.ThemeProperties.AxisGridCentered プロパティ

public virtual Boolean AxisGridCentered {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisGridColor

Steema.TeeChart.Themes.ThemeProperties.AxisGridColor プロパティ

public virtual String AxisGridColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisGridStyle

Steema.TeeChart.Themes.ThemeProperties.AxisGridStyle プロパティ

public virtual String AxisGridStyle {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxisGridVisible プロパティ

public virtual Boolean AxisGridVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisGridWidth

Steema.TeeChart.Themes.ThemeProperties.AxisGridWidth プロパティ

public virtual Int32 AxisGridWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisLabelsFontBold

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontBold プロパティ

public virtual Boolean AxisLabelsFontBold {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisLabelsFontColor

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontColor プロパティ

public virtual String AxisLabelsFontColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisLabelsFontName

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontName プロパティ

public virtual String AxisLabelsFontName {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisLabelsFontSize

Steema.TeeChart.Themes.ThemeProperties.AxisLabelsFontSize プロパティ

public virtual Int32 AxisLabelsFontSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisMinorGridColor

Steema.TeeChart.Themes.ThemeProperties.AxisMinorGridColor プロパティ

public virtual String AxisMinorGridColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisMinorGridVisible

Steema.TeeChart.Themes.ThemeProperties.AxisMinorGridVisible プロパティ

public virtual Boolean AxisMinorGridVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisMinorTickCount

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTickCount プロパティ

public virtual Int32 AxisMinorTickCount {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisMinorTicksLength

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTicksLength プロパティ

public virtual Int32 AxisMinorTicksLength {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisMinorTicksVisible

Steema.TeeChart.Themes.ThemeProperties.AxisMinorTicksVisible プロパティ

public virtual Boolean AxisMinorTicksVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTicksColor

Steema.TeeChart.Themes.ThemeProperties.AxisTicksColor プロパティ

public virtual String AxisTicksColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTicksInnerColor

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerColor プロパティ

public virtual String AxisTicksInnerColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTicksInnerLength

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerLength プロパティ

public virtual Int32 AxisTicksInnerLength {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTicksInnerVisible

Steema.TeeChart.Themes.ThemeProperties.AxisTicksInnerVisible プロパティ

public virtual Boolean AxisTicksInnerVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTicksLength

Steema.TeeChart.Themes.ThemeProperties.AxisTicksLength プロパティ

public virtual Int32 AxisTicksLength {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTitleFontColor

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontColor プロパティ

public virtual String AxisTitleFontColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


AxisTitleFontName

Steema.TeeChart.Themes.ThemeProperties.AxisTitleFontName プロパティ

public virtual String AxisTitleFontName {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Base64

Steema.TeeChart.Themes.ThemeProperties.Base64 プロパティ

public virtual String Base64 {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderColor

Steema.TeeChart.Themes.ThemeProperties.HeaderColor プロパティ

public virtual String HeaderColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderFontBold

Steema.TeeChart.Themes.ThemeProperties.HeaderFontBold プロパティ

public virtual Boolean HeaderFontBold {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderFontColor

Steema.TeeChart.Themes.ThemeProperties.HeaderFontColor プロパティ

public virtual String HeaderFontColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderFontName

Steema.TeeChart.Themes.ThemeProperties.HeaderFontName プロパティ

public virtual String HeaderFontName {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderFontSize

Steema.TeeChart.Themes.ThemeProperties.HeaderFontSize プロパティ

public virtual Int32 HeaderFontSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientDirection

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientDirection プロパティ

public virtual String HeaderGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientEndColor プロパティ

public virtual String HeaderGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientMiddleColor プロパティ

public virtual String HeaderGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientSigma

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigma プロパティ

public virtual Boolean HeaderGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigmaFocus プロパティ

public virtual Single HeaderGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientSigmaScale プロパティ

public virtual Single HeaderGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientStartColor プロパティ

public virtual String HeaderGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderGradientVisible

Steema.TeeChart.Themes.ThemeProperties.HeaderGradientVisible プロパティ

public virtual Boolean HeaderGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderPenColor

Steema.TeeChart.Themes.ThemeProperties.HeaderPenColor プロパティ

public virtual String HeaderPenColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderPenVisible

Steema.TeeChart.Themes.ThemeProperties.HeaderPenVisible プロパティ

public virtual Boolean HeaderPenVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderPenWidth

Steema.TeeChart.Themes.ThemeProperties.HeaderPenWidth プロパティ

public virtual Int32 HeaderPenWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderShadowSize

Steema.TeeChart.Themes.ThemeProperties.HeaderShadowSize プロパティ

public virtual Int32 HeaderShadowSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderShadowTransparency

Steema.TeeChart.Themes.ThemeProperties.HeaderShadowTransparency プロパティ

public virtual Int32 HeaderShadowTransparency {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


HeaderTransparency

Steema.TeeChart.Themes.ThemeProperties.HeaderTransparency プロパティ

public virtual Int32 HeaderTransparency {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Instance

Steema.TeeChart.Themes.ThemeProperties.Instance プロパティ

public static ThemeProperties Instance {get;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendDividingLinesColor

Steema.TeeChart.Themes.ThemeProperties.LegendDividingLinesColor プロパティ

public virtual String LegendDividingLinesColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendDividingLinesVisible

Steema.TeeChart.Themes.ThemeProperties.LegendDividingLinesVisible プロパティ

public virtual Boolean LegendDividingLinesVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendFontColor

Steema.TeeChart.Themes.ThemeProperties.LegendFontColor プロパティ

public virtual String LegendFontColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendFontName

Steema.TeeChart.Themes.ThemeProperties.LegendFontName プロパティ

public virtual String LegendFontName {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendFontSize

Steema.TeeChart.Themes.ThemeProperties.LegendFontSize プロパティ

public virtual Int32 LegendFontSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientDirection

Steema.TeeChart.Themes.ThemeProperties.LegendGradientDirection プロパティ

public virtual String LegendGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientEndColor プロパティ

public virtual String LegendGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientMiddleColor プロパティ

public virtual String LegendGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientSigma

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigma プロパティ

public virtual Boolean LegendGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigmaFocus プロパティ

public virtual Single LegendGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.LegendGradientSigmaScale プロパティ

public virtual Single LegendGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.LegendGradientStartColor プロパティ

public virtual String LegendGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendGradientVisible

Steema.TeeChart.Themes.ThemeProperties.LegendGradientVisible プロパティ

public virtual Boolean LegendGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendPenColor

Steema.TeeChart.Themes.ThemeProperties.LegendPenColor プロパティ

public virtual String LegendPenColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendPenStyle

Steema.TeeChart.Themes.ThemeProperties.LegendPenStyle プロパティ

public virtual String LegendPenStyle {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendPenVisible

Steema.TeeChart.Themes.ThemeProperties.LegendPenVisible プロパティ

public virtual Boolean LegendPenVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendPenWidth

Steema.TeeChart.Themes.ThemeProperties.LegendPenWidth プロパティ

public virtual Int32 LegendPenWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendShadowColor

Steema.TeeChart.Themes.ThemeProperties.LegendShadowColor プロパティ

public virtual String LegendShadowColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendShadowHeight

Steema.TeeChart.Themes.ThemeProperties.LegendShadowHeight プロパティ

public virtual Int32 LegendShadowHeight {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendShadowTransparency

Steema.TeeChart.Themes.ThemeProperties.LegendShadowTransparency プロパティ

public virtual Int32 LegendShadowTransparency {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendShadowWidth

Steema.TeeChart.Themes.ThemeProperties.LegendShadowWidth プロパティ

public virtual Int32 LegendShadowWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendSymbolDefaultPen

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolDefaultPen プロパティ

public virtual Boolean LegendSymbolDefaultPen {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendSymbolPenVisible

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolPenVisible プロパティ

public virtual Boolean LegendSymbolPenVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendSymbolSquared

Steema.TeeChart.Themes.ThemeProperties.LegendSymbolSquared プロパティ

public virtual Boolean LegendSymbolSquared {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


LegendTransparent

Steema.TeeChart.Themes.ThemeProperties.LegendTransparent プロパティ

public virtual Boolean LegendTransparent {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Palette

Steema.TeeChart.Themes.ThemeProperties.Palette プロパティ

public virtual String[] Palette {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelBevelInner

Steema.TeeChart.Themes.ThemeProperties.PanelBevelInner プロパティ

public virtual String PanelBevelInner {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelBevelOuter

Steema.TeeChart.Themes.ThemeProperties.PanelBevelOuter プロパティ

public virtual String PanelBevelOuter {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelBevelWidth

Steema.TeeChart.Themes.ThemeProperties.PanelBevelWidth プロパティ

public virtual Int32 PanelBevelWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelBorderRound

Steema.TeeChart.Themes.ThemeProperties.PanelBorderRound プロパティ

public virtual Int32 PanelBorderRound {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelColor

Steema.TeeChart.Themes.ThemeProperties.PanelColor プロパティ

public virtual String PanelColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientDirection

Steema.TeeChart.Themes.ThemeProperties.PanelGradientDirection プロパティ

public virtual String PanelGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientEndColor プロパティ

public virtual String PanelGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientMiddleColor プロパティ

public virtual String PanelGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientSigma

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigma プロパティ

public virtual Boolean PanelGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigmaFocus プロパティ

public virtual Single PanelGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.PanelGradientSigmaScale プロパティ

public virtual Single PanelGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.PanelGradientStartColor プロパティ

public virtual String PanelGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelGradientVisible

Steema.TeeChart.Themes.ThemeProperties.PanelGradientVisible プロパティ

public virtual Boolean PanelGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelPenColor

Steema.TeeChart.Themes.ThemeProperties.PanelPenColor プロパティ

public virtual String PanelPenColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelPenStyle

Steema.TeeChart.Themes.ThemeProperties.PanelPenStyle プロパティ

public virtual String PanelPenStyle {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelPenVisible

Steema.TeeChart.Themes.ThemeProperties.PanelPenVisible プロパティ

public virtual Boolean PanelPenVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelPenWidth

Steema.TeeChart.Themes.ThemeProperties.PanelPenWidth プロパティ

public virtual Int32 PanelPenWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelShadowColor

Steema.TeeChart.Themes.ThemeProperties.PanelShadowColor プロパティ

public virtual String PanelShadowColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelShadowSize

Steema.TeeChart.Themes.ThemeProperties.PanelShadowSize プロパティ

public virtual Int32 PanelShadowSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


PanelShadowVisible

Steema.TeeChart.Themes.ThemeProperties.PanelShadowVisible プロパティ

public virtual Boolean PanelShadowVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksArrowColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksArrowColor プロパティ

public virtual String SeriesMarksArrowColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksFontColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontColor プロパティ

public virtual String SeriesMarksFontColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksFontName

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontName プロパティ

public virtual String SeriesMarksFontName {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksFontSize

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksFontSize プロパティ

public virtual Int32 SeriesMarksFontSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientDirection

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientDirection プロパティ

public virtual String SeriesMarksGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientEndColor プロパティ

public virtual String SeriesMarksGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientMiddleColor プロパティ

public virtual String SeriesMarksGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientSigma

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigma プロパティ

public virtual Boolean SeriesMarksGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigmaFocus プロパティ

public virtual Single SeriesMarksGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientSigmaScale プロパティ

public virtual Single SeriesMarksGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientStartColor プロパティ

public virtual String SeriesMarksGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksGradientVisible

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksGradientVisible プロパティ

public virtual Boolean SeriesMarksGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


SeriesMarksTransparent

Steema.TeeChart.Themes.ThemeProperties.SeriesMarksTransparent プロパティ

public virtual Boolean SeriesMarksTransparent {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallApplyDark

Steema.TeeChart.Themes.ThemeProperties.WallApplyDark プロパティ

public virtual Boolean WallApplyDark {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientDirection

Steema.TeeChart.Themes.ThemeProperties.WallGradientDirection プロパティ

public virtual String WallGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientEndColor プロパティ

public virtual String WallGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientMiddleColor プロパティ

public virtual String WallGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientSigma

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigma プロパティ

public virtual Boolean WallGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigmaFocus プロパティ

public virtual Single WallGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.WallGradientSigmaScale プロパティ

public virtual Single WallGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.WallGradientStartColor プロパティ

public virtual String WallGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallGradientVisible

Steema.TeeChart.Themes.ThemeProperties.WallGradientVisible プロパティ

public virtual Boolean WallGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallPenColor

Steema.TeeChart.Themes.ThemeProperties.WallPenColor プロパティ

public virtual String WallPenColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallPenStyle

Steema.TeeChart.Themes.ThemeProperties.WallPenStyle プロパティ

public virtual String WallPenStyle {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallPenVisible

Steema.TeeChart.Themes.ThemeProperties.WallPenVisible プロパティ

public virtual Boolean WallPenVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallPenWidth

Steema.TeeChart.Themes.ThemeProperties.WallPenWidth プロパティ

public virtual Int32 WallPenWidth {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackColor プロパティ

public virtual String WallsBackColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientDirection

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientDirection プロパティ

public virtual String WallsBackGradientDirection {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientEndColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientEndColor プロパティ

public virtual String WallsBackGradientEndColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientMiddleColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientMiddleColor プロパティ

public virtual String WallsBackGradientMiddleColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientSigma

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigma プロパティ

public virtual Boolean WallsBackGradientSigma {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientSigmaFocus

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigmaFocus プロパティ

public virtual Single WallsBackGradientSigmaFocus {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientSigmaScale

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientSigmaScale プロパティ

public virtual Single WallsBackGradientSigmaScale {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientStartColor

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientStartColor プロパティ

public virtual String WallsBackGradientStartColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackGradientVisible

Steema.TeeChart.Themes.ThemeProperties.WallsBackGradientVisible プロパティ

public virtual Boolean WallsBackGradientVisible {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBackTransparent

Steema.TeeChart.Themes.ThemeProperties.WallsBackTransparent プロパティ

public virtual Boolean WallsBackTransparent {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsBottomColor

Steema.TeeChart.Themes.ThemeProperties.WallsBottomColor プロパティ

public virtual String WallsBottomColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallSize

Steema.TeeChart.Themes.ThemeProperties.WallSize プロパティ

public virtual Int32 WallSize {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsLeftColor

Steema.TeeChart.Themes.ThemeProperties.WallsLeftColor プロパティ

public virtual String WallsLeftColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


WallsRightColor

Steema.TeeChart.Themes.ThemeProperties.WallsRightColor プロパティ

public virtual String WallsRightColor {get; set;}

参照

ThemeProperties クラス | ThemeProperties メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemesList

Steema.TeeChart.Themes.ThemesList クラス

この型のすべてのメンバの一覧については、ThemesList メンバを参照してください。

System.Object
System.Collections.ArrayList
[Serializable]
public sealed class ThemesList : ArrayList , IList
, ICollection, IEnumerable, ICloneable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ：TeeChart.dll

参照

ThemesList メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemesList 全メンバ

ThemesList 概要

コンストラクタ

Constructor

パブリック プロパティ

Item

参照

ThemesList クラス | Steema.TeeChart.Themes 名前空間


ThemesList コンストラクタ

Steema.TeeChart.Themes.ThemesList コンストラクタ

public ThemesList()

参照

ThemesList クラス | ThemesList メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.ThemesList プロパティ

パブリック プロパティ

Item

参照

ThemesList クラス | Steema.TeeChart.Themes 名前空間


Item

Steema.TeeChart.Themes.ThemesList.Item プロパティ

public Type Item(Int32 index) {get;}

参照

ThemesList クラス | ThemesList メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.WebTheme

Steema.TeeChart.Themes.WebTheme クラス

Webテーマの概要。

この型のすべてのメンバの一覧については、WebTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
public class WebTheme : TeeChartTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

WebTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.WebTheme 全メンバ

WebTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

WebTheme クラス | Steema.TeeChart.Themes 名前空間


WebTheme コンストラクタ

Steema.TeeChart.Themes.WebTheme コンストラクタ

public WebTheme(Chart c)

参照

WebTheme クラス | WebTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.WebTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

WebTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.WebTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

WebTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.WebTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

WebTheme クラス | WebTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.WebTheme.ToString メソッド

public override String ToString()

参照

WebTheme クラス | WebTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.WebTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

WebTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.XPTheme

Steema.TeeChart.Themes.XPTheme クラス

Windows XPテーマの概要。

この型のすべてのメンバの一覧については、XPTheme メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Themes.Theme
Steema.TeeChart.Themes.CustomTheme
Steema.TeeChart.Themes.TeeChartTheme
Steema.TeeChart.Themes.BusinessTheme
public class XPTheme : BusinessTheme , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Themes 名前空間

アセンブリ: TeeChart.dll

参照

XPTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.XPTheme 全メンバ

XPTheme 概要

コンストラクタ

Constructor

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

プロテクト フィールド

InternalUse (TeeBaseの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

XPTheme クラス | Steema.TeeChart.Themes 名前空間


XPTheme コンストラクタ

Steema.TeeChart.Themes.XPTheme コンストラクタ

public XPTheme(Chart c)

参照

XPTheme クラス | XPTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.XPTheme フィールド

プロテクト フィールド

InternalUse (TeeBaseの継承元)

参照

XPTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.XPTheme メソッド

パブリック メソッド

Apply (CustomThemeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString |
WriteToXML (Themeの継承元) |

プロテクト メソッド

ChangeAllSeries (CustomThemeの継承元)
ChangeAspect (CustomThemeの継承元)
ChangeAxes (CustomThemeの継承元)
ChangeAxis (CustomThemeの継承元)
ChangeHeader (CustomThemeの継承元)
ChangeLegend (CustomThemeの継承元)
ChangePanel (CustomThemeの継承元)
ChangeSeries (CustomThemeの継承元)
ChangeWall (CustomThemeの継承元)
ChangeWalls (CustomThemeの継承元)
ResetHeaderGradient (CustomThemeの継承元)
ResetLegendGradient (CustomThemeの継承元)
ResetPanelGradient (CustomThemeの継承元)
ResetSeriesMarksGradient (CustomThemeの継承元)
ResetWallGradient (CustomThemeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (TeeBaseの継承元)
SetColorProperty (TeeBaseの継承元)
SetDefaultValues
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

XPTheme クラス | Steema.TeeChart.Themes 名前空間


SetDefaultValues

Steema.TeeChart.Themes.XPTheme.SetDefaultValues メソッド

protected internal abstract Void SetDefaultValues()

参照

XPTheme クラス | XPTheme メンバ | Steema.TeeChart.Themes 名前空間


ToString

Steema.TeeChart.Themes.XPTheme.ToString メソッド

public override String ToString()

参照

XPTheme クラス | XPTheme メンバ | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Themes.XPTheme プロパティ

パブリック プロパティ

Chart (TeeBaseの継承元) オブジェクトに関連付けるチャートを設定します。

参照

XPTheme クラス | Steema.TeeChart.Themes 名前空間


Steema.TeeChart.Tools

Steema.TeeChart.Tools 名前空間

名前空間の階層構造

パブリック クラス

ToolsCollection | ツールコンポーネントのコレクション。
MarkersCollection | マーカツールコンポーネントのコレクションです。
Tool | 基本ツールクラス。
Annotation | アノテーションツール。
Marker | マーカツール。
AnnotationCallout |
ToolAxis | Axisプロパティを持つツールコンポーネントの基本的な抽象クラス。
AxisArrow | 軸矢印ツール。
AxisScroll | 軸スクロールツール。
BannerTool |
ToolSeries | Seriesプロパティを持つツールコンポーネントの基本的な抽象クラス。
ChartImage | イメージツール。範囲として指定した系列の軸を使用してイメージを表示します。軸がズームあるいはスクロールされた場合、イメージもズームあるいはスクロールします。
ClipSeries | クリップツール。クリップ領域は系列の垂直軸と水平軸で制限されます。
ColorBand | 指定した軸と位置に色付けされた矩形（バンド）を表示するためにカラーバンドツールを使用してください。
ColorLine | カラーラインツール。軸値にカスタム線を描くためのツールです。
CursorTool | カーソルツール。
CursorChangeEventArgs | カーソルツールのChangeイベントのEventArgs。
CursorGetAxisRectEventArgs | カーソルツールのGetAxisRectイベントのEventArgs。
TableLegend | 凡例シェープ。
DataTableTool |
DragMarkEventArgs |
DragMarks | ドラッグマーカツール。
DragPoint | ドラッグポイントツール。
DrawLine | ドローラインツール。
DrawLines | DrawLineItemのコレクション。
DrawLineItem | ドローラインツールの線。
ExtraLegend | 拡張凡例ツール。
FaderTool | フェーダツールクラス。
FibonacciTool | フィボナッチの扇形や弧の金融ツール。フィボナッチの扇形や弧をサポートするツールです。フィボナッチの弧は3つの曲線（これは主要な買い支えと抵抗レベルを予想するために描画されます）と境界範囲からなるチャート・テクニックです。フィボナッチの弧はまず2つのポイント（通常、指定した期間の高値と安値）間に非表示のトレンドラインを描画し、次に38.2%、50%、61.8%の主要なフィボナッチレベルでこのトレンドラインと交差する3つの曲線を描画して作成されます。フィボナッチの扇形はまず2つのポイント（通常、指定した期間の高値と安値）を通過するトレンドラインを描画し、次にその2つのポイント間の縦方向の距離を主要なフィボナッチの割合（38.2%、50%、61.8%）で除算して作成されます。これらの除算結果はそれぞれ縦方向の距離内で1ポイントを表します。次に左端のポイントから3つのそれぞれのフィボナッチの割合（38.2%、50%、61.8%）まで線を描画してその3つの「扇形」の線が作成されます。
FibonacciItem | 個々のフィボナッチレベルの特性です。
FibonacciLevels | すべての弧のコレクション。
GanttTool | ガントドラッグツール。
GanttDragEventArgs | GanttDragEventHandlerのEventArgs。
GanttResizeEventArgs | GanttResizeEventHandlerのEventArgs。
GridBand | グリッドバンドツール。指定した軸や位置のグリッド線に色付けされた矩形（バンド）を表示するために使用します。
GridTranspose | 3Dグリッド置換ツール。
SeriesHotspotEventArgs | ホットスポットイベントの引数。
SeriesHotspot | ホットスポットの概要。
LegendPalette |
LightTool | このツールは、チャートコントロール上部で2次元のライトスポットを表示するために使用してください。
RectangleTool | 矩形ツール。
Magnify | 虫眼鏡ツール。
MarksTip | マーカチップツール。系列ポイント上にマウスが移動あるいはクリックした際に「チップ」あるいは「ヒント」を表示するためにマーカチップツールを使用します。
MarksTipGetTextEventArgs |
NearestPoint | マウスカーソルに近い系列ポイントにマークを表示するために近傍点ツールを使用します。
PageNumber | ページ数ツール。
PieTool | 円スライスツール。
Rotate | 回転ツール。
ScrollBarSetPositionEventArgs | スクロールバーツールのOnScrolledイベントのEventArgs。
ScrollBar | スクロールバーツール。
LegendScrollBar | 凡例スクロールバーツール。
ZoomAttributes |
ScrollAttributes |
ZoomTool | Webフォームでチャートイメージをズームします。これは、Webチャートコンポーネントのみサポートします。
ScrollTool | アクティブなスクロール可能なWebチャートを作成するためのツール。
Selector | このツールは、系列、軸、凡例、タイトル、などのようなチャートエレメントをクリックしてドラッグすることができます。そして、ユーザーがチャートエレメントをクリックして選択するか、ドラッグして新しい位置に配置するか、チャートをリサイズするとイベントが発生します。
SeriesAnimation | 系列アニメーションツール。
AnimationStepEventArgs | AnimationStepEventHandlerのEventArgs。
SeriesBandTool | 系列バンドツール。2つの（リボン）系列の間にバンドを描画するために使用してください。これは、mkaul@leuze.deにより2003-12-14に作成されました。
SeriesRegionTool | 系列領域ツール。これは、（系列ポイントの）カーブで囲まれている領域に色をつけます。
SeriesStats | 基本的な系列統計を計算します。
SeriesTranspose | 複数の系列を置換します（行と列を交換）。
SubChartTool | サブチャートツール。
SubChart |
ChartCollection | Chartコンポーネントのコレクション。
SurfaceNearestTool | サーフェス系列上にマウスを移動した際に、マウスカーソルに最も近いサーフェスセルを示します。
BeforeDrawAxesEventArgs | 内部使用。BeforeDrawAxesイベントのEventArgs。
BeforeDrawSeriesEventArgs | 内部使用。BeforeDrawSeriesイベントのEventArgs。
AfterDrawSeriesEventsArgs | 内部使用。AfterDrawSeriesイベントのEventArgs。
BeforeDrawEventArgs | 内部使用。BeforeDrawイベントのEventArgs。
AfterDrawEventArgs | 内部使用。AfterDrawイベントのEventArgs。

パブリック 列挙体

AnnotationPositions | Positionプロパティの使用可能な値です。
AxisArrowPosition | Positionプロパティの使用可能な値です。
ScrollingDirection | バナーテキストのスクロール方向を設定します。
CursorToolStyles | Styleプロパティの使用可能な値です。
SnapStyle | SnapプロパティがTrueの場合、SnapStyleプロパティはマウスを近づけた時に既存の系列ポイントに「ジャンプ」するかどうかを定義します。
ScopeCursorStyle | カーソルのXY位置の周りを描くためのシェープを定義します。StyleプロパティがScopeの場合のみ。
CursorClicked | Clickedメソッドの戻り値です。
DragPointStyles | Styleプロパティの使用可能な値です。
DrawLineStyle | Styleプロパティの使用可能な値です。
DrawLineHandle | DrawLine用のラインハンドルの配置。
FaderStyle |
FibonacciStyle | Levelsのスタイルを定義します。
GanttBarPart | 内部使用。ガントツールの位置をサポートします。
HotspotHelperScripts | ASP.NETチャートのクライアント側の機能を提供するTeeChartのヘルパースクリプトです。
LegendPaletteAxis |
LightStyle | 照明のスタイルを取得/設定します。
MarksTipMouseAction | MouseActionプロパティの使用可能な値です。
NearestPointStyles | Styleプロパティの使用可能な値です。
PieToolStyle | Styleプロパティの使用可能な値です。
RotateStyles | Styleプロパティの使用可能な値です。
ScrollBarDrawStyle |
ScrollToolViewUnit |
ScrollMouseAction |

パブリック デリゲート

ColorLineToolOnDragEventHandler | カラーラインツールのDragLineイベントハンドラ。
CursorChangeEventHandler | カーソルツールのChangeイベントハンドラ。
CursorGetAxisRectEventHandler | カーソルツールのGetAxisRectイベントハンドラ。
DragMarkDraggedEventHandler |
DragMarkDraggingEventHandler |
DragPointEventHandler | ドラッグポイントツールのイベントハンドラ。
DrawLineEventHandler | ドローラインツールのイベントハンドラ。
DrawLineSelectingEventHandler | ドローラインツールのSelectingイベントハンドラ。
GanttDragEventHandler | ガントバーがドラッグされた時に呼び出されるガントドラッグツールのイベントハンドラ。
GanttResizeEventHandler | ガントバーがリサイズされた時に呼び出されるガントドラッグツールのイベントハンドラ。
SeriesHotspotEventHandler | ホットスポットツールのGetHTMLMapイベントハンドラ。
MarksTipGetTextEventHandler | マーカチップツールのGetTextイベントハンドラ。
RectangleToolDraggingEventHandler |
RectangleToolResizingEventHandler |
RectangleToolResizedEventHandler |
RectangleToolDraggedEventHandler |
RotatingEventHandler |
ScrollBarScrolledHandler | スクロールバーツールのOnScrolledイベントハンドラ。
ScrollBarChangedSizeHandler | スクロールバーツールのOnChangedSizeイベントハンドラ。
ScrollBarSetPositionHandler | スクロールバーツールのOnSetPositionイベントハンドラ。
SelectorDraggedEventHandler |
SelectorDraggingEventHandler |
SelectorResizedEventHandler |
SelectorResizingEventHandler |
SelectorSelectedEventHandler |
AnimationStepEventHandler | 系列アニメーションツールのイベントハンドラ。
SelectEventHandler |

パブリック インターフェイス

IHotspot 内部使用。ホットスポットツールの識別インターフェイスです。

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll


Steema.TeeChart.Tools 階層構造

System.Object

Steema.TeeChart.Tools.DragMarkEventArgs

Steema.TeeChart.Tools.DrawLineItem

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem

Steema.TeeChart.Tools.SubChart

Steema.TeeChart.Tools.ZoomAttributes

Steema.TeeChart.Tools.ScrollAttributes

System.Collections.CollectionBase

Steema.TeeChart.Tools.ChartCollection

Steema.TeeChart.Tools.DrawLines

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels

Steema.TeeChart.Tools.ToolsCollection

Steema.TeeChart.Tools.MarkersCollection

System.EventArgs

Steema.TeeChart.Tools.AfterDrawEventArgs

Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs

Steema.TeeChart.Tools.AnimationStepEventArgs

Steema.TeeChart.Tools.BeforeDrawAxesEventArgs

Steema.TeeChart.Tools.BeforeDrawEventArgs

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs

Steema.TeeChart.Tools.CursorChangeEventArgs

Steema.TeeChart.Tools.CursorGetAxisRectEventArgs

Steema.TeeChart.Tools.GanttDragEventArgs

Steema.TeeChart.Tools.GanttResizeEventArgs

Steema.TeeChart.Tools.MarksTipGetTextEventArgs

Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs

Steema.TeeChart.Tools.SeriesHotspotEventArgs

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Shape

Steema.TeeChart.Tools.TableLegend

Steema.TeeChart.Styles.SeriesPointer

Steema.TeeChart.Styles.Callout

Steema.TeeChart.Tools.AnnotationCallout

Steema.TeeChart.Tools.Tool

Steema.TeeChart.Tools.Annotation

Steema.TeeChart.Tools.BannerTool

Steema.TeeChart.Tools.Marker

Steema.TeeChart.Tools.PageNumber

Steema.TeeChart.Tools.RectangleTool

Steema.TeeChart.Tools.Magnify

Steema.TeeChart.Tools.DataTableTool

Steema.TeeChart.Tools.FaderTool

Steema.TeeChart.Tools.GridTranspose

Steema.TeeChart.Tools.LightTool

Steema.TeeChart.Tools.Rotate

Steema.TeeChart.Tools.ScrollBar

Steema.TeeChart.Tools.LegendScrollBar

Steema.TeeChart.Tools.Selector

Steema.TeeChart.Tools.SeriesTranspose

Steema.TeeChart.Tools.SubChartTool

Steema.TeeChart.Tools.ToolAxis

Steema.TeeChart.Tools.AxisArrow

Steema.TeeChart.Tools.AxisScroll

Steema.TeeChart.Tools.ColorBand

Steema.TeeChart.Tools.ColorLine

Steema.TeeChart.Tools.GridBand

Steema.TeeChart.Tools.ToolSeries

Steema.TeeChart.Tools.ChartImage

Steema.TeeChart.Tools.ClipSeries

Steema.TeeChart.Tools.CursorTool

Steema.TeeChart.Tools.DragMarks

Steema.TeeChart.Tools.DragPoint

Steema.TeeChart.Tools.DrawLine

Steema.TeeChart.Tools.ExtraLegend

Steema.TeeChart.Tools.FibonacciTool

Steema.TeeChart.Tools.GanttTool

Steema.TeeChart.Tools.LegendPalette

Steema.TeeChart.Tools.MarksTip

Steema.TeeChart.Tools.NearestPoint

Steema.TeeChart.Tools.PieTool

Steema.TeeChart.Tools.SeriesAnimation

Steema.TeeChart.Tools.SeriesHotspot

Steema.TeeChart.Tools.SeriesRegionTool

Steema.TeeChart.Tools.SeriesStats

Steema.TeeChart.Tools.SurfaceNearestTool

Steema.TeeChart.Tools.ZoomTool

Steema.TeeChart.Tools.ScrollTool

参照

SteemaTeeChartTools 名前空間


Steema.TeeChart.Tools.AfterDrawEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AfterDrawEventArgs クラス

内部使用。AfterDrawイベントのEventArgs。

この型のすべてのメンバの一覧については、AfterDrawEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class AfterDrawEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

AfterDrawEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AfterDrawEventArgs 全メンバ

AfterDrawEventArgs 概要

コンストラクタ

Constructor

参照

AfterDrawEventArgs クラス | Steema.TeeChart.Tools 名前空間


AfterDrawEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AfterDrawEventArgs コンストラクタ

public AfterDrawEventArgs()

参照

AfterDrawEventArgs クラス | AfterDrawEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs

Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs クラス

内部使用。ツールサポートのEventArgs。

この型のすべてのメンバの一覧については、AfterDrawSeriesEventsArgs メンバを参照してください。

System.Object
System.EventArgs
public class AfterDrawSeriesEventsArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

AfterDrawSeriesEventsArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs 全メンバ

AfterDrawSeriesEventsArgs 概要

コンストラクタ

Constructor

参照

AfterDrawSeriesEventsArgs クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AfterDrawSeriesEventsArgs コンストラクタ

public AfterDrawSeriesEventsArgs()

参照

AfterDrawSeriesEventsArgs クラス | AfterDrawSeriesEventsArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnimationStepEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AnimationStepEventArgs クラス

AnimationStepEventHandlerのEventArgs。

この型のすべてのメンバの一覧については、AnimationStepEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class AnimationStepEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

AnimationStepEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnimationStepEventArgs 全メンバ

AnimationStepEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Step

参照

AnimationStepEventArgs クラス | Steema.TeeChart.Tools 名前空間


AnimationStepEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AnimationStepEventArgs コンストラクタ

public AnimationStepEventArgs(Int32 stepNum)

参照

AnimationStepEventArgs クラス | AnimationStepEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnimationStepEventArgs プロパティ

パブリック プロパティ

Step

参照

AnimationStepEventArgs クラス | Steema.TeeChart.Tools 名前空間


Step

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AnimationStepEventArgs.Step プロパティ

public Int32 Step {get;}

解説

デフォルト値：100

アニメーションステップの数を設定します。

ステップ数が大きい場合、アニメーションは遅くなります。

参照

AnimationStepEventArgs クラス | AnimationStepEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnimationStepEventHandler

Steema.TeeChart.Tools.AnimationStepEventHandler デリゲート

系列アニメーションツールのイベントハンドラ。
public delegate AnimationStepEventHandler (Object sender,
     AnimationStepEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation

Steema.TeeChart.Tools.Annotation クラス

アノテーションツール。

この型のすべてのメンバの一覧については、Annotation メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class Annotation : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation 全メンバ

Annotation 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click
KeyDown

パブリック メソッド

Clone (Toolの継承元) |
EditorKey | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit | ツールのテキストの編集を可能にします。
AutoSize | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds | アノテーションツールの矩形領域を取得/設定します。
Callout |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText |
Cursor |
Description | 説明のテキストを取得します。
Height | カスタムな高さを設定します。
Left | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary | 詳細な説明テキストを取得します。
Text | アノテーションツールのテキストを定義します。
TextAlign |
Top | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX
tmpY

プロテクト メソッド

Assign
CalcTempPosition
CalcTempWidth
CalcTextXY
ChartEvent
Clicked
Dispose (Toolの継承元)
DoDoubleClick
DrawString
DrawText
GetInnerText
KeyEvent
MouseEvent
OnClick
OnDisposing (Toolの継承元)
OnDoubleClick
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight
ShouldSerializeWidth

参照

Annotation クラス | Steema.TeeChart.Tools 名前空間


Annotation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation コンストラクタ

オーバーロードの一覧

public Annotation()
public Annotation(Steema.TeeChart.Chart)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Annotation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation コンストラクタ

public Annotation()

参照

Annotation コンストラクタのオーバーロードの一覧 | Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Annotation コンストラクタ

Steema.TeeChart.Tools.Annotation コンストラクタ

public Annotation(Chart c)

参照

Annotation コンストラクタのオーバーロードの一覧 | Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation イベント

パブリック イベント

Click
KeyDown

参照

Annotation クラス | Steema.TeeChart.Tools 名前空間


Click

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.Click イベント

public MouseEventHandler  Click

解説

アノテーション上をクリックすると、このイベントが発生します。

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


KeyDown

Steema.TeeChart.Tools.Annotation.KeyDown イベント

public KeyEventHandler  KeyDown

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX
tmpY

参照

Annotation クラス | Steema.TeeChart.Tools 名前空間


isEditing

Steema.TeeChart.Tools.Annotation.isEditing フィールド

protected Boolean isEditing

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


tmpX

Steema.TeeChart.Tools.Annotation.tmpX フィールド

protected Int32 tmpX

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


tmpY

Steema.TeeChart.Tools.Annotation.tmpY フィールド

protected Int32 tmpY

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
CalcTempPosition
CalcTempWidth
CalcTextXY
ChartEvent
Clicked
Dispose (Toolの継承元)
DoDoubleClick
DrawString
DrawText
GetInnerText
KeyEvent
MouseEvent
OnClick
OnDisposing (Toolの継承元)
OnDoubleClick
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight
ShouldSerializeWidth

参照

Annotation クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.Annotation.Assign メソッド

protected abstract Void Assign(Tool t)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


CalcTempPosition

Steema.TeeChart.Tools.Annotation.CalcTempPosition メソッド

protected abstract Void CalcTempPosition(Int32& x,
     Int32& y,
     Int32 tmpW,
     Int32 tmpH,
     Int32 horizMargin,
     Int32 vertMargin)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


CalcTempWidth

Steema.TeeChart.Tools.Annotation.CalcTempWidth メソッド

protected abstract Int32 CalcTempWidth(String tmp,
     Int32& NumLines)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


CalcTextXY

Steema.TeeChart.Tools.Annotation.CalcTextXY メソッド

protected abstract Void CalcTextXY(Int32& x,
     Int32& y)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Clicked

Steema.TeeChart.Tools.Annotation.Clicked メソッド

protected internal Boolean Clicked(Int32 x,
     Int32 y)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


DoDoubleClick

Steema.TeeChart.Tools.Annotation.DoDoubleClick メソッド

protected abstract Void DoDoubleClick(MouseEventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


DrawString

Steema.TeeChart.Tools.Annotation.DrawString メソッド

protected abstract Void DrawString(Graphics3D g,
     Int32 x,
     Int32 y,
     Int32 t,
     Int32 tmpHeight,
     String[] s)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


DrawText

Steema.TeeChart.Tools.Annotation.DrawText メソッド

protected internal Void DrawText()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


EditorKey

Steema.TeeChart.Tools.Annotation.EditorKey メソッド

メソッドはデフォルトによりKeyDownイベントに渡されます。
public Void EditorKey(Object sender,
     KeyEventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


EndEdit

Steema.TeeChart.Tools.Annotation.EndEdit メソッド

アノテーションのテキストを編集可能状態を中止します。
public Void EndEdit()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


GetInnerText

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.GetInnerText メソッド

protected virtual String GetInnerText()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


KeyEvent

Steema.TeeChart.Tools.Annotation.KeyEvent メソッド

protected internal abstract Void KeyEvent(KeyEventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.Annotation.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


OnClick

Steema.TeeChart.Tools.Annotation.OnClick メソッド

protected abstract Void OnClick(MouseEventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


OnDoubleClick

Steema.TeeChart.Tools.Annotation.OnDoubleClick メソッド

protected abstract Void OnDoubleClick(MouseEventArgs e)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.Annotation.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


ShouldSerializeHeight

Steema.TeeChart.Tools.Annotation.ShouldSerializeHeight メソッド

protected Boolean ShouldSerializeHeight()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


ShouldSerializeWidth

Steema.TeeChart.Tools.Annotation.ShouldSerializeWidth メソッド

protected Boolean ShouldSerializeWidth()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


StartEdit

Steema.TeeChart.Tools.Annotation.StartEdit メソッド

アノテーションのテキストを編集可能状態にします。
public Void StartEdit()

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Annotation プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit | ツールのテキストの編集を可能にします。
AutoSize | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds | アノテーションツールの矩形領域を取得/設定します。
Callout |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText |
Cursor |
Description | 説明のテキストを取得します。
Height | カスタムな高さを設定します。
Left | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary | 詳細な説明テキストを取得します。
Text | アノテーションツールのテキストを定義します。
TextAlign |
Top | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width | カスタムな幅を設定します。

参照

Annotation クラス | Steema.TeeChart.Tools 名前空間


AllowEdit

Steema.TeeChart.Tools.Annotation.AllowEdit プロパティ

ツールのテキストの編集を可能にします。
public Boolean AllowEdit {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


AutoSize

Steema.TeeChart.Tools.Annotation.AutoSize プロパティ

Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
public Boolean AutoSize {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Bounds

Steema.TeeChart.Tools.Annotation.Bounds プロパティ

アノテーションツールの矩形領域を取得/設定します。
public Rectangle Bounds {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Callout

Steema.TeeChart.Tools.Annotation.Callout プロパティ

public AnnotationCallout Callout {get;}

解説

アノテーションツールのコールアウト（引き出し線）の特性についてアクセスします。

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


ClipText

Steema.TeeChart.Tools.Annotation.ClipText プロパティ

public Boolean ClipText {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Cursor

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.Cursor プロパティ

public Cursor Cursor {get; set;}

解説

アノテーション領域にマウスが移動した際のカーソル型を設定します。

例

[C#]

annotation1.Cursor = System.Windows.Forms.Cursors.IBeam;

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Annotation.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Height

Steema.TeeChart.Tools.Annotation.Height プロパティ

カスタムな高さを設定します。
public Int32 Height {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Left

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.Left プロパティ

チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。

public Int32 Left {get; set;}

解説

チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。

例

[C#]

annotation1.Left = 150;
annotation1.Top = 30;
annotation1.Text = "My Text";

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Position

Steema.TeeChart.Tools.Annotation.Position プロパティ

アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
public AnnotationPositions Position {get; set;}

解説

アノテーションのシェープやテキストを表示する位置を設定します。
これは、シェープがカスタムな位置ではない（ShapeのLeftプロパティとTopプロパティを使用している）場合のみ有効です。

使用可能なオプションは以下のとおりです。

LeftBottom
LeftTop
RightBottom
RightTop

例

[C#]

annotation1.Position = Steema.TeeChart.Tools.AnnotationPositions.LeftBottom;

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


PositionUnits

Steema.TeeChart.Tools.Annotation.PositionUnits プロパティ

アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
public PositionUnits PositionUnits {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Shape

Steema.TeeChart.Tools.Annotation.Shape プロパティ

アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
public TextShapePosition Shape {get;}

解説

アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.Annotation.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.Text プロパティ

アノテーションツールのテキストを定義します。

public String Text {get; set;}

解説

アノテーション内に表示するテキストを設定します。

例

[C#]

annotation1.Left = 150;
annotation1.Top = 30;
annotation1.Text = "My Text";

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


TextAlign

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.TextAlign プロパティ

public StringAlignment TextAlign {get; set;}

解説

デフォルト値：Near

アノテーション矩形内に表示されるテキストの水平方向の位置を設定します。

使用可能な値：Center、Far、Near

例

[C#]

annotation1.TextAlign = System.Drawing.StringAlignment.Center;

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Top

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Annotation.Top プロパティ

チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。

public Int32 Top {get; set;}

解説

チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。

例

[C#]

annotation1.Left = 150;
annotation1.Top = 30;
annotation1.Text = "My Text";

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Width

Steema.TeeChart.Tools.Annotation.Width プロパティ

カスタムな幅を設定します。
public Int32 Width {get; set;}

参照

Annotation クラス | Annotation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationCallout

Steema.TeeChart.Tools.AnnotationCallout クラス

この型のすべてのメンバの一覧については、AnnotationCallout メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.SeriesPointer
Steema.TeeChart.Styles.Callout
public class AnnotationCallout : Callout , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

AnnotationCallout メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationCallout 全メンバ

AnnotationCallout 概要

コンストラクタ

Constructor

パブリック メソッド

Clone (SeriesPointerの継承元) |
Draw (SeriesPointerの継承元) | 内部使用。ポインタを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

パブリック プロパティ

Arrow (Calloutの継承元) |
ArrowHead (Calloutの継承元) |
ArrowHeadSize (Calloutの継承元) |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance (Calloutの継承元) |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを設定します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。
XPosition |
YPosition |
ZPosition |

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Draw (Calloutの継承元)
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Calloutの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

AnnotationCallout クラス | Steema.TeeChart.Tools 名前空間


AnnotationCallout コンストラクタ

Steema.TeeChart.Tools.AnnotationCallout コンストラクタ

public AnnotationCallout(Series s)

参照

AnnotationCallout クラス | AnnotationCallout メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationCallout フィールド

プロテクト フィールド

AllowChangeSize (SeriesPointerの継承元)
aSeries (SeriesPointerの継承元)
bVisible (SeriesPointerの継承元)
InternalUse (TeeBaseの継承元)
PXMinus (SeriesPointerの継承元)
PXPlus (SeriesPointerの継承元)
PYMinus (SeriesPointerの継承元)
PYPlus (SeriesPointerの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

AnnotationCallout クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationCallout メソッド

パブリック メソッド

Clone (SeriesPointerの継承元) |
Draw (SeriesPointerの継承元) | 内部使用。ポインタを描きます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。

プロテクト メソッド

Draw (Calloutの継承元)
GetBounds (SeriesPointerの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Calloutの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeVisible (SeriesPointerの継承元)

参照

AnnotationCallout クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationCallout プロパティ

パブリック プロパティ

Arrow (Calloutの継承元) |
ArrowHead (Calloutの継承元) |
ArrowHeadSize (Calloutの継承元) |
Brush (SeriesPointerの継承元) | 系列ポインタを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Color (SeriesPointerの継承元) | ポインタの色を設定します。
Dark3D (SeriesPointerの継承元) | 3Dモードでポインタの側面を暗い色で塗りつぶします。
Distance (Calloutの継承元) |
Draw3D (SeriesPointerの継承元) | 3Dモードでポインタを描画します。
EndZ (SeriesPointerの継承元) |
Gradient (SeriesPointerの継承元) | ポインタ内部を塗りつぶすグラデーションを定義します。
HorizSize (SeriesPointerの継承元) | ポインタの水平サイズをピクセル単位で取得/設定します。
InflateMargins (SeriesPointerの継承元) | ポインタを完全に表示させるために軸を再スケールするかどうか設定します。
MiddleZ (SeriesPointerの継承元) |
Pen (SeriesPointerの継承元) | 系列ポインタの枠を描くためのペンを設定します。
Series (SeriesPointerの継承元) |
StartZ (SeriesPointerの継承元) |
Style (SeriesPointerの継承元) | ポインタのスタイルを設定します。
Transparency (SeriesPointerの継承元) | ポインタの透明度を0～100%で設定します。
VertSize (SeriesPointerの継承元) | ポインタの垂直サイズをピクセル単位で取得/設定します。
Visible (SeriesPointerの継承元) | ポインタを表示/非表示にします。
XPosition |
YPosition |
ZPosition |

参照

AnnotationCallout クラス | Steema.TeeChart.Tools 名前空間


XPosition

Steema.TeeChart.Tools.AnnotationCallout.XPosition プロパティ

public Int32 XPosition {get; set;}

解説

アノテーションの引き出し線の終点のXピクセル座標値を定義します。

参照

AnnotationCallout クラス | AnnotationCallout メンバ | Steema.TeeChart.Tools 名前空間


YPosition

Steema.TeeChart.Tools.AnnotationCallout.YPosition プロパティ

public Int32 YPosition {get; set;}

解説

アノテーションの引き出し線の終点のYピクセル座標値を定義します。

参照

AnnotationCallout クラス | AnnotationCallout メンバ | Steema.TeeChart.Tools 名前空間


ZPosition

Steema.TeeChart.Tools.AnnotationCallout.ZPosition プロパティ

public Int32 ZPosition {get; set;}

解説

アノテーションの引き出し線の終点のZピクセル座標値を定義します。

参照

AnnotationCallout クラス | AnnotationCallout メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AnnotationPositions

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AnnotationPositions 列挙体

Positionプロパティの使用可能な値です。

[Serializable]
public enum AnnotationPositions : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
LeftTop | アノテーションツールをチャートパネルの左上に表示します。
LeftBottom | アノテーションツールをチャートパネルの左下に表示します。
RightTop | アノテーションツールをチャートパネルの右上に表示します。
RightBottom | アノテーションツールをチャートパネルの右下に表示します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow

Steema.TeeChart.Tools.AxisArrow クラス

軸矢印ツール。

この型のすべてのメンバの一覧については、AxisArrow メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class AxisArrow : ToolAxis , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow 全メンバ

AxisArrow 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Length | 矢印の長さを設定します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
Position | 軸上のどの位置に矢印を描画させるかを設定します。
ScrollInverted | 軸矢印のスクロール方向を逆にします。
ScrollPercent | スクロールさせる軸の割合をパーセントで設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisArrow クラス | Steema.TeeChart.Tools 名前空間


AxisArrow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow コンストラクタ

オーバーロードの一覧

public AxisArrow()
public AxisArrow(Steema.TeeChart.Chart)
public AxisArrow(Steema.TeeChart.Axis)

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


AxisArrow コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow コンストラクタ

public AxisArrow()

参照

AxisArrow コンストラクタのオーバーロードの一覧 | AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


AxisArrow コンストラクタ

Steema.TeeChart.Tools.AxisArrow コンストラクタ

public AxisArrow(Chart c)

参照

AxisArrow コンストラクタのオーバーロードの一覧 | AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


AxisArrow コンストラクタ

Steema.TeeChart.Tools.AxisArrow コンストラクタ

public AxisArrow(Axis a)

参照

AxisArrow コンストラクタのオーバーロードの一覧 | AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow イベント

パブリック イベント

Click

参照

AxisArrow クラス | Steema.TeeChart.Tools 名前空間


Click

Steema.TeeChart.Tools.AxisArrow.Click イベント

public MouseEventHandler  Click

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

AxisArrow クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisArrow クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.AxisArrow.Assign メソッド

protected abstract Void Assign(Tool t)

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.AxisArrow.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrow プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Brush | ブラシ特性のエレメント。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
Length | 矢印の長さを設定します。
Pen | ペン特性のエレメント。
Position | 軸上のどの位置に矢印を描画させるかを設定します。
ScrollInverted | 軸矢印のスクロール方向を逆にします。
ScrollPercent | スクロールさせる軸の割合をパーセントで設定します。

参照

AxisArrow クラス | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.AxisArrow.Brush プロパティ

ブラシ特性を取得/設定します。
public ChartBrush Brush {get; set;}

解説

軸矢印のブラシ特性を取得/設定します。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.AxisArrow.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Length

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow.Length プロパティ

矢印の長さを設定します。

public Int32 Length {get; set;}

解説

デフォルト値：16

矢印の長さを設定します。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Position

Steema.TeeChart.Tools.AxisArrow.Position プロパティ

軸上のどの位置に矢印を描画させるかを設定します。
public AxisArrowPosition Position {get; set;}

解説

軸上のどの位置に矢印を描画させるかを設定します。

使用可能な値は以下の通りです。

Start 軸の開始位置に矢印を描きます。
End 軸の終了位置に矢印を描きます。
Both 軸の開始と終了位置に矢印を描きます。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


ScrollInverted

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow.ScrollInverted プロパティ

軸矢印のスクロール方向を逆にします。

public Boolean ScrollInverted {get; set;}

解説

軸矢印のスクロール方向を逆にします。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


ScrollPercent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrow.ScrollPercent プロパティ

スクロールさせる軸の割合をパーセントで設定します。

public Int32 ScrollPercent {get; set;}

解説

デフォルト値：10

矢印がクリックされるとスクロールさせる軸の割合をパーセントで設定します。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.AxisArrow.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

AxisArrow クラス | AxisArrow メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisArrowPosition

TeeChartプログラミングガイド

Steema.TeeChart.Tools.AxisArrowPosition 列挙体

Positionプロパティの使用可能な値です。

[Serializable]
public enum AxisArrowPosition : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Start | 軸の開始位置に矢印を表示します。
End | 軸の終了位置に矢印を表示します。
Both | 軸の開始位置と終了位置に矢印を表示します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisScroll

Steema.TeeChart.Tools.AxisScroll クラス

軸スクロールツール。

この型のすべてのメンバの一覧については、AxisScroll メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class AxisScroll : ToolAxis , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisScroll 全メンバ

AxisScroll 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
ScrollInverted | trueの場合、水平軸を左から右にドラッグすると、関連付けられている系列を逆方向（右から左）にスクロールします。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisScroll クラス | Steema.TeeChart.Tools 名前空間


AxisScroll コンストラクタ

Steema.TeeChart.Tools.AxisScroll コンストラクタ

オーバーロードの一覧

public AxisScroll()
public AxisScroll(Steema.TeeChart.Chart)
public AxisScroll(Steema.TeeChart.Axis)

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


AxisScroll コンストラクタ

Steema.TeeChart.Tools.AxisScroll コンストラクタ

public AxisScroll()

参照

AxisScroll コンストラクタのオーバーロードの一覧 | AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


AxisScroll コンストラクタ

Steema.TeeChart.Tools.AxisScroll コンストラクタ

public AxisScroll(Chart c)

参照

AxisScroll コンストラクタのオーバーロードの一覧 | AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


AxisScroll コンストラクタ

Steema.TeeChart.Tools.AxisScroll コンストラクタ

public AxisScroll(Axis a)

参照

AxisScroll コンストラクタのオーバーロードの一覧 | AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisScroll フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

AxisScroll クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisScroll メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

AxisScroll クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.AxisScroll.Assign メソッド

protected abstract Void Assign(Tool t)

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.AxisScroll.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.AxisScroll プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
ScrollInverted | trueの場合、水平軸を左から右にドラッグすると、関連付けられている系列を逆方向（右から左）にスクロールします。
Summary | 詳細な説明テキストを取得します。

参照

AxisScroll クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.AxisScroll.Description プロパティ

説明のテキストを取得します。

public override String Description {get;}

解説

説明テキストを取得します。

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


ScrollInverted

Steema.TeeChart.Tools.AxisScroll.ScrollInverted プロパティ

trueの場合、水平軸を左から右にドラッグすると、関連付けられている系列を逆方向（右から左）にスクロールします。

public Boolean ScrollInverted {get; set;}

解説

デフォルト値：false

trueの場合、水平軸を左から右にドラッグすると関連付けられている系列を逆方向（右から左）にスクロールします。

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.AxisScroll.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

AxisScroll クラス | AxisScroll メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool

Steema.TeeChart.Tools.BannerTool クラス

この型のすべてのメンバの一覧については、BannerTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class BannerTool : Annotation , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool 全メンバ

BannerTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Blink | Trueの場合、テキストを点滅（表示/非表示）します。テキストは、BlinkDelayOnプロパティで設定されたミリ秒数表示して、BlinkDelayOffプロパティで設定されたミリ秒数非表示にします。
BlinkDelayOff | テキストを非表示にするミリ秒数を定義します。
BlinkDelayOn | テキストを表示するミリ秒数を定義します。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Scroll | Trueの場合、テキストをScrollDirectionプロパティで設定された方向にスクロールします。
ScrollDirection | テキストのスクロールする方向を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY
ChartEvent
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

BannerTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool コンストラクタ

オーバーロードの一覧

public BannerTool()
public BannerTool(Steema.TeeChart.Chart)

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool コンストラクタ

public BannerTool()

参照

BannerTool コンストラクタのオーバーロードの一覧 | BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool コンストラクタ

public BannerTool(Chart c)

参照

BannerTool コンストラクタのオーバーロードの一覧 | BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool イベント

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

参照

BannerTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

参照

BannerTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY
ChartEvent
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

BannerTool クラス | Steema.TeeChart.Tools 名前空間


CalcTextXY

Steema.TeeChart.Tools.BannerTool.CalcTextXY メソッド

protected abstract Void CalcTextXY(Int32& x,
     Int32& y)

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.BannerTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BannerTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Blink | Trueの場合、テキストを点滅（表示/非表示）します。テキストは、BlinkDelayOnプロパティで設定されたミリ秒数表示して、BlinkDelayOffプロパティで設定されたミリ秒数非表示にします。
BlinkDelayOff | テキストを非表示にするミリ秒数を定義します。
BlinkDelayOn | テキストを表示するミリ秒数を定義します。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Scroll | Trueの場合、テキストをScrollDirectionプロパティで設定された方向にスクロールします。
ScrollDirection | テキストのスクロールする方向を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

参照

BannerTool クラス | Steema.TeeChart.Tools 名前空間


Blink

Steema.TeeChart.Tools.BannerTool.Blink プロパティ

Trueの場合、テキストを点滅（表示/非表示）します。テキストは、BlinkDelayOnプロパティで設定されたミリ秒数表示して、BlinkDelayOffプロパティで設定されたミリ秒数非表示にします。
public Boolean Blink {get; set;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


BlinkDelayOff

Steema.TeeChart.Tools.BannerTool.BlinkDelayOff プロパティ

テキストを非表示にするミリ秒数を定義します。
public Int32 BlinkDelayOff {get; set;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間 | BlinkDelayOn


BlinkDelayOn

Steema.TeeChart.Tools.BannerTool.BlinkDelayOn プロパティ

テキストを表示するミリ秒数を定義します。
public Int32 BlinkDelayOn {get; set;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間 | BlinkDelayOff


Description

Steema.TeeChart.Tools.BannerTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Scroll

Steema.TeeChart.Tools.BannerTool.Scroll プロパティ

Trueの場合、テキストをScrollDirectionプロパティで設定された方向にスクロールします。
public Boolean Scroll {get; set;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


ScrollDirection

Steema.TeeChart.Tools.BannerTool.ScrollDirection プロパティ

テキストのスクロールする方向を定義します。
public ScrollingDirection ScrollDirection {get; set;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.BannerTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

BannerTool クラス | BannerTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawAxesEventArgs

Steema.TeeChart.Tools.BeforeDrawAxesEventArgs クラス

内部使用。ツールサポートのEventArgs。

この型のすべてのメンバの一覧については、BeforeDrawAxesEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class BeforeDrawAxesEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

BeforeDrawAxesEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawAxesEventArgs 全メンバ

BeforeDrawAxesEventArgs 概要

コンストラクタ

Constructor

参照

BeforeDrawAxesEventArgs クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawAxesEventArgs コンストラクタ

public BeforeDrawAxesEventArgs()

参照

BeforeDrawAxesEventArgs クラス | BeforeDrawAxesEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawEventArgs

Steema.TeeChart.Tools.BeforeDrawEventArgs クラス

内部使用。ツールサポートのEventArgs。

この型のすべてのメンバの一覧については、BeforeDrawEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class BeforeDrawEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

BeforeDrawEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawEventArgs 全メンバ

BeforeDrawEventArgs 概要

コンストラクタ

Constructor

参照

BeforeDrawEventArgs クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawEventArgs コンストラクタ

public BeforeDrawEventArgs()

参照

BeforeDrawEventArgs クラス | BeforeDrawEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs クラス

内部使用。BeforeDrawSeriesイベントのEventArgs。

この型のすべてのメンバの一覧については、BeforeDrawSeriesEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class BeforeDrawSeriesEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

BeforeDrawSeriesEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs 全メンバ

BeforeDrawSeriesEventArgs 概要

コンストラクタ

Constructor

参照

BeforeDrawSeriesEventArgs クラス | Steema.TeeChart.Tools 名前空間


BeforeDrawSeriesEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.BeforeDrawSeriesEventArgs コンストラクタ

public BeforeDrawSeriesEventArgs()

参照

BeforeDrawSeriesEventArgs クラス | BeforeDrawSeriesEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartCollection

Steema.TeeChart.Tools.ChartCollection クラス

Chartコンポーネントのコレクション。

この型のすべてのメンバの一覧については、ChartCollection メンバを参照してください。

System.Object
System.Collections.CollectionBase
[Serializable]
public sealed class ChartCollection : CollectionBase
, IList, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartCollection 全メンバ

ChartCollection 概要

コンストラクタ

Constructor

パブリック メソッド

Add
AddChart

パブリック プロパティ

Item
Owner

プロテクト メソッド

OnInsertComplete
OnRemoveComplete

参照

ChartCollection クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartCollection コンストラクタ

public ChartCollection(Tool tool)

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartCollection メソッド

パブリック メソッド

Add
AddChart

プロテクト メソッド

OnInsertComplete
OnRemoveComplete

参照

ChartCollection クラス | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.ChartCollection.Add メソッド

public SubChart Add(SubChart c)

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


AddChart

Steema.TeeChart.Tools.ChartCollection.AddChart メソッド

public TChart AddChart(String name)

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


OnInsertComplete

Steema.TeeChart.Tools.ChartCollection.OnInsertComplete メソッド

protected abstract Void OnInsertComplete(Int32 index,
     Object value)

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


OnRemoveComplete

Steema.TeeChart.Tools.ChartCollection.OnRemoveComplete メソッド

protected abstract Void OnRemoveComplete(Int32 index,
     Object value)

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartCollection プロパティ

パブリック プロパティ

Item
Owner

参照

ChartCollection クラス | Steema.TeeChart.Tools 名前空間


Item

Steema.TeeChart.Tools.ChartCollection.Item プロパティ

public SubChart Item(Int32 index) {get; set;}

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


Owner

Steema.TeeChart.Tools.ChartCollection.Owner プロパティ

public Tool Owner {get; set;}

参照

ChartCollection クラス | ChartCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartImage

Steema.TeeChart.Tools.ChartImage クラス

イメージツール。系列の軸を使用して指定された範囲にイメージを表示します。軸がズームあるいはスクロールされた場合、イメージもズームあるいはスクロールします。

この型のすべてのメンバの一覧については、ChartImage メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class ChartImage : ToolSeries , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartImage 全メンバ

ChartImage 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Image |
ImageMode |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartImage クラス | Steema.TeeChart.Tools 名前空間


ChartImage コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ChartImage コンストラクタ

オーバーロードの一覧

public ChartImage()
public ChartImage(Steema.TeeChart.Chart)

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


ChartImage コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ChartImage コンストラクタ

public ChartImage()

参照

ChartImage コンストラクタのオーバーロードの一覧 | ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


ChartImage コンストラクタ

Steema.TeeChart.Tools.ChartImage コンストラクタ

public ChartImage(Chart c)

参照

ChartImage コンストラクタのオーバーロードの一覧 | ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartImage フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

ChartImage クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartImage メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ChartImage クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ChartImage.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ChartImage.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ChartImage プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Image |
ImageMode |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。

参照

ChartImage クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ChartImage.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Image

Steema.TeeChart.Tools.ChartImage.Image プロパティ

public Image Image {get; set;}

解説

指定したファイルパスからイメージをロードします。

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


ImageMode

Steema.TeeChart.Tools.ChartImage.ImageMode プロパティ

public ImageMode ImageMode {get; set;}

解説

イメージをどのように描画するか定義します。

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ChartImage.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

ChartImage クラス | ChartImage メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries

Steema.TeeChart.Tools.ClipSeries クラス

クリップツール。クリップ領域は系列の垂直軸と水平軸で制限されます。

この型のすべてのメンバの一覧については、ClipSeries メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class ClipSeries : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries 全メンバ

ClipSeries 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ClipSeries クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries コンストラクタ

オーバーロードの一覧

public ClipSeries()
public ClipSeries(Steema.TeeChart.Chart)

参照

ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries コンストラクタ

public ClipSeries()

参照

ClipSeries コンストラクタのオーバーロードの一覧 | ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries コンストラクタ

public ClipSeries(Chart c)

参照

ClipSeries コンストラクタのオーバーロードの一覧 | ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

ClipSeries クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ClipSeries クラス | Steema.TeeChart.Tools 名前空間


SeriesEvent

Steema.TeeChart.Tools.ClipSeries.SeriesEvent メソッド

protected internal abstract Void SeriesEvent(EventArgs e)

参照

ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ClipSeries プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連付けられたチャートの水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連付けられたチャートの垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

参照

ClipSeries クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ClipSeries.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ClipSeries.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

ClipSeries クラス | ClipSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand

Steema.TeeChart.Tools.ColorBand クラス

指定した軸と位置に色付けされた矩形（バンド）を表示するためにカラーバンドツールを使用します。

この型のすべてのメンバの一覧については、ColorBand メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class ColorBand : ToolAxis , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand 全メンバ

ColorBand 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click

パブリック メソッド

Clicked |
Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | カラーバンドツールのバンドの色を設定します。
Description | 説明のテキストを取得します。
DrawBehind | trueの場合、系列の背面にカラーバンドを描画します。
End | カラーバンドの描画を終了する軸値を設定します。
EndLine | 実行時にカラーバンドツールの終了値をドラッグするための線の形式プロパティを含んでいます。
EndLinePen | カラーバンドツールの終了線を描くペンを定義します。
Gradient | カラーバンドのグラデーションを設定します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
ResizeEnd | カラーバンドツールの終了値の位置の線をマウスでドラッグできるかどうかを取得/設定します。
ResizeStart | カラーバンドツールの開始値の位置の線をマウスでドラッグできるかどうかを取得/設定します。
Start | カラーバンドの描画を開始する軸値を設定します。
StartLine | 実行時にカラーバンドツールの開始線をドラッグするための線の形式プロパティを含んでいます。
StartLinePen | カラーバンドツールの開始線を描くペンを定義します。
Summary | 詳細な説明テキストを取得します。
Transparency | カラーバンドの透明度を0～100%で設定します。

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnClick
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ColorBand クラス | Steema.TeeChart.Tools 名前空間


ColorBand コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand コンストラクタ

オーバーロードの一覧

public ColorBand()
public ColorBand(Steema.TeeChart.Chart)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


ColorBand コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand コンストラクタ

public ColorBand()

参照

ColorBand コンストラクタのオーバーロードの一覧 | ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


ColorBand コンストラクタ

Steema.TeeChart.Tools.ColorBand コンストラクタ

public ColorBand(Chart c)

参照

ColorBand コンストラクタのオーバーロードの一覧 | ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand イベント

パブリック イベント

Click

参照

ColorBand クラス | Steema.TeeChart.Tools 名前空間


Click

Steema.TeeChart.Tools.ColorBand.Click イベント

public MouseEventHandler  Click

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

ColorBand クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand メソッド

パブリック メソッド

Clicked |
Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnClick
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ColorBand クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ColorBand.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Clicked

Steema.TeeChart.Tools.ColorBand.Clicked メソッド

public Boolean Clicked(Int32 X,
     Int32 Y)

解説

xとyピクセルで指定したポイントがカラーバンドの境界矩形内にある場合、trueを返します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.ColorBand.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


OnClick

Steema.TeeChart.Tools.ColorBand.OnClick メソッド

protected internal Void OnClick(MouseEventArgs e)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


SetAxis

Steema.TeeChart.Tools.ColorBand.SetAxis メソッド

protected internal abstract Void SetAxis(Axis value)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.ColorBand.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorBand プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Brush | ブラシ特性のエレメント。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | カラーバンドツールのバンドの色を設定します。
Description | 説明のテキストを取得します。
DrawBehind | trueの場合、系列の背面にカラーバンドを描画します。
End | カラーバンドの描画を終了する軸値を設定します。
EndLine | 実行時にカラーバンドツールの終了値をドラッグするために使用される自動線のための形式プロパティを含んでいます。
EndLinePen | カラーバンドツールの終了線を描くペンを設定します。
Gradient | カラーバンドのグラデーションを設定します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
ResizeEnd | カラーバンドツールの終了値の位置の線をマウスでドラッグできるかどうかを取得/設定します。
ResizeStart | カラーバンドツールの開始値の位置の線をマウスでドラッグできるかどうかを取得/設定します。
Start | カラーバンドの描画を開始する軸値を設定します。
StartLine | 実行時にカラーバンドツールの開始値をドラッグするために使用される自動線のための形式プロパティを含んでいます。
StartLinePen | カラーバンドツールの開始線を描くペンを設定します。
Summary | 詳細な説明テキストを取得します。
Transparency | カラーバンドの透明度を0～100%で設定します。

参照

ColorBand クラス | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.ColorBand.Brush プロパティ

ブラシ特性を取得/設定します。
public ChartBrush Brush {get; set;}

解説

ブラシ特性を取得/設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Color

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.Color プロパティ

カラーバンドツールのバンドの色を設定します。

public Color Color {get; set;}

解説

カラーバンドツールのバンドの色を設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ColorBand.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


DrawBehind

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.DrawBehind プロパティ

trueの場合、系列の背面にカラーバンドを描画します。

public Boolean DrawBehind {get; set;}

解説

デフォルト値：true

trueの場合、系列の背面にカラーバンドを描画します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


End

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.End プロパティ

カラーバンドの描画を終了する軸値を設定します。

public Double End {get; set;}

解説

カラーバンドの描画を終了する軸値を設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


EndLine

Steema.TeeChart.Tools.ColorBand.EndLine プロパティ

実行時にカラーバンドツールの終了値をドラッグするための線の形式プロパティを含んでいます。
public ColorLine EndLine {get; set;}

解説

実行時にカラーバンドツールの終了値をドラッグするための線の形式プロパティを含んでいます。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


EndLinePen

Steema.TeeChart.Tools.ColorBand.EndLinePen プロパティ

カラーバンドツールの終了線を描くペンを定義します。

public ChartPen EndLinePen {get;}

解説

カラーバンドツールの終了線を描くペンを定義します。
ResizeEndプロパティがtrueの場合、この線をマウスでドラッグできます。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Gradient

Steema.TeeChart.Tools.ColorBand.Gradient プロパティ

カラーバンドのグラデーションを設定します。
public Gradient Gradient {get;}

解説

カラーバンドのグラデーションを設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


ResizeEnd

Steema.TeeChart.Tools.ColorBand.ResizeEnd プロパティ

カラーバンドツールの終了値の位置の線をマウスでドラッグできるかどうかを取得/設定します。

public Boolean ResizeEnd {get; set;}

解説

カラーバンドツールの終了値の位置の線をマウスでドラッグできるかどうかを取得/設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


ResizeStart

Steema.TeeChart.Tools.ColorBand.ResizeStart プロパティ

カラーバンドツールの開始値の位置の線をマウスでドラッグできるかどうかを取得/設定します。

public Boolean ResizeStart {get; set;}

解説

カラーバンドツールの開始値の位置の線をマウスでドラッグできるかどうかを取得/設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Start

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.Start プロパティ

カラーバンドの描画を開始する軸値を設定します。

public Double Start {get; set;}

解説

カラーバンドの描画を開始する軸値を設定します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


StartLine

Steema.TeeChart.Tools.ColorBand.StartLine プロパティ

実行時にカラーバンドツールの開始線をドラッグするための線の形式プロパティを含んでいます。
public ColorLine StartLine {get; set;}

解説

実行時にカラーバンドツールの開始線をドラッグするための線の形式プロパティを含んでいます。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


StartLinePen

Steema.TeeChart.Tools.ColorBand.StartLinePen プロパティ

カラーバンドツールの開始線を描くペンを定義します。

public ChartPen StartLinePen {get;}

解説

カラーバンドツールの開始線を描くペンを取得します。
ResizeStartプロパティがtrueの場合、この線をマウスでドラッグできます。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ColorBand.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Transparency

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorBand.Transparency プロパティ

カラーバンドの透明度を0～100%で設定します。

public Int32 Transparency {get; set;}

解説

カラーバンドの透明度を0～100%で設定します。透明度が0の場合、前景だけが表示されます。透明度が100の場合、背景だけが表示されます。

参照

ColorBand クラス | ColorBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine

Steema.TeeChart.Tools.ColorLine クラス

カラーラインツール。軸値にカスタムな線を描くためのツールです。

この型のすべてのメンバの一覧については、ColorLine メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class ColorLine : ToolAxis , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine 全メンバ

ColorLine 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

DragLine
EndDragLine

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag | trueの場合、カラーラインのマウスドラッグを有効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DragRepaint | trueの場合、カラーラインを移動する間にチャートを再描画します。
Draw3D | trueの場合、3Dでカラーラインを描画します。
DrawBehind | 系列値の背面にカラーラインを描画します。
NoLimitDrag | チャート矩形外へのカラーラインのドラッグを有効にします。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
Summary | 詳細な説明テキストを取得します。
Value | カラーラインを描画する軸の位置を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
DoDragLine
DoEndDragLine
DrawColorLine
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ColorLine クラス | Steema.TeeChart.Tools 名前空間


ColorLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine コンストラクタ

オーバーロードの一覧

public ColorLine()
public ColorLine(Steema.TeeChart.Chart)

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


ColorLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine コンストラクタ

public ColorLine()

参照

ColorLine コンストラクタのオーバーロードの一覧 | ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


ColorLine コンストラクタ

Steema.TeeChart.Tools.ColorLine コンストラクタ

public ColorLine(Chart c)

参照

ColorLine コンストラクタのオーバーロードの一覧 | ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine イベント

パブリック イベント

DragLine
EndDragLine

参照

ColorLine クラス | Steema.TeeChart.Tools 名前空間


DragLine

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.DragLine イベント

public EventHandler  DragLine

解説

カラーラインがドラッグされている間にこのイベントが発生します。

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


EndDragLine

Steema.TeeChart.Tools.ColorLine.EndDragLine イベント

public ColorLineToolOnDragEventHandler  EndDragLine

解説

このイベントは、カラーラインのドラッグが終了した際に発生します。

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

ColorLine クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
DoDragLine
DoEndDragLine
DrawColorLine
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ColorLine クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ColorLine.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DoDragLine

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.DoDragLine メソッド

protected virtual Void DoDragLine()

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DoEndDragLine

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.DoEndDragLine メソッド

protected virtual Void DoEndDragLine()

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DrawColorLine

Steema.TeeChart.Tools.ColorLine.DrawColorLine メソッド

protected internal Void DrawColorLine(Boolean Back)

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DrawColorLine

Steema.TeeChart.Tools.ColorLine.DrawColorLine メソッド

protected internal Void DrawColorLine(Graphics3D g,
     Boolean Back)

参照

DrawColorLine オーバーロードの一覧 | ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DrawColorLine

Steema.TeeChart.Tools.ColorLine.DrawColorLine メソッド

protected internal Void DrawColorLine(Boolean Back)

参照

DrawColorLine オーバーロードの一覧 | ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.ColorLine.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLine プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag | trueの場合、カラーラインのマウスドラッグを有効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
DragRepaint | trueの場合、カラーラインを移動する間にチャートを再描画します。
Draw3D | trueの場合、3Dでカラーラインを描画します。
DrawBehind | 系列値の背面にカラーラインを描画します。
NoLimitDrag | チャート矩形外へのカラーラインのドラッグを有効にします。
Pen | ペン特性のエレメント。
Value | カラーラインを描画する軸の位置を設定します。

参照

ColorLine クラス | Steema.TeeChart.Tools 名前空間


AllowDrag

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.AllowDrag プロパティ

trueの場合、カラーラインのマウスドラッグを有効にします。

public Boolean AllowDrag {get; set;}

解説

デフォルト値：false

trueの場合、カラーラインのマウスドラッグを有効にします。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;
colorLine1.Active = true;

colorLine1.AllowDrag =true;

colorLine1.Value = 250;
colorLine1.Pen.Color =Color.Blue;
colorLine1.Draw3D = true;
colorLine1.DragRepaint = true;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


ColorLineClickTolerance

Steema.TeeChart.Tools.ColorLine.ColorLineClickTolerance プロパティ

クリックを認識するピクセル単位の許容誤差を取得/設定します。
public Int32 ColorLineClickTolerance {get; set;}

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ColorLine.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DragRepaint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.DragRepaint プロパティ

trueの場合、カラーラインを移動する間にチャートを再描画します。

public Boolean DragRepaint {get; set;}

解説

デフォルト値：false

このプロパティがfalseの場合、チャートはドラッグされたカラーラインが解放されるまで再描画されません。このプロパティがtrueの場合、カラーラインが移動する間チャートは再描画します。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;
colorLine1.Active = true;

colorLine1.DragRepaint = true;

colorLine1.AllowDrag =true;
colorLine1.Value = 250;
colorLine1.Pen.Color =Color.Blue;
colorLine1.Draw3D = true;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Draw3D

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.Draw3D プロパティ

trueの場合、3Dでカラーラインを描画します。

public Boolean Draw3D {get; set;}

解説

デフォルト値：true

trueの場合、3Dでカラーラインを描画します。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;

colorLine1.Active = true;

colorLine1.Draw3D = true;
colorLine1.DragRepaint = true;
colorLine1.AllowDrag =true;
colorLine1.Value = 250;
colorLine1.Pen.Color =Color.Blue;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


DrawBehind

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.DrawBehind プロパティ

系列値の背面にカラーラインを描画します。

public Boolean DrawBehind {get; set;}

解説

デフォルト値：false

trueに設定すると、系列値の背面にカラーラインを描画します。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;

colorLine1.Active = true;

colorLine1.Draw3D = true;
colorLine1.DragRepaint = true;
colorLine1.AllowDrag =true;
colorLine1.Value = 250;
colorLine1.Pen.Color =Color.Blue;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


NoLimitDrag

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.NoLimitDrag プロパティ

チャート矩形外へのカラーラインのドラッグを有効にします。

public Boolean NoLimitDrag {get; set;}

解説

デフォルト値：false

trueの場合、チャート矩形外へのカラーラインのドラッグを有効にします。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;

colorLine1.NoLimitDrag = true;

colorLine1.Active = true;
colorLine1.Value = 250;
colorLine1.Pen.Color =Color.Blue;
colorLine1.AllowDrag =true;
colorLine1.Draw3D = true;
colorLine1.DragRepaint = true;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ColorLine.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Value

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLine.Value プロパティ

カラーラインを描画する軸の位置を設定します。

public Double Value {get; set;}

解説

カラーラインを描画する軸の位置を設定します。

例

[C#]

Steema.TeeChart.ColorLine colorLine1 = new Steema.TeeChart.ColorLine(tChart1.Chart);
colorLine1.Axis = tChart1.Axes.Left;

colorLine1.Value = 250;

colorLine1.Active = true;
colorLine1.Draw3D = true;
colorLine1.DragRepaint = true;
colorLine1.AllowDrag =true;
colorLine1.Pen.Color =Color.Blue;

参照

ColorLine クラス | ColorLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ColorLineToolOnDragEventHandler

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ColorLineToolOnDragEventHandler デリゲート

カラーラインツールのドラッグイベントハンドラ。

public virtual Void Invoke(Object sender)

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

SteemaTeeChartToolsColorLineToolOnDragEve 名前空間


Steema.TeeChart.Tools.CursorChangeEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs クラス

カーソルツールのChangeイベントのEventArgs。

この型のすべてのメンバの一覧については、CursorChangeEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class CursorChangeEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorChangeEventArgs 全メンバ

CursorChangeEventArgs 概要

コンストラクタ

Constructor

パブリック フィールド

Series
SnapPoint
ValueIndex
x
XValue
y
YValue

参照

CursorChangeEventArgs クラス | Steema.TeeChart.Tools 名前空間


CursorChangeEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs コンストラクタ

public CursorChangeEventArgs()

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorChangeEventArgs フィールド

パブリック フィールド

Series
SnapPoint
ValueIndex
x
XValue
y
YValue

参照

CursorChangeEventArgs クラス | Steema.TeeChart.Tools 名前空間


Series

Steema.TeeChart.Tools.CursorChangeEventArgs.Series フィールド

public Series Series

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


SnapPoint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.SnapPoint フィールド

public Int32 SnapPoint

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


ValueIndex

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.ValueIndex フィールド

public Int32 ValueIndex

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


x

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.x フィールド

public Int32 x

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


XValue

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.XValue フィールド

public Double XValue

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


y

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.y フィールド

public Int32 y

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


YValue

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorChangeEventArgs.YValue フィールド

public Double YValue

参照

CursorChangeEventArgs クラス | CursorChangeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorChangeEventHandler

Steema.TeeChart.Tools.CursorChangeEventHandler デリゲート

カーソルツールのイベントハンドラ。
public delegate CursorChangeEventHandler (Object sender,
     CursorChangeEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorClicked

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorClicked 列挙体

Clickedメソッドの使用可能な戻り値です。

[Serializable]
public enum CursorClicked : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | カーソルは、カーソルツール上にありません。
Horizontal | カーソルは、水平カーソルツール上にあります。
Vertical | カーソルは、垂直カーソル上にあります。
Both | カーソルは、垂直カーソルと水平カーソル上にあります。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorGetAxisRectEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorGetAxisRectEventArgs クラス

カーソルツールのGetAxisRectイベントのEventArgs。

この型のすべてのメンバの一覧については、CursorGetAxisRectEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class CursorGetAxisRectEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

CursorGetAxisRectEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorGetAxisRectEventArgs 全メンバ

CursorGetAxisRectEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Rectangle

参照

CursorGetAxisRectEventArgs クラス | Steema.TeeChart.Tools 名前空間


CursorGetAxisRectEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorGetAxisRectEventArgs コンストラクタ

public CursorGetAxisRectEventArgs(Rectangle rect)

参照

CursorGetAxisRectEventArgs クラス | CursorGetAxisRectEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorGetAxisRectEventArgs プロパティ

パブリック プロパティ

Rectangle

参照

CursorGetAxisRectEventArgs クラス | Steema.TeeChart.Tools 名前空間


Rectangle

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorGetAxisRectEventArgs.Rectangle プロパティ

public Rectangle Rectangle {get; set;}

参照

CursorGetAxisRectEventArgs クラス | CursorGetAxisRectEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorGetAxisRectEventHandler

Steema.TeeChart.Tools.CursorGetAxisRectEventHandler デリゲート

カーソルツールの軸のイベントハンドラ。
public delegate CursorGetAxisRectEventHandler (Object sender,
     CursorGetAxisRectEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool

Steema.TeeChart.Tools.CursorTool クラス

カーソルツール。

この型のすべてのメンバの一覧については、CursorTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class CursorTool : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool 全メンバ

CursorTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Change
GetAxisRect
SnapChange

パブリック メソッド

Clicked |
Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NearestPoint | カーソルに最も近いポイントおよび最短距離の値を返します。
SnapToPoint | カーソルを最も近い系列ポイントに移動してポイントインデックスを返します。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
FastCursor | FollowMouse = trueに設定した場合、チャート全体を再描画せずにカーソルのみ描画します。
FollowMouse | マウスの移動に合わせてカーソルツールも移動します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Snap | カーソルツールは最も近い系列ポイントに整列します。
Style | カーソルツールの表示する線を定義します。
Summary | 詳細な説明テキストを取得します。
UseChartRect | 軸の境界の代わりにチャート矩形全体に設定します。
XValue | 垂直方向のカーソルツールのX値を設定します。
YValue | 水平方向のカーソルツールのY値を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
CalcScreenPositions
ChartEvent
Dispose (Toolの継承元)
DoGetAxisRect
KeyEvent (Toolの継承元)
MouseEvent
OnChange
OnDisposing (Toolの継承元)
OnSnapChange
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

CursorTool クラス | Steema.TeeChart.Tools 名前空間


CursorTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool コンストラクタ

オーバーロードの一覧

public CursorTool()
public CursorTool(Steema.TeeChart.Chart)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


CursorTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool コンストラクタ

public CursorTool()

参照

CursorTool コンストラクタのオーバーロードの一覧 | CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


CursorTool コンストラクタ

Steema.TeeChart.Tools.CursorTool コンストラクタ

public CursorTool(Chart c)

参照

CursorTool コンストラクタのオーバーロードの一覧 | CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool イベント

パブリック イベント

Change
GetAxisRect
SnapChange

参照

CursorTool クラス | Steema.TeeChart.Tools 名前空間


Change

Steema.TeeChart.Tools.CursorTool.Change イベント

public CursorChangeEventHandler  Change

解説

このイベントは、ユーザまたはプログラムでカーソルツールの位置を変更すると発生します。

イベントハンドラで別のオブジェクトの制御を行うことができます。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


GetAxisRect

Steema.TeeChart.Tools.CursorTool.GetAxisRect イベント

public CursorGetAxisRectEventHandler  GetAxisRect

解説

カーソルツールに関連する矩形領域。複数軸のチャートで1つの系列に関連するカーソルツールは、系列の軸領域に関連する矩形を使用します。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


SnapChange

Steema.TeeChart.Tools.CursorTool.SnapChange イベント

public CursorChangeEventHandler  SnapChange

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

CursorTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool メソッド

パブリック メソッド

Clicked |
Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NearestPoint | カーソルに最も近いポイントおよび最短距離の値を返します。
SnapToPoint | カーソルを最も近い系列ポイントに移動してポイントインデックスを返します。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
CalcScreenPositions
ChartEvent
Dispose (Toolの継承元)
DoGetAxisRect
KeyEvent (Toolの継承元)
MouseEvent
OnChange
OnDisposing (Toolの継承元)
OnSnapChange
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

CursorTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.CursorTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


CalcScreenPositions

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.CalcScreenPositions メソッド

protected Void CalcScreenPositions()

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.Clicked メソッド

public CursorClicked Clicked(Int32 x,
     Int32 y)

解説

カーソルがどのカーソルツール上にあるかを返します。
使用可能な戻り値は以下の通りです。

None カーソルは、カーソルツール上にありません。
Horizontal カーソルは、水平カーソルツール上にあります。
Vertical カーソルは、垂直カーソル上にあります。
Both カーソルは、垂直カーソルと水平カーソル上にあります。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


DoGetAxisRect

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.DoGetAxisRect メソッド

protected Void DoGetAxisRect(Rectangle& tmpResult)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.CursorTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


NearestPoint

Steema.TeeChart.Tools.CursorTool.NearestPoint メソッド

カーソルに最も近いポイントおよび最短距離の値を返します。
public Int32 NearestPoint(CursorToolStyles style,
     Double& difference)

解説

カーソルに最も近いポイントおよび最短距離の値を返します。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


OnChange

Steema.TeeChart.Tools.CursorTool.OnChange メソッド

protected abstract Void OnChange(Int32 snapPoint)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


OnSnapChange

Steema.TeeChart.Tools.CursorTool.OnSnapChange メソッド

protected abstract Void OnSnapChange(Int32 snapPoint)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


SetSeries

Steema.TeeChart.Tools.CursorTool.SetSeries メソッド

protected abstract Void SetSeries(Series value)

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


SnapToPoint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.SnapToPoint メソッド

カーソルを最も近い系列ポイントに移動してポイントインデックスを返します。

public Int32 SnapToPoint()

解説

カーソルを最も近い系列ポイントに移動してポイントインデックスを返します。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
FastCursor | FollowMouse = trueに設定した場合、チャート全体を再描画せずにカーソルのみ描画します。
FollowMouse | マウスの移動に合わせてカーソルツールも移動します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Snap | カーソルツールは最も近い系列ポイントに整列します。
Style | カーソルツールの表示する線を定義します。
Summary | 詳細な説明テキストを取得します。
UseChartRect | 軸の境界の代わりにチャート矩形全体に設定します。
XValue | 垂直方向のカーソルツールのX値を設定します。
YValue | 水平方向のカーソルツールのY値を設定します。

参照

CursorTool クラス | Steema.TeeChart.Tools 名前空間


CursorClickTolerance

Steema.TeeChart.Tools.CursorTool.CursorClickTolerance プロパティ

クリックを認識するピクセル単位の許容誤差を取得/設定します。
public Int32 CursorClickTolerance {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.CursorTool.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


FastCursor

Steema.TeeChart.Tools.CursorTool.FastCursor プロパティ

FollowMouse = trueに設定した場合、チャート全体を再描画せずにカーソルのみ描画します。
public Boolean FastCursor {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


FollowMouse

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.FollowMouse プロパティ

マウスの移動に合わせてカーソルツールも移動します。

public Boolean FollowMouse {get; set;}

解説

このプロパティをtrueに設定すると、マウスに合わせてカーソルツールも移動します。

例

[C#]

barSeries1.FillSampleValues(20);
Steema.TeeChart.Tools.CursorTool cursor1 = new Steema.TeeChart.Tools.CursorTool();
tChart1.Tools.Add(cursor1);
cursor1.Series = barSeries1;
cursor1.FollowMouse = true;
cursor1.Style = CursorToolStyles.Both;
cursor1.XValue = 10;
cursor1.YValue = 100;

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


HorizSize

Steema.TeeChart.Tools.CursorTool.HorizSize プロパティ

カーソルツールの水平サイズを取得/設定します（0に設定すると、関連付けられている横軸の全体の長さになります）。
public Int32 HorizSize {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.CursorTool.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get;}

解説

ペン特性のエレメント。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


ScopeSize

Steema.TeeChart.Tools.CursorTool.ScopeSize プロパティ

StyleプロパティがScopeの場合、スコープのサイズを編集するために使用してください。
public Int32 ScopeSize {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


ScopeStyle

Steema.TeeChart.Tools.CursorTool.ScopeStyle プロパティ

StyleプロパティがScopeに設定されている場合、ScopeCursorStyleオプションを選択してください。
public ScopeCursorStyle ScopeStyle {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Snap

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.Snap プロパティ

カーソルツールは最も近い系列ポイントに整列します。

public Boolean Snap {get; set;}

解説

trueに設定すると、カーソルツールは最も近い系列ポイントに整列します。
これは、Seriesプロパティに系列が設定されていない場合は無効です。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


SnapStyle

Steema.TeeChart.Tools.CursorTool.SnapStyle プロパティ

SnapプロパティがTrueの場合、選択されたSnapStyleに該当するマウス移動のスナップになります。
public SnapStyle SnapStyle {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.CursorTool.Style プロパティ

カーソルツールの表示する線を定義します。
public CursorToolStyles Style {get; set;}

解説

デフォルト値：Both

チャート上に表示するカーソルツールの線を定義します。

カーソルツールのスタイル：

Horizontal チャート上に水平線が描画されます。
Vertical チャート上に垂直線が描画されます。
Both チャート上に水平線と垂直線が描画されます。

例

[C#]

barSeries1.FillSampleValues(20);
Steema.TeeChart.Tools.CursorTool cursor1 = new Steema.TeeChart.Tools.CursorTool();
tChart1.Tools.Add(cursor1);
cursor1.Series = barSeries1;
cursor1.FollowMouse = true;
cursor1.Style = CursorToolStyles.Both;
cursor1.XValue = 10;
cursor1.YValue = 100;

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.CursorTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


UseChartRect

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.UseChartRect プロパティ

軸の境界の代わりにチャート矩形全体に設定します。

public Boolean UseChartRect {get; set;}

解説

このプロパティを使用することにより、カーソルツールが軸の境界の代わりにチャート矩形全体で有効になります。

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


UseSeriesZ

Steema.TeeChart.Tools.CursorTool.UseSeriesZ プロパティ

カーソルをチャートの前面位置（デフォルト）あるいは系列の「Z」位置を使用して描画するかどうか取得/設定します。
public Boolean UseSeriesZ {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


VertSize

Steema.TeeChart.Tools.CursorTool.VertSize プロパティ

カーソルツールの垂直サイズを取得/設定します（0に設定すると、関連付けられている縦軸の全体の長さになります）。
public Int32 VertSize {get; set;}

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


XValue

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.XValue プロパティ

垂直方向のカーソルツールのX値を設定します。

public Double XValue {get; set;}

解説

垂直方向のカーソルツールのX値を定義します。

例

[C#]

barSeries1.FillSampleValues(20);
Steema.TeeChart.Tools.CursorTool cursor1 = new Steema.TeeChart.Tools.CursorTool();
tChart1.Tools.Add(cursor1);
cursor1.Series = barSeries1;
cursor1.FollowMouse = true;
cursor1.Style = CursorToolStyles.Both;
cursor1.XValue = 10;
cursor1.YValue = 100;

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


YValue

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorTool.YValue プロパティ

水平方向のカーソルツールのY値を設定します。

public Double YValue {get; set;}

解説

水平方向のカーソルツールのY値を定義します。

例

[C#]

barSeries1.FillSampleValues(20);
Steema.TeeChart.Tools.CursorTool cursor1 = new Steema.TeeChart.Tools.CursorTool();
tChart1.Tools.Add(cursor1);
cursor1.Series = barSeries1;
cursor1.FollowMouse = true;
cursor1.Style = CursorToolStyles.Both;
cursor1.XValue = 10;
cursor1.YValue = 100;

参照

CursorTool クラス | CursorTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.CursorToolStyles

TeeChartプログラミングガイド

Steema.TeeChart.Tools.CursorToolStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum CursorToolStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Horizontal | チャート系列の上部に水平線を表示します。
Vertical | チャート系列の上部に垂直線を表示します。
Both | チャート系列の上部に水平線と垂直線を表示します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool

Steema.TeeChart.Tools.DataTableTool クラス

この型のすべてのメンバの一覧については、DataTableTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class DataTableTool : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool 全メンバ

DataTableTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AutoPosition | 凡例の位置を自動的に取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText | 凡例テキストをクリップします。
ColumnPen |
Description | 説明のテキストを取得します。
Font | 凡例テキストのフォント特性を定義します。
Inverted | 凡例の内容を反対方向に描画します。
Left | 凡例の左座標を定義します。ゼロに設定した場合、左座標は自動的に計算されます。
RowPen |
Summary | 詳細な説明テキストを取得します。
TableLegend |
Top | 凡例の上座標を定義します。ゼロに設定した場合、上座標は自動的に計算されます。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DataTableTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool コンストラクタ

オーバーロードの一覧

public DataTableTool()
public DataTableTool(Steema.TeeChart.Chart)

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool コンストラクタ

public DataTableTool()

参照

DataTableTool コンストラクタのオーバーロードの一覧 | DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool コンストラクタ

public DataTableTool(Chart c)

参照

DataTableTool コンストラクタのオーバーロードの一覧 | DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

DataTableTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DataTableTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.DataTableTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.DataTableTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


OnDisposing

Steema.TeeChart.Tools.DataTableTool.OnDisposing メソッド

protected internal abstract Void OnDisposing()

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.DataTableTool.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DataTableTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AutoPosition | 凡例の位置を自動的に取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText | 凡例テキストをクリップします。
ColumnPen |
Description | 説明のテキストを取得します。
Font | 凡例テキストのフォント特性を定義します。
Inverted | 凡例の内容を反対方向に描画します。
Left | 凡例の左座標を定義します。ゼロに設定した場合、左座標は自動的に計算されます。
RowPen |
Summary | 詳細な説明テキストを取得します。
TableLegend |
Top | 凡例の上座標を定義します。ゼロに設定した場合、上座標は自動的に計算されます。

参照

DataTableTool クラス | Steema.TeeChart.Tools 名前空間


AutoPosition

Steema.TeeChart.Tools.DataTableTool.AutoPosition プロパティ

凡例の位置を自動的に取得/設定します。
public Boolean AutoPosition {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


ClipText

Steema.TeeChart.Tools.DataTableTool.ClipText プロパティ

凡例テキストをクリップします。
public Boolean ClipText {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


ColumnPen

Steema.TeeChart.Tools.DataTableTool.ColumnPen プロパティ

public ChartPen ColumnPen {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.DataTableTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Font

Steema.TeeChart.Tools.DataTableTool.Font プロパティ

凡例テキストのフォント特性を定義します。
public ChartFont Font {get;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Inverted

Steema.TeeChart.Tools.DataTableTool.Inverted プロパティ

凡例の内容を反対方向に描画します。
public Boolean Inverted {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Left

Steema.TeeChart.Tools.DataTableTool.Left プロパティ

凡例の左座標を定義します。ゼロに設定した場合、左座標は自動的に計算されます。
public Int32 Left {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


RowPen

Steema.TeeChart.Tools.DataTableTool.RowPen プロパティ

public ChartPen RowPen {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.DataTableTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


TableLegend

Steema.TeeChart.Tools.DataTableTool.TableLegend プロパティ

public TableLegend TableLegend {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Top

Steema.TeeChart.Tools.DataTableTool.Top プロパティ

凡例の上座標を定義します。ゼロに設定した場合、上座標は自動的に計算されます。
public Int32 Top {get; set;}

参照

DataTableTool クラス | DataTableTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkDraggedEventHandler

Steema.TeeChart.Tools.DragMarkDraggedEventHandler デリゲート

public delegate DragMarkDraggedEventHandler (Object sender,
     DragMarkEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkDraggingEventHandler

Steema.TeeChart.Tools.DragMarkDraggingEventHandler デリゲート

public delegate DragMarkDraggingEventHandler (Object sender,
     DragMarkEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkEventArgs

Steema.TeeChart.Tools.DragMarkEventArgs クラス

この型のすべてのメンバの一覧については、DragMarkEventArgs メンバを参照してください。

System.Object
public class DragMarkEventArgs : Object

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkEventArgs 全メンバ

DragMarkEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Button | どのマウスボタンが押されたかを取得します。
Clicks | マウスが押されて、離された回数を取得します。
Delta | マウスホイールの回転回数を表す符合付きの数値を取得します。マウスホイールのノッチ 1つ分が1移動量に相当します。
Index | マーカの値インデックスを取得/設定します。
X | マウスイベントが発生している間のマウスのX座標を取得します。
Y | マウスイベントが発生している間のマウスのY座標を取得します。

参照

DragMarkEventArgs クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkEventArgs コンストラクタ

public DragMarkEventArgs(Int32 index,
     MouseEventArgs e)

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarkEventArgs プロパティ

パブリック プロパティ

Button | どのマウスボタンが押されたかを取得します。
Clicks | マウスが押されて、離された回数を取得します。
Delta | マウスホイールの回転回数を表す符合付きの数値を取得します。マウスホイールのノッチ 1つ分が1移動量に相当します。
Index | マーカの値インデックスを取得/設定します。
X | マウスイベントが発生している間のマウスのX座標を取得します。
Y | マウスイベントが発生している間のマウスのY座標を取得します。

参照

DragMarkEventArgs クラス | Steema.TeeChart.Tools 名前空間


Button

Steema.TeeChart.Tools.DragMarkEventArgs.Button プロパティ

どのマウスボタンが押されたかを取得します。
public MouseButtons Button {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Clicks

Steema.TeeChart.Tools.DragMarkEventArgs.Clicks プロパティ

マウスが押されて、離された回数を取得します。
public Int32 Clicks {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Delta

Steema.TeeChart.Tools.DragMarkEventArgs.Delta プロパティ

マウスホイールの回転回数を表す符合付きの数値を取得します。マウスホイールのノッチ 1つ分が1移動量に相当します。
public Int32 Delta {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Index

Steema.TeeChart.Tools.DragMarkEventArgs.Index プロパティ

マーカの値インデックスを取得/設定します。
public Int32 Index {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


X

Steema.TeeChart.Tools.DragMarkEventArgs.X プロパティ

マウスイベントが発生している間のマウスのX座標を取得します。
public Int32 X {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Y

Steema.TeeChart.Tools.DragMarkEventArgs.Y プロパティ

マウスイベントが発生している間のマウスのY座標を取得します。
public Int32 Y {get; set;}

参照

DragMarkEventArgs クラス | DragMarkEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks

Steema.TeeChart.Tools.DragMarks クラス

ドラッグマーカツール。

この型のすべてのメンバの一覧については、DragMarks メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class DragMarks : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks 全メンバ

DragMarks 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Dragged
Dragging

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明テキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
OnDragged
OnDragging
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DragMarks クラス | Steema.TeeChart.Tools 名前空間


DragMarks コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragMarks コンストラクタ

オーバーロードの一覧

public DragMarks()
public DragMarks(Steema.TeeChart.Chart)

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


DragMarks コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragMarks コンストラクタ

public DragMarks()

参照

DragMarks コンストラクタのオーバーロードの一覧 | DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


DragMarks コンストラクタ

Steema.TeeChart.Tools.DragMarks コンストラクタ

public DragMarks(Chart c)

参照

DragMarks コンストラクタのオーバーロードの一覧 | DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks イベント

パブリック イベント

Dragged
Dragging

参照

DragMarks クラス | Steema.TeeChart.Tools 名前空間


Dragged

Steema.TeeChart.Tools.DragMarks.Dragged イベント

public DragMarkDraggedEventHandler  Dragged

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Dragging

Steema.TeeChart.Tools.DragMarks.Dragging イベント

public DragMarkDraggingEventHandler  Dragging

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

DragMarks クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
OnDragged
OnDragging
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DragMarks クラス | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.DragMarks.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


OnDragged

Steema.TeeChart.Tools.DragMarks.OnDragged メソッド

protected abstract Void OnDragged(DragMarkEventArgs e)

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


OnDragging

Steema.TeeChart.Tools.DragMarks.OnDragging メソッド

protected abstract Void OnDragging(DragMarkEventArgs e)

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragMarks プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。

参照

DragMarks クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.DragMarks.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.DragMarks.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

DragMarks クラス | DragMarks メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint

Steema.TeeChart.Tools.DragPoint クラス

ドラッグポイントツール。

この型のすべてのメンバの一覧については、DragPoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class DragPoint : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint 全メンバ

DragPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Drag

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | ドラッグポイントツールで使用するマウスボタンを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Cursor | ドラッグポイントツールのマウスカーソルを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style |
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DragPoint クラス | Steema.TeeChart.Tools 名前空間


DragPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragPoint コンストラクタ

オーバーロードの一覧

public DragPoint(Steema.TeeChart.Chart)
public DragPoint(Steema.TeeChart.Styles.Series)
public DragPoint()

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


DragPoint コンストラクタ

Steema.TeeChart.Tools.DragPoint コンストラクタ

public DragPoint(Chart c)

参照

DragPoint コンストラクタのオーバーロードの一覧 | DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


DragPoint コンストラクタ

Steema.TeeChart.Tools.DragPoint コンストラクタ

public DragPoint(Series s)

参照

DragPoint コンストラクタのオーバーロードの一覧 | DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


DragPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragPoint コンストラクタ

public DragPoint()

参照

DragPoint コンストラクタのオーバーロードの一覧 | DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint イベント

パブリック イベント

Drag

参照

DragPoint クラス | Steema.TeeChart.Tools 名前空間


Drag

Steema.TeeChart.Tools.DragPoint.Drag イベント

public DragPointEventHandler  Drag

解説

このイベントは、系列ポイントをドラッグするためにマウスを移動させると発生します。

ドラッグの開始と終了の認識は、ChartのMouseDownイベントやMouseUpイベントが使用できます。

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

DragPoint クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DragPoint クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.DragPoint.Assign メソッド

protected abstract Void Assign(Tool t)

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.DragPoint.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPoint プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | ドラッグポイントツールで使用するマウスボタンを設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Cursor | ドラッグポイントツールのマウスカーソルを設定します。
Description | 説明文字列を取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style |

参照

DragPoint クラス | Steema.TeeChart.Tools 名前空間


Button

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragPoint.Button プロパティ

ドラッグポイントツールで使用するマウスボタンを設定します。

public MouseButtons Button {get; set;}

解説

ドラッグポイントツールで使用するマウスボタンを設定します。

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Cursor

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragPoint.Cursor プロパティ

ドラッグポイントツールのマウスカーソルを設定します。

public Cursor Cursor {get; set;}

解説

マウスカーソルが系列ポイント上に移動した際にポイントのドラッグが可能になったことを表すようにマウスカーソルを変更することができます。

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.DragPoint.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.DragPoint.Style プロパティ

public DragPointStyles Style {get; set;}

解説

デフォルト値：Both

系列ポイントのドラッグの方向を制御します（X、Y、両方）。

例

[#]

// 垂直方向のみポイントをドラッグできます。
dragPoint1.Style = Steema.TeeChart.Tools.DragPointStyles.Y;

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.DragPoint.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

DragPoint クラス | DragPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPointEventHandler

Steema.TeeChart.Tools.DragPointEventHandler デリゲート

ドラッグポイントツールのイベントハンドラ。
public delegate DragPointEventHandler (DragPoint sender,
     Int32 index)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DragPointStyles

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DragPointStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum DragPointStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
X | 水平方向のみポイントのドラッグを有効にします。
Y | 垂直方向のみポイントのドラッグを有効にします。
Both | 水平および垂直方向のポイントのドラッグを有効にします。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine

Steema.TeeChart.Tools.DrawLine クラス

ドローラインツール。

この型のすべてのメンバの一覧については、DrawLine メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class DrawLine : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine 全メンバ

DrawLine 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

DraggedLine
DragLine
NewLine
Select
Selecting

パブリック フィールド

FromPoint
ToPoint

パブリック メソッド

AxisPoint |
Clicked |
Clone (Toolの継承元) |
DeleteSelected |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ScreenPoint |
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | どのマウスボタンでドローラインツールを動作させるかを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
EnableDraw | ユーザがチャートに線を描くことを有効/無効にします。
EnableSelect | ドローラインツールを使用してチャート上に描かれた線の選択を有効/無効にします。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Lines | チャートに描画されている線のリストを返します。
Pen | ペン特性のエレメント。
Selected | 現在選択されている線を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
IHandle
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
ClipDrawingRegion
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DrawLine クラス | Steema.TeeChart.Tools 名前空間


DrawLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine コンストラクタ

オーバーロードの一覧

public DrawLine()
public DrawLine(Steema.TeeChart.Chart)

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


DrawLine コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine コンストラクタ

public DrawLine()

参照

DrawLine コンストラクタのオーバーロードの一覧 | DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


DrawLine コンストラクタ

Steema.TeeChart.Tools.DrawLine コンストラクタ

public DrawLine(Chart c)

参照

DrawLine コンストラクタのオーバーロードの一覧 | DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine イベント

パブリック イベント

DraggedLine
DragLine
NewLine
Select
Selecting

参照

DrawLine クラス | Steema.TeeChart.Tools 名前空間


DraggedLine

Steema.TeeChart.Tools.DrawLine.DraggedLine イベント

public DrawLineEventHandler  DraggedLine

解説

このイベントは、線が新しい位置にドラッグされると発生します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


DragLine

Steema.TeeChart.Tools.DrawLine.DragLine イベント

public DrawLineEventHandler  DragLine

解説

このイベントは、線をクリックしてドラッグを開始した際に発生します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


NewLine

Steema.TeeChart.Tools.DrawLine.NewLine イベント

public DrawLineEventHandler  NewLine

解説

このイベントは、新しい線が追加されると発生します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Select

Steema.TeeChart.Tools.DrawLine.Select イベント

public DrawLineEventHandler  Select

解説

このイベントは、線が選択されると（例：マウスで線をクリックすると）発生します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Selecting

Steema.TeeChart.Tools.DrawLine.Selecting イベント

public DrawLineSelectingEventHandler  Selecting

解説

このイベントは、線をマウスでクリックして選択すると発生します。

線を選択したくない場合は、AllowSelectパラメーターをfalseに設定してください。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine フィールド

パブリック フィールド

FromPoint
ToPoint

プロテクト フィールド

bBrush (Toolの継承元)
IHandle
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

DrawLine クラス | Steema.TeeChart.Tools 名前空間


FromPoint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.FromPoint フィールド

public Point FromPoint

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


IHandle

Steema.TeeChart.Tools.DrawLine.IHandle フィールド

protected DrawLineHandle IHandle

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


ToPoint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.ToPoint フィールド

public Point ToPoint

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine メソッド

パブリック メソッド

AxisPoint |
Clicked |
Clone (Toolの継承元) |
DeleteSelected |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ScreenPoint |
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
ClipDrawingRegion
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

DrawLine クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.DrawLine.Assign メソッド

protected abstract Void Assign(Tool t)

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


AxisPoint

Steema.TeeChart.Tools.DrawLine.AxisPoint メソッド

public Point AxisPoint(PointDouble p)

解説

垂直および水平軸スケールの｢P｣ポイントに一致する座標位置をピクセル単位で返します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Clicked

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.Clicked メソッド

public DrawLineItem Clicked(Int32 x,
     Int32 y)

解説

X、Yポイントにドローラインの線を返します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


ClipDrawingRegion

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.ClipDrawingRegion メソッド

protected Void ClipDrawingRegion()

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


DeleteSelected

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.DeleteSelected メソッド

public Void DeleteSelected()

解説

現在選択されているドローラインを削除します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.DrawLine.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


ScreenPoint

Steema.TeeChart.Tools.DrawLine.ScreenPoint メソッド

public PointDouble ScreenPoint(Point p)

解説

画面位置｢P｣の水平軸と垂直軸のそれぞれに一致するポイント値を返します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLine プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | どのマウスボタンでドローラインツールを動作させるかを定義します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
EnableDraw | ユーザがチャートに線を描くことを有効/無効にします。
EnableSelect | ドローラインツールを使用してチャート上に描かれた線の選択を有効/無効にします。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Lines | チャートに描画されている線のリストを返します。
Pen | ペン特性のエレメント。
Selected | 現在選択されている線を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。

参照

DrawLine クラス | Steema.TeeChart.Tools 名前空間


Button

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.Button プロパティ

どのマウスボタンでドローラインツールを動作させるかを定義します。

public MouseButtons Button {get; set;}

解説

デフォルト値：MouseButtons.Left

このプロパティは、どのマウスボタンでドローラインツールを動作させるかを定義します。
次の値が使用可能です。

MouseButtons.Left 左マウスボタンのドラッグによりチャート上に線を描きます。
MouseButtons.Right 右マウスボタンのドラッグによりチャート上に線を描きます。

MouseButtons.Middle 中央マウスボタンのドラッグによりチャート上に線を描きます。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.DrawLine.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


EnableDraw

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.EnableDraw プロパティ

ユーザがチャートに線を描くことを有効/無効にします。

public Boolean EnableDraw {get; set;}

解説

デフォルト値：true

ユーザが実行時にマウスを使用してチャートに線を描くことを有効/無効にします。
描かれた線はすべてLinesプロパティに保持されます。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


EnableSelect

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLine.EnableSelect プロパティ

ドローラインツールを使用してチャート上に描かれた線の選択を有効/無効にします。

public Boolean EnableSelect {get; set;}

解説

デフォルト値：true

ドローラインツールを使用してチャート上に描かれた線の選択を有効/無効にします。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Lines

Steema.TeeChart.Tools.DrawLine.Lines プロパティ

チャートに描画されている線のリストを返します。
public DrawLines Lines {get;}

解説

ユーザが実行時にチャートに描画した線のリストを返します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.DrawLine.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

解説

ペン特性のエレメント。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Selected

Steema.TeeChart.Tools.DrawLine.Selected プロパティ

現在選択されている線を返します。
public DrawLineItem Selected {get; set;}

解説

現在選択されている線を返します。
選択された線は、両端に選択を示す小さな正方形が表示されます。

選択された線が存在しない場合「nil」を返します。

このプロパティを「nil」に設定すると、現在の選択を削除（クリア）します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.DrawLine.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

DrawLine クラス | DrawLine メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineEventHandler

Steema.TeeChart.Tools.DrawLineEventHandler デリゲート

ドローラインツールのイベントハンドラ。
public delegate DrawLineEventHandler (DrawLine sender)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineHandle

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLineHandle 列挙体

DrawLine用のラインハンドルの配置。

[Serializable]
public enum DrawLineHandle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None |
Start |
End |
Series |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLineItem クラス

ドローラインツールの線。

この型のすべてのメンバの一覧については、DrawLineItem メンバを参照してください。

System.Object
public class DrawLineItem : Object

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem 全メンバ

DrawLineItem 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

DrawHandles

パブリック プロパティ

EndHandle | ドローラインの終了ハンドルのRectを返します。
EndPos |
Pen | ドローラインのペンを取得/設定します。
StartHandle | ドローラインの開始ハンドルのRectを返します。
StartPos |
Style |

参照

DrawLineItem クラス | Steema.TeeChart.Tools 名前空間


DrawLineItem コンストラクタ

Steema.TeeChart.Tools.DrawLineItem コンストラクタ

public DrawLineItem(DrawLine owner)

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem コンストラクタ

public DrawLineItem()

参照

DrawLineItem コンストラクタのオーバーロードの一覧 | DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem コンストラクタ

public DrawLineItem(DrawLine owner)

参照

DrawLineItem コンストラクタのオーバーロードの一覧 | DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem メソッド

パブリック メソッド

DrawHandles

参照

DrawLineItem クラス | Steema.TeeChart.Tools 名前空間


DrawHandles

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLineItem.DrawHandles メソッド

public Void DrawHandles()

解説

マウスドラッグによる再配置をするために、描画された線の両端にハンドルをつけます。

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


DrawHandles

Steema.TeeChart.Tools.DrawLineItem.DrawHandles メソッド

public Void DrawHandles(Graphics3D g)

参照

DrawHandles オーバーロードの一覧 | DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


DrawHandles

Steema.TeeChart.Tools.DrawLineItem.DrawHandles メソッド

public Void DrawHandles()

参照

DrawHandles オーバーロードの一覧 | DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineItem プロパティ

パブリック プロパティ

EndHandle | ドローラインの終了ハンドルのRectを返します。
Pen | ドローラインのペンを取得/設定します。
StartHandle | ドローラインの開始ハンドルのRectを返します。

参照

DrawLineItem クラス | Steema.TeeChart.Tools 名前空間


EndHandle

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLineItem.EndHandle プロパティ

ドローラインの終了ハンドルのRectを返します。

public Rectangle EndHandle {get;}

解説

ドローラインの終了ハンドルのRectを返します。

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


EndPos

Steema.TeeChart.Tools.DrawLineItem.EndPos プロパティ

public PointDouble EndPos {get; set;}

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.DrawLineItem.Pen プロパティ

ドローラインのペンを取得/設定します。
public ChartPen Pen {get; set;}

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


StartHandle

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLineItem.StartHandle プロパティ

ドローラインの開始ハンドルのRectを返します。

public Rectangle StartHandle {get;}

解説

ドローラインの開始ハンドルのRectを返します。

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


StartPos

Steema.TeeChart.Tools.DrawLineItem.StartPos プロパティ

public PointDouble StartPos {get; set;}

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.DrawLineItem.Style プロパティ

public DrawLineStyle Style {get; set;}

参照

DrawLineItem クラス | DrawLineItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLines

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLines クラス

DrawLineItemのコレクション。

この型のすべてのメンバの一覧については、DrawLines メンバを参照してください。

System.Object
System.Collections.CollectionBase
public class DrawLines : CollectionBase , IList, ICollection, IEnumerable

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLines 全メンバ

DrawLines 概要

コンストラクタ

Constructor

パブリック メソッド

Add
Clear
IndexOf
Remove

パブリック プロパティ

Item

参照

DrawLines クラス | Steema.TeeChart.Tools 名前空間


DrawLines コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLines コンストラクタ

public DrawLines()

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLines メソッド

パブリック メソッド

Add
Clear
IndexOf
Remove

参照

DrawLines クラス | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.DrawLines.Add メソッド

public Int32 Add(DrawLineItem l)

解説

ドローラインツールにコードで線を追加します。

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Clear

TeeChartプログラミングガイド

Steema.TeeChart.Tools.DrawLines.Clear メソッド

public Void Clear()

解説

このメソッドはすべての系列値を削除します。従属系列は通知されます。新しいポイントが系列に追加されない場合、何も描画されません。

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


IndexOf

Steema.TeeChart.Tools.DrawLines.IndexOf メソッド

public Int32 IndexOf(DrawLineItem l)

解説

線コレクション内の指定された線のインデックスを取得するために使用することができます。

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Remove

Steema.TeeChart.Tools.DrawLines.Remove メソッド

public Void Remove(DrawLineItem s)

解説

Linesのチャートリストから指定した線を削除します。

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLines プロパティ

パブリック プロパティ

Item

参照

DrawLines クラス | Steema.TeeChart.Tools 名前空間


Item

Steema.TeeChart.Tools.DrawLines.Item プロパティ

public DrawLineItem Item(Int32 index) {get;}

参照

DrawLines クラス | DrawLines メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineSelectingEventHandler

Steema.TeeChart.Tools.DrawLineSelectingEventHandler デリゲート

ドローラインツールの選択のイベントハンドラ。
public delegate DrawLineSelectingEventHandler (DrawLine sender,
     DrawLineItem line,
     Boolean& allow)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.DrawLineStyle

Steema.TeeChart.Tools.DrawLineStyle 列挙体

Styleプロパティの使用可能な値です。
[Serializable]
public sealed enum DrawLineStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Line | 開始ポイントと終了ポイント間に線を描きます。
HorizParallel | 開始ポイントと終了ポイントで指定された矩形範囲の上下に沿って水平線を2本描きます。
VertParallel | 開始ポイントと終了ポイントで指定された矩形範囲の左右に沿って垂直線を2本描きます。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ExtraLegend

Steema.TeeChart.Tools.ExtraLegend クラス

拡張凡例ツール。

この型のすべてのメンバの一覧については、ExtraLegend メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class ExtraLegend : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ExtraLegend 全メンバ

ExtraLegend 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Legend | 凡例の特性にアクセスします。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ExtraLegend クラス | Steema.TeeChart.Tools 名前空間


ExtraLegend コンストラクタ

Steema.TeeChart.Tools.ExtraLegend コンストラクタ

オーバーロードの一覧

public ExtraLegend()
public ExtraLegend(Steema.TeeChart.Chart)

参照

ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


ExtraLegend コンストラクタ

Steema.TeeChart.Tools.ExtraLegend コンストラクタ

public ExtraLegend()

参照

ExtraLegend コンストラクタのオーバーロードの一覧 | ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


ExtraLegend コンストラクタ

Steema.TeeChart.Tools.ExtraLegend コンストラクタ

public ExtraLegend(Chart c)

参照

ExtraLegend コンストラクタのオーバーロードの一覧 | ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ExtraLegend フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

ExtraLegend クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ExtraLegend メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ExtraLegend クラス | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.ExtraLegend.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Tools.ExtraLegend プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Legend | 凡例の特性にアクセスします。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

参照

ExtraLegend クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ExtraLegend.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間


Legend

Steema.TeeChart.Tools.ExtraLegend.Legend プロパティ

凡例の特性にアクセスします。
public Legend Legend {get; set;}

解説

凡例の特性にアクセスします。

参照

ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ExtraLegend.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

ExtraLegend クラス | ExtraLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderStyle

Steema.TeeChart.Tools.FaderStyle 列挙体

[Serializable]
public sealed enum FaderStyle : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
FadeIn |
FadeOut |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool

Steema.TeeChart.Tools.FaderTool クラス

フェーダツールクラス。

この型のすべてのメンバの一覧については、FaderTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class FaderTool : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool 全メンバ

FaderTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

FaderStop フェーダツールがストップされると発生します。

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Reset | チャートを最初の状態にリセットします。
Start | フェーダツールの機能をスタートします。
Stop | フェーダツールの機能をストップします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 完全にフェードアウトした時のチャート上に表示する色を設定/返します。
Description |
InitialDelay | フェーディング処理の開始と終了の間の遅延時間を設定/返します。
Speed | フェーディング処理のステップ数を設定/返します。
Style | フェーディング処理のスタイルを設定/返します。
Summary |

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
OnFaderStop
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

FaderTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool コンストラクタ

オーバーロードの一覧

public FaderTool()
public FaderTool(Steema.TeeChart.Chart)

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool コンストラクタ

public FaderTool()

参照

FaderTool コンストラクタのオーバーロードの一覧 | FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool コンストラクタ

public FaderTool(Chart c)

参照

FaderTool コンストラクタのオーバーロードの一覧 | FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool イベント

パブリック イベント

FaderStop フェーダツールがストップされると発生します。

参照

FaderTool クラス | Steema.TeeChart.Tools 名前空間


FaderStop

Steema.TeeChart.Tools.FaderTool.FaderStop イベント

フェーダツールがストップされると発生します。
public EventHandler  FaderStop

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

FaderTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Reset | チャートを最初の状態にリセットします。
Start | フェーダツールの機能をスタートします。
Stop | フェーダツールの機能をストップします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
OnFaderStop
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

FaderTool クラス | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.FaderTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


OnFaderStop

Steema.TeeChart.Tools.FaderTool.OnFaderStop メソッド

protected abstract Void OnFaderStop(EventArgs e)

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Reset

Steema.TeeChart.Tools.FaderTool.Reset メソッド

チャートを最初の状態にリセットします。
public Void Reset()

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Start

Steema.TeeChart.Tools.FaderTool.Start メソッド

フェーダツールの機能をスタートします。
public Void Start()

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Stop

Steema.TeeChart.Tools.FaderTool.Stop メソッド

フェーダツールの機能をストップします。
public Void Stop()

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FaderTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 完全にフェードアウトした時のチャート上に表示する色を設定/返します。
Description |
InitialDelay | フェーディング処理の開始と終了の間の遅延時間を設定/返します。
Speed | フェーディング処理のステップ数を設定/返します。
Style | フェーディング処理のスタイルを設定/返します。
Summary |

参照

FaderTool クラス | Steema.TeeChart.Tools 名前空間


Color

Steema.TeeChart.Tools.FaderTool.Color プロパティ

完全にフェードアウトした時のチャート上に表示する色を設定/返します。
public Color Color {get; set;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.FaderTool.Description プロパティ

public override String Description {get;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


InitialDelay

Steema.TeeChart.Tools.FaderTool.InitialDelay プロパティ

フェーディング処理の開始と終了の間の遅延時間を設定/返します。
public Int32 InitialDelay {get; set;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Speed

Steema.TeeChart.Tools.FaderTool.Speed プロパティ

フェーディング処理のステップ数を設定/返します。
public Double Speed {get; set;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.FaderTool.Style プロパティ

フェーディング処理のスタイルを設定/返します。
public FaderStyle Style {get; set;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.FaderTool.Summary プロパティ

public override String Summary {get;}

参照

FaderTool クラス | FaderTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciStyle

Steema.TeeChart.Tools.FibonacciStyle 列挙体

Levelsプロパティのスタイルを定義します。
[Serializable]
public sealed enum FibonacciStyle : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
Arc | フィボナッチの弧。
Fan | フィボナッチの扇。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool

Steema.TeeChart.Tools.FibonacciTool クラス

フィボナッチの扇形や弧の金融ツール。フィボナッチの扇形や弧をサポートするツールです。フィボナッチの弧は3つの曲線（これは主要な買い支えと抵抗レベルを予想するために描画されます）と境界範囲からなるチャート・テクニックです。フィボナッチの弧はまず2つのポイント（通常、指定した期間の高値と安値）間に非表示のトレンドラインを描画し、次に38.2%、50%、61.8%の主要なフィボナッチレベルでこのトレンドラインと交差する3つの曲線を描画して作成されます。フィボナッチの扇形はまず2つのポイント（通常、指定した期間の高値と安値）を通過するトレンドラインを描画し、次にその2つのポイント間の縦方向の距離を主要なフィボナッチの割合（38.2%、50%、61.8%）で除算して作成されます。これらの除算結果はそれぞれ縦方向の距離内で1ポイントを表します。次に左端のポイントから3つのそれぞれのフィボナッチの割合（38.2%、50%、61.8%）まで線を描画してその3つの「扇形」の線が作成されます。

この型のすべてのメンバの一覧については、FibonacciTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class FibonacciTool : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Tools.FibonacciTool 全メンバ

FibonacciTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

AxisPoint | 軸のXY値をdoubleから画面ピクセルに変換します。
Clone (Toolの継承元) |
CreateDefaultLevels | 38.2%、50%、61.8%にデフォルトのフィボナッチレベルを作成します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawStyle | フィボナッチツールの描画スタイルを定義します。ツールは、フィボナッチ弧とフィボナッチ扇をサポートします。
EndX | トレンドラインの終了ポイントのX座標を定義します。
EndY | トレンドラインの終了ポイントのY座標を定義します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
LabelsAngle | ラベルの角度を取得/設定します。
LabelsFont | ラベルのフォント特性を制御します。
Levels | フィボナッチのレベルリストを返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
ShowLabels | Trueの場合、個々のフィボナッチレベルのラベルを表示します。
StartX | トレンドラインの開始ポイントのX座標を定義します。
StartY | トレンドラインの開始ポイントのY座標を定義します。
Summary | 詳細な説明テキストを取得します。
TrendPen | トレンドのペン特性を定義します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
ClipDrawingRegion
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

FibonacciTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool コンストラクタ

オーバーロードの一覧

public FibonacciTool()
public FibonacciTool(Steema.TeeChart.Chart)

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool コンストラクタ

public FibonacciTool()

参照

FibonacciTool コンストラクタのオーバーロードの一覧 | FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool コンストラクタ

public FibonacciTool(Chart c)

参照

FibonacciTool コンストラクタのオーバーロードの一覧 | FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

FibonacciTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool メソッド

パブリック メソッド

AxisPoint | 軸のXY値をdoubleから画面ピクセルに変換します。
Clone (Toolの継承元) |
CreateDefaultLevels | 38.2%、50%、61.8%にデフォルトのフィボナッチレベルを作成します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
ClipDrawingRegion
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

FibonacciTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.FibonacciTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


AxisPoint

Steema.TeeChart.Tools.FibonacciTool.AxisPoint メソッド

軸のXY値をdoubleから画面ピクセルに変換します。
public Point AxisPoint(Double x,
     Double y)

パラメーター

p
軸ポイント座標

戻り値

画面ポイント座標

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.FibonacciTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


ClipDrawingRegion

Steema.TeeChart.Tools.FibonacciTool.ClipDrawingRegion メソッド

protected Void ClipDrawingRegion()

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


CreateDefaultLevels

Steema.TeeChart.Tools.FibonacciTool.CreateDefaultLevels メソッド

38.2%、50%、61.8%にデフォルトのフィボナッチレベルを作成します。
public Void CreateDefaultLevels()

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawStyle | フィボナッチツールの描画スタイルを定義します。ツールは、フィボナッチ弧とフィボナッチ扇をサポートします。
EndX | トレンドラインの終了ポイントのX座標を定義します。
EndY | トレンドラインの終了ポイントのY座標を定義します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
LabelsAngle | ラベルの角度を取得/設定します。
LabelsFont | ラベルのフォント特性を制御します。
Levels | フィボナッチのレベルリストを返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
ShowLabels | Trueの場合、個々のフィボナッチレベルのラベルを表示します。
StartX | トレンドラインの開始ポイントのX座標を定義します。
StartY | トレンドラインの開始ポイントのY座標を定義します。
Summary | 詳細な説明テキストを取得します。
TrendPen | トレンドのペン特性を定義します。

参照

FibonacciTool クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.FibonacciTool.Description プロパティ

public override String Description {get;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


DrawStyle

Steema.TeeChart.Tools.FibonacciTool.DrawStyle プロパティ

フィボナッチツールの描画スタイルを定義します。ツールは、フィボナッチ弧とフィボナッチ扇をサポートします。
public FibonacciStyle DrawStyle {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


EndX

Steema.TeeChart.Tools.FibonacciTool.EndX プロパティ

トレンドラインの終了ポイントのX座標を定義します。
public Double EndX {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


EndY

Steema.TeeChart.Tools.FibonacciTool.EndY プロパティ

トレンドラインの終了ポイントのY座標を定義します。
public Double EndY {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


LabelsAngle

Steema.TeeChart.Tools.FibonacciTool.LabelsAngle プロパティ

ラベルの角度を取得/設定します。
public Int32 LabelsAngle {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


LabelsFont

Steema.TeeChart.Tools.FibonacciTool.LabelsFont プロパティ

ラベルのフォント特性を制御します。
public ChartFont LabelsFont {get;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Levels

Steema.TeeChart.Tools.FibonacciTool.Levels プロパティ

フィボナッチのレベルリストを返します。
public FibonacciLevels Levels {get;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


ShowLabels

Steema.TeeChart.Tools.FibonacciTool.ShowLabels プロパティ

Trueの場合、個々のフィボナッチレベルのラベルを表示します。
public Boolean ShowLabels {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


StartX

Steema.TeeChart.Tools.FibonacciTool.StartX プロパティ

トレンドラインの開始ポイントのX座標を定義します。
public Double StartX {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


StartY

Steema.TeeChart.Tools.FibonacciTool.StartY プロパティ

トレンドラインの開始ポイントのY座標を定義します。
public Double StartY {get; set;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.FibonacciTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


TrendPen

Steema.TeeChart.Tools.FibonacciTool.TrendPen プロパティ

トレンドのペン特性を定義します。
public ChartPen TrendPen {get;}

参照

FibonacciTool クラス | FibonacciTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciItem

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem クラス

個々のフィボナッチレベルの特性です。

この型のすべてのメンバの一覧については、FibonacciItem メンバを参照してください。

System.Object
public class FibonacciItem : Object

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

FibonacciItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciItem 全メンバ

FibonacciItem 概要

コンストラクタ

Steema.TeeChart.Tools.FibonacciTool.FibonacciItem..ctor

パブリック プロパティ

Pen | 個々のフィボナッチレベルのペン特性を定義します。
Value | 範囲(0,100)でフィボナッチの弧の値を定義します。

参照

FibonacciItem クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool+FibonacciItem コンストラクタ

public FibonacciTool+FibonacciItem(FibonacciTool owner,
     Double value)

参照

FibonacciItem クラス | FibonacciItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciItem プロパティ

パブリック プロパティ

Pen | 個々のフィボナッチレベルのペン特性を定義します。
Value | 範囲(0,100)でフィボナッチの弧の値を定義します。

参照

FibonacciItem クラス | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.FibonacciTool+FibonacciItem.Pen プロパティ

個々のフィボナッチレベルのペン特性を定義します。
public ChartPen Pen {get;}

参照

FibonacciItem クラス | FibonacciItem メンバ | Steema.TeeChart.Tools 名前空間


Value

Steema.TeeChart.Tools.FibonacciTool+FibonacciItem.Value プロパティ

範囲(0,100)でフィボナッチの弧の値を定義します。
public Double Value {get; set;}

参照

FibonacciItem クラス | FibonacciItem メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels クラス

すべての弧のコレクション。

この型のすべてのメンバの一覧については、FibonacciLevels メンバを参照してください。

System.Object
System.Collections.CollectionBase
public class FibonacciLevels : CollectionBase , IList, ICollection
, IEnumerable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels 全メンバ

FibonacciLevels 概要

コンストラクタ

Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels..ctor

パブリック メソッド

Add
Clear
IndexOf
Remove

パブリック プロパティ

Item

参照

FibonacciLevels クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels コンストラクタ

public FibonacciTool+FibonacciLevels()

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels メソッド

パブリック メソッド

Add
Clear
IndexOf
Remove

参照

FibonacciLevels クラス | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Add メソッド

public Int32 Add(FibonacciItem l)

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Clear

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Clear メソッド

public Void Clear()

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


IndexOf

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.IndexOf メソッド

public Int32 IndexOf(FibonacciItem l)

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Remove

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Remove メソッド

public Void Remove(FibonacciItem s)

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.FibonacciTool.FibonacciLevels プロパティ

パブリック プロパティ

Item

参照

FibonacciLevels クラス | Steema.TeeChart.Tools 名前空間


Item

Steema.TeeChart.Tools.FibonacciTool+FibonacciLevels.Item プロパティ

public FibonacciItem Item(Int32 index) {get;}

参照

FibonacciLevels クラス | FibonacciLevels メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttBarPart

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttBarPart 列挙体

内部使用。ガントツールの位置をサポートします。

[Serializable]
public enum GanttBarPart : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Start |
All |
End |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttDragEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttDragEventArgs クラス

GanttDragEventHandlerのEventArgs

この型のすべてのメンバの一覧については、GanttDragEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class GanttDragEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

GanttDragEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttDragEventArgs 全メンバ

GanttDragEventArgs 概要

コンストラクタ

Constructor

パブリック フィールド

Bar

参照

GanttDragEventArgs クラス | Steema.TeeChart.Tools 名前空間


GanttDragEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttDragEventArgs コンストラクタ

public GanttDragEventArgs(Int32 bar)

参照

GanttDragEventArgs クラス | GanttDragEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttDragEventArgs フィールド

パブリック フィールド

Bar

参照

GanttDragEventArgs クラス | Steema.TeeChart.Tools 名前空間


Bar

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttDragEventArgs.Bar フィールド

public Int32 Bar

参照

GanttDragEventArgs クラス | GanttDragEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttDragEventHandler

Steema.TeeChart.Tools.GanttDragEventHandler デリゲート

ガントバーがドラッグされた時に呼び出される、ガントツールのイベントハンドラ。
public delegate GanttDragEventHandler (Object sender,
     GanttDragEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttResizeEventArgs

Steema.TeeChart.Tools.GanttResizeEventArgs クラス

GanttResizeEventHandlerのEventArgs。

この型のすべてのメンバの一覧については、GanttResizeEventArgs メンバを参照してください。

System.Object
System.EventArgs
Steema.TeeChart.Tools.GanttDragEventArgs
public class GanttResizeEventArgs : GanttDragEventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

GanttResizeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttResizeEventArgs 全メンバ

GanttResizeEventArgs 概要

コンストラクタ

Constructor

パブリック フィールド

Bar (GanttDragEventArgsの継承元)
Part

参照

GanttResizeEventArgs クラス | Steema.TeeChart.Tools 名前空間


GanttResizeEventArgs コンストラクタ

Steema.TeeChart.Tools.GanttResizeEventArgs コンストラクタ

public GanttResizeEventArgs(Int32 bar,
     GanttBarPart part)

参照

GanttResizeEventArgs クラス | GanttResizeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttResizeEventArgs フィールド

パブリック フィールド

Bar (GanttDragEventArgsの継承元)
Part

参照

GanttResizeEventArgs クラス | Steema.TeeChart.Tools 名前空間


Part

Steema.TeeChart.Tools.GanttResizeEventArgs.Part フィールド

public GanttBarPart Part

参照

GanttResizeEventArgs クラス | GanttResizeEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttResizeEventHandler

Steema.TeeChart.Tools.GanttResizeEventHandler デリゲート

ガントバーがリサイズされた時に呼び出される、ガントツールのイベントハンドラ。
public delegate GanttResizeEventHandler (Object sender,
     GanttResizeEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool

Steema.TeeChart.Tools.GanttTool クラス

ガントドラッグツール。

この型のすべてのメンバの一覧については、GanttTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class GanttTool : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool 全メンバ

GanttTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

DragBar
ResizeBar

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag |
AllowResize |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CursorDrag |
CursorResize |
Description | 説明のテキストを取得します。
Gantt |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
MinPixels |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GanttTool クラス | Steema.TeeChart.Tools 名前空間


GanttTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool コンストラクタ

オーバーロードの一覧

public GanttTool()
public GanttTool(Steema.TeeChart.Chart)

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


GanttTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool コンストラクタ

public GanttTool()

参照

GanttTool コンストラクタのオーバーロードの一覧 | GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


GanttTool コンストラクタ

Steema.TeeChart.Tools.GanttTool コンストラクタ

public GanttTool(Chart c)

参照

GanttTool コンストラクタのオーバーロードの一覧 | GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool イベント

パブリック イベント

DragBar
ResizeBar

参照

GanttTool クラス | Steema.TeeChart.Tools 名前空間


DragBar

Steema.TeeChart.Tools.GanttTool.DragBar イベント

public GanttDragEventHandler  DragBar

解説

このイベントは、ガントバーをドラッグしている間に発生します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


ResizeBar

Steema.TeeChart.Tools.GanttTool.ResizeBar イベント

public GanttResizeEventHandler  ResizeBar

解説

このイベントは、ガントバーをリサイズすると発生します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

GanttTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GanttTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.GanttTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.GanttTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GanttTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag |
AllowResize |
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
CursorDrag |
CursorResize |
Description | 説明文字列を取得します。
Gantt |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
MinPixels |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。

参照

GanttTool クラス | Steema.TeeChart.Tools 名前空間


AllowDrag

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool.AllowDrag プロパティ

public Boolean AllowDrag {get; set;}

解説

デフォルト値：true

trueの場合、マウスを使用してガント系列のバーをクリックやドラッグできます。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


AllowResize

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool.AllowResize プロパティ

public Boolean AllowResize {get; set;}

解説

デフォルト値：true

trueの場合、ガント系列のバーをリサイズするためにマウスが使用できます。

ガントバーをリサイズするために、ガントバーの端（左あるいは右）をマウスでクリックおよびドラッグしてください。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


CursorDrag

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool.CursorDrag プロパティ

public Cursor CursorDrag {get; set;}

解説

デフォルト値：HandPoint

ガントバーのドラッグ中に表示するカーソルを定義します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


CursorResize

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool.CursorResize プロパティ

public Cursor CursorResize {get; set;}

解説

デフォルト値：SizeWE

ガント系列のバーの端（左あるいは右）にマウスが移動した際のカーソルを設定します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.GanttTool.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Gantt

Steema.TeeChart.Tools.GanttTool.Gantt プロパティ

public Gantt Gantt {get; set;}

解説

このツールに関連付けられているガント系列を返します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


MinPixels

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GanttTool.MinPixels プロパティ

public Int32 MinPixels {get; set;}

解説

デフォルト値：5

ガントバーをリサイズする際に、マウスカーソルがガントバーの端（左あるいは右）に移動すると指定したマウスカーソルに切り替わります。このプロパティはマウスカーソルがガントバーの端（左あるいは右）に移動したと認識させる最小距離を画面ピクセル単位で設定します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.GanttTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

GanttTool クラス | GanttTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridBand

Steema.TeeChart.Tools.GridBand クラス

グリッドバンドツール。指定した軸や位置のグリッド線に色付けされた矩形（バンド）を表示するために使用します。

この型のすべてのメンバの一覧については、GridBand メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolAxis
public class GridBand : ToolAxis , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

GridBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridBand 全メンバ

GridBand 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Band1 | グリッドバンドツールの最初のバンドのブラシ特性について定義します。
Band2 | グリッドバンドツールの2番目のバンドのブラシ特性について定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GridBand クラス | Steema.TeeChart.Tools 名前空間


GridBand コンストラクタ

Steema.TeeChart.Tools.GridBand コンストラクタ

オーバーロードの一覧

public GridBand()
public GridBand(Steema.TeeChart.Chart)

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


GridBand コンストラクタ

Steema.TeeChart.Tools.GridBand コンストラクタ

public GridBand()

参照

GridBand コンストラクタのオーバーロードの一覧 | GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


GridBand コンストラクタ

Steema.TeeChart.Tools.GridBand コンストラクタ

public GridBand(Chart c)

参照

GridBand コンストラクタのオーバーロードの一覧 | GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridBand フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis (ToolAxisの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

GridBand クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridBand メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis (ToolAxisの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GridBand クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.GridBand.Assign メソッド

protected abstract Void Assign(Tool t)

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.GridBand.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Steema.TeeChart.Tools.GridBand プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis (ToolAxisの継承元) | ツールを適用させる軸を設定します。
Band1 | グリッドバンドツールの最初のバンドのブラシ特性について定義します。
Band2 | グリッドバンドツールの2番目のバンドのブラシ特性について定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Pen (ToolAxisの継承元) | ペン特性のエレメント。
Summary | 詳細な説明テキストを取得します。

参照

GridBand クラス | Steema.TeeChart.Tools 名前空間

© 2002-2006 Steema Software SL. All rights reserved.


Band1

Steema.TeeChart.Tools.GridBand.Band1 プロパティ

グリッドバンドツールの最初のバンドのブラシ特性について定義します。
public ChartBrush Band1 {get; set;}

解説

グリッドバンドツールの最初のバンドのブラシ特性について定義します。

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


Band2

Steema.TeeChart.Tools.GridBand.Band2 プロパティ

グリッドバンドツールの2番目のバンドのブラシ特性について定義します。
public ChartBrush Band2 {get; set;}

解説

グリッドバンドツールの2番目のバンドのブラシ特性について定義します。

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.GridBand.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.GridBand.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

GridBand クラス | GridBand メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridTranspose

Steema.TeeChart.Tools.GridTranspose クラス

3Dグリッド置換ツール。

この型のすべてのメンバの一覧については、GridTranspose メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class GridTranspose : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridTranspose 全メンバ

GridTranspose 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |
Transpose |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Series |
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GridTranspose クラス | Steema.TeeChart.Tools 名前空間


GridTranspose コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GridTranspose コンストラクタ

オーバーロードの一覧

public GridTranspose()
public GridTranspose(Steema.TeeChart.Chart)

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


GridTranspose コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GridTranspose コンストラクタ

public GridTranspose()

参照

GridTranspose コンストラクタのオーバーロードの一覧 | GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


GridTranspose コンストラクタ

Steema.TeeChart.Tools.GridTranspose コンストラクタ

public GridTranspose(Chart c)

参照

GridTranspose コンストラクタのオーバーロードの一覧 | GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridTranspose フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

GridTranspose クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridTranspose メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |
Transpose |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

GridTranspose クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.GridTranspose.Assign メソッド

protected abstract Void Assign(Tool t)

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Transpose

TeeChartプログラミングガイド

Steema.TeeChart.Tools.GridTranspose.Transpose メソッド

public Void Transpose()

解説

3Dグリッド系列において、X値をZ値と交換します。

例

[C#]

gridTranspose1.Series = surface1;
gridTranspose1.Transpose();

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.GridTranspose プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
Series |

参照

GridTranspose クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.GridTranspose.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Series

Steema.TeeChart.Tools.GridTranspose.Series プロパティ

public Custom3DGrid Series {get; set;}

解説

置換する3Dグリッド系列を取得/設定します。

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.GridTranspose.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

GridTranspose クラス | GridTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.HotspotHelperScripts

Steema.TeeChart.Tools.HotspotHelperScripts 列挙体

ASP.NETチャートのクライアント側の機能を提供するTeeChartのヘルパースクリプトです。

[Serializable]
public sealed enum HotspotHelperScripts : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | TeeChartのクライアントのヘルパー機能を適用しません。
Annotation | マウスオーバーで位置付けしたテキストやイメージを動的に表示するためにアノテーションのヘルパースクリプトを適用します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.IHotspot

Steema.TeeChart.Tools.IHotspot インターフェイス

内部使用。ホットスポットツールの識別インターフェイスです。

public interface IHotspot

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

IHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.IHotspot 全メンバ

IHotspot 概要

パブリック メソッド

GenerateMap

パブリック プロパティ

MapElements

参照

IHotspot インターフェイス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.IHotspot メソッド

パブリック メソッド

GenerateMap

参照

IHotspot インターフェイス | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.IHotspot.GenerateMap メソッド

オーバーロードの一覧

public abstract String GenerateMap()
public abstract String GenerateMap(System.Drawing.Rectangle)

参照

IHotspot インターフェイス | IHotspot メンバ | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.IHotspot.GenerateMap メソッド

public abstract String GenerateMap()

参照

GenerateMap オーバーロードの一覧 | IHotspot インターフェイス | IHotspot メンバ | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.IHotspot.GenerateMap メソッド

public abstract String GenerateMap(Rectangle bounds)

参照

GenerateMap オーバーロードの一覧 | IHotspot インターフェイス | IHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.IHotspot プロパティ

パブリック プロパティ

MapElements

参照

IHotspot インターフェイス | Steema.TeeChart.Tools 名前空間


MapElements

Steema.TeeChart.Tools.IHotspot.MapElements プロパティ

public abstract String MapElements {get; set;}

参照

IHotspot インターフェイス | IHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette

Steema.TeeChart.Tools.LegendPalette クラス

この型のすべてのメンバの一覧については、LegendPalette メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class LegendPalette : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette 全メンバ

LegendPalette 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis |
Border |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Height |
Inverted |
Left |
Pen |
PositionUnits |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Smooth |
Summary | 詳細な説明テキストを取得します。
Top |
Transparent |
Vertical |
Width |

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

LegendPalette クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette コンストラクタ

オーバーロードの一覧

public LegendPalette()
public LegendPalette(Steema.TeeChart.Chart)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette コンストラクタ

public LegendPalette()

参照

LegendPalette コンストラクタのオーバーロードの一覧 | LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette コンストラクタ

public LegendPalette(Chart c)

参照

LegendPalette コンストラクタのオーバーロードの一覧 | LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

LegendPalette クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

LegendPalette クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.LegendPalette.Assign メソッド

protected abstract Void Assign(Tool t)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.LegendPalette.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Dispose

Steema.TeeChart.Tools.LegendPalette.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.LegendPalette.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.LegendPalette.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


SetSeries

Steema.TeeChart.Tools.LegendPalette.SetSeries メソッド

protected abstract Void SetSeries(Series value)

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPalette プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis |
Border |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Height |
Inverted |
Left |
Pen |
PositionUnits |
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Smooth |
Summary | 詳細な説明テキストを取得します。
Top |
Transparent |
Vertical |
Width |

参照

LegendPalette クラス | Steema.TeeChart.Tools 名前空間


Axis

Steema.TeeChart.Tools.LegendPalette.Axis プロパティ

public LegendPaletteAxis Axis {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Border

Steema.TeeChart.Tools.LegendPalette.Border プロパティ

public ChartPen Border {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.LegendPalette.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Gradient

Steema.TeeChart.Tools.LegendPalette.Gradient プロパティ

public Gradient Gradient {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Height

Steema.TeeChart.Tools.LegendPalette.Height プロパティ

public Int32 Height {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Inverted

Steema.TeeChart.Tools.LegendPalette.Inverted プロパティ

public Boolean Inverted {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Left

Steema.TeeChart.Tools.LegendPalette.Left プロパティ

public Int32 Left {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.LegendPalette.Pen プロパティ

public ChartPen Pen {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


PositionUnits

Steema.TeeChart.Tools.LegendPalette.PositionUnits プロパティ

public PositionUnits PositionUnits {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Smooth

Steema.TeeChart.Tools.LegendPalette.Smooth プロパティ

public Boolean Smooth {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.LegendPalette.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Top

Steema.TeeChart.Tools.LegendPalette.Top プロパティ

public Int32 Top {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Transparent

Steema.TeeChart.Tools.LegendPalette.Transparent プロパティ

public Boolean Transparent {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Vertical

Steema.TeeChart.Tools.LegendPalette.Vertical プロパティ

public Boolean Vertical {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Width

Steema.TeeChart.Tools.LegendPalette.Width プロパティ

public Int32 Width {get; set;}

参照

LegendPalette クラス | LegendPalette メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendPaletteAxis

Steema.TeeChart.Tools.LegendPaletteAxis 列挙体

[Serializable]
public sealed enum LegendPaletteAxis : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
laDefault | デフォルト軸を使用。
laOther | その他の軸を使用。
laBoth | 両方の軸を使用。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar

Steema.TeeChart.Tools.LegendScrollBar クラス

凡例スクロールバーツール。

この型のすべてのメンバの一覧については、LegendScrollBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ScrollBar
public class LegendScrollBar : ScrollBar , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar 全メンバ

LegendScrollBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

ChangeSize (ScrollBarの継承元)
Scrolled (ScrollBarの継承元)
SetPosition (ScrollBarの継承元)

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
MainRectangle (ScrollBarの継承元) | スクロールバーの境界矩形を返します。
ScrollRectangle (ScrollBarの継承元) | スクロールバーのサムの境界矩形を返します。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
ArrowBrush (ScrollBarの継承元) | 上/下や右/下の矢印を塗りつぶすブラシを定義します。
AutoRepeat (ScrollBarの継承元) | Trueの場合（デフォルト）、マウスボタンを押したままの状態にするとスクロールし続けます。
Bevel (ScrollBarの継承元) | スクロールバーの枠のスタイルを定義します。
Brush (ScrollBarの継承元) | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description (ScrollBarの継承元) | 説明のテキストを取得します。
DrawStyle (ScrollBarの継承元) | スクロールバーの表示スタイルを定義します。値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。
Gradient (ScrollBarの継承元) | スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。
Horizontal (ScrollBarの継承元) | Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。
InitialDelay (ScrollBarの継承元) | オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。AutoRepeatプロパティを参照してください。
MinThumbSize (ScrollBarの継承元) | スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。
Pen (ScrollBarの継承元) | ペン特性のエレメント。
Position (ScrollBarの継承元) | スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。Sizeプロパティを参照してください。
Size (ScrollBarの継承元) | スクロールバー全体の大きさを取得/設定します。Positionプロパティを参照してください。
Summary | 詳細な説明テキストを取得します。
ThumbBrush (ScrollBarの継承元) | スクロールバーのサムを塗りつぶすブラシを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
Max (ScrollBarの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
ThumbLength (ScrollBarの継承元)

プロテクト メソッド

Assign (Toolの継承元)
CalcDelta (ScrollBarの継承元)
ChartEvent (ScrollBarの継承元)
CurrentCount
DeltaMain
Dispose (Toolの継承元)
Draw (ScrollBarの継承元)
DrawArrows (ScrollBarの継承元)
GetPosition
KeyEvent (Toolの継承元)
MouseEvent (ScrollBarの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (ScrollBarの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetIPosition
SetStringProperty (TeeBaseの継承元)
ShouldDraw
TotalCount

プロテクト プロパティ

R (ScrollBarの継承元)

参照

LegendScrollBar クラス | Steema.TeeChart.Tools 名前空間


LegendScrollBar コンストラクタ

Steema.TeeChart.Tools.LegendScrollBar コンストラクタ

オーバーロードの一覧

public LegendScrollBar()
public LegendScrollBar(Steema.TeeChart.Chart)

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


LegendScrollBar コンストラクタ

Steema.TeeChart.Tools.LegendScrollBar コンストラクタ

public LegendScrollBar()

参照

LegendScrollBar コンストラクタのオーバーロードの一覧 | LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


LegendScrollBar コンストラクタ

Steema.TeeChart.Tools.LegendScrollBar コンストラクタ

public LegendScrollBar(Chart c)

参照

LegendScrollBar コンストラクタのオーバーロードの一覧 | LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar イベント

パブリック イベント

ChangeSize (ScrollBarの継承元)
Scrolled (ScrollBarの継承元)
SetPosition (ScrollBarの継承元)

参照

LegendScrollBar クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
Max (ScrollBarの継承元)
pPen (Toolの継承元)
ThumbLength (ScrollBarの継承元)

参照

LegendScrollBar クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
MainRectangle (ScrollBarの継承元) | スクロールバーの境界矩形を返します。
ScrollRectangle (ScrollBarの継承元) | スクロールバーのサムの境界矩形を返します。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Toolの継承元)
CalcDelta (ScrollBarの継承元)
ChartEvent (ScrollBarの継承元)
CurrentCount
DeltaMain
Dispose (Toolの継承元)
Draw (ScrollBarの継承元)
DrawArrows (ScrollBarの継承元)
GetPosition
KeyEvent (Toolの継承元)
MouseEvent (ScrollBarの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (ScrollBarの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetIPosition
SetStringProperty (TeeBaseの継承元)
ShouldDraw
TotalCount

参照

LegendScrollBar クラス | Steema.TeeChart.Tools 名前空間


CurrentCount

Steema.TeeChart.Tools.LegendScrollBar.CurrentCount メソッド

protected abstract Int32 CurrentCount()

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


DeltaMain

Steema.TeeChart.Tools.LegendScrollBar.DeltaMain メソッド

protected abstract Int32 DeltaMain()

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


GetPosition

Steema.TeeChart.Tools.LegendScrollBar.GetPosition メソッド

protected abstract Int32 GetPosition()

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


SetIPosition

Steema.TeeChart.Tools.LegendScrollBar.SetIPosition メソッド

protected abstract Void SetIPosition(Int32 value)

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ShouldDraw

Steema.TeeChart.Tools.LegendScrollBar.ShouldDraw メソッド

protected abstract Boolean ShouldDraw()

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


TotalCount

Steema.TeeChart.Tools.LegendScrollBar.TotalCount メソッド

protected abstract Int32 TotalCount()

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LegendScrollBar プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
ArrowBrush (ScrollBarの継承元) | 上/下や右/下の矢印を塗りつぶすブラシを定義します。
AutoRepeat (ScrollBarの継承元) | Trueの場合（デフォルト）、マウスボタンを押したままの状態にするとスクロールし続けます。
Bevel (ScrollBarの継承元) | スクロールバーの枠のスタイルを定義します。
Brush (ScrollBarの継承元) | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description (ScrollBarの継承元) | 説明のテキストを取得します。
DrawStyle (ScrollBarの継承元) | スクロールバーの表示スタイルを定義します。値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。
Gradient (ScrollBarの継承元) | スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。
Horizontal (ScrollBarの継承元) | Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。
InitialDelay (ScrollBarの継承元) | オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。AutoRepeatプロパティを参照してください。
MinThumbSize (ScrollBarの継承元) | スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。
Pen (ScrollBarの継承元) | ペン特性のエレメント。
Position (ScrollBarの継承元) | スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。Sizeプロパティを参照してください。
Size (ScrollBarの継承元) | スクロールバー全体の大きさを取得/設定します。Positionプロパティを参照してください。
Summary | 詳細な説明テキストを取得します。
ThumbBrush (ScrollBarの継承元) | スクロールバーのサムを塗りつぶすブラシを取得します。

プロテクト プロパティ

R (ScrollBarの継承元)

参照

LegendScrollBar クラス | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.LegendScrollBar.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

LegendScrollBar クラス | LegendScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightStyle

Steema.TeeChart.Tools.LightStyle 列挙体

2D 照明ツールのライトのスタイルを定義します。
[Serializable]
public sealed enum LightStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Linear | 照明は左上位置周辺になります。
SpotLight | 照明はスポットライトになります。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightTool

Steema.TeeChart.Tools.LightTool クラス

このツールは、チャートコントロール上部で2次元のライトスポットを表示するために使用してください。

この型のすべてのメンバの一覧については、LightTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class LightTool : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

LightTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightTool 全メンバ

LightTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Iluminate | ParentChartキャンバス上の照明効果を適用します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Factor | 最大のチャート寸法のパーセンテージで「ライトスポット」のサイズを定義します。
FollowMouse | trueの場合、ライトスポットはマウスの移動に合わせて移動します。falseの場合、左上のピクセル座標を設定できます。
Left | ライトスポットの中央の水平座標をピクセル単位で定義します。
Style | 照明のスタイルを取得/設定します。
Summary | 詳細な説明テキストを取得します。
Top | ライトスポットの中央の垂直座標をピクセル単位で定義します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

LightTool クラス | Steema.TeeChart.Tools 名前空間


LightTool コンストラクタ

Steema.TeeChart.Tools.LightTool コンストラクタ

オーバーロードの一覧

public LightTool()
public LightTool(Steema.TeeChart.Chart)

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


LightTool コンストラクタ

Steema.TeeChart.Tools.LightTool コンストラクタ

public LightTool()

参照

LightTool コンストラクタのオーバーロードの一覧 | LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


LightTool コンストラクタ

Steema.TeeChart.Tools.LightTool コンストラクタ

public LightTool(Chart c)

参照

LightTool コンストラクタのオーバーロードの一覧 | LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

LightTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Iluminate | ParentChartキャンバス上の照明効果を適用します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

LightTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.LightTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.LightTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Iluminate

Steema.TeeChart.Tools.LightTool.Iluminate メソッド

ParentChartキャンバス上の照明効果を適用します。
public Void Iluminate()

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.LightTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.LightTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Factor | 最大のチャート寸法のパーセンテージで「ライトスポット」のサイズを定義します。
FollowMouse | trueの場合、ライトスポットはマウスの移動に合わせて移動します。falseの場合、左上のピクセル座標を設定できます。
Left | ライトスポットの中央の水平座標をピクセル単位で定義します。
Style | 照明のスタイルを取得/設定します。
Summary | 詳細な説明テキストを取得します。
Top | ライトスポットの中央の垂直座標をピクセル単位で定義します。

参照

LightTool クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.LightTool.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Factor

Steema.TeeChart.Tools.LightTool.Factor プロパティ

最大のチャート寸法のパーセンテージで「ライトスポット」のサイズを定義します。
public Double Factor {get; set;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


FollowMouse

Steema.TeeChart.Tools.LightTool.FollowMouse プロパティ

trueの場合、ライトスポットはマウスの移動に合わせて移動します。 falseの場合、左上のピクセル座標を設定できます。
public Boolean FollowMouse {get; set;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Left

Steema.TeeChart.Tools.LightTool.Left プロパティ

ライトスポットの中央の水平座標をピクセル単位で定義します。
public Int32 Left {get; set;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.LightTool.Style プロパティ

照明のスタイルを取得/設定します。
public LightStyle Style {get; set;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.LightTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Top

Steema.TeeChart.Tools.LightTool.Top プロパティ

ライトスポットの中央の垂直座標をピクセル単位で定義します。
public Int32 Top {get; set;}

参照

LightTool クラス | LightTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify

Steema.TeeChart.Tools.Magnify クラス

虫眼鏡ツール。

この型のすべてのメンバの一覧については、Magnify メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
Steema.TeeChart.Tools.RectangleTool
public class Magnify : RectangleTool , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify 全メンバ

Magnify 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click (Annotationの継承元)
Dragged (RectangleToolの継承元)
Dragging (RectangleToolの継承元)
KeyDown (Annotationの継承元)
Resized (RectangleToolの継承元)
Resizing (RectangleToolの継承元)

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag (RectangleToolの継承元) |
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AllowResize (RectangleToolの継承元) |
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Circled | Trueの場合、ズーム領域は円形になります。Falseの場合、ズーム領域は矩形になります。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description |
FollowMouse | Trueに設定すると、ツールはマウスの移動に合わせて移動します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Percent | イメージを拡大する量を0～100%で定義します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Smooth | Trueの場合、拡大されたイメージは滑らかになります。
Summary |
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
WheelZoom | マウスホイールがイメージを拡大するパーセントを設定/返します。
Width (Annotationの継承元) | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

プロテクト メソッド

Assign
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
OnDragged (RectangleToolの継承元)
OnDragging (RectangleToolの継承元)
OnResized (RectangleToolの継承元)
OnResizing (RectangleToolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

Magnify クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify コンストラクタ

オーバーロードの一覧

public Magnify()
public Magnify(Steema.TeeChart.Chart)

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify コンストラクタ

public Magnify()

参照

Magnify コンストラクタのオーバーロードの一覧 | Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify コンストラクタ

public Magnify(Chart c)

参照

Magnify コンストラクタのオーバーロードの一覧 | Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify イベント

パブリック イベント

Click (Annotationの継承元)
Dragged (RectangleToolの継承元)
Dragging (RectangleToolの継承元)
KeyDown (Annotationの継承元)
Resized (RectangleToolの継承元)
Resizing (RectangleToolの継承元)

参照

Magnify クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

参照

Magnify クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
OnDragged (RectangleToolの継承元)
OnDragging (RectangleToolの継承元)
OnResized (RectangleToolの継承元)
OnResizing (RectangleToolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

Magnify クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.Magnify.Assign メソッド

protected abstract Void Assign(Tool t)

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.Magnify.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.Magnify.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.Magnify.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Magnify プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag (RectangleToolの継承元) |
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AllowResize (RectangleToolの継承元) |
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Circled | Trueの場合、ズーム領域は円形になります。Falseの場合、ズーム領域は矩形になります。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description |
FollowMouse | Trueに設定すると、ツールはマウスの移動に合わせて移動します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Percent | イメージを拡大する量を0～100%で定義します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Smooth | Trueの場合、拡大されたイメージは滑らかになります。
Summary |
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
WheelZoom | マウスホイールがイメージを拡大するパーセントを設定/返します。
Width (Annotationの継承元) | カスタムな幅を設定します。

参照

Magnify クラス | Steema.TeeChart.Tools 名前空間


Circled

Steema.TeeChart.Tools.Magnify.Circled プロパティ

Trueの場合、ズーム領域は円形になります。Falseの場合、ズーム領域は矩形になります。
public Boolean Circled {get; set;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Magnify.Description プロパティ

public override String Description {get;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


FollowMouse

Steema.TeeChart.Tools.Magnify.FollowMouse プロパティ

Trueに設定すると、ツールはマウスの移動に合わせて移動します。
public Boolean FollowMouse {get; set;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Percent

Steema.TeeChart.Tools.Magnify.Percent プロパティ

イメージを拡大する量を0～100%で定義します。
public Double Percent {get; set;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Smooth

Steema.TeeChart.Tools.Magnify.Smooth プロパティ

Trueの場合、拡大されたイメージは滑らかになります。
public Boolean Smooth {get; set;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.Magnify.Summary プロパティ

public override String Summary {get;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


WheelZoom

Steema.TeeChart.Tools.Magnify.WheelZoom プロパティ

マウスホイールがイメージを拡大するパーセントを設定/返します。
public Int32 WheelZoom {get; set;}

参照

Magnify クラス | Magnify メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker

Steema.TeeChart.Tools.Marker クラス

マーカツール。

この型のすべてのメンバの一覧については、Marker メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class Marker : Annotation , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker 全メンバ

Marker 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

パブリック フィールド

IRectangle

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
TextWidth |
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Centered |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
UsePalette |
Width (Annotationの継承元) | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition
CalcTempWidth
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

Marker クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker コンストラクタ

オーバーロードの一覧

public Marker(System.String, System.Int32, Steema.TeeChart.Tools.AnnotationPositions, System.Drawing.StringAlignment, System.Drawing.Color, System.Drawing.Color)
public Marker()
public Marker(Steema.TeeChart.Chart, System.String, System.Int32, Steema.TeeChart.Tools.AnnotationPositions, System.Drawing.StringAlignment, System.Drawing.Color, System.Drawing.Color)

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker コンストラクタ

public Marker(String text,
     Int32 fontsize,
     AnnotationPositions pos,
     StringAlignment align,
     Color color1,
     Color color2)

参照

Marker コンストラクタのオーバーロードの一覧 | Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker コンストラクタ

public Marker()

参照

Marker コンストラクタのオーバーロードの一覧 | Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker コンストラクタ

public Marker(Chart c,
     String text,
     Int32 fontsize,
     AnnotationPositions pos,
     StringAlignment align,
     Color color1,
     Color color2)

参照

Marker コンストラクタのオーバーロードの一覧 | Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker イベント

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

参照

Marker クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker フィールド

パブリック フィールド

IRectangle

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

参照

Marker クラス | Steema.TeeChart.Tools 名前空間


IRectangle

Steema.TeeChart.Tools.Marker.IRectangle フィールド

public Rectangle IRectangle

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
TextWidth |
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition
CalcTempWidth
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

Marker クラス | Steema.TeeChart.Tools 名前空間


CalcTempPosition

Steema.TeeChart.Tools.Marker.CalcTempPosition メソッド

protected abstract Void CalcTempPosition(Int32& x,
     Int32& y,
     Int32 tmpW,
     Int32 tmpH,
     Int32 horizMargin,
     Int32 vertMargin)

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


CalcTempWidth

Steema.TeeChart.Tools.Marker.CalcTempWidth メソッド

protected abstract Int32 CalcTempWidth(String tmp,
     Int32& NumLines)

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


DrawString

Steema.TeeChart.Tools.Marker.DrawString メソッド

protected abstract Void DrawString(Graphics3D g,
     Int32 x,
     Int32 y,
     Int32 t,
     Int32 tmpHeight,
     String[] s)

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


TextWidth

Steema.TeeChart.Tools.Marker.TextWidth メソッド

public Int32 TextWidth()

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Marker プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Centered |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
UsePalette |
Width (Annotationの継承元) | カスタムな幅を設定します。

参照

Marker クラス | Steema.TeeChart.Tools 名前空間


Centered

Steema.TeeChart.Tools.Marker.Centered プロパティ

public Boolean Centered {get; set;}

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Marker.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


UsePalette

Steema.TeeChart.Tools.Marker.UsePalette プロパティ

public Boolean UsePalette {get; set;}

参照

Marker クラス | Marker メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection

Steema.TeeChart.Tools.MarkersCollection クラス

マーカツールコンポーネントのコレクションです。

この型のすべてのメンバの一覧については、MarkersCollection メンバを参照してください。

System.Object
System.Collections.CollectionBase
Steema.TeeChart.Tools.ToolsCollection
[Serializable]
public class MarkersCollection : ToolsCollection
, IList, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection 全メンバ

MarkersCollection 概要

コンストラクタ

Constructor

パブリック フィールド

chart (ToolsCollectionの継承元)

パブリック メソッド

Add |
Clear (ToolsCollectionの継承元) | 全ての系列を削除します（また、必要に応じて解放することもできます）。
IndexOf (ToolsCollectionの継承元) | 指定した値に該当するポイントインデックスを返します。
Remove (ToolsCollectionの継承元) | TChartからツールを削除します。
SetParentChart |

パブリック プロパティ

Item

プロテクト メソッド

OnInsertComplete (ToolsCollectionの継承元)

参照

MarkersCollection クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection コンストラクタ

public MarkersCollection(Chart c)

参照

MarkersCollection クラス | MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection フィールド

パブリック フィールド

chart (ToolsCollectionの継承元)

参照

MarkersCollection クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection メソッド

パブリック メソッド

Add |
Clear (ToolsCollectionの継承元) | 全ての系列を削除します（また、必要に応じて解放することもできます）。
IndexOf (ToolsCollectionの継承元) | 指定した値に該当するポイントインデックスを返します。
Remove (ToolsCollectionの継承元) | TChartからツールを削除します。
SetParentChart |

プロテクト メソッド

OnInsertComplete (ToolsCollectionの継承元)

参照

MarkersCollection クラス | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.MarkersCollection.Add メソッド

オーバーロードの一覧

public Marker Add(System.String)

参照

MarkersCollection クラス | MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.MarkersCollection.Add メソッド

public Marker Add(String aText)

参照

Add オーバーロードの一覧 | MarkersCollection クラス | MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


SetParentChart

Steema.TeeChart.Tools.MarkersCollection.SetParentChart メソッド

public Void SetParentChart(Chart chart)

参照

MarkersCollection クラス | MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarkersCollection プロパティ

パブリック プロパティ

Item

参照

MarkersCollection クラス | Steema.TeeChart.Tools 名前空間


Item

Steema.TeeChart.Tools.MarkersCollection.Item プロパティ

public Marker Item(Int32 index) {get; set;}

参照

MarkersCollection クラス | MarkersCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip

Steema.TeeChart.Tools.MarksTip クラス

マーカチップツール。系列ポイント上にマウスが移動あるいはクリックした際に「チップ」あるいは「ヒント」を表示するためにマーカチップツールを使用します。

この型のすべてのメンバの一覧については、MarksTip メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class MarksTip : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip 全メンバ

MarksTip 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

GetText

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
HideDelay | ツールチップを表示してから非表示するまでのタイムラグを取得/設定します。
MouseAction | マウスの移動あるいはクリックでマーカチップを表示します。
MouseDelay | ツールチップを表示する前のタイムラグを設定します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style | マーカチップツールのテキスト書式を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

MarksTip クラス | Steema.TeeChart.Tools 名前空間


MarksTip コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTip コンストラクタ

オーバーロードの一覧

public MarksTip()
public MarksTip(Steema.TeeChart.Chart)

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


MarksTip コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTip コンストラクタ

public MarksTip()

参照

MarksTip コンストラクタのオーバーロードの一覧 | MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


MarksTip コンストラクタ

Steema.TeeChart.Tools.MarksTip コンストラクタ

public MarksTip(Chart c)

参照

MarksTip コンストラクタのオーバーロードの一覧 | MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip イベント

パブリック イベント

GetText

参照

MarksTip クラス | Steema.TeeChart.Tools 名前空間


GetText

Steema.TeeChart.Tools.MarksTip.GetText イベント

public MarksTipGetTextEventHandler  GetText

解説

マーカチップのテキストを取得すると発生します。このイベントを使用して、実行時にテキストを変更できます。

例

[C#]

private void marksTip1_GetText(Steema.TeeChart.MarksTip sender, Steema.TeeChart.MarksTipGetTextEventArgs e)
{
     e.Text = Text + " kilos";
}

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

MarksTip クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

MarksTip クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.MarksTip.Assign メソッド

protected abstract Void Assign(Tool t)

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.MarksTip.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


SetActive

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTip.SetActive メソッド

protected virtual Void SetActive(Boolean value)

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTip プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
HideDelay | ツールチップを表示してから非表示するまでのタイムラグを取得/設定します。
MouseAction | マウスの移動あるいはクリックでマーカチップを表示します。
MouseDelay | ツールチップを表示する前のタイムラグを設定します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style | マーカチップツールのテキスト書式を設定します。
Summary | 詳細な説明テキストを取得します。

参照

MarksTip クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.MarksTip.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


HideDelay

Steema.TeeChart.Tools.MarksTip.HideDelay プロパティ

ツールチップを表示してから非表示するまでのタイムラグを取得/設定します。
public Int32 HideDelay {get; set;}

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


MouseAction

Steema.TeeChart.Tools.MarksTip.MouseAction プロパティ

マウスの移動あるいはクリックでマーカチップを表示します。
public MarksTipMouseAction MouseAction {get; set;}

解説

マウスの移動あるいはクリックでマーカチップを表示します。

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


MouseDelay

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTip.MouseDelay プロパティ

ツールチップを表示する前にタイムラグを設定します。

public Int32 MouseDelay {get; set;}

解説

ツールチップを表示する前にタイムラグを設定します。

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.MarksTip.Style プロパティ

マーカチップツールのテキスト書式を設定します。
public MarksStyles Style {get; set;}

解説

マーカチップツールのテキスト書式を設定するためにMarksStylesを使用してください。

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.MarksTip.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

MarksTip クラス | MarksTip メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTipGetTextEventArgs

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTipGetTextEventArgs クラス

この型のすべてのメンバの一覧については、MarksTipGetTextEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class MarksTipGetTextEventArgs : EventArgs

必要条件

名前空間： Steema.TeeChart.Tools

アセンブリ：TeeChart.dll

参照

MarksTipGetTextEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTipGetTextEventArgs 全メンバ

MarksTipGetTextEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Text

参照

MarksTipGetTextEventArgs クラス | Steema.TeeChart.Tools 名前空間


MarksTipGetTextEventArgs コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTipGetTextEventArgs コンストラクタ

public MarksTipGetTextEventArgs(String text)

参照

MarksTipGetTextEventArgs クラス | MarksTipGetTextEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTipGetTextEventArgs プロパティ

パブリック プロパティ

Text

参照

MarksTipGetTextEventArgs クラス | Steema.TeeChart.Tools 名前空間


Text

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTipGetTextEventArgs.Text プロパティ

public String Text {get; set;}

参照

MarksTipGetTextEventArgs クラス | MarksTipGetTextEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTipGetTextEventHandler

Steema.TeeChart.Tools.MarksTipGetTextEventHandler デリゲート

マーカチップツールのイベントハンドラ。
public delegate MarksTipGetTextEventHandler (MarksTip sender,
     MarksTipGetTextEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.MarksTipMouseAction

TeeChartプログラミングガイド

Steema.TeeChart.Tools.MarksTipMouseAction 列挙体

MouseActionプロパティの使用可能な値です。

[Serializable]
public enum MarksTipMouseAction : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Move | 系列ポイント上にマウスが移動するとチップを表示します。
Click | 系列ポイントをクリックするとチップを表示します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint

Steema.TeeChart.Tools.NearestPoint クラス

マウスカーソルに近い系列ポイントにマークを表示するために近傍点ツールを使用します。

この型のすべてのメンバの一覧については、NearestPoint メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class NearestPoint : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint 全メンバ

NearestPoint 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Change

パブリック フィールド

Point

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawLine | マウスから最も近いポイントに線を描画するかどうか設定します。
FullRepaint | trueの場合、近傍点が他の系列ポイントに移動するとチャート全体を再描画します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Size | 近傍点ツールのシェープのサイズを設定します。
Style | 近傍点ツールのシェープのスタイルを設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

NearestPoint クラス | Steema.TeeChart.Tools 名前空間


NearestPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint コンストラクタ

オーバーロードの一覧

public NearestPoint(Steema.TeeChart.Styles.Series)
public NearestPoint()
public NearestPoint(Steema.TeeChart.Chart)

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


NearestPoint コンストラクタ

Steema.TeeChart.Tools.NearestPoint コンストラクタ

public NearestPoint(Series s)

参照

NearestPoint コンストラクタのオーバーロードの一覧 | NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


NearestPoint コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint コンストラクタ

public NearestPoint()

参照

NearestPoint コンストラクタのオーバーロードの一覧 | NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


NearestPoint コンストラクタ

Steema.TeeChart.Tools.NearestPoint コンストラクタ

public NearestPoint(Chart c)

参照

NearestPoint コンストラクタのオーバーロードの一覧 | NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint イベント

パブリック イベント

Change

参照

NearestPoint クラス | Steema.TeeChart.Tools 名前空間


Change

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.Change イベント

public EventHandler  Change

解説

マウスの移動により、近傍点ツールが他の系列ポイントへ移動した際に発生します。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint フィールド

パブリック フィールド

Point

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

NearestPoint クラス | Steema.TeeChart.Tools 名前空間


Point

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.Point フィールド

public Int32 Point

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

NearestPoint クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.NearestPoint.Assign メソッド

protected abstract Void Assign(Tool t)

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.NearestPoint.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPoint プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Brush | ブラシ特性のエレメント。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
DrawLine | マウスから最も近いポイントに線を描画するかどうか設定します。
FullRepaint | trueの場合、近傍点が他の系列ポイントに移動するとチャート全体を再描画します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Size | 近傍点ツールのシェープのサイズを設定します。
Style | 近傍点ツールのシェープのスタイルを設定します。

参照

NearestPoint クラス | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.NearestPoint.Brush プロパティ

ブラシ特性を取得/設定します。
public ChartBrush Brush {get; set;}

解説

ブラシ特性を取得/設定します。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.NearestPoint.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


DrawLine

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.DrawLine プロパティ

マウスから最も近いポイントに線を描画するかどうか設定します。

public Boolean DrawLine {get; set;}

解説

デフォルト値：true

マウスから最も近いポイントに線を描画する場合はtrueに設定してください。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


FullRepaint

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.FullRepaint プロパティ

trueの場合、近傍点が他の系列ポイントに移動するとチャート全体を再描画します。

public Boolean FullRepaint {get; set;}

解説

デフォルト値：

trueの場合、近傍点が他の系列ポイントに移動するとチャート全体を再描画します。

例

[C#]

nearestPoint1.FullRepaint = false;

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.NearestPoint.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

解説

ペン特性のエレメント。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Size

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPoint.Size プロパティ

近傍点ツールのシェープのサイズを設定します。

public Int32 Size {get; set;}

解説

デフォルト値：20

近傍点ツールのシェープのサイズを設定します。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.NearestPoint.Style プロパティ

近傍点ツールのシェープのスタイルを設定します。
public NearestPointStyles Style {get; set;}

解説

近傍点ツールのシェープのスタイルを設定します。

使用可能な値は以下の通りです。

None シェープは描画されません。
Circle 円
Rectangle 矩形

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.NearestPoint.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

NearestPoint クラス | NearestPoint メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.NearestPointStyles

TeeChartプログラミングガイド

Steema.TeeChart.Tools.NearestPointStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum NearestPointStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
None | 何も描画されません。
Circle | 円。
Rectangle | 矩形。
Diamond | 菱形。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber

Steema.TeeChart.Tools.PageNumber クラス

ページ数ツール。

この型のすべてのメンバの一覧については、PageNumber メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class PageNumber : Annotation , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

PageNumber メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber 全メンバ

PageNumber 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Format | ページ数ツールのテキスト文字列の書式を定義します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

PageNumber クラス | Steema.TeeChart.Tools 名前空間


PageNumber コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PageNumber コンストラクタ

オーバーロードの一覧

public PageNumber()
public PageNumber(Steema.TeeChart.Chart)

参照

PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


PageNumber コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PageNumber コンストラクタ

public PageNumber()

参照

PageNumber コンストラクタのオーバーロードの一覧 | PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


PageNumber コンストラクタ

Steema.TeeChart.Tools.PageNumber コンストラクタ

public PageNumber(Chart c)

参照

PageNumber コンストラクタのオーバーロードの一覧 | PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber イベント

パブリック イベント

Click (Annotationの継承元)
KeyDown (Annotationの継承元)

参照

PageNumber クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

参照

PageNumber クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText
KeyEvent (Annotationの継承元)
MouseEvent (Annotationの継承元)
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

PageNumber クラス | Steema.TeeChart.Tools 名前空間


GetInnerText

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PageNumber.GetInnerText メソッド

protected virtual String GetInnerText()

参照

PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PageNumber プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Format | ページ数ツールのテキスト文字列の書式を定義します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

参照

PageNumber クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.PageNumber.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


Format

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PageNumber.Format プロパティ

ページ数ツールのテキスト文字列の書式を定義します。

public String Format {get; set;}

解説

ページ数ツールのテキスト文字列の書式を定義します。

参照

PageNumber クラス | PageNumber メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieTool

Steema.TeeChart.Tools.PieTool クラス

円スライスツール。

この型のすべてのメンバの一覧については、PieTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class PieTool : ToolSeries , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

PieTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieTool 全メンバ

PieTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Slice |
Style |
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieTool クラス | Steema.TeeChart.Tools 名前空間


PieTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PieTool コンストラクタ

オーバーロードの一覧

public PieTool()
public PieTool(Steema.TeeChart.Chart)

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


PieTool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PieTool コンストラクタ

public PieTool()

参照

PieTool コンストラクタのオーバーロードの一覧 | PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


PieTool コンストラクタ

Steema.TeeChart.Tools.PieTool コンストラクタ

public PieTool(Chart c)

参照

PieTool コンストラクタのオーバーロードの一覧 | PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

PieTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

PieTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.PieTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.PieTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieTool プロパティ

パブリック プロパティ

Active (Toollの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBase lの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
GetHorizAxis (ToolSeries lの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeries lの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Pen | ペン特性のエレメント。
Series (ToolSeries lの継承元) | ツールに関連付ける系列を設定します。
Slice |
Style |

参照

PieTool クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.PieTool.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.PieTool.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

解説

ペン特性のエレメント。
線や枠を描くためにこのプロパティを使用します。

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Slice

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PieTool.Slice プロパティ

public Int32 Slice {get;}

解説

現在、強調されたスライスのポイントインデックスを返します。

例

[C#]

private void Form1_Load(object sender, System.EventArgs e) {
pie1.FillSampleValues(6);
}

private void tChart1_MouseMove(object sender, System.Windows.Forms.MouseEventArgs e)
{
     int index = pie1.Clicked(e.X, e.Y);
     if(index != -1)
    {
        int tmp = pieTool1.Slice;
        if(tmp==-1)
        {
            label1.Text = "";
        }
        else
        {
            label1.Text = pie1.Labels[tmp];
        }
    }
}

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.PieTool.Style プロパティ

public PieToolStyle Style {get; set;}

解説

デフォルト値：Focus

円スライスツールのスタイルを設定します。デフォルトは、マウスカーソルの下の円スライスに枠を付けます。
Explodeは、マウスカーソルの下の円スライスを円の中心から分離します。

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.PieTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

PieTool クラス | PieTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.PieToolStyle

TeeChartプログラミングガイド

Steema.TeeChart.Tools.PieToolStyle 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum PieToolStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Focus | マウスカーソルの下の円スライスの周りに枠を描きます。
Explode | マウスカーソルの下の円スライスを円の中心から分離します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool

Steema.TeeChart.Tools.RectangleTool クラス

矩形ツール。

この型のすべてのメンバの一覧については、RectangleTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.Annotation
public class RectangleTool : Annotation , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool 全メンバ

RectangleTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Click (Annotationの継承元)
Dragged
Dragging
KeyDown (Annotationの継承元)
Resized
Resizing

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag |
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AllowResize |
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
OnDragged
OnDragging
OnResized
OnResizing
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

RectangleTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool コンストラクタ

オーバーロードの一覧

public RectangleTool()
public RectangleTool(Steema.TeeChart.Chart)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool コンストラクタ

public RectangleTool()

参照

RectangleTool コンストラクタのオーバーロードの一覧 | RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool コンストラクタ

public RectangleTool(Chart c)

参照

RectangleTool コンストラクタのオーバーロードの一覧 | RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool イベント

パブリック イベント

Click (Annotationの継承元)
Dragged
Dragging
KeyDown (Annotationの継承元)
Resized
Resizing

参照

RectangleTool クラス | Steema.TeeChart.Tools 名前空間


Dragged

Steema.TeeChart.Tools.RectangleTool.Dragged イベント

public RectangleToolDraggedEventHandler  Dragged

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Dragging

Steema.TeeChart.Tools.RectangleTool.Dragging イベント

public RectangleToolDraggingEventHandler  Dragging

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Resized

Steema.TeeChart.Tools.RectangleTool.Resized イベント

public RectangleToolResizedEventHandler  Resized

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Resizing

Steema.TeeChart.Tools.RectangleTool.Resizing イベント

public RectangleToolResizingEventHandler  Resizing

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
tmpX (Annotationの継承元)
tmpY (Annotationの継承元)

参照

RectangleTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
EditorKey (Annotationの継承元) | メソッドはデフォルトによりKeyDownイベントに渡されます。
EndEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態を中止します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
StartEdit (Annotationの継承元) | アノテーションのテキストを編集可能状態にします。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Annotationの継承元)
CalcTempPosition (Annotationの継承元)
CalcTempWidth (Annotationの継承元)
CalcTextXY (Annotationの継承元)
ChartEvent (Annotationの継承元)
Clicked (Annotationの継承元)
Dispose (Toolの継承元)
DoDoubleClick (Annotationの継承元)
DrawString (Annotationの継承元)
DrawText (Annotationの継承元)
GetInnerText (Annotationの継承元)
KeyEvent (Annotationの継承元)
MouseEvent
OnClick (Annotationの継承元)
OnDisposing (Toolの継承元)
OnDoubleClick (Annotationの継承元)
OnDragged
OnDragging
OnResized
OnResizing
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Annotationの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeHeight (Annotationの継承元)
ShouldSerializeWidth (Annotationの継承元)

参照

RectangleTool クラス | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.RectangleTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


OnDragged

Steema.TeeChart.Tools.RectangleTool.OnDragged メソッド

protected abstract Void OnDragged(EventArgs e)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


OnDragging

Steema.TeeChart.Tools.RectangleTool.OnDragging メソッド

protected abstract Void OnDragging(EventArgs e)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


OnResized

Steema.TeeChart.Tools.RectangleTool.OnResized メソッド

protected abstract Void OnResized(EventArgs e)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


OnResizing

Steema.TeeChart.Tools.RectangleTool.OnResizing メソッド

protected abstract Void OnResizing(EventArgs e)

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag |
AllowEdit (Annotationの継承元) | ツールのテキストの編集を可能にします。
AllowResize |
AutoSize (Annotationの継承元) | Trueの場合、TextShapeのカスタムなサイズ設定を可能にします。
Bounds (Annotationの継承元) | アノテーションツールの矩形領域を取得/設定します。
Callout (Annotationの継承元) |
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ClipText (Annotationの継承元) |
Cursor (Annotationの継承元) |
Description | 説明のテキストを取得します。
Height (Annotationの継承元) | カスタムな高さを設定します。
Left (Annotationの継承元) | チャートの左端を始点とするテキストボックスの水平位置をピクセル単位で設定します。
Position (Annotationの継承元) | アノテーションツールのテキストボックスとテキストのデフォルト位置を定義します。
PositionUnits (Annotationの継承元) | アノテーションの位置の単位（ピクセルあるいは百分率）を定義します。
Shape (Annotationの継承元) | アノテーションツールのテキストやテキストボックス（形状）の特性を設定します。
Summary (Annotationの継承元) | 詳細な説明テキストを取得します。
Text (Annotationの継承元) | アノテーションツールのテキストを定義します。
TextAlign (Annotationの継承元) |
Top (Annotationの継承元) | チャートの上端を始点とするテキストボックスの垂直位置をピクセル単位で設定します。
Width (Annotationの継承元) | カスタムな幅を設定します。

参照

RectangleTool クラス | Steema.TeeChart.Tools 名前空間


AllowDrag

Steema.TeeChart.Tools.RectangleTool.AllowDrag プロパティ

public Boolean AllowDrag {get; set;}

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


AllowResize

Steema.TeeChart.Tools.RectangleTool.AllowResize プロパティ

public Boolean AllowResize {get; set;}

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.RectangleTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

RectangleTool クラス | RectangleTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleToolDraggedEventHandler

Steema.TeeChart.Tools.RectangleToolDraggedEventHandler デリゲート

public delegate RectangleToolDraggedEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleToolDraggingEventHandler

Steema.TeeChart.Tools.RectangleToolDraggingEventHandler デリゲート

public delegate RectangleToolDraggingEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleToolResizedEventHandler

Steema.TeeChart.Tools.RectangleToolResizedEventHandler デリゲート

public delegate RectangleToolResizedEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RectangleToolResizingEventHandler

Steema.TeeChart.Tools.RectangleToolResizingEventHandler デリゲート

public delegate RectangleToolResizingEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate

Steema.TeeChart.Tools.Rotate クラス

回転ツール。

この型のすべてのメンバの一覧については、Rotate メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class Rotate : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Rotate メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate 全メンバ

Rotate 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Rotating

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
OnRotating |
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | 回転ツールを有効にするボタンを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Inertia |
Inverted | 回転と仰角の方向を逆にします。
Pen | ペン特性のエレメント。
Speed | 回転ツールの速度を設定します。
Style | 回転ツールのスタイルを設定します（回転、仰角、両方）。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Rotate クラス | Steema.TeeChart.Tools 名前空間


Rotate コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Rotate コンストラクタ

オーバーロードの一覧

public Rotate()
public Rotate(Steema.TeeChart.Chart)

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Rotate コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Rotate コンストラクタ

public Rotate()

参照

Rotate コンストラクタのオーバーロードの一覧 | Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Rotate コンストラクタ

Steema.TeeChart.Tools.Rotate コンストラクタ

public Rotate(Chart c)

参照

Rotate コンストラクタのオーバーロードの一覧 | Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate イベント

パブリック イベント

Rotating

参照

Rotate クラス | Steema.TeeChart.Tools 名前空間


Rotating

Steema.TeeChart.Tools.Rotate.Rotating イベント

public RotatingEventHandler  Rotating

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

Rotate クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
OnRotating |
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Rotate クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.Rotate.Assign メソッド

protected abstract Void Assign(Tool t)

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.Rotate.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.Rotate.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


OnRotating

Steema.TeeChart.Tools.Rotate.OnRotating メソッド

public abstract Void OnRotating()

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Rotate プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Button | 回転ツールを有効にするボタンを定義します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Inertia |
Inverted | 回転と仰角の方向を逆にします。
Pen | ペン特性のエレメント。
Speed | 回転ツールの速度を設定します。
Style | 回転ツールのスタイルを設定します（回転、仰角、両方）。
Summary | 詳細な説明テキストを取得します。

参照

Rotate クラス | Steema.TeeChart.Tools 名前空間


Button

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Rotate.Button プロパティ

回転ツールを有効にするボタンを定義します。

public MouseButtons Button {get; set;}

解説

デフォルト値：Left

このプロパティは、回転ツールを有効にするボタンを定義します。
以下の値が使用できます。

Left 左マウスボタンをドラッグするとチャートの回転/仰角をします。
Right 右マウスボタンをドラッグするとチャートの回転/仰角をします。
Middle 中央マウスボタンをドラッグするとチャートの回転/仰角をします。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Rotate.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Inertia

Steema.TeeChart.Tools.Rotate.Inertia プロパティ

public Int32 Inertia {get; set;}

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Inverted

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Rotate.Inverted プロパティ

回転と仰角の方向を逆にします。

public Boolean Inverted {get; set;}

解説

回転と仰角の方向を逆にします。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.Rotate.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

解説

ペン特性のエレメント。
線や枠を描くためにこのプロパティを使用します。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Speed

Steema.TeeChart.Tools.Rotate.Speed プロパティ

回転ツールの速度を設定します。
public Int32 Speed {get; set;}

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.Rotate.Style プロパティ

回転ツールに適用するマウスアクションを設定します（回転、仰角、両方）。
public RotateStyles Style {get; set;}

解説

回転ツールに適用するマウスアクションを設定します（回転、仰角、両方）。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.Rotate.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

Rotate クラス | Rotate メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RotateStyles

TeeChartプログラミングガイド

Steema.TeeChart.Tools.RotateStyles 列挙体

Styleプロパティの使用可能な値です。

[Serializable]
public enum RotateStyles : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
All | チャート系列の仰角と回転の指定ができます。
Rotation | チャート系列の回転の指定ができます。
Elevation | チャート系列の仰角の指定ができます。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.RotatingEventHandler

Steema.TeeChart.Tools.RotatingEventHandler デリゲート

public delegate RotatingEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScopeCursorStyle

Steema.TeeChart.Tools.ScopeCursorStyle 列挙体

カーソルのXY位置の周りを描くためのシェープを定義します。StyleプロパティがScopeの場合のみ。
[Serializable]
public sealed enum ScopeCursorStyle : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Rectangle |
Circle |
Diamond |
Empty |
Camera |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollAttributes

Steema.TeeChart.Tools.ScrollAttributes クラス

この型のすべてのメンバの一覧については、ScrollAttributes メンバを参照してください。

System.Object
Steema.TeeChart.Tools.ZoomAttributes
public class ScrollAttributes : ZoomAttributes

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollAttributes 全メンバ

ScrollAttributes 概要

コンストラクタ

Constructor

パブリック フィールド

Attribs (ZoomAttributesの継承元)
b
bottomAxisPos
CanvasIndex (ZoomAttributesの継承元)
destRect
DragZoom (ZoomAttributesの継承元)
FillTransp (ZoomAttributesの継承元)
frames
grabRect
ImageStr (ZoomAttributesの継承元)
imgList
mouseAction
newChartRect
newLeftWall
newWidth
oldHeight
oldWidth
PenColor (ZoomAttributesの継承元)
renderRect
rightAxisMargin
scrollPages
sourceRect
startPos

参照

ScrollAttributes クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollAttributes コンストラクタ

public ScrollAttributes()

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollAttributes フィールド

パブリック フィールド

Attribs (ZoomAttributesの継承元)
b
bottomAxisPos
CanvasIndex (ZoomAttributesの継承元)
destRect
DragZoom (ZoomAttributesの継承元)
FillTransp (ZoomAttributesの継承元)
frames
grabRect
ImageStr (ZoomAttributesの継承元)
imgList
mouseAction
newChartRect
newLeftWall
newWidth
oldHeight
oldWidth
PenColor (ZoomAttributesの継承元)
renderRect
rightAxisMargin
scrollPages
sourceRect
startPos

参照

ScrollAttributes クラス | Steema.TeeChart.Tools 名前空間


b

Steema.TeeChart.Tools.ScrollAttributes.b フィールド

public Bitmap b

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


bottomAxisPos

Steema.TeeChart.Tools.ScrollAttributes.bottomAxisPos フィールド

public Int32 bottomAxisPos

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


destRect

Steema.TeeChart.Tools.ScrollAttributes.destRect フィールド

public Rectangle destRect

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


frames

Steema.TeeChart.Tools.ScrollAttributes.frames フィールド

public ArrayList frames

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


grabRect

Steema.TeeChart.Tools.ScrollAttributes.grabRect フィールド

public Rectangle grabRect

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


imgList

Steema.TeeChart.Tools.ScrollAttributes.imgList フィールド

public Hashtable imgList

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


mouseAction

Steema.TeeChart.Tools.ScrollAttributes.mouseAction フィールド

public Int32 mouseAction

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


newChartRect

Steema.TeeChart.Tools.ScrollAttributes.newChartRect フィールド

public Rectangle newChartRect

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


newLeftWall

Steema.TeeChart.Tools.ScrollAttributes.newLeftWall フィールド

public Int32 newLeftWall

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


newWidth

Steema.TeeChart.Tools.ScrollAttributes.newWidth フィールド

public Int32 newWidth

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


oldHeight

Steema.TeeChart.Tools.ScrollAttributes.oldHeight フィールド

public Int32 oldHeight

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


oldWidth

Steema.TeeChart.Tools.ScrollAttributes.oldWidth フィールド

public Int32 oldWidth

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


renderRect

Steema.TeeChart.Tools.ScrollAttributes.renderRect フィールド

public Rectangle renderRect

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


rightAxisMargin

Steema.TeeChart.Tools.ScrollAttributes.rightAxisMargin フィールド

public Int32 rightAxisMargin

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


scrollPages

Steema.TeeChart.Tools.ScrollAttributes.scrollPages フィールド

public Int32 scrollPages

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


sourceRect

Steema.TeeChart.Tools.ScrollAttributes.sourceRect フィールド

public Rectangle sourceRect

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


startPos

Steema.TeeChart.Tools.ScrollAttributes.startPos フィールド

public Int32 startPos

参照

ScrollAttributes クラス | ScrollAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar

Steema.TeeChart.Tools.ScrollBar クラス

スクロールバーツール。

この型のすべてのメンバの一覧については、ScrollBar メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ScrollBar : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar 全メンバ

ScrollBar 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

ChangeSize
Scrolled
SetPosition

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
MainRectangle | スクロールバーの境界矩形を返します。
ScrollRectangle | スクロールバーのサムの境界矩形を返します。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
ArrowBrush | 上/下や右/下の矢印を塗りつぶすブラシを定義します。
AutoRepeat | Trueの場合（デフォルト）、マウスボタンを押したままの状態にするとスクロールし続けます。
Bevel | スクロールバーの枠のスタイルを定義します。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawStyle | スクロールバーの表示スタイルを定義します。値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。
Gradient | スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。
Horizontal | Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。
InitialDelay | オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。AutoRepeatプロパティを参照してください。
MinThumbSize | スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。
Pen | ペン特性のエレメント。
Position | スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。Sizeプロパティを参照してください。
Size | スクロールバー全体の大きさを取得/設定します。Positionプロパティを参照してください。
Summary (Toolの継承元) |
ThumbBrush | スクロールバーのサムを塗りつぶすブラシを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
Max
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
ThumbLength

プロテクト メソッド

Assign (Toolの継承元)
CalcDelta
ChartEvent
CurrentCount
DeltaMain
Dispose (Toolの継承元)
Draw
DrawArrows
GetPosition
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetIPosition
SetStringProperty (TeeBaseの継承元)
ShouldDraw
TotalCount

プロテクト プロパティ

R

参照

ScrollBar クラス | Steema.TeeChart.Tools 名前空間


ScrollBar コンストラクタ

Steema.TeeChart.Tools.ScrollBar コンストラクタ

オーバーロードの一覧

public ScrollBar()
public ScrollBar(Steema.TeeChart.Chart)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ScrollBar コンストラクタ

Steema.TeeChart.Tools.ScrollBar コンストラクタ

public ScrollBar()

参照

ScrollBar コンストラクタのオーバーロードの一覧 | ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ScrollBar コンストラクタ

Steema.TeeChart.Tools.ScrollBar コンストラクタ

public ScrollBar(Chart c)

参照

ScrollBar コンストラクタのオーバーロードの一覧 | ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar イベント

パブリック イベント

ChangeSize
Scrolled
SetPosition

参照

ScrollBar クラス | Steema.TeeChart.Tools 名前空間


ChangeSize

Steema.TeeChart.Tools.ScrollBar.ChangeSize イベント

public ScrollBarChangedSizeHandler  ChangeSize

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Scrolled

Steema.TeeChart.Tools.ScrollBar.Scrolled イベント

public ScrollBarScrolledHandler  Scrolled

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


SetPosition

Steema.TeeChart.Tools.ScrollBar.SetPosition イベント

public ScrollBarSetPositionHandler  SetPosition

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
Max
pPen (Toolの継承元)
ThumbLength

参照

ScrollBar クラス | Steema.TeeChart.Tools 名前空間


Max

Steema.TeeChart.Tools.ScrollBar.Max フィールド

protected Int32 Max

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ThumbLength

Steema.TeeChart.Tools.ScrollBar.ThumbLength フィールド

protected Int32 ThumbLength

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
MainRectangle | スクロールバーの境界矩形を返します。
ScrollRectangle | スクロールバーのサムの境界矩形を返します。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Toolの継承元)
CalcDelta
ChartEvent
CurrentCount
DeltaMain
Dispose (Toolの継承元)
Draw
DrawArrows
GetPosition
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetIPosition
SetStringProperty (TeeBaseの継承元)
ShouldDraw
TotalCount

参照

ScrollBar クラス | Steema.TeeChart.Tools 名前空間


CalcDelta

Steema.TeeChart.Tools.ScrollBar.CalcDelta メソッド

protected abstract Double CalcDelta(Int32 A,
     Int32 B)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.ScrollBar.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


CurrentCount

Steema.TeeChart.Tools.ScrollBar.CurrentCount メソッド

protected abstract Int32 CurrentCount()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


DeltaMain

Steema.TeeChart.Tools.ScrollBar.DeltaMain メソッド

protected abstract Int32 DeltaMain()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Draw

Steema.TeeChart.Tools.ScrollBar.Draw メソッド

protected Void Draw()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


DrawArrows

Steema.TeeChart.Tools.ScrollBar.DrawArrows メソッド

protected Void DrawArrows(Graphics3D g)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


GetPosition

Steema.TeeChart.Tools.ScrollBar.GetPosition メソッド

protected abstract Int32 GetPosition()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


MainRectangle

Steema.TeeChart.Tools.ScrollBar.MainRectangle メソッド

スクロールバーの境界矩形を返します。

public Rectangle MainRectangle()

解説

スクロールバーの境界矩形を返します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.ScrollBar.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ScrollRectangle

Steema.TeeChart.Tools.ScrollBar.ScrollRectangle メソッド

スクロールバーのサムの境界矩形を返します。

public Rectangle ScrollRectangle()

解説

スクロールバーのサムの境界矩形を返します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.ScrollBar.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


SetIPosition

Steema.TeeChart.Tools.ScrollBar.SetIPosition メソッド

protected abstract Void SetIPosition(Int32 value)

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ShouldDraw

Steema.TeeChart.Tools.ScrollBar.ShouldDraw メソッド

protected abstract Boolean ShouldDraw()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


TotalCount

Steema.TeeChart.Tools.ScrollBar.TotalCount メソッド

protected abstract Int32 TotalCount()

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBar プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
ArrowBrush | 上/下や右/下の矢印を塗りつぶすブラシを定義します。
AutoRepeat | Trueの場合（デフォルト）、マウスボタンを押したままの状態にするとスクロールし続けます。
Bevel | スクロールバーの枠のスタイルを定義します。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawStyle | スクロールバーの表示スタイルを定義します。値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。
Gradient | スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。
Horizontal | Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。
InitialDelay | オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。AutoRepeatプロパティを参照してください。
MinThumbSize | スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。
Pen | ペン特性のエレメント。
Position | スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。Sizeプロパティを参照してください。
Size | スクロールバー全体の大きさを取得/設定します。Positionプロパティを参照してください。
Summary (Toolの継承元) |
ThumbBrush | スクロールバーのサムを塗りつぶすブラシを取得します。

プロテクト プロパティ

R

参照

ScrollBar クラス | Steema.TeeChart.Tools 名前空間


ArrowBrush

Steema.TeeChart.Tools.ScrollBar.ArrowBrush プロパティ

上/下や右/下の矢印を塗りつぶすブラシを定義します。

public ChartBrush ArrowBrush {get;}

解説

上/下や右/下の矢印を塗りつぶすブラシを定義します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


AutoRepeat

Steema.TeeChart.Tools.ScrollBar.AutoRepeat プロパティ

Trueの場合（デフォルト）、マウスボタンを押したままの状態にするとスクロールし続けます。

public Boolean AutoRepeat {get; set;}

解説

デフォルト値：True
Trueの場合、マウスボタンを押したままの状態にするとスクロールし続けます。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Bevel

Steema.TeeChart.Tools.ScrollBar.Bevel プロパティ

スクロールバーの枠のスタイルを定義します。

public Bevel Bevel {get;}

解説

スクロールバーの枠のスタイルを定義します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.ScrollBar.Brush プロパティ

ブラシ特性を定義します。

public ChartBrush Brush {get;}

解説

ブラシ特性を定義します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ScrollBar.Description プロパティ

説明のテキストを取得します。

public override String Description {get;}

解説

説明テキストを取得します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


DrawStyle

Steema.TeeChart.Tools.ScrollBar.DrawStyle プロパティ

スクロールバーの表示スタイルを定義します。値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。

public ScrollBarDrawStyle DrawStyle {get; set;}

解説

スクロールバーの表示スタイルを定義します。
値は「Always」（常時表示）と「WhenNeeded」（必要に応じて表示）です。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Gradient

Steema.TeeChart.Tools.ScrollBar.Gradient プロパティ

スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。

public Gradient Gradient {get;}

解説

スクロールバーの矩形を塗りつぶすグラデーション特性を定義します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Horizontal

Steema.TeeChart.Tools.ScrollBar.Horizontal プロパティ

Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。

public Boolean Horizontal {get; set;}

解説

Trueの場合は水平スクロールバー、Falseの場合は垂直スクロールバーを表示します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


InitialDelay

Steema.TeeChart.Tools.ScrollBar.InitialDelay プロパティ

オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。AutoRepeatプロパティを参照してください。

public Int32 InitialDelay {get; set;}

解説

オートリピート機能を開始する前の遅延時間をミリ秒単位で取得/設定します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


MinThumbSize

Steema.TeeChart.Tools.ScrollBar.MinThumbSize プロパティ

スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。

public Int32 MinThumbSize {get; set;}

解説

スクロールバーのサムの最小サイズ（幅/高さ）を定義するピクセル数を取得/設定します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.ScrollBar.Pen プロパティ

ペン特性のエレメント。

public ChartPen Pen {get;}

解説

ペン特性のエレメント。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Position

Steema.TeeChart.Tools.ScrollBar.Position プロパティ

スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。Sizeプロパティを参照してください。

public Int32 Position {get; set;}

解説

スクロールバーのSizeプロパティに応じて、スクロールバーのサムインジケータの位置を指定する値を取得/設定します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


R

Steema.TeeChart.Tools.ScrollBar.R プロパティ

protected Rectangle R {get; set;}

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Size

Steema.TeeChart.Tools.ScrollBar.Size プロパティ

スクロールバー全体の大きさを取得/設定します。Positionプロパティを参照してください。

public Int32 Size {get; set;}

解説

スクロールバー全体の大きさを取得/設定します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


ThumbBrush

Steema.TeeChart.Tools.ScrollBar.ThumbBrush プロパティ

スクロールバーのサムを塗りつぶすブラシを取得します。

public ChartBrush ThumbBrush {get;}

解説

スクロールバーのサムを塗りつぶすブラシを取得します。

参照

ScrollBar クラス | ScrollBar メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarChangedSizeHandler

Steema.TeeChart.Tools.ScrollBarChangedSizeHandler デリゲート

スクロールバーのOnChangedSizeのイベントハンドラ。

public delegate ScrollBarChangedSizeHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarDrawStyle

Steema.TeeChart.Tools.ScrollBarDrawStyle 列挙体

[Serializable]
public sealed enum ScrollBarDrawStyle : Enum
, IComparable, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
Always |
WhenNeeded |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarScrolledHandler

Steema.TeeChart.Tools.ScrollBarScrolledHandler デリゲート

スクロールバーのOnScrolledイベントハンドラ。

public delegate ScrollBarScrolledHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs

Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs クラス

スクロールバーのOnScrolledイベントをサポートするEventArgs。

この型のすべてのメンバの一覧については、ScrollBarSetPositionEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class ScrollBarSetPositionEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

ScrollBarSetPositionEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs 全メンバ

ScrollBarSetPositionEventArgs 概要

コンストラクタ

Constructor

パブリック プロパティ

Position

参照

ScrollBarSetPositionEventArgs クラス | Steema.TeeChart.Tools 名前空間


ScrollBarSetPositionEventArgs コンストラクタ

Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs コンストラクタ

public ScrollBarSetPositionEventArgs(Int32 Position)

参照

ScrollBarSetPositionEventArgs クラス | ScrollBarSetPositionEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs プロパティ

パブリック プロパティ

Position

参照

ScrollBarSetPositionEventArgs クラス | Steema.TeeChart.Tools 名前空間


Position

Steema.TeeChart.Tools.ScrollBarSetPositionEventArgs.Position プロパティ

public Int32 Position {get;}

参照

ScrollBarSetPositionEventArgs クラス | ScrollBarSetPositionEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollBarSetPositionHandler

Steema.TeeChart.Tools.ScrollBarSetPositionHandler デリゲート

スクロールバーのOnSetPositionのイベントハンドラ。

public delegate ScrollBarSetPositionHandler (Object sender,
     ScrollBarSetPositionEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollingDirection

Steema.TeeChart.Tools.ScrollingDirection 列挙体

バナーテキストのスクロール方向を設定します。
[Serializable]
public sealed enum ScrollingDirection : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
sdRightLeft | 右から左へスクロールします。
sdLeftRight | 左から右へスクロールします。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollMouseAction

Steema.TeeChart.Tools.ScrollMouseAction 列挙体

[Serializable]
public sealed enum ScrollMouseAction : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
none | マウスボタンを押しても、アクションなし。
drag | マウスボタンを押した場合、チャートをドラッグします。

参照

Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Tools.ScrollTool

Steema.TeeChart.Tools.ScrollTool クラス

アクティブなスクロール可能なWebチャートを作成するためのツール。

この型のすべてのメンバの一覧については、ScrollTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ZoomTool
public class ScrollTool : ZoomTool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool 全メンバ

ScrollTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GenerateImageList |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
initScrollVars |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
SetCurrentZoom (ZoomToolの継承元) | ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。
SetSavedZoom (ZoomToolの継承元) | 現在のズーム状態をセッション変数に保存した場合、その保存されたズーム状態を現在のチャートに設定します。
ToString (Toolの継承元) |
Zoom (ZoomToolの継承元) | チャートをズームします。

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Attributes | スクロールツールを作成するためのサポート属性。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomVariables (ZoomToolの継承元) | チャートの新しいページの呼び出しに任意のカスタム変数を追加します。
Description | 説明のテキストを取得します。
MouseAction | スクロール可能なチャート上でマウスドラッグされた時のアクションを設定します。
SegmentViewUnits | チャートを開いて表示する際の表示するセグメントの大きさや開始位置を設定するための単位。
StartPosition | チャートを開く際の開始位置。位置はパーセントまたは軸の値で表します。SegmentViewUnits を参照してください。
Summary | 詳細な説明テキストを取得します。
ViewSegmentSize | 表示するチャートのパーセント。
ZoomCanvasIndex (ZoomToolの継承元) | ズーム矩形描画の相対的なZ深さを取得/設定します。Webフォーム上に複数のオブジェクトが存在する場合、ズーム領域が有効にならない場合がありますので、この場合はズーム領域を最も上の位置に置く必要があります。
ZoomFillTransparency (ZoomToolの継承元) | ズームを指定する矩形の透明度（0～100%）を定義します。0（デフォルト）は透明になります。
ZoomPenColor (ZoomToolの継承元) | ズーム矩形のペンの色を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ZoomToolの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
getZoomArgs (ZoomToolの継承元)
IsChart (ZoomToolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
setAttributes (ZoomToolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ScrollTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool コンストラクタ

オーバーロードの一覧

public ScrollTool()
public ScrollTool(Steema.TeeChart.Chart)

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool コンストラクタ

public ScrollTool()

参照

ScrollTool コンストラクタのオーバーロードの一覧 | ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool コンストラクタ

public ScrollTool(Chart c)

参照

ScrollTool コンストラクタのオーバーロードの一覧 | ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

ScrollTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GenerateImageList |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
initScrollVars |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
SetCurrentZoom (ZoomToolの継承元) | ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。
SetSavedZoom (ZoomToolの継承元) | 現在のズーム状態をセッション変数に保存した場合、その保存されたズーム状態を現在のチャートに設定します。
ToString (Toolの継承元) |
Zoom (ZoomToolの継承元) | チャートをズームします。

プロテクト メソッド

Assign (ZoomToolの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
getZoomArgs (ZoomToolの継承元)
IsChart (ZoomToolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
setAttributes (ZoomToolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ScrollTool クラス | Steema.TeeChart.Tools 名前空間


GenerateImageList

Steema.TeeChart.Tools.ScrollTool.GenerateImageList メソッド

public String GenerateImageList(MemoryStream& chartImg,
     Int32& i,
     ImageExportFormat format,
     String fileRoot)

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


initScrollVars

Steema.TeeChart.Tools.ScrollTool.initScrollVars メソッド

public Void initScrollVars(Chart chart)

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ScrollTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Attributes | スクロールツールを作成するためのサポート属性。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomVariables (ZoomToolの継承元) | チャートの新しいページの呼び出しに任意のカスタム変数を追加します。
Description | 説明のテキストを取得します。
MouseAction | スクロール可能なチャート上でマウスドラッグされた時のアクションを設定します。
SegmentViewUnits | チャートを開いて表示する際の表示するセグメントの大きさや開始位置を設定するための単位。
StartPosition | チャートを開く際の開始位置。位置はパーセントまたは軸の値で表します。SegmentViewUnits を参照してください。
Summary | 詳細な説明テキストを取得します。
ViewSegmentSize | 表示するチャートのパーセント。
ZoomCanvasIndex (ZoomToolの継承元) | ズーム矩形描画の相対的なZ深さを取得/設定します。Webフォーム上に複数のオブジェクトが存在する場合、ズーム領域が有効にならない場合がありますので、この場合はズーム領域を最も上の位置に置く必要があります。
ZoomFillTransparency (ZoomToolの継承元) | ズームを指定する矩形の透明度（0～100%）を定義します。0（デフォルト）は透明になります。
ZoomPenColor (ZoomToolの継承元) | ズーム矩形のペンの色を設定します。

参照

ScrollTool クラス | Steema.TeeChart.Tools 名前空間


Attributes

Steema.TeeChart.Tools.ScrollTool.Attributes プロパティ

スクロールツールを作成するためのサポート属性。
public ScrollAttributes Attributes {get; set;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Description

Steema.TeeChart.Tools.ScrollTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


MouseAction

Steema.TeeChart.Tools.ScrollTool.MouseAction プロパティ

スクロール可能なチャート上でマウスドラッグされた時のアクションを設定します。
public ScrollMouseAction MouseAction {get; set;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


SegmentViewUnits

Steema.TeeChart.Tools.ScrollTool.SegmentViewUnits プロパティ

チャートを開いて表示する際の表示するセグメントの大きさや開始位置を設定するための単位。
public ScrollToolViewUnit SegmentViewUnits {get; set;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


StartPosition

Steema.TeeChart.Tools.ScrollTool.StartPosition プロパティ

チャートを開く際の開始位置。位置はパーセントまたは軸の値で表します。SegmentViewUnits を参照してください。
public Int32 StartPosition {get; set;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Summary

Steema.TeeChart.Tools.ScrollTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間


ViewSegmentSize

Steema.TeeChart.Tools.ScrollTool.ViewSegmentSize プロパティ

表示するチャートのパーセント。
public Int32 ViewSegmentSize {get; set;}

参照

ScrollTool クラス | ScrollTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Tools.ScrollToolViewUnit

Steema.TeeChart.Tools.ScrollToolViewUnit 列挙体

[Serializable]
public sealed enum ScrollToolViewUnit : Enum
, IComparable, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
percent | チャート幅のパーセントとして位置を設定します。
axisvalue | 軸値として位置を設定します。

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectEventHandler

Steema.TeeChart.Tools.SelectEventHandler デリゲート

public delegate SelectEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector

Steema.TeeChart.Tools.Selector クラス

このツールは、系列、軸、凡例、タイトル、などのようなチャートエレメントをクリックしてドラッグすることができます。そして、ユーザーがチャートエレメントをクリックして選択するか、ドラッグして新しい位置に配置するか、チャートをリサイズするとイベントが発生します。

この型のすべてのメンバの一覧については、Selector メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class Selector : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector 全メンバ

Selector 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Dragged | 左マウスボタンを離してドラッグ操作をした後に呼び出されます。
Dragging | チャートエレメント上でマウスの左ボタンを押しながら移動させると呼び出されます。
Resized | チャートのリサイズ操作が終った後、左マウスボタンを離した時に呼び出されます。
Resizing | マウスを移動させてチャートをリサイズしている最中に呼び出されます。
Selected | 以前に選択されたものと異なったチャート要素をクリックした際に発生します。

パブリック フィールド

Part

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
OnDragged |
OnDragging |
OnResized |
OnResizing |
OnSelected |
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag | 系列マーカ、凡例、タイトルなどのような選択されたチャートエレメントの移動を有効/無効にします。
AllowResizeChart | Trueの場合、セレクタツールは、チャート内のアイテムを選択してドラッグしたり、チャートをリサイズすることができます。
Annotation | 現在選択されているアノテーションツールを返します。アノテーションツールが選択されていない場合、ヌルを返します。
Brush | ペン特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Cursor |
Description | 説明のテキストを取得します。
DraggingShape | 現在、ドラッグしているオブジェクトを返します。
DrawHandles | セレクタツールが選択されたアイテムの角に小さな黒色の矩形を表示するかどうか制御します。
HandleSize | 選択されたアイテムの角に表示される小さな黒色の矩形のサイズをピクセル単位で取得/設定します。
Pen | ペン特性を取得/設定します。
Selection |
Series | 現在、選択されている系列を取得/設定します。選択されている系列がない場合は、nullを返します。
Summary | 詳細な説明テキストを取得します。
Wall | 現在、選択されている壁を取得/設定します。選択されている壁がない場合は、nullを返します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Selector クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector コンストラクタ

オーバーロードの一覧

public Selector()
public Selector(Steema.TeeChart.Chart)

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector コンストラクタ

public Selector()

参照

Selector コンストラクタのオーバーロードの一覧 | Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector コンストラクタ

public Selector(Chart c)

参照

Selector コンストラクタのオーバーロードの一覧 | Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector イベント

パブリック イベント

Dragged | 左マウスボタンを離してドラッグ操作をした後に呼び出されます。
Dragging | チャートエレメント上でマウスの左ボタンを押しながら移動させると呼び出されます。
Resized | チャートのリサイズ操作が終った後、左マウスボタンを離した時に呼び出されます。
Resizing | マウスを移動させてチャートをリサイズしている最中に呼び出されます。
Selected | 以前に選択されたものと異なったチャート要素をクリックした際に発生します。

参照

Selector クラス | Steema.TeeChart.Tools 名前空間


Dragged

Steema.TeeChart.Tools.Selector.Dragged イベント

左マウスボタンを離してドラッグ操作をした後に呼び出されます。
public SelectorDraggedEventHandler  Dragged

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Dragging

Steema.TeeChart.Tools.Selector.Dragging イベント

チャートエレメント上でマウスの左ボタンを押しながら移動させると呼び出されます。
public SelectorDraggingEventHandler  Dragging

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Resized

Steema.TeeChart.Tools.Selector.Resized イベント

チャートのリサイズ操作が終った後、左マウスボタンを離した時に呼び出されます。
public SelectorResizedEventHandler  Resized

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Resizing

Steema.TeeChart.Tools.Selector.Resizing イベント

マウスを移動させてチャートをリサイズしている最中に呼び出されます。
public SelectorResizingEventHandler  Resizing

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Selected

Steema.TeeChart.Tools.Selector.Selected イベント

以前に選択されたものと異なったチャート要素をクリックした際に発生します。
public SelectorSelectedEventHandler  Selected

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector フィールド

パブリック フィールド

Part

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

Selector クラス | Steema.TeeChart.Tools 名前空間


Part

Steema.TeeChart.Tools.Selector.Part フィールド

public ChartClickedPart Part

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
OnDragged |
OnDragging |
OnResized |
OnResizing |
OnSelected |
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Selector クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.Selector.Assign メソッド

protected abstract Void Assign(Tool t)

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.Selector.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.Selector.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


OnDragged

Steema.TeeChart.Tools.Selector.OnDragged メソッド

public abstract Void OnDragged()

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


OnDragging

Steema.TeeChart.Tools.Selector.OnDragging メソッド

public abstract Void OnDragging()

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


OnResized

Steema.TeeChart.Tools.Selector.OnResized メソッド

public abstract Void OnResized()

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


OnResizing

Steema.TeeChart.Tools.Selector.OnResizing メソッド

public abstract Void OnResizing()

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


OnSelected

Steema.TeeChart.Tools.Selector.OnSelected メソッド

public abstract Void OnSelected()

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Selector プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AllowDrag | 系列マーカ、凡例、タイトルなどのような選択されたチャートエレメントの移動を有効/無効にします。
AllowResizeChart | Trueの場合、セレクタツールは、チャート内のアイテムを選択してドラッグしたり、チャートをリサイズすることができます。
Annotation | 現在選択されているアノテーションツールを返します。アノテーションツールが選択されていない場合、ヌルを返します。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Cursor |
Description | 説明のテキストを取得します。
DraggingShape | 現在、ドラッグしているオブジェクトを返します。
DrawHandles | セレクタツールが選択されたアイテムの角に小さな黒色の矩形を表示するかどうか制御します。
HandleSize | 選択されたアイテムの角に表示される小さな黒色の矩形のサイズをピクセル単位で取得/設定します。
Pen | ペン特性を取得/設定します。
Selection |
Series | 現在、選択されている系列を取得/設定します。選択されている系列がない場合は、nullを返します。
Summary | 詳細な説明テキストを取得します。
Wall | 現在、選択されている壁を取得/設定します。選択されている壁がない場合は、nullを返します。

参照

Selector クラス | Steema.TeeChart.Tools 名前空間


AllowDrag

Steema.TeeChart.Tools.Selector.AllowDrag プロパティ

系列マーカ、凡例、タイトルなどのような選択されたチャートエレメントの移動を有効/無効にします。
public Boolean AllowDrag {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


AllowResizeChart

Steema.TeeChart.Tools.Selector.AllowResizeChart プロパティ

Trueの場合、セレクタツールは、チャート内のアイテムを選択してドラッグしたり、チャートをリサイズすることができます。
public Boolean AllowResizeChart {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Annotation

Steema.TeeChart.Tools.Selector.Annotation プロパティ

現在選択されているアノテーションツールを返します。アノテーションツールが選択されていない場合、ヌルを返します。
public Annotation Annotation {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.Selector.Brush プロパティ

ブラシ特性を取得/設定します。
public ChartBrush Brush {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Cursor

Steema.TeeChart.Tools.Selector.Cursor プロパティ

public Cursor Cursor {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Selector.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


DraggingShape

Steema.TeeChart.Tools.Selector.DraggingShape プロパティ

現在、ドラッグしているオブジェクトを返します。
public TextShapePosition DraggingShape {get;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


DrawHandles

Steema.TeeChart.Tools.Selector.DrawHandles プロパティ

セレクタツールが選択されたアイテムの角に小さな黒色の矩形を表示するかどうか制御します。
public Boolean DrawHandles {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


HandleSize

Steema.TeeChart.Tools.Selector.HandleSize プロパティ

選択されたアイテムの角に表示される小さな黒色の矩形のサイズをピクセル単位で取得/設定します。
public Int32 HandleSize {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.Selector.Pen プロパティ

ペン特性を取得/設定します。
public ChartPen Pen {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


SelectableParts

Steema.TeeChart.Tools.Selector.SelectableParts プロパティ

選択できるチャートのパートを取得/設定します。nullの場合、デフォルトとして全てのパートが選択できます。オブジェクトは、ChartClickedPartStyle列挙体あるいは系列あるいは軸のうち1つです。
private Points series1;
private Selector tool1;
private void InitializeChart()
{
tChart1.Series.Add(series1 = new Points());
tChart1.Tools.Add(tool1 = new Selector());

series1.FillSampleValues();

//左軸と凡例のみ選択可能
tool1.SelectableParts = new object[] { tChart1.Axes.Left, ChartClickedPartStyle.Legend };
tool1.Selected += new SelectorSelectedEventHandler(tool1_Selected);
}

void tool1_Selected(object sender, EventArgs e)
{
Steema.TeeChart.Editors.EditorUtils.EditChartPart(tChart1.Chart, tool1.Part, false);
}
public Object[] SelectableParts {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Selection

Steema.TeeChart.Tools.Selector.Selection プロパティ

public Object Selection {get;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Series

Steema.TeeChart.Tools.Selector.Series プロパティ

現在、選択されている系列を取得/設定します。選択されている系列がない場合は、nullを返します。
public Series Series {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.Selector.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Wall

Steema.TeeChart.Tools.Selector.Wall プロパティ

現在、選択されている壁を取得/設定します。選択されている壁がない場合は、nullを返します。
public Wall Wall {get; set;}

参照

Selector クラス | Selector メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectorDraggedEventHandler

Steema.TeeChart.Tools.SelectorDraggedEventHandler デリゲート

public delegate SelectorDraggedEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectorDraggingEventHandler

Steema.TeeChart.Tools.SelectorDraggingEventHandler デリゲート

public delegate SelectorDraggingEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectorResizedEventHandler

Steema.TeeChart.Tools.SelectorResizedEventHandler デリゲート

public delegate SelectorResizedEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectorResizingEventHandler

Steema.TeeChart.Tools.SelectorResizingEventHandler デリゲート

public delegate SelectorResizingEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SelectorSelectedEventHandler

Steema.TeeChart.Tools.SelectorSelectedEventHandler デリゲート

public delegate SelectorSelectedEventHandler (Object sender,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation

Steema.TeeChart.Tools.SeriesAnimation クラス

系列アニメーションツール。

この型のすべてのメンバの一覧については、SeriesAnimation メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesAnimation : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation 全メンバ

SeriesAnimation 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Step

パブリック メソッド

Clone (Toolの継承元) |
Execute |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
DrawEvery |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
StartAtMin |
StartValue |
Steps |
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesAnimation クラス | Steema.TeeChart.Tools 名前空間


SeriesAnimation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation コンストラクタ

オーバーロードの一覧

public SeriesAnimation(Steema.TeeChart.Styles.Series)
public SeriesAnimation()
public SeriesAnimation(Steema.TeeChart.Chart)

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


SeriesAnimation コンストラクタ

Steema.TeeChart.Tools.SeriesAnimation コンストラクタ

public SeriesAnimation(Series s)

参照

SeriesAnimation コンストラクタのオーバーロードの一覧 | SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


SeriesAnimation コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation コンストラクタ

public SeriesAnimation()

参照

SeriesAnimation コンストラクタのオーバーロードの一覧 | SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


SeriesAnimation コンストラクタ

Steema.TeeChart.Tools.SeriesAnimation コンストラクタ

public SeriesAnimation(Chart c)

参照

SeriesAnimation コンストラクタのオーバーロードの一覧 | SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation イベント

パブリック イベント

Step

参照

SeriesAnimation クラス | Steema.TeeChart.Tools 名前空間


Step

Steema.TeeChart.Tools.SeriesAnimation.Step イベント

public AnimationStepEventHandler  Step

解説

このイベントは、系列アニメーションツールにより各アニメーションステップで発生します。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

SeriesAnimation クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation メソッド

パブリック メソッド

Clone (Toolの継承元) |
Execute |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesAnimation クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.SeriesAnimation.Assign メソッド

protected abstract Void Assign(Tool t)

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Execute

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation.Execute メソッド

public Void Execute()

解説

アニメーションを実行します。

アニメーションが終了する前に、再度このメソッドを実行しないでください。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesAnimation プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description | 説明文字列を取得します。
DrawEvery |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
StartAtMin |
StartValue |
Steps |

参照

SeriesAnimation クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesAnimation.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

解説

説明テキストを取得します。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


DrawEvery

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation.DrawEvery プロパティ

public Int32 DrawEvery {get; set;}

解説

デフォルト値：0

デフォルトは、一度にすべての系列ポイントを使用してアニメーションが実行されます。

たとえば、このプロパティを1に設定すると、各系列ポイント毎にアニメーションが実行されます。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


StartAtMin

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation.StartAtMin プロパティ

public Boolean StartAtMin {get; set;}

解説

デフォルト値：true

アニメーションを全ての系列ポイントの最小値から開始するかどうか定義します。

このプロパティがfalseでStartValueプロパティを設定すると、アニメーションはその値で開始します。

例

[C#]

seriesAnimation1.StartAtMin = false;
seriesAnimation1.StartValue = 0;

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


StartValue

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation.StartValue プロパティ

public Double StartValue {get; set;}

解説

系列ポイントのアニメーションを実行する際の開始値を設定します。

例

[C#]

seriesAnimation1.StartAtMin = false;
seriesAnimation1.StartValue = 0;

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steps

TeeChartプログラミングガイド

Steema.TeeChart.Tools.SeriesAnimation.Steps プロパティ

public Int32 Steps {get; set;}

解説

デフォルト値：100

アニメーションステップの数を設定します。

ステップの数が大きくなるとアニメーションの速度は遅くなります。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesAnimation.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

SeriesAnimation クラス | SeriesAnimation メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool

Steema.TeeChart.Tools.SeriesBandTool クラス

系列バンドツール。2つの（リボン）系列の間にバンドを描画するために使用してください。これは、mkaul@leuze.deにより2003-12-14に作成されました。

この型のすべてのメンバの一覧については、SeriesBandTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesBandTool : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool 全メンバ

SeriesBandTool 概要

コンストラクタ

コンストラクタ オーバーロード。

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
BoundValue | バンド領域の制限の1つとして使用する定数の値を取得/設定します。メモ：BoundValueプロパティはSeries2プロパティが設定されていない（null）時だけ使用します。
Brush | ブラシ特性のエレメント。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明テキストを取得します。
DrawBehindSeries | Trueの場合、系列が描画される前に塗りつぶされ、Falseの場合、系列が描画された後に塗りつぶされます。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Gradient | 2つの系列の間の領域を塗りつぶすグラデーション色を取得/設定します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Series2 | このツールに関連付ける2番目の系列を取得/設定します。系列バンドツールは、2つの系列の間の領域を塗りつぶすために2つの系列が必要です。
Summary | 詳細な説明テキストを取得します。
Transparency | 2つの系列の間の領域を塗りつぶす際に適用する透明度を取得/設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AfterDrawValues
Assign (ToolSeriesの継承元)
BeforeDrawValues
ChartEvent
Dispose (Toolの継承元)
DrawBandTool
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetSeries2
SetStringProperty (TeeBaseの継承元)

参照

SeriesBandTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool コンストラクタ

オーバーロードの一覧

public SeriesBandTool()
public SeriesBandTool(Steema.TeeChart.Chart)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool コンストラクタ

public SeriesBandTool()

参照

SeriesBandTool コンストラクタのオーバーロードの一覧 | SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool コンストラクタ

public SeriesBandTool(Chart c)

参照

SeriesBandTool コンストラクタのオーバーロードの一覧 | SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesBandTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

AfterDrawValues
Assign (ToolSeriesの継承元)
BeforeDrawValues
ChartEvent
Dispose (Toolの継承元)
DrawBandTool
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetSeries2
SetStringProperty (TeeBaseの継承元)

参照

SeriesBandTool クラス | Steema.TeeChart.Tools 名前空間


AfterDrawValues

Steema.TeeChart.Tools.SeriesBandTool.AfterDrawValues メソッド

protected abstract Void AfterDrawValues(Object sender,
     Graphics3D g)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


BeforeDrawValues

Steema.TeeChart.Tools.SeriesBandTool.BeforeDrawValues メソッド

protected abstract Void BeforeDrawValues(Object sender,
     Graphics3D g)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.SeriesBandTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


DrawBandTool

Steema.TeeChart.Tools.SeriesBandTool.DrawBandTool メソッド

protected abstract Void DrawBandTool()

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


SetSeries

Steema.TeeChart.Tools.SeriesBandTool.SetSeries メソッド

protected abstract Void SetSeries(Series value)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


SetSeries2

Steema.TeeChart.Tools.SeriesBandTool.SetSeries2 メソッド

protected abstract Void SetSeries2(Series value)

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesBandTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
BoundValue | バンド領域の制限の1つとして使用する定数の値を取得/設定します。メモ：BoundValueプロパティはSeries2プロパティが設定されていない（null）時だけ使用します。
Brush | ブラシ特性のエレメント。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明テキストを取得します。
DrawBehindSeries | Trueの場合、系列が描画される前に塗りつぶされ、Falseの場合、系列が描画された後に塗りつぶされます。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Gradient | 2つの系列の間の領域を塗りつぶすグラデーション色を取得/設定します。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Series2 | このツールに関連付ける2番目の系列を取得/設定します。系列バンドツールは、2つの系列の間の領域を塗りつぶすために2つの系列が必要です。
Summary | 詳細な説明テキストを取得します。
Transparency | 2つの系列の間の領域を塗りつぶす際に適用する透明度を取得/設定します。

参照

SeriesBandTool クラス | Steema.TeeChart.Tools 名前空間


BoundValue

Steema.TeeChart.Tools.SeriesBandTool.BoundValue プロパティ

バンド領域の制限の1つとして使用する定数の値を取得/設定します。
メモ：BoundValueプロパティは Series2プロパティが設定されていない（null）時だけ使用します。
public Double BoundValue {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.SeriesBandTool.Brush プロパティ

ブラシ特性のエレメント。
public ChartBrush Brush {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesBandTool.Description プロパティ

説明テキストを取得します。
public override String Description {get;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


DrawBehindSeries

Steema.TeeChart.Tools.SeriesBandTool.DrawBehindSeries プロパティ

Trueの場合、系列が描画される前に塗りつぶされ、Falseの場合、系列が描画された後に塗りつぶされます。
public Boolean DrawBehindSeries {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Gradient

Steema.TeeChart.Tools.SeriesBandTool.Gradient プロパティ

2つの系列の間の領域を塗りつぶすグラデーション色を取得/設定します。
public Gradient Gradient {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.SeriesBandTool.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Series2

Steema.TeeChart.Tools.SeriesBandTool.Series2 プロパティ

このツールに関連付ける2番目の系列を取得/設定します。系列バンドツールは、2つの系列の間の領域を塗りつぶすために2つの系列が必要です。
public Series Series2 {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesBandTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Transparency

Steema.TeeChart.Tools.SeriesBandTool.Transparency プロパティ

2つの系列の間の領域を塗りつぶす際に適用する透明度を取得/設定します。
public Int32 Transparency {get; set;}

参照

SeriesBandTool クラス | SeriesBandTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot

Steema.TeeChart.Tools.SeriesHotspot クラス

ホットスポットの概要。

この型のすべてのメンバの一覧については、SeriesHotspot メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesHotspot : ToolSeries , IComponent, IDisposable
, ICloneable, IHotspot

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot 全メンバ

SeriesHotspot 概要

コンストラクタ

Constructor オーバーロードされたコンストラクタ

パブリック イベント

GetHTMLMap ホットスポットのマップのポイント領域の外観を変更するためにホットスポットイベントを使用してください。このイベントは、手動でWebフォームに追加してください。

パブリック メソッド

Clone (Toolの継承元) |
GenerateMap | チャートのマップを取得します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
GetMap | イメージマップのチャートのホットスポットの文字列を取得します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
HelperScript | ホットスポットツールを使用する際にチャートを自動制御するために用意されたクライアント側のスクリプトを提供します。
HotspotCanvasIndex | HotspotのAnnotationオブジェクトの相対的な座標系の深さを取得/設定します。Webフォーム上に複数のアイテムが存在する場合、Hotspotの領域が有効にならない場合があるので、この場合はAnnotationオブジェクトを最も上の位置に配置する必要があります。
MapAction | マップ領域がどのように動作するかを定義します。マップ領域をクリックすると、ポイントのラベル、新しいURL、あるいはVB/Jscriptedの機能（プログラム）を表示するよう定義できます。
MapElements | IDのような任意のエレメントをマップ定義に追加します。
MapRegion | チャートのマップ領域を定義します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style | ホットスポットのツールチップのテキスト書式を定義します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign |
ChartEvent (Toolの継承元) |
Dispose (Toolの継承元) |
DoGetHTMLMap | 内部使用。クライアント側にイベントがあるかどうかを確認して、ある場合はパラメーターを渡します。
KeyEvent (Toolの継承元) |
MouseEvent (Toolの継承元) |
OnDisposing (Toolの継承元) |
SeriesEvent (Toolの継承元) |
SetActive (Toolの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Toolの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeries (ToolSeriesの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

SeriesHotspot クラス | Steema.TeeChart.Tools 名前空間


SeriesHotspot コンストラクタ

Steema.TeeChart.Tools.SeriesHotspot コンストラクタ

オーバーロードの一覧

コンストラクタ。

public SeriesHotspot()

コンストラクタ。

public SeriesHotspot(Steema.TeeChart.Chart)

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


SeriesHotspot コンストラクタ

Steema.TeeChart.Tools.SeriesHotspot コンストラクタ

コンストラクタ。

public SeriesHotspot()

参照

SeriesHotspot コンストラクタ オーバーロードの一覧 | SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


SeriesHotspot コンストラクタ

Steema.TeeChart.Tools.SeriesHotspot コンストラクタ

コンストラクタ。

public SeriesHotspot(Chart c)

パラメーター

c
Hotspotを関連付けるチャート

参照

SeriesHotspot コンストラクタ オーバーロードの一覧 | SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot イベント

パブリック イベント

GetHTMLMap

ホットスポットのマップのポイント領域の外観を変更するためにホットスポットイベントを使用してください。このイベントは、手動でWebフォームに追加してください。

参照

SeriesHotspot クラス | Steema.TeeChart.Tools 名前空間


GetHTMLMap

Steema.TeeChart.Tools.SeriesHotspot.GetHTMLMap イベント

ホットスポットのマップのポイント領域の外観を変更するためにホットスポットイベントを使用してください。このイベントは、手動でWebフォームに追加してください。

public SeriesHotspotEventHandler  GetHTMLMap

例

//WebフォームのOnInitイベント。
override protected void OnInit(EventArgs e)
{

  ((Steema.TeeChart.Tools.Hotspot)(WebChart1.Chart.Tools[0])).GetHTMLMap +=
  new Steema.TeeChart.Tools.SeriesHotspotEventHandler(this.hotspot2_GetHTMLMap);

  base.OnInit(e);
}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

SeriesHotspot クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot メソッド

パブリック メソッド

Clone (Toolの継承元) |
GenerateMap | チャートのマップを取得します。
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
GetMap | イメージマップのチャートのホットスポットの文字列を取得します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign |
ChartEvent (Toolの継承元) |
Dispose (Toolの継承元) |
DoGetHTMLMap | 内部使用。クライアント側にイベントがあるかどうかを確認して、ある場合はパラメーターを渡します。
KeyEvent (Toolの継承元) |
MouseEvent (Toolの継承元) |
OnDisposing (Toolの継承元) |
SeriesEvent (Toolの継承元) |
SetActive (Toolの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart (Toolの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSeries (ToolSeriesの継承元) |
SetStringProperty (TeeBaseの継承元) |

参照

SeriesHotspot クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.SeriesHotspot.Assign メソッド

protected abstract Void Assign(Tool t)

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


DoGetHTMLMap

Steema.TeeChart.Tools.SeriesHotspot.DoGetHTMLMap メソッド

内部使用。クライアント側にイベントがあるかどうかを確認して、ある場合はパラメーターを渡します。

protected internal Void DoGetHTMLMap(Series s,
     PointPolygon p)

パラメーター

s
ポイントの系列
p
ポイントのマップ領域の多角形

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.SeriesHotspot.GenerateMap メソッド

オーバーロードの一覧

チャートのマップを取得します。

public virtual String GenerateMap(System.Drawing.Rectangle)

チャートのマップを取得します。

public virtual String GenerateMap()

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.SeriesHotspot.GenerateMap メソッド

チャートマップを取得します。
public virtual String GenerateMap(Rectangle bounds)

戻り値

イメージのホットスポットマップの文字列。

参照

GenerateMap オーバーロードの一覧 | SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


GenerateMap

Steema.TeeChart.Tools.SeriesHotspot.GenerateMap メソッド

チャートのマップを取得します。
public virtual String GenerateMap()

戻り値

Chart.ChartRectのための、イメージのホットスポットマップの文字列。

参照

GenerateMap オーバーロードの一覧 | SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


GetMap

Steema.TeeChart.Tools.SeriesHotspot.GetMap メソッド

イメージマップのチャートのホットスポットの文字列を取得します。
public String GetMap(MarksStyles style,
     Rectangle bounds)

パラメーター

style
マウスオーバーのヒントのマーカ表示スタイル

戻り値

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspot プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
HelperScript | ホットスポットツールを使用する際にチャートを自動制御するために用意されたクライアント側のスクリプトを提供します。
HotspotCanvasIndex | HotspotのAnnotationオブジェクトの相対的な座標系の深さを取得/設定します。Webフォーム上に複数のアイテムが存在する場合、Hotspotの領域が有効にならない場合があるので、この場合はAnnotationオブジェクトを最も上の位置に配置する必要があります。
MapAction | マップ領域がどのように動作するかを定義します。マップ領域をクリックすると、ポイントのラベル、新しいURL、あるいはVB/Jscriptedの機能（プログラム）を表示するよう定義できます。
MapElements | IDのような任意のエレメントをマップ定義に追加します。
MapRegion | チャートのマップ領域を定義します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Style | ホットスポットのツールチップのテキスト書式を定義します。
Summary | 詳細な説明テキストを取得します。

参照

SeriesHotspot クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesHotspot.Description プロパティ

説明テキストを取得します。

public override String Description {get;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


HelperScript

Steema.TeeChart.Tools.SeriesHotspot.HelperScript プロパティ

ホットスポットツールを使用する際にチャートを自動制御するために用意されたクライアント側のスクリプトを提供します。

public HotspotHelperScripts HelperScript {get; set;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


HotspotCanvasIndex

Steema.TeeChart.Tools.SeriesHotspot.HotspotCanvasIndex プロパティ

HotspotのAnnotationオブジェクトの相対的な座標系の深さを取得/設定します。Webフォーム上に複数のアイテムが存在する場合、Hotspotの領域が有効にならない場合があるので、この場合はAnnotationオブジェクトを最も上の位置に配置する必要があります。

public Int32 HotspotCanvasIndex {get; set;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


MapAction

Steema.TeeChart.Tools.SeriesHotspot.MapAction プロパティ

マップ領域がどのように動作するかを定義します。マップ領域をクリックすると、ポイントのラベル、新しいURL、あるいはVB/Jscriptedの機能（プログラム）を表示するよう定義できます。

public MapAction MapAction {get; set;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


MapElements

Steema.TeeChart.Tools.SeriesHotspot.MapElements プロパティ

IDのような任意のエレメントをマップ定義に追加します。

public virtual String MapElements {get; set;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


MapRegion

Steema.TeeChart.Tools.SeriesHotspot.MapRegion プロパティ

チャートのマップ領域を定義します。

public MapRegion MapRegion {get;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Style

Steema.TeeChart.Tools.SeriesHotspot.Style プロパティ

ホットスポットのツールチップのテキスト書式を定義します。

public MarksStyles Style {get; set;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesHotspot.Summary プロパティ

詳細な説明テキストを取得します。

public override String Summary {get;}

参照

SeriesHotspot クラス | SeriesHotspot メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspotEventArgs

Steema.TeeChart.Tools.SeriesHotspotEventArgs クラス

ホットスポットのイベントの引数。

この型のすべてのメンバの一覧については、 SeriesHotspotEventArgs メンバを参照してください。

System.Object
System.EventArgs
public class SeriesHotspotEventArgs : EventArgs

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

SeriesHotspotEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspotEventArgs 全メンバ

SeriesHotspotEventArgs 概要

コンストラクタ

Constructor コンストラクタ

パブリック プロパティ

PointPolygon | ポイントのマップ領域（多角形）の特性を取得/設定します。
Series | ポイントの系列を取得します。

参照

SeriesHotspotEventArgs クラス | Steema.TeeChart.Tools 名前空間


SeriesHotspotEventArgs コンストラクタ

Steema.TeeChart.Tools.SeriesHotspotEventArgs コンストラクタ

コンストラクタ。

public SeriesHotspotEventArgs(Series s,
     PointPolygon p)

パラメーター

s
ポイントの系列
p
ポイントのマップ領域（多角形）の特性

参照

SeriesHotspotEventArgs クラス | SeriesHotspotEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspotEventArgs プロパティ

パブリック プロパティ

PointPolygon | ポイントのマップ領域（多角形）の特性を取得/設定します。
Series | ポイントの系列を取得します。

参照

SeriesHotspotEventArgs クラス | Steema.TeeChart.Tools 名前空間


PointPolygon

Steema.TeeChart.Tools.SeriesHotspotEventArgs.PointPolygon プロパティ

ポイントのマップ領域（多角形）の特性を取得/設定します。

public PointPolygon PointPolygon {get; set;}

参照

SeriesHotspotEventArgs クラス | SeriesHotspotEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Series

Steema.TeeChart.Tools.SeriesHotspotEventArgs.Series プロパティ

ポイントの系列を取得します。

public Series Series {get;}

参照

SeriesHotspotEventArgs クラス | SeriesHotspotEventArgs メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesHotspotEventHandler

Steema.TeeChart.Tools.SeriesHotspotEventHandler デリゲート

ホットスポットツールのGetHTMLMapイベントハンドラ。

public delegate SeriesHotspotEventHandler (SeriesHotspot sender,
     SeriesHotspotEventArgs e)

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool

Steema.TeeChart.Tools.SeriesRegionTool クラス

領域ツール。これは、（系列ポイントの）カーブで囲まれている領域に色をつけます。

この型のすべてのメンバの一覧については、SeriesRegionTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesRegionTool : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool 全メンバ

SeriesRegionTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AutoBound | Trueの場合、リージョンの左と右の境界は系列の最小値・最大値と等しくなります。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 領域の色を設定します。
Description | 説明のテキストを取得します。
DrawBehindSeries | Trueの場合、系列の背面にリージョンを描画します。Falseの場合、系列の前にリージョンを描画します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Gradient | 領域のグラデーションを設定します。
LowerBound | AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを開始する系列のポイントインデックス値を定義します。
Origin | UseOriginプロパティがTrueの場合、ポイント値とOriginプロパティ値の間を領域ツールで塗りつぶします。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。
Transparency | パーセントとして領域の透明度を設定します。
UpperBound | AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを終了する系列のポイントインデックス値を定義します。
UseOrigin | Trueの場合、領域ツールはポイント値とOriginプロパティ値を使用して塗りつぶします。Falseの場合、領域ツールはポイント値と軸線の間を塗りつぶします。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesRegionTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool コンストラクタ

オーバーロードの一覧

public SeriesRegionTool()
public SeriesRegionTool(Steema.TeeChart.Chart)

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool コンストラクタ

public SeriesRegionTool()

参照

SeriesRegionTool コンストラクタのオーバーロードの一覧 | SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool コンストラクタ

public SeriesRegionTool(Chart c)

参照

SeriesRegionTool コンストラクタのオーバーロードの一覧 | SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesRegionTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesRegionTool クラス | Steema.TeeChart.Tools 名前空間


SeriesEvent

Steema.TeeChart.Tools.SeriesRegionTool.SeriesEvent メソッド

protected internal abstract Void SeriesEvent(EventArgs e)

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesRegionTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
AutoBound | Trueの場合、リージョンの左と右の境界は系列の最小値・最大値と等しくなります。
Brush | ブラシ特性を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color | 領域の色を設定します。
Description | 説明のテキストを取得します。
DrawBehindSeries | Trueの場合、系列の背面にリージョンを描画します。Falseの場合、系列の前にリージョンを描画します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Gradient | 領域のグラデーションを設定します。
LowerBound | AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを開始する系列のポイントインデックス値を定義します。
Origin | UseOriginプロパティがTrueの場合、ポイント値とOriginプロパティ値の間を領域ツールで塗りつぶします。
Pen | ペン特性のエレメント。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。
Transparency | パーセントとして領域の透明度を設定します。
UpperBound | AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを終了する系列のポイントインデックス値を定義します。
UseOrigin | Trueの場合、領域ツールはポイント値とOriginプロパティ値を使用して塗りつぶします。Falseの場合、領域ツールはポイント値と軸線の間を塗りつぶします。

参照

SeriesRegionTool クラス | Steema.TeeChart.Tools 名前空間


AutoBound

Steema.TeeChart.Tools.SeriesRegionTool.AutoBound プロパティ

Trueの場合、リージョンの左と右の境界は系列の最小値・最大値と等しくなります。
public Boolean AutoBound {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Brush

Steema.TeeChart.Tools.SeriesRegionTool.Brush プロパティ

ブラシ特性を取得/設定します。
public ChartBrush Brush {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Color

Steema.TeeChart.Tools.SeriesRegionTool.Color プロパティ

領域の色を設定します。
public Color Color {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesRegionTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


DrawBehindSeries

Steema.TeeChart.Tools.SeriesRegionTool.DrawBehindSeries プロパティ

Trueの場合、系列の背面にリージョンを描画します。Falseの場合、系列の前にリージョンを描画します。
public Boolean DrawBehindSeries {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Gradient

Steema.TeeChart.Tools.SeriesRegionTool.Gradient プロパティ

領域のグラデーションを設定します。
public Gradient Gradient {get;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


LowerBound

Steema.TeeChart.Tools.SeriesRegionTool.LowerBound プロパティ

AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを開始する系列のポイントインデックス値を定義します。
public Double LowerBound {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Origin

Steema.TeeChart.Tools.SeriesRegionTool.Origin プロパティ

UseOriginプロパティがTrueの場合、ポイント値とOriginプロパティ値の間を領域ツールで塗りつぶします。
public Double Origin {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間 | UseOrigin


Pen

Steema.TeeChart.Tools.SeriesRegionTool.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesRegionTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


Transparency

Steema.TeeChart.Tools.SeriesRegionTool.Transparency プロパティ

パーセントとして領域の透明度を設定します。
public Int32 Transparency {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


UpperBound

Steema.TeeChart.Tools.SeriesRegionTool.UpperBound プロパティ

AutoBoundプロパティがFalseの場合、領域ツールの塗りつぶしを終了する系列のポイントインデックス値を定義します。
public Double UpperBound {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間


UseOrigin

Steema.TeeChart.Tools.SeriesRegionTool.UseOrigin プロパティ

Trueの場合、領域ツールはポイント値とOriginプロパティ値を使用して塗りつぶします。Falseの場合、領域ツールはポイント値と軸線の間を塗りつぶします。
public Boolean UseOrigin {get; set;}

参照

SeriesRegionTool クラス | SeriesRegionTool メンバ | Steema.TeeChart.Tools 名前空間 | Origin


Steema.TeeChart.Tools.SeriesStats

Steema.TeeChart.Tools.SeriesStats クラス

基本的な系列統計を計算します。

この型のすべてのメンバの一覧については、SeriesStats メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SeriesStats : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats 全メンバ

SeriesStats 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description |
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Statistics | 統計はテキスト形式で記録します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesStats クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats コンストラクタ

オーバーロードの一覧

public SeriesStats()
public SeriesStats(Steema.TeeChart.Chart)

参照

SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats コンストラクタ

public SeriesStats()

参照

SeriesStats コンストラクタのオーバーロードの一覧 | SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats コンストラクタ

public SeriesStats(Chart c)

参照

SeriesStats コンストラクタのオーバーロードの一覧 | SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesStats クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (ToolSeriesの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesStats クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesStats プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description |
GetHorizAxis (ToolSeriesの継承元) | 関連付けられたチャートの水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連付けられたチャートの垂直軸（左軸あるいは右軸）を返します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Statistics | 統計はテキスト形式で記録します。
Summary | 詳細な説明テキストを取得します。

参照

SeriesStats クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesStats.Description プロパティ

public override String Description {get;}

参照

SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Statistics

Steema.TeeChart.Tools.SeriesStats.Statistics プロパティ

統計はテキスト形式で記録します。
public String Statistics {get;}

参照

SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesStats.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SeriesStats クラス | SeriesStats メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose

Steema.TeeChart.Tools.SeriesTranspose クラス

複数の系列を置換します（行と列を交換）。

この型のすべてのメンバの一覧については、SeriesTranspose メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class SeriesTranspose : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose 全メンバ

SeriesTranspose 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |
Transpose |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesTranspose クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose コンストラクタ

オーバーロードの一覧

public SeriesTranspose()
public SeriesTranspose(Steema.TeeChart.Chart)

参照

SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose コンストラクタ

public SeriesTranspose()

参照

SeriesTranspose コンストラクタのオーバーロードの一覧 | SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose コンストラクタ

public SeriesTranspose(Chart c)

参照

SeriesTranspose コンストラクタのオーバーロードの一覧 | SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SeriesTranspose クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |
Transpose |

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SeriesTranspose クラス | Steema.TeeChart.Tools 名前空間


Transpose

Steema.TeeChart.Tools.SeriesTranspose.Transpose メソッド

public Void Transpose()

参照

SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SeriesTranspose プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。

参照

SeriesTranspose クラス | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SeriesTranspose.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SeriesTranspose.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SeriesTranspose クラス | SeriesTranspose メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SnapStyle

Steema.TeeChart.Tools.SnapStyle 列挙体

SnapプロパティがTrueの場合、SnapStyleプロパティはマウスを近づけたときに既存の系列ポイントに「ジャンプ」するかどうかを定義します。
[Serializable]
public sealed enum SnapStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ | 説明
Default |
Horizontal |
Vertical |

参照

Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart

Steema.TeeChart.Tools.SubChart クラス

この型のすべてのメンバの一覧については、SubChart メンバを参照してください。

System.Object
public class SubChart : Object

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart 全メンバ

SubChart 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Bounds

パブリック プロパティ

Chart |
Data |
Height | チャートの高さをピクセル単位で設定します。
ITool |
Left | チャートの左の位置をピクセル単位で設定します。
Top | チャートの上の位置をピクセル単位で設定します。
Width | チャートの幅をピクセル単位で設定します。

参照

SubChart クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart コンストラクタ

オーバーロードの一覧

public SubChart()
public SubChart(Steema.TeeChart.Tools.ChartCollection)

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart コンストラクタ

public SubChart()

参照

SubChart コンストラクタのオーバーロードの一覧 | SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart コンストラクタ

public SubChart(ChartCollection collection)

参照

SubChart コンストラクタのオーバーロードの一覧 | SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart メソッド

パブリック メソッド

Bounds

参照

SubChart クラス | Steema.TeeChart.Tools 名前空間


Bounds

Steema.TeeChart.Tools.SubChart.Bounds メソッド

public Rectangle Bounds()

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChart プロパティ

パブリック プロパティ

Chart |
Data |
Height | チャートの高さをピクセル単位で設定します。
ITool |
Left | チャートの左の位置をピクセル単位で設定します。
Top | チャートの上の位置をピクセル単位で設定します。
Width | チャートの幅をピクセル単位で設定します。

参照

SubChart クラス | Steema.TeeChart.Tools 名前空間


Chart

Steema.TeeChart.Tools.SubChart.Chart プロパティ

public TChart Chart {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Data

Steema.TeeChart.Tools.SubChart.Data プロパティ

public String Data {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Height

Steema.TeeChart.Tools.SubChart.Height プロパティ

チャートの高さをピクセル単位で設定します。
public Int32 Height {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


ITool

Steema.TeeChart.Tools.SubChart.ITool プロパティ

public Tool ITool {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Left

Steema.TeeChart.Tools.SubChart.Left プロパティ

チャートの左の位置をピクセル単位で設定します。
public Int32 Left {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Top

Steema.TeeChart.Tools.SubChart.Top プロパティ

チャートの上の位置をピクセル単位で設定します。
public Int32 Top {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Width

Steema.TeeChart.Tools.SubChart.Width プロパティ

チャートの幅をピクセル単位で設定します。
public Int32 Width {get; set;}

参照

SubChart クラス | SubChart メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool

Steema.TeeChart.Tools.SubChartTool クラス

サブチャートツール。

この型のすべてのメンバの一覧については、SubChartTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class SubChartTool : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool 全メンバ

SubChartTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Charts | サブチャートツール内のチャートコレクションを取得/設定します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SubChartTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool コンストラクタ

オーバーロードの一覧

public SubChartTool()
public SubChartTool(Steema.TeeChart.Chart)

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool コンストラクタ

public SubChartTool()

参照

SubChartTool コンストラクタのオーバーロードの一覧 | SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool コンストラクタ

public SubChartTool(Chart c)

参照

SubChartTool コンストラクタのオーバーロードの一覧 | SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

SubChartTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign (Toolの継承元)
ChartEvent
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SubChartTool クラス | Steema.TeeChart.Tools 名前空間


ChartEvent

Steema.TeeChart.Tools.SubChartTool.ChartEvent メソッド

protected internal abstract Void ChartEvent(EventArgs e)

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.SubChartTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.SubChartTool.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SubChartTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Charts | サブチャートツール内のチャートコレクションを取得/設定します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。

参照

SubChartTool クラス | Steema.TeeChart.Tools 名前空間


Charts

Steema.TeeChart.Tools.SubChartTool.Charts プロパティ

サブチャートツール内のチャートコレクションを取得/設定します。
public ChartCollection Charts {get; set;}

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SubChartTool.Description プロパティ

説明のテキストを取得します。
public override String Description {get;}

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SubChartTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SubChartTool クラス | SubChartTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool

Steema.TeeChart.Tools.SurfaceNearestTool クラス

サーフェス系列上にマウスを移動した際に、マウスカーソルに最も近いサーフェスセルを示します。

この型のすべてのメンバの一覧については、SurfaceNearestTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
Steema.TeeChart.Tools.ToolSeries
public class SurfaceNearestTool : ToolSeries , IComponent, IDisposable
, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool 全メンバ

SurfaceNearestTool 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

Select

パブリック フィールド

SelectedCell

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
GetRowCol | マウスカーソルの下にある行数と列数をRowパラメーターとColパラメーターに代入します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
CellColor | マウスカーソルの下にあるサーフェスセルを塗りつぶす色を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColumnColor | マウスカーソルの下にあるグリッド列のすべてのサーフェスセルを塗りつぶす色を取得/設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
RowColor | マウスカーソルの下にあるグリッド行のすべてのサーフェスセルを塗りつぶす色を取得/設定します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SurfaceNearestTool クラス | Steema.TeeChart.Tools 名前空間


SurfaceNearestTool コンストラクタ

Steema.TeeChart.Tools.SurfaceNearestTool コンストラクタ

オーバーロードの一覧

public SurfaceNearestTool(Steema.TeeChart.Styles.Series)
public SurfaceNearestTool()
public SurfaceNearestTool(Steema.TeeChart.Chart)

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


SurfaceNearestTool コンストラクタ

Steema.TeeChart.Tools.SurfaceNearestTool コンストラクタ

public SurfaceNearestTool(Series s)

参照

SurfaceNearestTool コンストラクタのオーバーロードの一覧 | SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


SurfaceNearestTool コンストラクタ

Steema.TeeChart.Tools.SurfaceNearestTool コンストラクタ

public SurfaceNearestTool()

参照

SurfaceNearestTool コンストラクタのオーバーロードの一覧 | SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


SurfaceNearestTool コンストラクタ

Steema.TeeChart.Tools.SurfaceNearestTool コンストラクタ

public SurfaceNearestTool(Chart c)

参照

SurfaceNearestTool コンストラクタのオーバーロードの一覧 | SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool イベント

パブリック イベント

Select

参照

SurfaceNearestTool クラス | Steema.TeeChart.Tools 名前空間


Select

Steema.TeeChart.Tools.SurfaceNearestTool.Select イベント

public SelectEventHandler  Select

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool フィールド

パブリック フィールド

SelectedCell

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries (ToolSeriesの継承元)
pPen (Toolの継承元)

参照

SurfaceNearestTool クラス | Steema.TeeChart.Tools 名前空間


SelectedCell

Steema.TeeChart.Tools.SurfaceNearestTool.SelectedCell フィールド

public Int32 SelectedCell

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
GetRowCol | マウスカーソルの下にある行数と列数をRowパラメーターとColパラメーターに代入します。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries (ToolSeriesの継承元)
SetStringProperty (TeeBaseの継承元)

参照

SurfaceNearestTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.SurfaceNearestTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


GetRowCol

Steema.TeeChart.Tools.SurfaceNearestTool.GetRowCol メソッド

マウスカーソルの下にある行数と列数をRowパラメーターとColパラメーターに代入します。

public Void GetRowCol(Double& Row,
     Double& Col)

解説

マウスカーソルの下にある行数と列数をRowパラメーターとColパラメーターに代入します。

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.SurfaceNearestTool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.SurfaceNearestTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
CellColor | マウスカーソルの下にあるサーフェスセルを塗りつぶす色を取得/設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ColumnColor | マウスカーソルの下にあるグリッド列のすべてのサーフェスセルを塗りつぶす色を取得/設定します。
Description | 説明のテキストを取得します。
GetHorizAxis (ToolSeriesの継承元) | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis (ToolSeriesの継承元) | 関連する垂直軸（左軸あるいは右軸）を返します。
RowColor | マウスカーソルの下にあるグリッド行のすべてのサーフェスセルを塗りつぶす色を取得/設定します。
Series (ToolSeriesの継承元) | ツールに関連付ける系列を設定します。
Summary | 詳細な説明テキストを取得します。

参照

SurfaceNearestTool クラス | Steema.TeeChart.Tools 名前空間


CellColor

Steema.TeeChart.Tools.SurfaceNearestTool.CellColor プロパティ

マウスカーソルの下にあるサーフェスセルを塗りつぶす色を取得/設定します。

public Color CellColor {get; set;}

解説

マウスカーソルの下にあるサーフェスセルを塗りつぶす色を取得/設定します。

このプロパティをclNoneに設定すると、そのセルを非表示にします。

clTeeColorに設定すると、デフォルトのセルの色を変更しません。

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


ColumnColor

Steema.TeeChart.Tools.SurfaceNearestTool.ColumnColor プロパティ

マウスカーソルの下にあるグリッド列のすべてのサーフェスセルを塗りつぶす色を取得/設定します。

public Color ColumnColor {get; set;}

解説

マウスカーソルの下にあるグリッド列のすべてのサーフェスセルを塗りつぶす色を取得/設定します。

このプロパティをclNoneに設定すると、選択した列のセルすべてを非表示にします。

clTeeColorに設定すると、デフォルトのセルの色を変更しません。

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.SurfaceNearestTool.Description プロパティ

説明のテキストを取得します。

public override String Description {get;}

解説

説明テキストを取得します。

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


RowColor

Steema.TeeChart.Tools.SurfaceNearestTool.RowColor プロパティ

マウスカーソルの下にあるグリッド行のすべてのサーフェスセルを塗りつぶす色を取得/設定します。

public Color RowColor {get; set;}

解説

マウスカーソルの下にあるグリッド行のすべてのサーフェスセルを塗りつぶす色を取得/設定します。

このプロパティをclNoneに設定すると、選択した行のセルすべてを非表示にします。

clTeeColorに設定するとデフォルトのセルの色を変更しません。

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.SurfaceNearestTool.Summary プロパティ

詳細な説明テキストを取得します。
public override String Summary {get;}

参照

SurfaceNearestTool クラス | SurfaceNearestTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend

Steema.TeeChart.Tools.TableLegend クラス

凡例シェープ。

この型のすべてのメンバの一覧については、TableLegend メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Shape
public class TableLegend : Shape , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend 全メンバ

TableLegend 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

パブリック プロパティ

Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Font |
FontSeriesColor |
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
OtherSide |
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Symbol |
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

TableLegend クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend コンストラクタ

オーバーロードの一覧

public TableLegend()
public TableLegend(Steema.TeeChart.Chart)

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend コンストラクタ

public TableLegend()

参照

TableLegend コンストラクタのオーバーロードの一覧 | TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend コンストラクタ

public TableLegend(Chart c)

参照

TableLegend コンストラクタのオーバーロードの一覧 | TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend フィールド

プロテクト フィールド

bBevel (Shapeの継承元)
bBorderRound (Shapeの継承元)
bBrush (Shapeの継承元)
bImageBevel (Shapeの継承元)
bTransparent (Shapeの継承元)
defaultVisible (Shapeの継承元)
iBottom (Shapeの継承元)
iHeight (Shapeの継承元)
iLeft (Shapeの継承元)
InternalUse (TeeBaseの継承元)
iRight (Shapeの継承元)
iTop (Shapeの継承元)
iWidth (Shapeの継承元)
pPen (Shapeの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

参照

TableLegend クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend メソッド

パブリック メソッド

Assign (Shapeの継承元) | すべてのプロパティをシェープから他のシェープへ割り当てます。
Clone (Shapeの継承元) |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Paint (Shapeの継承元) |

プロテクト メソッド

AssignShape (Shapeの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)
ShouldSerializeBottom (Shapeの継承元)
ShouldSerializeLeft (Shapeの継承元)
ShouldSerializeRight (Shapeの継承元)
ShouldSerializeTop (Shapeの継承元)
ShouldSerializeTransparent (Shapeの継承元)
ShouldSerializeVisible (Shapeの継承元)

参照

TableLegend クラス | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.TableLegend.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.TableLegend プロパティ

パブリック プロパティ

Bevel (Shapeの継承元) | シェープのベベル特性を設定します。
BevelInner (Shapeの継承元) |
BevelOuter (Shapeの継承元) |
BevelWidth (Shapeの継承元) |
BorderRound (Shapeの継承元) | チャートの枠を丸くします。
Bottom (Shapeの継承元) | シェープ矩形の下座標を取得/設定します。
Brush (Shapeの継承元) | シェープの背面を塗りつぶすブラシの種類を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Shapeの継承元) | シェープの色を定義します。
Font |
FontSeriesColor |
Gradient (Shapeの継承元) | シェープのグラデーション特性を設定します。
Height (Shapeの継承元) | シェープの高さを取得/設定します。
Image (Shapeの継承元) | シェープの背面に表示するイメージを設定します。
ImageBevel (Shapeの継承元) | シェープのベベル特性を設定します。
ImageMode (Shapeの継承元) | 設定されたシェープの背面イメージの表示スタイルを設定します。
ImageTransparent (Shapeの継承元) | シェープのイメージを透明に設定します。
Left (Shapeの継承元) | シェープ矩形の左座標を取得/設定します。
OtherSide |
Pen (Shapeの継承元) | シェープを描くペンを指定します。
Right (Shapeの継承元) | シェープ矩形の右座標を取得/設定します。
Shadow (Shapeの継承元) | シェープの影の特性を定義します。
ShapeBounds (Shapeの継承元) | シェープの境界を定義します。
Symbol |
Top (Shapeの継承元) | シェープ矩形の上座標を取得/設定します。
Transparency (Shapeの継承元) | 0～100%までのシェープの透明度を設定します。
Transparent (Shapeの継承元) | シェープの透明度を有効/無効にします。
Visible (Shapeの継承元) | シェープを表示/非表示にします。
Width (Shapeの継承元) | シェープの幅を取得/設定します。

参照

TableLegend クラス | Steema.TeeChart.Tools 名前空間


Font

Steema.TeeChart.Tools.TableLegend.Font プロパティ

public ChartFont Font {get; set;}

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


FontSeriesColor

Steema.TeeChart.Tools.TableLegend.FontSeriesColor プロパティ

public Boolean FontSeriesColor {get; set;}

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


OtherSide

Steema.TeeChart.Tools.TableLegend.OtherSide プロパティ

public Boolean OtherSide {get; set;}

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Symbol

Steema.TeeChart.Tools.TableLegend.Symbol プロパティ

public LegendSymbol Symbol {get; set;}

参照

TableLegend クラス | TableLegend メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Tool

Steema.TeeChart.Tools.Tool クラス

基本ツールクラス。

この型のすべてのメンバの一覧については、Tool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
public class Tool : TeeBase , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

Tool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Tool 全メンバ

Tool 概要

コンストラクタ

Constructor オーバーロード。Windows.Formsクラスのコンポジションデザイナーサポートのために必要です。

パブリック フィールド

ClickTolerance

パブリック メソッド

Clone |
CreateNewTool | 新しいツールオブジェクトを作成して、ツール型やチャートを設定します。
GetBitmapEditor | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NewFromType | 既存のツールオブジェクトのSystem.Typeから新しいツールを作成します。
ToString |

パブリック プロパティ

Active | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description |
Summary |

プロテクト フィールド

bBrush
InternalUse (TeeBaseの継承元)
pPen
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent
Dispose
KeyEvent
MouseEvent
OnDisposing
SeriesEvent
SetActive
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Tool クラス | Steema.TeeChart.Tools 名前空間


Tool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool コンストラクタ

オーバーロードの一覧

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public Tool(System.ComponentModel.IContainer)
protected Tool(Steema.TeeChart.Chart)
protected Tool()

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Tool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool コンストラクタ

Windows.Formクラスのコンポジションデザイナーサポートのために必要です。

public Tool(IContainer container)

参照

Tool コンストラクタのオーバーロードの一覧 | Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Tool コンストラクタ

Steema.TeeChart.Tools.Tool コンストラクタ

protected Tool(Chart c)

参照

Tool コンストラクタのオーバーロードの一覧 | Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Tool コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool コンストラクタ

protected Tool()

参照

Tool コンストラクタのオーバーロードの一覧 | Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Tool フィールド

パブリック フィールド

ClickTolerance

プロテクト フィールド

bBrush
InternalUse (TeeBaseの継承元)
pPen

参照

Tool クラス | Steema.TeeChart.Tools 名前空間


bBrush

Steema.TeeChart.Tools.Tool.bBrush フィールド

protected ChartBrush bBrush

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


ClickTolerance

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool.ClickTolerance フィールド

public Int32 ClickTolerance

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


pPen

Steema.TeeChart.Tools.Tool.pPen フィールド

protected ChartPen pPen

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Tool メソッド

パブリック メソッド

Clone |
CreateNewTool | 新しいツールオブジェクトを作成して、ツール型やチャートを設定します。
GetBitmapEditor | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
NewFromType | 既存のツールオブジェクトのSystem.Typeから新しいツールを作成します。
ToString |

プロテクト メソッド

Assign
ChartEvent
Dispose
KeyEvent
MouseEvent
OnDisposing
SeriesEvent
SetActive
SetBooleanProperty (TeeBaseの継承元)
SetChart
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

Tool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.Tool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


ChartEvent

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool.ChartEvent メソッド

protected internal virtual Void ChartEvent(EventArgs e)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Clone

Steema.TeeChart.Tools.Tool.Clone メソッド

public virtual Object Clone()

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


CreateNewTool

Steema.TeeChart.Tools.Tool.CreateNewTool メソッド

新しいツールオブジェクトを作成して、ツール型やチャートを設定します。
public static Tool CreateNewTool(Chart chart,
     Type type)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Dispose

Steema.TeeChart.Tools.Tool.Dispose メソッド

protected override Void Dispose(Boolean disposing)

解説

使用したリソースを削除します。

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


GetBitmapEditor

Steema.TeeChart.Tools.Tool.GetBitmapEditor メソッド

指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
public Image GetBitmapEditor()

解説

指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


KeyEvent

Steema.TeeChart.Tools.Tool.KeyEvent メソッド

protected internal abstract Void KeyEvent(KeyEventArgs e)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


MouseEvent

Steema.TeeChart.Tools.Tool.MouseEvent メソッド

protected internal abstract Void MouseEvent(MouseEventKinds kind,
     MouseEventArgs e,
     Cursor& c)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


NewFromType

Steema.TeeChart.Tools.Tool.NewFromType メソッド

既存のツールオブジェクトのSystem.Typeから新しいツールを作成します。
public static Tool NewFromType(Type type)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


OnDisposing

Steema.TeeChart.Tools.Tool.OnDisposing メソッド

protected internal abstract Void OnDisposing()

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


SeriesEvent

Steema.TeeChart.Tools.Tool.SeriesEvent メソッド

protected internal abstract Void SeriesEvent(EventArgs e)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


SetActive

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool.SetActive メソッド

protected virtual Void SetActive(Boolean value)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


SetChart

Steema.TeeChart.Tools.Tool.SetChart メソッド

protected abstract Void SetChart(Chart value)

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


ToString

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool.ToString メソッド

public virtual String ToString()

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.Tool プロパティ

パブリック プロパティ

Active | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description |

参照

Tool クラス | Steema.TeeChart.Tools 名前空間


Active

TeeChartプログラミングガイド

Steema.TeeChart.Tools.Tool.Active プロパティ

指定したインデックスのツールを有効/無効にします。

public Boolean Active {get; set;}

解説

指定したインデックスのツールを有効/無効にします。

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.Tool.Description プロパティ

public abstract String Description {get;}

解説

説明テキストを取得します。

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.Tool.Summary プロパティ

public abstract String Summary {get;}

解説

詳細な説明テキストを取得します。

参照

Tool クラス | Tool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolAxis

Steema.TeeChart.Tools.ToolAxis クラス

Axisプロパティを持つツールコンポーネントの基本的な抽象クラス。

この型のすべてのメンバの一覧については、ToolAxis メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ToolAxis : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolAxis 全メンバ

ToolAxis 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description (Toolの継承元) |
Pen | ペン特性のエレメント。
Summary (Toolの継承元) |

プロテクト フィールド

bBrush (Toolの継承元)
iAxis
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ToolAxis クラス | Steema.TeeChart.Tools 名前空間


ToolAxis コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ToolAxis コンストラクタ

オーバーロードの一覧

public ToolAxis()
public ToolAxis(Steema.TeeChart.Chart)
public ToolAxis(Steema.TeeChart.Axis)

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


ToolAxis コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ToolAxis コンストラクタ

public ToolAxis()

参照

ToolAxis コンストラクタのオーバーロードの一覧 | ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


ToolAxis コンストラクタ

Steema.TeeChart.Tools.ToolAxis コンストラクタ

public ToolAxis(Chart c)

参照

ToolAxis コンストラクタのオーバーロードの一覧 | ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


ToolAxis コンストラクタ

Steema.TeeChart.Tools.ToolAxis コンストラクタ

public ToolAxis(Axis a)

参照

ToolAxis コンストラクタのオーバーロードの一覧 | ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolAxis フィールド

プロテクト フィールド

bBrush (Toolの継承元)
iAxis
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

ToolAxis クラス | Steema.TeeChart.Tools 名前空間


iAxis

Steema.TeeChart.Tools.ToolAxis.iAxis フィールド

protected Axis iAxis

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolAxis メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetAxis
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ToolAxis クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ToolAxis.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


SetAxis

Steema.TeeChart.Tools.ToolAxis.SetAxis メソッド

protected internal abstract Void SetAxis(Axis value)

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolAxis プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Axis | ツールを適用させる軸を設定します。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description (Toolの継承元) |

参照

ToolAxis クラス | Steema.TeeChart.Tools 名前空間


Axis

Steema.TeeChart.Tools.ToolAxis.Axis プロパティ

ツールを適用させる軸を設定します。
public Axis Axis {get; set;}

解説

ツールを適用させる軸を設定します。

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Pen

Steema.TeeChart.Tools.ToolAxis.Pen プロパティ

ペン特性のエレメント。
public ChartPen Pen {get;}

解説

ペン特性のエレメント。
線や枠を描くためにこのプロパティを使用します。

参照

ToolAxis クラス | ToolAxis メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolsCollection

Steema.TeeChart.Tools.ToolsCollection クラス

ツールコンポーネントのコレクション。

この型のすべてのメンバの一覧については、ToolsCollection メンバを参照してください。

System.Object
System.Collections.CollectionBase
[Serializable]
public class ToolsCollection : CollectionBase , IList
, ICollection, IEnumerable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolsCollection 全メンバ

ToolsCollection 概要

コンストラクタ

Constructor

パブリック フィールド

chart

パブリック メソッド

Add | TChartに新しいツールを追加します。
Clear | 全ての系列を消去（および任意で破棄）します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
Remove | TChartからツールを削除します。

パブリック プロパティ

Item

プロテクト メソッド

OnInsertComplete

参照

ToolsCollection クラス | Steema.TeeChart.Tools 名前空間


ToolsCollection コンストラクタ

Steema.TeeChart.Tools.ToolsCollection コンストラクタ

public ToolsCollection(Chart c)

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolsCollection フィールド

パブリック フィールド

chart

参照

ToolsCollection クラス | Steema.TeeChart.Tools 名前空間


chart

Steema.TeeChart.Tools.ToolsCollection.chart フィールド

public Chart chart

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolsCollection メソッド

パブリック メソッド

Add | TChartに新しいツールを追加します。
Clear | 全ての系列を消去（および任意で破棄）します。
IndexOf | 指定した値に該当するポイントインデックスを返します。
Remove | TChartからツールを削除します。

プロテクト メソッド

OnInsertComplete

参照

ToolsCollection クラス | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.ToolsCollection.Add メソッド

TChartに新しいツールを追加します。
public Int32 Add(Tool tool)

解説

TChartに新しいツールを追加します。

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.ToolsCollection.Add メソッド

TChartに新しいツールを追加します。
public Int32 Add(Tool tool)

参照

Add オーバーロードの一覧 | ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Add

Steema.TeeChart.Tools.ToolsCollection.Add メソッド

public Int32 Add(Type tool)

参照

Add オーバーロードの一覧 | ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear メソッド

オーバーロードの一覧

全ての系列を消去（および任意で破棄）します。

public Void Clear(System.Boolean)

全ての系列を消去および破棄します。

public Void Clear()

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear メソッド

全ての系列を消去（および任意で破棄）します。
public Void Clear(Boolean dispose)

参照

Clear オーバーロードの一覧 | ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Clear

Steema.TeeChart.Tools.ToolsCollection.Clear メソッド

全ての系列を消去および破棄します。
public Void Clear()

参照

Clear オーバーロードの一覧 | ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


IndexOf

Steema.TeeChart.Tools.ToolsCollection.IndexOf メソッド

指定した値を持つポイントのインデックスを返します。
public Int32 IndexOf(Tool s)

解説

指定した値を持つポイントのインデックスを返します。

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


OnInsertComplete

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ToolsCollection.OnInsertComplete メソッド

protected virtual Void OnInsertComplete(Int32 index,
     Object value)

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Remove

Steema.TeeChart.Tools.ToolsCollection.Remove メソッド

TChartからツールを削除します。
public Void Remove(Tool s)

解説

TChartからツールを削除します。

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolsCollection プロパティ

パブリック プロパティ

Item

参照

ToolsCollection クラス | Steema.TeeChart.Tools 名前空間


Item

Steema.TeeChart.Tools.ToolsCollection.Item プロパティ

public Tool Item(Int32 index) {get; set;}

参照

ToolsCollection クラス | ToolsCollection メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolSeries

Steema.TeeChart.Tools.ToolSeries クラス

Seriesプロパティを持つツールコンポーネントの基本的な抽象クラス。

この型のすべてのメンバの一覧については、ToolSeries メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ToolSeries : Tool , IComponent, IDisposable, ICloneable

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolSeries 全メンバ

ToolSeries 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Description (Toolの継承元) |
GetHorizAxis | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis | 関連する垂直軸（左軸あるいは右軸）を返します。
Series | ツールに関連付ける系列を設定します。
Summary (Toolの継承元) |

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

ToolSeries クラス | Steema.TeeChart.Tools 名前空間


ToolSeries コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ToolSeries コンストラクタ

オーバーロードの一覧

protected ToolSeries()
protected ToolSeries(Steema.TeeChart.Chart)
protected ToolSeries(Steema.TeeChart.Styles.Series)

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


ToolSeries コンストラクタ

TeeChartプログラミングガイド

Steema.TeeChart.Tools.ToolSeries コンストラクタ

protected ToolSeries()

参照

ToolSeries コンストラクタのオーバーロードの一覧 | ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


ToolSeries コンストラクタ

Steema.TeeChart.Tools.ToolSeries コンストラクタ

protected ToolSeries(Chart c)

参照

ToolSeries コンストラクタのオーバーロードの一覧 | ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


ToolSeries コンストラクタ

Steema.TeeChart.Tools.ToolSeries コンストラクタ

protected ToolSeries(Series s)

参照

ToolSeries コンストラクタのオーバーロードの一覧 | ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolSeries フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
iSeries
pPen (Toolの継承元)

参照

ToolSeries クラス | Steema.TeeChart.Tools 名前空間


iSeries

Steema.TeeChart.Tools.ToolSeries.iSeries フィールド

protected Series iSeries

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolSeries メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
ToString (Toolの継承元) |

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetSeries
SetStringProperty (TeeBaseの継承元)

参照

ToolSeries クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ToolSeries.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


SetSeries

Steema.TeeChart.Tools.ToolSeries.SetSeries メソッド

protected abstract Void SetSeries(Series value)

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ToolSeries プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Chart (TeeBaseの継承元) | このオブジェクトに関連しているチャート。
Description (Toolの継承元) |
GetHorizAxis | 関連する水平軸（上軸あるいは下軸）を返します。
GetVertAxis | 関連する垂直軸（左軸あるいは右軸）を返します。
Series | ツールに関連付ける系列を設定します。

参照

ToolSeries クラス | Steema.TeeChart.Tools 名前空間


GetHorizAxis

Steema.TeeChart.Tools.ToolSeries.GetHorizAxis プロパティ

関連する水平軸（上軸あるいは下軸）を返します。
public Axis GetHorizAxis {get;}

解説

すべての系列は、チャートの水平軸（上軸あるいは下軸）に関連しています。このプロパティは、「関連する」軸を返します。

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


GetVertAxis

Steema.TeeChart.Tools.ToolSeries.GetVertAxis プロパティ

関連する垂直軸（左軸あるいは右軸）を返します。
public Axis GetVertAxis {get;}

解説

すべての系列は、垂直軸（左軸あるいは右軸）に関連しています。このプロパティは、「関連する」軸を返します。

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Series

Steema.TeeChart.Tools.ToolSeries.Series プロパティ

ツールに関連付ける系列を設定します。
public Series Series {get; set;}

解説

このプロパティは、チャートコンポーネントが保持し、描画する系列のリストです。

参照

ToolSeries クラス | ToolSeries メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomAttributes

Steema.TeeChart.Tools.ZoomAttributes クラス

この型のすべてのメンバの一覧については、ZoomAttributes メンバを参照してください。

System.Object
public class ZoomAttributes : Object

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ: TeeChart.dll

参照

ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomAttributes 全メンバ

ZoomAttributes 概要

コンストラクタ

Constructor

パブリック フィールド

Attribs
CanvasIndex
DragZoom
FillTransp
ImageStr
PenColor

参照

ZoomAttributes クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomAttributes コンストラクタ

public ZoomAttributes()

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomAttributes フィールド

パブリック フィールド

Attribs
CanvasIndex
DragZoom
FillTransp
ImageStr
PenColor

参照

ZoomAttributes クラス | Steema.TeeChart.Tools 名前空間


Attribs

Steema.TeeChart.Tools.ZoomAttributes.Attribs フィールド

public String Attribs

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


CanvasIndex

Steema.TeeChart.Tools.ZoomAttributes.CanvasIndex フィールド

public Int32 CanvasIndex

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


DragZoom

Steema.TeeChart.Tools.ZoomAttributes.DragZoom フィールド

public Boolean DragZoom

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


FillTransp

Steema.TeeChart.Tools.ZoomAttributes.FillTransp フィールド

public Int32 FillTransp

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


ImageStr

Steema.TeeChart.Tools.ZoomAttributes.ImageStr フィールド

public String ImageStr

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


NoClickPostback

Steema.TeeChart.Tools.ZoomAttributes.NoClickPostback フィールド

クリックによるポストバックを行いません。
public Boolean NoClickPostback

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


PenColor

Steema.TeeChart.Tools.ZoomAttributes.PenColor フィールド

public String PenColor

参照

ZoomAttributes クラス | ZoomAttributes メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomTool

Steema.TeeChart.Tools.ZoomTool クラス

Webフォームに作成したチャートをズームします。WebChartコンポーネントのみサポートします。

この型のすべてのメンバの一覧については、ZoomTool メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Tools.Tool
public class ZoomTool : Tool , IComponent, IDisposable

解説

ズームツールを使用するには、次のエレメントが必要です。

  • チャートエディタを使用してチャートにズームツールを追加してください。これは、実行時にチャートをズームするためにクライアント側のJavascriptを生成します。
  • クライアント側のJavascriptのルーチンで送られた情報を理解するために、コードビハインドコードに追加してください。これは、通常Page_Loadメソッドに追加されます。
  • ズームツールは、ズームの呼び出し中はチャートのデータが同じだと見なします。

例

private void Page_Load(object sender, System.EventArgs e)
{
  /* ----- ここでチャートのルーチン (TeeChartのサンプルを参照) ----- */
  /* ---- または保存したチャートをインポートする ---- */
  WebChart1.Chart.Import.Template.Load(tmpChart);

  //既存のズーム状態があるかどうかを確認
  CheckZoom(WebChart2);
}

private void CheckZoom(WebChart wChart)
{
  //サーバーに新たにアクセスするということは、そのチャート用に新たにアクセスするということなので
  //チャート以外の情報が保存されなければなりません。ここで配列リストを使用して、
  //現在の軸の情報をセッション変数に読込/保存します。

  ArrayList zoomedState=(ArrayList)Session[wChart.ID+"Zoomed"];
  zoomedState=((Steema.TeeChart.Tools.ZoomTool)wChart.Chart.Tools[0]).SetCurrentZoom(Request,
 zoomedState);
  if (zoomedState==null)
Session.Remove(wChart.ID+"Zoomed");
  else
Session.Add(wChart.ID+"Zoomed",zoomedState);
}

必要条件

名前空間: Steema.TeeChart.Tools 名前空間

アセンブリ：TeeChart.dll

参照

ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomTool 全メンバ

ZoomTool 概要

コンストラクタ

Constructor オーバーロード

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
SetCurrentZoom | ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。
SetSavedZoom | 現在のズーム状態をセッション変数に保存した場合、その保存されたズーム状態を現在のチャートに設定します。
ToString (Toolの継承元) |
Zoom | チャートをズームします。

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Attributes | ズームツールを作成するためのサポート属性。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomVariables | チャートの新しいページの呼び出しに任意のカスタム変数を追加します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。
ZoomCanvasIndex | ズーム矩形描画の相対的なZ深さを取得/設定します。Webフォーム上に複数のオブジェクトが存在する場合、ズーム領域が有効にならない場合がありますので、この場合はズーム領域を最も上の位置に置く必要があります。
ZoomFillTransparency | ズームを指定する矩形の透明度（0～100%）を定義します。0（デフォルト）は透明になります。
ZoomPenColor | ズーム矩形のペンの色を設定します。

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
getZoomArgs
IsChart
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
setAttributes
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ZoomTool クラス | Steema.TeeChart.Tools 名前空間


ZoomTool コンストラクタ

Steema.TeeChart.Tools.ZoomTool コンストラクタ

オーバーロードの一覧

public ZoomTool()
public ZoomTool(Steema.TeeChart.Chart)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


ZoomTool コンストラクタ

Steema.TeeChart.Tools.ZoomTool コンストラクタ

public ZoomTool()

参照

ZoomTool コンストラクタのオーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


ZoomTool コンストラクタ

Steema.TeeChart.Tools.ZoomTool コンストラクタ

public ZoomTool(Chart c)

参照

ZoomTool コンストラクタのオーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomTool フィールド

プロテクト フィールド

bBrush (Toolの継承元)
InternalUse (TeeBaseの継承元)
pPen (Toolの継承元)

参照

ZoomTool クラス | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomTool メソッド

パブリック メソッド

Clone (Toolの継承元) |
GetBitmapEditor (Toolの継承元) | 指定したツールクラスに対応したビットマップのアイコンを返します。このアイコンはツールギャラリのListBoxやツールエディタダイアログで使用されます。
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
SetCurrentZoom | ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。
SetSavedZoom | 現在のズーム状態をセッション変数に保存した場合、その保存されたズーム状態を現在のチャートに設定します。
ToString (Toolの継承元) |
Zoom | チャートをズームします。

プロテクト メソッド

Assign
ChartEvent (Toolの継承元)
Dispose (Toolの継承元)
getZoomArgs
IsChart
KeyEvent (Toolの継承元)
MouseEvent (Toolの継承元)
OnDisposing (Toolの継承元)
SeriesEvent (Toolの継承元)
SetActive (Toolの継承元)
setAttributes
SetBooleanProperty (TeeBaseの継承元)
SetChart (Toolの継承元)
SetColorProperty (TeeBaseの継承元)
SetDoubleProperty (TeeBaseの継承元)
SetFloatProperty (TeeBaseの継承元)
SetIntegerProperty (TeeBaseの継承元)
SetStringProperty (TeeBaseの継承元)

参照

ZoomTool クラス | Steema.TeeChart.Tools 名前空間


Assign

Steema.TeeChart.Tools.ZoomTool.Assign メソッド

protected abstract Void Assign(Tool t)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


getZoomArgs

Steema.TeeChart.Tools.ZoomTool.getZoomArgs メソッド

protected Hashtable getZoomArgs(HttpRequest r)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


IsChart

Steema.TeeChart.Tools.ZoomTool.IsChart メソッド

protected internal Boolean IsChart(NameValueCollection postCollection)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


setAttributes

Steema.TeeChart.Tools.ZoomTool.setAttributes メソッド

protected internal Void setAttributes(String id)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetCurrentZoom

Steema.TeeChart.Tools.ZoomTool.SetCurrentZoom メソッド

オーバーロードの一覧

ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。

public ArrayList SetCurrentZoom(System.Web.HttpRequest, System.Collections.ArrayList, System.Collections.Specialized.NameValueCollection)

ページリクエストを送るページにポスト要素がない場所のズームを設定する場合このメソッドを使用します。

public ArrayList SetCurrentZoom(System.Web.HttpRequest, System.Collections.ArrayList)
public ArrayList SetCurrentZoom(System.Web.HttpRequest, System.Collections.Hashtable, System.Collections.ArrayList)
public ArrayList SetCurrentZoom(System.Web.HttpRequest, System.String, System.Collections.ArrayList)

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetCurrentZoom

Steema.TeeChart.Tools.ZoomTool.SetCurrentZoom メソッド

ズームなしのページリクエストを送るページにポスト要素（例：ButtonやDropDownListなど）がある場所のズームを設定する場合このメソッドを使用します。
public ArrayList SetCurrentZoom(HttpRequest r,
     ArrayList zoomState,
     NameValueCollection postCollection)

例

WebFormからPage_Loadでチャートをロードした後に、CheckZoomを呼び出してください。

private void Page_Load(object sender, System.EventArgs e)
{
        MemoryStream tmpChart;

        if (Session["ch1"]==null)
      {
          WebChart1.Chart[0].FillSampleValues();
          tmpChart=new MemoryStream();
          WebChart1.Chart.Export.Template.Save(tmpChart);
          //セッション変数にテンプレートを保存
          Session.Add("ch1",tmpChart);
      }
      else
      {
          //セッションの保存されたチャートを取得
          tmpChart=(MemoryStream)Session["ch1"];
          tmpChart.Position=0;
          //保存したチャートのインポート
          WebChart1.Chart.Import.Template.Load(tmpChart);
          CheckZoom(WebChart1);
      }
}

private void CheckZoom(WebChart wChart)
{
        ArrayList zoomedState=(ArrayList)Session[wChart.ID+"Zoomed"];
        zoomedState=((Steema.TeeChart.Tools.ZoomTool)wChart.Chart.Tools[0]).SetCurrentZoom(Request,
                                                                                zoomedState,DeterminePostBackMode());
        if (zoomedState==null)
          Session.Remove(wChart.ID+"Zoomed");
        else
          Session.Add(wChart.ID+"Zoomed",zoomedState);
}

参照

SetCurrentZoom オーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetCurrentZoom

Steema.TeeChart.Tools.ZoomTool.SetCurrentZoom メソッド

ページリクエストを送るページにポスト要素がない場所のズームを設定する場合このメソッドを使用します。
public ArrayList SetCurrentZoom(HttpRequest r,
     ArrayList zoomState)

例

WebFormからPage_Loadでチャートをロードした後に、CheckZoomを呼び出してください。

private void CheckZoom(WebChart wChart)
    {
        ArrayList zoomedState=(ArrayList)Session[wChart.ID+"Zoomed"];
        zoomedState=((Steema.TeeChart.Tools.ZoomTool)wChart.Chart.Tools[0]).SetCurrentZoom(Request,
                                                                                zoomedState);
        if (zoomedState==null)
          Session.Remove(wChart.ID+"Zoomed");
        else
          Session.Add(wChart.ID+"Zoomed",zoomedState);
    }

参照

SetCurrentZoom オーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetCurrentZoom

Steema.TeeChart.Tools.ZoomTool.SetCurrentZoom メソッド

public ArrayList SetCurrentZoom(HttpRequest r,
     Hashtable argumentList,
     ArrayList zoomState)

参照

SetCurrentZoom オーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetCurrentZoom

Steema.TeeChart.Tools.ZoomTool.SetCurrentZoom メソッド

public ArrayList SetCurrentZoom(HttpRequest r,
     String args,
     ArrayList zoomState)

参照

SetCurrentZoom オーバーロードの一覧 | ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


SetSavedZoom

Steema.TeeChart.Tools.ZoomTool.SetSavedZoom メソッド

現在のズーム状態をセッション変数に保存した場合、その保存されたズーム状態を現在のチャートに設定します。

public Void SetSavedZoom(ArrayList zoomedState)

パラメーター

zoomedState
配列リスト　保存された軸のセッション状態

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Zoom

Steema.TeeChart.Tools.ZoomTool.Zoom メソッド

チャートをズームします。

public ArrayList Zoom(Rectangle r)

パラメーター

r
ピクセル単位の境界矩形（左、上、幅、高さ）

解説

このメソッドの代わりに標準のZoomメソッドを使用して直接ズームできますが、全ポイントのピクセル位置を計算するにはまず内部チャートを生成する必要があります。

例

    WebChart1.Chart.Bitmap();
    WebChart1.Chart.Zoom.ZoomRect(new Rectangle(x0,y0,x1-x0 /*width*/,y1-y0 /*height*/));

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Tools.ZoomTool プロパティ

パブリック プロパティ

Active (Toolの継承元) | 指定したインデックスのツールを有効/無効にします。
Attributes | ズームツールを作成するためのサポート属性。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
CustomVariables | チャートの新しいページの呼び出しに任意のカスタム変数を追加します。
Description | 説明のテキストを取得します。
Summary | 詳細な説明テキストを取得します。
ZoomCanvasIndex | ズーム矩形描画の相対的なZ深さを取得/設定します。Webフォーム上に複数のオブジェクトが存在する場合、ズーム領域が有効にならない場合がありますので、この場合はズーム領域を最も上の位置に置く必要があります。
ZoomFillTransparency | ズームを指定する矩形の透明度（0～100%）を定義します。0（デフォルト）は透明になります。
ZoomPenColor | ズーム矩形のペンの色を設定します。

参照

ZoomTool クラス | Steema.TeeChart.Tools 名前空間


Attributes

Steema.TeeChart.Tools.ZoomTool.Attributes プロパティ

ズームツールを作成するためのサポート属性。
public ZoomAttributes Attributes {get; set;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


CustomVariables

Steema.TeeChart.Tools.ZoomTool.CustomVariables プロパティ

チャートの新しいページの呼び出しに任意のカスタム変数を追加します。

public String CustomVariables {get; set;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Description

Steema.TeeChart.Tools.ZoomTool.Description プロパティ

説明テキストを取得します。

public override String Description {get;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Summary

Steema.TeeChart.Tools.ZoomTool.Summary プロパティ

詳細な説明テキストを取得します。

public override String Summary {get;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


ZoomCanvasIndex

Steema.TeeChart.Tools.ZoomTool.ZoomCanvasIndex プロパティ

ズーム矩形描画の相対的なZ深さを取得/設定します。Webフォーム上に複数のオブジェクトが存在する場合、ズーム領域が有効にならない場合がありますので、この場合はズーム領域を最も上の位置に置く必要があります。

public Int32 ZoomCanvasIndex {get; set;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


ZoomFillTransparency

Steema.TeeChart.Tools.ZoomTool.ZoomFillTransparency プロパティ

ズームを指定する矩形の透明度（0～100%）を定義します。0（デフォルト）は透明になります。
public Int32 ZoomFillTransparency {get; set;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


ZoomPenColor

Steema.TeeChart.Tools.ZoomTool.ZoomPenColor プロパティ

ズーム矩形のペンの色を設定します。

public Color ZoomPenColor {get; set;}

参照

ZoomTool クラス | ZoomTool メンバ | Steema.TeeChart.Tools 名前空間


Steema.TeeChart.Web

Steema.TeeChart.Web 名前空間

名前空間の階層構造

パブリック 列挙体

TempChartStyle TempChartStyleは一時的なWebChartがどのように保存されるかを定義するためにTempChartで使用されます。

パブリック クラス

WebChart | WebChartコントトール。
TeeChartImgGen | ブラウザにストリームとしてイメージの取得をサポートします。<system.web>タグの間のどこかで以下の行をプロジェクトに追加してください。

パブリック・でリゲート

SeriesEventHandler | 系列のWebイベントハンドラ。
ClickEventHandler | Web Clickのイベントハンドラ。

必要条件

名前空間： Steema.TeeChart.Web

アセンブリ：TeeChart.dll


Steema.TeeChart.Web 階層構造

System.Object

System.Web.UI.Control

System.Web.UI.WebControls.WebControl

Steema.TeeChart.Web.WebChart

Steema.TeeChart.Web.TeeChartImgGen

参照

SteemaTeeChartWeb 名前空間


Steema.TeeChart.Web.TeeChartImgGen

Steema.TeeChart.Web.TeeChartImgGen クラス

ブラウザにストリームとしてイメージの取得をサポートします。 <system.web>タグの間のどこかで以下の行をプロジェクトに追加してください。

この型のすべてのメンバの一覧については、TeeChartImgGen メンバを参照してください。

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
Steema.TeeChart.Web.WebChart
public class TeeChartImgGen : WebChart , IComponent, IDisposable
, IParserAccessor, IUrlResolutionService, IDataBindingsAccessor, IControlBuilderAccessor
, IControlDesignerAccessor, IExpressionsAccessor, IAttributeAccessor
, INamingContainer, IPostBackEventHandler, IPostBackDataHandler, IChart
, ISerializable, IHttpHandler

必要条件

名前空間: Steema.TeeChart.Web 名前空間

アセンブリ: TeeChart.dll

参照

TeeChartImgGen メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TeeChartImgGen 全メンバ

TeeChartImgGen 概要

コンストラクタ

Constructor

パブリック イベント

AfterDraw (WebChartの継承元)
BeforeDraw (WebChartの継承元)
BeforeDrawAxes (WebChartの継承元)
BeforeDrawSeries (WebChartの継承元)
ClickAxis (WebChartの継承元)
ClickBackground (WebChartの継承元)
ClickLegend (WebChartの継承元)
ClickSeries (WebChartの継承元)
ClickTitle (WebChartの継承元)
GetAxesChartRect (WebChartの継承元)
GetAxisLabel (WebChartの継承元)
GetLegendPos (WebChartの継承元)
GetLegendRect (WebChartの継承元)
GetLegendText (WebChartの継承元)
GetNextAxisLabel (WebChartの継承元)

パブリック フィールド

tmpImg (WebChartの継承元)

パブリック メソッド

Clear (WebChartの継承元) | WebChartをデフォルト値にリセットします。
CreatePictureFile (WebChartの継承元) | 実行時のチャートを書き込みます。
Dispose (WebChartの継承元) | 使用したリソースを空にします。
GetObjectData (WebChartの継承元) |
LoadPostData (WebChartの継承元) | Postbackイベントのサポート。内部使用。
ProcessRequest |
RaisePostBackEvent (WebChartの継承元) | Postbackイベントのサポート。内部使用。
RaisePostDataChangedEvent (WebChartの継承元) | Postbackイベントのサポート。内部使用。

パブリック プロパティ

AutoPostback (WebChartの継承元) | trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。
Chart (WebChartの継承元) | チャートの構成。
ClickedX (WebChartの継承元) |
ClickedY (WebChartの継承元) |
Config (WebChartの継承元) |
GetChartFile (WebChartの継承元) | GetChart.aspxがプロジェクトフォルダと同じ位置にない場合、GetChart.aspxの代わりの位置を取得/設定します。チャートのストリーミングのために「セッション」を選択した場合、GetChartスクリプトを使用してください。
Height (WebChartの継承元) | チャートの高さをピクセル単位で取得/設定します。
IsReusable |
PictureFormat (WebChartの継承元) | チャートのイメージ形式を取得/設定します。
TempChart (WebChartの継承元) | ｢Session｣に設定すると、TeeChartはWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリファイルを作成しません）。｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。
Width (WebChartの継承元) | チャートの幅をピクセル単位で取得/設定します。

プロテクト フィールド

designPath (WebChartの継承元)
iChart (WebChartの継承元)

プロテクト メソッド

CreatePictureStream (WebChartの継承元) | 今後使用予定。
getMimeType |
OnInit (WebChartの継承元) |
OnPreRender (WebChartの継承元) |
ReadFromFile (WebChartの継承元) | Base64のチャートに保存されたXMLを読み込みます。使用されていません。
Render (WebChartの継承元) |
saveFileToImg (WebChartの継承元) |

参照

TeeChartImgGen クラス | Steema.TeeChart.Web 名前空間


TeeChartImgGen コンストラクタ

Steema.TeeChart.Web.TeeChartImgGen コンストラクタ

public TeeChartImgGen()

参照

TeeChartImgGen クラス | TeeChartImgGen メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TeeChartImgGen イベント

パブリック イベント

AfterDraw (WebChartの継承元)
BeforeDraw (WebChartの継承元)
BeforeDrawAxes (WebChartの継承元)
BeforeDrawSeries (WebChartの継承元)
ClickAxis (WebChartの継承元)
ClickBackground (WebChartの継承元)
ClickLegend (WebChartの継承元)
ClickSeries (WebChartの継承元)
ClickTitle (WebChartの継承元)
GetAxesChartRect (WebChartの継承元)
GetAxisLabel (WebChartの継承元)
GetLegendPos (WebChartの継承元)
GetLegendRect (WebChartの継承元)
GetLegendText (WebChartの継承元)
GetNextAxisLabel (WebChartの継承元)

参照

TeeChartImgGen クラス | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TeeChartImgGen フィールド

パブリック フィールド

tmpImg (WebChartの継承元)

プロテクト フィールド

designPath (WebChartの継承元)
iChart (WebChartの継承元)

参照

TeeChartImgGen クラス | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TeeChartImgGen メソッド

パブリック メソッド

Clear (WebChartの継承元) | WebChartをデフォルト値にリセットします。
CreatePictureFile (WebChartの継承元) | 実行時のチャートを書き込みます。
Dispose (WebChartの継承元) | 使用したリソースを空にします。
GetObjectData (WebChartの継承元) |
LoadPostData (WebChartの継承元) | Postbackイベントのサポート。内部使用。
ProcessRequest |
RaisePostBackEvent (WebChartの継承元) | Postbackイベントのサポート。内部使用。
RaisePostDataChangedEvent (WebChartの継承元) | Postbackイベントのサポート。内部使用。

プロテクト メソッド

CreatePictureStream (WebChartの継承元) | 今後使用予定。
getMimeType |
OnInit (WebChartの継承元) |
OnPreRender (WebChartの継承元) |
ReadFromFile (WebChartの継承元) | Base64のチャートに保存されたXMLを読み込みます。使用されていません。
Render (WebChartの継承元) |
saveFileToImg (WebChartの継承元) |

参照

TeeChartImgGen クラス | Steema.TeeChart.Web 名前空間


getMimeType

Steema.TeeChart.Web.TeeChartImgGen.getMimeType メソッド

protected internal String getMimeType(String ext)

参照

TeeChartImgGen クラス | TeeChartImgGen メンバ | Steema.TeeChart.Web 名前空間


ProcessRequest

Steema.TeeChart.Web.TeeChartImgGen.ProcessRequest メソッド

public virtual Void ProcessRequest(HttpContext context)

参照

TeeChartImgGen クラス | TeeChartImgGen メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TeeChartImgGen プロパティ

パブリック プロパティ

AutoPostback (WebChartの継承元) | trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。
Chart (WebChartの継承元) | チャートの構成。
ClickedX (WebChartの継承元) |
ClickedY (WebChartの継承元) |
Config (WebChartの継承元) |
GetChartFile (WebChartの継承元) | GetChart.aspxがプロジェクトフォルダと同じ位置にない場合、GetChart.aspxの代わりの位置を取得/設定します。チャートのストリーミングのために「セッション」を選択した場合、GetChartスクリプトを使用してください。
Height (WebChartの継承元) | チャートの高さをピクセル単位で取得/設定します。
IsReusable |
PictureFormat (WebChartの継承元) | チャートのイメージ形式を取得/設定します。
TempChart (WebChartの継承元) | ｢Session｣に設定すると、TeeChartはWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリファイルを作成しません）。｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。
Width (WebChartの継承元) | チャートの幅をピクセル単位で取得/設定します。

参照

TeeChartImgGen クラス | Steema.TeeChart.Web 名前空間


IsReusable

Steema.TeeChart.Web.TeeChartImgGen.IsReusable プロパティ

public virtual Boolean IsReusable {get;}

参照

TeeChartImgGen クラス | TeeChartImgGen メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.TempChartStyle

Steema.TeeChart.Web.TempChartStyle 列挙体

TempChartStyle は一時的なWebChartがどのように保存されるかを定義するためにTempChartで使用されます。

[Serializable]
public enum TempChartStyle : Enum , IComparable
, IFormattable, IConvertible

パブリック メンバ

メンバ名 | 説明
File | チャートは一時的なファイルとして保存されます。ファイルは自動的に削除されません。
Session | チャートはセッション変数として保存されます。ファイルはディスクに作成されず、セッション変数は自動的に削除されます。

参照

Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart

Steema.TeeChart.Web.WebChart クラス

WebChartコントロール。

この型のすべてのメンバの一覧については、WebChart メンバを参照してください。

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
[Serializable]
public class WebChart : WebControl , IComponent
, IDisposable, IParserAccessor, IDataBindingsAccessor, IAttributeAccessor
, INamingContainer, IPostBackEventHandler, IPostBackDataHandler, IChart
, ISerializable

解説

WebChartは、TeeChartライブラリのWebフォーム用の中心となるコンポーネントです。下図はWebChartクラスからアクセスすることができる主なTeeChartオブジェクトを示しています。

デザイン時にWebChartオブジェクトをWebフォームに追加する場合、マウスでWebChartコンポーネントをWebフォームにドラッグしてください。系列はデザイン時および実行時に追加できます。たとえば、実行時の場合、次のコードが使用できます。

[C#]
private void Page_Load(object sender, System.EventArgs e)
{
     if(!((System.Web.UI.Page)sender).IsPostBack) {
        Steema.TeeChart.Chart tChart1 = WebChart1.Chart;
        Steema.TeeChart.Styles.Bar bar1 = new Steema.TeeChart.Styles.Bar(tChart1);
        bar1.FillSampleValues(20);
    }
}

[VB.Net]
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If Not CType(sender, System.Web.UI.Page).IsPostBack Then
        Dim TChart1 As Steema.TeeChart.Chart = WebChart1.Chart
        Dim Bar1 As New Steema.TeeChart.Styles.Bar(TChart1)
        Bar1.FillSampleValues(20)
    End If
End Sub
or...

[C#]
private void Page_Load(object sender, System.EventArgs e)
{
     if(!((System.Web.UI.Page)sender).IsPostBack) {
        Steema.TeeChart.Chart tChart1 = WebChart1.Chart;
        tChart1.Series.Add(new Steema.TeeChart.Styles.Pie());
        tChart1.Series[0].FillSampleValues(20);
    }
}

[VB.Net]
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
    If Not CType(sender, System.Web.UI.Page).IsPostBack Then
        Dim TChart1 As Steema.TeeChart.Chart = WebChart1.Chart
        TChart1.Series.Add(New Steema.TeeChart.Styles.Pie())
        TChart1.Series(0).FillSampleValues(20)
    End If
End Sub

1つのWebフォームに、いくつでもWebChartオブジェクトを使用できます。WinFormでTeeChartを使用するためには、Steema.TeeChart.TChartクラスを使用してください。

TeeChartでチャートを作成する方法につきましては、TeeChartチュートリアルを参照してください。

必要条件

名前空間: Steema.TeeChart.Web 名前空間

アセンブリ: TeeChart.dll

参照

WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart 全メンバ

WebChart 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDraw
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ClickAxis
ClickBackground
ClickLegend
ClickSeries
ClickTitle
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel

パブリック フィールド

lastID
tmpImg

パブリック メソッド

Clear | WebChartをデフォルト値にリセットします。
CreatePictureFile | 実行時のチャートを書き込みます。
Dispose | 使用したリソースを空にします。
GetObjectData |
LoadPostData | Postbackイベントのサポート。内部使用。
RaisePostBackEvent | Postbackイベントのサポート。内部使用。
RaisePostDataChangedEvent | Postbackイベントのサポート。内部使用。

パブリック プロパティ

AutoPostback | trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。
Chart | チャートの構成。
ClickedX | 最後にクリックされたX座標の値を返します。
ClickedY | 最後にクリックされたY座標の値を返します。
Config |
GetChartFile | GetChart.aspxがプロジェクトフォルダと同じ位置にない場合、GetChart.aspxの代わりの位置を取得/設定します。チャートのストリーミングのために「セッション」を選択した場合、GetChartスクリプトを使用してください。
Height | チャートの高さをピクセル単位で取得/設定します。
PictureFormat | チャートのイメージ形式を取得/設定します。
TempChart | ｢Session｣に設定すると、TeeChartはWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリファイルを作成しません）。｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。
Width | チャートの幅をピクセル単位で取得/設定します。

プロテクト フィールド

designPath
iChart

プロテクト メソッド

CreatePictureStream | 今後使用予定。
OnInit |
OnPreRender |
ReadFromFile | Base64のチャートに保存されたXMLを読み込みます。使用されていません。
Render |
saveFileToImg |

参照

WebChart クラス | Steema.TeeChart.Web 名前空間


WebChart コンストラクタ

Steema.TeeChart.Web.WebChart コンストラクタ

オーバーロードの一覧

public WebChart()
public WebChart(System.Runtime.Serialization.SerializationInfo, System.Runtime.Serialization.StreamingContext)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


WebChart コンストラクタ

Steema.TeeChart.Web.WebChart コンストラクタ

public WebChart()

参照

WebChart コンストラクタのオーバーロードの一覧 | WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


WebChart コンストラクタ

Steema.TeeChart.Web.WebChart コンストラクタ

public WebChart(SerializationInfo info,
     StreamingContext context)

参照

WebChart コンストラクタのオーバーロードの一覧 | WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart イベント

パブリック イベント

AfterDraw
BeforeDraw
BeforeDrawAxes
BeforeDrawSeries
ClickAxis
ClickBackground
ClickLegend
ClickSeries
ClickTitle
GetAxesChartRect
GetAxisLabel
GetLegendPos
GetLegendRect
GetLegendText
GetNextAxisLabel

参照

WebChart クラス | Steema.TeeChart.Web 名前空間


AfterDraw

Steema.TeeChart.Web.WebChart.AfterDraw イベント

public PaintChartEventHandler  AfterDraw

解説

このイベントは、TChartがすべての系列を描画した直後に発生します。

警告：

このイベントの中で、TChartを再描画させるプロパティを変更しないでください。無限ループになります。

例

[C#]

private void WebChart1_AfterDraw(object sender, Steema.TeeChart.Drawing.Graphics3D g)
{
     // チャートにテキストを表示します。
     if (clickedX!=-1)
    {
       g.Font.Bold=true;
       g.Font.Color=Color.Blue;
       g.TextOut(clickedX,clickedY,msgText);
    }
}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


BeforeDraw

Steema.TeeChart.Web.WebChart.BeforeDraw イベント

public PaintChartEventHandler  BeforeDraw

解説

このイベントは、すべてのチャートを描画する前で、チャートの背景を描画した後に発生します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


BeforeDrawAxes

Steema.TeeChart.Web.WebChart.BeforeDrawAxes イベント

public PaintChartEventHandler  BeforeDrawAxes

解説

すべてのチャート軸を描く直前に発生します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


BeforeDrawSeries

Steema.TeeChart.Web.WebChart.BeforeDrawSeries イベント

public PaintChartEventHandler  BeforeDrawSeries

解説

このイベントは、すべてのチャート系列を描画する直前で、チャート軸を描画した後（軸が系列の後ろにある場合）に発生します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickAxis

Steema.TeeChart.Web.WebChart.ClickAxis イベント

public ClickEventHandler  ClickAxis

解説

このイベントは、ユーザがチャート軸のサブクラスでクリックすると発生します。

Senderパラメーターは、このイベントを発生させるチャートクラスを指定します。

Axisパラメーターは、クリックされたチャートの軸です。左、右、上、下のチャート軸のサブクラスです。

Buttonパラメーター、Shiftパラメーター、Xパラメーター、Yパラメーターは軸がクリックされた時にマウスボタンおよびマウスカーソル座標を定義します。

このイベントは、OnClickBackGroundイベントより優先度が高く、OnClickSeriesイベントより低くくなっています。

例

[C#]

private void tChart1_ClickAxis(object sender, System.Windows.Forms.MouseEventArgs e)
{
if ((Steema.TeeChart.Axis)sender==tChart1.Axes.Bottom)
MessageBox.Show("Clicked Bottom Axis!!!");
}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickBackground

Steema.TeeChart.Web.WebChart.ClickBackground イベント

public ClickEventHandler  ClickBackground

解説

このイベントは、軸、系列ポイント、チャート凡例以外のチャート領域をクリックすると発生します。

このイベント以外のマウスイベントのどれよりも優先度が低くなっています。

Senderパラメーターは、イベントを発生させるチャートクラスです。

Buttonパラメーター、Shiftパラメーター、Xパラメーター、Yパラメーターはチャートがクリックされた時にマウスボタンおよびマウスカーソル座標を定義します。

例

[C#]

private void WebChart1_ClickBackground(object sender, System.Web.UI.ImageClickEventArgs e)
{
     //チャート上のポイントがクリックされるとイベントが発生します。
     //ClickSeriesイベントがアクティブの場合、このイベントは発生しません。

     clickedX=e.X;

     clickedY=e.Y;

     msgText="Clicked background\n\rX:"+WebChart1.Chart.Axes.Bottom.CalcPosPoin(clickedX).ToString("#0.00")+",Y:"+WebChart1.Chart.Axes.Left.CalcPosPoint(clickedY).ToString("#0.00");

}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickLegend

Steema.TeeChart.Web.WebChart.ClickLegend イベント

public ClickEventHandler  ClickLegend

解説

このイベントは、チャートの凡例矩形でクリックすると発生します。

Senderパラメーターは、イベントを発生させるチャートクラスを指定します。

Buttonパラメーター、Shiftパラメーター、Xパラメーター、Yパラメーターはチャートの凡例がクリックされた時にマウスボタンおよびマウスカーソル座標を定義します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickSeries

Steema.TeeChart.Web.WebChart.ClickSeries イベント

public SeriesEventHandler  ClickSeries

解説

このイベントは、TChartの系列ポイントをクリックすると発生します。Senderパラメーターは、イベントを発生させるTChartクラスを指定します。Seriesパラメーターは、クリックされた系列クラスです。ValueIndexパラメーターは、系列のクリックされたポイントのインデックスです。系列は、クリックされたポイントを取得するために個々に使用できるClickイベントも持っています。Buttonパラメーター、Shiftパラメーター、Xパラメーター、Yパラメーターは系列ポイントがクリックされた時にマウスボタンおよびマウスカーソル座標を定義します。

例

[C#]

private void WebChart1_ClickSeries(object sender, Steema.TeeChart.Series s, int valueIndex, System.EventArgs e)
{
     Steema.TeeChart.Chart tChart=((WebChart)sender).Chart;
     clickedX=s.CalcXPos(valueIndex);
     clickedY=s.CalcYPos(valueIndex);
     msgText="Series: "+tChart.Series.IndexOf(s).ToString()+"\n\rValue: "+s.YValues[valueIndex].ToString("#0.00");
}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickTitle

Steema.TeeChart.Web.WebChart.ClickTitle イベント

public ClickEventHandler  ClickTitle

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetAxesChartRect

Steema.TeeChart.Web.WebChart.GetAxesChartRect イベント

public GetAxesChartRectEventHandler  GetAxesChartRect

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetAxisLabel

Steema.TeeChart.Web.WebChart.GetAxisLabel イベント

public GetAxisLabelEventHandler  GetAxisLabel

解説

このイベントは、各軸ラベルが表示される時に発生します。

1) : 軸ラベルが値の場合、Seriesパラメータはnilになり、ValueIndexは-1になります。
2) : 軸ラベル系列ポイントの場合、Seriesパラメータは有効な系列になり、ValueIndexは現在の系列ポイントの位置になります。異なる軸ラベルを描画するには、LabelTextパラメータを変更できます。

例

[C#]

private void WebChart2_GetAxisLabel(object sender, Steema.TeeChart.GetAxisLabelEventArgs e)
{
     //出力時に軸ラベルのテキストを表示する例です。
     if ((Steema.TeeChart.Axis)sender==WebChart2.Chart.Axes.Bottom)
    {
        switch (e.LabelText.Substring(e.LabelText.Length-1,1))
        {
            case "0": e.LabelText="init. 0"; break;
            case "1": e.LabelText=e.LabelText+"st"; break;
            case "2": e.LabelText=e.LabelText+"nd"; break;
            case "3": e.LabelText=e.LabelText+"rd"; break;
            default: e.LabelText=e.LabelText+"th"; break;
        }
    }
}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetLegendPos

Steema.TeeChart.Web.WebChart.GetLegendPos イベント

public GetLegendPosEventHandler  GetLegendPos

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetLegendRect

Steema.TeeChart.Web.WebChart.GetLegendRect イベント

public GetLegendRectEventHandler  GetLegendRect

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetLegendText

Steema.TeeChart.Web.WebChart.GetLegendText イベント

public GetLegendTextEventHandler  GetLegendText

解説

TChartLegendが描画する文字列をオーバーライドするためにこのイベントを使用できます。

TChartLegendには2つの異なるモード（またはLegendStyles）があります。

Series 凡例は系列名またはタイトルを表示します。
Values 凡例は系列値またはラベルを表示します。

LegendStyleがAutoの場合、TChartLegendはチャートにアクティブな系列が複数存在する場合はSeriesモードで描画します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetNextAxisLabel

Steema.TeeChart.Web.WebChart.GetNextAxisLabel イベント

public GetNextAxisLabelEventHandler  GetNextAxisLabel

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart フィールド

パブリック フィールド

lastID
tmpImg

プロテクト フィールド

designPath
iChart

参照

WebChart クラス | Steema.TeeChart.Web 名前空間


designPath

Steema.TeeChart.Web.WebChart.designPath フィールド

protected internal String designPath

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


iChart

Steema.TeeChart.Web.WebChart.iChart フィールド

protected internal Chart iChart

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


lastID

Steema.TeeChart.Web.WebChart.lastID フィールド

public String lastID

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


tmpImg

Steema.TeeChart.Web.WebChart.tmpImg フィールド

public MemoryStream tmpImg

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart メソッド

パブリック メソッド

Clear | WebChartをデフォルト値にリセットします。
CreatePictureFile | 実行時のチャートを書き込みます。
Dispose | 使用したリソースを空にします。
GetObjectData |
LoadPostData | Postbackイベントのサポート。内部使用。
RaisePostBackEvent | Postbackイベントのサポート。内部使用。
RaisePostDataChangedEvent | Postbackイベントのサポート。内部使用。

プロテクト メソッド

CreatePictureStream | 今後使用予定。
OnInit |
OnPreRender |
ReadFromFile | Base64のチャートに保存されたXMLを読み込みます。使用されていません。
Render |
saveFileToImg |

参照

WebChart クラス | Steema.TeeChart.Web 名前空間


Clear

Steema.TeeChart.Web.WebChart.Clear メソッド

WebChartをデフォルト値にリセットします。
public Void Clear()

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


CreatePictureFile

Steema.TeeChart.Web.WebChart.CreatePictureFile メソッド

実行時のチャートを書き込みます。
public Void CreatePictureFile(HtmlTextWriter writer,
     Int32 flag)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


CreatePictureStream

Steema.TeeChart.Web.WebChart.CreatePictureStream メソッド

今後使用予定

protected internal Void CreatePictureStream(HtmlTextWriter writer)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Dispose

Steema.TeeChart.Web.WebChart.Dispose メソッド

使用したリソースを削除します。
public override Void Dispose()

解説

使用したリソースを削除します。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetObjectData

Steema.TeeChart.Web.WebChart.GetObjectData メソッド

public virtual Void GetObjectData(SerializationInfo info,
     StreamingContext context)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


LoadPostData

Steema.TeeChart.Web.WebChart.LoadPostData メソッド

Postbackイベントのサポート。内部使用。
public abstract Boolean LoadPostData(String postDataKey,
     NameValueCollection postCollection)

解説

Postbackイベントのサポート。内部使用。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


OnInit

Steema.TeeChart.Web.WebChart.OnInit メソッド

protected virtual Void OnInit(EventArgs e)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


OnPreRender

Steema.TeeChart.Web.WebChart.OnPreRender メソッド

protected virtual Void OnPreRender(EventArgs e)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


RaisePostBackEvent

Steema.TeeChart.Web.WebChart.RaisePostBackEvent メソッド

Postbackイベントのサポート。内部使用。
public virtual Void RaisePostBackEvent(String eventArgument)

解説

Postbackイベントのサポート。内部使用。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


RaisePostDataChangedEvent

Steema.TeeChart.Web.WebChart.RaisePostDataChangedEvent メソッド

Postbackイベントのサポート。内部使用。
public abstract Void RaisePostDataChangedEvent()

解説

Postbackイベントのサポート。内部使用。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ReadFromFile

Steema.TeeChart.Web.WebChart.ReadFromFile メソッド

内部使用。Base64のチャートに保存されたXMLを読み込みます。

protected internal MemoryStream ReadFromFile(String chartID,
     String filePath,
     String extension)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Render

Steema.TeeChart.Web.WebChart.Render メソッド

protected virtual Void Render(HtmlTextWriter output)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


saveFileToImg

Steema.TeeChart.Web.WebChart.saveFileToImg メソッド

protected Void saveFileToImg(HttpContext Context,
     ImageExportFormat format,
     MemoryStream chartImg,
     String fileRoot,
     String fileName,
     Boolean scrolling)

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart プロパティ

パブリック プロパティ

AutoPostback | trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。
Chart | チャートの配置。
ClickedX | 最後にクリックされたX座標の値を返します。
ClickedY | 最後にクリックされたY座標の値を返します。
Config |
GetChartFile | GetChart.aspxがプロジェクトフォルダと同じ位置にない場合、GetChart.aspxの代わりの位置を取得/設定します。チャートのストリーミングのために「セッション」を選択した場合、GetChartスクリプトを使用してください。
Height | チャートのピクセル単位の高さ。
PictureFormat | チャートのイメージ形式。
TempChart | ｢Session｣に設定すると、TeeChart はWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリファイルを作成しません）。｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。
Width | チャートのピクセル単位の幅。

参照

WebChart クラス | Steema.TeeChart.Web 名前空間


AutoPostback

Steema.TeeChart.Web.WebChart.AutoPostback プロパティ

trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。
public Boolean AutoPostback {get; set;}

解説

trueの場合、TeeChartのWebChartはユーザのマウスクリックイベントに応じます。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Chart

Steema.TeeChart.Web.WebChart.Chart プロパティ

チャートの構成。
public Chart Chart {get;}

解説

チャートの構成。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickedX

Steema.TeeChart.Web.WebChart.ClickedX プロパティ

public Int32 ClickedX {get;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


ClickedY

Steema.TeeChart.Web.WebChart.ClickedY プロパティ

public Int32 ClickedY {get;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Config

Steema.TeeChart.Web.WebChart.Config プロパティ

public String Config {get; set;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


GetChartFile

Steema.TeeChart.Web.WebChart.GetChartFile プロパティ

GetChart.aspxがプロジェクトフォルダと同じ位置にない場合、GetChart.aspxの代わりの位置を取得/設定します。チャートのストリーミングのために「セッション」を選択した場合、GetChartスクリプトを使用してください。

public String GetChartFile {get; set;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Height

Steema.TeeChart.Web.WebChart.Height プロパティ

チャートの高さをピクセル単位で取得/設定します。

public override Unit Height {get; set;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


PictureFormat

Steema.TeeChart.Web.WebChart.PictureFormat プロパティ

チャートのイメージ形式を取得/設定します。
public PictureFormats PictureFormat {get; set;}

解説

チャートのイメージ形式。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


TempChart

Steema.TeeChart.Web.WebChart.TempChart プロパティ

｢Session｣に設定すると、TeeChartはWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリファイルを作成しません）。 ｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。以下の例を参照してください。
public TempChartStyle TempChart {get; set;}

例

新しいWebFormをWebプロジェクトに｢GetChart.aspx｣という名前で追加します。 Page_Loadイベントで以下のコードを設定します。

private void Page_Load(object sender, System.EventArgs e)
{
    // ストリームの保存したチャートをWebFormに返すコード
    string chartName=Request.QueryString["Chart"];

    if (Session[chartName]!=null)
    {
        System.IO.MemoryStream chartStream = new System.IO.MemoryStream();
        chartStream=((System.IO.MemoryStream)Session[chartName]);
        Response.OutputStream.Write(chartStream.ToArray(),0,(int)chartStream.Length);
        chartStream.Close();
        Session.Remove(chartName);
    }
}

解説

｢Session｣に設定すると、TeeChartはWebFormで直接使用されるためにチャートをセッション変数にストリームします（テンポラリーファイルではありません。） ｢Session｣を使用する場合、TeeChartを返すためにスクリプトファイルを追加する必要があります。

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Width

Steema.TeeChart.Web.WebChart.Width プロパティ

チャートの幅をピクセル単位で取得/設定します。
public override Unit Width {get; set;}

参照

WebChart クラス | WebChart メンバ | Steema.TeeChart.Web 名前空間


Steema.TeeChart.Web.WebChart.ClickEventHandler

Steema.TeeChart.Web.WebChart.ClickEventHandler デリゲート

Web Clickのイベントハンドラ。

public virtual Void Invoke(Object sender,
     ImageClickEventArgs e)

必要条件

名前空間： Steema.TeeChart.Web

アセンブリ：TeeChart.dll

参照

SteemaTeeChartWebWebChartClickEve 名前空間


Steema.TeeChart.Web.WebChart.SeriesEventHandler

Steema.TeeChart.Web.WebChart.SeriesEventHandler デリゲート

系列のWebイベントハンドラ。
public delegate SeriesEventHandler (Object sender,
     Series s,
     Int32 valueIndex,
     EventArgs e)

必要条件

名前空間: Steema.TeeChart.Web 名前空間

アセンブリ: TeeChart.dll

参照

Steema.TeeChart.Web 名前空間


TeeChart.Languages

TeeChart.Languages アセンブリ

解説

TeeChart.Languagesは、TeeChartエディタやメッセージテキストのための言語サポートを提供します。

例

言語の変更は、チャートエディタや他のTeeChart ダイアログの言語を変更します。実行時に言語を変更する場合：

1. プロジェクトでのTeeChart.Languages.dll の参照

2. 実行（この場合は日本語）

Steema.TeeChart.Languages.Japanese.Activate();

実行時にTeeChartのエディタダイアログを日本語で表示する場合、次の2つの方法があります。

1.静的メソッドを使用する場合
例：
[C#]

Steema.TeeChart.Editors.GradientEditor.Edit(areaSeries1.Brush.Gradient);

2.クラスを作成する場合
例：
[C#]
Steema.TeeChart.Editors.GradientEditor gradientEditor = new Steema.TeeChart.Editors.GradientEditor(area1.Brush.Gradient);

Steema.TeeChart.Editors.EditorUtils.Translate(gradientEditor);

gradientEditor.ShowDialog();

必要条件

アセンブリ：TeeChart.Languages.dll


Steema.TeeChart.Editors

TeeChartプログラミングガイド

Steema.TeeChart.Editors 名前空間

名前空間の階層構造

パブリック クラス

AskLanguage

必要条件

名前空間： Steema.TeeChart.Editors

アセンブリ：TeeChart.Languages.dll


Steema.TeeChart.Editors 階層構造

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

System.Windows.Forms.Control

System.Windows.Forms.ScrollableControl

System.Windows.Forms.ContainerControl

System.Windows.Forms.Form

Steema.TeeChart.Editors.AskLanguage

参照

SteemaTeeChartEditors 名前空間


Steema.TeeChart.Languages

Steema.TeeChart.Languages 名前空間

名前空間の階層構造

パブリック クラス

Turkish
Slovak
Hebrew
Brazilian
Slovene
Finnish
ChineseTrad
Danish
French
Swedish
Norwegian
Arabic
Utils
Portuguese
Japanese
German
Italian
Polish
Hellenic
ChineseSimp
Indonesian
Russian
Korean
Spanish
Hungarian
Galician
Ukrainian
Translator
Dutch
Catalan

必要条件

名前空間: Steema.TeeChart.Languages 名前空間

アセンブリ: TeeChart.Languages.dll


Steema.TeeChart.Languages 階層構造

System.Object

Steema.TeeChart.Languages.Arabic

Steema.TeeChart.Languages.Brazilian

Steema.TeeChart.Languages.Catalan

Steema.TeeChart.Languages.ChineseSimp

Steema.TeeChart.Languages.ChineseTrad

Steema.TeeChart.Languages.Danish

Steema.TeeChart.Languages.Dutch

Steema.TeeChart.Languages.Finnish

Steema.TeeChart.Languages.French

Steema.TeeChart.Languages.Galician

Steema.TeeChart.Languages.German

Steema.TeeChart.Languages.Hebrew

Steema.TeeChart.Languages.Hellenic

Steema.TeeChart.Languages.Hungarian

Steema.TeeChart.Languages.Indonesian

Steema.TeeChart.Languages.Italian

Steema.TeeChart.Languages.Japanese

Steema.TeeChart.Languages.Korean

Steema.TeeChart.Languages.Norwegian

Steema.TeeChart.Languages.Polish

Steema.TeeChart.Languages.Portuguese

Steema.TeeChart.Languages.Russian

Steema.TeeChart.Languages.Slovak

Steema.TeeChart.Languages.Slovene

Steema.TeeChart.Languages.Spanish

Steema.TeeChart.Languages.Swedish

Steema.TeeChart.Languages.Translator

Steema.TeeChart.Languages.Turkish

Steema.TeeChart.Languages.Ukrainian

Steema.TeeChart.Languages.Utils

参照

SteemaTeeChartLanguages 名前空間


Steema.TeeChart.Languages.Utils

Steema.TeeChart.Languages.Utils クラス

この型のすべてのメンバの一覧については、Utils メンバを参照してください。

System.Object
public class Utils : Object

必要条件

名前空間: Steema.TeeChart.Languages 名前空間

アセンブリ: TeeChart.Languages.dll

参照

Utils メンバ | Steema.TeeChart.Languages 名前空間


Steema.TeeChart.Languages.Utils 全メンバ

Utils 概要

パブリック フィールド

LanguageList

参照

Utils クラス | Steema.TeeChart.Languages 名前空間


Steema.TeeChart.Languages.Utils フィールド

パブリック フィールド

LanguageList

参照

Utils クラス | Steema.TeeChart.Languages 名前空間


LanguageList

Steema.TeeChart.Languages.Utils.LanguageList フィールド

public String[] LanguageList

参照

Utils クラス | Utils メンバ | Steema.TeeChart.Languages 名前空間


TeeChart.Mapping

TeeChart.Mapping アセンブリ

必要条件

アセンブリ: TeeChart.Mapping.dll


Steema.TeeChart.Data.SHP

Steema.TeeChart.Data.SHP クラス

TeeSHPの概要。

この型のすべてのメンバの一覧については、SHP メンバを参照してください。

System.Object
public class SHP : Object

必要条件

名前空間: Steema.TeeChart.Data 名前空間

アセンブリ: TeeChart.Mapping.dll

参照

SHP メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHP 全メンバ

SHP 概要

コンストラクタ

Constructor

パブリック メソッド

LoadMap

プロテクト メソッド

LoadMap

参照

SHP クラス | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHP コンストラクタ

public SHP()

参照

SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHP メソッド

パブリック メソッド

LoadMap

プロテクト メソッド

LoadMap

参照

SHP クラス | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

オーバーロードの一覧

public Void LoadMap(Steema.TeeChart.Styles.Map, System.String)
public Void LoadMap(Steema.TeeChart.Styles.Map, System.String, System.Boolean)
public Void LoadMap(Steema.TeeChart.Styles.Map, System.String, System.String)

マップ系列にESRI(c) SHPファイルをロードします。

public Void LoadMap(Steema.TeeChart.Styles.Map, System.String, System.Data.DataTable, System.String, System.String, System.Windows.Forms.ListBox+ObjectCollection, System.String)
protected internal Void LoadMap(Steema.TeeChart.Styles.Map, System.String, System.Data.DataTable, System.String, System.String, System.Windows.Forms.ListBox+ObjectCollection, System.String, System.Boolean)

参照

SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

public Void LoadMap(Map series,
     String fileName)

参照

LoadMap オーバーロードの一覧 | SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

public Void LoadMap(Map series,
     String fileName,
     Boolean isResource)

参照

LoadMap オーバーロードの一覧 | SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

public Void LoadMap(Map series,
     String fileName,
     String filter)

参照

LoadMap オーバーロードの一覧 | SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

マップ系列にESRI(c) SHPファイルをロードします。
public Void LoadMap(Map Series,
     String FileName,
     DataTable Table,
     String FieldName,
     String FieldValue,
     ObjectCollection Debug,
     String filter)

パラメーター

Series
FileName
Table
FieldName
FieldValue
Debug

参照

LoadMap オーバーロードの一覧 | SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


LoadMap

Steema.TeeChart.Data.SHP.LoadMap メソッド

protected internal Void LoadMap(Map Series,
     String FileName,
     DataTable Table,
     String FieldName,
     String FieldValue,
     ObjectCollection Debug,
     String filter,
     Boolean isResource)

参照

LoadMap オーバーロードの一覧 | SHP クラス | SHP メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPHeader

Steema.TeeChart.Data.SHPHeader 値型

この型のすべてのメンバの一覧については、SHPHeader メンバを参照してください。

System.Object
System.ValueType
public sealed struct SHPHeader : ValueType

参照

SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPHeader 全メンバ

SHPHeader 概要

パブリック フィールド

FileCode
FileLength
MMax
MMin
ShapeType
Unused1
Unused2
Unused3
Unused4
Unused5
Version
XMax
XMin
YMax
YMin
ZMax
ZMin

参照

SHPHeader 構造体 | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPHeader フィールド

パブリック フィールド

FileCode
FileLength
MMax
MMin
ShapeType
Unused1
Unused2
Unused3
Unused4
Unused5
Version
XMax
XMin
YMax
YMin
ZMax
ZMin

参照

SHPHeader 構造体 | Steema.TeeChart.Data 名前空間


FileCode

Steema.TeeChart.Data.SHPHeader.FileCode フィールド

public Int32 FileCode

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


FileLength

Steema.TeeChart.Data.SHPHeader.FileLength フィールド

public Int32 FileLength

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


MMax

Steema.TeeChart.Data.SHPHeader.MMax フィールド

public Double MMax

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


MMin

Steema.TeeChart.Data.SHPHeader.MMin フィールド

public Double MMin

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


ShapeType

Steema.TeeChart.Data.SHPHeader.ShapeType フィールド

public Int32 ShapeType

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Unused1

Steema.TeeChart.Data.SHPHeader.Unused1 フィールド

public Int32 Unused1

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Unused2

Steema.TeeChart.Data.SHPHeader.Unused2 フィールド

public Int32 Unused2

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Unused3

Steema.TeeChart.Data.SHPHeader.Unused3 フィールド

public Int32 Unused3

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Unused4

Steema.TeeChart.Data.SHPHeader.Unused4 フィールド

public Int32 Unused4

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Unused5

Steema.TeeChart.Data.SHPHeader.Unused5 フィールド

public Int32 Unused5

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Version

Steema.TeeChart.Data.SHPHeader.Version フィールド

public Int32 Version

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


XMax

Steema.TeeChart.Data.SHPHeader.XMax フィールド

public Double XMax

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


XMin

Steema.TeeChart.Data.SHPHeader.XMin フィールド

public Double XMin

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


YMax

Steema.TeeChart.Data.SHPHeader.YMax フィールド

public Double YMax

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


YMin

Steema.TeeChart.Data.SHPHeader.YMin フィールド

public Double YMin

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


ZMax

Steema.TeeChart.Data.SHPHeader.ZMax フィールド

public Double ZMax

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


ZMin

Steema.TeeChart.Data.SHPHeader.ZMin フィールド

public Double ZMin

参照

SHPHeader 構造体 | SHPHeader メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPRecordHeader

Steema.TeeChart.Data.SHPRecordHeader 値型

この型のすべてのメンバの一覧については、SHPRecordHeader メンバを参照してください。

System.Object
System.ValueType
public sealed struct SHPRecordHeader : ValueType

参照

SHPRecordHeader メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPRecordHeader 全メンバ

SHPRecordHeader 概要

パブリック フィールド

RecordLength
RecordNumber

参照

SHPRecordHeader 構造体 | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Data.SHPRecordHeader フィールド

パブリック フィールド

RecordLength
RecordNumber

参照

SHPRecordHeader 構造体 | Steema.TeeChart.Data 名前空間


RecordLength

Steema.TeeChart.Data.SHPRecordHeader.RecordLength フィールド

public Int32 RecordLength

参照

SHPRecordHeader 構造体 | SHPRecordHeader メンバ | Steema.TeeChart.Data 名前空間


RecordNumber

Steema.TeeChart.Data.SHPRecordHeader.RecordNumber フィールド

public Int32 RecordNumber

参照

SHPRecordHeader 構造体 | SHPRecordHeader メンバ | Steema.TeeChart.Data 名前空間


Steema.TeeChart.Mapping

Steema.TeeChart.Mapping 名前空間

名前空間の階層構造

パブリック クラス

Maps Mapsコンポーネントを配置して、地図を作成するためにチャートを設定できます。ツールボックスからMapsコンポーネントをフォームに追加し、チャートエディタのチャートギャラリ（利用可能な系列型のギャラリ）に表示するようMapsタブを有効にするには、それをTChart (または WebChart)に関連付けてください。チャートエディタのチャートギャラリにMapsタブを表示したくない場合は、プロジェクトでTeeChart.Mapping.dllの参照が必要で、次の実行時のコードを使用してください。
    //TeeChart.Mapping.dll 内から
    //利用可能な系列型です。
    private Steema.TeeChart.Styles.World world1;

    private void InitializeChart()
    {
        tChart1.Series.Add(world1 = new Steema.TeeChart.Styles.World());
        world1.Map = Steema.TeeChart.Styles.WorldMapType.Spain;
        world1.FillSampleValues(); //Y値の描画
    }

必要条件

名前空間: Steema.TeeChart.Mapping 名前空間

アセンブリ: TeeChart.Mapping.dll

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Mapping 階層構造

System.Object

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Mapping.Maps

参照

SteemaTeeChartMapping 名前空間


Steema.TeeChart.Mapping.Maps

Steema.TeeChart.Mapping.Maps クラス

Mapsコンポーネントを配置して、地図を作成するためにチャートを設定できます。ツールボックスからMapsコンポーネントをフォームに追加し、チャートエディタのチャートギャラリ（利用可能な系列型のギャラリ）に表示するようMapsタブを有効にするには、それをTChart (または WebChart)に関連付けてください。チャートエディタのチャートギャラリにMapsタブを表示したくない場合は、プロジェクトでTeeChart.Mapping.dllの参照が必要で、次の実行時のコードを使用してください。
    //TeeChart.Mapping.dll 内から
    //利用可能な系列型です。
    private Steema.TeeChart.Styles.World world1;

    private void InitializeChart()
    {
        tChart1.Series.Add(world1 = new Steema.TeeChart.Styles.World());
        world1.Map = Steema.TeeChart.Styles.WorldMapType.Spain;
        world1.FillSampleValues(); //Y値の描画
    }

この型のすべてのメンバの一覧については、Maps メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
public class Maps : Component , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Mapping 名前空間

アセンブリ: TeeChart.Mapping.dll

参照

Maps メンバ | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps 全メンバ

Maps 概要

コンストラクタ

Constructor オーバーロードされたコンストラクタ。Maps環境のセットアップ。

パブリック メソッド

SetChart マップコンポーネントに関連付けるチャートを設定します。

パブリック プロパティ

Active | trueに設定すると、チャートのOpenGLが有効になります。
TChart | MapsコンポーネントをリンクするTChartを選択します。
WebChart | MapsコンポーネントをリンクするWebChartを選択します。

参照

Maps クラス | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps コンストラクタ

オーバーロードの一覧

コンストラクタ。Maps環境のセットアップ。

public Maps()

コンストラクタ。

public Maps(Steema.TeeChart.TChart)

コンストラクタ。

public Maps(Steema.TeeChart.Web.WebChart)

コンストラクタ。

public Maps(Steema.TeeChart.Chart)

参照

Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Mapping.Maps コンストラクタ

コンストラクタ。Maps環境のセットアップ。
public Maps()

参照

Maps コンストラクタのオーバーロードの一覧 | Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間

c 2002-2008 Steema Software SL. All rights reserved.


Steema.TeeChart.Mapping.Maps コンストラクタ

コンストラクタ
public Maps(TChart tc)

パラメーター

tc
TChart

参照

Maps コンストラクタのオーバーロードの一覧 | Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps コンストラクタ

コンストラクタ
public Maps(WebChart wc)

パラメーター

tc
WebChart

参照

Maps コンストラクタのオーバーロードの一覧 | Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps コンストラクタ

コンストラクタ
public Maps(Chart c)

パラメーター

c
Chart

参照

Maps コンストラクタのオーバーロードの一覧 | Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps メソッド

パブリック メソッド

SetChart マップコンポーネントに関連付けるチャートを設定します。

参照

Maps クラス | Steema.TeeChart.Mapping 名前空間


SetChart

Steema.TeeChart.Mapping.Maps.SetChart メソッド

マップコンポーネントに関連付けるチャートを設定します。
public Void SetChart(Chart c)

パラメーター

c

参照

Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間


Steema.TeeChart.Mapping.Maps プロパティ

パブリック プロパティ

Active | trueに設定すると、チャートのOpenGLが有効になります。
TChart | MapsコンポーネントをリンクするTChartを選択します。
WebChart | MapsコンポーネントをリンクするWebChartを選択します。

参照

Maps クラス | Steema.TeeChart.Mapping 名前空間


Active

Steema.TeeChart.Mapping.Maps.Active プロパティ

trueに設定すると、チャートのOpenGLが有効になります。
public Boolean Active {get; set;}

参照

Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間


TChart

Steema.TeeChart.Mapping.Maps.TChart プロパティ

MapsコンポーネントをリンクするTChartを選択します。
public TChart TChart {get; set;}

参照

Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間 | TChart


WebChart

Steema.TeeChart.Mapping.Maps.WebChart プロパティ

MapsコンポーネントをリンクするWebChartを選択します。
public WebChart WebChart {get; set;}

参照

Maps クラス | Maps メンバ | Steema.TeeChart.Mapping 名前空間 | WebChart


Steema.TeeChart.Styles.World

Steema.TeeChart.Styles.World クラス

世界地図系列。

この型のすべてのメンバの一覧については、World メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Styles.Series
Steema.TeeChart.Styles.Custom3D
Steema.TeeChart.Styles.Custom3DPalette
Steema.TeeChart.Styles.Map
public class World : Map , IComponent, IDisposable, ICloneable
, IWorldMaps

必要条件

名前空間: Steema.TeeChart.Styles 名前空間

アセンブリ: TeeChart.Mapping.dll

参照

World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World 全メンバ

World 概要

コンストラクタ

Constructor オーバーロード

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddShape (Mapの継承元) | マップ系列に新しいシェープを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Mapの継承元) |
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Mapの継承元) | マップ系列で「クリックされた」ポイントのValueIndexを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Mapの継承元) |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Mapの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues |
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetWorldMapTypeNames |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
LoadMapFromResource |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Mapの継承元) |
MaxYValue (Mapの継承元) |
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Mapの継承元) |
MinYValue (Mapの継承元) |
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
ParseWorldMapTypeName |
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Mapの継承元) |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InGallery |
Item (Mapの継承元) | マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。
LabelMember (Mapの継承元) |
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Map |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃い/グレースケールを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow |
Shapes (Mapの継承元) | Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Mapの継承元) | マップ系列の透明度を設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Mapの継承元) |
YValues (Mapの継承元) |
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Mapの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Mapの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Mapの継承元) |
Dispose (Mapの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Mapの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Mapの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Mapの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeShapes (Mapの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

World クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World コンストラクタ

オーバーロードの一覧

public World(System.Object)
public World()
public World(Steema.TeeChart.Chart)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World コンストラクタ

public World(Object initArg)

参照

World コンストラクタのオーバーロードの一覧 | World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World コンストラクタ

public World()

参照

World コンストラクタのオーバーロードの一覧 | World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World コンストラクタ

public World(Chart c)

参照

World コンストラクタのオーバーロードの一覧 | World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World コンストラクタ

public World(Chart c,
     String loadMaps)

参照

World コンストラクタのオーバーロードの一覧 | World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World イベント

パブリック イベント

AfterDrawValues (Seriesの継承元) | すべての系列ポイントを描画した直後、および前面にある他の系列を描画する前に発生します。
BeforeDrawValues (Seriesの継承元) | すべての系列ポイントを描画する直前、および背面にある他の系列を描画した後に発生します。
Click (Seriesの継承元) | 系列ポイントをマウスでクリックした際に発生します。
DblClick (Seriesの継承元) | 系列ポイントをマウスでダブルクリックした際に発生します。
GetSeriesMark (Seriesの継承元) | 各系列ポイントにマーカを描画する際に発生します。マーカのテキスト内容を変更する場合に使用してください。
GetValueColor (Custom3DPaletteの継承元) | サーフェスのポリゴンが表示される度に発生します。このイベントを使用して、各サーフェスのポリゴンに特定の色を設定できます。
MouseEnter (Seriesの継承元) | マウスカーソルが系列のポイントに「触れる」と発生します。
MouseLeave (Seriesの継承元) | マウスカーソルが系列のポイントから「離れる」と発生します。

参照

World クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World フィールド

パブリック フィールド

bBrush (Seriesの継承元) |
GetHorizAxis (Seriesの継承元) | 系列に関連している水平軸を返します。
GetVertAxis (Seriesの継承元) | 系列に関連している垂直軸を返します。
HasZValues (Seriesの継承元) | 系列がZ値を持っている場合trueを返します。
mandatory (Seriesの継承元) |
manualData (Seriesの継承元) |
notMandatory (Seriesの継承元) |
UseAxis (Seriesの継承元) | 系列がポイントを表示するために軸が必要な場合、Trueを返します。例えば円系列はFalseを返します。

プロテクト フィールド

AllowSinglePoint (Seriesの継承元)
bActive (Seriesの継承元)
bColorEach (Seriesの継承元)
bUseColorRange (Custom3DPaletteの継承元)
bUsePalette (Custom3DPaletteの継承元)
calcVisiblePoints (Seriesの継承元)
DrawBetweenPoints (Seriesの継承元)
firstVisible (Seriesの継承元)
InternalUse (TeeBaseの継承元)
iPaletteSteps (Custom3DPaletteの継承元)
lastVisible (Seriesの継承元)
sameBrush (Custom3DPaletteの継承元)
sLabels (Seriesの継承元)
Steema.TeeChart.Drawing.TeeBase.Tag
UseSeriesColor (Seriesの継承元)
vxValues (Seriesの継承元)
vyValues (Seriesの継承元)
vzValues (Custom3Dの継承元)
yMandatory (Seriesの継承元)

参照

World クラス | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World メソッド

パブリック メソッド

Add (Custom3Dの継承元) | X,Y,Zの配列を追加します。
AddNull (Seriesの継承元) | 旧式：このメソッドの代わりにパラメーターなしでAdd()メソッドを使用してください。
AddNullXY (Seriesの継承元) | 旧式：このメソッドの代わりにAdd(x,y,Color.Transparent)メソッドを使用してください。
AddPalette (Custom3DPaletteの継承元) | パレットリストに色を追加します。
AddShape (Mapの継承元) | マップ系列に新しいシェープを追加します。
Assign (Seriesの継承元) | 指定した系列コンポーネントから他の系列コンポーネントへ全てのプロパティをコピーします。
AssignFormat |
AssignValues (Seriesの継承元) | 指定した系列から現在の系列に全ての値を割り当てます。
BeginUpdate (Seriesの継承元) | ポイントを追加後に一度で関数を再計算します。
CalcPosValue (Seriesの継承元) | 軸スケールの｢Value｣パラメーターに該当する座標位置をピクセル単位で返します。
CalcXPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の水平画面座標値をピクセル単位で返します。
CalcXPosValue (Seriesの継承元) | 指定したValueパラメーターの水平画面座標値をピクセル単位で返します。
CalcXSizeValue (Seriesの継承元) | 水平の軸スケール単位で指定したValueパラメーターに該当する水平画面寸法（サイズ）をピクセル単位で返します。
CalcYPos (Seriesの継承元) | 指定したValueIndexパラメーターの系列値の垂直画面座標値をピクセル単位で返します。
CalcYPosValue (Seriesの継承元) | 指定したValueパラメーターの垂直画面座標値をピクセル単位で返します。
CalcYSizeValue (Seriesの継承元) | 指定したValueパラメータの垂直画面寸法（サイズ）をピクセル単位で返します。
CalcZPos (Custom3Dの継承元) |
CheckDataSource (Seriesの継承元) | データベースのテーブル、クエリー、あるいは系列ポイントの変更内容を確認して全ての系列ポイント値を更新します。
CheckOrder (Seriesの継承元) | X値リスト、Y値リスト等のOrderプロパティによりポイントを再ソートします。
Clear (Mapの継承元) |
ClearPalette (Custom3DPaletteの継承元) | すべてのパレットの情報を削除します。
Clicked (Mapの継承元) | マップ系列で「クリックされた」ポイントのValueIndexを返します。
Clone (Seriesの継承元) | 指定した系列を新しい系列として複製します。
Delete (Mapの継承元) |
Draw |
DrawSeries (Seriesの継承元) | チャートキャンバスに系列を描画します。
DrawValue (Mapの継承元) |
DrawValuesForward (Seriesの継承元) | 系列が昇順または降順でポイントを描画するかどうかを返します。
EndUpdate (Seriesの継承元) | BeginUpdateメソッドと共に使用して、ポイントの追加後に1度で関数を計算させるために使用します。
FillSampleValues |
FirstDisplayedIndex (Seriesの継承元) | 系列を描画する際に最初に描画される系列ポイントのインデックスを返します。
GalleryChanged3D |
GetBitmapEditor (Seriesの継承元) | 指定した系列クラスに対応したビットマップのアイコンを返します。このアイコンはChartListBoxや系列のエディタダイアログで使用されます。
GetMarkValue (Seriesの継承元) | 系列マーカで表示されているポイント値を返します。
GetWorldMapTypeNames |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
IsNull (Seriesの継承元) | 系列の指定したインデックスのポイントが｢null｣または｢空｣の場合、true を返します。そのポイントの色が｢透明｣の場合、そのポイントを「null 」とみなします。
IsValidSourceOf (Custom3Dの継承元) | 指定した系列オブジェクトインスタンスがCustom3Dインスタンスかどうか確認します。
LegendString (Custom3DPaletteの継承元) | 指定したインデックスの凡例項目の書式化された文字列を返します。
LoadMapFromResource |
MaxMarkWidth (Seriesの継承元) | すべての系列マーカの中で最も長いマーカテキストの幅をピクセル単位で返します。
MaxXValue (Mapの継承元) |
MaxYValue (Mapの継承元) |
MaxZValue (Custom3Dの継承元) | Z値の最大値を返します。
MinXValue (Mapの継承元) |
MinYValue (Mapの継承元) |
MinZValue (Custom3Dの継承元) | Z値の最小値を返します。
ParseWorldMapTypeName |
PrepareForGallery |
RefreshSeries (Seriesの継承元) | すべての関連する系列のポイントを再計算します。
Repaint (Seriesの継承元) | 強制的にチャートを再描画します。
ScreenPointToValuePoint (Seriesの継承元) | 軸の境界間に画面位置の該当するPointDouble値を返します。
SetNull (Seriesの継承元) | 指定した系列ポイントをnull(透明）ポイントに設定します。
SetSubGallery |
SortByLabels (Seriesの継承元) | Labels（テキスト）リストを使用して系列のすべてのポイントをソートします。メモ：ソート後、｢X｣値は失われます（｢X｣値は再度番号付けされます）。
TitleOrName (Seriesの継承元) | 旧式：このメソッドの代わりにToString()メソッドを使用してください。
ToString (Seriesの継承元) | 系列のTitleプロパティに設定されている文字列を返します。
ValueColor (Custom3DPaletteの継承元) | 指定したインデックスのポイントの色を返します。
ValueMarkText (Seriesの継承元) | 指定したインデックスポイントのマーカの文字列を返します。
ValuePointToScreenPoint (Seriesの継承元) | 軸の境界間に値位置の該当する画面ポイント値を返します。
WriteToDataSource (Seriesの継承元) |
XScreenToValue (Seriesの継承元) | 画面位置に該当するX値を返します。画面位置は、軸の範囲内になければなりません。
YScreenToValue (Seriesの継承元) | 画面位置に該当するY値を返します。画面位置は、軸の範囲内になければなりません。

プロテクト メソッド

AddChartValue (Seriesの継承元) |
Added (Seriesの継承元) |
AddSampleValues |
AddValues (Custom3DPaletteの継承元) |
AssociatedToAxis (Seriesの継承元) |
BackFaced (Custom3Dの継承元) |
CalcColorRange (Custom3DPaletteの継承元) |
CalcDepthPositions (Seriesの継承元) |
CalcFirstLastPage (Seriesの継承元) |
CalcHorizMargins (Mapの継承元) |
CalculateMarkPosition (Seriesの継承元) |
CalcVerticalMargins (Mapの継承元) |
CalcZOrder (Custom3Dの継承元) |
CanAddRandomPoints (Seriesの継承元) |
CheckMouse (Seriesの継承元) |
ClearLists (Seriesの継承元) |
ConvertArray (Seriesの継承元) |
CountLegendItems (Custom3DPaletteの継承元) |
CreateDefaultPalette (Custom3DPaletteの継承元) |
CreateSubGallery (Mapの継承元) |
Dispose (Mapの継承元) |
DoAfterDrawValues (Seriesの継承元) |
DoBeforeDrawChart (Custom3DPaletteの継承元) |
DoBeforeDrawValues (Seriesの継承元) |
DoGetSeriesMark (Seriesの継承元) |
DrawLegendShape (Custom3DPaletteの継承元) |
DrawMark (Mapの継承元) |
DrawMarks (Seriesの継承元) |
DrawMarksSeries (Seriesの継承元) |
DrawSeriesForward (Seriesの継承元) |
GetBounds (Mapの継承元) |
GetDataSource (Seriesの継承元) |
GetDefaultColor (Seriesの継承元) |
GetMarkText (Seriesの継承元) |
GetOriginValue (Seriesの継承元) |
GetSeriesColor (Seriesの継承元) |
GetValueColorValue (Custom3DPaletteの継承元) |
InternalColor (Seriesの継承元) |
LegendItemColor (Custom3DPaletteの継承元) |
LegendToValueIndex (Seriesの継承元) |
ModifySeriesColors (Seriesの継承元) |
MoreSameZOrder (Seriesの継承元) | 同じZ方向に複数の系列が存在する場合、trueを返します。例：縦棒の積み重ね。
MouseEvent (Seriesの継承元) |
NumSampleValues (Mapの継承元) |
OnDisposing (Seriesの継承元) |
OriginalValueColor (Custom3DPaletteの継承元) |
PaintLegend (Seriesの継承元) |
PrepareLegendCanvas (Custom3Dの継承元) |
RandomBounds (Seriesの継承元) |
RecalcGetAxis (Seriesの継承元) |
SameClass (Seriesの継承元) | 指定したsパラメーターと同じクラスの場合、Trueを返します。
SetActive (Seriesの継承元) |
SetBooleanProperty (TeeBaseの継承元) |
SetChart |
SetColorEach (Seriesの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetFloatProperty (TeeBaseの継承元) |
SetHorizontal (Seriesの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetSameBrush (Custom3DPaletteの継承元) |
SetSeriesColor (Seriesの継承元) |
SetStringProperty (TeeBaseの継承元) |
SetValueList (Seriesの継承元) |
ShouldSerializeColors (Seriesの継承元) |
ShouldSerializeLabels (Seriesの継承元) |
ShouldSerializeShapes (Mapの継承元) |
ValueListOfAxis (Custom3Dの継承元) |

参照

World クラス | Steema.TeeChart.Styles 名前空間


AddSampleValues

Steema.TeeChart.Styles.World.AddSampleValues メソッド

protected abstract Void AddSampleValues(Int32 numValues)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


AssignFormat

Steema.TeeChart.Styles.World.AssignFormat メソッド

public override Void AssignFormat(Series source)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Draw

Steema.TeeChart.Styles.World.Draw メソッド

public override Void Draw()

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


FillSampleValues

Steema.TeeChart.Styles.World.FillSampleValues メソッド

オーバーロードの一覧

public override Void FillSampleValues(System.Int32)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


FillSampleValues

Steema.TeeChart.Styles.World.FillSampleValues メソッド

public override Void FillSampleValues(Int32 numValues)

参照

FillSampleValues オーバーロードの一覧 | World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


GalleryChanged3D

Steema.TeeChart.Styles.World.GalleryChanged3D メソッド

public override Void GalleryChanged3D(Boolean Is3D)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


GetWorldMapTypeNames

Steema.TeeChart.Styles.World.GetWorldMapTypeNames メソッド

public virtual String[] GetWorldMapTypeNames()

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


LoadMapFromResource

Steema.TeeChart.Styles.World.LoadMapFromResource メソッド

public Void LoadMapFromResource(Map Series,
     String ShpName)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


ParseWorldMapTypeName

Steema.TeeChart.Styles.World.ParseWorldMapTypeName メソッド

public virtual Object ParseWorldMapTypeName(String name)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


PrepareForGallery

Steema.TeeChart.Styles.World.PrepareForGallery メソッド

public override Void PrepareForGallery(Boolean IsEnabled)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


SetChart

Steema.TeeChart.Styles.World.SetChart メソッド

protected abstract Void SetChart(Chart c)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


SetSubGallery

Steema.TeeChart.Styles.World.SetSubGallery メソッド

public override Void SetSubGallery(Int32 index)

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.World プロパティ

パブリック プロパティ

Active (Seriesの継承元) | 系列を表示/非表示にします。
BlueFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの青のアルファ値を設定します。
Brush (Custom3DPaletteの継承元) | サーフェスポリゴンを塗りつぶすブラシを設定します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
Color (Seriesの継承元) | 系列ポイントのデフォルトの色を取得/設定します。
ColorEach (Seriesの継承元) | 異なる色で系列ポイントを描画します。
ColorEachPoint (Seriesの継承元) | このプロパティの代わりにColorEachプロパティを使用してください。
ColorMember (Seriesの継承元) | データソースのColorフィールドを取得/設定します。
Colors (Seriesの継承元) | 系列のための色の配列にアクセスします。
Count (Seriesの継承元) | 系列内のポイント数を返します。
Cursor (Seriesの継承元) | 系列ポイント上にマウスカーソルが移動した際に使用されるイメージを設定します。
CustomHorizAxis (Seriesの継承元) | 系列に関連付ける水平カスタム軸を設定します。
CustomVertAxis (Seriesの継承元) | 系列に関連付ける垂直カスタム軸を設定します。
DataSource (Seriesの継承元) | 系列にロードさせるデータソースを設定します。
DefaultNullValue (Seriesの継承元) | 系列内のヌル値として使用される値を設定/返します。
Depth (Seriesの継承元) | 系列ポイントあるいは、相互を接続する線の深さを設定します。
Description (Mapの継承元) |
EndColor (Custom3DPaletteの継承元) | 終了範囲パレット色を設定します。
EndZ (Seriesの継承元) | 内部使用。
FirstVisibleIndex (Seriesの継承元) | 系列の最初の可視ポイントのインデックスを返します。
Function (Seriesの継承元) | 値を計算する関数オブジェクトを設定します。
GreenFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの緑のアルファ値を設定します。
HorizAxis (Seriesの継承元) | 系列に関連付ける水平軸を設定します。
InGallery |
Item (Mapの継承元) | マップの多角形オブジェクトをより簡単に取得するための、マップ系列のデフォルトの配列プロパティです。
LabelMember (Mapの継承元) |
Labels (Seriesの継承元) | 系列ポイントのラベルリストにアクセスします。
LastVisibleIndex (Seriesの継承元) | 系列の最後の可視ポイントのインデックスを返します。
Map |
Marks (Seriesの継承元) | 各系列ポイントの近くにマーカを描くための特性を定義します。
MidColor (Custom3DPaletteの継承元) | 中央範囲パレット色を設定します。
MiddleZ (Seriesの継承元) | 内部使用。
NumGallerySeries (Seriesの継承元) | 内部使用。
Palette (Custom3DPaletteの継承元) | カラーパレットのリストにアクセスします。
PaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティがtrueの場合、カラーパレットを計算するための開始値を設定します。
PaletteRange (Custom3DPaletteの継承元) | デフォルトのカラーパレットで色の範囲を定義します。
PaletteStep (Custom3DPaletteの継承元) | パレット色の間隔を設定します。
PaletteSteps (Custom3DPaletteの継承元) | デフォルトのカラーパレットのエントリー数を設定します。
PaletteStyle (Custom3DPaletteの継承元) | カラーパレットの淡い/濃い/グレースケールを選択します。
Pen (Custom3DPaletteの継承元) | サーフェスのポリゴンを描くペンを設定します。
PercentFormat (Seriesの継承元) | パーセントとしてポイント値を表示するための書式を設定します。
RedFactor (Custom3DPaletteの継承元) | ARGBコンポーネントの赤のアルファ値を設定します。
SeriesColor (Seriesの継承元) | 旧式：このプロパティの代わりにSeries.Colorプロパティを使用してください。
SeriesData (Seriesの継承元) |
Shadow |
Shapes (Mapの継承元) | Polygonオブジェクトのリストを返します。リストの各多角形オブジェクトはマップ系列の「シェープ」を表します。
ShowInLegend (Seriesの継承元) | 凡例に系列のタイトルを表示します。
StartColor (Custom3DPaletteの継承元) | 開始範囲パレット色を設定します。
StartZ (Seriesの継承元) | 内部使用。
TimesZOrder (Custom3Dの継承元) | 内部使用。
Title (Seriesの継承元) | 凡例やエディタに表示する系列のタイトルを設定します。
Transparency (Mapの継承元) | マップ系列の透明度を設定します。
UseColorRange (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすグラデーションのカラーパレットを設定します。
UsePalette (Custom3DPaletteの継承元) | サーフェスのポリゴンを塗りつぶすためにマルチカラーパレットを設定します。
UsePaletteMin (Custom3DPaletteの継承元) | UsePaletteMinプロパティの値でカラーパレットを開始させるためには、このプロパティをtrueに設定してください。
ValueFormat (Seriesの継承元) | ポイント値を表示するための書式を設定します。
ValuesLists (Seriesの継承元) | 系列のSteema.TeeChart.Styles.ValuesListsオブジェクトを返します。
VertAxis (Seriesの継承元) | 系列に関連付ける垂直軸を設定します。
Visible (Seriesの継承元) | 系列を表示/非表示にします。
XValues (Mapの継承元) |
YValues (Mapの継承元) |
ZOrder (Seriesの継承元) | 系列が描画される奥軸の位置を取得/設定します。
ZValues (Custom3Dの継承元) | Zポイント位置を設定する値。

参照

World クラス | Steema.TeeChart.Styles 名前空間


InGallery

Steema.TeeChart.Styles.World.InGallery プロパティ

public virtual Boolean InGallery {get; set;}

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Map

Steema.TeeChart.Styles.World.Map プロパティ

public WorldMapType Map {get; set;}

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Shadow

Steema.TeeChart.Styles.World.Shadow プロパティ

public Shape Shadow {get; set;}

参照

World クラス | World メンバ | Steema.TeeChart.Styles 名前空間


Steema.TeeChart.Styles.WorldMapType

Steema.TeeChart.Styles.WorldMapType 列挙体

[Serializable]
public sealed enum WorldMapType : Enum , IComparable
, IFormattable, IConvertible

パリック メンバ

メンバ名 | 説明
World |
Africa |
Asia |
Australia |
CentralAmerica |
Europe |
Europe15 |
Europe27 |
Spain |
MiddleEast |
NorthAmerica |
SouthAmerica |
USA |
USAHawaiiAlaska |

参照

Steema.TeeChart.Styles 名前空間


TeeChart.OpenGL

TeeChart.OpenGL アセンブリ

必要条件

アセンブリ: TeeChart.OpenGL.dll


Steema.TeeChart.Drawing.GL

Steema.TeeChart.Drawing.GL 名前空間

名前空間の階層構造

パブリック クラス

Imports | 外部の宣言を使用してWindowsライブラリにアクセスします。
PIXELFORMATDESCRIPTOR |
BITMAPINFO |
TeeTexture | テクスチャの描画
GLLightSource | OpenGLのライトにアクセスします。
GLPosition | ライトの位置
TeeOpenGL | OpenGL環境はチャートをOpenGL描画に設定するためにTeeOpenGLコンポーネントの配置可能なクラスを格納します。TeeOpenGLはOpenGLキャンバスとLightソースへのアクセスを提供します。
GraphicsGL | CanvasOpenGLの概要。
OpenGL | OpenGLクラスは、3DのOpenGLライブラリを提供します。

パブリック 構造体

SIZE | GetTextExtentPoint32の構造体をサポートします。
PixelFormatDescriptor |
GLFontCache | OpenGLのフォントの一覧

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll


Steema.TeeChart.Drawing.GL Hierarchy

Steema.TeeChart.Drawing.GL 階層構造

System.Object

Steema.TeeChart.Drawing.GL.GLLightSource

Steema.TeeChart.Drawing.GL.GLPosition

Steema.TeeChart.Drawing.GL.Imports

Steema.TeeChart.Drawing.GL.OpenGL

Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO

Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR

Steema.TeeChart.Drawing.GL.TeeTexture

System.MarshalByRefObject

System.ComponentModel.Component

Steema.TeeChart.Drawing.GL.TeeOpenGL

Steema.TeeChart.Drawing.TeeBase

Steema.TeeChart.Drawing.Graphics3D

Steema.TeeChart.Drawing.GL.GraphicsGL

参照

SteemaTeeChartDrawingGL 名前空間


Steema.TeeChart.Drawing.GL.CanvasGL

Steema.TeeChart.Drawing.GL.CanvasGL クラス

この型のすべてのメンバの一覧については、CanvasGL メンバを参照してください。

System.Object
public sealed class CanvasGL : Object

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

CanvasGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.CanvasGL 全メンバ

CanvasGL 概要

コンストラクタ

Constructor

パブリック メソッド

ColorToGL

参照

CanvasGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.CanvasGL コンストラクタ

public CanvasGL()

参照

CanvasGL クラス | CanvasGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.CanvasGL メソッド

パブリック メソッド

ColorToGL

参照

CanvasGL クラス | Steema.TeeChart.Drawing.GL 名前空間


ColorToGL

Steema.TeeChart.Drawing.GL.CanvasGL.ColorToGL メソッド

オーバーロードの一覧

public static Void ColorToGL(System.Drawing.Color, System.Single[]&)
public static Single[] ColorToGL(System.Double)

参照

CanvasGL クラス | CanvasGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ColorToGL

Steema.TeeChart.Drawing.GL.CanvasGL.ColorToGL メソッド

public static Void ColorToGL(Color AColor,
     Single[]& C)

参照

ColorToGL オーバーロードの一覧 | CanvasGL クラス | CanvasGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ColorToGL

Steema.TeeChart.Drawing.GL.CanvasGL.ColorToGL メソッド

public static Single[] ColorToGL(Double Value)

参照

ColorToGL オーバーロードの一覧 | CanvasGL クラス | CanvasGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLFontCache

Steema.TeeChart.Drawing.GL.GLFontCache 構造体

OpenGLのフォントの一覧です。

この型のすべてのメンバの一覧については、GLFontCache メンバを参照してください。

System.Object
System.ValueType
public sealed struct GLFontCache : ValueType

参照

GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLFontCache 全メンバ

GLFontCache 概要

パブリック フィールド

Bold | フォントを太字に設定します（trueの場合は太字になります）。
Font | フォント
Italic | フォントを斜体に設定します（trueの場合は斜体になります）。
Name | フォント名
Offset | フォントのオフセット
Strikeout | フォントを打ち消し線に設定します（trueの場合は打ち消し線になります）。
Underline | フォントを下線に設定します（trueの場合は下線になります）。
Weight | フォントの太さ

参照

GLFontCache 構造体 | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLFontCache フィールド

パブリック フィールド

Bold | フォントを太字に設定します（trueの場合は太字になります）。
Font | フォント
Italic | フォントを斜体に設定します（trueの場合は斜体になります）。
Name | フォント名
Offset | フォントのオフセット
Strikeout | フォントを打ち消し線に設定します（trueの場合は打ち消し線になります）。
Underline | フォントを下線に設定します（trueの場合は下線になります）。
Weight | フォントの太さ

参照

GLFontCache 構造体 | Steema.TeeChart.Drawing.GL 名前空間


Bold

Steema.TeeChart.Drawing.GL.GLFontCache.Bold フィールド

フォントを太字に設定します（trueの場合は太字になります）。

public Boolean Bold

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Extrusion

Steema.TeeChart.Drawing.GL.GLFontCache.Extrusion フィールド

フォントの押出し
public Int32 Extrusion

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Font

Steema.TeeChart.Drawing.GL.GLFontCache.Font フィールド

フォント

public Font Font

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Italic

Steema.TeeChart.Drawing.GL.GLFontCache.Italic フィールド

フォントを斜体に設定します（trueの場合は斜体になります）。

public Boolean Italic

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Name

Steema.TeeChart.Drawing.GL.GLFontCache.Name フィールド

フォント名

public String Name

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Offset

Steema.TeeChart.Drawing.GL.GLFontCache.Offset フィールド

フォントのオフセット。

public UInt32 Offset

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Strikeout

Steema.TeeChart.Drawing.GL.GLFontCache.Strikeout フィールド

フォントを打ち消し線に設定します（trueの場合は打ち消し線になります）。

public Boolean Strikeout

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Underline

Steema.TeeChart.Drawing.GL.GLFontCache.Underline フィールド

フォントを下線に設定します（trueの場合は下線になります）。

public Boolean Underline

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Weight

Steema.TeeChart.Drawing.GL.GLFontCache.Weight フィールド

フォントの太さ

public Int32 Weight

参照

GLFontCache 構造体 | GLFontCache メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLLightSource

Steema.TeeChart.Drawing.GL.GLLightSource クラス

OpenGLのライトについてアクセスします。

この型のすべてのメンバの一覧については、GLLightSource メンバを参照してください。

System.Object
public class GLLightSource : Object , IGLLightsource

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLLightSource 全メンバ

GLLightSource 概要

コンストラクタ

Constructor TeeOpenGLコンポーネントにライトを関連付けるコンストラクタ

パブリック メソッド

GLColor アルファ値を含むRGBの色配列

パブリック プロパティ

Color | ライトの色
FixedPosition | ライトの位置を固定します。trueの場合、チャートを回転させてもライトは移動しません。
Position | 3Dでのライトの位置
Visible | ライトを表示/非表示にします。

参照

GLLightSource クラス | Steema.TeeChart.Drawing.GL 名前空間


GLLightSource コンストラクタ

Steema.TeeChart.Drawing.GL.GLLightSource コンストラクタ

TeeOpenGLコンポーネントにライトを関連付けるコンストラクタ。

public GLLightSource(TeeOpenGL aOwner)

パラメータ

aOwner

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLLightSource メソッド

パブリック メソッド

GLColor

アルファ値を含むRGBの色配列

参照

GLLightSource クラス | Steema.TeeChart.Drawing.GL 名前空間


GLColor

Steema.TeeChart.Drawing.GL.GLLightSource.GLColor メソッド

アルファ値を含むRGBの色配列。

public virtual Single[] GLColor()

戻り値

解説

アルファ値を含むRGBの色配列。

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLLightSource プロパティ

パブリック プロパティ

Color | ライトの色
FixedPosition | ライトの位置を固定します。trueの場合、チャートを回転させてもライトは移動しません。
Position | 3Dのライトの位置
Visible | ライトを表示/非表示にします。

参照

GLLightSource クラス | Steema.TeeChart.Drawing.GL 名前空間


Color

Steema.TeeChart.Drawing.GL.GLLightSource.Color プロパティ

ライトの色を定義します。

public virtual Color Color {get; set;}

解説

デフォルト値：clWhite

GLLightオブジェクトの色を定義します。
デフォルトでは、OpenGLのライトの色は白です。 このプロパティをグレー ( 例: clDkGray、 clSilver ) に設定することによりライトの明るさを変更できます。

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


FixedPosition

Steema.TeeChart.Drawing.GL.GLLightSource.FixedPosition プロパティ

ライトの位置を固定します。trueの場合、チャートを回転させてもライトは移動しません。

public virtual Boolean FixedPosition {get; set;}

解説

デフォルト値: false
ライトの位置を固定させるか、あるいはパネルと連動して回転させるかを取得/設定します。

デフォルトは、Positionプロパティが3D座標のライトのXYZ位置を定義しますが、これらの座標値はパネルのView3DOptionsの回転角度に応じて回転されます。

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Position

Steema.TeeChart.Drawing.GL.GLLightSource.Position プロパティ

3Dのライトの位置。

public virtual IGLPosition Position {get; set;}

解説

キャンバスのLightSourceのXYZ座標値を設定するために使用してください。

3D座標でのライトの回転を無効にするには、FixedPositionプロパティも参照してください。

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Visible

Steema.TeeChart.Drawing.GL.GLLightSource.Visible プロパティ

ライトを表示/非表示に設定します。

public virtual Boolean Visible {get; set;}

解説

ライトを表示/非表示に設定します。

参照

GLLightSource クラス | GLLightSource メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLPosition

Steema.TeeChart.Drawing.GL.GLPosition クラス

ライトの位置。

この型のすべてのメンバの一覧については、GLPosition メンバを参照してください。

System.Object
public class GLPosition : Object , IGLPosition

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLPosition 全メンバ

GLPosition 概要

コンストラクタ

Constructor コンストラクタ

パブリック プロパティ

Owner | GLPositionを実行させるTeeOpenGLのインスタンス
X | TGLLightSourceのX座標を設定します。
Y | TGLLightSourceのY座標を設定します。
Z | TGLLightSourceのZ座標を設定します。

参照

GLPosition クラス | Steema.TeeChart.Drawing.GL 名前空間


GLPosition コンストラクタ

Steema.TeeChart.Drawing.GL.GLPosition コンストラクタ

コンストラクタ

public GLPosition(TeeOpenGL o)

パラメータ

o
TeeOpenGL コンポーネント

参照

GLPosition クラス | GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GLPosition プロパティ

パブリック プロパティ

Owner | GLPositionを実行させるTeeOpenGLインスタンス
X | TGLLightSourceのX座標を設定します。
Y | TGLLightSourceのY座標を設定します。
Z | TGLLightSourceのZ座標を設定します。

参照

GLPosition クラス | Steema.TeeChart.Drawing.GL 名前空間


Owner

Steema.TeeChart.Drawing.GL.GLPosition.Owner プロパティ

GLPositionを実行させるTeeOpenGLインスタンス

public TeeOpenGL Owner {get; set;}

解説

GLPositionを実行させるTeeOpenGLインスタンス

参照

GLPosition クラス | GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


X

Steema.TeeChart.Drawing.GL.GLPosition.X プロパティ

TGLLightSourceのX座標を設定します。

public virtual Double X {get; set;}

解説

TGLLightSourceのX座標を設定します。

参照

GLPosition クラス | GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


Y

Steema.TeeChart.Drawing.GL.GLPosition.Y プロパティ

TGLLightSourceのY座標を設定します。

public virtual Double Y {get; set;}

解説

TGLLightSourceのY座標を設定します。

参照

GLPosition クラス | GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


Z

Steema.TeeChart.Drawing.GL.GLPosition.Z プロパティ

TGLLightSourceのZ座標を設定します。

public virtual Double Z {get; set;}

解説

TGLLightSourceのZ座標を設定します。

参照

GLPosition クラス | GLPosition メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL

Steema.TeeChart.Drawing.GL.GraphicsGL クラス

CanvasOpenGLの概要。

この型のすべてのメンバの一覧については、GraphicsGL メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
Steema.TeeChart.Drawing.TeeBase
Steema.TeeChart.Drawing.Graphics3D
public class GraphicsGL : Graphics3D , IComponent, IDisposable

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL 全メンバ

GraphicsGL 概要

コンストラクタ

Constructor オーバーロードされたコンストラクタ。

パブリック イベント

Init
Projectioned

パブリック フィールド

FontOutlines | フォントのアウトラインを設定します。
FontStyle |
FourPoints (Graphics3Dの継承元) |
IPointDoubles (Graphics3Dの継承元) |
Monochrome (Graphics3Dの継承元) |
TeeColorPlanes |
UsesStencil |

パブリック メソッド

ActivateBlend |
Arc | 今回のリリースでは実装されていません。
Arrow | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation |
DoProjection |
Draw | このバージョンでは実装されていません。
DrawBeziers | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
DrawString | 現在の位置に文字列を描画します。
Elevate |
Ellipse |
EllipseEnh | Ellipseを参照してください。
EnableRotation |
EndBlending | ブラシの透明度の重ね合わせ処理を終了します。
EraseBackground | 実装されていません。
FillRectangle | 塗りつぶされた矩形を描画します。
FillRegion | 領域の内側を塗りつぶします。
FindTexture |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。
LineTo | 現在位置から新しいx,y座標値までの線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo | LineToメソッドを呼び出す前に、線の描画を開始するxy座標を設定します。
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | パイスライスを描画します。
Pixel |
Plane | 平面図形を描画します。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
Polygon3D |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix |
PrepareDrawImage |
Projection |
PushMatrix |
Pyramid | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc |
Rectangle |
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY |
RectangleZ |
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetModelView |
SetTextAlign | テキストを揃えます。
ShowImage | イメージを描画します。
Sphere | 球を描画します。
SphereEnh | Sphereを参照してください。
StartBlending | ブラシの透明度の重ね合わせ処理を開始します。
Surface3D | 複数セルのサーフェスを描画します。
TeeCull (Graphics3Dの継承元) |
TextExtent |
TextHeight | テキストの高さをピクセル単位で返します。
TextOut | チャートキャンバスの指定したパラメーターの位置にテキストを出力します。
TextOutDouble |
TextWidth | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate |
Triangle |
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine |

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
DrawStyle |
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
RotationCenterFloat (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
Shininess |
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation | OpenGLキャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元) |
aspect (Graphics3Dの継承元) |
aTextRenderingHint (Graphics3Dの継承元) |
fontCache | フォントの配列を保存します。
fontExtrusion | フォントの深さ値を設定します。
g (Graphics3Dの継承元) |
gradientZ (Graphics3Dの継承元) |
hasClipRegion (Graphics3Dの継承元) |
IActiveBlend |
IAntiAlias |
iCanvasType (Graphics3Dの継承元) |
ifont (Graphics3Dの継承元) |
InternalUse (TeeBaseの継承元) |
IPoints (Graphics3Dの継承元) |
irotationCenter (Graphics3Dの継承元) |
IsOpenGL (Graphics3Dの継承元) |
oldRegion (Graphics3Dの継承元) |
stringFormat (Graphics3Dの継承元) |
Steema.TeeChart.Drawing.TeeBase.Tag |

プロテクト メソッド

CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DeleteFonts | フォントのリストを削除します。フォントの種類を初期化する場合に内部で使用されます。
DisposeObj (Graphics3Dの継承元) |
DoDrawString | XY位置に文字列を描画します。
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText |
InitWindow | TeeChartのOpenGLキャンバスの新しい描画環境を初期化します。
InternalCylinder | 内部使用のみ。
IsRectangle (Graphics3Dの継承元) |
Line | ピクセル位置 x0,y0 から x1,y1 までの線を描画します。
OnInit |
PolygonFour (Graphics3Dの継承元) |
Pop |
Push |
Quadric | Quadricオブジェクトへのハンドル。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetDrawStyle | DrawStyleを設定します。
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetShininess | 内部使用。サーフェスの輝度を設定します。
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

GraphicsGL クラス | Steema.TeeChart.Drawing.GL 名前空間


GraphicsGL コンストラクタ

Steema.TeeChart.Drawing.GL.GraphicsGL コンストラクタ

コンストラクタ

public GraphicsGL(Chart c,
     TeeOpenGL tgl)

パラメータ

c
Chart
tgl
TeeOpenGL

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL コンストラクタ

コンストラクタ
public GraphicsGL(Chart c)

パラメーター

c
Chart
tgl
TeeOpenGL

参照

GraphicsGL コンストラクタのオーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL コンストラクタ

コンストラクタ
public GraphicsGL(Chart c,
     TeeOpenGL tgl)

パラメーター

c
Chart
tgl
TeeOpenGL

参照

GraphicsGL コンストラクタのオーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL イベント

パブリック イベント

Init
Projectioned

参照

GraphicsGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Init

Steema.TeeChart.Drawing.GL.GraphicsGL.Init イベント

public EventHandler  Init

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Projectioned

Steema.TeeChart.Drawing.GL.GraphicsGL.Projectioned イベント

public EventHandler  Projectioned

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL フィールド

パブリック フィールド

FontOutlines | フォントのアウトラインを設定します。
FourPoints (Graphics3Dの継承元) |
g (Graphics3Dの継承元) |
IPointDoubles (Graphics3Dの継承元) |
Monochrome (Graphics3Dの継承元) |

プロテクト フィールド

aSmoothingMode (Graphics3Dの継承元) |
aspect (Graphics3Dの継承元) |
aTextRenderingHint (Graphics3Dの継承元) |
fontCache | フォントの配列を保存します。
fontExtrusion | フォントの深さ値を設定します。
hasClipRegion (Graphics3Dの継承元) |
iCanvasType (Graphics3Dの継承元) |
InternalUse (TeeBaseの継承元) |
IPoints (Graphics3Dの継承元) |
IsOpenGL (Graphics3Dの継承元) |
oldRegion (Graphics3Dの継承元) |
stringFormat (Graphics3Dの継承元) |
Steema.TeeChart.Drawing.TeeBase.Tag |

参照

GraphicsGL クラス | Steema.TeeChart.Drawing.GL 名前空間


fontCache

Steema.TeeChart.Drawing.GL.GraphicsGL.fontCache フィールド

フォントの配列を保存します。

protected internal GLFontCache[] fontCache

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


fontExtrusion

Steema.TeeChart.Drawing.GL.GraphicsGL.fontExtrusion フィールド

フォントの深さの値を設定します。

protected internal Int32 fontExtrusion

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FontOutlines

Steema.TeeChart.Drawing.GL.GraphicsGL.FontOutlines フィールド

フォントのアウトラインを設定します。

public Boolean FontOutlines

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FontStyle

Steema.TeeChart.Drawing.GL.GraphicsGL.FontStyle フィールド

public TeeFontStyle FontStyle

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


IActiveBlend

Steema.TeeChart.Drawing.GL.GraphicsGL.IActiveBlend フィールド

protected internal Boolean IActiveBlend

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


IAntiAlias

Steema.TeeChart.Drawing.GL.GraphicsGL.IAntiAlias フィールド

protected internal Boolean IAntiAlias

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TeeColorPlanes

Steema.TeeChart.Drawing.GL.GraphicsGL.TeeColorPlanes フィールド

public UInt32 TeeColorPlanes

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


UsesStencil

Steema.TeeChart.Drawing.GL.GraphicsGL.UsesStencil フィールド

public Boolean UsesStencil

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL メソッド

パブリック メソッド

ActivateBlend |
Arc | 今回のリリースでは実装されていません。
Arrow | 指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。
Calc3DPoint (Graphics3Dの継承元) |
Calc3DPos | XYZの3D座標のpのXY位置をピクセル単位で計算して返します。
CalcRect3D (Graphics3Dの継承元) | 3D矩形座標の位置をピクセル単位で計算して返します。
Calculate2DPosition (Graphics3Dの継承元) | 座標のXY位置をピクセル単位で計算/返します。
Calculate3DPosition (Graphics3Dの継承元) | XYZの3D座標のXY位置をピクセル単位で計算/返します。
Changed |
ClearClipRegions |
ClipCube (Graphics3Dの継承元) | 立方体のWindows GDIクリッピング領域を作成します。
ClipEllipse | 楕円のWindows GDIクリッピング領域を作成します。
ClipPolygon | 多角形のWindows GDIクリッピング領域を作成します。
ClipRectangle | 矩形のWindows GDIクリッピング領域を作成します。
Cone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
ConvexHull (Graphics3Dの継承元) | 2DのXYポイントの凸面体の境界ポイントを計算します。
Cube | 立方体を描画します。
Cylinder (Graphics3Dの継承元) | 円筒を描画します。Verticalパラメーターで円筒の向きを縦あるいは横に切り替えます。
DisableRotation |
DoProjection |
Draw | このバージョンでは実装されていません。
DrawBeziers | zの変位でのPoint配列pのベジェスプライン曲線を描画します。
DrawPath | GraphicsPathを描きます。
DrawString | 現在の位置に文字列を描画します。
Elevate |
Ellipse |
EllipseEnh | Ellipseを参照してください。
EnableRotation |
EndBlending | ブラシの透明度の重ね合わせ処理を終了します。
EraseBackground | 実装されていません。
FillRectangle | 塗りつぶされた矩形を描画します。
FillRegion | 領域の内側を塗りつぶします。
FindTexture |
FontTextHeight (Graphics3Dの継承元) | キャンバスに出力するテキストのフォントの高さを定義します。
FourPointsFromRect (Graphics3Dの継承元) | Point構造体の配列（要素数4）を返します。
FrontPlaneBegin (Graphics3Dの継承元) |
FrontPlaneEnd (Graphics3Dの継承元) |
GetChartPolygon (Graphics3Dの継承元) | 矩形からZ方向に移動した領域を返します。
GetClipRoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を含んでいるPointDouble配列を返します。
HorizCone (Graphics3Dの継承元) | 円錐を描きます。OPENGL専用で使用してください。
HorizontalLine |
Invalidate (TeeBaseの継承元) | キャンバス全体を再描画する必要がある場合に使用してください。
Line | ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。
LineTo | 現在位置から新しいx,y座標値までの線を描画します。
LineWithZ (Graphics3Dの継承元) |
MeasureString |
MoveTo | LineToメソッドを呼び出す前に、線の描画を開始するxy座標を設定します。
OrientRectangle (Graphics3Dの継承元) | 矩形RのLeftがRightより小さく、TopがBottomより小さいかどうかを確認します。修正された矩形を返します。
PaintBevel (Graphics3Dの継承元) |
PaintImageBevel (Graphics3Dの継承元) | 指定した矩形の周りにカスタムな枠を描画します。
Pie | パイスライスを描画します。
Pixel |
Plane | 平面図形を描画します。
PlaneFour3D (Graphics3Dの継承元) | 4ポイントの多角形を描画します。
PointFromCircle (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された円上にあるPointDoubleを返します。
PointFromEllipse (Graphics3Dの継承元) | 指定した角度とrectBoundsによって渡された楕円上にあるPointDoubleを返します。
PointFromSpiral (Graphics3Dの継承元) |
Polygon |
Polygon3D |
PolygonBounds (Graphics3Dの継承元) | 多角形「p」配列パラメーター内のすべてのポイントの左/上の最小値と右/下の最大値を返します。
PolygonFourDouble (Graphics3Dの継承元) |
PolygonRect (Graphics3Dの継承元) | p配列パラメーターで設定された矩形を返します。
Polyline |
PopMatrix |
PrepareDrawImage |
Projection |
PushMatrix |
Pyramid | 任意で影付きの垂直あるいは水平の四角錐を描きます。
PyramidTrunc |
Rectangle |
RectangleF (Graphics3Dの継承元) |
RectangleWithZ (Graphics3Dの継承元) |
RectangleY |
RectangleZ |
RectFromPolygon (Graphics3Dの継承元) | 指定したXYポイント配列の境界矩形を返します。
RectFromRectZ (Graphics3Dの継承元) | 3D位置を計算した後に「R」矩形の4つの角を含む境界矩形を返します。
Rotate |
RotateLabel |
RoundRectangle (Graphics3Dの継承元) | 角の丸い矩形を描画します。
SetClipRegion |
SetModelView |
SetTextAlign | テキストを揃えます。
ShowImage | イメージを描画します。
Sphere | 球を描画します。
SphereEnh | Sphereを参照してください。
StartBlending | ブラシの透明度の重ね合わせ処理を開始します。
Surface3D | 複数セルのサーフェスを描画します。
TeeCull (Graphics3Dの継承元) |
TextExtent |
TextHeight | テキストの高さをピクセル単位で返します。
TextOut | チャートキャンバスの指定したパラメーターの位置にテキストを出力します。
TextOutDouble |
TextWidth | ChartFont f の水平テキストサイズをピクセル単位で返します。
Translate |
Triangle |
UnClip |
UnClipRectangle (Graphics3Dの継承元) | チャートキャンバスに適用されるクリッピング領域をすべて削除します。
ValidState (Graphics3Dの継承元) | チャートキャンバスが描画できる場合、trueを返します。
VerticalLine | (X,Top) から (X,Bottom) に垂直線を描きます。
ZLine |

プロテクト メソッド

CalcArcAngles (Graphics3Dの継承元) | (x1,y1)から(x4, y4)のポイントを使用してstartAngleとsweepAngleを取得することができます。
CalcArcPoints (Graphics3Dの継承元) | x1,y1, x2,y2, startAngle, sweepAngle を使用して、弧の(x3,y3) と (x4,y4) のポイントを取得することができます。
CorrectAngle (Graphics3Dの継承元) |
CorrectRectangle (Graphics3Dの継承元) |
DeleteFonts | フォントのリストを削除します。フォントの種類を初期化する場合に内部で使用されます。
DisposeObj (Graphics3Dの継承元) |
DoDrawString | XY位置に文字列を描画します。
GetRotationCenter (Graphics3Dの継承元) |
GetSupports3DText |
InitWindow | TeeChartのOpenGLキャンバスの新しい描画環境を初期化します。
InternalCylinder | 内部使用のみ。
IsRectangle (Graphics3Dの継承元) |
Line | ピクセル位置 x0,y0 から x1,y1 までの線を描画します。
OnInit |
PolygonFour (Graphics3Dの継承元) |
Pop |
Push |
Quadric | Quadricオブジェクトへのハンドル。
SetBooleanProperty (TeeBaseの継承元) |
SetChart (TeeBaseの継承元) |
SetColorProperty (TeeBaseの継承元) |
SetDoubleProperty (TeeBaseの継承元) |
SetDrawStyle | DrawStyleを設定します。
SetFloatProperty (TeeBaseの継承元) |
SetIntegerProperty (TeeBaseの継承元) |
SetRotationCenter (Graphics3Dの継承元) |
SetShininess | 内部使用。サーフェスの輝度を設定します。
SetStringProperty (TeeBaseの継承元) |
TransparentEllipse |

参照

GraphicsGL クラス | Steema.TeeChart.Drawing.GL 名前空間


ActivateBlend

Steema.TeeChart.Drawing.GL.GraphicsGL.ActivateBlend メソッド

public Void ActivateBlend(Boolean Value)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Arc

Steema.TeeChart.Drawing.GL.GraphicsGL.Arc メソッド

オーバーロードの一覧

今回のリリースでは実装されていません。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

今回のリリースでは実装されていません。

public override Void Arc(System.Int32, System.Int32, System.Int32, System.Int32, System.Single, System.Single)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Arc

Steema.TeeChart.Drawing.GL.GraphicsGL.Arc メソッド

今回のリリースでは実装されていません。

public override Void Arc(Int32 X1,
     Int32 Y1,
     Int32 X2,
     Int32 Y2,
     Int32 X3,
     Int32 Y3,
     Int32 X4,
     Int32 Y4)

参照

Arc オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Arc

Steema.TeeChart.Drawing.GL.GraphicsGL.Arc メソッド

今回のリリースでは実装されていません。

public override Void Arc(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Single startAngle,
     Single sweepAngle)

参照

Arc オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Arrow

Steema.TeeChart.Drawing.GL.GraphicsGL.Arrow メソッド

指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。

public override Void Arrow(Boolean filled,
     Point fromPoint,
     Point toPoint,
     Int32 headWidth,
     Int32 headHeight,
     Int32 z)

解説

指定されたサイズ（ピクセル単位）の矢印ヘッドの幅と高さを持つ矢印線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Calc3DPos

Steema.TeeChart.Drawing.GL.GraphicsGL.Calc3DPos メソッド

XYZの3D座標のpのXY位置をピクセル単位で計算して返します。

public override Void Calc3DPos(Point& p,
     Int32 x,
     Int32 y,
     Int32 z)

解説

XYZの3D座標のpのXY位置をピクセル単位で計算して返します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ClearClipRegions

Steema.TeeChart.Drawing.GL.GraphicsGL.ClearClipRegions メソッド

public override Void ClearClipRegions()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ClipEllipse

Steema.TeeChart.Drawing.GL.GraphicsGL.ClipEllipse メソッド

楕円のWindows GDIクリッピング領域を作成します。

public override Void ClipEllipse(Rectangle r)

解説

楕円のWindows GDIクリッピング領域を作成します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ClipPolygon

Steema.TeeChart.Drawing.GL.GraphicsGL.ClipPolygon メソッド

多角形のWindows GDIクリッピング領域を作成します。

public override Void ClipPolygon(Point[] p)

解説

多角形のWindows GDIクリッピング領域を作成します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ClipRectangle

Steema.TeeChart.Drawing.GL.GraphicsGL.ClipRectangle メソッド

矩形のWindows GDIクリッピング領域を作成します。

public override Void ClipRectangle(Rectangle r)

解説

矩形のWindows GDIクリッピング領域を作成します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Cube

Steema.TeeChart.Drawing.GL.GraphicsGL.Cube メソッド

立方体を描画します。

public override Void Cube(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

解説

立方体を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Cube

Steema.TeeChart.Drawing.GL.GraphicsGL.Cube メソッド

立方体を描画します。
public Void Cube(Double left,
     Double right,
     Double top,
     Double bottom,
     Double z0,
     Double z1,
     Boolean darkSides)

参照

Cube オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Cube

Steema.TeeChart.Drawing.GL.GraphicsGL.Cube メソッド

立方体を描画します。
public override Void Cube(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

参照

Cube オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DeleteFonts

Steema.TeeChart.Drawing.GL.GraphicsGL.DeleteFonts メソッド

フォントのリストを削除します。フォントの種類を初期化する場合に内部で使用されます。

protected internal Void DeleteFonts()

解説

フォントのリストを削除します。フォントの種類を初期化する場合に内部で使用されます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DisableRotation

Steema.TeeChart.Drawing.GL.GraphicsGL.DisableRotation メソッド

public override Void DisableRotation()

解説

TeeChartのOpenGLキャンバスの回転機能を無効にする際に使用してください。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DoDrawString

Steema.TeeChart.Drawing.GL.GraphicsGL.DoDrawString メソッド

x,y位置に文字列を描画します。

protected abstract Void DoDrawString(Int32 x,
     Int32 y,
     String text,
     ChartBrush aBrush)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DoProjection

Steema.TeeChart.Drawing.GL.GraphicsGL.DoProjection メソッド

オーバーロードの一覧

public Void DoProjection(System.Boolean, System.Int32, System.Int32)
public Void DoProjection()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DoProjection

Steema.TeeChart.Drawing.GL.GraphicsGL.DoProjection メソッド

public Void DoProjection(Boolean DoPick,
     Int32 x,
     Int32 y)

参照

DoProjection オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DoProjection

Steema.TeeChart.Drawing.GL.GraphicsGL.DoProjection メソッド

public Void DoProjection()

参照

DoProjection オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Draw

Steema.TeeChart.Drawing.GL.GraphicsGL.Draw メソッド

オーバーロードの一覧

今回のリリースでは実装されていません。

public override Void Draw(System.Drawing.Rectangle, System.Drawing.Image, System.Boolean)

今回のリリースでは実装されていません。

public override Void Draw(System.Int32, System.Int32, System.Drawing.Image)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Draw

Steema.TeeChart.Drawing.GL.GraphicsGL.Draw メソッド

今回のリリースでは実装されていません。

public override Void Draw(Rectangle r,
     Image image,
     Boolean transparent)

参照

Draw オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Draw

Steema.TeeChart.Drawing.GL.GraphicsGL.Draw メソッド

今回のリリースでは実装されていません。

public override Void Draw(Int32 x,
     Int32 y,
     Image image)

参照

Draw オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DrawBeziers

Steema.TeeChart.Drawing.GL.GraphicsGL.DrawBeziers メソッド

Zの変位でのPoint配列pのベジェスプライン曲線を描画します。

public override Void DrawBeziers(Point[] p)

解説

Zの変位でのPoint配列pのベジェスプライン曲線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DrawPath

Steema.TeeChart.Drawing.GL.GraphicsGL.DrawPath メソッド

GraphicsPathを描きます。
public override Void DrawPath(Pen pen,
     GraphicsPath path)

パラメーター

pen
pathパラメーターの色、幅、スタイルを設定します。
path
描くためのGraphicsPath。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


DrawString

Steema.TeeChart.Drawing.GL.GraphicsGL.DrawString メソッド

現在の位置に文字列を描画します。

public Void DrawString(String s)

解説

現在の位置に文字列を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Elevate

Steema.TeeChart.Drawing.GL.GraphicsGL.Elevate メソッド

public override Void Elevate(Int32 angle)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Ellipse

Steema.TeeChart.Drawing.GL.GraphicsGL.Ellipse メソッド

オーバーロードの一覧

public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32)
public override Void Ellipse(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

解説

(X1, Y1, X2, Y2) の矩形範囲に楕円を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Ellipse

Steema.TeeChart.Drawing.GL.GraphicsGL.Ellipse メソッド

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Ellipse オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Ellipse

Steema.TeeChart.Drawing.GL.GraphicsGL.Ellipse メソッド

public override Void Ellipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

参照

Ellipse オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


EllipseEnh

Steema.TeeChart.Drawing.GL.GraphicsGL.EllipseEnh メソッド

Ellipseを参照してください。
public override Void EllipseEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


EnableRotation

Steema.TeeChart.Drawing.GL.GraphicsGL.EnableRotation メソッド

public override Void EnableRotation()

解説

TeeChartのOpenGLキャンバスの回転機能を有効にします。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


EndBlending

Steema.TeeChart.Drawing.GL.GraphicsGL.EndBlending メソッド

ブラシの透明度の重ね合わせ処理を終了します。

public override Void EndBlending()

解説

ブラシの透明度の重ね合わせ処理を終了します。
透明度の操作を終了します。
Blendパラメータは、Canvas BeginBlending <TTeeCanvas.BeginBlending.html>メソッドの呼出時に取得したTTeeBlendオブジェクトでなければなりません。
このメソッドは、取得したBlendオブジェクトを自動的に解放します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


EraseBackground

Steema.TeeChart.Drawing.GL.GraphicsGL.EraseBackground メソッド

実装されていません。

public override Void EraseBackground(Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FillRectangle

Steema.TeeChart.Drawing.GL.GraphicsGL.FillRectangle メソッド

塗りつぶされた矩形を描画します。

public override Void FillRectangle(Brush brush,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

解説

現在のブラシを使用して塗りつぶした矩形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FillRegion

Steema.TeeChart.Drawing.GL.GraphicsGL.FillRegion メソッド

領域の内側を塗りつぶします。
public override Void FillRegion(Brush brush,
     Region region)

パラメーター

brush
塗りつぶしの特性を定義します。
region
塗りつぶす領域を定義します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FindTexture

Steema.TeeChart.Drawing.GL.GraphicsGL.FindTexture メソッド

public UInt32 FindTexture(Bitmap aBitmap)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


GetSupports3DText

Steema.TeeChart.Drawing.GL.GraphicsGL.GetSupports3DText メソッド

protected abstract Boolean GetSupports3DText()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


HorizontalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.HorizontalLine メソッド

オーバーロードの一覧

public override Void HorizontalLine(System.Int32, System.Int32, System.Int32)
public override Void HorizontalLine(System.Int32, System.Int32, System.Int32, System.Int32)

解説

水平線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


HorizontalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.HorizontalLine メソッド

public override Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y)

解説

(Left,Y) から (Right,Y) までの水平線を描画します。

参照

HorizontalLine オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


HorizontalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.HorizontalLine メソッド

public override Void HorizontalLine(Int32 left,
     Int32 right,
     Int32 y,
     Int32 z)

解説

(Left,Y,Z ) から (Right,Y ,Z ) までの水平線を描画します。

参照

HorizontalLine オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


InitWindow

Steema.TeeChart.Drawing.GL.GraphicsGL.InitWindow メソッド

TeeChartのOpenGLキャンバスの新しい描画環境を初期化します。

protected abstract Void InitWindow(Graphics graphics,
     Aspect a,
     Rectangle r,
     Int32 MaxDepth)

パラメータ

graphics
System.Drawing.Graphics
a
チャートの外観、Steema.TeeChart.Aspect
r
チャートの矩形
MaxDepth
使用されていません。

解説

TeeChartのOpenGLキャンバスの新しい描画環境を初期化します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


InternalCylinder

Steema.TeeChart.Drawing.GL.GraphicsGL.InternalCylinder メソッド

内部使用のみ。

protected abstract Void InternalCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


InternalCylinder

Steema.TeeChart.Drawing.GL.GraphicsGL.InternalCylinder メソッド

内部使用のみ。
protected abstract Void InternalCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent)

参照

InternalCylinder オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


InternalCylinder

Steema.TeeChart.Drawing.GL.GraphicsGL.InternalCylinder メソッド

内部使用のみ。
protected Void InternalCylinder(Boolean vertical,
     Rectangle r,
     Int32 z0,
     Int32 z1,
     Boolean dark3D,
     Int32 conePercent,
     ChartBrush side1,
     ChartBrush side2)

参照

InternalCylinder オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Line

Steema.TeeChart.Drawing.GL.GraphicsGL.Line メソッド

オーバーロードの一覧

ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。

public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。

public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32)

ピクセル位置 x0,y0 から x1,y1 までの線を描画します。

public override Void Line(System.Int32, System.Int32, System.Int32, System.Int32)
protected override Void Line(Steema.TeeChart.Drawing.ChartPen, System.Drawing.Point, System.Drawing.Point)

解説

現在のペンを使用して指定したパラメーターの位置に線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Line

Steema.TeeChart.Drawing.GL.GraphicsGL.Line メソッド

ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。
public override Void Line(Int32 x0,
     Int32 y0,
     Int32 z0,
     Int32 x1,
     Int32 y1,
     Int32 z1)

参照

Line オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Line

Steema.TeeChart.Drawing.GL.GraphicsGL.Line メソッド

ピクセル位置 x0,y0 から x1,y1 までの線をZ深さに描画します。
public override Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1,
     Int32 z)

参照

Line オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Line

Steema.TeeChart.Drawing.GL.GraphicsGL.Line メソッド

ピクセル位置 x0,y0 から x1,y1 までの線を描画します。
public override Void Line(Int32 x0,
     Int32 y0,
     Int32 x1,
     Int32 y1)

参照

Line オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Line

Steema.TeeChart.Drawing.GL.GraphicsGL.Line メソッド

protected override Void Line(ChartPen p,
     Point a,
     Point b)

参照

Line オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


LineTo

Steema.TeeChart.Drawing.GL.GraphicsGL.LineTo メソッド

オーバーロードの一覧

現在位置から新しいx,y座標値までの線を描画します。

public override Void LineTo(System.Int32, System.Int32)

現在位置から新しいx,y,z座標値までの線を描画します。

public override Void LineTo(Steema.TeeChart.Drawing.Point3D)

現在位置から新しいx,y,z座標値までの線を描画します。

public override Void LineTo(System.Int32, System.Int32, System.Int32)

解説

TCanvasと同じです。現在のカーソル位置（例：MoveToを使用して設定）からX,Yまでの線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


LineTo

Steema.TeeChart.Drawing.GL.GraphicsGL.LineTo メソッド

現在位置から新しいx,y座標値までの線を描画します。

public override Void LineTo(Int32 x,
     Int32 y)

参照

LineTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


LineTo

Steema.TeeChart.Drawing.GL.GraphicsGL.LineTo メソッド

現在位置から新しいx,y,z座標値までの線を描画します。
public override Void LineTo(Point3D p)

参照

LineTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


LineTo

Steema.TeeChart.Drawing.GL.GraphicsGL.LineTo メソッド

現在位置から新しいx,y,z座標値までの線を描画します。
public override Void LineTo(Int32 x,
     Int32 y,
     Int32 z)

参照

LineTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MeasureString

Steema.TeeChart.Drawing.GL.GraphicsGL.MeasureString メソッド

public override SizeF MeasureString(ChartFont f,
     String text)

解説

指定したフォントの文字列のSizeFを返します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MoveTo

Steema.TeeChart.Drawing.GL.GraphicsGL.MoveTo メソッド

オーバーロードの一覧

LineToメソッドを呼び出す前に、線の描画を開始するxy座標を設定します。

public override Void MoveTo(System.Int32, System.Int32)

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。

public override Void MoveTo(Steema.TeeChart.Drawing.Point3D)

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。

public override Void MoveTo(System.Int32, System.Int32, System.Int32)

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。

public override Void MoveTo(System.Drawing.Point, System.Int32)

解説

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MoveTo

Steema.TeeChart.Drawing.GL.GraphicsGL.MoveTo メソッド

LineToメソッドを呼び出す前に、線の描画を開始するxy座標を設定します。

public override Void MoveTo(Int32 x,
     Int32 y)

参照

MoveTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MoveTo

Steema.TeeChart.Drawing.GL.GraphicsGL.MoveTo メソッド

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。
public override Void MoveTo(Point3D p)

参照

MoveTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MoveTo

Steema.TeeChart.Drawing.GL.GraphicsGL.MoveTo メソッド

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。
public override Void MoveTo(Int32 x,
     Int32 y,
     Int32 z)

参照

MoveTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


MoveTo

Steema.TeeChart.Drawing.GL.GraphicsGL.MoveTo メソッド

LineToメソッドを呼び出す前に、線の描画を開始するxyz座標を設定します。
public override Void MoveTo(Point p,
     Int32 z)

参照

MoveTo オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


OnInit

Steema.TeeChart.Drawing.GL.GraphicsGL.OnInit メソッド

protected abstract Void OnInit()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pie

Steema.TeeChart.Drawing.GL.GraphicsGL.Pie メソッド

オーバーロードの一覧

パイスライスを描画します。

public override Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double, System.Boolean, System.Boolean, System.Int32, System.Int32, Steema.TeeChart.Drawing.EdgeStyles)
public override Void Pie(System.Int32, System.Int32, System.Int32, System.Int32, System.Double, System.Double)

解説

イメージにパイスライスを描画します。パイスライスはポイント (X1, Y1) と (X2, Y2) で定義された矩形範囲の楕円と、楕円の中心からポイント(X3, Y3)と(X4, Y4)までの2つの線で定義されます。

パイスライスの枠はPenを使用して描画され、Brushを使用して塗りつぶされます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pie

Steema.TeeChart.Drawing.GL.GraphicsGL.Pie メソッド

パイスライスを描画します。
public override Void Pie(Int32 xCenter,
     Int32 yCenter,
     Int32 xOffset,
     Int32 yOffset,
     Int32 xRadius,
     Int32 yRadius,
     Int32 z0,
     Int32 z1,
     Double startAngle,
     Double endAngle,
     Boolean darkSides,
     Boolean drawSides,
     Int32 donutPercent,
     Int32 bevelPercent,
     EdgeStyles edgeStyle)

パラメーター

xCenter
パイスライスのx方向の中心（ピクセル単位）
yCenter
パイスライスのy方向の中心（ピクセル単位）
xRadius
パイスライスのx方向の半径（ピクセル単位）
yRadius
パイスライスのy方向の半径（ピクセル単位）
z0
前面の深さ（ピクセル単位）
z1
背面の深さ（ピクセル単位）
startAngle
分離するパイスライスの開始角度
endAngle
分離するパイスライスの終了角度
darkSides
3Dのパイスライスの影
drawSides
3Dのパイスライスの側面
donutPercent
穴の大きさ

参照

Pie オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pie

Steema.TeeChart.Drawing.GL.GraphicsGL.Pie メソッド

public override Void Pie(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Double startAngle,
     Double endAngle)

参照

Pie オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pixel

Steema.TeeChart.Drawing.GL.GraphicsGL.Pixel メソッド

public override Void Pixel(Int32 x,
     Int32 y,
     Int32 z,
     Color color)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Plane

Steema.TeeChart.Drawing.GL.GraphicsGL.Plane メソッド

オーバーロードの一覧

Z深さオフセットに多角形(Point p1, Point p2)を描画します。

public override Void Plane(System.Drawing.Point, System.Drawing.Point, System.Int32, System.Int32)

平面図形を描画します。

public override Void Plane(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

解説

Z深さオフセットに多角形(Point p1, Point p2)を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Plane

Steema.TeeChart.Drawing.GL.GraphicsGL.Plane メソッド

Z深さオフセットに多角形（Point p1, Point p2）を描画します。

public override Void Plane(Point p1,
     Point p2,
     Int32 z0,
     Int32 z1)

参照

Plane オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Plane

Steema.TeeChart.Drawing.GL.GraphicsGL.Plane メソッド

平面図形を描画します。

public override Void Plane(Point p1,
     Point p2,
     Point p3,
     Point p4,
     Int32 z)

参照

Plane オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon メソッド

オーバーロードの一覧

public override Void Polygon(Steema.TeeChart.Drawing.Point3D[])
public override Void Polygon(System.Drawing.Point[])
public override Void Polygon(System.Int32, System.Drawing.Point[])
public override Void Polygon(Steema.TeeChart.Drawing.PointDouble[])

解説

多角形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon メソッド

public override Void Polygon(Point3D[] p)

参照

Polygon オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon メソッド

public override Void Polygon(Point[] p)

参照

Polygon オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon メソッド

public override Void Polygon(Int32 z,
     Point[] p)

参照

Polygon オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon メソッド

public override Void Polygon(PointDouble[] p)

参照

Polygon オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polygon3D

Steema.TeeChart.Drawing.GL.GraphicsGL.Polygon3D メソッド

public Void Polygon3D(Point3D[] p)

解説

Zの変位でのTPoints (X,Y) 配列の多角形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polyline

Steema.TeeChart.Drawing.GL.GraphicsGL.Polyline メソッド

オーバーロードの一覧

public override Void Polyline(System.Drawing.Point[])
public override Void Polyline(System.Int32, System.Drawing.Point[])

解説

Pointパラメーターのすべてのポイントに接合する線を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polyline

Steema.TeeChart.Drawing.GL.GraphicsGL.Polyline メソッド

public override Void Polyline(Point[] p)

参照

Polyline オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Polyline

Steema.TeeChart.Drawing.GL.GraphicsGL.Polyline メソッド

public override Void Polyline(Int32 z,
     Point[] p)

参照

Polyline オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pop

Steema.TeeChart.Drawing.GL.GraphicsGL.Pop メソッド

protected abstract Void Pop()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


PopMatrix

Steema.TeeChart.Drawing.GL.GraphicsGL.PopMatrix メソッド

public override Void PopMatrix()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


PrepareDrawImage

Steema.TeeChart.Drawing.GL.GraphicsGL.PrepareDrawImage メソッド

public override Void PrepareDrawImage()

解説

描画のためのチャートキャンバスを用意します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Projection

Steema.TeeChart.Drawing.GL.GraphicsGL.Projection メソッド

public override Void Projection(Int32 maxDepth,
     Rectangle r)

解説

描画および表示するための矩形座標を指定して、キャンバスを初期化するために内部的に使用されます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Push

Steema.TeeChart.Drawing.GL.GraphicsGL.Push メソッド

protected abstract Void Push()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


PushMatrix

Steema.TeeChart.Drawing.GL.GraphicsGL.PushMatrix メソッド

public override Void PushMatrix()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Pyramid

Steema.TeeChart.Drawing.GL.GraphicsGL.Pyramid メソッド

任意で影付きの垂直あるいは水平の四角錐を描画します。

public override Void Pyramid(Boolean vertical,
     Int32 left,
     Int32 top,
     Int32 right,
     Int32 bottom,
     Int32 z0,
     Int32 z1,
     Boolean darkSides)

解説

任意で影付きの垂直あるいは水平の四角錐を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


PyramidTrunc

Steema.TeeChart.Drawing.GL.GraphicsGL.PyramidTrunc メソッド

public override Void PyramidTrunc(Rectangle r,
     Int32 startZ,
     Int32 endZ,
     Int32 truncX,
     Int32 truncZ)

解説

角錐台を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Quadric

Steema.TeeChart.Drawing.GL.GraphicsGL.Quadric メソッド

Quadricオブジェクトへのハンドル。

protected IntPtr Quadric()

解説

Quadricオブジェクトへのハンドル。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Rectangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Rectangle メソッド

オーバーロードの一覧

public override Void Rectangle(System.Drawing.Rectangle)
public override Void Rectangle(System.Drawing.Rectangle, System.Int32)

解説

矩形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Rectangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Rectangle メソッド

public override Void Rectangle(Rectangle r)

参照

Rectangle オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Rectangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Rectangle メソッド

public override Void Rectangle(Rectangle r,
     Int32 z)

参照

Rectangle オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


RectangleY

Steema.TeeChart.Drawing.GL.GraphicsGL.RectangleY メソッド

public override Void RectangleY(Int32 left,
     Int32 top,
     Int32 right,
     Int32 z0,
     Int32 z1)

解説

指定したパラメータの位置に水平の矩形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


RectangleZ

Steema.TeeChart.Drawing.GL.GraphicsGL.RectangleZ メソッド

public override Void RectangleZ(Int32 left,
     Int32 top,
     Int32 bottom,
     Int32 z0,
     Int32 z1)

解説

指定したパラメータの位置に垂直の矩形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Rotate

Steema.TeeChart.Drawing.GL.GraphicsGL.Rotate メソッド

public override Void Rotate(Int32 angle)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


RotateLabel

Steema.TeeChart.Drawing.GL.GraphicsGL.RotateLabel メソッド

オーバーロードの一覧

public override Void RotateLabel(System.Int32, System.Int32, System.String, System.Double)
public override Void RotateLabel(System.Int32, System.Int32, System.Int32, System.String, System.Double)

解説

指定したxyz座標にRotDegreeの回転角度で回転させたテキストを出力します。RotDegreeの値は0から360の間でなければなりません。文字列はチャートの描画キャンバスに出力されます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


RotateLabel

Steema.TeeChart.Drawing.GL.GraphicsGL.RotateLabel メソッド

public override Void RotateLabel(Int32 x,
     Int32 y,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


RotateLabel

Steema.TeeChart.Drawing.GL.GraphicsGL.RotateLabel メソッド

public override Void RotateLabel(Int32 x,
     Int32 y,
     Int32 z,
     String text,
     Double rotDegree)

参照

RotateLabel オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetClipRegion

Steema.TeeChart.Drawing.GL.GraphicsGL.SetClipRegion メソッド

public override Void SetClipRegion(Region region)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetDrawStyle

Steema.TeeChart.Drawing.GL.GraphicsGL.SetDrawStyle メソッド

DrawStyleを設定します。

protected internal Void SetDrawStyle(SurfaceStyle csStyle)

パラメータ

csStyle

解説

DrawStyleを設定します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間 | SurfaceStyle


SetModelView

Steema.TeeChart.Drawing.GL.GraphicsGL.SetModelView メソッド

public Void SetModelView()

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetShininess

Steema.TeeChart.Drawing.GL.GraphicsGL.SetShininess メソッド

内部使用。サーフェスの輝度を設定します。

protected internal Void SetShininess(Double value)

パラメーター

value

解説

内部使用。サーフェスの輝度を設定します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetTextAlign

Steema.TeeChart.Drawing.GL.GraphicsGL.SetTextAlign メソッド

テキストを揃えます。

public override Void SetTextAlign(StringAlignment a)

パラメーター

a
System.Drawing.StringAlignment

解説

テキストを揃えます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ShowImage

Steema.TeeChart.Drawing.GL.GraphicsGL.ShowImage メソッド

イメージを描画します。

protected abstract Void ShowImage(Graphics g)

解説

イメージを描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Sphere

Steema.TeeChart.Drawing.GL.GraphicsGL.Sphere メソッド

球を描画します。

public override Void Sphere(Int32 x,
     Int32 y,
     Int32 z,
     Double radius)

解説

3Dの球を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SphereEnh

Steema.TeeChart.Drawing.GL.GraphicsGL.SphereEnh メソッド

球を描画します。

public override Void SphereEnh(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2,
     Int32 z)

解説

球を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


StartBlending

Steema.TeeChart.Drawing.GL.GraphicsGL.StartBlending メソッド

ブラシの透明度の重ね合わせ処理を開始します。

public override Void StartBlending(Double transparency)

パラメーター

transparency

解説

重ね合わせ（透明度）処理用のキャンバスを開始します。
矩形Rは2Dの透明領域を定義し、Transparencyパラメーターは透明度を定義します。
このメソッドは、EndBlendingメソッドに渡されなければならないTTeeBlendオブジェクトのインスタンスを返します。
EndBlendingメソッドは、テンポラリの重ね合わせオブジェクトを自動的に解放します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Surface3D

Steema.TeeChart.Drawing.GL.GraphicsGL.Surface3D メソッド

複数セルのサーフェスを描画します。

public override Void Surface3D(SurfaceStyle style,
     Boolean sameBrush,
     Int32 numXValues,
     Int32 numZValues,
     Surface surface)

解説

サーフェスを描画するための内部メソッドです。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextExtent

Steema.TeeChart.Drawing.GL.GraphicsGL.TextExtent メソッド

public SIZE TextExtent(String text)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextHeight

Steema.TeeChart.Drawing.GL.GraphicsGL.TextHeight メソッド

オーバーロードの一覧

テキストの高さをピクセル単位で返します。

public override Single TextHeight(System.String)
public override Single TextHeight(Steema.TeeChart.Drawing.ChartFont, System.String)

解説

イメージ内のテキストの高さを定義します。線、ボックス、追加されるテキスト行などイメージ以外のエレメントはテキストの高さに応じて配置できます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextHeight

Steema.TeeChart.Drawing.GL.GraphicsGL.TextHeight メソッド

テキストの高さをピクセル単位で返します。

public override Single TextHeight(String text)

戻り値

ピクセル単位のテキストの高さ

参照

TextHeight オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextHeight

Steema.TeeChart.Drawing.GL.GraphicsGL.TextHeight メソッド

public override Single TextHeight(ChartFont f,
     String text)

参照

TextHeight オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextOut

Steema.TeeChart.Drawing.GL.GraphicsGL.TextOut メソッド

オーバーロードの一覧

チャートキャンバスのZ深さの位置にテキストを出力します。

public override Void TextOut(System.Int32, System.Int32, System.Int32, System.String)

チャートキャンバスにテキストを出力します。

public override Void TextOut(System.Int32, System.Int32, System.String)

解説

TextAlignプロパティに応じてXYZ位置に2Dの回転なしのテキストを出力します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextOut

Steema.TeeChart.Drawing.GL.GraphicsGL.TextOut メソッド

チャートキャンバスのZ深さの位置にテキストを出力します。

public override Void TextOut(Int32 x,
     Int32 y,
     Int32 z,
     String text)

パラメーター

x
xピクセル位置
y
yピクセル位置
z
z深さのピクセル位置
text
テキスト

参照

TextOut オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextOut

Steema.TeeChart.Drawing.GL.GraphicsGL.TextOut メソッド

チャートキャンバスにテキストを出力します。

public override Void TextOut(Int32 x,
     Int32 y,
     String text)

パラメーター

x
xピクセル位置
y
yピクセル位置
text
テキスト

参照

TextOut オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextOutDouble

Steema.TeeChart.Drawing.GL.GraphicsGL.TextOutDouble メソッド

public Void TextOutDouble(Double x,
     Double y,
     Double z,
     String text)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TextWidth

Steema.TeeChart.Drawing.GL.GraphicsGL.TextWidth メソッド

ChartFont f のテキストの水平サイズをピクセル単位で返します。

public override Single TextWidth(String text)

解説

イメージ内で使用するテキストの幅を定義します。このメソッドは、指定したテキストが使用したい領域に収まるかどうかを表します。線、追加テキストなどイメージ以外のエレメントはテキストの幅に応じて配置できます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Translate

Steema.TeeChart.Drawing.GL.GraphicsGL.Translate メソッド

public override Void Translate(Int32 x,
     Int32 y,
     Int32 z)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TransparentEllipse

Steema.TeeChart.Drawing.GL.GraphicsGL.TransparentEllipse メソッド

protected abstract Void TransparentEllipse(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Triangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Triangle メソッド

オーバーロードの一覧

public override Void Triangle(Steema.TeeChart.Drawing.Triangle3D)
public override Void Triangle(System.Drawing.Point, System.Drawing.Point, System.Drawing.Point, System.Int32)

解説

三角形を描画します。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Triangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Triangle メソッド

public override Void Triangle(Triangle3D p)

解説

XYZポイント座標と色（三角形の各ポイントに1色ずつ）を使用して三角形を描画します。

参照

Triangle オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Triangle

Steema.TeeChart.Drawing.GL.GraphicsGL.Triangle メソッド

public override Void Triangle(Point p0,
     Point p1,
     Point p2,
     Int32 z)

解説

XYZポイント座標と色（三角形の各ポイントに1色ずつ）を使用して三角形を描画します。

参照

Triangle オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


UnClip

Steema.TeeChart.Drawing.GL.GraphicsGL.UnClip メソッド

public override Void UnClip()

解説

チャートキャンバスに適用されるクリッピング領域をすべて削除します。クリッピング領域は、矩形の座標外に描画しないために使用されます。これは、マーカや系列ポイントをChartRectの矩形外に表示しないように内部で使用されます。

メモ：メタファイルはクリッピング領域を適用しません。メタファイル形式は、印刷の際に使用されるのでクリッピングは実行されません。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


VerticalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.VerticalLine メソッド

オーバーロードの一覧

(X,Top) から (X,Bottom) に垂直線を描きます。

public override Void VerticalLine(System.Int32, System.Int32, System.Int32)
public override Void VerticalLine(System.Int32, System.Int32, System.Int32, System.Int32)

解説

(X,Top) から (X,Bottom) に垂直線を描きます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


VerticalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.VerticalLine メソッド

(X,Top) から (X,Bottom) に垂直線を描きます。

public override Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom)

参照

VerticalLine オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


VerticalLine

Steema.TeeChart.Drawing.GL.GraphicsGL.VerticalLine メソッド

public override Void VerticalLine(Int32 x,
     Int32 top,
     Int32 bottom,
     Int32 z)

参照

VerticalLine オーバーロードの一覧 | GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ZLine

Steema.TeeChart.Drawing.GL.GraphicsGL.ZLine メソッド

public override Void ZLine(Int32 x,
     Int32 y,
     Int32 z0,
     Int32 z1)

解説

(X,Y,Z0) から (X,Y,Z1)に線を描きます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.GraphicsGL プロパティ

パブリック プロパティ

BackColor (Graphics3Dの継承元) | テキストの表示、またはスタイルがSolid以外のブラシを使用した塗りつぶしの色を取得/設定します。
Brush (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすブラシの種類を定義します。
CanvasType (Graphics3Dの継承元) | チャートを描くために使用するキャンバスのタイプを取得します。
Chart (TeeBaseの継承元) | オブジェクトに関連付けるチャートを設定します。
ChartXCenter (Graphics3Dの継承元) | チャートの水平方向に対する中央の座標値を返します。
ChartYCenter (Graphics3Dの継承元) | チャートの垂直方向に対する中央の座標値を返します。
Font (Graphics3Dの継承元) | テキストの出力に使用されるフォント属性を定義します。
FontHeight (Graphics3Dの継承元) | ピクセル単位でフォントの高さを定義します。
Gradient (Graphics3Dの継承元) | キャンバスの矩形背景を塗りつぶすグラデーションを定義します。
Pen (Graphics3Dの継承元) | キャンバスに線を描くペンの種類を取得/設定します。
RotationCenter (Graphics3Dの継承元) | Aspect.Rotationプロパティとの使用により、回転の中央のピクセル位置（X、Y、Zを使用）を設定します。
SmoothingMode (Graphics3Dの継承元) | スムーシング（アンチエイリアシング）モード。
Supports3DText (Graphics3Dの継承元) | キャンバスが3Dテキストをサポートするかどうかを返します。
SupportsFullRotation | OpenGLキャンバスが90度以上の回転や仰角が実行可能かどうかを返します。
TextAlign (Graphics3Dの継承元) | TextOutメソッドあるいはTextOut3Dメソッドを使用してテキストを表示した時の、テキストの整列を設定します。
TextRenderingHint (Graphics3Dの継承元) | テキストを作成するための、スピードあるいは描画品質を選択します。
UseBuffer (Graphics3Dの継承元) | 画面のチラツキを防ぐために内部キャンバスにアイテムを描画します。
XCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のX座標をピクセル単位で取得/設定します。
YCenter (Graphics3Dの継承元) | 3Dキャンバスの中央のY座標をピクセル単位で取得/設定します。

参照

GraphicsGL クラス | Steema.TeeChart.Drawing.GL 名前空間


DrawStyle

Steema.TeeChart.Drawing.GL.GraphicsGL.DrawStyle プロパティ

public SurfaceStyle DrawStyle {get; set;}

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Shininess

Steema.TeeChart.Drawing.GL.GraphicsGL.Shininess プロパティ

public Double Shininess {get; set;}

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SupportsFullRotation

Steema.TeeChart.Drawing.GL.GraphicsGL.SupportsFullRotation プロパティ

OpenGLキャンバスは90度以上の回転や仰角を行えます。

public override Boolean SupportsFullRotation {get;}

解説

キャンバスが360度回転、仰角、傾斜が行えるかどうかを返します。
現在、OpenGLキャンバスのみ360度の回転が行えます。

参照

GraphicsGL クラス | GraphicsGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports

Steema.TeeChart.Drawing.GL.Imports クラス

外部の宣言を使用してWindowsライブラリにアクセスします。

この型のすべてのメンバの一覧については、Imports メンバを参照してください。

System.Object
public class Imports : Object

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports 全メンバ

Imports 概要

コンストラクタ

Constructor

パブリック フィールド

ACCUM_ALPHA_BITS
ACCUM_BLUE_BITS
ACCUM_BUFFER_BIT
ACCUM_CLEAR_VALUE
ACCUM_GREEN_BITS
ACCUM_RED_BITS
ALL_ATTRIB_BITS
ALPHA
ALPHA_BIAS
ALPHA_BITS
ALPHA_SCALE
ALPHA_TEST
ALPHA_TEST_FUNC
ALPHA_TEST_REF
ALPHA12
ALPHA16
ALPHA4
ALPHA8
ALWAYS
AMBIENT
AMBIENT_AND_DIFFUSE
AND
AND_INVERTED
AND_REVERSE
ATTRIB_STACK_DEPTH
AUTO_NORMAL
AUX_BUFFERS
AUX0
AUX1
AUX2
AUX3
BACK
BACK_LEFT
BACK_RIGHT
BGR_EXT
BGRA_EXT
BITMAP
BITMAP_TOKEN
BLEND
BLEND_DST
BLEND_SRC
BLUE
BLUE_BIAS
BLUE_BITS
BLUE_SCALE
BYTE
C3F_V3F
C4F_N3F_V3F
C4UB_V2F
C4UB_V3F
CCW
CLAMP
CLEAR
CLIENT_ALL_ATTRIB_BITS
CLIENT_ATTRIB_STACK_DEPTH
CLIENT_PIXEL_STORE_BIT
CLIENT_VERTEX_ARRAY_BIT
CLIP_PLANE0
CLIP_PLANE1
CLIP_PLANE2
CLIP_PLANE3
CLIP_PLANE4
CLIP_PLANE5
COEFF
COLOR
COLOR_ARRAY
COLOR_ARRAY_COUNT_EXT
COLOR_ARRAY_EXT
COLOR_ARRAY_POINTER
COLOR_ARRAY_POINTER_EXT
COLOR_ARRAY_SIZE
COLOR_ARRAY_SIZE_EXT
COLOR_ARRAY_STRIDE
COLOR_ARRAY_STRIDE_EXT
COLOR_ARRAY_TYPE
COLOR_ARRAY_TYPE_EXT
COLOR_BUFFER_BIT
COLOR_CLEAR_VALUE
COLOR_INDEX
COLOR_INDEX1_EXT
COLOR_INDEX12_EXT
COLOR_INDEX16_EXT
COLOR_INDEX2_EXT
COLOR_INDEX4_EXT
COLOR_INDEX8_EXT
COLOR_INDEXES
COLOR_LOGIC_OP
COLOR_MATERIAL
COLOR_MATERIAL_FACE
COLOR_MATERIAL_PARAMETER
COLOR_TABLE_ALPHA_SIZE_EXT
COLOR_TABLE_BLUE_SIZE_EXT
COLOR_TABLE_FORMAT_EXT
COLOR_TABLE_GREEN_SIZE_EXT
COLOR_TABLE_INTENSITY_SIZE_EXT
COLOR_TABLE_LUMINANCE_SIZE_EXT
COLOR_TABLE_RED_SIZE_EXT
COLOR_TABLE_WIDTH_EXT
COLOR_WRITEMASK
COMPILE
COMPILE_AND_EXECUTE
CONSTANT_ATTENUATION
COPY
COPY_INVERTED
COPY_PIXEL_TOKEN
CULL_FACE
CULL_FACE_MODE
CURRENT_BIT
CURRENT_COLOR
CURRENT_INDEX
CURRENT_NORMAL
CURRENT_RASTER_COLOR
CURRENT_RASTER_DISTANCE
CURRENT_RASTER_INDEX
CURRENT_RASTER_POSITION
CURRENT_RASTER_POSITION_VALID
CURRENT_RASTER_TEXTURE_COORDS
CURRENT_TEXTURE_COORDS
CW
DECAL
DECR
DEPTH
DEPTH_BIAS
DEPTH_BITS
DEPTH_BUFFER_BIT
DEPTH_CLEAR_VALUE
DEPTH_COMPONENT
DEPTH_FUNC
DEPTH_RANGE
DEPTH_SCALE
DEPTH_TEST
DEPTH_WRITEMASK
DIFFUSE
DITHER
DOMAIN
DONT_CARE
DOUBLE
DOUBLE_EXT
DOUBLEBUFFER
DRAW_BUFFER
DRAW_PIXEL_TOKEN
DST_ALPHA
DST_COLOR
EDGE_FLAG
EDGE_FLAG_ARRAY
EDGE_FLAG_ARRAY_COUNT_EXT
EDGE_FLAG_ARRAY_EXT
EDGE_FLAG_ARRAY_POINTER
EDGE_FLAG_ARRAY_POINTER_EXT
EDGE_FLAG_ARRAY_STRIDE
EDGE_FLAG_ARRAY_STRIDE_EXT
EMISSION
ENABLE_BIT
EQUAL
EQUIV
EVAL_BIT
EXP
EXP2
EXT_bgra
EXT_paletted_texture
EXT_vertex_array
EXTENSIONS
EYE_LINEAR
EYE_PLANE
FALSE
FASTEST
FEEDBACK
FEEDBACK_BUFFER_POINTER
FEEDBACK_BUFFER_SIZE
FEEDBACK_BUFFER_TYPE
FILL
FLAT
FLOAT
FOG
FOG_BIT
FOG_COLOR
FOG_DENSITY
FOG_END
FOG_HINT
FOG_INDEX
FOG_MODE
FOG_START
FRONT
FRONT_AND_BACK
FRONT_FACE
FRONT_LEFT
FRONT_RIGHT
GEQUAL
GL_2_BYTES
GL_2D
GL_3_BYTES
GL_3D
GL_3D_COLOR_TEXTURE
GL_4_BYTES
GL_4D_COLOR
GL_4D_COLOR_TEXTURE
GLU_AUTO_LOAD_MATRIX
GLU_CULLING
GLU_DISPLAY_MODE
GLU_DOMAIN_DISTANCE
GLU_EXTENSIONS
GLU_FALSE
GLU_FILL
GLU_FLAT
GLU_INCOMPATIBLE_GL_VERSION
GLU_INSIDE
GLU_INVALID_ENUM
GLU_INVALID_VALUE
GLU_LINE
GLU_MAP1_TRIM_2
GLU_MAP1_TRIM_3
GLU_NONE
GLU_NURBS_ERROR1
GLU_NURBS_ERROR10
GLU_NURBS_ERROR11
GLU_NURBS_ERROR12
GLU_NURBS_ERROR13
GLU_NURBS_ERROR14
GLU_NURBS_ERROR15
GLU_NURBS_ERROR16
GLU_NURBS_ERROR17
GLU_NURBS_ERROR18
GLU_NURBS_ERROR19
GLU_NURBS_ERROR2
GLU_NURBS_ERROR20
GLU_NURBS_ERROR21
GLU_NURBS_ERROR22
GLU_NURBS_ERROR23
GLU_NURBS_ERROR24
GLU_NURBS_ERROR25
GLU_NURBS_ERROR26
GLU_NURBS_ERROR27
GLU_NURBS_ERROR28
GLU_NURBS_ERROR29
GLU_NURBS_ERROR3
GLU_NURBS_ERROR30
GLU_NURBS_ERROR31
GLU_NURBS_ERROR32
GLU_NURBS_ERROR33
GLU_NURBS_ERROR34
GLU_NURBS_ERROR35
GLU_NURBS_ERROR36
GLU_NURBS_ERROR37
GLU_NURBS_ERROR4
GLU_NURBS_ERROR5
GLU_NURBS_ERROR6
GLU_NURBS_ERROR7
GLU_NURBS_ERROR8
GLU_NURBS_ERROR9
GLU_OUT_OF_MEMORY
GLU_OUTLINE_PATCH
GLU_OUTLINE_POLYGON
GLU_OUTSIDE
GLU_PARAMETRIC_ERROR
GLU_PARAMETRIC_TOLERANCE
GLU_PATH_LENGTH
GLU_POINT
GLU_SAMPLING_METHOD
GLU_SAMPLING_TOLERANCE
GLU_SILHOUETTE
GLU_SMOOTH
GLU_TESS_BEGIN
GLU_TESS_BEGIN_DATA
GLU_TESS_BOUNDARY_ONLY
GLU_TESS_COMBINE
GLU_TESS_COMBINE_DATA
GLU_TESS_COORD_TOO_LARGE
GLU_TESS_EDGE_FLAG
GLU_TESS_EDGE_FLAG_DATA
GLU_TESS_END
GLU_TESS_END_DATA
GLU_TESS_ERROR
GLU_TESS_ERROR_DATA
GLU_TESS_ERROR1
GLU_TESS_ERROR2
GLU_TESS_ERROR3
GLU_TESS_ERROR4
GLU_TESS_ERROR5
GLU_TESS_ERROR6
GLU_TESS_ERROR7
GLU_TESS_ERROR8
GLU_TESS_MAX_COORD
GLU_TESS_MISSING_BEGIN_CONTOUR
GLU_TESS_MISSING_BEGIN_POLYGON
GLU_TESS_MISSING_END_CONTOUR
GLU_TESS_MISSING_END_POLYGON
GLU_TESS_NEED_COMBINE_CALLBACK
GLU_TESS_TOLERANCE
GLU_TESS_VERTEX
GLU_TESS_VERTEX_DATA
GLU_TESS_WINDING_ABS_GEQ_TWO
GLU_TESS_WINDING_NEGATIVE
GLU_TESS_WINDING_NONZERO
GLU_TESS_WINDING_ODD
GLU_TESS_WINDING_POSITIVE
GLU_TESS_WINDING_RULE
GLU_TRUE
GLU_U_STEP
GLU_V_STEP
GLU_VERSION
GLU_VERSION_1_1
GLU_VERSION_1_2
GREATER
GREEN
GREEN_BIAS
GREEN_BITS
GREEN_SCALE
HINT_BIT
INCR
INDEX_ARRAY
INDEX_ARRAY_COUNT_EXT
INDEX_ARRAY_EXT
INDEX_ARRAY_POINTER
INDEX_ARRAY_POINTER_EXT
INDEX_ARRAY_STRIDE
INDEX_ARRAY_STRIDE_EXT
INDEX_ARRAY_TYPE
INDEX_ARRAY_TYPE_EXT
INDEX_BITS
INDEX_CLEAR_VALUE
INDEX_LOGIC_OP
INDEX_MODE
INDEX_OFFSET
INDEX_SHIFT
INDEX_WRITEMASK
INT
INTENSITY
INTENSITY12
INTENSITY16
INTENSITY4
INTENSITY8
INVALID_ENUM
INVALID_OPERATION
INVALID_VALUE
INVERT
KEEP
LEFT
LEQUAL
LESS
LIBRARY_GDI
LIBRARY_GLU
LIBRARY_KERNEL
LIBRARY_OPENGL
LIBRARY_USER
LIGHT_MODEL_AMBIENT
LIGHT_MODEL_LOCAL_VIEWER
LIGHT_MODEL_TWO_SIDE
LIGHT0
LIGHT1
LIGHT2
LIGHT3
LIGHT4
LIGHT5
LIGHT6
LIGHT7
LIGHTING
LIGHTING_BIT
LINE
LINE_BIT
LINE_LOOP
LINE_RESET_TOKEN
LINE_SMOOTH
LINE_SMOOTH_HINT
LINE_STIPPLE
LINE_STIPPLE_PATTERN
LINE_STIPPLE_REPEAT
LINE_STRIP
LINE_TOKEN
LINE_WIDTH
LINE_WIDTH_GRANULARITY
LINE_WIDTH_RANGE
LINEAR
LINEAR_ATTENUATION
LINEAR_MIPMAP_LINEAR
LINEAR_MIPMAP_NEAREST
LINES
LIST_BASE
LIST_BIT
LIST_INDEX
LIST_MODE
LOGIC_OP_MODE
LUMINANCE
LUMINANCE_ALPHA
LUMINANCE12
LUMINANCE12_ALPHA12
LUMINANCE12_ALPHA4
LUMINANCE16
LUMINANCE16_ALPHA16
LUMINANCE4
LUMINANCE4_ALPHA4
LUMINANCE6_ALPHA2
LUMINANCE8
LUMINANCE8_ALPHA8
MAP_COLOR
MAP_STENCIL
MAP1_COLOR_4
MAP1_GRID_DOMAIN
MAP1_GRID_SEGMENTS
MAP1_INDEX
MAP1_NORMAL
MAP1_TEXTURE_COORD_1
MAP1_TEXTURE_COORD_2
MAP1_TEXTURE_COORD_3
MAP1_TEXTURE_COORD_4
MAP1_VERTEX_3
MAP1_VERTEX_4
MAP2_COLOR_4
MAP2_GRID_DOMAIN
MAP2_GRID_SEGMENTS
MAP2_INDEX
MAP2_NORMAL
MAP2_TEXTURE_COORD_1
MAP2_TEXTURE_COORD_2
MAP2_TEXTURE_COORD_3
MAP2_TEXTURE_COORD_4
MAP2_VERTEX_3
MAP2_VERTEX_4
MATRIX_MODE
MAX_ATTRIB_STACK_DEPTH
MAX_CLIENT_ATTRIB_STACK_DEPTH
MAX_CLIP_PLANES
MAX_ELEMENTS_INDICES_WIN
MAX_ELEMENTS_VERTICES_WIN
MAX_EVAL_ORDER
MAX_LIGHTS
MAX_LIST_NESTING
MAX_MODELVIEW_STACK_DEPTH
MAX_NAME_STACK_DEPTH
MAX_PIXEL_MAP_TABLE
MAX_PROJECTION_STACK_DEPTH
MAX_TEXTURE_SIZE
MAX_TEXTURE_STACK_DEPTH
MAX_VIEWPORT_DIMS
MODELVIEW
MODELVIEW_MATRIX
MODELVIEW_STACK_DEPTH
MODULATE
N3F_V3F
NAME_STACK_DEPTH
NAND
NEAREST
NEAREST_MIPMAP_LINEAR
NEAREST_MIPMAP_NEAREST
NEVER
NICEST
NO_ERROR
NONE
NOOP
NOR
NORMAL_ARRAY
NORMAL_ARRAY_COUNT_EXT
NORMAL_ARRAY_EXT
NORMAL_ARRAY_POINTER
NORMAL_ARRAY_POINTER_EXT
NORMAL_ARRAY_STRIDE
NORMAL_ARRAY_STRIDE_EXT
NORMAL_ARRAY_TYPE
NORMAL_ARRAY_TYPE_EXT
NORMALIZE
NOTEQUAL
OBJECT_LINEAR
OBJECT_PLANE
ONE
ONE_MINUS_DST_ALPHA
ONE_MINUS_DST_COLOR
ONE_MINUS_SRC_ALPHA
ONE_MINUS_SRC_COLOR
OR
OR_INVERTED
OR_REVERSE
ORDER
OUT_OF_MEMORY
PACK_ALIGNMENT
PACK_LSB_FIRST
PACK_ROW_LENGTH
PACK_SKIP_PIXELS
PACK_SKIP_ROWS
PACK_SWAP_BYTES
PASS_THROUGH_TOKEN
PERSPECTIVE_CORRECTION_HINT
PHONG_HINT_WIN
PHONG_WIN
PIXEL_MAP_A_TO_A
PIXEL_MAP_A_TO_A_SIZE
PIXEL_MAP_B_TO_B
PIXEL_MAP_B_TO_B_SIZE
PIXEL_MAP_G_TO_G
PIXEL_MAP_G_TO_G_SIZE
PIXEL_MAP_I_TO_A
PIXEL_MAP_I_TO_A_SIZE
PIXEL_MAP_I_TO_B
PIXEL_MAP_I_TO_B_SIZE
PIXEL_MAP_I_TO_G
PIXEL_MAP_I_TO_G_SIZE
PIXEL_MAP_I_TO_I
PIXEL_MAP_I_TO_I_SIZE
PIXEL_MAP_I_TO_R
PIXEL_MAP_I_TO_R_SIZE
PIXEL_MAP_R_TO_R
PIXEL_MAP_R_TO_R_SIZE
PIXEL_MAP_S_TO_S
PIXEL_MAP_S_TO_S_SIZE
PIXEL_MODE_BIT
POINT
POINT_BIT
POINT_SIZE
POINT_SIZE_GRANULARITY
POINT_SIZE_RANGE
POINT_SMOOTH
POINT_SMOOTH_HINT
POINT_TOKEN
POINTS
POLYGON
POLYGON_BIT
POLYGON_MODE
POLYGON_OFFSET_FACTOR
POLYGON_OFFSET_FILL
POLYGON_OFFSET_LINE
POLYGON_OFFSET_POINT
POLYGON_OFFSET_UNITS
POLYGON_SMOOTH
POLYGON_SMOOTH_HINT
POLYGON_STIPPLE
POLYGON_STIPPLE_BIT
POLYGON_TOKEN
POSITION
PROJECTION
PROJECTION_MATRIX
PROJECTION_STACK_DEPTH
PROXY_TEXTURE_1D
PROXY_TEXTURE_2D
Q
QUAD_STRIP
QUADRATIC_ATTENUATION
QUADS
R
R3_G3_B2
READ_BUFFER
RED
RED_BIAS
RED_BITS
RED_SCALE
RENDER
RENDER_MODE
RENDERER
REPEAT
REPLACE
RGB
RGB10
RGB10_A2
RGB12
RGB16
RGB4
RGB5
RGB5_A1
RGB8
RGBA
RGBA_MODE
RGBA12
RGBA16
RGBA2
RGBA4
RGBA8
RIGHT
S
SCISSOR_BIT
SCISSOR_BOX
SCISSOR_TEST
SELECT
SELECTION_BUFFER_POINTER
SELECTION_BUFFER_SIZE
SET
SHADE_MODEL
SHININESS
SHORT
SMOOTH
SPECULAR
SPHERE_MAP
SPOT_CUTOFF
SPOT_DIRECTION
SPOT_EXPONENT
SRC_ALPHA
SRC_ALPHA_SATURATE
SRC_COLOR
STACK_OVERFLOW
STACK_UNDERFLOW
STENCIL
STENCIL_BITS
STENCIL_BUFFER_BIT
STENCIL_CLEAR_VALUE
STENCIL_FAIL
STENCIL_FUNC
STENCIL_INDEX
STENCIL_PASS_DEPTH_FAIL
STENCIL_PASS_DEPTH_PASS
STENCIL_REF
STENCIL_TEST
STENCIL_VALUE_MASK
STENCIL_WRITEMASK
STEREO
SUBPIXEL_BITS
T
T2F_C3F_V3F
T2F_C4F_N3F_V3F
T2F_C4UB_V3F
T2F_N3F_V3F
T2F_V3F
T4F_C4F_N3F_V4F
T4F_V4F
TEXTALIGN_BOTTOM
TEXTALIGN_CENTER
TEXTALIGN_LEFT
TEXTALIGN_RIGHT
TEXTALIGN_TOP
TEXTURE
TEXTURE_1D
TEXTURE_2D
TEXTURE_ALPHA_SIZE
TEXTURE_BINDING_1D
TEXTURE_BINDING_2D
TEXTURE_BIT
TEXTURE_BLUE_SIZE
TEXTURE_BORDER
TEXTURE_BORDER_COLOR
TEXTURE_COORD_ARRAY
TEXTURE_COORD_ARRAY_COUNT_EXT
TEXTURE_COORD_ARRAY_EXT
TEXTURE_COORD_ARRAY_POINTER
TEXTURE_COORD_ARRAY_POINTER_EXT
TEXTURE_COORD_ARRAY_SIZE
TEXTURE_COORD_ARRAY_SIZE_EXT
TEXTURE_COORD_ARRAY_STRIDE
TEXTURE_COORD_ARRAY_STRIDE_EXT
TEXTURE_COORD_ARRAY_TYPE
TEXTURE_COORD_ARRAY_TYPE_EXT
TEXTURE_ENV
TEXTURE_ENV_COLOR
TEXTURE_ENV_MODE
TEXTURE_GEN_MODE
TEXTURE_GEN_Q
TEXTURE_GEN_R
TEXTURE_GEN_S
TEXTURE_GEN_T
TEXTURE_GREEN_SIZE
TEXTURE_HEIGHT
TEXTURE_INTENSITY_SIZE
TEXTURE_INTERNAL_FORMAT
TEXTURE_LUMINANCE_SIZE
TEXTURE_MAG_FILTER
TEXTURE_MATRIX
TEXTURE_MIN_FILTER
TEXTURE_PRIORITY
TEXTURE_RED_SIZE
TEXTURE_RESIDENT
TEXTURE_STACK_DEPTH
TEXTURE_WIDTH
TEXTURE_WRAP_S
TEXTURE_WRAP_T
TRANSFORM_BIT
TRIANGLE_FAN
TRIANGLE_STRIP
TRIANGLES
TRUE
UNPACK_ALIGNMENT
UNPACK_LSB_FIRST
UNPACK_ROW_LENGTH
UNPACK_SKIP_PIXELS
UNPACK_SKIP_ROWS
UNPACK_SWAP_BYTES
UNSIGNED_BYTE
UNSIGNED_INT
UNSIGNED_SHORT
V2F
V3F
VENDOR
VERSION
VERSION_1_1
VERTEX_ARRAY
VERTEX_ARRAY_COUNT_EXT
VERTEX_ARRAY_EXT
VERTEX_ARRAY_POINTER
VERTEX_ARRAY_POINTER_EXT
VERTEX_ARRAY_SIZE
VERTEX_ARRAY_SIZE_EXT
VERTEX_ARRAY_STRIDE
VERTEX_ARRAY_STRIDE_EXT
VERTEX_ARRAY_TYPE
VERTEX_ARRAY_TYPE_EXT
VIEWPORT
VIEWPORT_BIT
WGL_FONT_LINES
WGL_FONT_POLYGONS
WIN_draw_range_elements
WIN_swap_hint
XOR
ZERO
ZOOM_X
ZOOM_Y

パブリック メソッド

BitBlt
ChoosePixelFormat
CreateFont
DeleteObject
DescribePixelFormat
GetDC
GetDeviceCaps
GetPixelFormat
GetTextExtentPoint32
glAccum
glAlphaFunc
glAreTexturesResident
glArrayElement
glBegin
glBindTexture
glBitmap
glBlendFunc
glCallList
glCallLists
glClear
glClearAccum
glClearColor
glClearDepth
glClearIndex
glClearStencil
glClipPlane
glColor3b
glColor3bv
glColor3d
glColor3dv
glColor3f
glColor3fv
glColor3i
glColor3iv
glColor3s
glColor3sv
glColor3ub
glColor3ubv
glColor3ui
glColor3uiv
glColor3us
glColor3usv
glColor4b
glColor4bv
glColor4d
glColor4dv
glColor4f
glColor4fv
glColor4i
glColor4iv
glColor4s
glColor4sv
glColor4ub
glColor4ubv
glColor4ui
glColor4uiv
glColor4us
glColor4usv
glColorMask
glColorMaterial
glColorPointer
glCopyPixels
glCopyTexImage1D
glCopyTexImage2D
glCopyTexSubImage1D
glCopyTexSubImage2D
glCullFace
glDeleteLists
glDeleteTextures
glDepthFunc
glDepthMask
glDepthRange
glDisable
glDisableClientState
glDrawArrays
glDrawBuffer
glDrawElements
glDrawPixels
glEdgeFlag
glEdgeFlagPointer
glEdgeFlagv
glEnable
glEnableClientState
glEnd
glEndList
glEvalCoord1d
glEvalCoord1dv
glEvalCoord1f
glEvalCoord1fv
glEvalCoord2d
glEvalCoord2dv
glEvalCoord2f
glEvalCoord2fv
glEvalMesh1
glEvalMesh2
glEvalPoint1
glEvalPoint2
glFeedbackBuffer
glFinish
glFlush
glFogf
glFogfv
glFogi
glFogiv
glFrontFace
glFrustum
glGenLists
glGenTextures
glGetBooleanv
glGetClipPlane
glGetDoublev
glGetError
glGetFloatv
glGetIntegerv
glGetLightfv
glGetLightiv
glGetMapdv
glGetMapfv
glGetMapiv
glGetMaterialfv
glGetMaterialiv
glGetPixelMapfv
glGetPixelMapuiv
glGetPixelMapusv
glGetPointerv
glGetPolygonStipple
glGetString
glGetTexEnvfv
glGetTexEnviv
glGetTexGendv
glGetTexGenfv
glGetTexGeniv
glGetTexImage
glGetTexLevelParameterfv
glGetTexLevelParameteriv
glGetTexParameterfv
glGetTexParameteriv
glHint
glIndexd
glIndexdv
glIndexf
glIndexfv
glIndexi
glIndexiv
glIndexMask
glIndexPointer
glIndexs
glIndexsv
glIndexub
glIndexubv
glInitNames
glInterleavedArrays
glIsEnabled
glIsList
glIsTexture
glLightf
glLightfv
glLighti
glLightiv
glLightModelf
glLightModelfv
glLightModeli
glLightModeliv
glLineStipple
glLineWidth
glListBase
glLoadIdentity
glLoadMatrixd
glLoadMatrixf
glLoadName
glLogicOp
glMap1d
glMap1f
glMap2d
glMap2f
glMapGrid1d
glMapGrid1f
glMapGrid2d
glMapGrid2f
glMaterialf
glMaterialfv
glMateriali
glMaterialiv
glMatrixMode
glMultMatrixd
glMultMatrixf
glNewList
glNormal3b
glNormal3bv
glNormal3d
glNormal3dv
glNormal3f
glNormal3fv
glNormal3i
glNormal3iv
glNormal3s
glNormal3sv
glNormalPointer
glOrtho
glPassThrough
glPixelMapfv
glPixelMapuiv
glPixelMapusv
glPixelStoref
glPixelStorei
glPixelTransferf
glPixelTransferi
glPixelZoom
glPointSize
glPolygonMode
glPolygonOffset
glPolygonStipple
glPopAttrib
glPopClientAttrib
glPopMatrix
glPopName
glPrioritizeTextures
glPushAttrib
glPushClientAttrib
glPushMatrix
glPushName
glRasterPos2d
glRasterPos2dv
glRasterPos2f
glRasterPos2fv
glRasterPos2i
glRasterPos2iv
glRasterPos2s
glRasterPos2sv
glRasterPos3d
glRasterPos3dv
glRasterPos3f
glRasterPos3fv
glRasterPos3i
glRasterPos3iv
glRasterPos3s
glRasterPos3sv
glRasterPos4d
glRasterPos4dv
glRasterPos4f
glRasterPos4fv
glRasterPos4i
glRasterPos4iv
glRasterPos4s
glRasterPos4sv
glReadBuffer
glReadPixels
glRectd
glRectdv
glRectf
glRectfv
glRecti
glRectiv
glRects
glRectsv
glRenderMode
glRotated
glRotatef
glScaled
glScalef
glScissor
glSelectBuffer
glShadeModel
glStencilFunc
glStencilMask
glStencilOp
glTexCoord1d
glTexCoord1dv
glTexCoord1f
glTexCoord1fv
glTexCoord1i
glTexCoord1iv
glTexCoord1s
glTexCoord1sv
glTexCoord2d
glTexCoord2dv
glTexCoord2f
glTexCoord2fv
glTexCoord2i
glTexCoord2iv
glTexCoord2s
glTexCoord2sv
glTexCoord3d
glTexCoord3dv
glTexCoord3f
glTexCoord3fv
glTexCoord3i
glTexCoord3iv
glTexCoord3s
glTexCoord3sv
glTexCoord4d
glTexCoord4dv
glTexCoord4f
glTexCoord4fv
glTexCoord4i
glTexCoord4iv
glTexCoord4s
glTexCoord4sv
glTexCoordPointer
glTexEnvf
glTexEnvfv
glTexEnvi
glTexEnviv
glTexGend
glTexGendv
glTexGenf
glTexGenfv
glTexGeni
glTexGeniv
glTexImage1D
glTexImage2D
glTexParameterf
glTexParameterfv
glTexParameteri
glTexParameteriv
glTexSubImage1D
glTexSubImage2D
glTranslated
glTranslatef
gluBeginCurve
gluBeginSurface
gluBeginTrim
gluBuild1DMipmaps
gluBuild2DMipmaps
gluCylinder
gluDeleteNurbsRenderer
gluDeleteQuadric
gluDeleteTess
gluDisk
gluEndCurve
gluEndSurface
gluEndTrim
gluErrorString
gluGetNurbsProperty
gluGetString
gluGetTessProperty
gluLoadSamplingMatrices
gluLookAt
gluNewNurbsRenderer
gluNewQuadric
gluNewTess
gluNurbsCurve
gluNurbsProperty
gluNurbsSurface
gluOrtho2D
gluPartialDisk
gluPerspective
gluPickMatrix
gluProject
gluPwlCurve
gluQuadricDrawStyle
gluQuadricNormals
gluQuadricOrientation
gluQuadricTexture
gluScaleImage
gluSphere
gluTessBeginContour
gluTessBeginPolygon
gluTessEndContour
gluTessEndPolygon
gluTessNormal
gluTessProperty
gluTessVertex
gluUnProject
glVertex2d
glVertex2dv
glVertex2f
glVertex2fv
glVertex2i
glVertex2iv
glVertex2s
glVertex2sv
glVertex3d
glVertex3dv
glVertex3f
glVertex3fv
glVertex3i
glVertex3iv
glVertex3s
glVertex3sv
glVertex4d
glVertex4dv
glVertex4f
glVertex4fv
glVertex4i
glVertex4iv
glVertex4s
glVertex4sv
glVertexPointer
glViewport
IntPtrCallback
LoadLibrary
ReleaseDC
SetPixelFormat
SwapBuffers
wglCreateContext
wglDeleteContext
wglGetCurrentContext
wglMakeCurrent
wglShareLists
wglUseFontOutlines

プロテクト フィールド

ACCUM
ADD
BI_BITFIELDS
BI_JPEG
BI_PNG
BI_RGB
BI_RLE4
BI_RLE8
BLACKNESS
DIB_PAL_COLORS
DIB_RGB_COLORS
DSTINVERT
FOG_SPECULAR_TEXTURE_WIN
LOAD
MERGECOPY
MERGEPAINT
MULT
NOTSRCCOPY
NOTSRCERASE
PATCOPY
PATINVERT
PATPAINT
PFD_DOUBLEBUFFER
PFD_DRAW_TO_BITMAP
PFD_DRAW_TO_WINDOW
PFD_GENERIC_ACCELERATED
PFD_GENERIC_FORMAT
PFD_MAIN_PLANE
PFD_NEED_PALETTE
PFD_NEED_SYSTEM_PALETTE
PFD_OVERLAY_PLANE
PFD_STEREO
PFD_SUPPORT_DIRECTDRAW
PFD_SUPPORT_GDI
PFD_SUPPORT_OPENGL
PFD_SWAP_COPY
PFD_SWAP_EXCHANGE
PFD_SWAP_LAYER_BUFFERS
PFD_TYPE_COLORINDEX
PFD_TYPE_RGBA
PFD_UNDERLAY_PLANE
RETURN
SRCAND
SRCCOPY
SRCERASE
SRCINVERT
SRCPAINT
WHITENESS

プロテクト メソッド

CreateCompatibleDC
CreateDIBSection
DeleteDC

参照

Imports クラス | Steema.TeeChart.Drawing.GL 名前空間


Imports コンストラクタ

Steema.TeeChart.Drawing.GL.Imports コンストラクタ

public Imports()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports フィールド

パブリック フィールド

ACCUM_ALPHA_BITS
ACCUM_BLUE_BITS
ACCUM_BUFFER_BIT
ACCUM_CLEAR_VALUE
ACCUM_GREEN_BITS
ACCUM_RED_BITS
ALL_ATTRIB_BITS
ALPHA
ALPHA_BIAS
ALPHA_BITS
ALPHA_SCALE
ALPHA_TEST
ALPHA_TEST_FUNC
ALPHA_TEST_REF
ALPHA12
ALPHA16
ALPHA4
ALPHA8
ALWAYS
AMBIENT
AMBIENT_AND_DIFFUSE
AND
AND_INVERTED
AND_REVERSE
ATTRIB_STACK_DEPTH
AUTO_NORMAL
AUX_BUFFERS
AUX0
AUX1
AUX2
AUX3
BACK
BACK_LEFT
BACK_RIGHT
BGR_EXT
BGRA_EXT
BITMAP
BITMAP_TOKEN
BLEND
BLEND_DST
BLEND_SRC
BLUE
BLUE_BIAS
BLUE_BITS
BLUE_SCALE
BYTE
C3F_V3F
C4F_N3F_V3F
C4UB_V2F
C4UB_V3F
CCW
CLAMP
CLEAR
CLIENT_ALL_ATTRIB_BITS
CLIENT_ATTRIB_STACK_DEPTH
CLIENT_PIXEL_STORE_BIT
CLIENT_VERTEX_ARRAY_BIT
CLIP_PLANE0
CLIP_PLANE1
CLIP_PLANE2
CLIP_PLANE3
CLIP_PLANE4
CLIP_PLANE5
COEFF
COLOR
COLOR_ARRAY
COLOR_ARRAY_COUNT_EXT
COLOR_ARRAY_EXT
COLOR_ARRAY_POINTER
COLOR_ARRAY_POINTER_EXT
COLOR_ARRAY_SIZE
COLOR_ARRAY_SIZE_EXT
COLOR_ARRAY_STRIDE
COLOR_ARRAY_STRIDE_EXT
COLOR_ARRAY_TYPE
COLOR_ARRAY_TYPE_EXT
COLOR_BUFFER_BIT
COLOR_CLEAR_VALUE
COLOR_INDEX
COLOR_INDEX1_EXT
COLOR_INDEX12_EXT
COLOR_INDEX16_EXT
COLOR_INDEX2_EXT
COLOR_INDEX4_EXT
COLOR_INDEX8_EXT
COLOR_INDEXES
COLOR_LOGIC_OP
COLOR_MATERIAL
COLOR_MATERIAL_FACE
COLOR_MATERIAL_PARAMETER
COLOR_TABLE_ALPHA_SIZE_EXT
COLOR_TABLE_BLUE_SIZE_EXT
COLOR_TABLE_FORMAT_EXT
COLOR_TABLE_GREEN_SIZE_EXT
COLOR_TABLE_INTENSITY_SIZE_EXT
COLOR_TABLE_LUMINANCE_SIZE_EXT
COLOR_TABLE_RED_SIZE_EXT
COLOR_TABLE_WIDTH_EXT
COLOR_WRITEMASK
COMPILE
COMPILE_AND_EXECUTE
CONSTANT_ATTENUATION
COPY
COPY_INVERTED
COPY_PIXEL_TOKEN
CULL_FACE
CULL_FACE_MODE
CURRENT_BIT
CURRENT_COLOR
CURRENT_INDEX
CURRENT_NORMAL
CURRENT_RASTER_COLOR
CURRENT_RASTER_DISTANCE
CURRENT_RASTER_INDEX
CURRENT_RASTER_POSITION
CURRENT_RASTER_POSITION_VALID
CURRENT_RASTER_TEXTURE_COORDS
CURRENT_TEXTURE_COORDS
CW
DECAL
DECR
DEPTH
DEPTH_BIAS
DEPTH_BITS
DEPTH_BUFFER_BIT
DEPTH_CLEAR_VALUE
DEPTH_COMPONENT
DEPTH_FUNC
DEPTH_RANGE
DEPTH_SCALE
DEPTH_TEST
DEPTH_WRITEMASK
DIFFUSE
DITHER
DOMAIN
DONT_CARE
DOUBLE
DOUBLE_EXT
DOUBLEBUFFER
DRAW_BUFFER
DRAW_PIXEL_TOKEN
DST_ALPHA
DST_COLOR
EDGE_FLAG
EDGE_FLAG_ARRAY
EDGE_FLAG_ARRAY_COUNT_EXT
EDGE_FLAG_ARRAY_EXT
EDGE_FLAG_ARRAY_POINTER
EDGE_FLAG_ARRAY_POINTER_EXT
EDGE_FLAG_ARRAY_STRIDE
EDGE_FLAG_ARRAY_STRIDE_EXT
EMISSION
ENABLE_BIT
EQUAL
EQUIV
EVAL_BIT
EXP
EXP2
EXT_bgra
EXT_paletted_texture
EXT_vertex_array
EXTENSIONS
EYE_LINEAR
EYE_PLANE
FALSE
FASTEST
FEEDBACK
FEEDBACK_BUFFER_POINTER
FEEDBACK_BUFFER_SIZE
FEEDBACK_BUFFER_TYPE
FILL
FLAT
FLOAT
FOG
FOG_BIT
FOG_COLOR
FOG_DENSITY
FOG_END
FOG_HINT
FOG_INDEX
FOG_MODE
FOG_START
FRONT
FRONT_AND_BACK
FRONT_FACE
FRONT_LEFT
FRONT_RIGHT
GEQUAL
GL_2_BYTES
GL_2D
GL_3_BYTES
GL_3D
GL_3D_COLOR_TEXTURE
GL_4_BYTES
GL_4D_COLOR
GL_4D_COLOR_TEXTURE
GLU_AUTO_LOAD_MATRIX
GLU_CULLING
GLU_DISPLAY_MODE
GLU_DOMAIN_DISTANCE
GLU_EXTENSIONS
GLU_FALSE
GLU_FILL
GLU_FLAT
GLU_INCOMPATIBLE_GL_VERSION
GLU_INSIDE
GLU_INVALID_ENUM
GLU_INVALID_VALUE
GLU_LINE
GLU_MAP1_TRIM_2
GLU_MAP1_TRIM_3
GLU_NONE
GLU_NURBS_ERROR1
GLU_NURBS_ERROR10
GLU_NURBS_ERROR11
GLU_NURBS_ERROR12
GLU_NURBS_ERROR13
GLU_NURBS_ERROR14
GLU_NURBS_ERROR15
GLU_NURBS_ERROR16
GLU_NURBS_ERROR17
GLU_NURBS_ERROR18
GLU_NURBS_ERROR19
GLU_NURBS_ERROR2
GLU_NURBS_ERROR20
GLU_NURBS_ERROR21
GLU_NURBS_ERROR22
GLU_NURBS_ERROR23
GLU_NURBS_ERROR24
GLU_NURBS_ERROR25
GLU_NURBS_ERROR26
GLU_NURBS_ERROR27
GLU_NURBS_ERROR28
GLU_NURBS_ERROR29
GLU_NURBS_ERROR3
GLU_NURBS_ERROR30
GLU_NURBS_ERROR31
GLU_NURBS_ERROR32
GLU_NURBS_ERROR33
GLU_NURBS_ERROR34
GLU_NURBS_ERROR35
GLU_NURBS_ERROR36
GLU_NURBS_ERROR37
GLU_NURBS_ERROR4
GLU_NURBS_ERROR5
GLU_NURBS_ERROR6
GLU_NURBS_ERROR7
GLU_NURBS_ERROR8
GLU_NURBS_ERROR9
GLU_OUT_OF_MEMORY
GLU_OUTLINE_PATCH
GLU_OUTLINE_POLYGON
GLU_OUTSIDE
GLU_PARAMETRIC_ERROR
GLU_PARAMETRIC_TOLERANCE
GLU_PATH_LENGTH
GLU_POINT
GLU_SAMPLING_METHOD
GLU_SAMPLING_TOLERANCE
GLU_SILHOUETTE
GLU_SMOOTH
GLU_TESS_BEGIN
GLU_TESS_BEGIN_DATA
GLU_TESS_BOUNDARY_ONLY
GLU_TESS_COMBINE
GLU_TESS_COMBINE_DATA
GLU_TESS_COORD_TOO_LARGE
GLU_TESS_EDGE_FLAG
GLU_TESS_EDGE_FLAG_DATA
GLU_TESS_END
GLU_TESS_END_DATA
GLU_TESS_ERROR
GLU_TESS_ERROR_DATA
GLU_TESS_ERROR1
GLU_TESS_ERROR2
GLU_TESS_ERROR3
GLU_TESS_ERROR4
GLU_TESS_ERROR5
GLU_TESS_ERROR6
GLU_TESS_ERROR7
GLU_TESS_ERROR8
GLU_TESS_MAX_COORD
GLU_TESS_MISSING_BEGIN_CONTOUR
GLU_TESS_MISSING_BEGIN_POLYGON
GLU_TESS_MISSING_END_CONTOUR
GLU_TESS_MISSING_END_POLYGON
GLU_TESS_NEED_COMBINE_CALLBACK
GLU_TESS_TOLERANCE
GLU_TESS_VERTEX
GLU_TESS_VERTEX_DATA
GLU_TESS_WINDING_ABS_GEQ_TWO
GLU_TESS_WINDING_NEGATIVE
GLU_TESS_WINDING_NONZERO
GLU_TESS_WINDING_ODD
GLU_TESS_WINDING_POSITIVE
GLU_TESS_WINDING_RULE
GLU_TRUE
GLU_U_STEP
GLU_V_STEP
GLU_VERSION
GLU_VERSION_1_1
GLU_VERSION_1_2
GREATER
GREEN
GREEN_BIAS
GREEN_BITS
GREEN_SCALE
HINT_BIT
INCR
INDEX_ARRAY
INDEX_ARRAY_COUNT_EXT
INDEX_ARRAY_EXT
INDEX_ARRAY_POINTER
INDEX_ARRAY_POINTER_EXT
INDEX_ARRAY_STRIDE
INDEX_ARRAY_STRIDE_EXT
INDEX_ARRAY_TYPE
INDEX_ARRAY_TYPE_EXT
INDEX_BITS
INDEX_CLEAR_VALUE
INDEX_LOGIC_OP
INDEX_MODE
INDEX_OFFSET
INDEX_SHIFT
INDEX_WRITEMASK
INT
INTENSITY
INTENSITY12
INTENSITY16
INTENSITY4
INTENSITY8
INVALID_ENUM
INVALID_OPERATION
INVALID_VALUE
INVERT
KEEP
LEFT
LEQUAL
LESS
LIBRARY_GDI
LIBRARY_GLU
LIBRARY_KERNEL
LIBRARY_OPENGL
LIBRARY_USER
LIGHT_MODEL_AMBIENT
LIGHT_MODEL_LOCAL_VIEWER
LIGHT_MODEL_TWO_SIDE
LIGHT0
LIGHT1
LIGHT2
LIGHT3
LIGHT4
LIGHT5
LIGHT6
LIGHT7
LIGHTING
LIGHTING_BIT
LINE
LINE_BIT
LINE_LOOP
LINE_RESET_TOKEN
LINE_SMOOTH
LINE_SMOOTH_HINT
LINE_STIPPLE
LINE_STIPPLE_PATTERN
LINE_STIPPLE_REPEAT
LINE_STRIP
LINE_TOKEN
LINE_WIDTH
LINE_WIDTH_GRANULARITY
LINE_WIDTH_RANGE
LINEAR
LINEAR_ATTENUATION
LINEAR_MIPMAP_LINEAR
LINEAR_MIPMAP_NEAREST
LINES
LIST_BASE
LIST_BIT
LIST_INDEX
LIST_MODE
LOGIC_OP_MODE
LUMINANCE
LUMINANCE_ALPHA
LUMINANCE12
LUMINANCE12_ALPHA12
LUMINANCE12_ALPHA4
LUMINANCE16
LUMINANCE16_ALPHA16
LUMINANCE4
LUMINANCE4_ALPHA4
LUMINANCE6_ALPHA2
LUMINANCE8
LUMINANCE8_ALPHA8
MAP_COLOR
MAP_STENCIL
MAP1_COLOR_4
MAP1_GRID_DOMAIN
MAP1_GRID_SEGMENTS
MAP1_INDEX
MAP1_NORMAL
MAP1_TEXTURE_COORD_1
MAP1_TEXTURE_COORD_2
MAP1_TEXTURE_COORD_3
MAP1_TEXTURE_COORD_4
MAP1_VERTEX_3
MAP1_VERTEX_4
MAP2_COLOR_4
MAP2_GRID_DOMAIN
MAP2_GRID_SEGMENTS
MAP2_INDEX
MAP2_NORMAL
MAP2_TEXTURE_COORD_1
MAP2_TEXTURE_COORD_2
MAP2_TEXTURE_COORD_3
MAP2_TEXTURE_COORD_4
MAP2_VERTEX_3
MAP2_VERTEX_4
MATRIX_MODE
MAX_ATTRIB_STACK_DEPTH
MAX_CLIENT_ATTRIB_STACK_DEPTH
MAX_CLIP_PLANES
MAX_ELEMENTS_INDICES_WIN
MAX_ELEMENTS_VERTICES_WIN
MAX_EVAL_ORDER
MAX_LIGHTS
MAX_LIST_NESTING
MAX_MODELVIEW_STACK_DEPTH
MAX_NAME_STACK_DEPTH
MAX_PIXEL_MAP_TABLE
MAX_PROJECTION_STACK_DEPTH
MAX_TEXTURE_SIZE
MAX_TEXTURE_STACK_DEPTH
MAX_VIEWPORT_DIMS
MODELVIEW
MODELVIEW_MATRIX
MODELVIEW_STACK_DEPTH
MODULATE
N3F_V3F
NAME_STACK_DEPTH
NAND
NEAREST
NEAREST_MIPMAP_LINEAR
NEAREST_MIPMAP_NEAREST
NEVER
NICEST
NO_ERROR
NONE
NOOP
NOR
NORMAL_ARRAY
NORMAL_ARRAY_COUNT_EXT
NORMAL_ARRAY_EXT
NORMAL_ARRAY_POINTER
NORMAL_ARRAY_POINTER_EXT
NORMAL_ARRAY_STRIDE
NORMAL_ARRAY_STRIDE_EXT
NORMAL_ARRAY_TYPE
NORMAL_ARRAY_TYPE_EXT
NORMALIZE
NOTEQUAL
OBJECT_LINEAR
OBJECT_PLANE
ONE
ONE_MINUS_DST_ALPHA
ONE_MINUS_DST_COLOR
ONE_MINUS_SRC_ALPHA
ONE_MINUS_SRC_COLOR
OR
OR_INVERTED
OR_REVERSE
ORDER
OUT_OF_MEMORY
PACK_ALIGNMENT
PACK_LSB_FIRST
PACK_ROW_LENGTH
PACK_SKIP_PIXELS
PACK_SKIP_ROWS
PACK_SWAP_BYTES
PASS_THROUGH_TOKEN
PERSPECTIVE_CORRECTION_HINT
PHONG_HINT_WIN
PHONG_WIN
PIXEL_MAP_A_TO_A
PIXEL_MAP_A_TO_A_SIZE
PIXEL_MAP_B_TO_B
PIXEL_MAP_B_TO_B_SIZE
PIXEL_MAP_G_TO_G
PIXEL_MAP_G_TO_G_SIZE
PIXEL_MAP_I_TO_A
PIXEL_MAP_I_TO_A_SIZE
PIXEL_MAP_I_TO_B
PIXEL_MAP_I_TO_B_SIZE
PIXEL_MAP_I_TO_G
PIXEL_MAP_I_TO_G_SIZE
PIXEL_MAP_I_TO_I
PIXEL_MAP_I_TO_I_SIZE
PIXEL_MAP_I_TO_R
PIXEL_MAP_I_TO_R_SIZE
PIXEL_MAP_R_TO_R
PIXEL_MAP_R_TO_R_SIZE
PIXEL_MAP_S_TO_S
PIXEL_MAP_S_TO_S_SIZE
PIXEL_MODE_BIT
POINT
POINT_BIT
POINT_SIZE
POINT_SIZE_GRANULARITY
POINT_SIZE_RANGE
POINT_SMOOTH
POINT_SMOOTH_HINT
POINT_TOKEN
POINTS
POLYGON
POLYGON_BIT
POLYGON_MODE
POLYGON_OFFSET_FACTOR
POLYGON_OFFSET_FILL
POLYGON_OFFSET_LINE
POLYGON_OFFSET_POINT
POLYGON_OFFSET_UNITS
POLYGON_SMOOTH
POLYGON_SMOOTH_HINT
POLYGON_STIPPLE
POLYGON_STIPPLE_BIT
POLYGON_TOKEN
POSITION
PROJECTION
PROJECTION_MATRIX
PROJECTION_STACK_DEPTH
PROXY_TEXTURE_1D
PROXY_TEXTURE_2D
Q
QUAD_STRIP
QUADRATIC_ATTENUATION
QUADS
R
R3_G3_B2
READ_BUFFER
RED
RED_BIAS
RED_BITS
RED_SCALE
RENDER
RENDER_MODE
RENDERER
REPEAT
REPLACE
RGB
RGB10
RGB10_A2
RGB12
RGB16
RGB4
RGB5
RGB5_A1
RGB8
RGBA
RGBA_MODE
RGBA12
RGBA16
RGBA2
RGBA4
RGBA8
RIGHT
S
SCISSOR_BIT
SCISSOR_BOX
SCISSOR_TEST
SELECT
SELECTION_BUFFER_POINTER
SELECTION_BUFFER_SIZE
SET
SHADE_MODEL
SHININESS
SHORT
SMOOTH
SPECULAR
SPHERE_MAP
SPOT_CUTOFF
SPOT_DIRECTION
SPOT_EXPONENT
SRC_ALPHA
SRC_ALPHA_SATURATE
SRC_COLOR
STACK_OVERFLOW
STACK_UNDERFLOW
STENCIL
STENCIL_BITS
STENCIL_BUFFER_BIT
STENCIL_CLEAR_VALUE
STENCIL_FAIL
STENCIL_FUNC
STENCIL_INDEX
STENCIL_PASS_DEPTH_FAIL
STENCIL_PASS_DEPTH_PASS
STENCIL_REF
STENCIL_TEST
STENCIL_VALUE_MASK
STENCIL_WRITEMASK
STEREO
SUBPIXEL_BITS
T
T2F_C3F_V3F
T2F_C4F_N3F_V3F
T2F_C4UB_V3F
T2F_N3F_V3F
T2F_V3F
T4F_C4F_N3F_V4F
T4F_V4F
TEXTALIGN_BOTTOM
TEXTALIGN_CENTER
TEXTALIGN_LEFT
TEXTALIGN_RIGHT
TEXTALIGN_TOP
TEXTURE
TEXTURE_1D
TEXTURE_2D
TEXTURE_ALPHA_SIZE
TEXTURE_BINDING_1D
TEXTURE_BINDING_2D
TEXTURE_BIT
TEXTURE_BLUE_SIZE
TEXTURE_BORDER
TEXTURE_BORDER_COLOR
TEXTURE_COORD_ARRAY
TEXTURE_COORD_ARRAY_COUNT_EXT
TEXTURE_COORD_ARRAY_EXT
TEXTURE_COORD_ARRAY_POINTER
TEXTURE_COORD_ARRAY_POINTER_EXT
TEXTURE_COORD_ARRAY_SIZE
TEXTURE_COORD_ARRAY_SIZE_EXT
TEXTURE_COORD_ARRAY_STRIDE
TEXTURE_COORD_ARRAY_STRIDE_EXT
TEXTURE_COORD_ARRAY_TYPE
TEXTURE_COORD_ARRAY_TYPE_EXT
TEXTURE_ENV
TEXTURE_ENV_COLOR
TEXTURE_ENV_MODE
TEXTURE_GEN_MODE
TEXTURE_GEN_Q
TEXTURE_GEN_R
TEXTURE_GEN_S
TEXTURE_GEN_T
TEXTURE_GREEN_SIZE
TEXTURE_HEIGHT
TEXTURE_INTENSITY_SIZE
TEXTURE_INTERNAL_FORMAT
TEXTURE_LUMINANCE_SIZE
TEXTURE_MAG_FILTER
TEXTURE_MATRIX
TEXTURE_MIN_FILTER
TEXTURE_PRIORITY
TEXTURE_RED_SIZE
TEXTURE_RESIDENT
TEXTURE_STACK_DEPTH
TEXTURE_WIDTH
TEXTURE_WRAP_S
TEXTURE_WRAP_T
TRANSFORM_BIT
TRIANGLE_FAN
TRIANGLE_STRIP
TRIANGLES
TRUE
UNPACK_ALIGNMENT
UNPACK_LSB_FIRST
UNPACK_ROW_LENGTH
UNPACK_SKIP_PIXELS
UNPACK_SKIP_ROWS
UNPACK_SWAP_BYTES
UNSIGNED_BYTE
UNSIGNED_INT
UNSIGNED_SHORT
V2F
V3F
VENDOR
VERSION
VERSION_1_1
VERTEX_ARRAY
VERTEX_ARRAY_COUNT_EXT
VERTEX_ARRAY_EXT
VERTEX_ARRAY_POINTER
VERTEX_ARRAY_POINTER_EXT
VERTEX_ARRAY_SIZE
VERTEX_ARRAY_SIZE_EXT
VERTEX_ARRAY_STRIDE
VERTEX_ARRAY_STRIDE_EXT
VERTEX_ARRAY_TYPE
VERTEX_ARRAY_TYPE_EXT
VIEWPORT
VIEWPORT_BIT
WGL_FONT_LINES
WGL_FONT_POLYGONS
WIN_draw_range_elements
WIN_swap_hint
XOR
ZERO
ZOOM_X
ZOOM_Y

プロテクト フィールド

ACCUM
ADD
BI_BITFIELDS
BI_JPEG
BI_PNG
BI_RGB
BI_RLE4
BI_RLE8
BLACKNESS
DIB_PAL_COLORS
DIB_RGB_COLORS
DSTINVERT
FOG_SPECULAR_TEXTURE_WIN
LOAD
MERGECOPY
MERGEPAINT
MULT
NOTSRCCOPY
NOTSRCERASE
PATCOPY
PATINVERT
PATPAINT
PFD_DOUBLEBUFFER
PFD_DRAW_TO_BITMAP
PFD_DRAW_TO_WINDOW
PFD_GENERIC_ACCELERATED
PFD_GENERIC_FORMAT
PFD_MAIN_PLANE
PFD_NEED_PALETTE
PFD_NEED_SYSTEM_PALETTE
PFD_OVERLAY_PLANE
PFD_STEREO
PFD_SUPPORT_DIRECTDRAW
PFD_SUPPORT_GDI
PFD_SUPPORT_OPENGL
PFD_SWAP_COPY
PFD_SWAP_EXCHANGE
PFD_SWAP_LAYER_BUFFERS
PFD_TYPE_COLORINDEX
PFD_TYPE_RGBA
PFD_UNDERLAY_PLANE
RETURN
SRCAND
SRCCOPY
SRCERASE
SRCINVERT
SRCPAINT
WHITENESS

参照

Imports クラス | Steema.TeeChart.Drawing.GL 名前空間


ACCUM

Steema.TeeChart.Drawing.GL.Imports.ACCUM フィールド

protected internal UInt32 ACCUM

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_ALPHA_BITS

Steema.TeeChart.Drawing.GL.Imports.ACCUM_ALPHA_BITS フィールド

public const UInt32 ACCUM_ALPHA_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_BLUE_BITS

Steema.TeeChart.Drawing.GL.Imports.ACCUM_BLUE_BITS フィールド

public const UInt32 ACCUM_BLUE_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_BUFFER_BIT

Steema.TeeChart.Drawing.GL.Imports.ACCUM_BUFFER_BIT フィールド

public const UInt32 ACCUM_BUFFER_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_CLEAR_VALUE

Steema.TeeChart.Drawing.GL.Imports.ACCUM_CLEAR_VALUE フィールド

public const UInt32 ACCUM_CLEAR_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_GREEN_BITS

Steema.TeeChart.Drawing.GL.Imports.ACCUM_GREEN_BITS フィールド

public const UInt32 ACCUM_GREEN_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ACCUM_RED_BITS

Steema.TeeChart.Drawing.GL.Imports.ACCUM_RED_BITS フィールド

public const UInt32 ACCUM_RED_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ADD

Steema.TeeChart.Drawing.GL.Imports.ADD フィールド

protected internal const UInt32 ADD

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALL_ATTRIB_BITS

Steema.TeeChart.Drawing.GL.Imports.ALL_ATTRIB_BITS フィールド

public const UInt32 ALL_ATTRIB_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA

Steema.TeeChart.Drawing.GL.Imports.ALPHA フィールド

public const UInt32 ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_BIAS

Steema.TeeChart.Drawing.GL.Imports.ALPHA_BIAS フィールド

public const UInt32 ALPHA_BIAS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_BITS

Steema.TeeChart.Drawing.GL.Imports.ALPHA_BITS フィールド

public const UInt32 ALPHA_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_SCALE

Steema.TeeChart.Drawing.GL.Imports.ALPHA_SCALE フィールド

public const UInt32 ALPHA_SCALE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_TEST

Steema.TeeChart.Drawing.GL.Imports.ALPHA_TEST フィールド

public const UInt32 ALPHA_TEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_TEST_FUNC

Steema.TeeChart.Drawing.GL.Imports.ALPHA_TEST_FUNC フィールド

public const UInt32 ALPHA_TEST_FUNC

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA_TEST_REF

Steema.TeeChart.Drawing.GL.Imports.ALPHA_TEST_REF フィールド

public const UInt32 ALPHA_TEST_REF

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA12

Steema.TeeChart.Drawing.GL.Imports.ALPHA12 フィールド

public const UInt32 ALPHA12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA16

Steema.TeeChart.Drawing.GL.Imports.ALPHA16 フィールド

public const UInt32 ALPHA16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA4

Steema.TeeChart.Drawing.GL.Imports.ALPHA4 フィールド

public const UInt32 ALPHA4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALPHA8

Steema.TeeChart.Drawing.GL.Imports.ALPHA8 フィールド

public const UInt32 ALPHA8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ALWAYS

Steema.TeeChart.Drawing.GL.Imports.ALWAYS フィールド

public const UInt32 ALWAYS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AMBIENT

Steema.TeeChart.Drawing.GL.Imports.AMBIENT フィールド

public const UInt32 AMBIENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AMBIENT_AND_DIFFUSE

Steema.TeeChart.Drawing.GL.Imports.AMBIENT_AND_DIFFUSE フィールド

public const UInt32 AMBIENT_AND_DIFFUSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AND

Steema.TeeChart.Drawing.GL.Imports.AND フィールド

public const UInt32 AND

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AND_INVERTED

Steema.TeeChart.Drawing.GL.Imports.AND_INVERTED フィールド

public const UInt32 AND_INVERTED

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AND_REVERSE

Steema.TeeChart.Drawing.GL.Imports.AND_REVERSE フィールド

public const UInt32 AND_REVERSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ATTRIB_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.ATTRIB_STACK_DEPTH フィールド

public const UInt32 ATTRIB_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUTO_NORMAL

Steema.TeeChart.Drawing.GL.Imports.AUTO_NORMAL フィールド

public const UInt32 AUTO_NORMAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUX_BUFFERS

Steema.TeeChart.Drawing.GL.Imports.AUX_BUFFERS フィールド

public const UInt32 AUX_BUFFERS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUX0

Steema.TeeChart.Drawing.GL.Imports.AUX0 フィールド

public const UInt32 AUX0

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUX1

Steema.TeeChart.Drawing.GL.Imports.AUX1 フィールド

public const UInt32 AUX1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUX2

Steema.TeeChart.Drawing.GL.Imports.AUX2 フィールド

public const UInt32 AUX2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


AUX3

Steema.TeeChart.Drawing.GL.Imports.AUX3 フィールド

public const UInt32 AUX3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BACK

Steema.TeeChart.Drawing.GL.Imports.BACK フィールド

public const UInt32 BACK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BACK_LEFT

Steema.TeeChart.Drawing.GL.Imports.BACK_LEFT フィールド

public const UInt32 BACK_LEFT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BACK_RIGHT

Steema.TeeChart.Drawing.GL.Imports.BACK_RIGHT フィールド

public const UInt32 BACK_RIGHT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BGR_EXT

Steema.TeeChart.Drawing.GL.Imports.BGR_EXT フィールド

public const UInt32 BGR_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BGRA_EXT

Steema.TeeChart.Drawing.GL.Imports.BGRA_EXT フィールド

public const UInt32 BGRA_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_BIT フィールド

Steema.TeeChart.Drawing.GL.Imports.BI_BITFIELDS フィールド

protected UInt32 BI_BITFIELDS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_JPEG

Steema.TeeChart.Drawing.GL.Imports.BI_JPEG フィールド

protected UInt32 BI_JPEG

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_PNG

Steema.TeeChart.Drawing.GL.Imports.BI_PNG フィールド

protected UInt32 BI_PNG

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_RGB

Steema.TeeChart.Drawing.GL.Imports.BI_RGB フィールド

protected UInt32 BI_RGB

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_RLE4

Steema.TeeChart.Drawing.GL.Imports.BI_RLE4 フィールド

protected UInt32 BI_RLE4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BI_RLE8

Steema.TeeChart.Drawing.GL.Imports.BI_RLE8 フィールド

protected UInt32 BI_RLE8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BITMAP

Steema.TeeChart.Drawing.GL.Imports.BITMAP フィールド

public const UInt32 BITMAP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BITMAP_TOKEN

Steema.TeeChart.Drawing.GL.Imports.BITMAP_TOKEN フィールド

public const UInt32 BITMAP_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLACKNESS

Steema.TeeChart.Drawing.GL.Imports.BLACKNESS フィールド

protected const UInt32 BLACKNESS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLEND

Steema.TeeChart.Drawing.GL.Imports.BLEND フィールド

public const UInt32 BLEND

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLEND_DST

Steema.TeeChart.Drawing.GL.Imports.BLEND_DST フィールド

public const UInt32 BLEND_DST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLEND_SRC

Steema.TeeChart.Drawing.GL.Imports.BLEND_SRC フィールド

public const UInt32 BLEND_SRC

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLUE

Steema.TeeChart.Drawing.GL.Imports.BLUE フィールド

public const UInt32 BLUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLUE_BIAS

Steema.TeeChart.Drawing.GL.Imports.BLUE_BIAS フィールド

public const UInt32 BLUE_BIAS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLUE_BITS

Steema.TeeChart.Drawing.GL.Imports.BLUE_BITS フィールド

public const UInt32 BLUE_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BLUE_SCALE

Steema.TeeChart.Drawing.GL.Imports.BLUE_SCALE フィールド

public const UInt32 BLUE_SCALE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


BYTE

Steema.TeeChart.Drawing.GL.Imports.BYTE フィールド

public const UInt32 BYTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


C3F_V3F

Steema.TeeChart.Drawing.GL.Imports.C3F_V3F フィールド

public const UInt32 C3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


C4F_N3F_V3F

Steema.TeeChart.Drawing.GL.Imports.C4F_N3F_V3F フィールド

public const UInt32 C4F_N3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


C4UB_V2F

Steema.TeeChart.Drawing.GL.Imports.C4UB_V2F フィールド

public const UInt32 C4UB_V2F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


C4UB_V3F

Steema.TeeChart.Drawing.GL.Imports.C4UB_V3F フィールド

public const UInt32 C4UB_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CCW

Steema.TeeChart.Drawing.GL.Imports.CCW フィールド

public const UInt32 CCW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLAMP

Steema.TeeChart.Drawing.GL.Imports.CLAMP フィールド

public const UInt32 CLAMP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLEAR

Steema.TeeChart.Drawing.GL.Imports.CLEAR フィールド

public const UInt32 CLEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIENT_ALL_ATTRIB_BITS

Steema.TeeChart.Drawing.GL.Imports.CLIENT_ALL_ATTRIB_BITS フィールド

public const UInt32 CLIENT_ALL_ATTRIB_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIENT_ATTRIB_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.CLIENT_ATTRIB_STACK_DEPTH フィールド

public const UInt32 CLIENT_ATTRIB_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIENT_PIXEL_STORE_BIT

Steema.TeeChart.Drawing.GL.Imports.CLIENT_PIXEL_STORE_BIT フィールド

public const UInt32 CLIENT_PIXEL_STORE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIENT_VERTEX_ARRAY_BIT

Steema.TeeChart.Drawing.GL.Imports.CLIENT_VERTEX_ARRAY_BIT フィールド

public const UInt32 CLIENT_VERTEX_ARRAY_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE0

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE0 フィールド

public const UInt32 CLIP_PLANE0

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE1

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE1 フィールド

public const UInt32 CLIP_PLANE1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE2

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE2 フィールド

public const UInt32 CLIP_PLANE2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE3

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE3 フィールド

public const UInt32 CLIP_PLANE3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE4

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE4 フィールド

public const UInt32 CLIP_PLANE4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CLIP_PLANE5

Steema.TeeChart.Drawing.GL.Imports.CLIP_PLANE5 フィールド

public const UInt32 CLIP_PLANE5

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COEFF

Steema.TeeChart.Drawing.GL.Imports.COEFF フィールド

public const UInt32 COEFF

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR

Steema.TeeChart.Drawing.GL.Imports.COLOR フィールド

public const UInt32 COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY フィールド

public const UInt32 COLOR_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_COUNT_EXT フィールド

public const UInt32 COLOR_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_EXT フィールド

public const UInt32 COLOR_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_POINTER フィールド

public const UInt32 COLOR_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_POINTER_EXT フィールド

public const UInt32 COLOR_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_SIZE

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_SIZE フィールド

public const UInt32 COLOR_ARRAY_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_SIZE_EXT フィールド

public const UInt32 COLOR_ARRAY_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_STRIDE フィールド

public const UInt32 COLOR_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_STRIDE_EXT フィールド

public const UInt32 COLOR_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_TYPE

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_TYPE フィールド

public const UInt32 COLOR_ARRAY_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_ARRAY_TYPE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_ARRAY_TYPE_EXT フィールド

public const UInt32 COLOR_ARRAY_TYPE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_BUFFER_BIT

Steema.TeeChart.Drawing.GL.Imports.COLOR_BUFFER_BIT フィールド

public const UInt32 COLOR_BUFFER_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_CLEAR_VALUE

Steema.TeeChart.Drawing.GL.Imports.COLOR_CLEAR_VALUE フィールド

public const UInt32 COLOR_CLEAR_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX フィールド

public const UInt32 COLOR_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX1_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX1_EXT フィールド

public const UInt32 COLOR_INDEX1_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX12_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX12_EXT フィールド

public const UInt32 COLOR_INDEX12_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX16_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX16_EXT フィールド

public const UInt32 COLOR_INDEX16_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX2_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX2_EXT フィールド

public const UInt32 COLOR_INDEX2_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX4_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX4_EXT フィールド

public const UInt32 COLOR_INDEX4_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEX8_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEX8_EXT フィールド

public const UInt32 COLOR_INDEX8_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_INDEXES

Steema.TeeChart.Drawing.GL.Imports.COLOR_INDEXES フィールド

public const UInt32 COLOR_INDEXES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_LOGIC_OP

Steema.TeeChart.Drawing.GL.Imports.COLOR_LOGIC_OP フィールド

public const UInt32 COLOR_LOGIC_OP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_MATERIAL

Steema.TeeChart.Drawing.GL.Imports.COLOR_MATERIAL フィールド

public const UInt32 COLOR_MATERIAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_MATERIAL_FACE

Steema.TeeChart.Drawing.GL.Imports.COLOR_MATERIAL_FACE フィールド

public const UInt32 COLOR_MATERIAL_FACE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_MATERIAL_PARAMETER

Steema.TeeChart.Drawing.GL.Imports.COLOR_MATERIAL_PARAMETER フィールド

public const UInt32 COLOR_MATERIAL_PARAMETER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_ALPHA_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_ALPHA_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_ALPHA_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_BLUE_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_BLUE_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_BLUE_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_FORMAT_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_FORMAT_EXT フィールド

public const UInt32 COLOR_TABLE_FORMAT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_GREEN_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_GREEN_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_GREEN_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_INTENSITY_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_INTENSITY_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_INTENSITY_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_LUMINANCE_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_LUMINANCE_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_LUMINANCE_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_RED_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_RED_SIZE_EXT フィールド

public const UInt32 COLOR_TABLE_RED_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_TABLE_WIDTH_EXT

Steema.TeeChart.Drawing.GL.Imports.COLOR_TABLE_WIDTH_EXT フィールド

public const UInt32 COLOR_TABLE_WIDTH_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COLOR_WRITEMASK

Steema.TeeChart.Drawing.GL.Imports.COLOR_WRITEMASK フィールド

public const UInt32 COLOR_WRITEMASK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COMPILE

Steema.TeeChart.Drawing.GL.Imports.COMPILE フィールド

public const UInt32 COMPILE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COMPILE_AND_EXECUTE

Steema.TeeChart.Drawing.GL.Imports.COMPILE_AND_EXECUTE フィールド

public const UInt32 COMPILE_AND_EXECUTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CONSTANT_ATTENUATION

Steema.TeeChart.Drawing.GL.Imports.CONSTANT_ATTENUATION フィールド

public const UInt32 CONSTANT_ATTENUATION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COPY

Steema.TeeChart.Drawing.GL.Imports.COPY フィールド

public const UInt32 COPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COPY_INVERTED

Steema.TeeChart.Drawing.GL.Imports.COPY_INVERTED フィールド

public const UInt32 COPY_INVERTED

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


COPY_PIXEL_TOKEN

Steema.TeeChart.Drawing.GL.Imports.COPY_PIXEL_TOKEN フィールド

public const UInt32 COPY_PIXEL_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CULL_FACE

Steema.TeeChart.Drawing.GL.Imports.CULL_FACE フィールド

public const UInt32 CULL_FACE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CULL_FACE_MODE

Steema.TeeChart.Drawing.GL.Imports.CULL_FACE_MODE フィールド

public const UInt32 CULL_FACE_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_BIT

Steema.TeeChart.Drawing.GL.Imports.CURRENT_BIT フィールド

public const UInt32 CURRENT_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_COLOR

Steema.TeeChart.Drawing.GL.Imports.CURRENT_COLOR フィールド

public const UInt32 CURRENT_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_INDEX

Steema.TeeChart.Drawing.GL.Imports.CURRENT_INDEX フィールド

public const UInt32 CURRENT_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_NORMAL

Steema.TeeChart.Drawing.GL.Imports.CURRENT_NORMAL フィールド

public const UInt32 CURRENT_NORMAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_COLOR

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_COLOR フィールド

public const UInt32 CURRENT_RASTER_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_DISTANCE

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_DISTANCE フィールド

public const UInt32 CURRENT_RASTER_DISTANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_INDEX

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_INDEX フィールド

public const UInt32 CURRENT_RASTER_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_POSITION

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_POSITION フィールド

public const UInt32 CURRENT_RASTER_POSITION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_POSITION_VALID

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_POSITION_VALID フィールド

public const UInt32 CURRENT_RASTER_POSITION_VALID

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_RASTER_TEXTURE_COORDS

Steema.TeeChart.Drawing.GL.Imports.CURRENT_RASTER_TEXTURE_COORDS フィールド

public const UInt32 CURRENT_RASTER_TEXTURE_COORDS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CURRENT_TEXTURE_COORDS

Steema.TeeChart.Drawing.GL.Imports.CURRENT_TEXTURE_COORDS フィールド

public const UInt32 CURRENT_TEXTURE_COORDS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CW

Steema.TeeChart.Drawing.GL.Imports.CW フィールド

public const UInt32 CW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DECAL

Steema.TeeChart.Drawing.GL.Imports.DECAL フィールド

public const UInt32 DECAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DECR

Steema.TeeChart.Drawing.GL.Imports.DECR フィールド

public const UInt32 DECR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH

Steema.TeeChart.Drawing.GL.Imports.DEPTH フィールド

public const UInt32 DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_BIAS

Steema.TeeChart.Drawing.GL.Imports.DEPTH_BIAS フィールド

public const UInt32 DEPTH_BIAS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_BITS

Steema.TeeChart.Drawing.GL.Imports.DEPTH_BITS フィールド

public const UInt32 DEPTH_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_BUFFER_BIT

Steema.TeeChart.Drawing.GL.Imports.DEPTH_BUFFER_BIT フィールド

public const UInt32 DEPTH_BUFFER_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_CLEAR_VALUE

Steema.TeeChart.Drawing.GL.Imports.DEPTH_CLEAR_VALUE フィールド

public const UInt32 DEPTH_CLEAR_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_COMPONENT

Steema.TeeChart.Drawing.GL.Imports.DEPTH_COMPONENT フィールド

public const UInt32 DEPTH_COMPONENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_FUNC

Steema.TeeChart.Drawing.GL.Imports.DEPTH_FUNC フィールド

public const UInt32 DEPTH_FUNC

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_RANGE

Steema.TeeChart.Drawing.GL.Imports.DEPTH_RANGE フィールド

public const UInt32 DEPTH_RANGE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_SCALE

Steema.TeeChart.Drawing.GL.Imports.DEPTH_SCALE フィールド

public const UInt32 DEPTH_SCALE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_TEST

Steema.TeeChart.Drawing.GL.Imports.DEPTH_TEST フィールド

public const UInt32 DEPTH_TEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DEPTH_WRITEMASK

Steema.TeeChart.Drawing.GL.Imports.DEPTH_WRITEMASK フィールド

public const UInt32 DEPTH_WRITEMASK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DIB_PAL_COLORS

Steema.TeeChart.Drawing.GL.Imports.DIB_PAL_COLORS フィールド

protected UInt32 DIB_PAL_COLORS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DIB_RGB_COLORS

Steema.TeeChart.Drawing.GL.Imports.DIB_RGB_COLORS フィールド

protected UInt32 DIB_RGB_COLORS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DIFFUSE

Steema.TeeChart.Drawing.GL.Imports.DIFFUSE フィールド

public const UInt32 DIFFUSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DITHER

Steema.TeeChart.Drawing.GL.Imports.DITHER フィールド

public const UInt32 DITHER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DOMAIN

Steema.TeeChart.Drawing.GL.Imports.DOMAIN フィールド

public const UInt32 DOMAIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DONT_CARE

Steema.TeeChart.Drawing.GL.Imports.DONT_CARE フィールド

public const UInt32 DONT_CARE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DOUBLE

Steema.TeeChart.Drawing.GL.Imports.DOUBLE フィールド

public const UInt32 DOUBLE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DOUBLE_EXT

Steema.TeeChart.Drawing.GL.Imports.DOUBLE_EXT フィールド

public const UInt32 DOUBLE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DOUBLEBUFFER

Steema.TeeChart.Drawing.GL.Imports.DOUBLEBUFFER フィールド

public const UInt32 DOUBLEBUFFER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DRAW_BUFFER

Steema.TeeChart.Drawing.GL.Imports.DRAW_BUFFER フィールド

public const UInt32 DRAW_BUFFER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DRAW_PIXEL_TOKEN

Steema.TeeChart.Drawing.GL.Imports.DRAW_PIXEL_TOKEN フィールド

public const UInt32 DRAW_PIXEL_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DST_ALPHA

Steema.TeeChart.Drawing.GL.Imports.DST_ALPHA フィールド

public const UInt32 DST_ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DST_COLOR

Steema.TeeChart.Drawing.GL.Imports.DST_COLOR フィールド

public const UInt32 DST_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DSTINVERT

Steema.TeeChart.Drawing.GL.Imports.DSTINVERT フィールド

protected const UInt32 DSTINVERT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG フィールド

public const UInt32 EDGE_FLAG

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY フィールド

public const UInt32 EDGE_FLAG_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_COUNT_EXT フィールド

public const UInt32 EDGE_FLAG_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_EXT フィールド

public const UInt32 EDGE_FLAG_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_POINTER フィールド

public const UInt32 EDGE_FLAG_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_POINTER_EXT フィールド

public const UInt32 EDGE_FLAG_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_STRIDE フィールド

public const UInt32 EDGE_FLAG_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EDGE_FLAG_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.EDGE_FLAG_ARRAY_STRIDE_EXT フィールド

public const UInt32 EDGE_FLAG_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EMISSION

Steema.TeeChart.Drawing.GL.Imports.EMISSION フィールド

public const UInt32 EMISSION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ENABLE_BIT

Steema.TeeChart.Drawing.GL.Imports.ENABLE_BIT フィールド

public const UInt32 ENABLE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EQUAL

Steema.TeeChart.Drawing.GL.Imports.EQUAL フィールド

public const UInt32 EQUAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EQUIV

Steema.TeeChart.Drawing.GL.Imports.EQUIV フィールド

public const UInt32 EQUIV

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EVAL_BIT

Steema.TeeChart.Drawing.GL.Imports.EVAL_BIT フィールド

public const UInt32 EVAL_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXP

Steema.TeeChart.Drawing.GL.Imports.EXP フィールド

public const UInt32 EXP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXP2

Steema.TeeChart.Drawing.GL.Imports.EXP2 フィールド

public const UInt32 EXP2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXT_bgra

Steema.TeeChart.Drawing.GL.Imports.EXT_bgra フィールド

public const UInt32 EXT_bgra

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXT_paletted_texture

Steema.TeeChart.Drawing.GL.Imports.EXT_paletted_texture フィールド

public const UInt32 EXT_paletted_texture

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXT_vertex_array

Steema.TeeChart.Drawing.GL.Imports.EXT_vertex_array フィールド

public const UInt32 EXT_vertex_array

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EXTENSIONS

Steema.TeeChart.Drawing.GL.Imports.EXTENSIONS フィールド

public const UInt32 EXTENSIONS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EYE_LINEAR

Steema.TeeChart.Drawing.GL.Imports.EYE_LINEAR フィールド

public const UInt32 EYE_LINEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


EYE_PLANE

Steema.TeeChart.Drawing.GL.Imports.EYE_PLANE フィールド

public const UInt32 EYE_PLANE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FALSE

Steema.TeeChart.Drawing.GL.Imports.FALSE フィールド

public const UInt32 FALSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FASTEST

Steema.TeeChart.Drawing.GL.Imports.FASTEST フィールド

public const UInt32 FASTEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FEEDBACK

Steema.TeeChart.Drawing.GL.Imports.FEEDBACK フィールド

public const UInt32 FEEDBACK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FEEDBACK_BUFFER_POINTER

Steema.TeeChart.Drawing.GL.Imports.FEEDBACK_BUFFER_POINTER フィールド

public const UInt32 FEEDBACK_BUFFER_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FEEDBACK_BUFFER_SIZE

Steema.TeeChart.Drawing.GL.Imports.FEEDBACK_BUFFER_SIZE フィールド

public const UInt32 FEEDBACK_BUFFER_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FEEDBACK_BUFFER_TYPE

Steema.TeeChart.Drawing.GL.Imports.FEEDBACK_BUFFER_TYPE フィールド

public const UInt32 FEEDBACK_BUFFER_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FILL

Steema.TeeChart.Drawing.GL.Imports.FILL フィールド

public const UInt32 FILL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FLAT

Steema.TeeChart.Drawing.GL.Imports.FLAT フィールド

public const UInt32 FLAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FLOAT

Steema.TeeChart.Drawing.GL.Imports.FLOAT フィールド

public const UInt32 FLOAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG

Steema.TeeChart.Drawing.GL.Imports.FOG フィールド

public const UInt32 FOG

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_BIT

Steema.TeeChart.Drawing.GL.Imports.FOG_BIT フィールド

public const UInt32 FOG_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_COLOR

Steema.TeeChart.Drawing.GL.Imports.FOG_COLOR フィールド

public const UInt32 FOG_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_DENSITY

Steema.TeeChart.Drawing.GL.Imports.FOG_DENSITY フィールド

public const UInt32 FOG_DENSITY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_END

Steema.TeeChart.Drawing.GL.Imports.FOG_END フィールド

public const UInt32 FOG_END

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_HINT

Steema.TeeChart.Drawing.GL.Imports.FOG_HINT フィールド

public const UInt32 FOG_HINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_INDEX

Steema.TeeChart.Drawing.GL.Imports.FOG_INDEX フィールド

public const UInt32 FOG_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_MODE

Steema.TeeChart.Drawing.GL.Imports.FOG_MODE フィールド

public const UInt32 FOG_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_SPECULAR_TEXTURE_WIN

Steema.TeeChart.Drawing.GL.Imports.FOG_SPECULAR_TEXTURE_WIN フィールド

protected internal UInt32 FOG_SPECULAR_TEXTURE_WIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FOG_START

Steema.TeeChart.Drawing.GL.Imports.FOG_START フィールド

public const UInt32 FOG_START

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FRONT

Steema.TeeChart.Drawing.GL.Imports.FRONT フィールド

public const UInt32 FRONT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FRONT_AND_BACK

Steema.TeeChart.Drawing.GL.Imports.FRONT_AND_BACK フィールド

public const UInt32 FRONT_AND_BACK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FRONT_FACE

Steema.TeeChart.Drawing.GL.Imports.FRONT_FACE フィールド

public const UInt32 FRONT_FACE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FRONT_LEFT

Steema.TeeChart.Drawing.GL.Imports.FRONT_LEFT フィールド

public const UInt32 FRONT_LEFT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


FRONT_RIGHT

Steema.TeeChart.Drawing.GL.Imports.FRONT_RIGHT フィールド

public const UInt32 FRONT_RIGHT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GEQUAL

Steema.TeeChart.Drawing.GL.Imports.GEQUAL フィールド

public const UInt32 GEQUAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_2_BYTES

Steema.TeeChart.Drawing.GL.Imports.GL_2_BYTES フィールド

public const UInt32 GL_2_BYTES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_2D

Steema.TeeChart.Drawing.GL.Imports.GL_2D フィールド

public const UInt32 GL_2D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_3_BYTES

Steema.TeeChart.Drawing.GL.Imports.GL_3_BYTES フィールド

public const UInt32 GL_3_BYTES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_3D

Steema.TeeChart.Drawing.GL.Imports.GL_3D フィールド

public const UInt32 GL_3D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_3D_COLOR_TEXTURE

Steema.TeeChart.Drawing.GL.Imports.GL_3D_COLOR_TEXTURE フィールド

public const UInt32 GL_3D_COLOR_TEXTURE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_4_BYTES

Steema.TeeChart.Drawing.GL.Imports.GL_4_BYTES フィールド

public const UInt32 GL_4_BYTES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_4D_COLOR

Steema.TeeChart.Drawing.GL.Imports.GL_4D_COLOR フィールド

public const UInt32 GL_4D_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GL_4D_COLOR_TEXTURE

Steema.TeeChart.Drawing.GL.Imports.GL_4D_COLOR_TEXTURE フィールド

public const UInt32 GL_4D_COLOR_TEXTURE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_AUTO_LOAD_MATRIX

Steema.TeeChart.Drawing.GL.Imports.GLU_AUTO_LOAD_MATRIX フィールド

public const UInt32 GLU_AUTO_LOAD_MATRIX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_CULLING

Steema.TeeChart.Drawing.GL.Imports.GLU_CULLING フィールド

public const UInt32 GLU_CULLING

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_DISPLAY_MODE

Steema.TeeChart.Drawing.GL.Imports.GLU_DISPLAY_MODE フィールド

public const UInt32 GLU_DISPLAY_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_DOMAIN_DISTANCE

Steema.TeeChart.Drawing.GL.Imports.GLU_DOMAIN_DISTANCE フィールド

public const UInt32 GLU_DOMAIN_DISTANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_EXTENSIONS

Steema.TeeChart.Drawing.GL.Imports.GLU_EXTENSIONS フィールド

public const UInt32 GLU_EXTENSIONS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_FALSE

Steema.TeeChart.Drawing.GL.Imports.GLU_FALSE フィールド

public const UInt32 GLU_FALSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_FILL

Steema.TeeChart.Drawing.GL.Imports.GLU_FILL フィールド

public const UInt32 GLU_FILL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_FLAT

Steema.TeeChart.Drawing.GL.Imports.GLU_FLAT フィールド

public const UInt32 GLU_FLAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_INCOMPATIBLE_GL_VERSION

Steema.TeeChart.Drawing.GL.Imports.GLU_INCOMPATIBLE_GL_VERSION フィールド

public const UInt32 GLU_INCOMPATIBLE_GL_VERSION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_INSIDE

Steema.TeeChart.Drawing.GL.Imports.GLU_INSIDE フィールド

public const UInt32 GLU_INSIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_INVALID_ENUM

Steema.TeeChart.Drawing.GL.Imports.GLU_INVALID_ENUM フィールド

public const UInt32 GLU_INVALID_ENUM

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_INVALID_VALUE

Steema.TeeChart.Drawing.GL.Imports.GLU_INVALID_VALUE フィールド

public const UInt32 GLU_INVALID_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_LINE

Steema.TeeChart.Drawing.GL.Imports.GLU_LINE フィールド

public const UInt32 GLU_LINE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_MAP1_TRIM_2

Steema.TeeChart.Drawing.GL.Imports.GLU_MAP1_TRIM_2 フィールド

public const UInt32 GLU_MAP1_TRIM_2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_MAP1_TRIM_3

Steema.TeeChart.Drawing.GL.Imports.GLU_MAP1_TRIM_3 フィールド

public const UInt32 GLU_MAP1_TRIM_3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NONE

Steema.TeeChart.Drawing.GL.Imports.GLU_NONE フィールド

public const UInt32 GLU_NONE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR1

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR1 フィールド

public const UInt32 GLU_NURBS_ERROR1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR10

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR10 フィールド

public const UInt32 GLU_NURBS_ERROR10

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR11

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR11 フィールド

public const UInt32 GLU_NURBS_ERROR11

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR12

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR12 フィールド

public const UInt32 GLU_NURBS_ERROR12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR13

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR13 フィールド

public const UInt32 GLU_NURBS_ERROR13

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR14

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR14 フィールド

public const UInt32 GLU_NURBS_ERROR14

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR15

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR15 フィールド

public const UInt32 GLU_NURBS_ERROR15

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR16

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR16 フィールド

public const UInt32 GLU_NURBS_ERROR16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR17

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR17 フィールド

public const UInt32 GLU_NURBS_ERROR17

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR18

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR18 フィールド

public const UInt32 GLU_NURBS_ERROR18

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR19

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR19 フィールド

public const UInt32 GLU_NURBS_ERROR19

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR2

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR2 フィールド

public const UInt32 GLU_NURBS_ERROR2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR20

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR20 フィールド

public const UInt32 GLU_NURBS_ERROR20

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR21

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR21 フィールド

public const UInt32 GLU_NURBS_ERROR21

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR22

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR22 フィールド

public const UInt32 GLU_NURBS_ERROR22

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR23

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR23 フィールド

public const UInt32 GLU_NURBS_ERROR23

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR24

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR24 フィールド

public const UInt32 GLU_NURBS_ERROR24

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR25

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR25 フィールド

public const UInt32 GLU_NURBS_ERROR25

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR26

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR26 フィールド

public const UInt32 GLU_NURBS_ERROR26

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR27

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR27 フィールド

public const UInt32 GLU_NURBS_ERROR27

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR28

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR28 フィールド

public const UInt32 GLU_NURBS_ERROR28

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR29

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR29 フィールド

public const UInt32 GLU_NURBS_ERROR29

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR3

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR3 フィールド

public const UInt32 GLU_NURBS_ERROR3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR30

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR30 フィールド

public const UInt32 GLU_NURBS_ERROR30

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR31

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR31 フィールド

public const UInt32 GLU_NURBS_ERROR31

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR32

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR32 フィールド

public const UInt32 GLU_NURBS_ERROR32

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR33

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR33 フィールド

public const UInt32 GLU_NURBS_ERROR33

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR34

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR34 フィールド

public const UInt32 GLU_NURBS_ERROR34

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR35

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR35 フィールド

public const UInt32 GLU_NURBS_ERROR35

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR36

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR36 フィールド

public const UInt32 GLU_NURBS_ERROR36

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR37

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR37 フィールド

public const UInt32 GLU_NURBS_ERROR37

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR4

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR4 フィールド

public const UInt32 GLU_NURBS_ERROR4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR5

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR5 フィールド

public const UInt32 GLU_NURBS_ERROR5

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR6

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR6 フィールド

public const UInt32 GLU_NURBS_ERROR6

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR7

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR7 フィールド

public const UInt32 GLU_NURBS_ERROR7

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR8

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR8 フィールド

public const UInt32 GLU_NURBS_ERROR8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_NURBS_ERROR9

Steema.TeeChart.Drawing.GL.Imports.GLU_NURBS_ERROR9 フィールド

public const UInt32 GLU_NURBS_ERROR9

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_OUT_OF_MEMORY

Steema.TeeChart.Drawing.GL.Imports.GLU_OUT_OF_MEMORY フィールド

public const UInt32 GLU_OUT_OF_MEMORY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_OUTLINE_PATCH

Steema.TeeChart.Drawing.GL.Imports.GLU_OUTLINE_PATCH フィールド

public const UInt32 GLU_OUTLINE_PATCH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_OUTLINE_POLYGON

Steema.TeeChart.Drawing.GL.Imports.GLU_OUTLINE_POLYGON フィールド

public const UInt32 GLU_OUTLINE_POLYGON

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_OUTSIDE

Steema.TeeChart.Drawing.GL.Imports.GLU_OUTSIDE フィールド

public const UInt32 GLU_OUTSIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_PARAMETRIC_ERROR

Steema.TeeChart.Drawing.GL.Imports.GLU_PARAMETRIC_ERROR フィールド

public const UInt32 GLU_PARAMETRIC_ERROR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_PARAMETRIC_TOLERANCE

Steema.TeeChart.Drawing.GL.Imports.GLU_PARAMETRIC_TOLERANCE フィールド

public const UInt32 GLU_PARAMETRIC_TOLERANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_PATH_LENGTH

Steema.TeeChart.Drawing.GL.Imports.GLU_PATH_LENGTH フィールド

public const UInt32 GLU_PATH_LENGTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_POINT

Steema.TeeChart.Drawing.GL.Imports.GLU_POINT フィールド

public const UInt32 GLU_POINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_SAMPLING_METHOD

Steema.TeeChart.Drawing.GL.Imports.GLU_SAMPLING_METHOD フィールド

public const UInt32 GLU_SAMPLING_METHOD

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_SAMPLING_TOLERANCE

Steema.TeeChart.Drawing.GL.Imports.GLU_SAMPLING_TOLERANCE フィールド

public const UInt32 GLU_SAMPLING_TOLERANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_SILHOUETTE

Steema.TeeChart.Drawing.GL.Imports.GLU_SILHOUETTE フィールド

public const UInt32 GLU_SILHOUETTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_SMOOTH

Steema.TeeChart.Drawing.GL.Imports.GLU_SMOOTH フィールド

public const UInt32 GLU_SMOOTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_BEGIN

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_BEGIN フィールド

public const UInt32 GLU_TESS_BEGIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_BEGIN_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_BEGIN_DATA フィールド

public const UInt32 GLU_TESS_BEGIN_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_BOUNDARY_ONLY

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_BOUNDARY_ONLY フィールド

public const UInt32 GLU_TESS_BOUNDARY_ONLY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_COMBINE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_COMBINE フィールド

public const UInt32 GLU_TESS_COMBINE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_COMBINE_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_COMBINE_DATA フィールド

public const UInt32 GLU_TESS_COMBINE_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_COORD_TOO_LARGE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_COORD_TOO_LARGE フィールド

public const UInt32 GLU_TESS_COORD_TOO_LARGE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_EDGE_FLAG

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_EDGE_FLAG フィールド

public const UInt32 GLU_TESS_EDGE_FLAG

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_EDGE_FLAG_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_EDGE_FLAG_DATA フィールド

public const UInt32 GLU_TESS_EDGE_FLAG_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_END

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_END フィールド

public const UInt32 GLU_TESS_END

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_END_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_END_DATA フィールド

public const UInt32 GLU_TESS_END_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR フィールド

public const UInt32 GLU_TESS_ERROR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR_DATA フィールド

public const UInt32 GLU_TESS_ERROR_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR1

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR1 フィールド

public const UInt32 GLU_TESS_ERROR1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR2

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR2 フィールド

public const UInt32 GLU_TESS_ERROR2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR3

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR3 フィールド

public const UInt32 GLU_TESS_ERROR3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR4

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR4 フィールド

public const UInt32 GLU_TESS_ERROR4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR5

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR5 フィールド

public const UInt32 GLU_TESS_ERROR5

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR6

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR6 フィールド

public const UInt32 GLU_TESS_ERROR6

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR7

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR7 フィールド

public const UInt32 GLU_TESS_ERROR7

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_ERROR8

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_ERROR8 フィールド

public const UInt32 GLU_TESS_ERROR8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_MAX_COORD

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_MAX_COORD フィールド

public const Double GLU_TESS_MAX_COORD

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_MISSING_BEGIN_CONTOUR

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_MISSING_BEGIN_CONTOUR フィールド

public const UInt32 GLU_TESS_MISSING_BEGIN_CONTOUR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_MISSING_BEGIN_POLYGON

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_MISSING_BEGIN_POLYGON フィールド

public const UInt32 GLU_TESS_MISSING_BEGIN_POLYGON

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_MISSING_END_CONTOUR

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_MISSING_END_CONTOUR フィールド

public const UInt32 GLU_TESS_MISSING_END_CONTOUR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_MISSING_END_POLYGON

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_MISSING_END_POLYGON フィールド

public const UInt32 GLU_TESS_MISSING_END_POLYGON

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_NEED_COMBINE_CALLBACK

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_NEED_COMBINE_CALLBACK フィールド

public const UInt32 GLU_TESS_NEED_COMBINE_CALLBACK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_TOLERANCE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_TOLERANCE フィールド

public const UInt32 GLU_TESS_TOLERANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_VERTEX

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_VERTEX フィールド

public const UInt32 GLU_TESS_VERTEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_VERTEX_DATA

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_VERTEX_DATA フィールド

public const UInt32 GLU_TESS_VERTEX_DATA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_ABS_GEQ_TWO

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_ABS_GEQ_TWO フィールド

public const UInt32 GLU_TESS_WINDING_ABS_GEQ_TWO

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_NEGATIVE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_NEGATIVE フィールド

public const UInt32 GLU_TESS_WINDING_NEGATIVE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_NONZERO

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_NONZERO フィールド

public const UInt32 GLU_TESS_WINDING_NONZERO

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_ODD

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_ODD フィールド

public const UInt32 GLU_TESS_WINDING_ODD

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_POSITIVE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_POSITIVE フィールド

public const UInt32 GLU_TESS_WINDING_POSITIVE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TESS_WINDING_RULE

Steema.TeeChart.Drawing.GL.Imports.GLU_TESS_WINDING_RULE フィールド

public const UInt32 GLU_TESS_WINDING_RULE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_TRUE

Steema.TeeChart.Drawing.GL.Imports.GLU_TRUE フィールド

public const UInt32 GLU_TRUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_U_STEP

Steema.TeeChart.Drawing.GL.Imports.GLU_U_STEP フィールド

public const UInt32 GLU_U_STEP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_V_STEP

Steema.TeeChart.Drawing.GL.Imports.GLU_V_STEP フィールド

public const UInt32 GLU_V_STEP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_VERSION

Steema.TeeChart.Drawing.GL.Imports.GLU_VERSION フィールド

public const UInt32 GLU_VERSION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_VERSION_1_1

Steema.TeeChart.Drawing.GL.Imports.GLU_VERSION_1_1 フィールド

public const UInt32 GLU_VERSION_1_1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLU_VERSION_1_2

Steema.TeeChart.Drawing.GL.Imports.GLU_VERSION_1_2 フィールド

public const UInt32 GLU_VERSION_1_2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GREATER

Steema.TeeChart.Drawing.GL.Imports.GREATER フィールド

public const UInt32 GREATER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GREEN

Steema.TeeChart.Drawing.GL.Imports.GREEN フィールド

public const UInt32 GREEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GREEN_BIAS

Steema.TeeChart.Drawing.GL.Imports.GREEN_BIAS フィールド

public const UInt32 GREEN_BIAS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GREEN_BITS

Steema.TeeChart.Drawing.GL.Imports.GREEN_BITS フィールド

public const UInt32 GREEN_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GREEN_SCALE

Steema.TeeChart.Drawing.GL.Imports.GREEN_SCALE フィールド

public const UInt32 GREEN_SCALE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


HINT_BIT

Steema.TeeChart.Drawing.GL.Imports.HINT_BIT フィールド

public const UInt32 HINT_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INCR

Steema.TeeChart.Drawing.GL.Imports.INCR フィールド

public const UInt32 INCR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY フィールド

public const UInt32 INDEX_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_COUNT_EXT フィールド

public const UInt32 INDEX_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_EXT フィールド

public const UInt32 INDEX_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_POINTER フィールド

public const UInt32 INDEX_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_POINTER_EXT フィールド

public const UInt32 INDEX_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_STRIDE フィールド

public const UInt32 INDEX_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_STRIDE_EXT フィールド

public const UInt32 INDEX_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_TYPE

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_TYPE フィールド

public const UInt32 INDEX_ARRAY_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_ARRAY_TYPE_EXT

Steema.TeeChart.Drawing.GL.Imports.INDEX_ARRAY_TYPE_EXT フィールド

public const UInt32 INDEX_ARRAY_TYPE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_BITS

Steema.TeeChart.Drawing.GL.Imports.INDEX_BITS フィールド

public const UInt32 INDEX_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_CLEAR_VALUE

Steema.TeeChart.Drawing.GL.Imports.INDEX_CLEAR_VALUE フィールド

public const UInt32 INDEX_CLEAR_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_LOGIC_OP

Steema.TeeChart.Drawing.GL.Imports.INDEX_LOGIC_OP フィールド

public const UInt32 INDEX_LOGIC_OP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_MODE

Steema.TeeChart.Drawing.GL.Imports.INDEX_MODE フィールド

public const UInt32 INDEX_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_OFFSET

Steema.TeeChart.Drawing.GL.Imports.INDEX_OFFSET フィールド

public const UInt32 INDEX_OFFSET

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_SHIFT

Steema.TeeChart.Drawing.GL.Imports.INDEX_SHIFT フィールド

public const UInt32 INDEX_SHIFT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INDEX_WRITEMASK

Steema.TeeChart.Drawing.GL.Imports.INDEX_WRITEMASK フィールド

public const UInt32 INDEX_WRITEMASK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INT

Steema.TeeChart.Drawing.GL.Imports.INT フィールド

public const UInt32 INT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INTENSITY

Steema.TeeChart.Drawing.GL.Imports.INTENSITY フィールド

public const UInt32 INTENSITY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INTENSITY12

Steema.TeeChart.Drawing.GL.Imports.INTENSITY12 フィールド

public const UInt32 INTENSITY12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INTENSITY16

Steema.TeeChart.Drawing.GL.Imports.INTENSITY16 フィールド

public const UInt32 INTENSITY16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INTENSITY4

Steema.TeeChart.Drawing.GL.Imports.INTENSITY4 フィールド

public const UInt32 INTENSITY4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INTENSITY8

Steema.TeeChart.Drawing.GL.Imports.INTENSITY8 フィールド

public const UInt32 INTENSITY8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INVALID_ENUM

Steema.TeeChart.Drawing.GL.Imports.INVALID_ENUM フィールド

public const UInt32 INVALID_ENUM

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INVALID_OPERATION

Steema.TeeChart.Drawing.GL.Imports.INVALID_OPERATION フィールド

public const UInt32 INVALID_OPERATION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INVALID_VALUE

Steema.TeeChart.Drawing.GL.Imports.INVALID_VALUE フィールド

public const UInt32 INVALID_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


INVERT

Steema.TeeChart.Drawing.GL.Imports.INVERT フィールド

public const UInt32 INVERT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


KEEP

Steema.TeeChart.Drawing.GL.Imports.KEEP フィールド

public const UInt32 KEEP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LEFT

Steema.TeeChart.Drawing.GL.Imports.LEFT フィールド

public const UInt32 LEFT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LEQUAL

Steema.TeeChart.Drawing.GL.Imports.LEQUAL フィールド

public const UInt32 LEQUAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LESS

Steema.TeeChart.Drawing.GL.Imports.LESS フィールド

public const UInt32 LESS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIBRARY_GDI

Steema.TeeChart.Drawing.GL.Imports.LIBRARY_GDI フィールド

public const String LIBRARY_GDI

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIBRARY_GLU

Steema.TeeChart.Drawing.GL.Imports.LIBRARY_GLU フィールド

public const String LIBRARY_GLU

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIBRARY_KERNEL

Steema.TeeChart.Drawing.GL.Imports.LIBRARY_KERNEL フィールド

public const String LIBRARY_KERNEL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIBRARY_OPENGL

Steema.TeeChart.Drawing.GL.Imports.LIBRARY_OPENGL フィールド

public const String LIBRARY_OPENGL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIBRARY_USER

Steema.TeeChart.Drawing.GL.Imports.LIBRARY_USER フィールド

public const String LIBRARY_USER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT_MODEL_AMBIENT

Steema.TeeChart.Drawing.GL.Imports.LIGHT_MODEL_AMBIENT フィールド

public const UInt32 LIGHT_MODEL_AMBIENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT_MODEL_LOCAL_VIEWER

Steema.TeeChart.Drawing.GL.Imports.LIGHT_MODEL_LOCAL_VIEWER フィールド

public const UInt32 LIGHT_MODEL_LOCAL_VIEWER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT_MODEL_TWO_SIDE

Steema.TeeChart.Drawing.GL.Imports.LIGHT_MODEL_TWO_SIDE フィールド

public const UInt32 LIGHT_MODEL_TWO_SIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT0

Steema.TeeChart.Drawing.GL.Imports.LIGHT0 フィールド

public const UInt32 LIGHT0

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT1

Steema.TeeChart.Drawing.GL.Imports.LIGHT1 フィールド

public const UInt32 LIGHT1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT2

Steema.TeeChart.Drawing.GL.Imports.LIGHT2 フィールド

public const UInt32 LIGHT2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT3

Steema.TeeChart.Drawing.GL.Imports.LIGHT3 フィールド

public const UInt32 LIGHT3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT4

Steema.TeeChart.Drawing.GL.Imports.LIGHT4 フィールド

public const UInt32 LIGHT4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT5

Steema.TeeChart.Drawing.GL.Imports.LIGHT5 フィールド

public const UInt32 LIGHT5

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT6

Steema.TeeChart.Drawing.GL.Imports.LIGHT6 フィールド

public const UInt32 LIGHT6

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHT7

Steema.TeeChart.Drawing.GL.Imports.LIGHT7 フィールド

public const UInt32 LIGHT7

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHTING

Steema.TeeChart.Drawing.GL.Imports.LIGHTING フィールド

public const UInt32 LIGHTING

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIGHTING_BIT

Steema.TeeChart.Drawing.GL.Imports.LIGHTING_BIT フィールド

public const UInt32 LIGHTING_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE

Steema.TeeChart.Drawing.GL.Imports.LINE フィールド

public const UInt32 LINE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_BIT

Steema.TeeChart.Drawing.GL.Imports.LINE_BIT フィールド

public const UInt32 LINE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_LOOP

Steema.TeeChart.Drawing.GL.Imports.LINE_LOOP フィールド

public const UInt32 LINE_LOOP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_RESET_TOKEN

Steema.TeeChart.Drawing.GL.Imports.LINE_RESET_TOKEN フィールド

public const UInt32 LINE_RESET_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_SMOOTH

Steema.TeeChart.Drawing.GL.Imports.LINE_SMOOTH フィールド

public const UInt32 LINE_SMOOTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_SMOOTH_HINT

Steema.TeeChart.Drawing.GL.Imports.LINE_SMOOTH_HINT フィールド

public const UInt32 LINE_SMOOTH_HINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_STIPPLE

Steema.TeeChart.Drawing.GL.Imports.LINE_STIPPLE フィールド

public const UInt32 LINE_STIPPLE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_STIPPLE_PATTERN

Steema.TeeChart.Drawing.GL.Imports.LINE_STIPPLE_PATTERN フィールド

public const UInt32 LINE_STIPPLE_PATTERN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_STIPPLE_REPEAT

Steema.TeeChart.Drawing.GL.Imports.LINE_STIPPLE_REPEAT フィールド

public const UInt32 LINE_STIPPLE_REPEAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_STRIP

Steema.TeeChart.Drawing.GL.Imports.LINE_STRIP フィールド

public const UInt32 LINE_STRIP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_TOKEN

Steema.TeeChart.Drawing.GL.Imports.LINE_TOKEN フィールド

public const UInt32 LINE_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_WIDTH

Steema.TeeChart.Drawing.GL.Imports.LINE_WIDTH フィールド

public const UInt32 LINE_WIDTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_WIDTH_GRANULARITY

Steema.TeeChart.Drawing.GL.Imports.LINE_WIDTH_GRANULARITY フィールド

public const UInt32 LINE_WIDTH_GRANULARITY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINE_WIDTH_RANGE

Steema.TeeChart.Drawing.GL.Imports.LINE_WIDTH_RANGE フィールド

public const UInt32 LINE_WIDTH_RANGE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINEAR

Steema.TeeChart.Drawing.GL.Imports.LINEAR フィールド

public const UInt32 LINEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINEAR_ATTENUATION

Steema.TeeChart.Drawing.GL.Imports.LINEAR_ATTENUATION フィールド

public const UInt32 LINEAR_ATTENUATION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINEAR_MIPMAP_LINEAR

Steema.TeeChart.Drawing.GL.Imports.LINEAR_MIPMAP_LINEAR フィールド

public const UInt32 LINEAR_MIPMAP_LINEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINEAR_MIPMAP_NEAREST

Steema.TeeChart.Drawing.GL.Imports.LINEAR_MIPMAP_NEAREST フィールド

public const UInt32 LINEAR_MIPMAP_NEAREST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LINES

Steema.TeeChart.Drawing.GL.Imports.LINES フィールド

public const UInt32 LINES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIST_BASE

Steema.TeeChart.Drawing.GL.Imports.LIST_BASE フィールド

public const UInt32 LIST_BASE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIST_BIT

Steema.TeeChart.Drawing.GL.Imports.LIST_BIT フィールド

public const UInt32 LIST_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIST_INDEX

Steema.TeeChart.Drawing.GL.Imports.LIST_INDEX フィールド

public const UInt32 LIST_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LIST_MODE

Steema.TeeChart.Drawing.GL.Imports.LIST_MODE フィールド

public const UInt32 LIST_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LOAD

Steema.TeeChart.Drawing.GL.Imports.LOAD フィールド

protected internal UInt32 LOAD

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LOGIC_OP_MODE

Steema.TeeChart.Drawing.GL.Imports.LOGIC_OP_MODE フィールド

public const UInt32 LOGIC_OP_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE フィールド

public const UInt32 LUMINANCE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE_ALPHA

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE_ALPHA フィールド

public const UInt32 LUMINANCE_ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE12

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE12 フィールド

public const UInt32 LUMINANCE12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE12_ALPHA12

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE12_ALPHA12 フィールド

public const UInt32 LUMINANCE12_ALPHA12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE12_ALPHA4

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE12_ALPHA4 フィールド

public const UInt32 LUMINANCE12_ALPHA4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE16

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE16 フィールド

public const UInt32 LUMINANCE16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE16_ALPHA16

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE16_ALPHA16 フィールド

public const UInt32 LUMINANCE16_ALPHA16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE4

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE4 フィールド

public const UInt32 LUMINANCE4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE4_ALPHA4

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE4_ALPHA4 フィールド

public const UInt32 LUMINANCE4_ALPHA4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE6_ALPHA2

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE6_ALPHA2 フィールド

public const UInt32 LUMINANCE6_ALPHA2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE8

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE8 フィールド

public const UInt32 LUMINANCE8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LUMINANCE8_ALPHA8

Steema.TeeChart.Drawing.GL.Imports.LUMINANCE8_ALPHA8 フィールド

public const UInt32 LUMINANCE8_ALPHA8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP_COLOR

Steema.TeeChart.Drawing.GL.Imports.MAP_COLOR フィールド

public const UInt32 MAP_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP_STENCIL

Steema.TeeChart.Drawing.GL.Imports.MAP_STENCIL フィールド

public const UInt32 MAP_STENCIL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_COLOR_4

Steema.TeeChart.Drawing.GL.Imports.MAP1_COLOR_4 フィールド

public const UInt32 MAP1_COLOR_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_GRID_DOMAIN

Steema.TeeChart.Drawing.GL.Imports.MAP1_GRID_DOMAIN フィールド

public const UInt32 MAP1_GRID_DOMAIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_GRID_SEGMENTS

Steema.TeeChart.Drawing.GL.Imports.MAP1_GRID_SEGMENTS フィールド

public const UInt32 MAP1_GRID_SEGMENTS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_INDEX

Steema.TeeChart.Drawing.GL.Imports.MAP1_INDEX フィールド

public const UInt32 MAP1_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_NORMAL

Steema.TeeChart.Drawing.GL.Imports.MAP1_NORMAL フィールド

public const UInt32 MAP1_NORMAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_TEXTURE_COORD_1

Steema.TeeChart.Drawing.GL.Imports.MAP1_TEXTURE_COORD_1 フィールド

public const UInt32 MAP1_TEXTURE_COORD_1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_TEXTURE_COORD_2

Steema.TeeChart.Drawing.GL.Imports.MAP1_TEXTURE_COORD_2 フィールド

public const UInt32 MAP1_TEXTURE_COORD_2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_TEXTURE_COORD_3

Steema.TeeChart.Drawing.GL.Imports.MAP1_TEXTURE_COORD_3 フィールド

public const UInt32 MAP1_TEXTURE_COORD_3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_TEXTURE_COORD_4

Steema.TeeChart.Drawing.GL.Imports.MAP1_TEXTURE_COORD_4 フィールド

public const UInt32 MAP1_TEXTURE_COORD_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_VERTEX_3

Steema.TeeChart.Drawing.GL.Imports.MAP1_VERTEX_3 フィールド

public const UInt32 MAP1_VERTEX_3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP1_VERTEX_4

Steema.TeeChart.Drawing.GL.Imports.MAP1_VERTEX_4 フィールド

public const UInt32 MAP1_VERTEX_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_COLOR_4

Steema.TeeChart.Drawing.GL.Imports.MAP2_COLOR_4 フィールド

public const UInt32 MAP2_COLOR_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_GRID_DOMAIN

Steema.TeeChart.Drawing.GL.Imports.MAP2_GRID_DOMAIN フィールド

public const UInt32 MAP2_GRID_DOMAIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_GRID_SEGMENTS

Steema.TeeChart.Drawing.GL.Imports.MAP2_GRID_SEGMENTS フィールド

public const UInt32 MAP2_GRID_SEGMENTS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_INDEX

Steema.TeeChart.Drawing.GL.Imports.MAP2_INDEX フィールド

public const UInt32 MAP2_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_NORMAL

Steema.TeeChart.Drawing.GL.Imports.MAP2_NORMAL フィールド

public const UInt32 MAP2_NORMAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_TEXTURE_COORD_1

Steema.TeeChart.Drawing.GL.Imports.MAP2_TEXTURE_COORD_1 フィールド

public const UInt32 MAP2_TEXTURE_COORD_1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_TEXTURE_COORD_2

Steema.TeeChart.Drawing.GL.Imports.MAP2_TEXTURE_COORD_2 フィールド

public const UInt32 MAP2_TEXTURE_COORD_2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_TEXTURE_COORD_3

Steema.TeeChart.Drawing.GL.Imports.MAP2_TEXTURE_COORD_3 フィールド

public const UInt32 MAP2_TEXTURE_COORD_3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_TEXTURE_COORD_4

Steema.TeeChart.Drawing.GL.Imports.MAP2_TEXTURE_COORD_4 フィールド

public const UInt32 MAP2_TEXTURE_COORD_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_VERTEX_3

Steema.TeeChart.Drawing.GL.Imports.MAP2_VERTEX_3 フィールド

public const UInt32 MAP2_VERTEX_3

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAP2_VERTEX_4

Steema.TeeChart.Drawing.GL.Imports.MAP2_VERTEX_4 フィールド

public const UInt32 MAP2_VERTEX_4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MATRIX_MODE

Steema.TeeChart.Drawing.GL.Imports.MATRIX_MODE フィールド

public const UInt32 MATRIX_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_ATTRIB_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_ATTRIB_STACK_DEPTH フィールド

public const UInt32 MAX_ATTRIB_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_CLIENT_ATTRIB_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_CLIENT_ATTRIB_STACK_DEPTH フィールド

public const UInt32 MAX_CLIENT_ATTRIB_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_CLIP_PLANES

Steema.TeeChart.Drawing.GL.Imports.MAX_CLIP_PLANES フィールド

public const UInt32 MAX_CLIP_PLANES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_ELEMENTS_INDICES_WIN

Steema.TeeChart.Drawing.GL.Imports.MAX_ELEMENTS_INDICES_WIN フィールド

public const UInt32 MAX_ELEMENTS_INDICES_WIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_ELEMENTS_VERTICES_WIN

Steema.TeeChart.Drawing.GL.Imports.MAX_ELEMENTS_VERTICES_WIN フィールド

public const UInt32 MAX_ELEMENTS_VERTICES_WIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_EVAL_ORDER

Steema.TeeChart.Drawing.GL.Imports.MAX_EVAL_ORDER フィールド

public const UInt32 MAX_EVAL_ORDER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_LIGHTS

Steema.TeeChart.Drawing.GL.Imports.MAX_LIGHTS フィールド

public const UInt32 MAX_LIGHTS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_LIST_NESTING

Steema.TeeChart.Drawing.GL.Imports.MAX_LIST_NESTING フィールド

public const UInt32 MAX_LIST_NESTING

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_MODELVIEW_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_MODELVIEW_STACK_DEPTH フィールド

public const UInt32 MAX_MODELVIEW_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_NAME_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_NAME_STACK_DEPTH フィールド

public const UInt32 MAX_NAME_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_PIXEL_MAP_TABLE

Steema.TeeChart.Drawing.GL.Imports.MAX_PIXEL_MAP_TABLE フィールド

public const UInt32 MAX_PIXEL_MAP_TABLE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_PROJECTION_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_PROJECTION_STACK_DEPTH フィールド

public const UInt32 MAX_PROJECTION_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_TEXTURE_SIZE

Steema.TeeChart.Drawing.GL.Imports.MAX_TEXTURE_SIZE フィールド

public const UInt32 MAX_TEXTURE_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_TEXTURE_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MAX_TEXTURE_STACK_DEPTH フィールド

public const UInt32 MAX_TEXTURE_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MAX_VIEWPORT_DIMS

Steema.TeeChart.Drawing.GL.Imports.MAX_VIEWPORT_DIMS フィールド

public const UInt32 MAX_VIEWPORT_DIMS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MERGECOPY

Steema.TeeChart.Drawing.GL.Imports.MERGECOPY フィールド

protected const UInt32 MERGECOPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MERGEPAINT

Steema.TeeChart.Drawing.GL.Imports.MERGEPAINT フィールド

protected const UInt32 MERGEPAINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MODELVIEW

Steema.TeeChart.Drawing.GL.Imports.MODELVIEW フィールド

public const UInt32 MODELVIEW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MODELVIEW_MATRIX

Steema.TeeChart.Drawing.GL.Imports.MODELVIEW_MATRIX フィールド

public const UInt32 MODELVIEW_MATRIX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MODELVIEW_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.MODELVIEW_STACK_DEPTH フィールド

public const UInt32 MODELVIEW_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MODULATE

Steema.TeeChart.Drawing.GL.Imports.MODULATE フィールド

public const UInt32 MODULATE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


MULT

Steema.TeeChart.Drawing.GL.Imports.MULT フィールド

protected internal UInt32 MULT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


N3F_V3F

Steema.TeeChart.Drawing.GL.Imports.N3F_V3F フィールド

public const UInt32 N3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NAME_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.NAME_STACK_DEPTH フィールド

public const UInt32 NAME_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NAND

Steema.TeeChart.Drawing.GL.Imports.NAND フィールド

public const UInt32 NAND

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NEAREST

Steema.TeeChart.Drawing.GL.Imports.NEAREST フィールド

public const UInt32 NEAREST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NEAREST_MIPMAP_LINEAR

Steema.TeeChart.Drawing.GL.Imports.NEAREST_MIPMAP_LINEAR フィールド

public const UInt32 NEAREST_MIPMAP_LINEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NEAREST_MIPMAP_NEAREST

Steema.TeeChart.Drawing.GL.Imports.NEAREST_MIPMAP_NEAREST フィールド

public const UInt32 NEAREST_MIPMAP_NEAREST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NEVER

Steema.TeeChart.Drawing.GL.Imports.NEVER フィールド

public const UInt32 NEVER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NICEST

Steema.TeeChart.Drawing.GL.Imports.NICEST フィールド

public const UInt32 NICEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NO_ERROR

Steema.TeeChart.Drawing.GL.Imports.NO_ERROR フィールド

public const UInt32 NO_ERROR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NONE

Steema.TeeChart.Drawing.GL.Imports.NONE フィールド

public const UInt32 NONE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NOOP

Steema.TeeChart.Drawing.GL.Imports.NOOP フィールド

public const UInt32 NOOP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NOR

Steema.TeeChart.Drawing.GL.Imports.NOR フィールド

public const UInt32 NOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY フィールド

public const UInt32 NORMAL_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_COUNT_EXT フィールド

public const UInt32 NORMAL_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_EXT フィールド

public const UInt32 NORMAL_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_POINTER フィールド

public const UInt32 NORMAL_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_POINTER_EXT フィールド

public const UInt32 NORMAL_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_STRIDE フィールド

public const UInt32 NORMAL_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_STRIDE_EXT フィールド

public const UInt32 NORMAL_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_TYPE

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_TYPE フィールド

public const UInt32 NORMAL_ARRAY_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMAL_ARRAY_TYPE_EXT

Steema.TeeChart.Drawing.GL.Imports.NORMAL_ARRAY_TYPE_EXT フィールド

public const UInt32 NORMAL_ARRAY_TYPE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NORMALIZE

Steema.TeeChart.Drawing.GL.Imports.NORMALIZE フィールド

public const UInt32 NORMALIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NOTEQUAL

Steema.TeeChart.Drawing.GL.Imports.NOTEQUAL フィールド

public const UInt32 NOTEQUAL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NOTSRCCOPY

Steema.TeeChart.Drawing.GL.Imports.NOTSRCCOPY フィールド

protected const UInt32 NOTSRCCOPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


NOTSRCERASE

Steema.TeeChart.Drawing.GL.Imports.NOTSRCERASE フィールド

protected const UInt32 NOTSRCERASE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OBJECT_LINEAR

Steema.TeeChart.Drawing.GL.Imports.OBJECT_LINEAR フィールド

public const UInt32 OBJECT_LINEAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OBJECT_PLANE

Steema.TeeChart.Drawing.GL.Imports.OBJECT_PLANE フィールド

public const UInt32 OBJECT_PLANE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ONE

Steema.TeeChart.Drawing.GL.Imports.ONE フィールド

public const UInt32 ONE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ONE_MINUS_DST_ALPHA

Steema.TeeChart.Drawing.GL.Imports.ONE_MINUS_DST_ALPHA フィールド

public const UInt32 ONE_MINUS_DST_ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ONE_MINUS_DST_COLOR

Steema.TeeChart.Drawing.GL.Imports.ONE_MINUS_DST_COLOR フィールド

public const UInt32 ONE_MINUS_DST_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ONE_MINUS_SRC_ALPHA

Steema.TeeChart.Drawing.GL.Imports.ONE_MINUS_SRC_ALPHA フィールド

public const UInt32 ONE_MINUS_SRC_ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ONE_MINUS_SRC_COLOR

Steema.TeeChart.Drawing.GL.Imports.ONE_MINUS_SRC_COLOR フィールド

public const UInt32 ONE_MINUS_SRC_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OR

Steema.TeeChart.Drawing.GL.Imports.OR フィールド

public const UInt32 OR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OR_INVERTED

Steema.TeeChart.Drawing.GL.Imports.OR_INVERTED フィールド

public const UInt32 OR_INVERTED

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OR_REVERSE

Steema.TeeChart.Drawing.GL.Imports.OR_REVERSE フィールド

public const UInt32 OR_REVERSE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ORDER

Steema.TeeChart.Drawing.GL.Imports.ORDER フィールド

public const UInt32 ORDER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


OUT_OF_MEMORY

Steema.TeeChart.Drawing.GL.Imports.OUT_OF_MEMORY フィールド

public const UInt32 OUT_OF_MEMORY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_ALIGNMENT

Steema.TeeChart.Drawing.GL.Imports.PACK_ALIGNMENT フィールド

public const UInt32 PACK_ALIGNMENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_LSB_FIRST

Steema.TeeChart.Drawing.GL.Imports.PACK_LSB_FIRST フィールド

public const UInt32 PACK_LSB_FIRST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_ROW_LENGTH

Steema.TeeChart.Drawing.GL.Imports.PACK_ROW_LENGTH フィールド

public const UInt32 PACK_ROW_LENGTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_SKIP_PIXELS

Steema.TeeChart.Drawing.GL.Imports.PACK_SKIP_PIXELS フィールド

public const UInt32 PACK_SKIP_PIXELS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_SKIP_ROWS

Steema.TeeChart.Drawing.GL.Imports.PACK_SKIP_ROWS フィールド

public const UInt32 PACK_SKIP_ROWS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PACK_SWAP_BYTES

Steema.TeeChart.Drawing.GL.Imports.PACK_SWAP_BYTES フィールド

public const UInt32 PACK_SWAP_BYTES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PASS_THROUGH_TOKEN

Steema.TeeChart.Drawing.GL.Imports.PASS_THROUGH_TOKEN フィールド

public const UInt32 PASS_THROUGH_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PATCOPY

Steema.TeeChart.Drawing.GL.Imports.PATCOPY フィールド

protected const UInt32 PATCOPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PATINVERT

Steema.TeeChart.Drawing.GL.Imports.PATINVERT フィールド

protected const UInt32 PATINVERT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PATPAINT

Steema.TeeChart.Drawing.GL.Imports.PATPAINT フィールド

protected const UInt32 PATPAINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PERSPECTIVE_CORRECTION_HINT

Steema.TeeChart.Drawing.GL.Imports.PERSPECTIVE_CORRECTION_HINT フィールド

public const UInt32 PERSPECTIVE_CORRECTION_HINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_DOUBLEBUFFER

Steema.TeeChart.Drawing.GL.Imports.PFD_DOUBLEBUFFER フィールド

protected const UInt32 PFD_DOUBLEBUFFER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_DRAW_TO_BITMAP

Steema.TeeChart.Drawing.GL.Imports.PFD_DRAW_TO_BITMAP フィールド

protected const UInt32 PFD_DRAW_TO_BITMAP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_DRAW_TO_WINDOW

Steema.TeeChart.Drawing.GL.Imports.PFD_DRAW_TO_WINDOW フィールド

protected const UInt32 PFD_DRAW_TO_WINDOW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_GENERIC_ACCELERATED

Steema.TeeChart.Drawing.GL.Imports.PFD_GENERIC_ACCELERATED フィールド

protected const UInt32 PFD_GENERIC_ACCELERATED

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_GENERIC_FORMAT

Steema.TeeChart.Drawing.GL.Imports.PFD_GENERIC_FORMAT フィールド

protected const UInt32 PFD_GENERIC_FORMAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_MAIN_PLANE

Steema.TeeChart.Drawing.GL.Imports.PFD_MAIN_PLANE フィールド

protected const SByte PFD_MAIN_PLANE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_NEED_PALETTE

Steema.TeeChart.Drawing.GL.Imports.PFD_NEED_PALETTE フィールド

protected const UInt32 PFD_NEED_PALETTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_NEED_SYSTEM_PALETTE

Steema.TeeChart.Drawing.GL.Imports.PFD_NEED_SYSTEM_PALETTE フィールド

protected const UInt32 PFD_NEED_SYSTEM_PALETTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_OVERLAY_PLANE

Steema.TeeChart.Drawing.GL.Imports.PFD_OVERLAY_PLANE フィールド

protected const SByte PFD_OVERLAY_PLANE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_STEREO

Steema.TeeChart.Drawing.GL.Imports.PFD_STEREO フィールド

protected const UInt32 PFD_STEREO

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SUPPORT_DIRECTDRAW

Steema.TeeChart.Drawing.GL.Imports.PFD_SUPPORT_DIRECTDRAW フィールド

protected const UInt32 PFD_SUPPORT_DIRECTDRAW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SUPPORT_GDI

Steema.TeeChart.Drawing.GL.Imports.PFD_SUPPORT_GDI フィールド

protected const UInt32 PFD_SUPPORT_GDI

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SUPPORT_OPENGL

Steema.TeeChart.Drawing.GL.Imports.PFD_SUPPORT_OPENGL フィールド

protected const UInt32 PFD_SUPPORT_OPENGL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SWAP_COPY

Steema.TeeChart.Drawing.GL.Imports.PFD_SWAP_COPY フィールド

protected const UInt32 PFD_SWAP_COPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SWAP_EXCHANGE

Steema.TeeChart.Drawing.GL.Imports.PFD_SWAP_EXCHANGE フィールド

protected const UInt32 PFD_SWAP_EXCHANGE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_SWAP_LAYER_BUFFERS

Steema.TeeChart.Drawing.GL.Imports.PFD_SWAP_LAYER_BUFFERS フィールド

protected const UInt32 PFD_SWAP_LAYER_BUFFERS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_TYPE_COLORINDEX

Steema.TeeChart.Drawing.GL.Imports.PFD_TYPE_COLORINDEX フィールド

protected const Byte PFD_TYPE_COLORINDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_TYPE_RGBA

Steema.TeeChart.Drawing.GL.Imports.PFD_TYPE_RGBA フィールド

protected const Byte PFD_TYPE_RGBA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PFD_UNDERLAY_PLANE

Steema.TeeChart.Drawing.GL.Imports.PFD_UNDERLAY_PLANE フィールド

protected const SByte PFD_UNDERLAY_PLANE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PHONG_HINT_WIN

Steema.TeeChart.Drawing.GL.Imports.PHONG_HINT_WIN フィールド

public const UInt32 PHONG_HINT_WIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PHONG_WIN

Steema.TeeChart.Drawing.GL.Imports.PHONG_WIN フィールド

public const UInt32 PHONG_WIN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_A_TO_A

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_A_TO_A フィールド

public const UInt32 PIXEL_MAP_A_TO_A

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_A_TO_A_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_A_TO_A_SIZE フィールド

public const UInt32 PIXEL_MAP_A_TO_A_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_B_TO_B

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_B_TO_B フィールド

public const UInt32 PIXEL_MAP_B_TO_B

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_B_TO_B_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_B_TO_B_SIZE フィールド

public const UInt32 PIXEL_MAP_B_TO_B_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_G_TO_G

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_G_TO_G フィールド

public const UInt32 PIXEL_MAP_G_TO_G

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_G_TO_G_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_G_TO_G_SIZE フィールド

public const UInt32 PIXEL_MAP_G_TO_G_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_A

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_A フィールド

public const UInt32 PIXEL_MAP_I_TO_A

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_A_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_A_SIZE フィールド

public const UInt32 PIXEL_MAP_I_TO_A_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_B

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_B フィールド

public const UInt32 PIXEL_MAP_I_TO_B

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_B_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_B_SIZE フィールド

public const UInt32 PIXEL_MAP_I_TO_B_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_G

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_G フィールド

public const UInt32 PIXEL_MAP_I_TO_G

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_G_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_G_SIZE フィールド

public const UInt32 PIXEL_MAP_I_TO_G_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_I

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_I フィールド

public const UInt32 PIXEL_MAP_I_TO_I

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_I_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_I_SIZE フィールド

public const UInt32 PIXEL_MAP_I_TO_I_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_R

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_R フィールド

public const UInt32 PIXEL_MAP_I_TO_R

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_I_TO_R_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_I_TO_R_SIZE フィールド

public const UInt32 PIXEL_MAP_I_TO_R_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_R_TO_R

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_R_TO_R フィールド

public const UInt32 PIXEL_MAP_R_TO_R

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_R_TO_R_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_R_TO_R_SIZE フィールド

public const UInt32 PIXEL_MAP_R_TO_R_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_S_TO_S

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_S_TO_S フィールド

public const UInt32 PIXEL_MAP_S_TO_S

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MAP_S_TO_S_SIZE

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MAP_S_TO_S_SIZE フィールド

public const UInt32 PIXEL_MAP_S_TO_S_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXEL_MODE_BIT

Steema.TeeChart.Drawing.GL.Imports.PIXEL_MODE_BIT フィールド

public const UInt32 PIXEL_MODE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT

Steema.TeeChart.Drawing.GL.Imports.POINT フィールド

public const UInt32 POINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_BIT

Steema.TeeChart.Drawing.GL.Imports.POINT_BIT フィールド

public const UInt32 POINT_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_SIZE

Steema.TeeChart.Drawing.GL.Imports.POINT_SIZE フィールド

public const UInt32 POINT_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_SIZE_GRANULARITY

Steema.TeeChart.Drawing.GL.Imports.POINT_SIZE_GRANULARITY フィールド

public const UInt32 POINT_SIZE_GRANULARITY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_SIZE_RANGE

Steema.TeeChart.Drawing.GL.Imports.POINT_SIZE_RANGE フィールド

public const UInt32 POINT_SIZE_RANGE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_SMOOTH

Steema.TeeChart.Drawing.GL.Imports.POINT_SMOOTH フィールド

public const UInt32 POINT_SMOOTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_SMOOTH_HINT

Steema.TeeChart.Drawing.GL.Imports.POINT_SMOOTH_HINT フィールド

public const UInt32 POINT_SMOOTH_HINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINT_TOKEN

Steema.TeeChart.Drawing.GL.Imports.POINT_TOKEN フィールド

public const UInt32 POINT_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POINTS

Steema.TeeChart.Drawing.GL.Imports.POINTS フィールド

public const UInt32 POINTS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON

Steema.TeeChart.Drawing.GL.Imports.POLYGON フィールド

public const UInt32 POLYGON

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_BIT

Steema.TeeChart.Drawing.GL.Imports.POLYGON_BIT フィールド

public const UInt32 POLYGON_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_MODE

Steema.TeeChart.Drawing.GL.Imports.POLYGON_MODE フィールド

public const UInt32 POLYGON_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_OFFSET_FACTOR

Steema.TeeChart.Drawing.GL.Imports.POLYGON_OFFSET_FACTOR フィールド

public const UInt32 POLYGON_OFFSET_FACTOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_OFFSET_FILL

Steema.TeeChart.Drawing.GL.Imports.POLYGON_OFFSET_FILL フィールド

public const UInt32 POLYGON_OFFSET_FILL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_OFFSET_LINE

Steema.TeeChart.Drawing.GL.Imports.POLYGON_OFFSET_LINE フィールド

public const UInt32 POLYGON_OFFSET_LINE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_OFFSET_POINT

Steema.TeeChart.Drawing.GL.Imports.POLYGON_OFFSET_POINT フィールド

public const UInt32 POLYGON_OFFSET_POINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_OFFSET_UNITS

Steema.TeeChart.Drawing.GL.Imports.POLYGON_OFFSET_UNITS フィールド

public const UInt32 POLYGON_OFFSET_UNITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_SMOOTH

Steema.TeeChart.Drawing.GL.Imports.POLYGON_SMOOTH フィールド

public const UInt32 POLYGON_SMOOTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_SMOOTH_HINT

Steema.TeeChart.Drawing.GL.Imports.POLYGON_SMOOTH_HINT フィールド

public const UInt32 POLYGON_SMOOTH_HINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_STIPPLE

Steema.TeeChart.Drawing.GL.Imports.POLYGON_STIPPLE フィールド

public const UInt32 POLYGON_STIPPLE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_STIPPLE_BIT

Steema.TeeChart.Drawing.GL.Imports.POLYGON_STIPPLE_BIT フィールド

public const UInt32 POLYGON_STIPPLE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POLYGON_TOKEN

Steema.TeeChart.Drawing.GL.Imports.POLYGON_TOKEN フィールド

public const UInt32 POLYGON_TOKEN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


POSITION

Steema.TeeChart.Drawing.GL.Imports.POSITION フィールド

public const UInt32 POSITION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PROJECTION

Steema.TeeChart.Drawing.GL.Imports.PROJECTION フィールド

public const UInt32 PROJECTION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PROJECTION_MATRIX

Steema.TeeChart.Drawing.GL.Imports.PROJECTION_MATRIX フィールド

public const UInt32 PROJECTION_MATRIX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PROJECTION_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.PROJECTION_STACK_DEPTH フィールド

public const UInt32 PROJECTION_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PROXY_TEXTURE_1D

Steema.TeeChart.Drawing.GL.Imports.PROXY_TEXTURE_1D フィールド

public const UInt32 PROXY_TEXTURE_1D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


PROXY_TEXTURE_2D

Steema.TeeChart.Drawing.GL.Imports.PROXY_TEXTURE_2D フィールド

public const UInt32 PROXY_TEXTURE_2D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


Q

Steema.TeeChart.Drawing.GL.Imports.Q フィールド

public const UInt32 Q

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


QUAD_STRIP

Steema.TeeChart.Drawing.GL.Imports.QUAD_STRIP フィールド

public const UInt32 QUAD_STRIP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


QUADRATIC_ATTENUATION

Steema.TeeChart.Drawing.GL.Imports.QUADRATIC_ATTENUATION フィールド

public const UInt32 QUADRATIC_ATTENUATION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


QUADS

Steema.TeeChart.Drawing.GL.Imports.QUADS フィールド

public const UInt32 QUADS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


R

Steema.TeeChart.Drawing.GL.Imports.R フィールド

public const UInt32 R

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


R3_G3_B2

Steema.TeeChart.Drawing.GL.Imports.R3_G3_B2 フィールド

public const UInt32 R3_G3_B2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


READ_BUFFER

Steema.TeeChart.Drawing.GL.Imports.READ_BUFFER フィールド

public const UInt32 READ_BUFFER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RED

Steema.TeeChart.Drawing.GL.Imports.RED フィールド

public const UInt32 RED

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RED_BIAS

Steema.TeeChart.Drawing.GL.Imports.RED_BIAS フィールド

public const UInt32 RED_BIAS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RED_BITS

Steema.TeeChart.Drawing.GL.Imports.RED_BITS フィールド

public const UInt32 RED_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RED_SCALE

Steema.TeeChart.Drawing.GL.Imports.RED_SCALE フィールド

public const UInt32 RED_SCALE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RENDER

Steema.TeeChart.Drawing.GL.Imports.RENDER フィールド

public const UInt32 RENDER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RENDER_MODE

Steema.TeeChart.Drawing.GL.Imports.RENDER_MODE フィールド

public const UInt32 RENDER_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RENDERER

Steema.TeeChart.Drawing.GL.Imports.RENDERER フィールド

public const UInt32 RENDERER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


REPEAT

Steema.TeeChart.Drawing.GL.Imports.REPEAT フィールド

public const UInt32 REPEAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


REPLACE

Steema.TeeChart.Drawing.GL.Imports.REPLACE フィールド

public const UInt32 REPLACE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RETURN

Steema.TeeChart.Drawing.GL.Imports.RETURN フィールド

protected internal UInt32 RETURN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB

Steema.TeeChart.Drawing.GL.Imports.RGB フィールド

public const UInt32 RGB

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB10

Steema.TeeChart.Drawing.GL.Imports.RGB10 フィールド

public const UInt32 RGB10

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB10_A2

Steema.TeeChart.Drawing.GL.Imports.RGB10_A2 フィールド

public const UInt32 RGB10_A2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB12

Steema.TeeChart.Drawing.GL.Imports.RGB12 フィールド

public const UInt32 RGB12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB16

Steema.TeeChart.Drawing.GL.Imports.RGB16 フィールド

public const UInt32 RGB16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB4

Steema.TeeChart.Drawing.GL.Imports.RGB4 フィールド

public const UInt32 RGB4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB5

Steema.TeeChart.Drawing.GL.Imports.RGB5 フィールド

public const UInt32 RGB5

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB5_A1

Steema.TeeChart.Drawing.GL.Imports.RGB5_A1 フィールド

public const UInt32 RGB5_A1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGB8

Steema.TeeChart.Drawing.GL.Imports.RGB8 フィールド

public const UInt32 RGB8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA

Steema.TeeChart.Drawing.GL.Imports.RGBA フィールド

public const UInt32 RGBA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA_MODE

Steema.TeeChart.Drawing.GL.Imports.RGBA_MODE フィールド

public const UInt32 RGBA_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA12

Steema.TeeChart.Drawing.GL.Imports.RGBA12 フィールド

public const UInt32 RGBA12

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA16

Steema.TeeChart.Drawing.GL.Imports.RGBA16 フィールド

public const UInt32 RGBA16

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA2

Steema.TeeChart.Drawing.GL.Imports.RGBA2 フィールド

public const UInt32 RGBA2

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA4

Steema.TeeChart.Drawing.GL.Imports.RGBA4 フィールド

public const UInt32 RGBA4

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RGBA8

Steema.TeeChart.Drawing.GL.Imports.RGBA8 フィールド

public const UInt32 RGBA8

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


RIGHT

Steema.TeeChart.Drawing.GL.Imports.RIGHT フィールド

public const UInt32 RIGHT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


S

Steema.TeeChart.Drawing.GL.Imports.S フィールド

public const UInt32 S

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SCISSOR_BIT

Steema.TeeChart.Drawing.GL.Imports.SCISSOR_BIT フィールド

public const UInt32 SCISSOR_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SCISSOR_BOX

Steema.TeeChart.Drawing.GL.Imports.SCISSOR_BOX フィールド

public const UInt32 SCISSOR_BOX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SCISSOR_TEST

Steema.TeeChart.Drawing.GL.Imports.SCISSOR_TEST フィールド

public const UInt32 SCISSOR_TEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SELECT

Steema.TeeChart.Drawing.GL.Imports.SELECT フィールド

public const UInt32 SELECT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SELECTION_BUFFER_POINTER

Steema.TeeChart.Drawing.GL.Imports.SELECTION_BUFFER_POINTER フィールド

public const UInt32 SELECTION_BUFFER_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SELECTION_BUFFER_SIZE

Steema.TeeChart.Drawing.GL.Imports.SELECTION_BUFFER_SIZE フィールド

public const UInt32 SELECTION_BUFFER_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SET

Steema.TeeChart.Drawing.GL.Imports.SET フィールド

public const UInt32 SET

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SHADE_MODEL

Steema.TeeChart.Drawing.GL.Imports.SHADE_MODEL フィールド

public const UInt32 SHADE_MODEL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SHININESS

Steema.TeeChart.Drawing.GL.Imports.SHININESS フィールド

public const UInt32 SHININESS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SHORT

Steema.TeeChart.Drawing.GL.Imports.SHORT フィールド

public const UInt32 SHORT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SMOOTH

Steema.TeeChart.Drawing.GL.Imports.SMOOTH フィールド

public const UInt32 SMOOTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SPECULAR

Steema.TeeChart.Drawing.GL.Imports.SPECULAR フィールド

public const UInt32 SPECULAR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SPHERE_MAP

Steema.TeeChart.Drawing.GL.Imports.SPHERE_MAP フィールド

public const UInt32 SPHERE_MAP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SPOT_CUTOFF

Steema.TeeChart.Drawing.GL.Imports.SPOT_CUTOFF フィールド

public const UInt32 SPOT_CUTOFF

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SPOT_DIRECTION

Steema.TeeChart.Drawing.GL.Imports.SPOT_DIRECTION フィールド

public const UInt32 SPOT_DIRECTION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SPOT_EXPONENT

Steema.TeeChart.Drawing.GL.Imports.SPOT_EXPONENT フィールド

public const UInt32 SPOT_EXPONENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRC_ALPHA

Steema.TeeChart.Drawing.GL.Imports.SRC_ALPHA フィールド

public const UInt32 SRC_ALPHA

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRC_ALPHA_SATURATE

Steema.TeeChart.Drawing.GL.Imports.SRC_ALPHA_SATURATE フィールド

public const UInt32 SRC_ALPHA_SATURATE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRC_COLOR

Steema.TeeChart.Drawing.GL.Imports.SRC_COLOR フィールド

public const UInt32 SRC_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRCAND

Steema.TeeChart.Drawing.GL.Imports.SRCAND フィールド

protected const UInt32 SRCAND

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRCCOPY

Steema.TeeChart.Drawing.GL.Imports.SRCCOPY フィールド

protected const UInt32 SRCCOPY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRCERASE

Steema.TeeChart.Drawing.GL.Imports.SRCERASE フィールド

protected const UInt32 SRCERASE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRCINVERT

Steema.TeeChart.Drawing.GL.Imports.SRCINVERT フィールド

protected const UInt32 SRCINVERT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SRCPAINT

Steema.TeeChart.Drawing.GL.Imports.SRCPAINT フィールド

protected const UInt32 SRCPAINT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STACK_OVERFLOW

Steema.TeeChart.Drawing.GL.Imports.STACK_OVERFLOW フィールド

public const UInt32 STACK_OVERFLOW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STACK_UNDERFLOW

Steema.TeeChart.Drawing.GL.Imports.STACK_UNDERFLOW フィールド

public const UInt32 STACK_UNDERFLOW

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL

Steema.TeeChart.Drawing.GL.Imports.STENCIL フィールド

public const UInt32 STENCIL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_BITS

Steema.TeeChart.Drawing.GL.Imports.STENCIL_BITS フィールド

public const UInt32 STENCIL_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_BUFFER_BIT

Steema.TeeChart.Drawing.GL.Imports.STENCIL_BUFFER_BIT フィールド

public const UInt32 STENCIL_BUFFER_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_CLEAR_VALUE

Steema.TeeChart.Drawing.GL.Imports.STENCIL_CLEAR_VALUE フィールド

public const UInt32 STENCIL_CLEAR_VALUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_FAIL

Steema.TeeChart.Drawing.GL.Imports.STENCIL_FAIL フィールド

public const UInt32 STENCIL_FAIL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_FUNC

Steema.TeeChart.Drawing.GL.Imports.STENCIL_FUNC フィールド

public const UInt32 STENCIL_FUNC

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_INDEX

Steema.TeeChart.Drawing.GL.Imports.STENCIL_INDEX フィールド

public const UInt32 STENCIL_INDEX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_PASS_DEPTH_FAIL

Steema.TeeChart.Drawing.GL.Imports.STENCIL_PASS_DEPTH_FAIL フィールド

public const UInt32 STENCIL_PASS_DEPTH_FAIL

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_PASS_DEPTH_PASS

Steema.TeeChart.Drawing.GL.Imports.STENCIL_PASS_DEPTH_PASS フィールド

public const UInt32 STENCIL_PASS_DEPTH_PASS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_REF

Steema.TeeChart.Drawing.GL.Imports.STENCIL_REF フィールド

public const UInt32 STENCIL_REF

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_TEST

Steema.TeeChart.Drawing.GL.Imports.STENCIL_TEST フィールド

public const UInt32 STENCIL_TEST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_VALUE_MASK

Steema.TeeChart.Drawing.GL.Imports.STENCIL_VALUE_MASK フィールド

public const UInt32 STENCIL_VALUE_MASK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STENCIL_WRITEMASK

Steema.TeeChart.Drawing.GL.Imports.STENCIL_WRITEMASK フィールド

public const UInt32 STENCIL_WRITEMASK

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


STEREO

Steema.TeeChart.Drawing.GL.Imports.STEREO フィールド

public const UInt32 STEREO

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SUBPIXEL_BITS

Steema.TeeChart.Drawing.GL.Imports.SUBPIXEL_BITS フィールド

public const UInt32 SUBPIXEL_BITS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T

Steema.TeeChart.Drawing.GL.Imports.T フィールド

public const UInt32 T

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T2F_C3F_V3F

Steema.TeeChart.Drawing.GL.Imports.T2F_C3F_V3F フィールド

public const UInt32 T2F_C3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T2F_C4F_N3F_V3F

Steema.TeeChart.Drawing.GL.Imports.T2F_C4F_N3F_V3F フィールド

public const UInt32 T2F_C4F_N3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T2F_C4UB_V3F

Steema.TeeChart.Drawing.GL.Imports.T2F_C4UB_V3F フィールド

public const UInt32 T2F_C4UB_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T2F_N3F_V3F

Steema.TeeChart.Drawing.GL.Imports.T2F_N3F_V3F フィールド

public const UInt32 T2F_N3F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T2F_V3F

Steema.TeeChart.Drawing.GL.Imports.T2F_V3F フィールド

public const UInt32 T2F_V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T4F_C4F_N3F_V4F

Steema.TeeChart.Drawing.GL.Imports.T4F_C4F_N3F_V4F フィールド

public const UInt32 T4F_C4F_N3F_V4F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


T4F_V4F

Steema.TeeChart.Drawing.GL.Imports.T4F_V4F フィールド

public const UInt32 T4F_V4F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTALIGN_BOTTOM

Steema.TeeChart.Drawing.GL.Imports.TEXTALIGN_BOTTOM フィールド

public const Int32 TEXTALIGN_BOTTOM

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTALIGN_CENTER

Steema.TeeChart.Drawing.GL.Imports.TEXTALIGN_CENTER フィールド

public const Int32 TEXTALIGN_CENTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTALIGN_LEFT

Steema.TeeChart.Drawing.GL.Imports.TEXTALIGN_LEFT フィールド

public const Int32 TEXTALIGN_LEFT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTALIGN_RIGHT

Steema.TeeChart.Drawing.GL.Imports.TEXTALIGN_RIGHT フィールド

public const Int32 TEXTALIGN_RIGHT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTALIGN_TOP

Steema.TeeChart.Drawing.GL.Imports.TEXTALIGN_TOP フィールド

public const Int32 TEXTALIGN_TOP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE フィールド

public const UInt32 TEXTURE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_1D

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_1D フィールド

public const UInt32 TEXTURE_1D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_2D

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_2D フィールド

public const UInt32 TEXTURE_2D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_ALPHA_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_ALPHA_SIZE フィールド

public const UInt32 TEXTURE_ALPHA_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BINDING_1D

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BINDING_1D フィールド

public const UInt32 TEXTURE_BINDING_1D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BINDING_2D

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BINDING_2D フィールド

public const UInt32 TEXTURE_BINDING_2D

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BIT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BIT フィールド

public const UInt32 TEXTURE_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BLUE_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BLUE_SIZE フィールド

public const UInt32 TEXTURE_BLUE_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BORDER

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BORDER フィールド

public const UInt32 TEXTURE_BORDER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_BORDER_COLOR

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_BORDER_COLOR フィールド

public const UInt32 TEXTURE_BORDER_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY フィールド

public const UInt32 TEXTURE_COORD_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_COUNT_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_POINTER フィールド

public const UInt32 TEXTURE_COORD_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_POINTER_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_SIZE フィールド

public const UInt32 TEXTURE_COORD_ARRAY_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_SIZE_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_STRIDE フィールド

public const UInt32 TEXTURE_COORD_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_STRIDE_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_TYPE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_TYPE フィールド

public const UInt32 TEXTURE_COORD_ARRAY_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_COORD_ARRAY_TYPE_EXT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_COORD_ARRAY_TYPE_EXT フィールド

public const UInt32 TEXTURE_COORD_ARRAY_TYPE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_ENV

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_ENV フィールド

public const UInt32 TEXTURE_ENV

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_ENV_COLOR

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_ENV_COLOR フィールド

public const UInt32 TEXTURE_ENV_COLOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_ENV_MODE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_ENV_MODE フィールド

public const UInt32 TEXTURE_ENV_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GEN_MODE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GEN_MODE フィールド

public const UInt32 TEXTURE_GEN_MODE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GEN_Q

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GEN_Q フィールド

public const UInt32 TEXTURE_GEN_Q

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GEN_R

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GEN_R フィールド

public const UInt32 TEXTURE_GEN_R

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GEN_S

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GEN_S フィールド

public const UInt32 TEXTURE_GEN_S

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GEN_T

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GEN_T フィールド

public const UInt32 TEXTURE_GEN_T

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_GREEN_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_GREEN_SIZE フィールド

public const UInt32 TEXTURE_GREEN_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_HEIGHT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_HEIGHT フィールド

public const UInt32 TEXTURE_HEIGHT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_INTENSITY_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_INTENSITY_SIZE フィールド

public const UInt32 TEXTURE_INTENSITY_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_INTERNAL_FORMAT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_INTERNAL_FORMAT フィールド

public const UInt32 TEXTURE_INTERNAL_FORMAT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_LUMINANCE_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_LUMINANCE_SIZE フィールド

public const UInt32 TEXTURE_LUMINANCE_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_MAG_FILTER

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_MAG_FILTER フィールド

public const UInt32 TEXTURE_MAG_FILTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_MATRIX

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_MATRIX フィールド

public const UInt32 TEXTURE_MATRIX

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_MIN_FILTER

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_MIN_FILTER フィールド

public const UInt32 TEXTURE_MIN_FILTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_PRIORITY

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_PRIORITY フィールド

public const UInt32 TEXTURE_PRIORITY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_RED_SIZE

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_RED_SIZE フィールド

public const UInt32 TEXTURE_RED_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_RESIDENT

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_RESIDENT フィールド

public const UInt32 TEXTURE_RESIDENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_STACK_DEPTH

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_STACK_DEPTH フィールド

public const UInt32 TEXTURE_STACK_DEPTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_WIDTH

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_WIDTH フィールド

public const UInt32 TEXTURE_WIDTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_WRAP_S

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_WRAP_S フィールド

public const UInt32 TEXTURE_WRAP_S

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TEXTURE_WRAP_T

Steema.TeeChart.Drawing.GL.Imports.TEXTURE_WRAP_T フィールド

public const UInt32 TEXTURE_WRAP_T

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TRANSFORM_BIT

Steema.TeeChart.Drawing.GL.Imports.TRANSFORM_BIT フィールド

public const UInt32 TRANSFORM_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TRIANGLE_FAN

Steema.TeeChart.Drawing.GL.Imports.TRIANGLE_FAN フィールド

public const UInt32 TRIANGLE_FAN

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TRIANGLE_STRIP

Steema.TeeChart.Drawing.GL.Imports.TRIANGLE_STRIP フィールド

public const UInt32 TRIANGLE_STRIP

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TRIANGLES

Steema.TeeChart.Drawing.GL.Imports.TRIANGLES フィールド

public const UInt32 TRIANGLES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


TRUE

Steema.TeeChart.Drawing.GL.Imports.TRUE フィールド

public const UInt32 TRUE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_ALIGNMENT

Steema.TeeChart.Drawing.GL.Imports.UNPACK_ALIGNMENT フィールド

public const UInt32 UNPACK_ALIGNMENT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_LSB_FIRST

Steema.TeeChart.Drawing.GL.Imports.UNPACK_LSB_FIRST フィールド

public const UInt32 UNPACK_LSB_FIRST

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_ROW_LENGTH

Steema.TeeChart.Drawing.GL.Imports.UNPACK_ROW_LENGTH フィールド

public const UInt32 UNPACK_ROW_LENGTH

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_SKIP_PIXELS

Steema.TeeChart.Drawing.GL.Imports.UNPACK_SKIP_PIXELS フィールド

public const UInt32 UNPACK_SKIP_PIXELS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_SKIP_ROWS

Steema.TeeChart.Drawing.GL.Imports.UNPACK_SKIP_ROWS フィールド

public const UInt32 UNPACK_SKIP_ROWS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNPACK_SWAP_BYTES

Steema.TeeChart.Drawing.GL.Imports.UNPACK_SWAP_BYTES フィールド

public const UInt32 UNPACK_SWAP_BYTES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNSIGNED_BYTE

Steema.TeeChart.Drawing.GL.Imports.UNSIGNED_BYTE フィールド

public const UInt32 UNSIGNED_BYTE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNSIGNED_INT

Steema.TeeChart.Drawing.GL.Imports.UNSIGNED_INT フィールド

public const UInt32 UNSIGNED_INT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


UNSIGNED_SHORT

Steema.TeeChart.Drawing.GL.Imports.UNSIGNED_SHORT フィールド

public const UInt32 UNSIGNED_SHORT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


V2F

Steema.TeeChart.Drawing.GL.Imports.V2F フィールド

public const UInt32 V2F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


V3F

Steema.TeeChart.Drawing.GL.Imports.V3F フィールド

public const UInt32 V3F

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VENDOR

Steema.TeeChart.Drawing.GL.Imports.VENDOR フィールド

public const UInt32 VENDOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERSION

Steema.TeeChart.Drawing.GL.Imports.VERSION フィールド

public const UInt32 VERSION

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERSION_1_1

Steema.TeeChart.Drawing.GL.Imports.VERSION_1_1 フィールド

public const UInt32 VERSION_1_1

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY フィールド

public const UInt32 VERTEX_ARRAY

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_COUNT_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_COUNT_EXT フィールド

public const UInt32 VERTEX_ARRAY_COUNT_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_EXT フィールド

public const UInt32 VERTEX_ARRAY_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_POINTER

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_POINTER フィールド

public const UInt32 VERTEX_ARRAY_POINTER

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_POINTER_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_POINTER_EXT フィールド

public const UInt32 VERTEX_ARRAY_POINTER_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_SIZE

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_SIZE フィールド

public const UInt32 VERTEX_ARRAY_SIZE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_SIZE_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_SIZE_EXT フィールド

public const UInt32 VERTEX_ARRAY_SIZE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_STRIDE

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_STRIDE フィールド

public const UInt32 VERTEX_ARRAY_STRIDE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_STRIDE_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_STRIDE_EXT フィールド

public const UInt32 VERTEX_ARRAY_STRIDE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_TYPE

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_TYPE フィールド

public const UInt32 VERTEX_ARRAY_TYPE

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VERTEX_ARRAY_TYPE_EXT

Steema.TeeChart.Drawing.GL.Imports.VERTEX_ARRAY_TYPE_EXT フィールド

public const UInt32 VERTEX_ARRAY_TYPE_EXT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VIEWPORT

Steema.TeeChart.Drawing.GL.Imports.VIEWPORT フィールド

public const UInt32 VIEWPORT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


VIEWPORT_BIT

Steema.TeeChart.Drawing.GL.Imports.VIEWPORT_BIT フィールド

public const UInt32 VIEWPORT_BIT

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


WGL_FONT_LINES

Steema.TeeChart.Drawing.GL.Imports.WGL_FONT_LINES フィールド

public const Int32 WGL_FONT_LINES

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


WGL_FONT_POLYGONS

Steema.TeeChart.Drawing.GL.Imports.WGL_FONT_POLYGONS フィールド

public const Int32 WGL_FONT_POLYGONS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


WHITENESS

Steema.TeeChart.Drawing.GL.Imports.WHITENESS フィールド

protected const UInt32 WHITENESS

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


WIN_draw_range_elements

Steema.TeeChart.Drawing.GL.Imports.WIN_draw_range_elements フィールド

public const UInt32 WIN_draw_range_elements

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


WIN_swap_hint

Steema.TeeChart.Drawing.GL.Imports.WIN_swap_hint フィールド

public const UInt32 WIN_swap_hint

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


XOR

Steema.TeeChart.Drawing.GL.Imports.XOR フィールド

public const UInt32 XOR

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ZERO

Steema.TeeChart.Drawing.GL.Imports.ZERO フィールド

public const UInt32 ZERO

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ZOOM_X

Steema.TeeChart.Drawing.GL.Imports.ZOOM_X フィールド

public const UInt32 ZOOM_X

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ZOOM_Y

Steema.TeeChart.Drawing.GL.Imports.ZOOM_Y フィールド

public const UInt32 ZOOM_Y

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports メソッド

パブリック メソッド

BitBlt
ChoosePixelFormat
CreateFont
DeleteObject
DescribePixelFormat
GetDC
GetDeviceCaps
GetPixelFormat
GetTextExtentPoint32
glAccum
glAlphaFunc
glAreTexturesResident
glArrayElement
glBegin
glBindTexture
glBitmap
glBlendFunc
glCallList
glCallLists
glClear
glClearAccum
glClearColor
glClearDepth
glClearIndex
glClearStencil
glClipPlane
glColor3b
glColor3bv
glColor3d
glColor3dv
glColor3f
glColor3fv
glColor3i
glColor3iv
glColor3s
glColor3sv
glColor3ub
glColor3ubv
glColor3ui
glColor3uiv
glColor3us
glColor3usv
glColor4b
glColor4bv
glColor4d
glColor4dv
glColor4f
glColor4fv
glColor4i
glColor4iv
glColor4s
glColor4sv
glColor4ub
glColor4ubv
glColor4ui
glColor4uiv
glColor4us
glColor4usv
glColorMask
glColorMaterial
glColorPointer
glCopyPixels
glCopyTexImage1D
glCopyTexImage2D
glCopyTexSubImage1D
glCopyTexSubImage2D
glCullFace
glDeleteLists
glDeleteTextures
glDepthFunc
glDepthMask
glDepthRange
glDisable
glDisableClientState
glDrawArrays
glDrawBuffer
glDrawElements
glDrawPixels
glEdgeFlag
glEdgeFlagPointer
glEdgeFlagv
glEnable
glEnableClientState
glEnd
glEndList
glEvalCoord1d
glEvalCoord1dv
glEvalCoord1f
glEvalCoord1fv
glEvalCoord2d
glEvalCoord2dv
glEvalCoord2f
glEvalCoord2fv
glEvalMesh1
glEvalMesh2
glEvalPoint1
glEvalPoint2
glFeedbackBuffer
glFinish
glFlush
glFogf
glFogfv
glFogi
glFogiv
glFrontFace
glFrustum
glGenLists
glGenTextures
glGetBooleanv
glGetClipPlane
glGetDoublev
glGetError
glGetFloatv
glGetIntegerv
glGetLightfv
glGetLightiv
glGetMapdv
glGetMapfv
glGetMapiv
glGetMaterialfv
glGetMaterialiv
glGetPixelMapfv
glGetPixelMapuiv
glGetPixelMapusv
glGetPointerv
glGetPolygonStipple
glGetString
glGetTexEnvfv
glGetTexEnviv
glGetTexGendv
glGetTexGenfv
glGetTexGeniv
glGetTexImage
glGetTexLevelParameterfv
glGetTexLevelParameteriv
glGetTexParameterfv
glGetTexParameteriv
glHint
glIndexd
glIndexdv
glIndexf
glIndexfv
glIndexi
glIndexiv
glIndexMask
glIndexPointer
glIndexs
glIndexsv
glIndexub
glIndexubv
glInitNames
glInterleavedArrays
glIsEnabled
glIsList
glIsTexture
glLightf
glLightfv
glLighti
glLightiv
glLightModelf
glLightModelfv
glLightModeli
glLightModeliv
glLineStipple
glLineWidth
glListBase
glLoadIdentity
glLoadMatrixd
glLoadMatrixf
glLoadName
glLogicOp
glMap1d
glMap1f
glMap2d
glMap2f
glMapGrid1d
glMapGrid1f
glMapGrid2d
glMapGrid2f
glMaterialf
glMaterialfv
glMateriali
glMaterialiv
glMatrixMode
glMultMatrixd
glMultMatrixf
glNewList
glNormal3b
glNormal3bv
glNormal3d
glNormal3dv
glNormal3f
glNormal3fv
glNormal3i
glNormal3iv
glNormal3s
glNormal3sv
glNormalPointer
glOrtho
glPassThrough
glPixelMapfv
glPixelMapuiv
glPixelMapusv
glPixelStoref
glPixelStorei
glPixelTransferf
glPixelTransferi
glPixelZoom
glPointSize
glPolygonMode
glPolygonOffset
glPolygonStipple
glPopAttrib
glPopClientAttrib
glPopMatrix
glPopName
glPrioritizeTextures
glPushAttrib
glPushClientAttrib
glPushMatrix
glPushName
glRasterPos2d
glRasterPos2dv
glRasterPos2f
glRasterPos2fv
glRasterPos2i
glRasterPos2iv
glRasterPos2s
glRasterPos2sv
glRasterPos3d
glRasterPos3dv
glRasterPos3f
glRasterPos3fv
glRasterPos3i
glRasterPos3iv
glRasterPos3s
glRasterPos3sv
glRasterPos4d
glRasterPos4dv
glRasterPos4f
glRasterPos4fv
glRasterPos4i
glRasterPos4iv
glRasterPos4s
glRasterPos4sv
glReadBuffer
glReadPixels
glRectd
glRectdv
glRectf
glRectfv
glRecti
glRectiv
glRects
glRectsv
glRenderMode
glRotated
glRotatef
glScaled
glScalef
glScissor
glSelectBuffer
glShadeModel
glStencilFunc
glStencilMask
glStencilOp
glTexCoord1d
glTexCoord1dv
glTexCoord1f
glTexCoord1fv
glTexCoord1i
glTexCoord1iv
glTexCoord1s
glTexCoord1sv
glTexCoord2d
glTexCoord2dv
glTexCoord2f
glTexCoord2fv
glTexCoord2i
glTexCoord2iv
glTexCoord2s
glTexCoord2sv
glTexCoord3d
glTexCoord3dv
glTexCoord3f
glTexCoord3fv
glTexCoord3i
glTexCoord3iv
glTexCoord3s
glTexCoord3sv
glTexCoord4d
glTexCoord4dv
glTexCoord4f
glTexCoord4fv
glTexCoord4i
glTexCoord4iv
glTexCoord4s
glTexCoord4sv
glTexCoordPointer
glTexEnvf
glTexEnvfv
glTexEnvi
glTexEnviv
glTexGend
glTexGendv
glTexGenf
glTexGenfv
glTexGeni
glTexGeniv
glTexImage1D
glTexImage2D
glTexParameterf
glTexParameterfv
glTexParameteri
glTexParameteriv
glTexSubImage1D
glTexSubImage2D
glTranslated
glTranslatef
gluBeginCurve
gluBeginSurface
gluBeginTrim
gluBuild1DMipmaps
gluBuild2DMipmaps
gluCylinder
gluDeleteNurbsRenderer
gluDeleteQuadric
gluDeleteTess
gluDisk
gluEndCurve
gluEndSurface
gluEndTrim
gluErrorString
gluGetNurbsProperty
gluGetString
gluGetTessProperty
gluLoadSamplingMatrices
gluLookAt
gluNewNurbsRenderer
gluNewQuadric
gluNewTess
gluNurbsCurve
gluNurbsProperty
gluNurbsSurface
gluOrtho2D
gluPartialDisk
gluPerspective
gluPickMatrix
gluProject
gluPwlCurve
gluQuadricDrawStyle
gluQuadricNormals
gluQuadricOrientation
gluQuadricTexture
gluScaleImage
gluSphere
gluTessBeginContour
gluTessBeginPolygon
gluTessEndContour
gluTessEndPolygon
gluTessNormal
gluTessProperty
gluTessVertex
gluUnProject
glVertex2d
glVertex2dv
glVertex2f
glVertex2fv
glVertex2i
glVertex2iv
glVertex2s
glVertex2sv
glVertex3d
glVertex3dv
glVertex3f
glVertex3fv
glVertex3i
glVertex3iv
glVertex3s
glVertex3sv
glVertex4d
glVertex4dv
glVertex4f
glVertex4fv
glVertex4i
glVertex4iv
glVertex4s
glVertex4sv
glVertexPointer
glViewport
IntPtrCallback
LoadLibrary
ReleaseDC
SetPixelFormat
SwapBuffers
wglCreateContext
wglDeleteContext
wglGetCurrentContext
wglMakeCurrent
wglShareLists
wglUseFontOutlines

プロテクト メソッド

CreateCompatibleDC
CreateDIBSection
DeleteDC

参照

Imports クラス | Steema.TeeChart.Drawing.GL 名前空間


BitBlt

Steema.TeeChart.Drawing.GL.Imports.BitBlt メソッド

public static extern Boolean BitBlt(IntPtr hDC,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     IntPtr hDCSource,
     Int32 sourceX,
     Int32 sourceY,
     UInt32 type)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ChoosePixelFormat

Steema.TeeChart.Drawing.GL.Imports.ChoosePixelFormat メソッド

public static extern Int32 ChoosePixelFormat(IntPtr hDC,
     PIXELFORMATDESCRIPTOR ppfd)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CreateCompatibleDC

Steema.TeeChart.Drawing.GL.Imports.CreateCompatibleDC メソッド

protected static extern IntPtr CreateCompatibleDC(IntPtr hDC)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CreateDIBSection

Steema.TeeChart.Drawing.GL.Imports.CreateDIBSection メソッド

protected static extern IntPtr CreateDIBSection(IntPtr hdc,
     BITMAPINFO pbmi,
     UInt32 iUsage,
     IntPtr& ppvBits,
     IntPtr hSection,
     UInt32 dwOffset)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


CreateFont

Steema.TeeChart.Drawing.GL.Imports.CreateFont メソッド

public static extern IntPtr CreateFont(Int32 nHeight,
     Int32 nWidth,
     Int32 nEscapement,
     Int32 nOrientaion,
     Int32 fnWeight,
     UInt32 fdwItalic,
     UInt32 fdwUnderline,
     UInt32 fdwStrikeOut,
     UInt32 fdwCharSet,
     UInt32 fdwOutputPrecision,
     UInt32 fdwClipPrecision,
     UInt32 fdwQuality,
     UInt32 fdwPitchAndFamily,
     IntPtr lpszFace)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DeleteDC

Steema.TeeChart.Drawing.GL.Imports.DeleteDC メソッド

protected static extern Boolean DeleteDC(IntPtr hDC)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DeleteObject

Steema.TeeChart.Drawing.GL.Imports.DeleteObject メソッド

public static extern Boolean DeleteObject(IntPtr p1)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


DescribePixelFormat

Steema.TeeChart.Drawing.GL.Imports.DescribePixelFormat メソッド

public static extern Int32 DescribePixelFormat(IntPtr hDC,
     Int32 p2,
     UInt32 p3,
     PIXELFORMATDESCRIPTOR ppfd)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GetDC

Steema.TeeChart.Drawing.GL.Imports.GetDC メソッド

public static extern IntPtr GetDC(IntPtr hWnd)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GetDeviceCaps

Steema.TeeChart.Drawing.GL.Imports.GetDeviceCaps メソッド

public static extern Int32 GetDeviceCaps(IntPtr DC,
     Int32 Index)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GetPixelFormat

Steema.TeeChart.Drawing.GL.Imports.GetPixelFormat メソッド

public static extern Int32 GetPixelFormat(IntPtr hDC)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


GetTextExtentPoint32

Steema.TeeChart.Drawing.GL.Imports.GetTextExtentPoint32 メソッド

public static extern Int32 GetTextExtentPoint32(IntPtr hdc,
     String str,
     Int32 len,
     SIZE& size)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glAccum

Steema.TeeChart.Drawing.GL.Imports.glAccum メソッド

public static extern Void glAccum(UInt32 op,
     Single value)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glAlphaFunc

Steema.TeeChart.Drawing.GL.Imports.glAlphaFunc メソッド

public static extern Void glAlphaFunc(UInt32 func,
     Single ref_notkeword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glAreTexturesResident

Steema.TeeChart.Drawing.GL.Imports.glAreTexturesResident メソッド

public static extern Byte glAreTexturesResident(Int32 n,
     UInt32[] textures,
     Byte[] residences)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glArrayElement

Steema.TeeChart.Drawing.GL.Imports.glArrayElement メソッド

public static extern Void glArrayElement(Int32 i)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glBegin

Steema.TeeChart.Drawing.GL.Imports.glBegin メソッド

public static extern Void glBegin(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glBindTexture

Steema.TeeChart.Drawing.GL.Imports.glBindTexture メソッド

public static extern Void glBindTexture(UInt32 target,
     UInt32 texture)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glBitmap

Steema.TeeChart.Drawing.GL.Imports.glBitmap メソッド

public static extern Void glBitmap(Int32 width,
     Int32 height,
     Single xorig,
     Single yorig,
     Single xmove,
     Single ymove,
     Byte[] bitmap)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glBlendFunc

Steema.TeeChart.Drawing.GL.Imports.glBlendFunc メソッド

public static extern Void glBlendFunc(UInt32 sfactor,
     UInt32 dfactor)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallList

Steema.TeeChart.Drawing.GL.Imports.glCallList メソッド

public static extern Void glCallList(UInt32 list)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

オーバーロードの一覧

public static extern Void glCallLists(System.Int32, System.UInt32, System.Byte[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.SByte[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.Int16[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.UInt16[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.Int32[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.UInt32[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.Single[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.Char[])
public static extern Void glCallLists(System.Int32, System.UInt32, System.String)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     Byte[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     SByte[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     Int16[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     UInt16[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     Int32[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     UInt32[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     Single[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     Char[] lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCallLists

Steema.TeeChart.Drawing.GL.Imports.glCallLists メソッド

public static extern Void glCallLists(Int32 n,
     UInt32 type,
     String lists)

参照

glCallLists オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClear

Steema.TeeChart.Drawing.GL.Imports.glClear メソッド

public static extern Void glClear(UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClearAccum

Steema.TeeChart.Drawing.GL.Imports.glClearAccum メソッド

public static extern Void glClearAccum(Single red,
     Single green,
     Single blue,
     Single alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClearColor

Steema.TeeChart.Drawing.GL.Imports.glClearColor メソッド

public static extern Void glClearColor(Single red,
     Single green,
     Single blue,
     Single alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClearDepth

Steema.TeeChart.Drawing.GL.Imports.glClearDepth メソッド

public static extern Void glClearDepth(Double depth)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClearIndex

Steema.TeeChart.Drawing.GL.Imports.glClearIndex メソッド

public static extern Void glClearIndex(Single c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClearStencil

Steema.TeeChart.Drawing.GL.Imports.glClearStencil メソッド

public static extern Void glClearStencil(Int32 s)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glClipPlane

Steema.TeeChart.Drawing.GL.Imports.glClipPlane メソッド

public static extern Void glClipPlane(UInt32 plane,
     Double[] equation)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3b

Steema.TeeChart.Drawing.GL.Imports.glColor3b メソッド

public static extern Void glColor3b(Byte red,
     Byte green,
     Byte blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3bv

Steema.TeeChart.Drawing.GL.Imports.glColor3bv メソッド

public static extern Void glColor3bv(Byte[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3d

Steema.TeeChart.Drawing.GL.Imports.glColor3d メソッド

public static extern Void glColor3d(Double red,
     Double green,
     Double blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3dv

Steema.TeeChart.Drawing.GL.Imports.glColor3dv メソッド

public static extern Void glColor3dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3f

Steema.TeeChart.Drawing.GL.Imports.glColor3f メソッド

public static extern Void glColor3f(Single red,
     Single green,
     Single blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3fv

Steema.TeeChart.Drawing.GL.Imports.glColor3fv メソッド

public static extern Void glColor3fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3i

Steema.TeeChart.Drawing.GL.Imports.glColor3i メソッド

public static extern Void glColor3i(Int32 red,
     Int32 green,
     Int32 blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3iv

Steema.TeeChart.Drawing.GL.Imports.glColor3iv メソッド

public static extern Void glColor3iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3s

Steema.TeeChart.Drawing.GL.Imports.glColor3s メソッド

public static extern Void glColor3s(Int16 red,
     Int16 green,
     Int16 blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3sv

Steema.TeeChart.Drawing.GL.Imports.glColor3sv メソッド

public static extern Void glColor3sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3ub

Steema.TeeChart.Drawing.GL.Imports.glColor3ub メソッド

public static extern Void glColor3ub(Byte red,
     Byte green,
     Byte blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3ubv

Steema.TeeChart.Drawing.GL.Imports.glColor3ubv メソッド

public static extern Void glColor3ubv(Byte[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3ubv

Steema.TeeChart.Drawing.GL.Imports.glColor3ubv メソッド

public static extern Void glColor3ubv(Byte[] v)

参照

glColor3ubv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3ubv

Steema.TeeChart.Drawing.GL.Imports.glColor3ubv メソッド

public static extern Void glColor3ubv(Byte* v)

参照

glColor3ubv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3ui

Steema.TeeChart.Drawing.GL.Imports.glColor3ui メソッド

public static extern Void glColor3ui(UInt32 red,
     UInt32 green,
     UInt32 blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3uiv

Steema.TeeChart.Drawing.GL.Imports.glColor3uiv メソッド

public static extern Void glColor3uiv(UInt32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3us

Steema.TeeChart.Drawing.GL.Imports.glColor3us メソッド

public static extern Void glColor3us(UInt16 red,
     UInt16 green,
     UInt16 blue)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor3usv

Steema.TeeChart.Drawing.GL.Imports.glColor3usv メソッド

public static extern Void glColor3usv(UInt16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4b

Steema.TeeChart.Drawing.GL.Imports.glColor4b メソッド

public static extern Void glColor4b(Byte red,
     Byte green,
     Byte blue,
     Byte alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4bv

Steema.TeeChart.Drawing.GL.Imports.glColor4bv メソッド

public static extern Void glColor4bv(Byte[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4d

Steema.TeeChart.Drawing.GL.Imports.glColor4d メソッド

public static extern Void glColor4d(Double red,
     Double green,
     Double blue,
     Double alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4dv

Steema.TeeChart.Drawing.GL.Imports.glColor4dv メソッド

public static extern Void glColor4dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4f

Steema.TeeChart.Drawing.GL.Imports.glColor4f メソッド

public static extern Void glColor4f(Single red,
     Single green,
     Single blue,
     Single alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4fv

Steema.TeeChart.Drawing.GL.Imports.glColor4fv メソッド

public static extern Void glColor4fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4i

Steema.TeeChart.Drawing.GL.Imports.glColor4i メソッド

public static extern Void glColor4i(Int32 red,
     Int32 green,
     Int32 blue,
     Int32 alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4iv

Steema.TeeChart.Drawing.GL.Imports.glColor4iv メソッド

public static extern Void glColor4iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4s

Steema.TeeChart.Drawing.GL.Imports.glColor4s メソッド

public static extern Void glColor4s(Int16 red,
     Int16 green,
     Int16 blue,
     Int16 alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4sv

Steema.TeeChart.Drawing.GL.Imports.glColor4sv メソッド

public static extern Void glColor4sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4ub

Steema.TeeChart.Drawing.GL.Imports.glColor4ub メソッド

public static extern Void glColor4ub(Byte red,
     Byte green,
     Byte blue,
     Byte alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4ubv

Steema.TeeChart.Drawing.GL.Imports.glColor4ubv メソッド

public static extern Void glColor4ubv(Byte[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4ubv

Steema.TeeChart.Drawing.GL.Imports.glColor4ubv メソッド

public static extern Void glColor4ubv(Byte[] v)

参照

glColor4ubv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4ubv

Steema.TeeChart.Drawing.GL.Imports.glColor4ubv メソッド

public static extern Void glColor4ubv(Byte* v)

参照

glColor4ubv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4ui

Steema.TeeChart.Drawing.GL.Imports.glColor4ui メソッド

public static extern Void glColor4ui(UInt32 red,
     UInt32 green,
     UInt32 blue,
     UInt32 alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4uiv

Steema.TeeChart.Drawing.GL.Imports.glColor4uiv メソッド

public static extern Void glColor4uiv(UInt32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4us

Steema.TeeChart.Drawing.GL.Imports.glColor4us メソッド

public static extern Void glColor4us(UInt16 red,
     UInt16 green,
     UInt16 blue,
     UInt16 alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColor4usv

Steema.TeeChart.Drawing.GL.Imports.glColor4usv メソッド

public static extern Void glColor4usv(UInt16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColorMask

Steema.TeeChart.Drawing.GL.Imports.glColorMask メソッド

public static extern Void glColorMask(Byte red,
     Byte green,
     Byte blue,
     Byte alpha)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColorMaterial

Steema.TeeChart.Drawing.GL.Imports.glColorMaterial メソッド

public static extern Void glColorMaterial(UInt32 face,
     UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glColorPointer

Steema.TeeChart.Drawing.GL.Imports.glColorPointer メソッド

public static extern Void glColorPointer(Int32 size,
     UInt32 type,
     Int32 stride,
     Int32[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCopyPixels

Steema.TeeChart.Drawing.GL.Imports.glCopyPixels メソッド

public static extern Void glCopyPixels(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     UInt32 type)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCopyTexImage1D

Steema.TeeChart.Drawing.GL.Imports.glCopyTexImage1D メソッド

public static extern Void glCopyTexImage1D(UInt32 target,
     Int32 level,
     UInt32 internalFormat,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 border)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCopyTexImage2D

Steema.TeeChart.Drawing.GL.Imports.glCopyTexImage2D メソッド

public static extern Void glCopyTexImage2D(UInt32 target,
     Int32 level,
     UInt32 internalFormat,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     Int32 border)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCopyTexSubImage1D

Steema.TeeChart.Drawing.GL.Imports.glCopyTexSubImage1D メソッド

public static extern Void glCopyTexSubImage1D(UInt32 target,
     Int32 level,
     Int32 xoffset,
     Int32 x,
     Int32 y,
     Int32 width)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCopyTexSubImage2D

Steema.TeeChart.Drawing.GL.Imports.glCopyTexSubImage2D メソッド

public static extern Void glCopyTexSubImage2D(UInt32 target,
     Int32 level,
     Int32 xoffset,
     Int32 yoffset,
     Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glCullFace

Steema.TeeChart.Drawing.GL.Imports.glCullFace メソッド

public static extern Void glCullFace(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDeleteLists

Steema.TeeChart.Drawing.GL.Imports.glDeleteLists メソッド

public static extern Void glDeleteLists(UInt32 list,
     Int32 range)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDeleteTextures

Steema.TeeChart.Drawing.GL.Imports.glDeleteTextures メソッド

public static extern Void glDeleteTextures(Int32 n,
     UInt32[] textures)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDepthFunc

Steema.TeeChart.Drawing.GL.Imports.glDepthFunc メソッド

public static extern Void glDepthFunc(UInt32 func)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDepthMask

Steema.TeeChart.Drawing.GL.Imports.glDepthMask メソッド

public static extern Void glDepthMask(Byte flag)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDepthRange

Steema.TeeChart.Drawing.GL.Imports.glDepthRange メソッド

public static extern Void glDepthRange(Double zNear,
     Double zFar)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDisable

Steema.TeeChart.Drawing.GL.Imports.glDisable メソッド

public static extern Void glDisable(UInt32 cap)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDisableClientState

Steema.TeeChart.Drawing.GL.Imports.glDisableClientState メソッド

public static extern Void glDisableClientState(UInt32 array)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDrawArrays

Steema.TeeChart.Drawing.GL.Imports.glDrawArrays メソッド

public static extern Void glDrawArrays(UInt32 mode,
     Int32 first,
     Int32 count)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDrawBuffer

Steema.TeeChart.Drawing.GL.Imports.glDrawBuffer メソッド

public static extern Void glDrawBuffer(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDrawElements

Steema.TeeChart.Drawing.GL.Imports.glDrawElements メソッド

public static extern Void glDrawElements(UInt32 mode,
     Int32 count,
     UInt32 type,
     Int32[] indices)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glDrawPixels

Steema.TeeChart.Drawing.GL.Imports.glDrawPixels メソッド

public static extern Void glDrawPixels(Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     Single[] pixels)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEdgeFlag

Steema.TeeChart.Drawing.GL.Imports.glEdgeFlag メソッド

public static extern Void glEdgeFlag(Byte flag)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEdgeFlagPointer

Steema.TeeChart.Drawing.GL.Imports.glEdgeFlagPointer メソッド

public static extern Void glEdgeFlagPointer(Int32 stride,
     Int32[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEdgeFlagv

Steema.TeeChart.Drawing.GL.Imports.glEdgeFlagv メソッド

public static extern Void glEdgeFlagv(Byte[] flag)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEnable

Steema.TeeChart.Drawing.GL.Imports.glEnable メソッド

public static extern Void glEnable(UInt32 cap)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEnableClientState

Steema.TeeChart.Drawing.GL.Imports.glEnableClientState メソッド

public static extern Void glEnableClientState(UInt32 array)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEnd

Steema.TeeChart.Drawing.GL.Imports.glEnd メソッド

public static extern Void glEnd()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEndList

Steema.TeeChart.Drawing.GL.Imports.glEndList メソッド

public static extern Void glEndList()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord1d

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord1d メソッド

public static extern Void glEvalCoord1d(Double u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord1dv

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord1dv メソッド

public static extern Void glEvalCoord1dv(Double[] u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord1f

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord1f メソッド

public static extern Void glEvalCoord1f(Single u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord1fv

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord1fv メソッド

public static extern Void glEvalCoord1fv(Single[] u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord2d

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord2d メソッド

public static extern Void glEvalCoord2d(Double u,
     Double v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord2dv

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord2dv メソッド

public static extern Void glEvalCoord2dv(Double[] u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord2f

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord2f メソッド

public static extern Void glEvalCoord2f(Single u,
     Single v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalCoord2fv

Steema.TeeChart.Drawing.GL.Imports.glEvalCoord2fv メソッド

public static extern Void glEvalCoord2fv(Single[] u)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalMesh1

Steema.TeeChart.Drawing.GL.Imports.glEvalMesh1 メソッド

public static extern Void glEvalMesh1(UInt32 mode,
     Int32 i1,
     Int32 i2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalMesh2

Steema.TeeChart.Drawing.GL.Imports.glEvalMesh2 メソッド

public static extern Void glEvalMesh2(UInt32 mode,
     Int32 i1,
     Int32 i2,
     Int32 j1,
     Int32 j2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalPoint1

Steema.TeeChart.Drawing.GL.Imports.glEvalPoint1 メソッド

public static extern Void glEvalPoint1(Int32 i)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glEvalPoint2

Steema.TeeChart.Drawing.GL.Imports.glEvalPoint2 メソッド

public static extern Void glEvalPoint2(Int32 i,
     Int32 j)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFeedbackBuffer

Steema.TeeChart.Drawing.GL.Imports.glFeedbackBuffer メソッド

public static extern Void glFeedbackBuffer(Int32 size,
     UInt32 type,
     Single[] buffer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFinish

Steema.TeeChart.Drawing.GL.Imports.glFinish メソッド

public static extern Void glFinish()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFlush

Steema.TeeChart.Drawing.GL.Imports.glFlush メソッド

public static extern Void glFlush()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFogf

Steema.TeeChart.Drawing.GL.Imports.glFogf メソッド

public static extern Void glFogf(UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFogfv

Steema.TeeChart.Drawing.GL.Imports.glFogfv メソッド

public static extern Void glFogfv(UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFogi

Steema.TeeChart.Drawing.GL.Imports.glFogi メソッド

public static extern Void glFogi(UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFogiv

Steema.TeeChart.Drawing.GL.Imports.glFogiv メソッド

public static extern Void glFogiv(UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFrontFace

Steema.TeeChart.Drawing.GL.Imports.glFrontFace メソッド

public static extern Void glFrontFace(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glFrustum

Steema.TeeChart.Drawing.GL.Imports.glFrustum メソッド

public static extern Void glFrustum(Double left,
     Double right,
     Double bottom,
     Double top,
     Double zNear,
     Double zFar)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGenLists

Steema.TeeChart.Drawing.GL.Imports.glGenLists メソッド

public static extern UInt32 glGenLists(Int32 range)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGenTextures

Steema.TeeChart.Drawing.GL.Imports.glGenTextures メソッド

public static extern Void glGenTextures(Int32 n,
     UInt32[] textures)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetBooleanv

Steema.TeeChart.Drawing.GL.Imports.glGetBooleanv メソッド

public static extern Void glGetBooleanv(UInt32 pname,
     Byte[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetClipPlane

Steema.TeeChart.Drawing.GL.Imports.glGetClipPlane メソッド

public static extern Void glGetClipPlane(UInt32 plane,
     Double[] equation)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetDoublev

Steema.TeeChart.Drawing.GL.Imports.glGetDoublev メソッド

public static extern Void glGetDoublev(UInt32 pname,
     Double[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetDoublev

Steema.TeeChart.Drawing.GL.Imports.glGetDoublev メソッド

public static extern Void glGetDoublev(UInt32 pname,
     Double[] params_notkeyword)

参照

glGetDoublev オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetDoublev

Steema.TeeChart.Drawing.GL.Imports.glGetDoublev メソッド

public static extern Void glGetDoublev(UInt32 pname,
     Double* params_notkeyword)

参照

glGetDoublev オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetError

Steema.TeeChart.Drawing.GL.Imports.glGetError メソッド

public static extern UInt32 glGetError()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetFloatv

Steema.TeeChart.Drawing.GL.Imports.glGetFloatv メソッド

public static extern Void glGetFloatv(UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetIntegerv

Steema.TeeChart.Drawing.GL.Imports.glGetIntegerv メソッド

public static extern Void glGetIntegerv(UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetIntegerv

Steema.TeeChart.Drawing.GL.Imports.glGetIntegerv メソッド

public static extern Void glGetIntegerv(UInt32 pname,
     Int32[] params_notkeyword)

参照

glGetIntegerv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetIntegerv

Steema.TeeChart.Drawing.GL.Imports.glGetIntegerv メソッド

public static extern Void glGetIntegerv(UInt32 pname,
     Int32* params_notkeyword)

参照

glGetIntegerv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetLightfv

Steema.TeeChart.Drawing.GL.Imports.glGetLightfv メソッド

public static extern Void glGetLightfv(UInt32 light,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetLightiv

Steema.TeeChart.Drawing.GL.Imports.glGetLightiv メソッド

public static extern Void glGetLightiv(UInt32 light,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetMapdv

Steema.TeeChart.Drawing.GL.Imports.glGetMapdv メソッド

public static extern Void glGetMapdv(UInt32 target,
     UInt32 query,
     Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetMapfv

Steema.TeeChart.Drawing.GL.Imports.glGetMapfv メソッド

public static extern Void glGetMapfv(UInt32 target,
     UInt32 query,
     Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetMapiv

Steema.TeeChart.Drawing.GL.Imports.glGetMapiv メソッド

public static extern Void glGetMapiv(UInt32 target,
     UInt32 query,
     Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetMaterialfv

Steema.TeeChart.Drawing.GL.Imports.glGetMaterialfv メソッド

public static extern Void glGetMaterialfv(UInt32 face,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetMaterialiv

Steema.TeeChart.Drawing.GL.Imports.glGetMaterialiv メソッド

public static extern Void glGetMaterialiv(UInt32 face,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetPixelMapfv

Steema.TeeChart.Drawing.GL.Imports.glGetPixelMapfv メソッド

public static extern Void glGetPixelMapfv(UInt32 map,
     Single[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetPixelMapuiv

Steema.TeeChart.Drawing.GL.Imports.glGetPixelMapuiv メソッド

public static extern Void glGetPixelMapuiv(UInt32 map,
     UInt32[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetPixelMapusv

Steema.TeeChart.Drawing.GL.Imports.glGetPixelMapusv メソッド

public static extern Void glGetPixelMapusv(UInt32 map,
     UInt16[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetPointerv

Steema.TeeChart.Drawing.GL.Imports.glGetPointerv メソッド

public static extern Void glGetPointerv(UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetPolygonStipple

Steema.TeeChart.Drawing.GL.Imports.glGetPolygonStipple メソッド

public static extern Void glGetPolygonStipple(Byte[] mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetString

Steema.TeeChart.Drawing.GL.Imports.glGetString メソッド

public static extern SByte* glGetString(UInt32 name)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexEnvfv

Steema.TeeChart.Drawing.GL.Imports.glGetTexEnvfv メソッド

public static extern Void glGetTexEnvfv(UInt32 target,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexEnviv

Steema.TeeChart.Drawing.GL.Imports.glGetTexEnviv メソッド

public static extern Void glGetTexEnviv(UInt32 target,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexGendv

Steema.TeeChart.Drawing.GL.Imports.glGetTexGendv メソッド

public static extern Void glGetTexGendv(UInt32 coord,
     UInt32 pname,
     Double[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexGenfv

Steema.TeeChart.Drawing.GL.Imports.glGetTexGenfv メソッド

public static extern Void glGetTexGenfv(UInt32 coord,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexGeniv

Steema.TeeChart.Drawing.GL.Imports.glGetTexGeniv メソッド

public static extern Void glGetTexGeniv(UInt32 coord,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexImage

Steema.TeeChart.Drawing.GL.Imports.glGetTexImage メソッド

public static extern Void glGetTexImage(UInt32 target,
     Int32 level,
     UInt32 format,
     UInt32 type,
     Int32[] pixels)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexLevelParameterfv

Steema.TeeChart.Drawing.GL.Imports.glGetTexLevelParameterfv メソッド

public static extern Void glGetTexLevelParameterfv(UInt32 target,
     Int32 level,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexLevelParameteriv

Steema.TeeChart.Drawing.GL.Imports.glGetTexLevelParameteriv メソッド

public static extern Void glGetTexLevelParameteriv(UInt32 target,
     Int32 level,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexParameterfv

Steema.TeeChart.Drawing.GL.Imports.glGetTexParameterfv メソッド

public static extern Void glGetTexParameterfv(UInt32 target,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glGetTexParameteriv

Steema.TeeChart.Drawing.GL.Imports.glGetTexParameteriv メソッド

public static extern Void glGetTexParameteriv(UInt32 target,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glHint

Steema.TeeChart.Drawing.GL.Imports.glHint メソッド

public static extern Void glHint(UInt32 target,
     UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexd

Steema.TeeChart.Drawing.GL.Imports.glIndexd メソッド

public static extern Void glIndexd(Double c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexdv

Steema.TeeChart.Drawing.GL.Imports.glIndexdv メソッド

public static extern Void glIndexdv(Double[] c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexf

Steema.TeeChart.Drawing.GL.Imports.glIndexf メソッド

public static extern Void glIndexf(Single c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexfv

Steema.TeeChart.Drawing.GL.Imports.glIndexfv メソッド

public static extern Void glIndexfv(Single[] c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexi

Steema.TeeChart.Drawing.GL.Imports.glIndexi メソッド

public static extern Void glIndexi(Int32 c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexiv

Steema.TeeChart.Drawing.GL.Imports.glIndexiv メソッド

public static extern Void glIndexiv(Int32[] c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexMask

Steema.TeeChart.Drawing.GL.Imports.glIndexMask メソッド

public static extern Void glIndexMask(UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexPointer

Steema.TeeChart.Drawing.GL.Imports.glIndexPointer メソッド

public static extern Void glIndexPointer(UInt32 type,
     Int32 stride,
     Int32[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexs

Steema.TeeChart.Drawing.GL.Imports.glIndexs メソッド

public static extern Void glIndexs(Int16 c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexsv

Steema.TeeChart.Drawing.GL.Imports.glIndexsv メソッド

public static extern Void glIndexsv(Int16[] c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexub

Steema.TeeChart.Drawing.GL.Imports.glIndexub メソッド

public static extern Void glIndexub(Byte c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIndexubv

Steema.TeeChart.Drawing.GL.Imports.glIndexubv メソッド

public static extern Void glIndexubv(Byte[] c)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glInitNames

Steema.TeeChart.Drawing.GL.Imports.glInitNames メソッド

public static extern Void glInitNames()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glInterleavedArrays

Steema.TeeChart.Drawing.GL.Imports.glInterleavedArrays メソッド

public static extern Void glInterleavedArrays(UInt32 format,
     Int32 stride,
     Int32[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIsEnabled

Steema.TeeChart.Drawing.GL.Imports.glIsEnabled メソッド

public static extern Byte glIsEnabled(UInt32 cap)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIsList

Steema.TeeChart.Drawing.GL.Imports.glIsList メソッド

public static extern Byte glIsList(UInt32 list)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glIsTexture

Steema.TeeChart.Drawing.GL.Imports.glIsTexture メソッド

public static extern Byte glIsTexture(UInt32 texture)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightf

Steema.TeeChart.Drawing.GL.Imports.glLightf メソッド

public static extern Void glLightf(UInt32 light,
     UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightfv

Steema.TeeChart.Drawing.GL.Imports.glLightfv メソッド

public static extern Void glLightfv(UInt32 light,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLighti

Steema.TeeChart.Drawing.GL.Imports.glLighti メソッド

public static extern Void glLighti(UInt32 light,
     UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightiv

Steema.TeeChart.Drawing.GL.Imports.glLightiv メソッド

public static extern Void glLightiv(UInt32 light,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightModelf

Steema.TeeChart.Drawing.GL.Imports.glLightModelf メソッド

public static extern Void glLightModelf(UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightModelfv

Steema.TeeChart.Drawing.GL.Imports.glLightModelfv メソッド

public static extern Void glLightModelfv(UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightModeli

Steema.TeeChart.Drawing.GL.Imports.glLightModeli メソッド

public static extern Void glLightModeli(UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLightModeliv

Steema.TeeChart.Drawing.GL.Imports.glLightModeliv メソッド

public static extern Void glLightModeliv(UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLineStipple

Steema.TeeChart.Drawing.GL.Imports.glLineStipple メソッド

public static extern Void glLineStipple(Int32 factor,
     UInt16 pattern)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLineWidth

Steema.TeeChart.Drawing.GL.Imports.glLineWidth メソッド

public static extern Void glLineWidth(Single width)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glListBase

Steema.TeeChart.Drawing.GL.Imports.glListBase メソッド

public static extern Void glListBase(UInt32 base_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLoadIdentity

Steema.TeeChart.Drawing.GL.Imports.glLoadIdentity メソッド

public static extern Void glLoadIdentity()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLoadMatrixd

Steema.TeeChart.Drawing.GL.Imports.glLoadMatrixd メソッド

public static extern Void glLoadMatrixd(Double[] m)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLoadMatrixf

Steema.TeeChart.Drawing.GL.Imports.glLoadMatrixf メソッド

public static extern Void glLoadMatrixf(Single[] m)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLoadName

Steema.TeeChart.Drawing.GL.Imports.glLoadName メソッド

public static extern Void glLoadName(UInt32 name)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glLogicOp

Steema.TeeChart.Drawing.GL.Imports.glLogicOp メソッド

public static extern Void glLogicOp(UInt32 opcode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMap1d

Steema.TeeChart.Drawing.GL.Imports.glMap1d メソッド

public static extern Void glMap1d(UInt32 target,
     Double u1,
     Double u2,
     Int32 stride,
     Int32 order,
     Double[] points)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMap1f

Steema.TeeChart.Drawing.GL.Imports.glMap1f メソッド

public static extern Void glMap1f(UInt32 target,
     Single u1,
     Single u2,
     Int32 stride,
     Int32 order,
     Single[] points)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMap2d

Steema.TeeChart.Drawing.GL.Imports.glMap2d メソッド

public static extern Void glMap2d(UInt32 target,
     Double u1,
     Double u2,
     Int32 ustride,
     Int32 uorder,
     Double v1,
     Double v2,
     Int32 vstride,
     Int32 vorder,
     Double[] points)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMap2f

Steema.TeeChart.Drawing.GL.Imports.glMap2f メソッド

public static extern Void glMap2f(UInt32 target,
     Single u1,
     Single u2,
     Int32 ustride,
     Int32 uorder,
     Single v1,
     Single v2,
     Int32 vstride,
     Int32 vorder,
     Single[] points)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMapGrid1d

Steema.TeeChart.Drawing.GL.Imports.glMapGrid1d メソッド

public static extern Void glMapGrid1d(Int32 un,
     Double u1,
     Double u2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMapGrid1f

Steema.TeeChart.Drawing.GL.Imports.glMapGrid1f メソッド

public static extern Void glMapGrid1f(Int32 un,
     Single u1,
     Single u2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMapGrid2d

Steema.TeeChart.Drawing.GL.Imports.glMapGrid2d メソッド

public static extern Void glMapGrid2d(Int32 un,
     Double u1,
     Double u2,
     Int32 vn,
     Double v1,
     Double v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMapGrid2f

Steema.TeeChart.Drawing.GL.Imports.glMapGrid2f メソッド

public static extern Void glMapGrid2f(Int32 un,
     Single u1,
     Single u2,
     Int32 vn,
     Single v1,
     Single v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMaterialf

Steema.TeeChart.Drawing.GL.Imports.glMaterialf メソッド

public static extern Void glMaterialf(UInt32 face,
     UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMaterialfv

Steema.TeeChart.Drawing.GL.Imports.glMaterialfv メソッド

public static extern Void glMaterialfv(UInt32 face,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMaterialfv

Steema.TeeChart.Drawing.GL.Imports.glMaterialfv メソッド

public static extern Void glMaterialfv(UInt32 face,
     UInt32 pname,
     Single[] params_notkeyword)

参照

glMaterialfv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMaterialfv

Steema.TeeChart.Drawing.GL.Imports.glMaterialfv メソッド

public static extern Void glMaterialfv(UInt32 face,
     UInt32 pname,
     Single* params_notkeyword)

参照

glMaterialfv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMateriali

Steema.TeeChart.Drawing.GL.Imports.glMateriali メソッド

public static extern Void glMateriali(UInt32 face,
     UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMaterialiv

Steema.TeeChart.Drawing.GL.Imports.glMaterialiv メソッド

public static extern Void glMaterialiv(UInt32 face,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMatrixMode

Steema.TeeChart.Drawing.GL.Imports.glMatrixMode メソッド

public static extern Void glMatrixMode(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMultMatrixd

Steema.TeeChart.Drawing.GL.Imports.glMultMatrixd メソッド

public static extern Void glMultMatrixd(Double[] m)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMultMatrixd

Steema.TeeChart.Drawing.GL.Imports.glMultMatrixd メソッド

public static extern Void glMultMatrixd(Double[] m)

参照

glMultMatrixd オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMultMatrixd

Steema.TeeChart.Drawing.GL.Imports.glMultMatrixd メソッド

public static extern Void glMultMatrixd(Double* m)

参照

glMultMatrixd オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glMultMatrixf

Steema.TeeChart.Drawing.GL.Imports.glMultMatrixf メソッド

public static extern Void glMultMatrixf(Single[] m)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNewList

Steema.TeeChart.Drawing.GL.Imports.glNewList メソッド

public static extern Void glNewList(UInt32 list,
     UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3b

Steema.TeeChart.Drawing.GL.Imports.glNormal3b メソッド

public static extern Void glNormal3b(Byte nx,
     Byte ny,
     Byte nz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3bv

Steema.TeeChart.Drawing.GL.Imports.glNormal3bv メソッド

public static extern Void glNormal3bv(Byte[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3d

Steema.TeeChart.Drawing.GL.Imports.glNormal3d メソッド

public static extern Void glNormal3d(Double nx,
     Double ny,
     Double nz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3dv

Steema.TeeChart.Drawing.GL.Imports.glNormal3dv メソッド

public static extern Void glNormal3dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3f

Steema.TeeChart.Drawing.GL.Imports.glNormal3f メソッド

public static extern Void glNormal3f(Single nx,
     Single ny,
     Single nz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3fv

Steema.TeeChart.Drawing.GL.Imports.glNormal3fv メソッド

public static extern Void glNormal3fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3i

Steema.TeeChart.Drawing.GL.Imports.glNormal3i メソッド

public static extern Void glNormal3i(Int32 nx,
     Int32 ny,
     Int32 nz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3iv

Steema.TeeChart.Drawing.GL.Imports.glNormal3iv メソッド

public static extern Void glNormal3iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3s

Steema.TeeChart.Drawing.GL.Imports.glNormal3s メソッド

public static extern Void glNormal3s(Int16 nx,
     Int16 ny,
     Int16 nz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormal3sv

Steema.TeeChart.Drawing.GL.Imports.glNormal3sv メソッド

public static extern Void glNormal3sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glNormalPointer

Steema.TeeChart.Drawing.GL.Imports.glNormalPointer メソッド

public static extern Void glNormalPointer(UInt32 type,
     Int32 stride,
     Single[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glOrtho

Steema.TeeChart.Drawing.GL.Imports.glOrtho メソッド

public static extern Void glOrtho(Double left,
     Double right,
     Double bottom,
     Double top,
     Double zNear,
     Double zFar)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPassThrough

Steema.TeeChart.Drawing.GL.Imports.glPassThrough メソッド

public static extern Void glPassThrough(Single token)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelMapfv

Steema.TeeChart.Drawing.GL.Imports.glPixelMapfv メソッド

public static extern Void glPixelMapfv(UInt32 map,
     Int32 mapsize,
     Single[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelMapuiv

Steema.TeeChart.Drawing.GL.Imports.glPixelMapuiv メソッド

public static extern Void glPixelMapuiv(UInt32 map,
     Int32 mapsize,
     UInt32[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelMapusv

Steema.TeeChart.Drawing.GL.Imports.glPixelMapusv メソッド

public static extern Void glPixelMapusv(UInt32 map,
     Int32 mapsize,
     UInt16[] values)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelStoref

Steema.TeeChart.Drawing.GL.Imports.glPixelStoref メソッド

public static extern Void glPixelStoref(UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelStorei

Steema.TeeChart.Drawing.GL.Imports.glPixelStorei メソッド

public static extern Void glPixelStorei(UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelTransferf

Steema.TeeChart.Drawing.GL.Imports.glPixelTransferf メソッド

public static extern Void glPixelTransferf(UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelTransferi

Steema.TeeChart.Drawing.GL.Imports.glPixelTransferi メソッド

public static extern Void glPixelTransferi(UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPixelZoom

Steema.TeeChart.Drawing.GL.Imports.glPixelZoom メソッド

public static extern Void glPixelZoom(Single xfactor,
     Single yfactor)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPointSize

Steema.TeeChart.Drawing.GL.Imports.glPointSize メソッド

public static extern Void glPointSize(Single size)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPolygonMode

Steema.TeeChart.Drawing.GL.Imports.glPolygonMode メソッド

public static extern Void glPolygonMode(UInt32 face,
     UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPolygonOffset

Steema.TeeChart.Drawing.GL.Imports.glPolygonOffset メソッド

public static extern Void glPolygonOffset(Single factor,
     Single units)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPolygonStipple

Steema.TeeChart.Drawing.GL.Imports.glPolygonStipple メソッド

public static extern Void glPolygonStipple(Byte[] mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPopAttrib

Steema.TeeChart.Drawing.GL.Imports.glPopAttrib メソッド

public static extern Void glPopAttrib()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPopClientAttrib

Steema.TeeChart.Drawing.GL.Imports.glPopClientAttrib メソッド

public static extern Void glPopClientAttrib()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPopMatrix

Steema.TeeChart.Drawing.GL.Imports.glPopMatrix メソッド

public static extern Void glPopMatrix()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPopName

Steema.TeeChart.Drawing.GL.Imports.glPopName メソッド

public static extern Void glPopName()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPrioritizeTextures

Steema.TeeChart.Drawing.GL.Imports.glPrioritizeTextures メソッド

public static extern Void glPrioritizeTextures(Int32 n,
     UInt32[] textures,
     Single[] priorities)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPushAttrib

Steema.TeeChart.Drawing.GL.Imports.glPushAttrib メソッド

public static extern Void glPushAttrib(UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPushClientAttrib

Steema.TeeChart.Drawing.GL.Imports.glPushClientAttrib メソッド

public static extern Void glPushClientAttrib(UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPushMatrix

Steema.TeeChart.Drawing.GL.Imports.glPushMatrix メソッド

public static extern Void glPushMatrix()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glPushName

Steema.TeeChart.Drawing.GL.Imports.glPushName メソッド

public static extern Void glPushName(UInt32 name)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2d

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2d メソッド

public static extern Void glRasterPos2d(Double x,
     Double y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2dv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2dv メソッド

public static extern Void glRasterPos2dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2f

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2f メソッド

public static extern Void glRasterPos2f(Single x,
     Single y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2fv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2fv メソッド

public static extern Void glRasterPos2fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2i

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2i メソッド

public static extern Void glRasterPos2i(Int32 x,
     Int32 y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2iv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2iv メソッド

public static extern Void glRasterPos2iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2s

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2s メソッド

public static extern Void glRasterPos2s(Int16 x,
     Int16 y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos2sv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos2sv メソッド

public static extern Void glRasterPos2sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3d

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3d メソッド

public static extern Void glRasterPos3d(Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3dv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3dv メソッド

public static extern Void glRasterPos3dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3f

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3f メソッド

public static extern Void glRasterPos3f(Single x,
     Single y,
     Single z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3fv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3fv メソッド

public static extern Void glRasterPos3fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3i

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3i メソッド

public static extern Void glRasterPos3i(Int32 x,
     Int32 y,
     Int32 z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3iv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3iv メソッド

public static extern Void glRasterPos3iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3s

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3s メソッド

public static extern Void glRasterPos3s(Int16 x,
     Int16 y,
     Int16 z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos3sv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos3sv メソッド

public static extern Void glRasterPos3sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4d

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4d メソッド

public static extern Void glRasterPos4d(Double x,
     Double y,
     Double z,
     Double w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4dv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4dv メソッド

public static extern Void glRasterPos4dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4f

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4f メソッド

public static extern Void glRasterPos4f(Single x,
     Single y,
     Single z,
     Single w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4fv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4fv メソッド

public static extern Void glRasterPos4fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4i

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4i メソッド

public static extern Void glRasterPos4i(Int32 x,
     Int32 y,
     Int32 z,
     Int32 w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4iv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4iv メソッド

public static extern Void glRasterPos4iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4s

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4s メソッド

public static extern Void glRasterPos4s(Int16 x,
     Int16 y,
     Int16 z,
     Int16 w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRasterPos4sv

Steema.TeeChart.Drawing.GL.Imports.glRasterPos4sv メソッド

public static extern Void glRasterPos4sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadBuffer

Steema.TeeChart.Drawing.GL.Imports.glReadBuffer メソッド

public static extern Void glReadBuffer(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadPixels

Steema.TeeChart.Drawing.GL.Imports.glReadPixels メソッド

オーバーロードの一覧

public static extern Void glReadPixels(System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.IntPtr)
public static extern Void glReadPixels(System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.Byte[])
public static extern Void glReadPixels(System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.UInt16[])
public static extern Void glReadPixels(System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.Single[])

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadPixels

Steema.TeeChart.Drawing.GL.Imports.glReadPixels メソッド

public static extern Void glReadPixels(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     IntPtr pixels)

参照

glReadPixels オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadPixels

Steema.TeeChart.Drawing.GL.Imports.glReadPixels メソッド

public static extern Void glReadPixels(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     Byte[] pixels)

参照

glReadPixels オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadPixels

Steema.TeeChart.Drawing.GL.Imports.glReadPixels メソッド

public static extern Void glReadPixels(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     UInt16[] pixels)

参照

glReadPixels オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glReadPixels

Steema.TeeChart.Drawing.GL.Imports.glReadPixels メソッド

public static extern Void glReadPixels(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     Single[] pixels)

参照

glReadPixels オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectd

Steema.TeeChart.Drawing.GL.Imports.glRectd メソッド

public static extern Void glRectd(Double x1,
     Double y1,
     Double x2,
     Double y2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectdv

Steema.TeeChart.Drawing.GL.Imports.glRectdv メソッド

public static extern Void glRectdv(Double[] v1,
     Double[] v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectf

Steema.TeeChart.Drawing.GL.Imports.glRectf メソッド

public static extern Void glRectf(Single x1,
     Single y1,
     Single x2,
     Single y2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectfv

Steema.TeeChart.Drawing.GL.Imports.glRectfv メソッド

public static extern Void glRectfv(Single[] v1,
     Single[] v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRecti

Steema.TeeChart.Drawing.GL.Imports.glRecti メソッド

public static extern Void glRecti(Int32 x1,
     Int32 y1,
     Int32 x2,
     Int32 y2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectiv

Steema.TeeChart.Drawing.GL.Imports.glRectiv メソッド

public static extern Void glRectiv(Int32[] v1,
     Int32[] v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRects

Steema.TeeChart.Drawing.GL.Imports.glRects メソッド

public static extern Void glRects(Int16 x1,
     Int16 y1,
     Int16 x2,
     Int16 y2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRectsv

Steema.TeeChart.Drawing.GL.Imports.glRectsv メソッド

public static extern Void glRectsv(Int16[] v1,
     Int16[] v2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRenderMode

Steema.TeeChart.Drawing.GL.Imports.glRenderMode メソッド

public static extern Int32 glRenderMode(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRotated

Steema.TeeChart.Drawing.GL.Imports.glRotated メソッド

public static extern Void glRotated(Double angle,
     Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glRotatef

Steema.TeeChart.Drawing.GL.Imports.glRotatef メソッド

public static extern Void glRotatef(Single angle,
     Single x,
     Single y,
     Single z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glScaled

Steema.TeeChart.Drawing.GL.Imports.glScaled メソッド

public static extern Void glScaled(Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glScalef

Steema.TeeChart.Drawing.GL.Imports.glScalef メソッド

public static extern Void glScalef(Single x,
     Single y,
     Single z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glScissor

Steema.TeeChart.Drawing.GL.Imports.glScissor メソッド

public static extern Void glScissor(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glSelectBuffer

Steema.TeeChart.Drawing.GL.Imports.glSelectBuffer メソッド

public static extern Void glSelectBuffer(Int32 size,
     UInt32[] buffer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glSelectBuffer

Steema.TeeChart.Drawing.GL.Imports.glSelectBuffer メソッド

public static extern Void glSelectBuffer(Int32 size,
     UInt32[] buffer)

参照

glSelectBuffer オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glSelectBuffer

Steema.TeeChart.Drawing.GL.Imports.glSelectBuffer メソッド

public static extern Void glSelectBuffer(Int32 size,
     UInt32* buffer)

参照

glSelectBuffer オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glShadeModel

Steema.TeeChart.Drawing.GL.Imports.glShadeModel メソッド

public static extern Void glShadeModel(UInt32 mode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glStencilFunc

Steema.TeeChart.Drawing.GL.Imports.glStencilFunc メソッド

public static extern Void glStencilFunc(UInt32 func,
     Int32 ref_notkeword,
     UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glStencilMask

Steema.TeeChart.Drawing.GL.Imports.glStencilMask メソッド

public static extern Void glStencilMask(UInt32 mask)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glStencilOp

Steema.TeeChart.Drawing.GL.Imports.glStencilOp メソッド

public static extern Void glStencilOp(UInt32 fail,
     UInt32 zfail,
     UInt32 zpass)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1d

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1d メソッド

public static extern Void glTexCoord1d(Double s)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1dv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1dv メソッド

public static extern Void glTexCoord1dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1f

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1f メソッド

public static extern Void glTexCoord1f(Single s)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1fv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1fv メソッド

public static extern Void glTexCoord1fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1i

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1i メソッド

public static extern Void glTexCoord1i(Int32 s)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1iv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1iv メソッド

public static extern Void glTexCoord1iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1s

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1s メソッド

public static extern Void glTexCoord1s(Int16 s)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord1sv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord1sv メソッド

public static extern Void glTexCoord1sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2d

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2d メソッド

public static extern Void glTexCoord2d(Double s,
     Double t)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2dv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2dv メソッド

public static extern Void glTexCoord2dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2f

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2f メソッド

public static extern Void glTexCoord2f(Single s,
     Single t)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2fv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2fv メソッド

public static extern Void glTexCoord2fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2i

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2i メソッド

public static extern Void glTexCoord2i(Int32 s,
     Int32 t)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2iv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2iv メソッド

public static extern Void glTexCoord2iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2s

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2s メソッド

public static extern Void glTexCoord2s(Int16 s,
     Int16 t)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord2sv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord2sv メソッド

public static extern Void glTexCoord2sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3d

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3d メソッド

public static extern Void glTexCoord3d(Double s,
     Double t,
     Double r)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3dv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3dv メソッド

public static extern Void glTexCoord3dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3f

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3f メソッド

public static extern Void glTexCoord3f(Single s,
     Single t,
     Single r)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3fv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3fv メソッド

public static extern Void glTexCoord3fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3i

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3i メソッド

public static extern Void glTexCoord3i(Int32 s,
     Int32 t,
     Int32 r)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3iv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3iv メソッド

public static extern Void glTexCoord3iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3s

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3s メソッド

public static extern Void glTexCoord3s(Int16 s,
     Int16 t,
     Int16 r)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord3sv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord3sv メソッド

public static extern Void glTexCoord3sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4d

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4d メソッド

public static extern Void glTexCoord4d(Double s,
     Double t,
     Double r,
     Double q)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4dv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4dv メソッド

public static extern Void glTexCoord4dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4f

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4f メソッド

public static extern Void glTexCoord4f(Single s,
     Single t,
     Single r,
     Single q)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4fv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4fv メソッド

public static extern Void glTexCoord4fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4i

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4i メソッド

public static extern Void glTexCoord4i(Int32 s,
     Int32 t,
     Int32 r,
     Int32 q)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4iv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4iv メソッド

public static extern Void glTexCoord4iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4s

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4s メソッド

public static extern Void glTexCoord4s(Int16 s,
     Int16 t,
     Int16 r,
     Int16 q)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoord4sv

Steema.TeeChart.Drawing.GL.Imports.glTexCoord4sv メソッド

public static extern Void glTexCoord4sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexCoordPointer

Steema.TeeChart.Drawing.GL.Imports.glTexCoordPointer メソッド

public static extern Void glTexCoordPointer(Int32 size,
     UInt32 type,
     Int32 stride,
     Single[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexEnvf

Steema.TeeChart.Drawing.GL.Imports.glTexEnvf メソッド

public static extern Void glTexEnvf(UInt32 target,
     UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexEnvfv

Steema.TeeChart.Drawing.GL.Imports.glTexEnvfv メソッド

public static extern Void glTexEnvfv(UInt32 target,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexEnvi

Steema.TeeChart.Drawing.GL.Imports.glTexEnvi メソッド

public static extern Void glTexEnvi(UInt32 target,
     UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexEnviv

Steema.TeeChart.Drawing.GL.Imports.glTexEnviv メソッド

public static extern Void glTexEnviv(UInt32 target,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGend

Steema.TeeChart.Drawing.GL.Imports.glTexGend メソッド

public static extern Void glTexGend(UInt32 coord,
     UInt32 pname,
     Double param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGendv

Steema.TeeChart.Drawing.GL.Imports.glTexGendv メソッド

public static extern Void glTexGendv(UInt32 coord,
     UInt32 pname,
     Double[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGenf

Steema.TeeChart.Drawing.GL.Imports.glTexGenf メソッド

public static extern Void glTexGenf(UInt32 coord,
     UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGenfv

Steema.TeeChart.Drawing.GL.Imports.glTexGenfv メソッド

public static extern Void glTexGenfv(UInt32 coord,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGeni

Steema.TeeChart.Drawing.GL.Imports.glTexGeni メソッド

public static extern Void glTexGeni(UInt32 coord,
     UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexGeniv

Steema.TeeChart.Drawing.GL.Imports.glTexGeniv メソッド

public static extern Void glTexGeniv(UInt32 coord,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexImage1D

Steema.TeeChart.Drawing.GL.Imports.glTexImage1D メソッド

public static extern Void glTexImage1D(UInt32 target,
     Int32 level,
     Int32 internalformat,
     Int32 width,
     Int32 border,
     UInt32 format,
     UInt32 type,
     Byte[] pixels)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexImage2D

Steema.TeeChart.Drawing.GL.Imports.glTexImage2D メソッド

オーバーロードの一覧

public static extern Void glTexImage2D(System.UInt32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.IntPtr)
public static extern Void glTexImage2D(System.UInt32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.Byte[])

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexImage2D

Steema.TeeChart.Drawing.GL.Imports.glTexImage2D メソッド

public static extern Void glTexImage2D(UInt32 target,
     Int32 level,
     Int32 components,
     Int32 width,
     Int32 height,
     Int32 border,
     UInt32 format,
     UInt32 type,
     IntPtr pixels)

参照

glTexImage2D オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexImage2D

Steema.TeeChart.Drawing.GL.Imports.glTexImage2D メソッド

public static extern Void glTexImage2D(UInt32 target,
     Int32 level,
     Int32 internalformat,
     Int32 width,
     Int32 height,
     Int32 border,
     UInt32 format,
     UInt32 type,
     Byte[] pixels)

参照

glTexImage2D オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexParameterf

Steema.TeeChart.Drawing.GL.Imports.glTexParameterf メソッド

public static extern Void glTexParameterf(UInt32 target,
     UInt32 pname,
     Single param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexParameterfv

Steema.TeeChart.Drawing.GL.Imports.glTexParameterfv メソッド

public static extern Void glTexParameterfv(UInt32 target,
     UInt32 pname,
     Single[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexParameteri

Steema.TeeChart.Drawing.GL.Imports.glTexParameteri メソッド

public static extern Void glTexParameteri(UInt32 target,
     UInt32 pname,
     Int32 param)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexParameteriv

Steema.TeeChart.Drawing.GL.Imports.glTexParameteriv メソッド

public static extern Void glTexParameteriv(UInt32 target,
     UInt32 pname,
     Int32[] params_notkeyword)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexSubImage1D

Steema.TeeChart.Drawing.GL.Imports.glTexSubImage1D メソッド

public static extern Void glTexSubImage1D(UInt32 target,
     Int32 level,
     Int32 xoffset,
     Int32 width,
     UInt32 format,
     UInt32 type,
     Int32[] pixels)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTexSubImage2D

Steema.TeeChart.Drawing.GL.Imports.glTexSubImage2D メソッド

public static extern Void glTexSubImage2D(UInt32 target,
     Int32 level,
     Int32 xoffset,
     Int32 yoffset,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     Int32[] pixels)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTranslated

Steema.TeeChart.Drawing.GL.Imports.glTranslated メソッド

public static extern Void glTranslated(Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glTranslatef

Steema.TeeChart.Drawing.GL.Imports.glTranslatef メソッド

public static extern Void glTranslatef(Single x,
     Single y,
     Single z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBeginCurve

Steema.TeeChart.Drawing.GL.Imports.gluBeginCurve メソッド

public static extern Void gluBeginCurve(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBeginSurface

Steema.TeeChart.Drawing.GL.Imports.gluBeginSurface メソッド

public static extern Void gluBeginSurface(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBeginTrim

Steema.TeeChart.Drawing.GL.Imports.gluBeginTrim メソッド

public static extern Void gluBeginTrim(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBuild1DMipmaps

Steema.TeeChart.Drawing.GL.Imports.gluBuild1DMipmaps メソッド

public static extern Void gluBuild1DMipmaps(Int32 target,
     Int32 components,
     Int32 width,
     Int32 format,
     Int32 type,
     Int32[] data)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBuild2DMipmaps

Steema.TeeChart.Drawing.GL.Imports.gluBuild2DMipmaps メソッド

オーバーロードの一覧

public static extern Int32 gluBuild2DMipmaps(System.UInt32, System.Int32, System.Int32, System.Int32, System.UInt32, System.UInt32, System.IntPtr)
public static extern Void gluBuild2DMipmaps(System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32, System.Int32[])

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBuild2DMipmaps

Steema.TeeChart.Drawing.GL.Imports.gluBuild2DMipmaps メソッド

public static extern Int32 gluBuild2DMipmaps(UInt32 target,
     Int32 component,
     Int32 width,
     Int32 height,
     UInt32 format,
     UInt32 type,
     IntPtr data)

参照

gluBuild2DMipmaps オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluBuild2DMipmaps

Steema.TeeChart.Drawing.GL.Imports.gluBuild2DMipmaps メソッド

public static extern Void gluBuild2DMipmaps(Int32 target,
     Int32 components,
     Int32 width,
     Int32 height,
     Int32 format,
     Int32 type,
     Int32[] data)

参照

gluBuild2DMipmaps オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluCylinder

Steema.TeeChart.Drawing.GL.Imports.gluCylinder メソッド

public static extern Void gluCylinder(IntPtr qobj,
     Double baseRadius,
     Double topRadius,
     Double height,
     Int32 slices,
     Int32 stacks)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluDeleteNurbsRenderer

Steema.TeeChart.Drawing.GL.Imports.gluDeleteNurbsRenderer メソッド

public static extern Void gluDeleteNurbsRenderer(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluDeleteQuadric

Steema.TeeChart.Drawing.GL.Imports.gluDeleteQuadric メソッド

public static extern Void gluDeleteQuadric(IntPtr state)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluDeleteTess

Steema.TeeChart.Drawing.GL.Imports.gluDeleteTess メソッド

public static extern Void gluDeleteTess(IntPtr tess)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluDisk

Steema.TeeChart.Drawing.GL.Imports.gluDisk メソッド

public static extern Void gluDisk(IntPtr qobj,
     Double innerRadius,
     Double outerRadius,
     Int32 slices,
     Int32 loops)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluEndCurve

Steema.TeeChart.Drawing.GL.Imports.gluEndCurve メソッド

public static extern Void gluEndCurve(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluEndSurface

Steema.TeeChart.Drawing.GL.Imports.gluEndSurface メソッド

public static extern Void gluEndSurface(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluEndTrim

Steema.TeeChart.Drawing.GL.Imports.gluEndTrim メソッド

public static extern Void gluEndTrim(IntPtr nobj)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluErrorString

Steema.TeeChart.Drawing.GL.Imports.gluErrorString メソッド

public static extern String gluErrorString(Int32 errCode)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluGetNurbsProperty

Steema.TeeChart.Drawing.GL.Imports.gluGetNurbsProperty メソッド

public static extern Void gluGetNurbsProperty(IntPtr nobj,
     Int32 property,
     Single value)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluGetString

Steema.TeeChart.Drawing.GL.Imports.gluGetString メソッド

public static extern String gluGetString(Int32 name)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluGetTessProperty

Steema.TeeChart.Drawing.GL.Imports.gluGetTessProperty メソッド

public static extern Void gluGetTessProperty(IntPtr tess,
     Int32 which,
     Double value)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluLoadSamplingMatrices

Steema.TeeChart.Drawing.GL.Imports.gluLoadSamplingMatrices メソッド

public static extern Void gluLoadSamplingMatrices(IntPtr nobj,
     Single[] modelMatrix,
     Single[] projMatrix,
     Int32[] viewport)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluLookAt

Steema.TeeChart.Drawing.GL.Imports.gluLookAt メソッド

public static extern Void gluLookAt(Double eyex,
     Double eyey,
     Double eyez,
     Double centerx,
     Double centery,
     Double centerz,
     Double upx,
     Double upy,
     Double upz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNewNurbsRenderer

Steema.TeeChart.Drawing.GL.Imports.gluNewNurbsRenderer メソッド

public static extern IntPtr gluNewNurbsRenderer()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNewQuadric

Steema.TeeChart.Drawing.GL.Imports.gluNewQuadric メソッド

public static extern IntPtr gluNewQuadric()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNewTess

Steema.TeeChart.Drawing.GL.Imports.gluNewTess メソッド

public static extern IntPtr gluNewTess()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNurbsCurve

Steema.TeeChart.Drawing.GL.Imports.gluNurbsCurve メソッド

public static extern Void gluNurbsCurve(IntPtr nobj,
     Int32 nknots,
     Single[] knot,
     Int32 stride,
     Single[] ctlarray,
     Int32 order,
     UInt32 type)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNurbsProperty

Steema.TeeChart.Drawing.GL.Imports.gluNurbsProperty メソッド

public static extern Void gluNurbsProperty(IntPtr nobj,
     Int32 property,
     Single value)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluNurbsSurface

Steema.TeeChart.Drawing.GL.Imports.gluNurbsSurface メソッド

public static extern Void gluNurbsSurface(IntPtr nobj,
     Int32 sknot_count,
     Single[] sknot,
     Int32 tknot_count,
     Single[] tknot,
     Int32 s_stride,
     Int32 t_stride,
     Single[] ctlarray,
     Int32 sorder,
     Int32 torder,
     UInt32 type)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluOrtho2D

Steema.TeeChart.Drawing.GL.Imports.gluOrtho2D メソッド

public static extern Void gluOrtho2D(Double left,
     Double right,
     Double bottom,
     Double top)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluPartialDisk

Steema.TeeChart.Drawing.GL.Imports.gluPartialDisk メソッド

public static extern Void gluPartialDisk(IntPtr qobj,
     Double innerRadius,
     Double outerRadius,
     Int32 slices,
     Int32 loops,
     Double startAngle,
     Double sweepAngle)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluPerspective

Steema.TeeChart.Drawing.GL.Imports.gluPerspective メソッド

public static extern Void gluPerspective(Double fovy,
     Double aspect,
     Double zNear,
     Double zFar)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluPickMatrix

Steema.TeeChart.Drawing.GL.Imports.gluPickMatrix メソッド

public static extern Void gluPickMatrix(Double x,
     Double y,
     Double width,
     Double height,
     Int32[] viewport)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluProject

Steema.TeeChart.Drawing.GL.Imports.gluProject メソッド

public static extern Void gluProject(Double objx,
     Double objy,
     Double objz,
     Double[] modelMatrix,
     Double[] projMatrix,
     Int32[] viewport,
     Double[] winx,
     Double[] winy,
     Double[] winz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluPwlCurve

Steema.TeeChart.Drawing.GL.Imports.gluPwlCurve メソッド

public static extern Void gluPwlCurve(IntPtr nobj,
     Int32 count,
     Single array,
     Int32 stride,
     UInt32 type)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluQuadricDrawStyle

Steema.TeeChart.Drawing.GL.Imports.gluQuadricDrawStyle メソッド

public static extern Void gluQuadricDrawStyle(IntPtr quadObject,
     UInt32 drawStyle)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluQuadricNormals

Steema.TeeChart.Drawing.GL.Imports.gluQuadricNormals メソッド

public static extern Void gluQuadricNormals(IntPtr quadObject,
     Int32 normals)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluQuadricOrientation

Steema.TeeChart.Drawing.GL.Imports.gluQuadricOrientation メソッド

public static extern Void gluQuadricOrientation(IntPtr quadObject,
     Int32 orientation)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluQuadricTexture

Steema.TeeChart.Drawing.GL.Imports.gluQuadricTexture メソッド

public static extern Void gluQuadricTexture(IntPtr quadObject,
     Int32 textureCoords)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluScaleImage

Steema.TeeChart.Drawing.GL.Imports.gluScaleImage メソッド

public static extern Void gluScaleImage(Int32 format,
     Int32 widthin,
     Int32 heightin,
     Int32 typein,
     Int32[] datain,
     Int32 widthout,
     Int32 heightout,
     Int32 typeout,
     Int32[] dataout)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluSphere

Steema.TeeChart.Drawing.GL.Imports.gluSphere メソッド

public static extern Void gluSphere(IntPtr qobj,
     Double radius,
     Int32 slices,
     Int32 stacks)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessBeginContour

Steema.TeeChart.Drawing.GL.Imports.gluTessBeginContour メソッド

public static extern Void gluTessBeginContour(IntPtr tess)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessBeginPolygon

Steema.TeeChart.Drawing.GL.Imports.gluTessBeginPolygon メソッド

public static extern Void gluTessBeginPolygon(IntPtr tess,
     IntPtr polygonData)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessEndContour

Steema.TeeChart.Drawing.GL.Imports.gluTessEndContour メソッド

public static extern Void gluTessEndContour(IntPtr tess)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessEndPolygon

Steema.TeeChart.Drawing.GL.Imports.gluTessEndPolygon メソッド

public static extern Void gluTessEndPolygon(IntPtr tess)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessNormal

Steema.TeeChart.Drawing.GL.Imports.gluTessNormal メソッド

public static extern Void gluTessNormal(IntPtr tess,
     Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessProperty

Steema.TeeChart.Drawing.GL.Imports.gluTessProperty メソッド

public static extern Void gluTessProperty(IntPtr tess,
     Int32 which,
     Double value)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluTessVertex

Steema.TeeChart.Drawing.GL.Imports.gluTessVertex メソッド

public static extern Void gluTessVertex(IntPtr tess,
     Double[] coords,
     Double[] data)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluUnProject

Steema.TeeChart.Drawing.GL.Imports.gluUnProject メソッド

public static extern Void gluUnProject(Double winx,
     Double winy,
     Double winz,
     Double[] modelMatrix,
     Double[] projMatrix,
     Int32[] viewport,
     Double[] objx,
     Double[] objy,
     Double[] objz)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluUnProject

Steema.TeeChart.Drawing.GL.Imports.gluUnProject メソッド

public static extern Int32 gluUnProject(Double winx,
     Double winy,
     Double winz,
     Double[][] modelMatrix,
     Double[][] projMatrix,
     Int32[] viewport,
     Double* objx,
     Double* objy,
     Double* objz)

参照

gluUnProject オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


gluUnProject

Steema.TeeChart.Drawing.GL.Imports.gluUnProject メソッド

public static extern Void gluUnProject(Double winx,
     Double winy,
     Double winz,
     Double[] modelMatrix,
     Double[] projMatrix,
     Int32[] viewport,
     Double[] objx,
     Double[] objy,
     Double[] objz)

参照

gluUnProject オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2d

Steema.TeeChart.Drawing.GL.Imports.glVertex2d メソッド

public static extern Void glVertex2d(Double x,
     Double y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2dv

Steema.TeeChart.Drawing.GL.Imports.glVertex2dv メソッド

public static extern Void glVertex2dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2f

Steema.TeeChart.Drawing.GL.Imports.glVertex2f メソッド

public static extern Void glVertex2f(Single x,
     Single y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2fv

Steema.TeeChart.Drawing.GL.Imports.glVertex2fv メソッド

public static extern Void glVertex2fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2i

Steema.TeeChart.Drawing.GL.Imports.glVertex2i メソッド

public static extern Void glVertex2i(Int32 x,
     Int32 y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2iv

Steema.TeeChart.Drawing.GL.Imports.glVertex2iv メソッド

public static extern Void glVertex2iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2s

Steema.TeeChart.Drawing.GL.Imports.glVertex2s メソッド

public static extern Void glVertex2s(Int16 x,
     Int16 y)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex2sv

Steema.TeeChart.Drawing.GL.Imports.glVertex2sv メソッド

public static extern Void glVertex2sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3d

Steema.TeeChart.Drawing.GL.Imports.glVertex3d メソッド

public static extern Void glVertex3d(Double x,
     Double y,
     Double z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3dv

Steema.TeeChart.Drawing.GL.Imports.glVertex3dv メソッド

public static extern Void glVertex3dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3dv

Steema.TeeChart.Drawing.GL.Imports.glVertex3dv メソッド

public static extern Void glVertex3dv(Double[] v)

参照

glVertex3dv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3dv

Steema.TeeChart.Drawing.GL.Imports.glVertex3dv メソッド

public static extern Void glVertex3dv(Double* v)

参照

glVertex3dv オーバーロードの一覧 | Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3f

Steema.TeeChart.Drawing.GL.Imports.glVertex3f メソッド

public static extern Void glVertex3f(Single x,
     Single y,
     Single z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3fv

Steema.TeeChart.Drawing.GL.Imports.glVertex3fv メソッド

public static extern Void glVertex3fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3i

Steema.TeeChart.Drawing.GL.Imports.glVertex3i メソッド

public static extern Void glVertex3i(Int32 x,
     Int32 y,
     Int32 z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3iv

Steema.TeeChart.Drawing.GL.Imports.glVertex3iv メソッド

public static extern Void glVertex3iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3s

Steema.TeeChart.Drawing.GL.Imports.glVertex3s メソッド

public static extern Void glVertex3s(Int16 x,
     Int16 y,
     Int16 z)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex3sv

Steema.TeeChart.Drawing.GL.Imports.glVertex3sv メソッド

public static extern Void glVertex3sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4d

Steema.TeeChart.Drawing.GL.Imports.glVertex4d メソッド

public static extern Void glVertex4d(Double x,
     Double y,
     Double z,
     Double w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4dv

Steema.TeeChart.Drawing.GL.Imports.glVertex4dv メソッド

public static extern Void glVertex4dv(Double[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4f

Steema.TeeChart.Drawing.GL.Imports.glVertex4f メソッド

public static extern Void glVertex4f(Single x,
     Single y,
     Single z,
     Single w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4fv

Steema.TeeChart.Drawing.GL.Imports.glVertex4fv メソッド

public static extern Void glVertex4fv(Single[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4i

Steema.TeeChart.Drawing.GL.Imports.glVertex4i メソッド

public static extern Void glVertex4i(Int32 x,
     Int32 y,
     Int32 z,
     Int32 w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4iv

Steema.TeeChart.Drawing.GL.Imports.glVertex4iv メソッド

public static extern Void glVertex4iv(Int32[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4s

Steema.TeeChart.Drawing.GL.Imports.glVertex4s メソッド

public static extern Void glVertex4s(Int16 x,
     Int16 y,
     Int16 z,
     Int16 w)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertex4sv

Steema.TeeChart.Drawing.GL.Imports.glVertex4sv メソッド

public static extern Void glVertex4sv(Int16[] v)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glVertexPointer

Steema.TeeChart.Drawing.GL.Imports.glVertexPointer メソッド

public static extern Void glVertexPointer(Int32 size,
     UInt32 type,
     Int32 stride,
     Single[] pointer)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


glViewport

Steema.TeeChart.Drawing.GL.Imports.glViewport メソッド

public static extern Void glViewport(Int32 x,
     Int32 y,
     Int32 width,
     Int32 height)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


IntPtrCallback

Steema.TeeChart.Drawing.GL.Imports.IntPtrCallback メソッド

public static extern Void IntPtrCallback(IntPtr nobj,
     Int32 which,
     IntPtr Callback)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


LoadLibrary

Steema.TeeChart.Drawing.GL.Imports.LoadLibrary メソッド

public static extern IntPtr LoadLibrary(String lpFileName)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


ReleaseDC

Steema.TeeChart.Drawing.GL.Imports.ReleaseDC メソッド

public static extern Int32 ReleaseDC(IntPtr hWnd,
     IntPtr hDC)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetPixelFormat

Steema.TeeChart.Drawing.GL.Imports.SetPixelFormat メソッド

public static extern Int32 SetPixelFormat(IntPtr hDC,
     Int32 iPixelFormat,
     PIXELFORMATDESCRIPTOR ppfd)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


SwapBuffers

Steema.TeeChart.Drawing.GL.Imports.SwapBuffers メソッド

public static extern Int32 SwapBuffers(IntPtr hDC)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglCreateContext

Steema.TeeChart.Drawing.GL.Imports.wglCreateContext メソッド

public static extern IntPtr wglCreateContext(IntPtr hdc)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglDeleteContext

Steema.TeeChart.Drawing.GL.Imports.wglDeleteContext メソッド

public static extern Int32 wglDeleteContext(IntPtr hrc)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglGetCurrentContext

Steema.TeeChart.Drawing.GL.Imports.wglGetCurrentContext メソッド

public static extern IntPtr wglGetCurrentContext()

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglMakeCurrent

Steema.TeeChart.Drawing.GL.Imports.wglMakeCurrent メソッド

public static extern Int32 wglMakeCurrent(IntPtr hdc,
     IntPtr hrc)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglShareLists

Steema.TeeChart.Drawing.GL.Imports.wglShareLists メソッド

public static extern Int32 wglShareLists(IntPtr p1,
     IntPtr p2)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


wglUseFontOutlines

Steema.TeeChart.Drawing.GL.Imports.wglUseFontOutlines メソッド

public static extern Int32 wglUseFontOutlines(IntPtr p1,
     Int32 p2,
     Int32 p3,
     Int32 p4,
     Single p5,
     Single p6,
     Int32 p7,
     IntPtr p8)

参照

Imports クラス | Imports メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO

Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO クラス

この型のすべてのメンバの一覧については、BITMAPINFO メンバを参照してください。

System.Object
public class BITMAPINFO : Object

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO 全メンバ

BITMAPINFO 概要

コンストラクタ

Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO

パブリック フィールド

biBitCount
biClrImportant
biClrUsed
biCompression
biHeight
biPlanes
biSize
biSizeImage
biWidth
biXPelsPerMeter
biYPelsPerMeter
colors

参照

BITMAPINFO クラス | Steema.TeeChart.Drawing.GL 名前空間


BITMAPINFO コンストラクタ

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO コンストラクタ

public Imports+BITMAPINFO()

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.BITMAPINFO フィールド

パブリック フィールド

biBitCount
biClrImportant
biClrUsed
biCompression
biHeight
biPlanes
biSize
biSizeImage
biWidth
biXPelsPerMeter
biYPelsPerMeter
colors

参照

BITMAPINFO クラス | Steema.TeeChart.Drawing.GL 名前空間


biBitCount

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biBitCount フィールド

public Int16 biBitCount

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biClrImportant

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biClrImportant フィールド

public Int32 biClrImportant

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biClrUsed

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biClrUsed フィールド

public Int32 biClrUsed

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biCompression

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biCompression フィールド

public Int32 biCompression

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biHeight

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biHeight フィールド

public Int32 biHeight

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biPlanes

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biPlanes フィールド

public Int16 biPlanes

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biSize

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biSize フィールド

public Int32 biSize

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biSizeImage

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biSizeImage フィールド

public Int32 biSizeImage

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biWidth

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biWidth フィールド

public Int32 biWidth

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biXPelsPerMeter

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biXPelsPerMeter フィールド

public Int32 biXPelsPerMeter

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


biYPelsPerMeter

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.biYPelsPerMeter フィールド

public Int32 biYPelsPerMeter

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


colors

Steema.TeeChart.Drawing.GL.Imports+BITMAPINFO.colors フィールド

public Int32 colors

参照

BITMAPINFO クラス | BITMAPINFO メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR

Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR クラス

この型のすべてのメンバの一覧については、PIXELFORMATDESCRIPTOR メンバを参照してください。

System.Object
public class PIXELFORMATDESCRIPTOR : Object

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR 全メンバ

PIXELFORMATDESCRIPTOR 概要

パブリック フィールド

bReserved
cAccumAlphaBits
cAccumBits
cAccumBlueBits
cAccumGreenBits
cAccumRedBits
cAlphaBits
cAlphaShift
cAuxBuffers
cBlueBits
cBlueShift
cColorBits
cDepthBits
cGreenBits
cGreenShift
cRedBits
cRedShift
cStencilBits
dwDamageMask
dwFlags
dwLayerMask
dwVisibleMask
iLayerType
iPixelType
nSize
nVersion

コンストラクタ

Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR

参照

PIXELFORMATDESCRIPTOR クラス | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.PIXELFORMATDESCRIPTOR フィールド

パブリック フィールド

bReserved
cAccumAlphaBits
cAccumBits
cAccumBlueBits
cAccumGreenBits
cAccumRedBits
cAlphaBits
cAlphaShift
cAuxBuffers
cBlueBits
cBlueShift
cColorBits
cDepthBits
cGreenBits
cGreenShift
cRedBits
cRedShift
cStencilBits
dwDamageMask
dwFlags
dwLayerMask
dwVisibleMask
iLayerType
iPixelType
nSize
nVersion

参照

PIXELFORMATDESCRIPTOR クラス | Steema.TeeChart.Drawing.GL 名前空間


bReserved

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.bReserved フィールド

public Byte bReserved

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAccumAlphaBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAccumAlphaBits フィールド

public Byte cAccumAlphaBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAccumBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAccumBits フィールド

public Byte cAccumBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAccumBlueBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAccumBlueBits フィールド

public Byte cAccumBlueBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAccumGreenBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAccumGreenBits フィールド

public Byte cAccumGreenBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAccumRedBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAccumRedBits フィールド

public Byte cAccumRedBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAlphaBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAlphaBits フィールド

public Byte cAlphaBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAlphaShift

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAlphaShift フィールド

public Byte cAlphaShift

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cAuxBuffers

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cAuxBuffers フィールド

public Byte cAuxBuffers

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cBlueBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cBlueBits フィールド

public Byte cBlueBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cBlueShift

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cBlueShift フィールド

public Byte cBlueShift

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cColorBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cColorBits フィールド

public Byte cColorBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cDepthBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cDepthBits フィールド

public Byte cDepthBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cGreenBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cGreenBits フィールド

public Byte cGreenBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cGreenShift

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cGreenShift フィールド

public Byte cGreenShift

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cRedBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cRedBits フィールド

public Byte cRedBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cRedShift

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cRedShift フィールド

public Byte cRedShift

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


cStencilBits

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.cStencilBits フィールド

public Byte cStencilBits

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


dwDamageMask

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.dwDamageMask フィールド

public UInt32 dwDamageMask

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


dwFlags

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.dwFlags フィールド

public UInt32 dwFlags

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


dwLayerMask

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.dwLayerMask フィールド

public UInt32 dwLayerMask

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


dwVisibleMask

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.dwVisibleMask フィールド

public UInt32 dwVisibleMask

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


iLayerType

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.iLayerType フィールド

public SByte iLayerType

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


iPixelType

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.iPixelType フィールド

public Byte iPixelType

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


nSize

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.nSize フィールド

public UInt16 nSize

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


nVersion

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR.nVersion フィールド

public UInt16 nVersion

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


PIXELFORMATDESCRIPTOR コンストラクタ

Steema.TeeChart.Drawing.GL.Imports+PIXELFORMATDESCRIPTOR コンストラクタ

public Imports+PIXELFORMATDESCRIPTOR()

参照

PIXELFORMATDESCRIPTOR クラス | PIXELFORMATDESCRIPTOR メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.SIZE

Steema.TeeChart.Drawing.GL.Imports.SIZE 構造体

GetTextExtentPoint32の構造体をサポートします。

この型のすべてのメンバの一覧については、SIZE メンバを参照してください。

System.Object
System.ValueType
public sealed struct SIZE : ValueType

参照

SIZE メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.SIZE 全メンバ

SIZE 概要

パブリック フィールド

cx
cy

参照

SIZE 構造体 | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.Imports.SIZE フィールド

パブリック フィールド

cx
cy

参照

SIZE 構造体 | Steema.TeeChart.Drawing.GL 名前空間


cx

Steema.TeeChart.Drawing.GL.Imports+SIZE.cx フィールド

public Int32 cx

参照

SIZE 構造体 | SIZE メンバ | Steema.TeeChart.Drawing.GL 名前空間


cy

Steema.TeeChart.Drawing.GL.Imports+SIZE.cy フィールド

public Int32 cy

参照

SIZE 構造体 | SIZE メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.OpenGL

Steema.TeeChart.Drawing.GL.OpenGL クラス

OpenGLクラスは、3DのOpenGLライブラリを提供します。

この型のすべてのメンバの一覧については、OpenGL メンバを参照してください。

System.Object
Steema.TeeChart.Drawing.GL.Imports
public class OpenGL : Imports

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.OpenGL 全メンバ

OpenGL 概要

コンストラクタ

Constructor

パブリック メソッド

Create | チャートのGL命令を作成するための描画キャンバスを生成します。
CreateDIB | 描画用のDIB形式（Device Independant Bitmap）を作成します。
Destroy |

パブリック プロパティ

HBitmap | イメージハンドルを取得します。
HDC |
Height | イメージの高さを取得します。
OpenGLBitmap |
Width | イメージの幅を取得します。

プロテクト フィールド

ACCUM (Importsの継承元)
FOG_SPECULAR_TEXTURE_WIN (Importsの継承元)
LOAD (Importsの継承元)
MULT (Importsの継承元)
RETURN (Importsの継承元)

プロテクト メソッド

Finalize |
SetPixelFormat | 基本的なビットマップのピクセル形式を設定します。

参照

OpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


OpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.OpenGL コンストラクタ

public OpenGL()

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.OpenGL フィールド

プロテクト フィールド

ACCUM (Importsの継承元)
FOG_SPECULAR_TEXTURE_WIN (Importsの継承元)
LOAD (Importsの継承元)
MULT (Importsの継承元)
RETURN (Importsの継承元)

参照

OpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.OpenGL メソッド

パブリック メソッド

Create | チャートのGL命令を作成するための描画キャンバスを生成します。
CreateDIB | 描画用のDIB形式（Device Independant Bitmap）を作成します。
Destroy |

プロテクト メソッド

Finalize |
SetPixelFormat | 基本的なビットマップのピクセル形式を設定します。

参照

OpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Create

Steema.TeeChart.Drawing.GL.OpenGL.Create メソッド

チャートのGL命令を描画するための描画キャンバスを生成します。

public abstract Boolean Create(Int32 width,
     Int32 height)

パラメーター

width
チャートの幅
height
チャートの高さ

解説

チャートのGL命令を描画するための描画キャンバスを生成します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


CreateDIB

Steema.TeeChart.Drawing.GL.OpenGL.CreateDIB メソッド

レンダリング用のDIB形式（Device Independant Bitmap）を作成します。

public abstract Boolean CreateDIB(Int32 width,
     Int32 height,
     UInt32 bitCount)

パラメーター

width
ビットマップの幅
height
ビットマップの高さ
bitCount
カラービット

戻り値

解説

レンダリング用のDIB形式（ Device Independant Bitmap）を作成します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Destroy

Steema.TeeChart.Drawing.GL.OpenGL.Destroy メソッド

public abstract Void Destroy()

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Finalize

Steema.TeeChart.Drawing.GL.OpenGL.Finalize メソッド

protected abstract Void Finalize()

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetPixelFormat

Steema.TeeChart.Drawing.GL.OpenGL.SetPixelFormat メソッド

基本的なビットマップのピクセル形式を設定します。

protected internal Boolean SetPixelFormat(UInt32 bitCount)

パラメーター

bitCount
ビット数

解説

基本的なビットマップのピクセル形式を設定します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.OpenGL プロパティ

パブリック プロパティ

HBitmap | イメージハンドルを取得します。
HDC |
Height | イメージの高さを取得します。
OpenGLBitmap |
Width | イメージの幅を取得します。

参照

OpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


HBitmap

Steema.TeeChart.Drawing.GL.OpenGL.HBitmap プロパティ

イメージハンドルを取得します。

public IntPtr HBitmap {get;}

解説

イメージハンドルを取得します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


HDC

Steema.TeeChart.Drawing.GL.OpenGL.HDC プロパティ

public IntPtr HDC {get;}

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Height

Steema.TeeChart.Drawing.GL.OpenGL.Height プロパティ

イメージの高さを取得します。

public Int32 Height {get;}

解説

イメージの高さを取得します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


OpenGLBitmap

Steema.TeeChart.Drawing.GL.OpenGL.OpenGLBitmap プロパティ

public Bitmap OpenGLBitmap {get;}

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Width

Steema.TeeChart.Drawing.GL.OpenGL.Width プロパティ

イメージの幅を取得します。

public Int32 Width {get;}

解説

イメージの幅を取得します。

参照

OpenGL クラス | OpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeOpenGL

Steema.TeeChart.Drawing.GL.TeeOpenGL クラス

OpenGL環境クラス。TeeOpenGLコンポーネントは、チャートをOpenGL描画に設定します。TeeOpenGLは、OpenGLキャンバスやライトソースへのアクセスを提供します。

この型のすべてのメンバの一覧については、TeeOpenGL メンバを参照してください。

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
public class TeeOpenGL : Component , IComponent, IDisposable, IOpenGL

例

private void Form1_Load(object sender, System.EventArgs e)
{
   teeOpenGL1.Active = true;
   teeOpenGL1.AmbientLight = 8;
   teeOpenGL1.Chart = tChart1;
}

private void numericUpDown2_ValueChanged(object sender, System.EventArgs e)
{
  teeOpenGL1.Light0.Position.X=(int)numericUpDown2.Value;
  teeOpenGL1.Light1.Position.X=teeOpenGL1.Light0.Position.X*-10;
}

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeOpenGL 全メンバ

TeeOpenGL 概要

コンストラクタ

Constructor オーバーロードされたOpenGL環境設定のコンストラクタ。

パブリック メソッド

SetChart TeeOpenGLコンポーネントに関連付けるチャートを設定します。

パブリック プロパティ

Active | trueに設定するとチャートのOpenGLが有効になります。
AmbientLight | デフォルトは8です。アンビエント光の割合（0～100%までの値）を取得/設定します。アンビエント光とはあらゆる方向から照らす環境光です。
Chart | TOpenGLコンポーネントを接続するTChartを設定します。
DrawStyle | 例えば、POINT、LINE、またはFILLで描画するためにOpenGLのPolygonModeを設定します。
FontExtrusion | フォントの字体に適用するZ深さを取得/設定します。
FontOutlines | trueの場合、フォントの輪郭だけ描画します（塗りつぶしなし）。
Light0 | 最初のライトソースを取得します。
Light1 | 二番目のライトソースを取得します。
Light2 | 三番目のライトソースを取得します。
ShadeQuality | OpenGLのShadingModelを取得または設定します。
Shininess | 輝度を0から1までの値で設定します。0は輝度が強く、1は輝度が弱くなります。
WebChart | TOpenGLコンポーネントと接続するWebChartを設定します。

プロテクト メソッド

Dispose

参照

TeeOpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


TeeOpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.TeeOpenGL コンストラクタ

オーバーロードの一覧

OpenGL環境の設定を行うコンストラクタ。

public TeeOpenGL()

コンストラクタ。

public TeeOpenGL(Steema.TeeChart.TChart)

コンストラクタ。

public TeeOpenGL(Steema.TeeChart.Chart)
public TeeOpenGL(Steema.TeeChart.Web.WebChart)

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TeeOpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.TeeOpenGL コンストラクタ

OpenGL環境の設定を行うコンストラクタ。

public TeeOpenGL()

参照

TeeOpenGL コンストラクタ オーバーロードの一覧 | TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TeeOpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.TeeOpenGL コンストラクタ

コンストラクタ。

public TeeOpenGL(TChart tc)

パラメーター

tc
TChart

参照

TeeOpenGL コンストラクタ オーバーロードの一覧 | TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TeeOpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.TeeOpenGL コンストラクタ

コンストラクタ。

public TeeOpenGL(Chart c)

パラメーター

c
Chart

参照

TeeOpenGL コンストラクタ オーバーロードの一覧 | TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


TeeOpenGL コンストラクタ

Steema.TeeChart.Drawing.GL.TeeOpenGL コンストラクタ

public TeeOpenGL(WebChart wc)

参照

TeeOpenGL コンストラクタのオーバーロードの一覧 | TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeOpenGL イベント

パブリック イベント

Init

参照

TeeOpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Init

Steema.TeeChart.Drawing.GL.TeeOpenGL.Init イベント

public EventHandler  Init

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeOpenGL メソッド

パブリック メソッド

SetChart TeeOpenGLコンポーネントに関連付けるチャートを設定してます。

プロテクト メソッド

Dispose

参照

TeeOpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Dispose

Steema.TeeChart.Drawing.GL.TeeOpenGL.Dispose メソッド

protected override Void Dispose(Boolean disposing)

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


OnInit

Steema.TeeChart.Drawing.GL.TeeOpenGL.OnInit メソッド

protected abstract Void OnInit()

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


SetChart

Steema.TeeChart.Drawing.GL.TeeOpenGL.SetChart メソッド

TeeOpenGLコンポーネントに関連付けるチャートを設定します。

public virtual Void SetChart(Chart c)

パラメーター

c

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeOpenGL プロパティ

パブリック プロパティ

Active | trueに設定するとチャートのOpenGLが有効になります。
AmbientLight | デフォルトは8です。アンビエント光の割合（0～100%までの値）を取得/設定します。アンビエント光とはあらゆる方向から照らす環境光です。
Chart | TOpenGLコンポーネントに接続するTChartを設定します。
DrawStyle | 例えば、POINT、LINE、またはFILLで描画するためにOpenGLのPolygonModeを設定します。
FontExtrusion | フォントの字体に適用するZ深さを取得/設定します。
FontOutlines | trueの場合、フォントの輪郭だけ描画します（塗りつぶしなし）。
Light0 | 最初のライトソースを取得します。
Light1 | 二番目のライトソースを取得します。
Light2 | 三番目のライトソースを取得します。
ShadeQuality | OpenGLのShadingModelを取得または設定します。
Shininess | 輝度を0から1までの値で設定します。0は輝度が強く、1は輝度が弱くなります。
WebChart | TOpenGLコンポーネントと接続するWebChartを設定します。

参照

TeeOpenGL クラス | Steema.TeeChart.Drawing.GL 名前空間


Active

Steema.TeeChart.Drawing.GL.TeeOpenGL.Active プロパティ

trueに設定するとチャートのOpenGLが有効になります。

public virtual Boolean Active {get; set;}

解説

trueに設定するとチャートのOpenGLが有効になります。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


AmbientLight

Steema.TeeChart.Drawing.GL.TeeOpenGL.AmbientLight プロパティ

デフォルトは8です。アンビエント光の割合（0～100%までの値）を取得/設定します。アンビエント光とはあらゆる方向から照らす環境光です。

public virtual Int32 AmbientLight {get; set;}

解説

デフォルト値：8

アンビエント光の割合（0～100%までの値）を取得/設定します。アンビエント光とはあらゆる方向から照らす環境光です。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Chart

Steema.TeeChart.Drawing.GL.TeeOpenGL.Chart プロパティ

TOpenGLコンポーネントを接続するTChartを設定します。

public TChart Chart {get; set;}

解説

TOpenGLコンポーネントを接続するTChartを設定します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間 | TChart


DrawStyle

Steema.TeeChart.Drawing.GL.TeeOpenGL.DrawStyle プロパティ

例えば、ポイント、線、または塗りつぶしで描画するためにOpenGLのPolygonModeを設定します。

public virtual SurfaceStyle DrawStyle {get; set;}

解説

例えば、ポイント、線、または塗りつぶしで描画するためにOpenGLのPolygonModeを設定します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FontExtrusion

Steema.TeeChart.Drawing.GL.TeeOpenGL.FontExtrusion プロパティ

フォントの字体に適用するZ深さを取得/設定します。

public virtual Int32 FontExtrusion {get; set;}

解説

フォントの字体に適用するZ深さを取得/設定します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


FontOutlines

Steema.TeeChart.Drawing.GL.TeeOpenGL.FontOutlines プロパティ

trueの場合、フォントの輪郭だけ描画します（塗りつぶしなし）。

public virtual Boolean FontOutlines {get; set;}

解説

trueの場合、フォントの輪郭だけ描画します（塗りつぶしなし）。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Light0

Steema.TeeChart.Drawing.GL.TeeOpenGL.Light0 プロパティ

最初のライトソースを取得します。

public virtual IGLLightsource Light0 {get;}

解説

最初のライトソースを取得します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Light1

Steema.TeeChart.Drawing.GL.TeeOpenGL.Light1 プロパティ

2番目のライトソースを取得します。

public virtual IGLLightsource Light1 {get;}

解説

2番目のライトソースを取得します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Light2

Steema.TeeChart.Drawing.GL.TeeOpenGL.Light2 プロパティ

3番目のライトソースを取得します。

public virtual IGLLightsource Light2 {get;}

解説

3番目のライトソースを取得します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


ShadeQuality

Steema.TeeChart.Drawing.GL.TeeOpenGL.ShadeQuality プロパティ

OpenGLのShadingModelを取得/設定します。

public virtual Boolean ShadeQuality {get; set;}

解説

OpenGLのShadingModelを取得/設定します。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


Shininess

Steema.TeeChart.Drawing.GL.TeeOpenGL.Shininess プロパティ

輝度を0から1までの値で設定します。0は輝度が高く、1は輝度が低くなります。

public virtual Double Shininess {get; set;}

解説

輝度を0から1までの値で設定します。0は輝度が高く、1は輝度が低くなります。

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間


WebChart

Steema.TeeChart.Drawing.GL.TeeOpenGL.WebChart プロパティ

TOpenGLコンポーネントと接続するWebChartを設定します。
public WebChart WebChart {get; set;}

参照

TeeOpenGL クラス | TeeOpenGL メンバ | Steema.TeeChart.Drawing.GL 名前空間 | WebChart


Steema.TeeChart.Drawing.GL.TeeTexture

Steema.TeeChart.Drawing.GL.TeeTexture クラス

テクスチャの描画を行います。

この型のすべてのメンバの一覧については、TeeTexture メンバを参照してください。

System.Object
public class TeeTexture : Object

必要条件

名前空間: Steema.TeeChart.Drawing.GL 名前空間

アセンブリ: TeeChart.OpenGL.dll

参照

TeeTexture メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeTexture 全メンバ

TeeTexture 概要

コンストラクタ

Constructor

パブリック フィールド

Bitmap | ビットマップテクスチャ
Bits | ピクセルデータ
GLTexture | テクスチャ名

参照

TeeTexture クラス | Steema.TeeChart.Drawing.GL 名前空間


TeeTexture コンストラクタ

Steema.TeeChart.Drawing.GL.TeeTexture コンストラクタ

public TeeTexture()

参照

TeeTexture クラス | TeeTexture メンバ | Steema.TeeChart.Drawing.GL 名前空間


Steema.TeeChart.Drawing.GL.TeeTexture フィールド

パブリック フィールド

Bitmap | ビットマップテクスチャ
Bits | ピクセルデータ
GLTexture | テクスチャ名

参照

TeeTexture クラス | Steema.TeeChart.Drawing.GL 名前空間


Bitmap

Steema.TeeChart.Drawing.GL.TeeTexture.Bitmap フィールド

ビットマップテクスチャ。

public Bitmap Bitmap

参照

TeeTexture クラス | TeeTexture メンバ | Steema.TeeChart.Drawing.GL 名前空間


Bits

Steema.TeeChart.Drawing.GL.TeeTexture.Bits フィールド

ピクセルデータ。

public Byte[] Bits

参照

TeeTexture クラス | TeeTexture メンバ | Steema.TeeChart.Drawing.GL 名前空間


GLTexture

Steema.TeeChart.Drawing.GL.TeeTexture.GLTexture フィールド

テクスチャ名。

public UInt32[] GLTexture

参照

TeeTexture クラス | TeeTexture メンバ | Steema.TeeChart.Drawing.GL 名前空間