ResizeKit2.NET

ResizeKit2.NET

ResizeKit2.NET Reference

Form Resizing Component

Newtone Corporation
1-6-43 Kotobuki
Nagaoka City, Niigata Prefecture, 940-0015
JAPAN
Fax: +81-258-24-7905
http://www.imagekit.com
rssupport@imagekit.com


Overview

The ResizeKit Control

Automatically adjusts the size of the controls and fonts displayed on the form in proportion to changes in the form size or screen resolution. The size of the form when it is initially displayed and the amount that the form can be enlarged or reduced can be set.

Simply paste the control on the form. Redesign or adding code is not necessary.

To use the ResizeKit, simply place the control on the form and recompile the program. Established programs can easily become size (and screen resolution) independent.

Simple sample programs included


Installation

ResizeKit2.NET

Installing the ResizeKit2.NET

To install the ResizeKit2.NET, download and execute the appropriate installer for your programming environment. The ResizeKit2.NET installation includes an assembly for .NET Framework 2.0 to 3.5 and another assembly for .NET Framework 4.0 and above. Please be sure to use the appropriate assembly for your development environments.

The trial version of the ResizeKit2.NET is fully functional and will work for approximately 30 days from the time of installation. The retail version license must be activated on the PC where the ResizeKit2.NET is installed. See below for more details about activation.

IMPORTANT: After installing the retail version, you will be prompted to activate the license. You have 2 weeks to activate the retail license after which the ResizeKit2.NET will stop working until the license is activated.

How to activate your ResizeKit2.NET License:
License activation is the final step in correctly installing your product. The License Activation tool will automatically start when the product is installed. You can activate the license during installation or choose to activate it later. If you choose to activate later, you can do so at any time by running the License Activation tool (LicenseActivation.exe) found in the "Tool" folder under the directory where the product is installed. If the license is not activated within 2 weeks of installation, the product will stop working until the license is activated. You can activate a license online or offline.

Online Activation:

To activate a license online, use the License Activation tool (LicenseActivation.exe) and select the "Online" radio button. The License Activation tool uses the Product ID and Serial Number that you received when you purchased the product. Enter the Product ID and Serial Number in the License Activation tool and click "Add License". Your license will be activated online in a matter of few minutes.

During online activation, the Product ID and Serial Number as well as a unique Confirmation ID that is generated by the License Activation tool are transmitted to our license activation server. No other information except for the Product ID, Serial Number, and Confirmation ID are transmitted. Once this information is confirmed by our server, the product will be automatically activated. The status of your activation will appear in the License Activation tool.

Before uninstalling the ResizeKit2.NET, you must remove the license from the machine where it was activated. If the license is not removed it will remain even after the product has been uninstalled. Until that license is removed, that product cannot be activated on another machine. To remove the license, run the License Activation tool and click the "Remove License" button.

Offline Activation:

License activation can also be performed offline via email. To activate a license offline, run the License Activation tool and select the "Offline" radio button. Send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at rssupport@imagekit.com. Once we receive the Product ID, Serial Number, and the Confirmation ID, we will send you a License Key which you will enter in the License Activation tool.

To remove a license offline, run the License Activation tool and select the "Offline" radio button. Enter the Product ID and Serial Number in the License Activation tool and click the "Remove License" button. Then send the Product ID, Serial Number, and the Confirmation ID shown in the License Activation tool to Newtone Corporation at rssupport@imagekit.com. Please allow 3 to 5 working days for the license to be removed.

Questions:

Please contact Newtone Corporation at rssupport@imagekit.com if you have any questions about activation or if you have any problems activating your product.


Deployment

ResizeKit2.NET

Deploying applications containing the ResizeKit2.NET

When distributing applications that use the ResizeKit2. NET, the "Newtone.ResizeKit.Win.ResizeKitNET.dll" file must be deployed with the your application.


Newtone.ResizeKit2NET Support

ResizeKit2.NET

User Registration and Technical Support

User Registration:

Please be sure to register your ResizeKit2.NET. User registration allows you to develop and distribute applications containing the ResizeKit2.NET. Registered users may also receive support from our technical staff and also receive discounts on upgrades for the ResizeKit2.NET or when purchasing our other products.

To register, please send the following information to register@imagekit.com:

The name of the developer using the ResizeKit2.NET
Your contact information including address and email address
The ResizeKit2.NET serial number

Technical Support:

Technical support is free to registered users and is available by email or fax only.

We periodically release updates and maintanence releases for the ResizeKit2.NET. Registered users can download these updates from the ResizeKit suppoert section of our web site at:

http://www.imagekit.com

Registered users are provided with a username and password. If you are not yet registered, please send us your name, address, email address and product serial number at the email address given above

To contact us:

Newtone Corporation, Kotobuki 1-6-43
Nagaoka City, Niigata Prefecture 940-0015, JAPAN
Attention: ResizeKit User Support
Fax: +81-258-24-7905
Email: rssupport@imagekit.com


ResizeKit class

Newtone.ResizeKit.Win

Newtone.ResizeKit.Win.ResizeKit Class

The main class for the WinForm ResizeKit control.

For a list of members of the ResizeKit class, please refer to ResizeKit Members

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
Newtone.ResizeKit.Win
public class ResizeKit : System.Windows.Forms.Control

Explanation

The ResizeKit control resizes all controls placed on a Windows Form. When the form's size changes the ResizeKit control will change the size of the contols on that form by the same proportion.

Necessary Conditions

Namespace : Newtone.ResizeKit.Win

Assembly : Newtone.ResizeKit.Win.ResizeKitNET.dll

Reference

ResizeKit Members


ResizeKit Members

Newtone.ResizeKit.Win.ResizeKit Members

ResizeKit Overview

Constructor

ResizeKit Constructor Initializes a new instance of the ResizeKit class.

Public Properties

NoResizeControls | Gets or sets the controsl that will be exclueded from resizing.
NoResizeFontControls | Gets or sets the controls whose fonts will be excluded from resizing.
ResizeEnabled | Enables the ResizeKit functionality.
ResizeFontEnabled | Sets whether or not the fonts of the controls on the form will be resized

Public Events

ResizeEnd This event fires after the form has been resized

Reference

Newtone.ResizeKit.Win.ResizeKit


ResizeKit Constructor

Newtone.ResizeKit.Win.ResizeKit Constructor

Initializes a new instance of the ResizeKit class.

[Visual Basic]Public Sub New()
[C#]public ResizeKit()

Explanation

Placing the ResizeKit control on a Windows Form will create an instance of the ResizeKit. It is also possible to create an instance of the ResizeKit using code (without placing the control on the form). Instances can be created in this way when using MDI child forms etc.

Example

Place the following code within the Form Load event

                [Visual Basic.NET]
                Dim rk = New Newtone.ResizeKit.Win.ResizeKit()
                Me.Controls.Add(rk)

                [Visual C#.NET]
                Newtone.ResizeKit.Win.ResizeKit rk = new Newtone.ResizeKit.Win.ResizeKit();
                this.Controls.Add(rk);

Reference

ResizeKit Members | Newtone.ResizeKit


NoResizeControls property

Newtone.ResizeKit.Win.ResizeKit.NoResizeControls Property

This property sets the controls that will be excluded from resizing.

[Visual Basic]Public Property NoResizeControls As String()
[C#]public string[] NoResizeControls {get; set;}

Property Value

Array of string type values representing control names

Default value is Nothing/null

Explanation

The NoResizeControls property refers to a control that does not resize even though the form is resized.

Control names which do not resize are set as an array of character strings. If the ResizeEnabled property is False, all controls will not be resized regardless of the value in this property.

Reference


NoResizeFontControls Property

Newtone.ResizeKit.Win.ResizeKit.NoResizeFontControls Property

This property sets the names of the controls on the form whose fonts will be excluded from resizing.

[Visual Basic]Public Property NoResizeFontControls As String()
[C#]public string[] NoResizeFontControls {get; set;}

Property Value

An array of string type values representing the control names

Defaullt value is Nothing/null

Explanation

The NoResizeFontControls property sets the controls whose fonts will be excluded from resizing.

Even if the ResizeFontEnabled property is set to True, the fonts for controls specified in the NoResizeFontControls property will not be resized.

Reference


ResizeEnabled property

Newtone.ResizeKit.Win.ResizeKit.ResizeEnabled Property

Gets or sets whether to enable the resize function.

[Visual Basic]Public Property ResizeEnabled As Boolean
[C#]public bool ResizeEnabled {get; set;}

Property Value

True ：Enable resize function

False：Disable resize function

Default value is True.

Explanation

If this property is set to False, each control on the form will not be resized even if the form size is changed.

If this property is False all controls will not be resized regardless of value in NoResizeControls property.

Reference


ResizeFontEnabled property

Newtone.ResizeKit.Win.ResizeKit.ResizeFontEnabled Property

This property sets whether or not the fonts of the controls will be resized.

[Visual Basic]Public Property ResizeFontEnabled As Boolean
[C#]public bool ResizeFontEnabled {get; set;}

Property Value

True：Allows fonts to be resized.

False：Disables font resizing.

Default value is True.

Explanation

If this property is set to False, the font on the controls will not be resized even if each control is resized.

If this property is False, the fonts of all controls are not resized regardless of the value of the NoResizeFontControls property.

Reference


ResizeEnd event

Newtone.ResizeKit.Win.ResizeKit.ResizeEnd Event

This event fires after the form has been resized.

[Visual Basic]Public Event ResizeEnd As ResizeEventHandler
[C#]public event ResizeEventHandler ResizeEnd;

Event Data

The event handler receives an argument of type ResizeEventArgs .

Explanation

Code placed within this event will execute after the form resize completes.

Reference


ResizeEventArgs class

Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs Class

Provides data of ResizeEnd event.

[Visual Basic]Public Class ResizeEventArgs Inherits System.EventArgs
[C#]public class ResizeEventArgs：System.EventArgs

Explanation

Properties | Type | Explanation
ScaleX | System.Double | The magnification of the width of the resized form relative to the width of the form at initial display (Width of form after resizing / width of form at initial display)
ScaleY | System.Double | The magnification of the height of the resized form relative to the height of the form at initial display (Height of form after resizing / height of form at initial display)

Reference


ResizeEventHandler delegate

Newtone.ResizeKit.Win.ResizeKit.ResizeEventHandler Delegate

This represents the delegate that handles the ResizeEnd Event
[Visual Basic]Public Delegate Sub ResizeEventHandler(ByVal sender As Object, ByVal e As Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs)
[C#]public delegate void ResizeEventHandler(object sender, Newtone.ResizeKit.Win.ResizeKit.ResizeEventArgs e);

Parameters

sender
Event source
e
Event data is retrieved in ResizeEventArgs

Reference