%%phrase%%

Noemax DotNetCompression
Noemax.GZip Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Noemax.GZip |

Copyright © 2010 Noemax Technologies. All rights reserved.


%%ItemTitle%%

Noemax.GZip Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | DeflateInputStream | Provides methods and properties for decompressing streams using the DEFLATE algorithm.
Class | DeflateOutputStream | Provides methods and properties for compressing streams using the DEFLATE algorithm.
Class | DeflateStream | Provides methods and properties for processing streams using the DEFLATE algorithm.
Class | ExtraFieldCollection | Represents a collection of GZip header fields.
Class | GZipHeaderField | Represents a GZip header field.
Class | GZipInputStream | Provides methods and properties to decompress GZIP stream.
Class | GZipOutputStream | Provides the compression stream writing GZip streams and files.
Class | GZipStream | Provides methods and properties for processing streams using GZIP.
Class | InvalidInputException | The exception that is thrown when a compressed input stream is in an invalid format.

Enumerations

 | Enumeration | Description
Enumeration | CompressionMode | Defines the compression modes for GZipStream.

See Also

Reference

Noemax.GZip Assembly


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

Provides methods and properties for decompressing streams using the DEFLATE algorithm.

Object Model

DeflateInputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
C#
public class DeflateInputStream : System.IO.Stream
Delphi
public class DeflateInputStream = class(System.IO.Stream)
JScript
public class DeflateInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateInputStream : public System.IO.Stream
C++/CLI
public ref class DeflateInputStream : public System.IO.Stream

Remarks

By default, DeflateInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateInputStream

See Also

Reference

DeflateInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
DeflateInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

The following tables list the members exposed by DeflateInputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : DeflateInputStream Constructor

Overload List

Overload | Description
DeflateInputStream Constructor(String) | Initializes a new instance of DeflateInputStream
DeflateInputStream Constructor(Stream,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream,Boolean,Boolean) | Initializes a new instance of DeflateInputStream.
DeflateInputStream Constructor(Stream) | Initializes a new instance of DeflateInputStream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of DeflateInputStream

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New DeflateInputStream(fileName)
C#
public DeflateInputStream(
   string fileName
)
Delphi
public DeflateInputStream(
    fileName: String
);
JScript
public function DeflateInputStream(
   fileName : String
);
Managed Extensions for C++
public: DeflateInputStream(
   string* fileName
)
C++/CLI
public:
DeflateInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Constructor(Stream,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream,Boolean,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateInputStream(stream, leaveOpen, zlibHeader)
C#
public DeflateInputStream(
   Stream stream,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateInputStream(
    stream: Stream;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateInputStream(
   stream : Stream,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the underlying stream is expected to be RFC1950 Zlib format stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > DeflateInputStream Constructor : DeflateInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of DeflateInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New DeflateInputStream(stream)
C#
public DeflateInputStream(
   Stream stream
)
Delphi
public DeflateInputStream(
    stream: Stream
);
JScript
public function DeflateInputStream(
   stream : Stream
);
Managed Extensions for C++
public: DeflateInputStream(
   Stream* stream
)
C++/CLI
public:
DeflateInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
DeflateInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream and releases any associated resources.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Restart | Restarts the decompression starting from current possition of the underlying stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Close Method

Closes the stream and releases any associated resources.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
DeflateInputStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Restart Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Restart Method

Restarts the decompression starting from current possition of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Restart()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Restart()
C#
public void Restart()
Delphi
public procedure Restart();
JScript
public function Restart();
Managed Extensions for C++
public: void Restart();
C++/CLI
public:
void Restart();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
DeflateInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateInputStream Class

For a list of all members of this type, see DeflateInputStream members.

Public Properties

 | Name | Description
public Property | BytesBuffered | Returns the number of unprocessed bytes in DeflateInputStream buffer.
public Property | CanRead | Overridden. This property always returns true.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BytesBuffered Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BytesBuffered Property

Returns the number of unprocessed bytes in DeflateInputStream buffer.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property BytesBuffered As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.BytesBuffered
C#
public int BytesBuffered {get;}
Delphi
public read-only property BytesBuffered: Integer;
JScript
public function get BytesBuffered : int
Managed Extensions for C++
public: __property int get_BytesBuffered();
C++/CLI
public:
property int BytesBuffered {
   int get();
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanRead Property

This property always returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

Provides methods and properties for compressing streams using the DEFLATE algorithm.

Object Model

DeflateOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
C#
public class DeflateOutputStream : System.IO.Stream
Delphi
public class DeflateOutputStream = class(System.IO.Stream)
JScript
public class DeflateOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateOutputStream : public System.IO.Stream
C++/CLI
public ref class DeflateOutputStream : public System.IO.Stream

Remarks

By default, DeflateOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateOutputStream

See Also

Reference

DeflateOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
DeflateOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

The following tables list the members exposed by DeflateOutputStream.

Public Constructors

 | Name | Description
public Constructor | DeflateOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : DeflateOutputStream Constructor

Overload List

Overload | Description
DeflateOutputStream Constructor(String,Int32) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean) | Initializes a new instance of DeflateOutputStream class.
DeflateOutputStream Constructor(Stream,Int32) | Initializes a new instance DeflateOutputStream class.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(String,Int32)

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(fileName, compressionLevel)
C#
public DeflateOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32,Boolean,Boolean)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

Initializes a new instance of DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateOutputStream(stream, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true RFC1950 Zlib format will be used to write DEFLATE stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > DeflateOutputStream Constructor : DeflateOutputStream Constructor(Stream,Int32)

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance DeflateOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New DeflateOutputStream(stream, compressionLevel)
C#
public DeflateOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public DeflateOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function DeflateOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
DeflateOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
DeflateOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Finish | Concludes compression and flushes the content of the internal buffer to the underlying stream.
public Method | Flush | Overloaded. Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
DeflateOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Dispose Method

Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the DeflateOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Finish Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Finish Method

Concludes compression and flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Sub Finish()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Finish()
C#
public void Finish()
Delphi
public procedure Finish();
JScript
public function Finish();
Managed Extensions for C++
public: void Finish();
C++/CLI
public:
void Finish();

Remarks

Finish concludes compression by writing the markup indicating the end of compressed data and flushing the content of the internal buffer.

After this method has been called, no more data can be written to this stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Overload List

Overload | Description
Flush() | Flushes the content of the internal buffer to the underlying stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Flush() Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Finish or Close method is called.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
DeflateOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateOutputStream Class

For a list of all members of this type, see DeflateOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

This property is always true if Finish has not been called. After Finish has been called this property is false.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

Provides methods and properties for processing streams using the DEFLATE algorithm.

Object Model

DeflateStream Class

Syntax

Visual Basic (Declaration)
Public Class DeflateStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
C#
public class DeflateStream : System.IO.Stream
Delphi
public class DeflateStream = class(System.IO.Stream)
JScript
public class DeflateStream extends System.IO.Stream
Managed Extensions for C++
public __gc class DeflateStream : public System.IO.Stream
C++/CLI
public ref class DeflateStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.DeflateStream

See Also

Reference

DeflateStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
DeflateStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : DeflateStream Class

The following tables list the members exposed by DeflateStream.

Public Constructors

 | Name | Description
public Constructor | DeflateStream Constructor | Overloaded. Initializes a new instance of the DeflateStream class.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Flushes the content of internal buffer and closes the current stream. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : DeflateStream Constructor

Initializes a new instance of the DeflateStream class.

Overload List

Overload | Description
DeflateStream Constructor(String,CompressionMode) | Initializes a new instance of DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the DeflateStream class.
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean) | Initializes a new instance of the DeflateStream class.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(String,CompressionMode)

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New DeflateStream(fileName, mode)
C#
public DeflateStream(
   string fileName,
   CompressionMode mode
)
Delphi
public DeflateStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file where to write compressed data or read compressed data from.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. There is no limit in the size of the stream to be compressed.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New DeflateStream(stream, mode)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.

Remarks

By default DeflateStream owns the underlying stream, so closing this stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New DeflateStream(stream, mode, compressionLevel)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > DeflateStream Constructor : DeflateStream Constructor(Stream,CompressionMode,Int32,Boolean,Boolean)

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Initializes a new instance of the DeflateStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean, _
   ByVal zlibHeader As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean
Dim zlibHeader As Boolean

Dim instance As New DeflateStream(stream, mode, compressionLevel, leaveOpen, zlibHeader)
C#
public DeflateStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
Delphi
public DeflateStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean;
    zlibHeader: Boolean
);
JScript
public function DeflateStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean,
   zlibHeader : boolean
);
Managed Extensions for C++
public: DeflateStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)
C++/CLI
public:
DeflateStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen,
   bool zlibHeader
)

Parameters

stream
The stream to compress or decompress.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
zlibHeader

If true the stream is to be RFC1950 Zlib format stream.

Remarks

By default, DeflateStream owns the underlying stream, so closing the stream also closes the underlying stream. Note that the state of the underlying stream can affect the usability of the stream. Also, no explicit checks are performed, so no additional exceptions are thrown when the new instance is created.

If an instance of the DeflateStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
DeflateStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Flushes the content of internal buffer and closes the current stream. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Dispose Method

Flushes the content of internal buffer and closes the current stream.

Overload List

Overload | Description
Dispose(Boolean) | Flushes the content of internal buffer and closes the current stream.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

If Finish has not yet been called, Close will call Finish before closing the stream. Do not close the underlying stream before closing this stream.

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
DeflateStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : DeflateStream Class

For a list of all members of this type, see DeflateStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

DeflateStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ExtraFieldCollection Class
Members See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

Represents a collection of GZip header fields.

Object Model

ExtraFieldCollection Class

Syntax

Visual Basic (Declaration)
<DefaultMemberAttribute("Item")>
Public NotInheritable Class ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
C#
[DefaultMemberAttribute("Item")]
public sealed class ExtraFieldCollection
Delphi
public class ExtraFieldCollection sealed;
JScript
DefaultMemberAttribute("Item")
public sealed class ExtraFieldCollection
Managed Extensions for C++
[DefaultMemberAttribute("Item")]
public __gc __sealed class ExtraFieldCollection
C++/CLI
[DefaultMemberAttribute("Item")]
public ref class ExtraFieldCollection sealed

Inheritance Hierarchy

System.Object
Noemax.GZip.ExtraFieldCollection

See Also

Reference

ExtraFieldCollection Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
ExtraFieldCollection Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

The following tables list the members exposed by ExtraFieldCollection.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
ExtraFieldCollection Class Methods
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Methods

 | Name | Description
public Method | Add | Overloaded. Adds the header to the list of GZip headers.
public Method | Clear | Clears the list of GZip headers.
public Method | CopyTo | Copies the content of the collection into an array of GZipHeaderField.
public Method | Get | Overloaded. Gets the header.Gets the header.
public Method | GetByID | Gets the header associated with the ID represented as a 16-bit unsigned integer.
public Method | GetEnumerator | Gets a list of items in a collection.
public Method | Remove | Removes the header with the specified index.
public Method | RemoveByID | Removes the header specified by the 16-bit unsigned integer ID.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Add Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Add Method

Adds the header to the list of GZip headers.

Overload List

Overload | Description
Add(Int32,Byte[]) | Adds the header to the list of GZip headers.
Add(Byte,Byte,Byte[]) | Adds the header to the list of GZip headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Add(Int32,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Int32,Byte[]) Method

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id As Integer, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim data() As Byte

instance.Add(id, data)
C#
public void Add(
   int id,
   byte[] data
)
Delphi
public procedure Add(
    id: Integer;
    data: Bytearray of
);
JScript
public function Add(
   id : int,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   int id,
   byte[]* data
)
C++/CLI
public:
void Add(
   int id,
   array<byte>^ data
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.
data
The array of bytes to be stored in header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Add(Byte, Byte, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Add(Byte,Byte,Byte[]) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Add Method : Add(Byte,Byte,Byte[]) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.
Adds the header to the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte, _
   ByVal data() As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim data() As Byte

instance.Add(id1, id2, data)
C#
public void Add(
   byte id1,
   byte id2,
   byte[] data
)
Delphi
public procedure Add(
    id1: Byte;
    id2: Byte;
    data: Bytearray of
);
JScript
public function Add(
   id1 : byte,
   id2 : byte,
   data : byte[]
);
Managed Extensions for C++
public: void Add(
   byte id1,
   byte id2,
   byte[]* data
)
C++/CLI
public:
void Add(
   byte id1,
   byte id2,
   array<byte>^ data
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
data
The array of bytes to be stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Add(Int32, Byte[]) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Clear Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Clear Method

Clears the list of GZip headers.

Syntax

Visual Basic (Declaration)
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection

instance.Clear()
C#
public void Clear()
Delphi
public procedure Clear();
JScript
public function Clear();
Managed Extensions for C++
public: void Clear();
C++/CLI
public:
void Clear();

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : CopyTo Method

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

Copies the content of the collection into an array of GZipHeaderField.

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As GZipHeaderField, _
   ByVal arrayIndex As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim array() As GZipHeaderField
Dim arrayIndex As Integer

instance.CopyTo(array, arrayIndex)
C#
public void CopyTo(
   GZipHeaderField[] array,
   int arrayIndex
)
Delphi
public procedure CopyTo(
    array: GZipHeaderFieldarray of;
    arrayIndex: Integer
);
JScript
public function CopyTo(
   array : GZipHeaderField[],
   arrayIndex : int
);
Managed Extensions for C++
public: void CopyTo(
   GZipHeaderField*[]* array,
   int arrayIndex
)
C++/CLI
public:
void CopyTo(
   array<GZipHeaderField^>^ array,
   int arrayIndex
)

Parameters

array
The destination array of GZipHeaderField.
arrayIndex

The index in the destination array at which to begin copying .

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Get Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Get Method

Gets the header.Gets the header.

Overload List

Overload | Description
Get(Byte,Byte) | Gets the header associated with the ID represented as two ANSI character octet.
Get(Int32) | Gets the GZip header specified by its index in the list of headers.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Get(Byte,Byte) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Byte,Byte) Method

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.
Gets the header associated with the ID represented as two ANSI character octet.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal id1 As Byte, _
   ByVal id2 As Byte _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id1 As Byte
Dim id2 As Byte
Dim value() As Byte

value = instance.Get(id1, id2)
C#
public byte[] Get(
   byte id1,
   byte id2
)
Delphi
public function Get(
    id1: Byte;
    id2: Byte
): array of Byte;
JScript
public function Get(
   id1 : byte,
   id2 : byte
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   byte id1,
   byte id2
)
C++/CLI
public:
array<byte>^ Get(
   byte id1,
   byte id2
)

Parameters

id1
The 8-bit ID1 value.
id2
The 8-bit ID2 value.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2).

Use this method if it's more comfortable to provide the ID as two 8-bit values. To provide the ID as a single 16-bit unsigned integer use Get(Int32) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Get(Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class > Get Method : Get(Int32) Method

index
The index of the header field.
Gets the GZip header specified by its index in the list of headers.

Syntax

Visual Basic (Declaration)
Public Overloads Function Get( _
   ByVal index As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value() As Byte

value = instance.Get(index)
C#
public byte[] Get(
   int index
)
Delphi
public function Get(
    index: Integer
): array of Byte;
JScript
public function Get(
   index : int
) : byte[];
Managed Extensions for C++
public: byte[]* Get(
   int index
)
C++/CLI
public:
array<byte>^ Get(
   int index
)

Parameters

index
The index of the header field.

Return Value

The array of bytes stored in the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetByID Method

id
The 16-bit unsigned integer identifier of the header field.
Gets the header associated with the ID represented as a 16-bit unsigned integer. Gets the header.

Syntax

Visual Basic (Declaration)
Public Function GetByID( _
   ByVal id As Integer _
) As Byte()
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer
Dim value() As Byte

value = instance.GetByID(id)
C#
public byte[] GetByID(
   int id
)
Delphi
public function GetByID(
    id: Integer
): array of Byte;
JScript
public function GetByID(
   id : int
) : byte[];
Managed Extensions for C++
public: byte[]* GetByID(
   int id
)
C++/CLI
public:
array<byte>^ GetByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

Return Value

The array of bytes stored in the header field.

Remarks

Each GZip header extra-field is identified by two 8-bit values (ID1 and ID2), which can be represented as a single 16-bit unsigned integer where ID1 is the most significant 8 bits and ID2 is the less significant 8 bits of its binary representation.

Use this method if it's more comfortable to provide the ID as a single Int16 value. To provide the ID as two 8-bit fields use Get(Byte, Byte) overload.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetEnumerator Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : GetEnumerator Method

Gets a list of items in a collection.

Syntax

Visual Basic (Declaration)
Public Function GetEnumerator() As IEnumerator(Of GZipHeaderField)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As IEnumerator(Of GZipHeaderField)

value = instance.GetEnumerator()
C#
public IEnumerator<GZipHeaderField> GetEnumerator()
Delphi
public function GetEnumerator(): IEnumerator;
JScript
public function GetEnumerator() : IEnumerator;
Managed Extensions for C++
public: IEnumerator<GZipHeaderField*>* GetEnumerator();
C++/CLI
public:
IEnumerator<GZipHeaderField^>^ GetEnumerator();

Return Value

An IEnumerator object that can be used to iterate through the collection.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Remove Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Remove Method

index
The index of header field.
Removes the header with the specified index.

Syntax

Visual Basic (Declaration)
Public Sub Remove( _
   ByVal index As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer

instance.Remove(index)
C#
public void Remove(
   int index
)
Delphi
public procedure Remove(
    index: Integer
);
JScript
public function Remove(
   index : int
);
Managed Extensions for C++
public: void Remove(
   int index
)
C++/CLI
public:
void Remove(
   int index
)

Parameters

index
The index of header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
RemoveByID Method
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : RemoveByID Method

id
The 16-bit unsigned integer identifier of the header field.

Removes the header specified by the 16-bit unsigned integer ID.

Syntax

Visual Basic (Declaration)
Public Sub RemoveByID( _
   ByVal id As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim id As Integer

instance.RemoveByID(id)
C#
public void RemoveByID(
   int id
)
Delphi
public procedure RemoveByID(
    id: Integer
);
JScript
public function RemoveByID(
   id : int
);
Managed Extensions for C++
public: void RemoveByID(
   int id
)
C++/CLI
public:
void RemoveByID(
   int id
)

Parameters

id
The 16-bit unsigned integer identifier of the header field.

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
ExtraFieldCollection Class Properties
See Also Send Feedback
Noemax.GZip Namespace : ExtraFieldCollection Class

For a list of all members of this type, see ExtraFieldCollection members.

Public Properties

 | Name | Description
public Property | Count | Gets the number of contained headers.
public Property | IsReadOnly | Gets a value indicating whether the collection is read-only.
public Property | Item | Gets the header at the specified index.
Top

See Also

Reference

ExtraFieldCollection Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Count Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Count Property

Gets the number of contained headers.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Integer

value = instance.Count
C#
public int Count {get;}
Delphi
public read-only property Count: Integer;
JScript
public function get Count : int
Managed Extensions for C++
public: __property int get_Count();
C++/CLI
public:
property int Count {
   int get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
IsReadOnly Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : IsReadOnly Property

Gets a value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim value As Boolean

value = instance.IsReadOnly
C#
public bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: Boolean;
JScript
public function get IsReadOnly : boolean
Managed Extensions for C++
public: __property bool get_IsReadOnly();
C++/CLI
public:
property bool IsReadOnly {
   bool get();
}

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Item Property
See Also Send Feedback
Noemax.GZip Namespace > ExtraFieldCollection Class : Item Property

index
Gets the header at the specified index.

Syntax

Visual Basic (Declaration)
Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As ExtraFieldCollection
Dim index As Integer
Dim value As GZipHeaderField

value = instance.Item(index)
C#
public GZipHeaderField this(
   int index
) {get;}
Delphi
public  this: : GZipHeaderField;(
    index: Integer
); read-only
JScript
public  this(
   index : int
) get : GZipHeaderField
Managed Extensions for C++
public: __property GZipHeaderField* get_Item(
   int index
);
C++/CLI
public:
property GZipHeaderField^ default [int] {
   GZipHeaderField^ get(int index);
}

Parameters

index

See Also

Reference

ExtraFieldCollection Class
ExtraFieldCollection Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipHeaderField Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

Represents a GZip header field.

Object Model

GZipHeaderField Class

Syntax

Visual Basic (Declaration)
Public Class GZipHeaderField
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
C#
public class GZipHeaderField
Delphi
public class GZipHeaderField
JScript
public class GZipHeaderField
Managed Extensions for C++
public __gc class GZipHeaderField
C++/CLI
public ref class GZipHeaderField

Inheritance Hierarchy

System.Object
Noemax.GZip.GZipHeaderField

See Also

Reference

GZipHeaderField Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
GZipHeaderField Class Members
See Also Properties Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

The following tables list the members exposed by GZipHeaderField.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
GZipHeaderField Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipHeaderField Class

For a list of all members of this type, see GZipHeaderField members.

Public Properties

 | Name | Description
public Property | Data | The data contained in the header field.
public Property | ID | The 16-bit identifier of the header field (concatenated ID1 and ID2).
public Property | ID1 | The 8-bit ID1 identifier.
public Property | ID2 | The 8-bit ID2 identifier.
Top

See Also

Reference

GZipHeaderField Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Data Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : Data Property

The data contained in the header field.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value() As Byte

value = instance.Data
C#
public byte[] Data {get;}
Delphi
public read-only property Data: array of Byte;
JScript
public function get Data : byte[]
Managed Extensions for C++
public: __property byte[]* get_Data();
C++/CLI
public:
property array<byte>^ Data {
   array<byte>^ get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ID Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID Property

The 16-bit identifier of the header field (concatenated ID1 and ID2).

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID As Short
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Short

value = instance.ID
C#
public short ID {get;}
Delphi
public read-only property ID: ShortInt;
JScript
public function get ID : short
Managed Extensions for C++
public: __property short get_ID();
C++/CLI
public:
property short ID {
   short get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ID1 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID1 Property

The 8-bit ID1 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID1 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID1
C#
public byte ID1 {get;}
Delphi
public read-only property ID1: Byte;
JScript
public function get ID1 : byte
Managed Extensions for C++
public: __property byte get_ID1();
C++/CLI
public:
property byte ID1 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ID2 Property
See Also Send Feedback
Noemax.GZip Namespace > GZipHeaderField Class : ID2 Property

The 8-bit ID2 identifier.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ID2 As Byte
Visual Basic (Usage) Copy Code
Dim instance As GZipHeaderField
Dim value As Byte

value = instance.ID2
C#
public byte ID2 {get;}
Delphi
public read-only property ID2: Byte;
JScript
public function get ID2 : byte
Managed Extensions for C++
public: __property byte get_ID2();
C++/CLI
public:
property byte ID2 {
   byte get();
}

See Also

Reference

GZipHeaderField Class
GZipHeaderField Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipInputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

Provides methods and properties to decompress GZIP stream.

Object Model

GZipInputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
C#
public class GZipInputStream : System.IO.Stream
Delphi
public class GZipInputStream = class(System.IO.Stream)
JScript
public class GZipInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipInputStream : public System.IO.Stream
C++/CLI
public ref class GZipInputStream : public System.IO.Stream

Remarks

By default, GZipInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipInputStream

See Also

Reference

GZipInputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
GZipInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

The following tables list the members exposed by GZipInputStream.

Public Constructors

 | Name | Description
public Constructor | GZipInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipInputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GZipInputStream Constructor

Overload List

Overload | Description
GZipInputStream Constructor(String) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream,Boolean) | Initializes a new instance of GZipInputStream class.
GZipInputStream Constructor(Stream) | Initializes a new instance of GZipInputStream class.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipInputStream Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New GZipInputStream(fileName)
C#
public GZipInputStream(
   string fileName
)
Delphi
public GZipInputStream(
    fileName: String
);
JScript
public function GZipInputStream(
   fileName : String
);
Managed Extensions for C++
public: GZipInputStream(
   string* fileName
)
C++/CLI
public:
GZipInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New GZipInputStream(stream, leaveOpen)
C#
public GZipInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public GZipInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function GZipInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipInputStream Constructor(Stream)
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > GZipInputStream Constructor : GZipInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of GZipInputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New GZipInputStream(stream)
C#
public GZipInputStream(
   Stream stream
)
Delphi
public GZipInputStream(
    stream: Stream
);
JScript
public function GZipInputStream(
   stream : Stream
);
Managed Extensions for C++
public: GZipInputStream(
   Stream* stream
)
C++/CLI
public:
GZipInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
GZipInputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.Closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. This method is not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | ReadHeader | Reads the GZIP header from the stream.
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.Closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream have been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members
GZipInputStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipInputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Flush Method

This method is not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown. A cyclic redundancy check (CRC) is performed when all data up to the end of stream have been read.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadHeader Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadHeader Method

Reads the GZIP header from the stream.

Syntax

Visual Basic (Declaration)
Public Sub ReadHeader()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ReadHeader()
C#
public void ReadHeader()
Delphi
public procedure ReadHeader();
JScript
public function ReadHeader();
Managed Extensions for C++
public: void ReadHeader();
C++/CLI
public:
void ReadHeader();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Write Method

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count

The number of bytes to be written to the current stream.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
GZipInputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipInputStream Class

For a list of all members of this type, see GZipInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading while decompressing a file.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. This property always returns false.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | ExtraFields | The collection of extra-fields read from the GZip header.
public Property | Filename | Gets the filename specified in the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | ParseExtraFields | Gets and sets whether the reader should parse the extra-fields stored in the GZip header.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipInputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanRead Property

Gets a value indicating whether the stream supports reading while decompressing a file.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports reading and is not closed.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CanWrite Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

Remarks

The length check can fail on the files that are bigger than 4GB, since GZIP header does not support serializing bigger number. For this reason it's recommended to set this property to false in cases when original data might exceed the 4294967295 bytes.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ExtraFields Property

The collection of extra-fields read from the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

If the GZip header does not contain any extra-fields this property returns an empty ExtraFieldCollection.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Filename Property

Gets the filename specified in the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As String

value = instance.Filename
C#
public string Filename {get;}
Delphi
public read-only property Filename: String;
JScript
public function get Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
C++/CLI
public:
property String^ Filename {
   String^ get();
}

Remarks

If the filename is not present in the GZip header it returns null (Nothing for Visual Basic).

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GZipInputStream will try to read the Length property of the underlying stream. Check the the Length property documentation of the underlying stream for more information.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ParseExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ParseExtraFields Property

Gets and sets whether the reader should parse the extra-fields stored in the GZip header.

Syntax

Visual Basic (Declaration)
Public Property ParseExtraFields As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Boolean

instance.ParseExtraFields = value

value = instance.ParseExtraFields
C#
public bool ParseExtraFields {get; set;}
Delphi
public read-write property ParseExtraFields: Boolean;
JScript
public function get,set ParseExtraFields : boolean
Managed Extensions for C++
public: __property bool get_ParseExtraFields();
public: __property void set_ParseExtraFields(
   bool value
);
C++/CLI
public:
property bool ParseExtraFields {
   bool get();
   void set (    bool value);
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipOutputStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

Provides the compression stream writing GZip streams and files.

Object Model

GZipOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
C#
public class GZipOutputStream : System.IO.Stream
Delphi
public class GZipOutputStream = class(System.IO.Stream)
JScript
public class GZipOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipOutputStream : public System.IO.Stream
C++/CLI
public ref class GZipOutputStream : public System.IO.Stream

Remarks

By default, GZipOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipOutputStream

See Also

Reference

GZipOutputStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
GZipOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

The following tables list the members exposed by GZipOutputStream.

Public Constructors

 | Name | Description
public Constructor | GZipOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipOutputStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GZipOutputStream Constructor

Overload List

Overload | Description
GZipOutputStream Constructor(String,Int32) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of the GZipOutputStream class.
GZipOutputStream Constructor(Stream,Int32) | Initializes a new instance of the GZipOutputStream class.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(String,Int32)

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(fileName, compressionLevel)
C#
public GZipOutputStream(
   string fileName,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    fileName: String;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   fileName : String,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   string* fileName,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   String^ fileName,
   int compressionLevel
)

Parameters

fileName
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipOutputStream(stream, compressionLevel, leaveOpen)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > GZipOutputStream Constructor : GZipOutputStream Constructor(Stream,Int32)

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipOutputStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New GZipOutputStream(stream, compressionLevel)
C#
public GZipOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public GZipOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function GZipOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
GZipOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
GZipOutputStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the internal buffer content and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Close Method

Flushes the internal buffer content and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

Before closing, the GZipOutputStream will also flush its buffer and write the GZip trailer fields into the underlying stream. Do not close the underlying stream before closing this stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
GZipOutputStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Dispose Method

Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Overload List

Overload | Description
Dispose(Boolean) | Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Releases the unmanaged resources used by the GZipOutputStream and optionally releases the managed resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset

The zero-based byte offset in buffer at which to begin storing the data read from the current stream.

count
The maximum number of bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush or Close method is called.

Upon the first write operation GZipOutputStream will write the GZip header into the underlying stream, therefore all required headers have to be specified before the first write operation.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
GZipOutputStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipOutputStream Class

For a list of all members of this type, see GZipOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. This property always returns false.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | Comments | Gets and sets the file comments to write into the GZip header.
public Property | ExtraFields | The collection of extra-fields to write into the GZip header.
public Property | Filename | Gets and sets the filename to write into the GZip header.
public Property | Length | Overridden. Gets the length in bytes of the underlying stream.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipOutputStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanRead Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

Remarks

Returns true if the underlying stream supports writing and is not closed; otherwise, false.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Comments Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Comments Property

Gets and sets the file comments to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Comments As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Comments = value

value = instance.Comments
C#
public string Comments {get; set;}
Delphi
public read-write property Comments: String;
JScript
public function get,set Comments : String
Managed Extensions for C++
public: __property string* get_Comments();
public: __property void set_Comments(
   string* value
);
C++/CLI
public:
property String^ Comments {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the comments for the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property has to be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ExtraFields Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ExtraFields Property

The collection of extra-fields to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ExtraFields As ExtraFieldCollection
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As ExtraFieldCollection

value = instance.ExtraFields
C#
public ExtraFieldCollection ExtraFields {get;}
Delphi
public read-only property ExtraFields: ExtraFieldCollection;
JScript
public function get ExtraFields : ExtraFieldCollection
Managed Extensions for C++
public: __property ExtraFieldCollection* get_ExtraFields();
C++/CLI
public:
property ExtraFieldCollection^ ExtraFields {
   ExtraFieldCollection^ get();
}

Remarks

You can provide the set of extra-fields to be written into the GZip header by modifying this collection.

The GZip header will be written during the first write operation, therefore the extra-header fields should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Filename Property

Gets and sets the filename to write into the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Length Property

Gets the length in bytes of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

Remarks

GzipOutputStream will try to readthe Length property of the underlying stream. Check the Length property documentation the underlying stream for more information .

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Class
Members See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

Provides methods and properties for processing streams using GZIP.

Object Model

GZipStream Class

Syntax

Visual Basic (Declaration)
Public Class GZipStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
C#
public class GZipStream : System.IO.Stream
Delphi
public class GZipStream = class(System.IO.Stream)
JScript
public class GZipStream extends System.IO.Stream
Managed Extensions for C++
public __gc class GZipStream : public System.IO.Stream
C++/CLI
public ref class GZipStream : public System.IO.Stream

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.GZip.GZipStream

See Also

Reference

GZipStream Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
GZipStream Class Members
See Also Properties Methods Send Feedback
Noemax.GZip Namespace : GZipStream Class

The following tables list the members exposed by GZipStream.

Public Constructors

 | Name | Description
public Constructor | GZipStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Closes the stream and releases the allocated resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GZipStream Constructor

Overload List

Overload | Description
GZipStream Constructor(String,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean) | Initializes a new instance of the GZipStream class.
GZipStream Constructor(Stream,CompressionMode,Int32) | Initializes a new instance of the GZipStream class.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor(String,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(String,CompressionMode)

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim fileName As String
Dim mode As CompressionMode

Dim instance As New GZipStream(fileName, mode)
C#
public GZipStream(
   string fileName,
   CompressionMode mode
)
Delphi
public GZipStream(
    fileName: String;
    mode: CompressionMode
);
JScript
public function GZipStream(
   fileName : String,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   string* fileName,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   String^ fileName,
   CompressionMode mode
)

Parameters

fileName
The path to the file to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor(Stream,CompressionMode)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode

Dim instance As New GZipStream(stream, mode)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor(Stream,CompressionMode,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32,Boolean)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New GZipStream(stream, mode, compressionLevel, leaveOpen)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GZipStream Constructor(Stream,CompressionMode,Int32)
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > GZipStream Constructor : GZipStream Constructor(Stream,CompressionMode,Int32)

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of the GZipStream class.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal mode As CompressionMode, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim mode As CompressionMode
Dim compressionLevel As Integer

Dim instance As New GZipStream(stream, mode, compressionLevel)
C#
public GZipStream(
   Stream stream,
   CompressionMode mode,
   int compressionLevel
)
Delphi
public GZipStream(
    stream: Stream;
    mode: CompressionMode;
    compressionLevel: Integer
);
JScript
public function GZipStream(
   stream : Stream,
   mode : CompressionMode,
   compressionLevel : int
);
Managed Extensions for C++
public: GZipStream(
   Stream* stream,
   CompressionMode mode,
   int compressionLevel
)
C++/CLI
public:
GZipStream(
   Stream^ stream,
   CompressionMode mode,
   int compressionLevel
)

Parameters

stream
The stream to which the compressed data will be written or from which the data to be decompressed will be read.
mode
One of the CompressionMode values that indicates the action to take.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

Remarks

If an instance of the GZipStream class is created with the mode parameter equal to Compress, header information is inserted immediately. If no further action occurs, the stream appears as a valid, empty, compressed file.

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
GZipStream Class Methods
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the content of internal buffer and closes the current stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. Closes the stream and releases the allocated resources. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the content of the internal buffer to the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads a number of decompressed bytes into the specified byte array.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | SetLength | Overridden. This method is not supported and always throws a NotSupportedException.
public Method | Write | Overridden. Writes compressed bytes to the underlying stream from the specified byte array.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Close Method

Flushes the content of internal buffer and closes the current stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

Remarks

If this stream had been initialized with leaveOpen set to true, the underlying stream remains open after this method is called, otherwise the underlying stream is also closed.

See Also

Reference

GZipStream Class
GZipStream Members
GZipStream Constructor


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Dispose Method

Closes the stream and releases the allocated resources.

Overload List

Overload | Description
Dispose(Boolean) | Closes the stream and releases the allocated resources.
Dispose() | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose(Boolean) Method

disposing
Closes the stream and releases the allocated resources.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); override;
JScript
protected override function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
) override
C++/CLI
protected:
void Dispose(
   bool disposing
) override

Parameters

disposing

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Flush Method

Flushes the content of the internal buffer to the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

Remarks

When writing using the Write method, the data may not be written to the stream since writing the data back in chunks can provide better performance. Calling the Flush method forces the data to be written.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Read Method

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.
Reads a number of decompressed bytes into the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the decompressed bytes read from the current source.
offset
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
The maximum number of bytes to be read from the current stream.

Return Value

The number of bytes that were decompressed into the byte array. If the end of the stream has been reached, zero or the number of bytes read is returned.

Remarks

If data is found in an invalid format, an IOException is thrown.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Seek Method

offset
The location in the stream.
origin
One of the SeekOrigin values.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
The location in the stream.
origin
One of the SeekOrigin values.

Return Value

A long value.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : SetLength Method

value
The length of the stream.
This method is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
The length of the stream.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Write Method

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.
Writes compressed bytes to the underlying stream from the specified byte array.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The array containing the bytes to compress.
offset

The zero-based byte offset in the buffer at which to begin compressing and copying bytes to the current stream.

count
The number of bytes to compress.

Return Value

The number of bytes compressed into the stream.

Remarks

The write might not occur immediately since it is buffered until the buffer size is reached or until the Flush, Close method is called.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
GZipStream Class Properties
See Also Send Feedback
Noemax.GZip Namespace : GZipStream Class

For a list of all members of this type, see GZipStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets a value indicating whether the stream supports reading.
public Property | CanSeek | Overridden. This property always returns false.
public Property | CanTimeout | Overridden. Gets a value that determines whether the current stream can time out.
public Property | CanWrite | Overridden. Gets a value indicating whether the stream supports writing.
public Property | CheckCRC | Gets and sets whether to check CRC of the decompressed data.
public Property | CheckLength | Gets and sets whether to check the length of uncompressed data.
public Property | Filename | Gets and sets the filename to write into or read from the GZip header.
public Property | Length | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | Position | Overridden. This property is not supported and always throws a NotSupportedException.
public Property | ReadTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
public Property | WriteTimeout | Overridden. Gets or sets a value that determines how long the stream will attempt to read before timing out.
Top

See Also

Reference

GZipStream Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanRead Property

Gets a value indicating whether the stream supports reading.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanSeek Property

This property always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanTimeout Property

Gets a value that determines whether the current stream can time out.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

Remarks

The CanTimeout property returns a value of the inner stream CanTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CanWrite Property

Gets a value indicating whether the stream supports writing.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CheckCRC Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckCRC Property

Gets and sets whether to check CRC of the decompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckCRC As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckCRC = value

value = instance.CheckCRC
C#
public bool CheckCRC {get; set;}
Delphi
public read-write property CheckCRC: Boolean;
JScript
public function get,set CheckCRC : boolean
Managed Extensions for C++
public: __property bool get_CheckCRC();
public: __property void set_CheckCRC(
   bool value
);
C++/CLI
public:
property bool CheckCRC {
   bool get();
   void set (    bool value);
}

Property Value

true if CRC of decompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CheckLength Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CheckLength Property

Gets and sets whether to check the length of uncompressed data.

Syntax

Visual Basic (Declaration)
Public Property CheckLength As Boolean
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Boolean

instance.CheckLength = value

value = instance.CheckLength
C#
public bool CheckLength {get; set;}
Delphi
public read-write property CheckLength: Boolean;
JScript
public function get,set CheckLength : boolean
Managed Extensions for C++
public: __property bool get_CheckLength();
public: __property void set_CheckLength(
   bool value
);
C++/CLI
public:
property bool CheckLength {
   bool get();
   void set (    bool value);
}

Property Value

true if the length of uncompressed data should be validated; otherwise false.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Filename Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Filename Property

Gets and sets the filename to write into or read from the GZip header.

Syntax

Visual Basic (Declaration)
Public Property Filename As String
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As String

instance.Filename = value

value = instance.Filename
C#
public string Filename {get; set;}
Delphi
public read-write property Filename: String;
JScript
public function get,set Filename : String
Managed Extensions for C++
public: __property string* get_Filename();
public: __property void set_Filename(
   string* value
);
C++/CLI
public:
property String^ Filename {
   String^ get();
   void set (    String^ value);
}

Remarks

You can provide the name of the compressed file to be written into the GZip header by setting this property.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

The GZip header will be written during the first write operation, therefore this property should be specified before writing any data into the stream.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Length Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : Position Property

This property is not supported and always throws a NotSupportedException.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The ReadTimeout property returns a value of the inner stream ReadTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteTimeout Property

Gets or sets a value that determines how long the stream will attempt to read before timing out.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

Remarks

The WriteTimeout property returns a value of the inner stream WriteTimeout property.

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InvalidInputException Class
Members See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The exception that is thrown when a compressed input stream is in an invalid format.

Object Model

InvalidInputException Class

Syntax

Visual Basic (Declaration)
Public Class InvalidInputException
   Inherits System.IO.IOException
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
C#
public class InvalidInputException : System.IO.IOException
Delphi
public class InvalidInputException = class(System.IO.IOException)
JScript
public class InvalidInputException extends System.IO.IOException
Managed Extensions for C++
public __gc class InvalidInputException : public System.IO.IOException
C++/CLI
public ref class InvalidInputException : public System.IO.IOException

Inheritance Hierarchy

System.Object
System.Exception
System.SystemException
System.IO.IOException
Noemax.GZip.InvalidInputException

See Also

Reference

InvalidInputException Members
Noemax.GZip Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
InvalidInputException Class Members
See Also Properties Methods Events Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

The following tables list the members exposed by InvalidInputException.

Public Constructors

 | Name | Description
public Constructor | InvalidInputException Constructor | Overloaded. Initializes a new instance of the InvalidInputException class.
Top

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InvalidInputException Constructor
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InvalidInputException Constructor

Initializes a new instance of the InvalidInputException class.

Overload List

Overload | Description
InvalidInputException Constructor() | Initializes a new instance of the InvalidInputException class.
InvalidInputException Constructor(String) | Initializes a new instance of the InvalidInputException class with a specified error message.
InvalidInputException Constructor(String,Exception) | Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InvalidInputException Constructor()
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor()

Initializes a new instance of the InvalidInputException class.

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New InvalidInputException()
C#
public InvalidInputException()
Delphi
public InvalidInputException();
JScript
public function InvalidInputException();
Managed Extensions for C++
public: InvalidInputException();
C++/CLI
public:
InvalidInputException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InvalidInputException Constructor(String)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String)

message
Initializes a new instance of the InvalidInputException class with a specified error message.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String _
)
Visual Basic (Usage) Copy Code
Dim message As String

Dim instance As New InvalidInputException(message)
C#
public InvalidInputException(
   string message
)
Delphi
public InvalidInputException(
    message: String
);
JScript
public function InvalidInputException(
   message : String
);
Managed Extensions for C++
public: InvalidInputException(
   string* message
)
C++/CLI
public:
InvalidInputException(
   String^ message
)

Parameters

message

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InvalidInputException Constructor(String,Exception)
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class > InvalidInputException Constructor : InvalidInputException Constructor(String,Exception)

message
innerException
Initializes a new instance of the InvalidInputException class with a reference to the inner exception that is the cause of this exception.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal message As String, _
   ByVal innerException As Exception _
)
Visual Basic (Usage) Copy Code
Dim message As String
Dim innerException As Exception

Dim instance As New InvalidInputException(message, innerException)
C#
public InvalidInputException(
   string message,
   Exception innerException
)
Delphi
public InvalidInputException(
    message: String;
    innerException: Exception
);
JScript
public function InvalidInputException(
   message : String,
   innerException : Exception
);
Managed Extensions for C++
public: InvalidInputException(
   string* message,
   Exception* innerException
)
C++/CLI
public:
InvalidInputException(
   String^ message,
   Exception^ innerException
)

Parameters

message
innerException

See Also

Reference

InvalidInputException Class
InvalidInputException Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CompressionMode Enumeration
See Also Send Feedback
Noemax.GZip Namespace : CompressionMode Enumeration

Defines the compression modes for GZipStream.

Syntax

Visual Basic (Declaration)
Public Enum CompressionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CompressionMode
C#
public enum CompressionMode : System.Enum
Delphi
public enum CompressionMode = class(System.Enum)
JScript
public enum CompressionMode extends System.Enum
Managed Extensions for C++
__value public enum CompressionMode : public System.Enum
C++/CLI
public enum class CompressionMode : public System.Enum

Members

Member | Description
Compress | To compress data.
Decompress | To decompress data.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
Noemax.GZip.CompressionMode

See Also

Reference

Noemax.GZip Namespace


%%phrase%%

Noemax.Lzf Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Noemax.Lzf |


%%ItemTitle%%

Noemax.Lzf Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | Lzf3InputStream | Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.
Class | Lzf3OutputStream | Provides methods and properties to compress streams using LZF3 compression algorithm.
Class | LzfInputStream | Provides methods and properties to decompress streams compressed by LZF compression algorithm.
Class | LzfOutputStream | Provides methods and properties to compress streams using LZF compression algorithm.

See Also

Reference

Noemax.Lzf Assembly


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3InputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

Provides methods and properties to decompress streams compressed by LZF3 compression algorithm.

Object Model

Lzf3InputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3InputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
C#
public sealed class Lzf3InputStream : System.IO.Stream
Delphi
public class Lzf3InputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3InputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3InputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3InputStream sealed : public System.IO.Stream

Remarks

By default, Lzf3InputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3InputStream

See Also

Reference

Lzf3InputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
Lzf3InputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

The following tables list the members exposed by Lzf3InputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3InputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3InputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Lzf3InputStream Constructor

Overload List

Overload | Description
Lzf3InputStream Constructor(String) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
Lzf3InputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3InputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3InputStream(fileName)
C#
public Lzf3InputStream(
   string fileName
)
Delphi
public Lzf3InputStream(
    fileName: String
);
JScript
public function Lzf3InputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3InputStream(
   string* fileName
)
C++/CLI
public:
Lzf3InputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3InputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3InputStream(stream)
C#
public Lzf3InputStream(
   Stream stream
)
Delphi
public Lzf3InputStream(
    stream: Stream
);
JScript
public function Lzf3InputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3InputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Lzf3InputStream Constructor : Lzf3InputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3InputStream(stream, leaveOpen)
C#
public Lzf3InputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3InputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3InputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3InputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3InputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
Lzf3InputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
Lzf3InputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3InputStream Class

For a list of all members of this type, see Lzf3InputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3InputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3OutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

Provides methods and properties to compress streams using LZF3 compression algorithm.

Object Model

Lzf3OutputStream Class

Syntax

Visual Basic (Declaration)
Public NotInheritable Class Lzf3OutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
C#
public sealed class Lzf3OutputStream : System.IO.Stream
Delphi
public class Lzf3OutputStream = class(System.IO.Stream)sealed;
JScript
public sealed class Lzf3OutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc __sealed class Lzf3OutputStream : public System.IO.Stream
C++/CLI
public ref class Lzf3OutputStream sealed : public System.IO.Stream

Remarks

By default, Lzf3OutputStream owns the underlying stream, so closing this stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.Lzf3OutputStream

See Also

Reference

Lzf3OutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
Lzf3OutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

The following tables list the members exposed by Lzf3OutputStream.

Public Constructors

 | Name | Description
public Constructor | Lzf3OutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3OutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Lzf3OutputStream Constructor

Overload List

Overload | Description
Lzf3OutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
Lzf3OutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3OutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(String)

fileName
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New Lzf3OutputStream(fileName)
C#
public Lzf3OutputStream(
   string fileName
)
Delphi
public Lzf3OutputStream(
    fileName: String
);
JScript
public function Lzf3OutputStream(
   fileName : String
);
Managed Extensions for C++
public: Lzf3OutputStream(
   string* fileName
)
C++/CLI
public:
Lzf3OutputStream(
   String^ fileName
)

Parameters

fileName
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3OutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New Lzf3OutputStream(stream)
C#
public Lzf3OutputStream(
   Stream stream
)
Delphi
public Lzf3OutputStream(
    stream: Stream
);
JScript
public function Lzf3OutputStream(
   stream : Stream
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Lzf3OutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Lzf3OutputStream Constructor : Lzf3OutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New Lzf3OutputStream(stream, leaveOpen)
C#
public Lzf3OutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public Lzf3OutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function Lzf3OutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: Lzf3OutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
Lzf3OutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
Lzf3OutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
Lzf3OutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : Lzf3OutputStream Class

For a list of all members of this type, see Lzf3OutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | (Inherited from System.IO.Stream)
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | (Inherited from System.IO.Stream)
public Property | WriteTimeout | (Inherited from System.IO.Stream)
Top

See Also

Reference

Lzf3OutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides NotOverridable Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfInputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

Provides methods and properties to decompress streams compressed by LZF compression algorithm.

Object Model

LzfInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
C#
public class LzfInputStream : System.IO.Stream
Delphi
public class LzfInputStream = class(System.IO.Stream)
JScript
public class LzfInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfInputStream : public System.IO.Stream
C++/CLI
public ref class LzfInputStream : public System.IO.Stream

Remarks

By default, LzfInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfInputStream

See Also

Reference

LzfInputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
LzfInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

The following tables list the members exposed by LzfInputStream.

Public Constructors

 | Name | Description
public Constructor | LzfInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfInputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : LzfInputStream Constructor

Overload List

Overload | Description
LzfInputStream Constructor(String) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream) | Initializes a new instance of LzfInputStream.
LzfInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfInputStream.

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(String)

fileName
The path to the file from which to read copressed data from.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzfInputStream(fileName)
C#
public LzfInputStream(
   string fileName
)
Delphi
public LzfInputStream(
    fileName: String
);
JScript
public function LzfInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzfInputStream(
   string* fileName
)
C++/CLI
public:
LzfInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which to read copressed data from.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfInputStream(stream)
C#
public LzfInputStream(
   Stream stream
)
Delphi
public LzfInputStream(
    stream: Stream
);
JScript
public function LzfInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > LzfInputStream Constructor : LzfInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfInputStream(stream, leaveOpen)
C#
public LzfInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
LzfInputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Close Method

Closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Write Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
LzfInputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfInputStream Class

For a list of all members of this type, see LzfInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Gets the CanRead property of the underlying stream.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Always returns false.
public Property | Length | Overridden. Returns the length of underlying compressed stream.
public Property | Position | Overridden. Get and set the possition of underlying compressed stream.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Get the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfInputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanRead Property

Gets the CanRead property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CanWrite Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Length Property

Returns the length of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Position Property

Get and set the possition of underlying compressed stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteTimeout Property

Get the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfOutputStream Class
Members See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

Provides methods and properties to compress streams using LZF compression algorithm.

Object Model

LzfOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzfOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
C#
public class LzfOutputStream : System.IO.Stream
Delphi
public class LzfOutputStream = class(System.IO.Stream)
JScript
public class LzfOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzfOutputStream : public System.IO.Stream
C++/CLI
public ref class LzfOutputStream : public System.IO.Stream

Remarks

By default, LzfOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzf.LzfOutputStream

See Also

Reference

LzfOutputStream Members
Noemax.Lzf Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
LzfOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

The following tables list the members exposed by LzfOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzfOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfOutputStream Constructor
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : LzfOutputStream Constructor

Overload List

Overload | Description
LzfOutputStream Constructor(String) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream) | Initializes a new instance of LzfOutputStream.
LzfOutputStream Constructor(Stream,Boolean) | Initializes a new instance of LzfOutputStream.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfOutputStream Constructor(String)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(String)

filename
The path to the file to which the compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String _
)
Visual Basic (Usage) Copy Code
Dim filename As String

Dim instance As New LzfOutputStream(filename)
C#
public LzfOutputStream(
   string filename
)
Delphi
public LzfOutputStream(
    filename: String
);
JScript
public function LzfOutputStream(
   filename : String
);
Managed Extensions for C++
public: LzfOutputStream(
   string* filename
)
C++/CLI
public:
LzfOutputStream(
   String^ filename
)

Parameters

filename
The path to the file to which the compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfOutputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream)

stream
The stream to which compressed data will be written.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzfOutputStream(stream)
C#
public LzfOutputStream(
   Stream stream
)
Delphi
public LzfOutputStream(
    stream: Stream
);
JScript
public function LzfOutputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream
)

Parameters

stream
The stream to which compressed data will be written.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzfOutputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > LzfOutputStream Constructor : LzfOutputStream Constructor(Stream,Boolean)

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzfOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzfOutputStream(stream, leaveOpen)
C#
public LzfOutputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzfOutputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzfOutputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzfOutputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzfOutputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
LzfOutputStream Class Methods
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes the buffer and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the buffered compressed data into underlying stream and flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Close Method

Flushes the buffer and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Flush Method

Flushes the buffered compressed data into underlying stream and flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
LzfOutputStream Class Properties
See Also Send Feedback
Noemax.Lzf Namespace : LzfOutputStream Class

For a list of all members of this type, see LzfOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Always returns false.
public Property | CanSeek | Overridden. Always returns false.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of the underlying stream.
public Property | CanWrite | Overridden. Returns the value of CanWrite property of underlying stream.
public Property | Length | Overridden. Gets the length of the underlying stream.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden. Gets the ReadTimeout property of the underlying stream.
public Property | WriteTimeout | Overridden. Gets the WriteTimeout property of the underlying stream.
Top

See Also

Reference

LzfOutputStream Class
Noemax.Lzf Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanRead Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanSeek Property

Always returns false.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanTimeout Property

Gets the CanTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CanWrite Property

Returns the value of CanWrite property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Length Property

Gets the length of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadTimeout Property

Gets the ReadTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteTimeout Property

Gets the WriteTimeout property of the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%phrase%%

Noemax.Lzma Assembly
See Also Send Feedback

Namespaces

Namespace | Description
Noemax.Lzma |


%%ItemTitle%%

Noemax.Lzma Namespace
See Also Inheritance Hierarchy Send Feedback

Classes

 | Class | Description
Class | LzmaInputStream | Provides methods and properties to decompress streams compressed by LZMA compression algorithm.
Class | LzmaOutputStream | Provides methods and properties to compress streams using LZMA compression algorithm.

See Also

Reference

Noemax.Lzma Assembly


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaInputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

Provides methods and properties to decompress streams compressed by LZMA compression algorithm.

Object Model

LzmaInputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaInputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
C#
public class LzmaInputStream : System.IO.Stream
Delphi
public class LzmaInputStream = class(System.IO.Stream)
JScript
public class LzmaInputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaInputStream : public System.IO.Stream
C++/CLI
public ref class LzmaInputStream : public System.IO.Stream

Remarks

By default, LzmaInputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be decompressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaInputStream

See Also

Reference

LzmaInputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
LzmaInputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

The following tables list the members exposed by LzmaInputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaInputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaInputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : LzmaInputStream Constructor

Overload List

Overload | Description
LzmaInputStream Constructor(Stream) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(String) | Initializes a new instance of LzmaInputStream.
LzmaInputStream Constructor(Stream,Boolean) | Initializes a new instance of LzmaInputStream.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaInputStream Constructor(Stream)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream)

stream
The stream to decompress.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream

Dim instance As New LzmaInputStream(stream)
C#
public LzmaInputStream(
   Stream stream
)
Delphi
public LzmaInputStream(
    stream: Stream
);
JScript
public function LzmaInputStream(
   stream : Stream
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream
)

Parameters

stream
The stream to decompress.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaInputStream Constructor(String)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(String)

fileName
The path to the file from which the compressed data will be read.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As String _
)
Visual Basic (Usage) Copy Code
Dim fileName As String

Dim instance As New LzmaInputStream(fileName)
C#
public LzmaInputStream(
   string fileName
)
Delphi
public LzmaInputStream(
    fileName: String
);
JScript
public function LzmaInputStream(
   fileName : String
);
Managed Extensions for C++
public: LzmaInputStream(
   string* fileName
)
C++/CLI
public:
LzmaInputStream(
   String^ fileName
)

Parameters

fileName
The path to the file from which the compressed data will be read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaInputStream Constructor(Stream,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > LzmaInputStream Constructor : LzmaInputStream Constructor(Stream,Boolean)

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaInputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim leaveOpen As Boolean

Dim instance As New LzmaInputStream(stream, leaveOpen)
C#
public LzmaInputStream(
   Stream stream,
   bool leaveOpen
)
Delphi
public LzmaInputStream(
    stream: Stream;
    leaveOpen: Boolean
);
JScript
public function LzmaInputStream(
   stream : Stream,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaInputStream(
   Stream* stream,
   bool leaveOpen
)
C++/CLI
public:
LzmaInputStream(
   Stream^ stream,
   bool leaveOpen
)

Parameters

stream
The stream to decompress.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
LzmaInputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Close this stream and the underlying stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Not supported.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Reads the data from compressed stream and decompresses it into specified buffer.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Not supported.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Close Method

Close this stream and the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Flush Method

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Read Method

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.
Reads the data from compressed stream and decompresses it into specified buffer.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer where to store dompressed bytes.
offset
The offset in the buffer.
count
The number of bytes to read.

Return Value

The number of bytes read.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Seek Method

offset
Not supported.
origin
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
Not supported.
origin
Not supported.

Return Value

Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : SetLength Method

value
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Write Method

buffer
Not supported.
offset
Not supported.
count
Not supported.
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
Not supported.
offset
Not supported.
count
Not supported.

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
LzmaInputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaInputStream Class

For a list of all members of this type, see LzmaInputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns true. This stream can read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns false. This stream cannot write.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaInputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanRead Property

Returns true. This stream can read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CanWrite Property

Returns false. This stream cannot write.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaOutputStream Class
Members See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

Provides methods and properties to compress streams using LZMA compression algorithm.

Object Model

LzmaOutputStream Class

Syntax

Visual Basic (Declaration)
Public Class LzmaOutputStream
   Inherits System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
C#
public class LzmaOutputStream : System.IO.Stream
Delphi
public class LzmaOutputStream = class(System.IO.Stream)
JScript
public class LzmaOutputStream extends System.IO.Stream
Managed Extensions for C++
public __gc class LzmaOutputStream : public System.IO.Stream
C++/CLI
public ref class LzmaOutputStream : public System.IO.Stream

Remarks

By default, LzmaOutputStream owns the underlying stream, so closing the stream also closes the underlying stream.

There is no limit in the size of the stream to be compressed.

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.IO.Stream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

LzmaOutputStream Members
Noemax.Lzma Namespace


%%PageItemTitle%% $$Members$$

[image]
Noemax DotNetCompression
LzmaOutputStream Class Members
See Also Properties Methods Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

The following tables list the members exposed by LzmaOutputStream.

Public Constructors

 | Name | Description
public Constructor | LzmaOutputStream Constructor | Overloaded.
Top

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaOutputStream Constructor
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : LzmaOutputStream Constructor

Overload List

Overload | Description
LzmaOutputStream Constructor(String,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32) | Initializes a new instance of LzmaOutputStream.
LzmaOutputStream Constructor(Stream,Int32,Boolean) | Initializes a new instance of LzmaOutputStream.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaOutputStream Constructor(String,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(String,Int32)

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal filename As String, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim filename As String
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(filename, compressionLevel)
C#
public LzmaOutputStream(
   string filename,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    filename: String;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   filename : String,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   string* filename,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   String^ filename,
   int compressionLevel
)

Parameters

filename
The path to the file to which the compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaOutputStream Constructor(Stream,Int32)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer

Dim instance As New LzmaOutputStream(stream, compressionLevel)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
LzmaOutputStream Constructor(Stream,Int32,Boolean)
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > LzmaOutputStream Constructor : LzmaOutputStream Constructor(Stream,Int32,Boolean)

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.
Initializes a new instance of LzmaOutputStream.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal stream As Stream, _
   ByVal compressionLevel As Integer, _
   ByVal leaveOpen As Boolean _
)
Visual Basic (Usage) Copy Code
Dim stream As Stream
Dim compressionLevel As Integer
Dim leaveOpen As Boolean

Dim instance As New LzmaOutputStream(stream, compressionLevel, leaveOpen)
C#
public LzmaOutputStream(
   Stream stream,
   int compressionLevel,
   bool leaveOpen
)
Delphi
public LzmaOutputStream(
    stream: Stream;
    compressionLevel: Integer;
    leaveOpen: Boolean
);
JScript
public function LzmaOutputStream(
   stream : Stream,
   compressionLevel : int,
   leaveOpen : boolean
);
Managed Extensions for C++
public: LzmaOutputStream(
   Stream* stream,
   int compressionLevel,
   bool leaveOpen
)
C++/CLI
public:
LzmaOutputStream(
   Stream^ stream,
   int compressionLevel,
   bool leaveOpen
)

Parameters

stream
The stream to which compressed data will be written.
compressionLevel
Gets and sets the compression level to be applied, were 1 is for fastest compression and 9 for maximum compression.
leaveOpen
true to leave the underlying stream open after this stream is closed.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
LzmaOutputStream Class Methods
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Methods

 | Name | Description
public Method | BeginRead | (Inherited from System.IO.Stream)
public Method | BeginWrite | (Inherited from System.IO.Stream)
public Method | Close | Overridden. Flushes compressed bytes and closes the stream.
public Method | CopyTo | Overloaded. (Inherited from System.IO.Stream)
public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
public Method | Dispose | Overloaded. (Inherited from System.IO.Stream)
public Method | EndRead | (Inherited from System.IO.Stream)
public Method | EndWrite | (Inherited from System.IO.Stream)
public Method | Flush | Overridden. Flushes the underlying stream.
public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
public Method | Read | Overridden. Not supported.
public Method | ReadByte | (Inherited from System.IO.Stream)
public Method | Seek | Overridden. Not supported.
public Method | SetLength | Overridden. Not supported.
public Method | Write | Overridden. Compresses bytes from the specified byte array and writers them into stream.
public Method | WriteByte | (Inherited from System.IO.Stream)
Top

Protected Methods

 | Name | Description
protected Method | CreateWaitHandle | (Inherited from System.IO.Stream)
protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
protected Method | ObjectInvariant | (Inherited from System.IO.Stream)
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Close Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Close Method

Flushes compressed bytes and closes the stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Close()
C#
public override void Close()
Delphi
public procedure Close(); override;
JScript
public override function Close();
Managed Extensions for C++
public: void Close(); override
C++/CLI
public:
void Close(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Flush Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Flush Method

Flushes the underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Flush()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Flush()
C#
public override void Flush()
Delphi
public procedure Flush(); override;
JScript
public override function Flush();
Managed Extensions for C++
public: void Flush(); override
C++/CLI
public:
void Flush(); override

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Read Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Read Method

buffer
offset
count
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Read( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim value As Integer

value = instance.Read(buffer, offset, count)
C#
public override int Read(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public function Read(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
): Integer; override;
JScript
public override function Read(
   buffer : byte[],
   offset : int,
   count : int
) : int;
Managed Extensions for C++
public: int Read(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
int Read(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
offset
count

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Seek Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Seek Method

offset
origin
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Function Seek( _
   ByVal offset As Long, _
   ByVal origin As SeekOrigin _
) As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim offset As Long
Dim origin As SeekOrigin
Dim value As Long

value = instance.Seek(offset, origin)
C#
public override long Seek(
   long offset,
   SeekOrigin origin
)
Delphi
public function Seek(
    offset: Int64;
    origin: SeekOrigin
): Int64; override;
JScript
public override function Seek(
   offset : long,
   origin : SeekOrigin
) : long;
Managed Extensions for C++
public: long Seek(
   long offset,
   SeekOrigin origin
) override
C++/CLI
public:
int64 Seek(
   int64 offset,
   SeekOrigin origin
) override

Parameters

offset
origin

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SetLength Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : SetLength Method

value
Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Sub SetLength( _
   ByVal value As Long _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.SetLength(value)
C#
public override void SetLength(
   long value
)
Delphi
public procedure SetLength(
    value: Int64
); override;
JScript
public override function SetLength(
   value : long
);
Managed Extensions for C++
public: void SetLength(
   long value
) override
C++/CLI
public:
void SetLength(
   int64 value
) override

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Write Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Write Method

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.
Compresses bytes from the specified byte array and writers them into stream.

Syntax

Visual Basic (Declaration)
Public Overrides Sub Write( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer

instance.Write(buffer, offset, count)
C#
public override void Write(
   byte[] buffer,
   int offset,
   int count
)
Delphi
public procedure Write(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer
); override;
JScript
public override function Write(
   buffer : byte[],
   offset : int,
   count : int
);
Managed Extensions for C++
public: void Write(
   byte[]* buffer,
   int offset,
   int count
) override
C++/CLI
public:
void Write(
   array<byte>^ buffer,
   int offset,
   int count
) override

Parameters

buffer
The buffer containing bytes to compress.
offset
The offset in the buffer.
count
The number of bytes to compress.

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
LzmaOutputStream Class Properties
See Also Send Feedback
Noemax.Lzma Namespace : LzmaOutputStream Class

For a list of all members of this type, see LzmaOutputStream members.

Public Properties

 | Name | Description
public Property | CanRead | Overridden. Returns false. This stream cannot be read.
public Property | CanSeek | Overridden. Returns false. This stream cannot seek possition.
public Property | CanTimeout | Overridden. Gets the CanTimeout property of underlying stream.
public Property | CanWrite | Overridden. Returns true.
public Property | Length | Overridden. Not supported.
public Property | Position | Overridden. Not supported.
public Property | ReadTimeout | Overridden.
public Property | WriteTimeout | Overridden.
Top

See Also

Reference

LzmaOutputStream Class
Noemax.Lzma Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanRead Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanRead Property

Returns false. This stream cannot be read.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanRead
C#
public override bool CanRead {get;}
Delphi
public read-only property CanRead: Boolean; override;
JScript
public override function get CanRead : boolean
Managed Extensions for C++
public: __property bool get_CanRead() override;
C++/CLI
public:
property bool CanRead {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanSeek Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanSeek Property

Returns false. This stream cannot seek possition.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanSeek
C#
public override bool CanSeek {get;}
Delphi
public read-only property CanSeek: Boolean; override;
JScript
public override function get CanSeek : boolean
Managed Extensions for C++
public: __property bool get_CanSeek() override;
C++/CLI
public:
property bool CanSeek {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanTimeout Property

Gets the CanTimeout property of underlying stream.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
public override bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean; override;
JScript
public override function get CanTimeout : boolean
Managed Extensions for C++
public: __property bool get_CanTimeout() override;
C++/CLI
public:
property bool CanTimeout {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanWrite Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CanWrite Property

Returns true.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Boolean

value = instance.CanWrite
C#
public override bool CanWrite {get;}
Delphi
public read-only property CanWrite: Boolean; override;
JScript
public override function get CanWrite : boolean
Managed Extensions for C++
public: __property bool get_CanWrite() override;
C++/CLI
public:
property bool CanWrite {
   bool get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Length Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Length Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

value = instance.Length
C#
public override long Length {get;}
Delphi
public read-only property Length: Int64; override;
JScript
public override function get Length : long
Managed Extensions for C++
public: __property long get_Length() override;
C++/CLI
public:
property int64 Length {
   int64 get() override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Position Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Position Property

Not supported.

Syntax

Visual Basic (Declaration)
Public Overrides Property Position As Long
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Long

instance.Position = value

value = instance.Position
C#
public override long Position {get; set;}
Delphi
public read-write property Position: Int64; override;
JScript
public override function get,set Position : long
Managed Extensions for C++
public: __property long get_Position() override;
public: __property void set_Position(
   long value
) override;
C++/CLI
public:
property int64 Position {
   int64 get() override;
   void set (    int64 value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
public override int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer; override;
JScript
public override function get,set ReadTimeout : int
Managed Extensions for C++
public: __property int get_ReadTimeout() override;
public: __property void set_ReadTimeout(
   int value
) override;
C++/CLI
public:
property int ReadTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
Public Overrides Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
public override int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer; override;
JScript
public override function get,set WriteTimeout : int
Managed Extensions for C++
public: __property int get_WriteTimeout() override;
public: __property void set_WriteTimeout(
   int value
) override;
C++/CLI
public:
property int WriteTimeout {
   int get() override;
   void set (    int value) override;
}

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


$$GETTING_STARTED$$ - %%projecttitle%%

Getting Started
Send Feedback


$$INTRODUCTION$$ - %%projecttitle%%

Introduction
Send Feedback


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateInputStream Class
DeflateInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateOutputStream Class
DeflateOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

DeflateStream Class
DeflateStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > DeflateStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As DeflateStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

DeflateStream Class
DeflateStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipInputStream Class
GZipInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipInputStream Class
GZipInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipOutputStream Class
GZipOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

GZipStream Class
GZipStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As GZipStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.GZip Namespace > GZipStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As GZipStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

GZipStream Class
GZipStream Members


%%PageItemTitle%% $$Events$$

[image]
Noemax DotNetCompression
InvalidInputException Class Events
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Protected Events

 | Name | Description
protected Event | SerializeObjectState | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Methods$$

[image]
Noemax DotNetCompression
InvalidInputException Class Methods
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Methods

 | Name | Description
public Method | GetBaseException | (Inherited from System.Exception)
public Method | GetObjectData | (Inherited from System.Exception)
public Method | GetType | Overloaded. (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%% $$Properties$$

[image]
Noemax DotNetCompression
InvalidInputException Class Properties
See Also Send Feedback
Noemax.GZip Namespace : InvalidInputException Class

For a list of all members of this type, see InvalidInputException members.

Public Properties

 | Name | Description
public Property | Data | (Inherited from System.Exception)
public Property | HelpLink | (Inherited from System.Exception)
public Property | InnerException | (Inherited from System.Exception)
public Property | Message | (Inherited from System.Exception)
public Property | Source | (Inherited from System.Exception)
public Property | StackTrace | (Inherited from System.Exception)
public Property | TargetSite | (Inherited from System.Exception)
Top

Protected Properties

 | Name | Description
protected Property | HResult | (Inherited from System.Exception)
Top

See Also

Reference

InvalidInputException Class
Noemax.GZip Namespace


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Data Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Data Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Data As IDictionary
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As IDictionary

value = instance.Data
C#
public virtual IDictionary Data {get;}
Delphi
public read-only property Data: IDictionary; virtual;
JScript
public function get Data : IDictionary
Managed Extensions for C++
public: __property virtual IDictionary* get_Data();
C++/CLI
public:
virtual property IDictionary^ Data {
   IDictionary^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetBaseException Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetBaseException Method

Syntax

Visual Basic (Declaration)
Public Overridable Function GetBaseException() As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.GetBaseException()
C#
public virtual Exception GetBaseException()
Delphi
public function GetBaseException(): Exception; virtual;
JScript
public function GetBaseException() : Exception;
Managed Extensions for C++
public: virtual Exception* GetBaseException();
C++/CLI
public:
virtual Exception^ GetBaseException();

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetObjectData Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetObjectData Method

info
context

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Sub GetObjectData( _
   ByVal info As SerializationInfo, _
   ByVal context As StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim info As SerializationInfo
Dim context As StreamingContext

instance.GetObjectData(info, context)
C#
[SecurityCriticalAttribute()]
public virtual void GetObjectData(
   SerializationInfo info,
   StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: SerializationInfo;
    context: StreamingContext
); virtual;
JScript
SecurityCriticalAttribute()
public function GetObjectData(
   info : SerializationInfo,
   context : StreamingContext
);
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual void GetObjectData(
   SerializationInfo* info,
   StreamingContext context
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual void GetObjectData(
   SerializationInfo^ info,
   StreamingContext context
)

Parameters

info
context

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetType Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetType Method

Overload List

Overload | Description
GetType() | (Inherited from System.Exception)

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetType() Method
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : GetType() Method

Syntax

Visual Basic (Declaration)
Public Function GetType() As Type
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Type

value = instance.GetType()
C#
public Type GetType()
Delphi
public function GetType(): Type;
JScript
public function GetType() : Type;
Managed Extensions for C++
public: Type* GetType();
C++/CLI
public:
Type^ GetType();

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
HelpLink Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HelpLink Property

Syntax

Visual Basic (Declaration)
Public Overridable Property HelpLink As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.HelpLink = value

value = instance.HelpLink
C#
public virtual string HelpLink {get; set;}
Delphi
public read-write property HelpLink: String; virtual;
JScript
public function get,set HelpLink : String
Managed Extensions for C++
public: __property virtual string* get_HelpLink();
public: __property virtual void set_HelpLink(
   string* value
);
C++/CLI
public:
virtual property String^ HelpLink {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
HResult Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : HResult Property

Syntax

Visual Basic (Declaration)
Protected Property HResult As Integer
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Integer

instance.HResult = value

value = instance.HResult
C#
protected int HResult {get; set;}
Delphi
protected read-write property HResult: Integer;
JScript
protected function get,set HResult : int
Managed Extensions for C++
protected: __property int get_HResult();
protected: __property void set_HResult(
   int value
);
C++/CLI
protected:
property int HResult {
   int get();
   void set (    int value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InnerException Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : InnerException Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property InnerException As Exception
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As Exception

value = instance.InnerException
C#
public Exception InnerException {get;}
Delphi
public read-only property InnerException: Exception;
JScript
public function get InnerException : Exception
Managed Extensions for C++
public: __property Exception* get_InnerException();
C++/CLI
public:
property Exception^ InnerException {
   Exception^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Message Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Message Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property Message As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.Message
C#
public virtual string Message {get;}
Delphi
public read-only property Message: String; virtual;
JScript
public function get Message : String
Managed Extensions for C++
public: __property virtual string* get_Message();
C++/CLI
public:
virtual property String^ Message {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
SerializeObjectState Event
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : SerializeObjectState Event

Syntax

Visual Basic (Declaration)
Protected Event SerializeObjectState As EventHandler(Of SafeSerializationEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim handler As EventHandler(Of SafeSerializationEventArgs)

AddHandler instance.SerializeObjectState, handler
C#
protected event EventHandler<SafeSerializationEventArgs> SerializeObjectState
Delphi
protected event SerializeObjectState: EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
protected: __event EventHandler<SafeSerializationEventArgs*>* SerializeObjectState
C++/CLI
protected:
event EventHandler<SafeSerializationEventArgs^>^ SerializeObjectState

Event Data

The event handler receives an argument of type SafeSerializationEventArgs containing data related to this event. The following SafeSerializationEventArgs properties provide information specific to this event.

Property | Description
StreamingContext |

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Source Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : Source Property

Syntax

Visual Basic (Declaration)
Public Overridable Property Source As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

instance.Source = value

value = instance.Source
C#
public virtual string Source {get; set;}
Delphi
public read-write property Source: String; virtual;
JScript
public function get,set Source : String
Managed Extensions for C++
public: __property virtual string* get_Source();
public: __property virtual void set_Source(
   string* value
);
C++/CLI
public:
virtual property String^ Source {
   String^ get();
   void set (    String^ value);
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
StackTrace Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : StackTrace Property

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property StackTrace As String
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As String

value = instance.StackTrace
C#
public virtual string StackTrace {get;}
Delphi
public read-only property StackTrace: String; virtual;
JScript
public function get StackTrace : String
Managed Extensions for C++
public: __property virtual string* get_StackTrace();
C++/CLI
public:
virtual property String^ StackTrace {
   String^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
TargetSite Property
See Also Send Feedback
Noemax.GZip Namespace > InvalidInputException Class : TargetSite Property

Syntax

Visual Basic (Declaration)
Public ReadOnly Property TargetSite As MethodBase
Visual Basic (Usage) Copy Code
Dim instance As InvalidInputException
Dim value As MethodBase

value = instance.TargetSite
C#
public MethodBase TargetSite {get;}
Delphi
public read-only property TargetSite: MethodBase;
JScript
public function get TargetSite : MethodBase
Managed Extensions for C++
public: __property MethodBase* get_TargetSite();
C++/CLI
public:
property MethodBase^ TargetSite {
   MethodBase^ get();
}

See Also

Reference

InvalidInputException Class
InvalidInputException Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.GZip Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
Noemax.GZip.ExtraFieldCollection
Noemax.GZip.GZipHeaderField
System.IO.IOException
System.SystemException
System.Exception
Noemax.GZip.InvalidInputException
System.IO.Stream
System.MarshalByRefObject
Noemax.GZip.DeflateInputStream
Noemax.GZip.DeflateOutputStream
Noemax.GZip.DeflateStream
Noemax.GZip.GZipInputStream
Noemax.GZip.GZipOutputStream
Noemax.GZip.GZipStream

See Also

Reference

Noemax.GZip Assembly


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3InputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3InputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3InputStream Class
Lzf3InputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CanTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CanTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public ReadOnly Property CanTimeout As Boolean
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Boolean

value = instance.CanTimeout
C#
[ComVisibleAttribute(false)]
public bool CanTimeout {get;}
Delphi
public read-only property CanTimeout: Boolean;
JScript
ComVisibleAttribute()
public function get CanTimeout : boolean
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property bool get_CanTimeout();
C++/CLI
[ComVisibleAttribute(false)]
public:
property bool CanTimeout {
   bool get();
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
WaitHandle^ CreateWaitHandle();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
);
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: void Dispose(
   bool disposing
)
C++/CLI
protected:
void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
);
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ InitializeLifetimeService();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream

instance.ObjectInvariant()
C#
protected void ObjectInvariant()
Delphi
protected procedure ObjectInvariant();
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: void ObjectInvariant();
C++/CLI
protected:
void ObjectInvariant();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public int ReadByte()
Delphi
public function ReadByte(): Integer;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
int ReadByte();

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : ReadTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property ReadTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.ReadTimeout = value

value = instance.ReadTimeout
C#
[ComVisibleAttribute(false)]
public int ReadTimeout {get; set;}
Delphi
public read-write property ReadTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set ReadTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_ReadTimeout();
public: __property void set_ReadTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int ReadTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
);
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: void WriteByte(
   byte value
)
C++/CLI
public:
void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteTimeout Property
See Also Send Feedback
Noemax.Lzf Namespace > Lzf3OutputStream Class : WriteTimeout Property

Syntax

Visual Basic (Declaration)
<ComVisibleAttribute(False)>
Public Property WriteTimeout As Integer
Visual Basic (Usage) Copy Code
Dim instance As Lzf3OutputStream
Dim value As Integer

instance.WriteTimeout = value

value = instance.WriteTimeout
C#
[ComVisibleAttribute(false)]
public int WriteTimeout {get; set;}
Delphi
public read-write property WriteTimeout: Integer;
JScript
ComVisibleAttribute()
public function get,set WriteTimeout : int
Managed Extensions for C++
[ComVisibleAttribute(false)]
public: __property int get_WriteTimeout();
public: __property void set_WriteTimeout(
   int value
);
C++/CLI
[ComVisibleAttribute(false)]
public:
property int WriteTimeout {
   int get();
   void set (    int value);
}

See Also

Reference

Lzf3OutputStream Class
Lzf3OutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfInputStream Class
LzfInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfInputStream Class
LzfInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzf Namespace > LzfOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzfOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzfOutputStream Class
LzfOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzf Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzf.Lzf3InputStream
Noemax.Lzf.Lzf3OutputStream
Noemax.Lzf.LzfInputStream
Noemax.Lzf.LzfOutputStream

See Also

Reference

Noemax.Lzf Assembly


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaInputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaInputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaInputStream Class
LzmaInputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginRead Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginRead( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginRead(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginRead(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginRead(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginRead(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginRead(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginRead(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
BeginWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : BeginWrite Method

buffer
offset
count
callback
state

Syntax

Visual Basic (Declaration)
<HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=True)>
Public Overridable Function BeginWrite( _
   ByVal buffer() As Byte, _
   ByVal offset As Integer, _
   ByVal count As Integer, _
   ByVal callback As AsyncCallback, _
   ByVal state As Object _
) As IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim buffer() As Byte
Dim offset As Integer
Dim count As Integer
Dim callback As AsyncCallback
Dim state As Object
Dim value As IAsyncResult

value = instance.BeginWrite(buffer, offset, count, callback, state)
C#
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public virtual IAsyncResult BeginWrite(
   byte[] buffer,
   int offset,
   int count,
   AsyncCallback callback,
   object state
)
Delphi
public function BeginWrite(
    buffer: Bytearray of;
    offset: Integer;
    count: Integer;
    callback: AsyncCallback;
    state: TObject
): IAsyncResult; virtual;
JScript
HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=)
public function BeginWrite(
   buffer : byte[],
   offset : int,
   count : int,
   callback : AsyncCallback,
   state : Object
) : IAsyncResult;
Managed Extensions for C++
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public: virtual IAsyncResult* BeginWrite(
   byte[]* buffer,
   int offset,
   int count,
   AsyncCallback* callback,
   Object* state
)
C++/CLI
[HostProtectionAttribute(Resources=HostProtectionResource.ExternalThreading, ExternalThreading=true)]
public:
virtual IAsyncResult^ BeginWrite(
   array<byte>^ buffer,
   int offset,
   int count,
   AsyncCallback^ callback,
   Object^ state
)

Parameters

buffer
offset
count
callback
state

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CopyTo Method

Overload List

Overload | Description
CopyTo(Stream) | (Inherited from System.IO.Stream)
CopyTo(Stream,Int32) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream) Method

destination

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream

instance.CopyTo(destination)
C#
public void CopyTo(
   Stream destination
)
Delphi
public procedure CopyTo(
    destination: Stream
);
JScript
public function CopyTo(
   destination : Stream
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination
)
C++/CLI
public:
void CopyTo(
   Stream^ destination
)

Parameters

destination

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CopyTo(Stream,Int32) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > CopyTo Method : CopyTo(Stream,Int32) Method

destination
bufferSize

Syntax

Visual Basic (Declaration)
Public Overloads Sub CopyTo( _
   ByVal destination As Stream, _
   ByVal bufferSize As Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim destination As Stream
Dim bufferSize As Integer

instance.CopyTo(destination, bufferSize)
C#
public void CopyTo(
   Stream destination,
   int bufferSize
)
Delphi
public procedure CopyTo(
    destination: Stream;
    bufferSize: Integer
);
JScript
public function CopyTo(
   destination : Stream,
   bufferSize : int
);
Managed Extensions for C++
public: void CopyTo(
   Stream* destination,
   int bufferSize
)
C++/CLI
public:
void CopyTo(
   Stream^ destination,
   int bufferSize
)

Parameters

destination
bufferSize

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateObjRef Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateObjRef Method

requestedType

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As Type _
) As ObjRef
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim requestedType As Type
Dim value As ObjRef

value = instance.CreateObjRef(requestedType)
C#
[SecurityCriticalAttribute()]
public virtual ObjRef CreateObjRef(
   Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: Type
): ObjRef; virtual;
JScript
SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : Type
) : ObjRef;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual ObjRef* CreateObjRef(
   Type* requestedType
)
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual ObjRef^ CreateObjRef(
   Type^ requestedType
)

Parameters

requestedType

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
CreateWaitHandle Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : CreateWaitHandle Method

Syntax

Visual Basic (Declaration)
<ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")>
Protected Overridable Function CreateWaitHandle() As WaitHandle
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As WaitHandle

value = instance.CreateWaitHandle()
C#
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected virtual WaitHandle CreateWaitHandle()
Delphi
protected function CreateWaitHandle(): WaitHandle; virtual;
JScript
ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")
protected function CreateWaitHandle() : WaitHandle;
Managed Extensions for C++
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected: virtual WaitHandle* CreateWaitHandle();
C++/CLI
[ObsoleteAttribute("CreateWaitHandle will be removed eventually.  Please use "new ManualResetEvent(false)" instead.")]
protected:
virtual WaitHandle^ CreateWaitHandle();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : Dispose Method

Overload List

Overload | Description
Dispose() | (Inherited from System.IO.Stream)
Dispose(Boolean) | (Inherited from System.IO.Stream)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose() Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose() Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.Dispose()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Dispose()
Delphi
public procedure Dispose();
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Dispose();
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Dispose();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Dispose();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
Dispose(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > Dispose Method : Dispose(Boolean) Method

disposing

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Dispose( _
   ByVal disposing As Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim disposing As Boolean

instance.Dispose(disposing)
C#
protected virtual void Dispose(
   bool disposing
)
Delphi
protected procedure Dispose(
    disposing: Boolean
); virtual;
JScript
protected function Dispose(
   disposing : boolean
);
Managed Extensions for C++
protected: virtual void Dispose(
   bool disposing
)
C++/CLI
protected:
virtual void Dispose(
   bool disposing
)

Parameters

disposing

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndRead Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndRead Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Function EndRead( _
   ByVal asyncResult As IAsyncResult _
) As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult
Dim value As Integer

value = instance.EndRead(asyncResult)
C#
public virtual int EndRead(
   IAsyncResult asyncResult
)
Delphi
public function EndRead(
    asyncResult: IAsyncResult
): Integer; virtual;
JScript
public function EndRead(
   asyncResult : IAsyncResult
) : int;
Managed Extensions for C++
public: virtual int EndRead(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual int EndRead(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
EndWrite Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : EndWrite Method

asyncResult

Syntax

Visual Basic (Declaration)
Public Overridable Sub EndWrite( _
   ByVal asyncResult As IAsyncResult _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim asyncResult As IAsyncResult

instance.EndWrite(asyncResult)
C#
public virtual void EndWrite(
   IAsyncResult asyncResult
)
Delphi
public procedure EndWrite(
    asyncResult: IAsyncResult
); virtual;
JScript
public function EndWrite(
   asyncResult : IAsyncResult
);
Managed Extensions for C++
public: virtual void EndWrite(
   IAsyncResult* asyncResult
)
C++/CLI
public:
virtual void EndWrite(
   IAsyncResult^ asyncResult
)

Parameters

asyncResult

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
GetLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : GetLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Function GetLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.GetLifetimeService()
C#
[SecurityCriticalAttribute()]
public object GetLifetimeService()
Delphi
public function GetLifetimeService(): TObject;
JScript
SecurityCriticalAttribute()
public function GetLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: Object* GetLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
Object^ GetLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
InitializeLifetimeService Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : InitializeLifetimeService Method

Syntax

Visual Basic (Declaration)
<SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As Object
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Object

value = instance.InitializeLifetimeService()
C#
[SecurityCriticalAttribute()]
public virtual object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): TObject; virtual;
JScript
SecurityCriticalAttribute()
public function InitializeLifetimeService() : Object;
Managed Extensions for C++
[SecurityCriticalAttribute()]
public: virtual Object* InitializeLifetimeService();
C++/CLI
[SecurityCriticalAttribute()]
public:
virtual Object^ InitializeLifetimeService();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : MemberwiseClone Method

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
MemberwiseClone(Boolean) Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As Boolean _
) As MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim cloneIdentity As Boolean
Dim value As MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected MarshalByRefObject MemberwiseClone(
   bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: Boolean
): MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : boolean
) : MarshalByRefObject;
Managed Extensions for C++
protected: MarshalByRefObject* MemberwiseClone(
   bool cloneIdentity
)
C++/CLI
protected:
MarshalByRefObject^ MemberwiseClone(
   bool cloneIdentity
)

Parameters

cloneIdentity

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members
Overload List


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ObjectInvariant Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ObjectInvariant Method

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ObjectInvariant()
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream

instance.ObjectInvariant()
C#
protected virtual void ObjectInvariant()
Delphi
protected procedure ObjectInvariant(); virtual;
JScript
protected function ObjectInvariant();
Managed Extensions for C++
protected: virtual void ObjectInvariant();
C++/CLI
protected:
virtual void ObjectInvariant();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
ReadByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : ReadByte Method

Syntax

Visual Basic (Declaration)
<TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overridable Function ReadByte() As Integer
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Integer

value = instance.ReadByte()
C#
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual int ReadByte()
Delphi
public function ReadByte(): Integer; virtual;
JScript
TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function ReadByte() : int;
Managed Extensions for C++
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual int ReadByte();
C++/CLI
[TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual int ReadByte();

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%PageItemTitle%%

[image]
Noemax DotNetCompression
WriteByte Method
See Also Send Feedback
Noemax.Lzma Namespace > LzmaOutputStream Class : WriteByte Method

value

Syntax

Visual Basic (Declaration)
Public Overridable Sub WriteByte( _
   ByVal value As Byte _
)
Visual Basic (Usage) Copy Code
Dim instance As LzmaOutputStream
Dim value As Byte

instance.WriteByte(value)
C#
public virtual void WriteByte(
   byte value
)
Delphi
public procedure WriteByte(
    value: Byte
); virtual;
JScript
public function WriteByte(
   value : byte
);
Managed Extensions for C++
public: virtual void WriteByte(
   byte value
)
C++/CLI
public:
virtual void WriteByte(
   byte value
)

Parameters

value

See Also

Reference

LzmaOutputStream Class
LzmaOutputStream Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

Noemax.Lzma Namespace Inheritance Hierarchy
See Also Send Feedback

Inheritance Hierarchy

System.Object
System.IO.Stream
System.MarshalByRefObject
Noemax.Lzma.LzmaInputStream
Noemax.Lzma.LzmaOutputStream

See Also

Reference

Noemax.Lzma Assembly